File > Import


Loads data from a scene file into the existing scene.

To import a file that was created in a earlier version of Maya, ensure the Ignore Version preference is turned on in the Files/Projects preferences.

Related topics

File > Import >

General options


Specifies whether the imported objects are grouped under a single transform when you import the file. Grouping makes it easier to work on the nodes of imported objects. The default is off.

Remove duplicate shading networks

This setting prevents the duplication of geometry and shading networks if you import a file more than once into Maya.

File type

Select from the drop-down list the file type you are importing. If you aren’t sure what type of file you are importing, you can select Best Guess.

Depending on the file type you select, various file type specific options may be displayed.

Referencing options

Preserve references

If Preserve References is turned on, the references within the imported file are preserved. If it is turned off, all references are imported into or exported within the file; that is, they are no longer references, but are now objects in the scene. The default is off.

Load saved reference load state

(Default setting) Respects the referenced file’s state in the referencing file when the referencing file was last saved. Whatever references were loaded or unloaded the last time you worked on the file are properly loaded or unloaded when you re-open it.

Load all references

Opens the file with all references loaded. You can change the state of reference loading after the file is open in Maya by opening the Reference Editor (Reference Editor overview) and selecting the references you want to unload.

Load no references

This opens the file without loading any references. You can load references after the file is open in Maya by opening the Reference Editor (Reference Editor overview) and selecting the references you want to load.

Load top-level references only

Loads only the top-most referenced files (which may themselves contain many nested referenced files). This is useful in cases where you may be opening a complex nested scene reference hierarchy with many nested references and you want to easily work at the top level of the hierarchy.

Namespace Options

Use namespaces

When you reference or import a scene with Use namespaces on, Maya creates a new namespace that contains the referenced data. Turning on Use namespaces ensures that all nodes are uniquely named. See What are namespaces? and Create namespaces when referencing or importing.


Before referencing a file, make sure that the renaming prefix contains no invalid characters.

The currently set namespace is indicated in the Namespace Options section by the icon. Namespaces that are parents of the currently set namespace are indicated by an icon. You can set the current namespace in the Namespace Editor by clicking Set Current. See Namespace Editor Overview and Edit namespaces.

Namespaces do not effect selection, the DAG, the Dependency Graph, or any other aspect of Maya.

Use selected namespace as parent and add new namespace (file name)

Specifies that the referenced file name is added to the beginning of object namespace.

For example, if you are referencing or importing a scene named that contains an object named ball, its namespace is foo:ball.

Use selected namespace as parent and add new namespace string:

Specifies that a text string is added to the beginning of the object namespace. Type the string in the field that appears.

Merge into selected namespace and rename incoming objects that match

Merges the object's namespace wih an existing, selected namespace.

If duplicate namespaces occur, the namespaces are merged and duplicate object names are incrementally suffixed with a number. Use this option to avoid an accumulation of new namespaces each time your referenced or imported objects have the same namespace.

Move file options

The following file type-specific options apply to importing move files:


Type the name of an attribute in the Attributes box and click Add to add the attribute to the list of attributes to use when importing or exporting. If the attribute is already included in the list, a duplicate is not made. You can add several attributes at one time by separating them with a space. To remove an attribute, type the name of the attribute and click Remove.

From Channel Box

Click From Channel Box to combine all of the selected objects in Maya, in the order of their selection, with the channels selected in the Channel Box and place them in the list. For example, if sphere and cone are selected, and tx, sx are selected in the Channel Box, sphere.tx cone.tx and are added to the list of attribute to import and export.

Remove Selected

Click Remove Selected to remove all of the attributes selected in the list.

Remove All

Click Remove All to remove all of the attributes from the list.


This is ignored in file export. For file import, this sets the precision of the file.

When you click import or export, the move file is written or read and only the attributes in the list are affected.

Adobe Illustrator and EPS options

The Illustrator importer cannot import Illustrator text objects. Convert any text objects in your file to paths before you import the file into Maya.

Scale factor

Allows you to control the scale of the curves produced from the import. It is the same operation as using the Scale Tool.


Turn on this option to group the imported curves. It is the same operation as using the Edit > Group option.

Animation curve options (animImport)

You must have the animImportExport plug-in loaded to see these options.

Time Range

Select a time range option and specify the appropriate settings.


Imports the animation information to the selected objects so that the animation starts at the time specified in the Start Time field.


Imports the animation information to the selected object or objects, scaling the animation to fit into the time range as specified in the Start Time and End Time fields. Animation information from the keys clipboard is either scaled or clipped depending on the setting of the Clipboard Adjustment option.


Imports the animation information to the selected objects so that the animation starts at the current time as displayed in the Animation Controls.


Transfers the animation information to the selected object(s), preserving the duration and timing of the animation information on the keys clipboard.


The value specifies the number of copies of the anim curves that are imported. Multiple copies are appended sequentially.

Help Images

Turn on Help Images to display illustrations of the effects of the various anim import options.

Clipboard Adjustment

Specify an option for how to handle the Clipboard contents.


Pastes the contents of the clipboard into their new positions on the curve without any changes.


Becomes enabled when Start/End is selected. The complete contents of the clipboard curves are stretched or compressed to fit into the specified import Time Range.


Becomes enabled when Start/End is selected. The contents of the clipboard are preserved (that is, not stretched or compressed) and as much as will fit into the specified time range is pasted into the new area.

Paste Method

Specify a paste method.


Places the clipboard contents before any existing keys in the specified time range. The keys from the original curve that were after the specified time range are shifted in time by the pasted range times.


Becomes enabled when Start/End or Clipboard is selected. The clipboard contents overwrite any existing keys in the specified time range.


The clipboard contents are added to any existing keys on the curve. In the case where a clipboard key is at the same time as an existing key, the clipboard’s key replaces the existing key.

Replace Region

These buttons are enabled when Paste Method is set to Replace.

Time Range

Replace keys and curve segment information in the specified time range with the contents of the keys clipboard.

Entire Curve

Is available only when the Time Range setting is Clipboard. The Entire Curve setting replaces the animation curve(s) on the imported attributes with the contents of the keys clipboard, in effect deleting any existing animation curves on these attributes and applying the new curves from the keys clipboard.


When turned on, adjusts the keys clipboard curves in value, so there’s no discontinuity in the animation at the start of the pasted segment.

Creative Commons License Except where otherwise noted, this work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License