“文件/项目”(Files/Projects)首选项

 
 
 

可以在“首选项”(Preferences)窗口的“文件/项目”(Files/Projects)类别中设置以下首选项。

项目设置(Projects Settings)

默认项目目录(Default projects directory)、始终使用此项目启动(Always start in this project)

创建新项目或启动项目时,可以使用这些设置来设置默认项目目录。

最近的历史大小(Recent History Size)

文件(Files)、递增文件(Increments)、项目(Projects)

指定要在每个“文件 > 最近”(File > Recent)子菜单中列出多少个文件,递增文件和项目。

自动保存

启用(Enable)

启用时,“自动保存”(Autosave)会按确定的间隔自动保存您的场景。文件按照“自动保存”(Autosave)选项,以名称 AUTO-SAVE 后跟递增数字进行保存。

保存之前提示(Prompt before save)

在自动保存之前以对话框形式提示用户。

限制自动保存(Limit autosaves)

限制可自动保存文件的次数。

自动保存数(Number of autosaves)

确定在“限制自动保存”(Limit autosaves)限处于启用状态时可以自动保存文件的次数。

间隔(分钟) (Interval (minutes))

确定每次自动保存之间的时间量(默认值为 10 分钟)。

自动保存目标(Autosave destination)

确定自动保存文件存储的位置。“项目”(Project)将其存储在当前项目的“自动保存”(autosave)文件夹下,而“命名的文件夹”(Named folder)将其存储在指定的文件夹中。环境变量根据环境变量 MAYA_AUTOSAVE_FOLDER 的值存储自动保存文件。

Ascii 文件压缩模式(Ascii File Compression Mode)

保存文件时(On file save)

指定保存 ASCII 文件时要使用的压缩模式:

压缩(Compressed)

采用压缩模式保存文件。文件压缩可缩小大文件的大小,使它们不会占用硬盘驱动器上的大量空间。

不压缩(Uncompressed)

采用不压缩模式保存文件。

按现状(As Is)

采用原始压缩模式保存文件,而不要压缩或解除压缩文件。“按现状”(As Is)是默认设置。

注意

要使用压缩模式,请确保在计算机上的相应路径中安装了 zip 实用程序。

显示层(Display Layer)

文件导入合并(File import merge)

指定在导入文件时希望“显示层”(Display Layer)合并的方式。

无(None)

读入的所有层都被放置在新层中、重新编号并重命名(如有必要)以保留唯一性。

按编号(By Number)

读入的与现有层具有相同索引编号的所有层都与该层合并,而不是创建新的层。

按名称(By Name)

读入的与现有层具有相同名称的所有层都与该层合并,而不是创建新的层。

渲染层(Render Layer)

文件导入合并(File import merge)

指定在导入文件时希望“渲染层”合并的方式。

无

读入的所有层都被放置在新层中、重新编号并重命名(如有必要)以保留唯一性。

按编号(By Number)

读入的与现有层具有相同索引编号的所有层都与该层合并,而不是创建新的层。

按名称(By Name)

读入的与现有层具有相同名称的所有层都与该层合并,而不是创建新的层。

文件对话框(File Dialog)

对话框样式(Dialog style)

本地操作系统(OS native)

在执行保存、打开、导入和导出操作时使用当前操作系统的本地文件浏览器。

Maya 默认(Maya default)

在执行保存、打开、导入和导出操作时使用 Maya 的内置文件浏览器。

版本(Version)

忽略版本(Ignore Version)

打开、导入或引用 Maya 文件时忽略文件版本。通过“忽略版本”(Ignore Version)首选项,可以打开由任意版本的 Maya 创建的文件,不管文件保存格式是 ASCII 还是二进制。如果需要在早期版本中打开文件,使用该功能就无需保存,也无需手动编辑 ASCII 版本的 Maya 文件来移除所需的版本行。

“忽略版本”(Ignore Version)首选项适用于“文件 > 打开场景”(File > Open Scene)、“文件 > 导入”(File > Import)和“文件创建引用命令”(File Create Reference commands)。

注意

在早期版本 Maya 中打开的 Maya 文件不受支持,因为无法确保功能是否与早期软件版本兼容。例如,在 Maya 2014 中保存为 Maya 二进制文件的场景与 Maya 的早期版本不兼容。“忽略版本”(Ignore Version)功能主要供同时在 Maya 多个版本的生产环境中工作的用户使用。

注意

从 Maya 2012 开始,对于 Linux 和 Mac 平台,在 Maya 尝试使用由 lastLocalWS 指向的目录之前,需要通过检查来确保该目录可访问。该目录必须具有 555 (r-xr-xr-x) 权限。否则,如果该目录仅具有 444 (r--r--r--) 权限,则 Maya 不能使用它;即使 cd or ls 不起作用也是如此。

除了 lastLocalWS 以外,还有其他 Maya 在启动时尝试使用的工作区,相同的检查也被应用于这些工作区。Maya 尝试使用这些工作区的顺序如下:

  • 从 -proj 命令行参数获取的值
  • 从 MAYA_PROJECT 环境变量获取的值
  • InitialProject optionVar(即标记为“始终使用此项目启动”(Always start in this project)的首选项)
  • lastLocalWS optionVar(在退出时由 Maya 自动存储,以记住上一活动工作区)
  • 默认项目