シェルフ項目のポップアップ メニューを作成/編集する

 
 
 

シェルフ項目に、カスタム タスクを実行するためのポップアップ メニューを追加することができます。ポップアップ メニューは、個々のシェルフ項目を右クリックしたときに表示されるメニューです。

新規ポップアップ メニューを作成するには

  1. シェルフ エディタ(Shelf Editor) (ウィンドウ > 設定/プリファレンス > シェルフ エディタ(Window > Settings/Preferences > Shelf Editor))を開きます。
  2. シェルフ(Shelves)タブで、ポップアップ メニューを追加するシェルフを選択します。
  3. ポップアップ メニュー項目(Popup Menu Items)タブを選択します。
  4. 新規メニュー項目(New Menu Item)ボタン をクリックします。

    User menuItem というエントリが、メニュー項目(Menu Items)リストに表示されます。

  5. 名前の変更(Rename)フィールドに、メニューの名前を入力します。
  6. メニュー項目コマンド(Menu Item Command)の MEL または Python を選択し、新規メニューの機能を定義するスクリプトを入力します。

    これで、対応するシェルフ項目をクリックすると、この新規メニュー項目がポップアップ メニューに表示されるようになりました。新規メニュー項目を選択すると、スクリプトで定義した動作が実行されます。

スクリプトを編集して、いつでもメニュー項目の機能を調整できます。上へ移動(Move Up)()と下へ移動(Move Down)()ボタンを使って、メニュー項目の表示順序を調整することもできます。メニュー項目を削除するには、対象となる項目をハイライトし、メニュー項目の削除(Delete Menu Item)()ボタンをクリックします。