ダイナミック リレーションシップ エディタ(Dynamic Relationships Editor)の例

 
 
 

次のセクションでは、Maya におけるダイナミック リレーションシップ エディタを使用したオブジェクトとフィールド、衝突ジオメトリ、エミッタ間の接続または接続解除の方法を例を挙げて説明します。

フィールドを接続または接続解除する

この例では、ダイナミック リレーションシップ エディタ(Dynamic Relationships Editor)を使用して、すでに Maya のクラシック パーティクル オブジェクトに接続されている渦(Vortex)フィールドをソフト ボディと nParticle オブジェクトに接続する方法について説明します。これにより、渦(Vortex)フィールドはクラシック パーティクル オブジェクトから接続解除されます。

フィールドを接続または接続解除するには

  1. ウィンドウ > リレーションシップ エディタ > ダイナミック リレーションシップ(Window > Relationship Editors > Dynamic Relationships)を選択してダイナミック リレーションシップ エディタ(Dynamic Relationships Editor)を開きます。
  2. ダイナミック リレーションシップ エディタの左側のパネルで、接続を変更するオブジェクトを選択します。

    この例では、左側のパネルでパーティクル、ソフト ボディ、nParticle オブジェクトを選択します。 キーを押しながらクリックすると複数のオブジェクトを選択できます。

  3. セレクション モード(Selection Mode)をフィールド(Fields)に設定します。

    右側のパネルの particle1 の下に、現在パーティクル オブジェクトに接続されているフィールドがハイライト表示されます。また、pPlane1Particle と nParticle1 の下にはソフト ボディと nParticle オブジェクトに接続可能なフィールドが表示されます。既定では、左側のパネルでソフト ボディ オブジェクトを選択すると、名前に関連パーティクル オブジェクトをアペンドしたオブジェクトが右側に表示されます。

  4. 渦(Vortex)フィールドをソフト ボディと nParticle オブジェクトに接続するには、pPlane1Particle の下にある vortexField1 と nParticle1 をクリックします。

    これで、渦(Vortex)フィールドがソフト ボディと nParticle オブジェクトに接続されます。

  5. 渦フィールドとパーティクル オブジェクトの接続を解除するには、Particle1 の下にある vortexField1 をクリックします。

    渦フィールドとパーティクルの接続が解除されます。

衝突ジオメトリを接続または接続解除する

この例では、ダイナミック リレーションシップ エディタ(Dynamic Relationships Editor)を使用して衝突オブジェクト(pCubeShape1)をパーティクル オブジェクトに接続して衝突させる方法を説明しています。このオブジェクトは接続されていて 2 番目のパーティクル オブジェクトに衝突するようになっています。

注:

nCloth、nParticle またはパッシブ衝突オブジェクト間の衝突などの nucleus ベースの衝突は、ダイナミック リレーションシップ エディタで編集することはできません。

衝突ジオメトリを接続または接続解除するには

  1. ウィンドウ > リレーションシップ エディタ > ダイナミック リレーションシップ(Window > Relationship Editors > Dynamic Relationships)を選択してダイナミック リレーションシップ エディタ(Dynamic Relationships Editor)を開きます。
  2. ダイナミック リレーションシップ エディタの左側のパネルで、衝突ジオメトリと接続または接続解除するオブジェクトを選択します。
  3. セレクション モード(Selection modes)を衝突(Collisions)に設定します。

    現在接続されて particle1 オブジェクトと衝突するようになっているジオメトリ(pCubeShape1)がエディタ右側のパネルの particle1 の下にハイライト表示され、接続して particle2 オブジェクトと衝突させることのできるジオメトリ(pCubeShape1)が particle2 の下に表示されます。

  4. particle2 の pCubeShape1 をクリックします。

    これで、衝突オブジェクトが接続され、particle1 オブジェクト、particle2 オブジェクトと衝突するようになります。

エミッタを接続または接続解除する

パーティクル オブジェクトを別のオブジェクトに接続されているエミッタに接続することはできません。

たとえば、ディレクショナル ポイントとして emitter1 と emitter2 を持つカーブを作成することができます。emitter1 は球パーティクルを右方向に、emitter2 はパーティクル ストリークを左方向に放出します。以下の図では、この球パーティクルを particle1、ストリークする方を particle2 とします。

particle1 を選択すると、それが emitter1 に接続されていることがダイナミック リレーションシップ エディタ(Dynamic Relationships Editor)に示されます。

右側のパネルでは、両方またはどちらか一方のエミッタを選択して particle1 に接続するか、またはどちらも接続しないようにすることもできます。particle1 を emitter2 と emitter1 の両方に接続すると、両方のエミッタから球が放出されます。

関連項目