Display ghosts for layered animation


Ghosts for layered animation let you preview the position of an object with each added layer of animation. The ghost options in the Animation Layer Editor let you show and hide ghosts for objects animated on multiple layers.

When a layer is ghosted, the ghost of the object is drawn such that the layer stack is evaluated up to and including the layer being ghosted. For example, if an object is added to AnimLayer1, AnimLayer2, and AnimLayer3, turning on the ghost for AnimLayer2 shows the result of the evaluation including the BaseAnimation, AnimLayer1, and AnimLayer2. The effect of AnimLayer3 is excluded.


Ghosting the top-most layer in the stack is unnecessary, as its ghost would display in the same position as the result animation.

Using the ghosting options, you can specify that you want objects to be auto-ghosted when you toggle the layer Ghost buttons on, or you can choose to turn ghosting on manually.

To display ghosts for selected objects automatically

  1. In the Animation Layer Editor, select Options > Auto Ghost Selected Objects from the menu bar, if it is not already selected.
  2. Select the objects in your scene you want to ghost.
  3. In the Animation Layer Editor, toggle the Ghost button on for any layer.

    Ghosts are turned on for the selected objects.

To display ghosts for all objects in a layer

  1. In the Animation Layer Editor, select Options > Auto Ghost Objects In Layer from the menu bar.
  2. Toggle the Ghost button on for any layer whose objects you want to ghost.

    Ghosts display in the scene for all the layer’s associated objects, letting you preview the animation from each layer.

To manually control ghosts

  1. In the Animation Layer Editor, select Options > Turn On Ghosts Manually from the menu bar.

    With this option on, you can use the main Animate > Ghost Selected option and the layer Ghost buttons to control what is ghosted in your scene. See also Ghost an object.

To set the ghost color

By default, animation layer ghosts are dark red. You can use the ghost buttons in the Animation Layer Editor to change the color of the ghosted objects for each layer.

  1. -click a Ghost button in the Animation Layer Editor. The Color Index Settings open.
  2. Drag the Select Color slider to choose a new color and click Ok.

    The layer’s ghost button and the ghosts of its animated objects change to the color you select.


    To change the 20 default colors available in the Color Index Settings, select Window > Settings/Preferences > Color Settings and change the colors in the Active Index Palette. See Change user interface colors.


Changing the ghost color also sets the color of the layer’s key ticks in the Time Slider.

To change how many animation layer ghosts display

Ghosts display the position of the animated object for a specified number of frames before and after the current frame. You can change how many ghosts display, for example if you want to view ghosts only for the current frame.

  1. Select Animate > Ghost Selected > from the main menu bar.
  2. In the Ghost Options, change the Type of Ghosting to Custom Frame Steps.
  3. Set the Steps Before Current Frame and Steps After Current Frame to 0.

    One ghost per object per layer now displays at the current frame.

Related topics

Creative Commons License Except where otherwise noted, this work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License