Overview
Overview

Overview

This reference describes the Civil .NET API for Civil 3D 2010, Service Pack 2.

  • Getting Started
  • Deprecated Items
  • Autodesk::Civil Namespace
Comments?


Getting Started

The AutoCAD Civil 3D .NET API enables you to reference AutoCAD Civil 3D components and functionality to extend and develop applications.

The AutoCAD Civil 3D Developer Help includes four components:

  • .NET API Reference (civil_api_net_reference.chm) - this document
  • ActiveX API Reference (civil_api_activex_reference.chm)
  • Civil 3D Developer's Guide (Civil3DDevelopersGuide.chm)
  • CustomDraw C++ API Reference (civil_api_draw_reference.chm)

This help file contains a comprehensive reference of .NET APIs. For "how to" information, including code samples, see the Developer's Guide.

Sources of Information

To develop applications using the AutoCAD Civil 3D API, you should be familiar with AutoCAD Civil 3D and AutoCAD applications.

  • AutoCAD ObjectARX documentation (arxdoc.chm), which is located in the docs folder of the ObjectARX installation. You can obtain ObjectARX through the AutoCAD Developer's Network (ADN).
  • AutoCAD Civil 3D Help, which is located in the Help folder of the AutoCAD Civil 3D installation.

Note: The AutoCAD Civil 3D Help is useful for understanding how AutoCAD Civil 3D models its domain, and for understanding Civil 3D objects and settings. Since detailed explanations are available in AutoCAD Civil 3D Help, the Civil 3D Developer Help explains them only briefly or not at all. Before you automate or extend an AutoCAD Civil 3D feature, review the subject in AutoCAD Civil 3D Help.

Languages

The .NET interface can be programmed in any .NET language, including VB.NET, C#, and managed C++. It requires Visual Studio 2008 SP1 or later.

Please send us your comment about this page.


Deprecated Items
Deprecated Items
Collapse All

Deprecated Items

These items are deprecated and will be removed in a future release.

Deprecated
Topic | Notes
AxisTickStyle::TickAndLabelStartElevation Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.AxisStyle.ShowTickAndLabel instead.
FeatureLineStyle::FeatureLineDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.FeatureLineStyle.GetFeatureLineDisplayStyleModel instead.
FeatureLineStyle::FeatureLineDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.FeatureLineStyle.GetFeatureLineDisplayStylePlan instead.
FeatureLineStyle::SectionMarkerDisplayStyleSection Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.FeatureLineStyle.GetSectionMarkerDisplayStyleSection instead.
LabelStyleBlockComponent::StyleGeneral::AnchorPoint Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleBlockComponent.StyleGeneral.AnchorLocation instead.
LabelStyleDirectionArrowComponent::StyleGeneral::AnchorPoint Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleDirectionArrowComponent.StyleGeneral.AnchorLocation instead.
LabelStyleLineComponent::StyleGeneral::EndPointAnchorPoint Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleLineComponent.StyleGeneral.EndAnchorPoint instead.
LabelStyleLineComponent::StyleGeneral::StartPointAnchorPoint Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleLineComponent.StyleGeneral.StartAnchorPoint instead.
LabelStyleTextComponent::StyleGeneral::AnchorPoint Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleTextComponent.StyleGeneral.AnchorLocation instead.
MarkerStyle::MarkerDisplayStyleProfile Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.MarkerStyle.GetMarkerDisplayStyleProfile instead.
MarkerStyle::MarkerDisplayStyleSection Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.MarkerStyle.GetMarkerDisplayStyleSection instead.
MarkerStyleBase::MarkerDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.MarkerStyleBase.GetMarkerDisplayStyleModel instead.
MarkerStyleBase::MarkerDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.MarkerStyleBase.GetMarkerDisplayStylePlan instead.
StyleCollectionBase::Remove Method (StyleBase^) | Deprecated: Use the override methods with an index or name instead.
TableStyle::BorderDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetBorderDisplayStyleModel instead.
TableStyle::BorderDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetBorderDisplayStylePlan instead.
TableStyle::DataAreaFillDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataAreaFillDisplayStyleModel instead.
TableStyle::DataAreaFillDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataAreaFillDisplayStylePlan instead.
TableStyle::DataDividerDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataDividerDisplayStyleModel instead.
TableStyle::DataDividerDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataDividerDisplayStylePlan instead.
TableStyle::DataSeparatorDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataSeparatorDisplayStyleModel instead.
TableStyle::DataSeparatorDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataSeparatorDisplayStylePlan instead.
TableStyle::DataTextDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataTextDisplayStyleModel instead.
TableStyle::DataTextDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataTextDisplayStylePlan instead.
TableStyle::HeaderAreaFillDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderAreaFillDisplayStyleModel instead.
TableStyle::HeaderAreaFillDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderAreaFillDisplayStylePlan instead.
TableStyle::HeaderSeparatorDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderSeparatorDisplayStyleModel instead.
TableStyle::HeaderSeparatorDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderSeparatorDisplayStylePlan instead.
TableStyle::HeaderTextDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderTextDisplayStyleModel instead.
TableStyle::HeaderTextDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderTextDisplayStylePlan instead.
TableStyle::TitleAreaFillDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleAreaFillDisplayStyleModel instead.
TableStyle::TitleAreaFillDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleAreaFillDisplayStylePlan instead.
TableStyle::TitleSeparatorDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleSeparatorDisplayStyleModel instead.
TableStyle::TitleSeparatorDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleSeparatorDisplayStylePlan instead.
TableStyle::TitleTextDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleTextDisplayStyleModel instead.
TableStyle::TitleTextDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleTextDisplayStylePlan instead.
AlignmentStyle::LineMarkerDisplayStyleSection Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.AlignmentStyle.GetLineMarkerDisplayStyleSection instead.
LabelStylesProfileRoot::GradeBreadLabelStyles Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.LabelStylesProfileRoot.GradeBreakLabelStyles instead.
MatchLineStyle::LinesDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.MatchLineStyle.GetLinesDisplayStylePlan instead.
MatchLineStyle::MatchLineMaskDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.MatchLineStyle.GetMatchLineMaskDisplayStylePlan instead.
MatchLineStyle::MatchLineMaskHatchDisplayStyle Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.MatchLineStyle.GetMatchLineMaskHatchDisplayStyle instead.
ParcelStyle::AreaFillHatchDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ParcelStyle.GetAreaFillHatchDisplayStyleModel instead.
ParcelStyle::AreaFillHatchDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ParcelStyle.GetAreaFillHatchDisplayStylePlan instead.
PointStyle::LabelDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.PointStyle.GetLabelDisplayStyleModel instead.
PointStyle::LabelDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.PointStyle.GetLabelDisplayStylePlan instead.
ProfileStyle::Chain3DDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ProfileStyle.GetChain3DDisplayStyleModel instead.
ProfileStyle::ProfileMarkerDisplayStyleSection Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ProfileStyle.GetProfileMarkerDisplayStyleSection instead.
ViewFrameStyle::ViewFrameBoundaryDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ViewFrameStyle.GetViewFrameBoundaryDisplayStylePlan instead.
SettingsAlignment::Data Property | Deprecated: Use the Autodesk.Civil.Land.Settings.SettingsAlignment.CriteriaBasedDesignOptions instead.
SettingsAlignment::SettingsData::CriteriaBasedDesignOption Property | Deprecated: Use the Autodesk.Civil.Land.Settings.SettingsAlignment.SettingsCriteriaBasedDesignOptions.UseDefaultDesignCheckSet instead.
SettingsProfileView::SettingsStyles::ProfileLabelStyle Property | Deprecated: Use Autodesk.Civil.Land.Settings.SettingsProfileView.SettingsStyles.ProfileLabelSet instead.
SettingsViewFrameGroup::Information Property | Deprecated: Property has been removed.
Part::SurfaceId Property | Deprecated: Use Autodesk.Civil.PipeNetwork.DatabaseServices.Part.RefSurfaceId instead.
Pipe::Length2D Property | Deprecated: Use Autodesk.Civil.PipeNetwork.Pipe.Length2DCenterToCenter instead.
Pipe::Length3D Property | Deprecated: Use Autodesk.Civil.PipeNetwork.Pipe.Length3DCenterToCenter instead.
LinkStyle::LinkDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.Roadway.DatabaseServices.Styles.LinkStyle.GetLinkDisplayStyleModel() instead.
LinkStyle::LinkDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.Roadway.DatabaseServices.Styles.LinkStyle.GetLinkDisplayStylePlan() instead.
ShapeStyle::AreaFillHatchDisplayStyleModel Property | Deprecated: Use Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle.GetAreaFillHatchDisplayStyleModel instead.
ShapeStyle::AreaFillHatchDisplayStylePlan Property | Deprecated: Use Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle.GetAreaFillHatchDisplayStylePlan instead.
SettingsIntersection::SettingsStyles::CurbReturnProfileLabelSet Property | Deprecated: Functionality has been removed
SettingsIntersection::SettingsStyles::OffsetProfileLabelSet Property | Deprecated: Functionality has been removed.
Param Class | Deprecated: Use Autodesk.Civil.Runtime.IParam instead.


Autodesk Namespace
Autodesk Namespace

The Autodesk namespace.

Namespaces
Namespace | Description
Civil | The Autodesk::Civil namespace.
Links
Namespaces


Autodesk::Civil Namespace

The Autodesk::Civil namespace.

Namespaces
Namespace | Description
ApplicationServices |
DatabaseServices | The Autodesk::Civil::DatabaseServices namespace.
Land | The Autodesk::Civil::Land namespace.
PipeNetwork | The Autodesk::Civil::PipeNetwork namespace.
QTO | The Autodesk::Civil::QTO namespace.
Roadway | The Autodesk::Civil::Roadway namespace.
Runtime | The Autodesk::Civil::Runtime namespace.
Settings | The Autodesk::Civil::Settings namespace.
Survey | The Autodesk::Civil::Survey namespace.
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
Constant | Constants used by the Civil API.
DesignCheck | The abstract design check class.
DesignCheckCollection | The DesignCheckCollection class.
PropertyAnchorPoint | Property template for label anchor location.
PropertyAngle | Angle property template.
PropertyBlock | Encapsulates a Block name.
PropertyBoolean | Encapsulates a boolean value.
PropertyEnum | Property template for enumerations.
PropertyObjectName | Object name property template.
Structs, Records, Enums
Struct, Record, Enum | Description
AccelerationUnitType | An enumeration that describes accelleration units.
AlignmentPointType | Defines types of points on an Alignment.
AnchorLocationType | Specifies where to anchor various label annotations.
AnchorPointType | Specifies where to anchor various label annotations.
AngleFormatType | Specifies angle format.
AngleUnitType | Specifies angle units.
AreaUnitType | Specifies area units.
ArrowHeadFitType | An enumeration that defines the arrow head fit type.
ArrowHeadSizeType | An enumeration that defines the arrow head size type.
ArrowHeadType | An enumeration that defines the arrow head type.
BearingQuadrantType | Specifies bearing quadrant type.
BlockAttachmentType | Specifies specifies how block label components are attached.
CapitalizationType | Specifies how direction value text is capitalized.
CurbReturnType | Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.
DecimalCharacterType | Specifies decimal character type.
DimensionAnchorOptionType | An enumeration that specifies the behavior of the anchor dimension.
DimensionAnchorType | Defines the location of the anchor used to position dimension lines for certain profile view labels, such as vertical curve... more
DirectionDisplayType | Specifies display direction.
DirectionNameDisplayType | Specifies direction name display.
DrivingDirectionType | The Autodesk::Civil::DrivingDirectionType enumeration.
DropDecimalWholeType | Specifies decimal rounding.
DropLeadingZeroType | Specifies whether to drop leading zeros.
FlowUnitType | Specifies flow units.
GradeFormatType | Specifies grade format.
GradeSlopeFormatType | Specifies grade slope format.
LabelContentDisplayType | Defines label content display type after it is dragged from its default position.
LabelingPromptType | Specifies labeling prompt.
LabelInsertionType | Specifies label insertion.
LabelInsideCurveType | Defines labels place type, inside or outside a curve.
LabelMaskType | Specifies label mask types.
LabelTextAttachmentType | Enumeration that label text attachment location.
LatLongDirectionType | Specifies latitude / longitude direction.
LayoutModeType | Specifies layout mode.
LeaderAttachmentBehaviorType | An enumeration that specifies the attachment behavior of the leader.
LeaderAttachmentType | Specifies leader attachment location.
LeaderShapeType | Defines the leader shape type.
LeaderTailVisibilityType | An enumeration that specifies the behavior of the leader tail visibility.
LeaderVisibilityType | An enumeration that specifies the behavior of the leader visibility.
LinearUnitType | Specifies linear units.
MaskType | An enumeration that specifies the behavior of a label's background mask.
OrientationReferenceType | Specifies orientation reference.
PlottedUnitDisplayType | Specifies plotted units.
ProfilePointType | Defines types of points on a Profile.
RotationDirType | Specifies rotation direction.
RoundingType | Specifies rounding.
ROWCleanupType | Specifies ROW cleanup.
SignType | Specifies sign.
SlopeFormatType | Specifies slope format.
SpeedUnitType | Specifies speed units.
SpiralType | An enumeration that defines the sprial types.
StationDelimiterCharacterType | Specifies station delimeter character.
StationDelimiterPositionType | Specifies station position.
StationFormatType | Specifies station format.
StructureColumnComponentType | An enumeration that specifies the structure table cell component type.
StyleConflictResolverType | Specifies how to resolve conflicts (the same name for an existing style and a new imported style) when exporting styles... more
SuperelevationPointType | Defines the superelevation critical points type that need to be labeled.
TableSegmentDataType | Defines the type of content in a table column.
TableTitleDirectionType | An enumeration that defines the table title directions.
TextBorderType | Specifies text border types.
TextJustificationType | Specifies text justification.
TransitionInputType | Specify the type of linear transition used for the widening: By Length or By Taper Ratio.
TransitionType | Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.
VectorMeasurementType | Specifies vector measurment.
VolumeUnitType | Specifies volume units.
Links
Namespaces, Topics, Classes, Structs, Records, Enums


Autodesk::Civil::ApplicationServices Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
CivilApplication | The CivilApplication class. This is the base class used to access CivilDocument.
CivilDocument | The CivilDocument class. This is the root object for accessing settings, styles, and C3D entities, Alignment etc.
Structs, Records, Enums
Struct, Record, Enum | Description
ProductType | The available products types, returned by CivilApplication.ActiveProduct.
Links
Topics, Classes, Structs, Records, Enums


Classes

The following table lists classes in this documentation.

Classes
Class | Description
CivilApplication | The CivilApplication class. This is the base class used to access CivilDocument.
CivilDocument | The CivilDocument class. This is the root object for accessing settings, styles, and C3D entities, Alignment etc.
Links
Classes


CivilApplication Class

The CivilApplication class. This is the base class used to access CivilDocument.

Class Hierarchy
Autodesk::Civil::ApplicationServices::CivilApplication
C#
public class CivilApplication;
Visual Basic
Public Class CivilApplication
Links
CivilApplication Properties, CivilApplication Members, Class Hierarchy


CivilApplication Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilApplication Class > CivilApplication Members
CivilApplication Members
Collapse All

The following tables list the members exposed by CivilApplication.

Public Properties
Public Property | Description
ActiveDocument | Gets the active CivilDocument object.
ActiveProduct | Gets the type of the currently running product.
Links
Public Properties


CivilApplication Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilApplication Class > CivilApplication Properties
CivilApplication Properties
Collapse All

The properties of CivilApplication are listed here.

Public Properties
Public Property | Description
ActiveDocument | Gets the active CivilDocument object.
ActiveProduct | Gets the type of the currently running product.
Links
Public Properties


CivilApplication::ActiveDocument Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilApplication Class > CivilApplication Properties > CivilApplication::ActiveDocument Property
CivilApplication::ActiveDocument Property
Collapse All

Gets the active CivilDocument object.

C#
public CivilDocument ActiveDocument;
Visual Basic
Public Property ActiveDocument() As CivilDocument
Returns

The CivilDocument object.

Example
CivilDocument doc = CivilApplication.ActiveDocument;
Links
CivilApplication Class, CivilApplication Members, Autodesk::Civil::ApplicationServices Namespace


CivilApplication::ActiveProduct Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilApplication Class > CivilApplication Properties > CivilApplication::ActiveProduct Property
CivilApplication::ActiveProduct Property
Collapse All

Gets the type of the currently running product.

C#
public ProductType ActiveProduct;
Visual Basic
Public Property ActiveProduct() As ProductType
Links
CivilApplication Class, CivilApplication Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument Class

The CivilDocument class. This is the root object for accessing settings, styles, and C3D entities, Alignment etc.

Class Hierarchy
Autodesk::Civil::ApplicationServices::CivilDocument
C#
public class CivilDocument : CivilWrapper<AcDbDatabase>;
Visual Basic
Public Class CivilDocument
Inherits CivilWrapper<AcDbDatabase>
Links
CivilDocument Methods, CivilDocument Properties, CivilDocument Members, Class Hierarchy


CivilDocument Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Members
CivilDocument Members
Collapse All

The following tables list the members exposed by CivilDocument.

Public Methods
Public Method | Description
GetAlignmentIds | Gets the objectId collection of all Alignment objects in the drawing.
GetAlignmentTableIds | Gets the objectId collection of all alignment tables.
GetAllPointIds | Gets the objectId collection of all points in the drawing.
GetIntersectionIds | Gets the objectId collection of all intersection objects in the drawing.
GetLegendTableIds | Gets the objectId collection of legend tables.
GetParcelSegmentTableIds | Gets the objectId collection of parcel segment tables.
GetParcelTableIds | Gets the objectId collection of parcel tables.
GetPipeNetworkIds | Gets the pipe network object id collection.
GetPointTableIds | Gets the objectId collection of point tables.
GetSiteIds | Gets the objectId collection of all site objects in the drawing.
GetSitelessAlignmentId | Gets the objectId of a siteless Alignment object by name.
GetSitelessAlignmentIds | Gets the objectId collection of all siteless Alignment objects in the drawing.
GetSurfaceIds | Gets the objectId collection of all surface objects in the drawing.
GetViewFrameGroupIds | Gets the objectId collection of all view frame groups in the drawing.
Public Properties
Public Property | Description
AssemblyCollection | Gets the ObjectId collection of Assembly objects in the drawing.
CorridorCollection | Gets the ObjectId collection of Corridor objects in the drawing.
CorridorState | Gets the CorridorState object, which is used for the creation of custom subassemblies.
IsCorridorSectionViewActive | Returns true if the corridor section view is active in the current document.
NetworkState | Gets the drawing's PipeNetworkState object.
Settings | Gets the root object for Civil 3D settings.
Styles | Gets the root object for Civil 3D styles.
SubassemblyCollection | Gets the ObjectId collection of SubAssembly objects in the drawing.
Links
Public Methods, Public Properties


CivilDocument Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods
CivilDocument Methods
Collapse All

The methods of CivilDocument are listed here.

Public Methods
Public Method | Description
GetAlignmentIds | Gets the objectId collection of all Alignment objects in the drawing.
GetAlignmentTableIds | Gets the objectId collection of all alignment tables.
GetAllPointIds | Gets the objectId collection of all points in the drawing.
GetIntersectionIds | Gets the objectId collection of all intersection objects in the drawing.
GetLegendTableIds | Gets the objectId collection of legend tables.
GetParcelSegmentTableIds | Gets the objectId collection of parcel segment tables.
GetParcelTableIds | Gets the objectId collection of parcel tables.
GetPipeNetworkIds | Gets the pipe network object id collection.
GetPointTableIds | Gets the objectId collection of point tables.
GetSiteIds | Gets the objectId collection of all site objects in the drawing.
GetSitelessAlignmentId | Gets the objectId of a siteless Alignment object by name.
GetSitelessAlignmentIds | Gets the objectId collection of all siteless Alignment objects in the drawing.
GetSurfaceIds | Gets the objectId collection of all surface objects in the drawing.
GetViewFrameGroupIds | Gets the objectId collection of all view frame groups in the drawing.
Links
Public Methods


CivilDocument::GetAlignmentIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetAlignmentIds Method
CivilDocument::GetAlignmentIds Method
Collapse All

Gets the objectId collection of all Alignment objects in the drawing.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAlignmentIds();
Visual Basic
Public Function GetAlignmentIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Remarks

The collection returned by this method includes both site and siteless alignments.

Example
// get first profile of first alignment in document
ObjectId alignID = doc.GetAlignmentIds()[0];
Alignment oAlignment = ts.GetObject(alignID, OpenMode.ForRead) as Alignment;
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetAlignmentTableIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetAlignmentTableIds Method
CivilDocument::GetAlignmentTableIds Method
Collapse All

Gets the objectId collection of all alignment tables.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAlignmentTableIds();
Visual Basic
Public Function GetAlignmentTableIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetAllPointIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetAllPointIds Method
CivilDocument::GetAllPointIds Method
Collapse All

Gets the objectId collection of all points in the drawing.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAllPointIds();
Visual Basic
Public Function GetAllPointIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetIntersectionIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetIntersectionIds Method
CivilDocument::GetIntersectionIds Method
Collapse All

Gets the objectId collection of all intersection objects in the drawing.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetIntersectionIds();
Visual Basic
Public Function GetIntersectionIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetLegendTableIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetLegendTableIds Method
CivilDocument::GetLegendTableIds Method
Collapse All

Gets the objectId collection of legend tables.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetLegendTableIds();
Visual Basic
Public Function GetLegendTableIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetParcelSegmentTableIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetParcelSegmentTableIds Method
CivilDocument::GetParcelSegmentTableIds Method
Collapse All

Gets the objectId collection of parcel segment tables.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetParcelSegmentTableIds();
Visual Basic
Public Function GetParcelSegmentTableIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetParcelTableIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetParcelTableIds Method
CivilDocument::GetParcelTableIds Method
Collapse All

Gets the objectId collection of parcel tables.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetParcelTableIds();
Visual Basic
Public Function GetParcelTableIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetPipeNetworkIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetPipeNetworkIds Method
CivilDocument::GetPipeNetworkIds Method
Collapse All

Gets the pipe network object id collection.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetPipeNetworkIds();
Visual Basic
Public Function GetPipeNetworkIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetPointTableIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetPointTableIds Method
CivilDocument::GetPointTableIds Method
Collapse All

Gets the objectId collection of point tables.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetPointTableIds();
Visual Basic
Public Function GetPointTableIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetSiteIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetSiteIds Method
CivilDocument::GetSiteIds Method
Collapse All

Gets the objectId collection of all site objects in the drawing.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetSiteIds();
Visual Basic
Public Function GetSiteIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetSitelessAlignmentId Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetSitelessAlignmentId Method
CivilDocument::GetSitelessAlignmentId Method
Collapse All

Gets the objectId of a siteless Alignment object by name.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId GetSitelessAlignmentId(
    ref System::String name
);
Visual Basic
Public Function GetSitelessAlignmentId(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | Name of the siteless alignment.
Remarks

The siteless alignment name is unique, therefore it can be used as a key to get an alignment id.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when there's no siteless alignment with this name in the drawing.
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetSitelessAlignmentIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetSitelessAlignmentIds Method
CivilDocument::GetSitelessAlignmentIds Method
Collapse All

Gets the objectId collection of all siteless Alignment objects in the drawing.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetSitelessAlignmentIds();
Visual Basic
Public Function GetSitelessAlignmentIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetSurfaceIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetSurfaceIds Method
CivilDocument::GetSurfaceIds Method
Collapse All

Gets the objectId collection of all surface objects in the drawing.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetSurfaceIds();
Visual Basic
Public Function GetSurfaceIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Remarks

OBJECTID TYPE:Autodesk.Civil.Land.DatabaseServices.Surface.

Example
// get first surface in the document
ObjectId surfaceId = doc.GetSurfaceIds()[0];
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::GetViewFrameGroupIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods > CivilDocument::GetViewFrameGroupIds Method
CivilDocument::GetViewFrameGroupIds Method
Collapse All

Gets the objectId collection of all view frame groups in the drawing.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetViewFrameGroupIds();
Visual Basic
Public Function GetViewFrameGroupIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties
CivilDocument Properties
Collapse All

The properties of CivilDocument are listed here.

Public Properties
Public Property | Description
AssemblyCollection | Gets the ObjectId collection of Assembly objects in the drawing.
CorridorCollection | Gets the ObjectId collection of Corridor objects in the drawing.
CorridorState | Gets the CorridorState object, which is used for the creation of custom subassemblies.
IsCorridorSectionViewActive | Returns true if the corridor section view is active in the current document.
NetworkState | Gets the drawing's PipeNetworkState object.
Settings | Gets the root object for Civil 3D settings.
Styles | Gets the root object for Civil 3D styles.
SubassemblyCollection | Gets the ObjectId collection of SubAssembly objects in the drawing.
Links
Public Properties


CivilDocument::AssemblyCollection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties > CivilDocument::AssemblyCollection Property
CivilDocument::AssemblyCollection Property
Collapse All

Gets the ObjectId collection of Assembly objects in the drawing.

C#
public Autodesk::Civil::Roadway::DatabaseServices::AssemblyCollection AssemblyCollection;
Visual Basic
Public Property AssemblyCollection() As Autodesk::Civil::Roadway::DatabaseServices::AssemblyCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::CorridorCollection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties > CivilDocument::CorridorCollection Property
CivilDocument::CorridorCollection Property
Collapse All

Gets the ObjectId collection of Corridor objects in the drawing.

C#
public Autodesk::Civil::Roadway::DatabaseServices::CorridorCollection CorridorCollection;
Visual Basic
Public Property CorridorCollection() As Autodesk::Civil::Roadway::DatabaseServices::CorridorCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::CorridorState Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties > CivilDocument::CorridorState Property
CivilDocument::CorridorState Property
Collapse All

Gets the CorridorState object, which is used for the creation of custom subassemblies.

C#
public Autodesk::Civil::Runtime::CorridorState CorridorState;
Visual Basic
Public Property CorridorState() As Autodesk::Civil::Runtime::CorridorState
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::IsCorridorSectionViewActive Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties > CivilDocument::IsCorridorSectionViewActive Property
CivilDocument::IsCorridorSectionViewActive Property
Collapse All

Returns true if the corridor section view is active in the current document.

C#
public bool IsCorridorSectionViewActive;
Visual Basic
Public Property IsCorridorSectionViewActive() As bool
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::NetworkState Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties > CivilDocument::NetworkState Property
CivilDocument::NetworkState Property
Collapse All

Gets the drawing's PipeNetworkState object.

C#
public Autodesk::Civil::Runtime::PipeNetworkState NetworkState;
Visual Basic
Public Property NetworkState() As Autodesk::Civil::Runtime::PipeNetworkState
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::Settings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties > CivilDocument::Settings Property
CivilDocument::Settings Property
Collapse All

Gets the root object for Civil 3D settings.

C#
public Autodesk::Civil::Settings::SettingsRoot Settings;
Visual Basic
Public Property Settings() As Autodesk::Civil::Settings::SettingsRoot
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties > CivilDocument::Styles Property
CivilDocument::Styles Property
Collapse All

Gets the root object for Civil 3D styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::StylesRoot Styles;
Visual Basic
Public Property Styles() As Autodesk::Civil::DatabaseServices::Styles::StylesRoot
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


CivilDocument::SubassemblyCollection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties > CivilDocument::SubassemblyCollection Property
CivilDocument::SubassemblyCollection Property
Collapse All

Gets the ObjectId collection of SubAssembly objects in the drawing.

C#
public Autodesk::Civil::Roadway::DatabaseServices::SubassemblyCollection SubassemblyCollection;
Visual Basic
Public Property SubassemblyCollection() As Autodesk::Civil::Roadway::DatabaseServices::SubassemblyCollection
Links
CivilDocument Class, CivilDocument Members, Autodesk::Civil::ApplicationServices Namespace


Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
ProductType | The available products types, returned by CivilApplication.ActiveProduct.
Links
Enumerations


Autodesk::Civil::ApplicationServices::ProductType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Structs, Records, Enums > Autodesk::Civil::ApplicationServices::ProductType Enumeration
Autodesk::Civil::ApplicationServices::ProductType Enumeration
Collapse All

The available products types, returned by CivilApplication.ActiveProduct.

C#
public enum ProductType {
  Unknown = Aecc::kUndetermined,
  Other = Aecc::kOther,
  Civil3D = Aecc::kCivil3D,
  Map = Aecc::kMap,
  Civil = Aecc::kCivil
}
Visual Basic
Public Enum ProductType
  Unknown = Aecc::kUndetermined
  Other = Aecc::kOther
  Civil3D = Aecc::kCivil3D
  Map = Aecc::kMap
  Civil = Aecc::kCivil
End Enum
Members
Members | Description
Unknown | Unknown
Other | Other (AutoCAD)
Civil3D | Civil 3D
Map | AutoCAD Map
Civil | Civil


Autodesk::Civil::DatabaseServices Namespace

The Autodesk::Civil::DatabaseServices namespace.

Namespaces
Namespace | Description
Styles | The Autodesk::Civil::DatabaseServices::Styles namespace.
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
AnchorInfo | This is class Autodesk::Civil::DatabaseServices::AnchorInfo.
AutoFeatureLabelGroup | The base class for all label group objects that automatically label a range on a feature.
DBObject | The base class for database entities.
Entity | The base class for entities, such as Feature, Table, Grading, Site, etc.
Feature | Base class for Alignment, FeatureLine, ParcelSegment, and Profile.
FeatureLabel | A base class for feature label classes, such as AlignmentCurveLabel.
GeoEntity | The base class for geometry db entities.
Graph | The base class for graphic entities.
GraphOverride | The base class for graphic override.
Label | The base class for all single-entity label objects.
LabelBase | The base class for all label classes, including single-feature labels (FeatureLabel derived classes) and group labels (LabelGroup derived... more
LabelGroup | The base class for all label group objects, such as AutoFeatureLabelGroup.
LabelGroupSubEntity | A class that represents individual labels in a label group.
LegendTable | A table that displays colors and range values for a surface analysis.
Table | Base class for table objects, such as LegendTable and AlignmentTable.
Interfaces
Interface | Description
ICommonLabel | The interface ICommonLabel declares properties and methods common to all classes representing labels.
ICommonLabelOptions | The interface ICommonLabelOptions declares common behavioral options on labels.
Structs, Records, Enums
Struct, Record, Enum | Description
LabelType | An enumeration that describes all possible label types that a base label object can be.
Links
Namespaces, Topics, Classes, Interfaces, Structs, Records, Enums


Autodesk::Civil::DatabaseServices::Styles Namespace

The Autodesk::Civil::DatabaseServices::Styles namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
AxisStyle | Controls the use of tick marks on the horizontal and vertical axes of the profile view or cross section view.... more
AxisTickStyle | Controls the title location and display on the horizontal and vertical axes of the profile view or cross section view.... more
AxisTitleStyle | The AxisTitleStyle class, which defines the text, text style, size etc. of an axis title.
BandSetItem | Encapsulates a single profile view data band style.
BandSetItemCollection | A collection of BandStyle objects.
BandStyle | Specifies style properties for data bands, the graphic frames that are associated with a profile view object or section view... more
BandStyleCollection | A collection of BandStyle objects.
BandStylesRoot | The root object that contains collections of the various band styles in a document.
BandTickStyle | Specifies the type and location of ticks for profile or section view data bands.
BaseLabelSetItem | The base class for alignment label set items.
BaseLabelSetStyle | The base class for alignment label set styles.
ColumnStyle | Defines column width and value properties for table style objects.
ColumnStyleCollection | A collection of ColumnStyle objects.
Expression | Encapsulates an expression used in label styles.
ExpressionCollection | A collection of Expression objects.
FeatureLineStyle | Specifies default display and other characteristics for feature line features when they are created.
FeatureLineStyleCollection | A collection of FeatureLineStyle objects.
GraphStyle | Specifies format and contents of the title, vertical exaggeration, and grid options for graphs.
GraphTitleStyle | Specifies display characteristics for profile and section view graphs.
GridOptions | Specifies various grid options used by GridStyle.
GridStyle | Specifies display characteristics for profile and section view graph gridlines.
LabelSetStylesRoot | The root object for accessing label set style collections in the database.
LabelStyle | The master label style class, containing feature-specific label styles and associated information such as derived styles.
LabelStyleBase | Base class for label style defaults.
LabelStyleBase::BaseBehavior | The behavior related properties of the default label style.
LabelStyleBase::BaseDraggedStateComponents | The dragged state components related properties of the default label style.
LabelStyleBase::BaseLabel | The label related properties of the default label style.
LabelStyleBase::BaseLeader | The leader related properties of the default label style.
LabelStyleBase::BasePlanReadability | The plan readability related properties of the default label style.
LabelStyleBlockComponent::StyleBlock | Block style settings for label block components.
LabelStyleBlockComponent::StyleGeneral | General style settings for label block components.
LabelStyleCollection | A collection of LabelStyle objects.
LabelStyleDefault::DefaultBehavior | The behavior related properties of the default label style settings.
LabelStyleDefault::DefaultComponents | The component related properties of the default label style settings.
LabelStyleDefault::DefaultDraggedStateComponents | The dragged state components related properties of the default label style settings.
LabelStyleDefault::DefaultLabel | The label related properties of the default label style settings.
LabelStyleDefault::DefaultLeader | The leader related properties of the default label style settings.
LabelStyleDefault::DefaultPlanReadability | The plan readability related properties of the default label style settings.
LabelStyleDirectionArrowComponent::StyleDirectionArrow | Direction arrow style settings for label direction arrow components.
LabelStyleDirectionArrowComponent::StyleGeneral | General style settings for label direction arrow components.
LabelStyleLineComponent::StyleGeneral | General style settings for line labels.
LabelStyleLineComponent::StyleLine | Line style settings for line labels.
LabelStylesNode | Base class for root label style classes, such as LabelStylesAlignmentRoot.
LabelStylesRoot | Root object for accessing all label styles in a CivilDocument.
LabelStyleTextComponent | Specifies the appearance and behavior of text feature labels in the drawing. Controls the appearance of the text itself.
LabelStyleTextComponent::StyleBorder | Border style settings for label text components.
LabelStyleTextComponent::StyleGeneral | General style settings for label text components.
LabelStyleTextComponent::StyleText | Text style settings for label text components.
LabelStyleTickComponent::StyleGeneral | General style settings for label tick components.
LabelStyleTickComponent::StyleTick | Tick style settings for label tick components.
MarkerStyle | Sets the style of a marker. Markers are used to mark locations along Alignment objects or survey figures (SurveyFigure... more
MarkerStyleBase | The base class for marker and point styles.
MarkerStyleCollection | A collection of MarkerStyle objects.
ProjectionProfileOptions | Contains display options and styles for objects projected from a plan view onto a profile view.
ProjectionSectionOptions | Contains display options and styles for objects projected from a plan view onto a section view. Used by ProjectionStyle.... more
ProjectionStyle | Contains display options and styles for objects projected from a plan view onto a section or profile view.
ProjectionStyleCollection | A collection of ProjectionStyle objects.
SegmentColumnStyle | Specifies the advance column style obtained from the Parcel Segment table style or Alignment Segment table style.
StructureColumnComponentData | Specifies the tabel cell component data information.
StructureColumnComponents |
StructureColumnStyle | Specifies the advance column style obtained from the Structure table style.
StyleBase | The base class for all style objects.
StyleCollectionBase | The base class for all style collections.
StylesRoot | The root class for accessing collections of all Civil 3D styles.
TableStyle | Controls the display of tables.
TableStyleCollection | A collection of TableStyle objects.
TableStylesRoot | The root object of all Civil 3D table-related styles.
Structs, Records, Enums
Struct, Record, Enum | Description
AxisPosition | Defines profile view, section view axis position.
AxisTickJustificationType | Specifies the position of the tick relative to the axis.
AxisTickType | Defines profile view, section view axis tick type.
AxisTitleLocationType | Specifies the location of the axis title in relation to the view grid.
BandLabelStyleType | Defines the band label style type.
BandSetItemLocationType | Enumerates the location for a band set item.
BandStyleType | Defines the band style type.
BandTickAttributeIdType | Defines the band tick position type.
BandTitleBoxPosition | Defines the band title box postion.
BandTitleTextLocation | Defines the band title text location.
CustomMarkerSuperimposeType | Specifies the custom point style marker as either none, a superimposed circle, a superimposed square, or both superimposed square and... more
CustomMarkerType | Specifies the custom point style marker as either a dot, a blank, two perpendicular lines (plus sign), two x-crossed lines,... more
ExpressionFormatedType | Defines the format type of the expression result.
FeatureLineDisplayStyleProfileType | Defines FeatureLineStyle display style type.
GraphDirectionType | Specifies the direction of the profile in the profile view grid.
GraphTitleJustificationType | Specifies the location of the graph title in relation to the view grid.
GraphTitleLocationType | Specifies the location of the graph title in relation to the view grid.
GridType | Defines clipping options on the profile view or section view grid.
LabelDisplayModeType | The Autodesk::Civil::DatabaseServices::Styles::LabelDisplayModeType enumeration.
LabelStyleComponentType | Defines the label style components type.
LabelStyleType | Defines the label style type.
MarkerDisplayType | Specifies the kind of marker to use: point, custom, symbol, or vertical line.
MarkerOrientationType | Defines how the marker is oriented, for example, to object, to world, or to view.
MarkerSizeType | Defines how the marker is sized, for example, relative to screen, or fixed scale.
markStylePropertyType | The Autodesk::Civil::DatabaseServices::Styles::markStylePropertyType enumeration.
ProjectionBlockDisplayType | An enumeration that defines projection block display type.
ProjectionDisplayStyleProfileType | An enumeration that defines projection display style profile type.
ProjectionDisplayStyleSectionType | An enumeration that defines projection display style section type.
ProjectionEntityDisplayType | An enumeration that defines projection point display type. This enum is only used for AutoCAD point and AutoCAD solid display... more
ReferenceTextComponentSelectedType | The Autodesk::Civil::DatabaseServices::Styles::ReferenceTextComponentSelectedType enumeration.
StaggerLabelType | Defines the grade break label stagger type.
TableDisplayStyleType | An enumeration that defines tab display style type.
TableSortingOrderType | Specifies the table sorting order type.
TableStyleType | Specifies the table style type.
TextForEachComponentSelectedType | The Autodesk::Civil::DatabaseServices::Styles::TextForEachComponentSelectedType enumeration.
Links
Topics, Classes, Structs, Records, Enums


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes
Classes
Collapse All

The following table lists classes in this documentation.

Classes
Class | Description
AxisStyle | Controls the use of tick marks on the horizontal and vertical axes of the profile view or cross section view.... more
AxisTickStyle | Controls the title location and display on the horizontal and vertical axes of the profile view or cross section view.... more
AxisTitleStyle | The AxisTitleStyle class, which defines the text, text style, size etc. of an axis title.
BandSetItem | Encapsulates a single profile view data band style.
BandSetItemCollection | A collection of BandStyle objects.
BandStyle | Specifies style properties for data bands, the graphic frames that are associated with a profile view object or section view... more
BandStyleCollection | A collection of BandStyle objects.
BandStylesRoot | The root object that contains collections of the various band styles in a document.
BandTickStyle | Specifies the type and location of ticks for profile or section view data bands.
BaseLabelSetItem | The base class for alignment label set items.
BaseLabelSetStyle | The base class for alignment label set styles.
ColumnStyle | Defines column width and value properties for table style objects.
ColumnStyleCollection | A collection of ColumnStyle objects.
Expression | Encapsulates an expression used in label styles.
ExpressionCollection | A collection of Expression objects.
FeatureLineStyle | Specifies default display and other characteristics for feature line features when they are created.
FeatureLineStyleCollection | A collection of FeatureLineStyle objects.
GraphStyle | Specifies format and contents of the title, vertical exaggeration, and grid options for graphs.
GraphTitleStyle | Specifies display characteristics for profile and section view graphs.
GridOptions | Specifies various grid options used by GridStyle.
GridStyle | Specifies display characteristics for profile and section view graph gridlines.
LabelSetStylesRoot | The root object for accessing label set style collections in the database.
LabelStyle | The master label style class, containing feature-specific label styles and associated information such as derived styles.
LabelStyleBase | Base class for label style defaults.
LabelStyleBase::BaseBehavior | The behavior related properties of the default label style.
LabelStyleBase::BaseDraggedStateComponents | The dragged state components related properties of the default label style.
LabelStyleBase::BaseLabel | The label related properties of the default label style.
LabelStyleBase::BaseLeader | The leader related properties of the default label style.
LabelStyleBase::BasePlanReadability | The plan readability related properties of the default label style.
LabelStyleBlockComponent::StyleBlock | Block style settings for label block components.
LabelStyleBlockComponent::StyleGeneral | General style settings for label block components.
LabelStyleCollection | A collection of LabelStyle objects.
LabelStyleDefault::DefaultBehavior | The behavior related properties of the default label style settings.
LabelStyleDefault::DefaultComponents | The component related properties of the default label style settings.
LabelStyleDefault::DefaultDraggedStateComponents | The dragged state components related properties of the default label style settings.
LabelStyleDefault::DefaultLabel | The label related properties of the default label style settings.
LabelStyleDefault::DefaultLeader | The leader related properties of the default label style settings.
LabelStyleDefault::DefaultPlanReadability | The plan readability related properties of the default label style settings.
LabelStyleDirectionArrowComponent::StyleDirectionArrow | Direction arrow style settings for label direction arrow components.
LabelStyleDirectionArrowComponent::StyleGeneral | General style settings for label direction arrow components.
LabelStyleLineComponent::StyleGeneral | General style settings for line labels.
LabelStyleLineComponent::StyleLine | Line style settings for line labels.
LabelStylesNode | Base class for root label style classes, such as LabelStylesAlignmentRoot.
LabelStylesRoot | Root object for accessing all label styles in a CivilDocument.
LabelStyleTextComponent | Specifies the appearance and behavior of text feature labels in the drawing. Controls the appearance of the text itself.
LabelStyleTextComponent::StyleBorder | Border style settings for label text components.
LabelStyleTextComponent::StyleGeneral | General style settings for label text components.
LabelStyleTextComponent::StyleText | Text style settings for label text components.
LabelStyleTickComponent::StyleGeneral | General style settings for label tick components.
LabelStyleTickComponent::StyleTick | Tick style settings for label tick components.
MarkerStyle | Sets the style of a marker. Markers are used to mark locations along Alignment objects or survey figures (SurveyFigure... more
MarkerStyleBase | The base class for marker and point styles.
MarkerStyleCollection | A collection of MarkerStyle objects.
ProjectionProfileOptions | Contains display options and styles for objects projected from a plan view onto a profile view.
ProjectionSectionOptions | Contains display options and styles for objects projected from a plan view onto a section view. Used by ProjectionStyle.... more
ProjectionStyle | Contains display options and styles for objects projected from a plan view onto a section or profile view.
ProjectionStyleCollection | A collection of ProjectionStyle objects.
SegmentColumnStyle | Specifies the advance column style obtained from the Parcel Segment table style or Alignment Segment table style.
StructureColumnComponentData | Specifies the tabel cell component data information.
StructureColumnComponents |
StructureColumnStyle | Specifies the advance column style obtained from the Structure table style.
StyleBase | The base class for all style objects.
StyleCollectionBase | The base class for all style collections.
StylesRoot | The root class for accessing collections of all Civil 3D styles.
TableStyle | Controls the display of tables.
TableStyleCollection | A collection of TableStyle objects.
TableStylesRoot | The root object of all Civil 3D table-related styles.
Links
Classes


AxisStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class
AxisStyle Class
Collapse All

Controls the use of tick marks on the horizontal and vertical axes of the profile view or cross section view.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::AxisStyle
C#
public class AxisStyle : CivilWrapper<AeccDbGraphStyle>;
Visual Basic
Public Class AxisStyle
Inherits CivilWrapper<AeccDbGraphStyle>
Links
AxisStyle Properties, AxisStyle Members, Class Hierarchy


AxisStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Members
AxisStyle Members
Collapse All

The following tables list the members exposed by AxisStyle.

Public Properties
Public Property | Description
HorizontalGeometryTickStyle | Gets the style object that specifies the appearance of horizontal geometry ticks on the horizontal axes, for example, interval, size,... more
MajorTickStyle | Gets the style object that specifies the appearance of major ticks on the vertical or horizontal axes, for example, interval,... more
MinorTickStyle | Gets the style object that specifies the appearance of minor ticks on the vertical or horizontal axes, for example, interval,... more
ShowTickAndLabel | Gets or sets the boolean value that specifies whether ticks and labels are placed at the start station on the... more
TitleStyle | Gets the style object that controls the appearance of the axis title text for profile or section views.
Links
Public Properties


AxisStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Properties
AxisStyle Properties
Collapse All

The properties of AxisStyle are listed here.

Public Properties
Public Property | Description
HorizontalGeometryTickStyle | Gets the style object that specifies the appearance of horizontal geometry ticks on the horizontal axes, for example, interval, size,... more
MajorTickStyle | Gets the style object that specifies the appearance of major ticks on the vertical or horizontal axes, for example, interval,... more
MinorTickStyle | Gets the style object that specifies the appearance of minor ticks on the vertical or horizontal axes, for example, interval,... more
ShowTickAndLabel | Gets or sets the boolean value that specifies whether ticks and labels are placed at the start station on the... more
TitleStyle | Gets the style object that controls the appearance of the axis title text for profile or section views.
Links
Public Properties


AxisStyle::HorizontalGeometryTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Properties > AxisStyle::HorizontalGeometryTickStyle Property
AxisStyle::HorizontalGeometryTickStyle Property
Collapse All

Gets the style object that specifies the appearance of horizontal geometry ticks on the horizontal axes, for example, interval, size, height, etc.

C#
public AxisTickStyle HorizontalGeometryTickStyle;
Visual Basic
Public Property HorizontalGeometryTickStyle() As AxisTickStyle
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when using the property HorizontalGeometryTickStyle in an AxisStyle which AxisPosition is Left, Center or Right.
Links
AxisStyle Class, AxisStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisStyle::MajorTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Properties > AxisStyle::MajorTickStyle Property
AxisStyle::MajorTickStyle Property
Collapse All

Gets the style object that specifies the appearance of major ticks on the vertical or horizontal axes, for example, interval, size, height, etc.

C#
public AxisTickStyle MajorTickStyle;
Visual Basic
Public Property MajorTickStyle() As AxisTickStyle
Links
AxisStyle Class, AxisStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisStyle::MinorTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Properties > AxisStyle::MinorTickStyle Property
AxisStyle::MinorTickStyle Property
Collapse All

Gets the style object that specifies the appearance of minor ticks on the vertical or horizontal axes, for example, interval, size, height, etc.

C#
public AxisTickStyle MinorTickStyle;
Visual Basic
Public Property MinorTickStyle() As AxisTickStyle
Links
AxisStyle Class, AxisStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisStyle::ShowTickAndLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Properties > AxisStyle::ShowTickAndLabel Property
AxisStyle::ShowTickAndLabel Property
Collapse All

Gets or sets the boolean value that specifies whether ticks and labels are placed at the start station on the horizontal axes.

C#
public bool ShowTickAndLabel;
Visual Basic
Public Property ShowTickAndLabel() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when: 1: The AxisStyle is obtained from a MassHaulViewStyle or SectionViewStyle. 2: The AxisPosition is Top.
Links
AxisStyle Class, AxisStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisStyle::TitleStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Properties > AxisStyle::TitleStyle Property
AxisStyle::TitleStyle Property
Collapse All

Gets the style object that controls the appearance of the axis title text for profile or section views.

C#
public AxisTitleStyle TitleStyle;
Visual Basic
Public Property TitleStyle() As AxisTitleStyle
Links
AxisStyle Class, AxisStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class
AxisTickStyle Class
Collapse All

Controls the title location and display on the horizontal and vertical axes of the profile view or cross section view.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::AxisTickStyle
C#
public class AxisTickStyle : CivilWrapper<AeccDbGraphStyle>;
Visual Basic
Public Class AxisTickStyle
Inherits CivilWrapper<AeccDbGraphStyle>
Links
AxisTickStyle Properties, AxisTickStyle Members, Class Hierarchy


AxisTickStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Members
AxisTickStyle Members
Collapse All

The following tables list the members exposed by AxisTickStyle.

Public Properties
Public Property | Description
Interval | Gets or sets the spacing of ticks on the axes, using the actual ground units.
Justification | Gets or sets the justification (alignment) of the title.
LabelText | Gets or sets the label text for the tick.
OffsetX | Gets or sets a horizontal offset for the tick label from the bottom of the tick.
OffsetY | Gets or sets a vertical offset for the tick label from the bottom of the tick.
Rotation | Gets or sets the angle for the tick label.
Size | Gets or sets the height of the actual ticks on axes, using plotted units.
TextHeight | Gets or sets the height of text (in plotted units) used to label ticks.
TextStyle | Gets or sets the text style for the tick label from the available AutoCAD text styles defined in the current... more
TickAndLabelStartElevation | Gets or sets a boolean value specifies that whether need to tick and label the start elevatioin.
Links
Public Properties


AxisTickStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties
AxisTickStyle Properties
Collapse All

The properties of AxisTickStyle are listed here.

Public Properties
Public Property | Description
Interval | Gets or sets the spacing of ticks on the axes, using the actual ground units.
Justification | Gets or sets the justification (alignment) of the title.
LabelText | Gets or sets the label text for the tick.
OffsetX | Gets or sets a horizontal offset for the tick label from the bottom of the tick.
OffsetY | Gets or sets a vertical offset for the tick label from the bottom of the tick.
Rotation | Gets or sets the angle for the tick label.
Size | Gets or sets the height of the actual ticks on axes, using plotted units.
TextHeight | Gets or sets the height of text (in plotted units) used to label ticks.
TextStyle | Gets or sets the text style for the tick label from the available AutoCAD text styles defined in the current... more
TickAndLabelStartElevation | Gets or sets a boolean value specifies that whether need to tick and label the start elevatioin.
Links
Public Properties


AxisTickStyle::Interval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::Interval Property
AxisTickStyle::Interval Property
Collapse All

Gets or sets the spacing of ticks on the axes, using the actual ground units.

C#
public double Interval;
Visual Basic
Public Property Interval() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when using the property Interval in an AxisTickStyle which AxisTickType is HorizontalGeometry.
Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle::Justification Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::Justification Property
AxisTickStyle::Justification Property
Collapse All

Gets or sets the justification (alignment) of the title.

C#
public AxisTickJustificationType Justification;
Visual Basic
Public Property Justification() As AxisTickJustificationType
Remarks

If axes type is horizontal, justification values are left, center, or right. If axes type is vertical or left, justification values are top, middle, or bottom.

Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle::LabelText Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::LabelText Property
AxisTickStyle::LabelText Property
Collapse All

Gets or sets the label text for the tick.

C#
public System::String LabelText;
Visual Basic
Public Property LabelText() As System::String
Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle::OffsetX Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::OffsetX Property
AxisTickStyle::OffsetX Property
Collapse All

Gets or sets a horizontal offset for the tick label from the bottom of the tick.

C#
public double OffsetX;
Visual Basic
Public Property OffsetX() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [-10.0000, 10.0000] in meters drawing units.
  2. The input value is out of the interval [-32.808398950131233595800524934383, 32.808398950131233595800524934383] in feet drawing units.

Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle::OffsetY Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::OffsetY Property
AxisTickStyle::OffsetY Property
Collapse All

Gets or sets a vertical offset for the tick label from the bottom of the tick.

C#
public double OffsetY;
Visual Basic
Public Property OffsetY() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [-10.0000, 10.0000] in meters drawing units.
  2. The input value is out of the interval [-32.808398950131233595800524934383, 32.808398950131233595800524934383] in feet drawing units.

Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle::Rotation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::Rotation Property
AxisTickStyle::Rotation Property
Collapse All

Gets or sets the angle for the tick label.

C#
public double Rotation;
Visual Basic
Public Property Rotation() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of the interval [-360.00, 360.00].
Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle::Size Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::Size Property
AxisTickStyle::Size Property
Collapse All

Gets or sets the height of the actual ticks on axes, using plotted units.

C#
public double Size;
Visual Basic
Public Property Size() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.00001, 10.000] in meters drawing units.
  2. The input value is out of the interval [0.000033333333333333333333333333333333, 32.808398950131233595800524934383] in feet drawing units.

Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle::TextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::TextHeight Property
AxisTickStyle::TextHeight Property
Collapse All

Gets or sets the height of text (in plotted units) used to label ticks.

C#
public double TextHeight;
Visual Basic
Public Property TextHeight() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.00001, 10.000] in meters drawing units.
  2. The input value is out of the interval [0.000033333333333333333333333333333333, 32.808398950131233595800524934383] in feet drawing units.

Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle::TextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::TextStyle Property
AxisTickStyle::TextStyle Property
Collapse All

Gets or sets the text style for the tick label from the available AutoCAD text styles defined in the current drawing.

C#
public System::String TextStyle;
Visual Basic
Public Property TextStyle() As System::String
Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTickStyle::TickAndLabelStartElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties > AxisTickStyle::TickAndLabelStartElevation Property
AxisTickStyle::TickAndLabelStartElevation Property deprecated
Collapse All

Gets or sets a boolean value specifies that whether need to tick and label the start elevatioin.

C#
public bool TickAndLabelStartElevation;
Visual Basic
Public Property TickAndLabelStartElevation() As bool
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.AxisStyle.ShowTickAndLabel instead.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the AxisTickStyle is obtained from a MassHaulViewStyle or SectionViewStyle.
Links
AxisTickStyle Class, AxisTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTitleStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class
AxisTitleStyle Class
Collapse All

The AxisTitleStyle class, which defines the text, text style, size etc. of an axis title.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::AxisTitleStyle
C#
public class AxisTitleStyle : CivilWrapper<AeccDbGraphStyle>;
Visual Basic
Public Class AxisTitleStyle
Inherits CivilWrapper<AeccDbGraphStyle>
Links
AxisTitleStyle Properties, AxisTitleStyle Members, Class Hierarchy


AxisTitleStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Members
AxisTitleStyle Members
Collapse All

The following tables list the members exposed by AxisTitleStyle.

Public Properties
Public Property | Description
Location | Gets or sets the location of the title in relation to the view grid.
OffsetX | Gets or sets a horizontal offset from the Location setting.
OffsetY | Gets or sets a vertical offset from the Location setting.
Rotation | Gets or sets the angle for the axis title.
Text | Gets or sets the title text for the axis.
TextHeight | Gets or sets the axis title text height (in plotted units).
TextStyle | Gets or sets the text style for the axis title from the available AutoCAD text styles defined in the current... more
Links
Public Properties


AxisTitleStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties
AxisTitleStyle Properties
Collapse All

The properties of AxisTitleStyle are listed here.

Public Properties
Public Property | Description
Location | Gets or sets the location of the title in relation to the view grid.
OffsetX | Gets or sets a horizontal offset from the Location setting.
OffsetY | Gets or sets a vertical offset from the Location setting.
Rotation | Gets or sets the angle for the axis title.
Text | Gets or sets the title text for the axis.
TextHeight | Gets or sets the axis title text height (in plotted units).
TextStyle | Gets or sets the text style for the axis title from the available AutoCAD text styles defined in the current... more
Links
Public Properties


AxisTitleStyle::Location Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties > AxisTitleStyle::Location Property
AxisTitleStyle::Location Property
Collapse All

Gets or sets the location of the title in relation to the view grid.

C#
public AxisTitleLocationType Location;
Visual Basic
Public Property Location() As AxisTitleLocationType
Links
AxisTitleStyle Class, AxisTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTitleStyle::OffsetX Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties > AxisTitleStyle::OffsetX Property
AxisTitleStyle::OffsetX Property
Collapse All

Gets or sets a horizontal offset from the Location setting.

C#
public double OffsetX;
Visual Basic
Public Property OffsetX() As double
Remarks

Enter a positive number to move the title right or a negative number to move it left.

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [-10.0000, 10.0000] in meteres drawing units.
  2. The input value is out of the interval [-32.808398950131233595800524934383, 32.808398950131233595800524934383] in feet drawing units.

Links
AxisTitleStyle Class, AxisTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTitleStyle::OffsetY Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties > AxisTitleStyle::OffsetY Property
AxisTitleStyle::OffsetY Property
Collapse All

Gets or sets a vertical offset from the Location setting.

C#
public double OffsetY;
Visual Basic
Public Property OffsetY() As double
Remarks

Enter a positive number to move up the title or a negative number to move it down.

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [-10.0000, 10.0000] in meteres drawing units.
  2. The input value is out of the interval [-32.808398950131233595800524934383, 32.808398950131233595800524934383] in feet drawing units.

Links
AxisTitleStyle Class, AxisTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTitleStyle::Rotation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties > AxisTitleStyle::Rotation Property
AxisTitleStyle::Rotation Property
Collapse All

Gets or sets the angle for the axis title.

C#
public double Rotation;
Visual Basic
Public Property Rotation() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of the interval [-360.00, 360.00].
Links
AxisTitleStyle Class, AxisTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTitleStyle::Text Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties > AxisTitleStyle::Text Property
AxisTitleStyle::Text Property
Collapse All

Gets or sets the title text for the axis.

C#
public System::String Text;
Visual Basic
Public Property Text() As System::String
Links
AxisTitleStyle Class, AxisTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTitleStyle::TextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties > AxisTitleStyle::TextHeight Property
AxisTitleStyle::TextHeight Property
Collapse All

Gets or sets the axis title text height (in plotted units).

C#
public double TextHeight;
Visual Basic
Public Property TextHeight() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.00001, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.000033333333333333333333333333333333, 32.808398950131233595800524934383] in feet drawing units.

Links
AxisTitleStyle Class, AxisTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


AxisTitleStyle::TextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties > AxisTitleStyle::TextStyle Property
AxisTitleStyle::TextStyle Property
Collapse All

Gets or sets the text style for the axis title from the available AutoCAD text styles defined in the current drawing.

C#
public System::String TextStyle;
Visual Basic
Public Property TextStyle() As System::String
Links
AxisTitleStyle Class, AxisTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandSetItem Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class
BandSetItem Class
Collapse All

Encapsulates a single profile view data band style.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItem
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetItem
    Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetItem
C#
public class BandSetItem : CivilWrapper<AeccDbGraphBandStyleSet>;
Visual Basic
Public Class BandSetItem
Inherits CivilWrapper<AeccDbGraphBandStyleSet>
Links
BandSetItem Properties, BandSetItem Members, Class Hierarchy


BandSetItem Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Members
BandSetItem Members
Collapse All

The following tables list the members exposed by BandSetItem.

Public Properties
Public Property | Description
BandStyleId | Gets the object that identifies the style for the band type.
Gap | Gets or sets the distance between the current data band and the adjacent grid or data band.
Location | Gets the BandSetOptionsType enum value that identifies band location and display settings.
Weeding | Gets or sets the weeding value.
Links
Public Properties


BandSetItem Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Properties
BandSetItem Properties
Collapse All

The properties of BandSetItem are listed here.

Public Properties
Public Property | Description
BandStyleId | Gets the object that identifies the style for the band type.
Gap | Gets or sets the distance between the current data band and the adjacent grid or data band.
Location | Gets the BandSetOptionsType enum value that identifies band location and display settings.
Weeding | Gets or sets the weeding value.
Links
Public Properties


BandSetItem::BandStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Properties > BandSetItem::BandStyleId Property
BandSetItem::BandStyleId Property
Collapse All

Gets the object that identifies the style for the band type.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId BandStyleId;
Visual Basic
Public Property BandStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.BandStyle.

Links
BandSetItem Class, BandSetItem Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandSetItem::Gap Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Properties > BandSetItem::Gap Property
BandSetItem::Gap Property
Collapse All

Gets or sets the distance between the current data band and the adjacent grid or data band.

C#
public double Gap;
Visual Basic
Public Property Gap() As double
Links
BandSetItem Class, BandSetItem Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandSetItem::Location Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Properties > BandSetItem::Location Property
BandSetItem::Location Property
Collapse All

Gets the BandSetOptionsType enum value that identifies band location and display settings.

C#
public BandSetItemLocationType Location;
Visual Basic
Public Property Location() As BandSetItemLocationType
Links
BandSetItem Class, BandSetItem Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandSetItem::Weeding Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Properties > BandSetItem::Weeding Property
BandSetItem::Weeding Property
Collapse All

Gets or sets the weeding value.

C#
public double Weeding;
Visual Basic
Public Property Weeding() As double
Remarks

Used only for labels at vertical geometry points on Profile Data bands or Section Data bands.

Links
BandSetItem Class, BandSetItem Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandSetItemCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class
BandSetItemCollection Class
Collapse All

A collection of BandStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItemCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetItemCollection
C#
public class BandSetItemCollection : CivilWrapper<AeccDbGraphBandStyleSet>;
Visual Basic
Public Class BandSetItemCollection
Inherits CivilWrapper<AeccDbGraphBandStyleSet>
Links
BandSetItemCollection Methods, BandSetItemCollection Properties, BandSetItemCollection Members, Class Hierarchy


BandSetItemCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Members
BandSetItemCollection Members
Collapse All

The following tables list the members exposed by BandSetItemCollection.

Public Methods
Public Method | Description
Remove | Removes an item from the collection.
Swap | Swap two items in the collection.
Public Properties
Public Property | Description
Count | Gets the number of band style sets in the collection.
Links
Public Methods, Public Properties


BandSetItemCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Methods
BandSetItemCollection Methods
Collapse All

The methods of BandSetItemCollection are listed here.

Public Methods
Public Method | Description
Remove | Removes an item from the collection.
Swap | Swap two items in the collection.
Links
Public Methods


BandSetItemCollection::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Methods > BandSetItemCollection::Remove Method
BandSetItemCollection::Remove Method
Collapse All

Removes an item from the collection.

C#
public Remove(
    int index
);
Visual Basic
Public Sub Remove(
    index As Integer
)
Parameters
Parameters | Description
index | Specified the band style set item by index.
Links
BandSetItemCollection Class, BandSetItemCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandSetItemCollection::Swap Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Methods > BandSetItemCollection::Swap Method
BandSetItemCollection::Swap Method
Collapse All

Swap two items in the collection.

C#
public Swap(
    int index1,
    int index2
);
Visual Basic
Public Sub Swap(
    index1 As Integer,
    index2 As Integer
)
Parameters
Parameters | Description
index1 | Specified the first band style set item by index.
index2 | Specified the second band style set item by index.
Links
BandSetItemCollection Class, BandSetItemCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandSetItemCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Properties
BandSetItemCollection Properties
Collapse All

The properties of BandSetItemCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of band style sets in the collection.
Links
Public Properties


BandSetItemCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Properties > BandSetItemCollection::Count Property
BandSetItemCollection::Count Property
Collapse All

Gets the number of band style sets in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
BandSetItemCollection Class, BandSetItemCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class
BandStyle Class
Collapse All

Specifies style properties for data bands, the graphic frames that are associated with a profile view object or section view object.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::HorizontalGeometryBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDataBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionalDataBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionDataBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionSegmentBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SuperelevationDataBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::VerticalGeometryBandStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeNetworkBandStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleBands"))]
public class BandStyle : StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleBands"))>
Public Class BandStyle
Inherits StyleBase
Links
BandStyle Properties, BandStyle Members, Class Hierarchy


BandStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Members
BandStyle Members
Collapse All

The following tables list the members exposed by BandStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Methods, Public Properties


BandStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties
BandStyle Properties
Collapse All

The properties of BandStyle are listed here.

Public Properties
Public Property | Description
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Properties


BandStyle::BandHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::BandHeight Property
BandStyle::BandHeight Property
Collapse All

Gets or sets the height of the band used in the title.

C#
public double BandHeight;
Visual Basic
Public Property BandHeight() As double
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::BandType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::BandType Property
BandStyle::BandType Property
Collapse All

Gets the BandStyleType enum value that specifies the type of data band data.

C#
public BandStyleType BandType;
Visual Basic
Public Property BandType() As BandStyleType
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::OffsetFromBand Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::OffsetFromBand Property
BandStyle::OffsetFromBand Property
Collapse All

Gets or sets the distance between the title box and the left side of the data band.

C#
public double OffsetFromBand;
Visual Basic
Public Property OffsetFromBand() As double
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::Text Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::Text Property
BandStyle::Text Property
Collapse All

Gets or sets the current title text.

C#
public System::String Text;
Visual Basic
Public Property Text() As System::String
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::TextBoxPosition Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::TextBoxPosition Property
BandStyle::TextBoxPosition Property
Collapse All

Gets or sets the text box position of the band title.

C#
public BandTitleBoxPosition TextBoxPosition;
Visual Basic
Public Property TextBoxPosition() As BandTitleBoxPosition
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::TextBoxWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::TextBoxWidth Property
BandStyle::TextBoxWidth Property
Collapse All

Gets or sets the width of the box that contains the text of the band title.

C#
public double TextBoxWidth;
Visual Basic
Public Property TextBoxWidth() As double
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::TextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::TextHeight Property
BandStyle::TextHeight Property
Collapse All

Gets or sets the height of the band title text in plot units.

C#
public double TextHeight;
Visual Basic
Public Property TextHeight() As double
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::TextLocation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::TextLocation Property
BandStyle::TextLocation Property
Collapse All

Gets or sets the band title text location.

C#
public BandTitleTextLocation TextLocation;
Visual Basic
Public Property TextLocation() As BandTitleTextLocation
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::TextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::TextStyle Property
BandStyle::TextStyle Property
Collapse All

Gets or sets the string name of the AutoCAD text style for the band.

C#
public System::String TextStyle;
Visual Basic
Public Property TextStyle() As System::String
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::TitleTextLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::TitleTextLabelStyleId Property
BandStyle::TitleTextLabelStyleId Property
Collapse All

Gets the band profile data title text label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TitleTextLabelStyleId;
Visual Basic
Public Property TitleTextLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyle::WeedingFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties > BandStyle::WeedingFactor Property
BandStyle::WeedingFactor Property
Collapse All

Gets or sets the band weeding factor.

C#
public double WeedingFactor;
Visual Basic
Public Property WeedingFactor() As double
Links
BandStyle Class, BandStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class
BandStyleCollection Class
Collapse All

A collection of BandStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::BandStyleCollection
C#
public class BandStyleCollection : StyleCollectionBase;
Visual Basic
Public Class BandStyleCollection
Inherits StyleCollectionBase
Links
BandStyleCollection Methods, BandStyleCollection Members, Class Hierarchy


BandStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class > BandStyleCollection Members
BandStyleCollection Members
Collapse All

The following tables list the members exposed by BandStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


BandStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class > BandStyleCollection Methods
BandStyleCollection Methods
Collapse All

The methods of BandStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


BandStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class > BandStyleCollection Methods > BandStyleCollection::Add Method
BandStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
BandStyleCollection Class, BandStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStylesRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class
BandStylesRoot Class
Collapse All

The root object that contains collections of the various band styles in a document.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandStylesRoot
C#
public class BandStylesRoot : TreeOidWrapper;
Visual Basic
Public Class BandStylesRoot
Inherits TreeOidWrapper
Links
BandStylesRoot Properties, BandStylesRoot Members, Class Hierarchy


BandStylesRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Members
BandStylesRoot Members
Collapse All

The following tables list the members exposed by BandStylesRoot.

Public Properties
Public Property | Description
ProfileViewHorizontalGeometryBandStyles | Gets the collection of all profile view horizontal geometry band styles.
ProfileViewPipeNetworkBandStyles | Gets the collection of all profile view pipe network band styles.
ProfileViewProfileDataBandStyles | Gets the collection of all profile view profile data band styles.
ProfileViewSectionalDataBandStyles | Gets the collection of all profile view sectional data band styles.
ProfileViewSuperElevationBandStyles | Gets the collection of all profile view super elevation band styles.
ProfileViewVerticalGeometryBandStyles | Gets the collection of all profile view vertical geometry band styles.
SectionViewSectionDataBandStyles | Gets the collection of all section view section data band styles.
SectionViewSegmentsBandStyles | Gets the collection of all section view section segments band styles.
Links
Public Properties


BandStylesRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties
BandStylesRoot Properties
Collapse All

The properties of BandStylesRoot are listed here.

Public Properties
Public Property | Description
ProfileViewHorizontalGeometryBandStyles | Gets the collection of all profile view horizontal geometry band styles.
ProfileViewPipeNetworkBandStyles | Gets the collection of all profile view pipe network band styles.
ProfileViewProfileDataBandStyles | Gets the collection of all profile view profile data band styles.
ProfileViewSectionalDataBandStyles | Gets the collection of all profile view sectional data band styles.
ProfileViewSuperElevationBandStyles | Gets the collection of all profile view super elevation band styles.
ProfileViewVerticalGeometryBandStyles | Gets the collection of all profile view vertical geometry band styles.
SectionViewSectionDataBandStyles | Gets the collection of all section view section data band styles.
SectionViewSegmentsBandStyles | Gets the collection of all section view section segments band styles.
Links
Public Properties


BandStylesRoot::ProfileViewHorizontalGeometryBandStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties > BandStylesRoot::ProfileViewHorizontalGeometryBandStyles Property
BandStylesRoot::ProfileViewHorizontalGeometryBandStyles Property
Collapse All

Gets the collection of all profile view horizontal geometry band styles.

C#
public BandStyleCollection ProfileViewHorizontalGeometryBandStyles;
Visual Basic
Public Property ProfileViewHorizontalGeometryBandStyles() As BandStyleCollection
Links
BandStylesRoot Class, BandStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStylesRoot::ProfileViewPipeNetworkBandStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties > BandStylesRoot::ProfileViewPipeNetworkBandStyles Property
BandStylesRoot::ProfileViewPipeNetworkBandStyles Property
Collapse All

Gets the collection of all profile view pipe network band styles.

C#
public BandStyleCollection ProfileViewPipeNetworkBandStyles;
Visual Basic
Public Property ProfileViewPipeNetworkBandStyles() As BandStyleCollection
Links
BandStylesRoot Class, BandStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStylesRoot::ProfileViewProfileDataBandStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties > BandStylesRoot::ProfileViewProfileDataBandStyles Property
BandStylesRoot::ProfileViewProfileDataBandStyles Property
Collapse All

Gets the collection of all profile view profile data band styles.

C#
public BandStyleCollection ProfileViewProfileDataBandStyles;
Visual Basic
Public Property ProfileViewProfileDataBandStyles() As BandStyleCollection
Links
BandStylesRoot Class, BandStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStylesRoot::ProfileViewSectionalDataBandStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties > BandStylesRoot::ProfileViewSectionalDataBandStyles Property
BandStylesRoot::ProfileViewSectionalDataBandStyles Property
Collapse All

Gets the collection of all profile view sectional data band styles.

C#
public BandStyleCollection ProfileViewSectionalDataBandStyles;
Visual Basic
Public Property ProfileViewSectionalDataBandStyles() As BandStyleCollection
Links
BandStylesRoot Class, BandStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStylesRoot::ProfileViewSuperElevationBandStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties > BandStylesRoot::ProfileViewSuperElevationBandStyles Property
BandStylesRoot::ProfileViewSuperElevationBandStyles Property
Collapse All

Gets the collection of all profile view super elevation band styles.

C#
public BandStyleCollection ProfileViewSuperElevationBandStyles;
Visual Basic
Public Property ProfileViewSuperElevationBandStyles() As BandStyleCollection
Links
BandStylesRoot Class, BandStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStylesRoot::ProfileViewVerticalGeometryBandStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties > BandStylesRoot::ProfileViewVerticalGeometryBandStyles Property
BandStylesRoot::ProfileViewVerticalGeometryBandStyles Property
Collapse All

Gets the collection of all profile view vertical geometry band styles.

C#
public BandStyleCollection ProfileViewVerticalGeometryBandStyles;
Visual Basic
Public Property ProfileViewVerticalGeometryBandStyles() As BandStyleCollection
Links
BandStylesRoot Class, BandStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStylesRoot::SectionViewSectionDataBandStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties > BandStylesRoot::SectionViewSectionDataBandStyles Property
BandStylesRoot::SectionViewSectionDataBandStyles Property
Collapse All

Gets the collection of all section view section data band styles.

C#
public BandStyleCollection SectionViewSectionDataBandStyles;
Visual Basic
Public Property SectionViewSectionDataBandStyles() As BandStyleCollection
Links
BandStylesRoot Class, BandStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandStylesRoot::SectionViewSegmentsBandStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties > BandStylesRoot::SectionViewSegmentsBandStyles Property
BandStylesRoot::SectionViewSegmentsBandStyles Property
Collapse All

Gets the collection of all section view section segments band styles.

C#
public BandStyleCollection SectionViewSegmentsBandStyles;
Visual Basic
Public Property SectionViewSegmentsBandStyles() As BandStyleCollection
Links
BandStylesRoot Class, BandStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandTickStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class
BandTickStyle Class
Collapse All

Specifies the type and location of ticks for profile or section view data bands.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
C#
public class BandTickStyle : CivilWrapper<AeccDbGraphStyleBands>;
Visual Basic
Public Class BandTickStyle
Inherits CivilWrapper<AeccDbGraphStyleBands>
Links
BandTickStyle Properties, BandTickStyle Members, Class Hierarchy


BandTickStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Members
BandTickStyle Members
Collapse All

The following tables list the members exposed by BandTickStyle.

Public Properties
Public Property | Description
IncrementSmallTicksAtBottom | Gets or sets the boolean value that indicates whether to draw the tick(s) at the bottom of the selected type.... more
IncrementSmallTicksAtMiddle | Gets or sets the boolean value that indicates whether to draw the tick(s) in the middle of the selected type.... more
IncrementSmallTicksAtTop | Gets or sets the boolean value that indicates whether to draw the tick(s) at the top of the selected type.... more
IncrementTicksToFullHeight | Gets or sets the boolean value that indicates whether to draw the tick at the full band height.
SmallTicksAtBottomSize | Gets or sets the height, in drawing units, of small ticks located at the bottom of the data band.
SmallTicksAtMiddleSize | Gets or sets the height, in drawing units, of small ticks located at the middle of the data band.
SmallTicksAtTopSize | Gets or sets the height, in drawing units, of small ticks located at the top of the data band.
Links
Public Properties


BandTickStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties
BandTickStyle Properties
Collapse All

The properties of BandTickStyle are listed here.

Public Properties
Public Property | Description
IncrementSmallTicksAtBottom | Gets or sets the boolean value that indicates whether to draw the tick(s) at the bottom of the selected type.... more
IncrementSmallTicksAtMiddle | Gets or sets the boolean value that indicates whether to draw the tick(s) in the middle of the selected type.... more
IncrementSmallTicksAtTop | Gets or sets the boolean value that indicates whether to draw the tick(s) at the top of the selected type.... more
IncrementTicksToFullHeight | Gets or sets the boolean value that indicates whether to draw the tick at the full band height.
SmallTicksAtBottomSize | Gets or sets the height, in drawing units, of small ticks located at the bottom of the data band.
SmallTicksAtMiddleSize | Gets or sets the height, in drawing units, of small ticks located at the middle of the data band.
SmallTicksAtTopSize | Gets or sets the height, in drawing units, of small ticks located at the top of the data band.
Links
Public Properties


BandTickStyle::IncrementSmallTicksAtBottom Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties > BandTickStyle::IncrementSmallTicksAtBottom Property
BandTickStyle::IncrementSmallTicksAtBottom Property
Collapse All

Gets or sets the boolean value that indicates whether to draw the tick(s) at the bottom of the selected type.

C#
public bool IncrementSmallTicksAtBottom;
Visual Basic
Public Property IncrementSmallTicksAtBottom() As bool
Links
BandTickStyle Class, BandTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandTickStyle::IncrementSmallTicksAtMiddle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties > BandTickStyle::IncrementSmallTicksAtMiddle Property
BandTickStyle::IncrementSmallTicksAtMiddle Property
Collapse All

Gets or sets the boolean value that indicates whether to draw the tick(s) in the middle of the selected type.

C#
public bool IncrementSmallTicksAtMiddle;
Visual Basic
Public Property IncrementSmallTicksAtMiddle() As bool
Links
BandTickStyle Class, BandTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandTickStyle::IncrementSmallTicksAtTop Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties > BandTickStyle::IncrementSmallTicksAtTop Property
BandTickStyle::IncrementSmallTicksAtTop Property
Collapse All

Gets or sets the boolean value that indicates whether to draw the tick(s) at the top of the selected type.

C#
public bool IncrementSmallTicksAtTop;
Visual Basic
Public Property IncrementSmallTicksAtTop() As bool
Links
BandTickStyle Class, BandTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandTickStyle::IncrementTicksToFullHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties > BandTickStyle::IncrementTicksToFullHeight Property
BandTickStyle::IncrementTicksToFullHeight Property
Collapse All

Gets or sets the boolean value that indicates whether to draw the tick at the full band height.

C#
public bool IncrementTicksToFullHeight;
Visual Basic
Public Property IncrementTicksToFullHeight() As bool
Links
BandTickStyle Class, BandTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandTickStyle::SmallTicksAtBottomSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties > BandTickStyle::SmallTicksAtBottomSize Property
BandTickStyle::SmallTicksAtBottomSize Property
Collapse All

Gets or sets the height, in drawing units, of small ticks located at the bottom of the data band.

C#
public double SmallTicksAtBottomSize;
Visual Basic
Public Property SmallTicksAtBottomSize() As double
Links
BandTickStyle Class, BandTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandTickStyle::SmallTicksAtMiddleSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties > BandTickStyle::SmallTicksAtMiddleSize Property
BandTickStyle::SmallTicksAtMiddleSize Property
Collapse All

Gets or sets the height, in drawing units, of small ticks located at the middle of the data band.

C#
public double SmallTicksAtMiddleSize;
Visual Basic
Public Property SmallTicksAtMiddleSize() As double
Links
BandTickStyle Class, BandTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BandTickStyle::SmallTicksAtTopSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties > BandTickStyle::SmallTicksAtTopSize Property
BandTickStyle::SmallTicksAtTopSize Property
Collapse All

Gets or sets the height, in drawing units, of small ticks located at the top of the data band.

C#
public double SmallTicksAtTopSize;
Visual Basic
Public Property SmallTicksAtTopSize() As double
Links
BandTickStyle Class, BandTickStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BaseLabelSetItem Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class
BaseLabelSetItem Class
Collapse All

The base class for alignment label set items.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetItem
C#
public class BaseLabelSetItem : CivilWrapper<AeccDbAlignStnLabelsDlgTemplate>;
Visual Basic
Public Class BaseLabelSetItem
Inherits CivilWrapper<AeccDbAlignStnLabelsDlgTemplate>
Links
BaseLabelSetItem Properties, BaseLabelSetItem Members, Class Hierarchy


BaseLabelSetItem Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class > BaseLabelSetItem Members
BaseLabelSetItem Members
Collapse All

The following tables list the members exposed by BaseLabelSetItem.

Public Properties
Public Property | Description
LabelStyleId | Gets or Sets the label style object id in the current label set item.
LabelStyleName | Gets or Sets the label style name in the current label set item.
LabelStyleType | Gets the label type in the current label set item.
Links
Public Properties


BaseLabelSetItem Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class > BaseLabelSetItem Properties
BaseLabelSetItem Properties
Collapse All

The properties of BaseLabelSetItem are listed here.

Public Properties
Public Property | Description
LabelStyleId | Gets or Sets the label style object id in the current label set item.
LabelStyleName | Gets or Sets the label style name in the current label set item.
LabelStyleType | Gets the label type in the current label set item.
Links
Public Properties


BaseLabelSetItem::LabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class > BaseLabelSetItem Properties > BaseLabelSetItem::LabelStyleId Property
BaseLabelSetItem::LabelStyleId Property
Collapse All

Gets or Sets the label style object id in the current label set item.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LabelStyleId;
Visual Basic
Public Property LabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle.

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input style type is not Autodesk.Civil.DatabaseServices.Styles.LabelStyle.
  2. The input label style type does not match the return value of property LabelStyleType.

Links
BaseLabelSetItem Class, BaseLabelSetItem Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BaseLabelSetItem::LabelStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class > BaseLabelSetItem Properties > BaseLabelSetItem::LabelStyleName Property
BaseLabelSetItem::LabelStyleName Property
Collapse All

Gets or Sets the label style name in the current label set item.

C#
public System::String LabelStyleName;
Visual Basic
Public Property LabelStyleName() As System::String
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The label style name is invalid.
  2. The label style type does not match the return value of property LabelStyleType.

Links
BaseLabelSetItem Class, BaseLabelSetItem Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BaseLabelSetItem::LabelStyleType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class > BaseLabelSetItem Properties > BaseLabelSetItem::LabelStyleType Property
BaseLabelSetItem::LabelStyleType Property
Collapse All

Gets the label type in the current label set item.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleType LabelStyleType;
Visual Basic
Public Property LabelStyleType() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleType
Links
BaseLabelSetItem Class, BaseLabelSetItem Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BaseLabelSetStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class
BaseLabelSetStyle Class
Collapse All

The base class for alignment label set styles.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileLabelSetStyle
C#
public class BaseLabelSetStyle : StyleBase;
Visual Basic
Public Class BaseLabelSetStyle
Inherits StyleBase
Links
BaseLabelSetStyle Methods, BaseLabelSetStyle Properties, BaseLabelSetStyle Members, Class Hierarchy


BaseLabelSetStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Members
BaseLabelSetStyle Members
Collapse All

The following tables list the members exposed by BaseLabelSetStyle.

Public Methods
Public Method | Description
Add | Overloaded
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
RemoveAt | Removes an label set item from the collection.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the number of label set items.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


BaseLabelSetStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Methods
BaseLabelSetStyle Methods
Collapse All

The methods of BaseLabelSetStyle are listed here.

Public Methods
Public Method | Description
Add | Overloaded
RemoveAt | Removes an label set item from the collection.
Links
Public Methods


Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Methods > Add Method
Add Method
Collapse All

Overloaded

Overload List
Method | Description
BaseLabelSetStyle::Add (Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a label set item with the given object id, adds it to the collection.
BaseLabelSetStyle::Add (BaseLabelSetItem^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a minor label set item with the an major station label set item and an minor station label style... more
BaseLabelSetStyle::Add (BaseLabelSetItem^, System::String^) | Creates a minor label set item with the an major station label set item and an minior lable style name,... more
BaseLabelSetStyle::Add (LabelStyleType, System::String^) | Creates a label set item with the given lable style type and name, adds it to the collection.


BaseLabelSetStyle::Add Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Methods > Add Method > BaseLabelSetStyle::Add Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
BaseLabelSetStyle::Add Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a label set item with the given object id, adds it to the collection.

C#
public Add(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Sub Add(
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
labelStyleId | The object id of label style.
Remarks
  1. Use the alignment related label style types in the AlignmentLabelSetStyle class.
  2. Use the profile related label style types in the ProfileLabelSetStyle class.
  3. Use the section related label style types in the SectionLabelSetStyle class.
  4. Cannot be used with these label style types: Autodesk.Civil.DatabaseServices.LabelType.AlignmentMinorStation, ProfileMinorStation, and SectionMinorOffset.

User can use the methods AddSagCurve/AddCrestCurve in the ProfileLabelSetStyle to add a profile curve label style.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when: 1: the type of input labelStyleId is ProfileCurve. 2: the type of input label style type is invalid.
Links
BaseLabelSetStyle Class, BaseLabelSetStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BaseLabelSetStyle::Add Method (BaseLabelSetItem^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Methods > Add Method > BaseLabelSetStyle::Add Method (BaseLabelSetItem^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
BaseLabelSetStyle::Add Method (BaseLabelSetItem^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a minor label set item with the an major station label set item and an minor station label style id, adds it to the collection.

C#
public Add(
    ref BaseLabelSetItem majorStation,
    Autodesk::AutoCAD::DatabaseServices::ObjectId minorStationLabelStyleId
);
Visual Basic
Public Sub Add(
    ByRef majorStation As BaseLabelSetItem,
    minorStationLabelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
majorStation | An label set itm withe a major station label style type.
minorStationLabelStyleId | The object id of label style.
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The label style type of the label set item is not Autodesk.Civil.DatabaseServices.LabelType.AlignmentMajorStation, ProfileMajorStation, or SectionMajorOffset.
  2. The type of input label style is not Autodesk.Civil.DatabaseServices.LabelType.AlignmentMinorStation, ProfileMinorStation, or SectionMinorOffset.

Links
BaseLabelSetStyle Class, BaseLabelSetStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BaseLabelSetStyle::Add Method (BaseLabelSetItem^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Methods > Add Method > BaseLabelSetStyle::Add Method (BaseLabelSetItem^, System::String^)
BaseLabelSetStyle::Add Method (BaseLabelSetItem^, System::String^)
Collapse All

Creates a minor label set item with the an major station label set item and an minior lable style name, adds it to the collection.

C#
public Add(
    ref BaseLabelSetItem majorStation,
    ref System::String minorStationLabelStyleName
);
Visual Basic
Public Sub Add(
    ByRef majorStation As BaseLabelSetItem,
    ByRef minorStationLabelStyleName As System::String
)
Parameters
Parameters | Description
majorStation | An label set itm withe a major station label style type.
minorStationLabelStyleName | The name of the label style with a type of minor station.
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The label style type of the label set item is not Autodesk.Civil.DatabaseServices.LabelType.AlignmentMajorStation, ProfileMajorStation, or SectionMajorOffset.
  2. The type of input label style is not Autodesk.Civil.DatabaseServices.LabelType.AlignmentMinorStation, ProfileMinorStation, or SectionMinorOffset.

Links
BaseLabelSetStyle Class, BaseLabelSetStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BaseLabelSetStyle::Add Method (LabelStyleType, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Methods > Add Method > BaseLabelSetStyle::Add Method (LabelStyleType, System::String^)
BaseLabelSetStyle::Add Method (LabelStyleType, System::String^)
Collapse All

Creates a label set item with the given lable style type and name, adds it to the collection.

C#
public Add(
    LabelStyleType labelStyleType,
    ref System::String labelStyleName
);
Visual Basic
Public Sub Add(
    labelStyleType As LabelStyleType,
    ByRef labelStyleName As System::String
)
Parameters
Parameters | Description
labelStyleType | The type of label style.
labelStyleName | The name of label style.
Remarks
  1. Use the alignment related label style types in the AlignmentLabelSetStyle class.
  2. Use the profile related label style types except ProfileCurve in the ProfileLabelSetStyle class.
  3. Use the section related label style types in the SectionLabelSetStyle class.
  4. Cannot be used with these label style types: Autodesk.Civil.DatabaseServices.LabelType.AlignmentMinorStation, ProfileMinorStation, and SectionMinorOffset.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the type of input label style type is invalid.
Links
BaseLabelSetStyle Class, BaseLabelSetStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BaseLabelSetStyle::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Methods > BaseLabelSetStyle::RemoveAt Method
BaseLabelSetStyle::RemoveAt Method
Collapse All

Removes an label set item from the collection.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Specified the label set item by index.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the collection's range.
Links
BaseLabelSetStyle Class, BaseLabelSetStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


BaseLabelSetStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Properties
BaseLabelSetStyle Properties
Collapse All

The properties of BaseLabelSetStyle are listed here.

Public Properties
Public Property | Description
Count | Gets the number of label set items.
Links
Public Properties


BaseLabelSetStyle::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Properties > BaseLabelSetStyle::Count Property
BaseLabelSetStyle::Count Property
Collapse All

Gets the number of label set items.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
BaseLabelSetStyle Class, BaseLabelSetStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class
ColumnStyle Class
Collapse All

Defines column width and value properties for table style objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ColumnStyle
    Autodesk::Civil::DatabaseServices::Styles::SegmentColumnStyle
    Autodesk::Civil::DatabaseServices::Styles::StructureColumnStyle
C#
public class ColumnStyle : CivilWrapper<AeccDbScheduleTableStyle>;
Visual Basic
Public Class ColumnStyle
Inherits CivilWrapper<AeccDbScheduleTableStyle>
Links
ColumnStyle Properties, ColumnStyle Members, Class Hierarchy


ColumnStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Members
ColumnStyle Members
Collapse All

The following tables list the members exposed by ColumnStyle.

Public Properties
Public Property | Description
ColumnWidth | Gets or sets the column width of the column style, 0 represents auto width.
ContentJustification | Gets or sets the Content Justification of column style.
ContentString | Gets the display content of column style, this property is usable for most table columns, but for alignment segment table,... more
ContentStringFormatted | Gets the formatted content of column style, this property is usable for most table columns, but for alignment segment table,... more
HeaderJustification | Gets or sets the Header Justification of column style
HeaderString | Gets or sets the display header string of the column style.
HeaderStringFormatted | Gets or sets the formatted header string of the column style.
Links
Public Properties


ColumnStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties
ColumnStyle Properties
Collapse All

The properties of ColumnStyle are listed here.

Public Properties
Public Property | Description
ColumnWidth | Gets or sets the column width of the column style, 0 represents auto width.
ContentJustification | Gets or sets the Content Justification of column style.
ContentString | Gets the display content of column style, this property is usable for most table columns, but for alignment segment table,... more
ContentStringFormatted | Gets the formatted content of column style, this property is usable for most table columns, but for alignment segment table,... more
HeaderJustification | Gets or sets the Header Justification of column style
HeaderString | Gets or sets the display header string of the column style.
HeaderStringFormatted | Gets or sets the formatted header string of the column style.
Links
Public Properties


ColumnStyle::ColumnWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties > ColumnStyle::ColumnWidth Property
ColumnStyle::ColumnWidth Property
Collapse All

Gets or sets the column width of the column style, 0 represents auto width.

C#
public double ColumnWidth;
Visual Basic
Public Property ColumnWidth() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when new value is less than zero.
Links
ColumnStyle Class, ColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyle::ContentJustification Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties > ColumnStyle::ContentJustification Property
ColumnStyle::ContentJustification Property
Collapse All

Gets or sets the Content Justification of column style.

C#
public TextJustificationType ContentJustification;
Visual Basic
Public Property ContentJustification() As TextJustificationType
Links
ColumnStyle Class, ColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyle::ContentString Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties > ColumnStyle::ContentString Property
ColumnStyle::ContentString Property
Collapse All

Gets the display content of column style, this property is usable for most table columns, but for alignment segment table, please use GetContentString() and specified type.

C#
public System::String ContentString;
Visual Basic
Public Property ContentString() As System::String
Remarks

Invalid property for the SegmentColumnStyle and StructureColumnStyle.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the column is obstained from a alignment segment table style or parcel segment table style or structure table style.
Links
ColumnStyle Class, ColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyle::ContentStringFormatted Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties > ColumnStyle::ContentStringFormatted Property
ColumnStyle::ContentStringFormatted Property
Collapse All

Gets the formatted content of column style, this property is usable for most table columns, but for alignment segment table, please use GetContentString() and specified type.

C#
public System::String ContentStringFormatted;
Visual Basic
Public Property ContentStringFormatted() As System::String
Remarks

Invalid property for the SegmentColumnStyle and StructureColumnStyle.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the column is obstained from a alignment segment table style or parcel segment table style or structure table style.
Links
ColumnStyle Class, ColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyle::HeaderJustification Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties > ColumnStyle::HeaderJustification Property
ColumnStyle::HeaderJustification Property
Collapse All

Gets or sets the Header Justification of column style

C#
public TextJustificationType HeaderJustification;
Visual Basic
Public Property HeaderJustification() As TextJustificationType
Links
ColumnStyle Class, ColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyle::HeaderString Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties > ColumnStyle::HeaderString Property
ColumnStyle::HeaderString Property
Collapse All

Gets or sets the display header string of the column style.

C#
public System::String HeaderString;
Visual Basic
Public Property HeaderString() As System::String
Links
ColumnStyle Class, ColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyle::HeaderStringFormatted Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties > ColumnStyle::HeaderStringFormatted Property
ColumnStyle::HeaderStringFormatted Property
Collapse All

Gets or sets the formatted header string of the column style.

C#
public System::String HeaderStringFormatted;
Visual Basic
Public Property HeaderStringFormatted() As System::String
Links
ColumnStyle Class, ColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class
ColumnStyleCollection Class
Collapse All

A collection of ColumnStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ColumnStyleCollection
C#
public class ColumnStyleCollection : Autodesk::Civil::CivilWrapper<AeccDbScheduleTableStyle>, System::Collections::Generic::IEnumerable<ColumnStyle^>;
Visual Basic
Public Class ColumnStyleCollection
Inherits Autodesk::Civil::CivilWrapper<AeccDbScheduleTableStyle>
Inherits System::Collections::Generic::IEnumerable<ColumnStyle^>
Links
ColumnStyleCollection Methods, ColumnStyleCollection Properties, ColumnStyleCollection Members, Class Hierarchy


ColumnStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Members
ColumnStyleCollection Members
Collapse All

The following tables list the members exposed by ColumnStyleCollection.

Public Methods
Public Method | Description
Add | Adds a ColumnStyle to the collection using column width and value, 0 width for auto width.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes column style by index in the collection, the first column of the collection cannot be removed.
Public Properties
Public Property | Description
Count | Gets the number of column styles in the collection.
default | Gets the column style at a specified index in the collection.
Links
Public Methods, Public Properties


ColumnStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Methods
ColumnStyleCollection Methods
Collapse All

The methods of ColumnStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a ColumnStyle to the collection using column width and value, 0 width for auto width.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes column style by index in the collection, the first column of the collection cannot be removed.
Links
Public Methods


ColumnStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Methods > ColumnStyleCollection::Add Method
ColumnStyleCollection::Add Method
Collapse All

Adds a ColumnStyle to the collection using column width and value, 0 width for auto width.

C#
public Add();
Visual Basic
Public Sub Add()
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when columnWidth is smaller than 0.
Links
ColumnStyleCollection Class, ColumnStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyleCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Methods > ColumnStyleCollection::GetEnumerator Method
ColumnStyleCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<ColumnStyle^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<ColumnStyle^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
ColumnStyleCollection Class, ColumnStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyleCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Methods > ColumnStyleCollection::GetObjectEnumerator Method
ColumnStyleCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ColumnStyleCollection Class, ColumnStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyleCollection::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Methods > ColumnStyleCollection::RemoveAt Method
ColumnStyleCollection::RemoveAt Method
Collapse All

Removes column style by index in the collection, the first column of the collection cannot be removed.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Index of the column style to remove.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when index is less than 1, or when index is greater than or equal to collection count.
Links
ColumnStyleCollection Class, ColumnStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyleCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Properties
ColumnStyleCollection Properties
Collapse All

The properties of ColumnStyleCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of column styles in the collection.
default | Gets the column style at a specified index in the collection.
Links
Public Properties


ColumnStyleCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Properties > ColumnStyleCollection::Count Property
ColumnStyleCollection::Count Property
Collapse All

Gets the number of column styles in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ColumnStyleCollection Class, ColumnStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ColumnStyleCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Properties > ColumnStyleCollection::default Property
ColumnStyleCollection::default Property
Collapse All

Gets the column style at a specified index in the collection.

C#
public ColumnStyle default;
Visual Basic
Public Property default() As ColumnStyle
Parameters
Parameters | Description
Index | column style index.
Links
ColumnStyleCollection Class, ColumnStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


Expression Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class
Expression Class
Collapse All

Encapsulates an expression used in label styles.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::Expression
C#
public class Expression;
Visual Basic
Public Class Expression
Links
Expression Properties, Expression Members, Class Hierarchy


Expression Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Members
Expression Members
Collapse All

The following tables list the members exposed by Expression.

Public Properties
Public Property | Description
Description | Gets and sets the description of the Expression.
ExpressionString | Gets or sets the expression string of the Expression.
FormatResultAs | Gets or sets the format type of the expression result.
Name | Gets the name of the Expression.
Links
Public Properties


Expression Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Properties
Expression Properties
Collapse All

The properties of Expression are listed here.

Public Properties
Public Property | Description
Description | Gets and sets the description of the Expression.
ExpressionString | Gets or sets the expression string of the Expression.
FormatResultAs | Gets or sets the format type of the expression result.
Name | Gets the name of the Expression.
Links
Public Properties


Expression::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Properties > Expression::Description Property
Expression::Description Property
Collapse All

Gets and sets the description of the Expression.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
Expression Class, Expression Members, Autodesk::Civil::DatabaseServices::Styles Namespace


Expression::ExpressionString Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Properties > Expression::ExpressionString Property
Expression::ExpressionString Property
Collapse All

Gets or sets the expression string of the Expression.

C#
public System::String ExpressionString;
Visual Basic
Public Property ExpressionString() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the the input expression is null, blank, or includes unknown properties.
Links
Expression Class, Expression Members, Autodesk::Civil::DatabaseServices::Styles Namespace


Expression::FormatResultAs Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Properties > Expression::FormatResultAs Property
Expression::FormatResultAs Property
Collapse All

Gets or sets the format type of the expression result.

C#
public ExpressionFormatedType FormatResultAs;
Visual Basic
Public Property FormatResultAs() As ExpressionFormatedType
Links
Expression Class, Expression Members, Autodesk::Civil::DatabaseServices::Styles Namespace


Expression::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Properties > Expression::Name Property
Expression::Name Property
Collapse All

Gets the name of the Expression.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
Expression Class, Expression Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ExpressionCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class
ExpressionCollection Class
Collapse All

A collection of Expression objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ExpressionCollection
C#
public class ExpressionCollection : IEnumerable<Expression^>;
Visual Basic
Public Class ExpressionCollection
Inherits IEnumerable<Expression^>
Links
ExpressionCollection Methods, ExpressionCollection Properties, ExpressionCollection Members, Class Hierarchy


ExpressionCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Members
ExpressionCollection Members
Collapse All

The following tables list the members exposed by ExpressionCollection.

Public Methods
Public Method | Description
Add | Adds a Expression by specifying the name and expression string.
Clear | Removes all Expressions from the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an Expression from the collection by the specified index.
Public Properties
Public Property | Description
Count | Gets the number of Expression objects in the collection.
default | Gets the Expression at a specified index in the collection.
Links
Public Methods, Public Properties


ExpressionCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Methods
ExpressionCollection Methods
Collapse All

The methods of ExpressionCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a Expression by specifying the name and expression string.
Clear | Removes all Expressions from the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an Expression from the collection by the specified index.
Links
Public Methods


ExpressionCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Methods > ExpressionCollection::Add Method
ExpressionCollection::Add Method
Collapse All

Adds a Expression by specifying the name and expression string.

C#
public Expression Add(
    ref System::String name,
    ref System::String description,
    ref System::String expression
);
Visual Basic
Public Function Add(
    ByRef name As System::String,
    ByRef description As System::String,
    ByRef expression As System::String
) As Expression
Parameters
Parameters | Description
name | The name of Expression.
description | The description of Expression.
expression | The expression string of Expression.
Exceptions
Exceptions | Description
System::ArgumentException | Throw when the expression is not valid.
Links
ExpressionCollection Class, ExpressionCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ExpressionCollection::Clear Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Methods > ExpressionCollection::Clear Method
ExpressionCollection::Clear Method
Collapse All

Removes all Expressions from the collection.

C#
public Clear();
Visual Basic
Public Sub Clear()
Remarks

This will remove all Expression objects in AlignmentExpressionSet or ProfileExpressionSet.

Links
ExpressionCollection Class, ExpressionCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ExpressionCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Methods > ExpressionCollection::GetEnumerator Method
ExpressionCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<Expression^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<Expression^>
Returns

An enumerator which implements the IEnumerator interface.

Links
ExpressionCollection Class, ExpressionCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ExpressionCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Methods > ExpressionCollection::GetObjectEnumerator Method
ExpressionCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ExpressionCollection Class, ExpressionCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ExpressionCollection::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Methods > ExpressionCollection::RemoveAt Method
ExpressionCollection::RemoveAt Method
Collapse All

Removes an Expression from the collection by the specified index.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Specifies index in the collection to remove.
Remarks

Removes the corresponding Expression from AlignmentExpressionSet or ProfileExpressionSet.

Links
ExpressionCollection Class, ExpressionCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ExpressionCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Properties
ExpressionCollection Properties
Collapse All

The properties of ExpressionCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of Expression objects in the collection.
default | Gets the Expression at a specified index in the collection.
Links
Public Properties


ExpressionCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Properties > ExpressionCollection::Count Property
ExpressionCollection::Count Property
Collapse All

Gets the number of Expression objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ExpressionCollection Class, ExpressionCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ExpressionCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Properties > ExpressionCollection::default Property
ExpressionCollection::default Property
Collapse All

Gets the Expression at a specified index in the collection.

C#
public Expression default;
Visual Basic
Public Property default() As Expression
Parameters
Parameters | Description
index | Expression index.
Links
ExpressionCollection Class, ExpressionCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class
FeatureLineStyle Class
Collapse All

Specifies default display and other characteristics for feature line features when they are created.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFeatureLineStyle"))]
public class FeatureLineStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFeatureLineStyle"))>
Public Class FeatureLineStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
FeatureLineStyle Methods, FeatureLineStyle Properties, FeatureLineStyle Members, Class Hierarchy


FeatureLineStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Members
FeatureLineStyle Members
Collapse All

The following tables list the members exposed by FeatureLineStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the FeatureLine component.
GetFeatureLineDisplayStyleModel | Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.
GetFeatureLineDisplayStylePlan | Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.
GetSectionMarkerDisplayStyleSection | Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
FeatureLineDisplayStyleModel | Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.
FeatureLineDisplayStylePlan | Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ProfileBeginningVertexMarkerStyleId | Gets or sets the object id of the profile beginning vertex marker style for the feature line style.
ProfileBeginningVertexMarkerStyleName | Gets or sets the name of the profile beginning vertex marker style for the feature line style.
ProfileEndingVertexMarkerStyleId | Gets or sets the object id of the profile ending vertex marker style for the feature line style.
ProfileEndingVertexMarkerStyleName | Gets or sets the name of the profile ending vertex marker style for the feature line style.
ProfileInternalVertexMarkerStyleId | Gets or sets the object id of the profile internal vertex marker style for the feature line style.
ProfileInternalVertexMarkerStyleName | Gets or sets the name of the profile internal vertex marker style for the feature line style.
SectionMarkerDisplayStyleSection | Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.
SectionMarkerStyleId | Gets or sets the object id of the marker style for the feature line style.
SectionMarkerStyleName | Gets or sets the name of the marker style for the feature line style.
Links
Public Methods, Public Properties


FeatureLineStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Methods
FeatureLineStyle Methods
Collapse All

The methods of FeatureLineStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the FeatureLine component.
GetFeatureLineDisplayStyleModel | Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.
GetFeatureLineDisplayStylePlan | Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.
GetSectionMarkerDisplayStyleSection | Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.
Links
Public Methods


FeatureLineStyle::GetDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Methods > FeatureLineStyle::GetDisplayStyleProfile Method
FeatureLineStyle::GetDisplayStyleProfile Method
Collapse All

Gets the DisplayStyle object that specifies profile display properties for the FeatureLine component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleProfile(
    FeatureLineDisplayStyleProfileType type
);
Visual Basic
Public Function GetDisplayStyleProfile(
    type As FeatureLineDisplayStyleProfileType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::GetFeatureLineDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Methods > FeatureLineStyle::GetFeatureLineDisplayStyleModel Method
FeatureLineStyle::GetFeatureLineDisplayStyleModel Method
Collapse All

Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetFeatureLineDisplayStyleModel();
Visual Basic
Public Function GetFeatureLineDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::GetFeatureLineDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Methods > FeatureLineStyle::GetFeatureLineDisplayStylePlan Method
FeatureLineStyle::GetFeatureLineDisplayStylePlan Method
Collapse All

Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetFeatureLineDisplayStylePlan();
Visual Basic
Public Function GetFeatureLineDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::GetSectionMarkerDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Methods > FeatureLineStyle::GetSectionMarkerDisplayStyleSection Method
FeatureLineStyle::GetSectionMarkerDisplayStyleSection Method
Collapse All

Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetSectionMarkerDisplayStyleSection();
Visual Basic
Public Function GetSectionMarkerDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties
FeatureLineStyle Properties
Collapse All

The properties of FeatureLineStyle are listed here.

Public Properties
Public Property | Description
FeatureLineDisplayStyleModel | Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.
FeatureLineDisplayStylePlan | Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.
ProfileBeginningVertexMarkerStyleId | Gets or sets the object id of the profile beginning vertex marker style for the feature line style.
ProfileBeginningVertexMarkerStyleName | Gets or sets the name of the profile beginning vertex marker style for the feature line style.
ProfileEndingVertexMarkerStyleId | Gets or sets the object id of the profile ending vertex marker style for the feature line style.
ProfileEndingVertexMarkerStyleName | Gets or sets the name of the profile ending vertex marker style for the feature line style.
ProfileInternalVertexMarkerStyleId | Gets or sets the object id of the profile internal vertex marker style for the feature line style.
ProfileInternalVertexMarkerStyleName | Gets or sets the name of the profile internal vertex marker style for the feature line style.
SectionMarkerDisplayStyleSection | Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.
SectionMarkerStyleId | Gets or sets the object id of the marker style for the feature line style.
SectionMarkerStyleName | Gets or sets the name of the marker style for the feature line style.
Links
Public Properties


FeatureLineStyle::FeatureLineDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::FeatureLineDisplayStyleModel Property
FeatureLineStyle::FeatureLineDisplayStyleModel Property deprecated
Collapse All

Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle FeatureLineDisplayStyleModel;
Visual Basic
Public Property FeatureLineDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.FeatureLineStyle.GetFeatureLineDisplayStyleModel instead.

Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::FeatureLineDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::FeatureLineDisplayStylePlan Property
FeatureLineStyle::FeatureLineDisplayStylePlan Property deprecated
Collapse All

Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle FeatureLineDisplayStylePlan;
Visual Basic
Public Property FeatureLineDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.FeatureLineStyle.GetFeatureLineDisplayStylePlan instead.

Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::ProfileBeginningVertexMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::ProfileBeginningVertexMarkerStyleId Property
FeatureLineStyle::ProfileBeginningVertexMarkerStyleId Property
Collapse All

Gets or sets the object id of the profile beginning vertex marker style for the feature line style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileBeginningVertexMarkerStyleId;
Visual Basic
Public Property ProfileBeginningVertexMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.MarkerStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not MarkStyle.
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::ProfileBeginningVertexMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::ProfileBeginningVertexMarkerStyleName Property
FeatureLineStyle::ProfileBeginningVertexMarkerStyleName Property
Collapse All

Gets or sets the name of the profile beginning vertex marker style for the feature line style.

C#
public System::String ProfileBeginningVertexMarkerStyleName;
Visual Basic
Public Property ProfileBeginningVertexMarkerStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name that a MarkStyle of this name is not exist.
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::ProfileEndingVertexMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::ProfileEndingVertexMarkerStyleId Property
FeatureLineStyle::ProfileEndingVertexMarkerStyleId Property
Collapse All

Gets or sets the object id of the profile ending vertex marker style for the feature line style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileEndingVertexMarkerStyleId;
Visual Basic
Public Property ProfileEndingVertexMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.MarkerStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not MarkStyle.
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::ProfileEndingVertexMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::ProfileEndingVertexMarkerStyleName Property
FeatureLineStyle::ProfileEndingVertexMarkerStyleName Property
Collapse All

Gets or sets the name of the profile ending vertex marker style for the feature line style.

C#
public System::String ProfileEndingVertexMarkerStyleName;
Visual Basic
Public Property ProfileEndingVertexMarkerStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name that a MarkStyle of this name is not exist.
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::ProfileInternalVertexMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::ProfileInternalVertexMarkerStyleId Property
FeatureLineStyle::ProfileInternalVertexMarkerStyleId Property
Collapse All

Gets or sets the object id of the profile internal vertex marker style for the feature line style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileInternalVertexMarkerStyleId;
Visual Basic
Public Property ProfileInternalVertexMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.MarkerStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not MarkStyle.
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::ProfileInternalVertexMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::ProfileInternalVertexMarkerStyleName Property
FeatureLineStyle::ProfileInternalVertexMarkerStyleName Property
Collapse All

Gets or sets the name of the profile internal vertex marker style for the feature line style.

C#
public System::String ProfileInternalVertexMarkerStyleName;
Visual Basic
Public Property ProfileInternalVertexMarkerStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name that a MarkStyle of this name is not exist.
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::SectionMarkerDisplayStyleSection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::SectionMarkerDisplayStyleSection Property
FeatureLineStyle::SectionMarkerDisplayStyleSection Property deprecated
Collapse All

Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle SectionMarkerDisplayStyleSection;
Visual Basic
Public Property SectionMarkerDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.FeatureLineStyle.GetSectionMarkerDisplayStyleSection instead.

Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::SectionMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::SectionMarkerStyleId Property
FeatureLineStyle::SectionMarkerStyleId Property
Collapse All

Gets or sets the object id of the marker style for the feature line style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SectionMarkerStyleId;
Visual Basic
Public Property SectionMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.MarkerStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not MarkStyle.
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyle::SectionMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties > FeatureLineStyle::SectionMarkerStyleName Property
FeatureLineStyle::SectionMarkerStyleName Property
Collapse All

Gets or sets the name of the marker style for the feature line style.

C#
public System::String SectionMarkerStyleName;
Visual Basic
Public Property SectionMarkerStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name that a MarkStyle of this name is not exist.
Links
FeatureLineStyle Class, FeatureLineStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


FeatureLineStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class
FeatureLineStyleCollection Class
Collapse All

A collection of FeatureLineStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyleCollection
C#
public class FeatureLineStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class FeatureLineStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
FeatureLineStyleCollection Methods, FeatureLineStyleCollection Members, Class Hierarchy


FeatureLineStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class > FeatureLineStyleCollection Members
FeatureLineStyleCollection Members
Collapse All

The following tables list the members exposed by FeatureLineStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


FeatureLineStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class > FeatureLineStyleCollection Methods
FeatureLineStyleCollection Methods
Collapse All

The methods of FeatureLineStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


FeatureLineStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class > FeatureLineStyleCollection Methods > FeatureLineStyleCollection::Add Method
FeatureLineStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
FeatureLineStyleCollection Class, FeatureLineStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class
GraphStyle Class
Collapse All

Specifies format and contents of the title, vertical exaggeration, and grid options for graphs.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::GraphStyle
C#
public class GraphStyle : CivilWrapper<AeccDbGraphStyle>;
Visual Basic
Public Class GraphStyle
Inherits CivilWrapper<AeccDbGraphStyle>
Links
GraphStyle Properties, GraphStyle Members, Class Hierarchy


GraphStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Members
GraphStyle Members
Collapse All

The following tables list the members exposed by GraphStyle.

Public Properties
Public Property | Description
CurrentHorizontalScale | Gets the plotted size of graph horizontal scale from draw setting.
Direction | Gets or sets the direction of the profile in the profile view grid.
TitleStyle | Gets the style object that specifies graph title text display properties for cross section and profile views.
VerticalExaggeration | Gets or sets the graph vertical exaggeration factor.
VerticalScale | Gets or sets the vertical scale of the profile view or section view.
Links
Public Properties


GraphStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Properties
GraphStyle Properties
Collapse All

The properties of GraphStyle are listed here.

Public Properties
Public Property | Description
CurrentHorizontalScale | Gets the plotted size of graph horizontal scale from draw setting.
Direction | Gets or sets the direction of the profile in the profile view grid.
TitleStyle | Gets the style object that specifies graph title text display properties for cross section and profile views.
VerticalExaggeration | Gets or sets the graph vertical exaggeration factor.
VerticalScale | Gets or sets the vertical scale of the profile view or section view.
Links
Public Properties


GraphStyle::CurrentHorizontalScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Properties > GraphStyle::CurrentHorizontalScale Property
GraphStyle::CurrentHorizontalScale Property
Collapse All

Gets the plotted size of graph horizontal scale from draw setting.

C#
public double CurrentHorizontalScale;
Visual Basic
Public Property CurrentHorizontalScale() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the GraphStyle is obtained from a MassHaulViewStyle.
Links
GraphStyle Class, GraphStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphStyle::Direction Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Properties > GraphStyle::Direction Property
GraphStyle::Direction Property
Collapse All

Gets or sets the direction of the profile in the profile view grid.

C#
public GraphDirectionType Direction;
Visual Basic
Public Property Direction() As GraphDirectionType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the GraphStyle is obtained from a SectionViewStyle.
Links
GraphStyle Class, GraphStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphStyle::TitleStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Properties > GraphStyle::TitleStyle Property
GraphStyle::TitleStyle Property
Collapse All

Gets the style object that specifies graph title text display properties for cross section and profile views.

C#
public GraphTitleStyle TitleStyle;
Visual Basic
Public Property TitleStyle() As GraphTitleStyle
Links
GraphStyle Class, GraphStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphStyle::VerticalExaggeration Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Properties > GraphStyle::VerticalExaggeration Property
GraphStyle::VerticalExaggeration Property
Collapse All

Gets or sets the graph vertical exaggeration factor.

C#
public double VerticalExaggeration;
Visual Basic
Public Property VerticalExaggeration() As double
Remarks

The Current Horizontal Scale (HS) factor of the drawing is divided by the Vertical Scale value (VS) to obtain the profile view Vertical Exaggeration value (VX). The Vertical Scale value is calculated automatically after the VerticalExaggeration change. The value of VerticalScale will be invalid when

  1. The input value is out of the interval (0.00, 2000.00) in meteres drawing units.
  2. The input value is out of the interval (0.00, 6561.6797900262467191601049868766) in feet drawing units.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is less than or equal to 0.0;
Links
GraphStyle Class, GraphStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphStyle::VerticalScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Properties > GraphStyle::VerticalScale Property
GraphStyle::VerticalScale Property
Collapse All

Gets or sets the vertical scale of the profile view or section view.

C#
public double VerticalScale;
Visual Basic
Public Property VerticalScale() As double
Remarks

Vertical Scale (VS) = Current Horizontal Scale (HS) divided by Vertical Exaggeration (VX). The value of VerticalScale will be invalid when

  1. The input value is out of the interval (0.00, 2000.00) in meteres drawing units.
  2. The input value is out of the interval (0.00, 6561.6797900262467191601049868766) in feet drawing units.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input is less than or equal to 0.00
System.InvalidOperationException | Thrown when the GraphStyle is obtained from a MassHaulViewStyle.
Links
GraphStyle Class, GraphStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphTitleStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class
GraphTitleStyle Class
Collapse All

Specifies display characteristics for profile and section view graphs.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::GraphTitleStyle
C#
public class GraphTitleStyle : CivilWrapper<AeccDbGraphStyle>;
Visual Basic
Public Class GraphTitleStyle
Inherits CivilWrapper<AeccDbGraphStyle>
Links
GraphTitleStyle Properties, GraphTitleStyle Members, Class Hierarchy


GraphTitleStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Members
GraphTitleStyle Members
Collapse All

The following tables list the members exposed by GraphTitleStyle.

Public Properties
Public Property | Description
Border | Gets or sets a bool value that specifies whether a border line is drawn around the title block.
BorderGap | Gets or sets the gap between the border and graph title text in plotted units.
Justification | Gets or sets the justification (alignment) of the title.
Location | Gets or sets the location of the title in relation to the view grid.
OffsetX | Gets or sets a horizontal offset from the position set by the Location and Justification values.
OffsetY | Gets or sets a vertical offset from the position set by Location and Justification values.
Text | Gets or sets the graph title text.
TextHeight | Gets or sets the current text height in drawing units.
TextStyle | Gets or sets the text style for the graph title from the available AutoCAD text styles defined in the current... more
Links
Public Properties


GraphTitleStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties
GraphTitleStyle Properties
Collapse All

The properties of GraphTitleStyle are listed here.

Public Properties
Public Property | Description
Border | Gets or sets a bool value that specifies whether a border line is drawn around the title block.
BorderGap | Gets or sets the gap between the border and graph title text in plotted units.
Justification | Gets or sets the justification (alignment) of the title.
Location | Gets or sets the location of the title in relation to the view grid.
OffsetX | Gets or sets a horizontal offset from the position set by the Location and Justification values.
OffsetY | Gets or sets a vertical offset from the position set by Location and Justification values.
Text | Gets or sets the graph title text.
TextHeight | Gets or sets the current text height in drawing units.
TextStyle | Gets or sets the text style for the graph title from the available AutoCAD text styles defined in the current... more
Links
Public Properties


GraphTitleStyle::Border Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties > GraphTitleStyle::Border Property
GraphTitleStyle::Border Property
Collapse All

Gets or sets a bool value that specifies whether a border line is drawn around the title block.

C#
public bool Border;
Visual Basic
Public Property Border() As bool
Links
GraphTitleStyle Class, GraphTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphTitleStyle::BorderGap Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties > GraphTitleStyle::BorderGap Property
GraphTitleStyle::BorderGap Property
Collapse All

Gets or sets the gap between the border and graph title text in plotted units.

C#
public double BorderGap;
Visual Basic
Public Property BorderGap() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.00001, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.000033333333333333333333333333333333, 32.808398950131233595800524934383] in feet drawing units.

Links
GraphTitleStyle Class, GraphTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphTitleStyle::Justification Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties > GraphTitleStyle::Justification Property
GraphTitleStyle::Justification Property
Collapse All

Gets or sets the justification (alignment) of the title.

C#
public GraphTitleJustificationType Justification;
Visual Basic
Public Property Justification() As GraphTitleJustificationType
Remarks

If Location is top or bottom, justification values are left, center, or right. If Location is right or left, justification values are top, middle, or bottom.

Links
GraphTitleStyle Class, GraphTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphTitleStyle::Location Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties > GraphTitleStyle::Location Property
GraphTitleStyle::Location Property
Collapse All

Gets or sets the location of the title in relation to the view grid.

C#
public GraphTitleLocationType Location;
Visual Basic
Public Property Location() As GraphTitleLocationType
Links
GraphTitleStyle Class, GraphTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphTitleStyle::OffsetX Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties > GraphTitleStyle::OffsetX Property
GraphTitleStyle::OffsetX Property
Collapse All

Gets or sets a horizontal offset from the position set by the Location and Justification values.

C#
public double OffsetX;
Visual Basic
Public Property OffsetX() As double
Remarks

Enter a positive number to move the title right or a negative number to move it left.

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [-10.0000, 10.0000] in meteres drawing units.
  2. The input value is out of the interval [-32.808398950131233595800524934383, 32.808398950131233595800524934383] in feet drawing units.

Links
GraphTitleStyle Class, GraphTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphTitleStyle::OffsetY Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties > GraphTitleStyle::OffsetY Property
GraphTitleStyle::OffsetY Property
Collapse All

Gets or sets a vertical offset from the position set by Location and Justification values.

C#
public double OffsetY;
Visual Basic
Public Property OffsetY() As double
Remarks

Enter a positive number to move up the title or a negative number to move it down.

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [-10.0000, 10.0000] in meteres drawing units.
  2. The input value is out of the interval [-32.808398950131233595800524934383, 32.808398950131233595800524934383] in feet drawing units.

Links
GraphTitleStyle Class, GraphTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphTitleStyle::Text Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties > GraphTitleStyle::Text Property
GraphTitleStyle::Text Property
Collapse All

Gets or sets the graph title text.

C#
public System::String Text;
Visual Basic
Public Property Text() As System::String
Links
GraphTitleStyle Class, GraphTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphTitleStyle::TextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties > GraphTitleStyle::TextHeight Property
GraphTitleStyle::TextHeight Property
Collapse All

Gets or sets the current text height in drawing units.

C#
public double TextHeight;
Visual Basic
Public Property TextHeight() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.00001, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.000033333333333333333333333333333333, 32.808398950131233595800524934383] in feet drawing units.

Links
GraphTitleStyle Class, GraphTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GraphTitleStyle::TextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties > GraphTitleStyle::TextStyle Property
GraphTitleStyle::TextStyle Property
Collapse All

Gets or sets the text style for the graph title from the available AutoCAD text styles defined in the current drawing.

C#
public System::String TextStyle;
Visual Basic
Public Property TextStyle() As System::String
Links
GraphTitleStyle Class, GraphTitleStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class
GridOptions Class
Collapse All

Specifies various grid options used by GridStyle.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::GridOptions
C#
public class GridOptions : CivilWrapper<AeccDbGraphStyle>;
Visual Basic
Public Class GridOptions
Inherits CivilWrapper<AeccDbGraphStyle>
Links
GridOptions Properties, GridOptions Members, Class Hierarchy


GridOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class > GridOptions Members
GridOptions Members
Collapse All

The following tables list the members exposed by GridOptions.

Public Properties
Public Property | Description
ClipToHighestProfile | Specifies whether vertical or horizontal profile view grid lines are drawn to the highest of all displayed profiles.
OmitGridInPaddingAreas | Specifies whether vertical or horizontal profile view grid lines are not drawn in the padding areas.
UseClipGrid | Specifies whether to clip a vertical or horizontal grid lines at a selected profile..
Links
Public Properties


GridOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class > GridOptions Properties
GridOptions Properties
Collapse All

The properties of GridOptions are listed here.

Public Properties
Public Property | Description
ClipToHighestProfile | Specifies whether vertical or horizontal profile view grid lines are drawn to the highest of all displayed profiles.
OmitGridInPaddingAreas | Specifies whether vertical or horizontal profile view grid lines are not drawn in the padding areas.
UseClipGrid | Specifies whether to clip a vertical or horizontal grid lines at a selected profile..
Links
Public Properties


GridOptions::ClipToHighestProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class > GridOptions Properties > GridOptions::ClipToHighestProfile Property
GridOptions::ClipToHighestProfile Property
Collapse All

Specifies whether vertical or horizontal profile view grid lines are drawn to the highest of all displayed profiles.

C#
public bool ClipToHighestProfile;
Visual Basic
Public Property ClipToHighestProfile() As bool
Links
GridOptions Class, GridOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridOptions::OmitGridInPaddingAreas Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class > GridOptions Properties > GridOptions::OmitGridInPaddingAreas Property
GridOptions::OmitGridInPaddingAreas Property
Collapse All

Specifies whether vertical or horizontal profile view grid lines are not drawn in the padding areas.

C#
public bool OmitGridInPaddingAreas;
Visual Basic
Public Property OmitGridInPaddingAreas() As bool
Links
GridOptions Class, GridOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridOptions::UseClipGrid Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class > GridOptions Properties > GridOptions::UseClipGrid Property
GridOptions::UseClipGrid Property
Collapse All

Specifies whether to clip a vertical or horizontal grid lines at a selected profile..

C#
public bool UseClipGrid;
Visual Basic
Public Property UseClipGrid() As bool
Remarks

If true, vertical or horizontal grid lines are drawn below the profile line, but not above. If false, grid lines are drawn for the full height of the grid.

Links
GridOptions Class, GridOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class
GridStyle Class
Collapse All

Specifies display characteristics for profile and section view graph gridlines.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::GridStyle
C#
public class GridStyle : CivilWrapper<AeccDbGraphStyle>;
Visual Basic
Public Class GridStyle
Inherits CivilWrapper<AeccDbGraphStyle>
Links
GridStyle Properties, GridStyle Members, Class Hierarchy


GridStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Members
GridStyle Members
Collapse All

The following tables list the members exposed by GridStyle.

Public Properties
Public Property | Description
AxisOffsetAbove | Gets or sets the distance to offset the axis above the vertical extent.
AxisOffsetBottom | Gets or sets the distance to offset the axis below the vertical extent.
AxisOffsetLeft | Gets or sets the distance to offset the axis to the left of the horizontal extent.
AxisOffsetRight | Gets or sets the distance to offset the horizontal axis to the right of the horizontal extent.
GridPaddingAbove | Gets or sets the number of grid blocks that the view extends above the maximum profile elevation.
GridPaddingBottom | Gets or sets the number of grid blocks that the view extends below the datum or minimum profile elevation.
GridPaddingLeft | Gets or sets the number of major grids to place before the left-most station value of the alignment.
GridPaddingRight | Gets or sets the number of major grids to place after the right-most station value of the alignment.
HorizontalGridOptions | Gets the horizontal clipping options on the profile view or section view grid.
VerticalGridOptions | Gets the vertical clipping options on the profile view or section view grid.
Links
Public Properties


GridStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties
GridStyle Properties
Collapse All

The properties of GridStyle are listed here.

Public Properties
Public Property | Description
AxisOffsetAbove | Gets or sets the distance to offset the axis above the vertical extent.
AxisOffsetBottom | Gets or sets the distance to offset the axis below the vertical extent.
AxisOffsetLeft | Gets or sets the distance to offset the axis to the left of the horizontal extent.
AxisOffsetRight | Gets or sets the distance to offset the horizontal axis to the right of the horizontal extent.
GridPaddingAbove | Gets or sets the number of grid blocks that the view extends above the maximum profile elevation.
GridPaddingBottom | Gets or sets the number of grid blocks that the view extends below the datum or minimum profile elevation.
GridPaddingLeft | Gets or sets the number of major grids to place before the left-most station value of the alignment.
GridPaddingRight | Gets or sets the number of major grids to place after the right-most station value of the alignment.
HorizontalGridOptions | Gets the horizontal clipping options on the profile view or section view grid.
VerticalGridOptions | Gets the vertical clipping options on the profile view or section view grid.
Links
Public Properties


GridStyle::AxisOffsetAbove Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::AxisOffsetAbove Property
GridStyle::AxisOffsetAbove Property
Collapse All

Gets or sets the distance to offset the axis above the vertical extent.

C#
public double AxisOffsetAbove;
Visual Basic
Public Property AxisOffsetAbove() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.0, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.0, 32.808398950131233595800524934383] in feet drawing units.

Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle::AxisOffsetBottom Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::AxisOffsetBottom Property
GridStyle::AxisOffsetBottom Property
Collapse All

Gets or sets the distance to offset the axis below the vertical extent.

C#
public double AxisOffsetBottom;
Visual Basic
Public Property AxisOffsetBottom() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.0, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.0, 32.808398950131233595800524934383] in feet drawing units.

Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle::AxisOffsetLeft Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::AxisOffsetLeft Property
GridStyle::AxisOffsetLeft Property
Collapse All

Gets or sets the distance to offset the axis to the left of the horizontal extent.

C#
public double AxisOffsetLeft;
Visual Basic
Public Property AxisOffsetLeft() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.0, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.0, 32.808398950131233595800524934383] in feet drawing units.

Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle::AxisOffsetRight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::AxisOffsetRight Property
GridStyle::AxisOffsetRight Property
Collapse All

Gets or sets the distance to offset the horizontal axis to the right of the horizontal extent.

C#
public double AxisOffsetRight;
Visual Basic
Public Property AxisOffsetRight() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.0, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.0, 32.808398950131233595800524934383] in feet drawing units.

Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle::GridPaddingAbove Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::GridPaddingAbove Property
GridStyle::GridPaddingAbove Property
Collapse All

Gets or sets the number of grid blocks that the view extends above the maximum profile elevation.

C#
public double GridPaddingAbove;
Visual Basic
Public Property GridPaddingAbove() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.0, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.0, 32.808398950131233595800524934383] in feet drawing units.

Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle::GridPaddingBottom Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::GridPaddingBottom Property
GridStyle::GridPaddingBottom Property
Collapse All

Gets or sets the number of grid blocks that the view extends below the datum or minimum profile elevation.

C#
public double GridPaddingBottom;
Visual Basic
Public Property GridPaddingBottom() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.0, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.0, 32.808398950131233595800524934383] in feet drawing units.

Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle::GridPaddingLeft Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::GridPaddingLeft Property
GridStyle::GridPaddingLeft Property
Collapse All

Gets or sets the number of major grids to place before the left-most station value of the alignment.

C#
public double GridPaddingLeft;
Visual Basic
Public Property GridPaddingLeft() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.0, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.0, 32.808398950131233595800524934383] in feet drawing units.

Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle::GridPaddingRight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::GridPaddingRight Property
GridStyle::GridPaddingRight Property
Collapse All

Gets or sets the number of major grids to place after the right-most station value of the alignment.

C#
public double GridPaddingRight;
Visual Basic
Public Property GridPaddingRight() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.0, 10.000] in meteres drawing units.
  2. The input value is out of the interval [0.0, 32.808398950131233595800524934383] in feet drawing units.

Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle::HorizontalGridOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::HorizontalGridOptions Property
GridStyle::HorizontalGridOptions Property
Collapse All

Gets the horizontal clipping options on the profile view or section view grid.

C#
public GridOptions HorizontalGridOptions;
Visual Basic
Public Property HorizontalGridOptions() As GridOptions
Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GridStyle::VerticalGridOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties > GridStyle::VerticalGridOptions Property
GridStyle::VerticalGridOptions Property
Collapse All

Gets the vertical clipping options on the profile view or section view grid.

C#
public GridOptions VerticalGridOptions;
Visual Basic
Public Property VerticalGridOptions() As GridOptions
Links
GridStyle Class, GridStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelSetStylesRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class
LabelSetStylesRoot Class
Collapse All

The root object for accessing label set style collections in the database.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelSetStylesRoot
C#
public class LabelSetStylesRoot : TreeOidWrapper;
Visual Basic
Public Class LabelSetStylesRoot
Inherits TreeOidWrapper
Links
LabelSetStylesRoot Properties, LabelSetStylesRoot Members, Class Hierarchy


LabelSetStylesRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class > LabelSetStylesRoot Members
LabelSetStylesRoot Members
Collapse All

The following tables list the members exposed by LabelSetStylesRoot.

Public Properties
Public Property | Description
AlignmentLabelSetStyles | Gets the collection of all alignment label set styles in the database.
ProfileLabelSetStyles | Gets the collection of all profile label set styles in the database.
SectionLabelSetStyles | Gets the collection of all section label set styles in the database.
Links
Public Properties


LabelSetStylesRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class > LabelSetStylesRoot Properties
LabelSetStylesRoot Properties
Collapse All

The properties of LabelSetStylesRoot are listed here.

Public Properties
Public Property | Description
AlignmentLabelSetStyles | Gets the collection of all alignment label set styles in the database.
ProfileLabelSetStyles | Gets the collection of all profile label set styles in the database.
SectionLabelSetStyles | Gets the collection of all section label set styles in the database.
Links
Public Properties


LabelSetStylesRoot::AlignmentLabelSetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class > LabelSetStylesRoot Properties > LabelSetStylesRoot::AlignmentLabelSetStyles Property
LabelSetStylesRoot::AlignmentLabelSetStyles Property
Collapse All

Gets the collection of all alignment label set styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentLabelSetStyleCollection AlignmentLabelSetStyles;
Visual Basic
Public Property AlignmentLabelSetStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentLabelSetStyleCollection
Links
LabelSetStylesRoot Class, LabelSetStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelSetStylesRoot::ProfileLabelSetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class > LabelSetStylesRoot Properties > LabelSetStylesRoot::ProfileLabelSetStyles Property
LabelSetStylesRoot::ProfileLabelSetStyles Property
Collapse All

Gets the collection of all profile label set styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::ProfileLabelSetStyleCollection ProfileLabelSetStyles;
Visual Basic
Public Property ProfileLabelSetStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::ProfileLabelSetStyleCollection
Example
// get the first label set style in the document
ObjectId labelSetId = doc.Styles.LabelSetStyles.ProfileLabelSetStyles[0];
Links
LabelSetStylesRoot Class, LabelSetStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelSetStylesRoot::SectionLabelSetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class > LabelSetStylesRoot Properties > LabelSetStylesRoot::SectionLabelSetStyles Property
LabelSetStylesRoot::SectionLabelSetStyles Property
Collapse All

Gets the collection of all section label set styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::SectionLabelSetStyleCollection SectionLabelSetStyles;
Visual Basic
Public Property SectionLabelSetStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::SectionLabelSetStyleCollection
Links
LabelSetStylesRoot Class, LabelSetStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class
LabelStyle Class
Collapse All

The master label style class, containing feature-specific label styles and associated information such as derived styles.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::LabelStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabelStyleCollector"))]
public class LabelStyle : StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabelStyleCollector"))>
Public Class LabelStyle
Inherits StyleBase
Links
LabelStyle Methods, LabelStyle Properties, LabelStyle Members, Class Hierarchy


LabelStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Members
LabelStyle Members
Collapse All

The following tables list the members exposed by LabelStyle.

Public Methods
Public Method | Description
AddChild | Add a new child label style to the current label style's node with the default setings' value.
AddComponent | Add a valid component into the label style.
AddReferenceTextComponent | Add ReferenceText component into the label style.
AddTextForEachComponent | Add TextForEach component into the label style.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetComponents | Gets the objectId collection of label style components that specify the appearance and behavior of labels.
GetComponentsCount | Overloaded
GetComponentsDrawOrder | Gets the supported components in draw order, component at the end(as UI list on the top) is drawn last.
IsSupportedComponent | Gets an bool value specifies whether the component type is supported in this label style.
RemoveAllDescendants | Removes all the descendants under the current labelstyle node.
RemoveChild | Overloaded
RemoveComponent | Remove a component from the label style.
SetComponentsDrawOrder | Sets the supported components' draw order.
SwitchComponentsDrawOrder | Switch the supported components' draw order by index.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
ChildrenCount | Gets the number of child label style under the current labelstyle node.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the child lable style by name.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ParentLabelStyleId | Gets the object id of parent lable style .
Properties | Gets the leader related properties of the default label style settings.
Links
Public Methods, Public Properties


LabelStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods
LabelStyle Methods
Collapse All

The methods of LabelStyle are listed here.

Public Methods
Public Method | Description
AddChild | Add a new child label style to the current label style's node with the default setings' value.
AddComponent | Add a valid component into the label style.
AddReferenceTextComponent | Add ReferenceText component into the label style.
AddTextForEachComponent | Add TextForEach component into the label style.
GetComponents | Gets the objectId collection of label style components that specify the appearance and behavior of labels.
GetComponentsCount | Overloaded
GetComponentsDrawOrder | Gets the supported components in draw order, component at the end(as UI list on the top) is drawn last.
IsSupportedComponent | Gets an bool value specifies whether the component type is supported in this label style.
RemoveAllDescendants | Removes all the descendants under the current labelstyle node.
RemoveChild | Overloaded
RemoveComponent | Remove a component from the label style.
SetComponentsDrawOrder | Sets the supported components' draw order.
SwitchComponentsDrawOrder | Switch the supported components' draw order by index.
Links
Public Methods


LabelStyle::AddChild Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::AddChild Method
LabelStyle::AddChild Method
Collapse All

Add a new child label style to the current label style's node with the default setings' value.

C#
public AddChild(
    ref System::String labelStyleName
);
Visual Basic
Public Sub AddChild(
    ByRef labelStyleName As System::String
)
Parameters
Parameters | Description
labelStyleName | The name of the label style.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name is duplicate.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::AddComponent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::AddComponent Method
LabelStyle::AddComponent Method
Collapse All

Add a valid component into the label style.

C#
public AddComponent(
    ref System::String name,
    LabelStyleComponentType type
);
Visual Basic
Public Sub AddComponent(
    ByRef name As System::String,
    type As LabelStyleComponentType
)
Parameters
Parameters | Description
name | The name of component.
type | The type of component.
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The type is ReferenceText or TextForEach;
  2. The type is not supported by this label style;
  3. The name is null, or duplicate, or its length is not in the interval 1 - 128.

Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::AddReferenceTextComponent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::AddReferenceTextComponent Method
LabelStyle::AddReferenceTextComponent Method
Collapse All

Add ReferenceText component into the label style.

C#
public AddReferenceTextComponent(
    ref System::String name,
    ReferenceTextComponentSelectedType selectedType
);
Visual Basic
Public Sub AddReferenceTextComponent(
    ByRef name As System::String,
    selectedType As ReferenceTextComponentSelectedType
)
Parameters
Parameters | Description
name | The name of component.
selectedType | The selected type of reference text component.
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The ReferenceText type is not supported in this label style;
  2. The name is null, or duplicate, or its length is not in the interval 1 - 128.

Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::AddTextForEachComponent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::AddTextForEachComponent Method
LabelStyle::AddTextForEachComponent Method
Collapse All

Add TextForEach component into the label style.

C#
public AddTextForEachComponent(
    ref System::String name,
    TextForEachComponentSelectedType selectedType
);
Visual Basic
Public Sub AddTextForEachComponent(
    ByRef name As System::String,
    selectedType As TextForEachComponentSelectedType
)
Parameters
Parameters | Description
name | The name of component.
selectedType | The selected type of text for each component.
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The TextForEach type is not supported by this label style.
  2. The name is null, or duplicate, or its length is not in the interval 1 - 128.
  3. The type of LabelStyle is StructureLabelStyle, but the selectedType is IntersectionAllAlignment.
  4. The type of LabelStyle is IntersectionLocationLabels, but the selectedType is not IntersectionAllAlignment.

Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::GetComponents Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::GetComponents Method
LabelStyle::GetComponents Method
Collapse All

Gets the objectId collection of label style components that specify the appearance and behavior of labels.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetComponents(
    LabelStyleComponentType type
);
Visual Basic
Public Function GetComponents(
    type As LabelStyleComponentType
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
type | Type of label style component to get.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the type is not supported in this label style.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


GetComponentsCount Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > GetComponentsCount Method
GetComponentsCount Method
Collapse All

Overloaded

Overload List
Method | Description
LabelStyle::GetComponentsCount () | The number of all components.
LabelStyle::GetComponentsCount (LabelStyleComponentType) | The number of a specific type of component.


LabelStyle::GetComponentsCount Method ()

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > GetComponentsCount Method > LabelStyle::GetComponentsCount Method ()
LabelStyle::GetComponentsCount Method ()
Collapse All

The number of all components.

C#
public int GetComponentsCount();
Visual Basic
Public Function GetComponentsCount() As Integer
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::GetComponentsCount Method (LabelStyleComponentType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > GetComponentsCount Method > LabelStyle::GetComponentsCount Method (LabelStyleComponentType)
LabelStyle::GetComponentsCount Method (LabelStyleComponentType)
Collapse All

The number of a specific type of component.

C#
public int GetComponentsCount(
    LabelStyleComponentType type
);
Visual Basic
Public Function GetComponentsCount(
    type As LabelStyleComponentType
) As Integer
Parameters
Parameters | Description
type | Type of label style component to count.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the type is not supported in this label style.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::GetComponentsDrawOrder Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::GetComponentsDrawOrder Method
LabelStyle::GetComponentsDrawOrder Method
Collapse All

Gets the supported components in draw order, component at the end(as UI list on the top) is drawn last.

C#
public array<Autodesk::AutoCAD::DatabaseServices::ObjectId> GetComponentsDrawOrder();
Visual Basic
Public Function GetComponentsDrawOrder() As array<Autodesk::AutoCAD::DatabaseServices::ObjectId>
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::IsSupportedComponent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::IsSupportedComponent Method
LabelStyle::IsSupportedComponent Method
Collapse All

Gets an bool value specifies whether the component type is supported in this label style.

C#
public bool IsSupportedComponent(
    LabelStyleComponentType type
);
Visual Basic
Public Function IsSupportedComponent(
    type As LabelStyleComponentType
) As bool
Parameters
Parameters | Description
type | Type of label style component to query.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::RemoveAllDescendants Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::RemoveAllDescendants Method
LabelStyle::RemoveAllDescendants Method
Collapse All

Removes all the descendants under the current labelstyle node.

C#
public RemoveAllDescendants();
Visual Basic
Public Sub RemoveAllDescendants()
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


RemoveChild Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > RemoveChild Method
RemoveChild Method
Collapse All

Overloaded

Overload List
Method | Description
LabelStyle::RemoveChild (int) | Removes a child label style by index from the current labelstyle node.
LabelStyle::RemoveChild (System::String^) | Removes a child label style by name from the current labelstyle node.


LabelStyle::RemoveChild Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > RemoveChild Method > LabelStyle::RemoveChild Method (System::String^)
LabelStyle::RemoveChild Method (System::String^)
Collapse All

Removes a child label style by name from the current labelstyle node.

C#
public RemoveChild(
    ref System::String labelStyleName
);
Visual Basic
Public Sub RemoveChild(
    ByRef labelStyleName As System::String
)
Parameters
Parameters | Description
labelStyleName | The name of the style to remove from the current labelstyle node.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name is invalid or not exist under the current labelstyle.
System.InvalidOperationException | Thrown when the child label style still has children.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::RemoveChild Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > RemoveChild Method > LabelStyle::RemoveChild Method (int)
LabelStyle::RemoveChild Method (int)
Collapse All

Removes a child label style by index from the current labelstyle node.

C#
public RemoveChild(
    int index
);
Visual Basic
Public Sub RemoveChild(
    index As Integer
)
Parameters
Parameters | Description
index | The index of the style to remove from the current labelstyle node.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the index is out of range.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::RemoveComponent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::RemoveComponent Method
LabelStyle::RemoveComponent Method
Collapse All

Remove a component from the label style.

C#
public RemoveComponent(
    ref System::String name
);
Visual Basic
Public Sub RemoveComponent(
    ByRef name As System::String
)
Parameters
Parameters | Description
name | The name of component.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name is null, or duplicate, or its length is not in the interval [1, 128].
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::SetComponentsDrawOrder Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::SetComponentsDrawOrder Method
LabelStyle::SetComponentsDrawOrder Method
Collapse All

Sets the supported components' draw order.

C#
public SetComponentsDrawOrder(
    ref array<Autodesk::AutoCAD::DatabaseServices::ObjectId> componentIds
);
Visual Basic
Public Sub SetComponentsDrawOrder(
    ByRef componentIds As array<Autodesk::AutoCAD::DatabaseServices::ObjectId>
)
Parameters
Parameters | Description
componentIds | The supported components' id.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when any supported components in not inclued in the input componentIds array.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::SwitchComponentsDrawOrder Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods > LabelStyle::SwitchComponentsDrawOrder Method
LabelStyle::SwitchComponentsDrawOrder Method
Collapse All

Switch the supported components' draw order by index.

C#
public SwitchComponentsDrawOrder(
    int index1,
    int index2
);
Visual Basic
Public Sub SwitchComponentsDrawOrder(
    index1 As Integer,
    index2 As Integer
)
Parameters
Parameters | Description
index1 | The first index of the child label style under the current labelstyle node.
index2 | The second index of the child label style under the current labelstyle node.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the index1 or index2 is out of range.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Properties
LabelStyle Properties
Collapse All

The properties of LabelStyle are listed here.

Public Properties
Public Property | Description
ChildrenCount | Gets the number of child label style under the current labelstyle node.
default | Gets the child lable style by name.
ParentLabelStyleId | Gets the object id of parent lable style .
Properties | Gets the leader related properties of the default label style settings.
Links
Public Properties


LabelStyle::ChildrenCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Properties > LabelStyle::ChildrenCount Property
LabelStyle::ChildrenCount Property
Collapse All

Gets the number of child label style under the current labelstyle node.

C#
public int ChildrenCount;
Visual Basic
Public Property ChildrenCount() As Integer
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Properties > LabelStyle::default Property
LabelStyle::default Property
Collapse All

Gets the child lable style by name.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId default;
Visual Basic
Public Property default() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when index is less than 0 or greater/equal to the ChildCount.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::ParentLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Properties > LabelStyle::ParentLabelStyleId Property
LabelStyle::ParentLabelStyleId Property
Collapse All

Gets the object id of parent lable style .

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ParentLabelStyleId;
Visual Basic
Public Property ParentLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the current label style is the top label style node.
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyle::Properties Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Properties > LabelStyle::Properties Property
LabelStyle::Properties Property
Collapse All

Gets the leader related properties of the default label style settings.

C#
public LabelStyleBase Properties;
Visual Basic
Public Property Properties() As LabelStyleBase
Links
LabelStyle Class, LabelStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class
LabelStyleBase Class
Collapse All

Base class for label style defaults.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase
C#
public class LabelStyleBase : CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleBase
Inherits CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleBase Properties, LabelStyleBase Members, Class Hierarchy


LabelStyleBase Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Members
LabelStyleBase Members
Collapse All

The following tables list the members exposed by LabelStyleBase.

Public Properties
Public Property | Description
Behavior | Gets the behavior related properties of the default label style.
DraggedStateComponents | Gets dragged state components related properties of the default label style.
Label | Gets the label related properties of the default label style.
Leader | Gets the leader related properties of the default label style.
PlanReadability | Gets the plan readability related properties of the default label style.
Links
Public Properties


LabelStyleBase Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Properties
LabelStyleBase Properties
Collapse All

The properties of LabelStyleBase are listed here.

Public Properties
Public Property | Description
Behavior | Gets the behavior related properties of the default label style.
DraggedStateComponents | Gets dragged state components related properties of the default label style.
Label | Gets the label related properties of the default label style.
Leader | Gets the leader related properties of the default label style.
PlanReadability | Gets the plan readability related properties of the default label style.
Links
Public Properties


LabelStyleBase::Behavior Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Properties > LabelStyleBase::Behavior Property
LabelStyleBase::Behavior Property
Collapse All

Gets the behavior related properties of the default label style.

C#
public BaseBehavior Behavior;
Visual Basic
Public Property Behavior() As BaseBehavior
Links
LabelStyleBase Class, LabelStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::DraggedStateComponents Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Properties > LabelStyleBase::DraggedStateComponents Property
LabelStyleBase::DraggedStateComponents Property
Collapse All

Gets dragged state components related properties of the default label style.

C#
public BaseDraggedStateComponents DraggedStateComponents;
Visual Basic
Public Property DraggedStateComponents() As BaseDraggedStateComponents
Links
LabelStyleBase Class, LabelStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::Label Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Properties > LabelStyleBase::Label Property
LabelStyleBase::Label Property
Collapse All

Gets the label related properties of the default label style.

C#
public BaseLabel Label;
Visual Basic
Public Property Label() As BaseLabel
Links
LabelStyleBase Class, LabelStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::Leader Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Properties > LabelStyleBase::Leader Property
LabelStyleBase::Leader Property
Collapse All

Gets the leader related properties of the default label style.

C#
public BaseLeader Leader;
Visual Basic
Public Property Leader() As BaseLeader
Links
LabelStyleBase Class, LabelStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::PlanReadability Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Properties > LabelStyleBase::PlanReadability Property
LabelStyleBase::PlanReadability Property
Collapse All

Gets the plan readability related properties of the default label style.

C#
public BasePlanReadability PlanReadability;
Visual Basic
Public Property PlanReadability() As BasePlanReadability
Links
LabelStyleBase Class, LabelStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseBehavior Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class
LabelStyleBase::BaseBehavior Class
Collapse All

The behavior related properties of the default label style.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BaseBehavior
C#
public class LabelStyleBase::BaseBehavior : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleBase::BaseBehavior
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleBase::BaseBehavior Properties, LabelStyleBase::BaseBehavior Members, Class Hierarchy


LabelStyleBase::BaseBehavior Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class > LabelStyleBase::BaseBehavior Members
LabelStyleBase::BaseBehavior Members
Collapse All

The following tables list the members exposed by LabelStyleBase::BaseBehavior.

Public Properties
Public Property | Description
InsertOption | Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.
InsideCurveOption | Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.
OrientationReference | Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.
Links
Public Properties


LabelStyleBase::BaseBehavior Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class > LabelStyleBase::BaseBehavior Properties
LabelStyleBase::BaseBehavior Properties
Collapse All

The properties of LabelStyleBase::BaseBehavior are listed here.

Public Properties
Public Property | Description
InsertOption | Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.
InsideCurveOption | Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.
OrientationReference | Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.
Links
Public Properties


LabelStyleBase::BaseBehavior::InsertOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class > LabelStyleBase::BaseBehavior Properties > LabelStyleBase::BaseBehavior::InsertOption Property
LabelStyleBase::BaseBehavior::InsertOption Property
Collapse All

Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.

C#
public PropertyEnum<LabelInsertionType> InsertOption;
Visual Basic
Public Property InsertOption() As PropertyEnum<LabelInsertionType>
Remarks
  1. Applies only when the Orientation Reference option is set to Object and the objects are lines, arc segments, or spline segments.
  2. Plan Readable should be set to True when using the Top or Bottom.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the type of label style belongs to anyone of the below types: ParcelArea, ProfileMajorStation, ProfileMinorStation, ProfileHorizontalGeometryPoint, ProfileGradeBreaks, ProfileLine, or ProfileCurve.
Links
LabelStyleBase::BaseBehavior Class, LabelStyleBase::BaseBehavior Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseBehavior::InsideCurveOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class > LabelStyleBase::BaseBehavior Properties > LabelStyleBase::BaseBehavior::InsideCurveOption Property
LabelStyleBase::BaseBehavior::InsideCurveOption Property
Collapse All

Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.

C#
public PropertyEnum<LabelInsideCurveType> InsideCurveOption;
Visual Basic
Public Property InsideCurveOption() As PropertyEnum<LabelInsideCurveType>
Remarks

If true: Moves label components on the outside of curve to the inside of curve. The components maintain the same offset and rotation. If false: All label components remain as composed. This is the default setting. Available only for curve label styles. This setting has precedence over any forced insertion setting.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the type of label style doesn't belong to anyone of the below types: GeneralCurve, GeneralLink, ParcelLine, AlignmentGeometryPoint, AlignmentDesignSpeed, AlignmentCurve, AlignmentMajorStation, AlignmentMinorStation, AlignmentSpiral, AlignmentStationEquation, AlignmentSuperelevationCriticalPoints, AlignmentProfileGeometryPoint, ProfileViewProjection, SectionViewProjection or PipePlanProfile.
Links
LabelStyleBase::BaseBehavior Class, LabelStyleBase::BaseBehavior Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseBehavior::OrientationReference Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class > LabelStyleBase::BaseBehavior Properties > LabelStyleBase::BaseBehavior::OrientationReference Property
LabelStyleBase::BaseBehavior::OrientationReference Property
Collapse All

Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.

C#
public PropertyEnum<OrientationReferenceType> OrientationReference;
Visual Basic
Public Property OrientationReference() As PropertyEnum<OrientationReferenceType>
Links
LabelStyleBase::BaseBehavior Class, LabelStyleBase::BaseBehavior Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class
LabelStyleBase::BaseDraggedStateComponents Class
Collapse All

The dragged state components related properties of the default label style.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BaseDraggedStateComponents
C#
public class LabelStyleBase::BaseDraggedStateComponents : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleBase::BaseDraggedStateComponents
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleBase::BaseDraggedStateComponents Properties, LabelStyleBase::BaseDraggedStateComponents Members, Class Hierarchy


LabelStyleBase::BaseDraggedStateComponents Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Members
LabelStyleBase::BaseDraggedStateComponents Members
Collapse All

The following tables list the members exposed by LabelStyleBase::BaseDraggedStateComponents.

Public Properties
Public Property | Description
BorderType | Gets the shape of the border, either rounded or rectangular.
BorderVisibility | Gets the boolean value that specifies whether a border is visible for dragged labels.
Color | Gets the color for dragged components.
DisplayType | Gets the enum value that specifies how label content is displayed after it is dragged from its default position.
Gap | Gets the distance between the leader and the label text.
LeaderAttachment | Gets the location where a leader hook is drawn in relation to label content.
LeaderJustification | Gets the boolean value that specifies the justification of label text in relation to the leader.
Linetype | Gets the linetype for dragged components.
Lineweight | Gets the linetype for dragged components.
TextHeight | Gets the plotted height for all text components.
UseBackgroundMask | Gets the boolean value that specifies whether use background mask when drawing.
Links
Public Properties


LabelStyleBase::BaseDraggedStateComponents Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties
LabelStyleBase::BaseDraggedStateComponents Properties
Collapse All

The properties of LabelStyleBase::BaseDraggedStateComponents are listed here.

Public Properties
Public Property | Description
BorderType | Gets the shape of the border, either rounded or rectangular.
BorderVisibility | Gets the boolean value that specifies whether a border is visible for dragged labels.
Color | Gets the color for dragged components.
DisplayType | Gets the enum value that specifies how label content is displayed after it is dragged from its default position.
Gap | Gets the distance between the leader and the label text.
LeaderAttachment | Gets the location where a leader hook is drawn in relation to label content.
LeaderJustification | Gets the boolean value that specifies the justification of label text in relation to the leader.
Linetype | Gets the linetype for dragged components.
Lineweight | Gets the linetype for dragged components.
TextHeight | Gets the plotted height for all text components.
UseBackgroundMask | Gets the boolean value that specifies whether use background mask when drawing.
Links
Public Properties


LabelStyleBase::BaseDraggedStateComponents::BorderType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::BorderType Property
LabelStyleBase::BaseDraggedStateComponents::BorderType Property
Collapse All

Gets the shape of the border, either rounded or rectangular.

C#
public PropertyEnum<TextBorderType> BorderType;
Visual Basic
Public Property BorderType() As PropertyEnum<TextBorderType>
Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::BorderVisibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::BorderVisibility Property
LabelStyleBase::BaseDraggedStateComponents::BorderVisibility Property
Collapse All

Gets the boolean value that specifies whether a border is visible for dragged labels.

C#
public PropertyBoolean BorderVisibility;
Visual Basic
Public Property BorderVisibility() As PropertyBoolean
Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::Color Property
LabelStyleBase::BaseDraggedStateComponents::Color Property
Collapse All

Gets the color for dragged components.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::DisplayType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::DisplayType Property
LabelStyleBase::BaseDraggedStateComponents::DisplayType Property
Collapse All

Gets the enum value that specifies how label content is displayed after it is dragged from its default position.

C#
public PropertyEnum<LabelContentDisplayType> DisplayType;
Visual Basic
Public Property DisplayType() As PropertyEnum<LabelContentDisplayType>
Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::Gap Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::Gap Property
LabelStyleBase::BaseDraggedStateComponents::Gap Property
Collapse All

Gets the distance between the leader and the label text.

C#
public PropertyDouble Gap;
Visual Basic
Public Property Gap() As PropertyDouble
Remarks

The gap value is also used to define the space between the border and the label text.

Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::LeaderAttachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::LeaderAttachment Property
LabelStyleBase::BaseDraggedStateComponents::LeaderAttachment Property
Collapse All

Gets the location where a leader hook is drawn in relation to label content.

C#
public PropertyEnum<LeaderAttachmentType> LeaderAttachment;
Visual Basic
Public Property LeaderAttachment() As PropertyEnum<LeaderAttachmentType>
Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::LeaderJustification Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::LeaderJustification Property
LabelStyleBase::BaseDraggedStateComponents::LeaderJustification Property
Collapse All

Gets the boolean value that specifies the justification of label text in relation to the leader.

C#
public PropertyBoolean LeaderJustification;
Visual Basic
Public Property LeaderJustification() As PropertyBoolean
Remarks

If true, text is left-justified when the leader is on the left, and right-justified when the leader is on the right, as shown in the following illustration. This is the default setting. If false, text is left-justified regardless of leader location.

Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::Linetype Property
LabelStyleBase::BaseDraggedStateComponents::Linetype Property
Collapse All

Gets the linetype for dragged components.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::Lineweight Property
LabelStyleBase::BaseDraggedStateComponents::Lineweight Property
Collapse All

Gets the linetype for dragged components.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::TextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::TextHeight Property
LabelStyleBase::BaseDraggedStateComponents::TextHeight Property
Collapse All

Gets the plotted height for all text components.

C#
public PropertyDouble TextHeight;
Visual Basic
Public Property TextHeight() As PropertyDouble
Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseDraggedStateComponents::UseBackgroundMask Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties > LabelStyleBase::BaseDraggedStateComponents::UseBackgroundMask Property
LabelStyleBase::BaseDraggedStateComponents::UseBackgroundMask Property
Collapse All

Gets the boolean value that specifies whether use background mask when drawing.

C#
public PropertyBoolean UseBackgroundMask;
Visual Basic
Public Property UseBackgroundMask() As PropertyBoolean
Links
LabelStyleBase::BaseDraggedStateComponents Class, LabelStyleBase::BaseDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class
LabelStyleBase::BaseLabel Class
Collapse All

The label related properties of the default label style.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BaseLabel
C#
public class LabelStyleBase::BaseLabel : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleBase::BaseLabel
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleBase::BaseLabel Properties, LabelStyleBase::BaseLabel Members, Class Hierarchy


LabelStyleBase::BaseLabel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Members
LabelStyleBase::BaseLabel Members
Collapse All

The following tables list the members exposed by LabelStyleBase::BaseLabel.

Public Properties
Public Property | Description
DisplayMode | Gets the display mode for all label styles in a drawing.
Layer | Gets the default layer for all label styles in a drawing.
TextStyle | Gets the default text style for all label text components in a drawing.
Visibility | Gets the boolean value that specifies visibility of labels in the drawing (independent of layer).
Links
Public Properties


LabelStyleBase::BaseLabel Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Properties
LabelStyleBase::BaseLabel Properties
Collapse All

The properties of LabelStyleBase::BaseLabel are listed here.

Public Properties
Public Property | Description
DisplayMode | Gets the display mode for all label styles in a drawing.
Layer | Gets the default layer for all label styles in a drawing.
TextStyle | Gets the default text style for all label text components in a drawing.
Visibility | Gets the boolean value that specifies visibility of labels in the drawing (independent of layer).
Links
Public Properties


LabelStyleBase::BaseLabel::DisplayMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Properties > LabelStyleBase::BaseLabel::DisplayMode Property
LabelStyleBase::BaseLabel::DisplayMode Property
Collapse All

Gets the display mode for all label styles in a drawing.

C#
public PropertyEnum<LabelDisplayModeType> DisplayMode;
Visual Basic
Public Property DisplayMode() As PropertyEnum<LabelDisplayModeType>
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the type of label style doesn't belong to anyone of the below types: AlignmentLine, AlignmentCurve, AlignmentSpiral, ParcelLine, ParcelCurve, GeneralLine, or GeneralCurve.
Links
LabelStyleBase::BaseLabel Class, LabelStyleBase::BaseLabel Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLabel::Layer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Properties > LabelStyleBase::BaseLabel::Layer Property
LabelStyleBase::BaseLabel::Layer Property
Collapse All

Gets the default layer for all label styles in a drawing.

C#
public PropertyLayer Layer;
Visual Basic
Public Property Layer() As PropertyLayer
Links
LabelStyleBase::BaseLabel Class, LabelStyleBase::BaseLabel Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLabel::TextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Properties > LabelStyleBase::BaseLabel::TextStyle Property
LabelStyleBase::BaseLabel::TextStyle Property
Collapse All

Gets the default text style for all label text components in a drawing.

C#
public PropertyString TextStyle;
Visual Basic
Public Property TextStyle() As PropertyString
Links
LabelStyleBase::BaseLabel Class, LabelStyleBase::BaseLabel Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLabel::Visibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Properties > LabelStyleBase::BaseLabel::Visibility Property
LabelStyleBase::BaseLabel::Visibility Property
Collapse All

Gets the boolean value that specifies visibility of labels in the drawing (independent of layer).

C#
public PropertyBoolean Visibility;
Visual Basic
Public Property Visibility() As PropertyBoolean
Remarks

Tip: use this setting to quickly turn all labels in the drawing off or on.

Links
LabelStyleBase::BaseLabel Class, LabelStyleBase::BaseLabel Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLeader Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class
LabelStyleBase::BaseLeader Class
Collapse All

The leader related properties of the default label style.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BaseLeader
C#
public class LabelStyleBase::BaseLeader : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleBase::BaseLeader
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleBase::BaseLeader Properties, LabelStyleBase::BaseLeader Members, Class Hierarchy


LabelStyleBase::BaseLeader Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Members
LabelStyleBase::BaseLeader Members
Collapse All

The following tables list the members exposed by LabelStyleBase::BaseLeader.

Public Properties
Public Property | Description
ArrowheadSize | Gets the size of the arrow head.
ArrowheadStyle | Gets the arrow head style for a leader.
Color | Gets the color for leaders.
Linetype | Gets the linetype for leaders.
Lineweight | Gets the lineweight for leaders.
Shape | Gets the enum value that specifies the shape of the leader.
Visibility | Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.
Links
Public Properties


LabelStyleBase::BaseLeader Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties
LabelStyleBase::BaseLeader Properties
Collapse All

The properties of LabelStyleBase::BaseLeader are listed here.

Public Properties
Public Property | Description
ArrowheadSize | Gets the size of the arrow head.
ArrowheadStyle | Gets the arrow head style for a leader.
Color | Gets the color for leaders.
Linetype | Gets the linetype for leaders.
Lineweight | Gets the lineweight for leaders.
Shape | Gets the enum value that specifies the shape of the leader.
Visibility | Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.
Links
Public Properties


LabelStyleBase::BaseLeader::ArrowheadSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties > LabelStyleBase::BaseLeader::ArrowheadSize Property
LabelStyleBase::BaseLeader::ArrowheadSize Property
Collapse All

Gets the size of the arrow head.

C#
public PropertyDouble ArrowheadSize;
Visual Basic
Public Property ArrowheadSize() As PropertyDouble
Remarks

The default arrow head size is defined in plot units (either inches or millimeters). The plot units are determined by the drawing units established in the drawing.

Links
LabelStyleBase::BaseLeader Class, LabelStyleBase::BaseLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLeader::ArrowheadStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties > LabelStyleBase::BaseLeader::ArrowheadStyle Property
LabelStyleBase::BaseLeader::ArrowheadStyle Property
Collapse All

Gets the arrow head style for a leader.

C#
public PropertyString ArrowheadStyle;
Visual Basic
Public Property ArrowheadStyle() As PropertyString
Links
LabelStyleBase::BaseLeader Class, LabelStyleBase::BaseLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLeader::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties > LabelStyleBase::BaseLeader::Color Property
LabelStyleBase::BaseLeader::Color Property
Collapse All

Gets the color for leaders.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleBase::BaseLeader Class, LabelStyleBase::BaseLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLeader::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties > LabelStyleBase::BaseLeader::Linetype Property
LabelStyleBase::BaseLeader::Linetype Property
Collapse All

Gets the linetype for leaders.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleBase::BaseLeader Class, LabelStyleBase::BaseLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLeader::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties > LabelStyleBase::BaseLeader::Lineweight Property
LabelStyleBase::BaseLeader::Lineweight Property
Collapse All

Gets the lineweight for leaders.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleBase::BaseLeader Class, LabelStyleBase::BaseLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLeader::Shape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties > LabelStyleBase::BaseLeader::Shape Property
LabelStyleBase::BaseLeader::Shape Property
Collapse All

Gets the enum value that specifies the shape of the leader.

C#
public PropertyEnum<LeaderShapeType> Shape;
Visual Basic
Public Property Shape() As PropertyEnum<LeaderShapeType>
Links
LabelStyleBase::BaseLeader Class, LabelStyleBase::BaseLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BaseLeader::Visibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties > LabelStyleBase::BaseLeader::Visibility Property
LabelStyleBase::BaseLeader::Visibility Property
Collapse All

Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.

C#
public PropertyBoolean Visibility;
Visual Basic
Public Property Visibility() As PropertyBoolean
Links
LabelStyleBase::BaseLeader Class, LabelStyleBase::BaseLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BasePlanReadability Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class
LabelStyleBase::BasePlanReadability Class
Collapse All

The plan readability related properties of the default label style.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BasePlanReadability
C#
public class LabelStyleBase::BasePlanReadability : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleBase::BasePlanReadability
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleBase::BasePlanReadability Properties, LabelStyleBase::BasePlanReadability Members, Class Hierarchy


LabelStyleBase::BasePlanReadability Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class > LabelStyleBase::BasePlanReadability Members
LabelStyleBase::BasePlanReadability Members
Collapse All

The following tables list the members exposed by LabelStyleBase::BasePlanReadability.

Public Properties
Public Property | Description
FlipAnchorsWithText | Gets the boolean that specifies whether flip anchors with text.
PlanReadable | Gets the boolean that specifies whether all text components in labels can be read easily in plan view.
PlanReadableBias | Gets the angle at which label text flips 180 degrees to remain plan readable.
Links
Public Properties


LabelStyleBase::BasePlanReadability Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class > LabelStyleBase::BasePlanReadability Properties
LabelStyleBase::BasePlanReadability Properties
Collapse All

The properties of LabelStyleBase::BasePlanReadability are listed here.

Public Properties
Public Property | Description
FlipAnchorsWithText | Gets the boolean that specifies whether flip anchors with text.
PlanReadable | Gets the boolean that specifies whether all text components in labels can be read easily in plan view.
PlanReadableBias | Gets the angle at which label text flips 180 degrees to remain plan readable.
Links
Public Properties


LabelStyleBase::BasePlanReadability::FlipAnchorsWithText Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class > LabelStyleBase::BasePlanReadability Properties > LabelStyleBase::BasePlanReadability::FlipAnchorsWithText Property
LabelStyleBase::BasePlanReadability::FlipAnchorsWithText Property
Collapse All

Gets the boolean that specifies whether flip anchors with text.

C#
public PropertyBoolean FlipAnchorsWithText;
Visual Basic
Public Property FlipAnchorsWithText() As PropertyBoolean
Remarks

If true: Ensures that if text is rotated to make plan-readable, the anchors will also be flipped. If false: The flipped label always looks like a mirror of the original.

Links
LabelStyleBase::BasePlanReadability Class, LabelStyleBase::BasePlanReadability Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BasePlanReadability::PlanReadable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class > LabelStyleBase::BasePlanReadability Properties > LabelStyleBase::BasePlanReadability::PlanReadable Property
LabelStyleBase::BasePlanReadability::PlanReadable Property
Collapse All

Gets the boolean that specifies whether all text components in labels can be read easily in plan view.

C#
public PropertyBoolean PlanReadable;
Visual Basic
Public Property PlanReadable() As PropertyBoolean
Remarks

If true: Rotates text to insure that it can be read easily in plan view or as if viewed from an angle at the bottom or right side of the screen/paper. If false: Displays Text as inserted. This option applies only to text components in labels.

Links
LabelStyleBase::BasePlanReadability Class, LabelStyleBase::BasePlanReadability Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBase::BasePlanReadability::PlanReadableBias Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class > LabelStyleBase::BasePlanReadability Properties > LabelStyleBase::BasePlanReadability::PlanReadableBias Property
LabelStyleBase::BasePlanReadability::PlanReadableBias Property
Collapse All

Gets the angle at which label text flips 180 degrees to remain plan readable.

C#
public PropertyDouble PlanReadableBias;
Visual Basic
Public Property PlanReadableBias() As PropertyDouble
Links
LabelStyleBase::BasePlanReadability Class, LabelStyleBase::BasePlanReadability Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleBlock Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class
LabelStyleBlockComponent::StyleBlock Class
Collapse All

Block style settings for label block components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBlockComponent::StyleBlock
C#
public class LabelStyleBlockComponent::StyleBlock : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleBlockComponent::StyleBlock
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleBlockComponent::StyleBlock Properties, LabelStyleBlockComponent::StyleBlock Members, Class Hierarchy


LabelStyleBlockComponent::StyleBlock Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Members
LabelStyleBlockComponent::StyleBlock Members
Collapse All

The following tables list the members exposed by LabelStyleBlockComponent::StyleBlock.

Public Properties
Public Property | Description
Attachment | Gets the location on the block component that is attached to the anchor point
BlockHeight | Gets the height to whick the block is scaled to fit.
BlockName | Gets the block to use for the block component.
Color | Gets the color of block component.
Linetype | Gets the line type of the block component.
Lineweight | Gets the line weight of the block component.
RotationAngle | Gets the angle for block component.
XOffset | Gets the offset distance between the attachment point and the anchor point in the X direction
YOffset | Gets the offset distance between the attachment point and the anchor point in the Y direction
Links
Public Properties


LabelStyleBlockComponent::StyleBlock Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties
LabelStyleBlockComponent::StyleBlock Properties
Collapse All

The properties of LabelStyleBlockComponent::StyleBlock are listed here.

Public Properties
Public Property | Description
Attachment | Gets the location on the block component that is attached to the anchor point
BlockHeight | Gets the height to whick the block is scaled to fit.
BlockName | Gets the block to use for the block component.
Color | Gets the color of block component.
Linetype | Gets the line type of the block component.
Lineweight | Gets the line weight of the block component.
RotationAngle | Gets the angle for block component.
XOffset | Gets the offset distance between the attachment point and the anchor point in the X direction
YOffset | Gets the offset distance between the attachment point and the anchor point in the Y direction
Links
Public Properties


LabelStyleBlockComponent::StyleBlock::Attachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties > LabelStyleBlockComponent::StyleBlock::Attachment Property
LabelStyleBlockComponent::StyleBlock::Attachment Property
Collapse All

Gets the location on the block component that is attached to the anchor point

C#
public PropertyEnum<BlockAttachmentType> Attachment;
Visual Basic
Public Property Attachment() As PropertyEnum<BlockAttachmentType>
Links
LabelStyleBlockComponent::StyleBlock Class, LabelStyleBlockComponent::StyleBlock Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleBlock::BlockHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties > LabelStyleBlockComponent::StyleBlock::BlockHeight Property
LabelStyleBlockComponent::StyleBlock::BlockHeight Property
Collapse All

Gets the height to whick the block is scaled to fit.

C#
public PropertyDouble BlockHeight;
Visual Basic
Public Property BlockHeight() As PropertyDouble
Links
LabelStyleBlockComponent::StyleBlock Class, LabelStyleBlockComponent::StyleBlock Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleBlock::BlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties > LabelStyleBlockComponent::StyleBlock::BlockName Property
LabelStyleBlockComponent::StyleBlock::BlockName Property
Collapse All

Gets the block to use for the block component.

C#
public PropertyString BlockName;
Visual Basic
Public Property BlockName() As PropertyString
Links
LabelStyleBlockComponent::StyleBlock Class, LabelStyleBlockComponent::StyleBlock Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleBlock::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties > LabelStyleBlockComponent::StyleBlock::Color Property
LabelStyleBlockComponent::StyleBlock::Color Property
Collapse All

Gets the color of block component.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleBlockComponent::StyleBlock Class, LabelStyleBlockComponent::StyleBlock Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleBlock::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties > LabelStyleBlockComponent::StyleBlock::Linetype Property
LabelStyleBlockComponent::StyleBlock::Linetype Property
Collapse All

Gets the line type of the block component.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleBlockComponent::StyleBlock Class, LabelStyleBlockComponent::StyleBlock Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleBlock::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties > LabelStyleBlockComponent::StyleBlock::Lineweight Property
LabelStyleBlockComponent::StyleBlock::Lineweight Property
Collapse All

Gets the line weight of the block component.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleBlockComponent::StyleBlock Class, LabelStyleBlockComponent::StyleBlock Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleBlock::RotationAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties > LabelStyleBlockComponent::StyleBlock::RotationAngle Property
LabelStyleBlockComponent::StyleBlock::RotationAngle Property
Collapse All

Gets the angle for block component.

C#
public PropertyDouble RotationAngle;
Visual Basic
Public Property RotationAngle() As PropertyDouble
Links
LabelStyleBlockComponent::StyleBlock Class, LabelStyleBlockComponent::StyleBlock Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleBlock::XOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties > LabelStyleBlockComponent::StyleBlock::XOffset Property
LabelStyleBlockComponent::StyleBlock::XOffset Property
Collapse All

Gets the offset distance between the attachment point and the anchor point in the X direction

C#
public PropertyDouble XOffset;
Visual Basic
Public Property XOffset() As PropertyDouble
Links
LabelStyleBlockComponent::StyleBlock Class, LabelStyleBlockComponent::StyleBlock Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleBlock::YOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties > LabelStyleBlockComponent::StyleBlock::YOffset Property
LabelStyleBlockComponent::StyleBlock::YOffset Property
Collapse All

Gets the offset distance between the attachment point and the anchor point in the Y direction

C#
public PropertyDouble YOffset;
Visual Basic
Public Property YOffset() As PropertyDouble
Links
LabelStyleBlockComponent::StyleBlock Class, LabelStyleBlockComponent::StyleBlock Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleGeneral Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class
LabelStyleBlockComponent::StyleGeneral Class
Collapse All

General style settings for label block components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBlockComponent::StyleGeneral
C#
public class LabelStyleBlockComponent::StyleGeneral : CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleBlockComponent::StyleGeneral
Inherits CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleBlockComponent::StyleGeneral Properties, LabelStyleBlockComponent::StyleGeneral Members, Class Hierarchy


LabelStyleBlockComponent::StyleGeneral Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Members
LabelStyleBlockComponent::StyleGeneral Members
Collapse All

The following tables list the members exposed by LabelStyleBlockComponent::StyleGeneral.

Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the block component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the block component is attached.
Name | Gets the name for block component.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the block component is visible in the label style.
Links
Public Properties


LabelStyleBlockComponent::StyleGeneral Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Properties
LabelStyleBlockComponent::StyleGeneral Properties
Collapse All

The properties of LabelStyleBlockComponent::StyleGeneral are listed here.

Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the block component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the block component is attached.
Name | Gets the name for block component.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the block component is visible in the label style.
Links
Public Properties


LabelStyleBlockComponent::StyleGeneral::AnchorComponent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Properties > LabelStyleBlockComponent::StyleGeneral::AnchorComponent Property
LabelStyleBlockComponent::StyleGeneral::AnchorComponent Property
Collapse All

Gets a reference object for positioning the point of the block component.

C#
public PropertyString AnchorComponent;
Visual Basic
Public Property AnchorComponent() As PropertyString
Links
LabelStyleBlockComponent::StyleGeneral Class, LabelStyleBlockComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleGeneral::AnchorLocation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Properties > LabelStyleBlockComponent::StyleGeneral::AnchorLocation Property
LabelStyleBlockComponent::StyleGeneral::AnchorLocation Property
Collapse All

Gets the location on the anchor component where the point of the block component is attached.

C#
public PropertyAnchorPoint AnchorLocation;
Visual Basic
Public Property AnchorLocation() As PropertyAnchorPoint
Links
LabelStyleBlockComponent::StyleGeneral Class, LabelStyleBlockComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleGeneral::AnchorPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Properties > LabelStyleBlockComponent::StyleGeneral::AnchorPoint Property
LabelStyleBlockComponent::StyleGeneral::AnchorPoint Property deprecated
Collapse All

Gets the location on the anchor component where the point of the block component is attached.

C#
public PropertyEnum<AnchorLocationType> AnchorPoint;
Visual Basic
Public Property AnchorPoint() As PropertyEnum<AnchorLocationType>
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleBlockComponent.StyleGeneral.AnchorLocation instead.

Links
LabelStyleBlockComponent::StyleGeneral Class, LabelStyleBlockComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleGeneral::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Properties > LabelStyleBlockComponent::StyleGeneral::Name Property
LabelStyleBlockComponent::StyleGeneral::Name Property
Collapse All

Gets the name for block component.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
LabelStyleBlockComponent::StyleGeneral Class, LabelStyleBlockComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleGeneral::UsedIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Properties > LabelStyleBlockComponent::StyleGeneral::UsedIn Property
LabelStyleBlockComponent::StyleGeneral::UsedIn Property
Collapse All

Gets the display mode in which the component is used;for example if this is set to label, only display the component when display mode is set to label.

C#
public PropertyEnum<LayoutModeType> UsedIn;
Visual Basic
Public Property UsedIn() As PropertyEnum<LayoutModeType>
Links
LabelStyleBlockComponent::StyleGeneral Class, LabelStyleBlockComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleBlockComponent::StyleGeneral::Visible Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Properties > LabelStyleBlockComponent::StyleGeneral::Visible Property
LabelStyleBlockComponent::StyleGeneral::Visible Property
Collapse All

Gets whether the block component is visible in the label style.

C#
public PropertyBoolean Visible;
Visual Basic
Public Property Visible() As PropertyBoolean
Links
LabelStyleBlockComponent::StyleGeneral Class, LabelStyleBlockComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class
LabelStyleCollection Class
Collapse All

A collection of LabelStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
C#
public class LabelStyleCollection : StyleCollectionBase;
Visual Basic
Public Class LabelStyleCollection
Inherits StyleCollectionBase
Links
LabelStyleCollection Methods, LabelStyleCollection Properties, LabelStyleCollection Members, Class Hierarchy


LabelStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Members
LabelStyleCollection Members
Collapse All

The following tables list the members exposed by LabelStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
DefaultLabelStyle | Gets the default vaules of label styles.
Expressions | This is Expressions, a member of class LabelStyleCollection.
Links
Public Methods, Public Properties


LabelStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Methods
LabelStyleCollection Methods
Collapse All

The methods of LabelStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Remove | Overloaded
Links
Public Methods


LabelStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Methods > LabelStyleCollection::Add Method
LabelStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
LabelStyleCollection Class, LabelStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Methods > Remove Method
Remove Method
Collapse All

Overloaded

Overload List
Method | Description
LabelStyleCollection::Remove (int) | Removes a label style by index from the collection.
LabelStyleCollection::Remove (System::String^) | Removes a label style by name from the collection.


LabelStyleCollection::Remove Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Methods > Remove Method > LabelStyleCollection::Remove Method (System::String^)
LabelStyleCollection::Remove Method (System::String^)
Collapse All

Removes a label style by name from the collection.

C#
public Remove(
    ref System::String styleName
);
Visual Basic
Public Sub Remove(
    ByRef styleName As System::String
)
Parameters
Parameters | Description
styleName | The name of the label style to remove from the collection.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name is invalid or not exist in the collection.
System.InvalidOperationException | Thrown when label style is still in use.
Links
LabelStyleCollection Class, LabelStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleCollection::Remove Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Methods > Remove Method > LabelStyleCollection::Remove Method (int)
LabelStyleCollection::Remove Method (int)
Collapse All

Removes a label style by index from the collection.

C#
public Remove(
    int index
);
Visual Basic
Public Sub Remove(
    index As Integer
)
Parameters
Parameters | Description
index | The index of the label style to remove from the collection.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of range.
System.InvalidOperationException | Thrown when label style is still in use.
Links
LabelStyleCollection Class, LabelStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Properties
LabelStyleCollection Properties
Collapse All

The properties of LabelStyleCollection are listed here.

Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
Expressions | This is Expressions, a member of class LabelStyleCollection.
Links
Public Properties


LabelStyleCollection::DefaultLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Properties > LabelStyleCollection::DefaultLabelStyle Property
LabelStyleCollection::DefaultLabelStyle Property
Collapse All

Gets the default vaules of label styles.

C#
public LabelStyleDefault DefaultLabelStyle;
Visual Basic
Public Property DefaultLabelStyle() As LabelStyleDefault
Links
LabelStyleCollection Class, LabelStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleCollection::Expressions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Properties > LabelStyleCollection::Expressions Property
LabelStyleCollection::Expressions Property
Collapse All

This is Expressions, a member of class LabelStyleCollection.

C#
public ExpressionCollection Expressions;
Visual Basic
Public Property Expressions() As ExpressionCollection
Links
LabelStyleCollection Class, LabelStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultBehavior Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class
LabelStyleDefault::DefaultBehavior Class
Collapse All

The behavior related properties of the default label style settings.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultBehavior
C#
public class LabelStyleDefault::DefaultBehavior : TreeOidWrapper;
Visual Basic
Public Class LabelStyleDefault::DefaultBehavior
Inherits TreeOidWrapper
Links
LabelStyleDefault::DefaultBehavior Properties, LabelStyleDefault::DefaultBehavior Members, Class Hierarchy


LabelStyleDefault::DefaultBehavior Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class > LabelStyleDefault::DefaultBehavior Members
LabelStyleDefault::DefaultBehavior Members
Collapse All

The following tables list the members exposed by LabelStyleDefault::DefaultBehavior.

Public Properties
Public Property | Description
InsertOption | Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.
InsideCurveOption | Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.
OrientationReference | Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.
Links
Public Properties


LabelStyleDefault::DefaultBehavior Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class > LabelStyleDefault::DefaultBehavior Properties
LabelStyleDefault::DefaultBehavior Properties
Collapse All

The properties of LabelStyleDefault::DefaultBehavior are listed here.

Public Properties
Public Property | Description
InsertOption | Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.
InsideCurveOption | Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.
OrientationReference | Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.
Links
Public Properties


LabelStyleDefault::DefaultBehavior::InsertOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class > LabelStyleDefault::DefaultBehavior Properties > LabelStyleDefault::DefaultBehavior::InsertOption Property
LabelStyleDefault::DefaultBehavior::InsertOption Property
Collapse All

Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.

C#
public PropertyEnum<LabelInsertionType> InsertOption;
Visual Basic
Public Property InsertOption() As PropertyEnum<LabelInsertionType>
Remarks
  1. Applies only when the Orientation Reference option is set to Object and the objects are lines, arc segments, or spline segments.
  2. Plan Readable should be set to True when using the Top or Bottom settings.
Links
LabelStyleDefault::DefaultBehavior Class, LabelStyleDefault::DefaultBehavior Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultBehavior::InsideCurveOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class > LabelStyleDefault::DefaultBehavior Properties > LabelStyleDefault::DefaultBehavior::InsideCurveOption Property
LabelStyleDefault::DefaultBehavior::InsideCurveOption Property
Collapse All

Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.

C#
public PropertyEnum<LabelInsideCurveType> InsideCurveOption;
Visual Basic
Public Property InsideCurveOption() As PropertyEnum<LabelInsideCurveType>
Remarks

If true: Moves label components on the outside of curve to the inside of curve. The components maintain the same offset and rotation. If false: All label components remain as composed. This is the default setting. Available only for curve label styles. This setting has precedence over any forced insertion setting.

Links
LabelStyleDefault::DefaultBehavior Class, LabelStyleDefault::DefaultBehavior Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultBehavior::OrientationReference Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class > LabelStyleDefault::DefaultBehavior Properties > LabelStyleDefault::DefaultBehavior::OrientationReference Property
LabelStyleDefault::DefaultBehavior::OrientationReference Property
Collapse All

Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.

C#
public PropertyEnum<OrientationReferenceType> OrientationReference;
Visual Basic
Public Property OrientationReference() As PropertyEnum<OrientationReferenceType>
Links
LabelStyleDefault::DefaultBehavior Class, LabelStyleDefault::DefaultBehavior Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultComponents Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class
LabelStyleDefault::DefaultComponents Class
Collapse All

The component related properties of the default label style settings.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultComponents
C#
public class LabelStyleDefault::DefaultComponents : TreeOidWrapper;
Visual Basic
Public Class LabelStyleDefault::DefaultComponents
Inherits TreeOidWrapper
Links
LabelStyleDefault::DefaultComponents Properties, LabelStyleDefault::DefaultComponents Members, Class Hierarchy


LabelStyleDefault::DefaultComponents Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Members
LabelStyleDefault::DefaultComponents Members
Collapse All

The following tables list the members exposed by LabelStyleDefault::DefaultComponents.

Public Properties
Public Property | Description
Color | Gets the color for label components.
Linetype | Gets the linetype for label components.
Lineweight | Gets the lineweight for label components.
TextHeight | Gets the plotted height for label text.
Links
Public Properties


LabelStyleDefault::DefaultComponents Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Properties
LabelStyleDefault::DefaultComponents Properties
Collapse All

The properties of LabelStyleDefault::DefaultComponents are listed here.

Public Properties
Public Property | Description
Color | Gets the color for label components.
Linetype | Gets the linetype for label components.
Lineweight | Gets the lineweight for label components.
TextHeight | Gets the plotted height for label text.
Links
Public Properties


LabelStyleDefault::DefaultComponents::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Properties > LabelStyleDefault::DefaultComponents::Color Property
LabelStyleDefault::DefaultComponents::Color Property
Collapse All

Gets the color for label components.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleDefault::DefaultComponents Class, LabelStyleDefault::DefaultComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultComponents::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Properties > LabelStyleDefault::DefaultComponents::Linetype Property
LabelStyleDefault::DefaultComponents::Linetype Property
Collapse All

Gets the linetype for label components.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleDefault::DefaultComponents Class, LabelStyleDefault::DefaultComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultComponents::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Properties > LabelStyleDefault::DefaultComponents::Lineweight Property
LabelStyleDefault::DefaultComponents::Lineweight Property
Collapse All

Gets the lineweight for label components.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleDefault::DefaultComponents Class, LabelStyleDefault::DefaultComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultComponents::TextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Properties > LabelStyleDefault::DefaultComponents::TextHeight Property
LabelStyleDefault::DefaultComponents::TextHeight Property
Collapse All

Gets the plotted height for label text.

C#
public PropertyDouble TextHeight;
Visual Basic
Public Property TextHeight() As PropertyDouble
Links
LabelStyleDefault::DefaultComponents Class, LabelStyleDefault::DefaultComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class
LabelStyleDefault::DefaultDraggedStateComponents Class
Collapse All

The dragged state components related properties of the default label style settings.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultDraggedStateComponents
C#
public class LabelStyleDefault::DefaultDraggedStateComponents : TreeOidWrapper;
Visual Basic
Public Class LabelStyleDefault::DefaultDraggedStateComponents
Inherits TreeOidWrapper
Links
LabelStyleDefault::DefaultDraggedStateComponents Properties, LabelStyleDefault::DefaultDraggedStateComponents Members, Class Hierarchy


LabelStyleDefault::DefaultDraggedStateComponents Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Members
LabelStyleDefault::DefaultDraggedStateComponents Members
Collapse All

The following tables list the members exposed by LabelStyleDefault::DefaultDraggedStateComponents.

Public Properties
Public Property | Description
BorderType | Gets the shape of the border, either rounded or rectangular.
BorderVisibility | Gets the boolean value that specifies whether a border is visible for dragged labels.
Color | Gets the color for dragged components.
DisplayType | Gets the enum value that specifies how label content is displayed after it is dragged from its default position.
Gap | Gets the distance between the leader and the label text.
LeaderAttachment | Gets the location where a leader hook is drawn in relation to label content.
LeaderJustification | Gets the boolean value that specifies the justification of label text in relation to the leader.
Linetype | Gets the linetype for dragged components.
Lineweight | Gets the lineweight for dragged components.
TextHeight | Gets the plotted height for all text components.
UseBackgroundMask | Gets the boolean value that specifies whether use background mask when drawing.
Links
Public Properties


LabelStyleDefault::DefaultDraggedStateComponents Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties
LabelStyleDefault::DefaultDraggedStateComponents Properties
Collapse All

The properties of LabelStyleDefault::DefaultDraggedStateComponents are listed here.

Public Properties
Public Property | Description
BorderType | Gets the shape of the border, either rounded or rectangular.
BorderVisibility | Gets the boolean value that specifies whether a border is visible for dragged labels.
Color | Gets the color for dragged components.
DisplayType | Gets the enum value that specifies how label content is displayed after it is dragged from its default position.
Gap | Gets the distance between the leader and the label text.
LeaderAttachment | Gets the location where a leader hook is drawn in relation to label content.
LeaderJustification | Gets the boolean value that specifies the justification of label text in relation to the leader.
Linetype | Gets the linetype for dragged components.
Lineweight | Gets the lineweight for dragged components.
TextHeight | Gets the plotted height for all text components.
UseBackgroundMask | Gets the boolean value that specifies whether use background mask when drawing.
Links
Public Properties


LabelStyleDefault::DefaultDraggedStateComponents::BorderType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::BorderType Property
LabelStyleDefault::DefaultDraggedStateComponents::BorderType Property
Collapse All

Gets the shape of the border, either rounded or rectangular.

C#
public PropertyEnum<TextBorderType> BorderType;
Visual Basic
Public Property BorderType() As PropertyEnum<TextBorderType>
Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::BorderVisibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::BorderVisibility Property
LabelStyleDefault::DefaultDraggedStateComponents::BorderVisibility Property
Collapse All

Gets the boolean value that specifies whether a border is visible for dragged labels.

C#
public PropertyBoolean BorderVisibility;
Visual Basic
Public Property BorderVisibility() As PropertyBoolean
Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::Color Property
LabelStyleDefault::DefaultDraggedStateComponents::Color Property
Collapse All

Gets the color for dragged components.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::DisplayType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::DisplayType Property
LabelStyleDefault::DefaultDraggedStateComponents::DisplayType Property
Collapse All

Gets the enum value that specifies how label content is displayed after it is dragged from its default position.

C#
public PropertyEnum<LabelContentDisplayType> DisplayType;
Visual Basic
Public Property DisplayType() As PropertyEnum<LabelContentDisplayType>
Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::Gap Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::Gap Property
LabelStyleDefault::DefaultDraggedStateComponents::Gap Property
Collapse All

Gets the distance between the leader and the label text.

C#
public PropertyDouble Gap;
Visual Basic
Public Property Gap() As PropertyDouble
Remarks

The gap value is also used to define the space between the border and the label text.

Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::LeaderAttachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::LeaderAttachment Property
LabelStyleDefault::DefaultDraggedStateComponents::LeaderAttachment Property
Collapse All

Gets the location where a leader hook is drawn in relation to label content.

C#
public PropertyEnum<LeaderAttachmentType> LeaderAttachment;
Visual Basic
Public Property LeaderAttachment() As PropertyEnum<LeaderAttachmentType>
Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::LeaderJustification Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::LeaderJustification Property
LabelStyleDefault::DefaultDraggedStateComponents::LeaderJustification Property
Collapse All

Gets the boolean value that specifies the justification of label text in relation to the leader.

C#
public PropertyBoolean LeaderJustification;
Visual Basic
Public Property LeaderJustification() As PropertyBoolean
Remarks

If true, text is left-justified when the leader is on the left, and right-justified when the leader is on the right, as shown in the following illustration. This is the default setting. If false, text is left-justified regardless of leader location.

Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::Linetype Property
LabelStyleDefault::DefaultDraggedStateComponents::Linetype Property
Collapse All

Gets the linetype for dragged components.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::Lineweight Property
LabelStyleDefault::DefaultDraggedStateComponents::Lineweight Property
Collapse All

Gets the lineweight for dragged components.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::TextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::TextHeight Property
LabelStyleDefault::DefaultDraggedStateComponents::TextHeight Property
Collapse All

Gets the plotted height for all text components.

C#
public PropertyDouble TextHeight;
Visual Basic
Public Property TextHeight() As PropertyDouble
Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultDraggedStateComponents::UseBackgroundMask Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties > LabelStyleDefault::DefaultDraggedStateComponents::UseBackgroundMask Property
LabelStyleDefault::DefaultDraggedStateComponents::UseBackgroundMask Property
Collapse All

Gets the boolean value that specifies whether use background mask when drawing.

C#
public PropertyBoolean UseBackgroundMask;
Visual Basic
Public Property UseBackgroundMask() As PropertyBoolean
Links
LabelStyleDefault::DefaultDraggedStateComponents Class, LabelStyleDefault::DefaultDraggedStateComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class
LabelStyleDefault::DefaultLabel Class
Collapse All

The label related properties of the default label style settings.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultLabel
C#
public class LabelStyleDefault::DefaultLabel : TreeOidWrapper;
Visual Basic
Public Class LabelStyleDefault::DefaultLabel
Inherits TreeOidWrapper
Links
LabelStyleDefault::DefaultLabel Properties, LabelStyleDefault::DefaultLabel Members, Class Hierarchy


LabelStyleDefault::DefaultLabel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class > LabelStyleDefault::DefaultLabel Members
LabelStyleDefault::DefaultLabel Members
Collapse All

The following tables list the members exposed by LabelStyleDefault::DefaultLabel.

Public Properties
Public Property | Description
Layer | Gets the default layer for all label styles in a drawing.
TextStyle | Gets the default text style for all label text components in a drawing.
Visibility | Gets the boolean value that specifies visibility of labels in the drawing (independent of layer settings).
Links
Public Properties


LabelStyleDefault::DefaultLabel Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class > LabelStyleDefault::DefaultLabel Properties
LabelStyleDefault::DefaultLabel Properties
Collapse All

The properties of LabelStyleDefault::DefaultLabel are listed here.

Public Properties
Public Property | Description
Layer | Gets the default layer for all label styles in a drawing.
TextStyle | Gets the default text style for all label text components in a drawing.
Visibility | Gets the boolean value that specifies visibility of labels in the drawing (independent of layer settings).
Links
Public Properties


LabelStyleDefault::DefaultLabel::Layer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class > LabelStyleDefault::DefaultLabel Properties > LabelStyleDefault::DefaultLabel::Layer Property
LabelStyleDefault::DefaultLabel::Layer Property
Collapse All

Gets the default layer for all label styles in a drawing.

C#
public PropertyLayer Layer;
Visual Basic
Public Property Layer() As PropertyLayer
Links
LabelStyleDefault::DefaultLabel Class, LabelStyleDefault::DefaultLabel Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLabel::TextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class > LabelStyleDefault::DefaultLabel Properties > LabelStyleDefault::DefaultLabel::TextStyle Property
LabelStyleDefault::DefaultLabel::TextStyle Property
Collapse All

Gets the default text style for all label text components in a drawing.

C#
public PropertyString TextStyle;
Visual Basic
Public Property TextStyle() As PropertyString
Links
LabelStyleDefault::DefaultLabel Class, LabelStyleDefault::DefaultLabel Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLabel::Visibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class > LabelStyleDefault::DefaultLabel Properties > LabelStyleDefault::DefaultLabel::Visibility Property
LabelStyleDefault::DefaultLabel::Visibility Property
Collapse All

Gets the boolean value that specifies visibility of labels in the drawing (independent of layer settings).

C#
public PropertyBoolean Visibility;
Visual Basic
Public Property Visibility() As PropertyBoolean
Remarks

Tip: use this setting to quickly turn all labels in the drawing off or on.

Links
LabelStyleDefault::DefaultLabel Class, LabelStyleDefault::DefaultLabel Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLeader Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class
LabelStyleDefault::DefaultLeader Class
Collapse All

The leader related properties of the default label style settings.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultLeader
C#
public class LabelStyleDefault::DefaultLeader : TreeOidWrapper;
Visual Basic
Public Class LabelStyleDefault::DefaultLeader
Inherits TreeOidWrapper
Links
LabelStyleDefault::DefaultLeader Properties, LabelStyleDefault::DefaultLeader Members, Class Hierarchy


LabelStyleDefault::DefaultLeader Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Members
LabelStyleDefault::DefaultLeader Members
Collapse All

The following tables list the members exposed by LabelStyleDefault::DefaultLeader.

Public Properties
Public Property | Description
ArrowheadSize | Gets the size of the arrow head.
ArrowheadStyle | Gets the arrow head style for a leader.
Color | Gets the color for leaders.
Linetype | Gets the linetype for leaders.
Lineweight | Gets the lineweight for leaders.
Shape | Gets the enum value that specifies the shape of the leader.
Visibility | Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.
Links
Public Properties


LabelStyleDefault::DefaultLeader Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties
LabelStyleDefault::DefaultLeader Properties
Collapse All

The properties of LabelStyleDefault::DefaultLeader are listed here.

Public Properties
Public Property | Description
ArrowheadSize | Gets the size of the arrow head.
ArrowheadStyle | Gets the arrow head style for a leader.
Color | Gets the color for leaders.
Linetype | Gets the linetype for leaders.
Lineweight | Gets the lineweight for leaders.
Shape | Gets the enum value that specifies the shape of the leader.
Visibility | Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.
Links
Public Properties


LabelStyleDefault::DefaultLeader::ArrowheadSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties > LabelStyleDefault::DefaultLeader::ArrowheadSize Property
LabelStyleDefault::DefaultLeader::ArrowheadSize Property
Collapse All

Gets the size of the arrow head.

C#
public PropertyDouble ArrowheadSize;
Visual Basic
Public Property ArrowheadSize() As PropertyDouble
Remarks

The default arrow head size is defined in plot units (either inches or millimeters). The plot units are determined by the drawing units established in the drawing settings.

Links
LabelStyleDefault::DefaultLeader Class, LabelStyleDefault::DefaultLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLeader::ArrowheadStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties > LabelStyleDefault::DefaultLeader::ArrowheadStyle Property
LabelStyleDefault::DefaultLeader::ArrowheadStyle Property
Collapse All

Gets the arrow head style for a leader.

C#
public PropertyString ArrowheadStyle;
Visual Basic
Public Property ArrowheadStyle() As PropertyString
Links
LabelStyleDefault::DefaultLeader Class, LabelStyleDefault::DefaultLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLeader::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties > LabelStyleDefault::DefaultLeader::Color Property
LabelStyleDefault::DefaultLeader::Color Property
Collapse All

Gets the color for leaders.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleDefault::DefaultLeader Class, LabelStyleDefault::DefaultLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLeader::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties > LabelStyleDefault::DefaultLeader::Linetype Property
LabelStyleDefault::DefaultLeader::Linetype Property
Collapse All

Gets the linetype for leaders.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleDefault::DefaultLeader Class, LabelStyleDefault::DefaultLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLeader::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties > LabelStyleDefault::DefaultLeader::Lineweight Property
LabelStyleDefault::DefaultLeader::Lineweight Property
Collapse All

Gets the lineweight for leaders.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleDefault::DefaultLeader Class, LabelStyleDefault::DefaultLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLeader::Shape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties > LabelStyleDefault::DefaultLeader::Shape Property
LabelStyleDefault::DefaultLeader::Shape Property
Collapse All

Gets the enum value that specifies the shape of the leader.

C#
public PropertyEnum<LeaderShapeType> Shape;
Visual Basic
Public Property Shape() As PropertyEnum<LeaderShapeType>
Links
LabelStyleDefault::DefaultLeader Class, LabelStyleDefault::DefaultLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultLeader::Visibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties > LabelStyleDefault::DefaultLeader::Visibility Property
LabelStyleDefault::DefaultLeader::Visibility Property
Collapse All

Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.

C#
public PropertyBoolean Visibility;
Visual Basic
Public Property Visibility() As PropertyBoolean
Links
LabelStyleDefault::DefaultLeader Class, LabelStyleDefault::DefaultLeader Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultPlanReadability Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class
LabelStyleDefault::DefaultPlanReadability Class
Collapse All

The plan readability related properties of the default label style settings.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultPlanReadability
C#
public class LabelStyleDefault::DefaultPlanReadability : TreeOidWrapper;
Visual Basic
Public Class LabelStyleDefault::DefaultPlanReadability
Inherits TreeOidWrapper
Links
LabelStyleDefault::DefaultPlanReadability Properties, LabelStyleDefault::DefaultPlanReadability Members, Class Hierarchy


LabelStyleDefault::DefaultPlanReadability Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class > LabelStyleDefault::DefaultPlanReadability Members
LabelStyleDefault::DefaultPlanReadability Members
Collapse All

The following tables list the members exposed by LabelStyleDefault::DefaultPlanReadability.

Public Properties
Public Property | Description
FlipAnchorsWithText | Gets the boolean that specifies whether flip anchors with text.
PlanReadable | Gets the boolean that specifies whether all text components in labels can be read easily in plan view.
PlanReadableBias | Gets the angle at which label text flips 180 degrees to remain plan readable.
Links
Public Properties


LabelStyleDefault::DefaultPlanReadability Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class > LabelStyleDefault::DefaultPlanReadability Properties
LabelStyleDefault::DefaultPlanReadability Properties
Collapse All

The properties of LabelStyleDefault::DefaultPlanReadability are listed here.

Public Properties
Public Property | Description
FlipAnchorsWithText | Gets the boolean that specifies whether flip anchors with text.
PlanReadable | Gets the boolean that specifies whether all text components in labels can be read easily in plan view.
PlanReadableBias | Gets the angle at which label text flips 180 degrees to remain plan readable.
Links
Public Properties


LabelStyleDefault::DefaultPlanReadability::FlipAnchorsWithText Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class > LabelStyleDefault::DefaultPlanReadability Properties > LabelStyleDefault::DefaultPlanReadability::FlipAnchorsWithText Property
LabelStyleDefault::DefaultPlanReadability::FlipAnchorsWithText Property
Collapse All

Gets the boolean that specifies whether flip anchors with text.

C#
public PropertyBoolean FlipAnchorsWithText;
Visual Basic
Public Property FlipAnchorsWithText() As PropertyBoolean
Remarks

If true: Ensures that if text is rotated to make plan-readable, the anchors will also be flipped. If false: The flipped label always looks like a mirror of the original.

Links
LabelStyleDefault::DefaultPlanReadability Class, LabelStyleDefault::DefaultPlanReadability Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultPlanReadability::PlanReadable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class > LabelStyleDefault::DefaultPlanReadability Properties > LabelStyleDefault::DefaultPlanReadability::PlanReadable Property
LabelStyleDefault::DefaultPlanReadability::PlanReadable Property
Collapse All

Gets the boolean that specifies whether all text components in labels can be read easily in plan view.

C#
public PropertyBoolean PlanReadable;
Visual Basic
Public Property PlanReadable() As PropertyBoolean
Remarks

If true: Rotates text to insure that it can be read easily in plan view or as if viewed from an angle at the bottom or right side of the screen/paper. If false: Displays Text as inserted. This option applies only to text components in labels.

Links
LabelStyleDefault::DefaultPlanReadability Class, LabelStyleDefault::DefaultPlanReadability Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDefault::DefaultPlanReadability::PlanReadableBias Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class > LabelStyleDefault::DefaultPlanReadability Properties > LabelStyleDefault::DefaultPlanReadability::PlanReadableBias Property
LabelStyleDefault::DefaultPlanReadability::PlanReadableBias Property
Collapse All

Gets the angle at which label text flips 180 degrees to remain plan readable.

C#
public PropertyDouble PlanReadableBias;
Visual Basic
Public Property PlanReadableBias() As PropertyDouble
Links
LabelStyleDefault::DefaultPlanReadability Class, LabelStyleDefault::DefaultPlanReadability Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class
Collapse All

Direction arrow style settings for label direction arrow components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDirectionArrowComponent::StyleDirectionArrow
C#
public class LabelStyleDirectionArrowComponent::StyleDirectionArrow : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleDirectionArrowComponent::StyleDirectionArrow
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Class Hierarchy


LabelStyleDirectionArrowComponent::StyleDirectionArrow Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Members
LabelStyleDirectionArrowComponent::StyleDirectionArrow Members
Collapse All

The following tables list the members exposed by LabelStyleDirectionArrowComponent::StyleDirectionArrow.

Public Properties
Public Property | Description
ArrowheadSize | Gets the size of arrow head in plot unit.
ArrowheadStyle | Gets the arrow head style.
Color | Gets the color of direction arrow component.
FixedLength | Gets whether the arrow length is controlled by the length setting or by the length of the object being labeled.... more
LengthOrMinimumLength | Gets the length of direction arrow.
Linetype | Gets the line type of the direction arrow component.
Lineweight | Gets the line weight of the direction arrow component.
RotationAngle | Gets the angle for direction arrow component.
XOffset | Gets the offset distance between the mid-point of the direction arrow and the anchor component in the X direction.
YOffset | Gets the offset distance between the mid-point of the direction arrow and the anchor component in the Y direction.
Links
Public Properties


LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties
LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties
Collapse All

The properties of LabelStyleDirectionArrowComponent::StyleDirectionArrow are listed here.

Public Properties
Public Property | Description
ArrowheadSize | Gets the size of arrow head in plot unit.
ArrowheadStyle | Gets the arrow head style.
Color | Gets the color of direction arrow component.
FixedLength | Gets whether the arrow length is controlled by the length setting or by the length of the object being labeled.... more
LengthOrMinimumLength | Gets the length of direction arrow.
Linetype | Gets the line type of the direction arrow component.
Lineweight | Gets the line weight of the direction arrow component.
RotationAngle | Gets the angle for direction arrow component.
XOffset | Gets the offset distance between the mid-point of the direction arrow and the anchor component in the X direction.
YOffset | Gets the offset distance between the mid-point of the direction arrow and the anchor component in the Y direction.
Links
Public Properties


LabelStyleDirectionArrowComponent::StyleDirectionArrow::ArrowheadSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::ArrowheadSize Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::ArrowheadSize Property
Collapse All

Gets the size of arrow head in plot unit.

C#
public PropertyDouble ArrowheadSize;
Visual Basic
Public Property ArrowheadSize() As PropertyDouble
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow::ArrowheadStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::ArrowheadStyle Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::ArrowheadStyle Property
Collapse All

Gets the arrow head style.

C#
public PropertyString ArrowheadStyle;
Visual Basic
Public Property ArrowheadStyle() As PropertyString
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::Color Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::Color Property
Collapse All

Gets the color of direction arrow component.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow::FixedLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::FixedLength Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::FixedLength Property
Collapse All

Gets whether the arrow length is controlled by the length setting or by the length of the object being labeled.

C#
public PropertyBoolean FixedLength;
Visual Basic
Public Property FixedLength() As PropertyBoolean
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow::LengthOrMinimumLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::LengthOrMinimumLength Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::LengthOrMinimumLength Property
Collapse All

Gets the length of direction arrow.

C#
public PropertyDouble LengthOrMinimumLength;
Visual Basic
Public Property LengthOrMinimumLength() As PropertyDouble
Remarks

If the FixedLength set to true,it get the length of direction arrow's fixed length.. If the FixedLength set to false, it get the minimum length for direction arrow.

Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::Linetype Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::Linetype Property
Collapse All

Gets the line type of the direction arrow component.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::Lineweight Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::Lineweight Property
Collapse All

Gets the line weight of the direction arrow component.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow::RotationAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::RotationAngle Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::RotationAngle Property
Collapse All

Gets the angle for direction arrow component.

C#
public PropertyDouble RotationAngle;
Visual Basic
Public Property RotationAngle() As PropertyDouble
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow::XOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::XOffset Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::XOffset Property
Collapse All

Gets the offset distance between the mid-point of the direction arrow and the anchor component in the X direction.

C#
public PropertyDouble XOffset;
Visual Basic
Public Property XOffset() As PropertyDouble
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleDirectionArrow::YOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties > LabelStyleDirectionArrowComponent::StyleDirectionArrow::YOffset Property
LabelStyleDirectionArrowComponent::StyleDirectionArrow::YOffset Property
Collapse All

Gets the offset distance between the mid-point of the direction arrow and the anchor component in the Y direction.

C#
public PropertyDouble YOffset;
Visual Basic
Public Property YOffset() As PropertyDouble
Links
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class, LabelStyleDirectionArrowComponent::StyleDirectionArrow Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleGeneral Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class
LabelStyleDirectionArrowComponent::StyleGeneral Class
Collapse All

General style settings for label direction arrow components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDirectionArrowComponent::StyleGeneral
C#
public class LabelStyleDirectionArrowComponent::StyleGeneral : CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleDirectionArrowComponent::StyleGeneral
Inherits CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleDirectionArrowComponent::StyleGeneral Properties, LabelStyleDirectionArrowComponent::StyleGeneral Members, Class Hierarchy


LabelStyleDirectionArrowComponent::StyleGeneral Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Members
LabelStyleDirectionArrowComponent::StyleGeneral Members
Collapse All

The following tables list the members exposed by LabelStyleDirectionArrowComponent::StyleGeneral.

Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the direction arrow component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the direction arrow component is attached.
Name | Gets the name for direction arrow component.
SpanOutsideSegments | Gets whether this component refers to the properties of outside segments.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the direction arrow component is visible in the label style.
Links
Public Properties


LabelStyleDirectionArrowComponent::StyleGeneral Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties
LabelStyleDirectionArrowComponent::StyleGeneral Properties
Collapse All

The properties of LabelStyleDirectionArrowComponent::StyleGeneral are listed here.

Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the direction arrow component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the direction arrow component is attached.
Name | Gets the name for direction arrow component.
SpanOutsideSegments | Gets whether this component refers to the properties of outside segments.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the direction arrow component is visible in the label style.
Links
Public Properties


LabelStyleDirectionArrowComponent::StyleGeneral::AnchorComponent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties > LabelStyleDirectionArrowComponent::StyleGeneral::AnchorComponent Property
LabelStyleDirectionArrowComponent::StyleGeneral::AnchorComponent Property
Collapse All

Gets a reference object for positioning the point of the direction arrow component.

C#
public PropertyString AnchorComponent;
Visual Basic
Public Property AnchorComponent() As PropertyString
Links
LabelStyleDirectionArrowComponent::StyleGeneral Class, LabelStyleDirectionArrowComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleGeneral::AnchorLocation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties > LabelStyleDirectionArrowComponent::StyleGeneral::AnchorLocation Property
LabelStyleDirectionArrowComponent::StyleGeneral::AnchorLocation Property
Collapse All

Gets the location on the anchor component where the point of the block component is attached.

C#
public PropertyAnchorPoint AnchorLocation;
Visual Basic
Public Property AnchorLocation() As PropertyAnchorPoint
Links
LabelStyleDirectionArrowComponent::StyleGeneral Class, LabelStyleDirectionArrowComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleGeneral::AnchorPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties > LabelStyleDirectionArrowComponent::StyleGeneral::AnchorPoint Property
LabelStyleDirectionArrowComponent::StyleGeneral::AnchorPoint Property deprecated
Collapse All

Gets the location on the anchor component where the point of the direction arrow component is attached.

C#
public PropertyEnum<AnchorLocationType> AnchorPoint;
Visual Basic
Public Property AnchorPoint() As PropertyEnum<AnchorLocationType>
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleDirectionArrowComponent.StyleGeneral.AnchorLocation instead.

Links
LabelStyleDirectionArrowComponent::StyleGeneral Class, LabelStyleDirectionArrowComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleGeneral::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties > LabelStyleDirectionArrowComponent::StyleGeneral::Name Property
LabelStyleDirectionArrowComponent::StyleGeneral::Name Property
Collapse All

Gets the name for direction arrow component.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
LabelStyleDirectionArrowComponent::StyleGeneral Class, LabelStyleDirectionArrowComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleGeneral::SpanOutsideSegments Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties > LabelStyleDirectionArrowComponent::StyleGeneral::SpanOutsideSegments Property
LabelStyleDirectionArrowComponent::StyleGeneral::SpanOutsideSegments Property
Collapse All

Gets whether this component refers to the properties of outside segments.

C#
public PropertyBoolean SpanOutsideSegments;
Visual Basic
Public Property SpanOutsideSegments() As PropertyBoolean
Links
LabelStyleDirectionArrowComponent::StyleGeneral Class, LabelStyleDirectionArrowComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleGeneral::UsedIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties > LabelStyleDirectionArrowComponent::StyleGeneral::UsedIn Property
LabelStyleDirectionArrowComponent::StyleGeneral::UsedIn Property
Collapse All

Gets the display mode in which the component is used;for example if this is set to label, only display the component when display mode is set to label.

C#
public PropertyEnum<LayoutModeType> UsedIn;
Visual Basic
Public Property UsedIn() As PropertyEnum<LayoutModeType>
Links
LabelStyleDirectionArrowComponent::StyleGeneral Class, LabelStyleDirectionArrowComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleDirectionArrowComponent::StyleGeneral::Visible Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties > LabelStyleDirectionArrowComponent::StyleGeneral::Visible Property
LabelStyleDirectionArrowComponent::StyleGeneral::Visible Property
Collapse All

Gets whether the direction arrow component is visible in the label style.

C#
public PropertyBoolean Visible;
Visual Basic
Public Property Visible() As PropertyBoolean
Links
LabelStyleDirectionArrowComponent::StyleGeneral Class, LabelStyleDirectionArrowComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class
LabelStyleLineComponent::StyleGeneral Class
Collapse All

General style settings for line labels.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleLineComponent::StyleGeneral
C#
public class LabelStyleLineComponent::StyleGeneral : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleLineComponent::StyleGeneral
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleLineComponent::StyleGeneral Properties, LabelStyleLineComponent::StyleGeneral Members, Class Hierarchy


LabelStyleLineComponent::StyleGeneral Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Members
LabelStyleLineComponent::StyleGeneral Members
Collapse All

The following tables list the members exposed by LabelStyleLineComponent::StyleGeneral.

Public Properties
Public Property | Description
EndAnchorPoint | Gets the location on the end point anchor component where the end point of the line component is attached.
EndPointAnchorComponent | Gets a reference object for positioning the end point of the line component.
EndPointAnchorPoint | Gets the location on the end point anchor component where the end point of the line component is attached.
Name | Gets the name for line component.
StartAnchorPoint | Gets the location on the start point anchor component where the start point of the line component is attached.
StartPointAnchorComponent | Gets a reference object for positioning the start point of the line component.
StartPointAnchorPoint | Gets the location on the start point anchor component where the start point of the line component is attached.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
UseEndPointAnchor | Gets the method for defining the line component.
Visible | Gets whether the line component is visible in the label style.
Links
Public Properties


LabelStyleLineComponent::StyleGeneral Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties
LabelStyleLineComponent::StyleGeneral Properties
Collapse All

The properties of LabelStyleLineComponent::StyleGeneral are listed here.

Public Properties
Public Property | Description
EndAnchorPoint | Gets the location on the end point anchor component where the end point of the line component is attached.
EndPointAnchorComponent | Gets a reference object for positioning the end point of the line component.
EndPointAnchorPoint | Gets the location on the end point anchor component where the end point of the line component is attached.
Name | Gets the name for line component.
StartAnchorPoint | Gets the location on the start point anchor component where the start point of the line component is attached.
StartPointAnchorComponent | Gets a reference object for positioning the start point of the line component.
StartPointAnchorPoint | Gets the location on the start point anchor component where the start point of the line component is attached.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
UseEndPointAnchor | Gets the method for defining the line component.
Visible | Gets whether the line component is visible in the label style.
Links
Public Properties


LabelStyleLineComponent::StyleGeneral::EndAnchorPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::EndAnchorPoint Property
LabelStyleLineComponent::StyleGeneral::EndAnchorPoint Property
Collapse All

Gets the location on the end point anchor component where the end point of the line component is attached.

C#
public PropertyAnchorPoint EndAnchorPoint;
Visual Basic
Public Property EndAnchorPoint() As PropertyAnchorPoint
Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral::EndPointAnchorComponent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::EndPointAnchorComponent Property
LabelStyleLineComponent::StyleGeneral::EndPointAnchorComponent Property
Collapse All

Gets a reference object for positioning the end point of the line component.

C#
public PropertyString EndPointAnchorComponent;
Visual Basic
Public Property EndPointAnchorComponent() As PropertyString
Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral::EndPointAnchorPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::EndPointAnchorPoint Property
LabelStyleLineComponent::StyleGeneral::EndPointAnchorPoint Property deprecated
Collapse All

Gets the location on the end point anchor component where the end point of the line component is attached.

C#
public PropertyEnum<AnchorLocationType> EndPointAnchorPoint;
Visual Basic
Public Property EndPointAnchorPoint() As PropertyEnum<AnchorLocationType>
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleLineComponent.StyleGeneral.EndAnchorPoint instead.

Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::Name Property
LabelStyleLineComponent::StyleGeneral::Name Property
Collapse All

Gets the name for line component.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral::StartAnchorPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::StartAnchorPoint Property
LabelStyleLineComponent::StyleGeneral::StartAnchorPoint Property
Collapse All

Gets the location on the start point anchor component where the start point of the line component is attached.

C#
public PropertyAnchorPoint StartAnchorPoint;
Visual Basic
Public Property StartAnchorPoint() As PropertyAnchorPoint
Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral::StartPointAnchorComponent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::StartPointAnchorComponent Property
LabelStyleLineComponent::StyleGeneral::StartPointAnchorComponent Property
Collapse All

Gets a reference object for positioning the start point of the line component.

C#
public PropertyString StartPointAnchorComponent;
Visual Basic
Public Property StartPointAnchorComponent() As PropertyString
Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral::StartPointAnchorPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::StartPointAnchorPoint Property
LabelStyleLineComponent::StyleGeneral::StartPointAnchorPoint Property deprecated
Collapse All

Gets the location on the start point anchor component where the start point of the line component is attached.

C#
public PropertyEnum<AnchorLocationType> StartPointAnchorPoint;
Visual Basic
Public Property StartPointAnchorPoint() As PropertyEnum<AnchorLocationType>
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleLineComponent.StyleGeneral.StartAnchorPoint instead.

Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral::UsedIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::UsedIn Property
LabelStyleLineComponent::StyleGeneral::UsedIn Property
Collapse All

Gets the display mode in which the component is used;for example if this is set to label, only display the component when display mode is set to label.

C#
public PropertyEnum<LayoutModeType> UsedIn;
Visual Basic
Public Property UsedIn() As PropertyEnum<LayoutModeType>
Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral::UseEndPointAnchor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::UseEndPointAnchor Property
LabelStyleLineComponent::StyleGeneral::UseEndPointAnchor Property
Collapse All

Gets the method for defining the line component.

C#
public PropertyBoolean UseEndPointAnchor;
Visual Basic
Public Property UseEndPointAnchor() As PropertyBoolean
Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleGeneral::Visible Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties > LabelStyleLineComponent::StyleGeneral::Visible Property
LabelStyleLineComponent::StyleGeneral::Visible Property
Collapse All

Gets whether the line component is visible in the label style.

C#
public PropertyBoolean Visible;
Visual Basic
Public Property Visible() As PropertyBoolean
Links
LabelStyleLineComponent::StyleGeneral Class, LabelStyleLineComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class
LabelStyleLineComponent::StyleLine Class
Collapse All

Line style settings for line labels.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleLineComponent::StyleLine
C#
public class LabelStyleLineComponent::StyleLine : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleLineComponent::StyleLine
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleLineComponent::StyleLine Properties, LabelStyleLineComponent::StyleLine Members, Class Hierarchy


LabelStyleLineComponent::StyleLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Members
LabelStyleLineComponent::StyleLine Members
Collapse All

The following tables list the members exposed by LabelStyleLineComponent::StyleLine.

Public Properties
Public Property | Description
Angle | Gets the angle of the line component from the start point.
Color | Gets the color of the line component.
EndPointXOffset | Gets the offsets the line end point from the end point anchor point in the X direction.
EndPointYOffset | Gets the offsets the line end point from the end point anchor point in the Y direction.
Length | Gets the length of line component.
Linetype | Gets the line type of the line component.
Lineweight | Gets the line weight of the line component.
StartPointXOffset | Gets the offsets the line start point from the start point anchor point in the X direction.
StartPointYOffset | Gets the offsets the line start point from the start point anchor point in the Y direction.
Links
Public Properties


LabelStyleLineComponent::StyleLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties
LabelStyleLineComponent::StyleLine Properties
Collapse All

The properties of LabelStyleLineComponent::StyleLine are listed here.

Public Properties
Public Property | Description
Angle | Gets the angle of the line component from the start point.
Color | Gets the color of the line component.
EndPointXOffset | Gets the offsets the line end point from the end point anchor point in the X direction.
EndPointYOffset | Gets the offsets the line end point from the end point anchor point in the Y direction.
Length | Gets the length of line component.
Linetype | Gets the line type of the line component.
Lineweight | Gets the line weight of the line component.
StartPointXOffset | Gets the offsets the line start point from the start point anchor point in the X direction.
StartPointYOffset | Gets the offsets the line start point from the start point anchor point in the Y direction.
Links
Public Properties


LabelStyleLineComponent::StyleLine::Angle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties > LabelStyleLineComponent::StyleLine::Angle Property
LabelStyleLineComponent::StyleLine::Angle Property
Collapse All

Gets the angle of the line component from the start point.

C#
public PropertyDouble Angle;
Visual Basic
Public Property Angle() As PropertyDouble
Links
LabelStyleLineComponent::StyleLine Class, LabelStyleLineComponent::StyleLine Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleLine::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties > LabelStyleLineComponent::StyleLine::Color Property
LabelStyleLineComponent::StyleLine::Color Property
Collapse All

Gets the color of the line component.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleLineComponent::StyleLine Class, LabelStyleLineComponent::StyleLine Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleLine::EndPointXOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties > LabelStyleLineComponent::StyleLine::EndPointXOffset Property
LabelStyleLineComponent::StyleLine::EndPointXOffset Property
Collapse All

Gets the offsets the line end point from the end point anchor point in the X direction.

C#
public PropertyDouble EndPointXOffset;
Visual Basic
Public Property EndPointXOffset() As PropertyDouble
Links
LabelStyleLineComponent::StyleLine Class, LabelStyleLineComponent::StyleLine Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleLine::EndPointYOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties > LabelStyleLineComponent::StyleLine::EndPointYOffset Property
LabelStyleLineComponent::StyleLine::EndPointYOffset Property
Collapse All

Gets the offsets the line end point from the end point anchor point in the Y direction.

C#
public PropertyDouble EndPointYOffset;
Visual Basic
Public Property EndPointYOffset() As PropertyDouble
Links
LabelStyleLineComponent::StyleLine Class, LabelStyleLineComponent::StyleLine Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleLine::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties > LabelStyleLineComponent::StyleLine::Length Property
LabelStyleLineComponent::StyleLine::Length Property
Collapse All

Gets the length of line component.

C#
public PropertyDouble Length;
Visual Basic
Public Property Length() As PropertyDouble
Links
LabelStyleLineComponent::StyleLine Class, LabelStyleLineComponent::StyleLine Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleLine::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties > LabelStyleLineComponent::StyleLine::Linetype Property
LabelStyleLineComponent::StyleLine::Linetype Property
Collapse All

Gets the line type of the line component.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleLineComponent::StyleLine Class, LabelStyleLineComponent::StyleLine Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleLine::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties > LabelStyleLineComponent::StyleLine::Lineweight Property
LabelStyleLineComponent::StyleLine::Lineweight Property
Collapse All

Gets the line weight of the line component.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleLineComponent::StyleLine Class, LabelStyleLineComponent::StyleLine Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleLine::StartPointXOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties > LabelStyleLineComponent::StyleLine::StartPointXOffset Property
LabelStyleLineComponent::StyleLine::StartPointXOffset Property
Collapse All

Gets the offsets the line start point from the start point anchor point in the X direction.

C#
public PropertyDouble StartPointXOffset;
Visual Basic
Public Property StartPointXOffset() As PropertyDouble
Links
LabelStyleLineComponent::StyleLine Class, LabelStyleLineComponent::StyleLine Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleLineComponent::StyleLine::StartPointYOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties > LabelStyleLineComponent::StyleLine::StartPointYOffset Property
LabelStyleLineComponent::StyleLine::StartPointYOffset Property
Collapse All

Gets the offsets the line start point from the start point anchor point in the Y direction.

C#
public PropertyDouble StartPointYOffset;
Visual Basic
Public Property StartPointYOffset() As PropertyDouble
Links
LabelStyleLineComponent::StyleLine Class, LabelStyleLineComponent::StyleLine Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesNode Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesNode Class
LabelStylesNode Class
Collapse All

Base class for root label style classes, such as LabelStylesAlignmentRoot.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::DatabaseServices::Styles::LabelStylesRoot
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesAlignmentRoot
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesMatchLineRoot
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProfileRoot
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesPipeRoot
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesStructureRoot
    Autodesk::Civil::Roadway::DatabaseServices::Styles::LabelStylesIntersectionRoot
C#
public class LabelStylesNode : TreeOidWrapper;
Visual Basic
Public Class LabelStylesNode
Inherits TreeOidWrapper
Links
LabelStylesNode Properties, LabelStylesNode Members, Class Hierarchy


LabelStylesNode Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesNode Class > LabelStylesNode Members
LabelStylesNode Members
Collapse All

The following tables list the members exposed by LabelStylesNode.

Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
Links
Public Properties


LabelStylesNode Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesNode Class > LabelStylesNode Properties
LabelStylesNode Properties
Collapse All

The properties of LabelStylesNode are listed here.

Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
Links
Public Properties


LabelStylesNode::DefaultLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesNode Class > LabelStylesNode Properties > LabelStylesNode::DefaultLabelStyle Property
LabelStylesNode::DefaultLabelStyle Property
Collapse All

Gets the default vaules of label styles.

C#
public LabelStyleDefault DefaultLabelStyle;
Visual Basic
Public Property DefaultLabelStyle() As LabelStyleDefault
Links
LabelStylesNode Class, LabelStylesNode Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class
LabelStylesRoot Class
Collapse All

Root object for accessing all label styles in a CivilDocument.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::DatabaseServices::Styles::LabelStylesRoot
C#
public class LabelStylesRoot : LabelStylesNode;
Visual Basic
Public Class LabelStylesRoot
Inherits LabelStylesNode
Links
LabelStylesRoot Properties, LabelStylesRoot Members, Class Hierarchy


LabelStylesRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Members
LabelStylesRoot Members
Collapse All

The following tables list the members exposed by LabelStylesRoot.

Public Properties
Public Property | Description
AlignmentLabelStyles | Gets the root of all alignment label styles.
DefaultLabelStyle | Gets the default vaules of label styles.
GeneralCurveLabelStyles | Gets the collection of all general curve label styles.
GeneralLineLabelStyles | Gets the collection of all general line label styles.
GeneralLinkLabelStyles | Gets the collection of all general link label styles.
GeneralMarkerLabelStyles | Gets the collection of all general marker label styles.
GeneralNoteLabelStyles | Gets the collection of all general note label styles.
GeneralShapeLabelStyles | Gets the collection of all general shape label styles.
IntersectionLabelStyles | Gets the root of all intersection label styles.
MatchLineLabelStyles | Gets the root of all match line label styles.
ParcelLabelStyles | Gets the root of all parcel label styles.
PipeLabelStyles | Gets the root of all pipe label styles.
PointLabelStyles | Gets the root of all point label styles.
ProfileLabelStyles | Gets the root of all profile label styles.
ProfileViewLabelStyles | Gets the root of all profile view label styles.
ProjectionLabelStyles | Gets the root of all projection label styles.
SampleLineLabelStyles | Gets the root of all sample line label styles.
SectionLabelStyles | Gets the root of all section label styles.
SectionViewLabelStyles | Gets the root of all section view label styles.
StructureLabelStyles | Gets the root of all structure label styles.
SurfaceLabelStyles | Gets the root of all surface label styles.
ViewFrameLabelStyles | Gets the root of all view frame label styles.
Links
Public Properties


LabelStylesRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties
LabelStylesRoot Properties
Collapse All

The properties of LabelStylesRoot are listed here.

Public Properties
Public Property | Description
AlignmentLabelStyles | Gets the root of all alignment label styles.
GeneralCurveLabelStyles | Gets the collection of all general curve label styles.
GeneralLineLabelStyles | Gets the collection of all general line label styles.
GeneralLinkLabelStyles | Gets the collection of all general link label styles.
GeneralMarkerLabelStyles | Gets the collection of all general marker label styles.
GeneralNoteLabelStyles | Gets the collection of all general note label styles.
GeneralShapeLabelStyles | Gets the collection of all general shape label styles.
IntersectionLabelStyles | Gets the root of all intersection label styles.
MatchLineLabelStyles | Gets the root of all match line label styles.
ParcelLabelStyles | Gets the root of all parcel label styles.
PipeLabelStyles | Gets the root of all pipe label styles.
PointLabelStyles | Gets the root of all point label styles.
ProfileLabelStyles | Gets the root of all profile label styles.
ProfileViewLabelStyles | Gets the root of all profile view label styles.
ProjectionLabelStyles | Gets the root of all projection label styles.
SampleLineLabelStyles | Gets the root of all sample line label styles.
SectionLabelStyles | Gets the root of all section label styles.
SectionViewLabelStyles | Gets the root of all section view label styles.
StructureLabelStyles | Gets the root of all structure label styles.
SurfaceLabelStyles | Gets the root of all surface label styles.
ViewFrameLabelStyles | Gets the root of all view frame label styles.
Links
Public Properties


LabelStylesRoot::AlignmentLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::AlignmentLabelStyles Property
LabelStylesRoot::AlignmentLabelStyles Property
Collapse All

Gets the root of all alignment label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesAlignmentRoot AlignmentLabelStyles;
Visual Basic
Public Property AlignmentLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesAlignmentRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::GeneralCurveLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::GeneralCurveLabelStyles Property
LabelStylesRoot::GeneralCurveLabelStyles Property
Collapse All

Gets the collection of all general curve label styles.

C#
public LabelStyleCollection GeneralCurveLabelStyles;
Visual Basic
Public Property GeneralCurveLabelStyles() As LabelStyleCollection
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::GeneralLineLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::GeneralLineLabelStyles Property
LabelStylesRoot::GeneralLineLabelStyles Property
Collapse All

Gets the collection of all general line label styles.

C#
public LabelStyleCollection GeneralLineLabelStyles;
Visual Basic
Public Property GeneralLineLabelStyles() As LabelStyleCollection
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::GeneralLinkLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::GeneralLinkLabelStyles Property
LabelStylesRoot::GeneralLinkLabelStyles Property
Collapse All

Gets the collection of all general link label styles.

C#
public LabelStyleCollection GeneralLinkLabelStyles;
Visual Basic
Public Property GeneralLinkLabelStyles() As LabelStyleCollection
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::GeneralMarkerLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::GeneralMarkerLabelStyles Property
LabelStylesRoot::GeneralMarkerLabelStyles Property
Collapse All

Gets the collection of all general marker label styles.

C#
public LabelStyleCollection GeneralMarkerLabelStyles;
Visual Basic
Public Property GeneralMarkerLabelStyles() As LabelStyleCollection
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::GeneralNoteLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::GeneralNoteLabelStyles Property
LabelStylesRoot::GeneralNoteLabelStyles Property
Collapse All

Gets the collection of all general note label styles.

C#
public LabelStyleCollection GeneralNoteLabelStyles;
Visual Basic
Public Property GeneralNoteLabelStyles() As LabelStyleCollection
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::GeneralShapeLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::GeneralShapeLabelStyles Property
LabelStylesRoot::GeneralShapeLabelStyles Property
Collapse All

Gets the collection of all general shape label styles.

C#
public LabelStyleCollection GeneralShapeLabelStyles;
Visual Basic
Public Property GeneralShapeLabelStyles() As LabelStyleCollection
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::IntersectionLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::IntersectionLabelStyles Property
LabelStylesRoot::IntersectionLabelStyles Property
Collapse All

Gets the root of all intersection label styles.

C#
public Autodesk::Civil::Roadway::DatabaseServices::Styles::LabelStylesIntersectionRoot IntersectionLabelStyles;
Visual Basic
Public Property IntersectionLabelStyles() As Autodesk::Civil::Roadway::DatabaseServices::Styles::LabelStylesIntersectionRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::MatchLineLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::MatchLineLabelStyles Property
LabelStylesRoot::MatchLineLabelStyles Property
Collapse All

Gets the root of all match line label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesMatchLineRoot MatchLineLabelStyles;
Visual Basic
Public Property MatchLineLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesMatchLineRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::ParcelLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::ParcelLabelStyles Property
LabelStylesRoot::ParcelLabelStyles Property
Collapse All

Gets the root of all parcel label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesParcelRoot ParcelLabelStyles;
Visual Basic
Public Property ParcelLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesParcelRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::PipeLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::PipeLabelStyles Property
LabelStylesRoot::PipeLabelStyles Property
Collapse All

Gets the root of all pipe label styles.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesPipeRoot PipeLabelStyles;
Visual Basic
Public Property PipeLabelStyles() As Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesPipeRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::PointLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::PointLabelStyles Property
LabelStylesRoot::PointLabelStyles Property
Collapse All

Gets the root of all point label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesPointRoot PointLabelStyles;
Visual Basic
Public Property PointLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesPointRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::ProfileLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::ProfileLabelStyles Property
LabelStylesRoot::ProfileLabelStyles Property
Collapse All

Gets the root of all profile label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProfileRoot ProfileLabelStyles;
Visual Basic
Public Property ProfileLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProfileRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::ProfileViewLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::ProfileViewLabelStyles Property
LabelStylesRoot::ProfileViewLabelStyles Property
Collapse All

Gets the root of all profile view label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProfileViewRoot ProfileViewLabelStyles;
Visual Basic
Public Property ProfileViewLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProfileViewRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::ProjectionLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::ProjectionLabelStyles Property
LabelStylesRoot::ProjectionLabelStyles Property
Collapse All

Gets the root of all projection label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProjectionRoot ProjectionLabelStyles;
Visual Basic
Public Property ProjectionLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProjectionRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::SampleLineLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::SampleLineLabelStyles Property
LabelStylesRoot::SampleLineLabelStyles Property
Collapse All

Gets the root of all sample line label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesSampleLineRoot SampleLineLabelStyles;
Visual Basic
Public Property SampleLineLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesSampleLineRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::SectionLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::SectionLabelStyles Property
LabelStylesRoot::SectionLabelStyles Property
Collapse All

Gets the root of all section label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesSectionRoot SectionLabelStyles;
Visual Basic
Public Property SectionLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesSectionRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::SectionViewLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::SectionViewLabelStyles Property
LabelStylesRoot::SectionViewLabelStyles Property
Collapse All

Gets the root of all section view label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesSectionViewRoot SectionViewLabelStyles;
Visual Basic
Public Property SectionViewLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesSectionViewRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::StructureLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::StructureLabelStyles Property
LabelStylesRoot::StructureLabelStyles Property
Collapse All

Gets the root of all structure label styles.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesStructureRoot StructureLabelStyles;
Visual Basic
Public Property StructureLabelStyles() As Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesStructureRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::SurfaceLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::SurfaceLabelStyles Property
LabelStylesRoot::SurfaceLabelStyles Property
Collapse All

Gets the root of all surface label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesSurfaceRoot SurfaceLabelStyles;
Visual Basic
Public Property SurfaceLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesSurfaceRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStylesRoot::ViewFrameLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties > LabelStylesRoot::ViewFrameLabelStyles Property
LabelStylesRoot::ViewFrameLabelStyles Property
Collapse All

Gets the root of all view frame label styles.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesViewFrameRoot ViewFrameLabelStyles;
Visual Basic
Public Property ViewFrameLabelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesViewFrameRoot
Links
LabelStylesRoot Class, LabelStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class
LabelStyleTextComponent Class
Collapse All

Specifies the appearance and behavior of text feature labels in the drawing. Controls the appearance of the text itself.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTextComponent
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabelStyleText"))]
public class LabelStyleTextComponent : LabelStyleComponent;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabelStyleText"))>
Public Class LabelStyleTextComponent
Inherits LabelStyleComponent
Links
LabelStyleTextComponent Properties, LabelStyleTextComponent Members, Class Hierarchy


LabelStyleTextComponent Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class > LabelStyleTextComponent Members
LabelStyleTextComponent Members
Collapse All

The following tables list the members exposed by LabelStyleTextComponent.

Public Properties
Public Property | Description
Border | Gets the border style settings.
General | Gets the general style settings.
Text | Gets the text style settings.
Links
Public Properties


LabelStyleTextComponent Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class > LabelStyleTextComponent Properties
LabelStyleTextComponent Properties
Collapse All

The properties of LabelStyleTextComponent are listed here.

Public Properties
Public Property | Description
Border | Gets the border style settings.
General | Gets the general style settings.
Text | Gets the text style settings.
Links
Public Properties


LabelStyleTextComponent::Border Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class > LabelStyleTextComponent Properties > LabelStyleTextComponent::Border Property
LabelStyleTextComponent::Border Property
Collapse All

Gets the border style settings.

C#
public StyleBorder Border;
Visual Basic
Public Property Border() As StyleBorder
Links
LabelStyleTextComponent Class, LabelStyleTextComponent Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::General Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class > LabelStyleTextComponent Properties > LabelStyleTextComponent::General Property
LabelStyleTextComponent::General Property
Collapse All

Gets the general style settings.

C#
public StyleGeneral General;
Visual Basic
Public Property General() As StyleGeneral
Links
LabelStyleTextComponent Class, LabelStyleTextComponent Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::Text Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class > LabelStyleTextComponent Properties > LabelStyleTextComponent::Text Property
LabelStyleTextComponent::Text Property
Collapse All

Gets the text style settings.

C#
public StyleText Text;
Visual Basic
Public Property Text() As StyleText
Links
LabelStyleTextComponent Class, LabelStyleTextComponent Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleBorder Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class
LabelStyleTextComponent::StyleBorder Class
Collapse All

Border style settings for label text components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTextComponent::StyleBorder
C#
public class LabelStyleTextComponent::StyleBorder : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleTextComponent::StyleBorder
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleTextComponent::StyleBorder Properties, LabelStyleTextComponent::StyleBorder Members, Class Hierarchy


LabelStyleTextComponent::StyleBorder Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Members
LabelStyleTextComponent::StyleBorder Members
Collapse All

The following tables list the members exposed by LabelStyleTextComponent::StyleBorder.

Public Properties
Public Property | Description
BackgroundMask | Gets whether use background mask when drawing.
BorderType | Gets the shape of the border around the entire label when the label has been dragged from its default position.... more
Color | Gets the color for a new text border or changes the color of an existing border.
Gap | Gets the gap, in plotted units, between the label text and the boarder.
Linetype | Gets the linetype for a new text border or changes an existing border linetype.
Lineweight | Gets the lineweight for a new text border or changes the lineweight of an existing border.
Visible | Gets whether to display a border around the text component.
Links
Public Properties


LabelStyleTextComponent::StyleBorder Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties
LabelStyleTextComponent::StyleBorder Properties
Collapse All

The properties of LabelStyleTextComponent::StyleBorder are listed here.

Public Properties
Public Property | Description
BackgroundMask | Gets whether use background mask when drawing.
BorderType | Gets the shape of the border around the entire label when the label has been dragged from its default position.... more
Color | Gets the color for a new text border or changes the color of an existing border.
Gap | Gets the gap, in plotted units, between the label text and the boarder.
Linetype | Gets the linetype for a new text border or changes an existing border linetype.
Lineweight | Gets the lineweight for a new text border or changes the lineweight of an existing border.
Visible | Gets whether to display a border around the text component.
Links
Public Properties


LabelStyleTextComponent::StyleBorder::BackgroundMask Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties > LabelStyleTextComponent::StyleBorder::BackgroundMask Property
LabelStyleTextComponent::StyleBorder::BackgroundMask Property
Collapse All

Gets whether use background mask when drawing.

C#
public PropertyBoolean BackgroundMask;
Visual Basic
Public Property BackgroundMask() As PropertyBoolean
Links
LabelStyleTextComponent::StyleBorder Class, LabelStyleTextComponent::StyleBorder Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleBorder::BorderType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties > LabelStyleTextComponent::StyleBorder::BorderType Property
LabelStyleTextComponent::StyleBorder::BorderType Property
Collapse All

Gets the shape of the border around the entire label when the label has been dragged from its default position.

C#
public PropertyEnum<TextBorderType> BorderType;
Visual Basic
Public Property BorderType() As PropertyEnum<TextBorderType>
Links
LabelStyleTextComponent::StyleBorder Class, LabelStyleTextComponent::StyleBorder Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleBorder::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties > LabelStyleTextComponent::StyleBorder::Color Property
LabelStyleTextComponent::StyleBorder::Color Property
Collapse All

Gets the color for a new text border or changes the color of an existing border.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleTextComponent::StyleBorder Class, LabelStyleTextComponent::StyleBorder Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleBorder::Gap Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties > LabelStyleTextComponent::StyleBorder::Gap Property
LabelStyleTextComponent::StyleBorder::Gap Property
Collapse All

Gets the gap, in plotted units, between the label text and the boarder.

C#
public PropertyDouble Gap;
Visual Basic
Public Property Gap() As PropertyDouble
Links
LabelStyleTextComponent::StyleBorder Class, LabelStyleTextComponent::StyleBorder Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleBorder::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties > LabelStyleTextComponent::StyleBorder::Linetype Property
LabelStyleTextComponent::StyleBorder::Linetype Property
Collapse All

Gets the linetype for a new text border or changes an existing border linetype.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleTextComponent::StyleBorder Class, LabelStyleTextComponent::StyleBorder Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleBorder::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties > LabelStyleTextComponent::StyleBorder::Lineweight Property
LabelStyleTextComponent::StyleBorder::Lineweight Property
Collapse All

Gets the lineweight for a new text border or changes the lineweight of an existing border.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleTextComponent::StyleBorder Class, LabelStyleTextComponent::StyleBorder Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleBorder::Visible Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties > LabelStyleTextComponent::StyleBorder::Visible Property
LabelStyleTextComponent::StyleBorder::Visible Property
Collapse All

Gets whether to display a border around the text component.

C#
public PropertyBoolean Visible;
Visual Basic
Public Property Visible() As PropertyBoolean
Links
LabelStyleTextComponent::StyleBorder Class, LabelStyleTextComponent::StyleBorder Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleGeneral Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class
LabelStyleTextComponent::StyleGeneral Class
Collapse All

General style settings for label text components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTextComponent::StyleGeneral
C#
public class LabelStyleTextComponent::StyleGeneral : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleTextComponent::StyleGeneral
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleTextComponent::StyleGeneral Properties, LabelStyleTextComponent::StyleGeneral Members, Class Hierarchy


LabelStyleTextComponent::StyleGeneral Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Members
LabelStyleTextComponent::StyleGeneral Members
Collapse All

The following tables list the members exposed by LabelStyleTextComponent::StyleGeneral.

Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the text component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the text component is attached.
Name | Gets the name for text component.
SpanOutsideSegments | Gets whether this component refers to the properties of outside segments.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the text component is visible in the label style.
Links
Public Properties


LabelStyleTextComponent::StyleGeneral Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties
LabelStyleTextComponent::StyleGeneral Properties
Collapse All

The properties of LabelStyleTextComponent::StyleGeneral are listed here.

Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the text component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the text component is attached.
Name | Gets the name for text component.
SpanOutsideSegments | Gets whether this component refers to the properties of outside segments.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the text component is visible in the label style.
Links
Public Properties


LabelStyleTextComponent::StyleGeneral::AnchorComponent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties > LabelStyleTextComponent::StyleGeneral::AnchorComponent Property
LabelStyleTextComponent::StyleGeneral::AnchorComponent Property
Collapse All

Gets a reference object for positioning the point of the text component.

C#
public PropertyString AnchorComponent;
Visual Basic
Public Property AnchorComponent() As PropertyString
Links
LabelStyleTextComponent::StyleGeneral Class, LabelStyleTextComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleGeneral::AnchorLocation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties > LabelStyleTextComponent::StyleGeneral::AnchorLocation Property
LabelStyleTextComponent::StyleGeneral::AnchorLocation Property
Collapse All

Gets the location on the anchor component where the point of the block component is attached.

C#
public PropertyAnchorPoint AnchorLocation;
Visual Basic
Public Property AnchorLocation() As PropertyAnchorPoint
Links
LabelStyleTextComponent::StyleGeneral Class, LabelStyleTextComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleGeneral::AnchorPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties > LabelStyleTextComponent::StyleGeneral::AnchorPoint Property
LabelStyleTextComponent::StyleGeneral::AnchorPoint Property deprecated
Collapse All

Gets the location on the anchor component where the point of the text component is attached.

C#
public PropertyEnum<AnchorLocationType> AnchorPoint;
Visual Basic
Public Property AnchorPoint() As PropertyEnum<AnchorLocationType>
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.LabelStyleTextComponent.StyleGeneral.AnchorLocation instead.

Links
LabelStyleTextComponent::StyleGeneral Class, LabelStyleTextComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleGeneral::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties > LabelStyleTextComponent::StyleGeneral::Name Property
LabelStyleTextComponent::StyleGeneral::Name Property
Collapse All

Gets the name for text component.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
LabelStyleTextComponent::StyleGeneral Class, LabelStyleTextComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleGeneral::SpanOutsideSegments Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties > LabelStyleTextComponent::StyleGeneral::SpanOutsideSegments Property
LabelStyleTextComponent::StyleGeneral::SpanOutsideSegments Property
Collapse All

Gets whether this component refers to the properties of outside segments.

C#
public PropertyBoolean SpanOutsideSegments;
Visual Basic
Public Property SpanOutsideSegments() As PropertyBoolean
Links
LabelStyleTextComponent::StyleGeneral Class, LabelStyleTextComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleGeneral::UsedIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties > LabelStyleTextComponent::StyleGeneral::UsedIn Property
LabelStyleTextComponent::StyleGeneral::UsedIn Property
Collapse All

Gets the display mode in which the component is used;for example if this is set to label, only display the component when display mode is set to label.

C#
public PropertyEnum<LayoutModeType> UsedIn;
Visual Basic
Public Property UsedIn() As PropertyEnum<LayoutModeType>
Links
LabelStyleTextComponent::StyleGeneral Class, LabelStyleTextComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleGeneral::Visible Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties > LabelStyleTextComponent::StyleGeneral::Visible Property
LabelStyleTextComponent::StyleGeneral::Visible Property
Collapse All

Gets whether the text component is visible in the label style.

C#
public PropertyBoolean Visible;
Visual Basic
Public Property Visible() As PropertyBoolean
Links
LabelStyleTextComponent::StyleGeneral Class, LabelStyleTextComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleText Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class
LabelStyleTextComponent::StyleText Class
Collapse All

Text style settings for label text components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTextComponent::StyleText
C#
public class LabelStyleTextComponent::StyleText : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleTextComponent::StyleText
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleTextComponent::StyleText Properties, LabelStyleTextComponent::StyleText Members, Class Hierarchy


LabelStyleTextComponent::StyleText Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Members
LabelStyleTextComponent::StyleText Members
Collapse All

The following tables list the members exposed by LabelStyleTextComponent::StyleText.

Public Properties
Public Property | Description
Angle | Gets the angle of the text comonent from the start point.
Attachment | Gets the point, calculated based on a rectangle that encompasses the text component, where the text component is attached to... more
Color | Gets the color of the text component.
Contents | Gets the contents for text component.
Height | Gets the height for text component.
Lineweight | Gets the line weight of the line component.
XOffset | Gets the text component away from an object in the X direction.
YOffset | Gets the text component away from an object in the Y direction.
Links
Public Properties


LabelStyleTextComponent::StyleText Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties
LabelStyleTextComponent::StyleText Properties
Collapse All

The properties of LabelStyleTextComponent::StyleText are listed here.

Public Properties
Public Property | Description
Angle | Gets the angle of the text comonent from the start point.
Attachment | Gets the point, calculated based on a rectangle that encompasses the text component, where the text component is attached to... more
Color | Gets the color of the text component.
Contents | Gets the contents for text component.
Height | Gets the height for text component.
Lineweight | Gets the line weight of the line component.
XOffset | Gets the text component away from an object in the X direction.
YOffset | Gets the text component away from an object in the Y direction.
Links
Public Properties


LabelStyleTextComponent::StyleText::Angle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties > LabelStyleTextComponent::StyleText::Angle Property
LabelStyleTextComponent::StyleText::Angle Property
Collapse All

Gets the angle of the text comonent from the start point.

C#
public PropertyDouble Angle;
Visual Basic
Public Property Angle() As PropertyDouble
Links
LabelStyleTextComponent::StyleText Class, LabelStyleTextComponent::StyleText Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleText::Attachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties > LabelStyleTextComponent::StyleText::Attachment Property
LabelStyleTextComponent::StyleText::Attachment Property
Collapse All

Gets the point, calculated based on a rectangle that encompasses the text component, where the text component is attached to the anchor point

C#
public PropertyEnum<LabelTextAttachmentType> Attachment;
Visual Basic
Public Property Attachment() As PropertyEnum<LabelTextAttachmentType>
Links
LabelStyleTextComponent::StyleText Class, LabelStyleTextComponent::StyleText Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleText::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties > LabelStyleTextComponent::StyleText::Color Property
LabelStyleTextComponent::StyleText::Color Property
Collapse All

Gets the color of the text component.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleTextComponent::StyleText Class, LabelStyleTextComponent::StyleText Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleText::Contents Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties > LabelStyleTextComponent::StyleText::Contents Property
LabelStyleTextComponent::StyleText::Contents Property
Collapse All

Gets the contents for text component.

C#
public PropertyString Contents;
Visual Basic
Public Property Contents() As PropertyString
Links
LabelStyleTextComponent::StyleText Class, LabelStyleTextComponent::StyleText Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleText::Height Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties > LabelStyleTextComponent::StyleText::Height Property
LabelStyleTextComponent::StyleText::Height Property
Collapse All

Gets the height for text component.

C#
public PropertyDouble Height;
Visual Basic
Public Property Height() As PropertyDouble
Links
LabelStyleTextComponent::StyleText Class, LabelStyleTextComponent::StyleText Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleText::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties > LabelStyleTextComponent::StyleText::Lineweight Property
LabelStyleTextComponent::StyleText::Lineweight Property
Collapse All

Gets the line weight of the line component.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleTextComponent::StyleText Class, LabelStyleTextComponent::StyleText Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleText::XOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties > LabelStyleTextComponent::StyleText::XOffset Property
LabelStyleTextComponent::StyleText::XOffset Property
Collapse All

Gets the text component away from an object in the X direction.

C#
public PropertyDouble XOffset;
Visual Basic
Public Property XOffset() As PropertyDouble
Links
LabelStyleTextComponent::StyleText Class, LabelStyleTextComponent::StyleText Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTextComponent::StyleText::YOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties > LabelStyleTextComponent::StyleText::YOffset Property
LabelStyleTextComponent::StyleText::YOffset Property
Collapse All

Gets the text component away from an object in the Y direction.

C#
public PropertyDouble YOffset;
Visual Basic
Public Property YOffset() As PropertyDouble
Links
LabelStyleTextComponent::StyleText Class, LabelStyleTextComponent::StyleText Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTickComponent::StyleGeneral Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class
LabelStyleTickComponent::StyleGeneral Class
Collapse All

General style settings for label tick components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTickComponent::StyleGeneral
C#
public class LabelStyleTickComponent::StyleGeneral : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleTickComponent::StyleGeneral
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleTickComponent::StyleGeneral Properties, LabelStyleTickComponent::StyleGeneral Members, Class Hierarchy


LabelStyleTickComponent::StyleGeneral Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class > LabelStyleTickComponent::StyleGeneral Members
LabelStyleTickComponent::StyleGeneral Members
Collapse All

The following tables list the members exposed by LabelStyleTickComponent::StyleGeneral.

Public Properties
Public Property | Description
Name | Gets the name for tick component.
Visible | Gets whether the tick component is visible in the label style.
Links
Public Properties


LabelStyleTickComponent::StyleGeneral Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class > LabelStyleTickComponent::StyleGeneral Properties
LabelStyleTickComponent::StyleGeneral Properties
Collapse All

The properties of LabelStyleTickComponent::StyleGeneral are listed here.

Public Properties
Public Property | Description
Name | Gets the name for tick component.
Visible | Gets whether the tick component is visible in the label style.
Links
Public Properties


LabelStyleTickComponent::StyleGeneral::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class > LabelStyleTickComponent::StyleGeneral Properties > LabelStyleTickComponent::StyleGeneral::Name Property
LabelStyleTickComponent::StyleGeneral::Name Property
Collapse All

Gets the name for tick component.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
LabelStyleTickComponent::StyleGeneral Class, LabelStyleTickComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTickComponent::StyleGeneral::Visible Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class > LabelStyleTickComponent::StyleGeneral Properties > LabelStyleTickComponent::StyleGeneral::Visible Property
LabelStyleTickComponent::StyleGeneral::Visible Property
Collapse All

Gets whether the tick component is visible in the label style.

C#
public PropertyBoolean Visible;
Visual Basic
Public Property Visible() As PropertyBoolean
Links
LabelStyleTickComponent::StyleGeneral Class, LabelStyleTickComponent::StyleGeneral Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTickComponent::StyleTick Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class
LabelStyleTickComponent::StyleTick Class
Collapse All

Tick style settings for label tick components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTickComponent::StyleTick
C#
public class LabelStyleTickComponent::StyleTick : Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>;
Visual Basic
Public Class LabelStyleTickComponent::StyleTick
Inherits Autodesk::Civil::CivilWrapper<AeccDbLabelStyleCollector>
Links
LabelStyleTickComponent::StyleTick Properties, LabelStyleTickComponent::StyleTick Members, Class Hierarchy


LabelStyleTickComponent::StyleTick Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Members
LabelStyleTickComponent::StyleTick Members
Collapse All

The following tables list the members exposed by LabelStyleTickComponent::StyleTick.

Public Properties
Public Property | Description
AlignWithObject | Gets whether the tick insert at an angle relative the object.
BlockHeight | Gets the height to whick the tick block is scaled to fit.
BlockName | Gets the block to use for the tick component.
Color | Gets the color of the tick component.
Linetype | Gets the line type of the tick component.
Lineweight | Gets the line weight of the tick component.
RotationAngle | Gets the angle for tick component.
Links
Public Properties


LabelStyleTickComponent::StyleTick Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties
LabelStyleTickComponent::StyleTick Properties
Collapse All

The properties of LabelStyleTickComponent::StyleTick are listed here.

Public Properties
Public Property | Description
AlignWithObject | Gets whether the tick insert at an angle relative the object.
BlockHeight | Gets the height to whick the tick block is scaled to fit.
BlockName | Gets the block to use for the tick component.
Color | Gets the color of the tick component.
Linetype | Gets the line type of the tick component.
Lineweight | Gets the line weight of the tick component.
RotationAngle | Gets the angle for tick component.
Links
Public Properties


LabelStyleTickComponent::StyleTick::AlignWithObject Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties > LabelStyleTickComponent::StyleTick::AlignWithObject Property
LabelStyleTickComponent::StyleTick::AlignWithObject Property
Collapse All

Gets whether the tick insert at an angle relative the object.

C#
public PropertyBoolean AlignWithObject;
Visual Basic
Public Property AlignWithObject() As PropertyBoolean
Links
LabelStyleTickComponent::StyleTick Class, LabelStyleTickComponent::StyleTick Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTickComponent::StyleTick::BlockHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties > LabelStyleTickComponent::StyleTick::BlockHeight Property
LabelStyleTickComponent::StyleTick::BlockHeight Property
Collapse All

Gets the height to whick the tick block is scaled to fit.

C#
public PropertyDouble BlockHeight;
Visual Basic
Public Property BlockHeight() As PropertyDouble
Links
LabelStyleTickComponent::StyleTick Class, LabelStyleTickComponent::StyleTick Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTickComponent::StyleTick::BlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties > LabelStyleTickComponent::StyleTick::BlockName Property
LabelStyleTickComponent::StyleTick::BlockName Property
Collapse All

Gets the block to use for the tick component.

C#
public PropertyString BlockName;
Visual Basic
Public Property BlockName() As PropertyString
Links
LabelStyleTickComponent::StyleTick Class, LabelStyleTickComponent::StyleTick Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTickComponent::StyleTick::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties > LabelStyleTickComponent::StyleTick::Color Property
LabelStyleTickComponent::StyleTick::Color Property
Collapse All

Gets the color of the tick component.

C#
public PropertyColor Color;
Visual Basic
Public Property Color() As PropertyColor
Links
LabelStyleTickComponent::StyleTick Class, LabelStyleTickComponent::StyleTick Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTickComponent::StyleTick::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties > LabelStyleTickComponent::StyleTick::Linetype Property
LabelStyleTickComponent::StyleTick::Linetype Property
Collapse All

Gets the line type of the tick component.

C#
public PropertyLinetype Linetype;
Visual Basic
Public Property Linetype() As PropertyLinetype
Links
LabelStyleTickComponent::StyleTick Class, LabelStyleTickComponent::StyleTick Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTickComponent::StyleTick::Lineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties > LabelStyleTickComponent::StyleTick::Lineweight Property
LabelStyleTickComponent::StyleTick::Lineweight Property
Collapse All

Gets the line weight of the tick component.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> Lineweight;
Visual Basic
Public Property Lineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
LabelStyleTickComponent::StyleTick Class, LabelStyleTickComponent::StyleTick Members, Autodesk::Civil::DatabaseServices::Styles Namespace


LabelStyleTickComponent::StyleTick::RotationAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties > LabelStyleTickComponent::StyleTick::RotationAngle Property
LabelStyleTickComponent::StyleTick::RotationAngle Property
Collapse All

Gets the angle for tick component.

C#
public PropertyDouble RotationAngle;
Visual Basic
Public Property RotationAngle() As PropertyDouble
Links
LabelStyleTickComponent::StyleTick Class, LabelStyleTickComponent::StyleTick Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class
MarkerStyle Class
Collapse All

Sets the style of a marker. Markers are used to mark locations along Alignment objects or survey figures (SurveyFigure), and can also used to indicate interferences in pipe networks (InterferenceChecks).

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase
            Autodesk::Civil::DatabaseServices::Styles::MarkerStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayMarkerStyle"))]
public class MarkerStyle : MarkerStyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayMarkerStyle"))>
Public Class MarkerStyle
Inherits MarkerStyleBase
Links
MarkerStyle Methods, MarkerStyle Properties, MarkerStyle Members, Class Hierarchy


MarkerStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Members
MarkerStyle Members
Collapse All

The following tables list the members exposed by MarkerStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetMarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStyleProfile | Gets the marker display style for profile views.
GetMarkerDisplayStyleSection | Gets the marker display style for section views.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
CustomMarkerStyle | Gets or sets a long value specifying a custom marker style.
CustomMarkerSuperimposeStyle | Gets or sets the CustomMarkerSuperimposeType enum value that specifies the shape superimposed on the custom point style marker as either... more
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStyleProfile | Gets the marker display style for profile views.
MarkerDisplayStyleSection | Gets the marker display style for section views.
MarkerFixedScale | Gets or sets a fixed scale used to scale the point symbol.
MarkerRotationAngle | Gets or sets the marker's rotation angle.
MarkerSize | Gets or sets the marker size in drawing units.
MarkerSymbolName | Gets or sets a string value that represents the marker symbol block name.
MarkerType | Gets or sets the marker type (point, symbol, vertical line, or custom).
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Orientation | Gets or sets the MarkerOrientationType enum value that defines how the marker rotation angle is applied.
SizeType | Gets or sets the MarkerSizeType enum value that defines how the marker is sized, such as relative to screen, fixed... more
Links
Public Methods, Public Properties


MarkerStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Methods
MarkerStyle Methods
Collapse All

The methods of MarkerStyle are listed here.

Public Methods
Public Method | Description
GetMarkerDisplayStyleProfile | Gets the marker display style for profile views.
GetMarkerDisplayStyleSection | Gets the marker display style for section views.
Links
Public Methods


MarkerStyle::GetMarkerDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Methods > MarkerStyle::GetMarkerDisplayStyleProfile Method
MarkerStyle::GetMarkerDisplayStyleProfile Method
Collapse All

Gets the marker display style for profile views.

C#
public DisplayStyle GetMarkerDisplayStyleProfile();
Visual Basic
Public Function GetMarkerDisplayStyleProfile() As DisplayStyle
Links
MarkerStyle Class, MarkerStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyle::GetMarkerDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Methods > MarkerStyle::GetMarkerDisplayStyleSection Method
MarkerStyle::GetMarkerDisplayStyleSection Method
Collapse All

Gets the marker display style for section views.

C#
public DisplayStyle GetMarkerDisplayStyleSection();
Visual Basic
Public Function GetMarkerDisplayStyleSection() As DisplayStyle
Links
MarkerStyle Class, MarkerStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Properties
MarkerStyle Properties
Collapse All

The properties of MarkerStyle are listed here.

Public Properties
Public Property | Description
MarkerDisplayStyleProfile | Gets the marker display style for profile views.
MarkerDisplayStyleSection | Gets the marker display style for section views.
MarkerType | Gets or sets the marker type (point, symbol, vertical line, or custom).
Links
Public Properties


MarkerStyle::MarkerDisplayStyleProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Properties > MarkerStyle::MarkerDisplayStyleProfile Property
MarkerStyle::MarkerDisplayStyleProfile Property deprecated
Collapse All

Gets the marker display style for profile views.

C#
public DisplayStyle MarkerDisplayStyleProfile;
Visual Basic
Public Property MarkerDisplayStyleProfile() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.MarkerStyle.GetMarkerDisplayStyleProfile instead.

Links
MarkerStyle Class, MarkerStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyle::MarkerDisplayStyleSection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Properties > MarkerStyle::MarkerDisplayStyleSection Property
MarkerStyle::MarkerDisplayStyleSection Property deprecated
Collapse All

Gets the marker display style for section views.

C#
public DisplayStyle MarkerDisplayStyleSection;
Visual Basic
Public Property MarkerDisplayStyleSection() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.MarkerStyle.GetMarkerDisplayStyleSection instead.

Links
MarkerStyle Class, MarkerStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyle::MarkerType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Properties > MarkerStyle::MarkerType Property
MarkerStyle::MarkerType Property
Collapse All

Gets or sets the marker type (point, symbol, vertical line, or custom).

C#
public MarkerDisplayType MarkerType;
Visual Basic
Public Property MarkerType() As MarkerDisplayType
Links
MarkerStyle Class, MarkerStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class
MarkerStyleBase Class
Collapse All

The base class for marker and point styles.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase
            Autodesk::Civil::DatabaseServices::Styles::MarkerStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::PointStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMarkerStyle"))]
public class MarkerStyleBase : StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMarkerStyle"))>
Public Class MarkerStyleBase
Inherits StyleBase
Links
MarkerStyleBase Methods, MarkerStyleBase Properties, MarkerStyleBase Members, Class Hierarchy


MarkerStyleBase Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Members
MarkerStyleBase Members
Collapse All

The following tables list the members exposed by MarkerStyleBase.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetMarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
CustomMarkerStyle | Gets or sets a long value specifying a custom marker style.
CustomMarkerSuperimposeStyle | Gets or sets the CustomMarkerSuperimposeType enum value that specifies the shape superimposed on the custom point style marker as either... more
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
MarkerFixedScale | Gets or sets a fixed scale used to scale the point symbol.
MarkerRotationAngle | Gets or sets the marker's rotation angle.
MarkerSize | Gets or sets the marker size in drawing units.
MarkerSymbolName | Gets or sets a string value that represents the marker symbol block name.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Orientation | Gets or sets the MarkerOrientationType enum value that defines how the marker rotation angle is applied.
SizeType | Gets or sets the MarkerSizeType enum value that defines how the marker is sized, such as relative to screen, fixed... more
Links
Public Methods, Public Properties


MarkerStyleBase Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Methods
MarkerStyleBase Methods
Collapse All

The methods of MarkerStyleBase are listed here.

Public Methods
Public Method | Description
GetMarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
Links
Public Methods


MarkerStyleBase::GetMarkerDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Methods > MarkerStyleBase::GetMarkerDisplayStyleModel Method
MarkerStyleBase::GetMarkerDisplayStyleModel Method
Collapse All

Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.

C#
public DisplayStyle GetMarkerDisplayStyleModel();
Visual Basic
Public Function GetMarkerDisplayStyleModel() As DisplayStyle
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::GetMarkerDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Methods > MarkerStyleBase::GetMarkerDisplayStylePlan Method
MarkerStyleBase::GetMarkerDisplayStylePlan Method
Collapse All

Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.

C#
public DisplayStyle GetMarkerDisplayStylePlan();
Visual Basic
Public Function GetMarkerDisplayStylePlan() As DisplayStyle
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties
MarkerStyleBase Properties
Collapse All

The properties of MarkerStyleBase are listed here.

Public Properties
Public Property | Description
CustomMarkerStyle | Gets or sets a long value specifying a custom marker style.
CustomMarkerSuperimposeStyle | Gets or sets the CustomMarkerSuperimposeType enum value that specifies the shape superimposed on the custom point style marker as either... more
MarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
MarkerFixedScale | Gets or sets a fixed scale used to scale the point symbol.
MarkerRotationAngle | Gets or sets the marker's rotation angle.
MarkerSize | Gets or sets the marker size in drawing units.
MarkerSymbolName | Gets or sets a string value that represents the marker symbol block name.
Orientation | Gets or sets the MarkerOrientationType enum value that defines how the marker rotation angle is applied.
SizeType | Gets or sets the MarkerSizeType enum value that defines how the marker is sized, such as relative to screen, fixed... more
Links
Public Properties


MarkerStyleBase::CustomMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::CustomMarkerStyle Property
MarkerStyleBase::CustomMarkerStyle Property
Collapse All

Gets or sets a long value specifying a custom marker style.

C#
public CustomMarkerType CustomMarkerStyle;
Visual Basic
Public Property CustomMarkerStyle() As CustomMarkerType
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::CustomMarkerSuperimposeStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::CustomMarkerSuperimposeStyle Property
MarkerStyleBase::CustomMarkerSuperimposeStyle Property
Collapse All

Gets or sets the CustomMarkerSuperimposeType enum value that specifies the shape superimposed on the custom point style marker as either none, a circle, a square, or both square and circle.

C#
public CustomMarkerSuperimposeType CustomMarkerSuperimposeStyle;
Visual Basic
Public Property CustomMarkerSuperimposeStyle() As CustomMarkerSuperimposeType
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::MarkerDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::MarkerDisplayStyleModel Property
MarkerStyleBase::MarkerDisplayStyleModel Property deprecated
Collapse All

Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.

C#
public DisplayStyle MarkerDisplayStyleModel;
Visual Basic
Public Property MarkerDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.MarkerStyleBase.GetMarkerDisplayStyleModel instead.

Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::MarkerDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::MarkerDisplayStylePlan Property
MarkerStyleBase::MarkerDisplayStylePlan Property deprecated
Collapse All

Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.

C#
public DisplayStyle MarkerDisplayStylePlan;
Visual Basic
Public Property MarkerDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.MarkerStyleBase.GetMarkerDisplayStylePlan instead.

Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::MarkerFixedScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::MarkerFixedScale Property
MarkerStyleBase::MarkerFixedScale Property
Collapse All

Gets or sets a fixed scale used to scale the point symbol.

C#
public Autodesk::AutoCAD::Geometry::Point3d MarkerFixedScale;
Visual Basic
Public Property MarkerFixedScale() As Autodesk::AutoCAD::Geometry::Point3d
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when any coordinate value of the input value is out of interval (0.0, 1E24].
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::MarkerRotationAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::MarkerRotationAngle Property
MarkerStyleBase::MarkerRotationAngle Property
Collapse All

Gets or sets the marker's rotation angle.

C#
public double MarkerRotationAngle;
Visual Basic
Public Property MarkerRotationAngle() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [-1E24, 1E24].
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::MarkerSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::MarkerSize Property
MarkerStyleBase::MarkerSize Property
Collapse All

Gets or sets the marker size in drawing units.

C#
public double MarkerSize;
Visual Basic
Public Property MarkerSize() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval (0.0, 1E24].
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::MarkerSymbolName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::MarkerSymbolName Property
MarkerStyleBase::MarkerSymbolName Property
Collapse All

Gets or sets a string value that represents the marker symbol block name.

C#
public System::String MarkerSymbolName;
Visual Basic
Public Property MarkerSymbolName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when The length of input string is out of interval [1,128]; The input string includes special symbols(*?/,").
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::Orientation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::Orientation Property
MarkerStyleBase::Orientation Property
Collapse All

Gets or sets the MarkerOrientationType enum value that defines how the marker rotation angle is applied.

C#
public MarkerOrientationType Orientation;
Visual Basic
Public Property Orientation() As MarkerOrientationType
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleBase::SizeType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties > MarkerStyleBase::SizeType Property
MarkerStyleBase::SizeType Property
Collapse All

Gets or sets the MarkerSizeType enum value that defines how the marker is sized, such as relative to screen, fixed scale, etc.

C#
public MarkerSizeType SizeType;
Visual Basic
Public Property SizeType() As MarkerSizeType
Links
MarkerStyleBase Class, MarkerStyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


MarkerStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class
MarkerStyleCollection Class
Collapse All

A collection of MarkerStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::MarkerStyleCollection
C#
public class MarkerStyleCollection : StyleCollectionBase;
Visual Basic
Public Class MarkerStyleCollection
Inherits StyleCollectionBase
Links
MarkerStyleCollection Methods, MarkerStyleCollection Members, Class Hierarchy


MarkerStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class > MarkerStyleCollection Members
MarkerStyleCollection Members
Collapse All

The following tables list the members exposed by MarkerStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


MarkerStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class > MarkerStyleCollection Methods
MarkerStyleCollection Methods
Collapse All

The methods of MarkerStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


MarkerStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class > MarkerStyleCollection Methods > MarkerStyleCollection::Add Method
MarkerStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
MarkerStyleCollection Class, MarkerStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class
ProjectionProfileOptions Class
Collapse All

Contains display options and styles for objects projected from a plan view onto a profile view.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ProjectionProfileOptions
C#
public class ProjectionProfileOptions : CivilWrapper<AeccDbProfileSectionEntityStyle>;
Visual Basic
Public Class ProjectionProfileOptions
Inherits CivilWrapper<AeccDbProfileSectionEntityStyle>
Links
ProjectionProfileOptions Properties, ProjectionProfileOptions Members, Class Hierarchy


ProjectionProfileOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Members
ProjectionProfileOptions Members
Collapse All

The following tables list the members exposed by ProjectionProfileOptions.

Public Properties
Public Property | Description
AutoCAD3dPolylineBeginVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline beginning vertex marker style.
AutoCAD3dPolylineBeginVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline beginning vertex marker style's name.
AutoCAD3dPolylineEndVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline ending vertex marker style.
AutoCAD3dPolylineEndVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline ending vertex marker style's name.
AutoCAD3dPolylineInternalVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline internal vertex marker style.
AutoCAD3dPolylineInternalVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline internal vertex marker style's name.
AutoCADBlockDisplayOptions | Gets or sets the AutoCAD block display options.
AutoCADBlockMarkerStyleId | Gets or sets the AutoCAD block marker style.
AutoCADBlockMarkerStyleName | Gets or sets the AutoCAD block marker style's name.
AutoCADBlockSymbolBlockId | Gets or sets the AutoCAD block symbol block.
AutoCADBlockSymbolBlockName | Gets or sets the AutoCAD block symbol block's name.
AutoCADPointDisplayOptions | Gets or sets AutoCAD point display options.
AutoCADPointMarkerStyleId | Gets or sets the AutoCAD point marker style.
AutoCADPointMarkerStyleName | Gets or sets the AutoCAD point marker style's name.
AutoCADSolidDisplayOptions | Gets or sets AutoCAD solid display options.
AutoCADSolidMarkerStyleId | Gets or sets the AutoCAD solid marker style.
AutoCADSolidMarkerStyleName | Gets or sets the AutoCAD solid marker style's name.
MultiViewBlockDirection | Gets or sets the multi-view block direction.
MultiViewBlockDisplayOptions | Gets or sets the multi-view block display options.
MultiViewBlockDisplayRepresentationId | Gets or sets the multi-view block display representation.
MultiViewBlockDisplayRepresentationName | Gets or sets the name of the multi-view block display representation.
MultiViewBlockMarkerStyleId | Gets or sets the multi-view block marker style.
MultiViewBlockMarkerStyleName | Gets or sets the multi-view block marker style's name.
MultiViewBlockSymbolBlockId | Gets or sets the multi-view block symbol block.
MultiViewBlockSymbolBlockName | Gets or sets the name of the multi-view block symbol block.
VerticallyExaggerateBlocks | Gets or sets whether to vertically exaggerate blocks.
VerticallyExaggerateMultiViewBlocks | Gets or sets whether to vetically exaggerate multi-view blocks.
VerticallyExaggerateSolids | Gets or sets whether to vertically exaggerate solids.
Links
Public Properties


ProjectionProfileOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties
ProjectionProfileOptions Properties
Collapse All

The properties of ProjectionProfileOptions are listed here.

Public Properties
Public Property | Description
AutoCAD3dPolylineBeginVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline beginning vertex marker style.
AutoCAD3dPolylineBeginVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline beginning vertex marker style's name.
AutoCAD3dPolylineEndVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline ending vertex marker style.
AutoCAD3dPolylineEndVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline ending vertex marker style's name.
AutoCAD3dPolylineInternalVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline internal vertex marker style.
AutoCAD3dPolylineInternalVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline internal vertex marker style's name.
AutoCADBlockDisplayOptions | Gets or sets the AutoCAD block display options.
AutoCADBlockMarkerStyleId | Gets or sets the AutoCAD block marker style.
AutoCADBlockMarkerStyleName | Gets or sets the AutoCAD block marker style's name.
AutoCADBlockSymbolBlockId | Gets or sets the AutoCAD block symbol block.
AutoCADBlockSymbolBlockName | Gets or sets the AutoCAD block symbol block's name.
AutoCADPointDisplayOptions | Gets or sets AutoCAD point display options.
AutoCADPointMarkerStyleId | Gets or sets the AutoCAD point marker style.
AutoCADPointMarkerStyleName | Gets or sets the AutoCAD point marker style's name.
AutoCADSolidDisplayOptions | Gets or sets AutoCAD solid display options.
AutoCADSolidMarkerStyleId | Gets or sets the AutoCAD solid marker style.
AutoCADSolidMarkerStyleName | Gets or sets the AutoCAD solid marker style's name.
MultiViewBlockDirection | Gets or sets the multi-view block direction.
MultiViewBlockDisplayOptions | Gets or sets the multi-view block display options.
MultiViewBlockDisplayRepresentationId | Gets or sets the multi-view block display representation.
MultiViewBlockDisplayRepresentationName | Gets or sets the name of the multi-view block display representation.
MultiViewBlockMarkerStyleId | Gets or sets the multi-view block marker style.
MultiViewBlockMarkerStyleName | Gets or sets the multi-view block marker style's name.
MultiViewBlockSymbolBlockId | Gets or sets the multi-view block symbol block.
MultiViewBlockSymbolBlockName | Gets or sets the name of the multi-view block symbol block.
VerticallyExaggerateBlocks | Gets or sets whether to vertically exaggerate blocks.
VerticallyExaggerateMultiViewBlocks | Gets or sets whether to vetically exaggerate multi-view blocks.
VerticallyExaggerateSolids | Gets or sets whether to vertically exaggerate solids.
Links
Public Properties


ProjectionProfileOptions::AutoCAD3dPolylineBeginVertexMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCAD3dPolylineBeginVertexMarkerStyleId Property
ProjectionProfileOptions::AutoCAD3dPolylineBeginVertexMarkerStyleId Property
Collapse All

Gets or sets the AutoCAD 3D polyline beginning vertex marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCAD3dPolylineBeginVertexMarkerStyleId;
Visual Basic
Public Property AutoCAD3dPolylineBeginVertexMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCAD3dPolylineBeginVertexMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCAD3dPolylineBeginVertexMarkerStyleName Property
ProjectionProfileOptions::AutoCAD3dPolylineBeginVertexMarkerStyleName Property
Collapse All

Gets or sets the AutoCAD 3D polyline beginning vertex marker style's name.

C#
public System::String AutoCAD3dPolylineBeginVertexMarkerStyleName;
Visual Basic
Public Property AutoCAD3dPolylineBeginVertexMarkerStyleName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCAD3dPolylineEndVertexMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCAD3dPolylineEndVertexMarkerStyleId Property
ProjectionProfileOptions::AutoCAD3dPolylineEndVertexMarkerStyleId Property
Collapse All

Gets or sets the AutoCAD 3D polyline ending vertex marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCAD3dPolylineEndVertexMarkerStyleId;
Visual Basic
Public Property AutoCAD3dPolylineEndVertexMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCAD3dPolylineEndVertexMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCAD3dPolylineEndVertexMarkerStyleName Property
ProjectionProfileOptions::AutoCAD3dPolylineEndVertexMarkerStyleName Property
Collapse All

Gets or sets the AutoCAD 3D polyline ending vertex marker style's name.

C#
public System::String AutoCAD3dPolylineEndVertexMarkerStyleName;
Visual Basic
Public Property AutoCAD3dPolylineEndVertexMarkerStyleName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCAD3dPolylineInternalVertexMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCAD3dPolylineInternalVertexMarkerStyleId Property
ProjectionProfileOptions::AutoCAD3dPolylineInternalVertexMarkerStyleId Property
Collapse All

Gets or sets the AutoCAD 3D polyline internal vertex marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCAD3dPolylineInternalVertexMarkerStyleId;
Visual Basic
Public Property AutoCAD3dPolylineInternalVertexMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCAD3dPolylineInternalVertexMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCAD3dPolylineInternalVertexMarkerStyleName Property
ProjectionProfileOptions::AutoCAD3dPolylineInternalVertexMarkerStyleName Property
Collapse All

Gets or sets the AutoCAD 3D polyline internal vertex marker style's name.

C#
public System::String AutoCAD3dPolylineInternalVertexMarkerStyleName;
Visual Basic
Public Property AutoCAD3dPolylineInternalVertexMarkerStyleName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADBlockDisplayOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADBlockDisplayOptions Property
ProjectionProfileOptions::AutoCADBlockDisplayOptions Property
Collapse All

Gets or sets the AutoCAD block display options.

C#
public ProjectionBlockDisplayType AutoCADBlockDisplayOptions;
Visual Basic
Public Property AutoCADBlockDisplayOptions() As ProjectionBlockDisplayType
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADBlockMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADBlockMarkerStyleId Property
ProjectionProfileOptions::AutoCADBlockMarkerStyleId Property
Collapse All

Gets or sets the AutoCAD block marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCADBlockMarkerStyleId;
Visual Basic
Public Property AutoCADBlockMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADBlockMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADBlockMarkerStyleName Property
ProjectionProfileOptions::AutoCADBlockMarkerStyleName Property
Collapse All

Gets or sets the AutoCAD block marker style's name.

C#
public System::String AutoCADBlockMarkerStyleName;
Visual Basic
Public Property AutoCADBlockMarkerStyleName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADBlockSymbolBlockId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADBlockSymbolBlockId Property
ProjectionProfileOptions::AutoCADBlockSymbolBlockId Property
Collapse All

Gets or sets the AutoCAD block symbol block.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCADBlockSymbolBlockId;
Visual Basic
Public Property AutoCADBlockSymbolBlockId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADBlockSymbolBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADBlockSymbolBlockName Property
ProjectionProfileOptions::AutoCADBlockSymbolBlockName Property
Collapse All

Gets or sets the AutoCAD block symbol block's name.

C#
public System::String AutoCADBlockSymbolBlockName;
Visual Basic
Public Property AutoCADBlockSymbolBlockName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADPointDisplayOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADPointDisplayOptions Property
ProjectionProfileOptions::AutoCADPointDisplayOptions Property
Collapse All

Gets or sets AutoCAD point display options.

C#
public ProjectionEntityDisplayType AutoCADPointDisplayOptions;
Visual Basic
Public Property AutoCADPointDisplayOptions() As ProjectionEntityDisplayType
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADPointMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADPointMarkerStyleId Property
ProjectionProfileOptions::AutoCADPointMarkerStyleId Property
Collapse All

Gets or sets the AutoCAD point marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCADPointMarkerStyleId;
Visual Basic
Public Property AutoCADPointMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADPointMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADPointMarkerStyleName Property
ProjectionProfileOptions::AutoCADPointMarkerStyleName Property
Collapse All

Gets or sets the AutoCAD point marker style's name.

C#
public System::String AutoCADPointMarkerStyleName;
Visual Basic
Public Property AutoCADPointMarkerStyleName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADSolidDisplayOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADSolidDisplayOptions Property
ProjectionProfileOptions::AutoCADSolidDisplayOptions Property
Collapse All

Gets or sets AutoCAD solid display options.

C#
public ProjectionEntityDisplayType AutoCADSolidDisplayOptions;
Visual Basic
Public Property AutoCADSolidDisplayOptions() As ProjectionEntityDisplayType
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADSolidMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADSolidMarkerStyleId Property
ProjectionProfileOptions::AutoCADSolidMarkerStyleId Property
Collapse All

Gets or sets the AutoCAD solid marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCADSolidMarkerStyleId;
Visual Basic
Public Property AutoCADSolidMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::AutoCADSolidMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::AutoCADSolidMarkerStyleName Property
ProjectionProfileOptions::AutoCADSolidMarkerStyleName Property
Collapse All

Gets or sets the AutoCAD solid marker style's name.

C#
public System::String AutoCADSolidMarkerStyleName;
Visual Basic
Public Property AutoCADSolidMarkerStyleName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::MultiViewBlockDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::MultiViewBlockDirection Property
ProjectionProfileOptions::MultiViewBlockDirection Property
Collapse All

Gets or sets the multi-view block direction.

C#
public Autodesk::Aec::DatabaseServices::ViewDirection MultiViewBlockDirection;
Visual Basic
Public Property MultiViewBlockDirection() As Autodesk::Aec::DatabaseServices::ViewDirection
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::MultiViewBlockDisplayOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::MultiViewBlockDisplayOptions Property
ProjectionProfileOptions::MultiViewBlockDisplayOptions Property
Collapse All

Gets or sets the multi-view block display options.

C#
public ProjectionBlockDisplayType MultiViewBlockDisplayOptions;
Visual Basic
Public Property MultiViewBlockDisplayOptions() As ProjectionBlockDisplayType
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::MultiViewBlockDisplayRepresentationId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::MultiViewBlockDisplayRepresentationId Property
ProjectionProfileOptions::MultiViewBlockDisplayRepresentationId Property
Collapse All

Gets or sets the multi-view block display representation.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MultiViewBlockDisplayRepresentationId;
Visual Basic
Public Property MultiViewBlockDisplayRepresentationId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId Type: Auto

Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::MultiViewBlockDisplayRepresentationName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::MultiViewBlockDisplayRepresentationName Property
ProjectionProfileOptions::MultiViewBlockDisplayRepresentationName Property
Collapse All

Gets or sets the name of the multi-view block display representation.

C#
public System::String MultiViewBlockDisplayRepresentationName;
Visual Basic
Public Property MultiViewBlockDisplayRepresentationName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::MultiViewBlockMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::MultiViewBlockMarkerStyleId Property
ProjectionProfileOptions::MultiViewBlockMarkerStyleId Property
Collapse All

Gets or sets the multi-view block marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MultiViewBlockMarkerStyleId;
Visual Basic
Public Property MultiViewBlockMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::MultiViewBlockMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::MultiViewBlockMarkerStyleName Property
ProjectionProfileOptions::MultiViewBlockMarkerStyleName Property
Collapse All

Gets or sets the multi-view block marker style's name.

C#
public System::String MultiViewBlockMarkerStyleName;
Visual Basic
Public Property MultiViewBlockMarkerStyleName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::MultiViewBlockSymbolBlockId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::MultiViewBlockSymbolBlockId Property
ProjectionProfileOptions::MultiViewBlockSymbolBlockId Property
Collapse All

Gets or sets the multi-view block symbol block.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MultiViewBlockSymbolBlockId;
Visual Basic
Public Property MultiViewBlockSymbolBlockId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::MultiViewBlockSymbolBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::MultiViewBlockSymbolBlockName Property
ProjectionProfileOptions::MultiViewBlockSymbolBlockName Property
Collapse All

Gets or sets the name of the multi-view block symbol block.

C#
public System::String MultiViewBlockSymbolBlockName;
Visual Basic
Public Property MultiViewBlockSymbolBlockName() As System::String
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::VerticallyExaggerateBlocks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::VerticallyExaggerateBlocks Property
ProjectionProfileOptions::VerticallyExaggerateBlocks Property
Collapse All

Gets or sets whether to vertically exaggerate blocks.

C#
public bool VerticallyExaggerateBlocks;
Visual Basic
Public Property VerticallyExaggerateBlocks() As bool
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::VerticallyExaggerateMultiViewBlocks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::VerticallyExaggerateMultiViewBlocks Property
ProjectionProfileOptions::VerticallyExaggerateMultiViewBlocks Property
Collapse All

Gets or sets whether to vetically exaggerate multi-view blocks.

C#
public bool VerticallyExaggerateMultiViewBlocks;
Visual Basic
Public Property VerticallyExaggerateMultiViewBlocks() As bool
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionProfileOptions::VerticallyExaggerateSolids Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties > ProjectionProfileOptions::VerticallyExaggerateSolids Property
ProjectionProfileOptions::VerticallyExaggerateSolids Property
Collapse All

Gets or sets whether to vertically exaggerate solids.

C#
public bool VerticallyExaggerateSolids;
Visual Basic
Public Property VerticallyExaggerateSolids() As bool
Links
ProjectionProfileOptions Class, ProjectionProfileOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class
ProjectionSectionOptions Class
Collapse All

Contains display options and styles for objects projected from a plan view onto a section view. Used by ProjectionStyle.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ProjectionSectionOptions
C#
public class ProjectionSectionOptions : CivilWrapper<AeccDbProfileSectionEntityStyle>;
Visual Basic
Public Class ProjectionSectionOptions
Inherits CivilWrapper<AeccDbProfileSectionEntityStyle>
Links
ProjectionSectionOptions Properties, ProjectionSectionOptions Members, Class Hierarchy


ProjectionSectionOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Members
ProjectionSectionOptions Members
Collapse All

The following tables list the members exposed by ProjectionSectionOptions.

Public Properties
Public Property | Description
AutoCAD3dPolylineCrossingMarkerStyleId | Gets AutoCAD 3D polyline crossing marker style.
AutoCAD3dPolylineCrossingMarkerStyleName | Gets AutoCAD 3D polyline crossing marker style's.
AutoCADBlockDisplayOptions | Gets AutoCAD block display options.
AutoCADBlockMarkerStyleId | Gets AutoCAD block marker style.
AutoCADBlockMarkerStyleName | Gets AutoCAD block marker style's name.
AutoCADBlockSymbolBlockId | Gets AutoCAD block symbol block.
AutoCADBlockSymbolBlockName | Gets AutoCAD block symbol block's name.
AutoCADPointDisplayOptions | Gets AutoCAD point display options.
AutoCADPointMarkerStyleId | Gets AutoCAD point marker style.
AutoCADPointMarkerStyleName | Gets AutoCAD point marker style's name.
AutoCADSolidDisplayOptions | Gets AutoCAD solid display options.
AutoCADSolidMarkerStyleId | Gets AutoCAD solid marker style.
AutoCADSolidMarkerStyleName | Gets AutoCAD solid marker style's name.
MultiViewBlockDirection | Gets multi-view block direction.
MultiViewBlockDisplayOptions | Gets multi-view block display options.
MultiViewBlockDisplayRepresentationId | Gets multi-view block display representation.
MultiViewBlockDisplayRepresentationName | Gets multi-view block display representation's name.
MultiViewBlockMarkerStyleId | Gets multi-view block marker style.
MultiViewBlockMarkerStyleName | Gets multi-view block marker style's name.
MultiViewBlockSymbolBlockId | Gets multi-view block symbol block.
MultiViewBlockSymbolBlockName | Gets multi-view block symbol block's name.
VerticallyExaggerateBlocks | Gets vertically exaggerate blocks.
VerticallyExaggerateMultiViewBlocks | Gets vertically exaggerate multi-view blocks.
VerticallyExaggerateSolids | Gets vertically exaggerate solids.
Links
Public Properties


ProjectionSectionOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties
ProjectionSectionOptions Properties
Collapse All

The properties of ProjectionSectionOptions are listed here.

Public Properties
Public Property | Description
AutoCAD3dPolylineCrossingMarkerStyleId | Gets AutoCAD 3D polyline crossing marker style.
AutoCAD3dPolylineCrossingMarkerStyleName | Gets AutoCAD 3D polyline crossing marker style's.
AutoCADBlockDisplayOptions | Gets AutoCAD block display options.
AutoCADBlockMarkerStyleId | Gets AutoCAD block marker style.
AutoCADBlockMarkerStyleName | Gets AutoCAD block marker style's name.
AutoCADBlockSymbolBlockId | Gets AutoCAD block symbol block.
AutoCADBlockSymbolBlockName | Gets AutoCAD block symbol block's name.
AutoCADPointDisplayOptions | Gets AutoCAD point display options.
AutoCADPointMarkerStyleId | Gets AutoCAD point marker style.
AutoCADPointMarkerStyleName | Gets AutoCAD point marker style's name.
AutoCADSolidDisplayOptions | Gets AutoCAD solid display options.
AutoCADSolidMarkerStyleId | Gets AutoCAD solid marker style.
AutoCADSolidMarkerStyleName | Gets AutoCAD solid marker style's name.
MultiViewBlockDirection | Gets multi-view block direction.
MultiViewBlockDisplayOptions | Gets multi-view block display options.
MultiViewBlockDisplayRepresentationId | Gets multi-view block display representation.
MultiViewBlockDisplayRepresentationName | Gets multi-view block display representation's name.
MultiViewBlockMarkerStyleId | Gets multi-view block marker style.
MultiViewBlockMarkerStyleName | Gets multi-view block marker style's name.
MultiViewBlockSymbolBlockId | Gets multi-view block symbol block.
MultiViewBlockSymbolBlockName | Gets multi-view block symbol block's name.
VerticallyExaggerateBlocks | Gets vertically exaggerate blocks.
VerticallyExaggerateMultiViewBlocks | Gets vertically exaggerate multi-view blocks.
VerticallyExaggerateSolids | Gets vertically exaggerate solids.
Links
Public Properties


ProjectionSectionOptions::AutoCAD3dPolylineCrossingMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCAD3dPolylineCrossingMarkerStyleId Property
ProjectionSectionOptions::AutoCAD3dPolylineCrossingMarkerStyleId Property
Collapse All

Gets AutoCAD 3D polyline crossing marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCAD3dPolylineCrossingMarkerStyleId;
Visual Basic
Public Property AutoCAD3dPolylineCrossingMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCAD3dPolylineCrossingMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCAD3dPolylineCrossingMarkerStyleName Property
ProjectionSectionOptions::AutoCAD3dPolylineCrossingMarkerStyleName Property
Collapse All

Gets AutoCAD 3D polyline crossing marker style's.

C#
public System::String AutoCAD3dPolylineCrossingMarkerStyleName;
Visual Basic
Public Property AutoCAD3dPolylineCrossingMarkerStyleName() As System::String
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADBlockDisplayOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADBlockDisplayOptions Property
ProjectionSectionOptions::AutoCADBlockDisplayOptions Property
Collapse All

Gets AutoCAD block display options.

C#
public ProjectionBlockDisplayType AutoCADBlockDisplayOptions;
Visual Basic
Public Property AutoCADBlockDisplayOptions() As ProjectionBlockDisplayType
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADBlockMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADBlockMarkerStyleId Property
ProjectionSectionOptions::AutoCADBlockMarkerStyleId Property
Collapse All

Gets AutoCAD block marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCADBlockMarkerStyleId;
Visual Basic
Public Property AutoCADBlockMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADBlockMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADBlockMarkerStyleName Property
ProjectionSectionOptions::AutoCADBlockMarkerStyleName Property
Collapse All

Gets AutoCAD block marker style's name.

C#
public System::String AutoCADBlockMarkerStyleName;
Visual Basic
Public Property AutoCADBlockMarkerStyleName() As System::String
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADBlockSymbolBlockId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADBlockSymbolBlockId Property
ProjectionSectionOptions::AutoCADBlockSymbolBlockId Property
Collapse All

Gets AutoCAD block symbol block.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCADBlockSymbolBlockId;
Visual Basic
Public Property AutoCADBlockSymbolBlockId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADBlockSymbolBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADBlockSymbolBlockName Property
ProjectionSectionOptions::AutoCADBlockSymbolBlockName Property
Collapse All

Gets AutoCAD block symbol block's name.

C#
public System::String AutoCADBlockSymbolBlockName;
Visual Basic
Public Property AutoCADBlockSymbolBlockName() As System::String
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADPointDisplayOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADPointDisplayOptions Property
ProjectionSectionOptions::AutoCADPointDisplayOptions Property
Collapse All

Gets AutoCAD point display options.

C#
public ProjectionEntityDisplayType AutoCADPointDisplayOptions;
Visual Basic
Public Property AutoCADPointDisplayOptions() As ProjectionEntityDisplayType
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADPointMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADPointMarkerStyleId Property
ProjectionSectionOptions::AutoCADPointMarkerStyleId Property
Collapse All

Gets AutoCAD point marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCADPointMarkerStyleId;
Visual Basic
Public Property AutoCADPointMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADPointMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADPointMarkerStyleName Property
ProjectionSectionOptions::AutoCADPointMarkerStyleName Property
Collapse All

Gets AutoCAD point marker style's name.

C#
public System::String AutoCADPointMarkerStyleName;
Visual Basic
Public Property AutoCADPointMarkerStyleName() As System::String
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADSolidDisplayOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADSolidDisplayOptions Property
ProjectionSectionOptions::AutoCADSolidDisplayOptions Property
Collapse All

Gets AutoCAD solid display options.

C#
public ProjectionEntityDisplayType AutoCADSolidDisplayOptions;
Visual Basic
Public Property AutoCADSolidDisplayOptions() As ProjectionEntityDisplayType
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADSolidMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADSolidMarkerStyleId Property
ProjectionSectionOptions::AutoCADSolidMarkerStyleId Property
Collapse All

Gets AutoCAD solid marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AutoCADSolidMarkerStyleId;
Visual Basic
Public Property AutoCADSolidMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::AutoCADSolidMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::AutoCADSolidMarkerStyleName Property
ProjectionSectionOptions::AutoCADSolidMarkerStyleName Property
Collapse All

Gets AutoCAD solid marker style's name.

C#
public System::String AutoCADSolidMarkerStyleName;
Visual Basic
Public Property AutoCADSolidMarkerStyleName() As System::String
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::MultiViewBlockDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::MultiViewBlockDirection Property
ProjectionSectionOptions::MultiViewBlockDirection Property
Collapse All

Gets multi-view block direction.

C#
public Autodesk::Aec::DatabaseServices::ViewDirection MultiViewBlockDirection;
Visual Basic
Public Property MultiViewBlockDirection() As Autodesk::Aec::DatabaseServices::ViewDirection
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::MultiViewBlockDisplayOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::MultiViewBlockDisplayOptions Property
ProjectionSectionOptions::MultiViewBlockDisplayOptions Property
Collapse All

Gets multi-view block display options.

C#
public ProjectionBlockDisplayType MultiViewBlockDisplayOptions;
Visual Basic
Public Property MultiViewBlockDisplayOptions() As ProjectionBlockDisplayType
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::MultiViewBlockDisplayRepresentationId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::MultiViewBlockDisplayRepresentationId Property
ProjectionSectionOptions::MultiViewBlockDisplayRepresentationId Property
Collapse All

Gets multi-view block display representation.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MultiViewBlockDisplayRepresentationId;
Visual Basic
Public Property MultiViewBlockDisplayRepresentationId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::MultiViewBlockDisplayRepresentationName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::MultiViewBlockDisplayRepresentationName Property
ProjectionSectionOptions::MultiViewBlockDisplayRepresentationName Property
Collapse All

Gets multi-view block display representation's name.

C#
public System::String MultiViewBlockDisplayRepresentationName;
Visual Basic
Public Property MultiViewBlockDisplayRepresentationName() As System::String
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::MultiViewBlockMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::MultiViewBlockMarkerStyleId Property
ProjectionSectionOptions::MultiViewBlockMarkerStyleId Property
Collapse All

Gets multi-view block marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MultiViewBlockMarkerStyleId;
Visual Basic
Public Property MultiViewBlockMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::MultiViewBlockMarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::MultiViewBlockMarkerStyleName Property
ProjectionSectionOptions::MultiViewBlockMarkerStyleName Property
Collapse All

Gets multi-view block marker style's name.

C#
public System::String MultiViewBlockMarkerStyleName;
Visual Basic
Public Property MultiViewBlockMarkerStyleName() As System::String
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::MultiViewBlockSymbolBlockId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::MultiViewBlockSymbolBlockId Property
ProjectionSectionOptions::MultiViewBlockSymbolBlockId Property
Collapse All

Gets multi-view block symbol block.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MultiViewBlockSymbolBlockId;
Visual Basic
Public Property MultiViewBlockSymbolBlockId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::MultiViewBlockSymbolBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::MultiViewBlockSymbolBlockName Property
ProjectionSectionOptions::MultiViewBlockSymbolBlockName Property
Collapse All

Gets multi-view block symbol block's name.

C#
public System::String MultiViewBlockSymbolBlockName;
Visual Basic
Public Property MultiViewBlockSymbolBlockName() As System::String
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::VerticallyExaggerateBlocks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::VerticallyExaggerateBlocks Property
ProjectionSectionOptions::VerticallyExaggerateBlocks Property
Collapse All

Gets vertically exaggerate blocks.

C#
public bool VerticallyExaggerateBlocks;
Visual Basic
Public Property VerticallyExaggerateBlocks() As bool
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::VerticallyExaggerateMultiViewBlocks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::VerticallyExaggerateMultiViewBlocks Property
ProjectionSectionOptions::VerticallyExaggerateMultiViewBlocks Property
Collapse All

Gets vertically exaggerate multi-view blocks.

C#
public bool VerticallyExaggerateMultiViewBlocks;
Visual Basic
Public Property VerticallyExaggerateMultiViewBlocks() As bool
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionSectionOptions::VerticallyExaggerateSolids Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties > ProjectionSectionOptions::VerticallyExaggerateSolids Property
ProjectionSectionOptions::VerticallyExaggerateSolids Property
Collapse All

Gets vertically exaggerate solids.

C#
public bool VerticallyExaggerateSolids;
Visual Basic
Public Property VerticallyExaggerateSolids() As bool
Links
ProjectionSectionOptions Class, ProjectionSectionOptions Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class
ProjectionStyle Class
Collapse All

Contains display options and styles for objects projected from a plan view onto a section or profile view.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::ProjectionStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbProfileSectionEntityStyle"))]
public class ProjectionStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbProfileSectionEntityStyle"))>
Public Class ProjectionStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
ProjectionStyle Methods, ProjectionStyle Properties, ProjectionStyle Members, Class Hierarchy


ProjectionStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Members
ProjectionStyle Members
Collapse All

The following tables list the members exposed by ProjectionStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ProfileOptions | Gets the ProjectionProfileOptions object that specifies profile options.
SectionOptions | Gets the ProjectionSectionOptions object that specifies section options.
Links
Public Methods, Public Properties


ProjectionStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Methods
ProjectionStyle Methods
Collapse All

The methods of ProjectionStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties.
Links
Public Methods


ProjectionStyle::GetDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Methods > ProjectionStyle::GetDisplayStyleProfile Method
ProjectionStyle::GetDisplayStyleProfile Method
Collapse All

Gets the DisplayStyle object that specifies profile display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleProfile(
    ProjectionDisplayStyleProfileType type
);
Visual Basic
Public Function GetDisplayStyleProfile(
    type As ProjectionDisplayStyleProfileType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ProjectionStyle Class, ProjectionStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Methods > ProjectionStyle::GetDisplayStyleSection Method
ProjectionStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle object that specifies section display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection(
    ProjectionDisplayStyleSectionType type
);
Visual Basic
Public Function GetDisplayStyleSection(
    type As ProjectionDisplayStyleSectionType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ProjectionStyle Class, ProjectionStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Properties
ProjectionStyle Properties
Collapse All

The properties of ProjectionStyle are listed here.

Public Properties
Public Property | Description
ProfileOptions | Gets the ProjectionProfileOptions object that specifies profile options.
SectionOptions | Gets the ProjectionSectionOptions object that specifies section options.
Links
Public Properties


ProjectionStyle::ProfileOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Properties > ProjectionStyle::ProfileOptions Property
ProjectionStyle::ProfileOptions Property
Collapse All

Gets the ProjectionProfileOptions object that specifies profile options.

C#
public ProjectionProfileOptions ProfileOptions;
Visual Basic
Public Property ProfileOptions() As ProjectionProfileOptions
Links
ProjectionStyle Class, ProjectionStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionStyle::SectionOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Properties > ProjectionStyle::SectionOptions Property
ProjectionStyle::SectionOptions Property
Collapse All

Gets the ProjectionSectionOptions object that specifies section options.

C#
public ProjectionSectionOptions SectionOptions;
Visual Basic
Public Property SectionOptions() As ProjectionSectionOptions
Links
ProjectionStyle Class, ProjectionStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ProjectionStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class
ProjectionStyleCollection Class
Collapse All

A collection of ProjectionStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::ProjectionStyleCollection
C#
public class ProjectionStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class ProjectionStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
ProjectionStyleCollection Methods, ProjectionStyleCollection Members, Class Hierarchy


ProjectionStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class > ProjectionStyleCollection Members
ProjectionStyleCollection Members
Collapse All

The following tables list the members exposed by ProjectionStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


ProjectionStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class > ProjectionStyleCollection Methods
ProjectionStyleCollection Methods
Collapse All

The methods of ProjectionStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


ProjectionStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class > ProjectionStyleCollection Methods > ProjectionStyleCollection::Add Method
ProjectionStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
ProjectionStyleCollection Class, ProjectionStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


SegmentColumnStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class
SegmentColumnStyle Class
Collapse All

Specifies the advance column style obtained from the Parcel Segment table style or Alignment Segment table style.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ColumnStyle
    Autodesk::Civil::DatabaseServices::Styles::SegmentColumnStyle
C#
public class SegmentColumnStyle : ColumnStyle;
Visual Basic
Public Class SegmentColumnStyle
Inherits ColumnStyle
Links
SegmentColumnStyle Methods, SegmentColumnStyle Members, Class Hierarchy


SegmentColumnStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Members
SegmentColumnStyle Members
Collapse All

The following tables list the members exposed by SegmentColumnStyle.

Public Methods
Public Method | Description
GetContentString | Gets the specified display content of segment column style.
GetContentStringFormatted | Gets the specified formatted content of segment column style.
SetContentString | Sets the specified display content of segment column style.
SetContentStringFormatted | Sets the specified formatted content of segment column style.
Public Properties
Public Property | Description
ColumnWidth | Gets or sets the column width of the column style, 0 represents auto width.
ContentJustification | Gets or sets the Content Justification of column style.
ContentString | Gets the display content of column style, this property is usable for most table columns, but for alignment segment table,... more
ContentStringFormatted | Gets the formatted content of column style, this property is usable for most table columns, but for alignment segment table,... more
HeaderJustification | Gets or sets the Header Justification of column style
HeaderString | Gets or sets the display header string of the column style.
HeaderStringFormatted | Gets or sets the formatted header string of the column style.
Links
Public Methods, Public Properties


SegmentColumnStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Methods
SegmentColumnStyle Methods
Collapse All

The methods of SegmentColumnStyle are listed here.

Public Methods
Public Method | Description
GetContentString | Gets the specified display content of segment column style.
GetContentStringFormatted | Gets the specified formatted content of segment column style.
SetContentString | Sets the specified display content of segment column style.
SetContentStringFormatted | Sets the specified formatted content of segment column style.
Links
Public Methods


SegmentColumnStyle::GetContentString Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Methods > SegmentColumnStyle::GetContentString Method
SegmentColumnStyle::GetContentString Method
Collapse All

Gets the specified display content of segment column style.

C#
public System::String GetContentString(
    Autodesk::Civil::TableSegmentDataType type
);
Visual Basic
Public Function GetContentString(
    type As Autodesk::Civil::TableSegmentDataType
) As System::String
Links
SegmentColumnStyle Class, SegmentColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


SegmentColumnStyle::GetContentStringFormatted Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Methods > SegmentColumnStyle::GetContentStringFormatted Method
SegmentColumnStyle::GetContentStringFormatted Method
Collapse All

Gets the specified formatted content of segment column style.

C#
public System::String GetContentStringFormatted(
    Autodesk::Civil::TableSegmentDataType type
);
Visual Basic
Public Function GetContentStringFormatted(
    type As Autodesk::Civil::TableSegmentDataType
) As System::String
Links
SegmentColumnStyle Class, SegmentColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


SegmentColumnStyle::SetContentString Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Methods > SegmentColumnStyle::SetContentString Method
SegmentColumnStyle::SetContentString Method
Collapse All

Sets the specified display content of segment column style.

C#
public SetContentString(
    Autodesk::Civil::TableSegmentDataType type,
    ref System::String newVal
);
Visual Basic
Public Sub SetContentString(
    type As Autodesk::Civil::TableSegmentDataType,
    ByRef newVal As System::String
)
Links
SegmentColumnStyle Class, SegmentColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


SegmentColumnStyle::SetContentStringFormatted Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Methods > SegmentColumnStyle::SetContentStringFormatted Method
SegmentColumnStyle::SetContentStringFormatted Method
Collapse All

Sets the specified formatted content of segment column style.

C#
public SetContentStringFormatted(
    Autodesk::Civil::TableSegmentDataType type,
    ref System::String newVal
);
Visual Basic
Public Sub SetContentStringFormatted(
    type As Autodesk::Civil::TableSegmentDataType,
    ByRef newVal As System::String
)
Links
SegmentColumnStyle Class, SegmentColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnComponentData Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class
StructureColumnComponentData Class
Collapse All

Specifies the tabel cell component data information.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StructureColumnComponentData
C#
public class StructureColumnComponentData : CivilWrapper<tableCellComponentVec>;
Visual Basic
Public Class StructureColumnComponentData
Inherits CivilWrapper<tableCellComponentVec>
Links
StructureColumnComponentData Properties, StructureColumnComponentData Members, Class Hierarchy


StructureColumnComponentData Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class > StructureColumnComponentData Members
StructureColumnComponentData Members
Collapse All

The following tables list the members exposed by StructureColumnComponentData.

Public Properties
Public Property | Description
ComponentType | Gets the type of the table cell component data.
Content | Gets or sets the content of the tabel cell component data.
Name | Gets or sets the name of the tabel cell component data.
Links
Public Properties


StructureColumnComponentData Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class > StructureColumnComponentData Properties
StructureColumnComponentData Properties
Collapse All

The properties of StructureColumnComponentData are listed here.

Public Properties
Public Property | Description
ComponentType | Gets the type of the table cell component data.
Content | Gets or sets the content of the tabel cell component data.
Name | Gets or sets the name of the tabel cell component data.
Links
Public Properties


StructureColumnComponentData::ComponentType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class > StructureColumnComponentData Properties > StructureColumnComponentData::ComponentType Property
StructureColumnComponentData::ComponentType Property
Collapse All

Gets the type of the table cell component data.

C#
public Autodesk::Civil::StructureColumnComponentType ComponentType;
Visual Basic
Public Property ComponentType() As Autodesk::Civil::StructureColumnComponentType
Links
StructureColumnComponentData Class, StructureColumnComponentData Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnComponentData::Content Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class > StructureColumnComponentData Properties > StructureColumnComponentData::Content Property
StructureColumnComponentData::Content Property
Collapse All

Gets or sets the content of the tabel cell component data.

C#
public System::String Content;
Visual Basic
Public Property Content() As System::String
Links
StructureColumnComponentData Class, StructureColumnComponentData Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnComponentData::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class > StructureColumnComponentData Properties > StructureColumnComponentData::Name Property
StructureColumnComponentData::Name Property
Collapse All

Gets or sets the name of the tabel cell component data.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
StructureColumnComponentData Class, StructureColumnComponentData Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnComponents Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class
StructureColumnComponents Class
Collapse All
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StructureColumnComponents
C#
public class StructureColumnComponents : CivilWrapper<tableCellComponentVec>;
Visual Basic
Public Class StructureColumnComponents
Inherits CivilWrapper<tableCellComponentVec>
Links
StructureColumnComponents Methods, StructureColumnComponents Properties, StructureColumnComponents Members, Class Hierarchy


StructureColumnComponents Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Members
StructureColumnComponents Members
Collapse All

The following tables list the members exposed by StructureColumnComponents.

Public Methods
Public Method | Description
AddComponent | Adds a table cell component data to the collection with the default Content("Structure Text") and Justification(Center).
Clear | Removes all the table cell component data from the collection.
RemoveAt | Overloaded
SwitchComponentsOrder | Switch the component data order by index.
Public Properties
Public Property | Description
Count | Gets the number of table cell component datas in the collection.
default | Gets the table cell component data at a specified index in the collection.
Links
Public Methods, Public Properties


StructureColumnComponents Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Methods
StructureColumnComponents Methods
Collapse All

The methods of StructureColumnComponents are listed here.

Public Methods
Public Method | Description
AddComponent | Adds a table cell component data to the collection with the default Content("Structure Text") and Justification(Center).
Clear | Removes all the table cell component data from the collection.
RemoveAt | Overloaded
SwitchComponentsOrder | Switch the component data order by index.
Links
Public Methods


StructureColumnComponents::AddComponent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Methods > StructureColumnComponents::AddComponent Method
StructureColumnComponents::AddComponent Method
Collapse All

Adds a table cell component data to the collection with the default Content("Structure Text") and Justification(Center).

C#
public AddComponent(
    ref System::String name,
    Autodesk::Civil::StructureColumnComponentType componentType
);
Visual Basic
Public Sub AddComponent(
    ByRef name As System::String,
    componentType As Autodesk::Civil::StructureColumnComponentType
)
Parameters
Parameters | Description
name | The name of the table cell component data.
componentType | The type of the table cell component data.
Links
StructureColumnComponents Class, StructureColumnComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnComponents::Clear Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Methods > StructureColumnComponents::Clear Method
StructureColumnComponents::Clear Method
Collapse All

Removes all the table cell component data from the collection.

C#
public Clear();
Visual Basic
Public Sub Clear()
Links
StructureColumnComponents Class, StructureColumnComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Methods > RemoveAt Method
RemoveAt Method
Collapse All

Overloaded

Overload List
Method | Description
StructureColumnComponents::RemoveAt (int) | Removes a table cell component data by index in the collection.
StructureColumnComponents::RemoveAt (System::String^) | Removes a table cell component data by name in the collection.


StructureColumnComponents::RemoveAt Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Methods > RemoveAt Method > StructureColumnComponents::RemoveAt Method (System::String^)
StructureColumnComponents::RemoveAt Method (System::String^)
Collapse All

Removes a table cell component data by name in the collection.

C#
public RemoveAt(
    ref System::String name
);
Visual Basic
Public Sub RemoveAt(
    ByRef name As System::String
)
Parameters
Parameters | Description
name | The name of the table cell component data.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the component data name is invalid.
Links
StructureColumnComponents Class, StructureColumnComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnComponents::RemoveAt Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Methods > RemoveAt Method > StructureColumnComponents::RemoveAt Method (int)
StructureColumnComponents::RemoveAt Method (int)
Collapse All

Removes a table cell component data by index in the collection.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | The index of the table cell component data to remove.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when index is out of the collection's range.
Links
StructureColumnComponents Class, StructureColumnComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnComponents::SwitchComponentsOrder Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Methods > StructureColumnComponents::SwitchComponentsOrder Method
StructureColumnComponents::SwitchComponentsOrder Method
Collapse All

Switch the component data order by index.

C#
public SwitchComponentsOrder(
    int index1,
    int index2
);
Visual Basic
Public Sub SwitchComponentsOrder(
    index1 As Integer,
    index2 As Integer
)
Parameters
Parameters | Description
index1 | The first index of the table cell component data in the collection.
index2 | The second index of the table cell component data in the collection.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index1 or index2 is out of range.
Links
StructureColumnComponents Class, StructureColumnComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnComponents Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Properties
StructureColumnComponents Properties
Collapse All

The properties of StructureColumnComponents are listed here.

Public Properties
Public Property | Description
Count | Gets the number of table cell component datas in the collection.
default | Gets the table cell component data at a specified index in the collection.
Links
Public Properties


StructureColumnComponents::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Properties > StructureColumnComponents::Count Property
StructureColumnComponents::Count Property
Collapse All

Gets the number of table cell component datas in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
StructureColumnComponents Class, StructureColumnComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnComponents::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Properties > StructureColumnComponents::default Property
StructureColumnComponents::default Property
Collapse All

Gets the table cell component data at a specified index in the collection.

C#
public StructureColumnComponentData default;
Visual Basic
Public Property default() As StructureColumnComponentData
Parameters
Parameters | Description
index | The index of the table cell component data.
Links
StructureColumnComponents Class, StructureColumnComponents Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class
StructureColumnStyle Class
Collapse All

Specifies the advance column style obtained from the Structure table style.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ColumnStyle
    Autodesk::Civil::DatabaseServices::Styles::StructureColumnStyle
C#
public class StructureColumnStyle : ColumnStyle;
Visual Basic
Public Class StructureColumnStyle
Inherits ColumnStyle
Links
StructureColumnStyle Methods, StructureColumnStyle Members, Class Hierarchy


StructureColumnStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Members
StructureColumnStyle Members
Collapse All

The following tables list the members exposed by StructureColumnStyle.

Public Methods
Public Method | Description
GetComponents | Gets the table cell components from the structure column style.
SetComponents | Sets the table cell components to the structure column style.
Public Properties
Public Property | Description
ColumnWidth | Gets or sets the column width of the column style, 0 represents auto width.
ContentJustification | Gets or sets the Content Justification of column style.
ContentString | Gets the display content of column style, this property is usable for most table columns, but for alignment segment table,... more
ContentStringFormatted | Gets the formatted content of column style, this property is usable for most table columns, but for alignment segment table,... more
HeaderJustification | Gets or sets the Header Justification of column style
HeaderString | Gets or sets the display header string of the column style.
HeaderStringFormatted | Gets or sets the formatted header string of the column style.
Links
Public Methods, Public Properties


StructureColumnStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Methods
StructureColumnStyle Methods
Collapse All

The methods of StructureColumnStyle are listed here.

Public Methods
Public Method | Description
GetComponents | Gets the table cell components from the structure column style.
SetComponents | Sets the table cell components to the structure column style.
Links
Public Methods


StructureColumnStyle::GetComponents Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Methods > StructureColumnStyle::GetComponents Method
StructureColumnStyle::GetComponents Method
Collapse All

Gets the table cell components from the structure column style.

C#
public StructureColumnComponents GetComponents();
Visual Basic
Public Function GetComponents() As StructureColumnComponents
Links
StructureColumnStyle Class, StructureColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StructureColumnStyle::SetComponents Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Methods > StructureColumnStyle::SetComponents Method
StructureColumnStyle::SetComponents Method
Collapse All

Sets the table cell components to the structure column style.

C#
public SetComponents(
    ref StructureColumnComponents componentDatas
);
Visual Basic
Public Sub SetComponents(
    ByRef componentDatas As StructureColumnComponents
)
Parameters
Parameters | Description
name | The table cell components.
Links
StructureColumnStyle Class, StructureColumnStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleBase Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class
StyleBase Class
Collapse All

The base class for all style objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
        Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetStyle
        Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyle
        Autodesk::Civil::DatabaseServices::Styles::LabelStyle
        Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase
        Autodesk::Civil::DatabaseServices::Styles::ProjectionStyle
        Autodesk::Civil::DatabaseServices::Styles::TableStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSet
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteria
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSet
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::MatchLineStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ParcelStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SheetStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ViewFrameStyle
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyle
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::NetworkRuleSetStyle
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsList
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyle
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteria
        Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStyle"))]
public class StyleBase : DBObject;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStyle"))>
Public Class StyleBase
Inherits DBObject
Links
StyleBase Methods, StyleBase Properties, StyleBase Members, Class Hierarchy


StyleBase Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Members
StyleBase Members
Collapse All

The following tables list the members exposed by StyleBase.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


StyleBase Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Methods
StyleBase Methods
Collapse All

The methods of StyleBase are listed here.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
Links
Public Methods


StyleBase::CopyAsSibling Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Methods > StyleBase::CopyAsSibling Method
StyleBase::CopyAsSibling Method
Collapse All

Copy the current style and add it to the parent node as a sibling.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CopyAsSibling(
    ref System::String styleName
);
Visual Basic
Public Function CopyAsSibling(
    ByRef styleName As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
styleName | The name of the style.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name is duplicate.
Links
StyleBase Class, StyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


ExportTo Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Methods > ExportTo Method
ExportTo Method
Collapse All

Overloaded

Overload List
Method | Description
StyleBase::ExportTo (Autodesk::AutoCAD::DatabaseServices::Database^, Autodesk::Civil::StyleConflictResolverType) | Exports the current style to another drawing.
StyleBase::ExportTo (Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection^, Autodesk::AutoCAD::DatabaseServices::Database^, Autodesk::Civil::StyleConflictResolverType) | Exports a collection of style ids to another drawing.


StyleBase::ExportTo Method (Autodesk::AutoCAD::DatabaseServices::Database^, Autodesk::Civil::StyleConflictResolverType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Methods > ExportTo Method > StyleBase::ExportTo Method (Autodesk::AutoCAD::DatabaseServices::Database^, Autodesk::Civil::StyleConflictResolverType)
StyleBase::ExportTo Method (Autodesk::AutoCAD::DatabaseServices::Database^, Autodesk::Civil::StyleConflictResolverType)
Collapse All

Exports the current style to another drawing.

C#
public ExportTo(
    ref Autodesk::AutoCAD::DatabaseServices::Database destinationDatabase,
    Autodesk::Civil::StyleConflictResolverType conflictResolution
);
Visual Basic
Public Sub ExportTo(
    ByRef destinationDatabase As Autodesk::AutoCAD::DatabaseServices::Database,
    conflictResolution As Autodesk::Civil::StyleConflictResolverType
)
Parameters
Parameters | Description
destinationDatabase | The destination database.
conflictResolution | Specifies how to resolve conflicts if the current style has the same name as a style in the destination database.
Links
StyleBase Class, StyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleBase::ExportTo Method (Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection^, Autodesk::AutoCAD::DatabaseServices::Database^, Autodesk::Civil::StyleConflictResolverType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Methods > ExportTo Method > StyleBase::ExportTo Method (Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection^, Autodesk::AutoCAD::DatabaseServices::Database^, Autodesk::Civil::StyleConflictResolverType)
StyleBase::ExportTo Method (Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection^, Autodesk::AutoCAD::DatabaseServices::Database^, Autodesk::Civil::StyleConflictResolverType)
Collapse All

Exports a collection of style ids to another drawing.

C#
public ExportTo(
    ref Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection styleIds,
    ref Autodesk::AutoCAD::DatabaseServices::Database destinationDatabase,
    Autodesk::Civil::StyleConflictResolverType conflictResolution
);
Visual Basic
Public Sub ExportTo(
    ByRef styleIds As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection,
    ByRef destinationDatabase As Autodesk::AutoCAD::DatabaseServices::Database,
    conflictResolution As Autodesk::Civil::StyleConflictResolverType
)
Parameters
Parameters | Description
styleIds | The object id collection of styles need to export.
conflictResolution | Specifies how to resolve conflicts if any exported styles have the same name as a style in the destination database.
destDb | The destination database.
Links
StyleBase Class, StyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleBase Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Properties
StyleBase Properties
Collapse All

The properties of StyleBase are listed here.

Public Properties
Public Property | Description
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
ModifiedBy | Gets the "Modified by" string for the style.
Links
Public Properties


StyleBase::CreateBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Properties > StyleBase::CreateBy Property
StyleBase::CreateBy Property
Collapse All

Gets or Sets the "Created by" string for the style.

C#
public System::String CreateBy;
Visual Basic
Public Property CreateBy() As System::String
Links
StyleBase Class, StyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleBase::DateCreated Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Properties > StyleBase::DateCreated Property
StyleBase::DateCreated Property
Collapse All

Gets the "Date created" string for the style.

C#
public System::String DateCreated;
Visual Basic
Public Property DateCreated() As System::String
Links
StyleBase Class, StyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleBase::DateModified Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Properties > StyleBase::DateModified Property
StyleBase::DateModified Property
Collapse All

Gets the "Date modified" string for the style.

C#
public System::String DateModified;
Visual Basic
Public Property DateModified() As System::String
Links
StyleBase Class, StyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleBase::ModifiedBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Properties > StyleBase::ModifiedBy Property
StyleBase::ModifiedBy Property
Collapse All

Gets the "Modified by" string for the style.

C#
public System::String ModifiedBy;
Visual Basic
Public Property ModifiedBy() As System::String
Links
StyleBase Class, StyleBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleCollectionBase Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class
StyleCollectionBase Class
Collapse All

The base class for all style collections.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::BandStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::MarkerStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::ProjectionStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::TableStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSetCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSetCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSetCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsListCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyleCollection
C#
public class StyleCollectionBase : TreeOidWrapper, System::Collections::Generic::IEnumerable<Autodesk::AutoCAD::DatabaseServices::ObjectId>;
Visual Basic
Public Class StyleCollectionBase
Inherits TreeOidWrapper
Inherits System::Collections::Generic::IEnumerable<Autodesk::AutoCAD::DatabaseServices::ObjectId>
Links
StyleCollectionBase Methods, StyleCollectionBase Properties, StyleCollectionBase Members, Class Hierarchy


StyleCollectionBase Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Members
StyleCollectionBase Members
Collapse All

The following tables list the members exposed by StyleCollectionBase.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


StyleCollectionBase Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods
StyleCollectionBase Methods
Collapse All

The methods of StyleCollectionBase are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Links
Public Methods


StyleCollectionBase::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods > StyleCollectionBase::Add Method
StyleCollectionBase::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
StyleCollectionBase Class, StyleCollectionBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleCollectionBase::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods > StyleCollectionBase::GetEnumerator Method
StyleCollectionBase::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<Autodesk::AutoCAD::DatabaseServices::ObjectId> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<Autodesk::AutoCAD::DatabaseServices::ObjectId>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
StyleCollectionBase Class, StyleCollectionBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleCollectionBase::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods > StyleCollectionBase::GetObjectEnumerator Method
StyleCollectionBase::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
StyleCollectionBase Class, StyleCollectionBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods > Remove Method
Remove Method
Collapse All

Overloaded

Overload List
Method | Description
StyleCollectionBase::Remove (int) | Removes a style by index from the collection.
StyleCollectionBase::Remove (StyleBase^) | Removes a style by Object from the collection.
StyleCollectionBase::Remove (System::String^) | Removes a style by name from the collection.


StyleCollectionBase::Remove Method (StyleBase^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods > Remove Method > StyleCollectionBase::Remove Method (StyleBase^)
StyleCollectionBase::Remove Method (StyleBase^) deprecated
Collapse All

Removes a style by Object from the collection.

C#
public Remove(
    ref StyleBase style
);
Visual Basic
Public Sub Remove(
    ByRef style As StyleBase
)
Parameters
Parameters | Description
style | The style object to remove from the collection.
Notes

Deprecated: Use the override methods with an index or name instead.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style is invalid or not exist in the collection.
System.InvalidOperationException | Thrown when style is still in use.
Links
StyleCollectionBase Class, StyleCollectionBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleCollectionBase::Remove Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods > Remove Method > StyleCollectionBase::Remove Method (System::String^)
StyleCollectionBase::Remove Method (System::String^)
Collapse All

Removes a style by name from the collection.

C#
public Remove(
    ref System::String styleName
);
Visual Basic
Public Sub Remove(
    ByRef styleName As System::String
)
Parameters
Parameters | Description
styleName | The name of the style to remove from the collection.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name is invalid or not exist in the collection.
System.InvalidOperationException | Thrown when style is still in use.
Links
StyleCollectionBase Class, StyleCollectionBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleCollectionBase::Remove Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods > Remove Method > StyleCollectionBase::Remove Method (int)
StyleCollectionBase::Remove Method (int)
Collapse All

Removes a style by index from the collection.

C#
public Remove(
    int index
);
Visual Basic
Public Sub Remove(
    index As Integer
)
Parameters
Parameters | Description
index | The index of the style to remove from the collection.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of range.
System.InvalidOperationException | Thrown when style is still in use.
Links
StyleCollectionBase Class, StyleCollectionBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleCollectionBase Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Properties
StyleCollectionBase Properties
Collapse All

The properties of StyleCollectionBase are listed here.

Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Properties


StyleCollectionBase::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Properties > StyleCollectionBase::Count Property
StyleCollectionBase::Count Property
Collapse All

Gets the number of style objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
StyleCollectionBase Class, StyleCollectionBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StyleCollectionBase::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Properties > StyleCollectionBase::default Property
StyleCollectionBase::default Property
Collapse All

Gets the style by name or index from the collection.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId default;
Visual Basic
Public Property default() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of range.
Links
StyleCollectionBase Class, StyleCollectionBase Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class
StylesRoot Class
Collapse All

The root class for accessing collections of all Civil 3D styles.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StylesRoot
C#
public class StylesRoot : TreeOidWrapper;
Visual Basic
Public Class StylesRoot
Inherits TreeOidWrapper
Links
StylesRoot Properties, StylesRoot Members, Class Hierarchy


StylesRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Members
StylesRoot Members
Collapse All

The following tables list the members exposed by StylesRoot.

Public Properties
Public Property | Description
AlignmentDesignCheckSets | Gets the collection of alignment design check set in the database.
AlignmentStyles | Gets the collection of all alignment styles in the database.
AssemblyStyles | Gets the collection of AssemblyStyle objects in the database.
BandStyles | Gets the root object of Civil 3D band styles.
BuildingSiteStyles | Gets the collection of BuildingSiteStyle objects in the database.
CodeSetStyles | Gets the collection of CodeSetStyle objects in the database.
CorridorStyles | Gets the collection of all corridor styles in the database.
FeatureLineStyles | Gets the collection of all feature line styles in the database.
GradingCriteriaSets | Gets the collection of GradingCriteriaSet objects in the database.
GradingStyles | Gets the collection of all grading styles in the database.
GroupPlotStyles | Gets the collection of all group plot styles in the database.
InterferenceStyles | Gets the collection of all interference styles in the database.
IntersectionStyles | Gets the collection of IntersectionStyle objects in the database.
LabelSetStyles | Gets the root object of Civil 3D label set styles.
LabelStyles | Gets the root object of Civil 3D label styles.
LinkStyles | Gets the collection of LinkStyle objects in the database.
MarkerStyles | Gets the root object of Civil 3D mark styles.
MassHaulLineStyles | Gets the collection of MassHaulLineStyle objects in the database.
MassHaulViewStyles | Gets the collection of MassHaulViewStyle objects in the database.
MatchLineStyles | Gets the collection of all match line styles in the database.
ParcelStyles | Gets the collection of all parcel styles in the database.
PartsListSet | Gets the collection of parts list in the database.
PipeRuleSetStyles | Gets the collection of all pipe rule set styles in the database.
PipeStyles | Gets the collection of all pipe styles in the database.
PointStyles | Gets the collection of all point styles in the database.
ProfileDesignCheckSets | Gets the collection of profile design check set in the database.
ProfileStyles | Gets the collection of all profile styles in the database.
ProfileViewBandSetStyles | Gets the collection of all profile view band set styles in the database.
ProfileViewStyles | Gets the collection of all profile view styles in the database.
ProjectionStyles | Gets the collection of ProjectionStyle objects in the database.
QuantityTakeoffCriterias | Gets the collection of QuantityTakeoffCriteria objects in the database.
SampleLineStyles | Gets the collection of all sample line styles in the database.
SectionStyles | Gets the collection of all section styles in the database.
SectionViewBandSetStyles | Gets the collection of all section view band set styles in the database.
SectionViewStyles | Gets the collection of all section view styles in the database.
ShapeStyles | Gets the collection of ShapeStyle objects in the database.
SheetStyles | Gets the collection of all sheet styles in the database.
SlopePatternStyles | Gets the collection of SlopePatternStyle objects in the database.
StructureRuleSetStyles | Gets the collection of all structure rule set styles in the database.
StructureStyles | Gets the collection of all structure styles in the database.
SurfaceStyles | Gets the collection of all surface styles in the database.
SurveyFigureStyles | Gets the collection of SurveyFigureStyle objects in the database.
SurveyNetworkStyles | Gets the collection of SurveyNetworkStyle objects in the database.
TableStyles | Gets the root object of Civil 3D table styles.
ViewFrameStyles | Gets the collection of all view frame styles in the database.
Links
Public Properties


StylesRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties
StylesRoot Properties
Collapse All

The properties of StylesRoot are listed here.

Public Properties
Public Property | Description
AlignmentDesignCheckSets | Gets the collection of alignment design check set in the database.
AlignmentStyles | Gets the collection of all alignment styles in the database.
AssemblyStyles | Gets the collection of AssemblyStyle objects in the database.
BandStyles | Gets the root object of Civil 3D band styles.
BuildingSiteStyles | Gets the collection of BuildingSiteStyle objects in the database.
CodeSetStyles | Gets the collection of CodeSetStyle objects in the database.
CorridorStyles | Gets the collection of all corridor styles in the database.
FeatureLineStyles | Gets the collection of all feature line styles in the database.
GradingCriteriaSets | Gets the collection of GradingCriteriaSet objects in the database.
GradingStyles | Gets the collection of all grading styles in the database.
GroupPlotStyles | Gets the collection of all group plot styles in the database.
InterferenceStyles | Gets the collection of all interference styles in the database.
IntersectionStyles | Gets the collection of IntersectionStyle objects in the database.
LabelSetStyles | Gets the root object of Civil 3D label set styles.
LabelStyles | Gets the root object of Civil 3D label styles.
LinkStyles | Gets the collection of LinkStyle objects in the database.
MarkerStyles | Gets the root object of Civil 3D mark styles.
MassHaulLineStyles | Gets the collection of MassHaulLineStyle objects in the database.
MassHaulViewStyles | Gets the collection of MassHaulViewStyle objects in the database.
MatchLineStyles | Gets the collection of all match line styles in the database.
ParcelStyles | Gets the collection of all parcel styles in the database.
PartsListSet | Gets the collection of parts list in the database.
PipeRuleSetStyles | Gets the collection of all pipe rule set styles in the database.
PipeStyles | Gets the collection of all pipe styles in the database.
PointStyles | Gets the collection of all point styles in the database.
ProfileDesignCheckSets | Gets the collection of profile design check set in the database.
ProfileStyles | Gets the collection of all profile styles in the database.
ProfileViewBandSetStyles | Gets the collection of all profile view band set styles in the database.
ProfileViewStyles | Gets the collection of all profile view styles in the database.
ProjectionStyles | Gets the collection of ProjectionStyle objects in the database.
QuantityTakeoffCriterias | Gets the collection of QuantityTakeoffCriteria objects in the database.
SampleLineStyles | Gets the collection of all sample line styles in the database.
SectionStyles | Gets the collection of all section styles in the database.
SectionViewBandSetStyles | Gets the collection of all section view band set styles in the database.
SectionViewStyles | Gets the collection of all section view styles in the database.
ShapeStyles | Gets the collection of ShapeStyle objects in the database.
SheetStyles | Gets the collection of all sheet styles in the database.
SlopePatternStyles | Gets the collection of SlopePatternStyle objects in the database.
StructureRuleSetStyles | Gets the collection of all structure rule set styles in the database.
StructureStyles | Gets the collection of all structure styles in the database.
SurfaceStyles | Gets the collection of all surface styles in the database.
SurveyFigureStyles | Gets the collection of SurveyFigureStyle objects in the database.
SurveyNetworkStyles | Gets the collection of SurveyNetworkStyle objects in the database.
TableStyles | Gets the root object of Civil 3D table styles.
ViewFrameStyles | Gets the collection of all view frame styles in the database.
Links
Public Properties


StylesRoot::AlignmentDesignCheckSets Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::AlignmentDesignCheckSets Property
StylesRoot::AlignmentDesignCheckSets Property
Collapse All

Gets the collection of alignment design check set in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSetCollection AlignmentDesignCheckSets;
Visual Basic
Public Property AlignmentDesignCheckSets() As Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSetCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::AlignmentStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::AlignmentStyles Property
StylesRoot::AlignmentStyles Property
Collapse All

Gets the collection of all alignment styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyleCollection AlignmentStyles;
Visual Basic
Public Property AlignmentStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::AssemblyStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::AssemblyStyles Property
StylesRoot::AssemblyStyles Property
Collapse All

Gets the collection of AssemblyStyle objects in the database.

C#
public Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyleCollection AssemblyStyles;
Visual Basic
Public Property AssemblyStyles() As Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::BandStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::BandStyles Property
StylesRoot::BandStyles Property
Collapse All

Gets the root object of Civil 3D band styles.

C#
public BandStylesRoot BandStyles;
Visual Basic
Public Property BandStyles() As BandStylesRoot
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::BuildingSiteStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::BuildingSiteStyles Property
StylesRoot::BuildingSiteStyles Property
Collapse All

Gets the collection of BuildingSiteStyle objects in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyleCollection BuildingSiteStyles;
Visual Basic
Public Property BuildingSiteStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::CodeSetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::CodeSetStyles Property
StylesRoot::CodeSetStyles Property
Collapse All

Gets the collection of CodeSetStyle objects in the database.

C#
public Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleCollection CodeSetStyles;
Visual Basic
Public Property CodeSetStyles() As Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::CorridorStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::CorridorStyles Property
StylesRoot::CorridorStyles Property
Collapse All

Gets the collection of all corridor styles in the database.

C#
public Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyleCollection CorridorStyles;
Visual Basic
Public Property CorridorStyles() As Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::FeatureLineStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::FeatureLineStyles Property
StylesRoot::FeatureLineStyles Property
Collapse All

Gets the collection of all feature line styles in the database.

C#
public Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyleCollection FeatureLineStyles;
Visual Basic
Public Property FeatureLineStyles() As Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::GradingCriteriaSets Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::GradingCriteriaSets Property
StylesRoot::GradingCriteriaSets Property
Collapse All

Gets the collection of GradingCriteriaSet objects in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSetCollection GradingCriteriaSets;
Visual Basic
Public Property GradingCriteriaSets() As Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSetCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::GradingStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::GradingStyles Property
StylesRoot::GradingStyles Property
Collapse All

Gets the collection of all grading styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyleCollection GradingStyles;
Visual Basic
Public Property GradingStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::GroupPlotStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::GroupPlotStyles Property
StylesRoot::GroupPlotStyles Property
Collapse All

Gets the collection of all group plot styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyleCollection GroupPlotStyles;
Visual Basic
Public Property GroupPlotStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::InterferenceStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::InterferenceStyles Property
StylesRoot::InterferenceStyles Property
Collapse All

Gets the collection of all interference styles in the database.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyleCollection InterferenceStyles;
Visual Basic
Public Property InterferenceStyles() As Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::IntersectionStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::IntersectionStyles Property
StylesRoot::IntersectionStyles Property
Collapse All

Gets the collection of IntersectionStyle objects in the database.

C#
public Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyleCollection IntersectionStyles;
Visual Basic
Public Property IntersectionStyles() As Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::LabelSetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::LabelSetStyles Property
StylesRoot::LabelSetStyles Property
Collapse All

Gets the root object of Civil 3D label set styles.

C#
public LabelSetStylesRoot LabelSetStyles;
Visual Basic
Public Property LabelSetStyles() As LabelSetStylesRoot
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::LabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::LabelStyles Property
StylesRoot::LabelStyles Property
Collapse All

Gets the root object of Civil 3D label styles.

C#
public LabelStylesRoot LabelStyles;
Visual Basic
Public Property LabelStyles() As LabelStylesRoot
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::LinkStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::LinkStyles Property
StylesRoot::LinkStyles Property
Collapse All

Gets the collection of LinkStyle objects in the database.

C#
public Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyleCollection LinkStyles;
Visual Basic
Public Property LinkStyles() As Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::MarkerStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::MarkerStyles Property
StylesRoot::MarkerStyles Property
Collapse All

Gets the root object of Civil 3D mark styles.

C#
public MarkerStyleCollection MarkerStyles;
Visual Basic
Public Property MarkerStyles() As MarkerStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::MassHaulLineStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::MassHaulLineStyles Property
StylesRoot::MassHaulLineStyles Property
Collapse All

Gets the collection of MassHaulLineStyle objects in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyleCollection MassHaulLineStyles;
Visual Basic
Public Property MassHaulLineStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::MassHaulViewStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::MassHaulViewStyles Property
StylesRoot::MassHaulViewStyles Property
Collapse All

Gets the collection of MassHaulViewStyle objects in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyleCollection MassHaulViewStyles;
Visual Basic
Public Property MassHaulViewStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::MatchLineStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::MatchLineStyles Property
StylesRoot::MatchLineStyles Property
Collapse All

Gets the collection of all match line styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::MatchLineStyleCollection MatchLineStyles;
Visual Basic
Public Property MatchLineStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::MatchLineStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::ParcelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::ParcelStyles Property
StylesRoot::ParcelStyles Property
Collapse All

Gets the collection of all parcel styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::ParcelStyleCollection ParcelStyles;
Visual Basic
Public Property ParcelStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::ParcelStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::PartsListSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::PartsListSet Property
StylesRoot::PartsListSet Property
Collapse All

Gets the collection of parts list in the database.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsListCollection PartsListSet;
Visual Basic
Public Property PartsListSet() As Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsListCollection
Example
PartsListCollection oPartListCollection = doc.Styles.PartsListSet;
ed.WriteMessage("Number of parts lists in document: {0}n", oPartListCollection.Count);
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::PipeRuleSetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::PipeRuleSetStyles Property
StylesRoot::PipeRuleSetStyles Property
Collapse All

Gets the collection of all pipe rule set styles in the database.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyleCollection PipeRuleSetStyles;
Visual Basic
Public Property PipeRuleSetStyles() As Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::PipeStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::PipeStyles Property
StylesRoot::PipeStyles Property
Collapse All

Gets the collection of all pipe styles in the database.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleCollection PipeStyles;
Visual Basic
Public Property PipeStyles() As Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::PointStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::PointStyles Property
StylesRoot::PointStyles Property
Collapse All

Gets the collection of all point styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::PointStyleCollection PointStyles;
Visual Basic
Public Property PointStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::PointStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::ProfileDesignCheckSets Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::ProfileDesignCheckSets Property
StylesRoot::ProfileDesignCheckSets Property
Collapse All

Gets the collection of profile design check set in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSetCollection ProfileDesignCheckSets;
Visual Basic
Public Property ProfileDesignCheckSets() As Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSetCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::ProfileStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::ProfileStyles Property
StylesRoot::ProfileStyles Property
Collapse All

Gets the collection of all profile styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::ProfileStyleCollection ProfileStyles;
Visual Basic
Public Property ProfileStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::ProfileStyleCollection
Example
// get first style in the document
ObjectId styleId = doc.Styles.ProfileStyles[0];
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::ProfileViewBandSetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::ProfileViewBandSetStyles Property
StylesRoot::ProfileViewBandSetStyles Property
Collapse All

Gets the collection of all profile view band set styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetStyleCollection ProfileViewBandSetStyles;
Visual Basic
Public Property ProfileViewBandSetStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::ProfileViewStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::ProfileViewStyles Property
StylesRoot::ProfileViewStyles Property
Collapse All

Gets the collection of all profile view styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyleCollection ProfileViewStyles;
Visual Basic
Public Property ProfileViewStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::ProjectionStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::ProjectionStyles Property
StylesRoot::ProjectionStyles Property
Collapse All

Gets the collection of ProjectionStyle objects in the database.

C#
public Autodesk::Civil::DatabaseServices::Styles::ProjectionStyleCollection ProjectionStyles;
Visual Basic
Public Property ProjectionStyles() As Autodesk::Civil::DatabaseServices::Styles::ProjectionStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::QuantityTakeoffCriterias Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::QuantityTakeoffCriterias Property
StylesRoot::QuantityTakeoffCriterias Property
Collapse All

Gets the collection of QuantityTakeoffCriteria objects in the database.

C#
public Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaCollection QuantityTakeoffCriterias;
Visual Basic
Public Property QuantityTakeoffCriterias() As Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::SampleLineStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::SampleLineStyles Property
StylesRoot::SampleLineStyles Property
Collapse All

Gets the collection of all sample line styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineStyleCollection SampleLineStyles;
Visual Basic
Public Property SampleLineStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::SectionStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::SectionStyles Property
StylesRoot::SectionStyles Property
Collapse All

Gets the collection of all section styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::SectionStyleCollection SectionStyles;
Visual Basic
Public Property SectionStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::SectionStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::SectionViewBandSetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::SectionViewBandSetStyles Property
StylesRoot::SectionViewBandSetStyles Property
Collapse All

Gets the collection of all section view band set styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetStyleCollection SectionViewBandSetStyles;
Visual Basic
Public Property SectionViewBandSetStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::SectionViewStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::SectionViewStyles Property
StylesRoot::SectionViewStyles Property
Collapse All

Gets the collection of all section view styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewStyleCollection SectionViewStyles;
Visual Basic
Public Property SectionViewStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::ShapeStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::ShapeStyles Property
StylesRoot::ShapeStyles Property
Collapse All

Gets the collection of ShapeStyle objects in the database.

C#
public Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyleCollection ShapeStyles;
Visual Basic
Public Property ShapeStyles() As Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::SheetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::SheetStyles Property
StylesRoot::SheetStyles Property
Collapse All

Gets the collection of all sheet styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::SheetStyleCollection SheetStyles;
Visual Basic
Public Property SheetStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::SheetStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::SlopePatternStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::SlopePatternStyles Property
StylesRoot::SlopePatternStyles Property
Collapse All

Gets the collection of SlopePatternStyle objects in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyleCollection SlopePatternStyles;
Visual Basic
Public Property SlopePatternStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::StructureRuleSetStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::StructureRuleSetStyles Property
StylesRoot::StructureRuleSetStyles Property
Collapse All

Gets the collection of all structure rule set styles in the database.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyleCollection StructureRuleSetStyles;
Visual Basic
Public Property StructureRuleSetStyles() As Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::StructureStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::StructureStyles Property
StylesRoot::StructureStyles Property
Collapse All

Gets the collection of all structure styles in the database.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleCollection StructureStyles;
Visual Basic
Public Property StructureStyles() As Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::SurfaceStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::SurfaceStyles Property
StylesRoot::SurfaceStyles Property
Collapse All

Gets the collection of all surface styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceStyleCollection SurfaceStyles;
Visual Basic
Public Property SurfaceStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::SurveyFigureStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::SurveyFigureStyles Property
StylesRoot::SurveyFigureStyles Property
Collapse All

Gets the collection of SurveyFigureStyle objects in the database.

C#
public Autodesk::Civil::Survey::DatabaseServices::Styles::SurveyFigureStyleCollection SurveyFigureStyles;
Visual Basic
Public Property SurveyFigureStyles() As Autodesk::Civil::Survey::DatabaseServices::Styles::SurveyFigureStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::SurveyNetworkStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::SurveyNetworkStyles Property
StylesRoot::SurveyNetworkStyles Property
Collapse All

Gets the collection of SurveyNetworkStyle objects in the database.

C#
public Autodesk::Civil::Survey::DatabaseServices::Styles::SurveyNetworkStyleCollection SurveyNetworkStyles;
Visual Basic
Public Property SurveyNetworkStyles() As Autodesk::Civil::Survey::DatabaseServices::Styles::SurveyNetworkStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::TableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::TableStyles Property
StylesRoot::TableStyles Property
Collapse All

Gets the root object of Civil 3D table styles.

C#
public TableStylesRoot TableStyles;
Visual Basic
Public Property TableStyles() As TableStylesRoot
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


StylesRoot::ViewFrameStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties > StylesRoot::ViewFrameStyles Property
StylesRoot::ViewFrameStyles Property
Collapse All

Gets the collection of all view frame styles in the database.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::ViewFrameStyleCollection ViewFrameStyles;
Visual Basic
Public Property ViewFrameStyles() As Autodesk::Civil::Land::DatabaseServices::Styles::ViewFrameStyleCollection
Links
StylesRoot Class, StylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class
TableStyle Class
Collapse All

Controls the display of tables.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::TableStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbScheduleTableStyle"))]
public class TableStyle : StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbScheduleTableStyle"))>
Public Class TableStyle
Inherits StyleBase
Links
TableStyle Methods, TableStyle Properties, TableStyle Members, Class Hierarchy


TableStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Members
TableStyle Members
Collapse All

The following tables list the members exposed by TableStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BorderDisplayStyleModel | Gets the AeccDisplayStyle object that specifies Model display settings such as layer and linetype for the graphic line that forms... more
BorderDisplayStylePlan | Gets the AeccDisplayStyle object that specifies Plan display settings such as layer and linetype for the graphic line that forms... more
ColumnStyles | Gets the ColumnStyles collection of styles defining column width and value properties.
CreateBy | Gets or Sets the "Created by" string for the style.
DataAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for all... more
DataAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for all... more
DataDividerDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the vertical graphic line that separates columns.
DataDividerDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the vertical graphic line that separates columns.
DataSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates data rows.
DataSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates data rows.
DataTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the all text in data rows of table.
DataTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the all text in data rows of table.
DataTextHeight | Gets or sets the height for row data text.
DataTextStyle | Gets or sets the text style for the row data from the available AutoCAD text styles defined in the current... more
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
EnableWordWrapping | Gets or sets the boolean value that determines whether to force text to fit within the specified width of the... more
HeaderAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the... more
HeaderAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the... more
HeaderSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates column headings from data rows.... more
HeaderSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates column headings from data rows.... more
HeaderTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the column names in second row of table.
HeaderTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the column names in second row of table.
HeaderTextHeight | Gets or sets the height for column headings text.
HeaderTextStyle | Gets or sets the text style for the column headings from the available AutoCAD text styles defined in the current... more
MaintainViewOrientation | Gets or sets the boolean value that determines whether to realign the table to the view (screen) direction regardless of... more
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RepeatHeaderInSplitTables | Gets or sets the boolean value that determines whether to show the column headers when displaying split tables.
RepeatTitleInSplitTables | Gets or sets the boolean value that determines whether to show the title header when displaying split tables.
SortData | Gets or sets the boolean value that specifies whether to enable the table style data sorting option.
SortingColumn | Gets or sets the column that determines whether to organize drawing information for clear and quick reference.
SortingOrder | Gets or sets the AeccTableSortingOrderType enum value that specifies the table style sort order as either ascending or descending.
TableType | Gets the type of feature to which this table style applies.
Title | Gets or sets the title that displays as the first row of a table.
TitleAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the... more
TitleAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the... more
TitleJustification | Gets or sets the justification of the title that displays as the first row of a table.
TitleSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates title from column headings.
TitleSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates title from column headings.
TitleTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the table name in first row of table.
TitleTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the table name in first row of table.
TitleTextHeight | The text height of the table title.
TitleTextStyle | Gets or sets the text style for the title text from the available AutoCAD text styles defined in the current... more
TitleUnformatted | Gets the unformatted table title string.
TransposeSectionViewTable | Gets or sets the boolean value that determines whether to transpose the section view table.
Links
Public Methods, Public Properties


TableStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Methods
TableStyle Methods
Collapse All

The methods of TableStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties.
Links
Public Methods


TableStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Methods > TableStyle::GetDisplayStyleModel Method
TableStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies model display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    TableDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As TableDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the table style type is TableStyleType::SectionViewTotalVolume or TableStyleType::SectionViewMaterial.
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Methods > TableStyle::GetDisplayStylePlan Method
TableStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    TableDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As TableDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties
TableStyle Properties
Collapse All

The properties of TableStyle are listed here.

Public Properties
Public Property | Description
BorderDisplayStyleModel | Gets the AeccDisplayStyle object that specifies Model display settings such as layer and linetype for the graphic line that forms... more
BorderDisplayStylePlan | Gets the AeccDisplayStyle object that specifies Plan display settings such as layer and linetype for the graphic line that forms... more
ColumnStyles | Gets the ColumnStyles collection of styles defining column width and value properties.
DataAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for all... more
DataAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for all... more
DataDividerDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the vertical graphic line that separates columns.
DataDividerDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the vertical graphic line that separates columns.
DataSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates data rows.
DataSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates data rows.
DataTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the all text in data rows of table.
DataTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the all text in data rows of table.
DataTextHeight | Gets or sets the height for row data text.
DataTextStyle | Gets or sets the text style for the row data from the available AutoCAD text styles defined in the current... more
EnableWordWrapping | Gets or sets the boolean value that determines whether to force text to fit within the specified width of the... more
HeaderAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the... more
HeaderAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the... more
HeaderSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates column headings from data rows.... more
HeaderSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates column headings from data rows.... more
HeaderTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the column names in second row of table.
HeaderTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the column names in second row of table.
HeaderTextHeight | Gets or sets the height for column headings text.
HeaderTextStyle | Gets or sets the text style for the column headings from the available AutoCAD text styles defined in the current... more
MaintainViewOrientation | Gets or sets the boolean value that determines whether to realign the table to the view (screen) direction regardless of... more
RepeatHeaderInSplitTables | Gets or sets the boolean value that determines whether to show the column headers when displaying split tables.
RepeatTitleInSplitTables | Gets or sets the boolean value that determines whether to show the title header when displaying split tables.
SortData | Gets or sets the boolean value that specifies whether to enable the table style data sorting option.
SortingColumn | Gets or sets the column that determines whether to organize drawing information for clear and quick reference.
SortingOrder | Gets or sets the AeccTableSortingOrderType enum value that specifies the table style sort order as either ascending or descending.
TableType | Gets the type of feature to which this table style applies.
Title | Gets or sets the title that displays as the first row of a table.
TitleAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the... more
TitleAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the... more
TitleJustification | Gets or sets the justification of the title that displays as the first row of a table.
TitleSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates title from column headings.
TitleSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates title from column headings.
TitleTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the table name in first row of table.
TitleTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the table name in first row of table.
TitleTextHeight | The text height of the table title.
TitleTextStyle | Gets or sets the text style for the title text from the available AutoCAD text styles defined in the current... more
TitleUnformatted | Gets the unformatted table title string.
TransposeSectionViewTable | Gets or sets the boolean value that determines whether to transpose the section view table.
Links
Public Properties


TableStyle::BorderDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::BorderDisplayStyleModel Property
TableStyle::BorderDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle object that specifies Model display settings such as layer and linetype for the graphic line that forms a boundary around the outside of table.

C#
public DisplayStyle BorderDisplayStyleModel;
Visual Basic
Public Property BorderDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetBorderDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::BorderDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::BorderDisplayStylePlan Property
TableStyle::BorderDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle object that specifies Plan display settings such as layer and linetype for the graphic line that forms a boundary around the outside of table.

C#
public DisplayStyle BorderDisplayStylePlan;
Visual Basic
Public Property BorderDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetBorderDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::ColumnStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::ColumnStyles Property
TableStyle::ColumnStyles Property
Collapse All

Gets the ColumnStyles collection of styles defining column width and value properties.

C#
public ColumnStyleCollection ColumnStyles;
Visual Basic
Public Property ColumnStyles() As ColumnStyleCollection
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataAreaFillDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataAreaFillDisplayStyleModel Property
TableStyle::DataAreaFillDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for all data rows.

C#
public DisplayStyle DataAreaFillDisplayStyleModel;
Visual Basic
Public Property DataAreaFillDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataAreaFillDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataAreaFillDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataAreaFillDisplayStylePlan Property
TableStyle::DataAreaFillDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for all data rows.

C#
public DisplayStyle DataAreaFillDisplayStylePlan;
Visual Basic
Public Property DataAreaFillDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataAreaFillDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataDividerDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataDividerDisplayStyleModel Property
TableStyle::DataDividerDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the vertical graphic line that separates columns.

C#
public DisplayStyle DataDividerDisplayStyleModel;
Visual Basic
Public Property DataDividerDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataDividerDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataDividerDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataDividerDisplayStylePlan Property
TableStyle::DataDividerDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the vertical graphic line that separates columns.

C#
public DisplayStyle DataDividerDisplayStylePlan;
Visual Basic
Public Property DataDividerDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataDividerDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataSeparatorDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataSeparatorDisplayStyleModel Property
TableStyle::DataSeparatorDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates data rows.

C#
public DisplayStyle DataSeparatorDisplayStyleModel;
Visual Basic
Public Property DataSeparatorDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataSeparatorDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataSeparatorDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataSeparatorDisplayStylePlan Property
TableStyle::DataSeparatorDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates data rows.

C#
public DisplayStyle DataSeparatorDisplayStylePlan;
Visual Basic
Public Property DataSeparatorDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataSeparatorDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataTextDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataTextDisplayStyleModel Property
TableStyle::DataTextDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the all text in data rows of table.

C#
public DisplayStyle DataTextDisplayStyleModel;
Visual Basic
Public Property DataTextDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataTextDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataTextDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataTextDisplayStylePlan Property
TableStyle::DataTextDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the all text in data rows of table.

C#
public DisplayStyle DataTextDisplayStylePlan;
Visual Basic
Public Property DataTextDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetDataTextDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataTextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataTextHeight Property
TableStyle::DataTextHeight Property
Collapse All

Gets or sets the height for row data text.

C#
public double DataTextHeight;
Visual Basic
Public Property DataTextHeight() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.00001, 10.0] in meteres drawing units.
  2. The input value is out of the interval [0.000033333333333333333333333333333333, 32.808398950131233595800524934383] in feet drawing units.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::DataTextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::DataTextStyle Property
TableStyle::DataTextStyle Property
Collapse All

Gets or sets the text style for the row data from the available AutoCAD text styles defined in the current drawing.

C#
public System::String DataTextStyle;
Visual Basic
Public Property DataTextStyle() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting a data text style that is not exist.
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::EnableWordWrapping Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::EnableWordWrapping Property
TableStyle::EnableWordWrapping Property
Collapse All

Gets or sets the boolean value that determines whether to force text to fit within the specified width of the column boundary by wrapping text to display as multiple lines as necessary.

C#
public bool EnableWordWrapping;
Visual Basic
Public Property EnableWordWrapping() As bool
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::HeaderAreaFillDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::HeaderAreaFillDisplayStyleModel Property
TableStyle::HeaderAreaFillDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the column heading areas.

C#
public DisplayStyle HeaderAreaFillDisplayStyleModel;
Visual Basic
Public Property HeaderAreaFillDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderAreaFillDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::HeaderAreaFillDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::HeaderAreaFillDisplayStylePlan Property
TableStyle::HeaderAreaFillDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the column heading areas.

C#
public DisplayStyle HeaderAreaFillDisplayStylePlan;
Visual Basic
Public Property HeaderAreaFillDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderAreaFillDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::HeaderSeparatorDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::HeaderSeparatorDisplayStyleModel Property
TableStyle::HeaderSeparatorDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates column headings from data rows.

C#
public DisplayStyle HeaderSeparatorDisplayStyleModel;
Visual Basic
Public Property HeaderSeparatorDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderSeparatorDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::HeaderSeparatorDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::HeaderSeparatorDisplayStylePlan Property
TableStyle::HeaderSeparatorDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates column headings from data rows.

C#
public DisplayStyle HeaderSeparatorDisplayStylePlan;
Visual Basic
Public Property HeaderSeparatorDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderSeparatorDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::HeaderTextDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::HeaderTextDisplayStyleModel Property
TableStyle::HeaderTextDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the column names in second row of table.

C#
public DisplayStyle HeaderTextDisplayStyleModel;
Visual Basic
Public Property HeaderTextDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderTextDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::HeaderTextDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::HeaderTextDisplayStylePlan Property
TableStyle::HeaderTextDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the column names in second row of table.

C#
public DisplayStyle HeaderTextDisplayStylePlan;
Visual Basic
Public Property HeaderTextDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetHeaderTextDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::HeaderTextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::HeaderTextHeight Property
TableStyle::HeaderTextHeight Property
Collapse All

Gets or sets the height for column headings text.

C#
public double HeaderTextHeight;
Visual Basic
Public Property HeaderTextHeight() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.00001, 10.0] in meteres drawing units.
  2. The input value is out of the interval [0.000033333333333333333333333333333333, 32.808398950131233595800524934383] in feet drawing units.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::HeaderTextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::HeaderTextStyle Property
TableStyle::HeaderTextStyle Property
Collapse All

Gets or sets the text style for the column headings from the available AutoCAD text styles defined in the current drawing.

C#
public System::String HeaderTextStyle;
Visual Basic
Public Property HeaderTextStyle() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting a header text style that is not exist.
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::MaintainViewOrientation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::MaintainViewOrientation Property
TableStyle::MaintainViewOrientation Property
Collapse All

Gets or sets the boolean value that determines whether to realign the table to the view (screen) direction regardless of User Coordinate System or twist settings.

C#
public bool MaintainViewOrientation;
Visual Basic
Public Property MaintainViewOrientation() As bool
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::RepeatHeaderInSplitTables Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::RepeatHeaderInSplitTables Property
TableStyle::RepeatHeaderInSplitTables Property
Collapse All

Gets or sets the boolean value that determines whether to show the column headers when displaying split tables.

C#
public bool RepeatHeaderInSplitTables;
Visual Basic
Public Property RepeatHeaderInSplitTables() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the table style type is TableStyleType::SectionViewTotalVolume or TableStyleType::SectionViewMaterial.
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::RepeatTitleInSplitTables Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::RepeatTitleInSplitTables Property
TableStyle::RepeatTitleInSplitTables Property
Collapse All

Gets or sets the boolean value that determines whether to show the title header when displaying split tables.

C#
public bool RepeatTitleInSplitTables;
Visual Basic
Public Property RepeatTitleInSplitTables() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the table style type is TableStyleType::SectionViewTotalVolume or TableStyleType::SectionViewMaterial.
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::SortData Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::SortData Property
TableStyle::SortData Property
Collapse All

Gets or sets the boolean value that specifies whether to enable the table style data sorting option.

C#
public bool SortData;
Visual Basic
Public Property SortData() As bool
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::SortingColumn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::SortingColumn Property
TableStyle::SortingColumn Property
Collapse All

Gets or sets the column that determines whether to organize drawing information for clear and quick reference.

C#
public long SortingColumn;
Visual Basic
Public Property SortingColumn() As long
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when setting a newValue that is greater than the table's column count.
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::SortingOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::SortingOrder Property
TableStyle::SortingOrder Property
Collapse All

Gets or sets the AeccTableSortingOrderType enum value that specifies the table style sort order as either ascending or descending.

C#
public TableSortingOrderType SortingOrder;
Visual Basic
Public Property SortingOrder() As TableSortingOrderType
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TableType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TableType Property
TableStyle::TableType Property
Collapse All

Gets the type of feature to which this table style applies.

C#
public TableStyleType TableType;
Visual Basic
Public Property TableType() As TableStyleType
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::Title Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::Title Property
TableStyle::Title Property
Collapse All

Gets or sets the title that displays as the first row of a table.

C#
public System::String Title;
Visual Basic
Public Property Title() As System::String
Remarks

Table titles must be justified left, center, or right.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleAreaFillDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleAreaFillDisplayStyleModel Property
TableStyle::TitleAreaFillDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the table title area.

C#
public DisplayStyle TitleAreaFillDisplayStyleModel;
Visual Basic
Public Property TitleAreaFillDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleAreaFillDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleAreaFillDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleAreaFillDisplayStylePlan Property
TableStyle::TitleAreaFillDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the table title area.

C#
public DisplayStyle TitleAreaFillDisplayStylePlan;
Visual Basic
Public Property TitleAreaFillDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleAreaFillDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleJustification Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleJustification Property
TableStyle::TitleJustification Property
Collapse All

Gets or sets the justification of the title that displays as the first row of a table.

C#
public TextJustificationType TitleJustification;
Visual Basic
Public Property TitleJustification() As TextJustificationType
Remarks

Table titles must be justified left, center, or right.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleSeparatorDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleSeparatorDisplayStyleModel Property
TableStyle::TitleSeparatorDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates title from column headings.

C#
public DisplayStyle TitleSeparatorDisplayStyleModel;
Visual Basic
Public Property TitleSeparatorDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleSeparatorDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleSeparatorDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleSeparatorDisplayStylePlan Property
TableStyle::TitleSeparatorDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates title from column headings.

C#
public DisplayStyle TitleSeparatorDisplayStylePlan;
Visual Basic
Public Property TitleSeparatorDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleSeparatorDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleTextDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleTextDisplayStyleModel Property
TableStyle::TitleTextDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Model display properties for the table name in first row of table.

C#
public DisplayStyle TitleTextDisplayStyleModel;
Visual Basic
Public Property TitleTextDisplayStyleModel() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleTextDisplayStyleModel instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleTextDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleTextDisplayStylePlan Property
TableStyle::TitleTextDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle that specifies Plan display properties for the table name in first row of table.

C#
public DisplayStyle TitleTextDisplayStylePlan;
Visual Basic
Public Property TitleTextDisplayStylePlan() As DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.DatabaseServices.Styles.TableStyle.GetTitleTextDisplayStylePlan instead.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleTextHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleTextHeight Property
TableStyle::TitleTextHeight Property
Collapse All

The text height of the table title.

C#
public double TitleTextHeight;
Visual Basic
Public Property TitleTextHeight() As double
Remarks

The table's row height is determined by the highest character in the title.

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [0.00001, 10.0] in meteres drawing units.
  2. The input value is out of the interval [0.000033333333333333333333333333333333, 32.808398950131233595800524934383] in feet drawing units.

Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleTextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleTextStyle Property
TableStyle::TitleTextStyle Property
Collapse All

Gets or sets the text style for the title text from the available AutoCAD text styles defined in the current drawing.

C#
public System::String TitleTextStyle;
Visual Basic
Public Property TitleTextStyle() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting a title text style that is not exist.
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TitleUnformatted Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TitleUnformatted Property
TableStyle::TitleUnformatted Property
Collapse All

Gets the unformatted table title string.

C#
public System::String TitleUnformatted;
Visual Basic
Public Property TitleUnformatted() As System::String
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyle::TransposeSectionViewTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties > TableStyle::TransposeSectionViewTable Property
TableStyle::TransposeSectionViewTable Property
Collapse All

Gets or sets the boolean value that determines whether to transpose the section view table.

C#
public bool TransposeSectionViewTable;
Visual Basic
Public Property TransposeSectionViewTable() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the table style type is neither TableStyleType::SectionViewTotalVolume nor TableStyleType::SectionViewMaterial.
Links
TableStyle Class, TableStyle Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class
TableStyleCollection Class
Collapse All

A collection of TableStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::TableStyleCollection
C#
public class TableStyleCollection : StyleCollectionBase;
Visual Basic
Public Class TableStyleCollection
Inherits StyleCollectionBase
Links
TableStyleCollection Methods, TableStyleCollection Members, Class Hierarchy


TableStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class > TableStyleCollection Members
TableStyleCollection Members
Collapse All

The following tables list the members exposed by TableStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


TableStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class > TableStyleCollection Methods
TableStyleCollection Methods
Collapse All

The methods of TableStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


TableStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class > TableStyleCollection Methods > TableStyleCollection::Add Method
TableStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
TableStyleCollection Class, TableStyleCollection Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class
TableStylesRoot Class
Collapse All

The root object of all Civil 3D table-related styles.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::TableStylesRoot
C#
public class TableStylesRoot : TreeOidWrapper;
Visual Basic
Public Class TableStylesRoot
Inherits TreeOidWrapper
Links
TableStylesRoot Properties, TableStylesRoot Members, Class Hierarchy


TableStylesRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Members
TableStylesRoot Members
Collapse All

The following tables list the members exposed by TableStylesRoot.

Public Properties
Public Property | Description
AlignmentCurveTableStyles | Gets the collection of all alignment curve table styles.
AlignmentLineTableStyles | Gets the collection of all alignment line table styles.
AlignmentSegmentTableStyles | Gets the collection of all alignment segment table styles.
AlignmentSpiralTableStyles | Gets the collection of all alignment spiral table styles.
ParcelAreaTableStyles | Gets the collection of all parcel area table styles.
ParcelCurveTableStyles | Gets the collection of all parcel curve table styles.
ParcelLineTableStyles | Gets the collection of all parcel line table styles.
ParcelSegmentTableStyles | Gets the collection of all parcel segment table styles.
PipeTableStyles | Gets the collection of all pipe table styles.
PointTableStyles | Gets the collection of all point table styles.
QuantityTakeoffMaterialTableStyles | Gets the collection of all quantity takeoff material table styles.
QuantityTakeoffTotalVolumeTableStyles | Gets the collection of all quantity takeoff total volume table styles.
SectionViewMaterialTableStyles | Gets the collection of all section view material table styles.
SectionViewTotalVolumeTableStyles | Gets the collection of all section view total volume table styles.
StructureTableStyles | Gets the collection of all structure table styles.
SurfaceContourTableStyles | Gets the collection of all surface contour table styles.
SurfaceDirectionTableStyles | Gets the collection of all surface direction table styles.
SurfaceElevationTableStyles | Gets the collection of all surface elevation table styles.
SurfaceSlopeArrowContourTableStyles | Gets the collection of all surface user slope arrow table styles.
SurfaceSlopeTableStyles | Gets the collection of all surface slope table styles.
SurfaceUserDefinedContourTableStyles | Gets the collection of all surface user defined contour table styles.
SurfaceWatershedTableStyles | Gets the collection of all surface watershed table styles.
Links
Public Properties


TableStylesRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties
TableStylesRoot Properties
Collapse All

The properties of TableStylesRoot are listed here.

Public Properties
Public Property | Description
AlignmentCurveTableStyles | Gets the collection of all alignment curve table styles.
AlignmentLineTableStyles | Gets the collection of all alignment line table styles.
AlignmentSegmentTableStyles | Gets the collection of all alignment segment table styles.
AlignmentSpiralTableStyles | Gets the collection of all alignment spiral table styles.
ParcelAreaTableStyles | Gets the collection of all parcel area table styles.
ParcelCurveTableStyles | Gets the collection of all parcel curve table styles.
ParcelLineTableStyles | Gets the collection of all parcel line table styles.
ParcelSegmentTableStyles | Gets the collection of all parcel segment table styles.
PipeTableStyles | Gets the collection of all pipe table styles.
PointTableStyles | Gets the collection of all point table styles.
QuantityTakeoffMaterialTableStyles | Gets the collection of all quantity takeoff material table styles.
QuantityTakeoffTotalVolumeTableStyles | Gets the collection of all quantity takeoff total volume table styles.
SectionViewMaterialTableStyles | Gets the collection of all section view material table styles.
SectionViewTotalVolumeTableStyles | Gets the collection of all section view total volume table styles.
StructureTableStyles | Gets the collection of all structure table styles.
SurfaceContourTableStyles | Gets the collection of all surface contour table styles.
SurfaceDirectionTableStyles | Gets the collection of all surface direction table styles.
SurfaceElevationTableStyles | Gets the collection of all surface elevation table styles.
SurfaceSlopeArrowContourTableStyles | Gets the collection of all surface user slope arrow table styles.
SurfaceSlopeTableStyles | Gets the collection of all surface slope table styles.
SurfaceUserDefinedContourTableStyles | Gets the collection of all surface user defined contour table styles.
SurfaceWatershedTableStyles | Gets the collection of all surface watershed table styles.
Links
Public Properties


TableStylesRoot::AlignmentCurveTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::AlignmentCurveTableStyles Property
TableStylesRoot::AlignmentCurveTableStyles Property
Collapse All

Gets the collection of all alignment curve table styles.

C#
public TableStyleCollection AlignmentCurveTableStyles;
Visual Basic
Public Property AlignmentCurveTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::AlignmentLineTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::AlignmentLineTableStyles Property
TableStylesRoot::AlignmentLineTableStyles Property
Collapse All

Gets the collection of all alignment line table styles.

C#
public TableStyleCollection AlignmentLineTableStyles;
Visual Basic
Public Property AlignmentLineTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::AlignmentSegmentTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::AlignmentSegmentTableStyles Property
TableStylesRoot::AlignmentSegmentTableStyles Property
Collapse All

Gets the collection of all alignment segment table styles.

C#
public TableStyleCollection AlignmentSegmentTableStyles;
Visual Basic
Public Property AlignmentSegmentTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::AlignmentSpiralTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::AlignmentSpiralTableStyles Property
TableStylesRoot::AlignmentSpiralTableStyles Property
Collapse All

Gets the collection of all alignment spiral table styles.

C#
public TableStyleCollection AlignmentSpiralTableStyles;
Visual Basic
Public Property AlignmentSpiralTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::ParcelAreaTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::ParcelAreaTableStyles Property
TableStylesRoot::ParcelAreaTableStyles Property
Collapse All

Gets the collection of all parcel area table styles.

C#
public TableStyleCollection ParcelAreaTableStyles;
Visual Basic
Public Property ParcelAreaTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::ParcelCurveTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::ParcelCurveTableStyles Property
TableStylesRoot::ParcelCurveTableStyles Property
Collapse All

Gets the collection of all parcel curve table styles.

C#
public TableStyleCollection ParcelCurveTableStyles;
Visual Basic
Public Property ParcelCurveTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::ParcelLineTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::ParcelLineTableStyles Property
TableStylesRoot::ParcelLineTableStyles Property
Collapse All

Gets the collection of all parcel line table styles.

C#
public TableStyleCollection ParcelLineTableStyles;
Visual Basic
Public Property ParcelLineTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::ParcelSegmentTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::ParcelSegmentTableStyles Property
TableStylesRoot::ParcelSegmentTableStyles Property
Collapse All

Gets the collection of all parcel segment table styles.

C#
public TableStyleCollection ParcelSegmentTableStyles;
Visual Basic
Public Property ParcelSegmentTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::PipeTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::PipeTableStyles Property
TableStylesRoot::PipeTableStyles Property
Collapse All

Gets the collection of all pipe table styles.

C#
public TableStyleCollection PipeTableStyles;
Visual Basic
Public Property PipeTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::PointTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::PointTableStyles Property
TableStylesRoot::PointTableStyles Property
Collapse All

Gets the collection of all point table styles.

C#
public TableStyleCollection PointTableStyles;
Visual Basic
Public Property PointTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::QuantityTakeoffMaterialTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::QuantityTakeoffMaterialTableStyles Property
TableStylesRoot::QuantityTakeoffMaterialTableStyles Property
Collapse All

Gets the collection of all quantity takeoff material table styles.

C#
public TableStyleCollection QuantityTakeoffMaterialTableStyles;
Visual Basic
Public Property QuantityTakeoffMaterialTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::QuantityTakeoffTotalVolumeTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::QuantityTakeoffTotalVolumeTableStyles Property
TableStylesRoot::QuantityTakeoffTotalVolumeTableStyles Property
Collapse All

Gets the collection of all quantity takeoff total volume table styles.

C#
public TableStyleCollection QuantityTakeoffTotalVolumeTableStyles;
Visual Basic
Public Property QuantityTakeoffTotalVolumeTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::SectionViewMaterialTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::SectionViewMaterialTableStyles Property
TableStylesRoot::SectionViewMaterialTableStyles Property
Collapse All

Gets the collection of all section view material table styles.

C#
public TableStyleCollection SectionViewMaterialTableStyles;
Visual Basic
Public Property SectionViewMaterialTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::SectionViewTotalVolumeTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::SectionViewTotalVolumeTableStyles Property
TableStylesRoot::SectionViewTotalVolumeTableStyles Property
Collapse All

Gets the collection of all section view total volume table styles.

C#
public TableStyleCollection SectionViewTotalVolumeTableStyles;
Visual Basic
Public Property SectionViewTotalVolumeTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::StructureTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::StructureTableStyles Property
TableStylesRoot::StructureTableStyles Property
Collapse All

Gets the collection of all structure table styles.

C#
public TableStyleCollection StructureTableStyles;
Visual Basic
Public Property StructureTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::SurfaceContourTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::SurfaceContourTableStyles Property
TableStylesRoot::SurfaceContourTableStyles Property
Collapse All

Gets the collection of all surface contour table styles.

C#
public TableStyleCollection SurfaceContourTableStyles;
Visual Basic
Public Property SurfaceContourTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::SurfaceDirectionTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::SurfaceDirectionTableStyles Property
TableStylesRoot::SurfaceDirectionTableStyles Property
Collapse All

Gets the collection of all surface direction table styles.

C#
public TableStyleCollection SurfaceDirectionTableStyles;
Visual Basic
Public Property SurfaceDirectionTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::SurfaceElevationTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::SurfaceElevationTableStyles Property
TableStylesRoot::SurfaceElevationTableStyles Property
Collapse All

Gets the collection of all surface elevation table styles.

C#
public TableStyleCollection SurfaceElevationTableStyles;
Visual Basic
Public Property SurfaceElevationTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::SurfaceSlopeArrowContourTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::SurfaceSlopeArrowContourTableStyles Property
TableStylesRoot::SurfaceSlopeArrowContourTableStyles Property
Collapse All

Gets the collection of all surface user slope arrow table styles.

C#
public TableStyleCollection SurfaceSlopeArrowContourTableStyles;
Visual Basic
Public Property SurfaceSlopeArrowContourTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::SurfaceSlopeTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::SurfaceSlopeTableStyles Property
TableStylesRoot::SurfaceSlopeTableStyles Property
Collapse All

Gets the collection of all surface slope table styles.

C#
public TableStyleCollection SurfaceSlopeTableStyles;
Visual Basic
Public Property SurfaceSlopeTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::SurfaceUserDefinedContourTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::SurfaceUserDefinedContourTableStyles Property
TableStylesRoot::SurfaceUserDefinedContourTableStyles Property
Collapse All

Gets the collection of all surface user defined contour table styles.

C#
public TableStyleCollection SurfaceUserDefinedContourTableStyles;
Visual Basic
Public Property SurfaceUserDefinedContourTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


TableStylesRoot::SurfaceWatershedTableStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties > TableStylesRoot::SurfaceWatershedTableStyles Property
TableStylesRoot::SurfaceWatershedTableStyles Property
Collapse All

Gets the collection of all surface watershed table styles.

C#
public TableStyleCollection SurfaceWatershedTableStyles;
Visual Basic
Public Property SurfaceWatershedTableStyles() As TableStyleCollection
Links
TableStylesRoot Class, TableStylesRoot Members, Autodesk::Civil::DatabaseServices::Styles Namespace


Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums
Structs, Records, Enums
Collapse All

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
AxisPosition | Defines profile view, section view axis position.
AxisTickJustificationType | Specifies the position of the tick relative to the axis.
AxisTickType | Defines profile view, section view axis tick type.
AxisTitleLocationType | Specifies the location of the axis title in relation to the view grid.
BandLabelStyleType | Defines the band label style type.
BandSetItemLocationType | Enumerates the location for a band set item.
BandStyleType | Defines the band style type.
BandTickAttributeIdType | Defines the band tick position type.
BandTitleBoxPosition | Defines the band title box postion.
BandTitleTextLocation | Defines the band title text location.
CustomMarkerSuperimposeType | Specifies the custom point style marker as either none, a superimposed circle, a superimposed square, or both superimposed square and... more
CustomMarkerType | Specifies the custom point style marker as either a dot, a blank, two perpendicular lines (plus sign), two x-crossed lines,... more
ExpressionFormatedType | Defines the format type of the expression result.
FeatureLineDisplayStyleProfileType | Defines FeatureLineStyle display style type.
GraphDirectionType | Specifies the direction of the profile in the profile view grid.
GraphTitleJustificationType | Specifies the location of the graph title in relation to the view grid.
GraphTitleLocationType | Specifies the location of the graph title in relation to the view grid.
GridType | Defines clipping options on the profile view or section view grid.
LabelDisplayModeType | The Autodesk::Civil::DatabaseServices::Styles::LabelDisplayModeType enumeration.
LabelStyleComponentType | Defines the label style components type.
LabelStyleType | Defines the label style type.
MarkerDisplayType | Specifies the kind of marker to use: point, custom, symbol, or vertical line.
MarkerOrientationType | Defines how the marker is oriented, for example, to object, to world, or to view.
MarkerSizeType | Defines how the marker is sized, for example, relative to screen, or fixed scale.
markStylePropertyType | The Autodesk::Civil::DatabaseServices::Styles::markStylePropertyType enumeration.
ProjectionBlockDisplayType | An enumeration that defines projection block display type.
ProjectionDisplayStyleProfileType | An enumeration that defines projection display style profile type.
ProjectionDisplayStyleSectionType | An enumeration that defines projection display style section type.
ProjectionEntityDisplayType | An enumeration that defines projection point display type. This enum is only used for AutoCAD point and AutoCAD solid display... more
ReferenceTextComponentSelectedType | The Autodesk::Civil::DatabaseServices::Styles::ReferenceTextComponentSelectedType enumeration.
StaggerLabelType | Defines the grade break label stagger type.
TableDisplayStyleType | An enumeration that defines tab display style type.
TableSortingOrderType | Specifies the table sorting order type.
TableStyleType | Specifies the table style type.
TextForEachComponentSelectedType | The Autodesk::Civil::DatabaseServices::Styles::TextForEachComponentSelectedType enumeration.
Links
Enumerations


Autodesk::Civil::DatabaseServices::Styles::AxisPosition Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::AxisPosition Enumeration
Autodesk::Civil::DatabaseServices::Styles::AxisPosition Enumeration
Collapse All

Defines profile view, section view axis position.

C#
public enum AxisPosition {
  Top = 0x0,
  Middle,
  Bottom,
  Left,
  Center,
  Right
}
Visual Basic
Public Enum AxisPosition
  Top = &H0
  Middle
  Bottom
  Left
  Center
  Right
End Enum


Autodesk::Civil::DatabaseServices::Styles::AxisTickJustificationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::AxisTickJustificationType Enumeration
Autodesk::Civil::DatabaseServices::Styles::AxisTickJustificationType Enumeration
Collapse All

Specifies the position of the tick relative to the axis.

C#
public enum AxisTickJustificationType {
  TopOrLeft = AeccDbGraphStyle::kGraphHorizontalGridTickTop,
  Center = AeccDbGraphStyle::kGraphHorizontalGridTickCenter,
  BottomOrRight = AeccDbGraphStyle::kGraphHorizontalGridTickBottom
}
Visual Basic
Public Enum AxisTickJustificationType
  TopOrLeft = AeccDbGraphStyle::kGraphHorizontalGridTickTop
  Center = AeccDbGraphStyle::kGraphHorizontalGridTickCenter
  BottomOrRight = AeccDbGraphStyle::kGraphHorizontalGridTickBottom
End Enum


Autodesk::Civil::DatabaseServices::Styles::AxisTickType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::AxisTickType Enumeration
Autodesk::Civil::DatabaseServices::Styles::AxisTickType Enumeration
Collapse All

Defines profile view, section view axis tick type.

C#
public enum AxisTickType {
  Major = 0x0,
  Minor,
  HorizontalGeometry
}
Visual Basic
Public Enum AxisTickType
  Major = &H0
  Minor
  HorizontalGeometry
End Enum


Autodesk::Civil::DatabaseServices::Styles::AxisTitleLocationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::AxisTitleLocationType Enumeration
Autodesk::Civil::DatabaseServices::Styles::AxisTitleLocationType Enumeration
Collapse All

Specifies the location of the axis title in relation to the view grid.

C#
public enum AxisTitleLocationType {
  BottomOrRight = AeccDbGraphStyle::kGraphAxisTitlePositionStart,
  Center = AeccDbGraphStyle::kGraphAxisTitlePositionMiddle,
  TopOrLeft = AeccDbGraphStyle::kGraphAxisTitlePositionEnd
}
Visual Basic
Public Enum AxisTitleLocationType
  BottomOrRight = AeccDbGraphStyle::kGraphAxisTitlePositionStart
  Center = AeccDbGraphStyle::kGraphAxisTitlePositionMiddle
  TopOrLeft = AeccDbGraphStyle::kGraphAxisTitlePositionEnd
End Enum


Autodesk::Civil::DatabaseServices::Styles::BandLabelStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::BandLabelStyleType Enumeration
Autodesk::Civil::DatabaseServices::Styles::BandLabelStyleType Enumeration
Collapse All

Defines the band label style type.

C#
public enum BandLabelStyleType {
  ProfileDataMajorIncrement = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtMajorIncrementLabelStyle,
  ProfileDataMinorIncrement = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtMinorIncrementLabelStyle,
  ProfileDataHGP = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtHGPLocationLabelStyle,
  ProfileDataVGP = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtVGPLocationLabelStyle,
  ProfileDataStationEquation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtStationEquationLabelStyle,
  ProfileDataIncrementalDistance = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelStyle,
  VerticalGeometryUphillTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryUphillTangentLabelStyle,
  VerticalGeometryDownhillTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryDownhillTangentLabelStyle,
  VerticalGeometryCrestCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryCrestCurveLabelStyle,
  VerticalGeometrySagCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometrySagCurveLabelStyle,
  HorizontalGeometryTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometryTangentLabelStyle,
  HorizontalGeometryCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometryCurveLabelStyle,
  HorizontalGeometrySpiral = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometrySpiralLabelStyle,
  SuperelevationDataNormalCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtNormalCrownLocationLabelStyle,
  SuperelevationDataLevelCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtLevelCrownLocationLabelStyle,
  SuperelevationDataReverseCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtReverseCrownLocationLabelStyle,
  SuperelevationDataFullSuper = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtFullSuperLocationLabelStyle,
  SuperelevationDataShoulderCritical = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtShoulderCriticalLocationLabelStyle,
  SuperelevationDataSlopeTransition = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtSlopeTransitionRegionLabelStyle,
  SectionalDataSampleLineLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSectionalDataSampleLineLocationLabelStyle,
  SectionalDataIncrementalSectionData = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSectionalDataIncremenalSectionDataLabelStyle,
  PipeNetworkStructureLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsPipeNetworkStructureLocationLabelStyle,
  PipeNetworkPipeLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsPipeNetworkPipeLocationLabelStyle,
  SectionSegmentSurfaceLabels = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsRoadSurfaceAtSurfaceLabelsLabelStyle,
  SectionDataMajorIncrement = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtMajorIncrementLabelStyle,
  SectionDataMinorIncrement = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtMinorIncrementLabelStyle,
  SectionDataCenterline = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtCenterLineLabelStyle,
  SectionDataGradeBreaks = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtGradeBreaksLabelStyle,
  SectionDataSampleLineVertices = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtSampleLineVerticesLabelStyle,
  SectionDataIncrementalDistance = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelStyle
}
Visual Basic
Public Enum BandLabelStyleType
  ProfileDataMajorIncrement = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtMajorIncrementLabelStyle
  ProfileDataMinorIncrement = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtMinorIncrementLabelStyle
  ProfileDataHGP = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtHGPLocationLabelStyle
  ProfileDataVGP = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtVGPLocationLabelStyle
  ProfileDataStationEquation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtStationEquationLabelStyle
  ProfileDataIncrementalDistance = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelStyle
  VerticalGeometryUphillTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryUphillTangentLabelStyle
  VerticalGeometryDownhillTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryDownhillTangentLabelStyle
  VerticalGeometryCrestCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryCrestCurveLabelStyle
  VerticalGeometrySagCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometrySagCurveLabelStyle
  HorizontalGeometryTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometryTangentLabelStyle
  HorizontalGeometryCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometryCurveLabelStyle
  HorizontalGeometrySpiral = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometrySpiralLabelStyle
  SuperelevationDataNormalCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtNormalCrownLocationLabelStyle
  SuperelevationDataLevelCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtLevelCrownLocationLabelStyle
  SuperelevationDataReverseCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtReverseCrownLocationLabelStyle
  SuperelevationDataFullSuper = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtFullSuperLocationLabelStyle
  SuperelevationDataShoulderCritical = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtShoulderCriticalLocationLabelStyle
  SuperelevationDataSlopeTransition = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtSlopeTransitionRegionLabelStyle
  SectionalDataSampleLineLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSectionalDataSampleLineLocationLabelStyle
  SectionalDataIncrementalSectionData = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSectionalDataIncremenalSectionDataLabelStyle
  PipeNetworkStructureLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsPipeNetworkStructureLocationLabelStyle
  PipeNetworkPipeLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsPipeNetworkPipeLocationLabelStyle
  SectionSegmentSurfaceLabels = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsRoadSurfaceAtSurfaceLabelsLabelStyle
  SectionDataMajorIncrement = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtMajorIncrementLabelStyle
  SectionDataMinorIncrement = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtMinorIncrementLabelStyle
  SectionDataCenterline = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtCenterLineLabelStyle
  SectionDataGradeBreaks = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtGradeBreaksLabelStyle
  SectionDataSampleLineVertices = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtSampleLineVerticesLabelStyle
  SectionDataIncrementalDistance = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelStyle
End Enum


Autodesk::Civil::DatabaseServices::Styles::BandSetItemLocationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::BandSetItemLocationType Enumeration
Autodesk::Civil::DatabaseServices::Styles::BandSetItemLocationType Enumeration
Collapse All

Enumerates the location for a band set item.

C#
public enum BandSetItemLocationType {
  Top = 0,
  Bottom
}
Visual Basic
Public Enum BandSetItemLocationType
  Top = 0
  Bottom
End Enum


Autodesk::Civil::DatabaseServices::Styles::BandStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::BandStyleType Enumeration
Autodesk::Civil::DatabaseServices::Styles::BandStyleType Enumeration
Collapse All

Defines the band style type.

C#
public enum BandStyleType {
  ProfileData = AeccDbGraphStyleBands::kBandTypeProfileData,
  HorizontalGeometry = AeccDbGraphStyleBands::kBandTypeHorizontalGeometry,
  VerticalGeometry = AeccDbGraphStyleBands::kBandTypeVerticalGeometry,
  SuperelevationData = AeccDbGraphStyleBands::kBandTypeSuperelevation,
  SectionData = AeccDbGraphStyleBands::kBandTypeSectionData,
  SectionSegment = AeccDbGraphStyleBands::kBandTypeSectionRoadSurface,
  PipeNetwork = AeccDbGraphStyleBands::kBandTypeProfileViewPipeNetwork,
  SectionalData = AeccDbGraphStyleBands::kBandTypeProfileViewSectionalData
}
Visual Basic
Public Enum BandStyleType
  ProfileData = AeccDbGraphStyleBands::kBandTypeProfileData
  HorizontalGeometry = AeccDbGraphStyleBands::kBandTypeHorizontalGeometry
  VerticalGeometry = AeccDbGraphStyleBands::kBandTypeVerticalGeometry
  SuperelevationData = AeccDbGraphStyleBands::kBandTypeSuperelevation
  SectionData = AeccDbGraphStyleBands::kBandTypeSectionData
  SectionSegment = AeccDbGraphStyleBands::kBandTypeSectionRoadSurface
  PipeNetwork = AeccDbGraphStyleBands::kBandTypeProfileViewPipeNetwork
  SectionalData = AeccDbGraphStyleBands::kBandTypeProfileViewSectionalData
End Enum


Autodesk::Civil::DatabaseServices::Styles::BandTickAttributeIdType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::BandTickAttributeIdType Enumeration
Autodesk::Civil::DatabaseServices::Styles::BandTickAttributeIdType Enumeration
Collapse All

Defines the band tick position type.

C#
public enum BandTickAttributeIdType {
  FullHeight = 0,
  Top,
  Middle,
  Bottom,
  TopSize,
  MiddleSize,
  BottomSize
}
Visual Basic
Public Enum BandTickAttributeIdType
  FullHeight = 0
  Top
  Middle
  Bottom
  TopSize
  MiddleSize
  BottomSize
End Enum


Autodesk::Civil::DatabaseServices::Styles::BandTitleBoxPosition Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::BandTitleBoxPosition Enumeration
Autodesk::Civil::DatabaseServices::Styles::BandTitleBoxPosition Enumeration
Collapse All

Defines the band title box postion.

C#
public enum BandTitleBoxPosition {
  LeftOfBand = AeccDbGraphStyleBands::kBandTitleBoxPositionLeftofBand,
  RightOfBand = AeccDbGraphStyleBands::kBandTitleBoxPositionRightofBand
}
Visual Basic
Public Enum BandTitleBoxPosition
  LeftOfBand = AeccDbGraphStyleBands::kBandTitleBoxPositionLeftofBand
  RightOfBand = AeccDbGraphStyleBands::kBandTitleBoxPositionRightofBand
End Enum


Autodesk::Civil::DatabaseServices::Styles::BandTitleTextLocation Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::BandTitleTextLocation Enumeration
Autodesk::Civil::DatabaseServices::Styles::BandTitleTextLocation Enumeration
Collapse All

Defines the band title text location.

C#
public enum BandTitleTextLocation {
  Right = AeccDbGraphStyleBands::kBandTitleTextLocationRight,
  Center = AeccDbGraphStyleBands::kBandTitleTextLocationCenter,
  Left = AeccDbGraphStyleBands::kBandTitleTextLocationLeft
}
Visual Basic
Public Enum BandTitleTextLocation
  Right = AeccDbGraphStyleBands::kBandTitleTextLocationRight
  Center = AeccDbGraphStyleBands::kBandTitleTextLocationCenter
  Left = AeccDbGraphStyleBands::kBandTitleTextLocationLeft
End Enum


Autodesk::Civil::DatabaseServices::Styles::CustomMarkerSuperimposeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::CustomMarkerSuperimposeType Enumeration
Autodesk::Civil::DatabaseServices::Styles::CustomMarkerSuperimposeType Enumeration
Collapse All

Specifies the custom point style marker as either none, a superimposed circle, a superimposed square, or both superimposed square and circle.

C#
public enum CustomMarkerSuperimposeType {
  None = 0,
  Square = 1,
  Circle = 2,
  SquareCircle = 3
}
Visual Basic
Public Enum CustomMarkerSuperimposeType
  None = 0
  Square = 1
  Circle = 2
  SquareCircle = 3
End Enum


Autodesk::Civil::DatabaseServices::Styles::CustomMarkerType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::CustomMarkerType Enumeration
Autodesk::Civil::DatabaseServices::Styles::CustomMarkerType Enumeration
Collapse All

Specifies the custom point style marker as either a dot, a blank, two perpendicular lines (plus sign), two x-crossed lines, or a single vertical line.

C#
public enum CustomMarkerType {
  CustomMarkerDot = 0,
  CustomMarkerBlank = 1,
  CustomMarkerPlus = 2,
  CustomMarkerX = 3,
  CustomMarkerVLine = 4
}
Visual Basic
Public Enum CustomMarkerType
  CustomMarkerDot = 0
  CustomMarkerBlank = 1
  CustomMarkerPlus = 2
  CustomMarkerX = 3
  CustomMarkerVLine = 4
End Enum


Autodesk::Civil::DatabaseServices::Styles::ExpressionFormatedType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::ExpressionFormatedType Enumeration
Autodesk::Civil::DatabaseServices::Styles::ExpressionFormatedType Enumeration
Collapse All

Defines the format type of the expression result.

C#
public enum ExpressionFormatedType {
  Angle = 0,
  Area,
  Azimuth,
  Coordinate,
  Dimension,
  Direction,
  Distance,
  Double,
  Elevation,
  GradeSlope,
  Latitude,
  Longitude,
  Percent,
  Station,
  Volume
}
Visual Basic
Public Enum ExpressionFormatedType
  Angle = 0
  Area
  Azimuth
  Coordinate
  Dimension
  Direction
  Distance
  Double
  Elevation
  GradeSlope
  Latitude
  Longitude
  Percent
  Station
  Volume
End Enum


Autodesk::Civil::DatabaseServices::Styles::FeatureLineDisplayStyleProfileType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::FeatureLineDisplayStyleProfileType Enumeration
Autodesk::Civil::DatabaseServices::Styles::FeatureLineDisplayStyleProfileType Enumeration
Collapse All

Defines FeatureLineStyle display style type.

C#
public enum FeatureLineDisplayStyleProfileType {
  FeatureLine = AeccDbFeatureLineStyle::kDispCompFeatureLine,
  BeginningVertex = AeccDbFeatureLineStyle::kDispCompFeatureLineBeginningVertexMarker,
  InternalVertex = AeccDbFeatureLineStyle::kDispCompFeatureLineInternalVertexMarker,
  EndingVertex = AeccDbFeatureLineStyle::kDispCompFeatureLineEndingVertexMarker
}
Visual Basic
Public Enum FeatureLineDisplayStyleProfileType
  FeatureLine = AeccDbFeatureLineStyle::kDispCompFeatureLine
  BeginningVertex = AeccDbFeatureLineStyle::kDispCompFeatureLineBeginningVertexMarker
  InternalVertex = AeccDbFeatureLineStyle::kDispCompFeatureLineInternalVertexMarker
  EndingVertex = AeccDbFeatureLineStyle::kDispCompFeatureLineEndingVertexMarker
End Enum


Autodesk::Civil::DatabaseServices::Styles::GraphDirectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::GraphDirectionType Enumeration
Autodesk::Civil::DatabaseServices::Styles::GraphDirectionType Enumeration
Collapse All

Specifies the direction of the profile in the profile view grid.

C#
public enum GraphDirectionType {
  LeftToRight,
  RightToLeft
}
Visual Basic
Public Enum GraphDirectionType
  LeftToRight
  RightToLeft
End Enum


Autodesk::Civil::DatabaseServices::Styles::GraphTitleJustificationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::GraphTitleJustificationType Enumeration
Autodesk::Civil::DatabaseServices::Styles::GraphTitleJustificationType Enumeration
Collapse All

Specifies the location of the graph title in relation to the view grid.

C#
public enum GraphTitleJustificationType {
  TopOrLeft = 0x0,
  MiddleOrCenter,
  BottomOrRight
}
Visual Basic
Public Enum GraphTitleJustificationType
  TopOrLeft = &H0
  MiddleOrCenter
  BottomOrRight
End Enum


Autodesk::Civil::DatabaseServices::Styles::GraphTitleLocationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::GraphTitleLocationType Enumeration
Autodesk::Civil::DatabaseServices::Styles::GraphTitleLocationType Enumeration
Collapse All

Specifies the location of the graph title in relation to the view grid.

C#
public enum GraphTitleLocationType {
  Top = 0x0,
  Bottom,
  Left,
  Right
}
Visual Basic
Public Enum GraphTitleLocationType
  Top = &H0
  Bottom
  Left
  Right
End Enum


Autodesk::Civil::DatabaseServices::Styles::GridType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::GridType Enumeration
Autodesk::Civil::DatabaseServices::Styles::GridType Enumeration
Collapse All

Defines clipping options on the profile view or section view grid.

C#
public enum GridType {
  Vertical = 0x0,
  Horizontal
}
Visual Basic
Public Enum GridType
  Vertical = &H0
  Horizontal
End Enum


Autodesk::Civil::DatabaseServices::Styles::LabelDisplayModeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::LabelDisplayModeType Enumeration
Autodesk::Civil::DatabaseServices::Styles::LabelDisplayModeType Enumeration
Collapse All

The Autodesk::Civil::DatabaseServices::Styles::LabelDisplayModeType enumeration.

C#
public enum LabelDisplayModeType {
  Label = 0,
  Tag = 1
}
Visual Basic
Public Enum LabelDisplayModeType
  Label = 0
  Tag = 1
End Enum


Autodesk::Civil::DatabaseServices::Styles::LabelStyleComponentType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::LabelStyleComponentType Enumeration
Autodesk::Civil::DatabaseServices::Styles::LabelStyleComponentType Enumeration
Collapse All

Defines the label style components type.

C#
public enum LabelStyleComponentType {
  Text = 0x01,
  Line = 0x02,
  Block = 0x04,
  Tick = 0x08,
  ReferenceText = 0x10,
  DirectionArrow = 0x20,
  TextForEach = 0x40
}
Visual Basic
Public Enum LabelStyleComponentType
  Text = &H01
  Line = &H02
  Block = &H04
  Tick = &H08
  ReferenceText = &H10
  DirectionArrow = &H20
  TextForEach = &H40
End Enum


Autodesk::Civil::DatabaseServices::Styles::LabelStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::LabelStyleType Enumeration
Autodesk::Civil::DatabaseServices::Styles::LabelStyleType Enumeration
Collapse All

Defines the label style type.

C#
public enum LabelStyleType {
  GeneralNote = AeccAttributeId::kAttrIdLabelStyleGeneralNote,
  GeneralLine = AeccAttributeId::kAttrIdLabelStyleGeneralLine,
  GeneralCurve = AeccAttributeId::kAttrIdLabelStyleGeneralCurve,
  GeneralMarker = AeccAttributeId::kAttrIdLabelStyleSubassemblyMarker,
  GeneralLink = AeccAttributeId::kAttrIdLabelStyleSubassemblyLink,
  GeneralShape = AeccAttributeId::kAttrIdLabelStyleSubassemblyShape,
  Point = AeccAttributeId::kAttrIdLabelStylePoint,
  SurfaceContour = AeccAttributeId::kAttrIdLabelStyleSurfaceContour,
  SurfaceSlope = AeccAttributeId::kAttrIdLabelStyleSurfaceSlope,
  SurfaceSpotElevation = AeccAttributeId::kAttrIdLabelStyleSurfaceSpotElevation,
  SurfaceWatershed = AeccAttributeId::kAttrIdLabelStyleSurfaceStyleWatershed,
  ParcelArea = AeccAttributeId::kAttrIdLabelStyleParcelArea,
  ParcelLine = AeccAttributeId::kAttrIdLabelStyleParcelLine,
  ParcelCurve = AeccAttributeId::kAttrIdLabelStyleParcelCurve,
  AlignmentMajorStation = AeccAttributeId::kAttrIdLabelStyleAlignmentMajorStation,
  AlignmentMinorStation = AeccAttributeId::kAttrIdLabelStyleAlignmentMinorStation,
  AlignmentGeometryPoint = AeccAttributeId::kAttrIdLabelStyleAlignmentGeometryPoint,
  AlignmentProfileGeometryPoint = AeccAttributeId::kAttrIdLabelStyleAlignmentVAGeometryPoint,
  AlignmentStationEquation = AeccAttributeId::kAttrIdLabelStyleAlignmentStationEquation,
  AlignmentDesignSpeed = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignSpeed,
  AlignmentSuperelevationCriticalPoints = AeccAttributeId::kAttrIdLabelStyleAlignmentSuperelevation,
  AlignmentStationOffset = AeccAttributeId::kAttrIdLabelStyleAlignmentStationOffset,
  AlignmentLine = AeccAttributeId::kAttrIdLabelStyleAlignmentLine,
  AlignmentCurve = AeccAttributeId::kAttrIdLabelStyleAlignmentCurve,
  AlignmentSpiral = AeccAttributeId::kAttrIdLabelStyleAlignmentSpiral,
  AlignmentTangentIntersection = AeccAttributeId::kAttrIdLabelStyleAlignmentTangentIntersect,
  ProfileMajorStation = AeccAttributeId::kAttrIdLabelStyleVAlignmentMajorStation,
  ProfileMinorStation = AeccAttributeId::kAttrIdLabelStyleVAlignmentMinorStation,
  ProfileHorizontalGeometryPoint = AeccAttributeId::kAttrIdLabelStyleVAlignmentGeometryPoint,
  ProfileGradeBreaks = AeccAttributeId::kAttrIdLabelStyleVAlignmentGradeBreak,
  ProfileLine = AeccAttributeId::kAttrIdLabelStyleVAlignmentLine,
  ProfileCurve = AeccAttributeId::kAttrIdLabelStyleVAlignmentCurve,
  ProfileViewStationElevation = AeccAttributeId::kAttrIdLabelStyleProfileStationElevation,
  ProfileViewDepth = AeccAttributeId::kAttrIdLabelStyleProfileDepth,
  ProfileViewProjection = AeccAttributeId::kAttrIdLabelStyleProfileProjection,
  SampleLineLabelStyles = AeccAttributeId::kAttrIdSampleLineLabelStyle,
  SectionMajorOffset = AeccAttributeId::kAttrIdLabelStyleSectionMajorOffset,
  SectionMinorOffset = AeccAttributeId::kAttrIdLabelStyleSectionMinorOffset,
  SectionGradeBreak = AeccAttributeId::kAttrIdLabelStyleSectionGradeBreak,
  SectionSegment = AeccAttributeId::kAttrIdLabelStyleSectionSegment,
  SectionViewOffsetElevation = AeccAttributeId::kAttrIdLabelStyleSectionViewOffsetElev,
  SectionViewGrade = AeccAttributeId::kAttrIdLabelStyleSectionViewDepthGrade,
  SectionViewProjection = AeccAttributeId::kAttrIdLabelStyleSectionProjection,
  PipePlanProfile = AeccAttributeId::kAttrIdLabelStylePipe,
  PipeCrossSection = AeccAttributeId::kAttrIdLabelStylePipeCrossing,
  StructureLabelStyle = AeccAttributeId::kAttrIdLabelStyleStructure,
  IntersectionLocationLabels = AeccAttributeId::kAttrIdLabelStyleIntersectionLocation,
  ViewFrame = AeccAttributeId::kAttrIdLabelStyleViewFrame,
  MatchLineLeft = AeccAttributeId::kAttrIdLabelStyleMatchLineLeft,
  MatchLineRight = AeccAttributeId::kAttrIdLabelStyleMatchLineRight,
  ProfileBandMajorIncrement = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtMajorIncrementLabelStyle,
  ProfileBandMinorIncrement = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtMinorIncrementLabelStyle,
  ProfileBandHGP = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtHGPLocationLabelStyle,
  ProfileBandVGP = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtVGPLocationLabelStyle,
  ProfileBandStationEquation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtStationEquationLabelStyle,
  ProfileBandIncrementalDistance = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelStyle,
  ProfileBandVerticalGeometryUphillTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryUphillTangentLabelStyle,
  ProfileBandVerticalGeometryDownhillTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryDownhillTangentLabelStyle,
  ProfileBandVerticalGeometryCrestCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryCrestCurveLabelStyle,
  ProfileBandVerticalGeometrySagCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometrySagCurveLabelStyle,
  ProfileBandHorizontalGeometryTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometryTangentLabelStyle,
  ProfileBandHorizontalGeometryCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometryCurveLabelStyle,
  ProfileBandHorizontalGeometrySpiral = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometrySpiralLabelStyle,
  ProfileBandSuperelevationDataNormalCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtNormalCrownLocationLabelStyle,
  ProfileBandSuperelevationDataLevelCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtLevelCrownLocationLabelStyle,
  ProfileBandSuperelevationDataReverseCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtReverseCrownLocationLabelStyle,
  ProfileBandSuperelevationDataFullSuper = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtFullSuperLocationLabelStyle,
  ProfileBandSuperelevationDataShoulderCritical = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtShoulderCriticalLocationLabelStyle,
  ProfileBandSuperelevationDataSlopeTransition = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtSlopeTransitionRegionLabelStyle,
  ProfileBandSectionalDataSampleLineLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSectionalDataSampleLineLocationLabelStyle,
  ProfileBandSectionalDataIncrementalSectionData = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSectionalDataIncremenalSectionDataLabelStyle,
  ProfileBandPipeNetworkStructureLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsPipeNetworkStructureLocationLabelStyle,
  ProfileBandPipeNetworkPipeLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsPipeNetworkPipeLocationLabelStyle,
  SectionBandSegmentSurfaceLabels = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsRoadSurfaceAtSurfaceLabelsLabelStyle,
  SectionBandMajorIncrement = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtMajorIncrementLabelStyle,
  SectionBandMinorIncrement = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtMinorIncrementLabelStyle,
  SectionBandCenterline = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtCenterLineLabelStyle,
  SectionBandGradeBreaks = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtGradeBreaksLabelStyle,
  SectionBandSampleLineVertices = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtSampleLineVerticesLabelStyle,
  SectionBandIncrementalDistance = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelStyle,
  ProfileSagCurve = AeccAttributeId::kAttrIdLabelStyleVAlignmentSagCurve,
  ProfileCrestCurve = AeccAttributeId::kAttrIdLabelStyleVAlignmentCrestCurve
}
Visual Basic
Public Enum LabelStyleType
  GeneralNote = AeccAttributeId::kAttrIdLabelStyleGeneralNote
  GeneralLine = AeccAttributeId::kAttrIdLabelStyleGeneralLine
  GeneralCurve = AeccAttributeId::kAttrIdLabelStyleGeneralCurve
  GeneralMarker = AeccAttributeId::kAttrIdLabelStyleSubassemblyMarker
  GeneralLink = AeccAttributeId::kAttrIdLabelStyleSubassemblyLink
  GeneralShape = AeccAttributeId::kAttrIdLabelStyleSubassemblyShape
  Point = AeccAttributeId::kAttrIdLabelStylePoint
  SurfaceContour = AeccAttributeId::kAttrIdLabelStyleSurfaceContour
  SurfaceSlope = AeccAttributeId::kAttrIdLabelStyleSurfaceSlope
  SurfaceSpotElevation = AeccAttributeId::kAttrIdLabelStyleSurfaceSpotElevation
  SurfaceWatershed = AeccAttributeId::kAttrIdLabelStyleSurfaceStyleWatershed
  ParcelArea = AeccAttributeId::kAttrIdLabelStyleParcelArea
  ParcelLine = AeccAttributeId::kAttrIdLabelStyleParcelLine
  ParcelCurve = AeccAttributeId::kAttrIdLabelStyleParcelCurve
  AlignmentMajorStation = AeccAttributeId::kAttrIdLabelStyleAlignmentMajorStation
  AlignmentMinorStation = AeccAttributeId::kAttrIdLabelStyleAlignmentMinorStation
  AlignmentGeometryPoint = AeccAttributeId::kAttrIdLabelStyleAlignmentGeometryPoint
  AlignmentProfileGeometryPoint = AeccAttributeId::kAttrIdLabelStyleAlignmentVAGeometryPoint
  AlignmentStationEquation = AeccAttributeId::kAttrIdLabelStyleAlignmentStationEquation
  AlignmentDesignSpeed = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignSpeed
  AlignmentSuperelevationCriticalPoints = AeccAttributeId::kAttrIdLabelStyleAlignmentSuperelevation
  AlignmentStationOffset = AeccAttributeId::kAttrIdLabelStyleAlignmentStationOffset
  AlignmentLine = AeccAttributeId::kAttrIdLabelStyleAlignmentLine
  AlignmentCurve = AeccAttributeId::kAttrIdLabelStyleAlignmentCurve
  AlignmentSpiral = AeccAttributeId::kAttrIdLabelStyleAlignmentSpiral
  AlignmentTangentIntersection = AeccAttributeId::kAttrIdLabelStyleAlignmentTangentIntersect
  ProfileMajorStation = AeccAttributeId::kAttrIdLabelStyleVAlignmentMajorStation
  ProfileMinorStation = AeccAttributeId::kAttrIdLabelStyleVAlignmentMinorStation
  ProfileHorizontalGeometryPoint = AeccAttributeId::kAttrIdLabelStyleVAlignmentGeometryPoint
  ProfileGradeBreaks = AeccAttributeId::kAttrIdLabelStyleVAlignmentGradeBreak
  ProfileLine = AeccAttributeId::kAttrIdLabelStyleVAlignmentLine
  ProfileCurve = AeccAttributeId::kAttrIdLabelStyleVAlignmentCurve
  ProfileViewStationElevation = AeccAttributeId::kAttrIdLabelStyleProfileStationElevation
  ProfileViewDepth = AeccAttributeId::kAttrIdLabelStyleProfileDepth
  ProfileViewProjection = AeccAttributeId::kAttrIdLabelStyleProfileProjection
  SampleLineLabelStyles = AeccAttributeId::kAttrIdSampleLineLabelStyle
  SectionMajorOffset = AeccAttributeId::kAttrIdLabelStyleSectionMajorOffset
  SectionMinorOffset = AeccAttributeId::kAttrIdLabelStyleSectionMinorOffset
  SectionGradeBreak = AeccAttributeId::kAttrIdLabelStyleSectionGradeBreak
  SectionSegment = AeccAttributeId::kAttrIdLabelStyleSectionSegment
  SectionViewOffsetElevation = AeccAttributeId::kAttrIdLabelStyleSectionViewOffsetElev
  SectionViewGrade = AeccAttributeId::kAttrIdLabelStyleSectionViewDepthGrade
  SectionViewProjection = AeccAttributeId::kAttrIdLabelStyleSectionProjection
  PipePlanProfile = AeccAttributeId::kAttrIdLabelStylePipe
  PipeCrossSection = AeccAttributeId::kAttrIdLabelStylePipeCrossing
  StructureLabelStyle = AeccAttributeId::kAttrIdLabelStyleStructure
  IntersectionLocationLabels = AeccAttributeId::kAttrIdLabelStyleIntersectionLocation
  ViewFrame = AeccAttributeId::kAttrIdLabelStyleViewFrame
  MatchLineLeft = AeccAttributeId::kAttrIdLabelStyleMatchLineLeft
  MatchLineRight = AeccAttributeId::kAttrIdLabelStyleMatchLineRight
  ProfileBandMajorIncrement = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtMajorIncrementLabelStyle
  ProfileBandMinorIncrement = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtMinorIncrementLabelStyle
  ProfileBandHGP = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtHGPLocationLabelStyle
  ProfileBandVGP = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtVGPLocationLabelStyle
  ProfileBandStationEquation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtStationEquationLabelStyle
  ProfileBandIncrementalDistance = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelStyle
  ProfileBandVerticalGeometryUphillTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryUphillTangentLabelStyle
  ProfileBandVerticalGeometryDownhillTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryDownhillTangentLabelStyle
  ProfileBandVerticalGeometryCrestCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometryCrestCurveLabelStyle
  ProfileBandVerticalGeometrySagCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsVerticalGeometrySagCurveLabelStyle
  ProfileBandHorizontalGeometryTangent = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometryTangentLabelStyle
  ProfileBandHorizontalGeometryCurve = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometryCurveLabelStyle
  ProfileBandHorizontalGeometrySpiral = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsHorizontalGeometrySpiralLabelStyle
  ProfileBandSuperelevationDataNormalCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtNormalCrownLocationLabelStyle
  ProfileBandSuperelevationDataLevelCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtLevelCrownLocationLabelStyle
  ProfileBandSuperelevationDataReverseCrown = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtReverseCrownLocationLabelStyle
  ProfileBandSuperelevationDataFullSuper = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtFullSuperLocationLabelStyle
  ProfileBandSuperelevationDataShoulderCritical = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtShoulderCriticalLocationLabelStyle
  ProfileBandSuperelevationDataSlopeTransition = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSuperelevationAtSlopeTransitionRegionLabelStyle
  ProfileBandSectionalDataSampleLineLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSectionalDataSampleLineLocationLabelStyle
  ProfileBandSectionalDataIncrementalSectionData = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsSectionalDataIncremenalSectionDataLabelStyle
  ProfileBandPipeNetworkStructureLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsPipeNetworkStructureLocationLabelStyle
  ProfileBandPipeNetworkPipeLocation = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsPipeNetworkPipeLocationLabelStyle
  SectionBandSegmentSurfaceLabels = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsRoadSurfaceAtSurfaceLabelsLabelStyle
  SectionBandMajorIncrement = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtMajorIncrementLabelStyle
  SectionBandMinorIncrement = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtMinorIncrementLabelStyle
  SectionBandCenterline = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtCenterLineLabelStyle
  SectionBandGradeBreaks = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtGradeBreaksLabelStyle
  SectionBandSampleLineVertices = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtSampleLineVerticesLabelStyle
  SectionBandIncrementalDistance = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelStyle
  ProfileSagCurve = AeccAttributeId::kAttrIdLabelStyleVAlignmentSagCurve
  ProfileCrestCurve = AeccAttributeId::kAttrIdLabelStyleVAlignmentCrestCurve
End Enum


Autodesk::Civil::DatabaseServices::Styles::MarkerDisplayType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::MarkerDisplayType Enumeration
Autodesk::Civil::DatabaseServices::Styles::MarkerDisplayType Enumeration
Collapse All

Specifies the kind of marker to use: point, custom, symbol, or vertical line.

C#
public enum MarkerDisplayType {
  UsePointForMarker = AeccDbMarkerStyle::ACAD_POINT,
  UseCustomMarker = AeccDbMarkerStyle::CUSTOM_MARKER,
  UseSymbolForMarker = AeccDbMarkerStyle::BLOCK_REFERENCE,
  UseVerticalLineForMarker = AeccDbMarkerStyle::VERTICAL_LINE
}
Visual Basic
Public Enum MarkerDisplayType
  UsePointForMarker = AeccDbMarkerStyle::ACAD_POINT
  UseCustomMarker = AeccDbMarkerStyle::CUSTOM_MARKER
  UseSymbolForMarker = AeccDbMarkerStyle::BLOCK_REFERENCE
  UseVerticalLineForMarker = AeccDbMarkerStyle::VERTICAL_LINE
End Enum


Autodesk::Civil::DatabaseServices::Styles::MarkerOrientationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::MarkerOrientationType Enumeration
Autodesk::Civil::DatabaseServices::Styles::MarkerOrientationType Enumeration
Collapse All

Defines how the marker is oriented, for example, to object, to world, or to view.

C#
public enum MarkerOrientationType {
  OrientToView = AeccDbMarkerStyle::VIEW,
  OrientToWCS = AeccDbMarkerStyle::WORLD,
  OrientToObject = AeccDbMarkerStyle::OBJECT
}
Visual Basic
Public Enum MarkerOrientationType
  OrientToView = AeccDbMarkerStyle::VIEW
  OrientToWCS = AeccDbMarkerStyle::WORLD
  OrientToObject = AeccDbMarkerStyle::OBJECT
End Enum


Autodesk::Civil::DatabaseServices::Styles::MarkerSizeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::MarkerSizeType Enumeration
Autodesk::Civil::DatabaseServices::Styles::MarkerSizeType Enumeration
Collapse All

Defines how the marker is sized, for example, relative to screen, or fixed scale.

C#
public enum MarkerSizeType {
  DrawingScale = AeccDbMarkerStyle::DRAWING_SCALE,
  RelativeToScreen = AeccDbMarkerStyle::SCREEN_RELATIVE,
  AbsoluteUnits = AeccDbMarkerStyle::ABSOLUTE_UNITS,
  FixedScale = AeccDbMarkerStyle::FIXED_SCALE
}
Visual Basic
Public Enum MarkerSizeType
  DrawingScale = AeccDbMarkerStyle::DRAWING_SCALE
  RelativeToScreen = AeccDbMarkerStyle::SCREEN_RELATIVE
  AbsoluteUnits = AeccDbMarkerStyle::ABSOLUTE_UNITS
  FixedScale = AeccDbMarkerStyle::FIXED_SCALE
End Enum


Autodesk::Civil::DatabaseServices::Styles::markStylePropertyType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::markStylePropertyType Enumeration
Autodesk::Civil::DatabaseServices::Styles::markStylePropertyType Enumeration
Collapse All

The Autodesk::Civil::DatabaseServices::Styles::markStylePropertyType enumeration.

C#
public enum markStylePropertyType {
  CustomMarkerStyle = 1,
  CustomMarkerSuperimposeStyle,
  MarkerSymbolName,
  MarkerRotationAngle,
  SizeType,
  MarkerSize,
  MarkerFixedScale,
  Orientation
}
Visual Basic
Public Enum markStylePropertyType
  CustomMarkerStyle = 1
  CustomMarkerSuperimposeStyle
  MarkerSymbolName
  MarkerRotationAngle
  SizeType
  MarkerSize
  MarkerFixedScale
  Orientation
End Enum


Autodesk::Civil::DatabaseServices::Styles::ProjectionBlockDisplayType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::ProjectionBlockDisplayType Enumeration
Autodesk::Civil::DatabaseServices::Styles::ProjectionBlockDisplayType Enumeration
Collapse All

An enumeration that defines projection block display type.

C#
public enum ProjectionBlockDisplayType {
  NativeEntity = AeccDbProfileSectionEntityStyle::kNativeEntity,
  Marker = AeccDbProfileSectionEntityStyle::kMarker,
  Block = AeccDbProfileSectionEntityStyle::kBlock
}
Visual Basic
Public Enum ProjectionBlockDisplayType
  NativeEntity = AeccDbProfileSectionEntityStyle::kNativeEntity
  Marker = AeccDbProfileSectionEntityStyle::kMarker
  Block = AeccDbProfileSectionEntityStyle::kBlock
End Enum


Autodesk::Civil::DatabaseServices::Styles::ProjectionDisplayStyleProfileType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::ProjectionDisplayStyleProfileType Enumeration
Autodesk::Civil::DatabaseServices::Styles::ProjectionDisplayStyleProfileType Enumeration
Collapse All

An enumeration that defines projection display style profile type.

C#
public enum ProjectionDisplayStyleProfileType {
  SolidProfile = AeccDbProfileSectionEntityStyle::kDispCompSolidProfile,
  PointProfile = AeccDbProfileSectionEntityStyle::kDispCompPointProfile,
  ThreeDPolylineSegmentsProfile = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineSegmentsProfile,
  ThreeDPolylineBeginVertexProfile = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineBeginVertexProfile,
  ThreeDPolylineInternalVertexProfile = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineInternalVertexProfile,
  ThreeDPolylineEndVertexProfile = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineEndVertexProfile,
  BlockProfile = AeccDbProfileSectionEntityStyle::kDispCompBlockProfile,
  MvBlockProfile = AeccDbProfileSectionEntityStyle::kDispCompMvBlockProfile
}
Visual Basic
Public Enum ProjectionDisplayStyleProfileType
  SolidProfile = AeccDbProfileSectionEntityStyle::kDispCompSolidProfile
  PointProfile = AeccDbProfileSectionEntityStyle::kDispCompPointProfile
  ThreeDPolylineSegmentsProfile = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineSegmentsProfile
  ThreeDPolylineBeginVertexProfile = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineBeginVertexProfile
  ThreeDPolylineInternalVertexProfile = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineInternalVertexProfile
  ThreeDPolylineEndVertexProfile = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineEndVertexProfile
  BlockProfile = AeccDbProfileSectionEntityStyle::kDispCompBlockProfile
  MvBlockProfile = AeccDbProfileSectionEntityStyle::kDispCompMvBlockProfile
End Enum


Autodesk::Civil::DatabaseServices::Styles::ProjectionDisplayStyleSectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::ProjectionDisplayStyleSectionType Enumeration
Autodesk::Civil::DatabaseServices::Styles::ProjectionDisplayStyleSectionType Enumeration
Collapse All

An enumeration that defines projection display style section type.

C#
public enum ProjectionDisplayStyleSectionType {
  SolidSection = AeccDbProfileSectionEntityStyle::kDispCompSolidSection,
  PointSection = AeccDbProfileSectionEntityStyle::kDispCompPointSection,
  ThreeDPolylineSection = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineSection,
  BlockSection = AeccDbProfileSectionEntityStyle::kDispCompBlockSection,
  MvBlockSection = AeccDbProfileSectionEntityStyle::kDispCompMvBlockSection
}
Visual Basic
Public Enum ProjectionDisplayStyleSectionType
  SolidSection = AeccDbProfileSectionEntityStyle::kDispCompSolidSection
  PointSection = AeccDbProfileSectionEntityStyle::kDispCompPointSection
  ThreeDPolylineSection = AeccDbProfileSectionEntityStyle::kDispComp3dPolylineSection
  BlockSection = AeccDbProfileSectionEntityStyle::kDispCompBlockSection
  MvBlockSection = AeccDbProfileSectionEntityStyle::kDispCompMvBlockSection
End Enum


Autodesk::Civil::DatabaseServices::Styles::ProjectionEntityDisplayType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::ProjectionEntityDisplayType Enumeration
Autodesk::Civil::DatabaseServices::Styles::ProjectionEntityDisplayType Enumeration
Collapse All

An enumeration that defines projection point display type. This enum is only used for AutoCAD point and AutoCAD solid display options.

C#
public enum ProjectionEntityDisplayType {
  NativeEntity = AeccDbProfileSectionEntityStyle::kNativeEntity,
  Marker = AeccDbProfileSectionEntityStyle::kMarker
}
Visual Basic
Public Enum ProjectionEntityDisplayType
  NativeEntity = AeccDbProfileSectionEntityStyle::kNativeEntity
  Marker = AeccDbProfileSectionEntityStyle::kMarker
End Enum


Autodesk::Civil::DatabaseServices::Styles::ReferenceTextComponentSelectedType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::ReferenceTextComponentSelectedType Enumeration
Autodesk::Civil::DatabaseServices::Styles::ReferenceTextComponentSelectedType Enumeration
Collapse All

The Autodesk::Civil::DatabaseServices::Styles::ReferenceTextComponentSelectedType enumeration.

C#
public enum ReferenceTextComponentSelectedType {
  Alignment = 0,
  CogoPoint = 1,
  Parcel = 2,
  Profile = 3,
  Surface = 4
}
Visual Basic
Public Enum ReferenceTextComponentSelectedType
  Alignment = 0
  CogoPoint = 1
  Parcel = 2
  Profile = 3
  Surface = 4
End Enum


Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType Enumeration
Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType Enumeration
Collapse All

Defines the grade break label stagger type.

C#
public enum StaggerLabelType {
  None = AeccDbLabeling::kStaggerNone,
  Left = AeccDbLabeling::kStaggerHorizontalToLeft,
  Right = AeccDbLabeling::kStaggerHorizontalToRight,
  Both = AeccDbLabeling::kStaggerHorizontalCluster
}
Visual Basic
Public Enum StaggerLabelType
  None = AeccDbLabeling::kStaggerNone
  Left = AeccDbLabeling::kStaggerHorizontalToLeft
  Right = AeccDbLabeling::kStaggerHorizontalToRight
  Both = AeccDbLabeling::kStaggerHorizontalCluster
End Enum


Autodesk::Civil::DatabaseServices::Styles::TableDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::TableDisplayStyleType Enumeration
Autodesk::Civil::DatabaseServices::Styles::TableDisplayStyleType Enumeration
Collapse All

An enumeration that defines tab display style type.

C#
public enum TableDisplayStyleType {
  Border = AeccDbScheduleTableStyle::kBorder,
  TitleSeparator = AeccDbScheduleTableStyle::kTitleSeparator,
  HeaderSeparator = AeccDbScheduleTableStyle::kHeaderSeparator,
  DataSeparator = AeccDbScheduleTableStyle::kDataSeparator,
  DataDivider = AeccDbScheduleTableStyle::kDataDivider,
  TitleAreaFill = AeccDbScheduleTableStyle::kTitleAreaFill,
  HeaderAreaFill = AeccDbScheduleTableStyle::kHeaderAreaFill,
  DataAreaFill = AeccDbScheduleTableStyle::kDataAreaFill,
  TitleText = AeccDbScheduleTableStyle::kTitleText,
  HeaderText = AeccDbScheduleTableStyle::kHeaderText,
  DataText = AeccDbScheduleTableStyle::kDataText
}
Visual Basic
Public Enum TableDisplayStyleType
  Border = AeccDbScheduleTableStyle::kBorder
  TitleSeparator = AeccDbScheduleTableStyle::kTitleSeparator
  HeaderSeparator = AeccDbScheduleTableStyle::kHeaderSeparator
  DataSeparator = AeccDbScheduleTableStyle::kDataSeparator
  DataDivider = AeccDbScheduleTableStyle::kDataDivider
  TitleAreaFill = AeccDbScheduleTableStyle::kTitleAreaFill
  HeaderAreaFill = AeccDbScheduleTableStyle::kHeaderAreaFill
  DataAreaFill = AeccDbScheduleTableStyle::kDataAreaFill
  TitleText = AeccDbScheduleTableStyle::kTitleText
  HeaderText = AeccDbScheduleTableStyle::kHeaderText
  DataText = AeccDbScheduleTableStyle::kDataText
End Enum


Autodesk::Civil::DatabaseServices::Styles::TableSortingOrderType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::TableSortingOrderType Enumeration
Autodesk::Civil::DatabaseServices::Styles::TableSortingOrderType Enumeration
Collapse All

Specifies the table sorting order type.

C#
public enum TableSortingOrderType {
  Ascending = AeccDbScheduleTableStyle::kAscending,
  Descending = AeccDbScheduleTableStyle::kDescending
}
Visual Basic
Public Enum TableSortingOrderType
  Ascending = AeccDbScheduleTableStyle::kAscending
  Descending = AeccDbScheduleTableStyle::kDescending
End Enum


Autodesk::Civil::DatabaseServices::Styles::TableStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::TableStyleType Enumeration
Autodesk::Civil::DatabaseServices::Styles::TableStyleType Enumeration
Collapse All

Specifies the table style type.

C#
public enum TableStyleType {
  Point = AeccAtomId::point,
  AlignmentLine = AeccAtomId::alignmentLine,
  AlignmentCurve = AeccAtomId::alignmentCurve,
  AlignmentSpiral = AeccAtomId::alignmentSpiral,
  AlignmentSegment = AeccAtomId::alignment,
  ParcelLine = AeccAtomId::lotLine,
  ParcelCurve = AeccAtomId::curve,
  ParcelArea = AeccAtomId::parcels,
  ParcelSegment = AeccAtomId::parcelSegment,
  SurfaceDirection = AeccAtomId::directions,
  SurfaceElevation = AeccAtomId::elevations,
  SurfaceSlope = AeccAtomId::slopes,
  SurfaceSlopeArrow = AeccAtomId::slopeArrows,
  SurfaceContour = AeccAtomId::contours,
  SurfaceContoursUser = AeccAtomId::contoursUser,
  SurfaceWatershed = AeccAtomId::watersheds,
  QuantityTakeoffTotalVolume = AeccAtomId::quantityTakeoffAggregateEarthWorkTable,
  QuantityTakeoffMaterial = AeccAtomId::quantityTakeoffMaterialTable,
  Pipe = AeccAtomId::pipeTables,
  SectionViewTotalVolume = AeccAtomId::sectionViewCumulativeVolumeTable,
  SectionViewMaterial = AeccAtomId::sectionViewMaterialsTable,
  Structure = AeccAtomId::structureTables
}
Visual Basic
Public Enum TableStyleType
  Point = AeccAtomId::point
  AlignmentLine = AeccAtomId::alignmentLine
  AlignmentCurve = AeccAtomId::alignmentCurve
  AlignmentSpiral = AeccAtomId::alignmentSpiral
  AlignmentSegment = AeccAtomId::alignment
  ParcelLine = AeccAtomId::lotLine
  ParcelCurve = AeccAtomId::curve
  ParcelArea = AeccAtomId::parcels
  ParcelSegment = AeccAtomId::parcelSegment
  SurfaceDirection = AeccAtomId::directions
  SurfaceElevation = AeccAtomId::elevations
  SurfaceSlope = AeccAtomId::slopes
  SurfaceSlopeArrow = AeccAtomId::slopeArrows
  SurfaceContour = AeccAtomId::contours
  SurfaceContoursUser = AeccAtomId::contoursUser
  SurfaceWatershed = AeccAtomId::watersheds
  QuantityTakeoffTotalVolume = AeccAtomId::quantityTakeoffAggregateEarthWorkTable
  QuantityTakeoffMaterial = AeccAtomId::quantityTakeoffMaterialTable
  Pipe = AeccAtomId::pipeTables
  SectionViewTotalVolume = AeccAtomId::sectionViewCumulativeVolumeTable
  SectionViewMaterial = AeccAtomId::sectionViewMaterialsTable
  Structure = AeccAtomId::structureTables
End Enum


Autodesk::Civil::DatabaseServices::Styles::TextForEachComponentSelectedType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::Styles::TextForEachComponentSelectedType Enumeration
Autodesk::Civil::DatabaseServices::Styles::TextForEachComponentSelectedType Enumeration
Collapse All

The Autodesk::Civil::DatabaseServices::Styles::TextForEachComponentSelectedType enumeration.

C#
public enum TextForEachComponentSelectedType {
  StructureAllPipes = 0,
  StructureInFlowPipes = 1,
  StructureOutFlowPipes = 2,
  IntersectionAllAlignment = 3
}
Visual Basic
Public Enum TextForEachComponentSelectedType
  StructureAllPipes = 0
  StructureInFlowPipes = 1
  StructureOutFlowPipes = 2
  IntersectionAllAlignment = 3
End Enum


Classes

The following table lists classes in this documentation.

Classes
Class | Description
AnchorInfo | This is class Autodesk::Civil::DatabaseServices::AnchorInfo.
AutoFeatureLabelGroup | The base class for all label group objects that automatically label a range on a feature.
DBObject | The base class for database entities.
Entity | The base class for entities, such as Feature, Table, Grading, Site, etc.
Feature | Base class for Alignment, FeatureLine, ParcelSegment, and Profile.
FeatureLabel | A base class for feature label classes, such as AlignmentCurveLabel.
GeoEntity | The base class for geometry db entities.
Graph | The base class for graphic entities.
GraphOverride | The base class for graphic override.
Label | The base class for all single-entity label objects.
LabelBase | The base class for all label classes, including single-feature labels (FeatureLabel derived classes) and group labels (LabelGroup derived... more
LabelGroup | The base class for all label group objects, such as AutoFeatureLabelGroup.
LabelGroupSubEntity | A class that represents individual labels in a label group.
LegendTable | A table that displays colors and range values for a surface analysis.
Table | Base class for table objects, such as LegendTable and AlignmentTable.
Links
Classes


AnchorInfo Class

This is class Autodesk::Civil::DatabaseServices::AnchorInfo.

Class Hierarchy
Autodesk::Civil::DatabaseServices::AnchorInfo
C#
public class AnchorInfo;
Visual Basic
Public Class AnchorInfo
Links
AnchorInfo Data Members, AnchorInfo Constructors, AnchorInfo Members, Class Hierarchy


AnchorInfo Members

The following tables list the members exposed by AnchorInfo.

Public Data Members
Public Data Member | Description
CenterOfCurve | This is CenterOfCurve, a member of class AnchorInfo.
DirectionAtLocation | This is DirectionAtLocation, a member of class AnchorInfo.
IsOnCurve | This is IsOnCurve, a member of class AnchorInfo.
Location | This is Location, a member of class AnchorInfo.
Public Methods
Public Method | Description
AnchorInfo | This is AnchorInfo, a member of class AnchorInfo.
Links
Public Data Members, Public Methods


AnchorInfo Data Members

The data members of AnchorInfo are listed here.

Public Data Members
Public Data Member | Description
CenterOfCurve | This is CenterOfCurve, a member of class AnchorInfo.
DirectionAtLocation | This is DirectionAtLocation, a member of class AnchorInfo.
IsOnCurve | This is IsOnCurve, a member of class AnchorInfo.
Location | This is Location, a member of class AnchorInfo.
Links
Public Data Members


AnchorInfo::CenterOfCurve Data Member

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AnchorInfo Class > AnchorInfo Data Members > AnchorInfo::CenterOfCurve Data Member
AnchorInfo::CenterOfCurve Data Member
Collapse All

This is CenterOfCurve, a member of class AnchorInfo.

C#
public initonly Autodesk::AutoCAD::Geometry::Point2d CenterOfCurve;
Visual Basic
Public CenterOfCurve As initonly Autodesk::AutoCAD::Geometry::Point2d
Links
AnchorInfo Class, AnchorInfo Members, Autodesk::Civil::DatabaseServices Namespace


AnchorInfo::DirectionAtLocation Data Member

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AnchorInfo Class > AnchorInfo Data Members > AnchorInfo::DirectionAtLocation Data Member
AnchorInfo::DirectionAtLocation Data Member
Collapse All

This is DirectionAtLocation, a member of class AnchorInfo.

C#
public initonly Autodesk::AutoCAD::Geometry::Vector3d DirectionAtLocation;
Visual Basic
Public DirectionAtLocation As initonly Autodesk::AutoCAD::Geometry::Vector3d
Links
AnchorInfo Class, AnchorInfo Members, Autodesk::Civil::DatabaseServices Namespace


AnchorInfo::IsOnCurve Data Member

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AnchorInfo Class > AnchorInfo Data Members > AnchorInfo::IsOnCurve Data Member
AnchorInfo::IsOnCurve Data Member
Collapse All

This is IsOnCurve, a member of class AnchorInfo.

C#
public initonly bool IsOnCurve;
Visual Basic
Public IsOnCurve As initonly bool
Links
AnchorInfo Class, AnchorInfo Members, Autodesk::Civil::DatabaseServices Namespace


AnchorInfo::Location Data Member

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AnchorInfo Class > AnchorInfo Data Members > AnchorInfo::Location Data Member
AnchorInfo::Location Data Member
Collapse All

This is Location, a member of class AnchorInfo.

C#
public initonly Autodesk::AutoCAD::Geometry::Point3d Location;
Visual Basic
Public Location As initonly Autodesk::AutoCAD::Geometry::Point3d
Links
AnchorInfo Class, AnchorInfo Members, Autodesk::Civil::DatabaseServices Namespace


AnchorInfo Constructors

The constructors of AnchorInfo are listed here.

Public Methods
Public Method | Description
AnchorInfo | This is AnchorInfo, a member of class AnchorInfo.
Links
Public Methods


AnchorInfo::AnchorInfo Constructor

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AnchorInfo Class > AnchorInfo Constructors > AnchorInfo::AnchorInfo Constructor
AnchorInfo::AnchorInfo Constructor
Collapse All

This is AnchorInfo, a member of class AnchorInfo.

C#
public AnchorInfo(
    bool isOnCurve,
    Autodesk::AutoCAD::Geometry::Point2d centerOfCurve,
    Autodesk::AutoCAD::Geometry::Vector3d directionAtLocation,
    Autodesk::AutoCAD::Geometry::Point3d location
);
Visual Basic
Public Sub New(
    isOnCurve As bool,
    centerOfCurve As Autodesk::AutoCAD::Geometry::Point2d,
    directionAtLocation As Autodesk::AutoCAD::Geometry::Vector3d,
    location As Autodesk::AutoCAD::Geometry::Point3d
)
Links
AnchorInfo Class, AnchorInfo Members, Autodesk::Civil::DatabaseServices Namespace


AutoFeatureLabelGroup Class

The base class for all label group objects that automatically label a range on a feature.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAutoFeatureLabeling"))]
public class AutoFeatureLabelGroup : LabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAutoFeatureLabeling"))>
Public Class AutoFeatureLabelGroup
Inherits LabelGroup
Links
AutoFeatureLabelGroup Methods, AutoFeatureLabelGroup Properties, AutoFeatureLabelGroup Members, Class Hierarchy


AutoFeatureLabelGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Members
AutoFeatureLabelGroup Members
Collapse All

The following tables list the members exposed by AutoFeatureLabelGroup.

Public Methods
Public Method | Description
GetAt | Gets one LabelGroupSubEntity from label group according the index.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AutoFeatureLabelGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Methods
AutoFeatureLabelGroup Methods
Collapse All

The methods of AutoFeatureLabelGroup are listed here.

Public Methods
Public Method | Description
SetRange | Sets both range parameters (start and end) at once.
Links
Public Methods


AutoFeatureLabelGroup::SetRange Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Methods > AutoFeatureLabelGroup::SetRange Method
AutoFeatureLabelGroup::SetRange Method
Collapse All

Sets both range parameters (start and end) at once.

C#
public SetRange(
    double rangeStart,
    double rangeEnd
);
Visual Basic
Public Sub SetRange(
    rangeStart As double,
    rangeEnd As double
)
Links
AutoFeatureLabelGroup Class, AutoFeatureLabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


AutoFeatureLabelGroup Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Properties
AutoFeatureLabelGroup Properties
Collapse All

The properties of AutoFeatureLabelGroup are listed here.

Public Properties
Public Property | Description
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
Links
Public Properties


AutoFeatureLabelGroup::RangeEnd Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Properties > AutoFeatureLabelGroup::RangeEnd Property
AutoFeatureLabelGroup::RangeEnd Property
Collapse All

Gets or sets the end of the labeled range.

C#
public double RangeEnd;
Visual Basic
Public Property RangeEnd() As double
Links
AutoFeatureLabelGroup Class, AutoFeatureLabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


AutoFeatureLabelGroup::RangeEndFromFeature Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Properties > AutoFeatureLabelGroup::RangeEndFromFeature Property
AutoFeatureLabelGroup::RangeEndFromFeature Property
Collapse All

Gets or sets whether the range ends at the same value where the feature ends.

C#
public bool RangeEndFromFeature;
Visual Basic
Public Property RangeEndFromFeature() As bool
Links
AutoFeatureLabelGroup Class, AutoFeatureLabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


AutoFeatureLabelGroup::RangeStart Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Properties > AutoFeatureLabelGroup::RangeStart Property
AutoFeatureLabelGroup::RangeStart Property
Collapse All

Gets or sets the start of the labeled range.

C#
public double RangeStart;
Visual Basic
Public Property RangeStart() As double
Links
AutoFeatureLabelGroup Class, AutoFeatureLabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


AutoFeatureLabelGroup::RangeStartFromFeature Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Properties > AutoFeatureLabelGroup::RangeStartFromFeature Property
AutoFeatureLabelGroup::RangeStartFromFeature Property
Collapse All

Gets or sets whether the range starts at the same value where the feature starts.

C#
public bool RangeStartFromFeature;
Visual Basic
Public Property RangeStartFromFeature() As bool
Links
AutoFeatureLabelGroup Class, AutoFeatureLabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


DBObject Class

The base class for database entities.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::NetworkRule
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartFamily
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartSize
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbTreeNode"))]
public class DBObject : Autodesk::AutoCAD::DatabaseServices::DBObject;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbTreeNode"))>
Public Class DBObject
Inherits Autodesk::AutoCAD::DatabaseServices::DBObject
Links
DBObject Properties, DBObject Members, Class Hierarchy


DBObject Members

The following tables list the members exposed by DBObject.

Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
Name | Gets or sets the name.
Links
Public Properties


DBObject Properties

The properties of DBObject are listed here.

Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
Name | Gets or sets the name.
Links
Public Properties


DBObject::Application Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > DBObject Class > DBObject Properties > DBObject::Application Property
DBObject::Application Property
Collapse All

Gets the Application associated with the DBObject. Not implemented.

C#
public System::Object Application;
Visual Basic
Public Property Application() As System::Object
Links
DBObject Class, DBObject Members, Autodesk::Civil::DatabaseServices Namespace


DBObject::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > DBObject Class > DBObject Properties > DBObject::Description Property
DBObject::Description Property
Collapse All

Gets or sets the description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
DBObject Class, DBObject Members, Autodesk::Civil::DatabaseServices Namespace


DBObject::Document Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > DBObject Class > DBObject Properties > DBObject::Document Property
DBObject::Document Property
Collapse All

Gets the Document associated with the DBObject. Not implemented.

C#
public System::Object Document;
Visual Basic
Public Property Document() As System::Object
Links
DBObject Class, DBObject Members, Autodesk::Civil::DatabaseServices Namespace


DBObject::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > DBObject Class > DBObject Properties > DBObject::Name Property
DBObject::Name Property
Collapse All

Gets or sets the name.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
DBObject Class, DBObject Members, Autodesk::Civil::DatabaseServices Namespace


Entity Class

The base class for entities, such as Feature, Table, Grading, Site, etc.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
    Autodesk::Civil::DatabaseServices::GeoEntity
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::Table
    Autodesk::Civil::Land::DatabaseServices::Grading
    Autodesk::Civil::Land::DatabaseServices::MassHaulLine
    Autodesk::Civil::Land::DatabaseServices::Parcel
    Autodesk::Civil::Land::DatabaseServices::ProfileProjection
    Autodesk::Civil::Land::DatabaseServices::Site
    Autodesk::Civil::Land::DatabaseServices::Surface
    Autodesk::Civil::PipeNetwork::DatabaseServices::ProfileViewPart
    Autodesk::Civil::Roadway::DatabaseServices::Corridor
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSection
    Autodesk::Civil::Roadway::DatabaseServices::Intersection
    Autodesk::Civil::Survey::DatabaseServices::SurveyNetworkEntity
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbEntity"))]
public class Entity : Autodesk::Aec::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbEntity"))>
Public Class Entity
Inherits Autodesk::Aec::DatabaseServices::Entity
Links
Entity Properties, Entity Members, Class Hierarchy


Entity Members

The following tables list the members exposed by Entity.

Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


Entity Properties

The properties of Entity are listed here.

Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


Entity::Application Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::Application Property
Entity::Application Property
Collapse All

Gets the Application. Not currently implemented.

C#
public System::Object Application;
Visual Basic
Public Property Application() As System::Object
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::DisplayName Property
Entity::DisplayName Property
Collapse All

Gets the Entity object's display name.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::Document Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::Document Property
Entity::Document Property
Collapse All

Gets the Document. Not currently implemented.

C#
public System::Object Document;
Visual Basic
Public Property Document() As System::Object
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::IsReferenceObject Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::IsReferenceObject Property
Entity::IsReferenceObject Property
Collapse All

Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a data shortcut or Vault. If the entity is native to the current drawing this property returns false; if it is being referenced via data shortcuts or AutoCAD Vault it returns true.

C#
public bool IsReferenceObject;
Visual Basic
Public Property IsReferenceObject() As bool
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::IsReferenceStale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::IsReferenceStale Property
Entity::IsReferenceStale Property
Collapse All

For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.

C#
public bool IsReferenceStale;
Visual Basic
Public Property IsReferenceStale() As bool
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::IsReferenceSubObject Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::IsReferenceSubObject Property
Entity::IsReferenceSubObject Property
Collapse All

For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through the structure of a pipe network referenced from another drawing, this property is true for each entity.

C#
public bool IsReferenceSubObject;
Visual Basic
Public Property IsReferenceSubObject() As bool
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::IsReferenceValid Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::IsReferenceValid Property
Entity::IsReferenceValid Property
Collapse All

For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced object can be found.

C#
public bool IsReferenceValid;
Visual Basic
Public Property IsReferenceValid() As bool
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::Name Property
Entity::Name Property
Collapse All

Gets or sets the Entity object's name.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::ShowToolTip Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::ShowToolTip Property
Entity::ShowToolTip Property
Collapse All

Gets or sets whether to show tooltips for the Entity.

C#
public bool ShowToolTip;
Visual Basic
Public Property ShowToolTip() As bool
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::StyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::StyleId Property
Entity::StyleId Property
Collapse All

Gets or sets the Entity object's style Id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StyleId;
Visual Basic
Public Property StyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the entity does not have a style property.
System.ArgumentException | Thrown when the style Id is invalid.
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Entity::StyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Entity Class > Entity Properties > Entity::StyleName Property
Entity::StyleName Property
Collapse All

Gets or sets the Entity object's style name.

C#
public System::String StyleName;
Visual Basic
Public Property StyleName() As System::String
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the entity does not have a style property.
System.ArgumentException | Thrown when the style name is invalid.
Links
Entity Class, Entity Members, Autodesk::Civil::DatabaseServices Namespace


Feature Class

Base class for Alignment, FeatureLine, ParcelSegment, and Profile.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::Alignment
        Autodesk::Civil::Land::DatabaseServices::FeatureLine
        Autodesk::Civil::Land::DatabaseServices::ParcelSegment
        Autodesk::Civil::Land::DatabaseServices::Profile
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFeature"))]
public class Feature : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFeature"))>
Public Class Feature
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
Feature Methods, Feature Properties, Feature Members, Class Hierarchy


Feature Members

The following tables list the members exposed by Feature.

Public Methods
Public Method | Description
IsEditableFeature | Check whether the Feature-derived entity (Alignment,Profile,etc) is editable.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsEditable | Gets the value indicates whether the Feature derived entity (Alignment,Profile,etc) is editable.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


Feature Methods

The methods of Feature are listed here.

Public Methods
Public Method | Description
IsEditableFeature | Check whether the Feature-derived entity (Alignment,Profile,etc) is editable.
Links
Public Methods


Feature::IsEditableFeature Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Feature Class > Feature Methods > Feature::IsEditableFeature Method
Feature::IsEditableFeature Method
Collapse All

Check whether the Feature-derived entity (Alignment,Profile,etc) is editable.

C#
public bool IsEditableFeature(
    Autodesk::AutoCAD::DatabaseServices::ObjectId featureId
);
Visual Basic
Public Function IsEditableFeature(
    featureId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As bool
Parameters
Parameters | Description
featureId | ObjectId for the Feature-derived entity you want to check.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when featureId is not invalid or represent entity which is not derived from Feature.
Links
Feature Class, Feature Members, Autodesk::Civil::DatabaseServices Namespace


Feature Properties

The properties of Feature are listed here.

Public Properties
Public Property | Description
IsEditable | Gets the value indicates whether the Feature derived entity (Alignment,Profile,etc) is editable.
Links
Public Properties


Feature::IsEditable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Feature Class > Feature Properties > Feature::IsEditable Property
Feature::IsEditable Property
Collapse All

Gets the value indicates whether the Feature derived entity (Alignment,Profile,etc) is editable.

C#
public bool IsEditable;
Visual Basic
Public Property IsEditable() As bool
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when featureId is not invalid or represent entity which is not derived from Feature.
Links
Feature Class, Feature Members, Autodesk::Civil::DatabaseServices Namespace


FeatureLabel Class

A base class for feature label classes, such as AlignmentCurveLabel.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentCurveLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentPILabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentSpiralLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentTangentLabel
                Autodesk::Civil::Land::DatabaseServices::StationOffsetLabel
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFeatureLabel"))]
public class FeatureLabel : Label;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFeatureLabel"))>
Public Class FeatureLabel
Inherits Label
Links
Class Hierarchy


GeoEntity Class

The base class for geometry db entities.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
        Autodesk::Civil::Land::DatabaseServices::MatchLine
        Autodesk::Civil::Land::DatabaseServices::SampleLine
        Autodesk::Civil::Land::DatabaseServices::SampleLineGroup
        Autodesk::Civil::Land::DatabaseServices::Section
        Autodesk::Civil::Land::DatabaseServices::Sheet
        Autodesk::Civil::Land::DatabaseServices::ViewFrame
        Autodesk::Civil::Land::DatabaseServices::ViewFrameGroup
        Autodesk::Civil::PipeNetwork::DatabaseServices::Interference
        Autodesk::Civil::PipeNetwork::DatabaseServices::InterferenceCheck
        Autodesk::Civil::PipeNetwork::DatabaseServices::Network
        Autodesk::Civil::PipeNetwork::DatabaseServices::Part
        Autodesk::Civil::Roadway::DatabaseServices::Assembly
        Autodesk::Civil::Roadway::DatabaseServices::Subassembly
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGeo"))]
public class GeoEntity : Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGeo"))>
Public Class GeoEntity
Inherits Entity
Links
Class Hierarchy


Graph Class

The base class for graphic entities.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
            Autodesk::Civil::Land::DatabaseServices::MassHaulView
            Autodesk::Civil::Land::DatabaseServices::ProfileView
            Autodesk::Civil::Land::DatabaseServices::SectionView
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraph"))]
public class Graph : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraph"))>
Public Class Graph
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
Class Hierarchy


GraphOverride Class

The base class for graphic override.

Class Hierarchy
Autodesk::Civil::DatabaseServices::GraphOverride
    Autodesk::Civil::Land::DatabaseServices::ProfileOverride
C#
public class GraphOverride : CivilWrapper<AeccDbGraph>;
Visual Basic
Public Class GraphOverride
Inherits CivilWrapper<AeccDbGraph>
Links
GraphOverride Properties, GraphOverride Members, Class Hierarchy


GraphOverride Members

The following tables list the members exposed by GraphOverride.

Public Properties
Public Property | Description
Draw | Gets or sets whether this entity will be drawn in the graph.
OverrideStyleId | Gets or sets the override style of the entity.
OverrideStyleName | Gets or sets the override style of the entity.
UseOverrideStyle | Gets or sets whether to override style for the display of the entity.
Links
Public Properties


GraphOverride Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > GraphOverride Class > GraphOverride Properties
GraphOverride Properties
Collapse All

The properties of GraphOverride are listed here.

Public Properties
Public Property | Description
Draw | Gets or sets whether this entity will be drawn in the graph.
OverrideStyleId | Gets or sets the override style of the entity.
OverrideStyleName | Gets or sets the override style of the entity.
UseOverrideStyle | Gets or sets whether to override style for the display of the entity.
Links
Public Properties


GraphOverride::Draw Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > GraphOverride Class > GraphOverride Properties > GraphOverride::Draw Property
GraphOverride::Draw Property
Collapse All

Gets or sets whether this entity will be drawn in the graph.

C#
public bool Draw;
Visual Basic
Public Property Draw() As bool
Links
GraphOverride Class, GraphOverride Members, Autodesk::Civil::DatabaseServices Namespace


GraphOverride::OverrideStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > GraphOverride Class > GraphOverride Properties > GraphOverride::OverrideStyleId Property
GraphOverride::OverrideStyleId Property
Collapse All

Gets or sets the override style of the entity.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId OverrideStyleId;
Visual Basic
Public Property OverrideStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

This style is used only in the current Graph. Any other Graph that is plotting the entity will not be impacted.

Links
GraphOverride Class, GraphOverride Members, Autodesk::Civil::DatabaseServices Namespace


GraphOverride::OverrideStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > GraphOverride Class > GraphOverride Properties > GraphOverride::OverrideStyleName Property
GraphOverride::OverrideStyleName Property
Collapse All

Gets or sets the override style of the entity.

C#
public System::String OverrideStyleName;
Visual Basic
Public Property OverrideStyleName() As System::String
Remarks

This style is used only in the current Graph. Any other Graph that is plotting the entity will not be impacted.

Links
GraphOverride Class, GraphOverride Members, Autodesk::Civil::DatabaseServices Namespace


GraphOverride::UseOverrideStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > GraphOverride Class > GraphOverride Properties > GraphOverride::UseOverrideStyle Property
GraphOverride::UseOverrideStyle Property
Collapse All

Gets or sets whether to override style for the display of the entity.

C#
public bool UseOverrideStyle;
Visual Basic
Public Property UseOverrideStyle() As bool
Links
GraphOverride Class, GraphOverride Members, Autodesk::Civil::DatabaseServices Namespace


Label Class

The base class for all single-entity label objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabel"))]
public class Label : LabelBase, ICommonLabel;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabel"))>
Public Class Label
Inherits LabelBase
Inherits ICommonLabel
Remarks

For more information about Civil 3D labels, see the "Labels and Tags" section of the AutoCAD Civil 3D User's Guide.

Links
Label Methods, Label Properties, Label Members, Class Hierarchy


Label Members

The following tables list the members exposed by Label.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


Label Methods

The methods of Label are listed here.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
Links
Public Methods


Label::ClearAllTextComponentOverrides Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > Label::ClearAllTextComponentOverrides Method
Label::ClearAllTextComponentOverrides Method
Collapse All

Clears all text component overrides in the label.

C#
public ClearAllTextComponentOverrides();
Visual Basic
Public Sub ClearAllTextComponentOverrides()
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::GetTextComponentIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > Label::GetTextComponentIds Method
Label::GetTextComponentIds Method
Collapse All

Gets a collection of object ids that represent the text components in a label.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetTextComponentIds();
Visual Basic
Public Function GetTextComponentIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Remarks

Gets all the components with a type of LabelStyleComponentType.Text, ReferenceText or TextForEach.

Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::GetTextComponentJustificationOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > Label::GetTextComponentJustificationOverride Method
Label::GetTextComponentJustificationOverride Method
Collapse All

Get the overriden justification on the specified text component.

C#
public Autodesk::Civil::TextJustificationType GetTextComponentJustificationOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId
);
Visual Basic
Public Function GetTextComponentJustificationOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::Civil::TextJustificationType
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::GetTextComponentOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > Label::GetTextComponentOverride Method
Label::GetTextComponentOverride Method
Collapse All

Get the overriden text on the specified text component.

C#
public System::String GetTextComponentOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId
);
Visual Basic
Public Function GetTextComponentOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::IsTextComponentOverriden Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > Label::IsTextComponentOverriden Method
Label::IsTextComponentOverriden Method
Collapse All

Returns whether the specified text component is overridden.

C#
public bool IsTextComponentOverriden(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId
);
Visual Basic
Public Function IsTextComponentOverriden(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As bool
Parameters
Parameters | Description
labelStyleComponentId | The object id of text component.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::Reset Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > Label::Reset Method
Label::Reset Method
Collapse All

Resets the label object to its defaults.

C#
public Reset();
Visual Basic
Public Sub Reset()
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::ResetLocation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > Label::ResetLocation Method
Label::ResetLocation Method
Collapse All

Resets the location of the label object to its default.

C#
public ResetLocation();
Visual Basic
Public Sub ResetLocation()
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::ResetProperties Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > Label::ResetProperties Method
Label::ResetProperties Method
Collapse All

Resets the properties of the label object to its defaults.

C#
public ResetProperties();
Visual Basic
Public Sub ResetProperties()
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::SetTextComponentJustificationOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > Label::SetTextComponentJustificationOverride Method
Label::SetTextComponentJustificationOverride Method
Collapse All

Overrides the justification on the specified text component.

C#
public SetTextComponentJustificationOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId,
    Autodesk::Civil::TextJustificationType textJustificationType
);
Visual Basic
Public Sub SetTextComponentJustificationOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    textJustificationType As Autodesk::Civil::TextJustificationType
)
Parameters
Parameters | Description
labelStyleComponentId | The object id of the text component.
textJustificationType | The type of text justification to set.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


SetTextComponentOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > SetTextComponentOverride Method
SetTextComponentOverride Method
Collapse All

Overloaded

Overload List
Method | Description
Label::SetTextComponentOverride (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^) | Overrides the text on the specified text component.
Label::SetTextComponentOverride (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType) | Overrides the text and justification on the specified text component.


Label::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > SetTextComponentOverride Method > Label::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^)
Label::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^)
Collapse All

Overrides the text on the specified text component.

C#
public SetTextComponentOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId,
    ref System::String textOverride
);
Visual Basic
Public Sub SetTextComponentOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef textOverride As System::String
)
Parameters
Parameters | Description
labelStyleComponentId | The object id of the text component.
textOverride | The override label text.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Methods > SetTextComponentOverride Method > Label::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType)
Label::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType)
Collapse All

Overrides the text and justification on the specified text component.

C#
public SetTextComponentOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId,
    ref System::String textOverride,
    Autodesk::Civil::TextJustificationType textJustificationType
);
Visual Basic
Public Sub SetTextComponentOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef textOverride As System::String,
    textJustificationType As Autodesk::Civil::TextJustificationType
)
Parameters
Parameters | Description
labelStyleComponentId | The object id of the text component.
textOverride | The override label text.
textJustificationType | The type of text justification.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label Properties

The properties of Label are listed here.

Public Properties
Public Property | Description
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


Label::AnchorInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::AnchorInfo Property
Label::AnchorInfo Property
Collapse All

Gets information about the label anchor.

C#
public Autodesk::Civil::DatabaseServices::AnchorInfo AnchorInfo;
Visual Basic
Public Property AnchorInfo() As Autodesk::Civil::DatabaseServices::AnchorInfo
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::AnchorMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::AnchorMarkerStyleId Property
Label::AnchorMarkerStyleId Property
Collapse All

Gets or sets the anchor marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AnchorMarkerStyleId;
Visual Basic
Public Property AnchorMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when anchor markers are not supported by the label object.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::DimensionAnchorInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::DimensionAnchorInfo Property
Label::DimensionAnchorInfo Property
Collapse All

Gets information about the label dimension anchor.

C#
public Autodesk::Civil::DatabaseServices::AnchorInfo DimensionAnchorInfo;
Visual Basic
Public Property DimensionAnchorInfo() As Autodesk::Civil::DatabaseServices::AnchorInfo
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchors are not supported by the label object.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::DimensionAnchorOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::DimensionAnchorOption Property
Label::DimensionAnchorOption Property
Collapse All

Gets or sets the dimension anchor option.

C#
public Autodesk::Civil::DimensionAnchorOptionType DimensionAnchorOption;
Visual Basic
Public Property DimensionAnchorOption() As Autodesk::Civil::DimensionAnchorOptionType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchor are not supported by the label object.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::DimensionAnchorValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::DimensionAnchorValue Property
Label::DimensionAnchorValue Property
Collapse All

Gets or sets the dimension anchor value.

C#
public double DimensionAnchorValue;
Visual Basic
Public Property DimensionAnchorValue() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchor are not supported by the label object.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::Dragged Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::Dragged Property
Label::Dragged Property
Collapse All

Gets a bool value that specifies whether the label has been dragged.

C#
public bool Dragged;
Visual Basic
Public Property Dragged() As bool
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::DraggedOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::DraggedOffset Property
Label::DraggedOffset Property
Collapse All

Gets or sets the dragged offset on the sub-entity label.

C#
public Autodesk::AutoCAD::Geometry::Vector3d DraggedOffset;
Visual Basic
Public Property DraggedOffset() As Autodesk::AutoCAD::Geometry::Vector3d
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the label object can't be dragged.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::Flipped Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::Flipped Property
Label::Flipped Property
Collapse All

Gets or sets the flipped state of the label.

C#
public bool Flipped;
Visual Basic
Public Property Flipped() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the label object can't be flipped.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::LeaderAttachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::LeaderAttachment Property
Label::LeaderAttachment Property
Collapse All

Gets or sets the leader attachment option.

C#
public Autodesk::Civil::LeaderAttachmentBehaviorType LeaderAttachment;
Visual Basic
Public Property LeaderAttachment() As Autodesk::Civil::LeaderAttachmentBehaviorType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when leader attachment options are not supported by the label object.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::LeaderTailVisibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::LeaderTailVisibility Property
Label::LeaderTailVisibility Property
Collapse All

Gets or sets the leader tail visibility.

C#
public Autodesk::Civil::LeaderTailVisibilityType LeaderTailVisibility;
Visual Basic
Public Property LeaderTailVisibility() As Autodesk::Civil::LeaderTailVisibilityType
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::LeaderVisibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::LeaderVisibility Property
Label::LeaderVisibility Property
Collapse All

Gets or sets the leader visibility.

C#
public Autodesk::Civil::LeaderVisibilityType LeaderVisibility;
Visual Basic
Public Property LeaderVisibility() As Autodesk::Civil::LeaderVisibilityType
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::Pinned Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::Pinned Property
Label::Pinned Property
Collapse All

Gets or sets the pinned state of the label.

C#
public bool Pinned;
Visual Basic
Public Property Pinned() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when: (1) the label object can't be pinned when setting. (2) the label object is not dragged.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::Reversed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::Reversed Property
Label::Reversed Property
Collapse All

Gets or sets the reversed state of the label.

C#
public bool Reversed;
Visual Basic
Public Property Reversed() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the label object can't be reversed.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::StyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::StyleId Property
Label::StyleId Property
Collapse All

Gets or sets the Entity object's style Id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StyleId;
Visual Basic
Public Property StyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the entity does not have a style property.
System.ArgumentException | Thrown when the style Id is invalid.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


Label::StyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > Label Class > Label Properties > Label::StyleName Property
Label::StyleName Property
Collapse All

Gets or sets the Entity object's style name.

C#
public System::String StyleName;
Visual Basic
Public Property StyleName() As System::String
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the entity does not have a style property.
System.ArgumentException | Thrown when the style name is invalid.
Links
Label Class, Label Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase Class

The base class for all label classes, including single-feature labels (FeatureLabel derived classes) and group labels (LabelGroup derived classes). This class implements the ICommonLabelOptions interface, which defines common label behaviors.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::Label
        Autodesk::Civil::DatabaseServices::LabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabeling"))]
public class LabelBase : Autodesk::Civil::DatabaseServices::Entity, ICommonLabelOptions;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabeling"))>
Public Class LabelBase
Inherits Autodesk::Civil::DatabaseServices::Entity
Inherits ICommonLabelOptions
Links
LabelBase Properties, LabelBase Members, Class Hierarchy


LabelBase Members

The following tables list the members exposed by LabelBase.

Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Properties


LabelBase Properties

The properties of LabelBase are listed here.

Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Mask | Gets or sets the mask type.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Properties


LabelBase::AllowsAnchorMarker Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::AllowsAnchorMarker Property
LabelBase::AllowsAnchorMarker Property
Collapse All

Gets a boolean value that specifies whether anchor markers are supported by the label object.

C#
public bool AllowsAnchorMarker;
Visual Basic
Public Property AllowsAnchorMarker() As bool
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::AllowsDimensionAnchors Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::AllowsDimensionAnchors Property
LabelBase::AllowsDimensionAnchors Property
Collapse All

Gets a boolean value that specifies whether dimension anchors are supported by the label object.

C#
public bool AllowsDimensionAnchors;
Visual Basic
Public Property AllowsDimensionAnchors() As bool
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::AllowsDragging Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::AllowsDragging Property
LabelBase::AllowsDragging Property
Collapse All

Gets a boolean value that specifies whether the label object can be dragged.

C#
public bool AllowsDragging;
Visual Basic
Public Property AllowsDragging() As bool
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::AllowsFlipping Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::AllowsFlipping Property
LabelBase::AllowsFlipping Property
Collapse All

Gets a boolean value that specifies whether the label object can be flipped.

C#
public bool AllowsFlipping;
Visual Basic
Public Property AllowsFlipping() As bool
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::AllowsLeaderAttachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::AllowsLeaderAttachment Property
LabelBase::AllowsLeaderAttachment Property
Collapse All

Gets a boolean value that specifies whether leader attachment options are supported by the label object.

C#
public bool AllowsLeaderAttachment;
Visual Basic
Public Property AllowsLeaderAttachment() As bool
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::AllowsPinning Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::AllowsPinning Property
LabelBase::AllowsPinning Property
Collapse All

Gets a boolean value that specifies whether the label object can be pinned.

C#
public bool AllowsPinning;
Visual Basic
Public Property AllowsPinning() As bool
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::AllowsReversing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::AllowsReversing Property
LabelBase::AllowsReversing Property
Collapse All

Gets a boolean value that specifies whether the label object can be reversed.

C#
public bool AllowsReversing;
Visual Basic
Public Property AllowsReversing() As bool
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::AutoStagger Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::AutoStagger Property
LabelBase::AutoStagger Property
Collapse All

Gets or sets the auto stagger type on the label object.

C#
public Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType AutoStagger;
Visual Basic
Public Property AutoStagger() As Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::DefaultDimensionAnchorOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::DefaultDimensionAnchorOption Property
LabelBase::DefaultDimensionAnchorOption Property
Collapse All

Gets or sets the default dimension anchor option.

C#
public Autodesk::Civil::DimensionAnchorOptionType DefaultDimensionAnchorOption;
Visual Basic
Public Property DefaultDimensionAnchorOption() As Autodesk::Civil::DimensionAnchorOptionType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchors are not supported by the label object.
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::DefaultDimensionAnchorValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::DefaultDimensionAnchorValue Property
LabelBase::DefaultDimensionAnchorValue Property
Collapse All

Gets or sets the default anchor value.

C#
public double DefaultDimensionAnchorValue;
Visual Basic
Public Property DefaultDimensionAnchorValue() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchors are not supported by the label object.
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::FeatureId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::FeatureId Property
LabelBase::FeatureId Property
Collapse All

Gets the ObjectId of the feature being labeled by the label object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId FeatureId;
Visual Basic
Public Property FeatureId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::Mask Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::Mask Property
LabelBase::Mask Property
Collapse All

Gets or sets the mask type.

C#
public Autodesk::Civil::MaskType Mask;
Visual Basic
Public Property Mask() As Autodesk::Civil::MaskType
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelBase::ViewId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelBase Class > LabelBase Properties > LabelBase::ViewId Property
LabelBase::ViewId Property
Collapse All

Gets the ObjectId of the view where the label exists.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ViewId;
Visual Basic
Public Property ViewId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
LabelBase Class, LabelBase Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup Class

The base class for all label group objects, such as AutoFeatureLabelGroup.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
            Autodesk::Civil::Land::DatabaseServices::ProfileBandLabelGroup
            Autodesk::Civil::Land::DatabaseServices::SectionBandLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabeling"))]
public class LabelGroup : Autodesk::Civil::DatabaseServices::LabelBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLabeling"))>
Public Class LabelGroup
Inherits Autodesk::Civil::DatabaseServices::LabelBase
Remarks

For more information about Civil 3D labels, see the "Labels and Tags" section of the AutoCAD Civil 3D User's Guide.

Links
LabelGroup Methods, LabelGroup Properties, LabelGroup Members, Class Hierarchy


LabelGroup Members

The following tables list the members exposed by LabelGroup.

Public Methods
Public Method | Description
GetAt | Gets one LabelGroupSubEntity from label group according the index.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


LabelGroup Methods

The methods of LabelGroup are listed here.

Public Methods
Public Method | Description
GetAt | Gets one LabelGroupSubEntity from label group according the index.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
Links
Public Methods


LabelGroup::GetAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Methods > LabelGroup::GetAt Method
LabelGroup::GetAt Method
Collapse All

Gets one LabelGroupSubEntity from label group according the index.

C#
public LabelGroupSubEntity GetAt(
    unsigned long index
);
Visual Basic
Public Function GetAt(
    index As unsigned long
) As LabelGroupSubEntity
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup::ResetAllSubCommonLabelLocations Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Methods > LabelGroup::ResetAllSubCommonLabelLocations Method
LabelGroup::ResetAllSubCommonLabelLocations Method
Collapse All

Resets the location of all the sub-entity labels to their defaults.

C#
public ResetAllSubCommonLabelLocations();
Visual Basic
Public Sub ResetAllSubCommonLabelLocations()
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup::ResetAllSubCommonLabelProperties Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Methods > LabelGroup::ResetAllSubCommonLabelProperties Method
LabelGroup::ResetAllSubCommonLabelProperties Method
Collapse All

Resets the properties of all the sub-entity labels to their defaults.

C#
public ResetAllSubCommonLabelProperties();
Visual Basic
Public Sub ResetAllSubCommonLabelProperties()
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup::ResetAllSubCommonLabels Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Methods > LabelGroup::ResetAllSubCommonLabels Method
LabelGroup::ResetAllSubCommonLabels Method
Collapse All

Resets all the sub-entity labels (properties and location).

C#
public ResetAllSubCommonLabels();
Visual Basic
Public Sub ResetAllSubCommonLabels()
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup Properties

The properties of LabelGroup are listed here.

Public Properties
Public Property | Description
DescriptiveText | Gets a description of the label.
IsGroupLabelType | Specifies whether the label is a group label.
LabelType | Gets the type of the label.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
Links
Public Properties


LabelGroup::DescriptiveText Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Properties > LabelGroup::DescriptiveText Property
LabelGroup::DescriptiveText Property
Collapse All

Gets a description of the label.

C#
public String DescriptiveText;
Visual Basic
Public Property DescriptiveText() As String
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup::IsGroupLabelType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Properties > LabelGroup::IsGroupLabelType Property
LabelGroup::IsGroupLabelType Property
Collapse All

Specifies whether the label is a group label.

C#
public bool IsGroupLabelType;
Visual Basic
Public Property IsGroupLabelType() As bool
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup::LabelType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Properties > LabelGroup::LabelType Property
LabelGroup::LabelType Property
Collapse All

Gets the type of the label.

C#
public Autodesk::Civil::DatabaseServices::LabelType LabelType;
Visual Basic
Public Property LabelType() As Autodesk::Civil::DatabaseServices::LabelType
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup::StyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Properties > LabelGroup::StyleId Property
LabelGroup::StyleId Property
Collapse All

Gets or sets the label group's style Id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StyleId;
Visual Basic
Public Property StyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when input style id doesn't exist under the corresponding label style collection.
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup::StyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Properties > LabelGroup::StyleName Property
LabelGroup::StyleName Property
Collapse All

Gets or sets the label style name.

C#
public System::String StyleName;
Visual Basic
Public Property StyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when input style name doesn't exist under the corresponding label style collection.
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup::SubEntities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Properties > LabelGroup::SubEntities Property
LabelGroup::SubEntities Property
Collapse All

Gets the number of sub-entity labels managed by this group label.

C#
public System::Collections::Generic::IList<LabelGroupSubEntity^> SubEntities;
Visual Basic
Public Property SubEntities() As System::Collections::Generic::IList<LabelGroupSubEntity^>
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroup::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroup Class > LabelGroup Properties > LabelGroup::SubEntityCount Property
LabelGroup::SubEntityCount Property
Collapse All

Gets the number of sub-entity labels managed by this group label.

C#
public unsigned long SubEntityCount;
Visual Basic
Public Property SubEntityCount() As unsigned long
Links
LabelGroup Class, LabelGroup Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity Class

A class that represents individual labels in a label group.

Class Hierarchy
Autodesk::Civil::DatabaseServices::ICommonLabel
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelGroupSubEntity
C#
public class LabelGroupSubEntity : ICommonLabelOptions, ICommonLabel;
Visual Basic
Public Class LabelGroupSubEntity
Inherits ICommonLabelOptions
Inherits ICommonLabel
Links
LabelGroupSubEntity Methods, LabelGroupSubEntity Properties, LabelGroupSubEntity Members, Class Hierarchy


LabelGroupSubEntity Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Members
LabelGroupSubEntity Members
Collapse All

The following tables list the members exposed by LabelGroupSubEntity.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | ICommonLabel
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
Index | Gets a reference to the LabelGroup instance parent of this object.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Parent | Gets a reference to the LabelGroup instance parent of this object.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the label style.
Visibility | This is Visibility, a member of class LabelGroupSubEntity.
Links
Public Methods, Public Properties


LabelGroupSubEntity Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods
LabelGroupSubEntity Methods
Collapse All

The methods of LabelGroupSubEntity are listed here.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
Links
Public Methods


LabelGroupSubEntity::ClearAllTextComponentOverrides Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > LabelGroupSubEntity::ClearAllTextComponentOverrides Method
LabelGroupSubEntity::ClearAllTextComponentOverrides Method
Collapse All

Clears all text component overrides in the label.

C#
public ClearAllTextComponentOverrides();
Visual Basic
Public Sub ClearAllTextComponentOverrides()
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::GetTextComponentIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > LabelGroupSubEntity::GetTextComponentIds Method
LabelGroupSubEntity::GetTextComponentIds Method
Collapse All

Gets a collection of object ids that represent the text components in a label.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetTextComponentIds();
Visual Basic
Public Function GetTextComponentIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Remarks

Gets all the components with a type of LabelStyleComponentType.Text, ReferenceText or TextForEach.

Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::GetTextComponentJustificationOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > LabelGroupSubEntity::GetTextComponentJustificationOverride Method
LabelGroupSubEntity::GetTextComponentJustificationOverride Method
Collapse All

Get the overriden justification on the specified text component.

C#
public Autodesk::Civil::TextJustificationType GetTextComponentJustificationOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId
);
Visual Basic
Public Function GetTextComponentJustificationOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::Civil::TextJustificationType
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::GetTextComponentOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > LabelGroupSubEntity::GetTextComponentOverride Method
LabelGroupSubEntity::GetTextComponentOverride Method
Collapse All

Get the overriden text on the specified text component.

C#
public System::String GetTextComponentOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId
);
Visual Basic
Public Function GetTextComponentOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::IsTextComponentOverriden Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > LabelGroupSubEntity::IsTextComponentOverriden Method
LabelGroupSubEntity::IsTextComponentOverriden Method
Collapse All

Returns whether the specified text component is overridden.

C#
public bool IsTextComponentOverriden(
    Autodesk::AutoCAD::DatabaseServices::ObjectId newVal
);
Visual Basic
Public Function IsTextComponentOverriden(
    newVal As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As bool
Parameters
Parameters | Description
labelStyleComponentId | The object id of text component.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::Reset Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > LabelGroupSubEntity::Reset Method
LabelGroupSubEntity::Reset Method
Collapse All

Resets the label object to its defaults.

C#
public Reset();
Visual Basic
Public Sub Reset()
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::ResetLocation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > LabelGroupSubEntity::ResetLocation Method
LabelGroupSubEntity::ResetLocation Method
Collapse All

Resets the location of the label object to its default.

C#
public ResetLocation();
Visual Basic
Public Sub ResetLocation()
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::ResetProperties Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > LabelGroupSubEntity::ResetProperties Method
LabelGroupSubEntity::ResetProperties Method
Collapse All

Resets the properties of the label object to its defaults.

C#
public ResetProperties();
Visual Basic
Public Sub ResetProperties()
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::SetTextComponentJustificationOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > LabelGroupSubEntity::SetTextComponentJustificationOverride Method
LabelGroupSubEntity::SetTextComponentJustificationOverride Method
Collapse All

Overrides the justification on the specified text component.

C#
public SetTextComponentJustificationOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId,
    Autodesk::Civil::TextJustificationType textJustificationType
);
Visual Basic
Public Sub SetTextComponentJustificationOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    textJustificationType As Autodesk::Civil::TextJustificationType
)
Parameters
Parameters | Description
labelStyleComponentId | The object id of the text component.
textJustificationType | The type of text justification to set.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


SetTextComponentOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > SetTextComponentOverride Method
SetTextComponentOverride Method
Collapse All

Overloaded

Overload List
Method | Description
LabelGroupSubEntity::SetTextComponentOverride (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^) | Overrides the text on the specified text component.
LabelGroupSubEntity::SetTextComponentOverride (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType) | Overrides the text and justification on the specified text component.


LabelGroupSubEntity::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > SetTextComponentOverride Method > LabelGroupSubEntity::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^)
LabelGroupSubEntity::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^)
Collapse All

Overrides the text on the specified text component.

C#
public SetTextComponentOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId,
    ref System::String textOverride
);
Visual Basic
Public Sub SetTextComponentOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef textOverride As System::String
)
Parameters
Parameters | Description
labelStyleComponentId | The object id of the text component.
textOverride | The override label text.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods > SetTextComponentOverride Method > LabelGroupSubEntity::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType)
LabelGroupSubEntity::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType)
Collapse All

Overrides the text and justification on the specified text component.

C#
public SetTextComponentOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId,
    ref System::String textOverride,
    Autodesk::Civil::TextJustificationType textJustificationType
);
Visual Basic
Public Sub SetTextComponentOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef textOverride As System::String,
    textJustificationType As Autodesk::Civil::TextJustificationType
)
Parameters
Parameters | Description
labelStyleComponentId | The object id of the text component.
textOverride | The override label text.
textJustificationType | The type of text justification.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties
LabelGroupSubEntity Properties
Collapse All

The properties of LabelGroupSubEntity are listed here.

Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | ICommonLabel
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
Index | Gets a reference to the LabelGroup instance parent of this object.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Parent | Gets a reference to the LabelGroup instance parent of this object.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the label style.
Visibility | This is Visibility, a member of class LabelGroupSubEntity.
Links
Public Properties


LabelGroupSubEntity::AllowsAnchorMarker Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::AllowsAnchorMarker Property
LabelGroupSubEntity::AllowsAnchorMarker Property
Collapse All

Gets a boolean value that specifies whether anchor markers are supported by the label object.

C#
public bool AllowsAnchorMarker;
Visual Basic
Public Property AllowsAnchorMarker() As bool
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::AllowsDimensionAnchors Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::AllowsDimensionAnchors Property
LabelGroupSubEntity::AllowsDimensionAnchors Property
Collapse All

Gets a boolean value that specifies whether dimension anchors are supported by the label object.

C#
public bool AllowsDimensionAnchors;
Visual Basic
Public Property AllowsDimensionAnchors() As bool
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::AllowsDragging Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::AllowsDragging Property
LabelGroupSubEntity::AllowsDragging Property
Collapse All

Gets a boolean value that specifies whether the label object can be dragged.

C#
public bool AllowsDragging;
Visual Basic
Public Property AllowsDragging() As bool
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::AllowsFlipping Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::AllowsFlipping Property
LabelGroupSubEntity::AllowsFlipping Property
Collapse All

Gets a boolean value that specifies whether the label object can be flipped.

C#
public bool AllowsFlipping;
Visual Basic
Public Property AllowsFlipping() As bool
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::AllowsLeaderAttachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::AllowsLeaderAttachment Property
LabelGroupSubEntity::AllowsLeaderAttachment Property
Collapse All

Gets a boolean value that specifies whether leader attachment options are supported by the label object.

C#
public bool AllowsLeaderAttachment;
Visual Basic
Public Property AllowsLeaderAttachment() As bool
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::AllowsPinning Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::AllowsPinning Property
LabelGroupSubEntity::AllowsPinning Property
Collapse All

Gets a boolean value that specifies whether the label object can be pinned.

C#
public bool AllowsPinning;
Visual Basic
Public Property AllowsPinning() As bool
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::AllowsReversing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::AllowsReversing Property
LabelGroupSubEntity::AllowsReversing Property
Collapse All

Gets a boolean value that specifies whether the label object can be reversed.

C#
public bool AllowsReversing;
Visual Basic
Public Property AllowsReversing() As bool
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::AnchorInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::AnchorInfo Property
LabelGroupSubEntity::AnchorInfo Property
Collapse All

ICommonLabel

C#
public Autodesk::Civil::DatabaseServices::AnchorInfo AnchorInfo;
Visual Basic
Public Property AnchorInfo() As Autodesk::Civil::DatabaseServices::AnchorInfo
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::AnchorMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::AnchorMarkerStyleId Property
LabelGroupSubEntity::AnchorMarkerStyleId Property
Collapse All

Gets or sets the anchor marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AnchorMarkerStyleId;
Visual Basic
Public Property AnchorMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when anchor markers are not supported by the label object.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::DefaultDimensionAnchorOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::DefaultDimensionAnchorOption Property
LabelGroupSubEntity::DefaultDimensionAnchorOption Property
Collapse All

Gets or sets the default dimension anchor option.

C#
public Autodesk::Civil::DimensionAnchorOptionType DefaultDimensionAnchorOption;
Visual Basic
Public Property DefaultDimensionAnchorOption() As Autodesk::Civil::DimensionAnchorOptionType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchors are not supported by the label object.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::DefaultDimensionAnchorValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::DefaultDimensionAnchorValue Property
LabelGroupSubEntity::DefaultDimensionAnchorValue Property
Collapse All

Gets or sets the default anchor value.

C#
public double DefaultDimensionAnchorValue;
Visual Basic
Public Property DefaultDimensionAnchorValue() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchors are not supported by the label object.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::DimensionAnchorInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::DimensionAnchorInfo Property
LabelGroupSubEntity::DimensionAnchorInfo Property
Collapse All

Gets information about the label dimension anchor.

C#
public Autodesk::Civil::DatabaseServices::AnchorInfo DimensionAnchorInfo;
Visual Basic
Public Property DimensionAnchorInfo() As Autodesk::Civil::DatabaseServices::AnchorInfo
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchors are not supported by the label object.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::DimensionAnchorOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::DimensionAnchorOption Property
LabelGroupSubEntity::DimensionAnchorOption Property
Collapse All

Gets or sets the dimension anchor option.

C#
public Autodesk::Civil::DimensionAnchorOptionType DimensionAnchorOption;
Visual Basic
Public Property DimensionAnchorOption() As Autodesk::Civil::DimensionAnchorOptionType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchor are not supported by the label object.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::DimensionAnchorValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::DimensionAnchorValue Property
LabelGroupSubEntity::DimensionAnchorValue Property
Collapse All

Gets or sets the dimension anchor value.

C#
public double DimensionAnchorValue;
Visual Basic
Public Property DimensionAnchorValue() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchor are not supported by the label object.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::Dragged Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::Dragged Property
LabelGroupSubEntity::Dragged Property
Collapse All

Gets a bool value that specifies whether the label has been dragged.

C#
public bool Dragged;
Visual Basic
Public Property Dragged() As bool
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::DraggedOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::DraggedOffset Property
LabelGroupSubEntity::DraggedOffset Property
Collapse All

Gets or sets the dragged offset on the sub-entity label.

C#
public Autodesk::AutoCAD::Geometry::Vector3d DraggedOffset;
Visual Basic
Public Property DraggedOffset() As Autodesk::AutoCAD::Geometry::Vector3d
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the label object can't be dragged.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::Flipped Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::Flipped Property
LabelGroupSubEntity::Flipped Property
Collapse All

Gets or sets the flipped state of the label.

C#
public bool Flipped;
Visual Basic
Public Property Flipped() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the label object can't be flipped.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::Index Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::Index Property
LabelGroupSubEntity::Index Property
Collapse All

Gets a reference to the LabelGroup instance parent of this object.

C#
public unsigned long Index;
Visual Basic
Public Property Index() As unsigned long
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::LeaderAttachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::LeaderAttachment Property
LabelGroupSubEntity::LeaderAttachment Property
Collapse All

Gets or sets the leader attachment option.

C#
public Autodesk::Civil::LeaderAttachmentBehaviorType LeaderAttachment;
Visual Basic
Public Property LeaderAttachment() As Autodesk::Civil::LeaderAttachmentBehaviorType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when leader attachment options are not supported by the label object.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::LeaderTailVisibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::LeaderTailVisibility Property
LabelGroupSubEntity::LeaderTailVisibility Property
Collapse All

Gets or sets the leader tail visibility.

C#
public Autodesk::Civil::LeaderTailVisibilityType LeaderTailVisibility;
Visual Basic
Public Property LeaderTailVisibility() As Autodesk::Civil::LeaderTailVisibilityType
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::LeaderVisibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::LeaderVisibility Property
LabelGroupSubEntity::LeaderVisibility Property
Collapse All

Gets or sets the leader visibility.

C#
public Autodesk::Civil::LeaderVisibilityType LeaderVisibility;
Visual Basic
Public Property LeaderVisibility() As Autodesk::Civil::LeaderVisibilityType
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::Parent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::Parent Property
LabelGroupSubEntity::Parent Property
Collapse All

Gets a reference to the LabelGroup instance parent of this object.

C#
public LabelGroup Parent;
Visual Basic
Public Property Parent() As LabelGroup
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::Pinned Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::Pinned Property
LabelGroupSubEntity::Pinned Property
Collapse All

Gets or sets the pinned state of the label.

C#
public bool Pinned;
Visual Basic
Public Property Pinned() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when: (1) the label object can't be pinned when setting. (2) the label object is not dragged.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::Reversed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::Reversed Property
LabelGroupSubEntity::Reversed Property
Collapse All

Gets or sets the reversed state of the label.

C#
public bool Reversed;
Visual Basic
Public Property Reversed() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the label object can't be reversed.
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::StyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::StyleId Property
LabelGroupSubEntity::StyleId Property
Collapse All

Gets or sets the label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StyleId;
Visual Basic
Public Property StyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

If this property returns a null style id, you need to get the parent's style id manually. Set the style id to null to use the parent's style.

Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LabelGroupSubEntity::Visibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties > LabelGroupSubEntity::Visibility Property
LabelGroupSubEntity::Visibility Property
Collapse All

This is Visibility, a member of class LabelGroupSubEntity.

C#
public bool Visibility;
Visual Basic
Public Property Visibility() As bool
Links
LabelGroupSubEntity Class, LabelGroupSubEntity Members, Autodesk::Civil::DatabaseServices Namespace


LegendTable Class

A table that displays colors and range values for a surface analysis.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::DatabaseServices::LegendTable
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLegendScheduleTable"))]
public class LegendTable : Table;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLegendScheduleTable"))>
Public Class LegendTable
Inherits Table
Links
Class Hierarchy


Table Class

Base class for table objects, such as LegendTable and AlignmentTable.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::DatabaseServices::LegendTable
        Autodesk::Civil::Land::DatabaseServices::AlignmentTable
        Autodesk::Civil::Land::DatabaseServices::ParcelSegmentTable
        Autodesk::Civil::Land::DatabaseServices::ParcelTable
        Autodesk::Civil::Land::DatabaseServices::PointTable
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbScheduleTable"))]
public class Table : Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbScheduleTable"))>
Public Class Table
Inherits Entity
Links
Class Hierarchy


Interfaces

The following table lists interfaces in this documentation.

Interfaces
Interface | Description
ICommonLabel | The interface ICommonLabel declares properties and methods common to all classes representing labels.
ICommonLabelOptions | The interface ICommonLabelOptions declares common behavioral options on labels.
Links
Interfaces


ICommonLabel Interface

The interface ICommonLabel declares properties and methods common to all classes representing labels.

Class Hierarchy
Autodesk::Civil::DatabaseServices::ICommonLabel
    Autodesk::Civil::DatabaseServices::Label
    Autodesk::Civil::DatabaseServices::LabelGroupSubEntity
C#
public interface ICommonLabel;
Visual Basic
Public Interface ICommonLabel
Links
ICommonLabel Methods, ICommonLabel Properties, ICommonLabel Members, Class Hierarchy


ICommonLabel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Members
ICommonLabel Members
Collapse All

The following tables list the members exposed by ICommonLabel.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
Public Properties
Public Property | Description
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the label style id.
Links
Public Methods, Public Properties


ICommonLabel Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods
ICommonLabel Methods
Collapse All

The methods of ICommonLabel are listed here.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
Links
Public Methods


ICommonLabel::ClearAllTextComponentOverrides Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > ICommonLabel::ClearAllTextComponentOverrides Method
ICommonLabel::ClearAllTextComponentOverrides Method
Collapse All

Clears all text component overrides in the label.

C#
ClearAllTextComponentOverrides();
Visual Basic
Sub ClearAllTextComponentOverrides()
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::GetTextComponentIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > ICommonLabel::GetTextComponentIds Method
ICommonLabel::GetTextComponentIds Method
Collapse All

Gets a collection of object ids that represent the text components in a label.

C#
Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetTextComponentIds();
Visual Basic
Function GetTextComponentIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Remarks

Gets all the components with a type of LabelStyleComponentType.Text, ReferenceText or TextForEach.

Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::GetTextComponentJustificationOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > ICommonLabel::GetTextComponentJustificationOverride Method
ICommonLabel::GetTextComponentJustificationOverride Method
Collapse All

Get the overriden justification on the specified text component.

C#
Autodesk::Civil::TextJustificationType GetTextComponentJustificationOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId
);
Visual Basic
Function GetTextComponentJustificationOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::Civil::TextJustificationType
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::GetTextComponentOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > ICommonLabel::GetTextComponentOverride Method
ICommonLabel::GetTextComponentOverride Method
Collapse All

Get the overriden text on the specified text component.

C#
System::String GetTextComponentOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId
);
Visual Basic
Function GetTextComponentOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::IsTextComponentOverriden Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > ICommonLabel::IsTextComponentOverriden Method
ICommonLabel::IsTextComponentOverriden Method
Collapse All

Returns whether the specified text component is overridden.

C#
bool IsTextComponentOverriden(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId
);
Visual Basic
Function IsTextComponentOverriden(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As bool
Parameters
Parameters | Description
labelStyleComponentId | The object id of text component.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::Reset Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > ICommonLabel::Reset Method
ICommonLabel::Reset Method
Collapse All

Resets the label object to its defaults.

C#
Reset();
Visual Basic
Sub Reset()
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::ResetLocation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > ICommonLabel::ResetLocation Method
ICommonLabel::ResetLocation Method
Collapse All

Resets the location of the label object to its default.

C#
ResetLocation();
Visual Basic
Sub ResetLocation()
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::ResetProperties Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > ICommonLabel::ResetProperties Method
ICommonLabel::ResetProperties Method
Collapse All

Resets the properties of the label object to its defaults.

C#
ResetProperties();
Visual Basic
Sub ResetProperties()
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::SetTextComponentJustificationOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > ICommonLabel::SetTextComponentJustificationOverride Method
ICommonLabel::SetTextComponentJustificationOverride Method
Collapse All

Overrides the justification on the specified text component.

C#
SetTextComponentJustificationOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId,
    Autodesk::Civil::TextJustificationType textJustificationType
);
Visual Basic
Sub SetTextComponentJustificationOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    textJustificationType As Autodesk::Civil::TextJustificationType
)
Parameters
Parameters | Description
labelStyleComponentId | The object id of the text component.
textJustificationType | The type of text justification to set.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


SetTextComponentOverride Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > SetTextComponentOverride Method
SetTextComponentOverride Method
Collapse All

Overloaded

Overload List
Method | Description
ICommonLabel::SetTextComponentOverride (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^) | Overrides the text on the specified text component.
ICommonLabel::SetTextComponentOverride (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType) | Overrides the text and justification on the specified text component.


ICommonLabel::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > SetTextComponentOverride Method > ICommonLabel::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^)
ICommonLabel::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^)
Collapse All

Overrides the text on the specified text component.

C#
SetTextComponentOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId,
    ref System::String textOverride
);
Visual Basic
Sub SetTextComponentOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef textOverride As System::String
)
Parameters
Parameters | Description
labelStyleComponentId | The object id of the text component.
textOverride | The override label text.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods > SetTextComponentOverride Method > ICommonLabel::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType)
ICommonLabel::SetTextComponentOverride Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, System::String^, Autodesk::Civil::TextJustificationType)
Collapse All

Overrides the text and justification on the specified text component.

C#
SetTextComponentOverride(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleComponentId,
    ref System::String textOverride,
    Autodesk::Civil::TextJustificationType textJustificationType
);
Visual Basic
Sub SetTextComponentOverride(
    labelStyleComponentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef textOverride As System::String,
    textJustificationType As Autodesk::Civil::TextJustificationType
)
Parameters
Parameters | Description
labelStyleComponentId | The object id of the text component.
textOverride | The override label text.
textJustificationType | The type of text justification.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when labelStyleComponentId is not the objectId of the object that composes the text on the sub-entity label.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties
ICommonLabel Properties
Collapse All

The properties of ICommonLabel are listed here.

Public Properties
Public Property | Description
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the label style id.
Links
Public Properties


ICommonLabel::AnchorInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::AnchorInfo Property
ICommonLabel::AnchorInfo Property
Collapse All

Gets information about the label anchor.

C#
Autodesk::Civil::DatabaseServices::AnchorInfo AnchorInfo;
Visual Basic
Property AnchorInfo() As Autodesk::Civil::DatabaseServices::AnchorInfo
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::AnchorMarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::AnchorMarkerStyleId Property
ICommonLabel::AnchorMarkerStyleId Property
Collapse All

Gets or sets the anchor marker style.

C#
Autodesk::AutoCAD::DatabaseServices::ObjectId AnchorMarkerStyleId;
Visual Basic
Property AnchorMarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when anchor markers are not supported by the label object.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::DimensionAnchorInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::DimensionAnchorInfo Property
ICommonLabel::DimensionAnchorInfo Property
Collapse All

Gets information about the label dimension anchor.

C#
Autodesk::Civil::DatabaseServices::AnchorInfo DimensionAnchorInfo;
Visual Basic
Property DimensionAnchorInfo() As Autodesk::Civil::DatabaseServices::AnchorInfo
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchors are not supported by the label object.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::DimensionAnchorOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::DimensionAnchorOption Property
ICommonLabel::DimensionAnchorOption Property
Collapse All

Gets or sets the dimension anchor option.

C#
Autodesk::Civil::DimensionAnchorOptionType DimensionAnchorOption;
Visual Basic
Property DimensionAnchorOption() As Autodesk::Civil::DimensionAnchorOptionType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchor are not supported by the label object.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::DimensionAnchorValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::DimensionAnchorValue Property
ICommonLabel::DimensionAnchorValue Property
Collapse All

Gets or sets the dimension anchor value.

C#
double DimensionAnchorValue;
Visual Basic
Property DimensionAnchorValue() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchor are not supported by the label object.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::Dragged Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::Dragged Property
ICommonLabel::Dragged Property
Collapse All

Gets a bool value that specifies whether the label has been dragged.

C#
bool Dragged;
Visual Basic
Property Dragged() As bool
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::DraggedOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::DraggedOffset Property
ICommonLabel::DraggedOffset Property
Collapse All

Gets or sets the dragged offset on the sub-entity label.

C#
Autodesk::AutoCAD::Geometry::Vector3d DraggedOffset;
Visual Basic
Property DraggedOffset() As Autodesk::AutoCAD::Geometry::Vector3d
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the label object can't be dragged.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::Flipped Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::Flipped Property
ICommonLabel::Flipped Property
Collapse All

Gets or sets the flipped state of the label.

C#
bool Flipped;
Visual Basic
Property Flipped() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the label object can't be flipped.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::LeaderAttachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::LeaderAttachment Property
ICommonLabel::LeaderAttachment Property
Collapse All

Gets or sets the leader attachment option.

C#
Autodesk::Civil::LeaderAttachmentBehaviorType LeaderAttachment;
Visual Basic
Property LeaderAttachment() As Autodesk::Civil::LeaderAttachmentBehaviorType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when leader attachment options are not supported by the label object.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::LeaderTailVisibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::LeaderTailVisibility Property
ICommonLabel::LeaderTailVisibility Property
Collapse All

Gets or sets the leader tail visibility.

C#
Autodesk::Civil::LeaderTailVisibilityType LeaderTailVisibility;
Visual Basic
Property LeaderTailVisibility() As Autodesk::Civil::LeaderTailVisibilityType
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::LeaderVisibility Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::LeaderVisibility Property
ICommonLabel::LeaderVisibility Property
Collapse All

Gets or sets the leader visibility.

C#
Autodesk::Civil::LeaderVisibilityType LeaderVisibility;
Visual Basic
Property LeaderVisibility() As Autodesk::Civil::LeaderVisibilityType
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::Pinned Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::Pinned Property
ICommonLabel::Pinned Property
Collapse All

Gets or sets the pinned state of the label.

C#
bool Pinned;
Visual Basic
Property Pinned() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when: (1) the label object can't be pinned when setting. (2) the label object is not dragged.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::Reversed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::Reversed Property
ICommonLabel::Reversed Property
Collapse All

Gets or sets the reversed state of the label.

C#
bool Reversed;
Visual Basic
Property Reversed() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the label object can't be reversed.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabel::StyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties > ICommonLabel::StyleId Property
ICommonLabel::StyleId Property
Collapse All

Gets or sets the label style id.

C#
Autodesk::AutoCAD::DatabaseServices::ObjectId StyleId;
Visual Basic
Property StyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style id is invalid.
Links
ICommonLabel Interface, ICommonLabel Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabelOptions Interface

The interface ICommonLabelOptions declares common behavioral options on labels.

Class Hierarchy
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::LabelGroupSubEntity
C#
public interface ICommonLabelOptions;
Visual Basic
Public Interface ICommonLabelOptions
Links
ICommonLabelOptions Properties, ICommonLabelOptions Members, Class Hierarchy


ICommonLabelOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Members
ICommonLabelOptions Members
Collapse All

The following tables list the members exposed by ICommonLabelOptions.

Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
Links
Public Properties


ICommonLabelOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties
ICommonLabelOptions Properties
Collapse All

The properties of ICommonLabelOptions are listed here.

Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
Links
Public Properties


ICommonLabelOptions::AllowsAnchorMarker Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties > ICommonLabelOptions::AllowsAnchorMarker Property
ICommonLabelOptions::AllowsAnchorMarker Property
Collapse All

Gets a boolean value that specifies whether anchor markers are supported by the label object.

C#
bool AllowsAnchorMarker;
Visual Basic
Property AllowsAnchorMarker() As bool
Links
ICommonLabelOptions Interface, ICommonLabelOptions Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabelOptions::AllowsDimensionAnchors Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties > ICommonLabelOptions::AllowsDimensionAnchors Property
ICommonLabelOptions::AllowsDimensionAnchors Property
Collapse All

Gets a boolean value that specifies whether dimension anchors are supported by the label object.

C#
bool AllowsDimensionAnchors;
Visual Basic
Property AllowsDimensionAnchors() As bool
Links
ICommonLabelOptions Interface, ICommonLabelOptions Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabelOptions::AllowsDragging Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties > ICommonLabelOptions::AllowsDragging Property
ICommonLabelOptions::AllowsDragging Property
Collapse All

Gets a boolean value that specifies whether the label object can be dragged.

C#
bool AllowsDragging;
Visual Basic
Property AllowsDragging() As bool
Links
ICommonLabelOptions Interface, ICommonLabelOptions Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabelOptions::AllowsFlipping Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties > ICommonLabelOptions::AllowsFlipping Property
ICommonLabelOptions::AllowsFlipping Property
Collapse All

Gets a boolean value that specifies whether the label object can be flipped.

C#
bool AllowsFlipping;
Visual Basic
Property AllowsFlipping() As bool
Links
ICommonLabelOptions Interface, ICommonLabelOptions Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabelOptions::AllowsLeaderAttachment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties > ICommonLabelOptions::AllowsLeaderAttachment Property
ICommonLabelOptions::AllowsLeaderAttachment Property
Collapse All

Gets a boolean value that specifies whether leader attachment options are supported by the label object.

C#
bool AllowsLeaderAttachment;
Visual Basic
Property AllowsLeaderAttachment() As bool
Links
ICommonLabelOptions Interface, ICommonLabelOptions Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabelOptions::AllowsPinning Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties > ICommonLabelOptions::AllowsPinning Property
ICommonLabelOptions::AllowsPinning Property
Collapse All

Gets a boolean value that specifies whether the label object can be pinned.

C#
bool AllowsPinning;
Visual Basic
Property AllowsPinning() As bool
Links
ICommonLabelOptions Interface, ICommonLabelOptions Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabelOptions::AllowsReversing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties > ICommonLabelOptions::AllowsReversing Property
ICommonLabelOptions::AllowsReversing Property
Collapse All

Gets a boolean value that specifies whether the label object can be reversed.

C#
bool AllowsReversing;
Visual Basic
Property AllowsReversing() As bool
Links
ICommonLabelOptions Interface, ICommonLabelOptions Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabelOptions::DefaultDimensionAnchorOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties > ICommonLabelOptions::DefaultDimensionAnchorOption Property
ICommonLabelOptions::DefaultDimensionAnchorOption Property
Collapse All

Gets or sets the default dimension anchor option.

C#
Autodesk::Civil::DimensionAnchorOptionType DefaultDimensionAnchorOption;
Visual Basic
Property DefaultDimensionAnchorOption() As Autodesk::Civil::DimensionAnchorOptionType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchors are not supported by the label object.
Links
ICommonLabelOptions Interface, ICommonLabelOptions Members, Autodesk::Civil::DatabaseServices Namespace


ICommonLabelOptions::DefaultDimensionAnchorValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties > ICommonLabelOptions::DefaultDimensionAnchorValue Property
ICommonLabelOptions::DefaultDimensionAnchorValue Property
Collapse All

Gets or sets the default anchor value.

C#
double DefaultDimensionAnchorValue;
Visual Basic
Property DefaultDimensionAnchorValue() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when dimension anchors are not supported by the label object.
Links
ICommonLabelOptions Interface, ICommonLabelOptions Members, Autodesk::Civil::DatabaseServices Namespace


Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
LabelType | An enumeration that describes all possible label types that a base label object can be.
Links
Enumerations


Autodesk::Civil::DatabaseServices::LabelType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::DatabaseServices::LabelType Enumeration
Autodesk::Civil::DatabaseServices::LabelType Enumeration
Collapse All

An enumeration that describes all possible label types that a base label object can be.

C#
public enum LabelType {
  Unknown,
  Note,
  General,
  SurfaceContour,
  ParcelFace,
  ParcelSegment,
  AlignmentMajorStation,
  AlignmentMinorStation,
  AlignmentGeometryPoint,
  AlignmentProfileGeometryPoint,
  AlignmentStationEquation,
  AlignmentDesignSpeed,
  AlignmentSuperelevationCriticalPoints,
  AlignmentStationOffset,
  AlignmentTangent,
  AlignmentCurve,
  AlignmentSpiral,
  AlignmentTangentIntersection,
  ProfileMajorStation,
  ProfileMinorStation,
  ProfileHorizontalGeometryPoint,
  ProfileGradeBreaks,
  ProfileLine,
  ProfileCrestCurve,
  ProfileSagCurve,
  ProfileStationElevation,
  ProfileViewDepth,
  ProfileProjection,
  ProfileDataBand,
  VerticalGeometryBand,
  HorizontalGeometryBand,
  SuperElevationBand,
  PipeNetworkBand,
  SectionalDataBand,
  SectionViewOffsetElevation,
  SectionViewDepth,
  SectionProjection,
  SectionMajorOffset,
  SectionMinorOffset,
  SectionGradeBreak,
  SectionSegment,
  SectionDataBand,
  SampleLine,
  Pipe,
  PipeProfile,
  PipeSection,
  StructureLabel,
  StructureProfile,
  StructureSection,
  ViewFrame,
  MatchLine
}
Visual Basic
Public Enum LabelType
  Unknown
  Note
  General
  SurfaceContour
  ParcelFace
  ParcelSegment
  AlignmentMajorStation
  AlignmentMinorStation
  AlignmentGeometryPoint
  AlignmentProfileGeometryPoint
  AlignmentStationEquation
  AlignmentDesignSpeed
  AlignmentSuperelevationCriticalPoints
  AlignmentStationOffset
  AlignmentTangent
  AlignmentCurve
  AlignmentSpiral
  AlignmentTangentIntersection
  ProfileMajorStation
  ProfileMinorStation
  ProfileHorizontalGeometryPoint
  ProfileGradeBreaks
  ProfileLine
  ProfileCrestCurve
  ProfileSagCurve
  ProfileStationElevation
  ProfileViewDepth
  ProfileProjection
  ProfileDataBand
  VerticalGeometryBand
  HorizontalGeometryBand
  SuperElevationBand
  PipeNetworkBand
  SectionalDataBand
  SectionViewOffsetElevation
  SectionViewDepth
  SectionProjection
  SectionMajorOffset
  SectionMinorOffset
  SectionGradeBreak
  SectionSegment
  SectionDataBand
  SampleLine
  Pipe
  PipeProfile
  PipeSection
  StructureLabel
  StructureProfile
  StructureSection
  ViewFrame
  MatchLine
End Enum
Members
Members | Description
Unknown | Unknown
Note | AeccDbNoteLabel
General | AeccDbGeneralLabel
SurfaceContour | AeccDbSurfaceContourLabeling
ParcelFace | AeccDbParcelFaceLabel
ParcelSegment | AeccDbParcelSegmentLabel
AlignmentMajorStation | AeccDbAlignmentStationLabeling
AlignmentMinorStation | AeccDbAlignmentMinorStationLabeling
AlignmentGeometryPoint | AeccDbAlignmentGeomPointLabeling
AlignmentProfileGeometryPoint | AeccDbAlignmentVAGeomPointLabeling
AlignmentStationEquation | AeccDbAlignmentStaEquLabeling
AlignmentDesignSpeed | AeccDbAlignmentDesignSpeedLabeling
AlignmentStationOffset | AeccDbStaOffsetLabel
AlignmentTangent | AeccDbAlignmentTangentLabel
AlignmentCurve | AeccDbAlignmentCurveLabel
AlignmentSpiral | AeccDbAlignmentSpiralLabel
ProfileMajorStation | AeccDbVAlignmentStationLabeling
ProfileMinorStation | AeccDbVAlignmentMinorStationLabeling
ProfileHorizontalGeometryPoint | AeccDbVAlignmentHAGeomPointLabeling
ProfileGradeBreaks | AeccDbVAlignmentPVILabeling
ProfileLine | AeccDbVAlignmentLineLabeling
ProfileCrestCurve | AeccDbVAlignmentCrestCurveLabeling
ProfileSagCurve | AeccDbVAlignmentSagCurveLabeling
ProfileStationElevation | AeccDbStaElevLabel
ProfileViewDepth | AeccDbProfileViewDepthLabel
ProfileProjection | AeccDbProfileProjectionLabel
ProfileDataBand | AeccDbProfileDataBandLabeling
VerticalGeometryBand | AeccDbVerticalGeometryBandLabeling
HorizontalGeometryBand | AeccDbHorizontalGeometryBandLabeling
SuperElevationBand | AeccDbSuperElevationBandLabeling
PipeNetworkBand | AeccDbPipeNetworkBandLabeling
SectionalDataBand | AeccDbSectionalDataBandLabeling
SectionViewOffsetElevation | AeccDbOffsetElevLabel
SectionViewDepth | AeccDbSectionViewDepthLabel
SectionProjection | AeccDbSectionProjectionLabel
SectionMajorOffset | AeccDbSectionOffsetLabeling
SectionMinorOffset | AeccDbSectionMinorOffsetLabeling
SectionGradeBreak | AeccDbSectionGradeBreakLabeling
SectionSegment | AeccDbSectionSegmentLabeling
SectionDataBand | AeccDbSectionDataBandLabeling
SampleLine | AeccDbSampleLineLabeling
Pipe | AeccDbPipeLabel
PipeProfile | AeccDbPipeProfileLabel
PipeSection | AeccDbPipeSectionLabel
StructureLabel | AeccDbStructureLabel
StructureProfile | AeccDbStructureProfileLabel
StructureSection | AeccDbStructureSectionLabel
ViewFrame | AeccDbViewFrameLabeling
MatchLine | AeccDbMatchLineLabeling


Autodesk::Civil::Land Namespace

The Autodesk::Civil::Land namespace.

Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::Land::DatabaseServices namespace.
Settings | The Autodesk::Civil::Land::Settings namespace.
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
AlignmentDesignCheck | The Alignment design check class.
AlignmentDesignCheckCollection | The AlignmentDesignCheckCollection class.
AlignmentDesignCheckRoot | The AlignmentDesignCheckRoot class.
GeometryPointLabelOption | This class controls the selection state of a point type. The class is implemented as a generic that can be... more
GeometryPointSelector | This class encapsulates the functionality to allow selecting and un-selecting point types.
ProfileDesignCheck | The Profile design check class.
ProfileDesignCheckCollection | The ProfileDesignCheckCollection class.
ProfileDesignCheckRoot | The ProfileDesignCheckRoot class.
Structs, Records, Enums
Struct, Record, Enum | Description
AlignmentDesignCheckType | Specifies the kind of alignment design check.
BreaklineElevationType |
CatchmentWatershedObjectType |
CrossSectionShapeType | Specifies cross section shapes.
DesignSpeedLookupMethodType | Specifies design speed lookup methods.
ElevationSourceType |
ElevationToUseType | An enumeration that defines the elevation to use for the crossing breaklines.
FeatureLineLayerSettingType | Defines the layer setting type.
FeatureLineLayerType |
FreeHaulDisplayType | An enumeration that defines how to show the free haul in the graph.
GradingDistanceProjectionType | An enumeration that defines the type of projection for the Distance target.
GradingElevationProjectionType | An enumeration that defines the type of projection for the Elevation target.
GradingInteriorCornerOverlapSolutionType | An enumeration that defines how interior corner projections are cleaned up when the footprint corner has different elevations.
GradingRelativeElevationProjectionType | An enumeration that defines the type of projection for the Relative Elevation target.
GradingSearchOrderType | An enumeration that defines the secarch order for the grading.
GradingSlopeFormatType | An enumeration that defines the target method for the grading
GradingSurfaceProjectionType | An enumeration that defines the type of projection for the Surface target.
GradingTargetType | An enumeration that defines the target method for the grading
HighsideLocationType | Specifies whether to drop leading zeros.
MapcheckDefaultAngleType |
MapcheckDefaultCurveDirectionType |
MapcheckDefaultCurveTraverseMethodType |
MapcheckDefaultSideType |
MassHaulLineDisplayStyleType | An enumeration that defines MassHaulLineStye display style type.
MassHaulLineHatchDisplayStyleType | An enumeration that defines MassHaulLineStye hatch display style type.
MassHaulViewDisplayStyleType | An enumeration that defines masshaul view components type.
MatchLineLabelLocationType | The Autodesk::Civil::Land::MatchLineLabelLocationType enumeration.
ParcelAnalysisType |
ParcelRemainderDistributionType | Defines the parcel remainder distribution type.
ParcelSelectionType | Defines the parcel selection type.
ParcelSolutionType | Defines the parcel solution type.
PipeNetworkPartDisplayType | The Autodesk::Civil::Land::PipeNetworkPartDisplayType enumeration.
PlanViewAlignType |
PointNamesExistType | Specifies how to resolve existing point names on import.
PointNumbersAssignedType | Specifies how to assign point numbers.
PointNumbersExistType | Specifies how to resolve conflicting point numbers.
PointNumbersSuppliedType | Specifies how to number supplied point numbers.
ProfileApplyCurveType | The Autodesk::Civil::Land::ProfileApplyCurveType enumeration.
ProfileCircularVerticalConstraintType |
ProfileCurveType |
ProfileDesignCheckType | Specifies the kind of Profile design check.
ProfileParabolicVerticalConstraintType |
ProfileViewDatumType | #UI Remove public enum class PointCreationPromptType { }; /PROPERTYENUM(PointCreationPrompt);
ProfileViewDisplayNetworkPartsType |
ProfileViewPlotType |
ProfileViewSplitDatumType |
ProfileViewSplitStationType |
ProfileViewStartCornerType |
RadiusLookupMethodType |
RemainderDistributionType |
SectionViewElevationRangeType | Specifies section view elevation ranges.
SheetCreateType |
SheetSetType |
ShoulderMethodType | Specifies shoulder methods.
SlopePatternLengthType | An enumeration that defines the slope pattern length type.
SlopePatternOffsetType | An enumeration that defines the slope pattern offset type.
SlopePatternStartType | An enumeration that defines the slope pattern start type.
SlopePatternSymbolType | An enumeration that defines the slope pattern symbol type.
SuperelevationCorridorType | Specifies superelevation corridor types.
SuperelevationStationRoundingType |
SurfaceBoundaryType | Defines the boundary type.
SurfaceRegionOptionsType |
SurfaceSimplifyType |
SurfaceType |
ViewFrameAngleType |
ViewFrameLabelLocationType | The Autodesk::Civil::Land::ViewFrameLabelLocationType enumeration.
WaterdropObjectType |
Links
Namespaces, Topics, Classes, Structs, Records, Enums


Autodesk::Civil::Land::DatabaseServices Namespace

The Autodesk::Civil::Land::DatabaseServices namespace.

Namespaces
Namespace | Description
Styles | The Autodesk::Civil::Land::DatabaseServices::Styles namespace.
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
Alignment | The Alignment class. Alignment objects can represent centerlines, lanes, shoulders, right-of-ways, or construction baselines.
AlignmentArc | The AlignmentArc class. AlignmentArc derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single AlignmentSubEntityArc... more
AlignmentCurve | The AlignmentCurve class. This is an abstract base class for other Alignment Entity classes, such as AlignmentArc, AlignmentSCS,... more
AlignmentCurveLabel | This class represents an alignment curve label.
AlignmentDesignSpeedLabelGroup | This class represents an alignment design speed label group.
AlignmentEntity | The AlignmentEntity class. This is an abstract class from which AlignmentCurve inherits.
AlignmentEntityCollection | The AlignmentEntity collection class. This class represents the collection of all AlignmentEntity objects that belong to an Alignment.
AlignmentGeometryPointLabelGroup | This class encapsulates the functionality to label a geometry point group in an alignment.
AlignmentLabelGroup | This class represents an alignment label group.
AlignmentLine | The AlignmentLine class. This class represents an AlignmentEntity made up of a single line subentity.
AlignmentMinorStationLabelGroup | This class represents an alignment minor station label group.
AlignmentPILabel | This class represents an alignment tangent intersection label.
AlignmentPILabelGroup |
AlignmentRegion | Represents a segment of an alignment which uses a single assembly.
AlignmentRegionCollection | A collection of AlignmentRegion objects.
AlignmentSCS | The Alignment SpiralCurveSpiral class. This class represents an AlignmentEntity made up of an in spiral subentity, an arc subentity, and... more
AlignmentSCSCS | The Alignment SpiralCurveSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an... more
AlignmentSCSSCS | The Alignment SpiralCurveSpiralSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an... more
AlignmentSpiral | The AlignmentSpiral Class. AlignmentSpiral derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single spiral... more
AlignmentSpiralLabel | This class represents an alignment spiral label.
AlignmentSSCSS | The Alignment SpiralSpiralCurveSpiralSpiral class. This class represents an AlignmentEntity made up of the following subentities: spiral, spiral, arc, spiral, spiral.... more
AlignmentStationEquationLabelGroup | This class represents an alignment station equation label group.
AlignmentStationLabelGroup | This class represents an alignment station label group.
AlignmentSTS | The Alignment SpiralTangentSpiral class. This class represents an AlignmentEntity made up of a spiral, then tangent, then spiral subentities.
AlignmentSubEntity | The alignment subentity class. This class represents the basic drawing components that make up an alignment entity.
AlignmentSubEntityArc | The Alignment arc subentity class.
AlignmentSubEntityLine | The AlignmentSubEntityLine class. This class represents the line object in AlignmentEntity objects.
AlignmentSubEntitySpiral | The Alignment spiral subentity class. This class represents spiral object in AlignmentEntity objects.
AlignmentSuperelevationLabelGroup | This class encapsulates the functionality of an alignment super-elevation group label.
AlignmentTable | The AlignmentTable class.
AlignmentTangentLabel | This class represents an alignment tangent label.
AlignmentVerticalGeometryPointLabelGroup | This class represents an alignment vertical geometry point label group.
DesignSpeed | The Alignment DesignSpeed class. Specifies a single design speed used for criteria-based Alignment design.
DesignSpeedCollection | A collection of DesignSpeed objects.
FeatureLine | A feature line is a connected series of points along a corridor created by joining those points from each assembly... more
Grading | The Grading class.
GridSurface | A surface formed from points that lie on a regular grid.
MassHaulLine | A line that displays free haul and overhaul volumes in a mass haul view..
MassHaulView | A mass haul diagram view.
MatchLine | A match line is a straight line that indicate locations in a view frame group where one view frame intersects... more
MaterialSection | The AeccDbMaterialSection wrapper.
Parcel | An object that represents real estate parcels, such as lots in a subdivision, and other features that have closed boundaries... more
ParcelSegment | A parcel segment is a line segment, arc, or AutoCAD entity within a site. When parcel segments form a closed... more
ParcelSegmentTable | A Table associated with a ParcelSegment.
ParcelTable | A table associated with a Parcel.
PointEntity | Encapsulates a COGO point object, with associated information such as elevation, marker display styles, etc.
PointTable | The AeccDbPointScheduleTable wrapper.
PolylineOptions | The PolylineOptions class. This class specifies the options for creating an Alignment using a polyline.
Profile | A record of elevation against distance along a horizontal Alignment or other line. Profiles are used to visualize the terrain... more
ProfileBandLabelGroup | The AeccDbProfileBandLabeling wrapper.
ProfileCircular | The ProfileCircular class. This class represents an ProfileEntity made up of a circular curve.
ProfileCriteria | Critera used by the criteria-based design feature to apply agency-specific standards to a profile.
ProfileCriteriaCollection | The ProfileCriteria collection class represents the collection of all criteria in the hatch area.
ProfileEntity | The abstract class of profile entity. ProfileEntity has four derived classes: ProfileLine, ProfileAsymmetric, ProfileCircular, and ProfileParabolic.
ProfileEntityCollection | The ProfileEntity collection class. This class represents the collection of all ProfileEntity objects that belong to the Profile.
ProfileHatchArea | The ProfilevHatchArea class.
ProfileHatchAreaCollection | The ProfileHatchAreaCollection class represents the collection of all hatch areas in the ProfileView.
ProfileOverride | Object used to change the style or label set for a profile.
ProfileOverrideCollection | The ProfileOverride collection class represents the collection of all profiles listed in the ProfileView.
ProfileParabolaAsymmetric | The ProfileParabolaAsymmetric class. This class represents an ProfileEntity made up of a asymmetric parabola.
ProfileParabolaSymmetric | This class represents an ProfileEntity made up of a symmetric parabola.
ProfileProjection | The AeccDbProfileProjection class.
ProfilePVI | In a profile, the point where the lines formed by two tangent entities meet, whether the entities meet or not... more
ProfilePVICollection | The ProfilePVI collection class represents the collection of all ProfilePVI objects that belong to an Profile.
ProfileTangent | This class represents an ProfileEntity made up of a single tangent.
ProfileView | Manages the graphic display of profile data objects within a drawing. A ProfileView is used to display one or more... more
ProfileViewSplitData | This class represents a split location.
ProfileViewSplitDataCollection | The class provides a collection for the profile view split data.
SampleLine | Lines used for obtaining elevational information from an existing terrain model or surface for creating profiles and cross sections.
SampleLineGroup | Controls a set of related sample lines, the surfaces they sample, and methods for creating cross sections.
SCSCSConstraints | The SCSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Curve-Spiral (AlignmentSCSCS) compound Alignment entities.
SCSSCSConstraints | The SCSSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Spiral-Curve-Spiral (AlignmentSCSSCS) compound Alignment entities.
Section | Provides views created at a 90 degree angle to a surface or an alignment.
SectionBandLabelGroup | A group of section band labels.
SectionProjection | AutoCAD or AutoCAD Civil 3D objects projected from plan view into a section view.
SectionView | Used to display cross sectional data for both existing and finished ground along a sampled cross section line at any... more
Sheet | A sheet (construction document) object.
Site | The construction site abstraction containing parcels and alignments. Note: Alignments are generally associated with a site. An alignment interacts with... more
Station | The Alignment Station class.
StationEquation | Represents a particular system of renumbering or reordering stations within a portion of an alignment.
StationEquationCollection | A collection of StationEquation objects.
StationOffsetLabel | This class represents a station offset label.
SuperElevationData | The SuperelevationData class. This class is a collection of SuperelevationDataElement objects for an Alignment.
SuperElevationDataElement | Superelevation data element at a particular station.
Surface | The base class for TIN and grid surfaces. A surface is a three-dimensional geometric representation of the surface (TIN or... more
TinSurface | A Triangular Irregular Network (TIN) surface, from points connected together in triangles, and used to interpolate for contours, and to... more
ViewFrame | View frames are rectangular-shaped regions along an alignment that define an area that will be displayed in a sheet.
ViewFrameGroup | Manages a single group of view frames that are displaying consecutive station ranges along the same alignment.
Structs, Records, Enums
Struct, Record, Enum | Description
AlignmentArcConstraintType | Defines the underlying alignment arc entity constraint type. For example, three points, or center radius
AlignmentCreationType | The Autodesk::Civil::Land::DatabaseServices::AlignmentCreationType enumeration.
AlignmentEntityConstraintType | Specifies the underlying alignment entity constraint type.
AlignmentEntityType | Specifies the underlying entity type, for example, tangent, arc, spiral, etc.
AlignmentGeometryPointStationType | Defines types of Stations at geometry points on an alignment.
AlignmentLineConstraintType | Defines the underlying line entity constraint type. For example, two points, or through point.
AlignmentRegionType | Defines alignment regions.
AlignmentSCSConstraintType | Defines the underlying Spiral-Curve-Spiral entity constraint type.
AlignmentSCSCSConstraintType | Defines the underlying Spiral-Curve-Spiral-Curve-Spiral entity constraint type.
AlignmentSCSSCSConstraintType | Defines the underlying Spiral-Curve-Spiral-Spiral-Curve-Spiral entity constraint type.
AlignmentSide | Alignment side enumeration. This enum is used by DistanceToAlignment() to specify on which side of the Alignment to look for... more
AlignmentSpiralConstraintType | Defines the underlying spiral entity constraint type. For example, spiral in radius spiral out, spiral length radius pass point.
AlignmentSSCSSConstraintType | Defines the underlying Spiral-Spiral-Curve-SpiralSpiral entity constraint type.
AlignmentSTSConstraintType | Defines the underlying Spiral-Line-Spiral entity constraint type.
AlignmentSubEntityType | Specifies the sub-entity type, for example, line, arc, spiral, etc.
AlignmentType | The Autodesk::Civil::Land::DatabaseServices::AlignmentType enumeration.
AlignmentUpdateType | The Autodesk::Civil::Land::DatabaseServices::AlignmentUpdateType enumeration.
CurveParamType | Defines the free curve type.
CurveType | Defines the free curve type.
DatumRoundingType | Specifies where to round the vertical split location.
ElevationRangeType | Defines the ways to specify the vertical range of the profile view.
EntityAttachType | Defines the type to attach the entity.
EntityVerticalConstraintType | Specifies the construction constraint type of ProfileEntity, for example, use PassThroughPt1AndPt2 if you create this entity by two fixed... more
HatchCriteriaBoundaryType | Defines the hatch criteria's boundary type.
ProfileEntityConstraintType | Specifies the connection constraint type of ProfileEntity, including fixed(attached to none entity), float(attached to one entity) and free(attached to... more
ProfileEntityType | Specifies the underlying ProfileEntity type, including tangent, circular, symmetric parabola and asymmetric parabola.
ProfileType | Defines the profile type.
ProfileUpdateType | Defines the profile's update mode.
RegionPropertyType | The Autodesk::Civil::Land::DatabaseServices::RegionPropertyType enumeration.
SpiralCurveType | Defines the curve type for a spiral sub-entity.
SpiralDirectionType | Defines the direction of a spiral sub-entity.
SpiralParamType | Defines the type to attch the entity.
SplitStationType | Defines the ways to split profile view.
StationEquationType | Specifies the kind of StationEquation.
StationRangeType | Defines the ways to specify the horizontal range of the profile view.
StationRoundingType | Specifies where to round the horizontal split location.
StationTypes | Defines the possible station types, used by Alignment::GetStationSet().
SubEntityExtensionType | Specifies sub-entity extension type.
SuperElevationCrossSegmentType | Specifies the type of a SuperElevationDataElement cross segment.
SuperElevationTransitionPointType | Specifies the type of a SuperElevationDataElement transition point.
VerticalCurveType | Specifies the geometry type of a ProfileEntity curve, used for three types of parabolic entities.
Links
Namespaces, Topics, Classes, Structs, Records, Enums


Autodesk::Civil::Land::DatabaseServices::Styles Namespace

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Collapse All

The Autodesk::Civil::Land::DatabaseServices::Styles namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
AlignmentDesignCheckSet | A collection of alignment design checks, which can be applied to an alignment.
AlignmentDesignCheckSetCollection | The AlignmentDesignCheckSetCollection class.
AlignmentStyle | Specifies properties for the various alignment components.
AlignmentStyleCollection | A collection of AlignmentStyle objects.
ArrowHeadOption | Display options for arrows in AlignmentStyle and ProfileStyle.
BuildingSiteStyle | Display options for building site objects.
BuildingSiteStyleCollection | A collection of BuildingSiteStyle objects.
ContourValues | Defines how to display major and minor contour lines; used by the SurfaceContourStyle class.
GradingCriteria | Specifies grading criteria (a projection method and target) to create a finished grading surface.
GradingCriteriaCollection | A collection of GradingCriteria objects.
GradingCriteriaSet | A set of multiple related GradingCriteria objects.
GradingCriteriaSetCollection | A collection of GradingCriteriaSet objects.
GradingStyle | Specifies default display and other characteristics for grading features when they are created.
GradingStyleCollection | A collection of GradingStyle objects.
GroupPlotStyle | Specifies section view group plot style settings.
GroupPlotStyleCollection | A collection of GroupPlotStyle objects.
HorizontalGeometryBandStyle | The style object specifying characteristics for profile view horizontal geometry data bands.
LabelStylesAlignmentRoot | All Alignment-related label styles. These styles control the label display for alignment components, such as major and minor stations,... more
LabelStylesMatchLineRoot | All styles associated with match line labels.
LabelStylesProfileRoot | LabelStylesProfileRoot
MassHaulLineStyle | The view frame style wrapper class.
MassHaulLineStyleCollection | The MassHaulLineStyleCollection class.
MassHaulViewStyle | The view frame style wrapper class.
MassHaulViewStyleCollection | The MassHaulViewStyleCollection class.
MatchLineStyle | The match line style wrapper class.
ParcelStyle | The parcel style wrapper class.
PointStyle | The point style class.
ProfileDataBandStyle | The profile data band style wrapper class.
ProfileDesignCheckSet | A collection of profile design checks, which can be applied to an alignment.
ProfileDesignCheckSetCollection | The AlignmentStyleCollection class.
ProfileLabelSetStyle | The profile lable set wrapper class.
ProfileStyle | The profile style wrapper class.
ProfileViewBandSetItem | The profile view band set item wrapper class.
ProfileViewBandSetStyle | A collection of ProfileViewBandSetItemCollection objects for profile view band set styles.
ProfileViewStyle | The profile view style wrapper class.
ProfileViewStyleCollection | The ProfileViewStyleCollection class.
SampleLineStyle | Specifies display properties for the sample lines used to obtain elevational information from an existing terrain model or surface.
SectionalDataBandStyle | The section data band style wrapper class.
SectionDataBandStyle | The section data band style wrapper class.
SectionSegmentBandStyle | The section data band style wrapper class.
SectionStyle | Specifies display characteristics and associated information for cross sections and their constituent components.
SectionViewBandSetItem | Encapsulates a single section view data band.
SectionViewBandSetItemCollection | The SectionViewBandSetItemCollectione wrapper class.
SectionViewBandSetStyle | The SectionViewBandSetStyle wrapper class.
SectionViewStyle | The section view style wrapper class.
SheetStyle | The sheet plot style applied when plot by page is selected.
SlopePatternComponent | Encapsulates the properties of slope pattern components used to make up a SlopePatternStyle.
SlopePatternLine | Defines a line used in a SlopePatternComponent.
SlopePatternLineOffset | Defines the offset of lines in a SlopePatternComponent.
SlopePatternLineSymbol | Defines the symbol used with a SlopePatternComponent.
SlopePatternStyle | A style that defines the pattern that represents a slope in a grading style.
SlopePatternStyleCollection | The SlopePatternStyleCollection class.
SuperelevationDataBandStyle | The super elevation data band style wrapper class.
SurfaceBaseStyle | The surface base style class
SurfaceContourStyle | The surface boundary style class
SurfaceDirectionStyle | The surface boundary style class
SurfaceElevationStyle | The surface boundary style class
SurfacePointStyle | The SurfacePointStyle class.
SurfaceSlopeArrowStyle | The SurfaceSlopeArrowStyle class.
SurfaceSlopeStyle | The SurfaceSlopeStyle class.
SurfaceStyle | The surface style class.
VerticalGeometryBandStyle | The vertical geometry band style wrapper class.
ViewFrameStyle | The view frame style wrapper class.
Structs, Records, Enums
Struct, Record, Enum | Description
AlignmentDisplayStyleType | Defines AlignmentStyle display style type.
BuildingSiteDisplayStyleType | An enumeration that defines BuildingSiteStyle display style type.
CenterMarkerSizeType | Defines grading style center marker size type.
ColorSchemeType | Defines color scheme type
ContourSmoothingType | Defines how surface contours are smoothed.
GradingDisplayStyleType | Defines grading display style type.
GroupPlotAlignType | Specifies how the section views are aligned.
GroupPlotAreaType | An enumeration that specify the method of plotting section views (either all or by page).
GroupPlotCellSizeType | Specifies how the size of each cell in the array will be determined.
GroupPlotStartCornerType | Specifies the starting corner for plotting the section views.
HorizontalGeometryDisplayStyleType | Defines HorizontalGeometryBandStyle display style type.
ParcelDisplayStyleType | Defines ParcelStyle display style type.
PointDisplay3dType | Specifies how point elevation is displayed.
PointDisplayStyleType | An enumeration that defines PointStyle display style type.
PointMarkerDisplayType | Specifies the kind of marker to use, any of: point, custom, or symbol.
PointSymbolType | Defines the symbology of the point display.
PrecisionRangeType | Defines range precision for some surface styles.
ProfileDataDisplayStyleType | Defines ProfileDataBandStyle display style type.
ProfileDesignCheckCurveType | Design check curve type.
ProfileDisplayStyleProfileType | Defines ProfileStyle display style type.
ProfileViewDisplayStyleType | Defines profile view components type.
SampleLineDisplayStyleType | Defines SampleLineStyle display style type.
ScaleType | Defines how to scale the point marker.
SchematicLineOption | Defines HorizontalGeometryBandStyle schematic line option.
SectionalDataDisplayStyleType | Defines SectionalDataBandStyle display style type.
SectionDataDisplayStyleType | Defines SectionDataBandStyle display style type.
SectionDisplayStyleSectionType | Defines SectionStyle display style type.
SectionSegmentDisplayStyleType | Defines SectionSegmentBandStyle display style type.
SectionViewDisplayStyleType | Defines section view components type.
SectionViewPlotRuleType | Specifies whether to plot the section views by rows or columns.
SheetDisplayStyleType | Defines SheetStyle display style type.
SlopeArrowType | Defines the head style of ArrowType
SuperelevationDataDisplayStyleType | Defines SuperelevationDataBandStyle display style type.
SurfaceDisplay3dType | Defines how to display surface style, whether it is exaggerated, flattened, or displayed at actual elevation levels.
SurfaceDisplayStyleType | Defines surface display style type.
SurfaceDisplayType | Defines how surface objects are to be displayed/rendered.
SurfaceGroupValuesByType | Defines how values are grouped.
VerticalGeometryDisplayStyleType | Defines VerticalGeometryBandStyle display style type.
Links
Topics, Classes, Structs, Records, Enums


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes
Classes
Collapse All

The following table lists classes in this documentation.

Classes
Class | Description
AlignmentDesignCheckSet | A collection of alignment design checks, which can be applied to an alignment.
AlignmentDesignCheckSetCollection | The AlignmentDesignCheckSetCollection class.
AlignmentStyle | Specifies properties for the various alignment components.
AlignmentStyleCollection | A collection of AlignmentStyle objects.
ArrowHeadOption | Display options for arrows in AlignmentStyle and ProfileStyle.
BuildingSiteStyle | Display options for building site objects.
BuildingSiteStyleCollection | A collection of BuildingSiteStyle objects.
ContourValues | Defines how to display major and minor contour lines; used by the SurfaceContourStyle class.
GradingCriteria | Specifies grading criteria (a projection method and target) to create a finished grading surface.
GradingCriteriaCollection | A collection of GradingCriteria objects.
GradingCriteriaSet | A set of multiple related GradingCriteria objects.
GradingCriteriaSetCollection | A collection of GradingCriteriaSet objects.
GradingStyle | Specifies default display and other characteristics for grading features when they are created.
GradingStyleCollection | A collection of GradingStyle objects.
GroupPlotStyle | Specifies section view group plot style settings.
GroupPlotStyleCollection | A collection of GroupPlotStyle objects.
HorizontalGeometryBandStyle | The style object specifying characteristics for profile view horizontal geometry data bands.
LabelStylesAlignmentRoot | All Alignment-related label styles. These styles control the label display for alignment components, such as major and minor stations,... more
LabelStylesMatchLineRoot | All styles associated with match line labels.
LabelStylesProfileRoot | LabelStylesProfileRoot
MassHaulLineStyle | The view frame style wrapper class.
MassHaulLineStyleCollection | The MassHaulLineStyleCollection class.
MassHaulViewStyle | The view frame style wrapper class.
MassHaulViewStyleCollection | The MassHaulViewStyleCollection class.
MatchLineStyle | The match line style wrapper class.
ParcelStyle | The parcel style wrapper class.
PointStyle | The point style class.
ProfileDataBandStyle | The profile data band style wrapper class.
ProfileDesignCheckSet | A collection of profile design checks, which can be applied to an alignment.
ProfileDesignCheckSetCollection | The AlignmentStyleCollection class.
ProfileLabelSetStyle | The profile lable set wrapper class.
ProfileStyle | The profile style wrapper class.
ProfileViewBandSetItem | The profile view band set item wrapper class.
ProfileViewBandSetStyle | A collection of ProfileViewBandSetItemCollection objects for profile view band set styles.
ProfileViewStyle | The profile view style wrapper class.
ProfileViewStyleCollection | The ProfileViewStyleCollection class.
SampleLineStyle | Specifies display properties for the sample lines used to obtain elevational information from an existing terrain model or surface.
SectionalDataBandStyle | The section data band style wrapper class.
SectionDataBandStyle | The section data band style wrapper class.
SectionSegmentBandStyle | The section data band style wrapper class.
SectionStyle | Specifies display characteristics and associated information for cross sections and their constituent components.
SectionViewBandSetItem | Encapsulates a single section view data band.
SectionViewBandSetItemCollection | The SectionViewBandSetItemCollectione wrapper class.
SectionViewBandSetStyle | The SectionViewBandSetStyle wrapper class.
SectionViewStyle | The section view style wrapper class.
SheetStyle | The sheet plot style applied when plot by page is selected.
SlopePatternComponent | Encapsulates the properties of slope pattern components used to make up a SlopePatternStyle.
SlopePatternLine | Defines a line used in a SlopePatternComponent.
SlopePatternLineOffset | Defines the offset of lines in a SlopePatternComponent.
SlopePatternLineSymbol | Defines the symbol used with a SlopePatternComponent.
SlopePatternStyle | A style that defines the pattern that represents a slope in a grading style.
SlopePatternStyleCollection | The SlopePatternStyleCollection class.
SuperelevationDataBandStyle | The super elevation data band style wrapper class.
SurfaceBaseStyle | The surface base style class
SurfaceContourStyle | The surface boundary style class
SurfaceDirectionStyle | The surface boundary style class
SurfaceElevationStyle | The surface boundary style class
SurfacePointStyle | The SurfacePointStyle class.
SurfaceSlopeArrowStyle | The SurfaceSlopeArrowStyle class.
SurfaceSlopeStyle | The SurfaceSlopeStyle class.
SurfaceStyle | The surface style class.
VerticalGeometryBandStyle | The vertical geometry band style wrapper class.
ViewFrameStyle | The view frame style wrapper class.
Links
Classes


AlignmentDesignCheckSet Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class
AlignmentDesignCheckSet Class
Collapse All

A collection of alignment design checks, which can be applied to an alignment.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSet
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSet
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentDesignCheckSet"))]
public class AlignmentDesignCheckSet : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentDesignCheckSet"))>
Public Class AlignmentDesignCheckSet
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
AlignmentDesignCheckSet Methods, AlignmentDesignCheckSet Members, Class Hierarchy


AlignmentDesignCheckSet Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Members
AlignmentDesignCheckSet Members
Collapse All

The following tables list the members exposed by AlignmentDesignCheckSet.

Public Methods
Public Method | Description
AddDesignCheck | Add one design check into this AlignmentDesignCheckSet.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetAllDesignChecks | Gets all design checks in this AlignmentDesignCheckSet.
RemoveAllDesignCheck | Remove all design checks from this AlignmentDesignCheckSet.
RemoveDesignCheck | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


AlignmentDesignCheckSet Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Methods
AlignmentDesignCheckSet Methods
Collapse All

The methods of AlignmentDesignCheckSet are listed here.

Public Methods
Public Method | Description
AddDesignCheck | Add one design check into this AlignmentDesignCheckSet.
GetAllDesignChecks | Gets all design checks in this AlignmentDesignCheckSet.
RemoveAllDesignCheck | Remove all design checks from this AlignmentDesignCheckSet.
RemoveDesignCheck | Overloaded
Links
Public Methods


AlignmentDesignCheckSet::AddDesignCheck Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Methods > AlignmentDesignCheckSet::AddDesignCheck Method
AlignmentDesignCheckSet::AddDesignCheck Method
Collapse All

Add one design check into this AlignmentDesignCheckSet.

C#
public AlignmentDesignCheck AddDesignCheck(
    AlignmentDesignCheckType type,
    ref System::String name
);
Visual Basic
Public Function AddDesignCheck(
    type As AlignmentDesignCheckType,
    ByRef name As System::String
) As AlignmentDesignCheck
Parameters
Parameters | Description
type | The type of design check.
name | The name of design check.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when: 1: The specified design check has been added; 2: The specified design check is not exist.
Links
AlignmentDesignCheckSet Class, AlignmentDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentDesignCheckSet::GetAllDesignChecks Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Methods > AlignmentDesignCheckSet::GetAllDesignChecks Method
AlignmentDesignCheckSet::GetAllDesignChecks Method
Collapse All

Gets all design checks in this AlignmentDesignCheckSet.

C#
public array<AlignmentDesignCheck^> GetAllDesignChecks();
Visual Basic
Public Function GetAllDesignChecks() As array<AlignmentDesignCheck^>
Links
AlignmentDesignCheckSet Class, AlignmentDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentDesignCheckSet::RemoveAllDesignCheck Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Methods > AlignmentDesignCheckSet::RemoveAllDesignCheck Method
AlignmentDesignCheckSet::RemoveAllDesignCheck Method
Collapse All

Remove all design checks from this AlignmentDesignCheckSet.

C#
public RemoveAllDesignCheck();
Visual Basic
Public Sub RemoveAllDesignCheck()
Links
AlignmentDesignCheckSet Class, AlignmentDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


RemoveDesignCheck Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Methods > RemoveDesignCheck Method
RemoveDesignCheck Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentDesignCheckSet::RemoveDesignCheck (AlignmentDesignCheck^) | Remove one design check from this AlignmentDesignCheckSet.
AlignmentDesignCheckSet::RemoveDesignCheck (AlignmentDesignCheckType, System::String^) | Remove one design check from this AlignmentDesignCheckSet.


AlignmentDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheckType, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Methods > RemoveDesignCheck Method > AlignmentDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheckType, System::String^)
AlignmentDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheckType, System::String^)
Collapse All

Remove one design check from this AlignmentDesignCheckSet.

C#
public RemoveDesignCheck(
    AlignmentDesignCheckType type,
    ref System::String name
);
Visual Basic
Public Sub RemoveDesignCheck(
    type As AlignmentDesignCheckType,
    ByRef name As System::String
)
Parameters
Parameters | Description
type | The type of design check.
name | The name of design check.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified design check is not exist.
Links
AlignmentDesignCheckSet Class, AlignmentDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheck^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Methods > RemoveDesignCheck Method > AlignmentDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheck^)
AlignmentDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheck^)
Collapse All

Remove one design check from this AlignmentDesignCheckSet.

C#
public RemoveDesignCheck(
    ref AlignmentDesignCheck designCheck
);
Visual Basic
Public Sub RemoveDesignCheck(
    ByRef designCheck As AlignmentDesignCheck
)
Parameters
Parameters | Description
designCheck | The design check needed to be removed.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified design check is not exist.
Links
AlignmentDesignCheckSet Class, AlignmentDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentDesignCheckSetCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class
AlignmentDesignCheckSetCollection Class
Collapse All

The AlignmentDesignCheckSetCollection class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSetCollection
C#
public class AlignmentDesignCheckSetCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class AlignmentDesignCheckSetCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
AlignmentDesignCheckSetCollection Methods, AlignmentDesignCheckSetCollection Members, Class Hierarchy


AlignmentDesignCheckSetCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class > AlignmentDesignCheckSetCollection Members
AlignmentDesignCheckSetCollection Members
Collapse All

The following tables list the members exposed by AlignmentDesignCheckSetCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


AlignmentDesignCheckSetCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class > AlignmentDesignCheckSetCollection Methods
AlignmentDesignCheckSetCollection Methods
Collapse All

The methods of AlignmentDesignCheckSetCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


AlignmentDesignCheckSetCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class > AlignmentDesignCheckSetCollection Methods > AlignmentDesignCheckSetCollection::Add Method
AlignmentDesignCheckSetCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
AlignmentDesignCheckSetCollection Class, AlignmentDesignCheckSetCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class
AlignmentStyle Class
Collapse All

Specifies properties for the various alignment components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentStyle"))]
public class AlignmentStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentStyle"))>
Public Class AlignmentStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
AlignmentStyle Methods, AlignmentStyle Properties, AlignmentStyle Members, Class Hierarchy


AlignmentStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Members
AlignmentStyle Members
Collapse All

The following tables list the members exposed by AlignmentStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the Alignment component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the Alignment component.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies the line marker in section display properties for the Alignment component.
GetLineMarkerDisplayStyleSection | Gets the display style for line markers in section view orientation.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
ArrowHeadOption | Gets the alignment arrow head option.
BeginPointMarkerStyle | Gets or sets the marker style object id for 'begin of alignment' points on the alignment.
CompoundCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'compound curve intersection' points on the alignment.
CreateBy | Gets or Sets the "Created by" string for the style.
CurveLineIntersectPointMarkerStyle | Gets or sets the marker style object id for 'curve line intersection' points on the alignment.
CurveSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'curve spiral intersection' points on the alignment.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
EnableRadiusSnap | Gets or sets the boolean value that specifies whether to enable snapping when changing the curve radius value.
EndPointMarkerStyle | Gets or sets the marker style object id for 'end of alignment' points on the alignment.
IntersectionPointMarkerStyle | Gets or sets the marker style object id for 'point of intersection' points on the alignment.
LineCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'line curve intersection' points on the alignment.
LineMarkerDisplayStyleSection | Gets the display style for line markers in section view orientation.
LineSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'line spiral intersection' points on the alignment.
MidPointMarkerStyle | Gets or sets the marker style object id for mid points on the alignment.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RadiusSnapValue | Gets or sets the even increment value by which a curve radius can change using snapping.
ReverseCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'reverse curve intersection' points on the alignment.
ReverseSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'reverse spiral intersection' points on the alignment.
SpiralCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral curve intersection' points on the alignment.
SpiralLineIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral line intersection' points on the alignment.
SpiralSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral spiral intersection' points on the alignment.
StationReferencePointMarkerStyle | Gets or sets the marker style object id for 'station reference' points on the alignment.
ThroughPointMarkerStyle | Gets or sets the marker style object id for 'through points' on the alignment.
Links
Public Methods, Public Properties


AlignmentStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Methods
AlignmentStyle Methods
Collapse All

The methods of AlignmentStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the Alignment component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the Alignment component.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies the line marker in section display properties for the Alignment component.
GetLineMarkerDisplayStyleSection | Gets the display style for line markers in section view orientation.
Links
Public Methods


AlignmentStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Methods > AlignmentStyle::GetDisplayStyleModel Method
AlignmentStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies model display properties for the Alignment component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    AlignmentDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As AlignmentDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Methods > AlignmentStyle::GetDisplayStylePlan Method
AlignmentStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the Alignment component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    AlignmentDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As AlignmentDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Methods > AlignmentStyle::GetDisplayStyleSection Method
AlignmentStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle object that specifies the line marker in section display properties for the Alignment component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection();
Visual Basic
Public Function GetDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Remarks

Replace for the property: LineMarkerDisplayStyleSection.

Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::GetLineMarkerDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Methods > AlignmentStyle::GetLineMarkerDisplayStyleSection Method
AlignmentStyle::GetLineMarkerDisplayStyleSection Method
Collapse All

Gets the display style for line markers in section view orientation.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetLineMarkerDisplayStyleSection();
Visual Basic
Public Function GetLineMarkerDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties
AlignmentStyle Properties
Collapse All

The properties of AlignmentStyle are listed here.

Public Properties
Public Property | Description
ArrowHeadOption | Gets the alignment arrow head option.
BeginPointMarkerStyle | Gets or sets the marker style object id for 'begin of alignment' points on the alignment.
CompoundCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'compound curve intersection' points on the alignment.
CurveLineIntersectPointMarkerStyle | Gets or sets the marker style object id for 'curve line intersection' points on the alignment.
CurveSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'curve spiral intersection' points on the alignment.
EnableRadiusSnap | Gets or sets the boolean value that specifies whether to enable snapping when changing the curve radius value.
EndPointMarkerStyle | Gets or sets the marker style object id for 'end of alignment' points on the alignment.
IntersectionPointMarkerStyle | Gets or sets the marker style object id for 'point of intersection' points on the alignment.
LineCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'line curve intersection' points on the alignment.
LineMarkerDisplayStyleSection | Gets the display style for line markers in section view orientation.
LineSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'line spiral intersection' points on the alignment.
MidPointMarkerStyle | Gets or sets the marker style object id for mid points on the alignment.
RadiusSnapValue | Gets or sets the even increment value by which a curve radius can change using snapping.
ReverseCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'reverse curve intersection' points on the alignment.
ReverseSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'reverse spiral intersection' points on the alignment.
SpiralCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral curve intersection' points on the alignment.
SpiralLineIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral line intersection' points on the alignment.
SpiralSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral spiral intersection' points on the alignment.
StationReferencePointMarkerStyle | Gets or sets the marker style object id for 'station reference' points on the alignment.
ThroughPointMarkerStyle | Gets or sets the marker style object id for 'through points' on the alignment.
Links
Public Properties


AlignmentStyle::ArrowHeadOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::ArrowHeadOption Property
AlignmentStyle::ArrowHeadOption Property
Collapse All

Gets the alignment arrow head option.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::ArrowHeadOption ArrowHeadOption;
Visual Basic
Public Property ArrowHeadOption() As Autodesk::Civil::Land::DatabaseServices::Styles::ArrowHeadOption
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::BeginPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::BeginPointMarkerStyle Property
AlignmentStyle::BeginPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'begin of alignment' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId BeginPointMarkerStyle;
Visual Basic
Public Property BeginPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::CompoundCurveIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::CompoundCurveIntersectPointMarkerStyle Property
AlignmentStyle::CompoundCurveIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'compound curve intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CompoundCurveIntersectPointMarkerStyle;
Visual Basic
Public Property CompoundCurveIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::CurveLineIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::CurveLineIntersectPointMarkerStyle Property
AlignmentStyle::CurveLineIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'curve line intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurveLineIntersectPointMarkerStyle;
Visual Basic
Public Property CurveLineIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::CurveSpiralIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::CurveSpiralIntersectPointMarkerStyle Property
AlignmentStyle::CurveSpiralIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'curve spiral intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurveSpiralIntersectPointMarkerStyle;
Visual Basic
Public Property CurveSpiralIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::EnableRadiusSnap Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::EnableRadiusSnap Property
AlignmentStyle::EnableRadiusSnap Property
Collapse All

Gets or sets the boolean value that specifies whether to enable snapping when changing the curve radius value.

C#
public bool EnableRadiusSnap;
Visual Basic
Public Property EnableRadiusSnap() As bool
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::EndPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::EndPointMarkerStyle Property
AlignmentStyle::EndPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'end of alignment' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId EndPointMarkerStyle;
Visual Basic
Public Property EndPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::IntersectionPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::IntersectionPointMarkerStyle Property
AlignmentStyle::IntersectionPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'point of intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId IntersectionPointMarkerStyle;
Visual Basic
Public Property IntersectionPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::LineCurveIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::LineCurveIntersectPointMarkerStyle Property
AlignmentStyle::LineCurveIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'line curve intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LineCurveIntersectPointMarkerStyle;
Visual Basic
Public Property LineCurveIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::LineMarkerDisplayStyleSection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::LineMarkerDisplayStyleSection Property
AlignmentStyle::LineMarkerDisplayStyleSection Property deprecated
Collapse All

Gets the display style for line markers in section view orientation.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle LineMarkerDisplayStyleSection;
Visual Basic
Public Property LineMarkerDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.AlignmentStyle.GetLineMarkerDisplayStyleSection instead.

Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::LineSpiralIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::LineSpiralIntersectPointMarkerStyle Property
AlignmentStyle::LineSpiralIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'line spiral intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LineSpiralIntersectPointMarkerStyle;
Visual Basic
Public Property LineSpiralIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::MidPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::MidPointMarkerStyle Property
AlignmentStyle::MidPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for mid points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MidPointMarkerStyle;
Visual Basic
Public Property MidPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::RadiusSnapValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::RadiusSnapValue Property
AlignmentStyle::RadiusSnapValue Property
Collapse All

Gets or sets the even increment value by which a curve radius can change using snapping.

C#
public double RadiusSnapValue;
Visual Basic
Public Property RadiusSnapValue() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value<0
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::ReverseCurveIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::ReverseCurveIntersectPointMarkerStyle Property
AlignmentStyle::ReverseCurveIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'reverse curve intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ReverseCurveIntersectPointMarkerStyle;
Visual Basic
Public Property ReverseCurveIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::ReverseSpiralIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::ReverseSpiralIntersectPointMarkerStyle Property
AlignmentStyle::ReverseSpiralIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'reverse spiral intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ReverseSpiralIntersectPointMarkerStyle;
Visual Basic
Public Property ReverseSpiralIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::SpiralCurveIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::SpiralCurveIntersectPointMarkerStyle Property
AlignmentStyle::SpiralCurveIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'spiral curve intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SpiralCurveIntersectPointMarkerStyle;
Visual Basic
Public Property SpiralCurveIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::SpiralLineIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::SpiralLineIntersectPointMarkerStyle Property
AlignmentStyle::SpiralLineIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'spiral line intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SpiralLineIntersectPointMarkerStyle;
Visual Basic
Public Property SpiralLineIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::SpiralSpiralIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::SpiralSpiralIntersectPointMarkerStyle Property
AlignmentStyle::SpiralSpiralIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'spiral spiral intersection' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SpiralSpiralIntersectPointMarkerStyle;
Visual Basic
Public Property SpiralSpiralIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::StationReferencePointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::StationReferencePointMarkerStyle Property
AlignmentStyle::StationReferencePointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'station reference' points on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StationReferencePointMarkerStyle;
Visual Basic
Public Property StationReferencePointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyle::ThroughPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties > AlignmentStyle::ThroughPointMarkerStyle Property
AlignmentStyle::ThroughPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'through points' on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ThroughPointMarkerStyle;
Visual Basic
Public Property ThroughPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the marker style object id is invalid.
Links
AlignmentStyle Class, AlignmentStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


AlignmentStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class
AlignmentStyleCollection Class
Collapse All

A collection of AlignmentStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyleCollection
C#
public class AlignmentStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class AlignmentStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
AlignmentStyleCollection Methods, AlignmentStyleCollection Members, Class Hierarchy


AlignmentStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class > AlignmentStyleCollection Members
AlignmentStyleCollection Members
Collapse All

The following tables list the members exposed by AlignmentStyleCollection.

Public Methods
Public Method | Description
Add |
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


AlignmentStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class > AlignmentStyleCollection Methods
AlignmentStyleCollection Methods
Collapse All

The methods of AlignmentStyleCollection are listed here.

Public Methods
Public Method | Description
Add |
Links
Public Methods


AlignmentStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class > AlignmentStyleCollection Methods > AlignmentStyleCollection::Add Method
AlignmentStyleCollection::Add Method
Collapse All
C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Example
ObjectId styleID = doc.Styles.AlignmentStyles.Add("Sample alignment style");
AlignmentStyle myAlignmentStyle = ts.GetObject(styleID, OpenMode.ForWrite) as AlignmentStyle;
Links
AlignmentStyleCollection Class, AlignmentStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ArrowHeadOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class
ArrowHeadOption Class
Collapse All

Display options for arrows in AlignmentStyle and ProfileStyle.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::ArrowHeadOption
C#
public class ArrowHeadOption : CivilWrapper<AeccDbStyle>;
Visual Basic
Public Class ArrowHeadOption
Inherits CivilWrapper<AeccDbStyle>
Links
ArrowHeadOption Properties, ArrowHeadOption Members, Class Hierarchy


ArrowHeadOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Members
ArrowHeadOption Members
Collapse All

The following tables list the members exposed by ArrowHeadOption.

Public Properties
Public Property | Description
ArrowBlockName | Gets or Sets the arrow block name.
ArrowType | Gets or Sets the arrow head drawing type.
Fit | Gets or Sets the arrow head fit option.
FixedScaleX | Gets or Sets the arrow head fixed scale in X.
FixedScaleY | Gets the arrow head fixed scale in Y.
FixedScaleZ | Gets the arrow head fixed scale in Z.
SizeOption | Gets or Sets the arrow head size option.
SizeValue | Gets or Sets the arrow head size value.
Links
Public Properties


ArrowHeadOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties
ArrowHeadOption Properties
Collapse All

The properties of ArrowHeadOption are listed here.

Public Properties
Public Property | Description
ArrowBlockName | Gets or Sets the arrow block name.
ArrowType | Gets or Sets the arrow head drawing type.
Fit | Gets or Sets the arrow head fit option.
FixedScaleX | Gets or Sets the arrow head fixed scale in X.
FixedScaleY | Gets the arrow head fixed scale in Y.
FixedScaleZ | Gets the arrow head fixed scale in Z.
SizeOption | Gets or Sets the arrow head size option.
SizeValue | Gets or Sets the arrow head size value.
Links
Public Properties


ArrowHeadOption::ArrowBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties > ArrowHeadOption::ArrowBlockName Property
ArrowHeadOption::ArrowBlockName Property
Collapse All

Gets or Sets the arrow block name.

C#
public System::String ArrowBlockName;
Visual Basic
Public Property ArrowBlockName() As System::String
Remarks

"" is a valid arrow block name for the ArrowHeadType::ClosedFilled.

Exceptions
Exceptions | Description
System::ArgumentException | Throw when the arrow block name is invalid.
Links
ArrowHeadOption Class, ArrowHeadOption Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ArrowHeadOption::ArrowType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties > ArrowHeadOption::ArrowType Property
ArrowHeadOption::ArrowType Property
Collapse All

Gets or Sets the arrow head drawing type.

C#
public Autodesk::Civil::ArrowHeadType ArrowType;
Visual Basic
Public Property ArrowType() As Autodesk::Civil::ArrowHeadType
Remarks

The item ArrowHeadType::UserDefined in the enum ArrowHeadType is readonly, if we set the property ArrowHeadName with a non build-in arrow head type, this property will return ArrowHeadType::UserDefined.

Exceptions
Exceptions | Description
System::InvalidOperationException | Throw when set the property to ArrowHeadType::UserDefined.
Links
ArrowHeadOption Class, ArrowHeadOption Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ArrowHeadOption::Fit Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties > ArrowHeadOption::Fit Property
ArrowHeadOption::Fit Property
Collapse All

Gets or Sets the arrow head fit option.

C#
public Autodesk::Civil::ArrowHeadFitType Fit;
Visual Basic
Public Property Fit() As Autodesk::Civil::ArrowHeadFitType
Links
ArrowHeadOption Class, ArrowHeadOption Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ArrowHeadOption::FixedScaleX Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties > ArrowHeadOption::FixedScaleX Property
ArrowHeadOption::FixedScaleX Property
Collapse All

Gets or Sets the arrow head fixed scale in X.

C#
public double FixedScaleX;
Visual Basic
Public Property FixedScaleX() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the value of property:SizeOption is not ArrowHeadSizeType::UseFixedScale.
Links
ArrowHeadOption Class, ArrowHeadOption Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ArrowHeadOption::FixedScaleY Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties > ArrowHeadOption::FixedScaleY Property
ArrowHeadOption::FixedScaleY Property
Collapse All

Gets the arrow head fixed scale in Y.

C#
public double FixedScaleY;
Visual Basic
Public Property FixedScaleY() As double
Links
ArrowHeadOption Class, ArrowHeadOption Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ArrowHeadOption::FixedScaleZ Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties > ArrowHeadOption::FixedScaleZ Property
ArrowHeadOption::FixedScaleZ Property
Collapse All

Gets the arrow head fixed scale in Z.

C#
public double FixedScaleZ;
Visual Basic
Public Property FixedScaleZ() As double
Links
ArrowHeadOption Class, ArrowHeadOption Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ArrowHeadOption::SizeOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties > ArrowHeadOption::SizeOption Property
ArrowHeadOption::SizeOption Property
Collapse All

Gets or Sets the arrow head size option.

C#
public Autodesk::Civil::ArrowHeadSizeType SizeOption;
Visual Basic
Public Property SizeOption() As Autodesk::Civil::ArrowHeadSizeType
Links
ArrowHeadOption Class, ArrowHeadOption Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ArrowHeadOption::SizeValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties > ArrowHeadOption::SizeValue Property
ArrowHeadOption::SizeValue Property
Collapse All

Gets or Sets the arrow head size value.

C#
public double SizeValue;
Visual Basic
Public Property SizeValue() As double
Links
ArrowHeadOption Class, ArrowHeadOption Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


BuildingSiteStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class
BuildingSiteStyle Class
Collapse All

Display options for building site objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbBuildingSiteStyle"))]
public class BuildingSiteStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbBuildingSiteStyle"))>
Public Class BuildingSiteStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
BuildingSiteStyle Methods, BuildingSiteStyle Properties, BuildingSiteStyle Members, Class Hierarchy


BuildingSiteStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Members
BuildingSiteStyle Members
Collapse All

The following tables list the members exposed by BuildingSiteStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the BuildingSite component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the BuildingSite component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerStyleId | Gets or sets the object id of the marker style for the building site style.
MarkerStyleName | Gets or sets the name of the marker style for the building site style.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


BuildingSiteStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Methods
BuildingSiteStyle Methods
Collapse All

The methods of BuildingSiteStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the BuildingSite component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the BuildingSite component.
Links
Public Methods


BuildingSiteStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Methods > BuildingSiteStyle::GetDisplayStyleModel Method
BuildingSiteStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies model display properties for the BuildingSite component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    BuildingSiteDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As BuildingSiteDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
BuildingSiteStyle Class, BuildingSiteStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


BuildingSiteStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Methods > BuildingSiteStyle::GetDisplayStylePlan Method
BuildingSiteStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the BuildingSite component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    BuildingSiteDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As BuildingSiteDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
BuildingSiteStyle Class, BuildingSiteStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


BuildingSiteStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Properties
BuildingSiteStyle Properties
Collapse All

The properties of BuildingSiteStyle are listed here.

Public Properties
Public Property | Description
MarkerStyleId | Gets or sets the object id of the marker style for the building site style.
MarkerStyleName | Gets or sets the name of the marker style for the building site style.
Links
Public Properties


BuildingSiteStyle::MarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Properties > BuildingSiteStyle::MarkerStyleId Property
BuildingSiteStyle::MarkerStyleId Property
Collapse All

Gets or sets the object id of the marker style for the building site style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MarkerStyleId;
Visual Basic
Public Property MarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.MarkerStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not a MarkerStyle.
Links
BuildingSiteStyle Class, BuildingSiteStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


BuildingSiteStyle::MarkerStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Properties > BuildingSiteStyle::MarkerStyleName Property
BuildingSiteStyle::MarkerStyleName Property
Collapse All

Gets or sets the name of the marker style for the building site style.

C#
public System::String MarkerStyleName;
Visual Basic
Public Property MarkerStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name that a MarkerStyle of this name is not exist.
Links
BuildingSiteStyle Class, BuildingSiteStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


BuildingSiteStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class
BuildingSiteStyleCollection Class
Collapse All

A collection of BuildingSiteStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyleCollection
C#
public class BuildingSiteStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class BuildingSiteStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
BuildingSiteStyleCollection Methods, BuildingSiteStyleCollection Members, Class Hierarchy


BuildingSiteStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class > BuildingSiteStyleCollection Members
BuildingSiteStyleCollection Members
Collapse All

The following tables list the members exposed by BuildingSiteStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


BuildingSiteStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class > BuildingSiteStyleCollection Methods
BuildingSiteStyleCollection Methods
Collapse All

The methods of BuildingSiteStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


BuildingSiteStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class > BuildingSiteStyleCollection Methods > BuildingSiteStyleCollection::Add Method
BuildingSiteStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
BuildingSiteStyleCollection Class, BuildingSiteStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ContourValues Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class
ContourValues Class
Collapse All

Defines how to display major and minor contour lines; used by the SurfaceContourStyle class.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::ContourValues
C#
public class ContourValues;
Visual Basic
Public Class ContourValues
Links
ContourValues Properties, ContourValues Members, Class Hierarchy


ContourValues Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Members
ContourValues Members
Collapse All

The following tables list the members exposed by ContourValues.

Public Properties
Public Property | Description
MajorColor | Gets or sets the color for major contours.
MajorLineTypeId | Gets or sets the ObjectId of the major line type.
MajorLineWight | Gets or sets the major line weight.
MinorColor | Gets or sets the color for minor contours.
MinorLineTypeId | Gets or sets the ObjectId of the minor line type.
MinorLineWight | Gets or sets the minor line weight.
Links
Public Properties


ContourValues Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Properties
ContourValues Properties
Collapse All

The properties of ContourValues are listed here.

Public Properties
Public Property | Description
MajorColor | Gets or sets the color for major contours.
MajorLineTypeId | Gets or sets the ObjectId of the major line type.
MajorLineWight | Gets or sets the major line weight.
MinorColor | Gets or sets the color for minor contours.
MinorLineTypeId | Gets or sets the ObjectId of the minor line type.
MinorLineWight | Gets or sets the minor line weight.
Links
Public Properties


ContourValues::MajorColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Properties > ContourValues::MajorColor Property
ContourValues::MajorColor Property
Collapse All

Gets or sets the color for major contours.

C#
public Autodesk::AutoCAD::Colors::Color MajorColor;
Visual Basic
Public Property MajorColor() As Autodesk::AutoCAD::Colors::Color
Links
ContourValues Class, ContourValues Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ContourValues::MajorLineTypeId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Properties > ContourValues::MajorLineTypeId Property
ContourValues::MajorLineTypeId Property
Collapse All

Gets or sets the ObjectId of the major line type.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MajorLineTypeId;
Visual Basic
Public Property MajorLineTypeId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ContourValues Class, ContourValues Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ContourValues::MajorLineWight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Properties > ContourValues::MajorLineWight Property
ContourValues::MajorLineWight Property
Collapse All

Gets or sets the major line weight.

C#
public Autodesk::AutoCAD::DatabaseServices::LineWeight MajorLineWight;
Visual Basic
Public Property MajorLineWight() As Autodesk::AutoCAD::DatabaseServices::LineWeight
Links
ContourValues Class, ContourValues Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ContourValues::MinorColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Properties > ContourValues::MinorColor Property
ContourValues::MinorColor Property
Collapse All

Gets or sets the color for minor contours.

C#
public Autodesk::AutoCAD::Colors::Color MinorColor;
Visual Basic
Public Property MinorColor() As Autodesk::AutoCAD::Colors::Color
Links
ContourValues Class, ContourValues Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ContourValues::MinorLineTypeId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Properties > ContourValues::MinorLineTypeId Property
ContourValues::MinorLineTypeId Property
Collapse All

Gets or sets the ObjectId of the minor line type.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MinorLineTypeId;
Visual Basic
Public Property MinorLineTypeId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ContourValues Class, ContourValues Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ContourValues::MinorLineWight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Properties > ContourValues::MinorLineWight Property
ContourValues::MinorLineWight Property
Collapse All

Gets or sets the minor line weight.

C#
public Autodesk::AutoCAD::DatabaseServices::LineWeight MinorLineWight;
Visual Basic
Public Property MinorLineWight() As Autodesk::AutoCAD::DatabaseServices::LineWeight
Links
ContourValues Class, ContourValues Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class
GradingCriteria Class
Collapse All

Specifies grading criteria (a projection method and target) to create a finished grading surface.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteria
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGradingCriteria"))]
public class GradingCriteria : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGradingCriteria"))>
Public Class GradingCriteria
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
GradingCriteria Methods, GradingCriteria Properties, GradingCriteria Members, Class Hierarchy


GradingCriteria Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Members
GradingCriteria Members
Collapse All

The following tables list the members exposed by GradingCriteria.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current grading criteria and add to the grading criteria set as a sibling.
ExportTo | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
CutSlope | Specifies the cut grade value.
CutSlopeFormatType | Specifies how the cut slope should be represented.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Distance | Specifies that the grading projection lines will be extended from the footprint until they are match a specified horizontal distance.... more
DistanceProjectionType | Specifies the type of projection for the Distance target.
Document | Gets the Document associated with the DBObject. Not implemented.
Elevation | Specifies that the grading projection lines will be extended from the footprint until they reach a specified elevation.
ElevationProjectionType | Specifies the type of projection for the Elevation target.
FillSlope | Specifies the fill grade value.
FillSlopeFormatType | Specifies how the fill slope should be represented.
InteriorCornerOverlap | Specifies how interior corner projections are cleaned up when the footprint corner has different elevations.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ProjectionDistance | Specifies the fixed distance from the footprint for the projection.
ProjectionRelativeElevation | Specifies the projection relative elevation.
RelativeElevation | Specifies that the grading projection lines will be extended from the footprint until they reach an elevation (depth or height)... more
RelativeElevationProjectionType | Specifies the type of projection for the Relative Elevation target.
SearchOrder | Specifies whether to search first for cut or fill slopes in cases where both would work.
Slope | Specifies the grade value.
SlopeFormatType | Specifies how the slope should be represented.
SurfaceProjectionType | Specifies the type of projection for the Surface target.
Target | Specifies the target method for the grading.
Links
Public Methods, Public Properties


GradingCriteria Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Methods
GradingCriteria Methods
Collapse All

The methods of GradingCriteria are listed here.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current grading criteria and add to the grading criteria set as a sibling.
Links
Public Methods


GradingCriteria::CopyAsSibling Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Methods > GradingCriteria::CopyAsSibling Method
GradingCriteria::CopyAsSibling Method
Collapse All

Copy the current grading criteria and add to the grading criteria set as a sibling.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CopyAsSibling(
    ref System::String criteriaName
);
Visual Basic
Public Function CopyAsSibling(
    ByRef criteriaName As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
criteriaName | The name of the new grading criteria.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name is duplicate.
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties
GradingCriteria Properties
Collapse All

The properties of GradingCriteria are listed here.

Public Properties
Public Property | Description
CutSlope | Specifies the cut grade value.
CutSlopeFormatType | Specifies how the cut slope should be represented.
Distance | Specifies that the grading projection lines will be extended from the footprint until they are match a specified horizontal distance.... more
DistanceProjectionType | Specifies the type of projection for the Distance target.
Elevation | Specifies that the grading projection lines will be extended from the footprint until they reach a specified elevation.
ElevationProjectionType | Specifies the type of projection for the Elevation target.
FillSlope | Specifies the fill grade value.
FillSlopeFormatType | Specifies how the fill slope should be represented.
InteriorCornerOverlap | Specifies how interior corner projections are cleaned up when the footprint corner has different elevations.
ProjectionDistance | Specifies the fixed distance from the footprint for the projection.
ProjectionRelativeElevation | Specifies the projection relative elevation.
RelativeElevation | Specifies that the grading projection lines will be extended from the footprint until they reach an elevation (depth or height)... more
RelativeElevationProjectionType | Specifies the type of projection for the Relative Elevation target.
SearchOrder | Specifies whether to search first for cut or fill slopes in cases where both would work.
Slope | Specifies the grade value.
SlopeFormatType | Specifies how the slope should be represented.
SurfaceProjectionType | Specifies the type of projection for the Surface target.
Target | Specifies the target method for the grading.
Links
Public Properties


GradingCriteria::CutSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::CutSlope Property
GradingCriteria::CutSlope Property
Collapse All

Specifies the cut grade value.

C#
public PropertyDouble CutSlope;
Visual Basic
Public Property CutSlope() As PropertyDouble
Remarks

Use the Autodesk.Civil.Constant.VerticalGrade to set the vertical grade.

Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::CutSlopeFormatType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::CutSlopeFormatType Property
GradingCriteria::CutSlopeFormatType Property
Collapse All

Specifies how the cut slope should be represented.

C#
public PropertyEnum<Autodesk::Civil::Land::GradingSlopeFormatType> CutSlopeFormatType;
Visual Basic
Public Property CutSlopeFormatType() As PropertyEnum<Autodesk::Civil::Land::GradingSlopeFormatType>
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::Distance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::Distance Property
GradingCriteria::Distance Property
Collapse All

Specifies that the grading projection lines will be extended from the footprint until they are match a specified horizontal distance.

C#
public PropertyDouble Distance;
Visual Basic
Public Property Distance() As PropertyDouble
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::DistanceProjectionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::DistanceProjectionType Property
GradingCriteria::DistanceProjectionType Property
Collapse All

Specifies the type of projection for the Distance target.

C#
public Autodesk::Civil::Land::GradingDistanceProjectionType DistanceProjectionType;
Visual Basic
Public Property DistanceProjectionType() As Autodesk::Civil::Land::GradingDistanceProjectionType
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::Elevation Property
GradingCriteria::Elevation Property
Collapse All

Specifies that the grading projection lines will be extended from the footprint until they reach a specified elevation.

C#
public PropertyDouble Elevation;
Visual Basic
Public Property Elevation() As PropertyDouble
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::ElevationProjectionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::ElevationProjectionType Property
GradingCriteria::ElevationProjectionType Property
Collapse All

Specifies the type of projection for the Elevation target.

C#
public Autodesk::Civil::Land::GradingElevationProjectionType ElevationProjectionType;
Visual Basic
Public Property ElevationProjectionType() As Autodesk::Civil::Land::GradingElevationProjectionType
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::FillSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::FillSlope Property
GradingCriteria::FillSlope Property
Collapse All

Specifies the fill grade value.

C#
public PropertyDouble FillSlope;
Visual Basic
Public Property FillSlope() As PropertyDouble
Remarks

Use the Autodesk.Civil.Constant.VerticalGrade to set the vertical grade.

Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::FillSlopeFormatType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::FillSlopeFormatType Property
GradingCriteria::FillSlopeFormatType Property
Collapse All

Specifies how the fill slope should be represented.

C#
public PropertyEnum<Autodesk::Civil::Land::GradingSlopeFormatType> FillSlopeFormatType;
Visual Basic
Public Property FillSlopeFormatType() As PropertyEnum<Autodesk::Civil::Land::GradingSlopeFormatType>
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::InteriorCornerOverlap Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::InteriorCornerOverlap Property
GradingCriteria::InteriorCornerOverlap Property
Collapse All

Specifies how interior corner projections are cleaned up when the footprint corner has different elevations.

C#
public PropertyEnum<Autodesk::Civil::Land::GradingInteriorCornerOverlapSolutionType> InteriorCornerOverlap;
Visual Basic
Public Property InteriorCornerOverlap() As PropertyEnum<Autodesk::Civil::Land::GradingInteriorCornerOverlapSolutionType>
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::ProjectionDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::ProjectionDistance Property
GradingCriteria::ProjectionDistance Property
Collapse All

Specifies the fixed distance from the footprint for the projection.

C#
public PropertyDouble ProjectionDistance;
Visual Basic
Public Property ProjectionDistance() As PropertyDouble
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::ProjectionRelativeElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::ProjectionRelativeElevation Property
GradingCriteria::ProjectionRelativeElevation Property
Collapse All

Specifies the projection relative elevation.

C#
public PropertyDouble ProjectionRelativeElevation;
Visual Basic
Public Property ProjectionRelativeElevation() As PropertyDouble
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::RelativeElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::RelativeElevation Property
GradingCriteria::RelativeElevation Property
Collapse All

Specifies that the grading projection lines will be extended from the footprint until they reach an elevation (depth or height) relative to the footprint.

C#
public PropertyDouble RelativeElevation;
Visual Basic
Public Property RelativeElevation() As PropertyDouble
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::RelativeElevationProjectionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::RelativeElevationProjectionType Property
GradingCriteria::RelativeElevationProjectionType Property
Collapse All

Specifies the type of projection for the Relative Elevation target.

C#
public Autodesk::Civil::Land::GradingRelativeElevationProjectionType RelativeElevationProjectionType;
Visual Basic
Public Property RelativeElevationProjectionType() As Autodesk::Civil::Land::GradingRelativeElevationProjectionType
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::SearchOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::SearchOrder Property
GradingCriteria::SearchOrder Property
Collapse All

Specifies whether to search first for cut or fill slopes in cases where both would work.

C#
public PropertyEnum<Autodesk::Civil::Land::GradingSearchOrderType> SearchOrder;
Visual Basic
Public Property SearchOrder() As PropertyEnum<Autodesk::Civil::Land::GradingSearchOrderType>
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::Slope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::Slope Property
GradingCriteria::Slope Property
Collapse All

Specifies the grade value.

C#
public PropertyDouble Slope;
Visual Basic
Public Property Slope() As PropertyDouble
Remarks

Use the Autodesk.Civil.Constant.VerticalGrade to set the vertical grade.

Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::SlopeFormatType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::SlopeFormatType Property
GradingCriteria::SlopeFormatType Property
Collapse All

Specifies how the slope should be represented.

C#
public PropertyEnum<Autodesk::Civil::Land::GradingSlopeFormatType> SlopeFormatType;
Visual Basic
Public Property SlopeFormatType() As PropertyEnum<Autodesk::Civil::Land::GradingSlopeFormatType>
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::SurfaceProjectionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::SurfaceProjectionType Property
GradingCriteria::SurfaceProjectionType Property
Collapse All

Specifies the type of projection for the Surface target.

C#
public Autodesk::Civil::Land::GradingSurfaceProjectionType SurfaceProjectionType;
Visual Basic
Public Property SurfaceProjectionType() As Autodesk::Civil::Land::GradingSurfaceProjectionType
Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteria::Target Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties > GradingCriteria::Target Property
GradingCriteria::Target Property
Collapse All

Specifies the target method for the grading.

C#
public Autodesk::Civil::Land::GradingTargetType Target;
Visual Basic
Public Property Target() As Autodesk::Civil::Land::GradingTargetType
Remarks

Must set the Target correctly before you getting or setting properties which are related to the target(like CutSlope/Slope/FillSlope) in the GradingCriteria.

Links
GradingCriteria Class, GradingCriteria Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteriaCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class
GradingCriteriaCollection Class
Collapse All

A collection of GradingCriteria objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaCollection
C#
public class GradingCriteriaCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class GradingCriteriaCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
GradingCriteriaCollection Methods, GradingCriteriaCollection Members, Class Hierarchy


GradingCriteriaCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class > GradingCriteriaCollection Members
GradingCriteriaCollection Members
Collapse All

The following tables list the members exposed by GradingCriteriaCollection.

Public Methods
Public Method | Description
Add | Adds a GradingCriteria object to the collection by name.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


GradingCriteriaCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class > GradingCriteriaCollection Methods
GradingCriteriaCollection Methods
Collapse All

The methods of GradingCriteriaCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a GradingCriteria object to the collection by name.
Links
Public Methods


GradingCriteriaCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class > GradingCriteriaCollection Methods > GradingCriteriaCollection::Add Method
GradingCriteriaCollection::Add Method
Collapse All

Adds a GradingCriteria object to the collection by name.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
GradingCriteriaCollection Class, GradingCriteriaCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteriaSet Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class
GradingCriteriaSet Class
Collapse All

A set of multiple related GradingCriteria objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSet
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGradingCriteriaSet"))]
public class GradingCriteriaSet : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGradingCriteriaSet"))>
Public Class GradingCriteriaSet
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
GradingCriteriaSet Methods, GradingCriteriaSet Properties, GradingCriteriaSet Members, Class Hierarchy


GradingCriteriaSet Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Members
GradingCriteriaSet Members
Collapse All

The following tables list the members exposed by GradingCriteriaSet.

Public Methods
Public Method | Description
AddCriteria | Add a new grading criteria to the current set.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GradingCriteriaIds | Gets the objectId collection of all grading criteria objects in the set.
MoveCriteria | Overloaded
RemoveCriteria | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the number of grading criteria in the current grading criteria set.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the grading criteria by name.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


GradingCriteriaSet Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods
GradingCriteriaSet Methods
Collapse All

The methods of GradingCriteriaSet are listed here.

Public Methods
Public Method | Description
AddCriteria | Add a new grading criteria to the current set.
GradingCriteriaIds | Gets the objectId collection of all grading criteria objects in the set.
MoveCriteria | Overloaded
RemoveCriteria | Overloaded
Links
Public Methods


GradingCriteriaSet::AddCriteria Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods > GradingCriteriaSet::AddCriteria Method
GradingCriteriaSet::AddCriteria Method
Collapse All

Add a new grading criteria to the current set.

C#
public AddCriteria(
    ref System::String criteriaName
);
Visual Basic
Public Sub AddCriteria(
    ByRef criteriaName As System::String
)
Parameters
Parameters | Description
criteriaName | The name of the grading criteria.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the grading criteria name is duplicate, it means that the grading criteria is exist in another grading criteria set.
Links
GradingCriteriaSet Class, GradingCriteriaSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteriaSet::GradingCriteriaIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods > GradingCriteriaSet::GradingCriteriaIds Method
GradingCriteriaSet::GradingCriteriaIds Method
Collapse All

Gets the objectId collection of all grading criteria objects in the set.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GradingCriteriaIds();
Visual Basic
Public Function GradingCriteriaIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
GradingCriteriaSet Class, GradingCriteriaSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MoveCriteria Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods > MoveCriteria Method
MoveCriteria Method
Collapse All

Overloaded

Overload List
Method | Description
GradingCriteriaSet::MoveCriteria (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Move a grading criteria from the current grading criteria set to another set by object id.
GradingCriteriaSet::MoveCriteria (System::String^, System::String^) | Move a grading criteria from the current grading criteria set to another set by name.


GradingCriteriaSet::MoveCriteria Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods > MoveCriteria Method > GradingCriteriaSet::MoveCriteria Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
GradingCriteriaSet::MoveCriteria Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Move a grading criteria from the current grading criteria set to another set by object id.

C#
public MoveCriteria(
    Autodesk::AutoCAD::DatabaseServices::ObjectId criteriaId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId criteriaSetId
);
Visual Basic
Public Sub MoveCriteria(
    criteriaId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    criteriaSetId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
criteriaId | The object id of the grading criteria.
criteriaSetId | The object id of the grading criteria set.
Remarks

OBJECTID TYPE: criteriaId <=> Autodesk.Civil.Land.DatabaseServices.Style.GradingCriteria. OBJECTID TYPE: criteriaSetId <=> Autodesk.Civil.Land.DatabaseServices.Style.GradingCriteriaSet.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when: 1: The criteriaId or criteriaSetId is invalid. 2: The criteriaId is not in the current criteria set.
Links
GradingCriteriaSet Class, GradingCriteriaSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteriaSet::MoveCriteria Method (System::String^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods > MoveCriteria Method > GradingCriteriaSet::MoveCriteria Method (System::String^, System::String^)
GradingCriteriaSet::MoveCriteria Method (System::String^, System::String^)
Collapse All

Move a grading criteria from the current grading criteria set to another set by name.

C#
public MoveCriteria(
    ref System::String criteriaName,
    ref System::String criteriaSetName
);
Visual Basic
Public Sub MoveCriteria(
    ByRef criteriaName As System::String,
    ByRef criteriaSetName As System::String
)
Parameters
Parameters | Description
criteriaName | The name of the grading criteria.
criteriaSetName | The name of the grading criteria set.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the criteriaName or criteriaSetName is invalid.
Links
GradingCriteriaSet Class, GradingCriteriaSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


RemoveCriteria Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods > RemoveCriteria Method
RemoveCriteria Method
Collapse All

Overloaded

Overload List
Method | Description
GradingCriteriaSet::RemoveCriteria (int) | Removes a grading criteria by index from the current grading criteria set.
GradingCriteriaSet::RemoveCriteria (System::String^) | Removes a grading criteria by name from the current grading criteria set.


GradingCriteriaSet::RemoveCriteria Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods > RemoveCriteria Method > GradingCriteriaSet::RemoveCriteria Method (System::String^)
GradingCriteriaSet::RemoveCriteria Method (System::String^)
Collapse All

Removes a grading criteria by name from the current grading criteria set.

C#
public RemoveCriteria(
    ref System::String criteriaName
);
Visual Basic
Public Sub RemoveCriteria(
    ByRef criteriaName As System::String
)
Parameters
Parameters | Description
criteriaName | The name of the grading criteria to remove from the current grading criteria set.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name is invalid or not exist under the current grading criteria set.
System.InvalidOperationException | Thrown when style is still in use.
Links
GradingCriteriaSet Class, GradingCriteriaSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteriaSet::RemoveCriteria Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods > RemoveCriteria Method > GradingCriteriaSet::RemoveCriteria Method (int)
GradingCriteriaSet::RemoveCriteria Method (int)
Collapse All

Removes a grading criteria by index from the current grading criteria set.

C#
public RemoveCriteria(
    int index
);
Visual Basic
Public Sub RemoveCriteria(
    index As Integer
)
Parameters
Parameters | Description
index | The index of the grading criteria to remove from the current grading criteria set.
Exceptions
Exceptions | Description
System.ArgumentOurOfRangeException | Thrown when the index is out of range.
System.InvalidOperationException | Thrown when style is still in use.
Links
GradingCriteriaSet Class, GradingCriteriaSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteriaSet Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Properties
GradingCriteriaSet Properties
Collapse All

The properties of GradingCriteriaSet are listed here.

Public Properties
Public Property | Description
Count | Gets the number of grading criteria in the current grading criteria set.
default | Gets the grading criteria by name.
Links
Public Properties


GradingCriteriaSet::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Properties > GradingCriteriaSet::Count Property
GradingCriteriaSet::Count Property
Collapse All

Gets the number of grading criteria in the current grading criteria set.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
GradingCriteriaSet Class, GradingCriteriaSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteriaSet::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Properties > GradingCriteriaSet::default Property
GradingCriteriaSet::default Property
Collapse All

Gets the grading criteria by name.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId default;
Visual Basic
Public Property default() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when index is less than 0 or greater/equal to the Count.
Links
GradingCriteriaSet Class, GradingCriteriaSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingCriteriaSetCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class
GradingCriteriaSetCollection Class
Collapse All

A collection of GradingCriteriaSet objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSetCollection
C#
public class GradingCriteriaSetCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class GradingCriteriaSetCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
GradingCriteriaSetCollection Methods, GradingCriteriaSetCollection Members, Class Hierarchy


GradingCriteriaSetCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class > GradingCriteriaSetCollection Members
GradingCriteriaSetCollection Members
Collapse All

The following tables list the members exposed by GradingCriteriaSetCollection.

Public Methods
Public Method | Description
Add | Adds a GradingCriteriaSet to the collection by name.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


GradingCriteriaSetCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class > GradingCriteriaSetCollection Methods
GradingCriteriaSetCollection Methods
Collapse All

The methods of GradingCriteriaSetCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a GradingCriteriaSet to the collection by name.
Links
Public Methods


GradingCriteriaSetCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class > GradingCriteriaSetCollection Methods > GradingCriteriaSetCollection::Add Method
GradingCriteriaSetCollection::Add Method
Collapse All

Adds a GradingCriteriaSet to the collection by name.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
GradingCriteriaSetCollection Class, GradingCriteriaSetCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class
GradingStyle Class
Collapse All

Specifies default display and other characteristics for grading features when they are created.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGradingStyle"))]
public class GradingStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGradingStyle"))>
Public Class GradingStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
GradingStyle Methods, GradingStyle Properties, GradingStyle Members, Class Hierarchy


GradingStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Members
GradingStyle Members
Collapse All

The following tables list the members exposed by GradingStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the grading component Model display color, layer, linetype, etc.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the grading component Plan display color, layer, linetype, etc.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CenterMarker | Gets or Sets the MarkerSizeType enum value that specifies the size of the marker and how it is calculated.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
FixedSize | Gets or sets the marker size that is specified in the current drawing units (usually feet or meters).
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PercentageOfScreen | Gets or sets the current zoom level of the marker size.
PlottedSize | Gets or sets the marker size that is based on the current drawing scale(inches or millimeters).
SlopePatternStyleId | Gets or sets the object id of the slope pattern style for the grading style.
SlopePatternStyleName | Gets or sets the name of the slope pattern style for the grading style.
SlopeRangeMax | Gets or sets the maximum value of the slope value.
SlopeRangeMin | Gets or sets the minimum value of the slope value.
UseSlopePatternStyle | Gets or sets a bool value that specifies whether use a slope pattern style for the grading style.
UseSlopeRange | Gets or sets a bool value that specifies whether the slope pattern is applied to a limited range of slope... more
Links
Public Methods, Public Properties


GradingStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Methods
GradingStyle Methods
Collapse All

The methods of GradingStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the grading component Model display color, layer, linetype, etc.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the grading component Plan display color, layer, linetype, etc.
Links
Public Methods


GradingStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Methods > GradingStyle::GetDisplayStyleModel Method
GradingStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies the grading component Model display color, layer, linetype, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    GradingDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As GradingDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Methods > GradingStyle::GetDisplayStylePlan Method
GradingStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies the grading component Plan display color, layer, linetype, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    GradingDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As GradingDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties
GradingStyle Properties
Collapse All

The properties of GradingStyle are listed here.

Public Properties
Public Property | Description
CenterMarker | Gets or Sets the MarkerSizeType enum value that specifies the size of the marker and how it is calculated.
FixedSize | Gets or sets the marker size that is specified in the current drawing units (usually feet or meters).
PercentageOfScreen | Gets or sets the current zoom level of the marker size.
PlottedSize | Gets or sets the marker size that is based on the current drawing scale(inches or millimeters).
SlopePatternStyleId | Gets or sets the object id of the slope pattern style for the grading style.
SlopePatternStyleName | Gets or sets the name of the slope pattern style for the grading style.
SlopeRangeMax | Gets or sets the maximum value of the slope value.
SlopeRangeMin | Gets or sets the minimum value of the slope value.
UseSlopePatternStyle | Gets or sets a bool value that specifies whether use a slope pattern style for the grading style.
UseSlopeRange | Gets or sets a bool value that specifies whether the slope pattern is applied to a limited range of slope... more
Links
Public Properties


GradingStyle::CenterMarker Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::CenterMarker Property
GradingStyle::CenterMarker Property
Collapse All

Gets or Sets the MarkerSizeType enum value that specifies the size of the marker and how it is calculated.

C#
public CenterMarkerSizeType CenterMarker;
Visual Basic
Public Property CenterMarker() As CenterMarkerSizeType
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::FixedSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::FixedSize Property
GradingStyle::FixedSize Property
Collapse All

Gets or sets the marker size that is specified in the current drawing units (usually feet or meters).

C#
public double FixedSize;
Visual Basic
Public Property FixedSize() As double
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::PercentageOfScreen Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::PercentageOfScreen Property
GradingStyle::PercentageOfScreen Property
Collapse All

Gets or sets the current zoom level of the marker size.

C#
public double PercentageOfScreen;
Visual Basic
Public Property PercentageOfScreen() As double
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::PlottedSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::PlottedSize Property
GradingStyle::PlottedSize Property
Collapse All

Gets or sets the marker size that is based on the current drawing scale(inches or millimeters).

C#
public double PlottedSize;
Visual Basic
Public Property PlottedSize() As double
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::SlopePatternStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::SlopePatternStyleId Property
GradingStyle::SlopePatternStyleId Property
Collapse All

Gets or sets the object id of the slope pattern style for the grading style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SlopePatternStyleId;
Visual Basic
Public Property SlopePatternStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.SlopePatternStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not SlopePatternStyle.
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::SlopePatternStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::SlopePatternStyleName Property
GradingStyle::SlopePatternStyleName Property
Collapse All

Gets or sets the name of the slope pattern style for the grading style.

C#
public System::String SlopePatternStyleName;
Visual Basic
Public Property SlopePatternStyleName() As System::String
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the SlopePatternStyleId is null.
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::SlopeRangeMax Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::SlopeRangeMax Property
GradingStyle::SlopeRangeMax Property
Collapse All

Gets or sets the maximum value of the slope value.

C#
public double SlopeRangeMax;
Visual Basic
Public Property SlopeRangeMax() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is less than SlopeRangeMin.
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::SlopeRangeMin Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::SlopeRangeMin Property
GradingStyle::SlopeRangeMin Property
Collapse All

Gets or sets the minimum value of the slope value.

C#
public double SlopeRangeMin;
Visual Basic
Public Property SlopeRangeMin() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is greater than SlopeRangeMax.
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::UseSlopePatternStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::UseSlopePatternStyle Property
GradingStyle::UseSlopePatternStyle Property
Collapse All

Gets or sets a bool value that specifies whether use a slope pattern style for the grading style.

C#
public bool UseSlopePatternStyle;
Visual Basic
Public Property UseSlopePatternStyle() As bool
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyle::UseSlopeRange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties > GradingStyle::UseSlopeRange Property
GradingStyle::UseSlopeRange Property
Collapse All

Gets or sets a bool value that specifies whether the slope pattern is applied to a limited range of slope values.

C#
public bool UseSlopeRange;
Visual Basic
Public Property UseSlopeRange() As bool
Links
GradingStyle Class, GradingStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class
GradingStyleCollection Class
Collapse All

A collection of GradingStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyleCollection
C#
public class GradingStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class GradingStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
GradingStyleCollection Methods, GradingStyleCollection Members, Class Hierarchy


GradingStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Members
GradingStyleCollection Members
Collapse All

The following tables list the members exposed by GradingStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
SetCenterMarkerVisable | Specifies whether the center marker of all grading styles is visable in the current view port(Plan/Model).
SetSlopePatternVisable | Specifies whether the slope pattern of all grading styles is visable in the current view port(Plan/Model).
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


GradingStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Methods
GradingStyleCollection Methods
Collapse All

The methods of GradingStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
SetCenterMarkerVisable | Specifies whether the center marker of all grading styles is visable in the current view port(Plan/Model).
SetSlopePatternVisable | Specifies whether the slope pattern of all grading styles is visable in the current view port(Plan/Model).
Links
Public Methods


GradingStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Methods > GradingStyleCollection::Add Method
GradingStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
GradingStyleCollection Class, GradingStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyleCollection::SetCenterMarkerVisable Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Methods > GradingStyleCollection::SetCenterMarkerVisable Method
GradingStyleCollection::SetCenterMarkerVisable Method
Collapse All

Specifies whether the center marker of all grading styles is visable in the current view port(Plan/Model).

C#
public SetCenterMarkerVisable(
    bool isVisable
);
Visual Basic
Public Sub SetCenterMarkerVisable(
    isVisable As bool
)
Links
GradingStyleCollection Class, GradingStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GradingStyleCollection::SetSlopePatternVisable Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Methods > GradingStyleCollection::SetSlopePatternVisable Method
GradingStyleCollection::SetSlopePatternVisable Method
Collapse All

Specifies whether the slope pattern of all grading styles is visable in the current view port(Plan/Model).

C#
public SetSlopePatternVisable(
    bool isVisable
);
Visual Basic
Public Sub SetSlopePatternVisable(
    isVisable As bool
)
Links
GradingStyleCollection Class, GradingStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class
GroupPlotStyle Class
Collapse All

Specifies section view group plot style settings.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSampleLineGroupStyle"))]
public class GroupPlotStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSampleLineGroupStyle"))>
Public Class GroupPlotStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
GroupPlotStyle Properties, GroupPlotStyle Members, Class Hierarchy


GroupPlotStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Members
GroupPlotStyle Members
Collapse All

The following tables list the members exposed by GroupPlotStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
Public Properties
Public Property | Description
AlignType | Gets or sets the GroupPlotAlignType enum value that specifies how the section views are aligned.
Application | Gets the Application associated with the DBObject. Not implemented.
CellSizeType | Gets or sets the GroupPlotCellSizeType enum value that specifies cell size as either uniform or uniform row/column.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GapBetweenPages | Gets of sets the plotted distance between each successive page in a multiple section view plot.
MaximumInColumn | Gets or sets the maximum number of cross section views plotted in a column before moving on to the next... more
MaximumInRow | Gets or sets the maximum number of cross section views plotted in a row before moving on to the next... more
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PlotAreaType | Gets or sets the GroupPlotAreaType enum value that specifies whether to plot page by page or plot all.
PlotRule | Gets or sets the SectionViewPlotRuleType enum value that specifies whether to plot the section views by column or row.
SheetStyleId | Gets or sets the object id of the sheet style for the GroupPlotStyle.
SheetStyleName | Gets or sets the name of the sheet style for the GroupPlotStyle.
SpaceColumn | Gets or sets the minimum number of major grid lines between columns of section views.
SpaceRow | Gets or sets the minimum number of major grid lines between rows of section views.
StartCorner | Gets or sets the GroupPlotStartCornerType enum value that specifies the starting corner type for plotting the section views.
Links
Public Methods, Public Properties


GroupPlotStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties
GroupPlotStyle Properties
Collapse All

The properties of GroupPlotStyle are listed here.

Public Properties
Public Property | Description
AlignType | Gets or sets the GroupPlotAlignType enum value that specifies how the section views are aligned.
CellSizeType | Gets or sets the GroupPlotCellSizeType enum value that specifies cell size as either uniform or uniform row/column.
GapBetweenPages | Gets of sets the plotted distance between each successive page in a multiple section view plot.
MaximumInColumn | Gets or sets the maximum number of cross section views plotted in a column before moving on to the next... more
MaximumInRow | Gets or sets the maximum number of cross section views plotted in a row before moving on to the next... more
PlotAreaType | Gets or sets the GroupPlotAreaType enum value that specifies whether to plot page by page or plot all.
PlotRule | Gets or sets the SectionViewPlotRuleType enum value that specifies whether to plot the section views by column or row.
SheetStyleId | Gets or sets the object id of the sheet style for the GroupPlotStyle.
SheetStyleName | Gets or sets the name of the sheet style for the GroupPlotStyle.
SpaceColumn | Gets or sets the minimum number of major grid lines between columns of section views.
SpaceRow | Gets or sets the minimum number of major grid lines between rows of section views.
StartCorner | Gets or sets the GroupPlotStartCornerType enum value that specifies the starting corner type for plotting the section views.
Links
Public Properties


GroupPlotStyle::AlignType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::AlignType Property
GroupPlotStyle::AlignType Property
Collapse All

Gets or sets the GroupPlotAlignType enum value that specifies how the section views are aligned.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAlignType AlignType;
Visual Basic
Public Property AlignType() As Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAlignType
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::CellSizeType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::CellSizeType Property
GroupPlotStyle::CellSizeType Property
Collapse All

Gets or sets the GroupPlotCellSizeType enum value that specifies cell size as either uniform or uniform row/column.

C#
public GroupPlotCellSizeType CellSizeType;
Visual Basic
Public Property CellSizeType() As GroupPlotCellSizeType
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::GapBetweenPages Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::GapBetweenPages Property
GroupPlotStyle::GapBetweenPages Property
Collapse All

Gets of sets the plotted distance between each successive page in a multiple section view plot.

C#
public double GapBetweenPages;
Visual Basic
Public Property GapBetweenPages() As double
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::MaximumInColumn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::MaximumInColumn Property
GroupPlotStyle::MaximumInColumn Property
Collapse All

Gets or sets the maximum number of cross section views plotted in a column before moving on to the next column.

C#
public int MaximumInColumn;
Visual Basic
Public Property MaximumInColumn() As Integer
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::MaximumInRow Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::MaximumInRow Property
GroupPlotStyle::MaximumInRow Property
Collapse All

Gets or sets the maximum number of cross section views plotted in a row before moving on to the next row.

C#
public int MaximumInRow;
Visual Basic
Public Property MaximumInRow() As Integer
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of the interval [0, 50].
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::PlotAreaType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::PlotAreaType Property
GroupPlotStyle::PlotAreaType Property
Collapse All

Gets or sets the GroupPlotAreaType enum value that specifies whether to plot page by page or plot all.

C#
public GroupPlotAreaType PlotAreaType;
Visual Basic
Public Property PlotAreaType() As GroupPlotAreaType
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::PlotRule Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::PlotRule Property
GroupPlotStyle::PlotRule Property
Collapse All

Gets or sets the SectionViewPlotRuleType enum value that specifies whether to plot the section views by column or row.

C#
public SectionViewPlotRuleType PlotRule;
Visual Basic
Public Property PlotRule() As SectionViewPlotRuleType
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::SheetStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::SheetStyleId Property
GroupPlotStyle::SheetStyleId Property
Collapse All

Gets or sets the object id of the sheet style for the GroupPlotStyle.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SheetStyleId;
Visual Basic
Public Property SheetStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.SheetStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not SheetStyle.
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::SheetStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::SheetStyleName Property
GroupPlotStyle::SheetStyleName Property
Collapse All

Gets or sets the name of the sheet style for the GroupPlotStyle.

C#
public System::String SheetStyleName;
Visual Basic
Public Property SheetStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name that a SheetStyle of this name is not exist.
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::SpaceColumn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::SpaceColumn Property
GroupPlotStyle::SpaceColumn Property
Collapse All

Gets or sets the minimum number of major grid lines between columns of section views.

C#
public double SpaceColumn;
Visual Basic
Public Property SpaceColumn() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [-10.0000, 10.0000] in meters drawing units.
  2. The input value is out of the interval [-32.808398950131233595800524934383, 32.808398950131233595800524934383] in feet drawing units.

Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::SpaceRow Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::SpaceRow Property
GroupPlotStyle::SpaceRow Property
Collapse All

Gets or sets the minimum number of major grid lines between rows of section views.

C#
public double SpaceRow;
Visual Basic
Public Property SpaceRow() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The input value is out of the interval [-10.0000, 10.0000] in meters drawing units.
  2. The input value is out of the interval [-32.808398950131233595800524934383, 32.808398950131233595800524934383] in feet drawing units.

Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyle::StartCorner Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties > GroupPlotStyle::StartCorner Property
GroupPlotStyle::StartCorner Property
Collapse All

Gets or sets the GroupPlotStartCornerType enum value that specifies the starting corner type for plotting the section views.

C#
public GroupPlotStartCornerType StartCorner;
Visual Basic
Public Property StartCorner() As GroupPlotStartCornerType
Links
GroupPlotStyle Class, GroupPlotStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


GroupPlotStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class
GroupPlotStyleCollection Class
Collapse All

A collection of GroupPlotStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyleCollection
C#
public class GroupPlotStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class GroupPlotStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
GroupPlotStyleCollection Methods, GroupPlotStyleCollection Members, Class Hierarchy


GroupPlotStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class > GroupPlotStyleCollection Members
GroupPlotStyleCollection Members
Collapse All

The following tables list the members exposed by GroupPlotStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


GroupPlotStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class > GroupPlotStyleCollection Methods
GroupPlotStyleCollection Methods
Collapse All

The methods of GroupPlotStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


GroupPlotStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class > GroupPlotStyleCollection Methods > GroupPlotStyleCollection::Add Method
GroupPlotStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
GroupPlotStyleCollection Class, GroupPlotStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class
HorizontalGeometryBandStyle Class
Collapse All

The style object specifying characteristics for profile view horizontal geometry data bands.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::HorizontalGeometryBandStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleHorGeometryBands"))]
public class HorizontalGeometryBandStyle : Autodesk::Civil::DatabaseServices::Styles::BandStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleHorGeometryBands"))>
Public Class HorizontalGeometryBandStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::BandStyle
Links
HorizontalGeometryBandStyle Methods, HorizontalGeometryBandStyle Properties, HorizontalGeometryBandStyle Members, Class Hierarchy


HorizontalGeometryBandStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Members
HorizontalGeometryBandStyle Members
Collapse All

The following tables list the members exposed by HorizontalGeometryBandStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the HorizontalGeometry component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
CurveLabelStyleId | Gets the band horizontal label style id at the curve.
CurveTickStyle | Gets the band horizontal tick style at the curve.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SchematicLineType | Gets the band horizontal line type at the schematic.
SpiralLabelStyleId | Gets the band horizontal geometry spiral label style id at the horizontal.
SpiralTickStyle | Gets the band horizontal tick style at the spiral.
TangentLabelStyleId | Gets the band horizontal label style id at the tangent.
TangentTickStyle | Gets the band horizontal tick style at the tangent.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Methods, Public Properties


HorizontalGeometryBandStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Methods
HorizontalGeometryBandStyle Methods
Collapse All

The methods of HorizontalGeometryBandStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the HorizontalGeometry component.
Links
Public Methods


HorizontalGeometryBandStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Methods > HorizontalGeometryBandStyle::GetDisplayStylePlan Method
HorizontalGeometryBandStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the HorizontalGeometry component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    HorizontalGeometryDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As HorizontalGeometryDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties
HorizontalGeometryBandStyle Properties
Collapse All

The properties of HorizontalGeometryBandStyle are listed here.

Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CurveLabelStyleId | Gets the band horizontal label style id at the curve.
CurveTickStyle | Gets the band horizontal tick style at the curve.
SchematicLineType | Gets the band horizontal line type at the schematic.
SpiralLabelStyleId | Gets the band horizontal geometry spiral label style id at the horizontal.
SpiralTickStyle | Gets the band horizontal tick style at the spiral.
TangentLabelStyleId | Gets the band horizontal label style id at the tangent.
TangentTickStyle | Gets the band horizontal tick style at the tangent.
TitleTextLabelStyleId | Gets the band profile data title text label style.
Links
Public Properties


HorizontalGeometryBandStyle::BandType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties > HorizontalGeometryBandStyle::BandType Property
HorizontalGeometryBandStyle::BandType Property
Collapse All

Gets the BandStyleType enum value that specifies the type of data band data.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandStyleType BandType;
Visual Basic
Public Property BandType() As Autodesk::Civil::DatabaseServices::Styles::BandStyleType
Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle::CurveLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties > HorizontalGeometryBandStyle::CurveLabelStyleId Property
HorizontalGeometryBandStyle::CurveLabelStyleId Property
Collapse All

Gets the band horizontal label style id at the curve.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurveLabelStyleId;
Visual Basic
Public Property CurveLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle::CurveTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties > HorizontalGeometryBandStyle::CurveTickStyle Property
HorizontalGeometryBandStyle::CurveTickStyle Property
Collapse All

Gets the band horizontal tick style at the curve.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle CurveTickStyle;
Visual Basic
Public Property CurveTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle::SchematicLineType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties > HorizontalGeometryBandStyle::SchematicLineType Property
HorizontalGeometryBandStyle::SchematicLineType Property
Collapse All

Gets the band horizontal line type at the schematic.

C#
public SchematicLineOption SchematicLineType;
Visual Basic
Public Property SchematicLineType() As SchematicLineOption
Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle::SpiralLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties > HorizontalGeometryBandStyle::SpiralLabelStyleId Property
HorizontalGeometryBandStyle::SpiralLabelStyleId Property
Collapse All

Gets the band horizontal geometry spiral label style id at the horizontal.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SpiralLabelStyleId;
Visual Basic
Public Property SpiralLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle::SpiralTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties > HorizontalGeometryBandStyle::SpiralTickStyle Property
HorizontalGeometryBandStyle::SpiralTickStyle Property
Collapse All

Gets the band horizontal tick style at the spiral.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle SpiralTickStyle;
Visual Basic
Public Property SpiralTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle::TangentLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties > HorizontalGeometryBandStyle::TangentLabelStyleId Property
HorizontalGeometryBandStyle::TangentLabelStyleId Property
Collapse All

Gets the band horizontal label style id at the tangent.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TangentLabelStyleId;
Visual Basic
Public Property TangentLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle::TangentTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties > HorizontalGeometryBandStyle::TangentTickStyle Property
HorizontalGeometryBandStyle::TangentTickStyle Property
Collapse All

Gets the band horizontal tick style at the tangent.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle TangentTickStyle;
Visual Basic
Public Property TangentTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


HorizontalGeometryBandStyle::TitleTextLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties > HorizontalGeometryBandStyle::TitleTextLabelStyleId Property
HorizontalGeometryBandStyle::TitleTextLabelStyleId Property
Collapse All

Gets the band profile data title text label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TitleTextLabelStyleId;
Visual Basic
Public Property TitleTextLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Links
HorizontalGeometryBandStyle Class, HorizontalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class
LabelStylesAlignmentRoot Class
Collapse All

All Alignment-related label styles. These styles control the label display for alignment components, such as major and minor stations, station equations, geometry points, and so on.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesAlignmentRoot
C#
public class LabelStylesAlignmentRoot : Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode;
Visual Basic
Public Class LabelStylesAlignmentRoot
Inherits Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
Links
LabelStylesAlignmentRoot Properties, LabelStylesAlignmentRoot Members, Class Hierarchy


LabelStylesAlignmentRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Members
LabelStylesAlignmentRoot Members
Collapse All

The following tables list the members exposed by LabelStylesAlignmentRoot.

Public Properties
Public Property | Description
CurveLabelStyles | Gets the collection of styles associated with an alignment's curve labels.
DefaultLabelStyle | Gets the default vaules of label styles.
DesignSpeedLabelStyles | Gets the collection of styles for design speedon the alignment.
GeometryPointLabelStyles | Gets the collection of all alignment geometry point label styles.
LineLabelStyles | Gets the collection of all alignment line label styles.
MajorStationLabelStyles | Gets the collection of all alignment major station label styles.
MinorStationLabelStyles | Gets the collection of all alignment minor station label styles.
SpiralLabelStyles | Gets the collection of all alignment spiral label styles.
StationEquationLabelStyles | Gets the collection of all alignment station equation label styles.
StationOffsetLabelStyles | Gets the collection of all alignment station offset label styles.
SuperelevationCriticalPointsLabelStyles | Gets the collection of all alignment superelevation Critical points label styles.
TangentIntersectionLabelStyles | Gets the collection of all alignment tangent intersection label styles.
VerticalGeometryPointLabelStyles | Gets the collection of all alignment vertical geometry point label styles.
Links
Public Properties


LabelStylesAlignmentRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties
LabelStylesAlignmentRoot Properties
Collapse All

The properties of LabelStylesAlignmentRoot are listed here.

Public Properties
Public Property | Description
CurveLabelStyles | Gets the collection of styles associated with an alignment's curve labels.
DesignSpeedLabelStyles | Gets the collection of styles for design speedon the alignment.
GeometryPointLabelStyles | Gets the collection of all alignment geometry point label styles.
LineLabelStyles | Gets the collection of all alignment line label styles.
MajorStationLabelStyles | Gets the collection of all alignment major station label styles.
MinorStationLabelStyles | Gets the collection of all alignment minor station label styles.
SpiralLabelStyles | Gets the collection of all alignment spiral label styles.
StationEquationLabelStyles | Gets the collection of all alignment station equation label styles.
StationOffsetLabelStyles | Gets the collection of all alignment station offset label styles.
SuperelevationCriticalPointsLabelStyles | Gets the collection of all alignment superelevation Critical points label styles.
TangentIntersectionLabelStyles | Gets the collection of all alignment tangent intersection label styles.
VerticalGeometryPointLabelStyles | Gets the collection of all alignment vertical geometry point label styles.
Links
Public Properties


LabelStylesAlignmentRoot::CurveLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::CurveLabelStyles Property
LabelStylesAlignmentRoot::CurveLabelStyles Property
Collapse All

Gets the collection of styles associated with an alignment's curve labels.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection CurveLabelStyles;
Visual Basic
Public Property CurveLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::DesignSpeedLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::DesignSpeedLabelStyles Property
LabelStylesAlignmentRoot::DesignSpeedLabelStyles Property
Collapse All

Gets the collection of styles for design speedon the alignment.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection DesignSpeedLabelStyles;
Visual Basic
Public Property DesignSpeedLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::GeometryPointLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::GeometryPointLabelStyles Property
LabelStylesAlignmentRoot::GeometryPointLabelStyles Property
Collapse All

Gets the collection of all alignment geometry point label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection GeometryPointLabelStyles;
Visual Basic
Public Property GeometryPointLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::LineLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::LineLabelStyles Property
LabelStylesAlignmentRoot::LineLabelStyles Property
Collapse All

Gets the collection of all alignment line label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection LineLabelStyles;
Visual Basic
Public Property LineLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::MajorStationLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::MajorStationLabelStyles Property
LabelStylesAlignmentRoot::MajorStationLabelStyles Property
Collapse All

Gets the collection of all alignment major station label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection MajorStationLabelStyles;
Visual Basic
Public Property MajorStationLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::MinorStationLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::MinorStationLabelStyles Property
LabelStylesAlignmentRoot::MinorStationLabelStyles Property
Collapse All

Gets the collection of all alignment minor station label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection MinorStationLabelStyles;
Visual Basic
Public Property MinorStationLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::SpiralLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::SpiralLabelStyles Property
LabelStylesAlignmentRoot::SpiralLabelStyles Property
Collapse All

Gets the collection of all alignment spiral label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection SpiralLabelStyles;
Visual Basic
Public Property SpiralLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::StationEquationLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::StationEquationLabelStyles Property
LabelStylesAlignmentRoot::StationEquationLabelStyles Property
Collapse All

Gets the collection of all alignment station equation label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection StationEquationLabelStyles;
Visual Basic
Public Property StationEquationLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::StationOffsetLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::StationOffsetLabelStyles Property
LabelStylesAlignmentRoot::StationOffsetLabelStyles Property
Collapse All

Gets the collection of all alignment station offset label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection StationOffsetLabelStyles;
Visual Basic
Public Property StationOffsetLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::SuperelevationCriticalPointsLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::SuperelevationCriticalPointsLabelStyles Property
LabelStylesAlignmentRoot::SuperelevationCriticalPointsLabelStyles Property
Collapse All

Gets the collection of all alignment superelevation Critical points label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection SuperelevationCriticalPointsLabelStyles;
Visual Basic
Public Property SuperelevationCriticalPointsLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::TangentIntersectionLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::TangentIntersectionLabelStyles Property
LabelStylesAlignmentRoot::TangentIntersectionLabelStyles Property
Collapse All

Gets the collection of all alignment tangent intersection label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection TangentIntersectionLabelStyles;
Visual Basic
Public Property TangentIntersectionLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesAlignmentRoot::VerticalGeometryPointLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties > LabelStylesAlignmentRoot::VerticalGeometryPointLabelStyles Property
LabelStylesAlignmentRoot::VerticalGeometryPointLabelStyles Property
Collapse All

Gets the collection of all alignment vertical geometry point label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection VerticalGeometryPointLabelStyles;
Visual Basic
Public Property VerticalGeometryPointLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesAlignmentRoot Class, LabelStylesAlignmentRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesMatchLineRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class
LabelStylesMatchLineRoot Class
Collapse All

All styles associated with match line labels.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesMatchLineRoot
C#
public class LabelStylesMatchLineRoot : Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode;
Visual Basic
Public Class LabelStylesMatchLineRoot
Inherits Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
Links
LabelStylesMatchLineRoot Properties, LabelStylesMatchLineRoot Members, Class Hierarchy


LabelStylesMatchLineRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class > LabelStylesMatchLineRoot Members
LabelStylesMatchLineRoot Members
Collapse All

The following tables list the members exposed by LabelStylesMatchLineRoot.

Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
LeftLabelStyles | Gets the collection of all match line left label styles.
RightLabelStyles | Gets the collection of all match line right label styles.
Links
Public Properties


LabelStylesMatchLineRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class > LabelStylesMatchLineRoot Properties
LabelStylesMatchLineRoot Properties
Collapse All

The properties of LabelStylesMatchLineRoot are listed here.

Public Properties
Public Property | Description
LeftLabelStyles | Gets the collection of all match line left label styles.
RightLabelStyles | Gets the collection of all match line right label styles.
Links
Public Properties


LabelStylesMatchLineRoot::LeftLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class > LabelStylesMatchLineRoot Properties > LabelStylesMatchLineRoot::LeftLabelStyles Property
LabelStylesMatchLineRoot::LeftLabelStyles Property
Collapse All

Gets the collection of all match line left label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection LeftLabelStyles;
Visual Basic
Public Property LeftLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesMatchLineRoot Class, LabelStylesMatchLineRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesMatchLineRoot::RightLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class > LabelStylesMatchLineRoot Properties > LabelStylesMatchLineRoot::RightLabelStyles Property
LabelStylesMatchLineRoot::RightLabelStyles Property
Collapse All

Gets the collection of all match line right label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection RightLabelStyles;
Visual Basic
Public Property RightLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesMatchLineRoot Class, LabelStylesMatchLineRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesProfileRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class
LabelStylesProfileRoot Class
Collapse All

LabelStylesProfileRoot

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProfileRoot
C#
public class LabelStylesProfileRoot : Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode;
Visual Basic
Public Class LabelStylesProfileRoot
Inherits Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
Links
LabelStylesProfileRoot Properties, LabelStylesProfileRoot Members, Class Hierarchy


LabelStylesProfileRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Members
LabelStylesProfileRoot Members
Collapse All

The following tables list the members exposed by LabelStylesProfileRoot.

Public Properties
Public Property | Description
CurveLabelStyles | Gets the collection of all profile curve label styles.
DefaultLabelStyle | Gets the default vaules of label styles.
GradeBreadLabelStyles | Gets the collection of all profile grade break label styles.
GradeBreakLabelStyles | Gets the collection of all profile grade break label styles.
HorizontalGeometryPointLabelStyles | Gets the collection of all profile horizontal geometry point label styles.
LineLabelStyles | Gets the collection of all profile line label styles.
MajorStationLabelStyles | Gets the collection of all profile major station label styles.
MinorStationLabelStyles | Gets the collection of all profile minor station label styles.
Links
Public Properties


LabelStylesProfileRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties
LabelStylesProfileRoot Properties
Collapse All

The properties of LabelStylesProfileRoot are listed here.

Public Properties
Public Property | Description
CurveLabelStyles | Gets the collection of all profile curve label styles.
GradeBreadLabelStyles | Gets the collection of all profile grade break label styles.
GradeBreakLabelStyles | Gets the collection of all profile grade break label styles.
HorizontalGeometryPointLabelStyles | Gets the collection of all profile horizontal geometry point label styles.
LineLabelStyles | Gets the collection of all profile line label styles.
MajorStationLabelStyles | Gets the collection of all profile major station label styles.
MinorStationLabelStyles | Gets the collection of all profile minor station label styles.
Links
Public Properties


LabelStylesProfileRoot::CurveLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties > LabelStylesProfileRoot::CurveLabelStyles Property
LabelStylesProfileRoot::CurveLabelStyles Property
Collapse All

Gets the collection of all profile curve label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection CurveLabelStyles;
Visual Basic
Public Property CurveLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesProfileRoot Class, LabelStylesProfileRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesProfileRoot::GradeBreadLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties > LabelStylesProfileRoot::GradeBreadLabelStyles Property
LabelStylesProfileRoot::GradeBreadLabelStyles Property deprecated
Collapse All

Gets the collection of all profile grade break label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection GradeBreadLabelStyles;
Visual Basic
Public Property GradeBreadLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.LabelStylesProfileRoot.GradeBreakLabelStyles instead.

Links
LabelStylesProfileRoot Class, LabelStylesProfileRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesProfileRoot::GradeBreakLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties > LabelStylesProfileRoot::GradeBreakLabelStyles Property
LabelStylesProfileRoot::GradeBreakLabelStyles Property
Collapse All

Gets the collection of all profile grade break label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection GradeBreakLabelStyles;
Visual Basic
Public Property GradeBreakLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesProfileRoot Class, LabelStylesProfileRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesProfileRoot::HorizontalGeometryPointLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties > LabelStylesProfileRoot::HorizontalGeometryPointLabelStyles Property
LabelStylesProfileRoot::HorizontalGeometryPointLabelStyles Property
Collapse All

Gets the collection of all profile horizontal geometry point label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection HorizontalGeometryPointLabelStyles;
Visual Basic
Public Property HorizontalGeometryPointLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesProfileRoot Class, LabelStylesProfileRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesProfileRoot::LineLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties > LabelStylesProfileRoot::LineLabelStyles Property
LabelStylesProfileRoot::LineLabelStyles Property
Collapse All

Gets the collection of all profile line label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection LineLabelStyles;
Visual Basic
Public Property LineLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesProfileRoot Class, LabelStylesProfileRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesProfileRoot::MajorStationLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties > LabelStylesProfileRoot::MajorStationLabelStyles Property
LabelStylesProfileRoot::MajorStationLabelStyles Property
Collapse All

Gets the collection of all profile major station label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection MajorStationLabelStyles;
Visual Basic
Public Property MajorStationLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesProfileRoot Class, LabelStylesProfileRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


LabelStylesProfileRoot::MinorStationLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties > LabelStylesProfileRoot::MinorStationLabelStyles Property
LabelStylesProfileRoot::MinorStationLabelStyles Property
Collapse All

Gets the collection of all profile minor station label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection MinorStationLabelStyles;
Visual Basic
Public Property MinorStationLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesProfileRoot Class, LabelStylesProfileRoot Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulLineStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class
MassHaulLineStyle Class
Collapse All

The view frame style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMassHaulLineStyle"))]
public class MassHaulLineStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMassHaulLineStyle"))>
Public Class MassHaulLineStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
MassHaulLineStyle Methods, MassHaulLineStyle Properties, MassHaulLineStyle Members, Class Hierarchy


MassHaulLineStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Members
MassHaulLineStyle Members
Collapse All

The following tables list the members exposed by MassHaulLineStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the MassHaulLine component.
GetHatchDisplayStyleProfile | Gets the HatchDisplayStyle object that specifies profile display properties for the MassHaulLine component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
FreeHaulOption | Gets the FreeHaulDisplayType enumeration that defines how to show the free haul in the graph.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


MassHaulLineStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Methods
MassHaulLineStyle Methods
Collapse All

The methods of MassHaulLineStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the MassHaulLine component.
GetHatchDisplayStyleProfile | Gets the HatchDisplayStyle object that specifies profile display properties for the MassHaulLine component.
Links
Public Methods


MassHaulLineStyle::GetDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Methods > MassHaulLineStyle::GetDisplayStyleProfile Method
MassHaulLineStyle::GetDisplayStyleProfile Method
Collapse All

Gets the DisplayStyle object that specifies profile display properties for the MassHaulLine component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleProfile(
    Autodesk::Civil::Land::MassHaulLineDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleProfile(
    type As Autodesk::Civil::Land::MassHaulLineDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
MassHaulLineStyle Class, MassHaulLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulLineStyle::GetHatchDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Methods > MassHaulLineStyle::GetHatchDisplayStyleProfile Method
MassHaulLineStyle::GetHatchDisplayStyleProfile Method
Collapse All

Gets the HatchDisplayStyle object that specifies profile display properties for the MassHaulLine component.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchDisplayStyleProfile(
    Autodesk::Civil::Land::MassHaulLineHatchDisplayStyleType type
);
Visual Basic
Public Function GetHatchDisplayStyleProfile(
    type As Autodesk::Civil::Land::MassHaulLineHatchDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Parameters
Parameters | Description
type | The type of HatchDisplayStyle to get.
Links
MassHaulLineStyle Class, MassHaulLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulLineStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Properties
MassHaulLineStyle Properties
Collapse All

The properties of MassHaulLineStyle are listed here.

Public Properties
Public Property | Description
FreeHaulOption | Gets the FreeHaulDisplayType enumeration that defines how to show the free haul in the graph.
Links
Public Properties


MassHaulLineStyle::FreeHaulOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Properties > MassHaulLineStyle::FreeHaulOption Property
MassHaulLineStyle::FreeHaulOption Property
Collapse All

Gets the FreeHaulDisplayType enumeration that defines how to show the free haul in the graph.

C#
public Autodesk::Civil::Land::FreeHaulDisplayType FreeHaulOption;
Visual Basic
Public Property FreeHaulOption() As Autodesk::Civil::Land::FreeHaulDisplayType
Links
MassHaulLineStyle Class, MassHaulLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulLineStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class
MassHaulLineStyleCollection Class
Collapse All

The MassHaulLineStyleCollection class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyleCollection
C#
public class MassHaulLineStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class MassHaulLineStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
MassHaulLineStyleCollection Methods, MassHaulLineStyleCollection Members, Class Hierarchy


MassHaulLineStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class > MassHaulLineStyleCollection Members
MassHaulLineStyleCollection Members
Collapse All

The following tables list the members exposed by MassHaulLineStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


MassHaulLineStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class > MassHaulLineStyleCollection Methods
MassHaulLineStyleCollection Methods
Collapse All

The methods of MassHaulLineStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


MassHaulLineStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class > MassHaulLineStyleCollection Methods > MassHaulLineStyleCollection::Add Method
MassHaulLineStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
MassHaulLineStyleCollection Class, MassHaulLineStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulViewStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class
MassHaulViewStyle Class
Collapse All

The view frame style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleMassHaulView"))]
public class MassHaulViewStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleMassHaulView"))>
Public Class MassHaulViewStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
MassHaulViewStyle Methods, MassHaulViewStyle Properties, MassHaulViewStyle Members, Class Hierarchy


MassHaulViewStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Members
MassHaulViewStyle Members
Collapse All

The following tables list the members exposed by MassHaulViewStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the masshual view component plan display color, layer, linetype, etc.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomAxis | Gets the style object that specifies display properties for masshual view bottom axes.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GraphStyle | Gets the style object that specifies all display properties for masshual view graphs.
GridStyle | Gets the style object that specifies display properties for masshual view grid.
LeftAxis | Gets the style object that specifies display properties for masshual view left axes.
MiddleAxis | Gets the style object that specifies display properties for masshual view midlle axes.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RightAxis | Gets the style object that specifies display properties for masshual view right axes.
TopAxis | Gets the style object that specifies display properties for masshual view top axes.
Links
Public Methods, Public Properties


MassHaulViewStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Methods
MassHaulViewStyle Methods
Collapse All

The methods of MassHaulViewStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the masshual view component plan display color, layer, linetype, etc.
Links
Public Methods


MassHaulViewStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Methods > MassHaulViewStyle::GetDisplayStylePlan Method
MassHaulViewStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies the masshual view component plan display color, layer, linetype, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    Autodesk::Civil::Land::MassHaulViewDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As Autodesk::Civil::Land::MassHaulViewDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
MassHaulViewStyle Class, MassHaulViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulViewStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties
MassHaulViewStyle Properties
Collapse All

The properties of MassHaulViewStyle are listed here.

Public Properties
Public Property | Description
BottomAxis | Gets the style object that specifies display properties for masshual view bottom axes.
GraphStyle | Gets the style object that specifies all display properties for masshual view graphs.
GridStyle | Gets the style object that specifies display properties for masshual view grid.
LeftAxis | Gets the style object that specifies display properties for masshual view left axes.
MiddleAxis | Gets the style object that specifies display properties for masshual view midlle axes.
RightAxis | Gets the style object that specifies display properties for masshual view right axes.
TopAxis | Gets the style object that specifies display properties for masshual view top axes.
Links
Public Properties


MassHaulViewStyle::BottomAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties > MassHaulViewStyle::BottomAxis Property
MassHaulViewStyle::BottomAxis Property
Collapse All

Gets the style object that specifies display properties for masshual view bottom axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle BottomAxis;
Visual Basic
Public Property BottomAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
MassHaulViewStyle Class, MassHaulViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulViewStyle::GraphStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties > MassHaulViewStyle::GraphStyle Property
MassHaulViewStyle::GraphStyle Property
Collapse All

Gets the style object that specifies all display properties for masshual view graphs.

C#
public Autodesk::Civil::DatabaseServices::Styles::GraphStyle GraphStyle;
Visual Basic
Public Property GraphStyle() As Autodesk::Civil::DatabaseServices::Styles::GraphStyle
Links
MassHaulViewStyle Class, MassHaulViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulViewStyle::GridStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties > MassHaulViewStyle::GridStyle Property
MassHaulViewStyle::GridStyle Property
Collapse All

Gets the style object that specifies display properties for masshual view grid.

C#
public Autodesk::Civil::DatabaseServices::Styles::GridStyle GridStyle;
Visual Basic
Public Property GridStyle() As Autodesk::Civil::DatabaseServices::Styles::GridStyle
Links
MassHaulViewStyle Class, MassHaulViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulViewStyle::LeftAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties > MassHaulViewStyle::LeftAxis Property
MassHaulViewStyle::LeftAxis Property
Collapse All

Gets the style object that specifies display properties for masshual view left axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle LeftAxis;
Visual Basic
Public Property LeftAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
MassHaulViewStyle Class, MassHaulViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulViewStyle::MiddleAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties > MassHaulViewStyle::MiddleAxis Property
MassHaulViewStyle::MiddleAxis Property
Collapse All

Gets the style object that specifies display properties for masshual view midlle axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle MiddleAxis;
Visual Basic
Public Property MiddleAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
MassHaulViewStyle Class, MassHaulViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulViewStyle::RightAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties > MassHaulViewStyle::RightAxis Property
MassHaulViewStyle::RightAxis Property
Collapse All

Gets the style object that specifies display properties for masshual view right axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle RightAxis;
Visual Basic
Public Property RightAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
MassHaulViewStyle Class, MassHaulViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulViewStyle::TopAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties > MassHaulViewStyle::TopAxis Property
MassHaulViewStyle::TopAxis Property
Collapse All

Gets the style object that specifies display properties for masshual view top axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle TopAxis;
Visual Basic
Public Property TopAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
MassHaulViewStyle Class, MassHaulViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MassHaulViewStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class
MassHaulViewStyleCollection Class
Collapse All

The MassHaulViewStyleCollection class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyleCollection
C#
public class MassHaulViewStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class MassHaulViewStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
MassHaulViewStyleCollection Methods, MassHaulViewStyleCollection Members, Class Hierarchy


MassHaulViewStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class > MassHaulViewStyleCollection Members
MassHaulViewStyleCollection Members
Collapse All

The following tables list the members exposed by MassHaulViewStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


MassHaulViewStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class > MassHaulViewStyleCollection Methods
MassHaulViewStyleCollection Methods
Collapse All

The methods of MassHaulViewStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


MassHaulViewStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class > MassHaulViewStyleCollection Methods > MassHaulViewStyleCollection::Add Method
MassHaulViewStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
MassHaulViewStyleCollection Class, MassHaulViewStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MatchLineStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class
MatchLineStyle Class
Collapse All

The match line style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::MatchLineStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMatchLineStyle"))]
public class MatchLineStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMatchLineStyle"))>
Public Class MatchLineStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
MatchLineStyle Methods, MatchLineStyle Properties, MatchLineStyle Members, Class Hierarchy


MatchLineStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Members
MatchLineStyle Members
Collapse All

The following tables list the members exposed by MatchLineStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetLinesDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match lines.
GetMatchLineMaskDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match line mask areas.
GetMatchLineMaskHatchDisplayStyle | Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
LinesDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match lines.
MatchLineMaskDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match line mask areas.
MatchLineMaskHatchDisplayStyle | Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


MatchLineStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Methods
MatchLineStyle Methods
Collapse All

The methods of MatchLineStyle are listed here.

Public Methods
Public Method | Description
GetLinesDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match lines.
GetMatchLineMaskDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match line mask areas.
GetMatchLineMaskHatchDisplayStyle | Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.
Links
Public Methods


MatchLineStyle::GetLinesDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Methods > MatchLineStyle::GetLinesDisplayStylePlan Method
MatchLineStyle::GetLinesDisplayStylePlan Method
Collapse All

Gets the DisplayStyle that specifies plan display properties for the match lines.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetLinesDisplayStylePlan();
Visual Basic
Public Function GetLinesDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
MatchLineStyle Class, MatchLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MatchLineStyle::GetMatchLineMaskDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Methods > MatchLineStyle::GetMatchLineMaskDisplayStylePlan Method
MatchLineStyle::GetMatchLineMaskDisplayStylePlan Method
Collapse All

Gets the DisplayStyle that specifies plan display properties for the match line mask areas.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetMatchLineMaskDisplayStylePlan();
Visual Basic
Public Function GetMatchLineMaskDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
MatchLineStyle Class, MatchLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MatchLineStyle::GetMatchLineMaskHatchDisplayStyle Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Methods > MatchLineStyle::GetMatchLineMaskHatchDisplayStyle Method
MatchLineStyle::GetMatchLineMaskHatchDisplayStyle Method
Collapse All

Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetMatchLineMaskHatchDisplayStyle();
Visual Basic
Public Function GetMatchLineMaskHatchDisplayStyle() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
MatchLineStyle Class, MatchLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MatchLineStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Properties
MatchLineStyle Properties
Collapse All

The properties of MatchLineStyle are listed here.

Public Properties
Public Property | Description
LinesDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match lines.
MatchLineMaskDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match line mask areas.
MatchLineMaskHatchDisplayStyle | Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.
Links
Public Properties


MatchLineStyle::LinesDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Properties > MatchLineStyle::LinesDisplayStylePlan Property
MatchLineStyle::LinesDisplayStylePlan Property deprecated
Collapse All

Gets the DisplayStyle that specifies plan display properties for the match lines.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle LinesDisplayStylePlan;
Visual Basic
Public Property LinesDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.MatchLineStyle.GetLinesDisplayStylePlan instead.

Links
MatchLineStyle Class, MatchLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MatchLineStyle::MatchLineMaskDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Properties > MatchLineStyle::MatchLineMaskDisplayStylePlan Property
MatchLineStyle::MatchLineMaskDisplayStylePlan Property deprecated
Collapse All

Gets the DisplayStyle that specifies plan display properties for the match line mask areas.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle MatchLineMaskDisplayStylePlan;
Visual Basic
Public Property MatchLineMaskDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.MatchLineStyle.GetMatchLineMaskDisplayStylePlan instead.

Links
MatchLineStyle Class, MatchLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


MatchLineStyle::MatchLineMaskHatchDisplayStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Properties > MatchLineStyle::MatchLineMaskHatchDisplayStyle Property
MatchLineStyle::MatchLineMaskHatchDisplayStyle Property deprecated
Collapse All

Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle MatchLineMaskHatchDisplayStyle;
Visual Basic
Public Property MatchLineMaskHatchDisplayStyle() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.MatchLineStyle.GetMatchLineMaskHatchDisplayStyle instead.

Links
MatchLineStyle Class, MatchLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ParcelStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class
ParcelStyle Class
Collapse All

The parcel style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ParcelStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbParcelStyle"))]
public class ParcelStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbParcelStyle"))>
Public Class ParcelStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
ParcelStyle Methods, ParcelStyle Properties, ParcelStyle Members, Class Hierarchy


ParcelStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Members
ParcelStyle Members
Collapse All

The following tables list the members exposed by ParcelStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetAreaFillHatchDisplayStyleModel | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle,... more
GetAreaFillHatchDisplayStylePlan | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle,... more
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the Parcel component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the Parcel component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
AreaFillHatchDisplayStyleModel | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle,... more
AreaFillHatchDisplayStylePlan | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle,... more
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
NameTemplate | Gets or sets the parcel name template string.
ObservePatternFillDistance | Gets or sets the boolean value that enables the use of the width of boundary area parcel setting, the offset... more
PatternFillDistance | Gets or sets the width of the boundary area parcel setting, which is the offset distance from the parcel boundary.... more
Links
Public Methods, Public Properties


ParcelStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Methods
ParcelStyle Methods
Collapse All

The methods of ParcelStyle are listed here.

Public Methods
Public Method | Description
GetAreaFillHatchDisplayStyleModel | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle,... more
GetAreaFillHatchDisplayStylePlan | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle,... more
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the Parcel component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the Parcel component.
Links
Public Methods


ParcelStyle::GetAreaFillHatchDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Methods > ParcelStyle::GetAreaFillHatchDisplayStyleModel Method
ParcelStyle::GetAreaFillHatchDisplayStyleModel Method
Collapse All

Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetAreaFillHatchDisplayStyleModel();
Visual Basic
Public Function GetAreaFillHatchDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
ParcelStyle Class, ParcelStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ParcelStyle::GetAreaFillHatchDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Methods > ParcelStyle::GetAreaFillHatchDisplayStylePlan Method
ParcelStyle::GetAreaFillHatchDisplayStylePlan Method
Collapse All

Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetAreaFillHatchDisplayStylePlan();
Visual Basic
Public Function GetAreaFillHatchDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
ParcelStyle Class, ParcelStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ParcelStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Methods > ParcelStyle::GetDisplayStyleModel Method
ParcelStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies model display properties for the Parcel component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    ParcelDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As ParcelDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ParcelStyle Class, ParcelStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ParcelStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Methods > ParcelStyle::GetDisplayStylePlan Method
ParcelStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the Parcel component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    ParcelDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As ParcelDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ParcelStyle Class, ParcelStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ParcelStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Properties
ParcelStyle Properties
Collapse All

The properties of ParcelStyle are listed here.

Public Properties
Public Property | Description
AreaFillHatchDisplayStyleModel | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle,... more
AreaFillHatchDisplayStylePlan | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle,... more
NameTemplate | Gets or sets the parcel name template string.
ObservePatternFillDistance | Gets or sets the boolean value that enables the use of the width of boundary area parcel setting, the offset... more
PatternFillDistance | Gets or sets the width of the boundary area parcel setting, which is the offset distance from the parcel boundary.... more
Links
Public Properties


ParcelStyle::AreaFillHatchDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Properties > ParcelStyle::AreaFillHatchDisplayStyleModel Property
ParcelStyle::AreaFillHatchDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle AreaFillHatchDisplayStyleModel;
Visual Basic
Public Property AreaFillHatchDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ParcelStyle.GetAreaFillHatchDisplayStyleModel instead.

Links
ParcelStyle Class, ParcelStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ParcelStyle::AreaFillHatchDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Properties > ParcelStyle::AreaFillHatchDisplayStylePlan Property
ParcelStyle::AreaFillHatchDisplayStylePlan Property deprecated
Collapse All

Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle AreaFillHatchDisplayStylePlan;
Visual Basic
Public Property AreaFillHatchDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ParcelStyle.GetAreaFillHatchDisplayStylePlan instead.

Links
ParcelStyle Class, ParcelStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ParcelStyle::NameTemplate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Properties > ParcelStyle::NameTemplate Property
ParcelStyle::NameTemplate Property
Collapse All

Gets or sets the parcel name template string.

C#
public System::String NameTemplate;
Visual Basic
Public Property NameTemplate() As System::String
Remarks

For example, '<[Parcel Style Name(CP)]> : <[Parcel Number]>'.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when The input string doesn't include the substring '<[Parcel Number]>'; The input string includes special symbols(*?/,").
Links
ParcelStyle Class, ParcelStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ParcelStyle::ObservePatternFillDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Properties > ParcelStyle::ObservePatternFillDistance Property
ParcelStyle::ObservePatternFillDistance Property
Collapse All

Gets or sets the boolean value that enables the use of the width of boundary area parcel setting, the offset distance from the parcel boundary.

C#
public bool ObservePatternFillDistance;
Visual Basic
Public Property ObservePatternFillDistance() As bool
Links
ParcelStyle Class, ParcelStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ParcelStyle::PatternFillDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Properties > ParcelStyle::PatternFillDistance Property
ParcelStyle::PatternFillDistance Property
Collapse All

Gets or sets the width of the boundary area parcel setting, which is the offset distance from the parcel boundary.

C#
public double PatternFillDistance;
Visual Basic
Public Property PatternFillDistance() As double
Remarks

Distance from parcel boundary which will be filled with a hatch pattern. Hatch pattern is selected on the display tab of the parcel style.

Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval (0.0, 1E24].
Links
ParcelStyle Class, ParcelStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class
PointStyle Class
Collapse All

The point style class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase
            Autodesk::Civil::Land::DatabaseServices::Styles::PointStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPointStyle"))]
public class PointStyle : Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPointStyle"))>
Public Class PointStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase
Links
PointStyle Methods, PointStyle Properties, PointStyle Members, Class Hierarchy


PointStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Members
PointStyle Members
Collapse All

The following tables list the members exposed by PointStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the point component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the point component.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the point component.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties for the point component.
GetLabelDisplayStyleModel | Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.
GetLabelDisplayStylePlan | Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
CustomMarkerStyle | Gets or sets a long value specifying a custom marker style.
CustomMarkerSuperimposeStyle | Gets or sets the CustomMarkerSuperimposeType enum value that specifies the shape superimposed on the custom point style marker as either... more
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Display3dType | Gets or sets the PointDisplay3dType enum value that specifies how the display elevation of the Points is established when view... more
Document | Gets the Document associated with the DBObject. Not implemented.
Elevation | Gets or sets the point's elevation if the points are to be flattened to an elevation.
LabelDisplayStyleModel | Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.
LabelDisplayStylePlan | Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
MarkerFixedScale | Gets or sets a fixed scale used to scale the point symbol.
MarkerRotationAngle | Gets or sets the marker's rotation angle.
MarkerSize | Gets or sets the marker size in drawing units.
MarkerSymbolName | Gets or sets a string value that represents the marker symbol block name.
MarkerType | Gets or sets the marker to an AutoCAD point, a customer mark, or a symbol.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Orientation | Gets or sets the MarkerOrientationType enum value that defines how the marker rotation angle is applied.
ScaleFactor | Gets or sets the scale factor for point elevations for when viewing in 3D.
SizeType | Gets or sets the MarkerSizeType enum value that defines how the marker is sized, such as relative to screen, fixed... more
Links
Public Methods, Public Properties


PointStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Methods
PointStyle Methods
Collapse All

The methods of PointStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the point component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the point component.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the point component.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties for the point component.
GetLabelDisplayStyleModel | Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.
GetLabelDisplayStylePlan | Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.
Links
Public Methods


PointStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Methods > PointStyle::GetDisplayStyleModel Method
PointStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies model display properties for the point component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    PointDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As PointDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Methods > PointStyle::GetDisplayStylePlan Method
PointStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the point component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    PointDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As PointDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::GetDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Methods > PointStyle::GetDisplayStyleProfile Method
PointStyle::GetDisplayStyleProfile Method
Collapse All

Gets the DisplayStyle object that specifies profile display properties for the point component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleProfile();
Visual Basic
Public Function GetDisplayStyleProfile() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Methods > PointStyle::GetDisplayStyleSection Method
PointStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle object that specifies section display properties for the point component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection();
Visual Basic
Public Function GetDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::GetLabelDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Methods > PointStyle::GetLabelDisplayStyleModel Method
PointStyle::GetLabelDisplayStyleModel Method
Collapse All

Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetLabelDisplayStyleModel();
Visual Basic
Public Function GetLabelDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::GetLabelDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Methods > PointStyle::GetLabelDisplayStylePlan Method
PointStyle::GetLabelDisplayStylePlan Method
Collapse All

Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetLabelDisplayStylePlan();
Visual Basic
Public Function GetLabelDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Properties
PointStyle Properties
Collapse All

The properties of PointStyle are listed here.

Public Properties
Public Property | Description
Display3dType | Gets or sets the PointDisplay3dType enum value that specifies how the display elevation of the Points is established when view... more
Elevation | Gets or sets the point's elevation if the points are to be flattened to an elevation.
LabelDisplayStyleModel | Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.
LabelDisplayStylePlan | Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.
MarkerType | Gets or sets the marker to an AutoCAD point, a customer mark, or a symbol.
ScaleFactor | Gets or sets the scale factor for point elevations for when viewing in 3D.
Links
Public Properties


PointStyle::Display3dType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Properties > PointStyle::Display3dType Property
PointStyle::Display3dType Property
Collapse All

Gets or sets the PointDisplay3dType enum value that specifies how the display elevation of the Points is established when view point3 in 3D.

C#
public PointDisplay3dType Display3dType;
Visual Basic
Public Property Display3dType() As PointDisplay3dType
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Properties > PointStyle::Elevation Property
PointStyle::Elevation Property
Collapse All

Gets or sets the point's elevation if the points are to be flattened to an elevation.

C#
public double Elevation;
Visual Basic
Public Property Elevation() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [-1E24, 1E24].
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::LabelDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Properties > PointStyle::LabelDisplayStyleModel Property
PointStyle::LabelDisplayStyleModel Property deprecated
Collapse All

Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle LabelDisplayStyleModel;
Visual Basic
Public Property LabelDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.PointStyle.GetLabelDisplayStyleModel instead.

Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::LabelDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Properties > PointStyle::LabelDisplayStylePlan Property
PointStyle::LabelDisplayStylePlan Property deprecated
Collapse All

Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle LabelDisplayStylePlan;
Visual Basic
Public Property LabelDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.PointStyle.GetLabelDisplayStylePlan instead.

Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::MarkerType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Properties > PointStyle::MarkerType Property
PointStyle::MarkerType Property
Collapse All

Gets or sets the marker to an AutoCAD point, a customer mark, or a symbol.

C#
public PointMarkerDisplayType MarkerType;
Visual Basic
Public Property MarkerType() As PointMarkerDisplayType
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


PointStyle::ScaleFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Properties > PointStyle::ScaleFactor Property
PointStyle::ScaleFactor Property
Collapse All

Gets or sets the scale factor for point elevations for when viewing in 3D.

C#
public double ScaleFactor;
Visual Basic
Public Property ScaleFactor() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval (0.0, 1E24].
Links
PointStyle Class, PointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class
ProfileDataBandStyle Class
Collapse All

The profile data band style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDataBandStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleProfileDataBands"))]
public class ProfileDataBandStyle : Autodesk::Civil::DatabaseServices::Styles::BandStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleProfileDataBands"))>
Public Class ProfileDataBandStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::BandStyle
Links
ProfileDataBandStyle Methods, ProfileDataBandStyle Properties, ProfileDataBandStyle Members, Class Hierarchy


ProfileDataBandStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Members
ProfileDataBandStyle Members
Collapse All

The following tables list the members exposed by ProfileDataBandStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the ProfileData component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
HGPLabelStyleId | Gets the band profile data label style id at the horizontal geometry point (HGP).
HGPTickStyle | Gets the band profile data tick style at the horizontal geometry point (HGP).
IncrementalDistanceLabelStyleId | Gets the band profile data label style id at the incremental distance.
MajorIncrementLabelStyleId | Gets the band profile data label style id at the major increment.
MajorIncrementTickStyle | Gets the band profile data tick style at the major increment.
MinorIncrementLabelStyleId | Gets the band profile data label style id at the minor increment.
MinorIncrementTickStyle | Gets the band profile data tick style at the minor increment.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
StationEquationLabelStyleId | Gets the band profile data label style id at the station equation.
StationEquationTickStyle | Gets the band profile data tick style at the station equation.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
VGPLabelStyleId | Gets the band profile data label style id at the vertical geometry point (VGP).
VGPTickStyle | Gets the band profile data tick style at the vertical geometry point (VGP).
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Methods, Public Properties


ProfileDataBandStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Methods
ProfileDataBandStyle Methods
Collapse All

The methods of ProfileDataBandStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the ProfileData component.
Links
Public Methods


ProfileDataBandStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Methods > ProfileDataBandStyle::GetDisplayStylePlan Method
ProfileDataBandStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the ProfileData component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    ProfileDataDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As ProfileDataDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties
ProfileDataBandStyle Properties
Collapse All

The properties of ProfileDataBandStyle are listed here.

Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
HGPLabelStyleId | Gets the band profile data label style id at the horizontal geometry point (HGP).
HGPTickStyle | Gets the band profile data tick style at the horizontal geometry point (HGP).
IncrementalDistanceLabelStyleId | Gets the band profile data label style id at the incremental distance.
MajorIncrementLabelStyleId | Gets the band profile data label style id at the major increment.
MajorIncrementTickStyle | Gets the band profile data tick style at the major increment.
MinorIncrementLabelStyleId | Gets the band profile data label style id at the minor increment.
MinorIncrementTickStyle | Gets the band profile data tick style at the minor increment.
StationEquationLabelStyleId | Gets the band profile data label style id at the station equation.
StationEquationTickStyle | Gets the band profile data tick style at the station equation.
TitleTextLabelStyleId | Gets the band profile data title text label style.
VGPLabelStyleId | Gets the band profile data label style id at the vertical geometry point (VGP).
VGPTickStyle | Gets the band profile data tick style at the vertical geometry point (VGP).
Links
Public Properties


ProfileDataBandStyle::BandType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::BandType Property
ProfileDataBandStyle::BandType Property
Collapse All

Gets the BandStyleType enum value that specifies the type of data band data.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandStyleType BandType;
Visual Basic
Public Property BandType() As Autodesk::Civil::DatabaseServices::Styles::BandStyleType
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::HGPLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::HGPLabelStyleId Property
ProfileDataBandStyle::HGPLabelStyleId Property
Collapse All

Gets the band profile data label style id at the horizontal geometry point (HGP).

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId HGPLabelStyleId;
Visual Basic
Public Property HGPLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::HGPTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::HGPTickStyle Property
ProfileDataBandStyle::HGPTickStyle Property
Collapse All

Gets the band profile data tick style at the horizontal geometry point (HGP).

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle HGPTickStyle;
Visual Basic
Public Property HGPTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::IncrementalDistanceLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::IncrementalDistanceLabelStyleId Property
ProfileDataBandStyle::IncrementalDistanceLabelStyleId Property
Collapse All

Gets the band profile data label style id at the incremental distance.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId IncrementalDistanceLabelStyleId;
Visual Basic
Public Property IncrementalDistanceLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::MajorIncrementLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::MajorIncrementLabelStyleId Property
ProfileDataBandStyle::MajorIncrementLabelStyleId Property
Collapse All

Gets the band profile data label style id at the major increment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MajorIncrementLabelStyleId;
Visual Basic
Public Property MajorIncrementLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::MajorIncrementTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::MajorIncrementTickStyle Property
ProfileDataBandStyle::MajorIncrementTickStyle Property
Collapse All

Gets the band profile data tick style at the major increment.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle MajorIncrementTickStyle;
Visual Basic
Public Property MajorIncrementTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::MinorIncrementLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::MinorIncrementLabelStyleId Property
ProfileDataBandStyle::MinorIncrementLabelStyleId Property
Collapse All

Gets the band profile data label style id at the minor increment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MinorIncrementLabelStyleId;
Visual Basic
Public Property MinorIncrementLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::MinorIncrementTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::MinorIncrementTickStyle Property
ProfileDataBandStyle::MinorIncrementTickStyle Property
Collapse All

Gets the band profile data tick style at the minor increment.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle MinorIncrementTickStyle;
Visual Basic
Public Property MinorIncrementTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::StationEquationLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::StationEquationLabelStyleId Property
ProfileDataBandStyle::StationEquationLabelStyleId Property
Collapse All

Gets the band profile data label style id at the station equation.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StationEquationLabelStyleId;
Visual Basic
Public Property StationEquationLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::StationEquationTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::StationEquationTickStyle Property
ProfileDataBandStyle::StationEquationTickStyle Property
Collapse All

Gets the band profile data tick style at the station equation.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle StationEquationTickStyle;
Visual Basic
Public Property StationEquationTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::TitleTextLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::TitleTextLabelStyleId Property
ProfileDataBandStyle::TitleTextLabelStyleId Property
Collapse All

Gets the band profile data title text label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TitleTextLabelStyleId;
Visual Basic
Public Property TitleTextLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::VGPLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::VGPLabelStyleId Property
ProfileDataBandStyle::VGPLabelStyleId Property
Collapse All

Gets the band profile data label style id at the vertical geometry point (VGP).

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId VGPLabelStyleId;
Visual Basic
Public Property VGPLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDataBandStyle::VGPTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties > ProfileDataBandStyle::VGPTickStyle Property
ProfileDataBandStyle::VGPTickStyle Property
Collapse All

Gets the band profile data tick style at the vertical geometry point (VGP).

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle VGPTickStyle;
Visual Basic
Public Property VGPTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
ProfileDataBandStyle Class, ProfileDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSet Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class
ProfileDesignCheckSet Class
Collapse All

A collection of profile design checks, which can be applied to an alignment.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSet
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSet
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignmentDesignCheckSet"))]
public class ProfileDesignCheckSet : AlignmentDesignCheckSet;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignmentDesignCheckSet"))>
Public Class ProfileDesignCheckSet
Inherits AlignmentDesignCheckSet
Links
ProfileDesignCheckSet Methods, ProfileDesignCheckSet Members, Class Hierarchy


ProfileDesignCheckSet Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Members
ProfileDesignCheckSet Members
Collapse All

The following tables list the members exposed by ProfileDesignCheckSet.

Public Methods
Public Method | Description
AddDesignCheck | Overloaded
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetAllDesignChecks | Gets all design checks in this ProfileDesignCheckSet.
GetCurveDesignCheckType | This function will get the curve design check type.
RemoveAllDesignCheck | Remove all design checks from this ProfileDesignCheckSet.
RemoveDesignCheck | Overloaded
RemoveDesignCheck | Overloaded
SetCurveDesignCheckType | This function will set the curve design check type.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


ProfileDesignCheckSet Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods
ProfileDesignCheckSet Methods
Collapse All

The methods of ProfileDesignCheckSet are listed here.

Public Methods
Public Method | Description
AddDesignCheck | Overloaded
GetAllDesignChecks | Gets all design checks in this ProfileDesignCheckSet.
GetCurveDesignCheckType | This function will get the curve design check type.
RemoveAllDesignCheck | Remove all design checks from this ProfileDesignCheckSet.
RemoveDesignCheck | Overloaded
SetCurveDesignCheckType | This function will set the curve design check type.
Links
Public Methods


AddDesignCheck Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > AddDesignCheck Method
AddDesignCheck Method
Collapse All

Overloaded

Overload List
Method | Description
ProfileDesignCheckSet::AddDesignCheck (AlignmentDesignCheckType, System::String^) | This function is just used to override the base class's function, and will be removed in MadRiver version.
ProfileDesignCheckSet::AddDesignCheck (ProfileDesignCheckType, System::String^) | Add one design check into this ProfileDesignCheckSet.


ProfileDesignCheckSet::AddDesignCheck Method (AlignmentDesignCheckType, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > AddDesignCheck Method > ProfileDesignCheckSet::AddDesignCheck Method (AlignmentDesignCheckType, System::String^)
ProfileDesignCheckSet::AddDesignCheck Method (AlignmentDesignCheckType, System::String^)
Collapse All

This function is just used to override the base class's function, and will be removed in MadRiver version.

C#
public AlignmentDesignCheck AddDesignCheck(
    AlignmentDesignCheckType type,
    ref System::String name
);
Visual Basic
Public Function AddDesignCheck(
    type As AlignmentDesignCheckType,
    ByRef name As System::String
) As AlignmentDesignCheck
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSet::AddDesignCheck Method (ProfileDesignCheckType, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > AddDesignCheck Method > ProfileDesignCheckSet::AddDesignCheck Method (ProfileDesignCheckType, System::String^)
ProfileDesignCheckSet::AddDesignCheck Method (ProfileDesignCheckType, System::String^)
Collapse All

Add one design check into this ProfileDesignCheckSet.

C#
public ProfileDesignCheck AddDesignCheck(
    ProfileDesignCheckType type,
    ref System::String name
);
Visual Basic
Public Function AddDesignCheck(
    type As ProfileDesignCheckType,
    ByRef name As System::String
) As ProfileDesignCheck
Parameters
Parameters | Description
type | The type of design check.
name | The name of design check.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when: 1: The specified design check has been added; 2: The specified design check is not exist.
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSet::GetAllDesignChecks Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > ProfileDesignCheckSet::GetAllDesignChecks Method
ProfileDesignCheckSet::GetAllDesignChecks Method
Collapse All

Gets all design checks in this ProfileDesignCheckSet.

C#
public array<ProfileDesignCheck^> GetAllDesignChecks();
Visual Basic
Public Function GetAllDesignChecks() As array<ProfileDesignCheck^>
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSet::GetCurveDesignCheckType Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > ProfileDesignCheckSet::GetCurveDesignCheckType Method
ProfileDesignCheckSet::GetCurveDesignCheckType Method
Collapse All

This function will get the curve design check type.

C#
public ProfileDesignCheckCurveType GetCurveDesignCheckType(
    ref System::String name
);
Visual Basic
Public Function GetCurveDesignCheckType(
    ByRef name As System::String
) As ProfileDesignCheckCurveType
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when: 1: The type of design check with specified name is not curve. 2: The design check with specified name is not in this design check set.
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSet::RemoveAllDesignCheck Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > ProfileDesignCheckSet::RemoveAllDesignCheck Method
ProfileDesignCheckSet::RemoveAllDesignCheck Method
Collapse All

Remove all design checks from this ProfileDesignCheckSet.

C#
public RemoveAllDesignCheck();
Visual Basic
Public Sub RemoveAllDesignCheck()
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


RemoveDesignCheck Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > RemoveDesignCheck Method
RemoveDesignCheck Method
Collapse All

Overloaded

Overload List
Method | Description
ProfileDesignCheckSet::RemoveDesignCheck (AlignmentDesignCheck^) | This function is just used to override the base class's function, and will be removed in MadRiver version.
ProfileDesignCheckSet::RemoveDesignCheck (AlignmentDesignCheckType, System::String^) | This function is just used to override the base class's function, and will be removed in MadRiver version.
ProfileDesignCheckSet::RemoveDesignCheck (ProfileDesignCheck^) | Remove one design check from this ProfileDesignCheckSet.
ProfileDesignCheckSet::RemoveDesignCheck (ProfileDesignCheckType, System::String^) | Remove one design check from this ProfileDesignCheckSet.


ProfileDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheckType, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > RemoveDesignCheck Method > ProfileDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheckType, System::String^)
ProfileDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheckType, System::String^)
Collapse All

This function is just used to override the base class's function, and will be removed in MadRiver version.

C#
public RemoveDesignCheck(
    AlignmentDesignCheckType type,
    ref System::String name
);
Visual Basic
Public Sub RemoveDesignCheck(
    type As AlignmentDesignCheckType,
    ByRef name As System::String
)
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheck^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > RemoveDesignCheck Method > ProfileDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheck^)
ProfileDesignCheckSet::RemoveDesignCheck Method (AlignmentDesignCheck^)
Collapse All

This function is just used to override the base class's function, and will be removed in MadRiver version.

C#
public RemoveDesignCheck(
    ref AlignmentDesignCheck type
);
Visual Basic
Public Sub RemoveDesignCheck(
    ByRef type As AlignmentDesignCheck
)
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSet::RemoveDesignCheck Method (ProfileDesignCheckType, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > RemoveDesignCheck Method > ProfileDesignCheckSet::RemoveDesignCheck Method (ProfileDesignCheckType, System::String^)
ProfileDesignCheckSet::RemoveDesignCheck Method (ProfileDesignCheckType, System::String^)
Collapse All

Remove one design check from this ProfileDesignCheckSet.

C#
public RemoveDesignCheck(
    ProfileDesignCheckType type,
    ref System::String name
);
Visual Basic
Public Sub RemoveDesignCheck(
    type As ProfileDesignCheckType,
    ByRef name As System::String
)
Parameters
Parameters | Description
type | The type of design check.
name | The name of design check.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified design check is not exist.
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSet::RemoveDesignCheck Method (ProfileDesignCheck^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > RemoveDesignCheck Method > ProfileDesignCheckSet::RemoveDesignCheck Method (ProfileDesignCheck^)
ProfileDesignCheckSet::RemoveDesignCheck Method (ProfileDesignCheck^)
Collapse All

Remove one design check from this ProfileDesignCheckSet.

C#
public RemoveDesignCheck(
    ref ProfileDesignCheck designCheck
);
Visual Basic
Public Sub RemoveDesignCheck(
    ByRef designCheck As ProfileDesignCheck
)
Parameters
Parameters | Description
designCheck | The design check needed to be removed.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified design check is not exist.
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSet::SetCurveDesignCheckType Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods > ProfileDesignCheckSet::SetCurveDesignCheckType Method
ProfileDesignCheckSet::SetCurveDesignCheckType Method
Collapse All

This function will set the curve design check type.

C#
public SetCurveDesignCheckType(
    ref System::String name,
    ProfileDesignCheckCurveType type
);
Visual Basic
Public Sub SetCurveDesignCheckType(
    ByRef name As System::String,
    type As ProfileDesignCheckCurveType
)
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when: 1: The type of design check with specified name is not curve. 2: The design check with specified name is not in this design check set.
Links
ProfileDesignCheckSet Class, ProfileDesignCheckSet Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileDesignCheckSetCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class
ProfileDesignCheckSetCollection Class
Collapse All

The AlignmentStyleCollection class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSetCollection
C#
public class ProfileDesignCheckSetCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class ProfileDesignCheckSetCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
ProfileDesignCheckSetCollection Methods, ProfileDesignCheckSetCollection Members, Class Hierarchy


ProfileDesignCheckSetCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class > ProfileDesignCheckSetCollection Members
ProfileDesignCheckSetCollection Members
Collapse All

The following tables list the members exposed by ProfileDesignCheckSetCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


ProfileDesignCheckSetCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class > ProfileDesignCheckSetCollection Methods
ProfileDesignCheckSetCollection Methods
Collapse All

The methods of ProfileDesignCheckSetCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


ProfileDesignCheckSetCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class > ProfileDesignCheckSetCollection Methods > ProfileDesignCheckSetCollection::Add Method
ProfileDesignCheckSetCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
ProfileDesignCheckSetCollection Class, ProfileDesignCheckSetCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileLabelSetStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class
ProfileLabelSetStyle Class
Collapse All

The profile lable set wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileLabelSetStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignStnLabelsDlgTemplate"))]
public class ProfileLabelSetStyle : Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetStyle, System::Collections::Generic::IEnumerable<ProfileLabelSetItem^>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignStnLabelsDlgTemplate"))>
Public Class ProfileLabelSetStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetStyle
Inherits System::Collections::Generic::IEnumerable<ProfileLabelSetItem^>
Links
ProfileLabelSetStyle Methods, ProfileLabelSetStyle Properties, ProfileLabelSetStyle Members, Class Hierarchy


ProfileLabelSetStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Members
ProfileLabelSetStyle Members
Collapse All

The following tables list the members exposed by ProfileLabelSetStyle.

Public Methods
Public Method | Description
Add | Overloaded
AddCrestCurve | Creates a label set item of type profile crest curve with the given profile curve object id, adds it to... more
AddSagCurve | Creates a label set item of type profile sag curve with the given profile curve object id, adds it to... more
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an label set item from the collection.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the number of label set items.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the profile label set item at the given index.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


ProfileLabelSetStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Methods
ProfileLabelSetStyle Methods
Collapse All

The methods of ProfileLabelSetStyle are listed here.

Public Methods
Public Method | Description
AddCrestCurve | Creates a label set item of type profile crest curve with the given profile curve object id, adds it to... more
AddSagCurve | Creates a label set item of type profile sag curve with the given profile curve object id, adds it to... more
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Links
Public Methods


ProfileLabelSetStyle::AddCrestCurve Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Methods > ProfileLabelSetStyle::AddCrestCurve Method
ProfileLabelSetStyle::AddCrestCurve Method
Collapse All

Creates a label set item of type profile crest curve with the given profile curve object id, adds it to the collection.

C#
public AddCrestCurve(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Sub AddCrestCurve(
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
labelStyleId | The object id of profile curve label style.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a profile curve label style.
Links
ProfileLabelSetStyle Class, ProfileLabelSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileLabelSetStyle::AddSagCurve Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Methods > ProfileLabelSetStyle::AddSagCurve Method
ProfileLabelSetStyle::AddSagCurve Method
Collapse All

Creates a label set item of type profile sag curve with the given profile curve object id, adds it to the collection.

C#
public AddSagCurve(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Sub AddSagCurve(
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
labelStyleId | The object id of profile curve label style.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a profile curve label style.
Links
ProfileLabelSetStyle Class, ProfileLabelSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileLabelSetStyle::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Methods > ProfileLabelSetStyle::GetEnumerator Method
ProfileLabelSetStyle::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<ProfileLabelSetItem^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<ProfileLabelSetItem^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
ProfileLabelSetStyle Class, ProfileLabelSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileLabelSetStyle::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Methods > ProfileLabelSetStyle::GetObjectEnumerator Method
ProfileLabelSetStyle::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileLabelSetStyle Class, ProfileLabelSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileLabelSetStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Properties
ProfileLabelSetStyle Properties
Collapse All

The properties of ProfileLabelSetStyle are listed here.

Public Properties
Public Property | Description
default | Gets the profile label set item at the given index.
Links
Public Properties


ProfileLabelSetStyle::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Properties > ProfileLabelSetStyle::default Property
ProfileLabelSetStyle::default Property
Collapse All

Gets the profile label set item at the given index.

C#
public ProfileLabelSetItem default;
Visual Basic
Public Property default() As ProfileLabelSetItem
Parameters
Parameters | Description
index | Specified the profile label set item by index.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the collection's range.
Links
ProfileLabelSetStyle Class, ProfileLabelSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class
ProfileStyle Class
Collapse All

The profile style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignmentStyle"))]
public class ProfileStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignmentStyle"))>
Public Class ProfileStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
ProfileStyle Methods, ProfileStyle Properties, ProfileStyle Members, Class Hierarchy


ProfileStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Members
ProfileStyle Members
Collapse All

The following tables list the members exposed by ProfileStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetChain3DDisplayStyleModel | Gets the AeccDisplayStyle for 3D chain display style in model view orientation.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the Profile component.
GetProfileMarkerDisplayStyleSection | Gets the AeccDisplayStyle for marker display style in section view orientation.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
ArrowHeadOption | Gets the profile arrow head option.
BeginPointMarkerStyle | Gets or sets the marker style object id for 'Begin point' on the profile.
Chain3DDisplayStyleModel | Gets the AeccDisplayStyle for 3D chain display style in model view orientation.
ChainTessellationDistance3D | Gets or sets the curve tessellation distance used for 3D chain visualization.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
EndPointMarkerStyle | Gets or sets the marker style object id for 'End point' on the profile
HighPointMarkerStyle | Gets or sets the marker style object id for 'High Point' on the profile
LowPointMarkerStyle | Gets or sets the marker style object id for 'Low Point' on the profile
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ProfileMarkerDisplayStyleSection | Gets the AeccDisplayStyle for marker display style in section view orientation.
ProfileMarkerSectionViewMarkerStyle | Gets or sets the marker style object id for 'Section View' on the profile
ThroughPointMarkerStyle | Gets or sets the marker style object id for 'Through points' on the profile.
VCompoundCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Compound Curve Intersection' on the profile
VCurveTangentIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Curve Tangent intersection' on the profile
VIntersectionPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Intersection' on the profile.
VReverseCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Reverse Curve Intersection' on the profile
VTangentCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Tangent Curve Intersection' on the profile
Links
Public Methods, Public Properties


ProfileStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Methods
ProfileStyle Methods
Collapse All

The methods of ProfileStyle are listed here.

Public Methods
Public Method | Description
GetChain3DDisplayStyleModel | Gets the AeccDisplayStyle for 3D chain display style in model view orientation.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the Profile component.
GetProfileMarkerDisplayStyleSection | Gets the AeccDisplayStyle for marker display style in section view orientation.
Links
Public Methods


ProfileStyle::GetChain3DDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Methods > ProfileStyle::GetChain3DDisplayStyleModel Method
ProfileStyle::GetChain3DDisplayStyleModel Method
Collapse All

Gets the AeccDisplayStyle for 3D chain display style in model view orientation.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetChain3DDisplayStyleModel();
Visual Basic
Public Function GetChain3DDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::GetDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Methods > ProfileStyle::GetDisplayStyleProfile Method
ProfileStyle::GetDisplayStyleProfile Method
Collapse All

Gets the DisplayStyle object that specifies profile display properties for the Profile component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleProfile(
    ProfileDisplayStyleProfileType type
);
Visual Basic
Public Function GetDisplayStyleProfile(
    type As ProfileDisplayStyleProfileType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::GetProfileMarkerDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Methods > ProfileStyle::GetProfileMarkerDisplayStyleSection Method
ProfileStyle::GetProfileMarkerDisplayStyleSection Method
Collapse All

Gets the AeccDisplayStyle for marker display style in section view orientation.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetProfileMarkerDisplayStyleSection();
Visual Basic
Public Function GetProfileMarkerDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties
ProfileStyle Properties
Collapse All

The properties of ProfileStyle are listed here.

Public Properties
Public Property | Description
ArrowHeadOption | Gets the profile arrow head option.
BeginPointMarkerStyle | Gets or sets the marker style object id for 'Begin point' on the profile.
Chain3DDisplayStyleModel | Gets the AeccDisplayStyle for 3D chain display style in model view orientation.
ChainTessellationDistance3D | Gets or sets the curve tessellation distance used for 3D chain visualization.
EndPointMarkerStyle | Gets or sets the marker style object id for 'End point' on the profile
HighPointMarkerStyle | Gets or sets the marker style object id for 'High Point' on the profile
LowPointMarkerStyle | Gets or sets the marker style object id for 'Low Point' on the profile
ProfileMarkerDisplayStyleSection | Gets the AeccDisplayStyle for marker display style in section view orientation.
ProfileMarkerSectionViewMarkerStyle | Gets or sets the marker style object id for 'Section View' on the profile
ThroughPointMarkerStyle | Gets or sets the marker style object id for 'Through points' on the profile.
VCompoundCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Compound Curve Intersection' on the profile
VCurveTangentIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Curve Tangent intersection' on the profile
VIntersectionPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Intersection' on the profile.
VReverseCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Reverse Curve Intersection' on the profile
VTangentCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Tangent Curve Intersection' on the profile
Links
Public Properties


ProfileStyle::ArrowHeadOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::ArrowHeadOption Property
ProfileStyle::ArrowHeadOption Property
Collapse All

Gets the profile arrow head option.

C#
public Autodesk::Civil::Land::DatabaseServices::Styles::ArrowHeadOption ArrowHeadOption;
Visual Basic
Public Property ArrowHeadOption() As Autodesk::Civil::Land::DatabaseServices::Styles::ArrowHeadOption
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::BeginPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::BeginPointMarkerStyle Property
ProfileStyle::BeginPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'Begin point' on the profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId BeginPointMarkerStyle;
Visual Basic
Public Property BeginPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::Chain3DDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::Chain3DDisplayStyleModel Property
ProfileStyle::Chain3DDisplayStyleModel Property deprecated
Collapse All

Gets the AeccDisplayStyle for 3D chain display style in model view orientation.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle Chain3DDisplayStyleModel;
Visual Basic
Public Property Chain3DDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ProfileStyle.GetChain3DDisplayStyleModel instead.

Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::ChainTessellationDistance3D Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::ChainTessellationDistance3D Property
ProfileStyle::ChainTessellationDistance3D Property
Collapse All

Gets or sets the curve tessellation distance used for 3D chain visualization.

C#
public double ChainTessellationDistance3D;
Visual Basic
Public Property ChainTessellationDistance3D() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when input value <0 or >= 1E+024
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::EndPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::EndPointMarkerStyle Property
ProfileStyle::EndPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'End point' on the profile

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId EndPointMarkerStyle;
Visual Basic
Public Property EndPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::HighPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::HighPointMarkerStyle Property
ProfileStyle::HighPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'High Point' on the profile

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId HighPointMarkerStyle;
Visual Basic
Public Property HighPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::LowPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::LowPointMarkerStyle Property
ProfileStyle::LowPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'Low Point' on the profile

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LowPointMarkerStyle;
Visual Basic
Public Property LowPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::ProfileMarkerDisplayStyleSection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::ProfileMarkerDisplayStyleSection Property
ProfileStyle::ProfileMarkerDisplayStyleSection Property deprecated
Collapse All

Gets the AeccDisplayStyle for marker display style in section view orientation.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle ProfileMarkerDisplayStyleSection;
Visual Basic
Public Property ProfileMarkerDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ProfileStyle.GetProfileMarkerDisplayStyleSection instead.

Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::ProfileMarkerSectionViewMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::ProfileMarkerSectionViewMarkerStyle Property
ProfileStyle::ProfileMarkerSectionViewMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'Section View' on the profile

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileMarkerSectionViewMarkerStyle;
Visual Basic
Public Property ProfileMarkerSectionViewMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::ThroughPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::ThroughPointMarkerStyle Property
ProfileStyle::ThroughPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'Through points' on the profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ThroughPointMarkerStyle;
Visual Basic
Public Property ThroughPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::VCompoundCurveIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::VCompoundCurveIntersectPointMarkerStyle Property
ProfileStyle::VCompoundCurveIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'Point of Vertical Compound Curve Intersection' on the profile

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId VCompoundCurveIntersectPointMarkerStyle;
Visual Basic
Public Property VCompoundCurveIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::VCurveTangentIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::VCurveTangentIntersectPointMarkerStyle Property
ProfileStyle::VCurveTangentIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'Point of Curve Tangent intersection' on the profile

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId VCurveTangentIntersectPointMarkerStyle;
Visual Basic
Public Property VCurveTangentIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::VIntersectionPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::VIntersectionPointMarkerStyle Property
ProfileStyle::VIntersectionPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'Point of Vertical Intersection' on the profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId VIntersectionPointMarkerStyle;
Visual Basic
Public Property VIntersectionPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::VReverseCurveIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::VReverseCurveIntersectPointMarkerStyle Property
ProfileStyle::VReverseCurveIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'Point of Reverse Curve Intersection' on the profile

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId VReverseCurveIntersectPointMarkerStyle;
Visual Basic
Public Property VReverseCurveIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileStyle::VTangentCurveIntersectPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties > ProfileStyle::VTangentCurveIntersectPointMarkerStyle Property
ProfileStyle::VTangentCurveIntersectPointMarkerStyle Property
Collapse All

Gets or sets the marker style object id for 'Point of Vertical Tangent Curve Intersection' on the profile

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId VTangentCurveIntersectPointMarkerStyle;
Visual Basic
Public Property VTangentCurveIntersectPointMarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ProfileStyle Class, ProfileStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class
ProfileViewBandSetItem Class
Collapse All

The profile view band set item wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItem
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetItem
C#
public class ProfileViewBandSetItem : Autodesk::Civil::DatabaseServices::Styles::BandSetItem;
Visual Basic
Public Class ProfileViewBandSetItem
Inherits Autodesk::Civil::DatabaseServices::Styles::BandSetItem
Links
ProfileViewBandSetItem Methods, ProfileViewBandSetItem Properties, ProfileViewBandSetItem Members, Class Hierarchy


ProfileViewBandSetItem Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Members
ProfileViewBandSetItem Members
Collapse All

The following tables list the members exposed by ProfileViewBandSetItem.

Public Methods
Public Method | Description
GetAlignmentGeometryPoints | Gets the alignment geometry points from profile data bands.
GetProfileGeometryPoints | Gets the profile geometry points from profile data bands.
SetAlignmentGeometryPoints | Sets the alignment geometry points from profile data bands.
SetProfileGeometryPoints | Sets the profile geometry points from profile data bands.
Public Properties
Public Property | Description
BandStyleId | Gets the object that identifies the style for the band type.
Gap | Gets or sets the distance between the current data band and the adjacent grid or data band.
LabelAtEndStation | Gets or sets the label at end station.
LabelAtStartStation | Gets or sets the label at start station.
Location | Gets the BandSetOptionsType enum value that identifies band location and display settings.
MajorInterval | Gets or sets the d view data band major interval distance.
MinorInterval | Gets or sets the section view data band minor interval distance.
StaggerLabel | Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor... more
StaggerLineHeight | Gets or sets height of the label stagger line.
Weeding | Gets or sets the weeding value.
Links
Public Methods, Public Properties


ProfileViewBandSetItem Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Methods
ProfileViewBandSetItem Methods
Collapse All

The methods of ProfileViewBandSetItem are listed here.

Public Methods
Public Method | Description
GetAlignmentGeometryPoints | Gets the alignment geometry points from profile data bands.
GetProfileGeometryPoints | Gets the profile geometry points from profile data bands.
SetAlignmentGeometryPoints | Sets the alignment geometry points from profile data bands.
SetProfileGeometryPoints | Sets the profile geometry points from profile data bands.
Links
Public Methods


ProfileViewBandSetItem::GetAlignmentGeometryPoints Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Methods > ProfileViewBandSetItem::GetAlignmentGeometryPoints Method
ProfileViewBandSetItem::GetAlignmentGeometryPoints Method
Collapse All

Gets the alignment geometry points from profile data bands.

C#
public array<AlignmentPointType> GetAlignmentGeometryPoints();
Visual Basic
Public Function GetAlignmentGeometryPoints() As array<AlignmentPointType>
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem::GetProfileGeometryPoints Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Methods > ProfileViewBandSetItem::GetProfileGeometryPoints Method
ProfileViewBandSetItem::GetProfileGeometryPoints Method
Collapse All

Gets the profile geometry points from profile data bands.

C#
public array<ProfilePointType> GetProfileGeometryPoints();
Visual Basic
Public Function GetProfileGeometryPoints() As array<ProfilePointType>
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem::SetAlignmentGeometryPoints Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Methods > ProfileViewBandSetItem::SetAlignmentGeometryPoints Method
ProfileViewBandSetItem::SetAlignmentGeometryPoints Method
Collapse All

Sets the alignment geometry points from profile data bands.

C#
public SetAlignmentGeometryPoints(
    ref array<AlignmentPointType> pointTypes
);
Visual Basic
Public Sub SetAlignmentGeometryPoints(
    ByRef pointTypes As array<AlignmentPointType>
)
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem::SetProfileGeometryPoints Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Methods > ProfileViewBandSetItem::SetProfileGeometryPoints Method
ProfileViewBandSetItem::SetProfileGeometryPoints Method
Collapse All

Sets the profile geometry points from profile data bands.

C#
public SetProfileGeometryPoints(
    ref array<ProfilePointType> pointTypes
);
Visual Basic
Public Sub SetProfileGeometryPoints(
    ByRef pointTypes As array<ProfilePointType>
)
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Properties
ProfileViewBandSetItem Properties
Collapse All

The properties of ProfileViewBandSetItem are listed here.

Public Properties
Public Property | Description
LabelAtEndStation | Gets or sets the label at end station.
LabelAtStartStation | Gets or sets the label at start station.
MajorInterval | Gets or sets the d view data band major interval distance.
MinorInterval | Gets or sets the section view data band minor interval distance.
StaggerLabel | Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor... more
StaggerLineHeight | Gets or sets height of the label stagger line.
Links
Public Properties


ProfileViewBandSetItem::LabelAtEndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Properties > ProfileViewBandSetItem::LabelAtEndStation Property
ProfileViewBandSetItem::LabelAtEndStation Property
Collapse All

Gets or sets the label at end station.

C#
public bool LabelAtEndStation;
Visual Basic
Public Property LabelAtEndStation() As bool
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem::LabelAtStartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Properties > ProfileViewBandSetItem::LabelAtStartStation Property
ProfileViewBandSetItem::LabelAtStartStation Property
Collapse All

Gets or sets the label at start station.

C#
public bool LabelAtStartStation;
Visual Basic
Public Property LabelAtStartStation() As bool
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem::MajorInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Properties > ProfileViewBandSetItem::MajorInterval Property
ProfileViewBandSetItem::MajorInterval Property
Collapse All

Gets or sets the d view data band major interval distance.

C#
public double MajorInterval;
Visual Basic
Public Property MajorInterval() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when MatchIncreament is false.
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem::MinorInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Properties > ProfileViewBandSetItem::MinorInterval Property
ProfileViewBandSetItem::MinorInterval Property
Collapse All

Gets or sets the section view data band minor interval distance.

C#
public double MinorInterval;
Visual Basic
Public Property MinorInterval() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when MatchIncreament is false.
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem::StaggerLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Properties > ProfileViewBandSetItem::StaggerLabel Property
ProfileViewBandSetItem::StaggerLabel Property
Collapse All

Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor grid spacing intervals. Select the checkbox to match major/minor increments to vertical grid intervals.

C#
public Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType StaggerLabel;
Visual Basic
Public Property StaggerLabel() As Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the band style type is not profile data.
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetItem::StaggerLineHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Properties > ProfileViewBandSetItem::StaggerLineHeight Property
ProfileViewBandSetItem::StaggerLineHeight Property
Collapse All

Gets or sets height of the label stagger line.

C#
public double StaggerLineHeight;
Visual Basic
Public Property StaggerLineHeight() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the band style type is not profile data.
Links
ProfileViewBandSetItem Class, ProfileViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class
ProfileViewBandSetStyle Class
Collapse All

A collection of ProfileViewBandSetItemCollection objects for profile view band set styles.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphProfileBandStyleSet"))]
public class ProfileViewBandSetStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphProfileBandStyleSet"))>
Public Class ProfileViewBandSetStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
ProfileViewBandSetStyle Properties, ProfileViewBandSetStyle Members, Class Hierarchy


ProfileViewBandSetStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Members
ProfileViewBandSetStyle Members
Collapse All

The following tables list the members exposed by ProfileViewBandSetStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomBandSetItems | Gets the bottom band set item collection from profile view band set style.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MatchIncrement | Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor... more
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
TopBandSetItems | Gets the top band set item collection from profile view band set style.
Links
Public Methods, Public Properties


ProfileViewBandSetStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Properties
ProfileViewBandSetStyle Properties
Collapse All

The properties of ProfileViewBandSetStyle are listed here.

Public Properties
Public Property | Description
BottomBandSetItems | Gets the bottom band set item collection from profile view band set style.
MatchIncrement | Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor... more
TopBandSetItems | Gets the top band set item collection from profile view band set style.
Links
Public Properties


ProfileViewBandSetStyle::BottomBandSetItems Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Properties > ProfileViewBandSetStyle::BottomBandSetItems Property
ProfileViewBandSetStyle::BottomBandSetItems Property
Collapse All

Gets the bottom band set item collection from profile view band set style.

C#
public ProfileViewBandSetItemCollection BottomBandSetItems;
Visual Basic
Public Property BottomBandSetItems() As ProfileViewBandSetItemCollection
Links
ProfileViewBandSetStyle Class, ProfileViewBandSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetStyle::MatchIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Properties > ProfileViewBandSetStyle::MatchIncrement Property
ProfileViewBandSetStyle::MatchIncrement Property
Collapse All

Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor grid spacing intervals. Set to true to match major/minor increments to vertical grid intervals.

C#
public bool MatchIncrement;
Visual Basic
Public Property MatchIncrement() As bool
Links
ProfileViewBandSetStyle Class, ProfileViewBandSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewBandSetStyle::TopBandSetItems Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Properties > ProfileViewBandSetStyle::TopBandSetItems Property
ProfileViewBandSetStyle::TopBandSetItems Property
Collapse All

Gets the top band set item collection from profile view band set style.

C#
public ProfileViewBandSetItemCollection TopBandSetItems;
Visual Basic
Public Property TopBandSetItems() As ProfileViewBandSetItemCollection
Links
ProfileViewBandSetStyle Class, ProfileViewBandSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class
ProfileViewStyle Class
Collapse All

The profile view style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleProfile"))]
public class ProfileViewStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleProfile"))>
Public Class ProfileViewStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
ProfileViewStyle Methods, ProfileViewStyle Properties, ProfileViewStyle Members, Class Hierarchy


ProfileViewStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Members
ProfileViewStyle Members
Collapse All

The following tables list the members exposed by ProfileViewStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the profile view component plan display color, layer, linetype, etc.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomAxis | Gets the style object that specifies display properties for profile view bottom axes.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GraphStyle | Gets the style object that specifies all display properties for profile view graphs.
GridStyle | Gets the style object that specifies display properties for profile view grid.
LeftAxis | Gets the style object that specifies display properties for profile view left axes.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RightAxis | Gets the style object that specifies display properties for profile view right axes.
TopAxis | Gets the style object that specifies display properties for profile view top axes.
Links
Public Methods, Public Properties


ProfileViewStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Methods
ProfileViewStyle Methods
Collapse All

The methods of ProfileViewStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the profile view component plan display color, layer, linetype, etc.
Links
Public Methods


ProfileViewStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Methods > ProfileViewStyle::GetDisplayStylePlan Method
ProfileViewStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies the profile view component plan display color, layer, linetype, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    ProfileViewDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As ProfileViewDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ProfileViewStyle Class, ProfileViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Properties
ProfileViewStyle Properties
Collapse All

The properties of ProfileViewStyle are listed here.

Public Properties
Public Property | Description
BottomAxis | Gets the style object that specifies display properties for profile view bottom axes.
GraphStyle | Gets the style object that specifies all display properties for profile view graphs.
GridStyle | Gets the style object that specifies display properties for profile view grid.
LeftAxis | Gets the style object that specifies display properties for profile view left axes.
RightAxis | Gets the style object that specifies display properties for profile view right axes.
TopAxis | Gets the style object that specifies display properties for profile view top axes.
Links
Public Properties


ProfileViewStyle::BottomAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Properties > ProfileViewStyle::BottomAxis Property
ProfileViewStyle::BottomAxis Property
Collapse All

Gets the style object that specifies display properties for profile view bottom axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle BottomAxis;
Visual Basic
Public Property BottomAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
ProfileViewStyle Class, ProfileViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewStyle::GraphStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Properties > ProfileViewStyle::GraphStyle Property
ProfileViewStyle::GraphStyle Property
Collapse All

Gets the style object that specifies all display properties for profile view graphs.

C#
public Autodesk::Civil::DatabaseServices::Styles::GraphStyle GraphStyle;
Visual Basic
Public Property GraphStyle() As Autodesk::Civil::DatabaseServices::Styles::GraphStyle
Links
ProfileViewStyle Class, ProfileViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewStyle::GridStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Properties > ProfileViewStyle::GridStyle Property
ProfileViewStyle::GridStyle Property
Collapse All

Gets the style object that specifies display properties for profile view grid.

C#
public Autodesk::Civil::DatabaseServices::Styles::GridStyle GridStyle;
Visual Basic
Public Property GridStyle() As Autodesk::Civil::DatabaseServices::Styles::GridStyle
Links
ProfileViewStyle Class, ProfileViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewStyle::LeftAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Properties > ProfileViewStyle::LeftAxis Property
ProfileViewStyle::LeftAxis Property
Collapse All

Gets the style object that specifies display properties for profile view left axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle LeftAxis;
Visual Basic
Public Property LeftAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
ProfileViewStyle Class, ProfileViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewStyle::RightAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Properties > ProfileViewStyle::RightAxis Property
ProfileViewStyle::RightAxis Property
Collapse All

Gets the style object that specifies display properties for profile view right axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle RightAxis;
Visual Basic
Public Property RightAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
ProfileViewStyle Class, ProfileViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewStyle::TopAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Properties > ProfileViewStyle::TopAxis Property
ProfileViewStyle::TopAxis Property
Collapse All

Gets the style object that specifies display properties for profile view top axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle TopAxis;
Visual Basic
Public Property TopAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
ProfileViewStyle Class, ProfileViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ProfileViewStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class
ProfileViewStyleCollection Class
Collapse All

The ProfileViewStyleCollection class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyleCollection
C#
public class ProfileViewStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class ProfileViewStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Example
Public Function CreateProfileViewStyle() As Boolean
   Dim oTransaction As Transaction = m_TransactionManager.TopTransaction

   Dim profileStyleCol As ProfileViewStyleCollection = m_CivilDoc.Styles.ProfileViewStyles()
   Dim id As ObjectId = ObjectId.Null
   Dim oProfileViewStyle As ProfileViewStyle = Nothing

   Try
       id = profileStyleCol(PROFILE_STYLE_NAME)
   Catch ex As SystemException
       'ObjectId not found
   End Try

   If Not (id = ObjectId.Null) Then
       Return False
   End If

   ' Create a new style and add it to the drawing's collection of profile styles.
   id = profileStyleCol.Add(PROFILE_VIEW_STYLE_NAME)
   oProfileViewStyle = oTransaction.GetObject(id, OpenMode.ForWrite)

   Dim axisStyle As AxisStyle = oProfileViewStyle.BottomAxis()
   axisStyle.MajorTickStyle.Size = 0.01
   ' feet, in documents that use Imperial measures
   axisStyle.MajorTickStyle.Interval = 50
   axisStyle.TitleStyle.Text = "Stations"

   axisStyle = oProfileViewStyle.TopAxis()
   axisStyle.TitleStyle.Text = "Meters"

   m_Editor.WriteMessage("Sample Profile View Style Created!" + Convert.ToChar(10))
   m_Editor.WriteMessage(Convert.ToChar(10))
   Return True
End Function
Links
ProfileViewStyleCollection Methods, ProfileViewStyleCollection Members, Class Hierarchy


ProfileViewStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class > ProfileViewStyleCollection Members
ProfileViewStyleCollection Members
Collapse All

The following tables list the members exposed by ProfileViewStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


ProfileViewStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class > ProfileViewStyleCollection Methods
ProfileViewStyleCollection Methods
Collapse All

The methods of ProfileViewStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


ProfileViewStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class > ProfileViewStyleCollection Methods > ProfileViewStyleCollection::Add Method
ProfileViewStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
ProfileViewStyleCollection Class, ProfileViewStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SampleLineStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class
SampleLineStyle Class
Collapse All

Specifies display properties for the sample lines used to obtain elevational information from an existing terrain model or surface.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSampleLineStyle"))]
public class SampleLineStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSampleLineStyle"))>
Public Class SampleLineStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
SampleLineStyle Methods, SampleLineStyle Members, Class Hierarchy


SampleLineStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Members
SampleLineStyle Members
Collapse All

The following tables list the members exposed by SampleLineStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the SampleLine component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SampleLine component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


SampleLineStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Methods
SampleLineStyle Methods
Collapse All

The methods of SampleLineStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the SampleLine component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SampleLine component.
Links
Public Methods


SampleLineStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Methods > SampleLineStyle::GetDisplayStyleModel Method
SampleLineStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies model display properties for the SampleLine component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    SampleLineDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As SampleLineDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
SampleLineStyle Class, SampleLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SampleLineStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Methods > SampleLineStyle::GetDisplayStylePlan Method
SampleLineStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the SampleLine component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    SampleLineDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As SampleLineDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
SampleLineStyle Class, SampleLineStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionalDataBandStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class
SectionalDataBandStyle Class
Collapse All

The section data band style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionalDataBandStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleSectionalDataBands"))]
public class SectionalDataBandStyle : Autodesk::Civil::DatabaseServices::Styles::BandStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleSectionalDataBands"))>
Public Class SectionalDataBandStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::BandStyle
Links
SectionalDataBandStyle Methods, SectionalDataBandStyle Properties, SectionalDataBandStyle Members, Class Hierarchy


SectionalDataBandStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Members
SectionalDataBandStyle Members
Collapse All

The following tables list the members exposed by SectionalDataBandStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionalData component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
IncrementalSectionDataLabelStyleId | Gets the band section data label style id at the incremental section data.
IncrementalSectionDataTickStyle | Gets the band section data tick style at the incremental section data.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SampleLineStationLabelStyleId | Gets the band section data label style id at the sample line station.
SampleLineStationTickStyle | Gets the band section data tick style at the sample line station.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Methods, Public Properties


SectionalDataBandStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Methods
SectionalDataBandStyle Methods
Collapse All

The methods of SectionalDataBandStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionalData component.
Links
Public Methods


SectionalDataBandStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Methods > SectionalDataBandStyle::GetDisplayStylePlan Method
SectionalDataBandStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the SectionalData component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    SectionalDataDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As SectionalDataDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
SectionalDataBandStyle Class, SectionalDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionalDataBandStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Properties
SectionalDataBandStyle Properties
Collapse All

The properties of SectionalDataBandStyle are listed here.

Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
IncrementalSectionDataLabelStyleId | Gets the band section data label style id at the incremental section data.
IncrementalSectionDataTickStyle | Gets the band section data tick style at the incremental section data.
SampleLineStationLabelStyleId | Gets the band section data label style id at the sample line station.
SampleLineStationTickStyle | Gets the band section data tick style at the sample line station.
TitleTextLabelStyleId | Gets the band profile data title text label style.
Links
Public Properties


SectionalDataBandStyle::BandType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Properties > SectionalDataBandStyle::BandType Property
SectionalDataBandStyle::BandType Property
Collapse All

Gets the BandStyleType enum value that specifies the type of data band data.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandStyleType BandType;
Visual Basic
Public Property BandType() As Autodesk::Civil::DatabaseServices::Styles::BandStyleType
Links
SectionalDataBandStyle Class, SectionalDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionalDataBandStyle::IncrementalSectionDataLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Properties > SectionalDataBandStyle::IncrementalSectionDataLabelStyleId Property
SectionalDataBandStyle::IncrementalSectionDataLabelStyleId Property
Collapse All

Gets the band section data label style id at the incremental section data.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId IncrementalSectionDataLabelStyleId;
Visual Basic
Public Property IncrementalSectionDataLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionalDataBandStyle Class, SectionalDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionalDataBandStyle::IncrementalSectionDataTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Properties > SectionalDataBandStyle::IncrementalSectionDataTickStyle Property
SectionalDataBandStyle::IncrementalSectionDataTickStyle Property
Collapse All

Gets the band section data tick style at the incremental section data.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle IncrementalSectionDataTickStyle;
Visual Basic
Public Property IncrementalSectionDataTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SectionalDataBandStyle Class, SectionalDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionalDataBandStyle::SampleLineStationLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Properties > SectionalDataBandStyle::SampleLineStationLabelStyleId Property
SectionalDataBandStyle::SampleLineStationLabelStyleId Property
Collapse All

Gets the band section data label style id at the sample line station.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SampleLineStationLabelStyleId;
Visual Basic
Public Property SampleLineStationLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionalDataBandStyle Class, SectionalDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionalDataBandStyle::SampleLineStationTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Properties > SectionalDataBandStyle::SampleLineStationTickStyle Property
SectionalDataBandStyle::SampleLineStationTickStyle Property
Collapse All

Gets the band section data tick style at the sample line station.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle SampleLineStationTickStyle;
Visual Basic
Public Property SampleLineStationTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SectionalDataBandStyle Class, SectionalDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionalDataBandStyle::TitleTextLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Properties > SectionalDataBandStyle::TitleTextLabelStyleId Property
SectionalDataBandStyle::TitleTextLabelStyleId Property
Collapse All

Gets the band profile data title text label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TitleTextLabelStyleId;
Visual Basic
Public Property TitleTextLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Links
SectionalDataBandStyle Class, SectionalDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class
SectionDataBandStyle Class
Collapse All

The section data band style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionDataBandStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleSectionDataBands"))]
public class SectionDataBandStyle : Autodesk::Civil::DatabaseServices::Styles::BandStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleSectionDataBands"))>
Public Class SectionDataBandStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::BandStyle
Links
SectionDataBandStyle Methods, SectionDataBandStyle Properties, SectionDataBandStyle Members, Class Hierarchy


SectionDataBandStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Members
SectionDataBandStyle Members
Collapse All

The following tables list the members exposed by SectionDataBandStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionData component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CenterlineLabelStyleId | Gets the band section data label style id at the centerline.
CenterlineTickStyle | Gets the band section data tick style at the centerline.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GradeBreaksLabelStyleId | Gets the band section data label style id at the grade breaks.
GradeBreaksTickStyle | Gets the band section data tick style at the grade breaks.
IncrementalDistanceLabelStyleId | Gets the band section data label style id at the incremental distance.
MajorIncrementLabelStyleId | Gets the band section data label style id at the major increment.
MajorIncrementTickStyle | Gets the band section data tick style at the major increment.
MinorIncrementLabelStyleId | Gets the band section data label style id at the minor increment.
MinorIncrementTickStyle | Gets the band section data tick style at the minor increment.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SampleLineVerticesLabelStyleId | Gets the band section data label style id at the sample line vertices.
SampleLineVerticesTickStyle | Gets the band section data tick style at the sample line vertices.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Methods, Public Properties


SectionDataBandStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Methods
SectionDataBandStyle Methods
Collapse All

The methods of SectionDataBandStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionData component.
Links
Public Methods


SectionDataBandStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Methods > SectionDataBandStyle::GetDisplayStylePlan Method
SectionDataBandStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the SectionData component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    SectionDataDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As SectionDataDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties
SectionDataBandStyle Properties
Collapse All

The properties of SectionDataBandStyle are listed here.

Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CenterlineLabelStyleId | Gets the band section data label style id at the centerline.
CenterlineTickStyle | Gets the band section data tick style at the centerline.
GradeBreaksLabelStyleId | Gets the band section data label style id at the grade breaks.
GradeBreaksTickStyle | Gets the band section data tick style at the grade breaks.
IncrementalDistanceLabelStyleId | Gets the band section data label style id at the incremental distance.
MajorIncrementLabelStyleId | Gets the band section data label style id at the major increment.
MajorIncrementTickStyle | Gets the band section data tick style at the major increment.
MinorIncrementLabelStyleId | Gets the band section data label style id at the minor increment.
MinorIncrementTickStyle | Gets the band section data tick style at the minor increment.
SampleLineVerticesLabelStyleId | Gets the band section data label style id at the sample line vertices.
SampleLineVerticesTickStyle | Gets the band section data tick style at the sample line vertices.
TitleTextLabelStyleId | Gets the band profile data title text label style.
Links
Public Properties


SectionDataBandStyle::BandType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::BandType Property
SectionDataBandStyle::BandType Property
Collapse All

Gets the BandStyleType enum value that specifies the type of data band data.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandStyleType BandType;
Visual Basic
Public Property BandType() As Autodesk::Civil::DatabaseServices::Styles::BandStyleType
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::CenterlineLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::CenterlineLabelStyleId Property
SectionDataBandStyle::CenterlineLabelStyleId Property
Collapse All

Gets the band section data label style id at the centerline.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CenterlineLabelStyleId;
Visual Basic
Public Property CenterlineLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::CenterlineTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::CenterlineTickStyle Property
SectionDataBandStyle::CenterlineTickStyle Property
Collapse All

Gets the band section data tick style at the centerline.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle CenterlineTickStyle;
Visual Basic
Public Property CenterlineTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::GradeBreaksLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::GradeBreaksLabelStyleId Property
SectionDataBandStyle::GradeBreaksLabelStyleId Property
Collapse All

Gets the band section data label style id at the grade breaks.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId GradeBreaksLabelStyleId;
Visual Basic
Public Property GradeBreaksLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::GradeBreaksTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::GradeBreaksTickStyle Property
SectionDataBandStyle::GradeBreaksTickStyle Property
Collapse All

Gets the band section data tick style at the grade breaks.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle GradeBreaksTickStyle;
Visual Basic
Public Property GradeBreaksTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::IncrementalDistanceLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::IncrementalDistanceLabelStyleId Property
SectionDataBandStyle::IncrementalDistanceLabelStyleId Property
Collapse All

Gets the band section data label style id at the incremental distance.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId IncrementalDistanceLabelStyleId;
Visual Basic
Public Property IncrementalDistanceLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::MajorIncrementLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::MajorIncrementLabelStyleId Property
SectionDataBandStyle::MajorIncrementLabelStyleId Property
Collapse All

Gets the band section data label style id at the major increment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MajorIncrementLabelStyleId;
Visual Basic
Public Property MajorIncrementLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::MajorIncrementTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::MajorIncrementTickStyle Property
SectionDataBandStyle::MajorIncrementTickStyle Property
Collapse All

Gets the band section data tick style at the major increment.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle MajorIncrementTickStyle;
Visual Basic
Public Property MajorIncrementTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::MinorIncrementLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::MinorIncrementLabelStyleId Property
SectionDataBandStyle::MinorIncrementLabelStyleId Property
Collapse All

Gets the band section data label style id at the minor increment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MinorIncrementLabelStyleId;
Visual Basic
Public Property MinorIncrementLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::MinorIncrementTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::MinorIncrementTickStyle Property
SectionDataBandStyle::MinorIncrementTickStyle Property
Collapse All

Gets the band section data tick style at the minor increment.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle MinorIncrementTickStyle;
Visual Basic
Public Property MinorIncrementTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::SampleLineVerticesLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::SampleLineVerticesLabelStyleId Property
SectionDataBandStyle::SampleLineVerticesLabelStyleId Property
Collapse All

Gets the band section data label style id at the sample line vertices.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SampleLineVerticesLabelStyleId;
Visual Basic
Public Property SampleLineVerticesLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::SampleLineVerticesTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::SampleLineVerticesTickStyle Property
SectionDataBandStyle::SampleLineVerticesTickStyle Property
Collapse All

Gets the band section data tick style at the sample line vertices.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle SampleLineVerticesTickStyle;
Visual Basic
Public Property SampleLineVerticesTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionDataBandStyle::TitleTextLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties > SectionDataBandStyle::TitleTextLabelStyleId Property
SectionDataBandStyle::TitleTextLabelStyleId Property
Collapse All

Gets the band profile data title text label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TitleTextLabelStyleId;
Visual Basic
Public Property TitleTextLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Links
SectionDataBandStyle Class, SectionDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionSegmentBandStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class
SectionSegmentBandStyle Class
Collapse All

The section data band style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionSegmentBandStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleSectionRoadSurfaceBands"))]
public class SectionSegmentBandStyle : Autodesk::Civil::DatabaseServices::Styles::BandStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleSectionRoadSurfaceBands"))>
Public Class SectionSegmentBandStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::BandStyle
Links
SectionSegmentBandStyle Methods, SectionSegmentBandStyle Properties, SectionSegmentBandStyle Members, Class Hierarchy


SectionSegmentBandStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Members
SectionSegmentBandStyle Members
Collapse All

The following tables list the members exposed by SectionSegmentBandStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionalSegment component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SegmentLabelsTickStyle | Gets the band section data tick style at the segment labels.
SegmentsLabelStyleId | Gets the band section data label style id at the segment labels.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Methods, Public Properties


SectionSegmentBandStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Methods
SectionSegmentBandStyle Methods
Collapse All

The methods of SectionSegmentBandStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionalSegment component.
Links
Public Methods


SectionSegmentBandStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Methods > SectionSegmentBandStyle::GetDisplayStylePlan Method
SectionSegmentBandStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the SectionalSegment component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    SectionSegmentDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As SectionSegmentDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
SectionSegmentBandStyle Class, SectionSegmentBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionSegmentBandStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Properties
SectionSegmentBandStyle Properties
Collapse All

The properties of SectionSegmentBandStyle are listed here.

Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
SegmentLabelsTickStyle | Gets the band section data tick style at the segment labels.
SegmentsLabelStyleId | Gets the band section data label style id at the segment labels.
TitleTextLabelStyleId | Gets the band profile data title text label style.
Links
Public Properties


SectionSegmentBandStyle::BandType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Properties > SectionSegmentBandStyle::BandType Property
SectionSegmentBandStyle::BandType Property
Collapse All

Gets the BandStyleType enum value that specifies the type of data band data.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandStyleType BandType;
Visual Basic
Public Property BandType() As Autodesk::Civil::DatabaseServices::Styles::BandStyleType
Links
SectionSegmentBandStyle Class, SectionSegmentBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionSegmentBandStyle::SegmentLabelsTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Properties > SectionSegmentBandStyle::SegmentLabelsTickStyle Property
SectionSegmentBandStyle::SegmentLabelsTickStyle Property
Collapse All

Gets the band section data tick style at the segment labels.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle SegmentLabelsTickStyle;
Visual Basic
Public Property SegmentLabelsTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SectionSegmentBandStyle Class, SectionSegmentBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionSegmentBandStyle::SegmentsLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Properties > SectionSegmentBandStyle::SegmentsLabelStyleId Property
SectionSegmentBandStyle::SegmentsLabelStyleId Property
Collapse All

Gets the band section data label style id at the segment labels.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SegmentsLabelStyleId;
Visual Basic
Public Property SegmentsLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionSegmentBandStyle Class, SectionSegmentBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionSegmentBandStyle::TitleTextLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Properties > SectionSegmentBandStyle::TitleTextLabelStyleId Property
SectionSegmentBandStyle::TitleTextLabelStyleId Property
Collapse All

Gets the band profile data title text label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TitleTextLabelStyleId;
Visual Basic
Public Property TitleTextLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Links
SectionSegmentBandStyle Class, SectionSegmentBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class
SectionStyle Class
Collapse All

Specifies display characteristics and associated information for cross sections and their constituent components.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionStyle"))]
public class SectionStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionStyle"))>
Public Class SectionStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
SectionStyle Methods, SectionStyle Members, Class Hierarchy


SectionStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class > SectionStyle Members
SectionStyle Members
Collapse All

The following tables list the members exposed by SectionStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties for the Section component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


SectionStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class > SectionStyle Methods
SectionStyle Methods
Collapse All

The methods of SectionStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties for the Section component.
Links
Public Methods


SectionStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class > SectionStyle Methods > SectionStyle::GetDisplayStyleSection Method
SectionStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle object that specifies section display properties for the Section component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection(
    SectionDisplayStyleSectionType type
);
Visual Basic
Public Function GetDisplayStyleSection(
    type As SectionDisplayStyleSectionType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
SectionStyle Class, SectionStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItem Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class
SectionViewBandSetItem Class
Collapse All

Encapsulates a single section view data band.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItem
    Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetItem
C#
public class SectionViewBandSetItem : Autodesk::Civil::DatabaseServices::Styles::BandSetItem;
Visual Basic
Public Class SectionViewBandSetItem
Inherits Autodesk::Civil::DatabaseServices::Styles::BandSetItem
Links
SectionViewBandSetItem Properties, SectionViewBandSetItem Members, Class Hierarchy


SectionViewBandSetItem Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Members
SectionViewBandSetItem Members
Collapse All

The following tables list the members exposed by SectionViewBandSetItem.

Public Properties
Public Property | Description
BandStyleId | Gets the object that identifies the style for the band type.
Gap | Gets or sets the distance between the current data band and the adjacent grid or data band.
LabelAtEndOffset | Gets or sets the label at end offset.
LabelAtStartOffset | Gets or sets the label at start offset.
Location | Gets the BandSetOptionsType enum value that identifies band location and display settings.
MajorInterval | Gets or sets the section view data band major interval distance.
MinorInterval | Gets or sets the section view data band minor interval distance.
StaggerLabel | Gets or sets the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or Stagger... more
StaggerLineHeight | Gets or sets the height of the label stagger line.
Weeding | Gets or sets the weeding value.
Links
Public Properties


SectionViewBandSetItem Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Properties
SectionViewBandSetItem Properties
Collapse All

The properties of SectionViewBandSetItem are listed here.

Public Properties
Public Property | Description
LabelAtEndOffset | Gets or sets the label at end offset.
LabelAtStartOffset | Gets or sets the label at start offset.
MajorInterval | Gets or sets the section view data band major interval distance.
MinorInterval | Gets or sets the section view data band minor interval distance.
StaggerLabel | Gets or sets the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or Stagger... more
StaggerLineHeight | Gets or sets the height of the label stagger line.
Links
Public Properties


SectionViewBandSetItem::LabelAtEndOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Properties > SectionViewBandSetItem::LabelAtEndOffset Property
SectionViewBandSetItem::LabelAtEndOffset Property
Collapse All

Gets or sets the label at end offset.

C#
public bool LabelAtEndOffset;
Visual Basic
Public Property LabelAtEndOffset() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the band style type is Section Segment.
Links
SectionViewBandSetItem Class, SectionViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItem::LabelAtStartOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Properties > SectionViewBandSetItem::LabelAtStartOffset Property
SectionViewBandSetItem::LabelAtStartOffset Property
Collapse All

Gets or sets the label at start offset.

C#
public bool LabelAtStartOffset;
Visual Basic
Public Property LabelAtStartOffset() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the band style type is Section Segment.
Links
SectionViewBandSetItem Class, SectionViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItem::MajorInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Properties > SectionViewBandSetItem::MajorInterval Property
SectionViewBandSetItem::MajorInterval Property
Collapse All

Gets or sets the section view data band major interval distance.

C#
public double MajorInterval;
Visual Basic
Public Property MajorInterval() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the band style type is Section Segment or MatchIncreament is false.
Links
SectionViewBandSetItem Class, SectionViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItem::MinorInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Properties > SectionViewBandSetItem::MinorInterval Property
SectionViewBandSetItem::MinorInterval Property
Collapse All

Gets or sets the section view data band minor interval distance.

C#
public double MinorInterval;
Visual Basic
Public Property MinorInterval() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the band style type is Section Segment or MatchIncreament is false.
Links
SectionViewBandSetItem Class, SectionViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItem::StaggerLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Properties > SectionViewBandSetItem::StaggerLabel Property
SectionViewBandSetItem::StaggerLabel Property
Collapse All

Gets or sets the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or Stagger to left.

C#
public Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType StaggerLabel;
Visual Basic
Public Property StaggerLabel() As Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the band style type is Section Segment.
Links
SectionViewBandSetItem Class, SectionViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItem::StaggerLineHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Properties > SectionViewBandSetItem::StaggerLineHeight Property
SectionViewBandSetItem::StaggerLineHeight Property
Collapse All

Gets or sets the height of the label stagger line.

C#
public double StaggerLineHeight;
Visual Basic
Public Property StaggerLineHeight() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the band style type is Section Segment.
Links
SectionViewBandSetItem Class, SectionViewBandSetItem Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItemCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class
SectionViewBandSetItemCollection Class
Collapse All

The SectionViewBandSetItemCollectione wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItemCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetItemCollection
C#
public class SectionViewBandSetItemCollection : Autodesk::Civil::DatabaseServices::Styles::BandSetItemCollection, System::Collections::Generic::IEnumerable<SectionViewBandSetItem^>;
Visual Basic
Public Class SectionViewBandSetItemCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::BandSetItemCollection
Inherits System::Collections::Generic::IEnumerable<SectionViewBandSetItem^>
Links
SectionViewBandSetItemCollection Methods, SectionViewBandSetItemCollection Properties, SectionViewBandSetItemCollection Members, Class Hierarchy


SectionViewBandSetItemCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Members
SectionViewBandSetItemCollection Members
Collapse All

The following tables list the members exposed by SectionViewBandSetItemCollection.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes an item from the collection.
Swap | Swap two items in the collection.
Public Properties
Public Property | Description
Count | Gets the number of band style sets in the collection.
default | Gets the profile view band set item at the given index.
Links
Public Methods, Public Properties


SectionViewBandSetItemCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Methods
SectionViewBandSetItemCollection Methods
Collapse All

The methods of SectionViewBandSetItemCollection are listed here.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Links
Public Methods


Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Methods > Add Method
Add Method
Collapse All

Overloaded

Overload List
Method | Description
SectionViewBandSetItemCollection::Add (Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new section view band set item with the given name, adds it to the collection, and returns a... more
SectionViewBandSetItemCollection::Add (Autodesk::Civil::DatabaseServices::Styles::BandStyleType, System::String^) | Creates a new profile view band set item with the given type and name, adds it to the collection, and... more


SectionViewBandSetItemCollection::Add Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Methods > Add Method > SectionViewBandSetItemCollection::Add Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
SectionViewBandSetItemCollection::Add Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new section view band set item with the given name, adds it to the collection, and returns a pointer to the new instance.

C#
public SectionViewBandSetItem Add(
    Autodesk::AutoCAD::DatabaseServices::ObjectId bandStyleId
);
Visual Basic
Public Function Add(
    bandStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As SectionViewBandSetItem
Parameters
Parameters | Description
bandStyleId | Band style object id.
Links
SectionViewBandSetItemCollection Class, SectionViewBandSetItemCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItemCollection::Add Method (Autodesk::Civil::DatabaseServices::Styles::BandStyleType, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Methods > Add Method > SectionViewBandSetItemCollection::Add Method (Autodesk::Civil::DatabaseServices::Styles::BandStyleType, System::String^)
SectionViewBandSetItemCollection::Add Method (Autodesk::Civil::DatabaseServices::Styles::BandStyleType, System::String^)
Collapse All

Creates a new profile view band set item with the given type and name, adds it to the collection, and returns a pointer to the new instance.

C#
public SectionViewBandSetItem Add(
    Autodesk::Civil::DatabaseServices::Styles::BandStyleType bandStyleType,
    ref System::String bandStyleName
);
Visual Basic
Public Function Add(
    bandStyleType As Autodesk::Civil::DatabaseServices::Styles::BandStyleType,
    ByRef bandStyleName As System::String
) As SectionViewBandSetItem
Parameters
Parameters | Description
bandStyleType | Band style type, only SectionData and SectionRoadSurface are valid here.
bandStyleName | Band style name.
Links
SectionViewBandSetItemCollection Class, SectionViewBandSetItemCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItemCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Methods > SectionViewBandSetItemCollection::GetEnumerator Method
SectionViewBandSetItemCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<SectionViewBandSetItem^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<SectionViewBandSetItem^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
SectionViewBandSetItemCollection Class, SectionViewBandSetItemCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItemCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Methods > SectionViewBandSetItemCollection::GetObjectEnumerator Method
SectionViewBandSetItemCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
SectionViewBandSetItemCollection Class, SectionViewBandSetItemCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetItemCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Properties
SectionViewBandSetItemCollection Properties
Collapse All

The properties of SectionViewBandSetItemCollection are listed here.

Public Properties
Public Property | Description
default | Gets the profile view band set item at the given index.
Links
Public Properties


SectionViewBandSetItemCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Properties > SectionViewBandSetItemCollection::default Property
SectionViewBandSetItemCollection::default Property
Collapse All

Gets the profile view band set item at the given index.

C#
public SectionViewBandSetItem default;
Visual Basic
Public Property default() As SectionViewBandSetItem
Parameters
Parameters | Description
index | Specified the band style set item by index.
Links
SectionViewBandSetItemCollection Class, SectionViewBandSetItemCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class
SectionViewBandSetStyle Class
Collapse All

The SectionViewBandSetStyle wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphSectionBandStyleSet"))]
public class SectionViewBandSetStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphSectionBandStyleSet"))>
Public Class SectionViewBandSetStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
SectionViewBandSetStyle Properties, SectionViewBandSetStyle Members, Class Hierarchy


SectionViewBandSetStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Members
SectionViewBandSetStyle Members
Collapse All

The following tables list the members exposed by SectionViewBandSetStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomBandSetItems | Gets the bottom band set item collection from section view band set style.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MatchIncrement | Gets or sets if the section data band major/minor interval distances for Section views matches the section view style’s major/minor... more
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
TopBandSetItems | Gets the top band set item collection from section view band set style.
Links
Public Methods, Public Properties


SectionViewBandSetStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Properties
SectionViewBandSetStyle Properties
Collapse All

The properties of SectionViewBandSetStyle are listed here.

Public Properties
Public Property | Description
BottomBandSetItems | Gets the bottom band set item collection from section view band set style.
MatchIncrement | Gets or sets if the section data band major/minor interval distances for Section views matches the section view style’s major/minor... more
TopBandSetItems | Gets the top band set item collection from section view band set style.
Links
Public Properties


SectionViewBandSetStyle::BottomBandSetItems Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Properties > SectionViewBandSetStyle::BottomBandSetItems Property
SectionViewBandSetStyle::BottomBandSetItems Property
Collapse All

Gets the bottom band set item collection from section view band set style.

C#
public SectionViewBandSetItemCollection BottomBandSetItems;
Visual Basic
Public Property BottomBandSetItems() As SectionViewBandSetItemCollection
Links
SectionViewBandSetStyle Class, SectionViewBandSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetStyle::MatchIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Properties > SectionViewBandSetStyle::MatchIncrement Property
SectionViewBandSetStyle::MatchIncrement Property
Collapse All

Gets or sets if the section data band major/minor interval distances for Section views matches the section view style’s major/minor grid spacing intervals.

C#
public bool MatchIncrement;
Visual Basic
Public Property MatchIncrement() As bool
Links
SectionViewBandSetStyle Class, SectionViewBandSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewBandSetStyle::TopBandSetItems Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Properties > SectionViewBandSetStyle::TopBandSetItems Property
SectionViewBandSetStyle::TopBandSetItems Property
Collapse All

Gets the top band set item collection from section view band set style.

C#
public SectionViewBandSetItemCollection TopBandSetItems;
Visual Basic
Public Property TopBandSetItems() As SectionViewBandSetItemCollection
Links
SectionViewBandSetStyle Class, SectionViewBandSetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class
SectionViewStyle Class
Collapse All

The section view style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleCrossSection"))]
public class SectionViewStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleCrossSection"))>
Public Class SectionViewStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
SectionViewStyle Methods, SectionViewStyle Properties, SectionViewStyle Members, Class Hierarchy


SectionViewStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Members
SectionViewStyle Members
Collapse All

The following tables list the members exposed by SectionViewStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the section view component plan display color, layer, linetype, etc.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomAxis | Gets the style object that specifies display properties for section view bottom axes.
CenterAxis | Gets the style object that specifies display properties for section view center axes.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GraphStyle | Gets the style object that specifies all display properties for section view graphs.
GridStyle | Gets the style object that specifies display properties for section view grid.
LeftAxis | Gets the style object that specifies display properties for section view left axes.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RightAxis | Gets the style object that specifies display properties for section view right axes.
TopAxis | Gets the style object that specifies display properties for section view top axes.
Links
Public Methods, Public Properties


SectionViewStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Methods
SectionViewStyle Methods
Collapse All

The methods of SectionViewStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the section view component plan display color, layer, linetype, etc.
Links
Public Methods


SectionViewStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Methods > SectionViewStyle::GetDisplayStylePlan Method
SectionViewStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies the section view component plan display color, layer, linetype, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    SectionViewDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As SectionViewDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
SectionViewStyle Class, SectionViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties
SectionViewStyle Properties
Collapse All

The properties of SectionViewStyle are listed here.

Public Properties
Public Property | Description
BottomAxis | Gets the style object that specifies display properties for section view bottom axes.
CenterAxis | Gets the style object that specifies display properties for section view center axes.
GraphStyle | Gets the style object that specifies all display properties for section view graphs.
GridStyle | Gets the style object that specifies display properties for section view grid.
LeftAxis | Gets the style object that specifies display properties for section view left axes.
RightAxis | Gets the style object that specifies display properties for section view right axes.
TopAxis | Gets the style object that specifies display properties for section view top axes.
Links
Public Properties


SectionViewStyle::BottomAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties > SectionViewStyle::BottomAxis Property
SectionViewStyle::BottomAxis Property
Collapse All

Gets the style object that specifies display properties for section view bottom axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle BottomAxis;
Visual Basic
Public Property BottomAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
SectionViewStyle Class, SectionViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewStyle::CenterAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties > SectionViewStyle::CenterAxis Property
SectionViewStyle::CenterAxis Property
Collapse All

Gets the style object that specifies display properties for section view center axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle CenterAxis;
Visual Basic
Public Property CenterAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
SectionViewStyle Class, SectionViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewStyle::GraphStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties > SectionViewStyle::GraphStyle Property
SectionViewStyle::GraphStyle Property
Collapse All

Gets the style object that specifies all display properties for section view graphs.

C#
public Autodesk::Civil::DatabaseServices::Styles::GraphStyle GraphStyle;
Visual Basic
Public Property GraphStyle() As Autodesk::Civil::DatabaseServices::Styles::GraphStyle
Links
SectionViewStyle Class, SectionViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewStyle::GridStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties > SectionViewStyle::GridStyle Property
SectionViewStyle::GridStyle Property
Collapse All

Gets the style object that specifies display properties for section view grid.

C#
public Autodesk::Civil::DatabaseServices::Styles::GridStyle GridStyle;
Visual Basic
Public Property GridStyle() As Autodesk::Civil::DatabaseServices::Styles::GridStyle
Links
SectionViewStyle Class, SectionViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewStyle::LeftAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties > SectionViewStyle::LeftAxis Property
SectionViewStyle::LeftAxis Property
Collapse All

Gets the style object that specifies display properties for section view left axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle LeftAxis;
Visual Basic
Public Property LeftAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
SectionViewStyle Class, SectionViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewStyle::RightAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties > SectionViewStyle::RightAxis Property
SectionViewStyle::RightAxis Property
Collapse All

Gets the style object that specifies display properties for section view right axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle RightAxis;
Visual Basic
Public Property RightAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
SectionViewStyle Class, SectionViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SectionViewStyle::TopAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties > SectionViewStyle::TopAxis Property
SectionViewStyle::TopAxis Property
Collapse All

Gets the style object that specifies display properties for section view top axes.

C#
public Autodesk::Civil::DatabaseServices::Styles::AxisStyle TopAxis;
Visual Basic
Public Property TopAxis() As Autodesk::Civil::DatabaseServices::Styles::AxisStyle
Links
SectionViewStyle Class, SectionViewStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class
SheetStyle Class
Collapse All

The sheet plot style applied when plot by page is selected.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SheetStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSheetStyle"))]
public class SheetStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSheetStyle"))>
Public Class SheetStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
SheetStyle Methods, SheetStyle Properties, SheetStyle Members, Class Hierarchy


SheetStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Members
SheetStyle Members
Collapse All

The following tables list the members exposed by SheetStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayPlan | Gets the DisplayStyle object that specifies plan display properties for the SheetStyle component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GridHorizontalMajor | Gets or Sets the value of sheet style's horizontal major plot area grid.
GridHorizontalMinor | Gets or Sets the value of sheet style's horizontal minor plot area grid.
GridVerticalMajor | Gets or Sets the value of sheet style's vertical major plot area grid.
GridVerticalMinor | Gets or Sets the value of sheet style's vertical minor plot area grid.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PageLayoutId | Gets or Sets the object id of the sheet style's page layout.
PageMarginBottom | Gets or Sets the sheet style's bottom page margin.
PageMarginLeft | Gets or Sets the sheet style's left page margin.
PageMarginRight | Gets or Sets the sheet style's right page margin.
PageMarginTop | Gets or Sets the sheet style's top page margin.
Links
Public Methods, Public Properties


SheetStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Methods
SheetStyle Methods
Collapse All

The methods of SheetStyle are listed here.

Public Methods
Public Method | Description
GetDisplayPlan | Gets the DisplayStyle object that specifies plan display properties for the SheetStyle component.
Links
Public Methods


SheetStyle::GetDisplayPlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Methods > SheetStyle::GetDisplayPlan Method
SheetStyle::GetDisplayPlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the SheetStyle component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayPlan(
    SheetDisplayStyleType type
);
Visual Basic
Public Function GetDisplayPlan(
    type As SheetDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties
SheetStyle Properties
Collapse All

The properties of SheetStyle are listed here.

Public Properties
Public Property | Description
GridHorizontalMajor | Gets or Sets the value of sheet style's horizontal major plot area grid.
GridHorizontalMinor | Gets or Sets the value of sheet style's horizontal minor plot area grid.
GridVerticalMajor | Gets or Sets the value of sheet style's vertical major plot area grid.
GridVerticalMinor | Gets or Sets the value of sheet style's vertical minor plot area grid.
PageLayoutId | Gets or Sets the object id of the sheet style's page layout.
PageMarginBottom | Gets or Sets the sheet style's bottom page margin.
PageMarginLeft | Gets or Sets the sheet style's left page margin.
PageMarginRight | Gets or Sets the sheet style's right page margin.
PageMarginTop | Gets or Sets the sheet style's top page margin.
Links
Public Properties


SheetStyle::GridHorizontalMajor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties > SheetStyle::GridHorizontalMajor Property
SheetStyle::GridHorizontalMajor Property
Collapse All

Gets or Sets the value of sheet style's horizontal major plot area grid.

C#
public double GridHorizontalMajor;
Visual Basic
Public Property GridHorizontalMajor() As double
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle::GridHorizontalMinor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties > SheetStyle::GridHorizontalMinor Property
SheetStyle::GridHorizontalMinor Property
Collapse All

Gets or Sets the value of sheet style's horizontal minor plot area grid.

C#
public double GridHorizontalMinor;
Visual Basic
Public Property GridHorizontalMinor() As double
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle::GridVerticalMajor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties > SheetStyle::GridVerticalMajor Property
SheetStyle::GridVerticalMajor Property
Collapse All

Gets or Sets the value of sheet style's vertical major plot area grid.

C#
public double GridVerticalMajor;
Visual Basic
Public Property GridVerticalMajor() As double
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle::GridVerticalMinor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties > SheetStyle::GridVerticalMinor Property
SheetStyle::GridVerticalMinor Property
Collapse All

Gets or Sets the value of sheet style's vertical minor plot area grid.

C#
public double GridVerticalMinor;
Visual Basic
Public Property GridVerticalMinor() As double
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle::PageLayoutId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties > SheetStyle::PageLayoutId Property
SheetStyle::PageLayoutId Property
Collapse All

Gets or Sets the object id of the sheet style's page layout.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PageLayoutId;
Visual Basic
Public Property PageLayoutId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.AutoCAD.DatabaseServices.Layout or Autodesk.AutoCAD.DatabaseServices.PlotSettings

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is neither Autodesk.AutoCAD.DatabaseServices.Layout nor Autodesk.AutoCAD.DatabaseServices.PlotSettings.
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle::PageMarginBottom Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties > SheetStyle::PageMarginBottom Property
SheetStyle::PageMarginBottom Property
Collapse All

Gets or Sets the sheet style's bottom page margin.

C#
public double PageMarginBottom;
Visual Basic
Public Property PageMarginBottom() As double
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle::PageMarginLeft Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties > SheetStyle::PageMarginLeft Property
SheetStyle::PageMarginLeft Property
Collapse All

Gets or Sets the sheet style's left page margin.

C#
public double PageMarginLeft;
Visual Basic
Public Property PageMarginLeft() As double
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle::PageMarginRight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties > SheetStyle::PageMarginRight Property
SheetStyle::PageMarginRight Property
Collapse All

Gets or Sets the sheet style's right page margin.

C#
public double PageMarginRight;
Visual Basic
Public Property PageMarginRight() As double
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SheetStyle::PageMarginTop Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties > SheetStyle::PageMarginTop Property
SheetStyle::PageMarginTop Property
Collapse All

Gets or Sets the sheet style's top page margin.

C#
public double PageMarginTop;
Visual Basic
Public Property PageMarginTop() As double
Links
SheetStyle Class, SheetStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternComponent Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class
SlopePatternComponent Class
Collapse All

Encapsulates the properties of slope pattern components used to make up a SlopePatternStyle.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternComponent
C#
public class SlopePatternComponent : CivilWrapper<AeccDbSlopePatternStyle>;
Visual Basic
Public Class SlopePatternComponent
Inherits CivilWrapper<AeccDbSlopePatternStyle>
Links
SlopePatternComponent Properties, SlopePatternComponent Members, Class Hierarchy


SlopePatternComponent Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class > SlopePatternComponent Members
SlopePatternComponent Members
Collapse All

The following tables list the members exposed by SlopePatternComponent.

Public Properties
Public Property | Description
SlopeLine | Gets the slope line class in the component.
SlopeLineOffset | Gets the slope line offset class in the component.
SlopeLineSymbol | Gets the slope line symbol class in the component.
Links
Public Properties


SlopePatternComponent Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class > SlopePatternComponent Properties
SlopePatternComponent Properties
Collapse All

The properties of SlopePatternComponent are listed here.

Public Properties
Public Property | Description
SlopeLine | Gets the slope line class in the component.
SlopeLineOffset | Gets the slope line offset class in the component.
SlopeLineSymbol | Gets the slope line symbol class in the component.
Links
Public Properties


SlopePatternComponent::SlopeLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class > SlopePatternComponent Properties > SlopePatternComponent::SlopeLine Property
SlopePatternComponent::SlopeLine Property
Collapse All

Gets the slope line class in the component.

C#
public SlopePatternLine SlopeLine;
Visual Basic
Public Property SlopeLine() As SlopePatternLine
Links
SlopePatternComponent Class, SlopePatternComponent Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternComponent::SlopeLineOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class > SlopePatternComponent Properties > SlopePatternComponent::SlopeLineOffset Property
SlopePatternComponent::SlopeLineOffset Property
Collapse All

Gets the slope line offset class in the component.

C#
public SlopePatternLineOffset SlopeLineOffset;
Visual Basic
Public Property SlopeLineOffset() As SlopePatternLineOffset
Links
SlopePatternComponent Class, SlopePatternComponent Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternComponent::SlopeLineSymbol Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class > SlopePatternComponent Properties > SlopePatternComponent::SlopeLineSymbol Property
SlopePatternComponent::SlopeLineSymbol Property
Collapse All

Gets the slope line symbol class in the component.

C#
public SlopePatternLineSymbol SlopeLineSymbol;
Visual Basic
Public Property SlopeLineSymbol() As SlopePatternLineSymbol
Links
SlopePatternComponent Class, SlopePatternComponent Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class
SlopePatternLine Class
Collapse All

Defines a line used in a SlopePatternComponent.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternLine
C#
public class SlopePatternLine : CivilWrapper<AeccDbSlopePatternStyle>;
Visual Basic
Public Class SlopePatternLine
Inherits CivilWrapper<AeccDbSlopePatternStyle>
Links
SlopePatternLine Properties, SlopePatternLine Members, Class Hierarchy


SlopePatternLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Members
SlopePatternLine Members
Collapse All

The following tables list the members exposed by SlopePatternLine.

Public Properties
Public Property | Description
Color | Specifies the color of the line.
Grade1 | Specifies the first grade values for the component.
Grade2 | Specifies the second grade values for the component.
Length | Specifies the length value in drawing units (usually feet or meters). The line is trimmed if the slope is shorter... more
LengthType | Specifies how to determine the line length for this component.
Linetype | Specifies the linetype for the component.
LineWeight | Specifies the lineweight for the component.
MaximumLength | Specifies the maximum line length in drawing units.
PercentofLength | Specifies the percentage value up to a specified maximum.
PercentofLength1 | Specifies the line length as a percent of slope length for Slope 1.
PercentofLength2 | Specifies the line length as a percent of slope length for Slope 2.
StartType | Specifies whether the pattern begins at the top or bottom of the slope.
Links
Public Properties


SlopePatternLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties
SlopePatternLine Properties
Collapse All

The properties of SlopePatternLine are listed here.

Public Properties
Public Property | Description
Color | Specifies the color of the line.
Grade1 | Specifies the first grade values for the component.
Grade2 | Specifies the second grade values for the component.
Length | Specifies the length value in drawing units (usually feet or meters). The line is trimmed if the slope is shorter... more
LengthType | Specifies how to determine the line length for this component.
Linetype | Specifies the linetype for the component.
LineWeight | Specifies the lineweight for the component.
MaximumLength | Specifies the maximum line length in drawing units.
PercentofLength | Specifies the percentage value up to a specified maximum.
PercentofLength1 | Specifies the line length as a percent of slope length for Slope 1.
PercentofLength2 | Specifies the line length as a percent of slope length for Slope 2.
StartType | Specifies whether the pattern begins at the top or bottom of the slope.
Links
Public Properties


SlopePatternLine::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::Color Property
SlopePatternLine::Color Property
Collapse All

Specifies the color of the line.

C#
public Autodesk::AutoCAD::Colors::Color Color;
Visual Basic
Public Property Color() As Autodesk::AutoCAD::Colors::Color
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::Grade1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::Grade1 Property
SlopePatternLine::Grade1 Property
Collapse All

Specifies the first grade values for the component.

C#
public double Grade1;
Visual Basic
Public Property Grade1() As double
Remarks

Use the Autodesk.Civil.Constant.VerticalGrade to set the vertical grade.

Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::Grade2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::Grade2 Property
SlopePatternLine::Grade2 Property
Collapse All

Specifies the second grade values for the component.

C#
public double Grade2;
Visual Basic
Public Property Grade2() As double
Remarks

Use the Autodesk.Civil.Constant.VerticalGrade to set the vertical grade.

Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::Length Property
SlopePatternLine::Length Property
Collapse All

Specifies the length value in drawing units (usually feet or meters). The line is trimmed if the slope is shorter than this length.

C#
public double Length;
Visual Basic
Public Property Length() As double
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::LengthType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::LengthType Property
SlopePatternLine::LengthType Property
Collapse All

Specifies how to determine the line length for this component.

C#
public Autodesk::Civil::Land::SlopePatternLengthType LengthType;
Visual Basic
Public Property LengthType() As Autodesk::Civil::Land::SlopePatternLengthType
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::Linetype Property
SlopePatternLine::Linetype Property
Collapse All

Specifies the linetype for the component.

C#
public System::String Linetype;
Visual Basic
Public Property Linetype() As System::String
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::LineWeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::LineWeight Property
SlopePatternLine::LineWeight Property
Collapse All

Specifies the lineweight for the component.

C#
public Autodesk::AutoCAD::DatabaseServices::LineWeight LineWeight;
Visual Basic
Public Property LineWeight() As Autodesk::AutoCAD::DatabaseServices::LineWeight
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::MaximumLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::MaximumLength Property
SlopePatternLine::MaximumLength Property
Collapse All

Specifies the maximum line length in drawing units.

C#
public double MaximumLength;
Visual Basic
Public Property MaximumLength() As double
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::PercentofLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::PercentofLength Property
SlopePatternLine::PercentofLength Property
Collapse All

Specifies the percentage value up to a specified maximum.

C#
public double PercentofLength;
Visual Basic
Public Property PercentofLength() As double
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::PercentofLength1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::PercentofLength1 Property
SlopePatternLine::PercentofLength1 Property
Collapse All

Specifies the line length as a percent of slope length for Slope 1.

C#
public double PercentofLength1;
Visual Basic
Public Property PercentofLength1() As double
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::PercentofLength2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::PercentofLength2 Property
SlopePatternLine::PercentofLength2 Property
Collapse All

Specifies the line length as a percent of slope length for Slope 2.

C#
public double PercentofLength2;
Visual Basic
Public Property PercentofLength2() As double
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLine::StartType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties > SlopePatternLine::StartType Property
SlopePatternLine::StartType Property
Collapse All

Specifies whether the pattern begins at the top or bottom of the slope.

C#
public Autodesk::Civil::Land::SlopePatternStartType StartType;
Visual Basic
Public Property StartType() As Autodesk::Civil::Land::SlopePatternStartType
Links
SlopePatternLine Class, SlopePatternLine Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineOffset Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class
SlopePatternLineOffset Class
Collapse All

Defines the offset of lines in a SlopePatternComponent.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternLineOffset
C#
public class SlopePatternLineOffset : CivilWrapper<AeccDbSlopePatternStyle>;
Visual Basic
Public Class SlopePatternLineOffset
Inherits CivilWrapper<AeccDbSlopePatternStyle>
Links
SlopePatternLineOffset Properties, SlopePatternLineOffset Members, Class Hierarchy


SlopePatternLineOffset Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Members
SlopePatternLineOffset Members
Collapse All

The following tables list the members exposed by SlopePatternLineOffset.

Public Properties
Public Property | Description
Distance | Specifies the linear value in drawing units (usually feet or meters).
MaximumDistance | Specifies maximum offsets value in drawing units.
MinimumDistance | Specifies minimum offsets value in drawing units.
Numberoflines | Specifies the number of instances of this component to insert.
OffsetType | Specifies how to determine the offset distance between this component and the previous component in the slope line style.
PercentofLength | Specifies the percentage to the slope length at the position being offset from.
RadialOffsetAngle | Specifies the angular value.
Links
Public Properties


SlopePatternLineOffset Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties
SlopePatternLineOffset Properties
Collapse All

The properties of SlopePatternLineOffset are listed here.

Public Properties
Public Property | Description
Distance | Specifies the linear value in drawing units (usually feet or meters).
MaximumDistance | Specifies maximum offsets value in drawing units.
MinimumDistance | Specifies minimum offsets value in drawing units.
Numberoflines | Specifies the number of instances of this component to insert.
OffsetType | Specifies how to determine the offset distance between this component and the previous component in the slope line style.
PercentofLength | Specifies the percentage to the slope length at the position being offset from.
RadialOffsetAngle | Specifies the angular value.
Links
Public Properties


SlopePatternLineOffset::Distance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties > SlopePatternLineOffset::Distance Property
SlopePatternLineOffset::Distance Property
Collapse All

Specifies the linear value in drawing units (usually feet or meters).

C#
public double Distance;
Visual Basic
Public Property Distance() As double
Links
SlopePatternLineOffset Class, SlopePatternLineOffset Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineOffset::MaximumDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties > SlopePatternLineOffset::MaximumDistance Property
SlopePatternLineOffset::MaximumDistance Property
Collapse All

Specifies maximum offsets value in drawing units.

C#
public double MaximumDistance;
Visual Basic
Public Property MaximumDistance() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the MaximumDistance value is less than MinimumDistance.
Links
SlopePatternLineOffset Class, SlopePatternLineOffset Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineOffset::MinimumDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties > SlopePatternLineOffset::MinimumDistance Property
SlopePatternLineOffset::MinimumDistance Property
Collapse All

Specifies minimum offsets value in drawing units.

C#
public double MinimumDistance;
Visual Basic
Public Property MinimumDistance() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the MinimumDistance value is larger than MaximumDistance.
Links
SlopePatternLineOffset Class, SlopePatternLineOffset Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineOffset::Numberoflines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties > SlopePatternLineOffset::Numberoflines Property
SlopePatternLineOffset::Numberoflines Property
Collapse All

Specifies the number of instances of this component to insert.

C#
public int Numberoflines;
Visual Basic
Public Property Numberoflines() As Integer
Links
SlopePatternLineOffset Class, SlopePatternLineOffset Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineOffset::OffsetType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties > SlopePatternLineOffset::OffsetType Property
SlopePatternLineOffset::OffsetType Property
Collapse All

Specifies how to determine the offset distance between this component and the previous component in the slope line style.

C#
public Autodesk::Civil::Land::SlopePatternOffsetType OffsetType;
Visual Basic
Public Property OffsetType() As Autodesk::Civil::Land::SlopePatternOffsetType
Exceptions
Exceptions | Description
System::InvalidOperationException | Throw when setting the property to SlopePatternOffsetType::Divide but the previous or next component is set to SlopePatternOffsetType::Divide already.
Links
SlopePatternLineOffset Class, SlopePatternLineOffset Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineOffset::PercentofLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties > SlopePatternLineOffset::PercentofLength Property
SlopePatternLineOffset::PercentofLength Property
Collapse All

Specifies the percentage to the slope length at the position being offset from.

C#
public double PercentofLength;
Visual Basic
Public Property PercentofLength() As double
Links
SlopePatternLineOffset Class, SlopePatternLineOffset Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineOffset::RadialOffsetAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties > SlopePatternLineOffset::RadialOffsetAngle Property
SlopePatternLineOffset::RadialOffsetAngle Property
Collapse All

Specifies the angular value.

C#
public double RadialOffsetAngle;
Visual Basic
Public Property RadialOffsetAngle() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the RadialOffsetAngle is out of range[0, 2PI).
Links
SlopePatternLineOffset Class, SlopePatternLineOffset Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class
SlopePatternLineSymbol Class
Collapse All

Defines the symbol used with a SlopePatternComponent.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternLineSymbol
C#
public class SlopePatternLineSymbol : CivilWrapper<AeccDbSlopePatternStyle>;
Visual Basic
Public Class SlopePatternLineSymbol
Inherits CivilWrapper<AeccDbSlopePatternStyle>
Links
SlopePatternLineSymbol Properties, SlopePatternLineSymbol Members, Class Hierarchy


SlopePatternLineSymbol Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Members
SlopePatternLineSymbol Members
Collapse All

The following tables list the members exposed by SlopePatternLineSymbol.

Public Properties
Public Property | Description
BlockName | Specifies the block to insert.
Color | Specifies the color of the symbol.
Length | Specifies the length value in drawing units (usually feet or meters).
LengthType | Specifies how to determine the length of the symbol.
Linetype | Specifies the linetype for the symbol.
LineWeight | Specifies the lineweight for the symbol.
Numberoflines | Specifies the number of lines to include in the tapered lines set.
PercentofLength | Specifies the percentage value to the slope length.
SymbolType | Specifies whether a symbol is added to the beginning of the slope line.
WidthRatio | Specifies the ratio of the symbol’s width to its length along the slope line (width = length * width ratio).... more
Links
Public Properties


SlopePatternLineSymbol Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties
SlopePatternLineSymbol Properties
Collapse All

The properties of SlopePatternLineSymbol are listed here.

Public Properties
Public Property | Description
BlockName | Specifies the block to insert.
Color | Specifies the color of the symbol.
Length | Specifies the length value in drawing units (usually feet or meters).
LengthType | Specifies how to determine the length of the symbol.
Linetype | Specifies the linetype for the symbol.
LineWeight | Specifies the lineweight for the symbol.
Numberoflines | Specifies the number of lines to include in the tapered lines set.
PercentofLength | Specifies the percentage value to the slope length.
SymbolType | Specifies whether a symbol is added to the beginning of the slope line.
WidthRatio | Specifies the ratio of the symbol’s width to its length along the slope line (width = length * width ratio).... more
Links
Public Properties


SlopePatternLineSymbol::BlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::BlockName Property
SlopePatternLineSymbol::BlockName Property
Collapse All

Specifies the block to insert.

C#
public System::String BlockName;
Visual Basic
Public Property BlockName() As System::String
Remarks

"" is a valid value for this property; it indicates that the block is null.

Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol::Color Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::Color Property
SlopePatternLineSymbol::Color Property
Collapse All

Specifies the color of the symbol.

C#
public Autodesk::AutoCAD::Colors::Color Color;
Visual Basic
Public Property Color() As Autodesk::AutoCAD::Colors::Color
Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::Length Property
SlopePatternLineSymbol::Length Property
Collapse All

Specifies the length value in drawing units (usually feet or meters).

C#
public double Length;
Visual Basic
Public Property Length() As double
Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol::LengthType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::LengthType Property
SlopePatternLineSymbol::LengthType Property
Collapse All

Specifies how to determine the length of the symbol.

C#
public Autodesk::Civil::Land::SlopePatternLengthType LengthType;
Visual Basic
Public Property LengthType() As Autodesk::Civil::Land::SlopePatternLengthType
Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol::Linetype Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::Linetype Property
SlopePatternLineSymbol::Linetype Property
Collapse All

Specifies the linetype for the symbol.

C#
public System::String Linetype;
Visual Basic
Public Property Linetype() As System::String
Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol::LineWeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::LineWeight Property
SlopePatternLineSymbol::LineWeight Property
Collapse All

Specifies the lineweight for the symbol.

C#
public Autodesk::AutoCAD::DatabaseServices::LineWeight LineWeight;
Visual Basic
Public Property LineWeight() As Autodesk::AutoCAD::DatabaseServices::LineWeight
Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol::Numberoflines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::Numberoflines Property
SlopePatternLineSymbol::Numberoflines Property
Collapse All

Specifies the number of lines to include in the tapered lines set.

C#
public int Numberoflines;
Visual Basic
Public Property Numberoflines() As Integer
Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol::PercentofLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::PercentofLength Property
SlopePatternLineSymbol::PercentofLength Property
Collapse All

Specifies the percentage value to the slope length.

C#
public double PercentofLength;
Visual Basic
Public Property PercentofLength() As double
Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol::SymbolType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::SymbolType Property
SlopePatternLineSymbol::SymbolType Property
Collapse All

Specifies whether a symbol is added to the beginning of the slope line.

C#
public Autodesk::Civil::Land::SlopePatternSymbolType SymbolType;
Visual Basic
Public Property SymbolType() As Autodesk::Civil::Land::SlopePatternSymbolType
Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternLineSymbol::WidthRatio Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties > SlopePatternLineSymbol::WidthRatio Property
SlopePatternLineSymbol::WidthRatio Property
Collapse All

Specifies the ratio of the symbol’s width to its length along the slope line (width = length * width ratio).

C#
public double WidthRatio;
Visual Basic
Public Property WidthRatio() As double
Links
SlopePatternLineSymbol Class, SlopePatternLineSymbol Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class
SlopePatternStyle Class
Collapse All

A style that defines the pattern that represents a slope in a grading style.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSlopePatternStyle"))]
public class SlopePatternStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSlopePatternStyle"))>
Public Class SlopePatternStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
SlopePatternStyle Methods, SlopePatternStyle Properties, SlopePatternStyle Members, Class Hierarchy


SlopePatternStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Members
SlopePatternStyle Members
Collapse All

The following tables list the members exposed by SlopePatternStyle.

Public Methods
Public Method | Description
AddComponent | Adds a new component using the default parameters in a specified position.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
CopyComponent | Copy a component and insert into the slope pattern style.
ExportTo | Overloaded
RemoveAt | Removes the component from the collection by the specified index.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets slope pattern style components' count.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the slope pattern component by index.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MinDisplayLength | Gets or sets the minimum slope length on which to display the slope pattern.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PreviewFeatureLength | Gets or sets the length of the feature line to display.
PreviewSlope | Gets or sets the slope value to display.
PreviewSlopeLength | Gets or sets the length of the slope to display.
Links
Public Methods, Public Properties


SlopePatternStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Methods
SlopePatternStyle Methods
Collapse All

The methods of SlopePatternStyle are listed here.

Public Methods
Public Method | Description
AddComponent | Adds a new component using the default parameters in a specified position.
CopyComponent | Copy a component and insert into the slope pattern style.
RemoveAt | Removes the component from the collection by the specified index.
Links
Public Methods


SlopePatternStyle::AddComponent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Methods > SlopePatternStyle::AddComponent Method
SlopePatternStyle::AddComponent Method
Collapse All

Adds a new component using the default parameters in a specified position.

C#
public AddComponent(
    int position
);
Visual Basic
Public Sub AddComponent(
    position As Integer
)
Parameters
Parameters | Description
position | The position of the new component in relation to existing components.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the position is less than 0 or greater than the component's count.
Links
SlopePatternStyle Class, SlopePatternStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyle::CopyComponent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Methods > SlopePatternStyle::CopyComponent Method
SlopePatternStyle::CopyComponent Method
Collapse All

Copy a component and insert into the slope pattern style.

C#
public CopyComponent(
    int index,
    int insertPosition
);
Visual Basic
Public Sub CopyComponent(
    index As Integer,
    insertPosition As Integer
)
Parameters
Parameters | Description
index | The index in the collection.
insertPosition | The position of the new component in relation to existing components.
Remarks

You can use the parameter- insertPosition as a index to get the component in the slope pattern style.

Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the collecton range.
System.ArgumentException | Thrown when the insertPosition is less than 0 or greater than the component's count.
System::InvalidOperationException | Throw when the offset type of component specified by the index is SlopePatternOffsetType::Divide.
Links
SlopePatternStyle Class, SlopePatternStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyle::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Methods > SlopePatternStyle::RemoveAt Method
SlopePatternStyle::RemoveAt Method
Collapse All

Removes the component from the collection by the specified index.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | The index in the collection.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when index is out of the collecton range.
System::InvalidOperationException | Throw when 1: Only one component exists. 2: The offset type of previous or next component specified by the index is SlopePatternOffsetType::Divide.
Links
SlopePatternStyle Class, SlopePatternStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Properties
SlopePatternStyle Properties
Collapse All

The properties of SlopePatternStyle are listed here.

Public Properties
Public Property | Description
Count | Gets slope pattern style components' count.
default | Gets the slope pattern component by index.
MinDisplayLength | Gets or sets the minimum slope length on which to display the slope pattern.
PreviewFeatureLength | Gets or sets the length of the feature line to display.
PreviewSlope | Gets or sets the slope value to display.
PreviewSlopeLength | Gets or sets the length of the slope to display.
Links
Public Properties


SlopePatternStyle::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Properties > SlopePatternStyle::Count Property
SlopePatternStyle::Count Property
Collapse All

Gets slope pattern style components' count.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
SlopePatternStyle Class, SlopePatternStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyle::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Properties > SlopePatternStyle::default Property
SlopePatternStyle::default Property
Collapse All

Gets the slope pattern component by index.

C#
public SlopePatternComponent default;
Visual Basic
Public Property default() As SlopePatternComponent
Parameters
Parameters | Description
index | Specified the slope pattern component by index.
Links
SlopePatternStyle Class, SlopePatternStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyle::MinDisplayLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Properties > SlopePatternStyle::MinDisplayLength Property
SlopePatternStyle::MinDisplayLength Property
Collapse All

Gets or sets the minimum slope length on which to display the slope pattern.

C#
public double MinDisplayLength;
Visual Basic
Public Property MinDisplayLength() As double
Links
SlopePatternStyle Class, SlopePatternStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyle::PreviewFeatureLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Properties > SlopePatternStyle::PreviewFeatureLength Property
SlopePatternStyle::PreviewFeatureLength Property
Collapse All

Gets or sets the length of the feature line to display.

C#
public double PreviewFeatureLength;
Visual Basic
Public Property PreviewFeatureLength() As double
Links
SlopePatternStyle Class, SlopePatternStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyle::PreviewSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Properties > SlopePatternStyle::PreviewSlope Property
SlopePatternStyle::PreviewSlope Property
Collapse All

Gets or sets the slope value to display.

C#
public double PreviewSlope;
Visual Basic
Public Property PreviewSlope() As double
Links
SlopePatternStyle Class, SlopePatternStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyle::PreviewSlopeLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Properties > SlopePatternStyle::PreviewSlopeLength Property
SlopePatternStyle::PreviewSlopeLength Property
Collapse All

Gets or sets the length of the slope to display.

C#
public double PreviewSlopeLength;
Visual Basic
Public Property PreviewSlopeLength() As double
Links
SlopePatternStyle Class, SlopePatternStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SlopePatternStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class
SlopePatternStyleCollection Class
Collapse All

The SlopePatternStyleCollection class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyleCollection
C#
public class SlopePatternStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class SlopePatternStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
SlopePatternStyleCollection Methods, SlopePatternStyleCollection Members, Class Hierarchy


SlopePatternStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class > SlopePatternStyleCollection Members
SlopePatternStyleCollection Members
Collapse All

The following tables list the members exposed by SlopePatternStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


SlopePatternStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class > SlopePatternStyleCollection Methods
SlopePatternStyleCollection Methods
Collapse All

The methods of SlopePatternStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


SlopePatternStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class > SlopePatternStyleCollection Methods > SlopePatternStyleCollection::Add Method
SlopePatternStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
SlopePatternStyleCollection Class, SlopePatternStyleCollection Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class
SuperelevationDataBandStyle Class
Collapse All

The super elevation data band style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SuperelevationDataBandStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleSuperElevationBands"))]
public class SuperelevationDataBandStyle : Autodesk::Civil::DatabaseServices::Styles::BandStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleSuperElevationBands"))>
Public Class SuperelevationDataBandStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::BandStyle
Links
SuperelevationDataBandStyle Methods, SuperelevationDataBandStyle Properties, SuperelevationDataBandStyle Members, Class Hierarchy


SuperelevationDataBandStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Members
SuperelevationDataBandStyle Members
Collapse All

The following tables list the members exposed by SuperelevationDataBandStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SuperelevationData component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
FullSuperLabelStyleId | Gets the band label style id at the full super.
FullSuperTickStyle | Gets the band tick style at the full super.
LevelCrownLabelStyleId | Gets the band label style id at the level crown.
LevelCrownTickStyle | Gets the band tick style at the level crown.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
NormalCrownLabelStyleId | Gets the band label style id at the normal crown.
NormalCrownTickStyle | Gets the band tick style at the normal crown.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
ReverseCrownLabelStyleId | Gets the band label style id at the reverse crown.
ReverseCrownTickStyle | Gets the band tick style at the reverse crown.
ShoulderCriticalPointsLabelStyleId | Gets the band label style id at the shoulder critical points.
ShoulderCriticalPointsTickStyle | Gets the band tick style at the shoulder critical points.
SlopeTransitionRegionLabelStyleId | Gets the band label style id at the slope transition region.
SlopeTransitionRegionTickStyle | Gets the band tick style at the slope transition region.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Methods, Public Properties


SuperelevationDataBandStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Methods
SuperelevationDataBandStyle Methods
Collapse All

The methods of SuperelevationDataBandStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SuperelevationData component.
Links
Public Methods


SuperelevationDataBandStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Methods > SuperelevationDataBandStyle::GetDisplayStylePlan Method
SuperelevationDataBandStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the SuperelevationData component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    SuperelevationDataDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As SuperelevationDataDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties
SuperelevationDataBandStyle Properties
Collapse All

The properties of SuperelevationDataBandStyle are listed here.

Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
FullSuperLabelStyleId | Gets the band label style id at the full super.
FullSuperTickStyle | Gets the band tick style at the full super.
LevelCrownLabelStyleId | Gets the band label style id at the level crown.
LevelCrownTickStyle | Gets the band tick style at the level crown.
NormalCrownLabelStyleId | Gets the band label style id at the normal crown.
NormalCrownTickStyle | Gets the band tick style at the normal crown.
ReverseCrownLabelStyleId | Gets the band label style id at the reverse crown.
ReverseCrownTickStyle | Gets the band tick style at the reverse crown.
ShoulderCriticalPointsLabelStyleId | Gets the band label style id at the shoulder critical points.
ShoulderCriticalPointsTickStyle | Gets the band tick style at the shoulder critical points.
SlopeTransitionRegionLabelStyleId | Gets the band label style id at the slope transition region.
SlopeTransitionRegionTickStyle | Gets the band tick style at the slope transition region.
TitleTextLabelStyleId | Gets the band profile data title text label style.
Links
Public Properties


SuperelevationDataBandStyle::BandType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::BandType Property
SuperelevationDataBandStyle::BandType Property
Collapse All

Gets the BandStyleType enum value that specifies the type of data band data.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandStyleType BandType;
Visual Basic
Public Property BandType() As Autodesk::Civil::DatabaseServices::Styles::BandStyleType
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::FullSuperLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::FullSuperLabelStyleId Property
SuperelevationDataBandStyle::FullSuperLabelStyleId Property
Collapse All

Gets the band label style id at the full super.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId FullSuperLabelStyleId;
Visual Basic
Public Property FullSuperLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::FullSuperTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::FullSuperTickStyle Property
SuperelevationDataBandStyle::FullSuperTickStyle Property
Collapse All

Gets the band tick style at the full super.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle FullSuperTickStyle;
Visual Basic
Public Property FullSuperTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::LevelCrownLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::LevelCrownLabelStyleId Property
SuperelevationDataBandStyle::LevelCrownLabelStyleId Property
Collapse All

Gets the band label style id at the level crown.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LevelCrownLabelStyleId;
Visual Basic
Public Property LevelCrownLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::LevelCrownTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::LevelCrownTickStyle Property
SuperelevationDataBandStyle::LevelCrownTickStyle Property
Collapse All

Gets the band tick style at the level crown.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle LevelCrownTickStyle;
Visual Basic
Public Property LevelCrownTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::NormalCrownLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::NormalCrownLabelStyleId Property
SuperelevationDataBandStyle::NormalCrownLabelStyleId Property
Collapse All

Gets the band label style id at the normal crown.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId NormalCrownLabelStyleId;
Visual Basic
Public Property NormalCrownLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::NormalCrownTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::NormalCrownTickStyle Property
SuperelevationDataBandStyle::NormalCrownTickStyle Property
Collapse All

Gets the band tick style at the normal crown.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle NormalCrownTickStyle;
Visual Basic
Public Property NormalCrownTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::ReverseCrownLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::ReverseCrownLabelStyleId Property
SuperelevationDataBandStyle::ReverseCrownLabelStyleId Property
Collapse All

Gets the band label style id at the reverse crown.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ReverseCrownLabelStyleId;
Visual Basic
Public Property ReverseCrownLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::ReverseCrownTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::ReverseCrownTickStyle Property
SuperelevationDataBandStyle::ReverseCrownTickStyle Property
Collapse All

Gets the band tick style at the reverse crown.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle ReverseCrownTickStyle;
Visual Basic
Public Property ReverseCrownTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::ShoulderCriticalPointsLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::ShoulderCriticalPointsLabelStyleId Property
SuperelevationDataBandStyle::ShoulderCriticalPointsLabelStyleId Property
Collapse All

Gets the band label style id at the shoulder critical points.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ShoulderCriticalPointsLabelStyleId;
Visual Basic
Public Property ShoulderCriticalPointsLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::ShoulderCriticalPointsTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::ShoulderCriticalPointsTickStyle Property
SuperelevationDataBandStyle::ShoulderCriticalPointsTickStyle Property
Collapse All

Gets the band tick style at the shoulder critical points.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle ShoulderCriticalPointsTickStyle;
Visual Basic
Public Property ShoulderCriticalPointsTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::SlopeTransitionRegionLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::SlopeTransitionRegionLabelStyleId Property
SuperelevationDataBandStyle::SlopeTransitionRegionLabelStyleId Property
Collapse All

Gets the band label style id at the slope transition region.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SlopeTransitionRegionLabelStyleId;
Visual Basic
Public Property SlopeTransitionRegionLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::SlopeTransitionRegionTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::SlopeTransitionRegionTickStyle Property
SuperelevationDataBandStyle::SlopeTransitionRegionTickStyle Property
Collapse All

Gets the band tick style at the slope transition region.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle SlopeTransitionRegionTickStyle;
Visual Basic
Public Property SlopeTransitionRegionTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SuperelevationDataBandStyle::TitleTextLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties > SuperelevationDataBandStyle::TitleTextLabelStyleId Property
SuperelevationDataBandStyle::TitleTextLabelStyleId Property
Collapse All

Gets the band profile data title text label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TitleTextLabelStyleId;
Visual Basic
Public Property TitleTextLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Links
SuperelevationDataBandStyle Class, SuperelevationDataBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceBaseStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class
SurfaceBaseStyle Class
Collapse All

The surface base style class

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceContourStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDirectionStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceElevationStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfacePointStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceSlopeArrowStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceSlopeStyle
C#
public class SurfaceBaseStyle : CivilWrapper<AeccDbSurfaceStyle>;
Visual Basic
Public Class SurfaceBaseStyle
Inherits CivilWrapper<AeccDbSurfaceStyle>
Links
SurfaceBaseStyle Properties, SurfaceBaseStyle Members, Class Hierarchy


SurfaceBaseStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class > SurfaceBaseStyle Members
SurfaceBaseStyle Members
Collapse All

The following tables list the members exposed by SurfaceBaseStyle.

Public Properties
Public Property | Description
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
Links
Public Properties


SurfaceBaseStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class > SurfaceBaseStyle Properties
SurfaceBaseStyle Properties
Collapse All

The properties of SurfaceBaseStyle are listed here.

Public Properties
Public Property | Description
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
Links
Public Properties


SurfaceBaseStyle::DisplayMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class > SurfaceBaseStyle Properties > SurfaceBaseStyle::DisplayMode Property
SurfaceBaseStyle::DisplayMode Property
Collapse All

Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.

C#
public SurfaceDisplay3dType DisplayMode;
Visual Basic
Public Property DisplayMode() As SurfaceDisplay3dType
Links
SurfaceBaseStyle Class, SurfaceBaseStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceBaseStyle::ExaggerateElevationBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class > SurfaceBaseStyle Properties > SurfaceBaseStyle::ExaggerateElevationBy Property
SurfaceBaseStyle::ExaggerateElevationBy Property
Collapse All

Gets or sets the double value by which the surface object component elevation values are scaled.

C#
public double ExaggerateElevationBy;
Visual Basic
Public Property ExaggerateElevationBy() As double
Remarks

This property is controlled by DisplayMode, it is usable only when DisplayMode is set to ExaggerateElevations.

Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [0.0, 999999999999999980000000.0].
Links
SurfaceBaseStyle Class, SurfaceBaseStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceBaseStyle::FlattenToElevationBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class > SurfaceBaseStyle Properties > SurfaceBaseStyle::FlattenToElevationBy Property
SurfaceBaseStyle::FlattenToElevationBy Property
Collapse All

Gets or sets the double value to which the surface object component is flattened, or projected.

C#
public double FlattenToElevationBy;
Visual Basic
Public Property FlattenToElevationBy() As double
Remarks

This property is controlled by DisplayMode, it is usable only when DisplayMode is set to FlattenElevations.

Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [-1.0e+24, 1.0e+24].
Links
SurfaceBaseStyle Class, SurfaceBaseStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class
SurfaceContourStyle Class
Collapse All

The surface boundary style class

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceContourStyle
C#
public class SurfaceContourStyle : SurfaceBaseStyle;
Visual Basic
Public Class SurfaceContourStyle
Inherits SurfaceBaseStyle
Links
SurfaceContourStyle Methods, SurfaceContourStyle Properties, SurfaceContourStyle Members, Class Hierarchy


SurfaceContourStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Members
SurfaceContourStyle Members
Collapse All

The following tables list the members exposed by SurfaceContourStyle.

Public Methods
Public Method | Description
GetContourValues | Gets an array of ContourValues that represent how to render major and minor contours.
Public Properties
Public Property | Description
BaseElevationInterval | Gets or sets the double value used to specify the contour base elevation interval.
DepressionTickMarkInterval | Gets or sets the double value that specifies the spacing of the tick marks along the depression contour.
DepressionTickMarkLength | Gets or sets the double value that specifies the length of the tick mark that is drawn normal to the... more
DisplayDepressions | Gets or sets the boolean value that specifies whether depression contours are displayed.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupRangeValuesBy | Gets or sets the GroupValuesByType enum value used to specify how to group the contour range values.
LegendStyleId | Gets or sets the string value that specifies the surface contour legend style.
LegendStyleName | Gets or sets the string value that specifies the surface contour legend style.
MajorContourColorScheme | Gets or sets the major color scheme for the contour range.
MajorContourInterval | Gets or sets the double value used to specify the number of minor contours per major contour.
MinorContourColorScheme | Gets or sets the minor color scheme for the contour range.
MinorContourInterval | Gets or sets the double value used to specify the contour interval.
NumberOfRanges | Gets or sets the long value that specifies the number of ranges to be used.
RangePrecision | Gets or sets the PrecisionRangeType enum value that specifies the range precision.
SmoothContours | Gets or sets the boolean value that specifies whether contours are smoothed.
SmoothingFactor | Gets or sets an int value that specifies the degree to which the surface is smoothed.
SmoothingType | Gets or sets the ContourSmoothingType enum value that specifies the type of smoothing used. This property is usable only when... more
UseColorScheme | Gets or sets the boolean value that specifies whether the major and minor color schemes are displayed.
Links
Public Methods, Public Properties


SurfaceContourStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Methods
SurfaceContourStyle Methods
Collapse All

The methods of SurfaceContourStyle are listed here.

Public Methods
Public Method | Description
GetContourValues | Gets an array of ContourValues that represent how to render major and minor contours.
Links
Public Methods


SurfaceContourStyle::GetContourValues Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Methods > SurfaceContourStyle::GetContourValues Method
SurfaceContourStyle::GetContourValues Method
Collapse All

Gets an array of ContourValues that represent how to render major and minor contours.

C#
public array<ContourValues^> GetContourValues();
Visual Basic
Public Function GetContourValues() As array<ContourValues^>
Remarks

Since this value is initialized in UI code, this method returns an empty array the first time it is called.

Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties
SurfaceContourStyle Properties
Collapse All

The properties of SurfaceContourStyle are listed here.

Public Properties
Public Property | Description
BaseElevationInterval | Gets or sets the double value used to specify the contour base elevation interval.
DepressionTickMarkInterval | Gets or sets the double value that specifies the spacing of the tick marks along the depression contour.
DepressionTickMarkLength | Gets or sets the double value that specifies the length of the tick mark that is drawn normal to the... more
DisplayDepressions | Gets or sets the boolean value that specifies whether depression contours are displayed.
GroupRangeValuesBy | Gets or sets the GroupValuesByType enum value used to specify how to group the contour range values.
LegendStyleId | Gets or sets the string value that specifies the surface contour legend style.
LegendStyleName | Gets or sets the string value that specifies the surface contour legend style.
MajorContourColorScheme | Gets or sets the major color scheme for the contour range.
MajorContourInterval | Gets or sets the double value used to specify the number of minor contours per major contour.
MinorContourColorScheme | Gets or sets the minor color scheme for the contour range.
MinorContourInterval | Gets or sets the double value used to specify the contour interval.
NumberOfRanges | Gets or sets the long value that specifies the number of ranges to be used.
RangePrecision | Gets or sets the PrecisionRangeType enum value that specifies the range precision.
SmoothContours | Gets or sets the boolean value that specifies whether contours are smoothed.
SmoothingFactor | Gets or sets an int value that specifies the degree to which the surface is smoothed.
SmoothingType | Gets or sets the ContourSmoothingType enum value that specifies the type of smoothing used. This property is usable only when... more
UseColorScheme | Gets or sets the boolean value that specifies whether the major and minor color schemes are displayed.
Links
Public Properties


SurfaceContourStyle::BaseElevationInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::BaseElevationInterval Property
SurfaceContourStyle::BaseElevationInterval Property
Collapse All

Gets or sets the double value used to specify the contour base elevation interval.

C#
public double BaseElevationInterval;
Visual Basic
Public Property BaseElevationInterval() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [-1.0e+24, 1.0e+24].
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::DepressionTickMarkInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::DepressionTickMarkInterval Property
SurfaceContourStyle::DepressionTickMarkInterval Property
Collapse All

Gets or sets the double value that specifies the spacing of the tick marks along the depression contour.

C#
public double DepressionTickMarkInterval;
Visual Basic
Public Property DepressionTickMarkInterval() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [0.0, 1.0e+24]. This property is usable only when DisplayDepressions is set to true.
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::DepressionTickMarkLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::DepressionTickMarkLength Property
SurfaceContourStyle::DepressionTickMarkLength Property
Collapse All

Gets or sets the double value that specifies the length of the tick mark that is drawn normal to the depression contour.

C#
public double DepressionTickMarkLength;
Visual Basic
Public Property DepressionTickMarkLength() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [0.0, 1.0e+24]. This property is usable only when DisplayDepressions is set to true.
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::DisplayDepressions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::DisplayDepressions Property
SurfaceContourStyle::DisplayDepressions Property
Collapse All

Gets or sets the boolean value that specifies whether depression contours are displayed.

C#
public bool DisplayDepressions;
Visual Basic
Public Property DisplayDepressions() As bool
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::GroupRangeValuesBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::GroupRangeValuesBy Property
SurfaceContourStyle::GroupRangeValuesBy Property
Collapse All

Gets or sets the GroupValuesByType enum value used to specify how to group the contour range values.

C#
public SurfaceGroupValuesByType GroupRangeValuesBy;
Visual Basic
Public Property GroupRangeValuesBy() As SurfaceGroupValuesByType
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::LegendStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::LegendStyleId Property
SurfaceContourStyle::LegendStyleId Property
Collapse All

Gets or sets the string value that specifies the surface contour legend style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LegendStyleId;
Visual Basic
Public Property LegendStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified table style id is not existed.
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::LegendStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::LegendStyleName Property
SurfaceContourStyle::LegendStyleName Property
Collapse All

Gets or sets the string value that specifies the surface contour legend style.

C#
public System::String LegendStyleName;
Visual Basic
Public Property LegendStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified table style name is not existed.
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::MajorContourColorScheme Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::MajorContourColorScheme Property
SurfaceContourStyle::MajorContourColorScheme Property
Collapse All

Gets or sets the major color scheme for the contour range.

C#
public ColorSchemeType MajorContourColorScheme;
Visual Basic
Public Property MajorContourColorScheme() As ColorSchemeType
Remarks

The color scheme can be one of the following: Blues, Greens, Hydro, Land, Pastels, Rainbow, Reds. This property is usable only when UseColorScheme is set to true.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input color scheme is not existed.
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::MajorContourInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::MajorContourInterval Property
SurfaceContourStyle::MajorContourInterval Property
Collapse All

Gets or sets the double value used to specify the number of minor contours per major contour.

C#
public double MajorContourInterval;
Visual Basic
Public Property MajorContourInterval() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [-1.0e+24, 1.0e+24].
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::MinorContourColorScheme Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::MinorContourColorScheme Property
SurfaceContourStyle::MinorContourColorScheme Property
Collapse All

Gets or sets the minor color scheme for the contour range.

C#
public ColorSchemeType MinorContourColorScheme;
Visual Basic
Public Property MinorContourColorScheme() As ColorSchemeType
Remarks

The color scheme can be one of the following: Blues, Greens, Hydro, Land, Pastels, Rainbow, Reds. This property is usable only when UseColorScheme is set to true.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input color scheme is not existed.
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::MinorContourInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::MinorContourInterval Property
SurfaceContourStyle::MinorContourInterval Property
Collapse All

Gets or sets the double value used to specify the contour interval.

C#
public double MinorContourInterval;
Visual Basic
Public Property MinorContourInterval() As double
Remarks

This value is representative of the drawing's linear units.

Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval[-1.0e+24, 1.0e+24].
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::NumberOfRanges Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::NumberOfRanges Property
SurfaceContourStyle::NumberOfRanges Property
Collapse All

Gets or sets the long value that specifies the number of ranges to be used.

C#
public int NumberOfRanges;
Visual Basic
Public Property NumberOfRanges() As Integer
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [1, 200].
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::RangePrecision Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::RangePrecision Property
SurfaceContourStyle::RangePrecision Property
Collapse All

Gets or sets the PrecisionRangeType enum value that specifies the range precision.

C#
public PrecisionRangeType RangePrecision;
Visual Basic
Public Property RangePrecision() As PrecisionRangeType
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::SmoothContours Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::SmoothContours Property
SurfaceContourStyle::SmoothContours Property
Collapse All

Gets or sets the boolean value that specifies whether contours are smoothed.

C#
public bool SmoothContours;
Visual Basic
Public Property SmoothContours() As bool
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::SmoothingFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::SmoothingFactor Property
SurfaceContourStyle::SmoothingFactor Property
Collapse All

Gets or sets an int value that specifies the degree to which the surface is smoothed.

C#
public int SmoothingFactor;
Visual Basic
Public Property SmoothingFactor() As Integer
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [0, 10].
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::SmoothingType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::SmoothingType Property
SurfaceContourStyle::SmoothingType Property
Collapse All

Gets or sets the ContourSmoothingType enum value that specifies the type of smoothing used. This property is usable only when SmoothContours is set to true.

C#
public ContourSmoothingType SmoothingType;
Visual Basic
Public Property SmoothingType() As ContourSmoothingType
Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceContourStyle::UseColorScheme Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties > SurfaceContourStyle::UseColorScheme Property
SurfaceContourStyle::UseColorScheme Property
Collapse All

Gets or sets the boolean value that specifies whether the major and minor color schemes are displayed.

C#
public bool UseColorScheme;
Visual Basic
Public Property UseColorScheme() As bool
Remarks

A value of true indicates that color schemes are displayed.

Links
SurfaceContourStyle Class, SurfaceContourStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceDirectionStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class
SurfaceDirectionStyle Class
Collapse All

The surface boundary style class

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDirectionStyle
C#
public class SurfaceDirectionStyle : SurfaceBaseStyle;
Visual Basic
Public Class SurfaceDirectionStyle
Inherits SurfaceBaseStyle
Links
SurfaceDirectionStyle Properties, SurfaceDirectionStyle Members, Class Hierarchy


SurfaceDirectionStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Members
SurfaceDirectionStyle Members
Collapse All

The following tables list the members exposed by SurfaceDirectionStyle.

Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme name.
DisplayEntityMode | Gets or sets the DisplayType Specifies how the surface should be displayed/rendered.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface directional data is grouped.
LegendStyleId | Gets or sets the ObjectId value that specifies the surface direction legend style.
LegendStyleName | Gets or sets the string value that specifies the surface direction legend style.
NumberOfRanges | Gets or sets the number of directional ranges.
RangePrecision | Gets or sets the PrecisionRangeType Specifies the precision to use for the directional ranges included in this style.
Links
Public Properties


SurfaceDirectionStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties
SurfaceDirectionStyle Properties
Collapse All

The properties of SurfaceDirectionStyle are listed here.

Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme name.
DisplayEntityMode | Gets or sets the DisplayType Specifies how the surface should be displayed/rendered.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface directional data is grouped.
LegendStyleId | Gets or sets the ObjectId value that specifies the surface direction legend style.
LegendStyleName | Gets or sets the string value that specifies the surface direction legend style.
NumberOfRanges | Gets or sets the number of directional ranges.
RangePrecision | Gets or sets the PrecisionRangeType Specifies the precision to use for the directional ranges included in this style.
Links
Public Properties


SurfaceDirectionStyle::ColorScheme Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties > SurfaceDirectionStyle::ColorScheme Property
SurfaceDirectionStyle::ColorScheme Property
Collapse All

Gets or sets the color scheme name.

C#
public ColorSchemeType ColorScheme;
Visual Basic
Public Property ColorScheme() As ColorSchemeType
Remarks

The color scheme can be one of the following: Blues, Greens, Hydro, Land, Pastels, Rainbow, Reds.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input color scheme is not existed.
Links
SurfaceDirectionStyle Class, SurfaceDirectionStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceDirectionStyle::DisplayEntityMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties > SurfaceDirectionStyle::DisplayEntityMode Property
SurfaceDirectionStyle::DisplayEntityMode Property
Collapse All

Gets or sets the DisplayType Specifies how the surface should be displayed/rendered.

C#
public SurfaceDisplayType DisplayEntityMode;
Visual Basic
Public Property DisplayEntityMode() As SurfaceDisplayType
Links
SurfaceDirectionStyle Class, SurfaceDirectionStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceDirectionStyle::GroupValuesBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties > SurfaceDirectionStyle::GroupValuesBy Property
SurfaceDirectionStyle::GroupValuesBy Property
Collapse All

Gets or sets the GroupValuesByType Specifies how the surface directional data is grouped.

C#
public SurfaceGroupValuesByType GroupValuesBy;
Visual Basic
Public Property GroupValuesBy() As SurfaceGroupValuesByType
Links
SurfaceDirectionStyle Class, SurfaceDirectionStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceDirectionStyle::LegendStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties > SurfaceDirectionStyle::LegendStyleId Property
SurfaceDirectionStyle::LegendStyleId Property
Collapse All

Gets or sets the ObjectId value that specifies the surface direction legend style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LegendStyleId;
Visual Basic
Public Property LegendStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified table style id is not existed.
Links
SurfaceDirectionStyle Class, SurfaceDirectionStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceDirectionStyle::LegendStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties > SurfaceDirectionStyle::LegendStyleName Property
SurfaceDirectionStyle::LegendStyleName Property
Collapse All

Gets or sets the string value that specifies the surface direction legend style.

C#
public System::String LegendStyleName;
Visual Basic
Public Property LegendStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified table style name is not existed.
Links
SurfaceDirectionStyle Class, SurfaceDirectionStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceDirectionStyle::NumberOfRanges Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties > SurfaceDirectionStyle::NumberOfRanges Property
SurfaceDirectionStyle::NumberOfRanges Property
Collapse All

Gets or sets the number of directional ranges.

C#
public int NumberOfRanges;
Visual Basic
Public Property NumberOfRanges() As Integer
Remarks

Surface triangles facing this number of directional ranges will be rendered.

Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [1, 100].
Links
SurfaceDirectionStyle Class, SurfaceDirectionStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceDirectionStyle::RangePrecision Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties > SurfaceDirectionStyle::RangePrecision Property
SurfaceDirectionStyle::RangePrecision Property
Collapse All

Gets or sets the PrecisionRangeType Specifies the precision to use for the directional ranges included in this style.

C#
public PrecisionRangeType RangePrecision;
Visual Basic
Public Property RangePrecision() As PrecisionRangeType
Links
SurfaceDirectionStyle Class, SurfaceDirectionStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceElevationStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class
SurfaceElevationStyle Class
Collapse All

The surface boundary style class

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceElevationStyle
C#
public class SurfaceElevationStyle : SurfaceBaseStyle;
Visual Basic
Public Class SurfaceElevationStyle
Inherits SurfaceBaseStyle
Links
SurfaceElevationStyle Properties, SurfaceElevationStyle Members, Class Hierarchy


SurfaceElevationStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Members
SurfaceElevationStyle Members
Collapse All

The following tables list the members exposed by SurfaceElevationStyle.

Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme for the range.
DisplayEntityMode | Gets or sets the 3D display behavior of the surface object sub-component.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface elevation data is grouped.
LegendStyleId | Gets or sets the ObjectId value that specifies the surface elevation legend style.
LegendStyleName | Gets or sets the string value that specifies the surface elevation legend style.
NumberOfRanges | Gets or sets the number of surface elevation range values to be used.
RangePrecision | Gets or sets the surface elevation range precision value.
Links
Public Properties


SurfaceElevationStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties
SurfaceElevationStyle Properties
Collapse All

The properties of SurfaceElevationStyle are listed here.

Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme for the range.
DisplayEntityMode | Gets or sets the 3D display behavior of the surface object sub-component.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface elevation data is grouped.
LegendStyleId | Gets or sets the ObjectId value that specifies the surface elevation legend style.
LegendStyleName | Gets or sets the string value that specifies the surface elevation legend style.
NumberOfRanges | Gets or sets the number of surface elevation range values to be used.
RangePrecision | Gets or sets the surface elevation range precision value.
Links
Public Properties


SurfaceElevationStyle::ColorScheme Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties > SurfaceElevationStyle::ColorScheme Property
SurfaceElevationStyle::ColorScheme Property
Collapse All

Gets or sets the color scheme for the range.

C#
public ColorSchemeType ColorScheme;
Visual Basic
Public Property ColorScheme() As ColorSchemeType
Remarks

The color scheme can be one of the following: Blues, Greens, Hydro, Land, Pastels, Rainbow, Reds.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input color scheme is not existed.
Links
SurfaceElevationStyle Class, SurfaceElevationStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceElevationStyle::DisplayEntityMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties > SurfaceElevationStyle::DisplayEntityMode Property
SurfaceElevationStyle::DisplayEntityMode Property
Collapse All

Gets or sets the 3D display behavior of the surface object sub-component.

C#
public SurfaceDisplayType DisplayEntityMode;
Visual Basic
Public Property DisplayEntityMode() As SurfaceDisplayType
Links
SurfaceElevationStyle Class, SurfaceElevationStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceElevationStyle::GroupValuesBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties > SurfaceElevationStyle::GroupValuesBy Property
SurfaceElevationStyle::GroupValuesBy Property
Collapse All

Gets or sets the GroupValuesByType Specifies how the surface elevation data is grouped.

C#
public SurfaceGroupValuesByType GroupValuesBy;
Visual Basic
Public Property GroupValuesBy() As SurfaceGroupValuesByType
Links
SurfaceElevationStyle Class, SurfaceElevationStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceElevationStyle::LegendStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties > SurfaceElevationStyle::LegendStyleId Property
SurfaceElevationStyle::LegendStyleId Property
Collapse All

Gets or sets the ObjectId value that specifies the surface elevation legend style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LegendStyleId;
Visual Basic
Public Property LegendStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified table style id is not existed.
Links
SurfaceElevationStyle Class, SurfaceElevationStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceElevationStyle::LegendStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties > SurfaceElevationStyle::LegendStyleName Property
SurfaceElevationStyle::LegendStyleName Property
Collapse All

Gets or sets the string value that specifies the surface elevation legend style.

C#
public System::String LegendStyleName;
Visual Basic
Public Property LegendStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified table style name is not existed.
Links
SurfaceElevationStyle Class, SurfaceElevationStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceElevationStyle::NumberOfRanges Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties > SurfaceElevationStyle::NumberOfRanges Property
SurfaceElevationStyle::NumberOfRanges Property
Collapse All

Gets or sets the number of surface elevation range values to be used.

C#
public int NumberOfRanges;
Visual Basic
Public Property NumberOfRanges() As Integer
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of interval [1, 100].
Links
SurfaceElevationStyle Class, SurfaceElevationStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceElevationStyle::RangePrecision Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties > SurfaceElevationStyle::RangePrecision Property
SurfaceElevationStyle::RangePrecision Property
Collapse All

Gets or sets the surface elevation range precision value.

C#
public PrecisionRangeType RangePrecision;
Visual Basic
Public Property RangePrecision() As PrecisionRangeType
Remarks

The default is .000001.

Links
SurfaceElevationStyle Class, SurfaceElevationStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfacePointStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class
SurfacePointStyle Class
Collapse All

The SurfacePointStyle class.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfacePointStyle
C#
public class SurfacePointStyle : SurfaceBaseStyle;
Visual Basic
Public Class SurfacePointStyle
Inherits SurfaceBaseStyle
Links
SurfacePointStyle Properties, SurfacePointStyle Members, Class Hierarchy


SurfacePointStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Members
SurfacePointStyle Members
Collapse All

The following tables list the members exposed by SurfacePointStyle.

Public Properties
Public Property | Description
DataPointsColor | Gets or sets the value specifying the true color of the data point display.
DataPointsSymbol | Gets or sets the value specifying the symbology of the data point display.
DerivedPointsColor | Gets or sets the value specifying the true color of the derived point display.
DerivedPointsSymbol | Gets or sets the value specifying the symbology of the derived point display.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
NondestructivePointsColor | Gets or sets the value specifying the true color of the non-destructive point display.
NondestructivePointsSymbol | Gets or sets the value specifying the symbology of the non-destructive point display.
ScalingMethodType | Gets or sets the ScaleType enum value that specifies how to scale the point marker.
Units | Gets or sets the units property.
Links
Public Properties


SurfacePointStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties
SurfacePointStyle Properties
Collapse All

The properties of SurfacePointStyle are listed here.

Public Properties
Public Property | Description
DataPointsColor | Gets or sets the value specifying the true color of the data point display.
DataPointsSymbol | Gets or sets the value specifying the symbology of the data point display.
DerivedPointsColor | Gets or sets the value specifying the true color of the derived point display.
DerivedPointsSymbol | Gets or sets the value specifying the symbology of the derived point display.
NondestructivePointsColor | Gets or sets the value specifying the true color of the non-destructive point display.
NondestructivePointsSymbol | Gets or sets the value specifying the symbology of the non-destructive point display.
ScalingMethodType | Gets or sets the ScaleType enum value that specifies how to scale the point marker.
Units | Gets or sets the units property.
Links
Public Properties


SurfacePointStyle::DataPointsColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties > SurfacePointStyle::DataPointsColor Property
SurfacePointStyle::DataPointsColor Property
Collapse All

Gets or sets the value specifying the true color of the data point display.

C#
public Autodesk::AutoCAD::Colors::Color DataPointsColor;
Visual Basic
Public Property DataPointsColor() As Autodesk::AutoCAD::Colors::Color
Links
SurfacePointStyle Class, SurfacePointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfacePointStyle::DataPointsSymbol Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties > SurfacePointStyle::DataPointsSymbol Property
SurfacePointStyle::DataPointsSymbol Property
Collapse All

Gets or sets the value specifying the symbology of the data point display.

C#
public PointSymbolType DataPointsSymbol;
Visual Basic
Public Property DataPointsSymbol() As PointSymbolType
Links
SurfacePointStyle Class, SurfacePointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfacePointStyle::DerivedPointsColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties > SurfacePointStyle::DerivedPointsColor Property
SurfacePointStyle::DerivedPointsColor Property
Collapse All

Gets or sets the value specifying the true color of the derived point display.

C#
public Autodesk::AutoCAD::Colors::Color DerivedPointsColor;
Visual Basic
Public Property DerivedPointsColor() As Autodesk::AutoCAD::Colors::Color
Links
SurfacePointStyle Class, SurfacePointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfacePointStyle::DerivedPointsSymbol Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties > SurfacePointStyle::DerivedPointsSymbol Property
SurfacePointStyle::DerivedPointsSymbol Property
Collapse All

Gets or sets the value specifying the symbology of the derived point display.

C#
public PointSymbolType DerivedPointsSymbol;
Visual Basic
Public Property DerivedPointsSymbol() As PointSymbolType
Links
SurfacePointStyle Class, SurfacePointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfacePointStyle::NondestructivePointsColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties > SurfacePointStyle::NondestructivePointsColor Property
SurfacePointStyle::NondestructivePointsColor Property
Collapse All

Gets or sets the value specifying the true color of the non-destructive point display.

C#
public Autodesk::AutoCAD::Colors::Color NondestructivePointsColor;
Visual Basic
Public Property NondestructivePointsColor() As Autodesk::AutoCAD::Colors::Color
Links
SurfacePointStyle Class, SurfacePointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfacePointStyle::NondestructivePointsSymbol Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties > SurfacePointStyle::NondestructivePointsSymbol Property
SurfacePointStyle::NondestructivePointsSymbol Property
Collapse All

Gets or sets the value specifying the symbology of the non-destructive point display.

C#
public PointSymbolType NondestructivePointsSymbol;
Visual Basic
Public Property NondestructivePointsSymbol() As PointSymbolType
Links
SurfacePointStyle Class, SurfacePointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfacePointStyle::ScalingMethodType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties > SurfacePointStyle::ScalingMethodType Property
SurfacePointStyle::ScalingMethodType Property
Collapse All

Gets or sets the ScaleType enum value that specifies how to scale the point marker.

C#
public ScaleType ScalingMethodType;
Visual Basic
Public Property ScalingMethodType() As ScaleType
Remarks

One of the following: use drawing scale, size relative to screen, size in absolute units.

Links
SurfacePointStyle Class, SurfacePointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfacePointStyle::Units Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties > SurfacePointStyle::Units Property
SurfacePointStyle::Units Property
Collapse All

Gets or sets the units property.

C#
public double Units;
Visual Basic
Public Property Units() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of the interval [0.0000, 1.0e+24].
Links
SurfacePointStyle Class, SurfacePointStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeArrowStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class
SurfaceSlopeArrowStyle Class
Collapse All

The SurfaceSlopeArrowStyle class.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceSlopeArrowStyle
C#
public class SurfaceSlopeArrowStyle : SurfaceBaseStyle;
Visual Basic
Public Class SurfaceSlopeArrowStyle
Inherits SurfaceBaseStyle
Links
SurfaceSlopeArrowStyle Properties, SurfaceSlopeArrowStyle Members, Class Hierarchy


SurfaceSlopeArrowStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Members
SurfaceSlopeArrowStyle Members
Collapse All

The following tables list the members exposed by SurfaceSlopeArrowStyle.

Public Properties
Public Property | Description
ArrowScale | Gets or sets the scale in which slope arrows are drawn.
ArrowType | Gets or sets the SlopeArrowType enum value that specifies the arrowhead style.
ColorScheme | Gets or sets the color scheme for the range.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface slope arrows are grouped.
LegendStyleId | Gets or sets the style for the slope arrow legend.
LegendStyleName | Gets or sets the style for the slope arrow legend.
NumberOfRanges | Gets or sets the number of surface slope arrow range values to be used.
RangePrecision | Gets or sets the surface slope arrow range precision value.
Links
Public Properties


SurfaceSlopeArrowStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties
SurfaceSlopeArrowStyle Properties
Collapse All

The properties of SurfaceSlopeArrowStyle are listed here.

Public Properties
Public Property | Description
ArrowScale | Gets or sets the scale in which slope arrows are drawn.
ArrowType | Gets or sets the SlopeArrowType enum value that specifies the arrowhead style.
ColorScheme | Gets or sets the color scheme for the range.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface slope arrows are grouped.
LegendStyleId | Gets or sets the style for the slope arrow legend.
LegendStyleName | Gets or sets the style for the slope arrow legend.
NumberOfRanges | Gets or sets the number of surface slope arrow range values to be used.
RangePrecision | Gets or sets the surface slope arrow range precision value.
Links
Public Properties


SurfaceSlopeArrowStyle::ArrowScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties > SurfaceSlopeArrowStyle::ArrowScale Property
SurfaceSlopeArrowStyle::ArrowScale Property
Collapse All

Gets or sets the scale in which slope arrows are drawn.

C#
public double ArrowScale;
Visual Basic
Public Property ArrowScale() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of the interval [0.0000, 1.0e+24].
Links
SurfaceSlopeArrowStyle Class, SurfaceSlopeArrowStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeArrowStyle::ArrowType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties > SurfaceSlopeArrowStyle::ArrowType Property
SurfaceSlopeArrowStyle::ArrowType Property
Collapse All

Gets or sets the SlopeArrowType enum value that specifies the arrowhead style.

C#
public SlopeArrowType ArrowType;
Visual Basic
Public Property ArrowType() As SlopeArrowType
Links
SurfaceSlopeArrowStyle Class, SurfaceSlopeArrowStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeArrowStyle::ColorScheme Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties > SurfaceSlopeArrowStyle::ColorScheme Property
SurfaceSlopeArrowStyle::ColorScheme Property
Collapse All

Gets or sets the color scheme for the range.

C#
public ColorSchemeType ColorScheme;
Visual Basic
Public Property ColorScheme() As ColorSchemeType
Remarks

One of the following: Blues, Greens, Hydro, Land, Pastels, Rainbow, Reds.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting a scheme that is not exist.
Links
SurfaceSlopeArrowStyle Class, SurfaceSlopeArrowStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeArrowStyle::GroupValuesBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties > SurfaceSlopeArrowStyle::GroupValuesBy Property
SurfaceSlopeArrowStyle::GroupValuesBy Property
Collapse All

Gets or sets the GroupValuesByType Specifies how the surface slope arrows are grouped.

C#
public SurfaceGroupValuesByType GroupValuesBy;
Visual Basic
Public Property GroupValuesBy() As SurfaceGroupValuesByType
Links
SurfaceSlopeArrowStyle Class, SurfaceSlopeArrowStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeArrowStyle::LegendStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties > SurfaceSlopeArrowStyle::LegendStyleId Property
SurfaceSlopeArrowStyle::LegendStyleId Property
Collapse All

Gets or sets the style for the slope arrow legend.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LegendStyleId;
Visual Basic
Public Property LegendStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting an invalid legend style id.
Links
SurfaceSlopeArrowStyle Class, SurfaceSlopeArrowStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeArrowStyle::LegendStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties > SurfaceSlopeArrowStyle::LegendStyleName Property
SurfaceSlopeArrowStyle::LegendStyleName Property
Collapse All

Gets or sets the style for the slope arrow legend.

C#
public System::String LegendStyleName;
Visual Basic
Public Property LegendStyleName() As System::String
Remarks

For example, 'Standard'.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting a legend style that is not exist.
Links
SurfaceSlopeArrowStyle Class, SurfaceSlopeArrowStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeArrowStyle::NumberOfRanges Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties > SurfaceSlopeArrowStyle::NumberOfRanges Property
SurfaceSlopeArrowStyle::NumberOfRanges Property
Collapse All

Gets or sets the number of surface slope arrow range values to be used.

C#
public int NumberOfRanges;
Visual Basic
Public Property NumberOfRanges() As Integer
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of the interval [1, 100].
Links
SurfaceSlopeArrowStyle Class, SurfaceSlopeArrowStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeArrowStyle::RangePrecision Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties > SurfaceSlopeArrowStyle::RangePrecision Property
SurfaceSlopeArrowStyle::RangePrecision Property
Collapse All

Gets or sets the surface slope arrow range precision value.

C#
public PrecisionRangeType RangePrecision;
Visual Basic
Public Property RangePrecision() As PrecisionRangeType
Remarks

The default is .000001.

Links
SurfaceSlopeArrowStyle Class, SurfaceSlopeArrowStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class
SurfaceSlopeStyle Class
Collapse All

The SurfaceSlopeStyle class.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceSlopeStyle
C#
public class SurfaceSlopeStyle : SurfaceBaseStyle;
Visual Basic
Public Class SurfaceSlopeStyle
Inherits SurfaceBaseStyle
Links
SurfaceSlopeStyle Properties, SurfaceSlopeStyle Members, Class Hierarchy


SurfaceSlopeStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Members
SurfaceSlopeStyle Members
Collapse All

The following tables list the members exposed by SurfaceSlopeStyle.

Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme for the range.
DisplayEntityMode | Gets or sets the 3D display behavior of the surface object sub-component.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface slope data is grouped.
LegendStyleId | Gets or sets the style for the surface slope legend.
LegendStyleName | Gets or sets the style for the surface slope legend.
NumberOfRanges | Gets or sets the number of surface slope range values to be used.
RangePrecision | Gets or sets the surface slope range precision value.
Links
Public Properties


SurfaceSlopeStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties
SurfaceSlopeStyle Properties
Collapse All

The properties of SurfaceSlopeStyle are listed here.

Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme for the range.
DisplayEntityMode | Gets or sets the 3D display behavior of the surface object sub-component.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface slope data is grouped.
LegendStyleId | Gets or sets the style for the surface slope legend.
LegendStyleName | Gets or sets the style for the surface slope legend.
NumberOfRanges | Gets or sets the number of surface slope range values to be used.
RangePrecision | Gets or sets the surface slope range precision value.
Links
Public Properties


SurfaceSlopeStyle::ColorScheme Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties > SurfaceSlopeStyle::ColorScheme Property
SurfaceSlopeStyle::ColorScheme Property
Collapse All

Gets or sets the color scheme for the range.

C#
public ColorSchemeType ColorScheme;
Visual Basic
Public Property ColorScheme() As ColorSchemeType
Remarks

One of the following: Blues, Greens, Hydro, Land, Pastels, Rainbow, Reds.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting a scheme that is not exist.
Links
SurfaceSlopeStyle Class, SurfaceSlopeStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeStyle::DisplayEntityMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties > SurfaceSlopeStyle::DisplayEntityMode Property
SurfaceSlopeStyle::DisplayEntityMode Property
Collapse All

Gets or sets the 3D display behavior of the surface object sub-component.

C#
public SurfaceDisplayType DisplayEntityMode;
Visual Basic
Public Property DisplayEntityMode() As SurfaceDisplayType
Links
SurfaceSlopeStyle Class, SurfaceSlopeStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeStyle::GroupValuesBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties > SurfaceSlopeStyle::GroupValuesBy Property
SurfaceSlopeStyle::GroupValuesBy Property
Collapse All

Gets or sets the GroupValuesByType Specifies how the surface slope data is grouped.

C#
public SurfaceGroupValuesByType GroupValuesBy;
Visual Basic
Public Property GroupValuesBy() As SurfaceGroupValuesByType
Links
SurfaceSlopeStyle Class, SurfaceSlopeStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeStyle::LegendStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties > SurfaceSlopeStyle::LegendStyleId Property
SurfaceSlopeStyle::LegendStyleId Property
Collapse All

Gets or sets the style for the surface slope legend.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LegendStyleId;
Visual Basic
Public Property LegendStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting an invalid legend style id.
Links
SurfaceSlopeStyle Class, SurfaceSlopeStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeStyle::LegendStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties > SurfaceSlopeStyle::LegendStyleName Property
SurfaceSlopeStyle::LegendStyleName Property
Collapse All

Gets or sets the style for the surface slope legend.

C#
public System::String LegendStyleName;
Visual Basic
Public Property LegendStyleName() As System::String
Remarks

For example, 'Standard'.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting a legend style that is not exist.
Links
SurfaceSlopeStyle Class, SurfaceSlopeStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeStyle::NumberOfRanges Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties > SurfaceSlopeStyle::NumberOfRanges Property
SurfaceSlopeStyle::NumberOfRanges Property
Collapse All

Gets or sets the number of surface slope range values to be used.

C#
public int NumberOfRanges;
Visual Basic
Public Property NumberOfRanges() As Integer
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the input value is out of the interval [1, 100].
Links
SurfaceSlopeStyle Class, SurfaceSlopeStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceSlopeStyle::RangePrecision Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties > SurfaceSlopeStyle::RangePrecision Property
SurfaceSlopeStyle::RangePrecision Property
Collapse All

Gets or sets the surface slope range precision value.

C#
public PrecisionRangeType RangePrecision;
Visual Basic
Public Property RangePrecision() As PrecisionRangeType
Remarks

The default is .000001.

Links
SurfaceSlopeStyle Class, SurfaceSlopeStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class
SurfaceStyle Class
Collapse All

The surface style class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSurfaceStyle"))]
public class SurfaceStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSurfaceStyle"))>
Public Class SurfaceStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
SurfaceStyle Methods, SurfaceStyle Properties, SurfaceStyle Members, Class Hierarchy


SurfaceStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Members
SurfaceStyle Members
Collapse All

The following tables list the members exposed by SurfaceStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the surface component Model display color, layer, linetype, etc.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the surface component Plan display color, layer, linetype, etc.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies the surface component Section display color, layer, linetype, etc.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BoundaryStyle | Gets the style object that specifies properties for surface outer, show and hide boundaries/borders.
ContourStyle | Gets the style object that specifies properties for surface minor, major, depression, and user-defined contour lines.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
DirectionStyle | Gets the style object that specifies properties for surface direction analysis components.
Document | Gets the Document associated with the DBObject. Not implemented.
ElevationStyle | Gets the style object that specifies properties for surface elevation analysis components.
GridStyle | Gets the style object that specifies properties for surface primary, secondary, and datum grid information.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PointStyle | Gets the style object that specifies properties for surface point objects.
SlopeArrowStyle | Gets the style object that specifies properties for the surface slope arrow analysis components.
SlopeStyle | Gets the style object that specifies properties for surface slope analysis components.
TriangleStyle | Gets the style object that specifies properties for the surface TIN face components.
WatershedStyle | Gets the style object that specifies properties for the various kinds of surface watershed analysis components.
Links
Public Methods, Public Properties


SurfaceStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Methods
SurfaceStyle Methods
Collapse All

The methods of SurfaceStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the surface component Model display color, layer, linetype, etc.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the surface component Plan display color, layer, linetype, etc.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies the surface component Section display color, layer, linetype, etc.
Links
Public Methods


SurfaceStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Methods > SurfaceStyle::GetDisplayStyleModel Method
SurfaceStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies the surface component Model display color, layer, linetype, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    SurfaceDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As SurfaceDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Methods > SurfaceStyle::GetDisplayStylePlan Method
SurfaceStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies the surface component Plan display color, layer, linetype, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    SurfaceDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As SurfaceDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Methods > SurfaceStyle::GetDisplayStyleSection Method
SurfaceStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle object that specifies the surface component Section display color, layer, linetype, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection();
Visual Basic
Public Function GetDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties
SurfaceStyle Properties
Collapse All

The properties of SurfaceStyle are listed here.

Public Properties
Public Property | Description
BoundaryStyle | Gets the style object that specifies properties for surface outer, show and hide boundaries/borders.
ContourStyle | Gets the style object that specifies properties for surface minor, major, depression, and user-defined contour lines.
DirectionStyle | Gets the style object that specifies properties for surface direction analysis components.
ElevationStyle | Gets the style object that specifies properties for surface elevation analysis components.
GridStyle | Gets the style object that specifies properties for surface primary, secondary, and datum grid information.
PointStyle | Gets the style object that specifies properties for surface point objects.
SlopeArrowStyle | Gets the style object that specifies properties for the surface slope arrow analysis components.
SlopeStyle | Gets the style object that specifies properties for surface slope analysis components.
TriangleStyle | Gets the style object that specifies properties for the surface TIN face components.
WatershedStyle | Gets the style object that specifies properties for the various kinds of surface watershed analysis components.
Links
Public Properties


SurfaceStyle::BoundaryStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::BoundaryStyle Property
SurfaceStyle::BoundaryStyle Property
Collapse All

Gets the style object that specifies properties for surface outer, show and hide boundaries/borders.

C#
public SurfaceBoundaryStyle BoundaryStyle;
Visual Basic
Public Property BoundaryStyle() As SurfaceBoundaryStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::ContourStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::ContourStyle Property
SurfaceStyle::ContourStyle Property
Collapse All

Gets the style object that specifies properties for surface minor, major, depression, and user-defined contour lines.

C#
public SurfaceContourStyle ContourStyle;
Visual Basic
Public Property ContourStyle() As SurfaceContourStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::DirectionStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::DirectionStyle Property
SurfaceStyle::DirectionStyle Property
Collapse All

Gets the style object that specifies properties for surface direction analysis components.

C#
public SurfaceDirectionStyle DirectionStyle;
Visual Basic
Public Property DirectionStyle() As SurfaceDirectionStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::ElevationStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::ElevationStyle Property
SurfaceStyle::ElevationStyle Property
Collapse All

Gets the style object that specifies properties for surface elevation analysis components.

C#
public SurfaceElevationStyle ElevationStyle;
Visual Basic
Public Property ElevationStyle() As SurfaceElevationStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::GridStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::GridStyle Property
SurfaceStyle::GridStyle Property
Collapse All

Gets the style object that specifies properties for surface primary, secondary, and datum grid information.

C#
public SurfaceGridStyle GridStyle;
Visual Basic
Public Property GridStyle() As SurfaceGridStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::PointStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::PointStyle Property
SurfaceStyle::PointStyle Property
Collapse All

Gets the style object that specifies properties for surface point objects.

C#
public SurfacePointStyle PointStyle;
Visual Basic
Public Property PointStyle() As SurfacePointStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::SlopeArrowStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::SlopeArrowStyle Property
SurfaceStyle::SlopeArrowStyle Property
Collapse All

Gets the style object that specifies properties for the surface slope arrow analysis components.

C#
public SurfaceSlopeArrowStyle SlopeArrowStyle;
Visual Basic
Public Property SlopeArrowStyle() As SurfaceSlopeArrowStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::SlopeStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::SlopeStyle Property
SurfaceStyle::SlopeStyle Property
Collapse All

Gets the style object that specifies properties for surface slope analysis components.

C#
public SurfaceSlopeStyle SlopeStyle;
Visual Basic
Public Property SlopeStyle() As SurfaceSlopeStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::TriangleStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::TriangleStyle Property
SurfaceStyle::TriangleStyle Property
Collapse All

Gets the style object that specifies properties for the surface TIN face components.

C#
public SurfaceTriangleStyle TriangleStyle;
Visual Basic
Public Property TriangleStyle() As SurfaceTriangleStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


SurfaceStyle::WatershedStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties > SurfaceStyle::WatershedStyle Property
SurfaceStyle::WatershedStyle Property
Collapse All

Gets the style object that specifies properties for the various kinds of surface watershed analysis components.

C#
public SurfaceWatershedStyle WatershedStyle;
Visual Basic
Public Property WatershedStyle() As SurfaceWatershedStyle
Links
SurfaceStyle Class, SurfaceStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class
VerticalGeometryBandStyle Class
Collapse All

The vertical geometry band style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::VerticalGeometryBandStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleVertGeometryBands"))]
public class VerticalGeometryBandStyle : Autodesk::Civil::DatabaseServices::Styles::BandStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphStyleVertGeometryBands"))>
Public Class VerticalGeometryBandStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::BandStyle
Links
VerticalGeometryBandStyle Methods, VerticalGeometryBandStyle Properties, VerticalGeometryBandStyle Members, Class Hierarchy


VerticalGeometryBandStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Members
VerticalGeometryBandStyle Members
Collapse All

The following tables list the members exposed by VerticalGeometryBandStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the VerticalGeometry component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
CrestCurveLabelStyleId | Gets the band vertical geometry label style id at the crest curve.
CrestCurveTickStyle | Gets the band vertical geometry tick style at the crest curve.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
DownhillTangentLabelStyleId | Gets the band vertical geometry label style id at the down hill tangent.
DownhillTangentTickStyle | Gets the band vertical geometry tick styleat the down hill tangent.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SagCurveLabelStyleId | Gets the band vertical geometry label style id at the sag curve.
SagCurveTickStyle | Gets the band vertical geometry tick style at the sag curve.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
UphillTangentLabelStyleId | Gets the band vertical geometry label style id at the up hill tangent.
UphillTangentTickStyle | Gets the band vertical geometry tick style at the up hill tangent.
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Methods, Public Properties


VerticalGeometryBandStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Methods
VerticalGeometryBandStyle Methods
Collapse All

The methods of VerticalGeometryBandStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the VerticalGeometry component.
Links
Public Methods


VerticalGeometryBandStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Methods > VerticalGeometryBandStyle::GetDisplayStylePlan Method
VerticalGeometryBandStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the VerticalGeometry component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    VerticalGeometryDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As VerticalGeometryDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties
VerticalGeometryBandStyle Properties
Collapse All

The properties of VerticalGeometryBandStyle are listed here.

Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CrestCurveLabelStyleId | Gets the band vertical geometry label style id at the crest curve.
CrestCurveTickStyle | Gets the band vertical geometry tick style at the crest curve.
DownhillTangentLabelStyleId | Gets the band vertical geometry label style id at the down hill tangent.
DownhillTangentTickStyle | Gets the band vertical geometry tick styleat the down hill tangent.
SagCurveLabelStyleId | Gets the band vertical geometry label style id at the sag curve.
SagCurveTickStyle | Gets the band vertical geometry tick style at the sag curve.
TitleTextLabelStyleId | Gets the band profile data title text label style.
UphillTangentLabelStyleId | Gets the band vertical geometry label style id at the up hill tangent.
UphillTangentTickStyle | Gets the band vertical geometry tick style at the up hill tangent.
Links
Public Properties


VerticalGeometryBandStyle::BandType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::BandType Property
VerticalGeometryBandStyle::BandType Property
Collapse All

Gets the BandStyleType enum value that specifies the type of data band data.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandStyleType BandType;
Visual Basic
Public Property BandType() As Autodesk::Civil::DatabaseServices::Styles::BandStyleType
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle::CrestCurveLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::CrestCurveLabelStyleId Property
VerticalGeometryBandStyle::CrestCurveLabelStyleId Property
Collapse All

Gets the band vertical geometry label style id at the crest curve.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CrestCurveLabelStyleId;
Visual Basic
Public Property CrestCurveLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle::CrestCurveTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::CrestCurveTickStyle Property
VerticalGeometryBandStyle::CrestCurveTickStyle Property
Collapse All

Gets the band vertical geometry tick style at the crest curve.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle CrestCurveTickStyle;
Visual Basic
Public Property CrestCurveTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle::DownhillTangentLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::DownhillTangentLabelStyleId Property
VerticalGeometryBandStyle::DownhillTangentLabelStyleId Property
Collapse All

Gets the band vertical geometry label style id at the down hill tangent.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId DownhillTangentLabelStyleId;
Visual Basic
Public Property DownhillTangentLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle::DownhillTangentTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::DownhillTangentTickStyle Property
VerticalGeometryBandStyle::DownhillTangentTickStyle Property
Collapse All

Gets the band vertical geometry tick styleat the down hill tangent.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle DownhillTangentTickStyle;
Visual Basic
Public Property DownhillTangentTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle::SagCurveLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::SagCurveLabelStyleId Property
VerticalGeometryBandStyle::SagCurveLabelStyleId Property
Collapse All

Gets the band vertical geometry label style id at the sag curve.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SagCurveLabelStyleId;
Visual Basic
Public Property SagCurveLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle::SagCurveTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::SagCurveTickStyle Property
VerticalGeometryBandStyle::SagCurveTickStyle Property
Collapse All

Gets the band vertical geometry tick style at the sag curve.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle SagCurveTickStyle;
Visual Basic
Public Property SagCurveTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle::TitleTextLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::TitleTextLabelStyleId Property
VerticalGeometryBandStyle::TitleTextLabelStyleId Property
Collapse All

Gets the band profile data title text label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TitleTextLabelStyleId;
Visual Basic
Public Property TitleTextLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle::UphillTangentLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::UphillTangentLabelStyleId Property
VerticalGeometryBandStyle::UphillTangentLabelStyleId Property
Collapse All

Gets the band vertical geometry label style id at the up hill tangent.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId UphillTangentLabelStyleId;
Visual Basic
Public Property UphillTangentLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


VerticalGeometryBandStyle::UphillTangentTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties > VerticalGeometryBandStyle::UphillTangentTickStyle Property
VerticalGeometryBandStyle::UphillTangentTickStyle Property
Collapse All

Gets the band vertical geometry tick style at the up hill tangent.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle UphillTangentTickStyle;
Visual Basic
Public Property UphillTangentTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
VerticalGeometryBandStyle Class, VerticalGeometryBandStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ViewFrameStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class
ViewFrameStyle Class
Collapse All

The view frame style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ViewFrameStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbViewFrameStyle"))]
public class ViewFrameStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbViewFrameStyle"))>
Public Class ViewFrameStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
ViewFrameStyle Methods, ViewFrameStyle Properties, ViewFrameStyle Members, Class Hierarchy


ViewFrameStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Members
ViewFrameStyle Members
Collapse All

The following tables list the members exposed by ViewFrameStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetViewFrameBoundaryDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ViewFrameBoundaryDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.
Links
Public Methods, Public Properties


ViewFrameStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Methods
ViewFrameStyle Methods
Collapse All

The methods of ViewFrameStyle are listed here.

Public Methods
Public Method | Description
GetViewFrameBoundaryDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.
Links
Public Methods


ViewFrameStyle::GetViewFrameBoundaryDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Methods > ViewFrameStyle::GetViewFrameBoundaryDisplayStylePlan Method
ViewFrameStyle::GetViewFrameBoundaryDisplayStylePlan Method
Collapse All

Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetViewFrameBoundaryDisplayStylePlan();
Visual Basic
Public Function GetViewFrameBoundaryDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
ViewFrameStyle Class, ViewFrameStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


ViewFrameStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Properties
ViewFrameStyle Properties
Collapse All

The properties of ViewFrameStyle are listed here.

Public Properties
Public Property | Description
ViewFrameBoundaryDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.
Links
Public Properties


ViewFrameStyle::ViewFrameBoundaryDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Properties > ViewFrameStyle::ViewFrameBoundaryDisplayStylePlan Property
ViewFrameStyle::ViewFrameBoundaryDisplayStylePlan Property deprecated
Collapse All

Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle ViewFrameBoundaryDisplayStylePlan;
Visual Basic
Public Property ViewFrameBoundaryDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Land.DatabaseServices.Styles.ViewFrameStyle.GetViewFrameBoundaryDisplayStylePlan instead.

Links
ViewFrameStyle Class, ViewFrameStyle Members, Autodesk::Civil::Land::DatabaseServices::Styles Namespace


Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums
Structs, Records, Enums
Collapse All

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
AlignmentDisplayStyleType | Defines AlignmentStyle display style type.
BuildingSiteDisplayStyleType | An enumeration that defines BuildingSiteStyle display style type.
CenterMarkerSizeType | Defines grading style center marker size type.
ColorSchemeType | Defines color scheme type
ContourSmoothingType | Defines how surface contours are smoothed.
GradingDisplayStyleType | Defines grading display style type.
GroupPlotAlignType | Specifies how the section views are aligned.
GroupPlotAreaType | An enumeration that specify the method of plotting section views (either all or by page).
GroupPlotCellSizeType | Specifies how the size of each cell in the array will be determined.
GroupPlotStartCornerType | Specifies the starting corner for plotting the section views.
HorizontalGeometryDisplayStyleType | Defines HorizontalGeometryBandStyle display style type.
ParcelDisplayStyleType | Defines ParcelStyle display style type.
PointDisplay3dType | Specifies how point elevation is displayed.
PointDisplayStyleType | An enumeration that defines PointStyle display style type.
PointMarkerDisplayType | Specifies the kind of marker to use, any of: point, custom, or symbol.
PointSymbolType | Defines the symbology of the point display.
PrecisionRangeType | Defines range precision for some surface styles.
ProfileDataDisplayStyleType | Defines ProfileDataBandStyle display style type.
ProfileDesignCheckCurveType | Design check curve type.
ProfileDisplayStyleProfileType | Defines ProfileStyle display style type.
ProfileViewDisplayStyleType | Defines profile view components type.
SampleLineDisplayStyleType | Defines SampleLineStyle display style type.
ScaleType | Defines how to scale the point marker.
SchematicLineOption | Defines HorizontalGeometryBandStyle schematic line option.
SectionalDataDisplayStyleType | Defines SectionalDataBandStyle display style type.
SectionDataDisplayStyleType | Defines SectionDataBandStyle display style type.
SectionDisplayStyleSectionType | Defines SectionStyle display style type.
SectionSegmentDisplayStyleType | Defines SectionSegmentBandStyle display style type.
SectionViewDisplayStyleType | Defines section view components type.
SectionViewPlotRuleType | Specifies whether to plot the section views by rows or columns.
SheetDisplayStyleType | Defines SheetStyle display style type.
SlopeArrowType | Defines the head style of ArrowType
SuperelevationDataDisplayStyleType | Defines SuperelevationDataBandStyle display style type.
SurfaceDisplay3dType | Defines how to display surface style, whether it is exaggerated, flattened, or displayed at actual elevation levels.
SurfaceDisplayStyleType | Defines surface display style type.
SurfaceDisplayType | Defines how surface objects are to be displayed/rendered.
SurfaceGroupValuesByType | Defines how values are grouped.
VerticalGeometryDisplayStyleType | Defines VerticalGeometryBandStyle display style type.
Links
Enumerations


Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDisplayStyleType Enumeration
Collapse All

Defines AlignmentStyle display style type.

C#
public enum AlignmentDisplayStyleType {
  Line = AeccDbAlignmentStyle::kDispCompAlignmentTangent,
  Curve = AeccDbAlignmentStyle::kDispCompAlignmentCurve,
  Spiral = AeccDbAlignmentStyle::kDispCompAlignmentSpiral,
  Arrow = AeccDbAlignmentStyle::kDispCompAlignmentArrow,
  LineExtensions = AeccDbAlignmentStyle::kDispCompAlignmentLineExtentions,
  CurveExtensions = AeccDbAlignmentStyle::kDispCompAlignmentCurveExtentions,
  WarningSymbol = AeccDbAlignmentStyle::kDispCompAlignmentDesignSpeedWarningSymbol
}
Visual Basic
Public Enum AlignmentDisplayStyleType
  Line = AeccDbAlignmentStyle::kDispCompAlignmentTangent
  Curve = AeccDbAlignmentStyle::kDispCompAlignmentCurve
  Spiral = AeccDbAlignmentStyle::kDispCompAlignmentSpiral
  Arrow = AeccDbAlignmentStyle::kDispCompAlignmentArrow
  LineExtensions = AeccDbAlignmentStyle::kDispCompAlignmentLineExtentions
  CurveExtensions = AeccDbAlignmentStyle::kDispCompAlignmentCurveExtentions
  WarningSymbol = AeccDbAlignmentStyle::kDispCompAlignmentDesignSpeedWarningSymbol
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteDisplayStyleType Enumeration
Collapse All

An enumeration that defines BuildingSiteStyle display style type.

C#
public enum BuildingSiteDisplayStyleType {
  BuildingFootprint = AeccDbBuildingSite::kFootprint,
  PropertyLines = AeccDbBuildingSite::kPropertyLines,
  Utilities = AeccDbBuildingSite::kUtilities,
  SiteModel = AeccDbBuildingSite::kSite,
  BuildingModel = AeccDbBuildingSite::kShell
}
Visual Basic
Public Enum BuildingSiteDisplayStyleType
  BuildingFootprint = AeccDbBuildingSite::kFootprint
  PropertyLines = AeccDbBuildingSite::kPropertyLines
  Utilities = AeccDbBuildingSite::kUtilities
  SiteModel = AeccDbBuildingSite::kSite
  BuildingModel = AeccDbBuildingSite::kShell
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::CenterMarkerSizeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::CenterMarkerSizeType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::CenterMarkerSizeType Enumeration
Collapse All

Defines grading style center marker size type.

C#
public enum CenterMarkerSizeType {
  PercentageOfScreen = AeccDbGradingStyle::kScreen,
  Plotted = AeccDbGradingStyle::kPlotted,
  Fixed = AeccDbGradingStyle::kFixed
}
Visual Basic
Public Enum CenterMarkerSizeType
  PercentageOfScreen = AeccDbGradingStyle::kScreen
  Plotted = AeccDbGradingStyle::kPlotted
  Fixed = AeccDbGradingStyle::kFixed
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::ColorSchemeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::ColorSchemeType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::ColorSchemeType Enumeration
Collapse All

Defines color scheme type

C#
public enum ColorSchemeType {
  Blues = AeccAnalysisRampContent::kBlues,
  Greens = AeccAnalysisRampContent::kGreens,
  Hydro = AeccAnalysisRampContent::kHydro,
  Land = AeccAnalysisRampContent::kLand,
  Pastels = AeccAnalysisRampContent::kPastels,
  Rainbow = AeccAnalysisRampContent::kRainbow,
  Reds = AeccAnalysisRampContent::kReds
}
Visual Basic
Public Enum ColorSchemeType
  Blues = AeccAnalysisRampContent::kBlues
  Greens = AeccAnalysisRampContent::kGreens
  Hydro = AeccAnalysisRampContent::kHydro
  Land = AeccAnalysisRampContent::kLand
  Pastels = AeccAnalysisRampContent::kPastels
  Rainbow = AeccAnalysisRampContent::kRainbow
  Reds = AeccAnalysisRampContent::kReds
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::ContourSmoothingType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::ContourSmoothingType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::ContourSmoothingType Enumeration
Collapse All

Defines how surface contours are smoothed.

C#
public enum ContourSmoothingType {
  AddVertices = 0,
  SplineCurve = 1
}
Visual Basic
Public Enum ContourSmoothingType
  AddVertices = 0
  SplineCurve = 1
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::GradingDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::GradingDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::GradingDisplayStyleType Enumeration
Collapse All

Defines grading display style type.

C#
public enum GradingDisplayStyleType {
  CentroidMarker = AeccDbGradingStyle::kDispCompGradingCentroidMarker,
  TargetLine = AeccDbGradingStyle::kDispCompGradingTargetLine,
  Projection = AeccDbGradingStyle::kDispCompGradingProjection,
  InternalEdges = AeccDbGradingStyle::kDispCompGradingInternalEdges,
  SolidShading = AeccDbGradingStyle::kDispCompGradingSolidShading,
  SlopePat = AeccDbGradingStyle::kDispCompGradingSlopePat
}
Visual Basic
Public Enum GradingDisplayStyleType
  CentroidMarker = AeccDbGradingStyle::kDispCompGradingCentroidMarker
  TargetLine = AeccDbGradingStyle::kDispCompGradingTargetLine
  Projection = AeccDbGradingStyle::kDispCompGradingProjection
  InternalEdges = AeccDbGradingStyle::kDispCompGradingInternalEdges
  SolidShading = AeccDbGradingStyle::kDispCompGradingSolidShading
  SlopePat = AeccDbGradingStyle::kDispCompGradingSlopePat
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAlignType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAlignType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAlignType Enumeration
Collapse All

Specifies how the section views are aligned.

C#
public enum GroupPlotAlignType {
  Left = AeccDbSampleLineGroupStyle::kAlignSectionViewsAboutLeft,
  Centerline = AeccDbSampleLineGroupStyle::kAlignSectionViewsAboutCenterLine,
  Right = AeccDbSampleLineGroupStyle::kAlignSectionViewsAboutRight
}
Visual Basic
Public Enum GroupPlotAlignType
  Left = AeccDbSampleLineGroupStyle::kAlignSectionViewsAboutLeft
  Centerline = AeccDbSampleLineGroupStyle::kAlignSectionViewsAboutCenterLine
  Right = AeccDbSampleLineGroupStyle::kAlignSectionViewsAboutRight
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAreaType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAreaType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAreaType Enumeration
Collapse All

An enumeration that specify the method of plotting section views (either all or by page).

C#
public enum GroupPlotAreaType {
  All = AeccDbSampleLineGroupStyle::kSectionViewPlotAll,
  Page = AeccDbSampleLineGroupStyle::kSectionViewPlotByPage
}
Visual Basic
Public Enum GroupPlotAreaType
  All = AeccDbSampleLineGroupStyle::kSectionViewPlotAll
  Page = AeccDbSampleLineGroupStyle::kSectionViewPlotByPage
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotCellSizeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotCellSizeType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotCellSizeType Enumeration
Collapse All

Specifies how the size of each cell in the array will be determined.

C#
public enum GroupPlotCellSizeType {
  UniformForAll = AeccDbSampleLineGroupStyle::kCellSizeUniformByAll,
  UniformPerRowOrColumn = AeccDbSampleLineGroupStyle::kCellSizeUniformByColumnOrRow
}
Visual Basic
Public Enum GroupPlotCellSizeType
  UniformForAll = AeccDbSampleLineGroupStyle::kCellSizeUniformByAll
  UniformPerRowOrColumn = AeccDbSampleLineGroupStyle::kCellSizeUniformByColumnOrRow
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStartCornerType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStartCornerType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStartCornerType Enumeration
Collapse All

Specifies the starting corner for plotting the section views.

C#
public enum GroupPlotStartCornerType {
  LowerLeft = AeccDbSampleLineGroupStyle::kSectionViewStartCornerLowerLeft,
  UpperLeft = AeccDbSampleLineGroupStyle::kSectionViewStartCornerUpperLeft,
  LowerRight = AeccDbSampleLineGroupStyle::kSectionViewStartCornerLowerRight,
  UpperRight = AeccDbSampleLineGroupStyle::kSectionViewStartCornerUpperRight
}
Visual Basic
Public Enum GroupPlotStartCornerType
  LowerLeft = AeccDbSampleLineGroupStyle::kSectionViewStartCornerLowerLeft
  UpperLeft = AeccDbSampleLineGroupStyle::kSectionViewStartCornerUpperLeft
  LowerRight = AeccDbSampleLineGroupStyle::kSectionViewStartCornerLowerRight
  UpperRight = AeccDbSampleLineGroupStyle::kSectionViewStartCornerUpperRight
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::HorizontalGeometryDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::HorizontalGeometryDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::HorizontalGeometryDisplayStyleType Enumeration
Collapse All

Defines HorizontalGeometryBandStyle display style type.

C#
public enum HorizontalGeometryDisplayStyleType {
  Border = AeccDbGraphStyleHorGeometryBands::kDispCompBandBorder,
  TitleBox = AeccDbGraphStyleHorGeometryBands::kDispCompBandTitleBox,
  TitleBoxText = AeccDbGraphStyleHorGeometryBands::kDispCompBandTitleBoxText,
  Ticks = AeccDbGraphStyleHorGeometryBands::kDispCompBandTicks,
  TangentLabels = AeccDbGraphStyleHorGeometryBands::kDispCompBandTangentLabels,
  CurveLabels = AeccDbGraphStyleHorGeometryBands::kDispCompBandCurveLabels,
  SpiralLabels = AeccDbGraphStyleHorGeometryBands::kDispCompBandSpiralLabels,
  TangentGeometry = AeccDbGraphStyleHorGeometryBands::kDispCompBandTangentGeometry,
  CurveGeometry = AeccDbGraphStyleHorGeometryBands::kDispCompBandCurveGeometry,
  SpiralGeometry = AeccDbGraphStyleHorGeometryBands::kDispCompBandSpiralGeometry,
  TangentCurvature = AeccDbGraphStyleHorGeometryBands::kDispCompBandTangentCurvature,
  CurveCurvature = AeccDbGraphStyleHorGeometryBands::kDispCompBandCurveCurvature,
  SpiralCurvature = AeccDbGraphStyleHorGeometryBands::kDispCompBandSpiralCurvature
}
Visual Basic
Public Enum HorizontalGeometryDisplayStyleType
  Border = AeccDbGraphStyleHorGeometryBands::kDispCompBandBorder
  TitleBox = AeccDbGraphStyleHorGeometryBands::kDispCompBandTitleBox
  TitleBoxText = AeccDbGraphStyleHorGeometryBands::kDispCompBandTitleBoxText
  Ticks = AeccDbGraphStyleHorGeometryBands::kDispCompBandTicks
  TangentLabels = AeccDbGraphStyleHorGeometryBands::kDispCompBandTangentLabels
  CurveLabels = AeccDbGraphStyleHorGeometryBands::kDispCompBandCurveLabels
  SpiralLabels = AeccDbGraphStyleHorGeometryBands::kDispCompBandSpiralLabels
  TangentGeometry = AeccDbGraphStyleHorGeometryBands::kDispCompBandTangentGeometry
  CurveGeometry = AeccDbGraphStyleHorGeometryBands::kDispCompBandCurveGeometry
  SpiralGeometry = AeccDbGraphStyleHorGeometryBands::kDispCompBandSpiralGeometry
  TangentCurvature = AeccDbGraphStyleHorGeometryBands::kDispCompBandTangentCurvature
  CurveCurvature = AeccDbGraphStyleHorGeometryBands::kDispCompBandCurveCurvature
  SpiralCurvature = AeccDbGraphStyleHorGeometryBands::kDispCompBandSpiralCurvature
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::ParcelDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::ParcelDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::ParcelDisplayStyleType Enumeration
Collapse All

Defines ParcelStyle display style type.

C#
public enum ParcelDisplayStyleType {
  Segments = AeccDbParcelStyle::kDispCompLineSegments,
  AreaFill = AeccDbParcelStyle::kDispCompAreaFill
}
Visual Basic
Public Enum ParcelDisplayStyleType
  Segments = AeccDbParcelStyle::kDispCompLineSegments
  AreaFill = AeccDbParcelStyle::kDispCompAreaFill
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::PointDisplay3dType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::PointDisplay3dType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::PointDisplay3dType Enumeration
Collapse All

Specifies how point elevation is displayed.

C#
public enum PointDisplay3dType {
  UsePointElevation = AeccDbPointStyle::kUsePointElevation,
  FlattenPointElevations = AeccDbPointStyle::kFlattenElevations,
  ExaggeratePointElevations = AeccDbPointStyle::kExaggerateElevations
}
Visual Basic
Public Enum PointDisplay3dType
  UsePointElevation = AeccDbPointStyle::kUsePointElevation
  FlattenPointElevations = AeccDbPointStyle::kFlattenElevations
  ExaggeratePointElevations = AeccDbPointStyle::kExaggerateElevations
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::PointDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::PointDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::PointDisplayStyleType Enumeration
Collapse All

An enumeration that defines PointStyle display style type.

C#
public enum PointDisplayStyleType {
  Marker = AeccDbPointStyle::kDispCompPointMarker,
  Label = AeccDbPointStyle::kDispCompPointLabel
}
Visual Basic
Public Enum PointDisplayStyleType
  Marker = AeccDbPointStyle::kDispCompPointMarker
  Label = AeccDbPointStyle::kDispCompPointLabel
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::PointMarkerDisplayType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::PointMarkerDisplayType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::PointMarkerDisplayType Enumeration
Collapse All

Specifies the kind of marker to use, any of: point, custom, or symbol.

C#
public enum PointMarkerDisplayType {
  UsePointForMarker = AeccDbMarkerStyle::ACAD_POINT,
  UseCustomMarker = AeccDbMarkerStyle::CUSTOM_MARKER,
  UseSymbolForMarker = AeccDbMarkerStyle::BLOCK_REFERENCE
}
Visual Basic
Public Enum PointMarkerDisplayType
  UsePointForMarker = AeccDbMarkerStyle::ACAD_POINT
  UseCustomMarker = AeccDbMarkerStyle::CUSTOM_MARKER
  UseSymbolForMarker = AeccDbMarkerStyle::BLOCK_REFERENCE
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::PointSymbolType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::PointSymbolType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::PointSymbolType Enumeration
Collapse All

Defines the symbology of the point display.

C#
public enum PointSymbolType {
  K0 = 0,
  K64 = 64,
  K1 = 1,
  K65 = 65,
  K2 = 2,
  K66 = 66,
  K3 = 3,
  K67 = 67,
  K4 = 4,
  K68 = 68,
  K32 = 32,
  K96 = 96,
  K33 = 33,
  K97 = 97,
  K34 = 34,
  K98 = 98,
  K35 = 35,
  K99 = 99,
  K36 = 36,
  K100 = 100
}
Visual Basic
Public Enum PointSymbolType
  K0 = 0
  K64 = 64
  K1 = 1
  K65 = 65
  K2 = 2
  K66 = 66
  K3 = 3
  K67 = 67
  K4 = 4
  K68 = 68
  K32 = 32
  K96 = 96
  K33 = 33
  K97 = 97
  K34 = 34
  K98 = 98
  K35 = 35
  K99 = 99
  K36 = 36
  K100 = 100
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::PrecisionRangeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::PrecisionRangeType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::PrecisionRangeType Enumeration
Collapse All

Defines range precision for some surface styles.

C#
public enum PrecisionRangeType {
  Precision000001 = 0,
  Precision00001,
  Precision0001,
  Precision001,
  Precision01,
  Precision1,
  Precision10,
  Precision100,
  Precision1000,
  Precision10000,
  Precision100000,
  Precision1000000
}
Visual Basic
Public Enum PrecisionRangeType
  Precision000001 = 0
  Precision00001
  Precision0001
  Precision001
  Precision01
  Precision1
  Precision10
  Precision100
  Precision1000
  Precision10000
  Precision100000
  Precision1000000
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDataDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDataDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDataDisplayStyleType Enumeration
Collapse All

Defines ProfileDataBandStyle display style type.

C#
public enum ProfileDataDisplayStyleType {
  Border = AeccDbGraphStyleProfileDataBands::kDispCompBandBorder,
  TitleBox = AeccDbGraphStyleProfileDataBands::kDispCompBandTitleBox,
  TitleBoxText = AeccDbGraphStyleProfileDataBands::kDispCompBandTitleBoxText,
  MajorTicks = AeccDbGraphStyleProfileDataBands::kDispCompBandMajorTicks,
  MinorTicks = AeccDbGraphStyleProfileDataBands::kDispCompBandMinorTicks,
  TicksAtVGP = AeccDbGraphStyleProfileDataBands::kDispCompBandTicksAtVGP,
  TicksAtHGP = AeccDbGraphStyleProfileDataBands::kDispCompBandTicksAtHGP,
  TicksAtStationEquations = AeccDbGraphStyleProfileDataBands::kDispCompBandTicksAtStationEqns,
  MajorStationLabel = AeccDbGraphStyleProfileDataBands::kDispCompBandMajorStationLabel,
  MinorStationLabel = AeccDbGraphStyleProfileDataBands::kDispCompBandMinorStationLabel,
  LabelsAtVGP = AeccDbGraphStyleProfileDataBands::kDispCompBandLabelsAtVGP,
  LabelsAtHGP = AeccDbGraphStyleProfileDataBands::kDispCompBandLabelsAtHGP,
  LabelsAtStationEquations = AeccDbGraphStyleProfileDataBands::kDispCompBandLabelsAtStationEqns,
  LabelsAtIncrementalDistance = AeccDbGraphStyleProfileDataBands::kDispCompBandLabelsAtIncrementalDistance
}
Visual Basic
Public Enum ProfileDataDisplayStyleType
  Border = AeccDbGraphStyleProfileDataBands::kDispCompBandBorder
  TitleBox = AeccDbGraphStyleProfileDataBands::kDispCompBandTitleBox
  TitleBoxText = AeccDbGraphStyleProfileDataBands::kDispCompBandTitleBoxText
  MajorTicks = AeccDbGraphStyleProfileDataBands::kDispCompBandMajorTicks
  MinorTicks = AeccDbGraphStyleProfileDataBands::kDispCompBandMinorTicks
  TicksAtVGP = AeccDbGraphStyleProfileDataBands::kDispCompBandTicksAtVGP
  TicksAtHGP = AeccDbGraphStyleProfileDataBands::kDispCompBandTicksAtHGP
  TicksAtStationEquations = AeccDbGraphStyleProfileDataBands::kDispCompBandTicksAtStationEqns
  MajorStationLabel = AeccDbGraphStyleProfileDataBands::kDispCompBandMajorStationLabel
  MinorStationLabel = AeccDbGraphStyleProfileDataBands::kDispCompBandMinorStationLabel
  LabelsAtVGP = AeccDbGraphStyleProfileDataBands::kDispCompBandLabelsAtVGP
  LabelsAtHGP = AeccDbGraphStyleProfileDataBands::kDispCompBandLabelsAtHGP
  LabelsAtStationEquations = AeccDbGraphStyleProfileDataBands::kDispCompBandLabelsAtStationEqns
  LabelsAtIncrementalDistance = AeccDbGraphStyleProfileDataBands::kDispCompBandLabelsAtIncrementalDistance
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckCurveType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckCurveType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckCurveType Enumeration
Collapse All

Design check curve type.

C#
public enum ProfileDesignCheckCurveType {
  CrestCurvesOnly = AeccDbVAlignmentDesignCheckSet::kCrestCurvesOnly,
  SagCurvesOnly = AeccDbVAlignmentDesignCheckSet::kSagCurvesOnly,
  CrestSagCurves = AeccDbVAlignmentDesignCheckSet::kCrestSagCurves
}
Visual Basic
Public Enum ProfileDesignCheckCurveType
  CrestCurvesOnly = AeccDbVAlignmentDesignCheckSet::kCrestCurvesOnly
  SagCurvesOnly = AeccDbVAlignmentDesignCheckSet::kSagCurvesOnly
  CrestSagCurves = AeccDbVAlignmentDesignCheckSet::kCrestSagCurves
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDisplayStyleProfileType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDisplayStyleProfileType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDisplayStyleProfileType Enumeration
Collapse All

Defines ProfileStyle display style type.

C#
public enum ProfileDisplayStyleProfileType {
  Line = AeccDbVAlignmentStyle::kDispCompVAlignmentTangent,
  Curve = AeccDbVAlignmentStyle::kDispCompVAlignmentCircularCurve,
  Arrow = AeccDbVAlignmentStyle::kDispCompVAlignmentArrow,
  LineExtension = AeccDbVAlignmentStyle::kDispCompVAlignmentLineExtentions,
  SymmetricalParabola = AeccDbVAlignmentStyle::kDispCompVAlignmentSymParabola,
  AsymmetricalParabola = AeccDbVAlignmentStyle::kDispCompVAlignmentASymParabola,
  ParabolicCurveExtension = AeccDbVAlignmentStyle::kDispCompVAlignmentParabolicCurveExt,
  WarningSymbol = AeccDbVAlignmentStyle::kDispCompVAlignmentWarningSymbol
}
Visual Basic
Public Enum ProfileDisplayStyleProfileType
  Line = AeccDbVAlignmentStyle::kDispCompVAlignmentTangent
  Curve = AeccDbVAlignmentStyle::kDispCompVAlignmentCircularCurve
  Arrow = AeccDbVAlignmentStyle::kDispCompVAlignmentArrow
  LineExtension = AeccDbVAlignmentStyle::kDispCompVAlignmentLineExtentions
  SymmetricalParabola = AeccDbVAlignmentStyle::kDispCompVAlignmentSymParabola
  AsymmetricalParabola = AeccDbVAlignmentStyle::kDispCompVAlignmentASymParabola
  ParabolicCurveExtension = AeccDbVAlignmentStyle::kDispCompVAlignmentParabolicCurveExt
  WarningSymbol = AeccDbVAlignmentStyle::kDispCompVAlignmentWarningSymbol
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewDisplayStyleType Enumeration
Collapse All

Defines profile view components type.

C#
public enum ProfileViewDisplayStyleType {
  GraphTitle = AeccDbGraphStyle::kDispCompGraphTitle,
  LeftAxis = AeccDbGraphStyle::kDispCompGraphLeftAxis,
  LeftAxisTitle = AeccDbGraphStyle::kDispCompGraphLeftAxisTitle,
  LeftAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMajor,
  LeftAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMinor,
  LeftAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMajor,
  LeftAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMinor,
  RightAxis = AeccDbGraphStyle::kDispCompGraphRightAxis,
  RightAxisTitle = AeccDbGraphStyle::kDispCompGraphRightAxisTitle,
  RightAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMajor,
  RightAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMinor,
  RightAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMajor,
  RightAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMinor,
  TopAxis = AeccDbGraphStyle::kDispCompGraphTopAxis,
  TopAxisTitle = AeccDbGraphStyle::kDispCompGraphTopAxisTitle,
  TopAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMajor,
  TopAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMinor,
  TopAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMajor,
  TopAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMinor,
  BottomAxis = AeccDbGraphStyle::kDispCompGraphBottomAxis,
  BottomAxisTitle = AeccDbGraphStyle::kDispCompGraphBottomAxisTitle,
  BottomAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMajor,
  BottomAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMinor,
  BottomAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMajor,
  BottomAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMinor,
  GridHorizontalMajor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMajor,
  GridHorizontalMinor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMinor,
  GridVerticalMajor = AeccDbGraphStyle::kDispCompGraphGridVerticalMajor,
  GridVerticalMinor = AeccDbGraphStyle::kDispCompGraphGridVerticalMinor,
  GridAtHGP = AeccDbGraphStyle::kDispCompGraphGridAtHGP,
  TopAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationHGP,
  TopAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphTopAxisTicksHGP,
  BottomAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationHGP,
  BottomAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksHGP,
  GridAtSampleLineStations = AeccDbGraphStyle::kDispCompGraphGridAtSLStations,
  ProfileHatch = AeccDbGraphStyle::kDispCompGraphProfileHatch
}
Visual Basic
Public Enum ProfileViewDisplayStyleType
  GraphTitle = AeccDbGraphStyle::kDispCompGraphTitle
  LeftAxis = AeccDbGraphStyle::kDispCompGraphLeftAxis
  LeftAxisTitle = AeccDbGraphStyle::kDispCompGraphLeftAxisTitle
  LeftAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMajor
  LeftAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMinor
  LeftAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMajor
  LeftAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMinor
  RightAxis = AeccDbGraphStyle::kDispCompGraphRightAxis
  RightAxisTitle = AeccDbGraphStyle::kDispCompGraphRightAxisTitle
  RightAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMajor
  RightAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMinor
  RightAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMajor
  RightAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMinor
  TopAxis = AeccDbGraphStyle::kDispCompGraphTopAxis
  TopAxisTitle = AeccDbGraphStyle::kDispCompGraphTopAxisTitle
  TopAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMajor
  TopAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMinor
  TopAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMajor
  TopAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMinor
  BottomAxis = AeccDbGraphStyle::kDispCompGraphBottomAxis
  BottomAxisTitle = AeccDbGraphStyle::kDispCompGraphBottomAxisTitle
  BottomAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMajor
  BottomAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMinor
  BottomAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMajor
  BottomAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMinor
  GridHorizontalMajor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMajor
  GridHorizontalMinor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMinor
  GridVerticalMajor = AeccDbGraphStyle::kDispCompGraphGridVerticalMajor
  GridVerticalMinor = AeccDbGraphStyle::kDispCompGraphGridVerticalMinor
  GridAtHGP = AeccDbGraphStyle::kDispCompGraphGridAtHGP
  TopAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationHGP
  TopAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphTopAxisTicksHGP
  BottomAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationHGP
  BottomAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksHGP
  GridAtSampleLineStations = AeccDbGraphStyle::kDispCompGraphGridAtSLStations
  ProfileHatch = AeccDbGraphStyle::kDispCompGraphProfileHatch
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineDisplayStyleType Enumeration
Collapse All

Defines SampleLineStyle display style type.

C#
public enum SampleLineDisplayStyleType {
  Lines = AeccDbSampleLineStyle::kDispCompSampleLineLines,
  Vertices = AeccDbSampleLineStyle::kDispCompSampleLineVertices
}
Visual Basic
Public Enum SampleLineDisplayStyleType
  Lines = AeccDbSampleLineStyle::kDispCompSampleLineLines
  Vertices = AeccDbSampleLineStyle::kDispCompSampleLineVertices
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::ScaleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::ScaleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::ScaleType Enumeration
Collapse All

Defines how to scale the point marker.

C#
public enum ScaleType {
  UseDrawingScale = 0,
  SizeRelativeToScreen,
  SizeInAbsoluteUnits
}
Visual Basic
Public Enum ScaleType
  UseDrawingScale = 0
  SizeRelativeToScreen
  SizeInAbsoluteUnits
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SchematicLineOption Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SchematicLineOption Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SchematicLineOption Enumeration
Collapse All

Defines HorizontalGeometryBandStyle schematic line option.

C#
public enum SchematicLineOption {
  Geometry = AeccDbGraphStyleHorGeometryBands::kBandSchematicLineOptionGeometry,
  Radius = AeccDbGraphStyleHorGeometryBands::kBandSchematicLineOptionRadius,
  Curvature = AeccDbGraphStyleHorGeometryBands::kBandSchematicLineOptionCurvature
}
Visual Basic
Public Enum SchematicLineOption
  Geometry = AeccDbGraphStyleHorGeometryBands::kBandSchematicLineOptionGeometry
  Radius = AeccDbGraphStyleHorGeometryBands::kBandSchematicLineOptionRadius
  Curvature = AeccDbGraphStyleHorGeometryBands::kBandSchematicLineOptionCurvature
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SectionalDataDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SectionalDataDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SectionalDataDisplayStyleType Enumeration
Collapse All

Defines SectionalDataBandStyle display style type.

C#
public enum SectionalDataDisplayStyleType {
  Border = AeccDbGraphStyleSectionalDataBands::kDispCompBandBorder,
  TitleBox = AeccDbGraphStyleSectionalDataBands::kDispCompBandTitleBox,
  TitleBoxText = AeccDbGraphStyleSectionalDataBands::kDispCompBandTitleBoxText,
  TicksAtSampleLineStation = AeccDbGraphStyleSectionalDataBands::kDispCompBandTicksAtSampleLineStation,
  SampleLineStationLabels = AeccDbGraphStyleSectionalDataBands::kDispCompBandSampleLineStationLabels,
  IncrementalStationRegionLabels = AeccDbGraphStyleSectionalDataBands::kDispCompBandIncrementalStationRegionLabels
}
Visual Basic
Public Enum SectionalDataDisplayStyleType
  Border = AeccDbGraphStyleSectionalDataBands::kDispCompBandBorder
  TitleBox = AeccDbGraphStyleSectionalDataBands::kDispCompBandTitleBox
  TitleBoxText = AeccDbGraphStyleSectionalDataBands::kDispCompBandTitleBoxText
  TicksAtSampleLineStation = AeccDbGraphStyleSectionalDataBands::kDispCompBandTicksAtSampleLineStation
  SampleLineStationLabels = AeccDbGraphStyleSectionalDataBands::kDispCompBandSampleLineStationLabels
  IncrementalStationRegionLabels = AeccDbGraphStyleSectionalDataBands::kDispCompBandIncrementalStationRegionLabels
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SectionDataDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SectionDataDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SectionDataDisplayStyleType Enumeration
Collapse All

Defines SectionDataBandStyle display style type.

C#
public enum SectionDataDisplayStyleType {
  Border = AeccDbGraphStyleSectionDataBands::kDispCompBandBorder,
  TitleBox = AeccDbGraphStyleSectionDataBands::kDispCompBandTitleBox,
  TitleBoxText = AeccDbGraphStyleSectionDataBands::kDispCompBandTitleBoxText,
  TicksAtMajorOffsets = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtMajorOffsets,
  TicksAtMinorOffsets = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtMinorOffsets,
  TicksAtCenterline = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtCenterLine,
  TicksAtSampleLineVertices = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtSampleLineVertices,
  TicksAtGradeBreaks = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtGradeBreaks,
  LabelsAtMajorOffsets = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtMajorOffsets,
  LabelsAtMinorOffsets = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtMinorOffsets,
  LabelsAtCenterline = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtCenterLine,
  LabelsAtSampleLineVertices = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtSampleLineVertices,
  LabelsAtGradeBreaks = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtGradeBreaks,
  LabelsAtIncrementalDistance = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtIncrementalDistance
}
Visual Basic
Public Enum SectionDataDisplayStyleType
  Border = AeccDbGraphStyleSectionDataBands::kDispCompBandBorder
  TitleBox = AeccDbGraphStyleSectionDataBands::kDispCompBandTitleBox
  TitleBoxText = AeccDbGraphStyleSectionDataBands::kDispCompBandTitleBoxText
  TicksAtMajorOffsets = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtMajorOffsets
  TicksAtMinorOffsets = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtMinorOffsets
  TicksAtCenterline = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtCenterLine
  TicksAtSampleLineVertices = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtSampleLineVertices
  TicksAtGradeBreaks = AeccDbGraphStyleSectionDataBands::kDispCompBandTicksAtGradeBreaks
  LabelsAtMajorOffsets = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtMajorOffsets
  LabelsAtMinorOffsets = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtMinorOffsets
  LabelsAtCenterline = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtCenterLine
  LabelsAtSampleLineVertices = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtSampleLineVertices
  LabelsAtGradeBreaks = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtGradeBreaks
  LabelsAtIncrementalDistance = AeccDbGraphStyleSectionDataBands::kDispCompBandLabelsAtIncrementalDistance
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SectionDisplayStyleSectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SectionDisplayStyleSectionType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SectionDisplayStyleSectionType Enumeration
Collapse All

Defines SectionStyle display style type.

C#
public enum SectionDisplayStyleSectionType {
  Segments = AeccDbSectionStyle::kDispCompCrossSectionSegments,
  Points = AeccDbSectionStyle::kDispCompCrossSectionPoints
}
Visual Basic
Public Enum SectionDisplayStyleSectionType
  Segments = AeccDbSectionStyle::kDispCompCrossSectionSegments
  Points = AeccDbSectionStyle::kDispCompCrossSectionPoints
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SectionSegmentDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SectionSegmentDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SectionSegmentDisplayStyleType Enumeration
Collapse All

Defines SectionSegmentBandStyle display style type.

C#
public enum SectionSegmentDisplayStyleType {
  Border = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandBorder,
  TitleBox = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandTitleBox,
  TitleBoxText = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandTitleBoxText,
  Ticks = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandTicks,
  Labels = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandLabels,
  Lines = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandLines
}
Visual Basic
Public Enum SectionSegmentDisplayStyleType
  Border = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandBorder
  TitleBox = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandTitleBox
  TitleBoxText = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandTitleBoxText
  Ticks = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandTicks
  Labels = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandLabels
  Lines = AeccDbGraphStyleSectionRoadSurfaceBands::kDispCompBandLines
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewDisplayStyleType Enumeration
Collapse All

Defines section view components type.

C#
public enum SectionViewDisplayStyleType {
  GraphTitle = AeccDbGraphStyle::kDispCompGraphTitle,
  LeftAxis = AeccDbGraphStyle::kDispCompGraphLeftAxis,
  LeftAxisTitle = AeccDbGraphStyle::kDispCompGraphLeftAxisTitle,
  LeftAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMajor,
  LeftAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMinor,
  LeftAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMajor,
  LeftAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMinor,
  RightAxis = AeccDbGraphStyle::kDispCompGraphRightAxis,
  RightAxisTitle = AeccDbGraphStyle::kDispCompGraphRightAxisTitle,
  RightAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMajor,
  RightAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMinor,
  RightAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMajor,
  RightAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMinor,
  TopAxis = AeccDbGraphStyle::kDispCompGraphTopAxis,
  TopAxisTitle = AeccDbGraphStyle::kDispCompGraphTopAxisTitle,
  TopAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMajor,
  TopAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMinor,
  TopAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMajor,
  TopAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMinor,
  BottomAxis = AeccDbGraphStyle::kDispCompGraphBottomAxis,
  BottomAxisTitle = AeccDbGraphStyle::kDispCompGraphBottomAxisTitle,
  BottomAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMajor,
  BottomAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMinor,
  BottomAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMajor,
  BottomAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMinor,
  CenterAxis = AeccDbGraphStyle::kDispCompGraphCenterAxis,
  CenterAxisTitle = AeccDbGraphStyle::kDispCompGraphCenterAxisTitle,
  CenterAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphCenterAxisAnnotationMajor,
  CenterAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphCenterAxisAnnotationMinor,
  CenterAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphCenterAxisTicksMajor,
  CenterAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphCenterAxisTicksMinor,
  GridHorizontalMajor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMajor,
  GridHorizontalMinor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMinor,
  GridVerticalMajor = AeccDbGraphStyle::kDispCompGraphGridVerticalMajor,
  GridVerticalMinor = AeccDbGraphStyle::kDispCompGraphGridVerticalMinor,
  GridAtSampleLineStations = AeccDbGraphStyle::kDispCompGraphGridSampleLineVertices,
  GridAtPGP = AeccDbGraphStyle::kDispCompGraphVertGridAtBaseLine
}
Visual Basic
Public Enum SectionViewDisplayStyleType
  GraphTitle = AeccDbGraphStyle::kDispCompGraphTitle
  LeftAxis = AeccDbGraphStyle::kDispCompGraphLeftAxis
  LeftAxisTitle = AeccDbGraphStyle::kDispCompGraphLeftAxisTitle
  LeftAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMajor
  LeftAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMinor
  LeftAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMajor
  LeftAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMinor
  RightAxis = AeccDbGraphStyle::kDispCompGraphRightAxis
  RightAxisTitle = AeccDbGraphStyle::kDispCompGraphRightAxisTitle
  RightAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMajor
  RightAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMinor
  RightAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMajor
  RightAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMinor
  TopAxis = AeccDbGraphStyle::kDispCompGraphTopAxis
  TopAxisTitle = AeccDbGraphStyle::kDispCompGraphTopAxisTitle
  TopAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMajor
  TopAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMinor
  TopAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMajor
  TopAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMinor
  BottomAxis = AeccDbGraphStyle::kDispCompGraphBottomAxis
  BottomAxisTitle = AeccDbGraphStyle::kDispCompGraphBottomAxisTitle
  BottomAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMajor
  BottomAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMinor
  BottomAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMajor
  BottomAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMinor
  CenterAxis = AeccDbGraphStyle::kDispCompGraphCenterAxis
  CenterAxisTitle = AeccDbGraphStyle::kDispCompGraphCenterAxisTitle
  CenterAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphCenterAxisAnnotationMajor
  CenterAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphCenterAxisAnnotationMinor
  CenterAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphCenterAxisTicksMajor
  CenterAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphCenterAxisTicksMinor
  GridHorizontalMajor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMajor
  GridHorizontalMinor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMinor
  GridVerticalMajor = AeccDbGraphStyle::kDispCompGraphGridVerticalMajor
  GridVerticalMinor = AeccDbGraphStyle::kDispCompGraphGridVerticalMinor
  GridAtSampleLineStations = AeccDbGraphStyle::kDispCompGraphGridSampleLineVertices
  GridAtPGP = AeccDbGraphStyle::kDispCompGraphVertGridAtBaseLine
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewPlotRuleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewPlotRuleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewPlotRuleType Enumeration
Collapse All

Specifies whether to plot the section views by rows or columns.

C#
public enum SectionViewPlotRuleType {
  ByRows = AeccDbSampleLineGroupStyle::kPlotSectionViewsByRows,
  ByColumns = AeccDbSampleLineGroupStyle::kPlotSectionViewsByColumns
}
Visual Basic
Public Enum SectionViewPlotRuleType
  ByRows = AeccDbSampleLineGroupStyle::kPlotSectionViewsByRows
  ByColumns = AeccDbSampleLineGroupStyle::kPlotSectionViewsByColumns
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SheetDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SheetDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SheetDisplayStyleType Enumeration
Collapse All

Defines SheetStyle display style type.

C#
public enum SheetDisplayStyleType {
  MajorHorizontalGrid = AeccDbSheetStyle::kDispCompSheetMajorHorGrid,
  MinorHorizontalGrid = AeccDbSheetStyle::kDispCompSheetMinorHorGrid,
  MajorVerticalGrid = AeccDbSheetStyle::kDispCompSheetMajorVertGrid,
  MinorVerticalGrid = AeccDbSheetStyle::kDispCompSheetMinorVertGrid,
  PrintArea = AeccDbSheetStyle::kDispCompSheetPrintArea,
  Border = AeccDbSheetStyle::kDispCompSheetBorder
}
Visual Basic
Public Enum SheetDisplayStyleType
  MajorHorizontalGrid = AeccDbSheetStyle::kDispCompSheetMajorHorGrid
  MinorHorizontalGrid = AeccDbSheetStyle::kDispCompSheetMinorHorGrid
  MajorVerticalGrid = AeccDbSheetStyle::kDispCompSheetMajorVertGrid
  MinorVerticalGrid = AeccDbSheetStyle::kDispCompSheetMinorVertGrid
  PrintArea = AeccDbSheetStyle::kDispCompSheetPrintArea
  Border = AeccDbSheetStyle::kDispCompSheetBorder
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SlopeArrowType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SlopeArrowType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SlopeArrowType Enumeration
Collapse All

Defines the head style of ArrowType

C#
public enum SlopeArrowType {
  Filled = AeccDbSurfaceStyle::kFilled,
  Closed = AeccDbSurfaceStyle::kClosed,
  Open = AeccDbSurfaceStyle::kOpen,
  Double = AeccDbSurfaceStyle::kDouble
}
Visual Basic
Public Enum SlopeArrowType
  Filled = AeccDbSurfaceStyle::kFilled
  Closed = AeccDbSurfaceStyle::kClosed
  Open = AeccDbSurfaceStyle::kOpen
  Double = AeccDbSurfaceStyle::kDouble
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SuperelevationDataDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SuperelevationDataDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SuperelevationDataDisplayStyleType Enumeration
Collapse All

Defines SuperelevationDataBandStyle display style type.

C#
public enum SuperelevationDataDisplayStyleType {
  Border = AeccDbGraphStyleSuperElevationBands::kDispCompBandBorder,
  TitleBox = AeccDbGraphStyleSuperElevationBands::kDispCompBandTitleBox,
  TitleBoxText = AeccDbGraphStyleSuperElevationBands::kDispCompBandTitleBoxText,
  TicksAtNormalCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtNormalCrown,
  TicksAtShoulderBreakOver = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtShoulderBreakOver,
  TicksAtLevelCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtLevelCrown,
  TicksAtReverseCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtReverseCrown,
  TicksAtFullSuper = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtFullSuper,
  LabelsAtNormalCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtNormalCrown,
  LabelsAtShoulderBreakOver = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtShoulderBreakOver,
  LabelsAtLevelCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtLevelCrown,
  LabelsAtReverseCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtReverseCrown,
  LabelsAtFullSuper = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtFullSuper,
  LabelsAlongTransitionSegment = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAlongTransitionSegment,
  ReferenceLine = AeccDbGraphStyleSuperElevationBands::kDispCompBandReferenceLine,
  LineLeftOutsideShoulder = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineLeftOutsideShoulder,
  LineLeftOutsidePavement = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineLeftOutsidePavement,
  LineLeftInsidePavement = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineLeftInsidePavement,
  LineLeftInsideShoulder = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineLeftInsideShoulder,
  LineRightInsideShoulder = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineRightInsideShoulder,
  LineRightInsidePavement = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineRightInsidePavement,
  LineRightOutsidePavement = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineRightOutsidePavement,
  LineRightOutsideShoulder = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineRightOutsideShoulder
}
Visual Basic
Public Enum SuperelevationDataDisplayStyleType
  Border = AeccDbGraphStyleSuperElevationBands::kDispCompBandBorder
  TitleBox = AeccDbGraphStyleSuperElevationBands::kDispCompBandTitleBox
  TitleBoxText = AeccDbGraphStyleSuperElevationBands::kDispCompBandTitleBoxText
  TicksAtNormalCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtNormalCrown
  TicksAtShoulderBreakOver = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtShoulderBreakOver
  TicksAtLevelCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtLevelCrown
  TicksAtReverseCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtReverseCrown
  TicksAtFullSuper = AeccDbGraphStyleSuperElevationBands::kDispCompBandTicksAtFullSuper
  LabelsAtNormalCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtNormalCrown
  LabelsAtShoulderBreakOver = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtShoulderBreakOver
  LabelsAtLevelCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtLevelCrown
  LabelsAtReverseCrown = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtReverseCrown
  LabelsAtFullSuper = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAtFullSuper
  LabelsAlongTransitionSegment = AeccDbGraphStyleSuperElevationBands::kDispCompBandLabelsAlongTransitionSegment
  ReferenceLine = AeccDbGraphStyleSuperElevationBands::kDispCompBandReferenceLine
  LineLeftOutsideShoulder = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineLeftOutsideShoulder
  LineLeftOutsidePavement = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineLeftOutsidePavement
  LineLeftInsidePavement = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineLeftInsidePavement
  LineLeftInsideShoulder = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineLeftInsideShoulder
  LineRightInsideShoulder = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineRightInsideShoulder
  LineRightInsidePavement = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineRightInsidePavement
  LineRightOutsidePavement = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineRightOutsidePavement
  LineRightOutsideShoulder = AeccDbGraphStyleSuperElevationBands::kDispCompBandLineRightOutsideShoulder
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplay3dType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplay3dType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplay3dType Enumeration
Collapse All

Defines how to display surface style, whether it is exaggerated, flattened, or displayed at actual elevation levels.

C#
public enum SurfaceDisplay3dType {
  UseSurfaceElevation = 0x00000001,
  FlattenElevations = 0x00000002,
  ExaggerateElevations = 0x00000004
}
Visual Basic
Public Enum SurfaceDisplay3dType
  UseSurfaceElevation = &H00000001
  FlattenElevations = &H00000002
  ExaggerateElevations = &H00000004
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplayStyleType Enumeration
Collapse All

Defines surface display style type.

C#
public enum SurfaceDisplayStyleType {
  Points = AeccDbSurfaceStyle::kDispCompPoints,
  Triangles = AeccDbSurfaceStyle::kDispCompTriangles,
  Boundary = AeccDbSurfaceStyle::kDispCompBorder,
  MajorContour = AeccDbSurfaceStyle::kDispCompMajorContours,
  MinorContour = AeccDbSurfaceStyle::kDispCompMinorContours,
  UserContours = AeccDbSurfaceStyle::kDispCompUserContours,
  Gridded = AeccDbSurfaceStyle::kDispCompGriddedMesh,
  Directions = AeccDbSurfaceStyle::kDispCompCodedDirections,
  Elevations = AeccDbSurfaceStyle::kDispCompCodedElevations,
  Slopes = AeccDbSurfaceStyle::kDispCompCodedSlopes,
  SlopeArrows = AeccDbSurfaceStyle::kDispCompSlopeVector,
  Watersheds = AeccDbSurfaceStyle::kDispCompWatersheds
}
Visual Basic
Public Enum SurfaceDisplayStyleType
  Points = AeccDbSurfaceStyle::kDispCompPoints
  Triangles = AeccDbSurfaceStyle::kDispCompTriangles
  Boundary = AeccDbSurfaceStyle::kDispCompBorder
  MajorContour = AeccDbSurfaceStyle::kDispCompMajorContours
  MinorContour = AeccDbSurfaceStyle::kDispCompMinorContours
  UserContours = AeccDbSurfaceStyle::kDispCompUserContours
  Gridded = AeccDbSurfaceStyle::kDispCompGriddedMesh
  Directions = AeccDbSurfaceStyle::kDispCompCodedDirections
  Elevations = AeccDbSurfaceStyle::kDispCompCodedElevations
  Slopes = AeccDbSurfaceStyle::kDispCompCodedSlopes
  SlopeArrows = AeccDbSurfaceStyle::kDispCompSlopeVector
  Watersheds = AeccDbSurfaceStyle::kDispCompWatersheds
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplayType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplayType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplayType Enumeration
Collapse All

Defines how surface objects are to be displayed/rendered.

C#
public enum SurfaceDisplayType {
  Solid2d = 0x00000001,
  Faces3d = 0x00000002,
  HatchSolid = 0x00000004,
  PolyMesh = 0x00000008
}
Visual Basic
Public Enum SurfaceDisplayType
  Solid2d = &H00000001
  Faces3d = &H00000002
  HatchSolid = &H00000004
  PolyMesh = &H00000008
End Enum


Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceGroupValuesByType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceGroupValuesByType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceGroupValuesByType Enumeration
Collapse All

Defines how values are grouped.

C#
public enum SurfaceGroupValuesByType {
  EqualInterval = AeccDbSurfaceStyle::kAnalysisEqualInterval,
  Quantile = AeccDbSurfaceStyle::kAnalysisQuantile,
  StandardDeviation = AeccDbSurfaceStyle::kAnalysisStandardDeviation
}
Visual Basic
Public Enum SurfaceGroupValuesByType
  EqualInterval = AeccDbSurfaceStyle::kAnalysisEqualInterval
  Quantile = AeccDbSurfaceStyle::kAnalysisQuantile
  StandardDeviation = AeccDbSurfaceStyle::kAnalysisStandardDeviation
End Enum
Remarks

The default is EqualInterval, which divides the data into a specified number of ranges from the minimum value to the maximum.


Autodesk::Civil::Land::DatabaseServices::Styles::VerticalGeometryDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::Styles::VerticalGeometryDisplayStyleType Enumeration
Autodesk::Civil::Land::DatabaseServices::Styles::VerticalGeometryDisplayStyleType Enumeration
Collapse All

Defines VerticalGeometryBandStyle display style type.

C#
public enum VerticalGeometryDisplayStyleType {
  Border = AeccDbGraphStyleVertGeometryBands::kDispCompBandBorder,
  TitleBox = AeccDbGraphStyleVertGeometryBands::kDispCompBandTitleBox,
  TitleBoxText = AeccDbGraphStyleVertGeometryBands::kDispCompBandTitleBoxText,
  Ticks = AeccDbGraphStyleVertGeometryBands::kDispCompBandTicks,
  TangentLabels = AeccDbGraphStyleVertGeometryBands::kDispCompBandTangentLabels,
  CurveLabels = AeccDbGraphStyleVertGeometryBands::kDispCompBandCurveLabels,
  TangentGeometry = AeccDbGraphStyleVertGeometryBands::kDispCompBandTangentGeometry,
  CurveGeometry = AeccDbGraphStyleVertGeometryBands::kDispCompBandCurveGeometry
}
Visual Basic
Public Enum VerticalGeometryDisplayStyleType
  Border = AeccDbGraphStyleVertGeometryBands::kDispCompBandBorder
  TitleBox = AeccDbGraphStyleVertGeometryBands::kDispCompBandTitleBox
  TitleBoxText = AeccDbGraphStyleVertGeometryBands::kDispCompBandTitleBoxText
  Ticks = AeccDbGraphStyleVertGeometryBands::kDispCompBandTicks
  TangentLabels = AeccDbGraphStyleVertGeometryBands::kDispCompBandTangentLabels
  CurveLabels = AeccDbGraphStyleVertGeometryBands::kDispCompBandCurveLabels
  TangentGeometry = AeccDbGraphStyleVertGeometryBands::kDispCompBandTangentGeometry
  CurveGeometry = AeccDbGraphStyleVertGeometryBands::kDispCompBandCurveGeometry
End Enum


Classes

The following table lists classes in this documentation.

Classes
Class | Description
Alignment | The Alignment class. Alignment objects can represent centerlines, lanes, shoulders, right-of-ways, or construction baselines.
AlignmentArc | The AlignmentArc class. AlignmentArc derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single AlignmentSubEntityArc... more
AlignmentCurve | The AlignmentCurve class. This is an abstract base class for other Alignment Entity classes, such as AlignmentArc, AlignmentSCS,... more
AlignmentCurveLabel | This class represents an alignment curve label.
AlignmentDesignSpeedLabelGroup | This class represents an alignment design speed label group.
AlignmentEntity | The AlignmentEntity class. This is an abstract class from which AlignmentCurve inherits.
AlignmentEntityCollection | The AlignmentEntity collection class. This class represents the collection of all AlignmentEntity objects that belong to an Alignment.
AlignmentGeometryPointLabelGroup | This class encapsulates the functionality to label a geometry point group in an alignment.
AlignmentLabelGroup | This class represents an alignment label group.
AlignmentLine | The AlignmentLine class. This class represents an AlignmentEntity made up of a single line subentity.
AlignmentMinorStationLabelGroup | This class represents an alignment minor station label group.
AlignmentPILabel | This class represents an alignment tangent intersection label.
AlignmentPILabelGroup |
AlignmentRegion | Represents a segment of an alignment which uses a single assembly.
AlignmentRegionCollection | A collection of AlignmentRegion objects.
AlignmentSCS | The Alignment SpiralCurveSpiral class. This class represents an AlignmentEntity made up of an in spiral subentity, an arc subentity, and... more
AlignmentSCSCS | The Alignment SpiralCurveSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an... more
AlignmentSCSSCS | The Alignment SpiralCurveSpiralSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an... more
AlignmentSpiral | The AlignmentSpiral Class. AlignmentSpiral derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single spiral... more
AlignmentSpiralLabel | This class represents an alignment spiral label.
AlignmentSSCSS | The Alignment SpiralSpiralCurveSpiralSpiral class. This class represents an AlignmentEntity made up of the following subentities: spiral, spiral, arc, spiral, spiral.... more
AlignmentStationEquationLabelGroup | This class represents an alignment station equation label group.
AlignmentStationLabelGroup | This class represents an alignment station label group.
AlignmentSTS | The Alignment SpiralTangentSpiral class. This class represents an AlignmentEntity made up of a spiral, then tangent, then spiral subentities.
AlignmentSubEntity | The alignment subentity class. This class represents the basic drawing components that make up an alignment entity.
AlignmentSubEntityArc | The Alignment arc subentity class.
AlignmentSubEntityLine | The AlignmentSubEntityLine class. This class represents the line object in AlignmentEntity objects.
AlignmentSubEntitySpiral | The Alignment spiral subentity class. This class represents spiral object in AlignmentEntity objects.
AlignmentSuperelevationLabelGroup | This class encapsulates the functionality of an alignment super-elevation group label.
AlignmentTable | The AlignmentTable class.
AlignmentTangentLabel | This class represents an alignment tangent label.
AlignmentVerticalGeometryPointLabelGroup | This class represents an alignment vertical geometry point label group.
DesignSpeed | The Alignment DesignSpeed class. Specifies a single design speed used for criteria-based Alignment design.
DesignSpeedCollection | A collection of DesignSpeed objects.
FeatureLine | A feature line is a connected series of points along a corridor created by joining those points from each assembly... more
Grading | The Grading class.
GridSurface | A surface formed from points that lie on a regular grid.
MassHaulLine | A line that displays free haul and overhaul volumes in a mass haul view..
MassHaulView | A mass haul diagram view.
MatchLine | A match line is a straight line that indicate locations in a view frame group where one view frame intersects... more
MaterialSection | The AeccDbMaterialSection wrapper.
Parcel | An object that represents real estate parcels, such as lots in a subdivision, and other features that have closed boundaries... more
ParcelSegment | A parcel segment is a line segment, arc, or AutoCAD entity within a site. When parcel segments form a closed... more
ParcelSegmentTable | A Table associated with a ParcelSegment.
ParcelTable | A table associated with a Parcel.
PointEntity | Encapsulates a COGO point object, with associated information such as elevation, marker display styles, etc.
PointTable | The AeccDbPointScheduleTable wrapper.
PolylineOptions | The PolylineOptions class. This class specifies the options for creating an Alignment using a polyline.
Profile | A record of elevation against distance along a horizontal Alignment or other line. Profiles are used to visualize the terrain... more
ProfileBandLabelGroup | The AeccDbProfileBandLabeling wrapper.
ProfileCircular | The ProfileCircular class. This class represents an ProfileEntity made up of a circular curve.
ProfileCriteria | Critera used by the criteria-based design feature to apply agency-specific standards to a profile.
ProfileCriteriaCollection | The ProfileCriteria collection class represents the collection of all criteria in the hatch area.
ProfileEntity | The abstract class of profile entity. ProfileEntity has four derived classes: ProfileLine, ProfileAsymmetric, ProfileCircular, and ProfileParabolic.
ProfileEntityCollection | The ProfileEntity collection class. This class represents the collection of all ProfileEntity objects that belong to the Profile.
ProfileHatchArea | The ProfilevHatchArea class.
ProfileHatchAreaCollection | The ProfileHatchAreaCollection class represents the collection of all hatch areas in the ProfileView.
ProfileOverride | Object used to change the style or label set for a profile.
ProfileOverrideCollection | The ProfileOverride collection class represents the collection of all profiles listed in the ProfileView.
ProfileParabolaAsymmetric | The ProfileParabolaAsymmetric class. This class represents an ProfileEntity made up of a asymmetric parabola.
ProfileParabolaSymmetric | This class represents an ProfileEntity made up of a symmetric parabola.
ProfileProjection | The AeccDbProfileProjection class.
ProfilePVI | In a profile, the point where the lines formed by two tangent entities meet, whether the entities meet or not... more
ProfilePVICollection | The ProfilePVI collection class represents the collection of all ProfilePVI objects that belong to an Profile.
ProfileTangent | This class represents an ProfileEntity made up of a single tangent.
ProfileView | Manages the graphic display of profile data objects within a drawing. A ProfileView is used to display one or more... more
ProfileViewSplitData | This class represents a split location.
ProfileViewSplitDataCollection | The class provides a collection for the profile view split data.
SampleLine | Lines used for obtaining elevational information from an existing terrain model or surface for creating profiles and cross sections.
SampleLineGroup | Controls a set of related sample lines, the surfaces they sample, and methods for creating cross sections.
SCSCSConstraints | The SCSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Curve-Spiral (AlignmentSCSCS) compound Alignment entities.
SCSSCSConstraints | The SCSSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Spiral-Curve-Spiral (AlignmentSCSSCS) compound Alignment entities.
Section | Provides views created at a 90 degree angle to a surface or an alignment.
SectionBandLabelGroup | A group of section band labels.
SectionProjection | AutoCAD or AutoCAD Civil 3D objects projected from plan view into a section view.
SectionView | Used to display cross sectional data for both existing and finished ground along a sampled cross section line at any... more
Sheet | A sheet (construction document) object.
Site | The construction site abstraction containing parcels and alignments. Note: Alignments are generally associated with a site. An alignment interacts with... more
Station | The Alignment Station class.
StationEquation | Represents a particular system of renumbering or reordering stations within a portion of an alignment.
StationEquationCollection | A collection of StationEquation objects.
StationOffsetLabel | This class represents a station offset label.
SuperElevationData | The SuperelevationData class. This class is a collection of SuperelevationDataElement objects for an Alignment.
SuperElevationDataElement | Superelevation data element at a particular station.
Surface | The base class for TIN and grid surfaces. A surface is a three-dimensional geometric representation of the surface (TIN or... more
TinSurface | A Triangular Irregular Network (TIN) surface, from points connected together in triangles, and used to interpolate for contours, and to... more
ViewFrame | View frames are rectangular-shaped regions along an alignment that define an area that will be displayed in a sheet.
ViewFrameGroup | Manages a single group of view frames that are displaying consecutive station ranges along the same alignment.
Links
Classes


Alignment Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class
Alignment Class
Collapse All

The Alignment class. Alignment objects can represent centerlines, lanes, shoulders, right-of-ways, or construction baselines.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::Alignment
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignment"))]
public class Alignment : Autodesk::Civil::DatabaseServices::Feature;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignment"))>
Public Class Alignment
Inherits Autodesk::Civil::DatabaseServices::Feature
Remarks

Creating and defining the horizontal alignment is one of the first steps in roadway, railroad, or site design. Note: Sites are usually associated with a site, though you can create a "siteless" alignment and then associate it with a site later. This may be useful if you want to create and manipulate an alignment that doesn't interact with objects in an associated site. An alignment on a site interacts with objects in the site in two ways:

  1. If an alignment exists on a site with parcels, the alignment will subdivide any parcels it crosses over.
  2. If one or more alignments on a site form a closed region, a parcel will be created from the region.
Links
Alignment Methods, Alignment Properties, Alignment Members, Class Hierarchy


Alignment Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Members
Alignment Members
Collapse All

The following tables list the members exposed by Alignment.

Public Methods
Public Method | Description
CopyToSite | Overloaded
Create | Overloaded
CreateOffsetAlignment | Creates an offset Alignment from the current alignment, returns the offset Alignment ObjectId. A positive value to create an offset... more
DistanceToAlignment | Overloaded
GetInstantaneousRadius | Returns the instantaneous radius at the specified station.
GetLabelGroupIds | Gets the ObjectIdCollection of the Alignment's label group.
GetLabelIds | Gets the ObjectIdCollection of the Alignment's labels.
GetNextUniqueName | Gets a string indicating a unique name for the Alignment. The input string could be a name template.
GetPolyline | Gets a polyline from the Alignment geometry.
GetProfileIds | Gets the ObjectIdCollection of all profiles belonging to this Alignment.
GetProfileViewIds | Gets the ObjectIdCollection of all profile views belonging to this Alignment.
GetRegions | Gets the regions, which are included in offset alignment or curb return.
GetSampleLineGroupIds | Gets the ObjectIdCollection of all sample line groups belonging to this Alignment.
GetStationSet | Overloaded
GetStationStringWithEquations | Gets a string indicating the station of an Alignment using the Station equations.
GetSuperelevationZoneAtStation | Gets the superelevation zone at the specified Station.
ImportLabelSet | Overloaded
IsEditableFeature | Check whether the Feature-derived entity (Alignment,Profile,etc) is editable.
PointLocation | Overloaded
Reverse | Reverse the Alignment direction.
StationOffset | Overloaded
SuperElevationAtStation | Gets the superelevation data element at a specified station. A read-only copy is returned.
Public Properties
Public Property | Description
AlignmentType | Gets the alignment type.
Application | Gets the Application. Not currently implemented.
CreationMode | Gets the Alignment creation mode.
DesignCheckSetId | Gets the object id of design check set that is used in the alignment.
DesignCheckSetName | Gets the name of of design check set that is used in the alignment.
DesignSpeeds | Gets the Alignment design speed collection.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
EndingStation | Gets the Alignment's end station.
Entities | Gets the Alignment entities collection for the Alignment.
IsEditable | Gets the value indicates whether the Feature derived entity (Alignment,Profile,etc) is editable.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
IsSiteless | Gets a bool value that indicates whether this Alignment is a siteless Alignment.
Length | Gets the Alignment's length.
Name | Gets or sets the Entity object's name.
ReferencePoint | Gets or sets the Alignment reference point.
ReferencePointStation | Gets or sets the Alignment reference point station.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
SiteId | Gets the Id for the Site to which this Alignment belongs. ObjectId.Null for a siteless alignment.
SiteName | Gets the name of the Site to which this Alignment belongs. a string of "" for a siteless alignment.
StartingStation | Gets the Alignment's start station.
StationEquations | Gets the Alignment's station equation collection.
StationIndexIncrement | Gets or sets the Alignment station index increment.
StyleId | Sets the Alignment's style Id.
StyleName | Sets the Alignment's style name.
SuperElevationData | Gets the superelevation data collection on the Alignment. A read-only copy is returned.
UpdateMode | Gets the update mode of the alignment.
UseDesignCheckSet | Gets or sets whether the Alignment uses the design check set.
UseDesignCriteriaFile | Gets or sets whether the alignment uses the design criteria file.
UseDesignSpeed | Gets or sets a bool value that indicates whether this Alignment uses degign speed.
Links
Public Methods, Public Properties


Alignment Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods
Alignment Methods
Collapse All

The methods of Alignment are listed here.

Public Methods
Public Method | Description
CopyToSite | Overloaded
Create | Overloaded
CreateOffsetAlignment | Creates an offset Alignment from the current alignment, returns the offset Alignment ObjectId. A positive value to create an offset... more
DistanceToAlignment | Overloaded
GetInstantaneousRadius | Returns the instantaneous radius at the specified station.
GetLabelGroupIds | Gets the ObjectIdCollection of the Alignment's label group.
GetLabelIds | Gets the ObjectIdCollection of the Alignment's labels.
GetNextUniqueName | Gets a string indicating a unique name for the Alignment. The input string could be a name template.
GetPolyline | Gets a polyline from the Alignment geometry.
GetProfileIds | Gets the ObjectIdCollection of all profiles belonging to this Alignment.
GetProfileViewIds | Gets the ObjectIdCollection of all profile views belonging to this Alignment.
GetRegions | Gets the regions, which are included in offset alignment or curb return.
GetSampleLineGroupIds | Gets the ObjectIdCollection of all sample line groups belonging to this Alignment.
GetStationSet | Overloaded
GetStationStringWithEquations | Gets a string indicating the station of an Alignment using the Station equations.
GetSuperelevationZoneAtStation | Gets the superelevation zone at the specified Station.
ImportLabelSet | Overloaded
PointLocation | Overloaded
Reverse | Reverse the Alignment direction.
StationOffset | Overloaded
SuperElevationAtStation | Gets the superelevation data element at a specified station. A read-only copy is returned.
Links
Public Methods


CopyToSite Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > CopyToSite Method
CopyToSite Method
Collapse All

Overloaded

Overload List
Method | Description
Alignment::CopyToSite (Autodesk::AutoCAD::DatabaseServices::ObjectId) | Copies the Alignment to a specified Site. Specifying ObjectId.Null to copy it to siteless. Calling this method copies all children... more
Alignment::CopyToSite (System::String^) | Copies the Alignment to a specified Site. Specifying "" to move it to siteless. Calling this method copies all children... more


Alignment::CopyToSite Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > CopyToSite Method > Alignment::CopyToSite Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Alignment::CopyToSite Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Copies the Alignment to a specified Site. Specifying ObjectId.Null to copy it to siteless. Calling this method copies all children profiles, profile views and sample line group with this alignment as well.

C#
public CopyToSite(
    Autodesk::AutoCAD::DatabaseServices::ObjectId siteId
);
Visual Basic
Public Sub CopyToSite(
    siteId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
siteId | The destination site ObjectId.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the Site ObjectId is invalid.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::CopyToSite Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > CopyToSite Method > Alignment::CopyToSite Method (System::String^)
Alignment::CopyToSite Method (System::String^)
Collapse All

Copies the Alignment to a specified Site. Specifying "" to move it to siteless. Calling this method copies all children profiles, profile views and sample line group with this alignment as well.

C#
public CopyToSite(
    ref System::String siteName
);
Visual Basic
Public Sub CopyToSite(
    ByRef siteName As System::String
)
Parameters
Parameters | Description
siteName | The destination site name.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the Site name is invalid.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Create Method
Create Method
Collapse All

Overloaded

Overload List
Method | Description
Alignment::Create (Autodesk::Civil::ApplicationServices::CivilDocument^, PolylineOptions, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates an Alignment from the specified Polyline, Polyline2d or Polyline3d.
Alignment::Create (Autodesk::Civil::ApplicationServices::CivilDocument^, PolylineOptions, System::String^, System::String^, System::String^, System::String^, System::String^) | Creates an Alignment from the specified Polyline, Polyline2d or Polyline3d.
Alignment::Create (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates an Alignment without geometry information.
Alignment::Create (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^) | Creates an Alignment without geometry information.


Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, PolylineOptions, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Create Method > Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, PolylineOptions, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, PolylineOptions, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates an Alignment from the specified Polyline, Polyline2d or Polyline3d.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    PolylineOptions plineOptions,
    ref System::String alignmentName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId siteId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId layerId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelSetId
);
Visual Basic
Public Function Create(
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    plineOptions As PolylineOptions,
    ByRef alignmentName As System::String,
    siteId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    layerId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    labelSetId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
document | Document object in which the Alignment is created.
plineOptions | Polyline options for creating the Alignment, including whether to add curves between tangents, and whether to erase the original polyline.
alignmentName | Name of the created Alignment.
siteId | ObjectId of the site on which the Alignment is created. Pass null to create a siteless alignment.
layerId | ObjectId of the layer on which the Alignment is created.
styleId | ObjectId of the style applied to the created Alignment.
labelSetId | ObjectId of the labelSet applied to the created Alignment.
Remarks

This method creates an Alignment using ObjectId parameters. Use an ObjectId.NULL for a siteless Alignment.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the the name of drawing or the objectId of the polyline, layer, style, labelSet or site are invalid.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, PolylineOptions, System::String^, System::String^, System::String^, System::String^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Create Method > Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, PolylineOptions, System::String^, System::String^, System::String^, System::String^, System::String^)
Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, PolylineOptions, System::String^, System::String^, System::String^, System::String^, System::String^)
Collapse All

Creates an Alignment from the specified Polyline, Polyline2d or Polyline3d.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    PolylineOptions plineOptions,
    ref System::String alignmentName,
    ref System::String siteName,
    ref System::String layerName,
    ref System::String styleName,
    ref System::String labelSetName
);
Visual Basic
Public Function Create(
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    plineOptions As PolylineOptions,
    ByRef alignmentName As System::String,
    ByRef siteName As System::String,
    ByRef layerName As System::String,
    ByRef styleName As System::String,
    ByRef labelSetName As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
document | Document object in which the Alignment is created.
plineOptions | Polyline options for creating the Alignment, including whether to add curves between tangents, and whether to erase the original polyline.
alignmentName | Name of the created Alignment.
siteName | Name of the site on which Alignment is created. Pass null to create a siteless alignment.
layerName | Name of the layer on which the Alignment is created.
styleName | Name of the style applied to the created Alignment.
labelSetName | Name of the labelSet applied to the created Alignment.
Remarks

This method creates an Alignment using string parameters. Use an null or empty site name for a siteless Alignment.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the the name of drawing, layer, style, labelSet or site is invalid.
Example
// create some polyline options for creating the new alignment
PolylineOptions plops = new PolylineOptions();
plops.AddCurvesBetweenTangents = true;
plops.EraseExistingEntities = true;
plops.PlineId = res.ObjectId;

// uses an existing Alignment Style and Label Set Style named "Standard" (for example, from
// the Civil 3D (Imperial) NCS.dwt template.  This call will fail if the named styles
// don't exist.
ObjectId testAlignmentID = Alignment.Create(doc, plops, "New Alignment", null, "0", "Standard", "Standard");
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Create Method > Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates an Alignment without geometry information.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    ref System::String alignmentName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId siteId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId layerId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelSetId
);
Visual Basic
Public Function Create(
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    ByRef alignmentName As System::String,
    siteId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    layerId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    labelSetId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
document | Document object in which the Alignment is created.
alignmentName | Name of the created Alignment.
siteId | ObjectId of the site on which the Alignment is created. Pass null to create a siteless alignment.
layerId | ObjectId of the layer on which the Alignment is created.
styleId | ObjectId of the style applied to the created Alignment.
labelSetId | ObjectId of the labelSet applied to the created Alignment.
Remarks

This method creates an Alignment using ObjectId parameters. Use an ObjectId.NULL for a siteless Alignment.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the the name of drawing or the objectId of the polyline, layer, style, labelSet or site are invalid.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Create Method > Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^)
Alignment::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^)
Collapse All

Creates an Alignment without geometry information.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    ref System::String alignmentName,
    ref System::String siteName,
    ref System::String layerName,
    ref System::String styleName,
    ref System::String labelSetName
);
Visual Basic
Public Function Create(
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    ByRef alignmentName As System::String,
    ByRef siteName As System::String,
    ByRef layerName As System::String,
    ByRef styleName As System::String,
    ByRef labelSetName As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
document | Document object in which the Alignment is created.
alignmentName | Name of the created Alignment.
siteName | Name of the site on which Alignment is created. Pass null to create a siteless alignment.
layerName | Name of the layer on which the Alignment is created.
styleName | Name of the style applied to the created Alignment.
labelSetName | Name of the labelSet applied to the created Alignment.
Remarks

This method creates an Alignment using string parameters. Use an empty site name for a siteless Alignment.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the the name of drawing, layer, style, labelSet or site is invalid.
Example
// Uses an existing Alignment Style and Label Set Style named "Standard" (for example, from
// the Civil 3D (Imperial) NCS.dwt template.  This call will fail if the named styles
// don't exist.
// Uses layer 0, and no site (null)
ObjectId testAlignmentID = Alignment.Create( doc, "New Alignment", null, "0", "Standard", "Standard");
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::CreateOffsetAlignment Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::CreateOffsetAlignment Method
Alignment::CreateOffsetAlignment Method
Collapse All

Creates an offset Alignment from the current alignment, returns the offset Alignment ObjectId. A positive value to create an offset alignment to the right side and negative to the left side.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CreateOffsetAlignment(
    double offsetDistance
);
Visual Basic
Public Function CreateOffsetAlignment(
    offsetDistance As double
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
offsetDistance | Specifies the distance to create offset Alignment.
Example
// Creates a new alignment with an offset of 10:
ObjectId offsetAlignmentID = align.CreateOffsetAlignment(0.4);
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


DistanceToAlignment Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > DistanceToAlignment Method
DistanceToAlignment Method
Collapse All

Overloaded

Overload List
Method | Description
Alignment::DistanceToAlignment (double, Alignment^, AlignmentSide, double%, double%) | Computes the distance to another Alignment, specifying the side of current Alignment to look for the target Alignment.... more
Alignment::DistanceToAlignment (double, Alignment^, double%, double%) | Computes the distance to another Alignment. If the target Alignment crosses the current Alignment, this method checks the... more


Alignment::DistanceToAlignment Method (double, Alignment^, AlignmentSide, double%, double%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > DistanceToAlignment Method > Alignment::DistanceToAlignment Method (double, Alignment^, AlignmentSide, double%, double%)
Alignment::DistanceToAlignment Method (double, Alignment^, AlignmentSide, double%, double%)
Collapse All

Computes the distance to another Alignment, specifying the side of current Alignment to look for the target Alignment.

C#
public DistanceToAlignment(
    double stationOnThisAlignment,
    ref Alignment otherAlignment,
    AlignmentSide enumSide,
    double% distanceToOtherAlignment,
    double% stationOnOtherAlignment
);
Visual Basic
Public Sub DistanceToAlignment(
    stationOnThisAlignment As double,
    ByRef otherAlignment As Alignment,
    enumSide As AlignmentSide,
    distanceToOtherAlignment As double%,
    stationOnOtherAlignment As double%
)
Parameters
Parameters | Description
stationOnThisAlignment | Specifies the station name located on the current Alignment.
otherAlignment | Specifies the name of target Alignment.
enumSide | Specifies which side of this Alignment to look for the target Alignment. This is required in the the case where the alignments cross, and the target Alignment can be found on both sides.
distanceToOtherAlignment | Returns the distance from the current Alignment to the other Alignment.
stationOnOtherAlignment | Returns the station located on the other Alignment.
Exceptions
Exceptions | Description
PointNotOnEntityException | Thrown if the target Alignment is not found.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::DistanceToAlignment Method (double, Alignment^, double%, double%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > DistanceToAlignment Method > Alignment::DistanceToAlignment Method (double, Alignment^, double%, double%)
Alignment::DistanceToAlignment Method (double, Alignment^, double%, double%)
Collapse All

Computes the distance to another Alignment. If the target Alignment crosses the current Alignment, this method checks the distance to the target Alignment on both sides, and returns the shorter distance.

C#
public DistanceToAlignment(
    double stationOnThisAlignment,
    ref Alignment otherAlignment,
    double% distanceToOtherAlignment,
    double% stationOnOtherAlignment
);
Visual Basic
Public Sub DistanceToAlignment(
    stationOnThisAlignment As double,
    ByRef otherAlignment As Alignment,
    distanceToOtherAlignment As double%,
    stationOnOtherAlignment As double%
)
Parameters
Parameters | Description
stationOnThisAlignment | Specifies the station name located on the current Alignment.
otherAlignment | Specifies the name of the target Alignment.
distanceToOtherAlignment | Returns the distance from the current Alignment to the other Alignment.
stationOnOtherAlignment | Returns the station located on the other Alignment.
Exceptions
Exceptions | Description
PointNotOnEntityException | Thrown if the target Alignment is not found.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetInstantaneousRadius Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetInstantaneousRadius Method
Alignment::GetInstantaneousRadius Method
Collapse All

Returns the instantaneous radius at the specified station.

C#
public double GetInstantaneousRadius(
    double rawStation
);
Visual Basic
Public Function GetInstantaneousRadius(
    rawStation As double
) As double
Parameters
Parameters | Description
rawStation | Specifies the raw (no equations) station value.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the rawStation is out of Alignment station range.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetLabelGroupIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetLabelGroupIds Method
Alignment::GetLabelGroupIds Method
Collapse All

Gets the ObjectIdCollection of the Alignment's label group.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetLabelGroupIds();
Visual Basic
Public Function GetLabelGroupIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetLabelIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetLabelIds Method
Alignment::GetLabelIds Method
Collapse All

Gets the ObjectIdCollection of the Alignment's labels.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetLabelIds();
Visual Basic
Public Function GetLabelIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetNextUniqueName Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetNextUniqueName Method
Alignment::GetNextUniqueName Method
Collapse All

Gets a string indicating a unique name for the Alignment. The input string could be a name template.

C#
public System::String GetNextUniqueName(
    ref System::String alignmentName
);
Visual Basic
Public Function GetNextUniqueName(
    ByRef alignmentName As System::String
) As System::String
Parameters
Parameters | Description
alignmentName | A proposed Alignment name.
Remarks

You can use this method to get a guaranteed unique name for the Alginment. Every time you call this method, the internal counter increments by one, even if no Alignment is created. For example:

String name1 = Alignment.GetNextUniqueName (…, “A”);   //  name1 = “A”
String name2 = Alignment.GetNextUniqueName (…, “A”);   //  name2 = “A(1)”
String name3 = Alignment.GetNextUniqueName (…, “Alignment - (<[Next Counter(CP)]>)”);   //  name3 = “Alignment - (1)”
String name4 = Alignment.GetNextUniqueName (…, “Alignment - (<[Next Counter(CP)]>)”);   //  name4 = “Alignment - (1)”
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetPolyline Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetPolyline Method
Alignment::GetPolyline Method
Collapse All

Gets a polyline from the Alignment geometry.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId GetPolyline();
Visual Basic
Public Function GetPolyline() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetProfileIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetProfileIds Method
Alignment::GetProfileIds Method
Collapse All

Gets the ObjectIdCollection of all profiles belonging to this Alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetProfileIds();
Visual Basic
Public Function GetProfileIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Example
Profile oProfile = ts.GetObject(oAlignment.GetProfileIds()[0], OpenMode.ForWrite) as Profile;

// check to make sure we have a profile:
if (oProfile == null)
{
   ed.WriteMessage("Must have at least one alignment with one profile");
   return;
}
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetProfileViewIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetProfileViewIds Method
Alignment::GetProfileViewIds Method
Collapse All

Gets the ObjectIdCollection of all profile views belonging to this Alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetProfileViewIds();
Visual Basic
Public Function GetProfileViewIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetRegions Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetRegions Method
Alignment::GetRegions Method
Collapse All

Gets the regions, which are included in offset alignment or curb return.

C#
public AlignmentRegionCollection GetRegions();
Visual Basic
Public Function GetRegions() As AlignmentRegionCollection
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when: (1) The alignment type is not offset or curb return. (2) The offset alignment has no parent alignment.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetSampleLineGroupIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetSampleLineGroupIds Method
Alignment::GetSampleLineGroupIds Method
Collapse All

Gets the ObjectIdCollection of all sample line groups belonging to this Alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetSampleLineGroupIds();
Visual Basic
Public Function GetSampleLineGroupIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


GetStationSet Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > GetStationSet Method
GetStationSet Method
Collapse All

Overloaded

Overload List
Method | Description
Alignment::GetStationSet (StationTypes) | Gets the station set according to the StationType.
Alignment::GetStationSet (StationTypes, double) | Gets the station set according to the StationType and interval.
Alignment::GetStationSet (StationTypes, double, double) | Gets the station set according to the StationType and intervals.


Alignment::GetStationSet Method (StationTypes)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > GetStationSet Method > Alignment::GetStationSet Method (StationTypes)
Alignment::GetStationSet Method (StationTypes)
Collapse All

Gets the station set according to the StationType.

C#
public array<Station^> GetStationSet(
    StationTypes stationType
);
Visual Basic
Public Function GetStationSet(
    stationType As StationTypes
) As array<Station^>
Parameters
Parameters | Description
stationType | The type of the station which will be collected. This method overload is intended to get station types other than All, Major, and Minor.
interval | The interval of station.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetStationSet Method (StationTypes, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > GetStationSet Method > Alignment::GetStationSet Method (StationTypes, double)
Alignment::GetStationSet Method (StationTypes, double)
Collapse All

Gets the station set according to the StationType and interval.

C#
public array<Station^> GetStationSet(
    StationTypes stationType,
    double interval
);
Visual Basic
Public Function GetStationSet(
    stationType As StationTypes,
    interval As double
) As array<Station^>
Parameters
Parameters | Description
stationType | The type of the station which will be collected. This method overload is intended to get Major or Minor station types.
interval | The interval of station. You can only enter a Major and Minor station.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the value of interval is negative.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetStationSet Method (StationTypes, double, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > GetStationSet Method > Alignment::GetStationSet Method (StationTypes, double, double)
Alignment::GetStationSet Method (StationTypes, double, double)
Collapse All

Gets the station set according to the StationType and intervals.

C#
public array<Station^> GetStationSet(
    StationTypes stationType,
    double majorInterval,
    double minorInterval
);
Visual Basic
Public Function GetStationSet(
    stationType As StationTypes,
    majorInterval As double,
    minorInterval As double
) As array<Station^>
Parameters
Parameters | Description
stationType | The type of the station which will be collected. This method overload is intended to get All or HorizontalMask station types.
majorInterval | The major interval of station.
minorInterval | The minor interval of station.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown if the value of majorInterval or minorInterval is negative.
Example
// Get all the potential stations with major interval = 100, and minor interval = 20
// Print out the raw station number, type, and location
Station[] myStations = myAlignment.GetStationSet(StationTypes.All, 100, 20);
ed.WriteMessage("Number of possible stations: {0}n", myStations.Length);

foreach (Station myStation in myStations)
{
   ed.WriteMessage("Station {0} is type {1} and at {2}n", myStation.RawStation, myStation.StationType.ToString(), myStation.Location.ToString());
}
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetStationStringWithEquations Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetStationStringWithEquations Method
Alignment::GetStationStringWithEquations Method
Collapse All

Gets a string indicating the station of an Alignment using the Station equations.

C#
public System::String GetStationStringWithEquations(
    double rawStation
);
Visual Basic
Public Function GetStationStringWithEquations(
    rawStation As double
) As System::String
Parameters
Parameters | Description
rawStation | Specifies the raw (no equations) Station value.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the rawStation is out of Alignment station range.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::GetSuperelevationZoneAtStation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::GetSuperelevationZoneAtStation Method
Alignment::GetSuperelevationZoneAtStation Method
Collapse All

Gets the superelevation zone at the specified Station.

C#
public array<SuperElevationDataElement^> GetSuperelevationZoneAtStation(
    double rawStation
);
Visual Basic
Public Function GetSuperelevationZoneAtStation(
    rawStation As double
) As array<SuperElevationDataElement^>
Parameters
Parameters | Description
rawStation | Specifies the raw station at which to get the superelevation zone.
Returns

Returns an array containing two elements representing the lower and upper bound of the zone.

Remarks

If the input raw station is in the Alignment station range but not in any two superelevation station elements, this method returns the superelvation data element at the input Station and nearest superelevation Station.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the rawStation is out of the Alignment station range.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


ImportLabelSet Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > ImportLabelSet Method
ImportLabelSet Method
Collapse All

Overloaded

Overload List
Method | Description
Alignment::ImportLabelSet (Autodesk::AutoCAD::DatabaseServices::ObjectId) | Takes the contents of the AlignmentLabelSetStyle template and copies its data into the database object.
Alignment::ImportLabelSet (System::String^) | Takes the contents of the AlignmentLabelSetStyle template and copies its data into the Database object.


Alignment::ImportLabelSet Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > ImportLabelSet Method > Alignment::ImportLabelSet Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Alignment::ImportLabelSet Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Takes the contents of the AlignmentLabelSetStyle template and copies its data into the database object.

C#
public ImportLabelSet(
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelSetStyleId
);
Visual Basic
Public Sub ImportLabelSet(
    labelSetStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
labelSetStyleId | Label style set template ObjectId.
Remarks

Note that when the copying is performed, any existing AlignmentLabelSetStyle values are removed.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelSetStyle ObjectId is invalid.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::ImportLabelSet Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > ImportLabelSet Method > Alignment::ImportLabelSet Method (System::String^)
Alignment::ImportLabelSet Method (System::String^)
Collapse All

Takes the contents of the AlignmentLabelSetStyle template and copies its data into the Database object.

C#
public ImportLabelSet(
    ref System::String labelSetStyleName
);
Visual Basic
Public Sub ImportLabelSet(
    ByRef labelSetStyleName As System::String
)
Parameters
Parameters | Description
labelSetStyleName | Label style set template name.
Remarks

Note that when the copying is performed, any existing AlignmentLabelSetStyle values are removed.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelSetStyle name is invalid.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


PointLocation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > PointLocation Method
PointLocation Method
Collapse All

Overloaded

Overload List
Method | Description
Alignment::PointLocation (double, double, double%, double%) | Returns the easting and northing of a point on an Alignment given a station and an offset for the Alignment... more
Alignment::PointLocation (double, double, double, double%, double%, double%) | Given station and offset values, returns the easting, northing, and bearing values at that point on the Alignment.


Alignment::PointLocation Method (double, double, double, double%, double%, double%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > PointLocation Method > Alignment::PointLocation Method (double, double, double, double%, double%, double%)
Alignment::PointLocation Method (double, double, double, double%, double%, double%)
Collapse All

Given station and offset values, returns the easting, northing, and bearing values at that point on the Alignment.

C#
public PointLocation(
    double station,
    double offset,
    double tolerance,
    double% easting,
    double% northing,
    double% Bearing
);
Visual Basic
Public Sub PointLocation(
    station As double,
    offset As double,
    tolerance As double,
    easting As double%,
    northing As double%,
    Bearing As double%
)
Parameters
Parameters | Description
station | Specifies the station name.
offset | Specifies the offset value.
tolerance | Specifies the tolerance value for the range of stations and offset values. For example, if you specify a station 50 m past the end of an alignment, and tolerance is 51, the method will find the point for the last station.
easting | Returns the Easting value.
northing | Returns the Northing value.
Bearing | Returns the Bearing value.
Exceptions
Exceptions | Description
Autodesk::Civil::PointNotOnEntityException | Thrown when the station is out of Alignment station range, or the station and offset are out of range using the tolerance given.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::PointLocation Method (double, double, double%, double%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > PointLocation Method > Alignment::PointLocation Method (double, double, double%, double%)
Alignment::PointLocation Method (double, double, double%, double%)
Collapse All

Returns the easting and northing of a point on an Alignment given a station and an offset for the Alignment.

C#
public PointLocation(
    double station,
    double offset,
    double% easting,
    double% northing
);
Visual Basic
Public Sub PointLocation(
    station As double,
    offset As double,
    easting As double%,
    northing As double%
)
Parameters
Parameters | Description
station | Specifies the station.
offset | Specifies the offset.
easting | Returns the Easting value.
northing | Returns the Northing value.
Exceptions
Exceptions | Description
Autodesk::Civil::PointNotOnEntityException | Thrown when the station is out of Alignment station range.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::Reverse Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::Reverse Method
Alignment::Reverse Method
Collapse All

Reverse the Alignment direction.

C#
public Reverse();
Visual Basic
Public Sub Reverse()
Remarks

Reversing the stationing will remove all station equations and design speeds, and may adversely affect objects and data already created from the Alignment.

Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationOffset Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > StationOffset Method
StationOffset Method
Collapse All

Overloaded

Overload List
Method | Description
Alignment::StationOffset (double, double, double%, double%) | Returns the station and offset on an Alignment at given easting and northing values.
Alignment::StationOffset (double, double, double, double%, double%) | Returns the nearest station and offset on an Alignment at given easting, northing and tolerance values.


Alignment::StationOffset Method (double, double, double, double%, double%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > StationOffset Method > Alignment::StationOffset Method (double, double, double, double%, double%)
Alignment::StationOffset Method (double, double, double, double%, double%)
Collapse All

Returns the nearest station and offset on an Alignment at given easting, northing and tolerance values.

C#
public StationOffset(
    double easting,
    double northing,
    double tolerance,
    double% station,
    double% offset
);
Visual Basic
Public Sub StationOffset(
    easting As double,
    northing As double,
    tolerance As double,
    station As double%,
    offset As double%
)
Parameters
Parameters | Description
easting | Specifies the Easting value.
northing | Specifies the Northing value.
tolerance | Specifies the tolerance value. This value is in the same coordinate units as the Easting and Northing values, and specifies a range within which the method looks for a point on the Alignment.
station | Returns the station value.
offset | Returns the offset value.
Remarks

This method returns an error code if the station and offset are out of range using the tolerance given.

Exceptions
Exceptions | Description
Autodesk::Civil::PointNotOnEntityException | Thrown when the easting and northing value are out of Alignment range.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::StationOffset Method (double, double, double%, double%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > StationOffset Method > Alignment::StationOffset Method (double, double, double%, double%)
Alignment::StationOffset Method (double, double, double%, double%)
Collapse All

Returns the station and offset on an Alignment at given easting and northing values.

C#
public StationOffset(
    double easting,
    double northing,
    double% station,
    double% offset
);
Visual Basic
Public Sub StationOffset(
    easting As double,
    northing As double,
    station As double%,
    offset As double%
)
Parameters
Parameters | Description
easting | Specifies the Easting value.
northing | Specifies the Northing value.
station | Returns the station specified by the northing and easting.
offset | Returns the offset specified by the northing and easting.
Exceptions
Exceptions | Description
Autodesk::Civil::PointNotOnEntityException | Thrown when the easting and northing value are out of Alignment range.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::SuperElevationAtStation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods > Alignment::SuperElevationAtStation Method
Alignment::SuperElevationAtStation Method
Collapse All

Gets the superelevation data element at a specified station. A read-only copy is returned.

C#
public SuperElevationDataElement SuperElevationAtStation(
    double rawStation
);
Visual Basic
Public Function SuperElevationAtStation(
    rawStation As double
) As SuperElevationDataElement
Parameters
Parameters | Description
rawStation | The raw station at which to get the superelevation data.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties
Alignment Properties
Collapse All

The properties of Alignment are listed here.

Public Properties
Public Property | Description
AlignmentType | Gets the alignment type.
CreationMode | Gets the Alignment creation mode.
DesignCheckSetId | Gets the object id of design check set that is used in the alignment.
DesignCheckSetName | Gets the name of of design check set that is used in the alignment.
DesignSpeeds | Gets the Alignment design speed collection.
EndingStation | Gets the Alignment's end station.
Entities | Gets the Alignment entities collection for the Alignment.
IsSiteless | Gets a bool value that indicates whether this Alignment is a siteless Alignment.
Length | Gets the Alignment's length.
ReferencePoint | Gets or sets the Alignment reference point.
ReferencePointStation | Gets or sets the Alignment reference point station.
SiteId | Gets the Id for the Site to which this Alignment belongs. ObjectId.Null for a siteless alignment.
SiteName | Gets the name of the Site to which this Alignment belongs. a string of "" for a siteless alignment.
StartingStation | Gets the Alignment's start station.
StationEquations | Gets the Alignment's station equation collection.
StationIndexIncrement | Gets or sets the Alignment station index increment.
StyleId | Sets the Alignment's style Id.
StyleName | Sets the Alignment's style name.
SuperElevationData | Gets the superelevation data collection on the Alignment. A read-only copy is returned.
UpdateMode | Gets the update mode of the alignment.
UseDesignCheckSet | Gets or sets whether the Alignment uses the design check set.
UseDesignCriteriaFile | Gets or sets whether the alignment uses the design criteria file.
UseDesignSpeed | Gets or sets a bool value that indicates whether this Alignment uses degign speed.
Links
Public Properties


Alignment::AlignmentType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::AlignmentType Property
Alignment::AlignmentType Property
Collapse All

Gets the alignment type.

C#
public Autodesk::Civil::Land::DatabaseServices::AlignmentType AlignmentType;
Visual Basic
Public Property AlignmentType() As Autodesk::Civil::Land::DatabaseServices::AlignmentType
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::CreationMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::CreationMode Property
Alignment::CreationMode Property
Collapse All

Gets the Alignment creation mode.

C#
public AlignmentCreationType CreationMode;
Visual Basic
Public Property CreationMode() As AlignmentCreationType
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::DesignCheckSetId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::DesignCheckSetId Property
Alignment::DesignCheckSetId Property
Collapse All

Gets the object id of design check set that is used in the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId DesignCheckSetId;
Visual Basic
Public Property DesignCheckSetId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.AlignmentDesignCheckSet

Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::DesignCheckSetName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::DesignCheckSetName Property
Alignment::DesignCheckSetName Property
Collapse All

Gets the name of of design check set that is used in the alignment.

C#
public System::String DesignCheckSetName;
Visual Basic
Public Property DesignCheckSetName() As System::String
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::DesignSpeeds Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::DesignSpeeds Property
Alignment::DesignSpeeds Property
Collapse All

Gets the Alignment design speed collection.

C#
public DesignSpeedCollection DesignSpeeds;
Visual Basic
Public Property DesignSpeeds() As DesignSpeedCollection
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::EndingStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::EndingStation Property
Alignment::EndingStation Property
Collapse All

Gets the Alignment's end station.

C#
public double EndingStation;
Visual Basic
Public Property EndingStation() As double
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::Entities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::Entities Property
Alignment::Entities Property
Collapse All

Gets the Alignment entities collection for the Alignment.

C#
public AlignmentEntityCollection Entities;
Visual Basic
Public Property Entities() As AlignmentEntityCollection
Example
int i = 0;
// iterate through each Entity and check its type
foreach (AlignmentEntity myAe in align.Entities)
{
   i++;
   String msg = "";

   switch (myAe.EntityType)
   {
       case AlignmentEntityType.Arc:
           AlignmentArc myArc = myAe as AlignmentArc;
           msg = String.Format("Entity{0} is an Arc, length: {1}n", i, myArc.Length);
           break;

       case AlignmentEntityType.Spiral:
           AlignmentSpiral mySpiral = myAe as AlignmentSpiral;
           msg = String.Format("Entity{0} is a Spiral, length: {1}n", i, mySpiral.Length);
           break;
       // we could detect other entity types as well, such as
       // Tangent, SpiralCurve, SpiralSpiral, etc.
       default:
           msg = String.Format("Entity{0} is not a spiral or arc.n", i);
           break;

   }
   // write out the Entity information
   ed.WriteMessage(msg);
}
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::IsSiteless Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::IsSiteless Property
Alignment::IsSiteless Property
Collapse All

Gets a bool value that indicates whether this Alignment is a siteless Alignment.

C#
public bool IsSiteless;
Visual Basic
Public Property IsSiteless() As bool
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::Length Property
Alignment::Length Property
Collapse All

Gets the Alignment's length.

C#
public double Length;
Visual Basic
Public Property Length() As double
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::ReferencePoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::ReferencePoint Property
Alignment::ReferencePoint Property
Collapse All

Gets or sets the Alignment reference point.

C#
public Autodesk::AutoCAD::Geometry::Point2d ReferencePoint;
Visual Basic
Public Property ReferencePoint() As Autodesk::AutoCAD::Geometry::Point2d
Remarks

If newValue is not on the Alignment, it will be automatically changed to the closest point along the Alignment.

Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::ReferencePointStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::ReferencePointStation Property
Alignment::ReferencePointStation Property
Collapse All

Gets or sets the Alignment reference point station.

C#
public double ReferencePointStation;
Visual Basic
Public Property ReferencePointStation() As double
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::SiteId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::SiteId Property
Alignment::SiteId Property
Collapse All

Gets the Id for the Site to which this Alignment belongs. ObjectId.Null for a siteless alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SiteId;
Visual Basic
Public Property SiteId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::SiteName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::SiteName Property
Alignment::SiteName Property
Collapse All

Gets the name of the Site to which this Alignment belongs. a string of "" for a siteless alignment.

C#
public System::String SiteName;
Visual Basic
Public Property SiteName() As System::String
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::StartingStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::StartingStation Property
Alignment::StartingStation Property
Collapse All

Gets the Alignment's start station.

C#
public double StartingStation;
Visual Basic
Public Property StartingStation() As double
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::StationEquations Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::StationEquations Property
Alignment::StationEquations Property
Collapse All

Gets the Alignment's station equation collection.

C#
public StationEquationCollection StationEquations;
Visual Basic
Public Property StationEquations() As StationEquationCollection
Example
// Add a station equation:
StationEquation myStationEquation = myAlignment.StationEquations.Add(80, 0, StationEquationType.Increasing);
ed.WriteMessage("Station added.");
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::StationIndexIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::StationIndexIncrement Property
Alignment::StationIndexIncrement Property
Collapse All

Gets or sets the Alignment station index increment.

C#
public double StationIndexIncrement;
Visual Basic
Public Property StationIndexIncrement() As double
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a negative value.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::StyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::StyleId Property
Alignment::StyleId Property
Collapse All

Sets the Alignment's style Id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StyleId;
Visual Basic
Public Property StyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style Id is invalid.
Example
// assign style to an existing alignment
myAlignment.StyleId = myAlignmentStyle.Id;
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::StyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::StyleName Property
Alignment::StyleName Property
Collapse All

Sets the Alignment's style name.

C#
public System::String StyleName;
Visual Basic
Public Property StyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style name is invalid.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::SuperElevationData Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::SuperElevationData Property
Alignment::SuperElevationData Property
Collapse All

Gets the superelevation data collection on the Alignment. A read-only copy is returned.

C#
public Autodesk::Civil::Land::DatabaseServices::SuperElevationData SuperElevationData;
Visual Basic
Public Property SuperElevationData() As Autodesk::Civil::Land::DatabaseServices::SuperElevationData
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::UpdateMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::UpdateMode Property
Alignment::UpdateMode Property
Collapse All

Gets the update mode of the alignment.

C#
public AlignmentUpdateType UpdateMode;
Visual Basic
Public Property UpdateMode() As AlignmentUpdateType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment type is not offset or curb return.
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::UseDesignCheckSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::UseDesignCheckSet Property
Alignment::UseDesignCheckSet Property
Collapse All

Gets or sets whether the Alignment uses the design check set.

C#
public bool UseDesignCheckSet;
Visual Basic
Public Property UseDesignCheckSet() As bool
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::UseDesignCriteriaFile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::UseDesignCriteriaFile Property
Alignment::UseDesignCriteriaFile Property
Collapse All

Gets or sets whether the alignment uses the design criteria file.

C#
public bool UseDesignCriteriaFile;
Visual Basic
Public Property UseDesignCriteriaFile() As bool
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


Alignment::UseDesignSpeed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties > Alignment::UseDesignSpeed Property
Alignment::UseDesignSpeed Property
Collapse All

Gets or sets a bool value that indicates whether this Alignment uses degign speed.

C#
public bool UseDesignSpeed;
Visual Basic
Public Property UseDesignSpeed() As bool
Example
// make alignment design speed-based:
myAlignment.UseDesignSpeed = true;
Links
Alignment Class, Alignment Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class
AlignmentArc Class
Collapse All

The AlignmentArc class.

AlignmentArc derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single AlignmentSubEntityArc object.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentArc
C#
public class AlignmentArc : AlignmentCurve;
Visual Basic
Public Class AlignmentArc
Inherits AlignmentCurve
Links
AlignmentArc Properties, AlignmentArc Members, Class Hierarchy


AlignmentArc Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Members
AlignmentArc Members
Collapse All

The following tables list the members exposed by AlignmentArc.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
CenterPoint | Gets or sets the AlignmentArc's center point.
ChordDirection | Gets the AlignmentArc's chord direction.
ChordLength | Gets or sets the AlignmentArc's chord length.
Clockwise | Gets a bool value that specifies whether the curve entity is a reverse curve.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentArc entity constraint type.
CurveGroupIndex | Gets or sets the AlignmentArc's group index.
CurveGroupSubEntityIndex | Gets or sets the AlignmentArc's group subentity index.
default | Gets a subentity from the AlignmentEntity by index.
DeflectedAngle | Gets or sets the AlignmentArc's deflected angle.
Delta | Gets or sets the AlignmentArc's delta.
DirectionAtPoint1 | Gets or sets the AlignmentArc's direction at point1.
DirectionAtPoint2 | Gets the AlignmentArc's direction at point2.
EndDirection | Gets the AlignmentArc's end direction.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
ExternalSecant | Gets or sets the AlignmentArc's external secant.
ExternalTangent | Gets or sets the AlignmentArc's external tangent.
GreaterThan180 | Gets or sets a bool value indicating whether the Arc solution angle is > 180 Degrees.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets or sets the AlignmentArc's length.
MidOrdinate | Gets or sets the AlignmentArc's mid ordinate.
MinimumRadius | Gets the minimum radius according to the design speed check.
PassThroughPoint1 | Gets or sets the AlignmentArc's first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentArc's second pass-through point.
PassThroughPoint3 | Gets or sets the AlignmentArc's third pass-through point.
PIStation | Gets the AlignmentArc's PI station.
Radius | Gets or sets the AlignmentArc's radius.
ReverseCurve | Gets a bool value that specifies whether the curve entity is a reverse curve.
StartDirection | Gets the AlignmentArc's start direction.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Methods, Public Properties


AlignmentArc Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties
AlignmentArc Properties
Collapse All

The properties of AlignmentArc are listed here.

Public Properties
Public Property | Description
CenterPoint | Gets or sets the AlignmentArc's center point.
ChordDirection | Gets the AlignmentArc's chord direction.
ChordLength | Gets or sets the AlignmentArc's chord length.
Clockwise | Gets a bool value that specifies whether the curve entity is a reverse curve.
Constraint2 | Gets the AlignmentArc entity constraint type.
CurveGroupIndex | Gets or sets the AlignmentArc's group index.
CurveGroupSubEntityIndex | Gets or sets the AlignmentArc's group subentity index.
default | Gets a subentity from the AlignmentEntity by index.
DeflectedAngle | Gets or sets the AlignmentArc's deflected angle.
Delta | Gets or sets the AlignmentArc's delta.
DirectionAtPoint1 | Gets or sets the AlignmentArc's direction at point1.
DirectionAtPoint2 | Gets the AlignmentArc's direction at point2.
EndDirection | Gets the AlignmentArc's end direction.
ExternalSecant | Gets or sets the AlignmentArc's external secant.
ExternalTangent | Gets or sets the AlignmentArc's external tangent.
GreaterThan180 | Gets or sets a bool value indicating whether the Arc solution angle is > 180 Degrees.
Length | Gets or sets the AlignmentArc's length.
MidOrdinate | Gets or sets the AlignmentArc's mid ordinate.
MinimumRadius | Gets the minimum radius according to the design speed check.
PassThroughPoint1 | Gets or sets the AlignmentArc's first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentArc's second pass-through point.
PassThroughPoint3 | Gets or sets the AlignmentArc's third pass-through point.
PIStation | Gets the AlignmentArc's PI station.
Radius | Gets or sets the AlignmentArc's radius.
ReverseCurve | Gets a bool value that specifies whether the curve entity is a reverse curve.
StartDirection | Gets the AlignmentArc's start direction.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Properties


AlignmentArc::CenterPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::CenterPoint Property
AlignmentArc::CenterPoint Property
Collapse All

Gets or sets the AlignmentArc's center point.

C#
public Autodesk::AutoCAD::Geometry::Point2d CenterPoint;
Visual Basic
Public Property CenterPoint() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::ChordDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::ChordDirection Property
AlignmentArc::ChordDirection Property
Collapse All

Gets the AlignmentArc's chord direction.

C#
public double ChordDirection;
Visual Basic
Public Property ChordDirection() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::ChordLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::ChordLength Property
AlignmentArc::ChordLength Property
Collapse All

Gets or sets the AlignmentArc's chord length.

C#
public double ChordLength;
Visual Basic
Public Property ChordLength() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::Clockwise Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::Clockwise Property
AlignmentArc::Clockwise Property
Collapse All

Gets a bool value that specifies whether the curve entity is a reverse curve.

C#
public bool Clockwise;
Visual Basic
Public Property Clockwise() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::Constraint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::Constraint2 Property
AlignmentArc::Constraint2 Property
Collapse All

Gets the AlignmentArc entity constraint type.

C#
public AlignmentArcConstraintType Constraint2;
Visual Basic
Public Property Constraint2() As AlignmentArcConstraintType
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::CurveGroupIndex Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::CurveGroupIndex Property
AlignmentArc::CurveGroupIndex Property
Collapse All

Gets or sets the AlignmentArc's group index.

C#
public System::String CurveGroupIndex;
Visual Basic
Public Property CurveGroupIndex() As System::String
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::CurveGroupSubEntityIndex Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::CurveGroupSubEntityIndex Property
AlignmentArc::CurveGroupSubEntityIndex Property
Collapse All

Gets or sets the AlignmentArc's group subentity index.

C#
public System::String CurveGroupSubEntityIndex;
Visual Basic
Public Property CurveGroupSubEntityIndex() As System::String
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when

  1. Gets an invalid property value in the entity's constraint type.
  2. Sets an invalid value to the property in the entity's constraint type.
  3. Sets operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::default Property
AlignmentArc::default Property
Collapse All

Gets a subentity from the AlignmentEntity by index.

C#
public AlignmentSubEntity default;
Visual Basic
Public Property default() As AlignmentSubEntity
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is 1: greater or equal to the sub-entity count. 2: less than 0.
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::DeflectedAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::DeflectedAngle Property
AlignmentArc::DeflectedAngle Property
Collapse All

Gets or sets the AlignmentArc's deflected angle.

C#
public double DeflectedAngle;
Visual Basic
Public Property DeflectedAngle() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::Delta Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::Delta Property
AlignmentArc::Delta Property
Collapse All

Gets or sets the AlignmentArc's delta.

C#
public double Delta;
Visual Basic
Public Property Delta() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::DirectionAtPoint1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::DirectionAtPoint1 Property
AlignmentArc::DirectionAtPoint1 Property
Collapse All

Gets or sets the AlignmentArc's direction at point1.

C#
public double DirectionAtPoint1;
Visual Basic
Public Property DirectionAtPoint1() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::DirectionAtPoint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::DirectionAtPoint2 Property
AlignmentArc::DirectionAtPoint2 Property
Collapse All

Gets the AlignmentArc's direction at point2.

C#
public double DirectionAtPoint2;
Visual Basic
Public Property DirectionAtPoint2() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::EndDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::EndDirection Property
AlignmentArc::EndDirection Property
Collapse All

Gets the AlignmentArc's end direction.

C#
public double EndDirection;
Visual Basic
Public Property EndDirection() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::ExternalSecant Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::ExternalSecant Property
AlignmentArc::ExternalSecant Property
Collapse All

Gets or sets the AlignmentArc's external secant.

C#
public double ExternalSecant;
Visual Basic
Public Property ExternalSecant() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::ExternalTangent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::ExternalTangent Property
AlignmentArc::ExternalTangent Property
Collapse All

Gets or sets the AlignmentArc's external tangent.

C#
public double ExternalTangent;
Visual Basic
Public Property ExternalTangent() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::GreaterThan180 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::GreaterThan180 Property
AlignmentArc::GreaterThan180 Property
Collapse All

Gets or sets a bool value indicating whether the Arc solution angle is > 180 Degrees.

C#
public bool GreaterThan180;
Visual Basic
Public Property GreaterThan180() As bool
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::Length Property
AlignmentArc::Length Property
Collapse All

Gets or sets the AlignmentArc's length.

C#
public double Length;
Visual Basic
Public Property Length() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. You attempt to set the property to an invalid constraint type.
  2. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::MidOrdinate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::MidOrdinate Property
AlignmentArc::MidOrdinate Property
Collapse All

Gets or sets the AlignmentArc's mid ordinate.

C#
public double MidOrdinate;
Visual Basic
Public Property MidOrdinate() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::MinimumRadius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::MinimumRadius Property
AlignmentArc::MinimumRadius Property
Collapse All

Gets the minimum radius according to the design speed check.

C#
public double MinimumRadius;
Visual Basic
Public Property MinimumRadius() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::PassThroughPoint1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::PassThroughPoint1 Property
AlignmentArc::PassThroughPoint1 Property
Collapse All

Gets or sets the AlignmentArc's first pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint1;
Visual Basic
Public Property PassThroughPoint1() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::PassThroughPoint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::PassThroughPoint2 Property
AlignmentArc::PassThroughPoint2 Property
Collapse All

Gets or sets the AlignmentArc's second pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint2;
Visual Basic
Public Property PassThroughPoint2() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::PassThroughPoint3 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::PassThroughPoint3 Property
AlignmentArc::PassThroughPoint3 Property
Collapse All

Gets or sets the AlignmentArc's third pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint3;
Visual Basic
Public Property PassThroughPoint3() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::PIStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::PIStation Property
AlignmentArc::PIStation Property
Collapse All

Gets the AlignmentArc's PI station.

C#
public double PIStation;
Visual Basic
Public Property PIStation() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::Radius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::Radius Property
AlignmentArc::Radius Property
Collapse All

Gets or sets the AlignmentArc's radius.

C#
public double Radius;
Visual Basic
Public Property Radius() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::ReverseCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::ReverseCurve Property
AlignmentArc::ReverseCurve Property
Collapse All

Gets a bool value that specifies whether the curve entity is a reverse curve.

C#
public bool ReverseCurve;
Visual Basic
Public Property ReverseCurve() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::StartDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::StartDirection Property
AlignmentArc::StartDirection Property
Collapse All

Gets the AlignmentArc's start direction.

C#
public double StartDirection;
Visual Basic
Public Property StartDirection() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentArc::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties > AlignmentArc::SubEntityCount Property
AlignmentArc::SubEntityCount Property
Collapse All

Gets the number of subentities that make up the AlignmentEntity.

C#
public int SubEntityCount;
Visual Basic
Public Property SubEntityCount() As Integer
Links
AlignmentArc Class, AlignmentArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentCurve Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class
AlignmentCurve Class
Collapse All

The AlignmentCurve class. This is an abstract base class for other Alignment Entity classes, such as AlignmentArc, AlignmentSCS, and AlignmentLine.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentArc
        Autodesk::Civil::Land::DatabaseServices::AlignmentLine
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCS
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCSCS
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCSSCS
        Autodesk::Civil::Land::DatabaseServices::AlignmentSpiral
        Autodesk::Civil::Land::DatabaseServices::AlignmentSSCSS
        Autodesk::Civil::Land::DatabaseServices::AlignmentSTS
C#
public class AlignmentCurve : AlignmentEntity;
Visual Basic
Public Class AlignmentCurve
Inherits AlignmentEntity
Links
AlignmentCurve Properties, AlignmentCurve Members, Class Hierarchy


AlignmentCurve Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Members
AlignmentCurve Members
Collapse All

The following tables list the members exposed by AlignmentCurve.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Methods, Public Properties


AlignmentCurve Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Properties
AlignmentCurve Properties
Collapse All

The properties of AlignmentCurve are listed here.

Public Properties
Public Property | Description
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
Links
Public Properties


AlignmentCurve::EndPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Properties > AlignmentCurve::EndPoint Property
AlignmentCurve::EndPoint Property
Collapse All

Gets the end point of the AlignmentCurve.

C#
public Autodesk::AutoCAD::Geometry::Point2d EndPoint;
Visual Basic
Public Property EndPoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
AlignmentCurve Class, AlignmentCurve Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentCurve::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Properties > AlignmentCurve::EndStation Property
AlignmentCurve::EndStation Property
Collapse All

Gets the end station of the AlignmentCurve.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
AlignmentCurve Class, AlignmentCurve Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentCurve::HighestDesignSpeed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Properties > AlignmentCurve::HighestDesignSpeed Property
AlignmentCurve::HighestDesignSpeed Property
Collapse All

Gets the highest design speed of the AlignmentCurve.

C#
public double HighestDesignSpeed;
Visual Basic
Public Property HighestDesignSpeed() As double
Links
AlignmentCurve Class, AlignmentCurve Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentCurve::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Properties > AlignmentCurve::Length Property
AlignmentCurve::Length Property
Collapse All

Gets the length of the AlignmentCurve.

C#
public double Length;
Visual Basic
Public Property Length() As double
Links
AlignmentCurve Class, AlignmentCurve Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentCurve::StartPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Properties > AlignmentCurve::StartPoint Property
AlignmentCurve::StartPoint Property
Collapse All

Gets the start point of the AlignmentCurve.

C#
public Autodesk::AutoCAD::Geometry::Point2d StartPoint;
Visual Basic
Public Property StartPoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
AlignmentCurve Class, AlignmentCurve Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentCurve::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Properties > AlignmentCurve::StartStation Property
AlignmentCurve::StartStation Property
Collapse All

Gets the start station of the AlignmentCurve.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
AlignmentCurve Class, AlignmentCurve Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentCurveLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class
AlignmentCurveLabel Class
Collapse All

This class represents an alignment curve label.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentCurveLabel
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentCurveLabel"))]
public class AlignmentCurveLabel : Autodesk::Civil::DatabaseServices::FeatureLabel;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentCurveLabel"))>
Public Class AlignmentCurveLabel
Inherits Autodesk::Civil::DatabaseServices::FeatureLabel
Links
AlignmentCurveLabel Methods, AlignmentCurveLabel Members, Class Hierarchy


AlignmentCurveLabel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Members
AlignmentCurveLabel Members
Collapse All

The following tables list the members exposed by AlignmentCurveLabel.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Overloaded
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentCurveLabel Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Methods
AlignmentCurveLabel Methods
Collapse All

The methods of AlignmentCurveLabel are listed here.

Public Methods
Public Method | Description
Create | Overloaded
Links
Public Methods


Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Methods > Create Method
Create Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentCurveLabel::Create (AlignmentArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new instance of an AlignmentCurveLabel on an alignment arc entity with the specified label style in the default... more
AlignmentCurveLabel::Create (AlignmentSubEntityArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new instance of an AlignmentCurveLabel on an alignment arc sub-entity with the specified label style in the default... more


AlignmentCurveLabel::Create Method (AlignmentArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Methods > Create Method > AlignmentCurveLabel::Create Method (AlignmentArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
AlignmentCurveLabel::Create Method (AlignmentArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new instance of an AlignmentCurveLabel on an alignment arc entity with the specified label style in the default layer.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref AlignmentArc entity,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Function Create(
    ByRef entity As AlignmentArc,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
entity | The alignment arc entity in which the label is located.
labelStyleId | The object id of label style for the label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentCurve.
Links
AlignmentCurveLabel Class, AlignmentCurveLabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentCurveLabel::Create Method (AlignmentSubEntityArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Methods > Create Method > AlignmentCurveLabel::Create Method (AlignmentSubEntityArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
AlignmentCurveLabel::Create Method (AlignmentSubEntityArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new instance of an AlignmentCurveLabel on an alignment arc sub-entity with the specified label style in the default layer.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref AlignmentSubEntityArc subEntityArc,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Function Create(
    ByRef subEntityArc As AlignmentSubEntityArc,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
subEntityArc | The alignment arc sub-entity in which the label is located.
labelStyleId | The object id of label style for the label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentCurve.
Links
AlignmentCurveLabel Class, AlignmentCurveLabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentDesignSpeedLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class
AlignmentDesignSpeedLabelGroup Class
Collapse All

This class represents an alignment design speed label group.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentDesignSpeedLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentDesignSpeedLabeling"))]
public class AlignmentDesignSpeedLabelGroup : AlignmentLabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentDesignSpeedLabeling"))>
Public Class AlignmentDesignSpeedLabelGroup
Inherits AlignmentLabelGroup
Links
AlignmentDesignSpeedLabelGroup Methods, AlignmentDesignSpeedLabelGroup Members, Class Hierarchy


AlignmentDesignSpeedLabelGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Members
AlignmentDesignSpeedLabelGroup Members
Collapse All

The following tables list the members exposed by AlignmentDesignSpeedLabelGroup.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentDesignSpeedLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentDesignSpeedLabelGroup objects on the alignment.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentDesignSpeedLabelGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Methods
AlignmentDesignSpeedLabelGroup Methods
Collapse All

The methods of AlignmentDesignSpeedLabelGroup are listed here.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentDesignSpeedLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentDesignSpeedLabelGroup objects on the alignment.
Links
Public Methods


AlignmentDesignSpeedLabelGroup::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Methods > AlignmentDesignSpeedLabelGroup::Create Method
AlignmentDesignSpeedLabelGroup::Create Method
Collapse All

Creates a new instance of an AlignmentDesignSpeedLabelGroup on an alignment entity with the specified label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId
);
Visual Basic
Public Function Create(
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
styleId | The style of the new AlignmentDesignSpeedLabelGroup.
alignmentId | The alignment in which the labelgroup is located.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the styleId or alignmentId is invalid.
Links
AlignmentDesignSpeedLabelGroup Class, AlignmentDesignSpeedLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentDesignSpeedLabelGroup::GetAvailableLabelGroups Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Methods > AlignmentDesignSpeedLabelGroup::GetAvailableLabelGroups Method
AlignmentDesignSpeedLabelGroup::GetAvailableLabelGroups Method
Collapse All

Returns the ObjectId collection of AlignmentDesignSpeedLabelGroup objects on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAvailableLabelGroups(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    bool includeDerived
);
Visual Basic
Public Function GetAvailableLabelGroups(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    includeDerived As bool
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
alignmentId | ObjectId of the alignment where the labels are located.
includeDerived | Indicates whether to include the derived types of label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the alignmentId is invalid.
Links
AlignmentDesignSpeedLabelGroup Class, AlignmentDesignSpeedLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntity Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class
AlignmentEntity Class
Collapse All

The AlignmentEntity class. This is an abstract class from which AlignmentCurve inherits.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
C#
public class AlignmentEntity : CivilWrapper<AeccDbAlignment>;
Visual Basic
Public Class AlignmentEntity
Inherits CivilWrapper<AeccDbAlignment>
Links
AlignmentEntity Methods, AlignmentEntity Properties, AlignmentEntity Members, Class Hierarchy


AlignmentEntity Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Members
AlignmentEntity Members
Collapse All

The following tables list the members exposed by AlignmentEntity.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
default | Gets a subentity from the AlignmentEntity by index.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Methods, Public Properties


AlignmentEntity Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Methods
AlignmentEntity Methods
Collapse All

The methods of AlignmentEntity are listed here.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Links
Public Methods


AlignmentEntity::DesignChecks Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Methods > AlignmentEntity::DesignChecks Method
AlignmentEntity::DesignChecks Method
Collapse All

Gets the collection of applicable design checks.

C#
public System::Collections::ObjectModel::Collection<AlignmentDesignCheck^> DesignChecks();
Visual Basic
Public Function DesignChecks() As System::Collections::ObjectModel::Collection<AlignmentDesignCheck^>
Links
AlignmentEntity Class, AlignmentEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntity::ValidateDesignCheck Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Methods > AlignmentEntity::ValidateDesignCheck Method
AlignmentEntity::ValidateDesignCheck Method
Collapse All

Validate a specific design check on this entity.

C#
public bool ValidateDesignCheck(
    ref AlignmentDesignCheck designCheck
);
Visual Basic
Public Function ValidateDesignCheck(
    ByRef designCheck As AlignmentDesignCheck
) As bool
Parameters
Parameters | Description
designCheck | The design check to validate
Remarks

This method is only used to check alignment entity with type AlignmentEntityType::SpiralCurve,CurveSpiral,SpiralSpiral,SpiralCurveSpiral.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when 1: The design check type is not AlignmentDesignCheckType::TangentIntersection. 2: The alignment entity type is not AlignmentEntityType::SpiralCurve, CurveSpiral, SpiralSpiral or SpiralCurveSpiral.
Links
AlignmentEntity Class, AlignmentEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntity Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties
AlignmentEntity Properties
Collapse All

The properties of AlignmentEntity are listed here.

Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
default | Gets a subentity from the AlignmentEntity by index.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Properties


AlignmentEntity::Constraint1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties > AlignmentEntity::Constraint1 Property
AlignmentEntity::Constraint1 Property
Collapse All

Gets the AlignmentEntity constraint type, either Fixed, Float or Free.

C#
public AlignmentEntityConstraintType Constraint1;
Visual Basic
Public Property Constraint1() As AlignmentEntityConstraintType
Links
AlignmentEntity Class, AlignmentEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntity::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties > AlignmentEntity::default Property
AlignmentEntity::default Property
Collapse All

Gets a subentity from the AlignmentEntity by index.

C#
public AlignmentSubEntity default;
Visual Basic
Public Property default() As AlignmentSubEntity
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is 1: greater or equal to the sub-entity count. 2: less than 0.
Links
AlignmentEntity Class, AlignmentEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntity::EntityAfter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties > AlignmentEntity::EntityAfter Property
AlignmentEntity::EntityAfter Property
Collapse All

Gets the ID of the AlignmentEntity after this one.

C#
public long EntityAfter;
Visual Basic
Public Property EntityAfter() As long
Exceptions
Exceptions | Description
Autodesk::Civil::EntityNotFoundException | Throw when the entity is the last one in the collection.
Links
AlignmentEntity Class, AlignmentEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntity::EntityBefore Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties > AlignmentEntity::EntityBefore Property
AlignmentEntity::EntityBefore Property
Collapse All

Gets the ID of the AlignmentEntity before this one.

C#
public long EntityBefore;
Visual Basic
Public Property EntityBefore() As long
Exceptions
Exceptions | Description
Autodesk::Civil::EntityNotFoundException | Throw when the entity is the first one in the collection.
Links
AlignmentEntity Class, AlignmentEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntity::EntityId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties > AlignmentEntity::EntityId Property
AlignmentEntity::EntityId Property
Collapse All

Gets the AlignmentEntity id, which is the unique representation of this alignment entity.

C#
public int EntityId;
Visual Basic
Public Property EntityId() As Integer
Links
AlignmentEntity Class, AlignmentEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntity::EntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties > AlignmentEntity::EntityType Property
AlignmentEntity::EntityType Property
Collapse All

Gets the AlignmentEntity type.

C#
public AlignmentEntityType EntityType;
Visual Basic
Public Property EntityType() As AlignmentEntityType
Links
AlignmentEntity Class, AlignmentEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntity::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties > AlignmentEntity::SubEntityCount Property
AlignmentEntity::SubEntityCount Property
Collapse All

Gets the number of subentities that make up the AlignmentEntity.

C#
public int SubEntityCount;
Visual Basic
Public Property SubEntityCount() As Integer
Links
AlignmentEntity Class, AlignmentEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class
AlignmentEntityCollection Class
Collapse All

The AlignmentEntity collection class. This class represents the collection of all AlignmentEntity objects that belong to an Alignment.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntityCollection
C#
public class AlignmentEntityCollection : CivilWrapper<AeccDbAlignment>, System::Collections::Generic::IEnumerable<AlignmentEntity^>;
Visual Basic
Public Class AlignmentEntityCollection
Inherits CivilWrapper<AeccDbAlignment>
Inherits System::Collections::Generic::IEnumerable<AlignmentEntity^>
Links
AlignmentEntityCollection Methods, AlignmentEntityCollection Properties, AlignmentEntityCollection Members, Class Hierarchy


AlignmentEntityCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Members
AlignmentEntityCollection Members
Collapse All

The following tables list the members exposed by AlignmentEntityCollection.

Public Methods
Public Method | Description
AddFixedCurve | Overloaded
AddFixedLine | Overloaded
AddFixedSpiral | Overloaded
AddFloatingArcWithSpiral | Overloaded
AddFloatingCSS | Overloaded
AddFloatingCurve | Overloaded
AddFloatingLine | Overloaded
AddFloatingLineWithSpiral | Overloaded
AddFloatingSSC | Overloaded
AddFreeCurve | Overloaded
AddFreeLine | Creates an AlignmentLine entity defined by two successive elements identified by ID.
AddFreeSCS | Creates a AlignmentSCS (Spiral-Curve-Spiral group) entity defined by a previous entity, a next entity, the 'A' values of two spirals,... more
AddFreeSCSCS | Creates an AlignmentSCSCS (Spiral-Curve-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition... more
AddFreeSCSSCS | Creates an AlignmentSCSSCS (Spiral-Curve-Spiral-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition... more
AddFreeSpiral | Creates a AlignmentSCS (Spiral-Curve-Spiral group with a curve and a spiral length is 0) entity defined by a previous entity,... more
AddFreeSSBetweenCurves | Adds an AlignmentSTS (Spiral-Line-Spiral group with the line length is 0) entity constrained by the two spiral parameters.
AddFreeSSBetweenTangents | Creates a AlignmentSCS (Spiral-Curve-Spiral groupwith the curve length is 0) entity defined by a previous entity, a next entity, the... more
AddFreeSTS | Overloaded
Clear | Removes all alignment entities from the collection.
EntityAtId | Returns the AlignmentEntity specified by ID.
EntityAtStation | Gets the AlignmentEntity at a specified Station in the Alignment.
GetEntityByOrder | Gets an AlignmentEntity at a specified order index along the alignment path. This function behaves like the GUI in that... more
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes alignment entity from the collection by the specified entity object.
RemoveAt | Removes alignment entity from the collection by the specified index.
Public Properties
Public Property | Description
Count | Gets the number of AlignmentEntity objects in the collection.
default | Gets the AlignmentEntity object at a specified index in the collection.
FirstEntity | Gets the ID of the first AlignmentEntity in the collection.
LastEntity | Gets the ID of the last AlignmentEntity in the collection.
Links
Public Methods, Public Properties


AlignmentEntityCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods
AlignmentEntityCollection Methods
Collapse All

The methods of AlignmentEntityCollection are listed here.

Public Methods
Public Method | Description
AddFixedCurve | Overloaded
AddFixedLine | Overloaded
AddFixedSpiral | Overloaded
AddFloatingArcWithSpiral | Overloaded
AddFloatingCSS | Overloaded
AddFloatingCurve | Overloaded
AddFloatingLine | Overloaded
AddFloatingLineWithSpiral | Overloaded
AddFloatingSSC | Overloaded
AddFreeCurve | Overloaded
AddFreeLine | Creates an AlignmentLine entity defined by two successive elements identified by ID.
AddFreeSCS | Creates a AlignmentSCS (Spiral-Curve-Spiral group) entity defined by a previous entity, a next entity, the 'A' values of two spirals,... more
AddFreeSCSCS | Creates an AlignmentSCSCS (Spiral-Curve-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition... more
AddFreeSCSSCS | Creates an AlignmentSCSSCS (Spiral-Curve-Spiral-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition... more
AddFreeSpiral | Creates a AlignmentSCS (Spiral-Curve-Spiral group with a curve and a spiral length is 0) entity defined by a previous entity,... more
AddFreeSSBetweenCurves | Adds an AlignmentSTS (Spiral-Line-Spiral group with the line length is 0) entity constrained by the two spiral parameters.
AddFreeSSBetweenTangents | Creates a AlignmentSCS (Spiral-Curve-Spiral groupwith the curve length is 0) entity defined by a previous entity, a next entity, the... more
AddFreeSTS | Overloaded
Clear | Removes all alignment entities from the collection.
EntityAtId | Returns the AlignmentEntity specified by ID.
EntityAtStation | Gets the AlignmentEntity at a specified Station in the Alignment.
GetEntityByOrder | Gets an AlignmentEntity at a specified order index along the alignment path. This function behaves like the GUI in that... more
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes alignment entity from the collection by the specified entity object.
RemoveAt | Removes alignment entity from the collection by the specified index.
Links
Public Methods


AddFixedCurve Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedCurve Method
AddFixedCurve Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFixedCurve (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d) | Creates an AlignmentArc entity defined by an initial pass-through point, a second pass-through point, and a direction at the second... more
AlignmentEntityCollection::AddFixedCurve (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, bool) | Creates an AlignmentArc entity defined by a center point, a pass-through point, and a boolean value that specifies whether the... more
AlignmentEntityCollection::AddFixedCurve (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, bool) | Creates an AlignmentArc entity defined by an initial pass-through point, a second pass-through point, the radius, and a boolean specifying... more
AlignmentEntityCollection::AddFixedCurve (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, Autodesk::AutoCAD::Geometry::Point3d) | Creates an AlignmentArc entity defined by an initial pass-through point, a direction at the initial pass-through point, and a second... more
AlignmentEntityCollection::AddFixedCurve (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, double, bool) | Creates an AlignmentArc entity defined by an initial pass-through point, a direction at the second pass-through point, the radius, and... more
AlignmentEntityCollection::AddFixedCurve (Autodesk::AutoCAD::Geometry::Point3d, double, bool) | Creates an AlignmentArc entity defined by a center point, radius, and boolean value that specifies whether the direction is clockwise.... more
AlignmentEntityCollection::AddFixedCurve (long, Autodesk::AutoCAD::Geometry::Point3d) | Creates an AlignmentArc entity defined by a previous entity and a pass-through point.
AlignmentEntityCollection::AddFixedCurve (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d) | Creates an AlignmentArc entity defined by a start point, middle point, and end point.


AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedCurve Method > AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d)
AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d)
Collapse All

Creates an AlignmentArc entity defined by an initial pass-through point, a second pass-through point, and a direction at the second pass-through point.

C#
public AlignmentArc AddFixedCurve(
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint1,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint2,
    Autodesk::AutoCAD::Geometry::Vector3d directionAtPassThroughPoint2
);
Visual Basic
Public Function AddFixedCurve(
    passThroughPoint1 As Autodesk::AutoCAD::Geometry::Point3d,
    passThroughPoint2 As Autodesk::AutoCAD::Geometry::Point3d,
    directionAtPassThroughPoint2 As Autodesk::AutoCAD::Geometry::Vector3d
) As AlignmentArc
Parameters
Parameters | Description
passThroughPoint1 | First pass-through point of the AlignmentArc entity (point #1).
passThroughPoint2 | Second pass-through point of the AlignmentArc entity (point #2).
directionAtPassThroughPoint2 | Direction at second pass-through point #2.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, bool)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedCurve Method > AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, bool)
AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, bool)
Collapse All

Creates an AlignmentArc entity defined by a center point, a pass-through point, and a boolean value that specifies whether the direction is clockwise at the pass-through point.

C#
public AlignmentArc AddFixedCurve(
    Autodesk::AutoCAD::Geometry::Point3d centerPoint,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    bool isClockwise
);
Visual Basic
Public Function AddFixedCurve(
    centerPoint As Autodesk::AutoCAD::Geometry::Point3d,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    isClockwise As bool
) As AlignmentArc
Parameters
Parameters | Description
centerPoint | Center point of the AlignmentArc entity.
passThroughPoint | Passthrough point of the AlignmentArc entity.
isClockwise | Specifies whether the AlignmentArc entity is created clockwise (True) or counter-clockwise (False).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, bool)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedCurve Method > AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, bool)
AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, bool)
Collapse All

Creates an AlignmentArc entity defined by an initial pass-through point, a second pass-through point, the radius, and a boolean specifying whether the curve direction is clockwise.

C#
public AlignmentArc AddFixedCurve(
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint1,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint2,
    double radius,
    bool isClockwise
);
Visual Basic
Public Function AddFixedCurve(
    passThroughPoint1 As Autodesk::AutoCAD::Geometry::Point3d,
    passThroughPoint2 As Autodesk::AutoCAD::Geometry::Point3d,
    radius As double,
    isClockwise As bool
) As AlignmentArc
Parameters
Parameters | Description
passThroughPoint1 | First pass-through point of the AlignmentArc entity (point #1).
passThroughPoint2 | Second pass-through point of the AlignmentArc entity (point #2).
radius | Radius of the AlignmentArc entity.
isClockwise | Specifies whether the AlignmentArc entity is created clockwise (True) or counter-clockwise (False).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedCurve Method > AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, Autodesk::AutoCAD::Geometry::Point3d)
AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates an AlignmentArc entity defined by an initial pass-through point, a direction at the initial pass-through point, and a second pass-through point.

C#
public AlignmentArc AddFixedCurve(
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint1,
    Autodesk::AutoCAD::Geometry::Vector3d directionAtPassThroughPoint1,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint2
);
Visual Basic
Public Function AddFixedCurve(
    passThroughPoint1 As Autodesk::AutoCAD::Geometry::Point3d,
    directionAtPassThroughPoint1 As Autodesk::AutoCAD::Geometry::Vector3d,
    passThroughPoint2 As Autodesk::AutoCAD::Geometry::Point3d
) As AlignmentArc
Parameters
Parameters | Description
passThroughPoint1 | First pass-through point of the AlignmentArc entity (point #1).
directionAtPassThroughPoint1 | Direction at first pass-through point #1.
passThroughPoint2 | Second pass-through point of the AlignmentArc entity (point #2).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, double, bool)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedCurve Method > AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, double, bool)
AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, double, bool)
Collapse All

Creates an AlignmentArc entity defined by an initial pass-through point, a direction at the second pass-through point, the radius, and a boolean indicating whether the curve direction is clockwise.

C#
public AlignmentArc AddFixedCurve(
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint1,
    Autodesk::AutoCAD::Geometry::Vector3d directionAtPassThroughPoint1,
    double radius,
    bool isClockwise
);
Visual Basic
Public Function AddFixedCurve(
    passThroughPoint1 As Autodesk::AutoCAD::Geometry::Point3d,
    directionAtPassThroughPoint1 As Autodesk::AutoCAD::Geometry::Vector3d,
    radius As double,
    isClockwise As bool
) As AlignmentArc
Parameters
Parameters | Description
passThroughPoint1 | Passthrough point of the AlignmentArc entity.
directionAtPassThroughPoint1 | Direction at pass-through point.
radius | Radius of the AlignmentArc entity.
isClockwise | Specifies whether the AlignmentArc entity is created clockwise (True) or counter-clockwise (False).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, double, bool)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedCurve Method > AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, double, bool)
AlignmentEntityCollection::AddFixedCurve Method (Autodesk::AutoCAD::Geometry::Point3d, double, bool)
Collapse All

Creates an AlignmentArc entity defined by a center point, radius, and boolean value that specifies whether the direction is clockwise.

C#
public AlignmentArc AddFixedCurve(
    Autodesk::AutoCAD::Geometry::Point3d centerPoint,
    double radius,
    bool isClockwise
);
Visual Basic
Public Function AddFixedCurve(
    centerPoint As Autodesk::AutoCAD::Geometry::Point3d,
    radius As double,
    isClockwise As bool
) As AlignmentArc
Parameters
Parameters | Description
centerPoint | Center point of the AlignmentArc entity.
radius | Radius of the AlignmentArc entity.
isClockwise | Specifies whether the AlignmentArc entity is created clockwise (True) or counter-clockwise (False).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedCurve Method > AlignmentEntityCollection::AddFixedCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d)
AlignmentEntityCollection::AddFixedCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates an AlignmentArc entity defined by a previous entity and a pass-through point.

C#
public AlignmentArc AddFixedCurve(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint
);
Visual Basic
Public Function AddFixedCurve(
    previousEntityId As long,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d
) As AlignmentArc
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
passThroughPoint | Passthrough point of the AlignmentArc entity.
Example
Alignment myAlignment = ts.GetObject(res.ObjectId, OpenMode.ForWrite) as Alignment;
Int32 previousEntityId = myAlignment.Entities.LastEntity;
Point3d passThroughPoint = new Point3d(7930.2822, 15744.28, 0);
AlignmentArc retVal = myAlignment.Entities.AddFixedCurve(previousEntityId, passThroughPoint);
if (retVal == null)
{
   ed.WriteMessage("AddFixedCurve failed.");
}
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedCurve Method > AlignmentEntityCollection::AddFixedCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d)
AlignmentEntityCollection::AddFixedCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates an AlignmentArc entity defined by a start point, middle point, and end point.

C#
public AlignmentArc AddFixedCurve(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d startPoint,
    Autodesk::AutoCAD::Geometry::Point3d middlePoint,
    Autodesk::AutoCAD::Geometry::Point3d endPoint
);
Visual Basic
Public Function AddFixedCurve(
    previousEntityId As long,
    startPoint As Autodesk::AutoCAD::Geometry::Point3d,
    middlePoint As Autodesk::AutoCAD::Geometry::Point3d,
    endPoint As Autodesk::AutoCAD::Geometry::Point3d
) As AlignmentArc
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
startPoint | Start point of the AlignmentArc entity.
middlePoint | Middle point of the AlignmentArc entity.
endPoint | End point of the AlignmentArc entity.
Remarks

If possible, connect to the previous entity.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFixedLine Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedLine Method
AddFixedLine Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFixedLine (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d) | Creates an AlignmentLine entity defined by a start point and an end point.
AlignmentEntityCollection::AddFixedLine (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d) | Creates an AlignmentLine entity defined by a start point and an end point.
AlignmentEntityCollection::AddFixedLine (long, double) | Creates an AlignmentLine entity defined by a previous entity ID and a distance value for the new line.


AlignmentEntityCollection::AddFixedLine Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedLine Method > AlignmentEntityCollection::AddFixedLine Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d)
AlignmentEntityCollection::AddFixedLine Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates an AlignmentLine entity defined by a start point and an end point.

C#
public AlignmentLine AddFixedLine(
    Autodesk::AutoCAD::Geometry::Point3d startPoint,
    Autodesk::AutoCAD::Geometry::Point3d endPoint
);
Visual Basic
Public Function AddFixedLine(
    startPoint As Autodesk::AutoCAD::Geometry::Point3d,
    endPoint As Autodesk::AutoCAD::Geometry::Point3d
) As AlignmentLine
Parameters
Parameters | Description
startPoint | Start point of the line entity.
endPoint | End point of the line entity.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedLine Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedLine Method > AlignmentEntityCollection::AddFixedLine Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d)
AlignmentEntityCollection::AddFixedLine Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates an AlignmentLine entity defined by a start point and an end point.

C#
public AlignmentLine AddFixedLine(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d startPoint,
    Autodesk::AutoCAD::Geometry::Point3d endPoint
);
Visual Basic
Public Function AddFixedLine(
    previousEntityId As long,
    startPoint As Autodesk::AutoCAD::Geometry::Point3d,
    endPoint As Autodesk::AutoCAD::Geometry::Point3d
) As AlignmentLine
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
startPoint | Start point of the line entity.
endPoint | End point of the line entity.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedLine Method (long, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedLine Method > AlignmentEntityCollection::AddFixedLine Method (long, double)
AlignmentEntityCollection::AddFixedLine Method (long, double)
Collapse All

Creates an AlignmentLine entity defined by a previous entity ID and a distance value for the new line.

C#
public AlignmentLine AddFixedLine(
    long previousEntityId,
    double distance
);
Visual Basic
Public Function AddFixedLine(
    previousEntityId As long,
    distance As double
) As AlignmentLine
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
distance | Distance of the line entity.
Remarks

Use absolute values for distance, so it is valid when distance is negative.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFixedSpiral Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedSpiral Method
AddFixedSpiral Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFixedSpiral (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, SpiralType) | Creates an AlignmentSpiral entity defined by a previous entity, a start point, a point of intersection, an end point and... more
AlignmentEntityCollection::AddFixedSpiral (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, double, bool, SpiralType) | Creates a spiral entity defined by a previous entity, a start point, a point of intersection, a start radius, an... more
AlignmentEntityCollection::AddFixedSpiral (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralCurveType, bool, SpiralType) | Creates an AlignmentSpiral entity defined by a previous entity, a start point, a point of intersection, a radius, a length,... more
AlignmentEntityCollection::AddFixedSpiral (long, double, double, double, SpiralType) | Creates an AlignmentSpiral entity defined by a previous entity, a start point, a point of intersection, a start radius, an... more
AlignmentEntityCollection::AddFixedSpiral (long, double, double, SpiralCurveType, SpiralType) | Creates an AlignmentSpiral entity defined by a previous entity, a start point, a point of intersection, a radius, a length,... more


AlignmentEntityCollection::AddFixedSpiral Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedSpiral Method > AlignmentEntityCollection::AddFixedSpiral Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)
AlignmentEntityCollection::AddFixedSpiral Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)
Collapse All

Creates an AlignmentSpiral entity defined by a previous entity, a start point, a point of intersection, an end point and a spiral curvature type.

C#
public AlignmentSpiral AddFixedSpiral(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d startPoint,
    Autodesk::AutoCAD::Geometry::Point3d spiralPI,
    Autodesk::AutoCAD::Geometry::Point3d endPoint,
    SpiralType definitionType
);
Visual Basic
Public Function AddFixedSpiral(
    previousEntityId As long,
    startPoint As Autodesk::AutoCAD::Geometry::Point3d,
    spiralPI As Autodesk::AutoCAD::Geometry::Point3d,
    endPoint As Autodesk::AutoCAD::Geometry::Point3d,
    definitionType As SpiralType
) As AlignmentSpiral
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
startPoint | Start point of the spriral entity.
spiralPI | Point of intersection for the spiral entity.
endPoint | End point of the spriral entity.
definitionType | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedSpiral Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralCurveType, bool, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedSpiral Method > AlignmentEntityCollection::AddFixedSpiral Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralCurveType, bool, SpiralType)
AlignmentEntityCollection::AddFixedSpiral Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralCurveType, bool, SpiralType)
Collapse All

Creates an AlignmentSpiral entity defined by a previous entity, a start point, a point of intersection, a radius, a length, a spiral curvature type and a clockwise indicator.

C#
public AlignmentSpiral AddFixedSpiral(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d startPoint,
    Autodesk::AutoCAD::Geometry::Point3d spiralPI,
    double radius,
    double length,
    SpiralCurveType spiralCurveType,
    bool isClockwise,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFixedSpiral(
    previousEntityId As long,
    startPoint As Autodesk::AutoCAD::Geometry::Point3d,
    spiralPI As Autodesk::AutoCAD::Geometry::Point3d,
    radius As double,
    length As double,
    spiralCurveType As SpiralCurveType,
    isClockwise As bool,
    spiralDefinition As SpiralType
) As AlignmentSpiral
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
startPoint | Start point of spriral entity.
spiralPI | Point of intersection for spiral entity.
radius | Radius of the arc entity.
length | Length of spriral entity.
spiralCurveType | Specifies the spiral curve type, InCurve or OutCurve.
isClockwise | Specifies whether spiral entity is created clockwise (True) or counter-clockwise (False).
spiralDefinition | Specifies the spiral definition type.
Remarks

If possible, connect to the previous entity.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedSpiral Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, double, bool, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedSpiral Method > AlignmentEntityCollection::AddFixedSpiral Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, double, bool, SpiralType)
AlignmentEntityCollection::AddFixedSpiral Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, double, bool, SpiralType)
Collapse All

Creates a spiral entity defined by a previous entity, a start point, a point of intersection, a start radius, an end radius, a length, a spiral definition, and a clockwise indicator.

C#
public AlignmentSpiral AddFixedSpiral(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d startPoint,
    Autodesk::AutoCAD::Geometry::Point3d spiralPI,
    double startRadius,
    double endRadius,
    double length,
    bool isClockwise,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFixedSpiral(
    previousEntityId As long,
    startPoint As Autodesk::AutoCAD::Geometry::Point3d,
    spiralPI As Autodesk::AutoCAD::Geometry::Point3d,
    startRadius As double,
    endRadius As double,
    length As double,
    isClockwise As bool,
    spiralDefinition As SpiralType
) As AlignmentSpiral
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
startPoint | Start point of the spiral entity.
spiralPI | Point of intersection of the spiral entity.
startRadius | Start value of the radius of the arc.
endRadius | End value of the radius of the arc.
length | Length of the spiral entity.
isClockwise | Specifies whether the spiral entity is created clockwise (True) or counter-clockwise (False).
spiralDefinition | Specifies the spiral definition type.
Remarks

If possible, connect to the previous entity.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedSpiral Method (long, double, double, SpiralCurveType, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedSpiral Method > AlignmentEntityCollection::AddFixedSpiral Method (long, double, double, SpiralCurveType, SpiralType)
AlignmentEntityCollection::AddFixedSpiral Method (long, double, double, SpiralCurveType, SpiralType)
Collapse All

Creates an AlignmentSpiral entity defined by a previous entity, a start point, a point of intersection, a radius, a length, a spiral curvature type and a clockwise indicator.

C#
public AlignmentSpiral AddFixedSpiral(
    long previousEntityId,
    double radius,
    double length,
    SpiralCurveType spiralCurveType,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFixedSpiral(
    previousEntityId As long,
    radius As double,
    length As double,
    spiralCurveType As SpiralCurveType,
    spiralDefinition As SpiralType
) As AlignmentSpiral
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
radius | Radius of the arc entity.
length | Length of the spriral entity.
spiralCurveType | Specifies the spiral curve type, InCurve or OutCurve.
spiralDefinition | Specifies the spiral definition type.
Remarks

If possible, connect to the previous entity.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFixedSpiral Method (long, double, double, double, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFixedSpiral Method > AlignmentEntityCollection::AddFixedSpiral Method (long, double, double, double, SpiralType)
AlignmentEntityCollection::AddFixedSpiral Method (long, double, double, double, SpiralType)
Collapse All

Creates an AlignmentSpiral entity defined by a previous entity, a start point, a point of intersection, a start radius, an end radius, a length, a spiral definition, and a clockwise indicator.

C#
public AlignmentSpiral AddFixedSpiral(
    long previousEntityId,
    double startRadius,
    double endRadius,
    double length,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFixedSpiral(
    previousEntityId As long,
    startRadius As double,
    endRadius As double,
    length As double,
    spiralDefinition As SpiralType
) As AlignmentSpiral
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
startRadius | Start value of the radius of the arc.
endRadius | End value of the radius of the arc.
length | Length of the spiral entity.
spiralDefinition | Specifies the spiral definition type.
Remarks

If possible, connect to the previous entity.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFloatingArcWithSpiral Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingArcWithSpiral Method
AddFloatingArcWithSpiral Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFloatingArcWithSpiral (long, EntityAttachType, double, SpiralParamType, double, Autodesk::AutoCAD::Geometry::Point3d, bool, SpiralType) | Adds an AlignmentSCS (SC or CS, Float Arc with Spiral) constrained by a spiral parameter, the radius for the circular... more
AlignmentEntityCollection::AddFloatingArcWithSpiral (long, EntityAttachType, double, SpiralParamType, double, double, bool, SpiralType) | Add an AlignmentSCS (SC or CS, Float Arc with Spiral) constrained by spiral parameter, the radius for the circular arc,... more


AlignmentEntityCollection::AddFloatingArcWithSpiral Method (long, EntityAttachType, double, SpiralParamType, double, Autodesk::AutoCAD::Geometry::Point3d, bool, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingArcWithSpiral Method > AlignmentEntityCollection::AddFloatingArcWithSpiral Method (long, EntityAttachType, double, SpiralParamType, double, Autodesk::AutoCAD::Geometry::Point3d, bool, SpiralType)
AlignmentEntityCollection::AddFloatingArcWithSpiral Method (long, EntityAttachType, double, SpiralParamType, double, Autodesk::AutoCAD::Geometry::Point3d, bool, SpiralType)
Collapse All

Adds an AlignmentSCS (SC or CS, Float Arc with Spiral) constrained by a spiral parameter, the radius for the circular arc, and a pass-through point for the circular arc.

C#
public AlignmentSCS AddFloatingArcWithSpiral(
    long attachEntityId,
    EntityAttachType attachType,
    double spParam,
    SpiralParamType spType,
    double radius,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    bool isGreaterThan180,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFloatingArcWithSpiral(
    attachEntityId As long,
    attachType As EntityAttachType,
    spParam As double,
    spType As SpiralParamType,
    radius As double,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    isGreaterThan180 As bool,
    spiralDefinition As SpiralType
) As AlignmentSCS
Parameters
Parameters | Description
attachEntityId | Previous or next entity identifer.
attachType | Specifies the type to attach to the entity.
spParam | Spiral parameter (length or A-value).
spType | Specifies the spParam's parameter's type.
radius | Radius of the arc entity.
passThroughPoint | Pass-through point of arc entity.
isGreaterThan180 | Specifies whether the curve encompasses more than 180 degrees (True) or less than 180 degrees (False).
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingArcWithSpiral Method (long, EntityAttachType, double, SpiralParamType, double, double, bool, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingArcWithSpiral Method > AlignmentEntityCollection::AddFloatingArcWithSpiral Method (long, EntityAttachType, double, SpiralParamType, double, double, bool, SpiralType)
AlignmentEntityCollection::AddFloatingArcWithSpiral Method (long, EntityAttachType, double, SpiralParamType, double, double, bool, SpiralType)
Collapse All

Add an AlignmentSCS (SC or CS, Float Arc with Spiral) constrained by spiral parameter, the radius for the circular arc, and length of the circular arc.

C#
public AlignmentSCS AddFloatingArcWithSpiral(
    long attachEntityId,
    EntityAttachType attachType,
    double spParam,
    SpiralParamType spType,
    double radius,
    double arcLength,
    bool isClockwise,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFloatingArcWithSpiral(
    attachEntityId As long,
    attachType As EntityAttachType,
    spParam As double,
    spType As SpiralParamType,
    radius As double,
    arcLength As double,
    isClockwise As bool,
    spiralDefinition As SpiralType
) As AlignmentSCS
Parameters
Parameters | Description
attachEntityId | Previous or Next entity identifier.
attachType | Specifies the type to attach the entity.
spParam | Spiral parameter(length or A-value).
spType | Specifies the previous parameter-spParam's type.
radius | Radius of the arc entity.
arcLength | Length of the arc.
isClockwise | Specifies whether arc entity is created clockwise (True) or counter-clockwise (False).
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFloatingCSS Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCSS Method
AddFloatingCSS Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFloatingCSS (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralParamType, SpiralType) | Adds an AlignmentSSCSS (Spiral-Spiral-Curve-Spiral-Spiral group) entity constrained by a next entity, spiral3 and spiral4 parameters, two pass through points of... more
AlignmentEntityCollection::AddFloatingCSS (long, double, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralParamType, SpiralType) | Adds an AlignmentSSCSS (Spiral-Spiral-Curve-Spiral-Spiral group) entity constrained by a next entity, spiral3 and spiral4 parameters, radius for circular arc, pass... more


AlignmentEntityCollection::AddFloatingCSS Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralParamType, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCSS Method > AlignmentEntityCollection::AddFloatingCSS Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralParamType, SpiralType)
AlignmentEntityCollection::AddFloatingCSS Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralParamType, SpiralType)
Collapse All

Adds an AlignmentSSCSS (Spiral-Spiral-Curve-Spiral-Spiral group) entity constrained by a next entity, spiral3 and spiral4 parameters, two pass through points of the circular arc, and a spiral definition type.

C#
public AlignmentSSCSS AddFloatingCSS(
    long nextEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint1,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint2,
    double sp3Param,
    double sp4Param,
    SpiralParamType spType,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFloatingCSS(
    nextEntityId As long,
    passThroughPoint1 As Autodesk::AutoCAD::Geometry::Point3d,
    passThroughPoint2 As Autodesk::AutoCAD::Geometry::Point3d,
    sp3Param As double,
    sp4Param As double,
    spType As SpiralParamType,
    spiralDefinition As SpiralType
) As AlignmentSSCSS
Parameters
Parameters | Description
nextEntityId | Next entity identifier.
passThroughPoint1 | First pass-through point of the arc entity (point #1).
passThroughPoint2 | Second pass-through point of the arc entity (point #2).
sp3Param | Third parameter (length or A-value).
sp4Param | Forth parameter (length or A-value).
spType | Specifies the spParam parameters' type.
spiralDefinition | Specifies the spiral definition type.
radius | .
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingCSS Method (long, double, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralParamType, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCSS Method > AlignmentEntityCollection::AddFloatingCSS Method (long, double, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralParamType, SpiralType)
AlignmentEntityCollection::AddFloatingCSS Method (long, double, Autodesk::AutoCAD::Geometry::Point3d, double, double, SpiralParamType, SpiralType)
Collapse All

Adds an AlignmentSSCSS (Spiral-Spiral-Curve-Spiral-Spiral group) entity constrained by a next entity, spiral3 and spiral4 parameters, radius for circular arc, pass through point of the circular arc, and a spiral definition type.

C#
public AlignmentSSCSS AddFloatingCSS(
    long nextEntityId,
    double radius,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    double sp3Param,
    double sp4Param,
    SpiralParamType spType,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFloatingCSS(
    nextEntityId As long,
    radius As double,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    sp3Param As double,
    sp4Param As double,
    spType As SpiralParamType,
    spiralDefinition As SpiralType
) As AlignmentSSCSS
Parameters
Parameters | Description
nextEntityId | Next entity identifier.
radius | .
passThroughPoint | Pass-through point of the arc entity.
sp3Param | Third parameter (length or A-value).
sp4Param | Forth parameter (length or A-value).
spType | Specifies the third and fourth spParam parameters' type.
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFloatingCurve Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCurve Method
AddFloatingCurve Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFloatingCurve (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, long) | Creates an AlignmentArc entity defined by a next entity, a pass-through point, and the direction at the pass-through point.
AlignmentEntityCollection::AddFloatingCurve (Autodesk::AutoCAD::Geometry::Point3d, double, bool, CurveType, long) | Creates an AlignmentArc entity defined by a next entity, a pass-through point, a radius, a boolean value indicating whether or... more
AlignmentEntityCollection::AddFloatingCurve (Autodesk::AutoCAD::Geometry::Point3d, long) | Creates an AlignmentArc entity defined by a next entity, and a pass-through point.
AlignmentEntityCollection::AddFloatingCurve (double, double, CurveParamType, bool, long) | Creates an AlignmentArc entity defined by a next entity, radius, a constraint type and value.
AlignmentEntityCollection::AddFloatingCurve (long, Autodesk::AutoCAD::Geometry::Point3d) | Creates an AlignmentArc entity defined by a previous entity, and a pass-through point.
AlignmentEntityCollection::AddFloatingCurve (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d) | Creates an AlignmentArc entity defined by a previous entity, a pass-through point, and the direction at the pass-through point.
AlignmentEntityCollection::AddFloatingCurve (long, Autodesk::AutoCAD::Geometry::Point3d, double, bool, CurveType) | Creates an AlignmentArc entity defined by a previous entity, a pass-through point, a radius, a boolean value indicating whether or... more
AlignmentEntityCollection::AddFloatingCurve (long, double, double, CurveParamType, bool) | Creates an AlignmentArc entity defined by a previous entity, radius, a constraint type and value.


AlignmentEntityCollection::AddFloatingCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, long)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCurve Method > AlignmentEntityCollection::AddFloatingCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, long)
AlignmentEntityCollection::AddFloatingCurve Method (Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d, long)
Collapse All

Creates an AlignmentArc entity defined by a next entity, a pass-through point, and the direction at the pass-through point.

C#
public AlignmentArc AddFloatingCurve(
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    Autodesk::AutoCAD::Geometry::Vector3d directionAtPassThroughPoint,
    long nextEntityId
);
Visual Basic
Public Function AddFloatingCurve(
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    directionAtPassThroughPoint As Autodesk::AutoCAD::Geometry::Vector3d,
    nextEntityId As long
) As AlignmentArc
Parameters
Parameters | Description
passThroughPoint | pass-through point of arc entity.
directionAtPassThroughPoint | Direction at pass-through point.
nextEntityId | Next entity identifier.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingCurve Method (Autodesk::AutoCAD::Geometry::Point3d, double, bool, CurveType, long)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCurve Method > AlignmentEntityCollection::AddFloatingCurve Method (Autodesk::AutoCAD::Geometry::Point3d, double, bool, CurveType, long)
AlignmentEntityCollection::AddFloatingCurve Method (Autodesk::AutoCAD::Geometry::Point3d, double, bool, CurveType, long)
Collapse All

Creates an AlignmentArc entity defined by a next entity, a pass-through point, a radius, a boolean value indicating whether or not the curve encompasses more than 180 degrees of a circle, and the curve type.

C#
public AlignmentArc AddFloatingCurve(
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    double radius,
    bool isGreaterThan180,
    CurveType curveType,
    long nextEntityId
);
Visual Basic
Public Function AddFloatingCurve(
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    radius As double,
    isGreaterThan180 As bool,
    curveType As CurveType,
    nextEntityId As long
) As AlignmentArc
Parameters
Parameters | Description
passThroughPoint | Pass-through point of arc entity.
radius | Radius of the arc entity.
isGreaterThan180 | Specifies whether the curve encompasses more than 180 degrees (True) or less than 180 degrees (False).
curveType | Specifies the curve type.
nextEntityId | Next entity identifier.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingCurve Method (Autodesk::AutoCAD::Geometry::Point3d, long)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCurve Method > AlignmentEntityCollection::AddFloatingCurve Method (Autodesk::AutoCAD::Geometry::Point3d, long)
AlignmentEntityCollection::AddFloatingCurve Method (Autodesk::AutoCAD::Geometry::Point3d, long)
Collapse All

Creates an AlignmentArc entity defined by a next entity, and a pass-through point.

C#
public AlignmentArc AddFloatingCurve(
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    long nextEntityId
);
Visual Basic
Public Function AddFloatingCurve(
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    nextEntityId As long
) As AlignmentArc
Parameters
Parameters | Description
passThroughPoint | Pass-through point of the arc entity.
nextEntityId | Next entity identifier.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingCurve Method (double, double, CurveParamType, bool, long)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCurve Method > AlignmentEntityCollection::AddFloatingCurve Method (double, double, CurveParamType, bool, long)
AlignmentEntityCollection::AddFloatingCurve Method (double, double, CurveParamType, bool, long)
Collapse All

Creates an AlignmentArc entity defined by a next entity, radius, a constraint type and value.

C#
public AlignmentArc AddFloatingCurve(
    double radius,
    double paramValue,
    CurveParamType paramType,
    bool isClockwise,
    long nextEntityId
);
Visual Basic
Public Function AddFloatingCurve(
    radius As double,
    paramValue As double,
    paramType As CurveParamType,
    isClockwise As bool,
    nextEntityId As long
) As AlignmentArc
Parameters
Parameters | Description
radius | Radius of the arc entity.
paramValue | Specifies the curve's constraint value.
paramType | Specifies the curve's constraint type.
isClockwise | Specifies whether arc entity is created clockwise (True) or counter-clockwise (False).
nextEntityId | identifier of the next entity (after the floating arc).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCurve Method > AlignmentEntityCollection::AddFloatingCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d)
AlignmentEntityCollection::AddFloatingCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates an AlignmentArc entity defined by a previous entity, and a pass-through point.

C#
public AlignmentArc AddFloatingCurve(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint
);
Visual Basic
Public Function AddFloatingCurve(
    previousEntityId As long,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d
) As AlignmentArc
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
passThroughPoint | Pass-through point of the arc entity.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCurve Method > AlignmentEntityCollection::AddFloatingCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d)
AlignmentEntityCollection::AddFloatingCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Vector3d)
Collapse All

Creates an AlignmentArc entity defined by a previous entity, a pass-through point, and the direction at the pass-through point.

C#
public AlignmentArc AddFloatingCurve(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    Autodesk::AutoCAD::Geometry::Vector3d directionAtPassThroughPoint
);
Visual Basic
Public Function AddFloatingCurve(
    previousEntityId As long,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    directionAtPassThroughPoint As Autodesk::AutoCAD::Geometry::Vector3d
) As AlignmentArc
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
passThroughPoint | Pass-through point of arc entity.
directionAtPassThroughPoint | Direction at the pass-through point.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d, double, bool, CurveType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCurve Method > AlignmentEntityCollection::AddFloatingCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d, double, bool, CurveType)
AlignmentEntityCollection::AddFloatingCurve Method (long, Autodesk::AutoCAD::Geometry::Point3d, double, bool, CurveType)
Collapse All

Creates an AlignmentArc entity defined by a previous entity, a pass-through point, a radius, a boolean value indicating whether or not the curve encompasses more than 180 degrees of a circle, and the curve type.

C#
public AlignmentArc AddFloatingCurve(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    double radius,
    bool isGreaterThan180,
    CurveType curveType
);
Visual Basic
Public Function AddFloatingCurve(
    previousEntityId As long,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    radius As double,
    isGreaterThan180 As bool,
    curveType As CurveType
) As AlignmentArc
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
passThroughPoint | pass-through point of arc entity.
radius | Radius of the arc entity.
isGreaterThan180 | Specifies whether the curve encompasses more than 180 degrees (True) or less than 180 degrees (False).
curveType | Specifies the curve type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingCurve Method (long, double, double, CurveParamType, bool)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingCurve Method > AlignmentEntityCollection::AddFloatingCurve Method (long, double, double, CurveParamType, bool)
AlignmentEntityCollection::AddFloatingCurve Method (long, double, double, CurveParamType, bool)
Collapse All

Creates an AlignmentArc entity defined by a previous entity, radius, a constraint type and value.

C#
public AlignmentArc AddFloatingCurve(
    long previousEntityId,
    double radius,
    double paramValue,
    CurveParamType paramType,
    bool isClockwise
);
Visual Basic
Public Function AddFloatingCurve(
    previousEntityId As long,
    radius As double,
    paramValue As double,
    paramType As CurveParamType,
    isClockwise As bool
) As AlignmentArc
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
radius | Radius of the arc entity.
paramValue | Specifies the curve's constraint value.
paramType | Specifies the curve's constraint type.
isClockwise | Specifies whether arc entity is created clockwise (True) or counter-clockwise (False).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFloatingLine Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingLine Method
AddFloatingLine Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFloatingLine (Autodesk::AutoCAD::Geometry::Point3d, long) | Creates an AlignmentLine entity defined by a next entity and a pass-through point.
AlignmentEntityCollection::AddFloatingLine (double, long) | Creates an AlignmentLine entity defined by a next entity (to which it is tangent) and a length.
AlignmentEntityCollection::AddFloatingLine (long, Autodesk::AutoCAD::Geometry::Point3d) | Creates an AlignmentLine entity defined by a previous entity and a pass-through point.
AlignmentEntityCollection::AddFloatingLine (long, double) | Creates an AlignmentLine entity defined by a previous entity (to which it is tangent) and a length.


AlignmentEntityCollection::AddFloatingLine Method (Autodesk::AutoCAD::Geometry::Point3d, long)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingLine Method > AlignmentEntityCollection::AddFloatingLine Method (Autodesk::AutoCAD::Geometry::Point3d, long)
AlignmentEntityCollection::AddFloatingLine Method (Autodesk::AutoCAD::Geometry::Point3d, long)
Collapse All

Creates an AlignmentLine entity defined by a next entity and a pass-through point.

C#
public AlignmentLine AddFloatingLine(
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    long nextEntityId
);
Visual Basic
Public Function AddFloatingLine(
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    nextEntityId As long
) As AlignmentLine
Parameters
Parameters | Description
passThroughPoint | Passthrough point of the line entity.
nextEntityId | Next entity identifier.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingLine Method (double, long)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingLine Method > AlignmentEntityCollection::AddFloatingLine Method (double, long)
AlignmentEntityCollection::AddFloatingLine Method (double, long)
Collapse All

Creates an AlignmentLine entity defined by a next entity (to which it is tangent) and a length.

C#
public AlignmentLine AddFloatingLine(
    double length,
    long nextEntityId
);
Visual Basic
Public Function AddFloatingLine(
    length As double,
    nextEntityId As long
) As AlignmentLine
Parameters
Parameters | Description
length | Length of the line entity.
nextEntityId | Next entity identifier.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingLine Method (long, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingLine Method > AlignmentEntityCollection::AddFloatingLine Method (long, Autodesk::AutoCAD::Geometry::Point3d)
AlignmentEntityCollection::AddFloatingLine Method (long, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates an AlignmentLine entity defined by a previous entity and a pass-through point.

C#
public AlignmentLine AddFloatingLine(
    long previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint
);
Visual Basic
Public Function AddFloatingLine(
    previousEntityId As long,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d
) As AlignmentLine
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
passThroughPoint | Passthrough point of the line entity.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingLine Method (long, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingLine Method > AlignmentEntityCollection::AddFloatingLine Method (long, double)
AlignmentEntityCollection::AddFloatingLine Method (long, double)
Collapse All

Creates an AlignmentLine entity defined by a previous entity (to which it is tangent) and a length.

C#
public AlignmentLine AddFloatingLine(
    long previousEntityId,
    double length
);
Visual Basic
Public Function AddFloatingLine(
    previousEntityId As long,
    length As double
) As AlignmentLine
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
length | Length of the line entity.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFloatingLineWithSpiral Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingLineWithSpiral Method
AddFloatingLineWithSpiral Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFloatingLineWithSpiral (long, EntityAttachType, double, SpiralParamType, Autodesk::AutoCAD::Geometry::Point3d, SpiralType) | Adds an AlignmentSTS (ST or TS, Float Line with Spiral) entity constrained by a spiral parameter and pass-through point for... more
AlignmentEntityCollection::AddFloatingLineWithSpiral (long, EntityAttachType, double, SpiralParamType, double, SpiralType) | Adds an AlignmentSTS (ST or TS, Float Line with Spiral) entity constrained by a spiral parameter and line length.


AlignmentEntityCollection::AddFloatingLineWithSpiral Method (long, EntityAttachType, double, SpiralParamType, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingLineWithSpiral Method > AlignmentEntityCollection::AddFloatingLineWithSpiral Method (long, EntityAttachType, double, SpiralParamType, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)
AlignmentEntityCollection::AddFloatingLineWithSpiral Method (long, EntityAttachType, double, SpiralParamType, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)
Collapse All

Adds an AlignmentSTS (ST or TS, Float Line with Spiral) entity constrained by a spiral parameter and pass-through point for the line.

C#
public AlignmentSTS AddFloatingLineWithSpiral(
    long attachEntityId,
    EntityAttachType attachType,
    double spParam,
    SpiralParamType spType,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFloatingLineWithSpiral(
    attachEntityId As long,
    attachType As EntityAttachType,
    spParam As double,
    spType As SpiralParamType,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    spiralDefinition As SpiralType
) As AlignmentSTS
Parameters
Parameters | Description
attachEntityId | Previous or next entity identifer.
attachType | Specifies whehther attachEntityId is the previous or next entity.
spParam | Spiral parameter (length or A-value).
spType | Specifies the spParam parameter's type.
passThroughPoint | Pass-through point of the arc entity.
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingLineWithSpiral Method (long, EntityAttachType, double, SpiralParamType, double, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingLineWithSpiral Method > AlignmentEntityCollection::AddFloatingLineWithSpiral Method (long, EntityAttachType, double, SpiralParamType, double, SpiralType)
AlignmentEntityCollection::AddFloatingLineWithSpiral Method (long, EntityAttachType, double, SpiralParamType, double, SpiralType)
Collapse All

Adds an AlignmentSTS (ST or TS, Float Line with Spiral) entity constrained by a spiral parameter and line length.

C#
public AlignmentSTS AddFloatingLineWithSpiral(
    long attachEntityId,
    EntityAttachType attachType,
    double spParam,
    SpiralParamType spType,
    double tanLength,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFloatingLineWithSpiral(
    attachEntityId As long,
    attachType As EntityAttachType,
    spParam As double,
    spType As SpiralParamType,
    tanLength As double,
    spiralDefinition As SpiralType
) As AlignmentSTS
Parameters
Parameters | Description
attachEntityId | Previous or next entity identifer.
attachType | Specifies whehther attachEntityId is the previous or next entity.
spParam | Spiral parameter (length or A-value).
spType | Specifies the previous parameter-spParam's type.
tanLength | Length of line entity.
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFloatingSSC Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingSSC Method
AddFloatingSSC Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFloatingSSC (long, double, double, SpiralParamType, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, SpiralType) | Adds an AlignmentSSCSS (Spiral-Spiral-Curve-Spiral-Spiral group) entity constrained by a previous entity, spiral1 and spiral2 parameters, two pass through points of... more
AlignmentEntityCollection::AddFloatingSSC (long, double, double, SpiralParamType, double, Autodesk::AutoCAD::Geometry::Point3d, SpiralType) | Adds an AlignmentSSCSS (Spiral-Spiral-Curve-Spiral-Spiral group) entity constrained by a previous entity, spiral1 and spiral2 parameters, radius for circular arc, pass... more


AlignmentEntityCollection::AddFloatingSSC Method (long, double, double, SpiralParamType, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingSSC Method > AlignmentEntityCollection::AddFloatingSSC Method (long, double, double, SpiralParamType, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)
AlignmentEntityCollection::AddFloatingSSC Method (long, double, double, SpiralParamType, Autodesk::AutoCAD::Geometry::Point3d, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)
Collapse All

Adds an AlignmentSSCSS (Spiral-Spiral-Curve-Spiral-Spiral group) entity constrained by a previous entity, spiral1 and spiral2 parameters, two pass through points of the circular arc, and a spiral definition type.

C#
public AlignmentSSCSS AddFloatingSSC(
    long previousEntityId,
    double sp1Param,
    double sp2Param,
    SpiralParamType spType,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint1,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint2,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFloatingSSC(
    previousEntityId As long,
    sp1Param As double,
    sp2Param As double,
    spType As SpiralParamType,
    passThroughPoint1 As Autodesk::AutoCAD::Geometry::Point3d,
    passThroughPoint2 As Autodesk::AutoCAD::Geometry::Point3d,
    spiralDefinition As SpiralType
) As AlignmentSSCSS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
sp1Param | First spiral parameter (length or A-value).
sp2Param | Second spiral parameter (length or A-value).
spType | Specifies the spParam parameters' type.
passThroughPoint1 | First pass-through point of the arc entity (point #1).
passThroughPoint2 | Second pass-through point of the arc entity (point #2).
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFloatingSSC Method (long, double, double, SpiralParamType, double, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFloatingSSC Method > AlignmentEntityCollection::AddFloatingSSC Method (long, double, double, SpiralParamType, double, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)
AlignmentEntityCollection::AddFloatingSSC Method (long, double, double, SpiralParamType, double, Autodesk::AutoCAD::Geometry::Point3d, SpiralType)
Collapse All

Adds an AlignmentSSCSS (Spiral-Spiral-Curve-Spiral-Spiral group) entity constrained by a previous entity, spiral1 and spiral2 parameters, radius for circular arc, pass through point of the circular arc, and a spiral definition type.

C#
public AlignmentSSCSS AddFloatingSSC(
    long previousEntityId,
    double sp1Param,
    double sp2Param,
    SpiralParamType spType,
    double radius,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFloatingSSC(
    previousEntityId As long,
    sp1Param As double,
    sp2Param As double,
    spType As SpiralParamType,
    radius As double,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d,
    spiralDefinition As SpiralType
) As AlignmentSSCSS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
sp1Param | First spiral parameter (length or A-value).
sp2Param | Second spiral parameter (length or A-value).
spType | Specifies the spParam parameters' type.
radius | Radius of the arc entity.
passThroughPoint | Pass-through point of the arc entity.
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFreeCurve Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFreeCurve Method
AddFreeCurve Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFreeCurve (long, long, Autodesk::AutoCAD::Geometry::Point3d) | Creates a free (dependent on two other subentities) AlignmentArc entity defined by a previous entity, a next entity, and a... more
AlignmentEntityCollection::AddFreeCurve (long, long, double, CurveParamType, bool, CurveType) | Creates a free (dependent on two other subentities) arc AlignmentArc defined by a previous entity, a next entity, a constraint... more


AlignmentEntityCollection::AddFreeCurve Method (long, long, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFreeCurve Method > AlignmentEntityCollection::AddFreeCurve Method (long, long, Autodesk::AutoCAD::Geometry::Point3d)
AlignmentEntityCollection::AddFreeCurve Method (long, long, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates a free (dependent on two other subentities) AlignmentArc entity defined by a previous entity, a next entity, and a pass-through point.

C#
public AlignmentArc AddFreeCurve(
    long previousEntityId,
    long nextEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passThroughPoint
);
Visual Basic
Public Function AddFreeCurve(
    previousEntityId As long,
    nextEntityId As long,
    passThroughPoint As Autodesk::AutoCAD::Geometry::Point3d
) As AlignmentArc
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
passThroughPoint | Passthrough point of the AlignmentArc entity.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFreeCurve Method (long, long, double, CurveParamType, bool, CurveType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFreeCurve Method > AlignmentEntityCollection::AddFreeCurve Method (long, long, double, CurveParamType, bool, CurveType)
AlignmentEntityCollection::AddFreeCurve Method (long, long, double, CurveParamType, bool, CurveType)
Collapse All

Creates a free (dependent on two other subentities) arc AlignmentArc defined by a previous entity, a next entity, a constraint type and value, a boolean value specifying whether the curve encompasses more than 180 degrees, and the curve type.

C#
public AlignmentArc AddFreeCurve(
    long previousEntityId,
    long nextEntityId,
    double paramValue,
    CurveParamType paramType,
    bool isGreaterThan180,
    CurveType curveType
);
Visual Basic
Public Function AddFreeCurve(
    previousEntityId As long,
    nextEntityId As long,
    paramValue As double,
    paramType As CurveParamType,
    isGreaterThan180 As bool,
    curveType As CurveType
) As AlignmentArc
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
paramValue | Specifies the curve's constraint value.
paramType | Specifies the curve's constraint type.
isGreaterThan180 | Specifies whether the curve encompasses more than 180 degrees (True) or less than 180 degrees (False).
curveType | Specifies the curve type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFreeLine Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::AddFreeLine Method
AlignmentEntityCollection::AddFreeLine Method
Collapse All

Creates an AlignmentLine entity defined by two successive elements identified by ID.

C#
public AlignmentLine AddFreeLine(
    long previousEntityId,
    long nextEntityId
);
Visual Basic
Public Function AddFreeLine(
    previousEntityId As long,
    nextEntityId As long
) As AlignmentLine
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFreeSCS Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::AddFreeSCS Method
AlignmentEntityCollection::AddFreeSCS Method
Collapse All

Creates a AlignmentSCS (Spiral-Curve-Spiral group) entity defined by a previous entity, a next entity, the 'A' values of two spirals, and the arc radius.

C#
public AlignmentSCS AddFreeSCS(
    long previousEntityId,
    long nextEntityId,
    double spiral1Param,
    double spiral2Param,
    SpiralParamType spType,
    double radius,
    bool isGreaterThan180,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFreeSCS(
    previousEntityId As long,
    nextEntityId As long,
    spiral1Param As double,
    spiral2Param As double,
    spType As SpiralParamType,
    radius As double,
    isGreaterThan180 As bool,
    spiralDefinition As SpiralType
) As AlignmentSCS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
spType | Specifies the first and second spParam parameters' type.
radius | Radius of the arc entity.
isGreaterThan180 | Specifies whether the curve encompasses more than 180 degrees (True) or less than 180 degrees (False).
spiralDefinition | Definition of the spiral.
sp1Param | First spiral parameter (length or A-value).
sp2Param | Second spiral parameter (length or A-value).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFreeSCSCS Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::AddFreeSCSCS Method
AlignmentEntityCollection::AddFreeSCSCS Method
Collapse All

Creates an AlignmentSCSCS (Spiral-Curve-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition type .

C#
public AlignmentSCSCS AddFreeSCSCS(
    long previousEntityId,
    long nextEntityId,
    ref SCSCSConstraints constraintValue,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFreeSCSCS(
    previousEntityId As long,
    nextEntityId As long,
    ByRef constraintValue As SCSCSConstraints,
    spiralDefinition As SpiralType
) As AlignmentSCSCS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
constraintValue | Specifies the entity constraint value.
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFreeSCSSCS Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::AddFreeSCSSCS Method
AlignmentEntityCollection::AddFreeSCSSCS Method
Collapse All

Creates an AlignmentSCSSCS (Spiral-Curve-Spiral-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition type.

C#
public AlignmentSCSSCS AddFreeSCSSCS(
    long previousEntityId,
    long nextEntityId,
    ref SCSSCSConstraints constraintValue,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFreeSCSSCS(
    previousEntityId As long,
    nextEntityId As long,
    ByRef constraintValue As SCSSCSConstraints,
    spiralDefinition As SpiralType
) As AlignmentSCSSCS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
constraintValue | Specifies the entity constraint value.
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFreeSpiral Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::AddFreeSpiral Method
AlignmentEntityCollection::AddFreeSpiral Method
Collapse All

Creates a AlignmentSCS (Spiral-Curve-Spiral group with a curve and a spiral length is 0) entity defined by a previous entity, a next entity, the lengths or A-Value of spiral, and the spiral type and the definition type.

C#
public AlignmentSCS AddFreeSpiral(
    long previousEntityId,
    long nextEntityId,
    double spParam,
    SpiralParamType spType,
    SpiralCurveType spiralCurveType,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFreeSpiral(
    previousEntityId As long,
    nextEntityId As long,
    spParam As double,
    spType As SpiralParamType,
    spiralCurveType As SpiralCurveType,
    spiralDefinition As SpiralType
) As AlignmentSCS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
spParam | Spiral parameter (length or A-value).
spType | Specifies the spParam parameter's type.
spiralCurveType | Specifies the spiral curve type, InCurve or OutCurve.
spiralDefinition | Definition of the spiral.
Remarks

You can use the AlignmentSCS.SpiralIn or AlignmentSCS.SpiralOut to get the real spiral sub-entity we added.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFreeSSBetweenCurves Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::AddFreeSSBetweenCurves Method
AlignmentEntityCollection::AddFreeSSBetweenCurves Method
Collapse All

Adds an AlignmentSTS (Spiral-Line-Spiral group with the line length is 0) entity constrained by the two spiral parameters.

C#
public AlignmentSTS AddFreeSSBetweenCurves(
    long previousEntityId,
    long nextEntityId,
    double spRatio,
    SpiralParamType spType,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFreeSSBetweenCurves(
    previousEntityId As long,
    nextEntityId As long,
    spRatio As double,
    spType As SpiralParamType,
    spiralDefinition As SpiralType
) As AlignmentSTS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
spRatio | Specifies spiral1 and spiral2 ratio (length or A-value) .
spType | Specifies the spRatio parameter's type.
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFreeSSBetweenTangents Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::AddFreeSSBetweenTangents Method
AlignmentEntityCollection::AddFreeSSBetweenTangents Method
Collapse All

Creates a AlignmentSCS (Spiral-Curve-Spiral groupwith the curve length is 0) entity defined by a previous entity, a next entity, the 'A' value or Length of two spirals.

C#
public AlignmentSCS AddFreeSSBetweenTangents(
    long previousEntityId,
    long nextEntityId,
    double spiral1Param,
    double spiral2Param,
    SpiralParamType spType,
    bool isGreaterThan180,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFreeSSBetweenTangents(
    previousEntityId As long,
    nextEntityId As long,
    spiral1Param As double,
    spiral2Param As double,
    spType As SpiralParamType,
    isGreaterThan180 As bool,
    spiralDefinition As SpiralType
) As AlignmentSCS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
spType | Specifies the first and second spParam parameters' type.
isGreaterThan180 | Specifies whether the curve encompasses more than 180 degrees (True) or less than 180 degrees (False).
spiralDefinition | Definition of the spiral.
sp1Param | First spiral parameter (length or A-value).
sp2Param | Second spiral parameter (length or A-value).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AddFreeSTS Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFreeSTS Method
AddFreeSTS Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentEntityCollection::AddFreeSTS (long, long, double, double, SpiralParamType, SpiralType) | Adds an AlignmentSTS (Spiral-Line-Spiral group) entity constrained by the two spiral parameters.
AlignmentEntityCollection::AddFreeSTS (long, long, double, SpiralType) | Adds an AlignmentSTS (Spiral-Line-Spiral) entity constrained by the line length.


AlignmentEntityCollection::AddFreeSTS Method (long, long, double, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFreeSTS Method > AlignmentEntityCollection::AddFreeSTS Method (long, long, double, SpiralType)
AlignmentEntityCollection::AddFreeSTS Method (long, long, double, SpiralType)
Collapse All

Adds an AlignmentSTS (Spiral-Line-Spiral) entity constrained by the line length.

C#
public AlignmentSTS AddFreeSTS(
    long previousEntityId,
    long nextEntityId,
    double tanLength,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFreeSTS(
    previousEntityId As long,
    nextEntityId As long,
    tanLength As double,
    spiralDefinition As SpiralType
) As AlignmentSTS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
tanLength | Length of the line entity.
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::AddFreeSTS Method (long, long, double, double, SpiralParamType, SpiralType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AddFreeSTS Method > AlignmentEntityCollection::AddFreeSTS Method (long, long, double, double, SpiralParamType, SpiralType)
AlignmentEntityCollection::AddFreeSTS Method (long, long, double, double, SpiralParamType, SpiralType)
Collapse All

Adds an AlignmentSTS (Spiral-Line-Spiral group) entity constrained by the two spiral parameters.

C#
public AlignmentSTS AddFreeSTS(
    long previousEntityId,
    long nextEntityId,
    double sp1Param,
    double sp2Param,
    SpiralParamType spType,
    SpiralType spiralDefinition
);
Visual Basic
Public Function AddFreeSTS(
    previousEntityId As long,
    nextEntityId As long,
    sp1Param As double,
    sp2Param As double,
    spType As SpiralParamType,
    spiralDefinition As SpiralType
) As AlignmentSTS
Parameters
Parameters | Description
previousEntityId | Previous entity identifier.
nextEntityId | Next entity identifier.
sp1Param | First spiral parameter (length or A-value).
sp2Param | Second spiral parameter (length or A-value).
spType | Specifies the first and second spParam parameters' type.
spiralDefinition | Specifies the spiral definition type.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::Clear Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::Clear Method
AlignmentEntityCollection::Clear Method
Collapse All

Removes all alignment entities from the collection.

C#
public Clear();
Visual Basic
Public Sub Clear()
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::EntityAtId Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::EntityAtId Method
AlignmentEntityCollection::EntityAtId Method
Collapse All

Returns the AlignmentEntity specified by ID.

C#
public AlignmentEntity EntityAtId(
    long id
);
Visual Basic
Public Function EntityAtId(
    id As long
) As AlignmentEntity
Parameters
Parameters | Description
id | The ID for the AlignmentEntity you want to get.
Exceptions
Exceptions | Description
System::ArgumentException | Throw the alignment entity id is invalid.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::EntityAtStation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::EntityAtStation Method
AlignmentEntityCollection::EntityAtStation Method
Collapse All

Gets the AlignmentEntity at a specified Station in the Alignment.

C#
public AlignmentEntity EntityAtStation(
    double rawStation
);
Visual Basic
Public Function EntityAtStation(
    rawStation As double
) As AlignmentEntity
Parameters
Parameters | Description
rawStation | Raw station
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the rawStation is out of alignment station range.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::GetEntityByOrder Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::GetEntityByOrder Method
AlignmentEntityCollection::GetEntityByOrder Method
Collapse All

Gets an AlignmentEntity at a specified order index along the alignment path. This function behaves like the GUI in that disconnected alignment entities are not considered.

C#
public AlignmentEntity GetEntityByOrder(
    int index
);
Visual Basic
Public Function GetEntityByOrder(
    index As Integer
) As AlignmentEntity
Parameters
Parameters | Description
index | The index at the alignment path, starting from 0
Remarks

This function can only get AlignmentEntity objects that are connected to the alignment. Connected AlignmentEntity objects have stations, super elevations, etc. For example, if you create an alignment which has 3 entities, entity1 and entity2 are connected, but entity3 is disconnected, the function result would be:

ent = entityCollection.GetEntityByOrder(0);  // ent = entity1
ent = entityCollection.GetEntityByOrder(1);  // ent = entity2
ent = entityCollection.GetEntityByOrder(2);  // ArgumentException, entity not found
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of connected alignment entity range.
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::GetEnumerator Method
AlignmentEntityCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<AlignmentEntity^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<AlignmentEntity^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::GetObjectEnumerator Method
AlignmentEntityCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::Remove Method
AlignmentEntityCollection::Remove Method
Collapse All

Removes alignment entity from the collection by the specified entity object.

C#
public Remove(
    ref AlignmentEntity entity
);
Visual Basic
Public Sub Remove(
    ByRef entity As AlignmentEntity
)
Parameters
Parameters | Description
entity | Specifies the entity of the AlignmentEntity to remove.
Exceptions
Exceptions | Description
System::ArgumentException | Throw when the specified entity cannot be found in the collection.
System::InvalidOperationException | Throw when there are other entities depending on it.( floating, free constraints).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods > AlignmentEntityCollection::RemoveAt Method
AlignmentEntityCollection::RemoveAt Method
Collapse All

Removes alignment entity from the collection by the specified index.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Specifies index in the collection to remove.
Exceptions
Exceptions | Description
System::ArgumentException | Throw when the specified entity cannot be found in the collection.
System::InvalidOperationException | Throw when there are other entities depending on it.( floating, free constraints).
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Properties
AlignmentEntityCollection Properties
Collapse All

The properties of AlignmentEntityCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of AlignmentEntity objects in the collection.
default | Gets the AlignmentEntity object at a specified index in the collection.
FirstEntity | Gets the ID of the first AlignmentEntity in the collection.
LastEntity | Gets the ID of the last AlignmentEntity in the collection.
Links
Public Properties


AlignmentEntityCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Properties > AlignmentEntityCollection::Count Property
AlignmentEntityCollection::Count Property
Collapse All

Gets the number of AlignmentEntity objects in the collection.

C#
public long Count;
Visual Basic
Public Property Count() As long
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Properties > AlignmentEntityCollection::default Property
AlignmentEntityCollection::default Property
Collapse All

Gets the AlignmentEntity object at a specified index in the collection.

C#
public AlignmentEntity default;
Visual Basic
Public Property default() As AlignmentEntity
Parameters
Parameters | Description
Index | Alignment entity index.
entity | Returns the alignment entity specified by Index.
Remarks

The returned entity object is an instance of a concrete entity type (e.g. AlignmentEntityArc), which is derived from the abstract class AlignmentEntity.

Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::FirstEntity Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Properties > AlignmentEntityCollection::FirstEntity Property
AlignmentEntityCollection::FirstEntity Property
Collapse All

Gets the ID of the first AlignmentEntity in the collection.

C#
public long FirstEntity;
Visual Basic
Public Property FirstEntity() As long
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentEntityCollection::LastEntity Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Properties > AlignmentEntityCollection::LastEntity Property
AlignmentEntityCollection::LastEntity Property
Collapse All

Gets the ID of the last AlignmentEntity in the collection.

C#
public long LastEntity;
Visual Basic
Public Property LastEntity() As long
Links
AlignmentEntityCollection Class, AlignmentEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentGeometryPointLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class
AlignmentGeometryPointLabelGroup Class
Collapse All

This class encapsulates the functionality to label a geometry point group in an alignment.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentGeometryPointLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentGeomPointLabeling"))]
public class AlignmentGeometryPointLabelGroup : AlignmentLabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentGeomPointLabeling"))>
Public Class AlignmentGeometryPointLabelGroup
Inherits AlignmentLabelGroup
Links
AlignmentGeometryPointLabelGroup Methods, AlignmentGeometryPointLabelGroup Members, Class Hierarchy


AlignmentGeometryPointLabelGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Members
AlignmentGeometryPointLabelGroup Members
Collapse All

The following tables list the members exposed by AlignmentGeometryPointLabelGroup.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentGeometryPointLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentGeometryPointLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector containing the state of all AlignmentPointTypes for the current label.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetGeometryPointsOptions | Sets the state of all AlignmentPointTypes for the current label.
SetRange | Sets both range parameters (start and end) at once.
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentGeometryPointLabelGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Methods
AlignmentGeometryPointLabelGroup Methods
Collapse All

The methods of AlignmentGeometryPointLabelGroup are listed here.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentGeometryPointLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentGeometryPointLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector containing the state of all AlignmentPointTypes for the current label.
SetGeometryPointsOptions | Sets the state of all AlignmentPointTypes for the current label.
Links
Public Methods


AlignmentGeometryPointLabelGroup::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Methods > AlignmentGeometryPointLabelGroup::Create Method
AlignmentGeometryPointLabelGroup::Create Method
Collapse All

Creates a new instance of an AlignmentGeometryPointLabelGroup on an alignment entity with the specified label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId
);
Visual Basic
Public Function Create(
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
styleId | The style of the new AlignmentGeometryPointLabelGroup.
alignmentId | The alignment in which the labelgroup is located.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the styleId or alignmentId is invalid.
Links
AlignmentGeometryPointLabelGroup Class, AlignmentGeometryPointLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentGeometryPointLabelGroup::GetAvailableLabelGroups Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Methods > AlignmentGeometryPointLabelGroup::GetAvailableLabelGroups Method
AlignmentGeometryPointLabelGroup::GetAvailableLabelGroups Method
Collapse All

Returns the ObjectId collection of AlignmentGeometryPointLabelGroup objects on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAvailableLabelGroups(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    bool includeDerived
);
Visual Basic
Public Function GetAvailableLabelGroups(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    includeDerived As bool
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
alignmentId | ObjectId of the alignment where the labels are located.
includeDerived | Indicates whether to include the derived types of the label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when alignmentId is invalid.
Links
AlignmentGeometryPointLabelGroup Class, AlignmentGeometryPointLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentGeometryPointLabelGroup::GetGeometryPointsOptions Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Methods > AlignmentGeometryPointLabelGroup::GetGeometryPointsOptions Method
AlignmentGeometryPointLabelGroup::GetGeometryPointsOptions Method
Collapse All

Gets a GeometryPointSelector containing the state of all AlignmentPointTypes for the current label.

C#
public Autodesk::Civil::Land::GeometryPointSelector<AlignmentPointType> GetGeometryPointsOptions();
Visual Basic
Public Function GetGeometryPointsOptions() As Autodesk::Civil::Land::GeometryPointSelector<AlignmentPointType>
Links
AlignmentGeometryPointLabelGroup Class, AlignmentGeometryPointLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentGeometryPointLabelGroup::SetGeometryPointsOptions Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Methods > AlignmentGeometryPointLabelGroup::SetGeometryPointsOptions Method
AlignmentGeometryPointLabelGroup::SetGeometryPointsOptions Method
Collapse All

Sets the state of all AlignmentPointTypes for the current label.

C#
public SetGeometryPointsOptions(
    ref Autodesk::Civil::Land::GeometryPointSelector<AlignmentPointType> alignmentGeometryPoints
);
Visual Basic
Public Sub SetGeometryPointsOptions(
    ByRef alignmentGeometryPoints As Autodesk::Civil::Land::GeometryPointSelector<AlignmentPointType>
)
Links
AlignmentGeometryPointLabelGroup Class, AlignmentGeometryPointLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class
AlignmentLabelGroup Class
Collapse All

This class represents an alignment label group.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentDesignSpeedLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentGeometryPointLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentPILabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationEquationLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentSuperelevationLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentVerticalGeometryPointLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentLabeling"))]
public class AlignmentLabelGroup : Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentLabeling"))>
Public Class AlignmentLabelGroup
Inherits Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
Links
AlignmentLabelGroup Methods, AlignmentLabelGroup Properties, AlignmentLabelGroup Members, Class Hierarchy


AlignmentLabelGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Members
AlignmentLabelGroup Members
Collapse All

The following tables list the members exposed by AlignmentLabelGroup.

Public Methods
Public Method | Description
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of labels on the alignment of a specified type.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentLabelGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Methods
AlignmentLabelGroup Methods
Collapse All

The methods of AlignmentLabelGroup are listed here.

Public Methods
Public Method | Description
GetAvailableLabelGroups | Returns the ObjectId collection of labels on the alignment of a specified type.
Links
Public Methods


AlignmentLabelGroup::GetAvailableLabelGroups Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Methods > AlignmentLabelGroup::GetAvailableLabelGroups Method
AlignmentLabelGroup::GetAvailableLabelGroups Method
Collapse All

Returns the ObjectId collection of labels on the alignment of a specified type.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAvailableLabelGroups(
    ref Autodesk::AutoCAD::Runtime::RXClass rxClass,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    bool includeDerived
);
Visual Basic
Public Function GetAvailableLabelGroups(
    ByRef rxClass As Autodesk::AutoCAD::Runtime::RXClass,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    includeDerived As bool
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
rxClass | Type of the labels.
alignmentId | ObjectId of the alignment where the labels are located.
includeDerived | Indicates whether to include the derived types of the specified type.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the rxClass or alignmentId is invalid.
Links
AlignmentLabelGroup Class, AlignmentLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLabelGroup Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Properties
AlignmentLabelGroup Properties
Collapse All

The properties of AlignmentLabelGroup are listed here.

Public Properties
Public Property | Description
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
Links
Public Properties


AlignmentLabelGroup::RangeEnd Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Properties > AlignmentLabelGroup::RangeEnd Property
AlignmentLabelGroup::RangeEnd Property
Collapse All

Gets or sets the end of the labeled range.

C#
public double RangeEnd;
Visual Basic
Public Property RangeEnd() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when the input value is outside of alignment limits when setting.
System.InvalidOperationException
Thrown when:

  1. The type of label group is MinorStation.
  2. The RangeEndFromFeature property is set to true when setting.

Links
AlignmentLabelGroup Class, AlignmentLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLabelGroup::RangeEndFromFeature Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Properties > AlignmentLabelGroup::RangeEndFromFeature Property
AlignmentLabelGroup::RangeEndFromFeature Property
Collapse All

Sets whether the range ends at the same value where the feature ends.

C#
public bool RangeEndFromFeature;
Visual Basic
Public Property RangeEndFromFeature() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the type of label group is MinorStation.
Links
AlignmentLabelGroup Class, AlignmentLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLabelGroup::RangeStart Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Properties > AlignmentLabelGroup::RangeStart Property
AlignmentLabelGroup::RangeStart Property
Collapse All

Gets or sets the start of the labeled range.

C#
public double RangeStart;
Visual Basic
Public Property RangeStart() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when the input value is outside of alignment limits when setting.
System.InvalidOperationException
Thrown when:

  1. The type of label group is MinorStation.
  2. The RangeStartFromFeature property is set to true when setting.

Links
AlignmentLabelGroup Class, AlignmentLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLabelGroup::RangeStartFromFeature Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Properties > AlignmentLabelGroup::RangeStartFromFeature Property
AlignmentLabelGroup::RangeStartFromFeature Property
Collapse All

Sets whether the range starts at the same value where the feature starts.

C#
public bool RangeStartFromFeature;
Visual Basic
Public Property RangeStartFromFeature() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the type of label group is MinorStation.
Links
AlignmentLabelGroup Class, AlignmentLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class
AlignmentLine Class
Collapse All

The AlignmentLine class. This class represents an AlignmentEntity made up of a single line subentity.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentLine
C#
public class AlignmentLine : AlignmentCurve;
Visual Basic
Public Class AlignmentLine
Inherits AlignmentCurve
Links
AlignmentLine Properties, AlignmentLine Members, Class Hierarchy


AlignmentLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Members
AlignmentLine Members
Collapse All

The following tables list the members exposed by AlignmentLine.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentLine entity constraint type.
CurveGroupIndex | Gets or sets the AlignmentLine's group index.
CurveGroupSubEntityIndex | Gets or sets the AlignmentLine's group subentity index.
default | Gets a subentity from the AlignmentEntity by index.
Direction | Gets the direction of the AlignmentSubEntityLine.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets or sets the AlignmentLine length.
MidPoint | Gets the AlignmentSubEntityLine middle point coordinate.
PassThroughPoint1 | Gets or sets the AlignmentSubEntityLine first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentSubEntityLine second pass-through point.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Methods, Public Properties


AlignmentLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties
AlignmentLine Properties
Collapse All

The properties of AlignmentLine are listed here.

Public Properties
Public Property | Description
Constraint2 | Gets the AlignmentLine entity constraint type.
CurveGroupIndex | Gets or sets the AlignmentLine's group index.
CurveGroupSubEntityIndex | Gets or sets the AlignmentLine's group subentity index.
default | Gets a subentity from the AlignmentEntity by index.
Direction | Gets the direction of the AlignmentSubEntityLine.
Length | Gets or sets the AlignmentLine length.
MidPoint | Gets the AlignmentSubEntityLine middle point coordinate.
PassThroughPoint1 | Gets or sets the AlignmentSubEntityLine first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentSubEntityLine second pass-through point.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Properties


AlignmentLine::Constraint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::Constraint2 Property
AlignmentLine::Constraint2 Property
Collapse All

Gets the AlignmentLine entity constraint type.

C#
public AlignmentLineConstraintType Constraint2;
Visual Basic
Public Property Constraint2() As AlignmentLineConstraintType
Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine::CurveGroupIndex Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::CurveGroupIndex Property
AlignmentLine::CurveGroupIndex Property
Collapse All

Gets or sets the AlignmentLine's group index.

C#
public System::String CurveGroupIndex;
Visual Basic
Public Property CurveGroupIndex() As System::String
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine::CurveGroupSubEntityIndex Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::CurveGroupSubEntityIndex Property
AlignmentLine::CurveGroupSubEntityIndex Property
Collapse All

Gets or sets the AlignmentLine's group subentity index.

C#
public System::String CurveGroupSubEntityIndex;
Visual Basic
Public Property CurveGroupSubEntityIndex() As System::String
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when

  1. Gets an invalid property value in the entity's constraint type.
  2. Sets an invalid value to the property in the entity's constraint type.
  3. Sets operation is restricted by the entity's constraint type.

Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::default Property
AlignmentLine::default Property
Collapse All

Gets a subentity from the AlignmentEntity by index.

C#
public AlignmentSubEntity default;
Visual Basic
Public Property default() As AlignmentSubEntity
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is 1: greater or equal to the sub-entity count. 2: less than 0.
Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine::Direction Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::Direction Property
AlignmentLine::Direction Property
Collapse All

Gets the direction of the AlignmentSubEntityLine.

C#
public double Direction;
Visual Basic
Public Property Direction() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::Length Property
AlignmentLine::Length Property
Collapse All

Gets or sets the AlignmentLine length.

C#
public double Length;
Visual Basic
Public Property Length() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when

  1. You attempt to set the property to an invalid value according to the entity's constraint type.
  2. The set operation is restricted by the entity's constraint type.

Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine::MidPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::MidPoint Property
AlignmentLine::MidPoint Property
Collapse All

Gets the AlignmentSubEntityLine middle point coordinate.

C#
public Autodesk::AutoCAD::Geometry::Point2d MidPoint;
Visual Basic
Public Property MidPoint() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine::PassThroughPoint1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::PassThroughPoint1 Property
AlignmentLine::PassThroughPoint1 Property
Collapse All

Gets or sets the AlignmentSubEntityLine first pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint1;
Visual Basic
Public Property PassThroughPoint1() As Autodesk::AutoCAD::Geometry::Point2d
Remarks

This property is valid (you can get or set it) when LineConstraint is set to fixed TwoPoint, ThroughPoint (tangent end combined with curve), or BestFitLine (tangent end combined with curve).

Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine::PassThroughPoint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::PassThroughPoint2 Property
AlignmentLine::PassThroughPoint2 Property
Collapse All

Gets or sets the AlignmentSubEntityLine second pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint2;
Visual Basic
Public Property PassThroughPoint2() As Autodesk::AutoCAD::Geometry::Point2d
Remarks

This property is valid (you can get or set it) when LineConstraint is set to fixed TwoPoint, ThroughPoint (tangent start combined with curve), or BestFitLine(tangent start combined with curve).

Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when

  1. The property gets an invalid value according to the entity's constraint type.
  2. You attempt to set the property to an invalid value according to the entity's constraint type.
  3. The set operation is restricted by the entity's constraint type.

Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentLine::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties > AlignmentLine::SubEntityCount Property
AlignmentLine::SubEntityCount Property
Collapse All

Gets the number of subentities that make up the AlignmentEntity.

C#
public int SubEntityCount;
Visual Basic
Public Property SubEntityCount() As Integer
Links
AlignmentLine Class, AlignmentLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentMinorStationLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class
AlignmentMinorStationLabelGroup Class
Collapse All

This class represents an alignment minor station label group.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationLabelGroup
                        Autodesk::Civil::Land::DatabaseServices::AlignmentMinorStationLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentMinorStationLabeling"))]
public class AlignmentMinorStationLabelGroup : AlignmentStationLabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentMinorStationLabeling"))>
Public Class AlignmentMinorStationLabelGroup
Inherits AlignmentStationLabelGroup
Links
AlignmentMinorStationLabelGroup Methods, AlignmentMinorStationLabelGroup Properties, AlignmentMinorStationLabelGroup Members, Class Hierarchy


AlignmentMinorStationLabelGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Members
AlignmentMinorStationLabelGroup Members
Collapse All

The following tables list the members exposed by AlignmentMinorStationLabelGroup.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentMinorStationLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentMinorStationLabelGroup objects on the alignment.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Increment | Gets or sets the increment at which to insert major and minor station labels.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
MajorStationLabelGroup | Gets or Sets the major station label group.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentMinorStationLabelGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Methods
AlignmentMinorStationLabelGroup Methods
Collapse All

The methods of AlignmentMinorStationLabelGroup are listed here.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentMinorStationLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentMinorStationLabelGroup objects on the alignment.
Links
Public Methods


AlignmentMinorStationLabelGroup::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Methods > AlignmentMinorStationLabelGroup::Create Method
AlignmentMinorStationLabelGroup::Create Method
Collapse All

Creates a new instance of an AlignmentMinorStationLabelGroup on an alignment entity with the specified label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId majorStationId,
    double increment
);
Visual Basic
Public Function Create(
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    majorStationId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    increment As double
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
styleId | The style ID of the new AlignmentMinorStationLabelGroup.
majorStationId | ObjectId of major station label group.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the styleId or majorStationId is invalid.
Links
AlignmentMinorStationLabelGroup Class, AlignmentMinorStationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentMinorStationLabelGroup::GetAvailableLabelGroups Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Methods > AlignmentMinorStationLabelGroup::GetAvailableLabelGroups Method
AlignmentMinorStationLabelGroup::GetAvailableLabelGroups Method
Collapse All

Returns the ObjectId collection of AlignmentMinorStationLabelGroup objects on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAvailableLabelGroups(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    bool includeDerived
);
Visual Basic
Public Function GetAvailableLabelGroups(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    includeDerived As bool
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
alignmentId | ObjectId of the alignment where the labels are located.
includeDerived | Indicates whether to include the derived types of the label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the alignmentId is invalid.
Links
AlignmentMinorStationLabelGroup Class, AlignmentMinorStationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentMinorStationLabelGroup Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Properties
AlignmentMinorStationLabelGroup Properties
Collapse All

The properties of AlignmentMinorStationLabelGroup are listed here.

Public Properties
Public Property | Description
MajorStationLabelGroup | Gets or Sets the major station label group.
Links
Public Properties


AlignmentMinorStationLabelGroup::MajorStationLabelGroup Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Properties > AlignmentMinorStationLabelGroup::MajorStationLabelGroup Property
AlignmentMinorStationLabelGroup::MajorStationLabelGroup Property
Collapse All

Gets or Sets the major station label group.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MajorStationLabelGroup;
Visual Basic
Public Property MajorStationLabelGroup() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AlignmentMinorStationLabelGroup Class, AlignmentMinorStationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentPILabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class
AlignmentPILabel Class
Collapse All

This class represents an alignment tangent intersection label.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentPILabel
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentPILabel"))]
public class AlignmentPILabel : Autodesk::Civil::DatabaseServices::FeatureLabel;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentPILabel"))>
Public Class AlignmentPILabel
Inherits Autodesk::Civil::DatabaseServices::FeatureLabel
Links
AlignmentPILabel Methods, AlignmentPILabel Members, Class Hierarchy


AlignmentPILabel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Members
AlignmentPILabel Members
Collapse All

The following tables list the members exposed by AlignmentPILabel.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Overloaded
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentPILabel Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Methods
AlignmentPILabel Methods
Collapse All

The methods of AlignmentPILabel are listed here.

Public Methods
Public Method | Description
Create | Overloaded
Links
Public Methods


Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Methods > Create Method
Create Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentPILabel::Create (AlignmentArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new instance of an AlignmentPILabel on an alignment arc entity with the specified label style in the default... more
AlignmentPILabel::Create (AlignmentLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new instance of an AlignmentPILabel on an alignment tangent in entity with the specified label style in the... more
AlignmentPILabel::Create (AlignmentSCS^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new instance of an AlignmentPILabel on an alignment SCS group entity with the specified label style in the... more


AlignmentPILabel::Create Method (AlignmentArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Methods > Create Method > AlignmentPILabel::Create Method (AlignmentArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
AlignmentPILabel::Create Method (AlignmentArc^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new instance of an AlignmentPILabel on an alignment arc entity with the specified label style in the default layer.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref AlignmentArc arc,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Function Create(
    ByRef arc As AlignmentArc,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
arc | The alignment arc entity in which the label is located.
labelStyleId | The object id of label style for the label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentTangentIntersection.
Links
AlignmentPILabel Class, AlignmentPILabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentPILabel::Create Method (AlignmentLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Methods > Create Method > AlignmentPILabel::Create Method (AlignmentLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
AlignmentPILabel::Create Method (AlignmentLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new instance of an AlignmentPILabel on an alignment tangent in entity with the specified label style in the default layer.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref AlignmentLine tangentIn,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Function Create(
    ByRef tangentIn As AlignmentLine,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
tangentIn | The alignment tangent in entity of the PI.
labelStyleId | The object id of label style for the label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentTangentIntersection.
Links
AlignmentPILabel Class, AlignmentPILabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentPILabel::Create Method (AlignmentSCS^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Methods > Create Method > AlignmentPILabel::Create Method (AlignmentSCS^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
AlignmentPILabel::Create Method (AlignmentSCS^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new instance of an AlignmentPILabel on an alignment SCS group entity with the specified label style in the default layer.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref AlignmentSCS scs,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Function Create(
    ByRef scs As AlignmentSCS,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
scs | The alignment scs group entity in which the label is located.
labelStyleId | The object id of label style for the label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentTangentIntersection.
Links
AlignmentPILabel Class, AlignmentPILabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentPILabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabelGroup Class
AlignmentPILabelGroup Class
Collapse All
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentPILabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentPILabeling"))]
public class AlignmentPILabelGroup : AlignmentLabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentPILabeling"))>
Public Class AlignmentPILabelGroup
Inherits AlignmentLabelGroup
Links
Class Hierarchy


AlignmentRegion Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class
AlignmentRegion Class
Collapse All

Represents a segment of an alignment which uses a single assembly.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentRegion
C#
public class AlignmentRegion : CivilWrapper<AeccDbAlignment>;
Visual Basic
Public Class AlignmentRegion
Inherits CivilWrapper<AeccDbAlignment>
Links
AlignmentRegion Properties, AlignmentRegion Members, Class Hierarchy


AlignmentRegion Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Members
AlignmentRegion Members
Collapse All

The following tables list the members exposed by AlignmentRegion.

Public Properties
Public Property | Description
EndStation | Gets or sets the end station.
Length | Gets or sets the length of region.
OffsetDist | Gets or sets the distance of offset.
RegionType | Gets or sets the type of region.
StartStation | Gets or sets the start station.
Links
Public Properties


AlignmentRegion Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Properties
AlignmentRegion Properties
Collapse All

The properties of AlignmentRegion are listed here.

Public Properties
Public Property | Description
EndStation | Gets or sets the end station.
Length | Gets or sets the length of region.
OffsetDist | Gets or sets the distance of offset.
RegionType | Gets or sets the type of region.
StartStation | Gets or sets the start station.
Links
Public Properties


AlignmentRegion::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Properties > AlignmentRegion::EndStation Property
AlignmentRegion::EndStation Property
Collapse All

Gets or sets the end station.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
AlignmentRegion Class, AlignmentRegion Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentRegion::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Properties > AlignmentRegion::Length Property
AlignmentRegion::Length Property
Collapse All

Gets or sets the length of region.

C#
public double Length;
Visual Basic
Public Property Length() As double
Links
AlignmentRegion Class, AlignmentRegion Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentRegion::OffsetDist Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Properties > AlignmentRegion::OffsetDist Property
AlignmentRegion::OffsetDist Property
Collapse All

Gets or sets the distance of offset.

C#
public double OffsetDist;
Visual Basic
Public Property OffsetDist() As double
Remarks

The set property will not execute the merge operation.

Links
AlignmentRegion Class, AlignmentRegion Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentRegion::RegionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Properties > AlignmentRegion::RegionType Property
AlignmentRegion::RegionType Property
Collapse All

Gets or sets the type of region.

C#
public AlignmentRegionType RegionType;
Visual Basic
Public Property RegionType() As AlignmentRegionType
Links
AlignmentRegion Class, AlignmentRegion Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentRegion::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Properties > AlignmentRegion::StartStation Property
AlignmentRegion::StartStation Property
Collapse All

Gets or sets the start station.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
AlignmentRegion Class, AlignmentRegion Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentRegionCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class
AlignmentRegionCollection Class
Collapse All

A collection of AlignmentRegion objects.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentRegionCollection
C#
public class AlignmentRegionCollection : CivilWrapper<AeccDbAlignment>, System::Collections::Generic::IEnumerable<AlignmentRegion^>;
Visual Basic
Public Class AlignmentRegionCollection
Inherits CivilWrapper<AeccDbAlignment>
Inherits System::Collections::Generic::IEnumerable<AlignmentRegion^>
Links
AlignmentRegionCollection Methods, AlignmentRegionCollection Properties, AlignmentRegionCollection Members, Class Hierarchy


AlignmentRegionCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Members
AlignmentRegionCollection Members
Collapse All

The following tables list the members exposed by AlignmentRegionCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
MergeToNeighborRegion | Merges the specified region to neighbor region.
Public Properties
Public Property | Description
Count | Gets the number of AlignmentRegion objects in the collection.
default | Gets the AlignmentRegion object at a specified index in the collection.
Links
Public Methods, Public Properties


AlignmentRegionCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Methods
AlignmentRegionCollection Methods
Collapse All

The methods of AlignmentRegionCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
MergeToNeighborRegion | Merges the specified region to neighbor region.
Links
Public Methods


AlignmentRegionCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Methods > AlignmentRegionCollection::GetEnumerator Method
AlignmentRegionCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<AlignmentRegion^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<AlignmentRegion^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
AlignmentRegionCollection Class, AlignmentRegionCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentRegionCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Methods > AlignmentRegionCollection::GetObjectEnumerator Method
AlignmentRegionCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
AlignmentRegionCollection Class, AlignmentRegionCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentRegionCollection::MergeToNeighborRegion Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Methods > AlignmentRegionCollection::MergeToNeighborRegion Method
AlignmentRegionCollection::MergeToNeighborRegion Method
Collapse All

Merges the specified region to neighbor region.

C#
public bool MergeToNeighborRegion(
    int index,
    bool preRegion
);
Visual Basic
Public Function MergeToNeighborRegion(
    index As Integer,
    preRegion As bool
) As bool
Parameters
Parameters | Description
index | AlignmentRegion index. And the corresponding region's offset will be changed.
preRegion | Specify whether merge to previous region or next region.
Remarks
  1. When preRegion is false and the input region is the last one, the method won't execute any operation, and still return ture.
  2. When preRegion is true and the input region is the first one, the method won't execute any operation, and still return ture.
  3. It's better to get new Count of this collection after executing this method.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the merged region has no previous or next region, such as turn lane's widening region.
Links
AlignmentRegionCollection Class, AlignmentRegionCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentRegionCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Properties
AlignmentRegionCollection Properties
Collapse All

The properties of AlignmentRegionCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of AlignmentRegion objects in the collection.
default | Gets the AlignmentRegion object at a specified index in the collection.
Links
Public Properties


AlignmentRegionCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Properties > AlignmentRegionCollection::Count Property
AlignmentRegionCollection::Count Property
Collapse All

Gets the number of AlignmentRegion objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
AlignmentRegionCollection Class, AlignmentRegionCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentRegionCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Properties > AlignmentRegionCollection::default Property
AlignmentRegionCollection::default Property
Collapse All

Gets the AlignmentRegion object at a specified index in the collection.

C#
public AlignmentRegion default;
Visual Basic
Public Property default() As AlignmentRegion
Parameters
Parameters | Description
index | AlignmentRegion index.
Links
AlignmentRegionCollection Class, AlignmentRegionCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCS Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class
AlignmentSCS Class
Collapse All

The Alignment SpiralCurveSpiral class. This class represents an AlignmentEntity made up of an in spiral subentity, an arc subentity, and and out spiral subentity.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCS
C#
public class AlignmentSCS : AlignmentCurve;
Visual Basic
Public Class AlignmentSCS
Inherits AlignmentCurve
Links
AlignmentSCS Properties, AlignmentSCS Members, Class Hierarchy


AlignmentSCS Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Members
AlignmentSCS Members
Collapse All

The following tables list the members exposed by AlignmentSCS.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Arc | Gets the arc of the SCS group.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
SpiralIn | Gets the in spiral of the SCS group.
SpiralOut | Gets the out spiral of the SCS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Methods, Public Properties


AlignmentSCS Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Properties
AlignmentSCS Properties
Collapse All

The properties of AlignmentSCS are listed here.

Public Properties
Public Property | Description
Arc | Gets the arc of the SCS group.
Constraint2 | Gets the AlignmentSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
SpiralIn | Gets the in spiral of the SCS group.
SpiralOut | Gets the out spiral of the SCS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Properties


AlignmentSCS::Arc Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Properties > AlignmentSCS::Arc Property
AlignmentSCS::Arc Property
Collapse All

Gets the arc of the SCS group.

C#
public AlignmentSubEntityArc Arc;
Visual Basic
Public Property Arc() As AlignmentSubEntityArc
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::SpiralSpiral.
Links
AlignmentSCS Class, AlignmentSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCS::Constraint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Properties > AlignmentSCS::Constraint2 Property
AlignmentSCS::Constraint2 Property
Collapse All

Gets the AlignmentSCS entity constraint type.

C#
public AlignmentSCSConstraintType Constraint2;
Visual Basic
Public Property Constraint2() As AlignmentSCSConstraintType
Links
AlignmentSCS Class, AlignmentSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCS::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Properties > AlignmentSCS::default Property
AlignmentSCS::default Property
Collapse All

Gets a subentity from the AlignmentEntity by index.

C#
public AlignmentSubEntity default;
Visual Basic
Public Property default() As AlignmentSubEntity
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is 1: greater or equal to the sub-entity count. 2: less than 0.
Links
AlignmentSCS Class, AlignmentSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCS::SpiralIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Properties > AlignmentSCS::SpiralIn Property
AlignmentSCS::SpiralIn Property
Collapse All

Gets the in spiral of the SCS group.

C#
public AlignmentSubEntitySpiral SpiralIn;
Visual Basic
Public Property SpiralIn() As AlignmentSubEntitySpiral
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::CurveSpiral.
Links
AlignmentSCS Class, AlignmentSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCS::SpiralOut Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Properties > AlignmentSCS::SpiralOut Property
AlignmentSCS::SpiralOut Property
Collapse All

Gets the out spiral of the SCS group.

C#
public AlignmentSubEntitySpiral SpiralOut;
Visual Basic
Public Property SpiralOut() As AlignmentSubEntitySpiral
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::SpiralCurve.
Links
AlignmentSCS Class, AlignmentSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCS::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Properties > AlignmentSCS::SubEntityCount Property
AlignmentSCS::SubEntityCount Property
Collapse All

Gets the number of subentities that make up the AlignmentEntity.

C#
public int SubEntityCount;
Visual Basic
Public Property SubEntityCount() As Integer
Links
AlignmentSCS Class, AlignmentSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSCS Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class
AlignmentSCSCS Class
Collapse All

The Alignment SpiralCurveSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an arc, spiral, arc, and out spiral.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCSCS
C#
public class AlignmentSCSCS : AlignmentCurve;
Visual Basic
Public Class AlignmentSCSCS
Inherits AlignmentCurve
Links
AlignmentSCSCS Properties, AlignmentSCSCS Members, Class Hierarchy


AlignmentSCSCS Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Members
AlignmentSCSCS Members
Collapse All

The following tables list the members exposed by AlignmentSCSCS.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Arc1 | Gets the first arc of the SCSCS group.
Arc2 | Gets the second arc of the SCSCS group.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSCSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
Spiral1 | Gets the first spiral of the SCSCS group.
Spiral2 | Gets the second spiral of the SCSCS group.
Spiral3 | Gets the third spiral of the SCSCS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Methods, Public Properties


AlignmentSCSCS Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties
AlignmentSCSCS Properties
Collapse All

The properties of AlignmentSCSCS are listed here.

Public Properties
Public Property | Description
Arc1 | Gets the first arc of the SCSCS group.
Arc2 | Gets the second arc of the SCSCS group.
Constraint2 | Gets the AlignmentSCSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
Spiral1 | Gets the first spiral of the SCSCS group.
Spiral2 | Gets the second spiral of the SCSCS group.
Spiral3 | Gets the third spiral of the SCSCS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Properties


AlignmentSCSCS::Arc1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties > AlignmentSCSCS::Arc1 Property
AlignmentSCSCS::Arc1 Property
Collapse All

Gets the first arc of the SCSCS group.

C#
public AlignmentSubEntityArc Arc1;
Visual Basic
Public Property Arc1() As AlignmentSubEntityArc
Links
AlignmentSCSCS Class, AlignmentSCSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSCS::Arc2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties > AlignmentSCSCS::Arc2 Property
AlignmentSCSCS::Arc2 Property
Collapse All

Gets the second arc of the SCSCS group.

C#
public AlignmentSubEntityArc Arc2;
Visual Basic
Public Property Arc2() As AlignmentSubEntityArc
Links
AlignmentSCSCS Class, AlignmentSCSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSCS::Constraint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties > AlignmentSCSCS::Constraint2 Property
AlignmentSCSCS::Constraint2 Property
Collapse All

Gets the AlignmentSCSCS entity constraint type.

C#
public AlignmentSCSCSConstraintType Constraint2;
Visual Basic
Public Property Constraint2() As AlignmentSCSCSConstraintType
Links
AlignmentSCSCS Class, AlignmentSCSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSCS::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties > AlignmentSCSCS::default Property
AlignmentSCSCS::default Property
Collapse All

Gets a subentity from the AlignmentEntity by index.

C#
public AlignmentSubEntity default;
Visual Basic
Public Property default() As AlignmentSubEntity
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is 1: greater or equal to the sub-entity count. 2: less than 0.
Links
AlignmentSCSCS Class, AlignmentSCSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSCS::Spiral1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties > AlignmentSCSCS::Spiral1 Property
AlignmentSCSCS::Spiral1 Property
Collapse All

Gets the first spiral of the SCSCS group.

C#
public AlignmentSubEntitySpiral Spiral1;
Visual Basic
Public Property Spiral1() As AlignmentSubEntitySpiral
Links
AlignmentSCSCS Class, AlignmentSCSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSCS::Spiral2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties > AlignmentSCSCS::Spiral2 Property
AlignmentSCSCS::Spiral2 Property
Collapse All

Gets the second spiral of the SCSCS group.

C#
public AlignmentSubEntitySpiral Spiral2;
Visual Basic
Public Property Spiral2() As AlignmentSubEntitySpiral
Links
AlignmentSCSCS Class, AlignmentSCSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSCS::Spiral3 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties > AlignmentSCSCS::Spiral3 Property
AlignmentSCSCS::Spiral3 Property
Collapse All

Gets the third spiral of the SCSCS group.

C#
public AlignmentSubEntitySpiral Spiral3;
Visual Basic
Public Property Spiral3() As AlignmentSubEntitySpiral
Links
AlignmentSCSCS Class, AlignmentSCSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSCS::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties > AlignmentSCSCS::SubEntityCount Property
AlignmentSCSCS::SubEntityCount Property
Collapse All

Gets the number of subentities that make up the AlignmentEntity.

C#
public int SubEntityCount;
Visual Basic
Public Property SubEntityCount() As Integer
Links
AlignmentSCSCS Class, AlignmentSCSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSSCS Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class
AlignmentSCSSCS Class
Collapse All

The Alignment SpiralCurveSpiralSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an arc, spiral, spiral, arc, and an out spiral.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCSSCS
C#
public class AlignmentSCSSCS : AlignmentCurve;
Visual Basic
Public Class AlignmentSCSSCS
Inherits AlignmentCurve
Links
AlignmentSCSSCS Properties, AlignmentSCSSCS Members, Class Hierarchy


AlignmentSCSSCS Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Members
AlignmentSCSSCS Members
Collapse All

The following tables list the members exposed by AlignmentSCSSCS.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Arc1 | Gets the first arc of the SCSSCS group.
Arc2 | Gets the second arc of the SCSSCS group.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSCSSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
Spiral1 | Gets the first spiral of the SCSSCS group.
Spiral2 | Gets the second spiral of the SCSSCS group.
Spiral3 | Gets the third spiral of the SCSSCS group.
Spiral4 | Gets the fourth spiral of the SCSSCS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Methods, Public Properties


AlignmentSCSSCS Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties
AlignmentSCSSCS Properties
Collapse All

The properties of AlignmentSCSSCS are listed here.

Public Properties
Public Property | Description
Arc1 | Gets the first arc of the SCSSCS group.
Arc2 | Gets the second arc of the SCSSCS group.
Constraint2 | Gets the AlignmentSCSSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
Spiral1 | Gets the first spiral of the SCSSCS group.
Spiral2 | Gets the second spiral of the SCSSCS group.
Spiral3 | Gets the third spiral of the SCSSCS group.
Spiral4 | Gets the fourth spiral of the SCSSCS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Properties


AlignmentSCSSCS::Arc1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties > AlignmentSCSSCS::Arc1 Property
AlignmentSCSSCS::Arc1 Property
Collapse All

Gets the first arc of the SCSSCS group.

C#
public AlignmentSubEntityArc Arc1;
Visual Basic
Public Property Arc1() As AlignmentSubEntityArc
Links
AlignmentSCSSCS Class, AlignmentSCSSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSSCS::Arc2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties > AlignmentSCSSCS::Arc2 Property
AlignmentSCSSCS::Arc2 Property
Collapse All

Gets the second arc of the SCSSCS group.

C#
public AlignmentSubEntityArc Arc2;
Visual Basic
Public Property Arc2() As AlignmentSubEntityArc
Links
AlignmentSCSSCS Class, AlignmentSCSSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSSCS::Constraint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties > AlignmentSCSSCS::Constraint2 Property
AlignmentSCSSCS::Constraint2 Property
Collapse All

Gets the AlignmentSCSSCS entity constraint type.

C#
public AlignmentSCSSCSConstraintType Constraint2;
Visual Basic
Public Property Constraint2() As AlignmentSCSSCSConstraintType
Links
AlignmentSCSSCS Class, AlignmentSCSSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSSCS::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties > AlignmentSCSSCS::default Property
AlignmentSCSSCS::default Property
Collapse All

Gets a subentity from the AlignmentEntity by index.

C#
public AlignmentSubEntity default;
Visual Basic
Public Property default() As AlignmentSubEntity
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is 1: greater or equal to the sub-entity count. 2: less than 0.
Links
AlignmentSCSSCS Class, AlignmentSCSSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSSCS::Spiral1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties > AlignmentSCSSCS::Spiral1 Property
AlignmentSCSSCS::Spiral1 Property
Collapse All

Gets the first spiral of the SCSSCS group.

C#
public AlignmentSubEntitySpiral Spiral1;
Visual Basic
Public Property Spiral1() As AlignmentSubEntitySpiral
Links
AlignmentSCSSCS Class, AlignmentSCSSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSSCS::Spiral2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties > AlignmentSCSSCS::Spiral2 Property
AlignmentSCSSCS::Spiral2 Property
Collapse All

Gets the second spiral of the SCSSCS group.

C#
public AlignmentSubEntitySpiral Spiral2;
Visual Basic
Public Property Spiral2() As AlignmentSubEntitySpiral
Links
AlignmentSCSSCS Class, AlignmentSCSSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSSCS::Spiral3 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties > AlignmentSCSSCS::Spiral3 Property
AlignmentSCSSCS::Spiral3 Property
Collapse All

Gets the third spiral of the SCSSCS group.

C#
public AlignmentSubEntitySpiral Spiral3;
Visual Basic
Public Property Spiral3() As AlignmentSubEntitySpiral
Links
AlignmentSCSSCS Class, AlignmentSCSSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSSCS::Spiral4 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties > AlignmentSCSSCS::Spiral4 Property
AlignmentSCSSCS::Spiral4 Property
Collapse All

Gets the fourth spiral of the SCSSCS group.

C#
public AlignmentSubEntitySpiral Spiral4;
Visual Basic
Public Property Spiral4() As AlignmentSubEntitySpiral
Links
AlignmentSCSSCS Class, AlignmentSCSSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSCSSCS::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties > AlignmentSCSSCS::SubEntityCount Property
AlignmentSCSSCS::SubEntityCount Property
Collapse All

Gets the number of subentities that make up the AlignmentEntity.

C#
public int SubEntityCount;
Visual Basic
Public Property SubEntityCount() As Integer
Links
AlignmentSCSSCS Class, AlignmentSCSSCS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class
AlignmentSpiral Class
Collapse All

The AlignmentSpiral Class. AlignmentSpiral derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single spiral subentity.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSpiral
C#
public class AlignmentSpiral : AlignmentCurve;
Visual Basic
Public Class AlignmentSpiral
Inherits AlignmentCurve
Links
AlignmentSpiral Properties, AlignmentSpiral Members, Class Hierarchy


AlignmentSpiral Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Members
AlignmentSpiral Members
Collapse All

The following tables list the members exposed by AlignmentSpiral.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
A | Gets the spiral A value.
Compound | Gets the AlignmentSpiral entity Simple/Compound Flag.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSpiral entity constraint type.
CurveGroupIndex | Gets the AlignmentSpiral entity curve group index string.
CurveGroupSubEntityIndex | Gets the AlignmentSpiral entity curve group subentity index string.
CurveType | Gets the AlignmentSpiral entity Incurve/Outcurve type.
default | Gets the subentity of the AlignmentEntity by index.
Delta | Gets the AlignmentSpiral entity curve delta angle.
Direction | Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.
EndDirection | Gets the direction value at the end point.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
K | Gets the spiral K value.
Length | Gets or sets the spiral length.
LongTangent | Gets the spiral long tangent.
MinimumTransitionLength | Gets the minimum transition length according to the design speed check.
P | Gets the spiral P value.
RadialPoint | Gets the AlignmentSpiral subentity radial Point2D coordinate.
RadiusIn | Gets the incoming curve radius.
RadiusOut | Gets the outgoing curve radius.
ShortTangent | Gets the spiral short tangent.
SPIAngle | Gets the AlignmentSpiral entity SPI angle.
SPIPoint | Gets the AlignmentSpiral entity SPI Point2D coordinate.
SpiralDefinition | Gets the AlignmentSpiral entity spiral type.
SPIStation | Gets the AlignmentSpiral entity SPI station.
StartDirection | Gets the direction value at the start point.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities in the AlignmentEntity.
TotalX | Gets the spiral total X value.
TotalY | Gets the spiral total Y value.
Links
Public Methods, Public Properties


AlignmentSpiral Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties
AlignmentSpiral Properties
Collapse All

The properties of AlignmentSpiral are listed here.

Public Properties
Public Property | Description
A | Gets the spiral A value.
Compound | Gets the AlignmentSpiral entity Simple/Compound Flag.
Constraint2 | Gets the AlignmentSpiral entity constraint type.
CurveGroupIndex | Gets the AlignmentSpiral entity curve group index string.
CurveGroupSubEntityIndex | Gets the AlignmentSpiral entity curve group subentity index string.
CurveType | Gets the AlignmentSpiral entity Incurve/Outcurve type.
default | Gets the subentity of the AlignmentEntity by index.
Delta | Gets the AlignmentSpiral entity curve delta angle.
Direction | Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.
EndDirection | Gets the direction value at the end point.
K | Gets the spiral K value.
Length | Gets or sets the spiral length.
LongTangent | Gets the spiral long tangent.
MinimumTransitionLength | Gets the minimum transition length according to the design speed check.
P | Gets the spiral P value.
RadialPoint | Gets the AlignmentSpiral subentity radial Point2D coordinate.
RadiusIn | Gets the incoming curve radius.
RadiusOut | Gets the outgoing curve radius.
ShortTangent | Gets the spiral short tangent.
SPIAngle | Gets the AlignmentSpiral entity SPI angle.
SPIPoint | Gets the AlignmentSpiral entity SPI Point2D coordinate.
SpiralDefinition | Gets the AlignmentSpiral entity spiral type.
SPIStation | Gets the AlignmentSpiral entity SPI station.
StartDirection | Gets the direction value at the start point.
SubEntityCount | Gets the number of subentities in the AlignmentEntity.
TotalX | Gets the spiral total X value.
TotalY | Gets the spiral total Y value.
Links
Public Properties


AlignmentSpiral::A Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::A Property
AlignmentSpiral::A Property
Collapse All

Gets the spiral A value.

C#
public double A;
Visual Basic
Public Property A() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::Compound Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::Compound Property
AlignmentSpiral::Compound Property
Collapse All

Gets the AlignmentSpiral entity Simple/Compound Flag.

C#
public bool Compound;
Visual Basic
Public Property Compound() As bool
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::Constraint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::Constraint2 Property
AlignmentSpiral::Constraint2 Property
Collapse All

Gets the AlignmentSpiral entity constraint type.

C#
public AlignmentSpiralConstraintType Constraint2;
Visual Basic
Public Property Constraint2() As AlignmentSpiralConstraintType
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::CurveGroupIndex Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::CurveGroupIndex Property
AlignmentSpiral::CurveGroupIndex Property
Collapse All

Gets the AlignmentSpiral entity curve group index string.

C#
public System::String CurveGroupIndex;
Visual Basic
Public Property CurveGroupIndex() As System::String
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::CurveGroupSubEntityIndex Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::CurveGroupSubEntityIndex Property
AlignmentSpiral::CurveGroupSubEntityIndex Property
Collapse All

Gets the AlignmentSpiral entity curve group subentity index string.

C#
public System::String CurveGroupSubEntityIndex;
Visual Basic
Public Property CurveGroupSubEntityIndex() As System::String
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::CurveType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::CurveType Property
AlignmentSpiral::CurveType Property
Collapse All

Gets the AlignmentSpiral entity Incurve/Outcurve type.

C#
public SpiralCurveType CurveType;
Visual Basic
Public Property CurveType() As SpiralCurveType
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::default Property
AlignmentSpiral::default Property
Collapse All

Gets the subentity of the AlignmentEntity by index.

C#
public AlignmentSubEntity default;
Visual Basic
Public Property default() As AlignmentSubEntity
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::Delta Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::Delta Property
AlignmentSpiral::Delta Property
Collapse All

Gets the AlignmentSpiral entity curve delta angle.

C#
public double Delta;
Visual Basic
Public Property Delta() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::Direction Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::Direction Property
AlignmentSpiral::Direction Property
Collapse All

Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.

C#
public SpiralDirectionType Direction;
Visual Basic
Public Property Direction() As SpiralDirectionType
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::EndDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::EndDirection Property
AlignmentSpiral::EndDirection Property
Collapse All

Gets the direction value at the end point.

C#
public double EndDirection;
Visual Basic
Public Property EndDirection() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::K Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::K Property
AlignmentSpiral::K Property
Collapse All

Gets the spiral K value.

C#
public double K;
Visual Basic
Public Property K() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::Length Property
AlignmentSpiral::Length Property
Collapse All

Gets or sets the spiral length.

C#
public double Length;
Visual Basic
Public Property Length() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::LongTangent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::LongTangent Property
AlignmentSpiral::LongTangent Property
Collapse All

Gets the spiral long tangent.

C#
public double LongTangent;
Visual Basic
Public Property LongTangent() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::MinimumTransitionLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::MinimumTransitionLength Property
AlignmentSpiral::MinimumTransitionLength Property
Collapse All

Gets the minimum transition length according to the design speed check.

C#
public double MinimumTransitionLength;
Visual Basic
Public Property MinimumTransitionLength() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::P Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::P Property
AlignmentSpiral::P Property
Collapse All

Gets the spiral P value.

C#
public double P;
Visual Basic
Public Property P() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::RadialPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::RadialPoint Property
AlignmentSpiral::RadialPoint Property
Collapse All

Gets the AlignmentSpiral subentity radial Point2D coordinate.

C#
public Autodesk::AutoCAD::Geometry::Point2d RadialPoint;
Visual Basic
Public Property RadialPoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::RadiusIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::RadiusIn Property
AlignmentSpiral::RadiusIn Property
Collapse All

Gets the incoming curve radius.

C#
public double RadiusIn;
Visual Basic
Public Property RadiusIn() As double
Remarks

The radius is in radians.

Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::RadiusOut Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::RadiusOut Property
AlignmentSpiral::RadiusOut Property
Collapse All

Gets the outgoing curve radius.

C#
public double RadiusOut;
Visual Basic
Public Property RadiusOut() As double
Remarks

The radius is in radians.

Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::ShortTangent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::ShortTangent Property
AlignmentSpiral::ShortTangent Property
Collapse All

Gets the spiral short tangent.

C#
public double ShortTangent;
Visual Basic
Public Property ShortTangent() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::SPIAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::SPIAngle Property
AlignmentSpiral::SPIAngle Property
Collapse All

Gets the AlignmentSpiral entity SPI angle.

C#
public double SPIAngle;
Visual Basic
Public Property SPIAngle() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::SPIPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::SPIPoint Property
AlignmentSpiral::SPIPoint Property
Collapse All

Gets the AlignmentSpiral entity SPI Point2D coordinate.

C#
public Autodesk::AutoCAD::Geometry::Point2d SPIPoint;
Visual Basic
Public Property SPIPoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::SpiralDefinition Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::SpiralDefinition Property
AlignmentSpiral::SpiralDefinition Property
Collapse All

Gets the AlignmentSpiral entity spiral type.

C#
public SpiralType SpiralDefinition;
Visual Basic
Public Property SpiralDefinition() As SpiralType
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::SPIStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::SPIStation Property
AlignmentSpiral::SPIStation Property
Collapse All

Gets the AlignmentSpiral entity SPI station.

C#
public double SPIStation;
Visual Basic
Public Property SPIStation() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::StartDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::StartDirection Property
AlignmentSpiral::StartDirection Property
Collapse All

Gets the direction value at the start point.

C#
public double StartDirection;
Visual Basic
Public Property StartDirection() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::SubEntityCount Property
AlignmentSpiral::SubEntityCount Property
Collapse All

Gets the number of subentities in the AlignmentEntity.

C#
public int SubEntityCount;
Visual Basic
Public Property SubEntityCount() As Integer
Remarks

For AlignmentSpiral objects, this property is always 5.

Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::TotalX Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::TotalX Property
AlignmentSpiral::TotalX Property
Collapse All

Gets the spiral total X value.

C#
public double TotalX;
Visual Basic
Public Property TotalX() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiral::TotalY Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties > AlignmentSpiral::TotalY Property
AlignmentSpiral::TotalY Property
Collapse All

Gets the spiral total Y value.

C#
public double TotalY;
Visual Basic
Public Property TotalY() As double
Links
AlignmentSpiral Class, AlignmentSpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiralLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class
AlignmentSpiralLabel Class
Collapse All

This class represents an alignment spiral label.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentSpiralLabel
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentSpiralLabel"))]
public class AlignmentSpiralLabel : Autodesk::Civil::DatabaseServices::FeatureLabel;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentSpiralLabel"))>
Public Class AlignmentSpiralLabel
Inherits Autodesk::Civil::DatabaseServices::FeatureLabel
Links
AlignmentSpiralLabel Methods, AlignmentSpiralLabel Members, Class Hierarchy


AlignmentSpiralLabel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Members
AlignmentSpiralLabel Members
Collapse All

The following tables list the members exposed by AlignmentSpiralLabel.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Overloaded
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentSpiralLabel Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Methods
AlignmentSpiralLabel Methods
Collapse All

The methods of AlignmentSpiralLabel are listed here.

Public Methods
Public Method | Description
Create | Overloaded
Links
Public Methods


Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Methods > Create Method
Create Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentSpiralLabel::Create (AlignmentSpiral^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new instance of an AlignmentSpiralLabel an alignment spiral entity with the specified label style in the default layer.... more
AlignmentSpiralLabel::Create (AlignmentSubEntitySpiral^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new instance of an AlignmentSpiralLabel an alignment spiral sub-entity with the specified label style in the default layer.... more


AlignmentSpiralLabel::Create Method (AlignmentSpiral^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Methods > Create Method > AlignmentSpiralLabel::Create Method (AlignmentSpiral^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
AlignmentSpiralLabel::Create Method (AlignmentSpiral^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new instance of an AlignmentSpiralLabel an alignment spiral entity with the specified label style in the default layer.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref AlignmentSpiral entitySpiral,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Function Create(
    ByRef entitySpiral As AlignmentSpiral,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
entitySpiral | The alignment entity in which the label is located.
labelStyleId | The object id of label style for the label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentSpiral.
Links
AlignmentSpiralLabel Class, AlignmentSpiralLabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSpiralLabel::Create Method (AlignmentSubEntitySpiral^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Methods > Create Method > AlignmentSpiralLabel::Create Method (AlignmentSubEntitySpiral^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
AlignmentSpiralLabel::Create Method (AlignmentSubEntitySpiral^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new instance of an AlignmentSpiralLabel an alignment spiral sub-entity with the specified label style in the default layer.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref AlignmentSubEntitySpiral subEntitySpiral,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Function Create(
    ByRef subEntitySpiral As AlignmentSubEntitySpiral,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
subEntitySpiral | The alignment sub-entity in which the label is located.
labelStyleId | The object id of label style for the label.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentSpiral.
Links
AlignmentSpiralLabel Class, AlignmentSpiralLabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSSCSS Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class
AlignmentSSCSS Class
Collapse All

The Alignment SpiralSpiralCurveSpiralSpiral class. This class represents an AlignmentEntity made up of the following subentities: spiral, spiral, arc, spiral, spiral.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSSCSS
C#
public class AlignmentSSCSS : AlignmentCurve;
Visual Basic
Public Class AlignmentSSCSS
Inherits AlignmentCurve
Links
AlignmentSSCSS Properties, AlignmentSSCSS Members, Class Hierarchy


AlignmentSSCSS Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Members
AlignmentSSCSS Members
Collapse All

The following tables list the members exposed by AlignmentSSCSS.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Arc | Gets the arc from the SSCSS group.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSSCSS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
Spiral1 | Gets the first spiral from the SSCSS group.
Spiral2 | Gets the second spiral from the SSCSS group.
Spiral3 | Gets the third spiral from the SSCSS group.
Spiral4 | Gets the fourth spiral from the SSCSS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Methods, Public Properties


AlignmentSSCSS Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties
AlignmentSSCSS Properties
Collapse All

The properties of AlignmentSSCSS are listed here.

Public Properties
Public Property | Description
Arc | Gets the arc from the SSCSS group.
Constraint2 | Gets the AlignmentSSCSS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
Spiral1 | Gets the first spiral from the SSCSS group.
Spiral2 | Gets the second spiral from the SSCSS group.
Spiral3 | Gets the third spiral from the SSCSS group.
Spiral4 | Gets the fourth spiral from the SSCSS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Links
Public Properties


AlignmentSSCSS::Arc Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties > AlignmentSSCSS::Arc Property
AlignmentSSCSS::Arc Property
Collapse All

Gets the arc from the SSCSS group.

C#
public AlignmentSubEntityArc Arc;
Visual Basic
Public Property Arc() As AlignmentSubEntityArc
Links
AlignmentSSCSS Class, AlignmentSSCSS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSSCSS::Constraint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties > AlignmentSSCSS::Constraint2 Property
AlignmentSSCSS::Constraint2 Property
Collapse All

Gets the AlignmentSSCSS entity constraint type.

C#
public AlignmentSSCSSConstraintType Constraint2;
Visual Basic
Public Property Constraint2() As AlignmentSSCSSConstraintType
Links
AlignmentSSCSS Class, AlignmentSSCSS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSSCSS::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties > AlignmentSSCSS::default Property
AlignmentSSCSS::default Property
Collapse All

Gets a subentity from the AlignmentEntity by index.

C#
public AlignmentSubEntity default;
Visual Basic
Public Property default() As AlignmentSubEntity
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is 1: greater or equal to the sub-entity count. 2: less than 0.
Links
AlignmentSSCSS Class, AlignmentSSCSS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSSCSS::Spiral1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties > AlignmentSSCSS::Spiral1 Property
AlignmentSSCSS::Spiral1 Property
Collapse All

Gets the first spiral from the SSCSS group.

C#
public AlignmentSubEntitySpiral Spiral1;
Visual Basic
Public Property Spiral1() As AlignmentSubEntitySpiral
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::CurveSpiralSpiral.
Links
AlignmentSSCSS Class, AlignmentSSCSS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSSCSS::Spiral2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties > AlignmentSSCSS::Spiral2 Property
AlignmentSSCSS::Spiral2 Property
Collapse All

Gets the second spiral from the SSCSS group.

C#
public AlignmentSubEntitySpiral Spiral2;
Visual Basic
Public Property Spiral2() As AlignmentSubEntitySpiral
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::CurveSpiralSpiral.
Links
AlignmentSSCSS Class, AlignmentSSCSS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSSCSS::Spiral3 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties > AlignmentSSCSS::Spiral3 Property
AlignmentSSCSS::Spiral3 Property
Collapse All

Gets the third spiral from the SSCSS group.

C#
public AlignmentSubEntitySpiral Spiral3;
Visual Basic
Public Property Spiral3() As AlignmentSubEntitySpiral
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::SpiralSpiralCurve.
Links
AlignmentSSCSS Class, AlignmentSSCSS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSSCSS::Spiral4 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties > AlignmentSSCSS::Spiral4 Property
AlignmentSSCSS::Spiral4 Property
Collapse All

Gets the fourth spiral from the SSCSS group.

C#
public AlignmentSubEntitySpiral Spiral4;
Visual Basic
Public Property Spiral4() As AlignmentSubEntitySpiral
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::SpiralSpiralCurve.
Links
AlignmentSSCSS Class, AlignmentSSCSS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSSCSS::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties > AlignmentSSCSS::SubEntityCount Property
AlignmentSSCSS::SubEntityCount Property
Collapse All

Gets the number of subentities that make up the AlignmentEntity.

C#
public int SubEntityCount;
Visual Basic
Public Property SubEntityCount() As Integer
Links
AlignmentSSCSS Class, AlignmentSSCSS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentStationEquationLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class
AlignmentStationEquationLabelGroup Class
Collapse All

This class represents an alignment station equation label group.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationEquationLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentStaEquLabeling"))]
public class AlignmentStationEquationLabelGroup : AlignmentLabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentStaEquLabeling"))>
Public Class AlignmentStationEquationLabelGroup
Inherits AlignmentLabelGroup
Links
AlignmentStationEquationLabelGroup Methods, AlignmentStationEquationLabelGroup Members, Class Hierarchy


AlignmentStationEquationLabelGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Members
AlignmentStationEquationLabelGroup Members
Collapse All

The following tables list the members exposed by AlignmentStationEquationLabelGroup.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentStationEquationLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentStationEquationLabelGroup obects on the alignment.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentStationEquationLabelGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Methods
AlignmentStationEquationLabelGroup Methods
Collapse All

The methods of AlignmentStationEquationLabelGroup are listed here.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentStationEquationLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentStationEquationLabelGroup obects on the alignment.
Links
Public Methods


AlignmentStationEquationLabelGroup::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Methods > AlignmentStationEquationLabelGroup::Create Method
AlignmentStationEquationLabelGroup::Create Method
Collapse All

Creates a new instance of an AlignmentStationEquationLabelGroup on an alignment entity with the specified label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId
);
Visual Basic
Public Function Create(
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
styleId | The style of the new AlignmentStationEquationLabelGroup.
alignmentId | The alignment in which the labelgroup is located.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the styleId or alignmentId is invalid.
Links
AlignmentStationEquationLabelGroup Class, AlignmentStationEquationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentStationEquationLabelGroup::GetAvailableLabelGroups Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Methods > AlignmentStationEquationLabelGroup::GetAvailableLabelGroups Method
AlignmentStationEquationLabelGroup::GetAvailableLabelGroups Method
Collapse All

Returns the ObjectId collection of AlignmentStationEquationLabelGroup obects on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAvailableLabelGroups(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    bool includeDerived
);
Visual Basic
Public Function GetAvailableLabelGroups(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    includeDerived As bool
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
alignmentId | ObjectId of the alignment where the labels are located.
includeDerived | Indicates whether to include the derived lable types.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the alignmentId is invalid.
Links
AlignmentStationEquationLabelGroup Class, AlignmentStationEquationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentStationLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class
AlignmentStationLabelGroup Class
Collapse All

This class represents an alignment station label group.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationLabelGroup
                        Autodesk::Civil::Land::DatabaseServices::AlignmentMinorStationLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentStationLabeling"))]
public class AlignmentStationLabelGroup : AlignmentLabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentStationLabeling"))>
Public Class AlignmentStationLabelGroup
Inherits AlignmentLabelGroup
Links
AlignmentStationLabelGroup Methods, AlignmentStationLabelGroup Properties, AlignmentStationLabelGroup Members, Class Hierarchy


AlignmentStationLabelGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Members
AlignmentStationLabelGroup Members
Collapse All

The following tables list the members exposed by AlignmentStationLabelGroup.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentStationLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of the specified label type on the alignment.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Increment | Gets or sets the increment at which to insert major and minor station labels.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentStationLabelGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Methods
AlignmentStationLabelGroup Methods
Collapse All

The methods of AlignmentStationLabelGroup are listed here.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentStationLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of the specified label type on the alignment.
Links
Public Methods


AlignmentStationLabelGroup::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Methods > AlignmentStationLabelGroup::Create Method
AlignmentStationLabelGroup::Create Method
Collapse All

Creates a new instance of an AlignmentStationLabelGroup on an alignment entity with the specified label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double increment
);
Visual Basic
Public Function Create(
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    increment As double
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
styleId | The style of the new AlignmentStationLabelGroup.
alignmentId | The alignment in which the label group is located.
increment | Increment at which to insert major and minor station labels.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the styleId or alignmentId is invalid.
Links
AlignmentStationLabelGroup Class, AlignmentStationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentStationLabelGroup::GetAvailableLabelGroups Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Methods > AlignmentStationLabelGroup::GetAvailableLabelGroups Method
AlignmentStationLabelGroup::GetAvailableLabelGroups Method
Collapse All

Returns the ObjectId collection of the specified label type on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAvailableLabelGroups(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    bool includeDerived
);
Visual Basic
Public Function GetAvailableLabelGroups(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    includeDerived As bool
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
alignmentId | ObjectId of the alignment where the labels are located.
includeDerived | Indicates whether to include the derived label types.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown alignmentId is invalid.
Links
AlignmentStationLabelGroup Class, AlignmentStationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentStationLabelGroup Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Properties
AlignmentStationLabelGroup Properties
Collapse All

The properties of AlignmentStationLabelGroup are listed here.

Public Properties
Public Property | Description
Increment | Gets or sets the increment at which to insert major and minor station labels.
Links
Public Properties


AlignmentStationLabelGroup::Increment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Properties > AlignmentStationLabelGroup::Increment Property
AlignmentStationLabelGroup::Increment Property
Collapse All

Gets or sets the increment at which to insert major and minor station labels.

C#
public double Increment;
Visual Basic
Public Property Increment() As double
Links
AlignmentStationLabelGroup Class, AlignmentStationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSTS Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class
AlignmentSTS Class
Collapse All

The Alignment SpiralTangentSpiral class. This class represents an AlignmentEntity made up of a spiral, then tangent, then spiral subentities.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSTS
C#
public class AlignmentSTS : AlignmentCurve;
Visual Basic
Public Class AlignmentSTS
Inherits AlignmentCurve
Links
AlignmentSTS Properties, AlignmentSTS Members, Class Hierarchy


AlignmentSTS Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Members
AlignmentSTS Members
Collapse All

The following tables list the members exposed by AlignmentSTS.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSTS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
SpiralIn | Gets the in spiral of the STS group.
SpiralOut | Gets the out spiral of the STS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Tangent | Gets the tangent of the STS group.
Links
Public Methods, Public Properties


AlignmentSTS Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Properties
AlignmentSTS Properties
Collapse All

The properties of AlignmentSTS are listed here.

Public Properties
Public Property | Description
Constraint2 | Gets the AlignmentSTS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
SpiralIn | Gets the in spiral of the STS group.
SpiralOut | Gets the out spiral of the STS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Tangent | Gets the tangent of the STS group.
Links
Public Properties


AlignmentSTS::Constraint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Properties > AlignmentSTS::Constraint2 Property
AlignmentSTS::Constraint2 Property
Collapse All

Gets the AlignmentSTS entity constraint type.

C#
public AlignmentSTSConstraintType Constraint2;
Visual Basic
Public Property Constraint2() As AlignmentSTSConstraintType
Links
AlignmentSTS Class, AlignmentSTS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSTS::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Properties > AlignmentSTS::default Property
AlignmentSTS::default Property
Collapse All

Gets a subentity from the AlignmentEntity by index.

C#
public AlignmentSubEntity default;
Visual Basic
Public Property default() As AlignmentSubEntity
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is 1: greater or equal to the sub-entity count. 2: less than 0.
Links
AlignmentSTS Class, AlignmentSTS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSTS::SpiralIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Properties > AlignmentSTS::SpiralIn Property
AlignmentSTS::SpiralIn Property
Collapse All

Gets the in spiral of the STS group.

C#
public AlignmentSubEntitySpiral SpiralIn;
Visual Basic
Public Property SpiralIn() As AlignmentSubEntitySpiral
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::LineSpiral.
Links
AlignmentSTS Class, AlignmentSTS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSTS::SpiralOut Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Properties > AlignmentSTS::SpiralOut Property
AlignmentSTS::SpiralOut Property
Collapse All

Gets the out spiral of the STS group.

C#
public AlignmentSubEntitySpiral SpiralOut;
Visual Basic
Public Property SpiralOut() As AlignmentSubEntitySpiral
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::SpiralLine.
Links
AlignmentSTS Class, AlignmentSTS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSTS::SubEntityCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Properties > AlignmentSTS::SubEntityCount Property
AlignmentSTS::SubEntityCount Property
Collapse All

Gets the number of subentities that make up the AlignmentEntity.

C#
public int SubEntityCount;
Visual Basic
Public Property SubEntityCount() As Integer
Links
AlignmentSTS Class, AlignmentSTS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSTS::Tangent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Properties > AlignmentSTS::Tangent Property
AlignmentSTS::Tangent Property
Collapse All

Gets the tangent of the STS group.

C#
public AlignmentSubEntityLine Tangent;
Visual Basic
Public Property Tangent() As AlignmentSubEntityLine
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the alignment entity type is AlignmentEntityType::SpiralSpiral.
Links
AlignmentSTS Class, AlignmentSTS Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class
AlignmentSubEntity Class
Collapse All

The alignment subentity class. This class represents the basic drawing components that make up an alignment entity.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityArc
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityLine
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntitySpiral
C#
public class AlignmentSubEntity : CivilWrapper<AeccDbAlignment>;
Visual Basic
Public Class AlignmentSubEntity
Inherits CivilWrapper<AeccDbAlignment>
Links
AlignmentSubEntity Methods, AlignmentSubEntity Properties, AlignmentSubEntity Members, Class Hierarchy


AlignmentSubEntity Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Members
AlignmentSubEntity Members
Collapse All

The following tables list the members exposed by AlignmentSubEntity.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
Length | Gets or sets the alignment sub-entity length.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.
Links
Public Methods, Public Properties


AlignmentSubEntity Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Methods
AlignmentSubEntity Methods
Collapse All

The methods of AlignmentSubEntity are listed here.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Links
Public Methods


AlignmentSubEntity::DesignChecks Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Methods > AlignmentSubEntity::DesignChecks Method
AlignmentSubEntity::DesignChecks Method
Collapse All

Gets the collection of applicable design checks.

C#
public System::Collections::ObjectModel::Collection<AlignmentDesignCheck^> DesignChecks();
Visual Basic
Public Function DesignChecks() As System::Collections::ObjectModel::Collection<AlignmentDesignCheck^>
Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity::ValidateDesignCheck Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Methods > AlignmentSubEntity::ValidateDesignCheck Method
AlignmentSubEntity::ValidateDesignCheck Method
Collapse All

Validate a specific design check on this entity.

C#
public bool ValidateDesignCheck(
    ref AlignmentDesignCheck designCheck
);
Visual Basic
Public Function ValidateDesignCheck(
    ByRef designCheck As AlignmentDesignCheck
) As bool
Parameters
Parameters | Description
designCheck | The design check to validate
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the design check type is inconsistent with the alignment sub-entity type.
Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties
AlignmentSubEntity Properties
Collapse All

The properties of AlignmentSubEntity are listed here.

Public Properties
Public Property | Description
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
Length | Gets or sets the alignment sub-entity length.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.
Links
Public Properties


AlignmentSubEntity::CurveGroupIndex Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties > AlignmentSubEntity::CurveGroupIndex Property
AlignmentSubEntity::CurveGroupIndex Property
Collapse All

Gets or sets the alignment sub-entity group index.

C#
public System::String CurveGroupIndex;
Visual Basic
Public Property CurveGroupIndex() As System::String
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity::CurveGroupSubEntityIndex Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties > AlignmentSubEntity::CurveGroupSubEntityIndex Property
AlignmentSubEntity::CurveGroupSubEntityIndex Property
Collapse All

Gets or sets the alignment sub-entity group subentity index.

C#
public System::String CurveGroupSubEntityIndex;
Visual Basic
Public Property CurveGroupSubEntityIndex() As System::String
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity::EndPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties > AlignmentSubEntity::EndPoint Property
AlignmentSubEntity::EndPoint Property
Collapse All

Gets the alignment sub-entity end point coordinate.

C#
public Autodesk::AutoCAD::Geometry::Point2d EndPoint;
Visual Basic
Public Property EndPoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties > AlignmentSubEntity::EndStation Property
AlignmentSubEntity::EndStation Property
Collapse All

Gets the alignment sub-entity ending station.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties > AlignmentSubEntity::Length Property
AlignmentSubEntity::Length Property
Collapse All

Gets or sets the alignment sub-entity length.

C#
public double Length;
Visual Basic
Public Property Length() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity::StartPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties > AlignmentSubEntity::StartPoint Property
AlignmentSubEntity::StartPoint Property
Collapse All

Gets the alignment sub-entity start point coordinate.

C#
public Autodesk::AutoCAD::Geometry::Point2d StartPoint;
Visual Basic
Public Property StartPoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties > AlignmentSubEntity::StartStation Property
AlignmentSubEntity::StartStation Property
Collapse All

Gets the alignment sub-entity starting station.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntity::SubEntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties > AlignmentSubEntity::SubEntityType Property
AlignmentSubEntity::SubEntityType Property
Collapse All

Gets the alignment sub-entity type.

C#
public AlignmentSubEntityType SubEntityType;
Visual Basic
Public Property SubEntityType() As AlignmentSubEntityType
Links
AlignmentSubEntity Class, AlignmentSubEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class
AlignmentSubEntityArc Class
Collapse All

The Alignment arc subentity class.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityArc
C#
public class AlignmentSubEntityArc : AlignmentSubEntity;
Visual Basic
Public Class AlignmentSubEntityArc
Inherits AlignmentSubEntity
Links
AlignmentSubEntityArc Properties, AlignmentSubEntityArc Members, Class Hierarchy


AlignmentSubEntityArc Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Members
AlignmentSubEntityArc Members
Collapse All

The following tables list the members exposed by AlignmentSubEntityArc.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
CenterPoint | Gets or sets the arc's center point.
ChordDirection | Gets the arc's chord direction.
ChordLength | Gets or sets the arc's chord length.
Clockwise | Gets a bool value that specifies whether the curve entity is clockwise.
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
DeflectedAngle | Gets or sets the arc's deflected angle.
Delta | Gets or sets the arc's delta.
DirectionAtPoint1 | Gets or sets the arc's direction at point1.
DirectionAtPoint2 | Gets the arc's direction at point2.
EndDirection | Gets the arc's end direction.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
ExternalSecant | Gets or sets the arc's external secant.
ExternalTangent | Gets or sets the arc's external tangent.
GreaterThan180 | Gets or sets a bool value that indicates whether the arc solution angle is greather than 180 Degrees.
Length | Gets or sets the alignment sub-entity length.
MidOrdinate | Gets or sets the arc's mid ordinate.
MinimumRadius | Gets the minimum radius according to the design speed check.
PassThroughPoint1 | Gets or sets the arc's first pass-through point.
PassThroughPoint2 | Gets or sets the arc's second pass-through point.
PassThroughPoint3 | Gets or sets the arc's third pass-through point.
PIPoint | Gets the arc's PI point.
PIStation | Gets the arc's PI station.
Radius | Gets or sets the arc's radius.
ReverseCurve | Gets a bool value that specifies whether the curve entity is a reverse curve.
StartDirection | Gets the arc's start direction.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.
Links
Public Methods, Public Properties


AlignmentSubEntityArc Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties
AlignmentSubEntityArc Properties
Collapse All

The properties of AlignmentSubEntityArc are listed here.

Public Properties
Public Property | Description
CenterPoint | Gets or sets the arc's center point.
ChordDirection | Gets the arc's chord direction.
ChordLength | Gets or sets the arc's chord length.
Clockwise | Gets a bool value that specifies whether the curve entity is clockwise.
DeflectedAngle | Gets or sets the arc's deflected angle.
Delta | Gets or sets the arc's delta.
DirectionAtPoint1 | Gets or sets the arc's direction at point1.
DirectionAtPoint2 | Gets the arc's direction at point2.
EndDirection | Gets the arc's end direction.
ExternalSecant | Gets or sets the arc's external secant.
ExternalTangent | Gets or sets the arc's external tangent.
GreaterThan180 | Gets or sets a bool value that indicates whether the arc solution angle is greather than 180 Degrees.
MidOrdinate | Gets or sets the arc's mid ordinate.
MinimumRadius | Gets the minimum radius according to the design speed check.
PassThroughPoint1 | Gets or sets the arc's first pass-through point.
PassThroughPoint2 | Gets or sets the arc's second pass-through point.
PassThroughPoint3 | Gets or sets the arc's third pass-through point.
PIPoint | Gets the arc's PI point.
PIStation | Gets the arc's PI station.
Radius | Gets or sets the arc's radius.
ReverseCurve | Gets a bool value that specifies whether the curve entity is a reverse curve.
StartDirection | Gets the arc's start direction.
SubEntityType | Gets the alignment sub-entity type.
Links
Public Properties


AlignmentSubEntityArc::CenterPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::CenterPoint Property
AlignmentSubEntityArc::CenterPoint Property
Collapse All

Gets or sets the arc's center point.

C#
public Autodesk::AutoCAD::Geometry::Point2d CenterPoint;
Visual Basic
Public Property CenterPoint() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::ChordDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::ChordDirection Property
AlignmentSubEntityArc::ChordDirection Property
Collapse All

Gets the arc's chord direction.

C#
public double ChordDirection;
Visual Basic
Public Property ChordDirection() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::ChordLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::ChordLength Property
AlignmentSubEntityArc::ChordLength Property
Collapse All

Gets or sets the arc's chord length.

C#
public double ChordLength;
Visual Basic
Public Property ChordLength() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::Clockwise Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::Clockwise Property
AlignmentSubEntityArc::Clockwise Property
Collapse All

Gets a bool value that specifies whether the curve entity is clockwise.

C#
public bool Clockwise;
Visual Basic
Public Property Clockwise() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::DeflectedAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::DeflectedAngle Property
AlignmentSubEntityArc::DeflectedAngle Property
Collapse All

Gets or sets the arc's deflected angle.

C#
public double DeflectedAngle;
Visual Basic
Public Property DeflectedAngle() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::Delta Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::Delta Property
AlignmentSubEntityArc::Delta Property
Collapse All

Gets or sets the arc's delta.

C#
public double Delta;
Visual Basic
Public Property Delta() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::DirectionAtPoint1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::DirectionAtPoint1 Property
AlignmentSubEntityArc::DirectionAtPoint1 Property
Collapse All

Gets or sets the arc's direction at point1.

C#
public double DirectionAtPoint1;
Visual Basic
Public Property DirectionAtPoint1() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::DirectionAtPoint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::DirectionAtPoint2 Property
AlignmentSubEntityArc::DirectionAtPoint2 Property
Collapse All

Gets the arc's direction at point2.

C#
public double DirectionAtPoint2;
Visual Basic
Public Property DirectionAtPoint2() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::EndDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::EndDirection Property
AlignmentSubEntityArc::EndDirection Property
Collapse All

Gets the arc's end direction.

C#
public double EndDirection;
Visual Basic
Public Property EndDirection() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::ExternalSecant Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::ExternalSecant Property
AlignmentSubEntityArc::ExternalSecant Property
Collapse All

Gets or sets the arc's external secant.

C#
public double ExternalSecant;
Visual Basic
Public Property ExternalSecant() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::ExternalTangent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::ExternalTangent Property
AlignmentSubEntityArc::ExternalTangent Property
Collapse All

Gets or sets the arc's external tangent.

C#
public double ExternalTangent;
Visual Basic
Public Property ExternalTangent() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::GreaterThan180 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::GreaterThan180 Property
AlignmentSubEntityArc::GreaterThan180 Property
Collapse All

Gets or sets a bool value that indicates whether the arc solution angle is greather than 180 Degrees.

C#
public bool GreaterThan180;
Visual Basic
Public Property GreaterThan180() As bool
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::MidOrdinate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::MidOrdinate Property
AlignmentSubEntityArc::MidOrdinate Property
Collapse All

Gets or sets the arc's mid ordinate.

C#
public double MidOrdinate;
Visual Basic
Public Property MidOrdinate() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::MinimumRadius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::MinimumRadius Property
AlignmentSubEntityArc::MinimumRadius Property
Collapse All

Gets the minimum radius according to the design speed check.

C#
public double MinimumRadius;
Visual Basic
Public Property MinimumRadius() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::PassThroughPoint1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::PassThroughPoint1 Property
AlignmentSubEntityArc::PassThroughPoint1 Property
Collapse All

Gets or sets the arc's first pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint1;
Visual Basic
Public Property PassThroughPoint1() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::PassThroughPoint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::PassThroughPoint2 Property
AlignmentSubEntityArc::PassThroughPoint2 Property
Collapse All

Gets or sets the arc's second pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint2;
Visual Basic
Public Property PassThroughPoint2() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::PassThroughPoint3 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::PassThroughPoint3 Property
AlignmentSubEntityArc::PassThroughPoint3 Property
Collapse All

Gets or sets the arc's third pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint3;
Visual Basic
Public Property PassThroughPoint3() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::PIPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::PIPoint Property
AlignmentSubEntityArc::PIPoint Property
Collapse All

Gets the arc's PI point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PIPoint;
Visual Basic
Public Property PIPoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::PIStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::PIStation Property
AlignmentSubEntityArc::PIStation Property
Collapse All

Gets the arc's PI station.

C#
public double PIStation;
Visual Basic
Public Property PIStation() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::Radius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::Radius Property
AlignmentSubEntityArc::Radius Property
Collapse All

Gets or sets the arc's radius.

C#
public double Radius;
Visual Basic
Public Property Radius() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::ReverseCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::ReverseCurve Property
AlignmentSubEntityArc::ReverseCurve Property
Collapse All

Gets a bool value that specifies whether the curve entity is a reverse curve.

C#
public bool ReverseCurve;
Visual Basic
Public Property ReverseCurve() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::StartDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::StartDirection Property
AlignmentSubEntityArc::StartDirection Property
Collapse All

Gets the arc's start direction.

C#
public double StartDirection;
Visual Basic
Public Property StartDirection() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityArc::SubEntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties > AlignmentSubEntityArc::SubEntityType Property
AlignmentSubEntityArc::SubEntityType Property
Collapse All

Gets the alignment sub-entity type.

C#
public AlignmentSubEntityType SubEntityType;
Visual Basic
Public Property SubEntityType() As AlignmentSubEntityType
Links
AlignmentSubEntityArc Class, AlignmentSubEntityArc Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class
AlignmentSubEntityLine Class
Collapse All

The AlignmentSubEntityLine class. This class represents the line object in AlignmentEntity objects.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityLine
C#
public class AlignmentSubEntityLine : AlignmentSubEntity;
Visual Basic
Public Class AlignmentSubEntityLine
Inherits AlignmentSubEntity
Links
AlignmentSubEntityLine Properties, AlignmentSubEntityLine Members, Class Hierarchy


AlignmentSubEntityLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Members
AlignmentSubEntityLine Members
Collapse All

The following tables list the members exposed by AlignmentSubEntityLine.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
Direction | Gets the direction of AlignmentSubEntityLine.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
Length | Gets or sets the alignment sub-entity length.
MidPoint | Gets the AlignmentSubEntityLine middle point coordinate.
PassThroughPoint1 | Gets or sets the AlignmentSubEntityLine first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentSubEntityLine second pass-through point.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.
Links
Public Methods, Public Properties


AlignmentSubEntityLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Properties
AlignmentSubEntityLine Properties
Collapse All

The properties of AlignmentSubEntityLine are listed here.

Public Properties
Public Property | Description
Direction | Gets the direction of AlignmentSubEntityLine.
MidPoint | Gets the AlignmentSubEntityLine middle point coordinate.
PassThroughPoint1 | Gets or sets the AlignmentSubEntityLine first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentSubEntityLine second pass-through point.
SubEntityType | Gets the alignment sub-entity type.
Links
Public Properties


AlignmentSubEntityLine::Direction Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Properties > AlignmentSubEntityLine::Direction Property
AlignmentSubEntityLine::Direction Property
Collapse All

Gets the direction of AlignmentSubEntityLine.

C#
public double Direction;
Visual Basic
Public Property Direction() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityLine Class, AlignmentSubEntityLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityLine::MidPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Properties > AlignmentSubEntityLine::MidPoint Property
AlignmentSubEntityLine::MidPoint Property
Collapse All

Gets the AlignmentSubEntityLine middle point coordinate.

C#
public Autodesk::AutoCAD::Geometry::Point2d MidPoint;
Visual Basic
Public Property MidPoint() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntityLine Class, AlignmentSubEntityLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityLine::PassThroughPoint1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Properties > AlignmentSubEntityLine::PassThroughPoint1 Property
AlignmentSubEntityLine::PassThroughPoint1 Property
Collapse All

Gets or sets the AlignmentSubEntityLine first pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint1;
Visual Basic
Public Property PassThroughPoint1() As Autodesk::AutoCAD::Geometry::Point2d
Remarks

You can get and set this property when LineConstraint is set to fixed TwoPoint, ThroughPoint (tangent end combine with curve), or BestFitLine(tangent end combine with curve).

Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityLine Class, AlignmentSubEntityLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityLine::PassThroughPoint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Properties > AlignmentSubEntityLine::PassThroughPoint2 Property
AlignmentSubEntityLine::PassThroughPoint2 Property
Collapse All

Gets or sets the AlignmentSubEntityLine second pass-through point.

C#
public Autodesk::AutoCAD::Geometry::Point2d PassThroughPoint2;
Visual Basic
Public Property PassThroughPoint2() As Autodesk::AutoCAD::Geometry::Point2d
Remarks

You can get and set this property when LineConstraint is set to fixed TwoPoint, ThroughPoint( tangent start combine with curve),BestFitLine( tangent start combine with curve)

Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntityLine Class, AlignmentSubEntityLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntityLine::SubEntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Properties > AlignmentSubEntityLine::SubEntityType Property
AlignmentSubEntityLine::SubEntityType Property
Collapse All

Gets the alignment sub-entity type.

C#
public AlignmentSubEntityType SubEntityType;
Visual Basic
Public Property SubEntityType() As AlignmentSubEntityType
Links
AlignmentSubEntityLine Class, AlignmentSubEntityLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class
AlignmentSubEntitySpiral Class
Collapse All

The Alignment spiral subentity class. This class represents spiral object in AlignmentEntity objects.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntitySpiral
C#
public class AlignmentSubEntitySpiral : AlignmentSubEntity;
Visual Basic
Public Class AlignmentSubEntitySpiral
Inherits AlignmentSubEntity
Links
AlignmentSubEntitySpiral Properties, AlignmentSubEntitySpiral Members, Class Hierarchy


AlignmentSubEntitySpiral Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Members
AlignmentSubEntitySpiral Members
Collapse All

The following tables list the members exposed by AlignmentSubEntitySpiral.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
A | Gets the spiral A value.
Compound | Gets the alignment spiral entity Simple/Compound Flag.
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
CurveType | Gets the alignment spiral entity Incurve/Outcurve type.
Delta | Gets the curve delta angle.
Direction | Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.
EndDirection | Gets the direction value at the end point.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
K | Gets the spiral K value.
Length | Gets or sets the alignment sub-entity length.
LongTangent | Gets the spiral long tangent.
MinimumTransitionLength | Gets the minimum transition length according to the design speed check.
P | Gets the spiral P value.
RadialPoint | Gets the alignment spiral subentity radial Point2D coordinate.
RadiusIn | Gets the incoming curve radius, in radians.
RadiusOut | Gets the outgoing curve radius, in radians.
ShortTangent | Gets the spiral short tangent.
SPIAngle | Gets the alignment spiral entity SPI angle.
SPIPoint | Gets the alignment spiral entity SPI Point2D coordinate.
SpiralDefinition | Gets the alignment spiral entity spiral type.
SPIStation | Gets the alignment spiral entity SPI station.
StartDirection | Gets the direction value at the start point.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.
TotalX | Gets the spiral total X value.
TotalY | Gets the spiral total Y value.
Links
Public Methods, Public Properties


AlignmentSubEntitySpiral Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties
AlignmentSubEntitySpiral Properties
Collapse All

The properties of AlignmentSubEntitySpiral are listed here.

Public Properties
Public Property | Description
A | Gets the spiral A value.
Compound | Gets the alignment spiral entity Simple/Compound Flag.
CurveType | Gets the alignment spiral entity Incurve/Outcurve type.
Delta | Gets the curve delta angle.
Direction | Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.
EndDirection | Gets the direction value at the end point.
K | Gets the spiral K value.
LongTangent | Gets the spiral long tangent.
MinimumTransitionLength | Gets the minimum transition length according to the design speed check.
P | Gets the spiral P value.
RadialPoint | Gets the alignment spiral subentity radial Point2D coordinate.
RadiusIn | Gets the incoming curve radius, in radians.
RadiusOut | Gets the outgoing curve radius, in radians.
ShortTangent | Gets the spiral short tangent.
SPIAngle | Gets the alignment spiral entity SPI angle.
SPIPoint | Gets the alignment spiral entity SPI Point2D coordinate.
SpiralDefinition | Gets the alignment spiral entity spiral type.
SPIStation | Gets the alignment spiral entity SPI station.
StartDirection | Gets the direction value at the start point.
SubEntityType | Gets the alignment sub-entity type.
TotalX | Gets the spiral total X value.
TotalY | Gets the spiral total Y value.
Links
Public Properties


AlignmentSubEntitySpiral::A Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::A Property
AlignmentSubEntitySpiral::A Property
Collapse All

Gets the spiral A value.

C#
public double A;
Visual Basic
Public Property A() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property gets or is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::Compound Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::Compound Property
AlignmentSubEntitySpiral::Compound Property
Collapse All

Gets the alignment spiral entity Simple/Compound Flag.

C#
public bool Compound;
Visual Basic
Public Property Compound() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::CurveType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::CurveType Property
AlignmentSubEntitySpiral::CurveType Property
Collapse All

Gets the alignment spiral entity Incurve/Outcurve type.

C#
public SpiralCurveType CurveType;
Visual Basic
Public Property CurveType() As SpiralCurveType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::Delta Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::Delta Property
AlignmentSubEntitySpiral::Delta Property
Collapse All

Gets the curve delta angle.

C#
public double Delta;
Visual Basic
Public Property Delta() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::Direction Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::Direction Property
AlignmentSubEntitySpiral::Direction Property
Collapse All

Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.

C#
public SpiralDirectionType Direction;
Visual Basic
Public Property Direction() As SpiralDirectionType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::EndDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::EndDirection Property
AlignmentSubEntitySpiral::EndDirection Property
Collapse All

Gets the direction value at the end point.

C#
public double EndDirection;
Visual Basic
Public Property EndDirection() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::K Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::K Property
AlignmentSubEntitySpiral::K Property
Collapse All

Gets the spiral K value.

C#
public double K;
Visual Basic
Public Property K() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::LongTangent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::LongTangent Property
AlignmentSubEntitySpiral::LongTangent Property
Collapse All

Gets the spiral long tangent.

C#
public double LongTangent;
Visual Basic
Public Property LongTangent() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::MinimumTransitionLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::MinimumTransitionLength Property
AlignmentSubEntitySpiral::MinimumTransitionLength Property
Collapse All

Gets the minimum transition length according to the design speed check.

C#
public double MinimumTransitionLength;
Visual Basic
Public Property MinimumTransitionLength() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::P Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::P Property
AlignmentSubEntitySpiral::P Property
Collapse All

Gets the spiral P value.

C#
public double P;
Visual Basic
Public Property P() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::RadialPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::RadialPoint Property
AlignmentSubEntitySpiral::RadialPoint Property
Collapse All

Gets the alignment spiral subentity radial Point2D coordinate.

C#
public Autodesk::AutoCAD::Geometry::Point2d RadialPoint;
Visual Basic
Public Property RadialPoint() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::RadiusIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::RadiusIn Property
AlignmentSubEntitySpiral::RadiusIn Property
Collapse All

Gets the incoming curve radius, in radians.

C#
public double RadiusIn;
Visual Basic
Public Property RadiusIn() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::RadiusOut Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::RadiusOut Property
AlignmentSubEntitySpiral::RadiusOut Property
Collapse All

Gets the outgoing curve radius, in radians.

C#
public double RadiusOut;
Visual Basic
Public Property RadiusOut() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::ShortTangent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::ShortTangent Property
AlignmentSubEntitySpiral::ShortTangent Property
Collapse All

Gets the spiral short tangent.

C#
public double ShortTangent;
Visual Basic
Public Property ShortTangent() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::SPIAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::SPIAngle Property
AlignmentSubEntitySpiral::SPIAngle Property
Collapse All

Gets the alignment spiral entity SPI angle.

C#
public double SPIAngle;
Visual Basic
Public Property SPIAngle() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::SPIPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::SPIPoint Property
AlignmentSubEntitySpiral::SPIPoint Property
Collapse All

Gets the alignment spiral entity SPI Point2D coordinate.

C#
public Autodesk::AutoCAD::Geometry::Point2d SPIPoint;
Visual Basic
Public Property SPIPoint() As Autodesk::AutoCAD::Geometry::Point2d
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::SpiralDefinition Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::SpiralDefinition Property
AlignmentSubEntitySpiral::SpiralDefinition Property
Collapse All

Gets the alignment spiral entity spiral type.

C#
public SpiralType SpiralDefinition;
Visual Basic
Public Property SpiralDefinition() As SpiralType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::SPIStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::SPIStation Property
AlignmentSubEntitySpiral::SPIStation Property
Collapse All

Gets the alignment spiral entity SPI station.

C#
public double SPIStation;
Visual Basic
Public Property SPIStation() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::StartDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::StartDirection Property
AlignmentSubEntitySpiral::StartDirection Property
Collapse All

Gets the direction value at the start point.

C#
public double StartDirection;
Visual Basic
Public Property StartDirection() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::SubEntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::SubEntityType Property
AlignmentSubEntitySpiral::SubEntityType Property
Collapse All

Gets the alignment sub-entity type.

C#
public AlignmentSubEntityType SubEntityType;
Visual Basic
Public Property SubEntityType() As AlignmentSubEntityType
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::TotalX Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::TotalX Property
AlignmentSubEntitySpiral::TotalX Property
Collapse All

Gets the spiral total X value.

C#
public double TotalX;
Visual Basic
Public Property TotalX() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSubEntitySpiral::TotalY Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties > AlignmentSubEntitySpiral::TotalY Property
AlignmentSubEntitySpiral::TotalY Property
Collapse All

Gets the spiral total Y value.

C#
public double TotalY;
Visual Basic
Public Property TotalY() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property gets an invalid value according to the entity's constraint type.
Links
AlignmentSubEntitySpiral Class, AlignmentSubEntitySpiral Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSuperelevationLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class
AlignmentSuperelevationLabelGroup Class
Collapse All

This class encapsulates the functionality of an alignment super-elevation group label.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentSuperelevationLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentSuperelevationLabeling"))]
public class AlignmentSuperelevationLabelGroup : AlignmentLabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentSuperelevationLabeling"))>
Public Class AlignmentSuperelevationLabelGroup
Inherits AlignmentLabelGroup
Links
AlignmentSuperelevationLabelGroup Methods, AlignmentSuperelevationLabelGroup Members, Class Hierarchy


AlignmentSuperelevationLabelGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Members
AlignmentSuperelevationLabelGroup Members
Collapse All

The following tables list the members exposed by AlignmentSuperelevationLabelGroup.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentSuperelevationLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentSuperelevationLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector object containing the state of all SuperelevationPointType objects for the current label.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetGeometryPointsOptions | Sets the state of all SuperelevationPointType objects for the current label.
SetRange | Sets both range parameters (start and end) at once.
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentSuperelevationLabelGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Methods
AlignmentSuperelevationLabelGroup Methods
Collapse All

The methods of AlignmentSuperelevationLabelGroup are listed here.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentSuperelevationLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentSuperelevationLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector object containing the state of all SuperelevationPointType objects for the current label.
SetGeometryPointsOptions | Sets the state of all SuperelevationPointType objects for the current label.
Links
Public Methods


AlignmentSuperelevationLabelGroup::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Methods > AlignmentSuperelevationLabelGroup::Create Method
AlignmentSuperelevationLabelGroup::Create Method
Collapse All

Creates a new instance of an AlignmentSuperelevationLabelGroup on an alignment entity with the specified label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId
);
Visual Basic
Public Function Create(
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
styleId | The style of the new AlignmentSuperelevationLabelGroup.
alignmentId | The alignment in which the label group is located.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the styleId or alignmentId is invalid.
Links
AlignmentSuperelevationLabelGroup Class, AlignmentSuperelevationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSuperelevationLabelGroup::GetAvailableLabelGroups Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Methods > AlignmentSuperelevationLabelGroup::GetAvailableLabelGroups Method
AlignmentSuperelevationLabelGroup::GetAvailableLabelGroups Method
Collapse All

Returns the ObjectId collection of AlignmentSuperelevationLabelGroup objects on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAvailableLabelGroups(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    bool includeDerived
);
Visual Basic
Public Function GetAvailableLabelGroups(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    includeDerived As bool
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
alignmentId | ObjectId of the alignment where the labels are located.
includeDerived | Indicates whether to include derived label types.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when alignmentId is invalid.
Links
AlignmentSuperelevationLabelGroup Class, AlignmentSuperelevationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSuperelevationLabelGroup::GetGeometryPointsOptions Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Methods > AlignmentSuperelevationLabelGroup::GetGeometryPointsOptions Method
AlignmentSuperelevationLabelGroup::GetGeometryPointsOptions Method
Collapse All

Gets a GeometryPointSelector object containing the state of all SuperelevationPointType objects for the current label.

C#
public Autodesk::Civil::Land::GeometryPointSelector<SuperelevationPointType> GetGeometryPointsOptions();
Visual Basic
Public Function GetGeometryPointsOptions() As Autodesk::Civil::Land::GeometryPointSelector<SuperelevationPointType>
Links
AlignmentSuperelevationLabelGroup Class, AlignmentSuperelevationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentSuperelevationLabelGroup::SetGeometryPointsOptions Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Methods > AlignmentSuperelevationLabelGroup::SetGeometryPointsOptions Method
AlignmentSuperelevationLabelGroup::SetGeometryPointsOptions Method
Collapse All

Sets the state of all SuperelevationPointType objects for the current label.

C#
public SetGeometryPointsOptions(
    ref Autodesk::Civil::Land::GeometryPointSelector<SuperelevationPointType> transitionPoints
);
Visual Basic
Public Sub SetGeometryPointsOptions(
    ByRef transitionPoints As Autodesk::Civil::Land::GeometryPointSelector<SuperelevationPointType>
)
Links
AlignmentSuperelevationLabelGroup Class, AlignmentSuperelevationLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTable Class
AlignmentTable Class
Collapse All

The AlignmentTable class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::Land::DatabaseServices::AlignmentTable
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentTable"))]
public class AlignmentTable : Autodesk::Civil::DatabaseServices::Table;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentTable"))>
Public Class AlignmentTable
Inherits Autodesk::Civil::DatabaseServices::Table
Links
Class Hierarchy


AlignmentTangentLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class
AlignmentTangentLabel Class
Collapse All

This class represents an alignment tangent label.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentTangentLabel
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentTangentLabel"))]
public class AlignmentTangentLabel : Autodesk::Civil::DatabaseServices::FeatureLabel;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentTangentLabel"))>
Public Class AlignmentTangentLabel
Inherits Autodesk::Civil::DatabaseServices::FeatureLabel
Links
AlignmentTangentLabel Methods, AlignmentTangentLabel Members, Class Hierarchy


AlignmentTangentLabel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Members
AlignmentTangentLabel Members
Collapse All

The following tables list the members exposed by AlignmentTangentLabel.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Overloaded
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentTangentLabel Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Methods
AlignmentTangentLabel Methods
Collapse All

The methods of AlignmentTangentLabel are listed here.

Public Methods
Public Method | Description
Create | Overloaded
Links
Public Methods


Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Methods > Create Method
Create Method
Collapse All

Overloaded

Overload List
Method | Description
AlignmentTangentLabel::Create (AlignmentLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new instance of an AlignmentTangentLabel on an alignment line entity with the specified label style in the default... more
AlignmentTangentLabel::Create (AlignmentSubEntityLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a new instance of an AlignmentTangentLabel on an alignment line sub-entity with the specified label style in the default... more


AlignmentTangentLabel::Create Method (AlignmentLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Methods > Create Method > AlignmentTangentLabel::Create Method (AlignmentLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
AlignmentTangentLabel::Create Method (AlignmentLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new instance of an AlignmentTangentLabel on an alignment line entity with the specified label style in the default layer.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref AlignmentLine entityLine,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Function Create(
    ByRef entityLine As AlignmentLine,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
entityLine | The alignment entity in which the label is located.
labelStyleId | The object id of label style for the label.
dwg | Destination drawing in which the label is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentLine.
Links
AlignmentTangentLabel Class, AlignmentTangentLabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentTangentLabel::Create Method (AlignmentSubEntityLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Methods > Create Method > AlignmentTangentLabel::Create Method (AlignmentSubEntityLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
AlignmentTangentLabel::Create Method (AlignmentSubEntityLine^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a new instance of an AlignmentTangentLabel on an alignment line sub-entity with the specified label style in the default layer.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref AlignmentSubEntityLine subEntityLine,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId
);
Visual Basic
Public Function Create(
    ByRef subEntityLine As AlignmentSubEntityLine,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
subEntityLine | The alignment sub-entity in which the label is located.
labelStyleId | The object id of label style for the label.
dwg | Destination drawing in which the label is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentLine.
Links
AlignmentTangentLabel Class, AlignmentTangentLabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentVerticalGeometryPointLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class
AlignmentVerticalGeometryPointLabelGroup Class
Collapse All

This class represents an alignment vertical geometry point label group.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentVerticalGeometryPointLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentVAGeomPointLabeling"))]
public class AlignmentVerticalGeometryPointLabelGroup : AlignmentLabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAlignmentVAGeomPointLabeling"))>
Public Class AlignmentVerticalGeometryPointLabelGroup
Inherits AlignmentLabelGroup
Links
AlignmentVerticalGeometryPointLabelGroup Methods, AlignmentVerticalGeometryPointLabelGroup Properties, AlignmentVerticalGeometryPointLabelGroup Members, Class Hierarchy


AlignmentVerticalGeometryPointLabelGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Members
AlignmentVerticalGeometryPointLabelGroup Members
Collapse All

The following tables list the members exposed by AlignmentVerticalGeometryPointLabelGroup.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentVerticalGeometryPointLabelGroup on an alignment entity with the label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the object Id collection of AlignmentVerticalGeometryPointLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector object containing the state of all ProfilePointType objects for the current label.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetGeometryPointsOptions | Sets the state of all ProfilePointType objects for the current label.
SetRange | Sets both range parameters (start and end) at once.
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
VerticalAlignment | Gets or sets the major station label group.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


AlignmentVerticalGeometryPointLabelGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Methods
AlignmentVerticalGeometryPointLabelGroup Methods
Collapse All

The methods of AlignmentVerticalGeometryPointLabelGroup are listed here.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentVerticalGeometryPointLabelGroup on an alignment entity with the label style.
GetAvailableLabelGroups | Returns the object Id collection of AlignmentVerticalGeometryPointLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector object containing the state of all ProfilePointType objects for the current label.
SetGeometryPointsOptions | Sets the state of all ProfilePointType objects for the current label.
Links
Public Methods


AlignmentVerticalGeometryPointLabelGroup::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Methods > AlignmentVerticalGeometryPointLabelGroup::Create Method
AlignmentVerticalGeometryPointLabelGroup::Create Method
Collapse All

Creates a new instance of an AlignmentVerticalGeometryPointLabelGroup on an alignment entity with the label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId verticalAlignmentId
);
Visual Basic
Public Function Create(
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    verticalAlignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
styleId | The style Id of the new AlignmentVerticalGeometryPointLabelGroup.
alignmentId | ObjectId of the alignment .
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the styleId or alignmentId or profileId is invalid.
Links
AlignmentVerticalGeometryPointLabelGroup Class, AlignmentVerticalGeometryPointLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentVerticalGeometryPointLabelGroup::GetAvailableLabelGroups Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Methods > AlignmentVerticalGeometryPointLabelGroup::GetAvailableLabelGroups Method
AlignmentVerticalGeometryPointLabelGroup::GetAvailableLabelGroups Method
Collapse All

Returns the object Id collection of AlignmentVerticalGeometryPointLabelGroup objects on the alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAvailableLabelGroups(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    bool includeDerived
);
Visual Basic
Public Function GetAvailableLabelGroups(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    includeDerived As bool
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
alignmentId | The object Id of the alignment where the labels are located.
includeDerived | Indicates whether to include derived lable types.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when alignmentId is invalid.
Links
AlignmentVerticalGeometryPointLabelGroup Class, AlignmentVerticalGeometryPointLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentVerticalGeometryPointLabelGroup::GetGeometryPointsOptions Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Methods > AlignmentVerticalGeometryPointLabelGroup::GetGeometryPointsOptions Method
AlignmentVerticalGeometryPointLabelGroup::GetGeometryPointsOptions Method
Collapse All

Gets a GeometryPointSelector object containing the state of all ProfilePointType objects for the current label.

C#
public Autodesk::Civil::Land::GeometryPointSelector<ProfilePointType> GetGeometryPointsOptions();
Visual Basic
Public Function GetGeometryPointsOptions() As Autodesk::Civil::Land::GeometryPointSelector<ProfilePointType>
Links
AlignmentVerticalGeometryPointLabelGroup Class, AlignmentVerticalGeometryPointLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentVerticalGeometryPointLabelGroup::SetGeometryPointsOptions Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Methods > AlignmentVerticalGeometryPointLabelGroup::SetGeometryPointsOptions Method
AlignmentVerticalGeometryPointLabelGroup::SetGeometryPointsOptions Method
Collapse All

Sets the state of all ProfilePointType objects for the current label.

C#
public SetGeometryPointsOptions(
    ref Autodesk::Civil::Land::GeometryPointSelector<ProfilePointType> alignmentVerticalGeometryPoints
);
Visual Basic
Public Sub SetGeometryPointsOptions(
    ByRef alignmentVerticalGeometryPoints As Autodesk::Civil::Land::GeometryPointSelector<ProfilePointType>
)
Links
AlignmentVerticalGeometryPointLabelGroup Class, AlignmentVerticalGeometryPointLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


AlignmentVerticalGeometryPointLabelGroup Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Properties
AlignmentVerticalGeometryPointLabelGroup Properties
Collapse All

The properties of AlignmentVerticalGeometryPointLabelGroup are listed here.

Public Properties
Public Property | Description
VerticalAlignment | Gets or sets the major station label group.
Links
Public Properties


AlignmentVerticalGeometryPointLabelGroup::VerticalAlignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Properties > AlignmentVerticalGeometryPointLabelGroup::VerticalAlignment Property
AlignmentVerticalGeometryPointLabelGroup::VerticalAlignment Property
Collapse All

Gets or sets the major station label group.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId VerticalAlignment;
Visual Basic
Public Property VerticalAlignment() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AlignmentVerticalGeometryPointLabelGroup Class, AlignmentVerticalGeometryPointLabelGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeed Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class
DesignSpeed Class
Collapse All

The Alignment DesignSpeed class. Specifies a single design speed used for criteria-based Alignment design.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::DesignSpeed
C#
public class DesignSpeed : CivilWrapper<AeccDbAlignment>;
Visual Basic
Public Class DesignSpeed
Inherits CivilWrapper<AeccDbAlignment>
Example
// Starting at station 0 + 00.00
DesignSpeed myDesignSpeed = myAlignment.DesignSpeeds.Add(0, 45);
myDesignSpeed.Comment = "Straigtaway";
// Starting at station 4 + 30.00
myDesignSpeed = myAlignment.DesignSpeeds.Add(430, 30);
myDesignSpeed.Comment = "Start of curve";
// Starting at station 14 + 27.131 to the end
myDesignSpeed = myAlignment.DesignSpeeds.Add(1427.131, 35);
myDesignSpeed.Comment = "End of curve";
Links
DesignSpeed Properties, DesignSpeed Members, Class Hierarchy


DesignSpeed Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Members
DesignSpeed Members
Collapse All

The following tables list the members exposed by DesignSpeed.

Public Properties
Public Property | Description
Comment | Gets and sets the DesignSpeed comment.
SpeedNumber | Gets the DesignSpeed number.
Station | Gets and sets the DesignSpeed Station.
Value | Gets and sets the DesignSpeed value.
Links
Public Properties


DesignSpeed Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Properties
DesignSpeed Properties
Collapse All

The properties of DesignSpeed are listed here.

Public Properties
Public Property | Description
Comment | Gets and sets the DesignSpeed comment.
SpeedNumber | Gets the DesignSpeed number.
Station | Gets and sets the DesignSpeed Station.
Value | Gets and sets the DesignSpeed value.
Links
Public Properties


DesignSpeed::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Properties > DesignSpeed::Comment Property
DesignSpeed::Comment Property
Collapse All

Gets and sets the DesignSpeed comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
DesignSpeed Class, DesignSpeed Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeed::SpeedNumber Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Properties > DesignSpeed::SpeedNumber Property
DesignSpeed::SpeedNumber Property
Collapse All

Gets the DesignSpeed number.

C#
public long SpeedNumber;
Visual Basic
Public Property SpeedNumber() As long
Links
DesignSpeed Class, DesignSpeed Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeed::Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Properties > DesignSpeed::Station Property
DesignSpeed::Station Property
Collapse All

Gets and sets the DesignSpeed Station.

C#
public double Station;
Visual Basic
Public Property Station() As double
Links
DesignSpeed Class, DesignSpeed Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeed::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Properties > DesignSpeed::Value Property
DesignSpeed::Value Property
Collapse All

Gets and sets the DesignSpeed value.

C#
public double Value;
Visual Basic
Public Property Value() As double
Links
DesignSpeed Class, DesignSpeed Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeedCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class
DesignSpeedCollection Class
Collapse All

A collection of DesignSpeed objects.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::DesignSpeedCollection
C#
public class DesignSpeedCollection : CivilWrapper<AeccDbAlignment>, System::Collections::Generic::IEnumerable<DesignSpeed^>;
Visual Basic
Public Class DesignSpeedCollection
Inherits CivilWrapper<AeccDbAlignment>
Inherits System::Collections::Generic::IEnumerable<DesignSpeed^>
Links
DesignSpeedCollection Methods, DesignSpeedCollection Properties, DesignSpeedCollection Members, Class Hierarchy


DesignSpeedCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Members
DesignSpeedCollection Members
Collapse All

The following tables list the members exposed by DesignSpeedCollection.

Public Methods
Public Method | Description
Add | Adds a DesignSpeed to the collection for the given Station value.
GetDesignSpeed | Gets the DesignSpeed object in the collection by raw Station value.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumertor which can be used to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumertor which can be used to enumerate this... more
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of DesignSpeed objects in the collection.
default | Gets the DesignSpeed at a specified index in the collection.
Links
Public Methods, Public Properties


DesignSpeedCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods
DesignSpeedCollection Methods
Collapse All

The methods of DesignSpeedCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a DesignSpeed to the collection for the given Station value.
GetDesignSpeed | Gets the DesignSpeed object in the collection by raw Station value.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumertor which can be used to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumertor which can be used to enumerate this... more
Remove | Overloaded
Links
Public Methods


DesignSpeedCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods > DesignSpeedCollection::Add Method
DesignSpeedCollection::Add Method
Collapse All

Adds a DesignSpeed to the collection for the given Station value.

C#
public DesignSpeed Add(
    double station,
    double speed
);
Visual Basic
Public Function Add(
    station As double,
    speed As double
) As DesignSpeed
Parameters
Parameters | Description
station | Station value in the design speed collection.
speed | Speed value in the design speed collection.
Links
DesignSpeedCollection Class, DesignSpeedCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeedCollection::GetDesignSpeed Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods > DesignSpeedCollection::GetDesignSpeed Method
DesignSpeedCollection::GetDesignSpeed Method
Collapse All

Gets the DesignSpeed object in the collection by raw Station value.

C#
public DesignSpeed GetDesignSpeed(
    double rawStation
);
Visual Basic
Public Function GetDesignSpeed(
    rawStation As double
) As DesignSpeed
Parameters
Parameters | Description
rawStation | Raw station value.
Links
DesignSpeedCollection Class, DesignSpeedCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeedCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods > DesignSpeedCollection::GetEnumerator Method
DesignSpeedCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumertor which can be used to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<DesignSpeed^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<DesignSpeed^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
DesignSpeedCollection Class, DesignSpeedCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeedCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods > DesignSpeedCollection::GetObjectEnumerator Method
DesignSpeedCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumertor which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
DesignSpeedCollection Class, DesignSpeedCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods > Remove Method
Remove Method
Collapse All

Overloaded

Overload List
Method | Description
DesignSpeedCollection::Remove (double) | Removes a DesignSpeed from the collection by raw Station value.
DesignSpeedCollection::Remove (int) | Removes a DesignSpeed from the collection at the given index.


DesignSpeedCollection::Remove Method (double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods > Remove Method > DesignSpeedCollection::Remove Method (double)
DesignSpeedCollection::Remove Method (double)
Collapse All

Removes a DesignSpeed from the collection by raw Station value.

C#
public Remove(
    double rawStation
);
Visual Basic
Public Sub Remove(
    rawStation As double
)
Parameters
Parameters | Description
rawStation | Raw station value.
Links
DesignSpeedCollection Class, DesignSpeedCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeedCollection::Remove Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods > Remove Method > DesignSpeedCollection::Remove Method (int)
DesignSpeedCollection::Remove Method (int)
Collapse All

Removes a DesignSpeed from the collection at the given index.

C#
public Remove(
    int Index
);
Visual Basic
Public Sub Remove(
    Index As Integer
)
Parameters
Parameters | Description
Index | Index of the DesignSpeed object to remove.
Links
DesignSpeedCollection Class, DesignSpeedCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeedCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Properties
DesignSpeedCollection Properties
Collapse All

The properties of DesignSpeedCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of DesignSpeed objects in the collection.
default | Gets the DesignSpeed at a specified index in the collection.
Links
Public Properties


DesignSpeedCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Properties > DesignSpeedCollection::Count Property
DesignSpeedCollection::Count Property
Collapse All

Gets the number of DesignSpeed objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
DesignSpeedCollection Class, DesignSpeedCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


DesignSpeedCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Properties > DesignSpeedCollection::default Property
DesignSpeedCollection::default Property
Collapse All

Gets the DesignSpeed at a specified index in the collection.

C#
public DesignSpeed default;
Visual Basic
Public Property default() As DesignSpeed
Parameters
Parameters | Description
Index | Index in the design speed collection.
speeds | Returns the DesignSpeed object specified by Index.
Links
DesignSpeedCollection Class, DesignSpeedCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


FeatureLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > FeatureLine Class
FeatureLine Class
Collapse All

A feature line is a connected series of points along a corridor created by joining those points from each assembly that share a particular code. Feature lines are used to build the 3D model of a corridor.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::FeatureLine
            Autodesk::Civil::Survey::DatabaseServices::SurveyFigure
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFeatureLine"))]
public class FeatureLine : Autodesk::Civil::DatabaseServices::Feature;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFeatureLine"))>
Public Class FeatureLine
Inherits Autodesk::Civil::DatabaseServices::Feature
Links
Class Hierarchy


Grading Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Grading Class
Grading Class
Collapse All

The Grading class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Grading
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGrading"))]
public class Grading : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGrading"))>
Public Class Grading
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
Class Hierarchy


GridSurface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > GridSurface Class
GridSurface Class
Collapse All

A surface formed from points that lie on a regular grid.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Surface
        Autodesk::Civil::Land::DatabaseServices::GridSurface
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSurfaceGrid"))]
public class GridSurface : Autodesk::Civil::Land::DatabaseServices::Surface;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSurfaceGrid"))>
Public Class GridSurface
Inherits Autodesk::Civil::Land::DatabaseServices::Surface
Links
Class Hierarchy


MassHaulLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulLine Class
MassHaulLine Class
Collapse All

A line that displays free haul and overhaul volumes in a mass haul view..

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::MassHaulLine
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMassHaulLine"))]
public class MassHaulLine : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMassHaulLine"))>
Public Class MassHaulLine
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
Class Hierarchy


MassHaulView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulView Class
MassHaulView Class
Collapse All

A mass haul diagram view.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
            Autodesk::Civil::Land::DatabaseServices::MassHaulView
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphMassHaulView"))]
public class MassHaulView : Autodesk::Civil::DatabaseServices::Graph;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphMassHaulView"))>
Public Class MassHaulView
Inherits Autodesk::Civil::DatabaseServices::Graph
Links
MassHaulView Properties, MassHaulView Members, Class Hierarchy


MassHaulView Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulView Class > MassHaulView Members
MassHaulView Members
Collapse All

The following tables list the members exposed by MassHaulView.

Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
MassHaulLineId | Gets the ObjectId of the MassHaulLine associated with this view.
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


MassHaulView Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulView Class > MassHaulView Properties
MassHaulView Properties
Collapse All

The properties of MassHaulView are listed here.

Public Properties
Public Property | Description
MassHaulLineId | Gets the ObjectId of the MassHaulLine associated with this view.
Links
Public Properties


MassHaulView::MassHaulLineId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulView Class > MassHaulView Properties > MassHaulView::MassHaulLineId Property
MassHaulView::MassHaulLineId Property
Collapse All

Gets the ObjectId of the MassHaulLine associated with this view.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MassHaulLineId;
Visual Basic
Public Property MassHaulLineId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
MassHaulView Class, MassHaulView Members, Autodesk::Civil::Land::DatabaseServices Namespace


MatchLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MatchLine Class
MatchLine Class
Collapse All

A match line is a straight line that indicate locations in a view frame group where one view frame intersects or matches up with another view frame.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::MatchLine
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMatchLine"))]
public class MatchLine : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMatchLine"))>
Public Class MatchLine
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
MatchLine Properties, MatchLine Members, Class Hierarchy


MatchLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MatchLine Class > MatchLine Members
MatchLine Members
Collapse All

The following tables list the members exposed by MatchLine.

Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GroupId | Gets the object id of the view frame group it belongs to.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


MatchLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MatchLine Class > MatchLine Properties
MatchLine Properties
Collapse All

The properties of MatchLine are listed here.

Public Properties
Public Property | Description
GroupId | Gets the object id of the view frame group it belongs to.
Links
Public Properties


MatchLine::GroupId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MatchLine Class > MatchLine Properties > MatchLine::GroupId Property
MatchLine::GroupId Property
Collapse All

Gets the object id of the view frame group it belongs to.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId GroupId;
Visual Basic
Public Property GroupId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.ViewFrameGroup

Links
MatchLine Class, MatchLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


MaterialSection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MaterialSection Class
MaterialSection Class
Collapse All

The AeccDbMaterialSection wrapper.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Section
            Autodesk::Civil::Land::DatabaseServices::MaterialSection
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMaterialSection"))]
public class MaterialSection : Section;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbMaterialSection"))>
Public Class MaterialSection
Inherits Section
Links
Class Hierarchy


Parcel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Parcel Class
Parcel Class
Collapse All

An object that represents real estate parcels, such as lots in a subdivision, and other features that have closed boundaries (such as bodies of water and soil regions).

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Parcel
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFace"))]
public class Parcel : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFace"))>
Public Class Parcel
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
Class Hierarchy


ParcelSegment Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ParcelSegment Class
ParcelSegment Class
Collapse All

A parcel segment is a line segment, arc, or AutoCAD entity within a site. When parcel segments form a closed region, that region becomes a Parcel.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::ParcelSegment
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLotLine"))]
public class ParcelSegment : Autodesk::Civil::DatabaseServices::Feature;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbLotLine"))>
Public Class ParcelSegment
Inherits Autodesk::Civil::DatabaseServices::Feature
Links
Class Hierarchy


ParcelSegmentTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ParcelSegmentTable Class
ParcelSegmentTable Class
Collapse All

A Table associated with a ParcelSegment.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::Land::DatabaseServices::ParcelSegmentTable
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbParcelSegmentTable"))]
public class ParcelSegmentTable : Autodesk::Civil::DatabaseServices::Table;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbParcelSegmentTable"))>
Public Class ParcelSegmentTable
Inherits Autodesk::Civil::DatabaseServices::Table
Links
Class Hierarchy


ParcelTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ParcelTable Class
ParcelTable Class
Collapse All

A table associated with a Parcel.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::Land::DatabaseServices::ParcelTable
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFaceScheduleTable"))]
public class ParcelTable : Autodesk::Civil::DatabaseServices::Table;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFaceScheduleTable"))>
Public Class ParcelTable
Inherits Autodesk::Civil::DatabaseServices::Table
Links
Class Hierarchy


PointEntity Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class
PointEntity Class
Collapse All

Encapsulates a COGO point object, with associated information such as elevation, marker display styles, etc.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::PointEntity
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbCogoPoint"))]
public class PointEntity : Autodesk::AutoCAD::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbCogoPoint"))>
Public Class PointEntity
Inherits Autodesk::AutoCAD::DatabaseServices::Entity
Links
PointEntity Properties, PointEntity Members, Class Hierarchy


PointEntity Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Members
PointEntity Members
Collapse All

The following tables list the members exposed by PointEntity.

Public Properties
Public Property | Description
DescriptionFormat | Gets or sets the description format string for the point.
FullDescription | Gets an expanded description determined by a description key match.
IsNamed | Check whether this Cogo Point is named.
IsSurveyPoint | Check whether this Cogo Point is Survey Point.
Location | Gets or sets the point location.
PointName | Gets or sets the name of Cogo Point.
PointNumber | Gets or sets the identifying number assigned to the point.
RawDescription | Gets or sets an unexpanded description for the point, which could be the description entered by the surveyor in the... more
Links
Public Properties


PointEntity Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties
PointEntity Properties
Collapse All

The properties of PointEntity are listed here.

Public Properties
Public Property | Description
DescriptionFormat | Gets or sets the description format string for the point.
FullDescription | Gets an expanded description determined by a description key match.
IsNamed | Check whether this Cogo Point is named.
IsSurveyPoint | Check whether this Cogo Point is Survey Point.
Location | Gets or sets the point location.
PointName | Gets or sets the name of Cogo Point.
PointNumber | Gets or sets the identifying number assigned to the point.
RawDescription | Gets or sets an unexpanded description for the point, which could be the description entered by the surveyor in the... more
Links
Public Properties


PointEntity::DescriptionFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties > PointEntity::DescriptionFormat Property
PointEntity::DescriptionFormat Property
Collapse All

Gets or sets the description format string for the point.

C#
public System::String DescriptionFormat;
Visual Basic
Public Property DescriptionFormat() As System::String
Links
PointEntity Class, PointEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


PointEntity::FullDescription Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties > PointEntity::FullDescription Property
PointEntity::FullDescription Property
Collapse All

Gets an expanded description determined by a description key match.

C#
public System::String FullDescription;
Visual Basic
Public Property FullDescription() As System::String
Remarks

If there is no description key match, the full description is the same as the raw description. You cannot edit this field, it can be updated only through description key matching.

Links
PointEntity Class, PointEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


PointEntity::IsNamed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties > PointEntity::IsNamed Property
PointEntity::IsNamed Property
Collapse All

Check whether this Cogo Point is named.

C#
public bool IsNamed;
Visual Basic
Public Property IsNamed() As bool
Remarks

Cogo point could be either named or not named. But once it's named, it can't be changed to unnamed any more.

Links
PointEntity Class, PointEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


PointEntity::IsSurveyPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties > PointEntity::IsSurveyPoint Property
PointEntity::IsSurveyPoint Property
Collapse All

Check whether this Cogo Point is Survey Point.

C#
public bool IsSurveyPoint;
Visual Basic
Public Property IsSurveyPoint() As bool
Links
PointEntity Class, PointEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


PointEntity::Location Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties > PointEntity::Location Property
PointEntity::Location Property
Collapse All

Gets or sets the point location.

C#
public Autodesk::AutoCAD::Geometry::Point3d Location;
Visual Basic
Public Property Location() As Autodesk::AutoCAD::Geometry::Point3d
Links
PointEntity Class, PointEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


PointEntity::PointName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties > PointEntity::PointName Property
PointEntity::PointName Property
Collapse All

Gets or sets the name of Cogo Point.

C#
public System::String PointName;
Visual Basic
Public Property PointName() As System::String
Remarks

To avoid catching exception, PointEntity.IsNamed is suggested to use before calling PointEntity.Name to get name. After set the name, PointEntity.IsNamed will be true for ever.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when get name while IsNamed is false.
Links
PointEntity Class, PointEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


PointEntity::PointNumber Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties > PointEntity::PointNumber Property
PointEntity::PointNumber Property
Collapse All

Gets or sets the identifying number assigned to the point.

C#
public unsigned long int PointNumber;
Visual Basic
Public Property PointNumber() As unsigned long int
Links
PointEntity Class, PointEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


PointEntity::RawDescription Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties > PointEntity::RawDescription Property
PointEntity::RawDescription Property
Collapse All

Gets or sets an unexpanded description for the point, which could be the description entered by the surveyor in the field.

C#
public System::String RawDescription;
Visual Basic
Public Property RawDescription() As System::String
Links
PointEntity Class, PointEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


PointTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointTable Class
PointTable Class
Collapse All

The AeccDbPointScheduleTable wrapper.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::Land::DatabaseServices::PointTable
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPointScheduleTable"))]
public class PointTable : Autodesk::Civil::DatabaseServices::Table;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPointScheduleTable"))>
Public Class PointTable
Inherits Autodesk::Civil::DatabaseServices::Table
Links
Class Hierarchy


PolylineOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class
PolylineOptions Class
Collapse All

The PolylineOptions class. This class specifies the options for creating an Alignment using a polyline.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::PolylineOptions
C#
public class PolylineOptions : System::IEquatable<PolylineOptions>;
Visual Basic
Public Class PolylineOptions
Inherits System::IEquatable<PolylineOptions>
Links
PolylineOptions Methods, PolylineOptions Operators, PolylineOptions Properties, PolylineOptions Members, Class Hierarchy


PolylineOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Members
PolylineOptions Members
Collapse All

The following tables list the members exposed by PolylineOptions.

Public Methods
Public Method | Description
Equals | Overloaded
GetHashCode | Gets a hash code for the PolylineOptions object.
Public Properties
Public Property | Description
AddCurvesBetweenTangents | Specifies whether to add curves between tangents.
EraseExistingEntities | Specifies whether to erase the polyline after the Alignment is created.
PlineId | Specifies the objectId of the polyline.
Public Operators
Public Operator | Description
!= | Compares two PolylineOptions objects, returns true if they are not equal.
== | Compares two PolylineOptions objects, returns true if they are equal.
Links
Public Methods, Public Properties, Public Operators


PolylineOptions Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Methods
PolylineOptions Methods
Collapse All

The methods of PolylineOptions are listed here.

Public Methods
Public Method | Description
Equals | Overloaded
GetHashCode | Gets a hash code for the PolylineOptions object.
Links
Public Methods


Equals Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Methods > Equals Method
Equals Method
Collapse All

Overloaded

Overload List
Method | Description
PolylineOptions::Equals (PolylineOptions) | Compares two PolylineOptions objects, returns true if they are equal.
PolylineOptions::Equals (System::Object^) | Compares a PolylineOptions object with a System::Object, returns true if they are equal.


PolylineOptions::Equals Method (PolylineOptions)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Methods > Equals Method > PolylineOptions::Equals Method (PolylineOptions)
PolylineOptions::Equals Method (PolylineOptions)
Collapse All

Compares two PolylineOptions objects, returns true if they are equal.

C#
public bool Equals(
    PolylineOptions other
);
Visual Basic
Public Function Equals(
    other As PolylineOptions
) As bool
Links
PolylineOptions Class, PolylineOptions Members, Autodesk::Civil::Land::DatabaseServices Namespace


PolylineOptions::Equals Method (System::Object^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Methods > Equals Method > PolylineOptions::Equals Method (System::Object^)
PolylineOptions::Equals Method (System::Object^)
Collapse All

Compares a PolylineOptions object with a System::Object, returns true if they are equal.

C#
public bool Equals(
    ref System::Object obj
);
Visual Basic
Public Function Equals(
    ByRef obj As System::Object
) As bool
Links
PolylineOptions Class, PolylineOptions Members, Autodesk::Civil::Land::DatabaseServices Namespace


PolylineOptions::GetHashCode Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Methods > PolylineOptions::GetHashCode Method
PolylineOptions::GetHashCode Method
Collapse All

Gets a hash code for the PolylineOptions object.

C#
public int GetHashCode();
Visual Basic
Public Function GetHashCode() As Integer
Links
PolylineOptions Class, PolylineOptions Members, Autodesk::Civil::Land::DatabaseServices Namespace


PolylineOptions Operators

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Operators
PolylineOptions Operators
Collapse All

The operators of PolylineOptions are listed here.

Public Operators
Public Operator | Description
!= | Compares two PolylineOptions objects, returns true if they are not equal.
== | Compares two PolylineOptions objects, returns true if they are equal.
Links
Public Operators


PolylineOptions::!= Operator

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Operators > PolylineOptions::!= Operator
PolylineOptions::!= Operator
Collapse All

Compares two PolylineOptions objects, returns true if they are not equal.

C#
public bool operator !=(
    PolylineOptions option1,
    PolylineOptions option2
);
Visual Basic
Public Operator !=(
    option1 As PolylineOptions,
    option2 As PolylineOptions
)
Links
PolylineOptions Class, PolylineOptions Members, Autodesk::Civil::Land::DatabaseServices Namespace


PolylineOptions::== Operator

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Operators > PolylineOptions::== Operator
PolylineOptions::== Operator
Collapse All

Compares two PolylineOptions objects, returns true if they are equal.

C#
public bool operator ==(
    PolylineOptions option1,
    PolylineOptions option2
);
Visual Basic
Public Operator ==(
    option1 As PolylineOptions,
    option2 As PolylineOptions
)
Links
PolylineOptions Class, PolylineOptions Members, Autodesk::Civil::Land::DatabaseServices Namespace


PolylineOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Properties
PolylineOptions Properties
Collapse All

The properties of PolylineOptions are listed here.

Public Properties
Public Property | Description
AddCurvesBetweenTangents | Specifies whether to add curves between tangents.
EraseExistingEntities | Specifies whether to erase the polyline after the Alignment is created.
PlineId | Specifies the objectId of the polyline.
Links
Public Properties


PolylineOptions::AddCurvesBetweenTangents Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Properties > PolylineOptions::AddCurvesBetweenTangents Property
PolylineOptions::AddCurvesBetweenTangents Property
Collapse All

Specifies whether to add curves between tangents.

C#
public bool AddCurvesBetweenTangents;
Visual Basic
Public Property AddCurvesBetweenTangents() As bool
Links
PolylineOptions Class, PolylineOptions Members, Autodesk::Civil::Land::DatabaseServices Namespace


PolylineOptions::EraseExistingEntities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Properties > PolylineOptions::EraseExistingEntities Property
PolylineOptions::EraseExistingEntities Property
Collapse All

Specifies whether to erase the polyline after the Alignment is created.

C#
public bool EraseExistingEntities;
Visual Basic
Public Property EraseExistingEntities() As bool
Links
PolylineOptions Class, PolylineOptions Members, Autodesk::Civil::Land::DatabaseServices Namespace


PolylineOptions::PlineId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Properties > PolylineOptions::PlineId Property
PolylineOptions::PlineId Property
Collapse All

Specifies the objectId of the polyline.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PlineId;
Visual Basic
Public Property PlineId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.AutoCAD.DatabaseServices.Polyline, Polyline2d or Polyline3d.

Links
PolylineOptions Class, PolylineOptions Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class
Profile Class
Collapse All

A record of elevation against distance along a horizontal Alignment or other line. Profiles are used to visualize the terrain along a route of interest, such as a proposed road, or simply to show how the elevation changes across a particular region.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::Profile
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignment"))]
public class Profile : Autodesk::Civil::DatabaseServices::Feature;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignment"))>
Public Class Profile
Inherits Autodesk::Civil::DatabaseServices::Feature
Remarks

A profile can record the elevation of the surface along an alignment. Together, a profile and an alignment represent a 3D path. Such a path can form the baseline of a Corridor.

A ProfileView is used to display one or more profiles for a horizontal alignment. You can configure data bands and profile annotations in a ProfileView to make it clearer or more informative for the user.

In general, you do not directly edit a surface profile (existing ground profile). If you move the parent alignment or edit the surface, the changes are reflected in the surface profile. By contrast, the layout profile is a fully designed object that you usually edit in many ways, such as changing tangent grades, modifying curves, and adding or moving points of vertical intersection (PVI).

Links
Profile Methods, Profile Properties, Profile Members, Class Hierarchy


Profile Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Members
Profile Members
Collapse All

The following tables list the members exposed by Profile.

Public Methods
Public Method | Description
CreateByLayout | Overloaded
CreateFromSurface | Overloaded
ElevationAt | Gets the elevation at a specified station.
GradeAt | Given a station, gets the instantaneous grade and the algebraic difference.
IsEditableFeature | Check whether the Feature-derived entity (Alignment,Profile,etc) is editable.
Public Properties
Public Property | Description
AlignmentId | Gets the object id of the corresponding alignment for the profile.
Application | Gets the Application. Not currently implemented.
DataSourceId | Gets the object id of object that is associated with the profile.
DataSourceName | Gets the name of object that is associated with the profile.
DesignCheckSetId | Gets the object id of design check set that is used in the profile.
DesignCheckSetName | Gets the name of of design check set that is used in the profile.
DesignSpeedBased | Gets or sets whether the design is speed-based.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
ElevationMax | Gets the maximum elevation value on the profile.
ElevationMin | Gets the minimum elevation value on the profile.
EndingStation | Gets the profile ending station.
Entities | Gets the profile entities' collection.
IsEditable | Gets the value indicates whether the Feature derived entity (Alignment,Profile,etc) is editable.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Length | Gets the profile length.
Name | Gets or sets the Entity object's name.
Offset | Gets the profile offset.
Plinegen | Gets or sets the PLINEGEN setting for the profile.
ProfileType | Gets or sets the profile type.
PVIs | Gets the points of vertical intersection for the profile.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StartingStation | Gets the profile starting station.
StyleId | Sets the profile's style Id.
StyleName | Sets the profile's style name.
UpdateMode | Gets or sets the update mode of the profile.
UseDesignCheckSet | Gets or sets whether the design check set is used.
UseDesignCriteriaFile | Gets or sets whether the design criteria file is used.
Links
Public Methods, Public Properties


Profile Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods
Profile Methods
Collapse All

The methods of Profile are listed here.

Public Methods
Public Method | Description
CreateByLayout | Overloaded
CreateFromSurface | Overloaded
ElevationAt | Gets the elevation at a specified station.
GradeAt | Given a station, gets the instantaneous grade and the algebraic difference.
Links
Public Methods


CreateByLayout Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > CreateByLayout Method
CreateByLayout Method
Collapse All

Overloaded

Overload List
Method | Description
Profile::CreateByLayout (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a profile of FG type.
Profile::CreateByLayout (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^) | Creates a profile of FG type.


Profile::CreateByLayout Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > CreateByLayout Method > Profile::CreateByLayout Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Profile::CreateByLayout Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a profile of FG type.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CreateByLayout(
    ref System::String profileName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId layerId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelSetId
);
Visual Basic
Public Function CreateByLayout(
    ByRef profileName As System::String,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    layerId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    labelSetId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
profileName | Name for the new profile, make sure this name is not used by another profile under the specified alignment
alignmentId | Alignment id to place the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment
layerId | Layer id to place the new profile, OBJECTID TYPE: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord
styleId | Style id to apply to the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.AlignmentStyle
labelSetId | LabelSet id to apply to the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.AlignmentLabelSetStyle
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. profileName is either null, blank, or existed under the specified alignment.
  2. alignmentId, layerId, styleId, or labelsetId is invalid.

Example
Alignment oAlignment = ts.GetObject(alignID, OpenMode.ForRead) as Alignment;

// use the same layer as the alignment
ObjectId layerId = oAlignment.LayerId;
// get the standard style and label set
// these calls will fail on templates without a style named "Standard"
ObjectId styleId = doc.Styles.ProfileStyles["Standard"];
ObjectId labelSetId = doc.Styles.LabelSetStyles.ProfileLabelSetStyles["Standard"];

ObjectId oProfileId = Profile.CreateByLayout("My Profile", alignID, layerId, styleId, labelSetId);
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::CreateByLayout Method (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > CreateByLayout Method > Profile::CreateByLayout Method (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^)
Profile::CreateByLayout Method (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^)
Collapse All

Creates a profile of FG type.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CreateByLayout(
    ref System::String profileName,
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    ref System::String alignmentName,
    ref System::String layerName,
    ref System::String styleName,
    ref System::String labelSetName
);
Visual Basic
Public Function CreateByLayout(
    ByRef profileName As System::String,
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    ByRef alignmentName As System::String,
    ByRef layerName As System::String,
    ByRef styleName As System::String,
    ByRef labelSetName As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
profileName | Name for the new profile, make sure this name is not used by another profile under the specified alignment
document | CivilDocument to place this new profile
alignmentName | Name of the alignment to place this new profile.
layerName | Name of the layer for this profile
styleName | Name of the style for this profile
labelSetName | Name of the label set for this profile
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. profileName is either null, blank, or existed under the specified alignment.
  2. alignmentName, layerName, styleName or labelSetName is invalid or cannot be found.

Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


CreateFromSurface Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > CreateFromSurface Method
CreateFromSurface Method
Collapse All

Overloaded

Overload List
Method | Description
Profile::CreateFromSurface (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates a profile of EG type from a surface.
Profile::CreateFromSurface (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, double, double, double) | Creates a profile of EG type from a surface.
Profile::CreateFromSurface (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^) | Creates a profile of EG type from a surface.
Profile::CreateFromSurface (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^, double, double, double) | Creates a profile of EG type from a surface.


Profile::CreateFromSurface Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > CreateFromSurface Method > Profile::CreateFromSurface Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Profile::CreateFromSurface Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates a profile of EG type from a surface.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CreateFromSurface(
    ref System::String profileName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId surfaceId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId layerId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelSetId
);
Visual Basic
Public Function CreateFromSurface(
    ByRef profileName As System::String,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    surfaceId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    layerId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    labelSetId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
profileName | Name for the new profile, make sure this name is not used by another profile under the specified alignment
alignmentId | Alignment id to place the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment
surfaceId | Surface id to place the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Surface
layerId | Layer id to place the new profile, OBJECTID TYPE: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord
styleId | Style id to apply to the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.AlignmentStyle
labelSetId | LabelSet id to apply to the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.AlignmentLabelSetStyle
Remarks

This method will use default values for offset, start station and end station. default offset = 0, default start station and end station will bind with the parent alignment station.

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. profileName is either null, blank, or existed under the specified alignment.
  2. alignmentId, surfaceId, layerId, styleId, or labelsetId is invalid.
  3. offset value too large or too small. sampleStart or sampleEnd are not within Alignment station range.

Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::CreateFromSurface Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, double, doubl

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > CreateFromSurface Method > Profile::CreateFromSurface Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, double, double, double)
Profile::CreateFromSurface Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, double, double, double)
Collapse All

Creates a profile of EG type from a surface.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CreateFromSurface(
    ref System::String profileName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId surfaceId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId layerId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelSetId,
    double offset,
    double sampleStart,
    double sampleEnd
);
Visual Basic
Public Function CreateFromSurface(
    ByRef profileName As System::String,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    surfaceId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    layerId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    labelSetId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    offset As double,
    sampleStart As double,
    sampleEnd As double
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
profileName | Name for the new profile, make sure this name is not used by another profile under the specified alignment
alignmentId | Alignment id to place the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment
surfaceId | Surface id to place the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Surface
layerId | Layer id to place the new profile, OBJECTID TYPE: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord
styleId | Style id to apply to the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.AlignmentStyle
labelSetId | LabelSet id to apply to the new profile, OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.AlignmentLabelSetStyle
offset | Sets the offset value to create this Profile.
sampleStart | Sets the start sample station for this Profile, it should be within Alignment station range
sampleEnd | Sets the end sample station for this Profile, it should be within Alignment station range
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. profileName is either null, blank, or existed under the specified alignment.
  2. alignmentId, surfaceId, layerId, styleId, or labelsetId is invalid.
  3. offset value too large or too small. sampleStart or sampleEnd are not within Alignment station range.

Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::CreateFromSurface Method (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > CreateFromSurface Method > Profile::CreateFromSurface Method (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^)
Profile::CreateFromSurface Method (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^)
Collapse All

Creates a profile of EG type from a surface.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CreateFromSurface(
    ref System::String profileName,
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    ref System::String alignmentName,
    ref System::String surfaceName,
    ref System::String layerName,
    ref System::String styleName,
    ref System::String labelSetName
);
Visual Basic
Public Function CreateFromSurface(
    ByRef profileName As System::String,
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    ByRef alignmentName As System::String,
    ByRef surfaceName As System::String,
    ByRef layerName As System::String,
    ByRef styleName As System::String,
    ByRef labelSetName As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
profileName | Name for the new profile, make sure this name is not used by another profile under the specified alignment
document | CivilDocument to place this new profile
alignmentName | Name of the alignment to place this new profile.
surfaceName | Name of the surface to place this new profile.
layerName | Name of the layer for this profile
styleName | Name of the style for this profile
labelSetName | Name of the label set for this profile
offset | Sets the offset value to create this Profile.
sampleStart | Sets the start sample station for this Profile, it should be within Alignment station range
sampleEnd | Sets the end sample station for this Profile, it should be within Alignment station range
Remarks

This method will use default values for offset, start station and end station. default offset = 0, default start station and end station will bind with the parent alignment station.

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. profileName is either null, blank, or existed under the specified alignment.
  2. alignmentId, surfaceId, layerId, styleId, or labelsetId is invalid.
  3. offset value too large or too small. sampleStart or sampleEnd are not within Alignment station range.

Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::CreateFromSurface Method (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^, double, double, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > CreateFromSurface Method > Profile::CreateFromSurface Method (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^, double, double, double)
Profile::CreateFromSurface Method (System::String^, Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, System::String^, System::String^, double, double, double)
Collapse All

Creates a profile of EG type from a surface.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CreateFromSurface(
    ref System::String profileName,
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    ref System::String alignmentName,
    ref System::String surfaceName,
    ref System::String layerName,
    ref System::String styleName,
    ref System::String labelSetName,
    double offset,
    double sampleStart,
    double sampleEnd
);
Visual Basic
Public Function CreateFromSurface(
    ByRef profileName As System::String,
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    ByRef alignmentName As System::String,
    ByRef surfaceName As System::String,
    ByRef layerName As System::String,
    ByRef styleName As System::String,
    ByRef labelSetName As System::String,
    offset As double,
    sampleStart As double,
    sampleEnd As double
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
profileName | Name for the new profile, make sure this name is not used by another profile under the specified alignment
document | CivilDocument to place this new profile
alignmentName | Name of the alignment to place this new profile.
surfaceName | Name of the surface to place this new profile.
layerName | Name of the layer for this profile
styleName | Name of the style for this profile
labelSetName | Name of the label set for this profile
offset | Sets the offset value to create this Profile.
sampleStart | Sets the start sample station for this Profile, it should be within Alignment station range
sampleEnd | Sets the end sample station for this Profile, it should be within Alignment station range
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. profileName is either null, blank, or existed under the specified alignment.
  2. alignmentId, surfaceId, layerId, styleId, or labelsetId is invalid.
  3. offset value too large or too small. sampleStart or sampleEnd are not within Alignment station range.

Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::ElevationAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > Profile::ElevationAt Method
Profile::ElevationAt Method
Collapse All

Gets the elevation at a specified station.

C#
public double ElevationAt(
    double station
);
Visual Basic
Public Function ElevationAt(
    station As double
) As double
Parameters
Parameters | Description
station | Station value.
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::GradeAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods > Profile::GradeAt Method
Profile::GradeAt Method
Collapse All

Given a station, gets the instantaneous grade and the algebraic difference.

C#
public double GradeAt(
    double station
);
Visual Basic
Public Function GradeAt(
    station As double
) As double
Parameters
Parameters | Description
station | Station value.
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties
Profile Properties
Collapse All

The properties of Profile are listed here.

Public Properties
Public Property | Description
AlignmentId | Gets the object id of the corresponding alignment for the profile.
DataSourceId | Gets the object id of object that is associated with the profile.
DataSourceName | Gets the name of object that is associated with the profile.
DesignCheckSetId | Gets the object id of design check set that is used in the profile.
DesignCheckSetName | Gets the name of of design check set that is used in the profile.
DesignSpeedBased | Gets or sets whether the design is speed-based.
ElevationMax | Gets the maximum elevation value on the profile.
ElevationMin | Gets the minimum elevation value on the profile.
EndingStation | Gets the profile ending station.
Entities | Gets the profile entities' collection.
Length | Gets the profile length.
Offset | Gets the profile offset.
Plinegen | Gets or sets the PLINEGEN setting for the profile.
ProfileType | Gets or sets the profile type.
PVIs | Gets the points of vertical intersection for the profile.
StartingStation | Gets the profile starting station.
StyleId | Sets the profile's style Id.
StyleName | Sets the profile's style name.
UpdateMode | Gets or sets the update mode of the profile.
UseDesignCheckSet | Gets or sets whether the design check set is used.
UseDesignCriteriaFile | Gets or sets whether the design criteria file is used.
Links
Public Properties


Profile::AlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::AlignmentId Property
Profile::AlignmentId Property
Collapse All

Gets the object id of the corresponding alignment for the profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AlignmentId;
Visual Basic
Public Property AlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment

Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::DataSourceId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::DataSourceId Property
Profile::DataSourceId Property
Collapse All

Gets the object id of object that is associated with the profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId DataSourceId;
Visual Basic
Public Property DataSourceId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Surface, for surface profile, returns the object id of the surface represented in the profile. OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile, for superimposed profiles, returns the object id of the superimposed profile. OBJECTID TYPE: Autodesk.Civil.Roadway.DatabaseServices.Corridor, for corridor profiles, returns the object id of the source corridor. Not used for other type of profiles.

Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::DataSourceName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::DataSourceName Property
Profile::DataSourceName Property
Collapse All

Gets the name of object that is associated with the profile.

C#
public System::String DataSourceName;
Visual Basic
Public Property DataSourceName() As System::String
Remarks

For surface profile, returns the name of the surface represented in the profile. For superimposed profiles, returns the name of the superimposed profile. For corridor profiles, returns the name of the source corridor. Not used for other type of profiles.

Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::DesignCheckSetId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::DesignCheckSetId Property
Profile::DesignCheckSetId Property
Collapse All

Gets the object id of design check set that is used in the profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId DesignCheckSetId;
Visual Basic
Public Property DesignCheckSetId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.ProfileDesignCheckSet

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not ProfileDesignCheckSet.
System.InvalidOperationException | Thrown when the value of property DesignSpeedBased is false.
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::DesignCheckSetName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::DesignCheckSetName Property
Profile::DesignCheckSetName Property
Collapse All

Gets the name of of design check set that is used in the profile.

C#
public System::String DesignCheckSetName;
Visual Basic
Public Property DesignCheckSetName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name that a ProfileDesignCheckSet of this name is not exist.
System.InvalidOperationException | Thrown when the value of property DesignSpeedBased is false.
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::DesignSpeedBased Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::DesignSpeedBased Property
Profile::DesignSpeedBased Property
Collapse All

Gets or sets whether the design is speed-based.

C#
public bool DesignSpeedBased;
Visual Basic
Public Property DesignSpeedBased() As bool
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::ElevationMax Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::ElevationMax Property
Profile::ElevationMax Property
Collapse All

Gets the maximum elevation value on the profile.

C#
public double ElevationMax;
Visual Basic
Public Property ElevationMax() As double
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::ElevationMin Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::ElevationMin Property
Profile::ElevationMin Property
Collapse All

Gets the minimum elevation value on the profile.

C#
public double ElevationMin;
Visual Basic
Public Property ElevationMin() As double
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::EndingStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::EndingStation Property
Profile::EndingStation Property
Collapse All

Gets the profile ending station.

C#
public double EndingStation;
Visual Basic
Public Property EndingStation() As double
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::Entities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::Entities Property
Profile::Entities Property
Collapse All

Gets the profile entities' collection.

C#
public ProfileEntityCollection Entities;
Visual Basic
Public Property Entities() As ProfileEntityCollection
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::Length Property
Profile::Length Property
Collapse All

Gets the profile length.

C#
public double Length;
Visual Basic
Public Property Length() As double
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::Offset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::Offset Property
Profile::Offset Property
Collapse All

Gets the profile offset.

C#
public double Offset;
Visual Basic
Public Property Offset() As double
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::Plinegen Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::Plinegen Property
Profile::Plinegen Property
Collapse All

Gets or sets the PLINEGEN setting for the profile.

C#
public bool Plinegen;
Visual Basic
Public Property Plinegen() As bool
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::ProfileType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::ProfileType Property
Profile::ProfileType Property
Collapse All

Gets or sets the profile type.

C#
public Autodesk::Civil::Land::DatabaseServices::ProfileType ProfileType;
Visual Basic
Public Property ProfileType() As Autodesk::Civil::Land::DatabaseServices::ProfileType
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::PVIs Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::PVIs Property
Profile::PVIs Property
Collapse All

Gets the points of vertical intersection for the profile.

C#
public ProfilePVICollection PVIs;
Visual Basic
Public Property PVIs() As ProfilePVICollection
Example
' Print out all the PVIs counts
m_Editor.WriteMessage("Sample Profile created, PVI count: " + oProfile.PVIs.Count.ToString + Convert.ToChar(10))
Dim oPVI As ProfilePVI
' Add another PVI
oPVI = oProfile.PVIs.AddPVI(607.4, -64.3)
m_Editor.WriteMessage("New PVI count: " + oProfile.PVIs.Count.ToString + Convert.ToChar(10))
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::StartingStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::StartingStation Property
Profile::StartingStation Property
Collapse All

Gets the profile starting station.

C#
public double StartingStation;
Visual Basic
Public Property StartingStation() As double
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::StyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::StyleId Property
Profile::StyleId Property
Collapse All

Sets the profile's style Id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StyleId;
Visual Basic
Public Property StyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.ProfileStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not ProfileStyle.
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::StyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::StyleName Property
Profile::StyleName Property
Collapse All

Sets the profile's style name.

C#
public System::String StyleName;
Visual Basic
Public Property StyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property an object name that a ProfileStyle of this name is not exist.
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::UpdateMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::UpdateMode Property
Profile::UpdateMode Property
Collapse All

Gets or sets the update mode of the profile.

C#
public ProfileUpdateType UpdateMode;
Visual Basic
Public Property UpdateMode() As ProfileUpdateType
Remarks

Gets for Superimposed, EG, CorridorFeature only. Sets for surface profiles only. Specifies whether the profile updates automatically to reflect changes in surface elevation.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when setting the UpdataMode which profile's type is not EG.
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::UseDesignCheckSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::UseDesignCheckSet Property
Profile::UseDesignCheckSet Property
Collapse All

Gets or sets whether the design check set is used.

C#
public bool UseDesignCheckSet;
Visual Basic
Public Property UseDesignCheckSet() As bool
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


Profile::UseDesignCriteriaFile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties > Profile::UseDesignCriteriaFile Property
Profile::UseDesignCriteriaFile Property
Collapse All

Gets or sets whether the design criteria file is used.

C#
public bool UseDesignCriteriaFile;
Visual Basic
Public Property UseDesignCriteriaFile() As bool
Links
Profile Class, Profile Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileBandLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileBandLabelGroup Class
ProfileBandLabelGroup Class
Collapse All

The AeccDbProfileBandLabeling wrapper.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::Land::DatabaseServices::ProfileBandLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbProfileBandLabeling"))]
public class ProfileBandLabelGroup : Autodesk::Civil::DatabaseServices::LabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbProfileBandLabeling"))>
Public Class ProfileBandLabelGroup
Inherits Autodesk::Civil::DatabaseServices::LabelGroup
Links
Class Hierarchy


ProfileCircular Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class
ProfileCircular Class
Collapse All

The ProfileCircular class. This class represents an ProfileEntity made up of a circular curve.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileCircular
C#
public class ProfileCircular : ProfileEntity;
Visual Basic
Public Class ProfileCircular
Inherits ProfileEntity
Links
ProfileCircular Properties, ProfileCircular Members, Class Hierarchy


ProfileCircular Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Members
ProfileCircular Members
Collapse All

The following tables list the members exposed by ProfileCircular.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
CurveType | Gets the curve type, crest or sag.
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighestDesignSpeed | Returns the highest speed in the station range.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
Length | Gets or sets the curve length.
M | Gets or sets the M value of the curve.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
Radius | Gets or sets the radius of the curve.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.
Links
Public Methods, Public Properties


ProfileCircular Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties
ProfileCircular Properties
Collapse All

The properties of ProfileCircular are listed here.

Public Properties
Public Property | Description
CurveType | Gets the curve type, crest or sag.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
M | Gets or sets the M value of the curve.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
Radius | Gets or sets the radius of the curve.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.
Links
Public Properties


ProfileCircular::CurveType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::CurveType Property
ProfileCircular::CurveType Property
Collapse All

Gets the curve type, crest or sag.

C#
public VerticalCurveType CurveType;
Visual Basic
Public Property CurveType() As VerticalCurveType
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::EntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::EntityType Property
ProfileCircular::EntityType Property
Collapse All

Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric

C#
public ProfileEntityType EntityType;
Visual Basic
Public Property EntityType() As ProfileEntityType
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::GradeChange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::GradeChange Property
ProfileCircular::GradeChange Property
Collapse All

Gets the A value (Grade Change) between the end point and start point.

C#
public double GradeChange;
Visual Basic
Public Property GradeChange() As double
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::GradeIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::GradeIn Property
ProfileCircular::GradeIn Property
Collapse All

Gets the grade at the start point.

C#
public double GradeIn;
Visual Basic
Public Property GradeIn() As double
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::GradeOut Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::GradeOut Property
ProfileCircular::GradeOut Property
Collapse All

Gets the grade at the end point.

C#
public double GradeOut;
Visual Basic
Public Property GradeOut() As double
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::HighLowPointElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::HighLowPointElevation Property
ProfileCircular::HighLowPointElevation Property
Collapse All

Gets the elevation value of the high/low point of the curve.

C#
public double HighLowPointElevation;
Visual Basic
Public Property HighLowPointElevation() As double
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::HighLowPointStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::HighLowPointStation Property
ProfileCircular::HighLowPointStation Property
Collapse All

Gets the station value of the high/low point of the curve.

C#
public double HighLowPointStation;
Visual Basic
Public Property HighLowPointStation() As double
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::K Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::K Property
ProfileCircular::K Property
Collapse All

Gets or sets the K value (Curve Coefficient) of the curve.

C#
public double K;
Visual Basic
Public Property K() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::M Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::M Property
ProfileCircular::M Property
Collapse All

Gets or sets the M value of the curve.

C#
public double M;
Visual Basic
Public Property M() As double
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::PVIElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::PVIElevation Property
ProfileCircular::PVIElevation Property
Collapse All

Gets the elevation value of the PVI this curve is associated with.

C#
public double PVIElevation;
Visual Basic
Public Property PVIElevation() As double
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::PVIStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::PVIStation Property
ProfileCircular::PVIStation Property
Collapse All

Gets the station value of the PVI this curve is associated with.

C#
public double PVIStation;
Visual Basic
Public Property PVIStation() As double
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::Radius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::Radius Property
ProfileCircular::Radius Property
Collapse All

Gets or sets the radius of the curve.

C#
public double Radius;
Visual Basic
Public Property Radius() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCircular::TangentOffsetAtPVI Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties > ProfileCircular::TangentOffsetAtPVI Property
ProfileCircular::TangentOffsetAtPVI Property
Collapse All

Gets the tangent offset value at the PVI the curve is associated with.

C#
public double TangentOffsetAtPVI;
Visual Basic
Public Property TangentOffsetAtPVI() As double
Links
ProfileCircular Class, ProfileCircular Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCriteria Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class
ProfileCriteria Class
Collapse All

Critera used by the criteria-based design feature to apply agency-specific standards to a profile.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileCriteria
C#
public class ProfileCriteria : CivilWrapper<AeccDbGraphProfile>;
Visual Basic
Public Class ProfileCriteria
Inherits CivilWrapper<AeccDbGraphProfile>
Links
ProfileCriteria Properties, ProfileCriteria Members, Class Hierarchy


ProfileCriteria Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class > ProfileCriteria Members
ProfileCriteria Members
Collapse All

The following tables list the members exposed by ProfileCriteria.

Public Properties
Public Property | Description
BoundaryType | Gets the profile critera's boundary type of the hatch area.
ProfileId | Gets or Sets the profile id in the profile critera of the hatch area.
ProfileName | Gets or Sets the profile name in the profile critera of the hatch area.
Links
Public Properties


ProfileCriteria Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class > ProfileCriteria Properties
ProfileCriteria Properties
Collapse All

The properties of ProfileCriteria are listed here.

Public Properties
Public Property | Description
BoundaryType | Gets the profile critera's boundary type of the hatch area.
ProfileId | Gets or Sets the profile id in the profile critera of the hatch area.
ProfileName | Gets or Sets the profile name in the profile critera of the hatch area.
Links
Public Properties


ProfileCriteria::BoundaryType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class > ProfileCriteria Properties > ProfileCriteria::BoundaryType Property
ProfileCriteria::BoundaryType Property
Collapse All

Gets the profile critera's boundary type of the hatch area.

C#
public HatchCriteriaBoundaryType BoundaryType;
Visual Basic
Public Property BoundaryType() As HatchCriteriaBoundaryType
Links
ProfileCriteria Class, ProfileCriteria Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCriteria::ProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class > ProfileCriteria Properties > ProfileCriteria::ProfileId Property
ProfileCriteria::ProfileId Property
Collapse All

Gets or Sets the profile id in the profile critera of the hatch area.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileId;
Visual Basic
Public Property ProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not Autodesk.Civil.Land.DatabaseServices.Profile.
Links
ProfileCriteria Class, ProfileCriteria Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCriteria::ProfileName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class > ProfileCriteria Properties > ProfileCriteria::ProfileName Property
ProfileCriteria::ProfileName Property
Collapse All

Gets or Sets the profile name in the profile critera of the hatch area.

C#
public System::String ProfileName;
Visual Basic
Public Property ProfileName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the profile name is invalid.
Links
ProfileCriteria Class, ProfileCriteria Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCriteriaCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class
ProfileCriteriaCollection Class
Collapse All

The ProfileCriteria collection class represents the collection of all criteria in the hatch area.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileCriteriaCollection
C#
public class ProfileCriteriaCollection : CivilWrapper<AeccDbGraphProfile>, System::Collections::Generic::IEnumerable<ProfileCriteria^>;
Visual Basic
Public Class ProfileCriteriaCollection
Inherits CivilWrapper<AeccDbGraphProfile>
Inherits System::Collections::Generic::IEnumerable<ProfileCriteria^>
Links
ProfileCriteriaCollection Methods, ProfileCriteriaCollection Properties, ProfileCriteriaCollection Members, Class Hierarchy


ProfileCriteriaCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Members
ProfileCriteriaCollection Members
Collapse All

The following tables list the members exposed by ProfileCriteriaCollection.

Public Methods
Public Method | Description
Add | Adds an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria to the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria from the collection.
Public Properties
Public Property | Description
Count | Gets the number of ProfileCriteria objects in the collection.
default | Gets the ProfileCriteria at a specified index in the collection.
Links
Public Methods, Public Properties


ProfileCriteriaCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Methods
ProfileCriteriaCollection Methods
Collapse All

The methods of ProfileCriteriaCollection are listed here.

Public Methods
Public Method | Description
Add | Adds an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria to the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria from the collection.
Links
Public Methods


ProfileCriteriaCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Methods > ProfileCriteriaCollection::Add Method
ProfileCriteriaCollection::Add Method
Collapse All

Adds an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria to the collection.

C#
public Add(
    Autodesk::AutoCAD::DatabaseServices::ObjectId profileId,
    HatchCriteriaBoundaryType type
);
Visual Basic
Public Sub Add(
    profileId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    type As HatchCriteriaBoundaryType
)
Parameters
Parameters | Description
profileId | The profile id of the hatch area criteria.
type | The profile hatch area criteria's boundary type.
Links
ProfileCriteriaCollection Class, ProfileCriteriaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCriteriaCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Methods > ProfileCriteriaCollection::GetEnumerator Method
ProfileCriteriaCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<ProfileCriteria^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<ProfileCriteria^>
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileCriteriaCollection Class, ProfileCriteriaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCriteriaCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Methods > ProfileCriteriaCollection::GetObjectEnumerator Method
ProfileCriteriaCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileCriteriaCollection Class, ProfileCriteriaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCriteriaCollection::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Methods > ProfileCriteriaCollection::RemoveAt Method
ProfileCriteriaCollection::RemoveAt Method
Collapse All

Removes an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria from the collection.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | The index of the ProfileCriteria in the ProfileCriteriaCollection.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the collection's range.
Links
ProfileCriteriaCollection Class, ProfileCriteriaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCriteriaCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Properties
ProfileCriteriaCollection Properties
Collapse All

The properties of ProfileCriteriaCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of ProfileCriteria objects in the collection.
default | Gets the ProfileCriteria at a specified index in the collection.
Links
Public Properties


ProfileCriteriaCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Properties > ProfileCriteriaCollection::Count Property
ProfileCriteriaCollection::Count Property
Collapse All

Gets the number of ProfileCriteria objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ProfileCriteriaCollection Class, ProfileCriteriaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileCriteriaCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Properties > ProfileCriteriaCollection::default Property
ProfileCriteriaCollection::default Property
Collapse All

Gets the ProfileCriteria at a specified index in the collection.

C#
public ProfileCriteria default;
Visual Basic
Public Property default() As ProfileCriteria
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the collection's range.
Links
ProfileCriteriaCollection Class, ProfileCriteriaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class
ProfileEntity Class
Collapse All

The abstract class of profile entity. ProfileEntity has four derived classes: ProfileLine, ProfileAsymmetric, ProfileCircular, and ProfileParabolic.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileCircular
    Autodesk::Civil::Land::DatabaseServices::ProfileParabolaAsymmetric
    Autodesk::Civil::Land::DatabaseServices::ProfileParabolaSymmetric
    Autodesk::Civil::Land::DatabaseServices::ProfileTangent
C#
public class ProfileEntity : CivilWrapper<AeccDbVAlignment>;
Visual Basic
Public Class ProfileEntity
Inherits CivilWrapper<AeccDbVAlignment>
Links
ProfileEntity Methods, ProfileEntity Properties, ProfileEntity Members, Class Hierarchy


ProfileEntity Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Members
ProfileEntity Members
Collapse All

The following tables list the members exposed by ProfileEntity.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
HighestDesignSpeed | Returns the highest speed in the station range.
Length | Gets or sets the curve length.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
Links
Public Methods, Public Properties


ProfileEntity Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Methods
ProfileEntity Methods
Collapse All

The methods of ProfileEntity are listed here.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Links
Public Methods


ProfileEntity::DesignChecks Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Methods > ProfileEntity::DesignChecks Method
ProfileEntity::DesignChecks Method
Collapse All

Gets the collection of applicable design checks.

C#
public array<ProfileDesignCheck^> DesignChecks();
Visual Basic
Public Function DesignChecks() As array<ProfileDesignCheck^>
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::ValidateDesignCheck Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Methods > ProfileEntity::ValidateDesignCheck Method
ProfileEntity::ValidateDesignCheck Method
Collapse All

Validate a specific design check on this entity.

C#
public bool ValidateDesignCheck(
    ref ProfileDesignCheck designCheck,
    ProfileApplyCurveType curveType
);
Visual Basic
Public Function ValidateDesignCheck(
    ByRef designCheck As ProfileDesignCheck,
    curveType As ProfileApplyCurveType
) As bool
Parameters
Parameters | Description
designCheck | The design check to validate.
curveType | The curve type to use for the validation.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the design check type is inconsistent with the profile entity type.
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties
ProfileEntity Properties
Collapse All

The properties of ProfileEntity are listed here.

Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
HighestDesignSpeed | Returns the highest speed in the station range.
Length | Gets or sets the curve length.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
Links
Public Properties


ProfileEntity::Constraint1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::Constraint1 Property
ProfileEntity::Constraint1 Property
Collapse All

Gets the entity constraint of the profile entity.

C#
public ProfileEntityConstraintType Constraint1;
Visual Basic
Public Property Constraint1() As ProfileEntityConstraintType
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::Constraint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::Constraint2 Property
ProfileEntity::Constraint2 Property
Collapse All

Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.

C#
public EntityVerticalConstraintType Constraint2;
Visual Basic
Public Property Constraint2() As EntityVerticalConstraintType
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::EndElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::EndElevation Property
ProfileEntity::EndElevation Property
Collapse All

Gets the curve end elevation.

C#
public double EndElevation;
Visual Basic
Public Property EndElevation() As double
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::EndStation Property
ProfileEntity::EndStation Property
Collapse All

Gets the curve end station.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::EntityAfter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::EntityAfter Property
ProfileEntity::EntityAfter Property
Collapse All

Gets the ID of the profile entity that follows the current entity.

C#
public unsigned int EntityAfter;
Visual Basic
Public Property EntityAfter() As unsigned int
Exceptions
Exceptions | Description
Autodesk::Civil::EntityNotFoundException | Throw when the entity is the last one in the collection.
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::EntityBefore Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::EntityBefore Property
ProfileEntity::EntityBefore Property
Collapse All

Gets the ID of the profile entity that precedes the current entity.

C#
public unsigned int EntityBefore;
Visual Basic
Public Property EntityBefore() As unsigned int
Exceptions
Exceptions | Description
Autodesk::Civil::EntityNotFoundException | Throw when the entity is the first one in the collection.
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::EntityId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::EntityId Property
ProfileEntity::EntityId Property
Collapse All

Gets the identifier of the profile entity.

C#
public unsigned int EntityId;
Visual Basic
Public Property EntityId() As unsigned int
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::EntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::EntityType Property
ProfileEntity::EntityType Property
Collapse All

Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric

C#
public ProfileEntityType EntityType;
Visual Basic
Public Property EntityType() As ProfileEntityType
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::HighestDesignSpeed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::HighestDesignSpeed Property
ProfileEntity::HighestDesignSpeed Property
Collapse All

Returns the highest speed in the station range.

C#
public double HighestDesignSpeed;
Visual Basic
Public Property HighestDesignSpeed() As double
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::Length Property
ProfileEntity::Length Property
Collapse All

Gets or sets the curve length.

C#
public double Length;
Visual Basic
Public Property Length() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The property is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::MinimumKValueHSD Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::MinimumKValueHSD Property
ProfileEntity::MinimumKValueHSD Property
Collapse All

Gets the minimum K value for headlight sight distance.

C#
public double MinimumKValueHSD;
Visual Basic
Public Property MinimumKValueHSD() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property is not supported by the entity or invalid according to entity's constraint type (this is only used for Sag curve).
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::MinimumKValuePSD Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::MinimumKValuePSD Property
ProfileEntity::MinimumKValuePSD Property
Collapse All

Gets the minimum K value for passing sight distance.

C#
public double MinimumKValuePSD;
Visual Basic
Public Property MinimumKValuePSD() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property is not supported by the entity or invalid according to entity's constraint type (this is only used for Crest curve).
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::MinimumKValueSSD Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::MinimumKValueSSD Property
ProfileEntity::MinimumKValueSSD Property
Collapse All

Gets the minimum K value for stopping sight distance.

C#
public double MinimumKValueSSD;
Visual Basic
Public Property MinimumKValueSSD() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property is not supported by the entity or invalid according to entity's constraint type (this is only used for Crest curve).
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::StartElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::StartElevation Property
ProfileEntity::StartElevation Property
Collapse All

Gets the curve start elevation.

C#
public double StartElevation;
Visual Basic
Public Property StartElevation() As double
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntity::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties > ProfileEntity::StartStation Property
ProfileEntity::StartStation Property
Collapse All

Gets the curve start station.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
ProfileEntity Class, ProfileEntity Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class
ProfileEntityCollection Class
Collapse All

The ProfileEntity collection class. This class represents the collection of all ProfileEntity objects that belong to the Profile.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntityCollection
C#
public class ProfileEntityCollection : CivilWrapper<AeccDbVAlignment>, System::Collections::Generic::IEnumerable<ProfileEntity^>;
Visual Basic
Public Class ProfileEntityCollection
Inherits CivilWrapper<AeccDbVAlignment>
Inherits System::Collections::Generic::IEnumerable<ProfileEntity^>
Links
ProfileEntityCollection Methods, ProfileEntityCollection Properties, ProfileEntityCollection Members, Class Hierarchy


ProfileEntityCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Members
ProfileEntityCollection Members
Collapse All

The following tables list the members exposed by ProfileEntityCollection.

Public Methods
Public Method | Description
AddFixedSymmetricParabolaByEntityEndAndThroughPoint | Creates a fixed Symmetric Parabola defined by the entity to attach to and pass-through point.
AddFixedSymmetricParabolaByThreePoints | Creates a fixed Symmetric Parabola defined by 3 pass-through points.
AddFixedSymmetricParabolaByTwoPointsAndEndGrade | Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the end point.
AddFixedSymmetricParabolaByTwoPointsAndK | Creates a fixed Symmetric Parabola defined by 2 pass-through points and K value.
AddFixedSymmetricParabolaByTwoPointsAndRadius | Creates a fixed Symmetric Parabola defined by 2 pass-through points and radius.
AddFixedSymmetricParabolaByTwoPointsAndStartGrade | Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the start point.
AddFixedTangent | Creates a fixed Tangent defined by 2 pass-through points.
AddFixedTangentWithPreviousEntity | Creates a fixed Tangent defined by 2 pass-through points and previous entity id.
AddFloatingSymmetricParabolaByThroughPointAndGrade | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the grade value at... more
AddFloatingSymmetricParabolaByThroughPointAndK | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the K value.
AddFloatingSymmetricParabolaByThroughPointAndRadius | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the radius value.
AddFloatingTangent | Creates a floating Tangent defined by an entity and a pass-through point, whether to append or prepend to the specified... more
AddFreeAsymmetricParabolaByPVIAndLengths | Creates a free Asymmetric Parabola constrained by a PVI and 2 parabola lengths.
AddFreeCircularCurveByPVIAndLength | Creates a free Circular Curve constrained by a PVI and length.
AddFreeCircularCurveByPVIAndRadius | Creates a free Circular Curve constrained by a PVI and radius.
AddFreeCircularCurveByPVIAndThroughPoint | Creates a free Circular Curve constrained by a PVI and a pass-through point.
AddFreeSymmetricParabolaByK | Creates a free Symmetric Parabola between two entities and the K value.
AddFreeSymmetricParabolaByLength | Creates a free Symmetric Parabola between two entities and curve length.
AddFreeSymmetricParabolaByPVIAndCurveLength | Creates a free Symmetric Parabola constrained by a PVI and curve length.
AddFreeSymmetricParabolaByPVIAndK | Creates a free Symmetric Parabola constrained by a PVI and K value.
AddFreeSymmetricParabolaByPVIAndThroughPoint | Creates a free Symmetric Parabola constrained by a PVI and a pass-through point.
AddFreeSymmetricParabolaByRadius | Creates a free Symmetric Parabola between two entities and the radius value.
AddFreeTangent | Creates a free Tangent between two entities.
Clear | Removes all Profile entities from the collection.
EntityAtId | Returns the ProfileEntity specified by ID.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes from the collection by the specified entity object.
RemoveAt | Removes from the collection by the specified index.
Public Properties
Public Property | Description
Count | Gets the number of ProfileEntity objects in the collection.
default | Gets the ProfileEntity object at a specified index in the collection.
FirstEntity | Gets the ID of the first ProfileEntity in the collection.
LastEntity | Gets the ID of the last ProfileEntity in the collection.
Links
Public Methods, Public Properties


ProfileEntityCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods
ProfileEntityCollection Methods
Collapse All

The methods of ProfileEntityCollection are listed here.

Public Methods
Public Method | Description
AddFixedSymmetricParabolaByEntityEndAndThroughPoint | Creates a fixed Symmetric Parabola defined by the entity to attach to and pass-through point.
AddFixedSymmetricParabolaByThreePoints | Creates a fixed Symmetric Parabola defined by 3 pass-through points.
AddFixedSymmetricParabolaByTwoPointsAndEndGrade | Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the end point.
AddFixedSymmetricParabolaByTwoPointsAndK | Creates a fixed Symmetric Parabola defined by 2 pass-through points and K value.
AddFixedSymmetricParabolaByTwoPointsAndRadius | Creates a fixed Symmetric Parabola defined by 2 pass-through points and radius.
AddFixedSymmetricParabolaByTwoPointsAndStartGrade | Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the start point.
AddFixedTangent | Creates a fixed Tangent defined by 2 pass-through points.
AddFixedTangentWithPreviousEntity | Creates a fixed Tangent defined by 2 pass-through points and previous entity id.
AddFloatingSymmetricParabolaByThroughPointAndGrade | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the grade value at... more
AddFloatingSymmetricParabolaByThroughPointAndK | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the K value.
AddFloatingSymmetricParabolaByThroughPointAndRadius | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the radius value.
AddFloatingTangent | Creates a floating Tangent defined by an entity and a pass-through point, whether to append or prepend to the specified... more
AddFreeAsymmetricParabolaByPVIAndLengths | Creates a free Asymmetric Parabola constrained by a PVI and 2 parabola lengths.
AddFreeCircularCurveByPVIAndLength | Creates a free Circular Curve constrained by a PVI and length.
AddFreeCircularCurveByPVIAndRadius | Creates a free Circular Curve constrained by a PVI and radius.
AddFreeCircularCurveByPVIAndThroughPoint | Creates a free Circular Curve constrained by a PVI and a pass-through point.
AddFreeSymmetricParabolaByK | Creates a free Symmetric Parabola between two entities and the K value.
AddFreeSymmetricParabolaByLength | Creates a free Symmetric Parabola between two entities and curve length.
AddFreeSymmetricParabolaByPVIAndCurveLength | Creates a free Symmetric Parabola constrained by a PVI and curve length.
AddFreeSymmetricParabolaByPVIAndK | Creates a free Symmetric Parabola constrained by a PVI and K value.
AddFreeSymmetricParabolaByPVIAndThroughPoint | Creates a free Symmetric Parabola constrained by a PVI and a pass-through point.
AddFreeSymmetricParabolaByRadius | Creates a free Symmetric Parabola between two entities and the radius value.
AddFreeTangent | Creates a free Tangent between two entities.
Clear | Removes all Profile entities from the collection.
EntityAtId | Returns the ProfileEntity specified by ID.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes from the collection by the specified entity object.
RemoveAt | Removes from the collection by the specified index.
Links
Public Methods


ProfileEntityCollection::AddFixedSymmetricParabolaByEntityEndAndThroughPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFixedSymmetricParabolaByEntityEndAndThroughPoint Method
ProfileEntityCollection::AddFixedSymmetricParabolaByEntityEndAndThroughPoint Method
Collapse All

Creates a fixed Symmetric Parabola defined by the entity to attach to and pass-through point.

C#
public ProfileParabolaSymmetric AddFixedSymmetricParabolaByEntityEndAndThroughPoint(
    unsigned int attachEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passPoint
);
Visual Basic
Public Function AddFixedSymmetricParabolaByEntityEndAndThroughPoint(
    attachEntityId As unsigned int,
    passPoint As Autodesk::AutoCAD::Geometry::Point3d
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
attachEntityId | Id of the entity to attach to.
passPoint | The pass-through point.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFixedSymmetricParabolaByThreePoints Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFixedSymmetricParabolaByThreePoints Method
ProfileEntityCollection::AddFixedSymmetricParabolaByThreePoints Method
Collapse All

Creates a fixed Symmetric Parabola defined by 3 pass-through points.

C#
public ProfileParabolaSymmetric AddFixedSymmetricParabolaByThreePoints(
    Autodesk::AutoCAD::Geometry::Point3d point,
    Autodesk::AutoCAD::Geometry::Point3d point2,
    Autodesk::AutoCAD::Geometry::Point3d point3
);
Visual Basic
Public Function AddFixedSymmetricParabolaByThreePoints(
    point As Autodesk::AutoCAD::Geometry::Point3d,
    point2 As Autodesk::AutoCAD::Geometry::Point3d,
    point3 As Autodesk::AutoCAD::Geometry::Point3d
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
point | The first pass-through point.
point2 | The second pass-through point.
point3 | The third pass-through point.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndEndGrade Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndEndGrade Method
ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndEndGrade Method
Collapse All

Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the end point.

C#
public ProfileParabolaSymmetric AddFixedSymmetricParabolaByTwoPointsAndEndGrade(
    Autodesk::AutoCAD::Geometry::Point3d point1,
    Autodesk::AutoCAD::Geometry::Point3d point2,
    double endGrade
);
Visual Basic
Public Function AddFixedSymmetricParabolaByTwoPointsAndEndGrade(
    point1 As Autodesk::AutoCAD::Geometry::Point3d,
    point2 As Autodesk::AutoCAD::Geometry::Point3d,
    endGrade As double
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
point1 | The first pass-through point.
point2 | The second pass-through point.
endGrade | The grade at the end point.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndK Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndK Method
ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndK Method
Collapse All

Creates a fixed Symmetric Parabola defined by 2 pass-through points and K value.

C#
public ProfileParabolaSymmetric AddFixedSymmetricParabolaByTwoPointsAndK(
    Autodesk::AutoCAD::Geometry::Point3d point1,
    Autodesk::AutoCAD::Geometry::Point3d point2,
    VerticalCurveType curveType,
    double k
);
Visual Basic
Public Function AddFixedSymmetricParabolaByTwoPointsAndK(
    point1 As Autodesk::AutoCAD::Geometry::Point3d,
    point2 As Autodesk::AutoCAD::Geometry::Point3d,
    curveType As VerticalCurveType,
    k As double
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
point1 | The first pass-through point.
point2 | The second pass-through point.
curveType | Specifies the vertical curve type, crest or sag.
k | The K value.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndRadius Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndRadius Method
ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndRadius Method
Collapse All

Creates a fixed Symmetric Parabola defined by 2 pass-through points and radius.

C#
public ProfileParabolaSymmetric AddFixedSymmetricParabolaByTwoPointsAndRadius(
    Autodesk::AutoCAD::Geometry::Point3d point1,
    Autodesk::AutoCAD::Geometry::Point3d point2,
    VerticalCurveType curType,
    double radius
);
Visual Basic
Public Function AddFixedSymmetricParabolaByTwoPointsAndRadius(
    point1 As Autodesk::AutoCAD::Geometry::Point3d,
    point2 As Autodesk::AutoCAD::Geometry::Point3d,
    curType As VerticalCurveType,
    radius As double
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
point1 | The first pass-through point.
point2 | The second pass-through point.
curType | Specifies the vertical curve type, crest or sag.
radius | The radius value.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndStartGrade Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndStartGrade Method
ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndStartGrade Method
Collapse All

Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the start point.

C#
public ProfileParabolaSymmetric AddFixedSymmetricParabolaByTwoPointsAndStartGrade(
    Autodesk::AutoCAD::Geometry::Point3d point1,
    Autodesk::AutoCAD::Geometry::Point3d point2,
    double startGrade
);
Visual Basic
Public Function AddFixedSymmetricParabolaByTwoPointsAndStartGrade(
    point1 As Autodesk::AutoCAD::Geometry::Point3d,
    point2 As Autodesk::AutoCAD::Geometry::Point3d,
    startGrade As double
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
point1 | The first pass-through point.
point2 | The second pass-through point.
startGrade | The grade at the start point.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFixedTangent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFixedTangent Method
ProfileEntityCollection::AddFixedTangent Method
Collapse All

Creates a fixed Tangent defined by 2 pass-through points.

C#
public ProfileTangent AddFixedTangent(
    Autodesk::AutoCAD::Geometry::Point3d startPoint,
    Autodesk::AutoCAD::Geometry::Point3d endPoint
);
Visual Basic
Public Function AddFixedTangent(
    startPoint As Autodesk::AutoCAD::Geometry::Point3d,
    endPoint As Autodesk::AutoCAD::Geometry::Point3d
) As ProfileTangent
Parameters
Parameters | Description
startPoint | The first pass-through point.
endPoint | The second pass-through point.
Example
// Now add the entities that define the profile.
Profile oProfile = ts.GetObject(oProfileId, OpenMode.ForRead) as Profile;

Point3d startPoint = new Point3d(oAlignment.StartingStation, -40, 0);
Point3d endPoint = new Point3d(758.2, -70, 0);
ProfileTangent oTangent1 = oProfile.Entities.AddFixedTangent(startPoint, endPoint);

startPoint = new Point3d(1508.2, -60.0, 0);
endPoint = new Point3d(oAlignment.EndingStation, -4.0, 0);
ProfileTangent oTangent2 = oProfile.Entities.AddFixedTangent(startPoint, endPoint);
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFixedTangentWithPreviousEntity Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFixedTangentWithPreviousEntity Method
ProfileEntityCollection::AddFixedTangentWithPreviousEntity Method
Collapse All

Creates a fixed Tangent defined by 2 pass-through points and previous entity id.

C#
public ProfileTangent AddFixedTangentWithPreviousEntity(
    unsigned int previousEntityId,
    Autodesk::AutoCAD::Geometry::Point3d startPoint,
    Autodesk::AutoCAD::Geometry::Point3d endPoint
);
Visual Basic
Public Function AddFixedTangentWithPreviousEntity(
    previousEntityId As unsigned int,
    startPoint As Autodesk::AutoCAD::Geometry::Point3d,
    endPoint As Autodesk::AutoCAD::Geometry::Point3d
) As ProfileTangent
Parameters
Parameters | Description
previousEntityId | Previous entity id to connect this entity. If previous entity is disconnected with the new entity, this parameter will be ommited.
startPoint | The first pass-through point.
endPoint | The second pass-through point.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndGrade Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndGrade Method
ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndGrade Method
Collapse All

Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the grade value at the end point.

C#
public ProfileParabolaSymmetric AddFloatingSymmetricParabolaByThroughPointAndGrade(
    unsigned int attachEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passPoint,
    double grade,
    EntityAttachType attachType
);
Visual Basic
Public Function AddFloatingSymmetricParabolaByThroughPointAndGrade(
    attachEntityId As unsigned int,
    passPoint As Autodesk::AutoCAD::Geometry::Point3d,
    grade As double,
    attachType As EntityAttachType
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
attachEntityId | The entity to attach to.
passPoint | The pass-through point.
grade | The grade value at the end point.
attachType | Specifies whether you want to append or prepend the new entity.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndK Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndK Method
ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndK Method
Collapse All

Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the K value.

C#
public ProfileParabolaSymmetric AddFloatingSymmetricParabolaByThroughPointAndK(
    unsigned int attachEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passPoint,
    double k,
    EntityAttachType attachType
);
Visual Basic
Public Function AddFloatingSymmetricParabolaByThroughPointAndK(
    attachEntityId As unsigned int,
    passPoint As Autodesk::AutoCAD::Geometry::Point3d,
    k As double,
    attachType As EntityAttachType
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
attachEntityId | The entity to attach to.
passPoint | The pass-through point.
k | The K value.
attachType | Specifies whether you want to append or prepend the new entity.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndRadius Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndRadius Method
ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndRadius Method
Collapse All

Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the radius value.

C#
public ProfileParabolaSymmetric AddFloatingSymmetricParabolaByThroughPointAndRadius(
    unsigned int attachEntityId,
    Autodesk::AutoCAD::Geometry::Point3d passPoint,
    double radius,
    EntityAttachType attachType
);
Visual Basic
Public Function AddFloatingSymmetricParabolaByThroughPointAndRadius(
    attachEntityId As unsigned int,
    passPoint As Autodesk::AutoCAD::Geometry::Point3d,
    radius As double,
    attachType As EntityAttachType
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
attachEntityId | The entity to attach to.
passPoint | The pass-through point.
radius | The radius
attachType | Specifies whether you want to append or prepend the new entity.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFloatingTangent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFloatingTangent Method
ProfileEntityCollection::AddFloatingTangent Method
Collapse All

Creates a floating Tangent defined by an entity and a pass-through point, whether to append or prepend to the specified entity is determined by the closest point to the passPoint.

C#
public ProfileTangent AddFloatingTangent(
    unsigned int entityId,
    Autodesk::AutoCAD::Geometry::Point3d passPoint,
    EntityAttachType attachType
);
Visual Basic
Public Function AddFloatingTangent(
    entityId As unsigned int,
    passPoint As Autodesk::AutoCAD::Geometry::Point3d,
    attachType As EntityAttachType
) As ProfileTangent
Parameters
Parameters | Description
entityId | Id of the entity to attach to.
passPoint | The pass-through point.
attachType | Specifies whether you want to append or prepend the new entity.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeAsymmetricParabolaByPVIAndLengths Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeAsymmetricParabolaByPVIAndLengths Method
ProfileEntityCollection::AddFreeAsymmetricParabolaByPVIAndLengths Method
Collapse All

Creates a free Asymmetric Parabola constrained by a PVI and 2 parabola lengths.

C#
public ProfileParabolaAsymmetric AddFreeAsymmetricParabolaByPVIAndLengths(
    ref ProfilePVI attachProfilePVI,
    double length1,
    double length2
);
Visual Basic
Public Function AddFreeAsymmetricParabolaByPVIAndLengths(
    ByRef attachProfilePVI As ProfilePVI,
    length1 As double,
    length2 As double
) As ProfileParabolaAsymmetric
Parameters
Parameters | Description
attachProfilePVI | The PVI to attach to.
length1 | The length of the parabola in.
length2 | The length of the parabola out.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the specified ProfilePVI already has curve attached, or it is at the end of the profile.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeCircularCurveByPVIAndLength Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeCircularCurveByPVIAndLength Method
ProfileEntityCollection::AddFreeCircularCurveByPVIAndLength Method
Collapse All

Creates a free Circular Curve constrained by a PVI and length.

C#
public ProfileCircular AddFreeCircularCurveByPVIAndLength(
    ref ProfilePVI attachProfilePVI,
    double length
);
Visual Basic
Public Function AddFreeCircularCurveByPVIAndLength(
    ByRef attachProfilePVI As ProfilePVI,
    length As double
) As ProfileCircular
Parameters
Parameters | Description
attachProfilePVI | The PVI to attach to
length | The length value.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the specified ProfilePVI already has curve attached, or it is at the end of the profile.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeCircularCurveByPVIAndRadius Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeCircularCurveByPVIAndRadius Method
ProfileEntityCollection::AddFreeCircularCurveByPVIAndRadius Method
Collapse All

Creates a free Circular Curve constrained by a PVI and radius.

C#
public ProfileCircular AddFreeCircularCurveByPVIAndRadius(
    ref ProfilePVI attachProfilePVI,
    double radius
);
Visual Basic
Public Function AddFreeCircularCurveByPVIAndRadius(
    ByRef attachProfilePVI As ProfilePVI,
    radius As double
) As ProfileCircular
Parameters
Parameters | Description
attachProfilePVI | The PVI to attach to.
radius | The radius value.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the specified ProfilePVI already has curve attached, or it is at the end of the profile.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeCircularCurveByPVIAndThroughPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeCircularCurveByPVIAndThroughPoint Method
ProfileEntityCollection::AddFreeCircularCurveByPVIAndThroughPoint Method
Collapse All

Creates a free Circular Curve constrained by a PVI and a pass-through point.

C#
public ProfileCircular AddFreeCircularCurveByPVIAndThroughPoint(
    ref ProfilePVI attachProfilePVI,
    Autodesk::AutoCAD::Geometry::Point3d passPoint
);
Visual Basic
Public Function AddFreeCircularCurveByPVIAndThroughPoint(
    ByRef attachProfilePVI As ProfilePVI,
    passPoint As Autodesk::AutoCAD::Geometry::Point3d
) As ProfileCircular
Parameters
Parameters | Description
attachProfilePVI | The PVI to attach to.
passPoint | The pass-through point.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the specified ProfilePVI already has curve attached, or it is at the end of the profile.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeSymmetricParabolaByK Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeSymmetricParabolaByK Method
ProfileEntityCollection::AddFreeSymmetricParabolaByK Method
Collapse All

Creates a free Symmetric Parabola between two entities and the K value.

C#
public ProfileParabolaSymmetric AddFreeSymmetricParabolaByK(
    unsigned int previousEntityId,
    unsigned int nextEntityId,
    VerticalCurveType curveType,
    double k
);
Visual Basic
Public Function AddFreeSymmetricParabolaByK(
    previousEntityId As unsigned int,
    nextEntityId As unsigned int,
    curveType As VerticalCurveType,
    k As double
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
previousEntityId | The previous entity to attach to.
nextEntityId | The next entity to attach to.
curveType | The vertical curve type, crest or sag.
k | The K value.
Remarks

The parameter curveType is only applicable when it is added between two ProfileParabolaSymmetric.

Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeSymmetricParabolaByLength Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeSymmetricParabolaByLength Method
ProfileEntityCollection::AddFreeSymmetricParabolaByLength Method
Collapse All

Creates a free Symmetric Parabola between two entities and curve length.

C#
public ProfileParabolaSymmetric AddFreeSymmetricParabolaByLength(
    unsigned int previousEntityId,
    unsigned int nextEntityId,
    VerticalCurveType curveType,
    double length,
    bool preferFlat
);
Visual Basic
Public Function AddFreeSymmetricParabolaByLength(
    previousEntityId As unsigned int,
    nextEntityId As unsigned int,
    curveType As VerticalCurveType,
    length As double,
    preferFlat As bool
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
previousEntityId | The previous entity to attach to.
nextEntityId | The next entity to attach to.
curveType | The vertical curve type, crest or sag.
length | The curve length.
preferFlat | Specifies whether to choose the flat curve if two solutions are available. Steep curve is preferred if preferFlat is false.
Remarks

The parameter curveType is applicable when it is added between two ProfileParabolaSymmetric. The parameter preferFlat is applicable when it is added between ProfileTangent and ProfileparabolaSymmetric.

Example
Dim dCrestLen As Double
dCrestLen = 900.1
oProfile.Entities.AddFreeSymmetricParabolaByLength(oProfileTangent1.EntityId, oProfileTangent2.EntityId, VerticalCurveType.Sag, dCrestLen, True)
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndCurveLength Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndCurveLength Method
ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndCurveLength Method
Collapse All

Creates a free Symmetric Parabola constrained by a PVI and curve length.

C#
public ProfileParabolaSymmetric AddFreeSymmetricParabolaByPVIAndCurveLength(
    ref ProfilePVI attachProfilePVI,
    double curveLength
);
Visual Basic
Public Function AddFreeSymmetricParabolaByPVIAndCurveLength(
    ByRef attachProfilePVI As ProfilePVI,
    curveLength As double
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
attachProfilePVI | The PVI to attach to.
curveLength | The curve length.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the specified ProfilePVI already has curve attached, or it is at the end of the profile.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndK Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndK Method
ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndK Method
Collapse All

Creates a free Symmetric Parabola constrained by a PVI and K value.

C#
public ProfileParabolaSymmetric AddFreeSymmetricParabolaByPVIAndK(
    ref ProfilePVI attachProfilePVI,
    double k
);
Visual Basic
Public Function AddFreeSymmetricParabolaByPVIAndK(
    ByRef attachProfilePVI As ProfilePVI,
    k As double
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
attachProfilePVI | The PVI to attach to.
k | The K value.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the specified ProfilePVI already has curve attached, or it is at the end of the profile.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndThroughPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndThroughPoint Method
ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndThroughPoint Method
Collapse All

Creates a free Symmetric Parabola constrained by a PVI and a pass-through point.

C#
public ProfileParabolaSymmetric AddFreeSymmetricParabolaByPVIAndThroughPoint(
    ref ProfilePVI attachProfilePVI,
    Autodesk::AutoCAD::Geometry::Point3d passPoint
);
Visual Basic
Public Function AddFreeSymmetricParabolaByPVIAndThroughPoint(
    ByRef attachProfilePVI As ProfilePVI,
    passPoint As Autodesk::AutoCAD::Geometry::Point3d
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
attachProfilePVI | The PVI to attach to.
passPoint | The pass-through point.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the specified ProfilePVI already has curve attached, or it is at the end of the profile.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeSymmetricParabolaByRadius Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeSymmetricParabolaByRadius Method
ProfileEntityCollection::AddFreeSymmetricParabolaByRadius Method
Collapse All

Creates a free Symmetric Parabola between two entities and the radius value.

C#
public ProfileParabolaSymmetric AddFreeSymmetricParabolaByRadius(
    unsigned int previousEntityId,
    unsigned int nextEntityId,
    VerticalCurveType curveType,
    double radius
);
Visual Basic
Public Function AddFreeSymmetricParabolaByRadius(
    previousEntityId As unsigned int,
    nextEntityId As unsigned int,
    curveType As VerticalCurveType,
    radius As double
) As ProfileParabolaSymmetric
Parameters
Parameters | Description
previousEntityId | The previous entity to attach to.
nextEntityId | The next entity to attach to.
curveType | The vertical curve type, crest or sag.
radius | The radius value.
Remarks

The parameter curveType is applicable when it is added between two ProfileParabolaSymmetric.

Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::AddFreeTangent Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::AddFreeTangent Method
ProfileEntityCollection::AddFreeTangent Method
Collapse All

Creates a free Tangent between two entities.

C#
public ProfileTangent AddFreeTangent(
    unsigned int previousEntityId,
    unsigned int nextEntityId
);
Visual Basic
Public Function AddFreeTangent(
    previousEntityId As unsigned int,
    nextEntityId As unsigned int
) As ProfileTangent
Parameters
Parameters | Description
previousEntityId | Id of the previous entity to attach to.
nextEntityId | Id of the next entity to attach to.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::Clear Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::Clear Method
ProfileEntityCollection::Clear Method
Collapse All

Removes all Profile entities from the collection.

C#
public Clear();
Visual Basic
Public Sub Clear()
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::EntityAtId Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::EntityAtId Method
ProfileEntityCollection::EntityAtId Method
Collapse All

Returns the ProfileEntity specified by ID.

C#
public ProfileEntity EntityAtId(
    unsigned int id
);
Visual Basic
Public Function EntityAtId(
    id As unsigned int
) As ProfileEntity
Parameters
Parameters | Description
id | The integer ID for the ProfileEntity. Which is unique in a collection.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::GetEnumerator Method
ProfileEntityCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<ProfileEntity^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<ProfileEntity^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::GetObjectEnumerator Method
ProfileEntityCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::Remove Method
ProfileEntityCollection::Remove Method
Collapse All

Removes from the collection by the specified entity object.

C#
public Remove(
    ref ProfileEntity entity
);
Visual Basic
Public Sub Remove(
    ByRef entity As ProfileEntity
)
Parameters
Parameters | Description
entity | Specifies the entity of the ProfileEntity to remove.
Exceptions
Exceptions | Description
System::ArgumentException | Throw when the specified entity cannot be found in the collection.
System::InvalidOperationException | Throw when there are other entities depending on it.( floating, free constraints).
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods > ProfileEntityCollection::RemoveAt Method
ProfileEntityCollection::RemoveAt Method
Collapse All

Removes from the collection by the specified index.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Specifies index in the collection to remove.
Exceptions
Exceptions | Description
System::ArgumentException | Throw when the specified entity cannot be found in the collection.
System::InvalidOperationException | Throw when there are other entities depending on it.( floating, free constraints).
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Properties
ProfileEntityCollection Properties
Collapse All

The properties of ProfileEntityCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of ProfileEntity objects in the collection.
default | Gets the ProfileEntity object at a specified index in the collection.
FirstEntity | Gets the ID of the first ProfileEntity in the collection.
LastEntity | Gets the ID of the last ProfileEntity in the collection.
Links
Public Properties


ProfileEntityCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Properties > ProfileEntityCollection::Count Property
ProfileEntityCollection::Count Property
Collapse All

Gets the number of ProfileEntity objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Properties > ProfileEntityCollection::default Property
ProfileEntityCollection::default Property
Collapse All

Gets the ProfileEntity object at a specified index in the collection.

C#
public ProfileEntity default;
Visual Basic
Public Property default() As ProfileEntity
Parameters
Parameters | Description
index | Profile entity index.
Remarks

The returned entity object is an instance of a concrete entity type (e.g. ProfileEntityCircular), which is derived from the abstract class ProfileEntity.

Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when index is out of collection range.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::FirstEntity Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Properties > ProfileEntityCollection::FirstEntity Property
ProfileEntityCollection::FirstEntity Property
Collapse All

Gets the ID of the first ProfileEntity in the collection.

C#
public unsigned int FirstEntity;
Visual Basic
Public Property FirstEntity() As unsigned int
Exceptions
Exceptions | Description
Autodesk::Civil::EntityNotFoundException | Throw when the collection is empty.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileEntityCollection::LastEntity Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Properties > ProfileEntityCollection::LastEntity Property
ProfileEntityCollection::LastEntity Property
Collapse All

Gets the ID of the last ProfileEntity in the collection.

C#
public unsigned int LastEntity;
Visual Basic
Public Property LastEntity() As unsigned int
Exceptions
Exceptions | Description
Autodesk::Civil::EntityNotFoundException | Throw when the collection is empty.
Links
ProfileEntityCollection Class, ProfileEntityCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchArea Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class
ProfileHatchArea Class
Collapse All

The ProfilevHatchArea class.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileHatchArea
C#
public class ProfileHatchArea : CivilWrapper<AeccDbGraphProfile>;
Visual Basic
Public Class ProfileHatchArea
Inherits CivilWrapper<AeccDbGraphProfile>
Links
ProfileHatchArea Properties, ProfileHatchArea Members, Class Hierarchy


ProfileHatchArea Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Members
ProfileHatchArea Members
Collapse All

The following tables list the members exposed by ProfileHatchArea.

Public Properties
Public Property | Description
Criteria | Gets the collection of hatch area criteria in the profile hatch area.
Name | Gets or Sets the profile hatch area's name.
ShapeStyleId | Gets or Sets the profile hatch area's shape style id.
ShapeStyleName | Gets or Sets the profile hatch area's shape style name.
Links
Public Properties


ProfileHatchArea Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Properties
ProfileHatchArea Properties
Collapse All

The properties of ProfileHatchArea are listed here.

Public Properties
Public Property | Description
Criteria | Gets the collection of hatch area criteria in the profile hatch area.
Name | Gets or Sets the profile hatch area's name.
ShapeStyleId | Gets or Sets the profile hatch area's shape style id.
ShapeStyleName | Gets or Sets the profile hatch area's shape style name.
Links
Public Properties


ProfileHatchArea::Criteria Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Properties > ProfileHatchArea::Criteria Property
ProfileHatchArea::Criteria Property
Collapse All

Gets the collection of hatch area criteria in the profile hatch area.

C#
public ProfileCriteriaCollection Criteria;
Visual Basic
Public Property Criteria() As ProfileCriteriaCollection
Links
ProfileHatchArea Class, ProfileHatchArea Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchArea::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Properties > ProfileHatchArea::Name Property
ProfileHatchArea::Name Property
Collapse All

Gets or Sets the profile hatch area's name.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the setting the property with a duplicate profile hatch area name.
Links
ProfileHatchArea Class, ProfileHatchArea Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchArea::ShapeStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Properties > ProfileHatchArea::ShapeStyleId Property
ProfileHatchArea::ShapeStyleId Property
Collapse All

Gets or Sets the profile hatch area's shape style id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ShapeStyleId;
Visual Basic
Public Property ShapeStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle.
Links
ProfileHatchArea Class, ProfileHatchArea Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchArea::ShapeStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Properties > ProfileHatchArea::ShapeStyleName Property
ProfileHatchArea::ShapeStyleName Property
Collapse All

Gets or Sets the profile hatch area's shape style name.

C#
public System::String ShapeStyleName;
Visual Basic
Public Property ShapeStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the shape style name is invalid.
Links
ProfileHatchArea Class, ProfileHatchArea Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchAreaCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class
ProfileHatchAreaCollection Class
Collapse All

The ProfileHatchAreaCollection class represents the collection of all hatch areas in the ProfileView.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileHatchAreaCollection
C#
public class ProfileHatchAreaCollection : CivilWrapper<AeccDbGraphProfile>, System::Collections::Generic::IEnumerable<ProfileHatchArea^>;
Visual Basic
Public Class ProfileHatchAreaCollection
Inherits CivilWrapper<AeccDbGraphProfile>
Inherits System::Collections::Generic::IEnumerable<ProfileHatchArea^>
Links
ProfileHatchAreaCollection Methods, ProfileHatchAreaCollection Properties, ProfileHatchAreaCollection Members, Class Hierarchy


ProfileHatchAreaCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Members
ProfileHatchAreaCollection Members
Collapse All

The following tables list the members exposed by ProfileHatchAreaCollection.

Public Methods
Public Method | Description
Add | Adds an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea to the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea by the hatch area name from the collection.
Public Properties
Public Property | Description
Count | Gets the number of ProfileHatchArea objects in the collection.
default | Gets the ProfileHatchArea at a specified index in the collection.
Links
Public Methods, Public Properties


ProfileHatchAreaCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Methods
ProfileHatchAreaCollection Methods
Collapse All

The methods of ProfileHatchAreaCollection are listed here.

Public Methods
Public Method | Description
Add | Adds an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea to the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea by the hatch area name from the collection.
Links
Public Methods


ProfileHatchAreaCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Methods > ProfileHatchAreaCollection::Add Method
ProfileHatchAreaCollection::Add Method
Collapse All

Adds an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea to the collection.

C#
public Add(
    ref System::String hatchAreaName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId upperProfileId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId lowerProfileId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId shapeStyleId
);
Visual Basic
Public Sub Add(
    ByRef hatchAreaName As System::String,
    upperProfileId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    lowerProfileId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    shapeStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
hatchAreaName | Profile hatch area name.
upperProfileId | Profile hatch area criteria's upper boundary object id.
lowerProfileId | Profile hatch area criteria's lower boundary object id.
shapeStyleId | Profile hatch area's shape style id.
Links
ProfileHatchAreaCollection Class, ProfileHatchAreaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchAreaCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Methods > ProfileHatchAreaCollection::GetEnumerator Method
ProfileHatchAreaCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<ProfileHatchArea^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<ProfileHatchArea^>
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileHatchAreaCollection Class, ProfileHatchAreaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchAreaCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Methods > ProfileHatchAreaCollection::GetObjectEnumerator Method
ProfileHatchAreaCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileHatchAreaCollection Class, ProfileHatchAreaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchAreaCollection::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Methods > ProfileHatchAreaCollection::Remove Method
ProfileHatchAreaCollection::Remove Method
Collapse All

Removes an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea by the hatch area name from the collection.

C#
public Remove(
    ref System::String hatchAreaName
);
Visual Basic
Public Sub Remove(
    ByRef hatchAreaName As System::String
)
Parameters
Parameters | Description
hatchAreaName | Profile hatch area name to remove.
Links
ProfileHatchAreaCollection Class, ProfileHatchAreaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchAreaCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Properties
ProfileHatchAreaCollection Properties
Collapse All

The properties of ProfileHatchAreaCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of ProfileHatchArea objects in the collection.
default | Gets the ProfileHatchArea at a specified index in the collection.
Links
Public Properties


ProfileHatchAreaCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Properties > ProfileHatchAreaCollection::Count Property
ProfileHatchAreaCollection::Count Property
Collapse All

Gets the number of ProfileHatchArea objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ProfileHatchAreaCollection Class, ProfileHatchAreaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileHatchAreaCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Properties > ProfileHatchAreaCollection::default Property
ProfileHatchAreaCollection::default Property
Collapse All

Gets the ProfileHatchArea at a specified index in the collection.

C#
public ProfileHatchArea default;
Visual Basic
Public Property default() As ProfileHatchArea
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the collection's range.
Links
ProfileHatchAreaCollection Class, ProfileHatchAreaCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverride Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class
ProfileOverride Class
Collapse All

Object used to change the style or label set for a profile.

Class Hierarchy
Autodesk::Civil::DatabaseServices::GraphOverride
    Autodesk::Civil::Land::DatabaseServices::ProfileOverride
C#
public class ProfileOverride : Autodesk::Civil::DatabaseServices::GraphOverride;
Visual Basic
Public Class ProfileOverride
Inherits Autodesk::Civil::DatabaseServices::GraphOverride
Remarks

Each ProfileOverride object represents an individual profile in a profile view.

Links
ProfileOverride Methods, ProfileOverride Properties, ProfileOverride Members, Class Hierarchy


ProfileOverride Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Members
ProfileOverride Members
Collapse All

The following tables list the members exposed by ProfileOverride.

Public Methods
Public Method | Description
GetLabelGroupIds | Gets the ObjectIdCollection of the Profile's label group.
Public Properties
Public Property | Description
Draw | Gets or sets whether this entity will be drawn in the graph.
OverrideStyleId | Sets the override style of the entity.
OverrideStyleName | Sets the override style of the entity.
ProfileId | Gets the object id of the profile.
ProfileName | Gets the name of the profile.
UseOverrideStyle | Gets or sets whether to override style for the display of the entity.
Links
Public Methods, Public Properties


ProfileOverride Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Methods
ProfileOverride Methods
Collapse All

The methods of ProfileOverride are listed here.

Public Methods
Public Method | Description
GetLabelGroupIds | Gets the ObjectIdCollection of the Profile's label group.
Links
Public Methods


ProfileOverride::GetLabelGroupIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Methods > ProfileOverride::GetLabelGroupIds Method
ProfileOverride::GetLabelGroupIds Method
Collapse All

Gets the ObjectIdCollection of the Profile's label group.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetLabelGroupIds();
Visual Basic
Public Function GetLabelGroupIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
ProfileOverride Class, ProfileOverride Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverride Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Properties
ProfileOverride Properties
Collapse All

The properties of ProfileOverride are listed here.

Public Properties
Public Property | Description
OverrideStyleId | Sets the override style of the entity.
OverrideStyleName | Sets the override style of the entity.
ProfileId | Gets the object id of the profile.
ProfileName | Gets the name of the profile.
Links
Public Properties


ProfileOverride::OverrideStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Properties > ProfileOverride::OverrideStyleId Property
ProfileOverride::OverrideStyleId Property
Collapse All

Sets the override style of the entity.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId OverrideStyleId;
Visual Basic
Public Property OverrideStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.ProfileStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not ProfileStyle.
Links
ProfileOverride Class, ProfileOverride Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverride::OverrideStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Properties > ProfileOverride::OverrideStyleName Property
ProfileOverride::OverrideStyleName Property
Collapse All

Sets the override style of the entity.

C#
public System::String OverrideStyleName;
Visual Basic
Public Property OverrideStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object which type is not ProfileStyle.
Links
ProfileOverride Class, ProfileOverride Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverride::ProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Properties > ProfileOverride::ProfileId Property
ProfileOverride::ProfileId Property
Collapse All

Gets the object id of the profile.

C#
public ObjectId ProfileId;
Visual Basic
Public Property ProfileId() As ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile.

Links
ProfileOverride Class, ProfileOverride Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverride::ProfileName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Properties > ProfileOverride::ProfileName Property
ProfileOverride::ProfileName Property
Collapse All

Gets the name of the profile.

C#
public System::String ProfileName;
Visual Basic
Public Property ProfileName() As System::String
Links
ProfileOverride Class, ProfileOverride Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverrideCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class
ProfileOverrideCollection Class
Collapse All

The ProfileOverride collection class represents the collection of all profiles listed in the ProfileView.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileOverrideCollection
C#
public class ProfileOverrideCollection : CivilWrapper<AeccDbGraphProfile>, System::Collections::Generic::IEnumerable<ProfileOverride^>;
Visual Basic
Public Class ProfileOverrideCollection
Inherits CivilWrapper<AeccDbGraphProfile>
Inherits System::Collections::Generic::IEnumerable<ProfileOverride^>
Links
ProfileOverrideCollection Methods, ProfileOverrideCollection Properties, ProfileOverrideCollection Members, Class Hierarchy


ProfileOverrideCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Members
ProfileOverrideCollection Members
Collapse All

The following tables list the members exposed by ProfileOverrideCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Public Properties
Public Property | Description
ClipGridAt | Gets or sets which profile controls the size of the profile view grid.
Count | Gets the number of ProfileOverride objects in the collection.
default | Gets the ProfileOverride at a specified index in the collection.
SplitAt | Gets or sets which profile to favor when splitting a profile view containing multiple profiles.
Links
Public Methods, Public Properties


ProfileOverrideCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Methods
ProfileOverrideCollection Methods
Collapse All

The methods of ProfileOverrideCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Links
Public Methods


ProfileOverrideCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Methods > ProfileOverrideCollection::GetEnumerator Method
ProfileOverrideCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<ProfileOverride^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<ProfileOverride^>
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileOverrideCollection Class, ProfileOverrideCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverrideCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Methods > ProfileOverrideCollection::GetObjectEnumerator Method
ProfileOverrideCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileOverrideCollection Class, ProfileOverrideCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverrideCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Properties
ProfileOverrideCollection Properties
Collapse All

The properties of ProfileOverrideCollection are listed here.

Public Properties
Public Property | Description
ClipGridAt | Gets or sets which profile controls the size of the profile view grid.
Count | Gets the number of ProfileOverride objects in the collection.
default | Gets the ProfileOverride at a specified index in the collection.
SplitAt | Gets or sets which profile to favor when splitting a profile view containing multiple profiles.
Links
Public Properties


ProfileOverrideCollection::ClipGridAt Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Properties > ProfileOverrideCollection::ClipGridAt Property
ProfileOverrideCollection::ClipGridAt Property
Collapse All

Gets or sets which profile controls the size of the profile view grid.

C#
public System::String ClipGridAt;
Visual Basic
Public Property ClipGridAt() As System::String
Remarks

True: lines are drawn below the profile or cross section line, but not above. False: lines are drawn for the full height of the grid.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input profile name cannot be found in the collection.
Links
ProfileOverrideCollection Class, ProfileOverrideCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverrideCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Properties > ProfileOverrideCollection::Count Property
ProfileOverrideCollection::Count Property
Collapse All

Gets the number of ProfileOverride objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ProfileOverrideCollection Class, ProfileOverrideCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverrideCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Properties > ProfileOverrideCollection::default Property
ProfileOverrideCollection::default Property
Collapse All

Gets the ProfileOverride at a specified index in the collection.

C#
public ProfileOverride default;
Visual Basic
Public Property default() As ProfileOverride
Links
ProfileOverrideCollection Class, ProfileOverrideCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileOverrideCollection::SplitAt Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Properties > ProfileOverrideCollection::SplitAt Property
ProfileOverrideCollection::SplitAt Property
Collapse All

Gets or sets which profile to favor when splitting a profile view containing multiple profiles.

C#
public System::String SplitAt;
Visual Basic
Public Property SplitAt() As System::String
Remarks

For example, a profile view often contains both existing ground and finished ground profiles. Selecting SplitAt for the finished ground profile ensures that split occurs at the finished ground profile elevation.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input profile name cannot be found in the collection.
Links
ProfileOverrideCollection Class, ProfileOverrideCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class
ProfileParabolaAsymmetric Class
Collapse All

The ProfileParabolaAsymmetric class. This class represents an ProfileEntity made up of a asymmetric parabola.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileParabolaAsymmetric
C#
public class ProfileParabolaAsymmetric : ProfileEntity;
Visual Basic
Public Class ProfileParabolaAsymmetric
Inherits ProfileEntity
Links
ProfileParabolaAsymmetric Properties, ProfileParabolaAsymmetric Members, Class Hierarchy


ProfileParabolaAsymmetric Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Members
ProfileParabolaAsymmetric Members
Collapse All

The following tables list the members exposed by ProfileParabolaAsymmetric.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
AsymmetricLength1 | Gets or sets the length of the parabola in.
AsymmetricLength2 | Gets or sets the length of the parabola out.
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
CurveType | Gets the curve type, crest or sag.
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighestDesignSpeed | Returns the highest speed in the station range.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
Length | Gets or sets the curve length.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.
Links
Public Methods, Public Properties


ProfileParabolaAsymmetric Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties
ProfileParabolaAsymmetric Properties
Collapse All

The properties of ProfileParabolaAsymmetric are listed here.

Public Properties
Public Property | Description
AsymmetricLength1 | Gets or sets the length of the parabola in.
AsymmetricLength2 | Gets or sets the length of the parabola out.
CurveType | Gets the curve type, crest or sag.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.
Links
Public Properties


ProfileParabolaAsymmetric::AsymmetricLength1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::AsymmetricLength1 Property
ProfileParabolaAsymmetric::AsymmetricLength1 Property
Collapse All

Gets or sets the length of the parabola in.

C#
public double AsymmetricLength1;
Visual Basic
Public Property AsymmetricLength1() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The property is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::AsymmetricLength2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::AsymmetricLength2 Property
ProfileParabolaAsymmetric::AsymmetricLength2 Property
Collapse All

Gets or sets the length of the parabola out.

C#
public double AsymmetricLength2;
Visual Basic
Public Property AsymmetricLength2() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The property is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::CurveType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::CurveType Property
ProfileParabolaAsymmetric::CurveType Property
Collapse All

Gets the curve type, crest or sag.

C#
public VerticalCurveType CurveType;
Visual Basic
Public Property CurveType() As VerticalCurveType
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::EntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::EntityType Property
ProfileParabolaAsymmetric::EntityType Property
Collapse All

Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric

C#
public ProfileEntityType EntityType;
Visual Basic
Public Property EntityType() As ProfileEntityType
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::GradeChange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::GradeChange Property
ProfileParabolaAsymmetric::GradeChange Property
Collapse All

Gets the A value (Grade Change) between the end point and start point.

C#
public double GradeChange;
Visual Basic
Public Property GradeChange() As double
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::GradeIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::GradeIn Property
ProfileParabolaAsymmetric::GradeIn Property
Collapse All

Gets the grade at the start point.

C#
public double GradeIn;
Visual Basic
Public Property GradeIn() As double
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::GradeOut Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::GradeOut Property
ProfileParabolaAsymmetric::GradeOut Property
Collapse All

Gets the grade at the end point.

C#
public double GradeOut;
Visual Basic
Public Property GradeOut() As double
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::HighLowPointElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::HighLowPointElevation Property
ProfileParabolaAsymmetric::HighLowPointElevation Property
Collapse All

Gets the elevation value of the high/low point of the curve.

C#
public double HighLowPointElevation;
Visual Basic
Public Property HighLowPointElevation() As double
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::HighLowPointStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::HighLowPointStation Property
ProfileParabolaAsymmetric::HighLowPointStation Property
Collapse All

Gets the station value of the high/low point of the curve.

C#
public double HighLowPointStation;
Visual Basic
Public Property HighLowPointStation() As double
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::K Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::K Property
ProfileParabolaAsymmetric::K Property
Collapse All

Gets or sets the K value (Curve Coefficient) of the curve.

C#
public double K;
Visual Basic
Public Property K() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The property is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::PVIElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::PVIElevation Property
ProfileParabolaAsymmetric::PVIElevation Property
Collapse All

Gets the elevation value of the PVI this curve is associated with.

C#
public double PVIElevation;
Visual Basic
Public Property PVIElevation() As double
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::PVIStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::PVIStation Property
ProfileParabolaAsymmetric::PVIStation Property
Collapse All

Gets the station value of the PVI this curve is associated with.

C#
public double PVIStation;
Visual Basic
Public Property PVIStation() As double
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaAsymmetric::TangentOffsetAtPVI Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties > ProfileParabolaAsymmetric::TangentOffsetAtPVI Property
ProfileParabolaAsymmetric::TangentOffsetAtPVI Property
Collapse All

Gets the tangent offset value at the PVI the curve is associated with.

C#
public double TangentOffsetAtPVI;
Visual Basic
Public Property TangentOffsetAtPVI() As double
Links
ProfileParabolaAsymmetric Class, ProfileParabolaAsymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class
ProfileParabolaSymmetric Class
Collapse All

This class represents an ProfileEntity made up of a symmetric parabola.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileParabolaSymmetric
C#
public class ProfileParabolaSymmetric : ProfileEntity;
Visual Basic
Public Class ProfileParabolaSymmetric
Inherits ProfileEntity
Links
ProfileParabolaSymmetric Methods, ProfileParabolaSymmetric Properties, ProfileParabolaSymmetric Members, Class Hierarchy


ProfileParabolaSymmetric Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Members
ProfileParabolaSymmetric Members
Collapse All

The following tables list the members exposed by ProfileParabolaSymmetric.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
GetHeadlightSightDistance | Gets the headlight sight distance with the given headlight angle and headlight height.
GetPassingSightDistance | Gets the passing sight distance with the given eye height and object height.
GetStoppingSightDistance | Gets the stopping sight distance with the given eye height and object height.
SetHeadlightSightDistance | Sets the headlight sight distance with the given headlight angle and headlight height.
SetPassingSightDistance | Sets the passing sight distance with the given eye height and object height.
SetStoppingSightDistance | Sets the stopping sight distance with the given eye height and object height.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
CurveType | Gets the curve type, crest or sag.
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeAtThroughPoint1 | Gets or sets the grade value of the first pass-through point.
GradeAtThroughPoint2 | Gets or sets the grade value of the second pass-through point.
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighestDesignSpeed | Returns the highest speed in the station range.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
Length | Gets or sets the curve length.
M | Gets the M value of the curve.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
Radius | Gets or sets the radius of the curve.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.
ThroughPoint1Elevation | Gets or sets the elevation value of the first pass-through point.
ThroughPoint1Station | Gets or sets the station value of the first pass-through point.
ThroughPoint2Elevation | Gets or sets the elevation value of the second pass-through point.
ThroughPoint2Station | Gets or sets the station value of the second pass-through point.
ThroughPoint3Elevation | Gets or sets the elevation value of the third pass-through point.
ThroughPoint3Station | Gets or sets the station value of the third pass-through point.
Links
Public Methods, Public Properties


ProfileParabolaSymmetric Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Methods
ProfileParabolaSymmetric Methods
Collapse All

The methods of ProfileParabolaSymmetric are listed here.

Public Methods
Public Method | Description
GetHeadlightSightDistance | Gets the headlight sight distance with the given headlight angle and headlight height.
GetPassingSightDistance | Gets the passing sight distance with the given eye height and object height.
GetStoppingSightDistance | Gets the stopping sight distance with the given eye height and object height.
SetHeadlightSightDistance | Sets the headlight sight distance with the given headlight angle and headlight height.
SetPassingSightDistance | Sets the passing sight distance with the given eye height and object height.
SetStoppingSightDistance | Sets the stopping sight distance with the given eye height and object height.
Links
Public Methods


ProfileParabolaSymmetric::GetHeadlightSightDistance Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Methods > ProfileParabolaSymmetric::GetHeadlightSightDistance Method
ProfileParabolaSymmetric::GetHeadlightSightDistance Method
Collapse All

Gets the headlight sight distance with the given headlight angle and headlight height.

C#
public double GetHeadlightSightDistance(
    double maxAngle,
    double headlightHeight
);
Visual Basic
Public Function GetHeadlightSightDistance(
    maxAngle As double,
    headlightHeight As double
) As double
Parameters
Parameters | Description
maxAngle | Headlight Angle.
headlightHeight | Headlight Height.
Remarks

Only valid for sag curve. This design method for sag curves provides a minimum curve length. The curve must be long enough so that in dark driving conditions, the headlights of a standard vehicle illuminate the road a safe distance beyond the stopping distance for the designed speed of travel.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input parameter is out of range (negative, unable to resolve etc).
System.InvalidOperationException | Thrown when CurveType property is Crest.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::GetPassingSightDistance Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Methods > ProfileParabolaSymmetric::GetPassingSightDistance Method
ProfileParabolaSymmetric::GetPassingSightDistance Method
Collapse All

Gets the passing sight distance with the given eye height and object height.

C#
public double GetPassingSightDistance(
    double eyeHeight,
    double objectHeight
);
Visual Basic
Public Function GetPassingSightDistance(
    eyeHeight As double,
    objectHeight As double
) As double
Parameters
Parameters | Description
eyeHeight | Eye Height.
objectHeight | Object Height.
Remarks

Only valid for crest curve. This design method for crest curves provides a minimum curve length. The curve must be long enough so that the driver of a standard vehicle can always see an oncoming vehicle within a safe distance for the designed speed of travel.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input parameter is out of range (negative, unable to resolve etc).
System.InvalidOperationException | Thrown when CurveType property is Sag.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::GetStoppingSightDistance Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Methods > ProfileParabolaSymmetric::GetStoppingSightDistance Method
ProfileParabolaSymmetric::GetStoppingSightDistance Method
Collapse All

Gets the stopping sight distance with the given eye height and object height.

C#
public double GetStoppingSightDistance(
    double eyeHeight,
    double objectHeight
);
Visual Basic
Public Function GetStoppingSightDistance(
    eyeHeight As double,
    objectHeight As double
) As double
Parameters
Parameters | Description
eyeHeight | Eye Height.
objectHeight | Object Height.
Remarks

Only valid for crest curve. This design method for crest curves provides a minimum curve length. The curve must be long enough so that the driver of a standard vehicle can always see an object before it gets within the maximum stopping distance for the designed speed of travel.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input parameter is out of range (negative, unable to resolve etc).
System.InvalidOperationException | Thrown when CurveType property is Sag.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::SetHeadlightSightDistance Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Methods > ProfileParabolaSymmetric::SetHeadlightSightDistance Method
ProfileParabolaSymmetric::SetHeadlightSightDistance Method
Collapse All

Sets the headlight sight distance with the given headlight angle and headlight height.

C#
public SetHeadlightSightDistance(
    double maxAngle,
    double headlightHeight,
    double distance
);
Visual Basic
Public Sub SetHeadlightSightDistance(
    maxAngle As double,
    headlightHeight As double,
    distance As double
)
Parameters
Parameters | Description
maxAngle | Headlight Angle.
headlightHeight | Headlight Height.
distance | New Headlight Sight Distance value.
Remarks

Only valid for sag curve. This design method for sag curves provides a minimum curve length. The curve must be long enough so that in dark driving conditions, the headlights of a standard vehicle illuminate the road a safe distance beyond the stopping distance for the designed speed of travel.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input parameter is out of range (negative, unable to resolve etc).
System.InvalidOperationException | Thrown when CurveType property is Crest.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::SetPassingSightDistance Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Methods > ProfileParabolaSymmetric::SetPassingSightDistance Method
ProfileParabolaSymmetric::SetPassingSightDistance Method
Collapse All

Sets the passing sight distance with the given eye height and object height.

C#
public SetPassingSightDistance(
    double eyeHeight,
    double objectHeight,
    double distance
);
Visual Basic
Public Sub SetPassingSightDistance(
    eyeHeight As double,
    objectHeight As double,
    distance As double
)
Parameters
Parameters | Description
eyeHeight | Eye Height.
objectHeight | Object Height.
distance | New Passing Sight Distance value.
Remarks

Only valid for crest curve. This design method for crest curves provides a minimum curve length. The curve must be long enough so that the driver of a standard vehicle can always see an oncoming vehicle within a safe distance for the designed speed of travel.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input parameter is out of range (negative, unable to resolve etc).
System.InvalidOperationException | Thrown when CurveType property is Sag.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::SetStoppingSightDistance Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Methods > ProfileParabolaSymmetric::SetStoppingSightDistance Method
ProfileParabolaSymmetric::SetStoppingSightDistance Method
Collapse All

Sets the stopping sight distance with the given eye height and object height.

C#
public SetStoppingSightDistance(
    double eyeHeight,
    double objectHeight,
    double distance
);
Visual Basic
Public Sub SetStoppingSightDistance(
    eyeHeight As double,
    objectHeight As double,
    distance As double
)
Parameters
Parameters | Description
eyeHeight | Eye Height.
objectHeight | Object Height.
distance | New Stopping Sight Distance value.
Remarks

Only valid for crest curve. This design method for crest curves provides a minimum curve length. The curve must be long enough so that the driver of a standard vehicle can always see an object before it gets within the maximum stopping distance for the designed speed of travel.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input parameter is out of range (negative, unable to resolve etc).
System.InvalidOperationException | Thrown when CurveType property is Sag.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties
ProfileParabolaSymmetric Properties
Collapse All

The properties of ProfileParabolaSymmetric are listed here.

Public Properties
Public Property | Description
CurveType | Gets the curve type, crest or sag.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeAtThroughPoint1 | Gets or sets the grade value of the first pass-through point.
GradeAtThroughPoint2 | Gets or sets the grade value of the second pass-through point.
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
M | Gets the M value of the curve.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
Radius | Gets or sets the radius of the curve.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.
ThroughPoint1Elevation | Gets or sets the elevation value of the first pass-through point.
ThroughPoint1Station | Gets or sets the station value of the first pass-through point.
ThroughPoint2Elevation | Gets or sets the elevation value of the second pass-through point.
ThroughPoint2Station | Gets or sets the station value of the second pass-through point.
ThroughPoint3Elevation | Gets or sets the elevation value of the third pass-through point.
ThroughPoint3Station | Gets or sets the station value of the third pass-through point.
Links
Public Properties


ProfileParabolaSymmetric::CurveType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::CurveType Property
ProfileParabolaSymmetric::CurveType Property
Collapse All

Gets the curve type, crest or sag.

C#
public VerticalCurveType CurveType;
Visual Basic
Public Property CurveType() As VerticalCurveType
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::EntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::EntityType Property
ProfileParabolaSymmetric::EntityType Property
Collapse All

Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric

C#
public ProfileEntityType EntityType;
Visual Basic
Public Property EntityType() As ProfileEntityType
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::GradeAtThroughPoint1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::GradeAtThroughPoint1 Property
ProfileParabolaSymmetric::GradeAtThroughPoint1 Property
Collapse All

Gets or sets the grade value of the first pass-through point.

C#
public double GradeAtThroughPoint1;
Visual Basic
Public Property GradeAtThroughPoint1() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
System.InvalidOperationException | Thrown when the property is readonly according to the entity's constraint.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::GradeAtThroughPoint2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::GradeAtThroughPoint2 Property
ProfileParabolaSymmetric::GradeAtThroughPoint2 Property
Collapse All

Gets or sets the grade value of the second pass-through point.

C#
public double GradeAtThroughPoint2;
Visual Basic
Public Property GradeAtThroughPoint2() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
System.InvalidOperationException | Thrown when the property is readonly according to the entity's constraint.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::GradeChange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::GradeChange Property
ProfileParabolaSymmetric::GradeChange Property
Collapse All

Gets the A value (Grade Change) between the end point and start point.

C#
public double GradeChange;
Visual Basic
Public Property GradeChange() As double
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::GradeIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::GradeIn Property
ProfileParabolaSymmetric::GradeIn Property
Collapse All

Gets the grade at the start point.

C#
public double GradeIn;
Visual Basic
Public Property GradeIn() As double
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::GradeOut Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::GradeOut Property
ProfileParabolaSymmetric::GradeOut Property
Collapse All

Gets the grade at the end point.

C#
public double GradeOut;
Visual Basic
Public Property GradeOut() As double
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::HighLowPointElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::HighLowPointElevation Property
ProfileParabolaSymmetric::HighLowPointElevation Property
Collapse All

Gets the elevation value of the high/low point of the curve.

C#
public double HighLowPointElevation;
Visual Basic
Public Property HighLowPointElevation() As double
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::HighLowPointStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::HighLowPointStation Property
ProfileParabolaSymmetric::HighLowPointStation Property
Collapse All

Gets the station value of the high/low point of the curve.

C#
public double HighLowPointStation;
Visual Basic
Public Property HighLowPointStation() As double
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::K Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::K Property
ProfileParabolaSymmetric::K Property
Collapse All

Gets or sets the K value (Curve Coefficient) of the curve.

C#
public double K;
Visual Basic
Public Property K() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::M Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::M Property
ProfileParabolaSymmetric::M Property
Collapse All

Gets the M value of the curve.

C#
public double M;
Visual Basic
Public Property M() As double
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::PVIElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::PVIElevation Property
ProfileParabolaSymmetric::PVIElevation Property
Collapse All

Gets the elevation value of the PVI this curve is associated with.

C#
public double PVIElevation;
Visual Basic
Public Property PVIElevation() As double
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::PVIStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::PVIStation Property
ProfileParabolaSymmetric::PVIStation Property
Collapse All

Gets the station value of the PVI this curve is associated with.

C#
public double PVIStation;
Visual Basic
Public Property PVIStation() As double
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::Radius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::Radius Property
ProfileParabolaSymmetric::Radius Property
Collapse All

Gets or sets the radius of the curve.

C#
public double Radius;
Visual Basic
Public Property Radius() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::TangentOffsetAtPVI Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::TangentOffsetAtPVI Property
ProfileParabolaSymmetric::TangentOffsetAtPVI Property
Collapse All

Gets the tangent offset value at the PVI the curve is associated with.

C#
public double TangentOffsetAtPVI;
Visual Basic
Public Property TangentOffsetAtPVI() As double
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::ThroughPoint1Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::ThroughPoint1Elevation Property
ProfileParabolaSymmetric::ThroughPoint1Elevation Property
Collapse All

Gets or sets the elevation value of the first pass-through point.

C#
public double ThroughPoint1Elevation;
Visual Basic
Public Property ThroughPoint1Elevation() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
System.InvalidOperationException | Thrown when this property is restricted by the entity's constraint type.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::ThroughPoint1Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::ThroughPoint1Station Property
ProfileParabolaSymmetric::ThroughPoint1Station Property
Collapse All

Gets or sets the station value of the first pass-through point.

C#
public double ThroughPoint1Station;
Visual Basic
Public Property ThroughPoint1Station() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
System.InvalidOperationException | Thrown when this property is restricted by the entity's constraint type.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::ThroughPoint2Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::ThroughPoint2Elevation Property
ProfileParabolaSymmetric::ThroughPoint2Elevation Property
Collapse All

Gets or sets the elevation value of the second pass-through point.

C#
public double ThroughPoint2Elevation;
Visual Basic
Public Property ThroughPoint2Elevation() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
System.InvalidOperationException | Thrown when this property is restricted by the entity's constraint type.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::ThroughPoint2Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::ThroughPoint2Station Property
ProfileParabolaSymmetric::ThroughPoint2Station Property
Collapse All

Gets or sets the station value of the second pass-through point.

C#
public double ThroughPoint2Station;
Visual Basic
Public Property ThroughPoint2Station() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
System.InvalidOperationException | Thrown when this property is restricted by the entity's constraint type.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::ThroughPoint3Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::ThroughPoint3Elevation Property
ProfileParabolaSymmetric::ThroughPoint3Elevation Property
Collapse All

Gets or sets the elevation value of the third pass-through point.

C#
public double ThroughPoint3Elevation;
Visual Basic
Public Property ThroughPoint3Elevation() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
System.InvalidOperationException | Thrown when this property is restricted by the entity's constraint type.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileParabolaSymmetric::ThroughPoint3Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties > ProfileParabolaSymmetric::ThroughPoint3Station Property
ProfileParabolaSymmetric::ThroughPoint3Station Property
Collapse All

Gets or sets the station value of the third pass-through point.

C#
public double ThroughPoint3Station;
Visual Basic
Public Property ThroughPoint3Station() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the property is set to an invalid value according to the entity's context.
System.InvalidOperationException | Thrown when this property is restricted by the entity's constraint type.
Links
ProfileParabolaSymmetric Class, ProfileParabolaSymmetric Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileProjection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileProjection Class
ProfileProjection Class
Collapse All

The AeccDbProfileProjection class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::ProfileProjection
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbProfileProjection"))]
public class ProfileProjection : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbProfileProjection"))>
Public Class ProfileProjection
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
Class Hierarchy


ProfilePVI Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class
ProfilePVI Class
Collapse All

In a profile, the point where the lines formed by two tangent entities meet, whether the entities meet or not (the "Point of Vertical Intersection").

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfilePVI
C#
public class ProfilePVI : CivilWrapper<AeccDbVAlignment>;
Visual Basic
Public Class ProfilePVI
Inherits CivilWrapper<AeccDbVAlignment>
Example
//  Find the PVI close to station 1000 elevation -70.
ProfilePVI oProfilePVI = oProfile.PVIs.GetPVIAt(1000, -70);
ed.WriteMessage("PVI closest to station 1000 is at station: {0}", oProfilePVI.Station);
// Add another PVI and slightly adjust its elevation.
oProfilePVI = oProfile.PVIs.AddPVI(607.4, -64.3);
oProfilePVI.Elevation -= 2.0;
Links
ProfilePVI Properties, ProfilePVI Members, Class Hierarchy


ProfilePVI Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Members
ProfilePVI Members
Collapse All

The following tables list the members exposed by ProfilePVI.

Public Properties
Public Property | Description
Elevation | Gets or sets the elevation value of the PVI.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
GradeIn | Gets or sets the grade of the curve into the PVI.
GradeOut | Gets or sets the grade of the curve out of the PVI.
HeadlightSightDistance | Gets or sets the headlight sight distance of the sag parabolic curve.
PassingSightDistance | Gets or sets the passing sight distance of the crest parabolic curve.
PVIType | Gets the type of subentity at the PVI.
Station | Gets or sets the station value of the PVI.
StoppingSightDistance | Gets or sets the stopping sight distance of the crest parabolic curve.
VerticalCurve | Gets the vertical curve object at the PVI.
Links
Public Properties


ProfilePVI Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties
ProfilePVI Properties
Collapse All

The properties of ProfilePVI are listed here.

Public Properties
Public Property | Description
Elevation | Gets or sets the elevation value of the PVI.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
GradeIn | Gets or sets the grade of the curve into the PVI.
GradeOut | Gets or sets the grade of the curve out of the PVI.
HeadlightSightDistance | Gets or sets the headlight sight distance of the sag parabolic curve.
PassingSightDistance | Gets or sets the passing sight distance of the crest parabolic curve.
PVIType | Gets the type of subentity at the PVI.
Station | Gets or sets the station value of the PVI.
StoppingSightDistance | Gets or sets the stopping sight distance of the crest parabolic curve.
VerticalCurve | Gets the vertical curve object at the PVI.
Links
Public Properties


ProfilePVI::Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::Elevation Property
ProfilePVI::Elevation Property
Collapse All

Gets or sets the elevation value of the PVI.

C#
public double Elevation;
Visual Basic
Public Property Elevation() As double
Remarks

The value of Elevation is limited in the UI, but it's not limited in the API.

Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::EntityAfter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::EntityAfter Property
ProfilePVI::EntityAfter Property
Collapse All

Gets the ID of the profile entity that follows the current entity.

C#
public unsigned int EntityAfter;
Visual Basic
Public Property EntityAfter() As unsigned int
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when there is no profile entity after current ProfilePVI.
Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::EntityBefore Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::EntityBefore Property
ProfilePVI::EntityBefore Property
Collapse All

Gets the ID of the profile entity that precedes the current entity.

C#
public unsigned int EntityBefore;
Visual Basic
Public Property EntityBefore() As unsigned int
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when there is no profile entity before current ProfilePVI.
Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::GradeIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::GradeIn Property
ProfilePVI::GradeIn Property
Collapse All

Gets or sets the grade of the curve into the PVI.

C#
public double GradeIn;
Visual Basic
Public Property GradeIn() As double
Remarks

Note that this property will fail for the first PVI in the profile. The profile starts and ends with a PVI point, but these start and end PVI points only contain half the necessary information - it is essentially a PVI that is cut in half.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when using GradeIn on the first PVI in the profile.
Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::GradeOut Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::GradeOut Property
ProfilePVI::GradeOut Property
Collapse All

Gets or sets the grade of the curve out of the PVI.

C#
public double GradeOut;
Visual Basic
Public Property GradeOut() As double
Remarks

Note that this property will fail on the last PVI in the profile. The profile starts and ends with a PVI point, but these start and end PVI points only contain half the necessary information - it is essentially a PVI that is cut in half.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when using on GradeOut the last PVI in the profile.
Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::HeadlightSightDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::HeadlightSightDistance Property
ProfilePVI::HeadlightSightDistance Property
Collapse All

Gets or sets the headlight sight distance of the sag parabolic curve.

C#
public double HeadlightSightDistance;
Visual Basic
Public Property HeadlightSightDistance() As double
Remarks

Property is valid only for the PVI that's type is ParabolaSymmetric.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the PVI type is not ParabolaSymmetric or the vertical curve type is VerticalCurveType::Sag.
Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::PassingSightDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::PassingSightDistance Property
ProfilePVI::PassingSightDistance Property
Collapse All

Gets or sets the passing sight distance of the crest parabolic curve.

C#
public double PassingSightDistance;
Visual Basic
Public Property PassingSightDistance() As double
Remarks

Property is valid only for the PVI that's type is ParabolaSymmetric.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the PVI type is not ParabolaSymmetric or the vertical curve type is VerticalCurveType::Sag.
Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::PVIType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::PVIType Property
ProfilePVI::PVIType Property
Collapse All

Gets the type of subentity at the PVI.

C#
public ProfileEntityType PVIType;
Visual Basic
Public Property PVIType() As ProfileEntityType
Remarks

Property is ProfileEntityType::None for the PVI the first PVI and the last PVI.

Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::Station Property
ProfilePVI::Station Property
Collapse All

Gets or sets the station value of the PVI.

C#
public double Station;
Visual Basic
Public Property Station() As double
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when:

  1. The value of the new PVI station is less than or equal to the begin station of the prvious PVI.
  2. The value of the new PVI station is greater than or equal to the end station of next PVI.

Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::StoppingSightDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::StoppingSightDistance Property
ProfilePVI::StoppingSightDistance Property
Collapse All

Gets or sets the stopping sight distance of the crest parabolic curve.

C#
public double StoppingSightDistance;
Visual Basic
Public Property StoppingSightDistance() As double
Remarks

Property is valid only for the PVI that's type is ParabolaSymmetric.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the PVI type is not ParabolaSymmetric or the vertical curve type is VerticalCurveType::Sag.
Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVI::VerticalCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties > ProfilePVI::VerticalCurve Property
ProfilePVI::VerticalCurve Property
Collapse All

Gets the vertical curve object at the PVI.

C#
public ProfileEntity VerticalCurve;
Visual Basic
Public Property VerticalCurve() As ProfileEntity
Links
ProfilePVI Class, ProfilePVI Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class
ProfilePVICollection Class
Collapse All

The ProfilePVI collection class represents the collection of all ProfilePVI objects that belong to an Profile.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfilePVICollection
C#
public class ProfilePVICollection : CivilWrapper<AeccDbVAlignment>, System::Collections::Generic::IEnumerable<ProfilePVI^>;
Visual Basic
Public Class ProfilePVICollection
Inherits CivilWrapper<AeccDbVAlignment>
Inherits System::Collections::Generic::IEnumerable<ProfilePVI^>
Links
ProfilePVICollection Methods, ProfilePVICollection Properties, ProfilePVICollection Members, Class Hierarchy


ProfilePVICollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Members
ProfilePVICollection Members
Collapse All

The following tables list the members exposed by ProfilePVICollection.

Public Methods
Public Method | Description
AddPVI | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is tangent to the collection.
AddPVIArc | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is Circular to the collection.
AddPVIAsymParabola | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaAsymmetric to the collection.
AddPVISymParabola | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaSymmetric to the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetPVIAt | Gets the PVI in the collection closest to the given station and elevation.
Remove | Removes a profile PVI from the collection.
RemoveAt | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of ProfilePVI objects in the collection.
default | Gets the ProfilePVI object at a specified index in the collection.
Links
Public Methods, Public Properties


ProfilePVICollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods
ProfilePVICollection Methods
Collapse All

The methods of ProfilePVICollection are listed here.

Public Methods
Public Method | Description
AddPVI | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is tangent to the collection.
AddPVIArc | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is Circular to the collection.
AddPVIAsymParabola | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaAsymmetric to the collection.
AddPVISymParabola | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaSymmetric to the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetPVIAt | Gets the PVI in the collection closest to the given station and elevation.
Remove | Removes a profile PVI from the collection.
RemoveAt | Overloaded
Links
Public Methods


ProfilePVICollection::AddPVI Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > ProfilePVICollection::AddPVI Method
ProfilePVICollection::AddPVI Method
Collapse All

Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is tangent to the collection.

C#
public ProfilePVI AddPVI(
    double station,
    double elevation
);
Visual Basic
Public Function AddPVI(
    station As double,
    elevation As double
) As ProfilePVI
Parameters
Parameters | Description
station | Station value for the new PVI.
elevation | Elevation value for the new PVI.
Remarks

The value of station is limited by the profile view in the UI, but it's not limited in the API.

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when :

  1. The value of the new PVI station is less than the start station or greater than the end station of the profile's corresponding alignment.
  2. The value of the new PVI station is less than or equal to the begin station of the prvious PVI.
  3. The value of the new PVI station is greater than or equal to the end station of next PVI.

Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection::AddPVIArc Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > ProfilePVICollection::AddPVIArc Method
ProfilePVICollection::AddPVIArc Method
Collapse All

Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is Circular to the collection.

C#
public ProfilePVI AddPVIArc(
    double station,
    double elevation,
    double radius
);
Visual Basic
Public Function AddPVIArc(
    station As double,
    elevation As double,
    radius As double
) As ProfilePVI
Parameters
Parameters | Description
station | The station value for the new PVI.
elevation | The elevation value for the new PVI.
radius | The radius value of Arc for the new PVI.
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when :

  1. The value of the new PVI station is less than the start station or greater than the end station of the profile's corresponding alignment.
  2. The value of the new PVI station is less than or equal to the begin station of the prvious PVI.
  3. The value of the new PVI station is greater than or equal to the end station of next PVI.
  4. Cannot add as Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is Circular with the given station, elevation and radius.

Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection::AddPVIAsymParabola Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > ProfilePVICollection::AddPVIAsymParabola Method
ProfilePVICollection::AddPVIAsymParabola Method
Collapse All

Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaAsymmetric to the collection.

C#
public ProfilePVI AddPVIAsymParabola(
    double station,
    double elevation,
    double tangentLen1,
    double tangentLen2
);
Visual Basic
Public Function AddPVIAsymParabola(
    station As double,
    elevation As double,
    tangentLen1 As double,
    tangentLen2 As double
) As ProfilePVI
Parameters
Parameters | Description
station | The station value for the new PVI.
elevation | The elevation value for the new PVI.
tangentLen1 | The lentgh value of the first tangent for the new PVI.
tangentLen2 | The lentgh value of the second tangent for the new PVI.
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when :

  1. The value of the new PVI station is less than the start station or greater than the end station of the profile's corresponding alignment.
  2. The value of the new PVI station is less than or equal to the begin station of the prvious PVI.
  3. The value of the new PVI station is greater than or equal to the end station of next PVI.
  4. Cannot Add an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaAsymmetric with the given station, elevation and radius.

Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection::AddPVISymParabola Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > ProfilePVICollection::AddPVISymParabola Method
ProfilePVICollection::AddPVISymParabola Method
Collapse All

Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaSymmetric to the collection.

C#
public ProfilePVI AddPVISymParabola(
    double station,
    double elevation,
    double curveLength
);
Visual Basic
Public Function AddPVISymParabola(
    station As double,
    elevation As double,
    curveLength As double
) As ProfilePVI
Parameters
Parameters | Description
station | The station value for the new PVI.
elevation | The elevation value for the new PVI.
curveLength | The lentgh value of Arc for the new PVI.
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when :

  1. The value of the new PVI station is less than the start station or greater than the end station of the profile's corresponding alignment.
  2. The value of the new PVI station is less than or equal to the begin station of the prvious PVI.
  3. The value of the new PVI station is greater than or equal to the end station of next PVI.
  4. Cannot add an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaSymmetric with the given station, elevation and radius.

Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > ProfilePVICollection::GetEnumerator Method
ProfilePVICollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<ProfilePVI^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<ProfilePVI^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > ProfilePVICollection::GetObjectEnumerator Method
ProfilePVICollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection::GetPVIAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > ProfilePVICollection::GetPVIAt Method
ProfilePVICollection::GetPVIAt Method
Collapse All

Gets the PVI in the collection closest to the given station and elevation.

C#
public ProfilePVI GetPVIAt(
    double station,
    double elevation
);
Visual Basic
Public Function GetPVIAt(
    station As double,
    elevation As double
) As ProfilePVI
Parameters
Parameters | Description
station | Station value.
elevation | Elevation value.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when ProfilePVICollection is an empty collection.
Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > ProfilePVICollection::Remove Method
ProfilePVICollection::Remove Method
Collapse All

Removes a profile PVI from the collection.

C#
public Remove(
    ref ProfilePVI profilePVI
);
Visual Basic
Public Sub Remove(
    ByRef profilePVI As ProfilePVI
)
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when remove a ProfilePVI that is not in the collection.
Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > RemoveAt Method
RemoveAt Method
Collapse All

Overloaded

Overload List
Method | Description
ProfilePVICollection::RemoveAt (double, double) | Removes a profile PVI from the collection closest to the given station and elevation.
ProfilePVICollection::RemoveAt (int) | Removes the specified PVI from this profile. Thrown when index is out of the collecton range.


ProfilePVICollection::RemoveAt Method (double, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > RemoveAt Method > ProfilePVICollection::RemoveAt Method (double, double)
ProfilePVICollection::RemoveAt Method (double, double)
Collapse All

Removes a profile PVI from the collection closest to the given station and elevation.

C#
public RemoveAt(
    double station,
    double elevation
);
Visual Basic
Public Sub RemoveAt(
    station As double,
    elevation As double
)
Parameters
Parameters | Description
station | Station value.
elevation | Elevation value.
Remarks

Can not remove the first or the last PVI.

Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. Removing the first or the last PVI.
  2. ProfilePVICollection is an empty collection.

Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection::RemoveAt Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods > RemoveAt Method > ProfilePVICollection::RemoveAt Method (int)
ProfilePVICollection::RemoveAt Method (int)
Collapse All

Removes the specified PVI from this profile.

Thrown when index is out of the collecton range.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | The index of the PVI in the ProfilePVICollection.
Remarks

Cannot remove the first or the last PVI.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when removing the first or the last PVI.
Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Properties
ProfilePVICollection Properties
Collapse All

The properties of ProfilePVICollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of ProfilePVI objects in the collection.
default | Gets the ProfilePVI object at a specified index in the collection.
Links
Public Properties


ProfilePVICollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Properties > ProfilePVICollection::Count Property
ProfilePVICollection::Count Property
Collapse All

Gets the number of ProfilePVI objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfilePVICollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Properties > ProfilePVICollection::default Property
ProfilePVICollection::default Property
Collapse All

Gets the ProfilePVI object at a specified index in the collection.

C#
public ProfilePVI default;
Visual Basic
Public Property default() As ProfilePVI
Parameters
Parameters | Description
index | The index of the PVI in the ProfilePVICollection.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when index is out of the collection range.
Links
ProfilePVICollection Class, ProfilePVICollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileTangent Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class
ProfileTangent Class
Collapse All

This class represents an ProfileEntity made up of a single tangent.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileTangent
C#
public class ProfileTangent : ProfileEntity;
Visual Basic
Public Class ProfileTangent
Inherits ProfileEntity
Links
ProfileTangent Properties, ProfileTangent Members, Class Hierarchy


ProfileTangent Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Members
ProfileTangent Members
Collapse All

The following tables list the members exposed by ProfileTangent.

Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.
Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type.
Grade | Gets the tangent grade.
HighestDesignSpeed | Returns the highest speed in the station range.
Length | Gets or sets the curve length.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
ThroughPoint1Elevation | Gets or sets the elevation value of the first pass-through point.
ThroughPoint1Station | Gets or sets the station value of the first pass-through point.
ThroughPoint2Elevation | Gets or sets the elevation value of the second pass-through point.
ThroughPoint2Station | Gets or sets the station value of the second pass-through point.
Links
Public Methods, Public Properties


ProfileTangent Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Properties
ProfileTangent Properties
Collapse All

The properties of ProfileTangent are listed here.

Public Properties
Public Property | Description
EntityType | Gets the profile entity type.
Grade | Gets the tangent grade.
ThroughPoint1Elevation | Gets or sets the elevation value of the first pass-through point.
ThroughPoint1Station | Gets or sets the station value of the first pass-through point.
ThroughPoint2Elevation | Gets or sets the elevation value of the second pass-through point.
ThroughPoint2Station | Gets or sets the station value of the second pass-through point.
Links
Public Properties


ProfileTangent::EntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Properties > ProfileTangent::EntityType Property
ProfileTangent::EntityType Property
Collapse All

Gets the profile entity type.

C#
public ProfileEntityType EntityType;
Visual Basic
Public Property EntityType() As ProfileEntityType
Links
ProfileTangent Class, ProfileTangent Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileTangent::Grade Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Properties > ProfileTangent::Grade Property
ProfileTangent::Grade Property
Collapse All

Gets the tangent grade.

C#
public double Grade;
Visual Basic
Public Property Grade() As double
Links
ProfileTangent Class, ProfileTangent Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileTangent::ThroughPoint1Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Properties > ProfileTangent::ThroughPoint1Elevation Property
ProfileTangent::ThroughPoint1Elevation Property
Collapse All

Gets or sets the elevation value of the first pass-through point.

C#
public double ThroughPoint1Elevation;
Visual Basic
Public Property ThroughPoint1Elevation() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
ProfileTangent Class, ProfileTangent Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileTangent::ThroughPoint1Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Properties > ProfileTangent::ThroughPoint1Station Property
ProfileTangent::ThroughPoint1Station Property
Collapse All

Gets or sets the station value of the first pass-through point.

C#
public double ThroughPoint1Station;
Visual Basic
Public Property ThroughPoint1Station() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
ProfileTangent Class, ProfileTangent Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileTangent::ThroughPoint2Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Properties > ProfileTangent::ThroughPoint2Elevation Property
ProfileTangent::ThroughPoint2Elevation Property
Collapse All

Gets or sets the elevation value of the second pass-through point.

C#
public double ThroughPoint2Elevation;
Visual Basic
Public Property ThroughPoint2Elevation() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
ProfileTangent Class, ProfileTangent Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileTangent::ThroughPoint2Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Properties > ProfileTangent::ThroughPoint2Station Property
ProfileTangent::ThroughPoint2Station Property
Collapse All

Gets or sets the station value of the second pass-through point.

C#
public double ThroughPoint2Station;
Visual Basic
Public Property ThroughPoint2Station() As double
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. The property is set to an invalid value according to the entity's constraint type.
  2. Setting the property is restricted by the entity's constraint type.

Links
ProfileTangent Class, ProfileTangent Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class
ProfileView Class
Collapse All

Manages the graphic display of profile data objects within a drawing. A ProfileView is used to display one or more profiles for a horizontal alignment. You can configure data bands and profile annotations in a ProfileView to make it clearer or more informative for the user.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
            Autodesk::Civil::Land::DatabaseServices::ProfileView
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphProfile"))]
public class ProfileView : Autodesk::Civil::DatabaseServices::Graph;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphProfile"))>
Public Class ProfileView
Inherits Autodesk::Civil::DatabaseServices::Graph
Links
ProfileView Methods, ProfileView Properties, ProfileView Members, Class Hierarchy


ProfileView Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Members
ProfileView Members
Collapse All

The following tables list the members exposed by ProfileView.

Public Methods
Public Method | Description
Create | Overloaded
FindStationAndElevationAtXY | Finds the station and elevation values at the given X,Y coordinate.
FindXYAtStationAndElevation | Finds the X,Y coordinate for the given station and elevation.
GetLabelIds | Gets the ObjectIdCollection of the ProfileView's labels.
Public Properties
Public Property | Description
AlignmentId | Gets the object id of the alignment from which the profile view was created.
AlignmentName | Gets the name of the alignment from which the profile view was created.
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
ElevationMax | Gets or sets the maximum elevation of the profile view.
ElevationMin | Gets or sets the minimum elevation of the profile view.
ElevationRangeMode | Gets or sets how to specify the vertical range of the profile view.
GraphOverrides | Gets the collection of the profiles that belong to the alignment.
HatchAreas | Gets the collection of hatch area in the profile view.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
SplitDataLines | Gets the collection of split data lines.
SplitDatumRounding | Gets or sets where to round the vertical split location.
SplitHeight | Gets or sets the elevation range for splitting the profile view.
SplitProfileView | Gets or sets whether to split the profile view to multiple segments.
SplitStationMode | Gets or sets the mode to split the profile view.
SplitStationRounding | Gets or sets where to round the horizontal split location.
StationEnd | Gets or sets the end station of the profile view.
StationRangeMode | Gets or sets how to specify the horizontal range of the profile view.
StationStart | Gets or sets the start station of the profile view.
StyleId | Sets the ProfileView's style by ObjectId.
StyleName | Sets the ProfileView's style by name.
Links
Public Methods, Public Properties


ProfileView Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Methods
ProfileView Methods
Collapse All

The methods of ProfileView are listed here.

Public Methods
Public Method | Description
Create | Overloaded
FindStationAndElevationAtXY | Finds the station and elevation values at the given X,Y coordinate.
FindXYAtStationAndElevation | Finds the X,Y coordinate for the given station and elevation.
GetLabelIds | Gets the ObjectIdCollection of the ProfileView's labels.
Links
Public Methods


Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Methods > Create Method
Create Method
Collapse All

Overloaded

Overload List
Method | Description
ProfileView::Create (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::Geometry::Point3d) | Creates a profile view from the specified alignment.
ProfileView::Create (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, Autodesk::AutoCAD::Geometry::Point3d) | Creates a profile view from the specified alignment.


ProfileView::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Methods > Create Method > ProfileView::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::Geometry::Point3d)
ProfileView::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates a profile view from the specified alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    ref System::String profileViewName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId profileViewBandSetId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    Autodesk::AutoCAD::Geometry::Point3d insertPosition
);
Visual Basic
Public Function Create(
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    ByRef profileViewName As System::String,
    profileViewBandSetId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    insertPosition As Autodesk::AutoCAD::Geometry::Point3d
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
document | Document object in which the ProfileView is created.
profileViewName | Name of the created ProfileView.
alignmentId | Object id of the alignment.
insertPosition | Position at which the ProfileView is inserted.
profileViewBandSetName | Object id of the profile view band set to import to profile view.
Remarks

We use the ProfileView feature settings to get the profileView style, profile labelset and other information, and put the profile view on the Layer "0" by default.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the profile view name is duplicated.
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Methods > Create Method > ProfileView::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, Autodesk::AutoCAD::Geometry::Point3d)
ProfileView::Create Method (Autodesk::Civil::ApplicationServices::CivilDocument^, System::String^, System::String^, System::String^, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Creates a profile view from the specified alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    ref System::String profileViewName,
    ref System::String profileViewBandSetName,
    ref System::String alignmentName,
    Autodesk::AutoCAD::Geometry::Point3d insertPosition
);
Visual Basic
Public Function Create(
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    ByRef profileViewName As System::String,
    ByRef profileViewBandSetName As System::String,
    ByRef alignmentName As System::String,
    insertPosition As Autodesk::AutoCAD::Geometry::Point3d
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
document | Document object in which the ProfileView is created.
profileViewName | Name of the created ProfileView.
profileViewBandSetName | Name of the profile view band set to import to profile view.
alignmentName | Name of the alignment.
insertPosition | Position at which the ProfileView is inserted.
Remarks

We use the ProfileView feature settings to get the profileView style, profile labelset and other information, and put the profile view on the Layer "0" by default.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the profile view name is duplicated.
Example
' Create the profile view and add it to the alignment's
' collection of profile views.
If oProfileView Is Nothing Then
   id = ProfileView.Create(m_CivilDoc, PROFILE_VIEW_NAME, PROFILEVIEW_BANDSET_STYLE_NAME, ALIGNMENT_NAME, position)
   oProfileView = oTransaction.GetObject(id, OpenMode.ForWrite)
End If

oProfileView.Description = "Profile view of alignment '" & m_SampleAlignment.Name & "'"
oProfileView.StyleName = PROFILE_VIEW_STYLE_NAME

m_Editor.WriteMessage("Sample Profile View Created!" + Convert.ToChar(10))
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::FindStationAndElevationAtXY Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Methods > ProfileView::FindStationAndElevationAtXY Method
ProfileView::FindStationAndElevationAtXY Method
Collapse All

Finds the station and elevation values at the given X,Y coordinate.

C#
public bool FindStationAndElevationAtXY(
    double x,
    double y,
    double% station,
    double% elevation
);
Visual Basic
Public Function FindStationAndElevationAtXY(
    x As double,
    y As double,
    station As double%,
    elevation As double%
) As bool
Parameters
Parameters | Description
x | X coordinate in the profile view's coordinate system.
y | Y coordinate in the profile view's coordinate system.
station | Returns the corresponding station.
elevation | Returns the corresponding elevation.
Returns

Returns a flag indicating whether the point specified is within the boundary of the profile view.

Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::FindXYAtStationAndElevation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Methods > ProfileView::FindXYAtStationAndElevation Method
ProfileView::FindXYAtStationAndElevation Method
Collapse All

Finds the X,Y coordinate for the given station and elevation.

C#
public bool FindXYAtStationAndElevation(
    double station,
    double elevation,
    double% x,
    double% y
);
Visual Basic
Public Function FindXYAtStationAndElevation(
    station As double,
    elevation As double,
    x As double%,
    y As double%
) As bool
Parameters
Parameters | Description
station | Station value along the parent alignment.
elevation | Elevation value along the parent alignment.
x | Returns the x value in the profile view's coordinate system.
y | Returns the y value in the profile view's coordinate system.
Returns

Returns a flag indicating whether the point returned is within the boundary of the graph.

Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::GetLabelIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Methods > ProfileView::GetLabelIds Method
ProfileView::GetLabelIds Method
Collapse All

Gets the ObjectIdCollection of the ProfileView's labels.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetLabelIds();
Visual Basic
Public Function GetLabelIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties
ProfileView Properties
Collapse All

The properties of ProfileView are listed here.

Public Properties
Public Property | Description
AlignmentId | Gets the object id of the alignment from which the profile view was created.
AlignmentName | Gets the name of the alignment from which the profile view was created.
ElevationMax | Gets or sets the maximum elevation of the profile view.
ElevationMin | Gets or sets the minimum elevation of the profile view.
ElevationRangeMode | Gets or sets how to specify the vertical range of the profile view.
GraphOverrides | Gets the collection of the profiles that belong to the alignment.
HatchAreas | Gets the collection of hatch area in the profile view.
SplitDataLines | Gets the collection of split data lines.
SplitDatumRounding | Gets or sets where to round the vertical split location.
SplitHeight | Gets or sets the elevation range for splitting the profile view.
SplitProfileView | Gets or sets whether to split the profile view to multiple segments.
SplitStationMode | Gets or sets the mode to split the profile view.
SplitStationRounding | Gets or sets where to round the horizontal split location.
StationEnd | Gets or sets the end station of the profile view.
StationRangeMode | Gets or sets how to specify the horizontal range of the profile view.
StationStart | Gets or sets the start station of the profile view.
StyleId | Sets the ProfileView's style by ObjectId.
StyleName | Sets the ProfileView's style by name.
Links
Public Properties


ProfileView::AlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::AlignmentId Property
ProfileView::AlignmentId Property
Collapse All

Gets the object id of the alignment from which the profile view was created.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AlignmentId;
Visual Basic
Public Property AlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment.

Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::AlignmentName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::AlignmentName Property
ProfileView::AlignmentName Property
Collapse All

Gets the name of the alignment from which the profile view was created.

C#
public System::String AlignmentName;
Visual Basic
Public Property AlignmentName() As System::String
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::ElevationMax Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::ElevationMax Property
ProfileView::ElevationMax Property
Collapse All

Gets or sets the maximum elevation of the profile view.

C#
public double ElevationMax;
Visual Basic
Public Property ElevationMax() As double
Remarks

This property is read-only when SplitProfileView is set to true or ElevationRangeMode is set to Automatic.

Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when setting this property while

  1. The property SplitProfileView is true.
  2. The property ElevationRangeMode is set to Automatic.

System.ArgumentException
Thrown when the input ElevationMax is less than ElevationMin.
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::ElevationMin Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::ElevationMin Property
ProfileView::ElevationMin Property
Collapse All

Gets or sets the minimum elevation of the profile view.

C#
public double ElevationMin;
Visual Basic
Public Property ElevationMin() As double
Remarks

This property is read-only when SplitProfileView is set to true or ElevationRangeMode is set to Automatic.

Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when setting this property while

  1. The property SplitProfileView is true.
  2. The property ElevationRangeMode is set to Automatic.

System.ArgumentException
Thrown when the input ElevationMin is greater than ElevationMax.
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::ElevationRangeMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::ElevationRangeMode Property
ProfileView::ElevationRangeMode Property
Collapse All

Gets or sets how to specify the vertical range of the profile view.

C#
public ElevationRangeType ElevationRangeMode;
Visual Basic
Public Property ElevationRangeMode() As ElevationRangeType
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::GraphOverrides Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::GraphOverrides Property
ProfileView::GraphOverrides Property
Collapse All

Gets the collection of the profiles that belong to the alignment.

C#
public ProfileOverrideCollection GraphOverrides;
Visual Basic
Public Property GraphOverrides() As ProfileOverrideCollection
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::HatchAreas Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::HatchAreas Property
ProfileView::HatchAreas Property
Collapse All

Gets the collection of hatch area in the profile view.

C#
public ProfileHatchAreaCollection HatchAreas;
Visual Basic
Public Property HatchAreas() As ProfileHatchAreaCollection
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::SplitDataLines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::SplitDataLines Property
ProfileView::SplitDataLines Property
Collapse All

Gets the collection of split data lines.

C#
public ProfileViewSplitDataCollection SplitDataLines;
Visual Basic
Public Property SplitDataLines() As ProfileViewSplitDataCollection
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::SplitDatumRounding Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::SplitDatumRounding Property
ProfileView::SplitDatumRounding Property
Collapse All

Gets or sets where to round the vertical split location.

C#
public DatumRoundingType SplitDatumRounding;
Visual Basic
Public Property SplitDatumRounding() As DatumRoundingType
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::SplitHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::SplitHeight Property
ProfileView::SplitHeight Property
Collapse All

Gets or sets the elevation range for splitting the profile view.

C#
public double SplitHeight;
Visual Basic
Public Property SplitHeight() As double
Remarks

SplitHeight = ElevationMax - ElevationMin. So ElevationMax will get updated automatically when SplitHeight changes.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when in put value is negative.
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::SplitProfileView Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::SplitProfileView Property
ProfileView::SplitProfileView Property
Collapse All

Gets or sets whether to split the profile view to multiple segments.

C#
public bool SplitProfileView;
Visual Basic
Public Property SplitProfileView() As bool
Remarks

SplitProfileView is only active when ElevationRangeMode is set to UserSpecified.

Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::SplitStationMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::SplitStationMode Property
ProfileView::SplitStationMode Property
Collapse All

Gets or sets the mode to split the profile view.

C#
public SplitStationType SplitStationMode;
Visual Basic
Public Property SplitStationMode() As SplitStationType
Remarks

Switching from Manual to Automatic clears all user-specified split settings.

Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::SplitStationRounding Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::SplitStationRounding Property
ProfileView::SplitStationRounding Property
Collapse All

Gets or sets where to round the horizontal split location.

C#
public StationRoundingType SplitStationRounding;
Visual Basic
Public Property SplitStationRounding() As StationRoundingType
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::StationEnd Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::StationEnd Property
ProfileView::StationEnd Property
Collapse All

Gets or sets the end station of the profile view.

C#
public double StationEnd;
Visual Basic
Public Property StationEnd() As double
Remarks

This property is read-only when StationRangeMode is set to Automatic.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when setting this property while StationRangeMode is Automatic.
System.ArgumentException | Thrown when the input StationEnd is less than StationStart.
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::StationRangeMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::StationRangeMode Property
ProfileView::StationRangeMode Property
Collapse All

Gets or sets how to specify the horizontal range of the profile view.

C#
public StationRangeType StationRangeMode;
Visual Basic
Public Property StationRangeMode() As StationRangeType
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::StationStart Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::StationStart Property
ProfileView::StationStart Property
Collapse All

Gets or sets the start station of the profile view.

C#
public double StationStart;
Visual Basic
Public Property StationStart() As double
Remarks

This property is read-only when StationRangeMode is set to Automatic.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when setting this property while StationRangeMode is Automatic.
System.ArgumentException | Thrown when the input StationStart is greater than StationEnd.
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::StyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::StyleId Property
ProfileView::StyleId Property
Collapse All

Sets the ProfileView's style by ObjectId.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StyleId;
Visual Basic
Public Property StyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.ProfileViewStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style Id is invalid.
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileView::StyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties > ProfileView::StyleName Property
ProfileView::StyleName Property
Collapse All

Sets the ProfileView's style by name.

C#
public System::String StyleName;
Visual Basic
Public Property StyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style name is invalid.
Links
ProfileView Class, ProfileView Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitData Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class
ProfileViewSplitData Class
Collapse All

This class represents a split location.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileViewSplitData
C#
public class ProfileViewSplitData : CivilWrapper<AeccDbGraphProfile>;
Visual Basic
Public Class ProfileViewSplitData
Inherits CivilWrapper<AeccDbGraphProfile>
Links
ProfileViewSplitData Properties, ProfileViewSplitData Members, Class Hierarchy


ProfileViewSplitData Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Members
ProfileViewSplitData Members
Collapse All

The following tables list the members exposed by ProfileViewSplitData.

Public Properties
Public Property | Description
AdjustedDatum | Gets or sets the vertical split location.
ProfileViewStyleId | Gets of sets the style of the profile view segment.
ProfileViewStyleName | Gets of sets the style of the profile view segment.
SplitStation | Gets or sets the starting station value of the split location.
Links
Public Properties


ProfileViewSplitData Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Properties
ProfileViewSplitData Properties
Collapse All

The properties of ProfileViewSplitData are listed here.

Public Properties
Public Property | Description
AdjustedDatum | Gets or sets the vertical split location.
ProfileViewStyleId | Gets of sets the style of the profile view segment.
ProfileViewStyleName | Gets of sets the style of the profile view segment.
SplitStation | Gets or sets the starting station value of the split location.
Links
Public Properties


ProfileViewSplitData::AdjustedDatum Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Properties > ProfileViewSplitData::AdjustedDatum Property
ProfileViewSplitData::AdjustedDatum Property
Collapse All

Gets or sets the vertical split location.

C#
public double AdjustedDatum;
Visual Basic
Public Property AdjustedDatum() As double
Links
ProfileViewSplitData Class, ProfileViewSplitData Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitData::ProfileViewStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Properties > ProfileViewSplitData::ProfileViewStyleId Property
ProfileViewSplitData::ProfileViewStyleId Property
Collapse All

Gets of sets the style of the profile view segment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileViewStyleId;
Visual Basic
Public Property ProfileViewStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Styles.ProfileViewStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style id is invalid.
Links
ProfileViewSplitData Class, ProfileViewSplitData Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitData::ProfileViewStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Properties > ProfileViewSplitData::ProfileViewStyleName Property
ProfileViewSplitData::ProfileViewStyleName Property
Collapse All

Gets of sets the style of the profile view segment.

C#
public System::String ProfileViewStyleName;
Visual Basic
Public Property ProfileViewStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style name is invalid.
Links
ProfileViewSplitData Class, ProfileViewSplitData Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitData::SplitStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Properties > ProfileViewSplitData::SplitStation Property
ProfileViewSplitData::SplitStation Property
Collapse All

Gets or sets the starting station value of the split location.

C#
public double SplitStation;
Visual Basic
Public Property SplitStation() As double
Remarks

The split station of the first segment is the starting station of the profile view and is not changable.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input station is beyond the station range of the profile view.
Links
ProfileViewSplitData Class, ProfileViewSplitData Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitDataCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class
ProfileViewSplitDataCollection Class
Collapse All

The class provides a collection for the profile view split data.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileViewSplitDataCollection
C#
public class ProfileViewSplitDataCollection : CivilWrapper<AeccDbGraphProfile>, System::Collections::Generic::IEnumerable<ProfileViewSplitData^>;
Visual Basic
Public Class ProfileViewSplitDataCollection
Inherits CivilWrapper<AeccDbGraphProfile>
Inherits System::Collections::Generic::IEnumerable<ProfileViewSplitData^>
Links
ProfileViewSplitDataCollection Methods, ProfileViewSplitDataCollection Properties, ProfileViewSplitDataCollection Members, Class Hierarchy


ProfileViewSplitDataCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Members
ProfileViewSplitDataCollection Members
Collapse All

The following tables list the members exposed by ProfileViewSplitDataCollection.

Public Methods
Public Method | Description
Add | Adds a new split location.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes the split location from the collection.
Public Properties
Public Property | Description
Count | Gets the number of ProfileViewSplitData objects in the collection.
default | Gets the ProfileViewSplitData at a specified index in the collection.
Links
Public Methods, Public Properties


ProfileViewSplitDataCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Methods
ProfileViewSplitDataCollection Methods
Collapse All

The methods of ProfileViewSplitDataCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a new split location.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes the split location from the collection.
Links
Public Methods


ProfileViewSplitDataCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Methods > ProfileViewSplitDataCollection::Add Method
ProfileViewSplitDataCollection::Add Method
Collapse All

Adds a new split location.

C#
public ProfileViewSplitData Add(
    double rawStation,
    double datum
);
Visual Basic
Public Function Add(
    rawStation As double,
    datum As double
) As ProfileViewSplitData
Parameters
Parameters | Description
datum | Specifies the elevation of the split location.
station | Specifies the station of the split location.
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when

  1. The input station is beyond the station range of the profile view.
  2. A split data item exists at the input station.

System.InvalidOperationException
Thrown when the property ProfileView::SplitProfileView is set to false.
Links
ProfileViewSplitDataCollection Class, ProfileViewSplitDataCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitDataCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Methods > ProfileViewSplitDataCollection::GetEnumerator Method
ProfileViewSplitDataCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<ProfileViewSplitData^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<ProfileViewSplitData^>
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileViewSplitDataCollection Class, ProfileViewSplitDataCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitDataCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Methods > ProfileViewSplitDataCollection::GetObjectEnumerator Method
ProfileViewSplitDataCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ProfileViewSplitDataCollection Class, ProfileViewSplitDataCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitDataCollection::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Methods > ProfileViewSplitDataCollection::RemoveAt Method
ProfileViewSplitDataCollection::RemoveAt Method
Collapse All

Removes the split location from the collection.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Specifies the item index to remove.
Exceptions
Exceptions
Description
System.ArgumentOutOfRangeException
Thrown when the index is out of the collection's range.
System.InvalidOperationException
Thrown when

  1. The index is equal to 0, because first item cannot be removed.
  2. The property ProfileView::SplitProfileView is set to false.

Links
ProfileViewSplitDataCollection Class, ProfileViewSplitDataCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitDataCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Properties
ProfileViewSplitDataCollection Properties
Collapse All

The properties of ProfileViewSplitDataCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of ProfileViewSplitData objects in the collection.
default | Gets the ProfileViewSplitData at a specified index in the collection.
Links
Public Properties


ProfileViewSplitDataCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Properties > ProfileViewSplitDataCollection::Count Property
ProfileViewSplitDataCollection::Count Property
Collapse All

Gets the number of ProfileViewSplitData objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ProfileViewSplitDataCollection Class, ProfileViewSplitDataCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


ProfileViewSplitDataCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Properties > ProfileViewSplitDataCollection::default Property
ProfileViewSplitDataCollection::default Property
Collapse All

Gets the ProfileViewSplitData at a specified index in the collection.

C#
public ProfileViewSplitData default;
Visual Basic
Public Property default() As ProfileViewSplitData
Links
ProfileViewSplitDataCollection Class, ProfileViewSplitDataCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


SampleLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class
SampleLine Class
Collapse All

Lines used for obtaining elevational information from an existing terrain model or surface for creating profiles and cross sections.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::SampleLine
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSampleLine"))]
public class SampleLine : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSampleLine"))>
Public Class SampleLine
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Remarks

Sample Lines are lines placed along an alignment at a specified station interval (or at defined stations of interest, such as at assemblies of a corridor object), using a specified left and right swath width. SampleLine objects are contained in SampleLineGroup objects, which organize multiple related sample lines. A SampleLine is used to create a SectionView object, which displays some or all of the sections sampled at that sample line.

Links
SampleLine Methods, SampleLine Properties, SampleLine Members, Class Hierarchy


SampleLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Members
SampleLine Members
Collapse All

The following tables list the members exposed by SampleLine.

Public Methods
Public Method | Description
GetSectionViewIds | Gets the objectId collection of all section views attached on this sample line.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GroupId | Gets the object id of the sample line group it belongs to.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


SampleLine Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Methods
SampleLine Methods
Collapse All

The methods of SampleLine are listed here.

Public Methods
Public Method | Description
GetSectionViewIds | Gets the objectId collection of all section views attached on this sample line.
Links
Public Methods


SampleLine::GetSectionViewIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Methods > SampleLine::GetSectionViewIds Method
SampleLine::GetSectionViewIds Method
Collapse All

Gets the objectId collection of all section views attached on this sample line.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetSectionViewIds();
Visual Basic
Public Function GetSectionViewIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
SampleLine Class, SampleLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


SampleLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Properties
SampleLine Properties
Collapse All

The properties of SampleLine are listed here.

Public Properties
Public Property | Description
GroupId | Gets the object id of the sample line group it belongs to.
Links
Public Properties


SampleLine::GroupId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Properties > SampleLine::GroupId Property
SampleLine::GroupId Property
Collapse All

Gets the object id of the sample line group it belongs to.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId GroupId;
Visual Basic
Public Property GroupId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.SampleLineGroup

Links
SampleLine Class, SampleLine Members, Autodesk::Civil::Land::DatabaseServices Namespace


SampleLineGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class
SampleLineGroup Class
Collapse All

Controls a set of related sample lines, the surfaces they sample, and methods for creating cross sections.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::SampleLineGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSampleLineGroup"))]
public class SampleLineGroup : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSampleLineGroup"))>
Public Class SampleLineGroup
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
SampleLineGroup Methods, SampleLineGroup Members, Class Hierarchy


SampleLineGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Members
SampleLineGroup Members
Collapse All

The following tables list the members exposed by SampleLineGroup.

Public Methods
Public Method | Description
GetMassHaulViewIds | Gets the objectId collection of mass haul views.
GetSampleLineIds | Gets the objectId collection of all sample lines in the sampline group.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


SampleLineGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Methods
SampleLineGroup Methods
Collapse All

The methods of SampleLineGroup are listed here.

Public Methods
Public Method | Description
GetMassHaulViewIds | Gets the objectId collection of mass haul views.
GetSampleLineIds | Gets the objectId collection of all sample lines in the sampline group.
Links
Public Methods


SampleLineGroup::GetMassHaulViewIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Methods > SampleLineGroup::GetMassHaulViewIds Method
SampleLineGroup::GetMassHaulViewIds Method
Collapse All

Gets the objectId collection of mass haul views.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetMassHaulViewIds();
Visual Basic
Public Function GetMassHaulViewIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
SampleLineGroup Class, SampleLineGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


SampleLineGroup::GetSampleLineIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Methods > SampleLineGroup::GetSampleLineIds Method
SampleLineGroup::GetSampleLineIds Method
Collapse All

Gets the objectId collection of all sample lines in the sampline group.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetSampleLineIds();
Visual Basic
Public Function GetSampleLineIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
SampleLineGroup Class, SampleLineGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class
SCSCSConstraints Class
Collapse All

The SCSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Curve-Spiral (AlignmentSCSCS) compound Alignment entities.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::SCSCSConstraints
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccGeSCSCSConstraints"))]
public class SCSCSConstraints : CivilWrapper<AeccGeSCSCSConstraints>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccGeSCSCSConstraints"))>
Public Class SCSCSConstraints
Inherits CivilWrapper<AeccGeSCSCSConstraints>
Remarks

An object of this type is required by the AlignmentEntityCollection::AddFreeSCSCS() method.

Links
SCSCSConstraints Methods, SCSCSConstraints Members, Class Hierarchy


SCSCSConstraints Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Members
SCSCSConstraints Members
Collapse All

The following tables list the members exposed by SCSCSConstraints.

Public Methods
Public Method | Description
CreateByArc1Angle | Creates an SCSCSConstraints object that constrains the SCSCS group by the angle of the first arc.
CreateByArc1Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the first arc.
CreateByArc1PassPt | Creates an SCSCSConstraints object that constrains the SCSCS group by a pass-through point for the first arc.
CreateByArc2Angle | Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.
CreateByArc2Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc length.
CreateByArc2PassPt | Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc pass through point.
CreateByEndPoint | Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.
CreateByStartPoint | Creates an SCSCSConstraints object that constrains the SCSCS group by the start point.
CreateByTan1Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the first tangent length.
CreateByTan2Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the second tangent.
Links
Public Methods


SCSCSConstraints Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods
SCSCSConstraints Methods
Collapse All

The methods of SCSCSConstraints are listed here.

Public Methods
Public Method | Description
CreateByArc1Angle | Creates an SCSCSConstraints object that constrains the SCSCS group by the angle of the first arc.
CreateByArc1Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the first arc.
CreateByArc1PassPt | Creates an SCSCSConstraints object that constrains the SCSCS group by a pass-through point for the first arc.
CreateByArc2Angle | Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.
CreateByArc2Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc length.
CreateByArc2PassPt | Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc pass through point.
CreateByEndPoint | Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.
CreateByStartPoint | Creates an SCSCSConstraints object that constrains the SCSCS group by the start point.
CreateByTan1Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the first tangent length.
CreateByTan2Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the second tangent.
Links
Public Methods


SCSCSConstraints::CreateByArc1Angle Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByArc1Angle Method
SCSCSConstraints::CreateByArc1Angle Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by the angle of the first arc.

C#
public SCSCSConstraints CreateByArc1Angle(
    double arc1Angle,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc1Angle(
    arc1Angle As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
arc1Angle | The angle of the first arc.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints::CreateByArc1Length Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByArc1Length Method
SCSCSConstraints::CreateByArc1Length Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the first arc.

C#
public SCSCSConstraints CreateByArc1Length(
    double arc1Len,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc1Length(
    arc1Len As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
arc1Len | The length of the first arc.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints::CreateByArc1PassPt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByArc1PassPt Method
SCSCSConstraints::CreateByArc1PassPt Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by a pass-through point for the first arc.

C#
public SCSCSConstraints CreateByArc1PassPt(
    Autodesk::AutoCAD::Geometry::Point2d ptArc1PassThru,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc1PassPt(
    ptArc1PassThru As Autodesk::AutoCAD::Geometry::Point2d,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
ptArc1PassThru | The pass-through point for the first arc.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints::CreateByArc2Angle Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByArc2Angle Method
SCSCSConstraints::CreateByArc2Angle Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.

C#
public SCSCSConstraints CreateByArc2Angle(
    double arc2Angle,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc2Angle(
    arc2Angle As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
endPoint | The end point.
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints::CreateByArc2Length Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByArc2Length Method
SCSCSConstraints::CreateByArc2Length Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc length.

C#
public SCSCSConstraints CreateByArc2Length(
    double arc2Len,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc2Length(
    arc2Len As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
arc2Len | The second arc length.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints::CreateByArc2PassPt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByArc2PassPt Method
SCSCSConstraints::CreateByArc2PassPt Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc pass through point.

C#
public SCSCSConstraints CreateByArc2PassPt(
    Autodesk::AutoCAD::Geometry::Point2d ptArc2PassThru,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc2PassPt(
    ptArc2PassThru As Autodesk::AutoCAD::Geometry::Point2d,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
ptArc2PassThru | The second arc pass through point.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints::CreateByEndPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByEndPoint Method
SCSCSConstraints::CreateByEndPoint Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.

C#
public SCSCSConstraints CreateByEndPoint(
    Autodesk::AutoCAD::Geometry::Point2d endPoint,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByEndPoint(
    endPoint As Autodesk::AutoCAD::Geometry::Point2d,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
endPoint | The end point.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints::CreateByStartPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByStartPoint Method
SCSCSConstraints::CreateByStartPoint Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by the start point.

C#
public SCSCSConstraints CreateByStartPoint(
    Autodesk::AutoCAD::Geometry::Point2d startPoint,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByStartPoint(
    startPoint As Autodesk::AutoCAD::Geometry::Point2d,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
startPoint | The start point.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints::CreateByTan1Length Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByTan1Length Method
SCSCSConstraints::CreateByTan1Length Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by the first tangent length.

C#
public SCSCSConstraints CreateByTan1Length(
    double extTan1Len,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByTan1Length(
    extTan1Len As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
extTan1Len | The first tangent length.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSCSConstraints::CreateByTan2Length Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods > SCSCSConstraints::CreateByTan2Length Method
SCSCSConstraints::CreateByTan2Length Method
Collapse All

Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the second tangent.

C#
public SCSCSConstraints CreateByTan2Length(
    double extTan2Len,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double arc2Radius,
    double sp3Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByTan2Length(
    extTan2Len As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    arc2Radius As double,
    sp3Param As double,
    isParamAValue As bool
) As SCSCSConstraints
Parameters
Parameters | Description
extTan2Len | The length of the second tangent.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSCSConstraints Class, SCSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSSCSConstraints Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class
SCSSCSConstraints Class
Collapse All

The SCSSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Spiral-Curve-Spiral (AlignmentSCSSCS) compound Alignment entities.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::SCSSCSConstraints
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccGeSCSSCSConstraints"))]
public class SCSSCSConstraints : CivilWrapper<AeccGeSCSSCSConstraints>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccGeSCSSCSConstraints"))>
Public Class SCSSCSConstraints
Inherits CivilWrapper<AeccGeSCSSCSConstraints>
Remarks

An object of this type is required by the AlignmentEntityCollection::AddFreeSCSSCS method.

Links
SCSSCSConstraints Methods, SCSSCSConstraints Members, Class Hierarchy


SCSSCSConstraints Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Members
SCSSCSConstraints Members
Collapse All

The following tables list the members exposed by SCSSCSConstraints.

Public Methods
Public Method | Description
CreateByArc1Angle | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the angle of the first arc.
CreateByArc1Length | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the length of the first arc.
CreateByArc1PassPt | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point of the first arc.
CreateByArc2Angle | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc angle.
CreateByArc2Length | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc length.
CreateByArc2PassPt | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point for the second arc.
CreateByEndPoint | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the end point.
CreateByStartPoint | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the start point.
Links
Public Methods


SCSSCSConstraints Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods
SCSSCSConstraints Methods
Collapse All

The methods of SCSSCSConstraints are listed here.

Public Methods
Public Method | Description
CreateByArc1Angle | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the angle of the first arc.
CreateByArc1Length | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the length of the first arc.
CreateByArc1PassPt | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point of the first arc.
CreateByArc2Angle | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc angle.
CreateByArc2Length | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc length.
CreateByArc2PassPt | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point for the second arc.
CreateByEndPoint | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the end point.
CreateByStartPoint | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the start point.
Links
Public Methods


SCSSCSConstraints::CreateByArc1Angle Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods > SCSSCSConstraints::CreateByArc1Angle Method
SCSSCSConstraints::CreateByArc1Angle Method
Collapse All

Creates an SCSSCSConstraints object that constrains the SCSSCS group by the angle of the first arc.

C#
public SCSSCSConstraints CreateByArc1Angle(
    double arc1Angle,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double sp3Param,
    double arc2Radius,
    double sp4Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc1Angle(
    arc1Angle As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    sp3Param As double,
    arc2Radius As double,
    sp4Param As double,
    isParamAValue As bool
) As SCSSCSConstraints
Parameters
Parameters | Description
arc1Angle | The angle of the first arc.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp4Param | The fourth spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSSCSConstraints Class, SCSSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSSCSConstraints::CreateByArc1Length Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods > SCSSCSConstraints::CreateByArc1Length Method
SCSSCSConstraints::CreateByArc1Length Method
Collapse All

Creates an SCSSCSConstraints object that constrains the SCSSCS group by the length of the first arc.

C#
public SCSSCSConstraints CreateByArc1Length(
    double arc1Len,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double sp3Param,
    double arc2Radius,
    double sp4Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc1Length(
    arc1Len As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    sp3Param As double,
    arc2Radius As double,
    sp4Param As double,
    isParamAValue As bool
) As SCSSCSConstraints
Parameters
Parameters | Description
arc1Len | The length of the first arc.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp4Param | The fourth spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSSCSConstraints Class, SCSSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSSCSConstraints::CreateByArc1PassPt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods > SCSSCSConstraints::CreateByArc1PassPt Method
SCSSCSConstraints::CreateByArc1PassPt Method
Collapse All

Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point of the first arc.

C#
public SCSSCSConstraints CreateByArc1PassPt(
    Autodesk::AutoCAD::Geometry::Point2d ptArc1PassThru,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double sp3Param,
    double arc2Radius,
    double sp4Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc1PassPt(
    ptArc1PassThru As Autodesk::AutoCAD::Geometry::Point2d,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    sp3Param As double,
    arc2Radius As double,
    sp4Param As double,
    isParamAValue As bool
) As SCSSCSConstraints
Parameters
Parameters | Description
ptArc1PassThru | The pass-through point of the first arc.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp4Param | The fourth spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSSCSConstraints Class, SCSSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSSCSConstraints::CreateByArc2Angle Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods > SCSSCSConstraints::CreateByArc2Angle Method
SCSSCSConstraints::CreateByArc2Angle Method
Collapse All

Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc angle.

C#
public SCSSCSConstraints CreateByArc2Angle(
    double arc2Angle,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double sp3Param,
    double arc2Radius,
    double sp4Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc2Angle(
    arc2Angle As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    sp3Param As double,
    arc2Radius As double,
    sp4Param As double,
    isParamAValue As bool
) As SCSSCSConstraints
Parameters
Parameters | Description
arc2Angle | The second arc angle.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp4Param | The fourth spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSSCSConstraints Class, SCSSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSSCSConstraints::CreateByArc2Length Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods > SCSSCSConstraints::CreateByArc2Length Method
SCSSCSConstraints::CreateByArc2Length Method
Collapse All

Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc length.

C#
public SCSSCSConstraints CreateByArc2Length(
    double arc2Len,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double sp3Param,
    double arc2Radius,
    double sp4Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc2Length(
    arc2Len As double,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    sp3Param As double,
    arc2Radius As double,
    sp4Param As double,
    isParamAValue As bool
) As SCSSCSConstraints
Parameters
Parameters | Description
arc2Len | The second arc length.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp4Param | The fourth spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSSCSConstraints Class, SCSSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSSCSConstraints::CreateByArc2PassPt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods > SCSSCSConstraints::CreateByArc2PassPt Method
SCSSCSConstraints::CreateByArc2PassPt Method
Collapse All

Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point for the second arc.

C#
public SCSSCSConstraints CreateByArc2PassPt(
    Autodesk::AutoCAD::Geometry::Point2d ptArc2PassThru,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double sp3Param,
    double arc2Radius,
    double sp4Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByArc2PassPt(
    ptArc2PassThru As Autodesk::AutoCAD::Geometry::Point2d,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    sp3Param As double,
    arc2Radius As double,
    sp4Param As double,
    isParamAValue As bool
) As SCSSCSConstraints
Parameters
Parameters | Description
ptArc2PassThru | The pass-through point for the second arc.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp4Param | The fourth spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSSCSConstraints Class, SCSSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSSCSConstraints::CreateByEndPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods > SCSSCSConstraints::CreateByEndPoint Method
SCSSCSConstraints::CreateByEndPoint Method
Collapse All

Creates an SCSSCSConstraints object that constrains the SCSSCS group by the end point.

C#
public SCSSCSConstraints CreateByEndPoint(
    Autodesk::AutoCAD::Geometry::Point2d endPoint,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double sp3Param,
    double arc2Radius,
    double sp4Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByEndPoint(
    endPoint As Autodesk::AutoCAD::Geometry::Point2d,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    sp3Param As double,
    arc2Radius As double,
    sp4Param As double,
    isParamAValue As bool
) As SCSSCSConstraints
Parameters
Parameters | Description
endPoint | The end point.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp4Param | The fourth spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSSCSConstraints Class, SCSSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


SCSSCSConstraints::CreateByStartPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods > SCSSCSConstraints::CreateByStartPoint Method
SCSSCSConstraints::CreateByStartPoint Method
Collapse All

Creates an SCSSCSConstraints object that constrains the SCSSCS group by the start point.

C#
public SCSSCSConstraints CreateByStartPoint(
    Autodesk::AutoCAD::Geometry::Point2d startPoint,
    double sp1Param,
    double arc1Radius,
    double sp2Param,
    double sp3Param,
    double arc2Radius,
    double sp4Param,
    bool isParamAValue
);
Visual Basic
Public Function CreateByStartPoint(
    startPoint As Autodesk::AutoCAD::Geometry::Point2d,
    sp1Param As double,
    arc1Radius As double,
    sp2Param As double,
    sp3Param As double,
    arc2Radius As double,
    sp4Param As double,
    isParamAValue As bool
) As SCSSCSConstraints
Parameters
Parameters | Description
startPoint | The start point.
sp1Param | The first spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc1Radius | The radius of the first arc.
sp2Param | The second spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
sp3Param | The third spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
arc2Radius | The radius of the second arc.
sp4Param | The fourth spiral value. If isParamAValue is true, this is the spiral A value. If isParamAValue is false, this is the spiral length.
isParamAValue | Indicates whether the sp_Param parameters are A values (true) or lengths (false).
Links
SCSSCSConstraints Class, SCSSCSConstraints Members, Autodesk::Civil::Land::DatabaseServices Namespace


Section Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Section Class
Section Class
Collapse All

Provides views created at a 90 degree angle to a surface or an alignment.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Section
            Autodesk::Civil::Land::DatabaseServices::MaterialSection
            Autodesk::Civil::Land::DatabaseServices::SectionProjection
            Autodesk::Civil::PipeNetwork::DatabaseServices::SectionPipeNetwork
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSection"))]
public class Section : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSection"))>
Public Class Section
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
Section Properties, Section Members, Class Hierarchy


Section Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Section Class > Section Members
Section Members
Collapse All

The following tables list the members exposed by Section.

Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ParentId | Gets the ObjectId of the Section object's parent.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


Section Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Section Class > Section Properties
Section Properties
Collapse All

The properties of Section are listed here.

Public Properties
Public Property | Description
ParentId | Gets the ObjectId of the Section object's parent.
Links
Public Properties


Section::ParentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Section Class > Section Properties > Section::ParentId Property
Section::ParentId Property
Collapse All

Gets the ObjectId of the Section object's parent.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ParentId;
Visual Basic
Public Property ParentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Section Class, Section Members, Autodesk::Civil::Land::DatabaseServices Namespace


SectionBandLabelGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionBandLabelGroup Class
SectionBandLabelGroup Class
Collapse All

A group of section band labels.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::Land::DatabaseServices::SectionBandLabelGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionBandLabeling"))]
public class SectionBandLabelGroup : Autodesk::Civil::DatabaseServices::LabelGroup;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionBandLabeling"))>
Public Class SectionBandLabelGroup
Inherits Autodesk::Civil::DatabaseServices::LabelGroup
Links
Class Hierarchy


SectionProjection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionProjection Class
SectionProjection Class
Collapse All

AutoCAD or AutoCAD Civil 3D objects projected from plan view into a section view.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Section
            Autodesk::Civil::Land::DatabaseServices::SectionProjection
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionProjection"))]
public class SectionProjection : Section;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionProjection"))>
Public Class SectionProjection
Inherits Section
Links
Class Hierarchy


SectionView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionView Class
SectionView Class
Collapse All

Used to display cross sectional data for both existing and finished ground along a sampled cross section line at any given station along a horizontal alignment.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
            Autodesk::Civil::Land::DatabaseServices::SectionView
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphCrossSection"))]
public class SectionView : Autodesk::Civil::DatabaseServices::Graph;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphCrossSection"))>
Public Class SectionView
Inherits Autodesk::Civil::DatabaseServices::Graph
Remarks

Section Views depend on a SampleLine, and are views displaying some or all of the Section objects sampled at that sample line. This graphical view has both abscissa limits based on the length of corresponding sample line and ordinate values based on the minimum and maximum elevations from the set of sections it is displaying.

Links
SectionView Properties, SectionView Members, Class Hierarchy


SectionView Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionView Class > SectionView Members
SectionView Members
Collapse All

The following tables list the members exposed by SectionView.

Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ParentEntityId | Gets the ObjectId of the parent Entity.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


SectionView Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionView Class > SectionView Properties
SectionView Properties
Collapse All

The properties of SectionView are listed here.

Public Properties
Public Property | Description
ParentEntityId | Gets the ObjectId of the parent Entity.
Links
Public Properties


SectionView::ParentEntityId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionView Class > SectionView Properties > SectionView::ParentEntityId Property
SectionView::ParentEntityId Property
Collapse All

Gets the ObjectId of the parent Entity.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ParentEntityId;
Visual Basic
Public Property ParentEntityId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SectionView Class, SectionView Members, Autodesk::Civil::Land::DatabaseServices Namespace


Sheet Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Sheet Class
Sheet Class
Collapse All

A sheet (construction document) object.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Sheet
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSheet"))]
public class Sheet : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSheet"))>
Public Class Sheet
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
Class Hierarchy


Site Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class
Site Class
Collapse All

The construction site abstraction containing parcels and alignments. Note: Alignments are generally associated with a site. An alignment interacts with objects on a site in two ways:

  1. If an alignment exists on a site with parcels, the alignment will subdivide any parcels it crosses over.
  2. If one or more alignments on a site form a closed region, a parcel will be created from the region.
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Site
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFace"))]
public class Site : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbFace"))>
Public Class Site
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
Site Methods, Site Members, Class Hierarchy


Site Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Members
Site Members
Collapse All

The following tables list the members exposed by Site.

Public Methods
Public Method | Description
Create | Creates a new site.
GetAlignmentIds | Gets the objectId collection of all alignment objects in the site.
GetFeatureLineIds | Gets the objectId collection of all feature lines in the site.
GetParcelIds | Gets the objectId collection of all parcels in the site.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


Site Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Methods
Site Methods
Collapse All

The methods of Site are listed here.

Public Methods
Public Method | Description
Create | Creates a new site.
GetAlignmentIds | Gets the objectId collection of all alignment objects in the site.
GetFeatureLineIds | Gets the objectId collection of all feature lines in the site.
GetParcelIds | Gets the objectId collection of all parcels in the site.
Links
Public Methods


Site::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Methods > Site::Create Method
Site::Create Method
Collapse All

Creates a new site.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    ref System::String siteName
);
Visual Basic
Public Function Create(
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    ByRef siteName As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
document | Document object in which the site is created.
siteName | Name of the new site.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the the siteName is used by a existing site.
Links
Site Class, Site Members, Autodesk::Civil::Land::DatabaseServices Namespace


Site::GetAlignmentIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Methods > Site::GetAlignmentIds Method
Site::GetAlignmentIds Method
Collapse All

Gets the objectId collection of all alignment objects in the site.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetAlignmentIds();
Visual Basic
Public Function GetAlignmentIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Site Class, Site Members, Autodesk::Civil::Land::DatabaseServices Namespace


Site::GetFeatureLineIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Methods > Site::GetFeatureLineIds Method
Site::GetFeatureLineIds Method
Collapse All

Gets the objectId collection of all feature lines in the site.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetFeatureLineIds();
Visual Basic
Public Function GetFeatureLineIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Site Class, Site Members, Autodesk::Civil::Land::DatabaseServices Namespace


Site::GetParcelIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Methods > Site::GetParcelIds Method
Site::GetParcelIds Method
Collapse All

Gets the objectId collection of all parcels in the site.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetParcelIds();
Visual Basic
Public Function GetParcelIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Site Class, Site Members, Autodesk::Civil::Land::DatabaseServices Namespace


Station Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class
Station Class
Collapse All

The Alignment Station class.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Station
C#
public class Station;
Visual Basic
Public Class Station
Links
Station Properties, Station Members, Class Hierarchy


Station Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Members
Station Members
Collapse All

The following tables list the members exposed by Station.

Public Properties
Public Property | Description
GeometryStationType | Gets the geometry point station type.
Location | Gets the station's location.
RawStation | Gets the station's raw station.
StationType | Gets the station type.
Links
Public Properties


Station Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Properties
Station Properties
Collapse All

The properties of Station are listed here.

Public Properties
Public Property | Description
GeometryStationType | Gets the geometry point station type.
Location | Gets the station's location.
RawStation | Gets the station's raw station.
StationType | Gets the station type.
Links
Public Properties


Station::GeometryStationType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Properties > Station::GeometryStationType Property
Station::GeometryStationType Property
Collapse All

Gets the geometry point station type.

C#
public AlignmentGeometryPointStationType GeometryStationType;
Visual Basic
Public Property GeometryStationType() As AlignmentGeometryPointStationType
Links
Station Class, Station Members, Autodesk::Civil::Land::DatabaseServices Namespace


Station::Location Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Properties > Station::Location Property
Station::Location Property
Collapse All

Gets the station's location.

C#
public Autodesk::AutoCAD::Geometry::Point2d Location;
Visual Basic
Public Property Location() As Autodesk::AutoCAD::Geometry::Point2d
Links
Station Class, Station Members, Autodesk::Civil::Land::DatabaseServices Namespace


Station::RawStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Properties > Station::RawStation Property
Station::RawStation Property
Collapse All

Gets the station's raw station.

C#
public double RawStation;
Visual Basic
Public Property RawStation() As double
Links
Station Class, Station Members, Autodesk::Civil::Land::DatabaseServices Namespace


Station::StationType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Properties > Station::StationType Property
Station::StationType Property
Collapse All

Gets the station type.

C#
public StationTypes StationType;
Visual Basic
Public Property StationType() As StationTypes
Links
Station Class, Station Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class
StationEquation Class
Collapse All

Represents a particular system of renumbering or reordering stations within a portion of an alignment.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::StationEquation
C#
public class StationEquation : CivilWrapper<AeccDbAlignment>;
Visual Basic
Public Class StationEquation
Inherits CivilWrapper<AeccDbAlignment>
Links
StationEquation Properties, StationEquation Members, Class Hierarchy


StationEquation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Members
StationEquation Members
Collapse All

The following tables list the members exposed by StationEquation.

Public Properties
Public Property | Description
EquationType | Gets or sets the type of station equation.
RawStationBack | Gets or sets the raw back station value.
StationAhead | Gets or sets the ahead station value.
StationBack | Gets or sets the back station value.
Links
Public Properties


StationEquation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Properties
StationEquation Properties
Collapse All

The properties of StationEquation are listed here.

Public Properties
Public Property | Description
EquationType | Gets or sets the type of station equation.
RawStationBack | Gets or sets the raw back station value.
StationAhead | Gets or sets the ahead station value.
StationBack | Gets or sets the back station value.
Links
Public Properties


StationEquation::EquationType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Properties > StationEquation::EquationType Property
StationEquation::EquationType Property
Collapse All

Gets or sets the type of station equation.

C#
public StationEquationType EquationType;
Visual Basic
Public Property EquationType() As StationEquationType
Links
StationEquation Class, StationEquation Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquation::RawStationBack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Properties > StationEquation::RawStationBack Property
StationEquation::RawStationBack Property
Collapse All

Gets or sets the raw back station value.

C#
public double RawStationBack;
Visual Basic
Public Property RawStationBack() As double
Links
StationEquation Class, StationEquation Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquation::StationAhead Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Properties > StationEquation::StationAhead Property
StationEquation::StationAhead Property
Collapse All

Gets or sets the ahead station value.

C#
public double StationAhead;
Visual Basic
Public Property StationAhead() As double
Links
StationEquation Class, StationEquation Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquation::StationBack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Properties > StationEquation::StationBack Property
StationEquation::StationBack Property
Collapse All

Gets or sets the back station value.

C#
public double StationBack;
Visual Basic
Public Property StationBack() As double
Links
StationEquation Class, StationEquation Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquationCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class
StationEquationCollection Class
Collapse All

A collection of StationEquation objects.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::StationEquationCollection
C#
public class StationEquationCollection : CivilWrapper<AeccDbAlignment>, System::Collections::Generic::IEnumerable<StationEquation^>;
Visual Basic
Public Class StationEquationCollection
Inherits CivilWrapper<AeccDbAlignment>
Inherits System::Collections::Generic::IEnumerable<StationEquation^>
Links
StationEquationCollection Methods, StationEquationCollection Properties, StationEquationCollection Members, Class Hierarchy


StationEquationCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Members
StationEquationCollection Members
Collapse All

The following tables list the members exposed by StationEquationCollection.

Public Methods
Public Method | Description
Add | Adds a station equation into the alignment.
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumerator which can be use to enumerate this collection.... more
GetStationEquation | Gets the StationEquation object in the collection by raw station back.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of StationEquation objects in the collection.
default | Gets the StationEquation object at a specified index in the collection.
Links
Public Methods, Public Properties


StationEquationCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods
StationEquationCollection Methods
Collapse All

The methods of StationEquationCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a station equation into the alignment.
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumerator which can be use to enumerate this collection.... more
GetStationEquation | Gets the StationEquation object in the collection by raw station back.
Remove | Overloaded
Links
Public Methods


StationEquationCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods > StationEquationCollection::Add Method
StationEquationCollection::Add Method
Collapse All

Adds a station equation into the alignment.

C#
public StationEquation Add(
    double rawStationBack,
    double stationAhead,
    StationEquationType stationEquationType
);
Visual Basic
Public Function Add(
    rawStationBack As double,
    stationAhead As double,
    stationEquationType As StationEquationType
) As StationEquation
Parameters
Parameters | Description
rawStationBack | Raw station back value.
stationAhead | Station ahead value.
stationEquationType | Specifies the station equation type.
Links
StationEquationCollection Class, StationEquationCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquationCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods > StationEquationCollection::GetEnumerator Method
StationEquationCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<StationEquation^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<StationEquation^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
StationEquationCollection Class, StationEquationCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquationCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods > StationEquationCollection::GetObjectEnumerator Method
StationEquationCollection::GetObjectEnumerator Method
Collapse All

Implement the method declare in IEnumerable interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator interface.

Links
StationEquationCollection Class, StationEquationCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquationCollection::GetStationEquation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods > StationEquationCollection::GetStationEquation Method
StationEquationCollection::GetStationEquation Method
Collapse All

Gets the StationEquation object in the collection by raw station back.

C#
public StationEquation GetStationEquation(
    double rawStationBack
);
Visual Basic
Public Function GetStationEquation(
    rawStationBack As double
) As StationEquation
Parameters
Parameters | Description
rawStationBack | Raw station back value.
Links
StationEquationCollection Class, StationEquationCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods > Remove Method
Remove Method
Collapse All

Overloaded

Overload List
Method | Description
StationEquationCollection::Remove (double) | Removes a station equation from the collection by raw station back.
StationEquationCollection::Remove (int) | Removes a station equation from the collection at the given index.


StationEquationCollection::Remove Method (double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods > Remove Method > StationEquationCollection::Remove Method (double)
StationEquationCollection::Remove Method (double)
Collapse All

Removes a station equation from the collection by raw station back.

C#
public Remove(
    double rawStationBack
);
Visual Basic
Public Sub Remove(
    rawStationBack As double
)
Parameters
Parameters | Description
rawStationBack | Raw station back value.
Links
StationEquationCollection Class, StationEquationCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquationCollection::Remove Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods > Remove Method > StationEquationCollection::Remove Method (int)
StationEquationCollection::Remove Method (int)
Collapse All

Removes a station equation from the collection at the given index.

C#
public Remove(
    int index
);
Visual Basic
Public Sub Remove(
    index As Integer
)
Parameters
Parameters | Description
index | Index of the StationEquation object to remove.
Links
StationEquationCollection Class, StationEquationCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquationCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Properties
StationEquationCollection Properties
Collapse All

The properties of StationEquationCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of StationEquation objects in the collection.
default | Gets the StationEquation object at a specified index in the collection.
Links
Public Properties


StationEquationCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Properties > StationEquationCollection::Count Property
StationEquationCollection::Count Property
Collapse All

Gets the number of StationEquation objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
StationEquationCollection Class, StationEquationCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationEquationCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Properties > StationEquationCollection::default Property
StationEquationCollection::default Property
Collapse All

Gets the StationEquation object at a specified index in the collection.

C#
public StationEquation default;
Visual Basic
Public Property default() As StationEquation
Parameters
Parameters | Description
Index | Station equation index.
StationEquation | Returns the station equation specified by Index.
Links
StationEquationCollection Class, StationEquationCollection Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationOffsetLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class
StationOffsetLabel Class
Collapse All

This class represents a station offset label.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::StationOffsetLabel
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStaOffsetLabel"))]
public class StationOffsetLabel : Autodesk::Civil::DatabaseServices::FeatureLabel;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStaOffsetLabel"))>
Public Class StationOffsetLabel
Inherits Autodesk::Civil::DatabaseServices::FeatureLabel
Links
StationOffsetLabel Methods, StationOffsetLabel Properties, StationOffsetLabel Members, Class Hierarchy


StationOffsetLabel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Members
StationOffsetLabel Members
Collapse All

The following tables list the members exposed by StationOffsetLabel.

Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Creates a new instance of an AlignmentCurveLabel and adds it to the specified database.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorAtXY | Gets or sets a flag to indicate whether the label should move when the alignment is moved or if it... more
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.
Links
Public Methods, Public Properties


StationOffsetLabel Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Methods
StationOffsetLabel Methods
Collapse All

The methods of StationOffsetLabel are listed here.

Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentCurveLabel and adds it to the specified database.
Links
Public Methods


StationOffsetLabel::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Methods > StationOffsetLabel::Create Method
StationOffsetLabel::Create Method
Collapse All

Creates a new instance of an AlignmentCurveLabel and adds it to the specified database.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId labelStyleId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId markerStyleId,
    Autodesk::AutoCAD::Geometry::Point2d location
);
Visual Basic
Public Function Create(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    labelStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    markerStyleId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    location As Autodesk::AutoCAD::Geometry::Point2d
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
alignmentId | The object id of alignment to which the label is attahed.
labelStyleId | The object id of label style for the label.
markerStyleId | The object id of marker style for the label.
location | The place in which the label is located.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the labelStyleId is not a valid label style of type: LabelStyleType::AlignmentStationOffset.
Links
StationOffsetLabel Class, StationOffsetLabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


StationOffsetLabel Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Properties
StationOffsetLabel Properties
Collapse All

The properties of StationOffsetLabel are listed here.

Public Properties
Public Property | Description
AnchorAtXY | Gets or sets a flag to indicate whether the label should move when the alignment is moved or if it... more
Links
Public Properties


StationOffsetLabel::AnchorAtXY Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Properties > StationOffsetLabel::AnchorAtXY Property
StationOffsetLabel::AnchorAtXY Property
Collapse All

Gets or sets a flag to indicate whether the label should move when the alignment is moved or if it is anchored at a specific point.

C#
public bool AnchorAtXY;
Visual Basic
Public Property AnchorAtXY() As bool
Links
StationOffsetLabel Class, StationOffsetLabel Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationData Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class
SuperElevationData Class
Collapse All

The SuperelevationData class. This class is a collection of SuperelevationDataElement objects for an Alignment.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::SuperElevationData
C#
public class SuperElevationData : CivilWrapper<AeccDbAlignment>, System::Collections::Generic::IEnumerable<SuperElevationDataElement^>;
Visual Basic
Public Class SuperElevationData
Inherits CivilWrapper<AeccDbAlignment>
Inherits System::Collections::Generic::IEnumerable<SuperElevationDataElement^>
Example
SuperElevationData mySuperElevationData = myAlignment.SuperElevationData;
foreach (SuperElevationDataElement dataElement in mySuperElevationData)
{
   ed.WriteMessage("Description: {0}n", dataElement.TransitionPointDescription);

}
Links
SuperElevationData Methods, SuperElevationData Properties, SuperElevationData Members, Class Hierarchy


SuperElevationData Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Members
SuperElevationData Members
Collapse All

The following tables list the members exposed by SuperElevationData.

Public Methods
Public Method | Description
Add | Adds a SuperElevationDataElement object to the SuperElevationData collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes a SuperElevationDataElement at a specified index.
Public Properties
Public Property | Description
Count | Gets the number of items in the collection.
default | Gets the default item.
Links
Public Methods, Public Properties


SuperElevationData Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Methods
SuperElevationData Methods
Collapse All

The methods of SuperElevationData are listed here.

Public Methods
Public Method | Description
Add | Adds a SuperElevationDataElement object to the SuperElevationData collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes a SuperElevationDataElement at a specified index.
Links
Public Methods


SuperElevationData::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Methods > SuperElevationData::Add Method
SuperElevationData::Add Method
Collapse All

Adds a SuperElevationDataElement object to the SuperElevationData collection.

C#
public Add(
    ref SuperElevationDataElement element
);
Visual Basic
Public Sub Add(
    ByRef element As SuperElevationDataElement
)
Parameters
Parameters | Description
element | The new element to add.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the raw station of the input element is out of alignment station range.
Links
SuperElevationData Class, SuperElevationData Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationData::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Methods > SuperElevationData::GetEnumerator Method
SuperElevationData::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<SuperElevationDataElement^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<SuperElevationDataElement^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
SuperElevationData Class, SuperElevationData Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationData::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Methods > SuperElevationData::GetObjectEnumerator Method
SuperElevationData::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
SuperElevationData Class, SuperElevationData Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationData::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Methods > SuperElevationData::Remove Method
SuperElevationData::Remove Method
Collapse All

Removes a SuperElevationDataElement at a specified index.

C#
public Remove(
    int index
);
Visual Basic
Public Sub Remove(
    index As Integer
)
Parameters
Parameters | Description
index | The index location to remove element.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the collection range.
Links
SuperElevationData Class, SuperElevationData Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationData Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Properties
SuperElevationData Properties
Collapse All

The properties of SuperElevationData are listed here.

Public Properties
Public Property | Description
Count | Gets the number of items in the collection.
default | Gets the default item.
Links
Public Properties


SuperElevationData::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Properties > SuperElevationData::Count Property
SuperElevationData::Count Property
Collapse All

Gets the number of items in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
SuperElevationData Class, SuperElevationData Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationData::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Properties > SuperElevationData::default Property
SuperElevationData::default Property
Collapse All

Gets the default item.

C#
public SuperElevationDataElement default;
Visual Basic
Public Property default() As SuperElevationDataElement
Links
SuperElevationData Class, SuperElevationData Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationDataElement Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class
SuperElevationDataElement Class
Collapse All

Superelevation data element at a particular station.

Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::SuperElevationDataElement
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccSuperElevationDataElement"))]
public class SuperElevationDataElement : CivilWrapper<AeccSuperElevationDataElement>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccSuperElevationDataElement"))>
Public Class SuperElevationDataElement
Inherits CivilWrapper<AeccSuperElevationDataElement>
Example
// Create an element at station 11+00.0.
SuperElevationDataElement myDataElement = new SuperElevationDataElement();
myDataElement.RawStation = 1100;
myAlignment.SuperElevationData.Add(myDataElement);
myDataElement.SetSegmentCrossSlope(SuperElevationCrossSegmentType.SuperLeftOutShoulderCrossSlope, 0.05);
myDataElement.SetSegmentCrossSlope(SuperElevationCrossSegmentType.SuperLeftOutLaneCrossSlope, 0.02);
myDataElement.SetSegmentCrossSlope(SuperElevationCrossSegmentType.SuperLeftInLaneCrossSlope, 0.01);
myDataElement.SetSegmentCrossSlope(SuperElevationCrossSegmentType.SuperLeftInShoulderCrossSlope, 0.03);
myDataElement.SetSegmentCrossSlope(SuperElevationCrossSegmentType.SuperRightInShoulderCrossSlope, 0.03);
myDataElement.SetSegmentCrossSlope(SuperElevationCrossSegmentType.SuperRightInLaneCrossSlope, 0.01);
myDataElement.SetSegmentCrossSlope(SuperElevationCrossSegmentType.SuperRightOutLaneCrossSlope, 0.02);
myDataElement.SetSegmentCrossSlope(SuperElevationCrossSegmentType.SuperRightOutShoulderCrossSlope, 0.05);
myDataElement.TransitionPointType = SuperElevationTransitionPointType.SuperManual;
myDataElement.TransitionPointDescription = "Manual adjustment";
Links
SuperElevationDataElement Methods, SuperElevationDataElement Constructors, SuperElevationDataElement Properties, SuperElevationDataElement Members, Class Hierarchy


SuperElevationDataElement Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Members
SuperElevationDataElement Members
Collapse All

The following tables list the members exposed by SuperElevationDataElement.

Public Methods
Public Method | Description
GetSegmentCrossSlope | Gets the superelevation cross slope value.
SetSegmentCrossSlope | Sets the superelevation cross slope value.
SuperElevationDataElement | Default constructor for SuperElevationDataElement, object's data should be set by it's properties.
Public Properties
Public Property | Description
RawStation | Gets or sets raw station value.
SmoothingCurveLength | Gets or sets smoothing curve length for superelevation data element.
TransitionPointDescription | Gets or sets transition point description string.
TransitionPointType | Gets or sets transition point type.
Links
Public Methods, Public Properties


SuperElevationDataElement Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Methods
SuperElevationDataElement Methods
Collapse All

The methods of SuperElevationDataElement are listed here.

Public Methods
Public Method | Description
GetSegmentCrossSlope | Gets the superelevation cross slope value.
SetSegmentCrossSlope | Sets the superelevation cross slope value.
Links
Public Methods


SuperElevationDataElement::GetSegmentCrossSlope Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Methods > SuperElevationDataElement::GetSegmentCrossSlope Method
SuperElevationDataElement::GetSegmentCrossSlope Method
Collapse All

Gets the superelevation cross slope value.

C#
public double GetSegmentCrossSlope(
    SuperElevationCrossSegmentType type
);
Visual Basic
Public Function GetSegmentCrossSlope(
    type As SuperElevationCrossSegmentType
) As double
Parameters
Parameters | Description
type | The enum value to specify SuperElevationCrossSegment type.
Links
SuperElevationDataElement Class, SuperElevationDataElement Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationDataElement::SetSegmentCrossSlope Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Methods > SuperElevationDataElement::SetSegmentCrossSlope Method
SuperElevationDataElement::SetSegmentCrossSlope Method
Collapse All

Sets the superelevation cross slope value.

C#
public SetSegmentCrossSlope(
    SuperElevationCrossSegmentType type,
    double newValue
);
Visual Basic
Public Sub SetSegmentCrossSlope(
    type As SuperElevationCrossSegmentType,
    newValue As double
)
Parameters
Parameters | Description
type | The enum value to specify superelevation cross slope type.
newValue | The double value to specify superelevation cross slope value.
Links
SuperElevationDataElement Class, SuperElevationDataElement Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationDataElement Constructors

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Constructors
SuperElevationDataElement Constructors
Collapse All

The constructors of SuperElevationDataElement are listed here.

Public Methods
Public Method | Description
SuperElevationDataElement | Default constructor for SuperElevationDataElement, object's data should be set by it's properties.
Links
Public Methods


SuperElevationDataElement::SuperElevationDataElement Constructor

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Constructors > SuperElevationDataElement::SuperElevationDataElement Constructor
SuperElevationDataElement::SuperElevationDataElement Constructor
Collapse All

Default constructor for SuperElevationDataElement, object's data should be set by it's properties.

C#
public SuperElevationDataElement();
Visual Basic
Public Sub New()
Links
SuperElevationDataElement Class, SuperElevationDataElement Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationDataElement Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Properties
SuperElevationDataElement Properties
Collapse All

The properties of SuperElevationDataElement are listed here.

Public Properties
Public Property | Description
RawStation | Gets or sets raw station value.
SmoothingCurveLength | Gets or sets smoothing curve length for superelevation data element.
TransitionPointDescription | Gets or sets transition point description string.
TransitionPointType | Gets or sets transition point type.
Links
Public Properties


SuperElevationDataElement::RawStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Properties > SuperElevationDataElement::RawStation Property
SuperElevationDataElement::RawStation Property
Collapse All

Gets or sets raw station value.

C#
public double RawStation;
Visual Basic
Public Property RawStation() As double
Remarks

Station range could be any value here. But SuperElevationDataElement would fail to add to SuperElevationData if raw station is out of alignment station range.

Links
SuperElevationDataElement Class, SuperElevationDataElement Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationDataElement::SmoothingCurveLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Properties > SuperElevationDataElement::SmoothingCurveLength Property
SuperElevationDataElement::SmoothingCurveLength Property
Collapse All

Gets or sets smoothing curve length for superelevation data element.

C#
public double SmoothingCurveLength;
Visual Basic
Public Property SmoothingCurveLength() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval [0.0, 999999999999999980000000.0].
Links
SuperElevationDataElement Class, SuperElevationDataElement Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationDataElement::TransitionPointDescription Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Properties > SuperElevationDataElement::TransitionPointDescription Property
SuperElevationDataElement::TransitionPointDescription Property
Collapse All

Gets or sets transition point description string.

C#
public System::String TransitionPointDescription;
Visual Basic
Public Property TransitionPointDescription() As System::String
Remarks

Sets a transition point description string would automatically sets TransitionPointType to SuperManual

Links
SuperElevationDataElement Class, SuperElevationDataElement Members, Autodesk::Civil::Land::DatabaseServices Namespace


SuperElevationDataElement::TransitionPointType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Properties > SuperElevationDataElement::TransitionPointType Property
SuperElevationDataElement::TransitionPointType Property
Collapse All

Gets or sets transition point type.

C#
public SuperElevationTransitionPointType TransitionPointType;
Visual Basic
Public Property TransitionPointType() As SuperElevationTransitionPointType
Remarks

Sets a transition point description string would automatically sets TransitionPointType to SuperManual

Links
SuperElevationDataElement Class, SuperElevationDataElement Members, Autodesk::Civil::Land::DatabaseServices Namespace


Surface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class
Surface Class
Collapse All

The base class for TIN and grid surfaces. A surface is a three-dimensional geometric representation of the surface (TIN or grid) of an area of land made up of triangles or grids, which are created when the points that make up the surface data are connected.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Surface
        Autodesk::Civil::Land::DatabaseServices::GridSurface
        Autodesk::Civil::Land::DatabaseServices::TinSurface
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSurface"))]
public class Surface : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSurface"))>
Public Class Surface
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
Surface Methods, Surface Properties, Surface Members, Class Hierarchy


Surface Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Members
Surface Members
Collapse All

The following tables list the members exposed by Surface.

Public Methods
Public Method | Description
FindElevationAtXY |
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
IsVolumeSurface | Gets if the surface is a volume surface.
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


Surface Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Methods
Surface Methods
Collapse All

The methods of Surface are listed here.

Public Methods
Public Method | Description
FindElevationAtXY |
Links
Public Methods


Surface::FindElevationAtXY Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Methods > Surface::FindElevationAtXY Method
Surface::FindElevationAtXY Method
Collapse All
C#
public double FindElevationAtXY(
    double x,
    double y
);
Visual Basic
Public Function FindElevationAtXY(
    x As double,
    y As double
) As double
Exceptions
Exceptions | Description
 | PointNotOnEntity
Links
Surface Class, Surface Members, Autodesk::Civil::Land::DatabaseServices Namespace


Surface Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Properties
Surface Properties
Collapse All

The properties of Surface are listed here.

Public Properties
Public Property | Description
IsVolumeSurface | Gets if the surface is a volume surface.
Links
Public Properties


Surface::IsVolumeSurface Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Properties > Surface::IsVolumeSurface Property
Surface::IsVolumeSurface Property
Collapse All

Gets if the surface is a volume surface.

C#
public bool IsVolumeSurface;
Visual Basic
Public Property IsVolumeSurface() As bool
Links
Surface Class, Surface Members, Autodesk::Civil::Land::DatabaseServices Namespace


TinSurface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > TinSurface Class
TinSurface Class
Collapse All

A Triangular Irregular Network (TIN) surface, from points connected together in triangles, and used to interpolate for contours, and to generate profiles/cross-sections.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Surface
        Autodesk::Civil::Land::DatabaseServices::TinSurface
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSurfaceTin"))]
public class TinSurface : Autodesk::Civil::Land::DatabaseServices::Surface;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSurfaceTin"))>
Public Class TinSurface
Inherits Autodesk::Civil::Land::DatabaseServices::Surface
Links
Class Hierarchy


ViewFrame Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrame Class
ViewFrame Class
Collapse All

View frames are rectangular-shaped regions along an alignment that define an area that will be displayed in a sheet.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::ViewFrame
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbViewFrame"))]
public class ViewFrame : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbViewFrame"))>
Public Class ViewFrame
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
ViewFrame Properties, ViewFrame Members, Class Hierarchy


ViewFrame Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrame Class > ViewFrame Members
ViewFrame Members
Collapse All

The following tables list the members exposed by ViewFrame.

Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GroupId | Gets the object id of the view frame group it belongs to.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


ViewFrame Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrame Class > ViewFrame Properties
ViewFrame Properties
Collapse All

The properties of ViewFrame are listed here.

Public Properties
Public Property | Description
GroupId | Gets the object id of the view frame group it belongs to.
Links
Public Properties


ViewFrame::GroupId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrame Class > ViewFrame Properties > ViewFrame::GroupId Property
ViewFrame::GroupId Property
Collapse All

Gets the object id of the view frame group it belongs to.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId GroupId;
Visual Basic
Public Property GroupId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.ViewFrameGroup

Links
ViewFrame Class, ViewFrame Members, Autodesk::Civil::Land::DatabaseServices Namespace


ViewFrameGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class
ViewFrameGroup Class
Collapse All

Manages a single group of view frames that are displaying consecutive station ranges along the same alignment.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::ViewFrameGroup
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbViewFrameGroup"))]
public class ViewFrameGroup : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbViewFrameGroup"))>
Public Class ViewFrameGroup
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
ViewFrameGroup Methods, ViewFrameGroup Members, Class Hierarchy


ViewFrameGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Members
ViewFrameGroup Members
Collapse All

The following tables list the members exposed by ViewFrameGroup.

Public Methods
Public Method | Description
GetMatchLineIds | Gets the objectId collection of all match line.
GetViewFrameIds | Gets the objectId collection of view frame.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


ViewFrameGroup Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Methods
ViewFrameGroup Methods
Collapse All

The methods of ViewFrameGroup are listed here.

Public Methods
Public Method | Description
GetMatchLineIds | Gets the objectId collection of all match line.
GetViewFrameIds | Gets the objectId collection of view frame.
Links
Public Methods


ViewFrameGroup::GetMatchLineIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Methods > ViewFrameGroup::GetMatchLineIds Method
ViewFrameGroup::GetMatchLineIds Method
Collapse All

Gets the objectId collection of all match line.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetMatchLineIds();
Visual Basic
Public Function GetMatchLineIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
ViewFrameGroup Class, ViewFrameGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


ViewFrameGroup::GetViewFrameIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Methods > ViewFrameGroup::GetViewFrameIds Method
ViewFrameGroup::GetViewFrameIds Method
Collapse All

Gets the objectId collection of view frame.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetViewFrameIds();
Visual Basic
Public Function GetViewFrameIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
ViewFrameGroup Class, ViewFrameGroup Members, Autodesk::Civil::Land::DatabaseServices Namespace


Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums
Structs, Records, Enums
Collapse All

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
AlignmentArcConstraintType | Defines the underlying alignment arc entity constraint type. For example, three points, or center radius
AlignmentCreationType | The Autodesk::Civil::Land::DatabaseServices::AlignmentCreationType enumeration.
AlignmentEntityConstraintType | Specifies the underlying alignment entity constraint type.
AlignmentEntityType | Specifies the underlying entity type, for example, tangent, arc, spiral, etc.
AlignmentGeometryPointStationType | Defines types of Stations at geometry points on an alignment.
AlignmentLineConstraintType | Defines the underlying line entity constraint type. For example, two points, or through point.
AlignmentRegionType | Defines alignment regions.
AlignmentSCSConstraintType | Defines the underlying Spiral-Curve-Spiral entity constraint type.
AlignmentSCSCSConstraintType | Defines the underlying Spiral-Curve-Spiral-Curve-Spiral entity constraint type.
AlignmentSCSSCSConstraintType | Defines the underlying Spiral-Curve-Spiral-Spiral-Curve-Spiral entity constraint type.
AlignmentSide | Alignment side enumeration. This enum is used by DistanceToAlignment() to specify on which side of the Alignment to look for... more
AlignmentSpiralConstraintType | Defines the underlying spiral entity constraint type. For example, spiral in radius spiral out, spiral length radius pass point.
AlignmentSSCSSConstraintType | Defines the underlying Spiral-Spiral-Curve-SpiralSpiral entity constraint type.
AlignmentSTSConstraintType | Defines the underlying Spiral-Line-Spiral entity constraint type.
AlignmentSubEntityType | Specifies the sub-entity type, for example, line, arc, spiral, etc.
AlignmentType | The Autodesk::Civil::Land::DatabaseServices::AlignmentType enumeration.
AlignmentUpdateType | The Autodesk::Civil::Land::DatabaseServices::AlignmentUpdateType enumeration.
CurveParamType | Defines the free curve type.
CurveType | Defines the free curve type.
DatumRoundingType | Specifies where to round the vertical split location.
ElevationRangeType | Defines the ways to specify the vertical range of the profile view.
EntityAttachType | Defines the type to attach the entity.
EntityVerticalConstraintType | Specifies the construction constraint type of ProfileEntity, for example, use PassThroughPt1AndPt2 if you create this entity by two fixed... more
HatchCriteriaBoundaryType | Defines the hatch criteria's boundary type.
ProfileEntityConstraintType | Specifies the connection constraint type of ProfileEntity, including fixed(attached to none entity), float(attached to one entity) and free(attached to... more
ProfileEntityType | Specifies the underlying ProfileEntity type, including tangent, circular, symmetric parabola and asymmetric parabola.
ProfileType | Defines the profile type.
ProfileUpdateType | Defines the profile's update mode.
RegionPropertyType | The Autodesk::Civil::Land::DatabaseServices::RegionPropertyType enumeration.
SpiralCurveType | Defines the curve type for a spiral sub-entity.
SpiralDirectionType | Defines the direction of a spiral sub-entity.
SpiralParamType | Defines the type to attch the entity.
SplitStationType | Defines the ways to split profile view.
StationEquationType | Specifies the kind of StationEquation.
StationRangeType | Defines the ways to specify the horizontal range of the profile view.
StationRoundingType | Specifies where to round the horizontal split location.
StationTypes | Defines the possible station types, used by Alignment::GetStationSet().
SubEntityExtensionType | Specifies sub-entity extension type.
SuperElevationCrossSegmentType | Specifies the type of a SuperElevationDataElement cross segment.
SuperElevationTransitionPointType | Specifies the type of a SuperElevationDataElement transition point.
VerticalCurveType | Specifies the geometry type of a ProfileEntity curve, used for three types of parabolic entities.
Links
Enumerations


Autodesk::Civil::Land::DatabaseServices::AlignmentArcConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentArcConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentArcConstraintType Enumeration
Collapse All

Defines the underlying alignment arc entity constraint type. For example, three points, or center radius

C#
public enum AlignmentArcConstraintType {
  ThreePoints = AeccHAlignment::kThreePoints,
  CenterRadius = AeccHAlignment::kCenterRadius,
  CenterPassThroughPoint = AeccHAlignment::kCenterPassthroughPoint,
  PassThroughRadius = AeccHAlignment::kPassThroughRadius,
  PassThroughHoldEnd = AeccHAlignment::kPassThroughHoldEnd,
  PassThroughDirection = AeccHAlignment::kPassThroughDirection,
  Radius = AeccHAlignment::kRadius,
  PassThrough = AeccHAlignment::kPassThrough,
  RadiusAndLength = AeccHAlignment::kRadiusAndLength,
  BestFitArc = AeccHAlignment::kBestFitArc
}
Visual Basic
Public Enum AlignmentArcConstraintType
  ThreePoints = AeccHAlignment::kThreePoints
  CenterRadius = AeccHAlignment::kCenterRadius
  CenterPassThroughPoint = AeccHAlignment::kCenterPassthroughPoint
  PassThroughRadius = AeccHAlignment::kPassThroughRadius
  PassThroughHoldEnd = AeccHAlignment::kPassThroughHoldEnd
  PassThroughDirection = AeccHAlignment::kPassThroughDirection
  Radius = AeccHAlignment::kRadius
  PassThrough = AeccHAlignment::kPassThrough
  RadiusAndLength = AeccHAlignment::kRadiusAndLength
  BestFitArc = AeccHAlignment::kBestFitArc
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentCreationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentCreationType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentCreationType Enumeration
Collapse All

The Autodesk::Civil::Land::DatabaseServices::AlignmentCreationType enumeration.

C#
public enum AlignmentCreationType {
  RuleBasedCreation = AeccHAlignment::kRuleBasedCreation,
  ManuallyCreation = AeccHAlignment::kManuallyCreation
}
Visual Basic
Public Enum AlignmentCreationType
  RuleBasedCreation = AeccHAlignment::kRuleBasedCreation
  ManuallyCreation = AeccHAlignment::kManuallyCreation
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentEntityConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentEntityConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentEntityConstraintType Enumeration
Collapse All

Specifies the underlying alignment entity constraint type.

C#
public enum AlignmentEntityConstraintType {
  Fixed = AeccHAlignment::kFixed,
  Float = AeccHAlignment::kFloat,
  Free = AeccHAlignment::kFree
}
Visual Basic
Public Enum AlignmentEntityConstraintType
  Fixed = AeccHAlignment::kFixed
  Float = AeccHAlignment::kFloat
  Free = AeccHAlignment::kFree
End Enum
Remarks

An alignment entity has one of these three constraint types in relationship to an adjacent alignment entity: Fixed, Float or Free.

For more information about entity constraint types, see Entity Descriptions in the Civil 3D User's Guide help.


Autodesk::Civil::Land::DatabaseServices::AlignmentEntityType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentEntityType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentEntityType Enumeration
Collapse All

Specifies the underlying entity type, for example, tangent, arc, spiral, etc.

C#
public enum AlignmentEntityType {
  Line = AeccHAlignment::kLine,
  Arc = AeccHAlignment::kArc,
  Spiral = AeccHAlignment::kSpiral,
  SpiralCurveSpiral = AeccHAlignment::kSpiralCurveSpiral,
  SpiralLineSpiral = AeccHAlignment::kSpiralTanSpiral,
  SpiralLine = AeccHAlignment::kSpiralTan,
  LineSpiral = AeccHAlignment::kTanSpiral,
  SpiralCurve = AeccHAlignment::kSpiralCurve,
  CurveSpiral = AeccHAlignment::kCurveSpiral,
  SpiralSpiralCurveSpiralSpiral = AeccHAlignment::kSpSpCurveSpSp,
  SpiralCurveSpiralCurveSpiral = AeccHAlignment::kSpCurveSpCurveSp,
  SpiralCurveSpiralSpiralCurveSpiral = AeccHAlignment::kSpCurveSpSpCurveSp,
  SpiralSpiral = AeccHAlignment::kSpiralSpiral,
  SpiralSpiralCurve = AeccHAlignment::kSpiralSpiralCurve,
  CurveSpiralSpiral = AeccHAlignment::kCurveSpiralSpiral
}
Visual Basic
Public Enum AlignmentEntityType
  Line = AeccHAlignment::kLine
  Arc = AeccHAlignment::kArc
  Spiral = AeccHAlignment::kSpiral
  SpiralCurveSpiral = AeccHAlignment::kSpiralCurveSpiral
  SpiralLineSpiral = AeccHAlignment::kSpiralTanSpiral
  SpiralLine = AeccHAlignment::kSpiralTan
  LineSpiral = AeccHAlignment::kTanSpiral
  SpiralCurve = AeccHAlignment::kSpiralCurve
  CurveSpiral = AeccHAlignment::kCurveSpiral
  SpiralSpiralCurveSpiralSpiral = AeccHAlignment::kSpSpCurveSpSp
  SpiralCurveSpiralCurveSpiral = AeccHAlignment::kSpCurveSpCurveSp
  SpiralCurveSpiralSpiralCurveSpiral = AeccHAlignment::kSpCurveSpSpCurveSp
  SpiralSpiral = AeccHAlignment::kSpiralSpiral
  SpiralSpiralCurve = AeccHAlignment::kSpiralSpiralCurve
  CurveSpiralSpiral = AeccHAlignment::kCurveSpiralSpiral
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentGeometryPointStationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentGeometryPointStationType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentGeometryPointStationType Enumeration
Collapse All

Defines types of Stations at geometry points on an alignment.

C#
public enum AlignmentGeometryPointStationType {
  BegOfAlign = AeccAlignStation::kStnGPBegOfAlign,
  EndOfAlign = AeccAlignStation::kStnGPEndOfAlign,
  TanTan = AeccAlignStation::kStnGPTanTan,
  TanCurve = AeccAlignStation::kStnGPTanCurve,
  CurveTan = AeccAlignStation::kStnGPCurveTan,
  CurveCompCurve = AeccAlignStation::kStnGPCurveCompCurve,
  CurveRevCurve = AeccAlignStation::kStnGPCurveRevCurve,
  TanSpiral = AeccAlignStation::kStnGPTanSpiral,
  SpiralTan = AeccAlignStation::kStnGPSpiralTan,
  CurveSpiral = AeccAlignStation::kStnGPCurveSpiral,
  SpiralCurve = AeccAlignStation::kStnGPSpiralCurve,
  SpiralCompSpiral = AeccAlignStation::kStnGPSpiralCompSpiral,
  SpiralRevSpiral = AeccAlignStation::kStnGPSpiralRevSpiral,
  PI = AeccAlignStation::kStnGPPI,
  CPI = AeccAlignStation::kStnGPCPI,
  SPI = AeccAlignStation::kStnGPSPI,
  ProfileTanCurve = AeccAlignStation::kStnVGPTanCurve,
  ProfileCurveTan = AeccAlignStation::kStnVGPCurveTan,
  ProfileCurveCompCurve = AeccAlignStation::kStnVGPCurveCompCurve,
  ProfileCurveRevCurve = AeccAlignStation::kStnVGPCurveRevCurve,
  ProfileCurveLowPoint = AeccAlignStation::kStnVGPCurveLowPoint,
  ProfileCurveHighPoint = AeccAlignStation::kStnVGPCurveHighPoint,
  ProfileCurvePVI = AeccAlignStation::kStnVGPCurvePVI,
  ProfileBegOfAlign = AeccAlignStation::kStnVGPBegOfAlign,
  ProfileEndOfAlign = AeccAlignStation::kStnVGPEndOfAlign,
  ProfileTanTan = AeccAlignStation::kStnVGPTanTan,
  ProfileOverallLowPoint = AeccAlignStation::kStnVGPOverallLowPoint,
  ProfileOverallHighPoint = AeccAlignStation::kStnVGPOverallHighPoint,
  BeginNormalCrown = AeccAlignStation::kBeginNormalCrown,
  BeginNormalShoulder = AeccAlignStation::kStnBeginNormalShoulder,
  BeginFullSuper = AeccAlignStation::kStnBeginFullSuper,
  EndFullSuper = AeccAlignStation::kStnEndFullSuper,
  EndNormalShoulder = AeccAlignStation::kStnEndNormalShoulder,
  EndNormalCrown = AeccAlignStation::kStnEndNormalCrown,
  LevelCrown = AeccAlignStation::kStnLevelCrown,
  LowShoulderMatch = AeccAlignStation::kStnLowShoulderMatch,
  ReverseCrown = AeccAlignStation::kStnReverseCrown,
  Manual = AeccAlignStation::kStnManual,
  ShoulderBreakOver = AeccAlignStation::kStnShoulderBreakOver
}
Visual Basic
Public Enum AlignmentGeometryPointStationType
  BegOfAlign = AeccAlignStation::kStnGPBegOfAlign
  EndOfAlign = AeccAlignStation::kStnGPEndOfAlign
  TanTan = AeccAlignStation::kStnGPTanTan
  TanCurve = AeccAlignStation::kStnGPTanCurve
  CurveTan = AeccAlignStation::kStnGPCurveTan
  CurveCompCurve = AeccAlignStation::kStnGPCurveCompCurve
  CurveRevCurve = AeccAlignStation::kStnGPCurveRevCurve
  TanSpiral = AeccAlignStation::kStnGPTanSpiral
  SpiralTan = AeccAlignStation::kStnGPSpiralTan
  CurveSpiral = AeccAlignStation::kStnGPCurveSpiral
  SpiralCurve = AeccAlignStation::kStnGPSpiralCurve
  SpiralCompSpiral = AeccAlignStation::kStnGPSpiralCompSpiral
  SpiralRevSpiral = AeccAlignStation::kStnGPSpiralRevSpiral
  PI = AeccAlignStation::kStnGPPI
  CPI = AeccAlignStation::kStnGPCPI
  SPI = AeccAlignStation::kStnGPSPI
  ProfileTanCurve = AeccAlignStation::kStnVGPTanCurve
  ProfileCurveTan = AeccAlignStation::kStnVGPCurveTan
  ProfileCurveCompCurve = AeccAlignStation::kStnVGPCurveCompCurve
  ProfileCurveRevCurve = AeccAlignStation::kStnVGPCurveRevCurve
  ProfileCurveLowPoint = AeccAlignStation::kStnVGPCurveLowPoint
  ProfileCurveHighPoint = AeccAlignStation::kStnVGPCurveHighPoint
  ProfileCurvePVI = AeccAlignStation::kStnVGPCurvePVI
  ProfileBegOfAlign = AeccAlignStation::kStnVGPBegOfAlign
  ProfileEndOfAlign = AeccAlignStation::kStnVGPEndOfAlign
  ProfileTanTan = AeccAlignStation::kStnVGPTanTan
  ProfileOverallLowPoint = AeccAlignStation::kStnVGPOverallLowPoint
  ProfileOverallHighPoint = AeccAlignStation::kStnVGPOverallHighPoint
  BeginNormalCrown = AeccAlignStation::kBeginNormalCrown
  BeginNormalShoulder = AeccAlignStation::kStnBeginNormalShoulder
  BeginFullSuper = AeccAlignStation::kStnBeginFullSuper
  EndFullSuper = AeccAlignStation::kStnEndFullSuper
  EndNormalShoulder = AeccAlignStation::kStnEndNormalShoulder
  EndNormalCrown = AeccAlignStation::kStnEndNormalCrown
  LevelCrown = AeccAlignStation::kStnLevelCrown
  LowShoulderMatch = AeccAlignStation::kStnLowShoulderMatch
  ReverseCrown = AeccAlignStation::kStnReverseCrown
  Manual = AeccAlignStation::kStnManual
  ShoulderBreakOver = AeccAlignStation::kStnShoulderBreakOver
End Enum
Remarks

For more information, see Creating Points at the Geometry Points of Alignments in the Civil 3D User's Guide.


Autodesk::Civil::Land::DatabaseServices::AlignmentLineConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentLineConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentLineConstraintType Enumeration
Collapse All

Defines the underlying line entity constraint type. For example, two points, or through point.

C#
public enum AlignmentLineConstraintType {
  TwoPoints = AeccHAlignment::kTwoPoints,
  ThroughPoint = AeccHAlignment::kThroughPoint,
  Length = AeccHAlignment::kLength,
  NoConstraint = AeccHAlignment::kNoConstraint,
  BestFit = AeccHAlignment::kBestFitLine
}
Visual Basic
Public Enum AlignmentLineConstraintType
  TwoPoints = AeccHAlignment::kTwoPoints
  ThroughPoint = AeccHAlignment::kThroughPoint
  Length = AeccHAlignment::kLength
  NoConstraint = AeccHAlignment::kNoConstraint
  BestFit = AeccHAlignment::kBestFitLine
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentRegionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentRegionType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentRegionType Enumeration
Collapse All

Defines alignment regions.

C#
public enum AlignmentRegionType {
  Specific = AeccAlignOffsetRegion::kSpecific,
  Norminal = AeccAlignOffsetRegion::kNorminal
}
Visual Basic
Public Enum AlignmentRegionType
  Specific = AeccAlignOffsetRegion::kSpecific
  Norminal = AeccAlignOffsetRegion::kNorminal
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentSCSConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentSCSConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentSCSConstraintType Enumeration
Collapse All

Defines the underlying Spiral-Curve-Spiral entity constraint type.

C#
public enum AlignmentSCSConstraintType {
  SpiralInRadiusSpiralOut = AeccHAlignment::kSpiralInRadiusSpiralOut,
  SpiralLenRadiusPassPt = AeccHAlignment::kSpiralLenRadiusPassPt,
  SpiralLenRadiusArcLen = AeccHAlignment::kSpiralLenRadiusArcLen,
  SpiralLenRadius = AeccHAlignment::kSpiralLenRadius,
  SpiralLength = AeccHAlignment::kSpiralLength,
  SpInLenSpOutLen = AeccHAlignment::kSpInLenSpOutLen,
  SpInAValSpOutAVal = AeccHAlignment::kSpInAValSpOutAVal,
  Spiral1AValRadiusSpiral2AVal = AeccHAlignment::kSpiral1AValRadiusSpiral2AVal,
  SpiralAValRadiusPassPt = AeccHAlignment::kSpiralAValRadiusPassPt,
  SpiralAValRadiusArcLen = AeccHAlignment::kSpiralAValRadiusArcLen,
  SpiralAValRadius = AeccHAlignment::kSpiralAValRadius,
  SpiralAVal = AeccHAlignment::kSpiralAVal,
  SpiralNoParameter = AeccHAlignment::kSpiralNoParameter
}
Visual Basic
Public Enum AlignmentSCSConstraintType
  SpiralInRadiusSpiralOut = AeccHAlignment::kSpiralInRadiusSpiralOut
  SpiralLenRadiusPassPt = AeccHAlignment::kSpiralLenRadiusPassPt
  SpiralLenRadiusArcLen = AeccHAlignment::kSpiralLenRadiusArcLen
  SpiralLenRadius = AeccHAlignment::kSpiralLenRadius
  SpiralLength = AeccHAlignment::kSpiralLength
  SpInLenSpOutLen = AeccHAlignment::kSpInLenSpOutLen
  SpInAValSpOutAVal = AeccHAlignment::kSpInAValSpOutAVal
  Spiral1AValRadiusSpiral2AVal = AeccHAlignment::kSpiral1AValRadiusSpiral2AVal
  SpiralAValRadiusPassPt = AeccHAlignment::kSpiralAValRadiusPassPt
  SpiralAValRadiusArcLen = AeccHAlignment::kSpiralAValRadiusArcLen
  SpiralAValRadius = AeccHAlignment::kSpiralAValRadius
  SpiralAVal = AeccHAlignment::kSpiralAVal
  SpiralNoParameter = AeccHAlignment::kSpiralNoParameter
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentSCSCSConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentSCSCSConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentSCSCSConstraintType Enumeration
Collapse All

Defines the underlying Spiral-Curve-Spiral-Curve-Spiral entity constraint type.

C#
public enum AlignmentSCSCSConstraintType {
  SpLenAndTanLenIn = AeccHAlignment::kSCSCSBySpLenAndTanLenIn,
  SpLenAndStartPoint = AeccHAlignment::kSCSCSBySpLenAndStartPoint,
  SpLenAndArc1Angle = AeccHAlignment::kSCSCSBySpLenAndArc1Angle,
  SpLenAndArc1PassPt = AeccHAlignment::kSCSCSBySpLenAndArc1PassPt,
  SpAValAndTanLenIn = AeccHAlignment::kSCSCSBySpAValAndTanLenIn,
  SpAValAndStartPoint = AeccHAlignment::kSCSCSBySpAValAndStartPoint,
  SpAValAndArc1Angle = AeccHAlignment::kSCSCSBySpAValAndArc1Angle,
  SpAValAndArc1PassPt = AeccHAlignment::kSCSCSBySpAValAndArc1PassPt,
  SpLenAndTanLenOut = AeccHAlignment::kSCSCSBySpLenAndTanLenOut,
  SpLenAndEndPoint = AeccHAlignment::kSCSCSBySpLenAndEndPoint,
  SpLenAndArc2Angle = AeccHAlignment::kSCSCSBySpLenAndArc2Angle,
  SpLenAndArc2PassPt = AeccHAlignment::kSCSCSBySpLenAndArc2PassPt,
  SpAValAndTanLenOut = AeccHAlignment::kSCSCSBySpAValAndTanLenOut,
  SpAValAndEndPoint = AeccHAlignment::kSCSCSBySpAValAndEndPoint,
  SpAValAndArc2Angle = AeccHAlignment::kSCSCSBySpAValAndArc2Angle,
  SpAValAndArc2PassPt = AeccHAlignment::kSCSCSBySpAValAndArc2PassPt,
  SpLenAndArc1Length = AeccHAlignment::kSCSCSBySpLenAndArc1Length,
  SpLenAndArc2Length = AeccHAlignment::kSCSCSBySpLenAndArc2Length,
  SpAValAndArc1Length = AeccHAlignment::kSCSCSBySpAValAndArc1Length,
  SpAValAndArc2Length = AeccHAlignment::kSCSCSBySpAValAndArc2Length
}
Visual Basic
Public Enum AlignmentSCSCSConstraintType
  SpLenAndTanLenIn = AeccHAlignment::kSCSCSBySpLenAndTanLenIn
  SpLenAndStartPoint = AeccHAlignment::kSCSCSBySpLenAndStartPoint
  SpLenAndArc1Angle = AeccHAlignment::kSCSCSBySpLenAndArc1Angle
  SpLenAndArc1PassPt = AeccHAlignment::kSCSCSBySpLenAndArc1PassPt
  SpAValAndTanLenIn = AeccHAlignment::kSCSCSBySpAValAndTanLenIn
  SpAValAndStartPoint = AeccHAlignment::kSCSCSBySpAValAndStartPoint
  SpAValAndArc1Angle = AeccHAlignment::kSCSCSBySpAValAndArc1Angle
  SpAValAndArc1PassPt = AeccHAlignment::kSCSCSBySpAValAndArc1PassPt
  SpLenAndTanLenOut = AeccHAlignment::kSCSCSBySpLenAndTanLenOut
  SpLenAndEndPoint = AeccHAlignment::kSCSCSBySpLenAndEndPoint
  SpLenAndArc2Angle = AeccHAlignment::kSCSCSBySpLenAndArc2Angle
  SpLenAndArc2PassPt = AeccHAlignment::kSCSCSBySpLenAndArc2PassPt
  SpAValAndTanLenOut = AeccHAlignment::kSCSCSBySpAValAndTanLenOut
  SpAValAndEndPoint = AeccHAlignment::kSCSCSBySpAValAndEndPoint
  SpAValAndArc2Angle = AeccHAlignment::kSCSCSBySpAValAndArc2Angle
  SpAValAndArc2PassPt = AeccHAlignment::kSCSCSBySpAValAndArc2PassPt
  SpLenAndArc1Length = AeccHAlignment::kSCSCSBySpLenAndArc1Length
  SpLenAndArc2Length = AeccHAlignment::kSCSCSBySpLenAndArc2Length
  SpAValAndArc1Length = AeccHAlignment::kSCSCSBySpAValAndArc1Length
  SpAValAndArc2Length = AeccHAlignment::kSCSCSBySpAValAndArc2Length
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentSCSSCSConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentSCSSCSConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentSCSSCSConstraintType Enumeration
Collapse All

Defines the underlying Spiral-Curve-Spiral-Spiral-Curve-Spiral entity constraint type.

C#
public enum AlignmentSCSSCSConstraintType {
  SpLenAndStartPoint = AeccHAlignment::kSCSSCSBySpLenAndStartPoint,
  SpLenAndArc1Angle = AeccHAlignment::kSCSSCSBySpLenAndArc1Angle,
  SpLenAndArc1PassPt = AeccHAlignment::kSCSSCSBySpLenAndArc1PassPt,
  SpAValAndStartPoint = AeccHAlignment::kSCSSCSBySpAValAndStartPoint,
  SpAValAndArc1Angle = AeccHAlignment::kSCSSCSBySpAValAndArc1Angle,
  SpAValAndArc1PassPt = AeccHAlignment::kSCSSCSBySpAValAndArc1PassPt,
  SpLenAndEndPoint = AeccHAlignment::kSCSSCSBySpLenAndEndPoint,
  SpLenAndArc2Angle = AeccHAlignment::kSCSSCSBySpLenAndArc2Angle,
  SpLenAndArc2PassPt = AeccHAlignment::kSCSSCSBySpLenAndArc2PassPt,
  SpAValAndEndPoint = AeccHAlignment::kSCSSCSBySpAValAndEndPoint,
  SpAValAndArc2Angle = AeccHAlignment::kSCSSCSBySpAValAndArc2Angle,
  SpAValAndArc2PassPt = AeccHAlignment::kSCSSCSBySpAValAndArc2PassPt,
  SpLenAndArc1Length = AeccHAlignment::kSCSSCSBySpLenAndArc1Length,
  SpLenAndArc2Length = AeccHAlignment::kSCSSCSBySpLenAndArc2Length,
  SpAValAndArc1Length = AeccHAlignment::kSCSSCSBySpAValAndArc1Length,
  SpAValAndArc2Length = AeccHAlignment::kSCSSCSBySpAValAndArc2Length
}
Visual Basic
Public Enum AlignmentSCSSCSConstraintType
  SpLenAndStartPoint = AeccHAlignment::kSCSSCSBySpLenAndStartPoint
  SpLenAndArc1Angle = AeccHAlignment::kSCSSCSBySpLenAndArc1Angle
  SpLenAndArc1PassPt = AeccHAlignment::kSCSSCSBySpLenAndArc1PassPt
  SpAValAndStartPoint = AeccHAlignment::kSCSSCSBySpAValAndStartPoint
  SpAValAndArc1Angle = AeccHAlignment::kSCSSCSBySpAValAndArc1Angle
  SpAValAndArc1PassPt = AeccHAlignment::kSCSSCSBySpAValAndArc1PassPt
  SpLenAndEndPoint = AeccHAlignment::kSCSSCSBySpLenAndEndPoint
  SpLenAndArc2Angle = AeccHAlignment::kSCSSCSBySpLenAndArc2Angle
  SpLenAndArc2PassPt = AeccHAlignment::kSCSSCSBySpLenAndArc2PassPt
  SpAValAndEndPoint = AeccHAlignment::kSCSSCSBySpAValAndEndPoint
  SpAValAndArc2Angle = AeccHAlignment::kSCSSCSBySpAValAndArc2Angle
  SpAValAndArc2PassPt = AeccHAlignment::kSCSSCSBySpAValAndArc2PassPt
  SpLenAndArc1Length = AeccHAlignment::kSCSSCSBySpLenAndArc1Length
  SpLenAndArc2Length = AeccHAlignment::kSCSSCSBySpLenAndArc2Length
  SpAValAndArc1Length = AeccHAlignment::kSCSSCSBySpAValAndArc1Length
  SpAValAndArc2Length = AeccHAlignment::kSCSSCSBySpAValAndArc2Length
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentSide Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentSide Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentSide Enumeration
Collapse All

Alignment side enumeration. This enum is used by DistanceToAlignment() to specify on which side of the Alignment to look for the target Alignment. This is required in the situation where the Alignments cross. Left and right are relative to a position at the Alignment start point facing the end point.

C#
public enum AlignmentSide {
  Both = AeccDbAlignment::kSideBoth,
  Left = AeccDbAlignment::kSideLeft,
  Right = AeccDbAlignment::kSideRight
}
Visual Basic
Public Enum AlignmentSide
  Both = AeccDbAlignment::kSideBoth
  Left = AeccDbAlignment::kSideLeft
  Right = AeccDbAlignment::kSideRight
End Enum
Members
Members | Description
Both | Look for the target Alignment on both sides, return the shortest distance.
Left | Look for the target Alignment on the left side only.
Right | Look for the target Alignment on the right side only.


Autodesk::Civil::Land::DatabaseServices::AlignmentSpiralConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentSpiralConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentSpiralConstraintType Enumeration
Collapse All

Defines the underlying spiral entity constraint type. For example, spiral in radius spiral out, spiral length radius pass point.

C#
public enum AlignmentSpiralConstraintType {
  StartPtAndDirRadiusLength = AeccHAlignment::kSpiralStartPtAndDirRadiusLength,
  StartPtAndDirStartAndEndRadiusLength = AeccHAlignment::kSpiralStartPtAndDirStartAndEndRadiusLength
}
Visual Basic
Public Enum AlignmentSpiralConstraintType
  StartPtAndDirRadiusLength = AeccHAlignment::kSpiralStartPtAndDirRadiusLength
  StartPtAndDirStartAndEndRadiusLength = AeccHAlignment::kSpiralStartPtAndDirStartAndEndRadiusLength
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentSSCSSConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentSSCSSConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentSSCSSConstraintType Enumeration
Collapse All

Defines the underlying Spiral-Spiral-Curve-SpiralSpiral entity constraint type.

C#
public enum AlignmentSSCSSConstraintType {
  kSp1LenSp2LenRadiusPt = AeccHAlignment::kSp1LenSp2LenRadiusPt,
  kSp1LenSp2LenPt1Pt2 = AeccHAlignment::kSp1LenSp2LenPt1Pt2,
  kSp1AValSp2AValRadiusPt = AeccHAlignment::kSp1AValSp2AValRadiusPt,
  kSp1AValSp2AValPt1Pt2 = AeccHAlignment::kSp1AValSp2AValPt1Pt2
}
Visual Basic
Public Enum AlignmentSSCSSConstraintType
  kSp1LenSp2LenRadiusPt = AeccHAlignment::kSp1LenSp2LenRadiusPt
  kSp1LenSp2LenPt1Pt2 = AeccHAlignment::kSp1LenSp2LenPt1Pt2
  kSp1AValSp2AValRadiusPt = AeccHAlignment::kSp1AValSp2AValRadiusPt
  kSp1AValSp2AValPt1Pt2 = AeccHAlignment::kSp1AValSp2AValPt1Pt2
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentSTSConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentSTSConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentSTSConstraintType Enumeration
Collapse All

Defines the underlying Spiral-Line-Spiral entity constraint type.

C#
public enum AlignmentSTSConstraintType {
  Spiral1LengthSpiral2Length = AeccHAlignment::kSpiral1LenSpiral2Len,
  TangentLength = AeccHAlignment::kTangentLength,
  Spiral1AValSpiral2AVal = AeccHAlignment::kSpiral1AValSpiral2AVal,
  SpiralLengthTangentPassPt = AeccHAlignment::kSpiralLenTanPassPt,
  SpiralLengthTangentLength = AeccHAlignment::kSpiralLenTanLength,
  SpiralAValTangentPassPt = AeccHAlignment::kSpiralAValTanPassPt,
  SpiralAValTangentLength = AeccHAlignment::kSpiralAValTanLength
}
Visual Basic
Public Enum AlignmentSTSConstraintType
  Spiral1LengthSpiral2Length = AeccHAlignment::kSpiral1LenSpiral2Len
  TangentLength = AeccHAlignment::kTangentLength
  Spiral1AValSpiral2AVal = AeccHAlignment::kSpiral1AValSpiral2AVal
  SpiralLengthTangentPassPt = AeccHAlignment::kSpiralLenTanPassPt
  SpiralLengthTangentLength = AeccHAlignment::kSpiralLenTanLength
  SpiralAValTangentPassPt = AeccHAlignment::kSpiralAValTanPassPt
  SpiralAValTangentLength = AeccHAlignment::kSpiralAValTanLength
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityType Enumeration
Collapse All

Specifies the sub-entity type, for example, line, arc, spiral, etc.

C#
public enum AlignmentSubEntityType {
  Line = 0,
  Arc,
  Spiral
}
Visual Basic
Public Enum AlignmentSubEntityType
  Line = 0
  Arc
  Spiral
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentType Enumeration
Collapse All

The Autodesk::Civil::Land::DatabaseServices::AlignmentType enumeration.

C#
public enum AlignmentType {
  Centerline = AeccHAlignment::kCenterLine,
  Offset = AeccHAlignment::kOffset,
  CurbReturn = AeccHAlignment::kCurbReturn,
  Utility = AeccHAlignment::kUtility
}
Visual Basic
Public Enum AlignmentType
  Centerline = AeccHAlignment::kCenterLine
  Offset = AeccHAlignment::kOffset
  CurbReturn = AeccHAlignment::kCurbReturn
  Utility = AeccHAlignment::kUtility
End Enum


Autodesk::Civil::Land::DatabaseServices::AlignmentUpdateType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::AlignmentUpdateType Enumeration
Autodesk::Civil::Land::DatabaseServices::AlignmentUpdateType Enumeration
Collapse All

The Autodesk::Civil::Land::DatabaseServices::AlignmentUpdateType enumeration.

C#
public enum AlignmentUpdateType {
  DynamicUpdate = AeccHAlignment::kDynamicUpdate,
  StaticUpdate = AeccHAlignment::kStaticUpdate
}
Visual Basic
Public Enum AlignmentUpdateType
  DynamicUpdate = AeccHAlignment::kDynamicUpdate
  StaticUpdate = AeccHAlignment::kStaticUpdate
End Enum


Autodesk::Civil::Land::DatabaseServices::CurveParamType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::CurveParamType Enumeration
Autodesk::Civil::Land::DatabaseServices::CurveParamType Enumeration
Collapse All

Defines the free curve type.

C#
public enum CurveParamType {
  Radius = AeccRGGraph::kRadius,
  DegreeOfCurve = AeccRGGraph::kDegreeOfCurve,
  TangentLength = AeccRGGraph::kTangentLength,
  ChordLength = AeccRGGraph::kChordLength,
  CurveLength = AeccRGGraph::kCurveLength,
  ExternalDist = AeccRGGraph::kExternalDist,
  MiddleOrdinate = AeccRGGraph::kMiddleOrdinate,
  CurveAngle = AeccRGGraph::kCurveAngle,
  CurveThroughPoint = AeccRGGraph::kCurvethroughPoint
}
Visual Basic
Public Enum CurveParamType
  Radius = AeccRGGraph::kRadius
  DegreeOfCurve = AeccRGGraph::kDegreeOfCurve
  TangentLength = AeccRGGraph::kTangentLength
  ChordLength = AeccRGGraph::kChordLength
  CurveLength = AeccRGGraph::kCurveLength
  ExternalDist = AeccRGGraph::kExternalDist
  MiddleOrdinate = AeccRGGraph::kMiddleOrdinate
  CurveAngle = AeccRGGraph::kCurveAngle
  CurveThroughPoint = AeccRGGraph::kCurvethroughPoint
End Enum


Autodesk::Civil::Land::DatabaseServices::CurveType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::CurveType Enumeration
Autodesk::Civil::Land::DatabaseServices::CurveType Enumeration
Collapse All

Defines the free curve type.

C#
public enum CurveType {
  Compound,
  Reverse
}
Visual Basic
Public Enum CurveType
  Compound
  Reverse
End Enum


Autodesk::Civil::Land::DatabaseServices::DatumRoundingType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::DatumRoundingType Enumeration
Autodesk::Civil::Land::DatabaseServices::DatumRoundingType Enumeration
Collapse All

Specifies where to round the vertical split location.

C#
public enum DatumRoundingType {
  ExactStation = AeccDbGraph::kSplitOptionsDatumExact,
  PreviousMajorGrid = AeccDbGraph::kSplitOptionsDatumMajor,
  PreviousMinorGrid = AeccDbGraph::kSplitOptionsDatumMinor
}
Visual Basic
Public Enum DatumRoundingType
  ExactStation = AeccDbGraph::kSplitOptionsDatumExact
  PreviousMajorGrid = AeccDbGraph::kSplitOptionsDatumMajor
  PreviousMinorGrid = AeccDbGraph::kSplitOptionsDatumMinor
End Enum


Autodesk::Civil::Land::DatabaseServices::ElevationRangeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::ElevationRangeType Enumeration
Autodesk::Civil::Land::DatabaseServices::ElevationRangeType Enumeration
Collapse All

Defines the ways to specify the vertical range of the profile view.

C#
public enum ElevationRangeType {
  Automatic = 0,
  UserSpecified = 1
}
Visual Basic
Public Enum ElevationRangeType
  Automatic = 0
  UserSpecified = 1
End Enum


Autodesk::Civil::Land::DatabaseServices::EntityAttachType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::EntityAttachType Enumeration
Autodesk::Civil::Land::DatabaseServices::EntityAttachType Enumeration
Collapse All

Defines the type to attach the entity.

C#
public enum EntityAttachType {
  Append,
  Prepend
}
Visual Basic
Public Enum EntityAttachType
  Append
  Prepend
End Enum


Autodesk::Civil::Land::DatabaseServices::EntityVerticalConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::EntityVerticalConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::EntityVerticalConstraintType Enumeration
Collapse All

Specifies the construction constraint type of ProfileEntity, for example, use PassThroughPt1AndPt2 if you create this entity by two fixed points. Note that some items are only valid for ProfileLine while others are only valid for three parabolic entities.

C#
public enum EntityVerticalConstraintType {
  CurveLength = AeccVAlignment::kCurveLength,
  KValue = AeccVAlignment::kKValue,
  Radius = AeccVAlignment::kRadius,
  PassThroughPt = AeccVAlignment::kPassThroughPt,
  PassThroughPt1AndPt2 = AeccVAlignment::kPassThroughPt1AndPt2,
  ThreePassPoints = AeccVAlignment::kThreePassPoints,
  TwoPassPointsAndGrade = AeccVAlignment::kTwoPassPointsAndGrade,
  TwoPassPointsAndParameter = AeccVAlignment::kTwoPassPointsAndParameter,
  PreviousSubEntPassPtAndParameter = AeccVAlignment::kPrevSubEntPassPtAndParameter,
  NextSubEntPassPtAndParameter = AeccVAlignment::kNextSubEntPassPtAndParameter,
  PreviousSubEntPassPtWithGrade = AeccVAlignment::kPrevSubEntPassPtWithGrade,
  NextSubEntPassPtWithGrade = AeccVAlignment::kNextSubEntPassPtWithGrade,
  PreviousSubEntEndAndPassPt = AeccVAlignment::kPrevSubEntEndAndPassPt,
  NextSubEntEndAndPassPt = AeccVAlignment::kNextSubEntEndAndPassPt,
  PassThroughPt1 = AeccVAlignment::kPassThroughPt1,
  PassThroughPt2 = AeccVAlignment::kPassThroughPt2,
  NoConstraints = AeccVAlignment::kNoConstraints,
  BestFit = AeccVAlignment::kBestFit
}
Visual Basic
Public Enum EntityVerticalConstraintType
  CurveLength = AeccVAlignment::kCurveLength
  KValue = AeccVAlignment::kKValue
  Radius = AeccVAlignment::kRadius
  PassThroughPt = AeccVAlignment::kPassThroughPt
  PassThroughPt1AndPt2 = AeccVAlignment::kPassThroughPt1AndPt2
  ThreePassPoints = AeccVAlignment::kThreePassPoints
  TwoPassPointsAndGrade = AeccVAlignment::kTwoPassPointsAndGrade
  TwoPassPointsAndParameter = AeccVAlignment::kTwoPassPointsAndParameter
  PreviousSubEntPassPtAndParameter = AeccVAlignment::kPrevSubEntPassPtAndParameter
  NextSubEntPassPtAndParameter = AeccVAlignment::kNextSubEntPassPtAndParameter
  PreviousSubEntPassPtWithGrade = AeccVAlignment::kPrevSubEntPassPtWithGrade
  NextSubEntPassPtWithGrade = AeccVAlignment::kNextSubEntPassPtWithGrade
  PreviousSubEntEndAndPassPt = AeccVAlignment::kPrevSubEntEndAndPassPt
  NextSubEntEndAndPassPt = AeccVAlignment::kNextSubEntEndAndPassPt
  PassThroughPt1 = AeccVAlignment::kPassThroughPt1
  PassThroughPt2 = AeccVAlignment::kPassThroughPt2
  NoConstraints = AeccVAlignment::kNoConstraints
  BestFit = AeccVAlignment::kBestFit
End Enum


Autodesk::Civil::Land::DatabaseServices::HatchCriteriaBoundaryType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::HatchCriteriaBoundaryType Enumeration
Autodesk::Civil::Land::DatabaseServices::HatchCriteriaBoundaryType Enumeration
Collapse All

Defines the hatch criteria's boundary type.

C#
public enum HatchCriteriaBoundaryType {
  Upper = HatchCriteria::kUpperBoundary,
  Lower = HatchCriteria::kLowerBoundary
}
Visual Basic
Public Enum HatchCriteriaBoundaryType
  Upper = HatchCriteria::kUpperBoundary
  Lower = HatchCriteria::kLowerBoundary
End Enum


Autodesk::Civil::Land::DatabaseServices::ProfileEntityConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::ProfileEntityConstraintType Enumeration
Autodesk::Civil::Land::DatabaseServices::ProfileEntityConstraintType Enumeration
Collapse All

Specifies the connection constraint type of ProfileEntity, including fixed(attached to none entity), float(attached to one entity) and free(attached to two entities).

C#
public enum ProfileEntityConstraintType {
  Fixed = AeccHAlignment::kFixed,
  Float = AeccHAlignment::kFloat,
  Free = AeccHAlignment::kFree
}
Visual Basic
Public Enum ProfileEntityConstraintType
  Fixed = AeccHAlignment::kFixed
  Float = AeccHAlignment::kFloat
  Free = AeccHAlignment::kFree
End Enum


Autodesk::Civil::Land::DatabaseServices::ProfileEntityType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::ProfileEntityType Enumeration
Autodesk::Civil::Land::DatabaseServices::ProfileEntityType Enumeration
Collapse All

Specifies the underlying ProfileEntity type, including tangent, circular, symmetric parabola and asymmetric parabola.

C#
public enum ProfileEntityType {
  Tangent = AeccVAlignment::kLine,
  Circular = AeccVAlignment::kCircArc2d,
  ParabolaSymmetric = AeccVAlignment::kSymParabola,
  ParabolaAsymmetric = AeccVAlignment::kASymParabola,
  None = AeccVAlignment::kNone
}
Visual Basic
Public Enum ProfileEntityType
  Tangent = AeccVAlignment::kLine
  Circular = AeccVAlignment::kCircArc2d
  ParabolaSymmetric = AeccVAlignment::kSymParabola
  ParabolaAsymmetric = AeccVAlignment::kASymParabola
  None = AeccVAlignment::kNone
End Enum


Autodesk::Civil::Land::DatabaseServices::ProfileType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::ProfileType Enumeration
Autodesk::Civil::Land::DatabaseServices::ProfileType Enumeration
Collapse All

Defines the profile type.

C#
public enum ProfileType {
  EG = AeccDbVAlignment::kEG,
  FG = AeccDbVAlignment::kFG,
  Superimposed = AeccDbVAlignment::kSuperimposed,
  File = AeccDbVAlignment::kFile,
  CorridorFeature = AeccDbVAlignment::kCorridorFeature,
  OffsetProfile = AeccDbVAlignment::kOffsetProfile,
  CurbReturnProfile = AeccDbVAlignment::kCurbReturnProfile
}
Visual Basic
Public Enum ProfileType
  EG = AeccDbVAlignment::kEG
  FG = AeccDbVAlignment::kFG
  Superimposed = AeccDbVAlignment::kSuperimposed
  File = AeccDbVAlignment::kFile
  CorridorFeature = AeccDbVAlignment::kCorridorFeature
  OffsetProfile = AeccDbVAlignment::kOffsetProfile
  CurbReturnProfile = AeccDbVAlignment::kCurbReturnProfile
End Enum


Autodesk::Civil::Land::DatabaseServices::ProfileUpdateType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::ProfileUpdateType Enumeration
Autodesk::Civil::Land::DatabaseServices::ProfileUpdateType Enumeration
Collapse All

Defines the profile's update mode.

C#
public enum ProfileUpdateType {
  Static = AeccDbVAlignment::kUpdateModeStatic,
  Dynamic = AeccDbVAlignment::kUpdateModeDynamic
}
Visual Basic
Public Enum ProfileUpdateType
  Static = AeccDbVAlignment::kUpdateModeStatic
  Dynamic = AeccDbVAlignment::kUpdateModeDynamic
End Enum


Autodesk::Civil::Land::DatabaseServices::RegionPropertyType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::RegionPropertyType Enumeration
Autodesk::Civil::Land::DatabaseServices::RegionPropertyType Enumeration
Collapse All

The Autodesk::Civil::Land::DatabaseServices::RegionPropertyType enumeration.

C#
public enum RegionPropertyType {
  StartStation = 0,
  EndStation,
  Length,
  OffsetDist
}
Visual Basic
Public Enum RegionPropertyType
  StartStation = 0
  EndStation
  Length
  OffsetDist
End Enum


Autodesk::Civil::Land::DatabaseServices::SpiralCurveType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::SpiralCurveType Enumeration
Autodesk::Civil::Land::DatabaseServices::SpiralCurveType Enumeration
Collapse All

Defines the curve type for a spiral sub-entity.

C#
public enum SpiralCurveType {
  InCurve = AeccAtomId::alignSpiralIncurve,
  OutCurve = AeccAtomId::alignSpiralOutcurve
}
Visual Basic
Public Enum SpiralCurveType
  InCurve = AeccAtomId::alignSpiralIncurve
  OutCurve = AeccAtomId::alignSpiralOutcurve
End Enum
Members
Members | Description
InCurve | incurve spiral
OutCurve | outcurve spiral


Autodesk::Civil::Land::DatabaseServices::SpiralDirectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::SpiralDirectionType Enumeration
Autodesk::Civil::Land::DatabaseServices::SpiralDirectionType Enumeration
Collapse All

Defines the direction of a spiral sub-entity.

C#
public enum SpiralDirectionType {
  DirectionRight = 0,
  DirectionLeft = 1
}
Visual Basic
Public Enum SpiralDirectionType
  DirectionRight = 0
  DirectionLeft = 1
End Enum


Autodesk::Civil::Land::DatabaseServices::SpiralParamType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::SpiralParamType Enumeration
Autodesk::Civil::Land::DatabaseServices::SpiralParamType Enumeration
Collapse All

Defines the type to attch the entity.

C#
public enum SpiralParamType {
  AValue,
  Length
}
Visual Basic
Public Enum SpiralParamType
  AValue
  Length
End Enum


Autodesk::Civil::Land::DatabaseServices::SplitStationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::SplitStationType Enumeration
Autodesk::Civil::Land::DatabaseServices::SplitStationType Enumeration
Collapse All

Defines the ways to split profile view.

C#
public enum SplitStationType {
  Automatic = 0,
  Manual = 1
}
Visual Basic
Public Enum SplitStationType
  Automatic = 0
  Manual = 1
End Enum


Autodesk::Civil::Land::DatabaseServices::StationEquationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::StationEquationType Enumeration
Autodesk::Civil::Land::DatabaseServices::StationEquationType Enumeration
Collapse All

Specifies the kind of StationEquation.

C#
public enum StationEquationType {
  Decreasing = 0,
  Increasing = 1
}
Visual Basic
Public Enum StationEquationType
  Decreasing = 0
  Increasing = 1
End Enum


Autodesk::Civil::Land::DatabaseServices::StationRangeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::StationRangeType Enumeration
Autodesk::Civil::Land::DatabaseServices::StationRangeType Enumeration
Collapse All

Defines the ways to specify the horizontal range of the profile view.

C#
public enum StationRangeType {
  Automatic = 0,
  UserSpecified = 1
}
Visual Basic
Public Enum StationRangeType
  Automatic = 0
  UserSpecified = 1
End Enum


Autodesk::Civil::Land::DatabaseServices::StationRoundingType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::StationRoundingType Enumeration
Autodesk::Civil::Land::DatabaseServices::StationRoundingType Enumeration
Collapse All

Specifies where to round the horizontal split location.

C#
public enum StationRoundingType {
  ExactStation = AeccDbGraph::kSplitOptionsStnExact,
  PreviousMajorGrid = AeccDbGraph::kSplitOptionsStnMajor,
  PreviousMinorGrid = AeccDbGraph::kSplitOptionsStnMinor
}
Visual Basic
Public Enum StationRoundingType
  ExactStation = AeccDbGraph::kSplitOptionsStnExact
  PreviousMajorGrid = AeccDbGraph::kSplitOptionsStnMajor
  PreviousMinorGrid = AeccDbGraph::kSplitOptionsStnMinor
End Enum


Autodesk::Civil::Land::DatabaseServices::StationTypes Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::StationTypes Enumeration
Autodesk::Civil::Land::DatabaseServices::StationTypes Enumeration
Collapse All

Defines the possible station types, used by Alignment::GetStationSet().

C#
[System::Flags]
public enum StationTypes {
  All = AeccAlignStation::kStnFlagAll,
  Major = AeccAlignStation::kStnFlagRegularMajor,
  Minor = AeccAlignStation::kStnFlagRegularMinor,
  GeometryPoint = AeccAlignStation::kStnFlagGeometryPoint,
  Equation = AeccAlignStation::kStnFlagEquation,
  SuperTransPoint = AeccAlignStation::kStnFlagSuperTrans,
  RangeStart = AeccAlignStation::kStnFlagRangeStart,
  RangeEnd = AeccAlignStation::kStnFlagRangeEnd,
  HorizontalMask = AeccAlignStation::kStnFlagHorizontalMask,
  PIPoint = AeccAlignStation::kStnFlagGPPIType
}
Visual Basic
<System::Flags>
Public Enum StationTypes
  All = AeccAlignStation::kStnFlagAll
  Major = AeccAlignStation::kStnFlagRegularMajor
  Minor = AeccAlignStation::kStnFlagRegularMinor
  GeometryPoint = AeccAlignStation::kStnFlagGeometryPoint
  Equation = AeccAlignStation::kStnFlagEquation
  SuperTransPoint = AeccAlignStation::kStnFlagSuperTrans
  RangeStart = AeccAlignStation::kStnFlagRangeStart
  RangeEnd = AeccAlignStation::kStnFlagRangeEnd
  HorizontalMask = AeccAlignStation::kStnFlagHorizontalMask
  PIPoint = AeccAlignStation::kStnFlagGPPIType
End Enum
Members
Members | Description
All | All station types.
Major | All major stations at the intervals specified by majorInterval from the alignment start to the end.
Minor | All minor stations at the intervals specified by minorInterval from the alignment start to the end.
GeometryPoint | All stations at the special geometry points (defined by GeometryPointType) of the alignment.
Equation | All stations added by a station equation.
SuperTransPoint | All stations at the superelevation transition points.
RangeStart | The station at the start point of the alignment.
RangeEnd | The station at the end point of the alignment.
HorizontalMask | All stations except those with type PIPoint.
PIPoint | All stations at the PI points of the alignment.


Autodesk::Civil::Land::DatabaseServices::SubEntityExtensionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::SubEntityExtensionType Enumeration
Autodesk::Civil::Land::DatabaseServices::SubEntityExtensionType Enumeration
Collapse All

Specifies sub-entity extension type.

C#
public enum SubEntityExtensionType {
  Spiral = 1,
  Arc = 2,
  Tangent = 3,
  GroupSpiral1 = 4,
  GroupSpiral2 = 5,
  GroupArc = 6,
  GroupTangent = 7,
  GroupSpiral3 = 8,
  GroupSpiral4 = 9,
  GroupArc2 = 10
}
Visual Basic
Public Enum SubEntityExtensionType
  Spiral = 1
  Arc = 2
  Tangent = 3
  GroupSpiral1 = 4
  GroupSpiral2 = 5
  GroupArc = 6
  GroupTangent = 7
  GroupSpiral3 = 8
  GroupSpiral4 = 9
  GroupArc2 = 10
End Enum


Autodesk::Civil::Land::DatabaseServices::SuperElevationCrossSegmentType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::SuperElevationCrossSegmentType Enumeration
Autodesk::Civil::Land::DatabaseServices::SuperElevationCrossSegmentType Enumeration
Collapse All

Specifies the type of a SuperElevationDataElement cross segment.

C#
public enum SuperElevationCrossSegmentType {
  SuperLeftOutShoulderCrossSlope = AeccSuperElevationDataElement::kLeftOutShoulderCrossSlope,
  SuperLeftOutLaneCrossSlope = AeccSuperElevationDataElement::kLeftOutLaneCrossSlope,
  SuperLeftInShoulderCrossSlope = AeccSuperElevationDataElement::kLeftInShoulderCrossSlope,
  SuperLeftInLaneCrossSlope = AeccSuperElevationDataElement::kLeftInLaneCrossSlope,
  SuperRightOutShoulderCrossSlope = AeccSuperElevationDataElement::kRightOutShoulderCrossSlope,
  SuperRightOutLaneCrossSlope = AeccSuperElevationDataElement::kRightOutLaneCrossSlope,
  SuperRightInShoulderCrossSlope = AeccSuperElevationDataElement::kRightInShoulderCrossSlope,
  SuperRightInLaneCrossSlope = AeccSuperElevationDataElement::kRightInLaneCrossSlope
}
Visual Basic
Public Enum SuperElevationCrossSegmentType
  SuperLeftOutShoulderCrossSlope = AeccSuperElevationDataElement::kLeftOutShoulderCrossSlope
  SuperLeftOutLaneCrossSlope = AeccSuperElevationDataElement::kLeftOutLaneCrossSlope
  SuperLeftInShoulderCrossSlope = AeccSuperElevationDataElement::kLeftInShoulderCrossSlope
  SuperLeftInLaneCrossSlope = AeccSuperElevationDataElement::kLeftInLaneCrossSlope
  SuperRightOutShoulderCrossSlope = AeccSuperElevationDataElement::kRightOutShoulderCrossSlope
  SuperRightOutLaneCrossSlope = AeccSuperElevationDataElement::kRightOutLaneCrossSlope
  SuperRightInShoulderCrossSlope = AeccSuperElevationDataElement::kRightInShoulderCrossSlope
  SuperRightInLaneCrossSlope = AeccSuperElevationDataElement::kRightInLaneCrossSlope
End Enum


Autodesk::Civil::Land::DatabaseServices::SuperElevationTransitionPointType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::SuperElevationTransitionPointType Enumeration
Autodesk::Civil::Land::DatabaseServices::SuperElevationTransitionPointType Enumeration
Collapse All

Specifies the type of a SuperElevationDataElement transition point.

C#
public enum SuperElevationTransitionPointType {
  SuperBeginAlignment = AeccSuperElevationDataElement::kBeginAlignment,
  SuperBeginNormalCrown = AeccSuperElevationDataElement::kBeginNormalCrown,
  SuperBeginNormalShoulder = AeccSuperElevationDataElement::kBeginNormalShoulder,
  SuperBeginFullSuper = AeccSuperElevationDataElement::kBeginFullSuper,
  SuperEndFullSuper = AeccSuperElevationDataElement::kEndFullSuper,
  SuperEndNormalShoulder = AeccSuperElevationDataElement::kEndNormalShoulder,
  SuperEndNormalCrown = AeccSuperElevationDataElement::kEndNormalCrown,
  SuperEndAlignment = AeccSuperElevationDataElement::kEndAlignment,
  SuperLevelCrown = AeccSuperElevationDataElement::kLevelCrown,
  SuperLowShoulderMatch = AeccSuperElevationDataElement::kLowShoulderMatch,
  SuperReverseCrown = AeccSuperElevationDataElement::kReverseCrown,
  SuperManual = AeccSuperElevationDataElement::kManual,
  SuperShoulderBreakOver = AeccSuperElevationDataElement::kShoulderBreakOver
}
Visual Basic
Public Enum SuperElevationTransitionPointType
  SuperBeginAlignment = AeccSuperElevationDataElement::kBeginAlignment
  SuperBeginNormalCrown = AeccSuperElevationDataElement::kBeginNormalCrown
  SuperBeginNormalShoulder = AeccSuperElevationDataElement::kBeginNormalShoulder
  SuperBeginFullSuper = AeccSuperElevationDataElement::kBeginFullSuper
  SuperEndFullSuper = AeccSuperElevationDataElement::kEndFullSuper
  SuperEndNormalShoulder = AeccSuperElevationDataElement::kEndNormalShoulder
  SuperEndNormalCrown = AeccSuperElevationDataElement::kEndNormalCrown
  SuperEndAlignment = AeccSuperElevationDataElement::kEndAlignment
  SuperLevelCrown = AeccSuperElevationDataElement::kLevelCrown
  SuperLowShoulderMatch = AeccSuperElevationDataElement::kLowShoulderMatch
  SuperReverseCrown = AeccSuperElevationDataElement::kReverseCrown
  SuperManual = AeccSuperElevationDataElement::kManual
  SuperShoulderBreakOver = AeccSuperElevationDataElement::kShoulderBreakOver
End Enum


Autodesk::Civil::Land::DatabaseServices::VerticalCurveType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DatabaseServices::VerticalCurveType Enumeration
Autodesk::Civil::Land::DatabaseServices::VerticalCurveType Enumeration
Collapse All

Specifies the geometry type of a ProfileEntity curve, used for three types of parabolic entities.

C#
public enum VerticalCurveType {
  Sag = AeccVAlignment::kSAG,
  Crest = AeccVAlignment::kCREST
}
Visual Basic
Public Enum VerticalCurveType
  Sag = AeccVAlignment::kSAG
  Crest = AeccVAlignment::kCREST
End Enum


Autodesk::Civil::Land::Settings Namespace

The Autodesk::Civil::Land::Settings namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
SettingsAbbreviationAlignment | Abbreviations Settings for Alignment Geometry Point Entity Data
SettingsAbbreviationAlignmentEnhanced | Abbreviations Settings for Alignment Geometry Point Text
SettingsAbbreviationProfile | Abbreviations Settings for Profile
SettingsAbbreviationSuperelevation | Abbreviations Settings for Superelevation
SettingsAlignment | Settings for Alignment.
SettingsAlignment::SettingsCriteriaBasedDesignOptions | Default settings for creating an alignment using design criteria.
SettingsAlignment::SettingsData | Default settings for creating an alignment using data.
SettingsAlignment::SettingsDefaultNameFormat | Settings for Alignment Default Name Format.
SettingsAlignment::SettingsDynamicAlignmentHighlight | Default settings for dynamic alignment hightlight options.
SettingsAlignment::SettingsStationIndexing | Settings for Alignment Station Indexing.
SettingsAlignment::SettingsStyles | Settings for Alignment default styles.
SettingsAlignment::SettingsSuperelevationOptions | Default settings for calculating superelevation specifications.
SettingsBuildingSite | Settings for ViewFrameGroup.
SettingsBuildingSite::SettingsNameFormat | Default name format for new building sites.
SettingsBuildingSite::SettingsStyles | Default styles for new building sites.
SettingsCmdAddAlignmentCurveTable | Settings for AddAlignmentCurveTable command.
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentCurveTable.
SettingsCmdAddAlignmentLineTable | Settings for AddAlignmentLineTable command.
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentLineTable.
SettingsCmdAddAlignmentOffLbl | Settings for AddAlignmentOffLbl command.
SettingsCmdAddAlignmentOffXYLbl | Settings for AddAlignmentOffXYLbl command.
SettingsCmdAddAlignmentSegmentTable | Settings for AddAlignmentSegmentTable command.
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentSegmentTable.
SettingsCmdAddAlignmentSpiralTable | Settings for AddAlignmentSpiralTable command.
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentSpiralTable.
SettingsCmdAddAlignSegLbl | Settings for AddAlignSegLbl command.
SettingsCmdAddAlignSegLbls | Settings for AddAlignSegLbls command.
SettingsCmdAddAlignTagentLbl | Settings for AddAlignTagentLbl command.
SettingsCmdAddAlignTagentLbls | Settings for AddAlignTagentLbls command.
SettingsCmdAddContourLabeling | Settings for AddContourLabeling command.
SettingsCmdAddContourLabelingGroup | Settings for AddContourLabelingGroup command.
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling | Settings that specify the defaults assigned to surface labels.
SettingsCmdAddContourLabelingSingle | Settings for AddContourLabelingSingle command.
SettingsCmdAddParcelAreaLabel | Settings for AddParcelAreaLabel command.
SettingsCmdAddParcelCurveTable | Settings for AddParcelCurveTable command.
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelCurveTable.
SettingsCmdAddParcelLineLabel | Settings for AddParcelLineLabel command.
SettingsCmdAddParcelLineTable | Settings for AddParcelLineTable command.
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelLineTable.
SettingsCmdAddParcelSegmentLabels | Settings for AddParcelSegmentLabels command.
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions | Settings that specify defaults for creating labels with parcel segments.
SettingsCmdAddParcelSegmentTable | Settings for AddParcelSegmentTable command.
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelSegmentTable.
SettingsCmdAddParcelTable | Settings for AddParcelTable command.
SettingsCmdAddParcelTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelTable.
SettingsCmdAddPointTable | Settings for AddPointTable command.
SettingsCmdAddPointTable::SettinsCmdTableCreation | Settings of table creation for the command AddPointTable.
SettingsCmdAddProfileViewDepthLbl | Settings for AddProfileViewDepthLbl command.
SettingsCmdAddProfileViewStaElevLbl | Settings for AddProfileViewStaElevLbl command.
SettingsCmdAddSectionViewGradeLbl | Settings for AddSectionViewGradeLbl command.
SettingsCmdAddSectionViewOffElevLbl | Settings for AddSectionViewOffElevLbl command.
SettingsCmdAddSpotElevLabelsOnGrid | Settings for AddSpotElevLabelsOnGrid command.
SettingsCmdAddSurfaceBoundaries | Settings for AddSurfaceBoundaries command.
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions | Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.
SettingsCmdAddSurfaceBreaklines | Settings for AddSurfaceBreaklines command.
SettingsCmdAddSurfaceContours | Settings for AddSurfaceContours command.
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions | Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.
SettingsCmdAddSurfaceDemFile | Settings for AddSurfaceDemFile command.
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdAddSurfaceDrawingObjects | Settings for AddSurfaceDrawingObjects command.
SettingsCmdAddSurfaceSlopeLabel | Settings for AddSurfaceSlopeLabel command.
SettingsCmdAddSurfaceSpotElevLabel | Settings for AddSurfaceSpotElevLabel command.
SettingsCmdAddWidening | Settings for AddWidening command.
SettingsCmdAddWidening::SettingsCmdWideningOptions | Settings for the alignment widening options.
SettingsCmdCatchmentArea | Settings for CatchmentArea command.
SettingsCmdConvertPointstoSdskPoints | Settings for ConvertPointstoSdskPoints command.
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer | Settings that specify defaults for Layer.
SettingsCmdCreateAlignmentEntities | Settings for CreateAlignmentEntities command.
SettingsCmdCreateAlignmentLayout | Settings for CreateAlignmentLayout command.
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption | Settings of alignment type option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings | Settings of curve and spiral for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption | Settings of curve tessellation option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption | Settings of tegression graph option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentReference | Settings for CreateAlignmentReference command.
SettingsCmdCreateFeatureLineFromAlign | Settings for CreateFeatureLineFromAlign command.
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating feature lines from alignments.
SettingsCmdCreateFeatureLines | Settings for CreateFeatureLines command.
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating feature lines from objects.
SettingsCmdCreateGrading | Settings for CreateGrading command.
SettingsCmdCreateGrading::SettingsCmdGradingCreation | Settings that specify the default behavior for creating grading.
SettingsCmdCreateGradingGroup | Settings for CreateGradingGroup command.
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation | Settings that specify the default behavior for creating grading.
SettingsCmdCreateMassHaulDiagram | Settings for CreateMassHallDiagram command.
SettingsCmdCreateMultipleProfileView | Settings for CreateMultipleProfileView command.
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation | Settings that specify defaults for creating multiple profile views.
SettingsCmdCreateMultipleSectionView | Settings for CreateMultipleSectionView command.
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation | Settings for the table creation.
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation | Settings for table creation.
SettingsCmdCreateOffsetAlignment | Settings for CreateOffsetAlignment command.
SettingsCmdCreateParcelByLayout | Settings for CreateParcelByLayout command.
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout | Settings that specify defaults for automatic parcel layout.
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities | Settings that specify defaults for creation of parcels.
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing | Settings that specify defaults for sizing parcels.
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics | Settings that specify defaults for temporary parcel layout preview graphics.
SettingsCmdCreateParcelFromObjects | Settings for CreateParcelFromObjects command.
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities | Settings that specify defaults for creation of parcels.
SettingsCmdCreateParcelROW | Settings for CreateParcelROW command.
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections | Settings that specify default offset for cleanup at alignment intersections.
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries | Settings that specify default offset for cleanup at parcel boundaries.
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay | Setting that specify default offset for creation of parcel rights of way.
SettingsCmdCreatePointGroup | Settings for CreatePointGroup command.
SettingsCmdCreatePoints | Settings for CreatePoints command.
SettingsCmdCreatePoints::SettingsCmdLayer | Default layer settings for the CreatePoints command.
SettingsCmdCreatePoints::SettingsCmdPointsCreation | Settings that specify defaults for Points Creation.
SettingsCmdCreateProfileFromFile | Settings for CreateProfileFromFile command.
SettingsCmdCreateProfileFromSurface | Settings for CreateProfileFromSurface command.
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry | Settings that specify the geometry setting.
SettingsCmdCreateProfileLayout | Settings for CreateProfileLayout command.
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption | Settings that specify the default behavior when curve entities are used as an input option for best fit arc, line,... more
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption | Setting that specifies the default behavior for regression analysis graphs in best fit arc, line, and parabola creation.
SettingsCmdCreateProfileReference | Settings for CreateProfileReference command.
SettingsCmdCreateProfileView | Settings for CreateProfileView command.
SettingsCmdCreateQuickProfile | Settings for CreateQuickProfile command.
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile | Settings that specify the default settings for quick profile creation.
SettingsCmdCreateSampleLines | Settings for CreateSampleLines command.
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls | Settings that specify the default behavior for additional sample controls.
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous | Setting that specifies miscellaneous default behavior for sample lines.
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements | Settings that specify the default behavior for sampling increments.
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths | Settings that specify the default behavior for sample line swath width.
SettingsCmdCreateSectionView | Settings for CreateSectionView command.
SettingsCmdCreateSectionView::SettingsCmdTableCreation | Settings for the table creation.
SettingsCmdCreateSheets | Settings for CreateSheets command.
SettingsCmdCreateSheets::SettingsCmdSheetCreation | Settings for the sheet creation.
SettingsCmdCreateSite | Settings for CreateSite command.
SettingsCmdCreateSite::SettingsCmdAlignment | Settings that specify default increments for alignment tag numbering.
SettingsCmdCreateSite::SettingsCmdFeatureLine | Settings that specify defaults for feature line style priority.
SettingsCmdCreateSite::SettingsCmdParcel | Settings that specify default increments for parcel numbering.
SettingsCmdCreateSurface | Settings for CreateSurface command.
SettingsCmdCreateSurface::SettingCmdBuildOptions | Settings that specify the build options assigned when creating surfaces.
SettingsCmdCreateSurface::SettingCmdSurfaceCreation | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdCreateSurface::SettingsNameFormat | Settings that specify name format for the command.
SettingsCmdCreateSurfaceFromTIN | Settings for CreateSurfaceFromTIN command.
SettingsCmdCreateSurfaceGridFromDEM | Settings for CreateSurfaceGridFromDEM command.
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions | Settings that specify the build options assigned when creating surfaces.
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdCreateSurfaceReference | Settings for CreateSurfaceReference command.
SettingsCmdCreateSurfaceWaterdrop | Settings for CreateSurfaceWaterdrop command.
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker | Settings that specify the default water drop marker options for surfaces.
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath | Settings that specify the default water drop path options for surfaces.
SettingsCmdCreateViewFrames | Settings for CreateViewFrames command.
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation | Settings for the view frame creation.
SettingsCmdDrawFeatureLine | Settings for DrawFeatureLine command.
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating featureline.
SettingsCmdEditSVGroupStyle | Settings for EditSVGroupStyle command.
SettingsCmdExportParcelAnalysis | Settings for ExportParcelAnalysis command.
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis | Settings that specify defaults for parcel analysis.
SettingsCmdFitCurveFeature | Settings for FitCurveFeature command.
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve | Settings that specify the default behavior for feature line fit curve.
SettingsCmdGradingElevEditor | Settings for GradingElevEditor command.
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor | Settings that specify the default behavior for grading elevation editor.
SettingsCmdGradingTools | Settings for GradingTools command.
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools | Settings that specify the default behavior for grading layout tools.
SettingsCmdGradingVolumeTools | Settings for GradingVolumeTools command.
SettingsCmdImportBuildingSite | Settings for ImportBuildingSite command.
SettingsCmdImportGEData | Settings for ImportGEData command.
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions | Settings that specify the default number of rows and columns collected when importing Google Earth information.
SettingsCmdImportGEData::SettingsCmdSurfaceCreation | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdImportGESurface | Settings for ImportGESurface command.
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions | Settings that specify the default number of rows and columns collected when importing Google Earth information.
SettingsCmdImportGESurface::SettingsNameFormat | Settings that specify name format for the command.
SettingsCmdJoinFeatures | Settings for JoinFeatures command.
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin | Settings that specify the default behavior for featureline join.
SettingsCmdLayoutSectionViewGroup | Settings for LayoutSectionViewGroup command.
SettingsCmdMoveBlockstoAttribElev | Settings for MoveBlockstoAttribElev command.
SettingsCmdMoveBlocksToSurface | Settings for MoveBlocksToSurface command.
SettingsCmdMoveTextToElevation | Settings for MoveTextToElevation command.
SettingsCmdProjectObjectsToProf | Settings for ProjectObjectsToProf command.
SettingsCmdProjectObjectsToSect | Settings for ProjectObjectsToSect command.
SettingsCmdReAddParcelAreaLabel | Settings for ReAddParcelAreaLabel command.
SettingsCmdReAddParcelSegmentLabels | Settings for ReAddParcelSegmentLabels command.
SettingsCmdReverseAlignmentDirection | Settings for ReverseAlignmentDirection command.
SettingsCmdShowGeodeticCalculator | Settings for ShowGeodeticCalculator command.
SettingsCmdShowPointGroupProperties | Settings for ShowPointGroupProperties command.
SettingsCmdSimplifySurface | Settings for SimplifySurface command.
SettingsCmdSuperimposeProfile | Settings for SuperimposeProfile command.
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption | Settings that specify the default values for the mid-ordinate distances that the system uses when tessellating (approximating) the shape of... more
SettingsCmdSurfaceExportToDem | Settings for SurfaceExportToDem command.
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions | Settings that specify the defaults assigned when exporting surfaces to a DEM file.
SettingsCmdSurfaceExtractObjects | Settings for SurfaceExtractObjects command.
SettingsCmdWeedFeatures | Settings for WeedFeatures command.
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed | Settings that specify the default behavior for grading layout tools.
SettingsGrading | Settings for Grading.
SettingsGrading::SettingsNameFormat | Default name format for grading feature settings.
SettingsGrading::SettingsStyles | Default styles.setting class
SettingsMassHaulLine | Settings for MassHaulLine.
SettingsMassHaulView | Settings for MassHaulView.
SettingsMassHaulView::SettingsMassHaulCreation | Default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings when you... more
SettingsMassHaulView::SettingsNameFormat | Default name format for new mass haul lines and new mass haul views.
SettingsMassHaulView::SettingsStyles | Default styles.for mass haul components.
SettingsMatchLine | Settings for MatchLine.
SettingsParcel | Settings for Parcel.
SettingsParcel::SettingsStyles | Default styles.setting class
SettingsPoint | Settings for Point.
SettingsPoint::SettingsNameFormat | Default name format for point feature settings.
SettingsPoint::SettingsStyles | Default styles.setting class
SettingsPoint::SettingsUpdatePoints | Update points setting class.
SettingsProfile | Settings for Profile.
SettingsProfile::SettingsCriteriaBasedDesignOptions | Criteria Based Design options setting class
SettingsProfile::SettingsDefaultNameFormat | Default name format setting class
SettingsProfile::SettingsProfileCreation | Default values for vertical curve sub-entities
SettingsProfile::SettingsStyles | Default styles.setting class
SettingsProfileView | Settings for ProfileView.
SettingsProfileView::SettingsCreation | Settings for ProfileView default Creation.
SettingsProfileView::SettingsNameFormat | Settings for ProfileView default NameFormat.
SettingsProfileView::SettingsProjectionLabelPlacement | Settings for ProfileView default ProjectionLabelPlacement.
SettingsProfileView::SettingsSplitOptions | Settings for ProfileView default SplitOptions.
SettingsProfileView::SettingsStackedOptions | Settings for ProfileView default StackedOptions.
SettingsProfileView::SettingsStyles | Settings for ProfileView default Styles.
SettingsSampleLine | Settings for SampleLine.
SettingsSampleLine::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSampleLine::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSection | Settings for Section.
SettingsSection::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSection::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSectionView | Settings to specify the default styles assigned to section view components
SettingsSectionView::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsProjectionLabelPlacement | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsSectionViewCreation | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSurface | Settings for Surface.
SettingsSurface::SettingsContourLabeling | Defaults assigned to surface labels.
SettingsSurface::SettingsDefaults | Default name format for new surfaces.
SettingsSurface::SettingsStyles | Default styles.assigned to surfaces and surface-related labels.
SettingsViewFrame | Settings for ViewFrame.
SettingsViewFrameGroup | Settings for ViewFrameGroup.
SettingsViewFrameGroup::SettingsInformation | Default match line label location.
SettingsViewFrameGroup::SettingsNameFormat | Default name format for view frame group components.
SettingsViewFrameGroup::SettingsStyles | Default styles assigned to view frame group components.
Structs, Records, Enums
Struct, Record, Enum | Description
AbbreviationAlignmentEnhancedType | Defines Abbreviation Alignment Enhanced type.
AbbreviationAlignmentType | Defines Abbreviation Alignment type.
AbbreviationProfileType | Defines Abbreviation Profile type.
AbbreviationSuperelevationType | Defines Abbreviation Superelevation type.
AutomaticManual | Specifies how some properties are assigned point creation.
GeographicCoordinateType | Specifies the order in which geographic coordinates are displayed on the command line during point creation.
GridCoordinateType | Specifies the order in which grid coordinates are displayed on the command line during point creation.
LocalCoordinateType | Specifies the order and format used to display local coordinates on the command line during point creation.
SectionViewAnchorType | Defines types of section view anchors.
TableAnchorType | Defines types of table anchors.
TableLayoutType | Defines table layout directions.
TileDirectionType | Defines tile directions.
Links
Topics, Classes, Structs, Records, Enums


Classes

The following table lists classes in this documentation.

Classes
Class | Description
SettingsAbbreviationAlignment | Abbreviations Settings for Alignment Geometry Point Entity Data
SettingsAbbreviationAlignmentEnhanced | Abbreviations Settings for Alignment Geometry Point Text
SettingsAbbreviationProfile | Abbreviations Settings for Profile
SettingsAbbreviationSuperelevation | Abbreviations Settings for Superelevation
SettingsAlignment | Settings for Alignment.
SettingsAlignment::SettingsCriteriaBasedDesignOptions | Default settings for creating an alignment using design criteria.
SettingsAlignment::SettingsData | Default settings for creating an alignment using data.
SettingsAlignment::SettingsDefaultNameFormat | Settings for Alignment Default Name Format.
SettingsAlignment::SettingsDynamicAlignmentHighlight | Default settings for dynamic alignment hightlight options.
SettingsAlignment::SettingsStationIndexing | Settings for Alignment Station Indexing.
SettingsAlignment::SettingsStyles | Settings for Alignment default styles.
SettingsAlignment::SettingsSuperelevationOptions | Default settings for calculating superelevation specifications.
SettingsBuildingSite | Settings for ViewFrameGroup.
SettingsBuildingSite::SettingsNameFormat | Default name format for new building sites.
SettingsBuildingSite::SettingsStyles | Default styles for new building sites.
SettingsCmdAddAlignmentCurveTable | Settings for AddAlignmentCurveTable command.
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentCurveTable.
SettingsCmdAddAlignmentLineTable | Settings for AddAlignmentLineTable command.
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentLineTable.
SettingsCmdAddAlignmentOffLbl | Settings for AddAlignmentOffLbl command.
SettingsCmdAddAlignmentOffXYLbl | Settings for AddAlignmentOffXYLbl command.
SettingsCmdAddAlignmentSegmentTable | Settings for AddAlignmentSegmentTable command.
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentSegmentTable.
SettingsCmdAddAlignmentSpiralTable | Settings for AddAlignmentSpiralTable command.
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentSpiralTable.
SettingsCmdAddAlignSegLbl | Settings for AddAlignSegLbl command.
SettingsCmdAddAlignSegLbls | Settings for AddAlignSegLbls command.
SettingsCmdAddAlignTagentLbl | Settings for AddAlignTagentLbl command.
SettingsCmdAddAlignTagentLbls | Settings for AddAlignTagentLbls command.
SettingsCmdAddContourLabeling | Settings for AddContourLabeling command.
SettingsCmdAddContourLabelingGroup | Settings for AddContourLabelingGroup command.
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling | Settings that specify the defaults assigned to surface labels.
SettingsCmdAddContourLabelingSingle | Settings for AddContourLabelingSingle command.
SettingsCmdAddParcelAreaLabel | Settings for AddParcelAreaLabel command.
SettingsCmdAddParcelCurveTable | Settings for AddParcelCurveTable command.
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelCurveTable.
SettingsCmdAddParcelLineLabel | Settings for AddParcelLineLabel command.
SettingsCmdAddParcelLineTable | Settings for AddParcelLineTable command.
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelLineTable.
SettingsCmdAddParcelSegmentLabels | Settings for AddParcelSegmentLabels command.
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions | Settings that specify defaults for creating labels with parcel segments.
SettingsCmdAddParcelSegmentTable | Settings for AddParcelSegmentTable command.
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelSegmentTable.
SettingsCmdAddParcelTable | Settings for AddParcelTable command.
SettingsCmdAddParcelTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelTable.
SettingsCmdAddPointTable | Settings for AddPointTable command.
SettingsCmdAddPointTable::SettinsCmdTableCreation | Settings of table creation for the command AddPointTable.
SettingsCmdAddProfileViewDepthLbl | Settings for AddProfileViewDepthLbl command.
SettingsCmdAddProfileViewStaElevLbl | Settings for AddProfileViewStaElevLbl command.
SettingsCmdAddSectionViewGradeLbl | Settings for AddSectionViewGradeLbl command.
SettingsCmdAddSectionViewOffElevLbl | Settings for AddSectionViewOffElevLbl command.
SettingsCmdAddSpotElevLabelsOnGrid | Settings for AddSpotElevLabelsOnGrid command.
SettingsCmdAddSurfaceBoundaries | Settings for AddSurfaceBoundaries command.
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions | Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.
SettingsCmdAddSurfaceBreaklines | Settings for AddSurfaceBreaklines command.
SettingsCmdAddSurfaceContours | Settings for AddSurfaceContours command.
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions | Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.
SettingsCmdAddSurfaceDemFile | Settings for AddSurfaceDemFile command.
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdAddSurfaceDrawingObjects | Settings for AddSurfaceDrawingObjects command.
SettingsCmdAddSurfaceSlopeLabel | Settings for AddSurfaceSlopeLabel command.
SettingsCmdAddSurfaceSpotElevLabel | Settings for AddSurfaceSpotElevLabel command.
SettingsCmdAddWidening | Settings for AddWidening command.
SettingsCmdAddWidening::SettingsCmdWideningOptions | Settings for the alignment widening options.
SettingsCmdCatchmentArea | Settings for CatchmentArea command.
SettingsCmdConvertPointstoSdskPoints | Settings for ConvertPointstoSdskPoints command.
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer | Settings that specify defaults for Layer.
SettingsCmdCreateAlignmentEntities | Settings for CreateAlignmentEntities command.
SettingsCmdCreateAlignmentLayout | Settings for CreateAlignmentLayout command.
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption | Settings of alignment type option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings | Settings of curve and spiral for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption | Settings of curve tessellation option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption | Settings of tegression graph option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentReference | Settings for CreateAlignmentReference command.
SettingsCmdCreateFeatureLineFromAlign | Settings for CreateFeatureLineFromAlign command.
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating feature lines from alignments.
SettingsCmdCreateFeatureLines | Settings for CreateFeatureLines command.
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating feature lines from objects.
SettingsCmdCreateGrading | Settings for CreateGrading command.
SettingsCmdCreateGrading::SettingsCmdGradingCreation | Settings that specify the default behavior for creating grading.
SettingsCmdCreateGradingGroup | Settings for CreateGradingGroup command.
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation | Settings that specify the default behavior for creating grading.
SettingsCmdCreateMassHaulDiagram | Settings for CreateMassHallDiagram command.
SettingsCmdCreateMultipleProfileView | Settings for CreateMultipleProfileView command.
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation | Settings that specify defaults for creating multiple profile views.
SettingsCmdCreateMultipleSectionView | Settings for CreateMultipleSectionView command.
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation | Settings for the table creation.
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation | Settings for table creation.
SettingsCmdCreateOffsetAlignment | Settings for CreateOffsetAlignment command.
SettingsCmdCreateParcelByLayout | Settings for CreateParcelByLayout command.
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout | Settings that specify defaults for automatic parcel layout.
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities | Settings that specify defaults for creation of parcels.
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing | Settings that specify defaults for sizing parcels.
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics | Settings that specify defaults for temporary parcel layout preview graphics.
SettingsCmdCreateParcelFromObjects | Settings for CreateParcelFromObjects command.
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities | Settings that specify defaults for creation of parcels.
SettingsCmdCreateParcelROW | Settings for CreateParcelROW command.
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections | Settings that specify default offset for cleanup at alignment intersections.
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries | Settings that specify default offset for cleanup at parcel boundaries.
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay | Setting that specify default offset for creation of parcel rights of way.
SettingsCmdCreatePointGroup | Settings for CreatePointGroup command.
SettingsCmdCreatePoints | Settings for CreatePoints command.
SettingsCmdCreatePoints::SettingsCmdLayer | Default layer settings for the CreatePoints command.
SettingsCmdCreatePoints::SettingsCmdPointsCreation | Settings that specify defaults for Points Creation.
SettingsCmdCreateProfileFromFile | Settings for CreateProfileFromFile command.
SettingsCmdCreateProfileFromSurface | Settings for CreateProfileFromSurface command.
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry | Settings that specify the geometry setting.
SettingsCmdCreateProfileLayout | Settings for CreateProfileLayout command.
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption | Settings that specify the default behavior when curve entities are used as an input option for best fit arc, line,... more
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption | Setting that specifies the default behavior for regression analysis graphs in best fit arc, line, and parabola creation.
SettingsCmdCreateProfileReference | Settings for CreateProfileReference command.
SettingsCmdCreateProfileView | Settings for CreateProfileView command.
SettingsCmdCreateQuickProfile | Settings for CreateQuickProfile command.
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile | Settings that specify the default settings for quick profile creation.
SettingsCmdCreateSampleLines | Settings for CreateSampleLines command.
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls | Settings that specify the default behavior for additional sample controls.
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous | Setting that specifies miscellaneous default behavior for sample lines.
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements | Settings that specify the default behavior for sampling increments.
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths | Settings that specify the default behavior for sample line swath width.
SettingsCmdCreateSectionView | Settings for CreateSectionView command.
SettingsCmdCreateSectionView::SettingsCmdTableCreation | Settings for the table creation.
SettingsCmdCreateSheets | Settings for CreateSheets command.
SettingsCmdCreateSheets::SettingsCmdSheetCreation | Settings for the sheet creation.
SettingsCmdCreateSite | Settings for CreateSite command.
SettingsCmdCreateSite::SettingsCmdAlignment | Settings that specify default increments for alignment tag numbering.
SettingsCmdCreateSite::SettingsCmdFeatureLine | Settings that specify defaults for feature line style priority.
SettingsCmdCreateSite::SettingsCmdParcel | Settings that specify default increments for parcel numbering.
SettingsCmdCreateSurface | Settings for CreateSurface command.
SettingsCmdCreateSurface::SettingCmdBuildOptions | Settings that specify the build options assigned when creating surfaces.
SettingsCmdCreateSurface::SettingCmdSurfaceCreation | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdCreateSurface::SettingsNameFormat | Settings that specify name format for the command.
SettingsCmdCreateSurfaceFromTIN | Settings for CreateSurfaceFromTIN command.
SettingsCmdCreateSurfaceGridFromDEM | Settings for CreateSurfaceGridFromDEM command.
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions | Settings that specify the build options assigned when creating surfaces.
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdCreateSurfaceReference | Settings for CreateSurfaceReference command.
SettingsCmdCreateSurfaceWaterdrop | Settings for CreateSurfaceWaterdrop command.
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker | Settings that specify the default water drop marker options for surfaces.
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath | Settings that specify the default water drop path options for surfaces.
SettingsCmdCreateViewFrames | Settings for CreateViewFrames command.
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation | Settings for the view frame creation.
SettingsCmdDrawFeatureLine | Settings for DrawFeatureLine command.
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating featureline.
SettingsCmdEditSVGroupStyle | Settings for EditSVGroupStyle command.
SettingsCmdExportParcelAnalysis | Settings for ExportParcelAnalysis command.
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis | Settings that specify defaults for parcel analysis.
SettingsCmdFitCurveFeature | Settings for FitCurveFeature command.
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve | Settings that specify the default behavior for feature line fit curve.
SettingsCmdGradingElevEditor | Settings for GradingElevEditor command.
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor | Settings that specify the default behavior for grading elevation editor.
SettingsCmdGradingTools | Settings for GradingTools command.
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools | Settings that specify the default behavior for grading layout tools.
SettingsCmdGradingVolumeTools | Settings for GradingVolumeTools command.
SettingsCmdImportBuildingSite | Settings for ImportBuildingSite command.
SettingsCmdImportGEData | Settings for ImportGEData command.
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions | Settings that specify the default number of rows and columns collected when importing Google Earth information.
SettingsCmdImportGEData::SettingsCmdSurfaceCreation | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdImportGESurface | Settings for ImportGESurface command.
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions | Settings that specify the default number of rows and columns collected when importing Google Earth information.
SettingsCmdImportGESurface::SettingsNameFormat | Settings that specify name format for the command.
SettingsCmdJoinFeatures | Settings for JoinFeatures command.
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin | Settings that specify the default behavior for featureline join.
SettingsCmdLayoutSectionViewGroup | Settings for LayoutSectionViewGroup command.
SettingsCmdMoveBlockstoAttribElev | Settings for MoveBlockstoAttribElev command.
SettingsCmdMoveBlocksToSurface | Settings for MoveBlocksToSurface command.
SettingsCmdMoveTextToElevation | Settings for MoveTextToElevation command.
SettingsCmdProjectObjectsToProf | Settings for ProjectObjectsToProf command.
SettingsCmdProjectObjectsToSect | Settings for ProjectObjectsToSect command.
SettingsCmdReAddParcelAreaLabel | Settings for ReAddParcelAreaLabel command.
SettingsCmdReAddParcelSegmentLabels | Settings for ReAddParcelSegmentLabels command.
SettingsCmdReverseAlignmentDirection | Settings for ReverseAlignmentDirection command.
SettingsCmdShowGeodeticCalculator | Settings for ShowGeodeticCalculator command.
SettingsCmdShowPointGroupProperties | Settings for ShowPointGroupProperties command.
SettingsCmdSimplifySurface | Settings for SimplifySurface command.
SettingsCmdSuperimposeProfile | Settings for SuperimposeProfile command.
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption | Settings that specify the default values for the mid-ordinate distances that the system uses when tessellating (approximating) the shape of... more
SettingsCmdSurfaceExportToDem | Settings for SurfaceExportToDem command.
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions | Settings that specify the defaults assigned when exporting surfaces to a DEM file.
SettingsCmdSurfaceExtractObjects | Settings for SurfaceExtractObjects command.
SettingsCmdWeedFeatures | Settings for WeedFeatures command.
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed | Settings that specify the default behavior for grading layout tools.
SettingsGrading | Settings for Grading.
SettingsGrading::SettingsNameFormat | Default name format for grading feature settings.
SettingsGrading::SettingsStyles | Default styles.setting class
SettingsMassHaulLine | Settings for MassHaulLine.
SettingsMassHaulView | Settings for MassHaulView.
SettingsMassHaulView::SettingsMassHaulCreation | Default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings when you... more
SettingsMassHaulView::SettingsNameFormat | Default name format for new mass haul lines and new mass haul views.
SettingsMassHaulView::SettingsStyles | Default styles.for mass haul components.
SettingsMatchLine | Settings for MatchLine.
SettingsParcel | Settings for Parcel.
SettingsParcel::SettingsStyles | Default styles.setting class
SettingsPoint | Settings for Point.
SettingsPoint::SettingsNameFormat | Default name format for point feature settings.
SettingsPoint::SettingsStyles | Default styles.setting class
SettingsPoint::SettingsUpdatePoints | Update points setting class.
SettingsProfile | Settings for Profile.
SettingsProfile::SettingsCriteriaBasedDesignOptions | Criteria Based Design options setting class
SettingsProfile::SettingsDefaultNameFormat | Default name format setting class
SettingsProfile::SettingsProfileCreation | Default values for vertical curve sub-entities
SettingsProfile::SettingsStyles | Default styles.setting class
SettingsProfileView | Settings for ProfileView.
SettingsProfileView::SettingsCreation | Settings for ProfileView default Creation.
SettingsProfileView::SettingsNameFormat | Settings for ProfileView default NameFormat.
SettingsProfileView::SettingsProjectionLabelPlacement | Settings for ProfileView default ProjectionLabelPlacement.
SettingsProfileView::SettingsSplitOptions | Settings for ProfileView default SplitOptions.
SettingsProfileView::SettingsStackedOptions | Settings for ProfileView default StackedOptions.
SettingsProfileView::SettingsStyles | Settings for ProfileView default Styles.
SettingsSampleLine | Settings for SampleLine.
SettingsSampleLine::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSampleLine::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSection | Settings for Section.
SettingsSection::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSection::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSectionView | Settings to specify the default styles assigned to section view components
SettingsSectionView::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsProjectionLabelPlacement | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsSectionViewCreation | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSurface | Settings for Surface.
SettingsSurface::SettingsContourLabeling | Defaults assigned to surface labels.
SettingsSurface::SettingsDefaults | Default name format for new surfaces.
SettingsSurface::SettingsStyles | Default styles.assigned to surfaces and surface-related labels.
SettingsViewFrame | Settings for ViewFrame.
SettingsViewFrameGroup | Settings for ViewFrameGroup.
SettingsViewFrameGroup::SettingsInformation | Default match line label location.
SettingsViewFrameGroup::SettingsNameFormat | Default name format for view frame group components.
SettingsViewFrameGroup::SettingsStyles | Default styles assigned to view frame group components.
Links
Classes


SettingsAbbreviationAlignment Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class
SettingsAbbreviationAlignment Class
Collapse All

Abbreviations Settings for Alignment Geometry Point Entity Data

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAbbreviationAlignment
C#
public class SettingsAbbreviationAlignment : TreeOidWrapper;
Visual Basic
Public Class SettingsAbbreviationAlignment
Inherits TreeOidWrapper
Links
SettingsAbbreviationAlignment Methods, SettingsAbbreviationAlignment Members, Class Hierarchy


SettingsAbbreviationAlignment Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class > SettingsAbbreviationAlignment Members
SettingsAbbreviationAlignment Members
Collapse All

The following tables list the members exposed by SettingsAbbreviationAlignment.

Public Methods
Public Method | Description
GetAlignmentAbbreviation | Gets the alignment abbreviation settings
SetAlignmentAbbreviation | Sets the alignment abbreviation settings
Links
Public Methods


SettingsAbbreviationAlignment Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class > SettingsAbbreviationAlignment Methods
SettingsAbbreviationAlignment Methods
Collapse All

The methods of SettingsAbbreviationAlignment are listed here.

Public Methods
Public Method | Description
GetAlignmentAbbreviation | Gets the alignment abbreviation settings
SetAlignmentAbbreviation | Sets the alignment abbreviation settings
Links
Public Methods


SettingsAbbreviationAlignment::GetAlignmentAbbreviation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class > SettingsAbbreviationAlignment Methods > SettingsAbbreviationAlignment::GetAlignmentAbbreviation Method
SettingsAbbreviationAlignment::GetAlignmentAbbreviation Method
Collapse All

Gets the alignment abbreviation settings

C#
public System::String GetAlignmentAbbreviation(
    AbbreviationAlignmentType type
);
Visual Basic
Public Function GetAlignmentAbbreviation(
    type As AbbreviationAlignmentType
) As System::String
Parameters
Parameters | Description
type | The type of settings to get.
Links
SettingsAbbreviationAlignment Class, SettingsAbbreviationAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsAbbreviationAlignment::SetAlignmentAbbreviation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class > SettingsAbbreviationAlignment Methods > SettingsAbbreviationAlignment::SetAlignmentAbbreviation Method
SettingsAbbreviationAlignment::SetAlignmentAbbreviation Method
Collapse All

Sets the alignment abbreviation settings

C#
public SetAlignmentAbbreviation(
    AbbreviationAlignmentType type,
    ref System::String value
);
Visual Basic
Public Sub SetAlignmentAbbreviation(
    type As AbbreviationAlignmentType,
    ByRef value As System::String
)
Parameters
Parameters | Description
type | The type of settings to set.
value | The value to set.
Links
SettingsAbbreviationAlignment Class, SettingsAbbreviationAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsAbbreviationAlignmentEnhanced Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class
SettingsAbbreviationAlignmentEnhanced Class
Collapse All

Abbreviations Settings for Alignment Geometry Point Text

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAbbreviationAlignmentEnhanced
C#
public class SettingsAbbreviationAlignmentEnhanced : TreeOidWrapper;
Visual Basic
Public Class SettingsAbbreviationAlignmentEnhanced
Inherits TreeOidWrapper
Links
SettingsAbbreviationAlignmentEnhanced Methods, SettingsAbbreviationAlignmentEnhanced Members, Class Hierarchy


SettingsAbbreviationAlignmentEnhanced Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class > SettingsAbbreviationAlignmentEnhanced Members
SettingsAbbreviationAlignmentEnhanced Members
Collapse All

The following tables list the members exposed by SettingsAbbreviationAlignmentEnhanced.

Public Methods
Public Method | Description
GetAlignmentEnhancedAbbreviation | Gets the alignment enhanced abbreviation settings
SetAlignmentEnhancedAbbreviation | Sets the alignment enhanced abbreviation settings
Links
Public Methods


SettingsAbbreviationAlignmentEnhanced Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class > SettingsAbbreviationAlignmentEnhanced Methods
SettingsAbbreviationAlignmentEnhanced Methods
Collapse All

The methods of SettingsAbbreviationAlignmentEnhanced are listed here.

Public Methods
Public Method | Description
GetAlignmentEnhancedAbbreviation | Gets the alignment enhanced abbreviation settings
SetAlignmentEnhancedAbbreviation | Sets the alignment enhanced abbreviation settings
Links
Public Methods


SettingsAbbreviationAlignmentEnhanced::GetAlignmentEnhancedAbbreviation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class > SettingsAbbreviationAlignmentEnhanced Methods > SettingsAbbreviationAlignmentEnhanced::GetAlignmentEnhancedAbbreviation Method
SettingsAbbreviationAlignmentEnhanced::GetAlignmentEnhancedAbbreviation Method
Collapse All

Gets the alignment enhanced abbreviation settings

C#
public System::String GetAlignmentEnhancedAbbreviation(
    AbbreviationAlignmentEnhancedType type
);
Visual Basic
Public Function GetAlignmentEnhancedAbbreviation(
    type As AbbreviationAlignmentEnhancedType
) As System::String
Parameters
Parameters | Description
type | The type of settings to get.
Links
SettingsAbbreviationAlignmentEnhanced Class, SettingsAbbreviationAlignmentEnhanced Members, Autodesk::Civil::Land::Settings Namespace


SettingsAbbreviationAlignmentEnhanced::SetAlignmentEnhancedAbbreviation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class > SettingsAbbreviationAlignmentEnhanced Methods > SettingsAbbreviationAlignmentEnhanced::SetAlignmentEnhancedAbbreviation Method
SettingsAbbreviationAlignmentEnhanced::SetAlignmentEnhancedAbbreviation Method
Collapse All

Sets the alignment enhanced abbreviation settings

C#
public SetAlignmentEnhancedAbbreviation(
    AbbreviationAlignmentEnhancedType type,
    ref System::String newValue
);
Visual Basic
Public Sub SetAlignmentEnhancedAbbreviation(
    type As AbbreviationAlignmentEnhancedType,
    ByRef newValue As System::String
)
Parameters
Parameters | Description
type | The type of settings to set.
newValue | The value to set.
Links
SettingsAbbreviationAlignmentEnhanced Class, SettingsAbbreviationAlignmentEnhanced Members, Autodesk::Civil::Land::Settings Namespace


SettingsAbbreviationProfile Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class
SettingsAbbreviationProfile Class
Collapse All

Abbreviations Settings for Profile

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAbbreviationProfile
C#
public class SettingsAbbreviationProfile : TreeOidWrapper;
Visual Basic
Public Class SettingsAbbreviationProfile
Inherits TreeOidWrapper
Links
SettingsAbbreviationProfile Methods, SettingsAbbreviationProfile Members, Class Hierarchy


SettingsAbbreviationProfile Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class > SettingsAbbreviationProfile Members
SettingsAbbreviationProfile Members
Collapse All

The following tables list the members exposed by SettingsAbbreviationProfile.

Public Methods
Public Method | Description
GetProfileAbbreviation | Gets the profile abbreviation settings
SetProfileAbbreviation | Sets the profile abbreviation settings
Links
Public Methods


SettingsAbbreviationProfile Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class > SettingsAbbreviationProfile Methods
SettingsAbbreviationProfile Methods
Collapse All

The methods of SettingsAbbreviationProfile are listed here.

Public Methods
Public Method | Description
GetProfileAbbreviation | Gets the profile abbreviation settings
SetProfileAbbreviation | Sets the profile abbreviation settings
Links
Public Methods


SettingsAbbreviationProfile::GetProfileAbbreviation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class > SettingsAbbreviationProfile Methods > SettingsAbbreviationProfile::GetProfileAbbreviation Method
SettingsAbbreviationProfile::GetProfileAbbreviation Method
Collapse All

Gets the profile abbreviation settings

C#
public System::String GetProfileAbbreviation(
    AbbreviationProfileType type
);
Visual Basic
Public Function GetProfileAbbreviation(
    type As AbbreviationProfileType
) As System::String
Parameters
Parameters | Description
type | The type of settings to get.
Links
SettingsAbbreviationProfile Class, SettingsAbbreviationProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsAbbreviationProfile::SetProfileAbbreviation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class > SettingsAbbreviationProfile Methods > SettingsAbbreviationProfile::SetProfileAbbreviation Method
SettingsAbbreviationProfile::SetProfileAbbreviation Method
Collapse All

Sets the profile abbreviation settings

C#
public SetProfileAbbreviation(
    AbbreviationProfileType type,
    ref System::String newValue
);
Visual Basic
Public Sub SetProfileAbbreviation(
    type As AbbreviationProfileType,
    ByRef newValue As System::String
)
Parameters
Parameters | Description
type | The type of settings to set.
newValue | The value to set.
Links
SettingsAbbreviationProfile Class, SettingsAbbreviationProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsAbbreviationSuperelevation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class
SettingsAbbreviationSuperelevation Class
Collapse All

Abbreviations Settings for Superelevation

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAbbreviationSuperelevation
C#
public class SettingsAbbreviationSuperelevation : TreeOidWrapper;
Visual Basic
Public Class SettingsAbbreviationSuperelevation
Inherits TreeOidWrapper
Links
SettingsAbbreviationSuperelevation Methods, SettingsAbbreviationSuperelevation Members, Class Hierarchy


SettingsAbbreviationSuperelevation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class > SettingsAbbreviationSuperelevation Members
SettingsAbbreviationSuperelevation Members
Collapse All

The following tables list the members exposed by SettingsAbbreviationSuperelevation.

Public Methods
Public Method | Description
GetSuperelevationAbbreviation | Gets the superelevation abbreviation settings
SetSuperelevationAbbreviation | Sets the superelevation abbreviation settings
Links
Public Methods


SettingsAbbreviationSuperelevation Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class > SettingsAbbreviationSuperelevation Methods
SettingsAbbreviationSuperelevation Methods
Collapse All

The methods of SettingsAbbreviationSuperelevation are listed here.

Public Methods
Public Method | Description
GetSuperelevationAbbreviation | Gets the superelevation abbreviation settings
SetSuperelevationAbbreviation | Sets the superelevation abbreviation settings
Links
Public Methods


SettingsAbbreviationSuperelevation::GetSuperelevationAbbreviation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class > SettingsAbbreviationSuperelevation Methods > SettingsAbbreviationSuperelevation::GetSuperelevationAbbreviation Method
SettingsAbbreviationSuperelevation::GetSuperelevationAbbreviation Method
Collapse All

Gets the superelevation abbreviation settings

C#
public System::String GetSuperelevationAbbreviation(
    AbbreviationSuperelevationType type
);
Visual Basic
Public Function GetSuperelevationAbbreviation(
    type As AbbreviationSuperelevationType
) As System::String
Parameters
Parameters | Description
type | The type of settings to get.
Links
SettingsAbbreviationSuperelevation Class, SettingsAbbreviationSuperelevation Members, Autodesk::Civil::Land::Settings Namespace


SettingsAbbreviationSuperelevation::SetSuperelevationAbbreviation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class > SettingsAbbreviationSuperelevation Methods > SettingsAbbreviationSuperelevation::SetSuperelevationAbbreviation Method
SettingsAbbreviationSuperelevation::SetSuperelevationAbbreviation Method
Collapse All

Sets the superelevation abbreviation settings

C#
public SetSuperelevationAbbreviation(
    AbbreviationSuperelevationType type,
    ref System::String newValue
);
Visual Basic
Public Sub SetSuperelevationAbbreviation(
    type As AbbreviationSuperelevationType,
    ByRef newValue As System::String
)
Parameters
Parameters | Description
type | The type of settings to set.
newValue | The value to set.
Links
SettingsAbbreviationSuperelevation Class, SettingsAbbreviationSuperelevation Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class
SettingsAlignment Class
Collapse All

Settings for Alignment.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentCurveTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentLineTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentOffLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentOffXYLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSegmentTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSpiralTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignSegLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignSegLbls
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignTagentLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignTagentLbls
        Autodesk::Civil::Land::Settings::SettingsCmdAddWidening
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentEntities
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentReference
        Autodesk::Civil::Land::Settings::SettingsCmdCreateOffsetAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdReverseAlignmentDirection
C#
public class SettingsAlignment : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsAlignment
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsAlignment Properties, SettingsAlignment Members, Class Hierarchy


SettingsAlignment Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Members
SettingsAlignment Members
Collapse All

The following tables list the members exposed by SettingsAlignment.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsAlignment Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties
SettingsAlignment Properties
Collapse All

The properties of SettingsAlignment are listed here.

Public Properties
Public Property | Description
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
Links
Public Properties


SettingsAlignment::CriteriaBasedDesignOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties > SettingsAlignment::CriteriaBasedDesignOptions Property
SettingsAlignment::CriteriaBasedDesignOptions Property
Collapse All

Gets the defaults for creating an alignment using design criteria

C#
public SettingsCriteriaBasedDesignOptions CriteriaBasedDesignOptions;
Visual Basic
Public Property CriteriaBasedDesignOptions() As SettingsCriteriaBasedDesignOptions
Links
SettingsAlignment Class, SettingsAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::Data Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties > SettingsAlignment::Data Property
SettingsAlignment::Data Property deprecated
Collapse All

Gets the defaults data for creating an alignment

C#
public SettingsData Data;
Visual Basic
Public Property Data() As SettingsData
Notes

Deprecated: Use the Autodesk.Civil.Land.Settings.SettingsAlignment.CriteriaBasedDesignOptions instead.

Links
SettingsAlignment Class, SettingsAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::DefaultNameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties > SettingsAlignment::DefaultNameFormat Property
SettingsAlignment::DefaultNameFormat Property
Collapse All

Gets the default name formats for new alignments

C#
public SettingsDefaultNameFormat DefaultNameFormat;
Visual Basic
Public Property DefaultNameFormat() As SettingsDefaultNameFormat
Links
SettingsAlignment Class, SettingsAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::DynamicAlignmentHighlight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties > SettingsAlignment::DynamicAlignmentHighlight Property
SettingsAlignment::DynamicAlignmentHighlight Property
Collapse All

Gets the defaults data for creating an alignment

C#
public SettingsDynamicAlignmentHighlight DynamicAlignmentHighlight;
Visual Basic
Public Property DynamicAlignmentHighlight() As SettingsDynamicAlignmentHighlight
Links
SettingsAlignment Class, SettingsAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::StationIndexing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties > SettingsAlignment::StationIndexing Property
SettingsAlignment::StationIndexing Property
Collapse All

Gets the default station indexing for new alignments

C#
public SettingsStationIndexing StationIndexing;
Visual Basic
Public Property StationIndexing() As SettingsStationIndexing
Links
SettingsAlignment Class, SettingsAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::StyleSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties > SettingsAlignment::StyleSettings Property
SettingsAlignment::StyleSettings Property
Collapse All

Gets the default styles for new alignments

C#
public SettingsStyles StyleSettings;
Visual Basic
Public Property StyleSettings() As SettingsStyles
Links
SettingsAlignment Class, SettingsAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SuperelevationOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties > SettingsAlignment::SuperelevationOptions Property
SettingsAlignment::SuperelevationOptions Property
Collapse All

Gets the defaults for calculating superelevation specifications

C#
public SettingsSuperelevationOptions SuperelevationOptions;
Visual Basic
Public Property SuperelevationOptions() As SettingsSuperelevationOptions
Links
SettingsAlignment Class, SettingsAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsCriteriaBasedDesignOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class
SettingsAlignment::SettingsCriteriaBasedDesignOptions Class
Collapse All

Default settings for creating an alignment using design criteria.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsCriteriaBasedDesignOptions
C#
public class SettingsAlignment::SettingsCriteriaBasedDesignOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsAlignment::SettingsCriteriaBasedDesignOptions
Inherits TreeOidWrapper
Links
SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties, SettingsAlignment::SettingsCriteriaBasedDesignOptions Members, Class Hierarchy


SettingsAlignment::SettingsCriteriaBasedDesignOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Members
SettingsAlignment::SettingsCriteriaBasedDesignOptions Members
Collapse All

The following tables list the members exposed by SettingsAlignment::SettingsCriteriaBasedDesignOptions.

Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
DesignSpeed | Gets default alignment design speed.
DesignSpeedLookupMethod | Gets the table lookup rule in cases where the actual design speed does not exactly match the speed specified in... more
RadiusLookupMethod | Gets the table lookup rule in cases where the actual radius does not exactly match the speed specified in the... more
UseCriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
UseDesignChecksOption | Gets whether to use a design check set by default.
UseDesignCriteriaFileOption | Gets whether to use a design criteria file by default.
Links
Public Properties


SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties
SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties
Collapse All

The properties of SettingsAlignment::SettingsCriteriaBasedDesignOptions are listed here.

Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
DesignSpeed | Gets default alignment design speed.
DesignSpeedLookupMethod | Gets the table lookup rule in cases where the actual design speed does not exactly match the speed specified in... more
RadiusLookupMethod | Gets the table lookup rule in cases where the actual radius does not exactly match the speed specified in the... more
UseCriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
UseDesignChecksOption | Gets whether to use a design check set by default.
UseDesignCriteriaFileOption | Gets whether to use a design criteria file by default.
Links
Public Properties


SettingsAlignment::SettingsCriteriaBasedDesignOptions::DefaultDesignCheckSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties > SettingsAlignment::SettingsCriteriaBasedDesignOptions::DefaultDesignCheckSet Property
SettingsAlignment::SettingsCriteriaBasedDesignOptions::DefaultDesignCheckSet Property
Collapse All

Gets the default design check set.

C#
public PropertyString DefaultDesignCheckSet;
Visual Basic
Public Property DefaultDesignCheckSet() As PropertyString
Links
SettingsAlignment::SettingsCriteriaBasedDesignOptions Class, SettingsAlignment::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsCriteriaBasedDesignOptions::DesignSpeed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties > SettingsAlignment::SettingsCriteriaBasedDesignOptions::DesignSpeed Property
SettingsAlignment::SettingsCriteriaBasedDesignOptions::DesignSpeed Property
Collapse All

Gets default alignment design speed.

C#
public PropertyDouble DesignSpeed;
Visual Basic
Public Property DesignSpeed() As PropertyDouble
Links
SettingsAlignment::SettingsCriteriaBasedDesignOptions Class, SettingsAlignment::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsCriteriaBasedDesignOptions::DesignSpeedLookupMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties > SettingsAlignment::SettingsCriteriaBasedDesignOptions::DesignSpeedLookupMethod Property
SettingsAlignment::SettingsCriteriaBasedDesignOptions::DesignSpeedLookupMethod Property
Collapse All

Gets the table lookup rule in cases where the actual design speed does not exactly match the speed specified in the design criteria tables.

C#
public PropertyEnum<DesignSpeedLookupMethodType> DesignSpeedLookupMethod;
Visual Basic
Public Property DesignSpeedLookupMethod() As PropertyEnum<DesignSpeedLookupMethodType>
Links
SettingsAlignment::SettingsCriteriaBasedDesignOptions Class, SettingsAlignment::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsCriteriaBasedDesignOptions::RadiusLookupMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties > SettingsAlignment::SettingsCriteriaBasedDesignOptions::RadiusLookupMethod Property
SettingsAlignment::SettingsCriteriaBasedDesignOptions::RadiusLookupMethod Property
Collapse All

Gets the table lookup rule in cases where the actual radius does not exactly match the speed specified in the design criteria tables.

C#
public PropertyEnum<RadiusLookupMethodType> RadiusLookupMethod;
Visual Basic
Public Property RadiusLookupMethod() As PropertyEnum<RadiusLookupMethodType>
Links
SettingsAlignment::SettingsCriteriaBasedDesignOptions Class, SettingsAlignment::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseCriteriaBasedDesignOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties > SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseCriteriaBasedDesignOption Property
SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseCriteriaBasedDesignOption Property
Collapse All

Gets whether alignments use design criteria by default.

C#
public PropertyBoolean UseCriteriaBasedDesignOption;
Visual Basic
Public Property UseCriteriaBasedDesignOption() As PropertyBoolean
Links
SettingsAlignment::SettingsCriteriaBasedDesignOptions Class, SettingsAlignment::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseDesignChecksOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties > SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseDesignChecksOption Property
SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseDesignChecksOption Property
Collapse All

Gets whether to use a design check set by default.

C#
public PropertyBoolean UseDesignChecksOption;
Visual Basic
Public Property UseDesignChecksOption() As PropertyBoolean
Links
SettingsAlignment::SettingsCriteriaBasedDesignOptions Class, SettingsAlignment::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties > SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property
SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property
Collapse All

Gets whether to use a design criteria file by default.

C#
public PropertyBoolean UseDesignCriteriaFileOption;
Visual Basic
Public Property UseDesignCriteriaFileOption() As PropertyBoolean
Links
SettingsAlignment::SettingsCriteriaBasedDesignOptions Class, SettingsAlignment::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsData Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsData Class
SettingsAlignment::SettingsData Class
Collapse All

Default settings for creating an alignment using data.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsData
C#
public class SettingsAlignment::SettingsData : TreeOidWrapper;
Visual Basic
Public Class SettingsAlignment::SettingsData
Inherits TreeOidWrapper
Links
SettingsAlignment::SettingsData Properties, SettingsAlignment::SettingsData Members, Class Hierarchy


SettingsAlignment::SettingsData Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsData Class > SettingsAlignment::SettingsData Members
SettingsAlignment::SettingsData Members
Collapse All

The following tables list the members exposed by SettingsAlignment::SettingsData.

Public Properties
Public Property | Description
CriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
Links
Public Properties


SettingsAlignment::SettingsData Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsData Class > SettingsAlignment::SettingsData Properties
SettingsAlignment::SettingsData Properties
Collapse All

The properties of SettingsAlignment::SettingsData are listed here.

Public Properties
Public Property | Description
CriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
Links
Public Properties


SettingsAlignment::SettingsData::CriteriaBasedDesignOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsData Class > SettingsAlignment::SettingsData Properties > SettingsAlignment::SettingsData::CriteriaBasedDesignOption Property
SettingsAlignment::SettingsData::CriteriaBasedDesignOption Property deprecated
Collapse All

Gets whether alignments use design criteria by default.

C#
public PropertyBoolean CriteriaBasedDesignOption;
Visual Basic
Public Property CriteriaBasedDesignOption() As PropertyBoolean
Notes

Deprecated: Use the Autodesk.Civil.Land.Settings.SettingsAlignment.SettingsCriteriaBasedDesignOptions.UseDefaultDesignCheckSet instead.

Links
SettingsAlignment::SettingsData Class, SettingsAlignment::SettingsData Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDefaultNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class
SettingsAlignment::SettingsDefaultNameFormat Class
Collapse All

Settings for Alignment Default Name Format.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsDefaultNameFormat
C#
public class SettingsAlignment::SettingsDefaultNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsAlignment::SettingsDefaultNameFormat
Inherits TreeOidWrapper
Links
SettingsAlignment::SettingsDefaultNameFormat Properties, SettingsAlignment::SettingsDefaultNameFormat Members, Class Hierarchy


SettingsAlignment::SettingsDefaultNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class > SettingsAlignment::SettingsDefaultNameFormat Members
SettingsAlignment::SettingsDefaultNameFormat Members
Collapse All

The following tables list the members exposed by SettingsAlignment::SettingsDefaultNameFormat.

Public Properties
Public Property | Description
AlignmentNameTemplate | Gets specify the default name formats for new alignments.
OffsetAlignmentNameTemplate | Gets specify the default name formats for new alignments.
Links
Public Properties


SettingsAlignment::SettingsDefaultNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class > SettingsAlignment::SettingsDefaultNameFormat Properties
SettingsAlignment::SettingsDefaultNameFormat Properties
Collapse All

The properties of SettingsAlignment::SettingsDefaultNameFormat are listed here.

Public Properties
Public Property | Description
AlignmentNameTemplate | Gets specify the default name formats for new alignments.
OffsetAlignmentNameTemplate | Gets specify the default name formats for new alignments.
Links
Public Properties


SettingsAlignment::SettingsDefaultNameFormat::AlignmentNameTemplate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class > SettingsAlignment::SettingsDefaultNameFormat Properties > SettingsAlignment::SettingsDefaultNameFormat::AlignmentNameTemplate Property
SettingsAlignment::SettingsDefaultNameFormat::AlignmentNameTemplate Property
Collapse All

Gets specify the default name formats for new alignments.

C#
public PropertyString AlignmentNameTemplate;
Visual Basic
Public Property AlignmentNameTemplate() As PropertyString
Links
SettingsAlignment::SettingsDefaultNameFormat Class, SettingsAlignment::SettingsDefaultNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDefaultNameFormat::OffsetAlignmentNameTemplate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class > SettingsAlignment::SettingsDefaultNameFormat Properties > SettingsAlignment::SettingsDefaultNameFormat::OffsetAlignmentNameTemplate Property
SettingsAlignment::SettingsDefaultNameFormat::OffsetAlignmentNameTemplate Property
Collapse All

Gets specify the default name formats for new alignments.

C#
public PropertyString OffsetAlignmentNameTemplate;
Visual Basic
Public Property OffsetAlignmentNameTemplate() As PropertyString
Links
SettingsAlignment::SettingsDefaultNameFormat Class, SettingsAlignment::SettingsDefaultNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class
SettingsAlignment::SettingsDynamicAlignmentHighlight Class
Collapse All

Default settings for dynamic alignment hightlight options.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsDynamicAlignmentHighlight
C#
public class SettingsAlignment::SettingsDynamicAlignmentHighlight : TreeOidWrapper;
Visual Basic
Public Class SettingsAlignment::SettingsDynamicAlignmentHighlight
Inherits TreeOidWrapper
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Properties, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Class Hierarchy


SettingsAlignment::SettingsDynamicAlignmentHighlight Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Members
SettingsAlignment::SettingsDynamicAlignmentHighlight Members
Collapse All

The following tables list the members exposed by SettingsAlignment::SettingsDynamicAlignmentHighlight.

Public Properties
Public Property | Description
CurbReturnFilletRegionColor | Gets CurbReturnFilletRegionColor for dynamic alignment highlight.
CurbReturnFilletRegionLineweight | Gets CurbReturnFilletRegionLineweight for dynamic alignment highlight.
OffsetRegionColor | Gets OffsetRegionColor for dynamic alignment highlight.
OffsetRegionLineweight | Gets OffsetRegionLineweight for dynamic alignment highlight.
ParentAlignmentColor | Gets ParentAlignmentColor for dynamic alignment highlight.
ParentAlignmentLineweight | Gets ParentAlignmentLineweight for dynamic alignment highlight.
ParentAlignmentTrackerColor | Gets ParentAlignmentTrackerColor for dynamic alignment highlight.
ParentAlignmentTrackerLineweight | Gets ParentAlignmentTrackerLineweight for dynamic alignment highlight.
TransitionRegionColor | Gets TransitionRegionColor for dynamic alignment highlight.
TransitionRegionLineweight | Gets TransitionRegionLineweight for dynamic alignment highlight.
Links
Public Properties


SettingsAlignment::SettingsDynamicAlignmentHighlight Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties
SettingsAlignment::SettingsDynamicAlignmentHighlight Properties
Collapse All

The properties of SettingsAlignment::SettingsDynamicAlignmentHighlight are listed here.

Public Properties
Public Property | Description
CurbReturnFilletRegionColor | Gets CurbReturnFilletRegionColor for dynamic alignment highlight.
CurbReturnFilletRegionLineweight | Gets CurbReturnFilletRegionLineweight for dynamic alignment highlight.
OffsetRegionColor | Gets OffsetRegionColor for dynamic alignment highlight.
OffsetRegionLineweight | Gets OffsetRegionLineweight for dynamic alignment highlight.
ParentAlignmentColor | Gets ParentAlignmentColor for dynamic alignment highlight.
ParentAlignmentLineweight | Gets ParentAlignmentLineweight for dynamic alignment highlight.
ParentAlignmentTrackerColor | Gets ParentAlignmentTrackerColor for dynamic alignment highlight.
ParentAlignmentTrackerLineweight | Gets ParentAlignmentTrackerLineweight for dynamic alignment highlight.
TransitionRegionColor | Gets TransitionRegionColor for dynamic alignment highlight.
TransitionRegionLineweight | Gets TransitionRegionLineweight for dynamic alignment highlight.
Links
Public Properties


SettingsAlignment::SettingsDynamicAlignmentHighlight::CurbReturnFilletRegionColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::CurbReturnFilletRegionColor Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::CurbReturnFilletRegionColor Property
Collapse All

Gets CurbReturnFilletRegionColor for dynamic alignment highlight.

C#
public PropertyColor CurbReturnFilletRegionColor;
Visual Basic
Public Property CurbReturnFilletRegionColor() As PropertyColor
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight::CurbReturnFilletRegionLineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::CurbReturnFilletRegionLineweight Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::CurbReturnFilletRegionLineweight Property
Collapse All

Gets CurbReturnFilletRegionLineweight for dynamic alignment highlight.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> CurbReturnFilletRegionLineweight;
Visual Basic
Public Property CurbReturnFilletRegionLineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight::OffsetRegionColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::OffsetRegionColor Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::OffsetRegionColor Property
Collapse All

Gets OffsetRegionColor for dynamic alignment highlight.

C#
public PropertyColor OffsetRegionColor;
Visual Basic
Public Property OffsetRegionColor() As PropertyColor
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight::OffsetRegionLineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::OffsetRegionLineweight Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::OffsetRegionLineweight Property
Collapse All

Gets OffsetRegionLineweight for dynamic alignment highlight.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> OffsetRegionLineweight;
Visual Basic
Public Property OffsetRegionLineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentColor Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentColor Property
Collapse All

Gets ParentAlignmentColor for dynamic alignment highlight.

C#
public PropertyColor ParentAlignmentColor;
Visual Basic
Public Property ParentAlignmentColor() As PropertyColor
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentLineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentLineweight Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentLineweight Property
Collapse All

Gets ParentAlignmentLineweight for dynamic alignment highlight.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> ParentAlignmentLineweight;
Visual Basic
Public Property ParentAlignmentLineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentTrackerColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentTrackerColor Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentTrackerColor Property
Collapse All

Gets ParentAlignmentTrackerColor for dynamic alignment highlight.

C#
public PropertyColor ParentAlignmentTrackerColor;
Visual Basic
Public Property ParentAlignmentTrackerColor() As PropertyColor
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentTrackerLineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentTrackerLineweight Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentTrackerLineweight Property
Collapse All

Gets ParentAlignmentTrackerLineweight for dynamic alignment highlight.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> ParentAlignmentTrackerLineweight;
Visual Basic
Public Property ParentAlignmentTrackerLineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight::TransitionRegionColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::TransitionRegionColor Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::TransitionRegionColor Property
Collapse All

Gets TransitionRegionColor for dynamic alignment highlight.

C#
public PropertyColor TransitionRegionColor;
Visual Basic
Public Property TransitionRegionColor() As PropertyColor
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsDynamicAlignmentHighlight::TransitionRegionLineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties > SettingsAlignment::SettingsDynamicAlignmentHighlight::TransitionRegionLineweight Property
SettingsAlignment::SettingsDynamicAlignmentHighlight::TransitionRegionLineweight Property
Collapse All

Gets TransitionRegionLineweight for dynamic alignment highlight.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> TransitionRegionLineweight;
Visual Basic
Public Property TransitionRegionLineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
SettingsAlignment::SettingsDynamicAlignmentHighlight Class, SettingsAlignment::SettingsDynamicAlignmentHighlight Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsStationIndexing Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStationIndexing Class
SettingsAlignment::SettingsStationIndexing Class
Collapse All

Settings for Alignment Station Indexing.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsStationIndexing
C#
public class SettingsAlignment::SettingsStationIndexing : TreeOidWrapper;
Visual Basic
Public Class SettingsAlignment::SettingsStationIndexing
Inherits TreeOidWrapper
Links
SettingsAlignment::SettingsStationIndexing Properties, SettingsAlignment::SettingsStationIndexing Members, Class Hierarchy


SettingsAlignment::SettingsStationIndexing Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStationIndexing Class > SettingsAlignment::SettingsStationIndexing Members
SettingsAlignment::SettingsStationIndexing Members
Collapse All

The following tables list the members exposed by SettingsAlignment::SettingsStationIndexing.

Public Properties
Public Property | Description
DefaultStationIndexIncrement | Gets the default value for station increments.
Links
Public Properties


SettingsAlignment::SettingsStationIndexing Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStationIndexing Class > SettingsAlignment::SettingsStationIndexing Properties
SettingsAlignment::SettingsStationIndexing Properties
Collapse All

The properties of SettingsAlignment::SettingsStationIndexing are listed here.

Public Properties
Public Property | Description
DefaultStationIndexIncrement | Gets the default value for station increments.
Links
Public Properties


SettingsAlignment::SettingsStationIndexing::DefaultStationIndexIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStationIndexing Class > SettingsAlignment::SettingsStationIndexing Properties > SettingsAlignment::SettingsStationIndexing::DefaultStationIndexIncrement Property
SettingsAlignment::SettingsStationIndexing::DefaultStationIndexIncrement Property
Collapse All

Gets the default value for station increments.

C#
public PropertyDouble DefaultStationIndexIncrement;
Visual Basic
Public Property DefaultStationIndexIncrement() As PropertyDouble
Links
SettingsAlignment::SettingsStationIndexing Class, SettingsAlignment::SettingsStationIndexing Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class
SettingsAlignment::SettingsStyles Class
Collapse All

Settings for Alignment default styles.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsStyles
C#
public class SettingsAlignment::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsAlignment::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsAlignment::SettingsStyles Properties, SettingsAlignment::SettingsStyles Members, Class Hierarchy


SettingsAlignment::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Members
SettingsAlignment::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsAlignment::SettingsStyles.

Public Properties
Public Property | Description
AlignmentLabelSet | Gets the default alignment label set.
AlignmentStyle | Gets the default alignment style.
CurveLabelStyle | Gets the default curve label style.
LineLabelStyle | Gets the default line label style.
MarkerStyle | Gets the display and appearance of points on the alignment.
SpiralLabelStyle | Gets the default spiral label style.
StationOffsetLabelStyle | Gets the default station offset label style.
TangentIntersectLabelStyle | Gets the default tangent intersection label style.
Links
Public Properties


SettingsAlignment::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties
SettingsAlignment::SettingsStyles Properties
Collapse All

The properties of SettingsAlignment::SettingsStyles are listed here.

Public Properties
Public Property | Description
AlignmentLabelSet | Gets the default alignment label set.
AlignmentStyle | Gets the default alignment style.
CurveLabelStyle | Gets the default curve label style.
LineLabelStyle | Gets the default line label style.
MarkerStyle | Gets the display and appearance of points on the alignment.
SpiralLabelStyle | Gets the default spiral label style.
StationOffsetLabelStyle | Gets the default station offset label style.
TangentIntersectLabelStyle | Gets the default tangent intersection label style.
Links
Public Properties


SettingsAlignment::SettingsStyles::AlignmentLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties > SettingsAlignment::SettingsStyles::AlignmentLabelSet Property
SettingsAlignment::SettingsStyles::AlignmentLabelSet Property
Collapse All

Gets the default alignment label set.

C#
public PropertyString AlignmentLabelSet;
Visual Basic
Public Property AlignmentLabelSet() As PropertyString
Links
SettingsAlignment::SettingsStyles Class, SettingsAlignment::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsStyles::AlignmentStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties > SettingsAlignment::SettingsStyles::AlignmentStyle Property
SettingsAlignment::SettingsStyles::AlignmentStyle Property
Collapse All

Gets the default alignment style.

C#
public PropertyString AlignmentStyle;
Visual Basic
Public Property AlignmentStyle() As PropertyString
Links
SettingsAlignment::SettingsStyles Class, SettingsAlignment::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsStyles::CurveLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties > SettingsAlignment::SettingsStyles::CurveLabelStyle Property
SettingsAlignment::SettingsStyles::CurveLabelStyle Property
Collapse All

Gets the default curve label style.

C#
public PropertyString CurveLabelStyle;
Visual Basic
Public Property CurveLabelStyle() As PropertyString
Links
SettingsAlignment::SettingsStyles Class, SettingsAlignment::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsStyles::LineLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties > SettingsAlignment::SettingsStyles::LineLabelStyle Property
SettingsAlignment::SettingsStyles::LineLabelStyle Property
Collapse All

Gets the default line label style.

C#
public PropertyString LineLabelStyle;
Visual Basic
Public Property LineLabelStyle() As PropertyString
Links
SettingsAlignment::SettingsStyles Class, SettingsAlignment::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsStyles::MarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties > SettingsAlignment::SettingsStyles::MarkerStyle Property
SettingsAlignment::SettingsStyles::MarkerStyle Property
Collapse All

Gets the display and appearance of points on the alignment.

C#
public PropertyString MarkerStyle;
Visual Basic
Public Property MarkerStyle() As PropertyString
Links
SettingsAlignment::SettingsStyles Class, SettingsAlignment::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsStyles::SpiralLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties > SettingsAlignment::SettingsStyles::SpiralLabelStyle Property
SettingsAlignment::SettingsStyles::SpiralLabelStyle Property
Collapse All

Gets the default spiral label style.

C#
public PropertyString SpiralLabelStyle;
Visual Basic
Public Property SpiralLabelStyle() As PropertyString
Links
SettingsAlignment::SettingsStyles Class, SettingsAlignment::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsStyles::StationOffsetLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties > SettingsAlignment::SettingsStyles::StationOffsetLabelStyle Property
SettingsAlignment::SettingsStyles::StationOffsetLabelStyle Property
Collapse All

Gets the default station offset label style.

C#
public PropertyString StationOffsetLabelStyle;
Visual Basic
Public Property StationOffsetLabelStyle() As PropertyString
Links
SettingsAlignment::SettingsStyles Class, SettingsAlignment::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsStyles::TangentIntersectLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties > SettingsAlignment::SettingsStyles::TangentIntersectLabelStyle Property
SettingsAlignment::SettingsStyles::TangentIntersectLabelStyle Property
Collapse All

Gets the default tangent intersection label style.

C#
public PropertyString TangentIntersectLabelStyle;
Visual Basic
Public Property TangentIntersectLabelStyle() As PropertyString
Links
SettingsAlignment::SettingsStyles Class, SettingsAlignment::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsSuperelevationOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class
SettingsAlignment::SettingsSuperelevationOptions Class
Collapse All

Default settings for calculating superelevation specifications.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsSuperelevationOptions
C#
public class SettingsAlignment::SettingsSuperelevationOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsAlignment::SettingsSuperelevationOptions
Inherits TreeOidWrapper
Links
SettingsAlignment::SettingsSuperelevationOptions Properties, SettingsAlignment::SettingsSuperelevationOptions Members, Class Hierarchy


SettingsAlignment::SettingsSuperelevationOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Members
SettingsAlignment::SettingsSuperelevationOptions Members
Collapse All

The following tables list the members exposed by SettingsAlignment::SettingsSuperelevationOptions.

Public Properties
Public Property | Description
CorridorType | Gets the type of roadway as Undivided (single carriage way) or Divided (dual carriage way).
CrossSectionShape | Gets the cross sectional shape of the roadway as Planar .
HighsideLocation | Gets the default Highside Location for planar roads.
InsideShoulderMethod | Gets the method that is applied to the inside shoulder during superelevation.
NominalWidth | Gets the typical width of the roadway from the superelevation pivot point to the outer edge-of-traveled way.
NormalLaneSlope | Gets the % slope of the roadway lanes on tangent (unsuperelevated) tangents.
NormalShoulderSlope | Gets the % slope value of the roadway shoulders.
OutsideShoulderMethod | Gets the method that is applied to the outside shoulder during superelevation.
StationRoundingOption | Gets the number of positions for station rounding.
Links
Public Properties


SettingsAlignment::SettingsSuperelevationOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties
SettingsAlignment::SettingsSuperelevationOptions Properties
Collapse All

The properties of SettingsAlignment::SettingsSuperelevationOptions are listed here.

Public Properties
Public Property | Description
CorridorType | Gets the type of roadway as Undivided (single carriage way) or Divided (dual carriage way).
CrossSectionShape | Gets the cross sectional shape of the roadway as Planar .
HighsideLocation | Gets the default Highside Location for planar roads.
InsideShoulderMethod | Gets the method that is applied to the inside shoulder during superelevation.
NominalWidth | Gets the typical width of the roadway from the superelevation pivot point to the outer edge-of-traveled way.
NormalLaneSlope | Gets the % slope of the roadway lanes on tangent (unsuperelevated) tangents.
NormalShoulderSlope | Gets the % slope value of the roadway shoulders.
OutsideShoulderMethod | Gets the method that is applied to the outside shoulder during superelevation.
StationRoundingOption | Gets the number of positions for station rounding.
Links
Public Properties


SettingsAlignment::SettingsSuperelevationOptions::CorridorType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties > SettingsAlignment::SettingsSuperelevationOptions::CorridorType Property
SettingsAlignment::SettingsSuperelevationOptions::CorridorType Property
Collapse All

Gets the type of roadway as Undivided (single carriage way) or Divided (dual carriage way).

C#
public PropertyEnum<SuperelevationCorridorType> CorridorType;
Visual Basic
Public Property CorridorType() As PropertyEnum<SuperelevationCorridorType>
Links
SettingsAlignment::SettingsSuperelevationOptions Class, SettingsAlignment::SettingsSuperelevationOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsSuperelevationOptions::CrossSectionShape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties > SettingsAlignment::SettingsSuperelevationOptions::CrossSectionShape Property
SettingsAlignment::SettingsSuperelevationOptions::CrossSectionShape Property
Collapse All

Gets the cross sectional shape of the roadway as Planar .

C#
public PropertyEnum<CrossSectionShapeType> CrossSectionShape;
Visual Basic
Public Property CrossSectionShape() As PropertyEnum<CrossSectionShapeType>
Links
SettingsAlignment::SettingsSuperelevationOptions Class, SettingsAlignment::SettingsSuperelevationOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsSuperelevationOptions::HighsideLocation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties > SettingsAlignment::SettingsSuperelevationOptions::HighsideLocation Property
SettingsAlignment::SettingsSuperelevationOptions::HighsideLocation Property
Collapse All

Gets the default Highside Location for planar roads.

C#
public PropertyEnum<HighsideLocationType> HighsideLocation;
Visual Basic
Public Property HighsideLocation() As PropertyEnum<HighsideLocationType>
Links
SettingsAlignment::SettingsSuperelevationOptions Class, SettingsAlignment::SettingsSuperelevationOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsSuperelevationOptions::InsideShoulderMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties > SettingsAlignment::SettingsSuperelevationOptions::InsideShoulderMethod Property
SettingsAlignment::SettingsSuperelevationOptions::InsideShoulderMethod Property
Collapse All

Gets the method that is applied to the inside shoulder during superelevation.

C#
public PropertyEnum<ShoulderMethodType> InsideShoulderMethod;
Visual Basic
Public Property InsideShoulderMethod() As PropertyEnum<ShoulderMethodType>
Links
SettingsAlignment::SettingsSuperelevationOptions Class, SettingsAlignment::SettingsSuperelevationOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsSuperelevationOptions::NominalWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties > SettingsAlignment::SettingsSuperelevationOptions::NominalWidth Property
SettingsAlignment::SettingsSuperelevationOptions::NominalWidth Property
Collapse All

Gets the typical width of the roadway from the superelevation pivot point to the outer edge-of-traveled way.

C#
public PropertyDouble NominalWidth;
Visual Basic
Public Property NominalWidth() As PropertyDouble
Links
SettingsAlignment::SettingsSuperelevationOptions Class, SettingsAlignment::SettingsSuperelevationOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsSuperelevationOptions::NormalLaneSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties > SettingsAlignment::SettingsSuperelevationOptions::NormalLaneSlope Property
SettingsAlignment::SettingsSuperelevationOptions::NormalLaneSlope Property
Collapse All

Gets the % slope of the roadway lanes on tangent (unsuperelevated) tangents.

C#
public PropertyDouble NormalLaneSlope;
Visual Basic
Public Property NormalLaneSlope() As PropertyDouble
Links
SettingsAlignment::SettingsSuperelevationOptions Class, SettingsAlignment::SettingsSuperelevationOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsSuperelevationOptions::NormalShoulderSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties > SettingsAlignment::SettingsSuperelevationOptions::NormalShoulderSlope Property
SettingsAlignment::SettingsSuperelevationOptions::NormalShoulderSlope Property
Collapse All

Gets the % slope value of the roadway shoulders.

C#
public PropertyDouble NormalShoulderSlope;
Visual Basic
Public Property NormalShoulderSlope() As PropertyDouble
Links
SettingsAlignment::SettingsSuperelevationOptions Class, SettingsAlignment::SettingsSuperelevationOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsSuperelevationOptions::OutsideShoulderMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties > SettingsAlignment::SettingsSuperelevationOptions::OutsideShoulderMethod Property
SettingsAlignment::SettingsSuperelevationOptions::OutsideShoulderMethod Property
Collapse All

Gets the method that is applied to the outside shoulder during superelevation.

C#
public PropertyEnum<ShoulderMethodType> OutsideShoulderMethod;
Visual Basic
Public Property OutsideShoulderMethod() As PropertyEnum<ShoulderMethodType>
Links
SettingsAlignment::SettingsSuperelevationOptions Class, SettingsAlignment::SettingsSuperelevationOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsAlignment::SettingsSuperelevationOptions::StationRoundingOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties > SettingsAlignment::SettingsSuperelevationOptions::StationRoundingOption Property
SettingsAlignment::SettingsSuperelevationOptions::StationRoundingOption Property
Collapse All

Gets the number of positions for station rounding.

C#
public PropertyEnum<SuperelevationStationRoundingType> StationRoundingOption;
Visual Basic
Public Property StationRoundingOption() As PropertyEnum<SuperelevationStationRoundingType>
Links
SettingsAlignment::SettingsSuperelevationOptions Class, SettingsAlignment::SettingsSuperelevationOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsBuildingSite Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class
SettingsBuildingSite Class
Collapse All

Settings for ViewFrameGroup.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsBuildingSite
        Autodesk::Civil::Land::Settings::SettingsCmdImportBuildingSite
C#
public class SettingsBuildingSite : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsBuildingSite
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsBuildingSite Properties, SettingsBuildingSite Members, Class Hierarchy


SettingsBuildingSite Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Members
SettingsBuildingSite Members
Collapse All

The following tables list the members exposed by SettingsBuildingSite.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name formats for new building sites.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for new building sites.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsBuildingSite Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Properties
SettingsBuildingSite Properties
Collapse All

The properties of SettingsBuildingSite are listed here.

Public Properties
Public Property | Description
NameFormat | Gets the default name formats for new building sites.
Styles | Gets the default styles for new building sites.
Links
Public Properties


SettingsBuildingSite::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Properties > SettingsBuildingSite::NameFormat Property
SettingsBuildingSite::NameFormat Property
Collapse All

Gets the default name formats for new building sites.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsBuildingSite Class, SettingsBuildingSite Members, Autodesk::Civil::Land::Settings Namespace


SettingsBuildingSite::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Properties > SettingsBuildingSite::Styles Property
SettingsBuildingSite::Styles Property
Collapse All

Gets the default styles for new building sites.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsBuildingSite Class, SettingsBuildingSite Members, Autodesk::Civil::Land::Settings Namespace


SettingsBuildingSite::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsNameFormat Class
SettingsBuildingSite::SettingsNameFormat Class
Collapse All

Default name format for new building sites.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsBuildingSite::SettingsNameFormat
C#
public class SettingsBuildingSite::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsBuildingSite::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsBuildingSite::SettingsNameFormat Properties, SettingsBuildingSite::SettingsNameFormat Members, Class Hierarchy


SettingsBuildingSite::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsNameFormat Class > SettingsBuildingSite::SettingsNameFormat Members
SettingsBuildingSite::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsBuildingSite::SettingsNameFormat.

Public Properties
Public Property | Description
BuildingSite | Gets the default name formats for building sites.
Links
Public Properties


SettingsBuildingSite::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsNameFormat Class > SettingsBuildingSite::SettingsNameFormat Properties
SettingsBuildingSite::SettingsNameFormat Properties
Collapse All

The properties of SettingsBuildingSite::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
BuildingSite | Gets the default name formats for building sites.
Links
Public Properties


SettingsBuildingSite::SettingsNameFormat::BuildingSite Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsNameFormat Class > SettingsBuildingSite::SettingsNameFormat Properties > SettingsBuildingSite::SettingsNameFormat::BuildingSite Property
SettingsBuildingSite::SettingsNameFormat::BuildingSite Property
Collapse All

Gets the default name formats for building sites.

C#
public PropertyString BuildingSite;
Visual Basic
Public Property BuildingSite() As PropertyString
Links
SettingsBuildingSite::SettingsNameFormat Class, SettingsBuildingSite::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsBuildingSite::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsStyles Class
SettingsBuildingSite::SettingsStyles Class
Collapse All

Default styles for new building sites.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsBuildingSite::SettingsStyles
C#
public class SettingsBuildingSite::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsBuildingSite::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsBuildingSite::SettingsStyles Properties, SettingsBuildingSite::SettingsStyles Members, Class Hierarchy


SettingsBuildingSite::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsStyles Class > SettingsBuildingSite::SettingsStyles Members
SettingsBuildingSite::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsBuildingSite::SettingsStyles.

Public Properties
Public Property | Description
BuildingSite | Gets the default style for building site.
Links
Public Properties


SettingsBuildingSite::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsStyles Class > SettingsBuildingSite::SettingsStyles Properties
SettingsBuildingSite::SettingsStyles Properties
Collapse All

The properties of SettingsBuildingSite::SettingsStyles are listed here.

Public Properties
Public Property | Description
BuildingSite | Gets the default style for building site.
Links
Public Properties


SettingsBuildingSite::SettingsStyles::BuildingSite Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsStyles Class > SettingsBuildingSite::SettingsStyles Properties > SettingsBuildingSite::SettingsStyles::BuildingSite Property
SettingsBuildingSite::SettingsStyles::BuildingSite Property
Collapse All

Gets the default style for building site.

C#
public PropertyString BuildingSite;
Visual Basic
Public Property BuildingSite() As PropertyString
Links
SettingsBuildingSite::SettingsStyles Class, SettingsBuildingSite::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentCurveTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class
SettingsCmdAddAlignmentCurveTable Class
Collapse All

Settings for AddAlignmentCurveTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentCurveTable
C#
public class SettingsCmdAddAlignmentCurveTable : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignmentCurveTable
Inherits SettingsAlignment
Links
SettingsCmdAddAlignmentCurveTable Properties, SettingsCmdAddAlignmentCurveTable Members, Class Hierarchy


SettingsCmdAddAlignmentCurveTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Members
SettingsCmdAddAlignmentCurveTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddAlignmentCurveTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TableCreation | Gets the default setting of table creation for the command AddAlignmentCurveTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddAlignmentCurveTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Properties
SettingsCmdAddAlignmentCurveTable Properties
Collapse All

The properties of SettingsCmdAddAlignmentCurveTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddAlignmentCurveTable.
Links
Public Properties


SettingsCmdAddAlignmentCurveTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Properties > SettingsCmdAddAlignmentCurveTable::TableCreation Property
SettingsCmdAddAlignmentCurveTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddAlignmentCurveTable.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdAddAlignmentCurveTable Class, SettingsCmdAddAlignmentCurveTable Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class
Collapse All

Settings of table creation for the command AddAlignmentCurveTable.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation
C#
public class SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties, SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::SplitTable Property
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TableStyle Property
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TileDirection Property
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentLineTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class
SettingsCmdAddAlignmentLineTable Class
Collapse All

Settings for AddAlignmentLineTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentLineTable
C#
public class SettingsCmdAddAlignmentLineTable : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignmentLineTable
Inherits SettingsAlignment
Links
SettingsCmdAddAlignmentLineTable Properties, SettingsCmdAddAlignmentLineTable Members, Class Hierarchy


SettingsCmdAddAlignmentLineTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Members
SettingsCmdAddAlignmentLineTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddAlignmentLineTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TableCreation | Gets the default setting of table creation for the command AddAlignmentLineTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddAlignmentLineTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Properties
SettingsCmdAddAlignmentLineTable Properties
Collapse All

The properties of SettingsCmdAddAlignmentLineTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddAlignmentLineTable.
Links
Public Properties


SettingsCmdAddAlignmentLineTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Properties > SettingsCmdAddAlignmentLineTable::TableCreation Property
SettingsCmdAddAlignmentLineTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddAlignmentLineTable.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdAddAlignmentLineTable Class, SettingsCmdAddAlignmentLineTable Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class
Collapse All

Settings of table creation for the command AddAlignmentLineTable.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation
C#
public class SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties, SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::SplitTable Property
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TableStyle Property
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TileDirection Property
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentOffLbl Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentOffLbl Class
SettingsCmdAddAlignmentOffLbl Class
Collapse All

Settings for AddAlignmentOffLbl command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentOffLbl
C#
public class SettingsCmdAddAlignmentOffLbl : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignmentOffLbl
Inherits SettingsAlignment
Links
Class Hierarchy


SettingsCmdAddAlignmentOffXYLbl Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentOffXYLbl Class
SettingsCmdAddAlignmentOffXYLbl Class
Collapse All

Settings for AddAlignmentOffXYLbl command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentOffXYLbl
C#
public class SettingsCmdAddAlignmentOffXYLbl : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignmentOffXYLbl
Inherits SettingsAlignment
Links
Class Hierarchy


SettingsCmdAddAlignmentSegmentTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class
SettingsCmdAddAlignmentSegmentTable Class
Collapse All

Settings for AddAlignmentSegmentTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSegmentTable
C#
public class SettingsCmdAddAlignmentSegmentTable : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignmentSegmentTable
Inherits SettingsAlignment
Links
SettingsCmdAddAlignmentSegmentTable Properties, SettingsCmdAddAlignmentSegmentTable Members, Class Hierarchy


SettingsCmdAddAlignmentSegmentTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Members
SettingsCmdAddAlignmentSegmentTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddAlignmentSegmentTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TableCreation | Gets the default setting of table creation for the command AddAlignmentSegmentTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddAlignmentSegmentTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Properties
SettingsCmdAddAlignmentSegmentTable Properties
Collapse All

The properties of SettingsCmdAddAlignmentSegmentTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddAlignmentSegmentTable.
Links
Public Properties


SettingsCmdAddAlignmentSegmentTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Properties > SettingsCmdAddAlignmentSegmentTable::TableCreation Property
SettingsCmdAddAlignmentSegmentTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddAlignmentSegmentTable.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdAddAlignmentSegmentTable Class, SettingsCmdAddAlignmentSegmentTable Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class
Collapse All

Settings of table creation for the command AddAlignmentSegmentTable.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation
C#
public class SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties, SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::SplitTable Property
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TableStyle Property
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TileDirection Property
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSpiralTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class
SettingsCmdAddAlignmentSpiralTable Class
Collapse All

Settings for AddAlignmentSpiralTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSpiralTable
C#
public class SettingsCmdAddAlignmentSpiralTable : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignmentSpiralTable
Inherits SettingsAlignment
Links
SettingsCmdAddAlignmentSpiralTable Properties, SettingsCmdAddAlignmentSpiralTable Members, Class Hierarchy


SettingsCmdAddAlignmentSpiralTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Members
SettingsCmdAddAlignmentSpiralTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddAlignmentSpiralTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TableCreation | Gets the default setting of table creation for the command AddAlignmentSpiralTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddAlignmentSpiralTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Properties
SettingsCmdAddAlignmentSpiralTable Properties
Collapse All

The properties of SettingsCmdAddAlignmentSpiralTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddAlignmentSpiralTable.
Links
Public Properties


SettingsCmdAddAlignmentSpiralTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Properties > SettingsCmdAddAlignmentSpiralTable::TableCreation Property
SettingsCmdAddAlignmentSpiralTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddAlignmentSpiralTable.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdAddAlignmentSpiralTable Class, SettingsCmdAddAlignmentSpiralTable Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class
Collapse All

Settings of table creation for the command AddAlignmentSpiralTable.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation
C#
public class SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties, SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::SplitTable Property
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TableStyle Property
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TileDirection Property
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class, SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddAlignSegLbl Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignSegLbl Class
SettingsCmdAddAlignSegLbl Class
Collapse All

Settings for AddAlignSegLbl command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignSegLbl
C#
public class SettingsCmdAddAlignSegLbl : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignSegLbl
Inherits SettingsAlignment
Links
Class Hierarchy


SettingsCmdAddAlignSegLbls Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignSegLbls Class
SettingsCmdAddAlignSegLbls Class
Collapse All

Settings for AddAlignSegLbls command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignSegLbls
C#
public class SettingsCmdAddAlignSegLbls : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignSegLbls
Inherits SettingsAlignment
Links
Class Hierarchy


SettingsCmdAddAlignTagentLbl Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignTagentLbl Class
SettingsCmdAddAlignTagentLbl Class
Collapse All

Settings for AddAlignTagentLbl command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignTagentLbl
C#
public class SettingsCmdAddAlignTagentLbl : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignTagentLbl
Inherits SettingsAlignment
Links
Class Hierarchy


SettingsCmdAddAlignTagentLbls Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignTagentLbls Class
SettingsCmdAddAlignTagentLbls Class
Collapse All

Settings for AddAlignTagentLbls command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignTagentLbls
C#
public class SettingsCmdAddAlignTagentLbls : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddAlignTagentLbls
Inherits SettingsAlignment
Links
Class Hierarchy


SettingsCmdAddContourLabeling Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabeling Class
SettingsCmdAddContourLabeling Class
Collapse All

Settings for AddContourLabeling command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabeling
C#
public class SettingsCmdAddContourLabeling : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddContourLabeling
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdAddContourLabelingGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class
SettingsCmdAddContourLabelingGroup Class
Collapse All

Settings for AddContourLabelingGroup command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingGroup
C#
public class SettingsCmdAddContourLabelingGroup : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddContourLabelingGroup
Inherits SettingsSurface
Links
SettingsCmdAddContourLabelingGroup Properties, SettingsCmdAddContourLabelingGroup Members, Class Hierarchy


SettingsCmdAddContourLabelingGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Members
SettingsCmdAddContourLabelingGroup Members
Collapse All

The following tables list the members exposed by SettingsCmdAddContourLabelingGroup.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
AddContourLabeling | Gets the defaults assigned to surface labels.
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddContourLabelingGroup Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Properties
SettingsCmdAddContourLabelingGroup Properties
Collapse All

The properties of SettingsCmdAddContourLabelingGroup are listed here.

Public Properties
Public Property | Description
AddContourLabeling | Gets the defaults assigned to surface labels.
Links
Public Properties


SettingsCmdAddContourLabelingGroup::AddContourLabeling Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Properties > SettingsCmdAddContourLabelingGroup::AddContourLabeling Property
SettingsCmdAddContourLabelingGroup::AddContourLabeling Property
Collapse All

Gets the defaults assigned to surface labels.

C#
public SettingsCmdAddContourLabeling AddContourLabeling;
Visual Basic
Public Property AddContourLabeling() As SettingsCmdAddContourLabeling
Links
SettingsCmdAddContourLabelingGroup Class, SettingsCmdAddContourLabelingGroup Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class
Collapse All

Settings that specify the defaults assigned to surface labels.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling
C#
public class SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling
Inherits TreeOidWrapper
Links
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties, SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members, Class Hierarchy


SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members
Collapse All

The following tables list the members exposed by SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling.

Public Properties
Public Property | Description
IntervalAlongContour | Gets the Interval Along Contour.
Links
Public Properties


SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties
Collapse All

The properties of SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling are listed here.

Public Properties
Public Property | Description
IntervalAlongContour | Gets the Interval Along Contour.
Links
Public Properties


SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling::IntervalAlongContour Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling::IntervalAlongContour Property
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling::IntervalAlongContour Property
Collapse All

Gets the Interval Along Contour.

C#
public PropertyDouble IntervalAlongContour;
Visual Basic
Public Property IntervalAlongContour() As PropertyDouble
Links
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class, SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddContourLabelingSingle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingSingle Class
SettingsCmdAddContourLabelingSingle Class
Collapse All

Settings for AddContourLabelingSingle command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingSingle
C#
public class SettingsCmdAddContourLabelingSingle : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddContourLabelingSingle
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdAddParcelAreaLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelAreaLabel Class
SettingsCmdAddParcelAreaLabel Class
Collapse All

Settings for AddParcelAreaLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelAreaLabel
C#
public class SettingsCmdAddParcelAreaLabel : SettingsParcel;
Visual Basic
Public Class SettingsCmdAddParcelAreaLabel
Inherits SettingsParcel
Links
Class Hierarchy


SettingsCmdAddParcelCurveTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class
SettingsCmdAddParcelCurveTable Class
Collapse All

Settings for AddParcelCurveTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelCurveTable
C#
public class SettingsCmdAddParcelCurveTable : SettingsParcel;
Visual Basic
Public Class SettingsCmdAddParcelCurveTable
Inherits SettingsParcel
Links
SettingsCmdAddParcelCurveTable Properties, SettingsCmdAddParcelCurveTable Members, Class Hierarchy


SettingsCmdAddParcelCurveTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Members
SettingsCmdAddParcelCurveTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelCurveTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TableCreation | Gets the default setting of table creation for the command AddParcelCurveTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddParcelCurveTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Properties
SettingsCmdAddParcelCurveTable Properties
Collapse All

The properties of SettingsCmdAddParcelCurveTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddParcelCurveTable.
Links
Public Properties


SettingsCmdAddParcelCurveTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Properties > SettingsCmdAddParcelCurveTable::TableCreation Property
SettingsCmdAddParcelCurveTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddParcelCurveTable.

C#
public SettinsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettinsCmdTableCreation
Links
SettingsCmdAddParcelCurveTable Class, SettingsCmdAddParcelCurveTable Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class
Collapse All

Settings of table creation for the command AddParcelCurveTable.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation
C#
public class SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties, SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::SplitTable Property
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TableSpacing Property
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TableStyle Property
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TileDirection Property
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelLineLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineLabel Class
SettingsCmdAddParcelLineLabel Class
Collapse All

Settings for AddParcelLineLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineLabel
C#
public class SettingsCmdAddParcelLineLabel : SettingsParcel;
Visual Basic
Public Class SettingsCmdAddParcelLineLabel
Inherits SettingsParcel
Links
Class Hierarchy


SettingsCmdAddParcelLineTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class
SettingsCmdAddParcelLineTable Class
Collapse All

Settings for AddParcelLineTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineTable
C#
public class SettingsCmdAddParcelLineTable : SettingsParcel;
Visual Basic
Public Class SettingsCmdAddParcelLineTable
Inherits SettingsParcel
Links
SettingsCmdAddParcelLineTable Properties, SettingsCmdAddParcelLineTable Members, Class Hierarchy


SettingsCmdAddParcelLineTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Members
SettingsCmdAddParcelLineTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelLineTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TableCreation | Gets the default setting of table creation for the command AddParcelLineTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddParcelLineTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Properties
SettingsCmdAddParcelLineTable Properties
Collapse All

The properties of SettingsCmdAddParcelLineTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddParcelLineTable.
Links
Public Properties


SettingsCmdAddParcelLineTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Properties > SettingsCmdAddParcelLineTable::TableCreation Property
SettingsCmdAddParcelLineTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddParcelLineTable.

C#
public SettinsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettinsCmdTableCreation
Links
SettingsCmdAddParcelLineTable Class, SettingsCmdAddParcelLineTable Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class
Collapse All

Settings of table creation for the command AddParcelLineTable.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineTable::SettinsCmdTableCreation
C#
public class SettingsCmdAddParcelLineTable::SettinsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddParcelLineTable::SettinsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties, SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelLineTable::SettinsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddParcelLineTable::SettinsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::SplitTable Property
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TableSpacing Property
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TableStyle Property
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TileDirection Property
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelSegmentLabels Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class
SettingsCmdAddParcelSegmentLabels Class
Collapse All

Settings for AddParcelSegmentLabels command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentLabels
C#
public class SettingsCmdAddParcelSegmentLabels : SettingsParcel;
Visual Basic
Public Class SettingsCmdAddParcelSegmentLabels
Inherits SettingsParcel
Links
SettingsCmdAddParcelSegmentLabels Properties, SettingsCmdAddParcelSegmentLabels Members, Class Hierarchy


SettingsCmdAddParcelSegmentLabels Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Members
SettingsCmdAddParcelSegmentLabels Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelSegmentLabels.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Options | Gets the default setting of Options.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddParcelSegmentLabels Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Properties
SettingsCmdAddParcelSegmentLabels Properties
Collapse All

The properties of SettingsCmdAddParcelSegmentLabels are listed here.

Public Properties
Public Property | Description
Options | Gets the default setting of Options.
Links
Public Properties


SettingsCmdAddParcelSegmentLabels::Options Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Properties > SettingsCmdAddParcelSegmentLabels::Options Property
SettingsCmdAddParcelSegmentLabels::Options Property
Collapse All

Gets the default setting of Options.

C#
public SettingsCmdOptions Options;
Visual Basic
Public Property Options() As SettingsCmdOptions
Links
SettingsCmdAddParcelSegmentLabels Class, SettingsCmdAddParcelSegmentLabels Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class
Collapse All

Settings that specify defaults for creating labels with parcel segments.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions
C#
public class SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions
Inherits TreeOidWrapper
Links
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties, SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members, Class Hierarchy


SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions.

Public Properties
Public Property | Description
LabelingDirection | Gets the default parcel segment labeling direction .
Links
Public Properties


SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties
Collapse All

The properties of SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions are listed here.

Public Properties
Public Property | Description
LabelingDirection | Gets the default parcel segment labeling direction .
Links
Public Properties


SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions::LabelingDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions::LabelingDirection Property
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions::LabelingDirection Property
Collapse All

Gets the default parcel segment labeling direction .

C#
public PropertyEnum<Autodesk::Civil::RotationDirType> LabelingDirection;
Visual Basic
Public Property LabelingDirection() As PropertyEnum<Autodesk::Civil::RotationDirType>
Links
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class, SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelSegmentTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class
SettingsCmdAddParcelSegmentTable Class
Collapse All

Settings for AddParcelSegmentTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentTable
C#
public class SettingsCmdAddParcelSegmentTable : SettingsParcel;
Visual Basic
Public Class SettingsCmdAddParcelSegmentTable
Inherits SettingsParcel
Links
SettingsCmdAddParcelSegmentTable Properties, SettingsCmdAddParcelSegmentTable Members, Class Hierarchy


SettingsCmdAddParcelSegmentTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Members
SettingsCmdAddParcelSegmentTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelSegmentTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TableCreation | Gets the default setting of table creation for the command AddParcelSegmentTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddParcelSegmentTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Properties
SettingsCmdAddParcelSegmentTable Properties
Collapse All

The properties of SettingsCmdAddParcelSegmentTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddParcelSegmentTable.
Links
Public Properties


SettingsCmdAddParcelSegmentTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Properties > SettingsCmdAddParcelSegmentTable::TableCreation Property
SettingsCmdAddParcelSegmentTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddParcelSegmentTable.

C#
public SettinsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettinsCmdTableCreation
Links
SettingsCmdAddParcelSegmentTable Class, SettingsCmdAddParcelSegmentTable Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class
Collapse All

Settings of table creation for the command AddParcelSegmentTable.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation
C#
public class SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties, SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::SplitTable Property
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TableSpacing Property
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TableStyle Property
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TileDirection Property
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class
SettingsCmdAddParcelTable Class
Collapse All

Settings for AddParcelTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelTable
C#
public class SettingsCmdAddParcelTable : SettingsParcel;
Visual Basic
Public Class SettingsCmdAddParcelTable
Inherits SettingsParcel
Links
SettingsCmdAddParcelTable Properties, SettingsCmdAddParcelTable Members, Class Hierarchy


SettingsCmdAddParcelTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Members
SettingsCmdAddParcelTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TableCreation | Gets the default setting of table creation for the command AddParcelTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddParcelTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Properties
SettingsCmdAddParcelTable Properties
Collapse All

The properties of SettingsCmdAddParcelTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddParcelTable.
Links
Public Properties


SettingsCmdAddParcelTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Properties > SettingsCmdAddParcelTable::TableCreation Property
SettingsCmdAddParcelTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddParcelTable.

C#
public SettinsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettinsCmdTableCreation
Links
SettingsCmdAddParcelTable Class, SettingsCmdAddParcelTable Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelTable::SettinsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class
SettingsCmdAddParcelTable::SettinsCmdTableCreation Class
Collapse All

Settings of table creation for the command AddParcelTable.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelTable::SettinsCmdTableCreation
C#
public class SettingsCmdAddParcelTable::SettinsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddParcelTable::SettinsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties, SettingsCmdAddParcelTable::SettinsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddParcelTable::SettinsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Members
SettingsCmdAddParcelTable::SettinsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddParcelTable::SettinsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties
SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddParcelTable::SettinsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddParcelTable::SettinsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddParcelTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddParcelTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelTable::SettinsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddParcelTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddParcelTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelTable::SettinsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelTable::SettinsCmdTableCreation::SplitTable Property
SettingsCmdAddParcelTable::SettinsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddParcelTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelTable::SettinsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelTable::SettinsCmdTableCreation::TableSpacing Property
SettingsCmdAddParcelTable::SettinsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddParcelTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelTable::SettinsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelTable::SettinsCmdTableCreation::TableStyle Property
SettingsCmdAddParcelTable::SettinsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddParcelTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddParcelTable::SettinsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties > SettingsCmdAddParcelTable::SettinsCmdTableCreation::TileDirection Property
SettingsCmdAddParcelTable::SettinsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddParcelTable::SettinsCmdTableCreation Class, SettingsCmdAddParcelTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddPointTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class
SettingsCmdAddPointTable Class
Collapse All

Settings for AddPointTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdAddPointTable
C#
public class SettingsCmdAddPointTable : SettingsPoint;
Visual Basic
Public Class SettingsCmdAddPointTable
Inherits SettingsPoint
Links
SettingsCmdAddPointTable Properties, SettingsCmdAddPointTable Members, Class Hierarchy


SettingsCmdAddPointTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Members
SettingsCmdAddPointTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddPointTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new points and point groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to points and points labels.
TableCreation | Gets the default setting of table creation for the command AddPointTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UpdatePoints | Gets whether you can change local copies of project points without checking them out.
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddPointTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Properties
SettingsCmdAddPointTable Properties
Collapse All

The properties of SettingsCmdAddPointTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddPointTable.
Links
Public Properties


SettingsCmdAddPointTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Properties > SettingsCmdAddPointTable::TableCreation Property
SettingsCmdAddPointTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddPointTable.

C#
public SettinsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettinsCmdTableCreation
Links
SettingsCmdAddPointTable Class, SettingsCmdAddPointTable Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddPointTable::SettinsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class
SettingsCmdAddPointTable::SettinsCmdTableCreation Class
Collapse All

Settings of table creation for the command AddPointTable.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddPointTable::SettinsCmdTableCreation
C#
public class SettingsCmdAddPointTable::SettinsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddPointTable::SettinsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddPointTable::SettinsCmdTableCreation Properties, SettingsCmdAddPointTable::SettinsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddPointTable::SettinsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Members
SettingsCmdAddPointTable::SettinsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddPointTable::SettinsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddPointTable::SettinsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Properties
SettingsCmdAddPointTable::SettinsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddPointTable::SettinsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddPointTable::SettinsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Properties > SettingsCmdAddPointTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddPointTable::SettinsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddPointTable::SettinsCmdTableCreation Class, SettingsCmdAddPointTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddPointTable::SettinsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Properties > SettingsCmdAddPointTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddPointTable::SettinsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddPointTable::SettinsCmdTableCreation Class, SettingsCmdAddPointTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddPointTable::SettinsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Properties > SettingsCmdAddPointTable::SettinsCmdTableCreation::SplitTable Property
SettingsCmdAddPointTable::SettinsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddPointTable::SettinsCmdTableCreation Class, SettingsCmdAddPointTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddPointTable::SettinsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Properties > SettingsCmdAddPointTable::SettinsCmdTableCreation::TableSpacing Property
SettingsCmdAddPointTable::SettinsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddPointTable::SettinsCmdTableCreation Class, SettingsCmdAddPointTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddPointTable::SettinsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Properties > SettingsCmdAddPointTable::SettinsCmdTableCreation::TableStyle Property
SettingsCmdAddPointTable::SettinsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddPointTable::SettinsCmdTableCreation Class, SettingsCmdAddPointTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddPointTable::SettinsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Properties > SettingsCmdAddPointTable::SettinsCmdTableCreation::TileDirection Property
SettingsCmdAddPointTable::SettinsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddPointTable::SettinsCmdTableCreation Class, SettingsCmdAddPointTable::SettinsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddProfileViewDepthLbl Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddProfileViewDepthLbl Class
SettingsCmdAddProfileViewDepthLbl Class
Collapse All

Settings for AddProfileViewDepthLbl command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdAddProfileViewDepthLbl
C#
public class SettingsCmdAddProfileViewDepthLbl : SettingsProfileView;
Visual Basic
Public Class SettingsCmdAddProfileViewDepthLbl
Inherits SettingsProfileView
Links
Class Hierarchy


SettingsCmdAddProfileViewStaElevLbl Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddProfileViewStaElevLbl Class
SettingsCmdAddProfileViewStaElevLbl Class
Collapse All

Settings for AddProfileViewStaElevLbl command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdAddProfileViewStaElevLbl
C#
public class SettingsCmdAddProfileViewStaElevLbl : SettingsProfileView;
Visual Basic
Public Class SettingsCmdAddProfileViewStaElevLbl
Inherits SettingsProfileView
Links
Class Hierarchy


SettingsCmdAddSectionViewGradeLbl Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSectionViewGradeLbl Class
SettingsCmdAddSectionViewGradeLbl Class
Collapse All

Settings for AddSectionViewGradeLbl command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdAddSectionViewGradeLbl
C#
public class SettingsCmdAddSectionViewGradeLbl : SettingsSectionView;
Visual Basic
Public Class SettingsCmdAddSectionViewGradeLbl
Inherits SettingsSectionView
Links
Class Hierarchy


SettingsCmdAddSectionViewOffElevLbl Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSectionViewOffElevLbl Class
SettingsCmdAddSectionViewOffElevLbl Class
Collapse All

Settings for AddSectionViewOffElevLbl command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdAddSectionViewOffElevLbl
C#
public class SettingsCmdAddSectionViewOffElevLbl : SettingsSectionView;
Visual Basic
Public Class SettingsCmdAddSectionViewOffElevLbl
Inherits SettingsSectionView
Links
Class Hierarchy


SettingsCmdAddSpotElevLabelsOnGrid Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSpotElevLabelsOnGrid Class
SettingsCmdAddSpotElevLabelsOnGrid Class
Collapse All

Settings for AddSpotElevLabelsOnGrid command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSpotElevLabelsOnGrid
C#
public class SettingsCmdAddSpotElevLabelsOnGrid : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddSpotElevLabelsOnGrid
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdAddSurfaceBoundaries Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class
SettingsCmdAddSurfaceBoundaries Class
Collapse All

Settings for AddSurfaceBoundaries command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBoundaries
C#
public class SettingsCmdAddSurfaceBoundaries : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddSurfaceBoundaries
Inherits SettingsSurface
Links
SettingsCmdAddSurfaceBoundaries Properties, SettingsCmdAddSurfaceBoundaries Members, Class Hierarchy


SettingsCmdAddSurfaceBoundaries Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Members
SettingsCmdAddSurfaceBoundaries Members
Collapse All

The following tables list the members exposed by SettingsCmdAddSurfaceBoundaries.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
DataOptions | Gets the default setting of adding data options for the command AddSurfaceBoundaries.
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddSurfaceBoundaries Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Properties
SettingsCmdAddSurfaceBoundaries Properties
Collapse All

The properties of SettingsCmdAddSurfaceBoundaries are listed here.

Public Properties
Public Property | Description
DataOptions | Gets the default setting of adding data options for the command AddSurfaceBoundaries.
Links
Public Properties


SettingsCmdAddSurfaceBoundaries::DataOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Properties > SettingsCmdAddSurfaceBoundaries::DataOptions Property
SettingsCmdAddSurfaceBoundaries::DataOptions Property
Collapse All

Gets the default setting of adding data options for the command AddSurfaceBoundaries.

C#
public SettingsCmdAddDataOptions DataOptions;
Visual Basic
Public Property DataOptions() As SettingsCmdAddDataOptions
Links
SettingsCmdAddSurfaceBoundaries Class, SettingsCmdAddSurfaceBoundaries Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class
Collapse All

Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions
C#
public class SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions
Inherits TreeOidWrapper
Links
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties, SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members, Class Hierarchy


SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions.

Public Properties
Public Property | Description
BoundaryType | Gets the default boundary type.
MidOrdinateDistance | Gets the default mid-ordinate distance.
NonDestructive | Gets a PropertyBoolean value that specifies the default selection of a type of breakline (destructive of non-destructive).
Links
Public Properties


SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties
Collapse All

The properties of SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions are listed here.

Public Properties
Public Property | Description
BoundaryType | Gets the default boundary type.
MidOrdinateDistance | Gets the default mid-ordinate distance.
NonDestructive | Gets a PropertyBoolean value that specifies the default selection of a type of breakline (destructive of non-destructive).
Links
Public Properties


SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::BoundaryType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::BoundaryType Property
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::BoundaryType Property
Collapse All

Gets the default boundary type.

C#
public PropertyEnum<Autodesk::Civil::Land::SurfaceBoundaryType> BoundaryType;
Visual Basic
Public Property BoundaryType() As PropertyEnum<Autodesk::Civil::Land::SurfaceBoundaryType>
Links
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class, SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::MidOrdinateDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::MidOrdinateDistance Property
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::MidOrdinateDistance Property
Collapse All

Gets the default mid-ordinate distance.

C#
public PropertyDouble MidOrdinateDistance;
Visual Basic
Public Property MidOrdinateDistance() As PropertyDouble
Links
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class, SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::NonDestructive Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::NonDestructive Property
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::NonDestructive Property
Collapse All

Gets a PropertyBoolean value that specifies the default selection of a type of breakline (destructive of non-destructive).

C#
public PropertyBoolean NonDestructive;
Visual Basic
Public Property NonDestructive() As PropertyBoolean
Links
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class, SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceBreaklines Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class
SettingsCmdAddSurfaceBreaklines Class
Collapse All

Settings for AddSurfaceBreaklines command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBreaklines
C#
public class SettingsCmdAddSurfaceBreaklines : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddSurfaceBreaklines
Inherits SettingsSurface
Links
SettingsCmdAddSurfaceBreaklines Properties, SettingsCmdAddSurfaceBreaklines Members, Class Hierarchy


SettingsCmdAddSurfaceBreaklines Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Members
SettingsCmdAddSurfaceBreaklines Members
Collapse All

The following tables list the members exposed by SettingsCmdAddSurfaceBreaklines.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
DataOptions | Gets the default setting of adding data options for the command AddSurfaceBreaklines.
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddSurfaceBreaklines Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Properties
SettingsCmdAddSurfaceBreaklines Properties
Collapse All

The properties of SettingsCmdAddSurfaceBreaklines are listed here.

Public Properties
Public Property | Description
DataOptions | Gets the default setting of adding data options for the command AddSurfaceBreaklines.
Links
Public Properties


SettingsCmdAddSurfaceBreaklines::DataOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Properties > SettingsCmdAddSurfaceBreaklines::DataOptions Property
SettingsCmdAddSurfaceBreaklines::DataOptions Property
Collapse All

Gets the default setting of adding data options for the command AddSurfaceBreaklines.

C#
public SettingsCmdAddDataOptions DataOptions;
Visual Basic
Public Property DataOptions() As SettingsCmdAddDataOptions
Links
SettingsCmdAddSurfaceBreaklines Class, SettingsCmdAddSurfaceBreaklines Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceContours Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class
SettingsCmdAddSurfaceContours Class
Collapse All

Settings for AddSurfaceContours command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceContours
C#
public class SettingsCmdAddSurfaceContours : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddSurfaceContours
Inherits SettingsSurface
Links
SettingsCmdAddSurfaceContours Properties, SettingsCmdAddSurfaceContours Members, Class Hierarchy


SettingsCmdAddSurfaceContours Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Members
SettingsCmdAddSurfaceContours Members
Collapse All

The following tables list the members exposed by SettingsCmdAddSurfaceContours.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
AddDataOptions | Gets the defaults assigned when adding contours, boundaries, and breaklines to a surface.
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddSurfaceContours Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Properties
SettingsCmdAddSurfaceContours Properties
Collapse All

The properties of SettingsCmdAddSurfaceContours are listed here.

Public Properties
Public Property | Description
AddDataOptions | Gets the defaults assigned when adding contours, boundaries, and breaklines to a surface.
Links
Public Properties


SettingsCmdAddSurfaceContours::AddDataOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Properties > SettingsCmdAddSurfaceContours::AddDataOptions Property
SettingsCmdAddSurfaceContours::AddDataOptions Property
Collapse All

Gets the defaults assigned when adding contours, boundaries, and breaklines to a surface.

C#
public SettingsCmdAddDataOptions AddDataOptions;
Visual Basic
Public Property AddDataOptions() As SettingsCmdAddDataOptions
Links
SettingsCmdAddSurfaceContours Class, SettingsCmdAddSurfaceContours Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class
Collapse All

Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions
C#
public class SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions
Inherits TreeOidWrapper
Links
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties, SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members, Class Hierarchy


SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions.

Public Properties
Public Property | Description
MidOrdinateDistance | Gets the default mid-ordinate distance.
SupplementingDistance | Gets the default supplementing distance.
WeedingAngle | Gets the default weeding angle.
WeedingDistance | Gets the default weeding distance.
Links
Public Properties


SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties
Collapse All

The properties of SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions are listed here.

Public Properties
Public Property | Description
MidOrdinateDistance | Gets the default mid-ordinate distance.
SupplementingDistance | Gets the default supplementing distance.
WeedingAngle | Gets the default weeding angle.
WeedingDistance | Gets the default weeding distance.
Links
Public Properties


SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::MidOrdinateDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::MidOrdinateDistance Property
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::MidOrdinateDistance Property
Collapse All

Gets the default mid-ordinate distance.

C#
public PropertyDouble MidOrdinateDistance;
Visual Basic
Public Property MidOrdinateDistance() As PropertyDouble
Links
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class, SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::SupplementingDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::SupplementingDistance Property
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::SupplementingDistance Property
Collapse All

Gets the default supplementing distance.

C#
public PropertyDouble SupplementingDistance;
Visual Basic
Public Property SupplementingDistance() As PropertyDouble
Links
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class, SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::WeedingAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::WeedingAngle Property
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::WeedingAngle Property
Collapse All

Gets the default weeding angle.

C#
public PropertyDouble WeedingAngle;
Visual Basic
Public Property WeedingAngle() As PropertyDouble
Links
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class, SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::WeedingDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::WeedingDistance Property
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::WeedingDistance Property
Collapse All

Gets the default weeding distance.

C#
public PropertyDouble WeedingDistance;
Visual Basic
Public Property WeedingDistance() As PropertyDouble
Links
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class, SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceDemFile Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class
SettingsCmdAddSurfaceDemFile Class
Collapse All

Settings for AddSurfaceDemFile command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDemFile
C#
public class SettingsCmdAddSurfaceDemFile : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddSurfaceDemFile
Inherits SettingsSurface
Links
SettingsCmdAddSurfaceDemFile Properties, SettingsCmdAddSurfaceDemFile Members, Class Hierarchy


SettingsCmdAddSurfaceDemFile Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Members
SettingsCmdAddSurfaceDemFile Members
Collapse All

The following tables list the members exposed by SettingsCmdAddSurfaceDemFile.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
ImportOptions | Gets the defaults assigned when creating surfaces.
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddSurfaceDemFile Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Properties
SettingsCmdAddSurfaceDemFile Properties
Collapse All

The properties of SettingsCmdAddSurfaceDemFile are listed here.

Public Properties
Public Property | Description
ImportOptions | Gets the defaults assigned when creating surfaces.
Links
Public Properties


SettingsCmdAddSurfaceDemFile::ImportOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Properties > SettingsCmdAddSurfaceDemFile::ImportOptions Property
SettingsCmdAddSurfaceDemFile::ImportOptions Property
Collapse All

Gets the defaults assigned when creating surfaces.

C#
public SettingsCmdImportOptions ImportOptions;
Visual Basic
Public Property ImportOptions() As SettingsCmdImportOptions
Links
SettingsCmdAddSurfaceDemFile Class, SettingsCmdAddSurfaceDemFile Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class
Collapse All

Settings that specify the defaults assigned when creating surfaces.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions
C#
public class SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions
Inherits TreeOidWrapper
Links
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties, SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members, Class Hierarchy


SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions.

Public Properties
Public Property | Description
NullElevation | Gets null elevation.
UseCustomNullElevation | Gets whether use custom null elevation.
Links
Public Properties


SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties
Collapse All

The properties of SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions are listed here.

Public Properties
Public Property | Description
NullElevation | Gets null elevation.
UseCustomNullElevation | Gets whether use custom null elevation.
Links
Public Properties


SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions::NullElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions::NullElevation Property
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions::NullElevation Property
Collapse All

Gets null elevation.

C#
public PropertyDouble NullElevation;
Visual Basic
Public Property NullElevation() As PropertyDouble
Links
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class, SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions::UseCustomNullElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions::UseCustomNullElevation Property
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions::UseCustomNullElevation Property
Collapse All

Gets whether use custom null elevation.

C#
public PropertyBoolean UseCustomNullElevation;
Visual Basic
Public Property UseCustomNullElevation() As PropertyBoolean
Links
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class, SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceDrawingObjects Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class
SettingsCmdAddSurfaceDrawingObjects Class
Collapse All

Settings for AddSurfaceDrawingObjects command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDrawingObjects
C#
public class SettingsCmdAddSurfaceDrawingObjects : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddSurfaceDrawingObjects
Inherits SettingsSurface
Links
SettingsCmdAddSurfaceDrawingObjects Properties, SettingsCmdAddSurfaceDrawingObjects Members, Class Hierarchy


SettingsCmdAddSurfaceDrawingObjects Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Members
SettingsCmdAddSurfaceDrawingObjects Members
Collapse All

The following tables list the members exposed by SettingsCmdAddSurfaceDrawingObjects.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
DataOptions | Gets the default setting of adding data options for the command AddSurfaceDrawingObjects.
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddSurfaceDrawingObjects Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Properties
SettingsCmdAddSurfaceDrawingObjects Properties
Collapse All

The properties of SettingsCmdAddSurfaceDrawingObjects are listed here.

Public Properties
Public Property | Description
DataOptions | Gets the default setting of adding data options for the command AddSurfaceDrawingObjects.
Links
Public Properties


SettingsCmdAddSurfaceDrawingObjects::DataOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Properties > SettingsCmdAddSurfaceDrawingObjects::DataOptions Property
SettingsCmdAddSurfaceDrawingObjects::DataOptions Property
Collapse All

Gets the default setting of adding data options for the command AddSurfaceDrawingObjects.

C#
public SettingsCmdAddDataOptions DataOptions;
Visual Basic
Public Property DataOptions() As SettingsCmdAddDataOptions
Links
SettingsCmdAddSurfaceDrawingObjects Class, SettingsCmdAddSurfaceDrawingObjects Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddSurfaceSlopeLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceSlopeLabel Class
SettingsCmdAddSurfaceSlopeLabel Class
Collapse All

Settings for AddSurfaceSlopeLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceSlopeLabel
C#
public class SettingsCmdAddSurfaceSlopeLabel : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddSurfaceSlopeLabel
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdAddSurfaceSpotElevLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceSpotElevLabel Class
SettingsCmdAddSurfaceSpotElevLabel Class
Collapse All

Settings for AddSurfaceSpotElevLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceSpotElevLabel
C#
public class SettingsCmdAddSurfaceSpotElevLabel : SettingsSurface;
Visual Basic
Public Class SettingsCmdAddSurfaceSpotElevLabel
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdAddWidening Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class
SettingsCmdAddWidening Class
Collapse All

Settings for AddWidening command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddWidening
C#
public class SettingsCmdAddWidening : SettingsAlignment;
Visual Basic
Public Class SettingsCmdAddWidening
Inherits SettingsAlignment
Links
SettingsCmdAddWidening Properties, SettingsCmdAddWidening Members, Class Hierarchy


SettingsCmdAddWidening Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Members
SettingsCmdAddWidening Members
Collapse All

The following tables list the members exposed by SettingsCmdAddWidening.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
WideningOptions | Gets the widening options settings.
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddWidening Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Properties
SettingsCmdAddWidening Properties
Collapse All

The properties of SettingsCmdAddWidening are listed here.

Public Properties
Public Property | Description
WideningOptions | Gets the widening options settings.
Links
Public Properties


SettingsCmdAddWidening::WideningOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Properties > SettingsCmdAddWidening::WideningOptions Property
SettingsCmdAddWidening::WideningOptions Property
Collapse All

Gets the widening options settings.

C#
public SettingsCmdWideningOptions WideningOptions;
Visual Basic
Public Property WideningOptions() As SettingsCmdWideningOptions
Links
SettingsCmdAddWidening Class, SettingsCmdAddWidening Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddWidening::SettingsCmdWideningOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class
SettingsCmdAddWidening::SettingsCmdWideningOptions Class
Collapse All

Settings for the alignment widening options.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddWidening::SettingsCmdWideningOptions
C#
public class SettingsCmdAddWidening::SettingsCmdWideningOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddWidening::SettingsCmdWideningOptions
Inherits TreeOidWrapper
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Properties, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Class Hierarchy


SettingsCmdAddWidening::SettingsCmdWideningOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Members
SettingsCmdAddWidening::SettingsCmdWideningOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdAddWidening::SettingsCmdWideningOptions.

Public Properties
Public Property | Description
RadiusForCurve1 | Specifies the RadiusForCurve1 for alignment widening options.
RadiusForCurve2 | Specifies the RadiusForCurve2 for alignment widening options.
RadiusForCurve3 | Specifies the RadiusForCurve3 for alignment widening options.
TaperInputType | Specifies the TaperInputType for alignment widening options.
TaperRatio | Specifies the TaperRatio for alignment widening options.
TransitionLength | Specifies the TransitionLength for alignment widening options.
TransitionType | Specifies the TransitionType for alignment widening options.
WideningOffset | Specifies the WideningOffset for alignment widening options.
WideningSegmentLength | Specifies the WideningSegmentLength for alignment widening options.
Links
Public Properties


SettingsCmdAddWidening::SettingsCmdWideningOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties
SettingsCmdAddWidening::SettingsCmdWideningOptions Properties
Collapse All

The properties of SettingsCmdAddWidening::SettingsCmdWideningOptions are listed here.

Public Properties
Public Property | Description
RadiusForCurve1 | Specifies the RadiusForCurve1 for alignment widening options.
RadiusForCurve2 | Specifies the RadiusForCurve2 for alignment widening options.
RadiusForCurve3 | Specifies the RadiusForCurve3 for alignment widening options.
TaperInputType | Specifies the TaperInputType for alignment widening options.
TaperRatio | Specifies the TaperRatio for alignment widening options.
TransitionLength | Specifies the TransitionLength for alignment widening options.
TransitionType | Specifies the TransitionType for alignment widening options.
WideningOffset | Specifies the WideningOffset for alignment widening options.
WideningSegmentLength | Specifies the WideningSegmentLength for alignment widening options.
Links
Public Properties


SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties > SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve1 Property
SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve1 Property
Collapse All

Specifies the RadiusForCurve1 for alignment widening options.

C#
public PropertyDouble RadiusForCurve1;
Visual Basic
Public Property RadiusForCurve1() As PropertyDouble
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Class, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties > SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve2 Property
SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve2 Property
Collapse All

Specifies the RadiusForCurve2 for alignment widening options.

C#
public PropertyDouble RadiusForCurve2;
Visual Basic
Public Property RadiusForCurve2() As PropertyDouble
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Class, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve3 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties > SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve3 Property
SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve3 Property
Collapse All

Specifies the RadiusForCurve3 for alignment widening options.

C#
public PropertyDouble RadiusForCurve3;
Visual Basic
Public Property RadiusForCurve3() As PropertyDouble
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Class, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddWidening::SettingsCmdWideningOptions::TaperInputType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties > SettingsCmdAddWidening::SettingsCmdWideningOptions::TaperInputType Property
SettingsCmdAddWidening::SettingsCmdWideningOptions::TaperInputType Property
Collapse All

Specifies the TaperInputType for alignment widening options.

C#
public PropertyEnum<Autodesk::Civil::TransitionInputType> TaperInputType;
Visual Basic
Public Property TaperInputType() As PropertyEnum<Autodesk::Civil::TransitionInputType>
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Class, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddWidening::SettingsCmdWideningOptions::TaperRatio Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties > SettingsCmdAddWidening::SettingsCmdWideningOptions::TaperRatio Property
SettingsCmdAddWidening::SettingsCmdWideningOptions::TaperRatio Property
Collapse All

Specifies the TaperRatio for alignment widening options.

C#
public PropertyDouble TaperRatio;
Visual Basic
Public Property TaperRatio() As PropertyDouble
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Class, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddWidening::SettingsCmdWideningOptions::TransitionLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties > SettingsCmdAddWidening::SettingsCmdWideningOptions::TransitionLength Property
SettingsCmdAddWidening::SettingsCmdWideningOptions::TransitionLength Property
Collapse All

Specifies the TransitionLength for alignment widening options.

C#
public PropertyDouble TransitionLength;
Visual Basic
Public Property TransitionLength() As PropertyDouble
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Class, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddWidening::SettingsCmdWideningOptions::TransitionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties > SettingsCmdAddWidening::SettingsCmdWideningOptions::TransitionType Property
SettingsCmdAddWidening::SettingsCmdWideningOptions::TransitionType Property
Collapse All

Specifies the TransitionType for alignment widening options.

C#
public PropertyEnum<Autodesk::Civil::TransitionType> TransitionType;
Visual Basic
Public Property TransitionType() As PropertyEnum<Autodesk::Civil::TransitionType>
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Class, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddWidening::SettingsCmdWideningOptions::WideningOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties > SettingsCmdAddWidening::SettingsCmdWideningOptions::WideningOffset Property
SettingsCmdAddWidening::SettingsCmdWideningOptions::WideningOffset Property
Collapse All

Specifies the WideningOffset for alignment widening options.

C#
public PropertyDouble WideningOffset;
Visual Basic
Public Property WideningOffset() As PropertyDouble
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Class, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdAddWidening::SettingsCmdWideningOptions::WideningSegmentLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties > SettingsCmdAddWidening::SettingsCmdWideningOptions::WideningSegmentLength Property
SettingsCmdAddWidening::SettingsCmdWideningOptions::WideningSegmentLength Property
Collapse All

Specifies the WideningSegmentLength for alignment widening options.

C#
public PropertyDouble WideningSegmentLength;
Visual Basic
Public Property WideningSegmentLength() As PropertyDouble
Links
SettingsCmdAddWidening::SettingsCmdWideningOptions Class, SettingsCmdAddWidening::SettingsCmdWideningOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCatchmentArea Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class
SettingsCmdCatchmentArea Class
Collapse All

Settings for CatchmentArea command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCatchmentArea
C#
public class SettingsCmdCatchmentArea : SettingsSurface;
Visual Basic
Public Class SettingsCmdCatchmentArea
Inherits SettingsSurface
Links
SettingsCmdCatchmentArea Properties, SettingsCmdCatchmentArea Members, Class Hierarchy


SettingsCmdCatchmentArea Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Members
SettingsCmdCatchmentArea Members
Collapse All

The following tables list the members exposed by SettingsCmdCatchmentArea.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Layer | Gets the catchment layer.
Marker | Gets the catchment marker.
MarkerStyle | Gets the catchment marker style.
ObjectType | Gets the catchment object type.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCatchmentArea Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Properties
SettingsCmdCatchmentArea Properties
Collapse All

The properties of SettingsCmdCatchmentArea are listed here.

Public Properties
Public Property | Description
Layer | Gets the catchment layer.
Marker | Gets the catchment marker.
MarkerStyle | Gets the catchment marker style.
ObjectType | Gets the catchment object type.
Links
Public Properties


SettingsCmdCatchmentArea::Layer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Properties > SettingsCmdCatchmentArea::Layer Property
SettingsCmdCatchmentArea::Layer Property
Collapse All

Gets the catchment layer.

C#
public PropertyLayer Layer;
Visual Basic
Public Property Layer() As PropertyLayer
Links
SettingsCmdCatchmentArea Class, SettingsCmdCatchmentArea Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCatchmentArea::Marker Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Properties > SettingsCmdCatchmentArea::Marker Property
SettingsCmdCatchmentArea::Marker Property
Collapse All

Gets the catchment marker.

C#
public PropertyBoolean Marker;
Visual Basic
Public Property Marker() As PropertyBoolean
Links
SettingsCmdCatchmentArea Class, SettingsCmdCatchmentArea Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCatchmentArea::MarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Properties > SettingsCmdCatchmentArea::MarkerStyle Property
SettingsCmdCatchmentArea::MarkerStyle Property
Collapse All

Gets the catchment marker style.

C#
public PropertyString MarkerStyle;
Visual Basic
Public Property MarkerStyle() As PropertyString
Links
SettingsCmdCatchmentArea Class, SettingsCmdCatchmentArea Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCatchmentArea::ObjectType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Properties > SettingsCmdCatchmentArea::ObjectType Property
SettingsCmdCatchmentArea::ObjectType Property
Collapse All

Gets the catchment object type.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::CatchmentWatershedObjectType> ObjectType;
Visual Basic
Public Property ObjectType() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::CatchmentWatershedObjectType>
Links
SettingsCmdCatchmentArea Class, SettingsCmdCatchmentArea Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdConvertPointstoSdskPoints Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class
SettingsCmdConvertPointstoSdskPoints Class
Collapse All

Settings for ConvertPointstoSdskPoints command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdConvertPointstoSdskPoints
C#
public class SettingsCmdConvertPointstoSdskPoints : SettingsPoint;
Visual Basic
Public Class SettingsCmdConvertPointstoSdskPoints
Inherits SettingsPoint
Links
SettingsCmdConvertPointstoSdskPoints Properties, SettingsCmdConvertPointstoSdskPoints Members, Class Hierarchy


SettingsCmdConvertPointstoSdskPoints Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Members
SettingsCmdConvertPointstoSdskPoints Members
Collapse All

The following tables list the members exposed by SettingsCmdConvertPointstoSdskPoints.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Layer | Gets the default setting of Layer.
NameFormat | Gets the default name format for new points and point groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to points and points labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UpdatePoints | Gets whether you can change local copies of project points without checking them out.
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdConvertPointstoSdskPoints Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Properties
SettingsCmdConvertPointstoSdskPoints Properties
Collapse All

The properties of SettingsCmdConvertPointstoSdskPoints are listed here.

Public Properties
Public Property | Description
Layer | Gets the default setting of Layer.
Links
Public Properties


SettingsCmdConvertPointstoSdskPoints::Layer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Properties > SettingsCmdConvertPointstoSdskPoints::Layer Property
SettingsCmdConvertPointstoSdskPoints::Layer Property
Collapse All

Gets the default setting of Layer.

C#
public SettingsCmdLayer Layer;
Visual Basic
Public Property Layer() As SettingsCmdLayer
Links
SettingsCmdConvertPointstoSdskPoints Class, SettingsCmdConvertPointstoSdskPoints Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class
Collapse All

Settings that specify defaults for Layer.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer
C#
public class SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer
Inherits TreeOidWrapper
Links
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties, SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members, Class Hierarchy


SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members
Collapse All

The following tables list the members exposed by SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer.

Public Properties
Public Property | Description
Layer | Gets the default Layer.
Links
Public Properties


SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties
Collapse All

The properties of SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer are listed here.

Public Properties
Public Property | Description
Layer | Gets the default Layer.
Links
Public Properties


SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer::Layer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer::Layer Property
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer::Layer Property
Collapse All

Gets the default Layer.

C#
public PropertyLayer Layer;
Visual Basic
Public Property Layer() As PropertyLayer
Links
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class, SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentEntities Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class
SettingsCmdCreateAlignmentEntities Class
Collapse All

Settings for CreateAlignmentEntities command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentEntities
C#
public class SettingsCmdCreateAlignmentEntities : SettingsAlignment;
Visual Basic
Public Class SettingsCmdCreateAlignmentEntities
Inherits SettingsAlignment
Links
SettingsCmdCreateAlignmentEntities Properties, SettingsCmdCreateAlignmentEntities Members, Class Hierarchy


SettingsCmdCreateAlignmentEntities Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Members
SettingsCmdCreateAlignmentEntities Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignmentEntities.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the AlignmentTypeOption settings.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CreateFromEntities | Gets the CreateFromEntities settings.
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateAlignmentEntities Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Properties
SettingsCmdCreateAlignmentEntities Properties
Collapse All

The properties of SettingsCmdCreateAlignmentEntities are listed here.

Public Properties
Public Property | Description
AlignmentTypeOption | Gets the AlignmentTypeOption settings.
CreateFromEntities | Gets the CreateFromEntities settings.
Links
Public Properties


SettingsCmdCreateAlignmentEntities::AlignmentTypeOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Properties > SettingsCmdCreateAlignmentEntities::AlignmentTypeOption Property
SettingsCmdCreateAlignmentEntities::AlignmentTypeOption Property
Collapse All

Gets the AlignmentTypeOption settings.

C#
public SettingsCmdAlignmentTypeOption AlignmentTypeOption;
Visual Basic
Public Property AlignmentTypeOption() As SettingsCmdAlignmentTypeOption
Links
SettingsCmdCreateAlignmentEntities Class, SettingsCmdCreateAlignmentEntities Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentEntities::CreateFromEntities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Properties > SettingsCmdCreateAlignmentEntities::CreateFromEntities Property
SettingsCmdCreateAlignmentEntities::CreateFromEntities Property
Collapse All

Gets the CreateFromEntities settings.

C#
public SettingsCmdCreateFromEntities CreateFromEntities;
Visual Basic
Public Property CreateFromEntities() As SettingsCmdCreateFromEntities
Links
SettingsCmdCreateAlignmentEntities Class, SettingsCmdCreateAlignmentEntities Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class
SettingsCmdCreateAlignmentLayout Class
Collapse All

Settings for CreateAlignmentLayout command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout
C#
public class SettingsCmdCreateAlignmentLayout : SettingsAlignment;
Visual Basic
Public Class SettingsCmdCreateAlignmentLayout
Inherits SettingsAlignment
Links
SettingsCmdCreateAlignmentLayout Properties, SettingsCmdCreateAlignmentLayout Members, Class Hierarchy


SettingsCmdCreateAlignmentLayout Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Members
SettingsCmdCreateAlignmentLayout Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignmentLayout.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the default setting of alignment type for the command CreateAlignmentLayout.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
CurveAndSpiralSettings | Gets the default setting of curve and spiral for the command CreateAlignmentLayout.
CurveTessellationOption | Gets the default setting of curve tessellation option for the command CreateAlignmentLayout.
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
RegressionGraphOption | Gets the default setting of tegression graph option for the command CreateAlignmentLayout.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateAlignmentLayout Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Properties
SettingsCmdCreateAlignmentLayout Properties
Collapse All

The properties of SettingsCmdCreateAlignmentLayout are listed here.

Public Properties
Public Property | Description
AlignmentTypeOption | Gets the default setting of alignment type for the command CreateAlignmentLayout.
CurveAndSpiralSettings | Gets the default setting of curve and spiral for the command CreateAlignmentLayout.
CurveTessellationOption | Gets the default setting of curve tessellation option for the command CreateAlignmentLayout.
RegressionGraphOption | Gets the default setting of tegression graph option for the command CreateAlignmentLayout.
Links
Public Properties


SettingsCmdCreateAlignmentLayout::AlignmentTypeOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Properties > SettingsCmdCreateAlignmentLayout::AlignmentTypeOption Property
SettingsCmdCreateAlignmentLayout::AlignmentTypeOption Property
Collapse All

Gets the default setting of alignment type for the command CreateAlignmentLayout.

C#
public SettingsCmdAlignmentTypeOption AlignmentTypeOption;
Visual Basic
Public Property AlignmentTypeOption() As SettingsCmdAlignmentTypeOption
Links
SettingsCmdCreateAlignmentLayout Class, SettingsCmdCreateAlignmentLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::CurveAndSpiralSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Properties > SettingsCmdCreateAlignmentLayout::CurveAndSpiralSettings Property
SettingsCmdCreateAlignmentLayout::CurveAndSpiralSettings Property
Collapse All

Gets the default setting of curve and spiral for the command CreateAlignmentLayout.

C#
public SettingsCmdCurveAndSpiralSettings CurveAndSpiralSettings;
Visual Basic
Public Property CurveAndSpiralSettings() As SettingsCmdCurveAndSpiralSettings
Links
SettingsCmdCreateAlignmentLayout Class, SettingsCmdCreateAlignmentLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::CurveTessellationOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Properties > SettingsCmdCreateAlignmentLayout::CurveTessellationOption Property
SettingsCmdCreateAlignmentLayout::CurveTessellationOption Property
Collapse All

Gets the default setting of curve tessellation option for the command CreateAlignmentLayout.

C#
public SettingsCmdCurveTessellationOption CurveTessellationOption;
Visual Basic
Public Property CurveTessellationOption() As SettingsCmdCurveTessellationOption
Links
SettingsCmdCreateAlignmentLayout Class, SettingsCmdCreateAlignmentLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::RegressionGraphOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Properties > SettingsCmdCreateAlignmentLayout::RegressionGraphOption Property
SettingsCmdCreateAlignmentLayout::RegressionGraphOption Property
Collapse All

Gets the default setting of tegression graph option for the command CreateAlignmentLayout.

C#
public SettingsCmdRegressionGraphOption RegressionGraphOption;
Visual Basic
Public Property RegressionGraphOption() As SettingsCmdRegressionGraphOption
Links
SettingsCmdCreateAlignmentLayout Class, SettingsCmdCreateAlignmentLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class
Collapse All

Settings of alignment type option for the command CreateAlignmentLayout.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption
C#
public class SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties, SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members, Class Hierarchy


SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption.

Public Properties
Public Property | Description
AlignmentType | Specifies whether to erase existing entities for creating alignment entities.
Links
Public Properties


SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties
Collapse All

The properties of SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption are listed here.

Public Properties
Public Property | Description
AlignmentType | Specifies whether to erase existing entities for creating alignment entities.
Links
Public Properties


SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption::AlignmentType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption::AlignmentType Property
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption::AlignmentType Property
Collapse All

Specifies whether to erase existing entities for creating alignment entities.

C#
public PropertyEnum<Autodesk::Civil::Land::DatabaseServices::AlignmentType> AlignmentType;
Visual Basic
Public Property AlignmentType() As PropertyEnum<Autodesk::Civil::Land::DatabaseServices::AlignmentType>
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class, SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class
Collapse All

Settings of curve and spiral for the command CreateAlignmentLayout.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings
C#
public class SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings
Inherits TreeOidWrapper
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Class Hierarchy


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings.

Public Properties
Public Property | Description
CurveRadiusForSCSGroup | Specifies a radius value for the SCS group.
SpiralInAValue | Specifies the length for the Spiral In.
SpiralInLength | Specifies the length for the Spiral In.
SpiralOutAValue | Specifies the A value for the Spiral Out.
SpiralOutLength | Specifies the length for the Spiral Out.
SpiralType | Specifies the spiral type.
UseCurve | Specifies whether your design includes a curve.
UseSpiralIn | Specifies whether your design includes a spiral either before a curve or before a Spiral Out.
UseSpiralOut | Specifies whether your design includes a Spiral Out.
Links
Public Properties


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties
Collapse All

The properties of SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings are listed here.

Public Properties
Public Property | Description
CurveRadiusForSCSGroup | Specifies a radius value for the SCS group.
SpiralInAValue | Specifies the length for the Spiral In.
SpiralInLength | Specifies the length for the Spiral In.
SpiralOutAValue | Specifies the A value for the Spiral Out.
SpiralOutLength | Specifies the length for the Spiral Out.
SpiralType | Specifies the spiral type.
UseCurve | Specifies whether your design includes a curve.
UseSpiralIn | Specifies whether your design includes a spiral either before a curve or before a Spiral Out.
UseSpiralOut | Specifies whether your design includes a Spiral Out.
Links
Public Properties


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::CurveRadiusForSCSGroup Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::CurveRadiusForSCSGroup Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::CurveRadiusForSCSGroup Property
Collapse All

Specifies a radius value for the SCS group.

C#
public PropertyDouble CurveRadiusForSCSGroup;
Visual Basic
Public Property CurveRadiusForSCSGroup() As PropertyDouble
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralInAValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralInAValue Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralInAValue Property
Collapse All

Specifies the length for the Spiral In.

C#
public PropertyDouble SpiralInAValue;
Visual Basic
Public Property SpiralInAValue() As PropertyDouble
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralInLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralInLength Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralInLength Property
Collapse All

Specifies the length for the Spiral In.

C#
public PropertyDouble SpiralInLength;
Visual Basic
Public Property SpiralInLength() As PropertyDouble
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralOutAValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralOutAValue Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralOutAValue Property
Collapse All

Specifies the A value for the Spiral Out.

C#
public PropertyDouble SpiralOutAValue;
Visual Basic
Public Property SpiralOutAValue() As PropertyDouble
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralOutLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralOutLength Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralOutLength Property
Collapse All

Specifies the length for the Spiral Out.

C#
public PropertyDouble SpiralOutLength;
Visual Basic
Public Property SpiralOutLength() As PropertyDouble
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralType Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralType Property
Collapse All

Specifies the spiral type.

C#
public PropertyEnum<Autodesk::Civil::SpiralType> SpiralType;
Visual Basic
Public Property SpiralType() As PropertyEnum<Autodesk::Civil::SpiralType>
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseCurve Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseCurve Property
Collapse All

Specifies whether your design includes a curve.

C#
public PropertyBoolean UseCurve;
Visual Basic
Public Property UseCurve() As PropertyBoolean
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseSpiralIn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseSpiralIn Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseSpiralIn Property
Collapse All

Specifies whether your design includes a spiral either before a curve or before a Spiral Out.

C#
public PropertyBoolean UseSpiralIn;
Visual Basic
Public Property UseSpiralIn() As PropertyBoolean
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseSpiralOut Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseSpiralOut Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseSpiralOut Property
Collapse All

Specifies whether your design includes a Spiral Out.

C#
public PropertyBoolean UseSpiralOut;
Visual Basic
Public Property UseSpiralOut() As PropertyBoolean
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class
Collapse All

Settings of curve tessellation option for the command CreateAlignmentLayout.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption
C#
public class SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members, Class Hierarchy


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption.

Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies the mid-ordinate tolerance based on a distance across the tessellated curve segments.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties
Collapse All

The properties of SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption are listed here.

Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies the mid-ordinate tolerance based on a distance across the tessellated curve segments.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
Collapse All

Specifies the mid-ordinate tolerance based on a distance across the tessellated curve segments.

C#
public PropertyDouble MidOrdinateTolerance;
Visual Basic
Public Property MidOrdinateTolerance() As PropertyDouble
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption::TessellateCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption::TessellateCurve Property
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption::TessellateCurve Property
Collapse All

Specifies whether to tesselate curve segments if they are included as an input option.

C#
public PropertyBoolean TessellateCurve;
Visual Basic
Public Property TessellateCurve() As PropertyBoolean
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class
Collapse All

Settings of tegression graph option for the command CreateAlignmentLayout.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption
C#
public class SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties, SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members, Class Hierarchy


SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties
Collapse All

The properties of SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption are listed here.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
Collapse All

Specifies whether the regression graph displays splines on the green line that represents the best fit entity.

C#
public PropertyBoolean SplineFitForRegressionAnalysisGraph;
Visual Basic
Public Property SplineFitForRegressionAnalysisGraph() As PropertyBoolean
Links
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class, SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateAlignmentReference Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentReference Class
SettingsCmdCreateAlignmentReference Class
Collapse All

Settings for CreateAlignmentReference command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentReference
C#
public class SettingsCmdCreateAlignmentReference : SettingsAlignment;
Visual Basic
Public Class SettingsCmdCreateAlignmentReference
Inherits SettingsAlignment
Links
Class Hierarchy


SettingsCmdCreateFeatureLineFromAlign Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class
SettingsCmdCreateFeatureLineFromAlign Class
Collapse All

Settings for CreateFeatureLineFromAlign command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLineFromAlign
C#
public class SettingsCmdCreateFeatureLineFromAlign : SettingsGrading;
Visual Basic
Public Class SettingsCmdCreateFeatureLineFromAlign
Inherits SettingsGrading
Links
SettingsCmdCreateFeatureLineFromAlign Properties, SettingsCmdCreateFeatureLineFromAlign Members, Class Hierarchy


SettingsCmdCreateFeatureLineFromAlign Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Members
SettingsCmdCreateFeatureLineFromAlign Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateFeatureLineFromAlign.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineCreation | Gets the default setting of feature line creation for the command CreateFeatureLineFromAlign.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateFeatureLineFromAlign Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Properties
SettingsCmdCreateFeatureLineFromAlign Properties
Collapse All

The properties of SettingsCmdCreateFeatureLineFromAlign are listed here.

Public Properties
Public Property | Description
FeatureLineCreation | Gets the default setting of feature line creation for the command CreateFeatureLineFromAlign.
Links
Public Properties


SettingsCmdCreateFeatureLineFromAlign::FeatureLineCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Properties > SettingsCmdCreateFeatureLineFromAlign::FeatureLineCreation Property
SettingsCmdCreateFeatureLineFromAlign::FeatureLineCreation Property
Collapse All

Gets the default setting of feature line creation for the command CreateFeatureLineFromAlign.

C#
public SettingsCmdFeatureLineCreation FeatureLineCreation;
Visual Basic
Public Property FeatureLineCreation() As SettingsCmdFeatureLineCreation
Links
SettingsCmdCreateFeatureLineFromAlign Class, SettingsCmdCreateFeatureLineFromAlign Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class
Collapse All

Settings that specify the default behavior for creating feature lines from alignments.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation
C#
public class SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties, SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members, Class Hierarchy


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation.

Public Properties
Public Property | Description
CreateDynamicLink | Gets a PropertyBoolean value specifies whether to create a dynamic link to the alignment. Change this value to False to... more
LayerSetting | Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from... more
MidOrdinateDistance | Gets the default Mid-ordinate distance for tessellating curves into short line segments.
SpiralTessellationFactor | Gets the default Spiral tessellation factor.
UseFeatureLineName | Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.
WeedPoints | Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when... more
Links
Public Properties


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties
Collapse All

The properties of SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation are listed here.

Public Properties
Public Property | Description
CreateDynamicLink | Gets a PropertyBoolean value specifies whether to create a dynamic link to the alignment. Change this value to False to... more
LayerSetting | Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from... more
MidOrdinateDistance | Gets the default Mid-ordinate distance for tessellating curves into short line segments.
SpiralTessellationFactor | Gets the default Spiral tessellation factor.
UseFeatureLineName | Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.
WeedPoints | Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when... more
Links
Public Properties


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::CreateDynamicLink Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::CreateDynamicLink Property
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::CreateDynamicLink Property
Collapse All

Gets a PropertyBoolean value specifies whether to create a dynamic link to the alignment. Change this value to False to prevent dynamic link creation.

C#
public PropertyBoolean CreateDynamicLink;
Visual Basic
Public Property CreateDynamicLink() As PropertyBoolean
Links
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::LayerSetting Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::LayerSetting Property
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::LayerSetting Property
Collapse All

Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from drawing settings.

C#
public PropertyEnum<Autodesk::Civil::Land::FeatureLineLayerSettingType> LayerSetting;
Visual Basic
Public Property LayerSetting() As PropertyEnum<Autodesk::Civil::Land::FeatureLineLayerSettingType>
Links
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::MidOrdinateDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::MidOrdinateDistance Property
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::MidOrdinateDistance Property
Collapse All

Gets the default Mid-ordinate distance for tessellating curves into short line segments.

C#
public PropertyDouble MidOrdinateDistance;
Visual Basic
Public Property MidOrdinateDistance() As PropertyDouble
Links
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::SpiralTessellationFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::SpiralTessellationFactor Property
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::SpiralTessellationFactor Property
Collapse All

Gets the default Spiral tessellation factor.

C#
public PropertyDouble SpiralTessellationFactor;
Visual Basic
Public Property SpiralTessellationFactor() As PropertyDouble
Links
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::UseFeatureLineName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::UseFeatureLineName Property
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::UseFeatureLineName Property
Collapse All

Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.

C#
public PropertyBoolean UseFeatureLineName;
Visual Basic
Public Property UseFeatureLineName() As PropertyBoolean
Links
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property
Collapse All

Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.

C#
public PropertyBoolean UseFeatureLineStyle;
Visual Basic
Public Property UseFeatureLineStyle() As PropertyBoolean
Links
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::WeedPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::WeedPoints Property
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::WeedPoints Property
Collapse All

Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when converting to a feature line. Change this value to True to open the Weed Vertices dialog box.

C#
public PropertyBoolean WeedPoints;
Visual Basic
Public Property WeedPoints() As PropertyBoolean
Links
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLines Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class
SettingsCmdCreateFeatureLines Class
Collapse All

Settings for CreateFeatureLines command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLines
C#
public class SettingsCmdCreateFeatureLines : SettingsGrading;
Visual Basic
Public Class SettingsCmdCreateFeatureLines
Inherits SettingsGrading
Links
SettingsCmdCreateFeatureLines Properties, SettingsCmdCreateFeatureLines Members, Class Hierarchy


SettingsCmdCreateFeatureLines Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Members
SettingsCmdCreateFeatureLines Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateFeatureLines.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineCreation | Gets the default setting of feature line creation for the command CreateFeatureLines.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateFeatureLines Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Properties
SettingsCmdCreateFeatureLines Properties
Collapse All

The properties of SettingsCmdCreateFeatureLines are listed here.

Public Properties
Public Property | Description
FeatureLineCreation | Gets the default setting of feature line creation for the command CreateFeatureLines.
Links
Public Properties


SettingsCmdCreateFeatureLines::FeatureLineCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Properties > SettingsCmdCreateFeatureLines::FeatureLineCreation Property
SettingsCmdCreateFeatureLines::FeatureLineCreation Property
Collapse All

Gets the default setting of feature line creation for the command CreateFeatureLines.

C#
public SettingsCmdFeatureLineCreation FeatureLineCreation;
Visual Basic
Public Property FeatureLineCreation() As SettingsCmdFeatureLineCreation
Links
SettingsCmdCreateFeatureLines Class, SettingsCmdCreateFeatureLines Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class
Collapse All

Settings that specify the default behavior for creating feature lines from objects.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation
C#
public class SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties, SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members, Class Hierarchy


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation.

Public Properties
Public Property | Description
AssignElevations | Gets a PropertyBoolean value specifies whether to open the Assign Elevations dialog box.
ElevationSource | Gets the default elevation source settings.
EraseExistingEntities | Gets a PropertyBoolean value specifies whether creation commands erase selected objects when they are converted to feature lines. By default... more
IncludeMidElevationBreaks | Gets a PropertyBoolean value specifies whether to include intermediate elevation breaks when assigning elevations from a surface or grading group.... more
LayerSetting | Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from... more
UseFeatureLineName | Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.
WeedPoints | Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when... more
Links
Public Properties


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties
Collapse All

The properties of SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation are listed here.

Public Properties
Public Property | Description
AssignElevations | Gets a PropertyBoolean value specifies whether to open the Assign Elevations dialog box.
ElevationSource | Gets the default elevation source settings.
EraseExistingEntities | Gets a PropertyBoolean value specifies whether creation commands erase selected objects when they are converted to feature lines. By default... more
IncludeMidElevationBreaks | Gets a PropertyBoolean value specifies whether to include intermediate elevation breaks when assigning elevations from a surface or grading group.... more
LayerSetting | Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from... more
UseFeatureLineName | Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.
WeedPoints | Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when... more
Links
Public Properties


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::AssignElevations Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::AssignElevations Property
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::AssignElevations Property
Collapse All

Gets a PropertyBoolean value specifies whether to open the Assign Elevations dialog box.

C#
public PropertyBoolean AssignElevations;
Visual Basic
Public Property AssignElevations() As PropertyBoolean
Links
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::ElevationSource Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::ElevationSource Property
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::ElevationSource Property
Collapse All

Gets the default elevation source settings.

C#
public PropertyEnum<Autodesk::Civil::Land::ElevationSourceType> ElevationSource;
Visual Basic
Public Property ElevationSource() As PropertyEnum<Autodesk::Civil::Land::ElevationSourceType>
Links
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::EraseExistingEntities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::EraseExistingEntities Property
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::EraseExistingEntities Property
Collapse All

Gets a PropertyBoolean value specifies whether creation commands erase selected objects when they are converted to feature lines. By default objects are erased. Change this value to False to have objects remain in the drawing.

C#
public PropertyBoolean EraseExistingEntities;
Visual Basic
Public Property EraseExistingEntities() As PropertyBoolean
Links
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::IncludeMidElevationBreaks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::IncludeMidElevationBreaks Property
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::IncludeMidElevationBreaks Property
Collapse All

Gets a PropertyBoolean value specifies whether to include intermediate elevation breaks when assigning elevations from a surface or grading group.

C#
public PropertyBoolean IncludeMidElevationBreaks;
Visual Basic
Public Property IncludeMidElevationBreaks() As PropertyBoolean
Links
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::LayerSetting Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::LayerSetting Property
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::LayerSetting Property
Collapse All

Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from drawing settings.

C#
public PropertyEnum<Autodesk::Civil::Land::FeatureLineLayerSettingType> LayerSetting;
Visual Basic
Public Property LayerSetting() As PropertyEnum<Autodesk::Civil::Land::FeatureLineLayerSettingType>
Links
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::UseFeatureLineName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::UseFeatureLineName Property
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::UseFeatureLineName Property
Collapse All

Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.

C#
public PropertyBoolean UseFeatureLineName;
Visual Basic
Public Property UseFeatureLineName() As PropertyBoolean
Links
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property
Collapse All

Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.

C#
public PropertyBoolean UseFeatureLineStyle;
Visual Basic
Public Property UseFeatureLineStyle() As PropertyBoolean
Links
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::WeedPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::WeedPoints Property
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::WeedPoints Property
Collapse All

Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when converting to a feature line.Change this value to True to open the Weed Vertices dialog box.

C#
public PropertyBoolean WeedPoints;
Visual Basic
Public Property WeedPoints() As PropertyBoolean
Links
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class, SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateGrading Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class
SettingsCmdCreateGrading Class
Collapse All

Settings for CreateGrading command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateGrading
C#
public class SettingsCmdCreateGrading : SettingsGrading;
Visual Basic
Public Class SettingsCmdCreateGrading
Inherits SettingsGrading
Links
SettingsCmdCreateGrading Properties, SettingsCmdCreateGrading Members, Class Hierarchy


SettingsCmdCreateGrading Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Members
SettingsCmdCreateGrading Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateGrading.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GradingCreation | Gets the default setting of grading creation for the command CreateGrading.
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateGrading Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Properties
SettingsCmdCreateGrading Properties
Collapse All

The properties of SettingsCmdCreateGrading are listed here.

Public Properties
Public Property | Description
GradingCreation | Gets the default setting of grading creation for the command CreateGrading.
Links
Public Properties


SettingsCmdCreateGrading::GradingCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Properties > SettingsCmdCreateGrading::GradingCreation Property
SettingsCmdCreateGrading::GradingCreation Property
Collapse All

Gets the default setting of grading creation for the command CreateGrading.

C#
public SettingsCmdGradingCreation GradingCreation;
Visual Basic
Public Property GradingCreation() As SettingsCmdGradingCreation
Links
SettingsCmdCreateGrading Class, SettingsCmdCreateGrading Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateGrading::SettingsCmdGradingCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading::SettingsCmdGradingCreation Class
SettingsCmdCreateGrading::SettingsCmdGradingCreation Class
Collapse All

Settings that specify the default behavior for creating grading.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateGrading::SettingsCmdGradingCreation
C#
public class SettingsCmdCreateGrading::SettingsCmdGradingCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateGrading::SettingsCmdGradingCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties, SettingsCmdCreateGrading::SettingsCmdGradingCreation Members, Class Hierarchy


SettingsCmdCreateGrading::SettingsCmdGradingCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading::SettingsCmdGradingCreation Class > SettingsCmdCreateGrading::SettingsCmdGradingCreation Members
SettingsCmdCreateGrading::SettingsCmdGradingCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateGrading::SettingsCmdGradingCreation.

Public Properties
Public Property | Description
TransitionRegionLength | Specifies the default length for transition regions.
Links
Public Properties


SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading::SettingsCmdGradingCreation Class > SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties
SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties
Collapse All

The properties of SettingsCmdCreateGrading::SettingsCmdGradingCreation are listed here.

Public Properties
Public Property | Description
TransitionRegionLength | Specifies the default length for transition regions.
Links
Public Properties


SettingsCmdCreateGrading::SettingsCmdGradingCreation::TransitionRegionLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading::SettingsCmdGradingCreation Class > SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties > SettingsCmdCreateGrading::SettingsCmdGradingCreation::TransitionRegionLength Property
SettingsCmdCreateGrading::SettingsCmdGradingCreation::TransitionRegionLength Property
Collapse All

Specifies the default length for transition regions.

C#
public PropertyDouble TransitionRegionLength;
Visual Basic
Public Property TransitionRegionLength() As PropertyDouble
Links
SettingsCmdCreateGrading::SettingsCmdGradingCreation Class, SettingsCmdCreateGrading::SettingsCmdGradingCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateGradingGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class
SettingsCmdCreateGradingGroup Class
Collapse All

Settings for CreateGradingGroup command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateGradingGroup
C#
public class SettingsCmdCreateGradingGroup : SettingsGrading;
Visual Basic
Public Class SettingsCmdCreateGradingGroup
Inherits SettingsGrading
Links
SettingsCmdCreateGradingGroup Properties, SettingsCmdCreateGradingGroup Members, Class Hierarchy


SettingsCmdCreateGradingGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Members
SettingsCmdCreateGradingGroup Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateGradingGroup.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GradingGroupCreation | Gets the default setting of grading group creation for the command CreateGradingGroup.
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateGradingGroup Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Properties
SettingsCmdCreateGradingGroup Properties
Collapse All

The properties of SettingsCmdCreateGradingGroup are listed here.

Public Properties
Public Property | Description
GradingGroupCreation | Gets the default setting of grading group creation for the command CreateGradingGroup.
Links
Public Properties


SettingsCmdCreateGradingGroup::GradingGroupCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Properties > SettingsCmdCreateGradingGroup::GradingGroupCreation Property
SettingsCmdCreateGradingGroup::GradingGroupCreation Property
Collapse All

Gets the default setting of grading group creation for the command CreateGradingGroup.

C#
public SettingsCmdGradingGroupCreation GradingGroupCreation;
Visual Basic
Public Property GradingGroupCreation() As SettingsCmdGradingGroupCreation
Links
SettingsCmdCreateGradingGroup Class, SettingsCmdCreateGradingGroup Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class
Collapse All

Settings that specify the default behavior for creating grading.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation
C#
public class SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties, SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members, Class Hierarchy


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation.

Public Properties
Public Property | Description
GradingSurfaceCreation | Specifies whether a grading group generates an automatic surface by default.
SurfaceConeTessellationAngle | Specifies the default maximum angle between supplemental projection lines on exterior corners.
SurfaceStyle | Specifies the default style for the grading group.
SurfaceTessellationIncrement | Specifies the default maximum distance along the feature line to add supplemental surface triangle lines for better definition of the... more
UseGroupName | Specifies whether the automatic surface is named after the grading group by default.
Links
Public Properties


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties
Collapse All

The properties of SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation are listed here.

Public Properties
Public Property | Description
GradingSurfaceCreation | Specifies whether a grading group generates an automatic surface by default.
SurfaceConeTessellationAngle | Specifies the default maximum angle between supplemental projection lines on exterior corners.
SurfaceStyle | Specifies the default style for the grading group.
SurfaceTessellationIncrement | Specifies the default maximum distance along the feature line to add supplemental surface triangle lines for better definition of the... more
UseGroupName | Specifies whether the automatic surface is named after the grading group by default.
Links
Public Properties


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::GradingSurfaceCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::GradingSurfaceCreation Property
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::GradingSurfaceCreation Property
Collapse All

Specifies whether a grading group generates an automatic surface by default.

C#
public PropertyBoolean GradingSurfaceCreation;
Visual Basic
Public Property GradingSurfaceCreation() As PropertyBoolean
Links
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class, SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceConeTessellationAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceConeTessellationAngle Property
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceConeTessellationAngle Property
Collapse All

Specifies the default maximum angle between supplemental projection lines on exterior corners.

C#
public PropertyDouble SurfaceConeTessellationAngle;
Visual Basic
Public Property SurfaceConeTessellationAngle() As PropertyDouble
Links
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class, SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceStyle Property
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceStyle Property
Collapse All

Specifies the default style for the grading group.

C#
public PropertyString SurfaceStyle;
Visual Basic
Public Property SurfaceStyle() As PropertyString
Links
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class, SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceTessellationIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceTessellationIncrement Property
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceTessellationIncrement Property
Collapse All

Specifies the default maximum distance along the feature line to add supplemental surface triangle lines for better definition of the grading group surface.

C#
public PropertyDouble SurfaceTessellationIncrement;
Visual Basic
Public Property SurfaceTessellationIncrement() As PropertyDouble
Links
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class, SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::UseGroupName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::UseGroupName Property
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::UseGroupName Property
Collapse All

Specifies whether the automatic surface is named after the grading group by default.

C#
public PropertyBoolean UseGroupName;
Visual Basic
Public Property UseGroupName() As PropertyBoolean
Links
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class, SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMassHaulDiagram Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class
SettingsCmdCreateMassHaulDiagram Class
Collapse All

Settings for CreateMassHallDiagram command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsMassHaulView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMassHaulDiagram
C#
public class SettingsCmdCreateMassHaulDiagram : SettingsMassHaulView;
Visual Basic
Public Class SettingsCmdCreateMassHaulDiagram
Inherits SettingsMassHaulView
Links
SettingsCmdCreateMassHaulDiagram Properties, SettingsCmdCreateMassHaulDiagram Members, Class Hierarchy


SettingsCmdCreateMassHaulDiagram Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Members
SettingsCmdCreateMassHaulDiagram Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateMassHaulDiagram.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MassHaulCreation | Specifies the Mass haul data settings.
NameFormat | Gets the default name formats for new mass haul lines and new mass haul views.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for mass haul components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateMassHaulDiagram Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Properties
SettingsCmdCreateMassHaulDiagram Properties
Collapse All

The properties of SettingsCmdCreateMassHaulDiagram are listed here.

Public Properties
Public Property | Description
MassHaulCreation | Specifies the Mass haul data settings.
Links
Public Properties


SettingsCmdCreateMassHaulDiagram::MassHaulCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Properties > SettingsCmdCreateMassHaulDiagram::MassHaulCreation Property
SettingsCmdCreateMassHaulDiagram::MassHaulCreation Property
Collapse All

Specifies the Mass haul data settings.

C#
public SettingsCmdMassHaulCreation MassHaulCreation;
Visual Basic
Public Property MassHaulCreation() As SettingsCmdMassHaulCreation
Links
SettingsCmdCreateMassHaulDiagram Class, SettingsCmdCreateMassHaulDiagram Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleProfileView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class
SettingsCmdCreateMultipleProfileView Class
Collapse All

Settings for CreateMultipleProfileView command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleProfileView
C#
public class SettingsCmdCreateMultipleProfileView : SettingsProfileView;
Visual Basic
Public Class SettingsCmdCreateMultipleProfileView
Inherits SettingsProfileView
Links
SettingsCmdCreateMultipleProfileView Properties, SettingsCmdCreateMultipleProfileView Members, Class Hierarchy


SettingsCmdCreateMultipleProfileView Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Members
SettingsCmdCreateMultipleProfileView Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateMultipleProfileView.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Creation | Gets style settings for profile view.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MultipleProfileViewCreation | Gets the default setting of multiple profile view creation.
NameFormat | Gets style settings for profile view.
ProjectionLabelPlacement | Gets style settings for profile view.
Slope | The Slope settings
Speed | The Speed settings
SplitOptions | Gets style settings for profile view.
StackedOptions | Gets style settings for profile view.
Station | The Station settings
Styles | Gets style settings for profile view.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateMultipleProfileView Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Properties
SettingsCmdCreateMultipleProfileView Properties
Collapse All

The properties of SettingsCmdCreateMultipleProfileView are listed here.

Public Properties
Public Property | Description
MultipleProfileViewCreation | Gets the default setting of multiple profile view creation.
Links
Public Properties


SettingsCmdCreateMultipleProfileView::MultipleProfileViewCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Properties > SettingsCmdCreateMultipleProfileView::MultipleProfileViewCreation Property
SettingsCmdCreateMultipleProfileView::MultipleProfileViewCreation Property
Collapse All

Gets the default setting of multiple profile view creation.

C#
public SettingsCmdMultipleProfileViewCreation MultipleProfileViewCreation;
Visual Basic
Public Property MultipleProfileViewCreation() As SettingsCmdMultipleProfileViewCreation
Links
SettingsCmdCreateMultipleProfileView Class, SettingsCmdCreateMultipleProfileView Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class
Collapse All

Settings that specify defaults for creating multiple profile views.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation
C#
public class SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties, SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members, Class Hierarchy


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation.

Public Properties
Public Property | Description
ColumnSpacing | Gets
DefaultProfileViewHeight | Gets
DefaultProfileViewLength | Gets the default length for profile views.
PlotPattern | Gets
ProfileViewDatumBy | Gets
ProfileViewsInRowOrColumn | Gets
RowSpacing | Gets
StartCorner | Gets
Links
Public Properties


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties
Collapse All

The properties of SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation are listed here.

Public Properties
Public Property | Description
ColumnSpacing | Gets
DefaultProfileViewHeight | Gets
DefaultProfileViewLength | Gets the default length for profile views.
PlotPattern | Gets
ProfileViewDatumBy | Gets
ProfileViewsInRowOrColumn | Gets
RowSpacing | Gets
StartCorner | Gets
Links
Public Properties


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ColumnSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ColumnSpacing Property
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ColumnSpacing Property
Collapse All

Gets

C#
public PropertyDouble ColumnSpacing;
Visual Basic
Public Property ColumnSpacing() As PropertyDouble
Links
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class, SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::DefaultProfileViewHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::DefaultProfileViewHeight Property
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::DefaultProfileViewHeight Property
Collapse All

Gets

C#
public PropertyDouble DefaultProfileViewHeight;
Visual Basic
Public Property DefaultProfileViewHeight() As PropertyDouble
Links
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class, SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::DefaultProfileViewLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::DefaultProfileViewLength Property
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::DefaultProfileViewLength Property
Collapse All

Gets the default length for profile views.

C#
public PropertyDouble DefaultProfileViewLength;
Visual Basic
Public Property DefaultProfileViewLength() As PropertyDouble
Links
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class, SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::PlotPattern Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::PlotPattern Property
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::PlotPattern Property
Collapse All

Gets

C#
public PropertyEnum<Autodesk::Civil::Land::ProfileViewPlotType> PlotPattern;
Visual Basic
Public Property PlotPattern() As PropertyEnum<Autodesk::Civil::Land::ProfileViewPlotType>
Links
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class, SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ProfileViewDatumBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ProfileViewDatumBy Property
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ProfileViewDatumBy Property
Collapse All

Gets

C#
public PropertyEnum<Autodesk::Civil::Land::ProfileViewDatumType> ProfileViewDatumBy;
Visual Basic
Public Property ProfileViewDatumBy() As PropertyEnum<Autodesk::Civil::Land::ProfileViewDatumType>
Links
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class, SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ProfileViewsInRowOrColumn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ProfileViewsInRowOrColumn Property
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ProfileViewsInRowOrColumn Property
Collapse All

Gets

C#
public PropertyInt ProfileViewsInRowOrColumn;
Visual Basic
Public Property ProfileViewsInRowOrColumn() As PropertyInt
Links
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class, SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::RowSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::RowSpacing Property
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::RowSpacing Property
Collapse All

Gets

C#
public PropertyDouble RowSpacing;
Visual Basic
Public Property RowSpacing() As PropertyDouble
Links
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class, SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::StartCorner Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::StartCorner Property
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::StartCorner Property
Collapse All

Gets

C#
public PropertyEnum<Autodesk::Civil::Land::ProfileViewStartCornerType> StartCorner;
Visual Basic
Public Property StartCorner() As PropertyEnum<Autodesk::Civil::Land::ProfileViewStartCornerType>
Links
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class, SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class
SettingsCmdCreateMultipleSectionView Class
Collapse All

Settings for CreateMultipleSectionView command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleSectionView
C#
public class SettingsCmdCreateMultipleSectionView : SettingsSectionView;
Visual Basic
Public Class SettingsCmdCreateMultipleSectionView
Inherits SettingsSectionView
Links
SettingsCmdCreateMultipleSectionView Properties, SettingsCmdCreateMultipleSectionView Members, Class Hierarchy


SettingsCmdCreateMultipleSectionView Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Members
SettingsCmdCreateMultipleSectionView Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateMultipleSectionView.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MultipleSectionViewCreation | Specifies the multiple section view settings.
NameFormat | Gets the template for naming the section view.
ProjectionLabelPlacement | settings to specify the default name formats for sample line.
SectionViewCreation | Gets the settings to establish the defaults assigned for section view creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to section view components
TableCreation | Specifies the table creation settings.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateMultipleSectionView Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Properties
SettingsCmdCreateMultipleSectionView Properties
Collapse All

The properties of SettingsCmdCreateMultipleSectionView are listed here.

Public Properties
Public Property | Description
MultipleSectionViewCreation | Specifies the multiple section view settings.
TableCreation | Specifies the table creation settings.
Links
Public Properties


SettingsCmdCreateMultipleSectionView::MultipleSectionViewCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Properties > SettingsCmdCreateMultipleSectionView::MultipleSectionViewCreation Property
SettingsCmdCreateMultipleSectionView::MultipleSectionViewCreation Property
Collapse All

Specifies the multiple section view settings.

C#
public SettingsCmdMultipleSectionViewCreation MultipleSectionViewCreation;
Visual Basic
Public Property MultipleSectionViewCreation() As SettingsCmdMultipleSectionViewCreation
Links
SettingsCmdCreateMultipleSectionView Class, SettingsCmdCreateMultipleSectionView Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Properties > SettingsCmdCreateMultipleSectionView::TableCreation Property
SettingsCmdCreateMultipleSectionView::TableCreation Property
Collapse All

Specifies the table creation settings.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdCreateMultipleSectionView Class, SettingsCmdCreateMultipleSectionView Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class
Collapse All

Settings for the table creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation
C#
public class SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties, SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members, Class Hierarchy


SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation.

Public Properties
Public Property | Description
SectionViewHeight | Specifies whether a station range is set for the creation of multiple section views.
SpecifyMultipleSectionViewStationRange | Specifies whether a station range is set for the creation of multiple section views.
Links
Public Properties


SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties
Collapse All

The properties of SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation are listed here.

Public Properties
Public Property | Description
SectionViewHeight | Specifies whether a station range is set for the creation of multiple section views.
SpecifyMultipleSectionViewStationRange | Specifies whether a station range is set for the creation of multiple section views.
Links
Public Properties


SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation::SectionViewHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation::SectionViewHeight Property
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation::SectionViewHeight Property
Collapse All

Specifies whether a station range is set for the creation of multiple section views.

C#
public PropertyDouble SectionViewHeight;
Visual Basic
Public Property SectionViewHeight() As PropertyDouble
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation::SpecifyMultipleSectionViewStationRange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation::SpecifyMultipleSectionViewStationRange Property
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation::SpecifyMultipleSectionViewStationRange Property
Collapse All

Specifies whether a station range is set for the creation of multiple section views.

C#
public PropertyBoolean SpecifyMultipleSectionViewStationRange;
Visual Basic
Public Property SpecifyMultipleSectionViewStationRange() As PropertyBoolean
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class
Collapse All

Settings for table creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation
C#
public class SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaterialVolumeTableStyle | Specifies the styles for a material table.
MaximumNumberOfRows | Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum,... more
MaximumTablesPerStack | Specifies the maximum number of sections to include in each stack.
SectionViewAnchor | Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableAnchor | Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
TableLayout | Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
TableSpacing | Specifies the spacing between tables.
TileDirection | Specifies the direction in which the table tiles (across or down).
TotalVolumeTableStyle | Specifies the style for a total volume table.
XOffset | Specifies the horizontal offset of the table.
YOffset | Specifies the vertical offset of the table.
Links
Public Properties


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaterialVolumeTableStyle | Specifies the styles for a material table.
MaximumNumberOfRows | Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum,... more
MaximumTablesPerStack | Specifies the maximum number of sections to include in each stack.
SectionViewAnchor | Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableAnchor | Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
TableLayout | Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
TableSpacing | Specifies the spacing between tables.
TileDirection | Specifies the direction in which the table tiles (across or down).
TotalVolumeTableStyle | Specifies the style for a total volume table.
XOffset | Specifies the horizontal offset of the table.
YOffset | Specifies the vertical offset of the table.
Links
Public Properties


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaterialVolumeTableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaterialVolumeTableStyle Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaterialVolumeTableStyle Property
Collapse All

Specifies the styles for a material table.

C#
public PropertyString MaterialVolumeTableStyle;
Visual Basic
Public Property MaterialVolumeTableStyle() As PropertyString
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of sections to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::SectionViewAnchor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::SectionViewAnchor Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::SectionViewAnchor Property
Collapse All

Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).

C#
public PropertyEnum<SectionViewAnchorType> SectionViewAnchor;
Visual Basic
Public Property SectionViewAnchor() As PropertyEnum<SectionViewAnchorType>
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::SplitTable Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableAnchor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableAnchor Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableAnchor Property
Collapse All

Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).

C#
public PropertyEnum<TableAnchorType> TableAnchor;
Visual Basic
Public Property TableAnchor() As PropertyEnum<TableAnchorType>
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableLayout Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableLayout Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableLayout Property
Collapse All

Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.

C#
public PropertyEnum<TableLayoutType> TableLayout;
Visual Basic
Public Property TableLayout() As PropertyEnum<TableLayoutType>
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TileDirection Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (across or down).

C#
public PropertyEnum<TileDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<TileDirectionType>
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TotalVolumeTableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TotalVolumeTableStyle Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TotalVolumeTableStyle Property
Collapse All

Specifies the style for a total volume table.

C#
public PropertyString TotalVolumeTableStyle;
Visual Basic
Public Property TotalVolumeTableStyle() As PropertyString
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::XOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::XOffset Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::XOffset Property
Collapse All

Specifies the horizontal offset of the table.

C#
public PropertyDouble XOffset;
Visual Basic
Public Property XOffset() As PropertyDouble
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::YOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::YOffset Property
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::YOffset Property
Collapse All

Specifies the vertical offset of the table.

C#
public PropertyDouble YOffset;
Visual Basic
Public Property YOffset() As PropertyDouble
Links
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateOffsetAlignment Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class
SettingsCmdCreateOffsetAlignment Class
Collapse All

Settings for CreateOffsetAlignment command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdCreateOffsetAlignment
C#
public class SettingsCmdCreateOffsetAlignment : SettingsAlignment;
Visual Basic
Public Class SettingsCmdCreateOffsetAlignment
Inherits SettingsAlignment
Links
SettingsCmdCreateOffsetAlignment Properties, SettingsCmdCreateOffsetAlignment Members, Class Hierarchy


SettingsCmdCreateOffsetAlignment Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Members
SettingsCmdCreateOffsetAlignment Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateOffsetAlignment.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
OffsetAlignmentOptions | Specifies the offset alignment options.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateOffsetAlignment Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Properties
SettingsCmdCreateOffsetAlignment Properties
Collapse All

The properties of SettingsCmdCreateOffsetAlignment are listed here.

Public Properties
Public Property | Description
OffsetAlignmentOptions | Specifies the offset alignment options.
Links
Public Properties


SettingsCmdCreateOffsetAlignment::OffsetAlignmentOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Properties > SettingsCmdCreateOffsetAlignment::OffsetAlignmentOptions Property
SettingsCmdCreateOffsetAlignment::OffsetAlignmentOptions Property
Collapse All

Specifies the offset alignment options.

C#
public SettingsCmdOffsetAlignmentOptions OffsetAlignmentOptions;
Visual Basic
Public Property OffsetAlignmentOptions() As SettingsCmdOffsetAlignmentOptions
Links
SettingsCmdCreateOffsetAlignment Class, SettingsCmdCreateOffsetAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class
SettingsCmdCreateParcelByLayout Class
Collapse All

Settings for CreateParcelByLayout command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout
C#
public class SettingsCmdCreateParcelByLayout : SettingsParcel;
Visual Basic
Public Class SettingsCmdCreateParcelByLayout
Inherits SettingsParcel
Links
SettingsCmdCreateParcelByLayout Properties, SettingsCmdCreateParcelByLayout Members, Class Hierarchy


SettingsCmdCreateParcelByLayout Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Members
SettingsCmdCreateParcelByLayout Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelByLayout.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AutomaticLayout | Gets the default setting of automatic layout for the command CreateParcelByLayout.
ConvertFromEntities | Gets the default setting of converting from entities for the command CreateParcelByLayout.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ParcelSizing | Gets the default setting of parcel sizing for the command CreateParcelByLayout.
PreviewGraphics | Gets the default setting of preview graphics for the command CreateParcelByLayout.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateParcelByLayout Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Properties
SettingsCmdCreateParcelByLayout Properties
Collapse All

The properties of SettingsCmdCreateParcelByLayout are listed here.

Public Properties
Public Property | Description
AutomaticLayout | Gets the default setting of automatic layout for the command CreateParcelByLayout.
ConvertFromEntities | Gets the default setting of converting from entities for the command CreateParcelByLayout.
ParcelSizing | Gets the default setting of parcel sizing for the command CreateParcelByLayout.
PreviewGraphics | Gets the default setting of preview graphics for the command CreateParcelByLayout.
Links
Public Properties


SettingsCmdCreateParcelByLayout::AutomaticLayout Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Properties > SettingsCmdCreateParcelByLayout::AutomaticLayout Property
SettingsCmdCreateParcelByLayout::AutomaticLayout Property
Collapse All

Gets the default setting of automatic layout for the command CreateParcelByLayout.

C#
public SettingsCmdAutomaticLayout AutomaticLayout;
Visual Basic
Public Property AutomaticLayout() As SettingsCmdAutomaticLayout
Links
SettingsCmdCreateParcelByLayout Class, SettingsCmdCreateParcelByLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::ConvertFromEntities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Properties > SettingsCmdCreateParcelByLayout::ConvertFromEntities Property
SettingsCmdCreateParcelByLayout::ConvertFromEntities Property
Collapse All

Gets the default setting of converting from entities for the command CreateParcelByLayout.

C#
public SettingsCmdConvertFromEntities ConvertFromEntities;
Visual Basic
Public Property ConvertFromEntities() As SettingsCmdConvertFromEntities
Links
SettingsCmdCreateParcelByLayout Class, SettingsCmdCreateParcelByLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::ParcelSizing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Properties > SettingsCmdCreateParcelByLayout::ParcelSizing Property
SettingsCmdCreateParcelByLayout::ParcelSizing Property
Collapse All

Gets the default setting of parcel sizing for the command CreateParcelByLayout.

C#
public SettingsCmdParcelSizing ParcelSizing;
Visual Basic
Public Property ParcelSizing() As SettingsCmdParcelSizing
Links
SettingsCmdCreateParcelByLayout Class, SettingsCmdCreateParcelByLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::PreviewGraphics Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Properties > SettingsCmdCreateParcelByLayout::PreviewGraphics Property
SettingsCmdCreateParcelByLayout::PreviewGraphics Property
Collapse All

Gets the default setting of preview graphics for the command CreateParcelByLayout.

C#
public SettingsCmdPreviewGraphics PreviewGraphics;
Visual Basic
Public Property PreviewGraphics() As SettingsCmdPreviewGraphics
Links
SettingsCmdCreateParcelByLayout Class, SettingsCmdCreateParcelByLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class
Collapse All

Settings that specify defaults for automatic parcel layout.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout
C#
public class SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout
Inherits TreeOidWrapper
Links
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties, SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members, Class Hierarchy


SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout.

Public Properties
Public Property | Description
AutomaticMode | Gets a PropertyBoolean value specifies whether the automatic mode is set for parcel layout.
RemainderDistributionType | Gets the PropertyEnum value spctifies remainder from a new parcel is distributed.
Links
Public Properties


SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties
Collapse All

The properties of SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout are listed here.

Public Properties
Public Property | Description
AutomaticMode | Gets a PropertyBoolean value specifies whether the automatic mode is set for parcel layout.
RemainderDistributionType | Gets the PropertyEnum value spctifies remainder from a new parcel is distributed.
Links
Public Properties


SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout::AutomaticMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout::AutomaticMode Property
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout::AutomaticMode Property
Collapse All

Gets a PropertyBoolean value specifies whether the automatic mode is set for parcel layout.

C#
public PropertyBoolean AutomaticMode;
Visual Basic
Public Property AutomaticMode() As PropertyBoolean
Links
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class, SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout::RemainderDistributionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout::RemainderDistributionType Property
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout::RemainderDistributionType Property
Collapse All

Gets the PropertyEnum value spctifies remainder from a new parcel is distributed.

C#
public PropertyEnum<Autodesk::Civil::Land::ParcelRemainderDistributionType> RemainderDistributionType;
Visual Basic
Public Property RemainderDistributionType() As PropertyEnum<Autodesk::Civil::Land::ParcelRemainderDistributionType>
Links
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class, SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class
Collapse All

Settings that specify defaults for creation of parcels.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities
C#
public class SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities
Inherits TreeOidWrapper
Links
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties, SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members, Class Hierarchy


SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities.

Public Properties
Public Property | Description
AutoAddSegmentLabel | Gets a PropertyBoolean value specifies whether segment labels are automatically added to a new parcel.
Links
Public Properties


SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties
Collapse All

The properties of SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities are listed here.

Public Properties
Public Property | Description
AutoAddSegmentLabel | Gets a PropertyBoolean value specifies whether segment labels are automatically added to a new parcel.
Links
Public Properties


SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities::AutoAddSegmentLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities::AutoAddSegmentLabel Property
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities::AutoAddSegmentLabel Property
Collapse All

Gets a PropertyBoolean value specifies whether segment labels are automatically added to a new parcel.

C#
public PropertyBoolean AutoAddSegmentLabel;
Visual Basic
Public Property AutoAddSegmentLabel() As PropertyBoolean
Links
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class, SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class
Collapse All

Settings that specify defaults for sizing parcels.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing
C#
public class SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing
Inherits TreeOidWrapper
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Class Hierarchy


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing.

Public Properties
Public Property | Description
FrontageOffset | Gets the default frontage offset. Must be greater than zero.
MaximumDepth | Gets the default maximum depth. Must be greater than or equal to zero.
MinimumArea | Gets the default minimum area for a new parcel.
MinimumDepth | Gets the default minimum depth.
MinimumFrontage | Gets the default minimum frontage for a new parcel.
MinimumWidth | Gets the default minimum width.
SelectionMethod | Gets the default parcel selection method.
SolutionPreference | Gets the default multiple solution preference.
UseMaximumDepth | Gets a PropertyBoolean value specifies whether using maximum depth.
UseMinimumFrontageAtOffset | Gets a PropertyBoolean value specifies whether using minimum frontage at offset.
Links
Public Properties


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties
Collapse All

The properties of SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing are listed here.

Public Properties
Public Property | Description
FrontageOffset | Gets the default frontage offset. Must be greater than zero.
MaximumDepth | Gets the default maximum depth. Must be greater than or equal to zero.
MinimumArea | Gets the default minimum area for a new parcel.
MinimumDepth | Gets the default minimum depth.
MinimumFrontage | Gets the default minimum frontage for a new parcel.
MinimumWidth | Gets the default minimum width.
SelectionMethod | Gets the default parcel selection method.
SolutionPreference | Gets the default multiple solution preference.
UseMaximumDepth | Gets a PropertyBoolean value specifies whether using maximum depth.
UseMinimumFrontageAtOffset | Gets a PropertyBoolean value specifies whether using minimum frontage at offset.
Links
Public Properties


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::FrontageOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::FrontageOffset Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::FrontageOffset Property
Collapse All

Gets the default frontage offset. Must be greater than zero.

C#
public PropertyDouble FrontageOffset;
Visual Basic
Public Property FrontageOffset() As PropertyDouble
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MaximumDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MaximumDepth Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MaximumDepth Property
Collapse All

Gets the default maximum depth. Must be greater than or equal to zero.

C#
public PropertyDouble MaximumDepth;
Visual Basic
Public Property MaximumDepth() As PropertyDouble
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumArea Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumArea Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumArea Property
Collapse All

Gets the default minimum area for a new parcel.

C#
public PropertyDouble MinimumArea;
Visual Basic
Public Property MinimumArea() As PropertyDouble
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumDepth Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumDepth Property
Collapse All

Gets the default minimum depth.

C#
public PropertyDouble MinimumDepth;
Visual Basic
Public Property MinimumDepth() As PropertyDouble
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumFrontage Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumFrontage Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumFrontage Property
Collapse All

Gets the default minimum frontage for a new parcel.

C#
public PropertyDouble MinimumFrontage;
Visual Basic
Public Property MinimumFrontage() As PropertyDouble
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumWidth Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumWidth Property
Collapse All

Gets the default minimum width.

C#
public PropertyDouble MinimumWidth;
Visual Basic
Public Property MinimumWidth() As PropertyDouble
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::SelectionMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::SelectionMethod Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::SelectionMethod Property
Collapse All

Gets the default parcel selection method.

C#
public PropertyEnum<Autodesk::Civil::Land::ParcelSelectionType> SelectionMethod;
Visual Basic
Public Property SelectionMethod() As PropertyEnum<Autodesk::Civil::Land::ParcelSelectionType>
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::SolutionPreference Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::SolutionPreference Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::SolutionPreference Property
Collapse All

Gets the default multiple solution preference.

C#
public PropertyEnum<Autodesk::Civil::Land::ParcelSolutionType> SolutionPreference;
Visual Basic
Public Property SolutionPreference() As PropertyEnum<Autodesk::Civil::Land::ParcelSolutionType>
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::UseMaximumDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::UseMaximumDepth Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::UseMaximumDepth Property
Collapse All

Gets a PropertyBoolean value specifies whether using maximum depth.

C#
public PropertyBoolean UseMaximumDepth;
Visual Basic
Public Property UseMaximumDepth() As PropertyBoolean
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::UseMinimumFrontageAtOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::UseMinimumFrontageAtOffset Property
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::UseMinimumFrontageAtOffset Property
Collapse All

Gets a PropertyBoolean value specifies whether using minimum frontage at offset.

C#
public PropertyBoolean UseMinimumFrontageAtOffset;
Visual Basic
Public Property UseMinimumFrontageAtOffset() As PropertyBoolean
Links
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class, SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class
Collapse All

Settings that specify defaults for temporary parcel layout preview graphics.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics
C#
public class SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics
Inherits TreeOidWrapper
Links
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties, SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members, Class Hierarchy


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics.

Public Properties
Public Property | Description
FrontageColor | Gets the default color for the frontage preview.
FrontageOffsetColor | Gets the default color for the frontage offset preview.
MinimumDepthColor | Gets the default color for the minimum depth preview.
MinimumFrontageColor | Gets the default color for the minimum frontage preview.
MinimumWidthColor | Gets the default color for the minimum width preview.
NewParcelColor | Gets the default color for the new parcel preview.
Links
Public Properties


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties
Collapse All

The properties of SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics are listed here.

Public Properties
Public Property | Description
FrontageColor | Gets the default color for the frontage preview.
FrontageOffsetColor | Gets the default color for the frontage offset preview.
MinimumDepthColor | Gets the default color for the minimum depth preview.
MinimumFrontageColor | Gets the default color for the minimum frontage preview.
MinimumWidthColor | Gets the default color for the minimum width preview.
NewParcelColor | Gets the default color for the new parcel preview.
Links
Public Properties


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::FrontageColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::FrontageColor Property
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::FrontageColor Property
Collapse All

Gets the default color for the frontage preview.

C#
public PropertyColor FrontageColor;
Visual Basic
Public Property FrontageColor() As PropertyColor
Links
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class, SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::FrontageOffsetColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::FrontageOffsetColor Property
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::FrontageOffsetColor Property
Collapse All

Gets the default color for the frontage offset preview.

C#
public PropertyColor FrontageOffsetColor;
Visual Basic
Public Property FrontageOffsetColor() As PropertyColor
Links
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class, SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumDepthColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumDepthColor Property
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumDepthColor Property
Collapse All

Gets the default color for the minimum depth preview.

C#
public PropertyColor MinimumDepthColor;
Visual Basic
Public Property MinimumDepthColor() As PropertyColor
Links
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class, SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumFrontageColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumFrontageColor Property
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumFrontageColor Property
Collapse All

Gets the default color for the minimum frontage preview.

C#
public PropertyColor MinimumFrontageColor;
Visual Basic
Public Property MinimumFrontageColor() As PropertyColor
Links
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class, SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumWidthColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumWidthColor Property
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumWidthColor Property
Collapse All

Gets the default color for the minimum width preview.

C#
public PropertyColor MinimumWidthColor;
Visual Basic
Public Property MinimumWidthColor() As PropertyColor
Links
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class, SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::NewParcelColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::NewParcelColor Property
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::NewParcelColor Property
Collapse All

Gets the default color for the new parcel preview.

C#
public PropertyColor NewParcelColor;
Visual Basic
Public Property NewParcelColor() As PropertyColor
Links
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class, SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelFromObjects Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class
SettingsCmdCreateParcelFromObjects Class
Collapse All

Settings for CreateParcelFromObjects command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelFromObjects
C#
public class SettingsCmdCreateParcelFromObjects : SettingsParcel;
Visual Basic
Public Class SettingsCmdCreateParcelFromObjects
Inherits SettingsParcel
Links
SettingsCmdCreateParcelFromObjects Properties, SettingsCmdCreateParcelFromObjects Members, Class Hierarchy


SettingsCmdCreateParcelFromObjects Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Members
SettingsCmdCreateParcelFromObjects Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelFromObjects.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ConvertFromEntities | Gets the default setting of Convert From Entities.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateParcelFromObjects Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Properties
SettingsCmdCreateParcelFromObjects Properties
Collapse All

The properties of SettingsCmdCreateParcelFromObjects are listed here.

Public Properties
Public Property | Description
ConvertFromEntities | Gets the default setting of Convert From Entities.
Links
Public Properties


SettingsCmdCreateParcelFromObjects::ConvertFromEntities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Properties > SettingsCmdCreateParcelFromObjects::ConvertFromEntities Property
SettingsCmdCreateParcelFromObjects::ConvertFromEntities Property
Collapse All

Gets the default setting of Convert From Entities.

C#
public SettingsCmdConvertFromEntities ConvertFromEntities;
Visual Basic
Public Property ConvertFromEntities() As SettingsCmdConvertFromEntities
Links
SettingsCmdCreateParcelFromObjects Class, SettingsCmdCreateParcelFromObjects Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class
Collapse All

Settings that specify defaults for creation of parcels.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities
C#
public class SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities
Inherits TreeOidWrapper
Links
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties, SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members, Class Hierarchy


SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities.

Public Properties
Public Property | Description
AutoAddSegmentLabels | Gets whether existing entities are erased when a new parcel is created.
EraseAllExistingEntities | Gets whether existing entities are erased when a new parcel is created.
Links
Public Properties


SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties
Collapse All

The properties of SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities are listed here.

Public Properties
Public Property | Description
AutoAddSegmentLabels | Gets whether existing entities are erased when a new parcel is created.
EraseAllExistingEntities | Gets whether existing entities are erased when a new parcel is created.
Links
Public Properties


SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities::AutoAddSegmentLabels Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities::AutoAddSegmentLabels Property
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities::AutoAddSegmentLabels Property
Collapse All

Gets whether existing entities are erased when a new parcel is created.

C#
public PropertyBoolean AutoAddSegmentLabels;
Visual Basic
Public Property AutoAddSegmentLabels() As PropertyBoolean
Links
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class, SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities::EraseAllExistingEntities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities::EraseAllExistingEntities Property
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities::EraseAllExistingEntities Property
Collapse All

Gets whether existing entities are erased when a new parcel is created.

C#
public PropertyBoolean EraseAllExistingEntities;
Visual Basic
Public Property EraseAllExistingEntities() As PropertyBoolean
Links
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class, SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelROW Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class
SettingsCmdCreateParcelROW Class
Collapse All

Settings for CreateParcelROW command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW
C#
public class SettingsCmdCreateParcelROW : SettingsParcel;
Visual Basic
Public Class SettingsCmdCreateParcelROW
Inherits SettingsParcel
Links
SettingsCmdCreateParcelROW Properties, SettingsCmdCreateParcelROW Members, Class Hierarchy


SettingsCmdCreateParcelROW Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Members
SettingsCmdCreateParcelROW Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelROW.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
CleanupAtAlignmentIntersections | Gets the default setting of Cleanup at Alignment Intersections for the command AeccCreateParcelROW.
CleanupAtParcelBoundaries | Gets the default setting of Cleanup at Parcel Boundaries for the command AeccCreateParcelROW.
Coordinate | The Coordinate settings
CreateParcelRightOfWay | Gets the default setting of Create Parcel Right Of Way for the command AeccCreateParcelROW.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateParcelROW Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Properties
SettingsCmdCreateParcelROW Properties
Collapse All

The properties of SettingsCmdCreateParcelROW are listed here.

Public Properties
Public Property | Description
CleanupAtAlignmentIntersections | Gets the default setting of Cleanup at Alignment Intersections for the command AeccCreateParcelROW.
CleanupAtParcelBoundaries | Gets the default setting of Cleanup at Parcel Boundaries for the command AeccCreateParcelROW.
CreateParcelRightOfWay | Gets the default setting of Create Parcel Right Of Way for the command AeccCreateParcelROW.
Links
Public Properties


SettingsCmdCreateParcelROW::CleanupAtAlignmentIntersections Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Properties > SettingsCmdCreateParcelROW::CleanupAtAlignmentIntersections Property
SettingsCmdCreateParcelROW::CleanupAtAlignmentIntersections Property
Collapse All

Gets the default setting of Cleanup at Alignment Intersections for the command AeccCreateParcelROW.

C#
public SettingsCmdCleanupAtAlignmentIntersections CleanupAtAlignmentIntersections;
Visual Basic
Public Property CleanupAtAlignmentIntersections() As SettingsCmdCleanupAtAlignmentIntersections
Links
SettingsCmdCreateParcelROW Class, SettingsCmdCreateParcelROW Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelROW::CleanupAtParcelBoundaries Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Properties > SettingsCmdCreateParcelROW::CleanupAtParcelBoundaries Property
SettingsCmdCreateParcelROW::CleanupAtParcelBoundaries Property
Collapse All

Gets the default setting of Cleanup at Parcel Boundaries for the command AeccCreateParcelROW.

C#
public SettingsCmdCleanupAtParcelBoundaries CleanupAtParcelBoundaries;
Visual Basic
Public Property CleanupAtParcelBoundaries() As SettingsCmdCleanupAtParcelBoundaries
Links
SettingsCmdCreateParcelROW Class, SettingsCmdCreateParcelROW Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelROW::CreateParcelRightOfWay Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Properties > SettingsCmdCreateParcelROW::CreateParcelRightOfWay Property
SettingsCmdCreateParcelROW::CreateParcelRightOfWay Property
Collapse All

Gets the default setting of Create Parcel Right Of Way for the command AeccCreateParcelROW.

C#
public SettingsCmdCreateParcelRightOfWay CreateParcelRightOfWay;
Visual Basic
Public Property CreateParcelRightOfWay() As SettingsCmdCreateParcelRightOfWay
Links
SettingsCmdCreateParcelROW Class, SettingsCmdCreateParcelROW Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class
Collapse All

Settings that specify default offset for cleanup at alignment intersections.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections
C#
public class SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections
Inherits TreeOidWrapper
Links
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties, SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members, Class Hierarchy


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections.

Public Properties
Public Property | Description
CleanupMethodFillet | Gets whether the cleanup method is Fillet, Chamfer, or None.
FilletRadiusAtAlignmentIntersections | Gets the width of the radius of the fillet at alignment intersections.
Links
Public Properties


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties
Collapse All

The properties of SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections are listed here.

Public Properties
Public Property | Description
CleanupMethodFillet | Gets whether the cleanup method is Fillet, Chamfer, or None.
FilletRadiusAtAlignmentIntersections | Gets the width of the radius of the fillet at alignment intersections.
Links
Public Properties


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections::CleanupMethodFillet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections::CleanupMethodFillet Property
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections::CleanupMethodFillet Property
Collapse All

Gets whether the cleanup method is Fillet, Chamfer, or None.

C#
public PropertyEnum<ROWCleanupType> CleanupMethodFillet;
Visual Basic
Public Property CleanupMethodFillet() As PropertyEnum<ROWCleanupType>
Links
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class, SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections::FilletRadiusAtAlignmentIntersections Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections::FilletRadiusAtAlignmentIntersections Property
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections::FilletRadiusAtAlignmentIntersections Property
Collapse All

Gets the width of the radius of the fillet at alignment intersections.

C#
public PropertyDouble FilletRadiusAtAlignmentIntersections;
Visual Basic
Public Property FilletRadiusAtAlignmentIntersections() As PropertyDouble
Links
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class, SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class
Collapse All

Settings that specify default offset for cleanup at parcel boundaries.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries
C#
public class SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries
Inherits TreeOidWrapper
Links
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties, SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members, Class Hierarchy


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries.

Public Properties
Public Property | Description
CleanupMethodFillet | Gets whether the cleanup method is Fillet, Chamfer, or None.
FilletRadiusAtParcelBoundaryIntersections | Gets the width of the radius of the fillet at parcel boundary intersections.
Links
Public Properties


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties
Collapse All

The properties of SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries are listed here.

Public Properties
Public Property | Description
CleanupMethodFillet | Gets whether the cleanup method is Fillet, Chamfer, or None.
FilletRadiusAtParcelBoundaryIntersections | Gets the width of the radius of the fillet at parcel boundary intersections.
Links
Public Properties


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries::CleanupMethodFillet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries::CleanupMethodFillet Property
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries::CleanupMethodFillet Property
Collapse All

Gets whether the cleanup method is Fillet, Chamfer, or None.

C#
public PropertyEnum<ROWCleanupType> CleanupMethodFillet;
Visual Basic
Public Property CleanupMethodFillet() As PropertyEnum<ROWCleanupType>
Links
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class, SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries::FilletRadiusAtParcelBoundaryIntersections Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries::FilletRadiusAtParcelBoundaryIntersections Property
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries::FilletRadiusAtParcelBoundaryIntersections Property
Collapse All

Gets the width of the radius of the fillet at parcel boundary intersections.

C#
public PropertyDouble FilletRadiusAtParcelBoundaryIntersections;
Visual Basic
Public Property FilletRadiusAtParcelBoundaryIntersections() As PropertyDouble
Links
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class, SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class
Collapse All

Setting that specify default offset for creation of parcel rights of way.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay
C#
public class SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay
Inherits TreeOidWrapper
Links
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties, SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members, Class Hierarchy


SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay.

Public Properties
Public Property | Description
OffsetFromAlignment | Gets the offset from the alignment for the new right of way.
Links
Public Properties


SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties
Collapse All

The properties of SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay are listed here.

Public Properties
Public Property | Description
OffsetFromAlignment | Gets the offset from the alignment for the new right of way.
Links
Public Properties


SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay::OffsetFromAlignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay::OffsetFromAlignment Property
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay::OffsetFromAlignment Property
Collapse All

Gets the offset from the alignment for the new right of way.

C#
public PropertyDouble OffsetFromAlignment;
Visual Basic
Public Property OffsetFromAlignment() As PropertyDouble
Links
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class, SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePointGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePointGroup Class
SettingsCmdCreatePointGroup Class
Collapse All

Settings for CreatePointGroup command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdCreatePointGroup
C#
public class SettingsCmdCreatePointGroup : SettingsPoint;
Visual Basic
Public Class SettingsCmdCreatePointGroup
Inherits SettingsPoint
Links
Class Hierarchy


SettingsCmdCreatePoints Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class
SettingsCmdCreatePoints Class
Collapse All

Settings for CreatePoints command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdCreatePoints
C#
public class SettingsCmdCreatePoints : SettingsPoint;
Visual Basic
Public Class SettingsCmdCreatePoints
Inherits SettingsPoint
Links
SettingsCmdCreatePoints Properties, SettingsCmdCreatePoints Members, Class Hierarchy


SettingsCmdCreatePoints Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Members
SettingsCmdCreatePoints Members
Collapse All

The following tables list the members exposed by SettingsCmdCreatePoints.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Layer | Gets the default setting of Layer.
NameFormat | Gets the default name format for new points and point groups.
PointsCreation | Gets the settings to establish default information for creating points.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to points and points labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UpdatePoints | Gets whether you can change local copies of project points without checking them out.
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreatePoints Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Properties
SettingsCmdCreatePoints Properties
Collapse All

The properties of SettingsCmdCreatePoints are listed here.

Public Properties
Public Property | Description
Layer | Gets the default setting of Layer.
PointsCreation | Gets the settings to establish default information for creating points.
Links
Public Properties


SettingsCmdCreatePoints::Layer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Properties > SettingsCmdCreatePoints::Layer Property
SettingsCmdCreatePoints::Layer Property
Collapse All

Gets the default setting of Layer.

C#
public SettingsCmdLayer Layer;
Visual Basic
Public Property Layer() As SettingsCmdLayer
Links
SettingsCmdCreatePoints Class, SettingsCmdCreatePoints Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::PointsCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Properties > SettingsCmdCreatePoints::PointsCreation Property
SettingsCmdCreatePoints::PointsCreation Property
Collapse All

Gets the settings to establish default information for creating points.

C#
public SettingsCmdPointsCreation PointsCreation;
Visual Basic
Public Property PointsCreation() As SettingsCmdPointsCreation
Links
SettingsCmdCreatePoints Class, SettingsCmdCreatePoints Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdLayer Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdLayer Class
SettingsCmdCreatePoints::SettingsCmdLayer Class
Collapse All

Default layer settings for the CreatePoints command.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreatePoints::SettingsCmdLayer
C#
public class SettingsCmdCreatePoints::SettingsCmdLayer : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreatePoints::SettingsCmdLayer
Inherits TreeOidWrapper
Links
SettingsCmdCreatePoints::SettingsCmdLayer Properties, SettingsCmdCreatePoints::SettingsCmdLayer Members, Class Hierarchy


SettingsCmdCreatePoints::SettingsCmdLayer Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdLayer Class > SettingsCmdCreatePoints::SettingsCmdLayer Members
SettingsCmdCreatePoints::SettingsCmdLayer Members
Collapse All

The following tables list the members exposed by SettingsCmdCreatePoints::SettingsCmdLayer.

Public Properties
Public Property | Description
Layer | Gets or sets a default layer
Links
Public Properties


SettingsCmdCreatePoints::SettingsCmdLayer Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdLayer Class > SettingsCmdCreatePoints::SettingsCmdLayer Properties
SettingsCmdCreatePoints::SettingsCmdLayer Properties
Collapse All

The properties of SettingsCmdCreatePoints::SettingsCmdLayer are listed here.

Public Properties
Public Property | Description
Layer | Gets or sets a default layer
Links
Public Properties


SettingsCmdCreatePoints::SettingsCmdLayer::Layer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdLayer Class > SettingsCmdCreatePoints::SettingsCmdLayer Properties > SettingsCmdCreatePoints::SettingsCmdLayer::Layer Property
SettingsCmdCreatePoints::SettingsCmdLayer::Layer Property
Collapse All

Gets or sets a default layer

C#
public PropertyLayer Layer;
Visual Basic
Public Property Layer() As PropertyLayer
Links
SettingsCmdCreatePoints::SettingsCmdLayer Class, SettingsCmdCreatePoints::SettingsCmdLayer Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class
Collapse All

Settings that specify defaults for Points Creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreatePoints::SettingsCmdPointsCreation
C#
public class SettingsCmdCreatePoints::SettingsCmdPointsCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreatePoints::SettingsCmdPointsCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Class Hierarchy


SettingsCmdCreatePoints::SettingsCmdPointsCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Members
SettingsCmdCreatePoints::SettingsCmdPointsCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreatePoints::SettingsCmdPointsCreation.

Public Properties
Public Property | Description
DefaultDescription | Gets or sets the description that is automatically assigned by the point creation commands when Prompt For Descriptions is set... more
DefaultElevation | Gets or sets the elevation automatically assigned by the point creation commands when the Prompt For Elevations setting is set... more
DisableDescriptionKeys | Gets or sets whether description key matching occurs during point creation.
EchoCoordinatesToCommandLine | Gets or sets whether description key matching occurs during point creation.
GeographicCoordinates | Gets or sets the order in which geographic coordinates are displayed on the command line during point creation.
GridCoordinates | Gets or sets the order in which grid coordinates are displayed on the command line during point creation.
LocalCoordinates | Gets or sets the order and format used to display local coordinates on the command line during point creation.
MatchOnDescriptionParameters | Gets or sets whether parameters are used in description key matching to rotate and scale the point symbol.
PromptForDescriptions | Gets or sets how descriptions are assigned during point creation.
PromptForElevations | Gets or sets how elevations are assigned point creation.
PromptForPointNames | Gets or sets how point names are entered during point creation.
Links
Public Properties


SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties
SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties
Collapse All

The properties of SettingsCmdCreatePoints::SettingsCmdPointsCreation are listed here.

Public Properties
Public Property | Description
DefaultDescription | Gets or sets the description that is automatically assigned by the point creation commands when Prompt For Descriptions is set... more
DefaultElevation | Gets or sets the elevation automatically assigned by the point creation commands when the Prompt For Elevations setting is set... more
DisableDescriptionKeys | Gets or sets whether description key matching occurs during point creation.
EchoCoordinatesToCommandLine | Gets or sets whether description key matching occurs during point creation.
GeographicCoordinates | Gets or sets the order in which geographic coordinates are displayed on the command line during point creation.
GridCoordinates | Gets or sets the order in which grid coordinates are displayed on the command line during point creation.
LocalCoordinates | Gets or sets the order and format used to display local coordinates on the command line during point creation.
MatchOnDescriptionParameters | Gets or sets whether parameters are used in description key matching to rotate and scale the point symbol.
PromptForDescriptions | Gets or sets how descriptions are assigned during point creation.
PromptForElevations | Gets or sets how elevations are assigned point creation.
PromptForPointNames | Gets or sets how point names are entered during point creation.
Links
Public Properties


SettingsCmdCreatePoints::SettingsCmdPointsCreation::DefaultDescription Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::DefaultDescription Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::DefaultDescription Property
Collapse All

Gets or sets the description that is automatically assigned by the point creation commands when Prompt For Descriptions is set to Automatic.

C#
public PropertyString DefaultDescription;
Visual Basic
Public Property DefaultDescription() As PropertyString
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::DefaultElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::DefaultElevation Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::DefaultElevation Property
Collapse All

Gets or sets the elevation automatically assigned by the point creation commands when the Prompt For Elevations setting is set to Automatic.

C#
public PropertyDouble DefaultElevation;
Visual Basic
Public Property DefaultElevation() As PropertyDouble
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::DisableDescriptionKeys Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::DisableDescriptionKeys Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::DisableDescriptionKeys Property
Collapse All

Gets or sets whether description key matching occurs during point creation.

C#
public PropertyBoolean DisableDescriptionKeys;
Visual Basic
Public Property DisableDescriptionKeys() As PropertyBoolean
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::EchoCoordinatesToCommandLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::EchoCoordinatesToCommandLine Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::EchoCoordinatesToCommandLine Property
Collapse All

Gets or sets whether description key matching occurs during point creation.

C#
public PropertyBoolean EchoCoordinatesToCommandLine;
Visual Basic
Public Property EchoCoordinatesToCommandLine() As PropertyBoolean
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::GeographicCoordinates Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::GeographicCoordinates Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::GeographicCoordinates Property
Collapse All

Gets or sets the order in which geographic coordinates are displayed on the command line during point creation.

C#
public PropertyEnum<GeographicCoordinateType> GeographicCoordinates;
Visual Basic
Public Property GeographicCoordinates() As PropertyEnum<GeographicCoordinateType>
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::GridCoordinates Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::GridCoordinates Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::GridCoordinates Property
Collapse All

Gets or sets the order in which grid coordinates are displayed on the command line during point creation.

C#
public PropertyEnum<GridCoordinateType> GridCoordinates;
Visual Basic
Public Property GridCoordinates() As PropertyEnum<GridCoordinateType>
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::LocalCoordinates Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::LocalCoordinates Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::LocalCoordinates Property
Collapse All

Gets or sets the order and format used to display local coordinates on the command line during point creation.

C#
public PropertyEnum<LocalCoordinateType> LocalCoordinates;
Visual Basic
Public Property LocalCoordinates() As PropertyEnum<LocalCoordinateType>
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::MatchOnDescriptionParameters Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::MatchOnDescriptionParameters Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::MatchOnDescriptionParameters Property
Collapse All

Gets or sets whether parameters are used in description key matching to rotate and scale the point symbol.

C#
public PropertyBoolean MatchOnDescriptionParameters;
Visual Basic
Public Property MatchOnDescriptionParameters() As PropertyBoolean
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForDescriptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForDescriptions Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForDescriptions Property
Collapse All

Gets or sets how descriptions are assigned during point creation.

C#
public PropertyEnum<AutomaticManual> PromptForDescriptions;
Visual Basic
Public Property PromptForDescriptions() As PropertyEnum<AutomaticManual>
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForElevations Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForElevations Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForElevations Property
Collapse All

Gets or sets how elevations are assigned point creation.

C#
public PropertyEnum<AutomaticManual> PromptForElevations;
Visual Basic
Public Property PromptForElevations() As PropertyEnum<AutomaticManual>
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForPointNames Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties > SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForPointNames Property
SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForPointNames Property
Collapse All

Gets or sets how point names are entered during point creation.

C#
public PropertyEnum<AutomaticManual> PromptForPointNames;
Visual Basic
Public Property PromptForPointNames() As PropertyEnum<AutomaticManual>
Links
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class, SettingsCmdCreatePoints::SettingsCmdPointsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateProfileFromFile Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromFile Class
SettingsCmdCreateProfileFromFile Class
Collapse All

Settings for CreateProfileFromFile command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromFile
C#
public class SettingsCmdCreateProfileFromFile : SettingsProfile;
Visual Basic
Public Class SettingsCmdCreateProfileFromFile
Inherits SettingsProfile
Links
Class Hierarchy


SettingsCmdCreateProfileFromSurface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class
SettingsCmdCreateProfileFromSurface Class
Collapse All

Settings for CreateProfileFromSurface command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromSurface
C#
public class SettingsCmdCreateProfileFromSurface : SettingsProfile;
Visual Basic
Public Class SettingsCmdCreateProfileFromSurface
Inherits SettingsProfile
Links
SettingsCmdCreateProfileFromSurface Properties, SettingsCmdCreateProfileFromSurface Members, Class Hierarchy


SettingsCmdCreateProfileFromSurface Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Members
SettingsCmdCreateProfileFromSurface Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateProfileFromSurface.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Geometry | Gets the default setting of Geometry.
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateProfileFromSurface Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Properties
SettingsCmdCreateProfileFromSurface Properties
Collapse All

The properties of SettingsCmdCreateProfileFromSurface are listed here.

Public Properties
Public Property | Description
Geometry | Gets the default setting of Geometry.
Links
Public Properties


SettingsCmdCreateProfileFromSurface::Geometry Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Properties > SettingsCmdCreateProfileFromSurface::Geometry Property
SettingsCmdCreateProfileFromSurface::Geometry Property
Collapse All

Gets the default setting of Geometry.

C#
public SettingsCmdGeometry Geometry;
Visual Basic
Public Property Geometry() As SettingsCmdGeometry
Links
SettingsCmdCreateProfileFromSurface Class, SettingsCmdCreateProfileFromSurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class
Collapse All

Settings that specify the geometry setting.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry
C#
public class SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry
Inherits TreeOidWrapper
Links
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties, SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members, Class Hierarchy


SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry.

Public Properties
Public Property | Description
ProfileSampleOffsetsCommandSetting | Specifies whether to create offset profiles.
Links
Public Properties


SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties
Collapse All

The properties of SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry are listed here.

Public Properties
Public Property | Description
ProfileSampleOffsetsCommandSetting | Specifies whether to create offset profiles.
Links
Public Properties


SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry::ProfileSampleOffsetsCommandSetting Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry::ProfileSampleOffsetsCommandSetting Property
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry::ProfileSampleOffsetsCommandSetting Property
Collapse All

Specifies whether to create offset profiles.

C#
public PropertyBoolean ProfileSampleOffsetsCommandSetting;
Visual Basic
Public Property ProfileSampleOffsetsCommandSetting() As PropertyBoolean
Links
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class, SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateProfileLayout Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class
SettingsCmdCreateProfileLayout Class
Collapse All

Settings for CreateProfileLayout command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileLayout
C#
public class SettingsCmdCreateProfileLayout : SettingsProfile;
Visual Basic
Public Class SettingsCmdCreateProfileLayout
Inherits SettingsProfile
Links
SettingsCmdCreateProfileLayout Properties, SettingsCmdCreateProfileLayout Members, Class Hierarchy


SettingsCmdCreateProfileLayout Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Members
SettingsCmdCreateProfileLayout Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateProfileLayout.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
CurveTessellationOption | Gets the default setting of curve tessellation option.
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
RegressionGraphOption | Gets the default setting of regression graph option.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateProfileLayout Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Properties
SettingsCmdCreateProfileLayout Properties
Collapse All

The properties of SettingsCmdCreateProfileLayout are listed here.

Public Properties
Public Property | Description
CurveTessellationOption | Gets the default setting of curve tessellation option.
RegressionGraphOption | Gets the default setting of regression graph option.
Links
Public Properties


SettingsCmdCreateProfileLayout::CurveTessellationOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Properties > SettingsCmdCreateProfileLayout::CurveTessellationOption Property
SettingsCmdCreateProfileLayout::CurveTessellationOption Property
Collapse All

Gets the default setting of curve tessellation option.

C#
public SettingsCmdCurveTessellationOption CurveTessellationOption;
Visual Basic
Public Property CurveTessellationOption() As SettingsCmdCurveTessellationOption
Links
SettingsCmdCreateProfileLayout Class, SettingsCmdCreateProfileLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateProfileLayout::RegressionGraphOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Properties > SettingsCmdCreateProfileLayout::RegressionGraphOption Property
SettingsCmdCreateProfileLayout::RegressionGraphOption Property
Collapse All

Gets the default setting of regression graph option.

C#
public SettingsCmdRegressionGraphOption RegressionGraphOption;
Visual Basic
Public Property RegressionGraphOption() As SettingsCmdRegressionGraphOption
Links
SettingsCmdCreateProfileLayout Class, SettingsCmdCreateProfileLayout Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class
Collapse All

Settings that specify the default behavior when curve entities are used as an input option for best fit arc, line, and parabola creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption
C#
public class SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties, SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members, Class Hierarchy


SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption.

Public Properties
Public Property | Description
MidOrdinateTolerance | Gets the mid-ordinate tolerance based on a distance across the tessellated curve segments.
TessellateCurve | Gets whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties
Collapse All

The properties of SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption are listed here.

Public Properties
Public Property | Description
MidOrdinateTolerance | Gets the mid-ordinate tolerance based on a distance across the tessellated curve segments.
TessellateCurve | Gets whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
Collapse All

Gets the mid-ordinate tolerance based on a distance across the tessellated curve segments.

C#
public PropertyDouble MidOrdinateTolerance;
Visual Basic
Public Property MidOrdinateTolerance() As PropertyDouble
Links
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption::TessellateCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption::TessellateCurve Property
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption::TessellateCurve Property
Collapse All

Gets whether to tesselate curve segments if they are included as an input option.

C#
public PropertyBoolean TessellateCurve;
Visual Basic
Public Property TessellateCurve() As PropertyBoolean
Links
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class
Collapse All

Setting that specifies the default behavior for regression analysis graphs in best fit arc, line, and parabola creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption
C#
public class SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties, SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members, Class Hierarchy


SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Gets whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties
Collapse All

The properties of SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption are listed here.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Gets whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
Collapse All

Gets whether the regression graph displays splines on the green line that represents the best fit entity.

C#
public PropertyBoolean SplineFitForRegressionAnalysisGraph;
Visual Basic
Public Property SplineFitForRegressionAnalysisGraph() As PropertyBoolean
Links
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class, SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateProfileReference Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileReference Class
SettingsCmdCreateProfileReference Class
Collapse All

Settings for CreateProfileReference command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileReference
C#
public class SettingsCmdCreateProfileReference : SettingsProfile;
Visual Basic
Public Class SettingsCmdCreateProfileReference
Inherits SettingsProfile
Links
Class Hierarchy


SettingsCmdCreateProfileView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileView Class
SettingsCmdCreateProfileView Class
Collapse All

Settings for CreateProfileView command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileView
C#
public class SettingsCmdCreateProfileView : SettingsProfileView;
Visual Basic
Public Class SettingsCmdCreateProfileView
Inherits SettingsProfileView
Links
Class Hierarchy


SettingsCmdCreateQuickProfile Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class
SettingsCmdCreateQuickProfile Class
Collapse All

Settings for CreateQuickProfile command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateQuickProfile
C#
public class SettingsCmdCreateQuickProfile : SettingsProfile;
Visual Basic
Public Class SettingsCmdCreateQuickProfile
Inherits SettingsProfile
Links
SettingsCmdCreateQuickProfile Properties, SettingsCmdCreateQuickProfile Members, Class Hierarchy


SettingsCmdCreateQuickProfile Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Members
SettingsCmdCreateQuickProfile Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateQuickProfile.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
QuickProfile | Gets the default setting of quick profile.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateQuickProfile Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Properties
SettingsCmdCreateQuickProfile Properties
Collapse All

The properties of SettingsCmdCreateQuickProfile are listed here.

Public Properties
Public Property | Description
QuickProfile | Gets the default setting of quick profile.
Links
Public Properties


SettingsCmdCreateQuickProfile::QuickProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Properties > SettingsCmdCreateQuickProfile::QuickProfile Property
SettingsCmdCreateQuickProfile::QuickProfile Property
Collapse All

Gets the default setting of quick profile.

C#
public SettingsCmdQuickProfile QuickProfile;
Visual Basic
Public Property QuickProfile() As SettingsCmdQuickProfile
Links
SettingsCmdCreateQuickProfile Class, SettingsCmdCreateQuickProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class
Collapse All

Settings that specify the default settings for quick profile creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile
C#
public class SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile
Inherits TreeOidWrapper
Links
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties, SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members, Class Hierarchy


SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile.

Public Properties
Public Property | Description
Draw3DEntityProfile | Gets whether to include elevation data for the selected 3D entity in the quick profile.
SelectAllSurfaces | Gets whether to generate profiles of all surfaces in the drawing file in the quick profile.
Links
Public Properties


SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties
Collapse All

The properties of SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile are listed here.

Public Properties
Public Property | Description
Draw3DEntityProfile | Gets whether to include elevation data for the selected 3D entity in the quick profile.
SelectAllSurfaces | Gets whether to generate profiles of all surfaces in the drawing file in the quick profile.
Links
Public Properties


SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile::Draw3DEntityProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile::Draw3DEntityProfile Property
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile::Draw3DEntityProfile Property
Collapse All

Gets whether to include elevation data for the selected 3D entity in the quick profile.

C#
public PropertyBoolean Draw3DEntityProfile;
Visual Basic
Public Property Draw3DEntityProfile() As PropertyBoolean
Links
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class, SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile::SelectAllSurfaces Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile::SelectAllSurfaces Property
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile::SelectAllSurfaces Property
Collapse All

Gets whether to generate profiles of all surfaces in the drawing file in the quick profile.

C#
public PropertyBoolean SelectAllSurfaces;
Visual Basic
Public Property SelectAllSurfaces() As PropertyBoolean
Links
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class, SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class
SettingsCmdCreateSampleLines Class
Collapse All

Settings for CreateSampleLines command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSampleLine
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines
C#
public class SettingsCmdCreateSampleLines : SettingsSampleLine;
Visual Basic
Public Class SettingsCmdCreateSampleLines
Inherits SettingsSampleLine
Links
SettingsCmdCreateSampleLines Properties, SettingsCmdCreateSampleLines Members, Class Hierarchy


SettingsCmdCreateSampleLines Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Members
SettingsCmdCreateSampleLines Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSampleLines.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
AdditionalSampleControls | Gets the default setting of Additional Sample Controls.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Miscellaneous | Gets the default setting of Miscellaneous.
NameFormat | settings to specify the default name formats for sample line.
SamplingIncrements | Gets the default setting of Sampling Increments.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to sample line.
SwathWidths | Gets the default setting of swath widths.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSampleLines Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Properties
SettingsCmdCreateSampleLines Properties
Collapse All

The properties of SettingsCmdCreateSampleLines are listed here.

Public Properties
Public Property | Description
AdditionalSampleControls | Gets the default setting of Additional Sample Controls.
Miscellaneous | Gets the default setting of Miscellaneous.
SamplingIncrements | Gets the default setting of Sampling Increments.
SwathWidths | Gets the default setting of swath widths.
Links
Public Properties


SettingsCmdCreateSampleLines::AdditionalSampleControls Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Properties > SettingsCmdCreateSampleLines::AdditionalSampleControls Property
SettingsCmdCreateSampleLines::AdditionalSampleControls Property
Collapse All

Gets the default setting of Additional Sample Controls.

C#
public SettingsCmdAdditionalSampleControls AdditionalSampleControls;
Visual Basic
Public Property AdditionalSampleControls() As SettingsCmdAdditionalSampleControls
Links
SettingsCmdCreateSampleLines Class, SettingsCmdCreateSampleLines Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::Miscellaneous Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Properties > SettingsCmdCreateSampleLines::Miscellaneous Property
SettingsCmdCreateSampleLines::Miscellaneous Property
Collapse All

Gets the default setting of Miscellaneous.

C#
public SettingsCmdMiscellaneous Miscellaneous;
Visual Basic
Public Property Miscellaneous() As SettingsCmdMiscellaneous
Links
SettingsCmdCreateSampleLines Class, SettingsCmdCreateSampleLines Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SamplingIncrements Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Properties > SettingsCmdCreateSampleLines::SamplingIncrements Property
SettingsCmdCreateSampleLines::SamplingIncrements Property
Collapse All

Gets the default setting of Sampling Increments.

C#
public SettingsCmdSamplingIncrements SamplingIncrements;
Visual Basic
Public Property SamplingIncrements() As SettingsCmdSamplingIncrements
Links
SettingsCmdCreateSampleLines Class, SettingsCmdCreateSampleLines Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SwathWidths Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Properties > SettingsCmdCreateSampleLines::SwathWidths Property
SettingsCmdCreateSampleLines::SwathWidths Property
Collapse All

Gets the default setting of swath widths.

C#
public SettingsCmdSwathWidths SwathWidths;
Visual Basic
Public Property SwathWidths() As SettingsCmdSwathWidths
Links
SettingsCmdCreateSampleLines Class, SettingsCmdCreateSampleLines Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class
Collapse All

Settings that specify the default behavior for additional sample controls.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls
C#
public class SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls
Inherits TreeOidWrapper
Links
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties, SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members, Class Hierarchy


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls.

Public Properties
Public Property | Description
AtHorizontalGeometryPoints | Gets whether additional sample lines are created at horizontal geometry points.
AtRangeEnd | Gets whether a sample line is created at the beginning of the specified range.
AtRangeStart | Gets whether a sample line is created at the beginning of the specified range.
AtSuperelevationCriticalStations | Gets whether additional sample lines are created at superelevation critical stations within the current range.
EndRangeAtAlignmentEnd | Gets whether the sampling range ends at the end of the alignment.
StartRangeAtAlignmentStart | Gets whether the sampling range starts at the beginning of the alignment.
Links
Public Properties


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties
Collapse All

The properties of SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls are listed here.

Public Properties
Public Property | Description
AtHorizontalGeometryPoints | Gets whether additional sample lines are created at horizontal geometry points.
AtRangeEnd | Gets whether a sample line is created at the beginning of the specified range.
AtRangeStart | Gets whether a sample line is created at the beginning of the specified range.
AtSuperelevationCriticalStations | Gets whether additional sample lines are created at superelevation critical stations within the current range.
EndRangeAtAlignmentEnd | Gets whether the sampling range ends at the end of the alignment.
StartRangeAtAlignmentStart | Gets whether the sampling range starts at the beginning of the alignment.
Links
Public Properties


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtHorizontalGeometryPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtHorizontalGeometryPoints Property
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtHorizontalGeometryPoints Property
Collapse All

Gets whether additional sample lines are created at horizontal geometry points.

C#
public PropertyBoolean AtHorizontalGeometryPoints;
Visual Basic
Public Property AtHorizontalGeometryPoints() As PropertyBoolean
Links
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class, SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtRangeEnd Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtRangeEnd Property
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtRangeEnd Property
Collapse All

Gets whether a sample line is created at the beginning of the specified range.

C#
public PropertyBoolean AtRangeEnd;
Visual Basic
Public Property AtRangeEnd() As PropertyBoolean
Links
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class, SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtRangeStart Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtRangeStart Property
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtRangeStart Property
Collapse All

Gets whether a sample line is created at the beginning of the specified range.

C#
public PropertyBoolean AtRangeStart;
Visual Basic
Public Property AtRangeStart() As PropertyBoolean
Links
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class, SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtSuperelevationCriticalStations Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtSuperelevationCriticalStations Property
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtSuperelevationCriticalStations Property
Collapse All

Gets whether additional sample lines are created at superelevation critical stations within the current range.

C#
public PropertyBoolean AtSuperelevationCriticalStations;
Visual Basic
Public Property AtSuperelevationCriticalStations() As PropertyBoolean
Links
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class, SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::EndRangeAtAlignmentEnd Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::EndRangeAtAlignmentEnd Property
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::EndRangeAtAlignmentEnd Property
Collapse All

Gets whether the sampling range ends at the end of the alignment.

C#
public PropertyBoolean EndRangeAtAlignmentEnd;
Visual Basic
Public Property EndRangeAtAlignmentEnd() As PropertyBoolean
Links
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class, SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::StartRangeAtAlignmentStart Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::StartRangeAtAlignmentStart Property
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::StartRangeAtAlignmentStart Property
Collapse All

Gets whether the sampling range starts at the beginning of the alignment.

C#
public PropertyBoolean StartRangeAtAlignmentStart;
Visual Basic
Public Property StartRangeAtAlignmentStart() As PropertyBoolean
Links
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class, SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class
Collapse All

Setting that specifies miscellaneous default behavior for sample lines.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous
C#
public class SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous
Inherits TreeOidWrapper
Links
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties, SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members, Class Hierarchy


SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous.

Public Properties
Public Property | Description
LockTostation | Gets whether the sample lines update when the alignment geometry and properties change.
Links
Public Properties


SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties
Collapse All

The properties of SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous are listed here.

Public Properties
Public Property | Description
LockTostation | Gets whether the sample lines update when the alignment geometry and properties change.
Links
Public Properties


SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous::LockTostation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous::LockTostation Property
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous::LockTostation Property
Collapse All

Gets whether the sample lines update when the alignment geometry and properties change.

C#
public PropertyBoolean LockTostation;
Visual Basic
Public Property LockTostation() As PropertyBoolean
Links
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class, SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class
Collapse All

Settings that specify the default behavior for sampling increments.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements
C#
public class SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements
Inherits TreeOidWrapper
Links
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties, SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members, Class Hierarchy


SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements.

Public Properties
Public Property | Description
IncrementAlongCurves | Gets the sample increment distance along curves.
IncrementAlongSpirals | Gets the sample increment distance along spirals.
IncrementAlongTangents | Gets the sample increment distance along tangents.
UseSamplingIncrements | Gets whether sample lines are created at incremental stations along the alignment.
Links
Public Properties


SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties
Collapse All

The properties of SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements are listed here.

Public Properties
Public Property | Description
IncrementAlongCurves | Gets the sample increment distance along curves.
IncrementAlongSpirals | Gets the sample increment distance along spirals.
IncrementAlongTangents | Gets the sample increment distance along tangents.
UseSamplingIncrements | Gets whether sample lines are created at incremental stations along the alignment.
Links
Public Properties


SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongCurves Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongCurves Property
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongCurves Property
Collapse All

Gets the sample increment distance along curves.

C#
public PropertyDouble IncrementAlongCurves;
Visual Basic
Public Property IncrementAlongCurves() As PropertyDouble
Links
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class, SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongSpirals Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongSpirals Property
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongSpirals Property
Collapse All

Gets the sample increment distance along spirals.

C#
public PropertyDouble IncrementAlongSpirals;
Visual Basic
Public Property IncrementAlongSpirals() As PropertyDouble
Links
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class, SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongTangents Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongTangents Property
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongTangents Property
Collapse All

Gets the sample increment distance along tangents.

C#
public PropertyDouble IncrementAlongTangents;
Visual Basic
Public Property IncrementAlongTangents() As PropertyDouble
Links
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class, SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::UseSamplingIncrements Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::UseSamplingIncrements Property
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::UseSamplingIncrements Property
Collapse All

Gets whether sample lines are created at incremental stations along the alignment.

C#
public PropertyBoolean UseSamplingIncrements;
Visual Basic
Public Property UseSamplingIncrements() As PropertyBoolean
Links
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class, SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class
Collapse All

Settings that specify the default behavior for sample line swath width.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines::SettingsCmdSwathWidths
C#
public class SettingsCmdCreateSampleLines::SettingsCmdSwathWidths : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSampleLines::SettingsCmdSwathWidths
Inherits TreeOidWrapper
Links
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties, SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members, Class Hierarchy


SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSampleLines::SettingsCmdSwathWidths.

Public Properties
Public Property | Description
LeftSwathWidth | Gets the swath width to the left of the alignment.
RightSwathWidth | Gets the swath width to the right of the alignment.
Links
Public Properties


SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties
Collapse All

The properties of SettingsCmdCreateSampleLines::SettingsCmdSwathWidths are listed here.

Public Properties
Public Property | Description
LeftSwathWidth | Gets the swath width to the left of the alignment.
RightSwathWidth | Gets the swath width to the right of the alignment.
Links
Public Properties


SettingsCmdCreateSampleLines::SettingsCmdSwathWidths::LeftSwathWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths::LeftSwathWidth Property
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths::LeftSwathWidth Property
Collapse All

Gets the swath width to the left of the alignment.

C#
public PropertyDouble LeftSwathWidth;
Visual Basic
Public Property LeftSwathWidth() As PropertyDouble
Links
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class, SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSampleLines::SettingsCmdSwathWidths::RightSwathWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths::RightSwathWidth Property
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths::RightSwathWidth Property
Collapse All

Gets the swath width to the right of the alignment.

C#
public PropertyDouble RightSwathWidth;
Visual Basic
Public Property RightSwathWidth() As PropertyDouble
Links
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class, SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class
SettingsCmdCreateSectionView Class
Collapse All

Settings for CreateSectionView command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSectionView
C#
public class SettingsCmdCreateSectionView : SettingsSectionView;
Visual Basic
Public Class SettingsCmdCreateSectionView
Inherits SettingsSectionView
Links
SettingsCmdCreateSectionView Properties, SettingsCmdCreateSectionView Members, Class Hierarchy


SettingsCmdCreateSectionView Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Members
SettingsCmdCreateSectionView Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSectionView.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the template for naming the section view.
ProjectionLabelPlacement | settings to specify the default name formats for sample line.
SectionViewCreation | Gets the settings to establish the defaults assigned for section view creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to section view components
TableCreation | Specifies the table creation settings.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSectionView Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Properties
SettingsCmdCreateSectionView Properties
Collapse All

The properties of SettingsCmdCreateSectionView are listed here.

Public Properties
Public Property | Description
TableCreation | Specifies the table creation settings.
Links
Public Properties


SettingsCmdCreateSectionView::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Properties > SettingsCmdCreateSectionView::TableCreation Property
SettingsCmdCreateSectionView::TableCreation Property
Collapse All

Specifies the table creation settings.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdCreateSectionView Class, SettingsCmdCreateSectionView Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class
Collapse All

Settings for the table creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSectionView::SettingsCmdTableCreation
C#
public class SettingsCmdCreateSectionView::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSectionView::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdCreateSectionView::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Members
SettingsCmdCreateSectionView::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSectionView::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaterialVolumeTableStyle | Specifies the styles for a material table.
MaximumNumberOfRows | Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum,... more
MaximumTablesPerStack | Specifies the maximum number of sections to include in each stack.
SectionViewAnchor | Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableAnchor | Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
TableLayout | Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
TableSpacing | Specifies the spacing between tables.
TileDirection | Specifies the direction in which the table tiles (across or down).
TotalVolumeTableStyle | Specifies the style for a total volume table.
XOffset | Specifies the horizontal offset of the table.
YOffset | Specifies the vertical offset of the table.
Links
Public Properties


SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties
SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdCreateSectionView::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaterialVolumeTableStyle | Specifies the styles for a material table.
MaximumNumberOfRows | Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum,... more
MaximumTablesPerStack | Specifies the maximum number of sections to include in each stack.
SectionViewAnchor | Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableAnchor | Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
TableLayout | Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
TableSpacing | Specifies the spacing between tables.
TileDirection | Specifies the direction in which the table tiles (across or down).
TotalVolumeTableStyle | Specifies the style for a total volume table.
XOffset | Specifies the horizontal offset of the table.
YOffset | Specifies the vertical offset of the table.
Links
Public Properties


SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaterialVolumeTableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaterialVolumeTableStyle Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaterialVolumeTableStyle Property
Collapse All

Specifies the styles for a material table.

C#
public PropertyString MaterialVolumeTableStyle;
Visual Basic
Public Property MaterialVolumeTableStyle() As PropertyString
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of sections to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::SectionViewAnchor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::SectionViewAnchor Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::SectionViewAnchor Property
Collapse All

Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).

C#
public PropertyEnum<SectionViewAnchorType> SectionViewAnchor;
Visual Basic
Public Property SectionViewAnchor() As PropertyEnum<SectionViewAnchorType>
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::SplitTable Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableAnchor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableAnchor Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableAnchor Property
Collapse All

Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).

C#
public PropertyEnum<TableAnchorType> TableAnchor;
Visual Basic
Public Property TableAnchor() As PropertyEnum<TableAnchorType>
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableLayout Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableLayout Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableLayout Property
Collapse All

Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.

C#
public PropertyEnum<TableLayoutType> TableLayout;
Visual Basic
Public Property TableLayout() As PropertyEnum<TableLayoutType>
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::TileDirection Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (across or down).

C#
public PropertyEnum<TileDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<TileDirectionType>
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::TotalVolumeTableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::TotalVolumeTableStyle Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::TotalVolumeTableStyle Property
Collapse All

Specifies the style for a total volume table.

C#
public PropertyString TotalVolumeTableStyle;
Visual Basic
Public Property TotalVolumeTableStyle() As PropertyString
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::XOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::XOffset Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::XOffset Property
Collapse All

Specifies the horizontal offset of the table.

C#
public PropertyDouble XOffset;
Visual Basic
Public Property XOffset() As PropertyDouble
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSectionView::SettingsCmdTableCreation::YOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties > SettingsCmdCreateSectionView::SettingsCmdTableCreation::YOffset Property
SettingsCmdCreateSectionView::SettingsCmdTableCreation::YOffset Property
Collapse All

Specifies the vertical offset of the table.

C#
public PropertyDouble YOffset;
Visual Basic
Public Property YOffset() As PropertyDouble
Links
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class, SettingsCmdCreateSectionView::SettingsCmdTableCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class
SettingsCmdCreateSheets Class
Collapse All

Settings for CreateSheets command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsViewFrameGroup
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSheets
C#
public class SettingsCmdCreateSheets : SettingsViewFrameGroup;
Visual Basic
Public Class SettingsCmdCreateSheets
Inherits SettingsViewFrameGroup
Links
SettingsCmdCreateSheets Properties, SettingsCmdCreateSheets Members, Class Hierarchy


SettingsCmdCreateSheets Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Members
SettingsCmdCreateSheets Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSheets.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Information | Gets the default match line label location.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name formats for view frame group components.
SheetCreation | Gets the setting of sheet creation for the command CreateSheets.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to view frame group components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSheets Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Properties
SettingsCmdCreateSheets Properties
Collapse All

The properties of SettingsCmdCreateSheets are listed here.

Public Properties
Public Property | Description
SheetCreation | Gets the setting of sheet creation for the command CreateSheets.
Links
Public Properties


SettingsCmdCreateSheets::SheetCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Properties > SettingsCmdCreateSheets::SheetCreation Property
SettingsCmdCreateSheets::SheetCreation Property
Collapse All

Gets the setting of sheet creation for the command CreateSheets.

C#
public SettingsCmdSheetCreation SheetCreation;
Visual Basic
Public Property SheetCreation() As SettingsCmdSheetCreation
Links
SettingsCmdCreateSheets Class, SettingsCmdCreateSheets Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets::SettingsCmdSheetCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class
Collapse All

Settings for the sheet creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSheets::SettingsCmdSheetCreation
C#
public class SettingsCmdCreateSheets::SettingsCmdSheetCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSheets::SettingsCmdSheetCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Class Hierarchy


SettingsCmdCreateSheets::SettingsCmdSheetCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Members
SettingsCmdCreateSheets::SettingsCmdSheetCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSheets::SettingsCmdSheetCreation.

Public Properties
Public Property | Description
AddNetworkLabels | Specify whether to copy the pipe network labels to destination drawings.
AddToVault | Specify whether to add newly created files to Vault.
AlignNorthArrow | Specify whether to cause the chosen North arrow block to be aligned to North.
AlignProfileAndPlanViewType | Specify how to align profile and plan view.
ExistingSheetSetName | Specify the existing sheet set file where to add created sheet.
NorthArrowBlockName | Specify the block that will be rotated as the North arrow block.
NumberOfLayoutsPerDrawing | Specify the number of layouts to be created in each drawing.
SheetCreateMethod | Specify the sheet create method.
UseExistingSheetSet | Specify whether to use an existing one or create new sheet set.
Links
Public Properties


SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties
SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties
Collapse All

The properties of SettingsCmdCreateSheets::SettingsCmdSheetCreation are listed here.

Public Properties
Public Property | Description
AddNetworkLabels | Specify whether to copy the pipe network labels to destination drawings.
AddToVault | Specify whether to add newly created files to Vault.
AlignNorthArrow | Specify whether to cause the chosen North arrow block to be aligned to North.
AlignProfileAndPlanViewType | Specify how to align profile and plan view.
ExistingSheetSetName | Specify the existing sheet set file where to add created sheet.
NorthArrowBlockName | Specify the block that will be rotated as the North arrow block.
NumberOfLayoutsPerDrawing | Specify the number of layouts to be created in each drawing.
SheetCreateMethod | Specify the sheet create method.
UseExistingSheetSet | Specify whether to use an existing one or create new sheet set.
Links
Public Properties


SettingsCmdCreateSheets::SettingsCmdSheetCreation::AddNetworkLabels Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties > SettingsCmdCreateSheets::SettingsCmdSheetCreation::AddNetworkLabels Property
SettingsCmdCreateSheets::SettingsCmdSheetCreation::AddNetworkLabels Property
Collapse All

Specify whether to copy the pipe network labels to destination drawings.

C#
public PropertyBoolean AddNetworkLabels;
Visual Basic
Public Property AddNetworkLabels() As PropertyBoolean
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets::SettingsCmdSheetCreation::AddToVault Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties > SettingsCmdCreateSheets::SettingsCmdSheetCreation::AddToVault Property
SettingsCmdCreateSheets::SettingsCmdSheetCreation::AddToVault Property
Collapse All

Specify whether to add newly created files to Vault.

C#
public PropertyBoolean AddToVault;
Visual Basic
Public Property AddToVault() As PropertyBoolean
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets::SettingsCmdSheetCreation::AlignNorthArrow Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties > SettingsCmdCreateSheets::SettingsCmdSheetCreation::AlignNorthArrow Property
SettingsCmdCreateSheets::SettingsCmdSheetCreation::AlignNorthArrow Property
Collapse All

Specify whether to cause the chosen North arrow block to be aligned to North.

C#
public PropertyBoolean AlignNorthArrow;
Visual Basic
Public Property AlignNorthArrow() As PropertyBoolean
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets::SettingsCmdSheetCreation::AlignProfileAndPlanViewType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties > SettingsCmdCreateSheets::SettingsCmdSheetCreation::AlignProfileAndPlanViewType Property
SettingsCmdCreateSheets::SettingsCmdSheetCreation::AlignProfileAndPlanViewType Property
Collapse All

Specify how to align profile and plan view.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::PlanViewAlignType> AlignProfileAndPlanViewType;
Visual Basic
Public Property AlignProfileAndPlanViewType() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::PlanViewAlignType>
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets::SettingsCmdSheetCreation::ExistingSheetSetName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties > SettingsCmdCreateSheets::SettingsCmdSheetCreation::ExistingSheetSetName Property
SettingsCmdCreateSheets::SettingsCmdSheetCreation::ExistingSheetSetName Property
Collapse All

Specify the existing sheet set file where to add created sheet.

C#
public PropertyString ExistingSheetSetName;
Visual Basic
Public Property ExistingSheetSetName() As PropertyString
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets::SettingsCmdSheetCreation::NorthArrowBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties > SettingsCmdCreateSheets::SettingsCmdSheetCreation::NorthArrowBlockName Property
SettingsCmdCreateSheets::SettingsCmdSheetCreation::NorthArrowBlockName Property
Collapse All

Specify the block that will be rotated as the North arrow block.

C#
public PropertyString NorthArrowBlockName;
Visual Basic
Public Property NorthArrowBlockName() As PropertyString
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets::SettingsCmdSheetCreation::NumberOfLayoutsPerDrawing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties > SettingsCmdCreateSheets::SettingsCmdSheetCreation::NumberOfLayoutsPerDrawing Property
SettingsCmdCreateSheets::SettingsCmdSheetCreation::NumberOfLayoutsPerDrawing Property
Collapse All

Specify the number of layouts to be created in each drawing.

C#
public PropertyInt NumberOfLayoutsPerDrawing;
Visual Basic
Public Property NumberOfLayoutsPerDrawing() As PropertyInt
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets::SettingsCmdSheetCreation::SheetCreateMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties > SettingsCmdCreateSheets::SettingsCmdSheetCreation::SheetCreateMethod Property
SettingsCmdCreateSheets::SettingsCmdSheetCreation::SheetCreateMethod Property
Collapse All

Specify the sheet create method.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SheetCreateType> SheetCreateMethod;
Visual Basic
Public Property SheetCreateMethod() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SheetCreateType>
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSheets::SettingsCmdSheetCreation::UseExistingSheetSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties > SettingsCmdCreateSheets::SettingsCmdSheetCreation::UseExistingSheetSet Property
SettingsCmdCreateSheets::SettingsCmdSheetCreation::UseExistingSheetSet Property
Collapse All

Specify whether to use an existing one or create new sheet set.

C#
public PropertyBoolean UseExistingSheetSet;
Visual Basic
Public Property UseExistingSheetSet() As PropertyBoolean
Links
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class, SettingsCmdCreateSheets::SettingsCmdSheetCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class
SettingsCmdCreateSite Class
Collapse All

Settings for CreateSite command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSite
C#
public class SettingsCmdCreateSite : SettingsParcel;
Visual Basic
Public Class SettingsCmdCreateSite
Inherits SettingsParcel
Links
SettingsCmdCreateSite Properties, SettingsCmdCreateSite Members, Class Hierarchy


SettingsCmdCreateSite Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Members
SettingsCmdCreateSite Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSite.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Alignment | Gets the default setting of alignment for the command CreateSite.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLine | Gets the default setting of freature line for the command CreateSite.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Parcel | Gets the default setting of parcel for the command CreateSite.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSite Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Properties
SettingsCmdCreateSite Properties
Collapse All

The properties of SettingsCmdCreateSite are listed here.

Public Properties
Public Property | Description
Alignment | Gets the default setting of alignment for the command CreateSite.
FeatureLine | Gets the default setting of freature line for the command CreateSite.
Parcel | Gets the default setting of parcel for the command CreateSite.
Links
Public Properties


SettingsCmdCreateSite::Alignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Properties > SettingsCmdCreateSite::Alignment Property
SettingsCmdCreateSite::Alignment Property
Collapse All

Gets the default setting of alignment for the command CreateSite.

C#
public SettingsCmdAlignment Alignment;
Visual Basic
Public Property Alignment() As SettingsCmdAlignment
Links
SettingsCmdCreateSite Class, SettingsCmdCreateSite Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::FeatureLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Properties > SettingsCmdCreateSite::FeatureLine Property
SettingsCmdCreateSite::FeatureLine Property
Collapse All

Gets the default setting of freature line for the command CreateSite.

C#
public SettingsCmdFeatureLine FeatureLine;
Visual Basic
Public Property FeatureLine() As SettingsCmdFeatureLine
Links
SettingsCmdCreateSite Class, SettingsCmdCreateSite Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::Parcel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Properties > SettingsCmdCreateSite::Parcel Property
SettingsCmdCreateSite::Parcel Property
Collapse All

Gets the default setting of parcel for the command CreateSite.

C#
public SettingsCmdParcel Parcel;
Visual Basic
Public Property Parcel() As SettingsCmdParcel
Links
SettingsCmdCreateSite Class, SettingsCmdCreateSite Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdAlignment Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class
SettingsCmdCreateSite::SettingsCmdAlignment Class
Collapse All

Settings that specify default increments for alignment tag numbering.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSite::SettingsCmdAlignment
C#
public class SettingsCmdCreateSite::SettingsCmdAlignment : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSite::SettingsCmdAlignment
Inherits TreeOidWrapper
Links
SettingsCmdCreateSite::SettingsCmdAlignment Properties, SettingsCmdCreateSite::SettingsCmdAlignment Members, Class Hierarchy


SettingsCmdCreateSite::SettingsCmdAlignment Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Members
SettingsCmdCreateSite::SettingsCmdAlignment Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSite::SettingsCmdAlignment.

Public Properties
Public Property | Description
AlignmentCurveNextAutomaticTagCounter | Gets the increment by which the next new alignment curve tag is automatically numbered.
AlignmentCurveNextManualTagCounter | Gets the increment by which the next new alignment curve tag is manually numbered.
AlignmentLineNextAutomaticTagCounter | Gets the increment by which the next new alignment line tag is automatically numbered.
AlignmentLineNextManualTagCounter | Gets the increment by which the next new alignment line tag is manually numbered.
AlignmentSpiralNextAutomaticTagCounter | Gets the increment by which the next new alignment spiral tag is automatically numbered.
AlignmentSpiralNextManualTagCounter | Gets the increment by which the next new alignment spiral tag is manually numbered.
Links
Public Properties


SettingsCmdCreateSite::SettingsCmdAlignment Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Properties
SettingsCmdCreateSite::SettingsCmdAlignment Properties
Collapse All

The properties of SettingsCmdCreateSite::SettingsCmdAlignment are listed here.

Public Properties
Public Property | Description
AlignmentCurveNextAutomaticTagCounter | Gets the increment by which the next new alignment curve tag is automatically numbered.
AlignmentCurveNextManualTagCounter | Gets the increment by which the next new alignment curve tag is manually numbered.
AlignmentLineNextAutomaticTagCounter | Gets the increment by which the next new alignment line tag is automatically numbered.
AlignmentLineNextManualTagCounter | Gets the increment by which the next new alignment line tag is manually numbered.
AlignmentSpiralNextAutomaticTagCounter | Gets the increment by which the next new alignment spiral tag is automatically numbered.
AlignmentSpiralNextManualTagCounter | Gets the increment by which the next new alignment spiral tag is manually numbered.
Links
Public Properties


SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentCurveNextAutomaticTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Properties > SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentCurveNextAutomaticTagCounter Property
SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentCurveNextAutomaticTagCounter Property
Collapse All

Gets the increment by which the next new alignment curve tag is automatically numbered.

C#
public PropertyInt AlignmentCurveNextAutomaticTagCounter;
Visual Basic
Public Property AlignmentCurveNextAutomaticTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdAlignment Class, SettingsCmdCreateSite::SettingsCmdAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentCurveNextManualTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Properties > SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentCurveNextManualTagCounter Property
SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentCurveNextManualTagCounter Property
Collapse All

Gets the increment by which the next new alignment curve tag is manually numbered.

C#
public PropertyInt AlignmentCurveNextManualTagCounter;
Visual Basic
Public Property AlignmentCurveNextManualTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdAlignment Class, SettingsCmdCreateSite::SettingsCmdAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentLineNextAutomaticTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Properties > SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentLineNextAutomaticTagCounter Property
SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentLineNextAutomaticTagCounter Property
Collapse All

Gets the increment by which the next new alignment line tag is automatically numbered.

C#
public PropertyInt AlignmentLineNextAutomaticTagCounter;
Visual Basic
Public Property AlignmentLineNextAutomaticTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdAlignment Class, SettingsCmdCreateSite::SettingsCmdAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentLineNextManualTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Properties > SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentLineNextManualTagCounter Property
SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentLineNextManualTagCounter Property
Collapse All

Gets the increment by which the next new alignment line tag is manually numbered.

C#
public PropertyInt AlignmentLineNextManualTagCounter;
Visual Basic
Public Property AlignmentLineNextManualTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdAlignment Class, SettingsCmdCreateSite::SettingsCmdAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentSpiralNextAutomaticTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Properties > SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentSpiralNextAutomaticTagCounter Property
SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentSpiralNextAutomaticTagCounter Property
Collapse All

Gets the increment by which the next new alignment spiral tag is automatically numbered.

C#
public PropertyInt AlignmentSpiralNextAutomaticTagCounter;
Visual Basic
Public Property AlignmentSpiralNextAutomaticTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdAlignment Class, SettingsCmdCreateSite::SettingsCmdAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentSpiralNextManualTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Properties > SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentSpiralNextManualTagCounter Property
SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentSpiralNextManualTagCounter Property
Collapse All

Gets the increment by which the next new alignment spiral tag is manually numbered.

C#
public PropertyInt AlignmentSpiralNextManualTagCounter;
Visual Basic
Public Property AlignmentSpiralNextManualTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdAlignment Class, SettingsCmdCreateSite::SettingsCmdAlignment Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdFeatureLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdFeatureLine Class
SettingsCmdCreateSite::SettingsCmdFeatureLine Class
Collapse All

Settings that specify defaults for feature line style priority.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSite::SettingsCmdFeatureLine
C#
public class SettingsCmdCreateSite::SettingsCmdFeatureLine : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSite::SettingsCmdFeatureLine
Inherits TreeOidWrapper
Links
SettingsCmdCreateSite::SettingsCmdFeatureLine Properties, SettingsCmdCreateSite::SettingsCmdFeatureLine Members, Class Hierarchy


SettingsCmdCreateSite::SettingsCmdFeatureLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdFeatureLine Class > SettingsCmdCreateSite::SettingsCmdFeatureLine Members
SettingsCmdCreateSite::SettingsCmdFeatureLine Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSite::SettingsCmdFeatureLine.

Public Properties
Public Property | Description
FeatureLineStyle | Gets the default feature line style priority.
Links
Public Properties


SettingsCmdCreateSite::SettingsCmdFeatureLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdFeatureLine Class > SettingsCmdCreateSite::SettingsCmdFeatureLine Properties
SettingsCmdCreateSite::SettingsCmdFeatureLine Properties
Collapse All

The properties of SettingsCmdCreateSite::SettingsCmdFeatureLine are listed here.

Public Properties
Public Property | Description
FeatureLineStyle | Gets the default feature line style priority.
Links
Public Properties


SettingsCmdCreateSite::SettingsCmdFeatureLine::FeatureLineStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdFeatureLine Class > SettingsCmdCreateSite::SettingsCmdFeatureLine Properties > SettingsCmdCreateSite::SettingsCmdFeatureLine::FeatureLineStyle Property
SettingsCmdCreateSite::SettingsCmdFeatureLine::FeatureLineStyle Property
Collapse All

Gets the default feature line style priority.

C#
public PropertyFeatureLineStylePriority FeatureLineStyle;
Visual Basic
Public Property FeatureLineStyle() As PropertyFeatureLineStylePriority
Links
SettingsCmdCreateSite::SettingsCmdFeatureLine Class, SettingsCmdCreateSite::SettingsCmdFeatureLine Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdParcel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class
SettingsCmdCreateSite::SettingsCmdParcel Class
Collapse All

Settings that specify default increments for parcel numbering.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSite::SettingsCmdParcel
C#
public class SettingsCmdCreateSite::SettingsCmdParcel : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSite::SettingsCmdParcel
Inherits TreeOidWrapper
Links
SettingsCmdCreateSite::SettingsCmdParcel Properties, SettingsCmdCreateSite::SettingsCmdParcel Members, Class Hierarchy


SettingsCmdCreateSite::SettingsCmdParcel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Members
SettingsCmdCreateSite::SettingsCmdParcel Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSite::SettingsCmdParcel.

Public Properties
Public Property | Description
ParcelCurveNextAutomaticTagCounter | Gets the increment by which the next new parcel line tag is manually numbered.
ParcelCurveNextManualTagCounter | Gets the increment by which the next new parcel curve tag is manually numbered.
ParcelLineNextAutomaticTagCounter | Gets the increment by which the next new parcel line tag is automatically numbered.
ParcelLineNextManualTagCounter | Gets the increment by which the next new parcel line tag is manually numbered.
ParcelNextAutomaticAreaCounter | Gets the increment by which the next new parcel area is automatically numbered.
ParcelNextManualAreaCounter | Gets the increment by which the next new parcel area is manually numbered.
Links
Public Properties


SettingsCmdCreateSite::SettingsCmdParcel Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Properties
SettingsCmdCreateSite::SettingsCmdParcel Properties
Collapse All

The properties of SettingsCmdCreateSite::SettingsCmdParcel are listed here.

Public Properties
Public Property | Description
ParcelCurveNextAutomaticTagCounter | Gets the increment by which the next new parcel line tag is manually numbered.
ParcelCurveNextManualTagCounter | Gets the increment by which the next new parcel curve tag is manually numbered.
ParcelLineNextAutomaticTagCounter | Gets the increment by which the next new parcel line tag is automatically numbered.
ParcelLineNextManualTagCounter | Gets the increment by which the next new parcel line tag is manually numbered.
ParcelNextAutomaticAreaCounter | Gets the increment by which the next new parcel area is automatically numbered.
ParcelNextManualAreaCounter | Gets the increment by which the next new parcel area is manually numbered.
Links
Public Properties


SettingsCmdCreateSite::SettingsCmdParcel::ParcelCurveNextAutomaticTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Properties > SettingsCmdCreateSite::SettingsCmdParcel::ParcelCurveNextAutomaticTagCounter Property
SettingsCmdCreateSite::SettingsCmdParcel::ParcelCurveNextAutomaticTagCounter Property
Collapse All

Gets the increment by which the next new parcel line tag is manually numbered.

C#
public PropertyInt ParcelCurveNextAutomaticTagCounter;
Visual Basic
Public Property ParcelCurveNextAutomaticTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdParcel Class, SettingsCmdCreateSite::SettingsCmdParcel Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdParcel::ParcelCurveNextManualTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Properties > SettingsCmdCreateSite::SettingsCmdParcel::ParcelCurveNextManualTagCounter Property
SettingsCmdCreateSite::SettingsCmdParcel::ParcelCurveNextManualTagCounter Property
Collapse All

Gets the increment by which the next new parcel curve tag is manually numbered.

C#
public PropertyInt ParcelCurveNextManualTagCounter;
Visual Basic
Public Property ParcelCurveNextManualTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdParcel Class, SettingsCmdCreateSite::SettingsCmdParcel Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdParcel::ParcelLineNextAutomaticTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Properties > SettingsCmdCreateSite::SettingsCmdParcel::ParcelLineNextAutomaticTagCounter Property
SettingsCmdCreateSite::SettingsCmdParcel::ParcelLineNextAutomaticTagCounter Property
Collapse All

Gets the increment by which the next new parcel line tag is automatically numbered.

C#
public PropertyInt ParcelLineNextAutomaticTagCounter;
Visual Basic
Public Property ParcelLineNextAutomaticTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdParcel Class, SettingsCmdCreateSite::SettingsCmdParcel Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdParcel::ParcelLineNextManualTagCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Properties > SettingsCmdCreateSite::SettingsCmdParcel::ParcelLineNextManualTagCounter Property
SettingsCmdCreateSite::SettingsCmdParcel::ParcelLineNextManualTagCounter Property
Collapse All

Gets the increment by which the next new parcel line tag is manually numbered.

C#
public PropertyInt ParcelLineNextManualTagCounter;
Visual Basic
Public Property ParcelLineNextManualTagCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdParcel Class, SettingsCmdCreateSite::SettingsCmdParcel Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdParcel::ParcelNextAutomaticAreaCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Properties > SettingsCmdCreateSite::SettingsCmdParcel::ParcelNextAutomaticAreaCounter Property
SettingsCmdCreateSite::SettingsCmdParcel::ParcelNextAutomaticAreaCounter Property
Collapse All

Gets the increment by which the next new parcel area is automatically numbered.

C#
public PropertyInt ParcelNextAutomaticAreaCounter;
Visual Basic
Public Property ParcelNextAutomaticAreaCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdParcel Class, SettingsCmdCreateSite::SettingsCmdParcel Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSite::SettingsCmdParcel::ParcelNextManualAreaCounter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Properties > SettingsCmdCreateSite::SettingsCmdParcel::ParcelNextManualAreaCounter Property
SettingsCmdCreateSite::SettingsCmdParcel::ParcelNextManualAreaCounter Property
Collapse All

Gets the increment by which the next new parcel area is manually numbered.

C#
public PropertyInt ParcelNextManualAreaCounter;
Visual Basic
Public Property ParcelNextManualAreaCounter() As PropertyInt
Links
SettingsCmdCreateSite::SettingsCmdParcel Class, SettingsCmdCreateSite::SettingsCmdParcel Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class
SettingsCmdCreateSurface Class
Collapse All

Settings for CreateSurface command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface
C#
public class SettingsCmdCreateSurface : SettingsSurface;
Visual Basic
Public Class SettingsCmdCreateSurface
Inherits SettingsSurface
Links
SettingsCmdCreateSurface Properties, SettingsCmdCreateSurface Members, Class Hierarchy


SettingsCmdCreateSurface Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Members
SettingsCmdCreateSurface Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurface.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
BuildOptions | Gets the defaults assigned when creating surfaces.
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default surface name format settings.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
SurfaceCreation | Gets the defaults assigned when creating surfaces.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSurface Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Properties
SettingsCmdCreateSurface Properties
Collapse All

The properties of SettingsCmdCreateSurface are listed here.

Public Properties
Public Property | Description
BuildOptions | Gets the defaults assigned when creating surfaces.
NameFormat | Gets the default surface name format settings.
SurfaceCreation | Gets the defaults assigned when creating surfaces.
Links
Public Properties


SettingsCmdCreateSurface::BuildOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Properties > SettingsCmdCreateSurface::BuildOptions Property
SettingsCmdCreateSurface::BuildOptions Property
Collapse All

Gets the defaults assigned when creating surfaces.

C#
public SettingCmdBuildOptions BuildOptions;
Visual Basic
Public Property BuildOptions() As SettingCmdBuildOptions
Links
SettingsCmdCreateSurface Class, SettingsCmdCreateSurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Properties > SettingsCmdCreateSurface::NameFormat Property
SettingsCmdCreateSurface::NameFormat Property
Collapse All

Gets the default surface name format settings.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsCmdCreateSurface Class, SettingsCmdCreateSurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SurfaceCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Properties > SettingsCmdCreateSurface::SurfaceCreation Property
SettingsCmdCreateSurface::SurfaceCreation Property
Collapse All

Gets the defaults assigned when creating surfaces.

C#
public SettingCmdSurfaceCreation SurfaceCreation;
Visual Basic
Public Property SurfaceCreation() As SettingCmdSurfaceCreation
Links
SettingsCmdCreateSurface Class, SettingsCmdCreateSurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class
SettingsCmdCreateSurface::SettingCmdBuildOptions Class
Collapse All

Settings that specify the build options assigned when creating surfaces.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface::SettingCmdBuildOptions
C#
public class SettingsCmdCreateSurface::SettingCmdBuildOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSurface::SettingCmdBuildOptions
Inherits TreeOidWrapper
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Properties, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Class Hierarchy


SettingsCmdCreateSurface::SettingCmdBuildOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Members
SettingsCmdCreateSurface::SettingCmdBuildOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurface::SettingCmdBuildOptions.

Public Properties
Public Property | Description
AllowCrossingBreaklines | Gets whether breaklines can cross each other.
ConvertProximityBreaklinesToStandard | Gets whether proximity breaklines are converted to standard breaklines when the surface is built.
CopyDeletedDependentObjects | Gets whether a drawing object is copied to the surface definition item if the object is deleted.
ElevationGreaterThan | Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.
ElevationLessThan | Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.
ElevationToUse | Gets the elevation to use for the crossing breaklines.
ExcludeElevationsGreaterThan | Gets whether an elevation greater than a certain value should be excluded when the surface is built.
ExcludeElevationsLessThan | Gets whether an elevation less than a certain value should be excluded when the surface is built.
MaximumTriangleLength | Gets the triangle length to use when the Use Maximum Triangle Length property is set to Yes.
UseMaximumTriangleLength | Gets whether the surface triangles that exceed the length specified by the Maximum Triangle Length property are removed from the... more
Links
Public Properties


SettingsCmdCreateSurface::SettingCmdBuildOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties
SettingsCmdCreateSurface::SettingCmdBuildOptions Properties
Collapse All

The properties of SettingsCmdCreateSurface::SettingCmdBuildOptions are listed here.

Public Properties
Public Property | Description
AllowCrossingBreaklines | Gets whether breaklines can cross each other.
ConvertProximityBreaklinesToStandard | Gets whether proximity breaklines are converted to standard breaklines when the surface is built.
CopyDeletedDependentObjects | Gets whether a drawing object is copied to the surface definition item if the object is deleted.
ElevationGreaterThan | Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.
ElevationLessThan | Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.
ElevationToUse | Gets the elevation to use for the crossing breaklines.
ExcludeElevationsGreaterThan | Gets whether an elevation greater than a certain value should be excluded when the surface is built.
ExcludeElevationsLessThan | Gets whether an elevation less than a certain value should be excluded when the surface is built.
MaximumTriangleLength | Gets the triangle length to use when the Use Maximum Triangle Length property is set to Yes.
UseMaximumTriangleLength | Gets whether the surface triangles that exceed the length specified by the Maximum Triangle Length property are removed from the... more
Links
Public Properties


SettingsCmdCreateSurface::SettingCmdBuildOptions::AllowCrossingBreaklines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::AllowCrossingBreaklines Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::AllowCrossingBreaklines Property
Collapse All

Gets whether breaklines can cross each other.

C#
public PropertyBoolean AllowCrossingBreaklines;
Visual Basic
Public Property AllowCrossingBreaklines() As PropertyBoolean
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions::ConvertProximityBreaklinesToStandard Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::ConvertProximityBreaklinesToStandard Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::ConvertProximityBreaklinesToStandard Property
Collapse All

Gets whether proximity breaklines are converted to standard breaklines when the surface is built.

C#
public PropertyBoolean ConvertProximityBreaklinesToStandard;
Visual Basic
Public Property ConvertProximityBreaklinesToStandard() As PropertyBoolean
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions::CopyDeletedDependentObjects Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::CopyDeletedDependentObjects Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::CopyDeletedDependentObjects Property
Collapse All

Gets whether a drawing object is copied to the surface definition item if the object is deleted.

C#
public PropertyBoolean CopyDeletedDependentObjects;
Visual Basic
Public Property CopyDeletedDependentObjects() As PropertyBoolean
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationGreaterThan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationGreaterThan Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationGreaterThan Property
Collapse All

Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.

C#
public PropertyDouble ElevationGreaterThan;
Visual Basic
Public Property ElevationGreaterThan() As PropertyDouble
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationLessThan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationLessThan Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationLessThan Property
Collapse All

Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.

C#
public PropertyDouble ElevationLessThan;
Visual Basic
Public Property ElevationLessThan() As PropertyDouble
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationToUse Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationToUse Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationToUse Property
Collapse All

Gets the elevation to use for the crossing breaklines.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::ElevationToUseType> ElevationToUse;
Visual Basic
Public Property ElevationToUse() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::ElevationToUseType>
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions::ExcludeElevationsGreaterThan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::ExcludeElevationsGreaterThan Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::ExcludeElevationsGreaterThan Property
Collapse All

Gets whether an elevation greater than a certain value should be excluded when the surface is built.

C#
public PropertyBoolean ExcludeElevationsGreaterThan;
Visual Basic
Public Property ExcludeElevationsGreaterThan() As PropertyBoolean
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions::ExcludeElevationsLessThan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::ExcludeElevationsLessThan Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::ExcludeElevationsLessThan Property
Collapse All

Gets whether an elevation less than a certain value should be excluded when the surface is built.

C#
public PropertyBoolean ExcludeElevationsLessThan;
Visual Basic
Public Property ExcludeElevationsLessThan() As PropertyBoolean
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions::MaximumTriangleLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::MaximumTriangleLength Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::MaximumTriangleLength Property
Collapse All

Gets the triangle length to use when the Use Maximum Triangle Length property is set to Yes.

C#
public PropertyDouble MaximumTriangleLength;
Visual Basic
Public Property MaximumTriangleLength() As PropertyDouble
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdBuildOptions::UseMaximumTriangleLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties > SettingsCmdCreateSurface::SettingCmdBuildOptions::UseMaximumTriangleLength Property
SettingsCmdCreateSurface::SettingCmdBuildOptions::UseMaximumTriangleLength Property
Collapse All

Gets whether the surface triangles that exceed the length specified by the Maximum Triangle Length property are removed from the boundary of the surface.

C#
public PropertyBoolean UseMaximumTriangleLength;
Visual Basic
Public Property UseMaximumTriangleLength() As PropertyBoolean
Links
SettingsCmdCreateSurface::SettingCmdBuildOptions Class, SettingsCmdCreateSurface::SettingCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class
Collapse All

Settings that specify the defaults assigned when creating surfaces.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface::SettingCmdSurfaceCreation
C#
public class SettingsCmdCreateSurface::SettingCmdSurfaceCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSurface::SettingCmdSurfaceCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties, SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members, Class Hierarchy


SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurface::SettingCmdSurfaceCreation.

Public Properties
Public Property | Description
CutFactor | Gets the cut factor.
DefaultType | Gets the default surface type that is used when creating a surface.
FillFactor | Gets the fill factor.
GridSurfaceOrientation | Gets the default orientation for a grid.
GridSurfaceXSpacing | Gets the default value for a grid surfaces X spacing.
GridSurfaceYSpacing | Gets the default value for a grid surfaces Y spacing.
Links
Public Properties


SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties
Collapse All

The properties of SettingsCmdCreateSurface::SettingCmdSurfaceCreation are listed here.

Public Properties
Public Property | Description
CutFactor | Gets the cut factor.
DefaultType | Gets the default surface type that is used when creating a surface.
FillFactor | Gets the fill factor.
GridSurfaceOrientation | Gets the default orientation for a grid.
GridSurfaceXSpacing | Gets the default value for a grid surfaces X spacing.
GridSurfaceYSpacing | Gets the default value for a grid surfaces Y spacing.
Links
Public Properties


SettingsCmdCreateSurface::SettingCmdSurfaceCreation::CutFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties > SettingsCmdCreateSurface::SettingCmdSurfaceCreation::CutFactor Property
SettingsCmdCreateSurface::SettingCmdSurfaceCreation::CutFactor Property
Collapse All

Gets the cut factor.

C#
public PropertyDouble CutFactor;
Visual Basic
Public Property CutFactor() As PropertyDouble
Links
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class, SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdSurfaceCreation::DefaultType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties > SettingsCmdCreateSurface::SettingCmdSurfaceCreation::DefaultType Property
SettingsCmdCreateSurface::SettingCmdSurfaceCreation::DefaultType Property
Collapse All

Gets the default surface type that is used when creating a surface.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SurfaceType> DefaultType;
Visual Basic
Public Property DefaultType() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SurfaceType>
Links
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class, SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdSurfaceCreation::FillFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties > SettingsCmdCreateSurface::SettingCmdSurfaceCreation::FillFactor Property
SettingsCmdCreateSurface::SettingCmdSurfaceCreation::FillFactor Property
Collapse All

Gets the fill factor.

C#
public PropertyDouble FillFactor;
Visual Basic
Public Property FillFactor() As PropertyDouble
Links
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class, SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceOrientation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties > SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceOrientation Property
SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceOrientation Property
Collapse All

Gets the default orientation for a grid.

C#
public PropertyDouble GridSurfaceOrientation;
Visual Basic
Public Property GridSurfaceOrientation() As PropertyDouble
Links
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class, SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceXSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties > SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceXSpacing Property
SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceXSpacing Property
Collapse All

Gets the default value for a grid surfaces X spacing.

C#
public PropertyDouble GridSurfaceXSpacing;
Visual Basic
Public Property GridSurfaceXSpacing() As PropertyDouble
Links
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class, SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceYSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties > SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceYSpacing Property
SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceYSpacing Property
Collapse All

Gets the default value for a grid surfaces Y spacing.

C#
public PropertyDouble GridSurfaceYSpacing;
Visual Basic
Public Property GridSurfaceYSpacing() As PropertyDouble
Links
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class, SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurface::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingsNameFormat Class
SettingsCmdCreateSurface::SettingsNameFormat Class
Collapse All

Settings that specify name format for the command.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface::SettingsNameFormat
C#
public class SettingsCmdCreateSurface::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSurface::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsCmdCreateSurface::SettingsNameFormat Properties, SettingsCmdCreateSurface::SettingsNameFormat Members, Class Hierarchy


SettingsCmdCreateSurface::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingsNameFormat Class > SettingsCmdCreateSurface::SettingsNameFormat Members
SettingsCmdCreateSurface::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurface::SettingsNameFormat.

Public Properties
Public Property | Description
Surface | Gets the default maintain edges setting.
Links
Public Properties


SettingsCmdCreateSurface::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingsNameFormat Class > SettingsCmdCreateSurface::SettingsNameFormat Properties
SettingsCmdCreateSurface::SettingsNameFormat Properties
Collapse All

The properties of SettingsCmdCreateSurface::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
Surface | Gets the default maintain edges setting.
Links
Public Properties


SettingsCmdCreateSurface::SettingsNameFormat::Surface Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingsNameFormat Class > SettingsCmdCreateSurface::SettingsNameFormat Properties > SettingsCmdCreateSurface::SettingsNameFormat::Surface Property
SettingsCmdCreateSurface::SettingsNameFormat::Surface Property
Collapse All

Gets the default maintain edges setting.

C#
public PropertyString Surface;
Visual Basic
Public Property Surface() As PropertyString
Links
SettingsCmdCreateSurface::SettingsNameFormat Class, SettingsCmdCreateSurface::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceFromTIN Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceFromTIN Class
SettingsCmdCreateSurfaceFromTIN Class
Collapse All

Settings for CreateSurfaceFromTIN command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceFromTIN
C#
public class SettingsCmdCreateSurfaceFromTIN : SettingsSurface;
Visual Basic
Public Class SettingsCmdCreateSurfaceFromTIN
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdCreateSurfaceGridFromDEM Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class
SettingsCmdCreateSurfaceGridFromDEM Class
Collapse All

Settings for CreateSurfaceGridFromDEM command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceGridFromDEM
C#
public class SettingsCmdCreateSurfaceGridFromDEM : SettingsSurface;
Visual Basic
Public Class SettingsCmdCreateSurfaceGridFromDEM
Inherits SettingsSurface
Links
SettingsCmdCreateSurfaceGridFromDEM Properties, SettingsCmdCreateSurfaceGridFromDEM Members, Class Hierarchy


SettingsCmdCreateSurfaceGridFromDEM Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Members
SettingsCmdCreateSurfaceGridFromDEM Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurfaceGridFromDEM.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
BuildOptions | Gets the build options assigned when creating surfaces.
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
ImportOptions | Gets the defaults assigned when creating surfaces.
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSurfaceGridFromDEM Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Properties
SettingsCmdCreateSurfaceGridFromDEM Properties
Collapse All

The properties of SettingsCmdCreateSurfaceGridFromDEM are listed here.

Public Properties
Public Property | Description
BuildOptions | Gets the build options assigned when creating surfaces.
ImportOptions | Gets the defaults assigned when creating surfaces.
Links
Public Properties


SettingsCmdCreateSurfaceGridFromDEM::BuildOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Properties > SettingsCmdCreateSurfaceGridFromDEM::BuildOptions Property
SettingsCmdCreateSurfaceGridFromDEM::BuildOptions Property
Collapse All

Gets the build options assigned when creating surfaces.

C#
public SettingsCmdBuildOptions BuildOptions;
Visual Basic
Public Property BuildOptions() As SettingsCmdBuildOptions
Links
SettingsCmdCreateSurfaceGridFromDEM Class, SettingsCmdCreateSurfaceGridFromDEM Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceGridFromDEM::ImportOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Properties > SettingsCmdCreateSurfaceGridFromDEM::ImportOptions Property
SettingsCmdCreateSurfaceGridFromDEM::ImportOptions Property
Collapse All

Gets the defaults assigned when creating surfaces.

C#
public SettingsCmdImportOptions ImportOptions;
Visual Basic
Public Property ImportOptions() As SettingsCmdImportOptions
Links
SettingsCmdCreateSurfaceGridFromDEM Class, SettingsCmdCreateSurfaceGridFromDEM Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class
Collapse All

Settings that specify the build options assigned when creating surfaces.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions
C#
public class SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions
Inherits TreeOidWrapper
Links
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties, SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members, Class Hierarchy


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions.

Public Properties
Public Property | Description
CopyDeletedDependentObjects | Gets whether a drawing object is copied to the surface definition item if the object is deleted.
ElevationGreaterThan | Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.
ElevationLessThan | Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.
ExcludeElevationsGreaterThan | Gets whether an elevation greater than a certain value should be excluded when the surface is built.
ExcludeElevationsLessThan | Gets whether an elevation less than a certain value should be excluded when the surface is built.
Links
Public Properties


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties
Collapse All

The properties of SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions are listed here.

Public Properties
Public Property | Description
CopyDeletedDependentObjects | Gets whether a drawing object is copied to the surface definition item if the object is deleted.
ElevationGreaterThan | Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.
ElevationLessThan | Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.
ExcludeElevationsGreaterThan | Gets whether an elevation greater than a certain value should be excluded when the surface is built.
ExcludeElevationsLessThan | Gets whether an elevation less than a certain value should be excluded when the surface is built.
Links
Public Properties


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::CopyDeletedDependentObjects Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::CopyDeletedDependentObjects Property
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::CopyDeletedDependentObjects Property
Collapse All

Gets whether a drawing object is copied to the surface definition item if the object is deleted.

C#
public PropertyBoolean CopyDeletedDependentObjects;
Visual Basic
Public Property CopyDeletedDependentObjects() As PropertyBoolean
Links
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class, SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ElevationGreaterThan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ElevationGreaterThan Property
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ElevationGreaterThan Property
Collapse All

Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.

C#
public PropertyDouble ElevationGreaterThan;
Visual Basic
Public Property ElevationGreaterThan() As PropertyDouble
Links
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class, SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ElevationLessThan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ElevationLessThan Property
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ElevationLessThan Property
Collapse All

Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.

C#
public PropertyDouble ElevationLessThan;
Visual Basic
Public Property ElevationLessThan() As PropertyDouble
Links
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class, SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ExcludeElevationsGreaterThan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ExcludeElevationsGreaterThan Property
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ExcludeElevationsGreaterThan Property
Collapse All

Gets whether an elevation greater than a certain value should be excluded when the surface is built.

C#
public PropertyBoolean ExcludeElevationsGreaterThan;
Visual Basic
Public Property ExcludeElevationsGreaterThan() As PropertyBoolean
Links
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class, SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ExcludeElevationsLessThan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ExcludeElevationsLessThan Property
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ExcludeElevationsLessThan Property
Collapse All

Gets whether an elevation less than a certain value should be excluded when the surface is built.

C#
public PropertyBoolean ExcludeElevationsLessThan;
Visual Basic
Public Property ExcludeElevationsLessThan() As PropertyBoolean
Links
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class, SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class
Collapse All

Settings that specify the defaults assigned when creating surfaces.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions
C#
public class SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions
Inherits TreeOidWrapper
Links
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties, SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members, Class Hierarchy


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions.

Public Properties
Public Property | Description
NullElevation | Gets null elevation.
UseCustomNullElevation | Gets whether use custom null elevation.
Links
Public Properties


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties
Collapse All

The properties of SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions are listed here.

Public Properties
Public Property | Description
NullElevation | Gets null elevation.
UseCustomNullElevation | Gets whether use custom null elevation.
Links
Public Properties


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions::NullElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions::NullElevation Property
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions::NullElevation Property
Collapse All

Gets null elevation.

C#
public PropertyDouble NullElevation;
Visual Basic
Public Property NullElevation() As PropertyDouble
Links
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class, SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions::UseCustomNullElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions::UseCustomNullElevation Property
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions::UseCustomNullElevation Property
Collapse All

Gets whether use custom null elevation.

C#
public PropertyBoolean UseCustomNullElevation;
Visual Basic
Public Property UseCustomNullElevation() As PropertyBoolean
Links
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class, SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceReference Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class
SettingsCmdCreateSurfaceReference Class
Collapse All

Settings for CreateSurfaceReference command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceReference
C#
public class SettingsCmdCreateSurfaceReference : SettingsSurface;
Visual Basic
Public Class SettingsCmdCreateSurfaceReference
Inherits SettingsSurface
Links
SettingsCmdCreateSurfaceReference Properties, SettingsCmdCreateSurfaceReference Members, Class Hierarchy


SettingsCmdCreateSurfaceReference Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Members
SettingsCmdCreateSurfaceReference Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurfaceReference.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default surface name format settings.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSurfaceReference Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Properties
SettingsCmdCreateSurfaceReference Properties
Collapse All

The properties of SettingsCmdCreateSurfaceReference are listed here.

Public Properties
Public Property | Description
NameFormat | Gets the default surface name format settings.
Links
Public Properties


SettingsCmdCreateSurfaceReference::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Properties > SettingsCmdCreateSurfaceReference::NameFormat Property
SettingsCmdCreateSurfaceReference::NameFormat Property
Collapse All

Gets the default surface name format settings.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsCmdCreateSurfaceReference Class, SettingsCmdCreateSurfaceReference Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceWaterdrop Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class
SettingsCmdCreateSurfaceWaterdrop Class
Collapse All

Settings for CreateSurfaceWaterdrop command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceWaterdrop
C#
public class SettingsCmdCreateSurfaceWaterdrop : SettingsSurface;
Visual Basic
Public Class SettingsCmdCreateSurfaceWaterdrop
Inherits SettingsSurface
Links
SettingsCmdCreateSurfaceWaterdrop Properties, SettingsCmdCreateSurfaceWaterdrop Members, Class Hierarchy


SettingsCmdCreateSurfaceWaterdrop Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Members
SettingsCmdCreateSurfaceWaterdrop Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurfaceWaterdrop.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
WaterdropMarker | Gets the default water drop marker options for surfaces.
WaterdropPath | Gets the default water drop path options for surfaces.
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSurfaceWaterdrop Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Properties
SettingsCmdCreateSurfaceWaterdrop Properties
Collapse All

The properties of SettingsCmdCreateSurfaceWaterdrop are listed here.

Public Properties
Public Property | Description
WaterdropMarker | Gets the default water drop marker options for surfaces.
WaterdropPath | Gets the default water drop path options for surfaces.
Links
Public Properties


SettingsCmdCreateSurfaceWaterdrop::WaterdropMarker Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Properties > SettingsCmdCreateSurfaceWaterdrop::WaterdropMarker Property
SettingsCmdCreateSurfaceWaterdrop::WaterdropMarker Property
Collapse All

Gets the default water drop marker options for surfaces.

C#
public SettingsCmdWaterdropMarker WaterdropMarker;
Visual Basic
Public Property WaterdropMarker() As SettingsCmdWaterdropMarker
Links
SettingsCmdCreateSurfaceWaterdrop Class, SettingsCmdCreateSurfaceWaterdrop Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceWaterdrop::WaterdropPath Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Properties > SettingsCmdCreateSurfaceWaterdrop::WaterdropPath Property
SettingsCmdCreateSurfaceWaterdrop::WaterdropPath Property
Collapse All

Gets the default water drop path options for surfaces.

C#
public SettingsCmdWaterdropPath WaterdropPath;
Visual Basic
Public Property WaterdropPath() As SettingsCmdWaterdropPath
Links
SettingsCmdCreateSurfaceWaterdrop Class, SettingsCmdCreateSurfaceWaterdrop Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class
Collapse All

Settings that specify the default water drop marker options for surfaces.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker
C#
public class SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker
Inherits TreeOidWrapper
Links
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties, SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members, Class Hierarchy


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker.

Public Properties
Public Property | Description
PlaceMarkerAtStartPoint | Gets whether to draw a marker at the start point of the water drop path.
StartPointMarkerStyle | Gets the default start point marker style.
Links
Public Properties


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties
Collapse All

The properties of SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker are listed here.

Public Properties
Public Property | Description
PlaceMarkerAtStartPoint | Gets whether to draw a marker at the start point of the water drop path.
StartPointMarkerStyle | Gets the default start point marker style.
Links
Public Properties


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker::PlaceMarkerAtStartPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker::PlaceMarkerAtStartPoint Property
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker::PlaceMarkerAtStartPoint Property
Collapse All

Gets whether to draw a marker at the start point of the water drop path.

C#
public PropertyBoolean PlaceMarkerAtStartPoint;
Visual Basic
Public Property PlaceMarkerAtStartPoint() As PropertyBoolean
Links
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class, SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker::StartPointMarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker::StartPointMarkerStyle Property
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker::StartPointMarkerStyle Property
Collapse All

Gets the default start point marker style.

C#
public PropertyString StartPointMarkerStyle;
Visual Basic
Public Property StartPointMarkerStyle() As PropertyString
Links
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class, SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class
Collapse All

Settings that specify the default water drop path options for surfaces.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath
C#
public class SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath
Inherits TreeOidWrapper
Links
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties, SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members, Class Hierarchy


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath.

Public Properties
Public Property | Description
PathLayer | Gets the default layer on which to draw the water drop path.
PathObjectType | Gets the default type of AutoCAD object to use for the water drop path.
Links
Public Properties


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties
Collapse All

The properties of SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath are listed here.

Public Properties
Public Property | Description
PathLayer | Gets the default layer on which to draw the water drop path.
PathObjectType | Gets the default type of AutoCAD object to use for the water drop path.
Links
Public Properties


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath::PathLayer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath::PathLayer Property
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath::PathLayer Property
Collapse All

Gets the default layer on which to draw the water drop path.

C#
public PropertyLayer PathLayer;
Visual Basic
Public Property PathLayer() As PropertyLayer
Links
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class, SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath::PathObjectType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath::PathObjectType Property
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath::PathObjectType Property
Collapse All

Gets the default type of AutoCAD object to use for the water drop path.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::WaterdropObjectType> PathObjectType;
Visual Basic
Public Property PathObjectType() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::WaterdropObjectType>
Links
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class, SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class
SettingsCmdCreateViewFrames Class
Collapse All

Settings for CreateViewFrames command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsViewFrameGroup
        Autodesk::Civil::Land::Settings::SettingsCmdCreateViewFrames
C#
public class SettingsCmdCreateViewFrames : SettingsViewFrameGroup;
Visual Basic
Public Class SettingsCmdCreateViewFrames
Inherits SettingsViewFrameGroup
Links
SettingsCmdCreateViewFrames Properties, SettingsCmdCreateViewFrames Members, Class Hierarchy


SettingsCmdCreateViewFrames Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Members
SettingsCmdCreateViewFrames Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateViewFrames.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Information | Gets the default match line label location.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name formats for view frame group components.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to view frame group components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
ViewFrameCreation | Gets the setting of view frame creation for the command CreateViewFrames.
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateViewFrames Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Properties
SettingsCmdCreateViewFrames Properties
Collapse All

The properties of SettingsCmdCreateViewFrames are listed here.

Public Properties
Public Property | Description
ViewFrameCreation | Gets the setting of view frame creation for the command CreateViewFrames.
Links
Public Properties


SettingsCmdCreateViewFrames::ViewFrameCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Properties > SettingsCmdCreateViewFrames::ViewFrameCreation Property
SettingsCmdCreateViewFrames::ViewFrameCreation Property
Collapse All

Gets the setting of view frame creation for the command CreateViewFrames.

C#
public SettingsCmdViewFrameCreation ViewFrameCreation;
Visual Basic
Public Property ViewFrameCreation() As SettingsCmdViewFrameCreation
Links
SettingsCmdCreateViewFrames Class, SettingsCmdCreateViewFrames Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class
Collapse All

Settings for the view frame creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation
C#
public class SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation
Inherits TreeOidWrapper
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Class Hierarchy


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation.

Public Properties
Public Property | Description
AlignmentStationRangeSpecifiedByUser | Specify whether to create view frames for a user specified range or for the entire alignment.
EnableFirstViewFrameOffset | Specify whether to enable first view frame offset.
FirstViewFrameOffsetDistance | Specify the distance of the first view frame offset.
InsertMatchLines | Specify whether to enable match lines to be inserted.
MatchLineRepositioning | Specify whether to enalbe extra margin for match line movement after placement.
MatchLineRepositioningValue | Specify the distance for additional margin of match line movement.
MatchLineSnapStation | Specify whether to enable match lines to snap down to a rounded station value.
MatchLineSnapStationValue | Specify the rounding value when match line snap to station.
SheetType | Specify the type of sheet what will be created.
ViewFrameOrientation | Specify the view frame orientation option.
Links
Public Properties


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties
Collapse All

The properties of SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation are listed here.

Public Properties
Public Property | Description
AlignmentStationRangeSpecifiedByUser | Specify whether to create view frames for a user specified range or for the entire alignment.
EnableFirstViewFrameOffset | Specify whether to enable first view frame offset.
FirstViewFrameOffsetDistance | Specify the distance of the first view frame offset.
InsertMatchLines | Specify whether to enable match lines to be inserted.
MatchLineRepositioning | Specify whether to enalbe extra margin for match line movement after placement.
MatchLineRepositioningValue | Specify the distance for additional margin of match line movement.
MatchLineSnapStation | Specify whether to enable match lines to snap down to a rounded station value.
MatchLineSnapStationValue | Specify the rounding value when match line snap to station.
SheetType | Specify the type of sheet what will be created.
ViewFrameOrientation | Specify the view frame orientation option.
Links
Public Properties


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::AlignmentStationRangeSpecifiedByUser Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::AlignmentStationRangeSpecifiedByUser Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::AlignmentStationRangeSpecifiedByUser Property
Collapse All

Specify whether to create view frames for a user specified range or for the entire alignment.

C#
public PropertyBoolean AlignmentStationRangeSpecifiedByUser;
Visual Basic
Public Property AlignmentStationRangeSpecifiedByUser() As PropertyBoolean
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::EnableFirstViewFrameOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::EnableFirstViewFrameOffset Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::EnableFirstViewFrameOffset Property
Collapse All

Specify whether to enable first view frame offset.

C#
public PropertyBoolean EnableFirstViewFrameOffset;
Visual Basic
Public Property EnableFirstViewFrameOffset() As PropertyBoolean
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::FirstViewFrameOffsetDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::FirstViewFrameOffsetDistance Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::FirstViewFrameOffsetDistance Property
Collapse All

Specify the distance of the first view frame offset.

C#
public PropertyDouble FirstViewFrameOffsetDistance;
Visual Basic
Public Property FirstViewFrameOffsetDistance() As PropertyDouble
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::InsertMatchLines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::InsertMatchLines Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::InsertMatchLines Property
Collapse All

Specify whether to enable match lines to be inserted.

C#
public PropertyBoolean InsertMatchLines;
Visual Basic
Public Property InsertMatchLines() As PropertyBoolean
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineRepositioning Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineRepositioning Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineRepositioning Property
Collapse All

Specify whether to enalbe extra margin for match line movement after placement.

C#
public PropertyBoolean MatchLineRepositioning;
Visual Basic
Public Property MatchLineRepositioning() As PropertyBoolean
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineRepositioningValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineRepositioningValue Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineRepositioningValue Property
Collapse All

Specify the distance for additional margin of match line movement.

C#
public PropertyDouble MatchLineRepositioningValue;
Visual Basic
Public Property MatchLineRepositioningValue() As PropertyDouble
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineSnapStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineSnapStation Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineSnapStation Property
Collapse All

Specify whether to enable match lines to snap down to a rounded station value.

C#
public PropertyBoolean MatchLineSnapStation;
Visual Basic
Public Property MatchLineSnapStation() As PropertyBoolean
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineSnapStationValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineSnapStationValue Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineSnapStationValue Property
Collapse All

Specify the rounding value when match line snap to station.

C#
public PropertyInt MatchLineSnapStationValue;
Visual Basic
Public Property MatchLineSnapStationValue() As PropertyInt
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::SheetType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::SheetType Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::SheetType Property
Collapse All

Specify the type of sheet what will be created.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SheetSetType> SheetType;
Visual Basic
Public Property SheetType() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SheetSetType>
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::ViewFrameOrientation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::ViewFrameOrientation Property
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::ViewFrameOrientation Property
Collapse All

Specify the view frame orientation option.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::ViewFrameAngleType> ViewFrameOrientation;
Visual Basic
Public Property ViewFrameOrientation() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::ViewFrameAngleType>
Links
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class, SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdDrawFeatureLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class
SettingsCmdDrawFeatureLine Class
Collapse All

Settings for DrawFeatureLine command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdDrawFeatureLine
C#
public class SettingsCmdDrawFeatureLine : SettingsGrading;
Visual Basic
Public Class SettingsCmdDrawFeatureLine
Inherits SettingsGrading
Links
SettingsCmdDrawFeatureLine Properties, SettingsCmdDrawFeatureLine Members, Class Hierarchy


SettingsCmdDrawFeatureLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Members
SettingsCmdDrawFeatureLine Members
Collapse All

The following tables list the members exposed by SettingsCmdDrawFeatureLine.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineCreation | Gets the default setting of feature line creation for the command DrawFeatureLine.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdDrawFeatureLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Properties
SettingsCmdDrawFeatureLine Properties
Collapse All

The properties of SettingsCmdDrawFeatureLine are listed here.

Public Properties
Public Property | Description
FeatureLineCreation | Gets the default setting of feature line creation for the command DrawFeatureLine.
Links
Public Properties


SettingsCmdDrawFeatureLine::FeatureLineCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Properties > SettingsCmdDrawFeatureLine::FeatureLineCreation Property
SettingsCmdDrawFeatureLine::FeatureLineCreation Property
Collapse All

Gets the default setting of feature line creation for the command DrawFeatureLine.

C#
public SettingsCmdFeatureLineCreation FeatureLineCreation;
Visual Basic
Public Property FeatureLineCreation() As SettingsCmdFeatureLineCreation
Links
SettingsCmdDrawFeatureLine Class, SettingsCmdDrawFeatureLine Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class
Collapse All

Settings that specify the default behavior for creating featureline.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation
C#
public class SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation
Inherits TreeOidWrapper
Links
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties, SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members, Class Hierarchy


SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation.

Public Properties
Public Property | Description
LayerSetting | Specifies the default layer setting when feature lines are created.
UseFeatureLineName | Specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Specifies whether a style is applied to feature lines when created.
Links
Public Properties


SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties
Collapse All

The properties of SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation are listed here.

Public Properties
Public Property | Description
LayerSetting | Specifies the default layer setting when feature lines are created.
UseFeatureLineName | Specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Specifies whether a style is applied to feature lines when created.
Links
Public Properties


SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::LayerSetting Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::LayerSetting Property
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::LayerSetting Property
Collapse All

Specifies the default layer setting when feature lines are created.

C#
public PropertyEnum<Autodesk::Civil::Land::FeatureLineLayerSettingType> LayerSetting;
Visual Basic
Public Property LayerSetting() As PropertyEnum<Autodesk::Civil::Land::FeatureLineLayerSettingType>
Links
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class, SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::UseFeatureLineName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::UseFeatureLineName Property
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::UseFeatureLineName Property
Collapse All

Specifies whether a name is applied to feature lines when created.

C#
public PropertyBoolean UseFeatureLineName;
Visual Basic
Public Property UseFeatureLineName() As PropertyBoolean
Links
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class, SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property
Collapse All

Specifies whether a style is applied to feature lines when created.

C#
public PropertyBoolean UseFeatureLineStyle;
Visual Basic
Public Property UseFeatureLineStyle() As PropertyBoolean
Links
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class, SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdEditSVGroupStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdEditSVGroupStyle Class
SettingsCmdEditSVGroupStyle Class
Collapse All

Settings for EditSVGroupStyle command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdEditSVGroupStyle
C#
public class SettingsCmdEditSVGroupStyle : SettingsSectionView;
Visual Basic
Public Class SettingsCmdEditSVGroupStyle
Inherits SettingsSectionView
Links
Class Hierarchy


SettingsCmdExportParcelAnalysis Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class
SettingsCmdExportParcelAnalysis Class
Collapse All

Settings for ExportParcelAnalysis command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdExportParcelAnalysis
C#
public class SettingsCmdExportParcelAnalysis : SettingsParcel;
Visual Basic
Public Class SettingsCmdExportParcelAnalysis
Inherits SettingsParcel
Links
SettingsCmdExportParcelAnalysis Properties, SettingsCmdExportParcelAnalysis Members, Class Hierarchy


SettingsCmdExportParcelAnalysis Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Members
SettingsCmdExportParcelAnalysis Members
Collapse All

The following tables list the members exposed by SettingsCmdExportParcelAnalysis.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ParcelAnalysis | Gets the default setting of parcel analysis.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdExportParcelAnalysis Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Properties
SettingsCmdExportParcelAnalysis Properties
Collapse All

The properties of SettingsCmdExportParcelAnalysis are listed here.

Public Properties
Public Property | Description
ParcelAnalysis | Gets the default setting of parcel analysis.
Links
Public Properties


SettingsCmdExportParcelAnalysis::ParcelAnalysis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Properties > SettingsCmdExportParcelAnalysis::ParcelAnalysis Property
SettingsCmdExportParcelAnalysis::ParcelAnalysis Property
Collapse All

Gets the default setting of parcel analysis.

C#
public SettingsCmdParcelAnalysis ParcelAnalysis;
Visual Basic
Public Property ParcelAnalysis() As SettingsCmdParcelAnalysis
Links
SettingsCmdExportParcelAnalysis Class, SettingsCmdExportParcelAnalysis Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class
Collapse All

Settings that specify defaults for parcel analysis.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis
C#
public class SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis
Inherits TreeOidWrapper
Links
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties, SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members, Class Hierarchy


SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members
Collapse All

The following tables list the members exposed by SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis.

Public Properties
Public Property | Description
AnalysisType | Gets whether Inverse Analysis or Mapcheck Analysis is used.
EnableMapcheckAcrossChord | Gets whether mapcheck across chord is enabled or disabled.
ProcessCounterClockwise | Gets whether segments will be processed in counter-clockwise or clockwise order.
Links
Public Properties


SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties
Collapse All

The properties of SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis are listed here.

Public Properties
Public Property | Description
AnalysisType | Gets whether Inverse Analysis or Mapcheck Analysis is used.
EnableMapcheckAcrossChord | Gets whether mapcheck across chord is enabled or disabled.
ProcessCounterClockwise | Gets whether segments will be processed in counter-clockwise or clockwise order.
Links
Public Properties


SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::AnalysisType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::AnalysisType Property
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::AnalysisType Property
Collapse All

Gets whether Inverse Analysis or Mapcheck Analysis is used.

C#
public PropertyEnum<Autodesk::Civil::Land::ParcelAnalysisType> AnalysisType;
Visual Basic
Public Property AnalysisType() As PropertyEnum<Autodesk::Civil::Land::ParcelAnalysisType>
Links
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class, SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::EnableMapcheckAcrossChord Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::EnableMapcheckAcrossChord Property
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::EnableMapcheckAcrossChord Property
Collapse All

Gets whether mapcheck across chord is enabled or disabled.

C#
public PropertyBoolean EnableMapcheckAcrossChord;
Visual Basic
Public Property EnableMapcheckAcrossChord() As PropertyBoolean
Links
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class, SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::ProcessCounterClockwise Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::ProcessCounterClockwise Property
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::ProcessCounterClockwise Property
Collapse All

Gets whether segments will be processed in counter-clockwise or clockwise order.

C#
public PropertyBoolean ProcessCounterClockwise;
Visual Basic
Public Property ProcessCounterClockwise() As PropertyBoolean
Links
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class, SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdFitCurveFeature Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class
SettingsCmdFitCurveFeature Class
Collapse All

Settings for FitCurveFeature command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdFitCurveFeature
C#
public class SettingsCmdFitCurveFeature : SettingsGrading;
Visual Basic
Public Class SettingsCmdFitCurveFeature
Inherits SettingsGrading
Links
SettingsCmdFitCurveFeature Properties, SettingsCmdFitCurveFeature Members, Class Hierarchy


SettingsCmdFitCurveFeature Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Members
SettingsCmdFitCurveFeature Members
Collapse All

The following tables list the members exposed by SettingsCmdFitCurveFeature.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineFitCurve | Gets the default setting of featureline fit curve for the command FitCurveFeature.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdFitCurveFeature Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Properties
SettingsCmdFitCurveFeature Properties
Collapse All

The properties of SettingsCmdFitCurveFeature are listed here.

Public Properties
Public Property | Description
FeatureLineFitCurve | Gets the default setting of featureline fit curve for the command FitCurveFeature.
Links
Public Properties


SettingsCmdFitCurveFeature::FeatureLineFitCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Properties > SettingsCmdFitCurveFeature::FeatureLineFitCurve Property
SettingsCmdFitCurveFeature::FeatureLineFitCurve Property
Collapse All

Gets the default setting of featureline fit curve for the command FitCurveFeature.

C#
public SettingsCmdFeatureLineFitCurve FeatureLineFitCurve;
Visual Basic
Public Property FeatureLineFitCurve() As SettingsCmdFeatureLineFitCurve
Links
SettingsCmdFitCurveFeature Class, SettingsCmdFitCurveFeature Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class
Collapse All

Settings that specify the default behavior for feature line fit curve.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve
C#
public class SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve
Inherits TreeOidWrapper
Links
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties, SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members, Class Hierarchy


SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members
Collapse All

The following tables list the members exposed by SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve.

Public Properties
Public Property | Description
MinimumNumberOfSegments | Specifies the minimum number of segments that must be identified before creating an arc.
Tolerance | Specifies the maximum distance from a PI along the feature to the arc that is to be inserted.
Links
Public Properties


SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties
Collapse All

The properties of SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve are listed here.

Public Properties
Public Property | Description
MinimumNumberOfSegments | Specifies the minimum number of segments that must be identified before creating an arc.
Tolerance | Specifies the maximum distance from a PI along the feature to the arc that is to be inserted.
Links
Public Properties


SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve::MinimumNumberOfSegments Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve::MinimumNumberOfSegments Property
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve::MinimumNumberOfSegments Property
Collapse All

Specifies the minimum number of segments that must be identified before creating an arc.

C#
public PropertyInt MinimumNumberOfSegments;
Visual Basic
Public Property MinimumNumberOfSegments() As PropertyInt
Links
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class, SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve::Tolerance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve::Tolerance Property
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve::Tolerance Property
Collapse All

Specifies the maximum distance from a PI along the feature to the arc that is to be inserted.

C#
public PropertyDouble Tolerance;
Visual Basic
Public Property Tolerance() As PropertyDouble
Links
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class, SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdGradingElevEditor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class
SettingsCmdGradingElevEditor Class
Collapse All

Settings for GradingElevEditor command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdGradingElevEditor
C#
public class SettingsCmdGradingElevEditor : SettingsGrading;
Visual Basic
Public Class SettingsCmdGradingElevEditor
Inherits SettingsGrading
Links
SettingsCmdGradingElevEditor Properties, SettingsCmdGradingElevEditor Members, Class Hierarchy


SettingsCmdGradingElevEditor Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Members
SettingsCmdGradingElevEditor Members
Collapse All

The following tables list the members exposed by SettingsCmdGradingElevEditor.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GradingElevationEditor | Gets the default setting of grading elevation editor for the command GradingElevEditor.
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdGradingElevEditor Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Properties
SettingsCmdGradingElevEditor Properties
Collapse All

The properties of SettingsCmdGradingElevEditor are listed here.

Public Properties
Public Property | Description
GradingElevationEditor | Gets the default setting of grading elevation editor for the command GradingElevEditor.
Links
Public Properties


SettingsCmdGradingElevEditor::GradingElevationEditor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Properties > SettingsCmdGradingElevEditor::GradingElevationEditor Property
SettingsCmdGradingElevEditor::GradingElevationEditor Property
Collapse All

Gets the default setting of grading elevation editor for the command GradingElevEditor.

C#
public SettingsCmdGradingElevationEditor GradingElevationEditor;
Visual Basic
Public Property GradingElevationEditor() As SettingsCmdGradingElevationEditor
Links
SettingsCmdGradingElevEditor Class, SettingsCmdGradingElevEditor Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class
Collapse All

Settings that specify the default behavior for grading elevation editor.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor
C#
public class SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor
Inherits TreeOidWrapper
Links
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties, SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members, Class Hierarchy


SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members
Collapse All

The following tables list the members exposed by SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor.

Public Properties
Public Property | Description
RaiseLowerIncrement | Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered... more
ShowGradeBreaksOnly | Specifies whether only the feature line start/end points and any grade breaks in between are displayed.
Links
Public Properties


SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties
Collapse All

The properties of SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor are listed here.

Public Properties
Public Property | Description
RaiseLowerIncrement | Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered... more
ShowGradeBreaksOnly | Specifies whether only the feature line start/end points and any grade breaks in between are displayed.
Links
Public Properties


SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor::RaiseLowerIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor::RaiseLowerIncrement Property
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor::RaiseLowerIncrement Property
Collapse All

Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered to adjust volumes.

C#
public PropertyDouble RaiseLowerIncrement;
Visual Basic
Public Property RaiseLowerIncrement() As PropertyDouble
Links
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class, SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor::ShowGradeBreaksOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor::ShowGradeBreaksOnly Property
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor::ShowGradeBreaksOnly Property
Collapse All

Specifies whether only the feature line start/end points and any grade breaks in between are displayed.

C#
public PropertyBoolean ShowGradeBreaksOnly;
Visual Basic
Public Property ShowGradeBreaksOnly() As PropertyBoolean
Links
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class, SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdGradingTools Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class
SettingsCmdGradingTools Class
Collapse All

Settings for GradingTools command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdGradingTools
C#
public class SettingsCmdGradingTools : SettingsGrading;
Visual Basic
Public Class SettingsCmdGradingTools
Inherits SettingsGrading
Links
SettingsCmdGradingTools Properties, SettingsCmdGradingTools Members, Class Hierarchy


SettingsCmdGradingTools Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Members
SettingsCmdGradingTools Members
Collapse All

The following tables list the members exposed by SettingsCmdGradingTools.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GradingLayoutTools | Gets the default setting of grading layout tools for the command GradingTools.
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdGradingTools Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Properties
SettingsCmdGradingTools Properties
Collapse All

The properties of SettingsCmdGradingTools are listed here.

Public Properties
Public Property | Description
GradingLayoutTools | Gets the default setting of grading layout tools for the command GradingTools.
Links
Public Properties


SettingsCmdGradingTools::GradingLayoutTools Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Properties > SettingsCmdGradingTools::GradingLayoutTools Property
SettingsCmdGradingTools::GradingLayoutTools Property
Collapse All

Gets the default setting of grading layout tools for the command GradingTools.

C#
public SettingsCmdGradingLayoutTools GradingLayoutTools;
Visual Basic
Public Property GradingLayoutTools() As SettingsCmdGradingLayoutTools
Links
SettingsCmdGradingTools Class, SettingsCmdGradingTools Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class
Collapse All

Settings that specify the default behavior for grading layout tools.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdGradingTools::SettingsCmdGradingLayoutTools
C#
public class SettingsCmdGradingTools::SettingsCmdGradingLayoutTools : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdGradingTools::SettingsCmdGradingLayoutTools
Inherits TreeOidWrapper
Links
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties, SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members, Class Hierarchy


SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members
Collapse All

The following tables list the members exposed by SettingsCmdGradingTools::SettingsCmdGradingLayoutTools.

Public Properties
Public Property | Description
Criteria | Specifies the default Criteria to use when creating grading.
GradingCriteriaSet | Specifies the default Criteria Set to use when creating grading.
Links
Public Properties


SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties
Collapse All

The properties of SettingsCmdGradingTools::SettingsCmdGradingLayoutTools are listed here.

Public Properties
Public Property | Description
Criteria | Specifies the default Criteria to use when creating grading.
GradingCriteriaSet | Specifies the default Criteria Set to use when creating grading.
Links
Public Properties


SettingsCmdGradingTools::SettingsCmdGradingLayoutTools::Criteria Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools::Criteria Property
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools::Criteria Property
Collapse All

Specifies the default Criteria to use when creating grading.

C#
public PropertyString Criteria;
Visual Basic
Public Property Criteria() As PropertyString
Links
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class, SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdGradingTools::SettingsCmdGradingLayoutTools::GradingCriteriaSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools::GradingCriteriaSet Property
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools::GradingCriteriaSet Property
Collapse All

Specifies the default Criteria Set to use when creating grading.

C#
public PropertyString GradingCriteriaSet;
Visual Basic
Public Property GradingCriteriaSet() As PropertyString
Links
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class, SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdGradingVolumeTools Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class
SettingsCmdGradingVolumeTools Class
Collapse All

Settings for GradingVolumeTools command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdGradingVolumeTools
C#
public class SettingsCmdGradingVolumeTools : SettingsGrading;
Visual Basic
Public Class SettingsCmdGradingVolumeTools
Inherits SettingsGrading
Links
SettingsCmdGradingVolumeTools Properties, SettingsCmdGradingVolumeTools Members, Class Hierarchy


SettingsCmdGradingVolumeTools Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Members
SettingsCmdGradingVolumeTools Members
Collapse All

The following tables list the members exposed by SettingsCmdGradingVolumeTools.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
LimitFeatureSelectionToCurrentGroup | Specifies whether features outside the current grading group can be selected for raising or lowering in the volume calculations.
NameFormat | Gets the default name format for new feature lines and grading groups.
RaiseLowerElevationIncrement | Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered... more
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdGradingVolumeTools Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Properties
SettingsCmdGradingVolumeTools Properties
Collapse All

The properties of SettingsCmdGradingVolumeTools are listed here.

Public Properties
Public Property | Description
LimitFeatureSelectionToCurrentGroup | Specifies whether features outside the current grading group can be selected for raising or lowering in the volume calculations.
RaiseLowerElevationIncrement | Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered... more
Links
Public Properties


SettingsCmdGradingVolumeTools::LimitFeatureSelectionToCurrentGroup Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Properties > SettingsCmdGradingVolumeTools::LimitFeatureSelectionToCurrentGroup Property
SettingsCmdGradingVolumeTools::LimitFeatureSelectionToCurrentGroup Property
Collapse All

Specifies whether features outside the current grading group can be selected for raising or lowering in the volume calculations.

C#
public PropertyBoolean LimitFeatureSelectionToCurrentGroup;
Visual Basic
Public Property LimitFeatureSelectionToCurrentGroup() As PropertyBoolean
Links
SettingsCmdGradingVolumeTools Class, SettingsCmdGradingVolumeTools Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdGradingVolumeTools::RaiseLowerElevationIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Properties > SettingsCmdGradingVolumeTools::RaiseLowerElevationIncrement Property
SettingsCmdGradingVolumeTools::RaiseLowerElevationIncrement Property
Collapse All

Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered to adjust volumes.

C#
public PropertyDouble RaiseLowerElevationIncrement;
Visual Basic
Public Property RaiseLowerElevationIncrement() As PropertyDouble
Links
SettingsCmdGradingVolumeTools Class, SettingsCmdGradingVolumeTools Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportBuildingSite Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportBuildingSite Class
SettingsCmdImportBuildingSite Class
Collapse All

Settings for ImportBuildingSite command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsBuildingSite
        Autodesk::Civil::Land::Settings::SettingsCmdImportBuildingSite
C#
public class SettingsCmdImportBuildingSite : SettingsBuildingSite;
Visual Basic
Public Class SettingsCmdImportBuildingSite
Inherits SettingsBuildingSite
Links
Class Hierarchy


SettingsCmdImportGEData Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class
SettingsCmdImportGEData Class
Collapse All

Settings for ImportGEData command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdImportGEData
C#
public class SettingsCmdImportGEData : SettingsSurface;
Visual Basic
Public Class SettingsCmdImportGEData
Inherits SettingsSurface
Links
SettingsCmdImportGEData Properties, SettingsCmdImportGEData Members, Class Hierarchy


SettingsCmdImportGEData Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Members
SettingsCmdImportGEData Members
Collapse All

The following tables list the members exposed by SettingsCmdImportGEData.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
GoogleEarthOptions | Gets the default number of rows and columns collected when importing Google Earth information.
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
SurfaceCreation | Gets the defaults assigned when creating surfaces.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdImportGEData Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Properties
SettingsCmdImportGEData Properties
Collapse All

The properties of SettingsCmdImportGEData are listed here.

Public Properties
Public Property | Description
GoogleEarthOptions | Gets the default number of rows and columns collected when importing Google Earth information.
SurfaceCreation | Gets the defaults assigned when creating surfaces.
Links
Public Properties


SettingsCmdImportGEData::GoogleEarthOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Properties > SettingsCmdImportGEData::GoogleEarthOptions Property
SettingsCmdImportGEData::GoogleEarthOptions Property
Collapse All

Gets the default number of rows and columns collected when importing Google Earth information.

C#
public SettingsCmdGoogleEarthOptions GoogleEarthOptions;
Visual Basic
Public Property GoogleEarthOptions() As SettingsCmdGoogleEarthOptions
Links
SettingsCmdImportGEData Class, SettingsCmdImportGEData Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportGEData::SurfaceCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Properties > SettingsCmdImportGEData::SurfaceCreation Property
SettingsCmdImportGEData::SurfaceCreation Property
Collapse All

Gets the defaults assigned when creating surfaces.

C#
public SettingsCmdSurfaceCreation SurfaceCreation;
Visual Basic
Public Property SurfaceCreation() As SettingsCmdSurfaceCreation
Links
SettingsCmdImportGEData Class, SettingsCmdImportGEData Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class
Collapse All

Settings that specify the default number of rows and columns collected when importing Google Earth information.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions
C#
public class SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions
Inherits TreeOidWrapper
Links
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties, SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members, Class Hierarchy


SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions.

Public Properties
Public Property | Description
GoogleEarthColumns | Gets the number of columns of data that are collected when importing terrain information from Google Earth.
GoogleEarthRows | Gets the number of rows of data that are collected when importing terrain information from Google Earth.
Links
Public Properties


SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties
Collapse All

The properties of SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions are listed here.

Public Properties
Public Property | Description
GoogleEarthColumns | Gets the number of columns of data that are collected when importing terrain information from Google Earth.
GoogleEarthRows | Gets the number of rows of data that are collected when importing terrain information from Google Earth.
Links
Public Properties


SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions::GoogleEarthColumns Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions::GoogleEarthColumns Property
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions::GoogleEarthColumns Property
Collapse All

Gets the number of columns of data that are collected when importing terrain information from Google Earth.

C#
public PropertyInt GoogleEarthColumns;
Visual Basic
Public Property GoogleEarthColumns() As PropertyInt
Links
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class, SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions::GoogleEarthRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions::GoogleEarthRows Property
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions::GoogleEarthRows Property
Collapse All

Gets the number of rows of data that are collected when importing terrain information from Google Earth.

C#
public PropertyInt GoogleEarthRows;
Visual Basic
Public Property GoogleEarthRows() As PropertyInt
Links
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class, SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class
Collapse All

Settings that specify the defaults assigned when creating surfaces.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdImportGEData::SettingsCmdSurfaceCreation
C#
public class SettingsCmdImportGEData::SettingsCmdSurfaceCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdImportGEData::SettingsCmdSurfaceCreation
Inherits TreeOidWrapper
Links
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties, SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members, Class Hierarchy


SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdImportGEData::SettingsCmdSurfaceCreation.

Public Properties
Public Property | Description
NameFormat | Gets the default name format for new surfaces.
Links
Public Properties


SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties
Collapse All

The properties of SettingsCmdImportGEData::SettingsCmdSurfaceCreation are listed here.

Public Properties
Public Property | Description
NameFormat | Gets the default name format for new surfaces.
Links
Public Properties


SettingsCmdImportGEData::SettingsCmdSurfaceCreation::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties > SettingsCmdImportGEData::SettingsCmdSurfaceCreation::NameFormat Property
SettingsCmdImportGEData::SettingsCmdSurfaceCreation::NameFormat Property
Collapse All

Gets the default name format for new surfaces.

C#
public PropertyString NameFormat;
Visual Basic
Public Property NameFormat() As PropertyString
Links
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class, SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportGESurface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class
SettingsCmdImportGESurface Class
Collapse All

Settings for ImportGESurface command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdImportGESurface
C#
public class SettingsCmdImportGESurface : SettingsSurface;
Visual Basic
Public Class SettingsCmdImportGESurface
Inherits SettingsSurface
Links
SettingsCmdImportGESurface Properties, SettingsCmdImportGESurface Members, Class Hierarchy


SettingsCmdImportGESurface Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Members
SettingsCmdImportGESurface Members
Collapse All

The following tables list the members exposed by SettingsCmdImportGESurface.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
GoogleEarthOptions | Gets the default number of rows and columns collected when importing Google Earth information.
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default surface name format settings.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdImportGESurface Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Properties
SettingsCmdImportGESurface Properties
Collapse All

The properties of SettingsCmdImportGESurface are listed here.

Public Properties
Public Property | Description
GoogleEarthOptions | Gets the default number of rows and columns collected when importing Google Earth information.
NameFormat | Gets the default surface name format settings.
Links
Public Properties


SettingsCmdImportGESurface::GoogleEarthOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Properties > SettingsCmdImportGESurface::GoogleEarthOptions Property
SettingsCmdImportGESurface::GoogleEarthOptions Property
Collapse All

Gets the default number of rows and columns collected when importing Google Earth information.

C#
public SettingsCmdGoogleEarthOptions GoogleEarthOptions;
Visual Basic
Public Property GoogleEarthOptions() As SettingsCmdGoogleEarthOptions
Links
SettingsCmdImportGESurface Class, SettingsCmdImportGESurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportGESurface::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Properties > SettingsCmdImportGESurface::NameFormat Property
SettingsCmdImportGESurface::NameFormat Property
Collapse All

Gets the default surface name format settings.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsCmdImportGESurface Class, SettingsCmdImportGESurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class
Collapse All

Settings that specify the default number of rows and columns collected when importing Google Earth information.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions
C#
public class SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions
Inherits TreeOidWrapper
Links
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties, SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members, Class Hierarchy


SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions.

Public Properties
Public Property | Description
GoogleEarthColumns | Gets the number of columns of data that are collected when importing terrain information from Google Earth.
GoogleEarthRows | Gets the number of rows of data that are collected when importing terrain information from Google Earth.
Links
Public Properties


SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties
Collapse All

The properties of SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions are listed here.

Public Properties
Public Property | Description
GoogleEarthColumns | Gets the number of columns of data that are collected when importing terrain information from Google Earth.
GoogleEarthRows | Gets the number of rows of data that are collected when importing terrain information from Google Earth.
Links
Public Properties


SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions::GoogleEarthColumns Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions::GoogleEarthColumns Property
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions::GoogleEarthColumns Property
Collapse All

Gets the number of columns of data that are collected when importing terrain information from Google Earth.

C#
public PropertyInt GoogleEarthColumns;
Visual Basic
Public Property GoogleEarthColumns() As PropertyInt
Links
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class, SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions::GoogleEarthRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions::GoogleEarthRows Property
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions::GoogleEarthRows Property
Collapse All

Gets the number of rows of data that are collected when importing terrain information from Google Earth.

C#
public PropertyInt GoogleEarthRows;
Visual Basic
Public Property GoogleEarthRows() As PropertyInt
Links
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class, SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdImportGESurface::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsNameFormat Class
SettingsCmdImportGESurface::SettingsNameFormat Class
Collapse All

Settings that specify name format for the command.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdImportGESurface::SettingsNameFormat
C#
public class SettingsCmdImportGESurface::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdImportGESurface::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsCmdImportGESurface::SettingsNameFormat Properties, SettingsCmdImportGESurface::SettingsNameFormat Members, Class Hierarchy


SettingsCmdImportGESurface::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsNameFormat Class > SettingsCmdImportGESurface::SettingsNameFormat Members
SettingsCmdImportGESurface::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsCmdImportGESurface::SettingsNameFormat.

Public Properties
Public Property | Description
Surface | Gets the default maintain edges setting.
Links
Public Properties


SettingsCmdImportGESurface::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsNameFormat Class > SettingsCmdImportGESurface::SettingsNameFormat Properties
SettingsCmdImportGESurface::SettingsNameFormat Properties
Collapse All

The properties of SettingsCmdImportGESurface::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
Surface | Gets the default maintain edges setting.
Links
Public Properties


SettingsCmdImportGESurface::SettingsNameFormat::Surface Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsNameFormat Class > SettingsCmdImportGESurface::SettingsNameFormat Properties > SettingsCmdImportGESurface::SettingsNameFormat::Surface Property
SettingsCmdImportGESurface::SettingsNameFormat::Surface Property
Collapse All

Gets the default maintain edges setting.

C#
public PropertyString Surface;
Visual Basic
Public Property Surface() As PropertyString
Links
SettingsCmdImportGESurface::SettingsNameFormat Class, SettingsCmdImportGESurface::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdJoinFeatures Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class
SettingsCmdJoinFeatures Class
Collapse All

Settings for JoinFeatures command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdJoinFeatures
C#
public class SettingsCmdJoinFeatures : SettingsGrading;
Visual Basic
Public Class SettingsCmdJoinFeatures
Inherits SettingsGrading
Links
SettingsCmdJoinFeatures Properties, SettingsCmdJoinFeatures Members, Class Hierarchy


SettingsCmdJoinFeatures Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Members
SettingsCmdJoinFeatures Members
Collapse All

The following tables list the members exposed by SettingsCmdJoinFeatures.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineJoin | Gets the default setting of featureline join for the command JoinFeatures.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdJoinFeatures Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Properties
SettingsCmdJoinFeatures Properties
Collapse All

The properties of SettingsCmdJoinFeatures are listed here.

Public Properties
Public Property | Description
FeatureLineJoin | Gets the default setting of featureline join for the command JoinFeatures.
Links
Public Properties


SettingsCmdJoinFeatures::FeatureLineJoin Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Properties > SettingsCmdJoinFeatures::FeatureLineJoin Property
SettingsCmdJoinFeatures::FeatureLineJoin Property
Collapse All

Gets the default setting of featureline join for the command JoinFeatures.

C#
public SettingsCmdFeatureLineJoin FeatureLineJoin;
Visual Basic
Public Property FeatureLineJoin() As SettingsCmdFeatureLineJoin
Links
SettingsCmdJoinFeatures Class, SettingsCmdJoinFeatures Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class
Collapse All

Settings that specify the default behavior for featureline join.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin
C#
public class SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin
Inherits TreeOidWrapper
Links
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties, SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members, Class Hierarchy


SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members
Collapse All

The following tables list the members exposed by SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin.

Public Properties
Public Property | Description
Tolerance | Specifies how close feature lines must be when using the Join command.
Links
Public Properties


SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties
Collapse All

The properties of SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin are listed here.

Public Properties
Public Property | Description
Tolerance | Specifies how close feature lines must be when using the Join command.
Links
Public Properties


SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin::Tolerance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin::Tolerance Property
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin::Tolerance Property
Collapse All

Specifies how close feature lines must be when using the Join command.

C#
public PropertyDouble Tolerance;
Visual Basic
Public Property Tolerance() As PropertyDouble
Links
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class, SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdLayoutSectionViewGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdLayoutSectionViewGroup Class
SettingsCmdLayoutSectionViewGroup Class
Collapse All

Settings for LayoutSectionViewGroup command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdLayoutSectionViewGroup
C#
public class SettingsCmdLayoutSectionViewGroup : SettingsSectionView;
Visual Basic
Public Class SettingsCmdLayoutSectionViewGroup
Inherits SettingsSectionView
Links
Class Hierarchy


SettingsCmdMoveBlockstoAttribElev Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdMoveBlockstoAttribElev Class
SettingsCmdMoveBlockstoAttribElev Class
Collapse All

Settings for MoveBlockstoAttribElev command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveBlockstoAttribElev
C#
public class SettingsCmdMoveBlockstoAttribElev : SettingsSurface;
Visual Basic
Public Class SettingsCmdMoveBlockstoAttribElev
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdMoveBlocksToSurface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdMoveBlocksToSurface Class
SettingsCmdMoveBlocksToSurface Class
Collapse All

Settings for MoveBlocksToSurface command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveBlocksToSurface
C#
public class SettingsCmdMoveBlocksToSurface : SettingsSurface;
Visual Basic
Public Class SettingsCmdMoveBlocksToSurface
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdMoveTextToElevation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdMoveTextToElevation Class
SettingsCmdMoveTextToElevation Class
Collapse All

Settings for MoveTextToElevation command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveTextToElevation
C#
public class SettingsCmdMoveTextToElevation : SettingsSurface;
Visual Basic
Public Class SettingsCmdMoveTextToElevation
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdProjectObjectsToProf Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdProjectObjectsToProf Class
SettingsCmdProjectObjectsToProf Class
Collapse All

Settings for ProjectObjectsToProf command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdProjectObjectsToProf
C#
public class SettingsCmdProjectObjectsToProf : SettingsProfileView;
Visual Basic
Public Class SettingsCmdProjectObjectsToProf
Inherits SettingsProfileView
Links
Class Hierarchy


SettingsCmdProjectObjectsToSect Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdProjectObjectsToSect Class
SettingsCmdProjectObjectsToSect Class
Collapse All

Settings for ProjectObjectsToSect command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdProjectObjectsToSect
C#
public class SettingsCmdProjectObjectsToSect : SettingsSectionView;
Visual Basic
Public Class SettingsCmdProjectObjectsToSect
Inherits SettingsSectionView
Links
Class Hierarchy


SettingsCmdReAddParcelAreaLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdReAddParcelAreaLabel Class
SettingsCmdReAddParcelAreaLabel Class
Collapse All

Settings for ReAddParcelAreaLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdReAddParcelAreaLabel
C#
public class SettingsCmdReAddParcelAreaLabel : SettingsParcel;
Visual Basic
Public Class SettingsCmdReAddParcelAreaLabel
Inherits SettingsParcel
Links
Class Hierarchy


SettingsCmdReAddParcelSegmentLabels Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdReAddParcelSegmentLabels Class
SettingsCmdReAddParcelSegmentLabels Class
Collapse All

Settings for ReAddParcelSegmentLabels command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdReAddParcelSegmentLabels
C#
public class SettingsCmdReAddParcelSegmentLabels : SettingsParcel;
Visual Basic
Public Class SettingsCmdReAddParcelSegmentLabels
Inherits SettingsParcel
Links
Class Hierarchy


SettingsCmdReverseAlignmentDirection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdReverseAlignmentDirection Class
SettingsCmdReverseAlignmentDirection Class
Collapse All

Settings for ReverseAlignmentDirection command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdReverseAlignmentDirection
C#
public class SettingsCmdReverseAlignmentDirection : SettingsAlignment;
Visual Basic
Public Class SettingsCmdReverseAlignmentDirection
Inherits SettingsAlignment
Links
Class Hierarchy


SettingsCmdShowGeodeticCalculator Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdShowGeodeticCalculator Class
SettingsCmdShowGeodeticCalculator Class
Collapse All

Settings for ShowGeodeticCalculator command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdShowGeodeticCalculator
C#
public class SettingsCmdShowGeodeticCalculator : SettingsPoint;
Visual Basic
Public Class SettingsCmdShowGeodeticCalculator
Inherits SettingsPoint
Links
Class Hierarchy


SettingsCmdShowPointGroupProperties Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdShowPointGroupProperties Class
SettingsCmdShowPointGroupProperties Class
Collapse All

Settings for ShowPointGroupProperties command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdShowPointGroupProperties
C#
public class SettingsCmdShowPointGroupProperties : SettingsPoint;
Visual Basic
Public Class SettingsCmdShowPointGroupProperties
Inherits SettingsPoint
Links
Class Hierarchy


SettingsCmdSimplifySurface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class
SettingsCmdSimplifySurface Class
Collapse All

Settings for SimplifySurface command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdSimplifySurface
C#
public class SettingsCmdSimplifySurface : SettingsSurface;
Visual Basic
Public Class SettingsCmdSimplifySurface
Inherits SettingsSurface
Links
SettingsCmdSimplifySurface Properties, SettingsCmdSimplifySurface Members, Class Hierarchy


SettingsCmdSimplifySurface Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Members
SettingsCmdSimplifySurface Members
Collapse All

The following tables list the members exposed by SettingsCmdSimplifySurface.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MaximumChangeInElevation | Gets the maximum allowed difference between the elevation of the original surface and the elevation of the simplified surface.
PercentageOfPointsToRemove | Gets the percent of surface points to remove.
RegionOptions | Gets the default option by which surfaces will be simplified.
SimplifyMethod | Gets the default method by which surfaces will be simplified.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UseMaximumChangeInElevation | Gets whether you will set a default maximum change in elevation.
UsePercentageOfPointsToRemove | Gets whether simplify the image by removing a percent of surface points.
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdSimplifySurface Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Properties
SettingsCmdSimplifySurface Properties
Collapse All

The properties of SettingsCmdSimplifySurface are listed here.

Public Properties
Public Property | Description
MaximumChangeInElevation | Gets the maximum allowed difference between the elevation of the original surface and the elevation of the simplified surface.
PercentageOfPointsToRemove | Gets the percent of surface points to remove.
RegionOptions | Gets the default option by which surfaces will be simplified.
SimplifyMethod | Gets the default method by which surfaces will be simplified.
UseMaximumChangeInElevation | Gets whether you will set a default maximum change in elevation.
UsePercentageOfPointsToRemove | Gets whether simplify the image by removing a percent of surface points.
Links
Public Properties


SettingsCmdSimplifySurface::MaximumChangeInElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Properties > SettingsCmdSimplifySurface::MaximumChangeInElevation Property
SettingsCmdSimplifySurface::MaximumChangeInElevation Property
Collapse All

Gets the maximum allowed difference between the elevation of the original surface and the elevation of the simplified surface.

C#
public PropertyDouble MaximumChangeInElevation;
Visual Basic
Public Property MaximumChangeInElevation() As PropertyDouble
Links
SettingsCmdSimplifySurface Class, SettingsCmdSimplifySurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSimplifySurface::PercentageOfPointsToRemove Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Properties > SettingsCmdSimplifySurface::PercentageOfPointsToRemove Property
SettingsCmdSimplifySurface::PercentageOfPointsToRemove Property
Collapse All

Gets the percent of surface points to remove.

C#
public PropertyDouble PercentageOfPointsToRemove;
Visual Basic
Public Property PercentageOfPointsToRemove() As PropertyDouble
Links
SettingsCmdSimplifySurface Class, SettingsCmdSimplifySurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSimplifySurface::RegionOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Properties > SettingsCmdSimplifySurface::RegionOptions Property
SettingsCmdSimplifySurface::RegionOptions Property
Collapse All

Gets the default option by which surfaces will be simplified.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SurfaceRegionOptionsType> RegionOptions;
Visual Basic
Public Property RegionOptions() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SurfaceRegionOptionsType>
Links
SettingsCmdSimplifySurface Class, SettingsCmdSimplifySurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSimplifySurface::SimplifyMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Properties > SettingsCmdSimplifySurface::SimplifyMethod Property
SettingsCmdSimplifySurface::SimplifyMethod Property
Collapse All

Gets the default method by which surfaces will be simplified.

C#
public Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SurfaceSimplifyType> SimplifyMethod;
Visual Basic
Public Property SimplifyMethod() As Autodesk::Civil::PropertyEnum<Autodesk::Civil::Land::SurfaceSimplifyType>
Links
SettingsCmdSimplifySurface Class, SettingsCmdSimplifySurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSimplifySurface::UseMaximumChangeInElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Properties > SettingsCmdSimplifySurface::UseMaximumChangeInElevation Property
SettingsCmdSimplifySurface::UseMaximumChangeInElevation Property
Collapse All

Gets whether you will set a default maximum change in elevation.

C#
public PropertyBoolean UseMaximumChangeInElevation;
Visual Basic
Public Property UseMaximumChangeInElevation() As PropertyBoolean
Links
SettingsCmdSimplifySurface Class, SettingsCmdSimplifySurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSimplifySurface::UsePercentageOfPointsToRemove Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Properties > SettingsCmdSimplifySurface::UsePercentageOfPointsToRemove Property
SettingsCmdSimplifySurface::UsePercentageOfPointsToRemove Property
Collapse All

Gets whether simplify the image by removing a percent of surface points.

C#
public PropertyBoolean UsePercentageOfPointsToRemove;
Visual Basic
Public Property UsePercentageOfPointsToRemove() As PropertyBoolean
Links
SettingsCmdSimplifySurface Class, SettingsCmdSimplifySurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSuperimposeProfile Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class
SettingsCmdSuperimposeProfile Class
Collapse All

Settings for SuperimposeProfile command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdSuperimposeProfile
C#
public class SettingsCmdSuperimposeProfile : SettingsProfile;
Visual Basic
Public Class SettingsCmdSuperimposeProfile
Inherits SettingsProfile
Links
SettingsCmdSuperimposeProfile Properties, SettingsCmdSuperimposeProfile Members, Class Hierarchy


SettingsCmdSuperimposeProfile Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Members
SettingsCmdSuperimposeProfile Members
Collapse All

The following tables list the members exposed by SettingsCmdSuperimposeProfile.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
SuperimposeProfile | Gets the default setting of superimpose profile.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdSuperimposeProfile Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Properties
SettingsCmdSuperimposeProfile Properties
Collapse All

The properties of SettingsCmdSuperimposeProfile are listed here.

Public Properties
Public Property | Description
SuperimposeProfile | Gets the default setting of superimpose profile.
Links
Public Properties


SettingsCmdSuperimposeProfile::SuperimposeProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Properties > SettingsCmdSuperimposeProfile::SuperimposeProfile Property
SettingsCmdSuperimposeProfile::SuperimposeProfile Property
Collapse All

Gets the default setting of superimpose profile.

C#
public SettingsCmdSuperimposeProfileOption SuperimposeProfile;
Visual Basic
Public Property SuperimposeProfile() As SettingsCmdSuperimposeProfileOption
Links
SettingsCmdSuperimposeProfile Class, SettingsCmdSuperimposeProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class
Collapse All

Settings that specify the default values for the mid-ordinate distances that the system uses when tessellating (approximating) the shape of curves in superimposed profiles.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption
C#
public class SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption
Inherits TreeOidWrapper
Links
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties, SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members, Class Hierarchy


SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members
Collapse All

The following tables list the members exposed by SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption.

Public Properties
Public Property | Description
HorizontalMidOrdinateDistance | Gets the horizontal mid-ordinate distance for tessellated curve segments.
VerticalMidOrdinateDistance | Gets the horizontal mid-ordinate distance for tessellated curve segments.
Links
Public Properties


SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties
Collapse All

The properties of SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption are listed here.

Public Properties
Public Property | Description
HorizontalMidOrdinateDistance | Gets the horizontal mid-ordinate distance for tessellated curve segments.
VerticalMidOrdinateDistance | Gets the horizontal mid-ordinate distance for tessellated curve segments.
Links
Public Properties


SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption::HorizontalMidOrdinateDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption::HorizontalMidOrdinateDistance Property
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption::HorizontalMidOrdinateDistance Property
Collapse All

Gets the horizontal mid-ordinate distance for tessellated curve segments.

C#
public PropertyDouble HorizontalMidOrdinateDistance;
Visual Basic
Public Property HorizontalMidOrdinateDistance() As PropertyDouble
Links
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class, SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption::VerticalMidOrdinateDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption::VerticalMidOrdinateDistance Property
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption::VerticalMidOrdinateDistance Property
Collapse All

Gets the horizontal mid-ordinate distance for tessellated curve segments.

C#
public PropertyDouble VerticalMidOrdinateDistance;
Visual Basic
Public Property VerticalMidOrdinateDistance() As PropertyDouble
Links
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class, SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSurfaceExportToDem Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class
SettingsCmdSurfaceExportToDem Class
Collapse All

Settings for SurfaceExportToDem command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExportToDem
C#
public class SettingsCmdSurfaceExportToDem : SettingsSurface;
Visual Basic
Public Class SettingsCmdSurfaceExportToDem
Inherits SettingsSurface
Links
SettingsCmdSurfaceExportToDem Properties, SettingsCmdSurfaceExportToDem Members, Class Hierarchy


SettingsCmdSurfaceExportToDem Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Members
SettingsCmdSurfaceExportToDem Members
Collapse All

The following tables list the members exposed by SettingsCmdSurfaceExportToDem.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
ExportOptions | Gets the defaults assigned when exporting surfaces to a DEM file.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdSurfaceExportToDem Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Properties
SettingsCmdSurfaceExportToDem Properties
Collapse All

The properties of SettingsCmdSurfaceExportToDem are listed here.

Public Properties
Public Property | Description
ExportOptions | Gets the defaults assigned when exporting surfaces to a DEM file.
Links
Public Properties


SettingsCmdSurfaceExportToDem::ExportOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Properties > SettingsCmdSurfaceExportToDem::ExportOptions Property
SettingsCmdSurfaceExportToDem::ExportOptions Property
Collapse All

Gets the defaults assigned when exporting surfaces to a DEM file.

C#
public SettingsCmdExportOptions ExportOptions;
Visual Basic
Public Property ExportOptions() As SettingsCmdExportOptions
Links
SettingsCmdSurfaceExportToDem Class, SettingsCmdSurfaceExportToDem Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class
Collapse All

Settings that specify the defaults assigned when exporting surfaces to a DEM file.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions
C#
public class SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions
Inherits TreeOidWrapper
Links
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties, SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members, Class Hierarchy


SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions.

Public Properties
Public Property | Description
GridSpacing | Gets the spacing between grids when exporting to a DEM file.
NullElevation | Gets the default custom null elevation used when exporting to a DEM file.
UseCustomNullElevation | Gets whether a custom null elevation is used when exporting to a DEM file.
Links
Public Properties


SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties
Collapse All

The properties of SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions are listed here.

Public Properties
Public Property | Description
GridSpacing | Gets the spacing between grids when exporting to a DEM file.
NullElevation | Gets the default custom null elevation used when exporting to a DEM file.
UseCustomNullElevation | Gets whether a custom null elevation is used when exporting to a DEM file.
Links
Public Properties


SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::GridSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::GridSpacing Property
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::GridSpacing Property
Collapse All

Gets the spacing between grids when exporting to a DEM file.

C#
public PropertyDouble GridSpacing;
Visual Basic
Public Property GridSpacing() As PropertyDouble
Links
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class, SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::NullElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::NullElevation Property
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::NullElevation Property
Collapse All

Gets the default custom null elevation used when exporting to a DEM file.

C#
public PropertyDouble NullElevation;
Visual Basic
Public Property NullElevation() As PropertyDouble
Links
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class, SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::UseCustomNullElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::UseCustomNullElevation Property
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::UseCustomNullElevation Property
Collapse All

Gets whether a custom null elevation is used when exporting to a DEM file.

C#
public PropertyBoolean UseCustomNullElevation;
Visual Basic
Public Property UseCustomNullElevation() As PropertyBoolean
Links
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class, SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdSurfaceExtractObjects Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExtractObjects Class
SettingsCmdSurfaceExtractObjects Class
Collapse All

Settings for SurfaceExtractObjects command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExtractObjects
C#
public class SettingsCmdSurfaceExtractObjects : SettingsSurface;
Visual Basic
Public Class SettingsCmdSurfaceExtractObjects
Inherits SettingsSurface
Links
Class Hierarchy


SettingsCmdWeedFeatures Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class
SettingsCmdWeedFeatures Class
Collapse All

Settings for WeedFeatures command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdWeedFeatures
C#
public class SettingsCmdWeedFeatures : SettingsGrading;
Visual Basic
Public Class SettingsCmdWeedFeatures
Inherits SettingsGrading
Links
SettingsCmdWeedFeatures Properties, SettingsCmdWeedFeatures Members, Class Hierarchy


SettingsCmdWeedFeatures Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Members
SettingsCmdWeedFeatures Members
Collapse All

The following tables list the members exposed by SettingsCmdWeedFeatures.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineWeed | Gets the default setting of featureline weed for the command WeedFeatures.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdWeedFeatures Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Properties
SettingsCmdWeedFeatures Properties
Collapse All

The properties of SettingsCmdWeedFeatures are listed here.

Public Properties
Public Property | Description
FeatureLineWeed | Gets the default setting of featureline weed for the command WeedFeatures.
Links
Public Properties


SettingsCmdWeedFeatures::FeatureLineWeed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Properties > SettingsCmdWeedFeatures::FeatureLineWeed Property
SettingsCmdWeedFeatures::FeatureLineWeed Property
Collapse All

Gets the default setting of featureline weed for the command WeedFeatures.

C#
public SettingsCmdFeatureLineWeed FeatureLineWeed;
Visual Basic
Public Property FeatureLineWeed() As SettingsCmdFeatureLineWeed
Links
SettingsCmdWeedFeatures Class, SettingsCmdWeedFeatures Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class
Collapse All

Settings that specify the default behavior for grading layout tools.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed
C#
public class SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed
Inherits TreeOidWrapper
Links
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties, SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members, Class Hierarchy


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members
Collapse All

The following tables list the members exposed by SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed.

Public Properties
Public Property | Description
AngleFactor | Specifies the default Angle factor.
ApplyAngleFactor | Specifies whether the Angle factor in the Weed Vertices dialog box is selected by default.
ApplyGradeFactor | Specifies whether the Grade factor in the Weed Vertices dialog box is selected by default.
ApplyLengthFactor | Specifies whether the Length factor in the Weed Vertices dialog box is selected by default.
ClosePoint3DDistance | Specifies the 3D distance for weeding. Points that are close together in plan view, with slightly different elevations can be... more
ClosePointRemoval | Specifies whether the 3D Distance factor in the Weed Vertices dialog box is selected by default.
GradeFactor | Specifies the default Grade factor.
LengthFactor | Specifies the default Length factor.
Links
Public Properties


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties
Collapse All

The properties of SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed are listed here.

Public Properties
Public Property | Description
AngleFactor | Specifies the default Angle factor.
ApplyAngleFactor | Specifies whether the Angle factor in the Weed Vertices dialog box is selected by default.
ApplyGradeFactor | Specifies whether the Grade factor in the Weed Vertices dialog box is selected by default.
ApplyLengthFactor | Specifies whether the Length factor in the Weed Vertices dialog box is selected by default.
ClosePoint3DDistance | Specifies the 3D distance for weeding. Points that are close together in plan view, with slightly different elevations can be... more
ClosePointRemoval | Specifies whether the 3D Distance factor in the Weed Vertices dialog box is selected by default.
GradeFactor | Specifies the default Grade factor.
LengthFactor | Specifies the default Length factor.
Links
Public Properties


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::AngleFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::AngleFactor Property
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::AngleFactor Property
Collapse All

Specifies the default Angle factor.

C#
public PropertyDouble AngleFactor;
Visual Basic
Public Property AngleFactor() As PropertyDouble
Links
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class, SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyAngleFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyAngleFactor Property
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyAngleFactor Property
Collapse All

Specifies whether the Angle factor in the Weed Vertices dialog box is selected by default.

C#
public PropertyBoolean ApplyAngleFactor;
Visual Basic
Public Property ApplyAngleFactor() As PropertyBoolean
Links
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class, SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyGradeFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyGradeFactor Property
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyGradeFactor Property
Collapse All

Specifies whether the Grade factor in the Weed Vertices dialog box is selected by default.

C#
public PropertyBoolean ApplyGradeFactor;
Visual Basic
Public Property ApplyGradeFactor() As PropertyBoolean
Links
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class, SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyLengthFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyLengthFactor Property
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyLengthFactor Property
Collapse All

Specifies whether the Length factor in the Weed Vertices dialog box is selected by default.

C#
public PropertyBoolean ApplyLengthFactor;
Visual Basic
Public Property ApplyLengthFactor() As PropertyBoolean
Links
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class, SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ClosePoint3DDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ClosePoint3DDistance Property
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ClosePoint3DDistance Property
Collapse All

Specifies the 3D distance for weeding. Points that are close together in plan view, with slightly different elevations can be weeded using this setting.

C#
public PropertyDouble ClosePoint3DDistance;
Visual Basic
Public Property ClosePoint3DDistance() As PropertyDouble
Links
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class, SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ClosePointRemoval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ClosePointRemoval Property
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ClosePointRemoval Property
Collapse All

Specifies whether the 3D Distance factor in the Weed Vertices dialog box is selected by default.

C#
public PropertyBoolean ClosePointRemoval;
Visual Basic
Public Property ClosePointRemoval() As PropertyBoolean
Links
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class, SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::GradeFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::GradeFactor Property
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::GradeFactor Property
Collapse All

Specifies the default Grade factor.

C#
public PropertyDouble GradeFactor;
Visual Basic
Public Property GradeFactor() As PropertyDouble
Links
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class, SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members, Autodesk::Civil::Land::Settings Namespace


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::LengthFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::LengthFactor Property
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::LengthFactor Property
Collapse All

Specifies the default Length factor.

C#
public PropertyDouble LengthFactor;
Visual Basic
Public Property LengthFactor() As PropertyDouble
Links
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class, SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members, Autodesk::Civil::Land::Settings Namespace


SettingsGrading Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class
SettingsGrading Class
Collapse All

Settings for Grading.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLineFromAlign
        Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLines
        Autodesk::Civil::Land::Settings::SettingsCmdCreateGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateGradingGroup
        Autodesk::Civil::Land::Settings::SettingsCmdDrawFeatureLine
        Autodesk::Civil::Land::Settings::SettingsCmdFitCurveFeature
        Autodesk::Civil::Land::Settings::SettingsCmdGradingElevEditor
        Autodesk::Civil::Land::Settings::SettingsCmdGradingTools
        Autodesk::Civil::Land::Settings::SettingsCmdGradingVolumeTools
        Autodesk::Civil::Land::Settings::SettingsCmdJoinFeatures
        Autodesk::Civil::Land::Settings::SettingsCmdWeedFeatures
C#
public class SettingsGrading : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsGrading
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsGrading Properties, SettingsGrading Members, Class Hierarchy


SettingsGrading Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Members
SettingsGrading Members
Collapse All

The following tables list the members exposed by SettingsGrading.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsGrading Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Properties
SettingsGrading Properties
Collapse All

The properties of SettingsGrading are listed here.

Public Properties
Public Property | Description
NameFormat | Gets the default name format for new feature lines and grading groups.
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
Links
Public Properties


SettingsGrading::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Properties > SettingsGrading::NameFormat Property
SettingsGrading::NameFormat Property
Collapse All

Gets the default name format for new feature lines and grading groups.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsGrading Class, SettingsGrading Members, Autodesk::Civil::Land::Settings Namespace


SettingsGrading::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Properties > SettingsGrading::Styles Property
SettingsGrading::Styles Property
Collapse All

Property for Grading feature setting //////////////////////////////////////////

Gets the default styles for new slope grading .

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsGrading Class, SettingsGrading Members, Autodesk::Civil::Land::Settings Namespace


SettingsGrading::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class
SettingsGrading::SettingsNameFormat Class
Collapse All

Default name format for grading feature settings.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsGrading::SettingsNameFormat
C#
public class SettingsGrading::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsGrading::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsGrading::SettingsNameFormat Properties, SettingsGrading::SettingsNameFormat Members, Class Hierarchy


SettingsGrading::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class > SettingsGrading::SettingsNameFormat Members
SettingsGrading::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsGrading::SettingsNameFormat.

Public Properties
Public Property | Description
FeatureLine | Gets the default name formats for new new feature lines.
GradingGroup | Gets the default name formats for new grading groups.
Links
Public Properties


SettingsGrading::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class > SettingsGrading::SettingsNameFormat Properties
SettingsGrading::SettingsNameFormat Properties
Collapse All

The properties of SettingsGrading::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
FeatureLine | Gets the default name formats for new new feature lines.
GradingGroup | Gets the default name formats for new grading groups.
Links
Public Properties


SettingsGrading::SettingsNameFormat::FeatureLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class > SettingsGrading::SettingsNameFormat Properties > SettingsGrading::SettingsNameFormat::FeatureLine Property
SettingsGrading::SettingsNameFormat::FeatureLine Property
Collapse All

Gets the default name formats for new new feature lines.

C#
public PropertyString FeatureLine;
Visual Basic
Public Property FeatureLine() As PropertyString
Links
SettingsGrading::SettingsNameFormat Class, SettingsGrading::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsGrading::SettingsNameFormat::GradingGroup Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class > SettingsGrading::SettingsNameFormat Properties > SettingsGrading::SettingsNameFormat::GradingGroup Property
SettingsGrading::SettingsNameFormat::GradingGroup Property
Collapse All

Gets the default name formats for new grading groups.

C#
public PropertyString GradingGroup;
Visual Basic
Public Property GradingGroup() As PropertyString
Links
SettingsGrading::SettingsNameFormat Class, SettingsGrading::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsGrading::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class
SettingsGrading::SettingsStyles Class
Collapse All

Default styles.setting class

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsGrading::SettingsStyles
C#
public class SettingsGrading::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsGrading::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsGrading::SettingsStyles Properties, SettingsGrading::SettingsStyles Members, Class Hierarchy


SettingsGrading::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Members
SettingsGrading::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsGrading::SettingsStyles.

Public Properties
Public Property | Description
CutSlopeGrading | Gets the default style to apply when creating cut slope grading.
FeatureLineStyle | Gets the default style to apply when creating feature lines.
FillSlopeGrading | Gets the default style to apply when creating fill slope grading..
GradingStyle | Gets the default style to apply when creating grading.
Links
Public Properties


SettingsGrading::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Properties
SettingsGrading::SettingsStyles Properties
Collapse All

The properties of SettingsGrading::SettingsStyles are listed here.

Public Properties
Public Property | Description
CutSlopeGrading | Gets the default style to apply when creating cut slope grading.
FeatureLineStyle | Gets the default style to apply when creating feature lines.
FillSlopeGrading | Gets the default style to apply when creating fill slope grading..
GradingStyle | Gets the default style to apply when creating grading.
Links
Public Properties


SettingsGrading::SettingsStyles::CutSlopeGrading Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Properties > SettingsGrading::SettingsStyles::CutSlopeGrading Property
SettingsGrading::SettingsStyles::CutSlopeGrading Property
Collapse All

Gets the default style to apply when creating cut slope grading.

C#
public PropertyString CutSlopeGrading;
Visual Basic
Public Property CutSlopeGrading() As PropertyString
Links
SettingsGrading::SettingsStyles Class, SettingsGrading::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsGrading::SettingsStyles::FeatureLineStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Properties > SettingsGrading::SettingsStyles::FeatureLineStyle Property
SettingsGrading::SettingsStyles::FeatureLineStyle Property
Collapse All

Gets the default style to apply when creating feature lines.

C#
public PropertyString FeatureLineStyle;
Visual Basic
Public Property FeatureLineStyle() As PropertyString
Links
SettingsGrading::SettingsStyles Class, SettingsGrading::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsGrading::SettingsStyles::FillSlopeGrading Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Properties > SettingsGrading::SettingsStyles::FillSlopeGrading Property
SettingsGrading::SettingsStyles::FillSlopeGrading Property
Collapse All

Gets the default style to apply when creating fill slope grading..

C#
public PropertyString FillSlopeGrading;
Visual Basic
Public Property FillSlopeGrading() As PropertyString
Links
SettingsGrading::SettingsStyles Class, SettingsGrading::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsGrading::SettingsStyles::GradingStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Properties > SettingsGrading::SettingsStyles::GradingStyle Property
SettingsGrading::SettingsStyles::GradingStyle Property
Collapse All

Gets the default style to apply when creating grading.

C#
public PropertyString GradingStyle;
Visual Basic
Public Property GradingStyle() As PropertyString
Links
SettingsGrading::SettingsStyles Class, SettingsGrading::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsMassHaulLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulLine Class
SettingsMassHaulLine Class
Collapse All

Settings for MassHaulLine.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsMassHaulLine
C#
public class SettingsMassHaulLine : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsMassHaulLine
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
Class Hierarchy


SettingsMassHaulView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class
SettingsMassHaulView Class
Collapse All

Settings for MassHaulView.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsMassHaulView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMassHaulDiagram
C#
public class SettingsMassHaulView : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsMassHaulView
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsMassHaulView Properties, SettingsMassHaulView Members, Class Hierarchy


SettingsMassHaulView Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Members
SettingsMassHaulView Members
Collapse All

The following tables list the members exposed by SettingsMassHaulView.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MassHaulCreation | Gets the default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings... more
NameFormat | Gets the default name formats for new mass haul lines and new mass haul views.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for mass haul components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsMassHaulView Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Properties
SettingsMassHaulView Properties
Collapse All

The properties of SettingsMassHaulView are listed here.

Public Properties
Public Property | Description
MassHaulCreation | Gets the default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings... more
NameFormat | Gets the default name formats for new mass haul lines and new mass haul views.
Styles | Gets the default styles for mass haul components.
Links
Public Properties


SettingsMassHaulView::MassHaulCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Properties > SettingsMassHaulView::MassHaulCreation Property
SettingsMassHaulView::MassHaulCreation Property
Collapse All

Gets the default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings when you create a mass haul diagram.

C#
public SettingsMassHaulCreation MassHaulCreation;
Visual Basic
Public Property MassHaulCreation() As SettingsMassHaulCreation
Links
SettingsMassHaulView Class, SettingsMassHaulView Members, Autodesk::Civil::Land::Settings Namespace


SettingsMassHaulView::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Properties > SettingsMassHaulView::NameFormat Property
SettingsMassHaulView::NameFormat Property
Collapse All

Gets the default name formats for new mass haul lines and new mass haul views.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsMassHaulView Class, SettingsMassHaulView Members, Autodesk::Civil::Land::Settings Namespace


SettingsMassHaulView::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Properties > SettingsMassHaulView::Styles Property
SettingsMassHaulView::Styles Property
Collapse All

Gets the default styles for mass haul components.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsMassHaulView Class, SettingsMassHaulView Members, Autodesk::Civil::Land::Settings Namespace


SettingsMassHaulView::SettingsMassHaulCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class
SettingsMassHaulView::SettingsMassHaulCreation Class
Collapse All

Default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings when you create a mass haul diagram..

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsMassHaulView::SettingsMassHaulCreation
C#
public class SettingsMassHaulView::SettingsMassHaulCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsMassHaulView::SettingsMassHaulCreation
Inherits TreeOidWrapper
Links
SettingsMassHaulView::SettingsMassHaulCreation Properties, SettingsMassHaulView::SettingsMassHaulCreation Members, Class Hierarchy


SettingsMassHaulView::SettingsMassHaulCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class > SettingsMassHaulView::SettingsMassHaulCreation Members
SettingsMassHaulView::SettingsMassHaulCreation Members
Collapse All

The following tables list the members exposed by SettingsMassHaulView::SettingsMassHaulCreation.

Public Properties
Public Property | Description
BorrowPitCapacity | Gets the the capacity of a borrow pit.
DumpSiteCapacity | Gets the the capacity of a dump site.
Links
Public Properties


SettingsMassHaulView::SettingsMassHaulCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class > SettingsMassHaulView::SettingsMassHaulCreation Properties
SettingsMassHaulView::SettingsMassHaulCreation Properties
Collapse All

The properties of SettingsMassHaulView::SettingsMassHaulCreation are listed here.

Public Properties
Public Property | Description
BorrowPitCapacity | Gets the the capacity of a borrow pit.
DumpSiteCapacity | Gets the the capacity of a dump site.
Links
Public Properties


SettingsMassHaulView::SettingsMassHaulCreation::BorrowPitCapacity Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class > SettingsMassHaulView::SettingsMassHaulCreation Properties > SettingsMassHaulView::SettingsMassHaulCreation::BorrowPitCapacity Property
SettingsMassHaulView::SettingsMassHaulCreation::BorrowPitCapacity Property
Collapse All

Gets the the capacity of a borrow pit.

C#
public PropertyDouble BorrowPitCapacity;
Visual Basic
Public Property BorrowPitCapacity() As PropertyDouble
Links
SettingsMassHaulView::SettingsMassHaulCreation Class, SettingsMassHaulView::SettingsMassHaulCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsMassHaulView::SettingsMassHaulCreation::DumpSiteCapacity Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class > SettingsMassHaulView::SettingsMassHaulCreation Properties > SettingsMassHaulView::SettingsMassHaulCreation::DumpSiteCapacity Property
SettingsMassHaulView::SettingsMassHaulCreation::DumpSiteCapacity Property
Collapse All

Gets the the capacity of a dump site.

C#
public PropertyDouble DumpSiteCapacity;
Visual Basic
Public Property DumpSiteCapacity() As PropertyDouble
Links
SettingsMassHaulView::SettingsMassHaulCreation Class, SettingsMassHaulView::SettingsMassHaulCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsMassHaulView::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class
SettingsMassHaulView::SettingsNameFormat Class
Collapse All

Default name format for new mass haul lines and new mass haul views.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsMassHaulView::SettingsNameFormat
C#
public class SettingsMassHaulView::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsMassHaulView::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsMassHaulView::SettingsNameFormat Properties, SettingsMassHaulView::SettingsNameFormat Members, Class Hierarchy


SettingsMassHaulView::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class > SettingsMassHaulView::SettingsNameFormat Members
SettingsMassHaulView::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsMassHaulView::SettingsNameFormat.

Public Properties
Public Property | Description
MassHaulLine | Gets the default name formats for mass haul lines.
MassHaulView | Gets the default name formats for mass haul views.
Links
Public Properties


SettingsMassHaulView::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class > SettingsMassHaulView::SettingsNameFormat Properties
SettingsMassHaulView::SettingsNameFormat Properties
Collapse All

The properties of SettingsMassHaulView::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
MassHaulLine | Gets the default name formats for mass haul lines.
MassHaulView | Gets the default name formats for mass haul views.
Links
Public Properties


SettingsMassHaulView::SettingsNameFormat::MassHaulLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class > SettingsMassHaulView::SettingsNameFormat Properties > SettingsMassHaulView::SettingsNameFormat::MassHaulLine Property
SettingsMassHaulView::SettingsNameFormat::MassHaulLine Property
Collapse All

Gets the default name formats for mass haul lines.

C#
public PropertyString MassHaulLine;
Visual Basic
Public Property MassHaulLine() As PropertyString
Links
SettingsMassHaulView::SettingsNameFormat Class, SettingsMassHaulView::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsMassHaulView::SettingsNameFormat::MassHaulView Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class > SettingsMassHaulView::SettingsNameFormat Properties > SettingsMassHaulView::SettingsNameFormat::MassHaulView Property
SettingsMassHaulView::SettingsNameFormat::MassHaulView Property
Collapse All

Gets the default name formats for mass haul views.

C#
public PropertyString MassHaulView;
Visual Basic
Public Property MassHaulView() As PropertyString
Links
SettingsMassHaulView::SettingsNameFormat Class, SettingsMassHaulView::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsMassHaulView::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class
SettingsMassHaulView::SettingsStyles Class
Collapse All

Default styles.for mass haul components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsMassHaulView::SettingsStyles
C#
public class SettingsMassHaulView::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsMassHaulView::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsMassHaulView::SettingsStyles Properties, SettingsMassHaulView::SettingsStyles Members, Class Hierarchy


SettingsMassHaulView::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class > SettingsMassHaulView::SettingsStyles Members
SettingsMassHaulView::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsMassHaulView::SettingsStyles.

Public Properties
Public Property | Description
MassHaulLine | Gets the default style for mass haul lines.
MassHaulView | Gets the default style for mass haul views.
Links
Public Properties


SettingsMassHaulView::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class > SettingsMassHaulView::SettingsStyles Properties
SettingsMassHaulView::SettingsStyles Properties
Collapse All

The properties of SettingsMassHaulView::SettingsStyles are listed here.

Public Properties
Public Property | Description
MassHaulLine | Gets the default style for mass haul lines.
MassHaulView | Gets the default style for mass haul views.
Links
Public Properties


SettingsMassHaulView::SettingsStyles::MassHaulLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class > SettingsMassHaulView::SettingsStyles Properties > SettingsMassHaulView::SettingsStyles::MassHaulLine Property
SettingsMassHaulView::SettingsStyles::MassHaulLine Property
Collapse All

Gets the default style for mass haul lines.

C#
public PropertyString MassHaulLine;
Visual Basic
Public Property MassHaulLine() As PropertyString
Links
SettingsMassHaulView::SettingsStyles Class, SettingsMassHaulView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsMassHaulView::SettingsStyles::MassHaulView Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class > SettingsMassHaulView::SettingsStyles Properties > SettingsMassHaulView::SettingsStyles::MassHaulView Property
SettingsMassHaulView::SettingsStyles::MassHaulView Property
Collapse All

Gets the default style for mass haul views.

C#
public PropertyString MassHaulView;
Visual Basic
Public Property MassHaulView() As PropertyString
Links
SettingsMassHaulView::SettingsStyles Class, SettingsMassHaulView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsMatchLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMatchLine Class
SettingsMatchLine Class
Collapse All

Settings for MatchLine.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsMatchLine
C#
public class SettingsMatchLine : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsMatchLine
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
Class Hierarchy


SettingsParcel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class
SettingsParcel Class
Collapse All

Settings for Parcel.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelAreaLabel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelCurveTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineLabel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentLabels
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelTable
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelFromObjects
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSite
        Autodesk::Civil::Land::Settings::SettingsCmdExportParcelAnalysis
        Autodesk::Civil::Land::Settings::SettingsCmdReAddParcelAreaLabel
        Autodesk::Civil::Land::Settings::SettingsCmdReAddParcelSegmentLabels
C#
public class SettingsParcel : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsParcel
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsParcel Properties, SettingsParcel Members, Class Hierarchy


SettingsParcel Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Members
SettingsParcel Members
Collapse All

The following tables list the members exposed by SettingsParcel.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsParcel Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Properties
SettingsParcel Properties
Collapse All

The properties of SettingsParcel are listed here.

Public Properties
Public Property | Description
Styles | Gets the default styles for creating and labeling parcels.
Links
Public Properties


SettingsParcel::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Properties > SettingsParcel::Styles Property
SettingsParcel::Styles Property
Collapse All

Gets the default styles for creating and labeling parcels.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsParcel Class, SettingsParcel Members, Autodesk::Civil::Land::Settings Namespace


SettingsParcel::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class
SettingsParcel::SettingsStyles Class
Collapse All

Default styles.setting class

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsParcel::SettingsStyles
C#
public class SettingsParcel::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsParcel::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsParcel::SettingsStyles Properties, SettingsParcel::SettingsStyles Members, Class Hierarchy


SettingsParcel::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Members
SettingsParcel::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsParcel::SettingsStyles.

Public Properties
Public Property | Description
Parcel | Gets the default style for parcel .
ParcelAreaLabelStyle | Gets the default style for parcel area label.
ParcelCurveLabel | Gets the default style for parcel curve label
ParcelLineLabel | Gets the default style for parcel line label
Links
Public Properties


SettingsParcel::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Properties
SettingsParcel::SettingsStyles Properties
Collapse All

The properties of SettingsParcel::SettingsStyles are listed here.

Public Properties
Public Property | Description
Parcel | Gets the default style for parcel .
ParcelAreaLabelStyle | Gets the default style for parcel area label.
ParcelCurveLabel | Gets the default style for parcel curve label
ParcelLineLabel | Gets the default style for parcel line label
Links
Public Properties


SettingsParcel::SettingsStyles::Parcel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Properties > SettingsParcel::SettingsStyles::Parcel Property
SettingsParcel::SettingsStyles::Parcel Property
Collapse All

Gets the default style for parcel .

C#
public PropertyString Parcel;
Visual Basic
Public Property Parcel() As PropertyString
Links
SettingsParcel::SettingsStyles Class, SettingsParcel::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsParcel::SettingsStyles::ParcelAreaLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Properties > SettingsParcel::SettingsStyles::ParcelAreaLabelStyle Property
SettingsParcel::SettingsStyles::ParcelAreaLabelStyle Property
Collapse All

Gets the default style for parcel area label.

C#
public PropertyString ParcelAreaLabelStyle;
Visual Basic
Public Property ParcelAreaLabelStyle() As PropertyString
Links
SettingsParcel::SettingsStyles Class, SettingsParcel::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsParcel::SettingsStyles::ParcelCurveLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Properties > SettingsParcel::SettingsStyles::ParcelCurveLabel Property
SettingsParcel::SettingsStyles::ParcelCurveLabel Property
Collapse All

Gets the default style for parcel curve label

C#
public PropertyString ParcelCurveLabel;
Visual Basic
Public Property ParcelCurveLabel() As PropertyString
Links
SettingsParcel::SettingsStyles Class, SettingsParcel::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsParcel::SettingsStyles::ParcelLineLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Properties > SettingsParcel::SettingsStyles::ParcelLineLabel Property
SettingsParcel::SettingsStyles::ParcelLineLabel Property
Collapse All

Gets the default style for parcel line label

C#
public PropertyString ParcelLineLabel;
Visual Basic
Public Property ParcelLineLabel() As PropertyString
Links
SettingsParcel::SettingsStyles Class, SettingsParcel::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsPoint Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class
SettingsPoint Class
Collapse All

Settings for Point.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdAddPointTable
        Autodesk::Civil::Land::Settings::SettingsCmdConvertPointstoSdskPoints
        Autodesk::Civil::Land::Settings::SettingsCmdCreatePointGroup
        Autodesk::Civil::Land::Settings::SettingsCmdCreatePoints
        Autodesk::Civil::Land::Settings::SettingsCmdShowGeodeticCalculator
        Autodesk::Civil::Land::Settings::SettingsCmdShowPointGroupProperties
C#
public class SettingsPoint : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsPoint
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsPoint Properties, SettingsPoint Members, Class Hierarchy


SettingsPoint Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Members
SettingsPoint Members
Collapse All

The following tables list the members exposed by SettingsPoint.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new points and point groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to points and points labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UpdatePoints | Gets whether you can change local copies of project points without checking them out.
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsPoint Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Properties
SettingsPoint Properties
Collapse All

The properties of SettingsPoint are listed here.

Public Properties
Public Property | Description
NameFormat | Gets the default name format for new points and point groups.
Styles | Gets the default styles assigned to points and points labels.
UpdatePoints | Gets whether you can change local copies of project points without checking them out.
Links
Public Properties


SettingsPoint::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Properties > SettingsPoint::NameFormat Property
SettingsPoint::NameFormat Property
Collapse All

Gets the default name format for new points and point groups.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsPoint Class, SettingsPoint Members, Autodesk::Civil::Land::Settings Namespace


SettingsPoint::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Properties > SettingsPoint::Styles Property
SettingsPoint::Styles Property
Collapse All

Gets the default styles assigned to points and points labels.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsPoint Class, SettingsPoint Members, Autodesk::Civil::Land::Settings Namespace


SettingsPoint::UpdatePoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Properties > SettingsPoint::UpdatePoints Property
SettingsPoint::UpdatePoints Property
Collapse All

Gets whether you can change local copies of project points without checking them out.

C#
public SettingsUpdatePoints UpdatePoints;
Visual Basic
Public Property UpdatePoints() As SettingsUpdatePoints
Links
SettingsPoint Class, SettingsPoint Members, Autodesk::Civil::Land::Settings Namespace


SettingsPoint::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class
SettingsPoint::SettingsNameFormat Class
Collapse All

Default name format for point feature settings.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsPoint::SettingsNameFormat
C#
public class SettingsPoint::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsPoint::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsPoint::SettingsNameFormat Properties, SettingsPoint::SettingsNameFormat Members, Class Hierarchy


SettingsPoint::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class > SettingsPoint::SettingsNameFormat Members
SettingsPoint::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsPoint::SettingsNameFormat.

Public Properties
Public Property | Description
Point | Gets the default name formats for new points.
PointGroup | Gets the default name formats for new point groups.
Links
Public Properties


SettingsPoint::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class > SettingsPoint::SettingsNameFormat Properties
SettingsPoint::SettingsNameFormat Properties
Collapse All

The properties of SettingsPoint::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
Point | Gets the default name formats for new points.
PointGroup | Gets the default name formats for new point groups.
Links
Public Properties


SettingsPoint::SettingsNameFormat::Point Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class > SettingsPoint::SettingsNameFormat Properties > SettingsPoint::SettingsNameFormat::Point Property
SettingsPoint::SettingsNameFormat::Point Property
Collapse All

Gets the default name formats for new points.

C#
public PropertyString Point;
Visual Basic
Public Property Point() As PropertyString
Links
SettingsPoint::SettingsNameFormat Class, SettingsPoint::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsPoint::SettingsNameFormat::PointGroup Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class > SettingsPoint::SettingsNameFormat Properties > SettingsPoint::SettingsNameFormat::PointGroup Property
SettingsPoint::SettingsNameFormat::PointGroup Property
Collapse All

Gets the default name formats for new point groups.

C#
public PropertyString PointGroup;
Visual Basic
Public Property PointGroup() As PropertyString
Links
SettingsPoint::SettingsNameFormat Class, SettingsPoint::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsPoint::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class
SettingsPoint::SettingsStyles Class
Collapse All

Default styles.setting class

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsPoint::SettingsStyles
C#
public class SettingsPoint::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsPoint::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsPoint::SettingsStyles Properties, SettingsPoint::SettingsStyles Members, Class Hierarchy


SettingsPoint::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class > SettingsPoint::SettingsStyles Members
SettingsPoint::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsPoint::SettingsStyles.

Public Properties
Public Property | Description
Point | Gets the default point style.
PointLabel | Gets the default point label style.
Links
Public Properties


SettingsPoint::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class > SettingsPoint::SettingsStyles Properties
SettingsPoint::SettingsStyles Properties
Collapse All

The properties of SettingsPoint::SettingsStyles are listed here.

Public Properties
Public Property | Description
Point | Gets the default point style.
PointLabel | Gets the default point label style.
Links
Public Properties


SettingsPoint::SettingsStyles::Point Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class > SettingsPoint::SettingsStyles Properties > SettingsPoint::SettingsStyles::Point Property
SettingsPoint::SettingsStyles::Point Property
Collapse All

Gets the default point style.

C#
public PropertyString Point;
Visual Basic
Public Property Point() As PropertyString
Links
SettingsPoint::SettingsStyles Class, SettingsPoint::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsPoint::SettingsStyles::PointLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class > SettingsPoint::SettingsStyles Properties > SettingsPoint::SettingsStyles::PointLabel Property
SettingsPoint::SettingsStyles::PointLabel Property
Collapse All

Gets the default point label style.

C#
public PropertyString PointLabel;
Visual Basic
Public Property PointLabel() As PropertyString
Links
SettingsPoint::SettingsStyles Class, SettingsPoint::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsPoint::SettingsUpdatePoints Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsUpdatePoints Class
SettingsPoint::SettingsUpdatePoints Class
Collapse All

Update points setting class.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsPoint::SettingsUpdatePoints
C#
public class SettingsPoint::SettingsUpdatePoints : TreeOidWrapper;
Visual Basic
Public Class SettingsPoint::SettingsUpdatePoints
Inherits TreeOidWrapper
Links
SettingsPoint::SettingsUpdatePoints Properties, SettingsPoint::SettingsUpdatePoints Members, Class Hierarchy


SettingsPoint::SettingsUpdatePoints Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsUpdatePoints Class > SettingsPoint::SettingsUpdatePoints Members
SettingsPoint::SettingsUpdatePoints Members
Collapse All

The following tables list the members exposed by SettingsPoint::SettingsUpdatePoints.

Public Properties
Public Property | Description
AllowCheckedInPointsToBeModified | Gets whether you can change checked in points when you are working offline.
Links
Public Properties


SettingsPoint::SettingsUpdatePoints Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsUpdatePoints Class > SettingsPoint::SettingsUpdatePoints Properties
SettingsPoint::SettingsUpdatePoints Properties
Collapse All

The properties of SettingsPoint::SettingsUpdatePoints are listed here.

Public Properties
Public Property | Description
AllowCheckedInPointsToBeModified | Gets whether you can change checked in points when you are working offline.
Links
Public Properties


SettingsPoint::SettingsUpdatePoints::AllowCheckedInPointsToBeModified Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsUpdatePoints Class > SettingsPoint::SettingsUpdatePoints Properties > SettingsPoint::SettingsUpdatePoints::AllowCheckedInPointsToBeModified Property
SettingsPoint::SettingsUpdatePoints::AllowCheckedInPointsToBeModified Property
Collapse All

Gets whether you can change checked in points when you are working offline.

C#
public PropertyBoolean AllowCheckedInPointsToBeModified;
Visual Basic
Public Property AllowCheckedInPointsToBeModified() As PropertyBoolean
Links
SettingsPoint::SettingsUpdatePoints Class, SettingsPoint::SettingsUpdatePoints Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class
SettingsProfile Class
Collapse All

Settings for Profile.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromFile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileLayout
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileReference
        Autodesk::Civil::Land::Settings::SettingsCmdCreateQuickProfile
        Autodesk::Civil::Land::Settings::SettingsCmdSuperimposeProfile
C#
public class SettingsProfile : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsProfile
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsProfile Properties, SettingsProfile Members, Class Hierarchy


SettingsProfile Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Members
SettingsProfile Members
Collapse All

The following tables list the members exposed by SettingsProfile.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsProfile Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Properties
SettingsProfile Properties
Collapse All

The properties of SettingsProfile are listed here.

Public Properties
Public Property | Description
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
ProfilesCreation | Gets default values for vertical curve sub-entities
StyleSettings | Gets the default styles for new profiles
Links
Public Properties


SettingsProfile::CriteriaBasedDesignOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Properties > SettingsProfile::CriteriaBasedDesignOptions Property
SettingsProfile::CriteriaBasedDesignOptions Property
Collapse All

Gets the defaults for creating a profile using design criteria

C#
public SettingsCriteriaBasedDesignOptions CriteriaBasedDesignOptions;
Visual Basic
Public Property CriteriaBasedDesignOptions() As SettingsCriteriaBasedDesignOptions
Links
SettingsProfile Class, SettingsProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::DefaultNameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Properties > SettingsProfile::DefaultNameFormat Property
SettingsProfile::DefaultNameFormat Property
Collapse All

Gets the default name formats for new profiles

C#
public SettingsDefaultNameFormat DefaultNameFormat;
Visual Basic
Public Property DefaultNameFormat() As SettingsDefaultNameFormat
Links
SettingsProfile Class, SettingsProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::ProfilesCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Properties > SettingsProfile::ProfilesCreation Property
SettingsProfile::ProfilesCreation Property
Collapse All

Gets default values for vertical curve sub-entities

C#
public SettingsProfileCreation ProfilesCreation;
Visual Basic
Public Property ProfilesCreation() As SettingsProfileCreation
Links
SettingsProfile Class, SettingsProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::StyleSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Properties > SettingsProfile::StyleSettings Property
SettingsProfile::StyleSettings Property
Collapse All

Gets the default styles for new profiles

C#
public SettingsStyles StyleSettings;
Visual Basic
Public Property StyleSettings() As SettingsStyles
Links
SettingsProfile Class, SettingsProfile Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsCriteriaBasedDesignOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class
SettingsProfile::SettingsCriteriaBasedDesignOptions Class
Collapse All

Criteria Based Design options setting class

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfile::SettingsCriteriaBasedDesignOptions
C#
public class SettingsProfile::SettingsCriteriaBasedDesignOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsProfile::SettingsCriteriaBasedDesignOptions
Inherits TreeOidWrapper
Links
SettingsProfile::SettingsCriteriaBasedDesignOptions Properties, SettingsProfile::SettingsCriteriaBasedDesignOptions Members, Class Hierarchy


SettingsProfile::SettingsCriteriaBasedDesignOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class > SettingsProfile::SettingsCriteriaBasedDesignOptions Members
SettingsProfile::SettingsCriteriaBasedDesignOptions Members
Collapse All

The following tables list the members exposed by SettingsProfile::SettingsCriteriaBasedDesignOptions.

Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
UseDesignChecksOption | Gets whether to associate a design check set with the profile
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the profile.
Links
Public Properties


SettingsProfile::SettingsCriteriaBasedDesignOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class > SettingsProfile::SettingsCriteriaBasedDesignOptions Properties
SettingsProfile::SettingsCriteriaBasedDesignOptions Properties
Collapse All

The properties of SettingsProfile::SettingsCriteriaBasedDesignOptions are listed here.

Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
UseDesignChecksOption | Gets whether to associate a design check set with the profile
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the profile.
Links
Public Properties


SettingsProfile::SettingsCriteriaBasedDesignOptions::DefaultDesignCheckSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class > SettingsProfile::SettingsCriteriaBasedDesignOptions Properties > SettingsProfile::SettingsCriteriaBasedDesignOptions::DefaultDesignCheckSet Property
SettingsProfile::SettingsCriteriaBasedDesignOptions::DefaultDesignCheckSet Property
Collapse All

Gets the default design check set.

C#
public PropertyString DefaultDesignCheckSet;
Visual Basic
Public Property DefaultDesignCheckSet() As PropertyString
Links
SettingsProfile::SettingsCriteriaBasedDesignOptions Class, SettingsProfile::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsCriteriaBasedDesignOptions::UseDesignChecksOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class > SettingsProfile::SettingsCriteriaBasedDesignOptions Properties > SettingsProfile::SettingsCriteriaBasedDesignOptions::UseDesignChecksOption Property
SettingsProfile::SettingsCriteriaBasedDesignOptions::UseDesignChecksOption Property
Collapse All

Gets whether to associate a design check set with the profile

C#
public PropertyBoolean UseDesignChecksOption;
Visual Basic
Public Property UseDesignChecksOption() As PropertyBoolean
Links
SettingsProfile::SettingsCriteriaBasedDesignOptions Class, SettingsProfile::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class > SettingsProfile::SettingsCriteriaBasedDesignOptions Properties > SettingsProfile::SettingsCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property
SettingsProfile::SettingsCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property
Collapse All

Gets whether to associate a design criteria file with the profile.

C#
public PropertyBoolean UseDesignCriteriaFileOption;
Visual Basic
Public Property UseDesignCriteriaFileOption() As PropertyBoolean
Links
SettingsProfile::SettingsCriteriaBasedDesignOptions Class, SettingsProfile::SettingsCriteriaBasedDesignOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsDefaultNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class
SettingsProfile::SettingsDefaultNameFormat Class
Collapse All

Default name format setting class

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfile::SettingsDefaultNameFormat
C#
public class SettingsProfile::SettingsDefaultNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsProfile::SettingsDefaultNameFormat
Inherits TreeOidWrapper
Links
SettingsProfile::SettingsDefaultNameFormat Properties, SettingsProfile::SettingsDefaultNameFormat Members, Class Hierarchy


SettingsProfile::SettingsDefaultNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Members
SettingsProfile::SettingsDefaultNameFormat Members
Collapse All

The following tables list the members exposed by SettingsProfile::SettingsDefaultNameFormat.

Public Properties
Public Property | Description
OffsetProfileNameTemplate | Gets the default name formats for default name formats for offset profiles
ProfileNameTemplate | Gets the default name formats for default name formats for profiles
SuperimposedProfileNameTemplate | Gets the default name formats for default name formats for superimposed profiles
ThreeDEntityProfileNameTemplate | Gets the default name formats for default name formats for 3D entity profiles
Links
Public Properties


SettingsProfile::SettingsDefaultNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Properties
SettingsProfile::SettingsDefaultNameFormat Properties
Collapse All

The properties of SettingsProfile::SettingsDefaultNameFormat are listed here.

Public Properties
Public Property | Description
OffsetProfileNameTemplate | Gets the default name formats for default name formats for offset profiles
ProfileNameTemplate | Gets the default name formats for default name formats for profiles
SuperimposedProfileNameTemplate | Gets the default name formats for default name formats for superimposed profiles
ThreeDEntityProfileNameTemplate | Gets the default name formats for default name formats for 3D entity profiles
Links
Public Properties


SettingsProfile::SettingsDefaultNameFormat::OffsetProfileNameTemplate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Properties > SettingsProfile::SettingsDefaultNameFormat::OffsetProfileNameTemplate Property
SettingsProfile::SettingsDefaultNameFormat::OffsetProfileNameTemplate Property
Collapse All

Gets the default name formats for default name formats for offset profiles

C#
public PropertyString OffsetProfileNameTemplate;
Visual Basic
Public Property OffsetProfileNameTemplate() As PropertyString
Links
SettingsProfile::SettingsDefaultNameFormat Class, SettingsProfile::SettingsDefaultNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsDefaultNameFormat::ProfileNameTemplate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Properties > SettingsProfile::SettingsDefaultNameFormat::ProfileNameTemplate Property
SettingsProfile::SettingsDefaultNameFormat::ProfileNameTemplate Property
Collapse All

Gets the default name formats for default name formats for profiles

C#
public PropertyString ProfileNameTemplate;
Visual Basic
Public Property ProfileNameTemplate() As PropertyString
Links
SettingsProfile::SettingsDefaultNameFormat Class, SettingsProfile::SettingsDefaultNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsDefaultNameFormat::SuperimposedProfileNameTemplate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Properties > SettingsProfile::SettingsDefaultNameFormat::SuperimposedProfileNameTemplate Property
SettingsProfile::SettingsDefaultNameFormat::SuperimposedProfileNameTemplate Property
Collapse All

Gets the default name formats for default name formats for superimposed profiles

C#
public PropertyString SuperimposedProfileNameTemplate;
Visual Basic
Public Property SuperimposedProfileNameTemplate() As PropertyString
Links
SettingsProfile::SettingsDefaultNameFormat Class, SettingsProfile::SettingsDefaultNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsDefaultNameFormat::ThreeDEntityProfileNameTemplate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Properties > SettingsProfile::SettingsDefaultNameFormat::ThreeDEntityProfileNameTemplate Property
SettingsProfile::SettingsDefaultNameFormat::ThreeDEntityProfileNameTemplate Property
Collapse All

Gets the default name formats for default name formats for 3D entity profiles

C#
public PropertyString ThreeDEntityProfileNameTemplate;
Visual Basic
Public Property ThreeDEntityProfileNameTemplate() As PropertyString
Links
SettingsProfile::SettingsDefaultNameFormat Class, SettingsProfile::SettingsDefaultNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class
SettingsProfile::SettingsProfileCreation Class
Collapse All

Default values for vertical curve sub-entities

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfile::SettingsProfileCreation
C#
public class SettingsProfile::SettingsProfileCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsProfile::SettingsProfileCreation
Inherits TreeOidWrapper
Links
SettingsProfile::SettingsProfileCreation Properties, SettingsProfile::SettingsProfileCreation Members, Class Hierarchy


SettingsProfile::SettingsProfileCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Members
SettingsProfile::SettingsProfileCreation Members
Collapse All

The following tables list the members exposed by SettingsProfile::SettingsProfileCreation.

Public Properties
Public Property | Description
AsymmetricalCrestCurveLength1 | Gets the default length for the first part of the asymmetrical crest curve.
AsymmetricalCrestCurveLength2 | Gets the default length for the second part of the asymmetrical crest curve.
AsymmetricalSagCurveLength1 | Gets the default length for the first part of the asymmetrical sag curve.
AsymmetricalSagCurveLength2 | Gets the default length for the second part of the asymmetrical sag curve.
CircularCrestCurveConstraint | Gets whether curve length or radius is the primary constraint on a circular crest curve.
CircularCrestCurveLength | Gets the default length for a circular crest curve.
CircularCrestCurveRadius | Gets the default radius for a circular crest curve.
CircularSagCurveConstraint | Gets whether curve length or radius is the primary constraint on a circular sag curve.
CircularSagCurveLength | Gets the default length for a circular sag curve.
CircularSagCurveRadius | Gets the default radius for a circular sag curve.
DefaultVerticalCurve | Gets the default vertical curve type for a new profile.
HeadlightAngle | Gets the default headlight angle.
HeadlightHeight | Gets the default headlight height.
ParabolicCrestCurveKValue | Gets the default K-value for a parabolic crest curve.
ParabolicCrestCurveLength | Gets the default length for a parabolic crest curve.
ParabolicCrestVerticalConstraint | Gets whether curve length or K value is the primary constraint on a parabolic crest curve.
ParabolicSagCurveKValue | Gets the default K-value for a parabolic sag curve.
ParabolicSagCurveLength | Gets the default length for a parabolic sag curve.
ParabolicSagVerticalConstraint | Gets whether curve length or K value is the primary constraint on a parabolic sag curve.
PassingEyeHeight | Gets the default passing eye height.
PassingObjectHeight | Gets the default passing object height.
StopEyeHeight | Gets the default stop eye height.
StopObjectHeight | Gets the default stop object height.
Links
Public Properties


SettingsProfile::SettingsProfileCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties
SettingsProfile::SettingsProfileCreation Properties
Collapse All

The properties of SettingsProfile::SettingsProfileCreation are listed here.

Public Properties
Public Property | Description
AsymmetricalCrestCurveLength1 | Gets the default length for the first part of the asymmetrical crest curve.
AsymmetricalCrestCurveLength2 | Gets the default length for the second part of the asymmetrical crest curve.
AsymmetricalSagCurveLength1 | Gets the default length for the first part of the asymmetrical sag curve.
AsymmetricalSagCurveLength2 | Gets the default length for the second part of the asymmetrical sag curve.
CircularCrestCurveConstraint | Gets whether curve length or radius is the primary constraint on a circular crest curve.
CircularCrestCurveLength | Gets the default length for a circular crest curve.
CircularCrestCurveRadius | Gets the default radius for a circular crest curve.
CircularSagCurveConstraint | Gets whether curve length or radius is the primary constraint on a circular sag curve.
CircularSagCurveLength | Gets the default length for a circular sag curve.
CircularSagCurveRadius | Gets the default radius for a circular sag curve.
DefaultVerticalCurve | Gets the default vertical curve type for a new profile.
HeadlightAngle | Gets the default headlight angle.
HeadlightHeight | Gets the default headlight height.
ParabolicCrestCurveKValue | Gets the default K-value for a parabolic crest curve.
ParabolicCrestCurveLength | Gets the default length for a parabolic crest curve.
ParabolicCrestVerticalConstraint | Gets whether curve length or K value is the primary constraint on a parabolic crest curve.
ParabolicSagCurveKValue | Gets the default K-value for a parabolic sag curve.
ParabolicSagCurveLength | Gets the default length for a parabolic sag curve.
ParabolicSagVerticalConstraint | Gets whether curve length or K value is the primary constraint on a parabolic sag curve.
PassingEyeHeight | Gets the default passing eye height.
PassingObjectHeight | Gets the default passing object height.
StopEyeHeight | Gets the default stop eye height.
StopObjectHeight | Gets the default stop object height.
Links
Public Properties


SettingsProfile::SettingsProfileCreation::AsymmetricalCrestCurveLength1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::AsymmetricalCrestCurveLength1 Property
SettingsProfile::SettingsProfileCreation::AsymmetricalCrestCurveLength1 Property
Collapse All

Gets the default length for the first part of the asymmetrical crest curve.

C#
public PropertyDouble AsymmetricalCrestCurveLength1;
Visual Basic
Public Property AsymmetricalCrestCurveLength1() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::AsymmetricalCrestCurveLength2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::AsymmetricalCrestCurveLength2 Property
SettingsProfile::SettingsProfileCreation::AsymmetricalCrestCurveLength2 Property
Collapse All

Gets the default length for the second part of the asymmetrical crest curve.

C#
public PropertyDouble AsymmetricalCrestCurveLength2;
Visual Basic
Public Property AsymmetricalCrestCurveLength2() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::AsymmetricalSagCurveLength1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::AsymmetricalSagCurveLength1 Property
SettingsProfile::SettingsProfileCreation::AsymmetricalSagCurveLength1 Property
Collapse All

Gets the default length for the first part of the asymmetrical sag curve.

C#
public PropertyDouble AsymmetricalSagCurveLength1;
Visual Basic
Public Property AsymmetricalSagCurveLength1() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::AsymmetricalSagCurveLength2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::AsymmetricalSagCurveLength2 Property
SettingsProfile::SettingsProfileCreation::AsymmetricalSagCurveLength2 Property
Collapse All

Gets the default length for the second part of the asymmetrical sag curve.

C#
public PropertyDouble AsymmetricalSagCurveLength2;
Visual Basic
Public Property AsymmetricalSagCurveLength2() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::CircularCrestCurveConstraint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::CircularCrestCurveConstraint Property
SettingsProfile::SettingsProfileCreation::CircularCrestCurveConstraint Property
Collapse All

Gets whether curve length or radius is the primary constraint on a circular crest curve.

C#
public PropertyEnum<ProfileCircularVerticalConstraintType> CircularCrestCurveConstraint;
Visual Basic
Public Property CircularCrestCurveConstraint() As PropertyEnum<ProfileCircularVerticalConstraintType>
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::CircularCrestCurveLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::CircularCrestCurveLength Property
SettingsProfile::SettingsProfileCreation::CircularCrestCurveLength Property
Collapse All

Gets the default length for a circular crest curve.

C#
public PropertyDouble CircularCrestCurveLength;
Visual Basic
Public Property CircularCrestCurveLength() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::CircularCrestCurveRadius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::CircularCrestCurveRadius Property
SettingsProfile::SettingsProfileCreation::CircularCrestCurveRadius Property
Collapse All

Gets the default radius for a circular crest curve.

C#
public PropertyDouble CircularCrestCurveRadius;
Visual Basic
Public Property CircularCrestCurveRadius() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::CircularSagCurveConstraint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::CircularSagCurveConstraint Property
SettingsProfile::SettingsProfileCreation::CircularSagCurveConstraint Property
Collapse All

Gets whether curve length or radius is the primary constraint on a circular sag curve.

C#
public PropertyEnum<ProfileCircularVerticalConstraintType> CircularSagCurveConstraint;
Visual Basic
Public Property CircularSagCurveConstraint() As PropertyEnum<ProfileCircularVerticalConstraintType>
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::CircularSagCurveLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::CircularSagCurveLength Property
SettingsProfile::SettingsProfileCreation::CircularSagCurveLength Property
Collapse All

Gets the default length for a circular sag curve.

C#
public PropertyDouble CircularSagCurveLength;
Visual Basic
Public Property CircularSagCurveLength() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::CircularSagCurveRadius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::CircularSagCurveRadius Property
SettingsProfile::SettingsProfileCreation::CircularSagCurveRadius Property
Collapse All

Gets the default radius for a circular sag curve.

C#
public PropertyDouble CircularSagCurveRadius;
Visual Basic
Public Property CircularSagCurveRadius() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::DefaultVerticalCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::DefaultVerticalCurve Property
SettingsProfile::SettingsProfileCreation::DefaultVerticalCurve Property
Collapse All

Gets the default vertical curve type for a new profile.

C#
public PropertyEnum<ProfileCurveType> DefaultVerticalCurve;
Visual Basic
Public Property DefaultVerticalCurve() As PropertyEnum<ProfileCurveType>
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::HeadlightAngle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::HeadlightAngle Property
SettingsProfile::SettingsProfileCreation::HeadlightAngle Property
Collapse All

Gets the default headlight angle.

C#
public PropertyDouble HeadlightAngle;
Visual Basic
Public Property HeadlightAngle() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::HeadlightHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::HeadlightHeight Property
SettingsProfile::SettingsProfileCreation::HeadlightHeight Property
Collapse All

Gets the default headlight height.

C#
public PropertyDouble HeadlightHeight;
Visual Basic
Public Property HeadlightHeight() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::ParabolicCrestCurveKValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::ParabolicCrestCurveKValue Property
SettingsProfile::SettingsProfileCreation::ParabolicCrestCurveKValue Property
Collapse All

Gets the default K-value for a parabolic crest curve.

C#
public PropertyDouble ParabolicCrestCurveKValue;
Visual Basic
Public Property ParabolicCrestCurveKValue() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::ParabolicCrestCurveLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::ParabolicCrestCurveLength Property
SettingsProfile::SettingsProfileCreation::ParabolicCrestCurveLength Property
Collapse All

Gets the default length for a parabolic crest curve.

C#
public PropertyDouble ParabolicCrestCurveLength;
Visual Basic
Public Property ParabolicCrestCurveLength() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::ParabolicCrestVerticalConstraint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::ParabolicCrestVerticalConstraint Property
SettingsProfile::SettingsProfileCreation::ParabolicCrestVerticalConstraint Property
Collapse All

Gets whether curve length or K value is the primary constraint on a parabolic crest curve.

C#
public PropertyEnum<ProfileParabolicVerticalConstraintType> ParabolicCrestVerticalConstraint;
Visual Basic
Public Property ParabolicCrestVerticalConstraint() As PropertyEnum<ProfileParabolicVerticalConstraintType>
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::ParabolicSagCurveKValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::ParabolicSagCurveKValue Property
SettingsProfile::SettingsProfileCreation::ParabolicSagCurveKValue Property
Collapse All

Gets the default K-value for a parabolic sag curve.

C#
public PropertyDouble ParabolicSagCurveKValue;
Visual Basic
Public Property ParabolicSagCurveKValue() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::ParabolicSagCurveLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::ParabolicSagCurveLength Property
SettingsProfile::SettingsProfileCreation::ParabolicSagCurveLength Property
Collapse All

Gets the default length for a parabolic sag curve.

C#
public PropertyDouble ParabolicSagCurveLength;
Visual Basic
Public Property ParabolicSagCurveLength() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::ParabolicSagVerticalConstraint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::ParabolicSagVerticalConstraint Property
SettingsProfile::SettingsProfileCreation::ParabolicSagVerticalConstraint Property
Collapse All

Gets whether curve length or K value is the primary constraint on a parabolic sag curve.

C#
public PropertyEnum<ProfileParabolicVerticalConstraintType> ParabolicSagVerticalConstraint;
Visual Basic
Public Property ParabolicSagVerticalConstraint() As PropertyEnum<ProfileParabolicVerticalConstraintType>
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::PassingEyeHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::PassingEyeHeight Property
SettingsProfile::SettingsProfileCreation::PassingEyeHeight Property
Collapse All

Gets the default passing eye height.

C#
public PropertyDouble PassingEyeHeight;
Visual Basic
Public Property PassingEyeHeight() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::PassingObjectHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::PassingObjectHeight Property
SettingsProfile::SettingsProfileCreation::PassingObjectHeight Property
Collapse All

Gets the default passing object height.

C#
public PropertyDouble PassingObjectHeight;
Visual Basic
Public Property PassingObjectHeight() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::StopEyeHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::StopEyeHeight Property
SettingsProfile::SettingsProfileCreation::StopEyeHeight Property
Collapse All

Gets the default stop eye height.

C#
public PropertyDouble StopEyeHeight;
Visual Basic
Public Property StopEyeHeight() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsProfileCreation::StopObjectHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties > SettingsProfile::SettingsProfileCreation::StopObjectHeight Property
SettingsProfile::SettingsProfileCreation::StopObjectHeight Property
Collapse All

Gets the default stop object height.

C#
public PropertyDouble StopObjectHeight;
Visual Basic
Public Property StopObjectHeight() As PropertyDouble
Links
SettingsProfile::SettingsProfileCreation Class, SettingsProfile::SettingsProfileCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class
SettingsProfile::SettingsStyles Class
Collapse All

Default styles.setting class

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfile::SettingsStyles
C#
public class SettingsProfile::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsProfile::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsProfile::SettingsStyles Properties, SettingsProfile::SettingsStyles Members, Class Hierarchy


SettingsProfile::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class > SettingsProfile::SettingsStyles Members
SettingsProfile::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsProfile::SettingsStyles.

Public Properties
Public Property | Description
ProfileLabelSet | Gets the default profile label set.
ProfileStyle | Gets the default profile style.
Links
Public Properties


SettingsProfile::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class > SettingsProfile::SettingsStyles Properties
SettingsProfile::SettingsStyles Properties
Collapse All

The properties of SettingsProfile::SettingsStyles are listed here.

Public Properties
Public Property | Description
ProfileLabelSet | Gets the default profile label set.
ProfileStyle | Gets the default profile style.
Links
Public Properties


SettingsProfile::SettingsStyles::ProfileLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class > SettingsProfile::SettingsStyles Properties > SettingsProfile::SettingsStyles::ProfileLabelSet Property
SettingsProfile::SettingsStyles::ProfileLabelSet Property
Collapse All

Gets the default profile label set.

C#
public PropertyString ProfileLabelSet;
Visual Basic
Public Property ProfileLabelSet() As PropertyString
Links
SettingsProfile::SettingsStyles Class, SettingsProfile::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfile::SettingsStyles::ProfileStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class > SettingsProfile::SettingsStyles Properties > SettingsProfile::SettingsStyles::ProfileStyle Property
SettingsProfile::SettingsStyles::ProfileStyle Property
Collapse All

Gets the default profile style.

C#
public PropertyString ProfileStyle;
Visual Basic
Public Property ProfileStyle() As PropertyString
Links
SettingsProfile::SettingsStyles Class, SettingsProfile::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class
SettingsProfileView Class
Collapse All

Settings for ProfileView.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdAddProfileViewDepthLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddProfileViewStaElevLbl
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdProjectObjectsToProf
C#
public class SettingsProfileView : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsProfileView
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsProfileView Properties, SettingsProfileView Members, Class Hierarchy


SettingsProfileView Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Members
SettingsProfileView Members
Collapse All

The following tables list the members exposed by SettingsProfileView.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Creation | Gets style settings for profile view.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets style settings for profile view.
ProjectionLabelPlacement | Gets style settings for profile view.
Slope | The Slope settings
Speed | The Speed settings
SplitOptions | Gets style settings for profile view.
StackedOptions | Gets style settings for profile view.
Station | The Station settings
Styles | Gets style settings for profile view.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsProfileView Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Properties
SettingsProfileView Properties
Collapse All

The properties of SettingsProfileView are listed here.

Public Properties
Public Property | Description
Creation | Gets style settings for profile view.
NameFormat | Gets style settings for profile view.
ProjectionLabelPlacement | Gets style settings for profile view.
SplitOptions | Gets style settings for profile view.
StackedOptions | Gets style settings for profile view.
Styles | Gets style settings for profile view.
Links
Public Properties


SettingsProfileView::Creation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Properties > SettingsProfileView::Creation Property
SettingsProfileView::Creation Property
Collapse All

Gets style settings for profile view.

C#
public SettingsCreation Creation;
Visual Basic
Public Property Creation() As SettingsCreation
Links
SettingsProfileView Class, SettingsProfileView Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Properties > SettingsProfileView::NameFormat Property
SettingsProfileView::NameFormat Property
Collapse All

Gets style settings for profile view.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsProfileView Class, SettingsProfileView Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::ProjectionLabelPlacement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Properties > SettingsProfileView::ProjectionLabelPlacement Property
SettingsProfileView::ProjectionLabelPlacement Property
Collapse All

Gets style settings for profile view.

C#
public SettingsProjectionLabelPlacement ProjectionLabelPlacement;
Visual Basic
Public Property ProjectionLabelPlacement() As SettingsProjectionLabelPlacement
Links
SettingsProfileView Class, SettingsProfileView Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SplitOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Properties > SettingsProfileView::SplitOptions Property
SettingsProfileView::SplitOptions Property
Collapse All

Gets style settings for profile view.

C#
public SettingsSplitOptions SplitOptions;
Visual Basic
Public Property SplitOptions() As SettingsSplitOptions
Links
SettingsProfileView Class, SettingsProfileView Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::StackedOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Properties > SettingsProfileView::StackedOptions Property
SettingsProfileView::StackedOptions Property
Collapse All

Gets style settings for profile view.

C#
public SettingsStackedOptions StackedOptions;
Visual Basic
Public Property StackedOptions() As SettingsStackedOptions
Links
SettingsProfileView Class, SettingsProfileView Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Properties > SettingsProfileView::Styles Property
SettingsProfileView::Styles Property
Collapse All

Gets style settings for profile view.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsProfileView Class, SettingsProfileView Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class
SettingsProfileView::SettingsCreation Class
Collapse All

Settings for ProfileView default Creation.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsCreation
C#
public class SettingsProfileView::SettingsCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsProfileView::SettingsCreation
Inherits TreeOidWrapper
Links
SettingsProfileView::SettingsCreation Properties, SettingsProfileView::SettingsCreation Members, Class Hierarchy


SettingsProfileView::SettingsCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class > SettingsProfileView::SettingsCreation Members
SettingsProfileView::SettingsCreation Members
Collapse All

The following tables list the members exposed by SettingsProfileView::SettingsCreation.

Public Properties
Public Property | Description
PipeNetworkParts | Settings for PipeNetworkParts.
SpecifyProfileElevationRange | Settings for SpecifyProfileElevationRange.
SpecifyProfileStationRange | Settings for SpecifyProfileElevationRange.
Links
Public Properties


SettingsProfileView::SettingsCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class > SettingsProfileView::SettingsCreation Properties
SettingsProfileView::SettingsCreation Properties
Collapse All

The properties of SettingsProfileView::SettingsCreation are listed here.

Public Properties
Public Property | Description
PipeNetworkParts | Settings for PipeNetworkParts.
SpecifyProfileElevationRange | Settings for SpecifyProfileElevationRange.
SpecifyProfileStationRange | Settings for SpecifyProfileElevationRange.
Links
Public Properties


SettingsProfileView::SettingsCreation::PipeNetworkParts Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class > SettingsProfileView::SettingsCreation Properties > SettingsProfileView::SettingsCreation::PipeNetworkParts Property
SettingsProfileView::SettingsCreation::PipeNetworkParts Property
Collapse All

Settings for PipeNetworkParts.

C#
public PropertyEnum<PipeNetworkPartDisplayType> PipeNetworkParts;
Visual Basic
Public Property PipeNetworkParts() As PropertyEnum<PipeNetworkPartDisplayType>
Links
SettingsProfileView::SettingsCreation Class, SettingsProfileView::SettingsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsCreation::SpecifyProfileElevationRange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class > SettingsProfileView::SettingsCreation Properties > SettingsProfileView::SettingsCreation::SpecifyProfileElevationRange Property
SettingsProfileView::SettingsCreation::SpecifyProfileElevationRange Property
Collapse All

Settings for SpecifyProfileElevationRange.

C#
public PropertyBoolean SpecifyProfileElevationRange;
Visual Basic
Public Property SpecifyProfileElevationRange() As PropertyBoolean
Links
SettingsProfileView::SettingsCreation Class, SettingsProfileView::SettingsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsCreation::SpecifyProfileStationRange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class > SettingsProfileView::SettingsCreation Properties > SettingsProfileView::SettingsCreation::SpecifyProfileStationRange Property
SettingsProfileView::SettingsCreation::SpecifyProfileStationRange Property
Collapse All

Settings for SpecifyProfileElevationRange.

C#
public PropertyBoolean SpecifyProfileStationRange;
Visual Basic
Public Property SpecifyProfileStationRange() As PropertyBoolean
Links
SettingsProfileView::SettingsCreation Class, SettingsProfileView::SettingsCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class
SettingsProfileView::SettingsNameFormat Class
Collapse All

Settings for ProfileView default NameFormat.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsNameFormat
C#
public class SettingsProfileView::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsProfileView::SettingsNameFormat
Inherits TreeOidWrapper
Remarks

Profile View Station Range property is followed by a number of parameters that define how the text is displayed. Using this property without using its parameters would make it using default values. U—Units: Select one of ft (foot), m (meter), mile (mile), km (kilometer), in (inch), or yd (yard). The default is Uft. F—Format: Select either S (station format) or D (DD.DDDDDD decimal). The default is FS. P—Precision: Select one of 0 (1), 1 (0.1), 2 (0.01), ... , or 8 (0.00000001). The default is P2. R—Rounding: Select one of N (round normal), U (round up), or T (truncate). The default is RN. S—Sign: Select one of n (sign negative ‘-’), Bn ((Bracket negative)), a (sign always (±)), D (drop sign), BL (‘(‘ left prentice), or BR (right prentice ‘(‘). The default is Sn. O—Output: Select one of F (full), LD (left of decimal), RD (right of decimal), DS (decimal character), LB (left of station character), RB (right of station character), BBD (between station character and decimal), or BC (station character). The default is OF. A—Decimal character: Select either P (‘.’ period) or C (‘,’ comma). The default is AP. B—Station character position: Select one of 1 (1+0), 2 (1+00), 3 (1+000), 4 (1+0000), or 5 (1+00000). The default is B2. T—Station character: Select one of P (plus sign ‘+’), M (minus sign ‘-’), A (automatic (±)), U (underscore ‘_’), or N (none). The default is TP. E—Drop decimal for whole number: Select either N (No) or Y (Yes). The default is EN. W—Minimum display width: Select one of 0 (none), 1, 2, ..., 32. The default is W0. DZ—Drop leading zeros: Select one of Y (yes) or N (no). The default is DZN. For example, a profile view name, using the above defaults and following the “rules” of the parameters, could look like this: 2+50.00 (2)

Links
SettingsProfileView::SettingsNameFormat Properties, SettingsProfileView::SettingsNameFormat Members, Class Hierarchy


SettingsProfileView::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Members
SettingsProfileView::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsProfileView::SettingsNameFormat.

Public Properties
Public Property | Description
CutArea | Settings for CutArea name template.
FillArea | Settings for FillArea name template.
MultipleBoundaryArea | Settings for MultipleBoundaryArea name template.
ProfileView | Settings for ProfileView name template.
Links
Public Properties


SettingsProfileView::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Properties
SettingsProfileView::SettingsNameFormat Properties
Collapse All

The properties of SettingsProfileView::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
CutArea | Settings for CutArea name template.
FillArea | Settings for FillArea name template.
MultipleBoundaryArea | Settings for MultipleBoundaryArea name template.
ProfileView | Settings for ProfileView name template.
Links
Public Properties


SettingsProfileView::SettingsNameFormat::CutArea Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Properties > SettingsProfileView::SettingsNameFormat::CutArea Property
SettingsProfileView::SettingsNameFormat::CutArea Property
Collapse All

Settings for CutArea name template.

C#
public PropertyString CutArea;
Visual Basic
Public Property CutArea() As PropertyString
Links
SettingsProfileView::SettingsNameFormat Class, SettingsProfileView::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsNameFormat::FillArea Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Properties > SettingsProfileView::SettingsNameFormat::FillArea Property
SettingsProfileView::SettingsNameFormat::FillArea Property
Collapse All

Settings for FillArea name template.

C#
public PropertyString FillArea;
Visual Basic
Public Property FillArea() As PropertyString
Links
SettingsProfileView::SettingsNameFormat Class, SettingsProfileView::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsNameFormat::MultipleBoundaryArea Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Properties > SettingsProfileView::SettingsNameFormat::MultipleBoundaryArea Property
SettingsProfileView::SettingsNameFormat::MultipleBoundaryArea Property
Collapse All

Settings for MultipleBoundaryArea name template.

C#
public PropertyString MultipleBoundaryArea;
Visual Basic
Public Property MultipleBoundaryArea() As PropertyString
Links
SettingsProfileView::SettingsNameFormat Class, SettingsProfileView::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsNameFormat::ProfileView Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Properties > SettingsProfileView::SettingsNameFormat::ProfileView Property
SettingsProfileView::SettingsNameFormat::ProfileView Property
Collapse All

Settings for ProfileView name template.

C#
public PropertyString ProfileView;
Visual Basic
Public Property ProfileView() As PropertyString
Links
SettingsProfileView::SettingsNameFormat Class, SettingsProfileView::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsProjectionLabelPlacement Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class
SettingsProfileView::SettingsProjectionLabelPlacement Class
Collapse All

Settings for ProfileView default ProjectionLabelPlacement.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsProjectionLabelPlacement
C#
public class SettingsProfileView::SettingsProjectionLabelPlacement : TreeOidWrapper;
Visual Basic
Public Class SettingsProfileView::SettingsProjectionLabelPlacement
Inherits TreeOidWrapper
Links
SettingsProfileView::SettingsProjectionLabelPlacement Properties, SettingsProfileView::SettingsProjectionLabelPlacement Members, Class Hierarchy


SettingsProfileView::SettingsProjectionLabelPlacement Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class > SettingsProfileView::SettingsProjectionLabelPlacement Members
SettingsProfileView::SettingsProjectionLabelPlacement Members
Collapse All

The following tables list the members exposed by SettingsProfileView::SettingsProjectionLabelPlacement.

Public Properties
Public Property | Description
DimensionAnchorElevationValueForProjections | Settings for DimensionAnchorElevationValueforProjections.
DimensionAnchorOption | Settings for DimensionAnchorOption.
DimensionAnchorPlotHeightValueForProjections | Settings for DimensionAnchorPlotHeightValueforProjections.
Links
Public Properties


SettingsProfileView::SettingsProjectionLabelPlacement Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class > SettingsProfileView::SettingsProjectionLabelPlacement Properties
SettingsProfileView::SettingsProjectionLabelPlacement Properties
Collapse All

The properties of SettingsProfileView::SettingsProjectionLabelPlacement are listed here.

Public Properties
Public Property | Description
DimensionAnchorElevationValueForProjections | Settings for DimensionAnchorElevationValueforProjections.
DimensionAnchorOption | Settings for DimensionAnchorOption.
DimensionAnchorPlotHeightValueForProjections | Settings for DimensionAnchorPlotHeightValueforProjections.
Links
Public Properties


SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorElevationValueForProjections Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class > SettingsProfileView::SettingsProjectionLabelPlacement Properties > SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorElevationValueForProjections Property
SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorElevationValueForProjections Property
Collapse All

Settings for DimensionAnchorElevationValueforProjections.

C#
public PropertyDouble DimensionAnchorElevationValueForProjections;
Visual Basic
Public Property DimensionAnchorElevationValueForProjections() As PropertyDouble
Links
SettingsProfileView::SettingsProjectionLabelPlacement Class, SettingsProfileView::SettingsProjectionLabelPlacement Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class > SettingsProfileView::SettingsProjectionLabelPlacement Properties > SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorOption Property
SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorOption Property
Collapse All

Settings for DimensionAnchorOption.

C#
public PropertyEnum<DimensionAnchorType> DimensionAnchorOption;
Visual Basic
Public Property DimensionAnchorOption() As PropertyEnum<DimensionAnchorType>
Links
SettingsProfileView::SettingsProjectionLabelPlacement Class, SettingsProfileView::SettingsProjectionLabelPlacement Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorPlotHeightValueForProjections Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class > SettingsProfileView::SettingsProjectionLabelPlacement Properties > SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorPlotHeightValueForProjections Property
SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorPlotHeightValueForProjections Property
Collapse All

Settings for DimensionAnchorPlotHeightValueforProjections.

C#
public PropertyDouble DimensionAnchorPlotHeightValueForProjections;
Visual Basic
Public Property DimensionAnchorPlotHeightValueForProjections() As PropertyDouble
Links
SettingsProfileView::SettingsProjectionLabelPlacement Class, SettingsProfileView::SettingsProjectionLabelPlacement Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsSplitOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class
SettingsProfileView::SettingsSplitOptions Class
Collapse All

Settings for ProfileView default SplitOptions.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsSplitOptions
C#
public class SettingsProfileView::SettingsSplitOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsProfileView::SettingsSplitOptions
Inherits TreeOidWrapper
Links
SettingsProfileView::SettingsSplitOptions Properties, SettingsProfileView::SettingsSplitOptions Members, Class Hierarchy


SettingsProfileView::SettingsSplitOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class > SettingsProfileView::SettingsSplitOptions Members
SettingsProfileView::SettingsSplitOptions Members
Collapse All

The following tables list the members exposed by SettingsProfileView::SettingsSplitOptions.

Public Properties
Public Property | Description
SplitDatumOption | Settings for SplitDatumOption.
SplitProfileViews | Settings for SplitProfileViews.
SplitStationOption | Settings for SplitStationOption.
Links
Public Properties


SettingsProfileView::SettingsSplitOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class > SettingsProfileView::SettingsSplitOptions Properties
SettingsProfileView::SettingsSplitOptions Properties
Collapse All

The properties of SettingsProfileView::SettingsSplitOptions are listed here.

Public Properties
Public Property | Description
SplitDatumOption | Settings for SplitDatumOption.
SplitProfileViews | Settings for SplitProfileViews.
SplitStationOption | Settings for SplitStationOption.
Links
Public Properties


SettingsProfileView::SettingsSplitOptions::SplitDatumOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class > SettingsProfileView::SettingsSplitOptions Properties > SettingsProfileView::SettingsSplitOptions::SplitDatumOption Property
SettingsProfileView::SettingsSplitOptions::SplitDatumOption Property
Collapse All

Settings for SplitDatumOption.

C#
public PropertyEnum<ProfileViewSplitDatumType> SplitDatumOption;
Visual Basic
Public Property SplitDatumOption() As PropertyEnum<ProfileViewSplitDatumType>
Links
SettingsProfileView::SettingsSplitOptions Class, SettingsProfileView::SettingsSplitOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsSplitOptions::SplitProfileViews Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class > SettingsProfileView::SettingsSplitOptions Properties > SettingsProfileView::SettingsSplitOptions::SplitProfileViews Property
SettingsProfileView::SettingsSplitOptions::SplitProfileViews Property
Collapse All

Settings for SplitProfileViews.

C#
public PropertyBoolean SplitProfileViews;
Visual Basic
Public Property SplitProfileViews() As PropertyBoolean
Links
SettingsProfileView::SettingsSplitOptions Class, SettingsProfileView::SettingsSplitOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsSplitOptions::SplitStationOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class > SettingsProfileView::SettingsSplitOptions Properties > SettingsProfileView::SettingsSplitOptions::SplitStationOption Property
SettingsProfileView::SettingsSplitOptions::SplitStationOption Property
Collapse All

Settings for SplitStationOption.

C#
public PropertyEnum<ProfileViewSplitStationType> SplitStationOption;
Visual Basic
Public Property SplitStationOption() As PropertyEnum<ProfileViewSplitStationType>
Links
SettingsProfileView::SettingsSplitOptions Class, SettingsProfileView::SettingsSplitOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStackedOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class
SettingsProfileView::SettingsStackedOptions Class
Collapse All

Settings for ProfileView default StackedOptions.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsStackedOptions
C#
public class SettingsProfileView::SettingsStackedOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsProfileView::SettingsStackedOptions
Inherits TreeOidWrapper
Links
SettingsProfileView::SettingsStackedOptions Properties, SettingsProfileView::SettingsStackedOptions Members, Class Hierarchy


SettingsProfileView::SettingsStackedOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class > SettingsProfileView::SettingsStackedOptions Members
SettingsProfileView::SettingsStackedOptions Members
Collapse All

The following tables list the members exposed by SettingsProfileView::SettingsStackedOptions.

Public Properties
Public Property | Description
GapBetweenViews | Settings for GapBetweenViews.
NumberOfStackedViews | Settings for NumberofStackedViews.
StackedViews | Settings for StackedViews.
Links
Public Properties


SettingsProfileView::SettingsStackedOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class > SettingsProfileView::SettingsStackedOptions Properties
SettingsProfileView::SettingsStackedOptions Properties
Collapse All

The properties of SettingsProfileView::SettingsStackedOptions are listed here.

Public Properties
Public Property | Description
GapBetweenViews | Settings for GapBetweenViews.
NumberOfStackedViews | Settings for NumberofStackedViews.
StackedViews | Settings for StackedViews.
Links
Public Properties


SettingsProfileView::SettingsStackedOptions::GapBetweenViews Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class > SettingsProfileView::SettingsStackedOptions Properties > SettingsProfileView::SettingsStackedOptions::GapBetweenViews Property
SettingsProfileView::SettingsStackedOptions::GapBetweenViews Property
Collapse All

Settings for GapBetweenViews.

C#
public PropertyDouble GapBetweenViews;
Visual Basic
Public Property GapBetweenViews() As PropertyDouble
Links
SettingsProfileView::SettingsStackedOptions Class, SettingsProfileView::SettingsStackedOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStackedOptions::NumberOfStackedViews Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class > SettingsProfileView::SettingsStackedOptions Properties > SettingsProfileView::SettingsStackedOptions::NumberOfStackedViews Property
SettingsProfileView::SettingsStackedOptions::NumberOfStackedViews Property
Collapse All

Settings for NumberofStackedViews.

C#
public PropertyInt NumberOfStackedViews;
Visual Basic
Public Property NumberOfStackedViews() As PropertyInt
Links
SettingsProfileView::SettingsStackedOptions Class, SettingsProfileView::SettingsStackedOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStackedOptions::StackedViews Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class > SettingsProfileView::SettingsStackedOptions Properties > SettingsProfileView::SettingsStackedOptions::StackedViews Property
SettingsProfileView::SettingsStackedOptions::StackedViews Property
Collapse All

Settings for StackedViews.

C#
public PropertyBoolean StackedViews;
Visual Basic
Public Property StackedViews() As PropertyBoolean
Links
SettingsProfileView::SettingsStackedOptions Class, SettingsProfileView::SettingsStackedOptions Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class
SettingsProfileView::SettingsStyles Class
Collapse All

Settings for ProfileView default Styles.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsStyles
C#
public class SettingsProfileView::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsProfileView::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsProfileView::SettingsStyles Properties, SettingsProfileView::SettingsStyles Members, Class Hierarchy


SettingsProfileView::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Members
SettingsProfileView::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsProfileView::SettingsStyles.

Public Properties
Public Property | Description
BottomStackViewStyle | Settings for ProfileView BottomStackViewStyle.
CutAreaShapeStyle | Settings for ProfileView CutAreaShapeStyle.
FillAreaShapeStyle | Settings for ProfileView FillAreaShapeStyle.
FirstSplitViewStyle | Settings for ProfileView FirstSliptViewStyle.
IntermediateSplitViewStyle | Settings for ProfileView IntermediateSplitViewStyle.
LastSplitViewStyle | Settings for ProfileView LastSplitViewStyle.
MarkerStyle | Settings for ProfileView MarkerStyle.
MiddleStackViewStyle | Settings for ProfileView MiddleStackViewStyle.
MultipleBoundaryAreaShapeStyle | Settings for ProfileView MultipleBoundaryAreaShapeStyle.
ProfileDepthLabelStyle | Settings for ProfileView ProfileDepthLabelStyle.
ProfileLabelSet | Settings for ProfileView ProfileLabelSet.
ProfileLabelStyle | Settings for ProfileView ProfileLabelStyle.
ProfileProjectionLabelStyle | Settings for ProfileView ProfileProjectionLabelStyle.
ProfileStationAndElevationLabelStyle | Settings for ProfileView ProfileStationandElevationLabelStyle.
ProfileViewBandStyle | Settings for ProfileView ProfileViewBandStyle.
ProfileViewStyle | Settings for ProfileView ProfileViewStyle.
ProjectionStyle | Settings for ProfileView ProjectionStyle.
TopStackViewStyle | Settings for ProfileView TopStackViewStyle.
Links
Public Properties


SettingsProfileView::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties
SettingsProfileView::SettingsStyles Properties
Collapse All

The properties of SettingsProfileView::SettingsStyles are listed here.

Public Properties
Public Property | Description
BottomStackViewStyle | Settings for ProfileView BottomStackViewStyle.
CutAreaShapeStyle | Settings for ProfileView CutAreaShapeStyle.
FillAreaShapeStyle | Settings for ProfileView FillAreaShapeStyle.
FirstSplitViewStyle | Settings for ProfileView FirstSliptViewStyle.
IntermediateSplitViewStyle | Settings for ProfileView IntermediateSplitViewStyle.
LastSplitViewStyle | Settings for ProfileView LastSplitViewStyle.
MarkerStyle | Settings for ProfileView MarkerStyle.
MiddleStackViewStyle | Settings for ProfileView MiddleStackViewStyle.
MultipleBoundaryAreaShapeStyle | Settings for ProfileView MultipleBoundaryAreaShapeStyle.
ProfileDepthLabelStyle | Settings for ProfileView ProfileDepthLabelStyle.
ProfileLabelSet | Settings for ProfileView ProfileLabelSet.
ProfileLabelStyle | Settings for ProfileView ProfileLabelStyle.
ProfileProjectionLabelStyle | Settings for ProfileView ProfileProjectionLabelStyle.
ProfileStationAndElevationLabelStyle | Settings for ProfileView ProfileStationandElevationLabelStyle.
ProfileViewBandStyle | Settings for ProfileView ProfileViewBandStyle.
ProfileViewStyle | Settings for ProfileView ProfileViewStyle.
ProjectionStyle | Settings for ProfileView ProjectionStyle.
TopStackViewStyle | Settings for ProfileView TopStackViewStyle.
Links
Public Properties


SettingsProfileView::SettingsStyles::BottomStackViewStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::BottomStackViewStyle Property
SettingsProfileView::SettingsStyles::BottomStackViewStyle Property
Collapse All

Settings for ProfileView BottomStackViewStyle.

C#
public PropertyString BottomStackViewStyle;
Visual Basic
Public Property BottomStackViewStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::CutAreaShapeStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::CutAreaShapeStyle Property
SettingsProfileView::SettingsStyles::CutAreaShapeStyle Property
Collapse All

Settings for ProfileView CutAreaShapeStyle.

C#
public PropertyString CutAreaShapeStyle;
Visual Basic
Public Property CutAreaShapeStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::FillAreaShapeStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::FillAreaShapeStyle Property
SettingsProfileView::SettingsStyles::FillAreaShapeStyle Property
Collapse All

Settings for ProfileView FillAreaShapeStyle.

C#
public PropertyString FillAreaShapeStyle;
Visual Basic
Public Property FillAreaShapeStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::FirstSplitViewStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::FirstSplitViewStyle Property
SettingsProfileView::SettingsStyles::FirstSplitViewStyle Property
Collapse All

Settings for ProfileView FirstSliptViewStyle.

C#
public PropertyString FirstSplitViewStyle;
Visual Basic
Public Property FirstSplitViewStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::IntermediateSplitViewStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::IntermediateSplitViewStyle Property
SettingsProfileView::SettingsStyles::IntermediateSplitViewStyle Property
Collapse All

Settings for ProfileView IntermediateSplitViewStyle.

C#
public PropertyString IntermediateSplitViewStyle;
Visual Basic
Public Property IntermediateSplitViewStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::LastSplitViewStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::LastSplitViewStyle Property
SettingsProfileView::SettingsStyles::LastSplitViewStyle Property
Collapse All

Settings for ProfileView LastSplitViewStyle.

C#
public PropertyString LastSplitViewStyle;
Visual Basic
Public Property LastSplitViewStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::MarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::MarkerStyle Property
SettingsProfileView::SettingsStyles::MarkerStyle Property
Collapse All

Settings for ProfileView MarkerStyle.

C#
public PropertyString MarkerStyle;
Visual Basic
Public Property MarkerStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::MiddleStackViewStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::MiddleStackViewStyle Property
SettingsProfileView::SettingsStyles::MiddleStackViewStyle Property
Collapse All

Settings for ProfileView MiddleStackViewStyle.

C#
public PropertyString MiddleStackViewStyle;
Visual Basic
Public Property MiddleStackViewStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::MultipleBoundaryAreaShapeStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::MultipleBoundaryAreaShapeStyle Property
SettingsProfileView::SettingsStyles::MultipleBoundaryAreaShapeStyle Property
Collapse All

Settings for ProfileView MultipleBoundaryAreaShapeStyle.

C#
public PropertyString MultipleBoundaryAreaShapeStyle;
Visual Basic
Public Property MultipleBoundaryAreaShapeStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::ProfileDepthLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::ProfileDepthLabelStyle Property
SettingsProfileView::SettingsStyles::ProfileDepthLabelStyle Property
Collapse All

Settings for ProfileView ProfileDepthLabelStyle.

C#
public PropertyString ProfileDepthLabelStyle;
Visual Basic
Public Property ProfileDepthLabelStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::ProfileLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::ProfileLabelSet Property
SettingsProfileView::SettingsStyles::ProfileLabelSet Property
Collapse All

Settings for ProfileView ProfileLabelSet.

C#
public PropertyString ProfileLabelSet;
Visual Basic
Public Property ProfileLabelSet() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::ProfileLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::ProfileLabelStyle Property
SettingsProfileView::SettingsStyles::ProfileLabelStyle Property deprecated
Collapse All

Settings for ProfileView ProfileLabelStyle.

C#
public PropertyString ProfileLabelStyle;
Visual Basic
Public Property ProfileLabelStyle() As PropertyString
Notes

Deprecated: Use Autodesk.Civil.Land.Settings.SettingsProfileView.SettingsStyles.ProfileLabelSet instead.

Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::ProfileProjectionLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::ProfileProjectionLabelStyle Property
SettingsProfileView::SettingsStyles::ProfileProjectionLabelStyle Property
Collapse All

Settings for ProfileView ProfileProjectionLabelStyle.

C#
public PropertyString ProfileProjectionLabelStyle;
Visual Basic
Public Property ProfileProjectionLabelStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::ProfileStationAndElevationLabelStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::ProfileStationAndElevationLabelStyle Property
SettingsProfileView::SettingsStyles::ProfileStationAndElevationLabelStyle Property
Collapse All

Settings for ProfileView ProfileStationandElevationLabelStyle.

C#
public PropertyString ProfileStationAndElevationLabelStyle;
Visual Basic
Public Property ProfileStationAndElevationLabelStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::ProfileViewBandStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::ProfileViewBandStyle Property
SettingsProfileView::SettingsStyles::ProfileViewBandStyle Property
Collapse All

Settings for ProfileView ProfileViewBandStyle.

C#
public PropertyString ProfileViewBandStyle;
Visual Basic
Public Property ProfileViewBandStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::ProfileViewStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::ProfileViewStyle Property
SettingsProfileView::SettingsStyles::ProfileViewStyle Property
Collapse All

Settings for ProfileView ProfileViewStyle.

C#
public PropertyString ProfileViewStyle;
Visual Basic
Public Property ProfileViewStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::ProjectionStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::ProjectionStyle Property
SettingsProfileView::SettingsStyles::ProjectionStyle Property
Collapse All

Settings for ProfileView ProjectionStyle.

C#
public PropertyString ProjectionStyle;
Visual Basic
Public Property ProjectionStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsProfileView::SettingsStyles::TopStackViewStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties > SettingsProfileView::SettingsStyles::TopStackViewStyle Property
SettingsProfileView::SettingsStyles::TopStackViewStyle Property
Collapse All

Settings for ProfileView TopStackViewStyle.

C#
public PropertyString TopStackViewStyle;
Visual Basic
Public Property TopStackViewStyle() As PropertyString
Links
SettingsProfileView::SettingsStyles Class, SettingsProfileView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSampleLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class
SettingsSampleLine Class
Collapse All

Settings for SampleLine.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSampleLine
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines
C#
public class SettingsSampleLine : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsSampleLine
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsSampleLine Properties, SettingsSampleLine Members, Class Hierarchy


SettingsSampleLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Members
SettingsSampleLine Members
Collapse All

The following tables list the members exposed by SettingsSampleLine.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for sample line.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to sample line.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsSampleLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Properties
SettingsSampleLine Properties
Collapse All

The properties of SettingsSampleLine are listed here.

Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for sample line.
Styles | Settings to establish the default styles assigned to sample line.
Links
Public Properties


SettingsSampleLine::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Properties > SettingsSampleLine::NameFormat Property
SettingsSampleLine::NameFormat Property
Collapse All

settings to specify the default name formats for sample line.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsSampleLine Class, SettingsSampleLine Members, Autodesk::Civil::Land::Settings Namespace


SettingsSampleLine::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Properties > SettingsSampleLine::Styles Property
SettingsSampleLine::Styles Property
Collapse All

Settings to establish the default styles assigned to sample line.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsSampleLine Class, SettingsSampleLine Members, Autodesk::Civil::Land::Settings Namespace


SettingsSampleLine::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class
SettingsSampleLine::SettingsNameFormat Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSampleLine::SettingsNameFormat
C#
public class SettingsSampleLine::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsSampleLine::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsSampleLine::SettingsNameFormat Properties, SettingsSampleLine::SettingsNameFormat Members, Class Hierarchy


SettingsSampleLine::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class > SettingsSampleLine::SettingsNameFormat Members
SettingsSampleLine::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsSampleLine::SettingsNameFormat.

Public Properties
Public Property | Description
SampleLine | Settings SampleLine default name format.
SampleLineGroup | Settings SampleLine group default name format.
Links
Public Properties


SettingsSampleLine::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class > SettingsSampleLine::SettingsNameFormat Properties
SettingsSampleLine::SettingsNameFormat Properties
Collapse All

The properties of SettingsSampleLine::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
SampleLine | Settings SampleLine default name format.
SampleLineGroup | Settings SampleLine group default name format.
Links
Public Properties


SettingsSampleLine::SettingsNameFormat::SampleLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class > SettingsSampleLine::SettingsNameFormat Properties > SettingsSampleLine::SettingsNameFormat::SampleLine Property
SettingsSampleLine::SettingsNameFormat::SampleLine Property
Collapse All

Settings SampleLine default name format.

C#
public PropertyString SampleLine;
Visual Basic
Public Property SampleLine() As PropertyString
Links
SettingsSampleLine::SettingsNameFormat Class, SettingsSampleLine::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsSampleLine::SettingsNameFormat::SampleLineGroup Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class > SettingsSampleLine::SettingsNameFormat Properties > SettingsSampleLine::SettingsNameFormat::SampleLineGroup Property
SettingsSampleLine::SettingsNameFormat::SampleLineGroup Property
Collapse All

Settings SampleLine group default name format.

C#
public PropertyString SampleLineGroup;
Visual Basic
Public Property SampleLineGroup() As PropertyString
Links
SettingsSampleLine::SettingsNameFormat Class, SettingsSampleLine::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsSampleLine::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class
SettingsSampleLine::SettingsStyles Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSampleLine::SettingsStyles
C#
public class SettingsSampleLine::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsSampleLine::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsSampleLine::SettingsStyles Properties, SettingsSampleLine::SettingsStyles Members, Class Hierarchy


SettingsSampleLine::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class > SettingsSampleLine::SettingsStyles Members
SettingsSampleLine::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsSampleLine::SettingsStyles.

Public Properties
Public Property | Description
SampleLine | Settings of SampleLine style.
SampleLineLabel | Settings of SampleLine label style.
Links
Public Properties


SettingsSampleLine::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class > SettingsSampleLine::SettingsStyles Properties
SettingsSampleLine::SettingsStyles Properties
Collapse All

The properties of SettingsSampleLine::SettingsStyles are listed here.

Public Properties
Public Property | Description
SampleLine | Settings of SampleLine style.
SampleLineLabel | Settings of SampleLine label style.
Links
Public Properties


SettingsSampleLine::SettingsStyles::SampleLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class > SettingsSampleLine::SettingsStyles Properties > SettingsSampleLine::SettingsStyles::SampleLine Property
SettingsSampleLine::SettingsStyles::SampleLine Property
Collapse All

Settings of SampleLine style.

C#
public PropertyString SampleLine;
Visual Basic
Public Property SampleLine() As PropertyString
Links
SettingsSampleLine::SettingsStyles Class, SettingsSampleLine::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSampleLine::SettingsStyles::SampleLineLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class > SettingsSampleLine::SettingsStyles Properties > SettingsSampleLine::SettingsStyles::SampleLineLabel Property
SettingsSampleLine::SettingsStyles::SampleLineLabel Property
Collapse All

Settings of SampleLine label style.

C#
public PropertyString SampleLineLabel;
Visual Basic
Public Property SampleLineLabel() As PropertyString
Links
SettingsSampleLine::SettingsStyles Class, SettingsSampleLine::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class
SettingsSection Class
Collapse All

Settings for Section.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSection
C#
public class SettingsSection : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsSection
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsSection Properties, SettingsSection Members, Class Hierarchy


SettingsSection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Members
SettingsSection Members
Collapse All

The following tables list the members exposed by SettingsSection.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for sample line.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to sample line.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsSection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Properties
SettingsSection Properties
Collapse All

The properties of SettingsSection are listed here.

Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for sample line.
Styles | Settings to establish the default styles assigned to sample line.
Links
Public Properties


SettingsSection::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Properties > SettingsSection::NameFormat Property
SettingsSection::NameFormat Property
Collapse All

settings to specify the default name formats for sample line.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsSection Class, SettingsSection Members, Autodesk::Civil::Land::Settings Namespace


SettingsSection::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Properties > SettingsSection::Styles Property
SettingsSection::Styles Property
Collapse All

Settings to establish the default styles assigned to sample line.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsSection Class, SettingsSection Members, Autodesk::Civil::Land::Settings Namespace


SettingsSection::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsNameFormat Class
SettingsSection::SettingsNameFormat Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSection::SettingsNameFormat
C#
public class SettingsSection::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsSection::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsSection::SettingsNameFormat Properties, SettingsSection::SettingsNameFormat Members, Class Hierarchy


SettingsSection::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsNameFormat Class > SettingsSection::SettingsNameFormat Members
SettingsSection::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsSection::SettingsNameFormat.

Public Properties
Public Property | Description
Section | Settings Section default name format.
Links
Public Properties


SettingsSection::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsNameFormat Class > SettingsSection::SettingsNameFormat Properties
SettingsSection::SettingsNameFormat Properties
Collapse All

The properties of SettingsSection::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
Section | Settings Section default name format.
Links
Public Properties


SettingsSection::SettingsNameFormat::Section Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsNameFormat Class > SettingsSection::SettingsNameFormat Properties > SettingsSection::SettingsNameFormat::Section Property
SettingsSection::SettingsNameFormat::Section Property
Collapse All

Settings Section default name format.

C#
public PropertyString Section;
Visual Basic
Public Property Section() As PropertyString
Links
SettingsSection::SettingsNameFormat Class, SettingsSection::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsSection::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsStyles Class
SettingsSection::SettingsStyles Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSection::SettingsStyles
C#
public class SettingsSection::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsSection::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsSection::SettingsStyles Properties, SettingsSection::SettingsStyles Members, Class Hierarchy


SettingsSection::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsStyles Class > SettingsSection::SettingsStyles Members
SettingsSection::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsSection::SettingsStyles.

Public Properties
Public Property | Description
Section | Settings of Section style.
Links
Public Properties


SettingsSection::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsStyles Class > SettingsSection::SettingsStyles Properties
SettingsSection::SettingsStyles Properties
Collapse All

The properties of SettingsSection::SettingsStyles are listed here.

Public Properties
Public Property | Description
Section | Settings of Section style.
Links
Public Properties


SettingsSection::SettingsStyles::Section Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsStyles Class > SettingsSection::SettingsStyles Properties > SettingsSection::SettingsStyles::Section Property
SettingsSection::SettingsStyles::Section Property
Collapse All

Settings of Section style.

C#
public PropertyString Section;
Visual Basic
Public Property Section() As PropertyString
Links
SettingsSection::SettingsStyles Class, SettingsSection::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class
SettingsSectionView Class
Collapse All

Settings to specify the default styles assigned to section view components

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdAddSectionViewGradeLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddSectionViewOffElevLbl
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdEditSVGroupStyle
        Autodesk::Civil::Land::Settings::SettingsCmdLayoutSectionViewGroup
        Autodesk::Civil::Land::Settings::SettingsCmdProjectObjectsToSect
C#
public class SettingsSectionView : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsSectionView
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsSectionView Properties, SettingsSectionView Members, Class Hierarchy


SettingsSectionView Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Members
SettingsSectionView Members
Collapse All

The following tables list the members exposed by SettingsSectionView.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the template for naming the section view.
ProjectionLabelPlacement | settings to specify the default name formats for sample line.
SectionViewCreation | Gets the settings to establish the defaults assigned for section view creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to section view components
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsSectionView Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Properties
SettingsSectionView Properties
Collapse All

The properties of SettingsSectionView are listed here.

Public Properties
Public Property | Description
NameFormat | Gets the template for naming the section view.
ProjectionLabelPlacement | settings to specify the default name formats for sample line.
SectionViewCreation | Gets the settings to establish the defaults assigned for section view creation.
Styles | Gets the default styles assigned to section view components
Links
Public Properties


SettingsSectionView::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Properties > SettingsSectionView::NameFormat Property
SettingsSectionView::NameFormat Property
Collapse All

Gets the template for naming the section view.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsSectionView Class, SettingsSectionView Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::ProjectionLabelPlacement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Properties > SettingsSectionView::ProjectionLabelPlacement Property
SettingsSectionView::ProjectionLabelPlacement Property
Collapse All

settings to specify the default name formats for sample line.

C#
public SettingsProjectionLabelPlacement ProjectionLabelPlacement;
Visual Basic
Public Property ProjectionLabelPlacement() As SettingsProjectionLabelPlacement
Links
SettingsSectionView Class, SettingsSectionView Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SectionViewCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Properties > SettingsSectionView::SectionViewCreation Property
SettingsSectionView::SectionViewCreation Property
Collapse All

Gets the settings to establish the defaults assigned for section view creation.

C#
public SettingsSectionViewCreation SectionViewCreation;
Visual Basic
Public Property SectionViewCreation() As SettingsSectionViewCreation
Links
SettingsSectionView Class, SettingsSectionView Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Properties > SettingsSectionView::Styles Property
SettingsSectionView::Styles Property
Collapse All

Gets the default styles assigned to section view components

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsSectionView Class, SettingsSectionView Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsNameFormat Class
SettingsSectionView::SettingsNameFormat Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSectionView::SettingsNameFormat
C#
public class SettingsSectionView::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsSectionView::SettingsNameFormat
Inherits TreeOidWrapper
Remarks

Section View Station Range property is followed by a number of parameters that define how the text is displayed. Using this property without using its parameters would make it using default values. U—Units: Select one of ft (foot), m (meter), mile (mile), km (kilometer), in (inch), or yd (yard). The default is Uft. F—Format: Select either S (station format) or D (DD.DDDDDD decimal). The default is FS. P—Precision: Select one of 0 (1), 1 (0.1), 2 (0.01), ... , or 8 (0.00000001). The default is P2. R—Rounding: Select one of N (round normal), U (round up), or T (truncate). The default is RN. S—Sign: Select one of n (sign negative ‘-’), Bn ((Bracket negative)), a (sign always (±)), D (drop sign), BL (‘(‘ left prentice), or BR (right prentice ‘(‘). The default is Sn. O—Output: Select one of F (full), LD (left of decimal), RD (right of decimal), DS (decimal character), LB (left of station character), RB (right of station character), BBD (between station character and decimal), or BC (station character). The default is OF. A—Decimal character: Select either P (‘.’ period) or C (‘,’ comma). The default is AP. B—Station character position: Select one of 1 (1+0), 2 (1+00), 3 (1+000), 4 (1+0000), or 5 (1+00000). The default is B2. T—Station character: Select one of P (plus sign ‘+’), M (minus sign ‘-’), A (automatic (±)), U (underscore ‘_’), or N (none). The default is TP. E—Drop decimal for whole number: Select either N (No) or Y (Yes). The default is EN. W—Minimum display width: Select one of 0 (none), 1, 2, ..., 32. The default is W0. DZ—Drop leading zeros: Select one of Y (yes) or N (no). The default is DZN. For example, a section view name, using the above defaults and following the “rules” of the parameters, could look like this: 2+50.00 (2)

Links
SettingsSectionView::SettingsNameFormat Properties, SettingsSectionView::SettingsNameFormat Members, Class Hierarchy


SettingsSectionView::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsNameFormat Class > SettingsSectionView::SettingsNameFormat Members
SettingsSectionView::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsSectionView::SettingsNameFormat.

Public Properties
Public Property | Description
SectionView | Settings SectionView default name format.
Links
Public Properties


SettingsSectionView::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsNameFormat Class > SettingsSectionView::SettingsNameFormat Properties
SettingsSectionView::SettingsNameFormat Properties
Collapse All

The properties of SettingsSectionView::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
SectionView | Settings SectionView default name format.
Links
Public Properties


SettingsSectionView::SettingsNameFormat::SectionView Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsNameFormat Class > SettingsSectionView::SettingsNameFormat Properties > SettingsSectionView::SettingsNameFormat::SectionView Property
SettingsSectionView::SettingsNameFormat::SectionView Property
Collapse All

Settings SectionView default name format.

C#
public PropertyString SectionView;
Visual Basic
Public Property SectionView() As PropertyString
Links
SettingsSectionView::SettingsNameFormat Class, SettingsSectionView::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsProjectionLabelPlacement Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class
SettingsSectionView::SettingsProjectionLabelPlacement Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSectionView::SettingsProjectionLabelPlacement
C#
public class SettingsSectionView::SettingsProjectionLabelPlacement : TreeOidWrapper;
Visual Basic
Public Class SettingsSectionView::SettingsProjectionLabelPlacement
Inherits TreeOidWrapper
Links
SettingsSectionView::SettingsProjectionLabelPlacement Properties, SettingsSectionView::SettingsProjectionLabelPlacement Members, Class Hierarchy


SettingsSectionView::SettingsProjectionLabelPlacement Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class > SettingsSectionView::SettingsProjectionLabelPlacement Members
SettingsSectionView::SettingsProjectionLabelPlacement Members
Collapse All

The following tables list the members exposed by SettingsSectionView::SettingsProjectionLabelPlacement.

Public Properties
Public Property | Description
DimensionAnchorElevationValueForProjections | Specifies the default value for anchor elevation. Enter a value or click and select an elevation in the drawing area.... more
DimensionAnchorOption | Specifies whether the default anchor option will be Fixed, Above, Below, Graph View Top, or Graph View Bottom.
DimensionAnchorPlotHeightValueForProjections | Specifies the default value for anchor plot height. Enter a value or retain the existing default value.
Links
Public Properties


SettingsSectionView::SettingsProjectionLabelPlacement Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class > SettingsSectionView::SettingsProjectionLabelPlacement Properties
SettingsSectionView::SettingsProjectionLabelPlacement Properties
Collapse All

The properties of SettingsSectionView::SettingsProjectionLabelPlacement are listed here.

Public Properties
Public Property | Description
DimensionAnchorElevationValueForProjections | Specifies the default value for anchor elevation. Enter a value or click and select an elevation in the drawing area.... more
DimensionAnchorOption | Specifies whether the default anchor option will be Fixed, Above, Below, Graph View Top, or Graph View Bottom.
DimensionAnchorPlotHeightValueForProjections | Specifies the default value for anchor plot height. Enter a value or retain the existing default value.
Links
Public Properties


SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorElevationValueForProjections Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class > SettingsSectionView::SettingsProjectionLabelPlacement Properties > SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorElevationValueForProjections Property
SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorElevationValueForProjections Property
Collapse All

Specifies the default value for anchor elevation. Enter a value or click and select an elevation in the drawing area.

C#
public PropertyDouble DimensionAnchorElevationValueForProjections;
Visual Basic
Public Property DimensionAnchorElevationValueForProjections() As PropertyDouble
Links
SettingsSectionView::SettingsProjectionLabelPlacement Class, SettingsSectionView::SettingsProjectionLabelPlacement Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class > SettingsSectionView::SettingsProjectionLabelPlacement Properties > SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorOption Property
SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorOption Property
Collapse All

Specifies whether the default anchor option will be Fixed, Above, Below, Graph View Top, or Graph View Bottom.

C#
public PropertyEnum<DimensionAnchorType> DimensionAnchorOption;
Visual Basic
Public Property DimensionAnchorOption() As PropertyEnum<DimensionAnchorType>
Links
SettingsSectionView::SettingsProjectionLabelPlacement Class, SettingsSectionView::SettingsProjectionLabelPlacement Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorPlotHeightValueForProjections Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class > SettingsSectionView::SettingsProjectionLabelPlacement Properties > SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorPlotHeightValueForProjections Property
SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorPlotHeightValueForProjections Property
Collapse All

Specifies the default value for anchor plot height. Enter a value or retain the existing default value.

C#
public PropertyDouble DimensionAnchorPlotHeightValueForProjections;
Visual Basic
Public Property DimensionAnchorPlotHeightValueForProjections() As PropertyDouble
Links
SettingsSectionView::SettingsProjectionLabelPlacement Class, SettingsSectionView::SettingsProjectionLabelPlacement Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsSectionViewCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class
SettingsSectionView::SettingsSectionViewCreation Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSectionView::SettingsSectionViewCreation
C#
public class SettingsSectionView::SettingsSectionViewCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsSectionView::SettingsSectionViewCreation
Inherits TreeOidWrapper
Links
SettingsSectionView::SettingsSectionViewCreation Properties, SettingsSectionView::SettingsSectionViewCreation Members, Class Hierarchy


SettingsSectionView::SettingsSectionViewCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class > SettingsSectionView::SettingsSectionViewCreation Members
SettingsSectionView::SettingsSectionViewCreation Members
Collapse All

The following tables list the members exposed by SettingsSectionView::SettingsSectionViewCreation.

Public Properties
Public Property | Description
SectionGroupElevationRange | Specifies how the elevation range of the section group is set.
SpecifySectionViewHeight | Specifies whether the default section view height is set for the creation of a section view.
SpecifySectionViewOffsetRange | Specifies whether an offset range is set for the creation of a section view.
Links
Public Properties


SettingsSectionView::SettingsSectionViewCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class > SettingsSectionView::SettingsSectionViewCreation Properties
SettingsSectionView::SettingsSectionViewCreation Properties
Collapse All

The properties of SettingsSectionView::SettingsSectionViewCreation are listed here.

Public Properties
Public Property | Description
SectionGroupElevationRange | Specifies how the elevation range of the section group is set.
SpecifySectionViewHeight | Specifies whether the default section view height is set for the creation of a section view.
SpecifySectionViewOffsetRange | Specifies whether an offset range is set for the creation of a section view.
Links
Public Properties


SettingsSectionView::SettingsSectionViewCreation::SectionGroupElevationRange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class > SettingsSectionView::SettingsSectionViewCreation Properties > SettingsSectionView::SettingsSectionViewCreation::SectionGroupElevationRange Property
SettingsSectionView::SettingsSectionViewCreation::SectionGroupElevationRange Property
Collapse All

Specifies how the elevation range of the section group is set.

C#
public PropertyEnum<Autodesk::Civil::Land::SectionViewElevationRangeType> SectionGroupElevationRange;
Visual Basic
Public Property SectionGroupElevationRange() As PropertyEnum<Autodesk::Civil::Land::SectionViewElevationRangeType>
Links
SettingsSectionView::SettingsSectionViewCreation Class, SettingsSectionView::SettingsSectionViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsSectionViewCreation::SpecifySectionViewHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class > SettingsSectionView::SettingsSectionViewCreation Properties > SettingsSectionView::SettingsSectionViewCreation::SpecifySectionViewHeight Property
SettingsSectionView::SettingsSectionViewCreation::SpecifySectionViewHeight Property
Collapse All

Specifies whether the default section view height is set for the creation of a section view.

C#
public PropertyBoolean SpecifySectionViewHeight;
Visual Basic
Public Property SpecifySectionViewHeight() As PropertyBoolean
Links
SettingsSectionView::SettingsSectionViewCreation Class, SettingsSectionView::SettingsSectionViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsSectionViewCreation::SpecifySectionViewOffsetRange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class > SettingsSectionView::SettingsSectionViewCreation Properties > SettingsSectionView::SettingsSectionViewCreation::SpecifySectionViewOffsetRange Property
SettingsSectionView::SettingsSectionViewCreation::SpecifySectionViewOffsetRange Property
Collapse All

Specifies whether an offset range is set for the creation of a section view.

C#
public PropertyBoolean SpecifySectionViewOffsetRange;
Visual Basic
Public Property SpecifySectionViewOffsetRange() As PropertyBoolean
Links
SettingsSectionView::SettingsSectionViewCreation Class, SettingsSectionView::SettingsSectionViewCreation Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class
SettingsSectionView::SettingsStyles Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSectionView::SettingsStyles
C#
public class SettingsSectionView::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsSectionView::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsSectionView::SettingsStyles Properties, SettingsSectionView::SettingsStyles Members, Class Hierarchy


SettingsSectionView::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Members
SettingsSectionView::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsSectionView::SettingsStyles.

Public Properties
Public Property | Description
GroupPlot | Settings of GroupPlot style.
Marker | Specifies the default marker style for section view points for offset elevation and depth grade labels.
Projection | Settings of Projection style.
SectionLabelSet | Settings of SectionLabelSet style.
SectionProjectionLabel | Settings of SectionProjectionLabel style.
SectionView | Settings of SectionView style.
SectionViewBandSet | Settings of SectionViewBandSet style.
SectionViewDepthGradeLabel | Specifies the default section view grade label style.
SectionViewOffsetElevationLabel | Specifies the default section view offset elevation label style.
Links
Public Properties


SettingsSectionView::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties
SettingsSectionView::SettingsStyles Properties
Collapse All

The properties of SettingsSectionView::SettingsStyles are listed here.

Public Properties
Public Property | Description
GroupPlot | Settings of GroupPlot style.
Marker | Specifies the default marker style for section view points for offset elevation and depth grade labels.
Projection | Settings of Projection style.
SectionLabelSet | Settings of SectionLabelSet style.
SectionProjectionLabel | Settings of SectionProjectionLabel style.
SectionView | Settings of SectionView style.
SectionViewBandSet | Settings of SectionViewBandSet style.
SectionViewDepthGradeLabel | Specifies the default section view grade label style.
SectionViewOffsetElevationLabel | Specifies the default section view offset elevation label style.
Links
Public Properties


SettingsSectionView::SettingsStyles::GroupPlot Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties > SettingsSectionView::SettingsStyles::GroupPlot Property
SettingsSectionView::SettingsStyles::GroupPlot Property
Collapse All

Settings of GroupPlot style.

C#
public PropertyString GroupPlot;
Visual Basic
Public Property GroupPlot() As PropertyString
Links
SettingsSectionView::SettingsStyles Class, SettingsSectionView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsStyles::Marker Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties > SettingsSectionView::SettingsStyles::Marker Property
SettingsSectionView::SettingsStyles::Marker Property
Collapse All

Specifies the default marker style for section view points for offset elevation and depth grade labels.

C#
public PropertyString Marker;
Visual Basic
Public Property Marker() As PropertyString
Remarks

We can set the style value to "<none>" as UI did with the value: "".

Links
SettingsSectionView::SettingsStyles Class, SettingsSectionView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsStyles::Projection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties > SettingsSectionView::SettingsStyles::Projection Property
SettingsSectionView::SettingsStyles::Projection Property
Collapse All

Settings of Projection style.

C#
public PropertyString Projection;
Visual Basic
Public Property Projection() As PropertyString
Links
SettingsSectionView::SettingsStyles Class, SettingsSectionView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsStyles::SectionLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties > SettingsSectionView::SettingsStyles::SectionLabelSet Property
SettingsSectionView::SettingsStyles::SectionLabelSet Property
Collapse All

Settings of SectionLabelSet style.

C#
public PropertyString SectionLabelSet;
Visual Basic
Public Property SectionLabelSet() As PropertyString
Links
SettingsSectionView::SettingsStyles Class, SettingsSectionView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsStyles::SectionProjectionLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties > SettingsSectionView::SettingsStyles::SectionProjectionLabel Property
SettingsSectionView::SettingsStyles::SectionProjectionLabel Property
Collapse All

Settings of SectionProjectionLabel style.

C#
public PropertyString SectionProjectionLabel;
Visual Basic
Public Property SectionProjectionLabel() As PropertyString
Remarks

We can set the style value to "<none>" as UI did with the value: "".

Links
SettingsSectionView::SettingsStyles Class, SettingsSectionView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsStyles::SectionView Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties > SettingsSectionView::SettingsStyles::SectionView Property
SettingsSectionView::SettingsStyles::SectionView Property
Collapse All

Settings of SectionView style.

C#
public PropertyString SectionView;
Visual Basic
Public Property SectionView() As PropertyString
Links
SettingsSectionView::SettingsStyles Class, SettingsSectionView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsStyles::SectionViewBandSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties > SettingsSectionView::SettingsStyles::SectionViewBandSet Property
SettingsSectionView::SettingsStyles::SectionViewBandSet Property
Collapse All

Settings of SectionViewBandSet style.

C#
public PropertyString SectionViewBandSet;
Visual Basic
Public Property SectionViewBandSet() As PropertyString
Links
SettingsSectionView::SettingsStyles Class, SettingsSectionView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsStyles::SectionViewDepthGradeLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties > SettingsSectionView::SettingsStyles::SectionViewDepthGradeLabel Property
SettingsSectionView::SettingsStyles::SectionViewDepthGradeLabel Property
Collapse All

Specifies the default section view grade label style.

C#
public PropertyString SectionViewDepthGradeLabel;
Visual Basic
Public Property SectionViewDepthGradeLabel() As PropertyString
Links
SettingsSectionView::SettingsStyles Class, SettingsSectionView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSectionView::SettingsStyles::SectionViewOffsetElevationLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties > SettingsSectionView::SettingsStyles::SectionViewOffsetElevationLabel Property
SettingsSectionView::SettingsStyles::SectionViewOffsetElevationLabel Property
Collapse All

Specifies the default section view offset elevation label style.

C#
public PropertyString SectionViewOffsetElevationLabel;
Visual Basic
Public Property SectionViewOffsetElevationLabel() As PropertyString
Links
SettingsSectionView::SettingsStyles Class, SettingsSectionView::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class
SettingsSurface Class
Collapse All

Settings for Surface.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabeling
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingGroup
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingSingle
        Autodesk::Civil::Land::Settings::SettingsCmdAddSpotElevLabelsOnGrid
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBoundaries
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBreaklines
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceContours
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDemFile
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDrawingObjects
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceSlopeLabel
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceSpotElevLabel
        Autodesk::Civil::Land::Settings::SettingsCmdCatchmentArea
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceFromTIN
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceGridFromDEM
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceReference
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceWaterdrop
        Autodesk::Civil::Land::Settings::SettingsCmdImportGEData
        Autodesk::Civil::Land::Settings::SettingsCmdImportGESurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveBlockstoAttribElev
        Autodesk::Civil::Land::Settings::SettingsCmdMoveBlocksToSurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveTextToElevation
        Autodesk::Civil::Land::Settings::SettingsCmdSimplifySurface
        Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExportToDem
        Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExtractObjects
C#
public class SettingsSurface : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsSurface
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsSurface Properties, SettingsSurface Members, Class Hierarchy


SettingsSurface Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Members
SettingsSurface Members
Collapse All

The following tables list the members exposed by SettingsSurface.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsSurface Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Properties
SettingsSurface Properties
Collapse All

The properties of SettingsSurface are listed here.

Public Properties
Public Property | Description
ContourLabeling | Gets the defaults assigned to surface labels.
Defaults | Gets the surface defaults setting.
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
Links
Public Properties


SettingsSurface::ContourLabeling Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Properties > SettingsSurface::ContourLabeling Property
SettingsSurface::ContourLabeling Property
Collapse All

Gets the defaults assigned to surface labels.

C#
public SettingsContourLabeling ContourLabeling;
Visual Basic
Public Property ContourLabeling() As SettingsContourLabeling
Links
SettingsSurface Class, SettingsSurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::Defaults Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Properties > SettingsSurface::Defaults Property
SettingsSurface::Defaults Property
Collapse All

Gets the surface defaults setting.

C#
public SettingsDefaults Defaults;
Visual Basic
Public Property Defaults() As SettingsDefaults
Links
SettingsSurface Class, SettingsSurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Properties > SettingsSurface::Styles Property
SettingsSurface::Styles Property
Collapse All

Gets the default styles.assigned to surfaces and surface-related labels.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsSurface Class, SettingsSurface Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsContourLabeling Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class
SettingsSurface::SettingsContourLabeling Class
Collapse All

Defaults assigned to surface labels.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSurface::SettingsContourLabeling
C#
public class SettingsSurface::SettingsContourLabeling : TreeOidWrapper;
Visual Basic
Public Class SettingsSurface::SettingsContourLabeling
Inherits TreeOidWrapper
Links
SettingsSurface::SettingsContourLabeling Properties, SettingsSurface::SettingsContourLabeling Members, Class Hierarchy


SettingsSurface::SettingsContourLabeling Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Members
SettingsSurface::SettingsContourLabeling Members
Collapse All

The following tables list the members exposed by SettingsSurface::SettingsContourLabeling.

Public Properties
Public Property | Description
DisplayContourLabelLine | Gets whether or not the contour label lines are displayed.
LabelMask | Gets the label mask type.
SurfaceContourLabelStyleMajor | Gets the default major contour label style.
SurfaceContourLabelStyleMinor | Gets the default minor contour label style.
SurfaceContourLabelStyleUserDefined | Gets the user-defined major contour label style.
Links
Public Properties


SettingsSurface::SettingsContourLabeling Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Properties
SettingsSurface::SettingsContourLabeling Properties
Collapse All

The properties of SettingsSurface::SettingsContourLabeling are listed here.

Public Properties
Public Property | Description
DisplayContourLabelLine | Gets whether or not the contour label lines are displayed.
LabelMask | Gets the label mask type.
SurfaceContourLabelStyleMajor | Gets the default major contour label style.
SurfaceContourLabelStyleMinor | Gets the default minor contour label style.
SurfaceContourLabelStyleUserDefined | Gets the user-defined major contour label style.
Links
Public Properties


SettingsSurface::SettingsContourLabeling::DisplayContourLabelLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Properties > SettingsSurface::SettingsContourLabeling::DisplayContourLabelLine Property
SettingsSurface::SettingsContourLabeling::DisplayContourLabelLine Property
Collapse All

Gets whether or not the contour label lines are displayed.

C#
public PropertyBoolean DisplayContourLabelLine;
Visual Basic
Public Property DisplayContourLabelLine() As PropertyBoolean
Links
SettingsSurface::SettingsContourLabeling Class, SettingsSurface::SettingsContourLabeling Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsContourLabeling::LabelMask Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Properties > SettingsSurface::SettingsContourLabeling::LabelMask Property
SettingsSurface::SettingsContourLabeling::LabelMask Property
Collapse All

Gets the label mask type.

C#
public PropertyEnum<LabelMaskType> LabelMask;
Visual Basic
Public Property LabelMask() As PropertyEnum<LabelMaskType>
Links
SettingsSurface::SettingsContourLabeling Class, SettingsSurface::SettingsContourLabeling Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleMajor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Properties > SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleMajor Property
SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleMajor Property
Collapse All

Gets the default major contour label style.

C#
public PropertyString SurfaceContourLabelStyleMajor;
Visual Basic
Public Property SurfaceContourLabelStyleMajor() As PropertyString
Links
SettingsSurface::SettingsContourLabeling Class, SettingsSurface::SettingsContourLabeling Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleMinor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Properties > SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleMinor Property
SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleMinor Property
Collapse All

Gets the default minor contour label style.

C#
public PropertyString SurfaceContourLabelStyleMinor;
Visual Basic
Public Property SurfaceContourLabelStyleMinor() As PropertyString
Links
SettingsSurface::SettingsContourLabeling Class, SettingsSurface::SettingsContourLabeling Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleUserDefined Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Properties > SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleUserDefined Property
SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleUserDefined Property
Collapse All

Gets the user-defined major contour label style.

C#
public PropertyString SurfaceContourLabelStyleUserDefined;
Visual Basic
Public Property SurfaceContourLabelStyleUserDefined() As PropertyString
Links
SettingsSurface::SettingsContourLabeling Class, SettingsSurface::SettingsContourLabeling Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsDefaults Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsDefaults Class
SettingsSurface::SettingsDefaults Class
Collapse All

Default name format for new surfaces.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSurface::SettingsDefaults
C#
public class SettingsSurface::SettingsDefaults : TreeOidWrapper;
Visual Basic
Public Class SettingsSurface::SettingsDefaults
Inherits TreeOidWrapper
Links
SettingsSurface::SettingsDefaults Properties, SettingsSurface::SettingsDefaults Members, Class Hierarchy


SettingsSurface::SettingsDefaults Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsDefaults Class > SettingsSurface::SettingsDefaults Members
SettingsSurface::SettingsDefaults Members
Collapse All

The following tables list the members exposed by SettingsSurface::SettingsDefaults.

Public Properties
Public Property | Description
AutoRebuild | Gets the PropertyBoolean value that specifies Automatic as the default setting for the Rebuild Surface command.
Links
Public Properties


SettingsSurface::SettingsDefaults Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsDefaults Class > SettingsSurface::SettingsDefaults Properties
SettingsSurface::SettingsDefaults Properties
Collapse All

The properties of SettingsSurface::SettingsDefaults are listed here.

Public Properties
Public Property | Description
AutoRebuild | Gets the PropertyBoolean value that specifies Automatic as the default setting for the Rebuild Surface command.
Links
Public Properties


SettingsSurface::SettingsDefaults::AutoRebuild Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsDefaults Class > SettingsSurface::SettingsDefaults Properties > SettingsSurface::SettingsDefaults::AutoRebuild Property
SettingsSurface::SettingsDefaults::AutoRebuild Property
Collapse All

Gets the PropertyBoolean value that specifies Automatic as the default setting for the Rebuild Surface command.

C#
public PropertyBoolean AutoRebuild;
Visual Basic
Public Property AutoRebuild() As PropertyBoolean
Links
SettingsSurface::SettingsDefaults Class, SettingsSurface::SettingsDefaults Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class
SettingsSurface::SettingsStyles Class
Collapse All

Default styles.assigned to surfaces and surface-related labels.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSurface::SettingsStyles
C#
public class SettingsSurface::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsSurface::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsSurface::SettingsStyles Properties, SettingsSurface::SettingsStyles Members, Class Hierarchy


SettingsSurface::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Members
SettingsSurface::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsSurface::SettingsStyles.

Public Properties
Public Property | Description
Marker | Gets the default style for marker.
RenderMaterial | Gets the default render material.
Surface | Gets the default style for surface.
SurfaceSlopeLabel | Gets the default style for slope label.
SurfaceSpotElevationLabel | Gets the default style for spot elevation label .
Links
Public Properties


SettingsSurface::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Properties
SettingsSurface::SettingsStyles Properties
Collapse All

The properties of SettingsSurface::SettingsStyles are listed here.

Public Properties
Public Property | Description
Marker | Gets the default style for marker.
RenderMaterial | Gets the default render material.
Surface | Gets the default style for surface.
SurfaceSlopeLabel | Gets the default style for slope label.
SurfaceSpotElevationLabel | Gets the default style for spot elevation label .
Links
Public Properties


SettingsSurface::SettingsStyles::Marker Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Properties > SettingsSurface::SettingsStyles::Marker Property
SettingsSurface::SettingsStyles::Marker Property
Collapse All

Gets the default style for marker.

C#
public PropertyString Marker;
Visual Basic
Public Property Marker() As PropertyString
Links
SettingsSurface::SettingsStyles Class, SettingsSurface::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsStyles::RenderMaterial Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Properties > SettingsSurface::SettingsStyles::RenderMaterial Property
SettingsSurface::SettingsStyles::RenderMaterial Property
Collapse All

Gets the default render material.

C#
public PropertyString RenderMaterial;
Visual Basic
Public Property RenderMaterial() As PropertyString
Links
SettingsSurface::SettingsStyles Class, SettingsSurface::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsStyles::Surface Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Properties > SettingsSurface::SettingsStyles::Surface Property
SettingsSurface::SettingsStyles::Surface Property
Collapse All

Gets the default style for surface.

C#
public PropertyString Surface;
Visual Basic
Public Property Surface() As PropertyString
Links
SettingsSurface::SettingsStyles Class, SettingsSurface::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsStyles::SurfaceSlopeLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Properties > SettingsSurface::SettingsStyles::SurfaceSlopeLabel Property
SettingsSurface::SettingsStyles::SurfaceSlopeLabel Property
Collapse All

Gets the default style for slope label.

C#
public PropertyString SurfaceSlopeLabel;
Visual Basic
Public Property SurfaceSlopeLabel() As PropertyString
Links
SettingsSurface::SettingsStyles Class, SettingsSurface::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsSurface::SettingsStyles::SurfaceSpotElevationLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Properties > SettingsSurface::SettingsStyles::SurfaceSpotElevationLabel Property
SettingsSurface::SettingsStyles::SurfaceSpotElevationLabel Property
Collapse All

Gets the default style for spot elevation label .

C#
public PropertyString SurfaceSpotElevationLabel;
Visual Basic
Public Property SurfaceSpotElevationLabel() As PropertyString
Links
SettingsSurface::SettingsStyles Class, SettingsSurface::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrame Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrame Class
SettingsViewFrame Class
Collapse All

Settings for ViewFrame.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsViewFrame
C#
public class SettingsViewFrame : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsViewFrame
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
Class Hierarchy


SettingsViewFrameGroup Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class
SettingsViewFrameGroup Class
Collapse All

Settings for ViewFrameGroup.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsViewFrameGroup
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSheets
        Autodesk::Civil::Land::Settings::SettingsCmdCreateViewFrames
C#
public class SettingsViewFrameGroup : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsViewFrameGroup
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsViewFrameGroup Properties, SettingsViewFrameGroup Members, Class Hierarchy


SettingsViewFrameGroup Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Members
SettingsViewFrameGroup Members
Collapse All

The following tables list the members exposed by SettingsViewFrameGroup.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Information | Gets the default match line label location.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name formats for view frame group components.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to view frame group components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsViewFrameGroup Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Properties
SettingsViewFrameGroup Properties
Collapse All

The properties of SettingsViewFrameGroup are listed here.

Public Properties
Public Property | Description
Information | Gets the default match line label location.
NameFormat | Gets the default name formats for view frame group components.
Styles | Gets the default styles assigned to view frame group components.
Links
Public Properties


SettingsViewFrameGroup::Information Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Properties > SettingsViewFrameGroup::Information Property
SettingsViewFrameGroup::Information Property deprecated
Collapse All

Gets the default match line label location.

C#
public SettingsInformation Information;
Visual Basic
Public Property Information() As SettingsInformation
Notes

Deprecated: Property has been removed.

Links
SettingsViewFrameGroup Class, SettingsViewFrameGroup Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Properties > SettingsViewFrameGroup::NameFormat Property
SettingsViewFrameGroup::NameFormat Property
Collapse All

Gets the default name formats for view frame group components.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsViewFrameGroup Class, SettingsViewFrameGroup Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Properties > SettingsViewFrameGroup::Styles Property
SettingsViewFrameGroup::Styles Property
Collapse All

Gets the default styles assigned to view frame group components.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsViewFrameGroup Class, SettingsViewFrameGroup Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsInformation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsInformation Class
SettingsViewFrameGroup::SettingsInformation Class
Collapse All

Default match line label location.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsViewFrameGroup::SettingsInformation
C#
public class SettingsViewFrameGroup::SettingsInformation : TreeOidWrapper;
Visual Basic
Public Class SettingsViewFrameGroup::SettingsInformation
Inherits TreeOidWrapper
Links
Class Hierarchy


SettingsViewFrameGroup::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class
SettingsViewFrameGroup::SettingsNameFormat Class
Collapse All

Default name format for view frame group components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsViewFrameGroup::SettingsNameFormat
C#
public class SettingsViewFrameGroup::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsViewFrameGroup::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsViewFrameGroup::SettingsNameFormat Properties, SettingsViewFrameGroup::SettingsNameFormat Members, Class Hierarchy


SettingsViewFrameGroup::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Members
SettingsViewFrameGroup::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsViewFrameGroup::SettingsNameFormat.

Public Properties
Public Property | Description
Layout | Gets the default name formats for layouts.
MatchLine | Gets the default name formats for match lines.
SheetFile | Gets the default name formats for sheet files.
ViewFrame | Gets the default name formats for view frames.
ViewFrameGroup | Gets the default name formats for view frame groups.
Links
Public Properties


SettingsViewFrameGroup::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Properties
SettingsViewFrameGroup::SettingsNameFormat Properties
Collapse All

The properties of SettingsViewFrameGroup::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
Layout | Gets the default name formats for layouts.
MatchLine | Gets the default name formats for match lines.
SheetFile | Gets the default name formats for sheet files.
ViewFrame | Gets the default name formats for view frames.
ViewFrameGroup | Gets the default name formats for view frame groups.
Links
Public Properties


SettingsViewFrameGroup::SettingsNameFormat::Layout Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Properties > SettingsViewFrameGroup::SettingsNameFormat::Layout Property
SettingsViewFrameGroup::SettingsNameFormat::Layout Property
Collapse All

Gets the default name formats for layouts.

C#
public PropertyString Layout;
Visual Basic
Public Property Layout() As PropertyString
Links
SettingsViewFrameGroup::SettingsNameFormat Class, SettingsViewFrameGroup::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsNameFormat::MatchLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Properties > SettingsViewFrameGroup::SettingsNameFormat::MatchLine Property
SettingsViewFrameGroup::SettingsNameFormat::MatchLine Property
Collapse All

Gets the default name formats for match lines.

C#
public PropertyString MatchLine;
Visual Basic
Public Property MatchLine() As PropertyString
Links
SettingsViewFrameGroup::SettingsNameFormat Class, SettingsViewFrameGroup::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsNameFormat::SheetFile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Properties > SettingsViewFrameGroup::SettingsNameFormat::SheetFile Property
SettingsViewFrameGroup::SettingsNameFormat::SheetFile Property
Collapse All

Gets the default name formats for sheet files.

C#
public PropertyString SheetFile;
Visual Basic
Public Property SheetFile() As PropertyString
Links
SettingsViewFrameGroup::SettingsNameFormat Class, SettingsViewFrameGroup::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsNameFormat::ViewFrame Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Properties > SettingsViewFrameGroup::SettingsNameFormat::ViewFrame Property
SettingsViewFrameGroup::SettingsNameFormat::ViewFrame Property
Collapse All

Gets the default name formats for view frames.

C#
public PropertyString ViewFrame;
Visual Basic
Public Property ViewFrame() As PropertyString
Links
SettingsViewFrameGroup::SettingsNameFormat Class, SettingsViewFrameGroup::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsNameFormat::ViewFrameGroup Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Properties > SettingsViewFrameGroup::SettingsNameFormat::ViewFrameGroup Property
SettingsViewFrameGroup::SettingsNameFormat::ViewFrameGroup Property
Collapse All

Gets the default name formats for view frame groups.

C#
public PropertyString ViewFrameGroup;
Visual Basic
Public Property ViewFrameGroup() As PropertyString
Links
SettingsViewFrameGroup::SettingsNameFormat Class, SettingsViewFrameGroup::SettingsNameFormat Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class
SettingsViewFrameGroup::SettingsStyles Class
Collapse All

Default styles assigned to view frame group components.

Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsViewFrameGroup::SettingsStyles
C#
public class SettingsViewFrameGroup::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsViewFrameGroup::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsViewFrameGroup::SettingsStyles Properties, SettingsViewFrameGroup::SettingsStyles Members, Class Hierarchy


SettingsViewFrameGroup::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Members
SettingsViewFrameGroup::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsViewFrameGroup::SettingsStyles.

Public Properties
Public Property | Description
MatchLine | Gets the default style for match lines.
MatchLineLabelLeft | Gets the default style for labels that are displayed on the left side of a match line.
MatchLineLabelRight | Gets the default style for labels that are displayed on the right side of a match line.
MatchLineLeftLabelLocation | Gets the default location for labels that are displayed on the left side of a match line.
MatchLineRightLabelLocation | Gets the default location for labels that are displayed on the right side of a match line.
ProfileView | Gets the default profile view style.
ProfileViewBandSet | Gets the default style for profile view band sets.
ViewFrame | Gets the default style for view frames.
ViewFrameLabel | Gets the default style for view frame labels.
ViewFrameLabelLocation | Gets the default location on the view frame for view frame labels.
Links
Public Properties


SettingsViewFrameGroup::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties
SettingsViewFrameGroup::SettingsStyles Properties
Collapse All

The properties of SettingsViewFrameGroup::SettingsStyles are listed here.

Public Properties
Public Property | Description
MatchLine | Gets the default style for match lines.
MatchLineLabelLeft | Gets the default style for labels that are displayed on the left side of a match line.
MatchLineLabelRight | Gets the default style for labels that are displayed on the right side of a match line.
MatchLineLeftLabelLocation | Gets the default location for labels that are displayed on the left side of a match line.
MatchLineRightLabelLocation | Gets the default location for labels that are displayed on the right side of a match line.
ProfileView | Gets the default profile view style.
ProfileViewBandSet | Gets the default style for profile view band sets.
ViewFrame | Gets the default style for view frames.
ViewFrameLabel | Gets the default style for view frame labels.
ViewFrameLabelLocation | Gets the default location on the view frame for view frame labels.
Links
Public Properties


SettingsViewFrameGroup::SettingsStyles::MatchLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::MatchLine Property
SettingsViewFrameGroup::SettingsStyles::MatchLine Property
Collapse All

Gets the default style for match lines.

C#
public PropertyString MatchLine;
Visual Basic
Public Property MatchLine() As PropertyString
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles::MatchLineLabelLeft Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::MatchLineLabelLeft Property
SettingsViewFrameGroup::SettingsStyles::MatchLineLabelLeft Property
Collapse All

Gets the default style for labels that are displayed on the left side of a match line.

C#
public PropertyString MatchLineLabelLeft;
Visual Basic
Public Property MatchLineLabelLeft() As PropertyString
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles::MatchLineLabelRight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::MatchLineLabelRight Property
SettingsViewFrameGroup::SettingsStyles::MatchLineLabelRight Property
Collapse All

Gets the default style for labels that are displayed on the right side of a match line.

C#
public PropertyString MatchLineLabelRight;
Visual Basic
Public Property MatchLineLabelRight() As PropertyString
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles::MatchLineLeftLabelLocation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::MatchLineLeftLabelLocation Property
SettingsViewFrameGroup::SettingsStyles::MatchLineLeftLabelLocation Property
Collapse All

Gets the default location for labels that are displayed on the left side of a match line.

C#
public PropertyEnum<MatchLineLabelLocationType> MatchLineLeftLabelLocation;
Visual Basic
Public Property MatchLineLeftLabelLocation() As PropertyEnum<MatchLineLabelLocationType>
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles::MatchLineRightLabelLocation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::MatchLineRightLabelLocation Property
SettingsViewFrameGroup::SettingsStyles::MatchLineRightLabelLocation Property
Collapse All

Gets the default location for labels that are displayed on the right side of a match line.

C#
public PropertyEnum<MatchLineLabelLocationType> MatchLineRightLabelLocation;
Visual Basic
Public Property MatchLineRightLabelLocation() As PropertyEnum<MatchLineLabelLocationType>
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles::ProfileView Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::ProfileView Property
SettingsViewFrameGroup::SettingsStyles::ProfileView Property
Collapse All

Gets the default profile view style.

C#
public PropertyString ProfileView;
Visual Basic
Public Property ProfileView() As PropertyString
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles::ProfileViewBandSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::ProfileViewBandSet Property
SettingsViewFrameGroup::SettingsStyles::ProfileViewBandSet Property
Collapse All

Gets the default style for profile view band sets.

C#
public PropertyString ProfileViewBandSet;
Visual Basic
Public Property ProfileViewBandSet() As PropertyString
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles::ViewFrame Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::ViewFrame Property
SettingsViewFrameGroup::SettingsStyles::ViewFrame Property
Collapse All

Gets the default style for view frames.

C#
public PropertyString ViewFrame;
Visual Basic
Public Property ViewFrame() As PropertyString
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles::ViewFrameLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::ViewFrameLabel Property
SettingsViewFrameGroup::SettingsStyles::ViewFrameLabel Property
Collapse All

Gets the default style for view frame labels.

C#
public PropertyString ViewFrameLabel;
Visual Basic
Public Property ViewFrameLabel() As PropertyString
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


SettingsViewFrameGroup::SettingsStyles::ViewFrameLabelLocation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties > SettingsViewFrameGroup::SettingsStyles::ViewFrameLabelLocation Property
SettingsViewFrameGroup::SettingsStyles::ViewFrameLabelLocation Property
Collapse All

Gets the default location on the view frame for view frame labels.

C#
public PropertyEnum<ViewFrameLabelLocationType> ViewFrameLabelLocation;
Visual Basic
Public Property ViewFrameLabelLocation() As PropertyEnum<ViewFrameLabelLocationType>
Links
SettingsViewFrameGroup::SettingsStyles Class, SettingsViewFrameGroup::SettingsStyles Members, Autodesk::Civil::Land::Settings Namespace


Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
AbbreviationAlignmentEnhancedType | Defines Abbreviation Alignment Enhanced type.
AbbreviationAlignmentType | Defines Abbreviation Alignment type.
AbbreviationProfileType | Defines Abbreviation Profile type.
AbbreviationSuperelevationType | Defines Abbreviation Superelevation type.
AutomaticManual | Specifies how some properties are assigned point creation.
GeographicCoordinateType | Specifies the order in which geographic coordinates are displayed on the command line during point creation.
GridCoordinateType | Specifies the order in which grid coordinates are displayed on the command line during point creation.
LocalCoordinateType | Specifies the order and format used to display local coordinates on the command line during point creation.
SectionViewAnchorType | Defines types of section view anchors.
TableAnchorType | Defines types of table anchors.
TableLayoutType | Defines table layout directions.
TileDirectionType | Defines tile directions.
Links
Enumerations


Autodesk::Civil::Land::Settings::AbbreviationAlignmentEnhancedType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::AbbreviationAlignmentEnhancedType Enumeration
Autodesk::Civil::Land::Settings::AbbreviationAlignmentEnhancedType Enumeration
Collapse All

Defines Abbreviation Alignment Enhanced type.

C#
public enum AbbreviationAlignmentEnhancedType {
  AlignmentBeginningPoint = AeccAttributeId::kAttrIdAlignmentGeometryPointAlignmentBeginning1,
  AlignmentEndPoint = AeccAttributeId::kAttrIdAlignmentGeometryPointAlignmentEnd1,
  LineBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointLineBeginning1,
  LineEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointLineEnd1,
  CurveBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveBeginning1,
  CurveEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveEnd1,
  SimpleSpiralLargeRadiusAtBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointSimpleSpiralLgRadBeg1,
  SimpleSpiralLargeRadiusAtEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointSimpleSpiralLgRadEnd1,
  SimpleSpiralSmallRadiusAtBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointSimpleSpiralSmRadBeg1,
  SimpleSpiralSmallRadiusAtEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointSimpleSpiralSmRadEnd1,
  CompoundSpiralLargeRadiusAtBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointCompoundSpiralLgRadBeg1,
  CompoundSpiralLargeRadiusAtEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointCompoundSpiralLgRadEnd1,
  CompoundSpiralSmallRadiusAtBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointCompoundSpiralSmRadBeg1,
  CompoundSpiralSmallRadiusAtEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointCompoundSpiralSmRadEnd1
}
Visual Basic
Public Enum AbbreviationAlignmentEnhancedType
  AlignmentBeginningPoint = AeccAttributeId::kAttrIdAlignmentGeometryPointAlignmentBeginning1
  AlignmentEndPoint = AeccAttributeId::kAttrIdAlignmentGeometryPointAlignmentEnd1
  LineBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointLineBeginning1
  LineEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointLineEnd1
  CurveBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveBeginning1
  CurveEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveEnd1
  SimpleSpiralLargeRadiusAtBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointSimpleSpiralLgRadBeg1
  SimpleSpiralLargeRadiusAtEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointSimpleSpiralLgRadEnd1
  SimpleSpiralSmallRadiusAtBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointSimpleSpiralSmRadBeg1
  SimpleSpiralSmallRadiusAtEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointSimpleSpiralSmRadEnd1
  CompoundSpiralLargeRadiusAtBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointCompoundSpiralLgRadBeg1
  CompoundSpiralLargeRadiusAtEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointCompoundSpiralLgRadEnd1
  CompoundSpiralSmallRadiusAtBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointCompoundSpiralSmRadBeg1
  CompoundSpiralSmallRadiusAtEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointCompoundSpiralSmRadEnd1
End Enum


Autodesk::Civil::Land::Settings::AbbreviationAlignmentType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::AbbreviationAlignmentType Enumeration
Autodesk::Civil::Land::Settings::AbbreviationAlignmentType Enumeration
Collapse All

Defines Abbreviation Alignment type.

C#
public enum AbbreviationAlignmentType {
  SpiralCurveIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointSpiralCurveText,
  CurveSpiralIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveSpiralText,
  SpiralTangentIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointSpiralTangentText,
  TangentSpiralIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointTangentSpiralText,
  ReverseCurveCurveIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveReverseCurveText,
  CompoundCurveCurveIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveCompoundCurveText,
  CurveTangentIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveTangentText,
  TangentCurveIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointTangentCurveText,
  TangentTangentIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointTangentTangentText,
  ReverseSpiralIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointSpiralReverseSpiralText,
  SpiralSpiralIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointSpiralCompoundSpiralText,
  StationEquationIncreasing = AeccAttributeId::kAttrIdAlignmentGeometryPointIncreasingText,
  StationEquationDecreasing = AeccAttributeId::kAttrIdAlignmentGeometryPointDecreasingText,
  AlignmentBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointAlignmentBeginningText,
  AlignmentEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointAlignmentEndText
}
Visual Basic
Public Enum AbbreviationAlignmentType
  SpiralCurveIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointSpiralCurveText
  CurveSpiralIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveSpiralText
  SpiralTangentIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointSpiralTangentText
  TangentSpiralIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointTangentSpiralText
  ReverseCurveCurveIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveReverseCurveText
  CompoundCurveCurveIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveCompoundCurveText
  CurveTangentIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointCurveTangentText
  TangentCurveIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointTangentCurveText
  TangentTangentIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointTangentTangentText
  ReverseSpiralIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointSpiralReverseSpiralText
  SpiralSpiralIntersect = AeccAttributeId::kAttrIdAlignmentGeometryPointSpiralCompoundSpiralText
  StationEquationIncreasing = AeccAttributeId::kAttrIdAlignmentGeometryPointIncreasingText
  StationEquationDecreasing = AeccAttributeId::kAttrIdAlignmentGeometryPointDecreasingText
  AlignmentBeginning = AeccAttributeId::kAttrIdAlignmentGeometryPointAlignmentBeginningText
  AlignmentEnd = AeccAttributeId::kAttrIdAlignmentGeometryPointAlignmentEndText
End Enum


Autodesk::Civil::Land::Settings::AbbreviationProfileType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::AbbreviationProfileType Enumeration
Autodesk::Civil::Land::Settings::AbbreviationProfileType Enumeration
Collapse All

Defines Abbreviation Profile type.

C#
public enum AbbreviationProfileType {
  ProfileStart = AeccAttributeId::kAttrIdVAlignmentStartText,
  ProfileEnd = AeccAttributeId::kAttrIdVAlignmentEndText,
  PointOfVerticalIntersection = AeccAttributeId::kAttrIdVAlignmentPVIText,
  GradeBreak = AeccAttributeId::kAttrIdVAlignmentGradeBreakText,
  BeginVerticalCurve = AeccAttributeId::kAttrIdVAlignmentBeginVCurveText,
  BeginVerticalCurveStation = AeccAttributeId::kAttrIdVAlignmentBeginVCurveStationText,
  BeginVerticalCurveElevation = AeccAttributeId::kAttrIdVAlignmentBeginVCurveElevText,
  EndVerticalCurve = AeccAttributeId::kAttrIdVAlignmentEndVCurveText,
  EndVerticalCurveStation = AeccAttributeId::kAttrIdVAlignmentEndVCurveStationText,
  EndVerticalCurveElevation = AeccAttributeId::kAttrIdVAlignmentEndVCurveElevText,
  VerticalCompoundCurveIntersect = AeccAttributeId::kAttrIdVAlignmentPointOfCompoundCurvatureText,
  VerticalCompoundCurveIntersectStation = AeccAttributeId::kAttrIdVAlignmentPointOfCompoundCurvatureStationText,
  VerticalCompoundCurveIntersectElevation = AeccAttributeId::kAttrIdVAlignmentPointOfCompoundCurvatureElevText,
  VerticalReverseCurveIntersect = AeccAttributeId::kAttrIdVAlignmentPointOfReverseCurvatureText,
  VerticalReverseCurveIntersectStation = AeccAttributeId::kAttrIdVAlignmentPointOfReverseCurvatureStationText,
  VerticalReverseCurveIntersectElevation = AeccAttributeId::kAttrIdVAlignmentPointOfReverseCurvatureElevText,
  HighPoint = AeccAttributeId::kAttrIdVAlignmentHighPointText,
  LowPoint = AeccAttributeId::kAttrIdVAlignmentLowPointText,
  CurveCoefficient = AeccAttributeId::kAttrIdVAlignmentKValueText,
  GradeChange = AeccAttributeId::kAttrIdVAlignmentGradeChangeText,
  OverallHighPoint = AeccAttributeId::kAttrIdVAlignmentOverallHighPointText,
  OverallLowPoint = AeccAttributeId::kAttrIdVAlignmentOverallLowPointText
}
Visual Basic
Public Enum AbbreviationProfileType
  ProfileStart = AeccAttributeId::kAttrIdVAlignmentStartText
  ProfileEnd = AeccAttributeId::kAttrIdVAlignmentEndText
  PointOfVerticalIntersection = AeccAttributeId::kAttrIdVAlignmentPVIText
  GradeBreak = AeccAttributeId::kAttrIdVAlignmentGradeBreakText
  BeginVerticalCurve = AeccAttributeId::kAttrIdVAlignmentBeginVCurveText
  BeginVerticalCurveStation = AeccAttributeId::kAttrIdVAlignmentBeginVCurveStationText
  BeginVerticalCurveElevation = AeccAttributeId::kAttrIdVAlignmentBeginVCurveElevText
  EndVerticalCurve = AeccAttributeId::kAttrIdVAlignmentEndVCurveText
  EndVerticalCurveStation = AeccAttributeId::kAttrIdVAlignmentEndVCurveStationText
  EndVerticalCurveElevation = AeccAttributeId::kAttrIdVAlignmentEndVCurveElevText
  VerticalCompoundCurveIntersect = AeccAttributeId::kAttrIdVAlignmentPointOfCompoundCurvatureText
  VerticalCompoundCurveIntersectStation = AeccAttributeId::kAttrIdVAlignmentPointOfCompoundCurvatureStationText
  VerticalCompoundCurveIntersectElevation = AeccAttributeId::kAttrIdVAlignmentPointOfCompoundCurvatureElevText
  VerticalReverseCurveIntersect = AeccAttributeId::kAttrIdVAlignmentPointOfReverseCurvatureText
  VerticalReverseCurveIntersectStation = AeccAttributeId::kAttrIdVAlignmentPointOfReverseCurvatureStationText
  VerticalReverseCurveIntersectElevation = AeccAttributeId::kAttrIdVAlignmentPointOfReverseCurvatureElevText
  HighPoint = AeccAttributeId::kAttrIdVAlignmentHighPointText
  LowPoint = AeccAttributeId::kAttrIdVAlignmentLowPointText
  CurveCoefficient = AeccAttributeId::kAttrIdVAlignmentKValueText
  GradeChange = AeccAttributeId::kAttrIdVAlignmentGradeChangeText
  OverallHighPoint = AeccAttributeId::kAttrIdVAlignmentOverallHighPointText
  OverallLowPoint = AeccAttributeId::kAttrIdVAlignmentOverallLowPointText
End Enum


Autodesk::Civil::Land::Settings::AbbreviationSuperelevationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::AbbreviationSuperelevationType Enumeration
Autodesk::Civil::Land::Settings::AbbreviationSuperelevationType Enumeration
Collapse All

Defines Abbreviation Superelevation type.

C#
public enum AbbreviationSuperelevationType {
  Manual = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointManual,
  ShoulderBreakover = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointShBreakOverText,
  ReverseCrown = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointRevCrownText,
  LowShoulderMatch = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointLowShMatchText,
  LevelCrown = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointLevelCrwnText,
  EndNormalShoulder = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointEndNormShText,
  BeginNormalShoulder = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointBegNormShText,
  EndFullSuper = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointEndFullSupText,
  BeginFullSuper = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointBegFullSupText,
  BeginNormalCrown = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointBegNormCrwnText,
  EndOfAlignment = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointEndOfAlnText,
  BeginOfAlignment = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointBegOfAlnText,
  EndNormalCrown = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointEndNormCrwnText
}
Visual Basic
Public Enum AbbreviationSuperelevationType
  Manual = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointManual
  ShoulderBreakover = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointShBreakOverText
  ReverseCrown = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointRevCrownText
  LowShoulderMatch = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointLowShMatchText
  LevelCrown = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointLevelCrwnText
  EndNormalShoulder = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointEndNormShText
  BeginNormalShoulder = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointBegNormShText
  EndFullSuper = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointEndFullSupText
  BeginFullSuper = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointBegFullSupText
  BeginNormalCrown = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointBegNormCrwnText
  EndOfAlignment = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointEndOfAlnText
  BeginOfAlignment = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointBegOfAlnText
  EndNormalCrown = AeccAttributeId::kAttrIdAlignmentSuperElevTransPointEndNormCrwnText
End Enum


Autodesk::Civil::Land::Settings::AutomaticManual Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::AutomaticManual Enumeration
Autodesk::Civil::Land::Settings::AutomaticManual Enumeration
Collapse All

Specifies how some properties are assigned point creation.

C#
public enum AutomaticManual {
  Automatic = AeccPromptSetPointCreate::kAutomatic,
  AutomaticObject = AeccPromptSetPointCreate::kAutomaticObject,
  Manual = AeccPromptSetPointCreate::kManual,
  None = AeccPromptSetPointCreate::kNone
}
Visual Basic
Public Enum AutomaticManual
  Automatic = AeccPromptSetPointCreate::kAutomatic
  AutomaticObject = AeccPromptSetPointCreate::kAutomaticObject
  Manual = AeccPromptSetPointCreate::kManual
  None = AeccPromptSetPointCreate::kNone
End Enum


Autodesk::Civil::Land::Settings::GeographicCoordinateType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::GeographicCoordinateType Enumeration
Autodesk::Civil::Land::Settings::GeographicCoordinateType Enumeration
Collapse All

Specifies the order in which geographic coordinates are displayed on the command line during point creation.

C#
public enum GeographicCoordinateType {
  LatLong = AeccPromptSetPointCreateGeodeticDirect::kLatLong,
  LongLat = AeccPromptSetPointCreateGeodeticDirect::kLongLat
}
Visual Basic
Public Enum GeographicCoordinateType
  LatLong = AeccPromptSetPointCreateGeodeticDirect::kLatLong
  LongLat = AeccPromptSetPointCreateGeodeticDirect::kLongLat
End Enum


Autodesk::Civil::Land::Settings::GridCoordinateType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::GridCoordinateType Enumeration
Autodesk::Civil::Land::Settings::GridCoordinateType Enumeration
Collapse All

Specifies the order in which grid coordinates are displayed on the command line during point creation.

C#
public enum GridCoordinateType {
  EastingNorthing = AeccPromptSetPointCreateGeodeticDirect::kGridEastingNorthing,
  NorthingEasting = AeccPromptSetPointCreateGeodeticDirect::kGridNorthingEasting
}
Visual Basic
Public Enum GridCoordinateType
  EastingNorthing = AeccPromptSetPointCreateGeodeticDirect::kGridEastingNorthing
  NorthingEasting = AeccPromptSetPointCreateGeodeticDirect::kGridNorthingEasting
End Enum


Autodesk::Civil::Land::Settings::LocalCoordinateType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::LocalCoordinateType Enumeration
Autodesk::Civil::Land::Settings::LocalCoordinateType Enumeration
Collapse All

Specifies the order and format used to display local coordinates on the command line during point creation.

C#
public enum LocalCoordinateType {
  EastingNorthing = AeccPromptSetPointCreateGeodeticDirect::kEN,
  NorthingEasting = AeccPromptSetPointCreateGeodeticDirect::kNE,
  XY = AeccPromptSetPointCreateGeodeticDirect::kXY,
  YX = AeccPromptSetPointCreateGeodeticDirect::kYX
}
Visual Basic
Public Enum LocalCoordinateType
  EastingNorthing = AeccPromptSetPointCreateGeodeticDirect::kEN
  NorthingEasting = AeccPromptSetPointCreateGeodeticDirect::kNE
  XY = AeccPromptSetPointCreateGeodeticDirect::kXY
  YX = AeccPromptSetPointCreateGeodeticDirect::kYX
End Enum


Autodesk::Civil::Land::Settings::SectionViewAnchorType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::SectionViewAnchorType Enumeration
Autodesk::Civil::Land::Settings::SectionViewAnchorType Enumeration
Collapse All

Defines types of section view anchors.

C#
public enum SectionViewAnchorType {
  TopLeft,
  TopCenter,
  TopRight,
  MiddleLeft,
  MiddleCenter,
  MiddleRight,
  BottomLeft,
  BottomCenter,
  BottomRight
}
Visual Basic
Public Enum SectionViewAnchorType
  TopLeft
  TopCenter
  TopRight
  MiddleLeft
  MiddleCenter
  MiddleRight
  BottomLeft
  BottomCenter
  BottomRight
End Enum


Autodesk::Civil::Land::Settings::TableAnchorType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::TableAnchorType Enumeration
Autodesk::Civil::Land::Settings::TableAnchorType Enumeration
Collapse All

Defines types of table anchors.

C#
public enum TableAnchorType {
  TopLeft,
  TopCenter,
  TopRight,
  MiddleLeft,
  MiddleCenter,
  MiddleRight,
  BottomLeft,
  BottomCenter,
  BottomRight
}
Visual Basic
Public Enum TableAnchorType
  TopLeft
  TopCenter
  TopRight
  MiddleLeft
  MiddleCenter
  MiddleRight
  BottomLeft
  BottomCenter
  BottomRight
End Enum


Autodesk::Civil::Land::Settings::TableLayoutType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::TableLayoutType Enumeration
Autodesk::Civil::Land::Settings::TableLayoutType Enumeration
Collapse All

Defines table layout directions.

C#
public enum TableLayoutType {
  Horizontal,
  Vertical
}
Visual Basic
Public Enum TableLayoutType
  Horizontal
  Vertical
End Enum


Autodesk::Civil::Land::Settings::TileDirectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Land::Settings::TileDirectionType Enumeration
Autodesk::Civil::Land::Settings::TileDirectionType Enumeration
Collapse All

Defines tile directions.

C#
public enum TileDirectionType {
  Across,
  Down
}
Visual Basic
Public Enum TileDirectionType
  Across
  Down
End Enum


Classes

The following table lists classes in this documentation.

Classes
Class | Description
AlignmentDesignCheck | The Alignment design check class.
AlignmentDesignCheckCollection | The AlignmentDesignCheckCollection class.
AlignmentDesignCheckRoot | The AlignmentDesignCheckRoot class.
ProfileDesignCheck | The Profile design check class.
ProfileDesignCheckCollection | The ProfileDesignCheckCollection class.
ProfileDesignCheckRoot | The ProfileDesignCheckRoot class.
Templates
Template | Description
GeometryPointLabelOption | This class controls the selection state of a point type. The class is implemented as a generic that can be... more
GeometryPointSelector | This class encapsulates the functionality to allow selecting and un-selecting point types.
Links
Classes, Templates


AlignmentDesignCheck Class

The Alignment design check class.

Class Hierarchy
Autodesk::Civil::DesignCheck
    Autodesk::Civil::Land::AlignmentDesignCheck
C#
public class AlignmentDesignCheck : Autodesk::Civil::DesignCheck;
Visual Basic
Public Class AlignmentDesignCheck
Inherits Autodesk::Civil::DesignCheck
Links
AlignmentDesignCheck Properties, AlignmentDesignCheck Members, Class Hierarchy


AlignmentDesignCheck Members

The following tables list the members exposed by AlignmentDesignCheck.

Public Properties
Public Property | Description
Description | Gets and sets the description of the DesignCheck.
DesignCheckType | Gets the type of the DesignCheck.
Expression | Gets or sets the expression of the DesignCheck.
Name | Gets the name of the DesignCheck.
Links
Public Properties


AlignmentDesignCheck Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheck Class > AlignmentDesignCheck Properties
AlignmentDesignCheck Properties
Collapse All

The properties of AlignmentDesignCheck are listed here.

Public Properties
Public Property | Description
DesignCheckType | Gets the type of the DesignCheck.
Links
Public Properties


AlignmentDesignCheck::DesignCheckType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheck Class > AlignmentDesignCheck Properties > AlignmentDesignCheck::DesignCheckType Property
AlignmentDesignCheck::DesignCheckType Property
Collapse All

Gets the type of the DesignCheck.

C#
public AlignmentDesignCheckType DesignCheckType;
Visual Basic
Public Property DesignCheckType() As AlignmentDesignCheckType
Links
AlignmentDesignCheck Class, AlignmentDesignCheck Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckCollection Class

The AlignmentDesignCheckCollection class.

Class Hierarchy
Autodesk::Civil::Land::AlignmentDesignCheckCollection
C#
public class AlignmentDesignCheckCollection : Autodesk::Civil::DesignCheckCollection<AlignmentDesignCheck^>;
Visual Basic
Public Class AlignmentDesignCheckCollection
Inherits Autodesk::Civil::DesignCheckCollection<AlignmentDesignCheck^>
Links
AlignmentDesignCheckCollection Methods, AlignmentDesignCheckCollection Properties, AlignmentDesignCheckCollection Members, Class Hierarchy


AlignmentDesignCheckCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Members
AlignmentDesignCheckCollection Members
Collapse All

The following tables list the members exposed by AlignmentDesignCheckCollection.

Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
Remove | Removes AlignmentDesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.
Public Properties
Public Property | Description
Count | Gets the number of AlignmentDesignCheck in the collection.
default | Gets the AlignmentDesignCheck by a specified name in the collection.
Links
Public Methods, Public Properties


AlignmentDesignCheckCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Methods
AlignmentDesignCheckCollection Methods
Collapse All

The methods of AlignmentDesignCheckCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
Remove | Removes AlignmentDesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.
Links
Public Methods


AlignmentDesignCheckCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Methods > AlignmentDesignCheckCollection::Add Method
AlignmentDesignCheckCollection::Add Method
Collapse All

Adds a DesignCheck by specifying the name and expression.

C#
public AlignmentDesignCheck Add(
    ref System::String name,
    ref System::String description,
    ref System::String expression
);
Visual Basic
Public Function Add(
    ByRef name As System::String,
    ByRef description As System::String,
    ByRef expression As System::String
) As AlignmentDesignCheck
Parameters
Parameters | Description
name | The name of DesignCheck.
description | The description of DesignCheck.
expression | The expression of DesignCheck.
Exceptions
Exceptions | Description
System::ArgumentException | Throw when: 1: The name is duplicated. 2: The expression is not valid.
Links
AlignmentDesignCheckCollection Class, AlignmentDesignCheckCollection Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckCollection::Clear Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Methods > AlignmentDesignCheckCollection::Clear Method
AlignmentDesignCheckCollection::Clear Method
Collapse All

Removes all DesignChecks from the collection.

C#
public Clear();
Visual Basic
Public Sub Clear()
Remarks

It will remove all corresponding DesignChecks existed in AlignmentDesignCheckSet or ProfileDesignCheckSet.

Links
AlignmentDesignCheckCollection Class, AlignmentDesignCheckCollection Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckCollection::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Methods > AlignmentDesignCheckCollection::Remove Method
AlignmentDesignCheckCollection::Remove Method
Collapse All

Removes AlignmentDesignCheck from the collection by the specified name.

C#
public Remove(
    ref System::String name
);
Visual Basic
Public Sub Remove(
    ByRef name As System::String
)
Parameters
Parameters | Description
name | Specifies the name of DesignCheck to remove.
Remarks

It will remove the corresponding AlignmentDesignCheck existed in AlignmentDesignCheckSet.

Exceptions
Exceptions | Description
System::ArgumentException | Throw when the DesignCheck with specified name cannot be found in the collection.
Links
AlignmentDesignCheckCollection Class, AlignmentDesignCheckCollection Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckCollection::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Methods > AlignmentDesignCheckCollection::RemoveAt Method
AlignmentDesignCheckCollection::RemoveAt Method
Collapse All

Removes DesignCheck from the collection by the specified index.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Specifies index in the collection to remove.
Remarks

It will remove the corresponding AlignmentDesignCheck existed in AlignmentDesignCheckSet.

Links
AlignmentDesignCheckCollection Class, AlignmentDesignCheckCollection Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Properties
AlignmentDesignCheckCollection Properties
Collapse All

The properties of AlignmentDesignCheckCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of AlignmentDesignCheck in the collection.
default | Gets the AlignmentDesignCheck by a specified name in the collection.
Links
Public Properties


AlignmentDesignCheckCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Properties > AlignmentDesignCheckCollection::Count Property
AlignmentDesignCheckCollection::Count Property
Collapse All

Gets the number of AlignmentDesignCheck in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
AlignmentDesignCheckCollection Class, AlignmentDesignCheckCollection Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Properties > AlignmentDesignCheckCollection::default Property
AlignmentDesignCheckCollection::default Property
Collapse All

Gets the AlignmentDesignCheck by a specified name in the collection.

C#
public AlignmentDesignCheck default;
Visual Basic
Public Property default() As AlignmentDesignCheck
Parameters
Parameters | Description
name | Design check name.
Links
AlignmentDesignCheckCollection Class, AlignmentDesignCheckCollection Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckRoot Class

The AlignmentDesignCheckRoot class.

Class Hierarchy
Autodesk::Civil::Land::AlignmentDesignCheckRoot
C#
public class AlignmentDesignCheckRoot;
Visual Basic
Public Class AlignmentDesignCheckRoot
Links
AlignmentDesignCheckRoot Constructors, AlignmentDesignCheckRoot Properties, AlignmentDesignCheckRoot Members, Class Hierarchy


AlignmentDesignCheckRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Members
AlignmentDesignCheckRoot Members
Collapse All

The following tables list the members exposed by AlignmentDesignCheckRoot.

Public Methods
Public Method | Description
AlignmentDesignCheckRoot | Constructor of AlignmentDesignCheckRoot class.
Public Properties
Public Property | Description
CurveDesignChecks | Gets the collection of all alignment curve design checks.
LineDesignChecks | Gets the collection of all alignment line design checks.
SpiralDesignChecks | Gets the collection of all alignment spiral design checks.
TangentIntersectionDesignChecks | Gets the collection of all alignment tangent intersection design checks.
Links
Public Methods, Public Properties


AlignmentDesignCheckRoot Constructors

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Constructors
AlignmentDesignCheckRoot Constructors
Collapse All

The constructors of AlignmentDesignCheckRoot are listed here.

Public Methods
Public Method | Description
AlignmentDesignCheckRoot | Constructor of AlignmentDesignCheckRoot class.
Links
Public Methods


AlignmentDesignCheckRoot::AlignmentDesignCheckRoot Constructor

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Constructors > AlignmentDesignCheckRoot::AlignmentDesignCheckRoot Constructor
AlignmentDesignCheckRoot::AlignmentDesignCheckRoot Constructor
Collapse All

Constructor of AlignmentDesignCheckRoot class.

C#
public AlignmentDesignCheckRoot(
    ref Autodesk::AutoCAD::DatabaseServices::Database pDatabase
);
Visual Basic
Public Sub New(
    ByRef pDatabase As Autodesk::AutoCAD::DatabaseServices::Database
)
Links
AlignmentDesignCheckRoot Class, AlignmentDesignCheckRoot Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Properties
AlignmentDesignCheckRoot Properties
Collapse All

The properties of AlignmentDesignCheckRoot are listed here.

Public Properties
Public Property | Description
CurveDesignChecks | Gets the collection of all alignment curve design checks.
LineDesignChecks | Gets the collection of all alignment line design checks.
SpiralDesignChecks | Gets the collection of all alignment spiral design checks.
TangentIntersectionDesignChecks | Gets the collection of all alignment tangent intersection design checks.
Links
Public Properties


AlignmentDesignCheckRoot::CurveDesignChecks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Properties > AlignmentDesignCheckRoot::CurveDesignChecks Property
AlignmentDesignCheckRoot::CurveDesignChecks Property
Collapse All

Gets the collection of all alignment curve design checks.

C#
public AlignmentDesignCheckCollection CurveDesignChecks;
Visual Basic
Public Property CurveDesignChecks() As AlignmentDesignCheckCollection
Links
AlignmentDesignCheckRoot Class, AlignmentDesignCheckRoot Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckRoot::LineDesignChecks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Properties > AlignmentDesignCheckRoot::LineDesignChecks Property
AlignmentDesignCheckRoot::LineDesignChecks Property
Collapse All

Gets the collection of all alignment line design checks.

C#
public AlignmentDesignCheckCollection LineDesignChecks;
Visual Basic
Public Property LineDesignChecks() As AlignmentDesignCheckCollection
Links
AlignmentDesignCheckRoot Class, AlignmentDesignCheckRoot Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckRoot::SpiralDesignChecks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Properties > AlignmentDesignCheckRoot::SpiralDesignChecks Property
AlignmentDesignCheckRoot::SpiralDesignChecks Property
Collapse All

Gets the collection of all alignment spiral design checks.

C#
public AlignmentDesignCheckCollection SpiralDesignChecks;
Visual Basic
Public Property SpiralDesignChecks() As AlignmentDesignCheckCollection
Links
AlignmentDesignCheckRoot Class, AlignmentDesignCheckRoot Members, Autodesk::Civil::Land Namespace


AlignmentDesignCheckRoot::TangentIntersectionDesignChecks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Properties > AlignmentDesignCheckRoot::TangentIntersectionDesignChecks Property
AlignmentDesignCheckRoot::TangentIntersectionDesignChecks Property
Collapse All

Gets the collection of all alignment tangent intersection design checks.

C#
public AlignmentDesignCheckCollection TangentIntersectionDesignChecks;
Visual Basic
Public Property TangentIntersectionDesignChecks() As AlignmentDesignCheckCollection
Links
AlignmentDesignCheckRoot Class, AlignmentDesignCheckRoot Members, Autodesk::Civil::Land Namespace


GeometryPointLabelOption Template

This class controls the selection state of a point type. The class is implemented as a generic that can be parameterized on the point type to manage.

Class Hierarchy
Autodesk::Civil::Land::GeometryPointLabelOption
C#
public class GeometryPointLabelOption<typename T> where T : Enum;
Visual Basic
Public Class GeometryPointLabelOption(Of typename T)
Links
GeometryPointLabelOption Properties, GeometryPointLabelOption Members, Class Hierarchy


GeometryPointLabelOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointLabelOption Template > GeometryPointLabelOption Members
GeometryPointLabelOption Members
Collapse All

The following tables list the members exposed by GeometryPointLabelOption.

Public Properties
Public Property | Description
PointType | This is PointType, a member of class GeometryPointLabelOption.
Selected | This is Selected, a member of class GeometryPointLabelOption.
Links
Public Properties


GeometryPointLabelOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointLabelOption Template > GeometryPointLabelOption Properties
GeometryPointLabelOption Properties
Collapse All

The properties of GeometryPointLabelOption are listed here.

Public Properties
Public Property | Description
PointType | This is PointType, a member of class GeometryPointLabelOption.
Selected | This is Selected, a member of class GeometryPointLabelOption.
Links
Public Properties


GeometryPointLabelOption::PointType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointLabelOption Template > GeometryPointLabelOption Properties > GeometryPointLabelOption::PointType Property
GeometryPointLabelOption::PointType Property
Collapse All

This is PointType, a member of class GeometryPointLabelOption.

C#
public T PointType;
Visual Basic
Public Property PointType() As T
Links
GeometryPointLabelOption Template, GeometryPointLabelOption Members, Autodesk::Civil::Land Namespace


GeometryPointLabelOption::Selected Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointLabelOption Template > GeometryPointLabelOption Properties > GeometryPointLabelOption::Selected Property
GeometryPointLabelOption::Selected Property
Collapse All

This is Selected, a member of class GeometryPointLabelOption.

C#
public bool Selected;
Visual Basic
Public Property Selected() As bool
Links
GeometryPointLabelOption Template, GeometryPointLabelOption Members, Autodesk::Civil::Land Namespace


GeometryPointSelector Template

This class encapsulates the functionality to allow selecting and un-selecting point types.

Class Hierarchy
Autodesk::Civil::Land::GeometryPointSelector
C#
public class GeometryPointSelector<typename T> where T : Enum;
Visual Basic
Public Class GeometryPointSelector(Of typename T)
Links
GeometryPointSelector Methods, GeometryPointSelector Constructors, GeometryPointSelector Properties, GeometryPointSelector Members, Class Hierarchy


GeometryPointSelector Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Members
GeometryPointSelector Members
Collapse All

The following tables list the members exposed by GeometryPointSelector.

Public Methods
Public Method | Description
GeometryPointSelector | This is GeometryPointSelector, a member of class GeometryPointSelector.
SelectAll | Selects all supported geometry points.
UnSelectAll | Unselects all supported geometry points.
Public Properties
Public Property | Description
default | Gets the GeometryPointLabelOption instance for the specified type, which allows the user to modify its Selected state.
Links
Public Methods, Public Properties


GeometryPointSelector Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Methods
GeometryPointSelector Methods
Collapse All

The methods of GeometryPointSelector are listed here.

Public Methods
Public Method | Description
SelectAll | Selects all supported geometry points.
UnSelectAll | Unselects all supported geometry points.
Links
Public Methods


GeometryPointSelector::SelectAll Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Methods > GeometryPointSelector::SelectAll Method
GeometryPointSelector::SelectAll Method
Collapse All

Selects all supported geometry points.

C#
public SelectAll();
Visual Basic
Public Sub SelectAll()
Links
GeometryPointSelector Template, GeometryPointSelector Members, Autodesk::Civil::Land Namespace


GeometryPointSelector::UnSelectAll Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Methods > GeometryPointSelector::UnSelectAll Method
GeometryPointSelector::UnSelectAll Method
Collapse All

Unselects all supported geometry points.

C#
public UnSelectAll();
Visual Basic
Public Sub UnSelectAll()
Links
GeometryPointSelector Template, GeometryPointSelector Members, Autodesk::Civil::Land Namespace


GeometryPointSelector Constructors

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Constructors
GeometryPointSelector Constructors
Collapse All

The constructors of GeometryPointSelector are listed here.

Public Methods
Public Method | Description
GeometryPointSelector | This is GeometryPointSelector, a member of class GeometryPointSelector.
Links
Public Methods


GeometryPointSelector::GeometryPointSelector Constructor

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Constructors > GeometryPointSelector::GeometryPointSelector Constructor
GeometryPointSelector::GeometryPointSelector Constructor
Collapse All

This is GeometryPointSelector, a member of class GeometryPointSelector.

C#
public GeometryPointSelector();
Visual Basic
Public Sub New()
Links
GeometryPointSelector Template, GeometryPointSelector Members, Autodesk::Civil::Land Namespace


GeometryPointSelector Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Properties
GeometryPointSelector Properties
Collapse All

The properties of GeometryPointSelector are listed here.

Public Properties
Public Property | Description
default | Gets the GeometryPointLabelOption instance for the specified type, which allows the user to modify its Selected state.
Links
Public Properties


GeometryPointSelector::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Properties > GeometryPointSelector::default Property
GeometryPointSelector::default Property
Collapse All

Gets the GeometryPointLabelOption instance for the specified type, which allows the user to modify its Selected state.

C#
public GeometryPointLabelOption<T> default;
Visual Basic
Public Property default() As GeometryPointLabelOption<T>
Links
GeometryPointSelector Template, GeometryPointSelector Members, Autodesk::Civil::Land Namespace


ProfileDesignCheck Class

The Profile design check class.

Class Hierarchy
Autodesk::Civil::DesignCheck
    Autodesk::Civil::Land::ProfileDesignCheck
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignmentDesignCheckSet"))]
public class ProfileDesignCheck : Autodesk::Civil::DesignCheck;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbVAlignmentDesignCheckSet"))>
Public Class ProfileDesignCheck
Inherits Autodesk::Civil::DesignCheck
Links
ProfileDesignCheck Properties, ProfileDesignCheck Members, Class Hierarchy


ProfileDesignCheck Members

The following tables list the members exposed by ProfileDesignCheck.

Public Properties
Public Property | Description
Description | Gets and sets the description of the DesignCheck.
DesignCheckType | Gets the type of the Profile DesignCheck type.
Expression | Gets or sets the expression of the DesignCheck.
Name | Gets the name of the DesignCheck.
Links
Public Properties


ProfileDesignCheck Properties

The properties of ProfileDesignCheck are listed here.

Public Properties
Public Property | Description
DesignCheckType | Gets the type of the Profile DesignCheck type.
Links
Public Properties


ProfileDesignCheck::DesignCheckType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheck Class > ProfileDesignCheck Properties > ProfileDesignCheck::DesignCheckType Property
ProfileDesignCheck::DesignCheckType Property
Collapse All

Gets the type of the Profile DesignCheck type.

C#
public ProfileDesignCheckType DesignCheckType;
Visual Basic
Public Property DesignCheckType() As ProfileDesignCheckType
Links
ProfileDesignCheck Class, ProfileDesignCheck Members, Autodesk::Civil::Land Namespace


ProfileDesignCheckCollection Class

The ProfileDesignCheckCollection class.

Class Hierarchy
Autodesk::Civil::Land::ProfileDesignCheckCollection
C#
public class ProfileDesignCheckCollection : Autodesk::Civil::DesignCheckCollection<ProfileDesignCheck^>;
Visual Basic
Public Class ProfileDesignCheckCollection
Inherits Autodesk::Civil::DesignCheckCollection<ProfileDesignCheck^>
Links
ProfileDesignCheckCollection Methods, ProfileDesignCheckCollection Properties, ProfileDesignCheckCollection Members, Class Hierarchy


ProfileDesignCheckCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Members
ProfileDesignCheckCollection Members
Collapse All

The following tables list the members exposed by ProfileDesignCheckCollection.

Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
Remove | Removes ProfileDesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.
Public Properties
Public Property | Description
Count | Gets the number of ProfileDesignCheck in the collection.
default | Gets the ProfileDesignCheck by a specified name in the collection.
Links
Public Methods, Public Properties


ProfileDesignCheckCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Methods
ProfileDesignCheckCollection Methods
Collapse All

The methods of ProfileDesignCheckCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
Remove | Removes ProfileDesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.
Links
Public Methods


ProfileDesignCheckCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Methods > ProfileDesignCheckCollection::Add Method
ProfileDesignCheckCollection::Add Method
Collapse All

Adds a DesignCheck by specifying the name and expression.

C#
public ProfileDesignCheck Add(
    ref System::String name,
    ref System::String description,
    ref System::String expression
);
Visual Basic
Public Function Add(
    ByRef name As System::String,
    ByRef description As System::String,
    ByRef expression As System::String
) As ProfileDesignCheck
Parameters
Parameters | Description
name | The name of DesignCheck.
description | The description of DesignCheck.
expression | The expression of DesignCheck.
Exceptions
Exceptions | Description
System::ArgumentException | Throw when: 1: The name is duplicated. 2: The expression is not valid.
Links
ProfileDesignCheckCollection Class, ProfileDesignCheckCollection Members, Autodesk::Civil::Land Namespace


ProfileDesignCheckCollection::Clear Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Methods > ProfileDesignCheckCollection::Clear Method
ProfileDesignCheckCollection::Clear Method
Collapse All

Removes all DesignChecks from the collection.

C#
public Clear();
Visual Basic
Public Sub Clear()
Remarks

It will remove all corresponding DesignChecks existed in ProfileDesignCheckSet or ProfileDesignCheckSet.

Links
ProfileDesignCheckCollection Class, ProfileDesignCheckCollection Members, Autodesk::Civil::Land Namespace


ProfileDesignCheckCollection::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Methods > ProfileDesignCheckCollection::Remove Method
ProfileDesignCheckCollection::Remove Method
Collapse All

Removes ProfileDesignCheck from the collection by the specified name.

C#
public Remove(
    ref System::String name
);
Visual Basic
Public Sub Remove(
    ByRef name As System::String
)
Parameters
Parameters | Description
name | Specifies the name of DesignCheck to remove.
Remarks

It will remove the corresponding ProfileDesignCheck existed in ProfileDesignCheckSet.

Exceptions
Exceptions | Description
System::ArgumentException | Throw when the DesignCheck with specified name cannot be found in the collection.
Links
ProfileDesignCheckCollection Class, ProfileDesignCheckCollection Members, Autodesk::Civil::Land Namespace


ProfileDesignCheckCollection::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Methods > ProfileDesignCheckCollection::RemoveAt Method
ProfileDesignCheckCollection::RemoveAt Method
Collapse All

Removes DesignCheck from the collection by the specified index.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Specifies index in the collection to remove.
Remarks

It will remove the corresponding ProfileDesignCheck existed in ProfileDesignCheckSet.

Links
ProfileDesignCheckCollection Class, ProfileDesignCheckCollection Members, Autodesk::Civil::Land Namespace


ProfileDesignCheckCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Properties
ProfileDesignCheckCollection Properties
Collapse All

The properties of ProfileDesignCheckCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of ProfileDesignCheck in the collection.
default | Gets the ProfileDesignCheck by a specified name in the collection.
Links
Public Properties


ProfileDesignCheckCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Properties > ProfileDesignCheckCollection::Count Property
ProfileDesignCheckCollection::Count Property
Collapse All

Gets the number of ProfileDesignCheck in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ProfileDesignCheckCollection Class, ProfileDesignCheckCollection Members, Autodesk::Civil::Land Namespace


ProfileDesignCheckCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Properties > ProfileDesignCheckCollection::default Property
ProfileDesignCheckCollection::default Property
Collapse All

Gets the ProfileDesignCheck by a specified name in the collection.

C#
public ProfileDesignCheck default;
Visual Basic
Public Property default() As ProfileDesignCheck
Parameters
Parameters | Description
name | Design check name.
Links
ProfileDesignCheckCollection Class, ProfileDesignCheckCollection Members, Autodesk::Civil::Land Namespace


ProfileDesignCheckRoot Class

The ProfileDesignCheckRoot class.

Class Hierarchy
Autodesk::Civil::Land::ProfileDesignCheckRoot
C#
public class ProfileDesignCheckRoot;
Visual Basic
Public Class ProfileDesignCheckRoot
Links
ProfileDesignCheckRoot Constructors, ProfileDesignCheckRoot Properties, ProfileDesignCheckRoot Members, Class Hierarchy


ProfileDesignCheckRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Members
ProfileDesignCheckRoot Members
Collapse All

The following tables list the members exposed by ProfileDesignCheckRoot.

Public Methods
Public Method | Description
ProfileDesignCheckRoot | Constructor of ProfileDesignCheckRoot class.
Public Properties
Public Property | Description
CurveDesignChecks | Gets the collection of all profile curve design checks.
LineDesignChecks | Gets the collection of all profile line design checks.
Links
Public Methods, Public Properties


ProfileDesignCheckRoot Constructors

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Constructors
ProfileDesignCheckRoot Constructors
Collapse All

The constructors of ProfileDesignCheckRoot are listed here.

Public Methods
Public Method | Description
ProfileDesignCheckRoot | Constructor of ProfileDesignCheckRoot class.
Links
Public Methods


ProfileDesignCheckRoot::ProfileDesignCheckRoot Constructor

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Constructors > ProfileDesignCheckRoot::ProfileDesignCheckRoot Constructor
ProfileDesignCheckRoot::ProfileDesignCheckRoot Constructor
Collapse All

Constructor of ProfileDesignCheckRoot class.

C#
public ProfileDesignCheckRoot(
    ref Autodesk::AutoCAD::DatabaseServices::Database pDatabase
);
Visual Basic
Public Sub New(
    ByRef pDatabase As Autodesk::AutoCAD::DatabaseServices::Database
)
Links
ProfileDesignCheckRoot Class, ProfileDesignCheckRoot Members, Autodesk::Civil::Land Namespace


ProfileDesignCheckRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Properties
ProfileDesignCheckRoot Properties
Collapse All

The properties of ProfileDesignCheckRoot are listed here.

Public Properties
Public Property | Description
CurveDesignChecks | Gets the collection of all profile curve design checks.
LineDesignChecks | Gets the collection of all profile line design checks.
Links
Public Properties


ProfileDesignCheckRoot::CurveDesignChecks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Properties > ProfileDesignCheckRoot::CurveDesignChecks Property
ProfileDesignCheckRoot::CurveDesignChecks Property
Collapse All

Gets the collection of all profile curve design checks.

C#
public ProfileDesignCheckCollection CurveDesignChecks;
Visual Basic
Public Property CurveDesignChecks() As ProfileDesignCheckCollection
Links
ProfileDesignCheckRoot Class, ProfileDesignCheckRoot Members, Autodesk::Civil::Land Namespace


ProfileDesignCheckRoot::LineDesignChecks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Properties > ProfileDesignCheckRoot::LineDesignChecks Property
ProfileDesignCheckRoot::LineDesignChecks Property
Collapse All

Gets the collection of all profile line design checks.

C#
public ProfileDesignCheckCollection LineDesignChecks;
Visual Basic
Public Property LineDesignChecks() As ProfileDesignCheckCollection
Links
ProfileDesignCheckRoot Class, ProfileDesignCheckRoot Members, Autodesk::Civil::Land Namespace


Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
AlignmentDesignCheckType | Specifies the kind of alignment design check.
BreaklineElevationType |
CatchmentWatershedObjectType |
CrossSectionShapeType | Specifies cross section shapes.
DesignSpeedLookupMethodType | Specifies design speed lookup methods.
ElevationSourceType |
ElevationToUseType | An enumeration that defines the elevation to use for the crossing breaklines.
FeatureLineLayerSettingType | Defines the layer setting type.
FeatureLineLayerType |
FreeHaulDisplayType | An enumeration that defines how to show the free haul in the graph.
GradingDistanceProjectionType | An enumeration that defines the type of projection for the Distance target.
GradingElevationProjectionType | An enumeration that defines the type of projection for the Elevation target.
GradingInteriorCornerOverlapSolutionType | An enumeration that defines how interior corner projections are cleaned up when the footprint corner has different elevations.
GradingRelativeElevationProjectionType | An enumeration that defines the type of projection for the Relative Elevation target.
GradingSearchOrderType | An enumeration that defines the secarch order for the grading.
GradingSlopeFormatType | An enumeration that defines the target method for the grading
GradingSurfaceProjectionType | An enumeration that defines the type of projection for the Surface target.
GradingTargetType | An enumeration that defines the target method for the grading
HighsideLocationType | Specifies whether to drop leading zeros.
MapcheckDefaultAngleType |
MapcheckDefaultCurveDirectionType |
MapcheckDefaultCurveTraverseMethodType |
MapcheckDefaultSideType |
MassHaulLineDisplayStyleType | An enumeration that defines MassHaulLineStye display style type.
MassHaulLineHatchDisplayStyleType | An enumeration that defines MassHaulLineStye hatch display style type.
MassHaulViewDisplayStyleType | An enumeration that defines masshaul view components type.
MatchLineLabelLocationType | The Autodesk::Civil::Land::MatchLineLabelLocationType enumeration.
ParcelAnalysisType |
ParcelRemainderDistributionType | Defines the parcel remainder distribution type.
ParcelSelectionType | Defines the parcel selection type.
ParcelSolutionType | Defines the parcel solution type.
PipeNetworkPartDisplayType | The Autodesk::Civil::Land::PipeNetworkPartDisplayType enumeration.
PlanViewAlignType |
PointNamesExistType | Specifies how to resolve existing point names on import.
PointNumbersAssignedType | Specifies how to assign point numbers.
PointNumbersExistType | Specifies how to resolve conflicting point numbers.
PointNumbersSuppliedType | Specifies how to number supplied point numbers.
ProfileApplyCurveType | The Autodesk::Civil::Land::ProfileApplyCurveType enumeration.
ProfileCircularVerticalConstraintType |
ProfileCurveType |
ProfileDesignCheckType | Specifies the kind of Profile design check.
ProfileParabolicVerticalConstraintType |
ProfileViewDatumType | #UI Remove public enum class PointCreationPromptType { }; /PROPERTYENUM(PointCreationPrompt);
ProfileViewDisplayNetworkPartsType |
ProfileViewPlotType |
ProfileViewSplitDatumType |
ProfileViewSplitStationType |
ProfileViewStartCornerType |
RadiusLookupMethodType |
RemainderDistributionType |
SectionViewElevationRangeType | Specifies section view elevation ranges.
SheetCreateType |
SheetSetType |
ShoulderMethodType | Specifies shoulder methods.
SlopePatternLengthType | An enumeration that defines the slope pattern length type.
SlopePatternOffsetType | An enumeration that defines the slope pattern offset type.
SlopePatternStartType | An enumeration that defines the slope pattern start type.
SlopePatternSymbolType | An enumeration that defines the slope pattern symbol type.
SuperelevationCorridorType | Specifies superelevation corridor types.
SuperelevationStationRoundingType |
SurfaceBoundaryType | Defines the boundary type.
SurfaceRegionOptionsType |
SurfaceSimplifyType |
SurfaceType |
ViewFrameAngleType |
ViewFrameLabelLocationType | The Autodesk::Civil::Land::ViewFrameLabelLocationType enumeration.
WaterdropObjectType |
Links
Enumerations


Autodesk::Civil::Land::AlignmentDesignCheckType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::AlignmentDesignCheckType Enumeration
Autodesk::Civil::Land::AlignmentDesignCheckType Enumeration
Collapse All

Specifies the kind of alignment design check.

C#
public enum AlignmentDesignCheckType {
  TangentIntersection = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignCheckTangentIntersection,
  Line = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignCheckLine,
  Spiral = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignCheckSpiral,
  Curve = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignCheckCurve
}
Visual Basic
Public Enum AlignmentDesignCheckType
  TangentIntersection = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignCheckTangentIntersection
  Line = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignCheckLine
  Spiral = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignCheckSpiral
  Curve = AeccAttributeId::kAttrIdLabelStyleAlignmentDesignCheckCurve
End Enum


Autodesk::Civil::Land::BreaklineElevationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::BreaklineElevationType Enumeration
Autodesk::Civil::Land::BreaklineElevationType Enumeration
Collapse All
C#
public enum BreaklineElevationType {
  First = AeccDbSurfaceTin::kUseFirst,
  Last = AeccDbSurfaceTin::kUseLast,
  Average = AeccDbSurfaceTin::kUseAverage
}
Visual Basic
Public Enum BreaklineElevationType
  First = AeccDbSurfaceTin::kUseFirst
  Last = AeccDbSurfaceTin::kUseLast
  Average = AeccDbSurfaceTin::kUseAverage
End Enum


Autodesk::Civil::Land::CatchmentWatershedObjectType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::CatchmentWatershedObjectType Enumeration
Autodesk::Civil::Land::CatchmentWatershedObjectType Enumeration
Collapse All
C#
public enum CatchmentWatershedObjectType {
  Polyline2D = AeccDbCatchmentArea::k2DPolyline,
  Polyline3D = AeccDbCatchmentArea::k3DPolyline
}
Visual Basic
Public Enum CatchmentWatershedObjectType
  Polyline2D = AeccDbCatchmentArea::k2DPolyline
  Polyline3D = AeccDbCatchmentArea::k3DPolyline
End Enum


Autodesk::Civil::Land::CrossSectionShapeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::CrossSectionShapeType Enumeration
Autodesk::Civil::Land::CrossSectionShapeType Enumeration
Collapse All

Specifies cross section shapes.

C#
public enum CrossSectionShapeType {
  Planar = AeccHAlignment::kPlanarShape,
  Crowned = AeccHAlignment::kCrownedShape
}
Visual Basic
Public Enum CrossSectionShapeType
  Planar = AeccHAlignment::kPlanarShape
  Crowned = AeccHAlignment::kCrownedShape
End Enum


Autodesk::Civil::Land::DesignSpeedLookupMethodType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::DesignSpeedLookupMethodType Enumeration
Autodesk::Civil::Land::DesignSpeedLookupMethodType Enumeration
Collapse All

Specifies design speed lookup methods.

C#
public enum DesignSpeedLookupMethodType {
  Interpolate = AeccHAlignment::kInterpolateSpeed,
  Nearest = AeccHAlignment::kUseNearestHigherSpeed,
  RoundToNearest = AeccHAlignment::kRoundToNearestSpeed
}
Visual Basic
Public Enum DesignSpeedLookupMethodType
  Interpolate = AeccHAlignment::kInterpolateSpeed
  Nearest = AeccHAlignment::kUseNearestHigherSpeed
  RoundToNearest = AeccHAlignment::kRoundToNearestSpeed
End Enum


Autodesk::Civil::Land::ElevationSourceType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ElevationSourceType Enumeration
Autodesk::Civil::Land::ElevationSourceType Enumeration
Collapse All
C#
public enum ElevationSourceType {
  Surface = AeccDbFeatureLine::kElevsFromSurface,
  Grading = AeccDbFeatureLine::kElevsFromGradings,
  FixedElevation = AeccDbFeatureLine::kFixedElevation
}
Visual Basic
Public Enum ElevationSourceType
  Surface = AeccDbFeatureLine::kElevsFromSurface
  Grading = AeccDbFeatureLine::kElevsFromGradings
  FixedElevation = AeccDbFeatureLine::kFixedElevation
End Enum


Autodesk::Civil::Land::ElevationToUseType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ElevationToUseType Enumeration
Autodesk::Civil::Land::ElevationToUseType Enumeration
Collapse All

An enumeration that defines the elevation to use for the crossing breaklines.

C#
public enum ElevationToUseType {
  UseFirst = AeccDbSurfaceTin::kUseFirst,
  UseLast = AeccDbSurfaceTin::kUseLast,
  UseAverage = AeccDbSurfaceTin::kUseAverage
}
Visual Basic
Public Enum ElevationToUseType
  UseFirst = AeccDbSurfaceTin::kUseFirst
  UseLast = AeccDbSurfaceTin::kUseLast
  UseAverage = AeccDbSurfaceTin::kUseAverage
End Enum


Autodesk::Civil::Land::FeatureLineLayerSettingType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::FeatureLineLayerSettingType Enumeration
Autodesk::Civil::Land::FeatureLineLayerSettingType Enumeration
Collapse All

Defines the layer setting type.

C#
public enum FeatureLineLayerSettingType {
  UseLayerSetting = AeccDbFeatureLine::kUseLayerSetting,
  UseCurrentLayer = AeccDbFeatureLine::kUseCurrentLayer,
  UserEntityLayer = AeccDbFeatureLine::kUserEntityLayer
}
Visual Basic
Public Enum FeatureLineLayerSettingType
  UseLayerSetting = AeccDbFeatureLine::kUseLayerSetting
  UseCurrentLayer = AeccDbFeatureLine::kUseCurrentLayer
  UserEntityLayer = AeccDbFeatureLine::kUserEntityLayer
End Enum


Autodesk::Civil::Land::FeatureLineLayerType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::FeatureLineLayerType Enumeration
Autodesk::Civil::Land::FeatureLineLayerType Enumeration
Collapse All
C#
public enum FeatureLineLayerType {
  LayerSetting = AeccDbFeatureLine::kUseLayerSetting,
  CurrentLayer = AeccDbFeatureLine::kUseCurrentLayer
}
Visual Basic
Public Enum FeatureLineLayerType
  LayerSetting = AeccDbFeatureLine::kUseLayerSetting
  CurrentLayer = AeccDbFeatureLine::kUseCurrentLayer
End Enum


Autodesk::Civil::Land::FreeHaulDisplayType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::FreeHaulDisplayType Enumeration
Autodesk::Civil::Land::FreeHaulDisplayType Enumeration
Collapse All

An enumeration that defines how to show the free haul in the graph.

C#
public enum FreeHaulDisplayType {
  GradePoint = AeccDbMassHaulLineStyle::kFromGradePoint,
  BalancePoint = AeccDbMassHaulLineStyle::kFromBalancePoint
}
Visual Basic
Public Enum FreeHaulDisplayType
  GradePoint = AeccDbMassHaulLineStyle::kFromGradePoint
  BalancePoint = AeccDbMassHaulLineStyle::kFromBalancePoint
End Enum


Autodesk::Civil::Land::GradingDistanceProjectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::GradingDistanceProjectionType Enumeration
Autodesk::Civil::Land::GradingDistanceProjectionType Enumeration
Collapse All

An enumeration that defines the type of projection for the Distance target.

C#
public enum GradingDistanceProjectionType {
  Slope = AeccDbGradingCriteria::kDistProjTypeSlope,
  RelativeElevation = AeccDbGradingCriteria::kDistProjTypeRelElev
}
Visual Basic
Public Enum GradingDistanceProjectionType
  Slope = AeccDbGradingCriteria::kDistProjTypeSlope
  RelativeElevation = AeccDbGradingCriteria::kDistProjTypeRelElev
End Enum


Autodesk::Civil::Land::GradingElevationProjectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::GradingElevationProjectionType Enumeration
Autodesk::Civil::Land::GradingElevationProjectionType Enumeration
Collapse All

An enumeration that defines the type of projection for the Elevation target.

C#
public enum GradingElevationProjectionType {
  CutFillSlope = AeccDbGradingCriteria::kElevProjTypeCutFillSlope,
  CutSlope = AeccDbGradingCriteria::kElevProjTypeCutSlope,
  FillSlope = AeccDbGradingCriteria::kElevProjTypeFillSlope
}
Visual Basic
Public Enum GradingElevationProjectionType
  CutFillSlope = AeccDbGradingCriteria::kElevProjTypeCutFillSlope
  CutSlope = AeccDbGradingCriteria::kElevProjTypeCutSlope
  FillSlope = AeccDbGradingCriteria::kElevProjTypeFillSlope
End Enum


Autodesk::Civil::Land::GradingInteriorCornerOverlapSolutionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::GradingInteriorCornerOverlapSolutionType Enumeration
Autodesk::Civil::Land::GradingInteriorCornerOverlapSolutionType Enumeration
Collapse All

An enumeration that defines how interior corner projections are cleaned up when the footprint corner has different elevations.

C#
public enum GradingInteriorCornerOverlapSolutionType {
  UseAverageSlope = AeccDbGradingCriteria::kAverageElev,
  HoldSlopeAsMinimum = AeccDbGradingCriteria::kSlopeAsMin,
  HoldSlopeAsMaximum = AeccDbGradingCriteria::kSlopeAsMax
}
Visual Basic
Public Enum GradingInteriorCornerOverlapSolutionType
  UseAverageSlope = AeccDbGradingCriteria::kAverageElev
  HoldSlopeAsMinimum = AeccDbGradingCriteria::kSlopeAsMin
  HoldSlopeAsMaximum = AeccDbGradingCriteria::kSlopeAsMax
End Enum


Autodesk::Civil::Land::GradingRelativeElevationProjectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::GradingRelativeElevationProjectionType Enumeration
Autodesk::Civil::Land::GradingRelativeElevationProjectionType Enumeration
Collapse All

An enumeration that defines the type of projection for the Relative Elevation target.

C#
public enum GradingRelativeElevationProjectionType {
  Slope = AeccDbGradingCriteria::kRelElevProjTypeSlope,
  Distance = AeccDbGradingCriteria::kRelElevProjTypeDist
}
Visual Basic
Public Enum GradingRelativeElevationProjectionType
  Slope = AeccDbGradingCriteria::kRelElevProjTypeSlope
  Distance = AeccDbGradingCriteria::kRelElevProjTypeDist
End Enum


Autodesk::Civil::Land::GradingSearchOrderType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::GradingSearchOrderType Enumeration
Autodesk::Civil::Land::GradingSearchOrderType Enumeration
Collapse All

An enumeration that defines the secarch order for the grading.

C#
public enum GradingSearchOrderType {
  CutFirst = AeccDbGradingCriteria::kCutFirst,
  FillFirst = AeccDbGradingCriteria::kFillFirst
}
Visual Basic
Public Enum GradingSearchOrderType
  CutFirst = AeccDbGradingCriteria::kCutFirst
  FillFirst = AeccDbGradingCriteria::kFillFirst
End Enum


Autodesk::Civil::Land::GradingSlopeFormatType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::GradingSlopeFormatType Enumeration
Autodesk::Civil::Land::GradingSlopeFormatType Enumeration
Collapse All

An enumeration that defines the target method for the grading

C#
public enum GradingSlopeFormatType {
  Slope = AeccDbGradingCriteria::kSlopeTypeSlope,
  Grade = AeccDbGradingCriteria::kSlopeTypeGrade
}
Visual Basic
Public Enum GradingSlopeFormatType
  Slope = AeccDbGradingCriteria::kSlopeTypeSlope
  Grade = AeccDbGradingCriteria::kSlopeTypeGrade
End Enum


Autodesk::Civil::Land::GradingSurfaceProjectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::GradingSurfaceProjectionType Enumeration
Autodesk::Civil::Land::GradingSurfaceProjectionType Enumeration
Collapse All

An enumeration that defines the type of projection for the Surface target.

C#
public enum GradingSurfaceProjectionType {
  CutFillSlope = AeccDbGradingCriteria::kSurfProjTypeCutFillSlope,
  CutSlope = AeccDbGradingCriteria::kSurfProjTypeCutSlope,
  FillSlope = AeccDbGradingCriteria::kSurfProjTypeFillSlope
}
Visual Basic
Public Enum GradingSurfaceProjectionType
  CutFillSlope = AeccDbGradingCriteria::kSurfProjTypeCutFillSlope
  CutSlope = AeccDbGradingCriteria::kSurfProjTypeCutSlope
  FillSlope = AeccDbGradingCriteria::kSurfProjTypeFillSlope
End Enum


Autodesk::Civil::Land::GradingTargetType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::GradingTargetType Enumeration
Autodesk::Civil::Land::GradingTargetType Enumeration
Collapse All

An enumeration that defines the target method for the grading

C#
public enum GradingTargetType {
  Surface = AeccDbGradingCriteria::kTargetTypeSurf,
  Elevation = AeccDbGradingCriteria::kTargetTypeElev,
  RelativeElevation = AeccDbGradingCriteria::kTargetTypeRelElev,
  Distance = AeccDbGradingCriteria::kTargetTypeDist
}
Visual Basic
Public Enum GradingTargetType
  Surface = AeccDbGradingCriteria::kTargetTypeSurf
  Elevation = AeccDbGradingCriteria::kTargetTypeElev
  RelativeElevation = AeccDbGradingCriteria::kTargetTypeRelElev
  Distance = AeccDbGradingCriteria::kTargetTypeDist
End Enum


Autodesk::Civil::Land::HighsideLocationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::HighsideLocationType Enumeration
Autodesk::Civil::Land::HighsideLocationType Enumeration
Collapse All

Specifies whether to drop leading zeros.

C#
public enum HighsideLocationType {
  LeftEdge = AeccHAlignment::kLeftEdge,
  Level = AeccHAlignment::kLevel,
  RightEdge = AeccHAlignment::kRightEdge
}
Visual Basic
Public Enum HighsideLocationType
  LeftEdge = AeccHAlignment::kLeftEdge
  Level = AeccHAlignment::kLevel
  RightEdge = AeccHAlignment::kRightEdge
End Enum


Autodesk::Civil::Land::MapcheckDefaultAngleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::MapcheckDefaultAngleType Enumeration
Autodesk::Civil::Land::MapcheckDefaultAngleType Enumeration
Collapse All
C#
public enum MapcheckDefaultAngleType {
  Direction = AeccMapcheck::kAngTypeDirection,
  Angle = AeccMapcheck::kAngTypeAngle,
  DeflectionAngle = AeccMapcheck::kAngTypeDeflectionAngle
}
Visual Basic
Public Enum MapcheckDefaultAngleType
  Direction = AeccMapcheck::kAngTypeDirection
  Angle = AeccMapcheck::kAngTypeAngle
  DeflectionAngle = AeccMapcheck::kAngTypeDeflectionAngle
End Enum


Autodesk::Civil::Land::MapcheckDefaultCurveDirectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::MapcheckDefaultCurveDirectionType Enumeration
Autodesk::Civil::Land::MapcheckDefaultCurveDirectionType Enumeration
Collapse All
C#
public enum MapcheckDefaultCurveDirectionType {
  Clockwise = AeccMapcheck::kClockwise,
  Counterclockwise = AeccMapcheck::kCounterClockwise
}
Visual Basic
Public Enum MapcheckDefaultCurveDirectionType
  Clockwise = AeccMapcheck::kClockwise
  Counterclockwise = AeccMapcheck::kCounterClockwise
End Enum


Autodesk::Civil::Land::MapcheckDefaultCurveTraverseMethodType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::MapcheckDefaultCurveTraverseMethodType Enumeration
Autodesk::Civil::Land::MapcheckDefaultCurveTraverseMethodType Enumeration
Collapse All
C#
public enum MapcheckDefaultCurveTraverseMethodType {
  AcrossChord = AeccMapcheck::kAcrossChord,
  ThroughRadius = AeccMapcheck::kThroughRadius
}
Visual Basic
Public Enum MapcheckDefaultCurveTraverseMethodType
  AcrossChord = AeccMapcheck::kAcrossChord
  ThroughRadius = AeccMapcheck::kThroughRadius
End Enum


Autodesk::Civil::Land::MapcheckDefaultSideType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::MapcheckDefaultSideType Enumeration
Autodesk::Civil::Land::MapcheckDefaultSideType Enumeration
Collapse All
C#
public enum MapcheckDefaultSideType {
  Line = AeccMapcheck::kLine,
  Curve = AeccMapcheck::kCurve
}
Visual Basic
Public Enum MapcheckDefaultSideType
  Line = AeccMapcheck::kLine
  Curve = AeccMapcheck::kCurve
End Enum


Autodesk::Civil::Land::MassHaulLineDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::MassHaulLineDisplayStyleType Enumeration
Autodesk::Civil::Land::MassHaulLineDisplayStyleType Enumeration
Collapse All

An enumeration that defines MassHaulLineStye display style type.

C#
public enum MassHaulLineDisplayStyleType {
  MassHaulLine = AeccDbMassHaulLineStyle::kDispCompMassHaulLineMassHaulLine,
  FreeHaulLine = AeccDbMassHaulLineStyle::kDispCompMassHaulLineFreeHaulLine,
  FreeHaulAreaHatch = AeccDbMassHaulLineStyle::kDispCompMassHaulLineFreeHaulAreaHatch,
  OverHaulAreaHatch = AeccDbMassHaulLineStyle::kDispCompMassHaulLineOverHaulAreaHatch
}
Visual Basic
Public Enum MassHaulLineDisplayStyleType
  MassHaulLine = AeccDbMassHaulLineStyle::kDispCompMassHaulLineMassHaulLine
  FreeHaulLine = AeccDbMassHaulLineStyle::kDispCompMassHaulLineFreeHaulLine
  FreeHaulAreaHatch = AeccDbMassHaulLineStyle::kDispCompMassHaulLineFreeHaulAreaHatch
  OverHaulAreaHatch = AeccDbMassHaulLineStyle::kDispCompMassHaulLineOverHaulAreaHatch
End Enum


Autodesk::Civil::Land::MassHaulLineHatchDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::MassHaulLineHatchDisplayStyleType Enumeration
Autodesk::Civil::Land::MassHaulLineHatchDisplayStyleType Enumeration
Collapse All

An enumeration that defines MassHaulLineStye hatch display style type.

C#
public enum MassHaulLineHatchDisplayStyleType {
  FreeHaulAreaHatch = AeccDbMassHaulLineStyle::kHatchCompMassHaulLineFreeHaulAreaHatch,
  OverHaulAreaHatch = AeccDbMassHaulLineStyle::kHatchCompMassHaulLineOverHaulAreaHatch
}
Visual Basic
Public Enum MassHaulLineHatchDisplayStyleType
  FreeHaulAreaHatch = AeccDbMassHaulLineStyle::kHatchCompMassHaulLineFreeHaulAreaHatch
  OverHaulAreaHatch = AeccDbMassHaulLineStyle::kHatchCompMassHaulLineOverHaulAreaHatch
End Enum


Autodesk::Civil::Land::MassHaulViewDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::MassHaulViewDisplayStyleType Enumeration
Autodesk::Civil::Land::MassHaulViewDisplayStyleType Enumeration
Collapse All

An enumeration that defines masshaul view components type.

C#
public enum MassHaulViewDisplayStyleType {
  GraphTitle = AeccDbGraphStyle::kDispCompGraphTitle,
  LeftAxis = AeccDbGraphStyle::kDispCompGraphLeftAxis,
  LeftAxisTitle = AeccDbGraphStyle::kDispCompGraphLeftAxisTitle,
  LeftAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMajor,
  LeftAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMinor,
  LeftAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMajor,
  LeftAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMinor,
  RightAxis = AeccDbGraphStyle::kDispCompGraphRightAxis,
  RightAxisTitle = AeccDbGraphStyle::kDispCompGraphRightAxisTitle,
  RightAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMajor,
  RightAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMinor,
  RightAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMajor,
  RightAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMinor,
  TopAxis = AeccDbGraphStyle::kDispCompGraphTopAxis,
  TopAxisTitle = AeccDbGraphStyle::kDispCompGraphTopAxisTitle,
  TopAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMajor,
  TopAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMinor,
  TopAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMajor,
  TopAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMinor,
  BottomAxis = AeccDbGraphStyle::kDispCompGraphBottomAxis,
  BottomAxisTitle = AeccDbGraphStyle::kDispCompGraphBottomAxisTitle,
  BottomAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMajor,
  BottomAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMinor,
  BottomAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMajor,
  BottomAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMinor,
  MiddleAxis = AeccDbGraphStyle::kDispCompGraphCenterAxis,
  MiddleAxisTitle = AeccDbGraphStyle::kDispCompGraphCenterAxisTitle,
  MiddleAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphCenterAxisAnnotationMajor,
  MiddleAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphCenterAxisAnnotationMinor,
  MiddleAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphCenterAxisTicksMajor,
  MiddleAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphCenterAxisTicksMinor,
  GridHorizontalMajor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMajor,
  GridHorizontalMinor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMinor,
  GridVerticalMajor = AeccDbGraphStyle::kDispCompGraphGridVerticalMajor,
  GridVerticalMinor = AeccDbGraphStyle::kDispCompGraphGridVerticalMinor,
  GridAtSampleLineStations = AeccDbGraphStyle::kDispCompGraphGridSampleLineVertices,
  GridAtHGP = AeccDbGraphStyle::kDispCompGraphGridAtHGP,
  TopAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationHGP,
  TopAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphTopAxisTicksHGP,
  BottomAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationHGP,
  BottomAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksHGP,
  MiddleAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphMiddleAxisAnnotationHGP,
  MiddleAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphMiddleAxisTicksHGP
}
Visual Basic
Public Enum MassHaulViewDisplayStyleType
  GraphTitle = AeccDbGraphStyle::kDispCompGraphTitle
  LeftAxis = AeccDbGraphStyle::kDispCompGraphLeftAxis
  LeftAxisTitle = AeccDbGraphStyle::kDispCompGraphLeftAxisTitle
  LeftAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMajor
  LeftAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisAnnotationMinor
  LeftAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMajor
  LeftAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphLeftAxisTicksMinor
  RightAxis = AeccDbGraphStyle::kDispCompGraphRightAxis
  RightAxisTitle = AeccDbGraphStyle::kDispCompGraphRightAxisTitle
  RightAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMajor
  RightAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphRightAxisAnnotationMinor
  RightAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMajor
  RightAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphRightAxisTicksMinor
  TopAxis = AeccDbGraphStyle::kDispCompGraphTopAxis
  TopAxisTitle = AeccDbGraphStyle::kDispCompGraphTopAxisTitle
  TopAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMajor
  TopAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationMinor
  TopAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMajor
  TopAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphTopAxisTicksMinor
  BottomAxis = AeccDbGraphStyle::kDispCompGraphBottomAxis
  BottomAxisTitle = AeccDbGraphStyle::kDispCompGraphBottomAxisTitle
  BottomAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMajor
  BottomAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationMinor
  BottomAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMajor
  BottomAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksMinor
  MiddleAxis = AeccDbGraphStyle::kDispCompGraphCenterAxis
  MiddleAxisTitle = AeccDbGraphStyle::kDispCompGraphCenterAxisTitle
  MiddleAxisAnnotationMajor = AeccDbGraphStyle::kDispCompGraphCenterAxisAnnotationMajor
  MiddleAxisAnnotationMinor = AeccDbGraphStyle::kDispCompGraphCenterAxisAnnotationMinor
  MiddleAxisTicksMajor = AeccDbGraphStyle::kDispCompGraphCenterAxisTicksMajor
  MiddleAxisTicksMinor = AeccDbGraphStyle::kDispCompGraphCenterAxisTicksMinor
  GridHorizontalMajor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMajor
  GridHorizontalMinor = AeccDbGraphStyle::kDispCompGraphGridHorizontalMinor
  GridVerticalMajor = AeccDbGraphStyle::kDispCompGraphGridVerticalMajor
  GridVerticalMinor = AeccDbGraphStyle::kDispCompGraphGridVerticalMinor
  GridAtSampleLineStations = AeccDbGraphStyle::kDispCompGraphGridSampleLineVertices
  GridAtHGP = AeccDbGraphStyle::kDispCompGraphGridAtHGP
  TopAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphTopAxisAnnotationHGP
  TopAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphTopAxisTicksHGP
  BottomAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphBottomAxisAnnotationHGP
  BottomAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphBottomAxisTicksHGP
  MiddleAxisAnnotationHGP = AeccDbGraphStyle::kDispCompGraphMiddleAxisAnnotationHGP
  MiddleAxisTicksHGP = AeccDbGraphStyle::kDispCompGraphMiddleAxisTicksHGP
End Enum


Autodesk::Civil::Land::MatchLineLabelLocationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::MatchLineLabelLocationType Enumeration
Autodesk::Civil::Land::MatchLineLabelLocationType Enumeration
Collapse All

The Autodesk::Civil::Land::MatchLineLabelLocationType enumeration.

C#
public enum MatchLineLabelLocationType {
  Start = AeccDbMatchLine::kMatchLineAnchorStart,
  Middle = AeccDbMatchLine::kMatchLineAnchorMiddle,
  End = AeccDbMatchLine::kMatchLineAnchorEnd,
  Intersection = AeccDbMatchLine::kMatchLineAnchorIntersection
}
Visual Basic
Public Enum MatchLineLabelLocationType
  Start = AeccDbMatchLine::kMatchLineAnchorStart
  Middle = AeccDbMatchLine::kMatchLineAnchorMiddle
  End = AeccDbMatchLine::kMatchLineAnchorEnd
  Intersection = AeccDbMatchLine::kMatchLineAnchorIntersection
End Enum


Autodesk::Civil::Land::ParcelAnalysisType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ParcelAnalysisType Enumeration
Autodesk::Civil::Land::ParcelAnalysisType Enumeration
Collapse All
C#
public enum ParcelAnalysisType {
  Inverse = AeccDbFace::kInverse,
  Mapcheck = AeccDbFace::kMapcheck
}
Visual Basic
Public Enum ParcelAnalysisType
  Inverse = AeccDbFace::kInverse
  Mapcheck = AeccDbFace::kMapcheck
End Enum


Autodesk::Civil::Land::ParcelRemainderDistributionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ParcelRemainderDistributionType Enumeration
Autodesk::Civil::Land::ParcelRemainderDistributionType Enumeration
Collapse All

Defines the parcel remainder distribution type.

C#
public enum ParcelRemainderDistributionType {
  CreateRemainderParcel = AeccLotSizer2::createRemainderParcel,
  PlaceRemainderInLastParcel = AeccLotSizer2::placeRemainderInLastParcel,
  RedistributeRemainder = AeccLotSizer2::redistributeRemainder
}
Visual Basic
Public Enum ParcelRemainderDistributionType
  CreateRemainderParcel = AeccLotSizer2::createRemainderParcel
  PlaceRemainderInLastParcel = AeccLotSizer2::placeRemainderInLastParcel
  RedistributeRemainder = AeccLotSizer2::redistributeRemainder
End Enum


Autodesk::Civil::Land::ParcelSelectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ParcelSelectionType Enumeration
Autodesk::Civil::Land::ParcelSelectionType Enumeration
Collapse All

Defines the parcel selection type.

C#
public enum ParcelSelectionType {
  PickPointWithinParcel,
  SelectParcelAreaLabel
}
Visual Basic
Public Enum ParcelSelectionType
  PickPointWithinParcel
  SelectParcelAreaLabel
End Enum


Autodesk::Civil::Land::ParcelSolutionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ParcelSolutionType Enumeration
Autodesk::Civil::Land::ParcelSolutionType Enumeration
Collapse All

Defines the parcel solution type.

C#
public enum ParcelSolutionType {
  UseShortestFrontage = AeccCreateLotSizer::kUseShortestFrontage,
  UseSmallestArea = AeccCreateLotSizer::kUseSmallestArea
}
Visual Basic
Public Enum ParcelSolutionType
  UseShortestFrontage = AeccCreateLotSizer::kUseShortestFrontage
  UseSmallestArea = AeccCreateLotSizer::kUseSmallestArea
End Enum


Autodesk::Civil::Land::PipeNetworkPartDisplayType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::PipeNetworkPartDisplayType Enumeration
Autodesk::Civil::Land::PipeNetworkPartDisplayType Enumeration
Collapse All

The Autodesk::Civil::Land::PipeNetworkPartDisplayType enumeration.

C#
public enum PipeNetworkPartDisplayType {
  OnlySelected = AeccUiCmdGraphProfile::kPipeNetworkPartsDisplaySelected,
  All = AeccUiCmdGraphProfile::kPipeNetworkPartsDisplayAll
}
Visual Basic
Public Enum PipeNetworkPartDisplayType
  OnlySelected = AeccUiCmdGraphProfile::kPipeNetworkPartsDisplaySelected
  All = AeccUiCmdGraphProfile::kPipeNetworkPartsDisplayAll
End Enum


Autodesk::Civil::Land::PlanViewAlignType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::PlanViewAlignType Enumeration
Autodesk::Civil::Land::PlanViewAlignType Enumeration
Collapse All
C#
public enum PlanViewAlignType {
  Start = AeccPlanProd::kAlignStart,
  Center = AeccPlanProd::kAlignCenter,
  End = AeccPlanProd::kAlignEnd
}
Visual Basic
Public Enum PlanViewAlignType
  Start = AeccPlanProd::kAlignStart
  Center = AeccPlanProd::kAlignCenter
  End = AeccPlanProd::kAlignEnd
End Enum


Autodesk::Civil::Land::PointNamesExistType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::PointNamesExistType Enumeration
Autodesk::Civil::Land::PointNamesExistType Enumeration
Collapse All

Specifies how to resolve existing point names on import.

C#
public enum PointNamesExistType {
  UseNameTemplate = AeccDuplicatePointNumberResolver::kDuplicateNameTemplate,
  Counter = AeccDuplicatePointNumberResolver::kDuplicateNameCounter,
  Notify = AeccDuplicatePointNumberResolver::kDuplicateNameNotify
}
Visual Basic
Public Enum PointNamesExistType
  UseNameTemplate = AeccDuplicatePointNumberResolver::kDuplicateNameTemplate
  Counter = AeccDuplicatePointNumberResolver::kDuplicateNameCounter
  Notify = AeccDuplicatePointNumberResolver::kDuplicateNameNotify
End Enum


Autodesk::Civil::Land::PointNumbersAssignedType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::PointNumbersAssignedType Enumeration
Autodesk::Civil::Land::PointNumbersAssignedType Enumeration
Collapse All

Specifies how to assign point numbers.

C#
public enum PointNumbersAssignedType {
  UseNext = AeccDuplicatePointNumberResolver::kUseNext,
  SequenceFrom = AeccDuplicatePointNumberResolver::kSequenceFrom
}
Visual Basic
Public Enum PointNumbersAssignedType
  UseNext = AeccDuplicatePointNumberResolver::kUseNext
  SequenceFrom = AeccDuplicatePointNumberResolver::kSequenceFrom
End Enum


Autodesk::Civil::Land::PointNumbersExistType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::PointNumbersExistType Enumeration
Autodesk::Civil::Land::PointNumbersExistType Enumeration
Collapse All

Specifies how to resolve conflicting point numbers.

C#
public enum PointNumbersExistType {
  Renumber = AeccDuplicatePointNumberResolver::kRenumber,
  Merge = AeccDuplicatePointNumberResolver::kMergeNumbers,
  Overwrite = AeccDuplicatePointNumberResolver::kOverwriteNumbers,
  Notify = AeccDuplicatePointNumberResolver::kNotifyNumbers
}
Visual Basic
Public Enum PointNumbersExistType
  Renumber = AeccDuplicatePointNumberResolver::kRenumber
  Merge = AeccDuplicatePointNumberResolver::kMergeNumbers
  Overwrite = AeccDuplicatePointNumberResolver::kOverwriteNumbers
  Notify = AeccDuplicatePointNumberResolver::kNotifyNumbers
End Enum


Autodesk::Civil::Land::PointNumbersSuppliedType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::PointNumbersSuppliedType Enumeration
Autodesk::Civil::Land::PointNumbersSuppliedType Enumeration
Collapse All

Specifies how to number supplied point numbers.

C#
public enum PointNumbersSuppliedType {
  Use = AeccDuplicatePointNumberResolver::kUse,
  Ignore = AeccDuplicatePointNumberResolver::kIgnore,
  AddOffset = AeccDuplicatePointNumberResolver::kAddOffsetToSupplied
}
Visual Basic
Public Enum PointNumbersSuppliedType
  Use = AeccDuplicatePointNumberResolver::kUse
  Ignore = AeccDuplicatePointNumberResolver::kIgnore
  AddOffset = AeccDuplicatePointNumberResolver::kAddOffsetToSupplied
End Enum
Remarks

The AddOffset enum specifies that a fixed value is added to each point number in the point data file. The value to add is specified by the point number offset setting. For example, if you specify 200 for the point number offset, then points with numbers 1, 2, and 3 in the point data file are numbered 201, 202, and 203 when imported.


Autodesk::Civil::Land::ProfileApplyCurveType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileApplyCurveType Enumeration
Autodesk::Civil::Land::ProfileApplyCurveType Enumeration
Collapse All

The Autodesk::Civil::Land::ProfileApplyCurveType enumeration.

C#
public enum ProfileApplyCurveType {
  CrestAndSag = AeccDbVAlignmentDesignCheckSet::kCrestSagCurves,
  CrestOnly = AeccDbVAlignmentDesignCheckSet::kCrestCurvesOnly,
  SagOnly = AeccDbVAlignmentDesignCheckSet::kSagCurvesOnly
}
Visual Basic
Public Enum ProfileApplyCurveType
  CrestAndSag = AeccDbVAlignmentDesignCheckSet::kCrestSagCurves
  CrestOnly = AeccDbVAlignmentDesignCheckSet::kCrestCurvesOnly
  SagOnly = AeccDbVAlignmentDesignCheckSet::kSagCurvesOnly
End Enum


Autodesk::Civil::Land::ProfileCircularVerticalConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileCircularVerticalConstraintType Enumeration
Autodesk::Civil::Land::ProfileCircularVerticalConstraintType Enumeration
Collapse All
C#
public enum ProfileCircularVerticalConstraintType {
  CurveLength = AeccVAlignment::kCurveLength,
  Radius = AeccVAlignment::kRadius
}
Visual Basic
Public Enum ProfileCircularVerticalConstraintType
  CurveLength = AeccVAlignment::kCurveLength
  Radius = AeccVAlignment::kRadius
End Enum


Autodesk::Civil::Land::ProfileCurveType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileCurveType Enumeration
Autodesk::Civil::Land::ProfileCurveType Enumeration
Collapse All
C#
public enum ProfileCurveType {
  Circular = AeccVAlignment::kCircArc2d,
  SymmetricParabola = AeccVAlignment::kSymParabola,
  AsymmetricParabola = AeccVAlignment::kASymParabola
}
Visual Basic
Public Enum ProfileCurveType
  Circular = AeccVAlignment::kCircArc2d
  SymmetricParabola = AeccVAlignment::kSymParabola
  AsymmetricParabola = AeccVAlignment::kASymParabola
End Enum


Autodesk::Civil::Land::ProfileDesignCheckType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileDesignCheckType Enumeration
Autodesk::Civil::Land::ProfileDesignCheckType Enumeration
Collapse All

Specifies the kind of Profile design check.

C#
public enum ProfileDesignCheckType {
  Line = AeccAttributeId::kAttrIdLabelStyleVAlignmentDesignCheckLine,
  Curve = AeccAttributeId::kAttrIdLabelStyleVAlignmentDesignCheckCurve
}
Visual Basic
Public Enum ProfileDesignCheckType
  Line = AeccAttributeId::kAttrIdLabelStyleVAlignmentDesignCheckLine
  Curve = AeccAttributeId::kAttrIdLabelStyleVAlignmentDesignCheckCurve
End Enum


Autodesk::Civil::Land::ProfileParabolicVerticalConstraintType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileParabolicVerticalConstraintType Enumeration
Autodesk::Civil::Land::ProfileParabolicVerticalConstraintType Enumeration
Collapse All
C#
public enum ProfileParabolicVerticalConstraintType {
  CurveLength = AeccVAlignment::kCurveLength,
  KValue = AeccVAlignment::kKValue
}
Visual Basic
Public Enum ProfileParabolicVerticalConstraintType
  CurveLength = AeccVAlignment::kCurveLength
  KValue = AeccVAlignment::kKValue
End Enum


Autodesk::Civil::Land::ProfileViewDatumType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileViewDatumType Enumeration
Autodesk::Civil::Land::ProfileViewDatumType Enumeration
Collapse All

#UI Remove

public enum class PointCreationPromptType { }; /PROPERTYENUM(PointCreationPrompt);

C#
public enum ProfileViewDatumType {
  MinElevation = AeccUiCmdGraphProfile::kPVDatumByMinElevation,
  MeanElevation = AeccUiCmdGraphProfile::kPVDatumByMeanElevation
}
Visual Basic
Public Enum ProfileViewDatumType
  MinElevation = AeccUiCmdGraphProfile::kPVDatumByMinElevation
  MeanElevation = AeccUiCmdGraphProfile::kPVDatumByMeanElevation
End Enum


Autodesk::Civil::Land::ProfileViewDisplayNetworkPartsType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileViewDisplayNetworkPartsType Enumeration
Autodesk::Civil::Land::ProfileViewDisplayNetworkPartsType Enumeration
Collapse All
C#
public enum ProfileViewDisplayNetworkPartsType {
  DisplaySelected = AeccUiCmdGraphProfile::kPipeNetworkPartsDisplaySelected,
  DisplayAll = AeccUiCmdGraphProfile::kPipeNetworkPartsDisplayAll
}
Visual Basic
Public Enum ProfileViewDisplayNetworkPartsType
  DisplaySelected = AeccUiCmdGraphProfile::kPipeNetworkPartsDisplaySelected
  DisplayAll = AeccUiCmdGraphProfile::kPipeNetworkPartsDisplayAll
End Enum


Autodesk::Civil::Land::ProfileViewPlotType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileViewPlotType Enumeration
Autodesk::Civil::Land::ProfileViewPlotType Enumeration
Collapse All
C#
public enum ProfileViewPlotType {
  ByRows = AeccDbGraphProfile::kPlotByRows,
  ByColumns = AeccDbGraphProfile::kPlotByColumns
}
Visual Basic
Public Enum ProfileViewPlotType
  ByRows = AeccDbGraphProfile::kPlotByRows
  ByColumns = AeccDbGraphProfile::kPlotByColumns
End Enum


Autodesk::Civil::Land::ProfileViewSplitDatumType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileViewSplitDatumType Enumeration
Autodesk::Civil::Land::ProfileViewSplitDatumType Enumeration
Collapse All
C#
public enum ProfileViewSplitDatumType {
  ExactElevation = AeccUiCmdGraphProfile::kSplitDatumOptionExactElevation,
  PreviousMajorGrid = AeccUiCmdGraphProfile::kSplitDatumOptionPrevMajorGrid,
  PreviousMinorGrid = AeccUiCmdGraphProfile::kSplitDatumOptionPrevMinorGrid
}
Visual Basic
Public Enum ProfileViewSplitDatumType
  ExactElevation = AeccUiCmdGraphProfile::kSplitDatumOptionExactElevation
  PreviousMajorGrid = AeccUiCmdGraphProfile::kSplitDatumOptionPrevMajorGrid
  PreviousMinorGrid = AeccUiCmdGraphProfile::kSplitDatumOptionPrevMinorGrid
End Enum


Autodesk::Civil::Land::ProfileViewSplitStationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileViewSplitStationType Enumeration
Autodesk::Civil::Land::ProfileViewSplitStationType Enumeration
Collapse All
C#
public enum ProfileViewSplitStationType {
  ExactStation = AeccUiCmdGraphProfile::kSplitStationOptionExactStation,
  PreviousMajorGrid = AeccUiCmdGraphProfile::kSplitStationOptionPrevMajorGrid,
  PreviousMinorGrid = AeccUiCmdGraphProfile::kSplitStationOptionPrevMinorGrid
}
Visual Basic
Public Enum ProfileViewSplitStationType
  ExactStation = AeccUiCmdGraphProfile::kSplitStationOptionExactStation
  PreviousMajorGrid = AeccUiCmdGraphProfile::kSplitStationOptionPrevMajorGrid
  PreviousMinorGrid = AeccUiCmdGraphProfile::kSplitStationOptionPrevMinorGrid
End Enum


Autodesk::Civil::Land::ProfileViewStartCornerType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ProfileViewStartCornerType Enumeration
Autodesk::Civil::Land::ProfileViewStartCornerType Enumeration
Collapse All
C#
public enum ProfileViewStartCornerType {
  LowerLeft = AeccDbGraphProfile::kLowerLeft,
  UpperLeft = AeccDbGraphProfile::kUpperLeft,
  LowerRight = AeccDbGraphProfile::kLowerRight,
  UpperRight = AeccDbGraphProfile::kUpperRight
}
Visual Basic
Public Enum ProfileViewStartCornerType
  LowerLeft = AeccDbGraphProfile::kLowerLeft
  UpperLeft = AeccDbGraphProfile::kUpperLeft
  LowerRight = AeccDbGraphProfile::kLowerRight
  UpperRight = AeccDbGraphProfile::kUpperRight
End Enum


Autodesk::Civil::Land::RadiusLookupMethodType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::RadiusLookupMethodType Enumeration
Autodesk::Civil::Land::RadiusLookupMethodType Enumeration
Collapse All
C#
public enum RadiusLookupMethodType {
  Interpolate = AeccHAlignment::kInterpolateRadius,
  Nearest = AeccHAlignment::kUseNearestLowerRadius,
  RoundToNearest = AeccHAlignment::kRoundToNearestRadius
}
Visual Basic
Public Enum RadiusLookupMethodType
  Interpolate = AeccHAlignment::kInterpolateRadius
  Nearest = AeccHAlignment::kUseNearestLowerRadius
  RoundToNearest = AeccHAlignment::kRoundToNearestRadius
End Enum


Autodesk::Civil::Land::RemainderDistributionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::RemainderDistributionType Enumeration
Autodesk::Civil::Land::RemainderDistributionType Enumeration
Collapse All
C#
public enum RemainderDistributionType {
  CreateRemainderParcel = AeccLotSizer2::createRemainderParcel,
  PlaceRemainderInLastParcel = AeccLotSizer2::placeRemainderInLastParcel,
  RedistributeRemainder = AeccLotSizer2::redistributeRemainder
}
Visual Basic
Public Enum RemainderDistributionType
  CreateRemainderParcel = AeccLotSizer2::createRemainderParcel
  PlaceRemainderInLastParcel = AeccLotSizer2::placeRemainderInLastParcel
  RedistributeRemainder = AeccLotSizer2::redistributeRemainder
End Enum


Autodesk::Civil::Land::SectionViewElevationRangeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SectionViewElevationRangeType Enumeration
Autodesk::Civil::Land::SectionViewElevationRangeType Enumeration
Collapse All

Specifies section view elevation ranges.

C#
public enum SectionViewElevationRangeType {
  LowestElevation = AeccSectionViewAxesRangeOptions::kFromLowestElevOfSections,
  MeanElevation = AeccSectionViewAxesRangeOptions::kFromMeanElevOfSections,
  FollowASection = AeccSectionViewAxesRangeOptions::kFollowASection
}
Visual Basic
Public Enum SectionViewElevationRangeType
  LowestElevation = AeccSectionViewAxesRangeOptions::kFromLowestElevOfSections
  MeanElevation = AeccSectionViewAxesRangeOptions::kFromMeanElevOfSections
  FollowASection = AeccSectionViewAxesRangeOptions::kFollowASection
End Enum


Autodesk::Civil::Land::SheetCreateType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SheetCreateType Enumeration
Autodesk::Civil::Land::SheetCreateType Enumeration
Collapse All
C#
public enum SheetCreateType {
  NLayoutsPerNewDrawing = AeccPlanProd::kNLayoutsPerNewDrawing,
  AllLayoutsInOneNewDrawing = AeccPlanProd::kAllLayoutsInOneNewDrawing,
  AllLayoutsInCurrentDrawing = AeccPlanProd::kAllLayoutsInCurrentDrawing
}
Visual Basic
Public Enum SheetCreateType
  NLayoutsPerNewDrawing = AeccPlanProd::kNLayoutsPerNewDrawing
  AllLayoutsInOneNewDrawing = AeccPlanProd::kAllLayoutsInOneNewDrawing
  AllLayoutsInCurrentDrawing = AeccPlanProd::kAllLayoutsInCurrentDrawing
End Enum


Autodesk::Civil::Land::SheetSetType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SheetSetType Enumeration
Autodesk::Civil::Land::SheetSetType Enumeration
Collapse All
C#
public enum SheetSetType {
  PlanAndProfile = AeccPlanProd::kPlanAndProfile,
  PlanOnly = AeccPlanProd::kPlanOnly,
  ProfileOnly = AeccPlanProd::kProfileOnly
}
Visual Basic
Public Enum SheetSetType
  PlanAndProfile = AeccPlanProd::kPlanAndProfile
  PlanOnly = AeccPlanProd::kPlanOnly
  ProfileOnly = AeccPlanProd::kProfileOnly
End Enum


Autodesk::Civil::Land::ShoulderMethodType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ShoulderMethodType Enumeration
Autodesk::Civil::Land::ShoulderMethodType Enumeration
Collapse All

Specifies shoulder methods.

C#
public enum ShoulderMethodType {
  DefaultSlope = AeccHAlignment::kDefaultSlope,
  MatchLaneSlope = AeccHAlignment::kMatchLaneSlope,
  BreakoverRemoval = AeccHAlignment::kBreakoverRemoval
}
Visual Basic
Public Enum ShoulderMethodType
  DefaultSlope = AeccHAlignment::kDefaultSlope
  MatchLaneSlope = AeccHAlignment::kMatchLaneSlope
  BreakoverRemoval = AeccHAlignment::kBreakoverRemoval
End Enum


Autodesk::Civil::Land::SlopePatternLengthType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SlopePatternLengthType Enumeration
Autodesk::Civil::Land::SlopePatternLengthType Enumeration
Collapse All

An enumeration that defines the slope pattern length type.

C#
public enum SlopePatternLengthType {
  PercentOfLength = AeccSlopePatternLine::kPercentLength,
  Length = AeccSlopePatternLine::kFixedLength,
  SlopeRatio = AeccSlopePatternLine::kSlopeRatioLength,
  GradeRatio = AeccSlopePatternLine::kGradeRatioLength
}
Visual Basic
Public Enum SlopePatternLengthType
  PercentOfLength = AeccSlopePatternLine::kPercentLength
  Length = AeccSlopePatternLine::kFixedLength
  SlopeRatio = AeccSlopePatternLine::kSlopeRatioLength
  GradeRatio = AeccSlopePatternLine::kGradeRatioLength
End Enum
Members
Members | Description
PercentOfLength | Specifies that Line length is a fixed value
Length | Specifies that Line length is a percentage of the slope length, up to a specified maximum.
SlopeRatio | Specifies that line length varies directly with the steepness of the slope


Autodesk::Civil::Land::SlopePatternOffsetType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SlopePatternOffsetType Enumeration
Autodesk::Civil::Land::SlopePatternOffsetType Enumeration
Collapse All

An enumeration that defines the slope pattern offset type.

C#
public enum SlopePatternOffsetType {
  PercentLength = AeccSlopePatternLine::kPercentLengthOffset,
  FixedLength = AeccSlopePatternLine::kFixedLengthOffset,
  Divide = AeccSlopePatternLine::kDivideOffset
}
Visual Basic
Public Enum SlopePatternOffsetType
  PercentLength = AeccSlopePatternLine::kPercentLengthOffset
  FixedLength = AeccSlopePatternLine::kFixedLengthOffset
  Divide = AeccSlopePatternLine::kDivideOffset
End Enum
Members
Members | Description
PercentLength | Specifies that Offset is a percentage of the slope length at the position being offset from.
FixedLength | Specifies that Offset is a fixed value.
Divide | Specifies that Offset evenly divides the distance between the previous and the next components to insert one or more instances of the current component.


Autodesk::Civil::Land::SlopePatternStartType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SlopePatternStartType Enumeration
Autodesk::Civil::Land::SlopePatternStartType Enumeration
Collapse All

An enumeration that defines the slope pattern start type.

C#
public enum SlopePatternStartType {
  Top = AeccSlopePatternLine::kTop,
  Bottom = AeccSlopePatternLine::kBottom
}
Visual Basic
Public Enum SlopePatternStartType
  Top = AeccSlopePatternLine::kTop
  Bottom = AeccSlopePatternLine::kBottom
End Enum


Autodesk::Civil::Land::SlopePatternSymbolType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SlopePatternSymbolType Enumeration
Autodesk::Civil::Land::SlopePatternSymbolType Enumeration
Collapse All

An enumeration that defines the slope pattern symbol type.

C#
public enum SlopePatternSymbolType {
  None = AeccSlopePatternLine::kNone,
  Block = AeccSlopePatternLine::kBlock,
  Triangle = AeccSlopePatternLine::kTriangle,
  TriangleFilled = AeccSlopePatternLine::kTriangleFilled,
  TaperedLines = AeccSlopePatternLine::kTaperedLines,
  TaperedLinesNoGap = AeccSlopePatternLine::kTaperedLinesNoGap
}
Visual Basic
Public Enum SlopePatternSymbolType
  None = AeccSlopePatternLine::kNone
  Block = AeccSlopePatternLine::kBlock
  Triangle = AeccSlopePatternLine::kTriangle
  TriangleFilled = AeccSlopePatternLine::kTriangleFilled
  TaperedLines = AeccSlopePatternLine::kTaperedLines
  TaperedLinesNoGap = AeccSlopePatternLine::kTaperedLinesNoGap
End Enum
Members
Members | Description
None | No symbol.
Block | Adds a block that is defined in the drawing..
Triangle | Adds a triangle.
TriangleFilled | Adds a triangle with a solid fill.
TaperedLines | Adds a set of lines parallel to the edge of the slope, tapering toward the slope line in a triangular pattern.
TaperedLinesNoGap | Adds a set of tapered lines, and attaches the last tapered line to the slope line.


Autodesk::Civil::Land::SuperelevationCorridorType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SuperelevationCorridorType Enumeration
Autodesk::Civil::Land::SuperelevationCorridorType Enumeration
Collapse All

Specifies superelevation corridor types.

C#
public enum SuperelevationCorridorType {
  Undivided = AeccHAlignment::kUndividedType,
  Divided = AeccHAlignment::kDividedType
}
Visual Basic
Public Enum SuperelevationCorridorType
  Undivided = AeccHAlignment::kUndividedType
  Divided = AeccHAlignment::kDividedType
End Enum


Autodesk::Civil::Land::SuperelevationStationRoundingType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SuperelevationStationRoundingType Enumeration
Autodesk::Civil::Land::SuperelevationStationRoundingType Enumeration
Collapse All
C#
public enum SuperelevationStationRoundingType {
  None = AeccHAlignment::kNone,
  PointOne = AeccHAlignment::kNearestPtOne,
  One = AeccHAlignment::kNearestOne,
  Five = AeccHAlignment::kNearestFive,
  Ten = AeccHAlignment::kNearestTen
}
Visual Basic
Public Enum SuperelevationStationRoundingType
  None = AeccHAlignment::kNone
  PointOne = AeccHAlignment::kNearestPtOne
  One = AeccHAlignment::kNearestOne
  Five = AeccHAlignment::kNearestFive
  Ten = AeccHAlignment::kNearestTen
End Enum


Autodesk::Civil::Land::SurfaceBoundaryType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SurfaceBoundaryType Enumeration
Autodesk::Civil::Land::SurfaceBoundaryType Enumeration
Collapse All

Defines the boundary type.

C#
public enum SurfaceBoundaryType {
  Show = AeccSurface::boundaryTypeShow,
  Hide = AeccSurface::boundaryTypeHide,
  Outer = AeccSurface::boundaryTypeOuter,
  DataClip = AeccSurface::boundaryTypeDataClip
}
Visual Basic
Public Enum SurfaceBoundaryType
  Show = AeccSurface::boundaryTypeShow
  Hide = AeccSurface::boundaryTypeHide
  Outer = AeccSurface::boundaryTypeOuter
  DataClip = AeccSurface::boundaryTypeDataClip
End Enum


Autodesk::Civil::Land::SurfaceRegionOptionsType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SurfaceRegionOptionsType Enumeration
Autodesk::Civil::Land::SurfaceRegionOptionsType Enumeration
Collapse All
C#
public enum SurfaceRegionOptionsType {
  SurfBorder = AeccSurfaceTin::kSurfBorder,
  SpecifyWindow = AeccSurfaceTin::kSpecifyWindow,
  SelectObjects = AeccSurfaceTin::kSelectObjects
}
Visual Basic
Public Enum SurfaceRegionOptionsType
  SurfBorder = AeccSurfaceTin::kSurfBorder
  SpecifyWindow = AeccSurfaceTin::kSpecifyWindow
  SelectObjects = AeccSurfaceTin::kSelectObjects
End Enum


Autodesk::Civil::Land::SurfaceSimplifyType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SurfaceSimplifyType Enumeration
Autodesk::Civil::Land::SurfaceSimplifyType Enumeration
Collapse All
C#
public enum SurfaceSimplifyType {
  PointRemoval = AeccSurfaceTin::kPointBased,
  EdgeContraction = AeccSurfaceTin::kEdgeBased
}
Visual Basic
Public Enum SurfaceSimplifyType
  PointRemoval = AeccSurfaceTin::kPointBased
  EdgeContraction = AeccSurfaceTin::kEdgeBased
End Enum


Autodesk::Civil::Land::SurfaceType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::SurfaceType Enumeration
Autodesk::Civil::Land::SurfaceType Enumeration
Collapse All
C#
public enum SurfaceType {
  GridSurface = AeccLand::kGridSurface,
  TinSurface = AeccLand::kTinSurface,
  GridVolumeSurface = AeccLand::kGridVolumeSurface,
  TinVolumeSurface = AeccLand::kTinVolumeSurface
}
Visual Basic
Public Enum SurfaceType
  GridSurface = AeccLand::kGridSurface
  TinSurface = AeccLand::kTinSurface
  GridVolumeSurface = AeccLand::kGridVolumeSurface
  TinVolumeSurface = AeccLand::kTinVolumeSurface
End Enum


Autodesk::Civil::Land::ViewFrameAngleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ViewFrameAngleType Enumeration
Autodesk::Civil::Land::ViewFrameAngleType Enumeration
Collapse All
C#
public enum ViewFrameAngleType {
  AlongAlignment = AeccPlanProd::kAlongAlignment,
  RotateToNorth = AeccPlanProd::kRotateToNorth
}
Visual Basic
Public Enum ViewFrameAngleType
  AlongAlignment = AeccPlanProd::kAlongAlignment
  RotateToNorth = AeccPlanProd::kRotateToNorth
End Enum


Autodesk::Civil::Land::ViewFrameLabelLocationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::ViewFrameLabelLocationType Enumeration
Autodesk::Civil::Land::ViewFrameLabelLocationType Enumeration
Collapse All

The Autodesk::Civil::Land::ViewFrameLabelLocationType enumeration.

C#
public enum ViewFrameLabelLocationType {
  TopLeft = AeccDbViewFrame::kViewFrameAnchorTopLeft,
  TopCenter = AeccDbViewFrame::kViewFrameAnchorTopCenter,
  TopRight = AeccDbViewFrame::kViewFrameAnchorTopRight,
  MiddleLeft = AeccDbViewFrame::kViewFrameAnchorMiddleLeft,
  MiddleCenter = AeccDbViewFrame::kViewFrameAnchorMiddleCenter,
  MiddleRight = AeccDbViewFrame::kViewFrameAnchorMiddleRight,
  BottomLeft = AeccDbViewFrame::kViewFrameAnchorBottomLeft,
  BottomCenter = AeccDbViewFrame::kViewFrameAnchorBottomCenter,
  BottomRight = AeccDbViewFrame::kViewFrameAnchorBottomRight
}
Visual Basic
Public Enum ViewFrameLabelLocationType
  TopLeft = AeccDbViewFrame::kViewFrameAnchorTopLeft
  TopCenter = AeccDbViewFrame::kViewFrameAnchorTopCenter
  TopRight = AeccDbViewFrame::kViewFrameAnchorTopRight
  MiddleLeft = AeccDbViewFrame::kViewFrameAnchorMiddleLeft
  MiddleCenter = AeccDbViewFrame::kViewFrameAnchorMiddleCenter
  MiddleRight = AeccDbViewFrame::kViewFrameAnchorMiddleRight
  BottomLeft = AeccDbViewFrame::kViewFrameAnchorBottomLeft
  BottomCenter = AeccDbViewFrame::kViewFrameAnchorBottomCenter
  BottomRight = AeccDbViewFrame::kViewFrameAnchorBottomRight
End Enum


Autodesk::Civil::Land::WaterdropObjectType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Structs, Records, Enums > Autodesk::Civil::Land::WaterdropObjectType Enumeration
Autodesk::Civil::Land::WaterdropObjectType Enumeration
Collapse All
C#
public enum WaterdropObjectType {
  Polyline2D = AeccDbSurface::k2DPolyline,
  Polyline3D = AeccDbSurface::k3DPolyline
}
Visual Basic
Public Enum WaterdropObjectType
  Polyline2D = AeccDbSurface::k2DPolyline
  Polyline3D = AeccDbSurface::k3DPolyline
End Enum


Autodesk::Civil::PipeNetwork Namespace

The Autodesk::Civil::PipeNetwork namespace.

Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::PipeNetwork::DatabaseServices namespace.
Settings | The Autodesk::Civil::PipeNetwork::Settings namespace.
Topics
Topic | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Structs, Records, Enums
Struct, Record, Enum | Description
DistanceScaleFactorType | The Autodesk::Civil::PipeNetwork::DistanceScaleFactorType enumeration.
NetworkDefaultLayoutCommandType | The Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType enumeration.
PipeSectionLabelPlacementType | The Autodesk::Civil::PipeNetwork::PipeSectionLabelPlacementType enumeration.
StructureProfileLabelPlacementType | The Autodesk::Civil::PipeNetwork::StructureProfileLabelPlacementType enumeration.
Links
Namespaces, Topics, Structs, Records, Enums


Autodesk::Civil::PipeNetwork::DatabaseServices Namespace

The Autodesk::Civil::PipeNetwork::DatabaseServices namespace.

Namespaces
Namespace | Description
Styles | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles namespace.
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
Interference | Represents one location where elements of a pipe network interfere with each other.
InterferenceCheck | Determines where pipes and structures intersect or are too close to each other, and holds a collection of the resulting... more
Network | The container object used to associate pipes and structures that are part of the same pipe run or pipe network.... more
NetworkCatalogDef | The NetworkCatalogDef class. This class allows you to use a part catalog definition at runtime.
NetworkRule | Holds parameter collections for pipe and structure rules.
Part | A pipe network part, base class for Pipe and Structure classes.
PartDataField | An extensible field of part data.
PartDataList | The part data list associated with a PartDataField or SizeFilterField.
PartDataRange | Defines the range of valid data for a PartDataField.
PartDataRecord | A single data record for a Part object.
PartDef | A part definition for Pipe or Structure objects.
PartViewDef | Contains information about how a part is displayed.
Pipe | A pipe network part serving to move fluids from one point to another.
ProfileViewPart | Manages the graphic display of pipe network parts in profile view.
SectionPipeNetwork | Section view of a pipe network.
Structure | The drawing shape used to represent items such as manholes, catch basins, and headwalls used in utility networks. A Structure... more
Structs, Records, Enums
Struct, Record, Enum | Description
BoundingShapeType | Specifies bounding shapes for Part objects.
ConnectorPositionType | Specifies the connector position.
DomainType | Specifies a Part domain type.
FlowDirectionMethodType | Specifies the method that is used to determine the flow for a pipe.
FlowDirectionType | Specifies the current flow direction of a pipe.
HoldOnResizeType | Specifies the pipe behavior that occurs when the pipe is automatically resized.
PartCatalogDataType | Specifies the data type of the reserved data.
PartContextType | Specifies the context type, which corresponds to every property of a Part.
PartParamUsageType | Defines the usage of a part catalog parameter.
PartType | Specifies a Part type.
PipeSubEntityType | Specifies the subentity type of a pipe.
StructureControlSumpType | Specifies how a sump should be adjusted.
SweptShapeType | Specifies the swept shape of a pipe.
Links
Namespaces, Topics, Classes, Structs, Records, Enums


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Collapse All

The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
DataPartFamily | Part family data that is queried from the catalog.
InterferenceStyle | Defines how a pipe interference appears in plan, profile, section, and 3D view.
InterferenceStyleCollection | A collection of InterferenceStyle objects.
LabelStylesPipeRoot | Root object for pipe label styles.
LabelStylesStructureRoot | Root object for structure label styles.
NetworkRuleSetStyle | Base class for Pipe and Structure rule sets.
PartFamily | Each Part is a member of a PartFamily containing all size variations for a given part.
PartSize | Pipe network part size filter.
PartsList | List of pipe network parts (pipes and structures) used for a particular drawing.
PartsListCollection | A collection of PartsList objects.
PipeNetworkBandStyle | Band style in pipe network profile views.
PipeRuleSetStyle | A set of rules for pipe objects.
PipeRuleSetStyleCollection | A collection of PipeRuleSetStyle objects.
PipeStyle | Defines how a pipe appears in plan, profile, section, and 3D view.
PipeStyleCollection | A collection of PipeStyle objects.
PipeStyleOptionBase | Base interface for settings that define the appearance of the pipe in a 2D plan view. Used by PipeStylePlanOption and... more
PipeStylePlanOption | Settings that define the appearance of the pipe in a 2D plan view.
PipeStyleProfileOption | Settings that define the appearance of the pipe in a profile view.
SizeFilterField | Part size parameters from a SizeFilterRecord.
SizeFilterRecord | Lets users specify what part sizes they want to add into a part family.
StructureRuleSetStyle | A set of rules for structure objects.
StructureRuleSetStyleCollection | A collection of StructureRuleSetStyle objects.
StructureStyle | Specifies display properties for all structure objects in the drawing.
StructureStyleCollection | A collection of StructureStyle objects.
StructureStyleModelOption | Specifies the method that is used to define and draw the dimensions of the structure in model view.
StructureStyleOptionBase | Base class for StructureStyleProfileOption and StructureStyleSectionOption.
StructureStylePlanOption | Specifies the method that is used to define and draw the dimensions of the structure in 2D plan view.
StructureStyleProfileOption | Specifies the method that is used to define and draw the dimensions of the structure in profile view.
StructureStyleSectionOption | Specifies the method that is used to define and draw the dimensions of the structure in section view.
Structs, Records, Enums
Struct, Record, Enum | Description
InterferenceDisplayStyleType | Specifies the display style type when the Structure is displayed in plan/model/section view.
InterferenceModelSizeOptionType | Specifies the model size option.
InterferenceModelSizeType | Specifies the size of the sphere in model view.
InterferenceModelType | Specifies the type that will be used to visually identify interferences in model view.
PartDataSourceType | Specifies the source type of part data.
PipeCenterlineType | Specifies the method that will be used to define and draw the dimensions of the pipe centerline.
PipeCenterlineWidthType | Specifies the centerline width type.
PipeDisplayStylePlanType | Specifies the display style type when the pipe is displayed in plan view.
PipeDisplayStyleProfileType | Specifies the display style type when the pipe is displayed in profile view.
PipeDisplayStyleSectionType | Specifies the display style type when the pipe is displayed in section view.
PipeEndSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe ends.
PipeHatchStyleProfileType | Specifies the hatch display style type when the pipe is displayed in profile view.
PipeHatchType | Specifies which components of the pipe shape display a hatch pattern.
PipeNetworkDisplayStyleType | Defines ProfileViewPipeNetworkBandStyle display style type.
PipeStylePropertyType | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePropertyType enumeration.
PipeUserDefinedType | Specifies the user defined type.
PipeWallSizeType | Specifies which components of the pipe shape display a hatch pattern.
StructureDisplayStylePlanType | Specifies the display style type when the Structure is displayed in plan view.
StructureDisplayStyleProfileType | Specifies the display style type when the Structure is displayed in profile view.
StructureDisplayStyleSectionType | Specifies the display style type when the Structure is displayed in section view.
StructureInsertionLocation | Specifies the block insertion laction.
StructureModelViewOptionType | Specifies the dimensions of the structure in model view.
StructurePlanViewType | specifies whether the 2D plan view of the structure style is displayed as an outline of the 3D object, or... more
StructureSimpleSolidType | Specifies the simple shape options.
StructureSizeOptionsType | Specifies the size options type.
StructureStylePropertyType | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePropertyType enumeration.
StructureViewType | Specifies the method that will be used to define and draw the dimensions of the structure in profile or section... more
Links
Topics, Classes, Structs, Records, Enums


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes
Classes
Collapse All

The following table lists classes in this documentation.

Classes
Class | Description
DataPartFamily | Part family data that is queried from the catalog.
InterferenceStyle | Defines how a pipe interference appears in plan, profile, section, and 3D view.
InterferenceStyleCollection | A collection of InterferenceStyle objects.
LabelStylesPipeRoot | Root object for pipe label styles.
LabelStylesStructureRoot | Root object for structure label styles.
NetworkRuleSetStyle | Base class for Pipe and Structure rule sets.
PartFamily | Each Part is a member of a PartFamily containing all size variations for a given part.
PartSize | Pipe network part size filter.
PartsList | List of pipe network parts (pipes and structures) used for a particular drawing.
PartsListCollection | A collection of PartsList objects.
PipeNetworkBandStyle | Band style in pipe network profile views.
PipeRuleSetStyle | A set of rules for pipe objects.
PipeRuleSetStyleCollection | A collection of PipeRuleSetStyle objects.
PipeStyle | Defines how a pipe appears in plan, profile, section, and 3D view.
PipeStyleCollection | A collection of PipeStyle objects.
PipeStyleOptionBase | Base interface for settings that define the appearance of the pipe in a 2D plan view. Used by PipeStylePlanOption and... more
PipeStylePlanOption | Settings that define the appearance of the pipe in a 2D plan view.
PipeStyleProfileOption | Settings that define the appearance of the pipe in a profile view.
SizeFilterField | Part size parameters from a SizeFilterRecord.
SizeFilterRecord | Lets users specify what part sizes they want to add into a part family.
StructureRuleSetStyle | A set of rules for structure objects.
StructureRuleSetStyleCollection | A collection of StructureRuleSetStyle objects.
StructureStyle | Specifies display properties for all structure objects in the drawing.
StructureStyleCollection | A collection of StructureStyle objects.
StructureStyleModelOption | Specifies the method that is used to define and draw the dimensions of the structure in model view.
StructureStyleOptionBase | Base class for StructureStyleProfileOption and StructureStyleSectionOption.
StructureStylePlanOption | Specifies the method that is used to define and draw the dimensions of the structure in 2D plan view.
StructureStyleProfileOption | Specifies the method that is used to define and draw the dimensions of the structure in profile view.
StructureStyleSectionOption | Specifies the method that is used to define and draw the dimensions of the structure in section view.
Links
Classes


DataPartFamily Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class
DataPartFamily Class
Collapse All

Part family data that is queried from the catalog.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::DataPartFamily
C#
public class DataPartFamily;
Visual Basic
Public Class DataPartFamily
Links
DataPartFamily Properties, DataPartFamily Members, Class Hierarchy


DataPartFamily Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Members
DataPartFamily Members
Collapse All

The following tables list the members exposed by DataPartFamily.

Public Properties
Public Property | Description
BoundingShape | Gets the bounding shape type if the part is Structure, or it's undefined.
Description | Gets the part description
Domain | Gets the part domain
GUID | Gets the GUID of the part family
PartType | Gets the part type
SweptShape | Gets the swept shape type if the part is Pipe, or it's undefined.
Links
Public Properties


DataPartFamily Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Properties
DataPartFamily Properties
Collapse All

The properties of DataPartFamily are listed here.

Public Properties
Public Property | Description
BoundingShape | Gets the bounding shape type if the part is Structure, or it's undefined.
Description | Gets the part description
Domain | Gets the part domain
GUID | Gets the GUID of the part family
PartType | Gets the part type
SweptShape | Gets the swept shape type if the part is Pipe, or it's undefined.
Links
Public Properties


DataPartFamily::BoundingShape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Properties > DataPartFamily::BoundingShape Property
DataPartFamily::BoundingShape Property
Collapse All

Gets the bounding shape type if the part is Structure, or it's undefined.

C#
public BoundingShapeType BoundingShape;
Visual Basic
Public Property BoundingShape() As BoundingShapeType
Links
DataPartFamily Class, DataPartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


DataPartFamily::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Properties > DataPartFamily::Description Property
DataPartFamily::Description Property
Collapse All

Gets the part description

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
DataPartFamily Class, DataPartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


DataPartFamily::Domain Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Properties > DataPartFamily::Domain Property
DataPartFamily::Domain Property
Collapse All

Gets the part domain

C#
public DomainType Domain;
Visual Basic
Public Property Domain() As DomainType
Links
DataPartFamily Class, DataPartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


DataPartFamily::GUID Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Properties > DataPartFamily::GUID Property
DataPartFamily::GUID Property
Collapse All

Gets the GUID of the part family

C#
public System::String GUID;
Visual Basic
Public Property GUID() As System::String
Links
DataPartFamily Class, DataPartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


DataPartFamily::PartType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Properties > DataPartFamily::PartType Property
DataPartFamily::PartType Property
Collapse All

Gets the part type

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::PartType PartType;
Visual Basic
Public Property PartType() As Autodesk::Civil::PipeNetwork::DatabaseServices::PartType
Links
DataPartFamily Class, DataPartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


DataPartFamily::SweptShape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Properties > DataPartFamily::SweptShape Property
DataPartFamily::SweptShape Property
Collapse All

Gets the swept shape type if the part is Pipe, or it's undefined.

C#
public SweptShapeType SweptShape;
Visual Basic
Public Property SweptShape() As SweptShapeType
Links
DataPartFamily Class, DataPartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class
InterferenceStyle Class
Collapse All

Defines how a pipe interference appears in plan, profile, section, and 3D view.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbInterferenceStyle"))]
public class InterferenceStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbInterferenceStyle"))>
Public Class InterferenceStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Example
ObjectId intStyleId;
intStyleId = doc.Styles.InterferenceStyles.Add("Interference style 01");
InterferenceStyle oIntStyle = ts.GetObject(intStyleId, OpenMode.ForWrite) as InterferenceStyle;
// Draw a symbol of a violet X with circle with a specified
// drawing size at the points of intersection.
oIntStyle.GetDisplayStylePlan(InterferenceDisplayStyleType.Symbol).Visible = true;
ObjectId markerStyleId = oIntStyle.MarkerStyle;
MarkerStyle oMarkerStyle = ts.GetObject(markerStyleId, OpenMode.ForWrite) as MarkerStyle;
oMarkerStyle.MarkerType = MarkerDisplayType.UseCustomMarker;
oMarkerStyle.CustomMarkerStyle = CustomMarkerType.CustomMarkerX;
oMarkerStyle.CustomMarkerSuperimposeStyle = CustomMarkerSuperimposeType.Circle;
oMarkerStyle.MarkerDisplayStylePlan.Color = Color.FromColorIndex(ColorMethod.ByAci, 200);
oMarkerStyle.MarkerDisplayStylePlan.Visible = true;
oMarkerStyle.SizeType = MarkerSizeType.AbsoluteUnits;
oMarkerStyle.MarkerSize = 5.5;

// Hide any model display at intersection points.
oIntStyle.GetDisplayStyleModel(InterferenceDisplayStyleType.Solid).Visible = false;
Links
InterferenceStyle Methods, InterferenceStyle Properties, InterferenceStyle Members, Class Hierarchy


InterferenceStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Members
InterferenceStyle Members
Collapse All

The following tables list the members exposed by InterferenceStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that defines the model style for the component indicated by the specified InterferenceDisplayStyleType value.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified InterferenceDisplayStyleType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified InterferenceDisplayStyleType value.
Public Properties
Public Property | Description
AbsoluteModelSize | Gets or sets the absolute model size.
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
DrawingScaleModelSize | Gets or sets the drawing scale model size.
MarkerStyle | Gets or sets the marker style.
ModelOptions | Gets or sets the model options, TrueSolid or Sphere.
ModelSizeOptions | Gets or sets the model size options, UseAbsoluteUnits or UseDrawingScale.
ModelSizeType | Gets or sets the interference size type, SolidExtents or UserDefined.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


InterferenceStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Methods
InterferenceStyle Methods
Collapse All

The methods of InterferenceStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that defines the model style for the component indicated by the specified InterferenceDisplayStyleType value.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified InterferenceDisplayStyleType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified InterferenceDisplayStyleType value.
Links
Public Methods


InterferenceStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Methods > InterferenceStyle::GetDisplayStyleModel Method
InterferenceStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that defines the model style for the component indicated by the specified InterferenceDisplayStyleType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    InterferenceDisplayStyleType component
);
Visual Basic
Public Function GetDisplayStyleModel(
    component As InterferenceDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
component | The interference display component to get.
Links
InterferenceStyle Class, InterferenceStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Methods > InterferenceStyle::GetDisplayStylePlan Method
InterferenceStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified InterferenceDisplayStyleType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    InterferenceDisplayStyleType component
);
Visual Basic
Public Function GetDisplayStylePlan(
    component As InterferenceDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
component | The interference display component to get.
Links
InterferenceStyle Class, InterferenceStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Methods > InterferenceStyle::GetDisplayStyleSection Method
InterferenceStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle object that defines the Section style for the component indicated by the specified InterferenceDisplayStyleType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection(
    InterferenceDisplayStyleType component
);
Visual Basic
Public Function GetDisplayStyleSection(
    component As InterferenceDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
component | The interference display component to get.
Links
InterferenceStyle Class, InterferenceStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Properties
InterferenceStyle Properties
Collapse All

The properties of InterferenceStyle are listed here.

Public Properties
Public Property | Description
AbsoluteModelSize | Gets or sets the absolute model size.
DrawingScaleModelSize | Gets or sets the drawing scale model size.
MarkerStyle | Gets or sets the marker style.
ModelOptions | Gets or sets the model options, TrueSolid or Sphere.
ModelSizeOptions | Gets or sets the model size options, UseAbsoluteUnits or UseDrawingScale.
ModelSizeType | Gets or sets the interference size type, SolidExtents or UserDefined.
Links
Public Properties


InterferenceStyle::AbsoluteModelSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Properties > InterferenceStyle::AbsoluteModelSize Property
InterferenceStyle::AbsoluteModelSize Property
Collapse All

Gets or sets the absolute model size.

C#
public double AbsoluteModelSize;
Visual Basic
Public Property AbsoluteModelSize() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval [0.0, 1.0E24].
Links
InterferenceStyle Class, InterferenceStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyle::DrawingScaleModelSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Properties > InterferenceStyle::DrawingScaleModelSize Property
InterferenceStyle::DrawingScaleModelSize Property
Collapse All

Gets or sets the drawing scale model size.

C#
public double DrawingScaleModelSize;
Visual Basic
Public Property DrawingScaleModelSize() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval [0.0004, 393.7008].
Links
InterferenceStyle Class, InterferenceStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyle::MarkerStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Properties > InterferenceStyle::MarkerStyle Property
InterferenceStyle::MarkerStyle Property
Collapse All

Gets or sets the marker style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MarkerStyle;
Visual Basic
Public Property MarkerStyle() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.MarkerStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the ObjectId is null, invalid or not a roadway mark style id.
Links
InterferenceStyle Class, InterferenceStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyle::ModelOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Properties > InterferenceStyle::ModelOptions Property
InterferenceStyle::ModelOptions Property
Collapse All

Gets or sets the model options, TrueSolid or Sphere.

C#
public InterferenceModelType ModelOptions;
Visual Basic
Public Property ModelOptions() As InterferenceModelType
Links
InterferenceStyle Class, InterferenceStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyle::ModelSizeOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Properties > InterferenceStyle::ModelSizeOptions Property
InterferenceStyle::ModelSizeOptions Property
Collapse All

Gets or sets the model size options, UseAbsoluteUnits or UseDrawingScale.

C#
public InterferenceModelSizeOptionType ModelSizeOptions;
Visual Basic
Public Property ModelSizeOptions() As InterferenceModelSizeOptionType
Links
InterferenceStyle Class, InterferenceStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyle::ModelSizeType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Properties > InterferenceStyle::ModelSizeType Property
InterferenceStyle::ModelSizeType Property
Collapse All

Gets or sets the interference size type, SolidExtents or UserDefined.

C#
public InterferenceModelSizeType ModelSizeType;
Visual Basic
Public Property ModelSizeType() As InterferenceModelSizeType
Links
InterferenceStyle Class, InterferenceStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


InterferenceStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class
InterferenceStyleCollection Class
Collapse All

A collection of InterferenceStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyleCollection
C#
public class InterferenceStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class InterferenceStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
InterferenceStyleCollection Methods, InterferenceStyleCollection Members, Class Hierarchy


InterferenceStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class > InterferenceStyleCollection Members
InterferenceStyleCollection Members
Collapse All

The following tables list the members exposed by InterferenceStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


InterferenceStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class > InterferenceStyleCollection Methods
InterferenceStyleCollection Methods
Collapse All

The methods of InterferenceStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


InterferenceStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class > InterferenceStyleCollection Methods > InterferenceStyleCollection::Add Method
InterferenceStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
InterferenceStyleCollection Class, InterferenceStyleCollection Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


LabelStylesPipeRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class
LabelStylesPipeRoot Class
Collapse All

Root object for pipe label styles.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesPipeRoot
C#
public class LabelStylesPipeRoot : Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode;
Visual Basic
Public Class LabelStylesPipeRoot
Inherits Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
Links
LabelStylesPipeRoot Properties, LabelStylesPipeRoot Members, Class Hierarchy


LabelStylesPipeRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class > LabelStylesPipeRoot Members
LabelStylesPipeRoot Members
Collapse All

The following tables list the members exposed by LabelStylesPipeRoot.

Public Properties
Public Property | Description
CrossSectionLabelStyles | Gets the collection of all pipe Cross Section label styles in the database.
DefaultLabelStyle | Gets the default vaules of label styles.
PlanProfileLabelStyles | Gets the collection of all pipe Plan Profile label styles in the database.
Links
Public Properties


LabelStylesPipeRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class > LabelStylesPipeRoot Properties
LabelStylesPipeRoot Properties
Collapse All

The properties of LabelStylesPipeRoot are listed here.

Public Properties
Public Property | Description
CrossSectionLabelStyles | Gets the collection of all pipe Cross Section label styles in the database.
PlanProfileLabelStyles | Gets the collection of all pipe Plan Profile label styles in the database.
Links
Public Properties


LabelStylesPipeRoot::CrossSectionLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class > LabelStylesPipeRoot Properties > LabelStylesPipeRoot::CrossSectionLabelStyles Property
LabelStylesPipeRoot::CrossSectionLabelStyles Property
Collapse All

Gets the collection of all pipe Cross Section label styles in the database.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection CrossSectionLabelStyles;
Visual Basic
Public Property CrossSectionLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesPipeRoot Class, LabelStylesPipeRoot Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


LabelStylesPipeRoot::PlanProfileLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class > LabelStylesPipeRoot Properties > LabelStylesPipeRoot::PlanProfileLabelStyles Property
LabelStylesPipeRoot::PlanProfileLabelStyles Property
Collapse All

Gets the collection of all pipe Plan Profile label styles in the database.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection PlanProfileLabelStyles;
Visual Basic
Public Property PlanProfileLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesPipeRoot Class, LabelStylesPipeRoot Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


LabelStylesStructureRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesStructureRoot Class
LabelStylesStructureRoot Class
Collapse All

Root object for structure label styles.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesStructureRoot
C#
public class LabelStylesStructureRoot : Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode;
Visual Basic
Public Class LabelStylesStructureRoot
Inherits Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
Links
LabelStylesStructureRoot Properties, LabelStylesStructureRoot Members, Class Hierarchy


LabelStylesStructureRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesStructureRoot Class > LabelStylesStructureRoot Members
LabelStylesStructureRoot Members
Collapse All

The following tables list the members exposed by LabelStylesStructureRoot.

Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
LabelStyles | Gets the collection of all structure label styles in the database.
Links
Public Properties


LabelStylesStructureRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesStructureRoot Class > LabelStylesStructureRoot Properties
LabelStylesStructureRoot Properties
Collapse All

The properties of LabelStylesStructureRoot are listed here.

Public Properties
Public Property | Description
LabelStyles | Gets the collection of all structure label styles in the database.
Links
Public Properties


LabelStylesStructureRoot::LabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesStructureRoot Class > LabelStylesStructureRoot Properties > LabelStylesStructureRoot::LabelStyles Property
LabelStylesStructureRoot::LabelStyles Property
Collapse All

Gets the collection of all structure label styles in the database.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection LabelStyles;
Visual Basic
Public Property LabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesStructureRoot Class, LabelStylesStructureRoot Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


NetworkRuleSetStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class
NetworkRuleSetStyle Class
Collapse All

Base class for Pipe and Structure rule sets.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::NetworkRuleSetStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkPartRules"))]
public class NetworkRuleSetStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkPartRules"))>
Public Class NetworkRuleSetStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
NetworkRuleSetStyle Methods, NetworkRuleSetStyle Properties, NetworkRuleSetStyle Members, Class Hierarchy


NetworkRuleSetStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Members
NetworkRuleSetStyle Members
Collapse All

The following tables list the members exposed by NetworkRuleSetStyle.

Public Methods
Public Method | Description
CloneAndAddRule | Add a copy of input source rule to rule set.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetRuleIds | Gets the objectId collection of all rules belonging to this network rule set.
RemoveAllRules | Remove all the rules belonging to the rule set.
RemoveRule | Remove the specified rule from rule set.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RulesCount | Gets the count of all rules belonging to this network rule set.
Links
Public Methods, Public Properties


NetworkRuleSetStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Methods
NetworkRuleSetStyle Methods
Collapse All

The methods of NetworkRuleSetStyle are listed here.

Public Methods
Public Method | Description
CloneAndAddRule | Add a copy of input source rule to rule set.
GetRuleIds | Gets the objectId collection of all rules belonging to this network rule set.
RemoveAllRules | Remove all the rules belonging to the rule set.
RemoveRule | Remove the specified rule from rule set.
Links
Public Methods


NetworkRuleSetStyle::CloneAndAddRule Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Methods > NetworkRuleSetStyle::CloneAndAddRule Method
NetworkRuleSetStyle::CloneAndAddRule Method
Collapse All

Add a copy of input source rule to rule set.

C#
public CloneAndAddRule(
    Autodesk::AutoCAD::DatabaseServices::ObjectId sourceRuleId
);
Visual Basic
Public Sub CloneAndAddRule(
    sourceRuleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
sourceRuleId | ObjectId of source rule.
Remarks

the source rule will not be added into current rule set, instead a copy will be added. OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.NetworkRule

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when sourceRuleId is not an objectId of network rule.
Links
NetworkRuleSetStyle Class, NetworkRuleSetStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


NetworkRuleSetStyle::GetRuleIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Methods > NetworkRuleSetStyle::GetRuleIds Method
NetworkRuleSetStyle::GetRuleIds Method
Collapse All

Gets the objectId collection of all rules belonging to this network rule set.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetRuleIds();
Visual Basic
Public Function GetRuleIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.NetworkRule

Links
NetworkRuleSetStyle Class, NetworkRuleSetStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


NetworkRuleSetStyle::RemoveAllRules Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Methods > NetworkRuleSetStyle::RemoveAllRules Method
NetworkRuleSetStyle::RemoveAllRules Method
Collapse All

Remove all the rules belonging to the rule set.

C#
public RemoveAllRules();
Visual Basic
Public Sub RemoveAllRules()
Links
NetworkRuleSetStyle Class, NetworkRuleSetStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


NetworkRuleSetStyle::RemoveRule Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Methods > NetworkRuleSetStyle::RemoveRule Method
NetworkRuleSetStyle::RemoveRule Method
Collapse All

Remove the specified rule from rule set.

C#
public RemoveRule(
    Autodesk::AutoCAD::DatabaseServices::ObjectId ruleId
);
Visual Basic
Public Sub RemoveRule(
    ruleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
ruleId | ObjectId of rule which is to be removed.
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.NetworkRule

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when ruleId is invalid.
Links
NetworkRuleSetStyle Class, NetworkRuleSetStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


NetworkRuleSetStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Properties
NetworkRuleSetStyle Properties
Collapse All

The properties of NetworkRuleSetStyle are listed here.

Public Properties
Public Property | Description
RulesCount | Gets the count of all rules belonging to this network rule set.
Links
Public Properties


NetworkRuleSetStyle::RulesCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Properties > NetworkRuleSetStyle::RulesCount Property
NetworkRuleSetStyle::RulesCount Property
Collapse All

Gets the count of all rules belonging to this network rule set.

C#
public int RulesCount;
Visual Basic
Public Property RulesCount() As Integer
Links
NetworkRuleSetStyle Class, NetworkRuleSetStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class
PartFamily Class
Collapse All

Each Part is a member of a PartFamily containing all size variations for a given part.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartFamily
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPartFamilyItem"))]
public class PartFamily : Autodesk::Civil::DatabaseServices::DBObject;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPartFamilyItem"))>
Public Class PartFamily
Inherits Autodesk::Civil::DatabaseServices::DBObject
Links
PartFamily Methods, PartFamily Properties, PartFamily Members, Class Hierarchy


PartFamily Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Members
PartFamily Members
Collapse All

The following tables list the members exposed by PartFamily.

Public Methods
Public Method | Description
AddPartSize | Adds part one or more part sizes to this part family.
RemovePartSize | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BoundingShape | Gets the bounding shape type if the part is Structure, or it's undefined.
default | Gets the object id of the part size with the given description under the part family.
Description | Gets the part family description
Document | Gets the Document associated with the DBObject. Not implemented.
Domain | Gets the part domain
GUID | Gets the GUID of the part family
Name | Gets or sets the name.
PartSizeCount | Gets count of part sizes under this part family
PartSizeFilter | Gets the part size filter record through which you can set the corresponding properties to specify what part sizes you... more
PartType | Gets the part type
SweptShape | Gets the swept shape type if the part is Pipe, or it's undefined.
Links
Public Methods, Public Properties


PartFamily Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Methods
PartFamily Methods
Collapse All

The methods of PartFamily are listed here.

Public Methods
Public Method | Description
AddPartSize | Adds part one or more part sizes to this part family.
RemovePartSize | Overloaded
Links
Public Methods


PartFamily::AddPartSize Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Methods > PartFamily::AddPartSize Method
PartFamily::AddPartSize Method
Collapse All

Adds part one or more part sizes to this part family.

C#
public AddPartSize(
    ref SizeFilterRecord partSizeFilter
);
Visual Basic
Public Sub AddPartSize(
    ByRef partSizeFilter As SizeFilterRecord
)
Parameters
Parameters | Description
partSizeTemplate | Specifies the filter part size property collection to tell what part sizes to add
Exceptions
Exceptions | Description
System::ArgumentException | Thrown when the input partSizeFilter isn't for the part family
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


RemovePartSize Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Methods > RemovePartSize Method
RemovePartSize Method
Collapse All

Overloaded

Overload List
Method | Description
PartFamily::RemovePartSize (Autodesk::AutoCAD::DatabaseServices::ObjectId) | Remove a part size of given object id from this parts family.
PartFamily::RemovePartSize (int) | Remove a part size at given index from this parts family.


PartFamily::RemovePartSize Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Methods > RemovePartSize Method > PartFamily::RemovePartSize Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
PartFamily::RemovePartSize Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Remove a part size of given object id from this parts family.

C#
public RemovePartSize(
    Autodesk::AutoCAD::DatabaseServices::ObjectId partSizeId
);
Visual Basic
Public Sub RemovePartSize(
    partSizeId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
partSizeId | Specifies the object id of the part size to remove
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily::RemovePartSize Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Methods > RemovePartSize Method > PartFamily::RemovePartSize Method (int)
PartFamily::RemovePartSize Method (int)
Collapse All

Remove a part size at given index from this parts family.

C#
public RemovePartSize(
    int index
);
Visual Basic
Public Sub RemovePartSize(
    index As Integer
)
Parameters
Parameters | Description
partSizeId | Specifies the index of the part size to remove
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties
PartFamily Properties
Collapse All

The properties of PartFamily are listed here.

Public Properties
Public Property | Description
BoundingShape | Gets the bounding shape type if the part is Structure, or it's undefined.
default | Gets the object id of the part size with the given description under the part family.
Description | Gets the part family description
Domain | Gets the part domain
GUID | Gets the GUID of the part family
PartSizeCount | Gets count of part sizes under this part family
PartSizeFilter | Gets the part size filter record through which you can set the corresponding properties to specify what part sizes you... more
PartType | Gets the part type
SweptShape | Gets the swept shape type if the part is Pipe, or it's undefined.
Links
Public Properties


PartFamily::BoundingShape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties > PartFamily::BoundingShape Property
PartFamily::BoundingShape Property
Collapse All

Gets the bounding shape type if the part is Structure, or it's undefined.

C#
public BoundingShapeType BoundingShape;
Visual Basic
Public Property BoundingShape() As BoundingShapeType
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties > PartFamily::default Property
PartFamily::default Property
Collapse All

Gets the object id of the part size with the given description under the part family.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId default;
Visual Basic
Public Property default() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when cannot find the specified part family
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties > PartFamily::Description Property
PartFamily::Description Property
Collapse All

Gets the part family description

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily::Domain Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties > PartFamily::Domain Property
PartFamily::Domain Property
Collapse All

Gets the part domain

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType Domain;
Visual Basic
Public Property Domain() As Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily::GUID Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties > PartFamily::GUID Property
PartFamily::GUID Property
Collapse All

Gets the GUID of the part family

C#
public System::String GUID;
Visual Basic
Public Property GUID() As System::String
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily::PartSizeCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties > PartFamily::PartSizeCount Property
PartFamily::PartSizeCount Property
Collapse All

Gets count of part sizes under this part family

C#
public int PartSizeCount;
Visual Basic
Public Property PartSizeCount() As Integer
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily::PartSizeFilter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties > PartFamily::PartSizeFilter Property
PartFamily::PartSizeFilter Property
Collapse All

Gets the part size filter record through which you can set the corresponding properties to specify what part sizes you want to have under this part family.

C#
public SizeFilterRecord PartSizeFilter;
Visual Basic
Public Property PartSizeFilter() As SizeFilterRecord
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily::PartType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties > PartFamily::PartType Property
PartFamily::PartType Property
Collapse All

Gets the part type

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::PartType PartType;
Visual Basic
Public Property PartType() As Autodesk::Civil::PipeNetwork::DatabaseServices::PartType
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartFamily::SweptShape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties > PartFamily::SweptShape Property
PartFamily::SweptShape Property
Collapse All

Gets the swept shape type if the part is Pipe, or it's undefined.

C#
public SweptShapeType SweptShape;
Visual Basic
Public Property SweptShape() As SweptShapeType
Links
PartFamily Class, PartFamily Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartSize Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class
PartSize Class
Collapse All

Pipe network part size filter.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartSize
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPartSizeFilter"))]
public class PartSize : Autodesk::Civil::DatabaseServices::DBObject;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPartSizeFilter"))>
Public Class PartSize
Inherits Autodesk::Civil::DatabaseServices::DBObject
Remarks

To edit the value of a PartDataField in a PartSize.SizeDataRecord, you must open the PartSize for write, get a reference to the object's SizeDataRecord property (type PartDataRecord), modify the PartDatafield value, and then re-set the PartSize object's PartData. See the example code.

Example
[CommandMethod("testSizeDataRecord")]
public void testSizeDataRecord () {
   Transaction ts = Application.DocumentManager.MdiActiveDocument.Database.TransactionManager.StartTransaction();

   PartsListCollection col = CivilApplication.ActiveDocument.Styles.PartsListSet;
   PartsList partList1 = ts.GetObject(col["Standard"], OpenMode.ForWrite) as PartsList;
   PartFamily partFamily = ts.GetObject(partList1["Concrete Pipe"], OpenMode.ForWrite) as PartFamily;
   PartSize partSize = ts.GetObject(partFamily["12 inch Concrete Pipe"], OpenMode.ForWrite) as PartSize;

   // Save a reference to the SizeDataRecord to restore later.
   PartDataRecord record = partSize.SizeDataRecord;
   PartDataField field = record.GetDataFieldBy(PartContextType.MinCurveRadius);
   field.Value = 1.0;
   double newVal = ( double )field.Value;

   // Re-set the SizeDataRecord property.  The data will not be saved without this step.
   partSize.SizeDataRecord = record;

   ts.Commit();
}
Links
PartSize Properties, PartSize Members, Class Hierarchy


PartSize Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Members
PartSize Members
Collapse All

The following tables list the members exposed by PartSize.

Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MaterialStyleId | Gets or sets the object id of the material style to apply side by side with the part size.
Name | Gets or sets the name.
PartStyleId | Gets or sets the object id of the part style to apply side by side with the part size.
PayItems | Gets or Sets the payitem list.
RulesStyleId | Gets or sets the object id of the rule set style to apply side by side with the part size.... more
SizeDataRecord | Gets the serialized catalog part size record.
Links
Public Properties


PartSize Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Properties
PartSize Properties
Collapse All

The properties of PartSize are listed here.

Public Properties
Public Property | Description
MaterialStyleId | Gets or sets the object id of the material style to apply side by side with the part size.
PartStyleId | Gets or sets the object id of the part style to apply side by side with the part size.
PayItems | Gets or Sets the payitem list.
RulesStyleId | Gets or sets the object id of the rule set style to apply side by side with the part size.... more
SizeDataRecord | Gets the serialized catalog part size record.
Links
Public Properties


PartSize::MaterialStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Properties > PartSize::MaterialStyleId Property
PartSize::MaterialStyleId Property
Collapse All

Gets or sets the object id of the material style to apply side by side with the part size.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MaterialStyleId;
Visual Basic
Public Property MaterialStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
PartSize Class, PartSize Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartSize::PartStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Properties > PartSize::PartStyleId Property
PartSize::PartStyleId Property
Collapse All

Gets or sets the object id of the part style to apply side by side with the part size.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PartStyleId;
Visual Basic
Public Property PartStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
PartSize Class, PartSize Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartSize::PayItems Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Properties > PartSize::PayItems Property
PartSize::PayItems Property
Collapse All

Gets or Sets the payitem list.

C#
public array<System::String^> PayItems;
Visual Basic
Public Property PayItems() As array<System::String^>
Remarks

We can set the pay item list to "none" as UI did with an empty String array.

Links
PartSize Class, PartSize Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartSize::RulesStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Properties > PartSize::RulesStyleId Property
PartSize::RulesStyleId Property
Collapse All

Gets or sets the object id of the rule set style to apply side by side with the part size.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId RulesStyleId;
Visual Basic
Public Property RulesStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
PartSize Class, PartSize Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartSize::SizeDataRecord Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Properties > PartSize::SizeDataRecord Property
PartSize::SizeDataRecord Property
Collapse All

Gets the serialized catalog part size record.

C#
public PartDataRecord SizeDataRecord;
Visual Basic
Public Property SizeDataRecord() As PartDataRecord
Links
PartSize Class, PartSize Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartsList Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class
PartsList Class
Collapse All

List of pipe network parts (pipes and structures) used for a particular drawing.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsList
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPartList"))]
public class PartsList : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPartList"))>
Public Class PartsList
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
PartsList Methods, PartsList Properties, PartsList Members, Class Hierarchy


PartsList Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Members
PartsList Members
Collapse All

The following tables list the members exposed by PartsList.

Public Methods
Public Method | Description
AddPartFamilyByDescription | Adds a part family referenced by unique description of current active catalog to this parts list.
AddPartFamilyByGuid | Adds a part family referenced by unique GUID of current active catalog to this parts list. A parts list can... more
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetAvailablePartFamilies | Gets available part families of the current active catalog.
GetPartFamilyIdsByDomain | Gets the object id collection of part families of specified domain under this parts list.
RemovePartFamily | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the object id of the part family from this parts list by given description. Returns null object id if... more
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PartFamilyCount | Gets the count of part families under this parts list.
Links
Public Methods, Public Properties


PartsList Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods
PartsList Methods
Collapse All

The methods of PartsList are listed here.

Public Methods
Public Method | Description
AddPartFamilyByDescription | Adds a part family referenced by unique description of current active catalog to this parts list.
AddPartFamilyByGuid | Adds a part family referenced by unique GUID of current active catalog to this parts list. A parts list can... more
GetAvailablePartFamilies | Gets available part families of the current active catalog.
GetPartFamilyIdsByDomain | Gets the object id collection of part families of specified domain under this parts list.
RemovePartFamily | Overloaded
Links
Public Methods


PartsList::AddPartFamilyByDescription Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods > PartsList::AddPartFamilyByDescription Method
PartsList::AddPartFamilyByDescription Method
Collapse All

Adds a part family referenced by unique description of current active catalog to this parts list.

C#
public AddPartFamilyByDescription(
    Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType domain,
    ref System::String description
);
Visual Basic
Public Sub AddPartFamilyByDescription(
    domain As Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType,
    ByRef description As System::String
)
Parameters
Parameters | Description
domain | Specifies the domain of the part family to add
desc | Specifies the description of the part family to add, the decription string should be unique within a given catalog
Links
PartsList Class, PartsList Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartsList::AddPartFamilyByGuid Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods > PartsList::AddPartFamilyByGuid Method
PartsList::AddPartFamilyByGuid Method
Collapse All

Adds a part family referenced by unique GUID of current active catalog to this parts list. A parts list can only hold parts from the same catalog.

C#
public AddPartFamilyByGuid(
    Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType domain,
    ref System::String guid
);
Visual Basic
Public Sub AddPartFamilyByGuid(
    domain As Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType,
    ByRef guid As System::String
)
Parameters
Parameters | Description
domain | Specifies the domain of the part family to add
guid | Specifies the GUID of the part family to add
Links
PartsList Class, PartsList Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartsList::GetAvailablePartFamilies Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods > PartsList::GetAvailablePartFamilies Method
PartsList::GetAvailablePartFamilies Method
Collapse All

Gets available part families of the current active catalog.

C#
public array<Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::DataPartFamily^> GetAvailablePartFamilies(
    Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType domain
);
Visual Basic
Public Function GetAvailablePartFamilies(
    domain As Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType
) As array<Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::DataPartFamily^>
Parameters
Parameters | Description
partFamilyId | Specifies the object id of the part family to delete
Links
PartsList Class, PartsList Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartsList::GetPartFamilyIdsByDomain Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods > PartsList::GetPartFamilyIdsByDomain Method
PartsList::GetPartFamilyIdsByDomain Method
Collapse All

Gets the object id collection of part families of specified domain under this parts list.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetPartFamilyIdsByDomain(
    Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType domain
);
Visual Basic
Public Function GetPartFamilyIdsByDomain(
    domain As Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
domain | Specifies the part domain (Pipe or Structure)
Example
// From the part list, looking at only those part families
// that are pipes, print all the individual parts, plus
// some information about each part.
ObjectIdCollection pipeFamilyCollection = oPartsList.GetPartFamilyIdsByDomain(DomainType.Pipe);
ed.WriteMessage("  Pipesn  =====n");
foreach ( ObjectId objIdPfa in pipeFamilyCollection ) {

   PartFamily oPartFamily = ts.GetObject(objIdPfa, OpenMode.ForWrite) as PartFamily;
   if ( oPartFamily.Domain == DomainType.Pipe ) {
       ed.WriteMessage("  Family: {0}n", oPartFamily.Name);
       SizeFilterRecord oSizeFilterRecord = oPartFamily.PartSizeFilter;
       SizeFilterField SweptShape = oSizeFilterRecord.GetParamByContextAndIndex(PartContextType.SweptShape, 0);
       SizeFilterField MinCurveRadius = oSizeFilterRecord.GetParamByContextAndIndex(PartContextType.MinCurveRadius, 0);
       //SizeFilterField StructPipeWallThickness;
       SizeFilterField FlowAnalysisManning = oSizeFilterRecord.GetParamByContextAndIndex(PartContextType.FlowAnalysisManning, 0);
       SizeFilterField m_Material = oSizeFilterRecord.GetParamByContextAndIndex(PartContextType.Material, 0);
       // SizeFilterField PipeInnerDiameter = oSizeFilterRecord.GetParamByContextAndIndex(PartContextType.PipeInnerDiameter, 0);

       ed.WriteMessage("  {0}: {1}, {2}: {3}, {4}: {5} {6}: {7}n",
           SweptShape.Description, SweptShape.Value,
           MinCurveRadius.Description, MinCurveRadius.Value,
           FlowAnalysisManning.Description, FlowAnalysisManning.Value,
           m_Material.Description, m_Material.Value

           );
   }
}
Links
PartsList Class, PartsList Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


RemovePartFamily Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods > RemovePartFamily Method
RemovePartFamily Method
Collapse All

Overloaded

Overload List
Method | Description
PartsList::RemovePartFamily (Autodesk::AutoCAD::DatabaseServices::ObjectId) | Remove a part family referenced by its object id from this parts list
PartsList::RemovePartFamily (System::String^) | Remove a part family referenced by unique description from this parts list.


PartsList::RemovePartFamily Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods > RemovePartFamily Method > PartsList::RemovePartFamily Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
PartsList::RemovePartFamily Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Remove a part family referenced by its object id from this parts list

C#
public RemovePartFamily(
    Autodesk::AutoCAD::DatabaseServices::ObjectId partFamilyId
);
Visual Basic
Public Sub RemovePartFamily(
    partFamilyId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
partFamilyId | Specifies the object id of the part family to delete
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when you want to remove the NULL structure part family
Links
PartsList Class, PartsList Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartsList::RemovePartFamily Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods > RemovePartFamily Method > PartsList::RemovePartFamily Method (System::String^)
PartsList::RemovePartFamily Method (System::String^)
Collapse All

Remove a part family referenced by unique description from this parts list.

C#
public RemovePartFamily(
    ref System::String description
);
Visual Basic
Public Sub RemovePartFamily(
    ByRef description As System::String
)
Parameters
Parameters | Description
desc | Specifies the description of the part family to delete
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when you want to remove the NULL structure part family
Links
PartsList Class, PartsList Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartsList Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Properties
PartsList Properties
Collapse All

The properties of PartsList are listed here.

Public Properties
Public Property | Description
default | Gets the object id of the part family from this parts list by given description. Returns null object id if... more
PartFamilyCount | Gets the count of part families under this parts list.
Links
Public Properties


PartsList::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Properties > PartsList::default Property
PartsList::default Property
Collapse All

Gets the object id of the part family from this parts list by given description. Returns null object id if the part family doesn't exist.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId default;
Visual Basic
Public Property default() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
desc | Specifies the description of the part family to get
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.Styles.PartFamily

Links
PartsList Class, PartsList Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartsList::PartFamilyCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Properties > PartsList::PartFamilyCount Property
PartsList::PartFamilyCount Property
Collapse All

Gets the count of part families under this parts list.

C#
public int PartFamilyCount;
Visual Basic
Public Property PartFamilyCount() As Integer
Links
PartsList Class, PartsList Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PartsListCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class
PartsListCollection Class
Collapse All

A collection of PartsList objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsListCollection
C#
public class PartsListCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class PartsListCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
PartsListCollection Methods, PartsListCollection Members, Class Hierarchy


PartsListCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class > PartsListCollection Members
PartsListCollection Members
Collapse All

The following tables list the members exposed by PartsListCollection.

Public Methods
Public Method | Description
Add | Create a new parts list named by the input string. The new parts list will automatically have the null structure... more
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


PartsListCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class > PartsListCollection Methods
PartsListCollection Methods
Collapse All

The methods of PartsListCollection are listed here.

Public Methods
Public Method | Description
Add | Create a new parts list named by the input string. The new parts list will automatically have the null structure... more
Links
Public Methods


PartsListCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class > PartsListCollection Methods > PartsListCollection::Add Method
PartsListCollection::Add Method
Collapse All

Create a new parts list named by the input string. The new parts list will automatically have the null structure part.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
partsListName | Specifies the name of the new parts list. If it's empty, a dynamically generated name will be applied.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name users specifies is already used
Links
PartsListCollection Class, PartsListCollection Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeNetworkBandStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class
PipeNetworkBandStyle Class
Collapse All

Band style in pipe network profile views.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeNetworkBandStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphProfileStylePipeNetworkBand"))]
public class PipeNetworkBandStyle : Autodesk::Civil::DatabaseServices::Styles::BandStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphProfileStylePipeNetworkBand"))>
Public Class PipeNetworkBandStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::BandStyle
Links
PipeNetworkBandStyle Methods, PipeNetworkBandStyle Properties, PipeNetworkBandStyle Members, Class Hierarchy


PipeNetworkBandStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Members
PipeNetworkBandStyle Members
Collapse All

The following tables list the members exposed by PipeNetworkBandStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the PipeNetwork component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
PipeLabelStyleId | Gets the band profile data pipe label style id.
PipeTickStyle | Gets the band profile data pipe tick style.
StructureLabelStyleId | Gets the band profile data structure label style id.
StructureTickStyle | Gets the band profile data structure tick style.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.
Links
Public Methods, Public Properties


PipeNetworkBandStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Methods
PipeNetworkBandStyle Methods
Collapse All

The methods of PipeNetworkBandStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the PipeNetwork component.
Links
Public Methods


PipeNetworkBandStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Methods > PipeNetworkBandStyle::GetDisplayStylePlan Method
PipeNetworkBandStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the PipeNetwork component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    PipeNetworkDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As PipeNetworkDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
PipeNetworkBandStyle Class, PipeNetworkBandStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeNetworkBandStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Properties
PipeNetworkBandStyle Properties
Collapse All

The properties of PipeNetworkBandStyle are listed here.

Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
PipeLabelStyleId | Gets the band profile data pipe label style id.
PipeTickStyle | Gets the band profile data pipe tick style.
StructureLabelStyleId | Gets the band profile data structure label style id.
StructureTickStyle | Gets the band profile data structure tick style.
TitleTextLabelStyleId | Gets the band profile data title text label style.
Links
Public Properties


PipeNetworkBandStyle::BandType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Properties > PipeNetworkBandStyle::BandType Property
PipeNetworkBandStyle::BandType Property
Collapse All

Gets the BandStyleType enum value that specifies the type of data band data.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandStyleType BandType;
Visual Basic
Public Property BandType() As Autodesk::Civil::DatabaseServices::Styles::BandStyleType
Links
PipeNetworkBandStyle Class, PipeNetworkBandStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeNetworkBandStyle::PipeLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Properties > PipeNetworkBandStyle::PipeLabelStyleId Property
PipeNetworkBandStyle::PipeLabelStyleId Property
Collapse All

Gets the band profile data pipe label style id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PipeLabelStyleId;
Visual Basic
Public Property PipeLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
PipeNetworkBandStyle Class, PipeNetworkBandStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeNetworkBandStyle::PipeTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Properties > PipeNetworkBandStyle::PipeTickStyle Property
PipeNetworkBandStyle::PipeTickStyle Property
Collapse All

Gets the band profile data pipe tick style.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle PipeTickStyle;
Visual Basic
Public Property PipeTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
PipeNetworkBandStyle Class, PipeNetworkBandStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeNetworkBandStyle::StructureLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Properties > PipeNetworkBandStyle::StructureLabelStyleId Property
PipeNetworkBandStyle::StructureLabelStyleId Property
Collapse All

Gets the band profile data structure label style id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StructureLabelStyleId;
Visual Basic
Public Property StructureLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
PipeNetworkBandStyle Class, PipeNetworkBandStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeNetworkBandStyle::StructureTickStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Properties > PipeNetworkBandStyle::StructureTickStyle Property
PipeNetworkBandStyle::StructureTickStyle Property
Collapse All

Gets the band profile data structure tick style.

C#
public Autodesk::Civil::DatabaseServices::Styles::BandTickStyle StructureTickStyle;
Visual Basic
Public Property StructureTickStyle() As Autodesk::Civil::DatabaseServices::Styles::BandTickStyle
Links
PipeNetworkBandStyle Class, PipeNetworkBandStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeNetworkBandStyle::TitleTextLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Properties > PipeNetworkBandStyle::TitleTextLabelStyleId Property
PipeNetworkBandStyle::TitleTextLabelStyleId Property
Collapse All

Gets the band profile data title text label style.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TitleTextLabelStyleId;
Visual Basic
Public Property TitleTextLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Links
PipeNetworkBandStyle Class, PipeNetworkBandStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeRuleSetStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyle Class
PipeRuleSetStyle Class
Collapse All

A set of rules for pipe objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::NetworkRuleSetStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPipeRules"))]
public class PipeRuleSetStyle : NetworkRuleSetStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPipeRules"))>
Public Class PipeRuleSetStyle
Inherits NetworkRuleSetStyle
Links
Class Hierarchy


PipeRuleSetStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class
PipeRuleSetStyleCollection Class
Collapse All

A collection of PipeRuleSetStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyleCollection
C#
public class PipeRuleSetStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class PipeRuleSetStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
PipeRuleSetStyleCollection Methods, PipeRuleSetStyleCollection Members, Class Hierarchy


PipeRuleSetStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class > PipeRuleSetStyleCollection Members
PipeRuleSetStyleCollection Members
Collapse All

The following tables list the members exposed by PipeRuleSetStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


PipeRuleSetStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class > PipeRuleSetStyleCollection Methods
PipeRuleSetStyleCollection Methods
Collapse All

The methods of PipeRuleSetStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


PipeRuleSetStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class > PipeRuleSetStyleCollection Methods > PipeRuleSetStyleCollection::Add Method
PipeRuleSetStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
PipeRuleSetStyleCollection Class, PipeRuleSetStyleCollection Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class
PipeStyle Class
Collapse All

Defines how a pipe appears in plan, profile, section, and 3D view.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPipeStyle"))]
public class PipeStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPipeStyle"))>
Public Class PipeStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
PipeStyle Methods, PipeStyle Properties, PipeStyle Members, Class Hierarchy


PipeStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Members
PipeStyle Members
Collapse All

The following tables list the members exposed by PipeStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that defines the Model style.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified PipeDisplayStylePlanType value.
GetDisplayStyleProfile | Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified PipeDisplayStyleProfileType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified PipeDisplayStyleSectionType value.
GetHatchStylePlan | Gets the HatchDisplayStyle object that defines the Plan style.
GetHatchStyleProfile | Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified PipeHatchStyleProfileType value.
GetHatchStyleSection | Gets the HatchDisplayStyle object that defines the Section style.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PlanOption | Gets the object that defines the appearance of the pipe in a 2D plan view.
ProfileOption | Gets the object that defines the appearance of the pipe in a profile view.
SectionCrossingHatch | Gets or sets the PipeHatchOptions object that specifies the style for the inside walls of pipe crossings displayed in section... more
Links
Public Methods, Public Properties


PipeStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods
PipeStyle Methods
Collapse All

The methods of PipeStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that defines the Model style.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified PipeDisplayStylePlanType value.
GetDisplayStyleProfile | Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified PipeDisplayStyleProfileType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified PipeDisplayStyleSectionType value.
GetHatchStylePlan | Gets the HatchDisplayStyle object that defines the Plan style.
GetHatchStyleProfile | Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified PipeHatchStyleProfileType value.
GetHatchStyleSection | Gets the HatchDisplayStyle object that defines the Section style.
Links
Public Methods


PipeStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods > PipeStyle::GetDisplayStyleModel Method
PipeStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that defines the Model style.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel();
Visual Basic
Public Function GetDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods > PipeStyle::GetDisplayStylePlan Method
PipeStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified PipeDisplayStylePlanType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    PipeDisplayStylePlanType component
);
Visual Basic
Public Function GetDisplayStylePlan(
    component As PipeDisplayStylePlanType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
component | The pipe display component to get.
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle::GetDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods > PipeStyle::GetDisplayStyleProfile Method
PipeStyle::GetDisplayStyleProfile Method
Collapse All

Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified PipeDisplayStyleProfileType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleProfile(
    PipeDisplayStyleProfileType component
);
Visual Basic
Public Function GetDisplayStyleProfile(
    component As PipeDisplayStyleProfileType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
component | The pipe display component to get.
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods > PipeStyle::GetDisplayStyleSection Method
PipeStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle object that defines the Section style for the component indicated by the specified PipeDisplayStyleSectionType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection(
    PipeDisplayStyleSectionType component
);
Visual Basic
Public Function GetDisplayStyleSection(
    component As PipeDisplayStyleSectionType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
component | The pipe display component to get.
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle::GetHatchStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods > PipeStyle::GetHatchStylePlan Method
PipeStyle::GetHatchStylePlan Method
Collapse All

Gets the HatchDisplayStyle object that defines the Plan style.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchStylePlan();
Visual Basic
Public Function GetHatchStylePlan() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle::GetHatchStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods > PipeStyle::GetHatchStyleProfile Method
PipeStyle::GetHatchStyleProfile Method
Collapse All

Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified PipeHatchStyleProfileType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchStyleProfile(
    PipeHatchStyleProfileType component
);
Visual Basic
Public Function GetHatchStyleProfile(
    component As PipeHatchStyleProfileType
) As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Parameters
Parameters | Description
component | The pipe hatch component to get.
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle::GetHatchStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods > PipeStyle::GetHatchStyleSection Method
PipeStyle::GetHatchStyleSection Method
Collapse All

Gets the HatchDisplayStyle object that defines the Section style.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchStyleSection();
Visual Basic
Public Function GetHatchStyleSection() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Properties
PipeStyle Properties
Collapse All

The properties of PipeStyle are listed here.

Public Properties
Public Property | Description
PlanOption | Gets the object that defines the appearance of the pipe in a 2D plan view.
ProfileOption | Gets the object that defines the appearance of the pipe in a profile view.
SectionCrossingHatch | Gets or sets the PipeHatchOptions object that specifies the style for the inside walls of pipe crossings displayed in section... more
Links
Public Properties


PipeStyle::PlanOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Properties > PipeStyle::PlanOption Property
PipeStyle::PlanOption Property
Collapse All

Gets the object that defines the appearance of the pipe in a 2D plan view.

C#
public PipeStylePlanOption PlanOption;
Visual Basic
Public Property PlanOption() As PipeStylePlanOption
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle::ProfileOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Properties > PipeStyle::ProfileOption Property
PipeStyle::ProfileOption Property
Collapse All

Gets the object that defines the appearance of the pipe in a profile view.

C#
public PipeStyleProfileOption ProfileOption;
Visual Basic
Public Property ProfileOption() As PipeStyleProfileOption
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyle::SectionCrossingHatch Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Properties > PipeStyle::SectionCrossingHatch Property
PipeStyle::SectionCrossingHatch Property
Collapse All

Gets or sets the PipeHatchOptions object that specifies the style for the inside walls of pipe crossings displayed in section view.

C#
public PipeHatchType SectionCrossingHatch;
Visual Basic
Public Property SectionCrossingHatch() As PipeHatchType
Links
PipeStyle Class, PipeStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class
PipeStyleCollection Class
Collapse All

A collection of PipeStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleCollection
C#
public class PipeStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class PipeStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.Styles.PipeStyle

Links
PipeStyleCollection Methods, PipeStyleCollection Members, Class Hierarchy


PipeStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class > PipeStyleCollection Members
PipeStyleCollection Members
Collapse All

The following tables list the members exposed by PipeStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


PipeStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class > PipeStyleCollection Methods
PipeStyleCollection Methods
Collapse All

The methods of PipeStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


PipeStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class > PipeStyleCollection Methods > PipeStyleCollection::Add Method
PipeStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
PipeStyleCollection Class, PipeStyleCollection Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class
PipeStyleOptionBase Class
Collapse All

Base interface for settings that define the appearance of the pipe in a 2D plan view. Used by PipeStylePlanOption and PipeStyleProfileOption.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePlanOption
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleProfileOption
C#
public class PipeStyleOptionBase : CivilWrapper<AeccDbPipeStyle>;
Visual Basic
Public Class PipeStyleOptionBase
Inherits CivilWrapper<AeccDbPipeStyle>
Links
PipeStyleOptionBase Properties, PipeStyleOptionBase Members, Class Hierarchy


PipeStyleOptionBase Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Members
PipeStyleOptionBase Members
Collapse All

The following tables list the members exposed by PipeStyleOptionBase.

Public Properties
Public Property | Description
AlignHatchToPipe | Gets or sets the AlignHatchToPipe value that specifies whether the angle of the hatch lines for the pipe align with... more
EndLineSize | Pipe style end line size.
EndLineSizePercent | Pipe style end line size percent.
EndSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe end size is drawn in absolute units, to drawing scale,... more
EndSizeType | Specifies the appearance of the pipe end, such as draw to inner wall, draw to outer wall, or user-defined.
HatchOptions | Specifies which components of the pipe shape display a hatch pattern.
InnerDiameter | Specifies the inner pipe wall dimensions as an absolute value.
InnerDiameterPercent | Specifies the inner pipe wall dimensions as a percent of drawing size.
OuterDiameter | Specifies the outer pipe wall dimensions as an absolute value.
OuterDiameterPercent | Specifies the outer pipe wall dimensions as a percent of drawing size.
PipeToPipeEndCleanup | Gets or sets the PipeToPipeEndCleanup value that specifies whether the appearance of pipe to pipe connections in plan/profile view is... more
WallSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe wall size is drawn in absolute units, to drawing scale,... more
WallSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe wall.
Links
Public Properties


PipeStyleOptionBase Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties
PipeStyleOptionBase Properties
Collapse All

The properties of PipeStyleOptionBase are listed here.

Public Properties
Public Property | Description
AlignHatchToPipe | Gets or sets the AlignHatchToPipe value that specifies whether the angle of the hatch lines for the pipe align with... more
EndLineSize | Pipe style end line size.
EndLineSizePercent | Pipe style end line size percent.
EndSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe end size is drawn in absolute units, to drawing scale,... more
EndSizeType | Specifies the appearance of the pipe end, such as draw to inner wall, draw to outer wall, or user-defined.
HatchOptions | Specifies which components of the pipe shape display a hatch pattern.
InnerDiameter | Specifies the inner pipe wall dimensions as an absolute value.
InnerDiameterPercent | Specifies the inner pipe wall dimensions as a percent of drawing size.
OuterDiameter | Specifies the outer pipe wall dimensions as an absolute value.
OuterDiameterPercent | Specifies the outer pipe wall dimensions as a percent of drawing size.
PipeToPipeEndCleanup | Gets or sets the PipeToPipeEndCleanup value that specifies whether the appearance of pipe to pipe connections in plan/profile view is... more
WallSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe wall size is drawn in absolute units, to drawing scale,... more
WallSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe wall.
Links
Public Properties


PipeStyleOptionBase::AlignHatchToPipe Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::AlignHatchToPipe Property
PipeStyleOptionBase::AlignHatchToPipe Property
Collapse All

Gets or sets the AlignHatchToPipe value that specifies whether the angle of the hatch lines for the pipe align with the angle of the pipe.

C#
public bool AlignHatchToPipe;
Visual Basic
Public Property AlignHatchToPipe() As bool
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::EndLineSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::EndLineSize Property
PipeStyleOptionBase::EndLineSize Property
Collapse All

Pipe style end line size.

C#
public double EndLineSize;
Visual Basic
Public Property EndLineSize() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval [0.0, 1.2E25].
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::EndLineSizePercent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::EndLineSizePercent Property
PipeStyleOptionBase::EndLineSizePercent Property
Collapse All

Pipe style end line size percent.

C#
public double EndLineSizePercent;
Visual Basic
Public Property EndLineSizePercent() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval (0.0, 100.0].
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::EndSizeOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::EndSizeOptions Property
PipeStyleOptionBase::EndSizeOptions Property
Collapse All

Gets or sets the PipeDisplayOptions value that specifies whether pipe end size is drawn in absolute units, to drawing scale, or as a percentage of the screen size.

C#
public PipeUserDefinedType EndSizeOptions;
Visual Basic
Public Property EndSizeOptions() As PipeUserDefinedType
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::EndSizeType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::EndSizeType Property
PipeStyleOptionBase::EndSizeType Property
Collapse All

Specifies the appearance of the pipe end, such as draw to inner wall, draw to outer wall, or user-defined.

C#
public PipeEndSizeType EndSizeType;
Visual Basic
Public Property EndSizeType() As PipeEndSizeType
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::HatchOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::HatchOptions Property
PipeStyleOptionBase::HatchOptions Property
Collapse All

Specifies which components of the pipe shape display a hatch pattern.

C#
public PipeHatchType HatchOptions;
Visual Basic
Public Property HatchOptions() As PipeHatchType
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::InnerDiameter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::InnerDiameter Property
PipeStyleOptionBase::InnerDiameter Property
Collapse All

Specifies the inner pipe wall dimensions as an absolute value.

C#
public double InnerDiameter;
Visual Basic
Public Property InnerDiameter() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval [0.0, 1.2E25].
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::InnerDiameterPercent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::InnerDiameterPercent Property
PipeStyleOptionBase::InnerDiameterPercent Property
Collapse All

Specifies the inner pipe wall dimensions as a percent of drawing size.

C#
public double InnerDiameterPercent;
Visual Basic
Public Property InnerDiameterPercent() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval (0.0, 100.0].
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::OuterDiameter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::OuterDiameter Property
PipeStyleOptionBase::OuterDiameter Property
Collapse All

Specifies the outer pipe wall dimensions as an absolute value.

C#
public double OuterDiameter;
Visual Basic
Public Property OuterDiameter() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval [0.0, 1.2E25].
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::OuterDiameterPercent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::OuterDiameterPercent Property
PipeStyleOptionBase::OuterDiameterPercent Property
Collapse All

Specifies the outer pipe wall dimensions as a percent of drawing size.

C#
public double OuterDiameterPercent;
Visual Basic
Public Property OuterDiameterPercent() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval (0.0, 100.0].
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::PipeToPipeEndCleanup Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::PipeToPipeEndCleanup Property
PipeStyleOptionBase::PipeToPipeEndCleanup Property
Collapse All

Gets or sets the PipeToPipeEndCleanup value that specifies whether the appearance of pipe to pipe connections in plan/profile view is cleaned up.

C#
public bool PipeToPipeEndCleanup;
Visual Basic
Public Property PipeToPipeEndCleanup() As bool
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::WallSizeOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::WallSizeOptions Property
PipeStyleOptionBase::WallSizeOptions Property
Collapse All

Gets or sets the PipeDisplayOptions value that specifies whether pipe wall size is drawn in absolute units, to drawing scale, or as a percentage of the screen size.

C#
public PipeUserDefinedType WallSizeOptions;
Visual Basic
Public Property WallSizeOptions() As PipeUserDefinedType
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleOptionBase::WallSizeType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties > PipeStyleOptionBase::WallSizeType Property
PipeStyleOptionBase::WallSizeType Property
Collapse All

Specifies the method that will be used to define and draw the dimensions of the pipe wall.

C#
public PipeWallSizeType WallSizeType;
Visual Basic
Public Property WallSizeType() As PipeWallSizeType
Links
PipeStyleOptionBase Class, PipeStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStylePlanOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class
PipeStylePlanOption Class
Collapse All

Settings that define the appearance of the pipe in a 2D plan view.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePlanOption
C#
public class PipeStylePlanOption : PipeStyleOptionBase;
Visual Basic
Public Class PipeStylePlanOption
Inherits PipeStyleOptionBase
Links
PipeStylePlanOption Properties, PipeStylePlanOption Members, Class Hierarchy


PipeStylePlanOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Members
PipeStylePlanOption Members
Collapse All

The following tables list the members exposed by PipeStylePlanOption.

Public Properties
Public Property | Description
AlignHatchToPipe | Gets or sets the AlignHatchToPipe value that specifies whether the angle of the hatch lines for the pipe align with... more
CenterlineOptions | Gets or sets the method that will be used to define and draw the dimensions of the pipe centerline.
CenterlineSize | Gets or sets pipe style center line size.
CenterlineSizePercent | Gets or sets pipe style center line size percent.
CenterlineWidthOptions | Gets or sets the center line width option.
EndLineSize | Pipe style end line size.
EndLineSizePercent | Pipe style end line size percent.
EndSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe end size is drawn in absolute units, to drawing scale,... more
EndSizeType | Specifies the appearance of the pipe end, such as draw to inner wall, draw to outer wall, or user-defined.
HatchOptions | Specifies which components of the pipe shape display a hatch pattern.
InnerDiameter | Specifies the inner pipe wall dimensions as an absolute value.
InnerDiameterPercent | Specifies the inner pipe wall dimensions as a percent of drawing size.
OuterDiameter | Specifies the outer pipe wall dimensions as an absolute value.
OuterDiameterPercent | Specifies the outer pipe wall dimensions as a percent of drawing size.
PipeToPipeEndCleanup | Gets or sets the PipeToPipeEndCleanup value that specifies whether the appearance of pipe to pipe connections in plan/profile view is... more
WallSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe wall size is drawn in absolute units, to drawing scale,... more
WallSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe wall.
Links
Public Properties


PipeStylePlanOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Properties
PipeStylePlanOption Properties
Collapse All

The properties of PipeStylePlanOption are listed here.

Public Properties
Public Property | Description
CenterlineOptions | Gets or sets the method that will be used to define and draw the dimensions of the pipe centerline.
CenterlineSize | Gets or sets pipe style center line size.
CenterlineSizePercent | Gets or sets pipe style center line size percent.
CenterlineWidthOptions | Gets or sets the center line width option.
Links
Public Properties


PipeStylePlanOption::CenterlineOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Properties > PipeStylePlanOption::CenterlineOptions Property
PipeStylePlanOption::CenterlineOptions Property
Collapse All

Gets or sets the method that will be used to define and draw the dimensions of the pipe centerline.

C#
public PipeCenterlineType CenterlineOptions;
Visual Basic
Public Property CenterlineOptions() As PipeCenterlineType
Links
PipeStylePlanOption Class, PipeStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStylePlanOption::CenterlineSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Properties > PipeStylePlanOption::CenterlineSize Property
PipeStylePlanOption::CenterlineSize Property
Collapse All

Gets or sets pipe style center line size.

C#
public double CenterlineSize;
Visual Basic
Public Property CenterlineSize() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval [0.0, 1.2E25].
Links
PipeStylePlanOption Class, PipeStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStylePlanOption::CenterlineSizePercent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Properties > PipeStylePlanOption::CenterlineSizePercent Property
PipeStylePlanOption::CenterlineSizePercent Property
Collapse All

Gets or sets pipe style center line size percent.

C#
public double CenterlineSizePercent;
Visual Basic
Public Property CenterlineSizePercent() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval (0.0, 100.0].
Links
PipeStylePlanOption Class, PipeStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStylePlanOption::CenterlineWidthOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Properties > PipeStylePlanOption::CenterlineWidthOptions Property
PipeStylePlanOption::CenterlineWidthOptions Property
Collapse All

Gets or sets the center line width option.

C#
public PipeCenterlineWidthType CenterlineWidthOptions;
Visual Basic
Public Property CenterlineWidthOptions() As PipeCenterlineWidthType
Links
PipeStylePlanOption Class, PipeStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


PipeStyleProfileOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleProfileOption Class
PipeStyleProfileOption Class
Collapse All

Settings that define the appearance of the pipe in a profile view.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleProfileOption
C#
public class PipeStyleProfileOption : PipeStyleOptionBase;
Visual Basic
Public Class PipeStyleProfileOption
Inherits PipeStyleOptionBase
Links
PipeStyleProfileOption Properties, PipeStyleProfileOption Members, Class Hierarchy


PipeStyleProfileOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleProfileOption Class > PipeStyleProfileOption Members
PipeStyleProfileOption Members
Collapse All

The following tables list the members exposed by PipeStyleProfileOption.

Public Properties
Public Property | Description
AlignHatchToPipe | Gets or sets the AlignHatchToPipe value that specifies whether the angle of the hatch lines for the pipe align with... more
CrossingHatch | Specifies which components of a pipe crossing display a hatch pattern.
EndLineSize | Pipe style end line size.
EndLineSizePercent | Pipe style end line size percent.
EndSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe end size is drawn in absolute units, to drawing scale,... more
EndSizeType | Specifies the appearance of the pipe end, such as draw to inner wall, draw to outer wall, or user-defined.
HatchOptions | Specifies which components of the pipe shape display a hatch pattern.
InnerDiameter | Specifies the inner pipe wall dimensions as an absolute value.
InnerDiameterPercent | Specifies the inner pipe wall dimensions as a percent of drawing size.
OuterDiameter | Specifies the outer pipe wall dimensions as an absolute value.
OuterDiameterPercent | Specifies the outer pipe wall dimensions as a percent of drawing size.
PipeToPipeEndCleanup | Gets or sets the PipeToPipeEndCleanup value that specifies whether the appearance of pipe to pipe connections in plan/profile view is... more
WallSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe wall size is drawn in absolute units, to drawing scale,... more
WallSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe wall.
Links
Public Properties


PipeStyleProfileOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleProfileOption Class > PipeStyleProfileOption Properties
PipeStyleProfileOption Properties
Collapse All

The properties of PipeStyleProfileOption are listed here.

Public Properties
Public Property | Description
CrossingHatch | Specifies which components of a pipe crossing display a hatch pattern.
Links
Public Properties


PipeStyleProfileOption::CrossingHatch Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleProfileOption Class > PipeStyleProfileOption Properties > PipeStyleProfileOption::CrossingHatch Property
PipeStyleProfileOption::CrossingHatch Property
Collapse All

Specifies which components of a pipe crossing display a hatch pattern.

C#
public PipeHatchType CrossingHatch;
Visual Basic
Public Property CrossingHatch() As PipeHatchType
Links
PipeStyleProfileOption Class, PipeStyleProfileOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


SizeFilterField Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class
SizeFilterField Class
Collapse All

Part size parameters from a SizeFilterRecord.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataField
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::SizeFilterField
C#
public class SizeFilterField : PartDataField;
Visual Basic
Public Class SizeFilterField
Inherits PartDataField
Links
SizeFilterField Properties, SizeFilterField Members, Class Hierarchy


SizeFilterField Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class > SizeFilterField Members
SizeFilterField Members
Collapse All

The following tables list the members exposed by SizeFilterField.

Public Properties
Public Property | Description
Context | Gets the parameter context.
ContextString | Gets the parameter context string.
DataSource | Gets the parameter data source.
DataType | Gets the type of the reserved data.
Description | Gets the description of the data field.
Index | Gets the parameter index.
IsFromList | Gets if the value of data field should be set from a fixed list.
IsFromRange | Gets if the value of data field should be set from a range.
IsMultipleSelect | Gets if multiselecting all the values if the data source of this parameter is "FixedList"
IsReadOnly | Checks if the data field is read-only.
Name | Gets the name of the data field.
Units | Gets the parameter units.
Value | Gets or sets the value. The value type is returned by the DataType property.
ValueList | Gets the list of valid data if the data field is from a fixed list.
ValueRange | Gets the range of valid data if the data field is from a range.
Links
Public Properties


SizeFilterField Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class > SizeFilterField Properties
SizeFilterField Properties
Collapse All

The properties of SizeFilterField are listed here.

Public Properties
Public Property | Description
DataSource | Gets the parameter data source.
IsMultipleSelect | Gets if multiselecting all the values if the data source of this parameter is "FixedList"
Links
Public Properties


SizeFilterField::DataSource Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class > SizeFilterField Properties > SizeFilterField::DataSource Property
SizeFilterField::DataSource Property
Collapse All

Gets the parameter data source.

C#
public PartDataSourceType DataSource;
Visual Basic
Public Property DataSource() As PartDataSourceType
Links
SizeFilterField Class, SizeFilterField Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


SizeFilterField::IsMultipleSelect Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class > SizeFilterField Properties > SizeFilterField::IsMultipleSelect Property
SizeFilterField::IsMultipleSelect Property
Collapse All

Gets if multiselecting all the values if the data source of this parameter is "FixedList"

C#
public bool IsMultipleSelect;
Visual Basic
Public Property IsMultipleSelect() As bool
Links
SizeFilterField Class, SizeFilterField Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


SizeFilterRecord Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class
SizeFilterRecord Class
Collapse All

Lets users specify what part sizes they want to add into a part family.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::SizeFilterRecord
C#
public class SizeFilterRecord;
Visual Basic
Public Class SizeFilterRecord
Links
SizeFilterRecord Methods, SizeFilterRecord Properties, SizeFilterRecord Members, Class Hierarchy


SizeFilterRecord Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Members
SizeFilterRecord Members
Collapse All

The following tables list the members exposed by SizeFilterRecord.

Public Methods
Public Method | Description
GetParamByContextAndIndex | Gets the catalog parameter by context and index.
Public Properties
Public Property | Description
default | Gets the catalog part parameter by name.
ParamCount | Gets the count of parameters in the catalog part.
PartFamilyGuid | Gets the guid of the part family this size filter belongs to
Links
Public Methods, Public Properties


SizeFilterRecord Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Methods
SizeFilterRecord Methods
Collapse All

The methods of SizeFilterRecord are listed here.

Public Methods
Public Method | Description
GetParamByContextAndIndex | Gets the catalog parameter by context and index.
Links
Public Methods


SizeFilterRecord::GetParamByContextAndIndex Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Methods > SizeFilterRecord::GetParamByContextAndIndex Method
SizeFilterRecord::GetParamByContextAndIndex Method
Collapse All

Gets the catalog parameter by context and index.

C#
public SizeFilterField GetParamByContextAndIndex(
    PartContextType context,
    int index
);
Visual Basic
Public Function GetParamByContextAndIndex(
    context As PartContextType,
    index As Integer
) As SizeFilterField
Links
SizeFilterRecord Class, SizeFilterRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


SizeFilterRecord Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Properties
SizeFilterRecord Properties
Collapse All

The properties of SizeFilterRecord are listed here.

Public Properties
Public Property | Description
default | Gets the catalog part parameter by name.
ParamCount | Gets the count of parameters in the catalog part.
PartFamilyGuid | Gets the guid of the part family this size filter belongs to
Links
Public Properties


SizeFilterRecord::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Properties > SizeFilterRecord::default Property
SizeFilterRecord::default Property
Collapse All

Gets the catalog part parameter by name.

C#
public SizeFilterField default;
Visual Basic
Public Property default() As SizeFilterField
Links
SizeFilterRecord Class, SizeFilterRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


SizeFilterRecord::ParamCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Properties > SizeFilterRecord::ParamCount Property
SizeFilterRecord::ParamCount Property
Collapse All

Gets the count of parameters in the catalog part.

C#
public int ParamCount;
Visual Basic
Public Property ParamCount() As Integer
Links
SizeFilterRecord Class, SizeFilterRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


SizeFilterRecord::PartFamilyGuid Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Properties > SizeFilterRecord::PartFamilyGuid Property
SizeFilterRecord::PartFamilyGuid Property
Collapse All

Gets the guid of the part family this size filter belongs to

C#
public System::String PartFamilyGuid;
Visual Basic
Public Property PartFamilyGuid() As System::String
Links
SizeFilterRecord Class, SizeFilterRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureRuleSetStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyle Class
StructureRuleSetStyle Class
Collapse All

A set of rules for structure objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::NetworkRuleSetStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStructureRules"))]
public class StructureRuleSetStyle : NetworkRuleSetStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStructureRules"))>
Public Class StructureRuleSetStyle
Inherits NetworkRuleSetStyle
Links
Class Hierarchy


StructureRuleSetStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class
StructureRuleSetStyleCollection Class
Collapse All

A collection of StructureRuleSetStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyleCollection
C#
public class StructureRuleSetStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class StructureRuleSetStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
StructureRuleSetStyleCollection Methods, StructureRuleSetStyleCollection Members, Class Hierarchy


StructureRuleSetStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class > StructureRuleSetStyleCollection Members
StructureRuleSetStyleCollection Members
Collapse All

The following tables list the members exposed by StructureRuleSetStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


StructureRuleSetStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class > StructureRuleSetStyleCollection Methods
StructureRuleSetStyleCollection Methods
Collapse All

The methods of StructureRuleSetStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


StructureRuleSetStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class > StructureRuleSetStyleCollection Methods > StructureRuleSetStyleCollection::Add Method
StructureRuleSetStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
StructureRuleSetStyleCollection Class, StructureRuleSetStyleCollection Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class
StructureStyle Class
Collapse All

Specifies display properties for all structure objects in the drawing.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStructureStyle"))]
public class StructureStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStructureStyle"))>
Public Class StructureStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
StructureStyle Methods, StructureStyle Properties, StructureStyle Members, Class Hierarchy


StructureStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Members
StructureStyle Members
Collapse All

The following tables list the members exposed by StructureStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that defines the Model style.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified StructureDisplayStylePlanType value.
GetDisplayStyleProfile | Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified StructureDisplayStyleProfileType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified StructureDisplayStyleSectionType value.
GetHatchStylePlan | Gets the HatchDisplayStyle object that defines the Plan style.
GetHatchStyleProfile | Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified StructureHatchStyleProfileType value.
GetHatchStyleSection | Gets the HatchDisplayStyle object that defines the Section style.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModelOption | Gets the object that defines the appearance of the Structure in a model view.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PlanOption | Gets the object that defines the appearance of the Structure in a 2D plan view.
ProfileOption | Gets the object that defines the appearance of the Structure in a profile view.
SectionOption | Gets the object that defines the appearance of the Structure in a section view.
Links
Public Methods, Public Properties


StructureStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods
StructureStyle Methods
Collapse All

The methods of StructureStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that defines the Model style.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified StructureDisplayStylePlanType value.
GetDisplayStyleProfile | Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified StructureDisplayStyleProfileType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified StructureDisplayStyleSectionType value.
GetHatchStylePlan | Gets the HatchDisplayStyle object that defines the Plan style.
GetHatchStyleProfile | Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified StructureHatchStyleProfileType value.
GetHatchStyleSection | Gets the HatchDisplayStyle object that defines the Section style.
Links
Public Methods


StructureStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods > StructureStyle::GetDisplayStyleModel Method
StructureStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that defines the Model style.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel();
Visual Basic
Public Function GetDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods > StructureStyle::GetDisplayStylePlan Method
StructureStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified StructureDisplayStylePlanType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    StructureDisplayStylePlanType component
);
Visual Basic
Public Function GetDisplayStylePlan(
    component As StructureDisplayStylePlanType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
component | The Structure display component to get.
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle::GetDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods > StructureStyle::GetDisplayStyleProfile Method
StructureStyle::GetDisplayStyleProfile Method
Collapse All

Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified StructureDisplayStyleProfileType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleProfile(
    StructureDisplayStyleProfileType component
);
Visual Basic
Public Function GetDisplayStyleProfile(
    component As StructureDisplayStyleProfileType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
component | The Structure display component to get.
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods > StructureStyle::GetDisplayStyleSection Method
StructureStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle object that defines the Section style for the component indicated by the specified StructureDisplayStyleSectionType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection(
    StructureDisplayStyleSectionType component
);
Visual Basic
Public Function GetDisplayStyleSection(
    component As StructureDisplayStyleSectionType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
component | The Structure display component to get.
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle::GetHatchStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods > StructureStyle::GetHatchStylePlan Method
StructureStyle::GetHatchStylePlan Method
Collapse All

Gets the HatchDisplayStyle object that defines the Plan style.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchStylePlan();
Visual Basic
Public Function GetHatchStylePlan() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle::GetHatchStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods > StructureStyle::GetHatchStyleProfile Method
StructureStyle::GetHatchStyleProfile Method
Collapse All

Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified StructureHatchStyleProfileType value.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchStyleProfile();
Visual Basic
Public Function GetHatchStyleProfile() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle::GetHatchStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods > StructureStyle::GetHatchStyleSection Method
StructureStyle::GetHatchStyleSection Method
Collapse All

Gets the HatchDisplayStyle object that defines the Section style.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchStyleSection();
Visual Basic
Public Function GetHatchStyleSection() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Properties
StructureStyle Properties
Collapse All

The properties of StructureStyle are listed here.

Public Properties
Public Property | Description
ModelOption | Gets the object that defines the appearance of the Structure in a model view.
PlanOption | Gets the object that defines the appearance of the Structure in a 2D plan view.
ProfileOption | Gets the object that defines the appearance of the Structure in a profile view.
SectionOption | Gets the object that defines the appearance of the Structure in a section view.
Links
Public Properties


StructureStyle::ModelOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Properties > StructureStyle::ModelOption Property
StructureStyle::ModelOption Property
Collapse All

Gets the object that defines the appearance of the Structure in a model view.

C#
public StructureStyleModelOption ModelOption;
Visual Basic
Public Property ModelOption() As StructureStyleModelOption
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle::PlanOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Properties > StructureStyle::PlanOption Property
StructureStyle::PlanOption Property
Collapse All

Gets the object that defines the appearance of the Structure in a 2D plan view.

C#
public StructureStylePlanOption PlanOption;
Visual Basic
Public Property PlanOption() As StructureStylePlanOption
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle::ProfileOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Properties > StructureStyle::ProfileOption Property
StructureStyle::ProfileOption Property
Collapse All

Gets the object that defines the appearance of the Structure in a profile view.

C#
public StructureStyleProfileOption ProfileOption;
Visual Basic
Public Property ProfileOption() As StructureStyleProfileOption
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyle::SectionOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Properties > StructureStyle::SectionOption Property
StructureStyle::SectionOption Property
Collapse All

Gets the object that defines the appearance of the Structure in a section view.

C#
public StructureStyleSectionOption SectionOption;
Visual Basic
Public Property SectionOption() As StructureStyleSectionOption
Links
StructureStyle Class, StructureStyle Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class
StructureStyleCollection Class
Collapse All

A collection of StructureStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleCollection
C#
public class StructureStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class StructureStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
StructureStyleCollection Methods, StructureStyleCollection Members, Class Hierarchy


StructureStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class > StructureStyleCollection Members
StructureStyleCollection Members
Collapse All

The following tables list the members exposed by StructureStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


StructureStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class > StructureStyleCollection Methods
StructureStyleCollection Methods
Collapse All

The methods of StructureStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


StructureStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class > StructureStyleCollection Methods > StructureStyleCollection::Add Method
StructureStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
StructureStyleCollection Class, StructureStyleCollection Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleModelOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class
StructureStyleModelOption Class
Collapse All

Specifies the method that is used to define and draw the dimensions of the structure in model view.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleModelOption
C#
public class StructureStyleModelOption : CivilWrapper<AeccDbStructureStyle>;
Visual Basic
Public Class StructureStyleModelOption
Inherits CivilWrapper<AeccDbStructureStyle>
Links
StructureStyleModelOption Properties, StructureStyleModelOption Members, Class Hierarchy


StructureStyleModelOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class > StructureStyleModelOption Members
StructureStyleModelOption Members
Collapse All

The following tables list the members exposed by StructureStyleModelOption.

Public Properties
Public Property | Description
ModelViewOptions | Gets or sets the enum value that indicates whether the 3D object composed in the parts catalog should be used... more
SimpleSolidType | When ModelViewOptions is defined as Simple3dPart, the 3D object composed in the parts catalog is ignored and the structure is... more
Links
Public Properties


StructureStyleModelOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class > StructureStyleModelOption Properties
StructureStyleModelOption Properties
Collapse All

The properties of StructureStyleModelOption are listed here.

Public Properties
Public Property | Description
ModelViewOptions | Gets or sets the enum value that indicates whether the 3D object composed in the parts catalog should be used... more
SimpleSolidType | When ModelViewOptions is defined as Simple3dPart, the 3D object composed in the parts catalog is ignored and the structure is... more
Links
Public Properties


StructureStyleModelOption::ModelViewOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class > StructureStyleModelOption Properties > StructureStyleModelOption::ModelViewOptions Property
StructureStyleModelOption::ModelViewOptions Property
Collapse All

Gets or sets the enum value that indicates whether the 3D object composed in the parts catalog should be used when displaying the structure in 3D.

C#
public StructureModelViewOptionType ModelViewOptions;
Visual Basic
Public Property ModelViewOptions() As StructureModelViewOptionType
Links
StructureStyleModelOption Class, StructureStyleModelOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleModelOption::SimpleSolidType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class > StructureStyleModelOption Properties > StructureStyleModelOption::SimpleSolidType Property
StructureStyleModelOption::SimpleSolidType Property
Collapse All

When ModelViewOptions is defined as Simple3dPart, the 3D object composed in the parts catalog is ignored and the structure is displayed with one of the following simple shapes: cube, cylinder, or sphere.

C#
public StructureSimpleSolidType SimpleSolidType;
Visual Basic
Public Property SimpleSolidType() As StructureSimpleSolidType
Links
StructureStyleModelOption Class, StructureStyleModelOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class
StructureStyleOptionBase Class
Collapse All

Base class for StructureStyleProfileOption and StructureStyleSectionOption.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleProfileOption
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleSectionOption
C#
public class StructureStyleOptionBase : CivilWrapper<AeccDbStructureStyle>;
Visual Basic
Public Class StructureStyleOptionBase
Inherits CivilWrapper<AeccDbStructureStyle>
Links
StructureStyleOptionBase Properties, StructureStyleOptionBase Members, Class Hierarchy


StructureStyleOptionBase Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Members
StructureStyleOptionBase Members
Collapse All

The following tables list the members exposed by StructureStyleOptionBase.

Public Properties
Public Property | Description
BlockInsertLocation | Gets or sets the insertion point to use for the block displayed in profile/section view.
MaskConnectedObjects | Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in profile/section... more
SizeType | Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure... more
SymbolBlockName | Gets or sets the name of the block reference to use when displaying in profile/section view.
SymbolBlockXScale | Gets or sets the x scale to use when displaying with a block reference in profile/section view.
SymbolBlockYScale | Gets or sets the y scale to use when displaying with a block reference in profile/section view.
SymbolBlockZScale | Gets or sets the z scale to use when displaying with a block reference in profile/section view.
ViewOptions | Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as... more
XSize | Gets or sets the absolute X-dimension size of the block to display in profile/section view.
XSizePercent | Gets or sets the percentage of the screensize (X-dimension) for the block to display in profile/section view.
YSize | Gets or sets the absolute Y-dimension size of the block to display in profile/section view.
YSizePercent | Gets or sets the percentage of the screensize (Y-dimension) for the block to display in profile/section view.
Links
Public Properties


StructureStyleOptionBase Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties
StructureStyleOptionBase Properties
Collapse All

The properties of StructureStyleOptionBase are listed here.

Public Properties
Public Property | Description
BlockInsertLocation | Gets or sets the insertion point to use for the block displayed in profile/section view.
MaskConnectedObjects | Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in profile/section... more
SizeType | Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure... more
SymbolBlockName | Gets or sets the name of the block reference to use when displaying in profile/section view.
SymbolBlockXScale | Gets or sets the x scale to use when displaying with a block reference in profile/section view.
SymbolBlockYScale | Gets or sets the y scale to use when displaying with a block reference in profile/section view.
SymbolBlockZScale | Gets or sets the z scale to use when displaying with a block reference in profile/section view.
ViewOptions | Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as... more
XSize | Gets or sets the absolute X-dimension size of the block to display in profile/section view.
XSizePercent | Gets or sets the percentage of the screensize (X-dimension) for the block to display in profile/section view.
YSize | Gets or sets the absolute Y-dimension size of the block to display in profile/section view.
YSizePercent | Gets or sets the percentage of the screensize (Y-dimension) for the block to display in profile/section view.
Links
Public Properties


StructureStyleOptionBase::BlockInsertLocation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::BlockInsertLocation Property
StructureStyleOptionBase::BlockInsertLocation Property
Collapse All

Gets or sets the insertion point to use for the block displayed in profile/section view.

C#
public StructureInsertionLocation BlockInsertLocation;
Visual Basic
Public Property BlockInsertLocation() As StructureInsertionLocation
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::MaskConnectedObjects Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::MaskConnectedObjects Property
StructureStyleOptionBase::MaskConnectedObjects Property
Collapse All

Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in profile/section view.

C#
public bool MaskConnectedObjects;
Visual Basic
Public Property MaskConnectedObjects() As bool
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::SizeType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::SizeType Property
StructureStyleOptionBase::SizeType Property
Collapse All

Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure in profile/section view.

C#
public StructureSizeOptionsType SizeType;
Visual Basic
Public Property SizeType() As StructureSizeOptionsType
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::SymbolBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::SymbolBlockName Property
StructureStyleOptionBase::SymbolBlockName Property
Collapse All

Gets or sets the name of the block reference to use when displaying in profile/section view.

C#
public System::String SymbolBlockName;
Visual Basic
Public Property SymbolBlockName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is not an existed block name.
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::SymbolBlockXScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::SymbolBlockXScale Property
StructureStyleOptionBase::SymbolBlockXScale Property
Collapse All

Gets or sets the x scale to use when displaying with a block reference in profile/section view.

C#
public double SymbolBlockXScale;
Visual Basic
Public Property SymbolBlockXScale() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval (0.0, 1.0E24].
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::SymbolBlockYScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::SymbolBlockYScale Property
StructureStyleOptionBase::SymbolBlockYScale Property
Collapse All

Gets or sets the y scale to use when displaying with a block reference in profile/section view.

C#
public double SymbolBlockYScale;
Visual Basic
Public Property SymbolBlockYScale() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval (0.0, 1.0E24].
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::SymbolBlockZScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::SymbolBlockZScale Property
StructureStyleOptionBase::SymbolBlockZScale Property
Collapse All

Gets or sets the z scale to use when displaying with a block reference in profile/section view.

C#
public double SymbolBlockZScale;
Visual Basic
Public Property SymbolBlockZScale() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval (0.0, 1.0E24].
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::ViewOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::ViewOptions Property
StructureStyleOptionBase::ViewOptions Property
Collapse All

Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as an outline of the 3D object, or as an AutoCAD block reference.

C#
public StructureViewType ViewOptions;
Visual Basic
Public Property ViewOptions() As StructureViewType
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::XSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::XSize Property
StructureStyleOptionBase::XSize Property
Collapse All

Gets or sets the absolute X-dimension size of the block to display in profile/section view.

C#
public double XSize;
Visual Basic
Public Property XSize() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval [-1.0E25, 1.0E25].
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::XSizePercent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::XSizePercent Property
StructureStyleOptionBase::XSizePercent Property
Collapse All

Gets or sets the percentage of the screensize (X-dimension) for the block to display in profile/section view.

C#
public double XSizePercent;
Visual Basic
Public Property XSizePercent() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval (0.0, 100.0].
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::YSize Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::YSize Property
StructureStyleOptionBase::YSize Property
Collapse All

Gets or sets the absolute Y-dimension size of the block to display in profile/section view.

C#
public double YSize;
Visual Basic
Public Property YSize() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval [-1.0E25, 1.0E25].
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleOptionBase::YSizePercent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties > StructureStyleOptionBase::YSizePercent Property
StructureStyleOptionBase::YSizePercent Property
Collapse All

Gets or sets the percentage of the screensize (Y-dimension) for the block to display in profile/section view.

C#
public double YSizePercent;
Visual Basic
Public Property YSizePercent() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out of interval (0.0, 100.0].
Links
StructureStyleOptionBase Class, StructureStyleOptionBase Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStylePlanOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class
StructureStylePlanOption Class
Collapse All

Specifies the method that is used to define and draw the dimensions of the structure in 2D plan view.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePlanOption
C#
public class StructureStylePlanOption : CivilWrapper<AeccDbStructureStyle>;
Visual Basic
Public Class StructureStylePlanOption
Inherits CivilWrapper<AeccDbStructureStyle>
Links
StructureStylePlanOption Properties, StructureStylePlanOption Members, Class Hierarchy


StructureStylePlanOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Members
StructureStylePlanOption Members
Collapse All

The following tables list the members exposed by StructureStylePlanOption.

Public Properties
Public Property | Description
MaskConnectedObjects | Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in plan... more
PlanViewOptions | Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as... more
Size | Gets or sets the absolute size of the block to display in plan view, if the SizeType is specified as... more
SizePercent | Gets or sets the percent of screen to use when sizing the block displayed in plan view, if SizeType is... more
SizeType | Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure... more
SymbolBlockName | Gets or sets the name of the block reference to use when displaying in plan view.
SymbolBlockXScale | Gets or sets the X scale to use when displaying with a block reference in plan view.
SymbolBlockYScale | Gets or sets the Y scale to use when displaying with a block reference in plan view.
SymbolBlockZScale | Gets or sets the Z scale to use when displaying with a block reference in plan view.
Links
Public Properties


StructureStylePlanOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties
StructureStylePlanOption Properties
Collapse All

The properties of StructureStylePlanOption are listed here.

Public Properties
Public Property | Description
MaskConnectedObjects | Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in plan... more
PlanViewOptions | Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as... more
Size | Gets or sets the absolute size of the block to display in plan view, if the SizeType is specified as... more
SizePercent | Gets or sets the percent of screen to use when sizing the block displayed in plan view, if SizeType is... more
SizeType | Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure... more
SymbolBlockName | Gets or sets the name of the block reference to use when displaying in plan view.
SymbolBlockXScale | Gets or sets the X scale to use when displaying with a block reference in plan view.
SymbolBlockYScale | Gets or sets the Y scale to use when displaying with a block reference in plan view.
SymbolBlockZScale | Gets or sets the Z scale to use when displaying with a block reference in plan view.
Links
Public Properties


StructureStylePlanOption::MaskConnectedObjects Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties > StructureStylePlanOption::MaskConnectedObjects Property
StructureStylePlanOption::MaskConnectedObjects Property
Collapse All

Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in plan view.

C#
public bool MaskConnectedObjects;
Visual Basic
Public Property MaskConnectedObjects() As bool
Links
StructureStylePlanOption Class, StructureStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStylePlanOption::PlanViewOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties > StructureStylePlanOption::PlanViewOptions Property
StructureStylePlanOption::PlanViewOptions Property
Collapse All

Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as an outline of the 3D object, or as an AutoCAD block reference.

C#
public StructurePlanViewType PlanViewOptions;
Visual Basic
Public Property PlanViewOptions() As StructurePlanViewType
Links
StructureStylePlanOption Class, StructureStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStylePlanOption::Size Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties > StructureStylePlanOption::Size Property
StructureStylePlanOption::Size Property
Collapse All

Gets or sets the absolute size of the block to display in plan view, if the SizeType is specified as aeccStructureUseAbsoluteUnits.

C#
public double Size;
Visual Basic
Public Property Size() As double
Links
StructureStylePlanOption Class, StructureStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStylePlanOption::SizePercent Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties > StructureStylePlanOption::SizePercent Property
StructureStylePlanOption::SizePercent Property
Collapse All

Gets or sets the percent of screen to use when sizing the block displayed in plan view, if SizeType is defined as aeccStructureUseSizeAsPercentageOfScreen.

C#
public double SizePercent;
Visual Basic
Public Property SizePercent() As double
Links
StructureStylePlanOption Class, StructureStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStylePlanOption::SizeType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties > StructureStylePlanOption::SizeType Property
StructureStylePlanOption::SizeType Property
Collapse All

Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure in plan view.

C#
public StructureSizeOptionsType SizeType;
Visual Basic
Public Property SizeType() As StructureSizeOptionsType
Links
StructureStylePlanOption Class, StructureStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStylePlanOption::SymbolBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties > StructureStylePlanOption::SymbolBlockName Property
StructureStylePlanOption::SymbolBlockName Property
Collapse All

Gets or sets the name of the block reference to use when displaying in plan view.

C#
public System::String SymbolBlockName;
Visual Basic
Public Property SymbolBlockName() As System::String
Links
StructureStylePlanOption Class, StructureStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStylePlanOption::SymbolBlockXScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties > StructureStylePlanOption::SymbolBlockXScale Property
StructureStylePlanOption::SymbolBlockXScale Property
Collapse All

Gets or sets the X scale to use when displaying with a block reference in plan view.

C#
public double SymbolBlockXScale;
Visual Basic
Public Property SymbolBlockXScale() As double
Links
StructureStylePlanOption Class, StructureStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStylePlanOption::SymbolBlockYScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties > StructureStylePlanOption::SymbolBlockYScale Property
StructureStylePlanOption::SymbolBlockYScale Property
Collapse All

Gets or sets the Y scale to use when displaying with a block reference in plan view.

C#
public double SymbolBlockYScale;
Visual Basic
Public Property SymbolBlockYScale() As double
Links
StructureStylePlanOption Class, StructureStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStylePlanOption::SymbolBlockZScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties > StructureStylePlanOption::SymbolBlockZScale Property
StructureStylePlanOption::SymbolBlockZScale Property
Collapse All

Gets or sets the Z scale to use when displaying with a block reference in plan view.

C#
public double SymbolBlockZScale;
Visual Basic
Public Property SymbolBlockZScale() As double
Links
StructureStylePlanOption Class, StructureStylePlanOption Members, Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace


StructureStyleProfileOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleProfileOption Class
StructureStyleProfileOption Class
Collapse All

Specifies the method that is used to define and draw the dimensions of the structure in profile view.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleProfileOption
C#
public class StructureStyleProfileOption : StructureStyleOptionBase;
Visual Basic
Public Class StructureStyleProfileOption
Inherits StructureStyleOptionBase
Links
Class Hierarchy


StructureStyleSectionOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleSectionOption Class
StructureStyleSectionOption Class
Collapse All

Specifies the method that is used to define and draw the dimensions of the structure in section view.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleSectionOption
C#
public class StructureStyleSectionOption : StructureStyleOptionBase;
Visual Basic
Public Class StructureStyleSectionOption
Inherits StructureStyleOptionBase
Links
Class Hierarchy


Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums
Structs, Records, Enums
Collapse All

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
InterferenceDisplayStyleType | Specifies the display style type when the Structure is displayed in plan/model/section view.
InterferenceModelSizeOptionType | Specifies the model size option.
InterferenceModelSizeType | Specifies the size of the sphere in model view.
InterferenceModelType | Specifies the type that will be used to visually identify interferences in model view.
PartDataSourceType | Specifies the source type of part data.
PipeCenterlineType | Specifies the method that will be used to define and draw the dimensions of the pipe centerline.
PipeCenterlineWidthType | Specifies the centerline width type.
PipeDisplayStylePlanType | Specifies the display style type when the pipe is displayed in plan view.
PipeDisplayStyleProfileType | Specifies the display style type when the pipe is displayed in profile view.
PipeDisplayStyleSectionType | Specifies the display style type when the pipe is displayed in section view.
PipeEndSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe ends.
PipeHatchStyleProfileType | Specifies the hatch display style type when the pipe is displayed in profile view.
PipeHatchType | Specifies which components of the pipe shape display a hatch pattern.
PipeNetworkDisplayStyleType | Defines ProfileViewPipeNetworkBandStyle display style type.
PipeStylePropertyType | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePropertyType enumeration.
PipeUserDefinedType | Specifies the user defined type.
PipeWallSizeType | Specifies which components of the pipe shape display a hatch pattern.
StructureDisplayStylePlanType | Specifies the display style type when the Structure is displayed in plan view.
StructureDisplayStyleProfileType | Specifies the display style type when the Structure is displayed in profile view.
StructureDisplayStyleSectionType | Specifies the display style type when the Structure is displayed in section view.
StructureInsertionLocation | Specifies the block insertion laction.
StructureModelViewOptionType | Specifies the dimensions of the structure in model view.
StructurePlanViewType | specifies whether the 2D plan view of the structure style is displayed as an outline of the 3D object, or... more
StructureSimpleSolidType | Specifies the simple shape options.
StructureSizeOptionsType | Specifies the size options type.
StructureStylePropertyType | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePropertyType enumeration.
StructureViewType | Specifies the method that will be used to define and draw the dimensions of the structure in profile or section... more
Links
Enumerations


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceDisplayStyleType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceDisplayStyleType Enumeration
Collapse All

Specifies the display style type when the Structure is displayed in plan/model/section view.

C#
public enum InterferenceDisplayStyleType {
  Symbol = AeccDbInterferenceStyle::kDispCompSymbol,
  Solid = AeccDbInterferenceStyle::kDispCompSolid
}
Visual Basic
Public Enum InterferenceDisplayStyleType
  Symbol = AeccDbInterferenceStyle::kDispCompSymbol
  Solid = AeccDbInterferenceStyle::kDispCompSolid
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelSizeOptionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelSizeOptionType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelSizeOptionType Enumeration
Collapse All

Specifies the model size option.

C#
public enum InterferenceModelSizeOptionType {
  UseAbsoluteUnits = AeccDbInterferenceStyle::kUseAbsoluteUnits,
  UseDrawingUnits = AeccDbInterferenceStyle::kUseDrawingScale
}
Visual Basic
Public Enum InterferenceModelSizeOptionType
  UseAbsoluteUnits = AeccDbInterferenceStyle::kUseAbsoluteUnits
  UseDrawingUnits = AeccDbInterferenceStyle::kUseDrawingScale
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelSizeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelSizeType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelSizeType Enumeration
Collapse All

Specifies the size of the sphere in model view.

C#
public enum InterferenceModelSizeType {
  SolidExtents = AeccDbInterferenceStyle::kSolidExtents,
  UserSpecified = AeccDbInterferenceStyle::kUserSpecified
}
Visual Basic
Public Enum InterferenceModelSizeType
  SolidExtents = AeccDbInterferenceStyle::kSolidExtents
  UserSpecified = AeccDbInterferenceStyle::kUserSpecified
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelType Enumeration
Collapse All

Specifies the type that will be used to visually identify interferences in model view.

C#
public enum InterferenceModelType {
  TrueSolid = AeccDbInterferenceStyle::kTrueSolid,
  Sphere = AeccDbInterferenceStyle::kSphere
}
Visual Basic
Public Enum InterferenceModelType
  TrueSolid = AeccDbInterferenceStyle::kTrueSolid
  Sphere = AeccDbInterferenceStyle::kSphere
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartDataSourceType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartDataSourceType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartDataSourceType Enumeration
Collapse All

Specifies the source type of part data.

C#
public enum PartDataSourceType {
  Undefined = AeccNetworkEnums::kSourceUndefined,
  BasicTable = AeccNetworkEnums::kBasicTable,
  FixedList = AeccNetworkEnums::kFixedList,
  RangeList = AeccNetworkEnums::kRangeList,
  Constant = AeccNetworkEnums::kConst,
  Calculation = AeccNetworkEnums::kCalc,
  Optional = AeccNetworkEnums::kRuntimeAppend
}
Visual Basic
Public Enum PartDataSourceType
  Undefined = AeccNetworkEnums::kSourceUndefined
  BasicTable = AeccNetworkEnums::kBasicTable
  FixedList = AeccNetworkEnums::kFixedList
  RangeList = AeccNetworkEnums::kRangeList
  Constant = AeccNetworkEnums::kConst
  Calculation = AeccNetworkEnums::kCalc
  Optional = AeccNetworkEnums::kRuntimeAppend
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeCenterlineType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeCenterlineType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeCenterlineType Enumeration
Collapse All

Specifies the method that will be used to define and draw the dimensions of the pipe centerline.

C#
public enum PipeCenterlineType {
  ByLineWeight = AeccDbPipeStyle::kCenterLineByLineWeight,
  SpecifyWidth = AeccDbPipeStyle::kCenterLineSpecifyWidth
}
Visual Basic
Public Enum PipeCenterlineType
  ByLineWeight = AeccDbPipeStyle::kCenterLineByLineWeight
  SpecifyWidth = AeccDbPipeStyle::kCenterLineSpecifyWidth
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeCenterlineWidthType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeCenterlineWidthType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeCenterlineWidthType Enumeration
Collapse All

Specifies the centerline width type.

C#
public enum PipeCenterlineWidthType {
  DrawToInnerWalls = AeccDbPipeStyle::kCenterLineDrawToInnerWalls,
  DrawToOuterWalls = AeccDbPipeStyle::kCenterLineDrawToOuterWalls,
  UseDrawingScale = AeccDbPipeStyle::kCenterLineUseDrawingScale,
  UseAbsoluteUnits = AeccDbPipeStyle::kCenterLineUseSizeInAbsoluteUnits,
  UseSizeAsPercentageOfScreen = AeccDbPipeStyle::kCenterLineUseSizeAsPercentageOfScreen
}
Visual Basic
Public Enum PipeCenterlineWidthType
  DrawToInnerWalls = AeccDbPipeStyle::kCenterLineDrawToInnerWalls
  DrawToOuterWalls = AeccDbPipeStyle::kCenterLineDrawToOuterWalls
  UseDrawingScale = AeccDbPipeStyle::kCenterLineUseDrawingScale
  UseAbsoluteUnits = AeccDbPipeStyle::kCenterLineUseSizeInAbsoluteUnits
  UseSizeAsPercentageOfScreen = AeccDbPipeStyle::kCenterLineUseSizeAsPercentageOfScreen
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStylePlanType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStylePlanType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStylePlanType Enumeration
Collapse All

Specifies the display style type when the pipe is displayed in plan view.

C#
public enum PipeDisplayStylePlanType {
  Centerline = AeccDbPipeStyle::kDispCompPipeCenterLine,
  InsideWalls = AeccDbPipeStyle::kDispCompPipeInsideWalls,
  OutsideWalls = AeccDbPipeStyle::kDispCompPipeOutsideWalls,
  EndLine = AeccDbPipeStyle::kDispCompPipeEndLine,
  Hatch = AeccDbPipeStyle::kDispCompPipeHatch,
  Solid = AeccDbPipeStyle::kDispCompPipeSolid
}
Visual Basic
Public Enum PipeDisplayStylePlanType
  Centerline = AeccDbPipeStyle::kDispCompPipeCenterLine
  InsideWalls = AeccDbPipeStyle::kDispCompPipeInsideWalls
  OutsideWalls = AeccDbPipeStyle::kDispCompPipeOutsideWalls
  EndLine = AeccDbPipeStyle::kDispCompPipeEndLine
  Hatch = AeccDbPipeStyle::kDispCompPipeHatch
  Solid = AeccDbPipeStyle::kDispCompPipeSolid
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStyleProfileType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStyleProfileType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStyleProfileType Enumeration
Collapse All

Specifies the display style type when the pipe is displayed in profile view.

C#
public enum PipeDisplayStyleProfileType {
  Centerline = AeccDbPipeStyle::kDispCompPipeCenterLine,
  InsideWalls = AeccDbPipeStyle::kDispCompPipeInsideWalls,
  OutsideWalls = AeccDbPipeStyle::kDispCompPipeOutsideWalls,
  EndLine = AeccDbPipeStyle::kDispCompPipeEndLine,
  Hatch = AeccDbPipeStyle::kDispCompPipeHatch,
  CrossingPipeInsideWall = AeccDbPipeStyle::kDispCompCrossingPipeInsideWall,
  CrossingPipeOutsideWall = AeccDbPipeStyle::kDispCompCrossingPipeOutsideWall,
  CrossingPipeHatch = AeccDbPipeStyle::kDispCompCrossingPipeHatch,
  HydraulicGradeLine = AeccDbPipeStyle::kDispCompPipeHGL,
  EnergyGradeLine = AeccDbPipeStyle::kDispCompPipeEGL
}
Visual Basic
Public Enum PipeDisplayStyleProfileType
  Centerline = AeccDbPipeStyle::kDispCompPipeCenterLine
  InsideWalls = AeccDbPipeStyle::kDispCompPipeInsideWalls
  OutsideWalls = AeccDbPipeStyle::kDispCompPipeOutsideWalls
  EndLine = AeccDbPipeStyle::kDispCompPipeEndLine
  Hatch = AeccDbPipeStyle::kDispCompPipeHatch
  CrossingPipeInsideWall = AeccDbPipeStyle::kDispCompCrossingPipeInsideWall
  CrossingPipeOutsideWall = AeccDbPipeStyle::kDispCompCrossingPipeOutsideWall
  CrossingPipeHatch = AeccDbPipeStyle::kDispCompCrossingPipeHatch
  HydraulicGradeLine = AeccDbPipeStyle::kDispCompPipeHGL
  EnergyGradeLine = AeccDbPipeStyle::kDispCompPipeEGL
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStyleSectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStyleSectionType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStyleSectionType Enumeration
Collapse All

Specifies the display style type when the pipe is displayed in section view.

C#
public enum PipeDisplayStyleSectionType {
  CrossingPipeInsideWall = AeccDbPipeStyle::kDispCompCrossingPipeInsideWall,
  CrossingPipeOutsideWall = AeccDbPipeStyle::kDispCompCrossingPipeOutsideWall,
  CrossingPipeHatch = AeccDbPipeStyle::kDispCompCrossingPipeHatch
}
Visual Basic
Public Enum PipeDisplayStyleSectionType
  CrossingPipeInsideWall = AeccDbPipeStyle::kDispCompCrossingPipeInsideWall
  CrossingPipeOutsideWall = AeccDbPipeStyle::kDispCompCrossingPipeOutsideWall
  CrossingPipeHatch = AeccDbPipeStyle::kDispCompCrossingPipeHatch
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeEndSizeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeEndSizeType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeEndSizeType Enumeration
Collapse All

Specifies the method that will be used to define and draw the dimensions of the pipe ends.

C#
public enum PipeEndSizeType {
  DrawToInnerWall = AeccDbPipeStyle::kDrawToInnerWall,
  DrawToOuterWall = AeccDbPipeStyle::kDrawToOuterWall,
  UserDefinedEndSize = AeccDbPipeStyle::kUserDefinedEndSize
}
Visual Basic
Public Enum PipeEndSizeType
  DrawToInnerWall = AeccDbPipeStyle::kDrawToInnerWall
  DrawToOuterWall = AeccDbPipeStyle::kDrawToOuterWall
  UserDefinedEndSize = AeccDbPipeStyle::kUserDefinedEndSize
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeHatchStyleProfileType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeHatchStyleProfileType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeHatchStyleProfileType Enumeration
Collapse All

Specifies the hatch display style type when the pipe is displayed in profile view.

C#
public enum PipeHatchStyleProfileType {
  Hatch = AeccDbPipeStyle::kHatchPipe,
  CrossingPipeHatch = AeccDbPipeStyle::kHatchCrossingPipe
}
Visual Basic
Public Enum PipeHatchStyleProfileType
  Hatch = AeccDbPipeStyle::kHatchPipe
  CrossingPipeHatch = AeccDbPipeStyle::kHatchCrossingPipe
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeHatchType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeHatchType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeHatchType Enumeration
Collapse All

Specifies which components of the pipe shape display a hatch pattern.

C#
public enum PipeHatchType {
  HatchToInnerWalls = AeccDbPipeStyle::kHatchToInnerWalls,
  HatchToOuterWalls = AeccDbPipeStyle::kHatchToOuterWalls,
  HatchWallsOnly = AeccDbPipeStyle::kHatchWallsOnly
}
Visual Basic
Public Enum PipeHatchType
  HatchToInnerWalls = AeccDbPipeStyle::kHatchToInnerWalls
  HatchToOuterWalls = AeccDbPipeStyle::kHatchToOuterWalls
  HatchWallsOnly = AeccDbPipeStyle::kHatchWallsOnly
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeNetworkDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeNetworkDisplayStyleType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeNetworkDisplayStyleType Enumeration
Collapse All

Defines ProfileViewPipeNetworkBandStyle display style type.

C#
public enum PipeNetworkDisplayStyleType {
  Border = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandBorder,
  TitleBox = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandTitleBox,
  TitleBoxText = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandTitleBoxText,
  TicksAtStructureLocation = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandTicksAtStructureLocation,
  TicksAtPipeEnds = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandTicksAtPipeEnds,
  LabelsAtStructureLocation = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandLabelsAtStructureLocation,
  LabelsForPipe = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandLabelsForPipe,
  LinePipeSchematic = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandLinePipeSchematic
}
Visual Basic
Public Enum PipeNetworkDisplayStyleType
  Border = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandBorder
  TitleBox = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandTitleBox
  TitleBoxText = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandTitleBoxText
  TicksAtStructureLocation = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandTicksAtStructureLocation
  TicksAtPipeEnds = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandTicksAtPipeEnds
  LabelsAtStructureLocation = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandLabelsAtStructureLocation
  LabelsForPipe = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandLabelsForPipe
  LinePipeSchematic = AeccDbGraphProfileStylePipeNetworkBand::kDispCompBandLinePipeSchematic
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePropertyType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePropertyType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePropertyType Enumeration
Collapse All

The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePropertyType enumeration.

C#
public enum PipeStylePropertyType {
  InnerDiameter = 1,
  InnerDiameterPercent,
  OuterDiameter,
  OuterDiameterPercent,
  EndLineSize,
  EndLineSizePercent,
  HatchOptions,
  WallSizeType,
  EndSizeType,
  WallSizeOptions,
  EndSizeOptions,
  AlignHatchToPipe,
  PipeToPipeEndCleanup
}
Visual Basic
Public Enum PipeStylePropertyType
  InnerDiameter = 1
  InnerDiameterPercent
  OuterDiameter
  OuterDiameterPercent
  EndLineSize
  EndLineSizePercent
  HatchOptions
  WallSizeType
  EndSizeType
  WallSizeOptions
  EndSizeOptions
  AlignHatchToPipe
  PipeToPipeEndCleanup
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeUserDefinedType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeUserDefinedType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeUserDefinedType Enumeration
Collapse All

Specifies the user defined type.

C#
public enum PipeUserDefinedType {
  UseDrawingScale = AeccDbPipeStyle::kUseDrawingScale,
  UseAbsoluteUnits = AeccDbPipeStyle::kUseAbsoluteUnits,
  UseSizeAsPercentageOfScreen = AeccDbPipeStyle::kUseSizeAsPercentageOfScreen
}
Visual Basic
Public Enum PipeUserDefinedType
  UseDrawingScale = AeccDbPipeStyle::kUseDrawingScale
  UseAbsoluteUnits = AeccDbPipeStyle::kUseAbsoluteUnits
  UseSizeAsPercentageOfScreen = AeccDbPipeStyle::kUseSizeAsPercentageOfScreen
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeWallSizeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeWallSizeType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeWallSizeType Enumeration
Collapse All

Specifies which components of the pipe shape display a hatch pattern.

C#
public enum PipeWallSizeType {
  UsePartDimensions = AeccDbPipeStyle::kUsePartDimensions,
  UserDefinedWallSize = AeccDbPipeStyle::kUserDefinedWallSize
}
Visual Basic
Public Enum PipeWallSizeType
  UsePartDimensions = AeccDbPipeStyle::kUsePartDimensions
  UserDefinedWallSize = AeccDbPipeStyle::kUserDefinedWallSize
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStylePlanType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStylePlanType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStylePlanType Enumeration
Collapse All

Specifies the display style type when the Structure is displayed in plan view.

C#
public enum StructureDisplayStylePlanType {
  Structure = AeccDbStructureStyle::kDispCompStructure,
  StructureHatch = AeccDbStructureStyle::kDispCompStructureHatch,
  Solid = AeccDbStructureStyle::kDispCompStructureSolid
}
Visual Basic
Public Enum StructureDisplayStylePlanType
  Structure = AeccDbStructureStyle::kDispCompStructure
  StructureHatch = AeccDbStructureStyle::kDispCompStructureHatch
  Solid = AeccDbStructureStyle::kDispCompStructureSolid
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStyleProfileType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStyleProfileType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStyleProfileType Enumeration
Collapse All

Specifies the display style type when the Structure is displayed in profile view.

C#
public enum StructureDisplayStyleProfileType {
  Structure = AeccDbStructureStyle::kDispCompStructure,
  StructureHatch = AeccDbStructureStyle::kDispCompStructureHatch,
  StructurePipeOutlines = AeccDbStructureStyle::kDispCompStructurePipeOutlines
}
Visual Basic
Public Enum StructureDisplayStyleProfileType
  Structure = AeccDbStructureStyle::kDispCompStructure
  StructureHatch = AeccDbStructureStyle::kDispCompStructureHatch
  StructurePipeOutlines = AeccDbStructureStyle::kDispCompStructurePipeOutlines
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStyleSectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStyleSectionType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStyleSectionType Enumeration
Collapse All

Specifies the display style type when the Structure is displayed in section view.

C#
public enum StructureDisplayStyleSectionType {
  Structure = AeccDbStructureStyle::kDispCompStructure,
  StructureHatch = AeccDbStructureStyle::kDispCompStructureHatch,
  StructurePipeOutlines = AeccDbStructureStyle::kDispCompStructurePipeOutlines
}
Visual Basic
Public Enum StructureDisplayStyleSectionType
  Structure = AeccDbStructureStyle::kDispCompStructure
  StructureHatch = AeccDbStructureStyle::kDispCompStructureHatch
  StructurePipeOutlines = AeccDbStructureStyle::kDispCompStructurePipeOutlines
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureInsertionLocation Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureInsertionLocation Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureInsertionLocation Enumeration
Collapse All

Specifies the block insertion laction.

C#
public enum StructureInsertionLocation {
  Rim = AeccDbStructureStyle::kRim,
  Sump = AeccDbStructureStyle::kSump
}
Visual Basic
Public Enum StructureInsertionLocation
  Rim = AeccDbStructureStyle::kRim
  Sump = AeccDbStructureStyle::kSump
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureModelViewOptionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureModelViewOptionType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureModelViewOptionType Enumeration
Collapse All

Specifies the dimensions of the structure in model view.

C#
public enum StructureModelViewOptionType {
  UseCatalogDefined3DPart = AeccDbStructureStyle::kCatalog3dPart,
  UseSimple3DPart = AeccDbStructureStyle::kSimple3dPart
}
Visual Basic
Public Enum StructureModelViewOptionType
  UseCatalogDefined3DPart = AeccDbStructureStyle::kCatalog3dPart
  UseSimple3DPart = AeccDbStructureStyle::kSimple3dPart
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructurePlanViewType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructurePlanViewType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructurePlanViewType Enumeration
Collapse All

specifies whether the 2D plan view of the structure style is displayed as an outline of the 3D object, or as an AutoCAD block reference.

C#
public enum StructurePlanViewType {
  UseOuterPartBoundary = AeccDbStructureStyle::kUseOuterPartBoundary,
  UserDefinedPart = AeccDbStructureStyle::kUserDefinedPart
}
Visual Basic
Public Enum StructurePlanViewType
  UseOuterPartBoundary = AeccDbStructureStyle::kUseOuterPartBoundary
  UserDefinedPart = AeccDbStructureStyle::kUserDefinedPart
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureSimpleSolidType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureSimpleSolidType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureSimpleSolidType Enumeration
Collapse All

Specifies the simple shape options.

C#
public enum StructureSimpleSolidType {
  Box = AeccDbStructureStyle::kBox,
  Cylinder = AeccDbStructureStyle::kCylinder,
  Sphere = AeccDbStructureStyle::kSphere,
  PartDefinedShape = AeccDbStructureStyle::kPartDefinedShape
}
Visual Basic
Public Enum StructureSimpleSolidType
  Box = AeccDbStructureStyle::kBox
  Cylinder = AeccDbStructureStyle::kCylinder
  Sphere = AeccDbStructureStyle::kSphere
  PartDefinedShape = AeccDbStructureStyle::kPartDefinedShape
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureSizeOptionsType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureSizeOptionsType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureSizeOptionsType Enumeration
Collapse All

Specifies the size options type.

C#
public enum StructureSizeOptionsType {
  UseDrawingScale = AeccDbStructureStyle::kUseDrawingScale,
  UseFixedScale = AeccDbStructureStyle::kUseFixedScale,
  UseAbsoluteUnits = AeccDbStructureStyle::kUseAbsoluteUnits,
  UseSizeAsPercentageOfScreen = AeccDbStructureStyle::kUseSizeAsPercentageOfScreen,
  UseFixedScaleFromPartSize = AeccDbStructureStyle::kUseFixedScaleFromPartSize
}
Visual Basic
Public Enum StructureSizeOptionsType
  UseDrawingScale = AeccDbStructureStyle::kUseDrawingScale
  UseFixedScale = AeccDbStructureStyle::kUseFixedScale
  UseAbsoluteUnits = AeccDbStructureStyle::kUseAbsoluteUnits
  UseSizeAsPercentageOfScreen = AeccDbStructureStyle::kUseSizeAsPercentageOfScreen
  UseFixedScaleFromPartSize = AeccDbStructureStyle::kUseFixedScaleFromPartSize
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePropertyType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePropertyType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePropertyType Enumeration
Collapse All

The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePropertyType enumeration.

C#
public enum StructureStylePropertyType {
  ViewOptions,
  SizeType,
  BlockInsertLocation,
  SymbolBlockName,
  SymbolBlockXScale,
  SymbolBlockYScale,
  SymbolBlockZScale,
  XSize,
  XSizePercent,
  YSize,
  YSizePercent,
  MaskConnectedObjects
}
Visual Basic
Public Enum StructureStylePropertyType
  ViewOptions
  SizeType
  BlockInsertLocation
  SymbolBlockName
  SymbolBlockXScale
  SymbolBlockYScale
  SymbolBlockZScale
  XSize
  XSizePercent
  YSize
  YSizePercent
  MaskConnectedObjects
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureViewType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureViewType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureViewType Enumeration
Collapse All

Specifies the method that will be used to define and draw the dimensions of the structure in profile or section view.

C#
public enum StructureViewType {
  DisplayAsSolid = AeccDbStructureStyle::kUseSolid,
  DisplayAsBoundary = AeccDbStructureStyle::kUseOuterPartBoundary,
  DisplayAsBlock = AeccDbStructureStyle::kUserDefinedPart
}
Visual Basic
Public Enum StructureViewType
  DisplayAsSolid = AeccDbStructureStyle::kUseSolid
  DisplayAsBoundary = AeccDbStructureStyle::kUseOuterPartBoundary
  DisplayAsBlock = AeccDbStructureStyle::kUserDefinedPart
End Enum


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes
Classes
Collapse All

The following table lists classes in this documentation.

Classes
Class | Description
Interference | Represents one location where elements of a pipe network interfere with each other.
InterferenceCheck | Determines where pipes and structures intersect or are too close to each other, and holds a collection of the resulting... more
Network | The container object used to associate pipes and structures that are part of the same pipe run or pipe network.... more
NetworkCatalogDef | The NetworkCatalogDef class. This class allows you to use a part catalog definition at runtime.
NetworkRule | Holds parameter collections for pipe and structure rules.
Part | A pipe network part, base class for Pipe and Structure classes.
PartDataField | An extensible field of part data.
PartDataList | The part data list associated with a PartDataField or SizeFilterField.
PartDataRange | Defines the range of valid data for a PartDataField.
PartDataRecord | A single data record for a Part object.
PartDef | A part definition for Pipe or Structure objects.
PartViewDef | Contains information about how a part is displayed.
Pipe | A pipe network part serving to move fluids from one point to another.
ProfileViewPart | Manages the graphic display of pipe network parts in profile view.
SectionPipeNetwork | Section view of a pipe network.
Structure | The drawing shape used to represent items such as manholes, catch basins, and headwalls used in utility networks. A Structure... more
Links
Classes


Interference Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class
Interference Class
Collapse All

Represents one location where elements of a pipe network interfere with each other.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Interference
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbInterference"))]
public class Interference : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbInterference"))>
Public Class Interference
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
Interference Properties, Interference Members, Class Hierarchy


Interference Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class > Interference Members
Interference Members
Collapse All

The following tables list the members exposed by Interference.

Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
Network1Id | This is Network1Id, a member of class Interference.
Network2Id | This is Network2Id, a member of class Interference.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


Interference Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class > Interference Properties
Interference Properties
Collapse All

The properties of Interference are listed here.

Public Properties
Public Property | Description
Network1Id | This is Network1Id, a member of class Interference.
Network2Id | This is Network2Id, a member of class Interference.
Links
Public Properties


Interference::Network1Id Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class > Interference Properties > Interference::Network1Id Property
Interference::Network1Id Property
Collapse All

This is Network1Id, a member of class Interference.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Network1Id;
Visual Basic
Public Property Network1Id() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Interference Class, Interference Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Interference::Network2Id Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class > Interference Properties > Interference::Network2Id Property
Interference::Network2Id Property
Collapse All

This is Network2Id, a member of class Interference.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Network2Id;
Visual Basic
Public Property Network2Id() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Interference Class, Interference Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


InterferenceCheck Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > InterferenceCheck Class
InterferenceCheck Class
Collapse All

Determines where pipes and structures intersect or are too close to each other, and holds a collection of the resulting interferences (Interference).

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::InterferenceCheck
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbInterferenceCheck"))]
public class InterferenceCheck : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbInterferenceCheck"))>
Public Class InterferenceCheck
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
Class Hierarchy


Network Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class
Network Class
Collapse All

The container object used to associate pipes and structures that are part of the same pipe run or pipe network.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Network
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetwork"))]
public class Network : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetwork"))>
Public Class Network
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
Network Methods, Network Properties, Network Members, Class Hierarchy


Network Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Members
Network Members
Collapse All

The following tables list the members exposed by Network.

Public Methods
Public Method | Description
AddCurvePipe | Add a curve pipe by using the geometry information of an input curve.
AddLinePipe | Add a line pipe by using the geometry information of an input line.
AddStructure | Overloaded
BreakPipe | Break the specified pipe with a specified existing structure at a point.
Create | Creates a pipe network specified by name.
FindShortestNetworkPath | Find a shortest path in the network.
GetPipeIds | Gets the objectId collection of all pipes belonging to this pipe network.
GetSpanningPipePlanLabelIds | Gets the spanning pipe plan label collection.
GetSpanningPipeProfileLabelIds | Get the spanning pipe profile label collection.
GetStructureIds | Gets the objectId collection of all structures belonging to this pipe network.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
PartsListId | Gets or sets the part list id.
PartsListName | Gets or sets the part list name.
PipeNameTemplate | Gets or sets the pipe name template string.
PipeNetworkSectionLayerId | Gets or sets the pipe network section layer id.
PipeNetworkSectionLayerName | Gets or sets the pipe network section layer name.
PipePlanLabelStyleId | Gets or sets the pipe plan label style id.
PipePlanLabelStyleName | Gets or sets the pipe plan label style name.
PipePlanLayerId | Gets or sets the pipe plan layer id.
PipePlanLayerName | Gets or sets the pipe plan layer name.
PipeProfileLabelStyleId | Gets or sets the pipe profile label style id.
PipeProfileLabelStyleName | Gets or sets the pipe profile label style name.
PipeProfileLayerId | Gets or sets the pipe profile layer id.
PipeProfileLayerName | Gets or sets the pipe profile layer name.
ReferenceAlignmentId | Gets or sets the reference alignment id.
ReferenceAlignmentName | Gets or sets the reference alignment name.
ReferenceSurfaceId | Gets or sets the reference surface id.
ReferenceSurfaceName | Gets or sets the reference surface name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StructureNameTemplate | Gets or sets the structure name template string.
StructurePlanLabelStyleId | Gets or sets the structure plan label style id.
StructurePlanLabelStyleName | Gets or sets the structure plan label style name.
StructurePlanLayerId | Gets or sets the structure plan layer id.
StructurePlanLayerName | Gets or sets the structure plan layer name.
StructureProfileLabelStyleId | Gets or sets the structure profile label style id.
StructureProfileLabelStyleName | Gets or sets the structure profile label style name.
StructureProfileLayerId | Gets or sets the structure profile layer id.
StructureProfileLayerName | Gets or sets the structure profile layer name.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


Network Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods
Network Methods
Collapse All

The methods of Network are listed here.

Public Methods
Public Method | Description
AddCurvePipe | Add a curve pipe by using the geometry information of an input curve.
AddLinePipe | Add a line pipe by using the geometry information of an input line.
AddStructure | Overloaded
BreakPipe | Break the specified pipe with a specified existing structure at a point.
Create | Creates a pipe network specified by name.
FindShortestNetworkPath | Find a shortest path in the network.
GetPipeIds | Gets the objectId collection of all pipes belonging to this pipe network.
GetSpanningPipePlanLabelIds | Gets the spanning pipe plan label collection.
GetSpanningPipeProfileLabelIds | Get the spanning pipe profile label collection.
GetStructureIds | Gets the objectId collection of all structures belonging to this pipe network.
Links
Public Methods


Network::AddCurvePipe Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > Network::AddCurvePipe Method
Network::AddCurvePipe Method
Collapse All

Add a curve pipe by using the geometry information of an input curve.

C#
public AddCurvePipe(
    Autodesk::AutoCAD::DatabaseServices::ObjectId pipeFamilyId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId pipeSizeId,
    ref Autodesk::AutoCAD::Geometry::Curve3d curve,
    bool clockwise,
    Autodesk::AutoCAD::DatabaseServices::ObjectId% newPipeId,
    bool applyRules
);
Visual Basic
Public Sub AddCurvePipe(
    pipeFamilyId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    pipeSizeId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef curve As Autodesk::AutoCAD::Geometry::Curve3d,
    clockwise As bool,
    newPipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId%,
    applyRules As bool
)
Parameters
Parameters | Description
pipeFamilyId | Pipe family id.
pipeSizeId | Object id of the Pipe Size.
curve | The curve which supplies the geometry information.
clockwise | Returns true if the new pipe has clockwise direction, false otherwise.
newPipeId | Returns the object id of the newly added pipe.
applyRules | Returns whether the method needed to apply rules.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::AddLinePipe Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > Network::AddLinePipe Method
Network::AddLinePipe Method
Collapse All

Add a line pipe by using the geometry information of an input line.

C#
public AddLinePipe(
    Autodesk::AutoCAD::DatabaseServices::ObjectId pipeFamilyId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId pipeSizeId,
    ref Autodesk::AutoCAD::Geometry::LineSegment3d line,
    Autodesk::AutoCAD::DatabaseServices::ObjectId% newPipeId,
    bool applyRules
);
Visual Basic
Public Sub AddLinePipe(
    pipeFamilyId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    pipeSizeId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef line As Autodesk::AutoCAD::Geometry::LineSegment3d,
    newPipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId%,
    applyRules As bool
)
Parameters
Parameters | Description
pipeFamilyId | Pipe family id.
pipeSizeId | Object id of the Pipe Size.
line | The line which supplies the geometry information.
newPipeId | Returns the object id of the added new pipe.
applyRules | Returns whether the method needed to apply rules.
Example
ObjectIdCollection oIdCollection = doc.GetPipeNetworkIds();
// Get the first network in the document
ObjectId objId = oIdCollection[0];
Network oNetwork = ts.GetObject(objId, OpenMode.ForWrite) as Network;
ed.WriteMessage("Pipe Network: {0}n", oNetwork.Name);
// Go through the list of part types and select the first pipe found
ObjectId pid = oNetwork.PartsListId;
PartsList pl = ts.GetObject(pid, OpenMode.ForWrite) as PartsList;

ObjectId oid = pl["Concrete Pipe"];
PartFamily pfa = ts.GetObject(oid, OpenMode.ForWrite) as PartFamily;
ObjectId psize = pfa[0];
LineSegment3d line = new LineSegment3d(new Point3d(30, 9, 0), new Point3d(33, 7, 0));
ObjectIdCollection col = oNetwork.GetPipeIds();
ObjectId oidNewPipe = ObjectId.Null;

oNetwork.AddLinePipe(oid, psize, line, ref oidNewPipe, false);
Pipe oNewPipe = ts.GetObject(oidNewPipe, OpenMode.ForRead) as Pipe;
ed.WriteMessage("Pipe created: {0}n", oNewPipe.DisplayName);
ts.Commit();
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


AddStructure Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > AddStructure Method
AddStructure Method
Collapse All

Overloaded

Overload List
Method | Description
Network::AddStructure (Autodesk::AutoCAD::DatabaseServices::ObjectId) | Add an existing structure into the network.
Network::AddStructure (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::Geometry::Point3d, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%, bool) | Create and add a new structure into the network.


Network::AddStructure Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > AddStructure Method > Network::AddStructure Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Network::AddStructure Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Add an existing structure into the network.

C#
public AddStructure(
    Autodesk::AutoCAD::DatabaseServices::ObjectId structureId
);
Visual Basic
Public Sub AddStructure(
    structureId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
structureId | The Object Id for the structure to add.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::AddStructure Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::Geometry::Point3d, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%, bool)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > AddStructure Method > Network::AddStructure Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::Geometry::Point3d, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%, bool)
Network::AddStructure Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::Geometry::Point3d, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%, bool)
Collapse All

Create and add a new structure into the network.

C#
public AddStructure(
    Autodesk::AutoCAD::DatabaseServices::ObjectId structureFamilyId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId structureSizeId,
    Autodesk::AutoCAD::Geometry::Point3d location,
    double rotation,
    Autodesk::AutoCAD::DatabaseServices::ObjectId% newStructureId,
    bool applyRules
);
Visual Basic
Public Sub AddStructure(
    structureFamilyId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    structureSizeId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    location As Autodesk::AutoCAD::Geometry::Point3d,
    rotation As double,
    newStructureId As Autodesk::AutoCAD::DatabaseServices::ObjectId%,
    applyRules As bool
)
Parameters
Parameters | Description
structureFamilyId | Structure family id.
structureSizeId | Object id for the Structure Size.
location | The location of the newly added structure.
rotation | The rotation of new added structure.
newStructureId | Returns the object id of the newly added structure.
applyRules | Returns whether the method needed to apply rules.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::BreakPipe Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > Network::BreakPipe Method
Network::BreakPipe Method
Collapse All

Break the specified pipe with a specified existing structure at a point.

C#
public BreakPipe(
    Autodesk::AutoCAD::DatabaseServices::ObjectId pipeIdToBreak,
    Autodesk::AutoCAD::Geometry::Point3d breakPoint,
    Autodesk::AutoCAD::DatabaseServices::ObjectId existingStructureId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId% newPipeId
);
Visual Basic
Public Sub BreakPipe(
    pipeIdToBreak As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    breakPoint As Autodesk::AutoCAD::Geometry::Point3d,
    existingStructureId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    newPipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId%
)
Parameters
Parameters | Description
pipeIdToBreak | The pipe to break.
breakPoint | Break point on pipe.
existingStructureId | The existing Structure to place at the break point.
newPipeId | Returns the object id of the newly added pipe created by the break.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::Create Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > Network::Create Method
Network::Create Method
Collapse All

Creates a pipe network specified by name.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Create(
    ref Autodesk::Civil::ApplicationServices::CivilDocument document,
    System::String^% networkName
);
Visual Basic
Public Function Create(
    ByRef document As Autodesk::Civil::ApplicationServices::CivilDocument,
    networkName As System::String^%
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
document | CivilDocument object in which the network is created.
networkName | The name of the new pipe network. If the name is duplicated, it is changed to a new name (see remarks below).
Remarks

If the name (such as "abc") is a duplicate of an existing network, the name is changed to "abc (n)". The value of n is an integer that increments until the name "abc (n)" is unique.

Exceptions
Exceptions
Description
System.ArgumentException
Thrown when the input string:

  1. Includes any of these special symbols: '', '"', ',', '/', ';', '?', '*', ':', '='.
  2. Only contains whitespace.

Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::FindShortestNetworkPath Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > Network::FindShortestNetworkPath Method
Network::FindShortestNetworkPath Method
Collapse All

Find a shortest path in the network.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection FindShortestNetworkPath(
    Autodesk::AutoCAD::DatabaseServices::ObjectId startPartId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId endPartId,
    double% minLength
);
Visual Basic
Public Function FindShortestNetworkPath(
    startPartId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    endPartId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    minLength As double%
) As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Parameters
Parameters | Description
startPartId | Starting part for the path.
endPartId | Ending part for the path.
minLength | Returns the length of the shortest path.
Returns

An ObjectIdCollection that contains the ObjectId for each parth in the shortest path.

Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::GetPipeIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > Network::GetPipeIds Method
Network::GetPipeIds Method
Collapse All

Gets the objectId collection of all pipes belonging to this pipe network.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetPipeIds();
Visual Basic
Public Function GetPipeIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::GetSpanningPipePlanLabelIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > Network::GetSpanningPipePlanLabelIds Method
Network::GetSpanningPipePlanLabelIds Method
Collapse All

Gets the spanning pipe plan label collection.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetSpanningPipePlanLabelIds();
Visual Basic
Public Function GetSpanningPipePlanLabelIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::GetSpanningPipeProfileLabelIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > Network::GetSpanningPipeProfileLabelIds Method
Network::GetSpanningPipeProfileLabelIds Method
Collapse All

Get the spanning pipe profile label collection.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetSpanningPipeProfileLabelIds();
Visual Basic
Public Function GetSpanningPipeProfileLabelIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::GetStructureIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods > Network::GetStructureIds Method
Network::GetStructureIds Method
Collapse All

Gets the objectId collection of all structures belonging to this pipe network.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetStructureIds();
Visual Basic
Public Function GetStructureIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties
Network Properties
Collapse All

The properties of Network are listed here.

Public Properties
Public Property | Description
PartsListId | Gets or sets the part list id.
PartsListName | Gets or sets the part list name.
PipeNameTemplate | Gets or sets the pipe name template string.
PipeNetworkSectionLayerId | Gets or sets the pipe network section layer id.
PipeNetworkSectionLayerName | Gets or sets the pipe network section layer name.
PipePlanLabelStyleId | Gets or sets the pipe plan label style id.
PipePlanLabelStyleName | Gets or sets the pipe plan label style name.
PipePlanLayerId | Gets or sets the pipe plan layer id.
PipePlanLayerName | Gets or sets the pipe plan layer name.
PipeProfileLabelStyleId | Gets or sets the pipe profile label style id.
PipeProfileLabelStyleName | Gets or sets the pipe profile label style name.
PipeProfileLayerId | Gets or sets the pipe profile layer id.
PipeProfileLayerName | Gets or sets the pipe profile layer name.
ReferenceAlignmentId | Gets or sets the reference alignment id.
ReferenceAlignmentName | Gets or sets the reference alignment name.
ReferenceSurfaceId | Gets or sets the reference surface id.
ReferenceSurfaceName | Gets or sets the reference surface name.
StructureNameTemplate | Gets or sets the structure name template string.
StructurePlanLabelStyleId | Gets or sets the structure plan label style id.
StructurePlanLabelStyleName | Gets or sets the structure plan label style name.
StructurePlanLayerId | Gets or sets the structure plan layer id.
StructurePlanLayerName | Gets or sets the structure plan layer name.
StructureProfileLabelStyleId | Gets or sets the structure profile label style id.
StructureProfileLabelStyleName | Gets or sets the structure profile label style name.
StructureProfileLayerId | Gets or sets the structure profile layer id.
StructureProfileLayerName | Gets or sets the structure profile layer name.
Links
Public Properties


Network::PartsListId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PartsListId Property
Network::PartsListId Property
Collapse All

Gets or sets the part list id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PartsListId;
Visual Basic
Public Property PartsListId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.Civil.PipeNetwork.DatabaseServices.Styles.PartsList

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the parts list Id is invalid.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PartsListName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PartsListName Property
Network::PartsListName Property
Collapse All

Gets or sets the part list name.

C#
public System::String PartsListName;
Visual Basic
Public Property PartsListName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the parts list name is invalid.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipeNameTemplate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipeNameTemplate Property
Network::PipeNameTemplate Property
Collapse All

Gets or sets the pipe name template string.

C#
public System::String PipeNameTemplate;
Visual Basic
Public Property PipeNameTemplate() As System::String
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when the input string:

  1. Includes any of these special symbols: '', '"', ',', '/', ';', '?', '*'.
  2. Only contains whitespace.

Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipeNetworkSectionLayerId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipeNetworkSectionLayerId Property
Network::PipeNetworkSectionLayerId Property
Collapse All

Gets or sets the pipe network section layer id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PipeNetworkSectionLayerId;
Visual Basic
Public Property PipeNetworkSectionLayerId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipeNetworkSectionLayerName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipeNetworkSectionLayerName Property
Network::PipeNetworkSectionLayerName Property
Collapse All

Gets or sets the pipe network section layer name.

C#
public System::String PipeNetworkSectionLayerName;
Visual Basic
Public Property PipeNetworkSectionLayerName() As System::String
Remarks

ObjectId type: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord

Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipePlanLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipePlanLabelStyleId Property
Network::PipePlanLabelStyleId Property
Collapse All

Gets or sets the pipe plan label style id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PipePlanLabelStyleId;
Visual Basic
Public Property PipePlanLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not Autodesk.Civil.DatabaseServices.Styles.LabelStyle.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipePlanLabelStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipePlanLabelStyleName Property
Network::PipePlanLabelStyleName Property
Collapse All

Gets or sets the pipe plan label style name.

C#
public System::String PipePlanLabelStyleName;
Visual Basic
Public Property PipePlanLabelStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name for a LabelStyle that doesn't exist.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipePlanLayerId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipePlanLayerId Property
Network::PipePlanLayerId Property
Collapse All

Gets or sets the pipe plan layer id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PipePlanLayerId;
Visual Basic
Public Property PipePlanLayerId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord

Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipePlanLayerName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipePlanLayerName Property
Network::PipePlanLayerName Property
Collapse All

Gets or sets the pipe plan layer name.

C#
public System::String PipePlanLayerName;
Visual Basic
Public Property PipePlanLayerName() As System::String
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipeProfileLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipeProfileLabelStyleId Property
Network::PipeProfileLabelStyleId Property
Collapse All

Gets or sets the pipe profile label style id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PipeProfileLabelStyleId;
Visual Basic
Public Property PipeProfileLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id which type is not Autodesk.Civil.DatabaseServices.Styles.LabelStyle.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipeProfileLabelStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipeProfileLabelStyleName Property
Network::PipeProfileLabelStyleName Property
Collapse All

Gets or sets the pipe profile label style name.

C#
public System::String PipeProfileLabelStyleName;
Visual Basic
Public Property PipeProfileLabelStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name for a LabelStyle that doesn't exist.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipeProfileLayerId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipeProfileLayerId Property
Network::PipeProfileLayerId Property
Collapse All

Gets or sets the pipe profile layer id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PipeProfileLayerId;
Visual Basic
Public Property PipeProfileLayerId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord

Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::PipeProfileLayerName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::PipeProfileLayerName Property
Network::PipeProfileLayerName Property
Collapse All

Gets or sets the pipe profile layer name.

C#
public System::String PipeProfileLayerName;
Visual Basic
Public Property PipeProfileLayerName() As System::String
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::ReferenceAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::ReferenceAlignmentId Property
Network::ReferenceAlignmentId Property
Collapse All

Gets or sets the reference alignment id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ReferenceAlignmentId;
Visual Basic
Public Property ReferenceAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.Civil.Land.DatabaseServices.Alignment

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id that isn't type Autodesk.Civil.Land.DatabaseServices.Surface.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::ReferenceAlignmentName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::ReferenceAlignmentName Property
Network::ReferenceAlignmentName Property
Collapse All

Gets or sets the reference alignment name.

C#
public System::String ReferenceAlignmentName;
Visual Basic
Public Property ReferenceAlignmentName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name that doens't match any existing Alignment name.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::ReferenceSurfaceId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::ReferenceSurfaceId Property
Network::ReferenceSurfaceId Property
Collapse All

Gets or sets the reference surface id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ReferenceSurfaceId;
Visual Basic
Public Property ReferenceSurfaceId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.Civil.Land.DatabaseServices.Surface

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id that isn't type Autodesk.Civil.Land.DatabaseServices.Surface.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::ReferenceSurfaceName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::ReferenceSurfaceName Property
Network::ReferenceSurfaceName Property
Collapse All

Gets or sets the reference surface name.

C#
public System::String ReferenceSurfaceName;
Visual Basic
Public Property ReferenceSurfaceName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when no existing Surface matches the name.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::StructureNameTemplate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::StructureNameTemplate Property
Network::StructureNameTemplate Property
Collapse All

Gets or sets the structure name template string.

C#
public System::String StructureNameTemplate;
Visual Basic
Public Property StructureNameTemplate() As System::String
Exceptions
Exceptions
Description
System.ArgumentException
Thrown when the input string:

  1. Includes special symbols: '', '"', ',', '/', ';', '?', '*'.
  2. Only has whitespace symbols.

Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::StructurePlanLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::StructurePlanLabelStyleId Property
Network::StructurePlanLabelStyleId Property
Collapse All

Gets or sets the structure plan label style id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StructurePlanLabelStyleId;
Visual Basic
Public Property StructurePlanLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an ObjectId for an object that isn't type Autodesk.Civil.DatabaseServices.Styles.LabelStyle.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::StructurePlanLabelStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::StructurePlanLabelStyleName Property
Network::StructurePlanLabelStyleName Property
Collapse All

Gets or sets the structure plan label style name.

C#
public System::String StructurePlanLabelStyleName;
Visual Basic
Public Property StructurePlanLabelStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name for a LabelStyle that doesn't exist.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::StructurePlanLayerId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::StructurePlanLayerId Property
Network::StructurePlanLayerId Property
Collapse All

Gets or sets the structure plan layer id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StructurePlanLayerId;
Visual Basic
Public Property StructurePlanLayerId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord

Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::StructurePlanLayerName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::StructurePlanLayerName Property
Network::StructurePlanLayerName Property
Collapse All

Gets or sets the structure plan layer name.

C#
public System::String StructurePlanLayerName;
Visual Basic
Public Property StructurePlanLayerName() As System::String
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::StructureProfileLabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::StructureProfileLabelStyleId Property
Network::StructureProfileLabelStyleId Property
Collapse All

Gets or sets the structure profile label style id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StructureProfileLabelStyleId;
Visual Basic
Public Property StructureProfileLabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.Civil.DatabaseServices.Styles.LabelStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object id that isn't type Autodesk.Civil.DatabaseServices.Styles.LabelStyle.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::StructureProfileLabelStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::StructureProfileLabelStyleName Property
Network::StructureProfileLabelStyleName Property
Collapse All

Gets or sets the structure profile label style name.

C#
public System::String StructureProfileLabelStyleName;
Visual Basic
Public Property StructureProfileLabelStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when setting the property with an object name for a LabelStyle that doesn't exist.
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::StructureProfileLayerId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::StructureProfileLayerId Property
Network::StructureProfileLayerId Property
Collapse All

Gets or sets the structure profile layer id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StructureProfileLayerId;
Visual Basic
Public Property StructureProfileLayerId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

ObjectId type: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord

Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Network::StructureProfileLayerName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties > Network::StructureProfileLayerName Property
Network::StructureProfileLayerName Property
Collapse All

Gets or sets the structure profile layer name.

C#
public System::String StructureProfileLayerName;
Visual Basic
Public Property StructureProfileLayerName() As System::String
Links
Network Class, Network Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


NetworkCatalogDef Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class
NetworkCatalogDef Class
Collapse All

The NetworkCatalogDef class. This class allows you to use a part catalog definition at runtime.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::NetworkCatalogDef
C#
public class NetworkCatalogDef;
Visual Basic
Public Class NetworkCatalogDef
Links
NetworkCatalogDef Methods, NetworkCatalogDef Members, Class Hierarchy


NetworkCatalogDef Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class > NetworkCatalogDef Members
NetworkCatalogDef Members
Collapse All

The following tables list the members exposed by NetworkCatalogDef.

Public Methods
Public Method | Description
DeclareNewParameter | Declares a new part catalog parameter
DeclarePartProperty | Declares a new part property.
Links
Public Methods


NetworkCatalogDef Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class > NetworkCatalogDef Methods
NetworkCatalogDef Methods
Collapse All

The methods of NetworkCatalogDef are listed here.

Public Methods
Public Method | Description
DeclareNewParameter | Declares a new part catalog parameter
DeclarePartProperty | Declares a new part property.
Links
Public Methods


NetworkCatalogDef::DeclareNewParameter Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class > NetworkCatalogDef Methods > NetworkCatalogDef::DeclareNewParameter Method
NetworkCatalogDef::DeclareNewParameter Method
Collapse All

Declares a new part catalog parameter

C#
public DeclareNewParameter(
    ref System::String globalContext,
    ref System::String displayContext,
    ref System::String paramName,
    ref System::String paramDesc,
    PartCatalogDataType dataType,
    PartParamUsageType usage,
    ref System::String defaultUnits,
    bool singleton,
    bool catManagedList
);
Visual Basic
Public Sub DeclareNewParameter(
    ByRef globalContext As System::String,
    ByRef displayContext As System::String,
    ByRef paramName As System::String,
    ByRef paramDesc As System::String,
    dataType As PartCatalogDataType,
    usage As PartParamUsageType,
    ByRef defaultUnits As System::String,
    singleton As bool,
    catManagedList As bool
)
Parameters
Parameters | Description
globalContext | Specifies the parameter's global context, which should be already declared.
displayContext | Specifies the display string of the parameter's context.
paramName | Specifies the parameter's name.
paramDesc | Specifies a description for the parameter.
dataType | Specifies the parameter's value data type.
usage | Specifies the parameter's usage.
defaultUnits | Specifies the parameter's default units.
singleton | Specifies if the parameter is a singleton.
catManagedList | Specifies if the parameter belongs to a managed list.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when input string is blank or when the input context is not declared yet.
Links
NetworkCatalogDef Class, NetworkCatalogDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


NetworkCatalogDef::DeclarePartProperty Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class > NetworkCatalogDef Methods > NetworkCatalogDef::DeclarePartProperty Method
NetworkCatalogDef::DeclarePartProperty Method
Collapse All

Declares a new part property.

C#
public DeclarePartProperty(
    ref System::String globalContext,
    DomainType domain,
    PartType partType
);
Visual Basic
Public Sub DeclarePartProperty(
    ByRef globalContext As System::String,
    domain As DomainType,
    partType As PartType
)
Parameters
Parameters | Description
globalContext | Specifies the parameter's global context, which should already exist.
domain | Specifies the part's domain.
partType | Specifies the part's type.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when a part property already exists.
Links
NetworkCatalogDef Class, NetworkCatalogDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


NetworkRule Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class
NetworkRule Class
Collapse All

Holds parameter collections for pipe and structure rules.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::PipeNetwork::DatabaseServices::NetworkRule
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkRule"))]
public class NetworkRule : Autodesk::Civil::DatabaseServices::DBObject;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkRule"))>
Public Class NetworkRule
Inherits Autodesk::Civil::DatabaseServices::DBObject
Links
NetworkRule Properties, NetworkRule Members, Class Hierarchy


NetworkRule Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class > NetworkRule Members
NetworkRule Members
Collapse All

The following tables list the members exposed by NetworkRule.

Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
Name | Gets or sets the name.
ParamsDouble | Gets the Double parameters collection.
ParamsLong | Gets the Long parameters collection.
Links
Public Properties


NetworkRule Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class > NetworkRule Properties
NetworkRule Properties
Collapse All

The properties of NetworkRule are listed here.

Public Properties
Public Property | Description
ParamsDouble | Gets the Double parameters collection.
ParamsLong | Gets the Long parameters collection.
Links
Public Properties


NetworkRule::ParamsDouble Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class > NetworkRule Properties > NetworkRule::ParamsDouble Property
NetworkRule::ParamsDouble Property
Collapse All

Gets the Double parameters collection.

C#
public Autodesk::Civil::Runtime::ParamDoubleCollection ParamsDouble;
Visual Basic
Public Property ParamsDouble() As Autodesk::Civil::Runtime::ParamDoubleCollection
Links
NetworkRule Class, NetworkRule Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


NetworkRule::ParamsLong Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class > NetworkRule Properties > NetworkRule::ParamsLong Property
NetworkRule::ParamsLong Property
Collapse All

Gets the Long parameters collection.

C#
public Autodesk::Civil::Runtime::ParamLongCollection ParamsLong;
Visual Basic
Public Property ParamsLong() As Autodesk::Civil::Runtime::ParamLongCollection
Links
NetworkRule Class, NetworkRule Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class
Part Class
Collapse All

A pipe network part, base class for Pipe and Structure classes.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Part
            Autodesk::Civil::PipeNetwork::DatabaseServices::Pipe
            Autodesk::Civil::PipeNetwork::DatabaseServices::Structure
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkPart"))]
public class Part : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkPart"))>
Public Class Part
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Links
Part Methods, Part Properties, Part Members, Class Hierarchy


Part Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Members
Part Members
Collapse All

The following tables list the members exposed by Part.

Public Methods
Public Method | Description
AddToProfileView | Draws the part into the specified profile view.
AddToSectionView | Draws the part into the specified section view.
GetOverriddenRuleIds | Gets the overridden Rule ids which this part contains.
GetProfileViewsDisplayingMe | Gets the object id collection of all the profile views in which this part was drawn.
GetSectionViewsDisplayingMe | Gets the object id collection of all the section views in which this part was drawn.
RemoveFromAllProfileViews | Remove the part from all the profile views in which it is drawn.
RemoveFromAllSectionViews | Removes the part from all the section views in which it is drawn.
RemoveFromProfileView | Remove the part from the specified profile view in which it is drawn.
RemoveFromSectionView | Removes the part from the specified section view in which it is drawn.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
ConnectedPartCount | Gets the number of parts that connects to the part
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Domain | Gets the part's domain.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Material | Gets the material defined for this part.
Name | Gets part's name.
NetworkId | Gets the object id of the network to which this part belongs
NetworkName | Gets the name of the network to which this part belongs
OverrideRuleSet | Gets or sets whether to use overridden rules.
ParamsBool | Gets the boolean parameters collection.
ParamsDouble | Gets the double parameters collection.
ParamsLong | Gets the long parameters collection.
ParamsString | Gets the string parameters collection.
PartData | Gets or sets the part data record.
PartDefId | Gets the object id of PartDef.
PartDescription | Gets the part’s description.
PartSizeName | Gets the part size name.
PartSubType | Gets the part’s subtype.
PartType | Gets the type of the network park.
Position | Gets or sets the position of the network part.
ProfileViewPartId | Gets the object id of the part's counterpart in profile views.
RefAlignmentId | Gets or sets the object id of the alignment which this part references.
RefAlignmentName | Gets the name of the alignment which this part references
RefSurfaceId | Gets or sets the object id of the surface that this part references.
RefSurfaceName | Gets the name of the surface which this part references.
RuleSetStyleId | Gets or sets the object id of RuleSetStyle.
RuleSetStyleName | Gets or sets RuleSetStyle by name.
SectionViewPartId | Gets the object id of the part's counterpart in section views.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
Solid3dBody | Gets the 3d solid body of the part.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
SurfaceId | Gets or sets the object id of the surface that this part references.
WallThickness | Gets the wall thickness for this structure, measured from the inside edge of the structure to the outside edge of... more
Links
Public Methods, Public Properties


Part Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods
Part Methods
Collapse All

The methods of Part are listed here.

Public Methods
Public Method | Description
AddToProfileView | Draws the part into the specified profile view.
AddToSectionView | Draws the part into the specified section view.
GetOverriddenRuleIds | Gets the overridden Rule ids which this part contains.
GetProfileViewsDisplayingMe | Gets the object id collection of all the profile views in which this part was drawn.
GetSectionViewsDisplayingMe | Gets the object id collection of all the section views in which this part was drawn.
RemoveFromAllProfileViews | Remove the part from all the profile views in which it is drawn.
RemoveFromAllSectionViews | Removes the part from all the section views in which it is drawn.
RemoveFromProfileView | Remove the part from the specified profile view in which it is drawn.
RemoveFromSectionView | Removes the part from the specified section view in which it is drawn.
Links
Public Methods


Part::AddToProfileView Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods > Part::AddToProfileView Method
Part::AddToProfileView Method
Collapse All

Draws the part into the specified profile view.

C#
public AddToProfileView(
    Autodesk::AutoCAD::DatabaseServices::ObjectId profileViewId
);
Visual Basic
Public Sub AddToProfileView(
    profileViewId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
profileViewId | The ObjectId of the target profile view.
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::AddToSectionView Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods > Part::AddToSectionView Method
Part::AddToSectionView Method
Collapse All

Draws the part into the specified section view.

C#
public AddToSectionView(
    Autodesk::AutoCAD::DatabaseServices::ObjectId sectionViewId
);
Visual Basic
Public Sub AddToSectionView(
    sectionViewId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
profileViewId | The ObjectId of the target section view.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input is not a valid object id for a section view.
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::GetOverriddenRuleIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods > Part::GetOverriddenRuleIds Method
Part::GetOverriddenRuleIds Method
Collapse All

Gets the overridden Rule ids which this part contains.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetOverriddenRuleIds();
Visual Basic
Public Function GetOverriddenRuleIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when OverrideRuleSet is false.
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::GetProfileViewsDisplayingMe Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods > Part::GetProfileViewsDisplayingMe Method
Part::GetProfileViewsDisplayingMe Method
Collapse All

Gets the object id collection of all the profile views in which this part was drawn.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetProfileViewsDisplayingMe();
Visual Basic
Public Function GetProfileViewsDisplayingMe() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.ProfileView

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::GetSectionViewsDisplayingMe Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods > Part::GetSectionViewsDisplayingMe Method
Part::GetSectionViewsDisplayingMe Method
Collapse All

Gets the object id collection of all the section views in which this part was drawn.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetSectionViewsDisplayingMe();
Visual Basic
Public Function GetSectionViewsDisplayingMe() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.SectionView

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RemoveFromAllProfileViews Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods > Part::RemoveFromAllProfileViews Method
Part::RemoveFromAllProfileViews Method
Collapse All

Remove the part from all the profile views in which it is drawn.

C#
public RemoveFromAllProfileViews();
Visual Basic
Public Sub RemoveFromAllProfileViews()
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RemoveFromAllSectionViews Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods > Part::RemoveFromAllSectionViews Method
Part::RemoveFromAllSectionViews Method
Collapse All

Removes the part from all the section views in which it is drawn.

C#
public RemoveFromAllSectionViews();
Visual Basic
Public Sub RemoveFromAllSectionViews()
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RemoveFromProfileView Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods > Part::RemoveFromProfileView Method
Part::RemoveFromProfileView Method
Collapse All

Remove the part from the specified profile view in which it is drawn.

C#
public RemoveFromProfileView(
    Autodesk::AutoCAD::DatabaseServices::ObjectId profileViewId
);
Visual Basic
Public Sub RemoveFromProfileView(
    profileViewId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
profileViewId | The ObjectId of the target profile view.
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RemoveFromSectionView Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods > Part::RemoveFromSectionView Method
Part::RemoveFromSectionView Method
Collapse All

Removes the part from the specified section view in which it is drawn.

C#
public RemoveFromSectionView(
    Autodesk::AutoCAD::DatabaseServices::ObjectId sectionViewId
);
Visual Basic
Public Sub RemoveFromSectionView(
    sectionViewId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
profileViewId | The ObjectId of the target section view.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input is not a valid object id of section view.
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties
Part Properties
Collapse All

The properties of Part are listed here.

Public Properties
Public Property | Description
ConnectedPartCount | Gets the number of parts that connects to the part
Domain | Gets the part's domain.
Material | Gets the material defined for this part.
Name | Gets part's name.
NetworkId | Gets the object id of the network to which this part belongs
NetworkName | Gets the name of the network to which this part belongs
OverrideRuleSet | Gets or sets whether to use overridden rules.
ParamsBool | Gets the boolean parameters collection.
ParamsDouble | Gets the double parameters collection.
ParamsLong | Gets the long parameters collection.
ParamsString | Gets the string parameters collection.
PartData | Gets or sets the part data record.
PartDefId | Gets the object id of PartDef.
PartDescription | Gets the part’s description.
PartSizeName | Gets the part size name.
PartSubType | Gets the part’s subtype.
PartType | Gets the type of the network park.
Position | Gets or sets the position of the network part.
ProfileViewPartId | Gets the object id of the part's counterpart in profile views.
RefAlignmentId | Gets or sets the object id of the alignment which this part references.
RefAlignmentName | Gets the name of the alignment which this part references
RefSurfaceId | Gets or sets the object id of the surface that this part references.
RefSurfaceName | Gets the name of the surface which this part references.
RuleSetStyleId | Gets or sets the object id of RuleSetStyle.
RuleSetStyleName | Gets or sets RuleSetStyle by name.
SectionViewPartId | Gets the object id of the part's counterpart in section views.
Solid3dBody | Gets the 3d solid body of the part.
SurfaceId | Gets or sets the object id of the surface that this part references.
WallThickness | Gets the wall thickness for this structure, measured from the inside edge of the structure to the outside edge of... more
Links
Public Properties


Part::ConnectedPartCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::ConnectedPartCount Property
Part::ConnectedPartCount Property
Collapse All

Gets the number of parts that connects to the part

C#
public int ConnectedPartCount;
Visual Basic
Public Property ConnectedPartCount() As Integer
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::Domain Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::Domain Property
Part::Domain Property
Collapse All

Gets the part's domain.

C#
public DomainType Domain;
Visual Basic
Public Property Domain() As DomainType
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::Material Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::Material Property
Part::Material Property
Collapse All

Gets the material defined for this part.

C#
public System::String Material;
Visual Basic
Public Property Material() As System::String
Remarks

This optional property is used mainly for labeling purposes. It allows you to identify the type of material used to construct this part.

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::Name Property
Part::Name Property
Collapse All

Gets part's name.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::NetworkId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::NetworkId Property
Part::NetworkId Property
Collapse All

Gets the object id of the network to which this part belongs

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId NetworkId;
Visual Basic
Public Property NetworkId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.Network

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::NetworkName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::NetworkName Property
Part::NetworkName Property
Collapse All

Gets the name of the network to which this part belongs

C#
public System::String NetworkName;
Visual Basic
Public Property NetworkName() As System::String
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::OverrideRuleSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::OverrideRuleSet Property
Part::OverrideRuleSet Property
Collapse All

Gets or sets whether to use overridden rules.

C#
public bool OverrideRuleSet;
Visual Basic
Public Property OverrideRuleSet() As bool
Remarks

When this property is set to false, all the overridden rules in parts are cleared. When this property is set to true, overridden rules are copied from the corresponding RuleSetStyle.

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::ParamsBool Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::ParamsBool Property
Part::ParamsBool Property
Collapse All

Gets the boolean parameters collection.

C#
public Autodesk::Civil::Runtime::ParamBoolCollection ParamsBool;
Visual Basic
Public Property ParamsBool() As Autodesk::Civil::Runtime::ParamBoolCollection
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::ParamsDouble Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::ParamsDouble Property
Part::ParamsDouble Property
Collapse All

Gets the double parameters collection.

C#
public Autodesk::Civil::Runtime::ParamDoubleCollection ParamsDouble;
Visual Basic
Public Property ParamsDouble() As Autodesk::Civil::Runtime::ParamDoubleCollection
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::ParamsLong Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::ParamsLong Property
Part::ParamsLong Property
Collapse All

Gets the long parameters collection.

C#
public Autodesk::Civil::Runtime::ParamLongCollection ParamsLong;
Visual Basic
Public Property ParamsLong() As Autodesk::Civil::Runtime::ParamLongCollection
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::ParamsString Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::ParamsString Property
Part::ParamsString Property
Collapse All

Gets the string parameters collection.

C#
public Autodesk::Civil::Runtime::ParamStringCollection ParamsString;
Visual Basic
Public Property ParamsString() As Autodesk::Civil::Runtime::ParamStringCollection
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::PartData Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::PartData Property
Part::PartData Property
Collapse All

Gets or sets the part data record.

C#
public PartDataRecord PartData;
Visual Basic
Public Property PartData() As PartDataRecord
Remarks

To edit the value of a PartDataField in a PartDataRecord, you must open the Part (Pipe or Structure) for write, get a reference to the Part object's PartData property (type PartDataRecord), modify the PartDatafield value, and then re-set the Part's PartData. See the example code for PartDataRecord.

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::PartDefId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::PartDefId Property
Part::PartDefId Property
Collapse All

Gets the object id of PartDef.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PartDefId;
Visual Basic
Public Property PartDefId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.PartDef

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::PartDescription Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::PartDescription Property
Part::PartDescription Property
Collapse All

Gets the part’s description.

C#
public System::String PartDescription;
Visual Basic
Public Property PartDescription() As System::String
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::PartSizeName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::PartSizeName Property
Part::PartSizeName Property
Collapse All

Gets the part size name.

C#
public System::String PartSizeName;
Visual Basic
Public Property PartSizeName() As System::String
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::PartSubType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::PartSubType Property
Part::PartSubType Property
Collapse All

Gets the part’s subtype.

C#
public System::String PartSubType;
Visual Basic
Public Property PartSubType() As System::String
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::PartType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::PartType Property
Part::PartType Property
Collapse All

Gets the type of the network park.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::PartType PartType;
Visual Basic
Public Property PartType() As Autodesk::Civil::PipeNetwork::DatabaseServices::PartType
Remarks

For example, pipe, wire, or conduit.

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::Position Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::Position Property
Part::Position Property
Collapse All

Gets or sets the position of the network part.

C#
public Autodesk::AutoCAD::Geometry::Point3d Position;
Visual Basic
Public Property Position() As Autodesk::AutoCAD::Geometry::Point3d
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::ProfileViewPartId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::ProfileViewPartId Property
Part::ProfileViewPartId Property
Collapse All

Gets the object id of the part's counterpart in profile views.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileViewPartId;
Visual Basic
Public Property ProfileViewPartId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.ProfileViewPart If the part is not ever drawn in any profile view, the returned object id is null.

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RefAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::RefAlignmentId Property
Part::RefAlignmentId Property
Collapse All

Gets or sets the object id of the alignment which this part references.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId RefAlignmentId;
Visual Basic
Public Property RefAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input is not a valid object id of alignment object.
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RefAlignmentName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::RefAlignmentName Property
Part::RefAlignmentName Property
Collapse All

Gets the name of the alignment which this part references

C#
public System::String RefAlignmentName;
Visual Basic
Public Property RefAlignmentName() As System::String
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RefSurfaceId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::RefSurfaceId Property
Part::RefSurfaceId Property
Collapse All

Gets or sets the object id of the surface that this part references.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId RefSurfaceId;
Visual Basic
Public Property RefSurfaceId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Surface

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input is not a valid object id for a surface.
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RefSurfaceName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::RefSurfaceName Property
Part::RefSurfaceName Property
Collapse All

Gets the name of the surface which this part references.

C#
public System::String RefSurfaceName;
Visual Basic
Public Property RefSurfaceName() As System::String
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RuleSetStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::RuleSetStyleId Property
Part::RuleSetStyleId Property
Collapse All

Gets or sets the object id of RuleSetStyle.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId RuleSetStyleId;
Visual Basic
Public Property RuleSetStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.Styles.NetworkRuleSetStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style Id is invalid.
System.InvalidOperationException | Thrown when calling set in case OverrideRuleSet is true.
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::RuleSetStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::RuleSetStyleName Property
Part::RuleSetStyleName Property
Collapse All

Gets or sets RuleSetStyle by name.

C#
public System::String RuleSetStyleName;
Visual Basic
Public Property RuleSetStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style name is invalid.
System.InvalidOperationException | Thrown when calling set in case OverrideRuleSet is true.
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::SectionViewPartId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::SectionViewPartId Property
Part::SectionViewPartId Property
Collapse All

Gets the object id of the part's counterpart in section views.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SectionViewPartId;
Visual Basic
Public Property SectionViewPartId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.SectionViewPart

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::Solid3dBody Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::Solid3dBody Property
Part::Solid3dBody Property
Collapse All

Gets the 3d solid body of the part.

C#
public Autodesk::AutoCAD::DatabaseServices::Solid3d Solid3dBody;
Visual Basic
Public Property Solid3dBody() As Autodesk::AutoCAD::DatabaseServices::Solid3d
Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::SurfaceId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::SurfaceId Property
Part::SurfaceId Property deprecated
Collapse All

Gets or sets the object id of the surface that this part references.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SurfaceId;
Visual Basic
Public Property SurfaceId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Notes

Deprecated: Use Autodesk.Civil.PipeNetwork.DatabaseServices.Part.RefSurfaceId instead.

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Part::WallThickness Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties > Part::WallThickness Property
Part::WallThickness Property
Collapse All

Gets the wall thickness for this structure, measured from the inside edge of the structure to the outside edge of the structure.

C#
public double WallThickness;
Visual Basic
Public Property WallThickness() As double
Remarks

This property is meaningful only for junction structures if the part is a structure.

Links
Part Class, Part Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class
PartDataField Class
Collapse All

An extensible field of part data.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataField
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::SizeFilterField
C#
public class PartDataField;
Visual Basic
Public Class PartDataField
Remarks

To edit the value of a PartDataField in a Part object's PartDataRecord, you must open the Part (Pipe or Structure) for write, get a reference to the Part object's PartData property (type PartDataRecord), modify the PartDatafield value, and then re-set the Part's PartData. See the example code for PartDataRecord. A similar procedure is required for editing a PartSize. See the example code for PartSize for a sample.

Links
PartDataField Properties, PartDataField Members, Class Hierarchy


PartDataField Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Members
PartDataField Members
Collapse All

The following tables list the members exposed by PartDataField.

Public Properties
Public Property | Description
Context | Gets the parameter context.
ContextString | Gets the parameter context string.
DataType | Gets the type of the reserved data.
Description | Gets the description of the data field.
Index | Gets the parameter index.
IsFromList | Gets if the value of data field should be set from a fixed list.
IsFromRange | Gets if the value of data field should be set from a range.
IsReadOnly | Checks if the data field is read-only.
Name | Gets the name of the data field.
Units | Gets the parameter units.
Value | Gets or sets the value. The value type is returned by the DataType property.
ValueList | Gets the list of valid data if the data field is from a fixed list.
ValueRange | Gets the range of valid data if the data field is from a range.
Links
Public Properties


PartDataField Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties
PartDataField Properties
Collapse All

The properties of PartDataField are listed here.

Public Properties
Public Property | Description
Context | Gets the parameter context.
ContextString | Gets the parameter context string.
DataType | Gets the type of the reserved data.
Description | Gets the description of the data field.
Index | Gets the parameter index.
IsFromList | Gets if the value of data field should be set from a fixed list.
IsFromRange | Gets if the value of data field should be set from a range.
IsReadOnly | Checks if the data field is read-only.
Name | Gets the name of the data field.
Units | Gets the parameter units.
Value | Gets or sets the value. The value type is returned by the DataType property.
ValueList | Gets the list of valid data if the data field is from a fixed list.
ValueRange | Gets the range of valid data if the data field is from a range.
Links
Public Properties


PartDataField::Context Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::Context Property
PartDataField::Context Property
Collapse All

Gets the parameter context.

C#
public PartContextType Context;
Visual Basic
Public Property Context() As PartContextType
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::ContextString Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::ContextString Property
PartDataField::ContextString Property
Collapse All

Gets the parameter context string.

C#
public System::String ContextString;
Visual Basic
Public Property ContextString() As System::String
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::DataType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::DataType Property
PartDataField::DataType Property
Collapse All

Gets the type of the reserved data.

C#
public PartCatalogDataType DataType;
Visual Basic
Public Property DataType() As PartCatalogDataType
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::Description Property
PartDataField::Description Property
Collapse All

Gets the description of the data field.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::Index Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::Index Property
PartDataField::Index Property
Collapse All

Gets the parameter index.

C#
public int Index;
Visual Basic
Public Property Index() As Integer
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::IsFromList Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::IsFromList Property
PartDataField::IsFromList Property
Collapse All

Gets if the value of data field should be set from a fixed list.

C#
public bool IsFromList;
Visual Basic
Public Property IsFromList() As bool
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::IsFromRange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::IsFromRange Property
PartDataField::IsFromRange Property
Collapse All

Gets if the value of data field should be set from a range.

C#
public bool IsFromRange;
Visual Basic
Public Property IsFromRange() As bool
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::IsReadOnly Property
PartDataField::IsReadOnly Property
Collapse All

Checks if the data field is read-only.

C#
public bool IsReadOnly;
Visual Basic
Public Property IsReadOnly() As bool
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::Name Property
PartDataField::Name Property
Collapse All

Gets the name of the data field.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::Units Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::Units Property
PartDataField::Units Property
Collapse All

Gets the parameter units.

C#
public System::String Units;
Visual Basic
Public Property Units() As System::String
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::Value Property
PartDataField::Value Property
Collapse All

Gets or sets the value. The value type is returned by the DataType property.

C#
public System::Object Value;
Visual Basic
Public Property Value() As System::Object
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the type of the input data is invalid.
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::ValueList Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::ValueList Property
PartDataField::ValueList Property
Collapse All

Gets the list of valid data if the data field is from a fixed list.

C#
public PartDataList ValueList;
Visual Basic
Public Property ValueList() As PartDataList
Exceptions
Exceptions | Description
System::InvalidOperationException | Thrown when the value of data field is not from a list
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataField::ValueRange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties > PartDataField::ValueRange Property
PartDataField::ValueRange Property
Collapse All

Gets the range of valid data if the data field is from a range.

C#
public PartDataRange ValueRange;
Visual Basic
Public Property ValueRange() As PartDataRange
Exceptions
Exceptions | Description
System::InvalidOperationException | Thrown when the value of data field is not from a range
Links
PartDataField Class, PartDataField Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataList Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class
PartDataList Class
Collapse All

The part data list associated with a PartDataField or SizeFilterField.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataList
C#
public class PartDataList;
Visual Basic
Public Class PartDataList
Links
PartDataList Methods, PartDataList Properties, PartDataList Members, Class Hierarchy


PartDataList Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Members
PartDataList Members
Collapse All

The following tables list the members exposed by PartDataList.

Public Methods
Public Method | Description
IsValidValue | Gets if the specified value is in the list.
Public Properties
Public Property | Description
Context | Gets the parameter context of the list
Count | The count of fields in the list
DataType | Gets the type of the data value.
default | Gets the value in the list by index.
Index | Gets the parameter index of the list
Links
Public Methods, Public Properties


PartDataList Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Methods
PartDataList Methods
Collapse All

The methods of PartDataList are listed here.

Public Methods
Public Method | Description
IsValidValue | Gets if the specified value is in the list.
Links
Public Methods


PartDataList::IsValidValue Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Methods > PartDataList::IsValidValue Method
PartDataList::IsValidValue Method
Collapse All

Gets if the specified value is in the list.

C#
public bool IsValidValue(
    ref System::Object value
);
Visual Basic
Public Function IsValidValue(
    ByRef value As System::Object
) As bool
Links
PartDataList Class, PartDataList Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataList Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Properties
PartDataList Properties
Collapse All

The properties of PartDataList are listed here.

Public Properties
Public Property | Description
Context | Gets the parameter context of the list
Count | The count of fields in the list
DataType | Gets the type of the data value.
default | Gets the value in the list by index.
Index | Gets the parameter index of the list
Links
Public Properties


PartDataList::Context Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Properties > PartDataList::Context Property
PartDataList::Context Property
Collapse All

Gets the parameter context of the list

C#
public PartContextType Context;
Visual Basic
Public Property Context() As PartContextType
Links
PartDataList Class, PartDataList Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataList::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Properties > PartDataList::Count Property
PartDataList::Count Property
Collapse All

The count of fields in the list

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
PartDataList Class, PartDataList Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataList::DataType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Properties > PartDataList::DataType Property
PartDataList::DataType Property
Collapse All

Gets the type of the data value.

C#
public PartCatalogDataType DataType;
Visual Basic
Public Property DataType() As PartCatalogDataType
Links
PartDataList Class, PartDataList Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataList::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Properties > PartDataList::default Property
PartDataList::default Property
Collapse All

Gets the value in the list by index.

C#
public System::Object default;
Visual Basic
Public Property default() As System::Object
Links
PartDataList Class, PartDataList Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataList::Index Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Properties > PartDataList::Index Property
PartDataList::Index Property
Collapse All

Gets the parameter index of the list

C#
public int Index;
Visual Basic
Public Property Index() As Integer
Links
PartDataList Class, PartDataList Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRange Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class
PartDataRange Class
Collapse All

Defines the range of valid data for a PartDataField.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataRange
C#
public class PartDataRange;
Visual Basic
Public Class PartDataRange
Links
PartDataRange Methods, PartDataRange Properties, PartDataRange Members, Class Hierarchy


PartDataRange Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Members
PartDataRange Members
Collapse All

The following tables list the members exposed by PartDataRange.

Public Methods
Public Method | Description
IsValidValue | Gets if the specified value is in the range.
Public Properties
Public Property | Description
Context | Gets the parameter context of the list.
DataType | Gets the type of the data value.
Index | Gets the parameter index of the list.
RangeDefault | Gets the default value of the range.
RangeMax | Gets the maximum of range.
RangeMin | Gets the minimum of range.
Links
Public Methods, Public Properties


PartDataRange Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Methods
PartDataRange Methods
Collapse All

The methods of PartDataRange are listed here.

Public Methods
Public Method | Description
IsValidValue | Gets if the specified value is in the range.
Links
Public Methods


PartDataRange::IsValidValue Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Methods > PartDataRange::IsValidValue Method
PartDataRange::IsValidValue Method
Collapse All

Gets if the specified value is in the range.

C#
public bool IsValidValue(
    ref System::Object value
);
Visual Basic
Public Function IsValidValue(
    ByRef value As System::Object
) As bool
Links
PartDataRange Class, PartDataRange Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRange Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Properties
PartDataRange Properties
Collapse All

The properties of PartDataRange are listed here.

Public Properties
Public Property | Description
Context | Gets the parameter context of the list.
DataType | Gets the type of the data value.
Index | Gets the parameter index of the list.
RangeDefault | Gets the default value of the range.
RangeMax | Gets the maximum of range.
RangeMin | Gets the minimum of range.
Links
Public Properties


PartDataRange::Context Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Properties > PartDataRange::Context Property
PartDataRange::Context Property
Collapse All

Gets the parameter context of the list.

C#
public PartContextType Context;
Visual Basic
Public Property Context() As PartContextType
Links
PartDataRange Class, PartDataRange Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRange::DataType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Properties > PartDataRange::DataType Property
PartDataRange::DataType Property
Collapse All

Gets the type of the data value.

C#
public PartCatalogDataType DataType;
Visual Basic
Public Property DataType() As PartCatalogDataType
Links
PartDataRange Class, PartDataRange Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRange::Index Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Properties > PartDataRange::Index Property
PartDataRange::Index Property
Collapse All

Gets the parameter index of the list.

C#
public int Index;
Visual Basic
Public Property Index() As Integer
Links
PartDataRange Class, PartDataRange Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRange::RangeDefault Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Properties > PartDataRange::RangeDefault Property
PartDataRange::RangeDefault Property
Collapse All

Gets the default value of the range.

C#
public System::Object RangeDefault;
Visual Basic
Public Property RangeDefault() As System::Object
Links
PartDataRange Class, PartDataRange Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRange::RangeMax Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Properties > PartDataRange::RangeMax Property
PartDataRange::RangeMax Property
Collapse All

Gets the maximum of range.

C#
public System::Object RangeMax;
Visual Basic
Public Property RangeMax() As System::Object
Links
PartDataRange Class, PartDataRange Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRange::RangeMin Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Properties > PartDataRange::RangeMin Property
PartDataRange::RangeMin Property
Collapse All

Gets the minimum of range.

C#
public System::Object RangeMin;
Visual Basic
Public Property RangeMin() As System::Object
Links
PartDataRange Class, PartDataRange Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRecord Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class
PartDataRecord Class
Collapse All

A single data record for a Part object.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataRecord
C#
public class PartDataRecord;
Visual Basic
Public Class PartDataRecord
Remarks

To edit the value of a PartDataField, you must open the Part (Pipe or Structure) for write, get a reference to the Part object's PartData property (type PartDataRecord), modify the PartDatafield value, and then re-set the Part's PartData. See the example code. A similar procedure is required for editing a PartSize. See the example code for PartSize for a sample.

Example
[CommandMethod("pipemann")]
public void getPipeManning () {
   Autodesk.AutoCAD.EditorInput.Editor ed = Application.DocumentManager.MdiActiveDocument.Editor;
   PromptEntityOptions opt = new PromptEntityOptions("nSelect a Pipe");
   opt.SetRejectMessage("nObject must be a pipe.");
   opt.AddAllowedClass(typeof(Pipe), false);
   ObjectId pipeID = ed.GetEntity(opt).ObjectId;

   CivilDocument doc = CivilApplication.ActiveDocument;

   using ( Transaction ts = Application.DocumentManager.MdiActiveDocument.Database.TransactionManager.StartTransaction() ) {
       Pipe PipeEle = ts.GetObject(pipeID, OpenMode.ForWrite) as Pipe;
       // Save a reference to the PartData to restore later.
       PartDataRecord record = PipeEle.PartData;
       PartDataField PartDataFld = record.GetDataFieldBy(PartContextType.FlowAnalysisManning);
       // Set the value:
       PartDataFld.Value = 0.44;
       // Re-set the PartData property.  The data will not be updated without this step.
       PipeEle.PartData = record;
       ed.WriteMessage("Manning value is now: {0}", PartDataFld.Value);
       ts.Commit();
   }
}
Links
PartDataRecord Methods, PartDataRecord Members, Class Hierarchy


PartDataRecord Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Members
PartDataRecord Members
Collapse All

The following tables list the members exposed by PartDataRecord.

Public Methods
Public Method | Description
GetAllDataFields | Gets all data fields.
GetDataFieldBy | Overloaded
GetMaxIndex | Gets the maximum index of one context type.
GetSupportedContexts | Gets the collection of supported ContextType.
Links
Public Methods


PartDataRecord Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods
PartDataRecord Methods
Collapse All

The methods of PartDataRecord are listed here.

Public Methods
Public Method | Description
GetAllDataFields | Gets all data fields.
GetDataFieldBy | Overloaded
GetMaxIndex | Gets the maximum index of one context type.
GetSupportedContexts | Gets the collection of supported ContextType.
Links
Public Methods


PartDataRecord::GetAllDataFields Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods > PartDataRecord::GetAllDataFields Method
PartDataRecord::GetAllDataFields Method
Collapse All

Gets all data fields.

C#
public array<PartDataField^> GetAllDataFields();
Visual Basic
Public Function GetAllDataFields() As array<PartDataField^>
Example
Network oNetwork = ts.GetObject(objId, OpenMode.ForRead) as Network;
ed.WriteMessage("Pipe Network: {0}n", oNetwork.Name);

// Get PartDataRecord for first pipe in the network
ObjectId pipeId = oNetwork.GetPipeIds()[0];
Pipe oPipe = ts.GetObject(pipeId, OpenMode.ForRead) as Pipe;
PartDataField[] oDataFields = oPipe.PartData.GetAllDataFields();
ed.WriteMessage("Additional info for pipe: {0}n", oPipe.Name);
foreach ( PartDataField oPartDataField in oDataFields ) {
   ed.WriteMessage("Name: {0}, Description: {1},  DataType: {2}, Value: {3}n",
       oPartDataField.Name,
       oPartDataField.Description,
       oPartDataField.DataType,
       oPartDataField.Value);
}
Links
PartDataRecord Class, PartDataRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


GetDataFieldBy Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods > GetDataFieldBy Method
GetDataFieldBy Method
Collapse All

Overloaded

Overload List
Method | Description
PartDataRecord::GetDataFieldBy (PartContextType) | Gets the object of DataField by Context.
PartDataRecord::GetDataFieldBy (PartContextType, int) | Gets the object of DataField by Context and index.
PartDataRecord::GetDataFieldBy (System::String^) | Gets the object of DataField by Name.


PartDataRecord::GetDataFieldBy Method (PartContextType)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods > GetDataFieldBy Method > PartDataRecord::GetDataFieldBy Method (PartContextType)
PartDataRecord::GetDataFieldBy Method (PartContextType)
Collapse All

Gets the object of DataField by Context.

C#
public PartDataField GetDataFieldBy(
    PartContextType context
);
Visual Basic
Public Function GetDataFieldBy(
    context As PartContextType
) As PartDataField
Parameters
Parameters | Description
context | The part context type to get.
Links
PartDataRecord Class, PartDataRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRecord::GetDataFieldBy Method (PartContextType, int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods > GetDataFieldBy Method > PartDataRecord::GetDataFieldBy Method (PartContextType, int)
PartDataRecord::GetDataFieldBy Method (PartContextType, int)
Collapse All

Gets the object of DataField by Context and index.

C#
public PartDataField GetDataFieldBy(
    PartContextType context,
    int index
);
Visual Basic
Public Function GetDataFieldBy(
    context As PartContextType,
    index As Integer
) As PartDataField
Parameters
Parameters | Description
context | The part context type to get.
index | The index of the PartDataField to get.
Example

This gets the first PartDataField of type StructHeight:

retVal = oPartDataRecord.GetDataFieldBy(PartContextType.StructHeight, 0);
Links
PartDataRecord Class, PartDataRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRecord::GetDataFieldBy Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods > GetDataFieldBy Method > PartDataRecord::GetDataFieldBy Method (System::String^)
PartDataRecord::GetDataFieldBy Method (System::String^)
Collapse All

Gets the object of DataField by Name.

C#
public PartDataField GetDataFieldBy(
    ref System::String name
);
Visual Basic
Public Function GetDataFieldBy(
    ByRef name As System::String
) As PartDataField
Parameters
Parameters | Description
name | The name of the DataField to get.
Links
PartDataRecord Class, PartDataRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRecord::GetMaxIndex Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods > PartDataRecord::GetMaxIndex Method
PartDataRecord::GetMaxIndex Method
Collapse All

Gets the maximum index of one context type.

C#
public int GetMaxIndex(
    PartContextType context
);
Visual Basic
Public Function GetMaxIndex(
    context As PartContextType
) As Integer
Parameters
Parameters | Description
context | The part context type to check.
Links
PartDataRecord Class, PartDataRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDataRecord::GetSupportedContexts Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods > PartDataRecord::GetSupportedContexts Method
PartDataRecord::GetSupportedContexts Method
Collapse All

Gets the collection of supported ContextType.

C#
public array<PartContextType> GetSupportedContexts();
Visual Basic
Public Function GetSupportedContexts() As array<PartContextType>
Links
PartDataRecord Class, PartDataRecord Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDef Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class
PartDef Class
Collapse All

A part definition for Pipe or Structure objects.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDef
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkPartDef"))]
public class PartDef : Autodesk::Aec::DatabaseServices::DBObject;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkPartDef"))>
Public Class PartDef
Inherits Autodesk::Aec::DatabaseServices::DBObject
Links
PartDef Methods, PartDef Constructors, PartDef Members, Class Hierarchy


PartDef Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Members
PartDef Members
Collapse All

The following tables list the members exposed by PartDef.

Public Methods
Public Method | Description
Get3dBody | Gets the 3d solid body.
GetBoundingShapeBody | Gets the bounding shape body.
GetNetworkPartViewDef | Gets the network part view def.
GetProfileInFrontView | Gets the profile in front view.
PartDef | This is PartDef, a member of class PartDef.
Links
Public Methods


PartDef Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Methods
PartDef Methods
Collapse All

The methods of PartDef are listed here.

Public Methods
Public Method | Description
Get3dBody | Gets the 3d solid body.
GetBoundingShapeBody | Gets the bounding shape body.
GetNetworkPartViewDef | Gets the network part view def.
GetProfileInFrontView | Gets the profile in front view.
Links
Public Methods


PartDef::Get3dBody Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Methods > PartDef::Get3dBody Method
PartDef::Get3dBody Method
Collapse All

Gets the 3d solid body.

C#
public Autodesk::AutoCAD::DatabaseServices::Solid3d Get3dBody();
Visual Basic
Public Function Get3dBody() As Autodesk::AutoCAD::DatabaseServices::Solid3d
Links
PartDef Class, PartDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDef::GetBoundingShapeBody Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Methods > PartDef::GetBoundingShapeBody Method
PartDef::GetBoundingShapeBody Method
Collapse All

Gets the bounding shape body.

C#
public Autodesk::AutoCAD::DatabaseServices::Solid3d GetBoundingShapeBody();
Visual Basic
Public Function GetBoundingShapeBody() As Autodesk::AutoCAD::DatabaseServices::Solid3d
Links
PartDef Class, PartDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDef::GetNetworkPartViewDef Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Methods > PartDef::GetNetworkPartViewDef Method
PartDef::GetNetworkPartViewDef Method
Collapse All

Gets the network part view def.

C#
public PartViewDef GetNetworkPartViewDef();
Visual Basic
Public Function GetNetworkPartViewDef() As PartViewDef
Links
PartDef Class, PartDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDef::GetProfileInFrontView Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Methods > PartDef::GetProfileInFrontView Method
PartDef::GetProfileInFrontView Method
Collapse All

Gets the profile in front view.

C#
public Autodesk::Aec::Geometry::Profile GetProfileInFrontView();
Visual Basic
Public Function GetProfileInFrontView() As Autodesk::Aec::Geometry::Profile
Links
PartDef Class, PartDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartDef Constructors

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Constructors
PartDef Constructors
Collapse All

The constructors of PartDef are listed here.

Public Methods
Public Method | Description
PartDef | This is PartDef, a member of class PartDef.
Links
Public Methods


PartDef::PartDef Constructor

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Constructors > PartDef::PartDef Constructor
PartDef::PartDef Constructor
Collapse All

This is PartDef, a member of class PartDef.

C#
public PartDef(
    System::IntPtr unmanagedPointer,
    bool autoDelete
);
Visual Basic
Public Sub New(
    unmanagedPointer As System::IntPtr,
    autoDelete As bool
)
Links
PartDef Class, PartDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartViewDef Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class
PartViewDef Class
Collapse All

Contains information about how a part is displayed.

Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartViewDef
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccNetworkPartViewDef"))]
public class PartViewDef : Autodesk::Aec::DatabaseServices::ImpObject;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccNetworkPartViewDef"))>
Public Class PartViewDef
Inherits Autodesk::Aec::DatabaseServices::ImpObject
Links
PartViewDef Properties, PartViewDef Members, Class Hierarchy


PartViewDef Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Members
PartViewDef Members
Collapse All

The following tables list the members exposed by PartViewDef.

Public Properties
Public Property | Description
BoundingBodyBlockId | Gets the bounding body block id.
BoundingBodyBlockName | Gets the bounding body block name.
PartBodyGraphicsBlockId | Gets the part body graphics block id.
PartBodyGraphicsBlockName | Gets the part body graphics block name.
Links
Public Properties


PartViewDef Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Properties
PartViewDef Properties
Collapse All

The properties of PartViewDef are listed here.

Public Properties
Public Property | Description
BoundingBodyBlockId | Gets the bounding body block id.
BoundingBodyBlockName | Gets the bounding body block name.
PartBodyGraphicsBlockId | Gets the part body graphics block id.
PartBodyGraphicsBlockName | Gets the part body graphics block name.
Links
Public Properties


PartViewDef::BoundingBodyBlockId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Properties > PartViewDef::BoundingBodyBlockId Property
PartViewDef::BoundingBodyBlockId Property
Collapse All

Gets the bounding body block id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId BoundingBodyBlockId;
Visual Basic
Public Property BoundingBodyBlockId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.AutoCAD.DatabaseServices.BlockTableRecord

Links
PartViewDef Class, PartViewDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartViewDef::BoundingBodyBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Properties > PartViewDef::BoundingBodyBlockName Property
PartViewDef::BoundingBodyBlockName Property
Collapse All

Gets the bounding body block name.

C#
public System::String BoundingBodyBlockName;
Visual Basic
Public Property BoundingBodyBlockName() As System::String
Links
PartViewDef Class, PartViewDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartViewDef::PartBodyGraphicsBlockId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Properties > PartViewDef::PartBodyGraphicsBlockId Property
PartViewDef::PartBodyGraphicsBlockId Property
Collapse All

Gets the part body graphics block id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId PartBodyGraphicsBlockId;
Visual Basic
Public Property PartBodyGraphicsBlockId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.AutoCAD.DatabaseServices.BlockTableRecord

Links
PartViewDef Class, PartViewDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


PartViewDef::PartBodyGraphicsBlockName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Properties > PartViewDef::PartBodyGraphicsBlockName Property
PartViewDef::PartBodyGraphicsBlockName Property
Collapse All

Gets the part body graphics block name.

C#
public System::String PartBodyGraphicsBlockName;
Visual Basic
Public Property PartBodyGraphicsBlockName() As System::String
Links
PartViewDef Class, PartViewDef Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class
Pipe Class
Collapse All

A pipe network part serving to move fluids from one point to another.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Part
            Autodesk::Civil::PipeNetwork::DatabaseServices::Pipe
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPipe"))]
public class Pipe : Part;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbPipe"))>
Public Class Pipe
Inherits Part
Remarks

Pipe objects represent the conduits of the pipe network. Pipes are created using the Network object's AddLinePipe() and AddCurvePipe() methods. Both methods require you to specify a particular part family and a particular part size filter object (both identified by ObjectId) as well as the geometry information (line or curve) of the pipe. The order of the start and end points of the geometry may have meaning in describing flow direction.

To make a new pipe a meaningful part of a pipe Network, it must be connected to structures or other pipes using the ConnectToStructure() or ConnectToPipe() methods.

Links
Pipe Methods, Pipe Properties, Pipe Members, Class Hierarchy


Pipe Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Members
Pipe Members
Collapse All

The following tables list the members exposed by Pipe.

Public Methods
Public Method | Description
AddToProfileView | Draws the part into the specified profile view.
AddToSectionView | Draws the part into the specified section view.
ConnectToPipe | Connect one pipe to another pipe. If needed, disconnect the original one and move the pipe to that pipe for... more
ConnectToStructure | Connect one pipe to another structure. If needed, disconnect the original one and move the pipe to that structure for... more
Disconnect | Disconnect pipe.
GetClosestPointTo | Gets the closest point found to the given point on a pipe.
GetLabelIds | Gets the collection of pipe label ids.
GetOverriddenRuleIds | Gets the overridden Rule ids which this part contains.
GetParamAtPoint | Gets the scale on the pipe for the given point.
GetPointAtParam | Gets a 3d point for the given parameter.
GetProfileViewsDisplayingMe | Gets the object id collection of all the profile views in which this part was drawn.
GetProject2dPointVertically | Returns true if get the Project2dPoint successfully, otherwise false.
GetSectionViewsDisplayingMe | Gets the object id collection of all the section views in which this part was drawn.
IsMaxCoverViolated | Returns true if the Maximum Cover is violated.
IsMinCoverViolated | Returns true if the Minimum Cover is violated.
RemoveFromAllProfileViews | Remove the part from all the profile views in which it is drawn.
RemoveFromAllSectionViews | Removes the part from all the section views in which it is drawn.
RemoveFromProfileView | Remove the part from the specified profile view in which it is drawn.
RemoveFromSectionView | Removes the part from the specified section view in which it is drawn.
ResizeByInnerDiameterOrWidth | Resize the pipe by inner diameter or width.
SetSlopeHoldEnd | Sets the slope of the pipe away from the pipe’s end point.
SetSlopeHoldStart | Sets the slope of the pipe away from the pipe’s start point.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
Bearing | Gets the horizontal bearing for straight pipes, and chord bearing for curved pipes.
ConnectedPartCount | Gets the number of parts that connects to the part
CoverOfEndpoint | Gets the end point's cover of pipe.
CoverOfStartPoint | Gets the start point's cover of pipe.
CrossSectionalShape | Gets the pipe’s cross sectional shape, such as circular, egg-shaped, elliptical, or rectangular.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Domain | Gets the part's domain.
EndOffset | Gets the offset of the ending point for the pipe object.
EndPoint | Gets or sets the endpoint of the Pipe.
EndStation | Gets the station of the ending point for the pipe object.
EndStructureId | Gets the end structure id of the Pipe. If no connected structure, return ObjectId::Null.
FlowDirection | Gets the current flow direction of the pipe, relative to the start and endpoint of the pipe.
FlowDirectionMethod | Gets or sets the method that is used to determine the flow for this pipe.
HoldOnResizeType | Gets or sets how Structure should hold when resized.
InnerDiameterOrWidth | Gets the inner diameter or inner width of the pipe.
InnerHeight | Gets the inner height of the pipe in drawing units.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Length2D | Use Autodesk.Civil.PipeNetwork.Pipe.Length2DCenterToCenter instead.
Length2DCenterToCenter | Gets the two-dimensional length of the pipe, measured from the center of the connected starting structure to the center of... more
Length2DToInsideEdge | Gets the two-dimensional length of the pipe, measured from the inside edge of the connected starting structure to the inside... more
Length3D | Use Autodesk.Civil.PipeNetwork.Pipe.Length3DCenterToCenter instead.
Length3DCenterToCenter | Gets the three-dimensional length of the pipe, measured from the center of the connected starting structure to the center of... more
Length3DToInsideEdge | Gets the three-dimensional length of the pipe,measured from the inside edge of the connected starting structure to the inside edge... more
Material | Gets the material defined for this part.
MaximumCover | Gets the maximum depth of cover along the entire length of pipe, from the top outside of the pipe to... more
MinimumCover | Gets the minimum depth of cover along the entire length of pipe, from the top outside of the pipe to... more
Name | Gets or sets the Entity object's name.
Name | Gets part's name.
NetworkId | Gets the object id of the network to which this part belongs
NetworkName | Gets the name of the network to which this part belongs
OuterDiameterOrWidth | Gets the outer diameter or outer width of the pipe.
OuterHeight | Gets the outer height of the pipe in drawing units.
OverrideRuleSet | Gets or sets whether to use overridden rules.
ParamsBool | Gets the boolean parameters collection.
ParamsDouble | Gets the double parameters collection.
ParamsLong | Gets the long parameters collection.
ParamsString | Gets the string parameters collection.
PartData | Gets or sets the part data record.
PartDefId | Gets the object id of PartDef.
PartDescription | Gets the part’s description.
PartSizeName | Gets the part size name.
PartSubType | Gets the part’s subtype.
PartType | Gets the type of the network park.
Position | Gets or sets the position of the network part.
ProfileViewPartId | Gets the object id of the part's counterpart in profile views.
Radius | Gets the radius of the pipe.
RefAlignmentId | Gets or sets the object id of the alignment which this part references.
RefAlignmentName | Gets the name of the alignment which this part references
RefSurfaceId | Gets or sets the object id of the surface that this part references.
RefSurfaceName | Gets the name of the surface which this part references.
RuleSetStyleId | Gets or sets the object id of RuleSetStyle.
RuleSetStyleName | Gets or sets RuleSetStyle by name.
SectionViewPartId | Gets the object id of the part's counterpart in section views.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
Slope | Gets the pipe’s slope in absolute value.
Solid3dBody | Gets the 3d solid body of the part.
StartOffset | Gets the offset of the starting point for the pipe object.
StartPoint | Gets or sets the start point of the Pipe.
StartStation | Gets the station of the starting point for the pipe object.
StartStructureId | Gets the start structure id of the Pipe. If no connected structure, return ObjectId::Null.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
SubEntityType | Gets the type of the pipe.
SurfaceId | Gets or sets the object id of the surface that this part references.
WallThickness | Gets the wall thickness for this structure, measured from the inside edge of the structure to the outside edge of... more
Links
Public Methods, Public Properties


Pipe Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods
Pipe Methods
Collapse All

The methods of Pipe are listed here.

Public Methods
Public Method | Description
ConnectToPipe | Connect one pipe to another pipe. If needed, disconnect the original one and move the pipe to that pipe for... more
ConnectToStructure | Connect one pipe to another structure. If needed, disconnect the original one and move the pipe to that structure for... more
Disconnect | Disconnect pipe.
GetClosestPointTo | Gets the closest point found to the given point on a pipe.
GetLabelIds | Gets the collection of pipe label ids.
GetParamAtPoint | Gets the scale on the pipe for the given point.
GetPointAtParam | Gets a 3d point for the given parameter.
GetProject2dPointVertically | Returns true if get the Project2dPoint successfully, otherwise false.
IsMaxCoverViolated | Returns true if the Maximum Cover is violated.
IsMinCoverViolated | Returns true if the Minimum Cover is violated.
ResizeByInnerDiameterOrWidth | Resize the pipe by inner diameter or width.
SetSlopeHoldEnd | Sets the slope of the pipe away from the pipe’s end point.
SetSlopeHoldStart | Sets the slope of the pipe away from the pipe’s start point.
Links
Public Methods


Pipe::ConnectToPipe Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::ConnectToPipe Method
Pipe::ConnectToPipe Method
Collapse All

Connect one pipe to another pipe. If needed, disconnect the original one and move the pipe to that pipe for connecting and add a structure.

C#
public ConnectToPipe(
    ConnectorPositionType sourceType,
    Autodesk::AutoCAD::DatabaseServices::ObjectId destinationPipeId,
    ConnectorPositionType destinationType,
    Autodesk::AutoCAD::DatabaseServices::ObjectId structureFamilyId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId structureSizeId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId% newStructureId,
    bool applyRules,
    bool force
);
Visual Basic
Public Sub ConnectToPipe(
    sourceType As ConnectorPositionType,
    destinationPipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    destinationType As ConnectorPositionType,
    structureFamilyId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    structureSizeId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    newStructureId As Autodesk::AutoCAD::DatabaseServices::ObjectId%,
    applyRules As bool,
    force As bool
)
Parameters
Parameters | Description
sourceType | If start or end point to connect of source pipe.
destinationPipeId | The destination pipe for connection.
destinationType | If start or end point to connect of destination pipe.
structureFamilyId | Family id of the needed structure.
structureSizeId | Object id of Structure Size.
newStructureId | The new structure id.
applyRules | Whether needed to apply the rules.
force | Whether force the pipe to disconnect the original connected structure.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::ConnectToStructure Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::ConnectToStructure Method
Pipe::ConnectToStructure Method
Collapse All

Connect one pipe to another structure. If needed, disconnect the original one and move the pipe to that structure for connecting.

C#
public ConnectToStructure(
    ConnectorPositionType sourcePosition,
    Autodesk::AutoCAD::DatabaseServices::ObjectId destinationStructureId,
    bool force
);
Visual Basic
Public Sub ConnectToStructure(
    sourcePosition As ConnectorPositionType,
    destinationStructureId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    force As bool
)
Parameters
Parameters | Description
sourcePosition | If start or end point to connect.
destinationStructureId | The destination structure id.
force | If force the pipe to disconnect the original connected structure.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::Disconnect Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::Disconnect Method
Pipe::Disconnect Method
Collapse All

Disconnect pipe.

C#
public Disconnect(
    ConnectorPositionType pos
);
Visual Basic
Public Sub Disconnect(
    pos As ConnectorPositionType
)
Parameters
Parameters | Description
pos | Which end of this pipe to disconnect.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::GetClosestPointTo Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::GetClosestPointTo Method
Pipe::GetClosestPointTo Method
Collapse All

Gets the closest point found to the given point on a pipe.

C#
public Autodesk::AutoCAD::Geometry::Point3d GetClosestPointTo(
    Autodesk::AutoCAD::Geometry::Point3d sourcePoint
);
Visual Basic
Public Function GetClosestPointTo(
    sourcePoint As Autodesk::AutoCAD::Geometry::Point3d
) As Autodesk::AutoCAD::Geometry::Point3d
Parameters
Parameters | Description
sourcePoint | A 3d point in the drawing.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::GetLabelIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::GetLabelIds Method
Pipe::GetLabelIds Method
Collapse All

Gets the collection of pipe label ids.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetLabelIds();
Visual Basic
Public Function GetLabelIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::GetParamAtPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::GetParamAtPoint Method
Pipe::GetParamAtPoint Method
Collapse All

Gets the scale on the pipe for the given point.

C#
public double GetParamAtPoint(
    Autodesk::AutoCAD::Geometry::Point3d point
);
Visual Basic
Public Function GetParamAtPoint(
    point As Autodesk::AutoCAD::Geometry::Point3d
) As double
Parameters
Parameters | Description
point | The point used to get the scale on the pipe.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::GetPointAtParam Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::GetPointAtParam Method
Pipe::GetPointAtParam Method
Collapse All

Gets a 3d point for the given parameter.

C#
public Autodesk::AutoCAD::Geometry::Point3d GetPointAtParam(
    double paramInterval
);
Visual Basic
Public Function GetPointAtParam(
    paramInterval As double
) As Autodesk::AutoCAD::Geometry::Point3d
Parameters
Parameters | Description
paramInterval | The scale of the returned point on the pipe.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the value of paramInterval is out of interval [0.0, 1.0].
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::GetProject2dPointVertically Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::GetProject2dPointVertically Method
Pipe::GetProject2dPointVertically Method
Collapse All

Returns true if get the Project2dPoint successfully, otherwise false.

C#
public bool GetProject2dPointVertically(
    Autodesk::AutoCAD::Geometry::Point2d sourcePoint,
    Autodesk::AutoCAD::Geometry::Point3d% projectPoint
);
Visual Basic
Public Function GetProject2dPointVertically(
    sourcePoint As Autodesk::AutoCAD::Geometry::Point2d,
    projectPoint As Autodesk::AutoCAD::Geometry::Point3d%
) As bool
Parameters
Parameters | Description
sourcePoint | A 2D point.
projectPoint | Project 2d point.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::IsMaxCoverViolated Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::IsMaxCoverViolated Method
Pipe::IsMaxCoverViolated Method
Collapse All

Returns true if the Maximum Cover is violated.

C#
public bool IsMaxCoverViolated(
    double maxCover,
    array<Autodesk::AutoCAD::Geometry::Point3d>^% pointsViolated,
    array<double>^% differences,
    array<double>^% params
);
Visual Basic
Public Function IsMaxCoverViolated(
    maxCover As double,
    pointsViolated As array<Autodesk::AutoCAD::Geometry::Point3d>^%,
    differences As array<double>^%,
    params As array<double>^%
) As bool
Parameters
Parameters | Description
maxCover | Max cover.
pointsViolated | The points which are on pipe and their distances to surface are shorter than maxCover.
differences | The distances of pointsViolated to surface.
params | The scales of pointsViolated on the pipe.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::IsMinCoverViolated Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::IsMinCoverViolated Method
Pipe::IsMinCoverViolated Method
Collapse All

Returns true if the Minimum Cover is violated.

C#
public bool IsMinCoverViolated(
    double minCover,
    array<Autodesk::AutoCAD::Geometry::Point3d>^% pointsViolated,
    array<double>^% differences,
    array<double>^% params
);
Visual Basic
Public Function IsMinCoverViolated(
    minCover As double,
    pointsViolated As array<Autodesk::AutoCAD::Geometry::Point3d>^%,
    differences As array<double>^%,
    params As array<double>^%
) As bool
Parameters
Parameters | Description
minCover | Min cover.
pointsViolated | The points which are on pipe and their distances to surface are shorter than minCover.
differences | The distances of pointsViolated to surface.
params | The scales of pointsViolated on the pipe.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::ResizeByInnerDiameterOrWidth Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::ResizeByInnerDiameterOrWidth Method
Pipe::ResizeByInnerDiameterOrWidth Method
Collapse All

Resize the pipe by inner diameter or width.

C#
public ResizeByInnerDiameterOrWidth(
    double innerDiameterOrWidth,
    bool useClosestSize
);
Visual Basic
Public Sub ResizeByInnerDiameterOrWidth(
    innerDiameterOrWidth As double,
    useClosestSize As bool
)
Parameters
Parameters | Description
innerDiameterOrWidth | Inner diameter or width value.
useClosestSize | True if this pipe should be resized to the closed size in the part family. False otherwise.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::SetSlopeHoldEnd Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::SetSlopeHoldEnd Method
Pipe::SetSlopeHoldEnd Method
Collapse All

Sets the slope of the pipe away from the pipe’s end point.

C#
public SetSlopeHoldEnd(
    double endValue
);
Visual Basic
Public Sub SetSlopeHoldEnd(
    endValue As double
)
Parameters
Parameters | Description
endValue | The slope value.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::SetSlopeHoldStart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods > Pipe::SetSlopeHoldStart Method
Pipe::SetSlopeHoldStart Method
Collapse All

Sets the slope of the pipe away from the pipe’s start point.

C#
public SetSlopeHoldStart(
    double startValue
);
Visual Basic
Public Sub SetSlopeHoldStart(
    startValue As double
)
Parameters
Parameters | Description
startValue | The slope value.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties
Pipe Properties
Collapse All

The properties of Pipe are listed here.

Public Properties
Public Property | Description
Bearing | Gets the horizontal bearing for straight pipes, and chord bearing for curved pipes.
CoverOfEndpoint | Gets the end point's cover of pipe.
CoverOfStartPoint | Gets the start point's cover of pipe.
CrossSectionalShape | Gets the pipe’s cross sectional shape, such as circular, egg-shaped, elliptical, or rectangular.
EndOffset | Gets the offset of the ending point for the pipe object.
EndPoint | Gets or sets the endpoint of the Pipe.
EndStation | Gets the station of the ending point for the pipe object.
EndStructureId | Gets the end structure id of the Pipe. If no connected structure, return ObjectId::Null.
FlowDirection | Gets the current flow direction of the pipe, relative to the start and endpoint of the pipe.
FlowDirectionMethod | Gets or sets the method that is used to determine the flow for this pipe.
HoldOnResizeType | Gets or sets how Structure should hold when resized.
InnerDiameterOrWidth | Gets the inner diameter or inner width of the pipe.
InnerHeight | Gets the inner height of the pipe in drawing units.
Length2D | Use Autodesk.Civil.PipeNetwork.Pipe.Length2DCenterToCenter instead.
Length2DCenterToCenter | Gets the two-dimensional length of the pipe, measured from the center of the connected starting structure to the center of... more
Length2DToInsideEdge | Gets the two-dimensional length of the pipe, measured from the inside edge of the connected starting structure to the inside... more
Length3D | Use Autodesk.Civil.PipeNetwork.Pipe.Length3DCenterToCenter instead.
Length3DCenterToCenter | Gets the three-dimensional length of the pipe, measured from the center of the connected starting structure to the center of... more
Length3DToInsideEdge | Gets the three-dimensional length of the pipe,measured from the inside edge of the connected starting structure to the inside edge... more
MaximumCover | Gets the maximum depth of cover along the entire length of pipe, from the top outside of the pipe to... more
MinimumCover | Gets the minimum depth of cover along the entire length of pipe, from the top outside of the pipe to... more
OuterDiameterOrWidth | Gets the outer diameter or outer width of the pipe.
OuterHeight | Gets the outer height of the pipe in drawing units.
Radius | Gets the radius of the pipe.
Slope | Gets the pipe’s slope in absolute value.
StartOffset | Gets the offset of the starting point for the pipe object.
StartPoint | Gets or sets the start point of the Pipe.
StartStation | Gets the station of the starting point for the pipe object.
StartStructureId | Gets the start structure id of the Pipe. If no connected structure, return ObjectId::Null.
SubEntityType | Gets the type of the pipe.
Links
Public Properties


Pipe::Bearing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::Bearing Property
Pipe::Bearing Property
Collapse All

Gets the horizontal bearing for straight pipes, and chord bearing for curved pipes.

C#
public double Bearing;
Visual Basic
Public Property Bearing() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::CoverOfEndpoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::CoverOfEndpoint Property
Pipe::CoverOfEndpoint Property
Collapse All

Gets the end point's cover of pipe.

C#
public double CoverOfEndpoint;
Visual Basic
Public Property CoverOfEndpoint() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::CoverOfStartPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::CoverOfStartPoint Property
Pipe::CoverOfStartPoint Property
Collapse All

Gets the start point's cover of pipe.

C#
public double CoverOfStartPoint;
Visual Basic
Public Property CoverOfStartPoint() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::CrossSectionalShape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::CrossSectionalShape Property
Pipe::CrossSectionalShape Property
Collapse All

Gets the pipe’s cross sectional shape, such as circular, egg-shaped, elliptical, or rectangular.

C#
public SweptShapeType CrossSectionalShape;
Visual Basic
Public Property CrossSectionalShape() As SweptShapeType
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::EndOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::EndOffset Property
Pipe::EndOffset Property
Collapse All

Gets the offset of the ending point for the pipe object.

C#
public double EndOffset;
Visual Basic
Public Property EndOffset() As double
Remarks

This offset is obtained from the alignment referenced by this pipe object. Flow direction is not considered.

Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::EndPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::EndPoint Property
Pipe::EndPoint Property
Collapse All

Gets or sets the endpoint of the Pipe.

C#
public Autodesk::AutoCAD::Geometry::Point3d EndPoint;
Visual Basic
Public Property EndPoint() As Autodesk::AutoCAD::Geometry::Point3d
Remarks

When set, other integrity operations such as break/join/resizing will also be executed.

Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::EndStation Property
Pipe::EndStation Property
Collapse All

Gets the station of the ending point for the pipe object.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Remarks

This station is obtained from the alignment referenced by this pipe object. Flow direction is not considered.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when there is no alignment referenced by this pipe object.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::EndStructureId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::EndStructureId Property
Pipe::EndStructureId Property
Collapse All

Gets the end structure id of the Pipe. If no connected structure, return ObjectId::Null.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId EndStructureId;
Visual Basic
Public Property EndStructureId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.Structure

Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::FlowDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::FlowDirection Property
Pipe::FlowDirection Property
Collapse All

Gets the current flow direction of the pipe, relative to the start and endpoint of the pipe.

C#
public FlowDirectionType FlowDirection;
Visual Basic
Public Property FlowDirection() As FlowDirectionType
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::FlowDirectionMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::FlowDirectionMethod Property
Pipe::FlowDirectionMethod Property
Collapse All

Gets or sets the method that is used to determine the flow for this pipe.

C#
public FlowDirectionMethodType FlowDirectionMethod;
Visual Basic
Public Property FlowDirectionMethod() As FlowDirectionMethodType
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::HoldOnResizeType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::HoldOnResizeType Property
Pipe::HoldOnResizeType Property
Collapse All

Gets or sets how Structure should hold when resized.

C#
public Autodesk::Civil::PipeNetwork::DatabaseServices::HoldOnResizeType HoldOnResizeType;
Visual Basic
Public Property HoldOnResizeType() As Autodesk::Civil::PipeNetwork::DatabaseServices::HoldOnResizeType
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::InnerDiameterOrWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::InnerDiameterOrWidth Property
Pipe::InnerDiameterOrWidth Property
Collapse All

Gets the inner diameter or inner width of the pipe.

C#
public double InnerDiameterOrWidth;
Visual Basic
Public Property InnerDiameterOrWidth() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::InnerHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::InnerHeight Property
Pipe::InnerHeight Property
Collapse All

Gets the inner height of the pipe in drawing units.

C#
public double InnerHeight;
Visual Basic
Public Property InnerHeight() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::Length2D Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::Length2D Property
Pipe::Length2D Property deprecated
Collapse All

Use Autodesk.Civil.PipeNetwork.Pipe.Length2DCenterToCenter instead.

C#
public double Length2D;
Visual Basic
Public Property Length2D() As double
Notes

Deprecated: Use Autodesk.Civil.PipeNetwork.Pipe.Length2DCenterToCenter instead.

Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::Length2DCenterToCenter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::Length2DCenterToCenter Property
Pipe::Length2DCenterToCenter Property
Collapse All

Gets the two-dimensional length of the pipe, measured from the center of the connected starting structure to the center of the connected ending structure.

C#
public double Length2DCenterToCenter;
Visual Basic
Public Property Length2DCenterToCenter() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::Length2DToInsideEdge Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::Length2DToInsideEdge Property
Pipe::Length2DToInsideEdge Property
Collapse All

Gets the two-dimensional length of the pipe, measured from the inside edge of the connected starting structure to the inside edge of the connected ending structure.

C#
public double Length2DToInsideEdge;
Visual Basic
Public Property Length2DToInsideEdge() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::Length3D Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::Length3D Property
Pipe::Length3D Property deprecated
Collapse All

Use Autodesk.Civil.PipeNetwork.Pipe.Length3DCenterToCenter instead.

C#
public double Length3D;
Visual Basic
Public Property Length3D() As double
Notes

Deprecated: Use Autodesk.Civil.PipeNetwork.Pipe.Length3DCenterToCenter instead.

Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::Length3DCenterToCenter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::Length3DCenterToCenter Property
Pipe::Length3DCenterToCenter Property
Collapse All

Gets the three-dimensional length of the pipe, measured from the center of the connected starting structure to the center of the connected ending structure.

C#
public double Length3DCenterToCenter;
Visual Basic
Public Property Length3DCenterToCenter() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::Length3DToInsideEdge Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::Length3DToInsideEdge Property
Pipe::Length3DToInsideEdge Property
Collapse All

Gets the three-dimensional length of the pipe,measured from the inside edge of the connected starting structure to the inside edge of the connected ending structure.

C#
public double Length3DToInsideEdge;
Visual Basic
Public Property Length3DToInsideEdge() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::MaximumCover Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::MaximumCover Property
Pipe::MaximumCover Property
Collapse All

Gets the maximum depth of cover along the entire length of pipe, from the top outside of the pipe to the reference surface.

C#
public double MaximumCover;
Visual Basic
Public Property MaximumCover() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::MinimumCover Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::MinimumCover Property
Pipe::MinimumCover Property
Collapse All

Gets the minimum depth of cover along the entire length of pipe, from the top outside of the pipe to the reference surface.

C#
public double MinimumCover;
Visual Basic
Public Property MinimumCover() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::OuterDiameterOrWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::OuterDiameterOrWidth Property
Pipe::OuterDiameterOrWidth Property
Collapse All

Gets the outer diameter or outer width of the pipe.

C#
public double OuterDiameterOrWidth;
Visual Basic
Public Property OuterDiameterOrWidth() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::OuterHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::OuterHeight Property
Pipe::OuterHeight Property
Collapse All

Gets the outer height of the pipe in drawing units.

C#
public double OuterHeight;
Visual Basic
Public Property OuterHeight() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::Radius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::Radius Property
Pipe::Radius Property
Collapse All

Gets the radius of the pipe.

C#
public double Radius;
Visual Basic
Public Property Radius() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::Slope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::Slope Property
Pipe::Slope Property
Collapse All

Gets the pipe’s slope in absolute value.

C#
public double Slope;
Visual Basic
Public Property Slope() As double
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::StartOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::StartOffset Property
Pipe::StartOffset Property
Collapse All

Gets the offset of the starting point for the pipe object.

C#
public double StartOffset;
Visual Basic
Public Property StartOffset() As double
Remarks

This offset is obtained from the alignment referenced by this pipe object. Flow direction is not considered.

Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::StartPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::StartPoint Property
Pipe::StartPoint Property
Collapse All

Gets or sets the start point of the Pipe.

C#
public Autodesk::AutoCAD::Geometry::Point3d StartPoint;
Visual Basic
Public Property StartPoint() As Autodesk::AutoCAD::Geometry::Point3d
Remarks

When set, other integrity operations such as break/join/resizing will also be executed.

Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::StartStation Property
Pipe::StartStation Property
Collapse All

Gets the station of the starting point for the pipe object.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Remarks

This station is obtained from the alignment referenced by this pipe object. Flow direction is not considered.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when there is no alignment referenced by this pipe object.
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::StartStructureId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::StartStructureId Property
Pipe::StartStructureId Property
Collapse All

Gets the start structure id of the Pipe. If no connected structure, return ObjectId::Null.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StartStructureId;
Visual Basic
Public Property StartStructureId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.Structure

Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Pipe::SubEntityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties > Pipe::SubEntityType Property
Pipe::SubEntityType Property
Collapse All

Gets the type of the pipe.

C#
public PipeSubEntityType SubEntityType;
Visual Basic
Public Property SubEntityType() As PipeSubEntityType
Links
Pipe Class, Pipe Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


ProfileViewPart Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class
ProfileViewPart Class
Collapse All

Manages the graphic display of pipe network parts in profile view.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::PipeNetwork::DatabaseServices::ProfileViewPart
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphProfileNetworkPart"))]
public class ProfileViewPart : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbGraphProfileNetworkPart"))>
Public Class ProfileViewPart
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
ProfileViewPart Methods, ProfileViewPart Properties, ProfileViewPart Members, Class Hierarchy


ProfileViewPart Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Members
ProfileViewPart Members
Collapse All

The following tables list the members exposed by ProfileViewPart.

Public Methods
Public Method | Description
GetLabelIds | Gets the object ids of the labels attached to this profile network part
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
ModelPartId | Gets the object id of the source network part of model space
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


ProfileViewPart Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Methods
ProfileViewPart Methods
Collapse All

The methods of ProfileViewPart are listed here.

Public Methods
Public Method | Description
GetLabelIds | Gets the object ids of the labels attached to this profile network part
Links
Public Methods


ProfileViewPart::GetLabelIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Methods > ProfileViewPart::GetLabelIds Method
ProfileViewPart::GetLabelIds Method
Collapse All

Gets the object ids of the labels attached to this profile network part

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetLabelIds();
Visual Basic
Public Function GetLabelIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
ProfileViewPart Class, ProfileViewPart Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


ProfileViewPart Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Properties
ProfileViewPart Properties
Collapse All

The properties of ProfileViewPart are listed here.

Public Properties
Public Property | Description
ModelPartId | Gets the object id of the source network part of model space
Links
Public Properties


ProfileViewPart::ModelPartId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Properties > ProfileViewPart::ModelPartId Property
ProfileViewPart::ModelPartId Property
Collapse All

Gets the object id of the source network part of model space

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ModelPartId;
Visual Basic
Public Property ModelPartId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.PipeNetwork.DatabaseServices.Part

Links
ProfileViewPart Class, ProfileViewPart Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


SectionPipeNetwork Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > SectionPipeNetwork Class
SectionPipeNetwork Class
Collapse All

Section view of a pipe network.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Section
            Autodesk::Civil::PipeNetwork::DatabaseServices::SectionPipeNetwork
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionPipeNetwork"))]
public class SectionPipeNetwork : Autodesk::Civil::Land::DatabaseServices::Section;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionPipeNetwork"))>
Public Class SectionPipeNetwork
Inherits Autodesk::Civil::Land::DatabaseServices::Section
Links
Class Hierarchy


Structure Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class
Structure Class
Collapse All

The drawing shape used to represent items such as manholes, catch basins, and headwalls used in utility networks. A Structure connects pipes together to form a pipe network.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Part
            Autodesk::Civil::PipeNetwork::DatabaseServices::Structure
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStructure"))]
public class Structure : Part;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbStructure"))>
Public Class Structure
Inherits Part
Remarks

Structures represent physical objects such as manholes, catch basins, and headwalls. Any number of Pipe objects can connect with a Structure. A Structure is created by using the AddStructure () method in a Network object.

Links
Structure Methods, Structure Properties, Structure Members, Class Hierarchy


Structure Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Members
Structure Members
Collapse All

The following tables list the members exposed by Structure.

Public Methods
Public Method | Description
AddToProfileView | Draws the part into the specified profile view.
AddToSectionView | Draws the part into the specified section view.
ConnectToPipe | Connect this structure to the specified pipe.
Disconnect | Disconnect with pipe.
GetConnectedPipeNames | Gets all the connected pipe names.
GetLabelIds | Gets the collection of structure label ids.
GetOverriddenRuleIds | Gets the overridden Rule ids which this part contains.
GetProfileViewsDisplayingMe | Gets the object id collection of all the profile views in which this part was drawn.
GetSectionViewsDisplayingMe | Gets the object id collection of all the section views in which this part was drawn.
IsConnectedPipeFlowingIn | Determines if the connected pipe is flowing into the structure
IsConnectedPipeFlowingOut | Determines if the connected pipe is flowing out of the structure
IsPointInsideStructureRegion | Returns true if the point is within the structure region.
RemoveFromAllProfileViews | Remove the part from all the profile views in which it is drawn.
RemoveFromAllSectionViews | Removes the part from all the section views in which it is drawn.
RemoveFromProfileView | Remove the part from the specified profile view in which it is drawn.
RemoveFromSectionView | Removes the part from the specified section view in which it is drawn.
ResizeByPipeDepths | Resize the structure by pipe depths.
ResizeJunctionStructure | Resize the Junction structure by rim and sump elevations.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
AutomaticRimSurfaceAdjustment | Gets or sets whether the rim should be automatically adjusted.
BarrelPipeClearance | Gets the clearance of barrel pipe.
BoundingShape | Gets the structure bounding shape.
ConeHeight | Gets the height of the cone shaped section of the structure.
ConnectedPartCount | Gets the number of parts that connects to the part
ConnectedPipe | Gets the pipe connected to the structure by index.
ConnectedPipesCount | Gets the count of the pipes connected to the structure.
ControlSumpBy | Gets or sets how the sump should be adjusted.
Cover | Gets the model or type of grate used for a structure intended to be used as a catchbasin.
DiameterOrWidth | Gets the structure diameter or width.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Domain | Gets the part's domain.
Easting | Gets or sets the structure’s easting.
FloorThickness | Gets the thickness of the bottom of the structure.
Frame | Gets the model or type of frame used for a structure.
FrameDiameter | Gets the diameter of the structure’s frame.
FrameHeight | Gets the height of the structure’s frame.
Grate | Gets the grate of the pipe.
HeadwallBaseThickness | Gets the thickness of the base of the headwall.
HeadwallBaseWidth | Gets the width of the base of the headwall.
Height | Gets the structure height.
InnerDiameterOrWidth | Gets the structure inner diameter or width.
InnerLength | Gets the structure inner length.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Length | Gets the structure length.
Location | Gets or sets the location.
Material | Gets the material defined for this part.
Name | Gets or sets the Entity object's name.
Name | Gets part's name.
NetworkId | Gets the object id of the network to which this part belongs
NetworkName | Gets the name of the network to which this part belongs
Northing | Gets or sets the structure’s northing.
Offset | Gets the structure’s offset.
OverrideRuleSet | Gets or sets whether to use overridden rules.
ParamsBool | Gets the boolean parameters collection.
ParamsDouble | Gets the double parameters collection.
ParamsLong | Gets the long parameters collection.
ParamsString | Gets the string parameters collection.
PartData | Gets or sets the part data record.
PartDefId | Gets the object id of PartDef.
PartDescription | Gets the part’s description.
PartSizeName | Gets the part size name.
PartSubType | Gets the part’s subtype.
PartType | Gets the type of the network park.
PipeCenterDepth | Gets the center depth of the pipe.
PipeInnerDiameterOrWidth | Gets the inner diameter or inner width of the pipe.
PipeInvertDepth | Gets the invert depth.
PipeLowestBottomDepth | Gets the lowest bottom depth of a pipe.
PipeOuterBottomDepth | Gets the outer bottom pipe depth.
PipeOuterTopDepth | Gets the outer top pipe depth.
PipeUpperTopDepth | Gets the upper top depth of a pipe.
PipeWallThickness | Gets the pipe wall thickness.
Position | Gets or sets the position of the network part.
ProfileViewPartId | Gets the object id of the part's counterpart in profile views.
RefAlignmentId | Gets or sets the object id of the alignment which this part references.
RefAlignmentName | Gets the name of the alignment which this part references
RefSurfaceId | Gets or sets the object id of the surface that this part references.
RefSurfaceName | Gets the name of the surface which this part references.
RimElevation | Gets or sets the rim elevation.
RimToSumpHeight | Gets or sets the distance between the sump to the structure’s rim.
Rotation | Gets or sets the structure rotation.
RuleSetStyleId | Gets or sets the object id of RuleSetStyle.
RuleSetStyleName | Gets or sets RuleSetStyle by name.
SectionViewPartId | Gets the object id of the part's counterpart in section views.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
Solid3dBody | Gets the 3d solid body of the part.
Station | Gets the structure’s station.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
SumpDepth | Gets or sets the sump depth.
SumpElevation | Gets or sets the sump elevation.
SurfaceAdjustmentValue | Gets or sets the surface adjustment value
SurfaceElevationAtInsertionPoint | Gets the inner diameter or inner width of the pipe.
SurfaceId | Gets or sets the object id of the surface that this part references.
VerticalPipeClearance | Gets the clearance required from the top outside of the highest pipe connected to the structure, to the rim.
WallThickness | Gets the wall thickness for this structure, measured from the inside edge of the structure to the outside edge of... more
Links
Public Methods, Public Properties


Structure Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods
Structure Methods
Collapse All

The methods of Structure are listed here.

Public Methods
Public Method | Description
ConnectToPipe | Connect this structure to the specified pipe.
Disconnect | Disconnect with pipe.
GetConnectedPipeNames | Gets all the connected pipe names.
GetLabelIds | Gets the collection of structure label ids.
IsConnectedPipeFlowingIn | Determines if the connected pipe is flowing into the structure
IsConnectedPipeFlowingOut | Determines if the connected pipe is flowing out of the structure
IsPointInsideStructureRegion | Returns true if the point is within the structure region.
ResizeByPipeDepths | Resize the structure by pipe depths.
ResizeJunctionStructure | Resize the Junction structure by rim and sump elevations.
Links
Public Methods


Structure::ConnectToPipe Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods > Structure::ConnectToPipe Method
Structure::ConnectToPipe Method
Collapse All

Connect this structure to the specified pipe.

C#
public ConnectToPipe(
    Autodesk::AutoCAD::DatabaseServices::ObjectId pipeId,
    ConnectorPositionType positionType
);
Visual Basic
Public Sub ConnectToPipe(
    pipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    positionType As ConnectorPositionType
)
Parameters
Parameters | Description
pipeId | The pipe to connect to.
positionType | The connector position, either start or end.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when pipeId's type is not Autodesk.Civil.PipeNetwork.Pipe.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Disconnect Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods > Structure::Disconnect Method
Structure::Disconnect Method
Collapse All

Disconnect with pipe.

C#
public Disconnect(
    Autodesk::AutoCAD::DatabaseServices::ObjectId pipeId
);
Visual Basic
Public Sub Disconnect(
    pipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
pipeId | The pipe to disconnect from.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when pipeId's type is not Autodesk.Civil.PipeNetwork.Pipe.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::GetConnectedPipeNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods > Structure::GetConnectedPipeNames Method
Structure::GetConnectedPipeNames Method
Collapse All

Gets all the connected pipe names.

C#
public array<System::String^> GetConnectedPipeNames();
Visual Basic
Public Function GetConnectedPipeNames() As array<System::String^>
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::GetLabelIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods > Structure::GetLabelIds Method
Structure::GetLabelIds Method
Collapse All

Gets the collection of structure label ids.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection GetLabelIds();
Visual Basic
Public Function GetLabelIds() As Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::IsConnectedPipeFlowingIn Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods > Structure::IsConnectedPipeFlowingIn Method
Structure::IsConnectedPipeFlowingIn Method
Collapse All

Determines if the connected pipe is flowing into the structure

C#
public bool IsConnectedPipeFlowingIn(
    int index
);
Visual Basic
Public Function IsConnectedPipeFlowingIn(
    index As Integer
) As bool
Parameters
Parameters | Description
index | The index of the pipe to check.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::IsConnectedPipeFlowingOut Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods > Structure::IsConnectedPipeFlowingOut Method
Structure::IsConnectedPipeFlowingOut Method
Collapse All

Determines if the connected pipe is flowing out of the structure

C#
public bool IsConnectedPipeFlowingOut(
    int index
);
Visual Basic
Public Function IsConnectedPipeFlowingOut(
    index As Integer
) As bool
Parameters
Parameters | Description
index | The index of the pipe to check.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::IsPointInsideStructureRegion Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods > Structure::IsPointInsideStructureRegion Method
Structure::IsPointInsideStructureRegion Method
Collapse All

Returns true if the point is within the structure region.

C#
public bool IsPointInsideStructureRegion(
    Autodesk::AutoCAD::Geometry::Point3d point
);
Visual Basic
Public Function IsPointInsideStructureRegion(
    point As Autodesk::AutoCAD::Geometry::Point3d
) As bool
Parameters
Parameters | Description
point | Point to test.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::ResizeByPipeDepths Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods > Structure::ResizeByPipeDepths Method
Structure::ResizeByPipeDepths Method
Collapse All

Resize the structure by pipe depths.

C#
public bool ResizeByPipeDepths();
Visual Basic
Public Function ResizeByPipeDepths() As bool
Returns

true if success, false if failed to resize.

Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::ResizeJunctionStructure Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods > Structure::ResizeJunctionStructure Method
Structure::ResizeJunctionStructure Method
Collapse All

Resize the Junction structure by rim and sump elevations.

C#
public ResizeJunctionStructure(
    ref System::String partFamilyGuid,
    double rimElevation,
    double sumpElevation
);
Visual Basic
Public Sub ResizeJunctionStructure(
    ByRef partFamilyGuid As System::String,
    rimElevation As double,
    sumpElevation As double
)
Parameters
Parameters | Description
partFamilyGuid | Part family's globally unique identifier.
rimElevation | Rim elevation
sumpElevation | Sump elevation.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties
Structure Properties
Collapse All

The properties of Structure are listed here.

Public Properties
Public Property | Description
AutomaticRimSurfaceAdjustment | Gets or sets whether the rim should be automatically adjusted.
BarrelPipeClearance | Gets the clearance of barrel pipe.
BoundingShape | Gets the structure bounding shape.
ConeHeight | Gets the height of the cone shaped section of the structure.
ConnectedPipe | Gets the pipe connected to the structure by index.
ConnectedPipesCount | Gets the count of the pipes connected to the structure.
ControlSumpBy | Gets or sets how the sump should be adjusted.
Cover | Gets the model or type of grate used for a structure intended to be used as a catchbasin.
DiameterOrWidth | Gets the structure diameter or width.
Easting | Gets or sets the structure’s easting.
FloorThickness | Gets the thickness of the bottom of the structure.
Frame | Gets the model or type of frame used for a structure.
FrameDiameter | Gets the diameter of the structure’s frame.
FrameHeight | Gets the height of the structure’s frame.
Grate | Gets the grate of the pipe.
HeadwallBaseThickness | Gets the thickness of the base of the headwall.
HeadwallBaseWidth | Gets the width of the base of the headwall.
Height | Gets the structure height.
InnerDiameterOrWidth | Gets the structure inner diameter or width.
InnerLength | Gets the structure inner length.
Length | Gets the structure length.
Location | Gets or sets the location.
Northing | Gets or sets the structure’s northing.
Offset | Gets the structure’s offset.
PipeCenterDepth | Gets the center depth of the pipe.
PipeInnerDiameterOrWidth | Gets the inner diameter or inner width of the pipe.
PipeInvertDepth | Gets the invert depth.
PipeLowestBottomDepth | Gets the lowest bottom depth of a pipe.
PipeOuterBottomDepth | Gets the outer bottom pipe depth.
PipeOuterTopDepth | Gets the outer top pipe depth.
PipeUpperTopDepth | Gets the upper top depth of a pipe.
PipeWallThickness | Gets the pipe wall thickness.
RimElevation | Gets or sets the rim elevation.
RimToSumpHeight | Gets or sets the distance between the sump to the structure’s rim.
Rotation | Gets or sets the structure rotation.
Station | Gets the structure’s station.
SumpDepth | Gets or sets the sump depth.
SumpElevation | Gets or sets the sump elevation.
SurfaceAdjustmentValue | Gets or sets the surface adjustment value
SurfaceElevationAtInsertionPoint | Gets the inner diameter or inner width of the pipe.
VerticalPipeClearance | Gets the clearance required from the top outside of the highest pipe connected to the structure, to the rim.
Links
Public Properties


Structure::AutomaticRimSurfaceAdjustment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::AutomaticRimSurfaceAdjustment Property
Structure::AutomaticRimSurfaceAdjustment Property
Collapse All

Gets or sets whether the rim should be automatically adjusted.

C#
public bool AutomaticRimSurfaceAdjustment;
Visual Basic
Public Property AutomaticRimSurfaceAdjustment() As bool
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::BarrelPipeClearance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::BarrelPipeClearance Property
Structure::BarrelPipeClearance Property
Collapse All

Gets the clearance of barrel pipe.

C#
public double BarrelPipeClearance;
Visual Basic
Public Property BarrelPipeClearance() As double
Remarks

This property lets you determine how close to the structure’s rim you can position a pipe. It is used for two-tiered junction structures only and specifies the clearance required above the top of the barrel section of the structure. It is similar to Vertical Pipe Clearance, but only describes the transition zone between the access cylinder and the larger barrel cylinder of a two-tiered structure.

Exceptions
Exceptions | Description
System.InvalidOperationException | The structure's type is not two-tiered junction.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::BoundingShape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::BoundingShape Property
Structure::BoundingShape Property
Collapse All

Gets the structure bounding shape.

C#
public BoundingShapeType BoundingShape;
Visual Basic
Public Property BoundingShape() As BoundingShapeType
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::ConeHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::ConeHeight Property
Structure::ConeHeight Property
Collapse All

Gets the height of the cone shaped section of the structure.

C#
public double ConeHeight;
Visual Basic
Public Property ConeHeight() As double
Remarks

This property is for two-tiered junction structures only.

Exceptions
Exceptions | Description
System.InvalidOperationException | The structure's type is not two-tiered junction.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::ConnectedPipe Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::ConnectedPipe Property
Structure::ConnectedPipe Property
Collapse All

Gets the pipe connected to the structure by index.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ConnectedPipe;
Visual Basic
Public Property ConnectedPipe() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::ConnectedPipesCount Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::ConnectedPipesCount Property
Structure::ConnectedPipesCount Property
Collapse All

Gets the count of the pipes connected to the structure.

C#
public int ConnectedPipesCount;
Visual Basic
Public Property ConnectedPipesCount() As Integer
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::ControlSumpBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::ControlSumpBy Property
Structure::ControlSumpBy Property
Collapse All

Gets or sets how the sump should be adjusted.

C#
public StructureControlSumpType ControlSumpBy;
Visual Basic
Public Property ControlSumpBy() As StructureControlSumpType
Remarks

Set to aeccElevation to modify the sump's elevation when you modify the pipe structure's elevation.

When set, it would hold the consistency with other related attributes/properties.

Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Cover Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Cover Property
Structure::Cover Property
Collapse All

Gets the model or type of grate used for a structure intended to be used as a catchbasin.

C#
public System::String Cover;
Visual Basic
Public Property Cover() As System::String
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::DiameterOrWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::DiameterOrWidth Property
Structure::DiameterOrWidth Property
Collapse All

Gets the structure diameter or width.

C#
public double DiameterOrWidth;
Visual Basic
Public Property DiameterOrWidth() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Easting Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Easting Property
Structure::Easting Property
Collapse All

Gets or sets the structure’s easting.

C#
public double Easting;
Visual Basic
Public Property Easting() As double
Remarks

When set, it would hold the consistency with other related attributes/properties.

Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::FloorThickness Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::FloorThickness Property
Structure::FloorThickness Property
Collapse All

Gets the thickness of the bottom of the structure.

C#
public double FloorThickness;
Visual Basic
Public Property FloorThickness() As double
Remarks

This property is for junction structures only.

Exceptions
Exceptions | Description
System.InvalidOperationException | The structure's type is not junction.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Frame Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Frame Property
Structure::Frame Property
Collapse All

Gets the model or type of frame used for a structure.

C#
public System::String Frame;
Visual Basic
Public Property Frame() As System::String
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::FrameDiameter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::FrameDiameter Property
Structure::FrameDiameter Property
Collapse All

Gets the diameter of the structure’s frame.

C#
public double FrameDiameter;
Visual Basic
Public Property FrameDiameter() As double
Remarks

This property is for junction structures only.

Exceptions
Exceptions | Description
System.InvalidOperationException | The structure's type is not junction.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::FrameHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::FrameHeight Property
Structure::FrameHeight Property
Collapse All

Gets the height of the structure’s frame.

C#
public double FrameHeight;
Visual Basic
Public Property FrameHeight() As double
Remarks

This property is for junction structures only.

Exceptions
Exceptions | Description
System.InvalidOperationException | The structure's type is not junction.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Grate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Grate Property
Structure::Grate Property
Collapse All

Gets the grate of the pipe.

C#
public System::String Grate;
Visual Basic
Public Property Grate() As System::String
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::HeadwallBaseThickness Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::HeadwallBaseThickness Property
Structure::HeadwallBaseThickness Property
Collapse All

Gets the thickness of the base of the headwall.

C#
public double HeadwallBaseThickness;
Visual Basic
Public Property HeadwallBaseThickness() As double
Remarks

This property is for inlet-outlet structures only.

Exceptions
Exceptions | Description
System.InvalidOperationException | The structure's type is not inlet-outlet.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::HeadwallBaseWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::HeadwallBaseWidth Property
Structure::HeadwallBaseWidth Property
Collapse All

Gets the width of the base of the headwall.

C#
public double HeadwallBaseWidth;
Visual Basic
Public Property HeadwallBaseWidth() As double
Remarks

This property is for inlet-outlet structures only.

Exceptions
Exceptions | Description
System.InvalidOperationException | The structure's type is not inlet-outlet.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Height Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Height Property
Structure::Height Property
Collapse All

Gets the structure height.

C#
public double Height;
Visual Basic
Public Property Height() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::InnerDiameterOrWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::InnerDiameterOrWidth Property
Structure::InnerDiameterOrWidth Property
Collapse All

Gets the structure inner diameter or width.

C#
public double InnerDiameterOrWidth;
Visual Basic
Public Property InnerDiameterOrWidth() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::InnerLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::InnerLength Property
Structure::InnerLength Property
Collapse All

Gets the structure inner length.

C#
public double InnerLength;
Visual Basic
Public Property InnerLength() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the structure's bounding shape is not box.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Length Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Length Property
Structure::Length Property
Collapse All

Gets the structure length.

C#
public double Length;
Visual Basic
Public Property Length() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the structure's bounding shape is not box.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Location Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Location Property
Structure::Location Property
Collapse All

Gets or sets the location.

C#
public Autodesk::AutoCAD::Geometry::Point3d Location;
Visual Basic
Public Property Location() As Autodesk::AutoCAD::Geometry::Point3d
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Northing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Northing Property
Structure::Northing Property
Collapse All

Gets or sets the structure’s northing.

C#
public double Northing;
Visual Basic
Public Property Northing() As double
Remarks

When set, it would hold the consistency with other related attributes/properties.

Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Offset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Offset Property
Structure::Offset Property
Collapse All

Gets the structure’s offset.

C#
public double Offset;
Visual Basic
Public Property Offset() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::PipeCenterDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::PipeCenterDepth Property
Structure::PipeCenterDepth Property
Collapse All

Gets the center depth of the pipe.

C#
public double PipeCenterDepth;
Visual Basic
Public Property PipeCenterDepth() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::PipeInnerDiameterOrWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::PipeInnerDiameterOrWidth Property
Structure::PipeInnerDiameterOrWidth Property
Collapse All

Gets the inner diameter or inner width of the pipe.

C#
public double PipeInnerDiameterOrWidth;
Visual Basic
Public Property PipeInnerDiameterOrWidth() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::PipeInvertDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::PipeInvertDepth Property
Structure::PipeInvertDepth Property
Collapse All

Gets the invert depth.

C#
public double PipeInvertDepth;
Visual Basic
Public Property PipeInvertDepth() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::PipeLowestBottomDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::PipeLowestBottomDepth Property
Structure::PipeLowestBottomDepth Property
Collapse All

Gets the lowest bottom depth of a pipe.

C#
public double PipeLowestBottomDepth;
Visual Basic
Public Property PipeLowestBottomDepth() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::PipeOuterBottomDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::PipeOuterBottomDepth Property
Structure::PipeOuterBottomDepth Property
Collapse All

Gets the outer bottom pipe depth.

C#
public double PipeOuterBottomDepth;
Visual Basic
Public Property PipeOuterBottomDepth() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::PipeOuterTopDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::PipeOuterTopDepth Property
Structure::PipeOuterTopDepth Property
Collapse All

Gets the outer top pipe depth.

C#
public double PipeOuterTopDepth;
Visual Basic
Public Property PipeOuterTopDepth() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::PipeUpperTopDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::PipeUpperTopDepth Property
Structure::PipeUpperTopDepth Property
Collapse All

Gets the upper top depth of a pipe.

C#
public double PipeUpperTopDepth;
Visual Basic
Public Property PipeUpperTopDepth() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::PipeWallThickness Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::PipeWallThickness Property
Structure::PipeWallThickness Property
Collapse All

Gets the pipe wall thickness.

C#
public double PipeWallThickness;
Visual Basic
Public Property PipeWallThickness() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::RimElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::RimElevation Property
Structure::RimElevation Property
Collapse All

Gets or sets the rim elevation.

C#
public double RimElevation;
Visual Basic
Public Property RimElevation() As double
Remarks

When set, it would hold the consistency with other related attributes/properties.

Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::RimToSumpHeight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::RimToSumpHeight Property
Structure::RimToSumpHeight Property
Collapse All

Gets or sets the distance between the sump to the structure’s rim.

C#
public double RimToSumpHeight;
Visual Basic
Public Property RimToSumpHeight() As double
Remarks

This property is for junction structures only.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when input value is less than zero.
System.InvalidOperationException | The structure's type is not junction.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Rotation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Rotation Property
Structure::Rotation Property
Collapse All

Gets or sets the structure rotation.

C#
public double Rotation;
Visual Basic
Public Property Rotation() As double
Remarks

When set, it would hold the consistency with other related attributes/properties.

Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::Station Property
Structure::Station Property
Collapse All

Gets the structure’s station.

C#
public double Station;
Visual Basic
Public Property Station() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::SumpDepth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::SumpDepth Property
Structure::SumpDepth Property
Collapse All

Gets or sets the sump depth.

C#
public double SumpDepth;
Visual Basic
Public Property SumpDepth() As double
Remarks

When set, it would hold the consistency with other related attributes/properties.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when input value is less than zero.
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::SumpElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::SumpElevation Property
Structure::SumpElevation Property
Collapse All

Gets or sets the sump elevation.

C#
public double SumpElevation;
Visual Basic
Public Property SumpElevation() As double
Remarks

When set, it would hold the consistency with other related attributes/properties.

Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::SurfaceAdjustmentValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::SurfaceAdjustmentValue Property
Structure::SurfaceAdjustmentValue Property
Collapse All

Gets or sets the surface adjustment value

C#
public double SurfaceAdjustmentValue;
Visual Basic
Public Property SurfaceAdjustmentValue() As double
Remarks

When set, it would hold the consistency with other related attributes/properties.

Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::SurfaceElevationAtInsertionPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::SurfaceElevationAtInsertionPoint Property
Structure::SurfaceElevationAtInsertionPoint Property
Collapse All

Gets the inner diameter or inner width of the pipe.

C#
public double SurfaceElevationAtInsertionPoint;
Visual Basic
Public Property SurfaceElevationAtInsertionPoint() As double
Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structure::VerticalPipeClearance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties > Structure::VerticalPipeClearance Property
Structure::VerticalPipeClearance Property
Collapse All

Gets the clearance required from the top outside of the highest pipe connected to the structure, to the rim.

C#
public double VerticalPipeClearance;
Visual Basic
Public Property VerticalPipeClearance() As double
Remarks

This is defined in the catalog and ensure that pipes enter the structure at an appropriate elevation. For example, it prevents a pipe from entering through the cone of structure.

Links
Structure Class, Structure Members, Autodesk::Civil::PipeNetwork::DatabaseServices Namespace


Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums
Structs, Records, Enums
Collapse All

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
BoundingShapeType | Specifies bounding shapes for Part objects.
ConnectorPositionType | Specifies the connector position.
DomainType | Specifies a Part domain type.
FlowDirectionMethodType | Specifies the method that is used to determine the flow for a pipe.
FlowDirectionType | Specifies the current flow direction of a pipe.
HoldOnResizeType | Specifies the pipe behavior that occurs when the pipe is automatically resized.
PartCatalogDataType | Specifies the data type of the reserved data.
PartContextType | Specifies the context type, which corresponds to every property of a Part.
PartParamUsageType | Defines the usage of a part catalog parameter.
PartType | Specifies a Part type.
PipeSubEntityType | Specifies the subentity type of a pipe.
StructureControlSumpType | Specifies how a sump should be adjusted.
SweptShapeType | Specifies the swept shape of a pipe.
Links
Enumerations


Autodesk::Civil::PipeNetwork::DatabaseServices::BoundingShapeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::BoundingShapeType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::BoundingShapeType Enumeration
Collapse All

Specifies bounding shapes for Part objects.

C#
public enum BoundingShapeType {
  Undefined = AeccNetworkEnums::kUndefinedBoundingShape,
  Cylinder = AeccNetworkEnums::kBoundingShapeCylinder,
  Box = AeccNetworkEnums::kBoundingShapeBox,
  Sphere = AeccNetworkEnums::kBoundingShapeSphere
}
Visual Basic
Public Enum BoundingShapeType
  Undefined = AeccNetworkEnums::kUndefinedBoundingShape
  Cylinder = AeccNetworkEnums::kBoundingShapeCylinder
  Box = AeccNetworkEnums::kBoundingShapeBox
  Sphere = AeccNetworkEnums::kBoundingShapeSphere
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::ConnectorPositionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::ConnectorPositionType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::ConnectorPositionType Enumeration
Collapse All

Specifies the connector position.

C#
public enum ConnectorPositionType {
  Start = AeccDbPipe::kPipeStart,
  End = AeccDbPipe::kPipeEnd
}
Visual Basic
Public Enum ConnectorPositionType
  Start = AeccDbPipe::kPipeStart
  End = AeccDbPipe::kPipeEnd
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType Enumeration
Collapse All

Specifies a Part domain type.

C#
public enum DomainType {
  Pipe = AeccNetworkEnums::kDomPipe,
  Structure = AeccNetworkEnums::kDomStructure
}
Visual Basic
Public Enum DomainType
  Pipe = AeccNetworkEnums::kDomPipe
  Structure = AeccNetworkEnums::kDomStructure
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::FlowDirectionMethodType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::FlowDirectionMethodType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::FlowDirectionMethodType Enumeration
Collapse All

Specifies the method that is used to determine the flow for a pipe.

C#
public enum FlowDirectionMethodType {
  Bidirectional = AeccDbPipe::kFDMBidirectional,
  StartToEnd = AeccDbPipe::kFDMStartToEnd,
  EndToStart = AeccDbPipe::kFDMEndToStart,
  BySlope = AeccDbPipe::kFDMBySlope
}
Visual Basic
Public Enum FlowDirectionMethodType
  Bidirectional = AeccDbPipe::kFDMBidirectional
  StartToEnd = AeccDbPipe::kFDMStartToEnd
  EndToStart = AeccDbPipe::kFDMEndToStart
  BySlope = AeccDbPipe::kFDMBySlope
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::FlowDirectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::FlowDirectionType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::FlowDirectionType Enumeration
Collapse All

Specifies the current flow direction of a pipe.

C#
public enum FlowDirectionType {
  Bidirectional = AeccDbPipe::kBidirectional,
  StartToEnd = AeccDbPipe::kStartToEnd,
  EndToStart = AeccDbPipe::kEndToStart
}
Visual Basic
Public Enum FlowDirectionType
  Bidirectional = AeccDbPipe::kBidirectional
  StartToEnd = AeccDbPipe::kStartToEnd
  EndToStart = AeccDbPipe::kEndToStart
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::HoldOnResizeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::HoldOnResizeType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::HoldOnResizeType Enumeration
Collapse All

Specifies the pipe behavior that occurs when the pipe is automatically resized.

C#
public enum HoldOnResizeType {
  Invert = AeccDbPipe::kInvert,
  Crown = AeccDbPipe::kCrown,
  Centerline = AeccDbPipe::kCenterline
}
Visual Basic
Public Enum HoldOnResizeType
  Invert = AeccDbPipe::kInvert
  Crown = AeccDbPipe::kCrown
  Centerline = AeccDbPipe::kCenterline
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::PartCatalogDataType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::PartCatalogDataType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::PartCatalogDataType Enumeration
Collapse All

Specifies the data type of the reserved data.

C#
public enum PartCatalogDataType {
  Double = AeccNetworkEnums::kDouble,
  Int = AeccNetworkEnums::kInt,
  Bool = AeccNetworkEnums::kBool,
  String = AeccNetworkEnums::kString
}
Visual Basic
Public Enum PartCatalogDataType
  Double = AeccNetworkEnums::kDouble
  Int = AeccNetworkEnums::kInt
  Bool = AeccNetworkEnums::kBool
  String = AeccNetworkEnums::kString
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::PartContextType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::PartContextType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::PartContextType Enumeration
Collapse All

Specifies the context type, which corresponds to every property of a Part.

C#
public enum PartContextType {
  Material = AeccNetworkEnums::kMaterial,
  WallThickness = AeccNetworkEnums::kWallThickness,
  FloorThickness = AeccNetworkEnums::kFloorThickness,
  ConnectionType = AeccNetworkEnums::kConnectionType,
  SweptShape = AeccNetworkEnums::kSweptShape,
  PipeInnerDiameter = AeccNetworkEnums::kPipeInnerDiameter,
  PipeInnerHeight = AeccNetworkEnums::kPipeInnerHeight,
  PipeInnerWidth = AeccNetworkEnums::kPipeInnerWidth,
  PipeInnerBottomToBasePoint = AeccNetworkEnums::kPipeInnerBottomToBasePoint,
  MinCurveRadius = AeccNetworkEnums::kMinCurveRadius,
  FlowAnalysisManning = AeccNetworkEnums::kFlowAnalysisManning,
  FlowAnalysisHazenWilliams = AeccNetworkEnums::kFlowAnalysisHazenWilliams,
  FlowAnalysisDarcyWeisbach = AeccNetworkEnums::kFlowAnalysisDarcyWeisbach,
  StructBoundingShape = AeccNetworkEnums::kStructBoundingShape,
  StructHeight = AeccNetworkEnums::kStructHeight,
  StructDiameter = AeccNetworkEnums::kStructDiameter,
  StructLength = AeccNetworkEnums::kStructLength,
  StructWidth = AeccNetworkEnums::kStructWidth,
  StructRimToSumpHeight = AeccNetworkEnums::kStructRimToSumpHeight,
  StructBarrelHeight = AeccNetworkEnums::kStructBarrelHeight,
  StructRiserHeight = AeccNetworkEnums::kStructRiserHeight,
  StructInnerDiameter = AeccNetworkEnums::kStructInnerDiameter,
  StructInnerLength = AeccNetworkEnums::kStructInnerLength,
  StructInnerWidth = AeccNetworkEnums::kStructInnerWidth,
  StructFrameHeight = AeccNetworkEnums::kStructFrameHeight,
  StructFrameDiameter = AeccNetworkEnums::kStructFrameDiameter,
  StructFrameLength = AeccNetworkEnums::kStructFrameLength,
  StructFrame = AeccNetworkEnums::kStructFrame,
  StructGrate = AeccNetworkEnums::kStructGrate,
  StructCover = AeccNetworkEnums::kStructCover,
  StructHeadwallBaseWidth = AeccNetworkEnums::kStructHeadwallBaseWidth,
  StructHeadwallBaseThickness = AeccNetworkEnums::kStructHeadwallBaseThickness,
  StructHeadwallTopWidth = AeccNetworkEnums::kStructHeadwallTopWidth,
  StructHeadwallTopThickness = AeccNetworkEnums::kStructHeadwallTopThickness,
  StructWingBackHeight = AeccNetworkEnums::kStructWingBackHeight,
  StructWingFrontHeight = AeccNetworkEnums::kStructWingFrontHeight,
  StructWingLength = AeccNetworkEnums::kStructWingLength,
  StructWingThickness = AeccNetworkEnums::kStructWingThickness,
  StructApronBackThickness = AeccNetworkEnums::kStructApronBackThickness,
  StructApronFrontThickness = AeccNetworkEnums::kStructApronFrontThickness,
  StructApronLength = AeccNetworkEnums::kStructApronLength,
  StructApronWidth = AeccNetworkEnums::kStructApronWidth,
  StructFrameWidth = AeccNetworkEnums::kStructFrameWidth,
  StructVerticalPipeClearance = AeccNetworkEnums::kStructVerticalPipeClearance,
  StructHorizontalPipeClearance = AeccNetworkEnums::kStructHorizontalPipeClearance,
  StructBarrelPipeClearance = AeccNetworkEnums::kStructBarrelPipeClearance,
  StructConeHeight = AeccNetworkEnums::kStructConeHeight,
  StructSlabThickness = AeccNetworkEnums::kStructSlabThickness,
  StructPipeOuterBottomElevation = AeccNetworkEnums::kStructPipeOuterBottomElevation,
  StructPipeInvertElevation = AeccNetworkEnums::kStructPipeInvertElevation,
  StructPipeCenterElevation = AeccNetworkEnums::kStructPipeCenterElevation,
  StructPipeCrownElevation = AeccNetworkEnums::kStructPipeCrownElevation,
  StructPipeOuterTopElevation = AeccNetworkEnums::kStructPipeOuterTopElevation,
  StructPipeInnerWidth = AeccNetworkEnums::kStructPipeInnerWidth,
  StructPipeInnerHeight = AeccNetworkEnums::kStructPipeInnerHeight,
  StructPipeOuterWidth = AeccNetworkEnums::kStructPipeOuterWidth,
  StructPipeOuterHeight = AeccNetworkEnums::kStructPipeOuterHeight,
  StructPipeFlowDirection = AeccNetworkEnums::kStructPipeFlowDirection,
  StructPipeDirection = AeccNetworkEnums::kStructPipeDirection,
  StructPipeShape = AeccNetworkEnums::kStructPipeShape,
  StructPipeWallThickness = AeccNetworkEnums::kStructPipeWallThickness,
  StructPipeMaterial = AeccNetworkEnums::kStructPipeMaterial
}
Visual Basic
Public Enum PartContextType
  Material = AeccNetworkEnums::kMaterial
  WallThickness = AeccNetworkEnums::kWallThickness
  FloorThickness = AeccNetworkEnums::kFloorThickness
  ConnectionType = AeccNetworkEnums::kConnectionType
  SweptShape = AeccNetworkEnums::kSweptShape
  PipeInnerDiameter = AeccNetworkEnums::kPipeInnerDiameter
  PipeInnerHeight = AeccNetworkEnums::kPipeInnerHeight
  PipeInnerWidth = AeccNetworkEnums::kPipeInnerWidth
  PipeInnerBottomToBasePoint = AeccNetworkEnums::kPipeInnerBottomToBasePoint
  MinCurveRadius = AeccNetworkEnums::kMinCurveRadius
  FlowAnalysisManning = AeccNetworkEnums::kFlowAnalysisManning
  FlowAnalysisHazenWilliams = AeccNetworkEnums::kFlowAnalysisHazenWilliams
  FlowAnalysisDarcyWeisbach = AeccNetworkEnums::kFlowAnalysisDarcyWeisbach
  StructBoundingShape = AeccNetworkEnums::kStructBoundingShape
  StructHeight = AeccNetworkEnums::kStructHeight
  StructDiameter = AeccNetworkEnums::kStructDiameter
  StructLength = AeccNetworkEnums::kStructLength
  StructWidth = AeccNetworkEnums::kStructWidth
  StructRimToSumpHeight = AeccNetworkEnums::kStructRimToSumpHeight
  StructBarrelHeight = AeccNetworkEnums::kStructBarrelHeight
  StructRiserHeight = AeccNetworkEnums::kStructRiserHeight
  StructInnerDiameter = AeccNetworkEnums::kStructInnerDiameter
  StructInnerLength = AeccNetworkEnums::kStructInnerLength
  StructInnerWidth = AeccNetworkEnums::kStructInnerWidth
  StructFrameHeight = AeccNetworkEnums::kStructFrameHeight
  StructFrameDiameter = AeccNetworkEnums::kStructFrameDiameter
  StructFrameLength = AeccNetworkEnums::kStructFrameLength
  StructFrame = AeccNetworkEnums::kStructFrame
  StructGrate = AeccNetworkEnums::kStructGrate
  StructCover = AeccNetworkEnums::kStructCover
  StructHeadwallBaseWidth = AeccNetworkEnums::kStructHeadwallBaseWidth
  StructHeadwallBaseThickness = AeccNetworkEnums::kStructHeadwallBaseThickness
  StructHeadwallTopWidth = AeccNetworkEnums::kStructHeadwallTopWidth
  StructHeadwallTopThickness = AeccNetworkEnums::kStructHeadwallTopThickness
  StructWingBackHeight = AeccNetworkEnums::kStructWingBackHeight
  StructWingFrontHeight = AeccNetworkEnums::kStructWingFrontHeight
  StructWingLength = AeccNetworkEnums::kStructWingLength
  StructWingThickness = AeccNetworkEnums::kStructWingThickness
  StructApronBackThickness = AeccNetworkEnums::kStructApronBackThickness
  StructApronFrontThickness = AeccNetworkEnums::kStructApronFrontThickness
  StructApronLength = AeccNetworkEnums::kStructApronLength
  StructApronWidth = AeccNetworkEnums::kStructApronWidth
  StructFrameWidth = AeccNetworkEnums::kStructFrameWidth
  StructVerticalPipeClearance = AeccNetworkEnums::kStructVerticalPipeClearance
  StructHorizontalPipeClearance = AeccNetworkEnums::kStructHorizontalPipeClearance
  StructBarrelPipeClearance = AeccNetworkEnums::kStructBarrelPipeClearance
  StructConeHeight = AeccNetworkEnums::kStructConeHeight
  StructSlabThickness = AeccNetworkEnums::kStructSlabThickness
  StructPipeOuterBottomElevation = AeccNetworkEnums::kStructPipeOuterBottomElevation
  StructPipeInvertElevation = AeccNetworkEnums::kStructPipeInvertElevation
  StructPipeCenterElevation = AeccNetworkEnums::kStructPipeCenterElevation
  StructPipeCrownElevation = AeccNetworkEnums::kStructPipeCrownElevation
  StructPipeOuterTopElevation = AeccNetworkEnums::kStructPipeOuterTopElevation
  StructPipeInnerWidth = AeccNetworkEnums::kStructPipeInnerWidth
  StructPipeInnerHeight = AeccNetworkEnums::kStructPipeInnerHeight
  StructPipeOuterWidth = AeccNetworkEnums::kStructPipeOuterWidth
  StructPipeOuterHeight = AeccNetworkEnums::kStructPipeOuterHeight
  StructPipeFlowDirection = AeccNetworkEnums::kStructPipeFlowDirection
  StructPipeDirection = AeccNetworkEnums::kStructPipeDirection
  StructPipeShape = AeccNetworkEnums::kStructPipeShape
  StructPipeWallThickness = AeccNetworkEnums::kStructPipeWallThickness
  StructPipeMaterial = AeccNetworkEnums::kStructPipeMaterial
End Enum
Members
Members | Description
PipeInnerDiameter | model parameter -- required for circular pipes
PipeInnerHeight | model parameter -- required for non-circ pipes
PipeInnerWidth | model parameter -- required for non-circ pipes
PipeInnerBottomToBasePoint | retired pre-Macallan release DO NOT USE
StructBoundingShape | General Outside Shape -- Box or Cylinder
StructHeight | model parameter -- required for all structures
StructDiameter | model parameter -- required for all cylindrical structures
StructLength | model parameter -- required for all rectangular structures
StructWidth | model parameter -- required for all rectangular structures
StructRimToSumpHeight | Junction structure required size parameter
StructBarrelHeight | Junction structure main (cyl or rect) Barrel Height
StructRiserHeight | Additional height sections above the Junction structure barrel
StructInnerDiameter | Junction structure inner base (barrel) dimensions
StructFrameHeight | Junction structure frame size parameters
StructFrameDiameter | Optional Frame Dim
StructFrameLength | Optional Frame Dim -- width AeccNetworkEnums:: below
StructFrame | Junction structure sub-assembly Frame+Grate or Frame+Cover references
StructHeadwallBaseWidth | Inlet-Outlet structure size parameters
StructWingBackHeight | Optional Wing Component to Inlet-Outlet parameters
StructApronBackThickness | Optional Apron Component to Inlet-Outlet arameters
StructVerticalPipeClearance | Used by app to verify pipe depths match part
StructBarrelPipeClearance | Constant offset value -- min distance from edges
StructConeHeight | Content-specific alternative to Structure Riser Height
StructSlabThickness | Content-specific alternative to Structure Riser Height
StructPipeInnerWidth | Circular pipe Dia == Width
StructPipeInnerHeight | Circular pipe Dia == Height
StructPipeOuterWidth | Circular pipe uses outer dia
StructPipeOuterHeight | Circular pipe uses outer dia
StructPipeDirection | N,NE,E,SE,S,SW,W,NW
StructPipeShape | Local String


Autodesk::Civil::PipeNetwork::DatabaseServices::PartParamUsageType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::PartParamUsageType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::PartParamUsageType Enumeration
Collapse All

Defines the usage of a part catalog parameter.

C#
public enum PartParamUsageType {
  DoubleGeneral = AeccNetworkEnums::kDoubleGeneral,
  DoubleNonZero = AeccNetworkEnums::kDoubleNonZero,
  DoubleNonZeroNonNegative = AeccNetworkEnums::kDoubleNonZeroNonNeg,
  DoubleDistance = AeccNetworkEnums::kDoubleDistance,
  DoubleDistanceMinor = AeccNetworkEnums::kDoubleDistanceMinor,
  DoubleAngle = AeccNetworkEnums::kDoubleAngle,
  DoublePercent = AeccNetworkEnums::kDoublePercent,
  DoubleArea = AeccNetworkEnums::kDoubleArea,
  DoubleVolume = AeccNetworkEnums::kDoubleVolume,
  DoubleElevation = AeccNetworkEnums::kDoubleElevation,
  IntGeneral = AeccNetworkEnums::kIntGeneral,
  IntNonZero = AeccNetworkEnums::kIntNonZero,
  IntNonZeroNonNegative = AeccNetworkEnums::kIntNonZeroNonNeg,
  StringGeneral = AeccNetworkEnums::kStringGeneral,
  StringName = AeccNetworkEnums::kStringName,
  StringGuid = AeccNetworkEnums::kStringGuid,
  StringEnumKey = AeccNetworkEnums::kStringEnumKey,
  BoolGeneral = AeccNetworkEnums::kBoolGeneral,
  MultipleValuePosition = AeccNetworkEnums::kMultivalPosition,
  MultipleValueDirection = AeccNetworkEnums::kMultivalDirection
}
Visual Basic
Public Enum PartParamUsageType
  DoubleGeneral = AeccNetworkEnums::kDoubleGeneral
  DoubleNonZero = AeccNetworkEnums::kDoubleNonZero
  DoubleNonZeroNonNegative = AeccNetworkEnums::kDoubleNonZeroNonNeg
  DoubleDistance = AeccNetworkEnums::kDoubleDistance
  DoubleDistanceMinor = AeccNetworkEnums::kDoubleDistanceMinor
  DoubleAngle = AeccNetworkEnums::kDoubleAngle
  DoublePercent = AeccNetworkEnums::kDoublePercent
  DoubleArea = AeccNetworkEnums::kDoubleArea
  DoubleVolume = AeccNetworkEnums::kDoubleVolume
  DoubleElevation = AeccNetworkEnums::kDoubleElevation
  IntGeneral = AeccNetworkEnums::kIntGeneral
  IntNonZero = AeccNetworkEnums::kIntNonZero
  IntNonZeroNonNegative = AeccNetworkEnums::kIntNonZeroNonNeg
  StringGeneral = AeccNetworkEnums::kStringGeneral
  StringName = AeccNetworkEnums::kStringName
  StringGuid = AeccNetworkEnums::kStringGuid
  StringEnumKey = AeccNetworkEnums::kStringEnumKey
  BoolGeneral = AeccNetworkEnums::kBoolGeneral
  MultipleValuePosition = AeccNetworkEnums::kMultivalPosition
  MultipleValueDirection = AeccNetworkEnums::kMultivalDirection
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::PartType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::PartType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::PartType Enumeration
Collapse All

Specifies a Part type.

C#
public enum PartType {
  UndefinedPartType = AeccNetworkEnums::kUndefinedPartType,
  Pipe = AeccNetworkEnums::kPipe,
  Channel = AeccNetworkEnums::kChannel,
  Wire = AeccNetworkEnums::kWire,
  Conduit = AeccNetworkEnums::kConduit,
  StructNull = AeccNetworkEnums::kStructNull,
  StructJunction = AeccNetworkEnums::kStructJunction,
  StructInletOutlet = AeccNetworkEnums::kStructInletOutlet,
  StructGeneral = AeccNetworkEnums::kStructGeneral,
  StructEquipment = AeccNetworkEnums::kStructEquipment
}
Visual Basic
Public Enum PartType
  UndefinedPartType = AeccNetworkEnums::kUndefinedPartType
  Pipe = AeccNetworkEnums::kPipe
  Channel = AeccNetworkEnums::kChannel
  Wire = AeccNetworkEnums::kWire
  Conduit = AeccNetworkEnums::kConduit
  StructNull = AeccNetworkEnums::kStructNull
  StructJunction = AeccNetworkEnums::kStructJunction
  StructInletOutlet = AeccNetworkEnums::kStructInletOutlet
  StructGeneral = AeccNetworkEnums::kStructGeneral
  StructEquipment = AeccNetworkEnums::kStructEquipment
End Enum
Members
Members | Description
UndefinedPartType | initialization only, not valid in content
Wire | Usage TBD out of Macallan Scope
Conduit | Usage TBD out of Macallan Scope
StructEquipment | Usage TBD out of Macallan Scope


Autodesk::Civil::PipeNetwork::DatabaseServices::PipeSubEntityType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::PipeSubEntityType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::PipeSubEntityType Enumeration
Collapse All

Specifies the subentity type of a pipe.

C#
public enum PipeSubEntityType {
  Straight = AeccDbPipe::kStraight,
  Curved = AeccDbPipe::kCurved,
  Segmented = AeccDbPipe::kSegmented,
  Flex = AeccDbPipe::kFlex
}
Visual Basic
Public Enum PipeSubEntityType
  Straight = AeccDbPipe::kStraight
  Curved = AeccDbPipe::kCurved
  Segmented = AeccDbPipe::kSegmented
  Flex = AeccDbPipe::kFlex
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::StructureControlSumpType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::StructureControlSumpType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::StructureControlSumpType Enumeration
Collapse All

Specifies how a sump should be adjusted.

C#
public enum StructureControlSumpType {
  ByDepth = AeccDbStructure::kDepth,
  ByElevation = AeccDbStructure::kElevation
}
Visual Basic
Public Enum StructureControlSumpType
  ByDepth = AeccDbStructure::kDepth
  ByElevation = AeccDbStructure::kElevation
End Enum


Autodesk::Civil::PipeNetwork::DatabaseServices::SweptShapeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DatabaseServices::SweptShapeType Enumeration
Autodesk::Civil::PipeNetwork::DatabaseServices::SweptShapeType Enumeration
Collapse All

Specifies the swept shape of a pipe.

C#
public enum SweptShapeType {
  Undefined = AeccNetworkEnums::kUndefinedSweptShape,
  CustomShape = AeccNetworkEnums::kCustomShape,
  Circular = AeccNetworkEnums::kCircular,
  Rectangular = AeccNetworkEnums::kRectangular,
  Elliptical = AeccNetworkEnums::kElliptical,
  EggShaped = AeccNetworkEnums::kEggShaped,
  HorizontalElliptical = AeccNetworkEnums::kHorizontalElliptical,
  Arched = AeccNetworkEnums::kArched
}
Visual Basic
Public Enum SweptShapeType
  Undefined = AeccNetworkEnums::kUndefinedSweptShape
  CustomShape = AeccNetworkEnums::kCustomShape
  Circular = AeccNetworkEnums::kCircular
  Rectangular = AeccNetworkEnums::kRectangular
  Elliptical = AeccNetworkEnums::kElliptical
  EggShaped = AeccNetworkEnums::kEggShaped
  HorizontalElliptical = AeccNetworkEnums::kHorizontalElliptical
  Arched = AeccNetworkEnums::kArched
End Enum


Autodesk::Civil::PipeNetwork::Settings Namespace

The Autodesk::Civil::PipeNetwork::Settings namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Classes
Class | Description
SettingsCmdAddNetworkPartPlanLabel | Settings for AddNetworkPartPlanLabel command.
SettingsCmdAddNetworkPartProfLabel | Settings for AddNetworkPartProfLabel command.
SettingsCmdAddNetworkPartSectLabel | Settings for AddNetworkPartSectLabel command.
SettingsCmdAddNetworkPartsToProf | Settings for AddNetworkPartsToProf command.
SettingsCmdAddNetworkPipeTable | Settings for AddNetworkPlanTable command.
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation | Settings for alignment type option.
SettingsCmdAddNetworkPlanLabels | Settings for AddNetworkPlanLabels command.
SettingsCmdAddNetworkProfLabels | Settings for AddNetworkProfLables command.
SettingsCmdAddNetworkSectLabels | Settings for AddNetworkSectLables command.
SettingsCmdAddNetworkStructTable | Settings for AddNetworkStructTable command.
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation | Settings for alignment type option.
SettingsCmdAddSpanningPipePlanLabel | Settings for AddSpanningPipePlanLabel command.
SettingsCmdAddSpanningPipeProfLabel | Settings for AddSpanningPipeProfLabel command.
SettingsCmdCreateAlignFromNetwork | Settings for CreateAlignFromNetwork command.
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption | Settings for alignment type option.
SettingsCmdCreateInterferenceCheck | Settings for CreateInterferenceCheck command.
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria | Settings for interference criteria.
SettingsCmdCreateNetwork | Settings for CreateNetwork command.
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts | Settings for alignment type option.
SettingsCmdCreateNetworkFromObject | Settings for CreateNetworkFromObject command.
SettingsCmdCreateNetworkPartsList | Settings for CreateNetworkPartsList command.
SettingsCmdCreateNetworkPartsListFull | Settings for CreateNetworkPartsListFull command.
SettingsCmdCreateNetworkReference | Settings for CreateNetworkReference command.
SettingsCmdEditInStormSewers | Settings for EditInStormSewers command.
SettingsCmdExportStormSewerData | Settings for ExportStormSewerData command.
SettingsCmdImportStormSewerData | Settings for ImportStormSewerData command.
SettingsCmdRenamePipeNetworkParts | Settings for RenamePipeNetworkParts command.
SettingsCmdResetAnchorPipe | Settings for ResetAnchorPipe command.
SettingsCmdShowSpanningPipes | Settings for ShowSpanningPipes command.
SettingsPipe | Settings for Pipe.
SettingsPipeNetwork | Settings for PipeNetwork.
SettingsPipeNetwork::SettingsNameFormat | Settings for PipeNetwork default NameFormat.
SettingsPipeNetwork::SettingsProfileLabelPlacement | Settings for PipeNetwork default ProfileLabelPlacement.
SettingsPipeNetwork::SettingsRules | Settings for PipeNetwork default Rules.
SettingsPipeNetwork::SettingsSectionLabelPlacement | Settings for PipeNetwork default SectionLabelPlacement.
SettingsPipeNetwork::SettingsStormSewersMigration | Settings for PipeNetwork default StormSewersMigration.
SettingsPipeNetwork::SettingsStyles | Settings for PipeNetwork default Styles.
SettingsStructure | Settings for Structure.
Links
Topics, Classes


Classes

The following table lists classes in this documentation.

Classes
Class | Description
SettingsCmdAddNetworkPartPlanLabel | Settings for AddNetworkPartPlanLabel command.
SettingsCmdAddNetworkPartProfLabel | Settings for AddNetworkPartProfLabel command.
SettingsCmdAddNetworkPartSectLabel | Settings for AddNetworkPartSectLabel command.
SettingsCmdAddNetworkPartsToProf | Settings for AddNetworkPartsToProf command.
SettingsCmdAddNetworkPipeTable | Settings for AddNetworkPlanTable command.
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation | Settings for alignment type option.
SettingsCmdAddNetworkPlanLabels | Settings for AddNetworkPlanLabels command.
SettingsCmdAddNetworkProfLabels | Settings for AddNetworkProfLables command.
SettingsCmdAddNetworkSectLabels | Settings for AddNetworkSectLables command.
SettingsCmdAddNetworkStructTable | Settings for AddNetworkStructTable command.
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation | Settings for alignment type option.
SettingsCmdAddSpanningPipePlanLabel | Settings for AddSpanningPipePlanLabel command.
SettingsCmdAddSpanningPipeProfLabel | Settings for AddSpanningPipeProfLabel command.
SettingsCmdCreateAlignFromNetwork | Settings for CreateAlignFromNetwork command.
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption | Settings for alignment type option.
SettingsCmdCreateInterferenceCheck | Settings for CreateInterferenceCheck command.
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria | Settings for interference criteria.
SettingsCmdCreateNetwork | Settings for CreateNetwork command.
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts | Settings for alignment type option.
SettingsCmdCreateNetworkFromObject | Settings for CreateNetworkFromObject command.
SettingsCmdCreateNetworkPartsList | Settings for CreateNetworkPartsList command.
SettingsCmdCreateNetworkPartsListFull | Settings for CreateNetworkPartsListFull command.
SettingsCmdCreateNetworkReference | Settings for CreateNetworkReference command.
SettingsCmdEditInStormSewers | Settings for EditInStormSewers command.
SettingsCmdExportStormSewerData | Settings for ExportStormSewerData command.
SettingsCmdImportStormSewerData | Settings for ImportStormSewerData command.
SettingsCmdRenamePipeNetworkParts | Settings for RenamePipeNetworkParts command.
SettingsCmdResetAnchorPipe | Settings for ResetAnchorPipe command.
SettingsCmdShowSpanningPipes | Settings for ShowSpanningPipes command.
SettingsPipe | Settings for Pipe.
SettingsPipeNetwork | Settings for PipeNetwork.
SettingsPipeNetwork::SettingsNameFormat | Settings for PipeNetwork default NameFormat.
SettingsPipeNetwork::SettingsProfileLabelPlacement | Settings for PipeNetwork default ProfileLabelPlacement.
SettingsPipeNetwork::SettingsRules | Settings for PipeNetwork default Rules.
SettingsPipeNetwork::SettingsSectionLabelPlacement | Settings for PipeNetwork default SectionLabelPlacement.
SettingsPipeNetwork::SettingsStormSewersMigration | Settings for PipeNetwork default StormSewersMigration.
SettingsPipeNetwork::SettingsStyles | Settings for PipeNetwork default Styles.
SettingsStructure | Settings for Structure.
Links
Classes


SettingsCmdAddNetworkPartPlanLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPartPlanLabel Class
SettingsCmdAddNetworkPartPlanLabel Class
Collapse All

Settings for AddNetworkPartPlanLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartPlanLabel
C#
public class SettingsCmdAddNetworkPartPlanLabel : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddNetworkPartPlanLabel
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdAddNetworkPartProfLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPartProfLabel Class
SettingsCmdAddNetworkPartProfLabel Class
Collapse All

Settings for AddNetworkPartProfLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartProfLabel
C#
public class SettingsCmdAddNetworkPartProfLabel : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddNetworkPartProfLabel
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdAddNetworkPartSectLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPartSectLabel Class
SettingsCmdAddNetworkPartSectLabel Class
Collapse All

Settings for AddNetworkPartSectLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartSectLabel
C#
public class SettingsCmdAddNetworkPartSectLabel : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddNetworkPartSectLabel
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdAddNetworkPartsToProf Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPartsToProf Class
SettingsCmdAddNetworkPartsToProf Class
Collapse All

Settings for AddNetworkPartsToProf command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartsToProf
C#
public class SettingsCmdAddNetworkPartsToProf : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddNetworkPartsToProf
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdAddNetworkPipeTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class
SettingsCmdAddNetworkPipeTable Class
Collapse All

Settings for AddNetworkPlanTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPipeTable
C#
public class SettingsCmdAddNetworkPipeTable : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddNetworkPipeTable
Inherits SettingsPipeNetwork
Links
SettingsCmdAddNetworkPipeTable Properties, SettingsCmdAddNetworkPipeTable Members, Class Hierarchy


SettingsCmdAddNetworkPipeTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Members
SettingsCmdAddNetworkPipeTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddNetworkPipeTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TableCreation | Gets the defaults when you add a network pipe table.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddNetworkPipeTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Properties
SettingsCmdAddNetworkPipeTable Properties
Collapse All

The properties of SettingsCmdAddNetworkPipeTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the defaults when you add a network pipe table.
Links
Public Properties


SettingsCmdAddNetworkPipeTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Properties > SettingsCmdAddNetworkPipeTable::TableCreation Property
SettingsCmdAddNetworkPipeTable::TableCreation Property
Collapse All

Gets the defaults when you add a network pipe table.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdAddNetworkPipeTable Class, SettingsCmdAddNetworkPipeTable Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class
Collapse All

Settings for alignment type option.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation
C#
public class SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties, SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Gets the maximum number of rows to include per section.
MaximumTablesPerStack | Gets the maximum number of sections to include in each stack.
SplitTable | Gets whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Gets the spacing between tables.
TableStyle | Gets the style for a table.
TileDirection | Gets the direction in which the table tiles (across or down).
Links
Public Properties


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Gets the maximum number of rows to include per section.
MaximumTablesPerStack | Gets the maximum number of sections to include in each stack.
SplitTable | Gets whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Gets the spacing between tables.
TableStyle | Gets the style for a table.
TileDirection | Gets the direction in which the table tiles (across or down).
Links
Public Properties


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Gets the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Gets the maximum number of sections to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::SplitTable Property
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::SplitTable Property
Collapse All

Gets whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Gets the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TableStyle Property
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TableStyle Property
Collapse All

Gets the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TileDirection Property
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TileDirection Property
Collapse All

Gets the direction in which the table tiles (across or down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkPlanLabels Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPlanLabels Class
SettingsCmdAddNetworkPlanLabels Class
Collapse All

Settings for AddNetworkPlanLabels command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPlanLabels
C#
public class SettingsCmdAddNetworkPlanLabels : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddNetworkPlanLabels
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdAddNetworkProfLabels Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkProfLabels Class
SettingsCmdAddNetworkProfLabels Class
Collapse All

Settings for AddNetworkProfLables command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkProfLabels
C#
public class SettingsCmdAddNetworkProfLabels : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddNetworkProfLabels
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdAddNetworkSectLabels Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkSectLabels Class
SettingsCmdAddNetworkSectLabels Class
Collapse All

Settings for AddNetworkSectLables command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkSectLabels
C#
public class SettingsCmdAddNetworkSectLabels : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddNetworkSectLabels
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdAddNetworkStructTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class
SettingsCmdAddNetworkStructTable Class
Collapse All

Settings for AddNetworkStructTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkStructTable
C#
public class SettingsCmdAddNetworkStructTable : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddNetworkStructTable
Inherits SettingsPipeNetwork
Links
SettingsCmdAddNetworkStructTable Properties, SettingsCmdAddNetworkStructTable Members, Class Hierarchy


SettingsCmdAddNetworkStructTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Members
SettingsCmdAddNetworkStructTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddNetworkStructTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TableCreation | Gets the defaults when you add a network structure table.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddNetworkStructTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Properties
SettingsCmdAddNetworkStructTable Properties
Collapse All

The properties of SettingsCmdAddNetworkStructTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the defaults when you add a network structure table.
Links
Public Properties


SettingsCmdAddNetworkStructTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Properties > SettingsCmdAddNetworkStructTable::TableCreation Property
SettingsCmdAddNetworkStructTable::TableCreation Property
Collapse All

Gets the defaults when you add a network structure table.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdAddNetworkStructTable Class, SettingsCmdAddNetworkStructTable Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class
Collapse All

Settings for alignment type option.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation
C#
public class SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties, SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Gets the maximum number of rows to include per section.
MaximumTablesPerStack | Gets the maximum number of sections to include in each stack.
SplitTable | Gets whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Gets the spacing between tables.
TableStyle | Gets the style for a table.
TileDirection | Gets the direction in which the table tiles (across or down).
Links
Public Properties


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Gets the maximum number of rows to include per section.
MaximumTablesPerStack | Gets the maximum number of sections to include in each stack.
SplitTable | Gets whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Gets the spacing between tables.
TableStyle | Gets the style for a table.
TileDirection | Gets the direction in which the table tiles (across or down).
Links
Public Properties


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Gets the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Gets the maximum number of sections to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::SplitTable Property
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::SplitTable Property
Collapse All

Gets whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Gets the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TableStyle Property
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TableStyle Property
Collapse All

Gets the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TileDirection Property
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TileDirection Property
Collapse All

Gets the direction in which the table tiles (across or down).

C#
public PropertyEnum<TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<TableTitleDirectionType>
Links
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class, SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdAddSpanningPipePlanLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddSpanningPipePlanLabel Class
SettingsCmdAddSpanningPipePlanLabel Class
Collapse All

Settings for AddSpanningPipePlanLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddSpanningPipePlanLabel
C#
public class SettingsCmdAddSpanningPipePlanLabel : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddSpanningPipePlanLabel
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdAddSpanningPipeProfLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddSpanningPipeProfLabel Class
SettingsCmdAddSpanningPipeProfLabel Class
Collapse All

Settings for AddSpanningPipeProfLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddSpanningPipeProfLabel
C#
public class SettingsCmdAddSpanningPipeProfLabel : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdAddSpanningPipeProfLabel
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdCreateAlignFromNetwork Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class
SettingsCmdCreateAlignFromNetwork Class
Collapse All

Settings for CreateAlignFromNetwork command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateAlignFromNetwork
C#
public class SettingsCmdCreateAlignFromNetwork : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdCreateAlignFromNetwork
Inherits SettingsPipeNetwork
Links
SettingsCmdCreateAlignFromNetwork Properties, SettingsCmdCreateAlignFromNetwork Members, Class Hierarchy


SettingsCmdCreateAlignFromNetwork Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Members
SettingsCmdCreateAlignFromNetwork Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignFromNetwork.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the alignment type options.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateAlignFromNetwork Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Properties
SettingsCmdCreateAlignFromNetwork Properties
Collapse All

The properties of SettingsCmdCreateAlignFromNetwork are listed here.

Public Properties
Public Property | Description
AlignmentTypeOption | Gets the alignment type options.
Links
Public Properties


SettingsCmdCreateAlignFromNetwork::AlignmentTypeOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Properties > SettingsCmdCreateAlignFromNetwork::AlignmentTypeOption Property
SettingsCmdCreateAlignFromNetwork::AlignmentTypeOption Property
Collapse All

Gets the alignment type options.

C#
public SettingsCmdAlignmentTypeOption AlignmentTypeOption;
Visual Basic
Public Property AlignmentTypeOption() As SettingsCmdAlignmentTypeOption
Links
SettingsCmdCreateAlignFromNetwork Class, SettingsCmdCreateAlignFromNetwork Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class
Collapse All

Settings for alignment type option.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption
C#
public class SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties, SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members, Class Hierarchy


SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption.

Public Properties
Public Property | Description
AlignmentType | Specifies the alignment type.
Links
Public Properties


SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties
Collapse All

The properties of SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption are listed here.

Public Properties
Public Property | Description
AlignmentType | Specifies the alignment type.
Links
Public Properties


SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption::AlignmentType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption::AlignmentType Property
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption::AlignmentType Property
Collapse All

Specifies the alignment type.

C#
public PropertyEnum<Autodesk::Civil::Land::DatabaseServices::AlignmentType> AlignmentType;
Visual Basic
Public Property AlignmentType() As PropertyEnum<Autodesk::Civil::Land::DatabaseServices::AlignmentType>
Links
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class, SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateInterferenceCheck Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class
SettingsCmdCreateInterferenceCheck Class
Collapse All

Settings for CreateInterferenceCheck command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateInterferenceCheck
C#
public class SettingsCmdCreateInterferenceCheck : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdCreateInterferenceCheck
Inherits SettingsPipeNetwork
Links
SettingsCmdCreateInterferenceCheck Properties, SettingsCmdCreateInterferenceCheck Members, Class Hierarchy


SettingsCmdCreateInterferenceCheck Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Members
SettingsCmdCreateInterferenceCheck Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateInterferenceCheck.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
InterferenceCriteria | Gets the default interference criteria.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateInterferenceCheck Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Properties
SettingsCmdCreateInterferenceCheck Properties
Collapse All

The properties of SettingsCmdCreateInterferenceCheck are listed here.

Public Properties
Public Property | Description
InterferenceCriteria | Gets the default interference criteria.
Links
Public Properties


SettingsCmdCreateInterferenceCheck::InterferenceCriteria Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Properties > SettingsCmdCreateInterferenceCheck::InterferenceCriteria Property
SettingsCmdCreateInterferenceCheck::InterferenceCriteria Property
Collapse All

Gets the default interference criteria.

C#
public SettingsCmdInterferenceCriteria InterferenceCriteria;
Visual Basic
Public Property InterferenceCriteria() As SettingsCmdInterferenceCriteria
Links
SettingsCmdCreateInterferenceCheck Class, SettingsCmdCreateInterferenceCheck Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class
Collapse All

Settings for interference criteria.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria
C#
public class SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria
Inherits TreeOidWrapper
Links
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties, SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members, Class Hierarchy


SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria.

Public Properties
Public Property | Description
Apply3DProximityCheck | Gets whether apply 3d proximity check.
Distance | Gets the tolerance distance value for interference check.
ScaleFactor | Gets the scale factor for scaling each network part for performing the interference check.
UseDistanceOrScaleFactor | Gets the selection of distance or scale factor to perform the 3D proximity check.
Links
Public Properties


SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties
Collapse All

The properties of SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria are listed here.

Public Properties
Public Property | Description
Apply3DProximityCheck | Gets whether apply 3d proximity check.
Distance | Gets the tolerance distance value for interference check.
ScaleFactor | Gets the scale factor for scaling each network part for performing the interference check.
UseDistanceOrScaleFactor | Gets the selection of distance or scale factor to perform the 3D proximity check.
Links
Public Properties


SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::Apply3DProximityCheck Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::Apply3DProximityCheck Property
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::Apply3DProximityCheck Property
Collapse All

Gets whether apply 3d proximity check.

C#
public PropertyBoolean Apply3DProximityCheck;
Visual Basic
Public Property Apply3DProximityCheck() As PropertyBoolean
Links
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class, SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::Distance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::Distance Property
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::Distance Property
Collapse All

Gets the tolerance distance value for interference check.

C#
public PropertyDouble Distance;
Visual Basic
Public Property Distance() As PropertyDouble
Links
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class, SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::ScaleFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::ScaleFactor Property
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::ScaleFactor Property
Collapse All

Gets the scale factor for scaling each network part for performing the interference check.

C#
public PropertyDouble ScaleFactor;
Visual Basic
Public Property ScaleFactor() As PropertyDouble
Links
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class, SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::UseDistanceOrScaleFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::UseDistanceOrScaleFactor Property
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::UseDistanceOrScaleFactor Property
Collapse All

Gets the selection of distance or scale factor to perform the 3D proximity check.

C#
public PropertyEnum<Autodesk::Civil::PipeNetwork::DistanceScaleFactorType> UseDistanceOrScaleFactor;
Visual Basic
Public Property UseDistanceOrScaleFactor() As PropertyEnum<Autodesk::Civil::PipeNetwork::DistanceScaleFactorType>
Links
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class, SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateNetwork Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class
SettingsCmdCreateNetwork Class
Collapse All

Settings for CreateNetwork command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetwork
C#
public class SettingsCmdCreateNetwork : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdCreateNetwork
Inherits SettingsPipeNetwork
Links
SettingsCmdCreateNetwork Properties, SettingsCmdCreateNetwork Members, Class Hierarchy


SettingsCmdCreateNetwork Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Members
SettingsCmdCreateNetwork Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateNetwork.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
DefaultLayoutCommand | Gets the default layout command type.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LabelNewParts | Gets the default labeling when you add parts to a network.
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateNetwork Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Properties
SettingsCmdCreateNetwork Properties
Collapse All

The properties of SettingsCmdCreateNetwork are listed here.

Public Properties
Public Property | Description
DefaultLayoutCommand | Gets the default layout command type.
LabelNewParts | Gets the default labeling when you add parts to a network.
Links
Public Properties


SettingsCmdCreateNetwork::DefaultLayoutCommand Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Properties > SettingsCmdCreateNetwork::DefaultLayoutCommand Property
SettingsCmdCreateNetwork::DefaultLayoutCommand Property
Collapse All

Gets the default layout command type.

C#
public PropertyEnum<Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType> DefaultLayoutCommand;
Visual Basic
Public Property DefaultLayoutCommand() As PropertyEnum<Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType>
Links
SettingsCmdCreateNetwork Class, SettingsCmdCreateNetwork Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateNetwork::LabelNewParts Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Properties > SettingsCmdCreateNetwork::LabelNewParts Property
SettingsCmdCreateNetwork::LabelNewParts Property
Collapse All

Gets the default labeling when you add parts to a network.

C#
public SettingsCmdLabelNewParts LabelNewParts;
Visual Basic
Public Property LabelNewParts() As SettingsCmdLabelNewParts
Links
SettingsCmdCreateNetwork Class, SettingsCmdCreateNetwork Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class
Collapse All

Settings for alignment type option.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetwork::SettingsCmdLabelNewParts
C#
public class SettingsCmdCreateNetwork::SettingsCmdLabelNewParts : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateNetwork::SettingsCmdLabelNewParts
Inherits TreeOidWrapper
Links
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties, SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members, Class Hierarchy


SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateNetwork::SettingsCmdLabelNewParts.

Public Properties
Public Property | Description
PipeInPlan | Gets whether a new pipe is labeled by default when placed in plan view.
PipeProfile | Gets whether a new pipe is labeled by default when placed in profile view.
StructureInPlan | Gets whether a new structure is labeled by default when placed in plan view.
StructureProfile | Gets whether a new structure is labeled by default when placed in profile view.
Links
Public Properties


SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties
Collapse All

The properties of SettingsCmdCreateNetwork::SettingsCmdLabelNewParts are listed here.

Public Properties
Public Property | Description
PipeInPlan | Gets whether a new pipe is labeled by default when placed in plan view.
PipeProfile | Gets whether a new pipe is labeled by default when placed in profile view.
StructureInPlan | Gets whether a new structure is labeled by default when placed in plan view.
StructureProfile | Gets whether a new structure is labeled by default when placed in profile view.
Links
Public Properties


SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::PipeInPlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::PipeInPlan Property
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::PipeInPlan Property
Collapse All

Gets whether a new pipe is labeled by default when placed in plan view.

C#
public PropertyBoolean PipeInPlan;
Visual Basic
Public Property PipeInPlan() As PropertyBoolean
Links
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class, SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::PipeProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::PipeProfile Property
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::PipeProfile Property
Collapse All

Gets whether a new pipe is labeled by default when placed in profile view.

C#
public PropertyBoolean PipeProfile;
Visual Basic
Public Property PipeProfile() As PropertyBoolean
Links
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class, SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::StructureInPlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::StructureInPlan Property
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::StructureInPlan Property
Collapse All

Gets whether a new structure is labeled by default when placed in plan view.

C#
public PropertyBoolean StructureInPlan;
Visual Basic
Public Property StructureInPlan() As PropertyBoolean
Links
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class, SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::StructureProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::StructureProfile Property
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::StructureProfile Property
Collapse All

Gets whether a new structure is labeled by default when placed in profile view.

C#
public PropertyBoolean StructureProfile;
Visual Basic
Public Property StructureProfile() As PropertyBoolean
Links
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class, SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsCmdCreateNetworkFromObject Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetworkFromObject Class
SettingsCmdCreateNetworkFromObject Class
Collapse All

Settings for CreateNetworkFromObject command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkFromObject
C#
public class SettingsCmdCreateNetworkFromObject : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdCreateNetworkFromObject
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdCreateNetworkPartsList Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetworkPartsList Class
SettingsCmdCreateNetworkPartsList Class
Collapse All

Settings for CreateNetworkPartsList command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkPartsList
C#
public class SettingsCmdCreateNetworkPartsList : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdCreateNetworkPartsList
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdCreateNetworkPartsListFull Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetworkPartsListFull Class
SettingsCmdCreateNetworkPartsListFull Class
Collapse All

Settings for CreateNetworkPartsListFull command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkPartsListFull
C#
public class SettingsCmdCreateNetworkPartsListFull : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdCreateNetworkPartsListFull
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdCreateNetworkReference Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetworkReference Class
SettingsCmdCreateNetworkReference Class
Collapse All

Settings for CreateNetworkReference command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkReference
C#
public class SettingsCmdCreateNetworkReference : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdCreateNetworkReference
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdEditInStormSewers Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdEditInStormSewers Class
SettingsCmdEditInStormSewers Class
Collapse All

Settings for EditInStormSewers command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdEditInStormSewers
C#
public class SettingsCmdEditInStormSewers : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdEditInStormSewers
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdExportStormSewerData Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdExportStormSewerData Class
SettingsCmdExportStormSewerData Class
Collapse All

Settings for ExportStormSewerData command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdExportStormSewerData
C#
public class SettingsCmdExportStormSewerData : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdExportStormSewerData
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdImportStormSewerData Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdImportStormSewerData Class
SettingsCmdImportStormSewerData Class
Collapse All

Settings for ImportStormSewerData command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdImportStormSewerData
C#
public class SettingsCmdImportStormSewerData : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdImportStormSewerData
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdRenamePipeNetworkParts Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdRenamePipeNetworkParts Class
SettingsCmdRenamePipeNetworkParts Class
Collapse All

Settings for RenamePipeNetworkParts command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdRenamePipeNetworkParts
C#
public class SettingsCmdRenamePipeNetworkParts : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdRenamePipeNetworkParts
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdResetAnchorPipe Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdResetAnchorPipe Class
SettingsCmdResetAnchorPipe Class
Collapse All

Settings for ResetAnchorPipe command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdResetAnchorPipe
C#
public class SettingsCmdResetAnchorPipe : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdResetAnchorPipe
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsCmdShowSpanningPipes Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdShowSpanningPipes Class
SettingsCmdShowSpanningPipes Class
Collapse All

Settings for ShowSpanningPipes command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdShowSpanningPipes
C#
public class SettingsCmdShowSpanningPipes : SettingsPipeNetwork;
Visual Basic
Public Class SettingsCmdShowSpanningPipes
Inherits SettingsPipeNetwork
Links
Class Hierarchy


SettingsPipe Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipe Class
SettingsPipe Class
Collapse All

Settings for Pipe.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipe
C#
public class SettingsPipe : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsPipe
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
Class Hierarchy


SettingsPipeNetwork Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class
SettingsPipeNetwork Class
Collapse All

Settings for PipeNetwork.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartPlanLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartProfLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartSectLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartsToProf
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPipeTable
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPlanLabels
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkProfLabels
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkSectLabels
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkStructTable
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddSpanningPipePlanLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddSpanningPipeProfLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateAlignFromNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateInterferenceCheck
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkFromObject
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkPartsList
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkPartsListFull
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkReference
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdEditInStormSewers
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdExportStormSewerData
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdImportStormSewerData
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdRenamePipeNetworkParts
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdResetAnchorPipe
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdShowSpanningPipes
C#
public class SettingsPipeNetwork : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsPipeNetwork
Inherits Autodesk::Civil::Settings::SettingsAmbient
Example
SettingsPipeNetwork oSettingsPipeNetwork = doc.Settings.GetSettings<SettingsPipeNetwork>() as SettingsPipeNetwork;
ed.WriteMessage("Using pipe rules: {0}n", oSettingsPipeNetwork.Rules.Pipe.Value);

//  Set the default units used for pipes in this document.
oSettingsPipeNetwork.Angle.Unit.Value = Autodesk.Civil.AngleUnitType.Radian;
oSettingsPipeNetwork.Coordinate.Unit.Value = Autodesk.Civil.LinearUnitType.Foot;
oSettingsPipeNetwork.Distance.Unit.Value = Autodesk.Civil.LinearUnitType.Foot;
Links
SettingsPipeNetwork Properties, SettingsPipeNetwork Members, Class Hierarchy


SettingsPipeNetwork Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Members
SettingsPipeNetwork Members
Collapse All

The following tables list the members exposed by SettingsPipeNetwork.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsPipeNetwork Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Properties
SettingsPipeNetwork Properties
Collapse All

The properties of SettingsPipeNetwork are listed here.

Public Properties
Public Property | Description
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
Links
Public Properties


SettingsPipeNetwork::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Properties > SettingsPipeNetwork::NameFormat Property
SettingsPipeNetwork::NameFormat Property
Collapse All

Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsPipeNetwork Class, SettingsPipeNetwork Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::ProfileLabelPlacement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Properties > SettingsPipeNetwork::ProfileLabelPlacement Property
SettingsPipeNetwork::ProfileLabelPlacement Property
Collapse All

Gets the settings to establish the default placement of profile view labels associated with the pipe network.

C#
public SettingsProfileLabelPlacement ProfileLabelPlacement;
Visual Basic
Public Property ProfileLabelPlacement() As SettingsProfileLabelPlacement
Links
SettingsPipeNetwork Class, SettingsPipeNetwork Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::Rules Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Properties > SettingsPipeNetwork::Rules Property
SettingsPipeNetwork::Rules Property
Collapse All

Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe network.

C#
public SettingsRules Rules;
Visual Basic
Public Property Rules() As SettingsRules
Links
SettingsPipeNetwork Class, SettingsPipeNetwork Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SectionLabelPlacement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Properties > SettingsPipeNetwork::SectionLabelPlacement Property
SettingsPipeNetwork::SectionLabelPlacement Property
Collapse All

Gets the settings to establish the default placement of section view labels associated with the pipe network.

C#
public SettingsSectionLabelPlacement SectionLabelPlacement;
Visual Basic
Public Property SectionLabelPlacement() As SettingsSectionLabelPlacement
Links
SettingsPipeNetwork Class, SettingsPipeNetwork Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::StormSewersMigration Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Properties > SettingsPipeNetwork::StormSewersMigration Property
SettingsPipeNetwork::StormSewersMigration Property
Collapse All

Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe network.

C#
public SettingsStormSewersMigration StormSewersMigration;
Visual Basic
Public Property StormSewersMigration() As SettingsStormSewersMigration
Links
SettingsPipeNetwork Class, SettingsPipeNetwork Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Properties > SettingsPipeNetwork::Styles Property
SettingsPipeNetwork::Styles Property
Collapse All

Gets the default styles assigned to pipe network components.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsPipeNetwork Class, SettingsPipeNetwork Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class
SettingsPipeNetwork::SettingsNameFormat Class
Collapse All

Settings for PipeNetwork default NameFormat.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsNameFormat
C#
public class SettingsPipeNetwork::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsPipeNetwork::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsPipeNetwork::SettingsNameFormat Properties, SettingsPipeNetwork::SettingsNameFormat Members, Class Hierarchy


SettingsPipeNetwork::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Members
SettingsPipeNetwork::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsPipeNetwork::SettingsNameFormat.

Public Properties
Public Property | Description
AlignmentFromNetwork | Settings for PipeNetwork AlignmentFromNetwork name format .
Interference | Settings for PipeNetwork Interference name format .
InterferenceCheck | Settings for PipeNetwork InterferenceCheck name format .
Network | Settings for PipeNetwork Network name format .
Pipe | Settings for PipeNetwork Pipe name format .
Structure | Settings for PipeNetwork Structure name format .
Links
Public Properties


SettingsPipeNetwork::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Properties
SettingsPipeNetwork::SettingsNameFormat Properties
Collapse All

The properties of SettingsPipeNetwork::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
AlignmentFromNetwork | Settings for PipeNetwork AlignmentFromNetwork name format .
Interference | Settings for PipeNetwork Interference name format .
InterferenceCheck | Settings for PipeNetwork InterferenceCheck name format .
Network | Settings for PipeNetwork Network name format .
Pipe | Settings for PipeNetwork Pipe name format .
Structure | Settings for PipeNetwork Structure name format .
Links
Public Properties


SettingsPipeNetwork::SettingsNameFormat::AlignmentFromNetwork Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Properties > SettingsPipeNetwork::SettingsNameFormat::AlignmentFromNetwork Property
SettingsPipeNetwork::SettingsNameFormat::AlignmentFromNetwork Property
Collapse All

Settings for PipeNetwork AlignmentFromNetwork name format .

C#
public PropertyString AlignmentFromNetwork;
Visual Basic
Public Property AlignmentFromNetwork() As PropertyString
Links
SettingsPipeNetwork::SettingsNameFormat Class, SettingsPipeNetwork::SettingsNameFormat Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsNameFormat::Interference Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Properties > SettingsPipeNetwork::SettingsNameFormat::Interference Property
SettingsPipeNetwork::SettingsNameFormat::Interference Property
Collapse All

Settings for PipeNetwork Interference name format .

C#
public PropertyString Interference;
Visual Basic
Public Property Interference() As PropertyString
Links
SettingsPipeNetwork::SettingsNameFormat Class, SettingsPipeNetwork::SettingsNameFormat Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsNameFormat::InterferenceCheck Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Properties > SettingsPipeNetwork::SettingsNameFormat::InterferenceCheck Property
SettingsPipeNetwork::SettingsNameFormat::InterferenceCheck Property
Collapse All

Settings for PipeNetwork InterferenceCheck name format .

C#
public PropertyString InterferenceCheck;
Visual Basic
Public Property InterferenceCheck() As PropertyString
Links
SettingsPipeNetwork::SettingsNameFormat Class, SettingsPipeNetwork::SettingsNameFormat Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsNameFormat::Network Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Properties > SettingsPipeNetwork::SettingsNameFormat::Network Property
SettingsPipeNetwork::SettingsNameFormat::Network Property
Collapse All

Settings for PipeNetwork Network name format .

C#
public PropertyString Network;
Visual Basic
Public Property Network() As PropertyString
Links
SettingsPipeNetwork::SettingsNameFormat Class, SettingsPipeNetwork::SettingsNameFormat Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsNameFormat::Pipe Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Properties > SettingsPipeNetwork::SettingsNameFormat::Pipe Property
SettingsPipeNetwork::SettingsNameFormat::Pipe Property
Collapse All

Settings for PipeNetwork Pipe name format .

C#
public PropertyString Pipe;
Visual Basic
Public Property Pipe() As PropertyString
Links
SettingsPipeNetwork::SettingsNameFormat Class, SettingsPipeNetwork::SettingsNameFormat Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsNameFormat::Structure Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Properties > SettingsPipeNetwork::SettingsNameFormat::Structure Property
SettingsPipeNetwork::SettingsNameFormat::Structure Property
Collapse All

Settings for PipeNetwork Structure name format .

C#
public PropertyString Structure;
Visual Basic
Public Property Structure() As PropertyString
Links
SettingsPipeNetwork::SettingsNameFormat Class, SettingsPipeNetwork::SettingsNameFormat Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsProfileLabelPlacement Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class
SettingsPipeNetwork::SettingsProfileLabelPlacement Class
Collapse All

Settings for PipeNetwork default ProfileLabelPlacement.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsProfileLabelPlacement
C#
public class SettingsPipeNetwork::SettingsProfileLabelPlacement : TreeOidWrapper;
Visual Basic
Public Class SettingsPipeNetwork::SettingsProfileLabelPlacement
Inherits TreeOidWrapper
Links
SettingsPipeNetwork::SettingsProfileLabelPlacement Properties, SettingsPipeNetwork::SettingsProfileLabelPlacement Members, Class Hierarchy


SettingsPipeNetwork::SettingsProfileLabelPlacement Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Members
SettingsPipeNetwork::SettingsProfileLabelPlacement Members
Collapse All

The following tables list the members exposed by SettingsPipeNetwork::SettingsProfileLabelPlacement.

Public Properties
Public Property | Description
DimensionAnchorElevationValueForPipes | Specifies the default elevation of the dimension line anchor for profile view labels for pipes.
DimensionAnchorElevationValueForStructures | Specifies the default elevation of the dimension line anchor for profile view labels for structures.
DimensionAnchorOptionForPipes | Specifies the location of the dimension line anchor for profile view labels for pipes.
DimensionAnchorOptionForStructures | Specifies the location of the dimension line anchor for profile view labels for structures.
DimensionAnchorPlotHeightValueForPipes | Specifies the default plot height of the dimension line anchor for profile view labels for pipes.
DimensionAnchorPlotHeightValueForStructures | Specifies the default plot height of the dimension line anchor for profile view labels for structures.
StructureLabelPlacement | Specifies the default location of structure labels.
Links
Public Properties


SettingsPipeNetwork::SettingsProfileLabelPlacement Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties
SettingsPipeNetwork::SettingsProfileLabelPlacement Properties
Collapse All

The properties of SettingsPipeNetwork::SettingsProfileLabelPlacement are listed here.

Public Properties
Public Property | Description
DimensionAnchorElevationValueForPipes | Specifies the default elevation of the dimension line anchor for profile view labels for pipes.
DimensionAnchorElevationValueForStructures | Specifies the default elevation of the dimension line anchor for profile view labels for structures.
DimensionAnchorOptionForPipes | Specifies the location of the dimension line anchor for profile view labels for pipes.
DimensionAnchorOptionForStructures | Specifies the location of the dimension line anchor for profile view labels for structures.
DimensionAnchorPlotHeightValueForPipes | Specifies the default plot height of the dimension line anchor for profile view labels for pipes.
DimensionAnchorPlotHeightValueForStructures | Specifies the default plot height of the dimension line anchor for profile view labels for structures.
StructureLabelPlacement | Specifies the default location of structure labels.
Links
Public Properties


SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorElevationValueForPipes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties > SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorElevationValueForPipes Property
SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorElevationValueForPipes Property
Collapse All

Specifies the default elevation of the dimension line anchor for profile view labels for pipes.

C#
public PropertyDouble DimensionAnchorElevationValueForPipes;
Visual Basic
Public Property DimensionAnchorElevationValueForPipes() As PropertyDouble
Links
SettingsPipeNetwork::SettingsProfileLabelPlacement Class, SettingsPipeNetwork::SettingsProfileLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorElevationValueForStructures Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties > SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorElevationValueForStructures Property
SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorElevationValueForStructures Property
Collapse All

Specifies the default elevation of the dimension line anchor for profile view labels for structures.

C#
public PropertyDouble DimensionAnchorElevationValueForStructures;
Visual Basic
Public Property DimensionAnchorElevationValueForStructures() As PropertyDouble
Links
SettingsPipeNetwork::SettingsProfileLabelPlacement Class, SettingsPipeNetwork::SettingsProfileLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorOptionForPipes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties > SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorOptionForPipes Property
SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorOptionForPipes Property
Collapse All

Specifies the location of the dimension line anchor for profile view labels for pipes.

C#
public PropertyEnum<DimensionAnchorType> DimensionAnchorOptionForPipes;
Visual Basic
Public Property DimensionAnchorOptionForPipes() As PropertyEnum<DimensionAnchorType>
Links
SettingsPipeNetwork::SettingsProfileLabelPlacement Class, SettingsPipeNetwork::SettingsProfileLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorOptionForStructures Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties > SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorOptionForStructures Property
SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorOptionForStructures Property
Collapse All

Specifies the location of the dimension line anchor for profile view labels for structures.

C#
public PropertyEnum<DimensionAnchorType> DimensionAnchorOptionForStructures;
Visual Basic
Public Property DimensionAnchorOptionForStructures() As PropertyEnum<DimensionAnchorType>
Links
SettingsPipeNetwork::SettingsProfileLabelPlacement Class, SettingsPipeNetwork::SettingsProfileLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorPlotHeightValueForPipes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties > SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorPlotHeightValueForPipes Property
SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorPlotHeightValueForPipes Property
Collapse All

Specifies the default plot height of the dimension line anchor for profile view labels for pipes.

C#
public PropertyDouble DimensionAnchorPlotHeightValueForPipes;
Visual Basic
Public Property DimensionAnchorPlotHeightValueForPipes() As PropertyDouble
Links
SettingsPipeNetwork::SettingsProfileLabelPlacement Class, SettingsPipeNetwork::SettingsProfileLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorPlotHeightValueForStructures Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties > SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorPlotHeightValueForStructures Property
SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorPlotHeightValueForStructures Property
Collapse All

Specifies the default plot height of the dimension line anchor for profile view labels for structures.

C#
public PropertyDouble DimensionAnchorPlotHeightValueForStructures;
Visual Basic
Public Property DimensionAnchorPlotHeightValueForStructures() As PropertyDouble
Links
SettingsPipeNetwork::SettingsProfileLabelPlacement Class, SettingsPipeNetwork::SettingsProfileLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsProfileLabelPlacement::StructureLabelPlacement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties > SettingsPipeNetwork::SettingsProfileLabelPlacement::StructureLabelPlacement Property
SettingsPipeNetwork::SettingsProfileLabelPlacement::StructureLabelPlacement Property
Collapse All

Specifies the default location of structure labels.

C#
public PropertyEnum<StructureProfileLabelPlacementType> StructureLabelPlacement;
Visual Basic
Public Property StructureLabelPlacement() As PropertyEnum<StructureProfileLabelPlacementType>
Links
SettingsPipeNetwork::SettingsProfileLabelPlacement Class, SettingsPipeNetwork::SettingsProfileLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsRules Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class
SettingsPipeNetwork::SettingsRules Class
Collapse All

Settings for PipeNetwork default Rules.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsRules
C#
public class SettingsPipeNetwork::SettingsRules : TreeOidWrapper;
Visual Basic
Public Class SettingsPipeNetwork::SettingsRules
Inherits TreeOidWrapper
Links
SettingsPipeNetwork::SettingsRules Properties, SettingsPipeNetwork::SettingsRules Members, Class Hierarchy


SettingsPipeNetwork::SettingsRules Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class > SettingsPipeNetwork::SettingsRules Members
SettingsPipeNetwork::SettingsRules Members
Collapse All

The following tables list the members exposed by SettingsPipeNetwork::SettingsRules.

Public Properties
Public Property | Description
Pipe | Specifies the default rule set assigned to pipes.
Structure | Specifies the default rule set assigned to structures.
Links
Public Properties


SettingsPipeNetwork::SettingsRules Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class > SettingsPipeNetwork::SettingsRules Properties
SettingsPipeNetwork::SettingsRules Properties
Collapse All

The properties of SettingsPipeNetwork::SettingsRules are listed here.

Public Properties
Public Property | Description
Pipe | Specifies the default rule set assigned to pipes.
Structure | Specifies the default rule set assigned to structures.
Links
Public Properties


SettingsPipeNetwork::SettingsRules::Pipe Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class > SettingsPipeNetwork::SettingsRules Properties > SettingsPipeNetwork::SettingsRules::Pipe Property
SettingsPipeNetwork::SettingsRules::Pipe Property
Collapse All

Specifies the default rule set assigned to pipes.

C#
public PropertyString Pipe;
Visual Basic
Public Property Pipe() As PropertyString
Links
SettingsPipeNetwork::SettingsRules Class, SettingsPipeNetwork::SettingsRules Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsRules::Structure Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class > SettingsPipeNetwork::SettingsRules Properties > SettingsPipeNetwork::SettingsRules::Structure Property
SettingsPipeNetwork::SettingsRules::Structure Property
Collapse All

Specifies the default rule set assigned to structures.

C#
public PropertyString Structure;
Visual Basic
Public Property Structure() As PropertyString
Links
SettingsPipeNetwork::SettingsRules Class, SettingsPipeNetwork::SettingsRules Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsSectionLabelPlacement Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class
SettingsPipeNetwork::SettingsSectionLabelPlacement Class
Collapse All

Settings for PipeNetwork default SectionLabelPlacement.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsSectionLabelPlacement
C#
public class SettingsPipeNetwork::SettingsSectionLabelPlacement : TreeOidWrapper;
Visual Basic
Public Class SettingsPipeNetwork::SettingsSectionLabelPlacement
Inherits TreeOidWrapper
Links
SettingsPipeNetwork::SettingsSectionLabelPlacement Properties, SettingsPipeNetwork::SettingsSectionLabelPlacement Members, Class Hierarchy


SettingsPipeNetwork::SettingsSectionLabelPlacement Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Members
SettingsPipeNetwork::SettingsSectionLabelPlacement Members
Collapse All

The following tables list the members exposed by SettingsPipeNetwork::SettingsSectionLabelPlacement.

Public Properties
Public Property | Description
DimensionAnchorElevationValueForPipes | Specifies the default elevation of the dimension line anchor for section view labels for pipes.
DimensionAnchorElevationValueForStructures | Specifies the default elevation of the dimension line anchor for section view labels for structures.
DimensionAnchorOptionForPipes | Specifies the location of the dimension line anchor for section view labels for pipes.
DimensionAnchorOptionForStructures | Specifies the location of the dimension line anchor for section view labels for structures.
DimensionAnchorPlotHeightValueForPipes | Specifies the default plot height of the dimension line anchor for section view labels for pipes.
DimensionAnchorPlotHeightValueForStructures | Specifies the default plot height of the dimension line anchor for section view labels for structures.
PipeSectionLabel | Specifies the default location of pipe labels displayed in section views.
StructureLabelPlacement | Specifies the default location of structure labels.
Links
Public Properties


SettingsPipeNetwork::SettingsSectionLabelPlacement Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties
SettingsPipeNetwork::SettingsSectionLabelPlacement Properties
Collapse All

The properties of SettingsPipeNetwork::SettingsSectionLabelPlacement are listed here.

Public Properties
Public Property | Description
DimensionAnchorElevationValueForPipes | Specifies the default elevation of the dimension line anchor for section view labels for pipes.
DimensionAnchorElevationValueForStructures | Specifies the default elevation of the dimension line anchor for section view labels for structures.
DimensionAnchorOptionForPipes | Specifies the location of the dimension line anchor for section view labels for pipes.
DimensionAnchorOptionForStructures | Specifies the location of the dimension line anchor for section view labels for structures.
DimensionAnchorPlotHeightValueForPipes | Specifies the default plot height of the dimension line anchor for section view labels for pipes.
DimensionAnchorPlotHeightValueForStructures | Specifies the default plot height of the dimension line anchor for section view labels for structures.
PipeSectionLabel | Specifies the default location of pipe labels displayed in section views.
StructureLabelPlacement | Specifies the default location of structure labels.
Links
Public Properties


SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorElevationValueForPipes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties > SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorElevationValueForPipes Property
SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorElevationValueForPipes Property
Collapse All

Specifies the default elevation of the dimension line anchor for section view labels for pipes.

C#
public PropertyDouble DimensionAnchorElevationValueForPipes;
Visual Basic
Public Property DimensionAnchorElevationValueForPipes() As PropertyDouble
Links
SettingsPipeNetwork::SettingsSectionLabelPlacement Class, SettingsPipeNetwork::SettingsSectionLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorElevationValueForStructures Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties > SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorElevationValueForStructures Property
SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorElevationValueForStructures Property
Collapse All

Specifies the default elevation of the dimension line anchor for section view labels for structures.

C#
public PropertyDouble DimensionAnchorElevationValueForStructures;
Visual Basic
Public Property DimensionAnchorElevationValueForStructures() As PropertyDouble
Links
SettingsPipeNetwork::SettingsSectionLabelPlacement Class, SettingsPipeNetwork::SettingsSectionLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorOptionForPipes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties > SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorOptionForPipes Property
SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorOptionForPipes Property
Collapse All

Specifies the location of the dimension line anchor for section view labels for pipes.

C#
public PropertyEnum<DimensionAnchorType> DimensionAnchorOptionForPipes;
Visual Basic
Public Property DimensionAnchorOptionForPipes() As PropertyEnum<DimensionAnchorType>
Links
SettingsPipeNetwork::SettingsSectionLabelPlacement Class, SettingsPipeNetwork::SettingsSectionLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorOptionForStructures Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties > SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorOptionForStructures Property
SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorOptionForStructures Property
Collapse All

Specifies the location of the dimension line anchor for section view labels for structures.

C#
public PropertyEnum<DimensionAnchorType> DimensionAnchorOptionForStructures;
Visual Basic
Public Property DimensionAnchorOptionForStructures() As PropertyEnum<DimensionAnchorType>
Links
SettingsPipeNetwork::SettingsSectionLabelPlacement Class, SettingsPipeNetwork::SettingsSectionLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorPlotHeightValueForPipes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties > SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorPlotHeightValueForPipes Property
SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorPlotHeightValueForPipes Property
Collapse All

Specifies the default plot height of the dimension line anchor for section view labels for pipes.

C#
public PropertyDouble DimensionAnchorPlotHeightValueForPipes;
Visual Basic
Public Property DimensionAnchorPlotHeightValueForPipes() As PropertyDouble
Links
SettingsPipeNetwork::SettingsSectionLabelPlacement Class, SettingsPipeNetwork::SettingsSectionLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorPlotHeightValueForStructures Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties > SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorPlotHeightValueForStructures Property
SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorPlotHeightValueForStructures Property
Collapse All

Specifies the default plot height of the dimension line anchor for section view labels for structures.

C#
public PropertyDouble DimensionAnchorPlotHeightValueForStructures;
Visual Basic
Public Property DimensionAnchorPlotHeightValueForStructures() As PropertyDouble
Links
SettingsPipeNetwork::SettingsSectionLabelPlacement Class, SettingsPipeNetwork::SettingsSectionLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsSectionLabelPlacement::PipeSectionLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties > SettingsPipeNetwork::SettingsSectionLabelPlacement::PipeSectionLabel Property
SettingsPipeNetwork::SettingsSectionLabelPlacement::PipeSectionLabel Property
Collapse All

Specifies the default location of pipe labels displayed in section views.

C#
public PropertyEnum<PipeSectionLabelPlacementType> PipeSectionLabel;
Visual Basic
Public Property PipeSectionLabel() As PropertyEnum<PipeSectionLabelPlacementType>
Links
SettingsPipeNetwork::SettingsSectionLabelPlacement Class, SettingsPipeNetwork::SettingsSectionLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsSectionLabelPlacement::StructureLabelPlacement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties > SettingsPipeNetwork::SettingsSectionLabelPlacement::StructureLabelPlacement Property
SettingsPipeNetwork::SettingsSectionLabelPlacement::StructureLabelPlacement Property
Collapse All

Specifies the default location of structure labels.

C#
public PropertyEnum<StructureProfileLabelPlacementType> StructureLabelPlacement;
Visual Basic
Public Property StructureLabelPlacement() As PropertyEnum<StructureProfileLabelPlacementType>
Links
SettingsPipeNetwork::SettingsSectionLabelPlacement Class, SettingsPipeNetwork::SettingsSectionLabelPlacement Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStormSewersMigration Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class
SettingsPipeNetwork::SettingsStormSewersMigration Class
Collapse All

Settings for PipeNetwork default StormSewersMigration.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsStormSewersMigration
C#
public class SettingsPipeNetwork::SettingsStormSewersMigration : TreeOidWrapper;
Visual Basic
Public Class SettingsPipeNetwork::SettingsStormSewersMigration
Inherits TreeOidWrapper
Links
SettingsPipeNetwork::SettingsStormSewersMigration Properties, SettingsPipeNetwork::SettingsStormSewersMigration Members, Class Hierarchy


SettingsPipeNetwork::SettingsStormSewersMigration Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class > SettingsPipeNetwork::SettingsStormSewersMigration Members
SettingsPipeNetwork::SettingsStormSewersMigration Members
Collapse All

The following tables list the members exposed by SettingsPipeNetwork::SettingsStormSewersMigration.

Public Properties
Public Property | Description
PartMatching | Specifies the defaults used for part matching when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil... more
PartsListUsedForMigration | Specifies the default parts list assigned when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil 3D.... more
Links
Public Properties


SettingsPipeNetwork::SettingsStormSewersMigration Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class > SettingsPipeNetwork::SettingsStormSewersMigration Properties
SettingsPipeNetwork::SettingsStormSewersMigration Properties
Collapse All

The properties of SettingsPipeNetwork::SettingsStormSewersMigration are listed here.

Public Properties
Public Property | Description
PartMatching | Specifies the defaults used for part matching when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil... more
PartsListUsedForMigration | Specifies the default parts list assigned when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil 3D.... more
Links
Public Properties


SettingsPipeNetwork::SettingsStormSewersMigration::PartMatching Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class > SettingsPipeNetwork::SettingsStormSewersMigration Properties > SettingsPipeNetwork::SettingsStormSewersMigration::PartMatching Property
SettingsPipeNetwork::SettingsStormSewersMigration::PartMatching Property
Collapse All

Specifies the defaults used for part matching when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil 3D.

C#
public PropertyString PartMatching;
Visual Basic
Public Property PartMatching() As PropertyString
Links
SettingsPipeNetwork::SettingsStormSewersMigration Class, SettingsPipeNetwork::SettingsStormSewersMigration Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStormSewersMigration::PartsListUsedForMigration Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class > SettingsPipeNetwork::SettingsStormSewersMigration Properties > SettingsPipeNetwork::SettingsStormSewersMigration::PartsListUsedForMigration Property
SettingsPipeNetwork::SettingsStormSewersMigration::PartsListUsedForMigration Property
Collapse All

Specifies the default parts list assigned when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil 3D.

C#
public PropertyString PartsListUsedForMigration;
Visual Basic
Public Property PartsListUsedForMigration() As PropertyString
Links
SettingsPipeNetwork::SettingsStormSewersMigration Class, SettingsPipeNetwork::SettingsStormSewersMigration Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class
SettingsPipeNetwork::SettingsStyles Class
Collapse All

Settings for PipeNetwork default Styles.

Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsStyles
C#
public class SettingsPipeNetwork::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsPipeNetwork::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsPipeNetwork::SettingsStyles Properties, SettingsPipeNetwork::SettingsStyles Members, Class Hierarchy


SettingsPipeNetwork::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Members
SettingsPipeNetwork::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsPipeNetwork::SettingsStyles.

Public Properties
Public Property | Description
Interference | Specifies the default style for interference in the pipe network.
InterferenceRenderMaterial | Specifies the default interference render material in the pipe network.
PartsList | Specifies the default parts list for the pipe network.
Pipe | Specifies the default style for pipes in the pipe network.
PipePlanLabel | Specifies the default style for pipe labels that are displayed in plan view.
PipeProfileLabel | Specifies the default style for pipe labels that are displayed in profile view.
PipeSectionLabel | Specifies the default style for pipe labels that are displayed in section view.
RenderMaterial | Specifies the default render material in the pipe network.
Structure | Specifies the default style for structures in the pipe network.
StructurePlanLabel | Specifies the default style for structure labels that are displayed in plan view.
StructureProfileLabel | Specifies the default style for structure labels that are displayed in a profile view.
StructureSectionLabel | Specifies the default style for structure labels that are displayed in a section view.
Links
Public Properties


SettingsPipeNetwork::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties
SettingsPipeNetwork::SettingsStyles Properties
Collapse All

The properties of SettingsPipeNetwork::SettingsStyles are listed here.

Public Properties
Public Property | Description
Interference | Specifies the default style for interference in the pipe network.
InterferenceRenderMaterial | Specifies the default interference render material in the pipe network.
PartsList | Specifies the default parts list for the pipe network.
Pipe | Specifies the default style for pipes in the pipe network.
PipePlanLabel | Specifies the default style for pipe labels that are displayed in plan view.
PipeProfileLabel | Specifies the default style for pipe labels that are displayed in profile view.
PipeSectionLabel | Specifies the default style for pipe labels that are displayed in section view.
RenderMaterial | Specifies the default render material in the pipe network.
Structure | Specifies the default style for structures in the pipe network.
StructurePlanLabel | Specifies the default style for structure labels that are displayed in plan view.
StructureProfileLabel | Specifies the default style for structure labels that are displayed in a profile view.
StructureSectionLabel | Specifies the default style for structure labels that are displayed in a section view.
Links
Public Properties


SettingsPipeNetwork::SettingsStyles::Interference Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::Interference Property
SettingsPipeNetwork::SettingsStyles::Interference Property
Collapse All

Specifies the default style for interference in the pipe network.

C#
public PropertyString Interference;
Visual Basic
Public Property Interference() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::InterferenceRenderMaterial Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::InterferenceRenderMaterial Property
SettingsPipeNetwork::SettingsStyles::InterferenceRenderMaterial Property
Collapse All

Specifies the default interference render material in the pipe network.

C#
public PropertyString InterferenceRenderMaterial;
Visual Basic
Public Property InterferenceRenderMaterial() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::PartsList Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::PartsList Property
SettingsPipeNetwork::SettingsStyles::PartsList Property
Collapse All

Specifies the default parts list for the pipe network.

C#
public PropertyString PartsList;
Visual Basic
Public Property PartsList() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::Pipe Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::Pipe Property
SettingsPipeNetwork::SettingsStyles::Pipe Property
Collapse All

Specifies the default style for pipes in the pipe network.

C#
public PropertyString Pipe;
Visual Basic
Public Property Pipe() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::PipePlanLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::PipePlanLabel Property
SettingsPipeNetwork::SettingsStyles::PipePlanLabel Property
Collapse All

Specifies the default style for pipe labels that are displayed in plan view.

C#
public PropertyString PipePlanLabel;
Visual Basic
Public Property PipePlanLabel() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::PipeProfileLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::PipeProfileLabel Property
SettingsPipeNetwork::SettingsStyles::PipeProfileLabel Property
Collapse All

Specifies the default style for pipe labels that are displayed in profile view.

C#
public PropertyString PipeProfileLabel;
Visual Basic
Public Property PipeProfileLabel() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::PipeSectionLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::PipeSectionLabel Property
SettingsPipeNetwork::SettingsStyles::PipeSectionLabel Property
Collapse All

Specifies the default style for pipe labels that are displayed in section view.

C#
public PropertyString PipeSectionLabel;
Visual Basic
Public Property PipeSectionLabel() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::RenderMaterial Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::RenderMaterial Property
SettingsPipeNetwork::SettingsStyles::RenderMaterial Property
Collapse All

Specifies the default render material in the pipe network.

C#
public PropertyString RenderMaterial;
Visual Basic
Public Property RenderMaterial() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::Structure Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::Structure Property
SettingsPipeNetwork::SettingsStyles::Structure Property
Collapse All

Specifies the default style for structures in the pipe network.

C#
public PropertyString Structure;
Visual Basic
Public Property Structure() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::StructurePlanLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::StructurePlanLabel Property
SettingsPipeNetwork::SettingsStyles::StructurePlanLabel Property
Collapse All

Specifies the default style for structure labels that are displayed in plan view.

C#
public PropertyString StructurePlanLabel;
Visual Basic
Public Property StructurePlanLabel() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::StructureProfileLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::StructureProfileLabel Property
SettingsPipeNetwork::SettingsStyles::StructureProfileLabel Property
Collapse All

Specifies the default style for structure labels that are displayed in a profile view.

C#
public PropertyString StructureProfileLabel;
Visual Basic
Public Property StructureProfileLabel() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsPipeNetwork::SettingsStyles::StructureSectionLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties > SettingsPipeNetwork::SettingsStyles::StructureSectionLabel Property
SettingsPipeNetwork::SettingsStyles::StructureSectionLabel Property
Collapse All

Specifies the default style for structure labels that are displayed in a section view.

C#
public PropertyString StructureSectionLabel;
Visual Basic
Public Property StructureSectionLabel() As PropertyString
Links
SettingsPipeNetwork::SettingsStyles Class, SettingsPipeNetwork::SettingsStyles Members, Autodesk::Civil::PipeNetwork::Settings Namespace


SettingsStructure Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsStructure Class
SettingsStructure Class
Collapse All

Settings for Structure.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsStructure
C#
public class SettingsStructure : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsStructure
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
Class Hierarchy


Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
DistanceScaleFactorType | The Autodesk::Civil::PipeNetwork::DistanceScaleFactorType enumeration.
NetworkDefaultLayoutCommandType | The Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType enumeration.
PipeSectionLabelPlacementType | The Autodesk::Civil::PipeNetwork::PipeSectionLabelPlacementType enumeration.
StructureProfileLabelPlacementType | The Autodesk::Civil::PipeNetwork::StructureProfileLabelPlacementType enumeration.
Links
Enumerations


Autodesk::Civil::PipeNetwork::DistanceScaleFactorType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::DistanceScaleFactorType Enumeration
Autodesk::Civil::PipeNetwork::DistanceScaleFactorType Enumeration
Collapse All

The Autodesk::Civil::PipeNetwork::DistanceScaleFactorType enumeration.

C#
public enum DistanceScaleFactorType {
  Distance = AeccInterferenceUtils::kDistance,
  ScaleFactor = AeccInterferenceUtils::kScaleFactor
}
Visual Basic
Public Enum DistanceScaleFactorType
  Distance = AeccInterferenceUtils::kDistance
  ScaleFactor = AeccInterferenceUtils::kScaleFactor
End Enum


Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType Enumeration
Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType Enumeration
Collapse All

The Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType enumeration.

C#
public enum NetworkDefaultLayoutCommandType {
  PipesAndStrucutres = 100,
  PipesOnly,
  StrucutresOnly
}
Visual Basic
Public Enum NetworkDefaultLayoutCommandType
  PipesAndStrucutres = 100
  PipesOnly
  StrucutresOnly
End Enum


Autodesk::Civil::PipeNetwork::PipeSectionLabelPlacementType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::PipeSectionLabelPlacementType Enumeration
Autodesk::Civil::PipeNetwork::PipeSectionLabelPlacementType Enumeration
Collapse All

The Autodesk::Civil::PipeNetwork::PipeSectionLabelPlacementType enumeration.

C#
public enum PipeSectionLabelPlacementType {
  AtPipeTop = AeccUiNetworkCmdLabelCreate::kAtPipeTop,
  AtPipeMiddle = AeccUiNetworkCmdLabelCreate::kAtPipeMiddle,
  AtPipeBottom = AeccUiNetworkCmdLabelCreate::kAtPipeBottom
}
Visual Basic
Public Enum PipeSectionLabelPlacementType
  AtPipeTop = AeccUiNetworkCmdLabelCreate::kAtPipeTop
  AtPipeMiddle = AeccUiNetworkCmdLabelCreate::kAtPipeMiddle
  AtPipeBottom = AeccUiNetworkCmdLabelCreate::kAtPipeBottom
End Enum


Autodesk::Civil::PipeNetwork::StructureProfileLabelPlacementType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Structs, Records, Enums > Autodesk::Civil::PipeNetwork::StructureProfileLabelPlacementType Enumeration
Autodesk::Civil::PipeNetwork::StructureProfileLabelPlacementType Enumeration
Collapse All

The Autodesk::Civil::PipeNetwork::StructureProfileLabelPlacementType enumeration.

C#
public enum StructureProfileLabelPlacementType {
  AtStructureTop = AeccUiNetworkCmdLabelCreate::kAtStructureTop,
  AtStructureMiddle = AeccUiNetworkCmdLabelCreate::kAtStructureMiddle,
  AtStructureBottom = AeccUiNetworkCmdLabelCreate::kAtStructureBottom
}
Visual Basic
Public Enum StructureProfileLabelPlacementType
  AtStructureTop = AeccUiNetworkCmdLabelCreate::kAtStructureTop
  AtStructureMiddle = AeccUiNetworkCmdLabelCreate::kAtStructureMiddle
  AtStructureBottom = AeccUiNetworkCmdLabelCreate::kAtStructureBottom
End Enum


Autodesk::Civil::QTO Namespace

The Autodesk::Civil::QTO namespace.

Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::QTO::DatabaseServices namespace.
Links
Namespaces


Autodesk::Civil::QTO::DatabaseServices Namespace

The Autodesk::Civil::QTO::DatabaseServices namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Classes
Class | Description
QTOUtility | This is class Autodesk::Civil::QTO::DatabaseServices::QTOUtility.
Links
Topics, Classes


Classes

The following table lists classes in this documentation.

Classes
Class | Description
QTOUtility | This is class Autodesk::Civil::QTO::DatabaseServices::QTOUtility.
Links
Classes


QTOUtility Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class
QTOUtility Class
Collapse All

This is class Autodesk::Civil::QTO::DatabaseServices::QTOUtility.

Class Hierarchy
Autodesk::Civil::QTO::DatabaseServices::QTOUtility
C#
public class QTOUtility;
Visual Basic
Public Class QTOUtility
Links
QTOUtility Methods, QTOUtility Members, Class Hierarchy


QTOUtility Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Members
QTOUtility Members
Collapse All

The following tables list the members exposed by QTOUtility.

Public Methods
Public Method | Description
AddPayItemId | Adds a pay item id.
DeleteAllPayItemsIds | Deletes all pay item information from the specified object.
DeletePayItemIds | Deletes the pay item ids in the collection from the specified object.
GetPayItemIds | Gets a string collection of pay items ids for the specified object.
Links
Public Methods


QTOUtility Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Methods
QTOUtility Methods
Collapse All

The methods of QTOUtility are listed here.

Public Methods
Public Method | Description
AddPayItemId | Adds a pay item id.
DeleteAllPayItemsIds | Deletes all pay item information from the specified object.
DeletePayItemIds | Deletes the pay item ids in the collection from the specified object.
GetPayItemIds | Gets a string collection of pay items ids for the specified object.
Links
Public Methods


QTOUtility::AddPayItemId Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Methods > QTOUtility::AddPayItemId Method
QTOUtility::AddPayItemId Method
Collapse All

Adds a pay item id.

C#
public AddPayItemId(
    Autodesk::AutoCAD::DatabaseServices::ObjectId oid,
    ref System::String payItemID
);
Visual Basic
Public Sub AddPayItemId(
    oid As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef payItemID As System::String
)
Parameters
Parameters | Description
oid | Object id of the object to which add the pay item.
payItemID | Pay item id to add.
Links
QTOUtility Class, QTOUtility Members, Autodesk::Civil::QTO::DatabaseServices Namespace


QTOUtility::DeleteAllPayItemsIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Methods > QTOUtility::DeleteAllPayItemsIds Method
QTOUtility::DeleteAllPayItemsIds Method
Collapse All

Deletes all pay item information from the specified object.

C#
public DeleteAllPayItemsIds(
    Autodesk::AutoCAD::DatabaseServices::ObjectId oid
);
Visual Basic
Public Sub DeleteAllPayItemsIds(
    oid As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
oid | Object id of the object from which delete all the pay item information.
Links
QTOUtility Class, QTOUtility Members, Autodesk::Civil::QTO::DatabaseServices Namespace


QTOUtility::DeletePayItemIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Methods > QTOUtility::DeletePayItemIds Method
QTOUtility::DeletePayItemIds Method
Collapse All

Deletes the pay item ids in the collection from the specified object.

C#
public DeletePayItemIds(
    Autodesk::AutoCAD::DatabaseServices::ObjectId oid,
    ref System::Collections::Specialized::StringCollection payItemIDs
);
Visual Basic
Public Sub DeletePayItemIds(
    oid As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef payItemIDs As System::Collections::Specialized::StringCollection
)
Parameters
Parameters | Description
oid | Object id of the object from which to delete the pay items.
payItemIDs | StringCollection containing the pay item ids to delete.
Links
QTOUtility Class, QTOUtility Members, Autodesk::Civil::QTO::DatabaseServices Namespace


QTOUtility::GetPayItemIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Methods > QTOUtility::GetPayItemIds Method
QTOUtility::GetPayItemIds Method
Collapse All

Gets a string collection of pay items ids for the specified object.

C#
public System::Collections::Specialized::StringCollection GetPayItemIds(
    Autodesk::AutoCAD::DatabaseServices::ObjectId oid
);
Visual Basic
Public Function GetPayItemIds(
    oid As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As System::Collections::Specialized::StringCollection
Parameters
Parameters | Description
oid | Object id for the object from which retrieve the pay item ids.
Returns

A StringCollection containing the pay item ids assigned to the object. The collection can be empty if no pay items have been assigned previously.

Links
QTOUtility Class, QTOUtility Members, Autodesk::Civil::QTO::DatabaseServices Namespace


Autodesk::Civil::Roadway Namespace

The Autodesk::Civil::Roadway namespace.

Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::Roadway::DatabaseServices namespace.
Settings | The Autodesk::Civil::Roadway::Settings namespace.
Topics
Topic | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Structs, Records, Enums
Struct, Record, Enum | Description
AssemblyDisplayStyleType | The Autodesk::Civil::Roadway::AssemblyDisplayStyleType enumeration.
LinkCreationType | An enumeration that defines the link creation type.
QuantityTakeoffLengthComputeType | An enumeration that specifies the length computation type in the take off process.
QuantityTakeoffPipeLengthType | An enumeration that specifies the pipe length type in the take off process.
QuantityTakeoffReportExtentType | An enumeration that specifies the extents used when finding entities to participate in the take off process.
QuantityTakeoffReportType | An enumeration that specifies the quantity takeoff report type.
RoadwaySideType | An enumeration that defines the roadway side type.
Links
Namespaces, Topics, Structs, Records, Enums


Autodesk::Civil::Roadway::DatabaseServices Namespace

The Autodesk::Civil::Roadway::DatabaseServices namespace.

Namespaces
Namespace | Description
Styles | The Autodesk::Civil::Roadway::DatabaseServices::Styles namespace.
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
AppliedAssembly | Represents an AppliedAssembly object. An AppliedAssembly is a cross section of an existing corridor.
AppliedAssemblyCollection | The collection of assembly cross sections placed at intervals along corridor baselines.
AppliedSubassembly | An AppliedSubassemby object. An AppliedSubassembly is a series of points, links, and shapes that make up part of an AppliedAssembly... more
AppliedSubassemblyCollection | Collection of AppliedSubassembly objects.
Assembly | Pattern for the cross section of a corridor. Made up of multiple Subassembly objects.
AssemblyCollection | A collection of Assembly objects.
BaseBaseline | The base class for baselines, such as Baseline, OffsetBaseline, and HardcodedOffsetBaseline.
Baseline | A 3D path defined by an alignment and a profile. A corridor is defined by a baseline (or multiple baselines)... more
BaselineCollection | A collection of Baseline objects.
BaselineFeatureLines | A collection of multiple feature line collections (FeatureLinesCol) associated with a particular baseline or offset baseline.
BaselineFeatureLinesCollection | A collection of multiple feature line collections (BaselineFeatureLines) objects.
BaselineRegion | A segment of a baseline, specified by alignment stations for the start and end point. In a corridor, each baseline... more
BaselineRegionCollection | A collection of baseline region (BaselineRegion) objects.
CalculatedLink | The CalculatedLink class. A CalculatedLink joins two CalculatedPoint objects, and is a component of an AppliedSubassembly object, which in turn... more
CalculatedLinkCollection | A calculated link is a collection of calculated points (CalculatedPoint) which are connected to form a line. Calculated... more
CalculatedPoint | The CalculatedPoint class. A CalculatedPoint is the basic component that defines the stucture of an AppliedSubassembly.
CalculatedPointCollection | A collection of calculated point (CalculatedPoint) objects. Calculated points are used to define applied subassemblies.
CalculatedShape | The CalculatedShape class. A CalculatedShape is defined from links and defines a closed region that represents materials used in a... more
CalculatedShapeCollection | Collection of calculated shape (CalculatedShape) objects.
CalculatedSubentity | Parent class for the CalculatedShape, CalculatedLink and CalculatedPoint interfaces.
CodeCollection | The Corridor code collection class. The wrapped object could be AeccDbRoadwayState or AeccDbSubassembly.
Corridor | Representation of a roadway. Follows a 3D path defined by a baseline, and is made up of cross sections (... more
CorridorCodeCollection | A collection of strings containing corridor codes. A code is used to identify common calculated points in applied assemblies in... more
CorridorCollection | A collection of Corridor objects.
CorridorSection | A section of a Corridor.
CorridorSurface | Represents a layer of a corridor, and is computed from a set of feature lines, calculated points, and calculated links.... more
CorridorSurfaceBaseMask | Base class for CorridorSurfaceMask and CorridorSurfaceBoundary.
CorridorSurfaceBoundary | A corridor surface boundary represents an outside or inside edge of a corridor surface (CorridorSurface). It is defined... more
CorridorSurfaceBoundaryCollection | Collection of corridor surface boundary (CorridorSurfaceBoundary) objects.
CorridorSurfaceCollection | A collection of corridor surface (CorridorSurface) objects.
CorridorSurfaceMask | The corridor surface mask is a region defined by a polygon or a series of feature line components (FeatureLineComponent... more
CorridorSurfaceMaskCollection | Collection of corridor surface mask (CorridorSurfaceMask) objects.
FeatureLine | A feature line is a connected series of points along a corridor created by joining those points from each assembly... more
FeatureLineCodeInfo | Information about the code used to construct a feature line.
FeatureLineCodeInfoCollection | A collection of feature line code information (FeatureLineCodeInfo) objects.
FeatureLineCollection | Collection of feature lines that share a particular code. Multiple points in a single assembly may contain the same code,... more
FeatureLineCollectionMap | A collection of multiple feature line collections (FeatureLineCollection) objects.
FeatureLineComponent | A portion of an entire feature line, delimited by a starting and ending station.
FeatureLineComponentCollection | A collection of feature line component (FeatureLineComponent) objects.
FeatureLinePoint | A point in a feature line (FeatureLine object). A feature line is created by connecting common points within applied... more
FeatureLinePointCollection | A collection of feature line point (FeatureLinePoint) objects.
HardcodedOffsetBaseline | An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between... more
Intersection | An object that manages the intersection of two Alignments. An intersection object builds on and manages various object data, including... more
IntersectionRegion | Corridor regions in an Intersection area.
IntersectionRegionCollection | A collection of IntersectionRegion objects.
IntersectionRoad | Road components managed by an Intersection object.
IntersectionRoadCollection | A collection of IntersectionRoad objecs managed by an Intersection object.
Link | Roadway Link object. Connects roadway points in a subassembly.
LinkCollection | A collection of Link objects.
OffsetBaseline | An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between... more
OffsetBaselineCollection | Collection of offset baseline objects. There are two kinds of offset baselines, OffsetBaseline and HardcodedOffsetBaseline. Both of these are... more
Point | Roadway Point object. Represents a single point within a subassembly.
PointCollection | A collection of Roadway Point objects.
SampledSectionLink | Defines a single line segment of sample surface cross-section data.
SampledSectionLinkCollection | Collection of sampled elevation data.
Shape | Roadway Shape object. Represents a series of roadway links which form a closed shape. Used in subassemblies.
ShapeCollection | A collection of Roadway Shape objects.
SlopeElevationTarget | The SlopeElevation class.
Subassembly | Pattern for part of a corridor cross section, representing a particular portion of a roadway.
SubassemblyCollection | A collection of Subassembly objects.
SubassemblyGenerator | Controls the way Subassembly geometry is generated.
WidthOffsetTarget | The WidthOffsetTarget class.
Interfaces
Interface | Description
IPoint | This is class Autodesk::Civil::Roadway::DatabaseServices::IPoint.
Structs, Records, Enums
Struct, Record, Enum | Description
CorridorBaselineType | Enumerates baseline types.
CorridorLinkDisplay | The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDisplay enumeration.
CorridorLinkDrawOverride | The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDrawOverride enumeration.
CorridorSurfaceBoundaryType | Defines CorridorSurfaceBoundary types.
CurbReturnJoiningType | Specifies the method that is used to define the curb return profile.
IntersectionCorridorType | Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options... more
MaterialConditionType | An enumeration that specifies the material condition type.
MaterialItemType | An enumeration that specifies the material item type.
MaterialQuantityType | An enumeration that specifies the material quantity type.
OffsetLengthOption | Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are... more
SideRoadProfileDistanceRuleType | Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is... more
SubassemblyGeometryGenerateMode | Enumerates the way subassembly geometry can be generated.
Links
Namespaces, Topics, Classes, Interfaces, Structs, Records, Enums


Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Collapse All

The Autodesk::Civil::Roadway::DatabaseServices::Styles namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
AssemblyStyle | Used to control the visual style of an Assembly object.
AssemblyStyleCollection | A collection of AssemblyStyle objects.
CodeSetStyle | A collection of CodeSetStyleItem objects. CodeSetStyleItem defines a code and related style, where the style is the ObjectId of a... more
CodeSetStyleCollection | A collection of CodeSetStyle objects.
CodeSetStyleItem | Defines the style to apply to a specific code.
CorridorStyle | Defines the appearance of objects.
CorridorStyleCollection | A collection of CorridorStyle objects.
IntersectionStyle | The match line style wrapper class.
IntersectionStyleCollection | The IntersectionStyleCollection class.
LabelStylesIntersectionRoot | Root for all intersection label collections.
LinkStyle | Used to control the visual style of a roadway link (Link) object.
LinkStyleCollection | A collection of LinkStyle objects.
QuantityTakeoffCriteria | A collection of items that define the criteria used to calculate material lists, which are then used ot generate quantity... more
QuantityTakeoffCriteriaCollection | The QuantityTakeoffCriteriaCollection class.
QuantityTakeoffCriteriaData | Defines additional data for material in QuantityTakeoffCriteria.
QuantityTakeoffCriteriaItem | Defines a material used to create quantity takeoff criteria (QuantityTakeoffCriteria).
ShapeStyle | Used to control the visual style of a roadway shape (Shape) object.
ShapeStyleCollection | A collection of ShapeStyle objects.
SubassemblySubentityStyle | Base class for LinkStyle and ShapeStyle.
Structs, Records, Enums
Struct, Record, Enum | Description
CodeSetStyleItemType | Specifies valid CodeSetStyleItem types.
CorridorDisplayStyleType | The Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorDisplayStyleType enumeration.
ShapeDisplayStyleType | Defines ShapeStyle display style type.
SubassemblySubentityStyleType | The Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyleType enumeration.
Links
Topics, Classes, Structs, Records, Enums


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes
Classes
Collapse All

The following table lists classes in this documentation.

Classes
Class | Description
AssemblyStyle | Used to control the visual style of an Assembly object.
AssemblyStyleCollection | A collection of AssemblyStyle objects.
CodeSetStyle | A collection of CodeSetStyleItem objects. CodeSetStyleItem defines a code and related style, where the style is the ObjectId of a... more
CodeSetStyleCollection | A collection of CodeSetStyle objects.
CodeSetStyleItem | Defines the style to apply to a specific code.
CorridorStyle | Defines the appearance of objects.
CorridorStyleCollection | A collection of CorridorStyle objects.
IntersectionStyle | The match line style wrapper class.
IntersectionStyleCollection | The IntersectionStyleCollection class.
LabelStylesIntersectionRoot | Root for all intersection label collections.
LinkStyle | Used to control the visual style of a roadway link (Link) object.
LinkStyleCollection | A collection of LinkStyle objects.
QuantityTakeoffCriteria | A collection of items that define the criteria used to calculate material lists, which are then used ot generate quantity... more
QuantityTakeoffCriteriaCollection | The QuantityTakeoffCriteriaCollection class.
QuantityTakeoffCriteriaData | Defines additional data for material in QuantityTakeoffCriteria.
QuantityTakeoffCriteriaItem | Defines a material used to create quantity takeoff criteria (QuantityTakeoffCriteria).
ShapeStyle | Used to control the visual style of a roadway shape (Shape) object.
ShapeStyleCollection | A collection of ShapeStyle objects.
SubassemblySubentityStyle | Base class for LinkStyle and ShapeStyle.
Links
Classes


AssemblyStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class
AssemblyStyle Class
Collapse All

Used to control the visual style of an Assembly object.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAssemblyStyle"))]
public class AssemblyStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAssemblyStyle"))>
Public Class AssemblyStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Example
// Add a new assembly style to the document:
ObjectId objId = doc.Styles.AssemblyStyles.Add("Style1");
AssemblyStyle oAssemblyStyle = ts.GetObject(objId, OpenMode.ForWrite) as AssemblyStyle;
objId = oAssemblyStyle.MarkerStyleAtMainBaselineId;
MarkerStyle oMarker = ts.GetObject(objId, OpenMode.ForWrite) as MarkerStyle;
oMarker.CustomMarkerStyle = CustomMarkerType.CustomMarkerX;
oMarker.MarkerDisplayStylePlan.Color = Color.FromColorIndex(ColorMethod.ByAci, 10); // red
oMarker.MarkerDisplayStylePlan.Visible = true;

ts.Commit();
Links
AssemblyStyle Methods, AssemblyStyle Properties, AssemblyStyle Members, Class Hierarchy


AssemblyStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Members
AssemblyStyle Members
Collapse All

The following tables list the members exposed by AssemblyStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the corridor model display components.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the corridor plan display components.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerStyleAtAssemblyOriginId | Gets the ID of the marker style at the Assembly origin.
MarkerStyleAtMainBaselineId | Gets the ID of the marker style at the Assembly main baseline.
MarkerStyleAtMainBaselineOriginId | Gets the ID of the marker style at the Assembly main baseline origin.
MarkerStyleAtOffsetBaselineId | Gets the ID of the marker style at the Assembly offset baseline.
MarkerStyleAtOffsetBaselineOriginId | Gets the ID of the marker style at the Assembly offset baseline origin.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


AssemblyStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Methods
AssemblyStyle Methods
Collapse All

The methods of AssemblyStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the corridor model display components.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the corridor plan display components.
Links
Public Methods


AssemblyStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Methods > AssemblyStyle::GetDisplayStyleModel Method
AssemblyStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies the corridor model display components.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    Autodesk::Civil::Roadway::AssemblyDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As Autodesk::Civil::Roadway::AssemblyDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
AssemblyStyle Class, AssemblyStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


AssemblyStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Methods > AssemblyStyle::GetDisplayStylePlan Method
AssemblyStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies the corridor plan display components.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    Autodesk::Civil::Roadway::AssemblyDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As Autodesk::Civil::Roadway::AssemblyDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
AssemblyStyle Class, AssemblyStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


AssemblyStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Properties
AssemblyStyle Properties
Collapse All

The properties of AssemblyStyle are listed here.

Public Properties
Public Property | Description
MarkerStyleAtAssemblyOriginId | Gets the ID of the marker style at the Assembly origin.
MarkerStyleAtMainBaselineId | Gets the ID of the marker style at the Assembly main baseline.
MarkerStyleAtMainBaselineOriginId | Gets the ID of the marker style at the Assembly main baseline origin.
MarkerStyleAtOffsetBaselineId | Gets the ID of the marker style at the Assembly offset baseline.
MarkerStyleAtOffsetBaselineOriginId | Gets the ID of the marker style at the Assembly offset baseline origin.
Links
Public Properties


AssemblyStyle::MarkerStyleAtAssemblyOriginId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Properties > AssemblyStyle::MarkerStyleAtAssemblyOriginId Property
AssemblyStyle::MarkerStyleAtAssemblyOriginId Property
Collapse All

Gets the ID of the marker style at the Assembly origin.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MarkerStyleAtAssemblyOriginId;
Visual Basic
Public Property MarkerStyleAtAssemblyOriginId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AssemblyStyle Class, AssemblyStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


AssemblyStyle::MarkerStyleAtMainBaselineId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Properties > AssemblyStyle::MarkerStyleAtMainBaselineId Property
AssemblyStyle::MarkerStyleAtMainBaselineId Property
Collapse All

Gets the ID of the marker style at the Assembly main baseline.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MarkerStyleAtMainBaselineId;
Visual Basic
Public Property MarkerStyleAtMainBaselineId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AssemblyStyle Class, AssemblyStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


AssemblyStyle::MarkerStyleAtMainBaselineOriginId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Properties > AssemblyStyle::MarkerStyleAtMainBaselineOriginId Property
AssemblyStyle::MarkerStyleAtMainBaselineOriginId Property
Collapse All

Gets the ID of the marker style at the Assembly main baseline origin.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MarkerStyleAtMainBaselineOriginId;
Visual Basic
Public Property MarkerStyleAtMainBaselineOriginId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AssemblyStyle Class, AssemblyStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


AssemblyStyle::MarkerStyleAtOffsetBaselineId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Properties > AssemblyStyle::MarkerStyleAtOffsetBaselineId Property
AssemblyStyle::MarkerStyleAtOffsetBaselineId Property
Collapse All

Gets the ID of the marker style at the Assembly offset baseline.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MarkerStyleAtOffsetBaselineId;
Visual Basic
Public Property MarkerStyleAtOffsetBaselineId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AssemblyStyle Class, AssemblyStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


AssemblyStyle::MarkerStyleAtOffsetBaselineOriginId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Properties > AssemblyStyle::MarkerStyleAtOffsetBaselineOriginId Property
AssemblyStyle::MarkerStyleAtOffsetBaselineOriginId Property
Collapse All

Gets the ID of the marker style at the Assembly offset baseline origin.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MarkerStyleAtOffsetBaselineOriginId;
Visual Basic
Public Property MarkerStyleAtOffsetBaselineOriginId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AssemblyStyle Class, AssemblyStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


AssemblyStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class
AssemblyStyleCollection Class
Collapse All

A collection of AssemblyStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyleCollection
C#
public class AssemblyStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class AssemblyStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
AssemblyStyleCollection Methods, AssemblyStyleCollection Members, Class Hierarchy


AssemblyStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class > AssemblyStyleCollection Members
AssemblyStyleCollection Members
Collapse All

The following tables list the members exposed by AssemblyStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


AssemblyStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class > AssemblyStyleCollection Methods
AssemblyStyleCollection Methods
Collapse All

The methods of AssemblyStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


AssemblyStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class > AssemblyStyleCollection Methods > AssemblyStyleCollection::Add Method
AssemblyStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
AssemblyStyleCollection Class, AssemblyStyleCollection Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class
CodeSetStyle Class
Collapse All

A collection of CodeSetStyleItem objects. CodeSetStyleItem defines a code and related style, where the style is the ObjectId of a LinkStyle or ShapeStyle.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayStyleSet"))]
public class CodeSetStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase, System::Collections::Generic::IEnumerable<CodeSetStyleItem^>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayStyleSet"))>
Public Class CodeSetStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Inherits System::Collections::Generic::IEnumerable<CodeSetStyleItem^>
Example
// Create a new style set using our previously created styles.
objId = doc.Styles.ShapeStyles.Add("Style Set 1");
CodeSetStyle oCodeSetStyle = ts.GetObject(objId, OpenMode.ForWrite) as CodeSetStyle;
oCodeSetStyle.Add("TOP", doc.Styles.LinkStyles["Style2"]);
oCodeSetStyle.Add("BASE", doc.Styles.ShapeStyles["Style3"]);

ts.Commit();
Links
CodeSetStyle Methods, CodeSetStyle Properties, CodeSetStyle Members, Class Hierarchy


CodeSetStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Members
CodeSetStyle Members
Collapse All

The following tables list the members exposed by CodeSetStyle.

Public Methods
Public Method | Description
Add | Add method.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetCurrentStyleSetId | Gets the ObjectId of the current CodeSetStyle. void InitAsCurrent();
GetEnumerator | Get the enumerator of this collection.
GetItemBy | Indexer.
GetObjectEnumerator | Get the enumerator of this collection.
Remove | Remove method.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the code set item count.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Indexer.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
SubentityStyleType | Set the Corridor Style Type.
Links
Public Methods, Public Properties


CodeSetStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Methods
CodeSetStyle Methods
Collapse All

The methods of CodeSetStyle are listed here.

Public Methods
Public Method | Description
Add | Add method.
GetCurrentStyleSetId | Gets the ObjectId of the current CodeSetStyle. void InitAsCurrent();
GetEnumerator | Get the enumerator of this collection.
GetItemBy | Indexer.
GetObjectEnumerator | Get the enumerator of this collection.
Remove | Remove method.
Links
Public Methods


CodeSetStyle::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Methods > CodeSetStyle::Add Method
CodeSetStyle::Add Method
Collapse All

Add method.

C#
public CodeSetStyleItem Add(
    ref System::String code,
    Autodesk::AutoCAD::DatabaseServices::ObjectId styleId
);
Visual Basic
Public Function Add(
    ByRef code As System::String,
    styleId As Autodesk::AutoCAD::DatabaseServices::ObjectId
) As CodeSetStyleItem
Parameters
Parameters | Description
code | The name of this code.
codeStyle | The style of this code.
Remarks

You can use the method to add the item which type is NormalItemType.

Exceptions
Exceptions | Description
 | System::ArgumentNullException, System::ArgumentException
Links
CodeSetStyle Class, CodeSetStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyle::GetCurrentStyleSetId Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Methods > CodeSetStyle::GetCurrentStyleSetId Method
CodeSetStyle::GetCurrentStyleSetId Method
Collapse All

Gets the ObjectId of the current CodeSetStyle.

void InitAsCurrent();

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId GetCurrentStyleSetId();
Visual Basic
Public Function GetCurrentStyleSetId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CodeSetStyle Class, CodeSetStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyle::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Methods > CodeSetStyle::GetEnumerator Method
CodeSetStyle::GetEnumerator Method
Collapse All

Get the enumerator of this collection.

C#
public System::Collections::Generic::IEnumerator<CodeSetStyleItem^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<CodeSetStyleItem^>
Links
CodeSetStyle Class, CodeSetStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyle::GetItemBy Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Methods > CodeSetStyle::GetItemBy Method
CodeSetStyle::GetItemBy Method
Collapse All

Indexer.

C#
public CodeSetStyleItem GetItemBy(
    CodeSetStyleItemType itemType,
    ref System::String code
);
Visual Basic
Public Function GetItemBy(
    itemType As CodeSetStyleItemType,
    ByRef code As System::String
) As CodeSetStyleItem
Parameters
Parameters | Description
itemType | Indicate the item type.
code | The name of this code.
Remarks

You can use the method to get the item which type is DefaultItemType or NoCodeItemType, and the code just affect the item which type is NormalItemType.

Exceptions
Exceptions | Description
 | System::ArgumentException, System::ArgumentOutOfRangeException,System::Collections::Generic::KeyNotFoundException
Links
CodeSetStyle Class, CodeSetStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyle::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Methods > CodeSetStyle::GetObjectEnumerator Method
CodeSetStyle::GetObjectEnumerator Method
Collapse All

Get the enumerator of this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Links
CodeSetStyle Class, CodeSetStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyle::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Methods > CodeSetStyle::Remove Method
CodeSetStyle::Remove Method
Collapse All

Remove method.

C#
public Remove(
    ref System::String code
);
Visual Basic
Public Sub Remove(
    ByRef code As System::String
)
Parameters
Parameters | Description
code | The name of this code.
Remarks

You can use the method to remove the item which type is NormalItemType.

Exceptions
Exceptions | Description
 | System::ArgumentNullException, System::ArgumentException, System::Collections::Generic::KeyNotFoundException
Links
CodeSetStyle Class, CodeSetStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Properties
CodeSetStyle Properties
Collapse All

The properties of CodeSetStyle are listed here.

Public Properties
Public Property | Description
Count | Gets the code set item count.
default | Indexer.
SubentityStyleType | Set the Corridor Style Type.
Links
Public Properties


CodeSetStyle::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Properties > CodeSetStyle::Count Property
CodeSetStyle::Count Property
Collapse All

Gets the code set item count.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Remarks

The count number does not include these two items which type are DefaultItemType or NoCodeItemType.

Links
CodeSetStyle Class, CodeSetStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyle::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Properties > CodeSetStyle::default Property
CodeSetStyle::default Property
Collapse All

Indexer.

C#
public CodeSetStyleItem default;
Visual Basic
Public Property default() As CodeSetStyleItem
Parameters
Parameters | Description
index | Index of the item.
Remarks

You can use the method to get the item which type is NormalItemType.

Links
CodeSetStyle Class, CodeSetStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyle::SubentityStyleType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Properties > CodeSetStyle::SubentityStyleType Property
CodeSetStyle::SubentityStyleType Property
Collapse All

Set the Corridor Style Type.

C#
public SubassemblySubentityStyleType SubentityStyleType;
Visual Basic
Public Property SubentityStyleType() As SubassemblySubentityStyleType
Links
CodeSetStyle Class, CodeSetStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class
CodeSetStyleCollection Class
Collapse All

A collection of CodeSetStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleCollection
C#
public class CodeSetStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class CodeSetStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
CodeSetStyleCollection Methods, CodeSetStyleCollection Members, Class Hierarchy


CodeSetStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class > CodeSetStyleCollection Members
CodeSetStyleCollection Members
Collapse All

The following tables list the members exposed by CodeSetStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


CodeSetStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class > CodeSetStyleCollection Methods
CodeSetStyleCollection Methods
Collapse All

The methods of CodeSetStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


CodeSetStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class > CodeSetStyleCollection Methods > CodeSetStyleCollection::Add Method
CodeSetStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
CodeSetStyleCollection Class, CodeSetStyleCollection Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class
CodeSetStyleItem Class
Collapse All

Defines the style to apply to a specific code.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleItem
C#
public class CodeSetStyleItem : CivilWrapper<AeccDbRoadwayStyleSet>;
Visual Basic
Public Class CodeSetStyleItem
Inherits CivilWrapper<AeccDbRoadwayStyleSet>
Links
CodeSetStyleItem Properties, CodeSetStyleItem Members, Class Hierarchy


CodeSetStyleItem Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Members
CodeSetStyleItem Members
Collapse All

The following tables list the members exposed by CodeSetStyleItem.

Public Properties
Public Property | Description
Code | Gets or sets the code string.
CodeStyleId | Gets or sets the ID of the code style for this code.
CodeStyleName | Gets or Sets the code style name.
Description | Gets or sets the description for the CodeSetStyleItem.
FeatureLineStyleId | Gets or Sets the feature line style object id.
FeatureLineStyleName | Gets or Sets the feature line style name.
ItemType | Gets the code set style item type.
LabelStyleId | Gets or Sets the label style object id. We can set the label style to "none" as UI did with... more
LabelStyleName | Gets or Sets the label style name.
MaterialAreaFillStyleId | Gets or Sets the object id of the shape style used to fill the material area.
MaterialAreaFillStyleName | Gets or Sets the name of the shape style used to fill the material area.
PayItems | Gets or Sets the payitem list.
RenderMaterialStyleId | Gets or Sets the object id of render material style .
RenderMaterialStyleName | Gets or Sets the name of render material style.
StyleType | Gets the subassembly subentity style type.
Links
Public Properties


CodeSetStyleItem Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties
CodeSetStyleItem Properties
Collapse All

The properties of CodeSetStyleItem are listed here.

Public Properties
Public Property | Description
Code | Gets or sets the code string.
CodeStyleId | Gets or sets the ID of the code style for this code.
CodeStyleName | Gets or Sets the code style name.
Description | Gets or sets the description for the CodeSetStyleItem.
FeatureLineStyleId | Gets or Sets the feature line style object id.
FeatureLineStyleName | Gets or Sets the feature line style name.
ItemType | Gets the code set style item type.
LabelStyleId | Gets or Sets the label style object id. We can set the label style to "none" as UI did with... more
LabelStyleName | Gets or Sets the label style name.
MaterialAreaFillStyleId | Gets or Sets the object id of the shape style used to fill the material area.
MaterialAreaFillStyleName | Gets or Sets the name of the shape style used to fill the material area.
PayItems | Gets or Sets the payitem list.
RenderMaterialStyleId | Gets or Sets the object id of render material style .
RenderMaterialStyleName | Gets or Sets the name of render material style.
StyleType | Gets the subassembly subentity style type.
Links
Public Properties


CodeSetStyleItem::Code Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::Code Property
CodeSetStyleItem::Code Property
Collapse All

Gets or sets the code string.

C#
public System::String Code;
Visual Basic
Public Property Code() As System::String
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::CodeStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::CodeStyleId Property
CodeSetStyleItem::CodeStyleId Property
Collapse All

Gets or sets the ID of the code style for this code.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CodeStyleId;
Visual Basic
Public Property CodeStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::CodeStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::CodeStyleName Property
CodeSetStyleItem::CodeStyleName Property
Collapse All

Gets or Sets the code style name.

C#
public System::String CodeStyleName;
Visual Basic
Public Property CodeStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the label style name is invalid.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::Description Property
CodeSetStyleItem::Description Property
Collapse All

Gets or sets the description for the CodeSetStyleItem.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::FeatureLineStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::FeatureLineStyleId Property
CodeSetStyleItem::FeatureLineStyleId Property
Collapse All

Gets or Sets the feature line style object id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId FeatureLineStyleId;
Visual Basic
Public Property FeatureLineStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

We can set the feature line style to "none" as UI did with the value: ObjectId.Null.

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.FeatureLineStyle.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input style type is not Autodesk.Civil.DatabaseServices.Styles.FeatureLineStyle.
System.InvalidOperationException | Thrown when the property StyleType is SubassemblySubentityStyleType::LinkType or ShapeType.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::FeatureLineStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::FeatureLineStyleName Property
CodeSetStyleItem::FeatureLineStyleName Property
Collapse All

Gets or Sets the feature line style name.

C#
public System::String FeatureLineStyleName;
Visual Basic
Public Property FeatureLineStyleName() As System::String
Remarks

We can set the style value to "<none>" as UI did with the value: "".

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the feature line style name is invalid.
System.InvalidOperationException | Thrown when the property StyleType is SubassemblySubentityStyleType::LinkType or ShapeType.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::ItemType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::ItemType Property
CodeSetStyleItem::ItemType Property
Collapse All

Gets the code set style item type.

C#
public CodeSetStyleItemType ItemType;
Visual Basic
Public Property ItemType() As CodeSetStyleItemType
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::LabelStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::LabelStyleId Property
CodeSetStyleItem::LabelStyleId Property
Collapse All

Gets or Sets the label style object id.

We can set the label style to "none" as UI did with the value: ObjectId.Null.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LabelStyleId;
Visual Basic
Public Property LabelStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.LabelStyle.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input style type is not Autodesk.Civil.DatabaseServices.Styles.LabelStyle.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::LabelStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::LabelStyleName Property
CodeSetStyleItem::LabelStyleName Property
Collapse All

Gets or Sets the label style name.

C#
public System::String LabelStyleName;
Visual Basic
Public Property LabelStyleName() As System::String
Remarks

We can set the style value to "<none>" as UI did with the value: "".

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the label style name is invalid.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::MaterialAreaFillStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::MaterialAreaFillStyleId Property
CodeSetStyleItem::MaterialAreaFillStyleId Property
Collapse All

Gets or Sets the object id of the shape style used to fill the material area.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MaterialAreaFillStyleId;
Visual Basic
Public Property MaterialAreaFillStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

We can set the material area fill to "none" as UI did with the value: ObjectId.Null.

OBJECTID TYPE: Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input style type is not Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle.
System.InvalidOperationException | Thrown when the property StyleType is SubassemblySubentityStyleType::MarkerType or ShapeType.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::MaterialAreaFillStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::MaterialAreaFillStyleName Property
CodeSetStyleItem::MaterialAreaFillStyleName Property
Collapse All

Gets or Sets the name of the shape style used to fill the material area.

C#
public System::String MaterialAreaFillStyleName;
Visual Basic
Public Property MaterialAreaFillStyleName() As System::String
Remarks

We can set the style value to "<none>" as UI did with the value: "".

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the shape style name is invalid.
System.InvalidOperationException | Thrown when the property StyleType is SubassemblySubentityStyleType::MarkerType or ShapeType.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::PayItems Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::PayItems Property
CodeSetStyleItem::PayItems Property
Collapse All

Gets or Sets the payitem list.

C#
public array<System::String^> PayItems;
Visual Basic
Public Property PayItems() As array<System::String^>
Remarks

We can set the pay item list to "none" as UI did with a empty String array.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property StyleType is SubassemblySubentityStyleType::ShapeType.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::RenderMaterialStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::RenderMaterialStyleId Property
CodeSetStyleItem::RenderMaterialStyleId Property
Collapse All

Gets or Sets the object id of render material style .

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId RenderMaterialStyleId;
Visual Basic
Public Property RenderMaterialStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

We can set the render material to "none" as UI did with the value: ObjectId.Null.

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.XXX.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input style type is not Autodesk.Civil.DatabaseServices.Styles.XXX.
System.InvalidOperationException | Thrown when the property StyleType is SubassemblySubentityStyleType::MarkerType or ShapeType.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::RenderMaterialStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::RenderMaterialStyleName Property
CodeSetStyleItem::RenderMaterialStyleName Property
Collapse All

Gets or Sets the name of render material style.

C#
public System::String RenderMaterialStyleName;
Visual Basic
Public Property RenderMaterialStyleName() As System::String
Remarks

We can set the style value to "<none>" as UI did with the value: "".

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style name is invalid.
System.InvalidOperationException | Thrown when the property StyleType is SubassemblySubentityStyleType::MarkerType or ShapeType.
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CodeSetStyleItem::StyleType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties > CodeSetStyleItem::StyleType Property
CodeSetStyleItem::StyleType Property
Collapse All

Gets the subassembly subentity style type.

C#
public SubassemblySubentityStyleType StyleType;
Visual Basic
Public Property StyleType() As SubassemblySubentityStyleType
Links
CodeSetStyleItem Class, CodeSetStyleItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CorridorStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class
CorridorStyle Class
Collapse All

Defines the appearance of objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbCorridorStyle"))]
public class CorridorStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbCorridorStyle"))>
Public Class CorridorStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
CorridorStyle Methods, CorridorStyle Members, Class Hierarchy


CorridorStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Members
CorridorStyle Members
Collapse All

The following tables list the members exposed by CorridorStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the corridor model display components.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the corridor plan display components.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


CorridorStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Methods
CorridorStyle Methods
Collapse All

The methods of CorridorStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the corridor model display components.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the corridor plan display components.
Links
Public Methods


CorridorStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Methods > CorridorStyle::GetDisplayStyleModel Method
CorridorStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies the corridor model display components.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    CorridorDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As CorridorDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
CorridorStyle Class, CorridorStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CorridorStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Methods > CorridorStyle::GetDisplayStylePlan Method
CorridorStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies the corridor plan display components.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    CorridorDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As CorridorDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
CorridorStyle Class, CorridorStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


CorridorStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class
CorridorStyleCollection Class
Collapse All

A collection of CorridorStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyleCollection
C#
public class CorridorStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class CorridorStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
CorridorStyleCollection Methods, CorridorStyleCollection Members, Class Hierarchy


CorridorStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class > CorridorStyleCollection Members
CorridorStyleCollection Members
Collapse All

The following tables list the members exposed by CorridorStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


CorridorStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class > CorridorStyleCollection Methods
CorridorStyleCollection Methods
Collapse All

The methods of CorridorStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


CorridorStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class > CorridorStyleCollection Methods > CorridorStyleCollection::Add Method
CorridorStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
CorridorStyleCollection Class, CorridorStyleCollection Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


IntersectionStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class
IntersectionStyle Class
Collapse All

The match line style wrapper class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbIntersectionStyle"))]
public class IntersectionStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbIntersectionStyle"))>
Public Class IntersectionStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
IntersectionStyle Methods, IntersectionStyle Properties, IntersectionStyle Members, Class Hierarchy


IntersectionStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Members
IntersectionStyle Members
Collapse All

The following tables list the members exposed by IntersectionStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the intersection component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the intersection component.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerStyleId | Gets the marker style object id for the intersection.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


IntersectionStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Methods
IntersectionStyle Methods
Collapse All

The methods of IntersectionStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the intersection component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the intersection component.
Links
Public Methods


IntersectionStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Methods > IntersectionStyle::GetDisplayStyleModel Method
IntersectionStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies model display properties for the intersection component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel();
Visual Basic
Public Function GetDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
IntersectionStyle Class, IntersectionStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


IntersectionStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Methods > IntersectionStyle::GetDisplayStylePlan Method
IntersectionStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties for the intersection component.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan();
Visual Basic
Public Function GetDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
IntersectionStyle Class, IntersectionStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


IntersectionStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Properties
IntersectionStyle Properties
Collapse All

The properties of IntersectionStyle are listed here.

Public Properties
Public Property | Description
MarkerStyleId | Gets the marker style object id for the intersection.
Links
Public Properties


IntersectionStyle::MarkerStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Properties > IntersectionStyle::MarkerStyleId Property
IntersectionStyle::MarkerStyleId Property
Collapse All

Gets the marker style object id for the intersection.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId MarkerStyleId;
Visual Basic
Public Property MarkerStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.MarkerStyle

Links
IntersectionStyle Class, IntersectionStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


IntersectionStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class
IntersectionStyleCollection Class
Collapse All

The IntersectionStyleCollection class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyleCollection
C#
public class IntersectionStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class IntersectionStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
IntersectionStyleCollection Methods, IntersectionStyleCollection Members, Class Hierarchy


IntersectionStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class > IntersectionStyleCollection Members
IntersectionStyleCollection Members
Collapse All

The following tables list the members exposed by IntersectionStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


IntersectionStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class > IntersectionStyleCollection Methods
IntersectionStyleCollection Methods
Collapse All

The methods of IntersectionStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


IntersectionStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class > IntersectionStyleCollection Methods > IntersectionStyleCollection::Add Method
IntersectionStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
IntersectionStyleCollection Class, IntersectionStyleCollection Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LabelStylesIntersectionRoot Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LabelStylesIntersectionRoot Class
LabelStylesIntersectionRoot Class
Collapse All

Root for all intersection label collections.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::Roadway::DatabaseServices::Styles::LabelStylesIntersectionRoot
C#
public class LabelStylesIntersectionRoot : Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode;
Visual Basic
Public Class LabelStylesIntersectionRoot
Inherits Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
Links
LabelStylesIntersectionRoot Properties, LabelStylesIntersectionRoot Members, Class Hierarchy


LabelStylesIntersectionRoot Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LabelStylesIntersectionRoot Class > LabelStylesIntersectionRoot Members
LabelStylesIntersectionRoot Members
Collapse All

The following tables list the members exposed by LabelStylesIntersectionRoot.

Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
LocationLabelStyles | Gets the collection of all intersection location label styles.
Links
Public Properties


LabelStylesIntersectionRoot Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LabelStylesIntersectionRoot Class > LabelStylesIntersectionRoot Properties
LabelStylesIntersectionRoot Properties
Collapse All

The properties of LabelStylesIntersectionRoot are listed here.

Public Properties
Public Property | Description
LocationLabelStyles | Gets the collection of all intersection location label styles.
Links
Public Properties


LabelStylesIntersectionRoot::LocationLabelStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LabelStylesIntersectionRoot Class > LabelStylesIntersectionRoot Properties > LabelStylesIntersectionRoot::LocationLabelStyles Property
LabelStylesIntersectionRoot::LocationLabelStyles Property
Collapse All

Gets the collection of all intersection location label styles.

C#
public Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection LocationLabelStyles;
Visual Basic
Public Property LocationLabelStyles() As Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
Links
LabelStylesIntersectionRoot Class, LabelStylesIntersectionRoot Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LinkStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class
LinkStyle Class
Collapse All

Used to control the visual style of a roadway link (Link) object.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyle
            Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayLinkStyle"))]
public class LinkStyle : SubassemblySubentityStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayLinkStyle"))>
Public Class LinkStyle
Inherits SubassemblySubentityStyle
Example
// Add a new link style to the document:
objId = doc.Styles.LinkStyles.Add("Style2");
LinkStyle oLinkStyle = ts.GetObject(objId, OpenMode.ForWrite) as LinkStyle;
oLinkStyle.LinkDisplayStylePlan.Color = Color.FromColorIndex(ColorMethod.ByAci, 80);
oLinkStyle.LinkDisplayStylePlan.Visible = true;

ts.Commit();
Links
LinkStyle Methods, LinkStyle Properties, LinkStyle Members, Class Hierarchy


LinkStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Members
LinkStyle Members
Collapse All

The following tables list the members exposed by LinkStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
GetDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
GetDisplayStyleSection | Gets the DisplayStyle that specifies such Section display styles as color, linetype, plotstyle, etc.
GetLinkDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
GetLinkDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
LinkDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
LinkDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
StyleType | Gets the style type.
Links
Public Methods, Public Properties


LinkStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Methods
LinkStyle Methods
Collapse All

The methods of LinkStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
GetDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
GetDisplayStyleSection | Gets the DisplayStyle that specifies such Section display styles as color, linetype, plotstyle, etc.
GetLinkDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
GetLinkDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
Links
Public Methods


LinkStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Methods > LinkStyle::GetDisplayStyleModel Method
LinkStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel();
Visual Basic
Public Function GetDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
LinkStyle Class, LinkStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LinkStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Methods > LinkStyle::GetDisplayStylePlan Method
LinkStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan();
Visual Basic
Public Function GetDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
LinkStyle Class, LinkStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LinkStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Methods > LinkStyle::GetDisplayStyleSection Method
LinkStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle that specifies such Section display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection();
Visual Basic
Public Function GetDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
LinkStyle Class, LinkStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LinkStyle::GetLinkDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Methods > LinkStyle::GetLinkDisplayStyleModel Method
LinkStyle::GetLinkDisplayStyleModel Method
Collapse All

Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetLinkDisplayStyleModel();
Visual Basic
Public Function GetLinkDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
LinkStyle Class, LinkStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LinkStyle::GetLinkDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Methods > LinkStyle::GetLinkDisplayStylePlan Method
LinkStyle::GetLinkDisplayStylePlan Method
Collapse All

Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetLinkDisplayStylePlan();
Visual Basic
Public Function GetLinkDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Links
LinkStyle Class, LinkStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LinkStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Properties
LinkStyle Properties
Collapse All

The properties of LinkStyle are listed here.

Public Properties
Public Property | Description
LinkDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
LinkDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
StyleType | Gets the style type.
Links
Public Properties


LinkStyle::LinkDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Properties > LinkStyle::LinkDisplayStyleModel Property
LinkStyle::LinkDisplayStyleModel Property deprecated
Collapse All

Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle LinkDisplayStyleModel;
Visual Basic
Public Property LinkDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Roadway.DatabaseServices.Styles.LinkStyle.GetLinkDisplayStyleModel() instead.

Links
LinkStyle Class, LinkStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LinkStyle::LinkDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Properties > LinkStyle::LinkDisplayStylePlan Property
LinkStyle::LinkDisplayStylePlan Property deprecated
Collapse All

Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle LinkDisplayStylePlan;
Visual Basic
Public Property LinkDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Roadway.DatabaseServices.Styles.LinkStyle.GetLinkDisplayStylePlan() instead.

Links
LinkStyle Class, LinkStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LinkStyle::StyleType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Properties > LinkStyle::StyleType Property
LinkStyle::StyleType Property
Collapse All

Gets the style type.

C#
public SubassemblySubentityStyleType StyleType;
Visual Basic
Public Property StyleType() As SubassemblySubentityStyleType
Links
LinkStyle Class, LinkStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


LinkStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class
LinkStyleCollection Class
Collapse All

A collection of LinkStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyleCollection
C#
public class LinkStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class LinkStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
LinkStyleCollection Methods, LinkStyleCollection Members, Class Hierarchy


LinkStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class > LinkStyleCollection Members
LinkStyleCollection Members
Collapse All

The following tables list the members exposed by LinkStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


LinkStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class > LinkStyleCollection Methods
LinkStyleCollection Methods
Collapse All

The methods of LinkStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


LinkStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class > LinkStyleCollection Methods > LinkStyleCollection::Add Method
LinkStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
LinkStyleCollection Class, LinkStyleCollection Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteria Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class
QuantityTakeoffCriteria Class
Collapse All

A collection of items that define the criteria used to calculate material lists, which are then used ot generate quantity takeoff tables and reports.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteria
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbQuantityTakeoffCriteria"))]
public class QuantityTakeoffCriteria : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbQuantityTakeoffCriteria"))>
Public Class QuantityTakeoffCriteria
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
QuantityTakeoffCriteria Methods, QuantityTakeoffCriteria Properties, QuantityTakeoffCriteria Members, Class Hierarchy


QuantityTakeoffCriteria Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Members
QuantityTakeoffCriteria Members
Collapse All

The following tables list the members exposed by QuantityTakeoffCriteria.

Public Methods
Public Method | Description
AddMaterial | Adds a new empty material with the default value to the list.
Clear | Removes all the material items from the list.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
RemoveAt | Removes a material item from the list.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the number of material items.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the material item at the given index.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Links
Public Methods, Public Properties


QuantityTakeoffCriteria Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Methods
QuantityTakeoffCriteria Methods
Collapse All

The methods of QuantityTakeoffCriteria are listed here.

Public Methods
Public Method | Description
AddMaterial | Adds a new empty material with the default value to the list.
Clear | Removes all the material items from the list.
RemoveAt | Removes a material item from the list.
Links
Public Methods


QuantityTakeoffCriteria::AddMaterial Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Methods > QuantityTakeoffCriteria::AddMaterial Method
QuantityTakeoffCriteria::AddMaterial Method
Collapse All

Adds a new empty material with the default value to the list.

C#
public AddMaterial(
    ref System::String materialName
);
Visual Basic
Public Sub AddMaterial(
    ByRef materialName As System::String
)
Parameters
Parameters | Description
materialName | The name of the material item.
Links
QuantityTakeoffCriteria Class, QuantityTakeoffCriteria Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteria::Clear Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Methods > QuantityTakeoffCriteria::Clear Method
QuantityTakeoffCriteria::Clear Method
Collapse All

Removes all the material items from the list.

C#
public Clear();
Visual Basic
Public Sub Clear()
Links
QuantityTakeoffCriteria Class, QuantityTakeoffCriteria Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteria::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Methods > QuantityTakeoffCriteria::RemoveAt Method
QuantityTakeoffCriteria::RemoveAt Method
Collapse All

Removes a material item from the list.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Specified the material item by index.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the material list range.
Links
QuantityTakeoffCriteria Class, QuantityTakeoffCriteria Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteria Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Properties
QuantityTakeoffCriteria Properties
Collapse All

The properties of QuantityTakeoffCriteria are listed here.

Public Properties
Public Property | Description
Count | Gets the number of material items.
default | Gets the material item at the given index.
Links
Public Properties


QuantityTakeoffCriteria::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Properties > QuantityTakeoffCriteria::Count Property
QuantityTakeoffCriteria::Count Property
Collapse All

Gets the number of material items.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
QuantityTakeoffCriteria Class, QuantityTakeoffCriteria Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteria::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Properties > QuantityTakeoffCriteria::default Property
QuantityTakeoffCriteria::default Property
Collapse All

Gets the material item at the given index.

C#
public QuantityTakeoffCriteriaItem default;
Visual Basic
Public Property default() As QuantityTakeoffCriteriaItem
Parameters
Parameters | Description
index | Specified the material item by index.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the collection's range.
Links
QuantityTakeoffCriteria Class, QuantityTakeoffCriteria Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class
QuantityTakeoffCriteriaCollection Class
Collapse All

The QuantityTakeoffCriteriaCollection class.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaCollection
C#
public class QuantityTakeoffCriteriaCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class QuantityTakeoffCriteriaCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
QuantityTakeoffCriteriaCollection Methods, QuantityTakeoffCriteriaCollection Members, Class Hierarchy


QuantityTakeoffCriteriaCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class > QuantityTakeoffCriteriaCollection Members
QuantityTakeoffCriteriaCollection Members
Collapse All

The following tables list the members exposed by QuantityTakeoffCriteriaCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


QuantityTakeoffCriteriaCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class > QuantityTakeoffCriteriaCollection Methods
QuantityTakeoffCriteriaCollection Methods
Collapse All

The methods of QuantityTakeoffCriteriaCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


QuantityTakeoffCriteriaCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class > QuantityTakeoffCriteriaCollection Methods > QuantityTakeoffCriteriaCollection::Add Method
QuantityTakeoffCriteriaCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
QuantityTakeoffCriteriaCollection Class, QuantityTakeoffCriteriaCollection Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaData Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class
QuantityTakeoffCriteriaData Class
Collapse All

Defines additional data for material in QuantityTakeoffCriteria.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaData
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbQuantityTakeoffCriteria"))]
public class QuantityTakeoffCriteriaData : CivilWrapper<AeccDbQuantityTakeoffCriteria>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbQuantityTakeoffCriteria"))>
Public Class QuantityTakeoffCriteriaData
Inherits CivilWrapper<AeccDbQuantityTakeoffCriteria>
Links
QuantityTakeoffCriteriaData Properties, QuantityTakeoffCriteriaData Members, Class Hierarchy


QuantityTakeoffCriteriaData Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class > QuantityTakeoffCriteriaData Members
QuantityTakeoffCriteriaData Members
Collapse All

The following tables list the members exposed by QuantityTakeoffCriteriaData.

Public Properties
Public Property | Description
Condition | Gets or sets the material data condition.
ItemType | Gets the material item data type.
Name | Gets the name of material item data.
Links
Public Properties


QuantityTakeoffCriteriaData Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class > QuantityTakeoffCriteriaData Properties
QuantityTakeoffCriteriaData Properties
Collapse All

The properties of QuantityTakeoffCriteriaData are listed here.

Public Properties
Public Property | Description
Condition | Gets or sets the material data condition.
ItemType | Gets the material item data type.
Name | Gets the name of material item data.
Links
Public Properties


QuantityTakeoffCriteriaData::Condition Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class > QuantityTakeoffCriteriaData Properties > QuantityTakeoffCriteriaData::Condition Property
QuantityTakeoffCriteriaData::Condition Property
Collapse All

Gets or sets the material data condition.

C#
public Autodesk::Civil::Roadway::DatabaseServices::MaterialConditionType Condition;
Visual Basic
Public Property Condition() As Autodesk::Civil::Roadway::DatabaseServices::MaterialConditionType
Remarks
  1. MaterialQuantityType::Cut/Fill/CutFill/Structure <==> MaterialConditionType::Above/Below (MaterialItemType::Surface)
  2. MaterialQuantityType::Earthwork <==> MaterialConditionType::Base/Compare (MaterialItemType::Surface)
  3. MaterialQuantityType::Structure <==> MaterialConditionType::Include/Exclude (MaterialItemType::CorridorShape)
Exceptions
Exceptions
Description
System.InvalidOperationException
Thrown when:

  1. Setting the property to MaterialConditionType::Base/Compare/Include/Exclude when the property value of QuantityTakeoffCriteriaItem::QuantityType is not MaterialQuantityType::Earthwork.
  2. Setting the property to MaterialConditionType::Below/Above/Include/Exclude when the property value of QuantityTakeoffCriteriaItem::QuantityType is MaterialQuantityType::Earthwork.
  3. Setting the property to MaterialConditionType::Base/Compare/Below/Above when the property value of QuantityTakeoffCriteriaItem::QuantityType is MaterialQuantityType::Structure and the property:ItemType value is MaterialItemType::CorridorShape.

Links
QuantityTakeoffCriteriaData Class, QuantityTakeoffCriteriaData Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaData::ItemType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class > QuantityTakeoffCriteriaData Properties > QuantityTakeoffCriteriaData::ItemType Property
QuantityTakeoffCriteriaData::ItemType Property
Collapse All

Gets the material item data type.

C#
public Autodesk::Civil::Roadway::DatabaseServices::MaterialItemType ItemType;
Visual Basic
Public Property ItemType() As Autodesk::Civil::Roadway::DatabaseServices::MaterialItemType
Links
QuantityTakeoffCriteriaData Class, QuantityTakeoffCriteriaData Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaData::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class > QuantityTakeoffCriteriaData Properties > QuantityTakeoffCriteriaData::Name Property
QuantityTakeoffCriteriaData::Name Property
Collapse All

Gets the name of material item data.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
QuantityTakeoffCriteriaData Class, QuantityTakeoffCriteriaData Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class
QuantityTakeoffCriteriaItem Class
Collapse All

Defines a material used to create quantity takeoff criteria (QuantityTakeoffCriteria).

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaItem
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbQuantityTakeoffCriteria"))]
public class QuantityTakeoffCriteriaItem : CivilWrapper<AeccDbQuantityTakeoffCriteria>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbQuantityTakeoffCriteria"))>
Public Class QuantityTakeoffCriteriaItem
Inherits CivilWrapper<AeccDbQuantityTakeoffCriteria>
Links
QuantityTakeoffCriteriaItem Methods, QuantityTakeoffCriteriaItem Properties, QuantityTakeoffCriteriaItem Members, Class Hierarchy


QuantityTakeoffCriteriaItem Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Members
QuantityTakeoffCriteriaItem Members
Collapse All

The following tables list the members exposed by QuantityTakeoffCriteriaItem.

Public Methods
Public Method | Description
AddCorridorShape | Adds a new corridor shape data with the default value to the material item.
AddSurface | Remove a surface data from the material item.
RemoveCorridorShape | Remove a corridor shape data from the material item.
RemoveSurface | Adds a new surface data with the default value to the material item.
Public Properties
Public Property | Description
Count | Gets the number of material items' data count.
CutFactor | Gets or sets the expansion or swell of the cut material.
default | Gets the material item's data at the given index.
FillFactor | Gets or sets the contraction or shrinkage of the fill material.
MaterialName | Gets or sets the material name.
QuantityType | Gets or sets the material quantity type.
ReFillFactor | Gets or sets the usability factor used to calculate how much cut material can be reused as fill.
ShapeStyleId | Gets or Sets the object id of the default style used to display the material in a section view.
ShapeStyleName | Gets or Sets the name of the default style used to display the material in a section view.
Links
Public Methods, Public Properties


QuantityTakeoffCriteriaItem Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Methods
QuantityTakeoffCriteriaItem Methods
Collapse All

The methods of QuantityTakeoffCriteriaItem are listed here.

Public Methods
Public Method | Description
AddCorridorShape | Adds a new corridor shape data with the default value to the material item.
AddSurface | Remove a surface data from the material item.
RemoveCorridorShape | Remove a corridor shape data from the material item.
RemoveSurface | Adds a new surface data with the default value to the material item.
Links
Public Methods


QuantityTakeoffCriteriaItem::AddCorridorShape Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Methods > QuantityTakeoffCriteriaItem::AddCorridorShape Method
QuantityTakeoffCriteriaItem::AddCorridorShape Method
Collapse All

Adds a new corridor shape data with the default value to the material item.

C#
public AddCorridorShape(
    ref System::String shapeName
);
Visual Basic
Public Sub AddCorridorShape(
    ByRef shapeName As System::String
)
Parameters
Parameters | Description
shapeName | The name of the corridor shape.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the shape name is duplicated.
System.InvalidOperationException | Thrown when the property:QuantityType value is not NAMESPACE_ROADWAYDB::MaterialQuantityType::Structure.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::AddSurface Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Methods > QuantityTakeoffCriteriaItem::AddSurface Method
QuantityTakeoffCriteriaItem::AddSurface Method
Collapse All

Remove a surface data from the material item.

C#
public AddSurface(
    ref System::String surfaceName
);
Visual Basic
Public Sub AddSurface(
    ByRef surfaceName As System::String
)
Parameters
Parameters | Description
surfaceName | The name of the surface.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the shape name is duplicated.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::RemoveCorridorShape Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Methods > QuantityTakeoffCriteriaItem::RemoveCorridorShape Method
QuantityTakeoffCriteriaItem::RemoveCorridorShape Method
Collapse All

Remove a corridor shape data from the material item.

C#
public RemoveCorridorShape(
    ref System::String shapeName
);
Visual Basic
Public Sub RemoveCorridorShape(
    ByRef shapeName As System::String
)
Parameters
Parameters | Description
shapeName | The name of the corridor shape.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the shape name is invalid.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::RemoveSurface Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Methods > QuantityTakeoffCriteriaItem::RemoveSurface Method
QuantityTakeoffCriteriaItem::RemoveSurface Method
Collapse All

Adds a new surface data with the default value to the material item.

C#
public RemoveSurface(
    ref System::String surfaceName
);
Visual Basic
Public Sub RemoveSurface(
    ByRef surfaceName As System::String
)
Parameters
Parameters | Description
surfaceName | The name of the surface.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the surface name is invalid.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties
QuantityTakeoffCriteriaItem Properties
Collapse All

The properties of QuantityTakeoffCriteriaItem are listed here.

Public Properties
Public Property | Description
Count | Gets the number of material items' data count.
CutFactor | Gets or sets the expansion or swell of the cut material.
default | Gets the material item's data at the given index.
FillFactor | Gets or sets the contraction or shrinkage of the fill material.
MaterialName | Gets or sets the material name.
QuantityType | Gets or sets the material quantity type.
ReFillFactor | Gets or sets the usability factor used to calculate how much cut material can be reused as fill.
ShapeStyleId | Gets or Sets the object id of the default style used to display the material in a section view.
ShapeStyleName | Gets or Sets the name of the default style used to display the material in a section view.
Links
Public Properties


QuantityTakeoffCriteriaItem::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties > QuantityTakeoffCriteriaItem::Count Property
QuantityTakeoffCriteriaItem::Count Property
Collapse All

Gets the number of material items' data count.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::CutFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties > QuantityTakeoffCriteriaItem::CutFactor Property
QuantityTakeoffCriteriaItem::CutFactor Property
Collapse All

Gets or sets the expansion or swell of the cut material.

C#
public double CutFactor;
Visual Basic
Public Property CutFactor() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property:QuantityType value is NAMESPACE_ROADWAYDB::MaterialQuantityType::Fill or Structure.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties > QuantityTakeoffCriteriaItem::default Property
QuantityTakeoffCriteriaItem::default Property
Collapse All

Gets the material item's data at the given index.

C#
public QuantityTakeoffCriteriaData default;
Visual Basic
Public Property default() As QuantityTakeoffCriteriaData
Parameters
Parameters | Description
index | Specified the material item's data by index.
Exceptions
Exceptions | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of the item data collection's range.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::FillFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties > QuantityTakeoffCriteriaItem::FillFactor Property
QuantityTakeoffCriteriaItem::FillFactor Property
Collapse All

Gets or sets the contraction or shrinkage of the fill material.

C#
public double FillFactor;
Visual Basic
Public Property FillFactor() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property:QuantityType value is NAMESPACE_ROADWAYDB::MaterialQuantityType::Cut.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::MaterialName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties > QuantityTakeoffCriteriaItem::MaterialName Property
QuantityTakeoffCriteriaItem::MaterialName Property
Collapse All

Gets or sets the material name.

C#
public System::String MaterialName;
Visual Basic
Public Property MaterialName() As System::String
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::QuantityType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties > QuantityTakeoffCriteriaItem::QuantityType Property
QuantityTakeoffCriteriaItem::QuantityType Property
Collapse All

Gets or sets the material quantity type.

C#
public Autodesk::Civil::Roadway::DatabaseServices::MaterialQuantityType QuantityType;
Visual Basic
Public Property QuantityType() As Autodesk::Civil::Roadway::DatabaseServices::MaterialQuantityType
Remarks

It will delete all the shape item data if we change the QuantityType to a value that is not Structure.

Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::ReFillFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties > QuantityTakeoffCriteriaItem::ReFillFactor Property
QuantityTakeoffCriteriaItem::ReFillFactor Property
Collapse All

Gets or sets the usability factor used to calculate how much cut material can be reused as fill.

C#
public double ReFillFactor;
Visual Basic
Public Property ReFillFactor() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the property:QuantityType value is NAMESPACE_ROADWAYDB::MaterialQuantityType::Fill or Structure.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::ShapeStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties > QuantityTakeoffCriteriaItem::ShapeStyleId Property
QuantityTakeoffCriteriaItem::ShapeStyleId Property
Collapse All

Gets or Sets the object id of the default style used to display the material in a section view.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ShapeStyleId;
Visual Basic
Public Property ShapeStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input style type is not Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


QuantityTakeoffCriteriaItem::ShapeStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties > QuantityTakeoffCriteriaItem::ShapeStyleName Property
QuantityTakeoffCriteriaItem::ShapeStyleName Property
Collapse All

Gets or Sets the name of the default style used to display the material in a section view.

C#
public System::String ShapeStyleName;
Visual Basic
Public Property ShapeStyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the shape style name is invalid.
Links
QuantityTakeoffCriteriaItem Class, QuantityTakeoffCriteriaItem Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class
ShapeStyle Class
Collapse All

Used to control the visual style of a roadway shape (Shape) object.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyle
            Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyle
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayShapeStyle"))]
public class ShapeStyle : SubassemblySubentityStyle;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayShapeStyle"))>
Public Class ShapeStyle
Inherits SubassemblySubentityStyle
Example
// Create a new shape style and change it so that it has
// an orange border and a yellow hatch fill.
objId = doc.Styles.ShapeStyles.Add("Style3");
ShapeStyle oShapeStyle = ts.GetObject(objId, OpenMode.ForWrite) as ShapeStyle;
// 50 = yellow
oShapeStyle.GetDisplayStylePlan(ShapeDisplayStyleType.AreaFill).Color = Color.FromColorIndex(ColorMethod.ByAci, 50);
oShapeStyle.GetDisplayStylePlan(ShapeDisplayStyleType.AreaFill).Visible = true;
//oShapeStyle. GetDisplayStylePlan(ShapeDisplayStyleType.Border). HatchType = HatchType.PreDefined;
// oShapeStyle.AreaFillHatchDisplayStylePlan.Pattern = "LINE";
// 30 = orange
oShapeStyle.GetDisplayStylePlan(ShapeDisplayStyleType.Border).Color = Color.FromColorIndex(ColorMethod.ByAci, 30);
oShapeStyle.GetDisplayStylePlan(ShapeDisplayStyleType.Border).Visible = true;

ts.Commit();
Links
ShapeStyle Methods, ShapeStyle Properties, ShapeStyle Members, Class Hierarchy


ShapeStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Members
ShapeStyle Members
Collapse All

The following tables list the members exposed by ShapeStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties.
GetHatchDisplayStyleModel | Gets the HatchDisplayStyle object that specifies model display properties.
GetHatchDisplayStylePlan | Gets the HatchDisplayStyle object that specifies plan display properties.
GetHatchDisplayStyleProfile | Gets the HatchDisplayStyle object that specifies profile display properties.
GetHatchDisplayStyleSection | Gets the HatchDisplayStyle object that specifies section display properties.
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
AreaFillHatchDisplayStyleModel |
AreaFillHatchDisplayStylePlan |
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
StyleType | Gets the style type.
Links
Public Methods, Public Properties


ShapeStyle Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods
ShapeStyle Methods
Collapse All

The methods of ShapeStyle are listed here.

Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties.
GetHatchDisplayStyleModel | Gets the HatchDisplayStyle object that specifies model display properties.
GetHatchDisplayStylePlan | Gets the HatchDisplayStyle object that specifies plan display properties.
GetHatchDisplayStyleProfile | Gets the HatchDisplayStyle object that specifies profile display properties.
GetHatchDisplayStyleSection | Gets the HatchDisplayStyle object that specifies section display properties.
Links
Public Methods


ShapeStyle::GetDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods > ShapeStyle::GetDisplayStyleModel Method
ShapeStyle::GetDisplayStyleModel Method
Collapse All

Gets the DisplayStyle object that specifies model display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleModel(
    ShapeDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleModel(
    type As ShapeDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle::GetDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods > ShapeStyle::GetDisplayStylePlan Method
ShapeStyle::GetDisplayStylePlan Method
Collapse All

Gets the DisplayStyle object that specifies plan display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStylePlan(
    ShapeDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStylePlan(
    type As ShapeDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle::GetDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods > ShapeStyle::GetDisplayStyleProfile Method
ShapeStyle::GetDisplayStyleProfile Method
Collapse All

Gets the DisplayStyle object that specifies profile display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleProfile(
    ShapeDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleProfile(
    type As ShapeDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle::GetDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods > ShapeStyle::GetDisplayStyleSection Method
ShapeStyle::GetDisplayStyleSection Method
Collapse All

Gets the DisplayStyle object that specifies section display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::DisplayStyle GetDisplayStyleSection(
    ShapeDisplayStyleType type
);
Visual Basic
Public Function GetDisplayStyleSection(
    type As ShapeDisplayStyleType
) As Autodesk::Civil::DatabaseServices::Styles::DisplayStyle
Parameters
Parameters | Description
type | The type of DisplayStyle to get.
Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle::GetHatchDisplayStyleModel Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods > ShapeStyle::GetHatchDisplayStyleModel Method
ShapeStyle::GetHatchDisplayStyleModel Method
Collapse All

Gets the HatchDisplayStyle object that specifies model display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchDisplayStyleModel();
Visual Basic
Public Function GetHatchDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle::GetHatchDisplayStylePlan Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods > ShapeStyle::GetHatchDisplayStylePlan Method
ShapeStyle::GetHatchDisplayStylePlan Method
Collapse All

Gets the HatchDisplayStyle object that specifies plan display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchDisplayStylePlan();
Visual Basic
Public Function GetHatchDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle::GetHatchDisplayStyleProfile Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods > ShapeStyle::GetHatchDisplayStyleProfile Method
ShapeStyle::GetHatchDisplayStyleProfile Method
Collapse All

Gets the HatchDisplayStyle object that specifies profile display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchDisplayStyleProfile();
Visual Basic
Public Function GetHatchDisplayStyleProfile() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle::GetHatchDisplayStyleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods > ShapeStyle::GetHatchDisplayStyleSection Method
ShapeStyle::GetHatchDisplayStyleSection Method
Collapse All

Gets the HatchDisplayStyle object that specifies section display properties.

C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle GetHatchDisplayStyleSection();
Visual Basic
Public Function GetHatchDisplayStyleSection() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Properties
ShapeStyle Properties
Collapse All

The properties of ShapeStyle are listed here.

Public Properties
Public Property | Description
AreaFillHatchDisplayStyleModel |
AreaFillHatchDisplayStylePlan |
StyleType | Gets the style type.
Links
Public Properties


ShapeStyle::AreaFillHatchDisplayStyleModel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Properties > ShapeStyle::AreaFillHatchDisplayStyleModel Property
ShapeStyle::AreaFillHatchDisplayStyleModel Property deprecated
Collapse All
C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle AreaFillHatchDisplayStyleModel;
Visual Basic
Public Property AreaFillHatchDisplayStyleModel() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle.GetAreaFillHatchDisplayStyleModel instead.

Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle::AreaFillHatchDisplayStylePlan Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Properties > ShapeStyle::AreaFillHatchDisplayStylePlan Property
ShapeStyle::AreaFillHatchDisplayStylePlan Property deprecated
Collapse All
C#
public Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle AreaFillHatchDisplayStylePlan;
Visual Basic
Public Property AreaFillHatchDisplayStylePlan() As Autodesk::Civil::DatabaseServices::Styles::HatchDisplayStyle
Notes

Deprecated: Use Autodesk.Civil.Roadway.DatabaseServices.Styles.ShapeStyle.GetAreaFillHatchDisplayStylePlan instead.

Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyle::StyleType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Properties > ShapeStyle::StyleType Property
ShapeStyle::StyleType Property
Collapse All

Gets the style type.

C#
public SubassemblySubentityStyleType StyleType;
Visual Basic
Public Property StyleType() As SubassemblySubentityStyleType
Links
ShapeStyle Class, ShapeStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


ShapeStyleCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class
ShapeStyleCollection Class
Collapse All

A collection of ShapeStyle objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyleCollection
C#
public class ShapeStyleCollection : Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase;
Visual Basic
Public Class ShapeStyleCollection
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
Links
ShapeStyleCollection Methods, ShapeStyleCollection Members, Class Hierarchy


ShapeStyleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class > ShapeStyleCollection Members
ShapeStyleCollection Members
Collapse All

The following tables list the members exposed by ShapeStyleCollection.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
Links
Public Methods, Public Properties


ShapeStyleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class > ShapeStyleCollection Methods
ShapeStyleCollection Methods
Collapse All

The methods of ShapeStyleCollection are listed here.

Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Links
Public Methods


ShapeStyleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class > ShapeStyleCollection Methods > ShapeStyleCollection::Add Method
ShapeStyleCollection::Add Method
Collapse All

Creates a new style object, adds it to the collection, and returns an ObjectId for the object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As Autodesk::AutoCAD::DatabaseServices::ObjectId
Parameters
Parameters | Description
name | The name of the new style. If this string is empty or null, a dynamically generated name is created.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the name already exists.
Links
ShapeStyleCollection Class, ShapeStyleCollection Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


SubassemblySubentityStyle Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class
SubassemblySubentityStyle Class
Collapse All

Base class for LinkStyle and ShapeStyle.

Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyle
            Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyle
            Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyle
C#
public class SubassemblySubentityStyle : Autodesk::Civil::DatabaseServices::Styles::StyleBase;
Visual Basic
Public Class SubassemblySubentityStyle
Inherits Autodesk::Civil::DatabaseServices::Styles::StyleBase
Links
SubassemblySubentityStyle Properties, SubassemblySubentityStyle Members, Class Hierarchy


SubassemblySubentityStyle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class > SubassemblySubentityStyle Members
SubassemblySubentityStyle Members
Collapse All

The following tables list the members exposed by SubassemblySubentityStyle.

Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
StyleType | Gets the style type.
Links
Public Methods, Public Properties


SubassemblySubentityStyle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class > SubassemblySubentityStyle Properties
SubassemblySubentityStyle Properties
Collapse All

The properties of SubassemblySubentityStyle are listed here.

Public Properties
Public Property | Description
StyleType | Gets the style type.
Links
Public Properties


SubassemblySubentityStyle::StyleType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class > SubassemblySubentityStyle Properties > SubassemblySubentityStyle::StyleType Property
SubassemblySubentityStyle::StyleType Property
Collapse All

Gets the style type.

C#
public SubassemblySubentityStyleType StyleType;
Visual Basic
Public Property StyleType() As SubassemblySubentityStyleType
Links
SubassemblySubentityStyle Class, SubassemblySubentityStyle Members, Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace


Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Structs, Records, Enums
Structs, Records, Enums
Collapse All

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
CodeSetStyleItemType | Specifies valid CodeSetStyleItem types.
CorridorDisplayStyleType | The Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorDisplayStyleType enumeration.
ShapeDisplayStyleType | Defines ShapeStyle display style type.
SubassemblySubentityStyleType | The Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyleType enumeration.
Links
Enumerations


Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleItemType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleItemType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleItemType Enumeration
Collapse All

Specifies valid CodeSetStyleItem types.

C#
public enum CodeSetStyleItemType {
  NormalItemType = 0,
  DefaultItemType = 1,
  NoCodeItemType = 2
}
Visual Basic
Public Enum CodeSetStyleItemType
  NormalItemType = 0
  DefaultItemType = 1
  NoCodeItemType = 2
End Enum


Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorDisplayStyleType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorDisplayStyleType Enumeration
Collapse All

The Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorDisplayStyleType enumeration.

C#
public enum CorridorDisplayStyleType {
  RegionBoundaries = AeccDbCorridorStyle::kDispCompCorridorRegion,
  ParameterOverrideStations = AeccDbCorridorStyle::kDispCompCorridorParameterOverrideStation,
  GeometricOverrideStations = AeccDbCorridorStyle::kDispCompCorridorGeometryOverrideStation,
  AssemblyInsertionStations = AeccDbCorridorStyle::kDispCompAssemblyLast
}
Visual Basic
Public Enum CorridorDisplayStyleType
  RegionBoundaries = AeccDbCorridorStyle::kDispCompCorridorRegion
  ParameterOverrideStations = AeccDbCorridorStyle::kDispCompCorridorParameterOverrideStation
  GeometricOverrideStations = AeccDbCorridorStyle::kDispCompCorridorGeometryOverrideStation
  AssemblyInsertionStations = AeccDbCorridorStyle::kDispCompAssemblyLast
End Enum


Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeDisplayStyleType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeDisplayStyleType Enumeration
Collapse All

Defines ShapeStyle display style type.

C#
public enum ShapeDisplayStyleType {
  Border = AeccDbRoadwayShapeStyle::kDispCompRoadwayShapeBorder,
  AreaFill = AeccDbRoadwayShapeStyle::kDispCompRoadwayShapeFill
}
Visual Basic
Public Enum ShapeDisplayStyleType
  Border = AeccDbRoadwayShapeStyle::kDispCompRoadwayShapeBorder
  AreaFill = AeccDbRoadwayShapeStyle::kDispCompRoadwayShapeFill
End Enum


Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyleType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyleType Enumeration
Collapse All

The Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyleType enumeration.

C#
public enum SubassemblySubentityStyleType {
  MarkerType = 0,
  LinkType = 1,
  ShapeType = 2
}
Visual Basic
Public Enum SubassemblySubentityStyleType
  MarkerType = 0
  LinkType = 1
  ShapeType = 2
End Enum


Classes

The following table lists classes in this documentation.

Classes
Class | Description
AppliedAssembly | Represents an AppliedAssembly object. An AppliedAssembly is a cross section of an existing corridor.
AppliedAssemblyCollection | The collection of assembly cross sections placed at intervals along corridor baselines.
AppliedSubassembly | An AppliedSubassemby object. An AppliedSubassembly is a series of points, links, and shapes that make up part of an AppliedAssembly... more
AppliedSubassemblyCollection | Collection of AppliedSubassembly objects.
Assembly | Pattern for the cross section of a corridor. Made up of multiple Subassembly objects.
AssemblyCollection | A collection of Assembly objects.
BaseBaseline | The base class for baselines, such as Baseline, OffsetBaseline, and HardcodedOffsetBaseline.
Baseline | A 3D path defined by an alignment and a profile. A corridor is defined by a baseline (or multiple baselines)... more
BaselineCollection | A collection of Baseline objects.
BaselineFeatureLines | A collection of multiple feature line collections (FeatureLinesCol) associated with a particular baseline or offset baseline.
BaselineFeatureLinesCollection | A collection of multiple feature line collections (BaselineFeatureLines) objects.
BaselineRegion | A segment of a baseline, specified by alignment stations for the start and end point. In a corridor, each baseline... more
BaselineRegionCollection | A collection of baseline region (BaselineRegion) objects.
CalculatedLink | The CalculatedLink class. A CalculatedLink joins two CalculatedPoint objects, and is a component of an AppliedSubassembly object, which in turn... more
CalculatedLinkCollection | A calculated link is a collection of calculated points (CalculatedPoint) which are connected to form a line. Calculated... more
CalculatedPoint | The CalculatedPoint class. A CalculatedPoint is the basic component that defines the stucture of an AppliedSubassembly.
CalculatedPointCollection | A collection of calculated point (CalculatedPoint) objects. Calculated points are used to define applied subassemblies.
CalculatedShape | The CalculatedShape class. A CalculatedShape is defined from links and defines a closed region that represents materials used in a... more
CalculatedShapeCollection | Collection of calculated shape (CalculatedShape) objects.
CalculatedSubentity | Parent class for the CalculatedShape, CalculatedLink and CalculatedPoint interfaces.
CodeCollection | The Corridor code collection class. The wrapped object could be AeccDbRoadwayState or AeccDbSubassembly.
Corridor | Representation of a roadway. Follows a 3D path defined by a baseline, and is made up of cross sections (... more
CorridorCodeCollection | A collection of strings containing corridor codes. A code is used to identify common calculated points in applied assemblies in... more
CorridorCollection | A collection of Corridor objects.
CorridorSection | A section of a Corridor.
CorridorSurface | Represents a layer of a corridor, and is computed from a set of feature lines, calculated points, and calculated links.... more
CorridorSurfaceBaseMask | Base class for CorridorSurfaceMask and CorridorSurfaceBoundary.
CorridorSurfaceBoundary | A corridor surface boundary represents an outside or inside edge of a corridor surface (CorridorSurface). It is defined... more
CorridorSurfaceBoundaryCollection | Collection of corridor surface boundary (CorridorSurfaceBoundary) objects.
CorridorSurfaceCollection | A collection of corridor surface (CorridorSurface) objects.
CorridorSurfaceMask | The corridor surface mask is a region defined by a polygon or a series of feature line components (FeatureLineComponent... more
CorridorSurfaceMaskCollection | Collection of corridor surface mask (CorridorSurfaceMask) objects.
FeatureLine | A feature line is a connected series of points along a corridor created by joining those points from each assembly... more
FeatureLineCodeInfo | Information about the code used to construct a feature line.
FeatureLineCodeInfoCollection | A collection of feature line code information (FeatureLineCodeInfo) objects.
FeatureLineCollection | Collection of feature lines that share a particular code. Multiple points in a single assembly may contain the same code,... more
FeatureLineCollectionMap | A collection of multiple feature line collections (FeatureLineCollection) objects.
FeatureLineComponent | A portion of an entire feature line, delimited by a starting and ending station.
FeatureLineComponentCollection | A collection of feature line component (FeatureLineComponent) objects.
FeatureLinePoint | A point in a feature line (FeatureLine object). A feature line is created by connecting common points within applied... more
FeatureLinePointCollection | A collection of feature line point (FeatureLinePoint) objects.
HardcodedOffsetBaseline | An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between... more
Intersection | An object that manages the intersection of two Alignments. An intersection object builds on and manages various object data, including... more
IntersectionRegion | Corridor regions in an Intersection area.
IntersectionRegionCollection | A collection of IntersectionRegion objects.
IntersectionRoad | Road components managed by an Intersection object.
IntersectionRoadCollection | A collection of IntersectionRoad objecs managed by an Intersection object.
Link | Roadway Link object. Connects roadway points in a subassembly.
LinkCollection | A collection of Link objects.
OffsetBaseline | An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between... more
OffsetBaselineCollection | Collection of offset baseline objects. There are two kinds of offset baselines, OffsetBaseline and HardcodedOffsetBaseline. Both of these are... more
Point | Roadway Point object. Represents a single point within a subassembly.
PointCollection | A collection of Roadway Point objects.
SampledSectionLink | Defines a single line segment of sample surface cross-section data.
SampledSectionLinkCollection | Collection of sampled elevation data.
Shape | Roadway Shape object. Represents a series of roadway links which form a closed shape. Used in subassemblies.
ShapeCollection | A collection of Roadway Shape objects.
SlopeElevationTarget | The SlopeElevation class.
Subassembly | Pattern for part of a corridor cross section, representing a particular portion of a roadway.
SubassemblyCollection | A collection of Subassembly objects.
SubassemblyGenerator | Controls the way Subassembly geometry is generated.
WidthOffsetTarget | The WidthOffsetTarget class.
Links
Classes


AppliedAssembly Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class
AppliedAssembly Class
Collapse All

Represents an AppliedAssembly object. An AppliedAssembly is a cross section of an existing corridor.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AppliedAssembly
C#
public class AppliedAssembly : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class AppliedAssembly
Inherits CivilWrapper<AeccDbCorridor>
Remarks

An applied assembly is an instance of an assembly template attached to a specific station along a corridor.

Links
AppliedAssembly Methods, AppliedAssembly Properties, AppliedAssembly Nested Types, AppliedAssembly Members, Class Hierarchy


AppliedAssembly Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Members
AppliedAssembly Members
Collapse All

The following tables list the members exposed by AppliedAssembly.

Public Methods
Public Method | Description
GetAppliedSubassemblies | Gets the collection of AppliedAssemblies in this AppliedAssembly.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssembly::Identity.
Public Properties
Public Property | Description
AssemblyId | Gets the ID of this AppliedAssembly.
CorridorId | Gets the parent Corridor Id.
Links | Gets the collection of CalculatedLinks in this AppliedAssembly.
LinksByCode | Gets the collection of CalculatedLinks in this AppliedAssembly that have a particular code.
Points | Gets the collection of CalculatedPoints in this AppliedAssembly.
PointsByCode | Gets the collection of CalculatedPoints in this AppliedAssembly that have a particular code.
Shapes | Gets the collection of CalculatedShapes in this AppliedAssembly.
ShapesByCode | Gets the collection of CalculatedShapes in this AppliedAssembly that have a particular code.
Links
Public Methods, Public Nested Types, Public Properties


AppliedAssembly Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Methods
AppliedAssembly Methods
Collapse All

The methods of AppliedAssembly are listed here.

Public Methods
Public Method | Description
GetAppliedSubassemblies | Gets the collection of AppliedAssemblies in this AppliedAssembly.
Links
Public Methods


AppliedAssembly::GetAppliedSubassemblies Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Methods > AppliedAssembly::GetAppliedSubassemblies Method
AppliedAssembly::GetAppliedSubassemblies Method
Collapse All

Gets the collection of AppliedAssemblies in this AppliedAssembly.

C#
public AppliedSubassemblyCollection GetAppliedSubassemblies();
Visual Basic
Public Function GetAppliedSubassemblies() As AppliedSubassemblyCollection
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssembly Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties
AppliedAssembly Properties
Collapse All

The properties of AppliedAssembly are listed here.

Public Properties
Public Property | Description
AssemblyId | Gets the ID of this AppliedAssembly.
CorridorId | Gets the parent Corridor Id.
Links | Gets the collection of CalculatedLinks in this AppliedAssembly.
LinksByCode | Gets the collection of CalculatedLinks in this AppliedAssembly that have a particular code.
Points | Gets the collection of CalculatedPoints in this AppliedAssembly.
PointsByCode | Gets the collection of CalculatedPoints in this AppliedAssembly that have a particular code.
Shapes | Gets the collection of CalculatedShapes in this AppliedAssembly.
ShapesByCode | Gets the collection of CalculatedShapes in this AppliedAssembly that have a particular code.
Links
Public Properties


AppliedAssembly::AssemblyId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties > AppliedAssembly::AssemblyId Property
AppliedAssembly::AssemblyId Property
Collapse All

Gets the ID of this AppliedAssembly.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AssemblyId;
Visual Basic
Public Property AssemblyId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssembly::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties > AppliedAssembly::CorridorId Property
AppliedAssembly::CorridorId Property
Collapse All

Gets the parent Corridor Id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssembly::Links Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties > AppliedAssembly::Links Property
AppliedAssembly::Links Property
Collapse All

Gets the collection of CalculatedLinks in this AppliedAssembly.

C#
public CalculatedLinkCollection Links;
Visual Basic
Public Property Links() As CalculatedLinkCollection
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssembly::LinksByCode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties > AppliedAssembly::LinksByCode Property
AppliedAssembly::LinksByCode Property
Collapse All

Gets the collection of CalculatedLinks in this AppliedAssembly that have a particular code.

C#
public CalculatedLinkCollection LinksByCode;
Visual Basic
Public Property LinksByCode() As CalculatedLinkCollection
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssembly::Points Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties > AppliedAssembly::Points Property
AppliedAssembly::Points Property
Collapse All

Gets the collection of CalculatedPoints in this AppliedAssembly.

C#
public CalculatedPointCollection Points;
Visual Basic
Public Property Points() As CalculatedPointCollection
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssembly::PointsByCode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties > AppliedAssembly::PointsByCode Property
AppliedAssembly::PointsByCode Property
Collapse All

Gets the collection of CalculatedPoints in this AppliedAssembly that have a particular code.

C#
public CalculatedPointCollection PointsByCode;
Visual Basic
Public Property PointsByCode() As CalculatedPointCollection
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssembly::Shapes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties > AppliedAssembly::Shapes Property
AppliedAssembly::Shapes Property
Collapse All

Gets the collection of CalculatedShapes in this AppliedAssembly.

C#
public CalculatedShapeCollection Shapes;
Visual Basic
Public Property Shapes() As CalculatedShapeCollection
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssembly::ShapesByCode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties > AppliedAssembly::ShapesByCode Property
AppliedAssembly::ShapesByCode Property
Collapse All

Gets the collection of CalculatedShapes in this AppliedAssembly that have a particular code.

C#
public CalculatedShapeCollection ShapesByCode;
Visual Basic
Public Property ShapesByCode() As CalculatedShapeCollection
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssembly Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Nested Types
AppliedAssembly Nested Types
Collapse All

The nested types of AppliedAssembly are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssembly::Identity.
Links
Public Nested Types


AppliedAssembly::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Nested Types > AppliedAssembly::Identity Nested Type
AppliedAssembly::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssembly::Identity.

C#
Identity
Visual Basic
Identity
Links
AppliedAssembly Class, AppliedAssembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssemblyCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class
AppliedAssemblyCollection Class
Collapse All

The collection of assembly cross sections placed at intervals along corridor baselines.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AppliedAssemblyCollection
C#
public class AppliedAssemblyCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<AppliedAssembly^>;
Visual Basic
Public Class AppliedAssemblyCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<AppliedAssembly^>
Links
AppliedAssemblyCollection Methods, AppliedAssemblyCollection Properties, AppliedAssemblyCollection Nested Types, AppliedAssemblyCollection Members, Class Hierarchy


AppliedAssemblyCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Members
AppliedAssemblyCollection Members
Collapse All

The following tables list the members exposed by AppliedAssemblyCollection.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetItemAt | Gets the AppliedAssembly object nearest the specified station.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Stations | Gets a list of stations in the collection.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssemblyCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of AppliedAssembly objects in the collection.
default | Gets the default AppliedAssembly object from the collection.
Links
Public Methods, Public Nested Types, Public Properties


AppliedAssemblyCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Methods
AppliedAssemblyCollection Methods
Collapse All

The methods of AppliedAssemblyCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetItemAt | Gets the AppliedAssembly object nearest the specified station.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Stations | Gets a list of stations in the collection.
Links
Public Methods


AppliedAssemblyCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Methods > AppliedAssemblyCollection::GetEnumerator Method
AppliedAssemblyCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<AppliedAssembly^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<AppliedAssembly^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
AppliedAssemblyCollection Class, AppliedAssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssemblyCollection::GetItemAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Methods > AppliedAssemblyCollection::GetItemAt Method
AppliedAssemblyCollection::GetItemAt Method
Collapse All

Gets the AppliedAssembly object nearest the specified station.

C#
public AppliedAssembly GetItemAt(
    double station
);
Visual Basic
Public Function GetItemAt(
    station As double
) As AppliedAssembly
Links
AppliedAssemblyCollection Class, AppliedAssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssemblyCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Methods > AppliedAssemblyCollection::GetObjectEnumerator Method
AppliedAssemblyCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
AppliedAssemblyCollection Class, AppliedAssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssemblyCollection::Stations Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Methods > AppliedAssemblyCollection::Stations Method
AppliedAssemblyCollection::Stations Method
Collapse All

Gets a list of stations in the collection.

C#
public array<double> Stations();
Visual Basic
Public Function Stations() As array<double>
Links
AppliedAssemblyCollection Class, AppliedAssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssemblyCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Properties
AppliedAssemblyCollection Properties
Collapse All

The properties of AppliedAssemblyCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of AppliedAssembly objects in the collection.
default | Gets the default AppliedAssembly object from the collection.
Links
Public Properties


AppliedAssemblyCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Properties > AppliedAssemblyCollection::CorridorId Property
AppliedAssemblyCollection::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AppliedAssemblyCollection Class, AppliedAssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssemblyCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Properties > AppliedAssemblyCollection::Count Property
AppliedAssemblyCollection::Count Property
Collapse All

Gets the number of AppliedAssembly objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
AppliedAssemblyCollection Class, AppliedAssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssemblyCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Properties > AppliedAssemblyCollection::default Property
AppliedAssemblyCollection::default Property
Collapse All

Gets the default AppliedAssembly object from the collection.

C#
public AppliedAssembly default;
Visual Basic
Public Property default() As AppliedAssembly
Links
AppliedAssemblyCollection Class, AppliedAssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedAssemblyCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Nested Types
AppliedAssemblyCollection Nested Types
Collapse All

The nested types of AppliedAssemblyCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssemblyCollection::Identity.
Links
Public Nested Types


AppliedAssemblyCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Nested Types > AppliedAssemblyCollection::Identity Nested Type
AppliedAssemblyCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssemblyCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
AppliedAssemblyCollection Class, AppliedAssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassembly Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class
AppliedSubassembly Class
Collapse All

An AppliedSubassemby object. An AppliedSubassembly is a series of points, links, and shapes that make up part of an AppliedAssembly (corridor cross section).

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassembly
C#
public class AppliedSubassembly : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class AppliedSubassembly
Inherits CivilWrapper<AeccDbCorridor>
Remarks

An AppliedSubassembly is an instance of a subassembly template within a specific applied assembly.

Links
AppliedSubassembly Properties, AppliedSubassembly Nested Types, AppliedSubassembly Members, Class Hierarchy


AppliedSubassembly Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Members
AppliedSubassembly Members
Collapse All

The following tables list the members exposed by AppliedSubassembly.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassembly::Identity.
Public Properties
Public Property | Description
BaselineHookedTo | Gets the hooked Baseline.
CorridorId | Gets the ID of the parent Corridor object.
Links | Gets the collection of CalculatedLinks in this AppliedSubssembly.
OriginStationOffsetElevationToBaseline | Gets the origin SOE coordinate to Baseline.
Points | Gets the collection of CalculatedPoints in this AppliedSubssembly.
Shapes | Gets the collection of CalculatedShapes in this AppliedSubssembly.
SubassemblyId | Gets the ID of this AppliedSubassembly.
Links
Public Nested Types, Public Properties


AppliedSubassembly Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties
AppliedSubassembly Properties
Collapse All

The properties of AppliedSubassembly are listed here.

Public Properties
Public Property | Description
BaselineHookedTo | Gets the hooked Baseline.
CorridorId | Gets the ID of the parent Corridor object.
Links | Gets the collection of CalculatedLinks in this AppliedSubssembly.
OriginStationOffsetElevationToBaseline | Gets the origin SOE coordinate to Baseline.
Points | Gets the collection of CalculatedPoints in this AppliedSubssembly.
Shapes | Gets the collection of CalculatedShapes in this AppliedSubssembly.
SubassemblyId | Gets the ID of this AppliedSubassembly.
Links
Public Properties


AppliedSubassembly::BaselineHookedTo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties > AppliedSubassembly::BaselineHookedTo Property
AppliedSubassembly::BaselineHookedTo Property
Collapse All

Gets the hooked Baseline.

C#
public BaseBaseline BaselineHookedTo;
Visual Basic
Public Property BaselineHookedTo() As BaseBaseline
Links
AppliedSubassembly Class, AppliedSubassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassembly::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties > AppliedSubassembly::CorridorId Property
AppliedSubassembly::CorridorId Property
Collapse All

Gets the ID of the parent Corridor object.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AppliedSubassembly Class, AppliedSubassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassembly::Links Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties > AppliedSubassembly::Links Property
AppliedSubassembly::Links Property
Collapse All

Gets the collection of CalculatedLinks in this AppliedSubssembly.

C#
public CalculatedLinkCollection Links;
Visual Basic
Public Property Links() As CalculatedLinkCollection
Links
AppliedSubassembly Class, AppliedSubassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassembly::OriginStationOffsetElevationToBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties > AppliedSubassembly::OriginStationOffsetElevationToBaseline Property
AppliedSubassembly::OriginStationOffsetElevationToBaseline Property
Collapse All

Gets the origin SOE coordinate to Baseline.

C#
public Autodesk::AutoCAD::Geometry::Point3d OriginStationOffsetElevationToBaseline;
Visual Basic
Public Property OriginStationOffsetElevationToBaseline() As Autodesk::AutoCAD::Geometry::Point3d
Links
AppliedSubassembly Class, AppliedSubassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassembly::Points Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties > AppliedSubassembly::Points Property
AppliedSubassembly::Points Property
Collapse All

Gets the collection of CalculatedPoints in this AppliedSubssembly.

C#
public CalculatedPointCollection Points;
Visual Basic
Public Property Points() As CalculatedPointCollection
Links
AppliedSubassembly Class, AppliedSubassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassembly::Shapes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties > AppliedSubassembly::Shapes Property
AppliedSubassembly::Shapes Property
Collapse All

Gets the collection of CalculatedShapes in this AppliedSubssembly.

C#
public CalculatedShapeCollection Shapes;
Visual Basic
Public Property Shapes() As CalculatedShapeCollection
Links
AppliedSubassembly Class, AppliedSubassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassembly::SubassemblyId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties > AppliedSubassembly::SubassemblyId Property
AppliedSubassembly::SubassemblyId Property
Collapse All

Gets the ID of this AppliedSubassembly.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SubassemblyId;
Visual Basic
Public Property SubassemblyId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
AppliedSubassembly Class, AppliedSubassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassembly Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Nested Types
AppliedSubassembly Nested Types
Collapse All

The nested types of AppliedSubassembly are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassembly::Identity.
Links
Public Nested Types


AppliedSubassembly::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Nested Types > AppliedSubassembly::Identity Nested Type
AppliedSubassembly::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassembly::Identity.

C#
Identity
Visual Basic
Identity
Links
AppliedSubassembly Class, AppliedSubassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassemblyCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class
AppliedSubassemblyCollection Class
Collapse All

Collection of AppliedSubassembly objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassemblyCollection
C#
public class AppliedSubassemblyCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<AppliedSubassembly^>;
Visual Basic
Public Class AppliedSubassemblyCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<AppliedSubassembly^>
Links
AppliedSubassemblyCollection Methods, AppliedSubassemblyCollection Properties, AppliedSubassemblyCollection Nested Types, AppliedSubassemblyCollection Members, Class Hierarchy


AppliedSubassemblyCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Members
AppliedSubassemblyCollection Members
Collapse All

The following tables list the members exposed by AppliedSubassemblyCollection.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
ObjectIds | Gets an array of AppliedSubassemblies' ObjectIds.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassemblyCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of AppliedSubassembly objects in the collection.
default | Gets the defaul AppliedSubassembly object from the collection.
Links
Public Methods, Public Nested Types, Public Properties


AppliedSubassemblyCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Methods
AppliedSubassemblyCollection Methods
Collapse All

The methods of AppliedSubassemblyCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
ObjectIds | Gets an array of AppliedSubassemblies' ObjectIds.
Links
Public Methods


AppliedSubassemblyCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Methods > AppliedSubassemblyCollection::GetEnumerator Method
AppliedSubassemblyCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<AppliedSubassembly^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<AppliedSubassembly^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
AppliedSubassemblyCollection Class, AppliedSubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassemblyCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Methods > AppliedSubassemblyCollection::GetObjectEnumerator Method
AppliedSubassemblyCollection::GetObjectEnumerator Method
Collapse All

Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator interface.

Links
AppliedSubassemblyCollection Class, AppliedSubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassemblyCollection::ObjectIds Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Methods > AppliedSubassemblyCollection::ObjectIds Method
AppliedSubassemblyCollection::ObjectIds Method
Collapse All

Gets an array of AppliedSubassemblies' ObjectIds.

C#
public array<ObjectId> ObjectIds();
Visual Basic
Public Function ObjectIds() As array<ObjectId>
Links
AppliedSubassemblyCollection Class, AppliedSubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassemblyCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Properties
AppliedSubassemblyCollection Properties
Collapse All

The properties of AppliedSubassemblyCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of AppliedSubassembly objects in the collection.
default | Gets the defaul AppliedSubassembly object from the collection.
Links
Public Properties


AppliedSubassemblyCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Properties > AppliedSubassemblyCollection::CorridorId Property
AppliedSubassemblyCollection::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As ObjectId
Links
AppliedSubassemblyCollection Class, AppliedSubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassemblyCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Properties > AppliedSubassemblyCollection::Count Property
AppliedSubassemblyCollection::Count Property
Collapse All

Gets the number of AppliedSubassembly objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
AppliedSubassemblyCollection Class, AppliedSubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassemblyCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Properties > AppliedSubassemblyCollection::default Property
AppliedSubassemblyCollection::default Property
Collapse All

Gets the defaul AppliedSubassembly object from the collection.

C#
public AppliedSubassembly default;
Visual Basic
Public Property default() As AppliedSubassembly
Links
AppliedSubassemblyCollection Class, AppliedSubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AppliedSubassemblyCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Nested Types
AppliedSubassemblyCollection Nested Types
Collapse All

The nested types of AppliedSubassemblyCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassemblyCollection::Identity.
Links
Public Nested Types


AppliedSubassemblyCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Nested Types > AppliedSubassemblyCollection::Identity Nested Type
AppliedSubassemblyCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassemblyCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
AppliedSubassemblyCollection Class, AppliedSubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Assembly Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class
Assembly Class
Collapse All

Pattern for the cross section of a corridor. Made up of multiple Subassembly objects.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Roadway::DatabaseServices::Assembly
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAssembly"))]
public class Assembly : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbAssembly"))>
Public Class Assembly
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Remarks

An assembly is a pattern for the cross section of a corridor at a particular station. An assembly consists of a connected set of subassemblies (Subassembly objects), each of which are linked to a centerpoint or to other subassemblies. When an Assembly is used to define the cross-section of a corridor, a series of applied assemblies (an object of type AppliedAssembly) is added to the corridor. Each applied assembly consists of a collection of applied subassemblies.

Links
Assembly Methods, Assembly Properties, Assembly Members, Class Hierarchy


Assembly Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Members
Assembly Members
Collapse All

The following tables list the members exposed by Assembly.

Public Methods
Public Method | Description
GetOffsetBaselineNames | Gets an array of names of associated offset baselines.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
CodeSetStyleName | Gets or sets the CodeSetStyle by name.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


Assembly Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Methods
Assembly Methods
Collapse All

The methods of Assembly are listed here.

Public Methods
Public Method | Description
GetOffsetBaselineNames | Gets an array of names of associated offset baselines.
Links
Public Methods


Assembly::GetOffsetBaselineNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Methods > Assembly::GetOffsetBaselineNames Method
Assembly::GetOffsetBaselineNames Method
Collapse All

Gets an array of names of associated offset baselines.

C#
public array<System::String^> GetOffsetBaselineNames();
Visual Basic
Public Function GetOffsetBaselineNames() As array<System::String^>
Links
Assembly Class, Assembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Assembly Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Properties
Assembly Properties
Collapse All

The properties of Assembly are listed here.

Public Properties
Public Property | Description
CodeSetStyleName | Gets or sets the CodeSetStyle by name.
Links
Public Properties


Assembly::CodeSetStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Properties > Assembly::CodeSetStyleName Property
Assembly::CodeSetStyleName Property
Collapse All

Gets or sets the CodeSetStyle by name.

C#
public System::String CodeSetStyleName;
Visual Basic
Public Property CodeSetStyleName() As System::String
Links
Assembly Class, Assembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AssemblyCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class
AssemblyCollection Class
Collapse All

A collection of Assembly objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AssemblyCollection
C#
public class AssemblyCollection : CivilWrapper<AcDbDatabase>, System::Collections::Generic::IEnumerable<Autodesk::AutoCAD::DatabaseServices::ObjectId>;
Visual Basic
Public Class AssemblyCollection
Inherits CivilWrapper<AcDbDatabase>
Inherits System::Collections::Generic::IEnumerable<Autodesk::AutoCAD::DatabaseServices::ObjectId>
Links
AssemblyCollection Methods, AssemblyCollection Properties, AssemblyCollection Members, Class Hierarchy


AssemblyCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Members
AssemblyCollection Members
Collapse All

The following tables list the members exposed by AssemblyCollection.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
Public Properties
Public Property | Description
Count | Gets the number of Assembly objects in the collection.
default | Gets an Assembly by name.
Links
Public Methods, Public Properties


AssemblyCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Methods
AssemblyCollection Methods
Collapse All

The methods of AssemblyCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
Links
Public Methods


AssemblyCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Methods > AssemblyCollection::GetEnumerator Method
AssemblyCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<Autodesk::AutoCAD::DatabaseServices::ObjectId> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<Autodesk::AutoCAD::DatabaseServices::ObjectId>
Returns

An enumerator which implements IEnumerator interface.

Links
AssemblyCollection Class, AssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AssemblyCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Methods > AssemblyCollection::GetObjectEnumerator Method
AssemblyCollection::GetObjectEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator<T> interface.

Links
AssemblyCollection Class, AssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AssemblyCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Properties
AssemblyCollection Properties
Collapse All

The properties of AssemblyCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of Assembly objects in the collection.
default | Gets an Assembly by name.
Links
Public Properties


AssemblyCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Properties > AssemblyCollection::Count Property
AssemblyCollection::Count Property
Collapse All

Gets the number of Assembly objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
AssemblyCollection Class, AssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


AssemblyCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Properties > AssemblyCollection::default Property
AssemblyCollection::default Property
Collapse All

Gets an Assembly by name.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId default;
Visual Basic
Public Property default() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
 | System::ArgumentNullException, System::ArgumentException
Links
AssemblyCollection Class, AssemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaseBaseline Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class
BaseBaseline Class
Collapse All

The base class for baselines, such as Baseline, OffsetBaseline, and HardcodedOffsetBaseline.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaseBaseline
    Autodesk::Civil::Roadway::DatabaseServices::Baseline
    Autodesk::Civil::Roadway::DatabaseServices::HardcodedOffsetBaseline
    Autodesk::Civil::Roadway::DatabaseServices::OffsetBaseline
C#
public class BaseBaseline : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class BaseBaseline
Inherits CivilWrapper<AeccDbCorridor>
Remarks

A baseline is a 3D path defined by an alignment and a profile. A corridor is defined by a baseline (or multiple baselines) which serves as an anchor for assemblies.

Links
BaseBaseline Methods, BaseBaseline Properties, BaseBaseline Members, Class Hierarchy


BaseBaseline Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Members
BaseBaseline Members
Collapse All

The following tables list the members exposed by BaseBaseline.

Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
StartStation | Gets the starting station for this baseline.
Links
Public Methods, Public Properties


BaseBaseline Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Methods
BaseBaseline Methods
Collapse All

The methods of BaseBaseline are listed here.

Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.
Links
Public Methods


BaseBaseline::SortedStations Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Methods > BaseBaseline::SortedStations Method
BaseBaseline::SortedStations Method
Collapse All

Gets the sorted stations for the baseline.

C#
public array<double> SortedStations();
Visual Basic
Public Function SortedStations() As array<double>
Links
BaseBaseline Class, BaseBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaseBaseline::StationOffsetElevationToXYZ Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Methods > BaseBaseline::StationOffsetElevationToXYZ Method
BaseBaseline::StationOffsetElevationToXYZ Method
Collapse All

Transforms an SOE coordinate to an xyz world coordinate.

C#
public Autodesk::AutoCAD::Geometry::Point3d StationOffsetElevationToXYZ(
    Autodesk::AutoCAD::Geometry::Point3d% soe
);
Visual Basic
Public Function StationOffsetElevationToXYZ(
    soe As Autodesk::AutoCAD::Geometry::Point3d%
) As Autodesk::AutoCAD::Geometry::Point3d
Links
BaseBaseline Class, BaseBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaseBaseline Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties
BaseBaseline Properties
Collapse All

The properties of BaseBaseline are listed here.

Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
StartStation | Gets the starting station for this baseline.
Links
Public Properties


BaseBaseline::AlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties > BaseBaseline::AlignmentId Property
BaseBaseline::AlignmentId Property
Collapse All

Gets the ID of the Alignment this baseline is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AlignmentId;
Visual Basic
Public Property AlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaseBaseline Class, BaseBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaseBaseline::BaselineType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties > BaseBaseline::BaselineType Property
BaseBaseline::BaselineType Property
Collapse All

Gets the baseline type.

C#
public CorridorBaselineType BaselineType;
Visual Basic
Public Property BaselineType() As CorridorBaselineType
Links
BaseBaseline Class, BaseBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaseBaseline::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties > BaseBaseline::CorridorId Property
BaseBaseline::CorridorId Property
Collapse All

Gets the ID of the Corridor this baseline is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaseBaseline Class, BaseBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaseBaseline::DirectionAtStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties > BaseBaseline::DirectionAtStation Property
BaseBaseline::DirectionAtStation Property
Collapse All

Gets the direction at a station of the baseline.

C#
public Autodesk::AutoCAD::Geometry::Vector3d DirectionAtStation;
Visual Basic
Public Property DirectionAtStation() As Autodesk::AutoCAD::Geometry::Vector3d
Links
BaseBaseline Class, BaseBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaseBaseline::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties > BaseBaseline::EndStation Property
BaseBaseline::EndStation Property
Collapse All

Gets the end station for this baseline.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
BaseBaseline Class, BaseBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaseBaseline::ProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties > BaseBaseline::ProfileId Property
BaseBaseline::ProfileId Property
Collapse All

Gets the ID of the Profile this baseline is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileId;
Visual Basic
Public Property ProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaseBaseline Class, BaseBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaseBaseline::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties > BaseBaseline::StartStation Property
BaseBaseline::StartStation Property
Collapse All

Gets the starting station for this baseline.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
BaseBaseline Class, BaseBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class
Baseline Class
Collapse All

A 3D path defined by an alignment and a profile. A corridor is defined by a baseline (or multiple baselines) which serves as an anchor for assemblies.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaseBaseline
    Autodesk::Civil::Roadway::DatabaseServices::Baseline
C#
public class Baseline : BaseBaseline;
Visual Basic
Public Class Baseline
Inherits BaseBaseline
Links
Baseline Methods, Baseline Properties, Baseline Nested Types, Baseline Members, Class Hierarchy


Baseline Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Members
Baseline Members
Collapse All

The following tables list the members exposed by Baseline.

Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::Baseline::Identity.
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
AppliedAssembly | Gets the AppliedAssembly by station.
BaselineRegions | Gets the collection of BaselineRegion objects in this Baseline.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
IsProcessed | Gets whether this Baseline is built during corridor rebuild.
MainBaselineFeatureLines | Gets the main baseline FeatureLine collection.
OffsetBaselineFeatureLinesCol | Gets the offset baseline FeatureLine collection.
ProfileId | Gets the ID of the Profile this baseline is associated with.
StartStation | Gets the starting station for this baseline.
Links
Public Methods, Public Nested Types, Public Properties


Baseline Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Methods
Baseline Methods
Collapse All

The methods of Baseline are listed here.

Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
Links
Public Methods


Baseline::SortedStations Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Methods > Baseline::SortedStations Method
Baseline::SortedStations Method
Collapse All

Gets the sorted stations for the baseline.

C#
public array<double> SortedStations();
Visual Basic
Public Function SortedStations() As array<double>
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties
Baseline Properties
Collapse All

The properties of Baseline are listed here.

Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
AppliedAssembly | Gets the AppliedAssembly by station.
BaselineRegions | Gets the collection of BaselineRegion objects in this Baseline.
BaselineType | Gets the baseline type.
EndStation | Gets the end station for this baseline.
IsProcessed | Gets whether this Baseline is built during corridor rebuild.
MainBaselineFeatureLines | Gets the main baseline FeatureLine collection.
OffsetBaselineFeatureLinesCol | Gets the offset baseline FeatureLine collection.
ProfileId | Gets the ID of the Profile this baseline is associated with.
StartStation | Gets the starting station for this baseline.
Links
Public Properties


Baseline::AlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::AlignmentId Property
Baseline::AlignmentId Property
Collapse All

Gets the ID of the Alignment this baseline is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AlignmentId;
Visual Basic
Public Property AlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline::AppliedAssembly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::AppliedAssembly Property
Baseline::AppliedAssembly Property
Collapse All

Gets the AppliedAssembly by station.

C#
public Autodesk::Civil::Roadway::DatabaseServices::AppliedAssembly AppliedAssembly;
Visual Basic
Public Property AppliedAssembly() As Autodesk::Civil::Roadway::DatabaseServices::AppliedAssembly
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline::BaselineRegions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::BaselineRegions Property
Baseline::BaselineRegions Property
Collapse All

Gets the collection of BaselineRegion objects in this Baseline.

C#
public BaselineRegionCollection BaselineRegions;
Visual Basic
Public Property BaselineRegions() As BaselineRegionCollection
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline::BaselineType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::BaselineType Property
Baseline::BaselineType Property
Collapse All

Gets the baseline type.

C#
public CorridorBaselineType BaselineType;
Visual Basic
Public Property BaselineType() As CorridorBaselineType
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::EndStation Property
Baseline::EndStation Property
Collapse All

Gets the end station for this baseline.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline::IsProcessed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::IsProcessed Property
Baseline::IsProcessed Property
Collapse All

Gets whether this Baseline is built during corridor rebuild.

C#
public bool IsProcessed;
Visual Basic
Public Property IsProcessed() As bool
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline::MainBaselineFeatureLines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::MainBaselineFeatureLines Property
Baseline::MainBaselineFeatureLines Property
Collapse All

Gets the main baseline FeatureLine collection.

C#
public BaselineFeatureLines MainBaselineFeatureLines;
Visual Basic
Public Property MainBaselineFeatureLines() As BaselineFeatureLines
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline::OffsetBaselineFeatureLinesCol Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::OffsetBaselineFeatureLinesCol Property
Baseline::OffsetBaselineFeatureLinesCol Property
Collapse All

Gets the offset baseline FeatureLine collection.

C#
public BaselineFeatureLinesCollection OffsetBaselineFeatureLinesCol;
Visual Basic
Public Property OffsetBaselineFeatureLinesCol() As BaselineFeatureLinesCollection
Example
// Get all the offset feature lines:
foreach (BaselineFeatureLines oBaselineFeaturelines in oBaseline.OffsetBaselineFeatureLinesCol)
{
   foreach (FeatureLineCollection oFeatureLineCollection in oBaselineFeaturelines.FeatureLineCollectionMap)
   {
       ed.WriteMessage("Feature Line Collectionn# Lines in collection: {0}n",
       oFeatureLineCollection.Count);
       foreach (Autodesk.Civil.Roadway.DatabaseServices.FeatureLine oFeatureLine in oFeatureLineCollection)
       {
           ed.WriteMessage("Feature line code: {0}n", oFeatureLine.CodeName);
           // print out all point locations on the feature line
           foreach (FeatureLinePoint oFeatureLinePoint in oFeatureLine.FeatureLinePoints)
           {
               ed.WriteMessage("Point: {0},{1},{2}n",
                   oFeatureLinePoint.XYZ.X,
                   oFeatureLinePoint.XYZ.Y,
                   oFeatureLinePoint.XYZ.Z);
           }

       }

   }
}
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline::ProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::ProfileId Property
Baseline::ProfileId Property
Collapse All

Gets the ID of the Profile this baseline is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileId;
Visual Basic
Public Property ProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties > Baseline::StartStation Property
Baseline::StartStation Property
Collapse All

Gets the starting station for this baseline.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Baseline Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Nested Types
Baseline Nested Types
Collapse All

The nested types of Baseline are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::Baseline::Identity.
Links
Public Nested Types


Baseline::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Nested Types > Baseline::Identity Nested Type
Baseline::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::Baseline::Identity.

C#
Identity
Visual Basic
Identity
Links
Baseline Class, Baseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class
BaselineCollection Class
Collapse All

A collection of Baseline objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineCollection
C#
public class BaselineCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<Baseline^>;
Visual Basic
Public Class BaselineCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<Baseline^>
Links
BaselineCollection Methods, BaselineCollection Properties, BaselineCollection Members, Class Hierarchy


BaselineCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Members
BaselineCollection Members
Collapse All

The following tables list the members exposed by BaselineCollection.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of Baseline objects in the collection.
default | Gets a Baseline by index.
Links
Public Methods, Public Properties


BaselineCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Methods
BaselineCollection Methods
Collapse All

The methods of BaselineCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
Links
Public Methods


BaselineCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Methods > BaselineCollection::GetEnumerator Method
BaselineCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<Baseline^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<Baseline^>
Returns

An enumerator which implements IEnumerator interface.

Links
BaselineCollection Class, BaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Methods > BaselineCollection::GetObjectEnumerator Method
BaselineCollection::GetObjectEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator<T> interface.

Links
BaselineCollection Class, BaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Properties
BaselineCollection Properties
Collapse All

The properties of BaselineCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of Baseline objects in the collection.
default | Gets a Baseline by index.
Links
Public Properties


BaselineCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Properties > BaselineCollection::CorridorId Property
BaselineCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaselineCollection Class, BaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Properties > BaselineCollection::Count Property
BaselineCollection::Count Property
Collapse All

Gets the number of Baseline objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
BaselineCollection Class, BaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Properties > BaselineCollection::default Property
BaselineCollection::default Property
Collapse All

Gets a Baseline by index.

C#
public Baseline default;
Visual Basic
Public Property default() As Baseline
Links
BaselineCollection Class, BaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLines Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class
BaselineFeatureLines Class
Collapse All

A collection of multiple feature line collections (FeatureLinesCol) associated with a particular baseline or offset baseline.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLines
C#
public class BaselineFeatureLines : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class BaselineFeatureLines
Inherits CivilWrapper<AeccDbCorridor>
Links
BaselineFeatureLines Methods, BaselineFeatureLines Properties, BaselineFeatureLines Nested Types, BaselineFeatureLines Members, Class Hierarchy


BaselineFeatureLines Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Members
BaselineFeatureLines Members
Collapse All

The following tables list the members exposed by BaselineFeatureLines.

Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLines::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
FeatureLineCollectionMap | Gets the collection of feature lines (FeatureLinesCollection).
HardcodedOffsetBaselineName | Gets the hardcoded offset baseline name.
IsMainBaseline | Returns True if this is a main baseline.
OffsetAlignmentId | Gets the ObjectId for the offset alignment.
Links
Public Methods, Public Nested Types, Public Properties


BaselineFeatureLines Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Methods
BaselineFeatureLines Methods
Collapse All

The methods of BaselineFeatureLines are listed here.

Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
Links
Public Methods


BaselineFeatureLines::CodeNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Methods > BaselineFeatureLines::CodeNames Method
BaselineFeatureLines::CodeNames Method
Collapse All

Gets a list of code names in the collection.

C#
public array<System::String^> CodeNames();
Visual Basic
Public Function CodeNames() As array<System::String^>
Links
BaselineFeatureLines Class, BaselineFeatureLines Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLines Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Properties
BaselineFeatureLines Properties
Collapse All

The properties of BaselineFeatureLines are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
FeatureLineCollectionMap | Gets the collection of feature lines (FeatureLinesCollection).
HardcodedOffsetBaselineName | Gets the hardcoded offset baseline name.
IsMainBaseline | Returns True if this is a main baseline.
OffsetAlignmentId | Gets the ObjectId for the offset alignment.
Links
Public Properties


BaselineFeatureLines::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Properties > BaselineFeatureLines::CorridorId Property
BaselineFeatureLines::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaselineFeatureLines Class, BaselineFeatureLines Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLines::FeatureLineCollectionMap Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Properties > BaselineFeatureLines::FeatureLineCollectionMap Property
BaselineFeatureLines::FeatureLineCollectionMap Property
Collapse All

Gets the collection of feature lines (FeatureLinesCollection).

C#
public Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollectionMap FeatureLineCollectionMap;
Visual Basic
Public Property FeatureLineCollectionMap() As Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollectionMap
Links
BaselineFeatureLines Class, BaselineFeatureLines Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLines::HardcodedOffsetBaselineName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Properties > BaselineFeatureLines::HardcodedOffsetBaselineName Property
BaselineFeatureLines::HardcodedOffsetBaselineName Property
Collapse All

Gets the hardcoded offset baseline name.

C#
public System::String HardcodedOffsetBaselineName;
Visual Basic
Public Property HardcodedOffsetBaselineName() As System::String
Links
BaselineFeatureLines Class, BaselineFeatureLines Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLines::IsMainBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Properties > BaselineFeatureLines::IsMainBaseline Property
BaselineFeatureLines::IsMainBaseline Property
Collapse All

Returns True if this is a main baseline.

C#
public bool IsMainBaseline;
Visual Basic
Public Property IsMainBaseline() As bool
Links
BaselineFeatureLines Class, BaselineFeatureLines Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLines::OffsetAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Properties > BaselineFeatureLines::OffsetAlignmentId Property
BaselineFeatureLines::OffsetAlignmentId Property
Collapse All

Gets the ObjectId for the offset alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId OffsetAlignmentId;
Visual Basic
Public Property OffsetAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaselineFeatureLines Class, BaselineFeatureLines Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLines Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Nested Types
BaselineFeatureLines Nested Types
Collapse All

The nested types of BaselineFeatureLines are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLines::Identity.
Links
Public Nested Types


BaselineFeatureLines::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Nested Types > BaselineFeatureLines::Identity Nested Type
BaselineFeatureLines::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLines::Identity.

C#
Identity
Visual Basic
Identity
Links
BaselineFeatureLines Class, BaselineFeatureLines Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLinesCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class
BaselineFeatureLinesCollection Class
Collapse All

A collection of multiple feature line collections (BaselineFeatureLines) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLinesCollection
C#
public class BaselineFeatureLinesCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<BaselineFeatureLines^>;
Visual Basic
Public Class BaselineFeatureLinesCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<BaselineFeatureLines^>
Links
BaselineFeatureLinesCollection Methods, BaselineFeatureLinesCollection Properties, BaselineFeatureLinesCollection Nested Types, BaselineFeatureLinesCollection Members, Class Hierarchy


BaselineFeatureLinesCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Members
BaselineFeatureLinesCollection Members
Collapse All

The following tables list the members exposed by BaselineFeatureLinesCollection.

Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLinesCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of BaselineFeatureLines objects in the collection.
default | Gets a BaselineFeatureLines object by index.
Links
Public Methods, Public Nested Types, Public Properties


BaselineFeatureLinesCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Methods
BaselineFeatureLinesCollection Methods
Collapse All

The methods of BaselineFeatureLinesCollection are listed here.

Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Links
Public Methods


BaselineFeatureLinesCollection::CodeNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Methods > BaselineFeatureLinesCollection::CodeNames Method
BaselineFeatureLinesCollection::CodeNames Method
Collapse All

Gets a list of code names in the collection.

C#
public array<System::String^> CodeNames();
Visual Basic
Public Function CodeNames() As array<System::String^>
Links
BaselineFeatureLinesCollection Class, BaselineFeatureLinesCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLinesCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Methods > BaselineFeatureLinesCollection::GetEnumerator Method
BaselineFeatureLinesCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<BaselineFeatureLines^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<BaselineFeatureLines^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
BaselineFeatureLinesCollection Class, BaselineFeatureLinesCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLinesCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Methods > BaselineFeatureLinesCollection::GetObjectEnumerator Method
BaselineFeatureLinesCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
BaselineFeatureLinesCollection Class, BaselineFeatureLinesCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLinesCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Properties
BaselineFeatureLinesCollection Properties
Collapse All

The properties of BaselineFeatureLinesCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of BaselineFeatureLines objects in the collection.
default | Gets a BaselineFeatureLines object by index.
Links
Public Properties


BaselineFeatureLinesCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Properties > BaselineFeatureLinesCollection::CorridorId Property
BaselineFeatureLinesCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaselineFeatureLinesCollection Class, BaselineFeatureLinesCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLinesCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Properties > BaselineFeatureLinesCollection::Count Property
BaselineFeatureLinesCollection::Count Property
Collapse All

Gets the number of BaselineFeatureLines objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
BaselineFeatureLinesCollection Class, BaselineFeatureLinesCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLinesCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Properties > BaselineFeatureLinesCollection::default Property
BaselineFeatureLinesCollection::default Property
Collapse All

Gets a BaselineFeatureLines object by index.

C#
public BaselineFeatureLines default;
Visual Basic
Public Property default() As BaselineFeatureLines
Links
BaselineFeatureLinesCollection Class, BaselineFeatureLinesCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineFeatureLinesCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Nested Types
BaselineFeatureLinesCollection Nested Types
Collapse All

The nested types of BaselineFeatureLinesCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLinesCollection::Identity.
Links
Public Nested Types


BaselineFeatureLinesCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Nested Types > BaselineFeatureLinesCollection::Identity Nested Type
BaselineFeatureLinesCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLinesCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
BaselineFeatureLinesCollection Class, BaselineFeatureLinesCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class
BaselineRegion Class
Collapse All

A segment of a baseline, specified by alignment stations for the start and end point. In a corridor, each baseline region uses a single assembly type.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineRegion
C#
public class BaselineRegion : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class BaselineRegion
Inherits CivilWrapper<AeccDbCorridor>
Links
BaselineRegion Methods, BaselineRegion Properties, BaselineRegion Nested Types, BaselineRegion Members, Class Hierarchy


BaselineRegion Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Members
BaselineRegion Members
Collapse All

The following tables list the members exposed by BaselineRegion.

Public Methods
Public Method | Description
AddStation | Adds a station to the BaselineRegion.
DeleteStation | Removes a station from the BaselineRegion.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegion::Identity.
Public Properties
Public Property | Description
AppliedAssemblies | Gets the collection of AppliedAssembly objects associated with this BaselineRegion.
AssemblyId | Gets the ObjectId of the Assembly associated with this BaselineRegion.
CorridorId | Gets the ObjectId of the Corridor this BaselineRegion is associated with.
EndStation | Gets the number of the end station for this BaselineRegion.
IsProcessed | Gets whether this BaselineRegion is processed.
OffsetBaselines | Gets the collection of OffsetBaseline objects associated with this BaselineRegion.
StartStation | Gets the number of the start station for this BaselineRegion.
Links
Public Methods, Public Nested Types, Public Properties


BaselineRegion Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Methods
BaselineRegion Methods
Collapse All

The methods of BaselineRegion are listed here.

Public Methods
Public Method | Description
AddStation | Adds a station to the BaselineRegion.
DeleteStation | Removes a station from the BaselineRegion.
Links
Public Methods


BaselineRegion::AddStation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Methods > BaselineRegion::AddStation Method
BaselineRegion::AddStation Method
Collapse All

Adds a station to the BaselineRegion.

C#
public AddStation(
    double rawStation,
    ref System::String description
);
Visual Basic
Public Sub AddStation(
    rawStation As double,
    ByRef description As System::String
)
Parameters
Parameters | Description
rawStation | The station number to add.
description | A description of the station.
Exceptions
Exceptions | Description
 | System::ArgumentOutOfRangeException
Example
// Add an assembly to the middle of the baseline region
double newStation = oBaselineRegion.StartStation +
   ((oBaselineRegion.EndStation - oBaselineRegion.StartStation) / 2);
oBaselineRegion.AddStation(newStation, "New Station");
ed.WriteMessage("Added New Station: {0}", newStation);
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion::DeleteStation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Methods > BaselineRegion::DeleteStation Method
BaselineRegion::DeleteStation Method
Collapse All

Removes a station from the BaselineRegion.

C#
public DeleteStation(
    double rawStation
);
Visual Basic
Public Sub DeleteStation(
    rawStation As double
)
Parameters
Parameters | Description
rawStation | The station number to remove.
Exceptions
Exceptions | Description
 | System::ArgumentOutOfRangeException, System::ArgumentOutOfRangeException
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties
BaselineRegion Properties
Collapse All

The properties of BaselineRegion are listed here.

Public Properties
Public Property | Description
AppliedAssemblies | Gets the collection of AppliedAssembly objects associated with this BaselineRegion.
AssemblyId | Gets the ObjectId of the Assembly associated with this BaselineRegion.
CorridorId | Gets the ObjectId of the Corridor this BaselineRegion is associated with.
EndStation | Gets the number of the end station for this BaselineRegion.
IsProcessed | Gets whether this BaselineRegion is processed.
OffsetBaselines | Gets the collection of OffsetBaseline objects associated with this BaselineRegion.
StartStation | Gets the number of the start station for this BaselineRegion.
Links
Public Properties


BaselineRegion::AppliedAssemblies Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties > BaselineRegion::AppliedAssemblies Property
BaselineRegion::AppliedAssemblies Property
Collapse All

Gets the collection of AppliedAssembly objects associated with this BaselineRegion.

C#
public AppliedAssemblyCollection AppliedAssemblies;
Visual Basic
Public Property AppliedAssemblies() As AppliedAssemblyCollection
Example
// List the applied assemblies in the baseline region
foreach (AppliedAssembly oAppliedAssembly in oBaselineRegion.AppliedAssemblies)
{
   ed.WriteMessage("Applied Assembly, num shapes: {0}, num links: {1}, num points: {2}n",
       oAppliedAssembly.Shapes.Count, oAppliedAssembly.Links.Count, oAppliedAssembly.Points.Count);

   // Iterate through each subassembly and print out some information
   AppliedSubassemblyCollection oASC = oAppliedAssembly.GetAppliedSubassemblies();
   foreach (AppliedSubassembly oAppliedSubassembly in oASC)
   {
       ed.WriteMessage("Applied subassembly: Station to baseline: {0}, Offset to baseline: {1}, Elevation to baseline: {2}n",
           oAppliedSubassembly.OriginStationOffsetElevationToBaseline.X,
           oAppliedSubassembly.OriginStationOffsetElevationToBaseline.Y,
           oAppliedSubassembly.OriginStationOffsetElevationToBaseline.Z);

       // Get information about the subassembly template:
       ObjectId oID = oAppliedSubassembly.SubassemblyId;
       Subassembly oSubassembly = ts.GetObject(oID, OpenMode.ForRead) as Subassembly;
       ed.WriteMessage("Subassembly name: {0}n", oSubassembly.Name);

   }

}
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion::AssemblyId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties > BaselineRegion::AssemblyId Property
BaselineRegion::AssemblyId Property
Collapse All

Gets the ObjectId of the Assembly associated with this BaselineRegion.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AssemblyId;
Visual Basic
Public Property AssemblyId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties > BaselineRegion::CorridorId Property
BaselineRegion::CorridorId Property
Collapse All

Gets the ObjectId of the Corridor this BaselineRegion is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties > BaselineRegion::EndStation Property
BaselineRegion::EndStation Property
Collapse All

Gets the number of the end station for this BaselineRegion.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion::IsProcessed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties > BaselineRegion::IsProcessed Property
BaselineRegion::IsProcessed Property
Collapse All

Gets whether this BaselineRegion is processed.

C#
public bool IsProcessed;
Visual Basic
Public Property IsProcessed() As bool
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion::OffsetBaselines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties > BaselineRegion::OffsetBaselines Property
BaselineRegion::OffsetBaselines Property
Collapse All

Gets the collection of OffsetBaseline objects associated with this BaselineRegion.

C#
public OffsetBaselineCollection OffsetBaselines;
Visual Basic
Public Property OffsetBaselines() As OffsetBaselineCollection
Example
foreach (BaseBaseline ob in oBaselineRegion.OffsetBaselines)
{
   ed.WriteMessage("Offset baseline: n");
   switch (ob.BaselineType)
   {
       case CorridorBaselineType.OffsetBaseline:
           OffsetBaseline offb = (OffsetBaseline)ob;
           ed.WriteMessage("Offset baseline, station {0} to {1}n",
               offb.StartStationOnMainBaseline, offb.EndStationOnMainBaseline);
           ed.WriteMessage(" is offset by: {0} horizontal and {1} vertical at startn",
               offb.GetOffsetElevationFromMainBaselineStation(offb.StartStationOnMainBaseline).X,
               offb.GetOffsetElevationFromMainBaselineStation(offb.StartStationOnMainBaseline).Y);
           ed.WriteMessage(" is offset by: {0} horizontal and {1} vertical at endn",
               offb.GetOffsetElevationFromMainBaselineStation(offb.EndStationOnMainBaseline).X,
               offb.GetOffsetElevationFromMainBaselineStation(offb.EndStationOnMainBaseline).Y);
           break;

       case CorridorBaselineType.HardcodedOffsetBaseline:
           HardcodedOffsetBaseline hob = (HardcodedOffsetBaseline)ob;
           ed.WriteMessage("Hardcoded offset baseline {0} n",
               hob.Name);
           ed.WriteMessage(" is offset by: {0} horizontal and {1} verticaln",
               hob.OffsetElevationFromMainBaseline.X,
               hob.OffsetElevationFromMainBaseline.Y);
           break;

       default:
           break;
   }
}
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties > BaselineRegion::StartStation Property
BaselineRegion::StartStation Property
Collapse All

Gets the number of the start station for this BaselineRegion.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegion Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Nested Types
BaselineRegion Nested Types
Collapse All

The nested types of BaselineRegion are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegion::Identity.
Links
Public Nested Types


BaselineRegion::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Nested Types > BaselineRegion::Identity Nested Type
BaselineRegion::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegion::Identity.

C#
Identity
Visual Basic
Identity
Links
BaselineRegion Class, BaselineRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegionCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class
BaselineRegionCollection Class
Collapse All

A collection of baseline region (BaselineRegion) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineRegionCollection
C#
public class BaselineRegionCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<BaselineRegion^>;
Visual Basic
Public Class BaselineRegionCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<BaselineRegion^>
Links
BaselineRegionCollection Methods, BaselineRegionCollection Properties, BaselineRegionCollection Nested Types, BaselineRegionCollection Members, Class Hierarchy


BaselineRegionCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Members
BaselineRegionCollection Members
Collapse All

The following tables list the members exposed by BaselineRegionCollection.

Public Methods
Public Method | Description
AddRegion | Overloaded
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegionCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLines BaselineRegion in the collection.
default | Gets a BaselineRegion object by index.
Links
Public Methods, Public Nested Types, Public Properties


BaselineRegionCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Methods
BaselineRegionCollection Methods
Collapse All

The methods of BaselineRegionCollection are listed here.

Public Methods
Public Method | Description
AddRegion | Overloaded
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Links
Public Methods


AddRegion Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Methods > AddRegion Method
AddRegion Method
Collapse All

Overloaded

Overload List
Method | Description
BaselineRegionCollection::AddRegion (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId) | Creates an Region with the given region name and the assembly object id.
BaselineRegionCollection::AddRegion (System::String^, System::String^) | Creates an Region with the given name.


BaselineRegionCollection::AddRegion Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Methods > AddRegion Method > BaselineRegionCollection::AddRegion Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
BaselineRegionCollection::AddRegion Method (System::String^, Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Creates an Region with the given region name and the assembly object id.

C#
public AddRegion(
    ref System::String regionName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId assemblyId
);
Visual Basic
Public Sub AddRegion(
    ByRef regionName As System::String,
    assemblyId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
regionName | Name of the created region.
assemblyId | Object id of the assembly used to create the region.
Remarks

OBJECTID TYPE: Autodesk.Civil.Roadway.DatabaseServices.Assembly

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the assembly id is invalid.
Links
BaselineRegionCollection Class, BaselineRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegionCollection::AddRegion Method (System::String^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Methods > AddRegion Method > BaselineRegionCollection::AddRegion Method (System::String^, System::String^)
BaselineRegionCollection::AddRegion Method (System::String^, System::String^)
Collapse All

Creates an Region with the given name.

C#
public AddRegion(
    ref System::String regionName,
    ref System::String assemblyName
);
Visual Basic
Public Sub AddRegion(
    ByRef regionName As System::String,
    ByRef assemblyName As System::String
)
Parameters
Parameters | Description
regionName | Name of the created region.
assemblyName | Name of the assembly used to create the region.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the region name or assebly name is invalid.
Links
BaselineRegionCollection Class, BaselineRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegionCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Methods > BaselineRegionCollection::GetEnumerator Method
BaselineRegionCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<BaselineRegion^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<BaselineRegion^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
BaselineRegionCollection Class, BaselineRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegionCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Methods > BaselineRegionCollection::GetObjectEnumerator Method
BaselineRegionCollection::GetObjectEnumerator Method
Collapse All

Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator interface.

Links
BaselineRegionCollection Class, BaselineRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegionCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Properties
BaselineRegionCollection Properties
Collapse All

The properties of BaselineRegionCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLines BaselineRegion in the collection.
default | Gets a BaselineRegion object by index.
Links
Public Properties


BaselineRegionCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Properties > BaselineRegionCollection::CorridorId Property
BaselineRegionCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
BaselineRegionCollection Class, BaselineRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegionCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Properties > BaselineRegionCollection::Count Property
BaselineRegionCollection::Count Property
Collapse All

Gets the number of FeatureLines BaselineRegion in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
BaselineRegionCollection Class, BaselineRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegionCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Properties > BaselineRegionCollection::default Property
BaselineRegionCollection::default Property
Collapse All

Gets a BaselineRegion object by index.

C#
public BaselineRegion default;
Visual Basic
Public Property default() As BaselineRegion
Links
BaselineRegionCollection Class, BaselineRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


BaselineRegionCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Nested Types
BaselineRegionCollection Nested Types
Collapse All

The nested types of BaselineRegionCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegionCollection::Identity.
Links
Public Nested Types


BaselineRegionCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Nested Types > BaselineRegionCollection::Identity Nested Type
BaselineRegionCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegionCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
BaselineRegionCollection Class, BaselineRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLink Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class
CalculatedLink Class
Collapse All

The CalculatedLink class.

A CalculatedLink joins two CalculatedPoint objects, and is a component of an AppliedSubassembly object, which in turn makes up an AppliedAssembly object that defines the profile of a Corridor.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedLink
C#
public class CalculatedLink : CalculatedSubentity;
Visual Basic
Public Class CalculatedLink
Inherits CalculatedSubentity
Links
CalculatedLink Properties, CalculatedLink Nested Types, CalculatedLink Members, Class Hierarchy


CalculatedLink Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Members
CalculatedLink Members
Collapse All

The following tables list the members exposed by CalculatedLink.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLink::Identity.
Public Properties
Public Property | Description
CalculatedPoints | Gets the collection of CalculatedPoints associated with the CalculatedLink.
CorridorCodes | Gets the collection of codes associated with the CalculatedLink.
CorridorId | Gets the ObjectId of the parent Corridor.
DrawOverride | Gets the draw override type of the CalculatedLink (CorridorLinkDrawOverride enumeration).
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.
Links
Public Nested Types, Public Properties


CalculatedLink Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Properties
CalculatedLink Properties
Collapse All

The properties of CalculatedLink are listed here.

Public Properties
Public Property | Description
CalculatedPoints | Gets the collection of CalculatedPoints associated with the CalculatedLink.
CorridorCodes | Gets the collection of codes associated with the CalculatedLink.
DrawOverride | Gets the draw override type of the CalculatedLink (CorridorLinkDrawOverride enumeration).
Links
Public Properties


CalculatedLink::CalculatedPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Properties > CalculatedLink::CalculatedPoints Property
CalculatedLink::CalculatedPoints Property
Collapse All

Gets the collection of CalculatedPoints associated with the CalculatedLink.

C#
public CalculatedPointCollection CalculatedPoints;
Visual Basic
Public Property CalculatedPoints() As CalculatedPointCollection
Links
CalculatedLink Class, CalculatedLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLink::CorridorCodes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Properties > CalculatedLink::CorridorCodes Property
CalculatedLink::CorridorCodes Property
Collapse All

Gets the collection of codes associated with the CalculatedLink.

C#
public CorridorCodeCollection CorridorCodes;
Visual Basic
Public Property CorridorCodes() As CorridorCodeCollection
Links
CalculatedLink Class, CalculatedLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLink::DrawOverride Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Properties > CalculatedLink::DrawOverride Property
CalculatedLink::DrawOverride Property
Collapse All

Gets the draw override type of the CalculatedLink (CorridorLinkDrawOverride enumeration).

C#
public CorridorLinkDrawOverride DrawOverride;
Visual Basic
Public Property DrawOverride() As CorridorLinkDrawOverride
Links
CalculatedLink Class, CalculatedLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLink Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Nested Types
CalculatedLink Nested Types
Collapse All

The nested types of CalculatedLink are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLink::Identity.
Links
Public Nested Types


CalculatedLink::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Nested Types > CalculatedLink::Identity Nested Type
CalculatedLink::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLink::Identity.

C#
Identity
Visual Basic
Identity
Links
CalculatedLink Class, CalculatedLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLinkCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class
CalculatedLinkCollection Class
Collapse All

A calculated link is a collection of calculated points (CalculatedPoint) which are connected to form a line. Calculated shapes (CalculatedShape) are made up of calculated links.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedLinkCollection
C#
public class CalculatedLinkCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<CalculatedLink^>;
Visual Basic
Public Class CalculatedLinkCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<CalculatedLink^>
Links
CalculatedLinkCollection Methods, CalculatedLinkCollection Properties, CalculatedLinkCollection Nested Types, CalculatedLinkCollection Members, Class Hierarchy


CalculatedLinkCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Members
CalculatedLinkCollection Members
Collapse All

The following tables list the members exposed by CalculatedLinkCollection.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLinkCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CalculatedLink objects in this collection.
default | Gets the default CalculatedLink object from the collection.
Links
Public Methods, Public Nested Types, Public Properties


CalculatedLinkCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Methods
CalculatedLinkCollection Methods
Collapse All

The methods of CalculatedLinkCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Links
Public Methods


CalculatedLinkCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Methods > CalculatedLinkCollection::GetEnumerator Method
CalculatedLinkCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<CalculatedLink^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<CalculatedLink^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
CalculatedLinkCollection Class, CalculatedLinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLinkCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Methods > CalculatedLinkCollection::GetObjectEnumerator Method
CalculatedLinkCollection::GetObjectEnumerator Method
Collapse All

Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator interface.

Links
CalculatedLinkCollection Class, CalculatedLinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLinkCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Properties
CalculatedLinkCollection Properties
Collapse All

The properties of CalculatedLinkCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CalculatedLink objects in this collection.
default | Gets the default CalculatedLink object from the collection.
Links
Public Properties


CalculatedLinkCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Properties > CalculatedLinkCollection::CorridorId Property
CalculatedLinkCollection::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CalculatedLinkCollection Class, CalculatedLinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLinkCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Properties > CalculatedLinkCollection::Count Property
CalculatedLinkCollection::Count Property
Collapse All

Gets the number of CalculatedLink objects in this collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
CalculatedLinkCollection Class, CalculatedLinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLinkCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Properties > CalculatedLinkCollection::default Property
CalculatedLinkCollection::default Property
Collapse All

Gets the default CalculatedLink object from the collection.

C#
public CalculatedLink default;
Visual Basic
Public Property default() As CalculatedLink
Links
CalculatedLinkCollection Class, CalculatedLinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedLinkCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Nested Types
CalculatedLinkCollection Nested Types
Collapse All

The nested types of CalculatedLinkCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLinkCollection::Identity.
Links
Public Nested Types


CalculatedLinkCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Nested Types > CalculatedLinkCollection::Identity Nested Type
CalculatedLinkCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLinkCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
CalculatedLinkCollection Class, CalculatedLinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPoint Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class
CalculatedPoint Class
Collapse All

The CalculatedPoint class.

A CalculatedPoint is the basic component that defines the stucture of an AppliedSubassembly.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedPoint
C#
public class CalculatedPoint : CalculatedSubentity;
Visual Basic
Public Class CalculatedPoint
Inherits CalculatedSubentity
Links
CalculatedPoint Properties, CalculatedPoint Nested Types, CalculatedPoint Members, Class Hierarchy


CalculatedPoint Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Members
CalculatedPoint Members
Collapse All

The following tables list the members exposed by CalculatedPoint.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPoint::Identity.
Public Properties
Public Property | Description
CorridorCodes | Gets the collection of codes associated with the CalculatedPoint.
CorridorId | Gets the ObjectId of the parent Corridor.
NormalToBaseline | Gets the normal to baseline vector.
NormalToSubassembly | Gets the normal to subassembly vector.
StationOffsetElevationToBaseline | Gets the Station (X), offset to baseline (Y) and elevation from baseline (Z) for the point.
StationOffsetElevationToSubassembly | Gets the Station (X), offset to subassembly (Y) and elevation from subassembly (Z) for the point.
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.
Links
Public Nested Types, Public Properties


CalculatedPoint Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Properties
CalculatedPoint Properties
Collapse All

The properties of CalculatedPoint are listed here.

Public Properties
Public Property | Description
CorridorCodes | Gets the collection of codes associated with the CalculatedPoint.
NormalToBaseline | Gets the normal to baseline vector.
NormalToSubassembly | Gets the normal to subassembly vector.
StationOffsetElevationToBaseline | Gets the Station (X), offset to baseline (Y) and elevation from baseline (Z) for the point.
StationOffsetElevationToSubassembly | Gets the Station (X), offset to subassembly (Y) and elevation from subassembly (Z) for the point.
Links
Public Properties


CalculatedPoint::CorridorCodes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Properties > CalculatedPoint::CorridorCodes Property
CalculatedPoint::CorridorCodes Property
Collapse All

Gets the collection of codes associated with the CalculatedPoint.

C#
public CorridorCodeCollection CorridorCodes;
Visual Basic
Public Property CorridorCodes() As CorridorCodeCollection
Links
CalculatedPoint Class, CalculatedPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPoint::NormalToBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Properties > CalculatedPoint::NormalToBaseline Property
CalculatedPoint::NormalToBaseline Property
Collapse All

Gets the normal to baseline vector.

C#
public Autodesk::AutoCAD::Geometry::Vector3d NormalToBaseline;
Visual Basic
Public Property NormalToBaseline() As Autodesk::AutoCAD::Geometry::Vector3d
Links
CalculatedPoint Class, CalculatedPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPoint::NormalToSubassembly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Properties > CalculatedPoint::NormalToSubassembly Property
CalculatedPoint::NormalToSubassembly Property
Collapse All

Gets the normal to subassembly vector.

C#
public Autodesk::AutoCAD::Geometry::Vector3d NormalToSubassembly;
Visual Basic
Public Property NormalToSubassembly() As Autodesk::AutoCAD::Geometry::Vector3d
Links
CalculatedPoint Class, CalculatedPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPoint::StationOffsetElevationToBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Properties > CalculatedPoint::StationOffsetElevationToBaseline Property
CalculatedPoint::StationOffsetElevationToBaseline Property
Collapse All

Gets the Station (X), offset to baseline (Y) and elevation from baseline (Z) for the point.

C#
public Autodesk::AutoCAD::Geometry::Point3d StationOffsetElevationToBaseline;
Visual Basic
Public Property StationOffsetElevationToBaseline() As Autodesk::AutoCAD::Geometry::Point3d
Links
CalculatedPoint Class, CalculatedPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPoint::StationOffsetElevationToSubassembly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Properties > CalculatedPoint::StationOffsetElevationToSubassembly Property
CalculatedPoint::StationOffsetElevationToSubassembly Property
Collapse All

Gets the Station (X), offset to subassembly (Y) and elevation from subassembly (Z) for the point.

C#
public Autodesk::AutoCAD::Geometry::Point3d StationOffsetElevationToSubassembly;
Visual Basic
Public Property StationOffsetElevationToSubassembly() As Autodesk::AutoCAD::Geometry::Point3d
Links
CalculatedPoint Class, CalculatedPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPoint Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Nested Types
CalculatedPoint Nested Types
Collapse All

The nested types of CalculatedPoint are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPoint::Identity.
Links
Public Nested Types


CalculatedPoint::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Nested Types > CalculatedPoint::Identity Nested Type
CalculatedPoint::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPoint::Identity.

C#
Identity
Visual Basic
Identity
Links
CalculatedPoint Class, CalculatedPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPointCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class
CalculatedPointCollection Class
Collapse All

A collection of calculated point (CalculatedPoint) objects. Calculated points are used to define applied subassemblies.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedPointCollection
C#
public class CalculatedPointCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<CalculatedPoint^>;
Visual Basic
Public Class CalculatedPointCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<CalculatedPoint^>
Links
CalculatedPointCollection Methods, CalculatedPointCollection Properties, CalculatedPointCollection Nested Types, CalculatedPointCollection Members, Class Hierarchy


CalculatedPointCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Members
CalculatedPointCollection Members
Collapse All

The following tables list the members exposed by CalculatedPointCollection.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPointCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CalculatedPoint objects in the collection.
default | Gets a CalculatedPoint by index.
Links
Public Methods, Public Nested Types, Public Properties


CalculatedPointCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Methods
CalculatedPointCollection Methods
Collapse All

The methods of CalculatedPointCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Links
Public Methods


CalculatedPointCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Methods > CalculatedPointCollection::GetEnumerator Method
CalculatedPointCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<CalculatedPoint^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<CalculatedPoint^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
CalculatedPointCollection Class, CalculatedPointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPointCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Methods > CalculatedPointCollection::GetObjectEnumerator Method
CalculatedPointCollection::GetObjectEnumerator Method
Collapse All

Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator interface.

Links
CalculatedPointCollection Class, CalculatedPointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPointCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Properties
CalculatedPointCollection Properties
Collapse All

The properties of CalculatedPointCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CalculatedPoint objects in the collection.
default | Gets a CalculatedPoint by index.
Links
Public Properties


CalculatedPointCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Properties > CalculatedPointCollection::CorridorId Property
CalculatedPointCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CalculatedPointCollection Class, CalculatedPointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPointCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Properties > CalculatedPointCollection::Count Property
CalculatedPointCollection::Count Property
Collapse All

Gets the number of CalculatedPoint objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
CalculatedPointCollection Class, CalculatedPointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPointCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Properties > CalculatedPointCollection::default Property
CalculatedPointCollection::default Property
Collapse All

Gets a CalculatedPoint by index.

C#
public CalculatedPoint default;
Visual Basic
Public Property default() As CalculatedPoint
Links
CalculatedPointCollection Class, CalculatedPointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedPointCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Nested Types
CalculatedPointCollection Nested Types
Collapse All

The nested types of CalculatedPointCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPointCollection::Identity.
Links
Public Nested Types


CalculatedPointCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Nested Types > CalculatedPointCollection::Identity Nested Type
CalculatedPointCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPointCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
CalculatedPointCollection Class, CalculatedPointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShape Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class
CalculatedShape Class
Collapse All

The CalculatedShape class.

A CalculatedShape is defined from links and defines a closed region that represents materials used in a corridor model.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedShape
C#
public class CalculatedShape : CalculatedSubentity;
Visual Basic
Public Class CalculatedShape
Inherits CalculatedSubentity
Links
CalculatedShape Properties, CalculatedShape Nested Types, CalculatedShape Members, Class Hierarchy


CalculatedShape Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Members
CalculatedShape Members
Collapse All

The following tables list the members exposed by CalculatedShape.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShape::Identity.
Public Properties
Public Property | Description
Area | Gets the area of the CalculatedShape.
CalculatedLinks | Gets the collection of links that make up the CalculatedShape.
CorridorCodes | Gets the collection of codes associated with the CalculatedShape.
CorridorId | Gets the ObjectId of the parent Corridor.
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.
Links
Public Nested Types, Public Properties


CalculatedShape Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Properties
CalculatedShape Properties
Collapse All

The properties of CalculatedShape are listed here.

Public Properties
Public Property | Description
Area | Gets the area of the CalculatedShape.
CalculatedLinks | Gets the collection of links that make up the CalculatedShape.
CorridorCodes | Gets the collection of codes associated with the CalculatedShape.
Links
Public Properties


CalculatedShape::Area Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Properties > CalculatedShape::Area Property
CalculatedShape::Area Property
Collapse All

Gets the area of the CalculatedShape.

C#
public double Area;
Visual Basic
Public Property Area() As double
Links
CalculatedShape Class, CalculatedShape Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShape::CalculatedLinks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Properties > CalculatedShape::CalculatedLinks Property
CalculatedShape::CalculatedLinks Property
Collapse All

Gets the collection of links that make up the CalculatedShape.

C#
public CalculatedLinkCollection CalculatedLinks;
Visual Basic
Public Property CalculatedLinks() As CalculatedLinkCollection
Links
CalculatedShape Class, CalculatedShape Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShape::CorridorCodes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Properties > CalculatedShape::CorridorCodes Property
CalculatedShape::CorridorCodes Property
Collapse All

Gets the collection of codes associated with the CalculatedShape.

C#
public CorridorCodeCollection CorridorCodes;
Visual Basic
Public Property CorridorCodes() As CorridorCodeCollection
Links
CalculatedShape Class, CalculatedShape Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShape Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Nested Types
CalculatedShape Nested Types
Collapse All

The nested types of CalculatedShape are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShape::Identity.
Links
Public Nested Types


CalculatedShape::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Nested Types > CalculatedShape::Identity Nested Type
CalculatedShape::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShape::Identity.

C#
Identity
Visual Basic
Identity
Links
CalculatedShape Class, CalculatedShape Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShapeCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class
CalculatedShapeCollection Class
Collapse All

Collection of calculated shape (CalculatedShape) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedShapeCollection
C#
public class CalculatedShapeCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<CalculatedShape^>;
Visual Basic
Public Class CalculatedShapeCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<CalculatedShape^>
Links
CalculatedShapeCollection Methods, CalculatedShapeCollection Properties, CalculatedShapeCollection Nested Types, CalculatedShapeCollection Members, Class Hierarchy


CalculatedShapeCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Members
CalculatedShapeCollection Members
Collapse All

The following tables list the members exposed by CalculatedShapeCollection.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShapeCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CorridorSurfaceBoundary objects in the collection.
default | Gets a CalculatedShape by index.
Links
Public Methods, Public Nested Types, Public Properties


CalculatedShapeCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Methods
CalculatedShapeCollection Methods
Collapse All

The methods of CalculatedShapeCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Links
Public Methods


CalculatedShapeCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Methods > CalculatedShapeCollection::GetEnumerator Method
CalculatedShapeCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<CalculatedShape^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<CalculatedShape^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
CalculatedShapeCollection Class, CalculatedShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShapeCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Methods > CalculatedShapeCollection::GetObjectEnumerator Method
CalculatedShapeCollection::GetObjectEnumerator Method
Collapse All

Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator interface.

Links
CalculatedShapeCollection Class, CalculatedShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShapeCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Properties
CalculatedShapeCollection Properties
Collapse All

The properties of CalculatedShapeCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CorridorSurfaceBoundary objects in the collection.
default | Gets a CalculatedShape by index.
Links
Public Properties


CalculatedShapeCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Properties > CalculatedShapeCollection::CorridorId Property
CalculatedShapeCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CalculatedShapeCollection Class, CalculatedShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShapeCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Properties > CalculatedShapeCollection::Count Property
CalculatedShapeCollection::Count Property
Collapse All

Gets the number of CorridorSurfaceBoundary objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
CalculatedShapeCollection Class, CalculatedShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShapeCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Properties > CalculatedShapeCollection::default Property
CalculatedShapeCollection::default Property
Collapse All

Gets a CalculatedShape by index.

C#
public CalculatedShape default;
Visual Basic
Public Property default() As CalculatedShape
Links
CalculatedShapeCollection Class, CalculatedShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedShapeCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Nested Types
CalculatedShapeCollection Nested Types
Collapse All

The nested types of CalculatedShapeCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShapeCollection::Identity.
Links
Public Nested Types


CalculatedShapeCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Nested Types > CalculatedShapeCollection::Identity Nested Type
CalculatedShapeCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShapeCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
CalculatedShapeCollection Class, CalculatedShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedSubentity Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class
CalculatedSubentity Class
Collapse All

Parent class for the CalculatedShape, CalculatedLink and CalculatedPoint interfaces.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedLink
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedPoint
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedShape
C#
public class CalculatedSubentity : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class CalculatedSubentity
Inherits CivilWrapper<AeccDbCorridor>
Links
CalculatedSubentity Properties, CalculatedSubentity Nested Types, CalculatedSubentity Members, Class Hierarchy


CalculatedSubentity Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Members
CalculatedSubentity Members
Collapse All

The following tables list the members exposed by CalculatedSubentity.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity::Identity.
Public Properties
Public Property | Description
CorridorCodes | Gets the collection of CorridorCode objects.
CorridorId | Gets the ObjectId of the parent Corridor.
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.
Links
Public Nested Types, Public Properties


CalculatedSubentity Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Properties
CalculatedSubentity Properties
Collapse All

The properties of CalculatedSubentity are listed here.

Public Properties
Public Property | Description
CorridorCodes | Gets the collection of CorridorCode objects.
CorridorId | Gets the ObjectId of the parent Corridor.
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.
Links
Public Properties


CalculatedSubentity::CorridorCodes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Properties > CalculatedSubentity::CorridorCodes Property
CalculatedSubentity::CorridorCodes Property
Collapse All

Gets the collection of CorridorCode objects.

C#
public CorridorCodeCollection CorridorCodes;
Visual Basic
Public Property CorridorCodes() As CorridorCodeCollection
Links
CalculatedSubentity Class, CalculatedSubentity Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedSubentity::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Properties > CalculatedSubentity::CorridorId Property
CalculatedSubentity::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CalculatedSubentity Class, CalculatedSubentity Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedSubentity::SubassemblyBelongedTo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Properties > CalculatedSubentity::SubassemblyBelongedTo Property
CalculatedSubentity::SubassemblyBelongedTo Property
Collapse All

Gets the AppliedSubassembly this calculated subentity belongs to.

C#
public AppliedSubassembly SubassemblyBelongedTo;
Visual Basic
Public Property SubassemblyBelongedTo() As AppliedSubassembly
Links
CalculatedSubentity Class, CalculatedSubentity Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CalculatedSubentity Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Nested Types
CalculatedSubentity Nested Types
Collapse All

The nested types of CalculatedSubentity are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity::Identity.
Links
Public Nested Types


CalculatedSubentity::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Nested Types > CalculatedSubentity::Identity Nested Type
CalculatedSubentity::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity::Identity.

C#
Identity
Visual Basic
Identity
Links
CalculatedSubentity Class, CalculatedSubentity Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CodeCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class
CodeCollection Class
Collapse All

The Corridor code collection class. The wrapped object could be AeccDbRoadwayState or AeccDbSubassembly.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CodeCollection
C#
public class CodeCollection : CivilWrapper<AeccDbEntity>, System::Collections::Generic::IEnumerable<System::String^>;
Visual Basic
Public Class CodeCollection
Inherits CivilWrapper<AeccDbEntity>
Inherits System::Collections::Generic::IEnumerable<System::String^>
Links
CodeCollection Methods, CodeCollection Properties, CodeCollection Nested Types, CodeCollection Members, Class Hierarchy


CodeCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Members
CodeCollection Members
Collapse All

The following tables list the members exposed by CodeCollection.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Remove | Remove the code from collection.
Public Nested Types
Public Nested Type | Description
SubEntityType | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CodeCollection::SubEntityType.
Public Properties
Public Property | Description
Count | Get the count of code in the collection
default | Get a code in the collection.
Links
Public Methods, Public Nested Types, Public Properties


CodeCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Methods
CodeCollection Methods
Collapse All

The methods of CodeCollection are listed here.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Remove | Remove the code from collection.
Links
Public Methods


Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Methods > Add Method
Add Method
Collapse All

Overloaded

Overload List
Method | Description
CodeCollection::Add (array<System::String^>^) | Adds new codes to the collection.
CodeCollection::Add (System::String^) | Adds a new code to the collection.


CodeCollection::Add Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Methods > Add Method > CodeCollection::Add Method (System::String^)
CodeCollection::Add Method (System::String^)
Collapse All

Adds a new code to the collection.

C#
public Add(
    ref System::String code
);
Visual Basic
Public Sub Add(
    ByRef code As System::String
)
Exceptions
Exceptions | Description
 | System::ArgumentNullException, System::ArgumentException
Links
CodeCollection Class, CodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CodeCollection::Add Method (array<System::String^>^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Methods > Add Method > CodeCollection::Add Method (array<System::String^>^)
CodeCollection::Add Method (array<System::String^>^)
Collapse All

Adds new codes to the collection.

C#
public Add(
    ref array<System::String^> codes
);
Visual Basic
Public Sub Add(
    ByRef codes As array<System::String^>
)
Exceptions
Exceptions | Description
 | System::ArgumentNullException
Links
CodeCollection Class, CodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CodeCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Methods > CodeCollection::GetEnumerator Method
CodeCollection::GetEnumerator Method
Collapse All

Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<System::String^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<System::String^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
CodeCollection Class, CodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CodeCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Methods > CodeCollection::GetObjectEnumerator Method
CodeCollection::GetObjectEnumerator Method
Collapse All

Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator interface.

Links
CodeCollection Class, CodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CodeCollection::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Methods > CodeCollection::Remove Method
CodeCollection::Remove Method
Collapse All

Remove the code from collection.

C#
public Remove(
    ref System::String code
);
Visual Basic
Public Sub Remove(
    ByRef code As System::String
)
Parameters
Parameters | Description
bstrCode | Name of the Corridor code.
Exceptions
Exceptions | Description
 | System::ArgumentException, System::ArgumentNullException
Links
CodeCollection Class, CodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CodeCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Properties
CodeCollection Properties
Collapse All

The properties of CodeCollection are listed here.

Public Properties
Public Property | Description
Count | Get the count of code in the collection
default | Get a code in the collection.
Links
Public Properties


CodeCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Properties > CodeCollection::Count Property
CodeCollection::Count Property
Collapse All

Get the count of code in the collection

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
CodeCollection Class, CodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CodeCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Properties > CodeCollection::default Property
CodeCollection::default Property
Collapse All

Get a code in the collection.

C#
public System::String default;
Visual Basic
Public Property default() As System::String
Parameters
Parameters | Description
index | The index of the code.
Exceptions
Exceptions | Description
 | System::ArgumentOutOfRangeException
Links
CodeCollection Class, CodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CodeCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Nested Types
CodeCollection Nested Types
Collapse All

The nested types of CodeCollection are listed here.

Public Nested Types
Public Nested Type | Description
SubEntityType | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CodeCollection::SubEntityType.
Links
Public Nested Types


CodeCollection::SubEntityType Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Nested Types > CodeCollection::SubEntityType Nested Type
CodeCollection::SubEntityType Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CodeCollection::SubEntityType.

C#
SubEntityType
Visual Basic
SubEntityType
Links
CodeCollection Class, CodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Corridor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class
Corridor Class
Collapse All

Representation of a roadway. Follows a 3D path defined by a baseline, and is made up of cross sections (AppliedAssembly) and feature lines (FeatureLine) connecting common points in each cross section.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Roadway::DatabaseServices::Corridor
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbCorridor"))]
public class Corridor : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbCorridor"))>
Public Class Corridor
Inherits Autodesk::Civil::DatabaseServices::Entity
Remarks

A corridor in Civil 3D represents a path, such as a road, trail, railroad, or airport runway. The geometry of a corridor is defined by a horizontal Alignment and a Profile. Together, these form the baseline - the centerline of the 3D path of the Corridor. Along the length of the baselines are a series of Assembly objects which define the cross-sectional shape of the Alignment. Common points in each Assembly are connected to form feature lines (FeatureLine objects). Together the assemblies and feature lines form the 3D shape of a corridor.

Links
Corridor Methods, Corridor Properties, Corridor Members, Class Hierarchy


Corridor Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Members
Corridor Members
Collapse All

The following tables list the members exposed by Corridor.

Public Methods
Public Method | Description
Rebuild | Forces the corridor to rebuild.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
Baselines | Gets the baselines collection for the corridor.
CodeSetStyleName | Gets or sets the corridor's code set style name.
CorridorSurfaces | Gets the surfaces collection for the corridor.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureLineCodeInfos | Gets the feature line code info collection for the corridor.
IsOutOfDate | Gets the corridor's out of date flag.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
MaximumTriangleSideLength | Gets or sets the corridor surface's maximum triangle side length.
Name | Gets or sets the Entity object's name.
RebuildAutomatic | Gets or sets the automatic rebuild mode for the corridor.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


Corridor Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Methods
Corridor Methods
Collapse All

The methods of Corridor are listed here.

Public Methods
Public Method | Description
Rebuild | Forces the corridor to rebuild.
Links
Public Methods


Corridor::Rebuild Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Methods > Corridor::Rebuild Method
Corridor::Rebuild Method
Collapse All

Forces the corridor to rebuild.

C#
public Rebuild();
Visual Basic
Public Sub Rebuild()
Links
Corridor Class, Corridor Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Corridor Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties
Corridor Properties
Collapse All

The properties of Corridor are listed here.

Public Properties
Public Property | Description
Baselines | Gets the baselines collection for the corridor.
CodeSetStyleName | Gets or sets the corridor's code set style name.
CorridorSurfaces | Gets the surfaces collection for the corridor.
FeatureLineCodeInfos | Gets the feature line code info collection for the corridor.
IsOutOfDate | Gets the corridor's out of date flag.
MaximumTriangleSideLength | Gets or sets the corridor surface's maximum triangle side length.
RebuildAutomatic | Gets or sets the automatic rebuild mode for the corridor.
Links
Public Properties


Corridor::Baselines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties > Corridor::Baselines Property
Corridor::Baselines Property
Collapse All

Gets the baselines collection for the corridor.

C#
public BaselineCollection Baselines;
Visual Basic
Public Property Baselines() As BaselineCollection
Example
foreach (Baseline oBaseline in oCorridor.Baselines)
{
   Alignment oAlign = ts.GetObject(oBaseline.AlignmentId, OpenMode.ForRead) as Alignment;
   Profile oProfile = ts.GetObject(oBaseline.ProfileId, OpenMode.ForRead) as Profile;
   ed.WriteMessage(@"Baseline information -
     Alignment     : {0}
     Profile       : {1}
     Start station : {2}
     End station   : {3}n",
     oAlign.Name,
     oProfile.Name,
     oBaseline.StartStation,
     oBaseline.EndStation);
Links
Corridor Class, Corridor Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Corridor::CodeSetStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties > Corridor::CodeSetStyleName Property
Corridor::CodeSetStyleName Property
Collapse All

Gets or sets the corridor's code set style name.

C#
public System::String CodeSetStyleName;
Visual Basic
Public Property CodeSetStyleName() As System::String
Links
Corridor Class, Corridor Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Corridor::CorridorSurfaces Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties > Corridor::CorridorSurfaces Property
Corridor::CorridorSurfaces Property
Collapse All

Gets the surfaces collection for the corridor.

C#
public CorridorSurfaceCollection CorridorSurfaces;
Visual Basic
Public Property CorridorSurfaces() As CorridorSurfaceCollection
Example
// List surfaces
foreach (CorridorSurface oCorridorSurface in oCorridor.CorridorSurfaces)
{
   ed.WriteMessage("Corridor surface: {0}n", oCorridorSurface.Name);

   // Get the point codes for the surface.
   String[] oPointCodes = oCorridorSurface.PointCodes();
   ed.WriteMessage("Surface point codes:n");
   foreach (String s in oPointCodes)
   {
       ed.WriteMessage("{0}n", s);
   }
Links
Corridor Class, Corridor Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Corridor::FeatureLineCodeInfos Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties > Corridor::FeatureLineCodeInfos Property
Corridor::FeatureLineCodeInfos Property
Collapse All

Gets the feature line code info collection for the corridor.

C#
public FeatureLineCodeInfoCollection FeatureLineCodeInfos;
Visual Basic
Public Property FeatureLineCodeInfos() As FeatureLineCodeInfoCollection
Links
Corridor Class, Corridor Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Corridor::IsOutOfDate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties > Corridor::IsOutOfDate Property
Corridor::IsOutOfDate Property
Collapse All

Gets the corridor's out of date flag.

C#
public bool IsOutOfDate;
Visual Basic
Public Property IsOutOfDate() As bool
Links
Corridor Class, Corridor Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Corridor::MaximumTriangleSideLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties > Corridor::MaximumTriangleSideLength Property
Corridor::MaximumTriangleSideLength Property
Collapse All

Gets or sets the corridor surface's maximum triangle side length.

C#
public double MaximumTriangleSideLength;
Visual Basic
Public Property MaximumTriangleSideLength() As double
Links
Corridor Class, Corridor Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Corridor::RebuildAutomatic Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties > Corridor::RebuildAutomatic Property
Corridor::RebuildAutomatic Property
Collapse All

Gets or sets the automatic rebuild mode for the corridor.

C#
public bool RebuildAutomatic;
Visual Basic
Public Property RebuildAutomatic() As bool
Links
Corridor Class, Corridor Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCodeCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class
CorridorCodeCollection Class
Collapse All

A collection of strings containing corridor codes. A code is used to identify common calculated points in applied assemblies in a corridor. For example, a code can be used to identify the inside upper edge of a sidewalk in each assembly. Points that share a particular code can be connected to form feature lines (FeatureLine).

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorCodeCollection
C#
public class CorridorCodeCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<System::String^>;
Visual Basic
Public Class CorridorCodeCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<System::String^>
Links
CorridorCodeCollection Methods, CorridorCodeCollection Properties, CorridorCodeCollection Nested Types, CorridorCodeCollection Members, Class Hierarchy


CorridorCodeCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Members
CorridorCodeCollection Members
Collapse All

The following tables list the members exposed by CorridorCodeCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implements the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorCodeCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of Corridor code strings in the collection.
default | Gets a Corridor code string from the collection by index.
Links
Public Methods, Public Nested Types, Public Properties


CorridorCodeCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Methods
CorridorCodeCollection Methods
Collapse All

The methods of CorridorCodeCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implements the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Links
Public Methods


CorridorCodeCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Methods > CorridorCodeCollection::GetEnumerator Method
CorridorCodeCollection::GetEnumerator Method
Collapse All

Implements the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<System::String^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<System::String^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
CorridorCodeCollection Class, CorridorCodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCodeCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Methods > CorridorCodeCollection::GetObjectEnumerator Method
CorridorCodeCollection::GetObjectEnumerator Method
Collapse All

Implements the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements IEnumerator interface.

Links
CorridorCodeCollection Class, CorridorCodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCodeCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Properties
CorridorCodeCollection Properties
Collapse All

The properties of CorridorCodeCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of Corridor code strings in the collection.
default | Gets a Corridor code string from the collection by index.
Links
Public Properties


CorridorCodeCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Properties > CorridorCodeCollection::CorridorId Property
CorridorCodeCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorCodeCollection Class, CorridorCodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCodeCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Properties > CorridorCodeCollection::Count Property
CorridorCodeCollection::Count Property
Collapse All

Gets the number of Corridor code strings in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
CorridorCodeCollection Class, CorridorCodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCodeCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Properties > CorridorCodeCollection::default Property
CorridorCodeCollection::default Property
Collapse All

Gets a Corridor code string from the collection by index.

C#
public System::String default;
Visual Basic
Public Property default() As System::String
Links
CorridorCodeCollection Class, CorridorCodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCodeCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Nested Types
CorridorCodeCollection Nested Types
Collapse All

The nested types of CorridorCodeCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorCodeCollection::Identity.
Links
Public Nested Types


CorridorCodeCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Nested Types > CorridorCodeCollection::Identity Nested Type
CorridorCodeCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorCodeCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
CorridorCodeCollection Class, CorridorCodeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class
CorridorCollection Class
Collapse All

A collection of Corridor objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorCollection
C#
public class CorridorCollection : CivilWrapper<AcDbDatabase>, System::Collections::Generic::IEnumerable<Autodesk::AutoCAD::DatabaseServices::ObjectId>;
Visual Basic
Public Class CorridorCollection
Inherits CivilWrapper<AcDbDatabase>
Inherits System::Collections::Generic::IEnumerable<Autodesk::AutoCAD::DatabaseServices::ObjectId>
Links
CorridorCollection Methods, CorridorCollection Properties, CorridorCollection Members, Class Hierarchy


CorridorCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Members
CorridorCollection Members
Collapse All

The following tables list the members exposed by CorridorCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Public Properties
Public Property | Description
Count | Gets the number of Corridor objects in the collection.
default | Gets an Corridor by name.
Links
Public Methods, Public Properties


CorridorCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Methods
CorridorCollection Methods
Collapse All

The methods of CorridorCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Links
Public Methods


CorridorCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Methods > CorridorCollection::GetEnumerator Method
CorridorCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<Autodesk::AutoCAD::DatabaseServices::ObjectId> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<Autodesk::AutoCAD::DatabaseServices::ObjectId>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
CorridorCollection Class, CorridorCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Methods > CorridorCollection::GetObjectEnumerator Method
CorridorCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
CorridorCollection Class, CorridorCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Properties
CorridorCollection Properties
Collapse All

The properties of CorridorCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of Corridor objects in the collection.
default | Gets an Corridor by name.
Links
Public Properties


CorridorCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Properties > CorridorCollection::Count Property
CorridorCollection::Count Property
Collapse All

Gets the number of Corridor objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
CorridorCollection Class, CorridorCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Properties > CorridorCollection::default Property
CorridorCollection::default Property
Collapse All

Gets an Corridor by name.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId default;
Visual Basic
Public Property default() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Exceptions
Exceptions | Description
 | System::ArgumentException, System::ArgumentNullException, System::ArgumentOutOfRangeException
Links
CorridorCollection Class, CorridorCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class
CorridorSection Class
Collapse All

A section of a Corridor.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSection
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionCorridor"))]
public class CorridorSection : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSectionCorridor"))>
Public Class CorridorSection
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
CorridorSection Methods, CorridorSection Members, Class Hierarchy


CorridorSection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Members
CorridorSection Members
Collapse All

The following tables list the members exposed by CorridorSection.

Public Methods
Public Method | Description
GetCorridor | Gets the ObjectId of the parent Corridor.
SetCorridor | Overloaded
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Methods, Public Properties


CorridorSection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Methods
CorridorSection Methods
Collapse All

The methods of CorridorSection are listed here.

Public Methods
Public Method | Description
GetCorridor | Gets the ObjectId of the parent Corridor.
SetCorridor | Overloaded
Links
Public Methods


CorridorSection::GetCorridor Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Methods > CorridorSection::GetCorridor Method
CorridorSection::GetCorridor Method
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId GetCorridor();
Visual Basic
Public Function GetCorridor() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorSection Class, CorridorSection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SetCorridor Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Methods > SetCorridor Method
SetCorridor Method
Collapse All

Overloaded

Overload List
Method | Description
CorridorSection::SetCorridor (Autodesk::AutoCAD::DatabaseServices::ObjectId) | Sets the source Corridor for the section.
CorridorSection::SetCorridor (System::String^) | Sets the source Corridor for the section.


CorridorSection::SetCorridor Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Methods > SetCorridor Method > CorridorSection::SetCorridor Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
CorridorSection::SetCorridor Method (Autodesk::AutoCAD::DatabaseServices::ObjectId)
Collapse All

Sets the source Corridor for the section.

C#
public SetCorridor(
    Autodesk::AutoCAD::DatabaseServices::ObjectId corridorId
);
Visual Basic
Public Sub SetCorridor(
    corridorId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Exceptions
Exceptions | Description
 | System::ArgumentException
Links
CorridorSection Class, CorridorSection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSection::SetCorridor Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Methods > SetCorridor Method > CorridorSection::SetCorridor Method (System::String^)
CorridorSection::SetCorridor Method (System::String^)
Collapse All

Sets the source Corridor for the section.

C#
public SetCorridor(
    ref System::String corridorName
);
Visual Basic
Public Sub SetCorridor(
    ByRef corridorName As System::String
)
Links
CorridorSection Class, CorridorSection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class
CorridorSurface Class
Collapse All

Represents a layer of a corridor, and is computed from a set of feature lines, calculated points, and calculated links.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurface
C#
public class CorridorSurface : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class CorridorSurface
Inherits CivilWrapper<AeccDbCorridor>
Links
CorridorSurface Methods, CorridorSurface Properties, CorridorSurface Nested Types, CorridorSurface Members, Class Hierarchy


CorridorSurface Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Members
CorridorSurface Members
Collapse All

The following tables list the members exposed by CorridorSurface.

Public Methods
Public Method | Description
FeatureLineCodeIsBreak | Gets the IsBreak value of the link code.
FeatureLineCodes | Gets the feature line codes used to construct the surface.
FindElevationAtXY | Finds the elevation of the surface at the specified XY location.
GetSampleElevations | Gets the collection of sample elevations.
LinkCodes | Gets the link codes used to construct the surface.
PointCodes | Gets the point codes used to construct the surface.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurface::Identity.
Public Properties
Public Property | Description
Boundaries | Gets the collection of surface boundaries.
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description for the CorridorSurface.
IsBuild | Returns true if the CorridorSurface is built.
IsDraw | Returns true if the CorridorSurface is drawn.
Masks | Gets the collection of surface masks.
Name | Gets the name of the CorridorSurface.
SectionStyleId | Gets the ID of the SectionStyle.
SurfaceStyleId | Gets the ID of the SurfaceStyle.
Links
Public Methods, Public Nested Types, Public Properties


CorridorSurface Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Methods
CorridorSurface Methods
Collapse All

The methods of CorridorSurface are listed here.

Public Methods
Public Method | Description
FeatureLineCodeIsBreak | Gets the IsBreak value of the link code.
FeatureLineCodes | Gets the feature line codes used to construct the surface.
FindElevationAtXY | Finds the elevation of the surface at the specified XY location.
GetSampleElevations | Gets the collection of sample elevations.
LinkCodes | Gets the link codes used to construct the surface.
PointCodes | Gets the point codes used to construct the surface.
Links
Public Methods


CorridorSurface::FeatureLineCodeIsBreak Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Methods > CorridorSurface::FeatureLineCodeIsBreak Method
CorridorSurface::FeatureLineCodeIsBreak Method
Collapse All

Gets the IsBreak value of the link code.

C#
public bool FeatureLineCodeIsBreak(
    ref System::String name
);
Visual Basic
Public Function FeatureLineCodeIsBreak(
    ByRef name As System::String
) As bool
Exceptions
Exceptions | Description
 | System::ArgumentException, System::ArgumentNullException, System::ArgumentOutOfRangeException
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::FeatureLineCodes Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Methods > CorridorSurface::FeatureLineCodes Method
CorridorSurface::FeatureLineCodes Method
Collapse All

Gets the feature line codes used to construct the surface.

C#
public array<System::String^> FeatureLineCodes();
Visual Basic
Public Function FeatureLineCodes() As array<System::String^>
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::FindElevationAtXY Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Methods > CorridorSurface::FindElevationAtXY Method
CorridorSurface::FindElevationAtXY Method
Collapse All

Finds the elevation of the surface at the specified XY location.

C#
public double FindElevationAtXY(
    double x,
    double y
);
Visual Basic
Public Function FindElevationAtXY(
    x As double,
    y As double
) As double
Exceptions
Exceptions | Description
 | Autodesk::Civil::PointNotOnEntityException
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::GetSampleElevations Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Methods > CorridorSurface::GetSampleElevations Method
CorridorSurface::GetSampleElevations Method
Collapse All

Gets the collection of sample elevations.

C#
public Autodesk::AutoCAD::Geometry::Point3dCollection GetSampleElevations(
    double startX,
    double startY,
    double endX,
    double endY
);
Visual Basic
Public Function GetSampleElevations(
    startX As double,
    startY As double,
    endX As double,
    endY As double
) As Autodesk::AutoCAD::Geometry::Point3dCollection
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::LinkCodes Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Methods > CorridorSurface::LinkCodes Method
CorridorSurface::LinkCodes Method
Collapse All

Gets the link codes used to construct the surface.

C#
public array<System::String^> LinkCodes();
Visual Basic
Public Function LinkCodes() As array<System::String^>
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::PointCodes Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Methods > CorridorSurface::PointCodes Method
CorridorSurface::PointCodes Method
Collapse All

Gets the point codes used to construct the surface.

C#
public array<System::String^> PointCodes();
Visual Basic
Public Function PointCodes() As array<System::String^>
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties
CorridorSurface Properties
Collapse All

The properties of CorridorSurface are listed here.

Public Properties
Public Property | Description
Boundaries | Gets the collection of surface boundaries.
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description for the CorridorSurface.
IsBuild | Returns true if the CorridorSurface is built.
IsDraw | Returns true if the CorridorSurface is drawn.
Masks | Gets the collection of surface masks.
Name | Gets the name of the CorridorSurface.
SectionStyleId | Gets the ID of the SectionStyle.
SurfaceStyleId | Gets the ID of the SurfaceStyle.
Links
Public Properties


CorridorSurface::Boundaries Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties > CorridorSurface::Boundaries Property
CorridorSurface::Boundaries Property
Collapse All

Gets the collection of surface boundaries.

C#
public CorridorSurfaceBoundaryCollection Boundaries;
Visual Basic
Public Property Boundaries() As CorridorSurfaceBoundaryCollection
Example
// List boundaries
foreach (CorridorSurfaceBoundary oCorridorSurfaceBoundary in oCorridorSurface.Boundaries)
{
   if (oCorridorSurfaceBoundary.BoundaryType == CorridorSurfaceBoundaryType.InsideBoundary)
       ed.WriteMessage("Inner Boundary: ");
   else
       ed.WriteMessage("Outer Boundary: ");

   ed.WriteMessage(oCorridorSurfaceBoundary.Name);
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties > CorridorSurface::CorridorId Property
CorridorSurface::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties > CorridorSurface::Description Property
CorridorSurface::Description Property
Collapse All

Gets the description for the CorridorSurface.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::IsBuild Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties > CorridorSurface::IsBuild Property
CorridorSurface::IsBuild Property
Collapse All

Returns true if the CorridorSurface is built.

C#
public bool IsBuild;
Visual Basic
Public Property IsBuild() As bool
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::IsDraw Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties > CorridorSurface::IsDraw Property
CorridorSurface::IsDraw Property
Collapse All

Returns true if the CorridorSurface is drawn.

C#
public bool IsDraw;
Visual Basic
Public Property IsDraw() As bool
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::Masks Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties > CorridorSurface::Masks Property
CorridorSurface::Masks Property
Collapse All

Gets the collection of surface masks.

C#
public CorridorSurfaceMaskCollection Masks;
Visual Basic
Public Property Masks() As CorridorSurfaceMaskCollection
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties > CorridorSurface::Name Property
CorridorSurface::Name Property
Collapse All

Gets the name of the CorridorSurface.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::SectionStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties > CorridorSurface::SectionStyleId Property
CorridorSurface::SectionStyleId Property
Collapse All

Gets the ID of the SectionStyle.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SectionStyleId;
Visual Basic
Public Property SectionStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface::SurfaceStyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties > CorridorSurface::SurfaceStyleId Property
CorridorSurface::SurfaceStyleId Property
Collapse All

Gets the ID of the SurfaceStyle.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SurfaceStyleId;
Visual Basic
Public Property SurfaceStyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurface Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Nested Types
CorridorSurface Nested Types
Collapse All

The nested types of CorridorSurface are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurface::Identity.
Links
Public Nested Types


CorridorSurface::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Nested Types > CorridorSurface::Identity Nested Type
CorridorSurface::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurface::Identity.

C#
Identity
Visual Basic
Identity
Links
CorridorSurface Class, CorridorSurface Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBaseMask Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class
CorridorSurfaceBaseMask Class
Collapse All

Base class for CorridorSurfaceMask and CorridorSurfaceBoundary.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundary
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMask
C#
public class CorridorSurfaceBaseMask : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class CorridorSurfaceBaseMask
Inherits CivilWrapper<AeccDbCorridor>
Links
CorridorSurfaceBaseMask Methods, CorridorSurfaceBaseMask Properties, CorridorSurfaceBaseMask Nested Types, CorridorSurfaceBaseMask Members, Class Hierarchy


CorridorSurfaceBaseMask Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Members
CorridorSurfaceBaseMask Members
Collapse All

The following tables list the members exposed by CorridorSurfaceBaseMask.

Public Methods
Public Method | Description
PolygonPoints | Gets the points of the polygon that make up the edge of the boundary or mask.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description.
FeatureLineComponents | Gets the collection of feature line components that make up the edge, if the border was originally defined by selecting... more
Name | Gets the name.
Links
Public Methods, Public Nested Types, Public Properties


CorridorSurfaceBaseMask Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Methods
CorridorSurfaceBaseMask Methods
Collapse All

The methods of CorridorSurfaceBaseMask are listed here.

Public Methods
Public Method | Description
PolygonPoints | Gets the points of the polygon that make up the edge of the boundary or mask.
Links
Public Methods


CorridorSurfaceBaseMask::PolygonPoints Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Methods > CorridorSurfaceBaseMask::PolygonPoints Method
CorridorSurfaceBaseMask::PolygonPoints Method
Collapse All

Gets the points of the polygon that make up the edge of the boundary or mask.

C#
public array<Autodesk::AutoCAD::Geometry::Point3d> PolygonPoints();
Visual Basic
Public Function PolygonPoints() As array<Autodesk::AutoCAD::Geometry::Point3d>
Links
CorridorSurfaceBaseMask Class, CorridorSurfaceBaseMask Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBaseMask Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Properties
CorridorSurfaceBaseMask Properties
Collapse All

The properties of CorridorSurfaceBaseMask are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description.
FeatureLineComponents | Gets the collection of feature line components that make up the edge, if the border was originally defined by selecting... more
Name | Gets the name.
Links
Public Properties


CorridorSurfaceBaseMask::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Properties > CorridorSurfaceBaseMask::CorridorId Property
CorridorSurfaceBaseMask::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorSurfaceBaseMask Class, CorridorSurfaceBaseMask Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBaseMask::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Properties > CorridorSurfaceBaseMask::Description Property
CorridorSurfaceBaseMask::Description Property
Collapse All

Gets the description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
CorridorSurfaceBaseMask Class, CorridorSurfaceBaseMask Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBaseMask::FeatureLineComponents Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Properties > CorridorSurfaceBaseMask::FeatureLineComponents Property
CorridorSurfaceBaseMask::FeatureLineComponents Property
Collapse All

Gets the collection of feature line components that make up the edge, if the border was originally defined by selecting segments of feature lines.

C#
public FeatureLineComponentCollection FeatureLineComponents;
Visual Basic
Public Property FeatureLineComponents() As FeatureLineComponentCollection
Example
foreach (FeatureLineComponent oFeatureLineComponent in oCorridorSurfaceBoundary.FeatureLineComponents)
{
   ed.WriteMessage("Code: {0}, Start station: {1}, End station: {2}n",
       oFeatureLineComponent.FeatureLine.CodeName,
       oFeatureLineComponent.StartStation,
       oFeatureLineComponent.EndStation);
}
Links
CorridorSurfaceBaseMask Class, CorridorSurfaceBaseMask Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBaseMask::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Properties > CorridorSurfaceBaseMask::Name Property
CorridorSurfaceBaseMask::Name Property
Collapse All

Gets the name.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
CorridorSurfaceBaseMask Class, CorridorSurfaceBaseMask Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBaseMask Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Nested Types
CorridorSurfaceBaseMask Nested Types
Collapse All

The nested types of CorridorSurfaceBaseMask are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask::Identity.
Links
Public Nested Types


CorridorSurfaceBaseMask::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Nested Types > CorridorSurfaceBaseMask::Identity Nested Type
CorridorSurfaceBaseMask::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask::Identity.

C#
Identity
Visual Basic
Identity
Links
CorridorSurfaceBaseMask Class, CorridorSurfaceBaseMask Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBoundary Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class
CorridorSurfaceBoundary Class
Collapse All

A corridor surface boundary represents an outside or inside edge of a corridor surface (CorridorSurface). It is defined by a polygon or a series of feature line components (FeatureLineComponent).

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundary
C#
public class CorridorSurfaceBoundary : CorridorSurfaceBaseMask;
Visual Basic
Public Class CorridorSurfaceBoundary
Inherits CorridorSurfaceBaseMask
Links
CorridorSurfaceBoundary Properties, CorridorSurfaceBoundary Members, Class Hierarchy


CorridorSurfaceBoundary Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Members
CorridorSurfaceBoundary Members
Collapse All

The following tables list the members exposed by CorridorSurfaceBoundary.

Public Methods
Public Method | Description
PolygonPoints | Gets the points of the polygon that make up the edge of the boundary or mask.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask::Identity.
Public Properties
Public Property | Description
BoundaryType | Gets the surface boundary type.
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description.
FeatureLineComponents | Gets the collection of feature line components that make up the edge, if the border was originally defined by selecting... more
Name | Gets the name.
Links
Public Methods, Public Nested Types, Public Properties


CorridorSurfaceBoundary Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Properties
CorridorSurfaceBoundary Properties
Collapse All

The properties of CorridorSurfaceBoundary are listed here.

Public Properties
Public Property | Description
BoundaryType | Gets the surface boundary type.
Links
Public Properties


CorridorSurfaceBoundary::BoundaryType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Properties > CorridorSurfaceBoundary::BoundaryType Property
CorridorSurfaceBoundary::BoundaryType Property
Collapse All

Gets the surface boundary type.

C#
public CorridorSurfaceBoundaryType BoundaryType;
Visual Basic
Public Property BoundaryType() As CorridorSurfaceBoundaryType
Links
CorridorSurfaceBoundary Class, CorridorSurfaceBoundary Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBoundaryCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class
CorridorSurfaceBoundaryCollection Class
Collapse All

Collection of corridor surface boundary (CorridorSurfaceBoundary) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryCollection
C#
public class CorridorSurfaceBoundaryCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<CorridorSurfaceBoundary^>;
Visual Basic
Public Class CorridorSurfaceBoundaryCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<CorridorSurfaceBoundary^>
Links
CorridorSurfaceBoundaryCollection Methods, CorridorSurfaceBoundaryCollection Properties, CorridorSurfaceBoundaryCollection Nested Types, CorridorSurfaceBoundaryCollection Members, Class Hierarchy


CorridorSurfaceBoundaryCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Members
CorridorSurfaceBoundaryCollection Members
Collapse All

The following tables list the members exposed by CorridorSurfaceBoundaryCollection.

Public Methods
Public Method | Description
BoundaryNames | Gets an array of boundary names.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CorridorSurfaceBoundary objects in the collection.
default | Gets a CorridorSurfaceBoundary by name.
Links
Public Methods, Public Nested Types, Public Properties


CorridorSurfaceBoundaryCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Methods
CorridorSurfaceBoundaryCollection Methods
Collapse All

The methods of CorridorSurfaceBoundaryCollection are listed here.

Public Methods
Public Method | Description
BoundaryNames | Gets an array of boundary names.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Links
Public Methods


CorridorSurfaceBoundaryCollection::BoundaryNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Methods > CorridorSurfaceBoundaryCollection::BoundaryNames Method
CorridorSurfaceBoundaryCollection::BoundaryNames Method
Collapse All

Gets an array of boundary names.

C#
public array<System::String^> BoundaryNames();
Visual Basic
Public Function BoundaryNames() As array<System::String^>
Links
CorridorSurfaceBoundaryCollection Class, CorridorSurfaceBoundaryCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBoundaryCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Methods > CorridorSurfaceBoundaryCollection::GetEnumerator Method
CorridorSurfaceBoundaryCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<CorridorSurfaceBoundary^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<CorridorSurfaceBoundary^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
CorridorSurfaceBoundaryCollection Class, CorridorSurfaceBoundaryCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBoundaryCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Methods > CorridorSurfaceBoundaryCollection::GetObjectEnumerator Method
CorridorSurfaceBoundaryCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
CorridorSurfaceBoundaryCollection Class, CorridorSurfaceBoundaryCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBoundaryCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Properties
CorridorSurfaceBoundaryCollection Properties
Collapse All

The properties of CorridorSurfaceBoundaryCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CorridorSurfaceBoundary objects in the collection.
default | Gets a CorridorSurfaceBoundary by name.
Links
Public Properties


CorridorSurfaceBoundaryCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Properties > CorridorSurfaceBoundaryCollection::CorridorId Property
CorridorSurfaceBoundaryCollection::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorSurfaceBoundaryCollection Class, CorridorSurfaceBoundaryCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBoundaryCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Properties > CorridorSurfaceBoundaryCollection::Count Property
CorridorSurfaceBoundaryCollection::Count Property
Collapse All

Gets the number of CorridorSurfaceBoundary objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
CorridorSurfaceBoundaryCollection Class, CorridorSurfaceBoundaryCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBoundaryCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Properties > CorridorSurfaceBoundaryCollection::default Property
CorridorSurfaceBoundaryCollection::default Property
Collapse All

Gets a CorridorSurfaceBoundary by name.

C#
public CorridorSurfaceBoundary default;
Visual Basic
Public Property default() As CorridorSurfaceBoundary
Links
CorridorSurfaceBoundaryCollection Class, CorridorSurfaceBoundaryCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceBoundaryCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Nested Types
CorridorSurfaceBoundaryCollection Nested Types
Collapse All

The nested types of CorridorSurfaceBoundaryCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryCollection::Identity.
Links
Public Nested Types


CorridorSurfaceBoundaryCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Nested Types > CorridorSurfaceBoundaryCollection::Identity Nested Type
CorridorSurfaceBoundaryCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
CorridorSurfaceBoundaryCollection Class, CorridorSurfaceBoundaryCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class
CorridorSurfaceCollection Class
Collapse All

A collection of corridor surface (CorridorSurface) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceCollection
C#
public class CorridorSurfaceCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<CorridorSurface^>;
Visual Basic
Public Class CorridorSurfaceCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<CorridorSurface^>
Links
CorridorSurfaceCollection Methods, CorridorSurfaceCollection Properties, CorridorSurfaceCollection Members, Class Hierarchy


CorridorSurfaceCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Members
CorridorSurfaceCollection Members
Collapse All

The following tables list the members exposed by CorridorSurfaceCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
SurfaceNames | Gets an array of surface names from the collection.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CorridorSurface objects in the collection.
default | Gets a CorridorSurface by name.
Links
Public Methods, Public Properties


CorridorSurfaceCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Methods
CorridorSurfaceCollection Methods
Collapse All

The methods of CorridorSurfaceCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
SurfaceNames | Gets an array of surface names from the collection.
Links
Public Methods


CorridorSurfaceCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Methods > CorridorSurfaceCollection::GetEnumerator Method
CorridorSurfaceCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<CorridorSurface^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<CorridorSurface^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
CorridorSurfaceCollection Class, CorridorSurfaceCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Methods > CorridorSurfaceCollection::GetObjectEnumerator Method
CorridorSurfaceCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
CorridorSurfaceCollection Class, CorridorSurfaceCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceCollection::SurfaceNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Methods > CorridorSurfaceCollection::SurfaceNames Method
CorridorSurfaceCollection::SurfaceNames Method
Collapse All

Gets an array of surface names from the collection.

C#
public array<System::String^> SurfaceNames();
Visual Basic
Public Function SurfaceNames() As array<System::String^>
Links
CorridorSurfaceCollection Class, CorridorSurfaceCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Properties
CorridorSurfaceCollection Properties
Collapse All

The properties of CorridorSurfaceCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CorridorSurface objects in the collection.
default | Gets a CorridorSurface by name.
Links
Public Properties


CorridorSurfaceCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Properties > CorridorSurfaceCollection::CorridorId Property
CorridorSurfaceCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorSurfaceCollection Class, CorridorSurfaceCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Properties > CorridorSurfaceCollection::Count Property
CorridorSurfaceCollection::Count Property
Collapse All

Gets the number of CorridorSurface objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
CorridorSurfaceCollection Class, CorridorSurfaceCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Properties > CorridorSurfaceCollection::default Property
CorridorSurfaceCollection::default Property
Collapse All

Gets a CorridorSurface by name.

C#
public CorridorSurface default;
Visual Basic
Public Property default() As CorridorSurface
Links
CorridorSurfaceCollection Class, CorridorSurfaceCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceMask Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMask Class
CorridorSurfaceMask Class
Collapse All

The corridor surface mask is a region defined by a polygon or a series of feature line components (FeatureLineComponent) describing the part of a corridor surface (CorridorSurface) that is visible.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMask
C#
public class CorridorSurfaceMask : CorridorSurfaceBaseMask;
Visual Basic
Public Class CorridorSurfaceMask
Inherits CorridorSurfaceBaseMask
Links
Class Hierarchy


CorridorSurfaceMaskCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class
CorridorSurfaceMaskCollection Class
Collapse All

Collection of corridor surface mask (CorridorSurfaceMask) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMaskCollection
C#
public class CorridorSurfaceMaskCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<CorridorSurfaceMask^>;
Visual Basic
Public Class CorridorSurfaceMaskCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<CorridorSurfaceMask^>
Links
CorridorSurfaceMaskCollection Methods, CorridorSurfaceMaskCollection Properties, CorridorSurfaceMaskCollection Nested Types, CorridorSurfaceMaskCollection Members, Class Hierarchy


CorridorSurfaceMaskCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Members
CorridorSurfaceMaskCollection Members
Collapse All

The following tables list the members exposed by CorridorSurfaceMaskCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
MaskNames | Gets an array of mask names.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMaskCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CorridorSurfaceMask objects in the collection.
default | Gets a CorridorSurfaceMask object by name.
Links
Public Methods, Public Nested Types, Public Properties


CorridorSurfaceMaskCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Methods
CorridorSurfaceMaskCollection Methods
Collapse All

The methods of CorridorSurfaceMaskCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
MaskNames | Gets an array of mask names.
Links
Public Methods


CorridorSurfaceMaskCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Methods > CorridorSurfaceMaskCollection::GetEnumerator Method
CorridorSurfaceMaskCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<CorridorSurfaceMask^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<CorridorSurfaceMask^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
CorridorSurfaceMaskCollection Class, CorridorSurfaceMaskCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceMaskCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Methods > CorridorSurfaceMaskCollection::GetObjectEnumerator Method
CorridorSurfaceMaskCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
CorridorSurfaceMaskCollection Class, CorridorSurfaceMaskCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceMaskCollection::MaskNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Methods > CorridorSurfaceMaskCollection::MaskNames Method
CorridorSurfaceMaskCollection::MaskNames Method
Collapse All

Gets an array of mask names.

C#
public array<System::String^> MaskNames();
Visual Basic
Public Function MaskNames() As array<System::String^>
Links
CorridorSurfaceMaskCollection Class, CorridorSurfaceMaskCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceMaskCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Properties
CorridorSurfaceMaskCollection Properties
Collapse All

The properties of CorridorSurfaceMaskCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CorridorSurfaceMask objects in the collection.
default | Gets a CorridorSurfaceMask object by name.
Links
Public Properties


CorridorSurfaceMaskCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Properties > CorridorSurfaceMaskCollection::CorridorId Property
CorridorSurfaceMaskCollection::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorSurfaceMaskCollection Class, CorridorSurfaceMaskCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceMaskCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Properties > CorridorSurfaceMaskCollection::Count Property
CorridorSurfaceMaskCollection::Count Property
Collapse All

Gets the number of CorridorSurfaceMask objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
CorridorSurfaceMaskCollection Class, CorridorSurfaceMaskCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceMaskCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Properties > CorridorSurfaceMaskCollection::default Property
CorridorSurfaceMaskCollection::default Property
Collapse All

Gets a CorridorSurfaceMask object by name.

C#
public CorridorSurfaceMask default;
Visual Basic
Public Property default() As CorridorSurfaceMask
Links
CorridorSurfaceMaskCollection Class, CorridorSurfaceMaskCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


CorridorSurfaceMaskCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Nested Types
CorridorSurfaceMaskCollection Nested Types
Collapse All

The nested types of CorridorSurfaceMaskCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMaskCollection::Identity.
Links
Public Nested Types


CorridorSurfaceMaskCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Nested Types > CorridorSurfaceMaskCollection::Identity Nested Type
CorridorSurfaceMaskCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMaskCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
CorridorSurfaceMaskCollection Class, CorridorSurfaceMaskCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLine Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class
FeatureLine Class
Collapse All

A feature line is a connected series of points along a corridor created by joining those points from each assembly that share a particular code. Feature lines are used to build the 3D model of a corridor.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLine
C#
public class FeatureLine : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class FeatureLine
Inherits CivilWrapper<AeccDbCorridor>
Example
// Get all the main feature lines:
foreach (FeatureLineCollection oFeatureLineCollection in oBaseline.MainBaselineFeatureLines.FeatureLineCollectionMap)
{
   ed.WriteMessage("Feature Line Collectionn# Lines in collection: {0}n",
       oFeatureLineCollection.Count);
   foreach (Autodesk.Civil.Roadway.DatabaseServices.FeatureLine oFeatureLine in oFeatureLineCollection)
   {
       ed.WriteMessage("Feature line code: {0}n", oFeatureLine.CodeName);
       // print out all point locations on the feature line
       foreach (FeatureLinePoint oFeatureLinePoint in oFeatureLine.FeatureLinePoints)
       {
           ed.WriteMessage("Point: {0},{1},{2}n",
               oFeatureLinePoint.XYZ.X,
               oFeatureLinePoint.XYZ.Y,
               oFeatureLinePoint.XYZ.Z);
       }
   }
}
Links
FeatureLine Properties, FeatureLine Nested Types, FeatureLine Members, Class Hierarchy


FeatureLine Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Members
FeatureLine Members
Collapse All

The following tables list the members exposed by FeatureLine.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLine::Identity.
Public Properties
Public Property | Description
CodeName | Gets the code name used to construct the feature line.
CorridorId | Gets the ObjectId of the parent Corridor.
FeatureLinePoints | Gets the collection of all points that make up the feature line.
StyleId | Gets or Sets the FeatureLine's style Id.
StyleName | Gets or Sets the FeatureLine's style name.
Links
Public Nested Types, Public Properties


FeatureLine Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Properties
FeatureLine Properties
Collapse All

The properties of FeatureLine are listed here.

Public Properties
Public Property | Description
CodeName | Gets the code name used to construct the feature line.
CorridorId | Gets the ObjectId of the parent Corridor.
FeatureLinePoints | Gets the collection of all points that make up the feature line.
StyleId | Gets or Sets the FeatureLine's style Id.
StyleName | Gets or Sets the FeatureLine's style name.
Links
Public Properties


FeatureLine::CodeName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Properties > FeatureLine::CodeName Property
FeatureLine::CodeName Property
Collapse All

Gets the code name used to construct the feature line.

C#
public System::String CodeName;
Visual Basic
Public Property CodeName() As System::String
Links
FeatureLine Class, FeatureLine Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLine::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Properties > FeatureLine::CorridorId Property
FeatureLine::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
FeatureLine Class, FeatureLine Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLine::FeatureLinePoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Properties > FeatureLine::FeatureLinePoints Property
FeatureLine::FeatureLinePoints Property
Collapse All

Gets the collection of all points that make up the feature line.

C#
public FeatureLinePointCollection FeatureLinePoints;
Visual Basic
Public Property FeatureLinePoints() As FeatureLinePointCollection
Links
FeatureLine Class, FeatureLine Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLine::StyleId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Properties > FeatureLine::StyleId Property
FeatureLine::StyleId Property
Collapse All

Gets or Sets the FeatureLine's style Id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId StyleId;
Visual Basic
Public Property StyleId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.DatabaseServices.Styles.FeatureLineStyle

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style Id is invalid.
Links
FeatureLine Class, FeatureLine Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLine::StyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Properties > FeatureLine::StyleName Property
FeatureLine::StyleName Property
Collapse All

Gets or Sets the FeatureLine's style name.

C#
public System::String StyleName;
Visual Basic
Public Property StyleName() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the style name is invalid.
Links
FeatureLine Class, FeatureLine Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLine Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Nested Types
FeatureLine Nested Types
Collapse All

The nested types of FeatureLine are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLine::Identity.
Links
Public Nested Types


FeatureLine::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Nested Types > FeatureLine::Identity Nested Type
FeatureLine::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLine::Identity.

C#
Identity
Visual Basic
Identity
Links
FeatureLine Class, FeatureLine Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfo Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class
FeatureLineCodeInfo Class
Collapse All

Information about the code used to construct a feature line.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfo
C#
public class FeatureLineCodeInfo : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class FeatureLineCodeInfo
Inherits CivilWrapper<AeccDbCorridor>
Links
FeatureLineCodeInfo Properties, FeatureLineCodeInfo Nested Types, FeatureLineCodeInfo Members, Class Hierarchy


FeatureLineCodeInfo Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Members
FeatureLineCodeInfo Members
Collapse All

The following tables list the members exposed by FeatureLineCodeInfo.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfo::Identity.
Public Properties
Public Property | Description
CodeName | Gets the code name.
CorridorId | Gets the ID of the parent Corridor.
IsConnect | Returns True if the feature line connects to multiple points in the same applied assembly if those points share the... more
IsDraw | Returns true if the feature line is drawn.
Links
Public Nested Types, Public Properties


FeatureLineCodeInfo Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Properties
FeatureLineCodeInfo Properties
Collapse All

The properties of FeatureLineCodeInfo are listed here.

Public Properties
Public Property | Description
CodeName | Gets the code name.
CorridorId | Gets the ID of the parent Corridor.
IsConnect | Returns True if the feature line connects to multiple points in the same applied assembly if those points share the... more
IsDraw | Returns true if the feature line is drawn.
Links
Public Properties


FeatureLineCodeInfo::CodeName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Properties > FeatureLineCodeInfo::CodeName Property
FeatureLineCodeInfo::CodeName Property
Collapse All

Gets the code name.

C#
public System::String CodeName;
Visual Basic
Public Property CodeName() As System::String
Links
FeatureLineCodeInfo Class, FeatureLineCodeInfo Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfo::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Properties > FeatureLineCodeInfo::CorridorId Property
FeatureLineCodeInfo::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
FeatureLineCodeInfo Class, FeatureLineCodeInfo Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfo::IsConnect Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Properties > FeatureLineCodeInfo::IsConnect Property
FeatureLineCodeInfo::IsConnect Property
Collapse All

Returns True if the feature line connects to multiple points in the same applied assembly if those points share the same code.

C#
public bool IsConnect;
Visual Basic
Public Property IsConnect() As bool
Links
FeatureLineCodeInfo Class, FeatureLineCodeInfo Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfo::IsDraw Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Properties > FeatureLineCodeInfo::IsDraw Property
FeatureLineCodeInfo::IsDraw Property
Collapse All

Returns true if the feature line is drawn.

C#
public bool IsDraw;
Visual Basic
Public Property IsDraw() As bool
Links
FeatureLineCodeInfo Class, FeatureLineCodeInfo Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfo Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Nested Types
FeatureLineCodeInfo Nested Types
Collapse All

The nested types of FeatureLineCodeInfo are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfo::Identity.
Links
Public Nested Types


FeatureLineCodeInfo::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Nested Types > FeatureLineCodeInfo::Identity Nested Type
FeatureLineCodeInfo::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfo::Identity.

C#
Identity
Visual Basic
Identity
Links
FeatureLineCodeInfo Class, FeatureLineCodeInfo Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfoCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class
FeatureLineCodeInfoCollection Class
Collapse All

A collection of feature line code information (FeatureLineCodeInfo) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfoCollection
C#
public class FeatureLineCodeInfoCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<FeatureLineCodeInfo^>;
Visual Basic
Public Class FeatureLineCodeInfoCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<FeatureLineCodeInfo^>
Links
FeatureLineCodeInfoCollection Methods, FeatureLineCodeInfoCollection Properties, FeatureLineCodeInfoCollection Members, Class Hierarchy


FeatureLineCodeInfoCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Members
FeatureLineCodeInfoCollection Members
Collapse All

The following tables list the members exposed by FeatureLineCodeInfoCollection.

Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineCodeInfo objects in the collection.
default | Gets a FeatureLineCodeInfo by name.
Links
Public Methods, Public Properties


FeatureLineCodeInfoCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Methods
FeatureLineCodeInfoCollection Methods
Collapse All

The methods of FeatureLineCodeInfoCollection are listed here.

Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Links
Public Methods


FeatureLineCodeInfoCollection::CodeNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Methods > FeatureLineCodeInfoCollection::CodeNames Method
FeatureLineCodeInfoCollection::CodeNames Method
Collapse All

Gets a list of code names in the collection.

C#
public array<System::String^> CodeNames();
Visual Basic
Public Function CodeNames() As array<System::String^>
Links
FeatureLineCodeInfoCollection Class, FeatureLineCodeInfoCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfoCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Methods > FeatureLineCodeInfoCollection::GetEnumerator Method
FeatureLineCodeInfoCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<FeatureLineCodeInfo^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<FeatureLineCodeInfo^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
FeatureLineCodeInfoCollection Class, FeatureLineCodeInfoCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfoCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Methods > FeatureLineCodeInfoCollection::GetObjectEnumerator Method
FeatureLineCodeInfoCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
FeatureLineCodeInfoCollection Class, FeatureLineCodeInfoCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfoCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Properties
FeatureLineCodeInfoCollection Properties
Collapse All

The properties of FeatureLineCodeInfoCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineCodeInfo objects in the collection.
default | Gets a FeatureLineCodeInfo by name.
Links
Public Properties


FeatureLineCodeInfoCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Properties > FeatureLineCodeInfoCollection::CorridorId Property
FeatureLineCodeInfoCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
FeatureLineCodeInfoCollection Class, FeatureLineCodeInfoCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfoCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Properties > FeatureLineCodeInfoCollection::Count Property
FeatureLineCodeInfoCollection::Count Property
Collapse All

Gets the number of FeatureLineCodeInfo objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
FeatureLineCodeInfoCollection Class, FeatureLineCodeInfoCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCodeInfoCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Properties > FeatureLineCodeInfoCollection::default Property
FeatureLineCodeInfoCollection::default Property
Collapse All

Gets a FeatureLineCodeInfo by name.

C#
public FeatureLineCodeInfo default;
Visual Basic
Public Property default() As FeatureLineCodeInfo
Links
FeatureLineCodeInfoCollection Class, FeatureLineCodeInfoCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class
FeatureLineCollection Class
Collapse All

Collection of feature lines that share a particular code. Multiple points in a single assembly may contain the same code, so feature lines can branch along a corridor. This collection represents a single interconnected series of feature lines branches.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollection
C#
public class FeatureLineCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<FeatureLine^>;
Visual Basic
Public Class FeatureLineCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<FeatureLine^>
Links
FeatureLineCollection Methods, FeatureLineCollection Properties, FeatureLineCollection Nested Types, FeatureLineCollection Members, Class Hierarchy


FeatureLineCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Members
FeatureLineCollection Members
Collapse All

The following tables list the members exposed by FeatureLineCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of FeatureLine objects in this collection.
default | Gets the default FeatureLine object in this collection.
FeatureLineCodeInfo | Gets the object that contains information about the code used to construct the FeatureLine.
Links
Public Methods, Public Nested Types, Public Properties


FeatureLineCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Methods
FeatureLineCollection Methods
Collapse All

The methods of FeatureLineCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Links
Public Methods


FeatureLineCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Methods > FeatureLineCollection::GetEnumerator Method
FeatureLineCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<FeatureLine^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<FeatureLine^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
FeatureLineCollection Class, FeatureLineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Methods > FeatureLineCollection::GetObjectEnumerator Method
FeatureLineCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
FeatureLineCollection Class, FeatureLineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Properties
FeatureLineCollection Properties
Collapse All

The properties of FeatureLineCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of FeatureLine objects in this collection.
default | Gets the default FeatureLine object in this collection.
FeatureLineCodeInfo | Gets the object that contains information about the code used to construct the FeatureLine.
Links
Public Properties


FeatureLineCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Properties > FeatureLineCollection::CorridorId Property
FeatureLineCollection::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
FeatureLineCollection Class, FeatureLineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Properties > FeatureLineCollection::Count Property
FeatureLineCollection::Count Property
Collapse All

Gets the number of FeatureLine objects in this collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
FeatureLineCollection Class, FeatureLineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Properties > FeatureLineCollection::default Property
FeatureLineCollection::default Property
Collapse All

Gets the default FeatureLine object in this collection.

C#
public FeatureLine default;
Visual Basic
Public Property default() As FeatureLine
Links
FeatureLineCollection Class, FeatureLineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollection::FeatureLineCodeInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Properties > FeatureLineCollection::FeatureLineCodeInfo Property
FeatureLineCollection::FeatureLineCodeInfo Property
Collapse All

Gets the object that contains information about the code used to construct the FeatureLine.

C#
public Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfo FeatureLineCodeInfo;
Visual Basic
Public Property FeatureLineCodeInfo() As Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfo
Links
FeatureLineCollection Class, FeatureLineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Nested Types
FeatureLineCollection Nested Types
Collapse All

The nested types of FeatureLineCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollection::Identity.
Links
Public Nested Types


FeatureLineCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Nested Types > FeatureLineCollection::Identity Nested Type
FeatureLineCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
FeatureLineCollection Class, FeatureLineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollectionMap Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class
FeatureLineCollectionMap Class
Collapse All

A collection of multiple feature line collections (FeatureLineCollection) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollectionMap
C#
public class FeatureLineCollectionMap : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<FeatureLineCollection^>;
Visual Basic
Public Class FeatureLineCollectionMap
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<FeatureLineCollection^>
Links
FeatureLineCollectionMap Methods, FeatureLineCollectionMap Properties, FeatureLineCollectionMap Nested Types, FeatureLineCollectionMap Members, Class Hierarchy


FeatureLineCollectionMap Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Members
FeatureLineCollectionMap Members
Collapse All

The following tables list the members exposed by FeatureLineCollectionMap.

Public Methods
Public Method | Description
CodeNames | Gets an array of code names used in all feature lines in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollectionMap::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineCollection objects in the collection.
default | Gets a FeatureLineCollection from the collection by name.
Links
Public Methods, Public Nested Types, Public Properties


FeatureLineCollectionMap Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Methods
FeatureLineCollectionMap Methods
Collapse All

The methods of FeatureLineCollectionMap are listed here.

Public Methods
Public Method | Description
CodeNames | Gets an array of code names used in all feature lines in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Links
Public Methods


FeatureLineCollectionMap::CodeNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Methods > FeatureLineCollectionMap::CodeNames Method
FeatureLineCollectionMap::CodeNames Method
Collapse All

Gets an array of code names used in all feature lines in the collection.

C#
public array<System::String^> CodeNames();
Visual Basic
Public Function CodeNames() As array<System::String^>
Links
FeatureLineCollectionMap Class, FeatureLineCollectionMap Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollectionMap::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Methods > FeatureLineCollectionMap::GetEnumerator Method
FeatureLineCollectionMap::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<FeatureLineCollection^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<FeatureLineCollection^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
FeatureLineCollectionMap Class, FeatureLineCollectionMap Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollectionMap::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Methods > FeatureLineCollectionMap::GetObjectEnumerator Method
FeatureLineCollectionMap::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
FeatureLineCollectionMap Class, FeatureLineCollectionMap Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollectionMap Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Properties
FeatureLineCollectionMap Properties
Collapse All

The properties of FeatureLineCollectionMap are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineCollection objects in the collection.
default | Gets a FeatureLineCollection from the collection by name.
Links
Public Properties


FeatureLineCollectionMap::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Properties > FeatureLineCollectionMap::CorridorId Property
FeatureLineCollectionMap::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
FeatureLineCollectionMap Class, FeatureLineCollectionMap Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollectionMap::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Properties > FeatureLineCollectionMap::Count Property
FeatureLineCollectionMap::Count Property
Collapse All

Gets the number of FeatureLineCollection objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
FeatureLineCollectionMap Class, FeatureLineCollectionMap Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollectionMap::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Properties > FeatureLineCollectionMap::default Property
FeatureLineCollectionMap::default Property
Collapse All

Gets a FeatureLineCollection from the collection by name.

C#
public FeatureLineCollection default;
Visual Basic
Public Property default() As FeatureLineCollection
Links
FeatureLineCollectionMap Class, FeatureLineCollectionMap Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineCollectionMap Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Nested Types
FeatureLineCollectionMap Nested Types
Collapse All

The nested types of FeatureLineCollectionMap are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollectionMap::Identity.
Links
Public Nested Types


FeatureLineCollectionMap::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Nested Types > FeatureLineCollectionMap::Identity Nested Type
FeatureLineCollectionMap::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollectionMap::Identity.

C#
Identity
Visual Basic
Identity
Links
FeatureLineCollectionMap Class, FeatureLineCollectionMap Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponent Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class
FeatureLineComponent Class
Collapse All

A portion of an entire feature line, delimited by a starting and ending station.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponent
C#
public class FeatureLineComponent : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class FeatureLineComponent
Inherits CivilWrapper<AeccDbCorridor>
Links
FeatureLineComponent Properties, FeatureLineComponent Nested Types, FeatureLineComponent Members, Class Hierarchy


FeatureLineComponent Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Members
FeatureLineComponent Members
Collapse All

The following tables list the members exposed by FeatureLineComponent.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponent::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the parent Corridor Id.
EndStation | Gets the end station.
FeatureLine | Gets the parent FeatureLine object.
IsReversed | Returns True if the station values have been reversed.
StartStation | Gets the start station.
UseEndStation | Returns true if the end station is used.
UseStartStation | Returns true if the start station is used.
Links
Public Nested Types, Public Properties


FeatureLineComponent Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties
FeatureLineComponent Properties
Collapse All

The properties of FeatureLineComponent are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the parent Corridor Id.
EndStation | Gets the end station.
FeatureLine | Gets the parent FeatureLine object.
IsReversed | Returns True if the station values have been reversed.
StartStation | Gets the start station.
UseEndStation | Returns true if the end station is used.
UseStartStation | Returns true if the start station is used.
Links
Public Properties


FeatureLineComponent::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties > FeatureLineComponent::CorridorId Property
FeatureLineComponent::CorridorId Property
Collapse All

Gets the parent Corridor Id.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
FeatureLineComponent Class, FeatureLineComponent Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponent::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties > FeatureLineComponent::EndStation Property
FeatureLineComponent::EndStation Property
Collapse All

Gets the end station.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
FeatureLineComponent Class, FeatureLineComponent Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponent::FeatureLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties > FeatureLineComponent::FeatureLine Property
FeatureLineComponent::FeatureLine Property
Collapse All

Gets the parent FeatureLine object.

C#
public Autodesk::Civil::Roadway::DatabaseServices::FeatureLine FeatureLine;
Visual Basic
Public Property FeatureLine() As Autodesk::Civil::Roadway::DatabaseServices::FeatureLine
Links
FeatureLineComponent Class, FeatureLineComponent Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponent::IsReversed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties > FeatureLineComponent::IsReversed Property
FeatureLineComponent::IsReversed Property
Collapse All

Returns True if the station values have been reversed.

C#
public bool IsReversed;
Visual Basic
Public Property IsReversed() As bool
Links
FeatureLineComponent Class, FeatureLineComponent Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponent::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties > FeatureLineComponent::StartStation Property
FeatureLineComponent::StartStation Property
Collapse All

Gets the start station.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
FeatureLineComponent Class, FeatureLineComponent Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponent::UseEndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties > FeatureLineComponent::UseEndStation Property
FeatureLineComponent::UseEndStation Property
Collapse All

Returns true if the end station is used.

C#
public bool UseEndStation;
Visual Basic
Public Property UseEndStation() As bool
Links
FeatureLineComponent Class, FeatureLineComponent Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponent::UseStartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties > FeatureLineComponent::UseStartStation Property
FeatureLineComponent::UseStartStation Property
Collapse All

Returns true if the start station is used.

C#
public bool UseStartStation;
Visual Basic
Public Property UseStartStation() As bool
Links
FeatureLineComponent Class, FeatureLineComponent Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponent Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Nested Types
FeatureLineComponent Nested Types
Collapse All

The nested types of FeatureLineComponent are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponent::Identity.
Links
Public Nested Types


FeatureLineComponent::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Nested Types > FeatureLineComponent::Identity Nested Type
FeatureLineComponent::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponent::Identity.

C#
Identity
Visual Basic
Identity
Links
FeatureLineComponent Class, FeatureLineComponent Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponentCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class
FeatureLineComponentCollection Class
Collapse All

A collection of feature line component (FeatureLineComponent) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponentCollection
C#
public class FeatureLineComponentCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<FeatureLineComponent^>;
Visual Basic
Public Class FeatureLineComponentCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<FeatureLineComponent^>
Links
FeatureLineComponentCollection Methods, FeatureLineComponentCollection Properties, FeatureLineComponentCollection Nested Types, FeatureLineComponentCollection Members, Class Hierarchy


FeatureLineComponentCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Members
FeatureLineComponentCollection Members
Collapse All

The following tables list the members exposed by FeatureLineComponentCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponentCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineComponent objects in the collection.
default | Gets a FeatureLineComponent by index.
Links
Public Methods, Public Nested Types, Public Properties


FeatureLineComponentCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Methods
FeatureLineComponentCollection Methods
Collapse All

The methods of FeatureLineComponentCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Links
Public Methods


FeatureLineComponentCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Methods > FeatureLineComponentCollection::GetEnumerator Method
FeatureLineComponentCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<FeatureLineComponent^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<FeatureLineComponent^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
FeatureLineComponentCollection Class, FeatureLineComponentCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponentCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Methods > FeatureLineComponentCollection::GetObjectEnumerator Method
FeatureLineComponentCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
FeatureLineComponentCollection Class, FeatureLineComponentCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponentCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Properties
FeatureLineComponentCollection Properties
Collapse All

The properties of FeatureLineComponentCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineComponent objects in the collection.
default | Gets a FeatureLineComponent by index.
Links
Public Properties


FeatureLineComponentCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Properties > FeatureLineComponentCollection::CorridorId Property
FeatureLineComponentCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
FeatureLineComponentCollection Class, FeatureLineComponentCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponentCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Properties > FeatureLineComponentCollection::Count Property
FeatureLineComponentCollection::Count Property
Collapse All

Gets the number of FeatureLineComponent objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
FeatureLineComponentCollection Class, FeatureLineComponentCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponentCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Properties > FeatureLineComponentCollection::default Property
FeatureLineComponentCollection::default Property
Collapse All

Gets a FeatureLineComponent by index.

C#
public FeatureLineComponent default;
Visual Basic
Public Property default() As FeatureLineComponent
Links
FeatureLineComponentCollection Class, FeatureLineComponentCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLineComponentCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Nested Types
FeatureLineComponentCollection Nested Types
Collapse All

The nested types of FeatureLineComponentCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponentCollection::Identity.
Links
Public Nested Types


FeatureLineComponentCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Nested Types > FeatureLineComponentCollection::Identity Nested Type
FeatureLineComponentCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponentCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
FeatureLineComponentCollection Class, FeatureLineComponentCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePoint Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class
FeatureLinePoint Class
Collapse All

A point in a feature line (FeatureLine object). A feature line is created by connecting common points within applied assemblies (AppliedAssembly objects) along a corridor. Points in each applied assembly are identified by codes. For example, a feature line can represent the inside upper edge of a sidewalk along a stretch of road.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePoint
C#
public class FeatureLinePoint : CivilWrapper<AeccDbCorridor>;
Visual Basic
Public Class FeatureLinePoint
Inherits CivilWrapper<AeccDbCorridor>
Links
FeatureLinePoint Properties, FeatureLinePoint Nested Types, FeatureLinePoint Members, Class Hierarchy


FeatureLinePoint Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Members
FeatureLinePoint Members
Collapse All

The following tables list the members exposed by FeatureLinePoint.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePoint::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
IsBreak | Gets the IsBreak value of this point.
Station | Gets the station of the assembly containing this point.
XYZ | Gets the coordinates of this point.
Links
Public Nested Types, Public Properties


FeatureLinePoint Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Properties
FeatureLinePoint Properties
Collapse All

The properties of FeatureLinePoint are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
IsBreak | Gets the IsBreak value of this point.
Station | Gets the station of the assembly containing this point.
XYZ | Gets the coordinates of this point.
Links
Public Properties


FeatureLinePoint::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Properties > FeatureLinePoint::CorridorId Property
FeatureLinePoint::CorridorId Property
Collapse All

Gets the ID of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
FeatureLinePoint Class, FeatureLinePoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePoint::IsBreak Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Properties > FeatureLinePoint::IsBreak Property
FeatureLinePoint::IsBreak Property
Collapse All

Gets the IsBreak value of this point.

C#
public bool IsBreak;
Visual Basic
Public Property IsBreak() As bool
Links
FeatureLinePoint Class, FeatureLinePoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePoint::Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Properties > FeatureLinePoint::Station Property
FeatureLinePoint::Station Property
Collapse All

Gets the station of the assembly containing this point.

C#
public double Station;
Visual Basic
Public Property Station() As double
Links
FeatureLinePoint Class, FeatureLinePoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePoint::XYZ Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Properties > FeatureLinePoint::XYZ Property
FeatureLinePoint::XYZ Property
Collapse All

Gets the coordinates of this point.

C#
public Autodesk::AutoCAD::Geometry::Point3d XYZ;
Visual Basic
Public Property XYZ() As Autodesk::AutoCAD::Geometry::Point3d
Links
FeatureLinePoint Class, FeatureLinePoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePoint Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Nested Types
FeatureLinePoint Nested Types
Collapse All

The nested types of FeatureLinePoint are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePoint::Identity.
Links
Public Nested Types


FeatureLinePoint::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Nested Types > FeatureLinePoint::Identity Nested Type
FeatureLinePoint::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePoint::Identity.

C#
Identity
Visual Basic
Identity
Links
FeatureLinePoint Class, FeatureLinePoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePointCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class
FeatureLinePointCollection Class
Collapse All

A collection of feature line point (FeatureLinePoint) objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePointCollection
C#
public class FeatureLinePointCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<FeatureLinePoint^>;
Visual Basic
Public Class FeatureLinePointCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<FeatureLinePoint^>
Links
FeatureLinePointCollection Methods, FeatureLinePointCollection Properties, FeatureLinePointCollection Nested Types, FeatureLinePointCollection Members, Class Hierarchy


FeatureLinePointCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Members
FeatureLinePointCollection Members
Collapse All

The following tables list the members exposed by FeatureLinePointCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePointCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLinePoint objects in the collection.
default | Gets a FeatureLinePoint by index.
Links
Public Methods, Public Nested Types, Public Properties


FeatureLinePointCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Methods
FeatureLinePointCollection Methods
Collapse All

The methods of FeatureLinePointCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Links
Public Methods


FeatureLinePointCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Methods > FeatureLinePointCollection::GetEnumerator Method
FeatureLinePointCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<FeatureLinePoint^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<FeatureLinePoint^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
FeatureLinePointCollection Class, FeatureLinePointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePointCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Methods > FeatureLinePointCollection::GetObjectEnumerator Method
FeatureLinePointCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
FeatureLinePointCollection Class, FeatureLinePointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePointCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Properties
FeatureLinePointCollection Properties
Collapse All

The properties of FeatureLinePointCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLinePoint objects in the collection.
default | Gets a FeatureLinePoint by index.
Links
Public Properties


FeatureLinePointCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Properties > FeatureLinePointCollection::CorridorId Property
FeatureLinePointCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
FeatureLinePointCollection Class, FeatureLinePointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePointCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Properties > FeatureLinePointCollection::Count Property
FeatureLinePointCollection::Count Property
Collapse All

Gets the number of FeatureLinePoint objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
FeatureLinePointCollection Class, FeatureLinePointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePointCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Properties > FeatureLinePointCollection::default Property
FeatureLinePointCollection::default Property
Collapse All

Gets a FeatureLinePoint by index.

C#
public FeatureLinePoint default;
Visual Basic
Public Property default() As FeatureLinePoint
Links
FeatureLinePointCollection Class, FeatureLinePointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


FeatureLinePointCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Nested Types
FeatureLinePointCollection Nested Types
Collapse All

The nested types of FeatureLinePointCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePointCollection::Identity.
Links
Public Nested Types


FeatureLinePointCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Nested Types > FeatureLinePointCollection::Identity Nested Type
FeatureLinePointCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePointCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
FeatureLinePointCollection Class, FeatureLinePointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class
HardcodedOffsetBaseline Class
Collapse All

An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between this kind offset baseline and the main baseline is a constant. These are used to create complicated corridor structures or to attach assemblies to a point outside the main baseline of a corridor.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaseBaseline
    Autodesk::Civil::Roadway::DatabaseServices::HardcodedOffsetBaseline
C#
public class HardcodedOffsetBaseline : BaseBaseline;
Visual Basic
Public Class HardcodedOffsetBaseline
Inherits BaseBaseline
Links
HardcodedOffsetBaseline Methods, HardcodedOffsetBaseline Properties, HardcodedOffsetBaseline Nested Types, HardcodedOffsetBaseline Members, Class Hierarchy


HardcodedOffsetBaseline Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Members
HardcodedOffsetBaseline Members
Collapse All

The following tables list the members exposed by HardcodedOffsetBaseline.

Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::HardcodedOffsetBaseline::Identity.
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
Name | Gets the name of the HardcodedOffsetBaseline.
OffsetElevationFromMainBaseline | Gets the offset elevation from the main Baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
RelatedOffsetBaselineFeatureLines | Gets related offset baseline featurelines.
StartStation | Gets the starting station for this baseline.
Links
Public Methods, Public Nested Types, Public Properties


HardcodedOffsetBaseline Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Methods
HardcodedOffsetBaseline Methods
Collapse All

The methods of HardcodedOffsetBaseline are listed here.

Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
Links
Public Methods


HardcodedOffsetBaseline::SortedStations Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Methods > HardcodedOffsetBaseline::SortedStations Method
HardcodedOffsetBaseline::SortedStations Method
Collapse All

Gets the sorted stations for the baseline.

C#
public array<double> SortedStations();
Visual Basic
Public Function SortedStations() As array<double>
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties
HardcodedOffsetBaseline Properties
Collapse All

The properties of HardcodedOffsetBaseline are listed here.

Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
EndStation | Gets the end station for this baseline.
Name | Gets the name of the HardcodedOffsetBaseline.
OffsetElevationFromMainBaseline | Gets the offset elevation from the main Baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
RelatedOffsetBaselineFeatureLines | Gets related offset baseline featurelines.
StartStation | Gets the starting station for this baseline.
Links
Public Properties


HardcodedOffsetBaseline::AlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties > HardcodedOffsetBaseline::AlignmentId Property
HardcodedOffsetBaseline::AlignmentId Property
Collapse All

Gets the ID of the Alignment this baseline is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AlignmentId;
Visual Basic
Public Property AlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline::BaselineType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties > HardcodedOffsetBaseline::BaselineType Property
HardcodedOffsetBaseline::BaselineType Property
Collapse All

Gets the baseline type.

C#
public CorridorBaselineType BaselineType;
Visual Basic
Public Property BaselineType() As CorridorBaselineType
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties > HardcodedOffsetBaseline::EndStation Property
HardcodedOffsetBaseline::EndStation Property
Collapse All

Gets the end station for this baseline.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties > HardcodedOffsetBaseline::Name Property
HardcodedOffsetBaseline::Name Property
Collapse All

Gets the name of the HardcodedOffsetBaseline.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline::OffsetElevationFromMainBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties > HardcodedOffsetBaseline::OffsetElevationFromMainBaseline Property
HardcodedOffsetBaseline::OffsetElevationFromMainBaseline Property
Collapse All

Gets the offset elevation from the main Baseline.

C#
public Autodesk::AutoCAD::Geometry::Point2d OffsetElevationFromMainBaseline;
Visual Basic
Public Property OffsetElevationFromMainBaseline() As Autodesk::AutoCAD::Geometry::Point2d
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline::ProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties > HardcodedOffsetBaseline::ProfileId Property
HardcodedOffsetBaseline::ProfileId Property
Collapse All

Gets the ID of the Profile this baseline is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileId;
Visual Basic
Public Property ProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline::RelatedOffsetBaselineFeatureLines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties > HardcodedOffsetBaseline::RelatedOffsetBaselineFeatureLines Property
HardcodedOffsetBaseline::RelatedOffsetBaselineFeatureLines Property
Collapse All

Gets related offset baseline featurelines.

C#
public BaselineFeatureLines RelatedOffsetBaselineFeatureLines;
Visual Basic
Public Property RelatedOffsetBaselineFeatureLines() As BaselineFeatureLines
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties > HardcodedOffsetBaseline::StartStation Property
HardcodedOffsetBaseline::StartStation Property
Collapse All

Gets the starting station for this baseline.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


HardcodedOffsetBaseline Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Nested Types
HardcodedOffsetBaseline Nested Types
Collapse All

The nested types of HardcodedOffsetBaseline are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::HardcodedOffsetBaseline::Identity.
Links
Public Nested Types


HardcodedOffsetBaseline::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Nested Types > HardcodedOffsetBaseline::Identity Nested Type
HardcodedOffsetBaseline::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::HardcodedOffsetBaseline::Identity.

C#
Identity
Visual Basic
Identity
Links
HardcodedOffsetBaseline Class, HardcodedOffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Intersection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class
Intersection Class
Collapse All

An object that manages the intersection of two Alignments. An intersection object builds on and manages various object data, including alignments, profiles, corridors, assemblies, subassemblies, and surfaces.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Roadway::DatabaseServices::Intersection
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbIntersection"))]
public class Intersection : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbIntersection"))>
Public Class Intersection
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
Intersection Properties, Intersection Members, Class Hierarchy


Intersection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Members
Intersection Members
Collapse All

The following tables list the members exposed by Intersection.

Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
CorridorId | Gets or sets the object id of the corresponding corridor.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GradeRuleType | Gets or sets the grade rule type.
IntersectionRegions | Gets the regions of this Intersection.
IntersectionRoads | Gets the roads of this Intersection.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Location | Gets the location of the intersection.
Name | Gets or sets the Entity object's name.
RoadwayDrivingDirection | Gets or sets the direction of roadway driving.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
Links
Public Properties


Intersection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Properties
Intersection Properties
Collapse All

The properties of Intersection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets or sets the object id of the corresponding corridor.
GradeRuleType | Gets or sets the grade rule type.
IntersectionRegions | Gets the regions of this Intersection.
IntersectionRoads | Gets the roads of this Intersection.
Location | Gets the location of the intersection.
RoadwayDrivingDirection | Gets or sets the direction of roadway driving.
Links
Public Properties


Intersection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Properties > Intersection::CorridorId Property
Intersection::CorridorId Property
Collapse All

Gets or sets the object id of the corresponding corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Intersection Class, Intersection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Intersection::GradeRuleType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Properties > Intersection::GradeRuleType Property
Intersection::GradeRuleType Property
Collapse All

Gets or sets the grade rule type.

C#
public IntersectionCorridorType GradeRuleType;
Visual Basic
Public Property GradeRuleType() As IntersectionCorridorType
Links
Intersection Class, Intersection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Intersection::IntersectionRegions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Properties > Intersection::IntersectionRegions Property
Intersection::IntersectionRegions Property
Collapse All

Gets the regions of this Intersection.

C#
public IntersectionRegionCollection IntersectionRegions;
Visual Basic
Public Property IntersectionRegions() As IntersectionRegionCollection
Links
Intersection Class, Intersection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Intersection::IntersectionRoads Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Properties > Intersection::IntersectionRoads Property
Intersection::IntersectionRoads Property
Collapse All

Gets the roads of this Intersection.

C#
public IntersectionRoadCollection IntersectionRoads;
Visual Basic
Public Property IntersectionRoads() As IntersectionRoadCollection
Links
Intersection Class, Intersection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Intersection::Location Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Properties > Intersection::Location Property
Intersection::Location Property
Collapse All

Gets the location of the intersection.

C#
public Autodesk::AutoCAD::Geometry::Point3d Location;
Visual Basic
Public Property Location() As Autodesk::AutoCAD::Geometry::Point3d
Links
Intersection Class, Intersection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Intersection::RoadwayDrivingDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Properties > Intersection::RoadwayDrivingDirection Property
Intersection::RoadwayDrivingDirection Property
Collapse All

Gets or sets the direction of roadway driving.

C#
public DrivingDirectionType RoadwayDrivingDirection;
Visual Basic
Public Property RoadwayDrivingDirection() As DrivingDirectionType
Links
Intersection Class, Intersection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegion Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class
IntersectionRegion Class
Collapse All

Corridor regions in an Intersection area.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IntersectionRegion
C#
public class IntersectionRegion : CivilWrapper<AeccDbIntersection>;
Visual Basic
Public Class IntersectionRegion
Inherits CivilWrapper<AeccDbIntersection>
Links
IntersectionRegion Properties, IntersectionRegion Members, Class Hierarchy


IntersectionRegion Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Members
IntersectionRegion Members
Collapse All

The following tables list the members exposed by IntersectionRegion.

Public Properties
Public Property | Description
Angle | Gets the angle.
CurbReturnAlignmentId | Gets the object id of curb return alignment.
CurbReturnProfileId | Gets the object id of curb return profile.
InAlignmentId | Gets the in alignment.
Name | Gets or sets the name of region.
OutAlignmentId | Gets the out alignment.
Links
Public Properties


IntersectionRegion Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Properties
IntersectionRegion Properties
Collapse All

The properties of IntersectionRegion are listed here.

Public Properties
Public Property | Description
Angle | Gets the angle.
CurbReturnAlignmentId | Gets the object id of curb return alignment.
CurbReturnProfileId | Gets the object id of curb return profile.
InAlignmentId | Gets the in alignment.
Name | Gets or sets the name of region.
OutAlignmentId | Gets the out alignment.
Links
Public Properties


IntersectionRegion::Angle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Properties > IntersectionRegion::Angle Property
IntersectionRegion::Angle Property
Collapse All

Gets the angle.

C#
public double Angle;
Visual Basic
Public Property Angle() As double
Links
IntersectionRegion Class, IntersectionRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegion::CurbReturnAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Properties > IntersectionRegion::CurbReturnAlignmentId Property
IntersectionRegion::CurbReturnAlignmentId Property
Collapse All

Gets the object id of curb return alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurbReturnAlignmentId;
Visual Basic
Public Property CurbReturnAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment

Links
IntersectionRegion Class, IntersectionRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegion::CurbReturnProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Properties > IntersectionRegion::CurbReturnProfileId Property
IntersectionRegion::CurbReturnProfileId Property
Collapse All

Gets the object id of curb return profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurbReturnProfileId;
Visual Basic
Public Property CurbReturnProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Links
IntersectionRegion Class, IntersectionRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegion::InAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Properties > IntersectionRegion::InAlignmentId Property
IntersectionRegion::InAlignmentId Property
Collapse All

Gets the in alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId InAlignmentId;
Visual Basic
Public Property InAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
IntersectionRegion Class, IntersectionRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegion::Name Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Properties > IntersectionRegion::Name Property
IntersectionRegion::Name Property
Collapse All

Gets or sets the name of region.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
IntersectionRegion Class, IntersectionRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegion::OutAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Properties > IntersectionRegion::OutAlignmentId Property
IntersectionRegion::OutAlignmentId Property
Collapse All

Gets the out alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId OutAlignmentId;
Visual Basic
Public Property OutAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
IntersectionRegion Class, IntersectionRegion Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegionCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class
IntersectionRegionCollection Class
Collapse All

A collection of IntersectionRegion objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IntersectionRegionCollection
C#
public class IntersectionRegionCollection : CivilWrapper<AeccDbIntersection>, System::Collections::Generic::IEnumerable<IntersectionRegion^>;
Visual Basic
Public Class IntersectionRegionCollection
Inherits CivilWrapper<AeccDbIntersection>
Inherits System::Collections::Generic::IEnumerable<IntersectionRegion^>
Links
IntersectionRegionCollection Methods, IntersectionRegionCollection Properties, IntersectionRegionCollection Members, Class Hierarchy


IntersectionRegionCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Members
IntersectionRegionCollection Members
Collapse All

The following tables list the members exposed by IntersectionRegionCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Public Properties
Public Property | Description
Count | Gets the number of IntersectionRegion objects in the collection.
default | Gets the IntersectionRegion object at a specified index in the collection.
Links
Public Methods, Public Properties


IntersectionRegionCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Methods
IntersectionRegionCollection Methods
Collapse All

The methods of IntersectionRegionCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Links
Public Methods


IntersectionRegionCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Methods > IntersectionRegionCollection::GetEnumerator Method
IntersectionRegionCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<IntersectionRegion^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<IntersectionRegion^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
IntersectionRegionCollection Class, IntersectionRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegionCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Methods > IntersectionRegionCollection::GetObjectEnumerator Method
IntersectionRegionCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
IntersectionRegionCollection Class, IntersectionRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegionCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Properties
IntersectionRegionCollection Properties
Collapse All

The properties of IntersectionRegionCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of IntersectionRegion objects in the collection.
default | Gets the IntersectionRegion object at a specified index in the collection.
Links
Public Properties


IntersectionRegionCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Properties > IntersectionRegionCollection::Count Property
IntersectionRegionCollection::Count Property
Collapse All

Gets the number of IntersectionRegion objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
IntersectionRegionCollection Class, IntersectionRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRegionCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Properties > IntersectionRegionCollection::default Property
IntersectionRegionCollection::default Property
Collapse All

Gets the IntersectionRegion object at a specified index in the collection.

C#
public IntersectionRegion default;
Visual Basic
Public Property default() As IntersectionRegion
Parameters
Parameters | Description
Index | IntersectionRegion index.
Links
IntersectionRegionCollection Class, IntersectionRegionCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoad Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class
IntersectionRoad Class
Collapse All

Road components managed by an Intersection object.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IntersectionRoad
C#
public class IntersectionRoad : CivilWrapper<AeccDbIntersection>;
Visual Basic
Public Class IntersectionRoad
Inherits CivilWrapper<AeccDbIntersection>
Links
IntersectionRoad Properties, IntersectionRoad Members, Class Hierarchy


IntersectionRoad Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Members
IntersectionRoad Members
Collapse All

The following tables list the members exposed by IntersectionRoad.

Public Properties
Public Property | Description
CenterlineAlignmentId | Gets the object id of Centerline alignment.
CenterlineProfileId | Gets the object id of Centerline profile.
OffsetLeftAlignmentId | Gets the object id of left offset alignment.
OffsetLeftProfileId | Gets the object id of left offset profile.
OffsetRightAlignmentId | Gets the object id of right offset alignment.
OffsetRightProfileId | Gets the object id of right offset profile.
Links
Public Properties


IntersectionRoad Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Properties
IntersectionRoad Properties
Collapse All

The properties of IntersectionRoad are listed here.

Public Properties
Public Property | Description
CenterlineAlignmentId | Gets the object id of Centerline alignment.
CenterlineProfileId | Gets the object id of Centerline profile.
OffsetLeftAlignmentId | Gets the object id of left offset alignment.
OffsetLeftProfileId | Gets the object id of left offset profile.
OffsetRightAlignmentId | Gets the object id of right offset alignment.
OffsetRightProfileId | Gets the object id of right offset profile.
Links
Public Properties


IntersectionRoad::CenterlineAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Properties > IntersectionRoad::CenterlineAlignmentId Property
IntersectionRoad::CenterlineAlignmentId Property
Collapse All

Gets the object id of Centerline alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CenterlineAlignmentId;
Visual Basic
Public Property CenterlineAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment

Links
IntersectionRoad Class, IntersectionRoad Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoad::CenterlineProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Properties > IntersectionRoad::CenterlineProfileId Property
IntersectionRoad::CenterlineProfileId Property
Collapse All

Gets the object id of Centerline profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CenterlineProfileId;
Visual Basic
Public Property CenterlineProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Links
IntersectionRoad Class, IntersectionRoad Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoad::OffsetLeftAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Properties > IntersectionRoad::OffsetLeftAlignmentId Property
IntersectionRoad::OffsetLeftAlignmentId Property
Collapse All

Gets the object id of left offset alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId OffsetLeftAlignmentId;
Visual Basic
Public Property OffsetLeftAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment

Links
IntersectionRoad Class, IntersectionRoad Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoad::OffsetLeftProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Properties > IntersectionRoad::OffsetLeftProfileId Property
IntersectionRoad::OffsetLeftProfileId Property
Collapse All

Gets the object id of left offset profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId OffsetLeftProfileId;
Visual Basic
Public Property OffsetLeftProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Links
IntersectionRoad Class, IntersectionRoad Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoad::OffsetRightAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Properties > IntersectionRoad::OffsetRightAlignmentId Property
IntersectionRoad::OffsetRightAlignmentId Property
Collapse All

Gets the object id of right offset alignment.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId OffsetRightAlignmentId;
Visual Basic
Public Property OffsetRightAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Alignment

Links
IntersectionRoad Class, IntersectionRoad Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoad::OffsetRightProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Properties > IntersectionRoad::OffsetRightProfileId Property
IntersectionRoad::OffsetRightProfileId Property
Collapse All

Gets the object id of right offset profile.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId OffsetRightProfileId;
Visual Basic
Public Property OffsetRightProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.Civil.Land.DatabaseServices.Profile

Links
IntersectionRoad Class, IntersectionRoad Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoadCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class
IntersectionRoadCollection Class
Collapse All

A collection of IntersectionRoad objecs managed by an Intersection object.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IntersectionRoadCollection
C#
public class IntersectionRoadCollection : CivilWrapper<AeccDbIntersection>, System::Collections::Generic::IEnumerable<IntersectionRoad^>;
Visual Basic
Public Class IntersectionRoadCollection
Inherits CivilWrapper<AeccDbIntersection>
Inherits System::Collections::Generic::IEnumerable<IntersectionRoad^>
Links
IntersectionRoadCollection Methods, IntersectionRoadCollection Properties, IntersectionRoadCollection Members, Class Hierarchy


IntersectionRoadCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Members
IntersectionRoadCollection Members
Collapse All

The following tables list the members exposed by IntersectionRoadCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Public Properties
Public Property | Description
Count | Gets the number of IntersectionRoad objects in the collection.
default | Gets the IntersectionRoad object at a specified index in the collection.
Links
Public Methods, Public Properties


IntersectionRoadCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Methods
IntersectionRoadCollection Methods
Collapse All

The methods of IntersectionRoadCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Links
Public Methods


IntersectionRoadCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Methods > IntersectionRoadCollection::GetEnumerator Method
IntersectionRoadCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<IntersectionRoad^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<IntersectionRoad^>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
IntersectionRoadCollection Class, IntersectionRoadCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoadCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Methods > IntersectionRoadCollection::GetObjectEnumerator Method
IntersectionRoadCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
IntersectionRoadCollection Class, IntersectionRoadCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoadCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Properties
IntersectionRoadCollection Properties
Collapse All

The properties of IntersectionRoadCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of IntersectionRoad objects in the collection.
default | Gets the IntersectionRoad object at a specified index in the collection.
Links
Public Properties


IntersectionRoadCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Properties > IntersectionRoadCollection::Count Property
IntersectionRoadCollection::Count Property
Collapse All

Gets the number of IntersectionRoad objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
IntersectionRoadCollection Class, IntersectionRoadCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IntersectionRoadCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Properties > IntersectionRoadCollection::default Property
IntersectionRoadCollection::default Property
Collapse All

Gets the IntersectionRoad object at a specified index in the collection.

C#
public IntersectionRoad default;
Visual Basic
Public Property default() As IntersectionRoad
Parameters
Parameters | Description
Index | IntersectionRoad index.
Links
IntersectionRoadCollection Class, IntersectionRoadCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Link Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class
Link Class
Collapse All

Roadway Link object. Connects roadway points in a subassembly.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Link
C#
public class Link : CivilWrapper<AeccDbEntity>;
Visual Basic
Public Class Link
Inherits CivilWrapper<AeccDbEntity>
Links
Link Properties, Link Members, Class Hierarchy


Link Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Members
Link Members
Collapse All

The following tables list the members exposed by Link.

Public Properties
Public Property | Description
Codes | Get the Corridor codes of a Link.
Index | Get the index of the link.
IsHidden | Gets or sets the boolean value that specifies if the link will be drawn.
Points | Gets the points collection.
Links
Public Properties


Link Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Properties
Link Properties
Collapse All

The properties of Link are listed here.

Public Properties
Public Property | Description
Codes | Get the Corridor codes of a Link.
Index | Get the index of the link.
IsHidden | Gets or sets the boolean value that specifies if the link will be drawn.
Points | Gets the points collection.
Links
Public Properties


Link::Codes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Properties > Link::Codes Property
Link::Codes Property
Collapse All

Get the Corridor codes of a Link.

C#
public CodeCollection Codes;
Visual Basic
Public Property Codes() As CodeCollection
Links
Link Class, Link Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Link::Index Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Properties > Link::Index Property
Link::Index Property
Collapse All

Get the index of the link.

C#
public int Index;
Visual Basic
Public Property Index() As Integer
Links
Link Class, Link Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Link::IsHidden Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Properties > Link::IsHidden Property
Link::IsHidden Property
Collapse All

Gets or sets the boolean value that specifies if the link will be drawn.

C#
public bool IsHidden;
Visual Basic
Public Property IsHidden() As bool
Links
Link Class, Link Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Link::Points Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Properties > Link::Points Property
Link::Points Property
Collapse All

Gets the points collection.

C#
public PointCollection Points;
Visual Basic
Public Property Points() As PointCollection
Links
Link Class, Link Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class
LinkCollection Class
Collapse All

A collection of Link objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::LinkCollection
C#
public class LinkCollection : CivilWrapper<AeccDbEntity>, System::Collections::Generic::IEnumerable<Link^>;
Visual Basic
Public Class LinkCollection
Inherits CivilWrapper<AeccDbEntity>
Inherits System::Collections::Generic::IEnumerable<Link^>
Links
LinkCollection Methods, LinkCollection Properties, LinkCollection Members, Class Hierarchy


LinkCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Members
LinkCollection Members
Collapse All

The following tables list the members exposed by LinkCollection.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded
Public Properties
Public Property | Description
Count | Gets the number of links in the collection.
default | Gets a link from the collection by index.
Links
Public Methods, Public Properties


LinkCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods
LinkCollection Methods
Collapse All

The methods of LinkCollection are listed here.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded
Links
Public Methods


Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Add Method
Add Method
Collapse All

Overloaded

Overload List
Method | Description
LinkCollection::Add (array<IPoint^>^, array<System::String^>^) | Add a link using the default Normal display mode.
LinkCollection::Add (array<IPoint^>^, array<System::String^>^, CorridorLinkDisplay) | Add a link.
LinkCollection::Add (array<IPoint^>^, System::String^) | Add a link using the default Normal display mode.
LinkCollection::Add (array<IPoint^>^, System::String^, CorridorLinkDisplay) | Add a link.
LinkCollection::Add (IPoint^, IPoint^, array<System::String^>^) | Add a link. In most cases using the default Normal display mode., a link is defined by 2 points .... more
LinkCollection::Add (IPoint^, IPoint^, array<System::String^>^, CorridorLinkDisplay) | Add a link. In most cases, a link is defined by 2 points.
LinkCollection::Add (IPoint^, IPoint^, System::String^) | Add a link. A link is defined by 2 points in most cases, using the default Normal display mode.
LinkCollection::Add (IPoint^, IPoint^, System::String^, CorridorLinkDisplay) | Add a link. In most cases, a link is defined by 2 points.


LinkCollection::Add Method (IPoint^, IPoint^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Add Method > LinkCollection::Add Method (IPoint^, IPoint^, System::String^)
LinkCollection::Add Method (IPoint^, IPoint^, System::String^)
Collapse All

Add a link. A link is defined by 2 points in most cases, using the default Normal display mode.

C#
public Link Add(
    ref IPoint point1,
    ref IPoint point2,
    ref System::String code
);
Visual Basic
Public Function Add(
    ByRef point1 As IPoint,
    ByRef point2 As IPoint,
    ByRef code As System::String
) As Link
Parameters
Parameters | Description
point1 | First point of the link.
point2 | Second point of the link.
code | The code of the link.
Returns

The link added.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::Add Method (IPoint^, IPoint^, System::String^, CorridorLinkDisplay)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Add Method > LinkCollection::Add Method (IPoint^, IPoint^, System::String^, CorridorLinkDisplay)
LinkCollection::Add Method (IPoint^, IPoint^, System::String^, CorridorLinkDisplay)
Collapse All

Add a link. In most cases, a link is defined by 2 points.

C#
public Link Add(
    ref IPoint point1,
    ref IPoint point2,
    ref System::String code,
    CorridorLinkDisplay displayMode
);
Visual Basic
Public Function Add(
    ByRef point1 As IPoint,
    ByRef point2 As IPoint,
    ByRef code As System::String,
    displayMode As CorridorLinkDisplay
) As Link
Parameters
Parameters | Description
point1 | First point of the link.
point2 | Second point of the link.
code | The code of the link.
displayMode | How to draw the link (solid, dashed, with/without arrowhead).
Returns

The link added.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::Add Method (IPoint^, IPoint^, array<System::String^>^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Add Method > LinkCollection::Add Method (IPoint^, IPoint^, array<System::String^>^)
LinkCollection::Add Method (IPoint^, IPoint^, array<System::String^>^)
Collapse All

Add a link. In most cases using the default Normal display mode., a link is defined by 2 points .

C#
public Link Add(
    ref IPoint point1,
    ref IPoint point2,
    ref array<System::String^> codes
);
Visual Basic
Public Function Add(
    ByRef point1 As IPoint,
    ByRef point2 As IPoint,
    ByRef codes As array<System::String^>
) As Link
Parameters
Parameters | Description
point1 | First point of the link.
point2 | Second point of the link.
code | The codes of the link.
Returns

The link added.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::Add Method (IPoint^, IPoint^, array<System::String^>^, CorridorLinkDisplay)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Add Method > LinkCollection::Add Method (IPoint^, IPoint^, array<System::String^>^, CorridorLinkDisplay)
LinkCollection::Add Method (IPoint^, IPoint^, array<System::String^>^, CorridorLinkDisplay)
Collapse All

Add a link. In most cases, a link is defined by 2 points.

C#
public Link Add(
    ref IPoint point1,
    ref IPoint point2,
    ref array<System::String^> codes,
    CorridorLinkDisplay displayMode
);
Visual Basic
Public Function Add(
    ByRef point1 As IPoint,
    ByRef point2 As IPoint,
    ByRef codes As array<System::String^>,
    displayMode As CorridorLinkDisplay
) As Link
Parameters
Parameters | Description
point1 | First point of the link.
point2 | Second point of the link.
displayMode | How to draw the link (solid, dashed, with/without arrowhead).
code | The codes of the link.
Returns

The link added.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::Add Method (array<IPoint^>^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Add Method > LinkCollection::Add Method (array<IPoint^>^, System::String^)
LinkCollection::Add Method (array<IPoint^>^, System::String^)
Collapse All

Add a link using the default Normal display mode.

C#
public Link Add(
    ref array<IPoint^> points,
    ref System::String code
);
Visual Basic
Public Function Add(
    ByRef points As array<IPoint^>,
    ByRef code As System::String
) As Link
Parameters
Parameters | Description
points | Points of the link.
code | The code of the link.
Returns

The link added.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::Add Method (array<IPoint^>^, System::String^, CorridorLinkDisplay)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Add Method > LinkCollection::Add Method (array<IPoint^>^, System::String^, CorridorLinkDisplay)
LinkCollection::Add Method (array<IPoint^>^, System::String^, CorridorLinkDisplay)
Collapse All

Add a link.

C#
public Link Add(
    ref array<IPoint^> points,
    ref System::String code,
    CorridorLinkDisplay displayMode
);
Visual Basic
Public Function Add(
    ByRef points As array<IPoint^>,
    ByRef code As System::String,
    displayMode As CorridorLinkDisplay
) As Link
Parameters
Parameters | Description
points | Points of the link.
code | The code of the link.
displayMode | How to draw the link (solid, dashed, with/without arrowhead).
Returns

The link added.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::Add Method (array<IPoint^>^, array<System::String^>^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Add Method > LinkCollection::Add Method (array<IPoint^>^, array<System::String^>^)
LinkCollection::Add Method (array<IPoint^>^, array<System::String^>^)
Collapse All

Add a link using the default Normal display mode.

C#
public Link Add(
    ref array<IPoint^> points,
    ref array<System::String^> codes
);
Visual Basic
Public Function Add(
    ByRef points As array<IPoint^>,
    ByRef codes As array<System::String^>
) As Link
Parameters
Parameters | Description
points | Points of the link.
code | The codes of the link.
Returns

The link added.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::Add Method (array<IPoint^>^, array<System::String^>^, CorridorLinkDisplay)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Add Method > LinkCollection::Add Method (array<IPoint^>^, array<System::String^>^, CorridorLinkDisplay)
LinkCollection::Add Method (array<IPoint^>^, array<System::String^>^, CorridorLinkDisplay)
Collapse All

Add a link.

C#
public Link Add(
    ref array<IPoint^> points,
    ref array<System::String^> codes,
    CorridorLinkDisplay displayMode
);
Visual Basic
Public Function Add(
    ByRef points As array<IPoint^>,
    ByRef codes As array<System::String^>,
    displayMode As CorridorLinkDisplay
) As Link
Parameters
Parameters | Description
points | Points of the link.
codes | The codes of the link.
displayMode | Specifies how to draw the link (solid, dashed, with/without arrowhead).
Returns

The link added.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > LinkCollection::GetEnumerator Method
LinkCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<Link^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<Link^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > LinkCollection::GetObjectEnumerator Method
LinkCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Remove Method
Remove Method
Collapse All

Overloaded

Overload List
Method | Description
LinkCollection::Remove (int) | Removes a link from the collection.
LinkCollection::Remove (Link^) | Removes a link from the collection.


LinkCollection::Remove Method (Link^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Remove Method > LinkCollection::Remove Method (Link^)
LinkCollection::Remove Method (Link^)
Collapse All

Removes a link from the collection.

C#
public Remove(
    ref Link link
);
Visual Basic
Public Sub Remove(
    ByRef link As Link
)
Parameters
Parameters | Description
link | The Link need to be removed.
Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::Remove Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods > Remove Method > LinkCollection::Remove Method (int)
LinkCollection::Remove Method (int)
Collapse All

Removes a link from the collection.

C#
public Remove(
    int index
);
Visual Basic
Public Sub Remove(
    index As Integer
)
Parameters
Parameters | Description
index | Index of the link.
Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Properties
LinkCollection Properties
Collapse All

The properties of LinkCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of links in the collection.
default | Gets a link from the collection by index.
Links
Public Properties


LinkCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Properties > LinkCollection::Count Property
LinkCollection::Count Property
Collapse All

Gets the number of links in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


LinkCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Properties > LinkCollection::default Property
LinkCollection::default Property
Collapse All

Gets a link from the collection by index.

C#
public Link default;
Visual Basic
Public Property default() As Link
Links
LinkCollection Class, LinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class
OffsetBaseline Class
Collapse All

An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between this kind offset baseline and the main baseline is variable. These are used to create complicated corridor structures or to attach assemblies to a point outside the main baseline of a corridor.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaseBaseline
    Autodesk::Civil::Roadway::DatabaseServices::OffsetBaseline
C#
public class OffsetBaseline : BaseBaseline;
Visual Basic
Public Class OffsetBaseline
Inherits BaseBaseline
Links
OffsetBaseline Methods, OffsetBaseline Properties, OffsetBaseline Nested Types, OffsetBaseline Members, Class Hierarchy


OffsetBaseline Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Members
OffsetBaseline Members
Collapse All

The following tables list the members exposed by OffsetBaseline.

Public Methods
Public Method | Description
GetOffsetElevationFromMainBaselineStation | Gets the offset at a station from main baseline.
MainBaselineStationToOffsetBaselineStation | Transforms the Main Baseline station to an offset Baseline station.
OffsetBaselineStationToMainBaselineStation | Transforms the offset Baseline station to Main Baseline station.
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaseline::Identity.
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
EndStationOnMainBaseline | Gets the end station on the main baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
RelatedOffsetBaselineFeatureLines | Gets related offset Baseline FeatureLines.
StartStation | Gets the starting station for this baseline.
StartStationOnMainBaseline | Gets the start station on the main baseline.
Links
Public Methods, Public Nested Types, Public Properties


OffsetBaseline Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Methods
OffsetBaseline Methods
Collapse All

The methods of OffsetBaseline are listed here.

Public Methods
Public Method | Description
GetOffsetElevationFromMainBaselineStation | Gets the offset at a station from main baseline.
MainBaselineStationToOffsetBaselineStation | Transforms the Main Baseline station to an offset Baseline station.
OffsetBaselineStationToMainBaselineStation | Transforms the offset Baseline station to Main Baseline station.
SortedStations | Gets the sorted stations for the baseline.
Links
Public Methods


OffsetBaseline::GetOffsetElevationFromMainBaselineStation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Methods > OffsetBaseline::GetOffsetElevationFromMainBaselineStation Method
OffsetBaseline::GetOffsetElevationFromMainBaselineStation Method
Collapse All

Gets the offset at a station from main baseline.

C#
public Autodesk::AutoCAD::Geometry::Point2d GetOffsetElevationFromMainBaselineStation(
    double mainBaselineStation
);
Visual Basic
Public Function GetOffsetElevationFromMainBaselineStation(
    mainBaselineStation As double
) As Autodesk::AutoCAD::Geometry::Point2d
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::MainBaselineStationToOffsetBaselineStation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Methods > OffsetBaseline::MainBaselineStationToOffsetBaselineStation Method
OffsetBaseline::MainBaselineStationToOffsetBaselineStation Method
Collapse All

Transforms the Main Baseline station to an offset Baseline station.

C#
public double MainBaselineStationToOffsetBaselineStation(
    double mainBaselineStation
);
Visual Basic
Public Function MainBaselineStationToOffsetBaselineStation(
    mainBaselineStation As double
) As double
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::OffsetBaselineStationToMainBaselineStation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Methods > OffsetBaseline::OffsetBaselineStationToMainBaselineStation Method
OffsetBaseline::OffsetBaselineStationToMainBaselineStation Method
Collapse All

Transforms the offset Baseline station to Main Baseline station.

C#
public double OffsetBaselineStationToMainBaselineStation(
    double offsetBaselineStation
);
Visual Basic
Public Function OffsetBaselineStationToMainBaselineStation(
    offsetBaselineStation As double
) As double
Exceptions
Exceptions | Description
 | System::ArgumentException
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::SortedStations Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Methods > OffsetBaseline::SortedStations Method
OffsetBaseline::SortedStations Method
Collapse All

Gets the sorted stations for the baseline.

C#
public array<double> SortedStations();
Visual Basic
Public Function SortedStations() As array<double>
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties
OffsetBaseline Properties
Collapse All

The properties of OffsetBaseline are listed here.

Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
EndStation | Gets the end station for this baseline.
EndStationOnMainBaseline | Gets the end station on the main baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
RelatedOffsetBaselineFeatureLines | Gets related offset Baseline FeatureLines.
StartStation | Gets the starting station for this baseline.
StartStationOnMainBaseline | Gets the start station on the main baseline.
Links
Public Properties


OffsetBaseline::AlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties > OffsetBaseline::AlignmentId Property
OffsetBaseline::AlignmentId Property
Collapse All

Gets the ID of the Alignment this baseline is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AlignmentId;
Visual Basic
Public Property AlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::BaselineType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties > OffsetBaseline::BaselineType Property
OffsetBaseline::BaselineType Property
Collapse All

Gets the baseline type.

C#
public CorridorBaselineType BaselineType;
Visual Basic
Public Property BaselineType() As CorridorBaselineType
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::EndStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties > OffsetBaseline::EndStation Property
OffsetBaseline::EndStation Property
Collapse All

Gets the end station for this baseline.

C#
public double EndStation;
Visual Basic
Public Property EndStation() As double
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::EndStationOnMainBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties > OffsetBaseline::EndStationOnMainBaseline Property
OffsetBaseline::EndStationOnMainBaseline Property
Collapse All

Gets the end station on the main baseline.

C#
public double EndStationOnMainBaseline;
Visual Basic
Public Property EndStationOnMainBaseline() As double
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::ProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties > OffsetBaseline::ProfileId Property
OffsetBaseline::ProfileId Property
Collapse All

Gets the ID of the Profile this baseline is associated with.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId ProfileId;
Visual Basic
Public Property ProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::RelatedOffsetBaselineFeatureLines Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties > OffsetBaseline::RelatedOffsetBaselineFeatureLines Property
OffsetBaseline::RelatedOffsetBaselineFeatureLines Property
Collapse All

Gets related offset Baseline FeatureLines.

C#
public BaselineFeatureLines RelatedOffsetBaselineFeatureLines;
Visual Basic
Public Property RelatedOffsetBaselineFeatureLines() As BaselineFeatureLines
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::StartStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties > OffsetBaseline::StartStation Property
OffsetBaseline::StartStation Property
Collapse All

Gets the starting station for this baseline.

C#
public double StartStation;
Visual Basic
Public Property StartStation() As double
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline::StartStationOnMainBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties > OffsetBaseline::StartStationOnMainBaseline Property
OffsetBaseline::StartStationOnMainBaseline Property
Collapse All

Gets the start station on the main baseline.

C#
public double StartStationOnMainBaseline;
Visual Basic
Public Property StartStationOnMainBaseline() As double
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaseline Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Nested Types
OffsetBaseline Nested Types
Collapse All

The nested types of OffsetBaseline are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaseline::Identity.
Links
Public Nested Types


OffsetBaseline::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Nested Types > OffsetBaseline::Identity Nested Type
OffsetBaseline::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaseline::Identity.

C#
Identity
Visual Basic
Identity
Links
OffsetBaseline Class, OffsetBaseline Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaselineCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class
OffsetBaselineCollection Class
Collapse All

Collection of offset baseline objects. There are two kinds of offset baselines, OffsetBaseline and HardcodedOffsetBaseline. Both of these are based on the BaseBaseline class. Check the Type property of each object derived from BaseBaseline to tell what kind of baseline it is.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::OffsetBaselineCollection
C#
public class OffsetBaselineCollection : CivilWrapper<AeccDbCorridor>, System::Collections::Generic::IEnumerable<BaseBaseline^>;
Visual Basic
Public Class OffsetBaselineCollection
Inherits CivilWrapper<AeccDbCorridor>
Inherits System::Collections::Generic::IEnumerable<BaseBaseline^>
Links
OffsetBaselineCollection Methods, OffsetBaselineCollection Properties, OffsetBaselineCollection Nested Types, OffsetBaselineCollection Members, Class Hierarchy


OffsetBaselineCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Members
OffsetBaselineCollection Members
Collapse All

The following tables list the members exposed by OffsetBaselineCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
OffsetBaselineNames | Gets an array of OffsetBaseline names.
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaselineCollection::Identity.
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of BaseBaseline objects in the collection.
default | Gets a BaseBaseline by name.
Links
Public Methods, Public Nested Types, Public Properties


OffsetBaselineCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Methods
OffsetBaselineCollection Methods
Collapse All

The methods of OffsetBaselineCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
OffsetBaselineNames | Gets an array of OffsetBaseline names.
Links
Public Methods


OffsetBaselineCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Methods > OffsetBaselineCollection::GetEnumerator Method
OffsetBaselineCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<BaseBaseline^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<BaseBaseline^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
OffsetBaselineCollection Class, OffsetBaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaselineCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Methods > OffsetBaselineCollection::GetObjectEnumerator Method
OffsetBaselineCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
OffsetBaselineCollection Class, OffsetBaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaselineCollection::OffsetBaselineNames Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Methods > OffsetBaselineCollection::OffsetBaselineNames Method
OffsetBaselineCollection::OffsetBaselineNames Method
Collapse All

Gets an array of OffsetBaseline names.

C#
public array<System::String^> OffsetBaselineNames();
Visual Basic
Public Function OffsetBaselineNames() As array<System::String^>
Links
OffsetBaselineCollection Class, OffsetBaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaselineCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Properties
OffsetBaselineCollection Properties
Collapse All

The properties of OffsetBaselineCollection are listed here.

Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of BaseBaseline objects in the collection.
default | Gets a BaseBaseline by name.
Links
Public Properties


OffsetBaselineCollection::CorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Properties > OffsetBaselineCollection::CorridorId Property
OffsetBaselineCollection::CorridorId Property
Collapse All

Gets the ObjectId of the parent Corridor.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CorridorId;
Visual Basic
Public Property CorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
OffsetBaselineCollection Class, OffsetBaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaselineCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Properties > OffsetBaselineCollection::Count Property
OffsetBaselineCollection::Count Property
Collapse All

Gets the number of BaseBaseline objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
OffsetBaselineCollection Class, OffsetBaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaselineCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Properties > OffsetBaselineCollection::default Property
OffsetBaselineCollection::default Property
Collapse All

Gets a BaseBaseline by name.

C#
public BaseBaseline default;
Visual Basic
Public Property default() As BaseBaseline
Links
OffsetBaselineCollection Class, OffsetBaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


OffsetBaselineCollection Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Nested Types
OffsetBaselineCollection Nested Types
Collapse All

The nested types of OffsetBaselineCollection are listed here.

Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaselineCollection::Identity.
Links
Public Nested Types


OffsetBaselineCollection::Identity Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Nested Types > OffsetBaselineCollection::Identity Nested Type
OffsetBaselineCollection::Identity Nested Type
Collapse All

This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaselineCollection::Identity.

C#
Identity
Visual Basic
Identity
Links
OffsetBaselineCollection Class, OffsetBaselineCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Point Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class
Point Class
Collapse All

Roadway Point object. Represents a single point within a subassembly.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IPoint
    Autodesk::Civil::Roadway::DatabaseServices::Point
C#
public class Point : CivilWrapper<AeccDbEntity>, IPoint;
Visual Basic
Public Class Point
Inherits CivilWrapper<AeccDbEntity>
Inherits IPoint
Links
Point Methods, Point Properties, Point Members, Class Hierarchy


Point Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Members
Point Members
Collapse All

The following tables list the members exposed by Point.

Public Methods
Public Method | Description
GetXYZ | Gets the XYZ world coordinates from the soe cordinates
Public Properties
Public Property | Description
Codes | Gets the collection of codes associated with this point.
Elevation | Gets or sets the point elevation.
Index | Gets the point index.
IsHidden | Gets or sets the boolean value that specifies if the Point will be drawn.
IsLoopPoint | Gets or sets the Point as a loop point for subsequent subassemblies to attach to.
Offset | Gets or sets the point offset.
Station | Gets or sets the point station.
Links
Public Methods, Public Properties


Point Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Methods
Point Methods
Collapse All

The methods of Point are listed here.

Public Methods
Public Method | Description
GetXYZ | Gets the XYZ world coordinates from the soe cordinates
Links
Public Methods


Point::GetXYZ Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Methods > Point::GetXYZ Method
Point::GetXYZ Method
Collapse All

Gets the XYZ world coordinates from the soe cordinates

C#
public GetXYZ(
    double % x,
    double % y,
    double % z
);
Visual Basic
Public Sub GetXYZ(
    x As double %,
    y As double %,
    z As double %
)
Links
Point Class, Point Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Point Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties
Point Properties
Collapse All

The properties of Point are listed here.

Public Properties
Public Property | Description
Codes | Gets the collection of codes associated with this point.
Elevation | Gets or sets the point elevation.
Index | Gets the point index.
IsHidden | Gets or sets the boolean value that specifies if the Point will be drawn.
IsLoopPoint | Gets or sets the Point as a loop point for subsequent subassemblies to attach to.
Offset | Gets or sets the point offset.
Station | Gets or sets the point station.
Links
Public Properties


Point::Codes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties > Point::Codes Property
Point::Codes Property
Collapse All

Gets the collection of codes associated with this point.

C#
public CodeCollection Codes;
Visual Basic
Public Property Codes() As CodeCollection
Links
Point Class, Point Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Point::Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties > Point::Elevation Property
Point::Elevation Property
Collapse All

Gets or sets the point elevation.

C#
public double Elevation;
Visual Basic
Public Property Elevation() As double
Links
Point Class, Point Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Point::Index Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties > Point::Index Property
Point::Index Property
Collapse All

Gets the point index.

C#
public int Index;
Visual Basic
Public Property Index() As Integer
Links
Point Class, Point Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Point::IsHidden Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties > Point::IsHidden Property
Point::IsHidden Property
Collapse All

Gets or sets the boolean value that specifies if the Point will be drawn.

C#
public bool IsHidden;
Visual Basic
Public Property IsHidden() As bool
Links
Point Class, Point Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Point::IsLoopPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties > Point::IsLoopPoint Property
Point::IsLoopPoint Property
Collapse All

Gets or sets the Point as a loop point for subsequent subassemblies to attach to.

C#
public bool IsLoopPoint;
Visual Basic
Public Property IsLoopPoint() As bool
Links
Point Class, Point Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Point::Offset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties > Point::Offset Property
Point::Offset Property
Collapse All

Gets or sets the point offset.

C#
public double Offset;
Visual Basic
Public Property Offset() As double
Links
Point Class, Point Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Point::Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties > Point::Station Property
Point::Station Property
Collapse All

Gets or sets the point station.

C#
public double Station;
Visual Basic
Public Property Station() As double
Links
Point Class, Point Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


PointCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class
PointCollection Class
Collapse All

A collection of Roadway Point objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::PointCollection
C#
public class PointCollection : CivilWrapper<AeccDbEntity>, System::Collections::Generic::IEnumerable<Point^>;
Visual Basic
Public Class PointCollection
Inherits CivilWrapper<AeccDbEntity>
Inherits System::Collections::Generic::IEnumerable<Point^>
Links
PointCollection Methods, PointCollection Properties, PointCollection Members, Class Hierarchy


PointCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Members
PointCollection Members
Collapse All

The following tables list the members exposed by PointCollection.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded
Public Properties
Public Property | Description
Count | Get the count of shape in the collection
default | Get a point in the collection.
Links
Public Methods, Public Properties


PointCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods
PointCollection Methods
Collapse All

The methods of PointCollection are listed here.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded
Links
Public Methods


Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods > Add Method
Add Method
Collapse All

Overloaded

Overload List
Method | Description
PointCollection::Add (double, double, array<System::String^>^) | Constructor
PointCollection::Add (double, double, System::String^) | Constructor


PointCollection::Add Method (double, double, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods > Add Method > PointCollection::Add Method (double, double, System::String^)
PointCollection::Add Method (double, double, System::String^)
Collapse All

Constructor

C#
public Point Add(
    double offset,
    double elevation,
    ref System::String code
);
Visual Basic
Public Function Add(
    offset As double,
    elevation As double,
    ByRef code As System::String
) As Point
Parameters
Parameters | Description
offset | The offset of the point.
elevation | The elevation of the point.
code | The code of the point.
Returns

The point added.

Links
PointCollection Class, PointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


PointCollection::Add Method (double, double, array<System::String^>^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods > Add Method > PointCollection::Add Method (double, double, array<System::String^>^)
PointCollection::Add Method (double, double, array<System::String^>^)
Collapse All

Constructor

C#
public Point Add(
    double offset,
    double elevation,
    ref array<System::String^> codes
);
Visual Basic
Public Function Add(
    offset As double,
    elevation As double,
    ByRef codes As array<System::String^>
) As Point
Parameters
Parameters | Description
offset | The offset of the point.
elevation | The elevation of the point.
code | The codes of the point.
Returns

The point added.

Links
PointCollection Class, PointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


PointCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods > PointCollection::GetEnumerator Method
PointCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<Point^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<Point^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
PointCollection Class, PointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


PointCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods > PointCollection::GetObjectEnumerator Method
PointCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
PointCollection Class, PointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods > Remove Method
Remove Method
Collapse All

Overloaded

Overload List
Method | Description
PointCollection::Remove (int) | Remove the point from collection.
PointCollection::Remove (Point^) | Remove the point from collection.


PointCollection::Remove Method (Point^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods > Remove Method > PointCollection::Remove Method (Point^)
PointCollection::Remove Method (Point^)
Collapse All

Remove the point from collection.

C#
public Remove(
    ref Point point
);
Visual Basic
Public Sub Remove(
    ByRef point As Point
)
Parameters
Parameters | Description
index | The point need to be removed.
Links
PointCollection Class, PointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


PointCollection::Remove Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods > Remove Method > PointCollection::Remove Method (int)
PointCollection::Remove Method (int)
Collapse All

Remove the point from collection.

C#
public Remove(
    int index
);
Visual Basic
Public Sub Remove(
    index As Integer
)
Parameters
Parameters | Description
index | Index of the point.
Links
PointCollection Class, PointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


PointCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Properties
PointCollection Properties
Collapse All

The properties of PointCollection are listed here.

Public Properties
Public Property | Description
Count | Get the count of shape in the collection
default | Get a point in the collection.
Links
Public Properties


PointCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Properties > PointCollection::Count Property
PointCollection::Count Property
Collapse All

Get the count of shape in the collection

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
PointCollection Class, PointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


PointCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Properties > PointCollection::default Property
PointCollection::default Property
Collapse All

Get a point in the collection.

C#
public Point default;
Visual Basic
Public Property default() As Point
Parameters
Parameters | Description
index | The index of the shape.
Links
PointCollection Class, PointCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SampledSectionLink Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class
SampledSectionLink Class
Collapse All

Defines a single line segment of sample surface cross-section data.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SampledSectionLink
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("SampleSectionLinkData"))]
public class SampledSectionLink : CivilWrapper<SampleSectionLinkData>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("SampleSectionLinkData"))>
Public Class SampledSectionLink
Inherits CivilWrapper<SampleSectionLinkData>
Links
SampledSectionLink Properties, SampledSectionLink Members, Class Hierarchy


SampledSectionLink Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Members
SampledSectionLink Members
Collapse All

The following tables list the members exposed by SampledSectionLink.

Public Properties
Public Property | Description
EndPointElevation | Gets or sets the line segment ending point elevation.
EndPointOffset | Gets or sets the line segment ending point offset.
EndPointStation | Gets the line segment ending point station.
StartPointElevation | Gets the line segment starting point elevation.
StartPointOffset | Gets the line segment starting point offset.
StartPointStation | Gets the line segment starting point station.
Links
Public Properties


SampledSectionLink Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Properties
SampledSectionLink Properties
Collapse All

The properties of SampledSectionLink are listed here.

Public Properties
Public Property | Description
EndPointElevation | Gets or sets the line segment ending point elevation.
EndPointOffset | Gets or sets the line segment ending point offset.
EndPointStation | Gets the line segment ending point station.
StartPointElevation | Gets the line segment starting point elevation.
StartPointOffset | Gets the line segment starting point offset.
StartPointStation | Gets the line segment starting point station.
Links
Public Properties


SampledSectionLink::EndPointElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Properties > SampledSectionLink::EndPointElevation Property
SampledSectionLink::EndPointElevation Property
Collapse All

Gets or sets the line segment ending point elevation.

C#
public double EndPointElevation;
Visual Basic
Public Property EndPointElevation() As double
Links
SampledSectionLink Class, SampledSectionLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SampledSectionLink::EndPointOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Properties > SampledSectionLink::EndPointOffset Property
SampledSectionLink::EndPointOffset Property
Collapse All

Gets or sets the line segment ending point offset.

C#
public double EndPointOffset;
Visual Basic
Public Property EndPointOffset() As double
Links
SampledSectionLink Class, SampledSectionLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SampledSectionLink::EndPointStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Properties > SampledSectionLink::EndPointStation Property
SampledSectionLink::EndPointStation Property
Collapse All

Gets the line segment ending point station.

C#
public double EndPointStation;
Visual Basic
Public Property EndPointStation() As double
Links
SampledSectionLink Class, SampledSectionLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SampledSectionLink::StartPointElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Properties > SampledSectionLink::StartPointElevation Property
SampledSectionLink::StartPointElevation Property
Collapse All

Gets the line segment starting point elevation.

C#
public double StartPointElevation;
Visual Basic
Public Property StartPointElevation() As double
Links
SampledSectionLink Class, SampledSectionLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SampledSectionLink::StartPointOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Properties > SampledSectionLink::StartPointOffset Property
SampledSectionLink::StartPointOffset Property
Collapse All

Gets the line segment starting point offset.

C#
public double StartPointOffset;
Visual Basic
Public Property StartPointOffset() As double
Links
SampledSectionLink Class, SampledSectionLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SampledSectionLink::StartPointStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Properties > SampledSectionLink::StartPointStation Property
SampledSectionLink::StartPointStation Property
Collapse All

Gets the line segment starting point station.

C#
public double StartPointStation;
Visual Basic
Public Property StartPointStation() As double
Links
SampledSectionLink Class, SampledSectionLink Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SampledSectionLinkCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class
SampledSectionLinkCollection Class
Collapse All

Collection of sampled elevation data.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SampledSectionLinkCollection
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("SampleSectionLinkDataVector"))]
public class SampledSectionLinkCollection : CivilWrapper<SampleSectionLinkDataVector>, System::Collections::Generic::IEnumerable<SampledSectionLink^>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("SampleSectionLinkDataVector"))>
Public Class SampledSectionLinkCollection
Inherits CivilWrapper<SampleSectionLinkDataVector>
Inherits System::Collections::Generic::IEnumerable<SampledSectionLink^>
Links
SampledSectionLinkCollection Methods, SampledSectionLinkCollection Properties, SampledSectionLinkCollection Members, Class Hierarchy


SampledSectionLinkCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Members
SampledSectionLinkCollection Members
Collapse All

The following tables list the members exposed by SampledSectionLinkCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Public Properties
Public Property | Description
default | Gets a SampledSectionLink in the collection by index.
Links
Public Methods, Public Properties


SampledSectionLinkCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Methods
SampledSectionLinkCollection Methods
Collapse All

The methods of SampledSectionLinkCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Links
Public Methods


SampledSectionLinkCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Methods > SampledSectionLinkCollection::GetEnumerator Method
SampledSectionLinkCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<SampledSectionLink^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<SampledSectionLink^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
SampledSectionLinkCollection Class, SampledSectionLinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SampledSectionLinkCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Methods > SampledSectionLinkCollection::GetObjectEnumerator Method
SampledSectionLinkCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
SampledSectionLinkCollection Class, SampledSectionLinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SampledSectionLinkCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Properties
SampledSectionLinkCollection Properties
Collapse All

The properties of SampledSectionLinkCollection are listed here.

Public Properties
Public Property | Description
default | Gets a SampledSectionLink in the collection by index.
Links
Public Properties


SampledSectionLinkCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Properties > SampledSectionLinkCollection::default Property
SampledSectionLinkCollection::default Property
Collapse All

Gets a SampledSectionLink in the collection by index.

C#
public SampledSectionLink default;
Visual Basic
Public Property default() As SampledSectionLink
Links
SampledSectionLinkCollection Class, SampledSectionLinkCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Shape Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class
Shape Class
Collapse All

Roadway Shape object. Represents a series of roadway links which form a closed shape. Used in subassemblies.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Shape
C#
public class Shape : CivilWrapper<AeccDbEntity>;
Visual Basic
Public Class Shape
Inherits CivilWrapper<AeccDbEntity>
Links
Shape Properties, Shape Members, Class Hierarchy


Shape Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Members
Shape Members
Collapse All

The following tables list the members exposed by Shape.

Public Properties
Public Property | Description
Codes | Get the roadway codes of the shape.
Index | Get the index of the shape.
IsHidden | Gets or sets the boolean value that specifies if the shape will be drawn.
Links | Get the roadway links of the shape.
Links
Public Properties


Shape Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Properties
Shape Properties
Collapse All

The properties of Shape are listed here.

Public Properties
Public Property | Description
Codes | Get the roadway codes of the shape.
Index | Get the index of the shape.
IsHidden | Gets or sets the boolean value that specifies if the shape will be drawn.
Links | Get the roadway links of the shape.
Links
Public Properties


Shape::Codes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Properties > Shape::Codes Property
Shape::Codes Property
Collapse All

Get the roadway codes of the shape.

C#
public CodeCollection Codes;
Visual Basic
Public Property Codes() As CodeCollection
Links
Shape Class, Shape Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Shape::Index Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Properties > Shape::Index Property
Shape::Index Property
Collapse All

Get the index of the shape.

C#
public int Index;
Visual Basic
Public Property Index() As Integer
Links
Shape Class, Shape Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Shape::IsHidden Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Properties > Shape::IsHidden Property
Shape::IsHidden Property
Collapse All

Gets or sets the boolean value that specifies if the shape will be drawn.

C#
public bool IsHidden;
Visual Basic
Public Property IsHidden() As bool
Links
Shape Class, Shape Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Shape::Links Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Properties > Shape::Links Property
Shape::Links Property
Collapse All

Get the roadway links of the shape.

C#
public LinkCollection Links;
Visual Basic
Public Property Links() As LinkCollection
Links
Shape Class, Shape Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


ShapeCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class
ShapeCollection Class
Collapse All

A collection of Roadway Shape objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::ShapeCollection
C#
public class ShapeCollection : CivilWrapper<AeccDbEntity>, System::Collections::Generic::IEnumerable<Shape^>;
Visual Basic
Public Class ShapeCollection
Inherits CivilWrapper<AeccDbEntity>
Inherits System::Collections::Generic::IEnumerable<Shape^>
Links
ShapeCollection Methods, ShapeCollection Properties, ShapeCollection Members, Class Hierarchy


ShapeCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Members
ShapeCollection Members
Collapse All

The following tables list the members exposed by ShapeCollection.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded
Public Properties
Public Property | Description
Count | Get the count of shape in the collection
default | Get a shape in the collection.
Links
Public Methods, Public Properties


ShapeCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods
ShapeCollection Methods
Collapse All

The methods of ShapeCollection are listed here.

Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded
Links
Public Methods


Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > Add Method
Add Method
Collapse All

Overloaded

Overload List
Method | Description
ShapeCollection::Add (array<Link^>^, array<System::String^>^) | Add a shape.
ShapeCollection::Add (array<Link^>^, System::String^) | Add a shape.
ShapeCollection::Add (Link^, Link^, Link^, Link^, array<System::String^>^) | Add a shape. In most cases, a shape is defined by 4 links.
ShapeCollection::Add (Link^, Link^, Link^, Link^, System::String^) | Add a shape. In most cases, a shape is defined by 4 links.


ShapeCollection::Add Method (Link^, Link^, Link^, Link^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > Add Method > ShapeCollection::Add Method (Link^, Link^, Link^, Link^, System::String^)
ShapeCollection::Add Method (Link^, Link^, Link^, Link^, System::String^)
Collapse All

Add a shape. In most cases, a shape is defined by 4 links.

C#
public Shape Add(
    ref Link link1,
    ref Link link2,
    ref Link link3,
    ref Link link4,
    ref System::String code
);
Visual Basic
Public Function Add(
    ByRef link1 As Link,
    ByRef link2 As Link,
    ByRef link3 As Link,
    ByRef link4 As Link,
    ByRef code As System::String
) As Shape
Parameters
Parameters | Description
link1 | First link of the shape.
link2 | Second link of the shape.
link3 | Third link of the shape.
link4 | Fourth link of the shape.
code | The code of the shape.
Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


ShapeCollection::Add Method (Link^, Link^, Link^, Link^, array<System::String^>^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > Add Method > ShapeCollection::Add Method (Link^, Link^, Link^, Link^, array<System::String^>^)
ShapeCollection::Add Method (Link^, Link^, Link^, Link^, array<System::String^>^)
Collapse All

Add a shape. In most cases, a shape is defined by 4 links.

C#
public Shape Add(
    ref Link link1,
    ref Link link2,
    ref Link link3,
    ref Link link4,
    ref array<System::String^> codes
);
Visual Basic
Public Function Add(
    ByRef link1 As Link,
    ByRef link2 As Link,
    ByRef link3 As Link,
    ByRef link4 As Link,
    ByRef codes As array<System::String^>
) As Shape
Parameters
Parameters | Description
link1 | First link of the shape.
link2 | Second link of the shape.
link3 | Third link of the shape.
link4 | Fourth link of the shape.
code | The codes of the shape.
Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


ShapeCollection::Add Method (array<Link^>^, System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > Add Method > ShapeCollection::Add Method (array<Link^>^, System::String^)
ShapeCollection::Add Method (array<Link^>^, System::String^)
Collapse All

Add a shape.

C#
public Shape Add(
    ref array<Link^> links,
    ref System::String code
);
Visual Basic
Public Function Add(
    ByRef links As array<Link^>,
    ByRef code As System::String
) As Shape
Parameters
Parameters | Description
links | Links of the shape.
code | The code of the shape.
Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


ShapeCollection::Add Method (array<Link^>^, array<System::String^>^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > Add Method > ShapeCollection::Add Method (array<Link^>^, array<System::String^>^)
ShapeCollection::Add Method (array<Link^>^, array<System::String^>^)
Collapse All

Add a shape.

C#
public Shape Add(
    ref array<Link^> links,
    ref array<System::String^> codes
);
Visual Basic
Public Function Add(
    ByRef links As array<Link^>,
    ByRef codes As array<System::String^>
) As Shape
Parameters
Parameters | Description
links | Links of the shape.
code | The codes of the shape.
Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


ShapeCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > ShapeCollection::GetEnumerator Method
ShapeCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<Shape^> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<Shape^>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


ShapeCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > ShapeCollection::GetObjectEnumerator Method
ShapeCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > Remove Method
Remove Method
Collapse All

Overloaded

Overload List
Method | Description
ShapeCollection::Remove (int) | Remove the Shape from collection.
ShapeCollection::Remove (Shape^) | Remove the Shape from collection.


ShapeCollection::Remove Method (Shape^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > Remove Method > ShapeCollection::Remove Method (Shape^)
ShapeCollection::Remove Method (Shape^)
Collapse All

Remove the Shape from collection.

C#
public Remove(
    ref Shape shape
);
Visual Basic
Public Sub Remove(
    ByRef shape As Shape
)
Parameters
Parameters | Description
index | The Shape need to be removed.
Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


ShapeCollection::Remove Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods > Remove Method > ShapeCollection::Remove Method (int)
ShapeCollection::Remove Method (int)
Collapse All

Remove the Shape from collection.

C#
public Remove(
    int index
);
Visual Basic
Public Sub Remove(
    index As Integer
)
Parameters
Parameters | Description
index | Index of the Shape.
Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


ShapeCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Properties
ShapeCollection Properties
Collapse All

The properties of ShapeCollection are listed here.

Public Properties
Public Property | Description
Count | Get the count of shape in the collection
default | Get a shape in the collection.
Links
Public Properties


ShapeCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Properties > ShapeCollection::Count Property
ShapeCollection::Count Property
Collapse All

Get the count of shape in the collection

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


ShapeCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Properties > ShapeCollection::default Property
ShapeCollection::default Property
Collapse All

Get a shape in the collection.

C#
public Shape default;
Visual Basic
Public Property default() As Shape
Parameters
Parameters | Description
index | The index of the shape.
Links
ShapeCollection Class, ShapeCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SlopeElevationTarget Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class
SlopeElevationTarget Class
Collapse All

The SlopeElevation class.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SlopeElevationTarget
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccSlopeElevationTarget"))]
public class SlopeElevationTarget : CivilWrapper<AeccSlopeElevationTarget>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccSlopeElevationTarget"))>
Public Class SlopeElevationTarget
Inherits CivilWrapper<AeccSlopeElevationTarget>
Links
SlopeElevationTarget Methods, SlopeElevationTarget Constructors, SlopeElevationTarget Properties, SlopeElevationTarget Members, Class Hierarchy


SlopeElevationTarget Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Members
SlopeElevationTarget Members
Collapse All

The following tables list the members exposed by SlopeElevationTarget.

Public Methods
Public Method | Description
GetElevation | Overloaded
GetNearestPipeOfNetworkToAlignment | Overloaded
SlopeElevationTarget | This is SlopeElevationTarget, a member of class SlopeElevationTarget.
Public Properties
Public Property | Description
TargetId | This is TargetId, a member of class SlopeElevationTarget.
Links
Public Methods, Public Properties


SlopeElevationTarget Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Methods
SlopeElevationTarget Methods
Collapse All

The methods of SlopeElevationTarget are listed here.

Public Methods
Public Method | Description
GetElevation | Overloaded
GetNearestPipeOfNetworkToAlignment | Overloaded
Links
Public Methods


GetElevation Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Methods > GetElevation Method
GetElevation Method
Collapse All

Overloaded

Overload List
Method | Description
SlopeElevationTarget::GetElevation (Autodesk::AutoCAD::DatabaseServices::ObjectId, double) | This is GetElevation, a member of class SlopeElevationTarget.
SlopeElevationTarget::GetElevation (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide) | This is GetElevation, a member of class SlopeElevationTarget.


SlopeElevationTarget::GetElevation Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Methods > GetElevation Method > SlopeElevationTarget::GetElevation Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double)
SlopeElevationTarget::GetElevation Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double)
Collapse All

This is GetElevation, a member of class SlopeElevationTarget.

C#
public double GetElevation(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double stationOnAlignment
);
Visual Basic
Public Function GetElevation(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    stationOnAlignment As double
) As double
Links
SlopeElevationTarget Class, SlopeElevationTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SlopeElevationTarget::GetElevation Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Methods > GetElevation Method > SlopeElevationTarget::GetElevation Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide)
SlopeElevationTarget::GetElevation Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide)
Collapse All

This is GetElevation, a member of class SlopeElevationTarget.

C#
public double GetElevation(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double stationOnAlignment,
    Autodesk::Civil::Land::DatabaseServices::AlignmentSide side
);
Visual Basic
Public Function GetElevation(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    stationOnAlignment As double,
    side As Autodesk::Civil::Land::DatabaseServices::AlignmentSide
) As double
Links
SlopeElevationTarget Class, SlopeElevationTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


GetNearestPipeOfNetworkToAlignment Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Methods > GetNearestPipeOfNetworkToAlignment Method
GetNearestPipeOfNetworkToAlignment Method
Collapse All

Overloaded

Overload List
Method | Description
SlopeElevationTarget::GetNearestPipeOfNetworkToAlignment (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%) | This is GetNearestPipeOfNetworkToAlignment, a member of class SlopeElevationTarget.
SlopeElevationTarget::GetNearestPipeOfNetworkToAlignment (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, Autodesk::AutoCAD::DatabaseServices::ObjectId%) | This is GetNearestPipeOfNetworkToAlignment, a member of class SlopeElevationTarget.


SlopeElevationTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Methods > GetNearestPipeOfNetworkToAlignment Method > SlopeElevationTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%)
SlopeElevationTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%)
Collapse All

This is GetNearestPipeOfNetworkToAlignment, a member of class SlopeElevationTarget.

C#
public GetNearestPipeOfNetworkToAlignment(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double stationOnAlignment,
    Autodesk::AutoCAD::DatabaseServices::ObjectId% pipeId
);
Visual Basic
Public Sub GetNearestPipeOfNetworkToAlignment(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    stationOnAlignment As double,
    pipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId%
)
Links
SlopeElevationTarget Class, SlopeElevationTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SlopeElevationTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, Autodesk::AutoCAD::DatabaseServices::ObjectId%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Methods > GetNearestPipeOfNetworkToAlignment Method > SlopeElevationTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, Autodesk::AutoCAD::DatabaseServices::ObjectId%)
SlopeElevationTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, Autodesk::AutoCAD::DatabaseServices::ObjectId%)
Collapse All

This is GetNearestPipeOfNetworkToAlignment, a member of class SlopeElevationTarget.

C#
public GetNearestPipeOfNetworkToAlignment(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double stationOnAlignment,
    Autodesk::Civil::Land::DatabaseServices::AlignmentSide side,
    Autodesk::AutoCAD::DatabaseServices::ObjectId% pipeId
);
Visual Basic
Public Sub GetNearestPipeOfNetworkToAlignment(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    stationOnAlignment As double,
    side As Autodesk::Civil::Land::DatabaseServices::AlignmentSide,
    pipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId%
)
Links
SlopeElevationTarget Class, SlopeElevationTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SlopeElevationTarget Constructors

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Constructors
SlopeElevationTarget Constructors
Collapse All

The constructors of SlopeElevationTarget are listed here.

Public Methods
Public Method | Description
SlopeElevationTarget | This is SlopeElevationTarget, a member of class SlopeElevationTarget.
Links
Public Methods


SlopeElevationTarget::SlopeElevationTarget Constructor

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Constructors > SlopeElevationTarget::SlopeElevationTarget Constructor
SlopeElevationTarget::SlopeElevationTarget Constructor
Collapse All

This is SlopeElevationTarget, a member of class SlopeElevationTarget.

C#
public SlopeElevationTarget(
    Autodesk::AutoCAD::DatabaseServices::ObjectId targetId
);
Visual Basic
Public Sub New(
    targetId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Links
SlopeElevationTarget Class, SlopeElevationTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SlopeElevationTarget Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Properties
SlopeElevationTarget Properties
Collapse All

The properties of SlopeElevationTarget are listed here.

Public Properties
Public Property | Description
TargetId | This is TargetId, a member of class SlopeElevationTarget.
Links
Public Properties


SlopeElevationTarget::TargetId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Properties > SlopeElevationTarget::TargetId Property
SlopeElevationTarget::TargetId Property
Collapse All

This is TargetId, a member of class SlopeElevationTarget.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TargetId;
Visual Basic
Public Property TargetId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SlopeElevationTarget Class, SlopeElevationTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class
Subassembly Class
Collapse All

Pattern for part of a corridor cross section, representing a particular portion of a roadway.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Roadway::DatabaseServices::Subassembly
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSubassembly"))]
public class Subassembly : Autodesk::Civil::DatabaseServices::GeoEntity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSubassembly"))>
Public Class Subassembly
Inherits Autodesk::Civil::DatabaseServices::GeoEntity
Remarks

Subassemblies are the basic building blocks of a corridor design. A subassembly is an AutoCAD drawing object (AECCSubassembly) that defines the geometry of a component used in a corridor section. A subassembly consists of a series of shapes, links, and points. Through the tool palette and tool catalogues, Autodesk Civil 3D provides preconfigured subassemblies for components such as carriageways, kerbs, batter slopes and ditches. These subassemblies are defined by a set of points, links, and optionally closed areas referred to as shapes.

The subassemblies provided with Autodesk Civil 3D have built-in intelligent behavior. They can automatically adapt to conditions such as superelevation and cut or fill requirements. For example, a slope subassembly has variable slopes that change automatically depending on the depth of cut along the corridor. In fill conditions exceeding a given depth, the verge automatically widens to include a guardrail or barrier.

Links
Subassembly Methods, Subassembly Properties, Subassembly Members, Class Hierarchy


Subassembly Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Members
Subassembly Members
Collapse All

The following tables list the members exposed by Subassembly.

Public Methods
Public Method | Description
EraseAllParams | Erases all the subassembly's script parameters.
GetResourceString | Overloaded
Run | Runs the callback function associated with the Subassembly.
ShowHelp | Shows the help information associated with a subassembly.
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
AssemblyId | Gets the ID of the Assembly this Subassembly belongs to.
AttachedToOffsetAssembly | Gets a bool value that specifies whether the subassembly is attached to a offset assembly or a main assembly.
CodeSetStyleName | Gets or sets the code set style name.
DefaultLoopInLayoutMode | Gets or sets a flag indicating if the first or last point in the subassembly is used as the loop... more
DefaultLoopOffsetInLayoutMode | Gets or sets the default loop point offset distance for subassembly in layout mode.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GeometryGenerator | Gets or sets the SubassemblyGenerator object that controls how the Subassembly geometry is generated.
HasParentAssembly | Returns true if this Subassembly has a parent Assembly.
HelpCommand | Gets or sets the command to invoke the Subassembly help.
HelpData | Gets or sets help data for the Subassembly.
HelpFile | Gets or sets the file name of the Subassembly help file.
IsDynamic | Returns true if the subassembly dynamically computes its state.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Links | Gets the Links collection.
Name | Gets or sets the Entity object's name.
OffsetToAssembly | Gets a vector value that specifies the offset to the assembly it belongs to in layout mode.
OffsetToBaseline | Gets a vector value that specifies the offset to the assembly or offset assembly it attached in layout mode.
ParamsBool | Gets the Boolean parameters collection.
ParamsDouble | Gets the Double parameters collection.
ParamsLong | Gets the Long parameters collection.
ParamsString | Gets the String parameters collection.
Points | Gets the Points collection.
ResourceModule | Gets or sets the Subassembly resource module file.
Shapes | Gets the Shapes collection.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | The name of the Subassembly style.
SubassemblyHookTo | Gets the object id of the Subassembly which it hook to
UseEmbeddedProject | Gets or sets whether the Subassembly uses macros in embedded projects.
Links
Public Methods, Public Properties


Subassembly Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Methods
Subassembly Methods
Collapse All

The methods of Subassembly are listed here.

Public Methods
Public Method | Description
EraseAllParams | Erases all the subassembly's script parameters.
GetResourceString | Overloaded
Run | Runs the callback function associated with the Subassembly.
ShowHelp | Shows the help information associated with a subassembly.
Links
Public Methods


Subassembly::EraseAllParams Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Methods > Subassembly::EraseAllParams Method
Subassembly::EraseAllParams Method
Collapse All

Erases all the subassembly's script parameters.

C#
public EraseAllParams();
Visual Basic
Public Sub EraseAllParams()
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


GetResourceString Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Methods > GetResourceString Method
GetResourceString Method
Collapse All

Overloaded

Overload List
Method | Description
Subassembly::GetResourceString (System::String^) | Converts a resource id (string) to a resource string from the current subassembly's resource module.
Subassembly::GetResourceString (unsigned long) | Converts a resource id (numeric) to a resource string from the current subassembly's resource module.


Subassembly::GetResourceString Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Methods > GetResourceString Method > Subassembly::GetResourceString Method (System::String^)
Subassembly::GetResourceString Method (System::String^)
Collapse All

Converts a resource id (string) to a resource string from the current subassembly's resource module.

C#
public System::String GetResourceString(
    ref System::String resourceId
);
Visual Basic
Public Function GetResourceString(
    ByRef resourceId As System::String
) As System::String
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::GetResourceString Method (unsigned long)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Methods > GetResourceString Method > Subassembly::GetResourceString Method (unsigned long)
Subassembly::GetResourceString Method (unsigned long)
Collapse All

Converts a resource id (numeric) to a resource string from the current subassembly's resource module.

C#
public System::String GetResourceString(
    unsigned long resourceId
);
Visual Basic
Public Function GetResourceString(
    resourceId As unsigned long
) As System::String
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::Run Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Methods > Subassembly::Run Method
Subassembly::Run Method
Collapse All

Runs the callback function associated with the Subassembly.

C#
public Run();
Visual Basic
Public Sub Run()
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::ShowHelp Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Methods > Subassembly::ShowHelp Method
Subassembly::ShowHelp Method
Collapse All

Shows the help information associated with a subassembly.

C#
public ShowHelp();
Visual Basic
Public Sub ShowHelp()
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties
Subassembly Properties
Collapse All

The properties of Subassembly are listed here.

Public Properties
Public Property | Description
AssemblyId | Gets the ID of the Assembly this Subassembly belongs to.
AttachedToOffsetAssembly | Gets a bool value that specifies whether the subassembly is attached to a offset assembly or a main assembly.
CodeSetStyleName | Gets or sets the code set style name.
DefaultLoopInLayoutMode | Gets or sets a flag indicating if the first or last point in the subassembly is used as the loop... more
DefaultLoopOffsetInLayoutMode | Gets or sets the default loop point offset distance for subassembly in layout mode.
GeometryGenerator | Gets or sets the SubassemblyGenerator object that controls how the Subassembly geometry is generated.
HasParentAssembly | Returns true if this Subassembly has a parent Assembly.
HelpCommand | Gets or sets the command to invoke the Subassembly help.
HelpData | Gets or sets help data for the Subassembly.
HelpFile | Gets or sets the file name of the Subassembly help file.
IsDynamic | Returns true if the subassembly dynamically computes its state.
Links | Gets the Links collection.
OffsetToAssembly | Gets a vector value that specifies the offset to the assembly it belongs to in layout mode.
OffsetToBaseline | Gets a vector value that specifies the offset to the assembly or offset assembly it attached in layout mode.
ParamsBool | Gets the Boolean parameters collection.
ParamsDouble | Gets the Double parameters collection.
ParamsLong | Gets the Long parameters collection.
ParamsString | Gets the String parameters collection.
Points | Gets the Points collection.
ResourceModule | Gets or sets the Subassembly resource module file.
Shapes | Gets the Shapes collection.
StyleName | The name of the Subassembly style.
SubassemblyHookTo | Gets the object id of the Subassembly which it hook to
UseEmbeddedProject | Gets or sets whether the Subassembly uses macros in embedded projects.
Links
Public Properties


Subassembly::AssemblyId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::AssemblyId Property
Subassembly::AssemblyId Property
Collapse All

Gets the ID of the Assembly this Subassembly belongs to.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId AssemblyId;
Visual Basic
Public Property AssemblyId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::AttachedToOffsetAssembly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::AttachedToOffsetAssembly Property
Subassembly::AttachedToOffsetAssembly Property
Collapse All

Gets a bool value that specifies whether the subassembly is attached to a offset assembly or a main assembly.

C#
public bool AttachedToOffsetAssembly;
Visual Basic
Public Property AttachedToOffsetAssembly() As bool
Remarks

Use Subassembly.HasParentAssembly to check whether it is attached to a assembly before using this property.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the subassembly is not attached to any assembly.
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::CodeSetStyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::CodeSetStyleName Property
Subassembly::CodeSetStyleName Property
Collapse All

Gets or sets the code set style name.

C#
public System::String CodeSetStyleName;
Visual Basic
Public Property CodeSetStyleName() As System::String
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::DefaultLoopInLayoutMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::DefaultLoopInLayoutMode Property
Subassembly::DefaultLoopInLayoutMode Property
Collapse All

Gets or sets a flag indicating if the first or last point in the subassembly is used as the loop point in layout mode.

C#
public bool DefaultLoopInLayoutMode;
Visual Basic
Public Property DefaultLoopInLayoutMode() As bool
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::DefaultLoopOffsetInLayoutMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::DefaultLoopOffsetInLayoutMode Property
Subassembly::DefaultLoopOffsetInLayoutMode Property
Collapse All

Gets or sets the default loop point offset distance for subassembly in layout mode.

C#
public double DefaultLoopOffsetInLayoutMode;
Visual Basic
Public Property DefaultLoopOffsetInLayoutMode() As double
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::GeometryGenerator Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::GeometryGenerator Property
Subassembly::GeometryGenerator Property
Collapse All

Gets or sets the SubassemblyGenerator object that controls how the Subassembly geometry is generated.

C#
public SubassemblyGenerator GeometryGenerator;
Visual Basic
Public Property GeometryGenerator() As SubassemblyGenerator
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::HasParentAssembly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::HasParentAssembly Property
Subassembly::HasParentAssembly Property
Collapse All

Returns true if this Subassembly has a parent Assembly.

C#
public bool HasParentAssembly;
Visual Basic
Public Property HasParentAssembly() As bool
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::HelpCommand Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::HelpCommand Property
Subassembly::HelpCommand Property
Collapse All

Gets or sets the command to invoke the Subassembly help.

C#
public System::String HelpCommand;
Visual Basic
Public Property HelpCommand() As System::String
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::HelpData Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::HelpData Property
Subassembly::HelpData Property
Collapse All

Gets or sets help data for the Subassembly.

C#
public System::String HelpData;
Visual Basic
Public Property HelpData() As System::String
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::HelpFile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::HelpFile Property
Subassembly::HelpFile Property
Collapse All

Gets or sets the file name of the Subassembly help file.

C#
public System::String HelpFile;
Visual Basic
Public Property HelpFile() As System::String
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::IsDynamic Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::IsDynamic Property
Subassembly::IsDynamic Property
Collapse All

Returns true if the subassembly dynamically computes its state.

C#
public bool IsDynamic;
Visual Basic
Public Property IsDynamic() As bool
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::Links Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::Links Property
Subassembly::Links Property
Collapse All

Gets the Links collection.

C#
public LinkCollection Links;
Visual Basic
Public Property Links() As LinkCollection
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::OffsetToAssembly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::OffsetToAssembly Property
Subassembly::OffsetToAssembly Property
Collapse All

Gets a vector value that specifies the offset to the assembly it belongs to in layout mode.

C#
public Autodesk::AutoCAD::Geometry::Vector2d OffsetToAssembly;
Visual Basic
Public Property OffsetToAssembly() As Autodesk::AutoCAD::Geometry::Vector2d
Remarks

Use Subassembly.HasParentAssembly to check whether it is attached to a assembly before using this property. When it is attached to an offset assembly, this property is different from Subassembly.OffsetToBaseline, otherwise they return the same value.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the subassembly is not attached to any assembly.
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::OffsetToBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::OffsetToBaseline Property
Subassembly::OffsetToBaseline Property
Collapse All

Gets a vector value that specifies the offset to the assembly or offset assembly it attached in layout mode.

C#
public Autodesk::AutoCAD::Geometry::Vector2d OffsetToBaseline;
Visual Basic
Public Property OffsetToBaseline() As Autodesk::AutoCAD::Geometry::Vector2d
Remarks

Use Subassembly.HasParentAssembly to check whether it is attached to a assembly before using this property. When it is attached to an offset assembly, this property is different from Subassembly.OffsetToAssembly, otherwise they return the same value.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the subassembly is not attached to any assembly.
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::ParamsBool Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::ParamsBool Property
Subassembly::ParamsBool Property
Collapse All

Gets the Boolean parameters collection.

C#
public Autodesk::Civil::Runtime::ParamBoolCollection ParamsBool;
Visual Basic
Public Property ParamsBool() As Autodesk::Civil::Runtime::ParamBoolCollection
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::ParamsDouble Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::ParamsDouble Property
Subassembly::ParamsDouble Property
Collapse All

Gets the Double parameters collection.

C#
public Autodesk::Civil::Runtime::ParamDoubleCollection ParamsDouble;
Visual Basic
Public Property ParamsDouble() As Autodesk::Civil::Runtime::ParamDoubleCollection
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::ParamsLong Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::ParamsLong Property
Subassembly::ParamsLong Property
Collapse All

Gets the Long parameters collection.

C#
public Autodesk::Civil::Runtime::ParamLongCollection ParamsLong;
Visual Basic
Public Property ParamsLong() As Autodesk::Civil::Runtime::ParamLongCollection
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::ParamsString Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::ParamsString Property
Subassembly::ParamsString Property
Collapse All

Gets the String parameters collection.

C#
public Autodesk::Civil::Runtime::ParamStringCollection ParamsString;
Visual Basic
Public Property ParamsString() As Autodesk::Civil::Runtime::ParamStringCollection
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::Points Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::Points Property
Subassembly::Points Property
Collapse All

Gets the Points collection.

C#
public PointCollection Points;
Visual Basic
Public Property Points() As PointCollection
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::ResourceModule Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::ResourceModule Property
Subassembly::ResourceModule Property
Collapse All

Gets or sets the Subassembly resource module file.

C#
public System::String ResourceModule;
Visual Basic
Public Property ResourceModule() As System::String
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::Shapes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::Shapes Property
Subassembly::Shapes Property
Collapse All

Gets the Shapes collection.

C#
public ShapeCollection Shapes;
Visual Basic
Public Property Shapes() As ShapeCollection
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::StyleName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::StyleName Property
Subassembly::StyleName Property
Collapse All

The name of the Subassembly style.

C#
public System::String StyleName;
Visual Basic
Public Property StyleName() As System::String
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::SubassemblyHookTo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::SubassemblyHookTo Property
Subassembly::SubassemblyHookTo Property
Collapse All

Gets the object id of the Subassembly which it hook to

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId SubassemblyHookTo;
Visual Basic
Public Property SubassemblyHookTo() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

It returns null when (1) the Subassembly isn't in an Assembly (2) or the Subassembly is in an Assembly and hook to this assembly

Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Subassembly::UseEmbeddedProject Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties > Subassembly::UseEmbeddedProject Property
Subassembly::UseEmbeddedProject Property
Collapse All

Gets or sets whether the Subassembly uses macros in embedded projects.

C#
public bool UseEmbeddedProject;
Visual Basic
Public Property UseEmbeddedProject() As bool
Links
Subassembly Class, Subassembly Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SubassemblyCollection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class
SubassemblyCollection Class
Collapse All

A collection of Subassembly objects.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SubassemblyCollection
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AcDbDatabase"))]
public class SubassemblyCollection : CivilWrapper<AcDbDatabase>, System::Collections::Generic::IEnumerable<Autodesk::AutoCAD::DatabaseServices::ObjectId>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AcDbDatabase"))>
Public Class SubassemblyCollection
Inherits CivilWrapper<AcDbDatabase>
Inherits System::Collections::Generic::IEnumerable<Autodesk::AutoCAD::DatabaseServices::ObjectId>
Links
SubassemblyCollection Methods, SubassemblyCollection Properties, SubassemblyCollection Members, Class Hierarchy


SubassemblyCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Members
SubassemblyCollection Members
Collapse All

The following tables list the members exposed by SubassemblyCollection.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Public Properties
Public Property | Description
Count | Gets the number of Subassembly objects in the collection.
default | Gets a Subassembly by name.
Links
Public Methods, Public Properties


SubassemblyCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Methods
SubassemblyCollection Methods
Collapse All

The methods of SubassemblyCollection are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Links
Public Methods


SubassemblyCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Methods > SubassemblyCollection::GetEnumerator Method
SubassemblyCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<Autodesk::AutoCAD::DatabaseServices::ObjectId> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<Autodesk::AutoCAD::DatabaseServices::ObjectId>
Returns

An enumerator which implements the IEnumerator<T> interface.

Links
SubassemblyCollection Class, SubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SubassemblyCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Methods > SubassemblyCollection::GetObjectEnumerator Method
SubassemblyCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
SubassemblyCollection Class, SubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SubassemblyCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Properties
SubassemblyCollection Properties
Collapse All

The properties of SubassemblyCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of Subassembly objects in the collection.
default | Gets a Subassembly by name.
Links
Public Properties


SubassemblyCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Properties > SubassemblyCollection::Count Property
SubassemblyCollection::Count Property
Collapse All

Gets the number of Subassembly objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
SubassemblyCollection Class, SubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SubassemblyCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Properties > SubassemblyCollection::default Property
SubassemblyCollection::default Property
Collapse All

Gets a Subassembly by name.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId default;
Visual Basic
Public Property default() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
SubassemblyCollection Class, SubassemblyCollection Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SubassemblyGenerator Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class
SubassemblyGenerator Class
Collapse All

Controls the way Subassembly geometry is generated.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SubassemblyGenerator
C#
public class SubassemblyGenerator;
Visual Basic
Public Class SubassemblyGenerator
Links
SubassemblyGenerator Constructors, SubassemblyGenerator Properties, SubassemblyGenerator Members, Class Hierarchy


SubassemblyGenerator Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Members
SubassemblyGenerator Members
Collapse All

The following tables list the members exposed by SubassemblyGenerator.

Public Methods
Public Method | Description
SubassemblyGenerator | Constructor.
Public Properties
Public Property | Description
GeometryGenerateMode | Gets or sets the way the Subassembly geometry is generated.
MacroOrClassName | Gets or sets the macro or class name. This is the class name when GeometryGenerateMode is UseDotNet.
ProjectOrAssemblyName | Gets or sets the project or assembly name. This is the assembly name when GeometryGenerateMode is UseDotNet.
Links
Public Methods, Public Properties


SubassemblyGenerator Constructors

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Constructors
SubassemblyGenerator Constructors
Collapse All

The constructors of SubassemblyGenerator are listed here.

Public Methods
Public Method | Description
SubassemblyGenerator | Constructor.
Links
Public Methods


SubassemblyGenerator::SubassemblyGenerator Constructor

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Constructors > SubassemblyGenerator::SubassemblyGenerator Constructor
SubassemblyGenerator::SubassemblyGenerator Constructor
Collapse All

Constructor.

C#
public SubassemblyGenerator(
    SubassemblyGeometryGenerateMode mode,
    ref System::String projectOrAssemblyName,
    ref System::String macroOrClassName
);
Visual Basic
Public Sub New(
    mode As SubassemblyGeometryGenerateMode,
    ByRef projectOrAssemblyName As System::String,
    ByRef macroOrClassName As System::String
)
Links
SubassemblyGenerator Class, SubassemblyGenerator Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SubassemblyGenerator Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Properties
SubassemblyGenerator Properties
Collapse All

The properties of SubassemblyGenerator are listed here.

Public Properties
Public Property | Description
GeometryGenerateMode | Gets or sets the way the Subassembly geometry is generated.
MacroOrClassName | Gets or sets the macro or class name. This is the class name when GeometryGenerateMode is UseDotNet.
ProjectOrAssemblyName | Gets or sets the project or assembly name. This is the assembly name when GeometryGenerateMode is UseDotNet.
Links
Public Properties


SubassemblyGenerator::GeometryGenerateMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Properties > SubassemblyGenerator::GeometryGenerateMode Property
SubassemblyGenerator::GeometryGenerateMode Property
Collapse All

Gets or sets the way the Subassembly geometry is generated.

C#
public SubassemblyGeometryGenerateMode GeometryGenerateMode;
Visual Basic
Public Property GeometryGenerateMode() As SubassemblyGeometryGenerateMode
Links
SubassemblyGenerator Class, SubassemblyGenerator Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SubassemblyGenerator::MacroOrClassName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Properties > SubassemblyGenerator::MacroOrClassName Property
SubassemblyGenerator::MacroOrClassName Property
Collapse All

Gets or sets the macro or class name. This is the class name when GeometryGenerateMode is UseDotNet.

C#
public System::String MacroOrClassName;
Visual Basic
Public Property MacroOrClassName() As System::String
Links
SubassemblyGenerator Class, SubassemblyGenerator Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


SubassemblyGenerator::ProjectOrAssemblyName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Properties > SubassemblyGenerator::ProjectOrAssemblyName Property
SubassemblyGenerator::ProjectOrAssemblyName Property
Collapse All

Gets or sets the project or assembly name. This is the assembly name when GeometryGenerateMode is UseDotNet.

C#
public System::String ProjectOrAssemblyName;
Visual Basic
Public Property ProjectOrAssemblyName() As System::String
Links
SubassemblyGenerator Class, SubassemblyGenerator Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


WidthOffsetTarget Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class
WidthOffsetTarget Class
Collapse All

The WidthOffsetTarget class.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::WidthOffsetTarget
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccWidthOffsetTarget"))]
public class WidthOffsetTarget : CivilWrapper<AeccWidthOffsetTarget>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccWidthOffsetTarget"))>
Public Class WidthOffsetTarget
Inherits CivilWrapper<AeccWidthOffsetTarget>
Links
WidthOffsetTarget Methods, WidthOffsetTarget Constructors, WidthOffsetTarget Properties, WidthOffsetTarget Members, Class Hierarchy


WidthOffsetTarget Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Members
WidthOffsetTarget Members
Collapse All

The following tables list the members exposed by WidthOffsetTarget.

Public Methods
Public Method | Description
GetDistanceToAlignment | Overloaded
GetNearestPipeOfNetworkToAlignment | Overloaded
WidthOffsetTarget | This is WidthOffsetTarget, a member of class WidthOffsetTarget.
Public Properties
Public Property | Description
TargetId | This is TargetId, a member of class WidthOffsetTarget.
Links
Public Methods, Public Properties


WidthOffsetTarget Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Methods
WidthOffsetTarget Methods
Collapse All

The methods of WidthOffsetTarget are listed here.

Public Methods
Public Method | Description
GetDistanceToAlignment | Overloaded
GetNearestPipeOfNetworkToAlignment | Overloaded
Links
Public Methods


GetDistanceToAlignment Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Methods > GetDistanceToAlignment Method
GetDistanceToAlignment Method
Collapse All

Overloaded

Overload List
Method | Description
WidthOffsetTarget::GetDistanceToAlignment (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, double%, double%) | This is GetDistanceToAlignment, a member of class WidthOffsetTarget.
WidthOffsetTarget::GetDistanceToAlignment (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, double%, double%) | This is GetDistanceToAlignment, a member of class WidthOffsetTarget.


WidthOffsetTarget::GetDistanceToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, double%, double%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Methods > GetDistanceToAlignment Method > WidthOffsetTarget::GetDistanceToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, double%, double%)
WidthOffsetTarget::GetDistanceToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, double%, double%)
Collapse All

This is GetDistanceToAlignment, a member of class WidthOffsetTarget.

C#
public double GetDistanceToAlignment(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double stationOnAlignment,
    Autodesk::Civil::Land::DatabaseServices::AlignmentSide side,
    double% xOnTarget,
    double% yOnTarget
);
Visual Basic
Public Function GetDistanceToAlignment(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    stationOnAlignment As double,
    side As Autodesk::Civil::Land::DatabaseServices::AlignmentSide,
    xOnTarget As double%,
    yOnTarget As double%
) As double
Links
WidthOffsetTarget Class, WidthOffsetTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


WidthOffsetTarget::GetDistanceToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, double%, double%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Methods > GetDistanceToAlignment Method > WidthOffsetTarget::GetDistanceToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, double%, double%)
WidthOffsetTarget::GetDistanceToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, double%, double%)
Collapse All

This is GetDistanceToAlignment, a member of class WidthOffsetTarget.

C#
public double GetDistanceToAlignment(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double stationOnAlignment,
    double% xOnTarget,
    double% yOnTarget
);
Visual Basic
Public Function GetDistanceToAlignment(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    stationOnAlignment As double,
    xOnTarget As double%,
    yOnTarget As double%
) As double
Links
WidthOffsetTarget Class, WidthOffsetTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


GetNearestPipeOfNetworkToAlignment Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Methods > GetNearestPipeOfNetworkToAlignment Method
GetNearestPipeOfNetworkToAlignment Method
Collapse All

Overloaded

Overload List
Method | Description
WidthOffsetTarget::GetNearestPipeOfNetworkToAlignment (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%) | This is GetNearestPipeOfNetworkToAlignment, a member of class WidthOffsetTarget.
WidthOffsetTarget::GetNearestPipeOfNetworkToAlignment (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, Autodesk::AutoCAD::DatabaseServices::ObjectId%) | This is GetNearestPipeOfNetworkToAlignment, a member of class WidthOffsetTarget.


WidthOffsetTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Methods > GetNearestPipeOfNetworkToAlignment Method > WidthOffsetTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%)
WidthOffsetTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::AutoCAD::DatabaseServices::ObjectId%)
Collapse All

This is GetNearestPipeOfNetworkToAlignment, a member of class WidthOffsetTarget.

C#
public GetNearestPipeOfNetworkToAlignment(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double stationOnAlignment,
    Autodesk::AutoCAD::DatabaseServices::ObjectId% pipeId
);
Visual Basic
Public Sub GetNearestPipeOfNetworkToAlignment(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    stationOnAlignment As double,
    pipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId%
)
Links
WidthOffsetTarget Class, WidthOffsetTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


WidthOffsetTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, Autodesk::AutoCAD::DatabaseServices::ObjectId%)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Methods > GetNearestPipeOfNetworkToAlignment Method > WidthOffsetTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, Autodesk::AutoCAD::DatabaseServices::ObjectId%)
WidthOffsetTarget::GetNearestPipeOfNetworkToAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, double, Autodesk::Civil::Land::DatabaseServices::AlignmentSide, Autodesk::AutoCAD::DatabaseServices::ObjectId%)
Collapse All

This is GetNearestPipeOfNetworkToAlignment, a member of class WidthOffsetTarget.

C#
public GetNearestPipeOfNetworkToAlignment(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double stationOnAlignment,
    Autodesk::Civil::Land::DatabaseServices::AlignmentSide side,
    Autodesk::AutoCAD::DatabaseServices::ObjectId% pipeId
);
Visual Basic
Public Sub GetNearestPipeOfNetworkToAlignment(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    stationOnAlignment As double,
    side As Autodesk::Civil::Land::DatabaseServices::AlignmentSide,
    pipeId As Autodesk::AutoCAD::DatabaseServices::ObjectId%
)
Links
WidthOffsetTarget Class, WidthOffsetTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


WidthOffsetTarget Constructors

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Constructors
WidthOffsetTarget Constructors
Collapse All

The constructors of WidthOffsetTarget are listed here.

Public Methods
Public Method | Description
WidthOffsetTarget | This is WidthOffsetTarget, a member of class WidthOffsetTarget.
Links
Public Methods


WidthOffsetTarget::WidthOffsetTarget Constructor

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Constructors > WidthOffsetTarget::WidthOffsetTarget Constructor
WidthOffsetTarget::WidthOffsetTarget Constructor
Collapse All

This is WidthOffsetTarget, a member of class WidthOffsetTarget.

C#
public WidthOffsetTarget(
    Autodesk::AutoCAD::DatabaseServices::ObjectId targetId
);
Visual Basic
Public Sub New(
    targetId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Links
WidthOffsetTarget Class, WidthOffsetTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


WidthOffsetTarget Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Properties
WidthOffsetTarget Properties
Collapse All

The properties of WidthOffsetTarget are listed here.

Public Properties
Public Property | Description
TargetId | This is TargetId, a member of class WidthOffsetTarget.
Links
Public Properties


WidthOffsetTarget::TargetId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Properties > WidthOffsetTarget::TargetId Property
WidthOffsetTarget::TargetId Property
Collapse All

This is TargetId, a member of class WidthOffsetTarget.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId TargetId;
Visual Basic
Public Property TargetId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
WidthOffsetTarget Class, WidthOffsetTarget Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Interfaces

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces
Interfaces
Collapse All

The following table lists interfaces in this documentation.

Interfaces
Interface | Description
IPoint | This is class Autodesk::Civil::Roadway::DatabaseServices::IPoint.
Links
Interfaces


IPoint Interface

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface
IPoint Interface
Collapse All

This is class Autodesk::Civil::Roadway::DatabaseServices::IPoint.

Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IPoint
    Autodesk::Civil::Roadway::DatabaseServices::Point
C#
public interface IPoint;
Visual Basic
Public Interface IPoint
Links
IPoint Properties, IPoint Members, Class Hierarchy


IPoint Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Members
IPoint Members
Collapse All

The following tables list the members exposed by IPoint.

Public Properties
Public Property | Description
Codes | Gets the roadway codes.
Elevation | Gets or sets the point elevation.
Index | Gets the point index.
Offset | Gets or sets the point offset.
Station | Gets or sets the point station.
Links
Public Properties


IPoint Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Properties
IPoint Properties
Collapse All

The properties of IPoint are listed here.

Public Properties
Public Property | Description
Codes | Gets the roadway codes.
Elevation | Gets or sets the point elevation.
Index | Gets the point index.
Offset | Gets or sets the point offset.
Station | Gets or sets the point station.
Links
Public Properties


IPoint::Codes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Properties > IPoint::Codes Property
IPoint::Codes Property
Collapse All

Gets the roadway codes.

C#
CodeCollection Codes;
Visual Basic
Property Codes() As CodeCollection
Links
IPoint Interface, IPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IPoint::Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Properties > IPoint::Elevation Property
IPoint::Elevation Property
Collapse All

Gets or sets the point elevation.

C#
double Elevation;
Visual Basic
Property Elevation() As double
Links
IPoint Interface, IPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IPoint::Index Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Properties > IPoint::Index Property
IPoint::Index Property
Collapse All

Gets the point index.

C#
int Index;
Visual Basic
Property Index() As Integer
Links
IPoint Interface, IPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IPoint::Offset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Properties > IPoint::Offset Property
IPoint::Offset Property
Collapse All

Gets or sets the point offset.

C#
double Offset;
Visual Basic
Property Offset() As double
Links
IPoint Interface, IPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


IPoint::Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Properties > IPoint::Station Property
IPoint::Station Property
Collapse All

Gets or sets the point station.

C#
double Station;
Visual Basic
Property Station() As double
Links
IPoint Interface, IPoint Members, Autodesk::Civil::Roadway::DatabaseServices Namespace


Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums
Structs, Records, Enums
Collapse All

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
CorridorBaselineType | Enumerates baseline types.
CorridorLinkDisplay | The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDisplay enumeration.
CorridorLinkDrawOverride | The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDrawOverride enumeration.
CorridorSurfaceBoundaryType | Defines CorridorSurfaceBoundary types.
CurbReturnJoiningType | Specifies the method that is used to define the curb return profile.
IntersectionCorridorType | Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options... more
MaterialConditionType | An enumeration that specifies the material condition type.
MaterialItemType | An enumeration that specifies the material item type.
MaterialQuantityType | An enumeration that specifies the material quantity type.
OffsetLengthOption | Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are... more
SideRoadProfileDistanceRuleType | Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is... more
SubassemblyGeometryGenerateMode | Enumerates the way subassembly geometry can be generated.
Links
Enumerations


Autodesk::Civil::Roadway::DatabaseServices::CorridorBaselineType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::CorridorBaselineType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::CorridorBaselineType Enumeration
Collapse All

Enumerates baseline types.

C#
public enum CorridorBaselineType {
  None = 0,
  MainBaseline = 1,
  OffsetBaseline = 2,
  HardcodedOffsetBaseline = 3
}
Visual Basic
Public Enum CorridorBaselineType
  None = 0
  MainBaseline = 1
  OffsetBaseline = 2
  HardcodedOffsetBaseline = 3
End Enum


Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDisplay Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDisplay Enumeration
Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDisplay Enumeration
Collapse All

The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDisplay enumeration.

C#
public enum CorridorLinkDisplay {
  Normal = 0,
  NormalWithArrowhead = 1,
  Dashed = 2,
  DashedWithArrowhead = 3
}
Visual Basic
Public Enum CorridorLinkDisplay
  Normal = 0
  NormalWithArrowhead = 1
  Dashed = 2
  DashedWithArrowhead = 3
End Enum


Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDrawOverride Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDrawOverride Enumeration
Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDrawOverride Enumeration
Collapse All

The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDrawOverride enumeration.

C#
public enum CorridorLinkDrawOverride {
  Normal = AeccSubassemblyLinkData::kDrawOverrideNormal,
  Dashed = AeccSubassemblyLinkData::kDrawOverrideDashed,
  WithArrowhead = AeccSubassemblyLinkData::kDrawOverrideWithArrowhead
}
Visual Basic
Public Enum CorridorLinkDrawOverride
  Normal = AeccSubassemblyLinkData::kDrawOverrideNormal
  Dashed = AeccSubassemblyLinkData::kDrawOverrideDashed
  WithArrowhead = AeccSubassemblyLinkData::kDrawOverrideWithArrowhead
End Enum


Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryType Enumeration
Collapse All

Defines CorridorSurfaceBoundary types.

C#
public enum CorridorSurfaceBoundaryType {
  InsideBoundary = 0,
  OutsideBoundary = 0x1
}
Visual Basic
Public Enum CorridorSurfaceBoundaryType
  InsideBoundary = 0
  OutsideBoundary = &H1
End Enum


Autodesk::Civil::Roadway::DatabaseServices::CurbReturnJoiningType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::CurbReturnJoiningType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::CurbReturnJoiningType Enumeration
Collapse All

Specifies the method that is used to define the curb return profile.

C#
public enum CurbReturnJoiningType {
  JoiningTangent = AeccVAlignCurbReturnRule::kJoiningTangent,
  ExtendingEdge = AeccVAlignCurbReturnRule::kExtendingEdge
}
Visual Basic
Public Enum CurbReturnJoiningType
  JoiningTangent = AeccVAlignCurbReturnRule::kJoiningTangent
  ExtendingEdge = AeccVAlignCurbReturnRule::kExtendingEdge
End Enum


Autodesk::Civil::Roadway::DatabaseServices::IntersectionCorridorType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::IntersectionCorridorType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::IntersectionCorridorType Enumeration
Collapse All

Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options is selected, the primary road crown is maintained through the intersection. All Crowns Maintained: When this options is selected, the crowns of both roads included in the intersection are maintained through the intersection.

C#
public enum IntersectionCorridorType {
  PrimaryRoadCrownMaintained = AeccIntersection::kHoldPriorityRoadCrossSlope,
  AllCrownsMaintained = AeccIntersection::kHoldProfilesOfAllCenterlines
}
Visual Basic
Public Enum IntersectionCorridorType
  PrimaryRoadCrownMaintained = AeccIntersection::kHoldPriorityRoadCrossSlope
  AllCrownsMaintained = AeccIntersection::kHoldProfilesOfAllCenterlines
End Enum


Autodesk::Civil::Roadway::DatabaseServices::MaterialConditionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::MaterialConditionType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::MaterialConditionType Enumeration
Collapse All

An enumeration that specifies the material condition type.

C#
public enum MaterialConditionType {
  Above = AeccDbQuantityTakeoffCriteriaData::kAbove,
  Below = AeccDbQuantityTakeoffCriteriaData::kBelow,
  Base = AeccDbQuantityTakeoffCriteriaData::kBase,
  Compare = AeccDbQuantityTakeoffCriteriaData::kCompare,
  Include = AeccDbQuantityTakeoffCriteriaData::kInclude,
  Exclude = AeccDbQuantityTakeoffCriteriaData::kExclude
}
Visual Basic
Public Enum MaterialConditionType
  Above = AeccDbQuantityTakeoffCriteriaData::kAbove
  Below = AeccDbQuantityTakeoffCriteriaData::kBelow
  Base = AeccDbQuantityTakeoffCriteriaData::kBase
  Compare = AeccDbQuantityTakeoffCriteriaData::kCompare
  Include = AeccDbQuantityTakeoffCriteriaData::kInclude
  Exclude = AeccDbQuantityTakeoffCriteriaData::kExclude
End Enum


Autodesk::Civil::Roadway::DatabaseServices::MaterialItemType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::MaterialItemType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::MaterialItemType Enumeration
Collapse All

An enumeration that specifies the material item type.

C#
public enum MaterialItemType {
  Surface = AeccDbQuantityTakeoffCriteriaData::kSurface,
  CorridorShape = AeccDbQuantityTakeoffCriteriaData::kShape
}
Visual Basic
Public Enum MaterialItemType
  Surface = AeccDbQuantityTakeoffCriteriaData::kSurface
  CorridorShape = AeccDbQuantityTakeoffCriteriaData::kShape
End Enum


Autodesk::Civil::Roadway::DatabaseServices::MaterialQuantityType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::MaterialQuantityType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::MaterialQuantityType Enumeration
Collapse All

An enumeration that specifies the material quantity type.

C#
public enum MaterialQuantityType {
  Cut = AeccDbQuantityTakeoffCriteriaData::kCut,
  Fill = AeccDbQuantityTakeoffCriteriaData::kFill,
  CutFill = AeccDbQuantityTakeoffCriteriaData::kCutFill,
  Earthwork = AeccDbQuantityTakeoffCriteriaData::kEarthwork,
  Structure = AeccDbQuantityTakeoffCriteriaData::kStructure
}
Visual Basic
Public Enum MaterialQuantityType
  Cut = AeccDbQuantityTakeoffCriteriaData::kCut
  Fill = AeccDbQuantityTakeoffCriteriaData::kFill
  CutFill = AeccDbQuantityTakeoffCriteriaData::kCutFill
  Earthwork = AeccDbQuantityTakeoffCriteriaData::kEarthwork
  Structure = AeccDbQuantityTakeoffCriteriaData::kStructure
End Enum


Autodesk::Civil::Roadway::DatabaseServices::OffsetLengthOption Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::OffsetLengthOption Enumeration
Autodesk::Civil::Roadway::DatabaseServices::OffsetLengthOption Enumeration
Collapse All

Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are extended to the length of the extent of the intersection object. When Alignment Start To End is selected, offset alignments are created the length of the parent alignment.

C#
public enum OffsetLengthOption {
  IntersectionExtents = AeccIntersection::kIntersectionExtents,
  AlignmentStartToEnd = AeccIntersection::kAlignmentStartToEnd
}
Visual Basic
Public Enum OffsetLengthOption
  IntersectionExtents = AeccIntersection::kIntersectionExtents
  AlignmentStartToEnd = AeccIntersection::kAlignmentStartToEnd
End Enum


Autodesk::Civil::Roadway::DatabaseServices::SideRoadProfileDistanceRuleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::SideRoadProfileDistanceRuleType Enumeration
Autodesk::Civil::Roadway::DatabaseServices::SideRoadProfileDistanceRuleType Enumeration
Collapse All

Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is selected, the grade of the secondary road profile is adjusted to meet the extents of the intersection object. When Specify Distance is used, the grade of the secondary road profile is adjusted by the value that is entered in the Distance Value.

C#
public enum SideRoadProfileDistanceRuleType {
  ToIntersectionExtents = AeccIntersection::kToIntersectionExtents,
  SpecifyDistance = AeccIntersection::kSpecifyDistance
}
Visual Basic
Public Enum SideRoadProfileDistanceRuleType
  ToIntersectionExtents = AeccIntersection::kToIntersectionExtents
  SpecifyDistance = AeccIntersection::kSpecifyDistance
End Enum


Autodesk::Civil::Roadway::DatabaseServices::SubassemblyGeometryGenerateMode Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::DatabaseServices::SubassemblyGeometryGenerateMode Enumeration
Autodesk::Civil::Roadway::DatabaseServices::SubassemblyGeometryGenerateMode Enumeration
Collapse All

Enumerates the way subassembly geometry can be generated.

C#
public enum SubassemblyGeometryGenerateMode {
  HardCoded = AeccDbSubassembly::kHardCoded,
  UseVBA = AeccDbSubassembly::kUseVBA,
  UseCOM = AeccDbSubassembly::kUseCOM,
  UseDotNet = AeccDbSubassembly::kUseDotNet
}
Visual Basic
Public Enum SubassemblyGeometryGenerateMode
  HardCoded = AeccDbSubassembly::kHardCoded
  UseVBA = AeccDbSubassembly::kUseVBA
  UseCOM = AeccDbSubassembly::kUseCOM
  UseDotNet = AeccDbSubassembly::kUseDotNet
End Enum


Autodesk::Civil::Roadway::Settings Namespace

The Autodesk::Civil::Roadway::Settings namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Classes
Class | Description
SettingsAssembly | Settings for Assembly.
SettingsAssembly::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsAssembly::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsCmdAddIntersectionLabel | Settings for AddIntersectionLabel command.
SettingsCmdAddMaterialVolumeTable | Settings for AddMaterialVolumeTable command.
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation | Settings of table creation for command AddMaterialVolumeTable.
SettingsCmdAddTotalVolumeTable | Settings for AddTotalVolumeTable command.
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation | Settings of table creation for command AddTotalVolumeTable.
SettingsCmdAssignPayItemToArea | Settings for AssignPayItemToArea command.
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions | Settings of pay item assignment for command AssignPayItemToArea.
SettingsCmdComputeMaterials | Settings for ComputeMaterials command.
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial | Settings of material definition for command ComputeMaterials.
SettingsCmdCorridorExtractSurfaces | Settings for CorridorExtractSurfaces command.
SettingsCmdCreateAlignFromCorridor | Settings for CreateAlignFromCorridor command.
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption | Settings for alignment type option.
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions | Settings for criteria based design options.
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption | Settings for profile creation option.
SettingsCmdCreateAssembly | Settings for CreateAssembly command.
SettingsCmdCreateAssemblyTool | Settings for CreateAssemblyTool command.
SettingsCmdCreateCorridor | Settings for CreateCorridor command.
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion | Settings for alignment type option.
SettingsCmdCreateIntersection | Settings for CreateIntersection command.
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion | Settings for the default assembly insertion of new intersection
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes | Settings for the default cross slopes of new intersection
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters | Settings for the default curb return parameters of new intersection
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules | Settings for the default curb return profile rules of new intersection
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions | Settings for the default intersection options of new intersection
SettingsCmdCreateIntersection::SettingsCmdOffsets | Settings for the default offsets of new intersection
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules | Settings for the default secondary road profile rules of new intersection
SettingsCmdCreateIntersection::SettingsCmdWideningParameters | Settings for the default widening parameters of new intersection
SettingsCmdCreatePointsFromCorridor | Settings for CreatePointsFromCorridor command.
SettingsCmdCreatePolylineFromCorridor | Settings for CreatePolylineFromCorridor command.
SettingsCmdCreateProfileFromCorridor | Settings for CreateProfileFromCorridor command.
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions | Settings that specify the defaults used when creating a profile using design criteria.
SettingsCmdCreateSimpleCorridor | Settings for CreateSimpleCorridor command.
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion | Settings that establish the defaults assigned to corridor creation.
SettingsCmdCreateSubassemblyTool | Settings for CreateSubassemblyTool command.
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions | Settings
SettingsCmdCreateSubFromPline | Settings for CreateSubFromPline command.
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities | Settings that specifies the default behavior for creating subassemblies from polylines.
SettingsCmdFeatureLinesFromCorridor | Settings for FeatureLinesFromCorridor command.
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation | Default settings for the Feature Line Creation command.
SettingsCmdGenerateQuantitiesReport | Settings for GenerateQuantitiesReport command.
SettingsCmdTakeOff | Settings for TakeOff command.
SettingsCmdTakeOff::SettingsCmdComputeTakeOff | Settings of take off computation for command TakeOff.
SettingsCmdViewEditCorridorSection | Settings for ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings | Settings for the Grid Settings section of the ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings | Settings for the Grid Text Settings section of the ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions | Settings for the View/Edit Options section of the ViewEditCorridorSection command.
SettingsCorridor | Controls ambient settings for corridors.
SettingsCorridor::SettingsNameFormat | Settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
SettingsCorridor::SettingsRegionHighlightGraphics | Settings for Corridor styles.
SettingsCorridor::SettingsStyles | Settings to establish the default styles assigned to corridor components.
SettingsIntersection | Settings for Intersection.
SettingsIntersection::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsIntersection::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsQuantityTakeoff | Settings for QuantityTakeoff.
SettingsQuantityTakeoff::SettingsNameFormat | Settings to establish the default name format to quantity takeoff.
SettingsQuantityTakeoff::SettingsStyles | Settings to establish the default styles assigned to quantity takeoff.
SettingsSubassembly | Contains settings that apply to the assembly feature, as specified in the Edit Feature Settings dialog box.
SettingsSubassembly::SettingsDefaultStyles | Settings for subassembly default styles.
SettingsSubassembly::SettingsNameFormat | Settings for Corridor styles.
Links
Topics, Classes


Classes

The following table lists classes in this documentation.

Classes
Class | Description
SettingsAssembly | Settings for Assembly.
SettingsAssembly::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsAssembly::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsCmdAddIntersectionLabel | Settings for AddIntersectionLabel command.
SettingsCmdAddMaterialVolumeTable | Settings for AddMaterialVolumeTable command.
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation | Settings of table creation for command AddMaterialVolumeTable.
SettingsCmdAddTotalVolumeTable | Settings for AddTotalVolumeTable command.
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation | Settings of table creation for command AddTotalVolumeTable.
SettingsCmdAssignPayItemToArea | Settings for AssignPayItemToArea command.
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions | Settings of pay item assignment for command AssignPayItemToArea.
SettingsCmdComputeMaterials | Settings for ComputeMaterials command.
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial | Settings of material definition for command ComputeMaterials.
SettingsCmdCorridorExtractSurfaces | Settings for CorridorExtractSurfaces command.
SettingsCmdCreateAlignFromCorridor | Settings for CreateAlignFromCorridor command.
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption | Settings for alignment type option.
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions | Settings for criteria based design options.
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption | Settings for profile creation option.
SettingsCmdCreateAssembly | Settings for CreateAssembly command.
SettingsCmdCreateAssemblyTool | Settings for CreateAssemblyTool command.
SettingsCmdCreateCorridor | Settings for CreateCorridor command.
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion | Settings for alignment type option.
SettingsCmdCreateIntersection | Settings for CreateIntersection command.
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion | Settings for the default assembly insertion of new intersection
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes | Settings for the default cross slopes of new intersection
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters | Settings for the default curb return parameters of new intersection
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules | Settings for the default curb return profile rules of new intersection
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions | Settings for the default intersection options of new intersection
SettingsCmdCreateIntersection::SettingsCmdOffsets | Settings for the default offsets of new intersection
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules | Settings for the default secondary road profile rules of new intersection
SettingsCmdCreateIntersection::SettingsCmdWideningParameters | Settings for the default widening parameters of new intersection
SettingsCmdCreatePointsFromCorridor | Settings for CreatePointsFromCorridor command.
SettingsCmdCreatePolylineFromCorridor | Settings for CreatePolylineFromCorridor command.
SettingsCmdCreateProfileFromCorridor | Settings for CreateProfileFromCorridor command.
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions | Settings that specify the defaults used when creating a profile using design criteria.
SettingsCmdCreateSimpleCorridor | Settings for CreateSimpleCorridor command.
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion | Settings that establish the defaults assigned to corridor creation.
SettingsCmdCreateSubassemblyTool | Settings for CreateSubassemblyTool command.
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions | Settings
SettingsCmdCreateSubFromPline | Settings for CreateSubFromPline command.
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities | Settings that specifies the default behavior for creating subassemblies from polylines.
SettingsCmdFeatureLinesFromCorridor | Settings for FeatureLinesFromCorridor command.
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation | Default settings for the Feature Line Creation command.
SettingsCmdGenerateQuantitiesReport | Settings for GenerateQuantitiesReport command.
SettingsCmdTakeOff | Settings for TakeOff command.
SettingsCmdTakeOff::SettingsCmdComputeTakeOff | Settings of take off computation for command TakeOff.
SettingsCmdViewEditCorridorSection | Settings for ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings | Settings for the Grid Settings section of the ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings | Settings for the Grid Text Settings section of the ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions | Settings for the View/Edit Options section of the ViewEditCorridorSection command.
SettingsCorridor | Controls ambient settings for corridors.
SettingsCorridor::SettingsNameFormat | Settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
SettingsCorridor::SettingsRegionHighlightGraphics | Settings for Corridor styles.
SettingsCorridor::SettingsStyles | Settings to establish the default styles assigned to corridor components.
SettingsIntersection | Settings for Intersection.
SettingsIntersection::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsIntersection::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsQuantityTakeoff | Settings for QuantityTakeoff.
SettingsQuantityTakeoff::SettingsNameFormat | Settings to establish the default name format to quantity takeoff.
SettingsQuantityTakeoff::SettingsStyles | Settings to establish the default styles assigned to quantity takeoff.
SettingsSubassembly | Contains settings that apply to the assembly feature, as specified in the Edit Feature Settings dialog box.
SettingsSubassembly::SettingsDefaultStyles | Settings for subassembly default styles.
SettingsSubassembly::SettingsNameFormat | Settings for Corridor styles.
Links
Classes


SettingsAssembly Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class
SettingsAssembly Class
Collapse All

Settings for Assembly.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsAssembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAssembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAssemblyTool
C#
public class SettingsAssembly : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsAssembly
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsAssembly Properties, SettingsAssembly Members, Class Hierarchy


SettingsAssembly Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Members
SettingsAssembly Members
Collapse All

The following tables list the members exposed by SettingsAssembly.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsAssembly Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Properties
SettingsAssembly Properties
Collapse All

The properties of SettingsAssembly are listed here.

Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Styles | Settings to establish the default styles assigned to corridor components.
Links
Public Properties


SettingsAssembly::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Properties > SettingsAssembly::NameFormat Property
SettingsAssembly::NameFormat Property
Collapse All

settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from feature lines.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsAssembly Class, SettingsAssembly Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsAssembly::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Properties > SettingsAssembly::Styles Property
SettingsAssembly::Styles Property
Collapse All

Settings to establish the default styles assigned to corridor components.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsAssembly Class, SettingsAssembly Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsAssembly::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class
SettingsAssembly::SettingsNameFormat Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsAssembly::SettingsNameFormat
C#
public class SettingsAssembly::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsAssembly::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsAssembly::SettingsNameFormat Properties, SettingsAssembly::SettingsNameFormat Members, Class Hierarchy


SettingsAssembly::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class > SettingsAssembly::SettingsNameFormat Members
SettingsAssembly::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsAssembly::SettingsNameFormat.

Public Properties
Public Property | Description
Assembly | Settings Assembly default name format.
Group | Settings Group default name format.
Offset | Settings Offset default name format.
Links
Public Properties


SettingsAssembly::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class > SettingsAssembly::SettingsNameFormat Properties
SettingsAssembly::SettingsNameFormat Properties
Collapse All

The properties of SettingsAssembly::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
Assembly | Settings Assembly default name format.
Group | Settings Group default name format.
Offset | Settings Offset default name format.
Links
Public Properties


SettingsAssembly::SettingsNameFormat::Assembly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class > SettingsAssembly::SettingsNameFormat Properties > SettingsAssembly::SettingsNameFormat::Assembly Property
SettingsAssembly::SettingsNameFormat::Assembly Property
Collapse All

Settings Assembly default name format.

C#
public PropertyString Assembly;
Visual Basic
Public Property Assembly() As PropertyString
Links
SettingsAssembly::SettingsNameFormat Class, SettingsAssembly::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsAssembly::SettingsNameFormat::Group Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class > SettingsAssembly::SettingsNameFormat Properties > SettingsAssembly::SettingsNameFormat::Group Property
SettingsAssembly::SettingsNameFormat::Group Property
Collapse All

Settings Group default name format.

C#
public PropertyString Group;
Visual Basic
Public Property Group() As PropertyString
Links
SettingsAssembly::SettingsNameFormat Class, SettingsAssembly::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsAssembly::SettingsNameFormat::Offset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class > SettingsAssembly::SettingsNameFormat Properties > SettingsAssembly::SettingsNameFormat::Offset Property
SettingsAssembly::SettingsNameFormat::Offset Property
Collapse All

Settings Offset default name format.

C#
public PropertyString Offset;
Visual Basic
Public Property Offset() As PropertyString
Links
SettingsAssembly::SettingsNameFormat Class, SettingsAssembly::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsAssembly::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class
SettingsAssembly::SettingsStyles Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsAssembly::SettingsStyles
C#
public class SettingsAssembly::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsAssembly::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsAssembly::SettingsStyles Properties, SettingsAssembly::SettingsStyles Members, Class Hierarchy


SettingsAssembly::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class > SettingsAssembly::SettingsStyles Members
SettingsAssembly::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsAssembly::SettingsStyles.

Public Properties
Public Property | Description
Assembly | Settings of Assembly style.
CodeSet | Settings of code set style.
Links
Public Properties


SettingsAssembly::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class > SettingsAssembly::SettingsStyles Properties
SettingsAssembly::SettingsStyles Properties
Collapse All

The properties of SettingsAssembly::SettingsStyles are listed here.

Public Properties
Public Property | Description
Assembly | Settings of Assembly style.
CodeSet | Settings of code set style.
Links
Public Properties


SettingsAssembly::SettingsStyles::Assembly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class > SettingsAssembly::SettingsStyles Properties > SettingsAssembly::SettingsStyles::Assembly Property
SettingsAssembly::SettingsStyles::Assembly Property
Collapse All

Settings of Assembly style.

C#
public PropertyString Assembly;
Visual Basic
Public Property Assembly() As PropertyString
Links
SettingsAssembly::SettingsStyles Class, SettingsAssembly::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsAssembly::SettingsStyles::CodeSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class > SettingsAssembly::SettingsStyles Properties > SettingsAssembly::SettingsStyles::CodeSet Property
SettingsAssembly::SettingsStyles::CodeSet Property
Collapse All

Settings of code set style.

C#
public PropertyString CodeSet;
Visual Basic
Public Property CodeSet() As PropertyString
Links
SettingsAssembly::SettingsStyles Class, SettingsAssembly::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddIntersectionLabel Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddIntersectionLabel Class
SettingsCmdAddIntersectionLabel Class
Collapse All

Settings for AddIntersectionLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsIntersection
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddIntersectionLabel
C#
public class SettingsCmdAddIntersectionLabel : SettingsIntersection;
Visual Basic
Public Class SettingsCmdAddIntersectionLabel
Inherits SettingsIntersection
Links
Class Hierarchy


SettingsCmdAddMaterialVolumeTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class
SettingsCmdAddMaterialVolumeTable Class
Collapse All

Settings for AddMaterialVolumeTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddMaterialVolumeTable
C#
public class SettingsCmdAddMaterialVolumeTable : SettingsQuantityTakeoff;
Visual Basic
Public Class SettingsCmdAddMaterialVolumeTable
Inherits SettingsQuantityTakeoff
Links
SettingsCmdAddMaterialVolumeTable Properties, SettingsCmdAddMaterialVolumeTable Members, Class Hierarchy


SettingsCmdAddMaterialVolumeTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Members
SettingsCmdAddMaterialVolumeTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddMaterialVolumeTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TableCreation | Gets the default setting of table creation for the command AddMaterialVolumeTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddMaterialVolumeTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Properties
SettingsCmdAddMaterialVolumeTable Properties
Collapse All

The properties of SettingsCmdAddMaterialVolumeTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddMaterialVolumeTable.
Links
Public Properties


SettingsCmdAddMaterialVolumeTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Properties > SettingsCmdAddMaterialVolumeTable::TableCreation Property
SettingsCmdAddMaterialVolumeTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddMaterialVolumeTable.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdAddMaterialVolumeTable Class, SettingsCmdAddMaterialVolumeTable Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class
Collapse All

Settings of table creation for command AddMaterialVolumeTable.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation
C#
public class SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties, SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::SplitTable Property
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TableStyle Property
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TileDirection Property
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddTotalVolumeTable Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class
SettingsCmdAddTotalVolumeTable Class
Collapse All

Settings for AddTotalVolumeTable command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddTotalVolumeTable
C#
public class SettingsCmdAddTotalVolumeTable : SettingsQuantityTakeoff;
Visual Basic
Public Class SettingsCmdAddTotalVolumeTable
Inherits SettingsQuantityTakeoff
Links
SettingsCmdAddTotalVolumeTable Properties, SettingsCmdAddTotalVolumeTable Members, Class Hierarchy


SettingsCmdAddTotalVolumeTable Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Members
SettingsCmdAddTotalVolumeTable Members
Collapse All

The following tables list the members exposed by SettingsCmdAddTotalVolumeTable.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TableCreation | Gets the default setting of table creation for the command AddTotalVolumeTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAddTotalVolumeTable Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Properties
SettingsCmdAddTotalVolumeTable Properties
Collapse All

The properties of SettingsCmdAddTotalVolumeTable are listed here.

Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddTotalVolumeTable.
Links
Public Properties


SettingsCmdAddTotalVolumeTable::TableCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Properties > SettingsCmdAddTotalVolumeTable::TableCreation Property
SettingsCmdAddTotalVolumeTable::TableCreation Property
Collapse All

Gets the default setting of table creation for the command AddTotalVolumeTable.

C#
public SettingsCmdTableCreation TableCreation;
Visual Basic
Public Property TableCreation() As SettingsCmdTableCreation
Links
SettingsCmdAddTotalVolumeTable Class, SettingsCmdAddTotalVolumeTable Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class
Collapse All

Settings of table creation for command AddTotalVolumeTable.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation
C#
public class SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation
Inherits TreeOidWrapper
Links
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties, SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members, Class Hierarchy


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties
Collapse All

The properties of SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation are listed here.

Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).
Links
Public Properties


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::MaximumNumberOfRows Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::MaximumNumberOfRows Property
Collapse All

Specifies the maximum number of rows to include per section.

C#
public PropertyInt MaximumNumberOfRows;
Visual Basic
Public Property MaximumNumberOfRows() As PropertyInt
Remarks

If the number of data rows exceeds the specified maximum, the table is split into sections, and they are displayed either side by side (left to right), or stacked vertically.

Links
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::MaximumTablesPerStack Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::MaximumTablesPerStack Property
Collapse All

Specifies the maximum number of tables to include in each stack.

C#
public PropertyInt MaximumTablesPerStack;
Visual Basic
Public Property MaximumTablesPerStack() As PropertyInt
Links
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::SplitTable Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::SplitTable Property
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::SplitTable Property
Collapse All

Specifies whether a table is split into two or more sections after a specified maximum number of rows has been met.

C#
public PropertyBoolean SplitTable;
Visual Basic
Public Property SplitTable() As PropertyBoolean
Links
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TableSpacing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TableSpacing Property
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TableSpacing Property
Collapse All

Specifies the spacing between tables.

C#
public PropertyDouble TableSpacing;
Visual Basic
Public Property TableSpacing() As PropertyDouble
Links
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TableStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TableStyle Property
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TableStyle Property
Collapse All

Specifies the style for a table.

C#
public PropertyString TableStyle;
Visual Basic
Public Property TableStyle() As PropertyString
Links
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TileDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TileDirection Property
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TileDirection Property
Collapse All

Specifies the direction in which the table tiles (Across or Down).

C#
public PropertyEnum<Autodesk::Civil::TableTitleDirectionType> TileDirection;
Visual Basic
Public Property TileDirection() As PropertyEnum<Autodesk::Civil::TableTitleDirectionType>
Links
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class, SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAssignPayItemToArea Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class
SettingsCmdAssignPayItemToArea Class
Collapse All

Settings for AssignPayItemToArea command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdAssignPayItemToArea
C#
public class SettingsCmdAssignPayItemToArea : SettingsQuantityTakeoff;
Visual Basic
Public Class SettingsCmdAssignPayItemToArea
Inherits SettingsQuantityTakeoff
Links
SettingsCmdAssignPayItemToArea Properties, SettingsCmdAssignPayItemToArea Members, Class Hierarchy


SettingsCmdAssignPayItemToArea Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Members
SettingsCmdAssignPayItemToArea Members
Collapse All

The following tables list the members exposed by SettingsCmdAssignPayItemToArea.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AssignPayItemToAreaOption | Gets the default setting for the command AssignPayItemToArea.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdAssignPayItemToArea Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Properties
SettingsCmdAssignPayItemToArea Properties
Collapse All

The properties of SettingsCmdAssignPayItemToArea are listed here.

Public Properties
Public Property | Description
AssignPayItemToAreaOption | Gets the default setting for the command AssignPayItemToArea.
Links
Public Properties


SettingsCmdAssignPayItemToArea::AssignPayItemToAreaOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Properties > SettingsCmdAssignPayItemToArea::AssignPayItemToAreaOption Property
SettingsCmdAssignPayItemToArea::AssignPayItemToAreaOption Property
Collapse All

Gets the default setting for the command AssignPayItemToArea.

C#
public SettingsCmdAssignPayItemToAreaOptions AssignPayItemToAreaOption;
Visual Basic
Public Property AssignPayItemToAreaOption() As SettingsCmdAssignPayItemToAreaOptions
Links
SettingsCmdAssignPayItemToArea Class, SettingsCmdAssignPayItemToArea Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class
Collapse All

Settings of pay item assignment for command AssignPayItemToArea.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions
C#
public class SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions
Inherits TreeOidWrapper
Links
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties, SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members, Class Hierarchy


SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions.

Public Properties
Public Property | Description
ColorForHatch | Specifies the color for hatch.
LayerForHatch | Specifies the layer for hatch.
UseAcadLayerAndColor | Specifies whether to use AutoCAD current layer and color.
Links
Public Properties


SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties
Collapse All

The properties of SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions are listed here.

Public Properties
Public Property | Description
ColorForHatch | Specifies the color for hatch.
LayerForHatch | Specifies the layer for hatch.
UseAcadLayerAndColor | Specifies whether to use AutoCAD current layer and color.
Links
Public Properties


SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::ColorForHatch Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::ColorForHatch Property
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::ColorForHatch Property
Collapse All

Specifies the color for hatch.

C#
public PropertyColor ColorForHatch;
Visual Basic
Public Property ColorForHatch() As PropertyColor
Links
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class, SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::LayerForHatch Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::LayerForHatch Property
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::LayerForHatch Property
Collapse All

Specifies the layer for hatch.

C#
public PropertyLayer LayerForHatch;
Visual Basic
Public Property LayerForHatch() As PropertyLayer
Links
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class, SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::UseAcadLayerAndColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::UseAcadLayerAndColor Property
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::UseAcadLayerAndColor Property
Collapse All

Specifies whether to use AutoCAD current layer and color.

C#
public PropertyBoolean UseAcadLayerAndColor;
Visual Basic
Public Property UseAcadLayerAndColor() As PropertyBoolean
Links
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class, SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdComputeMaterials Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class
SettingsCmdComputeMaterials Class
Collapse All

Settings for ComputeMaterials command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdComputeMaterials
C#
public class SettingsCmdComputeMaterials : SettingsQuantityTakeoff;
Visual Basic
Public Class SettingsCmdComputeMaterials
Inherits SettingsQuantityTakeoff
Links
SettingsCmdComputeMaterials Properties, SettingsCmdComputeMaterials Members, Class Hierarchy


SettingsCmdComputeMaterials Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Members
SettingsCmdComputeMaterials Members
Collapse All

The following tables list the members exposed by SettingsCmdComputeMaterials.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
DefineMaterialOption | Gets the default setting of define material for the command ComputeMaterials.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdComputeMaterials Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Properties
SettingsCmdComputeMaterials Properties
Collapse All

The properties of SettingsCmdComputeMaterials are listed here.

Public Properties
Public Property | Description
DefineMaterialOption | Gets the default setting of define material for the command ComputeMaterials.
Links
Public Properties


SettingsCmdComputeMaterials::DefineMaterialOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Properties > SettingsCmdComputeMaterials::DefineMaterialOption Property
SettingsCmdComputeMaterials::DefineMaterialOption Property
Collapse All

Gets the default setting of define material for the command ComputeMaterials.

C#
public SettingsCmdDefineMaterial DefineMaterialOption;
Visual Basic
Public Property DefineMaterialOption() As SettingsCmdDefineMaterial
Links
SettingsCmdComputeMaterials Class, SettingsCmdComputeMaterials Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class
Collapse All

Settings of material definition for command ComputeMaterials.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdComputeMaterials::SettingsCmdDefineMaterial
C#
public class SettingsCmdComputeMaterials::SettingsCmdDefineMaterial : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdComputeMaterials::SettingsCmdDefineMaterial
Inherits TreeOidWrapper
Links
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties, SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members, Class Hierarchy


SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members
Collapse All

The following tables list the members exposed by SettingsCmdComputeMaterials::SettingsCmdDefineMaterial.

Public Properties
Public Property | Description
ApplyCurveCorrection | Specifies whether to apply curve correction.
CurveCorrectionTolerance | Specifies the curve correction tolerance.
Links
Public Properties


SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties
Collapse All

The properties of SettingsCmdComputeMaterials::SettingsCmdDefineMaterial are listed here.

Public Properties
Public Property | Description
ApplyCurveCorrection | Specifies whether to apply curve correction.
CurveCorrectionTolerance | Specifies the curve correction tolerance.
Links
Public Properties


SettingsCmdComputeMaterials::SettingsCmdDefineMaterial::ApplyCurveCorrection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial::ApplyCurveCorrection Property
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial::ApplyCurveCorrection Property
Collapse All

Specifies whether to apply curve correction.

C#
public PropertyBoolean ApplyCurveCorrection;
Visual Basic
Public Property ApplyCurveCorrection() As PropertyBoolean
Links
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class, SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdComputeMaterials::SettingsCmdDefineMaterial::CurveCorrectionTolerance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial::CurveCorrectionTolerance Property
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial::CurveCorrectionTolerance Property
Collapse All

Specifies the curve correction tolerance.

C#
public PropertyDouble CurveCorrectionTolerance;
Visual Basic
Public Property CurveCorrectionTolerance() As PropertyDouble
Links
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class, SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCorridorExtractSurfaces Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCorridorExtractSurfaces Class
SettingsCmdCorridorExtractSurfaces Class
Collapse All

Settings for CorridorExtractSurfaces command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCorridorExtractSurfaces
C#
public class SettingsCmdCorridorExtractSurfaces : SettingsCorridor;
Visual Basic
Public Class SettingsCmdCorridorExtractSurfaces
Inherits SettingsCorridor
Links
Class Hierarchy


SettingsCmdCreateAlignFromCorridor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class
SettingsCmdCreateAlignFromCorridor Class
Collapse All

Settings for CreateAlignFromCorridor command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor
C#
public class SettingsCmdCreateAlignFromCorridor : SettingsCorridor;
Visual Basic
Public Class SettingsCmdCreateAlignFromCorridor
Inherits SettingsCorridor
Links
SettingsCmdCreateAlignFromCorridor Properties, SettingsCmdCreateAlignFromCorridor Members, Class Hierarchy


SettingsCmdCreateAlignFromCorridor Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Members
SettingsCmdCreateAlignFromCorridor Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignFromCorridor.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the alignment type options.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the criteria based design options.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
ProfileCreationOption | Gets the profile creation options.
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateAlignFromCorridor Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Properties
SettingsCmdCreateAlignFromCorridor Properties
Collapse All

The properties of SettingsCmdCreateAlignFromCorridor are listed here.

Public Properties
Public Property | Description
AlignmentTypeOption | Gets the alignment type options.
CriteriaBasedDesignOptions | Gets the criteria based design options.
ProfileCreationOption | Gets the profile creation options.
Links
Public Properties


SettingsCmdCreateAlignFromCorridor::AlignmentTypeOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Properties > SettingsCmdCreateAlignFromCorridor::AlignmentTypeOption Property
SettingsCmdCreateAlignFromCorridor::AlignmentTypeOption Property
Collapse All

Gets the alignment type options.

C#
public SettingsCmdAlignmentTypeOption AlignmentTypeOption;
Visual Basic
Public Property AlignmentTypeOption() As SettingsCmdAlignmentTypeOption
Links
SettingsCmdCreateAlignFromCorridor Class, SettingsCmdCreateAlignFromCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::CriteriaBasedDesignOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Properties > SettingsCmdCreateAlignFromCorridor::CriteriaBasedDesignOptions Property
SettingsCmdCreateAlignFromCorridor::CriteriaBasedDesignOptions Property
Collapse All

Gets the criteria based design options.

C#
public SettingsCmdCriteriaBasedDesignOptions CriteriaBasedDesignOptions;
Visual Basic
Public Property CriteriaBasedDesignOptions() As SettingsCmdCriteriaBasedDesignOptions
Links
SettingsCmdCreateAlignFromCorridor Class, SettingsCmdCreateAlignFromCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::ProfileCreationOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Properties > SettingsCmdCreateAlignFromCorridor::ProfileCreationOption Property
SettingsCmdCreateAlignFromCorridor::ProfileCreationOption Property
Collapse All

Gets the profile creation options.

C#
public SettingsCmdProfileCreationOption ProfileCreationOption;
Visual Basic
Public Property ProfileCreationOption() As SettingsCmdProfileCreationOption
Links
SettingsCmdCreateAlignFromCorridor Class, SettingsCmdCreateAlignFromCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class
Collapse All

Settings for alignment type option.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption
C#
public class SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties, SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members, Class Hierarchy


SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption.

Public Properties
Public Property | Description
AlignmentType | Specifies the alignment type.
Links
Public Properties


SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties
Collapse All

The properties of SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption are listed here.

Public Properties
Public Property | Description
AlignmentType | Specifies the alignment type.
Links
Public Properties


SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption::AlignmentType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption::AlignmentType Property
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption::AlignmentType Property
Collapse All

Specifies the alignment type.

C#
public PropertyEnum<Autodesk::Civil::Land::DatabaseServices::AlignmentType> AlignmentType;
Visual Basic
Public Property AlignmentType() As PropertyEnum<Autodesk::Civil::Land::DatabaseServices::AlignmentType>
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class, SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class
Collapse All

Settings for criteria based design options.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions
C#
public class SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions
Inherits TreeOidWrapper
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties, SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Class Hierarchy


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions.

Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
DesignSpeed | Gets the default design speed.
DesignSpeedLookupMethod | Gets the default design speed lookup method.
RadiusLookupMethod | Gets the default radius lookup method.
UseCriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
UseDesignChecksOption | Gets whether to associate a design check set with the alignment.
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the alignment.
Links
Public Properties


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
Collapse All

The properties of SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions are listed here.

Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
DesignSpeed | Gets the default design speed.
DesignSpeedLookupMethod | Gets the default design speed lookup method.
RadiusLookupMethod | Gets the default radius lookup method.
UseCriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
UseDesignChecksOption | Gets whether to associate a design check set with the alignment.
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the alignment.
Links
Public Properties


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DefaultDesignCheckSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DefaultDesignCheckSet Property
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DefaultDesignCheckSet Property
Collapse All

Gets the default design check set.

C#
public PropertyString DefaultDesignCheckSet;
Visual Basic
Public Property DefaultDesignCheckSet() As PropertyString
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DesignSpeed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DesignSpeed Property
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DesignSpeed Property
Collapse All

Gets the default design speed.

C#
public PropertyDouble DesignSpeed;
Visual Basic
Public Property DesignSpeed() As PropertyDouble
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DesignSpeedLookupMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DesignSpeedLookupMethod Property
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DesignSpeedLookupMethod Property
Collapse All

Gets the default design speed lookup method.

C#
public PropertyEnum<Autodesk::Civil::Land::DesignSpeedLookupMethodType> DesignSpeedLookupMethod;
Visual Basic
Public Property DesignSpeedLookupMethod() As PropertyEnum<Autodesk::Civil::Land::DesignSpeedLookupMethodType>
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::RadiusLookupMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::RadiusLookupMethod Property
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::RadiusLookupMethod Property
Collapse All

Gets the default radius lookup method.

C#
public PropertyEnum<Autodesk::Civil::Land::RadiusLookupMethodType> RadiusLookupMethod;
Visual Basic
Public Property RadiusLookupMethod() As PropertyEnum<Autodesk::Civil::Land::RadiusLookupMethodType>
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseCriteriaBasedDesignOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseCriteriaBasedDesignOption Property
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseCriteriaBasedDesignOption Property
Collapse All

Gets whether alignments use design criteria by default.

C#
public PropertyBoolean UseCriteriaBasedDesignOption;
Visual Basic
Public Property UseCriteriaBasedDesignOption() As PropertyBoolean
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignChecksOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignChecksOption Property
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignChecksOption Property
Collapse All

Gets whether to associate a design check set with the alignment.

C#
public PropertyBoolean UseDesignChecksOption;
Visual Basic
Public Property UseDesignChecksOption() As PropertyBoolean
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property
Collapse All

Gets whether to associate a design criteria file with the alignment.

C#
public PropertyBoolean UseDesignCriteriaFileOption;
Visual Basic
Public Property UseDesignCriteriaFileOption() As PropertyBoolean
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class
Collapse All

Settings for profile creation option.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption
C#
public class SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties, SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members, Class Hierarchy


SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption.

Public Properties
Public Property | Description
CreateProfileFromCorridor | Gets whether a profile is automatically created when creating an alignment from a corridor feature line.
Links
Public Properties


SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties
Collapse All

The properties of SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption are listed here.

Public Properties
Public Property | Description
CreateProfileFromCorridor | Gets whether a profile is automatically created when creating an alignment from a corridor feature line.
Links
Public Properties


SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption::CreateProfileFromCorridor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption::CreateProfileFromCorridor Property
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption::CreateProfileFromCorridor Property
Collapse All

Gets whether a profile is automatically created when creating an alignment from a corridor feature line.

C#
public PropertyBoolean CreateProfileFromCorridor;
Visual Basic
Public Property CreateProfileFromCorridor() As PropertyBoolean
Links
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class, SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateAssembly Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAssembly Class
SettingsCmdCreateAssembly Class
Collapse All

Settings for CreateAssembly command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsAssembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAssembly
C#
public class SettingsCmdCreateAssembly : SettingsAssembly;
Visual Basic
Public Class SettingsCmdCreateAssembly
Inherits SettingsAssembly
Links
Class Hierarchy


SettingsCmdCreateAssemblyTool Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAssemblyTool Class
SettingsCmdCreateAssemblyTool Class
Collapse All

Settings for CreateAssemblyTool command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsAssembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAssemblyTool
C#
public class SettingsCmdCreateAssemblyTool : SettingsAssembly;
Visual Basic
Public Class SettingsCmdCreateAssemblyTool
Inherits SettingsAssembly
Links
Class Hierarchy


SettingsCmdCreateCorridor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class
SettingsCmdCreateCorridor Class
Collapse All

Settings for CreateCorridor command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateCorridor
C#
public class SettingsCmdCreateCorridor : SettingsCorridor;
Visual Basic
Public Class SettingsCmdCreateCorridor
Inherits SettingsCorridor
Links
SettingsCmdCreateCorridor Properties, SettingsCmdCreateCorridor Members, Class Hierarchy


SettingsCmdCreateCorridor Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Members
SettingsCmdCreateCorridor Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateCorridor.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AssemblyInsertion | Gets the default settings of assembly insertion.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateCorridor Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Properties
SettingsCmdCreateCorridor Properties
Collapse All

The properties of SettingsCmdCreateCorridor are listed here.

Public Properties
Public Property | Description
AssemblyInsertion | Gets the default settings of assembly insertion.
Links
Public Properties


SettingsCmdCreateCorridor::AssemblyInsertion Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Properties > SettingsCmdCreateCorridor::AssemblyInsertion Property
SettingsCmdCreateCorridor::AssemblyInsertion Property
Collapse All

Gets the default settings of assembly insertion.

C#
public SettingsCmdAssemblyInsertion AssemblyInsertion;
Visual Basic
Public Property AssemblyInsertion() As SettingsCmdAssemblyInsertion
Links
SettingsCmdCreateCorridor Class, SettingsCmdCreateCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class
Collapse All

Settings for alignment type option.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion
C#
public class SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion
Inherits TreeOidWrapper
Links
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties, SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members, Class Hierarchy


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion.

Public Properties
Public Property | Description
FrequencyAlongCurves | Gets the corridor station placement frequency along the curve portion of an alignment.
FrequencyAlongProfileCurves | Gets the corridor station placement frequency along curve portions of the profile geometry.
FrequencyAlongSpirals | Gets the corridor station placement frequency along the spiral portion of an alignment.
FrequencyAlongTangents | Gets the corridor station placement frequency along the tangent portion of an alignment.
HorizontalGeometryPoints | Gets the corridor station placement frequency along the spiral portion of an alignment.
ProfileGeometryPoints | Gets whether corridor stations are placed at profile geometry points.
ProfileHighLowPoints | Gets whether assemblies are inserted at the high and low points of the profile geometry.
SuperelevationCriticalPoints | Gets whether corridor stations are placed at superelevation critical points.
Links
Public Properties


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties
Collapse All

The properties of SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion are listed here.

Public Properties
Public Property | Description
FrequencyAlongCurves | Gets the corridor station placement frequency along the curve portion of an alignment.
FrequencyAlongProfileCurves | Gets the corridor station placement frequency along curve portions of the profile geometry.
FrequencyAlongSpirals | Gets the corridor station placement frequency along the spiral portion of an alignment.
FrequencyAlongTangents | Gets the corridor station placement frequency along the tangent portion of an alignment.
HorizontalGeometryPoints | Gets the corridor station placement frequency along the spiral portion of an alignment.
ProfileGeometryPoints | Gets whether corridor stations are placed at profile geometry points.
ProfileHighLowPoints | Gets whether assemblies are inserted at the high and low points of the profile geometry.
SuperelevationCriticalPoints | Gets whether corridor stations are placed at superelevation critical points.
Links
Public Properties


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongCurves Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongCurves Property
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongCurves Property
Collapse All

Gets the corridor station placement frequency along the curve portion of an alignment.

C#
public PropertyDouble FrequencyAlongCurves;
Visual Basic
Public Property FrequencyAlongCurves() As PropertyDouble
Links
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves Property
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves Property
Collapse All

Gets the corridor station placement frequency along curve portions of the profile geometry.

C#
public PropertyDouble FrequencyAlongProfileCurves;
Visual Basic
Public Property FrequencyAlongProfileCurves() As PropertyDouble
Links
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals Property
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals Property
Collapse All

Gets the corridor station placement frequency along the spiral portion of an alignment.

C#
public PropertyDouble FrequencyAlongSpirals;
Visual Basic
Public Property FrequencyAlongSpirals() As PropertyDouble
Links
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongTangents Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongTangents Property
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongTangents Property
Collapse All

Gets the corridor station placement frequency along the tangent portion of an alignment.

C#
public PropertyDouble FrequencyAlongTangents;
Visual Basic
Public Property FrequencyAlongTangents() As PropertyDouble
Links
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints Property
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints Property
Collapse All

Gets the corridor station placement frequency along the spiral portion of an alignment.

C#
public PropertyBoolean HorizontalGeometryPoints;
Visual Basic
Public Property HorizontalGeometryPoints() As PropertyBoolean
Links
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::ProfileGeometryPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::ProfileGeometryPoints Property
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::ProfileGeometryPoints Property
Collapse All

Gets whether corridor stations are placed at profile geometry points.

C#
public PropertyBoolean ProfileGeometryPoints;
Visual Basic
Public Property ProfileGeometryPoints() As PropertyBoolean
Links
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::ProfileHighLowPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::ProfileHighLowPoints Property
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::ProfileHighLowPoints Property
Collapse All

Gets whether assemblies are inserted at the high and low points of the profile geometry.

C#
public PropertyBoolean ProfileHighLowPoints;
Visual Basic
Public Property ProfileHighLowPoints() As PropertyBoolean
Links
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints Property
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints Property
Collapse All

Gets whether corridor stations are placed at superelevation critical points.

C#
public PropertyBoolean SuperelevationCriticalPoints;
Visual Basic
Public Property SuperelevationCriticalPoints() As PropertyBoolean
Links
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class
SettingsCmdCreateIntersection Class
Collapse All

Settings for CreateIntersection command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsIntersection
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection
C#
public class SettingsCmdCreateIntersection : SettingsIntersection;
Visual Basic
Public Class SettingsCmdCreateIntersection
Inherits SettingsIntersection
Links
SettingsCmdCreateIntersection Properties, SettingsCmdCreateIntersection Members, Class Hierarchy


SettingsCmdCreateIntersection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Members
SettingsCmdCreateIntersection Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateIntersection.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AssemblyInsertion | Gets the default assembly insertion for new intersection
Coordinate | The Coordinate settings
CrossSlopes | Gets the default cross slopes for new intersection
CurbReturnParameters | Gets the default curb return parameters for new intersection
CurbReturnProfileRules | Gets the default curb return profile rules for new intersection
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
IntersectionOptions | Gets the default intersection options for new intersection
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Offsets | Gets the default offsets for new intersection
SecondaryRoadProfileRules | Gets the default secondary road profile rules for new intersection
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
WideningParameters | Gets the default widening parameters for new intersection
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateIntersection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties
SettingsCmdCreateIntersection Properties
Collapse All

The properties of SettingsCmdCreateIntersection are listed here.

Public Properties
Public Property | Description
AssemblyInsertion | Gets the default assembly insertion for new intersection
CrossSlopes | Gets the default cross slopes for new intersection
CurbReturnParameters | Gets the default curb return parameters for new intersection
CurbReturnProfileRules | Gets the default curb return profile rules for new intersection
IntersectionOptions | Gets the default intersection options for new intersection
Offsets | Gets the default offsets for new intersection
SecondaryRoadProfileRules | Gets the default secondary road profile rules for new intersection
WideningParameters | Gets the default widening parameters for new intersection
Links
Public Properties


SettingsCmdCreateIntersection::AssemblyInsertion Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties > SettingsCmdCreateIntersection::AssemblyInsertion Property
SettingsCmdCreateIntersection::AssemblyInsertion Property
Collapse All

Gets the default assembly insertion for new intersection

C#
public SettingsCmdAssemblyInsertion AssemblyInsertion;
Visual Basic
Public Property AssemblyInsertion() As SettingsCmdAssemblyInsertion
Links
SettingsCmdCreateIntersection Class, SettingsCmdCreateIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::CrossSlopes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties > SettingsCmdCreateIntersection::CrossSlopes Property
SettingsCmdCreateIntersection::CrossSlopes Property
Collapse All

Gets the default cross slopes for new intersection

C#
public SettingsCmdCrossSlopes CrossSlopes;
Visual Basic
Public Property CrossSlopes() As SettingsCmdCrossSlopes
Links
SettingsCmdCreateIntersection Class, SettingsCmdCreateIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::CurbReturnParameters Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties > SettingsCmdCreateIntersection::CurbReturnParameters Property
SettingsCmdCreateIntersection::CurbReturnParameters Property
Collapse All

Gets the default curb return parameters for new intersection

C#
public SettingsCmdCurbReturnParameters CurbReturnParameters;
Visual Basic
Public Property CurbReturnParameters() As SettingsCmdCurbReturnParameters
Links
SettingsCmdCreateIntersection Class, SettingsCmdCreateIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::CurbReturnProfileRules Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties > SettingsCmdCreateIntersection::CurbReturnProfileRules Property
SettingsCmdCreateIntersection::CurbReturnProfileRules Property
Collapse All

Gets the default curb return profile rules for new intersection

C#
public SettingsCmdCurbReturnProfileRules CurbReturnProfileRules;
Visual Basic
Public Property CurbReturnProfileRules() As SettingsCmdCurbReturnProfileRules
Links
SettingsCmdCreateIntersection Class, SettingsCmdCreateIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::IntersectionOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties > SettingsCmdCreateIntersection::IntersectionOptions Property
SettingsCmdCreateIntersection::IntersectionOptions Property
Collapse All

Gets the default intersection options for new intersection

C#
public SettingsCmdIntersectionOptions IntersectionOptions;
Visual Basic
Public Property IntersectionOptions() As SettingsCmdIntersectionOptions
Links
SettingsCmdCreateIntersection Class, SettingsCmdCreateIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::Offsets Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties > SettingsCmdCreateIntersection::Offsets Property
SettingsCmdCreateIntersection::Offsets Property
Collapse All

Gets the default offsets for new intersection

C#
public SettingsCmdOffsets Offsets;
Visual Basic
Public Property Offsets() As SettingsCmdOffsets
Links
SettingsCmdCreateIntersection Class, SettingsCmdCreateIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SecondaryRoadProfileRules Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties > SettingsCmdCreateIntersection::SecondaryRoadProfileRules Property
SettingsCmdCreateIntersection::SecondaryRoadProfileRules Property
Collapse All

Gets the default secondary road profile rules for new intersection

C#
public SettingsCmdSecondaryRoadProfileRules SecondaryRoadProfileRules;
Visual Basic
Public Property SecondaryRoadProfileRules() As SettingsCmdSecondaryRoadProfileRules
Links
SettingsCmdCreateIntersection Class, SettingsCmdCreateIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::WideningParameters Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties > SettingsCmdCreateIntersection::WideningParameters Property
SettingsCmdCreateIntersection::WideningParameters Property
Collapse All

Gets the default widening parameters for new intersection

C#
public SettingsCmdWideningParameters WideningParameters;
Visual Basic
Public Property WideningParameters() As SettingsCmdWideningParameters
Links
SettingsCmdCreateIntersection Class, SettingsCmdCreateIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class
Collapse All

Settings for the default assembly insertion of new intersection

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion
C#
public class SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion
Inherits TreeOidWrapper
Links
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties, SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members, Class Hierarchy


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion.

Public Properties
Public Property | Description
FrequencyAlongCurves | Specifies the frequency that the intersection object assemblies is inserted for curve segments of the alignment.
FrequencyAlongProfileCurves | Specifies the frequency along stations that intersection object assemblies are inserted for curve segments of the profile.
FrequencyAlongSpirals | Specifies the frequency that the intersection object assemblies is inserted for spiral segments of the alignment.
FrequencyAlongTangents | Specifies the frequency that the intersection object assemblies is inserted for tangent segments of the alignment.
HorizontalGeometryPoints | Specifies whether or not to use horizontal geometry points to define intersection objects.
ProfileGeometryPoints | Specifies whether or not to use profile geometry points to define intersection objects.
ProfileHighLowPoints | Specifies whether or not to use the highest and lowest points of the profile to define intersection objects.
SuperelevationCriticalPoints | Specifies whether or not to use superelevation critical points to define intersection objects.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties
Collapse All

The properties of SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion are listed here.

Public Properties
Public Property | Description
FrequencyAlongCurves | Specifies the frequency that the intersection object assemblies is inserted for curve segments of the alignment.
FrequencyAlongProfileCurves | Specifies the frequency along stations that intersection object assemblies are inserted for curve segments of the profile.
FrequencyAlongSpirals | Specifies the frequency that the intersection object assemblies is inserted for spiral segments of the alignment.
FrequencyAlongTangents | Specifies the frequency that the intersection object assemblies is inserted for tangent segments of the alignment.
HorizontalGeometryPoints | Specifies whether or not to use horizontal geometry points to define intersection objects.
ProfileGeometryPoints | Specifies whether or not to use profile geometry points to define intersection objects.
ProfileHighLowPoints | Specifies whether or not to use the highest and lowest points of the profile to define intersection objects.
SuperelevationCriticalPoints | Specifies whether or not to use superelevation critical points to define intersection objects.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongCurves Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongCurves Property
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongCurves Property
Collapse All

Specifies the frequency that the intersection object assemblies is inserted for curve segments of the alignment.

C#
public PropertyDouble FrequencyAlongCurves;
Visual Basic
Public Property FrequencyAlongCurves() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves Property
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves Property
Collapse All

Specifies the frequency along stations that intersection object assemblies are inserted for curve segments of the profile.

C#
public PropertyDouble FrequencyAlongProfileCurves;
Visual Basic
Public Property FrequencyAlongProfileCurves() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals Property
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals Property
Collapse All

Specifies the frequency that the intersection object assemblies is inserted for spiral segments of the alignment.

C#
public PropertyDouble FrequencyAlongSpirals;
Visual Basic
Public Property FrequencyAlongSpirals() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongTangents Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongTangents Property
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongTangents Property
Collapse All

Specifies the frequency that the intersection object assemblies is inserted for tangent segments of the alignment.

C#
public PropertyDouble FrequencyAlongTangents;
Visual Basic
Public Property FrequencyAlongTangents() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints Property
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints Property
Collapse All

Specifies whether or not to use horizontal geometry points to define intersection objects.

C#
public PropertyBoolean HorizontalGeometryPoints;
Visual Basic
Public Property HorizontalGeometryPoints() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::ProfileGeometryPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::ProfileGeometryPoints Property
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::ProfileGeometryPoints Property
Collapse All

Specifies whether or not to use profile geometry points to define intersection objects.

C#
public PropertyBoolean ProfileGeometryPoints;
Visual Basic
Public Property ProfileGeometryPoints() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::ProfileHighLowPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::ProfileHighLowPoints Property
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::ProfileHighLowPoints Property
Collapse All

Specifies whether or not to use the highest and lowest points of the profile to define intersection objects.

C#
public PropertyBoolean ProfileHighLowPoints;
Visual Basic
Public Property ProfileHighLowPoints() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints Property
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints Property
Collapse All

Specifies whether or not to use superelevation critical points to define intersection objects.

C#
public PropertyBoolean SuperelevationCriticalPoints;
Visual Basic
Public Property SuperelevationCriticalPoints() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class
Collapse All

Settings for the default cross slopes of new intersection

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdCrossSlopes
C#
public class SettingsCmdCreateIntersection::SettingsCmdCrossSlopes : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateIntersection::SettingsCmdCrossSlopes
Inherits TreeOidWrapper
Links
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties, SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members, Class Hierarchy


SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateIntersection::SettingsCmdCrossSlopes.

Public Properties
Public Property | Description
PrimaryRoadLeftCrossSlope | Specifies the cross slope of the left side of the primary road.
PrimaryRoadRightCrossSlope | Specifies the cross slope of the right side of the primary road.
SecondaryRoadLeftCrossSlope | Specifies the cross slope of the left side of the secondary road.
SecondaryRoadRightCrossSlope | Specifies the cross slope of the right side of the secondary road.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties
Collapse All

The properties of SettingsCmdCreateIntersection::SettingsCmdCrossSlopes are listed here.

Public Properties
Public Property | Description
PrimaryRoadLeftCrossSlope | Specifies the cross slope of the left side of the primary road.
PrimaryRoadRightCrossSlope | Specifies the cross slope of the right side of the primary road.
SecondaryRoadLeftCrossSlope | Specifies the cross slope of the left side of the secondary road.
SecondaryRoadRightCrossSlope | Specifies the cross slope of the right side of the secondary road.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::PrimaryRoadLeftCrossSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::PrimaryRoadLeftCrossSlope Property
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::PrimaryRoadLeftCrossSlope Property
Collapse All

Specifies the cross slope of the left side of the primary road.

C#
public PropertyDouble PrimaryRoadLeftCrossSlope;
Visual Basic
Public Property PrimaryRoadLeftCrossSlope() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class, SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::PrimaryRoadRightCrossSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::PrimaryRoadRightCrossSlope Property
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::PrimaryRoadRightCrossSlope Property
Collapse All

Specifies the cross slope of the right side of the primary road.

C#
public PropertyDouble PrimaryRoadRightCrossSlope;
Visual Basic
Public Property PrimaryRoadRightCrossSlope() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class, SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::SecondaryRoadLeftCrossSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::SecondaryRoadLeftCrossSlope Property
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::SecondaryRoadLeftCrossSlope Property
Collapse All

Specifies the cross slope of the left side of the secondary road.

C#
public PropertyDouble SecondaryRoadLeftCrossSlope;
Visual Basic
Public Property SecondaryRoadLeftCrossSlope() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class, SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::SecondaryRoadRightCrossSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::SecondaryRoadRightCrossSlope Property
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::SecondaryRoadRightCrossSlope Property
Collapse All

Specifies the cross slope of the right side of the secondary road.

C#
public PropertyDouble SecondaryRoadRightCrossSlope;
Visual Basic
Public Property SecondaryRoadRightCrossSlope() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class, SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class
Collapse All

Settings for the default curb return parameters of new intersection

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters
C#
public class SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters
Inherits TreeOidWrapper
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Class Hierarchy


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters.

Public Properties
Public Property | Description
ChamferFilletLengthAlongIncomingLane | When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s... more
ChamferFilletLengthAlongOutgoingLane | When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s... more
CircularFilletRadius | When Circular Fillet is selected as the curb return type, this option lets you specify the radius for the circular... more
CurbReturnType | Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.
LengthOfCurve1 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the first... more
LengthOfCurve3 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the third... more
RadiusOfCurve1 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the first... more
RadiusOfCurve2 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the second... more
RadiusOfCurve3 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the third... more
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties
Collapse All

The properties of SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters are listed here.

Public Properties
Public Property | Description
ChamferFilletLengthAlongIncomingLane | When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s... more
ChamferFilletLengthAlongOutgoingLane | When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s... more
CircularFilletRadius | When Circular Fillet is selected as the curb return type, this option lets you specify the radius for the circular... more
CurbReturnType | Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.
LengthOfCurve1 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the first... more
LengthOfCurve3 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the third... more
RadiusOfCurve1 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the first... more
RadiusOfCurve2 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the second... more
RadiusOfCurve3 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the third... more
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::ChamferFilletLengthAlongIncomingLane Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::ChamferFilletLengthAlongIncomingLane Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::ChamferFilletLengthAlongIncomingLane Property
Collapse All

When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s chamfer fillet along the incoming lane.

C#
public PropertyDouble ChamferFilletLengthAlongIncomingLane;
Visual Basic
Public Property ChamferFilletLengthAlongIncomingLane() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::ChamferFilletLengthAlongOutgoingLane Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::ChamferFilletLengthAlongOutgoingLane Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::ChamferFilletLengthAlongOutgoingLane Property
Collapse All

When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s chamfer fillet along the outgoing lane.

C#
public PropertyDouble ChamferFilletLengthAlongOutgoingLane;
Visual Basic
Public Property ChamferFilletLengthAlongOutgoingLane() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::CircularFilletRadius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::CircularFilletRadius Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::CircularFilletRadius Property
Collapse All

When Circular Fillet is selected as the curb return type, this option lets you specify the radius for the circular fillet on the curb return.

C#
public PropertyDouble CircularFilletRadius;
Visual Basic
Public Property CircularFilletRadius() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::CurbReturnType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::CurbReturnType Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::CurbReturnType Property
Collapse All

Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.

C#
public PropertyEnum<Autodesk::Civil::CurbReturnType> CurbReturnType;
Visual Basic
Public Property CurbReturnType() As PropertyEnum<Autodesk::Civil::CurbReturnType>
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::LengthOfCurve1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::LengthOfCurve1 Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::LengthOfCurve1 Property
Collapse All

When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the first curve on the curb return.

C#
public PropertyDouble LengthOfCurve1;
Visual Basic
Public Property LengthOfCurve1() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::LengthOfCurve3 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::LengthOfCurve3 Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::LengthOfCurve3 Property
Collapse All

When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the third curve on the curb return.

C#
public PropertyDouble LengthOfCurve3;
Visual Basic
Public Property LengthOfCurve3() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve1 Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve1 Property
Collapse All

When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the first curve on the curb return.

C#
public PropertyDouble RadiusOfCurve1;
Visual Basic
Public Property RadiusOfCurve1() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve2 Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve2 Property
Collapse All

When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the second curve on the curb return.

C#
public PropertyDouble RadiusOfCurve2;
Visual Basic
Public Property RadiusOfCurve2() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve3 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve3 Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve3 Property
Collapse All

When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the third curve on the curb return.

C#
public PropertyDouble RadiusOfCurve3;
Visual Basic
Public Property RadiusOfCurve3() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class
Collapse All

Settings for the default curb return profile rules of new intersection

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules
C#
public class SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules
Inherits TreeOidWrapper
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties, SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members, Class Hierarchy


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules.

Public Properties
Public Property | Description
DefineCurbReturnProfileBy | Specifies the method that is used to define the curb return profile.
ExtendProfileAlongIncomingLane | Specifies whether or not to extend the curb return profile along the incoming lane of the intersection.
ExtendProfileAlongOutgoingLane | Specifies whether or not to extend the curb return profile along the outgoing lane of the intersection.
LengthToExtendAlongIncomingLane | When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the... more
LengthToExtendAlongOutgoingLane | When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the... more
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties
Collapse All

The properties of SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules are listed here.

Public Properties
Public Property | Description
DefineCurbReturnProfileBy | Specifies the method that is used to define the curb return profile.
ExtendProfileAlongIncomingLane | Specifies whether or not to extend the curb return profile along the incoming lane of the intersection.
ExtendProfileAlongOutgoingLane | Specifies whether or not to extend the curb return profile along the outgoing lane of the intersection.
LengthToExtendAlongIncomingLane | When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the... more
LengthToExtendAlongOutgoingLane | When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the... more
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::DefineCurbReturnProfileBy Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::DefineCurbReturnProfileBy Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::DefineCurbReturnProfileBy Property
Collapse All

Specifies the method that is used to define the curb return profile.

C#
public PropertyEnum<Autodesk::Civil::Roadway::DatabaseServices::CurbReturnJoiningType> DefineCurbReturnProfileBy;
Visual Basic
Public Property DefineCurbReturnProfileBy() As PropertyEnum<Autodesk::Civil::Roadway::DatabaseServices::CurbReturnJoiningType>
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::ExtendProfileAlongIncomingLane Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::ExtendProfileAlongIncomingLane Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::ExtendProfileAlongIncomingLane Property
Collapse All

Specifies whether or not to extend the curb return profile along the incoming lane of the intersection.

C#
public PropertyBoolean ExtendProfileAlongIncomingLane;
Visual Basic
Public Property ExtendProfileAlongIncomingLane() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::ExtendProfileAlongOutgoingLane Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::ExtendProfileAlongOutgoingLane Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::ExtendProfileAlongOutgoingLane Property
Collapse All

Specifies whether or not to extend the curb return profile along the outgoing lane of the intersection.

C#
public PropertyBoolean ExtendProfileAlongOutgoingLane;
Visual Basic
Public Property ExtendProfileAlongOutgoingLane() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::LengthToExtendAlongIncomingLane Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::LengthToExtendAlongIncomingLane Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::LengthToExtendAlongIncomingLane Property
Collapse All

When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the curb return profile along the incoming lane of the intersection.

C#
public PropertyDouble LengthToExtendAlongIncomingLane;
Visual Basic
Public Property LengthToExtendAlongIncomingLane() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::LengthToExtendAlongOutgoingLane Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::LengthToExtendAlongOutgoingLane Property
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::LengthToExtendAlongOutgoingLane Property
Collapse All

When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the curb return profile along the outgoing lane of the intersection.

C#
public PropertyDouble LengthToExtendAlongOutgoingLane;
Visual Basic
Public Property LengthToExtendAlongOutgoingLane() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class
Collapse All

Settings for the default intersection options of new intersection

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions
C#
public class SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions
Inherits TreeOidWrapper
Links
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties, SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members, Class Hierarchy


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions.

Public Properties
Public Property | Description
CreateCurbReturnAlignments | Specifies whether or not to create curb return alignments.
CreateCurbReturnProfiles | Specifies whether or not to create curb return profiles.
CreateIntersectionCorridors | Specifies whether or not to create intersection corridors.
IntersectionType | Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options... more
PrimaryRoadDefaultExitAndEntryLength | Specifies the default length of the primary road as it enters and exits the intersection.
SecondaryRoadDefaultExitAndEntryLength | Specifies the default length of the secondary road as it enters and exits the intersection.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties
Collapse All

The properties of SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions are listed here.

Public Properties
Public Property | Description
CreateCurbReturnAlignments | Specifies whether or not to create curb return alignments.
CreateCurbReturnProfiles | Specifies whether or not to create curb return profiles.
CreateIntersectionCorridors | Specifies whether or not to create intersection corridors.
IntersectionType | Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options... more
PrimaryRoadDefaultExitAndEntryLength | Specifies the default length of the primary road as it enters and exits the intersection.
SecondaryRoadDefaultExitAndEntryLength | Specifies the default length of the secondary road as it enters and exits the intersection.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateCurbReturnAlignments Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateCurbReturnAlignments Property
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateCurbReturnAlignments Property
Collapse All

Specifies whether or not to create curb return alignments.

C#
public PropertyBoolean CreateCurbReturnAlignments;
Visual Basic
Public Property CreateCurbReturnAlignments() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class, SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateCurbReturnProfiles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateCurbReturnProfiles Property
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateCurbReturnProfiles Property
Collapse All

Specifies whether or not to create curb return profiles.

C#
public PropertyBoolean CreateCurbReturnProfiles;
Visual Basic
Public Property CreateCurbReturnProfiles() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class, SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateIntersectionCorridors Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateIntersectionCorridors Property
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateIntersectionCorridors Property
Collapse All

Specifies whether or not to create intersection corridors.

C#
public PropertyBoolean CreateIntersectionCorridors;
Visual Basic
Public Property CreateIntersectionCorridors() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class, SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::IntersectionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::IntersectionType Property
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::IntersectionType Property
Collapse All

Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options is selected, the primary road crown is maintained through the intersection. All Crowns Maintained: When this options is selected, the crowns of both roads included in the intersection are maintained through the intersection.

C#
public PropertyEnum<Autodesk::Civil::Roadway::DatabaseServices::IntersectionCorridorType> IntersectionType;
Visual Basic
Public Property IntersectionType() As PropertyEnum<Autodesk::Civil::Roadway::DatabaseServices::IntersectionCorridorType>
Links
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class, SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::PrimaryRoadDefaultExitAndEntryLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::PrimaryRoadDefaultExitAndEntryLength Property
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::PrimaryRoadDefaultExitAndEntryLength Property
Collapse All

Specifies the default length of the primary road as it enters and exits the intersection.

C#
public PropertyDouble PrimaryRoadDefaultExitAndEntryLength;
Visual Basic
Public Property PrimaryRoadDefaultExitAndEntryLength() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class, SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::SecondaryRoadDefaultExitAndEntryLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::SecondaryRoadDefaultExitAndEntryLength Property
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::SecondaryRoadDefaultExitAndEntryLength Property
Collapse All

Specifies the default length of the secondary road as it enters and exits the intersection.

C#
public PropertyDouble SecondaryRoadDefaultExitAndEntryLength;
Visual Basic
Public Property SecondaryRoadDefaultExitAndEntryLength() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class, SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdOffsets Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class
SettingsCmdCreateIntersection::SettingsCmdOffsets Class
Collapse All

Settings for the default offsets of new intersection

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdOffsets
C#
public class SettingsCmdCreateIntersection::SettingsCmdOffsets : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateIntersection::SettingsCmdOffsets
Inherits TreeOidWrapper
Links
SettingsCmdCreateIntersection::SettingsCmdOffsets Properties, SettingsCmdCreateIntersection::SettingsCmdOffsets Members, Class Hierarchy


SettingsCmdCreateIntersection::SettingsCmdOffsets Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Members
SettingsCmdCreateIntersection::SettingsCmdOffsets Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateIntersection::SettingsCmdOffsets.

Public Properties
Public Property | Description
OffsetLengthOptions | Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are... more
PrimaryRoadLeftOffset | Specifies the elevation of the offset alignment on the left side of the primary road.
PrimaryRoadRightOffset | Specifies the elevation of the offset alignment on the right side of the primary road.
SecondaryRoadLeftOffset | Specifies the elevation of the offset alignment on the left side of the secondary road.
SecondaryRoadRightOffset | Specifies the elevation of the offset alignment on the right side of the secondary road.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdOffsets Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Properties
SettingsCmdCreateIntersection::SettingsCmdOffsets Properties
Collapse All

The properties of SettingsCmdCreateIntersection::SettingsCmdOffsets are listed here.

Public Properties
Public Property | Description
OffsetLengthOptions | Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are... more
PrimaryRoadLeftOffset | Specifies the elevation of the offset alignment on the left side of the primary road.
PrimaryRoadRightOffset | Specifies the elevation of the offset alignment on the right side of the primary road.
SecondaryRoadLeftOffset | Specifies the elevation of the offset alignment on the left side of the secondary road.
SecondaryRoadRightOffset | Specifies the elevation of the offset alignment on the right side of the secondary road.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdOffsets::OffsetLengthOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Properties > SettingsCmdCreateIntersection::SettingsCmdOffsets::OffsetLengthOptions Property
SettingsCmdCreateIntersection::SettingsCmdOffsets::OffsetLengthOptions Property
Collapse All

Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are extended to the length of the extent of the intersection object. When Alignment Start To End is selected, offset alignments are created the length of the parent alignment.

C#
public PropertyEnum<Autodesk::Civil::Roadway::DatabaseServices::OffsetLengthOption> OffsetLengthOptions;
Visual Basic
Public Property OffsetLengthOptions() As PropertyEnum<Autodesk::Civil::Roadway::DatabaseServices::OffsetLengthOption>
Links
SettingsCmdCreateIntersection::SettingsCmdOffsets Class, SettingsCmdCreateIntersection::SettingsCmdOffsets Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdOffsets::PrimaryRoadLeftOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Properties > SettingsCmdCreateIntersection::SettingsCmdOffsets::PrimaryRoadLeftOffset Property
SettingsCmdCreateIntersection::SettingsCmdOffsets::PrimaryRoadLeftOffset Property
Collapse All

Specifies the elevation of the offset alignment on the left side of the primary road.

C#
public PropertyDouble PrimaryRoadLeftOffset;
Visual Basic
Public Property PrimaryRoadLeftOffset() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdOffsets Class, SettingsCmdCreateIntersection::SettingsCmdOffsets Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdOffsets::PrimaryRoadRightOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Properties > SettingsCmdCreateIntersection::SettingsCmdOffsets::PrimaryRoadRightOffset Property
SettingsCmdCreateIntersection::SettingsCmdOffsets::PrimaryRoadRightOffset Property
Collapse All

Specifies the elevation of the offset alignment on the right side of the primary road.

C#
public PropertyDouble PrimaryRoadRightOffset;
Visual Basic
Public Property PrimaryRoadRightOffset() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdOffsets Class, SettingsCmdCreateIntersection::SettingsCmdOffsets Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdOffsets::SecondaryRoadLeftOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Properties > SettingsCmdCreateIntersection::SettingsCmdOffsets::SecondaryRoadLeftOffset Property
SettingsCmdCreateIntersection::SettingsCmdOffsets::SecondaryRoadLeftOffset Property
Collapse All

Specifies the elevation of the offset alignment on the left side of the secondary road.

C#
public PropertyDouble SecondaryRoadLeftOffset;
Visual Basic
Public Property SecondaryRoadLeftOffset() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdOffsets Class, SettingsCmdCreateIntersection::SettingsCmdOffsets Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdOffsets::SecondaryRoadRightOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Properties > SettingsCmdCreateIntersection::SettingsCmdOffsets::SecondaryRoadRightOffset Property
SettingsCmdCreateIntersection::SettingsCmdOffsets::SecondaryRoadRightOffset Property
Collapse All

Specifies the elevation of the offset alignment on the right side of the secondary road.

C#
public PropertyDouble SecondaryRoadRightOffset;
Visual Basic
Public Property SecondaryRoadRightOffset() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdOffsets Class, SettingsCmdCreateIntersection::SettingsCmdOffsets Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class
Collapse All

Settings for the default secondary road profile rules of new intersection

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules
C#
public class SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules
Inherits TreeOidWrapper
Links
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties, SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members, Class Hierarchy


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules.

Public Properties
Public Property | Description
ApplyGradeRules | Specifies whether or not to apply grade rules.
DistanceRuleToAdjusttheGrade | Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is... more
DistanceValue | Specifes the distance that is used to adjust the grade for the secondary road profile when Specify Distance is selected... more
MaximumGrade | Specifies the maximum grade that can be used in the profile for the secondary road.
MaximumGradeChange | Specifies the maximum grade change that can be used in the profile for the secondary road.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties
Collapse All

The properties of SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules are listed here.

Public Properties
Public Property | Description
ApplyGradeRules | Specifies whether or not to apply grade rules.
DistanceRuleToAdjusttheGrade | Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is... more
DistanceValue | Specifes the distance that is used to adjust the grade for the secondary road profile when Specify Distance is selected... more
MaximumGrade | Specifies the maximum grade that can be used in the profile for the secondary road.
MaximumGradeChange | Specifies the maximum grade change that can be used in the profile for the secondary road.
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::ApplyGradeRules Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::ApplyGradeRules Property
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::ApplyGradeRules Property
Collapse All

Specifies whether or not to apply grade rules.

C#
public PropertyBoolean ApplyGradeRules;
Visual Basic
Public Property ApplyGradeRules() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::DistanceRuleToAdjusttheGrade Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::DistanceRuleToAdjusttheGrade Property
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::DistanceRuleToAdjusttheGrade Property
Collapse All

Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is selected, the grade of the secondary road profile is adjusted to meet the extents of the intersection object. When Specify Distance is used, the grade of the secondary road profile is adjusted by the value that is entered in the Distance Value.

C#
public PropertyEnum<Autodesk::Civil::Roadway::DatabaseServices::SideRoadProfileDistanceRuleType> DistanceRuleToAdjusttheGrade;
Visual Basic
Public Property DistanceRuleToAdjusttheGrade() As PropertyEnum<Autodesk::Civil::Roadway::DatabaseServices::SideRoadProfileDistanceRuleType>
Links
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::DistanceValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::DistanceValue Property
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::DistanceValue Property
Collapse All

Specifes the distance that is used to adjust the grade for the secondary road profile when Specify Distance is selected for Distance Rule to Adjust the Grade.

C#
public PropertyDouble DistanceValue;
Visual Basic
Public Property DistanceValue() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::MaximumGrade Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::MaximumGrade Property
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::MaximumGrade Property
Collapse All

Specifies the maximum grade that can be used in the profile for the secondary road.

C#
public PropertyDouble MaximumGrade;
Visual Basic
Public Property MaximumGrade() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::MaximumGradeChange Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::MaximumGradeChange Property
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::MaximumGradeChange Property
Collapse All

Specifies the maximum grade change that can be used in the profile for the secondary road.

C#
public PropertyDouble MaximumGradeChange;
Visual Basic
Public Property MaximumGradeChange() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class, SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class
Collapse All

Settings for the default widening parameters of new intersection

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdWideningParameters
C#
public class SettingsCmdCreateIntersection::SettingsCmdWideningParameters : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateIntersection::SettingsCmdWideningParameters
Inherits TreeOidWrapper
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Class Hierarchy


SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateIntersection::SettingsCmdWideningParameters.

Public Properties
Public Property | Description
LinearTransitionType | When Linear is selected as the Transition Type, this option lets you specify the type of linear transition used for... more
RadiusofCurve1 | When a curve option is selected as the Transition Type, this option lets you specify the radius for the first... more
RadiusofCurve2 | When a curve option is selected as the Transition Type, this option lets you specify the radius for the second... more
RadiusOfReverseCurve | When Curve-Curve - Reverse Curve is selected as the Transition Type, this option lets you specify the radius for the... more
TaperRation | When By Taper Ratio is selected as the Linear Transition Type, this option lets you specify the ratio of the... more
TransitionLength | When By Length is selected as the Linear Transition Type, this option lets you specify the length of the transition... more
TransitionType | Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.
WidenedOffset | Specifies the elevation for the offset alignment that has been widened, at both the entrance to the intersection, and as... more
WideningAtIncomingLane | Specifies whether or not to widen the incoming lane as it enters the intersection.
WideningAtOutgoingLane | Specifies whether or not to widen the outgoing lane as it exits the intersection.
WideningSegmentLength | Specifies the length of the offset alignment that will be widened, at both the entrance to the intersection, and as... more
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties
Collapse All

The properties of SettingsCmdCreateIntersection::SettingsCmdWideningParameters are listed here.

Public Properties
Public Property | Description
LinearTransitionType | When Linear is selected as the Transition Type, this option lets you specify the type of linear transition used for... more
RadiusofCurve1 | When a curve option is selected as the Transition Type, this option lets you specify the radius for the first... more
RadiusofCurve2 | When a curve option is selected as the Transition Type, this option lets you specify the radius for the second... more
RadiusOfReverseCurve | When Curve-Curve - Reverse Curve is selected as the Transition Type, this option lets you specify the radius for the... more
TaperRation | When By Taper Ratio is selected as the Linear Transition Type, this option lets you specify the ratio of the... more
TransitionLength | When By Length is selected as the Linear Transition Type, this option lets you specify the length of the transition... more
TransitionType | Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.
WidenedOffset | Specifies the elevation for the offset alignment that has been widened, at both the entrance to the intersection, and as... more
WideningAtIncomingLane | Specifies whether or not to widen the incoming lane as it enters the intersection.
WideningAtOutgoingLane | Specifies whether or not to widen the outgoing lane as it exits the intersection.
WideningSegmentLength | Specifies the length of the offset alignment that will be widened, at both the entrance to the intersection, and as... more
Links
Public Properties


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::LinearTransitionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::LinearTransitionType Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::LinearTransitionType Property
Collapse All

When Linear is selected as the Transition Type, this option lets you specify the type of linear transition used for the widening: By Length or By Taper Ratio.

C#
public PropertyEnum<Autodesk::Civil::TransitionInputType> LinearTransitionType;
Visual Basic
Public Property LinearTransitionType() As PropertyEnum<Autodesk::Civil::TransitionInputType>
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusofCurve1 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusofCurve1 Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusofCurve1 Property
Collapse All

When a curve option is selected as the Transition Type, this option lets you specify the radius for the first curve used in the widening.

C#
public PropertyDouble RadiusofCurve1;
Visual Basic
Public Property RadiusofCurve1() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusofCurve2 Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusofCurve2 Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusofCurve2 Property
Collapse All

When a curve option is selected as the Transition Type, this option lets you specify the radius for the second curve used in the widening.

C#
public PropertyDouble RadiusofCurve2;
Visual Basic
Public Property RadiusofCurve2() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusOfReverseCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusOfReverseCurve Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusOfReverseCurve Property
Collapse All

When Curve-Curve - Reverse Curve is selected as the Transition Type, this option lets you specify the radius for the first and second curves used in the widening.

C#
public PropertyDouble RadiusOfReverseCurve;
Visual Basic
Public Property RadiusOfReverseCurve() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TaperRation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TaperRation Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TaperRation Property
Collapse All

When By Taper Ratio is selected as the Linear Transition Type, this option lets you specify the ratio of the tapering for the widening.

C#
public PropertyDouble TaperRation;
Visual Basic
Public Property TaperRation() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TransitionLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TransitionLength Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TransitionLength Property
Collapse All

When By Length is selected as the Linear Transition Type, this option lets you specify the length of the transition for the widening.

C#
public PropertyDouble TransitionLength;
Visual Basic
Public Property TransitionLength() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TransitionType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TransitionType Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TransitionType Property
Collapse All

Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.

C#
public PropertyEnum<Autodesk::Civil::TransitionType> TransitionType;
Visual Basic
Public Property TransitionType() As PropertyEnum<Autodesk::Civil::TransitionType>
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WidenedOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WidenedOffset Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WidenedOffset Property
Collapse All

Specifies the elevation for the offset alignment that has been widened, at both the entrance to the intersection, and as it exits the intersection.

C#
public PropertyDouble WidenedOffset;
Visual Basic
Public Property WidenedOffset() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningAtIncomingLane Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningAtIncomingLane Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningAtIncomingLane Property
Collapse All

Specifies whether or not to widen the incoming lane as it enters the intersection.

C#
public PropertyBoolean WideningAtIncomingLane;
Visual Basic
Public Property WideningAtIncomingLane() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningAtOutgoingLane Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningAtOutgoingLane Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningAtOutgoingLane Property
Collapse All

Specifies whether or not to widen the outgoing lane as it exits the intersection.

C#
public PropertyBoolean WideningAtOutgoingLane;
Visual Basic
Public Property WideningAtOutgoingLane() As PropertyBoolean
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningSegmentLength Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties > SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningSegmentLength Property
SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningSegmentLength Property
Collapse All

Specifies the length of the offset alignment that will be widened, at both the entrance to the intersection, and as it exits the intersection.

C#
public PropertyDouble WideningSegmentLength;
Visual Basic
Public Property WideningSegmentLength() As PropertyDouble
Links
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class, SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreatePointsFromCorridor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreatePointsFromCorridor Class
SettingsCmdCreatePointsFromCorridor Class
Collapse All

Settings for CreatePointsFromCorridor command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreatePointsFromCorridor
C#
public class SettingsCmdCreatePointsFromCorridor : SettingsCorridor;
Visual Basic
Public Class SettingsCmdCreatePointsFromCorridor
Inherits SettingsCorridor
Links
Class Hierarchy


SettingsCmdCreatePolylineFromCorridor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreatePolylineFromCorridor Class
SettingsCmdCreatePolylineFromCorridor Class
Collapse All

Settings for CreatePolylineFromCorridor command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreatePolylineFromCorridor
C#
public class SettingsCmdCreatePolylineFromCorridor : SettingsCorridor;
Visual Basic
Public Class SettingsCmdCreatePolylineFromCorridor
Inherits SettingsCorridor
Links
Class Hierarchy


SettingsCmdCreateProfileFromCorridor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class
SettingsCmdCreateProfileFromCorridor Class
Collapse All

Settings for CreateProfileFromCorridor command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateProfileFromCorridor
C#
public class SettingsCmdCreateProfileFromCorridor : SettingsCorridor;
Visual Basic
Public Class SettingsCmdCreateProfileFromCorridor
Inherits SettingsCorridor
Links
SettingsCmdCreateProfileFromCorridor Properties, SettingsCmdCreateProfileFromCorridor Members, Class Hierarchy


SettingsCmdCreateProfileFromCorridor Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Members
SettingsCmdCreateProfileFromCorridor Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateProfileFromCorridor.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the default settings of criteria-based design options.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateProfileFromCorridor Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Properties
SettingsCmdCreateProfileFromCorridor Properties
Collapse All

The properties of SettingsCmdCreateProfileFromCorridor are listed here.

Public Properties
Public Property | Description
CriteriaBasedDesignOptions | Gets the default settings of criteria-based design options.
Links
Public Properties


SettingsCmdCreateProfileFromCorridor::CriteriaBasedDesignOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Properties > SettingsCmdCreateProfileFromCorridor::CriteriaBasedDesignOptions Property
SettingsCmdCreateProfileFromCorridor::CriteriaBasedDesignOptions Property
Collapse All

Gets the default settings of criteria-based design options.

C#
public SettingsCmdCriteriaBasedDesignOptions CriteriaBasedDesignOptions;
Visual Basic
Public Property CriteriaBasedDesignOptions() As SettingsCmdCriteriaBasedDesignOptions
Links
SettingsCmdCreateProfileFromCorridor Class, SettingsCmdCreateProfileFromCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class
Collapse All

Settings that specify the defaults used when creating a profile using design criteria.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions
C#
public class SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions
Inherits TreeOidWrapper
Links
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties, SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Class Hierarchy


SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions.

Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
UseDesignChecksOption | Gets whether to associate a design check set with the profile.
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the profile.
Links
Public Properties


SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
Collapse All

The properties of SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions are listed here.

Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
UseDesignChecksOption | Gets whether to associate a design check set with the profile.
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the profile.
Links
Public Properties


SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DefaultDesignCheckSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DefaultDesignCheckSet Property
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DefaultDesignCheckSet Property
Collapse All

Gets the default design check set.

C#
public PropertyString DefaultDesignCheckSet;
Visual Basic
Public Property DefaultDesignCheckSet() As PropertyString
Links
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignChecksOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignChecksOption Property
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignChecksOption Property
Collapse All

Gets whether to associate a design check set with the profile.

C#
public PropertyBoolean UseDesignChecksOption;
Visual Basic
Public Property UseDesignChecksOption() As PropertyBoolean
Links
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignCriteriaFileOption Property
Collapse All

Gets whether to associate a design criteria file with the profile.

C#
public PropertyBoolean UseDesignCriteriaFileOption;
Visual Basic
Public Property UseDesignCriteriaFileOption() As PropertyBoolean
Links
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class, SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSimpleCorridor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class
SettingsCmdCreateSimpleCorridor Class
Collapse All

Settings for CreateSimpleCorridor command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSimpleCorridor
C#
public class SettingsCmdCreateSimpleCorridor : SettingsCorridor;
Visual Basic
Public Class SettingsCmdCreateSimpleCorridor
Inherits SettingsCorridor
Links
SettingsCmdCreateSimpleCorridor Properties, SettingsCmdCreateSimpleCorridor Members, Class Hierarchy


SettingsCmdCreateSimpleCorridor Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Members
SettingsCmdCreateSimpleCorridor Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSimpleCorridor.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AssemblyInsertion | Gets the default settings of assembly insertion.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSimpleCorridor Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Properties
SettingsCmdCreateSimpleCorridor Properties
Collapse All

The properties of SettingsCmdCreateSimpleCorridor are listed here.

Public Properties
Public Property | Description
AssemblyInsertion | Gets the default settings of assembly insertion.
Links
Public Properties


SettingsCmdCreateSimpleCorridor::AssemblyInsertion Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Properties > SettingsCmdCreateSimpleCorridor::AssemblyInsertion Property
SettingsCmdCreateSimpleCorridor::AssemblyInsertion Property
Collapse All

Gets the default settings of assembly insertion.

C#
public SettingsCmdAssemblyInsertion AssemblyInsertion;
Visual Basic
Public Property AssemblyInsertion() As SettingsCmdAssemblyInsertion
Links
SettingsCmdCreateSimpleCorridor Class, SettingsCmdCreateSimpleCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class
Collapse All

Settings that establish the defaults assigned to corridor creation.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion
C#
public class SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion
Inherits TreeOidWrapper
Links
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties, SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members, Class Hierarchy


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion.

Public Properties
Public Property | Description
FrequencyAlongCurves | Gets the corridor station placement frequency along the curve portion of an alignment.
FrequencyAlongProfileCurves | Gets the corridor station placement frequency along curve portions of the profile geometry.
FrequencyAlongSpirals | Gets the corridor station placement frequency along the spiral portion of an alignment.
FrequencyAlongTangents | Gets the corridor station placement frequency along the tangent portion of an alignment.
HorizontalGeometryPoints | Gets whether corridor stations are placed at horizontal geometry points.
ProfileGeometryPoints | Gets whether corridor stations are placed at profile geometry points.
ProfileHighLowPoints | Gets whether assemblies are inserted at the high and low points of the profile geometry.
SuperelevationCriticalPoints | Gets whether corridor stations are placed at superelevation critical points.
Links
Public Properties


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties
Collapse All

The properties of SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion are listed here.

Public Properties
Public Property | Description
FrequencyAlongCurves | Gets the corridor station placement frequency along the curve portion of an alignment.
FrequencyAlongProfileCurves | Gets the corridor station placement frequency along curve portions of the profile geometry.
FrequencyAlongSpirals | Gets the corridor station placement frequency along the spiral portion of an alignment.
FrequencyAlongTangents | Gets the corridor station placement frequency along the tangent portion of an alignment.
HorizontalGeometryPoints | Gets whether corridor stations are placed at horizontal geometry points.
ProfileGeometryPoints | Gets whether corridor stations are placed at profile geometry points.
ProfileHighLowPoints | Gets whether assemblies are inserted at the high and low points of the profile geometry.
SuperelevationCriticalPoints | Gets whether corridor stations are placed at superelevation critical points.
Links
Public Properties


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongCurves Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongCurves Property
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongCurves Property
Collapse All

Gets the corridor station placement frequency along the curve portion of an alignment.

C#
public PropertyDouble FrequencyAlongCurves;
Visual Basic
Public Property FrequencyAlongCurves() As PropertyDouble
Links
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves Property
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves Property
Collapse All

Gets the corridor station placement frequency along curve portions of the profile geometry.

C#
public PropertyDouble FrequencyAlongProfileCurves;
Visual Basic
Public Property FrequencyAlongProfileCurves() As PropertyDouble
Links
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals Property
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals Property
Collapse All

Gets the corridor station placement frequency along the spiral portion of an alignment.

C#
public PropertyDouble FrequencyAlongSpirals;
Visual Basic
Public Property FrequencyAlongSpirals() As PropertyDouble
Links
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongTangents Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongTangents Property
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongTangents Property
Collapse All

Gets the corridor station placement frequency along the tangent portion of an alignment.

C#
public PropertyDouble FrequencyAlongTangents;
Visual Basic
Public Property FrequencyAlongTangents() As PropertyDouble
Links
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints Property
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints Property
Collapse All

Gets whether corridor stations are placed at horizontal geometry points.

C#
public PropertyBoolean HorizontalGeometryPoints;
Visual Basic
Public Property HorizontalGeometryPoints() As PropertyBoolean
Links
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::ProfileGeometryPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::ProfileGeometryPoints Property
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::ProfileGeometryPoints Property
Collapse All

Gets whether corridor stations are placed at profile geometry points.

C#
public PropertyBoolean ProfileGeometryPoints;
Visual Basic
Public Property ProfileGeometryPoints() As PropertyBoolean
Links
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::ProfileHighLowPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::ProfileHighLowPoints Property
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::ProfileHighLowPoints Property
Collapse All

Gets whether assemblies are inserted at the high and low points of the profile geometry.

C#
public PropertyBoolean ProfileHighLowPoints;
Visual Basic
Public Property ProfileHighLowPoints() As PropertyBoolean
Links
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints Property
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints Property
Collapse All

Gets whether corridor stations are placed at superelevation critical points.

C#
public PropertyBoolean SuperelevationCriticalPoints;
Visual Basic
Public Property SuperelevationCriticalPoints() As PropertyBoolean
Links
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class, SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSubassemblyTool Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class
SettingsCmdCreateSubassemblyTool Class
Collapse All

Settings for CreateSubassemblyTool command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsSubassembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubassemblyTool
C#
public class SettingsCmdCreateSubassemblyTool : SettingsSubassembly;
Visual Basic
Public Class SettingsCmdCreateSubassemblyTool
Inherits SettingsSubassembly
Links
SettingsCmdCreateSubassemblyTool Properties, SettingsCmdCreateSubassemblyTool Members, Class Hierarchy


SettingsCmdCreateSubassemblyTool Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Members
SettingsCmdCreateSubassemblyTool Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSubassemblyTool.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
DefaultStyles | Gets the settings to specify the default styles for subassembly.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for subassembly.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
SubassemblyOptions | Gets the default setting of subassembly option for the command CreateSubassemblyTool.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSubassemblyTool Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Properties
SettingsCmdCreateSubassemblyTool Properties
Collapse All

The properties of SettingsCmdCreateSubassemblyTool are listed here.

Public Properties
Public Property | Description
SubassemblyOptions | Gets the default setting of subassembly option for the command CreateSubassemblyTool.
Links
Public Properties


SettingsCmdCreateSubassemblyTool::SubassemblyOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Properties > SettingsCmdCreateSubassemblyTool::SubassemblyOptions Property
SettingsCmdCreateSubassemblyTool::SubassemblyOptions Property
Collapse All

Gets the default setting of subassembly option for the command CreateSubassemblyTool.

C#
public SettingsCmdSubassemblyOptions SubassemblyOptions;
Visual Basic
Public Property SubassemblyOptions() As SettingsCmdSubassemblyOptions
Links
SettingsCmdCreateSubassemblyTool Class, SettingsCmdCreateSubassemblyTool Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class
Collapse All

Settings

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions
C#
public class SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions
Inherits TreeOidWrapper
Links
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties, SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members, Class Hierarchy


SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions.

Public Properties
Public Property | Description
CurrentSide | Specifies the current side.
Links
Public Properties


SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties
Collapse All

The properties of SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions are listed here.

Public Properties
Public Property | Description
CurrentSide | Specifies the current side.
Links
Public Properties


SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions::CurrentSide Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions::CurrentSide Property
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions::CurrentSide Property
Collapse All

Specifies the current side.

C#
public PropertyEnum<Autodesk::Civil::Roadway::RoadwaySideType> CurrentSide;
Visual Basic
Public Property CurrentSide() As PropertyEnum<Autodesk::Civil::Roadway::RoadwaySideType>
Remarks

The next subassembly will be placed on this side of assembly.

Links
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class, SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSubFromPline Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class
SettingsCmdCreateSubFromPline Class
Collapse All

Settings for CreateSubFromPline command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsSubassembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubFromPline
C#
public class SettingsCmdCreateSubFromPline : SettingsSubassembly;
Visual Basic
Public Class SettingsCmdCreateSubFromPline
Inherits SettingsSubassembly
Links
SettingsCmdCreateSubFromPline Properties, SettingsCmdCreateSubFromPline Members, Class Hierarchy


SettingsCmdCreateSubFromPline Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Members
SettingsCmdCreateSubFromPline Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSubFromPline.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CreateFromEntities | Gets the default setting of create from entities for the command CreateSubFromPline.
DefaultStyles | Gets the settings to specify the default styles for subassembly.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for subassembly.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateSubFromPline Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Properties
SettingsCmdCreateSubFromPline Properties
Collapse All

The properties of SettingsCmdCreateSubFromPline are listed here.

Public Properties
Public Property | Description
CreateFromEntities | Gets the default setting of create from entities for the command CreateSubFromPline.
Links
Public Properties


SettingsCmdCreateSubFromPline::CreateFromEntities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Properties > SettingsCmdCreateSubFromPline::CreateFromEntities Property
SettingsCmdCreateSubFromPline::CreateFromEntities Property
Collapse All

Gets the default setting of create from entities for the command CreateSubFromPline.

C#
public SettingsCmdCreateFromEntities CreateFromEntities;
Visual Basic
Public Property CreateFromEntities() As SettingsCmdCreateFromEntities
Links
SettingsCmdCreateSubFromPline Class, SettingsCmdCreateSubFromPline Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class
Collapse All

Settings that specifies the default behavior for creating subassemblies from polylines.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities
C#
public class SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities
Inherits TreeOidWrapper
Links
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties, SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members, Class Hierarchy


SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities.

Public Properties
Public Property | Description
LinkCreation | Specifies the quantity of subassembly links (None, Single, Multiple) created from the polyline(s).
MidOrdinateDistance | Specifies mid-ordinate distance to approximate curvilinear segments
Links
Public Properties


SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties
Collapse All

The properties of SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities are listed here.

Public Properties
Public Property | Description
LinkCreation | Specifies the quantity of subassembly links (None, Single, Multiple) created from the polyline(s).
MidOrdinateDistance | Specifies mid-ordinate distance to approximate curvilinear segments
Links
Public Properties


SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities::LinkCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities::LinkCreation Property
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities::LinkCreation Property
Collapse All

Specifies the quantity of subassembly links (None, Single, Multiple) created from the polyline(s).

C#
public PropertyEnum<LinkCreationType> LinkCreation;
Visual Basic
Public Property LinkCreation() As PropertyEnum<LinkCreationType>
Links
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class, SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities::MidOrdinateDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities::MidOrdinateDistance Property
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities::MidOrdinateDistance Property
Collapse All

Specifies mid-ordinate distance to approximate curvilinear segments

C#
public PropertyDouble MidOrdinateDistance;
Visual Basic
Public Property MidOrdinateDistance() As PropertyDouble
Links
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class, SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdFeatureLinesFromCorridor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class
SettingsCmdFeatureLinesFromCorridor Class
Collapse All

Settings for FeatureLinesFromCorridor command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdFeatureLinesFromCorridor
C#
public class SettingsCmdFeatureLinesFromCorridor : SettingsCorridor;
Visual Basic
Public Class SettingsCmdFeatureLinesFromCorridor
Inherits SettingsCorridor
Links
SettingsCmdFeatureLinesFromCorridor Properties, SettingsCmdFeatureLinesFromCorridor Members, Class Hierarchy


SettingsCmdFeatureLinesFromCorridor Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Members
SettingsCmdFeatureLinesFromCorridor Members
Collapse All

The following tables list the members exposed by SettingsCmdFeatureLinesFromCorridor.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineCreation | Gets the default settings of feature line creation.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdFeatureLinesFromCorridor Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Properties
SettingsCmdFeatureLinesFromCorridor Properties
Collapse All

The properties of SettingsCmdFeatureLinesFromCorridor are listed here.

Public Properties
Public Property | Description
FeatureLineCreation | Gets the default settings of feature line creation.
Links
Public Properties


SettingsCmdFeatureLinesFromCorridor::FeatureLineCreation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Properties > SettingsCmdFeatureLinesFromCorridor::FeatureLineCreation Property
SettingsCmdFeatureLinesFromCorridor::FeatureLineCreation Property
Collapse All

Gets the default settings of feature line creation.

C#
public SettingsCmdFeatureLineCreation FeatureLineCreation;
Visual Basic
Public Property FeatureLineCreation() As SettingsCmdFeatureLineCreation
Links
SettingsCmdFeatureLinesFromCorridor Class, SettingsCmdFeatureLinesFromCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class
Collapse All

Default settings for the Feature Line Creation command.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation
C#
public class SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation
Inherits TreeOidWrapper
Links
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties, SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members, Class Hierarchy


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members
Collapse All

The following tables list the members exposed by SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation.

Public Properties
Public Property | Description
CreateDynamicLink | Gets the create dynamic link setting.
FeatureLineName | Gets whether to specify the name of the feature line.
HorizontalDeviation | Gets the horizontal deviation setting.
InclusionDistance | Gets the inclusion distance setting.
LayerSetting | Gets the layer setting.
SmoothTheFeatureLine | Gets the feature line smoothing setting.
UseFeatureLineStyle | Gets whether to use the feature line style.
WeedingDistance | Gets the weeding distance setting.
Links
Public Properties


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties
Collapse All

The properties of SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation are listed here.

Public Properties
Public Property | Description
CreateDynamicLink | Gets the create dynamic link setting.
FeatureLineName | Gets whether to specify the name of the feature line.
HorizontalDeviation | Gets the horizontal deviation setting.
InclusionDistance | Gets the inclusion distance setting.
LayerSetting | Gets the layer setting.
SmoothTheFeatureLine | Gets the feature line smoothing setting.
UseFeatureLineStyle | Gets whether to use the feature line style.
WeedingDistance | Gets the weeding distance setting.
Links
Public Properties


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::CreateDynamicLink Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::CreateDynamicLink Property
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::CreateDynamicLink Property
Collapse All

Gets the create dynamic link setting.

C#
public PropertyBoolean CreateDynamicLink;
Visual Basic
Public Property CreateDynamicLink() As PropertyBoolean
Links
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class, SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::FeatureLineName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::FeatureLineName Property
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::FeatureLineName Property
Collapse All

Gets whether to specify the name of the feature line.

C#
public PropertyBoolean FeatureLineName;
Visual Basic
Public Property FeatureLineName() As PropertyBoolean
Links
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class, SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::HorizontalDeviation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::HorizontalDeviation Property
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::HorizontalDeviation Property
Collapse All

Gets the horizontal deviation setting.

C#
public PropertyDouble HorizontalDeviation;
Visual Basic
Public Property HorizontalDeviation() As PropertyDouble
Links
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class, SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::InclusionDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::InclusionDistance Property
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::InclusionDistance Property
Collapse All

Gets the inclusion distance setting.

C#
public PropertyDouble InclusionDistance;
Visual Basic
Public Property InclusionDistance() As PropertyDouble
Links
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class, SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::LayerSetting Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::LayerSetting Property
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::LayerSetting Property
Collapse All

Gets the layer setting.

C#
public PropertyEnum<Autodesk::Civil::Land::FeatureLineLayerSettingType> LayerSetting;
Visual Basic
Public Property LayerSetting() As PropertyEnum<Autodesk::Civil::Land::FeatureLineLayerSettingType>
Links
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class, SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::SmoothTheFeatureLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::SmoothTheFeatureLine Property
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::SmoothTheFeatureLine Property
Collapse All

Gets the feature line smoothing setting.

C#
public PropertyBoolean SmoothTheFeatureLine;
Visual Basic
Public Property SmoothTheFeatureLine() As PropertyBoolean
Links
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class, SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::UseFeatureLineStyle Property
Collapse All

Gets whether to use the feature line style.

C#
public PropertyBoolean UseFeatureLineStyle;
Visual Basic
Public Property UseFeatureLineStyle() As PropertyBoolean
Links
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class, SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::WeedingDistance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::WeedingDistance Property
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::WeedingDistance Property
Collapse All

Gets the weeding distance setting.

C#
public PropertyDouble WeedingDistance;
Visual Basic
Public Property WeedingDistance() As PropertyDouble
Links
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class, SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdGenerateQuantitiesReport Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class
SettingsCmdGenerateQuantitiesReport Class
Collapse All

Settings for GenerateQuantitiesReport command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdGenerateQuantitiesReport
C#
public class SettingsCmdGenerateQuantitiesReport : SettingsQuantityTakeoff;
Visual Basic
Public Class SettingsCmdGenerateQuantitiesReport
Inherits SettingsQuantityTakeoff
Links
SettingsCmdGenerateQuantitiesReport Properties, SettingsCmdGenerateQuantitiesReport Members, Class Hierarchy


SettingsCmdGenerateQuantitiesReport Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Members
SettingsCmdGenerateQuantitiesReport Members
Collapse All

The following tables list the members exposed by SettingsCmdGenerateQuantitiesReport.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
DisplayXmlReport | specifies whether to display XML report.
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdGenerateQuantitiesReport Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Properties
SettingsCmdGenerateQuantitiesReport Properties
Collapse All

The properties of SettingsCmdGenerateQuantitiesReport are listed here.

Public Properties
Public Property | Description
DisplayXmlReport | specifies whether to display XML report.
Links
Public Properties


SettingsCmdGenerateQuantitiesReport::DisplayXmlReport Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Properties > SettingsCmdGenerateQuantitiesReport::DisplayXmlReport Property
SettingsCmdGenerateQuantitiesReport::DisplayXmlReport Property
Collapse All

specifies whether to display XML report.

C#
public PropertyBoolean DisplayXmlReport;
Visual Basic
Public Property DisplayXmlReport() As PropertyBoolean
Links
SettingsCmdGenerateQuantitiesReport Class, SettingsCmdGenerateQuantitiesReport Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class
SettingsCmdTakeOff Class
Collapse All

Settings for TakeOff command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdTakeOff
C#
public class SettingsCmdTakeOff : SettingsQuantityTakeoff;
Visual Basic
Public Class SettingsCmdTakeOff
Inherits SettingsQuantityTakeoff
Links
SettingsCmdTakeOff Properties, SettingsCmdTakeOff Members, Class Hierarchy


SettingsCmdTakeOff Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Members
SettingsCmdTakeOff Members
Collapse All

The following tables list the members exposed by SettingsCmdTakeOff.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ComputeTakeOffOption | Gets the default setting of take off computation for the command TakeOff.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdTakeOff Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Properties
SettingsCmdTakeOff Properties
Collapse All

The properties of SettingsCmdTakeOff are listed here.

Public Properties
Public Property | Description
ComputeTakeOffOption | Gets the default setting of take off computation for the command TakeOff.
Links
Public Properties


SettingsCmdTakeOff::ComputeTakeOffOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Properties > SettingsCmdTakeOff::ComputeTakeOffOption Property
SettingsCmdTakeOff::ComputeTakeOffOption Property
Collapse All

Gets the default setting of take off computation for the command TakeOff.

C#
public SettingsCmdComputeTakeOff ComputeTakeOffOption;
Visual Basic
Public Property ComputeTakeOffOption() As SettingsCmdComputeTakeOff
Links
SettingsCmdTakeOff Class, SettingsCmdTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class
Collapse All

Settings of take off computation for command TakeOff.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdTakeOff::SettingsCmdComputeTakeOff
C#
public class SettingsCmdTakeOff::SettingsCmdComputeTakeOff : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdTakeOff::SettingsCmdComputeTakeOff
Inherits TreeOidWrapper
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Class Hierarchy


SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members
Collapse All

The following tables list the members exposed by SettingsCmdTakeOff::SettingsCmdComputeTakeOff.

Public Properties
Public Property | Description
DefaultReportStyle | specifies the default style sheet which is used to format the take off report.
DrawingBasedReportTableFont | Specifies the text font used in drawing-based report table.
IncludeFormulasInReports | specifies whether to include the formulas of pay items in the quantity takeoff report remarks.
LengthComputeType | Specifies the length computation type in the quantity takeoff process.
LimitToAlignmentStation | specifies whether to limit the report extents to a specified alignment station range.
PipeLengthType | Specifies the pipe length type used in the quantity takeoff process.
ReportExtentsType | specifies the extents used when finding entities to participate in the quantity takeoff process.
ReportSelectedPayItemOnly | specifies whether to allow reports to be generated on a subset of pay items which are selected in master pay... more
ReportType | Specifies the report type for quantity takeoff process.
Links
Public Properties


SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties
Collapse All

The properties of SettingsCmdTakeOff::SettingsCmdComputeTakeOff are listed here.

Public Properties
Public Property | Description
DefaultReportStyle | specifies the default style sheet which is used to format the take off report.
DrawingBasedReportTableFont | Specifies the text font used in drawing-based report table.
IncludeFormulasInReports | specifies whether to include the formulas of pay items in the quantity takeoff report remarks.
LengthComputeType | Specifies the length computation type in the quantity takeoff process.
LimitToAlignmentStation | specifies whether to limit the report extents to a specified alignment station range.
PipeLengthType | Specifies the pipe length type used in the quantity takeoff process.
ReportExtentsType | specifies the extents used when finding entities to participate in the quantity takeoff process.
ReportSelectedPayItemOnly | specifies whether to allow reports to be generated on a subset of pay items which are selected in master pay... more
ReportType | Specifies the report type for quantity takeoff process.
Links
Public Properties


SettingsCmdTakeOff::SettingsCmdComputeTakeOff::DefaultReportStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties > SettingsCmdTakeOff::SettingsCmdComputeTakeOff::DefaultReportStyle Property
SettingsCmdTakeOff::SettingsCmdComputeTakeOff::DefaultReportStyle Property
Collapse All

specifies the default style sheet which is used to format the take off report.

C#
public PropertyString DefaultReportStyle;
Visual Basic
Public Property DefaultReportStyle() As PropertyString
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff::SettingsCmdComputeTakeOff::DrawingBasedReportTableFont Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties > SettingsCmdTakeOff::SettingsCmdComputeTakeOff::DrawingBasedReportTableFont Property
SettingsCmdTakeOff::SettingsCmdComputeTakeOff::DrawingBasedReportTableFont Property
Collapse All

Specifies the text font used in drawing-based report table.

C#
public PropertyString DrawingBasedReportTableFont;
Visual Basic
Public Property DrawingBasedReportTableFont() As PropertyString
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff::SettingsCmdComputeTakeOff::IncludeFormulasInReports Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties > SettingsCmdTakeOff::SettingsCmdComputeTakeOff::IncludeFormulasInReports Property
SettingsCmdTakeOff::SettingsCmdComputeTakeOff::IncludeFormulasInReports Property
Collapse All

specifies whether to include the formulas of pay items in the quantity takeoff report remarks.

C#
public PropertyBoolean IncludeFormulasInReports;
Visual Basic
Public Property IncludeFormulasInReports() As PropertyBoolean
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff::SettingsCmdComputeTakeOff::LengthComputeType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties > SettingsCmdTakeOff::SettingsCmdComputeTakeOff::LengthComputeType Property
SettingsCmdTakeOff::SettingsCmdComputeTakeOff::LengthComputeType Property
Collapse All

Specifies the length computation type in the quantity takeoff process.

C#
public PropertyEnum<Autodesk::Civil::Roadway::QuantityTakeoffLengthComputeType> LengthComputeType;
Visual Basic
Public Property LengthComputeType() As PropertyEnum<Autodesk::Civil::Roadway::QuantityTakeoffLengthComputeType>
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff::SettingsCmdComputeTakeOff::LimitToAlignmentStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties > SettingsCmdTakeOff::SettingsCmdComputeTakeOff::LimitToAlignmentStation Property
SettingsCmdTakeOff::SettingsCmdComputeTakeOff::LimitToAlignmentStation Property
Collapse All

specifies whether to limit the report extents to a specified alignment station range.

C#
public PropertyBoolean LimitToAlignmentStation;
Visual Basic
Public Property LimitToAlignmentStation() As PropertyBoolean
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff::SettingsCmdComputeTakeOff::PipeLengthType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties > SettingsCmdTakeOff::SettingsCmdComputeTakeOff::PipeLengthType Property
SettingsCmdTakeOff::SettingsCmdComputeTakeOff::PipeLengthType Property
Collapse All

Specifies the pipe length type used in the quantity takeoff process.

C#
public PropertyEnum<Autodesk::Civil::Roadway::QuantityTakeoffPipeLengthType> PipeLengthType;
Visual Basic
Public Property PipeLengthType() As PropertyEnum<Autodesk::Civil::Roadway::QuantityTakeoffPipeLengthType>
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportExtentsType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties > SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportExtentsType Property
SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportExtentsType Property
Collapse All

specifies the extents used when finding entities to participate in the quantity takeoff process.

C#
public PropertyEnum<Autodesk::Civil::Roadway::QuantityTakeoffReportExtentType> ReportExtentsType;
Visual Basic
Public Property ReportExtentsType() As PropertyEnum<Autodesk::Civil::Roadway::QuantityTakeoffReportExtentType>
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportSelectedPayItemOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties > SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportSelectedPayItemOnly Property
SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportSelectedPayItemOnly Property
Collapse All

specifies whether to allow reports to be generated on a subset of pay items which are selected in master pay item list.

C#
public PropertyBoolean ReportSelectedPayItemOnly;
Visual Basic
Public Property ReportSelectedPayItemOnly() As PropertyBoolean
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties > SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportType Property
SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportType Property
Collapse All

Specifies the report type for quantity takeoff process.

C#
public PropertyEnum<Autodesk::Civil::Roadway::QuantityTakeoffReportType> ReportType;
Visual Basic
Public Property ReportType() As PropertyEnum<Autodesk::Civil::Roadway::QuantityTakeoffReportType>
Links
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class, SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class
SettingsCmdViewEditCorridorSection Class
Collapse All

Settings for ViewEditCorridorSection command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection
C#
public class SettingsCmdViewEditCorridorSection : SettingsCorridor;
Visual Basic
Public Class SettingsCmdViewEditCorridorSection
Inherits SettingsCorridor
Links
SettingsCmdViewEditCorridorSection Properties, SettingsCmdViewEditCorridorSection Members, Class Hierarchy


SettingsCmdViewEditCorridorSection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Members
SettingsCmdViewEditCorridorSection Members
Collapse All

The following tables list the members exposed by SettingsCmdViewEditCorridorSection.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
GridSettings | Gets the default settings of grid settings.
GridTextSettings | Gets the default settings of grid text settings.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
ViewEditOptions | Gets the default settings of view/edit options.
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdViewEditCorridorSection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Properties
SettingsCmdViewEditCorridorSection Properties
Collapse All

The properties of SettingsCmdViewEditCorridorSection are listed here.

Public Properties
Public Property | Description
GridSettings | Gets the default settings of grid settings.
GridTextSettings | Gets the default settings of grid text settings.
ViewEditOptions | Gets the default settings of view/edit options.
Links
Public Properties


SettingsCmdViewEditCorridorSection::GridSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Properties > SettingsCmdViewEditCorridorSection::GridSettings Property
SettingsCmdViewEditCorridorSection::GridSettings Property
Collapse All

Gets the default settings of grid settings.

C#
public SettingsCmdGridSettings GridSettings;
Visual Basic
Public Property GridSettings() As SettingsCmdGridSettings
Links
SettingsCmdViewEditCorridorSection Class, SettingsCmdViewEditCorridorSection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::GridTextSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Properties > SettingsCmdViewEditCorridorSection::GridTextSettings Property
SettingsCmdViewEditCorridorSection::GridTextSettings Property
Collapse All

Gets the default settings of grid text settings.

C#
public SettingsCmdGridTextSettings GridTextSettings;
Visual Basic
Public Property GridTextSettings() As SettingsCmdGridTextSettings
Links
SettingsCmdViewEditCorridorSection Class, SettingsCmdViewEditCorridorSection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::ViewEditOptions Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Properties > SettingsCmdViewEditCorridorSection::ViewEditOptions Property
SettingsCmdViewEditCorridorSection::ViewEditOptions Property
Collapse All

Gets the default settings of view/edit options.

C#
public SettingsCmdViewEditOptions ViewEditOptions;
Visual Basic
Public Property ViewEditOptions() As SettingsCmdViewEditOptions
Links
SettingsCmdViewEditCorridorSection Class, SettingsCmdViewEditCorridorSection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class
Collapse All

Settings for the Grid Settings section of the ViewEditCorridorSection command.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings
C#
public class SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings
Inherits TreeOidWrapper
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties, SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members, Class Hierarchy


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members
Collapse All

The following tables list the members exposed by SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings.

Public Properties
Public Property | Description
CenterAxisColor | Gets the Center Axis Color setting.
DisplayCenterAxis | Gets the Display Center Axis setting.
DisplayHorizontalGrid | Gets the Display Horizontal Grid setting.
DisplayVerticalGrid | Gets the Display Vertical Grid setting.
GridColor | Gets the Grid Color setting.
HorizontalGridInterval | Gets the Horizontal Grid Interval setting.
VerticalGridInterval | Gets the Vertical Grid Interval setting.
Links
Public Properties


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties
Collapse All

The properties of SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings are listed here.

Public Properties
Public Property | Description
CenterAxisColor | Gets the Center Axis Color setting.
DisplayCenterAxis | Gets the Display Center Axis setting.
DisplayHorizontalGrid | Gets the Display Horizontal Grid setting.
DisplayVerticalGrid | Gets the Display Vertical Grid setting.
GridColor | Gets the Grid Color setting.
HorizontalGridInterval | Gets the Horizontal Grid Interval setting.
VerticalGridInterval | Gets the Vertical Grid Interval setting.
Links
Public Properties


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::CenterAxisColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::CenterAxisColor Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::CenterAxisColor Property
Collapse All

Gets the Center Axis Color setting.

C#
public PropertyColor CenterAxisColor;
Visual Basic
Public Property CenterAxisColor() As PropertyColor
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayCenterAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayCenterAxis Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayCenterAxis Property
Collapse All

Gets the Display Center Axis setting.

C#
public PropertyBoolean DisplayCenterAxis;
Visual Basic
Public Property DisplayCenterAxis() As PropertyBoolean
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayHorizontalGrid Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayHorizontalGrid Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayHorizontalGrid Property
Collapse All

Gets the Display Horizontal Grid setting.

C#
public PropertyBoolean DisplayHorizontalGrid;
Visual Basic
Public Property DisplayHorizontalGrid() As PropertyBoolean
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayVerticalGrid Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayVerticalGrid Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayVerticalGrid Property
Collapse All

Gets the Display Vertical Grid setting.

C#
public PropertyBoolean DisplayVerticalGrid;
Visual Basic
Public Property DisplayVerticalGrid() As PropertyBoolean
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::GridColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::GridColor Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::GridColor Property
Collapse All

Gets the Grid Color setting.

C#
public PropertyColor GridColor;
Visual Basic
Public Property GridColor() As PropertyColor
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::HorizontalGridInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::HorizontalGridInterval Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::HorizontalGridInterval Property
Collapse All

Gets the Horizontal Grid Interval setting.

C#
public PropertyDouble HorizontalGridInterval;
Visual Basic
Public Property HorizontalGridInterval() As PropertyDouble
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::VerticalGridInterval Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::VerticalGridInterval Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::VerticalGridInterval Property
Collapse All

Gets the Vertical Grid Interval setting.

C#
public PropertyDouble VerticalGridInterval;
Visual Basic
Public Property VerticalGridInterval() As PropertyDouble
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class
Collapse All

Settings for the Grid Text Settings section of the ViewEditCorridorSection command.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings
C#
public class SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings
Inherits TreeOidWrapper
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties, SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members, Class Hierarchy


SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members
Collapse All

The following tables list the members exposed by SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings.

Public Properties
Public Property | Description
AnnotateCenterAxis | Gets the Annotate Center Axis setting.
TextColor | Gets the Text Color setting.
TextHeightRelativeToScreen | Gets the Text Height Relative to Screen setting.
TextStyle | Gets the Text Style setting.
Links
Public Properties


SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties
Collapse All

The properties of SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings are listed here.

Public Properties
Public Property | Description
AnnotateCenterAxis | Gets the Annotate Center Axis setting.
TextColor | Gets the Text Color setting.
TextHeightRelativeToScreen | Gets the Text Height Relative to Screen setting.
TextStyle | Gets the Text Style setting.
Links
Public Properties


SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::AnnotateCenterAxis Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::AnnotateCenterAxis Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::AnnotateCenterAxis Property
Collapse All

Gets the Annotate Center Axis setting.

C#
public PropertyBoolean AnnotateCenterAxis;
Visual Basic
Public Property AnnotateCenterAxis() As PropertyBoolean
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextColor Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextColor Property
Collapse All

Gets the Text Color setting.

C#
public PropertyColor TextColor;
Visual Basic
Public Property TextColor() As PropertyColor
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextHeightRelativeToScreen Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextHeightRelativeToScreen Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextHeightRelativeToScreen Property
Collapse All

Gets the Text Height Relative to Screen setting.

C#
public PropertyDouble TextHeightRelativeToScreen;
Visual Basic
Public Property TextHeightRelativeToScreen() As PropertyDouble
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextStyle Property
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextStyle Property
Collapse All

Gets the Text Style setting.

C#
public PropertyString TextStyle;
Visual Basic
Public Property TextStyle() As PropertyString
Links
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class, SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class
Collapse All

Settings for the View/Edit Options section of the ViewEditCorridorSection command.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions
C#
public class SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions
Inherits TreeOidWrapper
Links
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties, SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members, Class Hierarchy


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members
Collapse All

The following tables list the members exposed by SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions.

Public Properties
Public Property | Description
BackClip | Gets the Back Clip setting.
DefaultViewScale | Gets the default view scale setting.
FrontClip | Gets the Front Clip setting.
RebuildOnEdit | Gets the Rebuild On Edit setting.
StationTrackerInMultipleViewports | Gets the Station Tracker in Multiple Viewports setting.
TurnOffUnassociatedLayers | Gets the Turn Off Unassociated Layers setting.
Links
Public Properties


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties
Collapse All

The properties of SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions are listed here.

Public Properties
Public Property | Description
BackClip | Gets the Back Clip setting.
DefaultViewScale | Gets the default view scale setting.
FrontClip | Gets the Front Clip setting.
RebuildOnEdit | Gets the Rebuild On Edit setting.
StationTrackerInMultipleViewports | Gets the Station Tracker in Multiple Viewports setting.
TurnOffUnassociatedLayers | Gets the Turn Off Unassociated Layers setting.
Links
Public Properties


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::BackClip Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::BackClip Property
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::BackClip Property
Collapse All

Gets the Back Clip setting.

C#
public PropertyDouble BackClip;
Visual Basic
Public Property BackClip() As PropertyDouble
Links
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class, SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::DefaultViewScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::DefaultViewScale Property
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::DefaultViewScale Property
Collapse All

Gets the default view scale setting.

C#
public PropertyDouble DefaultViewScale;
Visual Basic
Public Property DefaultViewScale() As PropertyDouble
Links
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class, SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::FrontClip Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::FrontClip Property
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::FrontClip Property
Collapse All

Gets the Front Clip setting.

C#
public PropertyDouble FrontClip;
Visual Basic
Public Property FrontClip() As PropertyDouble
Links
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class, SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::RebuildOnEdit Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::RebuildOnEdit Property
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::RebuildOnEdit Property
Collapse All

Gets the Rebuild On Edit setting.

C#
public PropertyBoolean RebuildOnEdit;
Visual Basic
Public Property RebuildOnEdit() As PropertyBoolean
Links
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class, SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::StationTrackerInMultipleViewports Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::StationTrackerInMultipleViewports Property
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::StationTrackerInMultipleViewports Property
Collapse All

Gets the Station Tracker in Multiple Viewports setting.

C#
public PropertyBoolean StationTrackerInMultipleViewports;
Visual Basic
Public Property StationTrackerInMultipleViewports() As PropertyBoolean
Links
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class, SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::TurnOffUnassociatedLayers Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::TurnOffUnassociatedLayers Property
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::TurnOffUnassociatedLayers Property
Collapse All

Gets the Turn Off Unassociated Layers setting.

C#
public PropertyBoolean TurnOffUnassociatedLayers;
Visual Basic
Public Property TurnOffUnassociatedLayers() As PropertyBoolean
Links
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class, SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class
SettingsCorridor Class
Collapse All

Controls ambient settings for corridors.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCorridorExtractSurfaces
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreatePointsFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreatePolylineFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateProfileFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSimpleCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdFeatureLinesFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection
C#
public class SettingsCorridor : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsCorridor
Inherits Autodesk::Civil::Settings::SettingsAmbient
Example
// Get the Corridor ambient settings root object
CivilDocument doc = CivilApplication.ActiveDocument;
Editor ed = Application.DocumentManager.MdiActiveDocument.Editor;
SettingsCorridor oCorridorSettings = doc.Settings.GetSettings<SettingsCorridor>() as SettingsCorridor;

// Set the template so new corridors are named "Corridor"
// followed by a unique number followed by the name of the
// corridor's first assembly in parenthesis.
oCorridorSettings.NameFormat.Corridor.Value = "Corridor <[Next Counter(CP)]>(<[Corridor First Assembly(CP)]>)";
Links
SettingsCorridor Properties, SettingsCorridor Members, Class Hierarchy


SettingsCorridor Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Members
SettingsCorridor Members
Collapse All

The following tables list the members exposed by SettingsCorridor.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCorridor Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Properties
SettingsCorridor Properties
Collapse All

The properties of SettingsCorridor are listed here.

Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Styles | Settings to establish the default styles assigned to corridor components.
Links
Public Properties


SettingsCorridor::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Properties > SettingsCorridor::NameFormat Property
SettingsCorridor::NameFormat Property
Collapse All

settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from feature lines.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsCorridor Class, SettingsCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::RegionHighlightGraphics Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Properties > SettingsCorridor::RegionHighlightGraphics Property
SettingsCorridor::RegionHighlightGraphics Property
Collapse All

Settings corridor highlight region graphics.

C#
public SettingsRegionHighlightGraphics RegionHighlightGraphics;
Visual Basic
Public Property RegionHighlightGraphics() As SettingsRegionHighlightGraphics
Links
SettingsCorridor Class, SettingsCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Properties > SettingsCorridor::Styles Property
SettingsCorridor::Styles Property
Collapse All

Settings to establish the default styles assigned to corridor components.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsCorridor Class, SettingsCorridor Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class
SettingsCorridor::SettingsNameFormat Class
Collapse All

Settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from feature lines.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCorridor::SettingsNameFormat
C#
public class SettingsCorridor::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsCorridor::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsCorridor::SettingsNameFormat Properties, SettingsCorridor::SettingsNameFormat Members, Class Hierarchy


SettingsCorridor::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Members
SettingsCorridor::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsCorridor::SettingsNameFormat.

Public Properties
Public Property | Description
AlignmentFromFeatureLine | AlignmentFromFeatureLine Style for corridor settings.
Corridor | CorridorName Style for corridor settings.
CorridorBaseline | CorridorBaseline Style for corridor settings.
CorridorRegion | CorridorRegion Style for corridor settings.
CorridorSurface | CorridorSurface Style for corridor settings.
FeatureLine | FeatureLine Style for corridor settings.
ProfileFromFeatureLine | ProfileFromFeatureLine Style for corridor settings.
Links
Public Properties


SettingsCorridor::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties
SettingsCorridor::SettingsNameFormat Properties
Collapse All

The properties of SettingsCorridor::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
AlignmentFromFeatureLine | AlignmentFromFeatureLine Style for corridor settings.
Corridor | CorridorName Style for corridor settings.
CorridorBaseline | CorridorBaseline Style for corridor settings.
CorridorRegion | CorridorRegion Style for corridor settings.
CorridorSurface | CorridorSurface Style for corridor settings.
FeatureLine | FeatureLine Style for corridor settings.
ProfileFromFeatureLine | ProfileFromFeatureLine Style for corridor settings.
Links
Public Properties


SettingsCorridor::SettingsNameFormat::AlignmentFromFeatureLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties > SettingsCorridor::SettingsNameFormat::AlignmentFromFeatureLine Property
SettingsCorridor::SettingsNameFormat::AlignmentFromFeatureLine Property
Collapse All

AlignmentFromFeatureLine Style for corridor settings.

C#
public PropertyString AlignmentFromFeatureLine;
Visual Basic
Public Property AlignmentFromFeatureLine() As PropertyString
Links
SettingsCorridor::SettingsNameFormat Class, SettingsCorridor::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsNameFormat::Corridor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties > SettingsCorridor::SettingsNameFormat::Corridor Property
SettingsCorridor::SettingsNameFormat::Corridor Property
Collapse All

CorridorName Style for corridor settings.

C#
public PropertyString Corridor;
Visual Basic
Public Property Corridor() As PropertyString
Links
SettingsCorridor::SettingsNameFormat Class, SettingsCorridor::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsNameFormat::CorridorBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties > SettingsCorridor::SettingsNameFormat::CorridorBaseline Property
SettingsCorridor::SettingsNameFormat::CorridorBaseline Property
Collapse All

CorridorBaseline Style for corridor settings.

C#
public PropertyString CorridorBaseline;
Visual Basic
Public Property CorridorBaseline() As PropertyString
Links
SettingsCorridor::SettingsNameFormat Class, SettingsCorridor::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsNameFormat::CorridorRegion Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties > SettingsCorridor::SettingsNameFormat::CorridorRegion Property
SettingsCorridor::SettingsNameFormat::CorridorRegion Property
Collapse All

CorridorRegion Style for corridor settings.

C#
public PropertyString CorridorRegion;
Visual Basic
Public Property CorridorRegion() As PropertyString
Links
SettingsCorridor::SettingsNameFormat Class, SettingsCorridor::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsNameFormat::CorridorSurface Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties > SettingsCorridor::SettingsNameFormat::CorridorSurface Property
SettingsCorridor::SettingsNameFormat::CorridorSurface Property
Collapse All

CorridorSurface Style for corridor settings.

C#
public PropertyString CorridorSurface;
Visual Basic
Public Property CorridorSurface() As PropertyString
Links
SettingsCorridor::SettingsNameFormat Class, SettingsCorridor::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsNameFormat::FeatureLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties > SettingsCorridor::SettingsNameFormat::FeatureLine Property
SettingsCorridor::SettingsNameFormat::FeatureLine Property
Collapse All

FeatureLine Style for corridor settings.

C#
public PropertyString FeatureLine;
Visual Basic
Public Property FeatureLine() As PropertyString
Links
SettingsCorridor::SettingsNameFormat Class, SettingsCorridor::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsNameFormat::ProfileFromFeatureLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties > SettingsCorridor::SettingsNameFormat::ProfileFromFeatureLine Property
SettingsCorridor::SettingsNameFormat::ProfileFromFeatureLine Property
Collapse All

ProfileFromFeatureLine Style for corridor settings.

C#
public PropertyString ProfileFromFeatureLine;
Visual Basic
Public Property ProfileFromFeatureLine() As PropertyString
Links
SettingsCorridor::SettingsNameFormat Class, SettingsCorridor::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class
SettingsCorridor::SettingsRegionHighlightGraphics Class
Collapse All

Settings for Corridor styles.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCorridor::SettingsRegionHighlightGraphics
C#
public class SettingsCorridor::SettingsRegionHighlightGraphics : TreeOidWrapper;
Visual Basic
Public Class SettingsCorridor::SettingsRegionHighlightGraphics
Inherits TreeOidWrapper
Links
SettingsCorridor::SettingsRegionHighlightGraphics Properties, SettingsCorridor::SettingsRegionHighlightGraphics Members, Class Hierarchy


SettingsCorridor::SettingsRegionHighlightGraphics Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Members
SettingsCorridor::SettingsRegionHighlightGraphics Members
Collapse All

The following tables list the members exposed by SettingsCorridor::SettingsRegionHighlightGraphics.

Public Properties
Public Property | Description
BaselineColor | BaselineColor highlight graphics for corridor settings.
BaselineLineweight | BaselineLineweight highlight graphics for corridor settings.
HighlightBaseline | HighlightBaseline highlight graphics for corridor settings.
HighlightHorizontalTargets | HighlightHorizontalTargets highlight graphics for corridor settings.
HighlightInteriorAssemblies | HighlightInteriorAssemblies highlight graphics for corridor settings.
HighlightRegionBoundary | HighlightRegionBoundary highlight graphics for corridor settings.
HorizontalTargetsColor | HorizontalTargetsColor highlight graphics for corridor settings.
HorizontalTargetsLineweight | HorizontalTargetsLineweight highlight graphics for corridor settings.
InteriorAssembliesColor | InteriorAssembliesColor highlight graphics for corridor settings.
InteriorAssembliesLineweight | InteriorAssembliesLineweight highlight graphics for corridor settings.
RegionBoundaryColor | RegionBoundaryColor highlight graphics for corridor settings.
RegionBoundaryLineweight | RegionBoundaryLineweight highlight graphics for corridor settings.
Links
Public Properties


SettingsCorridor::SettingsRegionHighlightGraphics Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties
SettingsCorridor::SettingsRegionHighlightGraphics Properties
Collapse All

The properties of SettingsCorridor::SettingsRegionHighlightGraphics are listed here.

Public Properties
Public Property | Description
BaselineColor | BaselineColor highlight graphics for corridor settings.
BaselineLineweight | BaselineLineweight highlight graphics for corridor settings.
HighlightBaseline | HighlightBaseline highlight graphics for corridor settings.
HighlightHorizontalTargets | HighlightHorizontalTargets highlight graphics for corridor settings.
HighlightInteriorAssemblies | HighlightInteriorAssemblies highlight graphics for corridor settings.
HighlightRegionBoundary | HighlightRegionBoundary highlight graphics for corridor settings.
HorizontalTargetsColor | HorizontalTargetsColor highlight graphics for corridor settings.
HorizontalTargetsLineweight | HorizontalTargetsLineweight highlight graphics for corridor settings.
InteriorAssembliesColor | InteriorAssembliesColor highlight graphics for corridor settings.
InteriorAssembliesLineweight | InteriorAssembliesLineweight highlight graphics for corridor settings.
RegionBoundaryColor | RegionBoundaryColor highlight graphics for corridor settings.
RegionBoundaryLineweight | RegionBoundaryLineweight highlight graphics for corridor settings.
Links
Public Properties


SettingsCorridor::SettingsRegionHighlightGraphics::BaselineColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::BaselineColor Property
SettingsCorridor::SettingsRegionHighlightGraphics::BaselineColor Property
Collapse All

BaselineColor highlight graphics for corridor settings.

C#
public PropertyColor BaselineColor;
Visual Basic
Public Property BaselineColor() As PropertyColor
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::BaselineLineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::BaselineLineweight Property
SettingsCorridor::SettingsRegionHighlightGraphics::BaselineLineweight Property
Collapse All

BaselineLineweight highlight graphics for corridor settings.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> BaselineLineweight;
Visual Basic
Public Property BaselineLineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::HighlightBaseline Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::HighlightBaseline Property
SettingsCorridor::SettingsRegionHighlightGraphics::HighlightBaseline Property
Collapse All

HighlightBaseline highlight graphics for corridor settings.

C#
public PropertyBoolean HighlightBaseline;
Visual Basic
Public Property HighlightBaseline() As PropertyBoolean
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::HighlightHorizontalTargets Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::HighlightHorizontalTargets Property
SettingsCorridor::SettingsRegionHighlightGraphics::HighlightHorizontalTargets Property
Collapse All

HighlightHorizontalTargets highlight graphics for corridor settings.

C#
public PropertyBoolean HighlightHorizontalTargets;
Visual Basic
Public Property HighlightHorizontalTargets() As PropertyBoolean
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::HighlightInteriorAssemblies Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::HighlightInteriorAssemblies Property
SettingsCorridor::SettingsRegionHighlightGraphics::HighlightInteriorAssemblies Property
Collapse All

HighlightInteriorAssemblies highlight graphics for corridor settings.

C#
public PropertyBoolean HighlightInteriorAssemblies;
Visual Basic
Public Property HighlightInteriorAssemblies() As PropertyBoolean
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::HighlightRegionBoundary Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::HighlightRegionBoundary Property
SettingsCorridor::SettingsRegionHighlightGraphics::HighlightRegionBoundary Property
Collapse All

HighlightRegionBoundary highlight graphics for corridor settings.

C#
public PropertyBoolean HighlightRegionBoundary;
Visual Basic
Public Property HighlightRegionBoundary() As PropertyBoolean
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::HorizontalTargetsColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::HorizontalTargetsColor Property
SettingsCorridor::SettingsRegionHighlightGraphics::HorizontalTargetsColor Property
Collapse All

HorizontalTargetsColor highlight graphics for corridor settings.

C#
public PropertyColor HorizontalTargetsColor;
Visual Basic
Public Property HorizontalTargetsColor() As PropertyColor
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::HorizontalTargetsLineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::HorizontalTargetsLineweight Property
SettingsCorridor::SettingsRegionHighlightGraphics::HorizontalTargetsLineweight Property
Collapse All

HorizontalTargetsLineweight highlight graphics for corridor settings.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> HorizontalTargetsLineweight;
Visual Basic
Public Property HorizontalTargetsLineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::InteriorAssembliesColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::InteriorAssembliesColor Property
SettingsCorridor::SettingsRegionHighlightGraphics::InteriorAssembliesColor Property
Collapse All

InteriorAssembliesColor highlight graphics for corridor settings.

C#
public PropertyColor InteriorAssembliesColor;
Visual Basic
Public Property InteriorAssembliesColor() As PropertyColor
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::InteriorAssembliesLineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::InteriorAssembliesLineweight Property
SettingsCorridor::SettingsRegionHighlightGraphics::InteriorAssembliesLineweight Property
Collapse All

InteriorAssembliesLineweight highlight graphics for corridor settings.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> InteriorAssembliesLineweight;
Visual Basic
Public Property InteriorAssembliesLineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::RegionBoundaryColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::RegionBoundaryColor Property
SettingsCorridor::SettingsRegionHighlightGraphics::RegionBoundaryColor Property
Collapse All

RegionBoundaryColor highlight graphics for corridor settings.

C#
public PropertyColor RegionBoundaryColor;
Visual Basic
Public Property RegionBoundaryColor() As PropertyColor
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsRegionHighlightGraphics::RegionBoundaryLineweight Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties > SettingsCorridor::SettingsRegionHighlightGraphics::RegionBoundaryLineweight Property
SettingsCorridor::SettingsRegionHighlightGraphics::RegionBoundaryLineweight Property
Collapse All

RegionBoundaryLineweight highlight graphics for corridor settings.

C#
public PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight> RegionBoundaryLineweight;
Visual Basic
Public Property RegionBoundaryLineweight() As PropertyEnum<Autodesk::AutoCAD::DatabaseServices::LineWeight>
Links
SettingsCorridor::SettingsRegionHighlightGraphics Class, SettingsCorridor::SettingsRegionHighlightGraphics Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class
SettingsCorridor::SettingsStyles Class
Collapse All

Settings to establish the default styles assigned to corridor components.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCorridor::SettingsStyles
C#
public class SettingsCorridor::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsCorridor::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsCorridor::SettingsStyles Properties, SettingsCorridor::SettingsStyles Members, Class Hierarchy


SettingsCorridor::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Members
SettingsCorridor::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsCorridor::SettingsStyles.

Public Properties
Public Property | Description
Alignment | Specifies the default style for an alignment created from the corridor.
AlignmentLabelSet | Specifies the default style for the alignment label sets created from corridors.
Corridor | Specifies the default style for the corridor.
CorridorCodeSet | Specifies the default code set style for corridors.
CorridorSurface | Specifies the default corridor surface style.
FeatureLine | Specifies the default feature line style for the corridor.
Profile | Specifies the default style for a profile created from the corridor.
ProfileLabelSet | Specifies the default profile label set style.
RenderMaterial | Specifies the default render material style for the corridor.
SlopePattern | Specifies the default style for the slope patterns added to corridors.
Links
Public Properties


SettingsCorridor::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties
SettingsCorridor::SettingsStyles Properties
Collapse All

The properties of SettingsCorridor::SettingsStyles are listed here.

Public Properties
Public Property | Description
Alignment | Specifies the default style for an alignment created from the corridor.
AlignmentLabelSet | Specifies the default style for the alignment label sets created from corridors.
Corridor | Specifies the default style for the corridor.
CorridorCodeSet | Specifies the default code set style for corridors.
CorridorSurface | Specifies the default corridor surface style.
FeatureLine | Specifies the default feature line style for the corridor.
Profile | Specifies the default style for a profile created from the corridor.
ProfileLabelSet | Specifies the default profile label set style.
RenderMaterial | Specifies the default render material style for the corridor.
SlopePattern | Specifies the default style for the slope patterns added to corridors.
Links
Public Properties


SettingsCorridor::SettingsStyles::Alignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::Alignment Property
SettingsCorridor::SettingsStyles::Alignment Property
Collapse All

Specifies the default style for an alignment created from the corridor.

C#
public PropertyString Alignment;
Visual Basic
Public Property Alignment() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles::AlignmentLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::AlignmentLabelSet Property
SettingsCorridor::SettingsStyles::AlignmentLabelSet Property
Collapse All

Specifies the default style for the alignment label sets created from corridors.

C#
public PropertyString AlignmentLabelSet;
Visual Basic
Public Property AlignmentLabelSet() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles::Corridor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::Corridor Property
SettingsCorridor::SettingsStyles::Corridor Property
Collapse All

Specifies the default style for the corridor.

C#
public PropertyString Corridor;
Visual Basic
Public Property Corridor() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles::CorridorCodeSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::CorridorCodeSet Property
SettingsCorridor::SettingsStyles::CorridorCodeSet Property
Collapse All

Specifies the default code set style for corridors.

C#
public PropertyString CorridorCodeSet;
Visual Basic
Public Property CorridorCodeSet() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles::CorridorSurface Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::CorridorSurface Property
SettingsCorridor::SettingsStyles::CorridorSurface Property
Collapse All

Specifies the default corridor surface style.

C#
public PropertyString CorridorSurface;
Visual Basic
Public Property CorridorSurface() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles::FeatureLine Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::FeatureLine Property
SettingsCorridor::SettingsStyles::FeatureLine Property
Collapse All

Specifies the default feature line style for the corridor.

C#
public PropertyString FeatureLine;
Visual Basic
Public Property FeatureLine() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles::Profile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::Profile Property
SettingsCorridor::SettingsStyles::Profile Property
Collapse All

Specifies the default style for a profile created from the corridor.

C#
public PropertyString Profile;
Visual Basic
Public Property Profile() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles::ProfileLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::ProfileLabelSet Property
SettingsCorridor::SettingsStyles::ProfileLabelSet Property
Collapse All

Specifies the default profile label set style.

C#
public PropertyString ProfileLabelSet;
Visual Basic
Public Property ProfileLabelSet() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles::RenderMaterial Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::RenderMaterial Property
SettingsCorridor::SettingsStyles::RenderMaterial Property
Collapse All

Specifies the default render material style for the corridor.

C#
public PropertyString RenderMaterial;
Visual Basic
Public Property RenderMaterial() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsCorridor::SettingsStyles::SlopePattern Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties > SettingsCorridor::SettingsStyles::SlopePattern Property
SettingsCorridor::SettingsStyles::SlopePattern Property
Collapse All

Specifies the default style for the slope patterns added to corridors.

C#
public PropertyString SlopePattern;
Visual Basic
Public Property SlopePattern() As PropertyString
Links
SettingsCorridor::SettingsStyles Class, SettingsCorridor::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class
SettingsIntersection Class
Collapse All

Settings for Intersection.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsIntersection
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddIntersectionLabel
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection
C#
public class SettingsIntersection : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsIntersection
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsIntersection Properties, SettingsIntersection Members, Class Hierarchy


SettingsIntersection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Members
SettingsIntersection Members
Collapse All

The following tables list the members exposed by SettingsIntersection.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsIntersection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Properties
SettingsIntersection Properties
Collapse All

The properties of SettingsIntersection are listed here.

Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Styles | Settings to establish the default styles assigned to corridor components.
Links
Public Properties


SettingsIntersection::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Properties > SettingsIntersection::NameFormat Property
SettingsIntersection::NameFormat Property
Collapse All

settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from feature lines.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsIntersection Class, SettingsIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Properties > SettingsIntersection::Styles Property
SettingsIntersection::Styles Property
Collapse All

Settings to establish the default styles assigned to corridor components.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsIntersection Class, SettingsIntersection Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class
SettingsIntersection::SettingsNameFormat Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsIntersection::SettingsNameFormat
C#
public class SettingsIntersection::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsIntersection::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsIntersection::SettingsNameFormat Properties, SettingsIntersection::SettingsNameFormat Members, Class Hierarchy


SettingsIntersection::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Members
SettingsIntersection::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsIntersection::SettingsNameFormat.

Public Properties
Public Property | Description
CorridorRegion | Settings CorridorRegion default name format.
CurbReturnAlignment | Settings CurbReturnAlignment default name format.
CurbReturnProfile | Settings CurbReturnProfile default name format.
Intersection | Settings Intersection default name format.
IntersectionQuadrant | Settings IntersectionQuadrant default name format.
OffsetAlignment | Settings OffsetAlignment default name format.
OffsetProfile | Settings OffsetProfile default name format.
Links
Public Properties


SettingsIntersection::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties
SettingsIntersection::SettingsNameFormat Properties
Collapse All

The properties of SettingsIntersection::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
CorridorRegion | Settings CorridorRegion default name format.
CurbReturnAlignment | Settings CurbReturnAlignment default name format.
CurbReturnProfile | Settings CurbReturnProfile default name format.
Intersection | Settings Intersection default name format.
IntersectionQuadrant | Settings IntersectionQuadrant default name format.
OffsetAlignment | Settings OffsetAlignment default name format.
OffsetProfile | Settings OffsetProfile default name format.
Links
Public Properties


SettingsIntersection::SettingsNameFormat::CorridorRegion Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties > SettingsIntersection::SettingsNameFormat::CorridorRegion Property
SettingsIntersection::SettingsNameFormat::CorridorRegion Property
Collapse All

Settings CorridorRegion default name format.

C#
public PropertyString CorridorRegion;
Visual Basic
Public Property CorridorRegion() As PropertyString
Links
SettingsIntersection::SettingsNameFormat Class, SettingsIntersection::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsNameFormat::CurbReturnAlignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties > SettingsIntersection::SettingsNameFormat::CurbReturnAlignment Property
SettingsIntersection::SettingsNameFormat::CurbReturnAlignment Property
Collapse All

Settings CurbReturnAlignment default name format.

C#
public PropertyString CurbReturnAlignment;
Visual Basic
Public Property CurbReturnAlignment() As PropertyString
Links
SettingsIntersection::SettingsNameFormat Class, SettingsIntersection::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsNameFormat::CurbReturnProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties > SettingsIntersection::SettingsNameFormat::CurbReturnProfile Property
SettingsIntersection::SettingsNameFormat::CurbReturnProfile Property
Collapse All

Settings CurbReturnProfile default name format.

C#
public PropertyString CurbReturnProfile;
Visual Basic
Public Property CurbReturnProfile() As PropertyString
Links
SettingsIntersection::SettingsNameFormat Class, SettingsIntersection::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsNameFormat::Intersection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties > SettingsIntersection::SettingsNameFormat::Intersection Property
SettingsIntersection::SettingsNameFormat::Intersection Property
Collapse All

Settings Intersection default name format.

C#
public PropertyString Intersection;
Visual Basic
Public Property Intersection() As PropertyString
Links
SettingsIntersection::SettingsNameFormat Class, SettingsIntersection::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsNameFormat::IntersectionQuadrant Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties > SettingsIntersection::SettingsNameFormat::IntersectionQuadrant Property
SettingsIntersection::SettingsNameFormat::IntersectionQuadrant Property
Collapse All

Settings IntersectionQuadrant default name format.

C#
public PropertyString IntersectionQuadrant;
Visual Basic
Public Property IntersectionQuadrant() As PropertyString
Links
SettingsIntersection::SettingsNameFormat Class, SettingsIntersection::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsNameFormat::OffsetAlignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties > SettingsIntersection::SettingsNameFormat::OffsetAlignment Property
SettingsIntersection::SettingsNameFormat::OffsetAlignment Property
Collapse All

Settings OffsetAlignment default name format.

C#
public PropertyString OffsetAlignment;
Visual Basic
Public Property OffsetAlignment() As PropertyString
Links
SettingsIntersection::SettingsNameFormat Class, SettingsIntersection::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsNameFormat::OffsetProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties > SettingsIntersection::SettingsNameFormat::OffsetProfile Property
SettingsIntersection::SettingsNameFormat::OffsetProfile Property
Collapse All

Settings OffsetProfile default name format.

C#
public PropertyString OffsetProfile;
Visual Basic
Public Property OffsetProfile() As PropertyString
Links
SettingsIntersection::SettingsNameFormat Class, SettingsIntersection::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class
SettingsIntersection::SettingsStyles Class
Collapse All

Settings to establish the default styles assigned to assembly components.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsIntersection::SettingsStyles
C#
public class SettingsIntersection::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsIntersection::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsIntersection::SettingsStyles Properties, SettingsIntersection::SettingsStyles Members, Class Hierarchy


SettingsIntersection::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Members
SettingsIntersection::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsIntersection::SettingsStyles.

Public Properties
Public Property | Description
CurbReturnAlignment | Settings of CurbReturnAlignment style.
CurbReturnAlignmentLabelSet | Settings of CurbReturnAlignmentLabelSet style.
CurbReturnProfile | Settings of CurbReturnProfile style.
CurbReturnProfileLabelSet | Settings of CurbReturnProfileLabelSet style.
Intersection | Settings of Intersection style.
IntersectionLabel | Settings of IntersectionLabel style.
OffsetAlignment | Settings of OffsetAlignment style.
OffsetAlignmentLabelSet | Settings of OffsetAlignmentLabelSet style.
OffsetProfile | Settings of OffsetProfile style.
OffsetProfileLabelSet | Settings of OffsetProfileLabelSet style.
Links
Public Properties


SettingsIntersection::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties
SettingsIntersection::SettingsStyles Properties
Collapse All

The properties of SettingsIntersection::SettingsStyles are listed here.

Public Properties
Public Property | Description
CurbReturnAlignment | Settings of CurbReturnAlignment style.
CurbReturnAlignmentLabelSet | Settings of CurbReturnAlignmentLabelSet style.
CurbReturnProfile | Settings of CurbReturnProfile style.
CurbReturnProfileLabelSet | Settings of CurbReturnProfileLabelSet style.
Intersection | Settings of Intersection style.
IntersectionLabel | Settings of IntersectionLabel style.
OffsetAlignment | Settings of OffsetAlignment style.
OffsetAlignmentLabelSet | Settings of OffsetAlignmentLabelSet style.
OffsetProfile | Settings of OffsetProfile style.
OffsetProfileLabelSet | Settings of OffsetProfileLabelSet style.
Links
Public Properties


SettingsIntersection::SettingsStyles::CurbReturnAlignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::CurbReturnAlignment Property
SettingsIntersection::SettingsStyles::CurbReturnAlignment Property
Collapse All

Settings of CurbReturnAlignment style.

C#
public PropertyString CurbReturnAlignment;
Visual Basic
Public Property CurbReturnAlignment() As PropertyString
Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles::CurbReturnAlignmentLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::CurbReturnAlignmentLabelSet Property
SettingsIntersection::SettingsStyles::CurbReturnAlignmentLabelSet Property
Collapse All

Settings of CurbReturnAlignmentLabelSet style.

C#
public PropertyString CurbReturnAlignmentLabelSet;
Visual Basic
Public Property CurbReturnAlignmentLabelSet() As PropertyString
Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles::CurbReturnProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::CurbReturnProfile Property
SettingsIntersection::SettingsStyles::CurbReturnProfile Property
Collapse All

Settings of CurbReturnProfile style.

C#
public PropertyString CurbReturnProfile;
Visual Basic
Public Property CurbReturnProfile() As PropertyString
Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles::CurbReturnProfileLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::CurbReturnProfileLabelSet Property
SettingsIntersection::SettingsStyles::CurbReturnProfileLabelSet Property deprecated
Collapse All

Settings of CurbReturnProfileLabelSet style.

C#
public PropertyString CurbReturnProfileLabelSet;
Visual Basic
Public Property CurbReturnProfileLabelSet() As PropertyString
Notes

Deprecated: Functionality has been removed

Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles::Intersection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::Intersection Property
SettingsIntersection::SettingsStyles::Intersection Property
Collapse All

Settings of Intersection style.

C#
public PropertyString Intersection;
Visual Basic
Public Property Intersection() As PropertyString
Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles::IntersectionLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::IntersectionLabel Property
SettingsIntersection::SettingsStyles::IntersectionLabel Property
Collapse All

Settings of IntersectionLabel style.

C#
public PropertyString IntersectionLabel;
Visual Basic
Public Property IntersectionLabel() As PropertyString
Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles::OffsetAlignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::OffsetAlignment Property
SettingsIntersection::SettingsStyles::OffsetAlignment Property
Collapse All

Settings of OffsetAlignment style.

C#
public PropertyString OffsetAlignment;
Visual Basic
Public Property OffsetAlignment() As PropertyString
Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles::OffsetAlignmentLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::OffsetAlignmentLabelSet Property
SettingsIntersection::SettingsStyles::OffsetAlignmentLabelSet Property
Collapse All

Settings of OffsetAlignmentLabelSet style.

C#
public PropertyString OffsetAlignmentLabelSet;
Visual Basic
Public Property OffsetAlignmentLabelSet() As PropertyString
Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles::OffsetProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::OffsetProfile Property
SettingsIntersection::SettingsStyles::OffsetProfile Property
Collapse All

Settings of OffsetProfile style.

C#
public PropertyString OffsetProfile;
Visual Basic
Public Property OffsetProfile() As PropertyString
Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsIntersection::SettingsStyles::OffsetProfileLabelSet Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties > SettingsIntersection::SettingsStyles::OffsetProfileLabelSet Property
SettingsIntersection::SettingsStyles::OffsetProfileLabelSet Property deprecated
Collapse All

Settings of OffsetProfileLabelSet style.

C#
public PropertyString OffsetProfileLabelSet;
Visual Basic
Public Property OffsetProfileLabelSet() As PropertyString
Notes

Deprecated: Functionality has been removed.

Links
SettingsIntersection::SettingsStyles Class, SettingsIntersection::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsQuantityTakeoff Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class
SettingsQuantityTakeoff Class
Collapse All

Settings for QuantityTakeoff.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddMaterialVolumeTable
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddTotalVolumeTable
        Autodesk::Civil::Roadway::Settings::SettingsCmdAssignPayItemToArea
        Autodesk::Civil::Roadway::Settings::SettingsCmdComputeMaterials
        Autodesk::Civil::Roadway::Settings::SettingsCmdGenerateQuantitiesReport
        Autodesk::Civil::Roadway::Settings::SettingsCmdTakeOff
C#
public class SettingsQuantityTakeoff : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsQuantityTakeoff
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsQuantityTakeoff Properties, SettingsQuantityTakeoff Members, Class Hierarchy


SettingsQuantityTakeoff Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Members
SettingsQuantityTakeoff Members
Collapse All

The following tables list the members exposed by SettingsQuantityTakeoff.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsQuantityTakeoff Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Properties
SettingsQuantityTakeoff Properties
Collapse All

The properties of SettingsQuantityTakeoff are listed here.

Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
Links
Public Properties


SettingsQuantityTakeoff::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Properties > SettingsQuantityTakeoff::NameFormat Property
SettingsQuantityTakeoff::NameFormat Property
Collapse All

settings to specify the default name formats for QuantityTakeoff.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsQuantityTakeoff Class, SettingsQuantityTakeoff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsQuantityTakeoff::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Properties > SettingsQuantityTakeoff::Styles Property
SettingsQuantityTakeoff::Styles Property
Collapse All

Settings to establish the default styles assigned to QuantityTakeoff components.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsQuantityTakeoff Class, SettingsQuantityTakeoff Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsQuantityTakeoff::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class
SettingsQuantityTakeoff::SettingsNameFormat Class
Collapse All

Settings to establish the default name format to quantity takeoff.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff::SettingsNameFormat
C#
public class SettingsQuantityTakeoff::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsQuantityTakeoff::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsQuantityTakeoff::SettingsNameFormat Properties, SettingsQuantityTakeoff::SettingsNameFormat Members, Class Hierarchy


SettingsQuantityTakeoff::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class > SettingsQuantityTakeoff::SettingsNameFormat Members
SettingsQuantityTakeoff::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsQuantityTakeoff::SettingsNameFormat.

Public Properties
Public Property | Description
Material | Settings QuantityTakeoff material name format.
MaterialList | Settings QuantityTakeoff material list name format.
Links
Public Properties


SettingsQuantityTakeoff::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class > SettingsQuantityTakeoff::SettingsNameFormat Properties
SettingsQuantityTakeoff::SettingsNameFormat Properties
Collapse All

The properties of SettingsQuantityTakeoff::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
Material | Settings QuantityTakeoff material name format.
MaterialList | Settings QuantityTakeoff material list name format.
Links
Public Properties


SettingsQuantityTakeoff::SettingsNameFormat::Material Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class > SettingsQuantityTakeoff::SettingsNameFormat Properties > SettingsQuantityTakeoff::SettingsNameFormat::Material Property
SettingsQuantityTakeoff::SettingsNameFormat::Material Property
Collapse All

Settings QuantityTakeoff material name format.

C#
public PropertyString Material;
Visual Basic
Public Property Material() As PropertyString
Links
SettingsQuantityTakeoff::SettingsNameFormat Class, SettingsQuantityTakeoff::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsQuantityTakeoff::SettingsNameFormat::MaterialList Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class > SettingsQuantityTakeoff::SettingsNameFormat Properties > SettingsQuantityTakeoff::SettingsNameFormat::MaterialList Property
SettingsQuantityTakeoff::SettingsNameFormat::MaterialList Property
Collapse All

Settings QuantityTakeoff material list name format.

C#
public PropertyString MaterialList;
Visual Basic
Public Property MaterialList() As PropertyString
Links
SettingsQuantityTakeoff::SettingsNameFormat Class, SettingsQuantityTakeoff::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsQuantityTakeoff::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class
SettingsQuantityTakeoff::SettingsStyles Class
Collapse All

Settings to establish the default styles assigned to quantity takeoff.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff::SettingsStyles
C#
public class SettingsQuantityTakeoff::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsQuantityTakeoff::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsQuantityTakeoff::SettingsStyles Properties, SettingsQuantityTakeoff::SettingsStyles Members, Class Hierarchy


SettingsQuantityTakeoff::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class > SettingsQuantityTakeoff::SettingsStyles Members
SettingsQuantityTakeoff::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsQuantityTakeoff::SettingsStyles.

Public Properties
Public Property | Description
MaterialShape | Settings of QuantityTakeoff material shape.
QuantityTakeoffCriteria | Settings of QuantityTakeoff criteria style.
Links
Public Properties


SettingsQuantityTakeoff::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class > SettingsQuantityTakeoff::SettingsStyles Properties
SettingsQuantityTakeoff::SettingsStyles Properties
Collapse All

The properties of SettingsQuantityTakeoff::SettingsStyles are listed here.

Public Properties
Public Property | Description
MaterialShape | Settings of QuantityTakeoff material shape.
QuantityTakeoffCriteria | Settings of QuantityTakeoff criteria style.
Links
Public Properties


SettingsQuantityTakeoff::SettingsStyles::MaterialShape Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class > SettingsQuantityTakeoff::SettingsStyles Properties > SettingsQuantityTakeoff::SettingsStyles::MaterialShape Property
SettingsQuantityTakeoff::SettingsStyles::MaterialShape Property
Collapse All

Settings of QuantityTakeoff material shape.

C#
public PropertyString MaterialShape;
Visual Basic
Public Property MaterialShape() As PropertyString
Links
SettingsQuantityTakeoff::SettingsStyles Class, SettingsQuantityTakeoff::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsQuantityTakeoff::SettingsStyles::QuantityTakeoffCriteria Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class > SettingsQuantityTakeoff::SettingsStyles Properties > SettingsQuantityTakeoff::SettingsStyles::QuantityTakeoffCriteria Property
SettingsQuantityTakeoff::SettingsStyles::QuantityTakeoffCriteria Property
Collapse All

Settings of QuantityTakeoff criteria style.

C#
public PropertyString QuantityTakeoffCriteria;
Visual Basic
Public Property QuantityTakeoffCriteria() As PropertyString
Links
SettingsQuantityTakeoff::SettingsStyles Class, SettingsQuantityTakeoff::SettingsStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsSubassembly Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class
SettingsSubassembly Class
Collapse All

Contains settings that apply to the assembly feature, as specified in the Edit Feature Settings dialog box.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsSubassembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubassemblyTool
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubFromPline
C#
public class SettingsSubassembly : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsSubassembly
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsSubassembly Properties, SettingsSubassembly Members, Class Hierarchy


SettingsSubassembly Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Members
SettingsSubassembly Members
Collapse All

The following tables list the members exposed by SettingsSubassembly.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
DefaultStyles | Gets the settings to specify the default styles for subassembly.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for subassembly.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsSubassembly Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Properties
SettingsSubassembly Properties
Collapse All

The properties of SettingsSubassembly are listed here.

Public Properties
Public Property | Description
DefaultStyles | Gets the settings to specify the default styles for subassembly.
NameFormat | Gets the settings to specify the default name formats for subassembly.
Links
Public Properties


SettingsSubassembly::DefaultStyles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Properties > SettingsSubassembly::DefaultStyles Property
SettingsSubassembly::DefaultStyles Property
Collapse All

Gets the settings to specify the default styles for subassembly.

C#
public SettingsDefaultStyles DefaultStyles;
Visual Basic
Public Property DefaultStyles() As SettingsDefaultStyles
Links
SettingsSubassembly Class, SettingsSubassembly Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsSubassembly::NameFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Properties > SettingsSubassembly::NameFormat Property
SettingsSubassembly::NameFormat Property
Collapse All

Gets the settings to specify the default name formats for subassembly.

C#
public SettingsNameFormat NameFormat;
Visual Basic
Public Property NameFormat() As SettingsNameFormat
Links
SettingsSubassembly Class, SettingsSubassembly Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsSubassembly::SettingsDefaultStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsDefaultStyles Class
SettingsSubassembly::SettingsDefaultStyles Class
Collapse All

Settings for subassembly default styles.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsSubassembly::SettingsDefaultStyles
C#
public class SettingsSubassembly::SettingsDefaultStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsSubassembly::SettingsDefaultStyles
Inherits TreeOidWrapper
Links
SettingsSubassembly::SettingsDefaultStyles Properties, SettingsSubassembly::SettingsDefaultStyles Members, Class Hierarchy


SettingsSubassembly::SettingsDefaultStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsDefaultStyles Class > SettingsSubassembly::SettingsDefaultStyles Members
SettingsSubassembly::SettingsDefaultStyles Members
Collapse All

The following tables list the members exposed by SettingsSubassembly::SettingsDefaultStyles.

Public Properties
Public Property | Description
CodeSetStyle | Gets the settings to specify the default code set style for subassembly.
Links
Public Properties


SettingsSubassembly::SettingsDefaultStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsDefaultStyles Class > SettingsSubassembly::SettingsDefaultStyles Properties
SettingsSubassembly::SettingsDefaultStyles Properties
Collapse All

The properties of SettingsSubassembly::SettingsDefaultStyles are listed here.

Public Properties
Public Property | Description
CodeSetStyle | Gets the settings to specify the default code set style for subassembly.
Links
Public Properties


SettingsSubassembly::SettingsDefaultStyles::CodeSetStyle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsDefaultStyles Class > SettingsSubassembly::SettingsDefaultStyles Properties > SettingsSubassembly::SettingsDefaultStyles::CodeSetStyle Property
SettingsSubassembly::SettingsDefaultStyles::CodeSetStyle Property
Collapse All

Gets the settings to specify the default code set style for subassembly.

C#
public PropertyString CodeSetStyle;
Visual Basic
Public Property CodeSetStyle() As PropertyString
Links
SettingsSubassembly::SettingsDefaultStyles Class, SettingsSubassembly::SettingsDefaultStyles Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsSubassembly::SettingsNameFormat Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class
SettingsSubassembly::SettingsNameFormat Class
Collapse All

Settings for Corridor styles.

Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsSubassembly::SettingsNameFormat
C#
public class SettingsSubassembly::SettingsNameFormat : TreeOidWrapper;
Visual Basic
Public Class SettingsSubassembly::SettingsNameFormat
Inherits TreeOidWrapper
Links
SettingsSubassembly::SettingsNameFormat Properties, SettingsSubassembly::SettingsNameFormat Members, Class Hierarchy


SettingsSubassembly::SettingsNameFormat Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class > SettingsSubassembly::SettingsNameFormat Members
SettingsSubassembly::SettingsNameFormat Members
Collapse All

The following tables list the members exposed by SettingsSubassembly::SettingsNameFormat.

Public Properties
Public Property | Description
CreateFromEntities | Gets the settings to specify the default name formats for subassembly.
CreateFromMacro | Gets the settings to specify the default name formats for subassembly.
Links
Public Properties


SettingsSubassembly::SettingsNameFormat Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class > SettingsSubassembly::SettingsNameFormat Properties
SettingsSubassembly::SettingsNameFormat Properties
Collapse All

The properties of SettingsSubassembly::SettingsNameFormat are listed here.

Public Properties
Public Property | Description
CreateFromEntities | Gets the settings to specify the default name formats for subassembly.
CreateFromMacro | Gets the settings to specify the default name formats for subassembly.
Links
Public Properties


SettingsSubassembly::SettingsNameFormat::CreateFromEntities Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class > SettingsSubassembly::SettingsNameFormat Properties > SettingsSubassembly::SettingsNameFormat::CreateFromEntities Property
SettingsSubassembly::SettingsNameFormat::CreateFromEntities Property
Collapse All

Gets the settings to specify the default name formats for subassembly.

C#
public PropertyString CreateFromEntities;
Visual Basic
Public Property CreateFromEntities() As PropertyString
Links
SettingsSubassembly::SettingsNameFormat Class, SettingsSubassembly::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


SettingsSubassembly::SettingsNameFormat::CreateFromMacro Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class > SettingsSubassembly::SettingsNameFormat Properties > SettingsSubassembly::SettingsNameFormat::CreateFromMacro Property
SettingsSubassembly::SettingsNameFormat::CreateFromMacro Property
Collapse All

Gets the settings to specify the default name formats for subassembly.

C#
public PropertyString CreateFromMacro;
Visual Basic
Public Property CreateFromMacro() As PropertyString
Links
SettingsSubassembly::SettingsNameFormat Class, SettingsSubassembly::SettingsNameFormat Members, Autodesk::Civil::Roadway::Settings Namespace


Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
AssemblyDisplayStyleType | The Autodesk::Civil::Roadway::AssemblyDisplayStyleType enumeration.
LinkCreationType | An enumeration that defines the link creation type.
QuantityTakeoffLengthComputeType | An enumeration that specifies the length computation type in the take off process.
QuantityTakeoffPipeLengthType | An enumeration that specifies the pipe length type in the take off process.
QuantityTakeoffReportExtentType | An enumeration that specifies the extents used when finding entities to participate in the take off process.
QuantityTakeoffReportType | An enumeration that specifies the quantity takeoff report type.
RoadwaySideType | An enumeration that defines the roadway side type.
Links
Enumerations


Autodesk::Civil::Roadway::AssemblyDisplayStyleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::AssemblyDisplayStyleType Enumeration
Autodesk::Civil::Roadway::AssemblyDisplayStyleType Enumeration
Collapse All

The Autodesk::Civil::Roadway::AssemblyDisplayStyleType enumeration.

C#
public enum AssemblyDisplayStyleType {
  InsertionPoint = AeccDbAssemblyStyle::kDispCompAssemblyOrigin,
  Baseline = AeccDbAssemblyStyle::kDispCompAssemblyBaseline,
  BaselineOrigin = AeccDbAssemblyStyle::kDispCompAssemblyBaselineOrigin,
  OffsetBaseline = AeccDbAssemblyStyle::kDispCompAssemblyOffsetBaseline,
  OffsetBaselineOrigin = AeccDbAssemblyStyle::kDispCompAssemblyOffsetBaselineOrigin
}
Visual Basic
Public Enum AssemblyDisplayStyleType
  InsertionPoint = AeccDbAssemblyStyle::kDispCompAssemblyOrigin
  Baseline = AeccDbAssemblyStyle::kDispCompAssemblyBaseline
  BaselineOrigin = AeccDbAssemblyStyle::kDispCompAssemblyBaselineOrigin
  OffsetBaseline = AeccDbAssemblyStyle::kDispCompAssemblyOffsetBaseline
  OffsetBaselineOrigin = AeccDbAssemblyStyle::kDispCompAssemblyOffsetBaselineOrigin
End Enum


Autodesk::Civil::Roadway::LinkCreationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::LinkCreationType Enumeration
Autodesk::Civil::Roadway::LinkCreationType Enumeration
Collapse All

An enumeration that defines the link creation type.

C#
public enum LinkCreationType {
  None = AeccDbSubassembly::kLinkCreationNone,
  Single = AeccDbSubassembly::kLinkCreationSingle,
  Multiple = AeccDbSubassembly::kLinkCreationMultiple
}
Visual Basic
Public Enum LinkCreationType
  None = AeccDbSubassembly::kLinkCreationNone
  Single = AeccDbSubassembly::kLinkCreationSingle
  Multiple = AeccDbSubassembly::kLinkCreationMultiple
End Enum


Autodesk::Civil::Roadway::QuantityTakeoffLengthComputeType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::QuantityTakeoffLengthComputeType Enumeration
Autodesk::Civil::Roadway::QuantityTakeoffLengthComputeType Enumeration
Collapse All

An enumeration that specifies the length computation type in the take off process.

C#
public enum QuantityTakeoffLengthComputeType {
  Compute2D = AeccQTOComputationEnum::kCompute2D,
  Compute3D = AeccQTOComputationEnum::kCompute3D
}
Visual Basic
Public Enum QuantityTakeoffLengthComputeType
  Compute2D = AeccQTOComputationEnum::kCompute2D
  Compute3D = AeccQTOComputationEnum::kCompute3D
End Enum


Autodesk::Civil::Roadway::QuantityTakeoffPipeLengthType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::QuantityTakeoffPipeLengthType Enumeration
Autodesk::Civil::Roadway::QuantityTakeoffPipeLengthType Enumeration
Collapse All

An enumeration that specifies the pipe length type in the take off process.

C#
public enum QuantityTakeoffPipeLengthType {
  CenterToCenter = AeccQTOComputationEnum::kPipeOuter,
  ToInsideEdges = AeccQTOComputationEnum::kPipeInner
}
Visual Basic
Public Enum QuantityTakeoffPipeLengthType
  CenterToCenter = AeccQTOComputationEnum::kPipeOuter
  ToInsideEdges = AeccQTOComputationEnum::kPipeInner
End Enum


Autodesk::Civil::Roadway::QuantityTakeoffReportExtentType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::QuantityTakeoffReportExtentType Enumeration
Autodesk::Civil::Roadway::QuantityTakeoffReportExtentType Enumeration
Collapse All

An enumeration that specifies the extents used when finding entities to participate in the take off process.

C#
public enum QuantityTakeoffReportExtentType {
  Drawing = AeccQTOComputationEnum::kExtentDrawing,
  Sheet = AeccQTOComputationEnum::kExtentSheet,
  SelectionSet = AeccQTOComputationEnum::kExtentSelectionSet
}
Visual Basic
Public Enum QuantityTakeoffReportExtentType
  Drawing = AeccQTOComputationEnum::kExtentDrawing
  Sheet = AeccQTOComputationEnum::kExtentSheet
  SelectionSet = AeccQTOComputationEnum::kExtentSelectionSet
End Enum


Autodesk::Civil::Roadway::QuantityTakeoffReportType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::QuantityTakeoffReportType Enumeration
Autodesk::Civil::Roadway::QuantityTakeoffReportType Enumeration
Collapse All

An enumeration that specifies the quantity takeoff report type.

C#
public enum QuantityTakeoffReportType {
  Summary = AeccQTOComputationEnum::kSummaryReport,
  Detailed = AeccQTOComputationEnum::kItemizedReport
}
Visual Basic
Public Enum QuantityTakeoffReportType
  Summary = AeccQTOComputationEnum::kSummaryReport
  Detailed = AeccQTOComputationEnum::kItemizedReport
End Enum


Autodesk::Civil::Roadway::RoadwaySideType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Structs, Records, Enums > Autodesk::Civil::Roadway::RoadwaySideType Enumeration
Autodesk::Civil::Roadway::RoadwaySideType Enumeration
Collapse All

An enumeration that defines the roadway side type.

C#
public enum RoadwaySideType {
  Right = 0,
  Left = 1
}
Visual Basic
Public Enum RoadwaySideType
  Right = 0
  Left = 1
End Enum


Autodesk::Civil::Runtime Namespace

The Autodesk::Civil::Runtime namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
CorridorState | Contains a wide array of information about a corridor and methods for determining locations relative to the corridor. Used in... more
Param | Use Autodesk.Civil.IParam instead.
ParamAlignment | Alignment parameter.
ParamAlignmentCollection | A collection of Alignment parameters.
ParamBase | The base class for parameters.
ParamBool | A boolean parameter.
ParamBoolCollection | A collection of boolean parameters.
ParamCollectionBase | Base class for parameter collections.
ParamDouble | A parameter with a double value.
ParamDoubleCollection | A collection of double parameters.
ParamElevationTarget | Elevation target parameter.
ParamElevationTargetCollection | A collection of elevation target parameters.
ParamLong | A long parameter.
ParamLongCollection | A collection of long parameters.
ParamOffsetTarget | An offset target parameter.
ParamOffsetTargetCollection | A collection of offset target parameters.
ParamPoint | A point parameter.
ParamPointCollection | A collection of point parameters.
ParamProfile | A Profile parameter.
ParamProfileCollection | A collection of profile parameters.
ParamString | A string parameter.
ParamStringCollection | A collection of string parameters.
ParamSurface | A Surface parameter.
ParamSurfaceCollection | A collection of surface parameters.
PipeNetworkState | Contains the properties of the drawing's pipe network state.
RuntimeState | Base class for objects containing user-defined parameters describing an object state.
Interfaces
Interface | Description
IParam | Interface for parameters.
Structs, Records, Enums
Struct, Record, Enum | Description
CorridorError | Corridor error types.
CorridorErrorLevel | Error severity levels for Corridors.
CorridorLayoutModeDisplay | Layout modes for subassemblies.
CorridorMode | Roadway mode (design or layout).
ParamAccessType | Defines access permissions for a parameter.
ParamLogicalNameType | The Autodesk::Civil::Runtime::ParamLogicalNameType enumeration.
ParamScope | Defines the parameter scope.
ParamsOwnerType | Defines the owner type for a parameter.
ParamType | Defines the parameter type.
TypeInfoBool | The Autodesk::Civil::Runtime::TypeInfoBool enumeration.
TypeInfoDouble | The Autodesk::Civil::Runtime::TypeInfoDouble enumeration.
TypeInfoLong | The Autodesk::Civil::Runtime::TypeInfoLong enumeration.
Links
Topics, Classes, Interfaces, Structs, Records, Enums


Classes

The following table lists classes in this documentation.

Classes
Class | Description
CorridorState | Contains a wide array of information about a corridor and methods for determining locations relative to the corridor. Used in... more
Param | Use Autodesk.Civil.IParam instead.
ParamAlignment | Alignment parameter.
ParamAlignmentCollection | A collection of Alignment parameters.
ParamBool | A boolean parameter.
ParamBoolCollection | A collection of boolean parameters.
ParamDouble | A parameter with a double value.
ParamDoubleCollection | A collection of double parameters.
ParamElevationTarget | Elevation target parameter.
ParamElevationTargetCollection | A collection of elevation target parameters.
ParamLong | A long parameter.
ParamLongCollection | A collection of long parameters.
ParamOffsetTarget | An offset target parameter.
ParamOffsetTargetCollection | A collection of offset target parameters.
ParamPoint | A point parameter.
ParamPointCollection | A collection of point parameters.
ParamProfile | A Profile parameter.
ParamProfileCollection | A collection of profile parameters.
ParamString | A string parameter.
ParamStringCollection | A collection of string parameters.
ParamSurface | A Surface parameter.
ParamSurfaceCollection | A collection of surface parameters.
PipeNetworkState | Contains the properties of the drawing's pipe network state.
RuntimeState | Base class for objects containing user-defined parameters describing an object state.
Templates
Template | Description
ParamBase | The base class for parameters.
ParamCollectionBase | Base class for parameter collections.
Links
Classes, Templates


CorridorState Class

Contains a wide array of information about a corridor and methods for determining locations relative to the corridor. Used in the creation of custom subassemblies.

Class Hierarchy
Autodesk::Civil::Runtime::RuntimeState
    Autodesk::Civil::Runtime::CorridorState
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayState"))]
public class CorridorState : RuntimeState;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRoadwayState"))>
Public Class CorridorState
Inherits RuntimeState
Links
CorridorState Methods, CorridorState Properties, CorridorState Members, Class Hierarchy


CorridorState Members

The following tables list the members exposed by CorridorState.

Public Methods
Public Method | Description
IntersectAlignment | Overloaded
IntersectLink | Intersects a ray with an assembly's links.
IntersectSurface | Overloaded
IsAboveSurface | Overloaded
RecordError | Record error.
SampleSection | Samples elevation along an existing surface.
SoeToXyz | Transforms from assembly local station, offset, elevation (SOE) coordinates to world x,y,z coordinates.
XyzToSoe | Transforms from world x,y,z coordinates to assembly local station, offset, elevation (SOE) coordinates.
Public Properties
Public Property | Description
CurrentAlignmentId | Gets the current alignment where Subassembly is being applied.
CurrentAlignmentIsOffsetAlignment | Returns true if current processing state is along an offset alignment.
CurrentAssemblyElevation | Returns elevation difference from profile grade line elevation where current assembly is being applied.
CurrentAssemblyFixedElevation | If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed elevation difference of the offset assembly portion from the... more
CurrentAssemblyFixedOffset | If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed offset distance of the offset assembly portion from the... more
CurrentAssemblyId | Gets the ObjectId of the current Assembly being applied.
CurrentAssemblyName | Gets the name of the current Assembly being applied.
CurrentAssemblyOffset | Returns offset from baseline alignment where current assembly is being applied.
CurrentAssemblyOffsetIsFixed | Returns true if current processing state is along offset portion of assembly without offset alignment defined.
CurrentBaselineId | Gets the current baseline alignment where a Subassembly is being applied.
CurrentCorridorId | Gets the OjbectId of the current Corridor being applied.
CurrentCorridorName | Gets the name of the current Corridor being applied.
CurrentElevation | Gets the current elevation.
CurrentMacroName | Gets the current macro name.
CurrentMacroProject | Gets the current macro project.
CurrentOffset | Gets the current offset.
CurrentProfileId | Gets the current profile where Subassembly is being applied.
CurrentStation | Gets the current baseline alignment station where a Subassembly is being applied.
CurrentSubassemblyElevation | Returns the elevation difference from the assembly origin where the current subassembly is being applied.
CurrentSubassemblyId | Gets the ObjectId of the current Subassembly being applied.
CurrentSubassemblyName | Gets the name of the current Subassembly being applied.
CurrentSubassemblyOffset | Returns the offset from assembly origin where the current subassembly is being applied.
LayoutModeDisplayType | Gets or sets the corridor state's display mode.
Links | Gets the collection of links.
Mode | Gets corridor state's mode.
ParamsAlignment | Gets the collection of alignment parameters.
ParamsAlignmentGlobal | ParamsAlignmentGlobal
ParamsBool | Gets the collection of boolean parameters.
ParamsBoolGlobal | ParamsBoolGlobal
ParamsDouble | Gets the collection of double parameters.
ParamsDoubleGlobal | ParamsDoubleGlobal
ParamsElevationTarget | Gets the collection of elevation parameters.
ParamsElevationTargetGlobal | ParamsElevationGlobal
ParamsLong | Gets the collection of long parameters.
ParamsLongGlobal | ParamsLongGlobal
ParamsOffsetTarget | Gets the collection of offset target parameters.
ParamsOffsetTargetGlobal | ParamsOffsetTargetGlobal
ParamsPoint | Gets the collection of marked point parameters.
ParamsPointGlobal | ParamsPointGlobal
ParamsProfile | Gets the collection of profile parameters.
ParamsProfileGlobal | ParamsProfileGlobal
ParamsString | Gets the collection of string parameters.
ParamsStringGlobal | ParamsStringGlobal
ParamsSurface | Gets the collection of surface parameters.
ParamsSurfaceGlobal | ParamsSurfaceGlobal
Points | Gets the collection of points.
ResourceString | Converts a resource id (numeric) to a resource string from the current subassembly's resource module.
Shapes | Gets the collection of shapes.
Links
Public Methods, Public Properties


CorridorState Methods

The methods of CorridorState are listed here.

Public Methods
Public Method | Description
IntersectAlignment | Overloaded
IntersectLink | Intersects a ray with an assembly's links.
IntersectSurface | Overloaded
IsAboveSurface | Overloaded
RecordError | Record error.
SampleSection | Samples elevation along an existing surface.
SoeToXyz | Transforms from assembly local station, offset, elevation (SOE) coordinates to world x,y,z coordinates.
XyzToSoe | Transforms from world x,y,z coordinates to assembly local station, offset, elevation (SOE) coordinates.
Links
Public Methods


IntersectAlignment Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > IntersectAlignment Method
IntersectAlignment Method
Collapse All

Overloaded

Overload List
Method | Description
CorridorState::IntersectAlignment (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool) | Intersects a ray with an alignment, with no maximum distance specified.
CorridorState::IntersectAlignment (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double) | Intersects a ray with an alignment.


CorridorState::IntersectAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > IntersectAlignment Method > CorridorState::IntersectAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool)
CorridorState::IntersectAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool)
Collapse All

Intersects a ray with an alignment, with no maximum distance specified.

C#
public Autodesk::Civil::Roadway::DatabaseServices::IPoint IntersectAlignment(
    Autodesk::AutoCAD::DatabaseServices::ObjectId targetAlignmentId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    ref Autodesk::Civil::Roadway::DatabaseServices::IPoint origin,
    bool lookRight
);
Visual Basic
Public Function IntersectAlignment(
    targetAlignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef origin As Autodesk::Civil::Roadway::DatabaseServices::IPoint,
    lookRight As bool
) As Autodesk::Civil::Roadway::DatabaseServices::IPoint
Parameters
Parameters | Description
targetAlignmentId | Intersect with this alignment.
alignmentId | Project the ray perpendicular to this alignment.
origin | Origin of the intersection ray.
lookRight | Project the ray to the right if true, to the left if false.
Returns

Returns the point of intersection.

Exceptions
Exceptions | Description
 | System::ArgumentNullException
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::IntersectAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > IntersectAlignment Method > CorridorState::IntersectAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double)
CorridorState::IntersectAlignment Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double)
Collapse All

Intersects a ray with an alignment.

C#
public Autodesk::Civil::Roadway::DatabaseServices::IPoint IntersectAlignment(
    Autodesk::AutoCAD::DatabaseServices::ObjectId targetAlignmentId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    ref Autodesk::Civil::Roadway::DatabaseServices::IPoint origin,
    bool lookRight,
    double maxDistance
);
Visual Basic
Public Function IntersectAlignment(
    targetAlignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef origin As Autodesk::Civil::Roadway::DatabaseServices::IPoint,
    lookRight As bool,
    maxDistance As double
) As Autodesk::Civil::Roadway::DatabaseServices::IPoint
Parameters
Parameters | Description
targetAlignmentId | Intersect with this alignment.
alignmentId | Project the ray perpendicular to this alignment.
origin | Origin of the intersection ray.
lookRight | Project the ray to the right if true, to the left if false.
maxDistance | Maximum distance to project the ray.
Returns

Returns the point of intersection.

Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::IntersectLink Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > CorridorState::IntersectLink Method
CorridorState::IntersectLink Method
Collapse All

Intersects a ray with an assembly's links.

C#
public Autodesk::Civil::Roadway::DatabaseServices::IPoint IntersectLink(
    ref Autodesk::Civil::Roadway::DatabaseServices::IPoint origin,
    bool lookRight,
    double slope,
    ref System::String linkCode
);
Visual Basic
Public Function IntersectLink(
    ByRef origin As Autodesk::Civil::Roadway::DatabaseServices::IPoint,
    lookRight As bool,
    slope As double,
    ByRef linkCode As System::String
) As Autodesk::Civil::Roadway::DatabaseServices::IPoint
Parameters
Parameters | Description
origin | Origin of the intersection ray.
lookRight | Project the ray to the right if true, to the left if false.
slope | Slope of the ray.
linkCode | Only intersect with links with this code. An empty string "" intersects with all links.
Returns

Returns the point of intersection.

Exceptions
Exceptions | Description
 | System::ArgumentNullException
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


IntersectSurface Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > IntersectSurface Method
IntersectSurface Method
Collapse All

Overloaded

Overload List
Method | Description
CorridorState::IntersectSurface (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double) | Intersects a ray with a surface, with no maximum ray distance.
CorridorState::IntersectSurface (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double, double) | Intersects a ray with a surface.


CorridorState::IntersectSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > IntersectSurface Method > CorridorState::IntersectSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double)
CorridorState::IntersectSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double)
Collapse All

Intersects a ray with a surface, with no maximum ray distance.

C#
public Autodesk::Civil::Roadway::DatabaseServices::IPoint IntersectSurface(
    Autodesk::AutoCAD::DatabaseServices::ObjectId surfaceId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    ref Autodesk::Civil::Roadway::DatabaseServices::IPoint origin,
    bool lookRight,
    double slope
);
Visual Basic
Public Function IntersectSurface(
    surfaceId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef origin As Autodesk::Civil::Roadway::DatabaseServices::IPoint,
    lookRight As bool,
    slope As double
) As Autodesk::Civil::Roadway::DatabaseServices::IPoint
Parameters
Parameters | Description
surfaceId | Intersect the ray with this surface.
alignmentId | Project the ray perpendicular to this alignment.
origin | Origin of the intersection ray.
lookRight | Project the ray to the right if true, to the left if false.
slope | Slope of the ray.
Returns

Returns the point of intersection.

Exceptions
Exceptions | Description
 | System::ArgumentNullException
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::IntersectSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > IntersectSurface Method > CorridorState::IntersectSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double, double)
CorridorState::IntersectSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, bool, double, double)
Collapse All

Intersects a ray with a surface.

C#
public Autodesk::Civil::Roadway::DatabaseServices::IPoint IntersectSurface(
    Autodesk::AutoCAD::DatabaseServices::ObjectId surfaceId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    ref Autodesk::Civil::Roadway::DatabaseServices::IPoint origin,
    bool lookRight,
    double slope,
    double maxDistance
);
Visual Basic
Public Function IntersectSurface(
    surfaceId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef origin As Autodesk::Civil::Roadway::DatabaseServices::IPoint,
    lookRight As bool,
    slope As double,
    maxDistance As double
) As Autodesk::Civil::Roadway::DatabaseServices::IPoint
Parameters
Parameters | Description
surfaceId | Intersect the ray with this surface.
alignmentId | Project the ray perpendicular to this alignment.
origin | Origin of the intersection ray.
lookRight | Project the ray to the right if true, to the left if false.
slope | Slope of the ray.
maxDistance | Maximum distance to project the ray.
Returns

Returns the point of intersection.

Exceptions
Exceptions | Description
 | System::ArgumentNullException
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


IsAboveSurface Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > IsAboveSurface Method
IsAboveSurface Method
Collapse All

Overloaded

Overload List
Method | Description
CorridorState::IsAboveSurface (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^) | Determines if roadway point is above a surface, with no minimum distance specified.
CorridorState::IsAboveSurface (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, double) | Determines if roadway point is above a surface.


CorridorState::IsAboveSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > IsAboveSurface Method > CorridorState::IsAboveSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^)
CorridorState::IsAboveSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^)
Collapse All

Determines if roadway point is above a surface, with no minimum distance specified.

C#
public bool IsAboveSurface(
    Autodesk::AutoCAD::DatabaseServices::ObjectId surfaceId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    ref Autodesk::Civil::Roadway::DatabaseServices::IPoint point
);
Visual Basic
Public Function IsAboveSurface(
    surfaceId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef point As Autodesk::Civil::Roadway::DatabaseServices::IPoint
) As bool
Parameters
Parameters | Description
surfaceId | Target surface.
alignmentId | Source alignment.
point | Source point.
Returns

Returns true if the point is above the surface.

Exceptions
Exceptions | Description
 | System::ArgumentNullException
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::IsAboveSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, double)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > IsAboveSurface Method > CorridorState::IsAboveSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, double)
CorridorState::IsAboveSurface Method (Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::AutoCAD::DatabaseServices::ObjectId, Autodesk::Civil::Roadway::DatabaseServices::IPoint^, double)
Collapse All

Determines if roadway point is above a surface.

C#
public bool IsAboveSurface(
    Autodesk::AutoCAD::DatabaseServices::ObjectId surfaceId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    ref Autodesk::Civil::Roadway::DatabaseServices::IPoint point,
    double minimumAmountAbove
);
Visual Basic
Public Function IsAboveSurface(
    surfaceId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef point As Autodesk::Civil::Roadway::DatabaseServices::IPoint,
    minimumAmountAbove As double
) As bool
Parameters
Parameters | Description
surfaceId | Target surface.
alignmentId | Source alignment.
point | Source point.
minimumAmountAbove | Minimum amount above surface.
Returns

Returns true if the point is above the surface plus minimumAmountAbove, false otherwise.

Exceptions
Exceptions | Description
 | System::ArgumentNullException
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::RecordError Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > CorridorState::RecordError Method
CorridorState::RecordError Method
Collapse All

Record error.

C#
public RecordError(
    CorridorError error,
    CorridorErrorLevel errorLevel,
    ref System::String description,
    ref System::String source,
    bool showInEventViewer
);
Visual Basic
Public Sub RecordError(
    error As CorridorError,
    errorLevel As CorridorErrorLevel,
    ByRef description As System::String,
    ByRef source As System::String,
    showInEventViewer As bool
)
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::SampleSection Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > CorridorState::SampleSection Method
CorridorState::SampleSection Method
Collapse All

Samples elevation along an existing surface.

C#
public Autodesk::Civil::Roadway::DatabaseServices::SampledSectionLinkCollection SampleSection(
    Autodesk::AutoCAD::DatabaseServices::ObjectId surfaceId,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    ref Autodesk::Civil::Roadway::DatabaseServices::IPoint point1,
    ref Autodesk::Civil::Roadway::DatabaseServices::IPoint point2
);
Visual Basic
Public Function SampleSection(
    surfaceId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    ByRef point1 As Autodesk::Civil::Roadway::DatabaseServices::IPoint,
    ByRef point2 As Autodesk::Civil::Roadway::DatabaseServices::IPoint
) As Autodesk::Civil::Roadway::DatabaseServices::SampledSectionLinkCollection
Parameters
Parameters | Description
surfaceId | Target surface.
alignmentId | Source alignment.
point1 | Start sampling at this point.
point2 | End sampling at this point.
Returns

Returns a collection of links.

Exceptions
Exceptions | Description
 | System::ArgumentNullException
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::SoeToXyz Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > CorridorState::SoeToXyz Method
CorridorState::SoeToXyz Method
Collapse All

Transforms from assembly local station, offset, elevation (SOE) coordinates to world x,y,z coordinates.

C#
public SoeToXyz(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double station,
    double offset,
    double elevation,
    ref double X,
    ref double Y,
    ref double Z
);
Visual Basic
Public Sub SoeToXyz(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    station As double,
    offset As double,
    elevation As double,
    ByRef X As double,
    ByRef Y As double,
    ByRef Z As double
)
Parameters
Parameters | Description
alignmentId | Transform using this alignment.
station | Source station.
offset | Source offset.
elevation | Source elevation.
X | Destination X.
Y | Destination Y.
Z | Destination Z.
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::XyzToSoe Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Methods > CorridorState::XyzToSoe Method
CorridorState::XyzToSoe Method
Collapse All

Transforms from world x,y,z coordinates to assembly local station, offset, elevation (SOE) coordinates.

C#
public XyzToSoe(
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId,
    double X,
    double Y,
    double Z,
    ref double station,
    ref double offset,
    ref double elevation
);
Visual Basic
Public Sub XyzToSoe(
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId,
    X As double,
    Y As double,
    Z As double,
    ByRef station As double,
    ByRef offset As double,
    ByRef elevation As double
)
Parameters
Parameters | Description
alignmentId | Transform using this alignment.
X | Source X.
Y | Source Y.
Z | Source Z.
station | Destination station.
offset | Destination offset.
elevation | Destination elevation.
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState Properties

The properties of CorridorState are listed here.

Public Properties
Public Property | Description
CurrentAlignmentId | Gets the current alignment where Subassembly is being applied.
CurrentAlignmentIsOffsetAlignment | Returns true if current processing state is along an offset alignment.
CurrentAssemblyElevation | Returns elevation difference from profile grade line elevation where current assembly is being applied.
CurrentAssemblyFixedElevation | If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed elevation difference of the offset assembly portion from the... more
CurrentAssemblyFixedOffset | If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed offset distance of the offset assembly portion from the... more
CurrentAssemblyId | Gets the ObjectId of the current Assembly being applied.
CurrentAssemblyName | Gets the name of the current Assembly being applied.
CurrentAssemblyOffset | Returns offset from baseline alignment where current assembly is being applied.
CurrentAssemblyOffsetIsFixed | Returns true if current processing state is along offset portion of assembly without offset alignment defined.
CurrentBaselineId | Gets the current baseline alignment where a Subassembly is being applied.
CurrentCorridorId | Gets the OjbectId of the current Corridor being applied.
CurrentCorridorName | Gets the name of the current Corridor being applied.
CurrentElevation | Gets the current elevation.
CurrentOffset | Gets the current offset.
CurrentProfileId | Gets the current profile where Subassembly is being applied.
CurrentStation | Gets the current baseline alignment station where a Subassembly is being applied.
CurrentSubassemblyElevation | Returns the elevation difference from the assembly origin where the current subassembly is being applied.
CurrentSubassemblyId | Gets the ObjectId of the current Subassembly being applied.
CurrentSubassemblyName | Gets the name of the current Subassembly being applied.
CurrentSubassemblyOffset | Returns the offset from assembly origin where the current subassembly is being applied.
LayoutModeDisplayType | Gets or sets the corridor state's display mode.
Links | Gets the collection of links.
Mode | Gets corridor state's mode.
ParamsAlignment | Gets the collection of alignment parameters.
ParamsAlignmentGlobal | ParamsAlignmentGlobal
ParamsBool | Gets the collection of boolean parameters.
ParamsBoolGlobal | ParamsBoolGlobal
ParamsDouble | Gets the collection of double parameters.
ParamsDoubleGlobal | ParamsDoubleGlobal
ParamsElevationTarget | Gets the collection of elevation parameters.
ParamsElevationTargetGlobal | ParamsElevationGlobal
ParamsLong | Gets the collection of long parameters.
ParamsLongGlobal | ParamsLongGlobal
ParamsOffsetTarget | Gets the collection of offset target parameters.
ParamsOffsetTargetGlobal | ParamsOffsetTargetGlobal
ParamsPoint | Gets the collection of marked point parameters.
ParamsPointGlobal | ParamsPointGlobal
ParamsProfile | Gets the collection of profile parameters.
ParamsProfileGlobal | ParamsProfileGlobal
ParamsString | Gets the collection of string parameters.
ParamsStringGlobal | ParamsStringGlobal
ParamsSurface | Gets the collection of surface parameters.
ParamsSurfaceGlobal | ParamsSurfaceGlobal
Points | Gets the collection of points.
ResourceString | Converts a resource id (numeric) to a resource string from the current subassembly's resource module.
Shapes | Gets the collection of shapes.
Links
Public Properties


CorridorState::CurrentAlignmentId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentAlignmentId Property
CorridorState::CurrentAlignmentId Property
Collapse All

Gets the current alignment where Subassembly is being applied.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurrentAlignmentId;
Visual Basic
Public Property CurrentAlignmentId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentAlignmentIsOffsetAlignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentAlignmentIsOffsetAlignment Property
CorridorState::CurrentAlignmentIsOffsetAlignment Property
Collapse All

Returns true if current processing state is along an offset alignment.

C#
public bool CurrentAlignmentIsOffsetAlignment;
Visual Basic
Public Property CurrentAlignmentIsOffsetAlignment() As bool
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentAssemblyElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentAssemblyElevation Property
CorridorState::CurrentAssemblyElevation Property
Collapse All

Returns elevation difference from profile grade line elevation where current assembly is being applied.

C#
public double CurrentAssemblyElevation;
Visual Basic
Public Property CurrentAssemblyElevation() As double
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentAssemblyFixedElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentAssemblyFixedElevation Property
CorridorState::CurrentAssemblyFixedElevation Property
Collapse All

If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed elevation difference of the offset assembly portion from the baseline assembly portion.

C#
public double CurrentAssemblyFixedElevation;
Visual Basic
Public Property CurrentAssemblyFixedElevation() As double
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentAssemblyFixedOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentAssemblyFixedOffset Property
CorridorState::CurrentAssemblyFixedOffset Property
Collapse All

If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed offset distance of the offset assembly portion from the baseline assembly portion.

C#
public double CurrentAssemblyFixedOffset;
Visual Basic
Public Property CurrentAssemblyFixedOffset() As double
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentAssemblyId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentAssemblyId Property
CorridorState::CurrentAssemblyId Property
Collapse All

Gets the ObjectId of the current Assembly being applied.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurrentAssemblyId;
Visual Basic
Public Property CurrentAssemblyId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentAssemblyName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentAssemblyName Property
CorridorState::CurrentAssemblyName Property
Collapse All

Gets the name of the current Assembly being applied.

C#
public System::String CurrentAssemblyName;
Visual Basic
Public Property CurrentAssemblyName() As System::String
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentAssemblyOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentAssemblyOffset Property
CorridorState::CurrentAssemblyOffset Property
Collapse All

Returns offset from baseline alignment where current assembly is being applied.

C#
public double CurrentAssemblyOffset;
Visual Basic
Public Property CurrentAssemblyOffset() As double
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentAssemblyOffsetIsFixed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentAssemblyOffsetIsFixed Property
CorridorState::CurrentAssemblyOffsetIsFixed Property
Collapse All

Returns true if current processing state is along offset portion of assembly without offset alignment defined.

C#
public bool CurrentAssemblyOffsetIsFixed;
Visual Basic
Public Property CurrentAssemblyOffsetIsFixed() As bool
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentBaselineId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentBaselineId Property
CorridorState::CurrentBaselineId Property
Collapse All

Gets the current baseline alignment where a Subassembly is being applied.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurrentBaselineId;
Visual Basic
Public Property CurrentBaselineId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentCorridorId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentCorridorId Property
CorridorState::CurrentCorridorId Property
Collapse All

Gets the OjbectId of the current Corridor being applied.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurrentCorridorId;
Visual Basic
Public Property CurrentCorridorId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentCorridorName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentCorridorName Property
CorridorState::CurrentCorridorName Property
Collapse All

Gets the name of the current Corridor being applied.

C#
public System::String CurrentCorridorName;
Visual Basic
Public Property CurrentCorridorName() As System::String
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentElevation Property
CorridorState::CurrentElevation Property
Collapse All

Gets the current elevation.

C#
public double CurrentElevation;
Visual Basic
Public Property CurrentElevation() As double
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentOffset Property
CorridorState::CurrentOffset Property
Collapse All

Gets the current offset.

C#
public double CurrentOffset;
Visual Basic
Public Property CurrentOffset() As double
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentProfileId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentProfileId Property
CorridorState::CurrentProfileId Property
Collapse All

Gets the current profile where Subassembly is being applied.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurrentProfileId;
Visual Basic
Public Property CurrentProfileId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentStation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentStation Property
CorridorState::CurrentStation Property
Collapse All

Gets the current baseline alignment station where a Subassembly is being applied.

C#
public double CurrentStation;
Visual Basic
Public Property CurrentStation() As double
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentSubassemblyElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentSubassemblyElevation Property
CorridorState::CurrentSubassemblyElevation Property
Collapse All

Returns the elevation difference from the assembly origin where the current subassembly is being applied.

C#
public double CurrentSubassemblyElevation;
Visual Basic
Public Property CurrentSubassemblyElevation() As double
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentSubassemblyId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentSubassemblyId Property
CorridorState::CurrentSubassemblyId Property
Collapse All

Gets the ObjectId of the current Subassembly being applied.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurrentSubassemblyId;
Visual Basic
Public Property CurrentSubassemblyId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentSubassemblyName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentSubassemblyName Property
CorridorState::CurrentSubassemblyName Property
Collapse All

Gets the name of the current Subassembly being applied.

C#
public System::String CurrentSubassemblyName;
Visual Basic
Public Property CurrentSubassemblyName() As System::String
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::CurrentSubassemblyOffset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::CurrentSubassemblyOffset Property
CorridorState::CurrentSubassemblyOffset Property
Collapse All

Returns the offset from assembly origin where the current subassembly is being applied.

C#
public double CurrentSubassemblyOffset;
Visual Basic
Public Property CurrentSubassemblyOffset() As double
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::LayoutModeDisplayType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::LayoutModeDisplayType Property
CorridorState::LayoutModeDisplayType Property
Collapse All

Gets or sets the corridor state's display mode.

C#
public CorridorLayoutModeDisplay LayoutModeDisplayType;
Visual Basic
Public Property LayoutModeDisplayType() As CorridorLayoutModeDisplay
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::Links Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::Links Property
CorridorState::Links Property
Collapse All

Gets the collection of links.

C#
public Autodesk::Civil::Roadway::DatabaseServices::LinkCollection Links;
Visual Basic
Public Property Links() As Autodesk::Civil::Roadway::DatabaseServices::LinkCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::Mode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::Mode Property
CorridorState::Mode Property
Collapse All

Gets corridor state's mode.

C#
public CorridorMode Mode;
Visual Basic
Public Property Mode() As CorridorMode
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsAlignment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsAlignment Property
CorridorState::ParamsAlignment Property
Collapse All

Gets the collection of alignment parameters.

C#
public ParamAlignmentCollection ParamsAlignment;
Visual Basic
Public Property ParamsAlignment() As ParamAlignmentCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsAlignmentGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsAlignmentGlobal Property
CorridorState::ParamsAlignmentGlobal Property
Collapse All

ParamsAlignmentGlobal

C#
public ParamAlignmentCollection ParamsAlignmentGlobal;
Visual Basic
Public Property ParamsAlignmentGlobal() As ParamAlignmentCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsBool Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsBool Property
CorridorState::ParamsBool Property
Collapse All

Gets the collection of boolean parameters.

C#
public ParamBoolCollection ParamsBool;
Visual Basic
Public Property ParamsBool() As ParamBoolCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsBoolGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsBoolGlobal Property
CorridorState::ParamsBoolGlobal Property
Collapse All

ParamsBoolGlobal

C#
public ParamBoolCollection ParamsBoolGlobal;
Visual Basic
Public Property ParamsBoolGlobal() As ParamBoolCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsDouble Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsDouble Property
CorridorState::ParamsDouble Property
Collapse All

Gets the collection of double parameters.

C#
public ParamDoubleCollection ParamsDouble;
Visual Basic
Public Property ParamsDouble() As ParamDoubleCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsDoubleGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsDoubleGlobal Property
CorridorState::ParamsDoubleGlobal Property
Collapse All

ParamsDoubleGlobal

C#
public ParamDoubleCollection ParamsDoubleGlobal;
Visual Basic
Public Property ParamsDoubleGlobal() As ParamDoubleCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsElevationTarget Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsElevationTarget Property
CorridorState::ParamsElevationTarget Property
Collapse All

Gets the collection of elevation parameters.

C#
public ParamElevationTargetCollection ParamsElevationTarget;
Visual Basic
Public Property ParamsElevationTarget() As ParamElevationTargetCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsElevationTargetGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsElevationTargetGlobal Property
CorridorState::ParamsElevationTargetGlobal Property
Collapse All

ParamsElevationGlobal

C#
public ParamElevationTargetCollection ParamsElevationTargetGlobal;
Visual Basic
Public Property ParamsElevationTargetGlobal() As ParamElevationTargetCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsLong Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsLong Property
CorridorState::ParamsLong Property
Collapse All

Gets the collection of long parameters.

C#
public ParamLongCollection ParamsLong;
Visual Basic
Public Property ParamsLong() As ParamLongCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsLongGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsLongGlobal Property
CorridorState::ParamsLongGlobal Property
Collapse All

ParamsLongGlobal

C#
public ParamLongCollection ParamsLongGlobal;
Visual Basic
Public Property ParamsLongGlobal() As ParamLongCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsOffsetTarget Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsOffsetTarget Property
CorridorState::ParamsOffsetTarget Property
Collapse All

Gets the collection of offset target parameters.

C#
public ParamOffsetTargetCollection ParamsOffsetTarget;
Visual Basic
Public Property ParamsOffsetTarget() As ParamOffsetTargetCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsOffsetTargetGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsOffsetTargetGlobal Property
CorridorState::ParamsOffsetTargetGlobal Property
Collapse All

ParamsOffsetTargetGlobal

C#
public ParamOffsetTargetCollection ParamsOffsetTargetGlobal;
Visual Basic
Public Property ParamsOffsetTargetGlobal() As ParamOffsetTargetCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsPoint Property
CorridorState::ParamsPoint Property
Collapse All

Gets the collection of marked point parameters.

C#
public ParamPointCollection ParamsPoint;
Visual Basic
Public Property ParamsPoint() As ParamPointCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsPointGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsPointGlobal Property
CorridorState::ParamsPointGlobal Property
Collapse All

ParamsPointGlobal

C#
public ParamPointCollection ParamsPointGlobal;
Visual Basic
Public Property ParamsPointGlobal() As ParamPointCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsProfile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsProfile Property
CorridorState::ParamsProfile Property
Collapse All

Gets the collection of profile parameters.

C#
public ParamProfileCollection ParamsProfile;
Visual Basic
Public Property ParamsProfile() As ParamProfileCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsProfileGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsProfileGlobal Property
CorridorState::ParamsProfileGlobal Property
Collapse All

ParamsProfileGlobal

C#
public ParamProfileCollection ParamsProfileGlobal;
Visual Basic
Public Property ParamsProfileGlobal() As ParamProfileCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsString Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsString Property
CorridorState::ParamsString Property
Collapse All

Gets the collection of string parameters.

C#
public ParamStringCollection ParamsString;
Visual Basic
Public Property ParamsString() As ParamStringCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsStringGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsStringGlobal Property
CorridorState::ParamsStringGlobal Property
Collapse All

ParamsStringGlobal

C#
public ParamStringCollection ParamsStringGlobal;
Visual Basic
Public Property ParamsStringGlobal() As ParamStringCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsSurface Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsSurface Property
CorridorState::ParamsSurface Property
Collapse All

Gets the collection of surface parameters.

C#
public ParamSurfaceCollection ParamsSurface;
Visual Basic
Public Property ParamsSurface() As ParamSurfaceCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ParamsSurfaceGlobal Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ParamsSurfaceGlobal Property
CorridorState::ParamsSurfaceGlobal Property
Collapse All

ParamsSurfaceGlobal

C#
public ParamSurfaceCollection ParamsSurfaceGlobal;
Visual Basic
Public Property ParamsSurfaceGlobal() As ParamSurfaceCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::Points Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::Points Property
CorridorState::Points Property
Collapse All

Gets the collection of points.

C#
public Autodesk::Civil::Roadway::DatabaseServices::PointCollection Points;
Visual Basic
Public Property Points() As Autodesk::Civil::Roadway::DatabaseServices::PointCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::ResourceString Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::ResourceString Property
CorridorState::ResourceString Property
Collapse All

Converts a resource id (numeric) to a resource string from the current subassembly's resource module.

C#
public System::String ResourceString;
Visual Basic
Public Property ResourceString() As System::String
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


CorridorState::Shapes Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > CorridorState Class > CorridorState Properties > CorridorState::Shapes Property
CorridorState::Shapes Property
Collapse All

Gets the collection of shapes.

C#
public Autodesk::Civil::Roadway::DatabaseServices::ShapeCollection Shapes;
Visual Basic
Public Property Shapes() As Autodesk::Civil::Roadway::DatabaseServices::ShapeCollection
Links
CorridorState Class, CorridorState Members, Autodesk::Civil::Runtime Namespace


Param Class

Param Class deprecated

Use Autodesk.Civil.IParam instead.

Class Hierarchy
Autodesk::Civil::Runtime::Param
C#
public class Param;
Visual Basic
Public Class Param
Notes

Deprecated: Use Autodesk.Civil.Runtime.IParam instead.

Links
Class Hierarchy


ParamAlignment Class

Alignment parameter.

Class Hierarchy
Autodesk::Civil::Runtime::ParamAlignment
C#
public class ParamAlignment : ParamBase<aeccParamTypeAlignment,Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,CastOpAlignmentId>;
Visual Basic
Public Class ParamAlignment
Inherits ParamBase<aeccParamTypeAlignment,Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,CastOpAlignmentId>
Links
ParamAlignment Properties, ParamAlignment Members, Class Hierarchy


ParamAlignment Members

The following tables list the members exposed by ParamAlignment.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamAlignment Properties

The properties of ParamAlignment are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamAlignment::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignment Class > ParamAlignment Properties > ParamAlignment::Access Property
ParamAlignment::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamAlignment Class, ParamAlignment Members, Autodesk::Civil::Runtime Namespace


ParamAlignment::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignment Class > ParamAlignment Properties > ParamAlignment::Comment Property
ParamAlignment::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamAlignment Class, ParamAlignment Members, Autodesk::Civil::Runtime Namespace


ParamAlignment::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignment Class > ParamAlignment Properties > ParamAlignment::Description Property
ParamAlignment::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamAlignment Class, ParamAlignment Members, Autodesk::Civil::Runtime Namespace


ParamAlignment::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignment Class > ParamAlignment Properties > ParamAlignment::DisplayName Property
ParamAlignment::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamAlignment Class, ParamAlignment Members, Autodesk::Civil::Runtime Namespace


ParamAlignment::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignment Class > ParamAlignment Properties > ParamAlignment::DisplayOrder Property
ParamAlignment::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamAlignment Class, ParamAlignment Members, Autodesk::Civil::Runtime Namespace


ParamAlignment::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignment Class > ParamAlignment Properties > ParamAlignment::IsReadOnly Property
ParamAlignment::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamAlignment Class, ParamAlignment Members, Autodesk::Civil::Runtime Namespace


ParamAlignment::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignment Class > ParamAlignment Properties > ParamAlignment::Value Property
ParamAlignment::Value Property
Collapse All

Gets or sets the parameter value.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Value;
Visual Basic
Public Property Value() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ParamAlignment Class, ParamAlignment Members, Autodesk::Civil::Runtime Namespace


ParamAlignmentCollection Class

A collection of Alignment parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamAlignmentCollection
C#
public class ParamAlignmentCollection : ParamCollectionBase<ParamAlignment>;
Visual Basic
Public Class ParamAlignmentCollection
Inherits ParamCollectionBase<ParamAlignment>
Links
ParamAlignmentCollection Methods, ParamAlignmentCollection Properties, ParamAlignmentCollection Members, Class Hierarchy


ParamAlignmentCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Members
ParamAlignmentCollection Members
Collapse All

The following tables list the members exposed by ParamAlignmentCollection.

Public Methods
Public Method | Description
Value | Overloaded
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Properties


ParamAlignmentCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Methods
ParamAlignmentCollection Methods
Collapse All

The methods of ParamAlignmentCollection are listed here.

Public Methods
Public Method | Description
Value | Overloaded
Links
Public Methods


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamAlignmentCollection::Value (int) | Gets the specified parameter.
ParamAlignmentCollection::Value (System::String^) | Gets the specified parameter.


ParamAlignmentCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Methods > Value Method > ParamAlignmentCollection::Value Method (System::String^)
ParamAlignmentCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamAlignment::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamAlignment::ValueType
Links
ParamAlignmentCollection Class, ParamAlignmentCollection Members, Autodesk::Civil::Runtime Namespace


ParamAlignmentCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Methods > Value Method > ParamAlignmentCollection::Value Method (int)
ParamAlignmentCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamAlignment::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamAlignment::ValueType
Links
ParamAlignmentCollection Class, ParamAlignmentCollection Members, Autodesk::Civil::Runtime Namespace


ParamAlignmentCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Properties
ParamAlignmentCollection Properties
Collapse All

The properties of ParamAlignmentCollection are listed here.

Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamAlignmentCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Properties > ParamAlignmentCollection::Count Property
ParamAlignmentCollection::Count Property
Collapse All

The number of parameters in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamAlignmentCollection Class, ParamAlignmentCollection Members, Autodesk::Civil::Runtime Namespace


ParamAlignmentCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Properties > ParamAlignmentCollection::default Property
ParamAlignmentCollection::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamAlignment default;
Visual Basic
Public Property default() As ParamAlignment
Links
ParamAlignmentCollection Class, ParamAlignmentCollection Members, Autodesk::Civil::Runtime Namespace


ParamBase Template

The base class for parameters.

Class Hierarchy
Autodesk::Civil::Runtime::IParam
    Autodesk::Civil::Runtime::ParamBase
C#
public class ParamBase<AeccParamType aeccParamType, typename ValueType, typename InnerType = ValueType, typename TCast = CastOp<ValueType, InnerType> > : IParam;
Visual Basic
Public Class ParamBase(Of AeccParamType aeccParamType, typename ValueType, typename InnerType = ValueType, typename TCast = CastOp<ValueType, InnerType> )
Inherits IParam
Links
ParamBase Properties, ParamBase Nested Types, ParamBase Members, Class Hierarchy


ParamBase Members

The following tables list the members exposed by ParamBase.

Public Nested Types
Public Nested Type | Description
InnerType | This is nested type Autodesk::Civil::Runtime::ParamBase::InnerType.
TCast | This is nested type Autodesk::Civil::Runtime::ParamBase::TCast.
ValueType | This is nested type Autodesk::Civil::Runtime::ParamBase::ValueType.
Public Properties
Public Property | Description
Access | Gets or sets access permissions for the parameter.
Comment | Gets or sets the comment string for the parameter.
Description | Gets or sets the description for the parameter.
DisplayName | Gets or sets the display name for the parameter.
DisplayOrder | Gets or sets the display order for the parameter.
IsReadOnly | Gets or sets whether the parameter is read-only.
Value | Gets or sets the parameter value.
Links
Public Nested Types, Public Properties


ParamBase Properties

The properties of ParamBase are listed here.

Public Properties
Public Property | Description
Access | Gets or sets access permissions for the parameter.
Comment | Gets or sets the comment string for the parameter.
Description | Gets or sets the description for the parameter.
DisplayName | Gets or sets the display name for the parameter.
DisplayOrder | Gets or sets the display order for the parameter.
IsReadOnly | Gets or sets whether the parameter is read-only.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamBase::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Properties > ParamBase::Access Property
ParamBase::Access Property
Collapse All

Gets or sets access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBase::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Properties > ParamBase::Comment Property
ParamBase::Comment Property
Collapse All

Gets or sets the comment string for the parameter.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBase::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Properties > ParamBase::Description Property
ParamBase::Description Property
Collapse All

Gets or sets the description for the parameter.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBase::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Properties > ParamBase::DisplayName Property
ParamBase::DisplayName Property
Collapse All

Gets or sets the display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBase::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Properties > ParamBase::DisplayOrder Property
ParamBase::DisplayOrder Property
Collapse All

Gets or sets the display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBase::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Properties > ParamBase::IsReadOnly Property
ParamBase::IsReadOnly Property
Collapse All

Gets or sets whether the parameter is read-only.

C#
public bool IsReadOnly;
Visual Basic
Public Property IsReadOnly() As bool
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBase::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Properties > ParamBase::Value Property
ParamBase::Value Property
Collapse All

Gets or sets the parameter value.

C#
public ValueType Value;
Visual Basic
Public Property Value() As ValueType
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBase Nested Types

The nested types of ParamBase are listed here.

Public Nested Types
Public Nested Type | Description
InnerType | This is nested type Autodesk::Civil::Runtime::ParamBase::InnerType.
TCast | This is nested type Autodesk::Civil::Runtime::ParamBase::TCast.
ValueType | This is nested type Autodesk::Civil::Runtime::ParamBase::ValueType.
Links
Public Nested Types


ParamBase::InnerType Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Nested Types > ParamBase::InnerType Nested Type
ParamBase::InnerType Nested Type
Collapse All

This is nested type Autodesk::Civil::Runtime::ParamBase::InnerType.

C#
InnerType
Visual Basic
InnerType
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBase::TCast Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Nested Types > ParamBase::TCast Nested Type
ParamBase::TCast Nested Type
Collapse All

This is nested type Autodesk::Civil::Runtime::ParamBase::TCast.

C#
TCast
Visual Basic
TCast
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBase::ValueType Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBase Template > ParamBase Nested Types > ParamBase::ValueType Nested Type
ParamBase::ValueType Nested Type
Collapse All

This is nested type Autodesk::Civil::Runtime::ParamBase::ValueType.

C#
ValueType
Visual Basic
ValueType
Links
ParamBase Template, ParamBase Members, Autodesk::Civil::Runtime Namespace


ParamBool Class

A boolean parameter.

Class Hierarchy
Autodesk::Civil::Runtime::ParamBool
C#
public class ParamBool : ParamBase<aeccParamTypeBool,bool>;
Visual Basic
Public Class ParamBool
Inherits ParamBase<aeccParamTypeBool,bool>
Links
ParamBool Properties, ParamBool Members, Class Hierarchy


ParamBool Members

The following tables list the members exposed by ParamBool.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | The sub-type of the boolean parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamBool Properties

The properties of ParamBool are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | The sub-type of the boolean parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamBool::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBool Class > ParamBool Properties > ParamBool::Access Property
ParamBool::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamBool Class, ParamBool Members, Autodesk::Civil::Runtime Namespace


ParamBool::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBool Class > ParamBool Properties > ParamBool::Comment Property
ParamBool::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamBool Class, ParamBool Members, Autodesk::Civil::Runtime Namespace


ParamBool::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBool Class > ParamBool Properties > ParamBool::Description Property
ParamBool::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamBool Class, ParamBool Members, Autodesk::Civil::Runtime Namespace


ParamBool::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBool Class > ParamBool Properties > ParamBool::DisplayName Property
ParamBool::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamBool Class, ParamBool Members, Autodesk::Civil::Runtime Namespace


ParamBool::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBool Class > ParamBool Properties > ParamBool::DisplayOrder Property
ParamBool::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamBool Class, ParamBool Members, Autodesk::Civil::Runtime Namespace


ParamBool::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBool Class > ParamBool Properties > ParamBool::IsReadOnly Property
ParamBool::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamBool Class, ParamBool Members, Autodesk::Civil::Runtime Namespace


ParamBool::TypeInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBool Class > ParamBool Properties > ParamBool::TypeInfo Property
ParamBool::TypeInfo Property
Collapse All

The sub-type of the boolean parameter.

C#
public TypeInfoBool TypeInfo;
Visual Basic
Public Property TypeInfo() As TypeInfoBool
Links
ParamBool Class, ParamBool Members, Autodesk::Civil::Runtime Namespace


ParamBool::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBool Class > ParamBool Properties > ParamBool::Value Property
ParamBool::Value Property
Collapse All

Gets or sets the parameter value.

C#
public bool Value;
Visual Basic
Public Property Value() As bool
Links
ParamBool Class, ParamBool Members, Autodesk::Civil::Runtime Namespace


ParamBoolCollection Class

A collection of boolean parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamBoolCollection
C#
public class ParamBoolCollection : ParamCollectionBase<ParamBool>;
Visual Basic
Public Class ParamBoolCollection
Inherits ParamCollectionBase<ParamBool>
Links
ParamBoolCollection Methods, ParamBoolCollection Properties, ParamBoolCollection Members, Class Hierarchy


ParamBoolCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Members
ParamBoolCollection Members
Collapse All

The following tables list the members exposed by ParamBoolCollection.

Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Properties


ParamBoolCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Methods
ParamBoolCollection Methods
Collapse All

The methods of ParamBoolCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded
Links
Public Methods


ParamBoolCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Methods > ParamBoolCollection::Add Method
ParamBoolCollection::Add Method
Collapse All

Adds a new item to parameters collection.

C#
public ParamBool Add(
    ref System::String name,
    bool value
);
Visual Basic
Public Function Add(
    ByRef name As System::String,
    value As bool
) As ParamBool
Parameters
Parameters | Description
name | Name of the new parameter.
value | Value of the new parameter.
Remarks

If the input name exists in collection, this function will not add new item, instead it will return existing item and change its value.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when name is a empty string.
Links
ParamBoolCollection Class, ParamBoolCollection Members, Autodesk::Civil::Runtime Namespace


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamBoolCollection::Value (int) | Gets the specified parameter.
ParamBoolCollection::Value (System::String^) | Gets the specified parameter.


ParamBoolCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Methods > Value Method > ParamBoolCollection::Value Method (System::String^)
ParamBoolCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamBool::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamBool::ValueType
Links
ParamBoolCollection Class, ParamBoolCollection Members, Autodesk::Civil::Runtime Namespace


ParamBoolCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Methods > Value Method > ParamBoolCollection::Value Method (int)
ParamBoolCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamBool::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamBool::ValueType
Links
ParamBoolCollection Class, ParamBoolCollection Members, Autodesk::Civil::Runtime Namespace


ParamBoolCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Properties
ParamBoolCollection Properties
Collapse All

The properties of ParamBoolCollection are listed here.

Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamBoolCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Properties > ParamBoolCollection::Count Property
ParamBoolCollection::Count Property
Collapse All

The number of parameters in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamBoolCollection Class, ParamBoolCollection Members, Autodesk::Civil::Runtime Namespace


ParamBoolCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Properties > ParamBoolCollection::default Property
ParamBoolCollection::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamBool default;
Visual Basic
Public Property default() As ParamBool
Links
ParamBoolCollection Class, ParamBoolCollection Members, Autodesk::Civil::Runtime Namespace


ParamCollectionBase Template

Base class for parameter collections.

Class Hierarchy
Autodesk::Civil::Runtime::ParamCollectionBase
C#
public class ParamCollectionBase< typename ParamType, typename ParamTypeRef = ParamType^> : System::Collections::Generic::IEnumerable<ParamTypeRef>;
Visual Basic
Public Class ParamCollectionBase(Of  typename ParamType, typename ParamTypeRef = ParamType^)
Inherits System::Collections::Generic::IEnumerable<ParamTypeRef>
Links
ParamCollectionBase Methods, ParamCollectionBase Properties, ParamCollectionBase Nested Types, ParamCollectionBase Members, Class Hierarchy


ParamCollectionBase Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Members
ParamCollectionBase Members
Collapse All

The following tables list the members exposed by ParamCollectionBase.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Value | Overloaded
Public Nested Types
Public Nested Type | Description
InnerType | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::InnerType.
TCast | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::TCast.
ValueType | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::ValueType.
Public Properties
Public Property | Description
Count | Gets the number of objects in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Nested Types, Public Properties


ParamCollectionBase Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Methods
ParamCollectionBase Methods
Collapse All

The methods of ParamCollectionBase are listed here.

Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Value | Overloaded
Links
Public Methods


ParamCollectionBase::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Methods > ParamCollectionBase::GetEnumerator Method
ParamCollectionBase::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.

C#
public System::Collections::Generic::IEnumerator<ParamTypeRef> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<ParamTypeRef>
Returns

An enumerator which implements IEnumerator<T> interface.

Links
ParamCollectionBase Template, ParamCollectionBase Members, Autodesk::Civil::Runtime Namespace


ParamCollectionBase::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Methods > ParamCollectionBase::GetObjectEnumerator Method
ParamCollectionBase::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
ParamCollectionBase Template, ParamCollectionBase Members, Autodesk::Civil::Runtime Namespace


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamCollectionBase::Value (int) | Gets the value of the parameter at the specified index.
ParamCollectionBase::Value (System::String^) | Gets the value of the parameter of the specified name.


ParamCollectionBase::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Methods > Value Method > ParamCollectionBase::Value Method (System::String^)
ParamCollectionBase::Value Method (System::String^)
Collapse All

Gets the value of the parameter of the specified name.

C#
public ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ValueType
Parameters
Parameters | Description
index | The name of the parameter to get.
Links
ParamCollectionBase Template, ParamCollectionBase Members, Autodesk::Civil::Runtime Namespace


ParamCollectionBase::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Methods > Value Method > ParamCollectionBase::Value Method (int)
ParamCollectionBase::Value Method (int)
Collapse All

Gets the value of the parameter at the specified index.

C#
public ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ValueType
Parameters
Parameters | Description
index | The index of the parameter to get.
Links
ParamCollectionBase Template, ParamCollectionBase Members, Autodesk::Civil::Runtime Namespace


ParamCollectionBase Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Properties
ParamCollectionBase Properties
Collapse All

The properties of ParamCollectionBase are listed here.

Public Properties
Public Property | Description
Count | Gets the number of objects in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamCollectionBase::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Properties > ParamCollectionBase::Count Property
ParamCollectionBase::Count Property
Collapse All

Gets the number of objects in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamCollectionBase Template, ParamCollectionBase Members, Autodesk::Civil::Runtime Namespace


ParamCollectionBase::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Properties > ParamCollectionBase::default Property
ParamCollectionBase::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamType default;
Visual Basic
Public Property default() As ParamType
Links
ParamCollectionBase Template, ParamCollectionBase Members, Autodesk::Civil::Runtime Namespace


ParamCollectionBase Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Nested Types
ParamCollectionBase Nested Types
Collapse All

The nested types of ParamCollectionBase are listed here.

Public Nested Types
Public Nested Type | Description
InnerType | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::InnerType.
TCast | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::TCast.
ValueType | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::ValueType.
Links
Public Nested Types


ParamCollectionBase::InnerType Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Nested Types > ParamCollectionBase::InnerType Nested Type
ParamCollectionBase::InnerType Nested Type
Collapse All

This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::InnerType.

C#
InnerType
Visual Basic
InnerType
Links
ParamCollectionBase Template, ParamCollectionBase Members, Autodesk::Civil::Runtime Namespace


ParamCollectionBase::TCast Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Nested Types > ParamCollectionBase::TCast Nested Type
ParamCollectionBase::TCast Nested Type
Collapse All

This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::TCast.

C#
TCast
Visual Basic
TCast
Links
ParamCollectionBase Template, ParamCollectionBase Members, Autodesk::Civil::Runtime Namespace


ParamCollectionBase::ValueType Nested Type

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Nested Types > ParamCollectionBase::ValueType Nested Type
ParamCollectionBase::ValueType Nested Type
Collapse All

This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::ValueType.

C#
ValueType
Visual Basic
ValueType
Links
ParamCollectionBase Template, ParamCollectionBase Members, Autodesk::Civil::Runtime Namespace


ParamDouble Class

A parameter with a double value.

Class Hierarchy
Autodesk::Civil::Runtime::ParamDouble
C#
public class ParamDouble : ParamBase<aeccParamTypeDouble,double>;
Visual Basic
Public Class ParamDouble
Inherits ParamBase<aeccParamTypeDouble,double>
Links
ParamDouble Properties, ParamDouble Members, Class Hierarchy


ParamDouble Members

The following tables list the members exposed by ParamDouble.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | Gets or sets the type information for this parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamDouble Properties

The properties of ParamDouble are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | Gets or sets the type information for this parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamDouble::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDouble Class > ParamDouble Properties > ParamDouble::Access Property
ParamDouble::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamDouble Class, ParamDouble Members, Autodesk::Civil::Runtime Namespace


ParamDouble::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDouble Class > ParamDouble Properties > ParamDouble::Comment Property
ParamDouble::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamDouble Class, ParamDouble Members, Autodesk::Civil::Runtime Namespace


ParamDouble::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDouble Class > ParamDouble Properties > ParamDouble::Description Property
ParamDouble::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamDouble Class, ParamDouble Members, Autodesk::Civil::Runtime Namespace


ParamDouble::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDouble Class > ParamDouble Properties > ParamDouble::DisplayName Property
ParamDouble::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamDouble Class, ParamDouble Members, Autodesk::Civil::Runtime Namespace


ParamDouble::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDouble Class > ParamDouble Properties > ParamDouble::DisplayOrder Property
ParamDouble::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamDouble Class, ParamDouble Members, Autodesk::Civil::Runtime Namespace


ParamDouble::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDouble Class > ParamDouble Properties > ParamDouble::IsReadOnly Property
ParamDouble::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamDouble Class, ParamDouble Members, Autodesk::Civil::Runtime Namespace


ParamDouble::TypeInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDouble Class > ParamDouble Properties > ParamDouble::TypeInfo Property
ParamDouble::TypeInfo Property
Collapse All

Gets or sets the type information for this parameter.

C#
public TypeInfoDouble TypeInfo;
Visual Basic
Public Property TypeInfo() As TypeInfoDouble
Links
ParamDouble Class, ParamDouble Members, Autodesk::Civil::Runtime Namespace


ParamDouble::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDouble Class > ParamDouble Properties > ParamDouble::Value Property
ParamDouble::Value Property
Collapse All

Gets or sets the parameter value.

C#
public double Value;
Visual Basic
Public Property Value() As double
Links
ParamDouble Class, ParamDouble Members, Autodesk::Civil::Runtime Namespace


ParamDoubleCollection Class

A collection of double parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamDoubleCollection
C#
public class ParamDoubleCollection : ParamCollectionBase<ParamDouble>;
Visual Basic
Public Class ParamDoubleCollection
Inherits ParamCollectionBase<ParamDouble>
Links
ParamDoubleCollection Methods, ParamDoubleCollection Properties, ParamDoubleCollection Members, Class Hierarchy


ParamDoubleCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Members
ParamDoubleCollection Members
Collapse All

The following tables list the members exposed by ParamDoubleCollection.

Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Properties


ParamDoubleCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Methods
ParamDoubleCollection Methods
Collapse All

The methods of ParamDoubleCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded
Links
Public Methods


ParamDoubleCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Methods > ParamDoubleCollection::Add Method
ParamDoubleCollection::Add Method
Collapse All

Adds a new item to parameters collection.

C#
public ParamDouble Add(
    ref System::String name,
    double value
);
Visual Basic
Public Function Add(
    ByRef name As System::String,
    value As double
) As ParamDouble
Parameters
Parameters | Description
name | Name of the new parameter.
value | Value of the new parameter.
Remarks

If the input name exists in collection, this function will not add new item, instead it will return existing item and change its value.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when name is a empty string.
Links
ParamDoubleCollection Class, ParamDoubleCollection Members, Autodesk::Civil::Runtime Namespace


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamDoubleCollection::Value (int) | Gets the specified parameter.
ParamDoubleCollection::Value (System::String^) | Gets the specified parameter.


ParamDoubleCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Methods > Value Method > ParamDoubleCollection::Value Method (System::String^)
ParamDoubleCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamDouble::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamDouble::ValueType
Links
ParamDoubleCollection Class, ParamDoubleCollection Members, Autodesk::Civil::Runtime Namespace


ParamDoubleCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Methods > Value Method > ParamDoubleCollection::Value Method (int)
ParamDoubleCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamDouble::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamDouble::ValueType
Links
ParamDoubleCollection Class, ParamDoubleCollection Members, Autodesk::Civil::Runtime Namespace


ParamDoubleCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Properties
ParamDoubleCollection Properties
Collapse All

The properties of ParamDoubleCollection are listed here.

Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamDoubleCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Properties > ParamDoubleCollection::Count Property
ParamDoubleCollection::Count Property
Collapse All

The number of parameters in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamDoubleCollection Class, ParamDoubleCollection Members, Autodesk::Civil::Runtime Namespace


ParamDoubleCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Properties > ParamDoubleCollection::default Property
ParamDoubleCollection::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamDouble default;
Visual Basic
Public Property default() As ParamDouble
Links
ParamDoubleCollection Class, ParamDoubleCollection Members, Autodesk::Civil::Runtime Namespace


ParamElevationTarget Class

Elevation target parameter.

Class Hierarchy
Autodesk::Civil::Runtime::ParamElevationTarget
C#
public class ParamElevationTarget : ParamBase<aeccParamTypeElevationTarget,Autodesk::Civil::Roadway::DatabaseServices::SlopeElevationTarget^,AcDbObjectIdArray>;
Visual Basic
Public Class ParamElevationTarget
Inherits ParamBase<aeccParamTypeElevationTarget,Autodesk::Civil::Roadway::DatabaseServices::SlopeElevationTarget^,AcDbObjectIdArray>
Links
ParamElevationTarget Properties, ParamElevationTarget Members, Class Hierarchy


ParamElevationTarget Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Members
ParamElevationTarget Members
Collapse All

The following tables list the members exposed by ParamElevationTarget.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamElevationTarget Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties
ParamElevationTarget Properties
Collapse All

The properties of ParamElevationTarget are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamElevationTarget::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties > ParamElevationTarget::Access Property
ParamElevationTarget::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamElevationTarget Class, ParamElevationTarget Members, Autodesk::Civil::Runtime Namespace


ParamElevationTarget::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties > ParamElevationTarget::Comment Property
ParamElevationTarget::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamElevationTarget Class, ParamElevationTarget Members, Autodesk::Civil::Runtime Namespace


ParamElevationTarget::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties > ParamElevationTarget::Description Property
ParamElevationTarget::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamElevationTarget Class, ParamElevationTarget Members, Autodesk::Civil::Runtime Namespace


ParamElevationTarget::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties > ParamElevationTarget::DisplayName Property
ParamElevationTarget::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamElevationTarget Class, ParamElevationTarget Members, Autodesk::Civil::Runtime Namespace


ParamElevationTarget::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties > ParamElevationTarget::DisplayOrder Property
ParamElevationTarget::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamElevationTarget Class, ParamElevationTarget Members, Autodesk::Civil::Runtime Namespace


ParamElevationTarget::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties > ParamElevationTarget::IsReadOnly Property
ParamElevationTarget::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamElevationTarget Class, ParamElevationTarget Members, Autodesk::Civil::Runtime Namespace


ParamElevationTarget::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties > ParamElevationTarget::Value Property
ParamElevationTarget::Value Property
Collapse All

Gets or sets the parameter value.

C#
public Autodesk::Civil::Roadway::DatabaseServices::SlopeElevationTarget Value;
Visual Basic
Public Property Value() As Autodesk::Civil::Roadway::DatabaseServices::SlopeElevationTarget
Links
ParamElevationTarget Class, ParamElevationTarget Members, Autodesk::Civil::Runtime Namespace


ParamElevationTargetCollection Class

A collection of elevation target parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamElevationTargetCollection
C#
public class ParamElevationTargetCollection : ParamCollectionBase<ParamElevationTarget>;
Visual Basic
Public Class ParamElevationTargetCollection
Inherits ParamCollectionBase<ParamElevationTarget>
Links
ParamElevationTargetCollection Methods, ParamElevationTargetCollection Properties, ParamElevationTargetCollection Members, Class Hierarchy


ParamElevationTargetCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Members
ParamElevationTargetCollection Members
Collapse All

The following tables list the members exposed by ParamElevationTargetCollection.

Public Methods
Public Method | Description
Value | Overloaded
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Properties


ParamElevationTargetCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Methods
ParamElevationTargetCollection Methods
Collapse All

The methods of ParamElevationTargetCollection are listed here.

Public Methods
Public Method | Description
Value | Overloaded
Links
Public Methods


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamElevationTargetCollection::Value (int) | Gets the specified parameter.
ParamElevationTargetCollection::Value (System::String^) | Gets the specified parameter.


ParamElevationTargetCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Methods > Value Method > ParamElevationTargetCollection::Value Method (System::String^)
ParamElevationTargetCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamElevationTarget::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamElevationTarget::ValueType
Links
ParamElevationTargetCollection Class, ParamElevationTargetCollection Members, Autodesk::Civil::Runtime Namespace


ParamElevationTargetCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Methods > Value Method > ParamElevationTargetCollection::Value Method (int)
ParamElevationTargetCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamElevationTarget::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamElevationTarget::ValueType
Links
ParamElevationTargetCollection Class, ParamElevationTargetCollection Members, Autodesk::Civil::Runtime Namespace


ParamElevationTargetCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Properties
ParamElevationTargetCollection Properties
Collapse All

The properties of ParamElevationTargetCollection are listed here.

Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamElevationTargetCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Properties > ParamElevationTargetCollection::Count Property
ParamElevationTargetCollection::Count Property
Collapse All

The number of parameters in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamElevationTargetCollection Class, ParamElevationTargetCollection Members, Autodesk::Civil::Runtime Namespace


ParamElevationTargetCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Properties > ParamElevationTargetCollection::default Property
ParamElevationTargetCollection::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamElevationTarget default;
Visual Basic
Public Property default() As ParamElevationTarget
Links
ParamElevationTargetCollection Class, ParamElevationTargetCollection Members, Autodesk::Civil::Runtime Namespace


ParamLong Class

A long parameter.

Class Hierarchy
Autodesk::Civil::Runtime::ParamLong
C#
public class ParamLong : ParamBase<aeccParamTypeInt,long>;
Visual Basic
Public Class ParamLong
Inherits ParamBase<aeccParamTypeInt,long>
Links
ParamLong Methods, ParamLong Properties, ParamLong Members, Class Hierarchy


ParamLong Members

The following tables list the members exposed by ParamLong.

Public Methods
Public Method | Description
AddEnumData | Gets the name, display name, and value for the enum specified by name.
EnumCount | Gets the number of values in the enums for this parameter.
GetEnumData | Gets the name, display name, and value for the enum specified by index.
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | Gets or sets the type information for this parameter.
Value | Gets or sets the parameter value.
Links
Public Methods, Public Properties


ParamLong Methods

The methods of ParamLong are listed here.

Public Methods
Public Method | Description
AddEnumData | Gets the name, display name, and value for the enum specified by name.
EnumCount | Gets the number of values in the enums for this parameter.
GetEnumData | Gets the name, display name, and value for the enum specified by index.
Links
Public Methods


ParamLong::AddEnumData Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Methods > ParamLong::AddEnumData Method
ParamLong::AddEnumData Method
Collapse All

Gets the name, display name, and value for the enum specified by name.

C#
public AddEnumData(
    ref System::String name,
    ref System::String displayName,
    int value
);
Visual Basic
Public Sub AddEnumData(
    ByRef name As System::String,
    ByRef displayName As System::String,
    value As Integer
)
Exceptions
Exceptions | Description
 | System::InvalidOperationException, System::ArgumentNullException, System::ArgumentException
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong::EnumCount Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Methods > ParamLong::EnumCount Method
ParamLong::EnumCount Method
Collapse All

Gets the number of values in the enums for this parameter.

C#
public unsigned long EnumCount();
Visual Basic
Public Function EnumCount() As unsigned long
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong::GetEnumData Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Methods > ParamLong::GetEnumData Method
ParamLong::GetEnumData Method
Collapse All

Gets the name, display name, and value for the enum specified by index.

C#
public GetEnumData(
    unsigned long index,
    System::String^% name,
    System::String^% displayName,
    int% value
);
Visual Basic
Public Sub GetEnumData(
    index As unsigned long,
    name As System::String^%,
    displayName As System::String^%,
    value As int%
)
Exceptions
Exceptions | Description
 | System::InvalidOperationException, System::ArgumentOutOfRangeException
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong Properties

The properties of ParamLong are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | Gets or sets the type information for this parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamLong::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Properties > ParamLong::Access Property
ParamLong::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Properties > ParamLong::Comment Property
ParamLong::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Properties > ParamLong::Description Property
ParamLong::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Properties > ParamLong::DisplayName Property
ParamLong::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Properties > ParamLong::DisplayOrder Property
ParamLong::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Properties > ParamLong::IsReadOnly Property
ParamLong::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong::TypeInfo Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Properties > ParamLong::TypeInfo Property
ParamLong::TypeInfo Property
Collapse All

Gets or sets the type information for this parameter.

C#
public TypeInfoLong TypeInfo;
Visual Basic
Public Property TypeInfo() As TypeInfoLong
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLong::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLong Class > ParamLong Properties > ParamLong::Value Property
ParamLong::Value Property
Collapse All

Gets or sets the parameter value.

C#
public long Value;
Visual Basic
Public Property Value() As long
Links
ParamLong Class, ParamLong Members, Autodesk::Civil::Runtime Namespace


ParamLongCollection Class

A collection of long parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamLongCollection
C#
public class ParamLongCollection : ParamCollectionBase<ParamLong>;
Visual Basic
Public Class ParamLongCollection
Inherits ParamCollectionBase<ParamLong>
Links
ParamLongCollection Methods, ParamLongCollection Properties, ParamLongCollection Members, Class Hierarchy


ParamLongCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Members
ParamLongCollection Members
Collapse All

The following tables list the members exposed by ParamLongCollection.

Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded
Public Properties
Public Property | Description
Count | This is Count, a member of class ParamLongCollection.
default | This is default, a member of class ParamLongCollection.
Links
Public Methods, Public Properties


ParamLongCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Methods
ParamLongCollection Methods
Collapse All

The methods of ParamLongCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded
Links
Public Methods


ParamLongCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Methods > ParamLongCollection::Add Method
ParamLongCollection::Add Method
Collapse All

Adds a new item to parameters collection.

C#
public ParamLong Add(
    ref System::String name,
    int value
);
Visual Basic
Public Function Add(
    ByRef name As System::String,
    value As Integer
) As ParamLong
Parameters
Parameters | Description
name | Name of the new parameter.
value | Value of the new parameter.
Remarks

If the input name exists in collection, this function will not add new item, instead it will return existing item and change its value.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when name is a empty string.
Links
ParamLongCollection Class, ParamLongCollection Members, Autodesk::Civil::Runtime Namespace


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamLongCollection::Value (int) | Gets the specified parameter.
ParamLongCollection::Value (System::String^) | Gets the specified parameter.


ParamLongCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Methods > Value Method > ParamLongCollection::Value Method (System::String^)
ParamLongCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamLong::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamLong::ValueType
Links
ParamLongCollection Class, ParamLongCollection Members, Autodesk::Civil::Runtime Namespace


ParamLongCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Methods > Value Method > ParamLongCollection::Value Method (int)
ParamLongCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamLong::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamLong::ValueType
Links
ParamLongCollection Class, ParamLongCollection Members, Autodesk::Civil::Runtime Namespace


ParamLongCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Properties
ParamLongCollection Properties
Collapse All

The properties of ParamLongCollection are listed here.

Public Properties
Public Property | Description
Count | This is Count, a member of class ParamLongCollection.
default | This is default, a member of class ParamLongCollection.
Links
Public Properties


ParamLongCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Properties > ParamLongCollection::Count Property
ParamLongCollection::Count Property
Collapse All

This is Count, a member of class ParamLongCollection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamLongCollection Class, ParamLongCollection Members, Autodesk::Civil::Runtime Namespace


ParamLongCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Properties > ParamLongCollection::default Property
ParamLongCollection::default Property
Collapse All

This is default, a member of class ParamLongCollection.

C#
public ParamLong default;
Visual Basic
Public Property default() As ParamLong
Links
ParamLongCollection Class, ParamLongCollection Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTarget Class

An offset target parameter.

Class Hierarchy
Autodesk::Civil::Runtime::ParamOffsetTarget
C#
public class ParamOffsetTarget : ParamBase<aeccParamTypeOffsetTarget,Autodesk::Civil::Roadway::DatabaseServices::WidthOffsetTarget^,AcDbObjectIdArray>;
Visual Basic
Public Class ParamOffsetTarget
Inherits ParamBase<aeccParamTypeOffsetTarget,Autodesk::Civil::Roadway::DatabaseServices::WidthOffsetTarget^,AcDbObjectIdArray>
Links
ParamOffsetTarget Properties, ParamOffsetTarget Members, Class Hierarchy


ParamOffsetTarget Members

The following tables list the members exposed by ParamOffsetTarget.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamOffsetTarget Properties

The properties of ParamOffsetTarget are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamOffsetTarget::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTarget Class > ParamOffsetTarget Properties > ParamOffsetTarget::Access Property
ParamOffsetTarget::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamOffsetTarget Class, ParamOffsetTarget Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTarget::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTarget Class > ParamOffsetTarget Properties > ParamOffsetTarget::Comment Property
ParamOffsetTarget::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamOffsetTarget Class, ParamOffsetTarget Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTarget::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTarget Class > ParamOffsetTarget Properties > ParamOffsetTarget::Description Property
ParamOffsetTarget::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamOffsetTarget Class, ParamOffsetTarget Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTarget::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTarget Class > ParamOffsetTarget Properties > ParamOffsetTarget::DisplayName Property
ParamOffsetTarget::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamOffsetTarget Class, ParamOffsetTarget Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTarget::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTarget Class > ParamOffsetTarget Properties > ParamOffsetTarget::DisplayOrder Property
ParamOffsetTarget::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamOffsetTarget Class, ParamOffsetTarget Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTarget::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTarget Class > ParamOffsetTarget Properties > ParamOffsetTarget::IsReadOnly Property
ParamOffsetTarget::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamOffsetTarget Class, ParamOffsetTarget Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTarget::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTarget Class > ParamOffsetTarget Properties > ParamOffsetTarget::Value Property
ParamOffsetTarget::Value Property
Collapse All

Gets or sets the parameter value.

C#
public Autodesk::Civil::Roadway::DatabaseServices::WidthOffsetTarget Value;
Visual Basic
Public Property Value() As Autodesk::Civil::Roadway::DatabaseServices::WidthOffsetTarget
Links
ParamOffsetTarget Class, ParamOffsetTarget Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTargetCollection Class

A collection of offset target parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamOffsetTargetCollection
C#
public class ParamOffsetTargetCollection : ParamCollectionBase<ParamOffsetTarget>;
Visual Basic
Public Class ParamOffsetTargetCollection
Inherits ParamCollectionBase<ParamOffsetTarget>
Links
ParamOffsetTargetCollection Methods, ParamOffsetTargetCollection Properties, ParamOffsetTargetCollection Members, Class Hierarchy


ParamOffsetTargetCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Members
ParamOffsetTargetCollection Members
Collapse All

The following tables list the members exposed by ParamOffsetTargetCollection.

Public Methods
Public Method | Description
Value | Overloaded
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Properties


ParamOffsetTargetCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Methods
ParamOffsetTargetCollection Methods
Collapse All

The methods of ParamOffsetTargetCollection are listed here.

Public Methods
Public Method | Description
Value | Overloaded
Links
Public Methods


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamOffsetTargetCollection::Value (int) | Gets the specified parameter.
ParamOffsetTargetCollection::Value (System::String^) | Gets the specified parameter.


ParamOffsetTargetCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Methods > Value Method > ParamOffsetTargetCollection::Value Method (System::String^)
ParamOffsetTargetCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamOffsetTarget::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamOffsetTarget::ValueType
Links
ParamOffsetTargetCollection Class, ParamOffsetTargetCollection Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTargetCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Methods > Value Method > ParamOffsetTargetCollection::Value Method (int)
ParamOffsetTargetCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamOffsetTarget::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamOffsetTarget::ValueType
Links
ParamOffsetTargetCollection Class, ParamOffsetTargetCollection Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTargetCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Properties
ParamOffsetTargetCollection Properties
Collapse All

The properties of ParamOffsetTargetCollection are listed here.

Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamOffsetTargetCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Properties > ParamOffsetTargetCollection::Count Property
ParamOffsetTargetCollection::Count Property
Collapse All

The number of parameters in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamOffsetTargetCollection Class, ParamOffsetTargetCollection Members, Autodesk::Civil::Runtime Namespace


ParamOffsetTargetCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Properties > ParamOffsetTargetCollection::default Property
ParamOffsetTargetCollection::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamOffsetTarget default;
Visual Basic
Public Property default() As ParamOffsetTarget
Links
ParamOffsetTargetCollection Class, ParamOffsetTargetCollection Members, Autodesk::Civil::Runtime Namespace


ParamPoint Class

A point parameter.

Class Hierarchy
Autodesk::Civil::Runtime::ParamPoint
C#
public class ParamPoint : ParamBase<aeccParamTypePoint3d,Autodesk::AutoCAD::Geometry::Point3d,AcGePoint3d>;
Visual Basic
Public Class ParamPoint
Inherits ParamBase<aeccParamTypePoint3d,Autodesk::AutoCAD::Geometry::Point3d,AcGePoint3d>
Links
ParamPoint Methods, ParamPoint Properties, ParamPoint Members, Class Hierarchy


ParamPoint Members

The following tables list the members exposed by ParamPoint.

Public Methods
Public Method | Description
GetPoint | Gets the station, offset, and elevation associated with the parameter.
SetPoint | Sets the station, offset, and elevation associated with the parameter.
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
Elevation | Gets or sets the elevation associated with the parameter.
IsReadOnly | Read only state for the parameter.
Offset | Gets or sets the offset associated with the parameter.
Station | Gets or sets the station associated with the parameter.
Value | Gets or sets the parameter value.
Links
Public Methods, Public Properties


ParamPoint Methods

The methods of ParamPoint are listed here.

Public Methods
Public Method | Description
GetPoint | Gets the station, offset, and elevation associated with the parameter.
SetPoint | Sets the station, offset, and elevation associated with the parameter.
Links
Public Methods


ParamPoint::GetPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Methods > ParamPoint::GetPoint Method
ParamPoint::GetPoint Method
Collapse All

Gets the station, offset, and elevation associated with the parameter.

C#
public GetPoint(
    double% station,
    double% offset,
    double% elevation
);
Visual Basic
Public Sub GetPoint(
    station As double%,
    offset As double%,
    elevation As double%
)
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::SetPoint Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Methods > ParamPoint::SetPoint Method
ParamPoint::SetPoint Method
Collapse All

Sets the station, offset, and elevation associated with the parameter.

C#
public SetPoint(
    double station,
    double offset,
    double elevation
);
Visual Basic
Public Sub SetPoint(
    station As double,
    offset As double,
    elevation As double
)
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint Properties

The properties of ParamPoint are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
Elevation | Gets or sets the elevation associated with the parameter.
IsReadOnly | Read only state for the parameter.
Offset | Gets or sets the offset associated with the parameter.
Station | Gets or sets the station associated with the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamPoint::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::Access Property
ParamPoint::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::Comment Property
ParamPoint::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::Description Property
ParamPoint::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::DisplayName Property
ParamPoint::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::DisplayOrder Property
ParamPoint::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::Elevation Property
ParamPoint::Elevation Property
Collapse All

Gets or sets the elevation associated with the parameter.

C#
public double Elevation;
Visual Basic
Public Property Elevation() As double
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::IsReadOnly Property
ParamPoint::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::Offset Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::Offset Property
ParamPoint::Offset Property
Collapse All

Gets or sets the offset associated with the parameter.

C#
public double Offset;
Visual Basic
Public Property Offset() As double
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::Station Property
ParamPoint::Station Property
Collapse All

Gets or sets the station associated with the parameter.

C#
public double Station;
Visual Basic
Public Property Station() As double
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPoint::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPoint Class > ParamPoint Properties > ParamPoint::Value Property
ParamPoint::Value Property
Collapse All

Gets or sets the parameter value.

C#
public Autodesk::AutoCAD::Geometry::Point3d Value;
Visual Basic
Public Property Value() As Autodesk::AutoCAD::Geometry::Point3d
Links
ParamPoint Class, ParamPoint Members, Autodesk::Civil::Runtime Namespace


ParamPointCollection Class

A collection of point parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamPointCollection
C#
public class ParamPointCollection : ParamCollectionBase<ParamPoint>;
Visual Basic
Public Class ParamPointCollection
Inherits ParamCollectionBase<ParamPoint>
Links
ParamPointCollection Methods, ParamPointCollection Properties, ParamPointCollection Members, Class Hierarchy


ParamPointCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Members
ParamPointCollection Members
Collapse All

The following tables list the members exposed by ParamPointCollection.

Public Methods
Public Method | Description
Add | Overloaded
Value | Overloaded
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Properties


ParamPointCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Methods
ParamPointCollection Methods
Collapse All

The methods of ParamPointCollection are listed here.

Public Methods
Public Method | Description
Add | Overloaded
Value | Overloaded
Links
Public Methods


Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Methods > Add Method
Add Method
Collapse All

Overloaded

Overload List
Method | Description
ParamPointCollection::Add (System::String^) | Adds a new item to parameters collection.
ParamPointCollection::Add (System::String^, Autodesk::AutoCAD::Geometry::Point3d) | Adds a new item to the parameters collection.


ParamPointCollection::Add Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Methods > Add Method > ParamPointCollection::Add Method (System::String^)
ParamPointCollection::Add Method (System::String^)
Collapse All

Adds a new item to parameters collection.

C#
public ParamPoint Add(
    ref System::String name
);
Visual Basic
Public Function Add(
    ByRef name As System::String
) As ParamPoint
Parameters
Parameters | Description
name | Name of the new parameter.
Remarks

If the input name exists in collection, this function will not add new item, instead it will return existing item and change its value.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when name is a empty string.
Links
ParamPointCollection Class, ParamPointCollection Members, Autodesk::Civil::Runtime Namespace


ParamPointCollection::Add Method (System::String^, Autodesk::AutoCAD::Geometry::Point3d)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Methods > Add Method > ParamPointCollection::Add Method (System::String^, Autodesk::AutoCAD::Geometry::Point3d)
ParamPointCollection::Add Method (System::String^, Autodesk::AutoCAD::Geometry::Point3d)
Collapse All

Adds a new item to the parameters collection.

C#
public ParamPoint Add(
    ref System::String name,
    Autodesk::AutoCAD::Geometry::Point3d value
);
Visual Basic
Public Function Add(
    ByRef name As System::String,
    value As Autodesk::AutoCAD::Geometry::Point3d
) As ParamPoint
Parameters
Parameters | Description
name | Name of the new parameter.
value | Value of the new parameter.
Remarks

If the input name exists in collection, this function will not add new item, instead it will return existing item and change its value.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when name is a empty string.
Links
ParamPointCollection Class, ParamPointCollection Members, Autodesk::Civil::Runtime Namespace


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamPointCollection::Value (int) | Gets the specified parameter.
ParamPointCollection::Value (System::String^) | Gets the specified parameter.


ParamPointCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Methods > Value Method > ParamPointCollection::Value Method (System::String^)
ParamPointCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamPoint::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamPoint::ValueType
Links
ParamPointCollection Class, ParamPointCollection Members, Autodesk::Civil::Runtime Namespace


ParamPointCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Methods > Value Method > ParamPointCollection::Value Method (int)
ParamPointCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamPoint::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamPoint::ValueType
Links
ParamPointCollection Class, ParamPointCollection Members, Autodesk::Civil::Runtime Namespace


ParamPointCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Properties
ParamPointCollection Properties
Collapse All

The properties of ParamPointCollection are listed here.

Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamPointCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Properties > ParamPointCollection::Count Property
ParamPointCollection::Count Property
Collapse All

The number of parameters in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamPointCollection Class, ParamPointCollection Members, Autodesk::Civil::Runtime Namespace


ParamPointCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Properties > ParamPointCollection::default Property
ParamPointCollection::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamPoint default;
Visual Basic
Public Property default() As ParamPoint
Links
ParamPointCollection Class, ParamPointCollection Members, Autodesk::Civil::Runtime Namespace


ParamProfile Class

A Profile parameter.

Class Hierarchy
Autodesk::Civil::Runtime::ParamProfile
C#
public class ParamProfile : ParamBase<aeccParamTypeProfile,Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,CastOpProfileId>;
Visual Basic
Public Class ParamProfile
Inherits ParamBase<aeccParamTypeProfile,Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,CastOpProfileId>
Links
ParamProfile Properties, ParamProfile Members, Class Hierarchy


ParamProfile Members

The following tables list the members exposed by ParamProfile.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamProfile Properties

The properties of ParamProfile are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamProfile::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfile Class > ParamProfile Properties > ParamProfile::Access Property
ParamProfile::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamProfile Class, ParamProfile Members, Autodesk::Civil::Runtime Namespace


ParamProfile::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfile Class > ParamProfile Properties > ParamProfile::Comment Property
ParamProfile::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamProfile Class, ParamProfile Members, Autodesk::Civil::Runtime Namespace


ParamProfile::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfile Class > ParamProfile Properties > ParamProfile::Description Property
ParamProfile::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamProfile Class, ParamProfile Members, Autodesk::Civil::Runtime Namespace


ParamProfile::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfile Class > ParamProfile Properties > ParamProfile::DisplayName Property
ParamProfile::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamProfile Class, ParamProfile Members, Autodesk::Civil::Runtime Namespace


ParamProfile::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfile Class > ParamProfile Properties > ParamProfile::DisplayOrder Property
ParamProfile::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamProfile Class, ParamProfile Members, Autodesk::Civil::Runtime Namespace


ParamProfile::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfile Class > ParamProfile Properties > ParamProfile::IsReadOnly Property
ParamProfile::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamProfile Class, ParamProfile Members, Autodesk::Civil::Runtime Namespace


ParamProfile::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfile Class > ParamProfile Properties > ParamProfile::Value Property
ParamProfile::Value Property
Collapse All

Gets or sets the parameter value.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Value;
Visual Basic
Public Property Value() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ParamProfile Class, ParamProfile Members, Autodesk::Civil::Runtime Namespace


ParamProfileCollection Class

A collection of profile parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamProfileCollection
C#
public class ParamProfileCollection : ParamCollectionBase<ParamProfile>;
Visual Basic
Public Class ParamProfileCollection
Inherits ParamCollectionBase<ParamProfile>
Links
ParamProfileCollection Methods, ParamProfileCollection Properties, ParamProfileCollection Members, Class Hierarchy


ParamProfileCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Members
ParamProfileCollection Members
Collapse All

The following tables list the members exposed by ParamProfileCollection.

Public Methods
Public Method | Description
Value | Overloaded
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Properties


ParamProfileCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Methods
ParamProfileCollection Methods
Collapse All

The methods of ParamProfileCollection are listed here.

Public Methods
Public Method | Description
Value | Overloaded
Links
Public Methods


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamProfileCollection::Value (int) | Gets the specified parameter.
ParamProfileCollection::Value (System::String^) | Gets the specified parameter.


ParamProfileCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Methods > Value Method > ParamProfileCollection::Value Method (System::String^)
ParamProfileCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamProfile::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamProfile::ValueType
Links
ParamProfileCollection Class, ParamProfileCollection Members, Autodesk::Civil::Runtime Namespace


ParamProfileCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Methods > Value Method > ParamProfileCollection::Value Method (int)
ParamProfileCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamProfile::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamProfile::ValueType
Links
ParamProfileCollection Class, ParamProfileCollection Members, Autodesk::Civil::Runtime Namespace


ParamProfileCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Properties
ParamProfileCollection Properties
Collapse All

The properties of ParamProfileCollection are listed here.

Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamProfileCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Properties > ParamProfileCollection::Count Property
ParamProfileCollection::Count Property
Collapse All

The number of parameters in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamProfileCollection Class, ParamProfileCollection Members, Autodesk::Civil::Runtime Namespace


ParamProfileCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Properties > ParamProfileCollection::default Property
ParamProfileCollection::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamProfile default;
Visual Basic
Public Property default() As ParamProfile
Links
ParamProfileCollection Class, ParamProfileCollection Members, Autodesk::Civil::Runtime Namespace


ParamString Class

A string parameter.

Class Hierarchy
Autodesk::Civil::Runtime::ParamString
C#
public class ParamString : ParamBase<aeccParamTypeString,System::String^,AecRmCString>;
Visual Basic
Public Class ParamString
Inherits ParamBase<aeccParamTypeString,System::String^,AecRmCString>
Links
ParamString Properties, ParamString Members, Class Hierarchy


ParamString Members

The following tables list the members exposed by ParamString.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamString Properties

The properties of ParamString are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamString::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamString Class > ParamString Properties > ParamString::Access Property
ParamString::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamString Class, ParamString Members, Autodesk::Civil::Runtime Namespace


ParamString::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamString Class > ParamString Properties > ParamString::Comment Property
ParamString::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamString Class, ParamString Members, Autodesk::Civil::Runtime Namespace


ParamString::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamString Class > ParamString Properties > ParamString::Description Property
ParamString::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamString Class, ParamString Members, Autodesk::Civil::Runtime Namespace


ParamString::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamString Class > ParamString Properties > ParamString::DisplayName Property
ParamString::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamString Class, ParamString Members, Autodesk::Civil::Runtime Namespace


ParamString::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamString Class > ParamString Properties > ParamString::DisplayOrder Property
ParamString::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamString Class, ParamString Members, Autodesk::Civil::Runtime Namespace


ParamString::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamString Class > ParamString Properties > ParamString::IsReadOnly Property
ParamString::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamString Class, ParamString Members, Autodesk::Civil::Runtime Namespace


ParamString::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamString Class > ParamString Properties > ParamString::Value Property
ParamString::Value Property
Collapse All

Gets or sets the parameter value.

C#
public System::String Value;
Visual Basic
Public Property Value() As System::String
Links
ParamString Class, ParamString Members, Autodesk::Civil::Runtime Namespace


ParamStringCollection Class

A collection of string parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamStringCollection
C#
public class ParamStringCollection : ParamCollectionBase<ParamString>;
Visual Basic
Public Class ParamStringCollection
Inherits ParamCollectionBase<ParamString>
Links
ParamStringCollection Methods, ParamStringCollection Properties, ParamStringCollection Members, Class Hierarchy


ParamStringCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Members
ParamStringCollection Members
Collapse All

The following tables list the members exposed by ParamStringCollection.

Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Properties


ParamStringCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Methods
ParamStringCollection Methods
Collapse All

The methods of ParamStringCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded
Links
Public Methods


ParamStringCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Methods > ParamStringCollection::Add Method
ParamStringCollection::Add Method
Collapse All

Adds a new item to parameters collection.

C#
public ParamString Add(
    ref System::String name,
    ref System::String value
);
Visual Basic
Public Function Add(
    ByRef name As System::String,
    ByRef value As System::String
) As ParamString
Parameters
Parameters | Description
name | Name of the new parameter.
value | Value of the new parameter.
Remarks

If the input name exists in the collection, this function will not add a new item. Instead it will return the existing item and change its value.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when name is an empty string.
Links
ParamStringCollection Class, ParamStringCollection Members, Autodesk::Civil::Runtime Namespace


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamStringCollection::Value (int) | Gets the specified parameter.
ParamStringCollection::Value (System::String^) | Gets the specified parameter.


ParamStringCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Methods > Value Method > ParamStringCollection::Value Method (System::String^)
ParamStringCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamString::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamString::ValueType
Links
ParamStringCollection Class, ParamStringCollection Members, Autodesk::Civil::Runtime Namespace


ParamStringCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Methods > Value Method > ParamStringCollection::Value Method (int)
ParamStringCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamString::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamString::ValueType
Links
ParamStringCollection Class, ParamStringCollection Members, Autodesk::Civil::Runtime Namespace


ParamStringCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Properties
ParamStringCollection Properties
Collapse All

The properties of ParamStringCollection are listed here.

Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamStringCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Properties > ParamStringCollection::Count Property
ParamStringCollection::Count Property
Collapse All

The number of parameters in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamStringCollection Class, ParamStringCollection Members, Autodesk::Civil::Runtime Namespace


ParamStringCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Properties > ParamStringCollection::default Property
ParamStringCollection::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamString default;
Visual Basic
Public Property default() As ParamString
Links
ParamStringCollection Class, ParamStringCollection Members, Autodesk::Civil::Runtime Namespace


ParamSurface Class

A Surface parameter.

Class Hierarchy
Autodesk::Civil::Runtime::ParamSurface
C#
public class ParamSurface : ParamBase<aeccParamTypeSurface,Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,CastOpSurfaceId>;
Visual Basic
Public Class ParamSurface
Inherits ParamBase<aeccParamTypeSurface,Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,CastOpSurfaceId>
Links
ParamSurface Properties, ParamSurface Members, Class Hierarchy


ParamSurface Members

The following tables list the members exposed by ParamSurface.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamSurface Properties

The properties of ParamSurface are listed here.

Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.
Links
Public Properties


ParamSurface::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurface Class > ParamSurface Properties > ParamSurface::Access Property
ParamSurface::Access Property
Collapse All

Access permissions for the parameter.

C#
public ParamAccessType Access;
Visual Basic
Public Property Access() As ParamAccessType
Links
ParamSurface Class, ParamSurface Members, Autodesk::Civil::Runtime Namespace


ParamSurface::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurface Class > ParamSurface Properties > ParamSurface::Comment Property
ParamSurface::Comment Property
Collapse All

Parameter comment.

C#
public System::String Comment;
Visual Basic
Public Property Comment() As System::String
Links
ParamSurface Class, ParamSurface Members, Autodesk::Civil::Runtime Namespace


ParamSurface::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurface Class > ParamSurface Properties > ParamSurface::Description Property
ParamSurface::Description Property
Collapse All

Parameter description.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
ParamSurface Class, ParamSurface Members, Autodesk::Civil::Runtime Namespace


ParamSurface::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurface Class > ParamSurface Properties > ParamSurface::DisplayName Property
ParamSurface::DisplayName Property
Collapse All

Display name for the parameter.

C#
public System::String DisplayName;
Visual Basic
Public Property DisplayName() As System::String
Links
ParamSurface Class, ParamSurface Members, Autodesk::Civil::Runtime Namespace


ParamSurface::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurface Class > ParamSurface Properties > ParamSurface::DisplayOrder Property
ParamSurface::DisplayOrder Property
Collapse All

Display order for the parameter.

C#
public System::UInt16 DisplayOrder;
Visual Basic
Public Property DisplayOrder() As System::UInt16
Links
ParamSurface Class, ParamSurface Members, Autodesk::Civil::Runtime Namespace


ParamSurface::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurface Class > ParamSurface Properties > ParamSurface::IsReadOnly Property
ParamSurface::IsReadOnly Property
Collapse All

Read only state for the parameter.

C#
public System::Boolean IsReadOnly;
Visual Basic
Public Property IsReadOnly() As System::Boolean
Links
ParamSurface Class, ParamSurface Members, Autodesk::Civil::Runtime Namespace


ParamSurface::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurface Class > ParamSurface Properties > ParamSurface::Value Property
ParamSurface::Value Property
Collapse All

Gets or sets the parameter value.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId Value;
Visual Basic
Public Property Value() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
ParamSurface Class, ParamSurface Members, Autodesk::Civil::Runtime Namespace


ParamSurfaceCollection Class

A collection of surface parameters.

Class Hierarchy
Autodesk::Civil::Runtime::ParamSurfaceCollection
C#
public class ParamSurfaceCollection : ParamCollectionBase<ParamSurface>;
Visual Basic
Public Class ParamSurfaceCollection
Inherits ParamCollectionBase<ParamSurface>
Links
ParamSurfaceCollection Methods, ParamSurfaceCollection Properties, ParamSurfaceCollection Members, Class Hierarchy


ParamSurfaceCollection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Members
ParamSurfaceCollection Members
Collapse All

The following tables list the members exposed by ParamSurfaceCollection.

Public Methods
Public Method | Description
Value | Overloaded
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Methods, Public Properties


ParamSurfaceCollection Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Methods
ParamSurfaceCollection Methods
Collapse All

The methods of ParamSurfaceCollection are listed here.

Public Methods
Public Method | Description
Value | Overloaded
Links
Public Methods


Value Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Methods > Value Method
Value Method
Collapse All

Overloaded

Overload List
Method | Description
ParamSurfaceCollection::Value (int) | Gets the specified parameter.
ParamSurfaceCollection::Value (System::String^) | Gets the specified parameter.


ParamSurfaceCollection::Value Method (System::String^)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Methods > Value Method > ParamSurfaceCollection::Value Method (System::String^)
ParamSurfaceCollection::Value Method (System::String^)
Collapse All

Gets the specified parameter.

C#
public ParamSurface::ValueType Value(
    ref System::String index
);
Visual Basic
Public Function Value(
    ByRef index As System::String
) As ParamSurface::ValueType
Links
ParamSurfaceCollection Class, ParamSurfaceCollection Members, Autodesk::Civil::Runtime Namespace


ParamSurfaceCollection::Value Method (int)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Methods > Value Method > ParamSurfaceCollection::Value Method (int)
ParamSurfaceCollection::Value Method (int)
Collapse All

Gets the specified parameter.

C#
public ParamSurface::ValueType Value(
    int index
);
Visual Basic
Public Function Value(
    index As Integer
) As ParamSurface::ValueType
Links
ParamSurfaceCollection Class, ParamSurfaceCollection Members, Autodesk::Civil::Runtime Namespace


ParamSurfaceCollection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Properties
ParamSurfaceCollection Properties
Collapse All

The properties of ParamSurfaceCollection are listed here.

Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.
Links
Public Properties


ParamSurfaceCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Properties > ParamSurfaceCollection::Count Property
ParamSurfaceCollection::Count Property
Collapse All

The number of parameters in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
ParamSurfaceCollection Class, ParamSurfaceCollection Members, Autodesk::Civil::Runtime Namespace


ParamSurfaceCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Properties > ParamSurfaceCollection::default Property
ParamSurfaceCollection::default Property
Collapse All

Gets the default parameter from the collection.

C#
public ParamSurface default;
Visual Basic
Public Property default() As ParamSurface
Links
ParamSurfaceCollection Class, ParamSurfaceCollection Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState Class

Contains the properties of the drawing's pipe network state.

Class Hierarchy
Autodesk::Civil::Runtime::RuntimeState
    Autodesk::Civil::Runtime::PipeNetworkState
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkState"))]
public class PipeNetworkState : RuntimeState;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbNetworkState"))>
Public Class PipeNetworkState
Inherits RuntimeState
Links
PipeNetworkState Methods, PipeNetworkState Properties, PipeNetworkState Members, Class Hierarchy


PipeNetworkState Members

The following tables list the members exposed by PipeNetworkState.

Public Methods
Public Method | Description
RuleResourceString | Resolves resource string ids defined inside the C3DPipeRules.DVB project.
SetAlignmentOnPart | Sets the specified parameter of alignment on the current part.
SetBoolOnPart | Sets the specified parameter of bool on the current part.
SetDoubleOnCurrentPart | Sets an double value on the current part for the specified parameter.
SetErrorMsgOnCurrentPart | Sets an error message on the current part for the specified parameter.
SetLongOnPart | Sets the specified parameter of long on the current part.
SetPointOnPart | Sets the specified parameter of point on the current part.
SetProfileOnPart | Sets the specified parameter of profile on the current part.
SetStringOnPart | Sets the specified parameter of string on the current part.
SetSurfaceOnPart | Sets the specified parameter of surface on the current part.
Public Properties
Public Property | Description
CurrentMacroName | Gets the current macro name.
CurrentMacroProject | Gets the current macro project.
CurrentPipeId | Gets the ID of the current pipe in the network.
CurrentStructureId | Gets the ID of the current structure in the network.
IsBreakingPipe | Gets the state if it's breaking a pipe
IsConnectingToStructure | Gets the state if it's connecting to a structure
IsCurrentPartBeingAdd | Gets the state if the current part is being added.
IsInLayoutMode | Returns whether the pipe network is in layout mode.
IsLayoutUpStream | Gets the state if 'upstream' is the current layout flow direction
LastPipeElevation | Gets or sets the elevation of the last pipe in the network.
ParamsBool | Gets a collection of parameters with boolean values associated with the network state.
ParamsDouble | Gets a collection of parameters with double values associated with the network state.
ParamsLong | Gets a collection of parameters with long values associated with the network state.
Links
Public Methods, Public Properties


PipeNetworkState Methods

The methods of PipeNetworkState are listed here.

Public Methods
Public Method | Description
RuleResourceString | Resolves resource string ids defined inside the C3DPipeRules.DVB project.
SetAlignmentOnPart | Sets the specified parameter of alignment on the current part.
SetBoolOnPart | Sets the specified parameter of bool on the current part.
SetDoubleOnCurrentPart | Sets an double value on the current part for the specified parameter.
SetErrorMsgOnCurrentPart | Sets an error message on the current part for the specified parameter.
SetLongOnPart | Sets the specified parameter of long on the current part.
SetPointOnPart | Sets the specified parameter of point on the current part.
SetProfileOnPart | Sets the specified parameter of profile on the current part.
SetStringOnPart | Sets the specified parameter of string on the current part.
SetSurfaceOnPart | Sets the specified parameter of surface on the current part.
Links
Public Methods


PipeNetworkState::RuleResourceString Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::RuleResourceString Method
PipeNetworkState::RuleResourceString Method
Collapse All

Resolves resource string ids defined inside the C3DPipeRules.DVB project.

C#
public System::String RuleResourceString(
    ref System::String resId
);
Visual Basic
Public Function RuleResourceString(
    ByRef resId As System::String
) As System::String
Parameters
Parameters | Description
resId | Resource string.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::SetAlignmentOnPart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::SetAlignmentOnPart Method
PipeNetworkState::SetAlignmentOnPart Method
Collapse All

Sets the specified parameter of alignment on the current part.

C#
public SetAlignmentOnPart(
    ref System::String paramName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId alignmentId
);
Visual Basic
Public Sub SetAlignmentOnPart(
    ByRef paramName As System::String,
    alignmentId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
paramName | The name of the parameter to set.
alignmentId | The value to assign to the parameter.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::SetBoolOnPart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::SetBoolOnPart Method
PipeNetworkState::SetBoolOnPart Method
Collapse All

Sets the specified parameter of bool on the current part.

C#
public SetBoolOnPart(
    ref System::String paramName,
    bool value
);
Visual Basic
Public Sub SetBoolOnPart(
    ByRef paramName As System::String,
    value As bool
)
Parameters
Parameters | Description
paramName | The name of the parameter to set.
value | The value to assign to the parameter.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::SetDoubleOnCurrentPart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::SetDoubleOnCurrentPart Method
PipeNetworkState::SetDoubleOnCurrentPart Method
Collapse All

Sets an double value on the current part for the specified parameter.

C#
public SetDoubleOnCurrentPart(
    ref System::String paramKey,
    double value
);
Visual Basic
Public Sub SetDoubleOnCurrentPart(
    ByRef paramKey As System::String,
    value As double
)
Parameters
Parameters | Description
paramKey | Name of the part parameter.
value | Value to assign to the specified part parameter.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::SetErrorMsgOnCurrentPart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::SetErrorMsgOnCurrentPart Method
PipeNetworkState::SetErrorMsgOnCurrentPart Method
Collapse All

Sets an error message on the current part for the specified parameter.

C#
public SetErrorMsgOnCurrentPart(
    ref System::String paramKey,
    ref System::String errorMessage
);
Visual Basic
Public Sub SetErrorMsgOnCurrentPart(
    ByRef paramKey As System::String,
    ByRef errorMessage As System::String
)
Parameters
Parameters | Description
paramKey | Name of the part parameter.
errorMessage | The error message.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::SetLongOnPart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::SetLongOnPart Method
PipeNetworkState::SetLongOnPart Method
Collapse All

Sets the specified parameter of long on the current part.

C#
public SetLongOnPart(
    ref System::String paramName,
    int value
);
Visual Basic
Public Sub SetLongOnPart(
    ByRef paramName As System::String,
    value As Integer
)
Parameters
Parameters | Description
paramName | The name of the parameter to set.
value | The value to assign to the parameter.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::SetPointOnPart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::SetPointOnPart Method
PipeNetworkState::SetPointOnPart Method
Collapse All

Sets the specified parameter of point on the current part.

C#
public SetPointOnPart(
    ref System::String paramName,
    Autodesk::AutoCAD::Geometry::Point3d value
);
Visual Basic
Public Sub SetPointOnPart(
    ByRef paramName As System::String,
    value As Autodesk::AutoCAD::Geometry::Point3d
)
Parameters
Parameters | Description
paramName | The name of the parameter to set.
value | The value to assign to the parameter.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::SetProfileOnPart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::SetProfileOnPart Method
PipeNetworkState::SetProfileOnPart Method
Collapse All

Sets the specified parameter of profile on the current part.

C#
public SetProfileOnPart(
    ref System::String paramName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId profileId
);
Visual Basic
Public Sub SetProfileOnPart(
    ByRef paramName As System::String,
    profileId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
paramName | The name of the parameter to set.
profileId | The value to assign to the parameter.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::SetStringOnPart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::SetStringOnPart Method
PipeNetworkState::SetStringOnPart Method
Collapse All

Sets the specified parameter of string on the current part.

C#
public SetStringOnPart(
    ref System::String paramName,
    ref System::String value
);
Visual Basic
Public Sub SetStringOnPart(
    ByRef paramName As System::String,
    ByRef value As System::String
)
Parameters
Parameters | Description
paramName | The name of the parameter to set.
value | The value to assign to the parameter.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::SetSurfaceOnPart Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Methods > PipeNetworkState::SetSurfaceOnPart Method
PipeNetworkState::SetSurfaceOnPart Method
Collapse All

Sets the specified parameter of surface on the current part.

C#
public SetSurfaceOnPart(
    ref System::String paramName,
    Autodesk::AutoCAD::DatabaseServices::ObjectId surfaceId
);
Visual Basic
Public Sub SetSurfaceOnPart(
    ByRef paramName As System::String,
    surfaceId As Autodesk::AutoCAD::DatabaseServices::ObjectId
)
Parameters
Parameters | Description
paramName | The name of the parameter to set.
surfaceId | The value to assign to the parameter.
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState Properties

The properties of PipeNetworkState are listed here.

Public Properties
Public Property | Description
CurrentPipeId | Gets the ID of the current pipe in the network.
CurrentStructureId | Gets the ID of the current structure in the network.
IsBreakingPipe | Gets the state if it's breaking a pipe
IsConnectingToStructure | Gets the state if it's connecting to a structure
IsCurrentPartBeingAdd | Gets the state if the current part is being added.
IsInLayoutMode | Returns whether the pipe network is in layout mode.
IsLayoutUpStream | Gets the state if 'upstream' is the current layout flow direction
LastPipeElevation | Gets or sets the elevation of the last pipe in the network.
ParamsBool | Gets a collection of parameters with boolean values associated with the network state.
ParamsDouble | Gets a collection of parameters with double values associated with the network state.
ParamsLong | Gets a collection of parameters with long values associated with the network state.
Links
Public Properties


PipeNetworkState::CurrentPipeId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::CurrentPipeId Property
PipeNetworkState::CurrentPipeId Property
Collapse All

Gets the ID of the current pipe in the network.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurrentPipeId;
Visual Basic
Public Property CurrentPipeId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::CurrentStructureId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::CurrentStructureId Property
PipeNetworkState::CurrentStructureId Property
Collapse All

Gets the ID of the current structure in the network.

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId CurrentStructureId;
Visual Basic
Public Property CurrentStructureId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::IsBreakingPipe Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::IsBreakingPipe Property
PipeNetworkState::IsBreakingPipe Property
Collapse All

Gets the state if it's breaking a pipe

C#
public bool IsBreakingPipe;
Visual Basic
Public Property IsBreakingPipe() As bool
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::IsConnectingToStructure Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::IsConnectingToStructure Property
PipeNetworkState::IsConnectingToStructure Property
Collapse All

Gets the state if it's connecting to a structure

C#
public bool IsConnectingToStructure;
Visual Basic
Public Property IsConnectingToStructure() As bool
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::IsCurrentPartBeingAdd Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::IsCurrentPartBeingAdd Property
PipeNetworkState::IsCurrentPartBeingAdd Property
Collapse All

Gets the state if the current part is being added.

C#
public bool IsCurrentPartBeingAdd;
Visual Basic
Public Property IsCurrentPartBeingAdd() As bool
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::IsInLayoutMode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::IsInLayoutMode Property
PipeNetworkState::IsInLayoutMode Property
Collapse All

Returns whether the pipe network is in layout mode.

C#
public bool IsInLayoutMode;
Visual Basic
Public Property IsInLayoutMode() As bool
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::IsLayoutUpStream Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::IsLayoutUpStream Property
PipeNetworkState::IsLayoutUpStream Property
Collapse All

Gets the state if 'upstream' is the current layout flow direction

C#
public bool IsLayoutUpStream;
Visual Basic
Public Property IsLayoutUpStream() As bool
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::LastPipeElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::LastPipeElevation Property
PipeNetworkState::LastPipeElevation Property
Collapse All

Gets or sets the elevation of the last pipe in the network.

C#
public double LastPipeElevation;
Visual Basic
Public Property LastPipeElevation() As double
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::ParamsBool Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::ParamsBool Property
PipeNetworkState::ParamsBool Property
Collapse All

Gets a collection of parameters with boolean values associated with the network state.

C#
public ParamBoolCollection ParamsBool;
Visual Basic
Public Property ParamsBool() As ParamBoolCollection
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::ParamsDouble Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::ParamsDouble Property
PipeNetworkState::ParamsDouble Property
Collapse All

Gets a collection of parameters with double values associated with the network state.

C#
public ParamDoubleCollection ParamsDouble;
Visual Basic
Public Property ParamsDouble() As ParamDoubleCollection
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


PipeNetworkState::ParamsLong Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > PipeNetworkState Class > PipeNetworkState Properties > PipeNetworkState::ParamsLong Property
PipeNetworkState::ParamsLong Property
Collapse All

Gets a collection of parameters with long values associated with the network state.

C#
public ParamLongCollection ParamsLong;
Visual Basic
Public Property ParamsLong() As ParamLongCollection
Links
PipeNetworkState Class, PipeNetworkState Members, Autodesk::Civil::Runtime Namespace


RuntimeState Class

Base class for objects containing user-defined parameters describing an object state.

Class Hierarchy
Autodesk::Civil::Runtime::RuntimeState
    Autodesk::Civil::Runtime::CorridorState
    Autodesk::Civil::Runtime::PipeNetworkState
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRuntimeState"))]
public class RuntimeState : CivilWrapper<AeccDbRuntimeState>;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbRuntimeState"))>
Public Class RuntimeState
Inherits CivilWrapper<AeccDbRuntimeState>
Links
RuntimeState Properties, RuntimeState Members, Class Hierarchy


RuntimeState Members

The following tables list the members exposed by RuntimeState.

Public Properties
Public Property | Description
CurrentMacroName | Gets the current macro name.
CurrentMacroProject | Gets the current macro project.
Links
Public Properties


RuntimeState Properties

The properties of RuntimeState are listed here.

Public Properties
Public Property | Description
CurrentMacroName | Gets the current macro name.
CurrentMacroProject | Gets the current macro project.
Links
Public Properties


RuntimeState::CurrentMacroName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > RuntimeState Class > RuntimeState Properties > RuntimeState::CurrentMacroName Property
RuntimeState::CurrentMacroName Property
Collapse All

Gets the current macro name.

C#
public System::String CurrentMacroName;
Visual Basic
Public Property CurrentMacroName() As System::String
Links
RuntimeState Class, RuntimeState Members, Autodesk::Civil::Runtime Namespace


RuntimeState::CurrentMacroProject Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > RuntimeState Class > RuntimeState Properties > RuntimeState::CurrentMacroProject Property
RuntimeState::CurrentMacroProject Property
Collapse All

Gets the current macro project.

C#
public System::String CurrentMacroProject;
Visual Basic
Public Property CurrentMacroProject() As System::String
Links
RuntimeState Class, RuntimeState Members, Autodesk::Civil::Runtime Namespace


Interfaces

The following table lists interfaces in this documentation.

Interfaces
Interface | Description
IParam | Interface for parameters.
Links
Interfaces


IParam Interface

Interface for parameters.

Class Hierarchy
Autodesk::Civil::Runtime::IParam
    Autodesk::Civil::Runtime::ParamBase
C#
public interface IParam;
Visual Basic
Public Interface IParam
Links
IParam Properties, IParam Members, Class Hierarchy


IParam Members

The following tables list the members exposed by IParam.

Public Properties
Public Property | Description
Access | Gets or sets access permissions for the parameter.
Comment | Gets or sets the comment string for the parameter.
Description | Gets or sets the description for the parameter.
DisplayName | Gets or sets the display name for the parameter.
DisplayOrder | Gets or sets the display order for the parameter.
IsReadOnly | Gets or sets whether the parameter is read-only.
Value | Gets or sets the parameter value.
Links
Public Properties


IParam Properties

The properties of IParam are listed here.

Public Properties
Public Property | Description
Access | Gets or sets access permissions for the parameter.
Comment | Gets or sets the comment string for the parameter.
Description | Gets or sets the description for the parameter.
DisplayName | Gets or sets the display name for the parameter.
DisplayOrder | Gets or sets the display order for the parameter.
IsReadOnly | Gets or sets whether the parameter is read-only.
Value | Gets or sets the parameter value.
Links
Public Properties


IParam::Access Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Interfaces > IParam Interface > IParam Properties > IParam::Access Property
IParam::Access Property
Collapse All

Gets or sets access permissions for the parameter.

C#
ParamAccessType Access;
Visual Basic
Property Access() As ParamAccessType
Links
IParam Interface, IParam Members, Autodesk::Civil::Runtime Namespace


IParam::Comment Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Interfaces > IParam Interface > IParam Properties > IParam::Comment Property
IParam::Comment Property
Collapse All

Gets or sets the comment string for the parameter.

C#
System::String Comment;
Visual Basic
Property Comment() As System::String
Links
IParam Interface, IParam Members, Autodesk::Civil::Runtime Namespace


IParam::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Interfaces > IParam Interface > IParam Properties > IParam::Description Property
IParam::Description Property
Collapse All

Gets or sets the description for the parameter.

C#
System::String Description;
Visual Basic
Property Description() As System::String
Links
IParam Interface, IParam Members, Autodesk::Civil::Runtime Namespace


IParam::DisplayName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Interfaces > IParam Interface > IParam Properties > IParam::DisplayName Property
IParam::DisplayName Property
Collapse All

Gets or sets the display name for the parameter.

C#
System::String DisplayName;
Visual Basic
Property DisplayName() As System::String
Links
IParam Interface, IParam Members, Autodesk::Civil::Runtime Namespace


IParam::DisplayOrder Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Interfaces > IParam Interface > IParam Properties > IParam::DisplayOrder Property
IParam::DisplayOrder Property
Collapse All

Gets or sets the display order for the parameter.

C#
System::UInt16 DisplayOrder;
Visual Basic
Property DisplayOrder() As System::UInt16
Links
IParam Interface, IParam Members, Autodesk::Civil::Runtime Namespace


IParam::IsReadOnly Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Interfaces > IParam Interface > IParam Properties > IParam::IsReadOnly Property
IParam::IsReadOnly Property
Collapse All

Gets or sets whether the parameter is read-only.

C#
System::Boolean IsReadOnly;
Visual Basic
Property IsReadOnly() As System::Boolean
Links
IParam Interface, IParam Members, Autodesk::Civil::Runtime Namespace


IParam::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Interfaces > IParam Interface > IParam Properties > IParam::Value Property
IParam::Value Property
Collapse All

Gets or sets the parameter value.

C#
Object Value;
Visual Basic
Property Value() As Object
Links
IParam Interface, IParam Members, Autodesk::Civil::Runtime Namespace


Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
CorridorError | Corridor error types.
CorridorErrorLevel | Error severity levels for Corridors.
CorridorLayoutModeDisplay | Layout modes for subassemblies.
CorridorMode | Roadway mode (design or layout).
ParamAccessType | Defines access permissions for a parameter.
ParamLogicalNameType | The Autodesk::Civil::Runtime::ParamLogicalNameType enumeration.
ParamScope | Defines the parameter scope.
ParamsOwnerType | Defines the owner type for a parameter.
ParamType | Defines the parameter type.
TypeInfoBool | The Autodesk::Civil::Runtime::TypeInfoBool enumeration.
TypeInfoDouble | The Autodesk::Civil::Runtime::TypeInfoDouble enumeration.
TypeInfoLong | The Autodesk::Civil::Runtime::TypeInfoLong enumeration.
Links
Enumerations


Autodesk::Civil::Runtime::CorridorError Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::CorridorError Enumeration
Autodesk::Civil::Runtime::CorridorError Enumeration
Collapse All

Corridor error types.

C#
public enum CorridorError {
  None = 0,
  Success = aeccRoadwayErrorSuccess,
  Failure = aeccRoadwayErrorFailure,
  CouldNotSolveInLayoutMode = aeccRoadwayErrorCouldNotSolveInLayoutMode,
  ParameterNotFound = aeccRoadwayErrorParameterNotFound,
  LogicalNameNotFound = aeccRoadwayErrorLogicalNameNotFound,
  NoSideslopeIntersectFound = aeccRoadwayErrorNoSideslopeIntersectFound,
  NoSubgradeIntersectFound = aeccRoadwayErrorNoSubgradeIntersectFound,
  ScriptModuleNotFound = aeccRoadwayErrorScriptModuleNotFound,
  ScriptMacroNotFound = aeccRoadwayErrorScriptMacroNotFound,
  CorridorStateNotFound = aeccRoadwayErrorRoadwayStateNotFound,
  ScriptPossibleSyntaxError = aeccRoadwayErrorScriptPossibleSyntaxError,
  StopProcessingGroup = aeccRoadwayErrorStopProcessingGroup,
  StopProcessingAssembly = aeccRoadwayErrorStopProcessingAssembly,
  StopProcessingRegion = aeccRoadwayErrorStopProcessingRegion,
  StopProcessingBaseline = aeccRoadwayErrorStopProcessingBaseline,
  StopProcessingCorridor = aeccRoadwayErrorStopProcessingCorridor,
  ElevationAtStationNotFound = aeccRoadwayErrorElevationAtStationNotFound,
  ScriptModulePathUpdated = aeccRoadwayErrorScriptModulePathUpdated,
  CorridorOutOfDate = aeccRoadwayErrorCorridorOutOfDate,
  ValueShouldNotBeLessThanOrEqualToZero = aeccRoadwayErrorValueShouldNotBeLessThanOrEqualToZero,
  ValueShouldNotBeLessThanZero = aeccRoadwayErrorValueShouldNotBeLessThanZero,
  ValueShouldNotBeZero = aeccRoadwayErrorValueShouldNotBeZero,
  ValueInABadPosition = aeccRoadwayErrorValueInABadPosition,
  ValueTooSmall = aeccRoadwayErrorValueTooSmall,
  ValueTooLarge = aeccRoadwayErrorValueTooLarge,
  NoLinkIntersectFound = aeccRoadwayErrorNoLinkIntersectFound,
  NoMarkedPointFound = aeccRoadwayErrorNoMarkedPointFound,
  ValueShouldNotBeOdd = aeccRoadwayErrorValueShouldNotBeOdd,
  InvalidArraySpecifiedForLinkDefinition = aeccRoadwayErrorInvalidArraySpecifiedForLinkDefinition,
  InvalidArraySpecifiedForLinkDefinitionFormat = aeccRoadwayErrorInvalidArraySpecifiedForLinkDefinitionFormat,
  InvalidArraySpecifiedForShapeDefinition = aeccRoadwayErrorInvalidArraySpecifiedForShapeDefinition,
  InvalidArraySpecifiedForShapeDefinitionFormat = aeccRoadwayErrorInvalidArraySpecifiedForShapeDefinitionFormat,
  InvalidCorridorStateObjectId = aeccRoadwayErrorInvalidRoadwayStateObjectId,
  InvalidSubassemblyCOMClassId = aeccRoadwayErrorInvalidSubassemblyCOMClassId,
  StopProcessingConditional = aeccRoadwayErrorStopProcessingConditional
}
Visual Basic
Public Enum CorridorError
  None = 0
  Success = aeccRoadwayErrorSuccess
  Failure = aeccRoadwayErrorFailure
  CouldNotSolveInLayoutMode = aeccRoadwayErrorCouldNotSolveInLayoutMode
  ParameterNotFound = aeccRoadwayErrorParameterNotFound
  LogicalNameNotFound = aeccRoadwayErrorLogicalNameNotFound
  NoSideslopeIntersectFound = aeccRoadwayErrorNoSideslopeIntersectFound
  NoSubgradeIntersectFound = aeccRoadwayErrorNoSubgradeIntersectFound
  ScriptModuleNotFound = aeccRoadwayErrorScriptModuleNotFound
  ScriptMacroNotFound = aeccRoadwayErrorScriptMacroNotFound
  CorridorStateNotFound = aeccRoadwayErrorRoadwayStateNotFound
  ScriptPossibleSyntaxError = aeccRoadwayErrorScriptPossibleSyntaxError
  StopProcessingGroup = aeccRoadwayErrorStopProcessingGroup
  StopProcessingAssembly = aeccRoadwayErrorStopProcessingAssembly
  StopProcessingRegion = aeccRoadwayErrorStopProcessingRegion
  StopProcessingBaseline = aeccRoadwayErrorStopProcessingBaseline
  StopProcessingCorridor = aeccRoadwayErrorStopProcessingCorridor
  ElevationAtStationNotFound = aeccRoadwayErrorElevationAtStationNotFound
  ScriptModulePathUpdated = aeccRoadwayErrorScriptModulePathUpdated
  CorridorOutOfDate = aeccRoadwayErrorCorridorOutOfDate
  ValueShouldNotBeLessThanOrEqualToZero = aeccRoadwayErrorValueShouldNotBeLessThanOrEqualToZero
  ValueShouldNotBeLessThanZero = aeccRoadwayErrorValueShouldNotBeLessThanZero
  ValueShouldNotBeZero = aeccRoadwayErrorValueShouldNotBeZero
  ValueInABadPosition = aeccRoadwayErrorValueInABadPosition
  ValueTooSmall = aeccRoadwayErrorValueTooSmall
  ValueTooLarge = aeccRoadwayErrorValueTooLarge
  NoLinkIntersectFound = aeccRoadwayErrorNoLinkIntersectFound
  NoMarkedPointFound = aeccRoadwayErrorNoMarkedPointFound
  ValueShouldNotBeOdd = aeccRoadwayErrorValueShouldNotBeOdd
  InvalidArraySpecifiedForLinkDefinition = aeccRoadwayErrorInvalidArraySpecifiedForLinkDefinition
  InvalidArraySpecifiedForLinkDefinitionFormat = aeccRoadwayErrorInvalidArraySpecifiedForLinkDefinitionFormat
  InvalidArraySpecifiedForShapeDefinition = aeccRoadwayErrorInvalidArraySpecifiedForShapeDefinition
  InvalidArraySpecifiedForShapeDefinitionFormat = aeccRoadwayErrorInvalidArraySpecifiedForShapeDefinitionFormat
  InvalidCorridorStateObjectId = aeccRoadwayErrorInvalidRoadwayStateObjectId
  InvalidSubassemblyCOMClassId = aeccRoadwayErrorInvalidSubassemblyCOMClassId
  StopProcessingConditional = aeccRoadwayErrorStopProcessingConditional
End Enum


Autodesk::Civil::Runtime::CorridorErrorLevel Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::CorridorErrorLevel Enumeration
Autodesk::Civil::Runtime::CorridorErrorLevel Enumeration
Collapse All

Error severity levels for Corridors.

C#
public enum CorridorErrorLevel {
  None = 0,
  Informational = aeccRoadwayErrorLevelInformational,
  AsWarning = aeccRoadwayErrorLevelWarning,
  Severe = aeccRoadwayErrorLevelSevere
}
Visual Basic
Public Enum CorridorErrorLevel
  None = 0
  Informational = aeccRoadwayErrorLevelInformational
  AsWarning = aeccRoadwayErrorLevelWarning
  Severe = aeccRoadwayErrorLevelSevere
End Enum


Autodesk::Civil::Runtime::CorridorLayoutModeDisplay Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::CorridorLayoutModeDisplay Enumeration
Autodesk::Civil::Runtime::CorridorLayoutModeDisplay Enumeration
Collapse All

Layout modes for subassemblies.

C#
public enum CorridorLayoutModeDisplay {
  General = aeccRoadwayLayoutModeDisplayGeneral,
  None = aeccRoadwayLayoutModeDisplayNone,
  Subgrade = aeccRoadwayLayoutModeDisplaySubgrade,
  Sideslope = aeccRoadwayLayoutModeDisplaySideslope,
  Conditional = aeccRoadwayLayoutModeDisplayConditional
}
Visual Basic
Public Enum CorridorLayoutModeDisplay
  General = aeccRoadwayLayoutModeDisplayGeneral
  None = aeccRoadwayLayoutModeDisplayNone
  Subgrade = aeccRoadwayLayoutModeDisplaySubgrade
  Sideslope = aeccRoadwayLayoutModeDisplaySideslope
  Conditional = aeccRoadwayLayoutModeDisplayConditional
End Enum


Autodesk::Civil::Runtime::CorridorMode Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::CorridorMode Enumeration
Autodesk::Civil::Runtime::CorridorMode Enumeration
Collapse All

Roadway mode (design or layout).

C#
public enum CorridorMode {
  None = 0,
  Layout = aeccRoadwayModeLayout,
  Design = aeccRoadwayModeDesign
}
Visual Basic
Public Enum CorridorMode
  None = 0
  Layout = aeccRoadwayModeLayout
  Design = aeccRoadwayModeDesign
End Enum


Autodesk::Civil::Runtime::ParamAccessType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::ParamAccessType Enumeration
Autodesk::Civil::Runtime::ParamAccessType Enumeration
Collapse All

Defines access permissions for a parameter.

C#
public enum ParamAccessType {
  None = 0,
  Input = aeccParamAccessInput,
  Output = aeccParamAccessOutput,
  InputAndOutput = aeccParamAccessInputAndOutput
}
Visual Basic
Public Enum ParamAccessType
  None = 0
  Input = aeccParamAccessInput
  Output = aeccParamAccessOutput
  InputAndOutput = aeccParamAccessInputAndOutput
End Enum


Autodesk::Civil::Runtime::ParamLogicalNameType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::ParamLogicalNameType Enumeration
Autodesk::Civil::Runtime::ParamLogicalNameType Enumeration
Collapse All

The Autodesk::Civil::Runtime::ParamLogicalNameType enumeration.

C#
public enum ParamLogicalNameType {
  None = 0,
  Surface = 1,
  Alignment = 2,
  Profile = 3,
  OffsetTarget = 4,
  ElevationTarget = 5,
  OffsetTargetPipe = 6,
  ElevationTargetPipe = 7
}
Visual Basic
Public Enum ParamLogicalNameType
  None = 0
  Surface = 1
  Alignment = 2
  Profile = 3
  OffsetTarget = 4
  ElevationTarget = 5
  OffsetTargetPipe = 6
  ElevationTargetPipe = 7
End Enum


Autodesk::Civil::Runtime::ParamScope Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::ParamScope Enumeration
Autodesk::Civil::Runtime::ParamScope Enumeration
Collapse All

Defines the parameter scope.

C#
public enum ParamScope {
  Local = 0,
  Global = 1
}
Visual Basic
Public Enum ParamScope
  Local = 0
  Global = 1
End Enum


Autodesk::Civil::Runtime::ParamsOwnerType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::ParamsOwnerType Enumeration
Autodesk::Civil::Runtime::ParamsOwnerType Enumeration
Collapse All

Defines the owner type for a parameter.

C#
public enum ParamsOwnerType {
  Subassembly,
  RoadwayState,
  PipeNetworkPart,
  PipeNetworkState,
  PipeNetworkRule
}
Visual Basic
Public Enum ParamsOwnerType
  Subassembly
  RoadwayState
  PipeNetworkPart
  PipeNetworkState
  PipeNetworkRule
End Enum


Autodesk::Civil::Runtime::ParamType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::ParamType Enumeration
Autodesk::Civil::Runtime::ParamType Enumeration
Collapse All

Defines the parameter type.

C#
public enum ParamType {
  Unknown = 0,
  Bool = 1,
  Int = 2,
  Double = 3,
  String = 4,
  Point3d = 5,
  Alignment = 6,
  Profile = 7,
  Surface = 8,
  OffsetTarget = 9,
  ElevationTarget = 10
}
Visual Basic
Public Enum ParamType
  Unknown = 0
  Bool = 1
  Int = 2
  Double = 3
  String = 4
  Point3d = 5
  Alignment = 6
  Profile = 7
  Surface = 8
  OffsetTarget = 9
  ElevationTarget = 10
End Enum


Autodesk::Civil::Runtime::TypeInfoBool Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::TypeInfoBool Enumeration
Autodesk::Civil::Runtime::TypeInfoBool Enumeration
Collapse All

The Autodesk::Civil::Runtime::TypeInfoBool enumeration.

C#
public enum TypeInfoBool {
  Bool = aeccTypeInfoBool,
  NoYes = aeccTypeInfoBoolNoYes,
  LabelTag = aeccTypeInfoBoolLabelTag,
  StraightSpline = aeccTypeInfoBoolStraightSpline,
  StackedText = aeccTypeInfoBoolStackedText,
  DisabledEnabled = aeccTypeInfoBoolDisabledEnabled,
  OffOn = aeccTypeInfoBoolOffOn,
  RightLeft = aeccTypeInfoBoolRightLeft,
  DecimalFractional = aeccTypeInfoBoolDecimalFractional,
  InOutCurve = aeccTypeInfoBoolInOutCurve
}
Visual Basic
Public Enum TypeInfoBool
  Bool = aeccTypeInfoBool
  NoYes = aeccTypeInfoBoolNoYes
  LabelTag = aeccTypeInfoBoolLabelTag
  StraightSpline = aeccTypeInfoBoolStraightSpline
  StackedText = aeccTypeInfoBoolStackedText
  DisabledEnabled = aeccTypeInfoBoolDisabledEnabled
  OffOn = aeccTypeInfoBoolOffOn
  RightLeft = aeccTypeInfoBoolRightLeft
  DecimalFractional = aeccTypeInfoBoolDecimalFractional
  InOutCurve = aeccTypeInfoBoolInOutCurve
End Enum


Autodesk::Civil::Runtime::TypeInfoDouble Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::TypeInfoDouble Enumeration
Autodesk::Civil::Runtime::TypeInfoDouble Enumeration
Collapse All

The Autodesk::Civil::Runtime::TypeInfoDouble enumeration.

C#
public enum TypeInfoDouble {
  Double = aeccTypeInfoDouble,
  NonNegativeDouble = aeccTypeInfoNonNegativeDouble,
  NonNegativeNonZeroDouble = aeccTypeInfoNonNegativeNonZeroDouble,
  NonPositiveDouble = aeccTypeInfoNonPositiveDouble,
  NonPositiveNonZeroDouble = aeccTypeInfoNonPositiveNonZeroDouble,
  NonZeroDouble = aeccTypeInfoNonZeroDouble,
  Station = aeccTypeInfoStation,
  DerivedStation = aeccTypeInfoDerivedStation,
  Grade = aeccTypeInfoGrade,
  TransparentCmdGrade = aeccTypeInfoTransparentCmdGrade,
  TransparentCmdSlope = aeccTypeInfoTransparentCmdSlope,
  Direction = aeccTypeInfoDirection,
  LatLong = aeccTypeInfoLatLong,
  Latitude = aeccTypeInfoLatitude,
  Angle = aeccTypeInfoAngle,
  ConvergenceAngle = aeccTypeInfoConvergenceAngle,
  Distance = aeccTypeInfoDistance,
  Dimension = aeccTypeInfoDimension,
  Coordinate = aeccTypeInfoCoordinate,
  XYCoordinatePair = aeccTypeInfoXYCoordinatePair,
  Area = aeccTypeInfoArea,
  Elevation = aeccTypeInfoElevation,
  ElevationPoint = aeccTypeInfoElevationPoint,
  PlotHeight = aeccTypeInfoPlotHeight,
  Volume = aeccTypeInfoVolume,
  Percent = aeccTypeInfoPercent,
  Azimuth = aeccTypeInfoAzimuth,
  Velocity = aeccTypeInfoVelocity,
  Acceleration = aeccTypeInfoAcceleration,
  Flow = aeccTypeInfoFlow
}
Visual Basic
Public Enum TypeInfoDouble
  Double = aeccTypeInfoDouble
  NonNegativeDouble = aeccTypeInfoNonNegativeDouble
  NonNegativeNonZeroDouble = aeccTypeInfoNonNegativeNonZeroDouble
  NonPositiveDouble = aeccTypeInfoNonPositiveDouble
  NonPositiveNonZeroDouble = aeccTypeInfoNonPositiveNonZeroDouble
  NonZeroDouble = aeccTypeInfoNonZeroDouble
  Station = aeccTypeInfoStation
  DerivedStation = aeccTypeInfoDerivedStation
  Grade = aeccTypeInfoGrade
  TransparentCmdGrade = aeccTypeInfoTransparentCmdGrade
  TransparentCmdSlope = aeccTypeInfoTransparentCmdSlope
  Direction = aeccTypeInfoDirection
  LatLong = aeccTypeInfoLatLong
  Latitude = aeccTypeInfoLatitude
  Angle = aeccTypeInfoAngle
  ConvergenceAngle = aeccTypeInfoConvergenceAngle
  Distance = aeccTypeInfoDistance
  Dimension = aeccTypeInfoDimension
  Coordinate = aeccTypeInfoCoordinate
  XYCoordinatePair = aeccTypeInfoXYCoordinatePair
  Area = aeccTypeInfoArea
  Elevation = aeccTypeInfoElevation
  ElevationPoint = aeccTypeInfoElevationPoint
  PlotHeight = aeccTypeInfoPlotHeight
  Volume = aeccTypeInfoVolume
  Percent = aeccTypeInfoPercent
  Azimuth = aeccTypeInfoAzimuth
  Velocity = aeccTypeInfoVelocity
  Acceleration = aeccTypeInfoAcceleration
  Flow = aeccTypeInfoFlow
End Enum


Autodesk::Civil::Runtime::TypeInfoLong Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Structs, Records, Enums > Autodesk::Civil::Runtime::TypeInfoLong Enumeration
Autodesk::Civil::Runtime::TypeInfoLong Enumeration
Collapse All

The Autodesk::Civil::Runtime::TypeInfoLong enumeration.

C#
public enum TypeInfoLong {
  Long = aeccTypeInfoLong,
  NonZeroLong = aeccTypeInfoNonZeroLong,
  NonNegativeLong = aeccTypeInfoNonNegativeLong,
  NonNegativeNonZeroLong = aeccTypeInfoNonNegativeNonZeroLong,
  NonPositiveLong = aeccTypeInfoNonPositiveLong,
  NonPositiveNonZeroLong = aeccTypeInfoNonPositiveNonZeroLong,
  Color = aeccTypeInfoColor,
  PDMODE = aeccTypeInfoPDMODE,
  LineWeight = aeccTypeInfoLineWeight
}
Visual Basic
Public Enum TypeInfoLong
  Long = aeccTypeInfoLong
  NonZeroLong = aeccTypeInfoNonZeroLong
  NonNegativeLong = aeccTypeInfoNonNegativeLong
  NonNegativeNonZeroLong = aeccTypeInfoNonNegativeNonZeroLong
  NonPositiveLong = aeccTypeInfoNonPositiveLong
  NonPositiveNonZeroLong = aeccTypeInfoNonPositiveNonZeroLong
  Color = aeccTypeInfoColor
  PDMODE = aeccTypeInfoPDMODE
  LineWeight = aeccTypeInfoLineWeight
End Enum


Autodesk::Civil::Settings Namespace

The Autodesk::Civil::Settings namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Classes
Class | Description
SettingsAbbreviation | Contains profile and alignment abbreviation strings as specified on the Abbreviations tab of the Drawing Settings dialog box.
SettingsAmbient | Specify default ambient (background) settings for units of measurement. These units are used throughout AutoCAD Civil 3D, unless they are... more
SettingsAmbient::SettingsAngle | Specify how to display deflection angles between two vectors.
SettingsAmbient::SettingsArea | Specify how to display surface areas.
SettingsAmbient::SettingsCoordinate | Specify how to display X and Y coordinates.
SettingsAmbient::SettingsDimension | Specify how to display linear dimensions.
SettingsAmbient::SettingsDirection | Specify how to display directions.
SettingsAmbient::SettingsDistance | Specify how to display linear distances.
SettingsAmbient::SettingsElevation | Specify how to display surface elevations.
SettingsAmbient::SettingsGeneral | Specify how to display text, numbers, and units.
SettingsAmbient::SettingsGrade | Specify how to display grade measurements.
SettingsAmbient::SettingsGradeSlope | Specify how to display grade and slope measurements.
SettingsAmbient::SettingsGridCoordinate | Specifies default (ambient) settings for grid coordinate values.
SettingsAmbient::SettingsLabeling | Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.
SettingsAmbient::SettingsLatLong | Specify how to display latitude and longitude.
SettingsAmbient::SettingsSlope | Specify how to display slope measurements.
SettingsAmbient::SettingsSpeed | Specify how to display speeds for design criteria.
SettingsAmbient::SettingsStation | Specify how to display linear features that use station or chainage.
SettingsAmbient::SettingsTransparentCommands | specify the prompting behavior of transparent commands across all features. The formats used to prompt for grade and slope values... more
SettingsAmbient::SettingsUnitless | These settings specify how to display numeric values that are not specifically defined by the unit type.
SettingsAmbient::SettingsVolume | Specify how to display terrain volumes.
SettingsCmdAddNoteLabel | Settings for AddNoteLabel command.
SettingsCmdAddSegmentLabel | Settings for AddSegmentLabel command.
SettingsCmdAddSegmentLabels | Settings for AddSegmentLabels command.
SettingsCmdCreateArcByBestFit | Settings for CreateArcByBestFit command.
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.
SettingsCmdCreateLineByBestFit | Settings for CreateLineByBestFit command.
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.
SettingsCmdCreateParabolaByBestFit | Settings for CreateParabolaByBestFit command.
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.
SettingsCmdMapCheck | Settings for MapCheck command.
SettingsCmdMapCheck::SettingsCmdMapcheck | Use these settings to specify the default behavior for Mapcheck.
SettingsCoordinateSystem | Encapsulates coordinate system settings.
SettingsDrawing | Contains settings that apply to the drawing, as specified in the Drawing Settings dialog box.
SettingsGeneral | Settings for General.
SettingsGeneral::SettingsStyles | Default styles settings class.
SettingsLandXML | Settings that define how data is imported from LandXML file.
SettingsLandXMLExport | Settings that define how data is exported from LandXML file.
SettingsLandXMLExport::SettingsAlignmentExport | Alignment Settings for LandXML export.
SettingsLandXMLExport::SettingsData | Data Settings for LandXML export.
SettingsLandXMLExport::SettingsIdentification | Identification Settings for LandXML export.
SettingsLandXMLExport::SettingsParcelExport | Parcel Settings for LandXML export.
SettingsLandXMLExport::SettingsPointExport | Point Settings for LandXML export.
SettingsLandXMLExport::SettingsSurfaceExport | Surface Settings for LandXML export.
SettingsLandXMLImport | Settings that define how data is imported from LandXML file.
SettingsLandXMLImport::SettingsConflictResolution | ConflictResolution settings for LandXML importing.
SettingsLandXMLImport::SettingsDiameterUnits | On import, AutoCAD Civil 3D reads the LandXML.Units.diameterUnits, and if they are defined, those units are used for both pipes... more
SettingsLandXMLImport::SettingsPipeNetwork | PipeNetwork settings for LandXML importing.
SettingsLandXMLImport::SettingsPointImport | PointImport settings for LandXML importing.
SettingsLandXMLImport::SettingsRotation | Rotation settings for LandXML importing.
SettingsLandXMLImport::SettingsSurfaceImport | SurfaceImport settings for LandXML importing.
SettingsLandXMLImport::SettingsTranslation | Translation settings for LandXML importing.
SettingsObjectLayer | SettingsObjectLayer class specifies layers for individual object in AutoCAD Civil 3D.
SettingsObjectLayers | The SettingsObjectLayers class is to specify layers for various objects in AutoCAD Civil 3D. For example, you can specify that... more
SettingsRoot | The root of the settings hierarchy.
SettingsTag | The Settings specify how line, curve and spiral components are numbered and renumbered.
SettingsTag::SettingsCreation | Settings of creation for the SettingsTag.
SettingsTag::SettingsRenumbering | Settings of renumbering for the SettingsTag.
SettingsTransformation | The SettingsTransformation class use to transform the coordinate system to local specifications.
SettingsUnitZone | The settings class for the unit zone.
Structs, Records, Enums
Struct, Record, Enum | Description
DrawingUnitType | Specifies the linear units (feet or meters) for drawing entities in AutoCAD model space.
GridScaleFactorType | Specifies the type of scale factor.
ImperialToMetricConversionType | Specifies the Imperial to Metric conversion type for the drawing.
LandXMLAngularUnits | Specifies the units of the exported angles and directions.
LandXMLAttributeExportType | Specifies the field that is used for specific attribute in the LandXML file.
LandXMLConflictResolutionType | Specifies how objects with the same name are handled.
LandXMLImperialUnitType | Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source... more
LandXMLLinearUnits | Specifies how to tag LandXML data when working in Imperial units.
LandXMLMetricUnitType | Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source... more
LandXMLPointDescriptionType | Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.
LandXMLSurfaceDataExportType | Specifies how to export the surface data.
LandXMLSurfaceDataImportType | Specifies how to import the data. NoteIf the LandXML surface you intend to import has only breaklines (for example, no... more
MapcheckAngleType | Definition of MapCheck Angle type.
MapcheckCurveDirectionType | Definition of MapCheck Curve Direction type.
MapcheckSideType | Definition of MapCheck side type.
MapcheckTraverseMethodType | Definition of MapCheck Traverse Method type.
ObjectLayerModifierType | Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.
SettingsObjectLayerType | The Autodesk::Civil::Settings::SettingsObjectLayerType enumeration.
SpecifyRotationType | An enumeration that use to specify a rotation about the reference point in one of two ways: specify a rotation... more
Links
Topics, Classes, Structs, Records, Enums


Classes

The following table lists classes in this documentation.

Classes
Class | Description
SettingsAbbreviation | Contains profile and alignment abbreviation strings as specified on the Abbreviations tab of the Drawing Settings dialog box.
SettingsAmbient | Specify default ambient (background) settings for units of measurement. These units are used throughout AutoCAD Civil 3D, unless they are... more
SettingsAmbient::SettingsAngle | Specify how to display deflection angles between two vectors.
SettingsAmbient::SettingsArea | Specify how to display surface areas.
SettingsAmbient::SettingsCoordinate | Specify how to display X and Y coordinates.
SettingsAmbient::SettingsDimension | Specify how to display linear dimensions.
SettingsAmbient::SettingsDirection | Specify how to display directions.
SettingsAmbient::SettingsDistance | Specify how to display linear distances.
SettingsAmbient::SettingsElevation | Specify how to display surface elevations.
SettingsAmbient::SettingsGeneral | Specify how to display text, numbers, and units.
SettingsAmbient::SettingsGrade | Specify how to display grade measurements.
SettingsAmbient::SettingsGradeSlope | Specify how to display grade and slope measurements.
SettingsAmbient::SettingsGridCoordinate | Specifies default (ambient) settings for grid coordinate values.
SettingsAmbient::SettingsLabeling | Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.
SettingsAmbient::SettingsLatLong | Specify how to display latitude and longitude.
SettingsAmbient::SettingsSlope | Specify how to display slope measurements.
SettingsAmbient::SettingsSpeed | Specify how to display speeds for design criteria.
SettingsAmbient::SettingsStation | Specify how to display linear features that use station or chainage.
SettingsAmbient::SettingsTransparentCommands | specify the prompting behavior of transparent commands across all features. The formats used to prompt for grade and slope values... more
SettingsAmbient::SettingsUnitless | These settings specify how to display numeric values that are not specifically defined by the unit type.
SettingsAmbient::SettingsVolume | Specify how to display terrain volumes.
SettingsCmdAddNoteLabel | Settings for AddNoteLabel command.
SettingsCmdAddSegmentLabel | Settings for AddSegmentLabel command.
SettingsCmdAddSegmentLabels | Settings for AddSegmentLabels command.
SettingsCmdCreateArcByBestFit | Settings for CreateArcByBestFit command.
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.
SettingsCmdCreateLineByBestFit | Settings for CreateLineByBestFit command.
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.
SettingsCmdCreateParabolaByBestFit | Settings for CreateParabolaByBestFit command.
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.
SettingsCmdMapCheck | Settings for MapCheck command.
SettingsCmdMapCheck::SettingsCmdMapcheck | Use these settings to specify the default behavior for Mapcheck.
SettingsCoordinateSystem | Encapsulates coordinate system settings.
SettingsDrawing | Contains settings that apply to the drawing, as specified in the Drawing Settings dialog box.
SettingsGeneral | Settings for General.
SettingsGeneral::SettingsStyles | Default styles settings class.
SettingsLandXML | Settings that define how data is imported from LandXML file.
SettingsLandXMLExport | Settings that define how data is exported from LandXML file.
SettingsLandXMLExport::SettingsAlignmentExport | Alignment Settings for LandXML export.
SettingsLandXMLExport::SettingsData | Data Settings for LandXML export.
SettingsLandXMLExport::SettingsIdentification | Identification Settings for LandXML export.
SettingsLandXMLExport::SettingsParcelExport | Parcel Settings for LandXML export.
SettingsLandXMLExport::SettingsPointExport | Point Settings for LandXML export.
SettingsLandXMLExport::SettingsSurfaceExport | Surface Settings for LandXML export.
SettingsLandXMLImport | Settings that define how data is imported from LandXML file.
SettingsLandXMLImport::SettingsConflictResolution | ConflictResolution settings for LandXML importing.
SettingsLandXMLImport::SettingsDiameterUnits | On import, AutoCAD Civil 3D reads the LandXML.Units.diameterUnits, and if they are defined, those units are used for both pipes... more
SettingsLandXMLImport::SettingsPipeNetwork | PipeNetwork settings for LandXML importing.
SettingsLandXMLImport::SettingsPointImport | PointImport settings for LandXML importing.
SettingsLandXMLImport::SettingsRotation | Rotation settings for LandXML importing.
SettingsLandXMLImport::SettingsSurfaceImport | SurfaceImport settings for LandXML importing.
SettingsLandXMLImport::SettingsTranslation | Translation settings for LandXML importing.
SettingsObjectLayer | SettingsObjectLayer class specifies layers for individual object in AutoCAD Civil 3D.
SettingsObjectLayers | The SettingsObjectLayers class is to specify layers for various objects in AutoCAD Civil 3D. For example, you can specify that... more
SettingsRoot | The root of the settings hierarchy.
SettingsTag | The Settings specify how line, curve and spiral components are numbered and renumbered.
SettingsTag::SettingsCreation | Settings of creation for the SettingsTag.
SettingsTag::SettingsRenumbering | Settings of renumbering for the SettingsTag.
SettingsTransformation | The SettingsTransformation class use to transform the coordinate system to local specifications.
SettingsUnitZone | The settings class for the unit zone.
Links
Classes


SettingsAbbreviation Class

Contains profile and alignment abbreviation strings as specified on the Abbreviations tab of the Drawing Settings dialog box.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAbbreviation
C#
public class SettingsAbbreviation : CivilWrapper<AcDbDatabase>;
Visual Basic
Public Class SettingsAbbreviation
Inherits CivilWrapper<AcDbDatabase>
Links
SettingsAbbreviation Properties, SettingsAbbreviation Members, Class Hierarchy


SettingsAbbreviation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Members
SettingsAbbreviation Members
Collapse All

The following tables list the members exposed by SettingsAbbreviation.

Public Properties
Public Property | Description
AlignmentGeoPointEntityData | Gets Abbreviation settings of Alignment Geometry Point Entity Data
AlignmentGeoPointText | Gets Abbreviation settings of Alignment Geometry Point Text
GeneralText | Gets Abbreviation settings that are not feature specific.
Profile | Gets Abbreviation settings of Profile
Superelevation | Gets Abbreviation settings of Superelevation
Links
Public Properties


SettingsAbbreviation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Properties
SettingsAbbreviation Properties
Collapse All

The properties of SettingsAbbreviation are listed here.

Public Properties
Public Property | Description
AlignmentGeoPointEntityData | Gets Abbreviation settings of Alignment Geometry Point Entity Data
AlignmentGeoPointText | Gets Abbreviation settings of Alignment Geometry Point Text
GeneralText | Gets Abbreviation settings that are not feature specific.
Profile | Gets Abbreviation settings of Profile
Superelevation | Gets Abbreviation settings of Superelevation
Links
Public Properties


SettingsAbbreviation::AlignmentGeoPointEntityData Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Properties > SettingsAbbreviation::AlignmentGeoPointEntityData Property
SettingsAbbreviation::AlignmentGeoPointEntityData Property
Collapse All

Gets Abbreviation settings of Alignment Geometry Point Entity Data

C#
public Autodesk::Civil::Land::Settings::SettingsAbbreviationAlignmentEnhanced AlignmentGeoPointEntityData;
Visual Basic
Public Property AlignmentGeoPointEntityData() As Autodesk::Civil::Land::Settings::SettingsAbbreviationAlignmentEnhanced
Links
SettingsAbbreviation Class, SettingsAbbreviation Members, Autodesk::Civil::Settings Namespace


SettingsAbbreviation::AlignmentGeoPointText Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Properties > SettingsAbbreviation::AlignmentGeoPointText Property
SettingsAbbreviation::AlignmentGeoPointText Property
Collapse All

Gets Abbreviation settings of Alignment Geometry Point Text

C#
public Autodesk::Civil::Land::Settings::SettingsAbbreviationAlignment AlignmentGeoPointText;
Visual Basic
Public Property AlignmentGeoPointText() As Autodesk::Civil::Land::Settings::SettingsAbbreviationAlignment
Links
SettingsAbbreviation Class, SettingsAbbreviation Members, Autodesk::Civil::Settings Namespace


SettingsAbbreviation::GeneralText Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Properties > SettingsAbbreviation::GeneralText Property
SettingsAbbreviation::GeneralText Property
Collapse All

Gets Abbreviation settings that are not feature specific.

C#
public SettingsAbbreviationGeneral GeneralText;
Visual Basic
Public Property GeneralText() As SettingsAbbreviationGeneral
Links
SettingsAbbreviation Class, SettingsAbbreviation Members, Autodesk::Civil::Settings Namespace


SettingsAbbreviation::Profile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Properties > SettingsAbbreviation::Profile Property
SettingsAbbreviation::Profile Property
Collapse All

Gets Abbreviation settings of Profile

C#
public Autodesk::Civil::Land::Settings::SettingsAbbreviationProfile Profile;
Visual Basic
Public Property Profile() As Autodesk::Civil::Land::Settings::SettingsAbbreviationProfile
Links
SettingsAbbreviation Class, SettingsAbbreviation Members, Autodesk::Civil::Settings Namespace


SettingsAbbreviation::Superelevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Properties > SettingsAbbreviation::Superelevation Property
SettingsAbbreviation::Superelevation Property
Collapse All

Gets Abbreviation settings of Superelevation

C#
public Autodesk::Civil::Land::Settings::SettingsAbbreviationSuperelevation Superelevation;
Visual Basic
Public Property Superelevation() As Autodesk::Civil::Land::Settings::SettingsAbbreviationSuperelevation
Links
SettingsAbbreviation Class, SettingsAbbreviation Members, Autodesk::Civil::Settings Namespace


SettingsAmbient Class

Specify default ambient (background) settings for units of measurement. These units are used throughout AutoCAD Civil 3D, unless they are overridden at the feature or command level.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
    Autodesk::Civil::Land::Settings::SettingsBuildingSite
    Autodesk::Civil::Land::Settings::SettingsGrading
    Autodesk::Civil::Land::Settings::SettingsMassHaulLine
    Autodesk::Civil::Land::Settings::SettingsMassHaulView
    Autodesk::Civil::Land::Settings::SettingsMatchLine
    Autodesk::Civil::Land::Settings::SettingsParcel
    Autodesk::Civil::Land::Settings::SettingsPoint
    Autodesk::Civil::Land::Settings::SettingsProfile
    Autodesk::Civil::Land::Settings::SettingsProfileView
    Autodesk::Civil::Land::Settings::SettingsSampleLine
    Autodesk::Civil::Land::Settings::SettingsSection
    Autodesk::Civil::Land::Settings::SettingsSectionView
    Autodesk::Civil::Land::Settings::SettingsSurface
    Autodesk::Civil::Land::Settings::SettingsViewFrame
    Autodesk::Civil::Land::Settings::SettingsViewFrameGroup
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipe
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
    Autodesk::Civil::PipeNetwork::Settings::SettingsStructure
    Autodesk::Civil::Roadway::Settings::SettingsAssembly
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
    Autodesk::Civil::Roadway::Settings::SettingsIntersection
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
    Autodesk::Civil::Roadway::Settings::SettingsSubassembly
    Autodesk::Civil::Settings::SettingsGeneral
    Autodesk::Civil::Survey::Settings::SettingsSurvey
C#
public class SettingsAmbient : TreeOidWrapper;
Visual Basic
Public Class SettingsAmbient
Inherits TreeOidWrapper
Links
SettingsAmbient Classes, SettingsAmbient Templates, SettingsAmbient Properties, SettingsAmbient Members, Class Hierarchy


SettingsAmbient Members

The following tables list the members exposed by SettingsAmbient.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsAmbient Classes

The classes of SettingsAmbient are listed here.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Links
Classes


SettingsAmbient::SettingsUnitlessNumber Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class
SettingsAmbient::SettingsUnitlessNumber Class
Collapse All

Representing a unitless number's settings, this is the base class for many other number based measurement

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsUnitlessNumber
C#
public class SettingsUnitlessNumber : TreeOidWrapper;
Visual Basic
Public Class SettingsUnitlessNumber
Inherits TreeOidWrapper
Links
SettingsUnitlessNumber Properties, SettingsUnitlessNumber Members, Class Hierarchy


SettingsUnitlessNumber Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class > SettingsUnitlessNumber Members
SettingsUnitlessNumber Members
Collapse All

The following tables list the members exposed by SettingsUnitlessNumber.

Public Properties
Public Property | Description
Precision | Specifies the number of digits to show to the right of the decimal.
Rounding | Specifies how numbers are rounded up or down to the number of decimal places specified in Precision.
Sign | Specifies how to mark numbers as positive or negative.
Links
Public Properties


SettingsUnitlessNumber Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class > SettingsUnitlessNumber Properties
SettingsUnitlessNumber Properties
Collapse All

The properties of SettingsUnitlessNumber are listed here.

Public Properties
Public Property | Description
Precision | Specifies the number of digits to show to the right of the decimal.
Rounding | Specifies how numbers are rounded up or down to the number of decimal places specified in Precision.
Sign | Specifies how to mark numbers as positive or negative.
Links
Public Properties


SettingsAmbient::SettingsUnitlessNumber::Precision Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class > SettingsUnitlessNumber Properties > SettingsAmbient::SettingsUnitlessNumber::Precision Property
SettingsAmbient::SettingsUnitlessNumber::Precision Property
Collapse All

Specifies the number of digits to show to the right of the decimal.

C#
public PropertyInt Precision;
Visual Basic
Public Property Precision() As PropertyInt
Links
SettingsAmbient::SettingsUnitlessNumber Class, SettingsUnitlessNumber Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsUnitlessNumber::Rounding Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class > SettingsUnitlessNumber Properties > SettingsAmbient::SettingsUnitlessNumber::Rounding Property
SettingsAmbient::SettingsUnitlessNumber::Rounding Property
Collapse All

Specifies how numbers are rounded up or down to the number of decimal places specified in Precision.

C#
public PropertyEnum<RoundingType> Rounding;
Visual Basic
Public Property Rounding() As PropertyEnum<RoundingType>
Links
SettingsAmbient::SettingsUnitlessNumber Class, SettingsUnitlessNumber Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsUnitlessNumber::Sign Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class > SettingsUnitlessNumber Properties > SettingsAmbient::SettingsUnitlessNumber::Sign Property
SettingsAmbient::SettingsUnitlessNumber::Sign Property
Collapse All

Specifies how to mark numbers as positive or negative.

C#
public PropertyEnum<SignType> Sign;
Visual Basic
Public Property Sign() As PropertyEnum<SignType>
Links
SettingsAmbient::SettingsUnitlessNumber Class, SettingsUnitlessNumber Members, Autodesk::Civil::Settings Namespace


SettingsAmbient Templates

The templates of SettingsAmbient are listed here.

Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Templates


SettingsAmbient::SettingsFormatNumber Template

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsFormatNumber Template
SettingsAmbient::SettingsFormatNumber Template
Collapse All

Representing a formattable number's settings, this is the base class for many other formattable number measurement.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsFormatNumber
C#
public class SettingsFormatNumber<typename TFormat> : SettingsUnitlessNumber where TFormat :;
Visual Basic
Public Class SettingsFormatNumber(Of typename TFormat)
Inherits SettingsUnitlessNumber
Links
SettingsFormatNumber Properties, SettingsFormatNumber Members, Class Hierarchy


SettingsFormatNumber Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsFormatNumber Template > SettingsFormatNumber Members
SettingsFormatNumber Members
Collapse All

The following tables list the members exposed by SettingsFormatNumber.

Public Properties
Public Property | Description
Format | Specifies the format of the measurement.
Links
Public Properties


SettingsFormatNumber Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsFormatNumber Template > SettingsFormatNumber Properties
SettingsFormatNumber Properties
Collapse All

The properties of SettingsFormatNumber are listed here.

Public Properties
Public Property | Description
Format | Specifies the format of the measurement.
Links
Public Properties


SettingsAmbient::SettingsFormatNumber::Format Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsFormatNumber Template > SettingsFormatNumber Properties > SettingsAmbient::SettingsFormatNumber::Format Property
SettingsAmbient::SettingsFormatNumber::Format Property
Collapse All

Specifies the format of the measurement.

C#
public PropertyEnum<TFormat> Format;
Visual Basic
Public Property Format() As PropertyEnum<TFormat>
Links
SettingsAmbient::SettingsFormatNumber Template, SettingsFormatNumber Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsUnitNumber Template

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsUnitNumber Template
SettingsAmbient::SettingsUnitNumber Template
Collapse All

Representing a unit number's settings, this is the base class for many other unit number based measurement

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsUnitNumber
C#
public class SettingsUnitNumber<typename TUnit> : SettingsUnitlessNumber where TUnit :;
Visual Basic
Public Class SettingsUnitNumber(Of typename TUnit)
Inherits SettingsUnitlessNumber
Links
SettingsUnitNumber Properties, SettingsUnitNumber Members, Class Hierarchy


SettingsUnitNumber Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsUnitNumber Template > SettingsUnitNumber Members
SettingsUnitNumber Members
Collapse All

The following tables list the members exposed by SettingsUnitNumber.

Public Properties
Public Property | Description
Unit | Specifies the unit of the measurement.
Links
Public Properties


SettingsUnitNumber Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsUnitNumber Template > SettingsUnitNumber Properties
SettingsUnitNumber Properties
Collapse All

The properties of SettingsUnitNumber are listed here.

Public Properties
Public Property | Description
Unit | Specifies the unit of the measurement.
Links
Public Properties


SettingsAmbient::SettingsUnitNumber::Unit Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsUnitNumber Template > SettingsUnitNumber Properties > SettingsAmbient::SettingsUnitNumber::Unit Property
SettingsAmbient::SettingsUnitNumber::Unit Property
Collapse All

Specifies the unit of the measurement.

C#
public PropertyEnum<TUnit> Unit;
Visual Basic
Public Property Unit() As PropertyEnum<TUnit>
Links
SettingsAmbient::SettingsUnitNumber Template, SettingsUnitNumber Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::TUnit Template

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template
SettingsAmbient::TUnit Template
Collapse All

Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::TUnit
C#
public class TUnit<typename TUnit, typename TFormat> : SettingsUnitlessNumber where TFormat :;
Visual Basic
Public Class TUnit(Of typename TUnit, typename TFormat)
Inherits SettingsUnitlessNumber
Links
TUnit Properties, TUnit Members, Class Hierarchy


TUnit Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template > TUnit Members
TUnit Members
Collapse All

The following tables list the members exposed by TUnit.

Public Properties
Public Property | Description
Format | Specifies the format of the measurement.
Unit | Specifies the unit of the measurement.
Links
Public Properties


TUnit Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template > TUnit Properties
TUnit Properties
Collapse All

The properties of TUnit are listed here.

Public Properties
Public Property | Description
Format | Specifies the format of the measurement.
Unit | Specifies the unit of the measurement.
Links
Public Properties


SettingsAmbient::TUnit::Format Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template > TUnit Properties > SettingsAmbient::TUnit::Format Property
SettingsAmbient::TUnit::Format Property
Collapse All

Specifies the format of the measurement.

C#
public PropertyEnum<TFormat> Format;
Visual Basic
Public Property Format() As PropertyEnum<TFormat>
Links
SettingsAmbient::TUnit Template, TUnit Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::TUnit::Unit Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template > TUnit Properties > SettingsAmbient::TUnit::Unit Property
SettingsAmbient::TUnit::Unit Property
Collapse All

Specifies the unit of the measurement.

C#
public PropertyEnum<TUnit> Unit;
Visual Basic
Public Property Unit() As PropertyEnum<TUnit>
Links
SettingsAmbient::TUnit Template, TUnit Members, Autodesk::Civil::Settings Namespace


SettingsAmbient Properties

The properties of SettingsAmbient are listed here.

Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Links
Public Properties


SettingsAmbient::Angle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Angle Property
SettingsAmbient::Angle Property
Collapse All

The Angle settings

C#
public SettingsAngle Angle;
Visual Basic
Public Property Angle() As SettingsAngle
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Area Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Area Property
SettingsAmbient::Area Property
Collapse All

The Area settings

C#
public SettingsArea Area;
Visual Basic
Public Property Area() As SettingsArea
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Coordinate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Coordinate Property
SettingsAmbient::Coordinate Property
Collapse All

The Coordinate settings

C#
public SettingsCoordinate Coordinate;
Visual Basic
Public Property Coordinate() As SettingsCoordinate
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Dimension Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Dimension Property
SettingsAmbient::Dimension Property
Collapse All

The Dimension settings

C#
public SettingsDimension Dimension;
Visual Basic
Public Property Dimension() As SettingsDimension
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Direction Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Direction Property
SettingsAmbient::Direction Property
Collapse All

The Direction settings

C#
public SettingsDirection Direction;
Visual Basic
Public Property Direction() As SettingsDirection
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Distance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Distance Property
SettingsAmbient::Distance Property
Collapse All

The Distance settings

C#
public SettingsDistance Distance;
Visual Basic
Public Property Distance() As SettingsDistance
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Elevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Elevation Property
SettingsAmbient::Elevation Property
Collapse All

The Elevation settings

C#
public SettingsElevation Elevation;
Visual Basic
Public Property Elevation() As SettingsElevation
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::General Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::General Property
SettingsAmbient::General Property
Collapse All

The General settings

C#
public SettingsGeneral General;
Visual Basic
Public Property General() As SettingsGeneral
Remarks

Some properties in UI are not exposed in API, because they are readonly and should be set in other places. Including: Drawing Unit displays the linear units that are used in the model space of the drawing. Set this value on the Units And Zone tab of this dialog box. Drawing Scale displays the intended plot scale. Set this value on the Units And Zone tab of this dialog box. Scale Inserted Objects displays whether objects are scaled when they are inserted from other drawings. Set this value on the Units And Zone tab of this dialog box. Independent Layer On has the same effect as the Immediate And Independent Layer On/Off Control Of Display Components setting on the Object Layers tab.

Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Grade Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Grade Property
SettingsAmbient::Grade Property
Collapse All

The Grade settings

C#
public SettingsGrade Grade;
Visual Basic
Public Property Grade() As SettingsGrade
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::GradeSlope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::GradeSlope Property
SettingsAmbient::GradeSlope Property
Collapse All

The GradeSlope settings

C#
public SettingsGradeSlope GradeSlope;
Visual Basic
Public Property GradeSlope() As SettingsGradeSlope
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::GridCoordinate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::GridCoordinate Property
SettingsAmbient::GridCoordinate Property
Collapse All

The GridCoordinate settings

C#
public SettingsGridCoordinate GridCoordinate;
Visual Basic
Public Property GridCoordinate() As SettingsGridCoordinate
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Labeling Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Labeling Property
SettingsAmbient::Labeling Property
Collapse All

The Labeling settings

C#
public SettingsLabeling Labeling;
Visual Basic
Public Property Labeling() As SettingsLabeling
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::LatLong Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::LatLong Property
SettingsAmbient::LatLong Property
Collapse All

The LatLong settings

C#
public SettingsLatLong LatLong;
Visual Basic
Public Property LatLong() As SettingsLatLong
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Slope Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Slope Property
SettingsAmbient::Slope Property
Collapse All

The Slope settings

C#
public SettingsSlope Slope;
Visual Basic
Public Property Slope() As SettingsSlope
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Speed Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Speed Property
SettingsAmbient::Speed Property
Collapse All

The Speed settings

C#
public SettingsSpeed Speed;
Visual Basic
Public Property Speed() As SettingsSpeed
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Station Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Station Property
SettingsAmbient::Station Property
Collapse All

The Station settings

C#
public SettingsStation Station;
Visual Basic
Public Property Station() As SettingsStation
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::TransparentCommands Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::TransparentCommands Property
SettingsAmbient::TransparentCommands Property
Collapse All

The TransparentCommands settings

C#
public SettingsTransparentCommands TransparentCommands;
Visual Basic
Public Property TransparentCommands() As SettingsTransparentCommands
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Unitless Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Unitless Property
SettingsAmbient::Unitless Property
Collapse All

The Unitless settings

C#
public SettingsUnitless Unitless;
Visual Basic
Public Property Unitless() As SettingsUnitless
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::Volume Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Properties > SettingsAmbient::Volume Property
SettingsAmbient::Volume Property
Collapse All

The Volume settings

C#
public SettingsVolume Volume;
Visual Basic
Public Property Volume() As SettingsVolume
Links
SettingsAmbient Class, SettingsAmbient Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsAngle Class

Specify how to display deflection angles between two vectors.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsAngle
C#
public class SettingsAmbient::SettingsAngle : SettingsUnitFormatNumber<AngleUnitType, AngleFormatType>;
Visual Basic
Public Class SettingsAmbient::SettingsAngle
Inherits SettingsUnitFormatNumber<AngleUnitType, AngleFormatType>
Links
SettingsAmbient::SettingsAngle Properties, SettingsAmbient::SettingsAngle Members, Class Hierarchy


SettingsAmbient::SettingsAngle Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsAngle Class > SettingsAmbient::SettingsAngle Members
SettingsAmbient::SettingsAngle Members
Collapse All

The following tables list the members exposed by SettingsAmbient::SettingsAngle.

Public Properties
Public Property | Description
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.
Links
Public Properties


SettingsAmbient::SettingsAngle Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsAngle Class > SettingsAmbient::SettingsAngle Properties
SettingsAmbient::SettingsAngle Properties
Collapse All

The properties of SettingsAmbient::SettingsAngle are listed here.

Public Properties
Public Property | Description
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.
Links
Public Properties


SettingsAmbient::SettingsAngle::DropDecimalForWholeNumbers Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsAngle Class > SettingsAmbient::SettingsAngle Properties > SettingsAmbient::SettingsAngle::DropDecimalForWholeNumbers Property
SettingsAmbient::SettingsAngle::DropDecimalForWholeNumbers Property
Collapse All

Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)

C#
public PropertyEnum<DropDecimalWholeType> DropDecimalForWholeNumbers;
Visual Basic
Public Property DropDecimalForWholeNumbers() As PropertyEnum<DropDecimalWholeType>
Links
SettingsAmbient::SettingsAngle Class, SettingsAmbient::SettingsAngle Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsAngle::DropLeadingZerosForDegrees Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsAngle Class > SettingsAmbient::SettingsAngle Properties > SettingsAmbient::SettingsAngle::DropLeadingZerosForDegrees Property
SettingsAmbient::SettingsAngle::DropLeadingZerosForDegrees Property
Collapse All

Drops leading zeros before values less than 10.

C#
public PropertyEnum<DropLeadingZeroType> DropLeadingZerosForDegrees;
Visual Basic
Public Property DropLeadingZerosForDegrees() As PropertyEnum<DropLeadingZeroType>
Links
SettingsAmbient::SettingsAngle Class, SettingsAmbient::SettingsAngle Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsArea Class

Specify how to display surface areas.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsArea
C#
public class SettingsAmbient::SettingsArea : SettingsUnitNumber<AreaUnitType>;
Visual Basic
Public Class SettingsAmbient::SettingsArea
Inherits SettingsUnitNumber<AreaUnitType>
Links
Class Hierarchy


SettingsAmbient::SettingsCoordinate Class

Specify how to display X and Y coordinates.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsCoordinate
C#
public class SettingsAmbient::SettingsCoordinate : SettingsUnitNumber<LinearUnitType>;
Visual Basic
Public Class SettingsAmbient::SettingsCoordinate
Inherits SettingsUnitNumber<LinearUnitType>
Links
Class Hierarchy


SettingsAmbient::SettingsDimension Class

Specify how to display linear dimensions.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsDimension
C#
public class SettingsAmbient::SettingsDimension : SettingsUnitNumber<LinearUnitType>;
Visual Basic
Public Class SettingsAmbient::SettingsDimension
Inherits SettingsUnitNumber<LinearUnitType>
Links
Class Hierarchy


SettingsAmbient::SettingsDirection Class

Specify how to display directions.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsDirection
C#
public class SettingsAmbient::SettingsDirection : SettingsUnitFormatNumber<AngleUnitType, AngleFormatType>;
Visual Basic
Public Class SettingsAmbient::SettingsDirection
Inherits SettingsUnitFormatNumber<AngleUnitType, AngleFormatType>
Links
SettingsAmbient::SettingsDirection Properties, SettingsAmbient::SettingsDirection Members, Class Hierarchy


SettingsAmbient::SettingsDirection Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Members
SettingsAmbient::SettingsDirection Members
Collapse All

The following tables list the members exposed by SettingsAmbient::SettingsDirection.

Public Properties
Public Property | Description
BearingQuadrant | Specifies which bearing quadrant to use.
Capitalization | Specifies how to display direction names.
Direction | Specify how to display directions.
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.
MeasurementType | Specifies how to calculate the direction of a vector.
Links
Public Properties


SettingsAmbient::SettingsDirection Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Properties
SettingsAmbient::SettingsDirection Properties
Collapse All

The properties of SettingsAmbient::SettingsDirection are listed here.

Public Properties
Public Property | Description
BearingQuadrant | Specifies which bearing quadrant to use.
Capitalization | Specifies how to display direction names.
Direction | Specify how to display directions.
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.
MeasurementType | Specifies how to calculate the direction of a vector.
Links
Public Properties


SettingsAmbient::SettingsDirection::BearingQuadrant Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Properties > SettingsAmbient::SettingsDirection::BearingQuadrant Property
SettingsAmbient::SettingsDirection::BearingQuadrant Property
Collapse All

Specifies which bearing quadrant to use.

C#
public PropertyEnum<BearingQuadrantType> BearingQuadrant;
Visual Basic
Public Property BearingQuadrant() As PropertyEnum<BearingQuadrantType>
Links
SettingsAmbient::SettingsDirection Class, SettingsAmbient::SettingsDirection Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsDirection::Capitalization Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Properties > SettingsAmbient::SettingsDirection::Capitalization Property
SettingsAmbient::SettingsDirection::Capitalization Property
Collapse All

Specifies how to display direction names.

C#
public PropertyEnum<DirectionNameDisplayType> Capitalization;
Visual Basic
Public Property Capitalization() As PropertyEnum<DirectionNameDisplayType>
Links
SettingsAmbient::SettingsDirection Class, SettingsAmbient::SettingsDirection Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsDirection::Direction Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Properties > SettingsAmbient::SettingsDirection::Direction Property
SettingsAmbient::SettingsDirection::Direction Property
Collapse All

Specify how to display directions.

C#
public PropertyEnum<DirectionDisplayType> Direction;
Visual Basic
Public Property Direction() As PropertyEnum<DirectionDisplayType>
Links
SettingsAmbient::SettingsDirection Class, SettingsAmbient::SettingsDirection Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsDirection::DropDecimalForWholeNumbers Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Properties > SettingsAmbient::SettingsDirection::DropDecimalForWholeNumbers Property
SettingsAmbient::SettingsDirection::DropDecimalForWholeNumbers Property
Collapse All

Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)

C#
public PropertyEnum<DropDecimalWholeType> DropDecimalForWholeNumbers;
Visual Basic
Public Property DropDecimalForWholeNumbers() As PropertyEnum<DropDecimalWholeType>
Links
SettingsAmbient::SettingsDirection Class, SettingsAmbient::SettingsDirection Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsDirection::DropLeadingZerosForDegrees Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Properties > SettingsAmbient::SettingsDirection::DropLeadingZerosForDegrees Property
SettingsAmbient::SettingsDirection::DropLeadingZerosForDegrees Property
Collapse All

Drops leading zeros before values less than 10.

C#
public PropertyEnum<DropLeadingZeroType> DropLeadingZerosForDegrees;
Visual Basic
Public Property DropLeadingZerosForDegrees() As PropertyEnum<DropLeadingZeroType>
Links
SettingsAmbient::SettingsDirection Class, SettingsAmbient::SettingsDirection Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsDirection::MeasurementType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Properties > SettingsAmbient::SettingsDirection::MeasurementType Property
SettingsAmbient::SettingsDirection::MeasurementType Property
Collapse All

Specifies how to calculate the direction of a vector.

C#
public PropertyEnum<VectorMeasurementType> MeasurementType;
Visual Basic
Public Property MeasurementType() As PropertyEnum<VectorMeasurementType>
Links
SettingsAmbient::SettingsDirection Class, SettingsAmbient::SettingsDirection Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsDistance Class

Specify how to display linear distances.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsDistance
C#
public class SettingsAmbient::SettingsDistance : SettingsUnitNumber<LinearUnitType>;
Visual Basic
Public Class SettingsAmbient::SettingsDistance
Inherits SettingsUnitNumber<LinearUnitType>
Links
Class Hierarchy


SettingsAmbient::SettingsElevation Class

Specify how to display surface elevations.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsElevation
C#
public class SettingsAmbient::SettingsElevation : SettingsUnitNumber<LinearUnitType>;
Visual Basic
Public Class SettingsAmbient::SettingsElevation
Inherits SettingsUnitNumber<LinearUnitType>
Links
Class Hierarchy


SettingsAmbient::SettingsGeneral Class

Specify how to display text, numbers, and units.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsGeneral
C#
public class SettingsAmbient::SettingsGeneral : TreeOidWrapper;
Visual Basic
Public Class SettingsAmbient::SettingsGeneral
Inherits TreeOidWrapper
Links
SettingsAmbient::SettingsGeneral Properties, SettingsAmbient::SettingsGeneral Members, Class Hierarchy


SettingsAmbient::SettingsGeneral Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Members
SettingsAmbient::SettingsGeneral Members
Collapse All

The following tables list the members exposed by SettingsAmbient::SettingsGeneral.

Public Properties
Public Property | Description
DrivingDirection | Specifies the direction of traffic on the roadway.
IndependentLayerOn | Specifies whether object display is controlled by layer visibility, This is equivalent to SettingsObjectLayers.ObjectControlledByLayer
NewEntityToolTipState | Specifies whether to display tooltips by default for new objects.
PlottedUnitDisplay | Specifies how to display numbers in interface controls and on the command line.
SaveCommandChangesToSettings | Specifies whether any changes made to the settings during a command are saved for the drawing, even if the setting... more
ShowEventViewer | Specifies whether the Event Viewer is displayed automatically when an event occurs.
ShowToolTips | Specifies whether to display tooltips in the drawing. This setting does not affect tooltips for toolbar icons.
Links
Public Properties


SettingsAmbient::SettingsGeneral Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties
SettingsAmbient::SettingsGeneral Properties
Collapse All

The properties of SettingsAmbient::SettingsGeneral are listed here.

Public Properties
Public Property | Description
DrivingDirection | Specifies the direction of traffic on the roadway.
IndependentLayerOn | Specifies whether object display is controlled by layer visibility, This is equivalent to SettingsObjectLayers.ObjectControlledByLayer
NewEntityToolTipState | Specifies whether to display tooltips by default for new objects.
PlottedUnitDisplay | Specifies how to display numbers in interface controls and on the command line.
SaveCommandChangesToSettings | Specifies whether any changes made to the settings during a command are saved for the drawing, even if the setting... more
ShowEventViewer | Specifies whether the Event Viewer is displayed automatically when an event occurs.
ShowToolTips | Specifies whether to display tooltips in the drawing. This setting does not affect tooltips for toolbar icons.
Links
Public Properties


SettingsAmbient::SettingsGeneral::DrivingDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties > SettingsAmbient::SettingsGeneral::DrivingDirection Property
SettingsAmbient::SettingsGeneral::DrivingDirection Property
Collapse All

Specifies the direction of traffic on the roadway.

C#
public PropertyEnum<DrivingDirectionType> DrivingDirection;
Visual Basic
Public Property DrivingDirection() As PropertyEnum<DrivingDirectionType>
Links
SettingsAmbient::SettingsGeneral Class, SettingsAmbient::SettingsGeneral Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsGeneral::IndependentLayerOn Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties > SettingsAmbient::SettingsGeneral::IndependentLayerOn Property
SettingsAmbient::SettingsGeneral::IndependentLayerOn Property
Collapse All

Specifies whether object display is controlled by layer visibility, This is equivalent to SettingsObjectLayers.ObjectControlledByLayer

C#
public PropertyBoolean IndependentLayerOn;
Visual Basic
Public Property IndependentLayerOn() As PropertyBoolean
Links
SettingsAmbient::SettingsGeneral Class, SettingsAmbient::SettingsGeneral Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsGeneral::NewEntityToolTipState Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties > SettingsAmbient::SettingsGeneral::NewEntityToolTipState Property
SettingsAmbient::SettingsGeneral::NewEntityToolTipState Property
Collapse All

Specifies whether to display tooltips by default for new objects.

C#
public PropertyBoolean NewEntityToolTipState;
Visual Basic
Public Property NewEntityToolTipState() As PropertyBoolean
Links
SettingsAmbient::SettingsGeneral Class, SettingsAmbient::SettingsGeneral Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsGeneral::PlottedUnitDisplay Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties > SettingsAmbient::SettingsGeneral::PlottedUnitDisplay Property
SettingsAmbient::SettingsGeneral::PlottedUnitDisplay Property
Collapse All

Specifies how to display numbers in interface controls and on the command line.

C#
public PropertyEnum<PlottedUnitDisplayType> PlottedUnitDisplay;
Visual Basic
Public Property PlottedUnitDisplay() As PropertyEnum<PlottedUnitDisplayType>
Links
SettingsAmbient::SettingsGeneral Class, SettingsAmbient::SettingsGeneral Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsGeneral::SaveCommandChangesToSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties > SettingsAmbient::SettingsGeneral::SaveCommandChangesToSettings Property
SettingsAmbient::SettingsGeneral::SaveCommandChangesToSettings Property
Collapse All

Specifies whether any changes made to the settings during a command are saved for the drawing, even if the setting is marked as "locked" in the settings dialog box.

C#
public PropertyBoolean SaveCommandChangesToSettings;
Visual Basic
Public Property SaveCommandChangesToSettings() As PropertyBoolean
Links
SettingsAmbient::SettingsGeneral Class, SettingsAmbient::SettingsGeneral Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsGeneral::ShowEventViewer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties > SettingsAmbient::SettingsGeneral::ShowEventViewer Property
SettingsAmbient::SettingsGeneral::ShowEventViewer Property
Collapse All

Specifies whether the Event Viewer is displayed automatically when an event occurs.

C#
public PropertyBoolean ShowEventViewer;
Visual Basic
Public Property ShowEventViewer() As PropertyBoolean
Links
SettingsAmbient::SettingsGeneral Class, SettingsAmbient::SettingsGeneral Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsGeneral::ShowToolTips Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties > SettingsAmbient::SettingsGeneral::ShowToolTips Property
SettingsAmbient::SettingsGeneral::ShowToolTips Property
Collapse All

Specifies whether to display tooltips in the drawing. This setting does not affect tooltips for toolbar icons.

C#
public PropertyBoolean ShowToolTips;
Visual Basic
Public Property ShowToolTips() As PropertyBoolean
Remarks

For example, if you move your cursor near an alignment, you see a tooltip that shows the station and offset location of the cursor. Tooltips can also show surface elevation, point, profile, and section information. NoteYou can also control tooltip display at the feature settings level and by editing the properties of an individual object.

Links
SettingsAmbient::SettingsGeneral Class, SettingsAmbient::SettingsGeneral Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsGrade Class

Specify how to display grade measurements.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsGrade
C#
public class SettingsAmbient::SettingsGrade : SettingsFormatNumber<GradeFormatType>;
Visual Basic
Public Class SettingsAmbient::SettingsGrade
Inherits SettingsFormatNumber<GradeFormatType>
Links
Class Hierarchy


SettingsAmbient::SettingsGradeSlope Class

Specify how to display grade and slope measurements.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsGradeSlope
C#
public class SettingsAmbient::SettingsGradeSlope : SettingsFormatNumber<GradeSlopeFormatType>;
Visual Basic
Public Class SettingsAmbient::SettingsGradeSlope
Inherits SettingsFormatNumber<GradeSlopeFormatType>
Links
Class Hierarchy


SettingsAmbient::SettingsGridCoordinate Class

Specifies default (ambient) settings for grid coordinate values.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsGridCoordinate
C#
public class SettingsAmbient::SettingsGridCoordinate : SettingsAmbient::SettingsUnitNumber<LinearUnitType>;
Visual Basic
Public Class SettingsAmbient::SettingsGridCoordinate
Inherits SettingsAmbient::SettingsUnitNumber<LinearUnitType>
Links
Class Hierarchy


SettingsAmbient::SettingsLabeling Class

Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsLabeling
C#
public class SettingsAmbient::SettingsLabeling : TreeOidWrapper;
Visual Basic
Public Class SettingsAmbient::SettingsLabeling
Inherits TreeOidWrapper
Links
SettingsAmbient::SettingsLabeling Properties, SettingsAmbient::SettingsLabeling Members, Class Hierarchy


SettingsAmbient::SettingsLabeling Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLabeling Class > SettingsAmbient::SettingsLabeling Members
SettingsAmbient::SettingsLabeling Members
Collapse All

The following tables list the members exposed by SettingsAmbient::SettingsLabeling.

Public Properties
Public Property | Description
PromptMethod | Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.
Links
Public Properties


SettingsAmbient::SettingsLabeling Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLabeling Class > SettingsAmbient::SettingsLabeling Properties
SettingsAmbient::SettingsLabeling Properties
Collapse All

The properties of SettingsAmbient::SettingsLabeling are listed here.

Public Properties
Public Property | Description
PromptMethod | Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.
Links
Public Properties


SettingsAmbient::SettingsLabeling::PromptMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLabeling Class > SettingsAmbient::SettingsLabeling Properties > SettingsAmbient::SettingsLabeling::PromptMethod Property
SettingsAmbient::SettingsLabeling::PromptMethod Property
Collapse All

Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.

C#
public PropertyEnum<LabelingPromptType> PromptMethod;
Visual Basic
Public Property PromptMethod() As PropertyEnum<LabelingPromptType>
Links
SettingsAmbient::SettingsLabeling Class, SettingsAmbient::SettingsLabeling Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsLatLong Class

Specify how to display latitude and longitude.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsLatLong
C#
public class SettingsAmbient::SettingsLatLong : SettingsUnitFormatNumber<AngleUnitType, AngleFormatType>;
Visual Basic
Public Class SettingsAmbient::SettingsLatLong
Inherits SettingsUnitFormatNumber<AngleUnitType, AngleFormatType>
Links
SettingsAmbient::SettingsLatLong Properties, SettingsAmbient::SettingsLatLong Members, Class Hierarchy


SettingsAmbient::SettingsLatLong Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Members
SettingsAmbient::SettingsLatLong Members
Collapse All

The following tables list the members exposed by SettingsAmbient::SettingsLatLong.

Public Properties
Public Property | Description
Capitalization | Specifies how to display direction names.
Direction | Specifies the format of lat/long labels.
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.
Links
Public Properties


SettingsAmbient::SettingsLatLong Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Properties
SettingsAmbient::SettingsLatLong Properties
Collapse All

The properties of SettingsAmbient::SettingsLatLong are listed here.

Public Properties
Public Property | Description
Capitalization | Specifies how to display direction names.
Direction | Specifies the format of lat/long labels.
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.
Links
Public Properties


SettingsAmbient::SettingsLatLong::Capitalization Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Properties > SettingsAmbient::SettingsLatLong::Capitalization Property
SettingsAmbient::SettingsLatLong::Capitalization Property
Collapse All

Specifies how to display direction names.

C#
public PropertyEnum<DirectionNameDisplayType> Capitalization;
Visual Basic
Public Property Capitalization() As PropertyEnum<DirectionNameDisplayType>
Links
SettingsAmbient::SettingsLatLong Class, SettingsAmbient::SettingsLatLong Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsLatLong::Direction Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Properties > SettingsAmbient::SettingsLatLong::Direction Property
SettingsAmbient::SettingsLatLong::Direction Property
Collapse All

Specifies the format of lat/long labels.

C#
public PropertyEnum<LatLongDirectionType> Direction;
Visual Basic
Public Property Direction() As PropertyEnum<LatLongDirectionType>
Links
SettingsAmbient::SettingsLatLong Class, SettingsAmbient::SettingsLatLong Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsLatLong::DropDecimalForWholeNumbers Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Properties > SettingsAmbient::SettingsLatLong::DropDecimalForWholeNumbers Property
SettingsAmbient::SettingsLatLong::DropDecimalForWholeNumbers Property
Collapse All

Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)

C#
public PropertyEnum<DropDecimalWholeType> DropDecimalForWholeNumbers;
Visual Basic
Public Property DropDecimalForWholeNumbers() As PropertyEnum<DropDecimalWholeType>
Links
SettingsAmbient::SettingsLatLong Class, SettingsAmbient::SettingsLatLong Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsLatLong::DropLeadingZerosForDegrees Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Properties > SettingsAmbient::SettingsLatLong::DropLeadingZerosForDegrees Property
SettingsAmbient::SettingsLatLong::DropLeadingZerosForDegrees Property
Collapse All

Drops leading zeros before values less than 10.

C#
public PropertyEnum<DropLeadingZeroType> DropLeadingZerosForDegrees;
Visual Basic
Public Property DropLeadingZerosForDegrees() As PropertyEnum<DropLeadingZeroType>
Links
SettingsAmbient::SettingsLatLong Class, SettingsAmbient::SettingsLatLong Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsSlope Class

Specify how to display slope measurements.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsSlope
C#
public class SettingsAmbient::SettingsSlope : SettingsFormatNumber<SlopeFormatType>;
Visual Basic
Public Class SettingsAmbient::SettingsSlope
Inherits SettingsFormatNumber<SlopeFormatType>
Links
Class Hierarchy


SettingsAmbient::SettingsSpeed Class

Specify how to display speeds for design criteria.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsSpeed
C#
public class SettingsAmbient::SettingsSpeed : SettingsUnitNumber<SpeedUnitType>;
Visual Basic
Public Class SettingsAmbient::SettingsSpeed
Inherits SettingsUnitNumber<SpeedUnitType>
Links
Class Hierarchy


SettingsAmbient::SettingsStation Class

Specify how to display linear features that use station or chainage.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsStation
C#
public class SettingsAmbient::SettingsStation : SettingsUnitFormatNumber<LinearUnitType, StationFormatType>;
Visual Basic
Public Class SettingsAmbient::SettingsStation
Inherits SettingsUnitFormatNumber<LinearUnitType, StationFormatType>
Links
SettingsAmbient::SettingsStation Properties, SettingsAmbient::SettingsStation Members, Class Hierarchy


SettingsAmbient::SettingsStation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Members
SettingsAmbient::SettingsStation Members
Collapse All

The following tables list the members exposed by SettingsAmbient::SettingsStation.

Public Properties
Public Property | Description
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosRightOfStationCharacter | Drops leading zeros before the station character for whole number station values.
MinimumDisplayWidth | Specifies the minimum display width for the station value, which allows leading zeros to be added if necessary. For example,... more
StationDelimiterCharacter | Specifies the separator character used to display stations.
StationDelimiterPosition | Specifies the scale to use for major stations.
Links
Public Properties


SettingsAmbient::SettingsStation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Properties
SettingsAmbient::SettingsStation Properties
Collapse All

The properties of SettingsAmbient::SettingsStation are listed here.

Public Properties
Public Property | Description
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosRightOfStationCharacter | Drops leading zeros before the station character for whole number station values.
MinimumDisplayWidth | Specifies the minimum display width for the station value, which allows leading zeros to be added if necessary. For example,... more
StationDelimiterCharacter | Specifies the separator character used to display stations.
StationDelimiterPosition | Specifies the scale to use for major stations.
Links
Public Properties


SettingsAmbient::SettingsStation::DropDecimalForWholeNumbers Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Properties > SettingsAmbient::SettingsStation::DropDecimalForWholeNumbers Property
SettingsAmbient::SettingsStation::DropDecimalForWholeNumbers Property
Collapse All

Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)

C#
public PropertyEnum<DropDecimalWholeType> DropDecimalForWholeNumbers;
Visual Basic
Public Property DropDecimalForWholeNumbers() As PropertyEnum<DropDecimalWholeType>
Links
SettingsAmbient::SettingsStation Class, SettingsAmbient::SettingsStation Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsStation::DropLeadingZerosRightOfStationCharacter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Properties > SettingsAmbient::SettingsStation::DropLeadingZerosRightOfStationCharacter Property
SettingsAmbient::SettingsStation::DropLeadingZerosRightOfStationCharacter Property
Collapse All

Drops leading zeros before the station character for whole number station values.

C#
public PropertyEnum<DropLeadingZeroType> DropLeadingZerosRightOfStationCharacter;
Visual Basic
Public Property DropLeadingZerosRightOfStationCharacter() As PropertyEnum<DropLeadingZeroType>
Links
SettingsAmbient::SettingsStation Class, SettingsAmbient::SettingsStation Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsStation::MinimumDisplayWidth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Properties > SettingsAmbient::SettingsStation::MinimumDisplayWidth Property
SettingsAmbient::SettingsStation::MinimumDisplayWidth Property
Collapse All

Specifies the minimum display width for the station value, which allows leading zeros to be added if necessary. For example, assuming a minimum display width of 10 and a precision of 2, a station value of 1234.234 would be displayed as 0012+34.23.

C#
public PropertyInt MinimumDisplayWidth;
Visual Basic
Public Property MinimumDisplayWidth() As PropertyInt
Links
SettingsAmbient::SettingsStation Class, SettingsAmbient::SettingsStation Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsStation::StationDelimiterCharacter Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Properties > SettingsAmbient::SettingsStation::StationDelimiterCharacter Property
SettingsAmbient::SettingsStation::StationDelimiterCharacter Property
Collapse All

Specifies the separator character used to display stations.

C#
public PropertyEnum<StationDelimiterCharacterType> StationDelimiterCharacter;
Visual Basic
Public Property StationDelimiterCharacter() As PropertyEnum<StationDelimiterCharacterType>
Links
SettingsAmbient::SettingsStation Class, SettingsAmbient::SettingsStation Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsStation::StationDelimiterPosition Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Properties > SettingsAmbient::SettingsStation::StationDelimiterPosition Property
SettingsAmbient::SettingsStation::StationDelimiterPosition Property
Collapse All

Specifies the scale to use for major stations.

C#
public PropertyEnum<StationDelimiterPositionType> StationDelimiterPosition;
Visual Basic
Public Property StationDelimiterPosition() As PropertyEnum<StationDelimiterPositionType>
Links
SettingsAmbient::SettingsStation Class, SettingsAmbient::SettingsStation Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsTransparentCommands Class

specify the prompting behavior of transparent commands across all features. The formats used to prompt for grade and slope values are set using the Grade and Slope ambient settings.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsTransparentCommands
C#
public class SettingsAmbient::SettingsTransparentCommands : TreeOidWrapper;
Visual Basic
Public Class SettingsAmbient::SettingsTransparentCommands
Inherits TreeOidWrapper
Links
SettingsAmbient::SettingsTransparentCommands Properties, SettingsAmbient::SettingsTransparentCommands Members, Class Hierarchy


SettingsAmbient::SettingsTransparentCommands Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Members
SettingsAmbient::SettingsTransparentCommands Members
Collapse All

The following tables list the members exposed by SettingsAmbient::SettingsTransparentCommands.

Public Properties
Public Property | Description
PromptFor3DPoints | Specifies the prompt sequence (X,Y or X, Y, Z) when creating a point in 3D. True (prompt for 3D points),... more
PromptForEastingThenNorthing | Specifies whether commands prompt for the Easting before the Northing: True (Easting first),False (Northing first)
PromptForLongitudeThenLatitude | Specifies whether commands prompt for the Longitude before the Latitude: False (Latitude first),True (Longitude first)
PromptForYBeforeX | Specifies whether commands prompt for the Y coordinate before the X coordinate: True (Y first),False (X first)
Links
Public Properties


SettingsAmbient::SettingsTransparentCommands Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Properties
SettingsAmbient::SettingsTransparentCommands Properties
Collapse All

The properties of SettingsAmbient::SettingsTransparentCommands are listed here.

Public Properties
Public Property | Description
PromptFor3DPoints | Specifies the prompt sequence (X,Y or X, Y, Z) when creating a point in 3D. True (prompt for 3D points),... more
PromptForEastingThenNorthing | Specifies whether commands prompt for the Easting before the Northing: True (Easting first),False (Northing first)
PromptForLongitudeThenLatitude | Specifies whether commands prompt for the Longitude before the Latitude: False (Latitude first),True (Longitude first)
PromptForYBeforeX | Specifies whether commands prompt for the Y coordinate before the X coordinate: True (Y first),False (X first)
Links
Public Properties


SettingsAmbient::SettingsTransparentCommands::PromptFor3DPoints Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Properties > SettingsAmbient::SettingsTransparentCommands::PromptFor3DPoints Property
SettingsAmbient::SettingsTransparentCommands::PromptFor3DPoints Property
Collapse All

Specifies the prompt sequence (X,Y or X, Y, Z) when creating a point in 3D. True (prompt for 3D points), False (no Z prompt)

C#
public PropertyBoolean PromptFor3DPoints;
Visual Basic
Public Property PromptFor3DPoints() As PropertyBoolean
Links
SettingsAmbient::SettingsTransparentCommands Class, SettingsAmbient::SettingsTransparentCommands Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsTransparentCommands::PromptForEastingThenNorthing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Properties > SettingsAmbient::SettingsTransparentCommands::PromptForEastingThenNorthing Property
SettingsAmbient::SettingsTransparentCommands::PromptForEastingThenNorthing Property
Collapse All

Specifies whether commands prompt for the Easting before the Northing: True (Easting first),False (Northing first)

C#
public PropertyBoolean PromptForEastingThenNorthing;
Visual Basic
Public Property PromptForEastingThenNorthing() As PropertyBoolean
Links
SettingsAmbient::SettingsTransparentCommands Class, SettingsAmbient::SettingsTransparentCommands Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsTransparentCommands::PromptForLongitudeThenLatitude Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Properties > SettingsAmbient::SettingsTransparentCommands::PromptForLongitudeThenLatitude Property
SettingsAmbient::SettingsTransparentCommands::PromptForLongitudeThenLatitude Property
Collapse All

Specifies whether commands prompt for the Longitude before the Latitude: False (Latitude first),True (Longitude first)

C#
public PropertyBoolean PromptForLongitudeThenLatitude;
Visual Basic
Public Property PromptForLongitudeThenLatitude() As PropertyBoolean
Links
SettingsAmbient::SettingsTransparentCommands Class, SettingsAmbient::SettingsTransparentCommands Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsTransparentCommands::PromptForYBeforeX Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Properties > SettingsAmbient::SettingsTransparentCommands::PromptForYBeforeX Property
SettingsAmbient::SettingsTransparentCommands::PromptForYBeforeX Property
Collapse All

Specifies whether commands prompt for the Y coordinate before the X coordinate: True (Y first),False (X first)

C#
public PropertyBoolean PromptForYBeforeX;
Visual Basic
Public Property PromptForYBeforeX() As PropertyBoolean
Links
SettingsAmbient::SettingsTransparentCommands Class, SettingsAmbient::SettingsTransparentCommands Members, Autodesk::Civil::Settings Namespace


SettingsAmbient::SettingsUnitless Class

These settings specify how to display numeric values that are not specifically defined by the unit type.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsUnitless
C#
public class SettingsAmbient::SettingsUnitless : SettingsUnitlessNumber;
Visual Basic
Public Class SettingsAmbient::SettingsUnitless
Inherits SettingsUnitlessNumber
Links
Class Hierarchy


SettingsAmbient::SettingsVolume Class

Specify how to display terrain volumes.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsVolume
C#
public class SettingsAmbient::SettingsVolume : SettingsUnitNumber<VolumeUnitType>;
Visual Basic
Public Class SettingsAmbient::SettingsVolume
Inherits SettingsUnitNumber<VolumeUnitType>
Links
Class Hierarchy


SettingsCmdAddNoteLabel Class

Settings for AddNoteLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdAddNoteLabel
C#
public class SettingsCmdAddNoteLabel : SettingsGeneral;
Visual Basic
Public Class SettingsCmdAddNoteLabel
Inherits SettingsGeneral
Links
Class Hierarchy


SettingsCmdAddSegmentLabel Class

Settings for AddSegmentLabel command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdAddSegmentLabel
C#
public class SettingsCmdAddSegmentLabel : SettingsGeneral;
Visual Basic
Public Class SettingsCmdAddSegmentLabel
Inherits SettingsGeneral
Links
Class Hierarchy


SettingsCmdAddSegmentLabels Class

Settings for AddSegmentLabels command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdAddSegmentLabels
C#
public class SettingsCmdAddSegmentLabels : SettingsGeneral;
Visual Basic
Public Class SettingsCmdAddSegmentLabels
Inherits SettingsGeneral
Links
Class Hierarchy


SettingsCmdCreateArcByBestFit Class

Settings for CreateArcByBestFit command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdCreateArcByBestFit
C#
public class SettingsCmdCreateArcByBestFit : SettingsGeneral;
Visual Basic
Public Class SettingsCmdCreateArcByBestFit
Inherits SettingsGeneral
Links
SettingsCmdCreateArcByBestFit Properties, SettingsCmdCreateArcByBestFit Members, Class Hierarchy


SettingsCmdCreateArcByBestFit Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Members
SettingsCmdCreateArcByBestFit Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateArcByBestFit.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateArcByBestFit Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Properties
SettingsCmdCreateArcByBestFit Properties
Collapse All

The properties of SettingsCmdCreateArcByBestFit are listed here.

Public Properties
Public Property | Description
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.
Links
Public Properties


SettingsCmdCreateArcByBestFit::CurveTessellationOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Properties > SettingsCmdCreateArcByBestFit::CurveTessellationOption Property
SettingsCmdCreateArcByBestFit::CurveTessellationOption Property
Collapse All

Use these settings to specify the default behavior when curve entities are used as an input option for best fit arc creation.

C#
public SettingsCmdCurveTessellationOption CurveTessellationOption;
Visual Basic
Public Property CurveTessellationOption() As SettingsCmdCurveTessellationOption
Links
SettingsCmdCreateArcByBestFit Class, SettingsCmdCreateArcByBestFit Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateArcByBestFit::RegressionGraphOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Properties > SettingsCmdCreateArcByBestFit::RegressionGraphOption Property
SettingsCmdCreateArcByBestFit::RegressionGraphOption Property
Collapse All

Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.

C#
public SettingsCmdRegressionGraphOption RegressionGraphOption;
Visual Basic
Public Property RegressionGraphOption() As SettingsCmdRegressionGraphOption
Links
SettingsCmdCreateArcByBestFit Class, SettingsCmdCreateArcByBestFit Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class
Collapse All

Use these settings to specify the default behavior when curve entities are used as an input option for best fit arc creation.

Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption
C#
public class SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties, SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members, Class Hierarchy


SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption.

Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties
Collapse All

The properties of SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption are listed here.

Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
Collapse All

Specifies whether to tesselate curve segments if they are included as an input option.

C#
public PropertyDouble MidOrdinateTolerance;
Visual Basic
Public Property MidOrdinateTolerance() As PropertyDouble
Links
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve Property
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve Property
Collapse All

Specifies whether to tesselate curve segments if they are included as an input option.

C#
public PropertyBoolean TessellateCurve;
Visual Basic
Public Property TessellateCurve() As PropertyBoolean
Links
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class
Collapse All

Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.

Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption
C#
public class SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties, SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members, Class Hierarchy


SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties
Collapse All

The properties of SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption are listed here.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
Collapse All

Specifies whether the regression graph displays splines on the green line that represents the best fit entity.

C#
public PropertyBoolean SplineFitForRegressionAnalysisGraph;
Visual Basic
Public Property SplineFitForRegressionAnalysisGraph() As PropertyBoolean
Links
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class, SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateLineByBestFit Class

Settings for CreateLineByBestFit command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdCreateLineByBestFit
C#
public class SettingsCmdCreateLineByBestFit : SettingsGeneral;
Visual Basic
Public Class SettingsCmdCreateLineByBestFit
Inherits SettingsGeneral
Links
SettingsCmdCreateLineByBestFit Properties, SettingsCmdCreateLineByBestFit Members, Class Hierarchy


SettingsCmdCreateLineByBestFit Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Members
SettingsCmdCreateLineByBestFit Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateLineByBestFit.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateLineByBestFit Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Properties
SettingsCmdCreateLineByBestFit Properties
Collapse All

The properties of SettingsCmdCreateLineByBestFit are listed here.

Public Properties
Public Property | Description
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.
Links
Public Properties


SettingsCmdCreateLineByBestFit::CurveTessellationOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Properties > SettingsCmdCreateLineByBestFit::CurveTessellationOption Property
SettingsCmdCreateLineByBestFit::CurveTessellationOption Property
Collapse All

Use these settings to specify the default behavior when curve entities are used as an input option for best fit line creation.

C#
public SettingsCmdCurveTessellationOption CurveTessellationOption;
Visual Basic
Public Property CurveTessellationOption() As SettingsCmdCurveTessellationOption
Links
SettingsCmdCreateLineByBestFit Class, SettingsCmdCreateLineByBestFit Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateLineByBestFit::RegressionGraphOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Properties > SettingsCmdCreateLineByBestFit::RegressionGraphOption Property
SettingsCmdCreateLineByBestFit::RegressionGraphOption Property
Collapse All

Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.

C#
public SettingsCmdRegressionGraphOption RegressionGraphOption;
Visual Basic
Public Property RegressionGraphOption() As SettingsCmdRegressionGraphOption
Links
SettingsCmdCreateLineByBestFit Class, SettingsCmdCreateLineByBestFit Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class
Collapse All

Use these settings to specify the default behavior when curve entities are used as an input option for best fit line creation.

Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption
C#
public class SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties, SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members, Class Hierarchy


SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption.

Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties
Collapse All

The properties of SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption are listed here.

Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
Collapse All

Specifies whether to tesselate curve segments if they are included as an input option.

C#
public PropertyDouble MidOrdinateTolerance;
Visual Basic
Public Property MidOrdinateTolerance() As PropertyDouble
Links
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve Property
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve Property
Collapse All

Specifies whether to tesselate curve segments if they are included as an input option.

C#
public PropertyBoolean TessellateCurve;
Visual Basic
Public Property TessellateCurve() As PropertyBoolean
Links
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class
Collapse All

Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.

Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption
C#
public class SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties, SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members, Class Hierarchy


SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties
Collapse All

The properties of SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption are listed here.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
Collapse All

Specifies whether the regression graph displays splines on the green line that represents the best fit entity.

C#
public PropertyBoolean SplineFitForRegressionAnalysisGraph;
Visual Basic
Public Property SplineFitForRegressionAnalysisGraph() As PropertyBoolean
Links
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class, SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateParabolaByBestFit Class

Settings for CreateParabolaByBestFit command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdCreateParabolaByBestFit
C#
public class SettingsCmdCreateParabolaByBestFit : SettingsGeneral;
Visual Basic
Public Class SettingsCmdCreateParabolaByBestFit
Inherits SettingsGeneral
Links
SettingsCmdCreateParabolaByBestFit Properties, SettingsCmdCreateParabolaByBestFit Members, Class Hierarchy


SettingsCmdCreateParabolaByBestFit Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Members
SettingsCmdCreateParabolaByBestFit Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParabolaByBestFit.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdCreateParabolaByBestFit Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Properties
SettingsCmdCreateParabolaByBestFit Properties
Collapse All

The properties of SettingsCmdCreateParabolaByBestFit are listed here.

Public Properties
Public Property | Description
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.
Links
Public Properties


SettingsCmdCreateParabolaByBestFit::CurveTessellationOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Properties > SettingsCmdCreateParabolaByBestFit::CurveTessellationOption Property
SettingsCmdCreateParabolaByBestFit::CurveTessellationOption Property
Collapse All

Use these settings to specify the default behavior when curve entities are used as an input option for best fit parabola creation.

C#
public SettingsCmdCurveTessellationOption CurveTessellationOption;
Visual Basic
Public Property CurveTessellationOption() As SettingsCmdCurveTessellationOption
Links
SettingsCmdCreateParabolaByBestFit Class, SettingsCmdCreateParabolaByBestFit Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateParabolaByBestFit::RegressionGraphOption Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Properties > SettingsCmdCreateParabolaByBestFit::RegressionGraphOption Property
SettingsCmdCreateParabolaByBestFit::RegressionGraphOption Property
Collapse All

Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.

C#
public SettingsCmdRegressionGraphOption RegressionGraphOption;
Visual Basic
Public Property RegressionGraphOption() As SettingsCmdRegressionGraphOption
Links
SettingsCmdCreateParabolaByBestFit Class, SettingsCmdCreateParabolaByBestFit Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class
Collapse All

Use these settings to specify the default behavior when curve entities are used as an input option for best fit parabola creation.

Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption
C#
public class SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties, SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members, Class Hierarchy


SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption.

Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties
Collapse All

The properties of SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption are listed here.

Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.
Links
Public Properties


SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance Property
Collapse All

Specifies whether to tesselate curve segments if they are included as an input option.

C#
public PropertyDouble MidOrdinateTolerance;
Visual Basic
Public Property MidOrdinateTolerance() As PropertyDouble
Links
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve Property
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve Property
Collapse All

Specifies whether to tesselate curve segments if they are included as an input option.

C#
public PropertyBoolean TessellateCurve;
Visual Basic
Public Property TessellateCurve() As PropertyBoolean
Links
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class, SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members, Autodesk::Civil::Settings Namespace


SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class
Collapse All

Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.

Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption
C#
public class SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption
Inherits TreeOidWrapper
Links
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties, SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members, Class Hierarchy


SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members
Collapse All

The following tables list the members exposed by SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties
Collapse All

The properties of SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption are listed here.

Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.
Links
Public Properties


SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph Property
Collapse All

Specifies whether the regression graph displays splines on the green line that represents the best fit entity.

C#
public PropertyBoolean SplineFitForRegressionAnalysisGraph;
Visual Basic
Public Property SplineFitForRegressionAnalysisGraph() As PropertyBoolean
Links
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class, SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck Class

Settings for MapCheck command.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdMapCheck
C#
public class SettingsCmdMapCheck : SettingsGeneral;
Visual Basic
Public Class SettingsCmdMapCheck
Inherits SettingsGeneral
Links
SettingsCmdMapCheck Properties, SettingsCmdMapCheck Members, Class Hierarchy


SettingsCmdMapCheck Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Members
SettingsCmdMapCheck Members
Collapse All

The following tables list the members exposed by SettingsCmdMapCheck.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Mapcheck | Use these settings to specify the default behavior for Mapcheck.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsCmdMapCheck Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Properties
SettingsCmdMapCheck Properties
Collapse All

The properties of SettingsCmdMapCheck are listed here.

Public Properties
Public Property | Description
Mapcheck | Use these settings to specify the default behavior for Mapcheck.
Links
Public Properties


SettingsCmdMapCheck::Mapcheck Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Properties > SettingsCmdMapCheck::Mapcheck Property
SettingsCmdMapCheck::Mapcheck Property
Collapse All

Use these settings to specify the default behavior for Mapcheck.

C#
public SettingsCmdMapcheck Mapcheck;
Visual Basic
Public Property Mapcheck() As SettingsCmdMapcheck
Links
SettingsCmdMapCheck Class, SettingsCmdMapCheck Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck::SettingsCmdMapcheck Class

Use these settings to specify the default behavior for Mapcheck.

Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdMapCheck::SettingsCmdMapcheck
C#
public class SettingsCmdMapCheck::SettingsCmdMapcheck : TreeOidWrapper;
Visual Basic
Public Class SettingsCmdMapCheck::SettingsCmdMapcheck
Inherits TreeOidWrapper
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Properties, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Class Hierarchy


SettingsCmdMapCheck::SettingsCmdMapcheck Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Members
SettingsCmdMapCheck::SettingsCmdMapcheck Members
Collapse All

The following tables list the members exposed by SettingsCmdMapCheck::SettingsCmdMapcheck.

Public Properties
Public Property | Description
CurrentMapcheckColor | Specifies the color for the current mapcheck.
CurrentPointofBeginningColor | Specifies the color of the beginning not for a selected mapcheck.
CurrentSideColor | Specifies the color for the current selected side.
DefaultAngleType | Specifies the default type of any angle created using Mapcheck.
DefaultCurveDirection | Specifies the default direction of any curve created using Mapcheck.
DefaultCurveTraverseMethod |
DefaultSideType | Specifies the default type of any side created using Mapcheck.
MapcheckColor | Specifies the color for Mapcheck lines and curves which are not part of the current mapcheck.
UseCommandLineInput | Specifies whether Mapcheck will accept commands from the command line interface. Selecting No causes Mapcheck to accept input only from... more
Links
Public Properties


SettingsCmdMapCheck::SettingsCmdMapcheck Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties
SettingsCmdMapCheck::SettingsCmdMapcheck Properties
Collapse All

The properties of SettingsCmdMapCheck::SettingsCmdMapcheck are listed here.

Public Properties
Public Property | Description
CurrentMapcheckColor | Specifies the color for the current mapcheck.
CurrentPointofBeginningColor | Specifies the color of the beginning not for a selected mapcheck.
CurrentSideColor | Specifies the color for the current selected side.
DefaultAngleType | Specifies the default type of any angle created using Mapcheck.
DefaultCurveDirection | Specifies the default direction of any curve created using Mapcheck.
DefaultCurveTraverseMethod |
DefaultSideType | Specifies the default type of any side created using Mapcheck.
MapcheckColor | Specifies the color for Mapcheck lines and curves which are not part of the current mapcheck.
UseCommandLineInput | Specifies whether Mapcheck will accept commands from the command line interface. Selecting No causes Mapcheck to accept input only from... more
Links
Public Properties


SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentMapcheckColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties > SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentMapcheckColor Property
SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentMapcheckColor Property
Collapse All

Specifies the color for the current mapcheck.

C#
public PropertyColor CurrentMapcheckColor;
Visual Basic
Public Property CurrentMapcheckColor() As PropertyColor
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Class, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentPointofBeginningColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties > SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentPointofBeginningColor Property
SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentPointofBeginningColor Property
Collapse All

Specifies the color of the beginning not for a selected mapcheck.

C#
public PropertyColor CurrentPointofBeginningColor;
Visual Basic
Public Property CurrentPointofBeginningColor() As PropertyColor
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Class, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentSideColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties > SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentSideColor Property
SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentSideColor Property
Collapse All

Specifies the color for the current selected side.

C#
public PropertyColor CurrentSideColor;
Visual Basic
Public Property CurrentSideColor() As PropertyColor
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Class, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultAngleType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties > SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultAngleType Property
SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultAngleType Property
Collapse All

Specifies the default type of any angle created using Mapcheck.

C#
public PropertyEnum<MapcheckAngleType> DefaultAngleType;
Visual Basic
Public Property DefaultAngleType() As PropertyEnum<MapcheckAngleType>
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Class, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultCurveDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties > SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultCurveDirection Property
SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultCurveDirection Property
Collapse All

Specifies the default direction of any curve created using Mapcheck.

C#
public PropertyEnum<MapcheckCurveDirectionType> DefaultCurveDirection;
Visual Basic
Public Property DefaultCurveDirection() As PropertyEnum<MapcheckCurveDirectionType>
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Class, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultCurveTraverseMethod Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties > SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultCurveTraverseMethod Property
SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultCurveTraverseMethod Property
Collapse All
C#
public PropertyEnum<MapcheckTraverseMethodType> DefaultCurveTraverseMethod;
Visual Basic
Public Property DefaultCurveTraverseMethod() As PropertyEnum<MapcheckTraverseMethodType>
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Class, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultSideType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties > SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultSideType Property
SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultSideType Property
Collapse All

Specifies the default type of any side created using Mapcheck.

C#
public PropertyEnum<MapcheckSideType> DefaultSideType;
Visual Basic
Public Property DefaultSideType() As PropertyEnum<MapcheckSideType>
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Class, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck::SettingsCmdMapcheck::MapcheckColor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties > SettingsCmdMapCheck::SettingsCmdMapcheck::MapcheckColor Property
SettingsCmdMapCheck::SettingsCmdMapcheck::MapcheckColor Property
Collapse All

Specifies the color for Mapcheck lines and curves which are not part of the current mapcheck.

C#
public PropertyColor MapcheckColor;
Visual Basic
Public Property MapcheckColor() As PropertyColor
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Class, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Autodesk::Civil::Settings Namespace


SettingsCmdMapCheck::SettingsCmdMapcheck::UseCommandLineInput Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties > SettingsCmdMapCheck::SettingsCmdMapcheck::UseCommandLineInput Property
SettingsCmdMapCheck::SettingsCmdMapcheck::UseCommandLineInput Property
Collapse All

Specifies whether Mapcheck will accept commands from the command line interface. Selecting No causes Mapcheck to accept input only from the Mapcheck vista.

C#
public PropertyBoolean UseCommandLineInput;
Visual Basic
Public Property UseCommandLineInput() As PropertyBoolean
Links
SettingsCmdMapCheck::SettingsCmdMapcheck Class, SettingsCmdMapCheck::SettingsCmdMapcheck Members, Autodesk::Civil::Settings Namespace


SettingsCoordinateSystem Class

Encapsulates coordinate system settings.

Class Hierarchy
Autodesk::Civil::Settings::SettingsCoordinateSystem
C#
public class SettingsCoordinateSystem;
Visual Basic
Public Class SettingsCoordinateSystem
Links
SettingsCoordinateSystem Properties, SettingsCoordinateSystem Members, Class Hierarchy


SettingsCoordinateSystem Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Members
SettingsCoordinateSystem Members
Collapse All

The following tables list the members exposed by SettingsCoordinateSystem.

Public Properties
Public Property | Description
Category | Gets the coordinate system geographic zone.
Code | Gets the coordinate system code string.
Datum | Gets the abbreviation for the datum on which the coordinate system is based.
Description | Gets the description for the selected zone.
Projection | Gets the projection method, which is the basis of the zone computation.
Unit | Gets the coordinate system unit.
Links
Public Properties


SettingsCoordinateSystem Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Properties
SettingsCoordinateSystem Properties
Collapse All

The properties of SettingsCoordinateSystem are listed here.

Public Properties
Public Property | Description
Category | Gets the coordinate system geographic zone.
Code | Gets the coordinate system code string.
Datum | Gets the abbreviation for the datum on which the coordinate system is based.
Description | Gets the description for the selected zone.
Projection | Gets the projection method, which is the basis of the zone computation.
Unit | Gets the coordinate system unit.
Links
Public Properties


SettingsCoordinateSystem::Category Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Properties > SettingsCoordinateSystem::Category Property
SettingsCoordinateSystem::Category Property
Collapse All

Gets the coordinate system geographic zone.

C#
public System::String Category;
Visual Basic
Public Property Category() As System::String
Links
SettingsCoordinateSystem Class, SettingsCoordinateSystem Members, Autodesk::Civil::Settings Namespace


SettingsCoordinateSystem::Code Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Properties > SettingsCoordinateSystem::Code Property
SettingsCoordinateSystem::Code Property
Collapse All

Gets the coordinate system code string.

C#
public System::String Code;
Visual Basic
Public Property Code() As System::String
Links
SettingsCoordinateSystem Class, SettingsCoordinateSystem Members, Autodesk::Civil::Settings Namespace


SettingsCoordinateSystem::Datum Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Properties > SettingsCoordinateSystem::Datum Property
SettingsCoordinateSystem::Datum Property
Collapse All

Gets the abbreviation for the datum on which the coordinate system is based.

C#
public System::String Datum;
Visual Basic
Public Property Datum() As System::String
Links
SettingsCoordinateSystem Class, SettingsCoordinateSystem Members, Autodesk::Civil::Settings Namespace


SettingsCoordinateSystem::Description Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Properties > SettingsCoordinateSystem::Description Property
SettingsCoordinateSystem::Description Property
Collapse All

Gets the description for the selected zone.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
SettingsCoordinateSystem Class, SettingsCoordinateSystem Members, Autodesk::Civil::Settings Namespace


SettingsCoordinateSystem::Projection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Properties > SettingsCoordinateSystem::Projection Property
SettingsCoordinateSystem::Projection Property
Collapse All

Gets the projection method, which is the basis of the zone computation.

C#
public System::String Projection;
Visual Basic
Public Property Projection() As System::String
Links
SettingsCoordinateSystem Class, SettingsCoordinateSystem Members, Autodesk::Civil::Settings Namespace


SettingsCoordinateSystem::Unit Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Properties > SettingsCoordinateSystem::Unit Property
SettingsCoordinateSystem::Unit Property
Collapse All

Gets the coordinate system unit.

C#
public System::String Unit;
Visual Basic
Public Property Unit() As System::String
Links
SettingsCoordinateSystem Class, SettingsCoordinateSystem Members, Autodesk::Civil::Settings Namespace


SettingsDrawing Class

Contains settings that apply to the drawing, as specified in the Drawing Settings dialog box.

Class Hierarchy
Autodesk::Civil::Settings::SettingsDrawing
C#
public class SettingsDrawing : TreeOidWrapper;
Visual Basic
Public Class SettingsDrawing
Inherits TreeOidWrapper
Links
SettingsDrawing Properties, SettingsDrawing Members, Class Hierarchy


SettingsDrawing Members

The following tables list the members exposed by SettingsDrawing.

Public Properties
Public Property | Description
AbbreviationsSettings | Gets Abbreviations of Drawing settings.
AmbientSettings | Gets Ambient setting of the drawing.
ApplyTransformSettings | Gets or sets the boolean value that specifies whether to apply the settings for coordinate system zone transformation.
ObjectLayerSettings | Gets the Object layer settings for various objects in AutoCAD Civil 3D. For example, you can specify that you want... more
TransformationSettings | Gets Transformation of Drawing settings.
UnitZoneSettings | Gets UnitZone of Drawing settings.
Links
Public Properties


SettingsDrawing Properties

The properties of SettingsDrawing are listed here.

Public Properties
Public Property | Description
AbbreviationsSettings | Gets Abbreviations of Drawing settings.
AmbientSettings | Gets Ambient setting of the drawing.
ApplyTransformSettings | Gets or sets the boolean value that specifies whether to apply the settings for coordinate system zone transformation.
ObjectLayerSettings | Gets the Object layer settings for various objects in AutoCAD Civil 3D. For example, you can specify that you want... more
TransformationSettings | Gets Transformation of Drawing settings.
UnitZoneSettings | Gets UnitZone of Drawing settings.
Links
Public Properties


SettingsDrawing::AbbreviationsSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsDrawing Class > SettingsDrawing Properties > SettingsDrawing::AbbreviationsSettings Property
SettingsDrawing::AbbreviationsSettings Property
Collapse All

Gets Abbreviations of Drawing settings.

C#
public SettingsAbbreviation AbbreviationsSettings;
Visual Basic
Public Property AbbreviationsSettings() As SettingsAbbreviation
Links
SettingsDrawing Class, SettingsDrawing Members, Autodesk::Civil::Settings Namespace


SettingsDrawing::AmbientSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsDrawing Class > SettingsDrawing Properties > SettingsDrawing::AmbientSettings Property
SettingsDrawing::AmbientSettings Property
Collapse All

Gets Ambient setting of the drawing.

C#
public SettingsAmbient AmbientSettings;
Visual Basic
Public Property AmbientSettings() As SettingsAmbient
Links
SettingsDrawing Class, SettingsDrawing Members, Autodesk::Civil::Settings Namespace


SettingsDrawing::ApplyTransformSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsDrawing Class > SettingsDrawing Properties > SettingsDrawing::ApplyTransformSettings Property
SettingsDrawing::ApplyTransformSettings Property
Collapse All

Gets or sets the boolean value that specifies whether to apply the settings for coordinate system zone transformation.

C#
public bool ApplyTransformSettings;
Visual Basic
Public Property ApplyTransformSettings() As bool
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when setting the property if the system zone is invalid or ".".
Links
SettingsDrawing Class, SettingsDrawing Members, Autodesk::Civil::Settings Namespace


SettingsDrawing::ObjectLayerSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsDrawing Class > SettingsDrawing Properties > SettingsDrawing::ObjectLayerSettings Property
SettingsDrawing::ObjectLayerSettings Property
Collapse All

Gets the Object layer settings for various objects in AutoCAD Civil 3D. For example, you can specify that you want all alignments on layer C-ROAD, all parcels on C-PROP, and so on. You can also specify prefixes and suffixes for the layer names.

C#
public SettingsObjectLayers ObjectLayerSettings;
Visual Basic
Public Property ObjectLayerSettings() As SettingsObjectLayers
Links
SettingsDrawing Class, SettingsDrawing Members, Autodesk::Civil::Settings Namespace


SettingsDrawing::TransformationSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsDrawing Class > SettingsDrawing Properties > SettingsDrawing::TransformationSettings Property
SettingsDrawing::TransformationSettings Property
Collapse All

Gets Transformation of Drawing settings.

C#
public SettingsTransformation TransformationSettings;
Visual Basic
Public Property TransformationSettings() As SettingsTransformation
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the value of ApplyTransformSettings is false.
Links
SettingsDrawing Class, SettingsDrawing Members, Autodesk::Civil::Settings Namespace


SettingsDrawing::UnitZoneSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsDrawing Class > SettingsDrawing Properties > SettingsDrawing::UnitZoneSettings Property
SettingsDrawing::UnitZoneSettings Property
Collapse All

Gets UnitZone of Drawing settings.

C#
public SettingsUnitZone UnitZoneSettings;
Visual Basic
Public Property UnitZoneSettings() As SettingsUnitZone
Links
SettingsDrawing Class, SettingsDrawing Members, Autodesk::Civil::Settings Namespace


SettingsGeneral Class

Settings for General.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdAddNoteLabel
        Autodesk::Civil::Settings::SettingsCmdAddSegmentLabel
        Autodesk::Civil::Settings::SettingsCmdAddSegmentLabels
        Autodesk::Civil::Settings::SettingsCmdCreateArcByBestFit
        Autodesk::Civil::Settings::SettingsCmdCreateLineByBestFit
        Autodesk::Civil::Settings::SettingsCmdCreateParabolaByBestFit
        Autodesk::Civil::Settings::SettingsCmdMapCheck
C#
public class SettingsGeneral : SettingsAmbient;
Visual Basic
Public Class SettingsGeneral
Inherits SettingsAmbient
Links
SettingsGeneral Properties, SettingsGeneral Members, Class Hierarchy


SettingsGeneral Members

The following tables list the members exposed by SettingsGeneral.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsGeneral Properties

The properties of SettingsGeneral are listed here.

Public Properties
Public Property | Description
Styles | Gets the default styles for general.
Links
Public Properties


SettingsGeneral::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral Class > SettingsGeneral Properties > SettingsGeneral::Styles Property
SettingsGeneral::Styles Property
Collapse All

Gets the default styles for general.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsGeneral Class, SettingsGeneral Members, Autodesk::Civil::Settings Namespace


SettingsGeneral::SettingsStyles Class

Default styles settings class.

Class Hierarchy
Autodesk::Civil::Settings::SettingsGeneral::SettingsStyles
C#
public class SettingsGeneral::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsGeneral::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsGeneral::SettingsStyles Properties, SettingsGeneral::SettingsStyles Members, Class Hierarchy


SettingsGeneral::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral::SettingsStyles Class > SettingsGeneral::SettingsStyles Members
SettingsGeneral::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsGeneral::SettingsStyles.

Public Properties
Public Property | Description
CurveLabel | Gets the default style to use when inserting Curve labels.
LineLabel | Gets the default style to use when inserting Line labels.
NoteLabel | Gets the default style to use when inserting Note labels.
Links
Public Properties


SettingsGeneral::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral::SettingsStyles Class > SettingsGeneral::SettingsStyles Properties
SettingsGeneral::SettingsStyles Properties
Collapse All

The properties of SettingsGeneral::SettingsStyles are listed here.

Public Properties
Public Property | Description
CurveLabel | Gets the default style to use when inserting Curve labels.
LineLabel | Gets the default style to use when inserting Line labels.
NoteLabel | Gets the default style to use when inserting Note labels.
Links
Public Properties


SettingsGeneral::SettingsStyles::CurveLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral::SettingsStyles Class > SettingsGeneral::SettingsStyles Properties > SettingsGeneral::SettingsStyles::CurveLabel Property
SettingsGeneral::SettingsStyles::CurveLabel Property
Collapse All

Gets the default style to use when inserting Curve labels.

C#
public PropertyString CurveLabel;
Visual Basic
Public Property CurveLabel() As PropertyString
Links
SettingsGeneral::SettingsStyles Class, SettingsGeneral::SettingsStyles Members, Autodesk::Civil::Settings Namespace


SettingsGeneral::SettingsStyles::LineLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral::SettingsStyles Class > SettingsGeneral::SettingsStyles Properties > SettingsGeneral::SettingsStyles::LineLabel Property
SettingsGeneral::SettingsStyles::LineLabel Property
Collapse All

Gets the default style to use when inserting Line labels.

C#
public PropertyString LineLabel;
Visual Basic
Public Property LineLabel() As PropertyString
Links
SettingsGeneral::SettingsStyles Class, SettingsGeneral::SettingsStyles Members, Autodesk::Civil::Settings Namespace


SettingsGeneral::SettingsStyles::NoteLabel Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral::SettingsStyles Class > SettingsGeneral::SettingsStyles Properties > SettingsGeneral::SettingsStyles::NoteLabel Property
SettingsGeneral::SettingsStyles::NoteLabel Property
Collapse All

Gets the default style to use when inserting Note labels.

C#
public PropertyString NoteLabel;
Visual Basic
Public Property NoteLabel() As PropertyString
Links
SettingsGeneral::SettingsStyles Class, SettingsGeneral::SettingsStyles Members, Autodesk::Civil::Settings Namespace


SettingsLandXML Class

Settings that define how data is imported from LandXML file.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXML
C#
public class SettingsLandXML : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXML
Inherits TreeOidWrapper
Links
SettingsLandXML Properties, SettingsLandXML Members, Class Hierarchy


SettingsLandXML Members

The following tables list the members exposed by SettingsLandXML.

Public Properties
Public Property | Description
Export | Export settings for landXML.
Import | Import settings for landXML.
Links
Public Properties


SettingsLandXML Properties

The properties of SettingsLandXML are listed here.

Public Properties
Public Property | Description
Export | Export settings for landXML.
Import | Import settings for landXML.
Links
Public Properties


SettingsLandXML::Export Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXML Class > SettingsLandXML Properties > SettingsLandXML::Export Property
SettingsLandXML::Export Property
Collapse All

Export settings for landXML.

C#
public SettingsLandXMLExport Export;
Visual Basic
Public Property Export() As SettingsLandXMLExport
Links
SettingsLandXML Class, SettingsLandXML Members, Autodesk::Civil::Settings Namespace


SettingsLandXML::Import Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXML Class > SettingsLandXML Properties > SettingsLandXML::Import Property
SettingsLandXML::Import Property
Collapse All

Import settings for landXML.

C#
public SettingsLandXMLImport Import;
Visual Basic
Public Property Import() As SettingsLandXMLImport
Links
SettingsLandXML Class, SettingsLandXML Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport Class

Settings that define how data is exported from LandXML file.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport
C#
public class SettingsLandXMLExport : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLExport
Inherits TreeOidWrapper
Links
SettingsLandXMLExport Properties, SettingsLandXMLExport Members, Class Hierarchy


SettingsLandXMLExport Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Members
SettingsLandXMLExport Members
Collapse All

The following tables list the members exposed by SettingsLandXMLExport.

Public Properties
Public Property | Description
AlignmentExport | AlignmentExport settings for LandXML exporting.
Data | Data settings for LandXML exporting.
Identification | Identification settings for LandXML exporting.
ParcelExport | ParcelExport settings for LandXML exporting.
PointExport | PointExport settings for LandXML exporting.
SurfaceExport | SurfaceExport settings for LandXML exporting.
Links
Public Properties


SettingsLandXMLExport Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Properties
SettingsLandXMLExport Properties
Collapse All

The properties of SettingsLandXMLExport are listed here.

Public Properties
Public Property | Description
AlignmentExport | AlignmentExport settings for LandXML exporting.
Data | Data settings for LandXML exporting.
Identification | Identification settings for LandXML exporting.
ParcelExport | ParcelExport settings for LandXML exporting.
PointExport | PointExport settings for LandXML exporting.
SurfaceExport | SurfaceExport settings for LandXML exporting.
Links
Public Properties


SettingsLandXMLExport::AlignmentExport Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Properties > SettingsLandXMLExport::AlignmentExport Property
SettingsLandXMLExport::AlignmentExport Property
Collapse All

AlignmentExport settings for LandXML exporting.

C#
public SettingsAlignmentExport AlignmentExport;
Visual Basic
Public Property AlignmentExport() As SettingsAlignmentExport
Links
SettingsLandXMLExport Class, SettingsLandXMLExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::Data Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Properties > SettingsLandXMLExport::Data Property
SettingsLandXMLExport::Data Property
Collapse All

Data settings for LandXML exporting.

C#
public SettingsData Data;
Visual Basic
Public Property Data() As SettingsData
Links
SettingsLandXMLExport Class, SettingsLandXMLExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::Identification Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Properties > SettingsLandXMLExport::Identification Property
SettingsLandXMLExport::Identification Property
Collapse All

Identification settings for LandXML exporting.

C#
public SettingsIdentification Identification;
Visual Basic
Public Property Identification() As SettingsIdentification
Links
SettingsLandXMLExport Class, SettingsLandXMLExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::ParcelExport Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Properties > SettingsLandXMLExport::ParcelExport Property
SettingsLandXMLExport::ParcelExport Property
Collapse All

ParcelExport settings for LandXML exporting.

C#
public SettingsParcelExport ParcelExport;
Visual Basic
Public Property ParcelExport() As SettingsParcelExport
Links
SettingsLandXMLExport Class, SettingsLandXMLExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::PointExport Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Properties > SettingsLandXMLExport::PointExport Property
SettingsLandXMLExport::PointExport Property
Collapse All

PointExport settings for LandXML exporting.

C#
public SettingsPointExport PointExport;
Visual Basic
Public Property PointExport() As SettingsPointExport
Links
SettingsLandXMLExport Class, SettingsLandXMLExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SurfaceExport Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Properties > SettingsLandXMLExport::SurfaceExport Property
SettingsLandXMLExport::SurfaceExport Property
Collapse All

SurfaceExport settings for LandXML exporting.

C#
public SettingsSurfaceExport SurfaceExport;
Visual Basic
Public Property SurfaceExport() As SettingsSurfaceExport
Links
SettingsLandXMLExport Class, SettingsLandXMLExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsAlignmentExport Class

Alignment Settings for LandXML export.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsAlignmentExport
C#
public class SettingsLandXMLExport::SettingsAlignmentExport : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLExport::SettingsAlignmentExport
Inherits TreeOidWrapper
Links
SettingsLandXMLExport::SettingsAlignmentExport Properties, SettingsLandXMLExport::SettingsAlignmentExport Members, Class Hierarchy


SettingsLandXMLExport::SettingsAlignmentExport Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsAlignmentExport Class > SettingsLandXMLExport::SettingsAlignmentExport Members
SettingsLandXMLExport::SettingsAlignmentExport Members
Collapse All

The following tables list the members exposed by SettingsLandXMLExport::SettingsAlignmentExport.

Public Properties
Public Property | Description
ExportCrossSections | Exports cross section data if sample lines are defined for the alignment.
Links
Public Properties


SettingsLandXMLExport::SettingsAlignmentExport Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsAlignmentExport Class > SettingsLandXMLExport::SettingsAlignmentExport Properties
SettingsLandXMLExport::SettingsAlignmentExport Properties
Collapse All

The properties of SettingsLandXMLExport::SettingsAlignmentExport are listed here.

Public Properties
Public Property | Description
ExportCrossSections | Exports cross section data if sample lines are defined for the alignment.
Links
Public Properties


SettingsLandXMLExport::SettingsAlignmentExport::ExportCrossSections Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsAlignmentExport Class > SettingsLandXMLExport::SettingsAlignmentExport Properties > SettingsLandXMLExport::SettingsAlignmentExport::ExportCrossSections Property
SettingsLandXMLExport::SettingsAlignmentExport::ExportCrossSections Property
Collapse All

Exports cross section data if sample lines are defined for the alignment.

C#
public bool ExportCrossSections;
Visual Basic
Public Property ExportCrossSections() As bool
Links
SettingsLandXMLExport::SettingsAlignmentExport Class, SettingsLandXMLExport::SettingsAlignmentExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsData Class

Data Settings for LandXML export.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsData
C#
public class SettingsLandXMLExport::SettingsData : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLExport::SettingsData
Inherits TreeOidWrapper
Links
SettingsLandXMLExport::SettingsData Properties, SettingsLandXMLExport::SettingsData Members, Class Hierarchy


SettingsLandXMLExport::SettingsData Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsData Class > SettingsLandXMLExport::SettingsData Members
SettingsLandXMLExport::SettingsData Members
Collapse All

The following tables list the members exposed by SettingsLandXMLExport::SettingsData.

Public Properties
Public Property | Description
AngleDirectionFormat | Specifies the units of the exported angles and directions.
CreateReadOnlyFile | Specifies whether the LandXML file is created as a read-only file. This is done in two places: a tag is... more
ImperialUnits | Specifies how to tag LandXML data when working in Imperial units.
Links
Public Properties


SettingsLandXMLExport::SettingsData Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsData Class > SettingsLandXMLExport::SettingsData Properties
SettingsLandXMLExport::SettingsData Properties
Collapse All

The properties of SettingsLandXMLExport::SettingsData are listed here.

Public Properties
Public Property | Description
AngleDirectionFormat | Specifies the units of the exported angles and directions.
CreateReadOnlyFile | Specifies whether the LandXML file is created as a read-only file. This is done in two places: a tag is... more
ImperialUnits | Specifies how to tag LandXML data when working in Imperial units.
Links
Public Properties


SettingsLandXMLExport::SettingsData::AngleDirectionFormat Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsData Class > SettingsLandXMLExport::SettingsData Properties > SettingsLandXMLExport::SettingsData::AngleDirectionFormat Property
SettingsLandXMLExport::SettingsData::AngleDirectionFormat Property
Collapse All

Specifies the units of the exported angles and directions.

C#
public LandXMLAngularUnits AngleDirectionFormat;
Visual Basic
Public Property AngleDirectionFormat() As LandXMLAngularUnits
Links
SettingsLandXMLExport::SettingsData Class, SettingsLandXMLExport::SettingsData Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsData::CreateReadOnlyFile Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsData Class > SettingsLandXMLExport::SettingsData Properties > SettingsLandXMLExport::SettingsData::CreateReadOnlyFile Property
SettingsLandXMLExport::SettingsData::CreateReadOnlyFile Property
Collapse All

Specifies whether the LandXML file is created as a read-only file. This is done in two places: a tag is inserted into the LandXML, and the operating system file attributes on the file are set to read only.

C#
public bool CreateReadOnlyFile;
Visual Basic
Public Property CreateReadOnlyFile() As bool
Links
SettingsLandXMLExport::SettingsData Class, SettingsLandXMLExport::SettingsData Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsData::ImperialUnits Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsData Class > SettingsLandXMLExport::SettingsData Properties > SettingsLandXMLExport::SettingsData::ImperialUnits Property
SettingsLandXMLExport::SettingsData::ImperialUnits Property
Collapse All

Specifies how to tag LandXML data when working in Imperial units.

C#
public LandXMLLinearUnits ImperialUnits;
Visual Basic
Public Property ImperialUnits() As LandXMLLinearUnits
Links
SettingsLandXMLExport::SettingsData Class, SettingsLandXMLExport::SettingsData Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsIdentification Class

Identification Settings for LandXML export.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsIdentification
C#
public class SettingsLandXMLExport::SettingsIdentification : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLExport::SettingsIdentification
Inherits TreeOidWrapper
Links
SettingsLandXMLExport::SettingsIdentification Properties, SettingsLandXMLExport::SettingsIdentification Members, Class Hierarchy


SettingsLandXMLExport::SettingsIdentification Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Members
SettingsLandXMLExport::SettingsIdentification Members
Collapse All

The following tables list the members exposed by SettingsLandXMLExport::SettingsIdentification.

Public Properties
Public Property | Description
Company | Specifies the creator’s company.
CompanyURL | Specifies the company’s URL.
Creator | Specifies the creator of the LandXML file.
EmailAddress | Specifies the creator’s email address.
WriteIdentificationElements | Specifies whether the identification properties are written to the LandXML file.
Links
Public Properties


SettingsLandXMLExport::SettingsIdentification Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Properties
SettingsLandXMLExport::SettingsIdentification Properties
Collapse All

The properties of SettingsLandXMLExport::SettingsIdentification are listed here.

Public Properties
Public Property | Description
Company | Specifies the creator’s company.
CompanyURL | Specifies the company’s URL.
Creator | Specifies the creator of the LandXML file.
EmailAddress | Specifies the creator’s email address.
WriteIdentificationElements | Specifies whether the identification properties are written to the LandXML file.
Links
Public Properties


SettingsLandXMLExport::SettingsIdentification::Company Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Properties > SettingsLandXMLExport::SettingsIdentification::Company Property
SettingsLandXMLExport::SettingsIdentification::Company Property
Collapse All

Specifies the creator’s company.

C#
public System::String Company;
Visual Basic
Public Property Company() As System::String
Links
SettingsLandXMLExport::SettingsIdentification Class, SettingsLandXMLExport::SettingsIdentification Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsIdentification::CompanyURL Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Properties > SettingsLandXMLExport::SettingsIdentification::CompanyURL Property
SettingsLandXMLExport::SettingsIdentification::CompanyURL Property
Collapse All

Specifies the company’s URL.

C#
public System::String CompanyURL;
Visual Basic
Public Property CompanyURL() As System::String
Links
SettingsLandXMLExport::SettingsIdentification Class, SettingsLandXMLExport::SettingsIdentification Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsIdentification::Creator Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Properties > SettingsLandXMLExport::SettingsIdentification::Creator Property
SettingsLandXMLExport::SettingsIdentification::Creator Property
Collapse All

Specifies the creator of the LandXML file.

C#
public System::String Creator;
Visual Basic
Public Property Creator() As System::String
Links
SettingsLandXMLExport::SettingsIdentification Class, SettingsLandXMLExport::SettingsIdentification Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsIdentification::EmailAddress Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Properties > SettingsLandXMLExport::SettingsIdentification::EmailAddress Property
SettingsLandXMLExport::SettingsIdentification::EmailAddress Property
Collapse All

Specifies the creator’s email address.

C#
public System::String EmailAddress;
Visual Basic
Public Property EmailAddress() As System::String
Links
SettingsLandXMLExport::SettingsIdentification Class, SettingsLandXMLExport::SettingsIdentification Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsIdentification::WriteIdentificationElements Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Properties > SettingsLandXMLExport::SettingsIdentification::WriteIdentificationElements Property
SettingsLandXMLExport::SettingsIdentification::WriteIdentificationElements Property
Collapse All

Specifies whether the identification properties are written to the LandXML file.

C#
public bool WriteIdentificationElements;
Visual Basic
Public Property WriteIdentificationElements() As bool
Links
SettingsLandXMLExport::SettingsIdentification Class, SettingsLandXMLExport::SettingsIdentification Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsParcelExport Class

Parcel Settings for LandXML export.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsParcelExport
C#
public class SettingsLandXMLExport::SettingsParcelExport : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLExport::SettingsParcelExport
Inherits TreeOidWrapper
Links
SettingsLandXMLExport::SettingsParcelExport Properties, SettingsLandXMLExport::SettingsParcelExport Members, Class Hierarchy


SettingsLandXMLExport::SettingsParcelExport Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsParcelExport Class > SettingsLandXMLExport::SettingsParcelExport Members
SettingsLandXMLExport::SettingsParcelExport Members
Collapse All

The following tables list the members exposed by SettingsLandXMLExport::SettingsParcelExport.

Public Properties
Public Property | Description
ParcelDirection | Specifies the direction from the parcel start point for exporting parcel segments. Parcel segments are exported in sequence in either... more
Links
Public Properties


SettingsLandXMLExport::SettingsParcelExport Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsParcelExport Class > SettingsLandXMLExport::SettingsParcelExport Properties
SettingsLandXMLExport::SettingsParcelExport Properties
Collapse All

The properties of SettingsLandXMLExport::SettingsParcelExport are listed here.

Public Properties
Public Property | Description
ParcelDirection | Specifies the direction from the parcel start point for exporting parcel segments. Parcel segments are exported in sequence in either... more
Links
Public Properties


SettingsLandXMLExport::SettingsParcelExport::ParcelDirection Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsParcelExport Class > SettingsLandXMLExport::SettingsParcelExport Properties > SettingsLandXMLExport::SettingsParcelExport::ParcelDirection Property
SettingsLandXMLExport::SettingsParcelExport::ParcelDirection Property
Collapse All

Specifies the direction from the parcel start point for exporting parcel segments. Parcel segments are exported in sequence in either a clockwise or counter-clockwise direction.

C#
public RotationDirType ParcelDirection;
Visual Basic
Public Property ParcelDirection() As RotationDirType
Links
SettingsLandXMLExport::SettingsParcelExport Class, SettingsLandXMLExport::SettingsParcelExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsPointExport Class

Point Settings for LandXML export.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsPointExport
C#
public class SettingsLandXMLExport::SettingsPointExport : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLExport::SettingsPointExport
Inherits TreeOidWrapper
Links
SettingsLandXMLExport::SettingsPointExport Properties, SettingsLandXMLExport::SettingsPointExport Members, Class Hierarchy


SettingsLandXMLExport::SettingsPointExport Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Members
SettingsLandXMLExport::SettingsPointExport Members
Collapse All

The following tables list the members exposed by SettingsLandXMLExport::SettingsPointExport.

Public Properties
Public Property | Description
CodeAttribute | Specifies the field that is used for the ‘code’ attribute in the LandXML file.
DescAttribute | Specifies the field that is used for the ‘desc’ attribute in the LandXML file
ExportDescriptionKeys | Specifies whether the description key definitions are exported. Select On to export all description key definitions in the drawing. If... more
ExportPointReferences | Specifies whether to export point references. Point references substitute a known point name instead of using northing and easting coordinates.... more
PointReferenceTolerance | Specifies the tolerance value for point references.
SkipFullWhenSameAsRaw | Specifies whether to export the full description if it is the same as the raw description.
Links
Public Properties


SettingsLandXMLExport::SettingsPointExport Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Properties
SettingsLandXMLExport::SettingsPointExport Properties
Collapse All

The properties of SettingsLandXMLExport::SettingsPointExport are listed here.

Public Properties
Public Property | Description
CodeAttribute | Specifies the field that is used for the ‘code’ attribute in the LandXML file.
DescAttribute | Specifies the field that is used for the ‘desc’ attribute in the LandXML file
ExportDescriptionKeys | Specifies whether the description key definitions are exported. Select On to export all description key definitions in the drawing. If... more
ExportPointReferences | Specifies whether to export point references. Point references substitute a known point name instead of using northing and easting coordinates.... more
PointReferenceTolerance | Specifies the tolerance value for point references.
SkipFullWhenSameAsRaw | Specifies whether to export the full description if it is the same as the raw description.
Links
Public Properties


SettingsLandXMLExport::SettingsPointExport::CodeAttribute Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Properties > SettingsLandXMLExport::SettingsPointExport::CodeAttribute Property
SettingsLandXMLExport::SettingsPointExport::CodeAttribute Property
Collapse All

Specifies the field that is used for the ‘code’ attribute in the LandXML file.

C#
public LandXMLAttributeExportType CodeAttribute;
Visual Basic
Public Property CodeAttribute() As LandXMLAttributeExportType
Links
SettingsLandXMLExport::SettingsPointExport Class, SettingsLandXMLExport::SettingsPointExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsPointExport::DescAttribute Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Properties > SettingsLandXMLExport::SettingsPointExport::DescAttribute Property
SettingsLandXMLExport::SettingsPointExport::DescAttribute Property
Collapse All

Specifies the field that is used for the ‘desc’ attribute in the LandXML file

C#
public LandXMLAttributeExportType DescAttribute;
Visual Basic
Public Property DescAttribute() As LandXMLAttributeExportType
Links
SettingsLandXMLExport::SettingsPointExport Class, SettingsLandXMLExport::SettingsPointExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsPointExport::ExportDescriptionKeys Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Properties > SettingsLandXMLExport::SettingsPointExport::ExportDescriptionKeys Property
SettingsLandXMLExport::SettingsPointExport::ExportDescriptionKeys Property
Collapse All

Specifies whether the description key definitions are exported. Select On to export all description key definitions in the drawing. If there are description keys in the drawing, a message dialog box is displayed.

C#
public bool ExportDescriptionKeys;
Visual Basic
Public Property ExportDescriptionKeys() As bool
Links
SettingsLandXMLExport::SettingsPointExport Class, SettingsLandXMLExport::SettingsPointExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsPointExport::ExportPointReferences Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Properties > SettingsLandXMLExport::SettingsPointExport::ExportPointReferences Property
SettingsLandXMLExport::SettingsPointExport::ExportPointReferences Property
Collapse All

Specifies whether to export point references. Point references substitute a known point name instead of using northing and easting coordinates.

C#
public bool ExportPointReferences;
Visual Basic
Public Property ExportPointReferences() As bool
Links
SettingsLandXMLExport::SettingsPointExport Class, SettingsLandXMLExport::SettingsPointExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsPointExport::PointReferenceTolerance Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Properties > SettingsLandXMLExport::SettingsPointExport::PointReferenceTolerance Property
SettingsLandXMLExport::SettingsPointExport::PointReferenceTolerance Property
Collapse All

Specifies the tolerance value for point references.

C#
public double PointReferenceTolerance;
Visual Basic
Public Property PointReferenceTolerance() As double
Links
SettingsLandXMLExport::SettingsPointExport Class, SettingsLandXMLExport::SettingsPointExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsPointExport::SkipFullWhenSameAsRaw Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Properties > SettingsLandXMLExport::SettingsPointExport::SkipFullWhenSameAsRaw Property
SettingsLandXMLExport::SettingsPointExport::SkipFullWhenSameAsRaw Property
Collapse All

Specifies whether to export the full description if it is the same as the raw description.

C#
public bool SkipFullWhenSameAsRaw;
Visual Basic
Public Property SkipFullWhenSameAsRaw() As bool
Links
SettingsLandXMLExport::SettingsPointExport Class, SettingsLandXMLExport::SettingsPointExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsSurfaceExport Class

Surface Settings for LandXML export.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsSurfaceExport
C#
public class SettingsLandXMLExport::SettingsSurfaceExport : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLExport::SettingsSurfaceExport
Inherits TreeOidWrapper
Links
SettingsLandXMLExport::SettingsSurfaceExport Properties, SettingsLandXMLExport::SettingsSurfaceExport Members, Class Hierarchy


SettingsLandXMLExport::SettingsSurfaceExport Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsSurfaceExport Class > SettingsLandXMLExport::SettingsSurfaceExport Members
SettingsLandXMLExport::SettingsSurfaceExport Members
Collapse All

The following tables list the members exposed by SettingsLandXMLExport::SettingsSurfaceExport.

Public Properties
Public Property | Description
SurfaceData | Specifies how to export the surface data.
Watersheds | Exports both the points and the surface faces, if available. Creates the surface information from the face edges and creates... more
Links
Public Properties


SettingsLandXMLExport::SettingsSurfaceExport Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsSurfaceExport Class > SettingsLandXMLExport::SettingsSurfaceExport Properties
SettingsLandXMLExport::SettingsSurfaceExport Properties
Collapse All

The properties of SettingsLandXMLExport::SettingsSurfaceExport are listed here.

Public Properties
Public Property | Description
SurfaceData | Specifies how to export the surface data.
Watersheds | Exports both the points and the surface faces, if available. Creates the surface information from the face edges and creates... more
Links
Public Properties


SettingsLandXMLExport::SettingsSurfaceExport::SurfaceData Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsSurfaceExport Class > SettingsLandXMLExport::SettingsSurfaceExport Properties > SettingsLandXMLExport::SettingsSurfaceExport::SurfaceData Property
SettingsLandXMLExport::SettingsSurfaceExport::SurfaceData Property
Collapse All

Specifies how to export the surface data.

C#
public LandXMLSurfaceDataExportType SurfaceData;
Visual Basic
Public Property SurfaceData() As LandXMLSurfaceDataExportType
Links
SettingsLandXMLExport::SettingsSurfaceExport Class, SettingsLandXMLExport::SettingsSurfaceExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLExport::SettingsSurfaceExport::Watersheds Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsSurfaceExport Class > SettingsLandXMLExport::SettingsSurfaceExport Properties > SettingsLandXMLExport::SettingsSurfaceExport::Watersheds Property
SettingsLandXMLExport::SettingsSurfaceExport::Watersheds Property
Collapse All

Exports both the points and the surface faces, if available. Creates the surface information from the face edges and creates a surface that is identical to the surface definition.

C#
public bool Watersheds;
Visual Basic
Public Property Watersheds() As bool
Links
SettingsLandXMLExport::SettingsSurfaceExport Class, SettingsLandXMLExport::SettingsSurfaceExport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport Class

Settings that define how data is imported from LandXML file.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport
C#
public class SettingsLandXMLImport : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLImport
Inherits TreeOidWrapper
Links
SettingsLandXMLImport Properties, SettingsLandXMLImport Members, Class Hierarchy


SettingsLandXMLImport Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Members
SettingsLandXMLImport Members
Collapse All

The following tables list the members exposed by SettingsLandXMLImport.

Public Properties
Public Property | Description
ConflictResolution | ConflictResolution settings for LandXML importing.
DiameterUnits | DiameterUnits settings for LandXML importing.
PipeNetwork | PipeNetwork settings for LandXML importing.
PointImport | PointImport settings for LandXML importing.
Rotation | Rotation settings for LandXML importing.
SurfaceImport | SurfaceImport settings for LandXML importing.
Translation | Translation settings for LandXML importing.
Links
Public Properties


SettingsLandXMLImport Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties
SettingsLandXMLImport Properties
Collapse All

The properties of SettingsLandXMLImport are listed here.

Public Properties
Public Property | Description
ConflictResolution | ConflictResolution settings for LandXML importing.
DiameterUnits | DiameterUnits settings for LandXML importing.
PipeNetwork | PipeNetwork settings for LandXML importing.
PointImport | PointImport settings for LandXML importing.
Rotation | Rotation settings for LandXML importing.
SurfaceImport | SurfaceImport settings for LandXML importing.
Translation | Translation settings for LandXML importing.
Links
Public Properties


SettingsLandXMLImport::ConflictResolution Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties > SettingsLandXMLImport::ConflictResolution Property
SettingsLandXMLImport::ConflictResolution Property
Collapse All

ConflictResolution settings for LandXML importing.

C#
public SettingsConflictResolution ConflictResolution;
Visual Basic
Public Property ConflictResolution() As SettingsConflictResolution
Links
SettingsLandXMLImport Class, SettingsLandXMLImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::DiameterUnits Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties > SettingsLandXMLImport::DiameterUnits Property
SettingsLandXMLImport::DiameterUnits Property
Collapse All

DiameterUnits settings for LandXML importing.

C#
public SettingsDiameterUnits DiameterUnits;
Visual Basic
Public Property DiameterUnits() As SettingsDiameterUnits
Links
SettingsLandXMLImport Class, SettingsLandXMLImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::PipeNetwork Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties > SettingsLandXMLImport::PipeNetwork Property
SettingsLandXMLImport::PipeNetwork Property
Collapse All

PipeNetwork settings for LandXML importing.

C#
public SettingsPipeNetwork PipeNetwork;
Visual Basic
Public Property PipeNetwork() As SettingsPipeNetwork
Links
SettingsLandXMLImport Class, SettingsLandXMLImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::PointImport Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties > SettingsLandXMLImport::PointImport Property
SettingsLandXMLImport::PointImport Property
Collapse All

PointImport settings for LandXML importing.

C#
public SettingsPointImport PointImport;
Visual Basic
Public Property PointImport() As SettingsPointImport
Links
SettingsLandXMLImport Class, SettingsLandXMLImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::Rotation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties > SettingsLandXMLImport::Rotation Property
SettingsLandXMLImport::Rotation Property
Collapse All

Rotation settings for LandXML importing.

C#
public SettingsRotation Rotation;
Visual Basic
Public Property Rotation() As SettingsRotation
Links
SettingsLandXMLImport Class, SettingsLandXMLImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SurfaceImport Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties > SettingsLandXMLImport::SurfaceImport Property
SettingsLandXMLImport::SurfaceImport Property
Collapse All

SurfaceImport settings for LandXML importing.

C#
public SettingsSurfaceImport SurfaceImport;
Visual Basic
Public Property SurfaceImport() As SettingsSurfaceImport
Links
SettingsLandXMLImport Class, SettingsLandXMLImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::Translation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties > SettingsLandXMLImport::Translation Property
SettingsLandXMLImport::Translation Property
Collapse All

Translation settings for LandXML importing.

C#
public SettingsTranslation Translation;
Visual Basic
Public Property Translation() As SettingsTranslation
Links
SettingsLandXMLImport Class, SettingsLandXMLImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsConflictResolution Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsConflictResolution Class
SettingsLandXMLImport::SettingsConflictResolution Class
Collapse All

ConflictResolution settings for LandXML importing.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsConflictResolution
C#
public class SettingsLandXMLImport::SettingsConflictResolution : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLImport::SettingsConflictResolution
Inherits TreeOidWrapper
Links
SettingsLandXMLImport::SettingsConflictResolution Properties, SettingsLandXMLImport::SettingsConflictResolution Members, Class Hierarchy


SettingsLandXMLImport::SettingsConflictResolution Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsConflictResolution Class > SettingsLandXMLImport::SettingsConflictResolution Members
SettingsLandXMLImport::SettingsConflictResolution Members
Collapse All

The following tables list the members exposed by SettingsLandXMLImport::SettingsConflictResolution.

Public Properties
Public Property | Description
ConflictResolution | Specifies how objects with the same name are handled.
Links
Public Properties


SettingsLandXMLImport::SettingsConflictResolution Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsConflictResolution Class > SettingsLandXMLImport::SettingsConflictResolution Properties
SettingsLandXMLImport::SettingsConflictResolution Properties
Collapse All

The properties of SettingsLandXMLImport::SettingsConflictResolution are listed here.

Public Properties
Public Property | Description
ConflictResolution | Specifies how objects with the same name are handled.
Links
Public Properties


SettingsLandXMLImport::SettingsConflictResolution::ConflictResolution Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsConflictResolution Class > SettingsLandXMLImport::SettingsConflictResolution Properties > SettingsLandXMLImport::SettingsConflictResolution::ConflictResolution Property
SettingsLandXMLImport::SettingsConflictResolution::ConflictResolution Property
Collapse All

Specifies how objects with the same name are handled.

C#
public LandXMLConflictResolutionType ConflictResolution;
Visual Basic
Public Property ConflictResolution() As LandXMLConflictResolutionType
Links
SettingsLandXMLImport::SettingsConflictResolution Class, SettingsLandXMLImport::SettingsConflictResolution Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsDiameterUnits Class

On import, AutoCAD Civil 3D reads the LandXML.Units.diameterUnits, and if they are defined, those units are used for both pipes and structures. If units are not defined, the following unit settings are applied. Either the Imperial or Metric diameter settings are applied, based on the defined LandXML.Units.linearUnit in the file.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsDiameterUnits
C#
public class SettingsLandXMLImport::SettingsDiameterUnits : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLImport::SettingsDiameterUnits
Inherits TreeOidWrapper
Links
SettingsLandXMLImport::SettingsDiameterUnits Properties, SettingsLandXMLImport::SettingsDiameterUnits Members, Class Hierarchy


SettingsLandXMLImport::SettingsDiameterUnits Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsDiameterUnits Class > SettingsLandXMLImport::SettingsDiameterUnits Members
SettingsLandXMLImport::SettingsDiameterUnits Members
Collapse All

The following tables list the members exposed by SettingsLandXMLImport::SettingsDiameterUnits.

Public Properties
Public Property | Description
Imperial | Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source... more
Metric | Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source... more
Links
Public Properties


SettingsLandXMLImport::SettingsDiameterUnits Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsDiameterUnits Class > SettingsLandXMLImport::SettingsDiameterUnits Properties
SettingsLandXMLImport::SettingsDiameterUnits Properties
Collapse All

The properties of SettingsLandXMLImport::SettingsDiameterUnits are listed here.

Public Properties
Public Property | Description
Imperial | Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source... more
Metric | Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source... more
Links
Public Properties


SettingsLandXMLImport::SettingsDiameterUnits::Imperial Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsDiameterUnits Class > SettingsLandXMLImport::SettingsDiameterUnits Properties > SettingsLandXMLImport::SettingsDiameterUnits::Imperial Property
SettingsLandXMLImport::SettingsDiameterUnits::Imperial Property
Collapse All

Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source LandXML file.

C#
public LandXMLImperialUnitType Imperial;
Visual Basic
Public Property Imperial() As LandXMLImperialUnitType
Links
SettingsLandXMLImport::SettingsDiameterUnits Class, SettingsLandXMLImport::SettingsDiameterUnits Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsDiameterUnits::Metric Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsDiameterUnits Class > SettingsLandXMLImport::SettingsDiameterUnits Properties > SettingsLandXMLImport::SettingsDiameterUnits::Metric Property
SettingsLandXMLImport::SettingsDiameterUnits::Metric Property
Collapse All

Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source LandXML file.

C#
public LandXMLMetricUnitType Metric;
Visual Basic
Public Property Metric() As LandXMLMetricUnitType
Links
SettingsLandXMLImport::SettingsDiameterUnits Class, SettingsLandXMLImport::SettingsDiameterUnits Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork Class

PipeNetwork settings for LandXML importing.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsPipeNetwork
C#
public class SettingsLandXMLImport::SettingsPipeNetwork : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLImport::SettingsPipeNetwork
Inherits TreeOidWrapper
Links
SettingsLandXMLImport::SettingsPipeNetwork Properties, SettingsLandXMLImport::SettingsPipeNetwork Members, Class Hierarchy


SettingsLandXMLImport::SettingsPipeNetwork Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Members
SettingsLandXMLImport::SettingsPipeNetwork Members
Collapse All

The following tables list the members exposed by SettingsLandXMLImport::SettingsPipeNetwork.

Public Properties
Public Property | Description
MatchChannelShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchCircularPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchCircularStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchConnectionStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchEggShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchEllipticalShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchInletOutletStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchRectangleShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchRectangleStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
PartsListForPartFamilySizeMatching | Specifies the pipe network parts list that is used during import to match pipe network part types in a LandXML... more
Links
Public Properties


SettingsLandXMLImport::SettingsPipeNetwork Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties
SettingsLandXMLImport::SettingsPipeNetwork Properties
Collapse All

The properties of SettingsLandXMLImport::SettingsPipeNetwork are listed here.

Public Properties
Public Property | Description
MatchChannelShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchCircularPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchCircularStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchConnectionStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchEggShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchEllipticalShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchInletOutletStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchRectangleShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchRectangleStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
PartsListForPartFamilySizeMatching | Specifies the pipe network parts list that is used during import to match pipe network part types in a LandXML... more
Links
Public Properties


SettingsLandXMLImport::SettingsPipeNetwork::MatchChannelShapedPipesWith Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::MatchChannelShapedPipesWith Property
SettingsLandXMLImport::SettingsPipeNetwork::MatchChannelShapedPipesWith Property
Collapse All

Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.

C#
public System::String MatchChannelShapedPipesWith;
Visual Basic
Public Property MatchChannelShapedPipesWith() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork::MatchCircularPipesWith Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::MatchCircularPipesWith Property
SettingsLandXMLImport::SettingsPipeNetwork::MatchCircularPipesWith Property
Collapse All

Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.

C#
public System::String MatchCircularPipesWith;
Visual Basic
Public Property MatchCircularPipesWith() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork::MatchCircularStructuresWith Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::MatchCircularStructuresWith Property
SettingsLandXMLImport::SettingsPipeNetwork::MatchCircularStructuresWith Property
Collapse All

Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.

C#
public System::String MatchCircularStructuresWith;
Visual Basic
Public Property MatchCircularStructuresWith() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork::MatchConnectionStructuresWith Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::MatchConnectionStructuresWith Property
SettingsLandXMLImport::SettingsPipeNetwork::MatchConnectionStructuresWith Property
Collapse All

Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.

C#
public System::String MatchConnectionStructuresWith;
Visual Basic
Public Property MatchConnectionStructuresWith() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork::MatchEggShapedPipesWith Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::MatchEggShapedPipesWith Property
SettingsLandXMLImport::SettingsPipeNetwork::MatchEggShapedPipesWith Property
Collapse All

Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.

C#
public System::String MatchEggShapedPipesWith;
Visual Basic
Public Property MatchEggShapedPipesWith() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork::MatchEllipticalShapedPipesWith Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::MatchEllipticalShapedPipesWith Property
SettingsLandXMLImport::SettingsPipeNetwork::MatchEllipticalShapedPipesWith Property
Collapse All

Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.

C#
public System::String MatchEllipticalShapedPipesWith;
Visual Basic
Public Property MatchEllipticalShapedPipesWith() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork::MatchInletOutletStructuresWith Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::MatchInletOutletStructuresWith Property
SettingsLandXMLImport::SettingsPipeNetwork::MatchInletOutletStructuresWith Property
Collapse All

Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.

C#
public System::String MatchInletOutletStructuresWith;
Visual Basic
Public Property MatchInletOutletStructuresWith() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork::MatchRectangleShapedPipesWith Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::MatchRectangleShapedPipesWith Property
SettingsLandXMLImport::SettingsPipeNetwork::MatchRectangleShapedPipesWith Property
Collapse All

Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.

C#
public System::String MatchRectangleShapedPipesWith;
Visual Basic
Public Property MatchRectangleShapedPipesWith() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork::MatchRectangleStructuresWith Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::MatchRectangleStructuresWith Property
SettingsLandXMLImport::SettingsPipeNetwork::MatchRectangleStructuresWith Property
Collapse All

Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.

C#
public System::String MatchRectangleStructuresWith;
Visual Basic
Public Property MatchRectangleStructuresWith() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPipeNetwork::PartsListForPartFamilySizeMatching Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties > SettingsLandXMLImport::SettingsPipeNetwork::PartsListForPartFamilySizeMatching Property
SettingsLandXMLImport::SettingsPipeNetwork::PartsListForPartFamilySizeMatching Property
Collapse All

Specifies the pipe network parts list that is used during import to match pipe network part types in a LandXML file with pipe network part types in a AutoCAD Civil 3D parts list.

C#
public System::String PartsListForPartFamilySizeMatching;
Visual Basic
Public Property PartsListForPartFamilySizeMatching() As System::String
Links
SettingsLandXMLImport::SettingsPipeNetwork Class, SettingsLandXMLImport::SettingsPipeNetwork Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsPointImport Class

PointImport settings for LandXML importing.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsPointImport
C#
public class SettingsLandXMLImport::SettingsPointImport : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLImport::SettingsPointImport
Inherits TreeOidWrapper
Links
SettingsLandXMLImport::SettingsPointImport Properties, SettingsLandXMLImport::SettingsPointImport Members, Class Hierarchy


SettingsLandXMLImport::SettingsPointImport Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPointImport Class > SettingsLandXMLImport::SettingsPointImport Members
SettingsLandXMLImport::SettingsPointImport Members
Collapse All

The following tables list the members exposed by SettingsLandXMLImport::SettingsPointImport.

Public Properties
Public Property | Description
PointDescription | Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.
Links
Public Properties


SettingsLandXMLImport::SettingsPointImport Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPointImport Class > SettingsLandXMLImport::SettingsPointImport Properties
SettingsLandXMLImport::SettingsPointImport Properties
Collapse All

The properties of SettingsLandXMLImport::SettingsPointImport are listed here.

Public Properties
Public Property | Description
PointDescription | Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.
Links
Public Properties


SettingsLandXMLImport::SettingsPointImport::PointDescription Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPointImport Class > SettingsLandXMLImport::SettingsPointImport Properties > SettingsLandXMLImport::SettingsPointImport::PointDescription Property
SettingsLandXMLImport::SettingsPointImport::PointDescription Property
Collapse All

Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.

C#
public LandXMLPointDescriptionType PointDescription;
Visual Basic
Public Property PointDescription() As LandXMLPointDescriptionType
Links
SettingsLandXMLImport::SettingsPointImport Class, SettingsLandXMLImport::SettingsPointImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsRotation Class

Rotation settings for LandXML importing.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsRotation
C#
public class SettingsLandXMLImport::SettingsRotation : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLImport::SettingsRotation
Inherits TreeOidWrapper
Links
SettingsLandXMLImport::SettingsRotation Properties, SettingsLandXMLImport::SettingsRotation Members, Class Hierarchy


SettingsLandXMLImport::SettingsRotation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsRotation Class > SettingsLandXMLImport::SettingsRotation Members
SettingsLandXMLImport::SettingsRotation Members
Collapse All

The following tables list the members exposed by SettingsLandXMLImport::SettingsRotation.

Public Properties
Public Property | Description
Angle | Specifies the angle about the base point where the LandXML data is rotated.
Direction | Specifies the direction of rotation.
Rotate | Specifies whether to rotate data when importing it from the LandXML file.
Links
Public Properties


SettingsLandXMLImport::SettingsRotation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsRotation Class > SettingsLandXMLImport::SettingsRotation Properties
SettingsLandXMLImport::SettingsRotation Properties
Collapse All

The properties of SettingsLandXMLImport::SettingsRotation are listed here.

Public Properties
Public Property | Description
Angle | Specifies the angle about the base point where the LandXML data is rotated.
Direction | Specifies the direction of rotation.
Rotate | Specifies whether to rotate data when importing it from the LandXML file.
Links
Public Properties


SettingsLandXMLImport::SettingsRotation::Angle Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsRotation Class > SettingsLandXMLImport::SettingsRotation Properties > SettingsLandXMLImport::SettingsRotation::Angle Property
SettingsLandXMLImport::SettingsRotation::Angle Property
Collapse All

Specifies the angle about the base point where the LandXML data is rotated.

C#
public double Angle;
Visual Basic
Public Property Angle() As double
Links
SettingsLandXMLImport::SettingsRotation Class, SettingsLandXMLImport::SettingsRotation Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsRotation::Direction Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsRotation Class > SettingsLandXMLImport::SettingsRotation Properties > SettingsLandXMLImport::SettingsRotation::Direction Property
SettingsLandXMLImport::SettingsRotation::Direction Property
Collapse All

Specifies the direction of rotation.

C#
public RotationDirType Direction;
Visual Basic
Public Property Direction() As RotationDirType
Links
SettingsLandXMLImport::SettingsRotation Class, SettingsLandXMLImport::SettingsRotation Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsRotation::Rotate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsRotation Class > SettingsLandXMLImport::SettingsRotation Properties > SettingsLandXMLImport::SettingsRotation::Rotate Property
SettingsLandXMLImport::SettingsRotation::Rotate Property
Collapse All

Specifies whether to rotate data when importing it from the LandXML file.

C#
public bool Rotate;
Visual Basic
Public Property Rotate() As bool
Links
SettingsLandXMLImport::SettingsRotation Class, SettingsLandXMLImport::SettingsRotation Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsSurfaceImport Class

SurfaceImport settings for LandXML importing.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsSurfaceImport
C#
public class SettingsLandXMLImport::SettingsSurfaceImport : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLImport::SettingsSurfaceImport
Inherits TreeOidWrapper
Links
SettingsLandXMLImport::SettingsSurfaceImport Properties, SettingsLandXMLImport::SettingsSurfaceImport Members, Class Hierarchy


SettingsLandXMLImport::SettingsSurfaceImport Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Members
SettingsLandXMLImport::SettingsSurfaceImport Members
Collapse All

The following tables list the members exposed by SettingsLandXMLImport::SettingsSurfaceImport.

Public Properties
Public Property | Description
ConvertSurveyFootToInternationalFoot | Specifies whether to convert survey foot to international foot.
CreateSnapshotAfterImport | After importing surface data, a snapshot can automatically be created. By creating a snapshot after importing a LandXML file, AutoCAD... more
CreateSourceDataInDrawing | Imports the surface source data (breaklines, contours, points, and chains) into the drawing as 3D polylines and points.
SurfaceData | Specifies how to import the data.
Links
Public Properties


SettingsLandXMLImport::SettingsSurfaceImport Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Properties
SettingsLandXMLImport::SettingsSurfaceImport Properties
Collapse All

The properties of SettingsLandXMLImport::SettingsSurfaceImport are listed here.

Public Properties
Public Property | Description
ConvertSurveyFootToInternationalFoot | Specifies whether to convert survey foot to international foot.
CreateSnapshotAfterImport | After importing surface data, a snapshot can automatically be created. By creating a snapshot after importing a LandXML file, AutoCAD... more
CreateSourceDataInDrawing | Imports the surface source data (breaklines, contours, points, and chains) into the drawing as 3D polylines and points.
SurfaceData | Specifies how to import the data.
Links
Public Properties


SettingsLandXMLImport::SettingsSurfaceImport::ConvertSurveyFootToInternationalFoot Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Properties > SettingsLandXMLImport::SettingsSurfaceImport::ConvertSurveyFootToInternationalFoot Property
SettingsLandXMLImport::SettingsSurfaceImport::ConvertSurveyFootToInternationalFoot Property
Collapse All

Specifies whether to convert survey foot to international foot.

C#
public bool ConvertSurveyFootToInternationalFoot;
Visual Basic
Public Property ConvertSurveyFootToInternationalFoot() As bool
Links
SettingsLandXMLImport::SettingsSurfaceImport Class, SettingsLandXMLImport::SettingsSurfaceImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsSurfaceImport::CreateSnapshotAfterImport Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Properties > SettingsLandXMLImport::SettingsSurfaceImport::CreateSnapshotAfterImport Property
SettingsLandXMLImport::SettingsSurfaceImport::CreateSnapshotAfterImport Property
Collapse All

After importing surface data, a snapshot can automatically be created. By creating a snapshot after importing a LandXML file, AutoCAD Civil 3D does not attempt to find and open the LandXML file each time the surface is built.

C#
public bool CreateSnapshotAfterImport;
Visual Basic
Public Property CreateSnapshotAfterImport() As bool
Links
SettingsLandXMLImport::SettingsSurfaceImport Class, SettingsLandXMLImport::SettingsSurfaceImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsSurfaceImport::CreateSourceDataInDrawing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Properties > SettingsLandXMLImport::SettingsSurfaceImport::CreateSourceDataInDrawing Property
SettingsLandXMLImport::SettingsSurfaceImport::CreateSourceDataInDrawing Property
Collapse All

Imports the surface source data (breaklines, contours, points, and chains) into the drawing as 3D polylines and points.

C#
public bool CreateSourceDataInDrawing;
Visual Basic
Public Property CreateSourceDataInDrawing() As bool
Remarks

Breaklines, contours, and chains are created as 3D polylines. DataPoints are created as COGO points in a point group named <surface name>_DataPoints. This data is created on the following layers prefixed with the surface name: [surface name]_Breaklines [surface name]_Contours [surface name]_Chains [surface name]_DataPoints_PntList3D NoteThis data is not added to the surface definition in the Prospector tree. You can manually add it if desired, or create a different surface from it for comparison purposes.

Links
SettingsLandXMLImport::SettingsSurfaceImport Class, SettingsLandXMLImport::SettingsSurfaceImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsSurfaceImport::SurfaceData Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Properties > SettingsLandXMLImport::SettingsSurfaceImport::SurfaceData Property
SettingsLandXMLImport::SettingsSurfaceImport::SurfaceData Property
Collapse All

Specifies how to import the data.

C#
public LandXMLSurfaceDataImportType SurfaceData;
Visual Basic
Public Property SurfaceData() As LandXMLSurfaceDataImportType
Links
SettingsLandXMLImport::SettingsSurfaceImport Class, SettingsLandXMLImport::SettingsSurfaceImport Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsTranslation Class

Translation settings for LandXML importing.

Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsTranslation
C#
public class SettingsLandXMLImport::SettingsTranslation : TreeOidWrapper;
Visual Basic
Public Class SettingsLandXMLImport::SettingsTranslation
Inherits TreeOidWrapper
Links
SettingsLandXMLImport::SettingsTranslation Properties, SettingsLandXMLImport::SettingsTranslation Members, Class Hierarchy


SettingsLandXMLImport::SettingsTranslation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Members
SettingsLandXMLImport::SettingsTranslation Members
Collapse All

The following tables list the members exposed by SettingsLandXMLImport::SettingsTranslation.

Public Properties
Public Property | Description
BasePointEasting | Specifies the base point easting coordinate from which all import values are translated.
BasePointElevation | Specifies the base point elevation from which all import values are translated.
BasePointNorthing | Specifies the base point northing coordinate from which all import values are translated.
Translate | Specifies whether to translate data to new coordinates when importing the data from the LandXML file.
TranslatedCoordinateEasting | Specifies the easting coordinate value used to translate data from the base point.
TranslatedCoordinateElevation | Specifies the elevation value used to translate data from the base point.
TranslatedCoordinateNorthing | Specifies the northing coordinate value used to translate data from the base point.
Links
Public Properties


SettingsLandXMLImport::SettingsTranslation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties
SettingsLandXMLImport::SettingsTranslation Properties
Collapse All

The properties of SettingsLandXMLImport::SettingsTranslation are listed here.

Public Properties
Public Property | Description
BasePointEasting | Specifies the base point easting coordinate from which all import values are translated.
BasePointElevation | Specifies the base point elevation from which all import values are translated.
BasePointNorthing | Specifies the base point northing coordinate from which all import values are translated.
Translate | Specifies whether to translate data to new coordinates when importing the data from the LandXML file.
TranslatedCoordinateEasting | Specifies the easting coordinate value used to translate data from the base point.
TranslatedCoordinateElevation | Specifies the elevation value used to translate data from the base point.
TranslatedCoordinateNorthing | Specifies the northing coordinate value used to translate data from the base point.
Links
Public Properties


SettingsLandXMLImport::SettingsTranslation::BasePointEasting Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties > SettingsLandXMLImport::SettingsTranslation::BasePointEasting Property
SettingsLandXMLImport::SettingsTranslation::BasePointEasting Property
Collapse All

Specifies the base point easting coordinate from which all import values are translated.

C#
public double BasePointEasting;
Visual Basic
Public Property BasePointEasting() As double
Links
SettingsLandXMLImport::SettingsTranslation Class, SettingsLandXMLImport::SettingsTranslation Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsTranslation::BasePointElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties > SettingsLandXMLImport::SettingsTranslation::BasePointElevation Property
SettingsLandXMLImport::SettingsTranslation::BasePointElevation Property
Collapse All

Specifies the base point elevation from which all import values are translated.

C#
public double BasePointElevation;
Visual Basic
Public Property BasePointElevation() As double
Links
SettingsLandXMLImport::SettingsTranslation Class, SettingsLandXMLImport::SettingsTranslation Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsTranslation::BasePointNorthing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties > SettingsLandXMLImport::SettingsTranslation::BasePointNorthing Property
SettingsLandXMLImport::SettingsTranslation::BasePointNorthing Property
Collapse All

Specifies the base point northing coordinate from which all import values are translated.

C#
public double BasePointNorthing;
Visual Basic
Public Property BasePointNorthing() As double
Links
SettingsLandXMLImport::SettingsTranslation Class, SettingsLandXMLImport::SettingsTranslation Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsTranslation::Translate Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties > SettingsLandXMLImport::SettingsTranslation::Translate Property
SettingsLandXMLImport::SettingsTranslation::Translate Property
Collapse All

Specifies whether to translate data to new coordinates when importing the data from the LandXML file.

C#
public bool Translate;
Visual Basic
Public Property Translate() As bool
Links
SettingsLandXMLImport::SettingsTranslation Class, SettingsLandXMLImport::SettingsTranslation Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateEasting Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties > SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateEasting Property
SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateEasting Property
Collapse All

Specifies the easting coordinate value used to translate data from the base point.

C#
public double TranslatedCoordinateEasting;
Visual Basic
Public Property TranslatedCoordinateEasting() As double
Links
SettingsLandXMLImport::SettingsTranslation Class, SettingsLandXMLImport::SettingsTranslation Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties > SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateElevation Property
SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateElevation Property
Collapse All

Specifies the elevation value used to translate data from the base point.

C#
public double TranslatedCoordinateElevation;
Visual Basic
Public Property TranslatedCoordinateElevation() As double
Links
SettingsLandXMLImport::SettingsTranslation Class, SettingsLandXMLImport::SettingsTranslation Members, Autodesk::Civil::Settings Namespace


SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateNorthing Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties > SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateNorthing Property
SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateNorthing Property
Collapse All

Specifies the northing coordinate value used to translate data from the base point.

C#
public double TranslatedCoordinateNorthing;
Visual Basic
Public Property TranslatedCoordinateNorthing() As double
Links
SettingsLandXMLImport::SettingsTranslation Class, SettingsLandXMLImport::SettingsTranslation Members, Autodesk::Civil::Settings Namespace


SettingsObjectLayer Class

SettingsObjectLayer class specifies layers for individual object in AutoCAD Civil 3D.

Class Hierarchy
Autodesk::Civil::Settings::SettingsObjectLayer
C#
public class SettingsObjectLayer : TreeOidWrapper;
Visual Basic
Public Class SettingsObjectLayer
Inherits TreeOidWrapper
Links
SettingsObjectLayer Properties, SettingsObjectLayer Members, Class Hierarchy


SettingsObjectLayer Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Members
SettingsObjectLayer Members
Collapse All

The following tables list the members exposed by SettingsObjectLayer.

Public Properties
Public Property | Description
LayerId | Specifies the layer on which the object is drawn
LayerName | Specifies the layer on which the object is drawn.
Locked | Specifies whether layer settings are locked for the drawing to prevent overrides for individual objects.
Modifier | Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.
ModifierValue | Specifies the text string to use as the modifier. You can enter an asterisk (*) to include the object name... more
ObjectType | Get the object type.
Links
Public Properties


SettingsObjectLayer Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Properties
SettingsObjectLayer Properties
Collapse All

The properties of SettingsObjectLayer are listed here.

Public Properties
Public Property | Description
LayerId | Specifies the layer on which the object is drawn
LayerName | Specifies the layer on which the object is drawn.
Locked | Specifies whether layer settings are locked for the drawing to prevent overrides for individual objects.
Modifier | Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.
ModifierValue | Specifies the text string to use as the modifier. You can enter an asterisk (*) to include the object name... more
ObjectType | Get the object type.
Links
Public Properties


SettingsObjectLayer::LayerId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Properties > SettingsObjectLayer::LayerId Property
SettingsObjectLayer::LayerId Property
Collapse All

Specifies the layer on which the object is drawn

C#
public Autodesk::AutoCAD::DatabaseServices::ObjectId LayerId;
Visual Basic
Public Property LayerId() As Autodesk::AutoCAD::DatabaseServices::ObjectId
Remarks

OBJECTID TYPE: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified layer object id does not exist.
Links
SettingsObjectLayer Class, SettingsObjectLayer Members, Autodesk::Civil::Settings Namespace


SettingsObjectLayer::LayerName Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Properties > SettingsObjectLayer::LayerName Property
SettingsObjectLayer::LayerName Property
Collapse All

Specifies the layer on which the object is drawn.

C#
public System::String LayerName;
Visual Basic
Public Property LayerName() As System::String
Remarks

OBJECTID TYPE: Autodesk.AutoCAD.DatabaseServices.LayerTableRecord

Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the specified layer name does not exist.
Links
SettingsObjectLayer Class, SettingsObjectLayer Members, Autodesk::Civil::Settings Namespace


SettingsObjectLayer::Locked Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Properties > SettingsObjectLayer::Locked Property
SettingsObjectLayer::Locked Property
Collapse All

Specifies whether layer settings are locked for the drawing to prevent overrides for individual objects.

C#
public bool Locked;
Visual Basic
Public Property Locked() As bool
Links
SettingsObjectLayer Class, SettingsObjectLayer Members, Autodesk::Civil::Settings Namespace


SettingsObjectLayer::Modifier Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Properties > SettingsObjectLayer::Modifier Property
SettingsObjectLayer::Modifier Property
Collapse All

Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.

C#
public ObjectLayerModifierType Modifier;
Visual Basic
Public Property Modifier() As ObjectLayerModifierType
Links
SettingsObjectLayer Class, SettingsObjectLayer Members, Autodesk::Civil::Settings Namespace


SettingsObjectLayer::ModifierValue Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Properties > SettingsObjectLayer::ModifierValue Property
SettingsObjectLayer::ModifierValue Property
Collapse All

Specifies the text string to use as the modifier. You can enter an asterisk (*) to include the object name as the modifier in the layer name and to put each named object on its own layer. For example, if C-ROAD is the name specified for alignment layers and you add -* as a suffix, an alignment named overpass is created on layer C-ROAD-OVERPASS.

C#
public System::String ModifierValue;
Visual Basic
Public Property ModifierValue() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when input value contains invalid character, including < > / " : ? | , = `
Links
SettingsObjectLayer Class, SettingsObjectLayer Members, Autodesk::Civil::Settings Namespace


SettingsObjectLayer::ObjectType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Properties > SettingsObjectLayer::ObjectType Property
SettingsObjectLayer::ObjectType Property
Collapse All

Get the object type.

C#
public SettingsObjectLayerType ObjectType;
Visual Basic
Public Property ObjectType() As SettingsObjectLayerType
Links
SettingsObjectLayer Class, SettingsObjectLayer Members, Autodesk::Civil::Settings Namespace


SettingsObjectLayers Class

The SettingsObjectLayers class is to specify layers for various objects in AutoCAD Civil 3D. For example, you can specify that you want all alignments on layer C-ROAD, all parcels on C-PROP, and so on. You can also specify prefixes and suffixes for the layer names.

Class Hierarchy
Autodesk::Civil::Settings::SettingsObjectLayers
C#
public class SettingsObjectLayers : TreeOidWrapper;
Visual Basic
Public Class SettingsObjectLayers
Inherits TreeOidWrapper
Links
SettingsObjectLayers Methods, SettingsObjectLayers Properties, SettingsObjectLayers Members, Class Hierarchy


SettingsObjectLayers Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Members
SettingsObjectLayers Members
Collapse All

The following tables list the members exposed by SettingsObjectLayers.

Public Methods
Public Method | Description
GetObjectLayerSetting | Gets a SettingsObjectLayer object by specifying its type.
Public Properties
Public Property | Description
ObjectControlledByLayer | Specifies whether object display is controlled by layer visibility.
Links
Public Methods, Public Properties


SettingsObjectLayers Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Methods
SettingsObjectLayers Methods
Collapse All

The methods of SettingsObjectLayers are listed here.

Public Methods
Public Method | Description
GetObjectLayerSetting | Gets a SettingsObjectLayer object by specifying its type.
Links
Public Methods


SettingsObjectLayers::GetObjectLayerSetting Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Methods > SettingsObjectLayers::GetObjectLayerSetting Method
SettingsObjectLayers::GetObjectLayerSetting Method
Collapse All

Gets a SettingsObjectLayer object by specifying its type.

C#
public SettingsObjectLayer GetObjectLayerSetting(
    SettingsObjectLayerType settingsType
);
Visual Basic
Public Function GetObjectLayerSetting(
    settingsType As SettingsObjectLayerType
) As SettingsObjectLayer
Links
SettingsObjectLayers Class, SettingsObjectLayers Members, Autodesk::Civil::Settings Namespace


SettingsObjectLayers Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Properties
SettingsObjectLayers Properties
Collapse All

The properties of SettingsObjectLayers are listed here.

Public Properties
Public Property | Description
ObjectControlledByLayer | Specifies whether object display is controlled by layer visibility.
Links
Public Properties


SettingsObjectLayers::ObjectControlledByLayer Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Properties > SettingsObjectLayers::ObjectControlledByLayer Property
SettingsObjectLayers::ObjectControlledByLayer Property
Collapse All

Specifies whether object display is controlled by layer visibility.

C#
public bool ObjectControlledByLayer;
Visual Basic
Public Property ObjectControlledByLayer() As bool
Links
SettingsObjectLayers Class, SettingsObjectLayers Members, Autodesk::Civil::Settings Namespace


SettingsRoot Class

The root of the settings hierarchy.

Class Hierarchy
Autodesk::Civil::Settings::SettingsRoot
C#
public class SettingsRoot : TreeOidWrapper;
Visual Basic
Public Class SettingsRoot
Inherits TreeOidWrapper
Links
SettingsRoot Methods, SettingsRoot Properties, SettingsRoot Members, Class Hierarchy


SettingsRoot Members

The following tables list the members exposed by SettingsRoot.

Public Methods
Public Method | Description
GetSettings | Gets feature settings or command settings by specifying a type.
Public Properties
Public Property | Description
AssociateShortcutProjectId | Gets or sets the id of associate shortcut project to this drawing.
DrawingSettings | Gets the Drawing settings.
LandXMLSettings | Gets the LandXML importing/exporting settings.
TagSettings | Gets the tag settings.
Links
Public Methods, Public Properties


SettingsRoot Methods

The methods of SettingsRoot are listed here.

Public Methods
Public Method | Description
GetSettings | Gets feature settings or command settings by specifying a type.
Links
Public Methods


SettingsRoot::GetSettings Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsRoot Class > SettingsRoot Methods > SettingsRoot::GetSettings Method
SettingsRoot::GetSettings Method
Collapse All

Gets feature settings or command settings by specifying a type.

C#
public T GetSettings() where T : SettingsAmbient;
Visual Basic
Public Function GetSettings() As T
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the specified type cannot be found.
Links
SettingsRoot Class, SettingsRoot Members, Autodesk::Civil::Settings Namespace


SettingsRoot Properties

The properties of SettingsRoot are listed here.

Public Properties
Public Property | Description
AssociateShortcutProjectId | Gets or sets the id of associate shortcut project to this drawing.
DrawingSettings | Gets the Drawing settings.
LandXMLSettings | Gets the LandXML importing/exporting settings.
TagSettings | Gets the tag settings.
Links
Public Properties


SettingsRoot::AssociateShortcutProjectId Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsRoot Class > SettingsRoot Properties > SettingsRoot::AssociateShortcutProjectId Property
SettingsRoot::AssociateShortcutProjectId Property
Collapse All

Gets or sets the id of associate shortcut project to this drawing.

C#
public System::String AssociateShortcutProjectId;
Visual Basic
Public Property AssociateShortcutProjectId() As System::String
Links
SettingsRoot Class, SettingsRoot Members, Autodesk::Civil::Settings Namespace


SettingsRoot::DrawingSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsRoot Class > SettingsRoot Properties > SettingsRoot::DrawingSettings Property
SettingsRoot::DrawingSettings Property
Collapse All

Gets the Drawing settings.

C#
public SettingsDrawing DrawingSettings;
Visual Basic
Public Property DrawingSettings() As SettingsDrawing
Links
SettingsRoot Class, SettingsRoot Members, Autodesk::Civil::Settings Namespace


SettingsRoot::LandXMLSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsRoot Class > SettingsRoot Properties > SettingsRoot::LandXMLSettings Property
SettingsRoot::LandXMLSettings Property
Collapse All

Gets the LandXML importing/exporting settings.

C#
public SettingsLandXML LandXMLSettings;
Visual Basic
Public Property LandXMLSettings() As SettingsLandXML
Links
SettingsRoot Class, SettingsRoot Members, Autodesk::Civil::Settings Namespace


SettingsRoot::TagSettings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsRoot Class > SettingsRoot Properties > SettingsRoot::TagSettings Property
SettingsRoot::TagSettings Property
Collapse All

Gets the tag settings.

C#
public SettingsTag TagSettings;
Visual Basic
Public Property TagSettings() As SettingsTag
Links
SettingsRoot Class, SettingsRoot Members, Autodesk::Civil::Settings Namespace


SettingsTag Class

The Settings specify how line, curve and spiral components are numbered and renumbered.

Class Hierarchy
Autodesk::Civil::Settings::SettingsTag
C#
public class SettingsTag : TreeOidWrapper;
Visual Basic
Public Class SettingsTag
Inherits TreeOidWrapper
Links
SettingsTag Properties, SettingsTag Members, Class Hierarchy


SettingsTag Members

The following tables list the members exposed by SettingsTag.

Public Properties
Public Property | Description
Creation | Gets the creation options of TableTag settings.
Renumbering | Gets the renumbering options of TableTag settings.
Links
Public Properties


SettingsTag Properties

The properties of SettingsTag are listed here.

Public Properties
Public Property | Description
Creation | Gets the creation options of TableTag settings.
Renumbering | Gets the renumbering options of TableTag settings.
Links
Public Properties


SettingsTag::Creation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag Class > SettingsTag Properties > SettingsTag::Creation Property
SettingsTag::Creation Property
Collapse All

Gets the creation options of TableTag settings.

C#
public SettingsCreation Creation;
Visual Basic
Public Property Creation() As SettingsCreation
Links
SettingsTag Class, SettingsTag Members, Autodesk::Civil::Settings Namespace


SettingsTag::Renumbering Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag Class > SettingsTag Properties > SettingsTag::Renumbering Property
SettingsTag::Renumbering Property
Collapse All

Gets the renumbering options of TableTag settings.

C#
public SettingsRenumbering Renumbering;
Visual Basic
Public Property Renumbering() As SettingsRenumbering
Links
SettingsTag Class, SettingsTag Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsCreation Class

Settings of creation for the SettingsTag.

Class Hierarchy
Autodesk::Civil::Settings::SettingsTag::SettingsCreation
C#
public class SettingsTag::SettingsCreation : TreeOidWrapper;
Visual Basic
Public Class SettingsTag::SettingsCreation
Inherits TreeOidWrapper
Links
SettingsTag::SettingsCreation Properties, SettingsTag::SettingsCreation Members, Class Hierarchy


SettingsTag::SettingsCreation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Members
SettingsTag::SettingsCreation Members
Collapse All

The following tables list the members exposed by SettingsTag::SettingsCreation.

Public Properties
Public Property | Description
CurvesIncrement | Specifies the difference between numbers in the numbering sequence.
CurvesStartingNumber | Specifies the starting number for new curve tags to be created in the site. The numbering is incremented with creation... more
LinesIncrement | Specifies the difference between numbers in the numbering sequence.
LinesStartingNumber | Specifies the starting number for new lines to be created in the site. The numbering is incremented with creation of... more
SpiralsIncrement | Specifies the difference between numbers in the numbering sequence.
SpiralsStartingNumber | Specifies the starting number for new spiral tags to be created in the site. The numbering is incremented with creation... more
Links
Public Properties


SettingsTag::SettingsCreation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Properties
SettingsTag::SettingsCreation Properties
Collapse All

The properties of SettingsTag::SettingsCreation are listed here.

Public Properties
Public Property | Description
CurvesIncrement | Specifies the difference between numbers in the numbering sequence.
CurvesStartingNumber | Specifies the starting number for new curve tags to be created in the site. The numbering is incremented with creation... more
LinesIncrement | Specifies the difference between numbers in the numbering sequence.
LinesStartingNumber | Specifies the starting number for new lines to be created in the site. The numbering is incremented with creation of... more
SpiralsIncrement | Specifies the difference between numbers in the numbering sequence.
SpiralsStartingNumber | Specifies the starting number for new spiral tags to be created in the site. The numbering is incremented with creation... more
Links
Public Properties


SettingsTag::SettingsCreation::CurvesIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Properties > SettingsTag::SettingsCreation::CurvesIncrement Property
SettingsTag::SettingsCreation::CurvesIncrement Property
Collapse All

Specifies the difference between numbers in the numbering sequence.

C#
public int CurvesIncrement;
Visual Basic
Public Property CurvesIncrement() As Integer
Links
SettingsTag::SettingsCreation Class, SettingsTag::SettingsCreation Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsCreation::CurvesStartingNumber Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Properties > SettingsTag::SettingsCreation::CurvesStartingNumber Property
SettingsTag::SettingsCreation::CurvesStartingNumber Property
Collapse All

Specifies the starting number for new curve tags to be created in the site. The numbering is incremented with creation of new tags.

C#
public int CurvesStartingNumber;
Visual Basic
Public Property CurvesStartingNumber() As Integer
Links
SettingsTag::SettingsCreation Class, SettingsTag::SettingsCreation Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsCreation::LinesIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Properties > SettingsTag::SettingsCreation::LinesIncrement Property
SettingsTag::SettingsCreation::LinesIncrement Property
Collapse All

Specifies the difference between numbers in the numbering sequence.

C#
public int LinesIncrement;
Visual Basic
Public Property LinesIncrement() As Integer
Links
SettingsTag::SettingsCreation Class, SettingsTag::SettingsCreation Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsCreation::LinesStartingNumber Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Properties > SettingsTag::SettingsCreation::LinesStartingNumber Property
SettingsTag::SettingsCreation::LinesStartingNumber Property
Collapse All

Specifies the starting number for new lines to be created in the site. The numbering is incremented with creation of new lines.

C#
public int LinesStartingNumber;
Visual Basic
Public Property LinesStartingNumber() As Integer
Links
SettingsTag::SettingsCreation Class, SettingsTag::SettingsCreation Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsCreation::SpiralsIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Properties > SettingsTag::SettingsCreation::SpiralsIncrement Property
SettingsTag::SettingsCreation::SpiralsIncrement Property
Collapse All

Specifies the difference between numbers in the numbering sequence.

C#
public int SpiralsIncrement;
Visual Basic
Public Property SpiralsIncrement() As Integer
Links
SettingsTag::SettingsCreation Class, SettingsTag::SettingsCreation Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsCreation::SpiralsStartingNumber Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Properties > SettingsTag::SettingsCreation::SpiralsStartingNumber Property
SettingsTag::SettingsCreation::SpiralsStartingNumber Property
Collapse All

Specifies the starting number for new spiral tags to be created in the site. The numbering is incremented with creation of new tags.

C#
public int SpiralsStartingNumber;
Visual Basic
Public Property SpiralsStartingNumber() As Integer
Links
SettingsTag::SettingsCreation Class, SettingsTag::SettingsCreation Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsRenumbering Class

Settings of renumbering for the SettingsTag.

Class Hierarchy
Autodesk::Civil::Settings::SettingsTag::SettingsRenumbering
C#
public class SettingsTag::SettingsRenumbering : TreeOidWrapper;
Visual Basic
Public Class SettingsTag::SettingsRenumbering
Inherits TreeOidWrapper
Links
SettingsTag::SettingsRenumbering Properties, SettingsTag::SettingsRenumbering Members, Class Hierarchy


SettingsTag::SettingsRenumbering Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Members
SettingsTag::SettingsRenumbering Members
Collapse All

The following tables list the members exposed by SettingsTag::SettingsRenumbering.

Public Properties
Public Property | Description
CurvesIncrement | Specifies the difference between numbers in the numbering sequence.
CurvesStartingNumber | Specifies the starting number for new curve tags to be renumbered.
LinesIncrement | Specifies the difference between numbers in the numbering sequence.
LinesStartingNumber | SettingsRenumbering.
SpiralsIncrement | Specifies the difference between numbers in the numbering sequence.
SpiralsStartingNumber | Specifies the starting number for new spiral tags to be created on alignments in the site. The numbering is incremented... more
Links
Public Properties


SettingsTag::SettingsRenumbering Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Properties
SettingsTag::SettingsRenumbering Properties
Collapse All

The properties of SettingsTag::SettingsRenumbering are listed here.

Public Properties
Public Property | Description
CurvesIncrement | Specifies the difference between numbers in the numbering sequence.
CurvesStartingNumber | Specifies the starting number for new curve tags to be renumbered.
LinesIncrement | Specifies the difference between numbers in the numbering sequence.
LinesStartingNumber | SettingsRenumbering.
SpiralsIncrement | Specifies the difference between numbers in the numbering sequence.
SpiralsStartingNumber | Specifies the starting number for new spiral tags to be created on alignments in the site. The numbering is incremented... more
Links
Public Properties


SettingsTag::SettingsRenumbering::CurvesIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Properties > SettingsTag::SettingsRenumbering::CurvesIncrement Property
SettingsTag::SettingsRenumbering::CurvesIncrement Property
Collapse All

Specifies the difference between numbers in the numbering sequence.

C#
public int CurvesIncrement;
Visual Basic
Public Property CurvesIncrement() As Integer
Links
SettingsTag::SettingsRenumbering Class, SettingsTag::SettingsRenumbering Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsRenumbering::CurvesStartingNumber Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Properties > SettingsTag::SettingsRenumbering::CurvesStartingNumber Property
SettingsTag::SettingsRenumbering::CurvesStartingNumber Property
Collapse All

Specifies the starting number for new curve tags to be renumbered.

C#
public int CurvesStartingNumber;
Visual Basic
Public Property CurvesStartingNumber() As Integer
Links
SettingsTag::SettingsRenumbering Class, SettingsTag::SettingsRenumbering Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsRenumbering::LinesIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Properties > SettingsTag::SettingsRenumbering::LinesIncrement Property
SettingsTag::SettingsRenumbering::LinesIncrement Property
Collapse All

Specifies the difference between numbers in the numbering sequence.

C#
public int LinesIncrement;
Visual Basic
Public Property LinesIncrement() As Integer
Links
SettingsTag::SettingsRenumbering Class, SettingsTag::SettingsRenumbering Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsRenumbering::LinesStartingNumber Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Properties > SettingsTag::SettingsRenumbering::LinesStartingNumber Property
SettingsTag::SettingsRenumbering::LinesStartingNumber Property
Collapse All

SettingsRenumbering.

C#
public int LinesStartingNumber;
Visual Basic
Public Property LinesStartingNumber() As Integer
Links
SettingsTag::SettingsRenumbering Class, SettingsTag::SettingsRenumbering Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsRenumbering::SpiralsIncrement Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Properties > SettingsTag::SettingsRenumbering::SpiralsIncrement Property
SettingsTag::SettingsRenumbering::SpiralsIncrement Property
Collapse All

Specifies the difference between numbers in the numbering sequence.

C#
public int SpiralsIncrement;
Visual Basic
Public Property SpiralsIncrement() As Integer
Links
SettingsTag::SettingsRenumbering Class, SettingsTag::SettingsRenumbering Members, Autodesk::Civil::Settings Namespace


SettingsTag::SettingsRenumbering::SpiralsStartingNumber Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Properties > SettingsTag::SettingsRenumbering::SpiralsStartingNumber Property
SettingsTag::SettingsRenumbering::SpiralsStartingNumber Property
Collapse All

Specifies the starting number for new spiral tags to be created on alignments in the site. The numbering is incremented with creation of new tags.

C#
public int SpiralsStartingNumber;
Visual Basic
Public Property SpiralsStartingNumber() As Integer
Links
SettingsTag::SettingsRenumbering Class, SettingsTag::SettingsRenumbering Members, Autodesk::Civil::Settings Namespace


SettingsTransformation Class

The SettingsTransformation class use to transform the coordinate system to local specifications.

Class Hierarchy
Autodesk::Civil::Settings::SettingsTransformation
C#
public class SettingsTransformation : TreeOidWrapper;
Visual Basic
Public Class SettingsTransformation
Inherits TreeOidWrapper
Links
SettingsTransformation Properties, SettingsTransformation Members, Class Hierarchy


SettingsTransformation Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Members
SettingsTransformation Members
Collapse All

The following tables list the members exposed by SettingsTransformation.

Public Properties
Public Property | Description
ApplySeaLevelScaleFactor | Gets or sets the boolean value that specifies whether to apply the settings for curvature correction to survey data so... more
GridReferencePoint | Gets or sets the grid reference point value used to associate local coordinates to grid coordinates.
GridRotationPoint | Gets or sets the grid rotation point that specifies a rotation about the grid reference point.
GridScaleFactor | Gets or sets a positive value for the grid scale factor.
GridScaleFactorComputation | Gets or sets the GridScaleFactorType enum value that specifies the type of scale factor.
LocalReferencePoint | Gets or sets the local reference point value used to associate local coordinates to grid coordinates.
LocalRotationPoint | Gets or sets the local rotation point that specifies a rotation about the local reference point.
RotationToGridAzimuth | Gets or sets the direction of the azimuth for the grid rotation angle in degree units.
RotationToGridNorth | Gets or sets the angle to grid north for the grid rotation angle in degree units.
SeaLevelScaleElevation | Gets or sets the mean elevation value of your project site with respect to the mean sea level.
SpecifyRotationType | Gets or sets an enumeration value that specify the rotation type.
SpheroidRadius | Gets the spheroid radius for the spheroid used by the coordinate system.
Links
Public Properties


SettingsTransformation Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties
SettingsTransformation Properties
Collapse All

The properties of SettingsTransformation are listed here.

Public Properties
Public Property | Description
ApplySeaLevelScaleFactor | Gets or sets the boolean value that specifies whether to apply the settings for curvature correction to survey data so... more
GridReferencePoint | Gets or sets the grid reference point value used to associate local coordinates to grid coordinates.
GridRotationPoint | Gets or sets the grid rotation point that specifies a rotation about the grid reference point.
GridScaleFactor | Gets or sets a positive value for the grid scale factor.
GridScaleFactorComputation | Gets or sets the GridScaleFactorType enum value that specifies the type of scale factor.
LocalReferencePoint | Gets or sets the local reference point value used to associate local coordinates to grid coordinates.
LocalRotationPoint | Gets or sets the local rotation point that specifies a rotation about the local reference point.
RotationToGridAzimuth | Gets or sets the direction of the azimuth for the grid rotation angle in degree units.
RotationToGridNorth | Gets or sets the angle to grid north for the grid rotation angle in degree units.
SeaLevelScaleElevation | Gets or sets the mean elevation value of your project site with respect to the mean sea level.
SpecifyRotationType | Gets or sets an enumeration value that specify the rotation type.
SpheroidRadius | Gets the spheroid radius for the spheroid used by the coordinate system.
Links
Public Properties


SettingsTransformation::ApplySeaLevelScaleFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::ApplySeaLevelScaleFactor Property
SettingsTransformation::ApplySeaLevelScaleFactor Property
Collapse All

Gets or sets the boolean value that specifies whether to apply the settings for curvature correction to survey data so that measured horizontal distances are reduced to the distances at the mean seal level (geodetic distances).

C#
public bool ApplySeaLevelScaleFactor;
Visual Basic
Public Property ApplySeaLevelScaleFactor() As bool
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::GridReferencePoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::GridReferencePoint Property
SettingsTransformation::GridReferencePoint Property
Collapse All

Gets or sets the grid reference point value used to associate local coordinates to grid coordinates.

C#
public Autodesk::AutoCAD::Geometry::Point2d GridReferencePoint;
Visual Basic
Public Property GridReferencePoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::GridRotationPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::GridRotationPoint Property
SettingsTransformation::GridRotationPoint Property
Collapse All

Gets or sets the grid rotation point that specifies a rotation about the grid reference point.

C#
public Autodesk::AutoCAD::Geometry::Point2d GridRotationPoint;
Visual Basic
Public Property GridRotationPoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::GridScaleFactor Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::GridScaleFactor Property
SettingsTransformation::GridScaleFactor Property
Collapse All

Gets or sets a positive value for the grid scale factor.

C#
public double GridScaleFactor;
Visual Basic
Public Property GridScaleFactor() As double
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the when the value of property GridScaleFactorComputation is not GridScaleFactorType::UserDefined.
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::GridScaleFactorComputation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::GridScaleFactorComputation Property
SettingsTransformation::GridScaleFactorComputation Property
Collapse All

Gets or sets the GridScaleFactorType enum value that specifies the type of scale factor.

C#
public GridScaleFactorType GridScaleFactorComputation;
Visual Basic
Public Property GridScaleFactorComputation() As GridScaleFactorType
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::LocalReferencePoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::LocalReferencePoint Property
SettingsTransformation::LocalReferencePoint Property
Collapse All

Gets or sets the local reference point value used to associate local coordinates to grid coordinates.

C#
public Autodesk::AutoCAD::Geometry::Point2d LocalReferencePoint;
Visual Basic
Public Property LocalReferencePoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::LocalRotationPoint Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::LocalRotationPoint Property
SettingsTransformation::LocalRotationPoint Property
Collapse All

Gets or sets the local rotation point that specifies a rotation about the local reference point.

C#
public Autodesk::AutoCAD::Geometry::Point2d LocalRotationPoint;
Visual Basic
Public Property LocalRotationPoint() As Autodesk::AutoCAD::Geometry::Point2d
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::RotationToGridAzimuth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::RotationToGridAzimuth Property
SettingsTransformation::RotationToGridAzimuth Property
Collapse All

Gets or sets the direction of the azimuth for the grid rotation angle in degree units.

C#
public double RotationToGridAzimuth;
Visual Basic
Public Property RotationToGridAzimuth() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out range [0.0, 360.0];
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::RotationToGridNorth Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::RotationToGridNorth Property
SettingsTransformation::RotationToGridNorth Property
Collapse All

Gets or sets the angle to grid north for the grid rotation angle in degree units.

C#
public double RotationToGridNorth;
Visual Basic
Public Property RotationToGridNorth() As double
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the input value is out range [0.0, 360.0];
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::SeaLevelScaleElevation Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::SeaLevelScaleElevation Property
SettingsTransformation::SeaLevelScaleElevation Property
Collapse All

Gets or sets the mean elevation value of your project site with respect to the mean sea level.

C#
public double SeaLevelScaleElevation;
Visual Basic
Public Property SeaLevelScaleElevation() As double
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::SpecifyRotationType Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::SpecifyRotationType Property
SettingsTransformation::SpecifyRotationType Property
Collapse All

Gets or sets an enumeration value that specify the rotation type.

C#
public Autodesk::Civil::Settings::SpecifyRotationType SpecifyRotationType;
Visual Basic
Public Property SpecifyRotationType() As Autodesk::Civil::Settings::SpecifyRotationType
Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsTransformation::SpheroidRadius Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties > SettingsTransformation::SpheroidRadius Property
SettingsTransformation::SpheroidRadius Property
Collapse All

Gets the spheroid radius for the spheroid used by the coordinate system.

C#
public double SpheroidRadius;
Visual Basic
Public Property SpheroidRadius() As double
Remarks

This value is the radius of a spheroid close to the shape of the Earth at sea level, approximately 6,370 km. The value shown in this box is derived from the ellipsoid for the current zone.

Links
SettingsTransformation Class, SettingsTransformation Members, Autodesk::Civil::Settings Namespace


SettingsUnitZone Class

The settings class for the unit zone.

Class Hierarchy
Autodesk::Civil::Settings::SettingsUnitZone
C#
public class SettingsUnitZone : TreeOidWrapper;
Visual Basic
Public Class SettingsUnitZone
Inherits TreeOidWrapper
Links
SettingsUnitZone Methods, SettingsUnitZone Properties, SettingsUnitZone Members, Class Hierarchy


SettingsUnitZone Members

The following tables list the members exposed by SettingsUnitZone.

Public Methods
Public Method | Description
GetAllCodes | Gets an array that specifies all avilable code strings.
GetCoordinateSystemByCode | Gets an coordinate system by an code string.
Public Properties
Public Property | Description
AngularUnits | Gets or sets the AngleUnitType enum value that specifies the units in which angles are displayed.
CoordinateSystemCode | Gets the coordinate system code string.
DrawingScale | Gets the plotted size of various annotation-related components, such as label text, ticks, and band heights. If you change the... more
DrawingUnits | Gets the linear unit, either meters or feet, for distances, lengths, widths, and offsets in a drawing.
ImperialToMetricConversion | Gets or sets the foot to meter conversion flag that determines what the unit "foot" means.
MatchAutoCADVariables | Synchronizes AutoCAD settings with Autodesk Civil 3D settings. Deprecated. Gets or sets the boolean value that specifies whether synchronizes AutoCAD... more
ScaleObjectsFromOtherDrawings | Gets or sets the boolean value that specifies whether objects inserted from another drawing will be scaled if necessary to... more
Links
Public Methods, Public Properties


SettingsUnitZone Methods

The methods of SettingsUnitZone are listed here.

Public Methods
Public Method | Description
GetAllCodes | Gets an array that specifies all avilable code strings.
GetCoordinateSystemByCode | Gets an coordinate system by an code string.
Links
Public Methods


SettingsUnitZone::GetAllCodes Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsUnitZone Class > SettingsUnitZone Methods > SettingsUnitZone::GetAllCodes Method
SettingsUnitZone::GetAllCodes Method
Collapse All

Gets an array that specifies all avilable code strings.

C#
public array<System::String^> GetAllCodes();
Visual Basic
Public Function GetAllCodes() As array<System::String^>
Links
SettingsUnitZone Class, SettingsUnitZone Members, Autodesk::Civil::Settings Namespace


SettingsUnitZone::GetCoordinateSystemByCode Method

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsUnitZone Class > SettingsUnitZone Methods > SettingsUnitZone::GetCoordinateSystemByCode Method
SettingsUnitZone::GetCoordinateSystemByCode Method
Collapse All

Gets an coordinate system by an code string.

C#
public SettingsCoordinateSystem GetCoordinateSystemByCode(
    ref System::String code
);
Visual Basic
Public Function GetCoordinateSystemByCode(
    ByRef code As System::String
) As SettingsCoordinateSystem
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the code is not a valid coordinate system code that means new code is not contained in the return array of method GetALLCode().
Links
SettingsUnitZone Class, SettingsUnitZone Members, Autodesk::Civil::Settings Namespace


SettingsUnitZone Properties

The properties of SettingsUnitZone are listed here.

Public Properties
Public Property | Description
AngularUnits | Gets or sets the AngleUnitType enum value that specifies the units in which angles are displayed.
CoordinateSystemCode | Gets the coordinate system code string.
DrawingScale | Gets the plotted size of various annotation-related components, such as label text, ticks, and band heights. If you change the... more
DrawingUnits | Gets the linear unit, either meters or feet, for distances, lengths, widths, and offsets in a drawing.
ImperialToMetricConversion | Gets or sets the foot to meter conversion flag that determines what the unit "foot" means.
MatchAutoCADVariables | Synchronizes AutoCAD settings with Autodesk Civil 3D settings. Deprecated. Gets or sets the boolean value that specifies whether synchronizes AutoCAD... more
ScaleObjectsFromOtherDrawings | Gets or sets the boolean value that specifies whether objects inserted from another drawing will be scaled if necessary to... more
Links
Public Properties


SettingsUnitZone::AngularUnits Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsUnitZone Class > SettingsUnitZone Properties > SettingsUnitZone::AngularUnits Property
SettingsUnitZone::AngularUnits Property
Collapse All

Gets or sets the AngleUnitType enum value that specifies the units in which angles are displayed.

C#
public AngleUnitType AngularUnits;
Visual Basic
Public Property AngularUnits() As AngleUnitType
Links
SettingsUnitZone Class, SettingsUnitZone Members, Autodesk::Civil::Settings Namespace


SettingsUnitZone::CoordinateSystemCode Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsUnitZone Class > SettingsUnitZone Properties > SettingsUnitZone::CoordinateSystemCode Property
SettingsUnitZone::CoordinateSystemCode Property
Collapse All

Gets the coordinate system code string.

C#
public System::String CoordinateSystemCode;
Visual Basic
Public Property CoordinateSystemCode() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the code is not a valid coordinate system code that means new code is not contained in the return array of method GetALLCode().
Links
SettingsUnitZone Class, SettingsUnitZone Members, Autodesk::Civil::Settings Namespace


SettingsUnitZone::DrawingScale Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsUnitZone Class > SettingsUnitZone Properties > SettingsUnitZone::DrawingScale Property
SettingsUnitZone::DrawingScale Property
Collapse All

Gets the plotted size of various annotation-related components, such as label text, ticks, and band heights. If you change the scale, all annotation objects adjust accordingly.

C#
public double DrawingScale;
Visual Basic
Public Property DrawingScale() As double
Links
SettingsUnitZone Class, SettingsUnitZone Members, Autodesk::Civil::Settings Namespace


SettingsUnitZone::DrawingUnits Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsUnitZone Class > SettingsUnitZone Properties > SettingsUnitZone::DrawingUnits Property
SettingsUnitZone::DrawingUnits Property
Collapse All

Gets the linear unit, either meters or feet, for distances, lengths, widths, and offsets in a drawing.

C#
public DrawingUnitType DrawingUnits;
Visual Basic
Public Property DrawingUnits() As DrawingUnitType
Links
SettingsUnitZone Class, SettingsUnitZone Members, Autodesk::Civil::Settings Namespace


SettingsUnitZone::ImperialToMetricConversion Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsUnitZone Class > SettingsUnitZone Properties > SettingsUnitZone::ImperialToMetricConversion Property
SettingsUnitZone::ImperialToMetricConversion Property
Collapse All

Gets or sets the foot to meter conversion flag that determines what the unit "foot" means.

C#
public ImperialToMetricConversionType ImperialToMetricConversion;
Visual Basic
Public Property ImperialToMetricConversion() As ImperialToMetricConversionType
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown when the DrawingUnits is DrawingUnitType::Feet and the coordinate system units is neither AeccICoordSys::UNIT_USFOOT nor AeccICoordSys::UNIT_METER.
Links
SettingsUnitZone Class, SettingsUnitZone Members, Autodesk::Civil::Settings Namespace


SettingsUnitZone::MatchAutoCADVariables Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsUnitZone Class > SettingsUnitZone Properties > SettingsUnitZone::MatchAutoCADVariables Property
SettingsUnitZone::MatchAutoCADVariables Property
Collapse All

Synchronizes AutoCAD settings with Autodesk Civil 3D settings. Deprecated.

Gets or sets the boolean value that specifies whether synchronizes AutoCAD settings with AutoCAD Civil 3D settings.

C#
public bool MatchAutoCADVariables;
Visual Basic
Public Property MatchAutoCADVariables() As bool
Links
SettingsUnitZone Class, SettingsUnitZone Members, Autodesk::Civil::Settings Namespace


SettingsUnitZone::ScaleObjectsFromOtherDrawings Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsUnitZone Class > SettingsUnitZone Properties > SettingsUnitZone::ScaleObjectsFromOtherDrawings Property
SettingsUnitZone::ScaleObjectsFromOtherDrawings Property
Collapse All

Gets or sets the boolean value that specifies whether objects inserted from another drawing will be scaled if necessary to match drawing units in the current drawing.

C#
public bool ScaleObjectsFromOtherDrawings;
Visual Basic
Public Property ScaleObjectsFromOtherDrawings() As bool
Links
SettingsUnitZone Class, SettingsUnitZone Members, Autodesk::Civil::Settings Namespace


Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
DrawingUnitType | Specifies the linear units (feet or meters) for drawing entities in AutoCAD model space.
GridScaleFactorType | Specifies the type of scale factor.
ImperialToMetricConversionType | Specifies the Imperial to Metric conversion type for the drawing.
LandXMLAngularUnits | Specifies the units of the exported angles and directions.
LandXMLAttributeExportType | Specifies the field that is used for specific attribute in the LandXML file.
LandXMLConflictResolutionType | Specifies how objects with the same name are handled.
LandXMLImperialUnitType | Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source... more
LandXMLLinearUnits | Specifies how to tag LandXML data when working in Imperial units.
LandXMLMetricUnitType | Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source... more
LandXMLPointDescriptionType | Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.
LandXMLSurfaceDataExportType | Specifies how to export the surface data.
LandXMLSurfaceDataImportType | Specifies how to import the data. NoteIf the LandXML surface you intend to import has only breaklines (for example, no... more
MapcheckAngleType | Definition of MapCheck Angle type.
MapcheckCurveDirectionType | Definition of MapCheck Curve Direction type.
MapcheckSideType | Definition of MapCheck side type.
MapcheckTraverseMethodType | Definition of MapCheck Traverse Method type.
ObjectLayerModifierType | Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.
SettingsObjectLayerType | The Autodesk::Civil::Settings::SettingsObjectLayerType enumeration.
SpecifyRotationType | An enumeration that use to specify a rotation about the reference point in one of two ways: specify a rotation... more
Links
Enumerations


Autodesk::Civil::Settings::DrawingUnitType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::DrawingUnitType Enumeration
Autodesk::Civil::Settings::DrawingUnitType Enumeration
Collapse All

Specifies the linear units (feet or meters) for drawing entities in AutoCAD model space.

C#
public enum DrawingUnitType {
  Feet = AeccUnitBase::foot,
  Meters = AeccUnitBase::meter
}
Visual Basic
Public Enum DrawingUnitType
  Feet = AeccUnitBase::foot
  Meters = AeccUnitBase::meter
End Enum


Autodesk::Civil::Settings::GridScaleFactorType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::GridScaleFactorType Enumeration
Autodesk::Civil::Settings::GridScaleFactorType Enumeration
Collapse All

Specifies the type of scale factor.

C#
public enum GridScaleFactorType {
  Unity = AeccICoordSys::kUnity,
  UserDefined = AeccICoordSys::kUserDefined,
  ReferencePoint = AeccICoordSys::kReferencePoint,
  PrismodialFormula = AeccICoordSys::kPrismodial
}
Visual Basic
Public Enum GridScaleFactorType
  Unity = AeccICoordSys::kUnity
  UserDefined = AeccICoordSys::kUserDefined
  ReferencePoint = AeccICoordSys::kReferencePoint
  PrismodialFormula = AeccICoordSys::kPrismodial
End Enum


Autodesk::Civil::Settings::ImperialToMetricConversionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::ImperialToMetricConversionType Enumeration
Autodesk::Civil::Settings::ImperialToMetricConversionType Enumeration
Collapse All

Specifies the Imperial to Metric conversion type for the drawing.

C#
public enum ImperialToMetricConversionType {
  InternationalFoot = AeccUnitBase::UseInternationalFoot,
  UsSurveyFoot = AeccUnitBase::UseUsSurveyFoot
}
Visual Basic
Public Enum ImperialToMetricConversionType
  InternationalFoot = AeccUnitBase::UseInternationalFoot
  UsSurveyFoot = AeccUnitBase::UseUsSurveyFoot
End Enum


Autodesk::Civil::Settings::LandXMLAngularUnits Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::LandXMLAngularUnits Enumeration
Autodesk::Civil::Settings::LandXMLAngularUnits Enumeration
Collapse All

Specifies the units of the exported angles and directions.

C#
public enum LandXMLAngularUnits {
  DegreesDecimal = AeccAttributeTypeInfoEnumLandXMLAngularUnits::kDegrees_decimal,
  DegreesDms = AeccAttributeTypeInfoEnumLandXMLAngularUnits::kDegrees_dms,
  Grads = AeccAttributeTypeInfoEnumLandXMLAngularUnits::kGrads,
  Radians = AeccAttributeTypeInfoEnumLandXMLAngularUnits::kRadians
}
Visual Basic
Public Enum LandXMLAngularUnits
  DegreesDecimal = AeccAttributeTypeInfoEnumLandXMLAngularUnits::kDegrees_decimal
  DegreesDms = AeccAttributeTypeInfoEnumLandXMLAngularUnits::kDegrees_dms
  Grads = AeccAttributeTypeInfoEnumLandXMLAngularUnits::kGrads
  Radians = AeccAttributeTypeInfoEnumLandXMLAngularUnits::kRadians
End Enum
Members
Members | Description
DegreesDecimal | Exports angles and directions as decimal degrees. Decimal degrees express the minutes and seconds of an angle as its decimal equivalent.
DegreesDms | Exports angles and directions using the degrees, minutes, and seconds convention, in which the numbers after the decimal are read as minutes and seconds, not decimal degrees.
Grads | Exports angles and directions using grads (where one grad equals 1/100 of a 90° angle, or 360° = 400 grads).
Radians | Exports angles and directions using radians (where 2PI radians equals 360°).


Autodesk::Civil::Settings::LandXMLAttributeExportType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::LandXMLAttributeExportType Enumeration
Autodesk::Civil::Settings::LandXMLAttributeExportType Enumeration
Collapse All

Specifies the field that is used for specific attribute in the LandXML file.

C#
public enum LandXMLAttributeExportType {
  Disabled = AeccAttributeTypeInfoEnumXMLFieldType::kDisabled,
  RawDescription = AeccAttributeTypeInfoEnumXMLFieldType::kRawDescription,
  FullDescription = AeccAttributeTypeInfoEnumXMLFieldType::kFullDescription
}
Visual Basic
Public Enum LandXMLAttributeExportType
  Disabled = AeccAttributeTypeInfoEnumXMLFieldType::kDisabled
  RawDescription = AeccAttributeTypeInfoEnumXMLFieldType::kRawDescription
  FullDescription = AeccAttributeTypeInfoEnumXMLFieldType::kFullDescription
End Enum
Members
Members | Description
Disabled | Does not export the point description.
RawDescription | Exports a point raw description.
FullDescription | Exports a point full description.


Autodesk::Civil::Settings::LandXMLConflictResolutionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::LandXMLConflictResolutionType Enumeration
Autodesk::Civil::Settings::LandXMLConflictResolutionType Enumeration
Collapse All

Specifies how objects with the same name are handled.

C#
public enum LandXMLConflictResolutionType {
  Skip = AeccAttributeTypeInfoEnumConflictResolution::kSkip,
  Update = AeccAttributeTypeInfoEnumConflictResolution::kUpdate,
  Append = AeccAttributeTypeInfoEnumConflictResolution::kAppend
}
Visual Basic
Public Enum LandXMLConflictResolutionType
  Skip = AeccAttributeTypeInfoEnumConflictResolution::kSkip
  Update = AeccAttributeTypeInfoEnumConflictResolution::kUpdate
  Append = AeccAttributeTypeInfoEnumConflictResolution::kAppend
End Enum
Members
Members | Description
Skip | Does not import conflicting objects.
Update | On import, replaces unlocked drawing object with object in LandXML file.
Append | Imports conflicting objects but renames the imported copy using the default name format that is specified in the feature settings.


Autodesk::Civil::Settings::LandXMLImperialUnitType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::LandXMLImperialUnitType Enumeration
Autodesk::Civil::Settings::LandXMLImperialUnitType Enumeration
Collapse All

Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source LandXML file.

C#
public enum LandXMLImperialUnitType {
  Foot = AeccUnitBase::foot,
  Inch = AeccUnitBase::inch,
  Yard = AeccUnitBase::yards,
  Mile = AeccUnitBase::mile
}
Visual Basic
Public Enum LandXMLImperialUnitType
  Foot = AeccUnitBase::foot
  Inch = AeccUnitBase::inch
  Yard = AeccUnitBase::yards
  Mile = AeccUnitBase::mile
End Enum


Autodesk::Civil::Settings::LandXMLLinearUnits Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::LandXMLLinearUnits Enumeration
Autodesk::Civil::Settings::LandXMLLinearUnits Enumeration
Collapse All

Specifies how to tag LandXML data when working in Imperial units.

C#
public enum LandXMLLinearUnits {
  InternationalFoot = AeccAttributeTypeInfoEnumLandXMLLinearUnits::kInternationalFoot,
  SurveyFoot = AeccAttributeTypeInfoEnumLandXMLLinearUnits::kSurveyFoot
}
Visual Basic
Public Enum LandXMLLinearUnits
  InternationalFoot = AeccAttributeTypeInfoEnumLandXMLLinearUnits::kInternationalFoot
  SurveyFoot = AeccAttributeTypeInfoEnumLandXMLLinearUnits::kSurveyFoot
End Enum
Members
Members | Description
InternationalFoot | Tags the data in the LandXML file as International feet.
SurveyFoot | Tags the data in the LandXML file as Survey feet.


Autodesk::Civil::Settings::LandXMLMetricUnitType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::LandXMLMetricUnitType Enumeration
Autodesk::Civil::Settings::LandXMLMetricUnitType Enumeration
Collapse All

Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source LandXML file.

C#
public enum LandXMLMetricUnitType {
  Meter = AeccUnitBase::meter,
  KiloMeter = AeccUnitBase::kilometer,
  DeciMeter = AeccUnitBase::decimeter,
  CentiMeter = AeccUnitBase::centimeter,
  MilliMeter = AeccUnitBase::millimeter
}
Visual Basic
Public Enum LandXMLMetricUnitType
  Meter = AeccUnitBase::meter
  KiloMeter = AeccUnitBase::kilometer
  DeciMeter = AeccUnitBase::decimeter
  CentiMeter = AeccUnitBase::centimeter
  MilliMeter = AeccUnitBase::millimeter
End Enum


Autodesk::Civil::Settings::LandXMLPointDescriptionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::LandXMLPointDescriptionType Enumeration
Autodesk::Civil::Settings::LandXMLPointDescriptionType Enumeration
Collapse All

Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.

C#
public enum LandXMLPointDescriptionType {
  UseCodeValue = AeccAttributeTypeInfoEnumPointDesc::kUseCodeValue,
  UseDescValue = AeccAttributeTypeInfoEnumPointDesc::kUseDescValue,
  UseCodeThenDesc = AeccAttributeTypeInfoEnumPointDesc::kUseCodeThenDesc,
  UseDescThenCode = AeccAttributeTypeInfoEnumPointDesc::kUseDescThenCode
}
Visual Basic
Public Enum LandXMLPointDescriptionType
  UseCodeValue = AeccAttributeTypeInfoEnumPointDesc::kUseCodeValue
  UseDescValue = AeccAttributeTypeInfoEnumPointDesc::kUseDescValue
  UseCodeThenDesc = AeccAttributeTypeInfoEnumPointDesc::kUseCodeThenDesc
  UseDescThenCode = AeccAttributeTypeInfoEnumPointDesc::kUseDescThenCode
End Enum
Members
Members | Description
UseCodeValue | Uses the “code” attribute value for the point description.
UseDescValue | Uses the “desc” attribute value for the point description.
UseCodeThenDesc | Attempts to use the “code” attribute value for the point description. If a point does not have a “code” attribute, the “desc” attribute value, if available, is used.
UseDescThenCode | Attempts to use the “desc” attribute value for the point description. If a point does not have a “desc” attribute, the “code” attribute value, if available, is used.


Autodesk::Civil::Settings::LandXMLSurfaceDataExportType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::LandXMLSurfaceDataExportType Enumeration
Autodesk::Civil::Settings::LandXMLSurfaceDataExportType Enumeration
Collapse All

Specifies how to export the surface data.

C#
public enum LandXMLSurfaceDataExportType {
  PointsOnly = AeccAttributeTypeInfoEnumSurfaceDataExport::kPointsOnly,
  PointsAndFaces = AeccAttributeTypeInfoEnumSurfaceDataExport::kPointsAndFaces
}
Visual Basic
Public Enum LandXMLSurfaceDataExportType
  PointsOnly = AeccAttributeTypeInfoEnumSurfaceDataExport::kPointsOnly
  PointsAndFaces = AeccAttributeTypeInfoEnumSurfaceDataExport::kPointsAndFaces
End Enum
Members
Members | Description
PointsOnly | Exports surface information as points. Creates a surface that has northing, easting, and elevation points that are identical to the surface definition. However, the triangulation may be different from the original surface.
PointsAndFaces | Exports both the points and the surface faces, if available. Creates the surface information from the face edges and creates a surface that is identical to the surface definition.


Autodesk::Civil::Settings::LandXMLSurfaceDataImportType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::LandXMLSurfaceDataImportType Enumeration
Autodesk::Civil::Settings::LandXMLSurfaceDataImportType Enumeration
Collapse All

Specifies how to import the data. NoteIf the LandXML surface you intend to import has only breaklines (for example, no other points and faces definition data is present), the resulting AutoCAD Civil 3D surface is built from the breakline data. However, the breaklines are not available for editing (that is, they do not appear in the Prospector tree).

C#
public enum LandXMLSurfaceDataImportType {
  QuickImport = AeccAttributeTypeInfoEnumSurfaceDataImport::kQuickImport,
  FullImport = AeccAttributeTypeInfoEnumSurfaceDataImport::kFullImport
}
Visual Basic
Public Enum LandXMLSurfaceDataImportType
  QuickImport = AeccAttributeTypeInfoEnumSurfaceDataImport::kQuickImport
  FullImport = AeccAttributeTypeInfoEnumSurfaceDataImport::kFullImport
End Enum
Members
Members | Description
QuickImport | Imports the surface information as points. Creates a surface that has identical northing/easting/elevation points as the surface definition in the LandXML file. However, the triangulation may be different from the original surface.
FullImport | Imports both the points and the surface faces, if available. Creates the surface information from the face edges and creates a surface that is identical to the surface definition in the LandXML file.


Autodesk::Civil::Settings::MapcheckAngleType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::MapcheckAngleType Enumeration
Autodesk::Civil::Settings::MapcheckAngleType Enumeration
Collapse All

Definition of MapCheck Angle type.

C#
public enum MapcheckAngleType {
  Direction = AeccMapcheck::kAngTypeDirection,
  Angle = AeccMapcheck::kAngTypeAngle,
  DeflectionAngle = AeccMapcheck::kAngTypeDeflectionAngle
}
Visual Basic
Public Enum MapcheckAngleType
  Direction = AeccMapcheck::kAngTypeDirection
  Angle = AeccMapcheck::kAngTypeAngle
  DeflectionAngle = AeccMapcheck::kAngTypeDeflectionAngle
End Enum


Autodesk::Civil::Settings::MapcheckCurveDirectionType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::MapcheckCurveDirectionType Enumeration
Autodesk::Civil::Settings::MapcheckCurveDirectionType Enumeration
Collapse All

Definition of MapCheck Curve Direction type.

C#
public enum MapcheckCurveDirectionType {
  Clockwise = AeccMapcheck::kClockwise,
  CounterClockwise = AeccMapcheck::kCounterClockwise
}
Visual Basic
Public Enum MapcheckCurveDirectionType
  Clockwise = AeccMapcheck::kClockwise
  CounterClockwise = AeccMapcheck::kCounterClockwise
End Enum


Autodesk::Civil::Settings::MapcheckSideType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::MapcheckSideType Enumeration
Autodesk::Civil::Settings::MapcheckSideType Enumeration
Collapse All

Definition of MapCheck side type.

C#
public enum MapcheckSideType {
  Line = AeccMapcheck::kLine,
  Curve = AeccMapcheck::kCurve
}
Visual Basic
Public Enum MapcheckSideType
  Line = AeccMapcheck::kLine
  Curve = AeccMapcheck::kCurve
End Enum


Autodesk::Civil::Settings::MapcheckTraverseMethodType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::MapcheckTraverseMethodType Enumeration
Autodesk::Civil::Settings::MapcheckTraverseMethodType Enumeration
Collapse All

Definition of MapCheck Traverse Method type.

C#
public enum MapcheckTraverseMethodType {
  AcrossChord = AeccMapcheck::kAcrossChord,
  ThroughRadius = AeccMapcheck::kThroughRadius
}
Visual Basic
Public Enum MapcheckTraverseMethodType
  AcrossChord = AeccMapcheck::kAcrossChord
  ThroughRadius = AeccMapcheck::kThroughRadius
End Enum


Autodesk::Civil::Settings::ObjectLayerModifierType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::ObjectLayerModifierType Enumeration
Autodesk::Civil::Settings::ObjectLayerModifierType Enumeration
Collapse All

Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.

C#
public enum ObjectLayerModifierType {
  None = AeccDbEntity::kNone,
  Prefix = AeccDbEntity::kPrefix,
  Suffix = AeccDbEntity::kSuffix
}
Visual Basic
Public Enum ObjectLayerModifierType
  None = AeccDbEntity::kNone
  Prefix = AeccDbEntity::kPrefix
  Suffix = AeccDbEntity::kSuffix
End Enum
Members
Members | Description
None | No modifier.
Prefix | Modifier is added at the beginning of the layer name.
Suffix | Modifier is added at the end of the layer name.


Autodesk::Civil::Settings::SettingsObjectLayerType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::SettingsObjectLayerType Enumeration
Autodesk::Civil::Settings::SettingsObjectLayerType Enumeration
Collapse All

The Autodesk::Civil::Settings::SettingsObjectLayerType enumeration.

C#
public enum SettingsObjectLayerType {
  Alignment,
  AlignmentLabeling,
  AlignmentTable,
  Assembly,
  Corridor,
  CorridorSection,
  FeatureLine,
  GeneralNoteLabel,
  GeneralSegmentLabel,
  Grading,
  GradingLabeling,
  GridSurface,
  GridSurfaceLabeling,
  Interference,
  MassHaulLine,
  MassHaulView,
  MatchLine,
  MatchLineLabeling,
  MaterialSection,
  MaterialTable,
  Parcel,
  ParcelLabeling,
  ParcelSegment,
  ParcelSegmentLabeling,
  ParcelTable,
  Pipe,
  PipeLabeling,
  PipeAndStructureTable,
  PipeNetworkSection,
  PipeOrStructureProfile,
  PointTable,
  Profile,
  ProfileLabeling,
  ProfileView,
  ProfileViewLabeling,
  SampleLine,
  SampleLineLabeling,
  Section,
  SectionLabeling,
  SectionView,
  SectionViewLabeling,
  SectionViewQuantityTakeoffTable,
  Sheet,
  Structure,
  StructureLabeling,
  Subassembly,
  SurfaceLegendTable,
  SurveyFigure,
  SurveyNetwork,
  TinSurface,
  TinSurfaceLabeling,
  ViewFrame,
  ViewFrameLabeling,
  BuildingSite,
  Intersection,
  IntersectionLabeling
}
Visual Basic
Public Enum SettingsObjectLayerType
  Alignment
  AlignmentLabeling
  AlignmentTable
  Assembly
  Corridor
  CorridorSection
  FeatureLine
  GeneralNoteLabel
  GeneralSegmentLabel
  Grading
  GradingLabeling
  GridSurface
  GridSurfaceLabeling
  Interference
  MassHaulLine
  MassHaulView
  MatchLine
  MatchLineLabeling
  MaterialSection
  MaterialTable
  Parcel
  ParcelLabeling
  ParcelSegment
  ParcelSegmentLabeling
  ParcelTable
  Pipe
  PipeLabeling
  PipeAndStructureTable
  PipeNetworkSection
  PipeOrStructureProfile
  PointTable
  Profile
  ProfileLabeling
  ProfileView
  ProfileViewLabeling
  SampleLine
  SampleLineLabeling
  Section
  SectionLabeling
  SectionView
  SectionViewLabeling
  SectionViewQuantityTakeoffTable
  Sheet
  Structure
  StructureLabeling
  Subassembly
  SurfaceLegendTable
  SurveyFigure
  SurveyNetwork
  TinSurface
  TinSurfaceLabeling
  ViewFrame
  ViewFrameLabeling
  BuildingSite
  Intersection
  IntersectionLabeling
End Enum


Autodesk::Civil::Settings::SpecifyRotationType Enumeration

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Structs, Records, Enums > Autodesk::Civil::Settings::SpecifyRotationType Enumeration
Autodesk::Civil::Settings::SpecifyRotationType Enumeration
Collapse All

An enumeration that use to specify a rotation about the reference point in one of two ways: specify a rotation point, or apply a grid rotation angle.

C#
public enum SpecifyRotationType {
  RotationPoint = 0,
  GridRotationAngle
}
Visual Basic
Public Enum SpecifyRotationType
  RotationPoint = 0
  GridRotationAngle
End Enum


Autodesk::Civil::Survey Namespace

The Autodesk::Civil::Survey namespace.

Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::Survey::DatabaseServices namespace.
Settings | The Autodesk::Civil::Survey::Settings namespace.
Links
Namespaces


Autodesk::Civil::Survey::DatabaseServices Namespace

The Autodesk::Civil::Survey::DatabaseServices namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Classes
Class | Description
SurveyFigure | Survey figure class. Figures are groups of connected lines and arcs where the figure vertexes can reference survey points.
SurveyNetworkEntity | The drawing database version of a survey network object.
Links
Topics, Classes


Classes

The following table lists classes in this documentation.

Classes
Class | Description
SurveyFigure | Survey figure class. Figures are groups of connected lines and arcs where the figure vertexes can reference survey points.
SurveyNetworkEntity | The drawing database version of a survey network object.
Links
Classes


SurveyFigure Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::DatabaseServices Namespace > Classes > SurveyFigure Class
SurveyFigure Class
Collapse All

Survey figure class. Figures are groups of connected lines and arcs where the figure vertexes can reference survey points.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::FeatureLine
            Autodesk::Civil::Survey::DatabaseServices::SurveyFigure
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSvFigure"))]
public class SurveyFigure : Autodesk::Civil::Land::DatabaseServices::FeatureLine;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSvFigure"))>
Public Class SurveyFigure
Inherits Autodesk::Civil::Land::DatabaseServices::FeatureLine
Links
Class Hierarchy


SurveyNetworkEntity Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::DatabaseServices Namespace > Classes > SurveyNetworkEntity Class
SurveyNetworkEntity Class
Collapse All

The drawing database version of a survey network object.

Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Survey::DatabaseServices::SurveyNetworkEntity
C#
[Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSvNetwork"))]
public class SurveyNetworkEntity : Autodesk::Civil::DatabaseServices::Entity;
Visual Basic
<Autodesk::AutoCAD::Runtime::Wrapper(_DNT("AeccDbSvNetwork"))>
Public Class SurveyNetworkEntity
Inherits Autodesk::Civil::DatabaseServices::Entity
Links
Class Hierarchy


Autodesk::Civil::Survey::Settings Namespace

The Autodesk::Civil::Survey::Settings namespace.

Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Classes
Class | Description
SettingsSurvey | Settings for Survey.
SettingsSurvey::SettingsStyles | Default styles settings for Survey class
Links
Topics, Classes


Classes

The following table lists classes in this documentation.

Classes
Class | Description
SettingsSurvey | Settings for Survey.
SettingsSurvey::SettingsStyles | Default styles settings for Survey class
Links
Classes


SettingsSurvey Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class
SettingsSurvey Class
Collapse All

Settings for Survey.

Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Survey::Settings::SettingsSurvey
C#
public class SettingsSurvey : Autodesk::Civil::Settings::SettingsAmbient;
Visual Basic
Public Class SettingsSurvey
Inherits Autodesk::Civil::Settings::SettingsAmbient
Links
SettingsSurvey Properties, SettingsSurvey Members, Class Hierarchy


SettingsSurvey Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Members
SettingsSurvey Members
Collapse All

The following tables list the members exposed by SettingsSurvey.

Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for survey features.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.
Links
Classes, Public Properties, Templates


SettingsSurvey Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Properties
SettingsSurvey Properties
Collapse All

The properties of SettingsSurvey are listed here.

Public Properties
Public Property | Description
Styles | Gets the default styles for survey features.
Links
Public Properties


SettingsSurvey::Styles Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Properties > SettingsSurvey::Styles Property
SettingsSurvey::Styles Property
Collapse All

Gets the default styles for survey features.

C#
public SettingsStyles Styles;
Visual Basic
Public Property Styles() As SettingsStyles
Links
SettingsSurvey Class, SettingsSurvey Members, Autodesk::Civil::Survey::Settings Namespace


SettingsSurvey::SettingsStyles Class

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class
SettingsSurvey::SettingsStyles Class
Collapse All

Default styles settings for Survey class

Class Hierarchy
Autodesk::Civil::Survey::Settings::SettingsSurvey::SettingsStyles
C#
public class SettingsSurvey::SettingsStyles : TreeOidWrapper;
Visual Basic
Public Class SettingsSurvey::SettingsStyles
Inherits TreeOidWrapper
Links
SettingsSurvey::SettingsStyles Properties, SettingsSurvey::SettingsStyles Members, Class Hierarchy


SettingsSurvey::SettingsStyles Members

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class > SettingsSurvey::SettingsStyles Members
SettingsSurvey::SettingsStyles Members
Collapse All

The following tables list the members exposed by SettingsSurvey::SettingsStyles.

Public Properties
Public Property | Description
Figure | Gets the default style for a survey figure.
Network | Gets the default style for a survey network.
Links
Public Properties


SettingsSurvey::SettingsStyles Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class > SettingsSurvey::SettingsStyles Properties
SettingsSurvey::SettingsStyles Properties
Collapse All

The properties of SettingsSurvey::SettingsStyles are listed here.

Public Properties
Public Property | Description
Figure | Gets the default style for a survey figure.
Network | Gets the default style for a survey network.
Links
Public Properties


SettingsSurvey::SettingsStyles::Figure Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class > SettingsSurvey::SettingsStyles Properties > SettingsSurvey::SettingsStyles::Figure Property
SettingsSurvey::SettingsStyles::Figure Property
Collapse All

Gets the default style for a survey figure.

C#
public PropertyString Figure;
Visual Basic
Public Property Figure() As PropertyString
Links
SettingsSurvey::SettingsStyles Class, SettingsSurvey::SettingsStyles Members, Autodesk::Civil::Survey::Settings Namespace


SettingsSurvey::SettingsStyles::Network Property

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class > SettingsSurvey::SettingsStyles Properties > SettingsSurvey::SettingsStyles::Network Property
SettingsSurvey::SettingsStyles::Network Property
Collapse All

Gets the default style for a survey network.

C#
public PropertyString Network;
Visual Basic
Public Property Network() As PropertyString
Links
SettingsSurvey::SettingsStyles Class, SettingsSurvey::SettingsStyles Members, Autodesk::Civil::Survey::Settings Namespace


Classes

The following table lists classes in this documentation.

Classes
Class | Description
Constant | Constants used by the Civil API.
DesignCheck | The abstract design check class.
PropertyAnchorPoint | Property template for label anchor location.
PropertyAngle | Angle property template.
PropertyBlock | Encapsulates a Block name.
PropertyBoolean | Encapsulates a boolean value.
PropertyObjectName | Object name property template.
Templates
Template | Description
DesignCheckCollection | The DesignCheckCollection class.
PropertyEnum | Property template for enumerations.
Links
Classes, Templates


Constant Class

Constants used by the Civil API.

Class Hierarchy
Autodesk::Civil::Constant
C#
public class Constant;
Visual Basic
Public Class Constant
Links
Constant Data Members, Constant Members, Class Hierarchy


Constant Members

The following tables list the members exposed by Constant.

Public Data Members
Public Data Member | Description
VerticalGrade | This is VerticalGrade, a member of class Constant.
Links
Public Data Members


Constant Data Members

The data members of Constant are listed here.

Public Data Members
Public Data Member | Description
VerticalGrade | This is VerticalGrade, a member of class Constant.
Links
Public Data Members


Constant::VerticalGrade Data Member

This is VerticalGrade, a member of class Constant.

C#
public literal double VerticalGrade = 1.0e+8;
Visual Basic
Public VerticalGrade As literal double = 1.0e+8
Links
Constant Class, Constant Members, Autodesk::Civil Namespace


DesignCheck Class

The abstract design check class.

Class Hierarchy
Autodesk::Civil::DesignCheck
    Autodesk::Civil::Land::AlignmentDesignCheck
    Autodesk::Civil::Land::ProfileDesignCheck
C#
public class DesignCheck : CivilWrapper<AcDbDatabase>;
Visual Basic
Public Class DesignCheck
Inherits CivilWrapper<AcDbDatabase>
Links
DesignCheck Properties, DesignCheck Members, Class Hierarchy


DesignCheck Members

The following tables list the members exposed by DesignCheck.

Public Properties
Public Property | Description
Description | Gets and sets the description of the DesignCheck.
Expression | Gets or sets the expression of the DesignCheck.
Name | Gets the name of the DesignCheck.
Links
Public Properties


DesignCheck Properties

The properties of DesignCheck are listed here.

Public Properties
Public Property | Description
Description | Gets and sets the description of the DesignCheck.
Expression | Gets or sets the expression of the DesignCheck.
Name | Gets the name of the DesignCheck.
Links
Public Properties


DesignCheck::Description Property

Gets and sets the description of the DesignCheck.

C#
public System::String Description;
Visual Basic
Public Property Description() As System::String
Links
DesignCheck Class, DesignCheck Members, Autodesk::Civil Namespace


DesignCheck::Expression Property

Gets or sets the expression of the DesignCheck.

C#
public System::String Expression;
Visual Basic
Public Property Expression() As System::String
Exceptions
Exceptions | Description
System.ArgumentException | Thrown when the the input expression is null, blank , or includes unknown properties.
Links
DesignCheck Class, DesignCheck Members, Autodesk::Civil Namespace


DesignCheck::Name Property

Gets the name of the DesignCheck.

C#
public System::String Name;
Visual Basic
Public Property Name() As System::String
Links
DesignCheck Class, DesignCheck Members, Autodesk::Civil Namespace


DesignCheckCollection Template

The DesignCheckCollection class.

Class Hierarchy
Autodesk::Civil::DesignCheckCollection
C#
public class DesignCheckCollection<class DesignCheckT> : IEnumerable<DesignCheckT>;
Visual Basic
Public Class DesignCheckCollection(Of class DesignCheckT)
Inherits IEnumerable<DesignCheckT>
Links
DesignCheckCollection Methods, DesignCheckCollection Properties, DesignCheckCollection Members, Class Hierarchy


DesignCheckCollection Members

The following tables list the members exposed by DesignCheckCollection.

Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes DesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.
Public Properties
Public Property | Description
Count | Gets the number of DesignCheck in the collection.
default | Gets the DesignCheck by a specified name in the collection.
Links
Public Methods, Public Properties


DesignCheckCollection Methods

The methods of DesignCheckCollection are listed here.

Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes DesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.
Links
Public Methods


DesignCheckCollection::Add Method

Autodesk Namespace > Autodesk::Civil Namespace > Classes > DesignCheckCollection Template > DesignCheckCollection Methods > DesignCheckCollection::Add Method
DesignCheckCollection::Add Method
Collapse All

Adds a DesignCheck by specifying the name and expression.

C#
public DesignCheckT Add(
    ref System::String name,
    ref System::String description,
    ref System::String expression
);
Visual Basic
Public Function Add(
    ByRef name As System::String,
    ByRef description As System::String,
    ByRef expression As System::String
) As DesignCheckT
Parameters
Parameters | Description
name | The name of DesignCheck.
description | The description of DesignCheck.
expression | The expression of DesignCheck.
Exceptions
Exceptions | Description
System::ArgumentException | Throw when: 1: The name is duplicated. 2: The expression is not valid.
Links
DesignCheckCollection Template, DesignCheckCollection Members, Autodesk::Civil Namespace


DesignCheckCollection::Clear Method

Autodesk Namespace > Autodesk::Civil Namespace > Classes > DesignCheckCollection Template > DesignCheckCollection Methods > DesignCheckCollection::Clear Method
DesignCheckCollection::Clear Method
Collapse All

Removes all DesignChecks from the collection.

C#
public Clear();
Visual Basic
Public Sub Clear()
Remarks

It will remove all corresponding DesignChecks existed in AlignmentDesignCheckSet or ProfileDesignCheckSet.

Links
DesignCheckCollection Template, DesignCheckCollection Members, Autodesk::Civil Namespace


DesignCheckCollection::GetEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Classes > DesignCheckCollection Template > DesignCheckCollection Methods > DesignCheckCollection::GetEnumerator Method
DesignCheckCollection::GetEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::Generic::IEnumerator<DesignCheckT> GetEnumerator();
Visual Basic
Public Function GetEnumerator() As System::Collections::Generic::IEnumerator<DesignCheckT>
Returns

An enumerator which implements the IEnumerator interface.

Links
DesignCheckCollection Template, DesignCheckCollection Members, Autodesk::Civil Namespace


DesignCheckCollection::GetObjectEnumerator Method

Autodesk Namespace > Autodesk::Civil Namespace > Classes > DesignCheckCollection Template > DesignCheckCollection Methods > DesignCheckCollection::GetObjectEnumerator Method
DesignCheckCollection::GetObjectEnumerator Method
Collapse All

Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.

C#
public System::Collections::IEnumerator GetObjectEnumerator();
Visual Basic
Public Function GetObjectEnumerator() As System::Collections::IEnumerator
Returns

An enumerator which implements the IEnumerator interface.

Links
DesignCheckCollection Template, DesignCheckCollection Members, Autodesk::Civil Namespace


DesignCheckCollection::Remove Method

Autodesk Namespace > Autodesk::Civil Namespace > Classes > DesignCheckCollection Template > DesignCheckCollection Methods > DesignCheckCollection::Remove Method
DesignCheckCollection::Remove Method
Collapse All

Removes DesignCheck from the collection by the specified name.

C#
public Remove(
    ref System::String name
);
Visual Basic
Public Sub Remove(
    ByRef name As System::String
)
Parameters
Parameters | Description
name | Specifies the name of DesignCheck to remove.
Remarks

It will remove the corresponding DesignCheck existed in AlignmentDesignCheckSet or ProfileDesignCheckSet.

Exceptions
Exceptions | Description
System::ArgumentException | Throw when the DesignCheck with specified name cannot be found in the collection.
Links
DesignCheckCollection Template, DesignCheckCollection Members, Autodesk::Civil Namespace


DesignCheckCollection::RemoveAt Method

Autodesk Namespace > Autodesk::Civil Namespace > Classes > DesignCheckCollection Template > DesignCheckCollection Methods > DesignCheckCollection::RemoveAt Method
DesignCheckCollection::RemoveAt Method
Collapse All

Removes DesignCheck from the collection by the specified index.

C#
public RemoveAt(
    int index
);
Visual Basic
Public Sub RemoveAt(
    index As Integer
)
Parameters
Parameters | Description
index | Specifies index in the collection to remove.
Remarks

It will remove the corresponding DesignCheck existed in AlignmentDesignCheckSet or ProfileDesignCheckSet.

Links
DesignCheckCollection Template, DesignCheckCollection Members, Autodesk::Civil Namespace


DesignCheckCollection Properties

The properties of DesignCheckCollection are listed here.

Public Properties
Public Property | Description
Count | Gets the number of DesignCheck in the collection.
default | Gets the DesignCheck by a specified name in the collection.
Links
Public Properties


DesignCheckCollection::Count Property

Autodesk Namespace > Autodesk::Civil Namespace > Classes > DesignCheckCollection Template > DesignCheckCollection Properties > DesignCheckCollection::Count Property
DesignCheckCollection::Count Property
Collapse All

Gets the number of DesignCheck in the collection.

C#
public int Count;
Visual Basic
Public Property Count() As Integer
Links
DesignCheckCollection Template, DesignCheckCollection Members, Autodesk::Civil Namespace


DesignCheckCollection::default Property

Autodesk Namespace > Autodesk::Civil Namespace > Classes > DesignCheckCollection Template > DesignCheckCollection Properties > DesignCheckCollection::default Property
DesignCheckCollection::default Property
Collapse All

Gets the DesignCheck by a specified name in the collection.

C#
public DesignCheckT default;
Visual Basic
Public Property default() As DesignCheckT
Parameters
Parameters | Description
name | Design check name.
Links
DesignCheckCollection Template, DesignCheckCollection Members, Autodesk::Civil Namespace


PropertyAnchorPoint Class

Property template for label anchor location.

Class Hierarchy
Autodesk::Civil::PropertyAnchorPoint
C#
public class PropertyAnchorPoint : Property<int>;
Visual Basic
Public Class PropertyAnchorPoint
Inherits Property<int>
Links
PropertyAnchorPoint Properties, PropertyAnchorPoint Members, Class Hierarchy


PropertyAnchorPoint Members

The following tables list the members exposed by PropertyAnchorPoint.

Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyAnchorPoint.
Links
Public Properties


PropertyAnchorPoint Properties

The properties of PropertyAnchorPoint are listed here.

Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyAnchorPoint.
Links
Public Properties


PropertyAnchorPoint::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Classes > PropertyAnchorPoint Class > PropertyAnchorPoint Properties > PropertyAnchorPoint::Value Property
PropertyAnchorPoint::Value Property
Collapse All

This is Value, a member of class PropertyAnchorPoint.

C#
public AnchorPointType Value;
Visual Basic
Public Property Value() As AnchorPointType
Links
PropertyAnchorPoint Class, PropertyAnchorPoint Members, Autodesk::Civil Namespace


PropertyAngle Class

Angle property template.

Class Hierarchy
Autodesk::Civil::PropertyAngle
C#
public class PropertyAngle : PropertyDouble;
Visual Basic
Public Class PropertyAngle
Inherits PropertyDouble
Remarks

The angle value will be converted to a value automatically that is fall in the range [0, 2*PI).

Links
PropertyAngle Properties, PropertyAngle Members, Class Hierarchy


PropertyAngle Members

The following tables list the members exposed by PropertyAngle.

Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyAngle.
Links
Public Properties


PropertyAngle Properties

The properties of PropertyAngle are listed here.

Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyAngle.
Links
Public Properties


PropertyAngle::Value Property

This is Value, a member of class PropertyAngle.

C#
public double Value;
Visual Basic
Public Property Value() As double
Links
PropertyAngle Class, PropertyAngle Members, Autodesk::Civil Namespace


PropertyBlock Class

Encapsulates a Block name.

Class Hierarchy
Autodesk::Civil::PropertyBlock
C#
public class PropertyBlock : PropertyString;
Visual Basic
Public Class PropertyBlock
Inherits PropertyString
Links
PropertyBlock Properties, PropertyBlock Members, Class Hierarchy


PropertyBlock Members

The following tables list the members exposed by PropertyBlock.

Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyBlock.
Links
Public Properties


PropertyBlock Properties

The properties of PropertyBlock are listed here.

Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyBlock.
Links
Public Properties


PropertyBlock::Value Property

This is Value, a member of class PropertyBlock.

C#
public System::String Value;
Visual Basic
Public Property Value() As System::String
Links
PropertyBlock Class, PropertyBlock Members, Autodesk::Civil Namespace


PropertyBoolean Class

Encapsulates a boolean value.

Class Hierarchy
Autodesk::Civil::PropertyBoolean
C#
public class PropertyBoolean : Property<bool>;
Visual Basic
Public Class PropertyBoolean
Inherits Property<bool>
Links
Class Hierarchy


PropertyEnum Template

Property template for enumerations.

Class Hierarchy
Autodesk::Civil::PropertyEnum
C#
public class PropertyEnum<typename T> : Property<int> where T :;
Visual Basic
Public Class PropertyEnum(Of typename T)
Inherits Property<int>
Links
PropertyEnum Properties, PropertyEnum Members, Class Hierarchy


PropertyEnum Members

The following tables list the members exposed by PropertyEnum.

Public Properties
Public Property | Description
Value | Gets or sets the property value.
Links
Public Properties


PropertyEnum Properties

The properties of PropertyEnum are listed here.

Public Properties
Public Property | Description
Value | Gets or sets the property value.
Links
Public Properties


PropertyEnum::Value Property

Gets or sets the property value.

C#
public T Value;
Visual Basic
Public Property Value() As T
Links
PropertyEnum Template, PropertyEnum Members, Autodesk::Civil Namespace


PropertyObjectName Class

Object name property template.

Class Hierarchy
Autodesk::Civil::PropertyObjectName
C#
public class PropertyObjectName : PropertyString;
Visual Basic
Public Class PropertyObjectName
Inherits PropertyString
Links
PropertyObjectName Properties, PropertyObjectName Members, Class Hierarchy


PropertyObjectName Members

The following tables list the members exposed by PropertyObjectName.

Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyObjectName.
Links
Public Properties


PropertyObjectName Properties

The properties of PropertyObjectName are listed here.

Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyObjectName.
Links
Public Properties


PropertyObjectName::Value Property

Autodesk Namespace > Autodesk::Civil Namespace > Classes > PropertyObjectName Class > PropertyObjectName Properties > PropertyObjectName::Value Property
PropertyObjectName::Value Property
Collapse All

This is Value, a member of class PropertyObjectName.

C#
public System::String Value;
Visual Basic
Public Property Value() As System::String
Links
PropertyObjectName Class, PropertyObjectName Members, Autodesk::Civil Namespace


Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Enumeration | Description
AccelerationUnitType | An enumeration that describes accelleration units.
AlignmentPointType | Defines types of points on an Alignment.
AnchorLocationType | Specifies where to anchor various label annotations.
AnchorPointType | Specifies where to anchor various label annotations.
AngleFormatType | Specifies angle format.
AngleUnitType | Specifies angle units.
AreaUnitType | Specifies area units.
ArrowHeadFitType | An enumeration that defines the arrow head fit type.
ArrowHeadSizeType | An enumeration that defines the arrow head size type.
ArrowHeadType | An enumeration that defines the arrow head type.
BearingQuadrantType | Specifies bearing quadrant type.
BlockAttachmentType | Specifies specifies how block label components are attached.
CapitalizationType | Specifies how direction value text is capitalized.
CurbReturnType | Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.
DecimalCharacterType | Specifies decimal character type.
DimensionAnchorOptionType | An enumeration that specifies the behavior of the anchor dimension.
DimensionAnchorType | Defines the location of the anchor used to position dimension lines for certain profile view labels, such as vertical curve... more
DirectionDisplayType | Specifies display direction.
DirectionNameDisplayType | Specifies direction name display.
DrivingDirectionType | The Autodesk::Civil::DrivingDirectionType enumeration.
DropDecimalWholeType | Specifies decimal rounding.
DropLeadingZeroType | Specifies whether to drop leading zeros.
FlowUnitType | Specifies flow units.
GradeFormatType | Specifies grade format.
GradeSlopeFormatType | Specifies grade slope format.
LabelContentDisplayType | Defines label content display type after it is dragged from its default position.
LabelingPromptType | Specifies labeling prompt.
LabelInsertionType | Specifies label insertion.
LabelInsideCurveType | Defines labels place type, inside or outside a curve.
LabelMaskType | Specifies label mask types.
LabelTextAttachmentType | Enumeration that label text attachment location.
LatLongDirectionType | Specifies latitude / longitude direction.
LayoutModeType | Specifies layout mode.
LeaderAttachmentBehaviorType | An enumeration that specifies the attachment behavior of the leader.
LeaderAttachmentType | Specifies leader attachment location.
LeaderShapeType | Defines the leader shape type.
LeaderTailVisibilityType | An enumeration that specifies the behavior of the leader tail visibility.
LeaderVisibilityType | An enumeration that specifies the behavior of the leader visibility.
LinearUnitType | Specifies linear units.
MaskType | An enumeration that specifies the behavior of a label's background mask.
OrientationReferenceType | Specifies orientation reference.
PlottedUnitDisplayType | Specifies plotted units.
ProfilePointType | Defines types of points on a Profile.
RotationDirType | Specifies rotation direction.
RoundingType | Specifies rounding.
ROWCleanupType | Specifies ROW cleanup.
SignType | Specifies sign.
SlopeFormatType | Specifies slope format.
SpeedUnitType | Specifies speed units.
SpiralType | An enumeration that defines the sprial types.
StationDelimiterCharacterType | Specifies station delimeter character.
StationDelimiterPositionType | Specifies station position.
StationFormatType | Specifies station format.
StructureColumnComponentType | An enumeration that specifies the structure table cell component type.
StyleConflictResolverType | Specifies how to resolve conflicts (the same name for an existing style and a new imported style) when exporting styles... more
SuperelevationPointType | Defines the superelevation critical points type that need to be labeled.
TableSegmentDataType | Defines the type of content in a table column.
TableTitleDirectionType | An enumeration that defines the table title directions.
TextBorderType | Specifies text border types.
TextJustificationType | Specifies text justification.
TransitionInputType | Specify the type of linear transition used for the widening: By Length or By Taper Ratio.
TransitionType | Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.
VectorMeasurementType | Specifies vector measurment.
VolumeUnitType | Specifies volume units.
Links
Enumerations


Autodesk::Civil::AccelerationUnitType Enumeration

An enumeration that describes accelleration units.

C#
public enum AccelerationUnitType {
  MeterPerSecSquared = AeccFormatInfo::meter_per_sec_squared,
  FootPerSecSquared = AeccFormatInfo::foot_per_sec_squared
}
Visual Basic
Public Enum AccelerationUnitType
  MeterPerSecSquared = AeccFormatInfo::meter_per_sec_squared
  FootPerSecSquared = AeccFormatInfo::foot_per_sec_squared
End Enum


Autodesk::Civil::AlignmentPointType Enumeration

Defines types of points on an Alignment.

C#
public enum AlignmentPointType {
  Begin = AeccAlignStation::kStnGPBegOfAlign,
  End = AeccAlignStation::kStnGPEndOfAlign,
  TanTan = AeccAlignStation::kStnGPTanTan,
  TanCurve = AeccAlignStation::kStnGPTanCurve,
  CurveTan = AeccAlignStation::kStnGPCurveTan,
  CompCurveCurve = AeccAlignStation::kStnGPCurveCompCurve,
  RevCurveCurve = AeccAlignStation::kStnGPCurveRevCurve,
  TanSpiral = AeccAlignStation::kStnGPTanSpiral,
  SpiralTan = AeccAlignStation::kStnGPSpiralTan,
  CurveSpiral = AeccAlignStation::kStnGPCurveSpiral,
  SpiralCurve = AeccAlignStation::kStnGPSpiralCurve,
  SpiralSpiral = AeccAlignStation::kStnGPSpiralCompSpiral,
  RevSpiral = AeccAlignStation::kStnGPSpiralRevSpiral
}
Visual Basic
Public Enum AlignmentPointType
  Begin = AeccAlignStation::kStnGPBegOfAlign
  End = AeccAlignStation::kStnGPEndOfAlign
  TanTan = AeccAlignStation::kStnGPTanTan
  TanCurve = AeccAlignStation::kStnGPTanCurve
  CurveTan = AeccAlignStation::kStnGPCurveTan
  CompCurveCurve = AeccAlignStation::kStnGPCurveCompCurve
  RevCurveCurve = AeccAlignStation::kStnGPCurveRevCurve
  TanSpiral = AeccAlignStation::kStnGPTanSpiral
  SpiralTan = AeccAlignStation::kStnGPSpiralTan
  CurveSpiral = AeccAlignStation::kStnGPCurveSpiral
  SpiralCurve = AeccAlignStation::kStnGPSpiralCurve
  SpiralSpiral = AeccAlignStation::kStnGPSpiralCompSpiral
  RevSpiral = AeccAlignStation::kStnGPSpiralRevSpiral
End Enum


Autodesk::Civil::AnchorLocationType Enumeration

Specifies where to anchor various label annotations.

C#
public enum AnchorLocationType {
  TopLeft = AeccAttributeId::kAttrIdLabelStyleAnchorTopLeft,
  TopCenter = AeccAttributeId::kAttrIdLabelStyleAnchorTopCenter,
  TopRight = AeccAttributeId::kAttrIdLabelStyleAnchorTopRight,
  MiddleLeft = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleLeft,
  MiddleCenter = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleCenter,
  MiddleRight = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleRight,
  BottomLeft = AeccAttributeId::kAttrIdLabelStyleAnchorBottomLeft,
  BottomCenter = AeccAttributeId::kAttrIdLabelStyleAnchorBottomCenter,
  BottomRight = AeccAttributeId::kAttrIdLabelStyleAnchorBottomRight,
  Start = AeccAttributeId::kAttrIdLabelStyleAnchorStart,
  Middle = AeccAttributeId::kAttrIdLabelStyleAnchorMiddle,
  End = AeccAttributeId::kAttrIdLabelStyleAnchorEnd,
  InsertionPoint = AeccAttributeId::kAttrIdLabelStyleAnchorInsertionPoint,
  Station = AeccAttributeId::kAttrIdLabelStyleAnchorStation,
  LabelLocation = AeccAttributeId::kAttrIdLabelStyleAnchorSegment,
  PI = AeccAttributeId::kAttrIdLabelStyleAnchorPI,
  PVI = AeccAttributeId::kAttrIdLabelStyleAnchorPVI,
  CurveStart = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStart,
  CurveEnd = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEnd,
  PVIExtension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIExtension,
  CurveStartExtension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStartExtension,
  CurveMiddleExtension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveMidExtension,
  CurveEndExtension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEndExtension,
  CurveHighPoint = AeccAttributeId::kAttrIdLabelStyleAnchorCurveHighPoint,
  CurveLowPoint = AeccAttributeId::kAttrIdLabelStyleAnchorCurveLowPoint,
  TangentStart = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStart,
  TangentMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorTangentMiddle,
  TangentEnd = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEnd,
  TangentStartExtension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStartExtension,
  TangentMiddleExtension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentMiddleExtension,
  TangentEndExtension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEndExtension,
  StationExtension = AeccAttributeId::kAttrIdLabelStyleAnchorStationExtension,
  BandTop = AeccAttributeId::kAttrIdLabelStyleAnchorBandTop,
  BandMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorBandMiddle,
  BandBottom = AeccAttributeId::kAttrIdLabelStyleAnchorBandBottom,
  StartExtension = AeccAttributeId::kAttrIdLabelStyleAnchorStartExtension,
  MiddleExtension = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleExtension,
  EndExtension = AeccAttributeId::kAttrIdLabelStyleAnchorEndExtension,
  Offset = AeccAttributeId::kAttrIdLabelStyleAnchorOffset,
  GradeBreak = AeccAttributeId::kAttrIdLabelStyleAnchorGradeBreak,
  GradeBreakExtension = AeccAttributeId::kAttrIdLabelStyleAnchorGradeBreakExtension
}
Visual Basic
Public Enum AnchorLocationType
  TopLeft = AeccAttributeId::kAttrIdLabelStyleAnchorTopLeft
  TopCenter = AeccAttributeId::kAttrIdLabelStyleAnchorTopCenter
  TopRight = AeccAttributeId::kAttrIdLabelStyleAnchorTopRight
  MiddleLeft = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleLeft
  MiddleCenter = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleCenter
  MiddleRight = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleRight
  BottomLeft = AeccAttributeId::kAttrIdLabelStyleAnchorBottomLeft
  BottomCenter = AeccAttributeId::kAttrIdLabelStyleAnchorBottomCenter
  BottomRight = AeccAttributeId::kAttrIdLabelStyleAnchorBottomRight
  Start = AeccAttributeId::kAttrIdLabelStyleAnchorStart
  Middle = AeccAttributeId::kAttrIdLabelStyleAnchorMiddle
  End = AeccAttributeId::kAttrIdLabelStyleAnchorEnd
  InsertionPoint = AeccAttributeId::kAttrIdLabelStyleAnchorInsertionPoint
  Station = AeccAttributeId::kAttrIdLabelStyleAnchorStation
  LabelLocation = AeccAttributeId::kAttrIdLabelStyleAnchorSegment
  PI = AeccAttributeId::kAttrIdLabelStyleAnchorPI
  PVI = AeccAttributeId::kAttrIdLabelStyleAnchorPVI
  CurveStart = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStart
  CurveEnd = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEnd
  PVIExtension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIExtension
  CurveStartExtension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStartExtension
  CurveMiddleExtension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveMidExtension
  CurveEndExtension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEndExtension
  CurveHighPoint = AeccAttributeId::kAttrIdLabelStyleAnchorCurveHighPoint
  CurveLowPoint = AeccAttributeId::kAttrIdLabelStyleAnchorCurveLowPoint
  TangentStart = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStart
  TangentMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorTangentMiddle
  TangentEnd = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEnd
  TangentStartExtension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStartExtension
  TangentMiddleExtension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentMiddleExtension
  TangentEndExtension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEndExtension
  StationExtension = AeccAttributeId::kAttrIdLabelStyleAnchorStationExtension
  BandTop = AeccAttributeId::kAttrIdLabelStyleAnchorBandTop
  BandMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorBandMiddle
  BandBottom = AeccAttributeId::kAttrIdLabelStyleAnchorBandBottom
  StartExtension = AeccAttributeId::kAttrIdLabelStyleAnchorStartExtension
  MiddleExtension = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleExtension
  EndExtension = AeccAttributeId::kAttrIdLabelStyleAnchorEndExtension
  Offset = AeccAttributeId::kAttrIdLabelStyleAnchorOffset
  GradeBreak = AeccAttributeId::kAttrIdLabelStyleAnchorGradeBreak
  GradeBreakExtension = AeccAttributeId::kAttrIdLabelStyleAnchorGradeBreakExtension
End Enum
Remarks

Used in BlockLabelStyles, VectorArrowLabelStyles, LineLabelStyles, and TextLabelStyles. There are nine anchor point values representing points along a rectangle that encompasses the entire text component and are relative to the rotation angle of the text.


Autodesk::Civil::AnchorPointType Enumeration

Specifies where to anchor various label annotations.

C#
public enum AnchorPointType {
  Start = AeccAttributeId::kAttrIdLabelStyleAnchorStart,
  Middle = AeccAttributeId::kAttrIdLabelStyleAnchorMiddle,
  End = AeccAttributeId::kAttrIdLabelStyleAnchorEnd,
  TopLeft = AeccAttributeId::kAttrIdLabelStyleAnchorTopLeft,
  TopCenter = AeccAttributeId::kAttrIdLabelStyleAnchorTopCenter,
  TopRight = AeccAttributeId::kAttrIdLabelStyleAnchorTopRight,
  MiddleLeft = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleLeft,
  MiddleCenter = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleCenter,
  MiddleRight = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleRight,
  BottomLeft = AeccAttributeId::kAttrIdLabelStyleAnchorBottomLeft,
  BottomCenter = AeccAttributeId::kAttrIdLabelStyleAnchorBottomCenter,
  BottomRight = AeccAttributeId::kAttrIdLabelStyleAnchorBottomRight,
  InsertionPoint = AeccAttributeId::kAttrIdLabelStyleAnchorInsertionPoint,
  Center = AeccAttributeId::kAttrIdLabelStyleAnchorCenter,
  PointOfIntersection = AeccAttributeId::kAttrIdLabelStyleAnchorPointOfIntersection,
  Station = AeccAttributeId::kAttrIdLabelStyleAnchorStation,
  PI = AeccAttributeId::kAttrIdLabelStyleAnchorPI,
  PVI = AeccAttributeId::kAttrIdLabelStyleAnchorPVI,
  CurveStart = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStart,
  CurveEnd = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEnd,
  PVIDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIExtension,
  CurveStartDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStartExtension,
  CurveMidDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveMidExtension,
  CurveEndDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEndExtension,
  CurveHighPoint = AeccAttributeId::kAttrIdLabelStyleAnchorCurveHighPoint,
  CurveLowPoint = AeccAttributeId::kAttrIdLabelStyleAnchorCurveLowPoint,
  TangentStart = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStart,
  TangentMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorTangentMiddle,
  TangentEnd = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEnd,
  TangentStartDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStartExtension,
  TangentMiddleDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentMiddleExtension,
  TangentEndDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEndExtension,
  StationExtension = AeccAttributeId::kAttrIdLabelStyleAnchorStationExtension,
  PVIStart = AeccAttributeId::kAttrIdLabelStyleAnchorPVIStart,
  PVIEnd = AeccAttributeId::kAttrIdLabelStyleAnchorPVIEnd,
  PVIStartDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIStartExtension,
  PVIEndDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIEndExtension,
  CurveMid = AeccAttributeId::kAttrIdLabelStyleAnchorCurveMid,
  CurveHighPointDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveHighPointExtension,
  CurveLowPointDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveLowPointExtension,
  CurveStartInView = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStartInView,
  CurveEndInView = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEndInView,
  CurveStartInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStartInViewExtension,
  CurveEndInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEndInViewExtension,
  TangentStartInView = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStartInView,
  TangentEndInView = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEndInView,
  TangentStartInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStartInViewExtension,
  TangentEndInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEndInViewExtension,
  PVIStartInView = AeccAttributeId::kAttrIdLabelStyleAnchorPVIStartInView,
  PVIEndInView = AeccAttributeId::kAttrIdLabelStyleAnchorPVIEndInView,
  PVIStartInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIStartInViewExtension,
  PVIEndInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIEndInViewExtension,
  StartExtension = AeccAttributeId::kAttrIdLabelStyleAnchorStartExtension,
  MiddleExtension = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleExtension,
  EndExtension = AeccAttributeId::kAttrIdLabelStyleAnchorEndExtension,
  Offset = AeccAttributeId::kAttrIdLabelStyleAnchorOffset,
  OffsetExtension = AeccAttributeId::kAttrIdLabelStyleAnchorOffsetExtension,
  GradeBreak = AeccAttributeId::kAttrIdLabelStyleAnchorGradeBreak,
  GradeBreakExtension = AeccAttributeId::kAttrIdLabelStyleAnchorGradeBreakExtension,
  Centerline = AeccAttributeId::kAttrIdLabelStyleAnchorCenterline,
  TopOuterDiameter = AeccAttributeId::kAttrIdLabelStyleAnchorTopOuterDiameter,
  TopInnerDiameter = AeccAttributeId::kAttrIdLabelStyleAnchorTopInnerDiameter,
  BottomOuterDiameter = AeccAttributeId::kAttrIdLabelStyleAnchorBottomOuterDiameter,
  BottomInnerDiameter = AeccAttributeId::kAttrIdLabelStyleAnchorBottomInnerDiameter,
  PipeDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPipeDimension,
  StructureDimension = AeccAttributeId::kAttrIdLabelStyleAnchorStructureDimension,
  SectionViewTop = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewTop,
  SectionViewBottom = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewBottom,
  SectionViewTopAtStart = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewTopAtStart,
  SectionViewBottomAtStart = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewBottomAtStart,
  SectionViewTopAtMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewTopAtMiddle,
  SectionViewBottomAtMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewBottomAtMiddle,
  SectionViewTopAtEnd = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewTopAtEnd,
  SectionViewBottomAtEnd = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewBottomAtEnd,
  SegmentMiddleSuperelevationBand = AeccAttributeId::kAttrIdLabelStyleAnchorSegmentMiddleSuperelevationBand,
  Insertion = AeccAttributeId::kAttrIdLabelStyleAnchorProjectionInsertion,
  Dimension = AeccAttributeId::kAttrIdLabelStyleAnchorProjectionDimension,
  LabelLocation = AeccAttributeId::kAttrIdLabelStyleBeadLocation,
  BandTop = AeccAttributeId::kAttrIdLabelStyleAnchorBandTop,
  BandMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorBandMiddle,
  BandBottom = AeccAttributeId::kAttrIdLabelStyleAnchorBandBottom,
  PreviousStationBandTop = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelPreviousStationBandTop,
  PreviousStationBandMiddle = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelPreviousStationBandMiddle,
  PreviousStationBandBottom = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelPreviousStationBandBottom,
  LengthMidBandTop = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelLengthMidBandTop,
  LengthMidBandMiddle = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelLengthMidBandMiddle,
  LengthMidBandBottom = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelLengthMidBandBottom,
  NextStationBandTop = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelNextStationBandTop,
  NextStationBandMiddle = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelNextStationBandMiddle,
  NextStationBandBottom = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelNextStationBandBottom,
  SegmentStartAndBandTop = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentStartAndBandTopLoc,
  SegmentStartAndBandMiddle = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentStartAndBandMiddleLoc,
  SegmentStartAndBandBot = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentStartAndBandBotLoc,
  SegmentMiddleAndBandTop = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentMiddleAndBandTopLoc,
  SegmentMiddleAndBandMiddle = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentMiddleAndBandMiddleLoc,
  SegmentMiddleAndBandBot = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentMiddleAndBandBotLoc,
  SegmentEndAndBandTop = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentEndAndBandTopLoc,
  SegmentEndAndBandMiddle = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentEndAndBandMiddleLoc,
  SegmentEndAndBandBot = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentEndAndBandBotLoc,
  SchematicLineStart = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentStartLoc,
  SchematicLineMid = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentMidLoc,
  SchematicLineEnd = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentEndLoc,
  PreviousOffsetBandTop = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelPreviousOffsetBandTop,
  PreviousOffsetBandMiddle = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelPreviousOffsetBandMiddle,
  PreviousOffsetBandBottom = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelPreviousOffsetBandBottom,
  NextOffsetBandTop = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelNextOffsetBandTop,
  NextOffsetBandMiddle = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelNextOffsetBandMiddle,
  NextOffsetBandBottom = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelNextOffsetBandBottom
}
Visual Basic
Public Enum AnchorPointType
  Start = AeccAttributeId::kAttrIdLabelStyleAnchorStart
  Middle = AeccAttributeId::kAttrIdLabelStyleAnchorMiddle
  End = AeccAttributeId::kAttrIdLabelStyleAnchorEnd
  TopLeft = AeccAttributeId::kAttrIdLabelStyleAnchorTopLeft
  TopCenter = AeccAttributeId::kAttrIdLabelStyleAnchorTopCenter
  TopRight = AeccAttributeId::kAttrIdLabelStyleAnchorTopRight
  MiddleLeft = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleLeft
  MiddleCenter = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleCenter
  MiddleRight = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleRight
  BottomLeft = AeccAttributeId::kAttrIdLabelStyleAnchorBottomLeft
  BottomCenter = AeccAttributeId::kAttrIdLabelStyleAnchorBottomCenter
  BottomRight = AeccAttributeId::kAttrIdLabelStyleAnchorBottomRight
  InsertionPoint = AeccAttributeId::kAttrIdLabelStyleAnchorInsertionPoint
  Center = AeccAttributeId::kAttrIdLabelStyleAnchorCenter
  PointOfIntersection = AeccAttributeId::kAttrIdLabelStyleAnchorPointOfIntersection
  Station = AeccAttributeId::kAttrIdLabelStyleAnchorStation
  PI = AeccAttributeId::kAttrIdLabelStyleAnchorPI
  PVI = AeccAttributeId::kAttrIdLabelStyleAnchorPVI
  CurveStart = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStart
  CurveEnd = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEnd
  PVIDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIExtension
  CurveStartDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStartExtension
  CurveMidDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveMidExtension
  CurveEndDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEndExtension
  CurveHighPoint = AeccAttributeId::kAttrIdLabelStyleAnchorCurveHighPoint
  CurveLowPoint = AeccAttributeId::kAttrIdLabelStyleAnchorCurveLowPoint
  TangentStart = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStart
  TangentMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorTangentMiddle
  TangentEnd = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEnd
  TangentStartDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStartExtension
  TangentMiddleDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentMiddleExtension
  TangentEndDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEndExtension
  StationExtension = AeccAttributeId::kAttrIdLabelStyleAnchorStationExtension
  PVIStart = AeccAttributeId::kAttrIdLabelStyleAnchorPVIStart
  PVIEnd = AeccAttributeId::kAttrIdLabelStyleAnchorPVIEnd
  PVIStartDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIStartExtension
  PVIEndDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIEndExtension
  CurveMid = AeccAttributeId::kAttrIdLabelStyleAnchorCurveMid
  CurveHighPointDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveHighPointExtension
  CurveLowPointDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveLowPointExtension
  CurveStartInView = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStartInView
  CurveEndInView = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEndInView
  CurveStartInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveStartInViewExtension
  CurveEndInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorCurveEndInViewExtension
  TangentStartInView = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStartInView
  TangentEndInView = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEndInView
  TangentStartInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentStartInViewExtension
  TangentEndInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorTangentEndInViewExtension
  PVIStartInView = AeccAttributeId::kAttrIdLabelStyleAnchorPVIStartInView
  PVIEndInView = AeccAttributeId::kAttrIdLabelStyleAnchorPVIEndInView
  PVIStartInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIStartInViewExtension
  PVIEndInViewDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPVIEndInViewExtension
  StartExtension = AeccAttributeId::kAttrIdLabelStyleAnchorStartExtension
  MiddleExtension = AeccAttributeId::kAttrIdLabelStyleAnchorMiddleExtension
  EndExtension = AeccAttributeId::kAttrIdLabelStyleAnchorEndExtension
  Offset = AeccAttributeId::kAttrIdLabelStyleAnchorOffset
  OffsetExtension = AeccAttributeId::kAttrIdLabelStyleAnchorOffsetExtension
  GradeBreak = AeccAttributeId::kAttrIdLabelStyleAnchorGradeBreak
  GradeBreakExtension = AeccAttributeId::kAttrIdLabelStyleAnchorGradeBreakExtension
  Centerline = AeccAttributeId::kAttrIdLabelStyleAnchorCenterline
  TopOuterDiameter = AeccAttributeId::kAttrIdLabelStyleAnchorTopOuterDiameter
  TopInnerDiameter = AeccAttributeId::kAttrIdLabelStyleAnchorTopInnerDiameter
  BottomOuterDiameter = AeccAttributeId::kAttrIdLabelStyleAnchorBottomOuterDiameter
  BottomInnerDiameter = AeccAttributeId::kAttrIdLabelStyleAnchorBottomInnerDiameter
  PipeDimension = AeccAttributeId::kAttrIdLabelStyleAnchorPipeDimension
  StructureDimension = AeccAttributeId::kAttrIdLabelStyleAnchorStructureDimension
  SectionViewTop = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewTop
  SectionViewBottom = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewBottom
  SectionViewTopAtStart = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewTopAtStart
  SectionViewBottomAtStart = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewBottomAtStart
  SectionViewTopAtMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewTopAtMiddle
  SectionViewBottomAtMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewBottomAtMiddle
  SectionViewTopAtEnd = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewTopAtEnd
  SectionViewBottomAtEnd = AeccAttributeId::kAttrIdLabelStyleAnchorSectionViewBottomAtEnd
  SegmentMiddleSuperelevationBand = AeccAttributeId::kAttrIdLabelStyleAnchorSegmentMiddleSuperelevationBand
  Insertion = AeccAttributeId::kAttrIdLabelStyleAnchorProjectionInsertion
  Dimension = AeccAttributeId::kAttrIdLabelStyleAnchorProjectionDimension
  LabelLocation = AeccAttributeId::kAttrIdLabelStyleBeadLocation
  BandTop = AeccAttributeId::kAttrIdLabelStyleAnchorBandTop
  BandMiddle = AeccAttributeId::kAttrIdLabelStyleAnchorBandMiddle
  BandBottom = AeccAttributeId::kAttrIdLabelStyleAnchorBandBottom
  PreviousStationBandTop = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelPreviousStationBandTop
  PreviousStationBandMiddle = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelPreviousStationBandMiddle
  PreviousStationBandBottom = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelPreviousStationBandBottom
  LengthMidBandTop = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelLengthMidBandTop
  LengthMidBandMiddle = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelLengthMidBandMiddle
  LengthMidBandBottom = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelLengthMidBandBottom
  NextStationBandTop = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelNextStationBandTop
  NextStationBandMiddle = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelNextStationBandMiddle
  NextStationBandBottom = AeccAttributeId::kAttrIdGraphStyleProfileBandDetailsStationElevationAtIncrementalDistanceLabelNextStationBandBottom
  SegmentStartAndBandTop = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentStartAndBandTopLoc
  SegmentStartAndBandMiddle = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentStartAndBandMiddleLoc
  SegmentStartAndBandBot = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentStartAndBandBotLoc
  SegmentMiddleAndBandTop = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentMiddleAndBandTopLoc
  SegmentMiddleAndBandMiddle = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentMiddleAndBandMiddleLoc
  SegmentMiddleAndBandBot = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentMiddleAndBandBotLoc
  SegmentEndAndBandTop = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentEndAndBandTopLoc
  SegmentEndAndBandMiddle = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentEndAndBandMiddleLoc
  SegmentEndAndBandBot = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentEndAndBandBotLoc
  SchematicLineStart = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentStartLoc
  SchematicLineMid = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentMidLoc
  SchematicLineEnd = AeccAttributeId::kAttrIdLabelStyleBandAnchorSegmentEndLoc
  PreviousOffsetBandTop = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelPreviousOffsetBandTop
  PreviousOffsetBandMiddle = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelPreviousOffsetBandMiddle
  PreviousOffsetBandBottom = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelPreviousOffsetBandBottom
  NextOffsetBandTop = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelNextOffsetBandTop
  NextOffsetBandMiddle = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelNextOffsetBandMiddle
  NextOffsetBandBottom = AeccAttributeId::kAttrIdGraphStyleSectionBandDetailsSectionDataAtIncrementalDistanceLabelNextOffsetBandBottom
End Enum
Remarks

Use for all the label style components.


Autodesk::Civil::AngleFormatType Enumeration

Specifies angle format.

C#
public enum AngleFormatType {
  Decimal = AeccFormatInfo::kFD,
  DegreeMinuteSecond = AeccFormatInfo::kFDMSDec,
  MinuteSecond = AeccFormatInfo::kFDMSd,
  MinuteSecondSpaced = AeccFormatInfo::kFDMSdSp
}
Visual Basic
Public Enum AngleFormatType
  Decimal = AeccFormatInfo::kFD
  DegreeMinuteSecond = AeccFormatInfo::kFDMSDec
  MinuteSecond = AeccFormatInfo::kFDMSd
  MinuteSecondSpaced = AeccFormatInfo::kFDMSdSp
End Enum


Autodesk::Civil::AngleUnitType Enumeration

Specifies angle units.

C#
public enum AngleUnitType {
  Degree = AeccFormatInfo::Degrees,
  Radian = AeccFormatInfo::Radians,
  Grad = AeccFormatInfo::Grads
}
Visual Basic
Public Enum AngleUnitType
  Degree = AeccFormatInfo::Degrees
  Radian = AeccFormatInfo::Radians
  Grad = AeccFormatInfo::Grads
End Enum


Autodesk::Civil::AreaUnitType Enumeration

Specifies area units.

C#
public enum AreaUnitType {
  SquareMeter = AeccFormatInfo::square_meters,
  SquareFoot = AeccFormatInfo::square_foot,
  Acre = AeccFormatInfo::acre,
  Hectare = AeccFormatInfo::hectare,
  SquareKilometer = AeccFormatInfo::square_kilometer,
  SquareMile = AeccFormatInfo::square_mile_statute,
  SquareYard = AeccFormatInfo::square_yard
}
Visual Basic
Public Enum AreaUnitType
  SquareMeter = AeccFormatInfo::square_meters
  SquareFoot = AeccFormatInfo::square_foot
  Acre = AeccFormatInfo::acre
  Hectare = AeccFormatInfo::hectare
  SquareKilometer = AeccFormatInfo::square_kilometer
  SquareMile = AeccFormatInfo::square_mile_statute
  SquareYard = AeccFormatInfo::square_yard
End Enum


Autodesk::Civil::ArrowHeadFitType Enumeration

An enumeration that defines the arrow head fit type.

C#
public enum ArrowHeadFitType {
  Shrink = AeccDbAlignmentStyle::kShrink,
  Omit = AeccDbAlignmentStyle::kOmit,
  AlwaysDraw = AeccDbAlignmentStyle::kAlwaysDraw
}
Visual Basic
Public Enum ArrowHeadFitType
  Shrink = AeccDbAlignmentStyle::kShrink
  Omit = AeccDbAlignmentStyle::kOmit
  AlwaysDraw = AeccDbAlignmentStyle::kAlwaysDraw
End Enum


Autodesk::Civil::ArrowHeadSizeType Enumeration

An enumeration that defines the arrow head size type.

C#
public enum ArrowHeadSizeType {
  UseDrawScale = AeccDbAlignmentStyle::kUserDrawScale,
  UseFixedScale = AeccDbAlignmentStyle::kUserFixedScale,
  UseSizeInAbsUnits = AeccDbAlignmentStyle::kUserSizeInAbsUnits,
  UseSizeInRelUnits = AeccDbAlignmentStyle::kUserSizeInRelUnits
}
Visual Basic
Public Enum ArrowHeadSizeType
  UseDrawScale = AeccDbAlignmentStyle::kUserDrawScale
  UseFixedScale = AeccDbAlignmentStyle::kUserFixedScale
  UseSizeInAbsUnits = AeccDbAlignmentStyle::kUserSizeInAbsUnits
  UseSizeInRelUnits = AeccDbAlignmentStyle::kUserSizeInRelUnits
End Enum


Autodesk::Civil::ArrowHeadType Enumeration

An enumeration that defines the arrow head type.

C#
public enum ArrowHeadType {
  ClosedFilled = kArrowDefault,
  ClosedBlank = kArrowClosedBlank,
  Closed = kArrowClosed,
  Dot = kArrowDot,
  ArchTick = kArrowArchTick,
  Oblique = kArrowOblique,
  Open = kArrowOpen,
  Origin = kArrowOrigin,
  Origin2 = kArrowOrigin2,
  Open90 = kArrowOpen90,
  Open30 = kArrowOpen30,
  DotSmall = kArrowDotSmall,
  DotBlank = kArrowDotBlank,
  Small = kArrowSmall,
  BoxBlank = kArrowBoxBlank,
  BoxFilled = kArrowBoxFilled,
  DatumBlank = kArrowDatumBlank,
  DatumFilled = kArrowDatumFilled,
  Integral = kArrowIntegral,
  None = kArrowNone,
  UserDefined = kArrowUserDefined
}
Visual Basic
Public Enum ArrowHeadType
  ClosedFilled = kArrowDefault
  ClosedBlank = kArrowClosedBlank
  Closed = kArrowClosed
  Dot = kArrowDot
  ArchTick = kArrowArchTick
  Oblique = kArrowOblique
  Open = kArrowOpen
  Origin = kArrowOrigin
  Origin2 = kArrowOrigin2
  Open90 = kArrowOpen90
  Open30 = kArrowOpen30
  DotSmall = kArrowDotSmall
  DotBlank = kArrowDotBlank
  Small = kArrowSmall
  BoxBlank = kArrowBoxBlank
  BoxFilled = kArrowBoxFilled
  DatumBlank = kArrowDatumBlank
  DatumFilled = kArrowDatumFilled
  Integral = kArrowIntegral
  None = kArrowNone
  UserDefined = kArrowUserDefined
End Enum


Autodesk::Civil::BearingQuadrantType Enumeration

Specifies bearing quadrant type.

C#
public enum BearingQuadrantType {
  Northeast = AeccQuadrant::kNE,
  Southeast = AeccQuadrant::kSE,
  Southwest = AeccQuadrant::kSW,
  Northwest = AeccQuadrant::kNW
}
Visual Basic
Public Enum BearingQuadrantType
  Northeast = AeccQuadrant::kNE
  Southeast = AeccQuadrant::kSE
  Southwest = AeccQuadrant::kSW
  Northwest = AeccQuadrant::kNW
End Enum


Autodesk::Civil::BlockAttachmentType Enumeration

Specifies specifies how block label components are attached.

C#
public enum BlockAttachmentType {
  TopLeft = AeccDbLabelStyleBlock::kIPAttachmentTopLeft,
  TopCenter = AeccDbLabelStyleBlock::kIPAttachmentTopCenter,
  TopRight = AeccDbLabelStyleBlock::kIPAttachmentTopRight,
  MiddleLeft = AeccDbLabelStyleBlock::kIPAttachmentMiddleLeft,
  MiddleCenter = AeccDbLabelStyleBlock::kIPAttachmentMiddleCenter,
  MiddleRight = AeccDbLabelStyleBlock::kIPAttachmentMiddleRight,
  BottomLeft = AeccDbLabelStyleBlock::kIPAttachmentBottomLeft,
  BottomCenter = AeccDbLabelStyleBlock::kIPAttachmentBottomCenter,
  BottomRight = AeccDbLabelStyleBlock::kIPAttachmentBottomRight,
  InsertionPoint = AeccDbLabelStyleBlock::kIPAttachmentInsertionPoint
}
Visual Basic
Public Enum BlockAttachmentType
  TopLeft = AeccDbLabelStyleBlock::kIPAttachmentTopLeft
  TopCenter = AeccDbLabelStyleBlock::kIPAttachmentTopCenter
  TopRight = AeccDbLabelStyleBlock::kIPAttachmentTopRight
  MiddleLeft = AeccDbLabelStyleBlock::kIPAttachmentMiddleLeft
  MiddleCenter = AeccDbLabelStyleBlock::kIPAttachmentMiddleCenter
  MiddleRight = AeccDbLabelStyleBlock::kIPAttachmentMiddleRight
  BottomLeft = AeccDbLabelStyleBlock::kIPAttachmentBottomLeft
  BottomCenter = AeccDbLabelStyleBlock::kIPAttachmentBottomCenter
  BottomRight = AeccDbLabelStyleBlock::kIPAttachmentBottomRight
  InsertionPoint = AeccDbLabelStyleBlock::kIPAttachmentInsertionPoint
End Enum


Autodesk::Civil::CapitalizationType Enumeration

Specifies how direction value text is capitalized.

C#
public enum CapitalizationType {
  MeterPerSecSquared = AeccFormatInfo::meter_per_sec_squared,
  FootPerSecSquared = AeccFormatInfo::foot_per_sec_squared
}
Visual Basic
Public Enum CapitalizationType
  MeterPerSecSquared = AeccFormatInfo::meter_per_sec_squared
  FootPerSecSquared = AeccFormatInfo::foot_per_sec_squared
End Enum


Autodesk::Civil::CurbReturnType Enumeration

Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.

C#
public enum CurbReturnType {
  Chamfer = AeccAlignCurbReturnComponent::kChamfer,
  CircularFillet = AeccAlignCurbReturnComponent::kArc,
  ThreeCenteredArcs = AeccAlignCurbReturnComponent::kThreeCentered
}
Visual Basic
Public Enum CurbReturnType
  Chamfer = AeccAlignCurbReturnComponent::kChamfer
  CircularFillet = AeccAlignCurbReturnComponent::kArc
  ThreeCenteredArcs = AeccAlignCurbReturnComponent::kThreeCentered
End Enum


Autodesk::Civil::DecimalCharacterType Enumeration

Specifies decimal character type.

C#
public enum DecimalCharacterType {
  Period = AeccFormatInfo::kAP,
  Comma = AeccFormatInfo::kAC
}
Visual Basic
Public Enum DecimalCharacterType
  Period = AeccFormatInfo::kAP
  Comma = AeccFormatInfo::kAC
End Enum


Autodesk::Civil::DimensionAnchorOptionType Enumeration

An enumeration that specifies the behavior of the anchor dimension.

C#
public enum DimensionAnchorOptionType {
  Elevation = AeccDbLabeling::kDimAnchorElev,
  Above = AeccDbLabeling::kDimAnchorAbove,
  Below = AeccDbLabeling::kDimAnchorBelow,
  Default = AeccDbLabeling::kDimAnchorDefault,
  ViewTop = AeccDbLabeling::kDimAnchorViewTop,
  ViewBottom = AeccDbLabeling::kDimAnchorViewBottom
}
Visual Basic
Public Enum DimensionAnchorOptionType
  Elevation = AeccDbLabeling::kDimAnchorElev
  Above = AeccDbLabeling::kDimAnchorAbove
  Below = AeccDbLabeling::kDimAnchorBelow
  Default = AeccDbLabeling::kDimAnchorDefault
  ViewTop = AeccDbLabeling::kDimAnchorViewTop
  ViewBottom = AeccDbLabeling::kDimAnchorViewBottom
End Enum


Autodesk::Civil::DimensionAnchorType Enumeration

Defines the location of the anchor used to position dimension lines for certain profile view labels, such as vertical curve labels.

C#
public enum DimensionAnchorType {
  FixedElevation = AeccDbLabeling::kDimAnchorElev,
  DistanceAbove = AeccDbLabeling::kDimAnchorAbove,
  DistanceBelow = AeccDbLabeling::kDimAnchorBelow,
  GraphViewTop = AeccDbLabeling::kDimAnchorViewTop,
  GraphViewBottom = AeccDbLabeling::kDimAnchorViewBottom
}
Visual Basic
Public Enum DimensionAnchorType
  FixedElevation = AeccDbLabeling::kDimAnchorElev
  DistanceAbove = AeccDbLabeling::kDimAnchorAbove
  DistanceBelow = AeccDbLabeling::kDimAnchorBelow
  GraphViewTop = AeccDbLabeling::kDimAnchorViewTop
  GraphViewBottom = AeccDbLabeling::kDimAnchorViewBottom
End Enum


Autodesk::Civil::DirectionDisplayType Enumeration

Specifies display direction.

C#
public enum DirectionDisplayType {
  LongName = AeccFormatInfo::kDLn,
  ShortName = AeccFormatInfo::kDSn,
  LongNameSpaced = AeccFormatInfo::kDLns,
  ShortNameSpaced = AeccFormatInfo::kDSns
}
Visual Basic
Public Enum DirectionDisplayType
  LongName = AeccFormatInfo::kDLn
  ShortName = AeccFormatInfo::kDSn
  LongNameSpaced = AeccFormatInfo::kDLns
  ShortNameSpaced = AeccFormatInfo::kDSns
End Enum


Autodesk::Civil::DirectionNameDisplayType Enumeration

Specifies direction name display.

C#
public enum DirectionNameDisplayType {
  PreserveCase = AeccFormatInfo::kCP,
  UpperCase = AeccFormatInfo::kCU,
  LowerCase = AeccFormatInfo::kCL,
  TitleCaps = AeccFormatInfo::kCT
}
Visual Basic
Public Enum DirectionNameDisplayType
  PreserveCase = AeccFormatInfo::kCP
  UpperCase = AeccFormatInfo::kCU
  LowerCase = AeccFormatInfo::kCL
  TitleCaps = AeccFormatInfo::kCT
End Enum


Autodesk::Civil::DrivingDirectionType Enumeration

The Autodesk::Civil::DrivingDirectionType enumeration.

C#
public enum DrivingDirectionType {
  RightSideOfTheRoad = AeccDbRootSettingsNode::kRightSideOfTheRoad,
  LeftSideOfTheRoad = AeccDbRootSettingsNode::kLeftSideOfTheRoad
}
Visual Basic
Public Enum DrivingDirectionType
  RightSideOfTheRoad = AeccDbRootSettingsNode::kRightSideOfTheRoad
  LeftSideOfTheRoad = AeccDbRootSettingsNode::kLeftSideOfTheRoad
End Enum


Autodesk::Civil::DropDecimalWholeType Enumeration

Specifies decimal rounding.

C#
public enum DropDecimalWholeType {
  Yes = AeccFormatInfo::kEY,
  No = AeccFormatInfo::kEN
}
Visual Basic
Public Enum DropDecimalWholeType
  Yes = AeccFormatInfo::kEY
  No = AeccFormatInfo::kEN
End Enum


Autodesk::Civil::DropLeadingZeroType Enumeration

Specifies whether to drop leading zeros.

C#
public enum DropLeadingZeroType {
  Yes = AeccFormatInfo::kDZY,
  No = AeccFormatInfo::kDZN
}
Visual Basic
Public Enum DropLeadingZeroType
  Yes = AeccFormatInfo::kDZY
  No = AeccFormatInfo::kDZN
End Enum


Autodesk::Civil::FlowUnitType Enumeration

Specifies flow units.

C#
public enum FlowUnitType {
  CubicMeterPerSec = AeccFormatInfo::cubic_meter_per_sec,
  CubicFootPerSec = AeccFormatInfo::cubic_foot_per_sec
}
Visual Basic
Public Enum FlowUnitType
  CubicMeterPerSec = AeccFormatInfo::cubic_meter_per_sec
  CubicFootPerSec = AeccFormatInfo::cubic_foot_per_sec
End Enum


Autodesk::Civil::GradeFormatType Enumeration

Specifies grade format.

C#
public enum GradeFormatType {
  Percent = AeccFormatInfo::kFP,
  Decimal = AeccFormatInfo::kFD,
  PerMille = AeccFormatInfo::kFPMill
}
Visual Basic
Public Enum GradeFormatType
  Percent = AeccFormatInfo::kFP
  Decimal = AeccFormatInfo::kFD
  PerMille = AeccFormatInfo::kFPMill
End Enum


Autodesk::Civil::GradeSlopeFormatType Enumeration

Specifies grade slope format.

C#
public enum GradeSlopeFormatType {
  RiseRun = AeccFormatInfo::kFRise,
  RunRise = AeccFormatInfo::kFRun,
  Percent = AeccFormatInfo::kFP,
  Decimal = AeccFormatInfo::kFD,
  PerMille = AeccFormatInfo::kFPMill
}
Visual Basic
Public Enum GradeSlopeFormatType
  RiseRun = AeccFormatInfo::kFRise
  RunRise = AeccFormatInfo::kFRun
  Percent = AeccFormatInfo::kFP
  Decimal = AeccFormatInfo::kFD
  PerMille = AeccFormatInfo::kFPMill
End Enum


Autodesk::Civil::LabelContentDisplayType Enumeration

Defines label content display type after it is dragged from its default position.

C#
public enum LabelContentDisplayType {
  Composed = 0,
  StackedText
}
Visual Basic
Public Enum LabelContentDisplayType
  Composed = 0
  StackedText
End Enum


Autodesk::Civil::LabelingPromptType Enumeration

Specifies labeling prompt.

C#
public enum LabelingPromptType {
  Suppress = AeccDbRootSettingsNode::kLabelingPromptMethodSuppress,
  CommandLine = AeccDbRootSettingsNode::kLabelingPromptMethodCommandLine,
  Dialog = AeccDbRootSettingsNode::kLabelingPromptMethodPropertiesDlg
}
Visual Basic
Public Enum LabelingPromptType
  Suppress = AeccDbRootSettingsNode::kLabelingPromptMethodSuppress
  CommandLine = AeccDbRootSettingsNode::kLabelingPromptMethodCommandLine
  Dialog = AeccDbRootSettingsNode::kLabelingPromptMethodPropertiesDlg
End Enum


Autodesk::Civil::LabelInsertionType Enumeration

Specifies label insertion.

C#
public enum LabelInsertionType {
  None = AeccDbLabelStyle::kForcedInsertPointNone,
  Top = AeccDbLabelStyle::kForcedInsertPointTop,
  Bottom = AeccDbLabelStyle::kForcedInsertPointBottom
}
Visual Basic
Public Enum LabelInsertionType
  None = AeccDbLabelStyle::kForcedInsertPointNone
  Top = AeccDbLabelStyle::kForcedInsertPointTop
  Bottom = AeccDbLabelStyle::kForcedInsertPointBottom
End Enum


Autodesk::Civil::LabelInsideCurveType Enumeration

Defines labels place type, inside or outside a curve.

C#
public enum LabelInsideCurveType {
  None = AeccDbLabelStyle::kCurveSideNone,
  Inside = AeccDbLabelStyle::kCurveInside,
  Outside = AeccDbLabelStyle::kCurveOutside
}
Visual Basic
Public Enum LabelInsideCurveType
  None = AeccDbLabelStyle::kCurveSideNone
  Inside = AeccDbLabelStyle::kCurveInside
  Outside = AeccDbLabelStyle::kCurveOutside
End Enum


Autodesk::Civil::LabelMaskType Enumeration

Specifies label mask types.

C#
public enum LabelMaskType {
  FromLabelStyle = AeccDbLabeling::kMaskFromLabelStyle,
  ContourLineOnly = AeccDbLabeling::kMaskObjectOnly
}
Visual Basic
Public Enum LabelMaskType
  FromLabelStyle = AeccDbLabeling::kMaskFromLabelStyle
  ContourLineOnly = AeccDbLabeling::kMaskObjectOnly
End Enum


Autodesk::Civil::LabelTextAttachmentType Enumeration

Enumeration that label text attachment location.

C#
public enum LabelTextAttachmentType {
  TopLeft = AeccDbLabelStyleText::kIPAttachmentTopLeft,
  TopCenter = AeccDbLabelStyleText::kIPAttachmentTopCenter,
  TopRight = AeccDbLabelStyleText::kIPAttachmentTopRight,
  MiddleLeft = AeccDbLabelStyleText::kIPAttachmentMiddleLeft,
  MiddleCenter = AeccDbLabelStyleText::kIPAttachmentMiddleCenter,
  MiddleRight = AeccDbLabelStyleText::kIPAttachmentMiddleRight,
  BottomLeft = AeccDbLabelStyleText::kIPAttachmentBottomLeft,
  BottomCenter = AeccDbLabelStyleText::kIPAttachmentBottomCenter,
  BottomRight = AeccDbLabelStyleText::kIPAttachmentBottomRight
}
Visual Basic
Public Enum LabelTextAttachmentType
  TopLeft = AeccDbLabelStyleText::kIPAttachmentTopLeft
  TopCenter = AeccDbLabelStyleText::kIPAttachmentTopCenter
  TopRight = AeccDbLabelStyleText::kIPAttachmentTopRight
  MiddleLeft = AeccDbLabelStyleText::kIPAttachmentMiddleLeft
  MiddleCenter = AeccDbLabelStyleText::kIPAttachmentMiddleCenter
  MiddleRight = AeccDbLabelStyleText::kIPAttachmentMiddleRight
  BottomLeft = AeccDbLabelStyleText::kIPAttachmentBottomLeft
  BottomCenter = AeccDbLabelStyleText::kIPAttachmentBottomCenter
  BottomRight = AeccDbLabelStyleText::kIPAttachmentBottomRight
End Enum


Autodesk::Civil::LatLongDirectionType Enumeration

Specifies latitude / longitude direction.

C#
public enum LatLongDirectionType {
  LongName = AeccFormatInfo::kDLn,
  SuffixLongName = AeccFormatInfo::kDSLn,
  PrefixLongName = AeccFormatInfo::kDPLn,
  PrefixShortName = AeccFormatInfo::kDPSn,
  LongNameSpaced = AeccFormatInfo::kDLns,
  SuffixLongNameSpaced = AeccFormatInfo::kDSLns,
  PrefixLongNameSpaced = AeccFormatInfo::kDPLns,
  PrefixShortNameSpaced = AeccFormatInfo::kDPSns
}
Visual Basic
Public Enum LatLongDirectionType
  LongName = AeccFormatInfo::kDLn
  SuffixLongName = AeccFormatInfo::kDSLn
  PrefixLongName = AeccFormatInfo::kDPLn
  PrefixShortName = AeccFormatInfo::kDPSn
  LongNameSpaced = AeccFormatInfo::kDLns
  SuffixLongNameSpaced = AeccFormatInfo::kDSLns
  PrefixLongNameSpaced = AeccFormatInfo::kDPLns
  PrefixShortNameSpaced = AeccFormatInfo::kDPSns
End Enum


Autodesk::Civil::LayoutModeType Enumeration

Specifies layout mode.

C#
public enum LayoutModeType {
  Label = AeccDbLabelStyle::kDisplayInLabelMode,
  Tag = AeccDbLabelStyle::kDisplayInTagMode,
  LabelTag = AeccDbLabelStyle::kDisplayInAllModes
}
Visual Basic
Public Enum LayoutModeType
  Label = AeccDbLabelStyle::kDisplayInLabelMode
  Tag = AeccDbLabelStyle::kDisplayInTagMode
  LabelTag = AeccDbLabelStyle::kDisplayInAllModes
End Enum


Autodesk::Civil::LeaderAttachmentBehaviorType Enumeration

An enumeration that specifies the attachment behavior of the leader.

C#
public enum LeaderAttachmentBehaviorType {
  ToPoint = AeccDbLabeling::kLeaderToPoint,
  ToMarkerExtents = AeccDbLabeling::kLeaderToMarkerExtents
}
Visual Basic
Public Enum LeaderAttachmentBehaviorType
  ToPoint = AeccDbLabeling::kLeaderToPoint
  ToMarkerExtents = AeccDbLabeling::kLeaderToMarkerExtents
End Enum


Autodesk::Civil::LeaderAttachmentType Enumeration

Specifies leader attachment location.

C#
public enum LeaderAttachmentType {
  LeaderTopOfTopLine = AeccDbLabelStyle::kLeaderAttachTopTop,
  LeaderMiddleOfTopLine = AeccDbLabelStyle::kLeaderAttachMiddleTop,
  LeaderMiddle = AeccDbLabelStyle::kLeaderAttachMiddle,
  LeaderMiddleOfBottomLine = AeccDbLabelStyle::kLeaderAttachMiddleBottom,
  LeaderBottomOfBottomLine = AeccDbLabelStyle::kLeaderAttachBottomBottom
}
Visual Basic
Public Enum LeaderAttachmentType
  LeaderTopOfTopLine = AeccDbLabelStyle::kLeaderAttachTopTop
  LeaderMiddleOfTopLine = AeccDbLabelStyle::kLeaderAttachMiddleTop
  LeaderMiddle = AeccDbLabelStyle::kLeaderAttachMiddle
  LeaderMiddleOfBottomLine = AeccDbLabelStyle::kLeaderAttachMiddleBottom
  LeaderBottomOfBottomLine = AeccDbLabelStyle::kLeaderAttachBottomBottom
End Enum


Autodesk::Civil::LeaderShapeType Enumeration

Defines the leader shape type.

C#
public enum LeaderShapeType {
  Straight = 0,
  Spline
}
Visual Basic
Public Enum LeaderShapeType
  Straight = 0
  Spline
End Enum


Autodesk::Civil::LeaderTailVisibilityType Enumeration

An enumeration that specifies the behavior of the leader tail visibility.

C#
public enum LeaderTailVisibilityType {
  FromLabelStyle = AeccDbLabeling::kLeaderTailFromLabelStyle,
  AlwaysHide = AeccDbLabeling::kLeaderTailAlwaysHide
}
Visual Basic
Public Enum LeaderTailVisibilityType
  FromLabelStyle = AeccDbLabeling::kLeaderTailFromLabelStyle
  AlwaysHide = AeccDbLabeling::kLeaderTailAlwaysHide
End Enum


Autodesk::Civil::LeaderVisibilityType Enumeration

An enumeration that specifies the behavior of the leader visibility.

C#
public enum LeaderVisibilityType {
  FromLabelStyle = AeccDbLabeling::kLeaderFromLabelStyle,
  AlwaysHide = AeccDbLabeling::kLeaderAlwaysHide
}
Visual Basic
Public Enum LeaderVisibilityType
  FromLabelStyle = AeccDbLabeling::kLeaderFromLabelStyle
  AlwaysHide = AeccDbLabeling::kLeaderAlwaysHide
End Enum


Autodesk::Civil::LinearUnitType Enumeration

Specifies linear units.

C#
public enum LinearUnitType {
  Meter = AeccFormatInfo::meter,
  Kilometer = AeccFormatInfo::kilometer,
  Foot = AeccFormatInfo::foot,
  Inch = AeccFormatInfo::inch,
  Yard = AeccFormatInfo::yards,
  Mile = AeccFormatInfo::mile,
  Millimeter = AeccFormatInfo::millimeter,
  Centimeter = AeccFormatInfo::centimeter,
  Decimeter = AeccFormatInfo::decimeter
}
Visual Basic
Public Enum LinearUnitType
  Meter = AeccFormatInfo::meter
  Kilometer = AeccFormatInfo::kilometer
  Foot = AeccFormatInfo::foot
  Inch = AeccFormatInfo::inch
  Yard = AeccFormatInfo::yards
  Mile = AeccFormatInfo::mile
  Millimeter = AeccFormatInfo::millimeter
  Centimeter = AeccFormatInfo::centimeter
  Decimeter = AeccFormatInfo::decimeter
End Enum


Autodesk::Civil::MaskType Enumeration

An enumeration that specifies the behavior of a label's background mask.

C#
public enum MaskType {
  FromLabelStyle = AeccDbLabeling::kMaskFromLabelStyle,
  ObjectOnly = AeccDbLabeling::kMaskObjectOnly
}
Visual Basic
Public Enum MaskType
  FromLabelStyle = AeccDbLabeling::kMaskFromLabelStyle
  ObjectOnly = AeccDbLabeling::kMaskObjectOnly
End Enum


Autodesk::Civil::OrientationReferenceType Enumeration

Specifies orientation reference.

C#
public enum OrientationReferenceType {
  Object = AeccDbLabelStyle::kReferenceObject,
  View = AeccDbLabelStyle::kReferencePlan,
  WorldCoordinateSystem = AeccDbLabelStyle::kReferenceNorth
}
Visual Basic
Public Enum OrientationReferenceType
  Object = AeccDbLabelStyle::kReferenceObject
  View = AeccDbLabelStyle::kReferencePlan
  WorldCoordinateSystem = AeccDbLabelStyle::kReferenceNorth
End Enum


Autodesk::Civil::PlottedUnitDisplayType Enumeration

Specifies plotted units.

C#
public enum PlottedUnitDisplayType {
  Decimal = AeccString::kNumericFormatDecimal,
  Fractional = AeccString::kNumericFormatFractional
}
Visual Basic
Public Enum PlottedUnitDisplayType
  Decimal = AeccString::kNumericFormatDecimal
  Fractional = AeccString::kNumericFormatFractional
End Enum


Autodesk::Civil::ProfilePointType Enumeration

Defines types of points on a Profile.

C#
public enum ProfilePointType {
  TanCurve = AeccAlignStation::kStnVGPTanCurve,
  CurveTan = AeccAlignStation::kStnVGPCurveTan,
  CompCurve = AeccAlignStation::kStnVGPCurveCompCurve,
  RevCurve = AeccAlignStation::kStnVGPCurveRevCurve,
  LowPoint = AeccAlignStation::kStnVGPCurveLowPoint,
  HighPoint = AeccAlignStation::kStnVGPCurveHighPoint,
  PVI = AeccAlignStation::kStnVGPCurvePVI,
  Start = AeccAlignStation::kStnVGPBegOfAlign,
  End = AeccAlignStation::kStnVGPEndOfAlign,
  GradeBreak = AeccAlignStation::kStnVGPTanTan,
  OverallLowPoint = AeccAlignStation::kStnVGPOverallLowPoint,
  OverallHighPoint = AeccAlignStation::kStnVGPOverallHighPoint
}
Visual Basic
Public Enum ProfilePointType
  TanCurve = AeccAlignStation::kStnVGPTanCurve
  CurveTan = AeccAlignStation::kStnVGPCurveTan
  CompCurve = AeccAlignStation::kStnVGPCurveCompCurve
  RevCurve = AeccAlignStation::kStnVGPCurveRevCurve
  LowPoint = AeccAlignStation::kStnVGPCurveLowPoint
  HighPoint = AeccAlignStation::kStnVGPCurveHighPoint
  PVI = AeccAlignStation::kStnVGPCurvePVI
  Start = AeccAlignStation::kStnVGPBegOfAlign
  End = AeccAlignStation::kStnVGPEndOfAlign
  GradeBreak = AeccAlignStation::kStnVGPTanTan
  OverallLowPoint = AeccAlignStation::kStnVGPOverallLowPoint
  OverallHighPoint = AeccAlignStation::kStnVGPOverallHighPoint
End Enum


Autodesk::Civil::RotationDirType Enumeration

Specifies rotation direction.

C#
public enum RotationDirType {
  Clockwise = AeccAttributeTypeInfoEnumRotationDir::kClockwise,
  Counterclockwise = AeccAttributeTypeInfoEnumRotationDir::kCounterClockwise
}
Visual Basic
Public Enum RotationDirType
  Clockwise = AeccAttributeTypeInfoEnumRotationDir::kClockwise
  Counterclockwise = AeccAttributeTypeInfoEnumRotationDir::kCounterClockwise
End Enum


Autodesk::Civil::RoundingType Enumeration

Specifies rounding.

C#
public enum RoundingType {
  Normal = AeccFormatInfo::kRN,
  Up = AeccFormatInfo::kRU,
  Truncate = AeccFormatInfo::kRT
}
Visual Basic
Public Enum RoundingType
  Normal = AeccFormatInfo::kRN
  Up = AeccFormatInfo::kRU
  Truncate = AeccFormatInfo::kRT
End Enum


Autodesk::Civil::ROWCleanupType Enumeration

Specifies ROW cleanup.

C#
public enum ROWCleanupType {
  None = AeccUiCmdFeature::kTrim,
  Fillet = AeccUiCmdFeature::kFillet,
  Chamfer = AeccUiCmdFeature::kChamfer
}
Visual Basic
Public Enum ROWCleanupType
  None = AeccUiCmdFeature::kTrim
  Fillet = AeccUiCmdFeature::kFillet
  Chamfer = AeccUiCmdFeature::kChamfer
End Enum


Autodesk::Civil::SignType Enumeration

Specifies sign.

C#
public enum SignType {
  Negative = AeccFormatInfo::kSn,
  BracketNegative = AeccFormatInfo::kSBn,
  Always = AeccFormatInfo::kSa
}
Visual Basic
Public Enum SignType
  Negative = AeccFormatInfo::kSn
  BracketNegative = AeccFormatInfo::kSBn
  Always = AeccFormatInfo::kSa
End Enum


Autodesk::Civil::SlopeFormatType Enumeration

Specifies slope format.

C#
public enum SlopeFormatType {
  RiseRun = AeccFormatInfo::kFRise,
  RunRise = AeccFormatInfo::kFRun
}
Visual Basic
Public Enum SlopeFormatType
  RiseRun = AeccFormatInfo::kFRise
  RunRise = AeccFormatInfo::kFRun
End Enum


Autodesk::Civil::SpeedUnitType Enumeration

Specifies speed units.

C#
public enum SpeedUnitType {
  MeterPerSec = AeccFormatInfo::meter_per_sec,
  KilometerPerHour = AeccFormatInfo::kilometer_per_hour,
  FootPerSec = AeccFormatInfo::foot_per_sec,
  MilePerHour = AeccFormatInfo::mile_per_hour
}
Visual Basic
Public Enum SpeedUnitType
  MeterPerSec = AeccFormatInfo::meter_per_sec
  KilometerPerHour = AeccFormatInfo::kilometer_per_hour
  FootPerSec = AeccFormatInfo::foot_per_sec
  MilePerHour = AeccFormatInfo::mile_per_hour
End Enum


Autodesk::Civil::SpiralType Enumeration

An enumeration that defines the sprial types.

C#
public enum SpiralType {
  Clothoid = AeccGeSpiral::kClothoid,
  JapaneseCubic = AeccGeSpiral::kJapaneseCubic,
  SineHalfWave = AeccGeSpiral::kHalfWaveLenDimnTangent,
  Bloss = AeccGeSpiral::kBloss,
  CubicParabola = AeccGeSpiral::kCubicParabola,
  Sinusoidal = AeccGeSpiral::kSinusoidal,
  BiQuadratic = AeccGeSpiral::kBiQuadratic
}
Visual Basic
Public Enum SpiralType
  Clothoid = AeccGeSpiral::kClothoid
  JapaneseCubic = AeccGeSpiral::kJapaneseCubic
  SineHalfWave = AeccGeSpiral::kHalfWaveLenDimnTangent
  Bloss = AeccGeSpiral::kBloss
  CubicParabola = AeccGeSpiral::kCubicParabola
  Sinusoidal = AeccGeSpiral::kSinusoidal
  BiQuadratic = AeccGeSpiral::kBiQuadratic
End Enum


Autodesk::Civil::StationDelimiterCharacterType Enumeration

Specifies station delimeter character.

C#
public enum StationDelimiterCharacterType {
  PlusSign = AeccFormatInfo::kTP,
  MinusSign = AeccFormatInfo::kTM,
  Automatic = AeccFormatInfo::kTA,
  Underscore = AeccFormatInfo::kTU,
  None = AeccFormatInfo::kTN
}
Visual Basic
Public Enum StationDelimiterCharacterType
  PlusSign = AeccFormatInfo::kTP
  MinusSign = AeccFormatInfo::kTM
  Automatic = AeccFormatInfo::kTA
  Underscore = AeccFormatInfo::kTU
  None = AeccFormatInfo::kTN
End Enum


Autodesk::Civil::StationDelimiterPositionType Enumeration

Specifies station position.

C#
public enum StationDelimiterPositionType {
  Delimiter10 = AeccFormatInfo::kB1,
  Delimiter100 = AeccFormatInfo::kB2,
  Delimiter1000 = AeccFormatInfo::kB3,
  Delimiter10000 = AeccFormatInfo::kB4,
  Delimiter100000 = AeccFormatInfo::kB5
}
Visual Basic
Public Enum StationDelimiterPositionType
  Delimiter10 = AeccFormatInfo::kB1
  Delimiter100 = AeccFormatInfo::kB2
  Delimiter1000 = AeccFormatInfo::kB3
  Delimiter10000 = AeccFormatInfo::kB4
  Delimiter100000 = AeccFormatInfo::kB5
End Enum


Autodesk::Civil::StationFormatType Enumeration

Specifies station format.

C#
public enum StationFormatType {
  StationIndexFormat = AeccFormatInfo::kFSI,
  StationFormat = AeccFormatInfo::kFS,
  StationFormatDecimal = AeccFormatInfo::kFD
}
Visual Basic
Public Enum StationFormatType
  StationIndexFormat = AeccFormatInfo::kFSI
  StationFormat = AeccFormatInfo::kFS
  StationFormatDecimal = AeccFormatInfo::kFD
End Enum


Autodesk::Civil::StructureColumnComponentType Enumeration

An enumeration that specifies the structure table cell component type.

C#
public enum StructureColumnComponentType {
  Default,
  PipeAll,
  PipeIn,
  PipeOut
}
Visual Basic
Public Enum StructureColumnComponentType
  Default
  PipeAll
  PipeIn
  PipeOut
End Enum


Autodesk::Civil::StyleConflictResolverType Enumeration

Specifies how to resolve conflicts (the same name for an existing style and a new imported style) when exporting styles to another drawing using StyleBase::ExportTo().

C#
public enum StyleConflictResolverType {
  Ignore = AeccStyleImportConflictResolver::ignore,
  Rename = AeccStyleImportConflictResolver::rename,
  Override = AeccStyleImportConflictResolver::stomp,
  CancelRemaining = AeccStyleImportConflictResolver::cancelRemaining
}
Visual Basic
Public Enum StyleConflictResolverType
  Ignore = AeccStyleImportConflictResolver::ignore
  Rename = AeccStyleImportConflictResolver::rename
  Override = AeccStyleImportConflictResolver::stomp
  CancelRemaining = AeccStyleImportConflictResolver::cancelRemaining
End Enum


Autodesk::Civil::SuperelevationPointType Enumeration

Defines the superelevation critical points type that need to be labeled.

C#
public enum SuperelevationPointType {
  BeginOfAlignment = AeccSuperElevationDataElement::kBeginAlignment,
  BeginNormalCrown = AeccSuperElevationDataElement::kBeginNormalCrown,
  BeginNormalShoulder = AeccSuperElevationDataElement::kBeginNormalShoulder,
  BeginFullSuper = AeccSuperElevationDataElement::kBeginFullSuper,
  EndFullSuper = AeccSuperElevationDataElement::kEndFullSuper,
  EndNormalShoulder = AeccSuperElevationDataElement::kEndNormalShoulder,
  EndNormalCrown = AeccSuperElevationDataElement::kEndNormalCrown,
  EndOfAlignment = AeccSuperElevationDataElement::kEndAlignment,
  LevelCrown = AeccSuperElevationDataElement::kLevelCrown,
  LowShoulderMatch = AeccSuperElevationDataElement::kLowShoulderMatch,
  ReverseCrown = AeccSuperElevationDataElement::kReverseCrown,
  Manual = AeccSuperElevationDataElement::kManual,
  ShoulderBreakOver = AeccSuperElevationDataElement::kShoulderBreakOver
}
Visual Basic
Public Enum SuperelevationPointType
  BeginOfAlignment = AeccSuperElevationDataElement::kBeginAlignment
  BeginNormalCrown = AeccSuperElevationDataElement::kBeginNormalCrown
  BeginNormalShoulder = AeccSuperElevationDataElement::kBeginNormalShoulder
  BeginFullSuper = AeccSuperElevationDataElement::kBeginFullSuper
  EndFullSuper = AeccSuperElevationDataElement::kEndFullSuper
  EndNormalShoulder = AeccSuperElevationDataElement::kEndNormalShoulder
  EndNormalCrown = AeccSuperElevationDataElement::kEndNormalCrown
  EndOfAlignment = AeccSuperElevationDataElement::kEndAlignment
  LevelCrown = AeccSuperElevationDataElement::kLevelCrown
  LowShoulderMatch = AeccSuperElevationDataElement::kLowShoulderMatch
  ReverseCrown = AeccSuperElevationDataElement::kReverseCrown
  Manual = AeccSuperElevationDataElement::kManual
  ShoulderBreakOver = AeccSuperElevationDataElement::kShoulderBreakOver
End Enum


Autodesk::Civil::TableSegmentDataType Enumeration

Defines the type of content in a table column.

C#
public enum TableSegmentDataType {
  Line = AeccTableSegmentData::kLine,
  Curve = AeccTableSegmentData::kCurve,
  Spiral = AeccTableSegmentData::kSpiral
}
Visual Basic
Public Enum TableSegmentDataType
  Line = AeccTableSegmentData::kLine
  Curve = AeccTableSegmentData::kCurve
  Spiral = AeccTableSegmentData::kSpiral
End Enum


Autodesk::Civil::TableTitleDirectionType Enumeration

An enumeration that defines the table title directions.

C#
public enum TableTitleDirectionType {
  Across = AeccDbScheduleTable::kAcross,
  Down = AeccDbScheduleTable::kDown
}
Visual Basic
Public Enum TableTitleDirectionType
  Across = AeccDbScheduleTable::kAcross
  Down = AeccDbScheduleTable::kDown
End Enum


Autodesk::Civil::TextBorderType Enumeration

Specifies text border types.

C#
public enum TextBorderType {
  Rectangular = AeccDbLabelStyle::kBorderRectangular,
  RoundedRectangular = AeccDbLabelStyle::kBorderRoundedRectangular,
  Circular = AeccDbLabelStyle::kBorderCircular
}
Visual Basic
Public Enum TextBorderType
  Rectangular = AeccDbLabelStyle::kBorderRectangular
  RoundedRectangular = AeccDbLabelStyle::kBorderRoundedRectangular
  Circular = AeccDbLabelStyle::kBorderCircular
End Enum


Autodesk::Civil::TextJustificationType Enumeration

Specifies text justification.

C#
public enum TextJustificationType {
  Left = AeccDbLabelStyleText::kJustificationLeft,
  Center = AeccDbLabelStyleText::kJustificationCenter,
  Right = AeccDbLabelStyleText::kJustificationRight
}
Visual Basic
Public Enum TextJustificationType
  Left = AeccDbLabelStyleText::kJustificationLeft
  Center = AeccDbLabelStyleText::kJustificationCenter
  Right = AeccDbLabelStyleText::kJustificationRight
End Enum


Autodesk::Civil::TransitionInputType Enumeration

Specify the type of linear transition used for the widening: By Length or By Taper Ratio.

C#
public enum TransitionInputType {
  ByLength = AeccAlignOffsetTransition::kByLength,
  ByTaperRatio = AeccAlignOffsetTransition::kByTaperRatio
}
Visual Basic
Public Enum TransitionInputType
  ByLength = AeccAlignOffsetTransition::kByLength
  ByTaperRatio = AeccAlignOffsetTransition::kByTaperRatio
End Enum


Autodesk::Civil::TransitionType Enumeration

Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.

C#
public enum TransitionType {
  Linear = AeccAlignOffsetTransition::kLinear,
  CurveLineCurve = AeccAlignOffsetTransition::kCTC,
  CurveCurveReverseCurve = AeccAlignOffsetTransition::kCCRevC,
  CurveReverseCurve = AeccAlignOffsetTransition::kCRevC
}
Visual Basic
Public Enum TransitionType
  Linear = AeccAlignOffsetTransition::kLinear
  CurveLineCurve = AeccAlignOffsetTransition::kCTC
  CurveCurveReverseCurve = AeccAlignOffsetTransition::kCCRevC
  CurveReverseCurve = AeccAlignOffsetTransition::kCRevC
End Enum


Autodesk::Civil::VectorMeasurementType Enumeration

Specifies vector measurment.

C#
public enum VectorMeasurementType {
  Bearings = AeccFormatInfo::kMB,
  NorthAzimuth = AeccFormatInfo::kMN,
  SouthAzimuth = AeccFormatInfo::kMS
}
Visual Basic
Public Enum VectorMeasurementType
  Bearings = AeccFormatInfo::kMB
  NorthAzimuth = AeccFormatInfo::kMN
  SouthAzimuth = AeccFormatInfo::kMS
End Enum


Autodesk::Civil::VolumeUnitType Enumeration

Specifies volume units.

C#
public enum VolumeUnitType {
  CubicMeter = AeccFormatInfo::cubic_meter,
  CubicFoot = AeccFormatInfo::cubic_foot,
  CubicYard = AeccFormatInfo::cubic_yard
}
Visual Basic
Public Enum VolumeUnitType
  CubicMeter = AeccFormatInfo::cubic_meter
  CubicFoot = AeccFormatInfo::cubic_foot
  CubicYard = AeccFormatInfo::cubic_yard
End Enum


Classes
Classes
Classes
Class | Description
Constant | Constants used by the Civil API.
DesignCheck | The abstract design check class.
PropertyAnchorPoint | Property template for label anchor location.
PropertyAngle | Angle property template.
PropertyBlock | Encapsulates a Block name.
PropertyBoolean | Encapsulates a boolean value.
PropertyObjectName | Object name property template.


Classes

Legend
Legend
Class


Classes Templates
Classes
Templates
Template | Description
DesignCheckCollection | The DesignCheckCollection class.
PropertyEnum | Property template for enumerations.


Templates

Legend
Legend
Template


Classes
Classes
Classes
Class | Description
CivilApplication | The CivilApplication class. This is the base class used to access CivilDocument.
CivilDocument | The CivilDocument class. This is the root object for accessing settings, styles, and C3D entities, Alignment etc.


Classes
Classes
Classes
Class | Description
AnchorInfo | This is class Autodesk::Civil::DatabaseServices::AnchorInfo.
AutoFeatureLabelGroup | The base class for all label group objects that automatically label a range on a feature.
DBObject | The base class for database entities.
Entity | The base class for entities, such as Feature, Table, Grading, Site, etc.
Feature | Base class for Alignment, FeatureLine, ParcelSegment, and Profile.
FeatureLabel | A base class for feature label classes, such as AlignmentCurveLabel.
GeoEntity | The base class for geometry db entities.
Graph | The base class for graphic entities.
GraphOverride | The base class for graphic override.
Label | The base class for all single-entity label objects.
LabelBase | The base class for all label classes, including single-feature labels (FeatureLabel derived classes) and group labels (LabelGroup derived... more
LabelGroup | The base class for all label group objects, such as AutoFeatureLabelGroup.
LabelGroupSubEntity | A class that represents individual labels in a label group.
LegendTable | A table that displays colors and range values for a surface analysis.
Table | Base class for table objects, such as LegendTable and AlignmentTable.


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes
Classes
Classes
Classes
Class | Description
AxisStyle | Controls the use of tick marks on the horizontal and vertical axes of the profile view or cross section view.... more
AxisTickStyle | Controls the title location and display on the horizontal and vertical axes of the profile view or cross section view.... more
AxisTitleStyle | The AxisTitleStyle class, which defines the text, text style, size etc. of an axis title.
BandSetItem | Encapsulates a single profile view data band style.
BandSetItemCollection | A collection of BandStyle objects.
BandStyle | Specifies style properties for data bands, the graphic frames that are associated with a profile view object or section view... more
BandStyleCollection | A collection of BandStyle objects.
BandStylesRoot | The root object that contains collections of the various band styles in a document.
BandTickStyle | Specifies the type and location of ticks for profile or section view data bands.
BaseLabelSetItem | The base class for alignment label set items.
BaseLabelSetStyle | The base class for alignment label set styles.
ColumnStyle | Defines column width and value properties for table style objects.
ColumnStyleCollection | A collection of ColumnStyle objects.
Expression | Encapsulates an expression used in label styles.
ExpressionCollection | A collection of Expression objects.
FeatureLineStyle | Specifies default display and other characteristics for feature line features when they are created.
FeatureLineStyleCollection | A collection of FeatureLineStyle objects.
GraphStyle | Specifies format and contents of the title, vertical exaggeration, and grid options for graphs.
GraphTitleStyle | Specifies display characteristics for profile and section view graphs.
GridOptions | Specifies various grid options used by GridStyle.
GridStyle | Specifies display characteristics for profile and section view graph gridlines.
LabelSetStylesRoot | The root object for accessing label set style collections in the database.
LabelStyle | The master label style class, containing feature-specific label styles and associated information such as derived styles.
LabelStyleBase | Base class for label style defaults.
LabelStyleBase::BaseBehavior | The behavior related properties of the default label style.
LabelStyleBase::BaseDraggedStateComponents | The dragged state components related properties of the default label style.
LabelStyleBase::BaseLabel | The label related properties of the default label style.
LabelStyleBase::BaseLeader | The leader related properties of the default label style.
LabelStyleBase::BasePlanReadability | The plan readability related properties of the default label style.
LabelStyleBlockComponent::StyleBlock | Block style settings for label block components.
LabelStyleBlockComponent::StyleGeneral | General style settings for label block components.
LabelStyleCollection | A collection of LabelStyle objects.
LabelStyleDefault::DefaultBehavior | The behavior related properties of the default label style settings.
LabelStyleDefault::DefaultComponents | The component related properties of the default label style settings.
LabelStyleDefault::DefaultDraggedStateComponents | The dragged state components related properties of the default label style settings.
LabelStyleDefault::DefaultLabel | The label related properties of the default label style settings.
LabelStyleDefault::DefaultLeader | The leader related properties of the default label style settings.
LabelStyleDefault::DefaultPlanReadability | The plan readability related properties of the default label style settings.
LabelStyleDirectionArrowComponent::StyleDirectionArrow | Direction arrow style settings for label direction arrow components.
LabelStyleDirectionArrowComponent::StyleGeneral | General style settings for label direction arrow components.
LabelStyleLineComponent::StyleGeneral | General style settings for line labels.
LabelStyleLineComponent::StyleLine | Line style settings for line labels.
LabelStylesNode | Base class for root label style classes, such as LabelStylesAlignmentRoot.
LabelStylesRoot | Root object for accessing all label styles in a CivilDocument.
LabelStyleTextComponent | Specifies the appearance and behavior of text feature labels in the drawing. Controls the appearance of the text itself.
LabelStyleTextComponent::StyleBorder | Border style settings for label text components.
LabelStyleTextComponent::StyleGeneral | General style settings for label text components.
LabelStyleTextComponent::StyleText | Text style settings for label text components.
LabelStyleTickComponent::StyleGeneral | General style settings for label tick components.
LabelStyleTickComponent::StyleTick | Tick style settings for label tick components.
MarkerStyle | Sets the style of a marker. Markers are used to mark locations along Alignment objects or survey figures (SurveyFigure... more
MarkerStyleBase | The base class for marker and point styles.
MarkerStyleCollection | A collection of MarkerStyle objects.
ProjectionProfileOptions | Contains display options and styles for objects projected from a plan view onto a profile view.
ProjectionSectionOptions | Contains display options and styles for objects projected from a plan view onto a section view. Used by ProjectionStyle.... more
ProjectionStyle | Contains display options and styles for objects projected from a plan view onto a section or profile view.
ProjectionStyleCollection | A collection of ProjectionStyle objects.
SegmentColumnStyle | Specifies the advance column style obtained from the Parcel Segment table style or Alignment Segment table style.
StructureColumnComponentData | Specifies the tabel cell component data information.
StructureColumnComponents |
StructureColumnStyle | Specifies the advance column style obtained from the Structure table style.
StyleBase | The base class for all style objects.
StyleCollectionBase | The base class for all style collections.
StylesRoot | The root class for accessing collections of all Civil 3D styles.
TableStyle | Controls the display of tables.
TableStyleCollection | A collection of TableStyle objects.
TableStylesRoot | The root object of all Civil 3D table-related styles.


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes
Legend
Legend
Class


Classes
Classes
Classes
Class | Description
AlignmentDesignCheck | The Alignment design check class.
AlignmentDesignCheckCollection | The AlignmentDesignCheckCollection class.
AlignmentDesignCheckRoot | The AlignmentDesignCheckRoot class.
ProfileDesignCheck | The Profile design check class.
ProfileDesignCheckCollection | The ProfileDesignCheckCollection class.
ProfileDesignCheckRoot | The ProfileDesignCheckRoot class.


Classes Templates
Classes
Templates
Template | Description
GeometryPointLabelOption | This class controls the selection state of a point type. The class is implemented as a generic that can be... more
GeometryPointSelector | This class encapsulates the functionality to allow selecting and un-selecting point types.


Classes
Classes
Classes
Class | Description
Alignment | The Alignment class. Alignment objects can represent centerlines, lanes, shoulders, right-of-ways, or construction baselines.
AlignmentArc | The AlignmentArc class. AlignmentArc derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single AlignmentSubEntityArc... more
AlignmentCurve | The AlignmentCurve class. This is an abstract base class for other Alignment Entity classes, such as AlignmentArc, AlignmentSCS,... more
AlignmentCurveLabel | This class represents an alignment curve label.
AlignmentDesignSpeedLabelGroup | This class represents an alignment design speed label group.
AlignmentEntity | The AlignmentEntity class. This is an abstract class from which AlignmentCurve inherits.
AlignmentEntityCollection | The AlignmentEntity collection class. This class represents the collection of all AlignmentEntity objects that belong to an Alignment.
AlignmentGeometryPointLabelGroup | This class encapsulates the functionality to label a geometry point group in an alignment.
AlignmentLabelGroup | This class represents an alignment label group.
AlignmentLine | The AlignmentLine class. This class represents an AlignmentEntity made up of a single line subentity.
AlignmentMinorStationLabelGroup | This class represents an alignment minor station label group.
AlignmentPILabel | This class represents an alignment tangent intersection label.
AlignmentPILabelGroup |
AlignmentRegion | Represents a segment of an alignment which uses a single assembly.
AlignmentRegionCollection | A collection of AlignmentRegion objects.
AlignmentSCS | The Alignment SpiralCurveSpiral class. This class represents an AlignmentEntity made up of an in spiral subentity, an arc subentity, and... more
AlignmentSCSCS | The Alignment SpiralCurveSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an... more
AlignmentSCSSCS | The Alignment SpiralCurveSpiralSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an... more
AlignmentSpiral | The AlignmentSpiral Class. AlignmentSpiral derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single spiral... more
AlignmentSpiralLabel | This class represents an alignment spiral label.
AlignmentSSCSS | The Alignment SpiralSpiralCurveSpiralSpiral class. This class represents an AlignmentEntity made up of the following subentities: spiral, spiral, arc, spiral, spiral.... more
AlignmentStationEquationLabelGroup | This class represents an alignment station equation label group.
AlignmentStationLabelGroup | This class represents an alignment station label group.
AlignmentSTS | The Alignment SpiralTangentSpiral class. This class represents an AlignmentEntity made up of a spiral, then tangent, then spiral subentities.
AlignmentSubEntity | The alignment subentity class. This class represents the basic drawing components that make up an alignment entity.
AlignmentSubEntityArc | The Alignment arc subentity class.
AlignmentSubEntityLine | The AlignmentSubEntityLine class. This class represents the line object in AlignmentEntity objects.
AlignmentSubEntitySpiral | The Alignment spiral subentity class. This class represents spiral object in AlignmentEntity objects.
AlignmentSuperelevationLabelGroup | This class encapsulates the functionality of an alignment super-elevation group label.
AlignmentTable | The AlignmentTable class.
AlignmentTangentLabel | This class represents an alignment tangent label.
AlignmentVerticalGeometryPointLabelGroup | This class represents an alignment vertical geometry point label group.
DesignSpeed | The Alignment DesignSpeed class. Specifies a single design speed used for criteria-based Alignment design.
DesignSpeedCollection | A collection of DesignSpeed objects.
FeatureLine | A feature line is a connected series of points along a corridor created by joining those points from each assembly... more
Grading | The Grading class.
GridSurface | A surface formed from points that lie on a regular grid.
MassHaulLine | A line that displays free haul and overhaul volumes in a mass haul view..
MassHaulView | A mass haul diagram view.
MatchLine | A match line is a straight line that indicate locations in a view frame group where one view frame intersects... more
MaterialSection | The AeccDbMaterialSection wrapper.
Parcel | An object that represents real estate parcels, such as lots in a subdivision, and other features that have closed boundaries... more
ParcelSegment | A parcel segment is a line segment, arc, or AutoCAD entity within a site. When parcel segments form a closed... more
ParcelSegmentTable | A Table associated with a ParcelSegment.
ParcelTable | A table associated with a Parcel.
PointEntity | Encapsulates a COGO point object, with associated information such as elevation, marker display styles, etc.
PointTable | The AeccDbPointScheduleTable wrapper.
PolylineOptions | The PolylineOptions class. This class specifies the options for creating an Alignment using a polyline.
Profile | A record of elevation against distance along a horizontal Alignment or other line. Profiles are used to visualize the terrain... more
ProfileBandLabelGroup | The AeccDbProfileBandLabeling wrapper.
ProfileCircular | The ProfileCircular class. This class represents an ProfileEntity made up of a circular curve.
ProfileCriteria | Critera used by the criteria-based design feature to apply agency-specific standards to a profile.
ProfileCriteriaCollection | The ProfileCriteria collection class represents the collection of all criteria in the hatch area.
ProfileEntity | The abstract class of profile entity. ProfileEntity has four derived classes: ProfileLine, ProfileAsymmetric, ProfileCircular, and ProfileParabolic.
ProfileEntityCollection | The ProfileEntity collection class. This class represents the collection of all ProfileEntity objects that belong to the Profile.
ProfileHatchArea | The ProfilevHatchArea class.
ProfileHatchAreaCollection | The ProfileHatchAreaCollection class represents the collection of all hatch areas in the ProfileView.
ProfileOverride | Object used to change the style or label set for a profile.
ProfileOverrideCollection | The ProfileOverride collection class represents the collection of all profiles listed in the ProfileView.
ProfileParabolaAsymmetric | The ProfileParabolaAsymmetric class. This class represents an ProfileEntity made up of a asymmetric parabola.
ProfileParabolaSymmetric | This class represents an ProfileEntity made up of a symmetric parabola.
ProfileProjection | The AeccDbProfileProjection class.
ProfilePVI | In a profile, the point where the lines formed by two tangent entities meet, whether the entities meet or not... more
ProfilePVICollection | The ProfilePVI collection class represents the collection of all ProfilePVI objects that belong to an Profile.
ProfileTangent | This class represents an ProfileEntity made up of a single tangent.
ProfileView | Manages the graphic display of profile data objects within a drawing. A ProfileView is used to display one or more... more
ProfileViewSplitData | This class represents a split location.
ProfileViewSplitDataCollection | The class provides a collection for the profile view split data.
SampleLine | Lines used for obtaining elevational information from an existing terrain model or surface for creating profiles and cross sections.
SampleLineGroup | Controls a set of related sample lines, the surfaces they sample, and methods for creating cross sections.
SCSCSConstraints | The SCSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Curve-Spiral (AlignmentSCSCS) compound Alignment entities.
SCSSCSConstraints | The SCSSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Spiral-Curve-Spiral (AlignmentSCSSCS) compound Alignment entities.
Section | Provides views created at a 90 degree angle to a surface or an alignment.
SectionBandLabelGroup | A group of section band labels.
SectionProjection | AutoCAD or AutoCAD Civil 3D objects projected from plan view into a section view.
SectionView | Used to display cross sectional data for both existing and finished ground along a sampled cross section line at any... more
Sheet | A sheet (construction document) object.
Site | The construction site abstraction containing parcels and alignments. Note: Alignments are generally associated with a site. An alignment interacts with... more
Station | The Alignment Station class.
StationEquation | Represents a particular system of renumbering or reordering stations within a portion of an alignment.
StationEquationCollection | A collection of StationEquation objects.
StationOffsetLabel | This class represents a station offset label.
SuperElevationData | The SuperelevationData class. This class is a collection of SuperelevationDataElement objects for an Alignment.
SuperElevationDataElement | Superelevation data element at a particular station.
Surface | The base class for TIN and grid surfaces. A surface is a three-dimensional geometric representation of the surface (TIN or... more
TinSurface | A Triangular Irregular Network (TIN) surface, from points connected together in triangles, and used to interpolate for contours, and to... more
ViewFrame | View frames are rectangular-shaped regions along an alignment that define an area that will be displayed in a sheet.
ViewFrameGroup | Manages a single group of view frames that are displaying consecutive station ranges along the same alignment.


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes
Classes
Classes
Classes
Class | Description
AlignmentDesignCheckSet | A collection of alignment design checks, which can be applied to an alignment.
AlignmentDesignCheckSetCollection | The AlignmentDesignCheckSetCollection class.
AlignmentStyle | Specifies properties for the various alignment components.
AlignmentStyleCollection | A collection of AlignmentStyle objects.
ArrowHeadOption | Display options for arrows in AlignmentStyle and ProfileStyle.
BuildingSiteStyle | Display options for building site objects.
BuildingSiteStyleCollection | A collection of BuildingSiteStyle objects.
ContourValues | Defines how to display major and minor contour lines; used by the SurfaceContourStyle class.
GradingCriteria | Specifies grading criteria (a projection method and target) to create a finished grading surface.
GradingCriteriaCollection | A collection of GradingCriteria objects.
GradingCriteriaSet | A set of multiple related GradingCriteria objects.
GradingCriteriaSetCollection | A collection of GradingCriteriaSet objects.
GradingStyle | Specifies default display and other characteristics for grading features when they are created.
GradingStyleCollection | A collection of GradingStyle objects.
GroupPlotStyle | Specifies section view group plot style settings.
GroupPlotStyleCollection | A collection of GroupPlotStyle objects.
HorizontalGeometryBandStyle | The style object specifying characteristics for profile view horizontal geometry data bands.
LabelStylesAlignmentRoot | All Alignment-related label styles. These styles control the label display for alignment components, such as major and minor stations,... more
LabelStylesMatchLineRoot | All styles associated with match line labels.
LabelStylesProfileRoot | LabelStylesProfileRoot
MassHaulLineStyle | The view frame style wrapper class.
MassHaulLineStyleCollection | The MassHaulLineStyleCollection class.
MassHaulViewStyle | The view frame style wrapper class.
MassHaulViewStyleCollection | The MassHaulViewStyleCollection class.
MatchLineStyle | The match line style wrapper class.
ParcelStyle | The parcel style wrapper class.
PointStyle | The point style class.
ProfileDataBandStyle | The profile data band style wrapper class.
ProfileDesignCheckSet | A collection of profile design checks, which can be applied to an alignment.
ProfileDesignCheckSetCollection | The AlignmentStyleCollection class.
ProfileLabelSetStyle | The profile lable set wrapper class.
ProfileStyle | The profile style wrapper class.
ProfileViewBandSetItem | The profile view band set item wrapper class.
ProfileViewBandSetStyle | A collection of ProfileViewBandSetItemCollection objects for profile view band set styles.
ProfileViewStyle | The profile view style wrapper class.
ProfileViewStyleCollection | The ProfileViewStyleCollection class.
SampleLineStyle | Specifies display properties for the sample lines used to obtain elevational information from an existing terrain model or surface.
SectionalDataBandStyle | The section data band style wrapper class.
SectionDataBandStyle | The section data band style wrapper class.
SectionSegmentBandStyle | The section data band style wrapper class.
SectionStyle | Specifies display characteristics and associated information for cross sections and their constituent components.
SectionViewBandSetItem | Encapsulates a single section view data band.
SectionViewBandSetItemCollection | The SectionViewBandSetItemCollectione wrapper class.
SectionViewBandSetStyle | The SectionViewBandSetStyle wrapper class.
SectionViewStyle | The section view style wrapper class.
SheetStyle | The sheet plot style applied when plot by page is selected.
SlopePatternComponent | Encapsulates the properties of slope pattern components used to make up a SlopePatternStyle.
SlopePatternLine | Defines a line used in a SlopePatternComponent.
SlopePatternLineOffset | Defines the offset of lines in a SlopePatternComponent.
SlopePatternLineSymbol | Defines the symbol used with a SlopePatternComponent.
SlopePatternStyle | A style that defines the pattern that represents a slope in a grading style.
SlopePatternStyleCollection | The SlopePatternStyleCollection class.
SuperelevationDataBandStyle | The super elevation data band style wrapper class.
SurfaceBaseStyle | The surface base style class
SurfaceContourStyle | The surface boundary style class
SurfaceDirectionStyle | The surface boundary style class
SurfaceElevationStyle | The surface boundary style class
SurfacePointStyle | The SurfacePointStyle class.
SurfaceSlopeArrowStyle | The SurfaceSlopeArrowStyle class.
SurfaceSlopeStyle | The SurfaceSlopeStyle class.
SurfaceStyle | The surface style class.
VerticalGeometryBandStyle | The vertical geometry band style wrapper class.
ViewFrameStyle | The view frame style wrapper class.


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes
Legend
Legend
Class


Classes
Classes
Classes
Class | Description
SettingsAbbreviationAlignment | Abbreviations Settings for Alignment Geometry Point Entity Data
SettingsAbbreviationAlignmentEnhanced | Abbreviations Settings for Alignment Geometry Point Text
SettingsAbbreviationProfile | Abbreviations Settings for Profile
SettingsAbbreviationSuperelevation | Abbreviations Settings for Superelevation
SettingsAlignment | Settings for Alignment.
SettingsAlignment::SettingsCriteriaBasedDesignOptions | Default settings for creating an alignment using design criteria.
SettingsAlignment::SettingsData | Default settings for creating an alignment using data.
SettingsAlignment::SettingsDefaultNameFormat | Settings for Alignment Default Name Format.
SettingsAlignment::SettingsDynamicAlignmentHighlight | Default settings for dynamic alignment hightlight options.
SettingsAlignment::SettingsStationIndexing | Settings for Alignment Station Indexing.
SettingsAlignment::SettingsStyles | Settings for Alignment default styles.
SettingsAlignment::SettingsSuperelevationOptions | Default settings for calculating superelevation specifications.
SettingsBuildingSite | Settings for ViewFrameGroup.
SettingsBuildingSite::SettingsNameFormat | Default name format for new building sites.
SettingsBuildingSite::SettingsStyles | Default styles for new building sites.
SettingsCmdAddAlignmentCurveTable | Settings for AddAlignmentCurveTable command.
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentCurveTable.
SettingsCmdAddAlignmentLineTable | Settings for AddAlignmentLineTable command.
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentLineTable.
SettingsCmdAddAlignmentOffLbl | Settings for AddAlignmentOffLbl command.
SettingsCmdAddAlignmentOffXYLbl | Settings for AddAlignmentOffXYLbl command.
SettingsCmdAddAlignmentSegmentTable | Settings for AddAlignmentSegmentTable command.
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentSegmentTable.
SettingsCmdAddAlignmentSpiralTable | Settings for AddAlignmentSpiralTable command.
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentSpiralTable.
SettingsCmdAddAlignSegLbl | Settings for AddAlignSegLbl command.
SettingsCmdAddAlignSegLbls | Settings for AddAlignSegLbls command.
SettingsCmdAddAlignTagentLbl | Settings for AddAlignTagentLbl command.
SettingsCmdAddAlignTagentLbls | Settings for AddAlignTagentLbls command.
SettingsCmdAddContourLabeling | Settings for AddContourLabeling command.
SettingsCmdAddContourLabelingGroup | Settings for AddContourLabelingGroup command.
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling | Settings that specify the defaults assigned to surface labels.
SettingsCmdAddContourLabelingSingle | Settings for AddContourLabelingSingle command.
SettingsCmdAddParcelAreaLabel | Settings for AddParcelAreaLabel command.
SettingsCmdAddParcelCurveTable | Settings for AddParcelCurveTable command.
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelCurveTable.
SettingsCmdAddParcelLineLabel | Settings for AddParcelLineLabel command.
SettingsCmdAddParcelLineTable | Settings for AddParcelLineTable command.
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelLineTable.
SettingsCmdAddParcelSegmentLabels | Settings for AddParcelSegmentLabels command.
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions | Settings that specify defaults for creating labels with parcel segments.
SettingsCmdAddParcelSegmentTable | Settings for AddParcelSegmentTable command.
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelSegmentTable.
SettingsCmdAddParcelTable | Settings for AddParcelTable command.
SettingsCmdAddParcelTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelTable.
SettingsCmdAddPointTable | Settings for AddPointTable command.
SettingsCmdAddPointTable::SettinsCmdTableCreation | Settings of table creation for the command AddPointTable.
SettingsCmdAddProfileViewDepthLbl | Settings for AddProfileViewDepthLbl command.
SettingsCmdAddProfileViewStaElevLbl | Settings for AddProfileViewStaElevLbl command.
SettingsCmdAddSectionViewGradeLbl | Settings for AddSectionViewGradeLbl command.
SettingsCmdAddSectionViewOffElevLbl | Settings for AddSectionViewOffElevLbl command.
SettingsCmdAddSpotElevLabelsOnGrid | Settings for AddSpotElevLabelsOnGrid command.
SettingsCmdAddSurfaceBoundaries | Settings for AddSurfaceBoundaries command.
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions | Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.
SettingsCmdAddSurfaceBreaklines | Settings for AddSurfaceBreaklines command.
SettingsCmdAddSurfaceContours | Settings for AddSurfaceContours command.
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions | Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.
SettingsCmdAddSurfaceDemFile | Settings for AddSurfaceDemFile command.
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdAddSurfaceDrawingObjects | Settings for AddSurfaceDrawingObjects command.
SettingsCmdAddSurfaceSlopeLabel | Settings for AddSurfaceSlopeLabel command.
SettingsCmdAddSurfaceSpotElevLabel | Settings for AddSurfaceSpotElevLabel command.
SettingsCmdAddWidening | Settings for AddWidening command.
SettingsCmdAddWidening::SettingsCmdWideningOptions | Settings for the alignment widening options.
SettingsCmdCatchmentArea | Settings for CatchmentArea command.
SettingsCmdConvertPointstoSdskPoints | Settings for ConvertPointstoSdskPoints command.
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer | Settings that specify defaults for Layer.
SettingsCmdCreateAlignmentEntities | Settings for CreateAlignmentEntities command.
SettingsCmdCreateAlignmentLayout | Settings for CreateAlignmentLayout command.
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption | Settings of alignment type option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings | Settings of curve and spiral for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption | Settings of curve tessellation option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption | Settings of tegression graph option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentReference | Settings for CreateAlignmentReference command.
SettingsCmdCreateFeatureLineFromAlign | Settings for CreateFeatureLineFromAlign command.
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating feature lines from alignments.
SettingsCmdCreateFeatureLines | Settings for CreateFeatureLines command.
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating feature lines from objects.
SettingsCmdCreateGrading | Settings for CreateGrading command.
SettingsCmdCreateGrading::SettingsCmdGradingCreation | Settings that specify the default behavior for creating grading.
SettingsCmdCreateGradingGroup | Settings for CreateGradingGroup command.
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation | Settings that specify the default behavior for creating grading.
SettingsCmdCreateMassHaulDiagram | Settings for CreateMassHallDiagram command.
SettingsCmdCreateMultipleProfileView | Settings for CreateMultipleProfileView command.
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation | Settings that specify defaults for creating multiple profile views.
SettingsCmdCreateMultipleSectionView | Settings for CreateMultipleSectionView command.
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation | Settings for the table creation.
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation | Settings for table creation.
SettingsCmdCreateOffsetAlignment | Settings for CreateOffsetAlignment command.
SettingsCmdCreateParcelByLayout | Settings for CreateParcelByLayout command.
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout | Settings that specify defaults for automatic parcel layout.
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities | Settings that specify defaults for creation of parcels.
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing | Settings that specify defaults for sizing parcels.
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics | Settings that specify defaults for temporary parcel layout preview graphics.
SettingsCmdCreateParcelFromObjects | Settings for CreateParcelFromObjects command.
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities | Settings that specify defaults for creation of parcels.
SettingsCmdCreateParcelROW | Settings for CreateParcelROW command.
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections | Settings that specify default offset for cleanup at alignment intersections.
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries | Settings that specify default offset for cleanup at parcel boundaries.
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay | Setting that specify default offset for creation of parcel rights of way.
SettingsCmdCreatePointGroup | Settings for CreatePointGroup command.
SettingsCmdCreatePoints | Settings for CreatePoints command.
SettingsCmdCreatePoints::SettingsCmdLayer | Default layer settings for the CreatePoints command.
SettingsCmdCreatePoints::SettingsCmdPointsCreation | Settings that specify defaults for Points Creation.
SettingsCmdCreateProfileFromFile | Settings for CreateProfileFromFile command.
SettingsCmdCreateProfileFromSurface | Settings for CreateProfileFromSurface command.
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry | Settings that specify the geometry setting.
SettingsCmdCreateProfileLayout | Settings for CreateProfileLayout command.
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption | Settings that specify the default behavior when curve entities are used as an input option for best fit arc, line,... more
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption | Setting that specifies the default behavior for regression analysis graphs in best fit arc, line, and parabola creation.
SettingsCmdCreateProfileReference | Settings for CreateProfileReference command.
SettingsCmdCreateProfileView | Settings for CreateProfileView command.
SettingsCmdCreateQuickProfile | Settings for CreateQuickProfile command.
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile | Settings that specify the default settings for quick profile creation.
SettingsCmdCreateSampleLines | Settings for CreateSampleLines command.
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls | Settings that specify the default behavior for additional sample controls.
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous | Setting that specifies miscellaneous default behavior for sample lines.
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements | Settings that specify the default behavior for sampling increments.
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths | Settings that specify the default behavior for sample line swath width.
SettingsCmdCreateSectionView | Settings for CreateSectionView command.
SettingsCmdCreateSectionView::SettingsCmdTableCreation | Settings for the table creation.
SettingsCmdCreateSheets | Settings for CreateSheets command.
SettingsCmdCreateSheets::SettingsCmdSheetCreation | Settings for the sheet creation.
SettingsCmdCreateSite | Settings for CreateSite command.
SettingsCmdCreateSite::SettingsCmdAlignment | Settings that specify default increments for alignment tag numbering.
SettingsCmdCreateSite::SettingsCmdFeatureLine | Settings that specify defaults for feature line style priority.
SettingsCmdCreateSite::SettingsCmdParcel | Settings that specify default increments for parcel numbering.
SettingsCmdCreateSurface | Settings for CreateSurface command.
SettingsCmdCreateSurface::SettingCmdBuildOptions | Settings that specify the build options assigned when creating surfaces.
SettingsCmdCreateSurface::SettingCmdSurfaceCreation | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdCreateSurface::SettingsNameFormat | Settings that specify name format for the command.
SettingsCmdCreateSurfaceFromTIN | Settings for CreateSurfaceFromTIN command.
SettingsCmdCreateSurfaceGridFromDEM | Settings for CreateSurfaceGridFromDEM command.
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions | Settings that specify the build options assigned when creating surfaces.
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdCreateSurfaceReference | Settings for CreateSurfaceReference command.
SettingsCmdCreateSurfaceWaterdrop | Settings for CreateSurfaceWaterdrop command.
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker | Settings that specify the default water drop marker options for surfaces.
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath | Settings that specify the default water drop path options for surfaces.
SettingsCmdCreateViewFrames | Settings for CreateViewFrames command.
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation | Settings for the view frame creation.
SettingsCmdDrawFeatureLine | Settings for DrawFeatureLine command.
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating featureline.
SettingsCmdEditSVGroupStyle | Settings for EditSVGroupStyle command.
SettingsCmdExportParcelAnalysis | Settings for ExportParcelAnalysis command.
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis | Settings that specify defaults for parcel analysis.
SettingsCmdFitCurveFeature | Settings for FitCurveFeature command.
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve | Settings that specify the default behavior for feature line fit curve.
SettingsCmdGradingElevEditor | Settings for GradingElevEditor command.
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor | Settings that specify the default behavior for grading elevation editor.
SettingsCmdGradingTools | Settings for GradingTools command.
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools | Settings that specify the default behavior for grading layout tools.
SettingsCmdGradingVolumeTools | Settings for GradingVolumeTools command.
SettingsCmdImportBuildingSite | Settings for ImportBuildingSite command.
SettingsCmdImportGEData | Settings for ImportGEData command.
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions | Settings that specify the default number of rows and columns collected when importing Google Earth information.
SettingsCmdImportGEData::SettingsCmdSurfaceCreation | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdImportGESurface | Settings for ImportGESurface command.
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions | Settings that specify the default number of rows and columns collected when importing Google Earth information.
SettingsCmdImportGESurface::SettingsNameFormat | Settings that specify name format for the command.
SettingsCmdJoinFeatures | Settings for JoinFeatures command.
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin | Settings that specify the default behavior for featureline join.
SettingsCmdLayoutSectionViewGroup | Settings for LayoutSectionViewGroup command.
SettingsCmdMoveBlockstoAttribElev | Settings for MoveBlockstoAttribElev command.
SettingsCmdMoveBlocksToSurface | Settings for MoveBlocksToSurface command.
SettingsCmdMoveTextToElevation | Settings for MoveTextToElevation command.
SettingsCmdProjectObjectsToProf | Settings for ProjectObjectsToProf command.
SettingsCmdProjectObjectsToSect | Settings for ProjectObjectsToSect command.
SettingsCmdReAddParcelAreaLabel | Settings for ReAddParcelAreaLabel command.
SettingsCmdReAddParcelSegmentLabels | Settings for ReAddParcelSegmentLabels command.
SettingsCmdReverseAlignmentDirection | Settings for ReverseAlignmentDirection command.
SettingsCmdShowGeodeticCalculator | Settings for ShowGeodeticCalculator command.
SettingsCmdShowPointGroupProperties | Settings for ShowPointGroupProperties command.
SettingsCmdSimplifySurface | Settings for SimplifySurface command.
SettingsCmdSuperimposeProfile | Settings for SuperimposeProfile command.
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption | Settings that specify the default values for the mid-ordinate distances that the system uses when tessellating (approximating) the shape of... more
SettingsCmdSurfaceExportToDem | Settings for SurfaceExportToDem command.
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions | Settings that specify the defaults assigned when exporting surfaces to a DEM file.
SettingsCmdSurfaceExtractObjects | Settings for SurfaceExtractObjects command.
SettingsCmdWeedFeatures | Settings for WeedFeatures command.
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed | Settings that specify the default behavior for grading layout tools.
SettingsGrading | Settings for Grading.
SettingsGrading::SettingsNameFormat | Default name format for grading feature settings.
SettingsGrading::SettingsStyles | Default styles.setting class
SettingsMassHaulLine | Settings for MassHaulLine.
SettingsMassHaulView | Settings for MassHaulView.
SettingsMassHaulView::SettingsMassHaulCreation | Default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings when you... more
SettingsMassHaulView::SettingsNameFormat | Default name format for new mass haul lines and new mass haul views.
SettingsMassHaulView::SettingsStyles | Default styles.for mass haul components.
SettingsMatchLine | Settings for MatchLine.
SettingsParcel | Settings for Parcel.
SettingsParcel::SettingsStyles | Default styles.setting class
SettingsPoint | Settings for Point.
SettingsPoint::SettingsNameFormat | Default name format for point feature settings.
SettingsPoint::SettingsStyles | Default styles.setting class
SettingsPoint::SettingsUpdatePoints | Update points setting class.
SettingsProfile | Settings for Profile.
SettingsProfile::SettingsCriteriaBasedDesignOptions | Criteria Based Design options setting class
SettingsProfile::SettingsDefaultNameFormat | Default name format setting class
SettingsProfile::SettingsProfileCreation | Default values for vertical curve sub-entities
SettingsProfile::SettingsStyles | Default styles.setting class
SettingsProfileView | Settings for ProfileView.
SettingsProfileView::SettingsCreation | Settings for ProfileView default Creation.
SettingsProfileView::SettingsNameFormat | Settings for ProfileView default NameFormat.
SettingsProfileView::SettingsProjectionLabelPlacement | Settings for ProfileView default ProjectionLabelPlacement.
SettingsProfileView::SettingsSplitOptions | Settings for ProfileView default SplitOptions.
SettingsProfileView::SettingsStackedOptions | Settings for ProfileView default StackedOptions.
SettingsProfileView::SettingsStyles | Settings for ProfileView default Styles.
SettingsSampleLine | Settings for SampleLine.
SettingsSampleLine::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSampleLine::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSection | Settings for Section.
SettingsSection::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSection::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSectionView | Settings to specify the default styles assigned to section view components
SettingsSectionView::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsProjectionLabelPlacement | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsSectionViewCreation | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSurface | Settings for Surface.
SettingsSurface::SettingsContourLabeling | Defaults assigned to surface labels.
SettingsSurface::SettingsDefaults | Default name format for new surfaces.
SettingsSurface::SettingsStyles | Default styles.assigned to surfaces and surface-related labels.
SettingsViewFrame | Settings for ViewFrame.
SettingsViewFrameGroup | Settings for ViewFrameGroup.
SettingsViewFrameGroup::SettingsInformation | Default match line label location.
SettingsViewFrameGroup::SettingsNameFormat | Default name format for view frame group components.
SettingsViewFrameGroup::SettingsStyles | Default styles assigned to view frame group components.


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes
Classes
Classes
Classes
Class | Description
Interference | Represents one location where elements of a pipe network interfere with each other.
InterferenceCheck | Determines where pipes and structures intersect or are too close to each other, and holds a collection of the resulting... more
Network | The container object used to associate pipes and structures that are part of the same pipe run or pipe network.... more
NetworkCatalogDef | The NetworkCatalogDef class. This class allows you to use a part catalog definition at runtime.
NetworkRule | Holds parameter collections for pipe and structure rules.
Part | A pipe network part, base class for Pipe and Structure classes.
PartDataField | An extensible field of part data.
PartDataList | The part data list associated with a PartDataField or SizeFilterField.
PartDataRange | Defines the range of valid data for a PartDataField.
PartDataRecord | A single data record for a Part object.
PartDef | A part definition for Pipe or Structure objects.
PartViewDef | Contains information about how a part is displayed.
Pipe | A pipe network part serving to move fluids from one point to another.
ProfileViewPart | Manages the graphic display of pipe network parts in profile view.
SectionPipeNetwork | Section view of a pipe network.
Structure | The drawing shape used to represent items such as manholes, catch basins, and headwalls used in utility networks. A Structure... more


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes
Legend
Legend
Class


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes
Classes
Classes
Classes
Class | Description
DataPartFamily | Part family data that is queried from the catalog.
InterferenceStyle | Defines how a pipe interference appears in plan, profile, section, and 3D view.
InterferenceStyleCollection | A collection of InterferenceStyle objects.
LabelStylesPipeRoot | Root object for pipe label styles.
LabelStylesStructureRoot | Root object for structure label styles.
NetworkRuleSetStyle | Base class for Pipe and Structure rule sets.
PartFamily | Each Part is a member of a PartFamily containing all size variations for a given part.
PartSize | Pipe network part size filter.
PartsList | List of pipe network parts (pipes and structures) used for a particular drawing.
PartsListCollection | A collection of PartsList objects.
PipeNetworkBandStyle | Band style in pipe network profile views.
PipeRuleSetStyle | A set of rules for pipe objects.
PipeRuleSetStyleCollection | A collection of PipeRuleSetStyle objects.
PipeStyle | Defines how a pipe appears in plan, profile, section, and 3D view.
PipeStyleCollection | A collection of PipeStyle objects.
PipeStyleOptionBase | Base interface for settings that define the appearance of the pipe in a 2D plan view. Used by PipeStylePlanOption and... more
PipeStylePlanOption | Settings that define the appearance of the pipe in a 2D plan view.
PipeStyleProfileOption | Settings that define the appearance of the pipe in a profile view.
SizeFilterField | Part size parameters from a SizeFilterRecord.
SizeFilterRecord | Lets users specify what part sizes they want to add into a part family.
StructureRuleSetStyle | A set of rules for structure objects.
StructureRuleSetStyleCollection | A collection of StructureRuleSetStyle objects.
StructureStyle | Specifies display properties for all structure objects in the drawing.
StructureStyleCollection | A collection of StructureStyle objects.
StructureStyleModelOption | Specifies the method that is used to define and draw the dimensions of the structure in model view.
StructureStyleOptionBase | Base class for StructureStyleProfileOption and StructureStyleSectionOption.
StructureStylePlanOption | Specifies the method that is used to define and draw the dimensions of the structure in 2D plan view.
StructureStyleProfileOption | Specifies the method that is used to define and draw the dimensions of the structure in profile view.
StructureStyleSectionOption | Specifies the method that is used to define and draw the dimensions of the structure in section view.


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes
Legend
Legend
Class


Classes
Classes
Classes
Class | Description
SettingsCmdAddNetworkPartPlanLabel | Settings for AddNetworkPartPlanLabel command.
SettingsCmdAddNetworkPartProfLabel | Settings for AddNetworkPartProfLabel command.
SettingsCmdAddNetworkPartSectLabel | Settings for AddNetworkPartSectLabel command.
SettingsCmdAddNetworkPartsToProf | Settings for AddNetworkPartsToProf command.
SettingsCmdAddNetworkPipeTable | Settings for AddNetworkPlanTable command.
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation | Settings for alignment type option.
SettingsCmdAddNetworkPlanLabels | Settings for AddNetworkPlanLabels command.
SettingsCmdAddNetworkProfLabels | Settings for AddNetworkProfLables command.
SettingsCmdAddNetworkSectLabels | Settings for AddNetworkSectLables command.
SettingsCmdAddNetworkStructTable | Settings for AddNetworkStructTable command.
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation | Settings for alignment type option.
SettingsCmdAddSpanningPipePlanLabel | Settings for AddSpanningPipePlanLabel command.
SettingsCmdAddSpanningPipeProfLabel | Settings for AddSpanningPipeProfLabel command.
SettingsCmdCreateAlignFromNetwork | Settings for CreateAlignFromNetwork command.
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption | Settings for alignment type option.
SettingsCmdCreateInterferenceCheck | Settings for CreateInterferenceCheck command.
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria | Settings for interference criteria.
SettingsCmdCreateNetwork | Settings for CreateNetwork command.
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts | Settings for alignment type option.
SettingsCmdCreateNetworkFromObject | Settings for CreateNetworkFromObject command.
SettingsCmdCreateNetworkPartsList | Settings for CreateNetworkPartsList command.
SettingsCmdCreateNetworkPartsListFull | Settings for CreateNetworkPartsListFull command.
SettingsCmdCreateNetworkReference | Settings for CreateNetworkReference command.
SettingsCmdEditInStormSewers | Settings for EditInStormSewers command.
SettingsCmdExportStormSewerData | Settings for ExportStormSewerData command.
SettingsCmdImportStormSewerData | Settings for ImportStormSewerData command.
SettingsCmdRenamePipeNetworkParts | Settings for RenamePipeNetworkParts command.
SettingsCmdResetAnchorPipe | Settings for ResetAnchorPipe command.
SettingsCmdShowSpanningPipes | Settings for ShowSpanningPipes command.
SettingsPipe | Settings for Pipe.
SettingsPipeNetwork | Settings for PipeNetwork.
SettingsPipeNetwork::SettingsNameFormat | Settings for PipeNetwork default NameFormat.
SettingsPipeNetwork::SettingsProfileLabelPlacement | Settings for PipeNetwork default ProfileLabelPlacement.
SettingsPipeNetwork::SettingsRules | Settings for PipeNetwork default Rules.
SettingsPipeNetwork::SettingsSectionLabelPlacement | Settings for PipeNetwork default SectionLabelPlacement.
SettingsPipeNetwork::SettingsStormSewersMigration | Settings for PipeNetwork default StormSewersMigration.
SettingsPipeNetwork::SettingsStyles | Settings for PipeNetwork default Styles.
SettingsStructure | Settings for Structure.


Classes
Classes
Classes
Class | Description
QTOUtility | This is class Autodesk::Civil::QTO::DatabaseServices::QTOUtility.


Classes
Classes
Classes
Class | Description
AppliedAssembly | Represents an AppliedAssembly object. An AppliedAssembly is a cross section of an existing corridor.
AppliedAssemblyCollection | The collection of assembly cross sections placed at intervals along corridor baselines.
AppliedSubassembly | An AppliedSubassemby object. An AppliedSubassembly is a series of points, links, and shapes that make up part of an AppliedAssembly... more
AppliedSubassemblyCollection | Collection of AppliedSubassembly objects.
Assembly | Pattern for the cross section of a corridor. Made up of multiple Subassembly objects.
AssemblyCollection | A collection of Assembly objects.
BaseBaseline | The base class for baselines, such as Baseline, OffsetBaseline, and HardcodedOffsetBaseline.
Baseline | A 3D path defined by an alignment and a profile. A corridor is defined by a baseline (or multiple baselines)... more
BaselineCollection | A collection of Baseline objects.
BaselineFeatureLines | A collection of multiple feature line collections (FeatureLinesCol) associated with a particular baseline or offset baseline.
BaselineFeatureLinesCollection | A collection of multiple feature line collections (BaselineFeatureLines) objects.
BaselineRegion | A segment of a baseline, specified by alignment stations for the start and end point. In a corridor, each baseline... more
BaselineRegionCollection | A collection of baseline region (BaselineRegion) objects.
CalculatedLink | The CalculatedLink class. A CalculatedLink joins two CalculatedPoint objects, and is a component of an AppliedSubassembly object, which in turn... more
CalculatedLinkCollection | A calculated link is a collection of calculated points (CalculatedPoint) which are connected to form a line. Calculated... more
CalculatedPoint | The CalculatedPoint class. A CalculatedPoint is the basic component that defines the stucture of an AppliedSubassembly.
CalculatedPointCollection | A collection of calculated point (CalculatedPoint) objects. Calculated points are used to define applied subassemblies.
CalculatedShape | The CalculatedShape class. A CalculatedShape is defined from links and defines a closed region that represents materials used in a... more
CalculatedShapeCollection | Collection of calculated shape (CalculatedShape) objects.
CalculatedSubentity | Parent class for the CalculatedShape, CalculatedLink and CalculatedPoint interfaces.
CodeCollection | The Corridor code collection class. The wrapped object could be AeccDbRoadwayState or AeccDbSubassembly.
Corridor | Representation of a roadway. Follows a 3D path defined by a baseline, and is made up of cross sections (... more
CorridorCodeCollection | A collection of strings containing corridor codes. A code is used to identify common calculated points in applied assemblies in... more
CorridorCollection | A collection of Corridor objects.
CorridorSection | A section of a Corridor.
CorridorSurface | Represents a layer of a corridor, and is computed from a set of feature lines, calculated points, and calculated links.... more
CorridorSurfaceBaseMask | Base class for CorridorSurfaceMask and CorridorSurfaceBoundary.
CorridorSurfaceBoundary | A corridor surface boundary represents an outside or inside edge of a corridor surface (CorridorSurface). It is defined... more
CorridorSurfaceBoundaryCollection | Collection of corridor surface boundary (CorridorSurfaceBoundary) objects.
CorridorSurfaceCollection | A collection of corridor surface (CorridorSurface) objects.
CorridorSurfaceMask | The corridor surface mask is a region defined by a polygon or a series of feature line components (FeatureLineComponent... more
CorridorSurfaceMaskCollection | Collection of corridor surface mask (CorridorSurfaceMask) objects.
FeatureLine | A feature line is a connected series of points along a corridor created by joining those points from each assembly... more
FeatureLineCodeInfo | Information about the code used to construct a feature line.
FeatureLineCodeInfoCollection | A collection of feature line code information (FeatureLineCodeInfo) objects.
FeatureLineCollection | Collection of feature lines that share a particular code. Multiple points in a single assembly may contain the same code,... more
FeatureLineCollectionMap | A collection of multiple feature line collections (FeatureLineCollection) objects.
FeatureLineComponent | A portion of an entire feature line, delimited by a starting and ending station.
FeatureLineComponentCollection | A collection of feature line component (FeatureLineComponent) objects.
FeatureLinePoint | A point in a feature line (FeatureLine object). A feature line is created by connecting common points within applied... more
FeatureLinePointCollection | A collection of feature line point (FeatureLinePoint) objects.
HardcodedOffsetBaseline | An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between... more
Intersection | An object that manages the intersection of two Alignments. An intersection object builds on and manages various object data, including... more
IntersectionRegion | Corridor regions in an Intersection area.
IntersectionRegionCollection | A collection of IntersectionRegion objects.
IntersectionRoad | Road components managed by an Intersection object.
IntersectionRoadCollection | A collection of IntersectionRoad objecs managed by an Intersection object.
Link | Roadway Link object. Connects roadway points in a subassembly.
LinkCollection | A collection of Link objects.
OffsetBaseline | An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between... more
OffsetBaselineCollection | Collection of offset baseline objects. There are two kinds of offset baselines, OffsetBaseline and HardcodedOffsetBaseline. Both of these are... more
Point | Roadway Point object. Represents a single point within a subassembly.
PointCollection | A collection of Roadway Point objects.
SampledSectionLink | Defines a single line segment of sample surface cross-section data.
SampledSectionLinkCollection | Collection of sampled elevation data.
Shape | Roadway Shape object. Represents a series of roadway links which form a closed shape. Used in subassemblies.
ShapeCollection | A collection of Roadway Shape objects.
SlopeElevationTarget | The SlopeElevation class.
Subassembly | Pattern for part of a corridor cross section, representing a particular portion of a roadway.
SubassemblyCollection | A collection of Subassembly objects.
SubassemblyGenerator | Controls the way Subassembly geometry is generated.
WidthOffsetTarget | The WidthOffsetTarget class.


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes
Classes
Classes
Classes
Class | Description
AssemblyStyle | Used to control the visual style of an Assembly object.
AssemblyStyleCollection | A collection of AssemblyStyle objects.
CodeSetStyle | A collection of CodeSetStyleItem objects. CodeSetStyleItem defines a code and related style, where the style is the ObjectId of a... more
CodeSetStyleCollection | A collection of CodeSetStyle objects.
CodeSetStyleItem | Defines the style to apply to a specific code.
CorridorStyle | Defines the appearance of objects.
CorridorStyleCollection | A collection of CorridorStyle objects.
IntersectionStyle | The match line style wrapper class.
IntersectionStyleCollection | The IntersectionStyleCollection class.
LabelStylesIntersectionRoot | Root for all intersection label collections.
LinkStyle | Used to control the visual style of a roadway link (Link) object.
LinkStyleCollection | A collection of LinkStyle objects.
QuantityTakeoffCriteria | A collection of items that define the criteria used to calculate material lists, which are then used ot generate quantity... more
QuantityTakeoffCriteriaCollection | The QuantityTakeoffCriteriaCollection class.
QuantityTakeoffCriteriaData | Defines additional data for material in QuantityTakeoffCriteria.
QuantityTakeoffCriteriaItem | Defines a material used to create quantity takeoff criteria (QuantityTakeoffCriteria).
ShapeStyle | Used to control the visual style of a roadway shape (Shape) object.
ShapeStyleCollection | A collection of ShapeStyle objects.
SubassemblySubentityStyle | Base class for LinkStyle and ShapeStyle.


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes
Legend
Legend
Class


Classes
Classes
Classes
Class | Description
SettingsAssembly | Settings for Assembly.
SettingsAssembly::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsAssembly::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsCmdAddIntersectionLabel | Settings for AddIntersectionLabel command.
SettingsCmdAddMaterialVolumeTable | Settings for AddMaterialVolumeTable command.
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation | Settings of table creation for command AddMaterialVolumeTable.
SettingsCmdAddTotalVolumeTable | Settings for AddTotalVolumeTable command.
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation | Settings of table creation for command AddTotalVolumeTable.
SettingsCmdAssignPayItemToArea | Settings for AssignPayItemToArea command.
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions | Settings of pay item assignment for command AssignPayItemToArea.
SettingsCmdComputeMaterials | Settings for ComputeMaterials command.
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial | Settings of material definition for command ComputeMaterials.
SettingsCmdCorridorExtractSurfaces | Settings for CorridorExtractSurfaces command.
SettingsCmdCreateAlignFromCorridor | Settings for CreateAlignFromCorridor command.
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption | Settings for alignment type option.
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions | Settings for criteria based design options.
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption | Settings for profile creation option.
SettingsCmdCreateAssembly | Settings for CreateAssembly command.
SettingsCmdCreateAssemblyTool | Settings for CreateAssemblyTool command.
SettingsCmdCreateCorridor | Settings for CreateCorridor command.
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion | Settings for alignment type option.
SettingsCmdCreateIntersection | Settings for CreateIntersection command.
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion | Settings for the default assembly insertion of new intersection
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes | Settings for the default cross slopes of new intersection
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters | Settings for the default curb return parameters of new intersection
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules | Settings for the default curb return profile rules of new intersection
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions | Settings for the default intersection options of new intersection
SettingsCmdCreateIntersection::SettingsCmdOffsets | Settings for the default offsets of new intersection
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules | Settings for the default secondary road profile rules of new intersection
SettingsCmdCreateIntersection::SettingsCmdWideningParameters | Settings for the default widening parameters of new intersection
SettingsCmdCreatePointsFromCorridor | Settings for CreatePointsFromCorridor command.
SettingsCmdCreatePolylineFromCorridor | Settings for CreatePolylineFromCorridor command.
SettingsCmdCreateProfileFromCorridor | Settings for CreateProfileFromCorridor command.
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions | Settings that specify the defaults used when creating a profile using design criteria.
SettingsCmdCreateSimpleCorridor | Settings for CreateSimpleCorridor command.
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion | Settings that establish the defaults assigned to corridor creation.
SettingsCmdCreateSubassemblyTool | Settings for CreateSubassemblyTool command.
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions | Settings
SettingsCmdCreateSubFromPline | Settings for CreateSubFromPline command.
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities | Settings that specifies the default behavior for creating subassemblies from polylines.
SettingsCmdFeatureLinesFromCorridor | Settings for FeatureLinesFromCorridor command.
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation | Default settings for the Feature Line Creation command.
SettingsCmdGenerateQuantitiesReport | Settings for GenerateQuantitiesReport command.
SettingsCmdTakeOff | Settings for TakeOff command.
SettingsCmdTakeOff::SettingsCmdComputeTakeOff | Settings of take off computation for command TakeOff.
SettingsCmdViewEditCorridorSection | Settings for ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings | Settings for the Grid Settings section of the ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings | Settings for the Grid Text Settings section of the ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions | Settings for the View/Edit Options section of the ViewEditCorridorSection command.
SettingsCorridor | Controls ambient settings for corridors.
SettingsCorridor::SettingsNameFormat | Settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
SettingsCorridor::SettingsRegionHighlightGraphics | Settings for Corridor styles.
SettingsCorridor::SettingsStyles | Settings to establish the default styles assigned to corridor components.
SettingsIntersection | Settings for Intersection.
SettingsIntersection::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsIntersection::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsQuantityTakeoff | Settings for QuantityTakeoff.
SettingsQuantityTakeoff::SettingsNameFormat | Settings to establish the default name format to quantity takeoff.
SettingsQuantityTakeoff::SettingsStyles | Settings to establish the default styles assigned to quantity takeoff.
SettingsSubassembly | Contains settings that apply to the assembly feature, as specified in the Edit Feature Settings dialog box.
SettingsSubassembly::SettingsDefaultStyles | Settings for subassembly default styles.
SettingsSubassembly::SettingsNameFormat | Settings for Corridor styles.


Classes
Classes
Classes
Class | Description
CorridorState | Contains a wide array of information about a corridor and methods for determining locations relative to the corridor. Used in... more
Param | Use Autodesk.Civil.IParam instead.
ParamAlignment | Alignment parameter.
ParamAlignmentCollection | A collection of Alignment parameters.
ParamBool | A boolean parameter.
ParamBoolCollection | A collection of boolean parameters.
ParamDouble | A parameter with a double value.
ParamDoubleCollection | A collection of double parameters.
ParamElevationTarget | Elevation target parameter.
ParamElevationTargetCollection | A collection of elevation target parameters.
ParamLong | A long parameter.
ParamLongCollection | A collection of long parameters.
ParamOffsetTarget | An offset target parameter.
ParamOffsetTargetCollection | A collection of offset target parameters.
ParamPoint | A point parameter.
ParamPointCollection | A collection of point parameters.
ParamProfile | A Profile parameter.
ParamProfileCollection | A collection of profile parameters.
ParamString | A string parameter.
ParamStringCollection | A collection of string parameters.
ParamSurface | A Surface parameter.
ParamSurfaceCollection | A collection of surface parameters.
PipeNetworkState | Contains the properties of the drawing's pipe network state.
RuntimeState | Base class for objects containing user-defined parameters describing an object state.


Classes Templates
Classes
Templates
Template | Description
ParamBase | The base class for parameters.
ParamCollectionBase | Base class for parameter collections.


Classes
Classes
Classes
Class | Description
SettingsAbbreviation | Contains profile and alignment abbreviation strings as specified on the Abbreviations tab of the Drawing Settings dialog box.
SettingsAmbient | Specify default ambient (background) settings for units of measurement. These units are used throughout AutoCAD Civil 3D, unless they are... more
SettingsAmbient::SettingsAngle | Specify how to display deflection angles between two vectors.
SettingsAmbient::SettingsArea | Specify how to display surface areas.
SettingsAmbient::SettingsCoordinate | Specify how to display X and Y coordinates.
SettingsAmbient::SettingsDimension | Specify how to display linear dimensions.
SettingsAmbient::SettingsDirection | Specify how to display directions.
SettingsAmbient::SettingsDistance | Specify how to display linear distances.
SettingsAmbient::SettingsElevation | Specify how to display surface elevations.
SettingsAmbient::SettingsGeneral | Specify how to display text, numbers, and units.
SettingsAmbient::SettingsGrade | Specify how to display grade measurements.
SettingsAmbient::SettingsGradeSlope | Specify how to display grade and slope measurements.
SettingsAmbient::SettingsGridCoordinate | Specifies default (ambient) settings for grid coordinate values.
SettingsAmbient::SettingsLabeling | Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.
SettingsAmbient::SettingsLatLong | Specify how to display latitude and longitude.
SettingsAmbient::SettingsSlope | Specify how to display slope measurements.
SettingsAmbient::SettingsSpeed | Specify how to display speeds for design criteria.
SettingsAmbient::SettingsStation | Specify how to display linear features that use station or chainage.
SettingsAmbient::SettingsTransparentCommands | specify the prompting behavior of transparent commands across all features. The formats used to prompt for grade and slope values... more
SettingsAmbient::SettingsUnitless | These settings specify how to display numeric values that are not specifically defined by the unit type.
SettingsAmbient::SettingsVolume | Specify how to display terrain volumes.
SettingsCmdAddNoteLabel | Settings for AddNoteLabel command.
SettingsCmdAddSegmentLabel | Settings for AddSegmentLabel command.
SettingsCmdAddSegmentLabels | Settings for AddSegmentLabels command.
SettingsCmdCreateArcByBestFit | Settings for CreateArcByBestFit command.
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.
SettingsCmdCreateLineByBestFit | Settings for CreateLineByBestFit command.
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.
SettingsCmdCreateParabolaByBestFit | Settings for CreateParabolaByBestFit command.
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.
SettingsCmdMapCheck | Settings for MapCheck command.
SettingsCmdMapCheck::SettingsCmdMapcheck | Use these settings to specify the default behavior for Mapcheck.
SettingsCoordinateSystem | Encapsulates coordinate system settings.
SettingsDrawing | Contains settings that apply to the drawing, as specified in the Drawing Settings dialog box.
SettingsGeneral | Settings for General.
SettingsGeneral::SettingsStyles | Default styles settings class.
SettingsLandXML | Settings that define how data is imported from LandXML file.
SettingsLandXMLExport | Settings that define how data is exported from LandXML file.
SettingsLandXMLExport::SettingsAlignmentExport | Alignment Settings for LandXML export.
SettingsLandXMLExport::SettingsData | Data Settings for LandXML export.
SettingsLandXMLExport::SettingsIdentification | Identification Settings for LandXML export.
SettingsLandXMLExport::SettingsParcelExport | Parcel Settings for LandXML export.
SettingsLandXMLExport::SettingsPointExport | Point Settings for LandXML export.
SettingsLandXMLExport::SettingsSurfaceExport | Surface Settings for LandXML export.
SettingsLandXMLImport | Settings that define how data is imported from LandXML file.
SettingsLandXMLImport::SettingsConflictResolution | ConflictResolution settings for LandXML importing.
SettingsLandXMLImport::SettingsDiameterUnits | On import, AutoCAD Civil 3D reads the LandXML.Units.diameterUnits, and if they are defined, those units are used for both pipes... more
SettingsLandXMLImport::SettingsPipeNetwork | PipeNetwork settings for LandXML importing.
SettingsLandXMLImport::SettingsPointImport | PointImport settings for LandXML importing.
SettingsLandXMLImport::SettingsRotation | Rotation settings for LandXML importing.
SettingsLandXMLImport::SettingsSurfaceImport | SurfaceImport settings for LandXML importing.
SettingsLandXMLImport::SettingsTranslation | Translation settings for LandXML importing.
SettingsObjectLayer | SettingsObjectLayer class specifies layers for individual object in AutoCAD Civil 3D.
SettingsObjectLayers | The SettingsObjectLayers class is to specify layers for various objects in AutoCAD Civil 3D. For example, you can specify that... more
SettingsRoot | The root of the settings hierarchy.
SettingsTag | The Settings specify how line, curve and spiral components are numbered and renumbered.
SettingsTag::SettingsCreation | Settings of creation for the SettingsTag.
SettingsTag::SettingsRenumbering | Settings of renumbering for the SettingsTag.
SettingsTransformation | The SettingsTransformation class use to transform the coordinate system to local specifications.
SettingsUnitZone | The settings class for the unit zone.


Classes
Classes
Classes
Class | Description
SurveyFigure | Survey figure class. Figures are groups of connected lines and arcs where the figure vertexes can reference survey points.
SurveyNetworkEntity | The drawing database version of a survey network object.


Classes
Classes
Classes
Class | Description
SettingsSurvey | Settings for Survey.
SettingsSurvey::SettingsStyles | Default styles settings for Survey class


Interfaces
Interfaces
Interfaces
Interface | Description
ICommonLabel | The interface ICommonLabel declares properties and methods common to all classes representing labels.
ICommonLabelOptions | The interface ICommonLabelOptions declares common behavioral options on labels.


Interfaces

Legend
Legend
Interface


Interfaces

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces
Interfaces
Interfaces
Interfaces
Interface | Description
IPoint | This is class Autodesk::Civil::Roadway::DatabaseServices::IPoint.


Interfaces

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces
Legend
Legend
Interface


Interfaces
Interfaces
Interfaces
Interface | Description
IParam | Interface for parameters.


CivilApplication Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilApplication Class > CivilApplication Members
CivilApplication Members Public Properties
CivilApplication Members
Public Properties
Public Property | Description
ActiveDocument | Gets the active CivilDocument object.
ActiveProduct | Gets the type of the currently running product.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilApplication Class > CivilApplication Members
Legend
Legend
Property
public


CivilDocument Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Members
CivilDocument Members Public Methods
CivilDocument Members
Public Methods
Public Method | Description
GetAlignmentIds | Gets the objectId collection of all Alignment objects in the drawing.
GetAlignmentTableIds | Gets the objectId collection of all alignment tables.
GetAllPointIds | Gets the objectId collection of all points in the drawing.
GetIntersectionIds | Gets the objectId collection of all intersection objects in the drawing.
GetLegendTableIds | Gets the objectId collection of legend tables.
GetParcelSegmentTableIds | Gets the objectId collection of parcel segment tables.
GetParcelTableIds | Gets the objectId collection of parcel tables.
GetPipeNetworkIds | Gets the pipe network object id collection.
GetPointTableIds | Gets the objectId collection of point tables.
GetSiteIds | Gets the objectId collection of all site objects in the drawing.
GetSitelessAlignmentId | Gets the objectId of a siteless Alignment object by name.
GetSitelessAlignmentIds | Gets the objectId collection of all siteless Alignment objects in the drawing.
GetSurfaceIds | Gets the objectId collection of all surface objects in the drawing.
GetViewFrameGroupIds | Gets the objectId collection of all view frame groups in the drawing.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Members
Legend
Legend
Method
public


CivilDocument Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Members
CivilDocument Members Public Properties
CivilDocument Members
Public Properties
Public Property | Description
AssemblyCollection | Gets the ObjectId collection of Assembly objects in the drawing.
CorridorCollection | Gets the ObjectId collection of Corridor objects in the drawing.
CorridorState | Gets the CorridorState object, which is used for the creation of custom subassemblies.
IsCorridorSectionViewActive | Returns true if the corridor section view is active in the current document.
NetworkState | Gets the drawing's PipeNetworkState object.
Settings | Gets the root object for Civil 3D settings.
Styles | Gets the root object for Civil 3D styles.
SubassemblyCollection | Gets the ObjectId collection of SubAssembly objects in the drawing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Members
Legend
Legend
Property
public


Constant Members Public Data Members
Constant Members
Public Data Members
Public Data Member | Description
VerticalGrade | This is VerticalGrade, a member of class Constant.


Public Data Members

Legend
Legend
Data Member
public


AnchorInfo Members Public Data Members
AnchorInfo Members
Public Data Members
Public Data Member | Description
CenterOfCurve | This is CenterOfCurve, a member of class AnchorInfo.
DirectionAtLocation | This is DirectionAtLocation, a member of class AnchorInfo.
IsOnCurve | This is IsOnCurve, a member of class AnchorInfo.
Location | This is Location, a member of class AnchorInfo.


AnchorInfo Members Public Methods
AnchorInfo Members
Public Methods
Public Method | Description
AnchorInfo | This is AnchorInfo, a member of class AnchorInfo.


Public Methods

Legend
Legend
Constructor
public


AutoFeatureLabelGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Members
AutoFeatureLabelGroup Members Public Methods
AutoFeatureLabelGroup Members
Public Methods
Public Method | Description
GetAt | Gets one LabelGroupSubEntity from label group according the index.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Members
Legend
Legend
Method
public


AutoFeatureLabelGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Members
AutoFeatureLabelGroup Members Public Properties
AutoFeatureLabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Members
Legend
Legend
Property
public


DBObject Members Public Properties
DBObject Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
Name | Gets or sets the name.


Public Properties

Legend
Legend
Property
public


Entity Members Public Properties
Entity Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Feature Members Public Methods
Feature Members
Public Methods
Public Method | Description
IsEditableFeature | Check whether the Feature-derived entity (Alignment,Profile,etc) is editable.


Public Methods

Legend
Legend
Method
public


Feature Members Public Properties
Feature Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsEditable | Gets the value indicates whether the Feature derived entity (Alignment,Profile,etc) is editable.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


GraphOverride Members Public Properties
GraphOverride Members
Public Properties
Public Property | Description
Draw | Gets or sets whether this entity will be drawn in the graph.
OverrideStyleId | Gets or sets the override style of the entity.
OverrideStyleName | Gets or sets the override style of the entity.
UseOverrideStyle | Gets or sets whether to override style for the display of the entity.


ICommonLabel Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Members
ICommonLabel Members Public Methods
ICommonLabel Members
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Members
Legend
Legend
Method
public


ICommonLabel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Members
ICommonLabel Members Public Properties
ICommonLabel Members
Public Properties
Public Property | Description
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the label style id.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Members
Legend
Legend
Property
public


ICommonLabelOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Members
ICommonLabelOptions Members Public Properties
ICommonLabelOptions Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Members
Legend
Legend
Property
public


Label Members Public Methods
Label Members
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded


Public Methods

Legend
Legend
Method
public
virtual


Label Members Public Properties
Label Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.


LabelBase Members Public Properties
LabelBase Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.


LabelGroup Members Public Methods
LabelGroup Members
Public Methods
Public Method | Description
GetAt | Gets one LabelGroupSubEntity from label group according the index.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).


LabelGroup Members Public Properties
LabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.


LabelGroupSubEntity Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Members
LabelGroupSubEntity Members Public Methods
LabelGroupSubEntity Members
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Members
Legend
Legend
Method
public
virtual


LabelGroupSubEntity Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Members
LabelGroupSubEntity Members Public Properties
LabelGroupSubEntity Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | ICommonLabel
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
Index | Gets a reference to the LabelGroup instance parent of this object.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Parent | Gets a reference to the LabelGroup instance parent of this object.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the label style.
Visibility | This is Visibility, a member of class LabelGroupSubEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Members
Legend
Legend
Property
public


AxisStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Members
AxisStyle Members Public Properties
AxisStyle Members
Public Properties
Public Property | Description
HorizontalGeometryTickStyle | Gets the style object that specifies the appearance of horizontal geometry ticks on the horizontal axes, for example, interval, size,... more
MajorTickStyle | Gets the style object that specifies the appearance of major ticks on the vertical or horizontal axes, for example, interval,... more
MinorTickStyle | Gets the style object that specifies the appearance of minor ticks on the vertical or horizontal axes, for example, interval,... more
ShowTickAndLabel | Gets or sets the boolean value that specifies whether ticks and labels are placed at the start station on the... more
TitleStyle | Gets the style object that controls the appearance of the axis title text for profile or section views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Members
Legend
Legend
Property
public


AxisTickStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Members
AxisTickStyle Members Public Properties
AxisTickStyle Members
Public Properties
Public Property | Description
Interval | Gets or sets the spacing of ticks on the axes, using the actual ground units.
Justification | Gets or sets the justification (alignment) of the title.
LabelText | Gets or sets the label text for the tick.
OffsetX | Gets or sets a horizontal offset for the tick label from the bottom of the tick.
OffsetY | Gets or sets a vertical offset for the tick label from the bottom of the tick.
Rotation | Gets or sets the angle for the tick label.
Size | Gets or sets the height of the actual ticks on axes, using plotted units.
TextHeight | Gets or sets the height of text (in plotted units) used to label ticks.
TextStyle | Gets or sets the text style for the tick label from the available AutoCAD text styles defined in the current... more
TickAndLabelStartElevation | Gets or sets a boolean value specifies that whether need to tick and label the start elevatioin.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Members
Legend
Legend
Property
public


AxisTitleStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Members
AxisTitleStyle Members Public Properties
AxisTitleStyle Members
Public Properties
Public Property | Description
Location | Gets or sets the location of the title in relation to the view grid.
OffsetX | Gets or sets a horizontal offset from the Location setting.
OffsetY | Gets or sets a vertical offset from the Location setting.
Rotation | Gets or sets the angle for the axis title.
Text | Gets or sets the title text for the axis.
TextHeight | Gets or sets the axis title text height (in plotted units).
TextStyle | Gets or sets the text style for the axis title from the available AutoCAD text styles defined in the current... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Members
Legend
Legend
Property
public


BandSetItem Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Members
BandSetItem Members Public Properties
BandSetItem Members
Public Properties
Public Property | Description
BandStyleId | Gets the object that identifies the style for the band type.
Gap | Gets or sets the distance between the current data band and the adjacent grid or data band.
Location | Gets the BandSetOptionsType enum value that identifies band location and display settings.
Weeding | Gets or sets the weeding value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Members
Legend
Legend
Property
public


BandSetItemCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Members
BandSetItemCollection Members Public Methods
BandSetItemCollection Members
Public Methods
Public Method | Description
Remove | Removes an item from the collection.
Swap | Swap two items in the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Members
Legend
Legend
Method
public


BandSetItemCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Members
BandSetItemCollection Members Public Properties
BandSetItemCollection Members
Public Properties
Public Property | Description
Count | Gets the number of band style sets in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Members
Legend
Legend
Property
public


BandStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Members
BandStyle Members Public Methods
BandStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Members
Legend
Legend
Method
public
virtual


BandStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Members
BandStyle Members Public Properties
BandStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Members
Legend
Legend
Property
public


BandStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class > BandStyleCollection Members
BandStyleCollection Members Public Methods
BandStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class > BandStyleCollection Members
Legend
Legend
Method
public
virtual


BandStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class > BandStyleCollection Members
BandStyleCollection Members Public Properties
BandStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class > BandStyleCollection Members
Legend
Legend
Property
public


BandStylesRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Members
BandStylesRoot Members Public Properties
BandStylesRoot Members
Public Properties
Public Property | Description
ProfileViewHorizontalGeometryBandStyles | Gets the collection of all profile view horizontal geometry band styles.
ProfileViewPipeNetworkBandStyles | Gets the collection of all profile view pipe network band styles.
ProfileViewProfileDataBandStyles | Gets the collection of all profile view profile data band styles.
ProfileViewSectionalDataBandStyles | Gets the collection of all profile view sectional data band styles.
ProfileViewSuperElevationBandStyles | Gets the collection of all profile view super elevation band styles.
ProfileViewVerticalGeometryBandStyles | Gets the collection of all profile view vertical geometry band styles.
SectionViewSectionDataBandStyles | Gets the collection of all section view section data band styles.
SectionViewSegmentsBandStyles | Gets the collection of all section view section segments band styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Members
Legend
Legend
Property
public


BandTickStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Members
BandTickStyle Members Public Properties
BandTickStyle Members
Public Properties
Public Property | Description
IncrementSmallTicksAtBottom | Gets or sets the boolean value that indicates whether to draw the tick(s) at the bottom of the selected type.... more
IncrementSmallTicksAtMiddle | Gets or sets the boolean value that indicates whether to draw the tick(s) in the middle of the selected type.... more
IncrementSmallTicksAtTop | Gets or sets the boolean value that indicates whether to draw the tick(s) at the top of the selected type.... more
IncrementTicksToFullHeight | Gets or sets the boolean value that indicates whether to draw the tick at the full band height.
SmallTicksAtBottomSize | Gets or sets the height, in drawing units, of small ticks located at the bottom of the data band.
SmallTicksAtMiddleSize | Gets or sets the height, in drawing units, of small ticks located at the middle of the data band.
SmallTicksAtTopSize | Gets or sets the height, in drawing units, of small ticks located at the top of the data band.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Members
Legend
Legend
Property
public


BaseLabelSetItem Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class > BaseLabelSetItem Members
BaseLabelSetItem Members Public Properties
BaseLabelSetItem Members
Public Properties
Public Property | Description
LabelStyleId | Gets or Sets the label style object id in the current label set item.
LabelStyleName | Gets or Sets the label style name in the current label set item.
LabelStyleType | Gets the label type in the current label set item.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class > BaseLabelSetItem Members
Legend
Legend
Property
public


BaseLabelSetStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Members
BaseLabelSetStyle Members Public Methods
BaseLabelSetStyle Members
Public Methods
Public Method | Description
Add | Overloaded
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
RemoveAt | Removes an label set item from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Members
Legend
Legend
Method
public
virtual


BaseLabelSetStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Members
BaseLabelSetStyle Members Public Properties
BaseLabelSetStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the number of label set items.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Members
Legend
Legend
Property
public


ColumnStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Members
ColumnStyle Members Public Properties
ColumnStyle Members
Public Properties
Public Property | Description
ColumnWidth | Gets or sets the column width of the column style, 0 represents auto width.
ContentJustification | Gets or sets the Content Justification of column style.
ContentString | Gets the display content of column style, this property is usable for most table columns, but for alignment segment table,... more
ContentStringFormatted | Gets the formatted content of column style, this property is usable for most table columns, but for alignment segment table,... more
HeaderJustification | Gets or sets the Header Justification of column style
HeaderString | Gets or sets the display header string of the column style.
HeaderStringFormatted | Gets or sets the formatted header string of the column style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Members
Legend
Legend
Property
public


ColumnStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Members
ColumnStyleCollection Members Public Methods
ColumnStyleCollection Members
Public Methods
Public Method | Description
Add | Adds a ColumnStyle to the collection using column width and value, 0 width for auto width.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes column style by index in the collection, the first column of the collection cannot be removed.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Members
Legend
Legend
Method
public
virtual


ColumnStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Members
ColumnStyleCollection Members Public Properties
ColumnStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of column styles in the collection.
default | Gets the column style at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Members
Legend
Legend
Property
public


Expression Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Members
Expression Members Public Properties
Expression Members
Public Properties
Public Property | Description
Description | Gets and sets the description of the Expression.
ExpressionString | Gets or sets the expression string of the Expression.
FormatResultAs | Gets or sets the format type of the expression result.
Name | Gets the name of the Expression.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Members
Legend
Legend
Property
public


ExpressionCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Members
ExpressionCollection Members Public Methods
ExpressionCollection Members
Public Methods
Public Method | Description
Add | Adds a Expression by specifying the name and expression string.
Clear | Removes all Expressions from the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an Expression from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Members
Legend
Legend
Method
public
virtual


ExpressionCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Members
ExpressionCollection Members Public Properties
ExpressionCollection Members
Public Properties
Public Property | Description
Count | Gets the number of Expression objects in the collection.
default | Gets the Expression at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Members
Legend
Legend
Property
public


FeatureLineStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Members
FeatureLineStyle Members Public Methods
FeatureLineStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the FeatureLine component.
GetFeatureLineDisplayStyleModel | Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.
GetFeatureLineDisplayStylePlan | Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.
GetSectionMarkerDisplayStyleSection | Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Members
Legend
Legend
Method
public
virtual


FeatureLineStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Members
FeatureLineStyle Members Public Properties
FeatureLineStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
FeatureLineDisplayStyleModel | Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.
FeatureLineDisplayStylePlan | Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ProfileBeginningVertexMarkerStyleId | Gets or sets the object id of the profile beginning vertex marker style for the feature line style.
ProfileBeginningVertexMarkerStyleName | Gets or sets the name of the profile beginning vertex marker style for the feature line style.
ProfileEndingVertexMarkerStyleId | Gets or sets the object id of the profile ending vertex marker style for the feature line style.
ProfileEndingVertexMarkerStyleName | Gets or sets the name of the profile ending vertex marker style for the feature line style.
ProfileInternalVertexMarkerStyleId | Gets or sets the object id of the profile internal vertex marker style for the feature line style.
ProfileInternalVertexMarkerStyleName | Gets or sets the name of the profile internal vertex marker style for the feature line style.
SectionMarkerDisplayStyleSection | Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.
SectionMarkerStyleId | Gets or sets the object id of the marker style for the feature line style.
SectionMarkerStyleName | Gets or sets the name of the marker style for the feature line style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Members
Legend
Legend
Property
public


FeatureLineStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class > FeatureLineStyleCollection Members
FeatureLineStyleCollection Members Public Methods
FeatureLineStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class > FeatureLineStyleCollection Members
Legend
Legend
Method
public
virtual


FeatureLineStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class > FeatureLineStyleCollection Members
FeatureLineStyleCollection Members Public Properties
FeatureLineStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class > FeatureLineStyleCollection Members
Legend
Legend
Property
public


GraphStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Members
GraphStyle Members Public Properties
GraphStyle Members
Public Properties
Public Property | Description
CurrentHorizontalScale | Gets the plotted size of graph horizontal scale from draw setting.
Direction | Gets or sets the direction of the profile in the profile view grid.
TitleStyle | Gets the style object that specifies graph title text display properties for cross section and profile views.
VerticalExaggeration | Gets or sets the graph vertical exaggeration factor.
VerticalScale | Gets or sets the vertical scale of the profile view or section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Members
Legend
Legend
Property
public


GraphTitleStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Members
GraphTitleStyle Members Public Properties
GraphTitleStyle Members
Public Properties
Public Property | Description
Border | Gets or sets a bool value that specifies whether a border line is drawn around the title block.
BorderGap | Gets or sets the gap between the border and graph title text in plotted units.
Justification | Gets or sets the justification (alignment) of the title.
Location | Gets or sets the location of the title in relation to the view grid.
OffsetX | Gets or sets a horizontal offset from the position set by the Location and Justification values.
OffsetY | Gets or sets a vertical offset from the position set by Location and Justification values.
Text | Gets or sets the graph title text.
TextHeight | Gets or sets the current text height in drawing units.
TextStyle | Gets or sets the text style for the graph title from the available AutoCAD text styles defined in the current... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Members
Legend
Legend
Property
public


GridOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class > GridOptions Members
GridOptions Members Public Properties
GridOptions Members
Public Properties
Public Property | Description
ClipToHighestProfile | Specifies whether vertical or horizontal profile view grid lines are drawn to the highest of all displayed profiles.
OmitGridInPaddingAreas | Specifies whether vertical or horizontal profile view grid lines are not drawn in the padding areas.
UseClipGrid | Specifies whether to clip a vertical or horizontal grid lines at a selected profile..


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class > GridOptions Members
Legend
Legend
Property
public


GridStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Members
GridStyle Members Public Properties
GridStyle Members
Public Properties
Public Property | Description
AxisOffsetAbove | Gets or sets the distance to offset the axis above the vertical extent.
AxisOffsetBottom | Gets or sets the distance to offset the axis below the vertical extent.
AxisOffsetLeft | Gets or sets the distance to offset the axis to the left of the horizontal extent.
AxisOffsetRight | Gets or sets the distance to offset the horizontal axis to the right of the horizontal extent.
GridPaddingAbove | Gets or sets the number of grid blocks that the view extends above the maximum profile elevation.
GridPaddingBottom | Gets or sets the number of grid blocks that the view extends below the datum or minimum profile elevation.
GridPaddingLeft | Gets or sets the number of major grids to place before the left-most station value of the alignment.
GridPaddingRight | Gets or sets the number of major grids to place after the right-most station value of the alignment.
HorizontalGridOptions | Gets the horizontal clipping options on the profile view or section view grid.
VerticalGridOptions | Gets the vertical clipping options on the profile view or section view grid.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Members
Legend
Legend
Property
public


LabelSetStylesRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class > LabelSetStylesRoot Members
LabelSetStylesRoot Members Public Properties
LabelSetStylesRoot Members
Public Properties
Public Property | Description
AlignmentLabelSetStyles | Gets the collection of all alignment label set styles in the database.
ProfileLabelSetStyles | Gets the collection of all profile label set styles in the database.
SectionLabelSetStyles | Gets the collection of all section label set styles in the database.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class > LabelSetStylesRoot Members
Legend
Legend
Property
public


LabelStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Members
LabelStyle Members Public Methods
LabelStyle Members
Public Methods
Public Method | Description
AddChild | Add a new child label style to the current label style's node with the default setings' value.
AddComponent | Add a valid component into the label style.
AddReferenceTextComponent | Add ReferenceText component into the label style.
AddTextForEachComponent | Add TextForEach component into the label style.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetComponents | Gets the objectId collection of label style components that specify the appearance and behavior of labels.
GetComponentsCount | Overloaded
GetComponentsDrawOrder | Gets the supported components in draw order, component at the end(as UI list on the top) is drawn last.
IsSupportedComponent | Gets an bool value specifies whether the component type is supported in this label style.
RemoveAllDescendants | Removes all the descendants under the current labelstyle node.
RemoveChild | Overloaded
RemoveComponent | Remove a component from the label style.
SetComponentsDrawOrder | Sets the supported components' draw order.
SwitchComponentsDrawOrder | Switch the supported components' draw order by index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Members
Legend
Legend
Method
public
virtual


LabelStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Members
LabelStyle Members Public Properties
LabelStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
ChildrenCount | Gets the number of child label style under the current labelstyle node.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the child lable style by name.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ParentLabelStyleId | Gets the object id of parent lable style .
Properties | Gets the leader related properties of the default label style settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Members
Legend
Legend
Property
public


LabelStyleBase Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Members
LabelStyleBase Members Public Properties
LabelStyleBase Members
Public Properties
Public Property | Description
Behavior | Gets the behavior related properties of the default label style.
DraggedStateComponents | Gets dragged state components related properties of the default label style.
Label | Gets the label related properties of the default label style.
Leader | Gets the leader related properties of the default label style.
PlanReadability | Gets the plan readability related properties of the default label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Members
Legend
Legend
Property
public


LabelStyleBase::BaseBehavior Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class > LabelStyleBase::BaseBehavior Members
LabelStyleBase::BaseBehavior Members Public Properties
LabelStyleBase::BaseBehavior Members
Public Properties
Public Property | Description
InsertOption | Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.
InsideCurveOption | Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.
OrientationReference | Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class > LabelStyleBase::BaseBehavior Members
Legend
Legend
Property
public


LabelStyleBase::BaseDraggedStateComponents Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Members
LabelStyleBase::BaseDraggedStateComponents Members Public Properties
LabelStyleBase::BaseDraggedStateComponents Members
Public Properties
Public Property | Description
BorderType | Gets the shape of the border, either rounded or rectangular.
BorderVisibility | Gets the boolean value that specifies whether a border is visible for dragged labels.
Color | Gets the color for dragged components.
DisplayType | Gets the enum value that specifies how label content is displayed after it is dragged from its default position.
Gap | Gets the distance between the leader and the label text.
LeaderAttachment | Gets the location where a leader hook is drawn in relation to label content.
LeaderJustification | Gets the boolean value that specifies the justification of label text in relation to the leader.
Linetype | Gets the linetype for dragged components.
Lineweight | Gets the linetype for dragged components.
TextHeight | Gets the plotted height for all text components.
UseBackgroundMask | Gets the boolean value that specifies whether use background mask when drawing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Members
Legend
Legend
Property
public


LabelStyleBase::BaseLabel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Members
LabelStyleBase::BaseLabel Members Public Properties
LabelStyleBase::BaseLabel Members
Public Properties
Public Property | Description
DisplayMode | Gets the display mode for all label styles in a drawing.
Layer | Gets the default layer for all label styles in a drawing.
TextStyle | Gets the default text style for all label text components in a drawing.
Visibility | Gets the boolean value that specifies visibility of labels in the drawing (independent of layer).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Members
Legend
Legend
Property
public


LabelStyleBase::BaseLeader Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Members
LabelStyleBase::BaseLeader Members Public Properties
LabelStyleBase::BaseLeader Members
Public Properties
Public Property | Description
ArrowheadSize | Gets the size of the arrow head.
ArrowheadStyle | Gets the arrow head style for a leader.
Color | Gets the color for leaders.
Linetype | Gets the linetype for leaders.
Lineweight | Gets the lineweight for leaders.
Shape | Gets the enum value that specifies the shape of the leader.
Visibility | Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Members
Legend
Legend
Property
public


LabelStyleBase::BasePlanReadability Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class > LabelStyleBase::BasePlanReadability Members
LabelStyleBase::BasePlanReadability Members Public Properties
LabelStyleBase::BasePlanReadability Members
Public Properties
Public Property | Description
FlipAnchorsWithText | Gets the boolean that specifies whether flip anchors with text.
PlanReadable | Gets the boolean that specifies whether all text components in labels can be read easily in plan view.
PlanReadableBias | Gets the angle at which label text flips 180 degrees to remain plan readable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class > LabelStyleBase::BasePlanReadability Members
Legend
Legend
Property
public


LabelStyleBlockComponent::StyleBlock Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Members
LabelStyleBlockComponent::StyleBlock Members Public Properties
LabelStyleBlockComponent::StyleBlock Members
Public Properties
Public Property | Description
Attachment | Gets the location on the block component that is attached to the anchor point
BlockHeight | Gets the height to whick the block is scaled to fit.
BlockName | Gets the block to use for the block component.
Color | Gets the color of block component.
Linetype | Gets the line type of the block component.
Lineweight | Gets the line weight of the block component.
RotationAngle | Gets the angle for block component.
XOffset | Gets the offset distance between the attachment point and the anchor point in the X direction
YOffset | Gets the offset distance between the attachment point and the anchor point in the Y direction


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Members
Legend
Legend
Property
public


LabelStyleBlockComponent::StyleGeneral Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Members
LabelStyleBlockComponent::StyleGeneral Members Public Properties
LabelStyleBlockComponent::StyleGeneral Members
Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the block component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the block component is attached.
Name | Gets the name for block component.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the block component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Members
Legend
Legend
Property
public


LabelStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Members
LabelStyleCollection Members Public Methods
LabelStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Members
Legend
Legend
Method
public
virtual


LabelStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Members
LabelStyleCollection Members Public Properties
LabelStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.
DefaultLabelStyle | Gets the default vaules of label styles.
Expressions | This is Expressions, a member of class LabelStyleCollection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Members
Legend
Legend
Property
public


LabelStyleDefault::DefaultBehavior Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class > LabelStyleDefault::DefaultBehavior Members
LabelStyleDefault::DefaultBehavior Members Public Properties
LabelStyleDefault::DefaultBehavior Members
Public Properties
Public Property | Description
InsertOption | Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.
InsideCurveOption | Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.
OrientationReference | Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class > LabelStyleDefault::DefaultBehavior Members
Legend
Legend
Property
public


LabelStyleDefault::DefaultComponents Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Members
LabelStyleDefault::DefaultComponents Members Public Properties
LabelStyleDefault::DefaultComponents Members
Public Properties
Public Property | Description
Color | Gets the color for label components.
Linetype | Gets the linetype for label components.
Lineweight | Gets the lineweight for label components.
TextHeight | Gets the plotted height for label text.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Members
Legend
Legend
Property
public


LabelStyleDefault::DefaultDraggedStateComponents Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Members
LabelStyleDefault::DefaultDraggedStateComponents Members Public Properties
LabelStyleDefault::DefaultDraggedStateComponents Members
Public Properties
Public Property | Description
BorderType | Gets the shape of the border, either rounded or rectangular.
BorderVisibility | Gets the boolean value that specifies whether a border is visible for dragged labels.
Color | Gets the color for dragged components.
DisplayType | Gets the enum value that specifies how label content is displayed after it is dragged from its default position.
Gap | Gets the distance between the leader and the label text.
LeaderAttachment | Gets the location where a leader hook is drawn in relation to label content.
LeaderJustification | Gets the boolean value that specifies the justification of label text in relation to the leader.
Linetype | Gets the linetype for dragged components.
Lineweight | Gets the lineweight for dragged components.
TextHeight | Gets the plotted height for all text components.
UseBackgroundMask | Gets the boolean value that specifies whether use background mask when drawing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Members
Legend
Legend
Property
public


LabelStyleDefault::DefaultLabel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class > LabelStyleDefault::DefaultLabel Members
LabelStyleDefault::DefaultLabel Members Public Properties
LabelStyleDefault::DefaultLabel Members
Public Properties
Public Property | Description
Layer | Gets the default layer for all label styles in a drawing.
TextStyle | Gets the default text style for all label text components in a drawing.
Visibility | Gets the boolean value that specifies visibility of labels in the drawing (independent of layer settings).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class > LabelStyleDefault::DefaultLabel Members
Legend
Legend
Property
public


LabelStyleDefault::DefaultLeader Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Members
LabelStyleDefault::DefaultLeader Members Public Properties
LabelStyleDefault::DefaultLeader Members
Public Properties
Public Property | Description
ArrowheadSize | Gets the size of the arrow head.
ArrowheadStyle | Gets the arrow head style for a leader.
Color | Gets the color for leaders.
Linetype | Gets the linetype for leaders.
Lineweight | Gets the lineweight for leaders.
Shape | Gets the enum value that specifies the shape of the leader.
Visibility | Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Members
Legend
Legend
Property
public


LabelStyleDefault::DefaultPlanReadability Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class > LabelStyleDefault::DefaultPlanReadability Members
LabelStyleDefault::DefaultPlanReadability Members Public Properties
LabelStyleDefault::DefaultPlanReadability Members
Public Properties
Public Property | Description
FlipAnchorsWithText | Gets the boolean that specifies whether flip anchors with text.
PlanReadable | Gets the boolean that specifies whether all text components in labels can be read easily in plan view.
PlanReadableBias | Gets the angle at which label text flips 180 degrees to remain plan readable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class > LabelStyleDefault::DefaultPlanReadability Members
Legend
Legend
Property
public


LabelStyleDirectionArrowComponent::StyleDirectionArrow Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Members
LabelStyleDirectionArrowComponent::StyleDirectionArrow Members Public Properties
LabelStyleDirectionArrowComponent::StyleDirectionArrow Members
Public Properties
Public Property | Description
ArrowheadSize | Gets the size of arrow head in plot unit.
ArrowheadStyle | Gets the arrow head style.
Color | Gets the color of direction arrow component.
FixedLength | Gets whether the arrow length is controlled by the length setting or by the length of the object being labeled.... more
LengthOrMinimumLength | Gets the length of direction arrow.
Linetype | Gets the line type of the direction arrow component.
Lineweight | Gets the line weight of the direction arrow component.
RotationAngle | Gets the angle for direction arrow component.
XOffset | Gets the offset distance between the mid-point of the direction arrow and the anchor component in the X direction.
YOffset | Gets the offset distance between the mid-point of the direction arrow and the anchor component in the Y direction.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Members
Legend
Legend
Property
public


LabelStyleDirectionArrowComponent::StyleGeneral Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Members
LabelStyleDirectionArrowComponent::StyleGeneral Members Public Properties
LabelStyleDirectionArrowComponent::StyleGeneral Members
Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the direction arrow component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the direction arrow component is attached.
Name | Gets the name for direction arrow component.
SpanOutsideSegments | Gets whether this component refers to the properties of outside segments.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the direction arrow component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Members
Legend
Legend
Property
public


LabelStyleLineComponent::StyleGeneral Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Members
LabelStyleLineComponent::StyleGeneral Members Public Properties
LabelStyleLineComponent::StyleGeneral Members
Public Properties
Public Property | Description
EndAnchorPoint | Gets the location on the end point anchor component where the end point of the line component is attached.
EndPointAnchorComponent | Gets a reference object for positioning the end point of the line component.
EndPointAnchorPoint | Gets the location on the end point anchor component where the end point of the line component is attached.
Name | Gets the name for line component.
StartAnchorPoint | Gets the location on the start point anchor component where the start point of the line component is attached.
StartPointAnchorComponent | Gets a reference object for positioning the start point of the line component.
StartPointAnchorPoint | Gets the location on the start point anchor component where the start point of the line component is attached.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
UseEndPointAnchor | Gets the method for defining the line component.
Visible | Gets whether the line component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Members
Legend
Legend
Property
public


LabelStyleLineComponent::StyleLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Members
LabelStyleLineComponent::StyleLine Members Public Properties
LabelStyleLineComponent::StyleLine Members
Public Properties
Public Property | Description
Angle | Gets the angle of the line component from the start point.
Color | Gets the color of the line component.
EndPointXOffset | Gets the offsets the line end point from the end point anchor point in the X direction.
EndPointYOffset | Gets the offsets the line end point from the end point anchor point in the Y direction.
Length | Gets the length of line component.
Linetype | Gets the line type of the line component.
Lineweight | Gets the line weight of the line component.
StartPointXOffset | Gets the offsets the line start point from the start point anchor point in the X direction.
StartPointYOffset | Gets the offsets the line start point from the start point anchor point in the Y direction.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Members
Legend
Legend
Property
public


LabelStylesNode Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesNode Class > LabelStylesNode Members
LabelStylesNode Members Public Properties
LabelStylesNode Members
Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesNode Class > LabelStylesNode Members
Legend
Legend
Property
public


LabelStylesRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Members
LabelStylesRoot Members Public Properties
LabelStylesRoot Members
Public Properties
Public Property | Description
AlignmentLabelStyles | Gets the root of all alignment label styles.
DefaultLabelStyle | Gets the default vaules of label styles.
GeneralCurveLabelStyles | Gets the collection of all general curve label styles.
GeneralLineLabelStyles | Gets the collection of all general line label styles.
GeneralLinkLabelStyles | Gets the collection of all general link label styles.
GeneralMarkerLabelStyles | Gets the collection of all general marker label styles.
GeneralNoteLabelStyles | Gets the collection of all general note label styles.
GeneralShapeLabelStyles | Gets the collection of all general shape label styles.
IntersectionLabelStyles | Gets the root of all intersection label styles.
MatchLineLabelStyles | Gets the root of all match line label styles.
ParcelLabelStyles | Gets the root of all parcel label styles.
PipeLabelStyles | Gets the root of all pipe label styles.
PointLabelStyles | Gets the root of all point label styles.
ProfileLabelStyles | Gets the root of all profile label styles.
ProfileViewLabelStyles | Gets the root of all profile view label styles.
ProjectionLabelStyles | Gets the root of all projection label styles.
SampleLineLabelStyles | Gets the root of all sample line label styles.
SectionLabelStyles | Gets the root of all section label styles.
SectionViewLabelStyles | Gets the root of all section view label styles.
StructureLabelStyles | Gets the root of all structure label styles.
SurfaceLabelStyles | Gets the root of all surface label styles.
ViewFrameLabelStyles | Gets the root of all view frame label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Members
Legend
Legend
Property
public


LabelStyleTextComponent Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class > LabelStyleTextComponent Members
LabelStyleTextComponent Members Public Properties
LabelStyleTextComponent Members
Public Properties
Public Property | Description
Border | Gets the border style settings.
General | Gets the general style settings.
Text | Gets the text style settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class > LabelStyleTextComponent Members
Legend
Legend
Property
public


LabelStyleTextComponent::StyleBorder Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Members
LabelStyleTextComponent::StyleBorder Members Public Properties
LabelStyleTextComponent::StyleBorder Members
Public Properties
Public Property | Description
BackgroundMask | Gets whether use background mask when drawing.
BorderType | Gets the shape of the border around the entire label when the label has been dragged from its default position.... more
Color | Gets the color for a new text border or changes the color of an existing border.
Gap | Gets the gap, in plotted units, between the label text and the boarder.
Linetype | Gets the linetype for a new text border or changes an existing border linetype.
Lineweight | Gets the lineweight for a new text border or changes the lineweight of an existing border.
Visible | Gets whether to display a border around the text component.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Members
Legend
Legend
Property
public


LabelStyleTextComponent::StyleGeneral Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Members
LabelStyleTextComponent::StyleGeneral Members Public Properties
LabelStyleTextComponent::StyleGeneral Members
Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the text component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the text component is attached.
Name | Gets the name for text component.
SpanOutsideSegments | Gets whether this component refers to the properties of outside segments.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the text component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Members
Legend
Legend
Property
public


LabelStyleTextComponent::StyleText Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Members
LabelStyleTextComponent::StyleText Members Public Properties
LabelStyleTextComponent::StyleText Members
Public Properties
Public Property | Description
Angle | Gets the angle of the text comonent from the start point.
Attachment | Gets the point, calculated based on a rectangle that encompasses the text component, where the text component is attached to... more
Color | Gets the color of the text component.
Contents | Gets the contents for text component.
Height | Gets the height for text component.
Lineweight | Gets the line weight of the line component.
XOffset | Gets the text component away from an object in the X direction.
YOffset | Gets the text component away from an object in the Y direction.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Members
Legend
Legend
Property
public


LabelStyleTickComponent::StyleGeneral Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class > LabelStyleTickComponent::StyleGeneral Members
LabelStyleTickComponent::StyleGeneral Members Public Properties
LabelStyleTickComponent::StyleGeneral Members
Public Properties
Public Property | Description
Name | Gets the name for tick component.
Visible | Gets whether the tick component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class > LabelStyleTickComponent::StyleGeneral Members
Legend
Legend
Property
public


LabelStyleTickComponent::StyleTick Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Members
LabelStyleTickComponent::StyleTick Members Public Properties
LabelStyleTickComponent::StyleTick Members
Public Properties
Public Property | Description
AlignWithObject | Gets whether the tick insert at an angle relative the object.
BlockHeight | Gets the height to whick the tick block is scaled to fit.
BlockName | Gets the block to use for the tick component.
Color | Gets the color of the tick component.
Linetype | Gets the line type of the tick component.
Lineweight | Gets the line weight of the tick component.
RotationAngle | Gets the angle for tick component.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Members
Legend
Legend
Property
public


MarkerStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Members
MarkerStyle Members Public Methods
MarkerStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetMarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStyleProfile | Gets the marker display style for profile views.
GetMarkerDisplayStyleSection | Gets the marker display style for section views.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Members
Legend
Legend
Method
public
virtual


MarkerStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Members
MarkerStyle Members Public Properties
MarkerStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
CustomMarkerStyle | Gets or sets a long value specifying a custom marker style.
CustomMarkerSuperimposeStyle | Gets or sets the CustomMarkerSuperimposeType enum value that specifies the shape superimposed on the custom point style marker as either... more
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStyleProfile | Gets the marker display style for profile views.
MarkerDisplayStyleSection | Gets the marker display style for section views.
MarkerFixedScale | Gets or sets a fixed scale used to scale the point symbol.
MarkerRotationAngle | Gets or sets the marker's rotation angle.
MarkerSize | Gets or sets the marker size in drawing units.
MarkerSymbolName | Gets or sets a string value that represents the marker symbol block name.
MarkerType | Gets or sets the marker type (point, symbol, vertical line, or custom).
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Orientation | Gets or sets the MarkerOrientationType enum value that defines how the marker rotation angle is applied.
SizeType | Gets or sets the MarkerSizeType enum value that defines how the marker is sized, such as relative to screen, fixed... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Members
Legend
Legend
Property
public


MarkerStyleBase Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Members
MarkerStyleBase Members Public Methods
MarkerStyleBase Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetMarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Members
Legend
Legend
Method
public
virtual


MarkerStyleBase Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Members
MarkerStyleBase Members Public Properties
MarkerStyleBase Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
CustomMarkerStyle | Gets or sets a long value specifying a custom marker style.
CustomMarkerSuperimposeStyle | Gets or sets the CustomMarkerSuperimposeType enum value that specifies the shape superimposed on the custom point style marker as either... more
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
MarkerFixedScale | Gets or sets a fixed scale used to scale the point symbol.
MarkerRotationAngle | Gets or sets the marker's rotation angle.
MarkerSize | Gets or sets the marker size in drawing units.
MarkerSymbolName | Gets or sets a string value that represents the marker symbol block name.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Orientation | Gets or sets the MarkerOrientationType enum value that defines how the marker rotation angle is applied.
SizeType | Gets or sets the MarkerSizeType enum value that defines how the marker is sized, such as relative to screen, fixed... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Members
Legend
Legend
Property
public


MarkerStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class > MarkerStyleCollection Members
MarkerStyleCollection Members Public Methods
MarkerStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class > MarkerStyleCollection Members
Legend
Legend
Method
public
virtual


MarkerStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class > MarkerStyleCollection Members
MarkerStyleCollection Members Public Properties
MarkerStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class > MarkerStyleCollection Members
Legend
Legend
Property
public


ProjectionProfileOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Members
ProjectionProfileOptions Members Public Properties
ProjectionProfileOptions Members
Public Properties
Public Property | Description
AutoCAD3dPolylineBeginVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline beginning vertex marker style.
AutoCAD3dPolylineBeginVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline beginning vertex marker style's name.
AutoCAD3dPolylineEndVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline ending vertex marker style.
AutoCAD3dPolylineEndVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline ending vertex marker style's name.
AutoCAD3dPolylineInternalVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline internal vertex marker style.
AutoCAD3dPolylineInternalVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline internal vertex marker style's name.
AutoCADBlockDisplayOptions | Gets or sets the AutoCAD block display options.
AutoCADBlockMarkerStyleId | Gets or sets the AutoCAD block marker style.
AutoCADBlockMarkerStyleName | Gets or sets the AutoCAD block marker style's name.
AutoCADBlockSymbolBlockId | Gets or sets the AutoCAD block symbol block.
AutoCADBlockSymbolBlockName | Gets or sets the AutoCAD block symbol block's name.
AutoCADPointDisplayOptions | Gets or sets AutoCAD point display options.
AutoCADPointMarkerStyleId | Gets or sets the AutoCAD point marker style.
AutoCADPointMarkerStyleName | Gets or sets the AutoCAD point marker style's name.
AutoCADSolidDisplayOptions | Gets or sets AutoCAD solid display options.
AutoCADSolidMarkerStyleId | Gets or sets the AutoCAD solid marker style.
AutoCADSolidMarkerStyleName | Gets or sets the AutoCAD solid marker style's name.
MultiViewBlockDirection | Gets or sets the multi-view block direction.
MultiViewBlockDisplayOptions | Gets or sets the multi-view block display options.
MultiViewBlockDisplayRepresentationId | Gets or sets the multi-view block display representation.
MultiViewBlockDisplayRepresentationName | Gets or sets the name of the multi-view block display representation.
MultiViewBlockMarkerStyleId | Gets or sets the multi-view block marker style.
MultiViewBlockMarkerStyleName | Gets or sets the multi-view block marker style's name.
MultiViewBlockSymbolBlockId | Gets or sets the multi-view block symbol block.
MultiViewBlockSymbolBlockName | Gets or sets the name of the multi-view block symbol block.
VerticallyExaggerateBlocks | Gets or sets whether to vertically exaggerate blocks.
VerticallyExaggerateMultiViewBlocks | Gets or sets whether to vetically exaggerate multi-view blocks.
VerticallyExaggerateSolids | Gets or sets whether to vertically exaggerate solids.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Members
Legend
Legend
Property
public


ProjectionSectionOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Members
ProjectionSectionOptions Members Public Properties
ProjectionSectionOptions Members
Public Properties
Public Property | Description
AutoCAD3dPolylineCrossingMarkerStyleId | Gets AutoCAD 3D polyline crossing marker style.
AutoCAD3dPolylineCrossingMarkerStyleName | Gets AutoCAD 3D polyline crossing marker style's.
AutoCADBlockDisplayOptions | Gets AutoCAD block display options.
AutoCADBlockMarkerStyleId | Gets AutoCAD block marker style.
AutoCADBlockMarkerStyleName | Gets AutoCAD block marker style's name.
AutoCADBlockSymbolBlockId | Gets AutoCAD block symbol block.
AutoCADBlockSymbolBlockName | Gets AutoCAD block symbol block's name.
AutoCADPointDisplayOptions | Gets AutoCAD point display options.
AutoCADPointMarkerStyleId | Gets AutoCAD point marker style.
AutoCADPointMarkerStyleName | Gets AutoCAD point marker style's name.
AutoCADSolidDisplayOptions | Gets AutoCAD solid display options.
AutoCADSolidMarkerStyleId | Gets AutoCAD solid marker style.
AutoCADSolidMarkerStyleName | Gets AutoCAD solid marker style's name.
MultiViewBlockDirection | Gets multi-view block direction.
MultiViewBlockDisplayOptions | Gets multi-view block display options.
MultiViewBlockDisplayRepresentationId | Gets multi-view block display representation.
MultiViewBlockDisplayRepresentationName | Gets multi-view block display representation's name.
MultiViewBlockMarkerStyleId | Gets multi-view block marker style.
MultiViewBlockMarkerStyleName | Gets multi-view block marker style's name.
MultiViewBlockSymbolBlockId | Gets multi-view block symbol block.
MultiViewBlockSymbolBlockName | Gets multi-view block symbol block's name.
VerticallyExaggerateBlocks | Gets vertically exaggerate blocks.
VerticallyExaggerateMultiViewBlocks | Gets vertically exaggerate multi-view blocks.
VerticallyExaggerateSolids | Gets vertically exaggerate solids.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Members
Legend
Legend
Property
public


ProjectionStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Members
ProjectionStyle Members Public Methods
ProjectionStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Members
Legend
Legend
Method
public
virtual


ProjectionStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Members
ProjectionStyle Members Public Properties
ProjectionStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ProfileOptions | Gets the ProjectionProfileOptions object that specifies profile options.
SectionOptions | Gets the ProjectionSectionOptions object that specifies section options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Members
Legend
Legend
Property
public


ProjectionStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class > ProjectionStyleCollection Members
ProjectionStyleCollection Members Public Methods
ProjectionStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class > ProjectionStyleCollection Members
Legend
Legend
Method
public
virtual


ProjectionStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class > ProjectionStyleCollection Members
ProjectionStyleCollection Members Public Properties
ProjectionStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class > ProjectionStyleCollection Members
Legend
Legend
Property
public


SegmentColumnStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Members
SegmentColumnStyle Members Public Methods
SegmentColumnStyle Members
Public Methods
Public Method | Description
GetContentString | Gets the specified display content of segment column style.
GetContentStringFormatted | Gets the specified formatted content of segment column style.
SetContentString | Sets the specified display content of segment column style.
SetContentStringFormatted | Sets the specified formatted content of segment column style.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Members
Legend
Legend
Method
public


SegmentColumnStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Members
SegmentColumnStyle Members Public Properties
SegmentColumnStyle Members
Public Properties
Public Property | Description
ColumnWidth | Gets or sets the column width of the column style, 0 represents auto width.
ContentJustification | Gets or sets the Content Justification of column style.
ContentString | Gets the display content of column style, this property is usable for most table columns, but for alignment segment table,... more
ContentStringFormatted | Gets the formatted content of column style, this property is usable for most table columns, but for alignment segment table,... more
HeaderJustification | Gets or sets the Header Justification of column style
HeaderString | Gets or sets the display header string of the column style.
HeaderStringFormatted | Gets or sets the formatted header string of the column style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Members
Legend
Legend
Property
public


StructureColumnComponentData Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class > StructureColumnComponentData Members
StructureColumnComponentData Members Public Properties
StructureColumnComponentData Members
Public Properties
Public Property | Description
ComponentType | Gets the type of the table cell component data.
Content | Gets or sets the content of the tabel cell component data.
Name | Gets or sets the name of the tabel cell component data.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class > StructureColumnComponentData Members
Legend
Legend
Property
public


StructureColumnComponents Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Members
StructureColumnComponents Members Public Methods
StructureColumnComponents Members
Public Methods
Public Method | Description
AddComponent | Adds a table cell component data to the collection with the default Content("Structure Text") and Justification(Center).
Clear | Removes all the table cell component data from the collection.
RemoveAt | Overloaded
SwitchComponentsOrder | Switch the component data order by index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Members
Legend
Legend
Method
public


StructureColumnComponents Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Members
StructureColumnComponents Members Public Properties
StructureColumnComponents Members
Public Properties
Public Property | Description
Count | Gets the number of table cell component datas in the collection.
default | Gets the table cell component data at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Members
Legend
Legend
Property
public


StructureColumnStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Members
StructureColumnStyle Members Public Methods
StructureColumnStyle Members
Public Methods
Public Method | Description
GetComponents | Gets the table cell components from the structure column style.
SetComponents | Sets the table cell components to the structure column style.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Members
Legend
Legend
Method
public


StructureColumnStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Members
StructureColumnStyle Members Public Properties
StructureColumnStyle Members
Public Properties
Public Property | Description
ColumnWidth | Gets or sets the column width of the column style, 0 represents auto width.
ContentJustification | Gets or sets the Content Justification of column style.
ContentString | Gets the display content of column style, this property is usable for most table columns, but for alignment segment table,... more
ContentStringFormatted | Gets the formatted content of column style, this property is usable for most table columns, but for alignment segment table,... more
HeaderJustification | Gets or sets the Header Justification of column style
HeaderString | Gets or sets the display header string of the column style.
HeaderStringFormatted | Gets or sets the formatted header string of the column style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Members
Legend
Legend
Property
public


StyleBase Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Members
StyleBase Members Public Methods
StyleBase Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Members
Legend
Legend
Method
public
virtual


StyleBase Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Members
StyleBase Members Public Properties
StyleBase Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Members
Legend
Legend
Property
public


StyleCollectionBase Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Members
StyleCollectionBase Members Public Methods
StyleCollectionBase Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Members
Legend
Legend
Method
public
virtual


StyleCollectionBase Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Members
StyleCollectionBase Members Public Properties
StyleCollectionBase Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Members
Legend
Legend
Property
public


StylesRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Members
StylesRoot Members Public Properties
StylesRoot Members
Public Properties
Public Property | Description
AlignmentDesignCheckSets | Gets the collection of alignment design check set in the database.
AlignmentStyles | Gets the collection of all alignment styles in the database.
AssemblyStyles | Gets the collection of AssemblyStyle objects in the database.
BandStyles | Gets the root object of Civil 3D band styles.
BuildingSiteStyles | Gets the collection of BuildingSiteStyle objects in the database.
CodeSetStyles | Gets the collection of CodeSetStyle objects in the database.
CorridorStyles | Gets the collection of all corridor styles in the database.
FeatureLineStyles | Gets the collection of all feature line styles in the database.
GradingCriteriaSets | Gets the collection of GradingCriteriaSet objects in the database.
GradingStyles | Gets the collection of all grading styles in the database.
GroupPlotStyles | Gets the collection of all group plot styles in the database.
InterferenceStyles | Gets the collection of all interference styles in the database.
IntersectionStyles | Gets the collection of IntersectionStyle objects in the database.
LabelSetStyles | Gets the root object of Civil 3D label set styles.
LabelStyles | Gets the root object of Civil 3D label styles.
LinkStyles | Gets the collection of LinkStyle objects in the database.
MarkerStyles | Gets the root object of Civil 3D mark styles.
MassHaulLineStyles | Gets the collection of MassHaulLineStyle objects in the database.
MassHaulViewStyles | Gets the collection of MassHaulViewStyle objects in the database.
MatchLineStyles | Gets the collection of all match line styles in the database.
ParcelStyles | Gets the collection of all parcel styles in the database.
PartsListSet | Gets the collection of parts list in the database.
PipeRuleSetStyles | Gets the collection of all pipe rule set styles in the database.
PipeStyles | Gets the collection of all pipe styles in the database.
PointStyles | Gets the collection of all point styles in the database.
ProfileDesignCheckSets | Gets the collection of profile design check set in the database.
ProfileStyles | Gets the collection of all profile styles in the database.
ProfileViewBandSetStyles | Gets the collection of all profile view band set styles in the database.
ProfileViewStyles | Gets the collection of all profile view styles in the database.
ProjectionStyles | Gets the collection of ProjectionStyle objects in the database.
QuantityTakeoffCriterias | Gets the collection of QuantityTakeoffCriteria objects in the database.
SampleLineStyles | Gets the collection of all sample line styles in the database.
SectionStyles | Gets the collection of all section styles in the database.
SectionViewBandSetStyles | Gets the collection of all section view band set styles in the database.
SectionViewStyles | Gets the collection of all section view styles in the database.
ShapeStyles | Gets the collection of ShapeStyle objects in the database.
SheetStyles | Gets the collection of all sheet styles in the database.
SlopePatternStyles | Gets the collection of SlopePatternStyle objects in the database.
StructureRuleSetStyles | Gets the collection of all structure rule set styles in the database.
StructureStyles | Gets the collection of all structure styles in the database.
SurfaceStyles | Gets the collection of all surface styles in the database.
SurveyFigureStyles | Gets the collection of SurveyFigureStyle objects in the database.
SurveyNetworkStyles | Gets the collection of SurveyNetworkStyle objects in the database.
TableStyles | Gets the root object of Civil 3D table styles.
ViewFrameStyles | Gets the collection of all view frame styles in the database.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Members
Legend
Legend
Property
public


TableStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Members
TableStyle Members Public Methods
TableStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Members
Legend
Legend
Method
public
virtual


TableStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Members
TableStyle Members Public Properties
TableStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BorderDisplayStyleModel | Gets the AeccDisplayStyle object that specifies Model display settings such as layer and linetype for the graphic line that forms... more
BorderDisplayStylePlan | Gets the AeccDisplayStyle object that specifies Plan display settings such as layer and linetype for the graphic line that forms... more
ColumnStyles | Gets the ColumnStyles collection of styles defining column width and value properties.
CreateBy | Gets or Sets the "Created by" string for the style.
DataAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for all... more
DataAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for all... more
DataDividerDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the vertical graphic line that separates columns.
DataDividerDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the vertical graphic line that separates columns.
DataSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates data rows.
DataSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates data rows.
DataTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the all text in data rows of table.
DataTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the all text in data rows of table.
DataTextHeight | Gets or sets the height for row data text.
DataTextStyle | Gets or sets the text style for the row data from the available AutoCAD text styles defined in the current... more
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
EnableWordWrapping | Gets or sets the boolean value that determines whether to force text to fit within the specified width of the... more
HeaderAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the... more
HeaderAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the... more
HeaderSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates column headings from data rows.... more
HeaderSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates column headings from data rows.... more
HeaderTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the column names in second row of table.
HeaderTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the column names in second row of table.
HeaderTextHeight | Gets or sets the height for column headings text.
HeaderTextStyle | Gets or sets the text style for the column headings from the available AutoCAD text styles defined in the current... more
MaintainViewOrientation | Gets or sets the boolean value that determines whether to realign the table to the view (screen) direction regardless of... more
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RepeatHeaderInSplitTables | Gets or sets the boolean value that determines whether to show the column headers when displaying split tables.
RepeatTitleInSplitTables | Gets or sets the boolean value that determines whether to show the title header when displaying split tables.
SortData | Gets or sets the boolean value that specifies whether to enable the table style data sorting option.
SortingColumn | Gets or sets the column that determines whether to organize drawing information for clear and quick reference.
SortingOrder | Gets or sets the AeccTableSortingOrderType enum value that specifies the table style sort order as either ascending or descending.
TableType | Gets the type of feature to which this table style applies.
Title | Gets or sets the title that displays as the first row of a table.
TitleAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the... more
TitleAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the... more
TitleJustification | Gets or sets the justification of the title that displays as the first row of a table.
TitleSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates title from column headings.
TitleSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates title from column headings.
TitleTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the table name in first row of table.
TitleTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the table name in first row of table.
TitleTextHeight | The text height of the table title.
TitleTextStyle | Gets or sets the text style for the title text from the available AutoCAD text styles defined in the current... more
TitleUnformatted | Gets the unformatted table title string.
TransposeSectionViewTable | Gets or sets the boolean value that determines whether to transpose the section view table.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Members
Legend
Legend
Property
public


TableStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class > TableStyleCollection Members
TableStyleCollection Members Public Methods
TableStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class > TableStyleCollection Members
Legend
Legend
Method
public
virtual


TableStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class > TableStyleCollection Members
TableStyleCollection Members Public Properties
TableStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class > TableStyleCollection Members
Legend
Legend
Property
public


TableStylesRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Members
TableStylesRoot Members Public Properties
TableStylesRoot Members
Public Properties
Public Property | Description
AlignmentCurveTableStyles | Gets the collection of all alignment curve table styles.
AlignmentLineTableStyles | Gets the collection of all alignment line table styles.
AlignmentSegmentTableStyles | Gets the collection of all alignment segment table styles.
AlignmentSpiralTableStyles | Gets the collection of all alignment spiral table styles.
ParcelAreaTableStyles | Gets the collection of all parcel area table styles.
ParcelCurveTableStyles | Gets the collection of all parcel curve table styles.
ParcelLineTableStyles | Gets the collection of all parcel line table styles.
ParcelSegmentTableStyles | Gets the collection of all parcel segment table styles.
PipeTableStyles | Gets the collection of all pipe table styles.
PointTableStyles | Gets the collection of all point table styles.
QuantityTakeoffMaterialTableStyles | Gets the collection of all quantity takeoff material table styles.
QuantityTakeoffTotalVolumeTableStyles | Gets the collection of all quantity takeoff total volume table styles.
SectionViewMaterialTableStyles | Gets the collection of all section view material table styles.
SectionViewTotalVolumeTableStyles | Gets the collection of all section view total volume table styles.
StructureTableStyles | Gets the collection of all structure table styles.
SurfaceContourTableStyles | Gets the collection of all surface contour table styles.
SurfaceDirectionTableStyles | Gets the collection of all surface direction table styles.
SurfaceElevationTableStyles | Gets the collection of all surface elevation table styles.
SurfaceSlopeArrowContourTableStyles | Gets the collection of all surface user slope arrow table styles.
SurfaceSlopeTableStyles | Gets the collection of all surface slope table styles.
SurfaceUserDefinedContourTableStyles | Gets the collection of all surface user defined contour table styles.
SurfaceWatershedTableStyles | Gets the collection of all surface watershed table styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Members
Legend
Legend
Property
public


DesignCheck Members Public Properties
DesignCheck Members
Public Properties
Public Property | Description
Description | Gets and sets the description of the DesignCheck.
Expression | Gets or sets the expression of the DesignCheck.
Name | Gets the name of the DesignCheck.


DesignCheckCollection Members Public Methods
DesignCheckCollection Members
Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes DesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.


DesignCheckCollection Members Public Properties
DesignCheckCollection Members
Public Properties
Public Property | Description
Count | Gets the number of DesignCheck in the collection.
default | Gets the DesignCheck by a specified name in the collection.


AlignmentDesignCheck Members Public Properties
AlignmentDesignCheck Members
Public Properties
Public Property | Description
Description | Gets and sets the description of the DesignCheck.
DesignCheckType | Gets the type of the DesignCheck.
Expression | Gets or sets the expression of the DesignCheck.
Name | Gets the name of the DesignCheck.


AlignmentDesignCheckCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Members
AlignmentDesignCheckCollection Members Public Methods
AlignmentDesignCheckCollection Members
Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
Remove | Removes AlignmentDesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Members
Legend
Legend
Method
public
virtual


AlignmentDesignCheckCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Members
AlignmentDesignCheckCollection Members Public Properties
AlignmentDesignCheckCollection Members
Public Properties
Public Property | Description
Count | Gets the number of AlignmentDesignCheck in the collection.
default | Gets the AlignmentDesignCheck by a specified name in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Members
Legend
Legend
Property
public


AlignmentDesignCheckRoot Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Members
AlignmentDesignCheckRoot Members Public Methods
AlignmentDesignCheckRoot Members
Public Methods
Public Method | Description
AlignmentDesignCheckRoot | Constructor of AlignmentDesignCheckRoot class.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Members
Legend
Legend
Constructor
public


AlignmentDesignCheckRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Members
AlignmentDesignCheckRoot Members Public Properties
AlignmentDesignCheckRoot Members
Public Properties
Public Property | Description
CurveDesignChecks | Gets the collection of all alignment curve design checks.
LineDesignChecks | Gets the collection of all alignment line design checks.
SpiralDesignChecks | Gets the collection of all alignment spiral design checks.
TangentIntersectionDesignChecks | Gets the collection of all alignment tangent intersection design checks.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Members
Legend
Legend
Property
public


Alignment Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Members
Alignment Members Public Methods
Alignment Members
Public Methods
Public Method | Description
CopyToSite | Overloaded
Create | Overloaded
CreateOffsetAlignment | Creates an offset Alignment from the current alignment, returns the offset Alignment ObjectId. A positive value to create an offset... more
DistanceToAlignment | Overloaded
GetInstantaneousRadius | Returns the instantaneous radius at the specified station.
GetLabelGroupIds | Gets the ObjectIdCollection of the Alignment's label group.
GetLabelIds | Gets the ObjectIdCollection of the Alignment's labels.
GetNextUniqueName | Gets a string indicating a unique name for the Alignment. The input string could be a name template.
GetPolyline | Gets a polyline from the Alignment geometry.
GetProfileIds | Gets the ObjectIdCollection of all profiles belonging to this Alignment.
GetProfileViewIds | Gets the ObjectIdCollection of all profile views belonging to this Alignment.
GetRegions | Gets the regions, which are included in offset alignment or curb return.
GetSampleLineGroupIds | Gets the ObjectIdCollection of all sample line groups belonging to this Alignment.
GetStationSet | Overloaded
GetStationStringWithEquations | Gets a string indicating the station of an Alignment using the Station equations.
GetSuperelevationZoneAtStation | Gets the superelevation zone at the specified Station.
ImportLabelSet | Overloaded
IsEditableFeature | Check whether the Feature-derived entity (Alignment,Profile,etc) is editable.
PointLocation | Overloaded
Reverse | Reverse the Alignment direction.
StationOffset | Overloaded
SuperElevationAtStation | Gets the superelevation data element at a specified station. A read-only copy is returned.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Members
Legend
Legend
Method
public


Alignment Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Members
Alignment Members Public Properties
Alignment Members
Public Properties
Public Property | Description
AlignmentType | Gets the alignment type.
Application | Gets the Application. Not currently implemented.
CreationMode | Gets the Alignment creation mode.
DesignCheckSetId | Gets the object id of design check set that is used in the alignment.
DesignCheckSetName | Gets the name of of design check set that is used in the alignment.
DesignSpeeds | Gets the Alignment design speed collection.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
EndingStation | Gets the Alignment's end station.
Entities | Gets the Alignment entities collection for the Alignment.
IsEditable | Gets the value indicates whether the Feature derived entity (Alignment,Profile,etc) is editable.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
IsSiteless | Gets a bool value that indicates whether this Alignment is a siteless Alignment.
Length | Gets the Alignment's length.
Name | Gets or sets the Entity object's name.
ReferencePoint | Gets or sets the Alignment reference point.
ReferencePointStation | Gets or sets the Alignment reference point station.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
SiteId | Gets the Id for the Site to which this Alignment belongs. ObjectId.Null for a siteless alignment.
SiteName | Gets the name of the Site to which this Alignment belongs. a string of "" for a siteless alignment.
StartingStation | Gets the Alignment's start station.
StationEquations | Gets the Alignment's station equation collection.
StationIndexIncrement | Gets or sets the Alignment station index increment.
StyleId | Sets the Alignment's style Id.
StyleName | Sets the Alignment's style name.
SuperElevationData | Gets the superelevation data collection on the Alignment. A read-only copy is returned.
UpdateMode | Gets the update mode of the alignment.
UseDesignCheckSet | Gets or sets whether the Alignment uses the design check set.
UseDesignCriteriaFile | Gets or sets whether the alignment uses the design criteria file.
UseDesignSpeed | Gets or sets a bool value that indicates whether this Alignment uses degign speed.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Members
Legend
Legend
Property
public


AlignmentArc Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Members
AlignmentArc Members Public Methods
AlignmentArc Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Members
Legend
Legend
Method
public


AlignmentArc Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Members
AlignmentArc Members Public Properties
AlignmentArc Members
Public Properties
Public Property | Description
CenterPoint | Gets or sets the AlignmentArc's center point.
ChordDirection | Gets the AlignmentArc's chord direction.
ChordLength | Gets or sets the AlignmentArc's chord length.
Clockwise | Gets a bool value that specifies whether the curve entity is a reverse curve.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentArc entity constraint type.
CurveGroupIndex | Gets or sets the AlignmentArc's group index.
CurveGroupSubEntityIndex | Gets or sets the AlignmentArc's group subentity index.
default | Gets a subentity from the AlignmentEntity by index.
DeflectedAngle | Gets or sets the AlignmentArc's deflected angle.
Delta | Gets or sets the AlignmentArc's delta.
DirectionAtPoint1 | Gets or sets the AlignmentArc's direction at point1.
DirectionAtPoint2 | Gets the AlignmentArc's direction at point2.
EndDirection | Gets the AlignmentArc's end direction.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
ExternalSecant | Gets or sets the AlignmentArc's external secant.
ExternalTangent | Gets or sets the AlignmentArc's external tangent.
GreaterThan180 | Gets or sets a bool value indicating whether the Arc solution angle is > 180 Degrees.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets or sets the AlignmentArc's length.
MidOrdinate | Gets or sets the AlignmentArc's mid ordinate.
MinimumRadius | Gets the minimum radius according to the design speed check.
PassThroughPoint1 | Gets or sets the AlignmentArc's first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentArc's second pass-through point.
PassThroughPoint3 | Gets or sets the AlignmentArc's third pass-through point.
PIStation | Gets the AlignmentArc's PI station.
Radius | Gets or sets the AlignmentArc's radius.
ReverseCurve | Gets a bool value that specifies whether the curve entity is a reverse curve.
StartDirection | Gets the AlignmentArc's start direction.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Members
Legend
Legend
Property
public


AlignmentCurve Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Members
AlignmentCurve Members Public Methods
AlignmentCurve Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Members
Legend
Legend
Method
public


AlignmentCurve Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Members
AlignmentCurve Members Public Properties
AlignmentCurve Members
Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Members
Legend
Legend
Property
public


AlignmentCurveLabel Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Members
AlignmentCurveLabel Members Public Methods
AlignmentCurveLabel Members
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Overloaded
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Members
Legend
Legend
Method
public
virtual


AlignmentCurveLabel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Members
AlignmentCurveLabel Members Public Properties
AlignmentCurveLabel Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Members
Legend
Legend
Property
public


AlignmentDesignSpeedLabelGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Members
AlignmentDesignSpeedLabelGroup Members Public Methods
AlignmentDesignSpeedLabelGroup Members
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentDesignSpeedLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentDesignSpeedLabelGroup objects on the alignment.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Members
Legend
Legend
Method
public


AlignmentDesignSpeedLabelGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Members
AlignmentDesignSpeedLabelGroup Members Public Properties
AlignmentDesignSpeedLabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Members
Legend
Legend
Property
public


AlignmentEntity Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Members
AlignmentEntity Members Public Methods
AlignmentEntity Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Members
Legend
Legend
Method
public


AlignmentEntity Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Members
AlignmentEntity Members Public Properties
AlignmentEntity Members
Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
default | Gets a subentity from the AlignmentEntity by index.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Members
Legend
Legend
Property
public


AlignmentEntityCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Members
AlignmentEntityCollection Members Public Methods
AlignmentEntityCollection Members
Public Methods
Public Method | Description
AddFixedCurve | Overloaded
AddFixedLine | Overloaded
AddFixedSpiral | Overloaded
AddFloatingArcWithSpiral | Overloaded
AddFloatingCSS | Overloaded
AddFloatingCurve | Overloaded
AddFloatingLine | Overloaded
AddFloatingLineWithSpiral | Overloaded
AddFloatingSSC | Overloaded
AddFreeCurve | Overloaded
AddFreeLine | Creates an AlignmentLine entity defined by two successive elements identified by ID.
AddFreeSCS | Creates a AlignmentSCS (Spiral-Curve-Spiral group) entity defined by a previous entity, a next entity, the 'A' values of two spirals,... more
AddFreeSCSCS | Creates an AlignmentSCSCS (Spiral-Curve-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition... more
AddFreeSCSSCS | Creates an AlignmentSCSSCS (Spiral-Curve-Spiral-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition... more
AddFreeSpiral | Creates a AlignmentSCS (Spiral-Curve-Spiral group with a curve and a spiral length is 0) entity defined by a previous entity,... more
AddFreeSSBetweenCurves | Adds an AlignmentSTS (Spiral-Line-Spiral group with the line length is 0) entity constrained by the two spiral parameters.
AddFreeSSBetweenTangents | Creates a AlignmentSCS (Spiral-Curve-Spiral groupwith the curve length is 0) entity defined by a previous entity, a next entity, the... more
AddFreeSTS | Overloaded
Clear | Removes all alignment entities from the collection.
EntityAtId | Returns the AlignmentEntity specified by ID.
EntityAtStation | Gets the AlignmentEntity at a specified Station in the Alignment.
GetEntityByOrder | Gets an AlignmentEntity at a specified order index along the alignment path. This function behaves like the GUI in that... more
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes alignment entity from the collection by the specified entity object.
RemoveAt | Removes alignment entity from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Members
Legend
Legend
Method
public
virtual


AlignmentEntityCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Members
AlignmentEntityCollection Members Public Properties
AlignmentEntityCollection Members
Public Properties
Public Property | Description
Count | Gets the number of AlignmentEntity objects in the collection.
default | Gets the AlignmentEntity object at a specified index in the collection.
FirstEntity | Gets the ID of the first AlignmentEntity in the collection.
LastEntity | Gets the ID of the last AlignmentEntity in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Members
Legend
Legend
Property
public


AlignmentGeometryPointLabelGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Members
AlignmentGeometryPointLabelGroup Members Public Methods
AlignmentGeometryPointLabelGroup Members
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentGeometryPointLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentGeometryPointLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector containing the state of all AlignmentPointTypes for the current label.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetGeometryPointsOptions | Sets the state of all AlignmentPointTypes for the current label.
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Members
Legend
Legend
Method
public


AlignmentGeometryPointLabelGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Members
AlignmentGeometryPointLabelGroup Members Public Properties
AlignmentGeometryPointLabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Members
Legend
Legend
Property
public


AlignmentLabelGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Members
AlignmentLabelGroup Members Public Methods
AlignmentLabelGroup Members
Public Methods
Public Method | Description
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of labels on the alignment of a specified type.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Members
Legend
Legend
Method
public


AlignmentLabelGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Members
AlignmentLabelGroup Members Public Properties
AlignmentLabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Members
Legend
Legend
Property
public


AlignmentLine Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Members
AlignmentLine Members Public Methods
AlignmentLine Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Members
Legend
Legend
Method
public


AlignmentLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Members
AlignmentLine Members Public Properties
AlignmentLine Members
Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentLine entity constraint type.
CurveGroupIndex | Gets or sets the AlignmentLine's group index.
CurveGroupSubEntityIndex | Gets or sets the AlignmentLine's group subentity index.
default | Gets a subentity from the AlignmentEntity by index.
Direction | Gets the direction of the AlignmentSubEntityLine.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets or sets the AlignmentLine length.
MidPoint | Gets the AlignmentSubEntityLine middle point coordinate.
PassThroughPoint1 | Gets or sets the AlignmentSubEntityLine first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentSubEntityLine second pass-through point.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Members
Legend
Legend
Property
public


AlignmentMinorStationLabelGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Members
AlignmentMinorStationLabelGroup Members Public Methods
AlignmentMinorStationLabelGroup Members
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentMinorStationLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentMinorStationLabelGroup objects on the alignment.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Members
Legend
Legend
Method
public


AlignmentMinorStationLabelGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Members
AlignmentMinorStationLabelGroup Members Public Properties
AlignmentMinorStationLabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Increment | Gets or sets the increment at which to insert major and minor station labels.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
MajorStationLabelGroup | Gets or Sets the major station label group.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Members
Legend
Legend
Property
public


AlignmentPILabel Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Members
AlignmentPILabel Members Public Methods
AlignmentPILabel Members
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Overloaded
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Members
Legend
Legend
Method
public
virtual


AlignmentPILabel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Members
AlignmentPILabel Members Public Properties
AlignmentPILabel Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Members
Legend
Legend
Property
public


AlignmentRegion Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Members
AlignmentRegion Members Public Properties
AlignmentRegion Members
Public Properties
Public Property | Description
EndStation | Gets or sets the end station.
Length | Gets or sets the length of region.
OffsetDist | Gets or sets the distance of offset.
RegionType | Gets or sets the type of region.
StartStation | Gets or sets the start station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Members
Legend
Legend
Property
public


AlignmentRegionCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Members
AlignmentRegionCollection Members Public Methods
AlignmentRegionCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
MergeToNeighborRegion | Merges the specified region to neighbor region.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Members
Legend
Legend
Method
public
virtual


AlignmentRegionCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Members
AlignmentRegionCollection Members Public Properties
AlignmentRegionCollection Members
Public Properties
Public Property | Description
Count | Gets the number of AlignmentRegion objects in the collection.
default | Gets the AlignmentRegion object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Members
Legend
Legend
Property
public


AlignmentSCS Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Members
AlignmentSCS Members Public Methods
AlignmentSCS Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Members
Legend
Legend
Method
public


AlignmentSCS Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Members
AlignmentSCS Members Public Properties
AlignmentSCS Members
Public Properties
Public Property | Description
Arc | Gets the arc of the SCS group.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
SpiralIn | Gets the in spiral of the SCS group.
SpiralOut | Gets the out spiral of the SCS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Members
Legend
Legend
Property
public


AlignmentSCSCS Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Members
AlignmentSCSCS Members Public Methods
AlignmentSCSCS Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Members
Legend
Legend
Method
public


AlignmentSCSCS Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Members
AlignmentSCSCS Members Public Properties
AlignmentSCSCS Members
Public Properties
Public Property | Description
Arc1 | Gets the first arc of the SCSCS group.
Arc2 | Gets the second arc of the SCSCS group.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSCSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
Spiral1 | Gets the first spiral of the SCSCS group.
Spiral2 | Gets the second spiral of the SCSCS group.
Spiral3 | Gets the third spiral of the SCSCS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Members
Legend
Legend
Property
public


AlignmentSCSSCS Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Members
AlignmentSCSSCS Members Public Methods
AlignmentSCSSCS Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Members
Legend
Legend
Method
public


AlignmentSCSSCS Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Members
AlignmentSCSSCS Members Public Properties
AlignmentSCSSCS Members
Public Properties
Public Property | Description
Arc1 | Gets the first arc of the SCSSCS group.
Arc2 | Gets the second arc of the SCSSCS group.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSCSSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
Spiral1 | Gets the first spiral of the SCSSCS group.
Spiral2 | Gets the second spiral of the SCSSCS group.
Spiral3 | Gets the third spiral of the SCSSCS group.
Spiral4 | Gets the fourth spiral of the SCSSCS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Members
Legend
Legend
Property
public


AlignmentSpiral Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Members
AlignmentSpiral Members Public Methods
AlignmentSpiral Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Members
Legend
Legend
Method
public


AlignmentSpiral Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Members
AlignmentSpiral Members Public Properties
AlignmentSpiral Members
Public Properties
Public Property | Description
A | Gets the spiral A value.
Compound | Gets the AlignmentSpiral entity Simple/Compound Flag.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSpiral entity constraint type.
CurveGroupIndex | Gets the AlignmentSpiral entity curve group index string.
CurveGroupSubEntityIndex | Gets the AlignmentSpiral entity curve group subentity index string.
CurveType | Gets the AlignmentSpiral entity Incurve/Outcurve type.
default | Gets the subentity of the AlignmentEntity by index.
Delta | Gets the AlignmentSpiral entity curve delta angle.
Direction | Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.
EndDirection | Gets the direction value at the end point.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
K | Gets the spiral K value.
Length | Gets or sets the spiral length.
LongTangent | Gets the spiral long tangent.
MinimumTransitionLength | Gets the minimum transition length according to the design speed check.
P | Gets the spiral P value.
RadialPoint | Gets the AlignmentSpiral subentity radial Point2D coordinate.
RadiusIn | Gets the incoming curve radius.
RadiusOut | Gets the outgoing curve radius.
ShortTangent | Gets the spiral short tangent.
SPIAngle | Gets the AlignmentSpiral entity SPI angle.
SPIPoint | Gets the AlignmentSpiral entity SPI Point2D coordinate.
SpiralDefinition | Gets the AlignmentSpiral entity spiral type.
SPIStation | Gets the AlignmentSpiral entity SPI station.
StartDirection | Gets the direction value at the start point.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities in the AlignmentEntity.
TotalX | Gets the spiral total X value.
TotalY | Gets the spiral total Y value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Members
Legend
Legend
Property
public


AlignmentSpiralLabel Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Members
AlignmentSpiralLabel Members Public Methods
AlignmentSpiralLabel Members
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Overloaded
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Members
Legend
Legend
Method
public
virtual


AlignmentSpiralLabel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Members
AlignmentSpiralLabel Members Public Properties
AlignmentSpiralLabel Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Members
Legend
Legend
Property
public


AlignmentSSCSS Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Members
AlignmentSSCSS Members Public Methods
AlignmentSSCSS Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Members
Legend
Legend
Method
public


AlignmentSSCSS Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Members
AlignmentSSCSS Members Public Properties
AlignmentSSCSS Members
Public Properties
Public Property | Description
Arc | Gets the arc from the SSCSS group.
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSSCSS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
Spiral1 | Gets the first spiral from the SSCSS group.
Spiral2 | Gets the second spiral from the SSCSS group.
Spiral3 | Gets the third spiral from the SSCSS group.
Spiral4 | Gets the fourth spiral from the SSCSS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Members
Legend
Legend
Property
public


AlignmentStationEquationLabelGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Members
AlignmentStationEquationLabelGroup Members Public Methods
AlignmentStationEquationLabelGroup Members
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentStationEquationLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentStationEquationLabelGroup obects on the alignment.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Members
Legend
Legend
Method
public


AlignmentStationEquationLabelGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Members
AlignmentStationEquationLabelGroup Members Public Properties
AlignmentStationEquationLabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Members
Legend
Legend
Property
public


AlignmentStationLabelGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Members
AlignmentStationLabelGroup Members Public Methods
AlignmentStationLabelGroup Members
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentStationLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of the specified label type on the alignment.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Members
Legend
Legend
Method
public


AlignmentStationLabelGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Members
AlignmentStationLabelGroup Members Public Properties
AlignmentStationLabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Increment | Gets or sets the increment at which to insert major and minor station labels.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Members
Legend
Legend
Property
public


AlignmentSTS Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Members
AlignmentSTS Members Public Methods
AlignmentSTS Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Members
Legend
Legend
Method
public


AlignmentSTS Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Members
AlignmentSTS Members Public Properties
AlignmentSTS Members
Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
Constraint2 | Gets the AlignmentSTS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
SpiralIn | Gets the in spiral of the STS group.
SpiralOut | Gets the out spiral of the STS group.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Tangent | Gets the tangent of the STS group.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Members
Legend
Legend
Property
public


AlignmentSubEntity Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Members
AlignmentSubEntity Members Public Methods
AlignmentSubEntity Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Members
Legend
Legend
Method
public


AlignmentSubEntity Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Members
AlignmentSubEntity Members Public Properties
AlignmentSubEntity Members
Public Properties
Public Property | Description
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
Length | Gets or sets the alignment sub-entity length.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Members
Legend
Legend
Property
public


AlignmentSubEntityArc Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Members
AlignmentSubEntityArc Members Public Methods
AlignmentSubEntityArc Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Members
Legend
Legend
Method
public


AlignmentSubEntityArc Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Members
AlignmentSubEntityArc Members Public Properties
AlignmentSubEntityArc Members
Public Properties
Public Property | Description
CenterPoint | Gets or sets the arc's center point.
ChordDirection | Gets the arc's chord direction.
ChordLength | Gets or sets the arc's chord length.
Clockwise | Gets a bool value that specifies whether the curve entity is clockwise.
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
DeflectedAngle | Gets or sets the arc's deflected angle.
Delta | Gets or sets the arc's delta.
DirectionAtPoint1 | Gets or sets the arc's direction at point1.
DirectionAtPoint2 | Gets the arc's direction at point2.
EndDirection | Gets the arc's end direction.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
ExternalSecant | Gets or sets the arc's external secant.
ExternalTangent | Gets or sets the arc's external tangent.
GreaterThan180 | Gets or sets a bool value that indicates whether the arc solution angle is greather than 180 Degrees.
Length | Gets or sets the alignment sub-entity length.
MidOrdinate | Gets or sets the arc's mid ordinate.
MinimumRadius | Gets the minimum radius according to the design speed check.
PassThroughPoint1 | Gets or sets the arc's first pass-through point.
PassThroughPoint2 | Gets or sets the arc's second pass-through point.
PassThroughPoint3 | Gets or sets the arc's third pass-through point.
PIPoint | Gets the arc's PI point.
PIStation | Gets the arc's PI station.
Radius | Gets or sets the arc's radius.
ReverseCurve | Gets a bool value that specifies whether the curve entity is a reverse curve.
StartDirection | Gets the arc's start direction.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Members
Legend
Legend
Property
public


AlignmentSubEntityLine Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Members
AlignmentSubEntityLine Members Public Methods
AlignmentSubEntityLine Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Members
Legend
Legend
Method
public


AlignmentSubEntityLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Members
AlignmentSubEntityLine Members Public Properties
AlignmentSubEntityLine Members
Public Properties
Public Property | Description
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
Direction | Gets the direction of AlignmentSubEntityLine.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
Length | Gets or sets the alignment sub-entity length.
MidPoint | Gets the AlignmentSubEntityLine middle point coordinate.
PassThroughPoint1 | Gets or sets the AlignmentSubEntityLine first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentSubEntityLine second pass-through point.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Members
Legend
Legend
Property
public


AlignmentSubEntitySpiral Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Members
AlignmentSubEntitySpiral Members Public Methods
AlignmentSubEntitySpiral Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Members
Legend
Legend
Method
public


AlignmentSubEntitySpiral Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Members
AlignmentSubEntitySpiral Members Public Properties
AlignmentSubEntitySpiral Members
Public Properties
Public Property | Description
A | Gets the spiral A value.
Compound | Gets the alignment spiral entity Simple/Compound Flag.
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
CurveType | Gets the alignment spiral entity Incurve/Outcurve type.
Delta | Gets the curve delta angle.
Direction | Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.
EndDirection | Gets the direction value at the end point.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
K | Gets the spiral K value.
Length | Gets or sets the alignment sub-entity length.
LongTangent | Gets the spiral long tangent.
MinimumTransitionLength | Gets the minimum transition length according to the design speed check.
P | Gets the spiral P value.
RadialPoint | Gets the alignment spiral subentity radial Point2D coordinate.
RadiusIn | Gets the incoming curve radius, in radians.
RadiusOut | Gets the outgoing curve radius, in radians.
ShortTangent | Gets the spiral short tangent.
SPIAngle | Gets the alignment spiral entity SPI angle.
SPIPoint | Gets the alignment spiral entity SPI Point2D coordinate.
SpiralDefinition | Gets the alignment spiral entity spiral type.
SPIStation | Gets the alignment spiral entity SPI station.
StartDirection | Gets the direction value at the start point.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.
TotalX | Gets the spiral total X value.
TotalY | Gets the spiral total Y value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Members
Legend
Legend
Property
public


AlignmentSuperelevationLabelGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Members
AlignmentSuperelevationLabelGroup Members Public Methods
AlignmentSuperelevationLabelGroup Members
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentSuperelevationLabelGroup on an alignment entity with the specified label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentSuperelevationLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector object containing the state of all SuperelevationPointType objects for the current label.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetGeometryPointsOptions | Sets the state of all SuperelevationPointType objects for the current label.
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Members
Legend
Legend
Method
public


AlignmentSuperelevationLabelGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Members
AlignmentSuperelevationLabelGroup Members Public Properties
AlignmentSuperelevationLabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Members
Legend
Legend
Property
public


AlignmentTangentLabel Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Members
AlignmentTangentLabel Members Public Methods
AlignmentTangentLabel Members
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Overloaded
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Members
Legend
Legend
Method
public
virtual


AlignmentTangentLabel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Members
AlignmentTangentLabel Members Public Properties
AlignmentTangentLabel Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Members
Legend
Legend
Property
public


AlignmentVerticalGeometryPointLabelGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Members
AlignmentVerticalGeometryPointLabelGroup Members Public Methods
AlignmentVerticalGeometryPointLabelGroup Members
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentVerticalGeometryPointLabelGroup on an alignment entity with the label style.
GetAt | Gets one LabelGroupSubEntity from label group according the index.
GetAvailableLabelGroups | Returns the object Id collection of AlignmentVerticalGeometryPointLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector object containing the state of all ProfilePointType objects for the current label.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).
SetGeometryPointsOptions | Sets the state of all ProfilePointType objects for the current label.
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Members
Legend
Legend
Method
public


AlignmentVerticalGeometryPointLabelGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Members
AlignmentVerticalGeometryPointLabelGroup Members Public Properties
AlignmentVerticalGeometryPointLabelGroup Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DescriptiveText | Gets a description of the label.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
IsGroupLabelType | Specifies whether the label is a group label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LabelType | Gets the type of the label.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
RangeEnd | Gets or sets the end of the labeled range.
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.
VerticalAlignment | Gets or sets the major station label group.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Members
Legend
Legend
Property
public


DesignSpeed Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Members
DesignSpeed Members Public Properties
DesignSpeed Members
Public Properties
Public Property | Description
Comment | Gets and sets the DesignSpeed comment.
SpeedNumber | Gets the DesignSpeed number.
Station | Gets and sets the DesignSpeed Station.
Value | Gets and sets the DesignSpeed value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Members
Legend
Legend
Property
public


DesignSpeedCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Members
DesignSpeedCollection Members Public Methods
DesignSpeedCollection Members
Public Methods
Public Method | Description
Add | Adds a DesignSpeed to the collection for the given Station value.
GetDesignSpeed | Gets the DesignSpeed object in the collection by raw Station value.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumertor which can be used to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumertor which can be used to enumerate this... more
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Members
Legend
Legend
Method
public
virtual


DesignSpeedCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Members
DesignSpeedCollection Members Public Properties
DesignSpeedCollection Members
Public Properties
Public Property | Description
Count | Gets the number of DesignSpeed objects in the collection.
default | Gets the DesignSpeed at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Members
Legend
Legend
Property
public


MassHaulView Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulView Class > MassHaulView Members
MassHaulView Members Public Properties
MassHaulView Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
MassHaulLineId | Gets the ObjectId of the MassHaulLine associated with this view.
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulView Class > MassHaulView Members
Legend
Legend
Property
public


MatchLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MatchLine Class > MatchLine Members
MatchLine Members Public Properties
MatchLine Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GroupId | Gets the object id of the view frame group it belongs to.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MatchLine Class > MatchLine Members
Legend
Legend
Property
public


PointEntity Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Members
PointEntity Members Public Properties
PointEntity Members
Public Properties
Public Property | Description
DescriptionFormat | Gets or sets the description format string for the point.
FullDescription | Gets an expanded description determined by a description key match.
IsNamed | Check whether this Cogo Point is named.
IsSurveyPoint | Check whether this Cogo Point is Survey Point.
Location | Gets or sets the point location.
PointName | Gets or sets the name of Cogo Point.
PointNumber | Gets or sets the identifying number assigned to the point.
RawDescription | Gets or sets an unexpanded description for the point, which could be the description entered by the surveyor in the... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Members
Legend
Legend
Property
public


PolylineOptions Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Members
PolylineOptions Members Public Methods
PolylineOptions Members
Public Methods
Public Method | Description
Equals | Overloaded
GetHashCode | Gets a hash code for the PolylineOptions object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Members
Legend
Legend
Method
public
virtual


PolylineOptions Members Public Operators

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Members
PolylineOptions Members Public Operators
PolylineOptions Members
Public Operators
Public Operator | Description
!= | Compares two PolylineOptions objects, returns true if they are not equal.
== | Compares two PolylineOptions objects, returns true if they are equal.


Public Operators

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Members
Legend
Legend
Operator
public


PolylineOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Members
PolylineOptions Members Public Properties
PolylineOptions Members
Public Properties
Public Property | Description
AddCurvesBetweenTangents | Specifies whether to add curves between tangents.
EraseExistingEntities | Specifies whether to erase the polyline after the Alignment is created.
PlineId | Specifies the objectId of the polyline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Members
Legend
Legend
Property
public


Profile Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Members
Profile Members Public Methods
Profile Members
Public Methods
Public Method | Description
CreateByLayout | Overloaded
CreateFromSurface | Overloaded
ElevationAt | Gets the elevation at a specified station.
GradeAt | Given a station, gets the instantaneous grade and the algebraic difference.
IsEditableFeature | Check whether the Feature-derived entity (Alignment,Profile,etc) is editable.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Members
Legend
Legend
Method
public


Profile Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Members
Profile Members Public Properties
Profile Members
Public Properties
Public Property | Description
AlignmentId | Gets the object id of the corresponding alignment for the profile.
Application | Gets the Application. Not currently implemented.
DataSourceId | Gets the object id of object that is associated with the profile.
DataSourceName | Gets the name of object that is associated with the profile.
DesignCheckSetId | Gets the object id of design check set that is used in the profile.
DesignCheckSetName | Gets the name of of design check set that is used in the profile.
DesignSpeedBased | Gets or sets whether the design is speed-based.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
ElevationMax | Gets the maximum elevation value on the profile.
ElevationMin | Gets the minimum elevation value on the profile.
EndingStation | Gets the profile ending station.
Entities | Gets the profile entities' collection.
IsEditable | Gets the value indicates whether the Feature derived entity (Alignment,Profile,etc) is editable.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Length | Gets the profile length.
Name | Gets or sets the Entity object's name.
Offset | Gets the profile offset.
Plinegen | Gets or sets the PLINEGEN setting for the profile.
ProfileType | Gets or sets the profile type.
PVIs | Gets the points of vertical intersection for the profile.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StartingStation | Gets the profile starting station.
StyleId | Sets the profile's style Id.
StyleName | Sets the profile's style name.
UpdateMode | Gets or sets the update mode of the profile.
UseDesignCheckSet | Gets or sets whether the design check set is used.
UseDesignCriteriaFile | Gets or sets whether the design criteria file is used.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Members
Legend
Legend
Property
public


ProfileCircular Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Members
ProfileCircular Members Public Methods
ProfileCircular Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Members
Legend
Legend
Method
public


ProfileCircular Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Members
ProfileCircular Members Public Properties
ProfileCircular Members
Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
CurveType | Gets the curve type, crest or sag.
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighestDesignSpeed | Returns the highest speed in the station range.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
Length | Gets or sets the curve length.
M | Gets or sets the M value of the curve.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
Radius | Gets or sets the radius of the curve.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Members
Legend
Legend
Property
public


ProfileCriteria Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class > ProfileCriteria Members
ProfileCriteria Members Public Properties
ProfileCriteria Members
Public Properties
Public Property | Description
BoundaryType | Gets the profile critera's boundary type of the hatch area.
ProfileId | Gets or Sets the profile id in the profile critera of the hatch area.
ProfileName | Gets or Sets the profile name in the profile critera of the hatch area.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class > ProfileCriteria Members
Legend
Legend
Property
public


ProfileCriteriaCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Members
ProfileCriteriaCollection Members Public Methods
ProfileCriteriaCollection Members
Public Methods
Public Method | Description
Add | Adds an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria to the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Members
Legend
Legend
Method
public
virtual


ProfileCriteriaCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Members
ProfileCriteriaCollection Members Public Properties
ProfileCriteriaCollection Members
Public Properties
Public Property | Description
Count | Gets the number of ProfileCriteria objects in the collection.
default | Gets the ProfileCriteria at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Members
Legend
Legend
Property
public


ProfileEntity Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Members
ProfileEntity Members Public Methods
ProfileEntity Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Members
Legend
Legend
Method
public


ProfileEntity Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Members
ProfileEntity Members Public Properties
ProfileEntity Members
Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
HighestDesignSpeed | Returns the highest speed in the station range.
Length | Gets or sets the curve length.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Members
Legend
Legend
Property
public


ProfileEntityCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Members
ProfileEntityCollection Members Public Methods
ProfileEntityCollection Members
Public Methods
Public Method | Description
AddFixedSymmetricParabolaByEntityEndAndThroughPoint | Creates a fixed Symmetric Parabola defined by the entity to attach to and pass-through point.
AddFixedSymmetricParabolaByThreePoints | Creates a fixed Symmetric Parabola defined by 3 pass-through points.
AddFixedSymmetricParabolaByTwoPointsAndEndGrade | Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the end point.
AddFixedSymmetricParabolaByTwoPointsAndK | Creates a fixed Symmetric Parabola defined by 2 pass-through points and K value.
AddFixedSymmetricParabolaByTwoPointsAndRadius | Creates a fixed Symmetric Parabola defined by 2 pass-through points and radius.
AddFixedSymmetricParabolaByTwoPointsAndStartGrade | Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the start point.
AddFixedTangent | Creates a fixed Tangent defined by 2 pass-through points.
AddFixedTangentWithPreviousEntity | Creates a fixed Tangent defined by 2 pass-through points and previous entity id.
AddFloatingSymmetricParabolaByThroughPointAndGrade | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the grade value at... more
AddFloatingSymmetricParabolaByThroughPointAndK | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the K value.
AddFloatingSymmetricParabolaByThroughPointAndRadius | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the radius value.
AddFloatingTangent | Creates a floating Tangent defined by an entity and a pass-through point, whether to append or prepend to the specified... more
AddFreeAsymmetricParabolaByPVIAndLengths | Creates a free Asymmetric Parabola constrained by a PVI and 2 parabola lengths.
AddFreeCircularCurveByPVIAndLength | Creates a free Circular Curve constrained by a PVI and length.
AddFreeCircularCurveByPVIAndRadius | Creates a free Circular Curve constrained by a PVI and radius.
AddFreeCircularCurveByPVIAndThroughPoint | Creates a free Circular Curve constrained by a PVI and a pass-through point.
AddFreeSymmetricParabolaByK | Creates a free Symmetric Parabola between two entities and the K value.
AddFreeSymmetricParabolaByLength | Creates a free Symmetric Parabola between two entities and curve length.
AddFreeSymmetricParabolaByPVIAndCurveLength | Creates a free Symmetric Parabola constrained by a PVI and curve length.
AddFreeSymmetricParabolaByPVIAndK | Creates a free Symmetric Parabola constrained by a PVI and K value.
AddFreeSymmetricParabolaByPVIAndThroughPoint | Creates a free Symmetric Parabola constrained by a PVI and a pass-through point.
AddFreeSymmetricParabolaByRadius | Creates a free Symmetric Parabola between two entities and the radius value.
AddFreeTangent | Creates a free Tangent between two entities.
Clear | Removes all Profile entities from the collection.
EntityAtId | Returns the ProfileEntity specified by ID.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes from the collection by the specified entity object.
RemoveAt | Removes from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Members
Legend
Legend
Method
public
virtual


ProfileEntityCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Members
ProfileEntityCollection Members Public Properties
ProfileEntityCollection Members
Public Properties
Public Property | Description
Count | Gets the number of ProfileEntity objects in the collection.
default | Gets the ProfileEntity object at a specified index in the collection.
FirstEntity | Gets the ID of the first ProfileEntity in the collection.
LastEntity | Gets the ID of the last ProfileEntity in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Members
Legend
Legend
Property
public


ProfileHatchArea Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Members
ProfileHatchArea Members Public Properties
ProfileHatchArea Members
Public Properties
Public Property | Description
Criteria | Gets the collection of hatch area criteria in the profile hatch area.
Name | Gets or Sets the profile hatch area's name.
ShapeStyleId | Gets or Sets the profile hatch area's shape style id.
ShapeStyleName | Gets or Sets the profile hatch area's shape style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Members
Legend
Legend
Property
public


ProfileHatchAreaCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Members
ProfileHatchAreaCollection Members Public Methods
ProfileHatchAreaCollection Members
Public Methods
Public Method | Description
Add | Adds an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea to the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea by the hatch area name from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Members
Legend
Legend
Method
public
virtual


ProfileHatchAreaCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Members
ProfileHatchAreaCollection Members Public Properties
ProfileHatchAreaCollection Members
Public Properties
Public Property | Description
Count | Gets the number of ProfileHatchArea objects in the collection.
default | Gets the ProfileHatchArea at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Members
Legend
Legend
Property
public


ProfileOverride Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Members
ProfileOverride Members Public Methods
ProfileOverride Members
Public Methods
Public Method | Description
GetLabelGroupIds | Gets the ObjectIdCollection of the Profile's label group.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Members
Legend
Legend
Method
public


ProfileOverride Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Members
ProfileOverride Members Public Properties
ProfileOverride Members
Public Properties
Public Property | Description
Draw | Gets or sets whether this entity will be drawn in the graph.
OverrideStyleId | Sets the override style of the entity.
OverrideStyleName | Sets the override style of the entity.
ProfileId | Gets the object id of the profile.
ProfileName | Gets the name of the profile.
UseOverrideStyle | Gets or sets whether to override style for the display of the entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Members
Legend
Legend
Property
public


ProfileOverrideCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Members
ProfileOverrideCollection Members Public Methods
ProfileOverrideCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Members
Legend
Legend
Method
public
virtual


ProfileOverrideCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Members
ProfileOverrideCollection Members Public Properties
ProfileOverrideCollection Members
Public Properties
Public Property | Description
ClipGridAt | Gets or sets which profile controls the size of the profile view grid.
Count | Gets the number of ProfileOverride objects in the collection.
default | Gets the ProfileOverride at a specified index in the collection.
SplitAt | Gets or sets which profile to favor when splitting a profile view containing multiple profiles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Members
Legend
Legend
Property
public


ProfileParabolaAsymmetric Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Members
ProfileParabolaAsymmetric Members Public Methods
ProfileParabolaAsymmetric Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Members
Legend
Legend
Method
public


ProfileParabolaAsymmetric Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Members
ProfileParabolaAsymmetric Members Public Properties
ProfileParabolaAsymmetric Members
Public Properties
Public Property | Description
AsymmetricLength1 | Gets or sets the length of the parabola in.
AsymmetricLength2 | Gets or sets the length of the parabola out.
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
CurveType | Gets the curve type, crest or sag.
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighestDesignSpeed | Returns the highest speed in the station range.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
Length | Gets or sets the curve length.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Members
Legend
Legend
Property
public


ProfileParabolaSymmetric Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Members
ProfileParabolaSymmetric Members Public Methods
ProfileParabolaSymmetric Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
GetHeadlightSightDistance | Gets the headlight sight distance with the given headlight angle and headlight height.
GetPassingSightDistance | Gets the passing sight distance with the given eye height and object height.
GetStoppingSightDistance | Gets the stopping sight distance with the given eye height and object height.
SetHeadlightSightDistance | Sets the headlight sight distance with the given headlight angle and headlight height.
SetPassingSightDistance | Sets the passing sight distance with the given eye height and object height.
SetStoppingSightDistance | Sets the stopping sight distance with the given eye height and object height.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Members
Legend
Legend
Method
public


ProfileParabolaSymmetric Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Members
ProfileParabolaSymmetric Members Public Properties
ProfileParabolaSymmetric Members
Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
CurveType | Gets the curve type, crest or sag.
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeAtThroughPoint1 | Gets or sets the grade value of the first pass-through point.
GradeAtThroughPoint2 | Gets or sets the grade value of the second pass-through point.
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighestDesignSpeed | Returns the highest speed in the station range.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
Length | Gets or sets the curve length.
M | Gets the M value of the curve.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
Radius | Gets or sets the radius of the curve.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.
ThroughPoint1Elevation | Gets or sets the elevation value of the first pass-through point.
ThroughPoint1Station | Gets or sets the station value of the first pass-through point.
ThroughPoint2Elevation | Gets or sets the elevation value of the second pass-through point.
ThroughPoint2Station | Gets or sets the station value of the second pass-through point.
ThroughPoint3Elevation | Gets or sets the elevation value of the third pass-through point.
ThroughPoint3Station | Gets or sets the station value of the third pass-through point.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Members
Legend
Legend
Property
public


ProfilePVI Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Members
ProfilePVI Members Public Properties
ProfilePVI Members
Public Properties
Public Property | Description
Elevation | Gets or sets the elevation value of the PVI.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
GradeIn | Gets or sets the grade of the curve into the PVI.
GradeOut | Gets or sets the grade of the curve out of the PVI.
HeadlightSightDistance | Gets or sets the headlight sight distance of the sag parabolic curve.
PassingSightDistance | Gets or sets the passing sight distance of the crest parabolic curve.
PVIType | Gets the type of subentity at the PVI.
Station | Gets or sets the station value of the PVI.
StoppingSightDistance | Gets or sets the stopping sight distance of the crest parabolic curve.
VerticalCurve | Gets the vertical curve object at the PVI.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Members
Legend
Legend
Property
public


ProfilePVICollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Members
ProfilePVICollection Members Public Methods
ProfilePVICollection Members
Public Methods
Public Method | Description
AddPVI | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is tangent to the collection.
AddPVIArc | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is Circular to the collection.
AddPVIAsymParabola | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaAsymmetric to the collection.
AddPVISymParabola | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaSymmetric to the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetPVIAt | Gets the PVI in the collection closest to the given station and elevation.
Remove | Removes a profile PVI from the collection.
RemoveAt | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Members
Legend
Legend
Method
public
virtual


ProfilePVICollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Members
ProfilePVICollection Members Public Properties
ProfilePVICollection Members
Public Properties
Public Property | Description
Count | Gets the number of ProfilePVI objects in the collection.
default | Gets the ProfilePVI object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Members
Legend
Legend
Property
public


ProfileTangent Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Members
ProfileTangent Members Public Methods
ProfileTangent Members
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Members
Legend
Legend
Method
public


ProfileTangent Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Members
ProfileTangent Members Public Properties
ProfileTangent Members
Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type.
Grade | Gets the tangent grade.
HighestDesignSpeed | Returns the highest speed in the station range.
Length | Gets or sets the curve length.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.
ThroughPoint1Elevation | Gets or sets the elevation value of the first pass-through point.
ThroughPoint1Station | Gets or sets the station value of the first pass-through point.
ThroughPoint2Elevation | Gets or sets the elevation value of the second pass-through point.
ThroughPoint2Station | Gets or sets the station value of the second pass-through point.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Members
Legend
Legend
Property
public


ProfileView Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Members
ProfileView Members Public Methods
ProfileView Members
Public Methods
Public Method | Description
Create | Overloaded
FindStationAndElevationAtXY | Finds the station and elevation values at the given X,Y coordinate.
FindXYAtStationAndElevation | Finds the X,Y coordinate for the given station and elevation.
GetLabelIds | Gets the ObjectIdCollection of the ProfileView's labels.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Members
Legend
Legend
Method
public


ProfileView Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Members
ProfileView Members Public Properties
ProfileView Members
Public Properties
Public Property | Description
AlignmentId | Gets the object id of the alignment from which the profile view was created.
AlignmentName | Gets the name of the alignment from which the profile view was created.
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
ElevationMax | Gets or sets the maximum elevation of the profile view.
ElevationMin | Gets or sets the minimum elevation of the profile view.
ElevationRangeMode | Gets or sets how to specify the vertical range of the profile view.
GraphOverrides | Gets the collection of the profiles that belong to the alignment.
HatchAreas | Gets the collection of hatch area in the profile view.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
SplitDataLines | Gets the collection of split data lines.
SplitDatumRounding | Gets or sets where to round the vertical split location.
SplitHeight | Gets or sets the elevation range for splitting the profile view.
SplitProfileView | Gets or sets whether to split the profile view to multiple segments.
SplitStationMode | Gets or sets the mode to split the profile view.
SplitStationRounding | Gets or sets where to round the horizontal split location.
StationEnd | Gets or sets the end station of the profile view.
StationRangeMode | Gets or sets how to specify the horizontal range of the profile view.
StationStart | Gets or sets the start station of the profile view.
StyleId | Sets the ProfileView's style by ObjectId.
StyleName | Sets the ProfileView's style by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Members
Legend
Legend
Property
public


ProfileViewSplitData Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Members
ProfileViewSplitData Members Public Properties
ProfileViewSplitData Members
Public Properties
Public Property | Description
AdjustedDatum | Gets or sets the vertical split location.
ProfileViewStyleId | Gets of sets the style of the profile view segment.
ProfileViewStyleName | Gets of sets the style of the profile view segment.
SplitStation | Gets or sets the starting station value of the split location.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Members
Legend
Legend
Property
public


ProfileViewSplitDataCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Members
ProfileViewSplitDataCollection Members Public Methods
ProfileViewSplitDataCollection Members
Public Methods
Public Method | Description
Add | Adds a new split location.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes the split location from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Members
Legend
Legend
Method
public
virtual


ProfileViewSplitDataCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Members
ProfileViewSplitDataCollection Members Public Properties
ProfileViewSplitDataCollection Members
Public Properties
Public Property | Description
Count | Gets the number of ProfileViewSplitData objects in the collection.
default | Gets the ProfileViewSplitData at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Members
Legend
Legend
Property
public


SampleLine Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Members
SampleLine Members Public Methods
SampleLine Members
Public Methods
Public Method | Description
GetSectionViewIds | Gets the objectId collection of all section views attached on this sample line.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Members
Legend
Legend
Method
public


SampleLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Members
SampleLine Members Public Properties
SampleLine Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GroupId | Gets the object id of the sample line group it belongs to.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Members
Legend
Legend
Property
public


SampleLineGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Members
SampleLineGroup Members Public Methods
SampleLineGroup Members
Public Methods
Public Method | Description
GetMassHaulViewIds | Gets the objectId collection of mass haul views.
GetSampleLineIds | Gets the objectId collection of all sample lines in the sampline group.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Members
Legend
Legend
Method
public


SampleLineGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Members
SampleLineGroup Members Public Properties
SampleLineGroup Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Members
Legend
Legend
Property
public


SCSCSConstraints Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Members
SCSCSConstraints Members Public Methods
SCSCSConstraints Members
Public Methods
Public Method | Description
CreateByArc1Angle | Creates an SCSCSConstraints object that constrains the SCSCS group by the angle of the first arc.
CreateByArc1Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the first arc.
CreateByArc1PassPt | Creates an SCSCSConstraints object that constrains the SCSCS group by a pass-through point for the first arc.
CreateByArc2Angle | Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.
CreateByArc2Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc length.
CreateByArc2PassPt | Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc pass through point.
CreateByEndPoint | Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.
CreateByStartPoint | Creates an SCSCSConstraints object that constrains the SCSCS group by the start point.
CreateByTan1Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the first tangent length.
CreateByTan2Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the second tangent.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Members
Legend
Legend
Method
public


SCSSCSConstraints Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Members
SCSSCSConstraints Members Public Methods
SCSSCSConstraints Members
Public Methods
Public Method | Description
CreateByArc1Angle | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the angle of the first arc.
CreateByArc1Length | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the length of the first arc.
CreateByArc1PassPt | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point of the first arc.
CreateByArc2Angle | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc angle.
CreateByArc2Length | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc length.
CreateByArc2PassPt | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point for the second arc.
CreateByEndPoint | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the end point.
CreateByStartPoint | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the start point.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Members
Legend
Legend
Method
public


Section Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Section Class > Section Members
Section Members Public Properties
Section Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ParentId | Gets the ObjectId of the Section object's parent.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Section Class > Section Members
Legend
Legend
Property
public


SectionView Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionView Class > SectionView Members
SectionView Members Public Properties
SectionView Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ParentEntityId | Gets the ObjectId of the parent Entity.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionView Class > SectionView Members
Legend
Legend
Property
public


Site Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Members
Site Members Public Methods
Site Members
Public Methods
Public Method | Description
Create | Creates a new site.
GetAlignmentIds | Gets the objectId collection of all alignment objects in the site.
GetFeatureLineIds | Gets the objectId collection of all feature lines in the site.
GetParcelIds | Gets the objectId collection of all parcels in the site.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Members
Legend
Legend
Method
public


Site Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Members
Site Members Public Properties
Site Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Members
Legend
Legend
Property
public


Station Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Members
Station Members Public Properties
Station Members
Public Properties
Public Property | Description
GeometryStationType | Gets the geometry point station type.
Location | Gets the station's location.
RawStation | Gets the station's raw station.
StationType | Gets the station type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Members
Legend
Legend
Property
public


StationEquation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Members
StationEquation Members Public Properties
StationEquation Members
Public Properties
Public Property | Description
EquationType | Gets or sets the type of station equation.
RawStationBack | Gets or sets the raw back station value.
StationAhead | Gets or sets the ahead station value.
StationBack | Gets or sets the back station value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Members
Legend
Legend
Property
public


StationEquationCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Members
StationEquationCollection Members Public Methods
StationEquationCollection Members
Public Methods
Public Method | Description
Add | Adds a station equation into the alignment.
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumerator which can be use to enumerate this collection.... more
GetStationEquation | Gets the StationEquation object in the collection by raw station back.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Members
Legend
Legend
Method
public
virtual


StationEquationCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Members
StationEquationCollection Members Public Properties
StationEquationCollection Members
Public Properties
Public Property | Description
Count | Gets the number of StationEquation objects in the collection.
default | Gets the StationEquation object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Members
Legend
Legend
Property
public


StationOffsetLabel Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Members
StationOffsetLabel Members Public Methods
StationOffsetLabel Members
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
Create | Creates a new instance of an AlignmentCurveLabel and adds it to the specified database.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded
SetTextComponentOverride | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Members
Legend
Legend
Method
public
virtual


StationOffsetLabel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Members
StationOffsetLabel Members Public Properties
StationOffsetLabel Members
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorAtXY | Gets or sets a flag to indicate whether the label should move when the alignment is moved or if it... more
AnchorInfo | Gets information about the label anchor.
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
Application | Gets the Application. Not currently implemented.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DimensionAnchorValue | Gets or sets the dimension anchor value.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Dragged | Gets a bool value that specifies whether the label has been dragged.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Flipped | Gets or sets the flipped state of the label.
Flipped | Gets or sets the flipped state of the label.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
LeaderAttachment | Gets or sets the leader attachment option.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
LeaderVisibility | Gets or sets the leader visibility.
Mask | Gets or sets the mask type.
Name | Gets or sets the Entity object's name.
Pinned | Gets or sets the pinned state of the label.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
Reversed | Gets or sets the reversed state of the label.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleId | Gets or sets the label style id.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
StyleName | Gets or sets the Entity object's style name.
ViewId | Gets the ObjectId of the view where the label exists.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Members
Legend
Legend
Property
public


AlignmentDesignCheckSet Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Members
AlignmentDesignCheckSet Members Public Methods
AlignmentDesignCheckSet Members
Public Methods
Public Method | Description
AddDesignCheck | Add one design check into this AlignmentDesignCheckSet.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetAllDesignChecks | Gets all design checks in this AlignmentDesignCheckSet.
RemoveAllDesignCheck | Remove all design checks from this AlignmentDesignCheckSet.
RemoveDesignCheck | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Members
Legend
Legend
Method
public
virtual


AlignmentDesignCheckSet Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Members
AlignmentDesignCheckSet Members Public Properties
AlignmentDesignCheckSet Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Members
Legend
Legend
Property
public


AlignmentDesignCheckSetCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class > AlignmentDesignCheckSetCollection Members
AlignmentDesignCheckSetCollection Members Public Methods
AlignmentDesignCheckSetCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class > AlignmentDesignCheckSetCollection Members
Legend
Legend
Method
public
virtual


AlignmentDesignCheckSetCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class > AlignmentDesignCheckSetCollection Members
AlignmentDesignCheckSetCollection Members Public Properties
AlignmentDesignCheckSetCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class > AlignmentDesignCheckSetCollection Members
Legend
Legend
Property
public


AlignmentStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Members
AlignmentStyle Members Public Methods
AlignmentStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the Alignment component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the Alignment component.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies the line marker in section display properties for the Alignment component.
GetLineMarkerDisplayStyleSection | Gets the display style for line markers in section view orientation.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Members
Legend
Legend
Method
public
virtual


AlignmentStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Members
AlignmentStyle Members Public Properties
AlignmentStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
ArrowHeadOption | Gets the alignment arrow head option.
BeginPointMarkerStyle | Gets or sets the marker style object id for 'begin of alignment' points on the alignment.
CompoundCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'compound curve intersection' points on the alignment.
CreateBy | Gets or Sets the "Created by" string for the style.
CurveLineIntersectPointMarkerStyle | Gets or sets the marker style object id for 'curve line intersection' points on the alignment.
CurveSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'curve spiral intersection' points on the alignment.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
EnableRadiusSnap | Gets or sets the boolean value that specifies whether to enable snapping when changing the curve radius value.
EndPointMarkerStyle | Gets or sets the marker style object id for 'end of alignment' points on the alignment.
IntersectionPointMarkerStyle | Gets or sets the marker style object id for 'point of intersection' points on the alignment.
LineCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'line curve intersection' points on the alignment.
LineMarkerDisplayStyleSection | Gets the display style for line markers in section view orientation.
LineSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'line spiral intersection' points on the alignment.
MidPointMarkerStyle | Gets or sets the marker style object id for mid points on the alignment.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RadiusSnapValue | Gets or sets the even increment value by which a curve radius can change using snapping.
ReverseCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'reverse curve intersection' points on the alignment.
ReverseSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'reverse spiral intersection' points on the alignment.
SpiralCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral curve intersection' points on the alignment.
SpiralLineIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral line intersection' points on the alignment.
SpiralSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral spiral intersection' points on the alignment.
StationReferencePointMarkerStyle | Gets or sets the marker style object id for 'station reference' points on the alignment.
ThroughPointMarkerStyle | Gets or sets the marker style object id for 'through points' on the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Members
Legend
Legend
Property
public


AlignmentStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class > AlignmentStyleCollection Members
AlignmentStyleCollection Members Public Methods
AlignmentStyleCollection Members
Public Methods
Public Method | Description
Add |
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class > AlignmentStyleCollection Members
Legend
Legend
Method
public
virtual


AlignmentStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class > AlignmentStyleCollection Members
AlignmentStyleCollection Members Public Properties
AlignmentStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class > AlignmentStyleCollection Members
Legend
Legend
Property
public


ArrowHeadOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Members
ArrowHeadOption Members Public Properties
ArrowHeadOption Members
Public Properties
Public Property | Description
ArrowBlockName | Gets or Sets the arrow block name.
ArrowType | Gets or Sets the arrow head drawing type.
Fit | Gets or Sets the arrow head fit option.
FixedScaleX | Gets or Sets the arrow head fixed scale in X.
FixedScaleY | Gets the arrow head fixed scale in Y.
FixedScaleZ | Gets the arrow head fixed scale in Z.
SizeOption | Gets or Sets the arrow head size option.
SizeValue | Gets or Sets the arrow head size value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Members
Legend
Legend
Property
public


BuildingSiteStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Members
BuildingSiteStyle Members Public Methods
BuildingSiteStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the BuildingSite component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the BuildingSite component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Members
Legend
Legend
Method
public
virtual


BuildingSiteStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Members
BuildingSiteStyle Members Public Properties
BuildingSiteStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerStyleId | Gets or sets the object id of the marker style for the building site style.
MarkerStyleName | Gets or sets the name of the marker style for the building site style.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Members
Legend
Legend
Property
public


BuildingSiteStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class > BuildingSiteStyleCollection Members
BuildingSiteStyleCollection Members Public Methods
BuildingSiteStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class > BuildingSiteStyleCollection Members
Legend
Legend
Method
public
virtual


BuildingSiteStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class > BuildingSiteStyleCollection Members
BuildingSiteStyleCollection Members Public Properties
BuildingSiteStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class > BuildingSiteStyleCollection Members
Legend
Legend
Property
public


ContourValues Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Members
ContourValues Members Public Properties
ContourValues Members
Public Properties
Public Property | Description
MajorColor | Gets or sets the color for major contours.
MajorLineTypeId | Gets or sets the ObjectId of the major line type.
MajorLineWight | Gets or sets the major line weight.
MinorColor | Gets or sets the color for minor contours.
MinorLineTypeId | Gets or sets the ObjectId of the minor line type.
MinorLineWight | Gets or sets the minor line weight.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Members
Legend
Legend
Property
public


GradingCriteria Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Members
GradingCriteria Members Public Methods
GradingCriteria Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current grading criteria and add to the grading criteria set as a sibling.
ExportTo | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Members
Legend
Legend
Method
public
virtual


GradingCriteria Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Members
GradingCriteria Members Public Properties
GradingCriteria Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
CutSlope | Specifies the cut grade value.
CutSlopeFormatType | Specifies how the cut slope should be represented.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Distance | Specifies that the grading projection lines will be extended from the footprint until they are match a specified horizontal distance.... more
DistanceProjectionType | Specifies the type of projection for the Distance target.
Document | Gets the Document associated with the DBObject. Not implemented.
Elevation | Specifies that the grading projection lines will be extended from the footprint until they reach a specified elevation.
ElevationProjectionType | Specifies the type of projection for the Elevation target.
FillSlope | Specifies the fill grade value.
FillSlopeFormatType | Specifies how the fill slope should be represented.
InteriorCornerOverlap | Specifies how interior corner projections are cleaned up when the footprint corner has different elevations.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ProjectionDistance | Specifies the fixed distance from the footprint for the projection.
ProjectionRelativeElevation | Specifies the projection relative elevation.
RelativeElevation | Specifies that the grading projection lines will be extended from the footprint until they reach an elevation (depth or height)... more
RelativeElevationProjectionType | Specifies the type of projection for the Relative Elevation target.
SearchOrder | Specifies whether to search first for cut or fill slopes in cases where both would work.
Slope | Specifies the grade value.
SlopeFormatType | Specifies how the slope should be represented.
SurfaceProjectionType | Specifies the type of projection for the Surface target.
Target | Specifies the target method for the grading.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Members
Legend
Legend
Property
public


GradingCriteriaCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class > GradingCriteriaCollection Members
GradingCriteriaCollection Members Public Methods
GradingCriteriaCollection Members
Public Methods
Public Method | Description
Add | Adds a GradingCriteria object to the collection by name.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class > GradingCriteriaCollection Members
Legend
Legend
Method
public
virtual


GradingCriteriaCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class > GradingCriteriaCollection Members
GradingCriteriaCollection Members Public Properties
GradingCriteriaCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class > GradingCriteriaCollection Members
Legend
Legend
Property
public


GradingCriteriaSet Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Members
GradingCriteriaSet Members Public Methods
GradingCriteriaSet Members
Public Methods
Public Method | Description
AddCriteria | Add a new grading criteria to the current set.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GradingCriteriaIds | Gets the objectId collection of all grading criteria objects in the set.
MoveCriteria | Overloaded
RemoveCriteria | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Members
Legend
Legend
Method
public
virtual


GradingCriteriaSet Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Members
GradingCriteriaSet Members Public Properties
GradingCriteriaSet Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the number of grading criteria in the current grading criteria set.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the grading criteria by name.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Members
Legend
Legend
Property
public


GradingCriteriaSetCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class > GradingCriteriaSetCollection Members
GradingCriteriaSetCollection Members Public Methods
GradingCriteriaSetCollection Members
Public Methods
Public Method | Description
Add | Adds a GradingCriteriaSet to the collection by name.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class > GradingCriteriaSetCollection Members
Legend
Legend
Method
public
virtual


GradingCriteriaSetCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class > GradingCriteriaSetCollection Members
GradingCriteriaSetCollection Members Public Properties
GradingCriteriaSetCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class > GradingCriteriaSetCollection Members
Legend
Legend
Property
public


GradingStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Members
GradingStyle Members Public Methods
GradingStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the grading component Model display color, layer, linetype, etc.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the grading component Plan display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Members
Legend
Legend
Method
public
virtual


GradingStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Members
GradingStyle Members Public Properties
GradingStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CenterMarker | Gets or Sets the MarkerSizeType enum value that specifies the size of the marker and how it is calculated.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
FixedSize | Gets or sets the marker size that is specified in the current drawing units (usually feet or meters).
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PercentageOfScreen | Gets or sets the current zoom level of the marker size.
PlottedSize | Gets or sets the marker size that is based on the current drawing scale(inches or millimeters).
SlopePatternStyleId | Gets or sets the object id of the slope pattern style for the grading style.
SlopePatternStyleName | Gets or sets the name of the slope pattern style for the grading style.
SlopeRangeMax | Gets or sets the maximum value of the slope value.
SlopeRangeMin | Gets or sets the minimum value of the slope value.
UseSlopePatternStyle | Gets or sets a bool value that specifies whether use a slope pattern style for the grading style.
UseSlopeRange | Gets or sets a bool value that specifies whether the slope pattern is applied to a limited range of slope... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Members
Legend
Legend
Property
public


GradingStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Members
GradingStyleCollection Members Public Methods
GradingStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded
SetCenterMarkerVisable | Specifies whether the center marker of all grading styles is visable in the current view port(Plan/Model).
SetSlopePatternVisable | Specifies whether the slope pattern of all grading styles is visable in the current view port(Plan/Model).


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Members
Legend
Legend
Method
public
virtual


GradingStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Members
GradingStyleCollection Members Public Properties
GradingStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Members
Legend
Legend
Property
public


GroupPlotStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Members
GroupPlotStyle Members Public Methods
GroupPlotStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Members
Legend
Legend
Method
public
virtual


GroupPlotStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Members
GroupPlotStyle Members Public Properties
GroupPlotStyle Members
Public Properties
Public Property | Description
AlignType | Gets or sets the GroupPlotAlignType enum value that specifies how the section views are aligned.
Application | Gets the Application associated with the DBObject. Not implemented.
CellSizeType | Gets or sets the GroupPlotCellSizeType enum value that specifies cell size as either uniform or uniform row/column.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GapBetweenPages | Gets of sets the plotted distance between each successive page in a multiple section view plot.
MaximumInColumn | Gets or sets the maximum number of cross section views plotted in a column before moving on to the next... more
MaximumInRow | Gets or sets the maximum number of cross section views plotted in a row before moving on to the next... more
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PlotAreaType | Gets or sets the GroupPlotAreaType enum value that specifies whether to plot page by page or plot all.
PlotRule | Gets or sets the SectionViewPlotRuleType enum value that specifies whether to plot the section views by column or row.
SheetStyleId | Gets or sets the object id of the sheet style for the GroupPlotStyle.
SheetStyleName | Gets or sets the name of the sheet style for the GroupPlotStyle.
SpaceColumn | Gets or sets the minimum number of major grid lines between columns of section views.
SpaceRow | Gets or sets the minimum number of major grid lines between rows of section views.
StartCorner | Gets or sets the GroupPlotStartCornerType enum value that specifies the starting corner type for plotting the section views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Members
Legend
Legend
Property
public


GroupPlotStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class > GroupPlotStyleCollection Members
GroupPlotStyleCollection Members Public Methods
GroupPlotStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class > GroupPlotStyleCollection Members
Legend
Legend
Method
public
virtual


GroupPlotStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class > GroupPlotStyleCollection Members
GroupPlotStyleCollection Members Public Properties
GroupPlotStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class > GroupPlotStyleCollection Members
Legend
Legend
Property
public


HorizontalGeometryBandStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Members
HorizontalGeometryBandStyle Members Public Methods
HorizontalGeometryBandStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the HorizontalGeometry component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Members
Legend
Legend
Method
public
virtual


HorizontalGeometryBandStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Members
HorizontalGeometryBandStyle Members Public Properties
HorizontalGeometryBandStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
CurveLabelStyleId | Gets the band horizontal label style id at the curve.
CurveTickStyle | Gets the band horizontal tick style at the curve.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SchematicLineType | Gets the band horizontal line type at the schematic.
SpiralLabelStyleId | Gets the band horizontal geometry spiral label style id at the horizontal.
SpiralTickStyle | Gets the band horizontal tick style at the spiral.
TangentLabelStyleId | Gets the band horizontal label style id at the tangent.
TangentTickStyle | Gets the band horizontal tick style at the tangent.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Members
Legend
Legend
Property
public


LabelStylesAlignmentRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Members
LabelStylesAlignmentRoot Members Public Properties
LabelStylesAlignmentRoot Members
Public Properties
Public Property | Description
CurveLabelStyles | Gets the collection of styles associated with an alignment's curve labels.
DefaultLabelStyle | Gets the default vaules of label styles.
DesignSpeedLabelStyles | Gets the collection of styles for design speedon the alignment.
GeometryPointLabelStyles | Gets the collection of all alignment geometry point label styles.
LineLabelStyles | Gets the collection of all alignment line label styles.
MajorStationLabelStyles | Gets the collection of all alignment major station label styles.
MinorStationLabelStyles | Gets the collection of all alignment minor station label styles.
SpiralLabelStyles | Gets the collection of all alignment spiral label styles.
StationEquationLabelStyles | Gets the collection of all alignment station equation label styles.
StationOffsetLabelStyles | Gets the collection of all alignment station offset label styles.
SuperelevationCriticalPointsLabelStyles | Gets the collection of all alignment superelevation Critical points label styles.
TangentIntersectionLabelStyles | Gets the collection of all alignment tangent intersection label styles.
VerticalGeometryPointLabelStyles | Gets the collection of all alignment vertical geometry point label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Members
Legend
Legend
Property
public


LabelStylesMatchLineRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class > LabelStylesMatchLineRoot Members
LabelStylesMatchLineRoot Members Public Properties
LabelStylesMatchLineRoot Members
Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
LeftLabelStyles | Gets the collection of all match line left label styles.
RightLabelStyles | Gets the collection of all match line right label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class > LabelStylesMatchLineRoot Members
Legend
Legend
Property
public


LabelStylesProfileRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Members
LabelStylesProfileRoot Members Public Properties
LabelStylesProfileRoot Members
Public Properties
Public Property | Description
CurveLabelStyles | Gets the collection of all profile curve label styles.
DefaultLabelStyle | Gets the default vaules of label styles.
GradeBreadLabelStyles | Gets the collection of all profile grade break label styles.
GradeBreakLabelStyles | Gets the collection of all profile grade break label styles.
HorizontalGeometryPointLabelStyles | Gets the collection of all profile horizontal geometry point label styles.
LineLabelStyles | Gets the collection of all profile line label styles.
MajorStationLabelStyles | Gets the collection of all profile major station label styles.
MinorStationLabelStyles | Gets the collection of all profile minor station label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Members
Legend
Legend
Property
public


MassHaulLineStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Members
MassHaulLineStyle Members Public Methods
MassHaulLineStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the MassHaulLine component.
GetHatchDisplayStyleProfile | Gets the HatchDisplayStyle object that specifies profile display properties for the MassHaulLine component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Members
Legend
Legend
Method
public
virtual


MassHaulLineStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Members
MassHaulLineStyle Members Public Properties
MassHaulLineStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
FreeHaulOption | Gets the FreeHaulDisplayType enumeration that defines how to show the free haul in the graph.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Members
Legend
Legend
Property
public


MassHaulLineStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class > MassHaulLineStyleCollection Members
MassHaulLineStyleCollection Members Public Methods
MassHaulLineStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class > MassHaulLineStyleCollection Members
Legend
Legend
Method
public
virtual


MassHaulLineStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class > MassHaulLineStyleCollection Members
MassHaulLineStyleCollection Members Public Properties
MassHaulLineStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class > MassHaulLineStyleCollection Members
Legend
Legend
Property
public


MassHaulViewStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Members
MassHaulViewStyle Members Public Methods
MassHaulViewStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the masshual view component plan display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Members
Legend
Legend
Method
public
virtual


MassHaulViewStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Members
MassHaulViewStyle Members Public Properties
MassHaulViewStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomAxis | Gets the style object that specifies display properties for masshual view bottom axes.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GraphStyle | Gets the style object that specifies all display properties for masshual view graphs.
GridStyle | Gets the style object that specifies display properties for masshual view grid.
LeftAxis | Gets the style object that specifies display properties for masshual view left axes.
MiddleAxis | Gets the style object that specifies display properties for masshual view midlle axes.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RightAxis | Gets the style object that specifies display properties for masshual view right axes.
TopAxis | Gets the style object that specifies display properties for masshual view top axes.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Members
Legend
Legend
Property
public


MassHaulViewStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class > MassHaulViewStyleCollection Members
MassHaulViewStyleCollection Members Public Methods
MassHaulViewStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class > MassHaulViewStyleCollection Members
Legend
Legend
Method
public
virtual


MassHaulViewStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class > MassHaulViewStyleCollection Members
MassHaulViewStyleCollection Members Public Properties
MassHaulViewStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class > MassHaulViewStyleCollection Members
Legend
Legend
Property
public


MatchLineStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Members
MatchLineStyle Members Public Methods
MatchLineStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetLinesDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match lines.
GetMatchLineMaskDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match line mask areas.
GetMatchLineMaskHatchDisplayStyle | Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Members
Legend
Legend
Method
public
virtual


MatchLineStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Members
MatchLineStyle Members Public Properties
MatchLineStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
LinesDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match lines.
MatchLineMaskDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match line mask areas.
MatchLineMaskHatchDisplayStyle | Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Members
Legend
Legend
Property
public


ParcelStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Members
ParcelStyle Members Public Methods
ParcelStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetAreaFillHatchDisplayStyleModel | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle,... more
GetAreaFillHatchDisplayStylePlan | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle,... more
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the Parcel component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the Parcel component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Members
Legend
Legend
Method
public
virtual


ParcelStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Members
ParcelStyle Members Public Properties
ParcelStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
AreaFillHatchDisplayStyleModel | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle,... more
AreaFillHatchDisplayStylePlan | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle,... more
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
NameTemplate | Gets or sets the parcel name template string.
ObservePatternFillDistance | Gets or sets the boolean value that enables the use of the width of boundary area parcel setting, the offset... more
PatternFillDistance | Gets or sets the width of the boundary area parcel setting, which is the offset distance from the parcel boundary.... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Members
Legend
Legend
Property
public


PointStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Members
PointStyle Members Public Methods
PointStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the point component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the point component.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the point component.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties for the point component.
GetLabelDisplayStyleModel | Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.
GetLabelDisplayStylePlan | Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Members
Legend
Legend
Method
public
virtual


PointStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Members
PointStyle Members Public Properties
PointStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
CustomMarkerStyle | Gets or sets a long value specifying a custom marker style.
CustomMarkerSuperimposeStyle | Gets or sets the CustomMarkerSuperimposeType enum value that specifies the shape superimposed on the custom point style marker as either... more
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Display3dType | Gets or sets the PointDisplay3dType enum value that specifies how the display elevation of the Points is established when view... more
Document | Gets the Document associated with the DBObject. Not implemented.
Elevation | Gets or sets the point's elevation if the points are to be flattened to an elevation.
LabelDisplayStyleModel | Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.
LabelDisplayStylePlan | Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
MarkerFixedScale | Gets or sets a fixed scale used to scale the point symbol.
MarkerRotationAngle | Gets or sets the marker's rotation angle.
MarkerSize | Gets or sets the marker size in drawing units.
MarkerSymbolName | Gets or sets a string value that represents the marker symbol block name.
MarkerType | Gets or sets the marker to an AutoCAD point, a customer mark, or a symbol.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
Orientation | Gets or sets the MarkerOrientationType enum value that defines how the marker rotation angle is applied.
ScaleFactor | Gets or sets the scale factor for point elevations for when viewing in 3D.
SizeType | Gets or sets the MarkerSizeType enum value that defines how the marker is sized, such as relative to screen, fixed... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Members
Legend
Legend
Property
public


ProfileDataBandStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Members
ProfileDataBandStyle Members Public Methods
ProfileDataBandStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the ProfileData component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Members
Legend
Legend
Method
public
virtual


ProfileDataBandStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Members
ProfileDataBandStyle Members Public Properties
ProfileDataBandStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
HGPLabelStyleId | Gets the band profile data label style id at the horizontal geometry point (HGP).
HGPTickStyle | Gets the band profile data tick style at the horizontal geometry point (HGP).
IncrementalDistanceLabelStyleId | Gets the band profile data label style id at the incremental distance.
MajorIncrementLabelStyleId | Gets the band profile data label style id at the major increment.
MajorIncrementTickStyle | Gets the band profile data tick style at the major increment.
MinorIncrementLabelStyleId | Gets the band profile data label style id at the minor increment.
MinorIncrementTickStyle | Gets the band profile data tick style at the minor increment.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
StationEquationLabelStyleId | Gets the band profile data label style id at the station equation.
StationEquationTickStyle | Gets the band profile data tick style at the station equation.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
VGPLabelStyleId | Gets the band profile data label style id at the vertical geometry point (VGP).
VGPTickStyle | Gets the band profile data tick style at the vertical geometry point (VGP).
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Members
Legend
Legend
Property
public


ProfileDesignCheckSet Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Members
ProfileDesignCheckSet Members Public Methods
ProfileDesignCheckSet Members
Public Methods
Public Method | Description
AddDesignCheck | Overloaded
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetAllDesignChecks | Gets all design checks in this ProfileDesignCheckSet.
GetCurveDesignCheckType | This function will get the curve design check type.
RemoveAllDesignCheck | Remove all design checks from this ProfileDesignCheckSet.
RemoveDesignCheck | Overloaded
RemoveDesignCheck | Overloaded
SetCurveDesignCheckType | This function will set the curve design check type.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Members
Legend
Legend
Method
public
virtual


ProfileDesignCheckSet Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Members
ProfileDesignCheckSet Members Public Properties
ProfileDesignCheckSet Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Members
Legend
Legend
Property
public


ProfileDesignCheckSetCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class > ProfileDesignCheckSetCollection Members
ProfileDesignCheckSetCollection Members Public Methods
ProfileDesignCheckSetCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class > ProfileDesignCheckSetCollection Members
Legend
Legend
Method
public
virtual


ProfileDesignCheckSetCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class > ProfileDesignCheckSetCollection Members
ProfileDesignCheckSetCollection Members Public Properties
ProfileDesignCheckSetCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class > ProfileDesignCheckSetCollection Members
Legend
Legend
Property
public


ProfileLabelSetStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Members
ProfileLabelSetStyle Members Public Methods
ProfileLabelSetStyle Members
Public Methods
Public Method | Description
Add | Overloaded
AddCrestCurve | Creates a label set item of type profile crest curve with the given profile curve object id, adds it to... more
AddSagCurve | Creates a label set item of type profile sag curve with the given profile curve object id, adds it to... more
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an label set item from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Members
Legend
Legend
Method
public
virtual


ProfileLabelSetStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Members
ProfileLabelSetStyle Members Public Properties
ProfileLabelSetStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the number of label set items.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the profile label set item at the given index.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Members
Legend
Legend
Property
public


ProfileStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Members
ProfileStyle Members Public Methods
ProfileStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetChain3DDisplayStyleModel | Gets the AeccDisplayStyle for 3D chain display style in model view orientation.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the Profile component.
GetProfileMarkerDisplayStyleSection | Gets the AeccDisplayStyle for marker display style in section view orientation.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Members
Legend
Legend
Method
public
virtual


ProfileStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Members
ProfileStyle Members Public Properties
ProfileStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
ArrowHeadOption | Gets the profile arrow head option.
BeginPointMarkerStyle | Gets or sets the marker style object id for 'Begin point' on the profile.
Chain3DDisplayStyleModel | Gets the AeccDisplayStyle for 3D chain display style in model view orientation.
ChainTessellationDistance3D | Gets or sets the curve tessellation distance used for 3D chain visualization.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
EndPointMarkerStyle | Gets or sets the marker style object id for 'End point' on the profile
HighPointMarkerStyle | Gets or sets the marker style object id for 'High Point' on the profile
LowPointMarkerStyle | Gets or sets the marker style object id for 'Low Point' on the profile
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ProfileMarkerDisplayStyleSection | Gets the AeccDisplayStyle for marker display style in section view orientation.
ProfileMarkerSectionViewMarkerStyle | Gets or sets the marker style object id for 'Section View' on the profile
ThroughPointMarkerStyle | Gets or sets the marker style object id for 'Through points' on the profile.
VCompoundCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Compound Curve Intersection' on the profile
VCurveTangentIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Curve Tangent intersection' on the profile
VIntersectionPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Intersection' on the profile.
VReverseCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Reverse Curve Intersection' on the profile
VTangentCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Tangent Curve Intersection' on the profile


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Members
Legend
Legend
Property
public


ProfileViewBandSetItem Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Members
ProfileViewBandSetItem Members Public Methods
ProfileViewBandSetItem Members
Public Methods
Public Method | Description
GetAlignmentGeometryPoints | Gets the alignment geometry points from profile data bands.
GetProfileGeometryPoints | Gets the profile geometry points from profile data bands.
SetAlignmentGeometryPoints | Sets the alignment geometry points from profile data bands.
SetProfileGeometryPoints | Sets the profile geometry points from profile data bands.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Members
Legend
Legend
Method
public


ProfileViewBandSetItem Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Members
ProfileViewBandSetItem Members Public Properties
ProfileViewBandSetItem Members
Public Properties
Public Property | Description
BandStyleId | Gets the object that identifies the style for the band type.
Gap | Gets or sets the distance between the current data band and the adjacent grid or data band.
LabelAtEndStation | Gets or sets the label at end station.
LabelAtStartStation | Gets or sets the label at start station.
Location | Gets the BandSetOptionsType enum value that identifies band location and display settings.
MajorInterval | Gets or sets the d view data band major interval distance.
MinorInterval | Gets or sets the section view data band minor interval distance.
StaggerLabel | Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor... more
StaggerLineHeight | Gets or sets height of the label stagger line.
Weeding | Gets or sets the weeding value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Members
Legend
Legend
Property
public


ProfileViewBandSetStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Members
ProfileViewBandSetStyle Members Public Methods
ProfileViewBandSetStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Members
Legend
Legend
Method
public
virtual


ProfileViewBandSetStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Members
ProfileViewBandSetStyle Members Public Properties
ProfileViewBandSetStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomBandSetItems | Gets the bottom band set item collection from profile view band set style.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MatchIncrement | Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor... more
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
TopBandSetItems | Gets the top band set item collection from profile view band set style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Members
Legend
Legend
Property
public


ProfileViewStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Members
ProfileViewStyle Members Public Methods
ProfileViewStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the profile view component plan display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Members
Legend
Legend
Method
public
virtual


ProfileViewStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Members
ProfileViewStyle Members Public Properties
ProfileViewStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomAxis | Gets the style object that specifies display properties for profile view bottom axes.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GraphStyle | Gets the style object that specifies all display properties for profile view graphs.
GridStyle | Gets the style object that specifies display properties for profile view grid.
LeftAxis | Gets the style object that specifies display properties for profile view left axes.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RightAxis | Gets the style object that specifies display properties for profile view right axes.
TopAxis | Gets the style object that specifies display properties for profile view top axes.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Members
Legend
Legend
Property
public


ProfileViewStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class > ProfileViewStyleCollection Members
ProfileViewStyleCollection Members Public Methods
ProfileViewStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class > ProfileViewStyleCollection Members
Legend
Legend
Method
public
virtual


ProfileViewStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class > ProfileViewStyleCollection Members
ProfileViewStyleCollection Members Public Properties
ProfileViewStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class > ProfileViewStyleCollection Members
Legend
Legend
Property
public


SampleLineStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Members
SampleLineStyle Members Public Methods
SampleLineStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the SampleLine component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SampleLine component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Members
Legend
Legend
Method
public
virtual


SampleLineStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Members
SampleLineStyle Members Public Properties
SampleLineStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Members
Legend
Legend
Property
public


SectionalDataBandStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Members
SectionalDataBandStyle Members Public Methods
SectionalDataBandStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionalData component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Members
Legend
Legend
Method
public
virtual


SectionalDataBandStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Members
SectionalDataBandStyle Members Public Properties
SectionalDataBandStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
IncrementalSectionDataLabelStyleId | Gets the band section data label style id at the incremental section data.
IncrementalSectionDataTickStyle | Gets the band section data tick style at the incremental section data.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SampleLineStationLabelStyleId | Gets the band section data label style id at the sample line station.
SampleLineStationTickStyle | Gets the band section data tick style at the sample line station.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Members
Legend
Legend
Property
public


SectionDataBandStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Members
SectionDataBandStyle Members Public Methods
SectionDataBandStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionData component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Members
Legend
Legend
Method
public
virtual


SectionDataBandStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Members
SectionDataBandStyle Members Public Properties
SectionDataBandStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CenterlineLabelStyleId | Gets the band section data label style id at the centerline.
CenterlineTickStyle | Gets the band section data tick style at the centerline.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GradeBreaksLabelStyleId | Gets the band section data label style id at the grade breaks.
GradeBreaksTickStyle | Gets the band section data tick style at the grade breaks.
IncrementalDistanceLabelStyleId | Gets the band section data label style id at the incremental distance.
MajorIncrementLabelStyleId | Gets the band section data label style id at the major increment.
MajorIncrementTickStyle | Gets the band section data tick style at the major increment.
MinorIncrementLabelStyleId | Gets the band section data label style id at the minor increment.
MinorIncrementTickStyle | Gets the band section data tick style at the minor increment.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SampleLineVerticesLabelStyleId | Gets the band section data label style id at the sample line vertices.
SampleLineVerticesTickStyle | Gets the band section data tick style at the sample line vertices.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Members
Legend
Legend
Property
public


SectionSegmentBandStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Members
SectionSegmentBandStyle Members Public Methods
SectionSegmentBandStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionalSegment component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Members
Legend
Legend
Method
public
virtual


SectionSegmentBandStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Members
SectionSegmentBandStyle Members Public Properties
SectionSegmentBandStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SegmentLabelsTickStyle | Gets the band section data tick style at the segment labels.
SegmentsLabelStyleId | Gets the band section data label style id at the segment labels.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Members
Legend
Legend
Property
public


SectionStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class > SectionStyle Members
SectionStyle Members Public Methods
SectionStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties for the Section component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class > SectionStyle Members
Legend
Legend
Method
public
virtual


SectionStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class > SectionStyle Members
SectionStyle Members Public Properties
SectionStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class > SectionStyle Members
Legend
Legend
Property
public


SectionViewBandSetItem Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Members
SectionViewBandSetItem Members Public Properties
SectionViewBandSetItem Members
Public Properties
Public Property | Description
BandStyleId | Gets the object that identifies the style for the band type.
Gap | Gets or sets the distance between the current data band and the adjacent grid or data band.
LabelAtEndOffset | Gets or sets the label at end offset.
LabelAtStartOffset | Gets or sets the label at start offset.
Location | Gets the BandSetOptionsType enum value that identifies band location and display settings.
MajorInterval | Gets or sets the section view data band major interval distance.
MinorInterval | Gets or sets the section view data band minor interval distance.
StaggerLabel | Gets or sets the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or Stagger... more
StaggerLineHeight | Gets or sets the height of the label stagger line.
Weeding | Gets or sets the weeding value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Members
Legend
Legend
Property
public


SectionViewBandSetItemCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Members
SectionViewBandSetItemCollection Members Public Methods
SectionViewBandSetItemCollection Members
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes an item from the collection.
Swap | Swap two items in the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Members
Legend
Legend
Method
public
virtual


SectionViewBandSetItemCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Members
SectionViewBandSetItemCollection Members Public Properties
SectionViewBandSetItemCollection Members
Public Properties
Public Property | Description
Count | Gets the number of band style sets in the collection.
default | Gets the profile view band set item at the given index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Members
Legend
Legend
Property
public


SectionViewBandSetStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Members
SectionViewBandSetStyle Members Public Methods
SectionViewBandSetStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Members
Legend
Legend
Method
public
virtual


SectionViewBandSetStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Members
SectionViewBandSetStyle Members Public Properties
SectionViewBandSetStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomBandSetItems | Gets the bottom band set item collection from section view band set style.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MatchIncrement | Gets or sets if the section data band major/minor interval distances for Section views matches the section view style’s major/minor... more
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
TopBandSetItems | Gets the top band set item collection from section view band set style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Members
Legend
Legend
Property
public


SectionViewStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Members
SectionViewStyle Members Public Methods
SectionViewStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the section view component plan display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Members
Legend
Legend
Method
public
virtual


SectionViewStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Members
SectionViewStyle Members Public Properties
SectionViewStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BottomAxis | Gets the style object that specifies display properties for section view bottom axes.
CenterAxis | Gets the style object that specifies display properties for section view center axes.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GraphStyle | Gets the style object that specifies all display properties for section view graphs.
GridStyle | Gets the style object that specifies display properties for section view grid.
LeftAxis | Gets the style object that specifies display properties for section view left axes.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RightAxis | Gets the style object that specifies display properties for section view right axes.
TopAxis | Gets the style object that specifies display properties for section view top axes.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Members
Legend
Legend
Property
public


SheetStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Members
SheetStyle Members Public Methods
SheetStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayPlan | Gets the DisplayStyle object that specifies plan display properties for the SheetStyle component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Members
Legend
Legend
Method
public
virtual


SheetStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Members
SheetStyle Members Public Properties
SheetStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
GridHorizontalMajor | Gets or Sets the value of sheet style's horizontal major plot area grid.
GridHorizontalMinor | Gets or Sets the value of sheet style's horizontal minor plot area grid.
GridVerticalMajor | Gets or Sets the value of sheet style's vertical major plot area grid.
GridVerticalMinor | Gets or Sets the value of sheet style's vertical minor plot area grid.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PageLayoutId | Gets or Sets the object id of the sheet style's page layout.
PageMarginBottom | Gets or Sets the sheet style's bottom page margin.
PageMarginLeft | Gets or Sets the sheet style's left page margin.
PageMarginRight | Gets or Sets the sheet style's right page margin.
PageMarginTop | Gets or Sets the sheet style's top page margin.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Members
Legend
Legend
Property
public


SlopePatternComponent Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class > SlopePatternComponent Members
SlopePatternComponent Members Public Properties
SlopePatternComponent Members
Public Properties
Public Property | Description
SlopeLine | Gets the slope line class in the component.
SlopeLineOffset | Gets the slope line offset class in the component.
SlopeLineSymbol | Gets the slope line symbol class in the component.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class > SlopePatternComponent Members
Legend
Legend
Property
public


SlopePatternLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Members
SlopePatternLine Members Public Properties
SlopePatternLine Members
Public Properties
Public Property | Description
Color | Specifies the color of the line.
Grade1 | Specifies the first grade values for the component.
Grade2 | Specifies the second grade values for the component.
Length | Specifies the length value in drawing units (usually feet or meters). The line is trimmed if the slope is shorter... more
LengthType | Specifies how to determine the line length for this component.
Linetype | Specifies the linetype for the component.
LineWeight | Specifies the lineweight for the component.
MaximumLength | Specifies the maximum line length in drawing units.
PercentofLength | Specifies the percentage value up to a specified maximum.
PercentofLength1 | Specifies the line length as a percent of slope length for Slope 1.
PercentofLength2 | Specifies the line length as a percent of slope length for Slope 2.
StartType | Specifies whether the pattern begins at the top or bottom of the slope.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Members
Legend
Legend
Property
public


SlopePatternLineOffset Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Members
SlopePatternLineOffset Members Public Properties
SlopePatternLineOffset Members
Public Properties
Public Property | Description
Distance | Specifies the linear value in drawing units (usually feet or meters).
MaximumDistance | Specifies maximum offsets value in drawing units.
MinimumDistance | Specifies minimum offsets value in drawing units.
Numberoflines | Specifies the number of instances of this component to insert.
OffsetType | Specifies how to determine the offset distance between this component and the previous component in the slope line style.
PercentofLength | Specifies the percentage to the slope length at the position being offset from.
RadialOffsetAngle | Specifies the angular value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Members
Legend
Legend
Property
public


SlopePatternLineSymbol Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Members
SlopePatternLineSymbol Members Public Properties
SlopePatternLineSymbol Members
Public Properties
Public Property | Description
BlockName | Specifies the block to insert.
Color | Specifies the color of the symbol.
Length | Specifies the length value in drawing units (usually feet or meters).
LengthType | Specifies how to determine the length of the symbol.
Linetype | Specifies the linetype for the symbol.
LineWeight | Specifies the lineweight for the symbol.
Numberoflines | Specifies the number of lines to include in the tapered lines set.
PercentofLength | Specifies the percentage value to the slope length.
SymbolType | Specifies whether a symbol is added to the beginning of the slope line.
WidthRatio | Specifies the ratio of the symbol’s width to its length along the slope line (width = length * width ratio).... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Members
Legend
Legend
Property
public


SlopePatternStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Members
SlopePatternStyle Members Public Methods
SlopePatternStyle Members
Public Methods
Public Method | Description
AddComponent | Adds a new component using the default parameters in a specified position.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
CopyComponent | Copy a component and insert into the slope pattern style.
ExportTo | Overloaded
RemoveAt | Removes the component from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Members
Legend
Legend
Method
public
virtual


SlopePatternStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Members
SlopePatternStyle Members Public Properties
SlopePatternStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets slope pattern style components' count.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the slope pattern component by index.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MinDisplayLength | Gets or sets the minimum slope length on which to display the slope pattern.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PreviewFeatureLength | Gets or sets the length of the feature line to display.
PreviewSlope | Gets or sets the slope value to display.
PreviewSlopeLength | Gets or sets the length of the slope to display.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Members
Legend
Legend
Property
public


SlopePatternStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class > SlopePatternStyleCollection Members
SlopePatternStyleCollection Members Public Methods
SlopePatternStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class > SlopePatternStyleCollection Members
Legend
Legend
Method
public
virtual


SlopePatternStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class > SlopePatternStyleCollection Members
SlopePatternStyleCollection Members Public Properties
SlopePatternStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class > SlopePatternStyleCollection Members
Legend
Legend
Property
public


SuperelevationDataBandStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Members
SuperelevationDataBandStyle Members Public Methods
SuperelevationDataBandStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SuperelevationData component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Members
Legend
Legend
Method
public
virtual


SuperelevationDataBandStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Members
SuperelevationDataBandStyle Members Public Properties
SuperelevationDataBandStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
FullSuperLabelStyleId | Gets the band label style id at the full super.
FullSuperTickStyle | Gets the band tick style at the full super.
LevelCrownLabelStyleId | Gets the band label style id at the level crown.
LevelCrownTickStyle | Gets the band tick style at the level crown.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
NormalCrownLabelStyleId | Gets the band label style id at the normal crown.
NormalCrownTickStyle | Gets the band tick style at the normal crown.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
ReverseCrownLabelStyleId | Gets the band label style id at the reverse crown.
ReverseCrownTickStyle | Gets the band tick style at the reverse crown.
ShoulderCriticalPointsLabelStyleId | Gets the band label style id at the shoulder critical points.
ShoulderCriticalPointsTickStyle | Gets the band tick style at the shoulder critical points.
SlopeTransitionRegionLabelStyleId | Gets the band label style id at the slope transition region.
SlopeTransitionRegionTickStyle | Gets the band tick style at the slope transition region.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Members
Legend
Legend
Property
public


SurfaceBaseStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class > SurfaceBaseStyle Members
SurfaceBaseStyle Members Public Properties
SurfaceBaseStyle Members
Public Properties
Public Property | Description
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class > SurfaceBaseStyle Members
Legend
Legend
Property
public


SurfaceContourStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Members
SurfaceContourStyle Members Public Methods
SurfaceContourStyle Members
Public Methods
Public Method | Description
GetContourValues | Gets an array of ContourValues that represent how to render major and minor contours.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Members
Legend
Legend
Method
public


SurfaceContourStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Members
SurfaceContourStyle Members Public Properties
SurfaceContourStyle Members
Public Properties
Public Property | Description
BaseElevationInterval | Gets or sets the double value used to specify the contour base elevation interval.
DepressionTickMarkInterval | Gets or sets the double value that specifies the spacing of the tick marks along the depression contour.
DepressionTickMarkLength | Gets or sets the double value that specifies the length of the tick mark that is drawn normal to the... more
DisplayDepressions | Gets or sets the boolean value that specifies whether depression contours are displayed.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupRangeValuesBy | Gets or sets the GroupValuesByType enum value used to specify how to group the contour range values.
LegendStyleId | Gets or sets the string value that specifies the surface contour legend style.
LegendStyleName | Gets or sets the string value that specifies the surface contour legend style.
MajorContourColorScheme | Gets or sets the major color scheme for the contour range.
MajorContourInterval | Gets or sets the double value used to specify the number of minor contours per major contour.
MinorContourColorScheme | Gets or sets the minor color scheme for the contour range.
MinorContourInterval | Gets or sets the double value used to specify the contour interval.
NumberOfRanges | Gets or sets the long value that specifies the number of ranges to be used.
RangePrecision | Gets or sets the PrecisionRangeType enum value that specifies the range precision.
SmoothContours | Gets or sets the boolean value that specifies whether contours are smoothed.
SmoothingFactor | Gets or sets an int value that specifies the degree to which the surface is smoothed.
SmoothingType | Gets or sets the ContourSmoothingType enum value that specifies the type of smoothing used. This property is usable only when... more
UseColorScheme | Gets or sets the boolean value that specifies whether the major and minor color schemes are displayed.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Members
Legend
Legend
Property
public


SurfaceDirectionStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Members
SurfaceDirectionStyle Members Public Properties
SurfaceDirectionStyle Members
Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme name.
DisplayEntityMode | Gets or sets the DisplayType Specifies how the surface should be displayed/rendered.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface directional data is grouped.
LegendStyleId | Gets or sets the ObjectId value that specifies the surface direction legend style.
LegendStyleName | Gets or sets the string value that specifies the surface direction legend style.
NumberOfRanges | Gets or sets the number of directional ranges.
RangePrecision | Gets or sets the PrecisionRangeType Specifies the precision to use for the directional ranges included in this style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Members
Legend
Legend
Property
public


SurfaceElevationStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Members
SurfaceElevationStyle Members Public Properties
SurfaceElevationStyle Members
Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme for the range.
DisplayEntityMode | Gets or sets the 3D display behavior of the surface object sub-component.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface elevation data is grouped.
LegendStyleId | Gets or sets the ObjectId value that specifies the surface elevation legend style.
LegendStyleName | Gets or sets the string value that specifies the surface elevation legend style.
NumberOfRanges | Gets or sets the number of surface elevation range values to be used.
RangePrecision | Gets or sets the surface elevation range precision value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Members
Legend
Legend
Property
public


SurfacePointStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Members
SurfacePointStyle Members Public Properties
SurfacePointStyle Members
Public Properties
Public Property | Description
DataPointsColor | Gets or sets the value specifying the true color of the data point display.
DataPointsSymbol | Gets or sets the value specifying the symbology of the data point display.
DerivedPointsColor | Gets or sets the value specifying the true color of the derived point display.
DerivedPointsSymbol | Gets or sets the value specifying the symbology of the derived point display.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
NondestructivePointsColor | Gets or sets the value specifying the true color of the non-destructive point display.
NondestructivePointsSymbol | Gets or sets the value specifying the symbology of the non-destructive point display.
ScalingMethodType | Gets or sets the ScaleType enum value that specifies how to scale the point marker.
Units | Gets or sets the units property.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Members
Legend
Legend
Property
public


SurfaceSlopeArrowStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Members
SurfaceSlopeArrowStyle Members Public Properties
SurfaceSlopeArrowStyle Members
Public Properties
Public Property | Description
ArrowScale | Gets or sets the scale in which slope arrows are drawn.
ArrowType | Gets or sets the SlopeArrowType enum value that specifies the arrowhead style.
ColorScheme | Gets or sets the color scheme for the range.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface slope arrows are grouped.
LegendStyleId | Gets or sets the style for the slope arrow legend.
LegendStyleName | Gets or sets the style for the slope arrow legend.
NumberOfRanges | Gets or sets the number of surface slope arrow range values to be used.
RangePrecision | Gets or sets the surface slope arrow range precision value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Members
Legend
Legend
Property
public


SurfaceSlopeStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Members
SurfaceSlopeStyle Members Public Properties
SurfaceSlopeStyle Members
Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme for the range.
DisplayEntityMode | Gets or sets the 3D display behavior of the surface object sub-component.
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface slope data is grouped.
LegendStyleId | Gets or sets the style for the surface slope legend.
LegendStyleName | Gets or sets the style for the surface slope legend.
NumberOfRanges | Gets or sets the number of surface slope range values to be used.
RangePrecision | Gets or sets the surface slope range precision value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Members
Legend
Legend
Property
public


SurfaceStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Members
SurfaceStyle Members Public Methods
SurfaceStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the surface component Model display color, layer, linetype, etc.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the surface component Plan display color, layer, linetype, etc.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies the surface component Section display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Members
Legend
Legend
Method
public
virtual


SurfaceStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Members
SurfaceStyle Members Public Properties
SurfaceStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BoundaryStyle | Gets the style object that specifies properties for surface outer, show and hide boundaries/borders.
ContourStyle | Gets the style object that specifies properties for surface minor, major, depression, and user-defined contour lines.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
DirectionStyle | Gets the style object that specifies properties for surface direction analysis components.
Document | Gets the Document associated with the DBObject. Not implemented.
ElevationStyle | Gets the style object that specifies properties for surface elevation analysis components.
GridStyle | Gets the style object that specifies properties for surface primary, secondary, and datum grid information.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PointStyle | Gets the style object that specifies properties for surface point objects.
SlopeArrowStyle | Gets the style object that specifies properties for the surface slope arrow analysis components.
SlopeStyle | Gets the style object that specifies properties for surface slope analysis components.
TriangleStyle | Gets the style object that specifies properties for the surface TIN face components.
WatershedStyle | Gets the style object that specifies properties for the various kinds of surface watershed analysis components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Members
Legend
Legend
Property
public


VerticalGeometryBandStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Members
VerticalGeometryBandStyle Members Public Methods
VerticalGeometryBandStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the VerticalGeometry component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Members
Legend
Legend
Method
public
virtual


VerticalGeometryBandStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Members
VerticalGeometryBandStyle Members Public Properties
VerticalGeometryBandStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
CrestCurveLabelStyleId | Gets the band vertical geometry label style id at the crest curve.
CrestCurveTickStyle | Gets the band vertical geometry tick style at the crest curve.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
DownhillTangentLabelStyleId | Gets the band vertical geometry label style id at the down hill tangent.
DownhillTangentTickStyle | Gets the band vertical geometry tick styleat the down hill tangent.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
SagCurveLabelStyleId | Gets the band vertical geometry label style id at the sag curve.
SagCurveTickStyle | Gets the band vertical geometry tick style at the sag curve.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
UphillTangentLabelStyleId | Gets the band vertical geometry label style id at the up hill tangent.
UphillTangentTickStyle | Gets the band vertical geometry tick style at the up hill tangent.
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Members
Legend
Legend
Property
public


ViewFrameStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Members
ViewFrameStyle Members Public Methods
ViewFrameStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetViewFrameBoundaryDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Members
Legend
Legend
Method
public
virtual


ViewFrameStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Members
ViewFrameStyle Members Public Properties
ViewFrameStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
ViewFrameBoundaryDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Members
Legend
Legend
Property
public


SuperElevationData Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Members
SuperElevationData Members Public Methods
SuperElevationData Members
Public Methods
Public Method | Description
Add | Adds a SuperElevationDataElement object to the SuperElevationData collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes a SuperElevationDataElement at a specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Members
Legend
Legend
Method
public
virtual


SuperElevationData Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Members
SuperElevationData Members Public Properties
SuperElevationData Members
Public Properties
Public Property | Description
Count | Gets the number of items in the collection.
default | Gets the default item.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Members
Legend
Legend
Property
public


SuperElevationDataElement Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Members
SuperElevationDataElement Members Public Methods
SuperElevationDataElement Members
Public Methods
Public Method | Description
GetSegmentCrossSlope | Gets the superelevation cross slope value.
SetSegmentCrossSlope | Sets the superelevation cross slope value.
SuperElevationDataElement | Default constructor for SuperElevationDataElement, object's data should be set by it's properties.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Members
Legend
Legend
Method
public


SuperElevationDataElement Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Members
SuperElevationDataElement Members Public Properties
SuperElevationDataElement Members
Public Properties
Public Property | Description
RawStation | Gets or sets raw station value.
SmoothingCurveLength | Gets or sets smoothing curve length for superelevation data element.
TransitionPointDescription | Gets or sets transition point description string.
TransitionPointType | Gets or sets transition point type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Members
Legend
Legend
Property
public


Surface Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Members
Surface Members Public Methods
Surface Members
Public Methods
Public Method | Description
FindElevationAtXY |


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Members
Legend
Legend
Method
public


Surface Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Members
Surface Members Public Properties
Surface Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
IsVolumeSurface | Gets if the surface is a volume surface.
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Members
Legend
Legend
Property
public


ViewFrame Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrame Class > ViewFrame Members
ViewFrame Members Public Properties
ViewFrame Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GroupId | Gets the object id of the view frame group it belongs to.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrame Class > ViewFrame Members
Legend
Legend
Property
public


ViewFrameGroup Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Members
ViewFrameGroup Members Public Methods
ViewFrameGroup Members
Public Methods
Public Method | Description
GetMatchLineIds | Gets the objectId collection of all match line.
GetViewFrameIds | Gets the objectId collection of view frame.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Members
Legend
Legend
Method
public


ViewFrameGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Members
ViewFrameGroup Members Public Properties
ViewFrameGroup Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Members
Legend
Legend
Property
public


GeometryPointLabelOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointLabelOption Template > GeometryPointLabelOption Members
GeometryPointLabelOption Members Public Properties
GeometryPointLabelOption Members
Public Properties
Public Property | Description
PointType | This is PointType, a member of class GeometryPointLabelOption.
Selected | This is Selected, a member of class GeometryPointLabelOption.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointLabelOption Template > GeometryPointLabelOption Members
Legend
Legend
Property
public


GeometryPointSelector Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Members
GeometryPointSelector Members Public Methods
GeometryPointSelector Members
Public Methods
Public Method | Description
GeometryPointSelector | This is GeometryPointSelector, a member of class GeometryPointSelector.
SelectAll | Selects all supported geometry points.
UnSelectAll | Unselects all supported geometry points.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Members
Legend
Legend
Constructor
public


GeometryPointSelector Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Members
GeometryPointSelector Members Public Properties
GeometryPointSelector Members
Public Properties
Public Property | Description
default | Gets the GeometryPointLabelOption instance for the specified type, which allows the user to modify its Selected state.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Members
Legend
Legend
Property
public


ProfileDesignCheck Members Public Properties
ProfileDesignCheck Members
Public Properties
Public Property | Description
Description | Gets and sets the description of the DesignCheck.
DesignCheckType | Gets the type of the Profile DesignCheck type.
Expression | Gets or sets the expression of the DesignCheck.
Name | Gets the name of the DesignCheck.


ProfileDesignCheckCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Members
ProfileDesignCheckCollection Members Public Methods
ProfileDesignCheckCollection Members
Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
Remove | Removes ProfileDesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Members
Legend
Legend
Method
public
virtual


ProfileDesignCheckCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Members
ProfileDesignCheckCollection Members Public Properties
ProfileDesignCheckCollection Members
Public Properties
Public Property | Description
Count | Gets the number of ProfileDesignCheck in the collection.
default | Gets the ProfileDesignCheck by a specified name in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Members
Legend
Legend
Property
public


ProfileDesignCheckRoot Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Members
ProfileDesignCheckRoot Members Public Methods
ProfileDesignCheckRoot Members
Public Methods
Public Method | Description
ProfileDesignCheckRoot | Constructor of ProfileDesignCheckRoot class.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Members
Legend
Legend
Constructor
public


ProfileDesignCheckRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Members
ProfileDesignCheckRoot Members Public Properties
ProfileDesignCheckRoot Members
Public Properties
Public Property | Description
CurveDesignChecks | Gets the collection of all profile curve design checks.
LineDesignChecks | Gets the collection of all profile line design checks.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Members
Legend
Legend
Property
public


SettingsAbbreviationAlignment Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class > SettingsAbbreviationAlignment Members
SettingsAbbreviationAlignment Members Public Methods
SettingsAbbreviationAlignment Members
Public Methods
Public Method | Description
GetAlignmentAbbreviation | Gets the alignment abbreviation settings
SetAlignmentAbbreviation | Sets the alignment abbreviation settings


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class > SettingsAbbreviationAlignment Members
Legend
Legend
Method
public


SettingsAbbreviationAlignmentEnhanced Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class > SettingsAbbreviationAlignmentEnhanced Members
SettingsAbbreviationAlignmentEnhanced Members Public Methods
SettingsAbbreviationAlignmentEnhanced Members
Public Methods
Public Method | Description
GetAlignmentEnhancedAbbreviation | Gets the alignment enhanced abbreviation settings
SetAlignmentEnhancedAbbreviation | Sets the alignment enhanced abbreviation settings


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class > SettingsAbbreviationAlignmentEnhanced Members
Legend
Legend
Method
public


SettingsAbbreviationProfile Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class > SettingsAbbreviationProfile Members
SettingsAbbreviationProfile Members Public Methods
SettingsAbbreviationProfile Members
Public Methods
Public Method | Description
GetProfileAbbreviation | Gets the profile abbreviation settings
SetProfileAbbreviation | Sets the profile abbreviation settings


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class > SettingsAbbreviationProfile Members
Legend
Legend
Method
public


SettingsAbbreviationSuperelevation Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class > SettingsAbbreviationSuperelevation Members
SettingsAbbreviationSuperelevation Members Public Methods
SettingsAbbreviationSuperelevation Members
Public Methods
Public Method | Description
GetSuperelevationAbbreviation | Gets the superelevation abbreviation settings
SetSuperelevationAbbreviation | Sets the superelevation abbreviation settings


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class > SettingsAbbreviationSuperelevation Members
Legend
Legend
Method
public


SettingsAlignment Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Members
SettingsAlignment Members Classes
SettingsAlignment Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Members
Legend
Legend
Class


SettingsAlignment Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Members
SettingsAlignment Members Public Properties
SettingsAlignment Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Members
Legend
Legend
Property
public


SettingsAlignment Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Members
SettingsAlignment Members Templates
SettingsAlignment Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Members
Legend
Legend
Template


SettingsAlignment::SettingsCriteriaBasedDesignOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Members
SettingsAlignment::SettingsCriteriaBasedDesignOptions Members Public Properties
SettingsAlignment::SettingsCriteriaBasedDesignOptions Members
Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
DesignSpeed | Gets default alignment design speed.
DesignSpeedLookupMethod | Gets the table lookup rule in cases where the actual design speed does not exactly match the speed specified in... more
RadiusLookupMethod | Gets the table lookup rule in cases where the actual radius does not exactly match the speed specified in the... more
UseCriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
UseDesignChecksOption | Gets whether to use a design check set by default.
UseDesignCriteriaFileOption | Gets whether to use a design criteria file by default.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Members
Legend
Legend
Property
public


SettingsAlignment::SettingsData Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsData Class > SettingsAlignment::SettingsData Members
SettingsAlignment::SettingsData Members Public Properties
SettingsAlignment::SettingsData Members
Public Properties
Public Property | Description
CriteriaBasedDesignOption | Gets whether alignments use design criteria by default.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsData Class > SettingsAlignment::SettingsData Members
Legend
Legend
Property
public


SettingsAlignment::SettingsDefaultNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class > SettingsAlignment::SettingsDefaultNameFormat Members
SettingsAlignment::SettingsDefaultNameFormat Members Public Properties
SettingsAlignment::SettingsDefaultNameFormat Members
Public Properties
Public Property | Description
AlignmentNameTemplate | Gets specify the default name formats for new alignments.
OffsetAlignmentNameTemplate | Gets specify the default name formats for new alignments.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class > SettingsAlignment::SettingsDefaultNameFormat Members
Legend
Legend
Property
public


SettingsAlignment::SettingsDynamicAlignmentHighlight Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Members
SettingsAlignment::SettingsDynamicAlignmentHighlight Members Public Properties
SettingsAlignment::SettingsDynamicAlignmentHighlight Members
Public Properties
Public Property | Description
CurbReturnFilletRegionColor | Gets CurbReturnFilletRegionColor for dynamic alignment highlight.
CurbReturnFilletRegionLineweight | Gets CurbReturnFilletRegionLineweight for dynamic alignment highlight.
OffsetRegionColor | Gets OffsetRegionColor for dynamic alignment highlight.
OffsetRegionLineweight | Gets OffsetRegionLineweight for dynamic alignment highlight.
ParentAlignmentColor | Gets ParentAlignmentColor for dynamic alignment highlight.
ParentAlignmentLineweight | Gets ParentAlignmentLineweight for dynamic alignment highlight.
ParentAlignmentTrackerColor | Gets ParentAlignmentTrackerColor for dynamic alignment highlight.
ParentAlignmentTrackerLineweight | Gets ParentAlignmentTrackerLineweight for dynamic alignment highlight.
TransitionRegionColor | Gets TransitionRegionColor for dynamic alignment highlight.
TransitionRegionLineweight | Gets TransitionRegionLineweight for dynamic alignment highlight.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Members
Legend
Legend
Property
public


SettingsAlignment::SettingsStationIndexing Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStationIndexing Class > SettingsAlignment::SettingsStationIndexing Members
SettingsAlignment::SettingsStationIndexing Members Public Properties
SettingsAlignment::SettingsStationIndexing Members
Public Properties
Public Property | Description
DefaultStationIndexIncrement | Gets the default value for station increments.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStationIndexing Class > SettingsAlignment::SettingsStationIndexing Members
Legend
Legend
Property
public


SettingsAlignment::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Members
SettingsAlignment::SettingsStyles Members Public Properties
SettingsAlignment::SettingsStyles Members
Public Properties
Public Property | Description
AlignmentLabelSet | Gets the default alignment label set.
AlignmentStyle | Gets the default alignment style.
CurveLabelStyle | Gets the default curve label style.
LineLabelStyle | Gets the default line label style.
MarkerStyle | Gets the display and appearance of points on the alignment.
SpiralLabelStyle | Gets the default spiral label style.
StationOffsetLabelStyle | Gets the default station offset label style.
TangentIntersectLabelStyle | Gets the default tangent intersection label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Members
Legend
Legend
Property
public


SettingsAlignment::SettingsSuperelevationOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Members
SettingsAlignment::SettingsSuperelevationOptions Members Public Properties
SettingsAlignment::SettingsSuperelevationOptions Members
Public Properties
Public Property | Description
CorridorType | Gets the type of roadway as Undivided (single carriage way) or Divided (dual carriage way).
CrossSectionShape | Gets the cross sectional shape of the roadway as Planar .
HighsideLocation | Gets the default Highside Location for planar roads.
InsideShoulderMethod | Gets the method that is applied to the inside shoulder during superelevation.
NominalWidth | Gets the typical width of the roadway from the superelevation pivot point to the outer edge-of-traveled way.
NormalLaneSlope | Gets the % slope of the roadway lanes on tangent (unsuperelevated) tangents.
NormalShoulderSlope | Gets the % slope value of the roadway shoulders.
OutsideShoulderMethod | Gets the method that is applied to the outside shoulder during superelevation.
StationRoundingOption | Gets the number of positions for station rounding.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Members
Legend
Legend
Property
public


SettingsBuildingSite Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Members
SettingsBuildingSite Members Classes
SettingsBuildingSite Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Members
Legend
Legend
Class


SettingsBuildingSite Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Members
SettingsBuildingSite Members Public Properties
SettingsBuildingSite Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name formats for new building sites.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for new building sites.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Members
Legend
Legend
Property
public


SettingsBuildingSite Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Members
SettingsBuildingSite Members Templates
SettingsBuildingSite Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Members
Legend
Legend
Template


SettingsBuildingSite::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsNameFormat Class > SettingsBuildingSite::SettingsNameFormat Members
SettingsBuildingSite::SettingsNameFormat Members Public Properties
SettingsBuildingSite::SettingsNameFormat Members
Public Properties
Public Property | Description
BuildingSite | Gets the default name formats for building sites.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsNameFormat Class > SettingsBuildingSite::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsBuildingSite::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsStyles Class > SettingsBuildingSite::SettingsStyles Members
SettingsBuildingSite::SettingsStyles Members Public Properties
SettingsBuildingSite::SettingsStyles Members
Public Properties
Public Property | Description
BuildingSite | Gets the default style for building site.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsStyles Class > SettingsBuildingSite::SettingsStyles Members
Legend
Legend
Property
public


SettingsCmdAddAlignmentCurveTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Members
SettingsCmdAddAlignmentCurveTable Members Classes
SettingsCmdAddAlignmentCurveTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Members
Legend
Legend
Class


SettingsCmdAddAlignmentCurveTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Members
SettingsCmdAddAlignmentCurveTable Members Public Properties
SettingsCmdAddAlignmentCurveTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TableCreation | Gets the default setting of table creation for the command AddAlignmentCurveTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Members
Legend
Legend
Property
public


SettingsCmdAddAlignmentCurveTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Members
SettingsCmdAddAlignmentCurveTable Members Templates
SettingsCmdAddAlignmentCurveTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Members
Legend
Legend
Template


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members Public Properties
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddAlignmentLineTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Members
SettingsCmdAddAlignmentLineTable Members Classes
SettingsCmdAddAlignmentLineTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Members
Legend
Legend
Class


SettingsCmdAddAlignmentLineTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Members
SettingsCmdAddAlignmentLineTable Members Public Properties
SettingsCmdAddAlignmentLineTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TableCreation | Gets the default setting of table creation for the command AddAlignmentLineTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Members
Legend
Legend
Property
public


SettingsCmdAddAlignmentLineTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Members
SettingsCmdAddAlignmentLineTable Members Templates
SettingsCmdAddAlignmentLineTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Members
Legend
Legend
Template


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members Public Properties
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddAlignmentSegmentTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Members
SettingsCmdAddAlignmentSegmentTable Members Classes
SettingsCmdAddAlignmentSegmentTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Members
Legend
Legend
Class


SettingsCmdAddAlignmentSegmentTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Members
SettingsCmdAddAlignmentSegmentTable Members Public Properties
SettingsCmdAddAlignmentSegmentTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TableCreation | Gets the default setting of table creation for the command AddAlignmentSegmentTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Members
Legend
Legend
Property
public


SettingsCmdAddAlignmentSegmentTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Members
SettingsCmdAddAlignmentSegmentTable Members Templates
SettingsCmdAddAlignmentSegmentTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Members
Legend
Legend
Template


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members Public Properties
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddAlignmentSpiralTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Members
SettingsCmdAddAlignmentSpiralTable Members Classes
SettingsCmdAddAlignmentSpiralTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Members
Legend
Legend
Class


SettingsCmdAddAlignmentSpiralTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Members
SettingsCmdAddAlignmentSpiralTable Members Public Properties
SettingsCmdAddAlignmentSpiralTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TableCreation | Gets the default setting of table creation for the command AddAlignmentSpiralTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Members
Legend
Legend
Property
public


SettingsCmdAddAlignmentSpiralTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Members
SettingsCmdAddAlignmentSpiralTable Members Templates
SettingsCmdAddAlignmentSpiralTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Members
Legend
Legend
Template


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members Public Properties
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddContourLabelingGroup Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Members
SettingsCmdAddContourLabelingGroup Members Classes
SettingsCmdAddContourLabelingGroup Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Members
Legend
Legend
Class


SettingsCmdAddContourLabelingGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Members
SettingsCmdAddContourLabelingGroup Members Public Properties
SettingsCmdAddContourLabelingGroup Members
Public Properties
Public Property | Description
AddContourLabeling | Gets the defaults assigned to surface labels.
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Members
Legend
Legend
Property
public


SettingsCmdAddContourLabelingGroup Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Members
SettingsCmdAddContourLabelingGroup Members Templates
SettingsCmdAddContourLabelingGroup Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Members
Legend
Legend
Template


SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members Public Properties
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members
Public Properties
Public Property | Description
IntervalAlongContour | Gets the Interval Along Contour.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Members
Legend
Legend
Property
public


SettingsCmdAddParcelCurveTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Members
SettingsCmdAddParcelCurveTable Members Classes
SettingsCmdAddParcelCurveTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Members
Legend
Legend
Class


SettingsCmdAddParcelCurveTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Members
SettingsCmdAddParcelCurveTable Members Public Properties
SettingsCmdAddParcelCurveTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TableCreation | Gets the default setting of table creation for the command AddParcelCurveTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Members
Legend
Legend
Property
public


SettingsCmdAddParcelCurveTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Members
SettingsCmdAddParcelCurveTable Members Templates
SettingsCmdAddParcelCurveTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Members
Legend
Legend
Template


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members Public Properties
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddParcelLineTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Members
SettingsCmdAddParcelLineTable Members Classes
SettingsCmdAddParcelLineTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Members
Legend
Legend
Class


SettingsCmdAddParcelLineTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Members
SettingsCmdAddParcelLineTable Members Public Properties
SettingsCmdAddParcelLineTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TableCreation | Gets the default setting of table creation for the command AddParcelLineTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Members
Legend
Legend
Property
public


SettingsCmdAddParcelLineTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Members
SettingsCmdAddParcelLineTable Members Templates
SettingsCmdAddParcelLineTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Members
Legend
Legend
Template


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members Public Properties
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddParcelSegmentLabels Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Members
SettingsCmdAddParcelSegmentLabels Members Classes
SettingsCmdAddParcelSegmentLabels Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Members
Legend
Legend
Class


SettingsCmdAddParcelSegmentLabels Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Members
SettingsCmdAddParcelSegmentLabels Members Public Properties
SettingsCmdAddParcelSegmentLabels Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Options | Gets the default setting of Options.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Members
Legend
Legend
Property
public


SettingsCmdAddParcelSegmentLabels Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Members
SettingsCmdAddParcelSegmentLabels Members Templates
SettingsCmdAddParcelSegmentLabels Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Members
Legend
Legend
Template


SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members Public Properties
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members
Public Properties
Public Property | Description
LabelingDirection | Gets the default parcel segment labeling direction .


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Members
Legend
Legend
Property
public


SettingsCmdAddParcelSegmentTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Members
SettingsCmdAddParcelSegmentTable Members Classes
SettingsCmdAddParcelSegmentTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Members
Legend
Legend
Class


SettingsCmdAddParcelSegmentTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Members
SettingsCmdAddParcelSegmentTable Members Public Properties
SettingsCmdAddParcelSegmentTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TableCreation | Gets the default setting of table creation for the command AddParcelSegmentTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Members
Legend
Legend
Property
public


SettingsCmdAddParcelSegmentTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Members
SettingsCmdAddParcelSegmentTable Members Templates
SettingsCmdAddParcelSegmentTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Members
Legend
Legend
Template


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members Public Properties
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddParcelTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Members
SettingsCmdAddParcelTable Members Classes
SettingsCmdAddParcelTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Members
Legend
Legend
Class


SettingsCmdAddParcelTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Members
SettingsCmdAddParcelTable Members Public Properties
SettingsCmdAddParcelTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TableCreation | Gets the default setting of table creation for the command AddParcelTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Members
Legend
Legend
Property
public


SettingsCmdAddParcelTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Members
SettingsCmdAddParcelTable Members Templates
SettingsCmdAddParcelTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Members
Legend
Legend
Template


SettingsCmdAddParcelTable::SettinsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Members
SettingsCmdAddParcelTable::SettinsCmdTableCreation Members Public Properties
SettingsCmdAddParcelTable::SettinsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddPointTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Members
SettingsCmdAddPointTable Members Classes
SettingsCmdAddPointTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Members
Legend
Legend
Class


SettingsCmdAddPointTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Members
SettingsCmdAddPointTable Members Public Properties
SettingsCmdAddPointTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new points and point groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to points and points labels.
TableCreation | Gets the default setting of table creation for the command AddPointTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UpdatePoints | Gets whether you can change local copies of project points without checking them out.
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Members
Legend
Legend
Property
public


SettingsCmdAddPointTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Members
SettingsCmdAddPointTable Members Templates
SettingsCmdAddPointTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Members
Legend
Legend
Template


SettingsCmdAddPointTable::SettinsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Members
SettingsCmdAddPointTable::SettinsCmdTableCreation Members Public Properties
SettingsCmdAddPointTable::SettinsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddSurfaceBoundaries Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Members
SettingsCmdAddSurfaceBoundaries Members Classes
SettingsCmdAddSurfaceBoundaries Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Members
Legend
Legend
Class


SettingsCmdAddSurfaceBoundaries Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Members
SettingsCmdAddSurfaceBoundaries Members Public Properties
SettingsCmdAddSurfaceBoundaries Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
DataOptions | Gets the default setting of adding data options for the command AddSurfaceBoundaries.
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Members
Legend
Legend
Property
public


SettingsCmdAddSurfaceBoundaries Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Members
SettingsCmdAddSurfaceBoundaries Members Templates
SettingsCmdAddSurfaceBoundaries Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Members
Legend
Legend
Template


SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members Public Properties
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members
Public Properties
Public Property | Description
BoundaryType | Gets the default boundary type.
MidOrdinateDistance | Gets the default mid-ordinate distance.
NonDestructive | Gets a PropertyBoolean value that specifies the default selection of a type of breakline (destructive of non-destructive).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Members
Legend
Legend
Property
public


SettingsCmdAddSurfaceBreaklines Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Members
SettingsCmdAddSurfaceBreaklines Members Classes
SettingsCmdAddSurfaceBreaklines Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Members
Legend
Legend
Class


SettingsCmdAddSurfaceBreaklines Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Members
SettingsCmdAddSurfaceBreaklines Members Public Properties
SettingsCmdAddSurfaceBreaklines Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
DataOptions | Gets the default setting of adding data options for the command AddSurfaceBreaklines.
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Members
Legend
Legend
Property
public


SettingsCmdAddSurfaceBreaklines Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Members
SettingsCmdAddSurfaceBreaklines Members Templates
SettingsCmdAddSurfaceBreaklines Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Members
Legend
Legend
Template


SettingsCmdAddSurfaceContours Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Members
SettingsCmdAddSurfaceContours Members Classes
SettingsCmdAddSurfaceContours Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Members
Legend
Legend
Class


SettingsCmdAddSurfaceContours Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Members
SettingsCmdAddSurfaceContours Members Public Properties
SettingsCmdAddSurfaceContours Members
Public Properties
Public Property | Description
AddDataOptions | Gets the defaults assigned when adding contours, boundaries, and breaklines to a surface.
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Members
Legend
Legend
Property
public


SettingsCmdAddSurfaceContours Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Members
SettingsCmdAddSurfaceContours Members Templates
SettingsCmdAddSurfaceContours Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Members
Legend
Legend
Template


SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members Public Properties
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members
Public Properties
Public Property | Description
MidOrdinateDistance | Gets the default mid-ordinate distance.
SupplementingDistance | Gets the default supplementing distance.
WeedingAngle | Gets the default weeding angle.
WeedingDistance | Gets the default weeding distance.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Members
Legend
Legend
Property
public


SettingsCmdAddSurfaceDemFile Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Members
SettingsCmdAddSurfaceDemFile Members Classes
SettingsCmdAddSurfaceDemFile Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Members
Legend
Legend
Class


SettingsCmdAddSurfaceDemFile Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Members
SettingsCmdAddSurfaceDemFile Members Public Properties
SettingsCmdAddSurfaceDemFile Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
ImportOptions | Gets the defaults assigned when creating surfaces.
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Members
Legend
Legend
Property
public


SettingsCmdAddSurfaceDemFile Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Members
SettingsCmdAddSurfaceDemFile Members Templates
SettingsCmdAddSurfaceDemFile Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Members
Legend
Legend
Template


SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members Public Properties
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members
Public Properties
Public Property | Description
NullElevation | Gets null elevation.
UseCustomNullElevation | Gets whether use custom null elevation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Members
Legend
Legend
Property
public


SettingsCmdAddSurfaceDrawingObjects Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Members
SettingsCmdAddSurfaceDrawingObjects Members Classes
SettingsCmdAddSurfaceDrawingObjects Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Members
Legend
Legend
Class


SettingsCmdAddSurfaceDrawingObjects Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Members
SettingsCmdAddSurfaceDrawingObjects Members Public Properties
SettingsCmdAddSurfaceDrawingObjects Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
DataOptions | Gets the default setting of adding data options for the command AddSurfaceDrawingObjects.
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Members
Legend
Legend
Property
public


SettingsCmdAddSurfaceDrawingObjects Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Members
SettingsCmdAddSurfaceDrawingObjects Members Templates
SettingsCmdAddSurfaceDrawingObjects Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Members
Legend
Legend
Template


SettingsCmdAddWidening Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Members
SettingsCmdAddWidening Members Classes
SettingsCmdAddWidening Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Members
Legend
Legend
Class


SettingsCmdAddWidening Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Members
SettingsCmdAddWidening Members Public Properties
SettingsCmdAddWidening Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
WideningOptions | Gets the widening options settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Members
Legend
Legend
Property
public


SettingsCmdAddWidening Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Members
SettingsCmdAddWidening Members Templates
SettingsCmdAddWidening Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Members
Legend
Legend
Template


SettingsCmdAddWidening::SettingsCmdWideningOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Members
SettingsCmdAddWidening::SettingsCmdWideningOptions Members Public Properties
SettingsCmdAddWidening::SettingsCmdWideningOptions Members
Public Properties
Public Property | Description
RadiusForCurve1 | Specifies the RadiusForCurve1 for alignment widening options.
RadiusForCurve2 | Specifies the RadiusForCurve2 for alignment widening options.
RadiusForCurve3 | Specifies the RadiusForCurve3 for alignment widening options.
TaperInputType | Specifies the TaperInputType for alignment widening options.
TaperRatio | Specifies the TaperRatio for alignment widening options.
TransitionLength | Specifies the TransitionLength for alignment widening options.
TransitionType | Specifies the TransitionType for alignment widening options.
WideningOffset | Specifies the WideningOffset for alignment widening options.
WideningSegmentLength | Specifies the WideningSegmentLength for alignment widening options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Members
Legend
Legend
Property
public


SettingsCmdCatchmentArea Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Members
SettingsCmdCatchmentArea Members Classes
SettingsCmdCatchmentArea Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Members
Legend
Legend
Class


SettingsCmdCatchmentArea Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Members
SettingsCmdCatchmentArea Members Public Properties
SettingsCmdCatchmentArea Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Layer | Gets the catchment layer.
Marker | Gets the catchment marker.
MarkerStyle | Gets the catchment marker style.
ObjectType | Gets the catchment object type.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Members
Legend
Legend
Property
public


SettingsCmdCatchmentArea Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Members
SettingsCmdCatchmentArea Members Templates
SettingsCmdCatchmentArea Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Members
Legend
Legend
Template


SettingsCmdConvertPointstoSdskPoints Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Members
SettingsCmdConvertPointstoSdskPoints Members Classes
SettingsCmdConvertPointstoSdskPoints Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Members
Legend
Legend
Class


SettingsCmdConvertPointstoSdskPoints Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Members
SettingsCmdConvertPointstoSdskPoints Members Public Properties
SettingsCmdConvertPointstoSdskPoints Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Layer | Gets the default setting of Layer.
NameFormat | Gets the default name format for new points and point groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to points and points labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UpdatePoints | Gets whether you can change local copies of project points without checking them out.
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Members
Legend
Legend
Property
public


SettingsCmdConvertPointstoSdskPoints Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Members
SettingsCmdConvertPointstoSdskPoints Members Templates
SettingsCmdConvertPointstoSdskPoints Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Members
Legend
Legend
Template


SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members Public Properties
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members
Public Properties
Public Property | Description
Layer | Gets the default Layer.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Members
Legend
Legend
Property
public


SettingsCmdCreateAlignmentEntities Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Members
SettingsCmdCreateAlignmentEntities Members Classes
SettingsCmdCreateAlignmentEntities Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Members
Legend
Legend
Class


SettingsCmdCreateAlignmentEntities Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Members
SettingsCmdCreateAlignmentEntities Members Public Properties
SettingsCmdCreateAlignmentEntities Members
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the AlignmentTypeOption settings.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CreateFromEntities | Gets the CreateFromEntities settings.
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Members
Legend
Legend
Property
public


SettingsCmdCreateAlignmentEntities Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Members
SettingsCmdCreateAlignmentEntities Members Templates
SettingsCmdCreateAlignmentEntities Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Members
Legend
Legend
Template


SettingsCmdCreateAlignmentLayout Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Members
SettingsCmdCreateAlignmentLayout Members Classes
SettingsCmdCreateAlignmentLayout Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Members
Legend
Legend
Class


SettingsCmdCreateAlignmentLayout Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Members
SettingsCmdCreateAlignmentLayout Members Public Properties
SettingsCmdCreateAlignmentLayout Members
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the default setting of alignment type for the command CreateAlignmentLayout.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
CurveAndSpiralSettings | Gets the default setting of curve and spiral for the command CreateAlignmentLayout.
CurveTessellationOption | Gets the default setting of curve tessellation option for the command CreateAlignmentLayout.
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
RegressionGraphOption | Gets the default setting of tegression graph option for the command CreateAlignmentLayout.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Members
Legend
Legend
Property
public


SettingsCmdCreateAlignmentLayout Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Members
SettingsCmdCreateAlignmentLayout Members Templates
SettingsCmdCreateAlignmentLayout Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Members
Legend
Legend
Template


SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members Public Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members
Public Properties
Public Property | Description
AlignmentType | Specifies whether to erase existing entities for creating alignment entities.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Members
Legend
Legend
Property
public


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members Public Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members
Public Properties
Public Property | Description
CurveRadiusForSCSGroup | Specifies a radius value for the SCS group.
SpiralInAValue | Specifies the length for the Spiral In.
SpiralInLength | Specifies the length for the Spiral In.
SpiralOutAValue | Specifies the A value for the Spiral Out.
SpiralOutLength | Specifies the length for the Spiral Out.
SpiralType | Specifies the spiral type.
UseCurve | Specifies whether your design includes a curve.
UseSpiralIn | Specifies whether your design includes a spiral either before a curve or before a Spiral Out.
UseSpiralOut | Specifies whether your design includes a Spiral Out.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Members
Legend
Legend
Property
public


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members Public Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members
Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies the mid-ordinate tolerance based on a distance across the tessellated curve segments.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Members
Legend
Legend
Property
public


SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members Public Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Members
Legend
Legend
Property
public


SettingsCmdCreateFeatureLineFromAlign Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Members
SettingsCmdCreateFeatureLineFromAlign Members Classes
SettingsCmdCreateFeatureLineFromAlign Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Members
Legend
Legend
Class


SettingsCmdCreateFeatureLineFromAlign Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Members
SettingsCmdCreateFeatureLineFromAlign Members Public Properties
SettingsCmdCreateFeatureLineFromAlign Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineCreation | Gets the default setting of feature line creation for the command CreateFeatureLineFromAlign.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Members
Legend
Legend
Property
public


SettingsCmdCreateFeatureLineFromAlign Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Members
SettingsCmdCreateFeatureLineFromAlign Members Templates
SettingsCmdCreateFeatureLineFromAlign Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Members
Legend
Legend
Template


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members Public Properties
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members
Public Properties
Public Property | Description
CreateDynamicLink | Gets a PropertyBoolean value specifies whether to create a dynamic link to the alignment. Change this value to False to... more
LayerSetting | Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from... more
MidOrdinateDistance | Gets the default Mid-ordinate distance for tessellating curves into short line segments.
SpiralTessellationFactor | Gets the default Spiral tessellation factor.
UseFeatureLineName | Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.
WeedPoints | Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Members
Legend
Legend
Property
public


SettingsCmdCreateFeatureLines Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Members
SettingsCmdCreateFeatureLines Members Classes
SettingsCmdCreateFeatureLines Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Members
Legend
Legend
Class


SettingsCmdCreateFeatureLines Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Members
SettingsCmdCreateFeatureLines Members Public Properties
SettingsCmdCreateFeatureLines Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineCreation | Gets the default setting of feature line creation for the command CreateFeatureLines.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Members
Legend
Legend
Property
public


SettingsCmdCreateFeatureLines Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Members
SettingsCmdCreateFeatureLines Members Templates
SettingsCmdCreateFeatureLines Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Members
Legend
Legend
Template


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members Public Properties
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members
Public Properties
Public Property | Description
AssignElevations | Gets a PropertyBoolean value specifies whether to open the Assign Elevations dialog box.
ElevationSource | Gets the default elevation source settings.
EraseExistingEntities | Gets a PropertyBoolean value specifies whether creation commands erase selected objects when they are converted to feature lines. By default... more
IncludeMidElevationBreaks | Gets a PropertyBoolean value specifies whether to include intermediate elevation breaks when assigning elevations from a surface or grading group.... more
LayerSetting | Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from... more
UseFeatureLineName | Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.
WeedPoints | Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Members
Legend
Legend
Property
public


SettingsCmdCreateGrading Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Members
SettingsCmdCreateGrading Members Classes
SettingsCmdCreateGrading Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Members
Legend
Legend
Class


SettingsCmdCreateGrading Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Members
SettingsCmdCreateGrading Members Public Properties
SettingsCmdCreateGrading Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GradingCreation | Gets the default setting of grading creation for the command CreateGrading.
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Members
Legend
Legend
Property
public


SettingsCmdCreateGrading Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Members
SettingsCmdCreateGrading Members Templates
SettingsCmdCreateGrading Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Members
Legend
Legend
Template


SettingsCmdCreateGrading::SettingsCmdGradingCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading::SettingsCmdGradingCreation Class > SettingsCmdCreateGrading::SettingsCmdGradingCreation Members
SettingsCmdCreateGrading::SettingsCmdGradingCreation Members Public Properties
SettingsCmdCreateGrading::SettingsCmdGradingCreation Members
Public Properties
Public Property | Description
TransitionRegionLength | Specifies the default length for transition regions.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading::SettingsCmdGradingCreation Class > SettingsCmdCreateGrading::SettingsCmdGradingCreation Members
Legend
Legend
Property
public


SettingsCmdCreateGradingGroup Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Members
SettingsCmdCreateGradingGroup Members Classes
SettingsCmdCreateGradingGroup Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Members
Legend
Legend
Class


SettingsCmdCreateGradingGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Members
SettingsCmdCreateGradingGroup Members Public Properties
SettingsCmdCreateGradingGroup Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GradingGroupCreation | Gets the default setting of grading group creation for the command CreateGradingGroup.
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Members
Legend
Legend
Property
public


SettingsCmdCreateGradingGroup Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Members
SettingsCmdCreateGradingGroup Members Templates
SettingsCmdCreateGradingGroup Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Members
Legend
Legend
Template


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members Public Properties
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members
Public Properties
Public Property | Description
GradingSurfaceCreation | Specifies whether a grading group generates an automatic surface by default.
SurfaceConeTessellationAngle | Specifies the default maximum angle between supplemental projection lines on exterior corners.
SurfaceStyle | Specifies the default style for the grading group.
SurfaceTessellationIncrement | Specifies the default maximum distance along the feature line to add supplemental surface triangle lines for better definition of the... more
UseGroupName | Specifies whether the automatic surface is named after the grading group by default.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Members
Legend
Legend
Property
public


SettingsCmdCreateMassHaulDiagram Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Members
SettingsCmdCreateMassHaulDiagram Members Classes
SettingsCmdCreateMassHaulDiagram Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Members
Legend
Legend
Class


SettingsCmdCreateMassHaulDiagram Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Members
SettingsCmdCreateMassHaulDiagram Members Public Properties
SettingsCmdCreateMassHaulDiagram Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MassHaulCreation | Specifies the Mass haul data settings.
NameFormat | Gets the default name formats for new mass haul lines and new mass haul views.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for mass haul components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Members
Legend
Legend
Property
public


SettingsCmdCreateMassHaulDiagram Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Members
SettingsCmdCreateMassHaulDiagram Members Templates
SettingsCmdCreateMassHaulDiagram Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Members
Legend
Legend
Template


SettingsCmdCreateMultipleProfileView Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Members
SettingsCmdCreateMultipleProfileView Members Classes
SettingsCmdCreateMultipleProfileView Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Members
Legend
Legend
Class


SettingsCmdCreateMultipleProfileView Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Members
SettingsCmdCreateMultipleProfileView Members Public Properties
SettingsCmdCreateMultipleProfileView Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Creation | Gets style settings for profile view.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MultipleProfileViewCreation | Gets the default setting of multiple profile view creation.
NameFormat | Gets style settings for profile view.
ProjectionLabelPlacement | Gets style settings for profile view.
Slope | The Slope settings
Speed | The Speed settings
SplitOptions | Gets style settings for profile view.
StackedOptions | Gets style settings for profile view.
Station | The Station settings
Styles | Gets style settings for profile view.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Members
Legend
Legend
Property
public


SettingsCmdCreateMultipleProfileView Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Members
SettingsCmdCreateMultipleProfileView Members Templates
SettingsCmdCreateMultipleProfileView Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Members
Legend
Legend
Template


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members Public Properties
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members
Public Properties
Public Property | Description
ColumnSpacing | Gets
DefaultProfileViewHeight | Gets
DefaultProfileViewLength | Gets the default length for profile views.
PlotPattern | Gets
ProfileViewDatumBy | Gets
ProfileViewsInRowOrColumn | Gets
RowSpacing | Gets
StartCorner | Gets


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Members
Legend
Legend
Property
public


SettingsCmdCreateMultipleSectionView Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Members
SettingsCmdCreateMultipleSectionView Members Classes
SettingsCmdCreateMultipleSectionView Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Members
Legend
Legend
Class


SettingsCmdCreateMultipleSectionView Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Members
SettingsCmdCreateMultipleSectionView Members Public Properties
SettingsCmdCreateMultipleSectionView Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MultipleSectionViewCreation | Specifies the multiple section view settings.
NameFormat | Gets the template for naming the section view.
ProjectionLabelPlacement | settings to specify the default name formats for sample line.
SectionViewCreation | Gets the settings to establish the defaults assigned for section view creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to section view components
TableCreation | Specifies the table creation settings.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Members
Legend
Legend
Property
public


SettingsCmdCreateMultipleSectionView Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Members
SettingsCmdCreateMultipleSectionView Members Templates
SettingsCmdCreateMultipleSectionView Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Members
Legend
Legend
Template


SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members Public Properties
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members
Public Properties
Public Property | Description
SectionViewHeight | Specifies whether a station range is set for the creation of multiple section views.
SpecifyMultipleSectionViewStationRange | Specifies whether a station range is set for the creation of multiple section views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Members
Legend
Legend
Property
public


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members Public Properties
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaterialVolumeTableStyle | Specifies the styles for a material table.
MaximumNumberOfRows | Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum,... more
MaximumTablesPerStack | Specifies the maximum number of sections to include in each stack.
SectionViewAnchor | Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableAnchor | Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
TableLayout | Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
TableSpacing | Specifies the spacing between tables.
TileDirection | Specifies the direction in which the table tiles (across or down).
TotalVolumeTableStyle | Specifies the style for a total volume table.
XOffset | Specifies the horizontal offset of the table.
YOffset | Specifies the vertical offset of the table.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdCreateOffsetAlignment Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Members
SettingsCmdCreateOffsetAlignment Members Classes
SettingsCmdCreateOffsetAlignment Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Members
Legend
Legend
Class


SettingsCmdCreateOffsetAlignment Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Members
SettingsCmdCreateOffsetAlignment Members Public Properties
SettingsCmdCreateOffsetAlignment Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
OffsetAlignmentOptions | Specifies the offset alignment options.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Members
Legend
Legend
Property
public


SettingsCmdCreateOffsetAlignment Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Members
SettingsCmdCreateOffsetAlignment Members Templates
SettingsCmdCreateOffsetAlignment Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Members
Legend
Legend
Template


SettingsCmdCreateParcelByLayout Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Members
SettingsCmdCreateParcelByLayout Members Classes
SettingsCmdCreateParcelByLayout Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Members
Legend
Legend
Class


SettingsCmdCreateParcelByLayout Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Members
SettingsCmdCreateParcelByLayout Members Public Properties
SettingsCmdCreateParcelByLayout Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AutomaticLayout | Gets the default setting of automatic layout for the command CreateParcelByLayout.
ConvertFromEntities | Gets the default setting of converting from entities for the command CreateParcelByLayout.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ParcelSizing | Gets the default setting of parcel sizing for the command CreateParcelByLayout.
PreviewGraphics | Gets the default setting of preview graphics for the command CreateParcelByLayout.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Members
Legend
Legend
Property
public


SettingsCmdCreateParcelByLayout Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Members
SettingsCmdCreateParcelByLayout Members Templates
SettingsCmdCreateParcelByLayout Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Members
Legend
Legend
Template


SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members Public Properties
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members
Public Properties
Public Property | Description
AutomaticMode | Gets a PropertyBoolean value specifies whether the automatic mode is set for parcel layout.
RemainderDistributionType | Gets the PropertyEnum value spctifies remainder from a new parcel is distributed.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Members
Legend
Legend
Property
public


SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members Public Properties
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members
Public Properties
Public Property | Description
AutoAddSegmentLabel | Gets a PropertyBoolean value specifies whether segment labels are automatically added to a new parcel.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Members
Legend
Legend
Property
public


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members Public Properties
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members
Public Properties
Public Property | Description
FrontageOffset | Gets the default frontage offset. Must be greater than zero.
MaximumDepth | Gets the default maximum depth. Must be greater than or equal to zero.
MinimumArea | Gets the default minimum area for a new parcel.
MinimumDepth | Gets the default minimum depth.
MinimumFrontage | Gets the default minimum frontage for a new parcel.
MinimumWidth | Gets the default minimum width.
SelectionMethod | Gets the default parcel selection method.
SolutionPreference | Gets the default multiple solution preference.
UseMaximumDepth | Gets a PropertyBoolean value specifies whether using maximum depth.
UseMinimumFrontageAtOffset | Gets a PropertyBoolean value specifies whether using minimum frontage at offset.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Members
Legend
Legend
Property
public


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members Public Properties
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members
Public Properties
Public Property | Description
FrontageColor | Gets the default color for the frontage preview.
FrontageOffsetColor | Gets the default color for the frontage offset preview.
MinimumDepthColor | Gets the default color for the minimum depth preview.
MinimumFrontageColor | Gets the default color for the minimum frontage preview.
MinimumWidthColor | Gets the default color for the minimum width preview.
NewParcelColor | Gets the default color for the new parcel preview.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Members
Legend
Legend
Property
public


SettingsCmdCreateParcelFromObjects Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Members
SettingsCmdCreateParcelFromObjects Members Classes
SettingsCmdCreateParcelFromObjects Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Members
Legend
Legend
Class


SettingsCmdCreateParcelFromObjects Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Members
SettingsCmdCreateParcelFromObjects Members Public Properties
SettingsCmdCreateParcelFromObjects Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ConvertFromEntities | Gets the default setting of Convert From Entities.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Members
Legend
Legend
Property
public


SettingsCmdCreateParcelFromObjects Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Members
SettingsCmdCreateParcelFromObjects Members Templates
SettingsCmdCreateParcelFromObjects Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Members
Legend
Legend
Template


SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members Public Properties
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members
Public Properties
Public Property | Description
AutoAddSegmentLabels | Gets whether existing entities are erased when a new parcel is created.
EraseAllExistingEntities | Gets whether existing entities are erased when a new parcel is created.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Members
Legend
Legend
Property
public


SettingsCmdCreateParcelROW Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Members
SettingsCmdCreateParcelROW Members Classes
SettingsCmdCreateParcelROW Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Members
Legend
Legend
Class


SettingsCmdCreateParcelROW Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Members
SettingsCmdCreateParcelROW Members Public Properties
SettingsCmdCreateParcelROW Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
CleanupAtAlignmentIntersections | Gets the default setting of Cleanup at Alignment Intersections for the command AeccCreateParcelROW.
CleanupAtParcelBoundaries | Gets the default setting of Cleanup at Parcel Boundaries for the command AeccCreateParcelROW.
Coordinate | The Coordinate settings
CreateParcelRightOfWay | Gets the default setting of Create Parcel Right Of Way for the command AeccCreateParcelROW.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Members
Legend
Legend
Property
public


SettingsCmdCreateParcelROW Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Members
SettingsCmdCreateParcelROW Members Templates
SettingsCmdCreateParcelROW Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Members
Legend
Legend
Template


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members Public Properties
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members
Public Properties
Public Property | Description
CleanupMethodFillet | Gets whether the cleanup method is Fillet, Chamfer, or None.
FilletRadiusAtAlignmentIntersections | Gets the width of the radius of the fillet at alignment intersections.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Members
Legend
Legend
Property
public


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members Public Properties
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members
Public Properties
Public Property | Description
CleanupMethodFillet | Gets whether the cleanup method is Fillet, Chamfer, or None.
FilletRadiusAtParcelBoundaryIntersections | Gets the width of the radius of the fillet at parcel boundary intersections.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Members
Legend
Legend
Property
public


SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members Public Properties
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members
Public Properties
Public Property | Description
OffsetFromAlignment | Gets the offset from the alignment for the new right of way.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Members
Legend
Legend
Property
public


SettingsCmdCreatePoints Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Members
SettingsCmdCreatePoints Members Classes
SettingsCmdCreatePoints Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Members
Legend
Legend
Class


SettingsCmdCreatePoints Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Members
SettingsCmdCreatePoints Members Public Properties
SettingsCmdCreatePoints Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Layer | Gets the default setting of Layer.
NameFormat | Gets the default name format for new points and point groups.
PointsCreation | Gets the settings to establish default information for creating points.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to points and points labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UpdatePoints | Gets whether you can change local copies of project points without checking them out.
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Members
Legend
Legend
Property
public


SettingsCmdCreatePoints Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Members
SettingsCmdCreatePoints Members Templates
SettingsCmdCreatePoints Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Members
Legend
Legend
Template


SettingsCmdCreatePoints::SettingsCmdLayer Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdLayer Class > SettingsCmdCreatePoints::SettingsCmdLayer Members
SettingsCmdCreatePoints::SettingsCmdLayer Members Public Properties
SettingsCmdCreatePoints::SettingsCmdLayer Members
Public Properties
Public Property | Description
Layer | Gets or sets a default layer


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdLayer Class > SettingsCmdCreatePoints::SettingsCmdLayer Members
Legend
Legend
Property
public


SettingsCmdCreatePoints::SettingsCmdPointsCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Members
SettingsCmdCreatePoints::SettingsCmdPointsCreation Members Public Properties
SettingsCmdCreatePoints::SettingsCmdPointsCreation Members
Public Properties
Public Property | Description
DefaultDescription | Gets or sets the description that is automatically assigned by the point creation commands when Prompt For Descriptions is set... more
DefaultElevation | Gets or sets the elevation automatically assigned by the point creation commands when the Prompt For Elevations setting is set... more
DisableDescriptionKeys | Gets or sets whether description key matching occurs during point creation.
EchoCoordinatesToCommandLine | Gets or sets whether description key matching occurs during point creation.
GeographicCoordinates | Gets or sets the order in which geographic coordinates are displayed on the command line during point creation.
GridCoordinates | Gets or sets the order in which grid coordinates are displayed on the command line during point creation.
LocalCoordinates | Gets or sets the order and format used to display local coordinates on the command line during point creation.
MatchOnDescriptionParameters | Gets or sets whether parameters are used in description key matching to rotate and scale the point symbol.
PromptForDescriptions | Gets or sets how descriptions are assigned during point creation.
PromptForElevations | Gets or sets how elevations are assigned point creation.
PromptForPointNames | Gets or sets how point names are entered during point creation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Members
Legend
Legend
Property
public


SettingsCmdCreateProfileFromSurface Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Members
SettingsCmdCreateProfileFromSurface Members Classes
SettingsCmdCreateProfileFromSurface Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Members
Legend
Legend
Class


SettingsCmdCreateProfileFromSurface Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Members
SettingsCmdCreateProfileFromSurface Members Public Properties
SettingsCmdCreateProfileFromSurface Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Geometry | Gets the default setting of Geometry.
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Members
Legend
Legend
Property
public


SettingsCmdCreateProfileFromSurface Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Members
SettingsCmdCreateProfileFromSurface Members Templates
SettingsCmdCreateProfileFromSurface Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Members
Legend
Legend
Template


SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members Public Properties
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members
Public Properties
Public Property | Description
ProfileSampleOffsetsCommandSetting | Specifies whether to create offset profiles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Members
Legend
Legend
Property
public


SettingsCmdCreateProfileLayout Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Members
SettingsCmdCreateProfileLayout Members Classes
SettingsCmdCreateProfileLayout Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Members
Legend
Legend
Class


SettingsCmdCreateProfileLayout Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Members
SettingsCmdCreateProfileLayout Members Public Properties
SettingsCmdCreateProfileLayout Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
CurveTessellationOption | Gets the default setting of curve tessellation option.
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
RegressionGraphOption | Gets the default setting of regression graph option.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Members
Legend
Legend
Property
public


SettingsCmdCreateProfileLayout Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Members
SettingsCmdCreateProfileLayout Members Templates
SettingsCmdCreateProfileLayout Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Members
Legend
Legend
Template


SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members Public Properties
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members
Public Properties
Public Property | Description
MidOrdinateTolerance | Gets the mid-ordinate tolerance based on a distance across the tessellated curve segments.
TessellateCurve | Gets whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Members
Legend
Legend
Property
public


SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members Public Properties
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Gets whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Members
Legend
Legend
Property
public


SettingsCmdCreateQuickProfile Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Members
SettingsCmdCreateQuickProfile Members Classes
SettingsCmdCreateQuickProfile Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Members
Legend
Legend
Class


SettingsCmdCreateQuickProfile Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Members
SettingsCmdCreateQuickProfile Members Public Properties
SettingsCmdCreateQuickProfile Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
QuickProfile | Gets the default setting of quick profile.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Members
Legend
Legend
Property
public


SettingsCmdCreateQuickProfile Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Members
SettingsCmdCreateQuickProfile Members Templates
SettingsCmdCreateQuickProfile Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Members
Legend
Legend
Template


SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members Public Properties
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members
Public Properties
Public Property | Description
Draw3DEntityProfile | Gets whether to include elevation data for the selected 3D entity in the quick profile.
SelectAllSurfaces | Gets whether to generate profiles of all surfaces in the drawing file in the quick profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Members
Legend
Legend
Property
public


SettingsCmdCreateSampleLines Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Members
SettingsCmdCreateSampleLines Members Classes
SettingsCmdCreateSampleLines Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Members
Legend
Legend
Class


SettingsCmdCreateSampleLines Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Members
SettingsCmdCreateSampleLines Members Public Properties
SettingsCmdCreateSampleLines Members
Public Properties
Public Property | Description
AdditionalSampleControls | Gets the default setting of Additional Sample Controls.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Miscellaneous | Gets the default setting of Miscellaneous.
NameFormat | settings to specify the default name formats for sample line.
SamplingIncrements | Gets the default setting of Sampling Increments.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to sample line.
SwathWidths | Gets the default setting of swath widths.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Members
Legend
Legend
Property
public


SettingsCmdCreateSampleLines Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Members
SettingsCmdCreateSampleLines Members Templates
SettingsCmdCreateSampleLines Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Members
Legend
Legend
Template


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members Public Properties
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members
Public Properties
Public Property | Description
AtHorizontalGeometryPoints | Gets whether additional sample lines are created at horizontal geometry points.
AtRangeEnd | Gets whether a sample line is created at the beginning of the specified range.
AtRangeStart | Gets whether a sample line is created at the beginning of the specified range.
AtSuperelevationCriticalStations | Gets whether additional sample lines are created at superelevation critical stations within the current range.
EndRangeAtAlignmentEnd | Gets whether the sampling range ends at the end of the alignment.
StartRangeAtAlignmentStart | Gets whether the sampling range starts at the beginning of the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Members
Legend
Legend
Property
public


SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members Public Properties
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members
Public Properties
Public Property | Description
LockTostation | Gets whether the sample lines update when the alignment geometry and properties change.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Members
Legend
Legend
Property
public


SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members Public Properties
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members
Public Properties
Public Property | Description
IncrementAlongCurves | Gets the sample increment distance along curves.
IncrementAlongSpirals | Gets the sample increment distance along spirals.
IncrementAlongTangents | Gets the sample increment distance along tangents.
UseSamplingIncrements | Gets whether sample lines are created at incremental stations along the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Members
Legend
Legend
Property
public


SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members Public Properties
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members
Public Properties
Public Property | Description
LeftSwathWidth | Gets the swath width to the left of the alignment.
RightSwathWidth | Gets the swath width to the right of the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Members
Legend
Legend
Property
public


SettingsCmdCreateSectionView Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Members
SettingsCmdCreateSectionView Members Classes
SettingsCmdCreateSectionView Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Members
Legend
Legend
Class


SettingsCmdCreateSectionView Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Members
SettingsCmdCreateSectionView Members Public Properties
SettingsCmdCreateSectionView Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the template for naming the section view.
ProjectionLabelPlacement | settings to specify the default name formats for sample line.
SectionViewCreation | Gets the settings to establish the defaults assigned for section view creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to section view components
TableCreation | Specifies the table creation settings.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Members
Legend
Legend
Property
public


SettingsCmdCreateSectionView Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Members
SettingsCmdCreateSectionView Members Templates
SettingsCmdCreateSectionView Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Members
Legend
Legend
Template


SettingsCmdCreateSectionView::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Members
SettingsCmdCreateSectionView::SettingsCmdTableCreation Members Public Properties
SettingsCmdCreateSectionView::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaterialVolumeTableStyle | Specifies the styles for a material table.
MaximumNumberOfRows | Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum,... more
MaximumTablesPerStack | Specifies the maximum number of sections to include in each stack.
SectionViewAnchor | Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableAnchor | Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
TableLayout | Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
TableSpacing | Specifies the spacing between tables.
TileDirection | Specifies the direction in which the table tiles (across or down).
TotalVolumeTableStyle | Specifies the style for a total volume table.
XOffset | Specifies the horizontal offset of the table.
YOffset | Specifies the vertical offset of the table.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdCreateSheets Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Members
SettingsCmdCreateSheets Members Classes
SettingsCmdCreateSheets Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Members
Legend
Legend
Class


SettingsCmdCreateSheets Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Members
SettingsCmdCreateSheets Members Public Properties
SettingsCmdCreateSheets Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Information | Gets the default match line label location.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name formats for view frame group components.
SheetCreation | Gets the setting of sheet creation for the command CreateSheets.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to view frame group components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Members
Legend
Legend
Property
public


SettingsCmdCreateSheets Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Members
SettingsCmdCreateSheets Members Templates
SettingsCmdCreateSheets Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Members
Legend
Legend
Template


SettingsCmdCreateSheets::SettingsCmdSheetCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Members
SettingsCmdCreateSheets::SettingsCmdSheetCreation Members Public Properties
SettingsCmdCreateSheets::SettingsCmdSheetCreation Members
Public Properties
Public Property | Description
AddNetworkLabels | Specify whether to copy the pipe network labels to destination drawings.
AddToVault | Specify whether to add newly created files to Vault.
AlignNorthArrow | Specify whether to cause the chosen North arrow block to be aligned to North.
AlignProfileAndPlanViewType | Specify how to align profile and plan view.
ExistingSheetSetName | Specify the existing sheet set file where to add created sheet.
NorthArrowBlockName | Specify the block that will be rotated as the North arrow block.
NumberOfLayoutsPerDrawing | Specify the number of layouts to be created in each drawing.
SheetCreateMethod | Specify the sheet create method.
UseExistingSheetSet | Specify whether to use an existing one or create new sheet set.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Members
Legend
Legend
Property
public


SettingsCmdCreateSite Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Members
SettingsCmdCreateSite Members Classes
SettingsCmdCreateSite Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Members
Legend
Legend
Class


SettingsCmdCreateSite Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Members
SettingsCmdCreateSite Members Public Properties
SettingsCmdCreateSite Members
Public Properties
Public Property | Description
Alignment | Gets the default setting of alignment for the command CreateSite.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLine | Gets the default setting of freature line for the command CreateSite.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Parcel | Gets the default setting of parcel for the command CreateSite.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Members
Legend
Legend
Property
public


SettingsCmdCreateSite Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Members
SettingsCmdCreateSite Members Templates
SettingsCmdCreateSite Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Members
Legend
Legend
Template


SettingsCmdCreateSite::SettingsCmdAlignment Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Members
SettingsCmdCreateSite::SettingsCmdAlignment Members Public Properties
SettingsCmdCreateSite::SettingsCmdAlignment Members
Public Properties
Public Property | Description
AlignmentCurveNextAutomaticTagCounter | Gets the increment by which the next new alignment curve tag is automatically numbered.
AlignmentCurveNextManualTagCounter | Gets the increment by which the next new alignment curve tag is manually numbered.
AlignmentLineNextAutomaticTagCounter | Gets the increment by which the next new alignment line tag is automatically numbered.
AlignmentLineNextManualTagCounter | Gets the increment by which the next new alignment line tag is manually numbered.
AlignmentSpiralNextAutomaticTagCounter | Gets the increment by which the next new alignment spiral tag is automatically numbered.
AlignmentSpiralNextManualTagCounter | Gets the increment by which the next new alignment spiral tag is manually numbered.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Members
Legend
Legend
Property
public


SettingsCmdCreateSite::SettingsCmdFeatureLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdFeatureLine Class > SettingsCmdCreateSite::SettingsCmdFeatureLine Members
SettingsCmdCreateSite::SettingsCmdFeatureLine Members Public Properties
SettingsCmdCreateSite::SettingsCmdFeatureLine Members
Public Properties
Public Property | Description
FeatureLineStyle | Gets the default feature line style priority.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdFeatureLine Class > SettingsCmdCreateSite::SettingsCmdFeatureLine Members
Legend
Legend
Property
public


SettingsCmdCreateSite::SettingsCmdParcel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Members
SettingsCmdCreateSite::SettingsCmdParcel Members Public Properties
SettingsCmdCreateSite::SettingsCmdParcel Members
Public Properties
Public Property | Description
ParcelCurveNextAutomaticTagCounter | Gets the increment by which the next new parcel line tag is manually numbered.
ParcelCurveNextManualTagCounter | Gets the increment by which the next new parcel curve tag is manually numbered.
ParcelLineNextAutomaticTagCounter | Gets the increment by which the next new parcel line tag is automatically numbered.
ParcelLineNextManualTagCounter | Gets the increment by which the next new parcel line tag is manually numbered.
ParcelNextAutomaticAreaCounter | Gets the increment by which the next new parcel area is automatically numbered.
ParcelNextManualAreaCounter | Gets the increment by which the next new parcel area is manually numbered.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Members
Legend
Legend
Property
public


SettingsCmdCreateSurface Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Members
SettingsCmdCreateSurface Members Classes
SettingsCmdCreateSurface Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Members
Legend
Legend
Class


SettingsCmdCreateSurface Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Members
SettingsCmdCreateSurface Members Public Properties
SettingsCmdCreateSurface Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
BuildOptions | Gets the defaults assigned when creating surfaces.
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default surface name format settings.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
SurfaceCreation | Gets the defaults assigned when creating surfaces.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Members
Legend
Legend
Property
public


SettingsCmdCreateSurface Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Members
SettingsCmdCreateSurface Members Templates
SettingsCmdCreateSurface Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Members
Legend
Legend
Template


SettingsCmdCreateSurface::SettingCmdBuildOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Members
SettingsCmdCreateSurface::SettingCmdBuildOptions Members Public Properties
SettingsCmdCreateSurface::SettingCmdBuildOptions Members
Public Properties
Public Property | Description
AllowCrossingBreaklines | Gets whether breaklines can cross each other.
ConvertProximityBreaklinesToStandard | Gets whether proximity breaklines are converted to standard breaklines when the surface is built.
CopyDeletedDependentObjects | Gets whether a drawing object is copied to the surface definition item if the object is deleted.
ElevationGreaterThan | Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.
ElevationLessThan | Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.
ElevationToUse | Gets the elevation to use for the crossing breaklines.
ExcludeElevationsGreaterThan | Gets whether an elevation greater than a certain value should be excluded when the surface is built.
ExcludeElevationsLessThan | Gets whether an elevation less than a certain value should be excluded when the surface is built.
MaximumTriangleLength | Gets the triangle length to use when the Use Maximum Triangle Length property is set to Yes.
UseMaximumTriangleLength | Gets whether the surface triangles that exceed the length specified by the Maximum Triangle Length property are removed from the... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Members
Legend
Legend
Property
public


SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members Public Properties
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members
Public Properties
Public Property | Description
CutFactor | Gets the cut factor.
DefaultType | Gets the default surface type that is used when creating a surface.
FillFactor | Gets the fill factor.
GridSurfaceOrientation | Gets the default orientation for a grid.
GridSurfaceXSpacing | Gets the default value for a grid surfaces X spacing.
GridSurfaceYSpacing | Gets the default value for a grid surfaces Y spacing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Members
Legend
Legend
Property
public


SettingsCmdCreateSurface::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingsNameFormat Class > SettingsCmdCreateSurface::SettingsNameFormat Members
SettingsCmdCreateSurface::SettingsNameFormat Members Public Properties
SettingsCmdCreateSurface::SettingsNameFormat Members
Public Properties
Public Property | Description
Surface | Gets the default maintain edges setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingsNameFormat Class > SettingsCmdCreateSurface::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsCmdCreateSurfaceGridFromDEM Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Members
SettingsCmdCreateSurfaceGridFromDEM Members Classes
SettingsCmdCreateSurfaceGridFromDEM Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Members
Legend
Legend
Class


SettingsCmdCreateSurfaceGridFromDEM Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Members
SettingsCmdCreateSurfaceGridFromDEM Members Public Properties
SettingsCmdCreateSurfaceGridFromDEM Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
BuildOptions | Gets the build options assigned when creating surfaces.
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
ImportOptions | Gets the defaults assigned when creating surfaces.
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Members
Legend
Legend
Property
public


SettingsCmdCreateSurfaceGridFromDEM Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Members
SettingsCmdCreateSurfaceGridFromDEM Members Templates
SettingsCmdCreateSurfaceGridFromDEM Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Members
Legend
Legend
Template


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members Public Properties
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members
Public Properties
Public Property | Description
CopyDeletedDependentObjects | Gets whether a drawing object is copied to the surface definition item if the object is deleted.
ElevationGreaterThan | Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.
ElevationLessThan | Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.
ExcludeElevationsGreaterThan | Gets whether an elevation greater than a certain value should be excluded when the surface is built.
ExcludeElevationsLessThan | Gets whether an elevation less than a certain value should be excluded when the surface is built.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Members
Legend
Legend
Property
public


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members Public Properties
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members
Public Properties
Public Property | Description
NullElevation | Gets null elevation.
UseCustomNullElevation | Gets whether use custom null elevation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Members
Legend
Legend
Property
public


SettingsCmdCreateSurfaceReference Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Members
SettingsCmdCreateSurfaceReference Members Classes
SettingsCmdCreateSurfaceReference Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Members
Legend
Legend
Class


SettingsCmdCreateSurfaceReference Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Members
SettingsCmdCreateSurfaceReference Members Public Properties
SettingsCmdCreateSurfaceReference Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default surface name format settings.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Members
Legend
Legend
Property
public


SettingsCmdCreateSurfaceReference Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Members
SettingsCmdCreateSurfaceReference Members Templates
SettingsCmdCreateSurfaceReference Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Members
Legend
Legend
Template


SettingsCmdCreateSurfaceWaterdrop Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Members
SettingsCmdCreateSurfaceWaterdrop Members Classes
SettingsCmdCreateSurfaceWaterdrop Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Members
Legend
Legend
Class


SettingsCmdCreateSurfaceWaterdrop Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Members
SettingsCmdCreateSurfaceWaterdrop Members Public Properties
SettingsCmdCreateSurfaceWaterdrop Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
WaterdropMarker | Gets the default water drop marker options for surfaces.
WaterdropPath | Gets the default water drop path options for surfaces.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Members
Legend
Legend
Property
public


SettingsCmdCreateSurfaceWaterdrop Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Members
SettingsCmdCreateSurfaceWaterdrop Members Templates
SettingsCmdCreateSurfaceWaterdrop Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Members
Legend
Legend
Template


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members Public Properties
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members
Public Properties
Public Property | Description
PlaceMarkerAtStartPoint | Gets whether to draw a marker at the start point of the water drop path.
StartPointMarkerStyle | Gets the default start point marker style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Members
Legend
Legend
Property
public


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members Public Properties
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members
Public Properties
Public Property | Description
PathLayer | Gets the default layer on which to draw the water drop path.
PathObjectType | Gets the default type of AutoCAD object to use for the water drop path.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Members
Legend
Legend
Property
public


SettingsCmdCreateViewFrames Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Members
SettingsCmdCreateViewFrames Members Classes
SettingsCmdCreateViewFrames Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Members
Legend
Legend
Class


SettingsCmdCreateViewFrames Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Members
SettingsCmdCreateViewFrames Members Public Properties
SettingsCmdCreateViewFrames Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Information | Gets the default match line label location.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name formats for view frame group components.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to view frame group components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
ViewFrameCreation | Gets the setting of view frame creation for the command CreateViewFrames.
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Members
Legend
Legend
Property
public


SettingsCmdCreateViewFrames Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Members
SettingsCmdCreateViewFrames Members Templates
SettingsCmdCreateViewFrames Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Members
Legend
Legend
Template


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members Public Properties
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members
Public Properties
Public Property | Description
AlignmentStationRangeSpecifiedByUser | Specify whether to create view frames for a user specified range or for the entire alignment.
EnableFirstViewFrameOffset | Specify whether to enable first view frame offset.
FirstViewFrameOffsetDistance | Specify the distance of the first view frame offset.
InsertMatchLines | Specify whether to enable match lines to be inserted.
MatchLineRepositioning | Specify whether to enalbe extra margin for match line movement after placement.
MatchLineRepositioningValue | Specify the distance for additional margin of match line movement.
MatchLineSnapStation | Specify whether to enable match lines to snap down to a rounded station value.
MatchLineSnapStationValue | Specify the rounding value when match line snap to station.
SheetType | Specify the type of sheet what will be created.
ViewFrameOrientation | Specify the view frame orientation option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Members
Legend
Legend
Property
public


SettingsCmdDrawFeatureLine Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Members
SettingsCmdDrawFeatureLine Members Classes
SettingsCmdDrawFeatureLine Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Members
Legend
Legend
Class


SettingsCmdDrawFeatureLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Members
SettingsCmdDrawFeatureLine Members Public Properties
SettingsCmdDrawFeatureLine Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineCreation | Gets the default setting of feature line creation for the command DrawFeatureLine.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Members
Legend
Legend
Property
public


SettingsCmdDrawFeatureLine Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Members
SettingsCmdDrawFeatureLine Members Templates
SettingsCmdDrawFeatureLine Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Members
Legend
Legend
Template


SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members Public Properties
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members
Public Properties
Public Property | Description
LayerSetting | Specifies the default layer setting when feature lines are created.
UseFeatureLineName | Specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Specifies whether a style is applied to feature lines when created.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Members
Legend
Legend
Property
public


SettingsCmdExportParcelAnalysis Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Members
SettingsCmdExportParcelAnalysis Members Classes
SettingsCmdExportParcelAnalysis Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Members
Legend
Legend
Class


SettingsCmdExportParcelAnalysis Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Members
SettingsCmdExportParcelAnalysis Members Public Properties
SettingsCmdExportParcelAnalysis Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ParcelAnalysis | Gets the default setting of parcel analysis.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Members
Legend
Legend
Property
public


SettingsCmdExportParcelAnalysis Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Members
SettingsCmdExportParcelAnalysis Members Templates
SettingsCmdExportParcelAnalysis Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Members
Legend
Legend
Template


SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members Public Properties
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members
Public Properties
Public Property | Description
AnalysisType | Gets whether Inverse Analysis or Mapcheck Analysis is used.
EnableMapcheckAcrossChord | Gets whether mapcheck across chord is enabled or disabled.
ProcessCounterClockwise | Gets whether segments will be processed in counter-clockwise or clockwise order.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Members
Legend
Legend
Property
public


SettingsCmdFitCurveFeature Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Members
SettingsCmdFitCurveFeature Members Classes
SettingsCmdFitCurveFeature Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Members
Legend
Legend
Class


SettingsCmdFitCurveFeature Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Members
SettingsCmdFitCurveFeature Members Public Properties
SettingsCmdFitCurveFeature Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineFitCurve | Gets the default setting of featureline fit curve for the command FitCurveFeature.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Members
Legend
Legend
Property
public


SettingsCmdFitCurveFeature Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Members
SettingsCmdFitCurveFeature Members Templates
SettingsCmdFitCurveFeature Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Members
Legend
Legend
Template


SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members Public Properties
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members
Public Properties
Public Property | Description
MinimumNumberOfSegments | Specifies the minimum number of segments that must be identified before creating an arc.
Tolerance | Specifies the maximum distance from a PI along the feature to the arc that is to be inserted.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Members
Legend
Legend
Property
public


SettingsCmdGradingElevEditor Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Members
SettingsCmdGradingElevEditor Members Classes
SettingsCmdGradingElevEditor Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Members
Legend
Legend
Class


SettingsCmdGradingElevEditor Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Members
SettingsCmdGradingElevEditor Members Public Properties
SettingsCmdGradingElevEditor Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GradingElevationEditor | Gets the default setting of grading elevation editor for the command GradingElevEditor.
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Members
Legend
Legend
Property
public


SettingsCmdGradingElevEditor Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Members
SettingsCmdGradingElevEditor Members Templates
SettingsCmdGradingElevEditor Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Members
Legend
Legend
Template


SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members Public Properties
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members
Public Properties
Public Property | Description
RaiseLowerIncrement | Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered... more
ShowGradeBreaksOnly | Specifies whether only the feature line start/end points and any grade breaks in between are displayed.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Members
Legend
Legend
Property
public


SettingsCmdGradingTools Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Members
SettingsCmdGradingTools Members Classes
SettingsCmdGradingTools Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Members
Legend
Legend
Class


SettingsCmdGradingTools Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Members
SettingsCmdGradingTools Members Public Properties
SettingsCmdGradingTools Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GradingLayoutTools | Gets the default setting of grading layout tools for the command GradingTools.
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Members
Legend
Legend
Property
public


SettingsCmdGradingTools Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Members
SettingsCmdGradingTools Members Templates
SettingsCmdGradingTools Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Members
Legend
Legend
Template


SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members Public Properties
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members
Public Properties
Public Property | Description
Criteria | Specifies the default Criteria to use when creating grading.
GradingCriteriaSet | Specifies the default Criteria Set to use when creating grading.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Members
Legend
Legend
Property
public


SettingsCmdGradingVolumeTools Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Members
SettingsCmdGradingVolumeTools Members Classes
SettingsCmdGradingVolumeTools Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Members
Legend
Legend
Class


SettingsCmdGradingVolumeTools Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Members
SettingsCmdGradingVolumeTools Members Public Properties
SettingsCmdGradingVolumeTools Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
LimitFeatureSelectionToCurrentGroup | Specifies whether features outside the current grading group can be selected for raising or lowering in the volume calculations.
NameFormat | Gets the default name format for new feature lines and grading groups.
RaiseLowerElevationIncrement | Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered... more
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Members
Legend
Legend
Property
public


SettingsCmdGradingVolumeTools Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Members
SettingsCmdGradingVolumeTools Members Templates
SettingsCmdGradingVolumeTools Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Members
Legend
Legend
Template


SettingsCmdImportGEData Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Members
SettingsCmdImportGEData Members Classes
SettingsCmdImportGEData Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Members
Legend
Legend
Class


SettingsCmdImportGEData Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Members
SettingsCmdImportGEData Members Public Properties
SettingsCmdImportGEData Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
GoogleEarthOptions | Gets the default number of rows and columns collected when importing Google Earth information.
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
SurfaceCreation | Gets the defaults assigned when creating surfaces.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Members
Legend
Legend
Property
public


SettingsCmdImportGEData Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Members
SettingsCmdImportGEData Members Templates
SettingsCmdImportGEData Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Members
Legend
Legend
Template


SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members Public Properties
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members
Public Properties
Public Property | Description
GoogleEarthColumns | Gets the number of columns of data that are collected when importing terrain information from Google Earth.
GoogleEarthRows | Gets the number of rows of data that are collected when importing terrain information from Google Earth.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Members
Legend
Legend
Property
public


SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members Public Properties
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members
Public Properties
Public Property | Description
NameFormat | Gets the default name format for new surfaces.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Members
Legend
Legend
Property
public


SettingsCmdImportGESurface Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Members
SettingsCmdImportGESurface Members Classes
SettingsCmdImportGESurface Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Members
Legend
Legend
Class


SettingsCmdImportGESurface Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Members
SettingsCmdImportGESurface Members Public Properties
SettingsCmdImportGESurface Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
GoogleEarthOptions | Gets the default number of rows and columns collected when importing Google Earth information.
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default surface name format settings.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Members
Legend
Legend
Property
public


SettingsCmdImportGESurface Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Members
SettingsCmdImportGESurface Members Templates
SettingsCmdImportGESurface Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Members
Legend
Legend
Template


SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members Public Properties
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members
Public Properties
Public Property | Description
GoogleEarthColumns | Gets the number of columns of data that are collected when importing terrain information from Google Earth.
GoogleEarthRows | Gets the number of rows of data that are collected when importing terrain information from Google Earth.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Members
Legend
Legend
Property
public


SettingsCmdImportGESurface::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsNameFormat Class > SettingsCmdImportGESurface::SettingsNameFormat Members
SettingsCmdImportGESurface::SettingsNameFormat Members Public Properties
SettingsCmdImportGESurface::SettingsNameFormat Members
Public Properties
Public Property | Description
Surface | Gets the default maintain edges setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsNameFormat Class > SettingsCmdImportGESurface::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsCmdJoinFeatures Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Members
SettingsCmdJoinFeatures Members Classes
SettingsCmdJoinFeatures Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Members
Legend
Legend
Class


SettingsCmdJoinFeatures Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Members
SettingsCmdJoinFeatures Members Public Properties
SettingsCmdJoinFeatures Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineJoin | Gets the default setting of featureline join for the command JoinFeatures.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Members
Legend
Legend
Property
public


SettingsCmdJoinFeatures Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Members
SettingsCmdJoinFeatures Members Templates
SettingsCmdJoinFeatures Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Members
Legend
Legend
Template


SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members Public Properties
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members
Public Properties
Public Property | Description
Tolerance | Specifies how close feature lines must be when using the Join command.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Members
Legend
Legend
Property
public


SettingsCmdSimplifySurface Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Members
SettingsCmdSimplifySurface Members Classes
SettingsCmdSimplifySurface Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Members
Legend
Legend
Class


SettingsCmdSimplifySurface Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Members
SettingsCmdSimplifySurface Members Public Properties
SettingsCmdSimplifySurface Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MaximumChangeInElevation | Gets the maximum allowed difference between the elevation of the original surface and the elevation of the simplified surface.
PercentageOfPointsToRemove | Gets the percent of surface points to remove.
RegionOptions | Gets the default option by which surfaces will be simplified.
SimplifyMethod | Gets the default method by which surfaces will be simplified.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UseMaximumChangeInElevation | Gets whether you will set a default maximum change in elevation.
UsePercentageOfPointsToRemove | Gets whether simplify the image by removing a percent of surface points.
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Members
Legend
Legend
Property
public


SettingsCmdSimplifySurface Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Members
SettingsCmdSimplifySurface Members Templates
SettingsCmdSimplifySurface Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Members
Legend
Legend
Template


SettingsCmdSuperimposeProfile Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Members
SettingsCmdSuperimposeProfile Members Classes
SettingsCmdSuperimposeProfile Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Members
Legend
Legend
Class


SettingsCmdSuperimposeProfile Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Members
SettingsCmdSuperimposeProfile Members Public Properties
SettingsCmdSuperimposeProfile Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
SuperimposeProfile | Gets the default setting of superimpose profile.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Members
Legend
Legend
Property
public


SettingsCmdSuperimposeProfile Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Members
SettingsCmdSuperimposeProfile Members Templates
SettingsCmdSuperimposeProfile Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Members
Legend
Legend
Template


SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members Public Properties
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members
Public Properties
Public Property | Description
HorizontalMidOrdinateDistance | Gets the horizontal mid-ordinate distance for tessellated curve segments.
VerticalMidOrdinateDistance | Gets the horizontal mid-ordinate distance for tessellated curve segments.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Members
Legend
Legend
Property
public


SettingsCmdSurfaceExportToDem Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Members
SettingsCmdSurfaceExportToDem Members Classes
SettingsCmdSurfaceExportToDem Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Members
Legend
Legend
Class


SettingsCmdSurfaceExportToDem Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Members
SettingsCmdSurfaceExportToDem Members Public Properties
SettingsCmdSurfaceExportToDem Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
ExportOptions | Gets the defaults assigned when exporting surfaces to a DEM file.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Members
Legend
Legend
Property
public


SettingsCmdSurfaceExportToDem Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Members
SettingsCmdSurfaceExportToDem Members Templates
SettingsCmdSurfaceExportToDem Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Members
Legend
Legend
Template


SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members Public Properties
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members
Public Properties
Public Property | Description
GridSpacing | Gets the spacing between grids when exporting to a DEM file.
NullElevation | Gets the default custom null elevation used when exporting to a DEM file.
UseCustomNullElevation | Gets whether a custom null elevation is used when exporting to a DEM file.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Members
Legend
Legend
Property
public


SettingsCmdWeedFeatures Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Members
SettingsCmdWeedFeatures Members Classes
SettingsCmdWeedFeatures Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Members
Legend
Legend
Class


SettingsCmdWeedFeatures Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Members
SettingsCmdWeedFeatures Members Public Properties
SettingsCmdWeedFeatures Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineWeed | Gets the default setting of featureline weed for the command WeedFeatures.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Members
Legend
Legend
Property
public


SettingsCmdWeedFeatures Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Members
SettingsCmdWeedFeatures Members Templates
SettingsCmdWeedFeatures Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Members
Legend
Legend
Template


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members Public Properties
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members
Public Properties
Public Property | Description
AngleFactor | Specifies the default Angle factor.
ApplyAngleFactor | Specifies whether the Angle factor in the Weed Vertices dialog box is selected by default.
ApplyGradeFactor | Specifies whether the Grade factor in the Weed Vertices dialog box is selected by default.
ApplyLengthFactor | Specifies whether the Length factor in the Weed Vertices dialog box is selected by default.
ClosePoint3DDistance | Specifies the 3D distance for weeding. Points that are close together in plan view, with slightly different elevations can be... more
ClosePointRemoval | Specifies whether the 3D Distance factor in the Weed Vertices dialog box is selected by default.
GradeFactor | Specifies the default Grade factor.
LengthFactor | Specifies the default Length factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Members
Legend
Legend
Property
public


SettingsGrading Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Members
SettingsGrading Members Classes
SettingsGrading Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Members
Legend
Legend
Class


SettingsGrading Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Members
SettingsGrading Members Public Properties
SettingsGrading Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new feature lines and grading groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Members
Legend
Legend
Property
public


SettingsGrading Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Members
SettingsGrading Members Templates
SettingsGrading Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Members
Legend
Legend
Template


SettingsGrading::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class > SettingsGrading::SettingsNameFormat Members
SettingsGrading::SettingsNameFormat Members Public Properties
SettingsGrading::SettingsNameFormat Members
Public Properties
Public Property | Description
FeatureLine | Gets the default name formats for new new feature lines.
GradingGroup | Gets the default name formats for new grading groups.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class > SettingsGrading::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsGrading::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Members
SettingsGrading::SettingsStyles Members Public Properties
SettingsGrading::SettingsStyles Members
Public Properties
Public Property | Description
CutSlopeGrading | Gets the default style to apply when creating cut slope grading.
FeatureLineStyle | Gets the default style to apply when creating feature lines.
FillSlopeGrading | Gets the default style to apply when creating fill slope grading..
GradingStyle | Gets the default style to apply when creating grading.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Members
Legend
Legend
Property
public


SettingsMassHaulView Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Members
SettingsMassHaulView Members Classes
SettingsMassHaulView Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Members
Legend
Legend
Class


SettingsMassHaulView Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Members
SettingsMassHaulView Members Public Properties
SettingsMassHaulView Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
MassHaulCreation | Gets the default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings... more
NameFormat | Gets the default name formats for new mass haul lines and new mass haul views.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for mass haul components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Members
Legend
Legend
Property
public


SettingsMassHaulView Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Members
SettingsMassHaulView Members Templates
SettingsMassHaulView Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Members
Legend
Legend
Template


SettingsMassHaulView::SettingsMassHaulCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class > SettingsMassHaulView::SettingsMassHaulCreation Members
SettingsMassHaulView::SettingsMassHaulCreation Members Public Properties
SettingsMassHaulView::SettingsMassHaulCreation Members
Public Properties
Public Property | Description
BorrowPitCapacity | Gets the the capacity of a borrow pit.
DumpSiteCapacity | Gets the the capacity of a dump site.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class > SettingsMassHaulView::SettingsMassHaulCreation Members
Legend
Legend
Property
public


SettingsMassHaulView::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class > SettingsMassHaulView::SettingsNameFormat Members
SettingsMassHaulView::SettingsNameFormat Members Public Properties
SettingsMassHaulView::SettingsNameFormat Members
Public Properties
Public Property | Description
MassHaulLine | Gets the default name formats for mass haul lines.
MassHaulView | Gets the default name formats for mass haul views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class > SettingsMassHaulView::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsMassHaulView::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class > SettingsMassHaulView::SettingsStyles Members
SettingsMassHaulView::SettingsStyles Members Public Properties
SettingsMassHaulView::SettingsStyles Members
Public Properties
Public Property | Description
MassHaulLine | Gets the default style for mass haul lines.
MassHaulView | Gets the default style for mass haul views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class > SettingsMassHaulView::SettingsStyles Members
Legend
Legend
Property
public


SettingsParcel Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Members
SettingsParcel Members Classes
SettingsParcel Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Members
Legend
Legend
Class


SettingsParcel Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Members
SettingsParcel Members Public Properties
SettingsParcel Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for creating and labeling parcels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Members
Legend
Legend
Property
public


SettingsParcel Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Members
SettingsParcel Members Templates
SettingsParcel Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Members
Legend
Legend
Template


SettingsParcel::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Members
SettingsParcel::SettingsStyles Members Public Properties
SettingsParcel::SettingsStyles Members
Public Properties
Public Property | Description
Parcel | Gets the default style for parcel .
ParcelAreaLabelStyle | Gets the default style for parcel area label.
ParcelCurveLabel | Gets the default style for parcel curve label
ParcelLineLabel | Gets the default style for parcel line label


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Members
Legend
Legend
Property
public


SettingsPoint Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Members
SettingsPoint Members Classes
SettingsPoint Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Members
Legend
Legend
Class


SettingsPoint Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Members
SettingsPoint Members Public Properties
SettingsPoint Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name format for new points and point groups.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to points and points labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
UpdatePoints | Gets whether you can change local copies of project points without checking them out.
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Members
Legend
Legend
Property
public


SettingsPoint Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Members
SettingsPoint Members Templates
SettingsPoint Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Members
Legend
Legend
Template


SettingsPoint::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class > SettingsPoint::SettingsNameFormat Members
SettingsPoint::SettingsNameFormat Members Public Properties
SettingsPoint::SettingsNameFormat Members
Public Properties
Public Property | Description
Point | Gets the default name formats for new points.
PointGroup | Gets the default name formats for new point groups.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class > SettingsPoint::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsPoint::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class > SettingsPoint::SettingsStyles Members
SettingsPoint::SettingsStyles Members Public Properties
SettingsPoint::SettingsStyles Members
Public Properties
Public Property | Description
Point | Gets the default point style.
PointLabel | Gets the default point label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class > SettingsPoint::SettingsStyles Members
Legend
Legend
Property
public


SettingsPoint::SettingsUpdatePoints Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsUpdatePoints Class > SettingsPoint::SettingsUpdatePoints Members
SettingsPoint::SettingsUpdatePoints Members Public Properties
SettingsPoint::SettingsUpdatePoints Members
Public Properties
Public Property | Description
AllowCheckedInPointsToBeModified | Gets whether you can change checked in points when you are working offline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsUpdatePoints Class > SettingsPoint::SettingsUpdatePoints Members
Legend
Legend
Property
public


SettingsProfile Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Members
SettingsProfile Members Classes
SettingsProfile Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Members
Legend
Legend
Class


SettingsProfile Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Members
SettingsProfile Members Public Properties
SettingsProfile Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
ProfilesCreation | Gets default values for vertical curve sub-entities
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StyleSettings | Gets the default styles for new profiles
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Members
Legend
Legend
Property
public


SettingsProfile Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Members
SettingsProfile Members Templates
SettingsProfile Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Members
Legend
Legend
Template


SettingsProfile::SettingsCriteriaBasedDesignOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class > SettingsProfile::SettingsCriteriaBasedDesignOptions Members
SettingsProfile::SettingsCriteriaBasedDesignOptions Members Public Properties
SettingsProfile::SettingsCriteriaBasedDesignOptions Members
Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
UseDesignChecksOption | Gets whether to associate a design check set with the profile
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class > SettingsProfile::SettingsCriteriaBasedDesignOptions Members
Legend
Legend
Property
public


SettingsProfile::SettingsDefaultNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Members
SettingsProfile::SettingsDefaultNameFormat Members Public Properties
SettingsProfile::SettingsDefaultNameFormat Members
Public Properties
Public Property | Description
OffsetProfileNameTemplate | Gets the default name formats for default name formats for offset profiles
ProfileNameTemplate | Gets the default name formats for default name formats for profiles
SuperimposedProfileNameTemplate | Gets the default name formats for default name formats for superimposed profiles
ThreeDEntityProfileNameTemplate | Gets the default name formats for default name formats for 3D entity profiles


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Members
Legend
Legend
Property
public


SettingsProfile::SettingsProfileCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Members
SettingsProfile::SettingsProfileCreation Members Public Properties
SettingsProfile::SettingsProfileCreation Members
Public Properties
Public Property | Description
AsymmetricalCrestCurveLength1 | Gets the default length for the first part of the asymmetrical crest curve.
AsymmetricalCrestCurveLength2 | Gets the default length for the second part of the asymmetrical crest curve.
AsymmetricalSagCurveLength1 | Gets the default length for the first part of the asymmetrical sag curve.
AsymmetricalSagCurveLength2 | Gets the default length for the second part of the asymmetrical sag curve.
CircularCrestCurveConstraint | Gets whether curve length or radius is the primary constraint on a circular crest curve.
CircularCrestCurveLength | Gets the default length for a circular crest curve.
CircularCrestCurveRadius | Gets the default radius for a circular crest curve.
CircularSagCurveConstraint | Gets whether curve length or radius is the primary constraint on a circular sag curve.
CircularSagCurveLength | Gets the default length for a circular sag curve.
CircularSagCurveRadius | Gets the default radius for a circular sag curve.
DefaultVerticalCurve | Gets the default vertical curve type for a new profile.
HeadlightAngle | Gets the default headlight angle.
HeadlightHeight | Gets the default headlight height.
ParabolicCrestCurveKValue | Gets the default K-value for a parabolic crest curve.
ParabolicCrestCurveLength | Gets the default length for a parabolic crest curve.
ParabolicCrestVerticalConstraint | Gets whether curve length or K value is the primary constraint on a parabolic crest curve.
ParabolicSagCurveKValue | Gets the default K-value for a parabolic sag curve.
ParabolicSagCurveLength | Gets the default length for a parabolic sag curve.
ParabolicSagVerticalConstraint | Gets whether curve length or K value is the primary constraint on a parabolic sag curve.
PassingEyeHeight | Gets the default passing eye height.
PassingObjectHeight | Gets the default passing object height.
StopEyeHeight | Gets the default stop eye height.
StopObjectHeight | Gets the default stop object height.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Members
Legend
Legend
Property
public


SettingsProfile::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class > SettingsProfile::SettingsStyles Members
SettingsProfile::SettingsStyles Members Public Properties
SettingsProfile::SettingsStyles Members
Public Properties
Public Property | Description
ProfileLabelSet | Gets the default profile label set.
ProfileStyle | Gets the default profile style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class > SettingsProfile::SettingsStyles Members
Legend
Legend
Property
public


SettingsProfileView Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Members
SettingsProfileView Members Classes
SettingsProfileView Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Members
Legend
Legend
Class


SettingsProfileView Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Members
SettingsProfileView Members Public Properties
SettingsProfileView Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Creation | Gets style settings for profile view.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets style settings for profile view.
ProjectionLabelPlacement | Gets style settings for profile view.
Slope | The Slope settings
Speed | The Speed settings
SplitOptions | Gets style settings for profile view.
StackedOptions | Gets style settings for profile view.
Station | The Station settings
Styles | Gets style settings for profile view.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Members
Legend
Legend
Property
public


SettingsProfileView Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Members
SettingsProfileView Members Templates
SettingsProfileView Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Members
Legend
Legend
Template


SettingsProfileView::SettingsCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class > SettingsProfileView::SettingsCreation Members
SettingsProfileView::SettingsCreation Members Public Properties
SettingsProfileView::SettingsCreation Members
Public Properties
Public Property | Description
PipeNetworkParts | Settings for PipeNetworkParts.
SpecifyProfileElevationRange | Settings for SpecifyProfileElevationRange.
SpecifyProfileStationRange | Settings for SpecifyProfileElevationRange.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class > SettingsProfileView::SettingsCreation Members
Legend
Legend
Property
public


SettingsProfileView::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Members
SettingsProfileView::SettingsNameFormat Members Public Properties
SettingsProfileView::SettingsNameFormat Members
Public Properties
Public Property | Description
CutArea | Settings for CutArea name template.
FillArea | Settings for FillArea name template.
MultipleBoundaryArea | Settings for MultipleBoundaryArea name template.
ProfileView | Settings for ProfileView name template.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsProfileView::SettingsProjectionLabelPlacement Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class > SettingsProfileView::SettingsProjectionLabelPlacement Members
SettingsProfileView::SettingsProjectionLabelPlacement Members Public Properties
SettingsProfileView::SettingsProjectionLabelPlacement Members
Public Properties
Public Property | Description
DimensionAnchorElevationValueForProjections | Settings for DimensionAnchorElevationValueforProjections.
DimensionAnchorOption | Settings for DimensionAnchorOption.
DimensionAnchorPlotHeightValueForProjections | Settings for DimensionAnchorPlotHeightValueforProjections.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class > SettingsProfileView::SettingsProjectionLabelPlacement Members
Legend
Legend
Property
public


SettingsProfileView::SettingsSplitOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class > SettingsProfileView::SettingsSplitOptions Members
SettingsProfileView::SettingsSplitOptions Members Public Properties
SettingsProfileView::SettingsSplitOptions Members
Public Properties
Public Property | Description
SplitDatumOption | Settings for SplitDatumOption.
SplitProfileViews | Settings for SplitProfileViews.
SplitStationOption | Settings for SplitStationOption.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class > SettingsProfileView::SettingsSplitOptions Members
Legend
Legend
Property
public


SettingsProfileView::SettingsStackedOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class > SettingsProfileView::SettingsStackedOptions Members
SettingsProfileView::SettingsStackedOptions Members Public Properties
SettingsProfileView::SettingsStackedOptions Members
Public Properties
Public Property | Description
GapBetweenViews | Settings for GapBetweenViews.
NumberOfStackedViews | Settings for NumberofStackedViews.
StackedViews | Settings for StackedViews.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class > SettingsProfileView::SettingsStackedOptions Members
Legend
Legend
Property
public


SettingsProfileView::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Members
SettingsProfileView::SettingsStyles Members Public Properties
SettingsProfileView::SettingsStyles Members
Public Properties
Public Property | Description
BottomStackViewStyle | Settings for ProfileView BottomStackViewStyle.
CutAreaShapeStyle | Settings for ProfileView CutAreaShapeStyle.
FillAreaShapeStyle | Settings for ProfileView FillAreaShapeStyle.
FirstSplitViewStyle | Settings for ProfileView FirstSliptViewStyle.
IntermediateSplitViewStyle | Settings for ProfileView IntermediateSplitViewStyle.
LastSplitViewStyle | Settings for ProfileView LastSplitViewStyle.
MarkerStyle | Settings for ProfileView MarkerStyle.
MiddleStackViewStyle | Settings for ProfileView MiddleStackViewStyle.
MultipleBoundaryAreaShapeStyle | Settings for ProfileView MultipleBoundaryAreaShapeStyle.
ProfileDepthLabelStyle | Settings for ProfileView ProfileDepthLabelStyle.
ProfileLabelSet | Settings for ProfileView ProfileLabelSet.
ProfileLabelStyle | Settings for ProfileView ProfileLabelStyle.
ProfileProjectionLabelStyle | Settings for ProfileView ProfileProjectionLabelStyle.
ProfileStationAndElevationLabelStyle | Settings for ProfileView ProfileStationandElevationLabelStyle.
ProfileViewBandStyle | Settings for ProfileView ProfileViewBandStyle.
ProfileViewStyle | Settings for ProfileView ProfileViewStyle.
ProjectionStyle | Settings for ProfileView ProjectionStyle.
TopStackViewStyle | Settings for ProfileView TopStackViewStyle.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Members
Legend
Legend
Property
public


SettingsSampleLine Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Members
SettingsSampleLine Members Classes
SettingsSampleLine Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Members
Legend
Legend
Class


SettingsSampleLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Members
SettingsSampleLine Members Public Properties
SettingsSampleLine Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for sample line.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to sample line.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Members
Legend
Legend
Property
public


SettingsSampleLine Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Members
SettingsSampleLine Members Templates
SettingsSampleLine Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Members
Legend
Legend
Template


SettingsSampleLine::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class > SettingsSampleLine::SettingsNameFormat Members
SettingsSampleLine::SettingsNameFormat Members Public Properties
SettingsSampleLine::SettingsNameFormat Members
Public Properties
Public Property | Description
SampleLine | Settings SampleLine default name format.
SampleLineGroup | Settings SampleLine group default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class > SettingsSampleLine::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsSampleLine::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class > SettingsSampleLine::SettingsStyles Members
SettingsSampleLine::SettingsStyles Members Public Properties
SettingsSampleLine::SettingsStyles Members
Public Properties
Public Property | Description
SampleLine | Settings of SampleLine style.
SampleLineLabel | Settings of SampleLine label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class > SettingsSampleLine::SettingsStyles Members
Legend
Legend
Property
public


SettingsSection Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Members
SettingsSection Members Classes
SettingsSection Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Members
Legend
Legend
Class


SettingsSection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Members
SettingsSection Members Public Properties
SettingsSection Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for sample line.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to sample line.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Members
Legend
Legend
Property
public


SettingsSection Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Members
SettingsSection Members Templates
SettingsSection Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Members
Legend
Legend
Template


SettingsSection::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsNameFormat Class > SettingsSection::SettingsNameFormat Members
SettingsSection::SettingsNameFormat Members Public Properties
SettingsSection::SettingsNameFormat Members
Public Properties
Public Property | Description
Section | Settings Section default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsNameFormat Class > SettingsSection::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsSection::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsStyles Class > SettingsSection::SettingsStyles Members
SettingsSection::SettingsStyles Members Public Properties
SettingsSection::SettingsStyles Members
Public Properties
Public Property | Description
Section | Settings of Section style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsStyles Class > SettingsSection::SettingsStyles Members
Legend
Legend
Property
public


SettingsSectionView Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Members
SettingsSectionView Members Classes
SettingsSectionView Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Members
Legend
Legend
Class


SettingsSectionView Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Members
SettingsSectionView Members Public Properties
SettingsSectionView Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the template for naming the section view.
ProjectionLabelPlacement | settings to specify the default name formats for sample line.
SectionViewCreation | Gets the settings to establish the defaults assigned for section view creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to section view components
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Members
Legend
Legend
Property
public


SettingsSectionView Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Members
SettingsSectionView Members Templates
SettingsSectionView Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Members
Legend
Legend
Template


SettingsSectionView::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsNameFormat Class > SettingsSectionView::SettingsNameFormat Members
SettingsSectionView::SettingsNameFormat Members Public Properties
SettingsSectionView::SettingsNameFormat Members
Public Properties
Public Property | Description
SectionView | Settings SectionView default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsNameFormat Class > SettingsSectionView::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsSectionView::SettingsProjectionLabelPlacement Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class > SettingsSectionView::SettingsProjectionLabelPlacement Members
SettingsSectionView::SettingsProjectionLabelPlacement Members Public Properties
SettingsSectionView::SettingsProjectionLabelPlacement Members
Public Properties
Public Property | Description
DimensionAnchorElevationValueForProjections | Specifies the default value for anchor elevation. Enter a value or click and select an elevation in the drawing area.... more
DimensionAnchorOption | Specifies whether the default anchor option will be Fixed, Above, Below, Graph View Top, or Graph View Bottom.
DimensionAnchorPlotHeightValueForProjections | Specifies the default value for anchor plot height. Enter a value or retain the existing default value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class > SettingsSectionView::SettingsProjectionLabelPlacement Members
Legend
Legend
Property
public


SettingsSectionView::SettingsSectionViewCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class > SettingsSectionView::SettingsSectionViewCreation Members
SettingsSectionView::SettingsSectionViewCreation Members Public Properties
SettingsSectionView::SettingsSectionViewCreation Members
Public Properties
Public Property | Description
SectionGroupElevationRange | Specifies how the elevation range of the section group is set.
SpecifySectionViewHeight | Specifies whether the default section view height is set for the creation of a section view.
SpecifySectionViewOffsetRange | Specifies whether an offset range is set for the creation of a section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class > SettingsSectionView::SettingsSectionViewCreation Members
Legend
Legend
Property
public


SettingsSectionView::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Members
SettingsSectionView::SettingsStyles Members Public Properties
SettingsSectionView::SettingsStyles Members
Public Properties
Public Property | Description
GroupPlot | Settings of GroupPlot style.
Marker | Specifies the default marker style for section view points for offset elevation and depth grade labels.
Projection | Settings of Projection style.
SectionLabelSet | Settings of SectionLabelSet style.
SectionProjectionLabel | Settings of SectionProjectionLabel style.
SectionView | Settings of SectionView style.
SectionViewBandSet | Settings of SectionViewBandSet style.
SectionViewDepthGradeLabel | Specifies the default section view grade label style.
SectionViewOffsetElevationLabel | Specifies the default section view offset elevation label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Members
Legend
Legend
Property
public


SettingsSurface Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Members
SettingsSurface Members Classes
SettingsSurface Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Members
Legend
Legend
Class


SettingsSurface Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Members
SettingsSurface Members Public Properties
SettingsSurface Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ContourLabeling | Gets the defaults assigned to surface labels.
Coordinate | The Coordinate settings
Defaults | Gets the surface defaults setting.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles.assigned to surfaces and surface-related labels.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Members
Legend
Legend
Property
public


SettingsSurface Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Members
SettingsSurface Members Templates
SettingsSurface Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Members
Legend
Legend
Template


SettingsSurface::SettingsContourLabeling Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Members
SettingsSurface::SettingsContourLabeling Members Public Properties
SettingsSurface::SettingsContourLabeling Members
Public Properties
Public Property | Description
DisplayContourLabelLine | Gets whether or not the contour label lines are displayed.
LabelMask | Gets the label mask type.
SurfaceContourLabelStyleMajor | Gets the default major contour label style.
SurfaceContourLabelStyleMinor | Gets the default minor contour label style.
SurfaceContourLabelStyleUserDefined | Gets the user-defined major contour label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Members
Legend
Legend
Property
public


SettingsSurface::SettingsDefaults Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsDefaults Class > SettingsSurface::SettingsDefaults Members
SettingsSurface::SettingsDefaults Members Public Properties
SettingsSurface::SettingsDefaults Members
Public Properties
Public Property | Description
AutoRebuild | Gets the PropertyBoolean value that specifies Automatic as the default setting for the Rebuild Surface command.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsDefaults Class > SettingsSurface::SettingsDefaults Members
Legend
Legend
Property
public


SettingsSurface::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Members
SettingsSurface::SettingsStyles Members Public Properties
SettingsSurface::SettingsStyles Members
Public Properties
Public Property | Description
Marker | Gets the default style for marker.
RenderMaterial | Gets the default render material.
Surface | Gets the default style for surface.
SurfaceSlopeLabel | Gets the default style for slope label.
SurfaceSpotElevationLabel | Gets the default style for spot elevation label .


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Members
Legend
Legend
Property
public


SettingsViewFrameGroup Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Members
SettingsViewFrameGroup Members Classes
SettingsViewFrameGroup Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Members
Legend
Legend
Class


SettingsViewFrameGroup Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Members
SettingsViewFrameGroup Members Public Properties
SettingsViewFrameGroup Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Information | Gets the default match line label location.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the default name formats for view frame group components.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles assigned to view frame group components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Members
Legend
Legend
Property
public


SettingsViewFrameGroup Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Members
SettingsViewFrameGroup Members Templates
SettingsViewFrameGroup Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Members
Legend
Legend
Template


SettingsViewFrameGroup::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Members
SettingsViewFrameGroup::SettingsNameFormat Members Public Properties
SettingsViewFrameGroup::SettingsNameFormat Members
Public Properties
Public Property | Description
Layout | Gets the default name formats for layouts.
MatchLine | Gets the default name formats for match lines.
SheetFile | Gets the default name formats for sheet files.
ViewFrame | Gets the default name formats for view frames.
ViewFrameGroup | Gets the default name formats for view frame groups.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsViewFrameGroup::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Members
SettingsViewFrameGroup::SettingsStyles Members Public Properties
SettingsViewFrameGroup::SettingsStyles Members
Public Properties
Public Property | Description
MatchLine | Gets the default style for match lines.
MatchLineLabelLeft | Gets the default style for labels that are displayed on the left side of a match line.
MatchLineLabelRight | Gets the default style for labels that are displayed on the right side of a match line.
MatchLineLeftLabelLocation | Gets the default location for labels that are displayed on the left side of a match line.
MatchLineRightLabelLocation | Gets the default location for labels that are displayed on the right side of a match line.
ProfileView | Gets the default profile view style.
ProfileViewBandSet | Gets the default style for profile view band sets.
ViewFrame | Gets the default style for view frames.
ViewFrameLabel | Gets the default style for view frame labels.
ViewFrameLabelLocation | Gets the default location on the view frame for view frame labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Members
Legend
Legend
Property
public


Interference Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class > Interference Members
Interference Members Public Properties
Interference Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
Network1Id | This is Network1Id, a member of class Interference.
Network2Id | This is Network2Id, a member of class Interference.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class > Interference Members
Legend
Legend
Property
public


Network Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Members
Network Members Public Methods
Network Members
Public Methods
Public Method | Description
AddCurvePipe | Add a curve pipe by using the geometry information of an input curve.
AddLinePipe | Add a line pipe by using the geometry information of an input line.
AddStructure | Overloaded
BreakPipe | Break the specified pipe with a specified existing structure at a point.
Create | Creates a pipe network specified by name.
FindShortestNetworkPath | Find a shortest path in the network.
GetPipeIds | Gets the objectId collection of all pipes belonging to this pipe network.
GetSpanningPipePlanLabelIds | Gets the spanning pipe plan label collection.
GetSpanningPipeProfileLabelIds | Get the spanning pipe profile label collection.
GetStructureIds | Gets the objectId collection of all structures belonging to this pipe network.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Members
Legend
Legend
Method
public


Network Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Members
Network Members Public Properties
Network Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
PartsListId | Gets or sets the part list id.
PartsListName | Gets or sets the part list name.
PipeNameTemplate | Gets or sets the pipe name template string.
PipeNetworkSectionLayerId | Gets or sets the pipe network section layer id.
PipeNetworkSectionLayerName | Gets or sets the pipe network section layer name.
PipePlanLabelStyleId | Gets or sets the pipe plan label style id.
PipePlanLabelStyleName | Gets or sets the pipe plan label style name.
PipePlanLayerId | Gets or sets the pipe plan layer id.
PipePlanLayerName | Gets or sets the pipe plan layer name.
PipeProfileLabelStyleId | Gets or sets the pipe profile label style id.
PipeProfileLabelStyleName | Gets or sets the pipe profile label style name.
PipeProfileLayerId | Gets or sets the pipe profile layer id.
PipeProfileLayerName | Gets or sets the pipe profile layer name.
ReferenceAlignmentId | Gets or sets the reference alignment id.
ReferenceAlignmentName | Gets or sets the reference alignment name.
ReferenceSurfaceId | Gets or sets the reference surface id.
ReferenceSurfaceName | Gets or sets the reference surface name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StructureNameTemplate | Gets or sets the structure name template string.
StructurePlanLabelStyleId | Gets or sets the structure plan label style id.
StructurePlanLabelStyleName | Gets or sets the structure plan label style name.
StructurePlanLayerId | Gets or sets the structure plan layer id.
StructurePlanLayerName | Gets or sets the structure plan layer name.
StructureProfileLabelStyleId | Gets or sets the structure profile label style id.
StructureProfileLabelStyleName | Gets or sets the structure profile label style name.
StructureProfileLayerId | Gets or sets the structure profile layer id.
StructureProfileLayerName | Gets or sets the structure profile layer name.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Members
Legend
Legend
Property
public


NetworkCatalogDef Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class > NetworkCatalogDef Members
NetworkCatalogDef Members Public Methods
NetworkCatalogDef Members
Public Methods
Public Method | Description
DeclareNewParameter | Declares a new part catalog parameter
DeclarePartProperty | Declares a new part property.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class > NetworkCatalogDef Members
Legend
Legend
Method
public


NetworkRule Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class > NetworkRule Members
NetworkRule Members Public Properties
NetworkRule Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
Name | Gets or sets the name.
ParamsDouble | Gets the Double parameters collection.
ParamsLong | Gets the Long parameters collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class > NetworkRule Members
Legend
Legend
Property
public


Part Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Members
Part Members Public Methods
Part Members
Public Methods
Public Method | Description
AddToProfileView | Draws the part into the specified profile view.
AddToSectionView | Draws the part into the specified section view.
GetOverriddenRuleIds | Gets the overridden Rule ids which this part contains.
GetProfileViewsDisplayingMe | Gets the object id collection of all the profile views in which this part was drawn.
GetSectionViewsDisplayingMe | Gets the object id collection of all the section views in which this part was drawn.
RemoveFromAllProfileViews | Remove the part from all the profile views in which it is drawn.
RemoveFromAllSectionViews | Removes the part from all the section views in which it is drawn.
RemoveFromProfileView | Remove the part from the specified profile view in which it is drawn.
RemoveFromSectionView | Removes the part from the specified section view in which it is drawn.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Members
Legend
Legend
Method
public


Part Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Members
Part Members Public Properties
Part Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
ConnectedPartCount | Gets the number of parts that connects to the part
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Domain | Gets the part's domain.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Material | Gets the material defined for this part.
Name | Gets part's name.
NetworkId | Gets the object id of the network to which this part belongs
NetworkName | Gets the name of the network to which this part belongs
OverrideRuleSet | Gets or sets whether to use overridden rules.
ParamsBool | Gets the boolean parameters collection.
ParamsDouble | Gets the double parameters collection.
ParamsLong | Gets the long parameters collection.
ParamsString | Gets the string parameters collection.
PartData | Gets or sets the part data record.
PartDefId | Gets the object id of PartDef.
PartDescription | Gets the part’s description.
PartSizeName | Gets the part size name.
PartSubType | Gets the part’s subtype.
PartType | Gets the type of the network park.
Position | Gets or sets the position of the network part.
ProfileViewPartId | Gets the object id of the part's counterpart in profile views.
RefAlignmentId | Gets or sets the object id of the alignment which this part references.
RefAlignmentName | Gets the name of the alignment which this part references
RefSurfaceId | Gets or sets the object id of the surface that this part references.
RefSurfaceName | Gets the name of the surface which this part references.
RuleSetStyleId | Gets or sets the object id of RuleSetStyle.
RuleSetStyleName | Gets or sets RuleSetStyle by name.
SectionViewPartId | Gets the object id of the part's counterpart in section views.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
Solid3dBody | Gets the 3d solid body of the part.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
SurfaceId | Gets or sets the object id of the surface that this part references.
WallThickness | Gets the wall thickness for this structure, measured from the inside edge of the structure to the outside edge of... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Members
Legend
Legend
Property
public


PartDataField Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Members
PartDataField Members Public Properties
PartDataField Members
Public Properties
Public Property | Description
Context | Gets the parameter context.
ContextString | Gets the parameter context string.
DataType | Gets the type of the reserved data.
Description | Gets the description of the data field.
Index | Gets the parameter index.
IsFromList | Gets if the value of data field should be set from a fixed list.
IsFromRange | Gets if the value of data field should be set from a range.
IsReadOnly | Checks if the data field is read-only.
Name | Gets the name of the data field.
Units | Gets the parameter units.
Value | Gets or sets the value. The value type is returned by the DataType property.
ValueList | Gets the list of valid data if the data field is from a fixed list.
ValueRange | Gets the range of valid data if the data field is from a range.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Members
Legend
Legend
Property
public


PartDataList Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Members
PartDataList Members Public Methods
PartDataList Members
Public Methods
Public Method | Description
IsValidValue | Gets if the specified value is in the list.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Members
Legend
Legend
Method
public


PartDataList Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Members
PartDataList Members Public Properties
PartDataList Members
Public Properties
Public Property | Description
Context | Gets the parameter context of the list
Count | The count of fields in the list
DataType | Gets the type of the data value.
default | Gets the value in the list by index.
Index | Gets the parameter index of the list


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Members
Legend
Legend
Property
public


PartDataRange Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Members
PartDataRange Members Public Methods
PartDataRange Members
Public Methods
Public Method | Description
IsValidValue | Gets if the specified value is in the range.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Members
Legend
Legend
Method
public


PartDataRange Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Members
PartDataRange Members Public Properties
PartDataRange Members
Public Properties
Public Property | Description
Context | Gets the parameter context of the list.
DataType | Gets the type of the data value.
Index | Gets the parameter index of the list.
RangeDefault | Gets the default value of the range.
RangeMax | Gets the maximum of range.
RangeMin | Gets the minimum of range.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Members
Legend
Legend
Property
public


PartDataRecord Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Members
PartDataRecord Members Public Methods
PartDataRecord Members
Public Methods
Public Method | Description
GetAllDataFields | Gets all data fields.
GetDataFieldBy | Overloaded
GetMaxIndex | Gets the maximum index of one context type.
GetSupportedContexts | Gets the collection of supported ContextType.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Members
Legend
Legend
Method
public


PartDef Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Members
PartDef Members Public Methods
PartDef Members
Public Methods
Public Method | Description
Get3dBody | Gets the 3d solid body.
GetBoundingShapeBody | Gets the bounding shape body.
GetNetworkPartViewDef | Gets the network part view def.
GetProfileInFrontView | Gets the profile in front view.
PartDef | This is PartDef, a member of class PartDef.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Members
Legend
Legend
Method
public


PartViewDef Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Members
PartViewDef Members Public Properties
PartViewDef Members
Public Properties
Public Property | Description
BoundingBodyBlockId | Gets the bounding body block id.
BoundingBodyBlockName | Gets the bounding body block name.
PartBodyGraphicsBlockId | Gets the part body graphics block id.
PartBodyGraphicsBlockName | Gets the part body graphics block name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Members
Legend
Legend
Property
public


Pipe Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Members
Pipe Members Public Methods
Pipe Members
Public Methods
Public Method | Description
AddToProfileView | Draws the part into the specified profile view.
AddToSectionView | Draws the part into the specified section view.
ConnectToPipe | Connect one pipe to another pipe. If needed, disconnect the original one and move the pipe to that pipe for... more
ConnectToStructure | Connect one pipe to another structure. If needed, disconnect the original one and move the pipe to that structure for... more
Disconnect | Disconnect pipe.
GetClosestPointTo | Gets the closest point found to the given point on a pipe.
GetLabelIds | Gets the collection of pipe label ids.
GetOverriddenRuleIds | Gets the overridden Rule ids which this part contains.
GetParamAtPoint | Gets the scale on the pipe for the given point.
GetPointAtParam | Gets a 3d point for the given parameter.
GetProfileViewsDisplayingMe | Gets the object id collection of all the profile views in which this part was drawn.
GetProject2dPointVertically | Returns true if get the Project2dPoint successfully, otherwise false.
GetSectionViewsDisplayingMe | Gets the object id collection of all the section views in which this part was drawn.
IsMaxCoverViolated | Returns true if the Maximum Cover is violated.
IsMinCoverViolated | Returns true if the Minimum Cover is violated.
RemoveFromAllProfileViews | Remove the part from all the profile views in which it is drawn.
RemoveFromAllSectionViews | Removes the part from all the section views in which it is drawn.
RemoveFromProfileView | Remove the part from the specified profile view in which it is drawn.
RemoveFromSectionView | Removes the part from the specified section view in which it is drawn.
ResizeByInnerDiameterOrWidth | Resize the pipe by inner diameter or width.
SetSlopeHoldEnd | Sets the slope of the pipe away from the pipe’s end point.
SetSlopeHoldStart | Sets the slope of the pipe away from the pipe’s start point.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Members
Legend
Legend
Method
public


Pipe Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Members
Pipe Members Public Properties
Pipe Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
Bearing | Gets the horizontal bearing for straight pipes, and chord bearing for curved pipes.
ConnectedPartCount | Gets the number of parts that connects to the part
CoverOfEndpoint | Gets the end point's cover of pipe.
CoverOfStartPoint | Gets the start point's cover of pipe.
CrossSectionalShape | Gets the pipe’s cross sectional shape, such as circular, egg-shaped, elliptical, or rectangular.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Domain | Gets the part's domain.
EndOffset | Gets the offset of the ending point for the pipe object.
EndPoint | Gets or sets the endpoint of the Pipe.
EndStation | Gets the station of the ending point for the pipe object.
EndStructureId | Gets the end structure id of the Pipe. If no connected structure, return ObjectId::Null.
FlowDirection | Gets the current flow direction of the pipe, relative to the start and endpoint of the pipe.
FlowDirectionMethod | Gets or sets the method that is used to determine the flow for this pipe.
HoldOnResizeType | Gets or sets how Structure should hold when resized.
InnerDiameterOrWidth | Gets the inner diameter or inner width of the pipe.
InnerHeight | Gets the inner height of the pipe in drawing units.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Length2D | Use Autodesk.Civil.PipeNetwork.Pipe.Length2DCenterToCenter instead.
Length2DCenterToCenter | Gets the two-dimensional length of the pipe, measured from the center of the connected starting structure to the center of... more
Length2DToInsideEdge | Gets the two-dimensional length of the pipe, measured from the inside edge of the connected starting structure to the inside... more
Length3D | Use Autodesk.Civil.PipeNetwork.Pipe.Length3DCenterToCenter instead.
Length3DCenterToCenter | Gets the three-dimensional length of the pipe, measured from the center of the connected starting structure to the center of... more
Length3DToInsideEdge | Gets the three-dimensional length of the pipe,measured from the inside edge of the connected starting structure to the inside edge... more
Material | Gets the material defined for this part.
MaximumCover | Gets the maximum depth of cover along the entire length of pipe, from the top outside of the pipe to... more
MinimumCover | Gets the minimum depth of cover along the entire length of pipe, from the top outside of the pipe to... more
Name | Gets or sets the Entity object's name.
Name | Gets part's name.
NetworkId | Gets the object id of the network to which this part belongs
NetworkName | Gets the name of the network to which this part belongs
OuterDiameterOrWidth | Gets the outer diameter or outer width of the pipe.
OuterHeight | Gets the outer height of the pipe in drawing units.
OverrideRuleSet | Gets or sets whether to use overridden rules.
ParamsBool | Gets the boolean parameters collection.
ParamsDouble | Gets the double parameters collection.
ParamsLong | Gets the long parameters collection.
ParamsString | Gets the string parameters collection.
PartData | Gets or sets the part data record.
PartDefId | Gets the object id of PartDef.
PartDescription | Gets the part’s description.
PartSizeName | Gets the part size name.
PartSubType | Gets the part’s subtype.
PartType | Gets the type of the network park.
Position | Gets or sets the position of the network part.
ProfileViewPartId | Gets the object id of the part's counterpart in profile views.
Radius | Gets the radius of the pipe.
RefAlignmentId | Gets or sets the object id of the alignment which this part references.
RefAlignmentName | Gets the name of the alignment which this part references
RefSurfaceId | Gets or sets the object id of the surface that this part references.
RefSurfaceName | Gets the name of the surface which this part references.
RuleSetStyleId | Gets or sets the object id of RuleSetStyle.
RuleSetStyleName | Gets or sets RuleSetStyle by name.
SectionViewPartId | Gets the object id of the part's counterpart in section views.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
Slope | Gets the pipe’s slope in absolute value.
Solid3dBody | Gets the 3d solid body of the part.
StartOffset | Gets the offset of the starting point for the pipe object.
StartPoint | Gets or sets the start point of the Pipe.
StartStation | Gets the station of the starting point for the pipe object.
StartStructureId | Gets the start structure id of the Pipe. If no connected structure, return ObjectId::Null.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
SubEntityType | Gets the type of the pipe.
SurfaceId | Gets or sets the object id of the surface that this part references.
WallThickness | Gets the wall thickness for this structure, measured from the inside edge of the structure to the outside edge of... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Members
Legend
Legend
Property
public


ProfileViewPart Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Members
ProfileViewPart Members Public Methods
ProfileViewPart Members
Public Methods
Public Method | Description
GetLabelIds | Gets the object ids of the labels attached to this profile network part


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Members
Legend
Legend
Method
public


ProfileViewPart Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Members
ProfileViewPart Members Public Properties
ProfileViewPart Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
ModelPartId | Gets the object id of the source network part of model space
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Members
Legend
Legend
Property
public


Structure Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Members
Structure Members Public Methods
Structure Members
Public Methods
Public Method | Description
AddToProfileView | Draws the part into the specified profile view.
AddToSectionView | Draws the part into the specified section view.
ConnectToPipe | Connect this structure to the specified pipe.
Disconnect | Disconnect with pipe.
GetConnectedPipeNames | Gets all the connected pipe names.
GetLabelIds | Gets the collection of structure label ids.
GetOverriddenRuleIds | Gets the overridden Rule ids which this part contains.
GetProfileViewsDisplayingMe | Gets the object id collection of all the profile views in which this part was drawn.
GetSectionViewsDisplayingMe | Gets the object id collection of all the section views in which this part was drawn.
IsConnectedPipeFlowingIn | Determines if the connected pipe is flowing into the structure
IsConnectedPipeFlowingOut | Determines if the connected pipe is flowing out of the structure
IsPointInsideStructureRegion | Returns true if the point is within the structure region.
RemoveFromAllProfileViews | Remove the part from all the profile views in which it is drawn.
RemoveFromAllSectionViews | Removes the part from all the section views in which it is drawn.
RemoveFromProfileView | Remove the part from the specified profile view in which it is drawn.
RemoveFromSectionView | Removes the part from the specified section view in which it is drawn.
ResizeByPipeDepths | Resize the structure by pipe depths.
ResizeJunctionStructure | Resize the Junction structure by rim and sump elevations.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Members
Legend
Legend
Method
public


Structure Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Members
Structure Members Public Properties
Structure Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
AutomaticRimSurfaceAdjustment | Gets or sets whether the rim should be automatically adjusted.
BarrelPipeClearance | Gets the clearance of barrel pipe.
BoundingShape | Gets the structure bounding shape.
ConeHeight | Gets the height of the cone shaped section of the structure.
ConnectedPartCount | Gets the number of parts that connects to the part
ConnectedPipe | Gets the pipe connected to the structure by index.
ConnectedPipesCount | Gets the count of the pipes connected to the structure.
ControlSumpBy | Gets or sets how the sump should be adjusted.
Cover | Gets the model or type of grate used for a structure intended to be used as a catchbasin.
DiameterOrWidth | Gets the structure diameter or width.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
Domain | Gets the part's domain.
Easting | Gets or sets the structure’s easting.
FloorThickness | Gets the thickness of the bottom of the structure.
Frame | Gets the model or type of frame used for a structure.
FrameDiameter | Gets the diameter of the structure’s frame.
FrameHeight | Gets the height of the structure’s frame.
Grate | Gets the grate of the pipe.
HeadwallBaseThickness | Gets the thickness of the base of the headwall.
HeadwallBaseWidth | Gets the width of the base of the headwall.
Height | Gets the structure height.
InnerDiameterOrWidth | Gets the structure inner diameter or width.
InnerLength | Gets the structure inner length.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Length | Gets the structure length.
Location | Gets or sets the location.
Material | Gets the material defined for this part.
Name | Gets or sets the Entity object's name.
Name | Gets part's name.
NetworkId | Gets the object id of the network to which this part belongs
NetworkName | Gets the name of the network to which this part belongs
Northing | Gets or sets the structure’s northing.
Offset | Gets the structure’s offset.
OverrideRuleSet | Gets or sets whether to use overridden rules.
ParamsBool | Gets the boolean parameters collection.
ParamsDouble | Gets the double parameters collection.
ParamsLong | Gets the long parameters collection.
ParamsString | Gets the string parameters collection.
PartData | Gets or sets the part data record.
PartDefId | Gets the object id of PartDef.
PartDescription | Gets the part’s description.
PartSizeName | Gets the part size name.
PartSubType | Gets the part’s subtype.
PartType | Gets the type of the network park.
PipeCenterDepth | Gets the center depth of the pipe.
PipeInnerDiameterOrWidth | Gets the inner diameter or inner width of the pipe.
PipeInvertDepth | Gets the invert depth.
PipeLowestBottomDepth | Gets the lowest bottom depth of a pipe.
PipeOuterBottomDepth | Gets the outer bottom pipe depth.
PipeOuterTopDepth | Gets the outer top pipe depth.
PipeUpperTopDepth | Gets the upper top depth of a pipe.
PipeWallThickness | Gets the pipe wall thickness.
Position | Gets or sets the position of the network part.
ProfileViewPartId | Gets the object id of the part's counterpart in profile views.
RefAlignmentId | Gets or sets the object id of the alignment which this part references.
RefAlignmentName | Gets the name of the alignment which this part references
RefSurfaceId | Gets or sets the object id of the surface that this part references.
RefSurfaceName | Gets the name of the surface which this part references.
RimElevation | Gets or sets the rim elevation.
RimToSumpHeight | Gets or sets the distance between the sump to the structure’s rim.
Rotation | Gets or sets the structure rotation.
RuleSetStyleId | Gets or sets the object id of RuleSetStyle.
RuleSetStyleName | Gets or sets RuleSetStyle by name.
SectionViewPartId | Gets the object id of the part's counterpart in section views.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
Solid3dBody | Gets the 3d solid body of the part.
Station | Gets the structure’s station.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.
SumpDepth | Gets or sets the sump depth.
SumpElevation | Gets or sets the sump elevation.
SurfaceAdjustmentValue | Gets or sets the surface adjustment value
SurfaceElevationAtInsertionPoint | Gets the inner diameter or inner width of the pipe.
SurfaceId | Gets or sets the object id of the surface that this part references.
VerticalPipeClearance | Gets the clearance required from the top outside of the highest pipe connected to the structure, to the rim.
WallThickness | Gets the wall thickness for this structure, measured from the inside edge of the structure to the outside edge of... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Members
Legend
Legend
Property
public


DataPartFamily Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Members
DataPartFamily Members Public Properties
DataPartFamily Members
Public Properties
Public Property | Description
BoundingShape | Gets the bounding shape type if the part is Structure, or it's undefined.
Description | Gets the part description
Domain | Gets the part domain
GUID | Gets the GUID of the part family
PartType | Gets the part type
SweptShape | Gets the swept shape type if the part is Pipe, or it's undefined.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Members
Legend
Legend
Property
public


InterferenceStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Members
InterferenceStyle Members Public Methods
InterferenceStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that defines the model style for the component indicated by the specified InterferenceDisplayStyleType value.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified InterferenceDisplayStyleType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified InterferenceDisplayStyleType value.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Members
Legend
Legend
Method
public
virtual


InterferenceStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Members
InterferenceStyle Members Public Properties
InterferenceStyle Members
Public Properties
Public Property | Description
AbsoluteModelSize | Gets or sets the absolute model size.
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
DrawingScaleModelSize | Gets or sets the drawing scale model size.
MarkerStyle | Gets or sets the marker style.
ModelOptions | Gets or sets the model options, TrueSolid or Sphere.
ModelSizeOptions | Gets or sets the model size options, UseAbsoluteUnits or UseDrawingScale.
ModelSizeType | Gets or sets the interference size type, SolidExtents or UserDefined.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Members
Legend
Legend
Property
public


InterferenceStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class > InterferenceStyleCollection Members
InterferenceStyleCollection Members Public Methods
InterferenceStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class > InterferenceStyleCollection Members
Legend
Legend
Method
public
virtual


InterferenceStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class > InterferenceStyleCollection Members
InterferenceStyleCollection Members Public Properties
InterferenceStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class > InterferenceStyleCollection Members
Legend
Legend
Property
public


LabelStylesPipeRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class > LabelStylesPipeRoot Members
LabelStylesPipeRoot Members Public Properties
LabelStylesPipeRoot Members
Public Properties
Public Property | Description
CrossSectionLabelStyles | Gets the collection of all pipe Cross Section label styles in the database.
DefaultLabelStyle | Gets the default vaules of label styles.
PlanProfileLabelStyles | Gets the collection of all pipe Plan Profile label styles in the database.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class > LabelStylesPipeRoot Members
Legend
Legend
Property
public


LabelStylesStructureRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesStructureRoot Class > LabelStylesStructureRoot Members
LabelStylesStructureRoot Members Public Properties
LabelStylesStructureRoot Members
Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
LabelStyles | Gets the collection of all structure label styles in the database.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesStructureRoot Class > LabelStylesStructureRoot Members
Legend
Legend
Property
public


NetworkRuleSetStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Members
NetworkRuleSetStyle Members Public Methods
NetworkRuleSetStyle Members
Public Methods
Public Method | Description
CloneAndAddRule | Add a copy of input source rule to rule set.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetRuleIds | Gets the objectId collection of all rules belonging to this network rule set.
RemoveAllRules | Remove all the rules belonging to the rule set.
RemoveRule | Remove the specified rule from rule set.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Members
Legend
Legend
Method
public
virtual


NetworkRuleSetStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Members
NetworkRuleSetStyle Members Public Properties
NetworkRuleSetStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
RulesCount | Gets the count of all rules belonging to this network rule set.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Members
Legend
Legend
Property
public


PartFamily Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Members
PartFamily Members Public Methods
PartFamily Members
Public Methods
Public Method | Description
AddPartSize | Adds part one or more part sizes to this part family.
RemovePartSize | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Members
Legend
Legend
Method
public


PartFamily Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Members
PartFamily Members Public Properties
PartFamily Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BoundingShape | Gets the bounding shape type if the part is Structure, or it's undefined.
default | Gets the object id of the part size with the given description under the part family.
Description | Gets the part family description
Document | Gets the Document associated with the DBObject. Not implemented.
Domain | Gets the part domain
GUID | Gets the GUID of the part family
Name | Gets or sets the name.
PartSizeCount | Gets count of part sizes under this part family
PartSizeFilter | Gets the part size filter record through which you can set the corresponding properties to specify what part sizes you... more
PartType | Gets the part type
SweptShape | Gets the swept shape type if the part is Pipe, or it's undefined.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Members
Legend
Legend
Property
public


PartSize Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Members
PartSize Members Public Properties
PartSize Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MaterialStyleId | Gets or sets the object id of the material style to apply side by side with the part size.
Name | Gets or sets the name.
PartStyleId | Gets or sets the object id of the part style to apply side by side with the part size.
PayItems | Gets or Sets the payitem list.
RulesStyleId | Gets or sets the object id of the rule set style to apply side by side with the part size.... more
SizeDataRecord | Gets the serialized catalog part size record.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Members
Legend
Legend
Property
public


PartsList Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Members
PartsList Members Public Methods
PartsList Members
Public Methods
Public Method | Description
AddPartFamilyByDescription | Adds a part family referenced by unique description of current active catalog to this parts list.
AddPartFamilyByGuid | Adds a part family referenced by unique GUID of current active catalog to this parts list. A parts list can... more
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetAvailablePartFamilies | Gets available part families of the current active catalog.
GetPartFamilyIdsByDomain | Gets the object id collection of part families of specified domain under this parts list.
RemovePartFamily | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Members
Legend
Legend
Method
public
virtual


PartsList Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Members
PartsList Members Public Properties
PartsList Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the object id of the part family from this parts list by given description. Returns null object id if... more
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PartFamilyCount | Gets the count of part families under this parts list.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Members
Legend
Legend
Property
public


PartsListCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class > PartsListCollection Members
PartsListCollection Members Public Methods
PartsListCollection Members
Public Methods
Public Method | Description
Add | Create a new parts list named by the input string. The new parts list will automatically have the null structure... more
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class > PartsListCollection Members
Legend
Legend
Method
public
virtual


PartsListCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class > PartsListCollection Members
PartsListCollection Members Public Properties
PartsListCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class > PartsListCollection Members
Legend
Legend
Property
public


PipeNetworkBandStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Members
PipeNetworkBandStyle Members Public Methods
PipeNetworkBandStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the PipeNetwork component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Members
Legend
Legend
Method
public
virtual


PipeNetworkBandStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Members
PipeNetworkBandStyle Members Public Properties
PipeNetworkBandStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
PipeLabelStyleId | Gets the band profile data pipe label style id.
PipeTickStyle | Gets the band profile data pipe tick style.
StructureLabelStyleId | Gets the band profile data structure label style id.
StructureTickStyle | Gets the band profile data structure tick style.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Members
Legend
Legend
Property
public


PipeRuleSetStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class > PipeRuleSetStyleCollection Members
PipeRuleSetStyleCollection Members Public Methods
PipeRuleSetStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class > PipeRuleSetStyleCollection Members
Legend
Legend
Method
public
virtual


PipeRuleSetStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class > PipeRuleSetStyleCollection Members
PipeRuleSetStyleCollection Members Public Properties
PipeRuleSetStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class > PipeRuleSetStyleCollection Members
Legend
Legend
Property
public


PipeStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Members
PipeStyle Members Public Methods
PipeStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that defines the Model style.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified PipeDisplayStylePlanType value.
GetDisplayStyleProfile | Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified PipeDisplayStyleProfileType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified PipeDisplayStyleSectionType value.
GetHatchStylePlan | Gets the HatchDisplayStyle object that defines the Plan style.
GetHatchStyleProfile | Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified PipeHatchStyleProfileType value.
GetHatchStyleSection | Gets the HatchDisplayStyle object that defines the Section style.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Members
Legend
Legend
Method
public
virtual


PipeStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Members
PipeStyle Members Public Properties
PipeStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PlanOption | Gets the object that defines the appearance of the pipe in a 2D plan view.
ProfileOption | Gets the object that defines the appearance of the pipe in a profile view.
SectionCrossingHatch | Gets or sets the PipeHatchOptions object that specifies the style for the inside walls of pipe crossings displayed in section... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Members
Legend
Legend
Property
public


PipeStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class > PipeStyleCollection Members
PipeStyleCollection Members Public Methods
PipeStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class > PipeStyleCollection Members
Legend
Legend
Method
public
virtual


PipeStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class > PipeStyleCollection Members
PipeStyleCollection Members Public Properties
PipeStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class > PipeStyleCollection Members
Legend
Legend
Property
public


PipeStyleOptionBase Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Members
PipeStyleOptionBase Members Public Properties
PipeStyleOptionBase Members
Public Properties
Public Property | Description
AlignHatchToPipe | Gets or sets the AlignHatchToPipe value that specifies whether the angle of the hatch lines for the pipe align with... more
EndLineSize | Pipe style end line size.
EndLineSizePercent | Pipe style end line size percent.
EndSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe end size is drawn in absolute units, to drawing scale,... more
EndSizeType | Specifies the appearance of the pipe end, such as draw to inner wall, draw to outer wall, or user-defined.
HatchOptions | Specifies which components of the pipe shape display a hatch pattern.
InnerDiameter | Specifies the inner pipe wall dimensions as an absolute value.
InnerDiameterPercent | Specifies the inner pipe wall dimensions as a percent of drawing size.
OuterDiameter | Specifies the outer pipe wall dimensions as an absolute value.
OuterDiameterPercent | Specifies the outer pipe wall dimensions as a percent of drawing size.
PipeToPipeEndCleanup | Gets or sets the PipeToPipeEndCleanup value that specifies whether the appearance of pipe to pipe connections in plan/profile view is... more
WallSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe wall size is drawn in absolute units, to drawing scale,... more
WallSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe wall.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Members
Legend
Legend
Property
public


PipeStylePlanOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Members
PipeStylePlanOption Members Public Properties
PipeStylePlanOption Members
Public Properties
Public Property | Description
AlignHatchToPipe | Gets or sets the AlignHatchToPipe value that specifies whether the angle of the hatch lines for the pipe align with... more
CenterlineOptions | Gets or sets the method that will be used to define and draw the dimensions of the pipe centerline.
CenterlineSize | Gets or sets pipe style center line size.
CenterlineSizePercent | Gets or sets pipe style center line size percent.
CenterlineWidthOptions | Gets or sets the center line width option.
EndLineSize | Pipe style end line size.
EndLineSizePercent | Pipe style end line size percent.
EndSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe end size is drawn in absolute units, to drawing scale,... more
EndSizeType | Specifies the appearance of the pipe end, such as draw to inner wall, draw to outer wall, or user-defined.
HatchOptions | Specifies which components of the pipe shape display a hatch pattern.
InnerDiameter | Specifies the inner pipe wall dimensions as an absolute value.
InnerDiameterPercent | Specifies the inner pipe wall dimensions as a percent of drawing size.
OuterDiameter | Specifies the outer pipe wall dimensions as an absolute value.
OuterDiameterPercent | Specifies the outer pipe wall dimensions as a percent of drawing size.
PipeToPipeEndCleanup | Gets or sets the PipeToPipeEndCleanup value that specifies whether the appearance of pipe to pipe connections in plan/profile view is... more
WallSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe wall size is drawn in absolute units, to drawing scale,... more
WallSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe wall.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Members
Legend
Legend
Property
public


PipeStyleProfileOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleProfileOption Class > PipeStyleProfileOption Members
PipeStyleProfileOption Members Public Properties
PipeStyleProfileOption Members
Public Properties
Public Property | Description
AlignHatchToPipe | Gets or sets the AlignHatchToPipe value that specifies whether the angle of the hatch lines for the pipe align with... more
CrossingHatch | Specifies which components of a pipe crossing display a hatch pattern.
EndLineSize | Pipe style end line size.
EndLineSizePercent | Pipe style end line size percent.
EndSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe end size is drawn in absolute units, to drawing scale,... more
EndSizeType | Specifies the appearance of the pipe end, such as draw to inner wall, draw to outer wall, or user-defined.
HatchOptions | Specifies which components of the pipe shape display a hatch pattern.
InnerDiameter | Specifies the inner pipe wall dimensions as an absolute value.
InnerDiameterPercent | Specifies the inner pipe wall dimensions as a percent of drawing size.
OuterDiameter | Specifies the outer pipe wall dimensions as an absolute value.
OuterDiameterPercent | Specifies the outer pipe wall dimensions as a percent of drawing size.
PipeToPipeEndCleanup | Gets or sets the PipeToPipeEndCleanup value that specifies whether the appearance of pipe to pipe connections in plan/profile view is... more
WallSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe wall size is drawn in absolute units, to drawing scale,... more
WallSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe wall.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleProfileOption Class > PipeStyleProfileOption Members
Legend
Legend
Property
public


SizeFilterField Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class > SizeFilterField Members
SizeFilterField Members Public Properties
SizeFilterField Members
Public Properties
Public Property | Description
Context | Gets the parameter context.
ContextString | Gets the parameter context string.
DataSource | Gets the parameter data source.
DataType | Gets the type of the reserved data.
Description | Gets the description of the data field.
Index | Gets the parameter index.
IsFromList | Gets if the value of data field should be set from a fixed list.
IsFromRange | Gets if the value of data field should be set from a range.
IsMultipleSelect | Gets if multiselecting all the values if the data source of this parameter is "FixedList"
IsReadOnly | Checks if the data field is read-only.
Name | Gets the name of the data field.
Units | Gets the parameter units.
Value | Gets or sets the value. The value type is returned by the DataType property.
ValueList | Gets the list of valid data if the data field is from a fixed list.
ValueRange | Gets the range of valid data if the data field is from a range.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class > SizeFilterField Members
Legend
Legend
Property
public


SizeFilterRecord Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Members
SizeFilterRecord Members Public Methods
SizeFilterRecord Members
Public Methods
Public Method | Description
GetParamByContextAndIndex | Gets the catalog parameter by context and index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Members
Legend
Legend
Method
public


SizeFilterRecord Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Members
SizeFilterRecord Members Public Properties
SizeFilterRecord Members
Public Properties
Public Property | Description
default | Gets the catalog part parameter by name.
ParamCount | Gets the count of parameters in the catalog part.
PartFamilyGuid | Gets the guid of the part family this size filter belongs to


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Members
Legend
Legend
Property
public


StructureRuleSetStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class > StructureRuleSetStyleCollection Members
StructureRuleSetStyleCollection Members Public Methods
StructureRuleSetStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class > StructureRuleSetStyleCollection Members
Legend
Legend
Method
public
virtual


StructureRuleSetStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class > StructureRuleSetStyleCollection Members
StructureRuleSetStyleCollection Members Public Properties
StructureRuleSetStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class > StructureRuleSetStyleCollection Members
Legend
Legend
Property
public


StructureStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Members
StructureStyle Members Public Methods
StructureStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that defines the Model style.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified StructureDisplayStylePlanType value.
GetDisplayStyleProfile | Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified StructureDisplayStyleProfileType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified StructureDisplayStyleSectionType value.
GetHatchStylePlan | Gets the HatchDisplayStyle object that defines the Plan style.
GetHatchStyleProfile | Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified StructureHatchStyleProfileType value.
GetHatchStyleSection | Gets the HatchDisplayStyle object that defines the Section style.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Members
Legend
Legend
Method
public
virtual


StructureStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Members
StructureStyle Members Public Properties
StructureStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModelOption | Gets the object that defines the appearance of the Structure in a model view.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
PlanOption | Gets the object that defines the appearance of the Structure in a 2D plan view.
ProfileOption | Gets the object that defines the appearance of the Structure in a profile view.
SectionOption | Gets the object that defines the appearance of the Structure in a section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Members
Legend
Legend
Property
public


StructureStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class > StructureStyleCollection Members
StructureStyleCollection Members Public Methods
StructureStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class > StructureStyleCollection Members
Legend
Legend
Method
public
virtual


StructureStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class > StructureStyleCollection Members
StructureStyleCollection Members Public Properties
StructureStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class > StructureStyleCollection Members
Legend
Legend
Property
public


StructureStyleModelOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class > StructureStyleModelOption Members
StructureStyleModelOption Members Public Properties
StructureStyleModelOption Members
Public Properties
Public Property | Description
ModelViewOptions | Gets or sets the enum value that indicates whether the 3D object composed in the parts catalog should be used... more
SimpleSolidType | When ModelViewOptions is defined as Simple3dPart, the 3D object composed in the parts catalog is ignored and the structure is... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class > StructureStyleModelOption Members
Legend
Legend
Property
public


StructureStyleOptionBase Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Members
StructureStyleOptionBase Members Public Properties
StructureStyleOptionBase Members
Public Properties
Public Property | Description
BlockInsertLocation | Gets or sets the insertion point to use for the block displayed in profile/section view.
MaskConnectedObjects | Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in profile/section... more
SizeType | Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure... more
SymbolBlockName | Gets or sets the name of the block reference to use when displaying in profile/section view.
SymbolBlockXScale | Gets or sets the x scale to use when displaying with a block reference in profile/section view.
SymbolBlockYScale | Gets or sets the y scale to use when displaying with a block reference in profile/section view.
SymbolBlockZScale | Gets or sets the z scale to use when displaying with a block reference in profile/section view.
ViewOptions | Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as... more
XSize | Gets or sets the absolute X-dimension size of the block to display in profile/section view.
XSizePercent | Gets or sets the percentage of the screensize (X-dimension) for the block to display in profile/section view.
YSize | Gets or sets the absolute Y-dimension size of the block to display in profile/section view.
YSizePercent | Gets or sets the percentage of the screensize (Y-dimension) for the block to display in profile/section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Members
Legend
Legend
Property
public


StructureStylePlanOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Members
StructureStylePlanOption Members Public Properties
StructureStylePlanOption Members
Public Properties
Public Property | Description
MaskConnectedObjects | Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in plan... more
PlanViewOptions | Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as... more
Size | Gets or sets the absolute size of the block to display in plan view, if the SizeType is specified as... more
SizePercent | Gets or sets the percent of screen to use when sizing the block displayed in plan view, if SizeType is... more
SizeType | Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure... more
SymbolBlockName | Gets or sets the name of the block reference to use when displaying in plan view.
SymbolBlockXScale | Gets or sets the X scale to use when displaying with a block reference in plan view.
SymbolBlockYScale | Gets or sets the Y scale to use when displaying with a block reference in plan view.
SymbolBlockZScale | Gets or sets the Z scale to use when displaying with a block reference in plan view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Members
Legend
Legend
Property
public


SettingsCmdAddNetworkPipeTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Members
SettingsCmdAddNetworkPipeTable Members Classes
SettingsCmdAddNetworkPipeTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Members
Legend
Legend
Class


SettingsCmdAddNetworkPipeTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Members
SettingsCmdAddNetworkPipeTable Members Public Properties
SettingsCmdAddNetworkPipeTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TableCreation | Gets the defaults when you add a network pipe table.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Members
Legend
Legend
Property
public


SettingsCmdAddNetworkPipeTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Members
SettingsCmdAddNetworkPipeTable Members Templates
SettingsCmdAddNetworkPipeTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Members
Legend
Legend
Template


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members Public Properties
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Gets the maximum number of rows to include per section.
MaximumTablesPerStack | Gets the maximum number of sections to include in each stack.
SplitTable | Gets whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Gets the spacing between tables.
TableStyle | Gets the style for a table.
TileDirection | Gets the direction in which the table tiles (across or down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddNetworkStructTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Members
SettingsCmdAddNetworkStructTable Members Classes
SettingsCmdAddNetworkStructTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Members
Legend
Legend
Class


SettingsCmdAddNetworkStructTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Members
SettingsCmdAddNetworkStructTable Members Public Properties
SettingsCmdAddNetworkStructTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TableCreation | Gets the defaults when you add a network structure table.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Members
Legend
Legend
Property
public


SettingsCmdAddNetworkStructTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Members
SettingsCmdAddNetworkStructTable Members Templates
SettingsCmdAddNetworkStructTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Members
Legend
Legend
Template


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members Public Properties
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Gets the maximum number of rows to include per section.
MaximumTablesPerStack | Gets the maximum number of sections to include in each stack.
SplitTable | Gets whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Gets the spacing between tables.
TableStyle | Gets the style for a table.
TileDirection | Gets the direction in which the table tiles (across or down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdCreateAlignFromNetwork Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Members
SettingsCmdCreateAlignFromNetwork Members Classes
SettingsCmdCreateAlignFromNetwork Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Members
Legend
Legend
Class


SettingsCmdCreateAlignFromNetwork Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Members
SettingsCmdCreateAlignFromNetwork Members Public Properties
SettingsCmdCreateAlignFromNetwork Members
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the alignment type options.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Members
Legend
Legend
Property
public


SettingsCmdCreateAlignFromNetwork Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Members
SettingsCmdCreateAlignFromNetwork Members Templates
SettingsCmdCreateAlignFromNetwork Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Members
Legend
Legend
Template


SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members Public Properties
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members
Public Properties
Public Property | Description
AlignmentType | Specifies the alignment type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Members
Legend
Legend
Property
public


SettingsCmdCreateInterferenceCheck Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Members
SettingsCmdCreateInterferenceCheck Members Classes
SettingsCmdCreateInterferenceCheck Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Members
Legend
Legend
Class


SettingsCmdCreateInterferenceCheck Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Members
SettingsCmdCreateInterferenceCheck Members Public Properties
SettingsCmdCreateInterferenceCheck Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
InterferenceCriteria | Gets the default interference criteria.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Members
Legend
Legend
Property
public


SettingsCmdCreateInterferenceCheck Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Members
SettingsCmdCreateInterferenceCheck Members Templates
SettingsCmdCreateInterferenceCheck Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Members
Legend
Legend
Template


SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members Public Properties
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members
Public Properties
Public Property | Description
Apply3DProximityCheck | Gets whether apply 3d proximity check.
Distance | Gets the tolerance distance value for interference check.
ScaleFactor | Gets the scale factor for scaling each network part for performing the interference check.
UseDistanceOrScaleFactor | Gets the selection of distance or scale factor to perform the 3D proximity check.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Members
Legend
Legend
Property
public


SettingsCmdCreateNetwork Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Members
SettingsCmdCreateNetwork Members Classes
SettingsCmdCreateNetwork Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Members
Legend
Legend
Class


SettingsCmdCreateNetwork Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Members
SettingsCmdCreateNetwork Members Public Properties
SettingsCmdCreateNetwork Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
DefaultLayoutCommand | Gets the default layout command type.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LabelNewParts | Gets the default labeling when you add parts to a network.
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Members
Legend
Legend
Property
public


SettingsCmdCreateNetwork Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Members
SettingsCmdCreateNetwork Members Templates
SettingsCmdCreateNetwork Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Members
Legend
Legend
Template


SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members Public Properties
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members
Public Properties
Public Property | Description
PipeInPlan | Gets whether a new pipe is labeled by default when placed in plan view.
PipeProfile | Gets whether a new pipe is labeled by default when placed in profile view.
StructureInPlan | Gets whether a new structure is labeled by default when placed in plan view.
StructureProfile | Gets whether a new structure is labeled by default when placed in profile view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Members
Legend
Legend
Property
public


SettingsPipeNetwork Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Members
SettingsPipeNetwork Members Classes
SettingsPipeNetwork Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Members
Legend
Legend
Class


SettingsPipeNetwork Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Members
SettingsPipeNetwork Members Public Properties
SettingsPipeNetwork Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Members
Legend
Legend
Property
public


SettingsPipeNetwork Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Members
SettingsPipeNetwork Members Templates
SettingsPipeNetwork Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Members
Legend
Legend
Template


SettingsPipeNetwork::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Members
SettingsPipeNetwork::SettingsNameFormat Members Public Properties
SettingsPipeNetwork::SettingsNameFormat Members
Public Properties
Public Property | Description
AlignmentFromNetwork | Settings for PipeNetwork AlignmentFromNetwork name format .
Interference | Settings for PipeNetwork Interference name format .
InterferenceCheck | Settings for PipeNetwork InterferenceCheck name format .
Network | Settings for PipeNetwork Network name format .
Pipe | Settings for PipeNetwork Pipe name format .
Structure | Settings for PipeNetwork Structure name format .


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsProfileLabelPlacement Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Members
SettingsPipeNetwork::SettingsProfileLabelPlacement Members Public Properties
SettingsPipeNetwork::SettingsProfileLabelPlacement Members
Public Properties
Public Property | Description
DimensionAnchorElevationValueForPipes | Specifies the default elevation of the dimension line anchor for profile view labels for pipes.
DimensionAnchorElevationValueForStructures | Specifies the default elevation of the dimension line anchor for profile view labels for structures.
DimensionAnchorOptionForPipes | Specifies the location of the dimension line anchor for profile view labels for pipes.
DimensionAnchorOptionForStructures | Specifies the location of the dimension line anchor for profile view labels for structures.
DimensionAnchorPlotHeightValueForPipes | Specifies the default plot height of the dimension line anchor for profile view labels for pipes.
DimensionAnchorPlotHeightValueForStructures | Specifies the default plot height of the dimension line anchor for profile view labels for structures.
StructureLabelPlacement | Specifies the default location of structure labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Members
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsRules Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class > SettingsPipeNetwork::SettingsRules Members
SettingsPipeNetwork::SettingsRules Members Public Properties
SettingsPipeNetwork::SettingsRules Members
Public Properties
Public Property | Description
Pipe | Specifies the default rule set assigned to pipes.
Structure | Specifies the default rule set assigned to structures.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class > SettingsPipeNetwork::SettingsRules Members
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsSectionLabelPlacement Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Members
SettingsPipeNetwork::SettingsSectionLabelPlacement Members Public Properties
SettingsPipeNetwork::SettingsSectionLabelPlacement Members
Public Properties
Public Property | Description
DimensionAnchorElevationValueForPipes | Specifies the default elevation of the dimension line anchor for section view labels for pipes.
DimensionAnchorElevationValueForStructures | Specifies the default elevation of the dimension line anchor for section view labels for structures.
DimensionAnchorOptionForPipes | Specifies the location of the dimension line anchor for section view labels for pipes.
DimensionAnchorOptionForStructures | Specifies the location of the dimension line anchor for section view labels for structures.
DimensionAnchorPlotHeightValueForPipes | Specifies the default plot height of the dimension line anchor for section view labels for pipes.
DimensionAnchorPlotHeightValueForStructures | Specifies the default plot height of the dimension line anchor for section view labels for structures.
PipeSectionLabel | Specifies the default location of pipe labels displayed in section views.
StructureLabelPlacement | Specifies the default location of structure labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Members
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsStormSewersMigration Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class > SettingsPipeNetwork::SettingsStormSewersMigration Members
SettingsPipeNetwork::SettingsStormSewersMigration Members Public Properties
SettingsPipeNetwork::SettingsStormSewersMigration Members
Public Properties
Public Property | Description
PartMatching | Specifies the defaults used for part matching when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil... more
PartsListUsedForMigration | Specifies the default parts list assigned when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil 3D.... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class > SettingsPipeNetwork::SettingsStormSewersMigration Members
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Members
SettingsPipeNetwork::SettingsStyles Members Public Properties
SettingsPipeNetwork::SettingsStyles Members
Public Properties
Public Property | Description
Interference | Specifies the default style for interference in the pipe network.
InterferenceRenderMaterial | Specifies the default interference render material in the pipe network.
PartsList | Specifies the default parts list for the pipe network.
Pipe | Specifies the default style for pipes in the pipe network.
PipePlanLabel | Specifies the default style for pipe labels that are displayed in plan view.
PipeProfileLabel | Specifies the default style for pipe labels that are displayed in profile view.
PipeSectionLabel | Specifies the default style for pipe labels that are displayed in section view.
RenderMaterial | Specifies the default render material in the pipe network.
Structure | Specifies the default style for structures in the pipe network.
StructurePlanLabel | Specifies the default style for structure labels that are displayed in plan view.
StructureProfileLabel | Specifies the default style for structure labels that are displayed in a profile view.
StructureSectionLabel | Specifies the default style for structure labels that are displayed in a section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Members
Legend
Legend
Property
public


PropertyAnchorPoint Members Public Properties
PropertyAnchorPoint Members
Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyAnchorPoint.


PropertyAngle Members Public Properties
PropertyAngle Members
Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyAngle.


PropertyBlock Members Public Properties
PropertyBlock Members
Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyBlock.


PropertyEnum Members Public Properties
PropertyEnum Members
Public Properties
Public Property | Description
Value | Gets or sets the property value.


PropertyObjectName Members Public Properties
PropertyObjectName Members
Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyObjectName.


QTOUtility Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Members
QTOUtility Members Public Methods
QTOUtility Members
Public Methods
Public Method | Description
AddPayItemId | Adds a pay item id.
DeleteAllPayItemsIds | Deletes all pay item information from the specified object.
DeletePayItemIds | Deletes the pay item ids in the collection from the specified object.
GetPayItemIds | Gets a string collection of pay items ids for the specified object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Members
Legend
Legend
Method
public


AppliedAssembly Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Members
AppliedAssembly Members Public Methods
AppliedAssembly Members
Public Methods
Public Method | Description
GetAppliedSubassemblies | Gets the collection of AppliedAssemblies in this AppliedAssembly.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Members
Legend
Legend
Method
public


AppliedAssembly Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Members
AppliedAssembly Members Public Nested Types
AppliedAssembly Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssembly::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Members
Legend
Legend
public


AppliedAssembly Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Members
AppliedAssembly Members Public Properties
AppliedAssembly Members
Public Properties
Public Property | Description
AssemblyId | Gets the ID of this AppliedAssembly.
CorridorId | Gets the parent Corridor Id.
Links | Gets the collection of CalculatedLinks in this AppliedAssembly.
LinksByCode | Gets the collection of CalculatedLinks in this AppliedAssembly that have a particular code.
Points | Gets the collection of CalculatedPoints in this AppliedAssembly.
PointsByCode | Gets the collection of CalculatedPoints in this AppliedAssembly that have a particular code.
Shapes | Gets the collection of CalculatedShapes in this AppliedAssembly.
ShapesByCode | Gets the collection of CalculatedShapes in this AppliedAssembly that have a particular code.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Members
Legend
Legend
Property
public


AppliedAssemblyCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Members
AppliedAssemblyCollection Members Public Methods
AppliedAssemblyCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetItemAt | Gets the AppliedAssembly object nearest the specified station.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Stations | Gets a list of stations in the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Members
Legend
Legend
Method
public
virtual


AppliedAssemblyCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Members
AppliedAssemblyCollection Members Public Nested Types
AppliedAssemblyCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssemblyCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Members
Legend
Legend
public


AppliedAssemblyCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Members
AppliedAssemblyCollection Members Public Properties
AppliedAssemblyCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of AppliedAssembly objects in the collection.
default | Gets the default AppliedAssembly object from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Members
Legend
Legend
Property
public


AppliedSubassembly Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Members
AppliedSubassembly Members Public Nested Types
AppliedSubassembly Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassembly::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Members
Legend
Legend
public


AppliedSubassembly Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Members
AppliedSubassembly Members Public Properties
AppliedSubassembly Members
Public Properties
Public Property | Description
BaselineHookedTo | Gets the hooked Baseline.
CorridorId | Gets the ID of the parent Corridor object.
Links | Gets the collection of CalculatedLinks in this AppliedSubssembly.
OriginStationOffsetElevationToBaseline | Gets the origin SOE coordinate to Baseline.
Points | Gets the collection of CalculatedPoints in this AppliedSubssembly.
Shapes | Gets the collection of CalculatedShapes in this AppliedSubssembly.
SubassemblyId | Gets the ID of this AppliedSubassembly.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Members
Legend
Legend
Property
public


AppliedSubassemblyCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Members
AppliedSubassemblyCollection Members Public Methods
AppliedSubassemblyCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
ObjectIds | Gets an array of AppliedSubassemblies' ObjectIds.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Members
Legend
Legend
Method
public
virtual


AppliedSubassemblyCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Members
AppliedSubassemblyCollection Members Public Nested Types
AppliedSubassemblyCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassemblyCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Members
Legend
Legend
public


AppliedSubassemblyCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Members
AppliedSubassemblyCollection Members Public Properties
AppliedSubassemblyCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of AppliedSubassembly objects in the collection.
default | Gets the defaul AppliedSubassembly object from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Members
Legend
Legend
Property
public


Assembly Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Members
Assembly Members Public Methods
Assembly Members
Public Methods
Public Method | Description
GetOffsetBaselineNames | Gets an array of names of associated offset baselines.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Members
Legend
Legend
Method
public


Assembly Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Members
Assembly Members Public Properties
Assembly Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
CodeSetStyleName | Gets or sets the CodeSetStyle by name.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Members
Legend
Legend
Property
public


AssemblyCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Members
AssemblyCollection Members Public Methods
AssemblyCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Members
Legend
Legend
Method
public
virtual


AssemblyCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Members
AssemblyCollection Members Public Properties
AssemblyCollection Members
Public Properties
Public Property | Description
Count | Gets the number of Assembly objects in the collection.
default | Gets an Assembly by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Members
Legend
Legend
Property
public


BaseBaseline Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Members
BaseBaseline Members Public Methods
BaseBaseline Members
Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Members
Legend
Legend
Method
public
abstract
virtual


BaseBaseline Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Members
BaseBaseline Members Public Properties
BaseBaseline Members
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
StartStation | Gets the starting station for this baseline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Members
Legend
Legend
Property
public


Baseline Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Members
Baseline Members Public Methods
Baseline Members
Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Members
Legend
Legend
Method
public
virtual


Baseline Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Members
Baseline Members Public Nested Types
Baseline Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::Baseline::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Members
Legend
Legend
public


Baseline Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Members
Baseline Members Public Properties
Baseline Members
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
AppliedAssembly | Gets the AppliedAssembly by station.
BaselineRegions | Gets the collection of BaselineRegion objects in this Baseline.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
IsProcessed | Gets whether this Baseline is built during corridor rebuild.
MainBaselineFeatureLines | Gets the main baseline FeatureLine collection.
OffsetBaselineFeatureLinesCol | Gets the offset baseline FeatureLine collection.
ProfileId | Gets the ID of the Profile this baseline is associated with.
StartStation | Gets the starting station for this baseline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Members
Legend
Legend
Property
public


BaselineCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Members
BaselineCollection Members Public Methods
BaselineCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Members
Legend
Legend
Method
public
virtual


BaselineCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Members
BaselineCollection Members Public Properties
BaselineCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of Baseline objects in the collection.
default | Gets a Baseline by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Members
Legend
Legend
Property
public


BaselineFeatureLines Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Members
BaselineFeatureLines Members Public Methods
BaselineFeatureLines Members
Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Members
Legend
Legend
Method
public


BaselineFeatureLines Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Members
BaselineFeatureLines Members Public Nested Types
BaselineFeatureLines Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLines::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Members
Legend
Legend
public


BaselineFeatureLines Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Members
BaselineFeatureLines Members Public Properties
BaselineFeatureLines Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
FeatureLineCollectionMap | Gets the collection of feature lines (FeatureLinesCollection).
HardcodedOffsetBaselineName | Gets the hardcoded offset baseline name.
IsMainBaseline | Returns True if this is a main baseline.
OffsetAlignmentId | Gets the ObjectId for the offset alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Members
Legend
Legend
Property
public


BaselineFeatureLinesCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Members
BaselineFeatureLinesCollection Members Public Methods
BaselineFeatureLinesCollection Members
Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Members
Legend
Legend
Method
public
virtual


BaselineFeatureLinesCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Members
BaselineFeatureLinesCollection Members Public Nested Types
BaselineFeatureLinesCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLinesCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Members
Legend
Legend
public


BaselineFeatureLinesCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Members
BaselineFeatureLinesCollection Members Public Properties
BaselineFeatureLinesCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of BaselineFeatureLines objects in the collection.
default | Gets a BaselineFeatureLines object by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Members
Legend
Legend
Property
public


BaselineRegion Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Members
BaselineRegion Members Public Methods
BaselineRegion Members
Public Methods
Public Method | Description
AddStation | Adds a station to the BaselineRegion.
DeleteStation | Removes a station from the BaselineRegion.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Members
Legend
Legend
Method
public


BaselineRegion Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Members
BaselineRegion Members Public Nested Types
BaselineRegion Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegion::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Members
Legend
Legend
public


BaselineRegion Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Members
BaselineRegion Members Public Properties
BaselineRegion Members
Public Properties
Public Property | Description
AppliedAssemblies | Gets the collection of AppliedAssembly objects associated with this BaselineRegion.
AssemblyId | Gets the ObjectId of the Assembly associated with this BaselineRegion.
CorridorId | Gets the ObjectId of the Corridor this BaselineRegion is associated with.
EndStation | Gets the number of the end station for this BaselineRegion.
IsProcessed | Gets whether this BaselineRegion is processed.
OffsetBaselines | Gets the collection of OffsetBaseline objects associated with this BaselineRegion.
StartStation | Gets the number of the start station for this BaselineRegion.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Members
Legend
Legend
Property
public


BaselineRegionCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Members
BaselineRegionCollection Members Public Methods
BaselineRegionCollection Members
Public Methods
Public Method | Description
AddRegion | Overloaded
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Members
Legend
Legend
Method
public
virtual


BaselineRegionCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Members
BaselineRegionCollection Members Public Nested Types
BaselineRegionCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegionCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Members
Legend
Legend
public


BaselineRegionCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Members
BaselineRegionCollection Members Public Properties
BaselineRegionCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLines BaselineRegion in the collection.
default | Gets a BaselineRegion object by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Members
Legend
Legend
Property
public


CalculatedLink Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Members
CalculatedLink Members Public Nested Types
CalculatedLink Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLink::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Members
Legend
Legend
public


CalculatedLink Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Members
CalculatedLink Members Public Properties
CalculatedLink Members
Public Properties
Public Property | Description
CalculatedPoints | Gets the collection of CalculatedPoints associated with the CalculatedLink.
CorridorCodes | Gets the collection of codes associated with the CalculatedLink.
CorridorId | Gets the ObjectId of the parent Corridor.
DrawOverride | Gets the draw override type of the CalculatedLink (CorridorLinkDrawOverride enumeration).
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Members
Legend
Legend
Property
public


CalculatedLinkCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Members
CalculatedLinkCollection Members Public Methods
CalculatedLinkCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Members
Legend
Legend
Method
public
virtual


CalculatedLinkCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Members
CalculatedLinkCollection Members Public Nested Types
CalculatedLinkCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLinkCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Members
Legend
Legend
public


CalculatedLinkCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Members
CalculatedLinkCollection Members Public Properties
CalculatedLinkCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CalculatedLink objects in this collection.
default | Gets the default CalculatedLink object from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Members
Legend
Legend
Property
public


CalculatedPoint Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Members
CalculatedPoint Members Public Nested Types
CalculatedPoint Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPoint::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Members
Legend
Legend
public


CalculatedPoint Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Members
CalculatedPoint Members Public Properties
CalculatedPoint Members
Public Properties
Public Property | Description
CorridorCodes | Gets the collection of codes associated with the CalculatedPoint.
CorridorId | Gets the ObjectId of the parent Corridor.
NormalToBaseline | Gets the normal to baseline vector.
NormalToSubassembly | Gets the normal to subassembly vector.
StationOffsetElevationToBaseline | Gets the Station (X), offset to baseline (Y) and elevation from baseline (Z) for the point.
StationOffsetElevationToSubassembly | Gets the Station (X), offset to subassembly (Y) and elevation from subassembly (Z) for the point.
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Members
Legend
Legend
Property
public


CalculatedPointCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Members
CalculatedPointCollection Members Public Methods
CalculatedPointCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Members
Legend
Legend
Method
public
virtual


CalculatedPointCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Members
CalculatedPointCollection Members Public Nested Types
CalculatedPointCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPointCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Members
Legend
Legend
public


CalculatedPointCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Members
CalculatedPointCollection Members Public Properties
CalculatedPointCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CalculatedPoint objects in the collection.
default | Gets a CalculatedPoint by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Members
Legend
Legend
Property
public


CalculatedShape Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Members
CalculatedShape Members Public Nested Types
CalculatedShape Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShape::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Members
Legend
Legend
public


CalculatedShape Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Members
CalculatedShape Members Public Properties
CalculatedShape Members
Public Properties
Public Property | Description
Area | Gets the area of the CalculatedShape.
CalculatedLinks | Gets the collection of links that make up the CalculatedShape.
CorridorCodes | Gets the collection of codes associated with the CalculatedShape.
CorridorId | Gets the ObjectId of the parent Corridor.
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Members
Legend
Legend
Property
public


CalculatedShapeCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Members
CalculatedShapeCollection Members Public Methods
CalculatedShapeCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Members
Legend
Legend
Method
public
virtual


CalculatedShapeCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Members
CalculatedShapeCollection Members Public Nested Types
CalculatedShapeCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShapeCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Members
Legend
Legend
public


CalculatedShapeCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Members
CalculatedShapeCollection Members Public Properties
CalculatedShapeCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CorridorSurfaceBoundary objects in the collection.
default | Gets a CalculatedShape by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Members
Legend
Legend
Property
public


CalculatedSubentity Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Members
CalculatedSubentity Members Public Nested Types
CalculatedSubentity Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Members
Legend
Legend
public


CalculatedSubentity Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Members
CalculatedSubentity Members Public Properties
CalculatedSubentity Members
Public Properties
Public Property | Description
CorridorCodes | Gets the collection of CorridorCode objects.
CorridorId | Gets the ObjectId of the parent Corridor.
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Members
Legend
Legend
Property
public


CodeCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Members
CodeCollection Members Public Methods
CodeCollection Members
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Remove | Remove the code from collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Members
Legend
Legend
Method
public
virtual


CodeCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Members
CodeCollection Members Public Nested Types
CodeCollection Members
Public Nested Types
Public Nested Type | Description
SubEntityType | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CodeCollection::SubEntityType.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Members
Legend
Legend
public


CodeCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Members
CodeCollection Members Public Properties
CodeCollection Members
Public Properties
Public Property | Description
Count | Get the count of code in the collection
default | Get a code in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Members
Legend
Legend
Property
public


Corridor Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Members
Corridor Members Public Methods
Corridor Members
Public Methods
Public Method | Description
Rebuild | Forces the corridor to rebuild.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Members
Legend
Legend
Method
public


Corridor Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Members
Corridor Members Public Properties
Corridor Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
Baselines | Gets the baselines collection for the corridor.
CodeSetStyleName | Gets or sets the corridor's code set style name.
CorridorSurfaces | Gets the surfaces collection for the corridor.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
FeatureLineCodeInfos | Gets the feature line code info collection for the corridor.
IsOutOfDate | Gets the corridor's out of date flag.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
MaximumTriangleSideLength | Gets or sets the corridor surface's maximum triangle side length.
Name | Gets or sets the Entity object's name.
RebuildAutomatic | Gets or sets the automatic rebuild mode for the corridor.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Members
Legend
Legend
Property
public


CorridorCodeCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Members
CorridorCodeCollection Members Public Methods
CorridorCodeCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implements the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Members
Legend
Legend
Method
public
virtual


CorridorCodeCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Members
CorridorCodeCollection Members Public Nested Types
CorridorCodeCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorCodeCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Members
Legend
Legend
public


CorridorCodeCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Members
CorridorCodeCollection Members Public Properties
CorridorCodeCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of Corridor code strings in the collection.
default | Gets a Corridor code string from the collection by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Members
Legend
Legend
Property
public


CorridorCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Members
CorridorCollection Members Public Methods
CorridorCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Members
Legend
Legend
Method
public
virtual


CorridorCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Members
CorridorCollection Members Public Properties
CorridorCollection Members
Public Properties
Public Property | Description
Count | Gets the number of Corridor objects in the collection.
default | Gets an Corridor by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Members
Legend
Legend
Property
public


CorridorSection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Members
CorridorSection Members Public Methods
CorridorSection Members
Public Methods
Public Method | Description
GetCorridor | Gets the ObjectId of the parent Corridor.
SetCorridor | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Members
Legend
Legend
Method
public


CorridorSection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Members
CorridorSection Members Public Properties
CorridorSection Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Members
Legend
Legend
Property
public


CorridorSurface Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Members
CorridorSurface Members Public Methods
CorridorSurface Members
Public Methods
Public Method | Description
FeatureLineCodeIsBreak | Gets the IsBreak value of the link code.
FeatureLineCodes | Gets the feature line codes used to construct the surface.
FindElevationAtXY | Finds the elevation of the surface at the specified XY location.
GetSampleElevations | Gets the collection of sample elevations.
LinkCodes | Gets the link codes used to construct the surface.
PointCodes | Gets the point codes used to construct the surface.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Members
Legend
Legend
Method
public


CorridorSurface Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Members
CorridorSurface Members Public Nested Types
CorridorSurface Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurface::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Members
Legend
Legend
public


CorridorSurface Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Members
CorridorSurface Members Public Properties
CorridorSurface Members
Public Properties
Public Property | Description
Boundaries | Gets the collection of surface boundaries.
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description for the CorridorSurface.
IsBuild | Returns true if the CorridorSurface is built.
IsDraw | Returns true if the CorridorSurface is drawn.
Masks | Gets the collection of surface masks.
Name | Gets the name of the CorridorSurface.
SectionStyleId | Gets the ID of the SectionStyle.
SurfaceStyleId | Gets the ID of the SurfaceStyle.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Members
Legend
Legend
Property
public


CorridorSurfaceBaseMask Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Members
CorridorSurfaceBaseMask Members Public Methods
CorridorSurfaceBaseMask Members
Public Methods
Public Method | Description
PolygonPoints | Gets the points of the polygon that make up the edge of the boundary or mask.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Members
Legend
Legend
Method
public


CorridorSurfaceBaseMask Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Members
CorridorSurfaceBaseMask Members Public Nested Types
CorridorSurfaceBaseMask Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Members
Legend
Legend
public


CorridorSurfaceBaseMask Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Members
CorridorSurfaceBaseMask Members Public Properties
CorridorSurfaceBaseMask Members
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description.
FeatureLineComponents | Gets the collection of feature line components that make up the edge, if the border was originally defined by selecting... more
Name | Gets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Members
Legend
Legend
Property
public


CorridorSurfaceBoundary Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Members
CorridorSurfaceBoundary Members Public Methods
CorridorSurfaceBoundary Members
Public Methods
Public Method | Description
PolygonPoints | Gets the points of the polygon that make up the edge of the boundary or mask.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Members
Legend
Legend
Method
public


CorridorSurfaceBoundary Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Members
CorridorSurfaceBoundary Members Public Nested Types
CorridorSurfaceBoundary Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Members
Legend
Legend
public


CorridorSurfaceBoundary Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Members
CorridorSurfaceBoundary Members Public Properties
CorridorSurfaceBoundary Members
Public Properties
Public Property | Description
BoundaryType | Gets the surface boundary type.
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description.
FeatureLineComponents | Gets the collection of feature line components that make up the edge, if the border was originally defined by selecting... more
Name | Gets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Members
Legend
Legend
Property
public


CorridorSurfaceBoundaryCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Members
CorridorSurfaceBoundaryCollection Members Public Methods
CorridorSurfaceBoundaryCollection Members
Public Methods
Public Method | Description
BoundaryNames | Gets an array of boundary names.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Members
Legend
Legend
Method
public
virtual


CorridorSurfaceBoundaryCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Members
CorridorSurfaceBoundaryCollection Members Public Nested Types
CorridorSurfaceBoundaryCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Members
Legend
Legend
public


CorridorSurfaceBoundaryCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Members
CorridorSurfaceBoundaryCollection Members Public Properties
CorridorSurfaceBoundaryCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CorridorSurfaceBoundary objects in the collection.
default | Gets a CorridorSurfaceBoundary by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Members
Legend
Legend
Property
public


CorridorSurfaceCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Members
CorridorSurfaceCollection Members Public Methods
CorridorSurfaceCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
SurfaceNames | Gets an array of surface names from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Members
Legend
Legend
Method
public
virtual


CorridorSurfaceCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Members
CorridorSurfaceCollection Members Public Properties
CorridorSurfaceCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CorridorSurface objects in the collection.
default | Gets a CorridorSurface by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Members
Legend
Legend
Property
public


CorridorSurfaceMaskCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Members
CorridorSurfaceMaskCollection Members Public Methods
CorridorSurfaceMaskCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
MaskNames | Gets an array of mask names.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Members
Legend
Legend
Method
public
virtual


CorridorSurfaceMaskCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Members
CorridorSurfaceMaskCollection Members Public Nested Types
CorridorSurfaceMaskCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMaskCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Members
Legend
Legend
public


CorridorSurfaceMaskCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Members
CorridorSurfaceMaskCollection Members Public Properties
CorridorSurfaceMaskCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CorridorSurfaceMask objects in the collection.
default | Gets a CorridorSurfaceMask object by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Members
Legend
Legend
Property
public


FeatureLine Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Members
FeatureLine Members Public Nested Types
FeatureLine Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLine::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Members
Legend
Legend
public


FeatureLine Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Members
FeatureLine Members Public Properties
FeatureLine Members
Public Properties
Public Property | Description
CodeName | Gets the code name used to construct the feature line.
CorridorId | Gets the ObjectId of the parent Corridor.
FeatureLinePoints | Gets the collection of all points that make up the feature line.
StyleId | Gets or Sets the FeatureLine's style Id.
StyleName | Gets or Sets the FeatureLine's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Members
Legend
Legend
Property
public


FeatureLineCodeInfo Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Members
FeatureLineCodeInfo Members Public Nested Types
FeatureLineCodeInfo Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfo::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Members
Legend
Legend
public


FeatureLineCodeInfo Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Members
FeatureLineCodeInfo Members Public Properties
FeatureLineCodeInfo Members
Public Properties
Public Property | Description
CodeName | Gets the code name.
CorridorId | Gets the ID of the parent Corridor.
IsConnect | Returns True if the feature line connects to multiple points in the same applied assembly if those points share the... more
IsDraw | Returns true if the feature line is drawn.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Members
Legend
Legend
Property
public


FeatureLineCodeInfoCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Members
FeatureLineCodeInfoCollection Members Public Methods
FeatureLineCodeInfoCollection Members
Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Members
Legend
Legend
Method
public
virtual


FeatureLineCodeInfoCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Members
FeatureLineCodeInfoCollection Members Public Properties
FeatureLineCodeInfoCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineCodeInfo objects in the collection.
default | Gets a FeatureLineCodeInfo by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Members
Legend
Legend
Property
public


FeatureLineCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Members
FeatureLineCollection Members Public Methods
FeatureLineCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Members
Legend
Legend
Method
public
virtual


FeatureLineCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Members
FeatureLineCollection Members Public Nested Types
FeatureLineCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Members
Legend
Legend
public


FeatureLineCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Members
FeatureLineCollection Members Public Properties
FeatureLineCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of FeatureLine objects in this collection.
default | Gets the default FeatureLine object in this collection.
FeatureLineCodeInfo | Gets the object that contains information about the code used to construct the FeatureLine.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Members
Legend
Legend
Property
public


FeatureLineCollectionMap Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Members
FeatureLineCollectionMap Members Public Methods
FeatureLineCollectionMap Members
Public Methods
Public Method | Description
CodeNames | Gets an array of code names used in all feature lines in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Members
Legend
Legend
Method
public
virtual


FeatureLineCollectionMap Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Members
FeatureLineCollectionMap Members Public Nested Types
FeatureLineCollectionMap Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollectionMap::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Members
Legend
Legend
public


FeatureLineCollectionMap Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Members
FeatureLineCollectionMap Members Public Properties
FeatureLineCollectionMap Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineCollection objects in the collection.
default | Gets a FeatureLineCollection from the collection by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Members
Legend
Legend
Property
public


FeatureLineComponent Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Members
FeatureLineComponent Members Public Nested Types
FeatureLineComponent Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponent::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Members
Legend
Legend
public


FeatureLineComponent Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Members
FeatureLineComponent Members Public Properties
FeatureLineComponent Members
Public Properties
Public Property | Description
CorridorId | Gets the parent Corridor Id.
EndStation | Gets the end station.
FeatureLine | Gets the parent FeatureLine object.
IsReversed | Returns True if the station values have been reversed.
StartStation | Gets the start station.
UseEndStation | Returns true if the end station is used.
UseStartStation | Returns true if the start station is used.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Members
Legend
Legend
Property
public


FeatureLineComponentCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Members
FeatureLineComponentCollection Members Public Methods
FeatureLineComponentCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Members
Legend
Legend
Method
public
virtual


FeatureLineComponentCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Members
FeatureLineComponentCollection Members Public Nested Types
FeatureLineComponentCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponentCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Members
Legend
Legend
public


FeatureLineComponentCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Members
FeatureLineComponentCollection Members Public Properties
FeatureLineComponentCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineComponent objects in the collection.
default | Gets a FeatureLineComponent by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Members
Legend
Legend
Property
public


FeatureLinePoint Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Members
FeatureLinePoint Members Public Nested Types
FeatureLinePoint Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePoint::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Members
Legend
Legend
public


FeatureLinePoint Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Members
FeatureLinePoint Members Public Properties
FeatureLinePoint Members
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
IsBreak | Gets the IsBreak value of this point.
Station | Gets the station of the assembly containing this point.
XYZ | Gets the coordinates of this point.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Members
Legend
Legend
Property
public


FeatureLinePointCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Members
FeatureLinePointCollection Members Public Methods
FeatureLinePointCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Members
Legend
Legend
Method
public
virtual


FeatureLinePointCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Members
FeatureLinePointCollection Members Public Nested Types
FeatureLinePointCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePointCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Members
Legend
Legend
public


FeatureLinePointCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Members
FeatureLinePointCollection Members Public Properties
FeatureLinePointCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLinePoint objects in the collection.
default | Gets a FeatureLinePoint by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Members
Legend
Legend
Property
public


HardcodedOffsetBaseline Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Members
HardcodedOffsetBaseline Members Public Methods
HardcodedOffsetBaseline Members
Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Members
Legend
Legend
Method
public
virtual


HardcodedOffsetBaseline Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Members
HardcodedOffsetBaseline Members Public Nested Types
HardcodedOffsetBaseline Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::HardcodedOffsetBaseline::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Members
Legend
Legend
public


HardcodedOffsetBaseline Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Members
HardcodedOffsetBaseline Members Public Properties
HardcodedOffsetBaseline Members
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
Name | Gets the name of the HardcodedOffsetBaseline.
OffsetElevationFromMainBaseline | Gets the offset elevation from the main Baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
RelatedOffsetBaselineFeatureLines | Gets related offset baseline featurelines.
StartStation | Gets the starting station for this baseline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Members
Legend
Legend
Property
public


Intersection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Members
Intersection Members Public Properties
Intersection Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
CorridorId | Gets or sets the object id of the corresponding corridor.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GradeRuleType | Gets or sets the grade rule type.
IntersectionRegions | Gets the regions of this Intersection.
IntersectionRoads | Gets the roads of this Intersection.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Location | Gets the location of the intersection.
Name | Gets or sets the Entity object's name.
RoadwayDrivingDirection | Gets or sets the direction of roadway driving.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Members
Legend
Legend
Property
public


IntersectionRegion Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Members
IntersectionRegion Members Public Properties
IntersectionRegion Members
Public Properties
Public Property | Description
Angle | Gets the angle.
CurbReturnAlignmentId | Gets the object id of curb return alignment.
CurbReturnProfileId | Gets the object id of curb return profile.
InAlignmentId | Gets the in alignment.
Name | Gets or sets the name of region.
OutAlignmentId | Gets the out alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Members
Legend
Legend
Property
public


IntersectionRegionCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Members
IntersectionRegionCollection Members Public Methods
IntersectionRegionCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Members
Legend
Legend
Method
public
virtual


IntersectionRegionCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Members
IntersectionRegionCollection Members Public Properties
IntersectionRegionCollection Members
Public Properties
Public Property | Description
Count | Gets the number of IntersectionRegion objects in the collection.
default | Gets the IntersectionRegion object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Members
Legend
Legend
Property
public


IntersectionRoad Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Members
IntersectionRoad Members Public Properties
IntersectionRoad Members
Public Properties
Public Property | Description
CenterlineAlignmentId | Gets the object id of Centerline alignment.
CenterlineProfileId | Gets the object id of Centerline profile.
OffsetLeftAlignmentId | Gets the object id of left offset alignment.
OffsetLeftProfileId | Gets the object id of left offset profile.
OffsetRightAlignmentId | Gets the object id of right offset alignment.
OffsetRightProfileId | Gets the object id of right offset profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Members
Legend
Legend
Property
public


IntersectionRoadCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Members
IntersectionRoadCollection Members Public Methods
IntersectionRoadCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Members
Legend
Legend
Method
public
virtual


IntersectionRoadCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Members
IntersectionRoadCollection Members Public Properties
IntersectionRoadCollection Members
Public Properties
Public Property | Description
Count | Gets the number of IntersectionRoad objects in the collection.
default | Gets the IntersectionRoad object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Members
Legend
Legend
Property
public


IPoint Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Members
IPoint Members Public Properties
IPoint Members
Public Properties
Public Property | Description
Codes | Gets the roadway codes.
Elevation | Gets or sets the point elevation.
Index | Gets the point index.
Offset | Gets or sets the point offset.
Station | Gets or sets the point station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Members
Legend
Legend
Property
public


Link Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Members
Link Members Public Properties
Link Members
Public Properties
Public Property | Description
Codes | Get the Corridor codes of a Link.
Index | Get the index of the link.
IsHidden | Gets or sets the boolean value that specifies if the link will be drawn.
Points | Gets the points collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Members
Legend
Legend
Property
public


LinkCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Members
LinkCollection Members Public Methods
LinkCollection Members
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Members
Legend
Legend
Method
public
virtual


LinkCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Members
LinkCollection Members Public Properties
LinkCollection Members
Public Properties
Public Property | Description
Count | Gets the number of links in the collection.
default | Gets a link from the collection by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Members
Legend
Legend
Property
public


OffsetBaseline Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Members
OffsetBaseline Members Public Methods
OffsetBaseline Members
Public Methods
Public Method | Description
GetOffsetElevationFromMainBaselineStation | Gets the offset at a station from main baseline.
MainBaselineStationToOffsetBaselineStation | Transforms the Main Baseline station to an offset Baseline station.
OffsetBaselineStationToMainBaselineStation | Transforms the offset Baseline station to Main Baseline station.
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Members
Legend
Legend
Method
public
virtual


OffsetBaseline Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Members
OffsetBaseline Members Public Nested Types
OffsetBaseline Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaseline::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Members
Legend
Legend
public


OffsetBaseline Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Members
OffsetBaseline Members Public Properties
OffsetBaseline Members
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
EndStationOnMainBaseline | Gets the end station on the main baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
RelatedOffsetBaselineFeatureLines | Gets related offset Baseline FeatureLines.
StartStation | Gets the starting station for this baseline.
StartStationOnMainBaseline | Gets the start station on the main baseline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Members
Legend
Legend
Property
public


OffsetBaselineCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Members
OffsetBaselineCollection Members Public Methods
OffsetBaselineCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
OffsetBaselineNames | Gets an array of OffsetBaseline names.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Members
Legend
Legend
Method
public
virtual


OffsetBaselineCollection Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Members
OffsetBaselineCollection Members Public Nested Types
OffsetBaselineCollection Members
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaselineCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Members
Legend
Legend
public


OffsetBaselineCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Members
OffsetBaselineCollection Members Public Properties
OffsetBaselineCollection Members
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of BaseBaseline objects in the collection.
default | Gets a BaseBaseline by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Members
Legend
Legend
Property
public


Point Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Members
Point Members Public Methods
Point Members
Public Methods
Public Method | Description
GetXYZ | Gets the XYZ world coordinates from the soe cordinates


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Members
Legend
Legend
Method
public


Point Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Members
Point Members Public Properties
Point Members
Public Properties
Public Property | Description
Codes | Gets the collection of codes associated with this point.
Elevation | Gets or sets the point elevation.
Index | Gets the point index.
IsHidden | Gets or sets the boolean value that specifies if the Point will be drawn.
IsLoopPoint | Gets or sets the Point as a loop point for subsequent subassemblies to attach to.
Offset | Gets or sets the point offset.
Station | Gets or sets the point station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Members
Legend
Legend
Property
public


PointCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Members
PointCollection Members Public Methods
PointCollection Members
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Members
Legend
Legend
Method
public
virtual


PointCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Members
PointCollection Members Public Properties
PointCollection Members
Public Properties
Public Property | Description
Count | Get the count of shape in the collection
default | Get a point in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Members
Legend
Legend
Property
public


SampledSectionLink Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Members
SampledSectionLink Members Public Properties
SampledSectionLink Members
Public Properties
Public Property | Description
EndPointElevation | Gets or sets the line segment ending point elevation.
EndPointOffset | Gets or sets the line segment ending point offset.
EndPointStation | Gets the line segment ending point station.
StartPointElevation | Gets the line segment starting point elevation.
StartPointOffset | Gets the line segment starting point offset.
StartPointStation | Gets the line segment starting point station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Members
Legend
Legend
Property
public


SampledSectionLinkCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Members
SampledSectionLinkCollection Members Public Methods
SampledSectionLinkCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Members
Legend
Legend
Method
public
virtual


SampledSectionLinkCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Members
SampledSectionLinkCollection Members Public Properties
SampledSectionLinkCollection Members
Public Properties
Public Property | Description
default | Gets a SampledSectionLink in the collection by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Members
Legend
Legend
Property
public


Shape Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Members
Shape Members Public Properties
Shape Members
Public Properties
Public Property | Description
Codes | Get the roadway codes of the shape.
Index | Get the index of the shape.
IsHidden | Gets or sets the boolean value that specifies if the shape will be drawn.
Links | Get the roadway links of the shape.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Members
Legend
Legend
Property
public


ShapeCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Members
ShapeCollection Members Public Methods
ShapeCollection Members
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Members
Legend
Legend
Method
public
virtual


ShapeCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Members
ShapeCollection Members Public Properties
ShapeCollection Members
Public Properties
Public Property | Description
Count | Get the count of shape in the collection
default | Get a shape in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Members
Legend
Legend
Property
public


SlopeElevationTarget Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Members
SlopeElevationTarget Members Public Methods
SlopeElevationTarget Members
Public Methods
Public Method | Description
GetElevation | Overloaded
GetNearestPipeOfNetworkToAlignment | Overloaded
SlopeElevationTarget | This is SlopeElevationTarget, a member of class SlopeElevationTarget.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Members
Legend
Legend
Method
public


SlopeElevationTarget Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Members
SlopeElevationTarget Members Public Properties
SlopeElevationTarget Members
Public Properties
Public Property | Description
TargetId | This is TargetId, a member of class SlopeElevationTarget.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Members
Legend
Legend
Property
public


AssemblyStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Members
AssemblyStyle Members Public Methods
AssemblyStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the corridor model display components.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the corridor plan display components.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Members
Legend
Legend
Method
public
virtual


AssemblyStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Members
AssemblyStyle Members Public Properties
AssemblyStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerStyleAtAssemblyOriginId | Gets the ID of the marker style at the Assembly origin.
MarkerStyleAtMainBaselineId | Gets the ID of the marker style at the Assembly main baseline.
MarkerStyleAtMainBaselineOriginId | Gets the ID of the marker style at the Assembly main baseline origin.
MarkerStyleAtOffsetBaselineId | Gets the ID of the marker style at the Assembly offset baseline.
MarkerStyleAtOffsetBaselineOriginId | Gets the ID of the marker style at the Assembly offset baseline origin.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Members
Legend
Legend
Property
public


AssemblyStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class > AssemblyStyleCollection Members
AssemblyStyleCollection Members Public Methods
AssemblyStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class > AssemblyStyleCollection Members
Legend
Legend
Method
public
virtual


AssemblyStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class > AssemblyStyleCollection Members
AssemblyStyleCollection Members Public Properties
AssemblyStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class > AssemblyStyleCollection Members
Legend
Legend
Property
public


CodeSetStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Members
CodeSetStyle Members Public Methods
CodeSetStyle Members
Public Methods
Public Method | Description
Add | Add method.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetCurrentStyleSetId | Gets the ObjectId of the current CodeSetStyle. void InitAsCurrent();
GetEnumerator | Get the enumerator of this collection.
GetItemBy | Indexer.
GetObjectEnumerator | Get the enumerator of this collection.
Remove | Remove method.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Members
Legend
Legend
Method
public
virtual


CodeSetStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Members
CodeSetStyle Members Public Properties
CodeSetStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the code set item count.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Indexer.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
SubentityStyleType | Set the Corridor Style Type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Members
Legend
Legend
Property
public


CodeSetStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class > CodeSetStyleCollection Members
CodeSetStyleCollection Members Public Methods
CodeSetStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class > CodeSetStyleCollection Members
Legend
Legend
Method
public
virtual


CodeSetStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class > CodeSetStyleCollection Members
CodeSetStyleCollection Members Public Properties
CodeSetStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class > CodeSetStyleCollection Members
Legend
Legend
Property
public


CodeSetStyleItem Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Members
CodeSetStyleItem Members Public Properties
CodeSetStyleItem Members
Public Properties
Public Property | Description
Code | Gets or sets the code string.
CodeStyleId | Gets or sets the ID of the code style for this code.
CodeStyleName | Gets or Sets the code style name.
Description | Gets or sets the description for the CodeSetStyleItem.
FeatureLineStyleId | Gets or Sets the feature line style object id.
FeatureLineStyleName | Gets or Sets the feature line style name.
ItemType | Gets the code set style item type.
LabelStyleId | Gets or Sets the label style object id. We can set the label style to "none" as UI did with... more
LabelStyleName | Gets or Sets the label style name.
MaterialAreaFillStyleId | Gets or Sets the object id of the shape style used to fill the material area.
MaterialAreaFillStyleName | Gets or Sets the name of the shape style used to fill the material area.
PayItems | Gets or Sets the payitem list.
RenderMaterialStyleId | Gets or Sets the object id of render material style .
RenderMaterialStyleName | Gets or Sets the name of render material style.
StyleType | Gets the subassembly subentity style type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Members
Legend
Legend
Property
public


CorridorStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Members
CorridorStyle Members Public Methods
CorridorStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the corridor model display components.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the corridor plan display components.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Members
Legend
Legend
Method
public
virtual


CorridorStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Members
CorridorStyle Members Public Properties
CorridorStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Members
Legend
Legend
Property
public


CorridorStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class > CorridorStyleCollection Members
CorridorStyleCollection Members Public Methods
CorridorStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class > CorridorStyleCollection Members
Legend
Legend
Method
public
virtual


CorridorStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class > CorridorStyleCollection Members
CorridorStyleCollection Members Public Properties
CorridorStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class > CorridorStyleCollection Members
Legend
Legend
Property
public


IntersectionStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Members
IntersectionStyle Members Public Methods
IntersectionStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the intersection component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the intersection component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Members
Legend
Legend
Method
public
virtual


IntersectionStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Members
IntersectionStyle Members Public Properties
IntersectionStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
MarkerStyleId | Gets the marker style object id for the intersection.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Members
Legend
Legend
Property
public


IntersectionStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class > IntersectionStyleCollection Members
IntersectionStyleCollection Members Public Methods
IntersectionStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class > IntersectionStyleCollection Members
Legend
Legend
Method
public
virtual


IntersectionStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class > IntersectionStyleCollection Members
IntersectionStyleCollection Members Public Properties
IntersectionStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class > IntersectionStyleCollection Members
Legend
Legend
Property
public


LabelStylesIntersectionRoot Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LabelStylesIntersectionRoot Class > LabelStylesIntersectionRoot Members
LabelStylesIntersectionRoot Members Public Properties
LabelStylesIntersectionRoot Members
Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
LocationLabelStyles | Gets the collection of all intersection location label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LabelStylesIntersectionRoot Class > LabelStylesIntersectionRoot Members
Legend
Legend
Property
public


LinkStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Members
LinkStyle Members Public Methods
LinkStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
GetDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
GetDisplayStyleSection | Gets the DisplayStyle that specifies such Section display styles as color, linetype, plotstyle, etc.
GetLinkDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
GetLinkDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Members
Legend
Legend
Method
public
virtual


LinkStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Members
LinkStyle Members Public Properties
LinkStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
LinkDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
LinkDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
StyleType | Gets the style type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Members
Legend
Legend
Property
public


LinkStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class > LinkStyleCollection Members
LinkStyleCollection Members Public Methods
LinkStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class > LinkStyleCollection Members
Legend
Legend
Method
public
virtual


LinkStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class > LinkStyleCollection Members
LinkStyleCollection Members Public Properties
LinkStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class > LinkStyleCollection Members
Legend
Legend
Property
public


QuantityTakeoffCriteria Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Members
QuantityTakeoffCriteria Members Public Methods
QuantityTakeoffCriteria Members
Public Methods
Public Method | Description
AddMaterial | Adds a new empty material with the default value to the list.
Clear | Removes all the material items from the list.
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
RemoveAt | Removes a material item from the list.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Members
Legend
Legend
Method
public
virtual


QuantityTakeoffCriteria Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Members
QuantityTakeoffCriteria Members Public Properties
QuantityTakeoffCriteria Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Count | Gets the number of material items.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
default | Gets the material item at the given index.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Members
Legend
Legend
Property
public


QuantityTakeoffCriteriaCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class > QuantityTakeoffCriteriaCollection Members
QuantityTakeoffCriteriaCollection Members Public Methods
QuantityTakeoffCriteriaCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class > QuantityTakeoffCriteriaCollection Members
Legend
Legend
Method
public
virtual


QuantityTakeoffCriteriaCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class > QuantityTakeoffCriteriaCollection Members
QuantityTakeoffCriteriaCollection Members Public Properties
QuantityTakeoffCriteriaCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class > QuantityTakeoffCriteriaCollection Members
Legend
Legend
Property
public


QuantityTakeoffCriteriaData Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class > QuantityTakeoffCriteriaData Members
QuantityTakeoffCriteriaData Members Public Properties
QuantityTakeoffCriteriaData Members
Public Properties
Public Property | Description
Condition | Gets or sets the material data condition.
ItemType | Gets the material item data type.
Name | Gets the name of material item data.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class > QuantityTakeoffCriteriaData Members
Legend
Legend
Property
public


QuantityTakeoffCriteriaItem Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Members
QuantityTakeoffCriteriaItem Members Public Methods
QuantityTakeoffCriteriaItem Members
Public Methods
Public Method | Description
AddCorridorShape | Adds a new corridor shape data with the default value to the material item.
AddSurface | Remove a surface data from the material item.
RemoveCorridorShape | Remove a corridor shape data from the material item.
RemoveSurface | Adds a new surface data with the default value to the material item.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Members
Legend
Legend
Method
public


QuantityTakeoffCriteriaItem Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Members
QuantityTakeoffCriteriaItem Members Public Properties
QuantityTakeoffCriteriaItem Members
Public Properties
Public Property | Description
Count | Gets the number of material items' data count.
CutFactor | Gets or sets the expansion or swell of the cut material.
default | Gets the material item's data at the given index.
FillFactor | Gets or sets the contraction or shrinkage of the fill material.
MaterialName | Gets or sets the material name.
QuantityType | Gets or sets the material quantity type.
ReFillFactor | Gets or sets the usability factor used to calculate how much cut material can be reused as fill.
ShapeStyleId | Gets or Sets the object id of the default style used to display the material in a section view.
ShapeStyleName | Gets or Sets the name of the default style used to display the material in a section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Members
Legend
Legend
Property
public


ShapeStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Members
ShapeStyle Members Public Methods
ShapeStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties.
GetHatchDisplayStyleModel | Gets the HatchDisplayStyle object that specifies model display properties.
GetHatchDisplayStylePlan | Gets the HatchDisplayStyle object that specifies plan display properties.
GetHatchDisplayStyleProfile | Gets the HatchDisplayStyle object that specifies profile display properties.
GetHatchDisplayStyleSection | Gets the HatchDisplayStyle object that specifies section display properties.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Members
Legend
Legend
Method
public
virtual


ShapeStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Members
ShapeStyle Members Public Properties
ShapeStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
AreaFillHatchDisplayStyleModel |
AreaFillHatchDisplayStylePlan |
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
StyleType | Gets the style type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Members
Legend
Legend
Property
public


ShapeStyleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class > ShapeStyleCollection Members
ShapeStyleCollection Members Public Methods
ShapeStyleCollection Members
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class > ShapeStyleCollection Members
Legend
Legend
Method
public
virtual


ShapeStyleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class > ShapeStyleCollection Members
ShapeStyleCollection Members Public Properties
ShapeStyleCollection Members
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class > ShapeStyleCollection Members
Legend
Legend
Property
public


SubassemblySubentityStyle Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class > SubassemblySubentityStyle Members
SubassemblySubentityStyle Members Public Methods
SubassemblySubentityStyle Members
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class > SubassemblySubentityStyle Members
Legend
Legend
Method
public
virtual


SubassemblySubentityStyle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class > SubassemblySubentityStyle Members
SubassemblySubentityStyle Members Public Properties
SubassemblySubentityStyle Members
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
ModifiedBy | Gets the "Modified by" string for the style.
Name | Gets or sets the name.
StyleType | Gets the style type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class > SubassemblySubentityStyle Members
Legend
Legend
Property
public


Subassembly Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Members
Subassembly Members Public Methods
Subassembly Members
Public Methods
Public Method | Description
EraseAllParams | Erases all the subassembly's script parameters.
GetResourceString | Overloaded
Run | Runs the callback function associated with the Subassembly.
ShowHelp | Shows the help information associated with a subassembly.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Members
Legend
Legend
Method
public


Subassembly Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Members
Subassembly Members Public Properties
Subassembly Members
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
AssemblyId | Gets the ID of the Assembly this Subassembly belongs to.
AttachedToOffsetAssembly | Gets a bool value that specifies whether the subassembly is attached to a offset assembly or a main assembly.
CodeSetStyleName | Gets or sets the code set style name.
DefaultLoopInLayoutMode | Gets or sets a flag indicating if the first or last point in the subassembly is used as the loop... more
DefaultLoopOffsetInLayoutMode | Gets or sets the default loop point offset distance for subassembly in layout mode.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
GeometryGenerator | Gets or sets the SubassemblyGenerator object that controls how the Subassembly geometry is generated.
HasParentAssembly | Returns true if this Subassembly has a parent Assembly.
HelpCommand | Gets or sets the command to invoke the Subassembly help.
HelpData | Gets or sets help data for the Subassembly.
HelpFile | Gets or sets the file name of the Subassembly help file.
IsDynamic | Returns true if the subassembly dynamically computes its state.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Links | Gets the Links collection.
Name | Gets or sets the Entity object's name.
OffsetToAssembly | Gets a vector value that specifies the offset to the assembly it belongs to in layout mode.
OffsetToBaseline | Gets a vector value that specifies the offset to the assembly or offset assembly it attached in layout mode.
ParamsBool | Gets the Boolean parameters collection.
ParamsDouble | Gets the Double parameters collection.
ParamsLong | Gets the Long parameters collection.
ParamsString | Gets the String parameters collection.
Points | Gets the Points collection.
ResourceModule | Gets or sets the Subassembly resource module file.
Shapes | Gets the Shapes collection.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | The name of the Subassembly style.
SubassemblyHookTo | Gets the object id of the Subassembly which it hook to
UseEmbeddedProject | Gets or sets whether the Subassembly uses macros in embedded projects.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Members
Legend
Legend
Property
public


SubassemblyCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Members
SubassemblyCollection Members Public Methods
SubassemblyCollection Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Members
Legend
Legend
Method
public
virtual


SubassemblyCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Members
SubassemblyCollection Members Public Properties
SubassemblyCollection Members
Public Properties
Public Property | Description
Count | Gets the number of Subassembly objects in the collection.
default | Gets a Subassembly by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Members
Legend
Legend
Property
public


SubassemblyGenerator Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Members
SubassemblyGenerator Members Public Methods
SubassemblyGenerator Members
Public Methods
Public Method | Description
SubassemblyGenerator | Constructor.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Members
Legend
Legend
Constructor
public


SubassemblyGenerator Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Members
SubassemblyGenerator Members Public Properties
SubassemblyGenerator Members
Public Properties
Public Property | Description
GeometryGenerateMode | Gets or sets the way the Subassembly geometry is generated.
MacroOrClassName | Gets or sets the macro or class name. This is the class name when GeometryGenerateMode is UseDotNet.
ProjectOrAssemblyName | Gets or sets the project or assembly name. This is the assembly name when GeometryGenerateMode is UseDotNet.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Members
Legend
Legend
Property
public


WidthOffsetTarget Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Members
WidthOffsetTarget Members Public Methods
WidthOffsetTarget Members
Public Methods
Public Method | Description
GetDistanceToAlignment | Overloaded
GetNearestPipeOfNetworkToAlignment | Overloaded
WidthOffsetTarget | This is WidthOffsetTarget, a member of class WidthOffsetTarget.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Members
Legend
Legend
Method
public


WidthOffsetTarget Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Members
WidthOffsetTarget Members Public Properties
WidthOffsetTarget Members
Public Properties
Public Property | Description
TargetId | This is TargetId, a member of class WidthOffsetTarget.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Members
Legend
Legend
Property
public


SettingsAssembly Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Members
SettingsAssembly Members Classes
SettingsAssembly Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Members
Legend
Legend
Class


SettingsAssembly Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Members
SettingsAssembly Members Public Properties
SettingsAssembly Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Members
Legend
Legend
Property
public


SettingsAssembly Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Members
SettingsAssembly Members Templates
SettingsAssembly Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Members
Legend
Legend
Template


SettingsAssembly::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class > SettingsAssembly::SettingsNameFormat Members
SettingsAssembly::SettingsNameFormat Members Public Properties
SettingsAssembly::SettingsNameFormat Members
Public Properties
Public Property | Description
Assembly | Settings Assembly default name format.
Group | Settings Group default name format.
Offset | Settings Offset default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class > SettingsAssembly::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsAssembly::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class > SettingsAssembly::SettingsStyles Members
SettingsAssembly::SettingsStyles Members Public Properties
SettingsAssembly::SettingsStyles Members
Public Properties
Public Property | Description
Assembly | Settings of Assembly style.
CodeSet | Settings of code set style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class > SettingsAssembly::SettingsStyles Members
Legend
Legend
Property
public


SettingsCmdAddMaterialVolumeTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Members
SettingsCmdAddMaterialVolumeTable Members Classes
SettingsCmdAddMaterialVolumeTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Members
Legend
Legend
Class


SettingsCmdAddMaterialVolumeTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Members
SettingsCmdAddMaterialVolumeTable Members Public Properties
SettingsCmdAddMaterialVolumeTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TableCreation | Gets the default setting of table creation for the command AddMaterialVolumeTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Members
Legend
Legend
Property
public


SettingsCmdAddMaterialVolumeTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Members
SettingsCmdAddMaterialVolumeTable Members Templates
SettingsCmdAddMaterialVolumeTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Members
Legend
Legend
Template


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members Public Properties
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAddTotalVolumeTable Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Members
SettingsCmdAddTotalVolumeTable Members Classes
SettingsCmdAddTotalVolumeTable Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Members
Legend
Legend
Class


SettingsCmdAddTotalVolumeTable Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Members
SettingsCmdAddTotalVolumeTable Members Public Properties
SettingsCmdAddTotalVolumeTable Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TableCreation | Gets the default setting of table creation for the command AddTotalVolumeTable.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Members
Legend
Legend
Property
public


SettingsCmdAddTotalVolumeTable Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Members
SettingsCmdAddTotalVolumeTable Members Templates
SettingsCmdAddTotalVolumeTable Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Members
Legend
Legend
Template


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members Public Properties
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Members
Legend
Legend
Property
public


SettingsCmdAssignPayItemToArea Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Members
SettingsCmdAssignPayItemToArea Members Classes
SettingsCmdAssignPayItemToArea Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Members
Legend
Legend
Class


SettingsCmdAssignPayItemToArea Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Members
SettingsCmdAssignPayItemToArea Members Public Properties
SettingsCmdAssignPayItemToArea Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AssignPayItemToAreaOption | Gets the default setting for the command AssignPayItemToArea.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Members
Legend
Legend
Property
public


SettingsCmdAssignPayItemToArea Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Members
SettingsCmdAssignPayItemToArea Members Templates
SettingsCmdAssignPayItemToArea Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Members
Legend
Legend
Template


SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members Public Properties
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members
Public Properties
Public Property | Description
ColorForHatch | Specifies the color for hatch.
LayerForHatch | Specifies the layer for hatch.
UseAcadLayerAndColor | Specifies whether to use AutoCAD current layer and color.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Members
Legend
Legend
Property
public


SettingsCmdComputeMaterials Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Members
SettingsCmdComputeMaterials Members Classes
SettingsCmdComputeMaterials Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Members
Legend
Legend
Class


SettingsCmdComputeMaterials Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Members
SettingsCmdComputeMaterials Members Public Properties
SettingsCmdComputeMaterials Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
DefineMaterialOption | Gets the default setting of define material for the command ComputeMaterials.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Members
Legend
Legend
Property
public


SettingsCmdComputeMaterials Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Members
SettingsCmdComputeMaterials Members Templates
SettingsCmdComputeMaterials Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Members
Legend
Legend
Template


SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members Public Properties
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members
Public Properties
Public Property | Description
ApplyCurveCorrection | Specifies whether to apply curve correction.
CurveCorrectionTolerance | Specifies the curve correction tolerance.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Members
Legend
Legend
Property
public


SettingsCmdCreateAlignFromCorridor Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Members
SettingsCmdCreateAlignFromCorridor Members Classes
SettingsCmdCreateAlignFromCorridor Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Members
Legend
Legend
Class


SettingsCmdCreateAlignFromCorridor Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Members
SettingsCmdCreateAlignFromCorridor Members Public Properties
SettingsCmdCreateAlignFromCorridor Members
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the alignment type options.
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the criteria based design options.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
ProfileCreationOption | Gets the profile creation options.
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Members
Legend
Legend
Property
public


SettingsCmdCreateAlignFromCorridor Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Members
SettingsCmdCreateAlignFromCorridor Members Templates
SettingsCmdCreateAlignFromCorridor Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Members
Legend
Legend
Template


SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members Public Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members
Public Properties
Public Property | Description
AlignmentType | Specifies the alignment type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Members
Legend
Legend
Property
public


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members Public Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
DesignSpeed | Gets the default design speed.
DesignSpeedLookupMethod | Gets the default design speed lookup method.
RadiusLookupMethod | Gets the default radius lookup method.
UseCriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
UseDesignChecksOption | Gets whether to associate a design check set with the alignment.
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
Legend
Legend
Property
public


SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members Public Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members
Public Properties
Public Property | Description
CreateProfileFromCorridor | Gets whether a profile is automatically created when creating an alignment from a corridor feature line.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Members
Legend
Legend
Property
public


SettingsCmdCreateCorridor Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Members
SettingsCmdCreateCorridor Members Classes
SettingsCmdCreateCorridor Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Members
Legend
Legend
Class


SettingsCmdCreateCorridor Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Members
SettingsCmdCreateCorridor Members Public Properties
SettingsCmdCreateCorridor Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AssemblyInsertion | Gets the default settings of assembly insertion.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Members
Legend
Legend
Property
public


SettingsCmdCreateCorridor Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Members
SettingsCmdCreateCorridor Members Templates
SettingsCmdCreateCorridor Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Members
Legend
Legend
Template


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members Public Properties
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members
Public Properties
Public Property | Description
FrequencyAlongCurves | Gets the corridor station placement frequency along the curve portion of an alignment.
FrequencyAlongProfileCurves | Gets the corridor station placement frequency along curve portions of the profile geometry.
FrequencyAlongSpirals | Gets the corridor station placement frequency along the spiral portion of an alignment.
FrequencyAlongTangents | Gets the corridor station placement frequency along the tangent portion of an alignment.
HorizontalGeometryPoints | Gets the corridor station placement frequency along the spiral portion of an alignment.
ProfileGeometryPoints | Gets whether corridor stations are placed at profile geometry points.
ProfileHighLowPoints | Gets whether assemblies are inserted at the high and low points of the profile geometry.
SuperelevationCriticalPoints | Gets whether corridor stations are placed at superelevation critical points.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Members
Legend
Legend
Property
public


SettingsCmdCreateIntersection Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Members
SettingsCmdCreateIntersection Members Classes
SettingsCmdCreateIntersection Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Members
Legend
Legend
Class


SettingsCmdCreateIntersection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Members
SettingsCmdCreateIntersection Members Public Properties
SettingsCmdCreateIntersection Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AssemblyInsertion | Gets the default assembly insertion for new intersection
Coordinate | The Coordinate settings
CrossSlopes | Gets the default cross slopes for new intersection
CurbReturnParameters | Gets the default curb return parameters for new intersection
CurbReturnProfileRules | Gets the default curb return profile rules for new intersection
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
IntersectionOptions | Gets the default intersection options for new intersection
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Offsets | Gets the default offsets for new intersection
SecondaryRoadProfileRules | Gets the default secondary road profile rules for new intersection
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings
WideningParameters | Gets the default widening parameters for new intersection


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Members
Legend
Legend
Property
public


SettingsCmdCreateIntersection Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Members
SettingsCmdCreateIntersection Members Templates
SettingsCmdCreateIntersection Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Members
Legend
Legend
Template


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members Public Properties
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members
Public Properties
Public Property | Description
FrequencyAlongCurves | Specifies the frequency that the intersection object assemblies is inserted for curve segments of the alignment.
FrequencyAlongProfileCurves | Specifies the frequency along stations that intersection object assemblies are inserted for curve segments of the profile.
FrequencyAlongSpirals | Specifies the frequency that the intersection object assemblies is inserted for spiral segments of the alignment.
FrequencyAlongTangents | Specifies the frequency that the intersection object assemblies is inserted for tangent segments of the alignment.
HorizontalGeometryPoints | Specifies whether or not to use horizontal geometry points to define intersection objects.
ProfileGeometryPoints | Specifies whether or not to use profile geometry points to define intersection objects.
ProfileHighLowPoints | Specifies whether or not to use the highest and lowest points of the profile to define intersection objects.
SuperelevationCriticalPoints | Specifies whether or not to use superelevation critical points to define intersection objects.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Members
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members Public Properties
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members
Public Properties
Public Property | Description
PrimaryRoadLeftCrossSlope | Specifies the cross slope of the left side of the primary road.
PrimaryRoadRightCrossSlope | Specifies the cross slope of the right side of the primary road.
SecondaryRoadLeftCrossSlope | Specifies the cross slope of the left side of the secondary road.
SecondaryRoadRightCrossSlope | Specifies the cross slope of the right side of the secondary road.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Members
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members Public Properties
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members
Public Properties
Public Property | Description
ChamferFilletLengthAlongIncomingLane | When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s... more
ChamferFilletLengthAlongOutgoingLane | When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s... more
CircularFilletRadius | When Circular Fillet is selected as the curb return type, this option lets you specify the radius for the circular... more
CurbReturnType | Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.
LengthOfCurve1 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the first... more
LengthOfCurve3 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the third... more
RadiusOfCurve1 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the first... more
RadiusOfCurve2 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the second... more
RadiusOfCurve3 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the third... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Members
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members Public Properties
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members
Public Properties
Public Property | Description
DefineCurbReturnProfileBy | Specifies the method that is used to define the curb return profile.
ExtendProfileAlongIncomingLane | Specifies whether or not to extend the curb return profile along the incoming lane of the intersection.
ExtendProfileAlongOutgoingLane | Specifies whether or not to extend the curb return profile along the outgoing lane of the intersection.
LengthToExtendAlongIncomingLane | When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the... more
LengthToExtendAlongOutgoingLane | When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Members
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members Public Properties
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members
Public Properties
Public Property | Description
CreateCurbReturnAlignments | Specifies whether or not to create curb return alignments.
CreateCurbReturnProfiles | Specifies whether or not to create curb return profiles.
CreateIntersectionCorridors | Specifies whether or not to create intersection corridors.
IntersectionType | Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options... more
PrimaryRoadDefaultExitAndEntryLength | Specifies the default length of the primary road as it enters and exits the intersection.
SecondaryRoadDefaultExitAndEntryLength | Specifies the default length of the secondary road as it enters and exits the intersection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Members
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdOffsets Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Members
SettingsCmdCreateIntersection::SettingsCmdOffsets Members Public Properties
SettingsCmdCreateIntersection::SettingsCmdOffsets Members
Public Properties
Public Property | Description
OffsetLengthOptions | Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are... more
PrimaryRoadLeftOffset | Specifies the elevation of the offset alignment on the left side of the primary road.
PrimaryRoadRightOffset | Specifies the elevation of the offset alignment on the right side of the primary road.
SecondaryRoadLeftOffset | Specifies the elevation of the offset alignment on the left side of the secondary road.
SecondaryRoadRightOffset | Specifies the elevation of the offset alignment on the right side of the secondary road.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Members
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members Public Properties
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members
Public Properties
Public Property | Description
ApplyGradeRules | Specifies whether or not to apply grade rules.
DistanceRuleToAdjusttheGrade | Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is... more
DistanceValue | Specifes the distance that is used to adjust the grade for the secondary road profile when Specify Distance is selected... more
MaximumGrade | Specifies the maximum grade that can be used in the profile for the secondary road.
MaximumGradeChange | Specifies the maximum grade change that can be used in the profile for the secondary road.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Members
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members Public Properties
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members
Public Properties
Public Property | Description
LinearTransitionType | When Linear is selected as the Transition Type, this option lets you specify the type of linear transition used for... more
RadiusofCurve1 | When a curve option is selected as the Transition Type, this option lets you specify the radius for the first... more
RadiusofCurve2 | When a curve option is selected as the Transition Type, this option lets you specify the radius for the second... more
RadiusOfReverseCurve | When Curve-Curve - Reverse Curve is selected as the Transition Type, this option lets you specify the radius for the... more
TaperRation | When By Taper Ratio is selected as the Linear Transition Type, this option lets you specify the ratio of the... more
TransitionLength | When By Length is selected as the Linear Transition Type, this option lets you specify the length of the transition... more
TransitionType | Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.
WidenedOffset | Specifies the elevation for the offset alignment that has been widened, at both the entrance to the intersection, and as... more
WideningAtIncomingLane | Specifies whether or not to widen the incoming lane as it enters the intersection.
WideningAtOutgoingLane | Specifies whether or not to widen the outgoing lane as it exits the intersection.
WideningSegmentLength | Specifies the length of the offset alignment that will be widened, at both the entrance to the intersection, and as... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Members
Legend
Legend
Property
public


SettingsCmdCreateProfileFromCorridor Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Members
SettingsCmdCreateProfileFromCorridor Members Classes
SettingsCmdCreateProfileFromCorridor Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Members
Legend
Legend
Class


SettingsCmdCreateProfileFromCorridor Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Members
SettingsCmdCreateProfileFromCorridor Members Public Properties
SettingsCmdCreateProfileFromCorridor Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CriteriaBasedDesignOptions | Gets the default settings of criteria-based design options.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Members
Legend
Legend
Property
public


SettingsCmdCreateProfileFromCorridor Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Members
SettingsCmdCreateProfileFromCorridor Members Templates
SettingsCmdCreateProfileFromCorridor Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Members
Legend
Legend
Template


SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members Public Properties
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
UseDesignChecksOption | Gets whether to associate a design check set with the profile.
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Members
Legend
Legend
Property
public


SettingsCmdCreateSimpleCorridor Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Members
SettingsCmdCreateSimpleCorridor Members Classes
SettingsCmdCreateSimpleCorridor Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Members
Legend
Legend
Class


SettingsCmdCreateSimpleCorridor Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Members
SettingsCmdCreateSimpleCorridor Members Public Properties
SettingsCmdCreateSimpleCorridor Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
AssemblyInsertion | Gets the default settings of assembly insertion.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Members
Legend
Legend
Property
public


SettingsCmdCreateSimpleCorridor Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Members
SettingsCmdCreateSimpleCorridor Members Templates
SettingsCmdCreateSimpleCorridor Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Members
Legend
Legend
Template


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members Public Properties
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members
Public Properties
Public Property | Description
FrequencyAlongCurves | Gets the corridor station placement frequency along the curve portion of an alignment.
FrequencyAlongProfileCurves | Gets the corridor station placement frequency along curve portions of the profile geometry.
FrequencyAlongSpirals | Gets the corridor station placement frequency along the spiral portion of an alignment.
FrequencyAlongTangents | Gets the corridor station placement frequency along the tangent portion of an alignment.
HorizontalGeometryPoints | Gets whether corridor stations are placed at horizontal geometry points.
ProfileGeometryPoints | Gets whether corridor stations are placed at profile geometry points.
ProfileHighLowPoints | Gets whether assemblies are inserted at the high and low points of the profile geometry.
SuperelevationCriticalPoints | Gets whether corridor stations are placed at superelevation critical points.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Members
Legend
Legend
Property
public


SettingsCmdCreateSubassemblyTool Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Members
SettingsCmdCreateSubassemblyTool Members Classes
SettingsCmdCreateSubassemblyTool Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Members
Legend
Legend
Class


SettingsCmdCreateSubassemblyTool Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Members
SettingsCmdCreateSubassemblyTool Members Public Properties
SettingsCmdCreateSubassemblyTool Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
DefaultStyles | Gets the settings to specify the default styles for subassembly.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for subassembly.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
SubassemblyOptions | Gets the default setting of subassembly option for the command CreateSubassemblyTool.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Members
Legend
Legend
Property
public


SettingsCmdCreateSubassemblyTool Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Members
SettingsCmdCreateSubassemblyTool Members Templates
SettingsCmdCreateSubassemblyTool Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Members
Legend
Legend
Template


SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members Public Properties
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members
Public Properties
Public Property | Description
CurrentSide | Specifies the current side.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Members
Legend
Legend
Property
public


SettingsCmdCreateSubFromPline Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Members
SettingsCmdCreateSubFromPline Members Classes
SettingsCmdCreateSubFromPline Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Members
Legend
Legend
Class


SettingsCmdCreateSubFromPline Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Members
SettingsCmdCreateSubFromPline Members Public Properties
SettingsCmdCreateSubFromPline Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CreateFromEntities | Gets the default setting of create from entities for the command CreateSubFromPline.
DefaultStyles | Gets the settings to specify the default styles for subassembly.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for subassembly.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Members
Legend
Legend
Property
public


SettingsCmdCreateSubFromPline Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Members
SettingsCmdCreateSubFromPline Members Templates
SettingsCmdCreateSubFromPline Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Members
Legend
Legend
Template


SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members Public Properties
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members
Public Properties
Public Property | Description
LinkCreation | Specifies the quantity of subassembly links (None, Single, Multiple) created from the polyline(s).
MidOrdinateDistance | Specifies mid-ordinate distance to approximate curvilinear segments


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Members
Legend
Legend
Property
public


SettingsCmdFeatureLinesFromCorridor Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Members
SettingsCmdFeatureLinesFromCorridor Members Classes
SettingsCmdFeatureLinesFromCorridor Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Members
Legend
Legend
Class


SettingsCmdFeatureLinesFromCorridor Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Members
SettingsCmdFeatureLinesFromCorridor Members Public Properties
SettingsCmdFeatureLinesFromCorridor Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
FeatureLineCreation | Gets the default settings of feature line creation.
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Members
Legend
Legend
Property
public


SettingsCmdFeatureLinesFromCorridor Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Members
SettingsCmdFeatureLinesFromCorridor Members Templates
SettingsCmdFeatureLinesFromCorridor Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Members
Legend
Legend
Template


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members Public Properties
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members
Public Properties
Public Property | Description
CreateDynamicLink | Gets the create dynamic link setting.
FeatureLineName | Gets whether to specify the name of the feature line.
HorizontalDeviation | Gets the horizontal deviation setting.
InclusionDistance | Gets the inclusion distance setting.
LayerSetting | Gets the layer setting.
SmoothTheFeatureLine | Gets the feature line smoothing setting.
UseFeatureLineStyle | Gets whether to use the feature line style.
WeedingDistance | Gets the weeding distance setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Members
Legend
Legend
Property
public


SettingsCmdGenerateQuantitiesReport Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Members
SettingsCmdGenerateQuantitiesReport Members Classes
SettingsCmdGenerateQuantitiesReport Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Members
Legend
Legend
Class


SettingsCmdGenerateQuantitiesReport Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Members
SettingsCmdGenerateQuantitiesReport Members Public Properties
SettingsCmdGenerateQuantitiesReport Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
DisplayXmlReport | specifies whether to display XML report.
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Members
Legend
Legend
Property
public


SettingsCmdGenerateQuantitiesReport Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Members
SettingsCmdGenerateQuantitiesReport Members Templates
SettingsCmdGenerateQuantitiesReport Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Members
Legend
Legend
Template


SettingsCmdTakeOff Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Members
SettingsCmdTakeOff Members Classes
SettingsCmdTakeOff Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Members
Legend
Legend
Class


SettingsCmdTakeOff Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Members
SettingsCmdTakeOff Members Public Properties
SettingsCmdTakeOff Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
ComputeTakeOffOption | Gets the default setting of take off computation for the command TakeOff.
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Members
Legend
Legend
Property
public


SettingsCmdTakeOff Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Members
SettingsCmdTakeOff Members Templates
SettingsCmdTakeOff Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Members
Legend
Legend
Template


SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members Public Properties
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members
Public Properties
Public Property | Description
DefaultReportStyle | specifies the default style sheet which is used to format the take off report.
DrawingBasedReportTableFont | Specifies the text font used in drawing-based report table.
IncludeFormulasInReports | specifies whether to include the formulas of pay items in the quantity takeoff report remarks.
LengthComputeType | Specifies the length computation type in the quantity takeoff process.
LimitToAlignmentStation | specifies whether to limit the report extents to a specified alignment station range.
PipeLengthType | Specifies the pipe length type used in the quantity takeoff process.
ReportExtentsType | specifies the extents used when finding entities to participate in the quantity takeoff process.
ReportSelectedPayItemOnly | specifies whether to allow reports to be generated on a subset of pay items which are selected in master pay... more
ReportType | Specifies the report type for quantity takeoff process.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Members
Legend
Legend
Property
public


SettingsCmdViewEditCorridorSection Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Members
SettingsCmdViewEditCorridorSection Members Classes
SettingsCmdViewEditCorridorSection Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Members
Legend
Legend
Class


SettingsCmdViewEditCorridorSection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Members
SettingsCmdViewEditCorridorSection Members Public Properties
SettingsCmdViewEditCorridorSection Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
GridSettings | Gets the default settings of grid settings.
GridTextSettings | Gets the default settings of grid text settings.
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
ViewEditOptions | Gets the default settings of view/edit options.
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Members
Legend
Legend
Property
public


SettingsCmdViewEditCorridorSection Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Members
SettingsCmdViewEditCorridorSection Members Templates
SettingsCmdViewEditCorridorSection Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Members
Legend
Legend
Template


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members Public Properties
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members
Public Properties
Public Property | Description
CenterAxisColor | Gets the Center Axis Color setting.
DisplayCenterAxis | Gets the Display Center Axis setting.
DisplayHorizontalGrid | Gets the Display Horizontal Grid setting.
DisplayVerticalGrid | Gets the Display Vertical Grid setting.
GridColor | Gets the Grid Color setting.
HorizontalGridInterval | Gets the Horizontal Grid Interval setting.
VerticalGridInterval | Gets the Vertical Grid Interval setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Members
Legend
Legend
Property
public


SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members Public Properties
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members
Public Properties
Public Property | Description
AnnotateCenterAxis | Gets the Annotate Center Axis setting.
TextColor | Gets the Text Color setting.
TextHeightRelativeToScreen | Gets the Text Height Relative to Screen setting.
TextStyle | Gets the Text Style setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Members
Legend
Legend
Property
public


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members Public Properties
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members
Public Properties
Public Property | Description
BackClip | Gets the Back Clip setting.
DefaultViewScale | Gets the default view scale setting.
FrontClip | Gets the Front Clip setting.
RebuildOnEdit | Gets the Rebuild On Edit setting.
StationTrackerInMultipleViewports | Gets the Station Tracker in Multiple Viewports setting.
TurnOffUnassociatedLayers | Gets the Turn Off Unassociated Layers setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Members
Legend
Legend
Property
public


SettingsCorridor Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Members
SettingsCorridor Members Classes
SettingsCorridor Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Members
Legend
Legend
Class


SettingsCorridor Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Members
SettingsCorridor Members Public Properties
SettingsCorridor Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Members
Legend
Legend
Property
public


SettingsCorridor Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Members
SettingsCorridor Members Templates
SettingsCorridor Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Members
Legend
Legend
Template


SettingsCorridor::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Members
SettingsCorridor::SettingsNameFormat Members Public Properties
SettingsCorridor::SettingsNameFormat Members
Public Properties
Public Property | Description
AlignmentFromFeatureLine | AlignmentFromFeatureLine Style for corridor settings.
Corridor | CorridorName Style for corridor settings.
CorridorBaseline | CorridorBaseline Style for corridor settings.
CorridorRegion | CorridorRegion Style for corridor settings.
CorridorSurface | CorridorSurface Style for corridor settings.
FeatureLine | FeatureLine Style for corridor settings.
ProfileFromFeatureLine | ProfileFromFeatureLine Style for corridor settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsCorridor::SettingsRegionHighlightGraphics Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Members
SettingsCorridor::SettingsRegionHighlightGraphics Members Public Properties
SettingsCorridor::SettingsRegionHighlightGraphics Members
Public Properties
Public Property | Description
BaselineColor | BaselineColor highlight graphics for corridor settings.
BaselineLineweight | BaselineLineweight highlight graphics for corridor settings.
HighlightBaseline | HighlightBaseline highlight graphics for corridor settings.
HighlightHorizontalTargets | HighlightHorizontalTargets highlight graphics for corridor settings.
HighlightInteriorAssemblies | HighlightInteriorAssemblies highlight graphics for corridor settings.
HighlightRegionBoundary | HighlightRegionBoundary highlight graphics for corridor settings.
HorizontalTargetsColor | HorizontalTargetsColor highlight graphics for corridor settings.
HorizontalTargetsLineweight | HorizontalTargetsLineweight highlight graphics for corridor settings.
InteriorAssembliesColor | InteriorAssembliesColor highlight graphics for corridor settings.
InteriorAssembliesLineweight | InteriorAssembliesLineweight highlight graphics for corridor settings.
RegionBoundaryColor | RegionBoundaryColor highlight graphics for corridor settings.
RegionBoundaryLineweight | RegionBoundaryLineweight highlight graphics for corridor settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Members
Legend
Legend
Property
public


SettingsCorridor::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Members
SettingsCorridor::SettingsStyles Members Public Properties
SettingsCorridor::SettingsStyles Members
Public Properties
Public Property | Description
Alignment | Specifies the default style for an alignment created from the corridor.
AlignmentLabelSet | Specifies the default style for the alignment label sets created from corridors.
Corridor | Specifies the default style for the corridor.
CorridorCodeSet | Specifies the default code set style for corridors.
CorridorSurface | Specifies the default corridor surface style.
FeatureLine | Specifies the default feature line style for the corridor.
Profile | Specifies the default style for a profile created from the corridor.
ProfileLabelSet | Specifies the default profile label set style.
RenderMaterial | Specifies the default render material style for the corridor.
SlopePattern | Specifies the default style for the slope patterns added to corridors.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Members
Legend
Legend
Property
public


SettingsIntersection Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Members
SettingsIntersection Members Classes
SettingsIntersection Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Members
Legend
Legend
Class


SettingsIntersection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Members
SettingsIntersection Members Public Properties
SettingsIntersection Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to corridor components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Members
Legend
Legend
Property
public


SettingsIntersection Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Members
SettingsIntersection Members Templates
SettingsIntersection Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Members
Legend
Legend
Template


SettingsIntersection::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Members
SettingsIntersection::SettingsNameFormat Members Public Properties
SettingsIntersection::SettingsNameFormat Members
Public Properties
Public Property | Description
CorridorRegion | Settings CorridorRegion default name format.
CurbReturnAlignment | Settings CurbReturnAlignment default name format.
CurbReturnProfile | Settings CurbReturnProfile default name format.
Intersection | Settings Intersection default name format.
IntersectionQuadrant | Settings IntersectionQuadrant default name format.
OffsetAlignment | Settings OffsetAlignment default name format.
OffsetProfile | Settings OffsetProfile default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsIntersection::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Members
SettingsIntersection::SettingsStyles Members Public Properties
SettingsIntersection::SettingsStyles Members
Public Properties
Public Property | Description
CurbReturnAlignment | Settings of CurbReturnAlignment style.
CurbReturnAlignmentLabelSet | Settings of CurbReturnAlignmentLabelSet style.
CurbReturnProfile | Settings of CurbReturnProfile style.
CurbReturnProfileLabelSet | Settings of CurbReturnProfileLabelSet style.
Intersection | Settings of Intersection style.
IntersectionLabel | Settings of IntersectionLabel style.
OffsetAlignment | Settings of OffsetAlignment style.
OffsetAlignmentLabelSet | Settings of OffsetAlignmentLabelSet style.
OffsetProfile | Settings of OffsetProfile style.
OffsetProfileLabelSet | Settings of OffsetProfileLabelSet style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Members
Legend
Legend
Property
public


SettingsQuantityTakeoff Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Members
SettingsQuantityTakeoff Members Classes
SettingsQuantityTakeoff Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Members
Legend
Legend
Class


SettingsQuantityTakeoff Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Members
SettingsQuantityTakeoff Members Public Properties
SettingsQuantityTakeoff Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Members
Legend
Legend
Property
public


SettingsQuantityTakeoff Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Members
SettingsQuantityTakeoff Members Templates
SettingsQuantityTakeoff Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Members
Legend
Legend
Template


SettingsQuantityTakeoff::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class > SettingsQuantityTakeoff::SettingsNameFormat Members
SettingsQuantityTakeoff::SettingsNameFormat Members Public Properties
SettingsQuantityTakeoff::SettingsNameFormat Members
Public Properties
Public Property | Description
Material | Settings QuantityTakeoff material name format.
MaterialList | Settings QuantityTakeoff material list name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class > SettingsQuantityTakeoff::SettingsNameFormat Members
Legend
Legend
Property
public


SettingsQuantityTakeoff::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class > SettingsQuantityTakeoff::SettingsStyles Members
SettingsQuantityTakeoff::SettingsStyles Members Public Properties
SettingsQuantityTakeoff::SettingsStyles Members
Public Properties
Public Property | Description
MaterialShape | Settings of QuantityTakeoff material shape.
QuantityTakeoffCriteria | Settings of QuantityTakeoff criteria style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class > SettingsQuantityTakeoff::SettingsStyles Members
Legend
Legend
Property
public


SettingsSubassembly Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Members
SettingsSubassembly Members Classes
SettingsSubassembly Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Members
Legend
Legend
Class


SettingsSubassembly Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Members
SettingsSubassembly Members Public Properties
SettingsSubassembly Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
DefaultStyles | Gets the settings to specify the default styles for subassembly.
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
NameFormat | Gets the settings to specify the default name formats for subassembly.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Members
Legend
Legend
Property
public


SettingsSubassembly Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Members
SettingsSubassembly Members Templates
SettingsSubassembly Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Members
Legend
Legend
Template


SettingsSubassembly::SettingsDefaultStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsDefaultStyles Class > SettingsSubassembly::SettingsDefaultStyles Members
SettingsSubassembly::SettingsDefaultStyles Members Public Properties
SettingsSubassembly::SettingsDefaultStyles Members
Public Properties
Public Property | Description
CodeSetStyle | Gets the settings to specify the default code set style for subassembly.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsDefaultStyles Class > SettingsSubassembly::SettingsDefaultStyles Members
Legend
Legend
Property
public


SettingsSubassembly::SettingsNameFormat Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class > SettingsSubassembly::SettingsNameFormat Members
SettingsSubassembly::SettingsNameFormat Members Public Properties
SettingsSubassembly::SettingsNameFormat Members
Public Properties
Public Property | Description
CreateFromEntities | Gets the settings to specify the default name formats for subassembly.
CreateFromMacro | Gets the settings to specify the default name formats for subassembly.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class > SettingsSubassembly::SettingsNameFormat Members
Legend
Legend
Property
public


CorridorState Members Public Methods
CorridorState Members
Public Methods
Public Method | Description
IntersectAlignment | Overloaded
IntersectLink | Intersects a ray with an assembly's links.
IntersectSurface | Overloaded
IsAboveSurface | Overloaded
RecordError | Record error.
SampleSection | Samples elevation along an existing surface.
SoeToXyz | Transforms from assembly local station, offset, elevation (SOE) coordinates to world x,y,z coordinates.
XyzToSoe | Transforms from world x,y,z coordinates to assembly local station, offset, elevation (SOE) coordinates.


CorridorState Members Public Properties
CorridorState Members
Public Properties
Public Property | Description
CurrentAlignmentId | Gets the current alignment where Subassembly is being applied.
CurrentAlignmentIsOffsetAlignment | Returns true if current processing state is along an offset alignment.
CurrentAssemblyElevation | Returns elevation difference from profile grade line elevation where current assembly is being applied.
CurrentAssemblyFixedElevation | If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed elevation difference of the offset assembly portion from the... more
CurrentAssemblyFixedOffset | If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed offset distance of the offset assembly portion from the... more
CurrentAssemblyId | Gets the ObjectId of the current Assembly being applied.
CurrentAssemblyName | Gets the name of the current Assembly being applied.
CurrentAssemblyOffset | Returns offset from baseline alignment where current assembly is being applied.
CurrentAssemblyOffsetIsFixed | Returns true if current processing state is along offset portion of assembly without offset alignment defined.
CurrentBaselineId | Gets the current baseline alignment where a Subassembly is being applied.
CurrentCorridorId | Gets the OjbectId of the current Corridor being applied.
CurrentCorridorName | Gets the name of the current Corridor being applied.
CurrentElevation | Gets the current elevation.
CurrentMacroName | Gets the current macro name.
CurrentMacroProject | Gets the current macro project.
CurrentOffset | Gets the current offset.
CurrentProfileId | Gets the current profile where Subassembly is being applied.
CurrentStation | Gets the current baseline alignment station where a Subassembly is being applied.
CurrentSubassemblyElevation | Returns the elevation difference from the assembly origin where the current subassembly is being applied.
CurrentSubassemblyId | Gets the ObjectId of the current Subassembly being applied.
CurrentSubassemblyName | Gets the name of the current Subassembly being applied.
CurrentSubassemblyOffset | Returns the offset from assembly origin where the current subassembly is being applied.
LayoutModeDisplayType | Gets or sets the corridor state's display mode.
Links | Gets the collection of links.
Mode | Gets corridor state's mode.
ParamsAlignment | Gets the collection of alignment parameters.
ParamsAlignmentGlobal | ParamsAlignmentGlobal
ParamsBool | Gets the collection of boolean parameters.
ParamsBoolGlobal | ParamsBoolGlobal
ParamsDouble | Gets the collection of double parameters.
ParamsDoubleGlobal | ParamsDoubleGlobal
ParamsElevationTarget | Gets the collection of elevation parameters.
ParamsElevationTargetGlobal | ParamsElevationGlobal
ParamsLong | Gets the collection of long parameters.
ParamsLongGlobal | ParamsLongGlobal
ParamsOffsetTarget | Gets the collection of offset target parameters.
ParamsOffsetTargetGlobal | ParamsOffsetTargetGlobal
ParamsPoint | Gets the collection of marked point parameters.
ParamsPointGlobal | ParamsPointGlobal
ParamsProfile | Gets the collection of profile parameters.
ParamsProfileGlobal | ParamsProfileGlobal
ParamsString | Gets the collection of string parameters.
ParamsStringGlobal | ParamsStringGlobal
ParamsSurface | Gets the collection of surface parameters.
ParamsSurfaceGlobal | ParamsSurfaceGlobal
Points | Gets the collection of points.
ResourceString | Converts a resource id (numeric) to a resource string from the current subassembly's resource module.
Shapes | Gets the collection of shapes.


IParam Members Public Properties
IParam Members
Public Properties
Public Property | Description
Access | Gets or sets access permissions for the parameter.
Comment | Gets or sets the comment string for the parameter.
Description | Gets or sets the description for the parameter.
DisplayName | Gets or sets the display name for the parameter.
DisplayOrder | Gets or sets the display order for the parameter.
IsReadOnly | Gets or sets whether the parameter is read-only.
Value | Gets or sets the parameter value.


ParamAlignment Members Public Properties
ParamAlignment Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamAlignmentCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Members
ParamAlignmentCollection Members Public Methods
ParamAlignmentCollection Members
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Members
Legend
Legend
Method
public
virtual


ParamAlignmentCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Members
ParamAlignmentCollection Members Public Properties
ParamAlignmentCollection Members
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Members
Legend
Legend
Property
public


ParamBase Members Public Nested Types
ParamBase Members
Public Nested Types
Public Nested Type | Description
InnerType | This is nested type Autodesk::Civil::Runtime::ParamBase::InnerType.
TCast | This is nested type Autodesk::Civil::Runtime::ParamBase::TCast.
ValueType | This is nested type Autodesk::Civil::Runtime::ParamBase::ValueType.


Public Nested Types

Legend
Legend
public


ParamBase Members Public Properties
ParamBase Members
Public Properties
Public Property | Description
Access | Gets or sets access permissions for the parameter.
Comment | Gets or sets the comment string for the parameter.
Description | Gets or sets the description for the parameter.
DisplayName | Gets or sets the display name for the parameter.
DisplayOrder | Gets or sets the display order for the parameter.
IsReadOnly | Gets or sets whether the parameter is read-only.
Value | Gets or sets the parameter value.


ParamBool Members Public Properties
ParamBool Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | The sub-type of the boolean parameter.
Value | Gets or sets the parameter value.


ParamBoolCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Members
ParamBoolCollection Members Public Methods
ParamBoolCollection Members
Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Members
Legend
Legend
Method
public
virtual


ParamBoolCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Members
ParamBoolCollection Members Public Properties
ParamBoolCollection Members
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Members
Legend
Legend
Property
public


ParamCollectionBase Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Members
ParamCollectionBase Members Public Methods
ParamCollectionBase Members
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Members
Legend
Legend
Method
public
virtual


ParamCollectionBase Members Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Members
ParamCollectionBase Members Public Nested Types
ParamCollectionBase Members
Public Nested Types
Public Nested Type | Description
InnerType | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::InnerType.
TCast | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::TCast.
ValueType | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::ValueType.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Members
Legend
Legend
public


ParamCollectionBase Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Members
ParamCollectionBase Members Public Properties
ParamCollectionBase Members
Public Properties
Public Property | Description
Count | Gets the number of objects in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Members
Legend
Legend
Property
public


ParamDouble Members Public Properties
ParamDouble Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | Gets or sets the type information for this parameter.
Value | Gets or sets the parameter value.


ParamDoubleCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Members
ParamDoubleCollection Members Public Methods
ParamDoubleCollection Members
Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Members
Legend
Legend
Method
public
virtual


ParamDoubleCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Members
ParamDoubleCollection Members Public Properties
ParamDoubleCollection Members
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Members
Legend
Legend
Property
public


ParamElevationTarget Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Members
ParamElevationTarget Members Public Properties
ParamElevationTarget Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Members
Legend
Legend
Property
public


ParamElevationTargetCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Members
ParamElevationTargetCollection Members Public Methods
ParamElevationTargetCollection Members
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Members
Legend
Legend
Method
public
virtual


ParamElevationTargetCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Members
ParamElevationTargetCollection Members Public Properties
ParamElevationTargetCollection Members
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Members
Legend
Legend
Property
public


ParamLong Members Public Methods
ParamLong Members
Public Methods
Public Method | Description
AddEnumData | Gets the name, display name, and value for the enum specified by name.
EnumCount | Gets the number of values in the enums for this parameter.
GetEnumData | Gets the name, display name, and value for the enum specified by index.


ParamLong Members Public Properties
ParamLong Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | Gets or sets the type information for this parameter.
Value | Gets or sets the parameter value.


ParamLongCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Members
ParamLongCollection Members Public Methods
ParamLongCollection Members
Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Members
Legend
Legend
Method
public
virtual


ParamLongCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Members
ParamLongCollection Members Public Properties
ParamLongCollection Members
Public Properties
Public Property | Description
Count | This is Count, a member of class ParamLongCollection.
default | This is default, a member of class ParamLongCollection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Members
Legend
Legend
Property
public


ParamOffsetTarget Members Public Properties
ParamOffsetTarget Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamOffsetTargetCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Members
ParamOffsetTargetCollection Members Public Methods
ParamOffsetTargetCollection Members
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Members
Legend
Legend
Method
public
virtual


ParamOffsetTargetCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Members
ParamOffsetTargetCollection Members Public Properties
ParamOffsetTargetCollection Members
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Members
Legend
Legend
Property
public


ParamPoint Members Public Methods
ParamPoint Members
Public Methods
Public Method | Description
GetPoint | Gets the station, offset, and elevation associated with the parameter.
SetPoint | Sets the station, offset, and elevation associated with the parameter.


ParamPoint Members Public Properties
ParamPoint Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
Elevation | Gets or sets the elevation associated with the parameter.
IsReadOnly | Read only state for the parameter.
Offset | Gets or sets the offset associated with the parameter.
Station | Gets or sets the station associated with the parameter.
Value | Gets or sets the parameter value.


ParamPointCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Members
ParamPointCollection Members Public Methods
ParamPointCollection Members
Public Methods
Public Method | Description
Add | Overloaded
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Members
Legend
Legend
Method
public
virtual


ParamPointCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Members
ParamPointCollection Members Public Properties
ParamPointCollection Members
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Members
Legend
Legend
Property
public


ParamProfile Members Public Properties
ParamProfile Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamProfileCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Members
ParamProfileCollection Members Public Methods
ParamProfileCollection Members
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Members
Legend
Legend
Method
public
virtual


ParamProfileCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Members
ParamProfileCollection Members Public Properties
ParamProfileCollection Members
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Members
Legend
Legend
Property
public


ParamString Members Public Properties
ParamString Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamStringCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Members
ParamStringCollection Members Public Methods
ParamStringCollection Members
Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Members
Legend
Legend
Method
public
virtual


ParamStringCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Members
ParamStringCollection Members Public Properties
ParamStringCollection Members
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Members
Legend
Legend
Property
public


ParamSurface Members Public Properties
ParamSurface Members
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamSurfaceCollection Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Members
ParamSurfaceCollection Members Public Methods
ParamSurfaceCollection Members
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Members
Legend
Legend
Method
public
virtual


ParamSurfaceCollection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Members
ParamSurfaceCollection Members Public Properties
ParamSurfaceCollection Members
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Members
Legend
Legend
Property
public


PipeNetworkState Members Public Methods
PipeNetworkState Members
Public Methods
Public Method | Description
RuleResourceString | Resolves resource string ids defined inside the C3DPipeRules.DVB project.
SetAlignmentOnPart | Sets the specified parameter of alignment on the current part.
SetBoolOnPart | Sets the specified parameter of bool on the current part.
SetDoubleOnCurrentPart | Sets an double value on the current part for the specified parameter.
SetErrorMsgOnCurrentPart | Sets an error message on the current part for the specified parameter.
SetLongOnPart | Sets the specified parameter of long on the current part.
SetPointOnPart | Sets the specified parameter of point on the current part.
SetProfileOnPart | Sets the specified parameter of profile on the current part.
SetStringOnPart | Sets the specified parameter of string on the current part.
SetSurfaceOnPart | Sets the specified parameter of surface on the current part.


PipeNetworkState Members Public Properties
PipeNetworkState Members
Public Properties
Public Property | Description
CurrentMacroName | Gets the current macro name.
CurrentMacroProject | Gets the current macro project.
CurrentPipeId | Gets the ID of the current pipe in the network.
CurrentStructureId | Gets the ID of the current structure in the network.
IsBreakingPipe | Gets the state if it's breaking a pipe
IsConnectingToStructure | Gets the state if it's connecting to a structure
IsCurrentPartBeingAdd | Gets the state if the current part is being added.
IsInLayoutMode | Returns whether the pipe network is in layout mode.
IsLayoutUpStream | Gets the state if 'upstream' is the current layout flow direction
LastPipeElevation | Gets or sets the elevation of the last pipe in the network.
ParamsBool | Gets a collection of parameters with boolean values associated with the network state.
ParamsDouble | Gets a collection of parameters with double values associated with the network state.
ParamsLong | Gets a collection of parameters with long values associated with the network state.


RuntimeState Members Public Properties
RuntimeState Members
Public Properties
Public Property | Description
CurrentMacroName | Gets the current macro name.
CurrentMacroProject | Gets the current macro project.


SettingsAbbreviation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Members
SettingsAbbreviation Members Public Properties
SettingsAbbreviation Members
Public Properties
Public Property | Description
AlignmentGeoPointEntityData | Gets Abbreviation settings of Alignment Geometry Point Entity Data
AlignmentGeoPointText | Gets Abbreviation settings of Alignment Geometry Point Text
GeneralText | Gets Abbreviation settings that are not feature specific.
Profile | Gets Abbreviation settings of Profile
Superelevation | Gets Abbreviation settings of Superelevation


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Members
Legend
Legend
Property
public


SettingsAmbient Members Classes
SettingsAmbient Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


SettingsAmbient Members Public Properties
SettingsAmbient Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


SettingsAmbient Members Templates
SettingsAmbient Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


SettingsAmbient::SettingsAngle Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsAngle Class > SettingsAmbient::SettingsAngle Members
SettingsAmbient::SettingsAngle Members Public Properties
SettingsAmbient::SettingsAngle Members
Public Properties
Public Property | Description
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsAngle Class > SettingsAmbient::SettingsAngle Members
Legend
Legend
Property
public


SettingsAmbient::SettingsDirection Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Members
SettingsAmbient::SettingsDirection Members Public Properties
SettingsAmbient::SettingsDirection Members
Public Properties
Public Property | Description
BearingQuadrant | Specifies which bearing quadrant to use.
Capitalization | Specifies how to display direction names.
Direction | Specify how to display directions.
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.
MeasurementType | Specifies how to calculate the direction of a vector.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Members
Legend
Legend
Property
public


SettingsFormatNumber Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsFormatNumber Template > SettingsFormatNumber Members
SettingsFormatNumber Members Public Properties
SettingsFormatNumber Members
Public Properties
Public Property | Description
Format | Specifies the format of the measurement.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsFormatNumber Template > SettingsFormatNumber Members
Legend
Legend
Property
public


SettingsAmbient::SettingsGeneral Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Members
SettingsAmbient::SettingsGeneral Members Public Properties
SettingsAmbient::SettingsGeneral Members
Public Properties
Public Property | Description
DrivingDirection | Specifies the direction of traffic on the roadway.
IndependentLayerOn | Specifies whether object display is controlled by layer visibility, This is equivalent to SettingsObjectLayers.ObjectControlledByLayer
NewEntityToolTipState | Specifies whether to display tooltips by default for new objects.
PlottedUnitDisplay | Specifies how to display numbers in interface controls and on the command line.
SaveCommandChangesToSettings | Specifies whether any changes made to the settings during a command are saved for the drawing, even if the setting... more
ShowEventViewer | Specifies whether the Event Viewer is displayed automatically when an event occurs.
ShowToolTips | Specifies whether to display tooltips in the drawing. This setting does not affect tooltips for toolbar icons.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Members
Legend
Legend
Property
public


SettingsAmbient::SettingsLabeling Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLabeling Class > SettingsAmbient::SettingsLabeling Members
SettingsAmbient::SettingsLabeling Members Public Properties
SettingsAmbient::SettingsLabeling Members
Public Properties
Public Property | Description
PromptMethod | Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLabeling Class > SettingsAmbient::SettingsLabeling Members
Legend
Legend
Property
public


SettingsAmbient::SettingsLatLong Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Members
SettingsAmbient::SettingsLatLong Members Public Properties
SettingsAmbient::SettingsLatLong Members
Public Properties
Public Property | Description
Capitalization | Specifies how to display direction names.
Direction | Specifies the format of lat/long labels.
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Members
Legend
Legend
Property
public


SettingsAmbient::SettingsStation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Members
SettingsAmbient::SettingsStation Members Public Properties
SettingsAmbient::SettingsStation Members
Public Properties
Public Property | Description
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosRightOfStationCharacter | Drops leading zeros before the station character for whole number station values.
MinimumDisplayWidth | Specifies the minimum display width for the station value, which allows leading zeros to be added if necessary. For example,... more
StationDelimiterCharacter | Specifies the separator character used to display stations.
StationDelimiterPosition | Specifies the scale to use for major stations.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Members
Legend
Legend
Property
public


SettingsAmbient::SettingsTransparentCommands Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Members
SettingsAmbient::SettingsTransparentCommands Members Public Properties
SettingsAmbient::SettingsTransparentCommands Members
Public Properties
Public Property | Description
PromptFor3DPoints | Specifies the prompt sequence (X,Y or X, Y, Z) when creating a point in 3D. True (prompt for 3D points),... more
PromptForEastingThenNorthing | Specifies whether commands prompt for the Easting before the Northing: True (Easting first),False (Northing first)
PromptForLongitudeThenLatitude | Specifies whether commands prompt for the Longitude before the Latitude: False (Latitude first),True (Longitude first)
PromptForYBeforeX | Specifies whether commands prompt for the Y coordinate before the X coordinate: True (Y first),False (X first)


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Members
Legend
Legend
Property
public


SettingsUnitlessNumber Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class > SettingsUnitlessNumber Members
SettingsUnitlessNumber Members Public Properties
SettingsUnitlessNumber Members
Public Properties
Public Property | Description
Precision | Specifies the number of digits to show to the right of the decimal.
Rounding | Specifies how numbers are rounded up or down to the number of decimal places specified in Precision.
Sign | Specifies how to mark numbers as positive or negative.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class > SettingsUnitlessNumber Members
Legend
Legend
Property
public


SettingsUnitNumber Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsUnitNumber Template > SettingsUnitNumber Members
SettingsUnitNumber Members Public Properties
SettingsUnitNumber Members
Public Properties
Public Property | Description
Unit | Specifies the unit of the measurement.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsUnitNumber Template > SettingsUnitNumber Members
Legend
Legend
Property
public


TUnit Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template > TUnit Members
TUnit Members Public Properties
TUnit Members
Public Properties
Public Property | Description
Format | Specifies the format of the measurement.
Unit | Specifies the unit of the measurement.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template > TUnit Members
Legend
Legend
Property
public


SettingsCmdCreateArcByBestFit Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Members
SettingsCmdCreateArcByBestFit Members Classes
SettingsCmdCreateArcByBestFit Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Members
Legend
Legend
Class


SettingsCmdCreateArcByBestFit Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Members
SettingsCmdCreateArcByBestFit Members Public Properties
SettingsCmdCreateArcByBestFit Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Members
Legend
Legend
Property
public


SettingsCmdCreateArcByBestFit Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Members
SettingsCmdCreateArcByBestFit Members Templates
SettingsCmdCreateArcByBestFit Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Members
Legend
Legend
Template


SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members Public Properties
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members
Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Members
Legend
Legend
Property
public


SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members Public Properties
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Members
Legend
Legend
Property
public


SettingsCmdCreateLineByBestFit Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Members
SettingsCmdCreateLineByBestFit Members Classes
SettingsCmdCreateLineByBestFit Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Members
Legend
Legend
Class


SettingsCmdCreateLineByBestFit Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Members
SettingsCmdCreateLineByBestFit Members Public Properties
SettingsCmdCreateLineByBestFit Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Members
Legend
Legend
Property
public


SettingsCmdCreateLineByBestFit Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Members
SettingsCmdCreateLineByBestFit Members Templates
SettingsCmdCreateLineByBestFit Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Members
Legend
Legend
Template


SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members Public Properties
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members
Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Members
Legend
Legend
Property
public


SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members Public Properties
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Members
Legend
Legend
Property
public


SettingsCmdCreateParabolaByBestFit Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Members
SettingsCmdCreateParabolaByBestFit Members Classes
SettingsCmdCreateParabolaByBestFit Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Members
Legend
Legend
Class


SettingsCmdCreateParabolaByBestFit Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Members
SettingsCmdCreateParabolaByBestFit Members Public Properties
SettingsCmdCreateParabolaByBestFit Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Members
Legend
Legend
Property
public


SettingsCmdCreateParabolaByBestFit Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Members
SettingsCmdCreateParabolaByBestFit Members Templates
SettingsCmdCreateParabolaByBestFit Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Members
Legend
Legend
Template


SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members Public Properties
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members
Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Members
Legend
Legend
Property
public


SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members Public Properties
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Members
Legend
Legend
Property
public


SettingsCmdMapCheck Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Members
SettingsCmdMapCheck Members Classes
SettingsCmdMapCheck Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Members
Legend
Legend
Class


SettingsCmdMapCheck Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Members
SettingsCmdMapCheck Members Public Properties
SettingsCmdMapCheck Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Mapcheck | Use these settings to specify the default behavior for Mapcheck.
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Members
Legend
Legend
Property
public


SettingsCmdMapCheck Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Members
SettingsCmdMapCheck Members Templates
SettingsCmdMapCheck Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Members
Legend
Legend
Template


SettingsCmdMapCheck::SettingsCmdMapcheck Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Members
SettingsCmdMapCheck::SettingsCmdMapcheck Members Public Properties
SettingsCmdMapCheck::SettingsCmdMapcheck Members
Public Properties
Public Property | Description
CurrentMapcheckColor | Specifies the color for the current mapcheck.
CurrentPointofBeginningColor | Specifies the color of the beginning not for a selected mapcheck.
CurrentSideColor | Specifies the color for the current selected side.
DefaultAngleType | Specifies the default type of any angle created using Mapcheck.
DefaultCurveDirection | Specifies the default direction of any curve created using Mapcheck.
DefaultCurveTraverseMethod |
DefaultSideType | Specifies the default type of any side created using Mapcheck.
MapcheckColor | Specifies the color for Mapcheck lines and curves which are not part of the current mapcheck.
UseCommandLineInput | Specifies whether Mapcheck will accept commands from the command line interface. Selecting No causes Mapcheck to accept input only from... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Members
Legend
Legend
Property
public


SettingsCoordinateSystem Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Members
SettingsCoordinateSystem Members Public Properties
SettingsCoordinateSystem Members
Public Properties
Public Property | Description
Category | Gets the coordinate system geographic zone.
Code | Gets the coordinate system code string.
Datum | Gets the abbreviation for the datum on which the coordinate system is based.
Description | Gets the description for the selected zone.
Projection | Gets the projection method, which is the basis of the zone computation.
Unit | Gets the coordinate system unit.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Members
Legend
Legend
Property
public


SettingsDrawing Members Public Properties
SettingsDrawing Members
Public Properties
Public Property | Description
AbbreviationsSettings | Gets Abbreviations of Drawing settings.
AmbientSettings | Gets Ambient setting of the drawing.
ApplyTransformSettings | Gets or sets the boolean value that specifies whether to apply the settings for coordinate system zone transformation.
ObjectLayerSettings | Gets the Object layer settings for various objects in AutoCAD Civil 3D. For example, you can specify that you want... more
TransformationSettings | Gets Transformation of Drawing settings.
UnitZoneSettings | Gets UnitZone of Drawing settings.


SettingsGeneral Members Classes
SettingsGeneral Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


SettingsGeneral Members Public Properties
SettingsGeneral Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for general.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


SettingsGeneral Members Templates
SettingsGeneral Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


SettingsGeneral::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral::SettingsStyles Class > SettingsGeneral::SettingsStyles Members
SettingsGeneral::SettingsStyles Members Public Properties
SettingsGeneral::SettingsStyles Members
Public Properties
Public Property | Description
CurveLabel | Gets the default style to use when inserting Curve labels.
LineLabel | Gets the default style to use when inserting Line labels.
NoteLabel | Gets the default style to use when inserting Note labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral::SettingsStyles Class > SettingsGeneral::SettingsStyles Members
Legend
Legend
Property
public


SettingsLandXML Members Public Properties
SettingsLandXML Members
Public Properties
Public Property | Description
Export | Export settings for landXML.
Import | Import settings for landXML.


SettingsLandXMLExport Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Members
SettingsLandXMLExport Members Public Properties
SettingsLandXMLExport Members
Public Properties
Public Property | Description
AlignmentExport | AlignmentExport settings for LandXML exporting.
Data | Data settings for LandXML exporting.
Identification | Identification settings for LandXML exporting.
ParcelExport | ParcelExport settings for LandXML exporting.
PointExport | PointExport settings for LandXML exporting.
SurfaceExport | SurfaceExport settings for LandXML exporting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Members
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsAlignmentExport Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsAlignmentExport Class > SettingsLandXMLExport::SettingsAlignmentExport Members
SettingsLandXMLExport::SettingsAlignmentExport Members Public Properties
SettingsLandXMLExport::SettingsAlignmentExport Members
Public Properties
Public Property | Description
ExportCrossSections | Exports cross section data if sample lines are defined for the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsAlignmentExport Class > SettingsLandXMLExport::SettingsAlignmentExport Members
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsData Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsData Class > SettingsLandXMLExport::SettingsData Members
SettingsLandXMLExport::SettingsData Members Public Properties
SettingsLandXMLExport::SettingsData Members
Public Properties
Public Property | Description
AngleDirectionFormat | Specifies the units of the exported angles and directions.
CreateReadOnlyFile | Specifies whether the LandXML file is created as a read-only file. This is done in two places: a tag is... more
ImperialUnits | Specifies how to tag LandXML data when working in Imperial units.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsData Class > SettingsLandXMLExport::SettingsData Members
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsIdentification Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Members
SettingsLandXMLExport::SettingsIdentification Members Public Properties
SettingsLandXMLExport::SettingsIdentification Members
Public Properties
Public Property | Description
Company | Specifies the creator’s company.
CompanyURL | Specifies the company’s URL.
Creator | Specifies the creator of the LandXML file.
EmailAddress | Specifies the creator’s email address.
WriteIdentificationElements | Specifies whether the identification properties are written to the LandXML file.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Members
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsParcelExport Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsParcelExport Class > SettingsLandXMLExport::SettingsParcelExport Members
SettingsLandXMLExport::SettingsParcelExport Members Public Properties
SettingsLandXMLExport::SettingsParcelExport Members
Public Properties
Public Property | Description
ParcelDirection | Specifies the direction from the parcel start point for exporting parcel segments. Parcel segments are exported in sequence in either... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsParcelExport Class > SettingsLandXMLExport::SettingsParcelExport Members
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsPointExport Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Members
SettingsLandXMLExport::SettingsPointExport Members Public Properties
SettingsLandXMLExport::SettingsPointExport Members
Public Properties
Public Property | Description
CodeAttribute | Specifies the field that is used for the ‘code’ attribute in the LandXML file.
DescAttribute | Specifies the field that is used for the ‘desc’ attribute in the LandXML file
ExportDescriptionKeys | Specifies whether the description key definitions are exported. Select On to export all description key definitions in the drawing. If... more
ExportPointReferences | Specifies whether to export point references. Point references substitute a known point name instead of using northing and easting coordinates.... more
PointReferenceTolerance | Specifies the tolerance value for point references.
SkipFullWhenSameAsRaw | Specifies whether to export the full description if it is the same as the raw description.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Members
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsSurfaceExport Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsSurfaceExport Class > SettingsLandXMLExport::SettingsSurfaceExport Members
SettingsLandXMLExport::SettingsSurfaceExport Members Public Properties
SettingsLandXMLExport::SettingsSurfaceExport Members
Public Properties
Public Property | Description
SurfaceData | Specifies how to export the surface data.
Watersheds | Exports both the points and the surface faces, if available. Creates the surface information from the face edges and creates... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsSurfaceExport Class > SettingsLandXMLExport::SettingsSurfaceExport Members
Legend
Legend
Property
public


SettingsLandXMLImport Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Members
SettingsLandXMLImport Members Public Properties
SettingsLandXMLImport Members
Public Properties
Public Property | Description
ConflictResolution | ConflictResolution settings for LandXML importing.
DiameterUnits | DiameterUnits settings for LandXML importing.
PipeNetwork | PipeNetwork settings for LandXML importing.
PointImport | PointImport settings for LandXML importing.
Rotation | Rotation settings for LandXML importing.
SurfaceImport | SurfaceImport settings for LandXML importing.
Translation | Translation settings for LandXML importing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Members
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsConflictResolution Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsConflictResolution Class > SettingsLandXMLImport::SettingsConflictResolution Members
SettingsLandXMLImport::SettingsConflictResolution Members Public Properties
SettingsLandXMLImport::SettingsConflictResolution Members
Public Properties
Public Property | Description
ConflictResolution | Specifies how objects with the same name are handled.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsConflictResolution Class > SettingsLandXMLImport::SettingsConflictResolution Members
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsDiameterUnits Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsDiameterUnits Class > SettingsLandXMLImport::SettingsDiameterUnits Members
SettingsLandXMLImport::SettingsDiameterUnits Members Public Properties
SettingsLandXMLImport::SettingsDiameterUnits Members
Public Properties
Public Property | Description
Imperial | Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source... more
Metric | Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsDiameterUnits Class > SettingsLandXMLImport::SettingsDiameterUnits Members
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsPipeNetwork Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Members
SettingsLandXMLImport::SettingsPipeNetwork Members Public Properties
SettingsLandXMLImport::SettingsPipeNetwork Members
Public Properties
Public Property | Description
MatchChannelShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchCircularPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchCircularStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchConnectionStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchEggShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchEllipticalShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchInletOutletStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchRectangleShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchRectangleStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
PartsListForPartFamilySizeMatching | Specifies the pipe network parts list that is used during import to match pipe network part types in a LandXML... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Members
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsPointImport Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPointImport Class > SettingsLandXMLImport::SettingsPointImport Members
SettingsLandXMLImport::SettingsPointImport Members Public Properties
SettingsLandXMLImport::SettingsPointImport Members
Public Properties
Public Property | Description
PointDescription | Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPointImport Class > SettingsLandXMLImport::SettingsPointImport Members
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsRotation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsRotation Class > SettingsLandXMLImport::SettingsRotation Members
SettingsLandXMLImport::SettingsRotation Members Public Properties
SettingsLandXMLImport::SettingsRotation Members
Public Properties
Public Property | Description
Angle | Specifies the angle about the base point where the LandXML data is rotated.
Direction | Specifies the direction of rotation.
Rotate | Specifies whether to rotate data when importing it from the LandXML file.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsRotation Class > SettingsLandXMLImport::SettingsRotation Members
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsSurfaceImport Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Members
SettingsLandXMLImport::SettingsSurfaceImport Members Public Properties
SettingsLandXMLImport::SettingsSurfaceImport Members
Public Properties
Public Property | Description
ConvertSurveyFootToInternationalFoot | Specifies whether to convert survey foot to international foot.
CreateSnapshotAfterImport | After importing surface data, a snapshot can automatically be created. By creating a snapshot after importing a LandXML file, AutoCAD... more
CreateSourceDataInDrawing | Imports the surface source data (breaklines, contours, points, and chains) into the drawing as 3D polylines and points.
SurfaceData | Specifies how to import the data.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Members
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsTranslation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Members
SettingsLandXMLImport::SettingsTranslation Members Public Properties
SettingsLandXMLImport::SettingsTranslation Members
Public Properties
Public Property | Description
BasePointEasting | Specifies the base point easting coordinate from which all import values are translated.
BasePointElevation | Specifies the base point elevation from which all import values are translated.
BasePointNorthing | Specifies the base point northing coordinate from which all import values are translated.
Translate | Specifies whether to translate data to new coordinates when importing the data from the LandXML file.
TranslatedCoordinateEasting | Specifies the easting coordinate value used to translate data from the base point.
TranslatedCoordinateElevation | Specifies the elevation value used to translate data from the base point.
TranslatedCoordinateNorthing | Specifies the northing coordinate value used to translate data from the base point.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Members
Legend
Legend
Property
public


SettingsObjectLayer Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Members
SettingsObjectLayer Members Public Properties
SettingsObjectLayer Members
Public Properties
Public Property | Description
LayerId | Specifies the layer on which the object is drawn
LayerName | Specifies the layer on which the object is drawn.
Locked | Specifies whether layer settings are locked for the drawing to prevent overrides for individual objects.
Modifier | Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.
ModifierValue | Specifies the text string to use as the modifier. You can enter an asterisk (*) to include the object name... more
ObjectType | Get the object type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Members
Legend
Legend
Property
public


SettingsObjectLayers Members Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Members
SettingsObjectLayers Members Public Methods
SettingsObjectLayers Members
Public Methods
Public Method | Description
GetObjectLayerSetting | Gets a SettingsObjectLayer object by specifying its type.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Members
Legend
Legend
Method
public


SettingsObjectLayers Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Members
SettingsObjectLayers Members Public Properties
SettingsObjectLayers Members
Public Properties
Public Property | Description
ObjectControlledByLayer | Specifies whether object display is controlled by layer visibility.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Members
Legend
Legend
Property
public


SettingsRoot Members Public Methods
SettingsRoot Members
Public Methods
Public Method | Description
GetSettings | Gets feature settings or command settings by specifying a type.


SettingsRoot Members Public Properties
SettingsRoot Members
Public Properties
Public Property | Description
AssociateShortcutProjectId | Gets or sets the id of associate shortcut project to this drawing.
DrawingSettings | Gets the Drawing settings.
LandXMLSettings | Gets the LandXML importing/exporting settings.
TagSettings | Gets the tag settings.


SettingsTag Members Public Properties
SettingsTag Members
Public Properties
Public Property | Description
Creation | Gets the creation options of TableTag settings.
Renumbering | Gets the renumbering options of TableTag settings.


SettingsTag::SettingsCreation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Members
SettingsTag::SettingsCreation Members Public Properties
SettingsTag::SettingsCreation Members
Public Properties
Public Property | Description
CurvesIncrement | Specifies the difference between numbers in the numbering sequence.
CurvesStartingNumber | Specifies the starting number for new curve tags to be created in the site. The numbering is incremented with creation... more
LinesIncrement | Specifies the difference between numbers in the numbering sequence.
LinesStartingNumber | Specifies the starting number for new lines to be created in the site. The numbering is incremented with creation of... more
SpiralsIncrement | Specifies the difference between numbers in the numbering sequence.
SpiralsStartingNumber | Specifies the starting number for new spiral tags to be created in the site. The numbering is incremented with creation... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Members
Legend
Legend
Property
public


SettingsTag::SettingsRenumbering Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Members
SettingsTag::SettingsRenumbering Members Public Properties
SettingsTag::SettingsRenumbering Members
Public Properties
Public Property | Description
CurvesIncrement | Specifies the difference between numbers in the numbering sequence.
CurvesStartingNumber | Specifies the starting number for new curve tags to be renumbered.
LinesIncrement | Specifies the difference between numbers in the numbering sequence.
LinesStartingNumber | SettingsRenumbering.
SpiralsIncrement | Specifies the difference between numbers in the numbering sequence.
SpiralsStartingNumber | Specifies the starting number for new spiral tags to be created on alignments in the site. The numbering is incremented... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Members
Legend
Legend
Property
public


SettingsTransformation Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Members
SettingsTransformation Members Public Properties
SettingsTransformation Members
Public Properties
Public Property | Description
ApplySeaLevelScaleFactor | Gets or sets the boolean value that specifies whether to apply the settings for curvature correction to survey data so... more
GridReferencePoint | Gets or sets the grid reference point value used to associate local coordinates to grid coordinates.
GridRotationPoint | Gets or sets the grid rotation point that specifies a rotation about the grid reference point.
GridScaleFactor | Gets or sets a positive value for the grid scale factor.
GridScaleFactorComputation | Gets or sets the GridScaleFactorType enum value that specifies the type of scale factor.
LocalReferencePoint | Gets or sets the local reference point value used to associate local coordinates to grid coordinates.
LocalRotationPoint | Gets or sets the local rotation point that specifies a rotation about the local reference point.
RotationToGridAzimuth | Gets or sets the direction of the azimuth for the grid rotation angle in degree units.
RotationToGridNorth | Gets or sets the angle to grid north for the grid rotation angle in degree units.
SeaLevelScaleElevation | Gets or sets the mean elevation value of your project site with respect to the mean sea level.
SpecifyRotationType | Gets or sets an enumeration value that specify the rotation type.
SpheroidRadius | Gets the spheroid radius for the spheroid used by the coordinate system.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Members
Legend
Legend
Property
public


SettingsUnitZone Members Public Methods
SettingsUnitZone Members
Public Methods
Public Method | Description
GetAllCodes | Gets an array that specifies all avilable code strings.
GetCoordinateSystemByCode | Gets an coordinate system by an code string.


SettingsUnitZone Members Public Properties
SettingsUnitZone Members
Public Properties
Public Property | Description
AngularUnits | Gets or sets the AngleUnitType enum value that specifies the units in which angles are displayed.
CoordinateSystemCode | Gets the coordinate system code string.
DrawingScale | Gets the plotted size of various annotation-related components, such as label text, ticks, and band heights. If you change the... more
DrawingUnits | Gets the linear unit, either meters or feet, for distances, lengths, widths, and offsets in a drawing.
ImperialToMetricConversion | Gets or sets the foot to meter conversion flag that determines what the unit "foot" means.
MatchAutoCADVariables | Synchronizes AutoCAD settings with Autodesk Civil 3D settings. Deprecated. Gets or sets the boolean value that specifies whether synchronizes AutoCAD... more
ScaleObjectsFromOtherDrawings | Gets or sets the boolean value that specifies whether objects inserted from another drawing will be scaled if necessary to... more


SettingsSurvey Members Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Members
SettingsSurvey Members Classes
SettingsSurvey Members
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Members
Legend
Legend
Class


SettingsSurvey Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Members
SettingsSurvey Members Public Properties
SettingsSurvey Members
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
Styles | Gets the default styles for survey features.
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Members
Legend
Legend
Property
public


SettingsSurvey Members Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Members
SettingsSurvey Members Templates
SettingsSurvey Members
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Templates

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Members
Legend
Legend
Template


SettingsSurvey::SettingsStyles Members Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class > SettingsSurvey::SettingsStyles Members
SettingsSurvey::SettingsStyles Members Public Properties
SettingsSurvey::SettingsStyles Members
Public Properties
Public Property | Description
Figure | Gets the default style for a survey figure.
Network | Gets the default style for a survey network.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class > SettingsSurvey::SettingsStyles Members
Legend
Legend
Property
public


SettingsAmbient Classes Classes
SettingsAmbient Classes
Classes
Class | Description
SettingsUnitlessNumber | Representing a unitless number's settings, this is the base class for many other number based measurement


AnchorInfo Constructors Public Methods
AnchorInfo Constructors
Public Methods
Public Method | Description
AnchorInfo | This is AnchorInfo, a member of class AnchorInfo.


AlignmentDesignCheckRoot Constructors Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Constructors
AlignmentDesignCheckRoot Constructors Public Methods
AlignmentDesignCheckRoot Constructors
Public Methods
Public Method | Description
AlignmentDesignCheckRoot | Constructor of AlignmentDesignCheckRoot class.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Constructors
Legend
Legend
Constructor
public


SuperElevationDataElement Constructors Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Constructors
SuperElevationDataElement Constructors Public Methods
SuperElevationDataElement Constructors
Public Methods
Public Method | Description
SuperElevationDataElement | Default constructor for SuperElevationDataElement, object's data should be set by it's properties.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Constructors
Legend
Legend
Constructor
public


GeometryPointSelector Constructors Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Constructors
GeometryPointSelector Constructors Public Methods
GeometryPointSelector Constructors
Public Methods
Public Method | Description
GeometryPointSelector | This is GeometryPointSelector, a member of class GeometryPointSelector.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Constructors
Legend
Legend
Constructor
public


ProfileDesignCheckRoot Constructors Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Constructors
ProfileDesignCheckRoot Constructors Public Methods
ProfileDesignCheckRoot Constructors
Public Methods
Public Method | Description
ProfileDesignCheckRoot | Constructor of ProfileDesignCheckRoot class.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Constructors
Legend
Legend
Constructor
public


PartDef Constructors Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Constructors
PartDef Constructors Public Methods
PartDef Constructors
Public Methods
Public Method | Description
PartDef | This is PartDef, a member of class PartDef.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Constructors
Legend
Legend
Constructor
public


SlopeElevationTarget Constructors Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Constructors
SlopeElevationTarget Constructors Public Methods
SlopeElevationTarget Constructors
Public Methods
Public Method | Description
SlopeElevationTarget | This is SlopeElevationTarget, a member of class SlopeElevationTarget.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Constructors
Legend
Legend
Constructor
public


SubassemblyGenerator Constructors Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Constructors
SubassemblyGenerator Constructors Public Methods
SubassemblyGenerator Constructors
Public Methods
Public Method | Description
SubassemblyGenerator | Constructor.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Constructors
Legend
Legend
Constructor
public


WidthOffsetTarget Constructors Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Constructors
WidthOffsetTarget Constructors Public Methods
WidthOffsetTarget Constructors
Public Methods
Public Method | Description
WidthOffsetTarget | This is WidthOffsetTarget, a member of class WidthOffsetTarget.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Constructors
Legend
Legend
Constructor
public


Constant Data Members Public Data Members
Constant Data Members
Public Data Members
Public Data Member | Description
VerticalGrade | This is VerticalGrade, a member of class Constant.


AnchorInfo Data Members Public Data Members
AnchorInfo Data Members
Public Data Members
Public Data Member | Description
CenterOfCurve | This is CenterOfCurve, a member of class AnchorInfo.
DirectionAtLocation | This is DirectionAtLocation, a member of class AnchorInfo.
IsOnCurve | This is IsOnCurve, a member of class AnchorInfo.
Location | This is Location, a member of class AnchorInfo.


CivilDocument Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods
CivilDocument Methods Public Methods
CivilDocument Methods
Public Methods
Public Method | Description
GetAlignmentIds | Gets the objectId collection of all Alignment objects in the drawing.
GetAlignmentTableIds | Gets the objectId collection of all alignment tables.
GetAllPointIds | Gets the objectId collection of all points in the drawing.
GetIntersectionIds | Gets the objectId collection of all intersection objects in the drawing.
GetLegendTableIds | Gets the objectId collection of legend tables.
GetParcelSegmentTableIds | Gets the objectId collection of parcel segment tables.
GetParcelTableIds | Gets the objectId collection of parcel tables.
GetPipeNetworkIds | Gets the pipe network object id collection.
GetPointTableIds | Gets the objectId collection of point tables.
GetSiteIds | Gets the objectId collection of all site objects in the drawing.
GetSitelessAlignmentId | Gets the objectId of a siteless Alignment object by name.
GetSitelessAlignmentIds | Gets the objectId collection of all siteless Alignment objects in the drawing.
GetSurfaceIds | Gets the objectId collection of all surface objects in the drawing.
GetViewFrameGroupIds | Gets the objectId collection of all view frame groups in the drawing.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Methods
Legend
Legend
Method
public


AutoFeatureLabelGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Methods
AutoFeatureLabelGroup Methods Public Methods
AutoFeatureLabelGroup Methods
Public Methods
Public Method | Description
SetRange | Sets both range parameters (start and end) at once.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Methods
Legend
Legend
Method
public


Feature Methods Public Methods
Feature Methods
Public Methods
Public Method | Description
IsEditableFeature | Check whether the Feature-derived entity (Alignment,Profile,etc) is editable.


ICommonLabel Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods
ICommonLabel Methods Public Methods
ICommonLabel Methods
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Methods
Legend
Legend
Method
public


Label Methods Public Methods
Label Methods
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded


LabelGroup Methods Public Methods
LabelGroup Methods
Public Methods
Public Method | Description
GetAt | Gets one LabelGroupSubEntity from label group according the index.
ResetAllSubCommonLabelLocations | Resets the location of all the sub-entity labels to their defaults.
ResetAllSubCommonLabelProperties | Resets the properties of all the sub-entity labels to their defaults.
ResetAllSubCommonLabels | Resets all the sub-entity labels (properties and location).


LabelGroupSubEntity Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods
LabelGroupSubEntity Methods Public Methods
LabelGroupSubEntity Methods
Public Methods
Public Method | Description
ClearAllTextComponentOverrides | Clears all text component overrides in the label.
GetTextComponentIds | Gets a collection of object ids that represent the text components in a label.
GetTextComponentJustificationOverride | Get the overriden justification on the specified text component.
GetTextComponentOverride | Get the overriden text on the specified text component.
IsTextComponentOverriden | Returns whether the specified text component is overridden.
Reset | Resets the label object to its defaults.
ResetLocation | Resets the location of the label object to its default.
ResetProperties | Resets the properties of the label object to its defaults.
SetTextComponentJustificationOverride | Overrides the justification on the specified text component.
SetTextComponentOverride | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Methods
Legend
Legend
Method
public
virtual


BandSetItemCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Methods
BandSetItemCollection Methods Public Methods
BandSetItemCollection Methods
Public Methods
Public Method | Description
Remove | Removes an item from the collection.
Swap | Swap two items in the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Methods
Legend
Legend
Method
public


BandStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class > BandStyleCollection Methods
BandStyleCollection Methods Public Methods
BandStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class > BandStyleCollection Methods
Legend
Legend
Method
public
virtual


BaseLabelSetStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Methods
BaseLabelSetStyle Methods Public Methods
BaseLabelSetStyle Methods
Public Methods
Public Method | Description
Add | Overloaded
RemoveAt | Removes an label set item from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Methods
Legend
Legend
Method
public


ColumnStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Methods
ColumnStyleCollection Methods Public Methods
ColumnStyleCollection Methods
Public Methods
Public Method | Description
Add | Adds a ColumnStyle to the collection using column width and value, 0 width for auto width.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes column style by index in the collection, the first column of the collection cannot be removed.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Methods
Legend
Legend
Method
public
virtual


ExpressionCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Methods
ExpressionCollection Methods Public Methods
ExpressionCollection Methods
Public Methods
Public Method | Description
Add | Adds a Expression by specifying the name and expression string.
Clear | Removes all Expressions from the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an Expression from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Methods
Legend
Legend
Method
public
virtual


FeatureLineStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Methods
FeatureLineStyle Methods Public Methods
FeatureLineStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the FeatureLine component.
GetFeatureLineDisplayStyleModel | Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.
GetFeatureLineDisplayStylePlan | Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.
GetSectionMarkerDisplayStyleSection | Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Methods
Legend
Legend
Method
public


FeatureLineStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class > FeatureLineStyleCollection Methods
FeatureLineStyleCollection Methods Public Methods
FeatureLineStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class > FeatureLineStyleCollection Methods
Legend
Legend
Method
public
virtual


LabelStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods
LabelStyle Methods Public Methods
LabelStyle Methods
Public Methods
Public Method | Description
AddChild | Add a new child label style to the current label style's node with the default setings' value.
AddComponent | Add a valid component into the label style.
AddReferenceTextComponent | Add ReferenceText component into the label style.
AddTextForEachComponent | Add TextForEach component into the label style.
GetComponents | Gets the objectId collection of label style components that specify the appearance and behavior of labels.
GetComponentsCount | Overloaded
GetComponentsDrawOrder | Gets the supported components in draw order, component at the end(as UI list on the top) is drawn last.
IsSupportedComponent | Gets an bool value specifies whether the component type is supported in this label style.
RemoveAllDescendants | Removes all the descendants under the current labelstyle node.
RemoveChild | Overloaded
RemoveComponent | Remove a component from the label style.
SetComponentsDrawOrder | Sets the supported components' draw order.
SwitchComponentsDrawOrder | Switch the supported components' draw order by index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Methods
Legend
Legend
Method
public


LabelStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Methods
LabelStyleCollection Methods Public Methods
LabelStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Methods
Legend
Legend
Method
public
virtual


MarkerStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Methods
MarkerStyle Methods Public Methods
MarkerStyle Methods
Public Methods
Public Method | Description
GetMarkerDisplayStyleProfile | Gets the marker display style for profile views.
GetMarkerDisplayStyleSection | Gets the marker display style for section views.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Methods
Legend
Legend
Method
public
virtual


MarkerStyleBase Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Methods
MarkerStyleBase Methods Public Methods
MarkerStyleBase Methods
Public Methods
Public Method | Description
GetMarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
GetMarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Methods
Legend
Legend
Method
public


MarkerStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class > MarkerStyleCollection Methods
MarkerStyleCollection Methods Public Methods
MarkerStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class > MarkerStyleCollection Methods
Legend
Legend
Method
public
virtual


ProjectionStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Methods
ProjectionStyle Methods Public Methods
ProjectionStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Methods
Legend
Legend
Method
public


ProjectionStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class > ProjectionStyleCollection Methods
ProjectionStyleCollection Methods Public Methods
ProjectionStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class > ProjectionStyleCollection Methods
Legend
Legend
Method
public
virtual


SegmentColumnStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Methods
SegmentColumnStyle Methods Public Methods
SegmentColumnStyle Methods
Public Methods
Public Method | Description
GetContentString | Gets the specified display content of segment column style.
GetContentStringFormatted | Gets the specified formatted content of segment column style.
SetContentString | Sets the specified display content of segment column style.
SetContentStringFormatted | Sets the specified formatted content of segment column style.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class > SegmentColumnStyle Methods
Legend
Legend
Method
public


StructureColumnComponents Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Methods
StructureColumnComponents Methods Public Methods
StructureColumnComponents Methods
Public Methods
Public Method | Description
AddComponent | Adds a table cell component data to the collection with the default Content("Structure Text") and Justification(Center).
Clear | Removes all the table cell component data from the collection.
RemoveAt | Overloaded
SwitchComponentsOrder | Switch the component data order by index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Methods
Legend
Legend
Method
public


StructureColumnStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Methods
StructureColumnStyle Methods Public Methods
StructureColumnStyle Methods
Public Methods
Public Method | Description
GetComponents | Gets the table cell components from the structure column style.
SetComponents | Sets the table cell components to the structure column style.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class > StructureColumnStyle Methods
Legend
Legend
Method
public


StyleBase Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Methods
StyleBase Methods Public Methods
StyleBase Methods
Public Methods
Public Method | Description
CopyAsSibling | Copy the current style and add it to the parent node as a sibling.
ExportTo | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Methods
Legend
Legend
Method
public
virtual


StyleCollectionBase Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods
StyleCollectionBase Methods Public Methods
StyleCollectionBase Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Methods
Legend
Legend
Method
public
virtual


TableStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Methods
TableStyle Methods Public Methods
TableStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Methods
Legend
Legend
Method
public


TableStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class > TableStyleCollection Methods
TableStyleCollection Methods Public Methods
TableStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class > TableStyleCollection Methods
Legend
Legend
Method
public
virtual


DesignCheckCollection Methods Public Methods
DesignCheckCollection Methods
Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes DesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.


AlignmentDesignCheckCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Methods
AlignmentDesignCheckCollection Methods Public Methods
AlignmentDesignCheckCollection Methods
Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
Remove | Removes AlignmentDesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Methods
Legend
Legend
Method
public
virtual


Alignment Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods
Alignment Methods Public Methods
Alignment Methods
Public Methods
Public Method | Description
CopyToSite | Overloaded
Create | Overloaded
CreateOffsetAlignment | Creates an offset Alignment from the current alignment, returns the offset Alignment ObjectId. A positive value to create an offset... more
DistanceToAlignment | Overloaded
GetInstantaneousRadius | Returns the instantaneous radius at the specified station.
GetLabelGroupIds | Gets the ObjectIdCollection of the Alignment's label group.
GetLabelIds | Gets the ObjectIdCollection of the Alignment's labels.
GetNextUniqueName | Gets a string indicating a unique name for the Alignment. The input string could be a name template.
GetPolyline | Gets a polyline from the Alignment geometry.
GetProfileIds | Gets the ObjectIdCollection of all profiles belonging to this Alignment.
GetProfileViewIds | Gets the ObjectIdCollection of all profile views belonging to this Alignment.
GetRegions | Gets the regions, which are included in offset alignment or curb return.
GetSampleLineGroupIds | Gets the ObjectIdCollection of all sample line groups belonging to this Alignment.
GetStationSet | Overloaded
GetStationStringWithEquations | Gets a string indicating the station of an Alignment using the Station equations.
GetSuperelevationZoneAtStation | Gets the superelevation zone at the specified Station.
ImportLabelSet | Overloaded
PointLocation | Overloaded
Reverse | Reverse the Alignment direction.
StationOffset | Overloaded
SuperElevationAtStation | Gets the superelevation data element at a specified station. A read-only copy is returned.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Methods
Legend
Legend
Method
public


AlignmentCurveLabel Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Methods
AlignmentCurveLabel Methods Public Methods
AlignmentCurveLabel Methods
Public Methods
Public Method | Description
Create | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class > AlignmentCurveLabel Methods
Legend
Legend
Method
public


AlignmentDesignSpeedLabelGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Methods
AlignmentDesignSpeedLabelGroup Methods Public Methods
AlignmentDesignSpeedLabelGroup Methods
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentDesignSpeedLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentDesignSpeedLabelGroup objects on the alignment.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class > AlignmentDesignSpeedLabelGroup Methods
Legend
Legend
Method
public


AlignmentEntity Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Methods
AlignmentEntity Methods Public Methods
AlignmentEntity Methods
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Methods
Legend
Legend
Method
public


AlignmentEntityCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods
AlignmentEntityCollection Methods Public Methods
AlignmentEntityCollection Methods
Public Methods
Public Method | Description
AddFixedCurve | Overloaded
AddFixedLine | Overloaded
AddFixedSpiral | Overloaded
AddFloatingArcWithSpiral | Overloaded
AddFloatingCSS | Overloaded
AddFloatingCurve | Overloaded
AddFloatingLine | Overloaded
AddFloatingLineWithSpiral | Overloaded
AddFloatingSSC | Overloaded
AddFreeCurve | Overloaded
AddFreeLine | Creates an AlignmentLine entity defined by two successive elements identified by ID.
AddFreeSCS | Creates a AlignmentSCS (Spiral-Curve-Spiral group) entity defined by a previous entity, a next entity, the 'A' values of two spirals,... more
AddFreeSCSCS | Creates an AlignmentSCSCS (Spiral-Curve-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition... more
AddFreeSCSSCS | Creates an AlignmentSCSSCS (Spiral-Curve-Spiral-Spiral-Curve-Spiral group) subentity defined by a previous element, a next element, an AeccGeSCSCSConstraints and a spiral definition... more
AddFreeSpiral | Creates a AlignmentSCS (Spiral-Curve-Spiral group with a curve and a spiral length is 0) entity defined by a previous entity,... more
AddFreeSSBetweenCurves | Adds an AlignmentSTS (Spiral-Line-Spiral group with the line length is 0) entity constrained by the two spiral parameters.
AddFreeSSBetweenTangents | Creates a AlignmentSCS (Spiral-Curve-Spiral groupwith the curve length is 0) entity defined by a previous entity, a next entity, the... more
AddFreeSTS | Overloaded
Clear | Removes all alignment entities from the collection.
EntityAtId | Returns the AlignmentEntity specified by ID.
EntityAtStation | Gets the AlignmentEntity at a specified Station in the Alignment.
GetEntityByOrder | Gets an AlignmentEntity at a specified order index along the alignment path. This function behaves like the GUI in that... more
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes alignment entity from the collection by the specified entity object.
RemoveAt | Removes alignment entity from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Methods
Legend
Legend
Method
public
virtual


AlignmentGeometryPointLabelGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Methods
AlignmentGeometryPointLabelGroup Methods Public Methods
AlignmentGeometryPointLabelGroup Methods
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentGeometryPointLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentGeometryPointLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector containing the state of all AlignmentPointTypes for the current label.
SetGeometryPointsOptions | Sets the state of all AlignmentPointTypes for the current label.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class > AlignmentGeometryPointLabelGroup Methods
Legend
Legend
Method
public


AlignmentLabelGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Methods
AlignmentLabelGroup Methods Public Methods
AlignmentLabelGroup Methods
Public Methods
Public Method | Description
GetAvailableLabelGroups | Returns the ObjectId collection of labels on the alignment of a specified type.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Methods
Legend
Legend
Method
public


AlignmentMinorStationLabelGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Methods
AlignmentMinorStationLabelGroup Methods Public Methods
AlignmentMinorStationLabelGroup Methods
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentMinorStationLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentMinorStationLabelGroup objects on the alignment.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Methods
Legend
Legend
Method
public


AlignmentPILabel Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Methods
AlignmentPILabel Methods Public Methods
AlignmentPILabel Methods
Public Methods
Public Method | Description
Create | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class > AlignmentPILabel Methods
Legend
Legend
Method
public


AlignmentRegionCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Methods
AlignmentRegionCollection Methods Public Methods
AlignmentRegionCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
MergeToNeighborRegion | Merges the specified region to neighbor region.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Methods
Legend
Legend
Method
public
virtual


AlignmentSpiralLabel Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Methods
AlignmentSpiralLabel Methods Public Methods
AlignmentSpiralLabel Methods
Public Methods
Public Method | Description
Create | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class > AlignmentSpiralLabel Methods
Legend
Legend
Method
public


AlignmentStationEquationLabelGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Methods
AlignmentStationEquationLabelGroup Methods Public Methods
AlignmentStationEquationLabelGroup Methods
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentStationEquationLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentStationEquationLabelGroup obects on the alignment.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class > AlignmentStationEquationLabelGroup Methods
Legend
Legend
Method
public


AlignmentStationLabelGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Methods
AlignmentStationLabelGroup Methods Public Methods
AlignmentStationLabelGroup Methods
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentStationLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of the specified label type on the alignment.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Methods
Legend
Legend
Method
public


AlignmentSubEntity Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Methods
AlignmentSubEntity Methods Public Methods
AlignmentSubEntity Methods
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Methods
Legend
Legend
Method
public


AlignmentSuperelevationLabelGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Methods
AlignmentSuperelevationLabelGroup Methods Public Methods
AlignmentSuperelevationLabelGroup Methods
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentSuperelevationLabelGroup on an alignment entity with the specified label style.
GetAvailableLabelGroups | Returns the ObjectId collection of AlignmentSuperelevationLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector object containing the state of all SuperelevationPointType objects for the current label.
SetGeometryPointsOptions | Sets the state of all SuperelevationPointType objects for the current label.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class > AlignmentSuperelevationLabelGroup Methods
Legend
Legend
Method
public


AlignmentTangentLabel Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Methods
AlignmentTangentLabel Methods Public Methods
AlignmentTangentLabel Methods
Public Methods
Public Method | Description
Create | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class > AlignmentTangentLabel Methods
Legend
Legend
Method
public


AlignmentVerticalGeometryPointLabelGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Methods
AlignmentVerticalGeometryPointLabelGroup Methods Public Methods
AlignmentVerticalGeometryPointLabelGroup Methods
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentVerticalGeometryPointLabelGroup on an alignment entity with the label style.
GetAvailableLabelGroups | Returns the object Id collection of AlignmentVerticalGeometryPointLabelGroup objects on the alignment.
GetGeometryPointsOptions | Gets a GeometryPointSelector object containing the state of all ProfilePointType objects for the current label.
SetGeometryPointsOptions | Sets the state of all ProfilePointType objects for the current label.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Methods
Legend
Legend
Method
public


DesignSpeedCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods
DesignSpeedCollection Methods Public Methods
DesignSpeedCollection Methods
Public Methods
Public Method | Description
Add | Adds a DesignSpeed to the collection for the given Station value.
GetDesignSpeed | Gets the DesignSpeed object in the collection by raw Station value.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumertor which can be used to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumertor which can be used to enumerate this... more
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Methods
Legend
Legend
Method
public
virtual


PolylineOptions Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Methods
PolylineOptions Methods Public Methods
PolylineOptions Methods
Public Methods
Public Method | Description
Equals | Overloaded
GetHashCode | Gets a hash code for the PolylineOptions object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Methods
Legend
Legend
Method
public
virtual


Profile Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods
Profile Methods Public Methods
Profile Methods
Public Methods
Public Method | Description
CreateByLayout | Overloaded
CreateFromSurface | Overloaded
ElevationAt | Gets the elevation at a specified station.
GradeAt | Given a station, gets the instantaneous grade and the algebraic difference.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Methods
Legend
Legend
Method
public


ProfileCriteriaCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Methods
ProfileCriteriaCollection Methods Public Methods
ProfileCriteriaCollection Methods
Public Methods
Public Method | Description
Add | Adds an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria to the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes an Autodesk.Civil.Land.DatabaseServices.ProfileCriteria from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Methods
Legend
Legend
Method
public
virtual


ProfileEntity Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Methods
ProfileEntity Methods Public Methods
ProfileEntity Methods
Public Methods
Public Method | Description
DesignChecks | Gets the collection of applicable design checks.
ValidateDesignCheck | Validate a specific design check on this entity.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Methods
Legend
Legend
Method
public


ProfileEntityCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods
ProfileEntityCollection Methods Public Methods
ProfileEntityCollection Methods
Public Methods
Public Method | Description
AddFixedSymmetricParabolaByEntityEndAndThroughPoint | Creates a fixed Symmetric Parabola defined by the entity to attach to and pass-through point.
AddFixedSymmetricParabolaByThreePoints | Creates a fixed Symmetric Parabola defined by 3 pass-through points.
AddFixedSymmetricParabolaByTwoPointsAndEndGrade | Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the end point.
AddFixedSymmetricParabolaByTwoPointsAndK | Creates a fixed Symmetric Parabola defined by 2 pass-through points and K value.
AddFixedSymmetricParabolaByTwoPointsAndRadius | Creates a fixed Symmetric Parabola defined by 2 pass-through points and radius.
AddFixedSymmetricParabolaByTwoPointsAndStartGrade | Creates a fixed Symmetric Parabola defined by 2 pass-through points and the grade at the start point.
AddFixedTangent | Creates a fixed Tangent defined by 2 pass-through points.
AddFixedTangentWithPreviousEntity | Creates a fixed Tangent defined by 2 pass-through points and previous entity id.
AddFloatingSymmetricParabolaByThroughPointAndGrade | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the grade value at... more
AddFloatingSymmetricParabolaByThroughPointAndK | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the K value.
AddFloatingSymmetricParabolaByThroughPointAndRadius | Creates a floating Symmetric Parabola defined by an entity to attach to, a pass-through point and the radius value.
AddFloatingTangent | Creates a floating Tangent defined by an entity and a pass-through point, whether to append or prepend to the specified... more
AddFreeAsymmetricParabolaByPVIAndLengths | Creates a free Asymmetric Parabola constrained by a PVI and 2 parabola lengths.
AddFreeCircularCurveByPVIAndLength | Creates a free Circular Curve constrained by a PVI and length.
AddFreeCircularCurveByPVIAndRadius | Creates a free Circular Curve constrained by a PVI and radius.
AddFreeCircularCurveByPVIAndThroughPoint | Creates a free Circular Curve constrained by a PVI and a pass-through point.
AddFreeSymmetricParabolaByK | Creates a free Symmetric Parabola between two entities and the K value.
AddFreeSymmetricParabolaByLength | Creates a free Symmetric Parabola between two entities and curve length.
AddFreeSymmetricParabolaByPVIAndCurveLength | Creates a free Symmetric Parabola constrained by a PVI and curve length.
AddFreeSymmetricParabolaByPVIAndK | Creates a free Symmetric Parabola constrained by a PVI and K value.
AddFreeSymmetricParabolaByPVIAndThroughPoint | Creates a free Symmetric Parabola constrained by a PVI and a pass-through point.
AddFreeSymmetricParabolaByRadius | Creates a free Symmetric Parabola between two entities and the radius value.
AddFreeTangent | Creates a free Tangent between two entities.
Clear | Removes all Profile entities from the collection.
EntityAtId | Returns the ProfileEntity specified by ID.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes from the collection by the specified entity object.
RemoveAt | Removes from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Methods
Legend
Legend
Method
public
virtual


ProfileHatchAreaCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Methods
ProfileHatchAreaCollection Methods Public Methods
ProfileHatchAreaCollection Methods
Public Methods
Public Method | Description
Add | Adds an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea to the collection.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes an Autodesk.Civil.Land.DatabaseServices.ProfileHatchArea by the hatch area name from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Methods
Legend
Legend
Method
public
virtual


ProfileOverride Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Methods
ProfileOverride Methods Public Methods
ProfileOverride Methods
Public Methods
Public Method | Description
GetLabelGroupIds | Gets the ObjectIdCollection of the Profile's label group.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Methods
Legend
Legend
Method
public


ProfileOverrideCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Methods
ProfileOverrideCollection Methods Public Methods
ProfileOverrideCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Methods
Legend
Legend
Method
public
virtual


ProfileParabolaSymmetric Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Methods
ProfileParabolaSymmetric Methods Public Methods
ProfileParabolaSymmetric Methods
Public Methods
Public Method | Description
GetHeadlightSightDistance | Gets the headlight sight distance with the given headlight angle and headlight height.
GetPassingSightDistance | Gets the passing sight distance with the given eye height and object height.
GetStoppingSightDistance | Gets the stopping sight distance with the given eye height and object height.
SetHeadlightSightDistance | Sets the headlight sight distance with the given headlight angle and headlight height.
SetPassingSightDistance | Sets the passing sight distance with the given eye height and object height.
SetStoppingSightDistance | Sets the stopping sight distance with the given eye height and object height.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Methods
Legend
Legend
Method
public


ProfilePVICollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods
ProfilePVICollection Methods Public Methods
ProfilePVICollection Methods
Public Methods
Public Method | Description
AddPVI | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is tangent to the collection.
AddPVIArc | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is Circular to the collection.
AddPVIAsymParabola | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaAsymmetric to the collection.
AddPVISymParabola | Adds an Autodesk.Civil.Land.DatabaseServices.ProfilePVI that's type is ParabolaSymmetric to the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetPVIAt | Gets the PVI in the collection closest to the given station and elevation.
Remove | Removes a profile PVI from the collection.
RemoveAt | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Methods
Legend
Legend
Method
public
virtual


ProfileView Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Methods
ProfileView Methods Public Methods
ProfileView Methods
Public Methods
Public Method | Description
Create | Overloaded
FindStationAndElevationAtXY | Finds the station and elevation values at the given X,Y coordinate.
FindXYAtStationAndElevation | Finds the X,Y coordinate for the given station and elevation.
GetLabelIds | Gets the ObjectIdCollection of the ProfileView's labels.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Methods
Legend
Legend
Method
public


ProfileViewSplitDataCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Methods
ProfileViewSplitDataCollection Methods Public Methods
ProfileViewSplitDataCollection Methods
Public Methods
Public Method | Description
Add | Adds a new split location.
GetEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
RemoveAt | Removes the split location from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Methods
Legend
Legend
Method
public
virtual


SampleLine Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Methods
SampleLine Methods Public Methods
SampleLine Methods
Public Methods
Public Method | Description
GetSectionViewIds | Gets the objectId collection of all section views attached on this sample line.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Methods
Legend
Legend
Method
public


SampleLineGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Methods
SampleLineGroup Methods Public Methods
SampleLineGroup Methods
Public Methods
Public Method | Description
GetMassHaulViewIds | Gets the objectId collection of mass haul views.
GetSampleLineIds | Gets the objectId collection of all sample lines in the sampline group.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class > SampleLineGroup Methods
Legend
Legend
Method
public


SCSCSConstraints Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods
SCSCSConstraints Methods Public Methods
SCSCSConstraints Methods
Public Methods
Public Method | Description
CreateByArc1Angle | Creates an SCSCSConstraints object that constrains the SCSCS group by the angle of the first arc.
CreateByArc1Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the first arc.
CreateByArc1PassPt | Creates an SCSCSConstraints object that constrains the SCSCS group by a pass-through point for the first arc.
CreateByArc2Angle | Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.
CreateByArc2Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc length.
CreateByArc2PassPt | Creates an SCSCSConstraints object that constrains the SCSCS group by the second arc pass through point.
CreateByEndPoint | Creates an SCSCSConstraints object that constrains the SCSCS group by an end point.
CreateByStartPoint | Creates an SCSCSConstraints object that constrains the SCSCS group by the start point.
CreateByTan1Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the first tangent length.
CreateByTan2Length | Creates an SCSCSConstraints object that constrains the SCSCS group by the length of the second tangent.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class > SCSCSConstraints Methods
Legend
Legend
Method
public


SCSSCSConstraints Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods
SCSSCSConstraints Methods Public Methods
SCSSCSConstraints Methods
Public Methods
Public Method | Description
CreateByArc1Angle | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the angle of the first arc.
CreateByArc1Length | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the length of the first arc.
CreateByArc1PassPt | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point of the first arc.
CreateByArc2Angle | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc angle.
CreateByArc2Length | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the second arc length.
CreateByArc2PassPt | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the pass-through point for the second arc.
CreateByEndPoint | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the end point.
CreateByStartPoint | Creates an SCSSCSConstraints object that constrains the SCSSCS group by the start point.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class > SCSSCSConstraints Methods
Legend
Legend
Method
public


Site Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Methods
Site Methods Public Methods
Site Methods
Public Methods
Public Method | Description
Create | Creates a new site.
GetAlignmentIds | Gets the objectId collection of all alignment objects in the site.
GetFeatureLineIds | Gets the objectId collection of all feature lines in the site.
GetParcelIds | Gets the objectId collection of all parcels in the site.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class > Site Methods
Legend
Legend
Method
public


StationEquationCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods
StationEquationCollection Methods Public Methods
StationEquationCollection Methods
Public Methods
Public Method | Description
Add | Adds a station equation into the alignment.
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumerator which can be use to enumerate this collection.... more
GetStationEquation | Gets the StationEquation object in the collection by raw station back.
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Methods
Legend
Legend
Method
public
virtual


StationOffsetLabel Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Methods
StationOffsetLabel Methods Public Methods
StationOffsetLabel Methods
Public Methods
Public Method | Description
Create | Creates a new instance of an AlignmentCurveLabel and adds it to the specified database.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Methods
Legend
Legend
Method
public


AlignmentDesignCheckSet Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Methods
AlignmentDesignCheckSet Methods Public Methods
AlignmentDesignCheckSet Methods
Public Methods
Public Method | Description
AddDesignCheck | Add one design check into this AlignmentDesignCheckSet.
GetAllDesignChecks | Gets all design checks in this AlignmentDesignCheckSet.
RemoveAllDesignCheck | Remove all design checks from this AlignmentDesignCheckSet.
RemoveDesignCheck | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class > AlignmentDesignCheckSet Methods
Legend
Legend
Method
public


AlignmentDesignCheckSetCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class > AlignmentDesignCheckSetCollection Methods
AlignmentDesignCheckSetCollection Methods Public Methods
AlignmentDesignCheckSetCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class > AlignmentDesignCheckSetCollection Methods
Legend
Legend
Method
public
virtual


AlignmentStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Methods
AlignmentStyle Methods Public Methods
AlignmentStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the Alignment component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the Alignment component.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies the line marker in section display properties for the Alignment component.
GetLineMarkerDisplayStyleSection | Gets the display style for line markers in section view orientation.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Methods
Legend
Legend
Method
public


AlignmentStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class > AlignmentStyleCollection Methods
AlignmentStyleCollection Methods Public Methods
AlignmentStyleCollection Methods
Public Methods
Public Method | Description
Add |


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class > AlignmentStyleCollection Methods
Legend
Legend
Method
public
virtual


BuildingSiteStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Methods
BuildingSiteStyle Methods Public Methods
BuildingSiteStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the BuildingSite component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the BuildingSite component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Methods
Legend
Legend
Method
public


BuildingSiteStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class > BuildingSiteStyleCollection Methods
BuildingSiteStyleCollection Methods Public Methods
BuildingSiteStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class > BuildingSiteStyleCollection Methods
Legend
Legend
Method
public
virtual


GradingCriteria Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Methods
GradingCriteria Methods Public Methods
GradingCriteria Methods
Public Methods
Public Method | Description
CopyAsSibling | Copy the current grading criteria and add to the grading criteria set as a sibling.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Methods
Legend
Legend
Method
public
virtual


GradingCriteriaCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class > GradingCriteriaCollection Methods
GradingCriteriaCollection Methods Public Methods
GradingCriteriaCollection Methods
Public Methods
Public Method | Description
Add | Adds a GradingCriteria object to the collection by name.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class > GradingCriteriaCollection Methods
Legend
Legend
Method
public
virtual


GradingCriteriaSet Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods
GradingCriteriaSet Methods Public Methods
GradingCriteriaSet Methods
Public Methods
Public Method | Description
AddCriteria | Add a new grading criteria to the current set.
GradingCriteriaIds | Gets the objectId collection of all grading criteria objects in the set.
MoveCriteria | Overloaded
RemoveCriteria | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Methods
Legend
Legend
Method
public


GradingCriteriaSetCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class > GradingCriteriaSetCollection Methods
GradingCriteriaSetCollection Methods Public Methods
GradingCriteriaSetCollection Methods
Public Methods
Public Method | Description
Add | Adds a GradingCriteriaSet to the collection by name.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class > GradingCriteriaSetCollection Methods
Legend
Legend
Method
public
virtual


GradingStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Methods
GradingStyle Methods Public Methods
GradingStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the grading component Model display color, layer, linetype, etc.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the grading component Plan display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Methods
Legend
Legend
Method
public


GradingStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Methods
GradingStyleCollection Methods Public Methods
GradingStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.
SetCenterMarkerVisable | Specifies whether the center marker of all grading styles is visable in the current view port(Plan/Model).
SetSlopePatternVisable | Specifies whether the slope pattern of all grading styles is visable in the current view port(Plan/Model).


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class > GradingStyleCollection Methods
Legend
Legend
Method
public
virtual


GroupPlotStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class > GroupPlotStyleCollection Methods
GroupPlotStyleCollection Methods Public Methods
GroupPlotStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class > GroupPlotStyleCollection Methods
Legend
Legend
Method
public
virtual


HorizontalGeometryBandStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Methods
HorizontalGeometryBandStyle Methods Public Methods
HorizontalGeometryBandStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the HorizontalGeometry component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Methods
Legend
Legend
Method
public


MassHaulLineStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Methods
MassHaulLineStyle Methods Public Methods
MassHaulLineStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the MassHaulLine component.
GetHatchDisplayStyleProfile | Gets the HatchDisplayStyle object that specifies profile display properties for the MassHaulLine component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Methods
Legend
Legend
Method
public


MassHaulLineStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class > MassHaulLineStyleCollection Methods
MassHaulLineStyleCollection Methods Public Methods
MassHaulLineStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class > MassHaulLineStyleCollection Methods
Legend
Legend
Method
public
virtual


MassHaulViewStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Methods
MassHaulViewStyle Methods Public Methods
MassHaulViewStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the masshual view component plan display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Methods
Legend
Legend
Method
public


MassHaulViewStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class > MassHaulViewStyleCollection Methods
MassHaulViewStyleCollection Methods Public Methods
MassHaulViewStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class > MassHaulViewStyleCollection Methods
Legend
Legend
Method
public
virtual


MatchLineStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Methods
MatchLineStyle Methods Public Methods
MatchLineStyle Methods
Public Methods
Public Method | Description
GetLinesDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match lines.
GetMatchLineMaskDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match line mask areas.
GetMatchLineMaskHatchDisplayStyle | Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Methods
Legend
Legend
Method
public


ParcelStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Methods
ParcelStyle Methods Public Methods
ParcelStyle Methods
Public Methods
Public Method | Description
GetAreaFillHatchDisplayStyleModel | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle,... more
GetAreaFillHatchDisplayStylePlan | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle,... more
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the Parcel component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the Parcel component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Methods
Legend
Legend
Method
public


PointStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Methods
PointStyle Methods Public Methods
PointStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the point component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the point component.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the point component.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties for the point component.
GetLabelDisplayStyleModel | Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.
GetLabelDisplayStylePlan | Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Methods
Legend
Legend
Method
public


ProfileDataBandStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Methods
ProfileDataBandStyle Methods Public Methods
ProfileDataBandStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the ProfileData component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Methods
Legend
Legend
Method
public


ProfileDesignCheckSet Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods
ProfileDesignCheckSet Methods Public Methods
ProfileDesignCheckSet Methods
Public Methods
Public Method | Description
AddDesignCheck | Overloaded
GetAllDesignChecks | Gets all design checks in this ProfileDesignCheckSet.
GetCurveDesignCheckType | This function will get the curve design check type.
RemoveAllDesignCheck | Remove all design checks from this ProfileDesignCheckSet.
RemoveDesignCheck | Overloaded
SetCurveDesignCheckType | This function will set the curve design check type.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class > ProfileDesignCheckSet Methods
Legend
Legend
Method
public


ProfileDesignCheckSetCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class > ProfileDesignCheckSetCollection Methods
ProfileDesignCheckSetCollection Methods Public Methods
ProfileDesignCheckSetCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class > ProfileDesignCheckSetCollection Methods
Legend
Legend
Method
public
virtual


ProfileLabelSetStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Methods
ProfileLabelSetStyle Methods Public Methods
ProfileLabelSetStyle Methods
Public Methods
Public Method | Description
AddCrestCurve | Creates a label set item of type profile crest curve with the given profile curve object id, adds it to... more
AddSagCurve | Creates a label set item of type profile sag curve with the given profile curve object id, adds it to... more
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Methods
Legend
Legend
Method
public
virtual


ProfileStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Methods
ProfileStyle Methods Public Methods
ProfileStyle Methods
Public Methods
Public Method | Description
GetChain3DDisplayStyleModel | Gets the AeccDisplayStyle for 3D chain display style in model view orientation.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties for the Profile component.
GetProfileMarkerDisplayStyleSection | Gets the AeccDisplayStyle for marker display style in section view orientation.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Methods
Legend
Legend
Method
public


ProfileViewBandSetItem Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Methods
ProfileViewBandSetItem Methods Public Methods
ProfileViewBandSetItem Methods
Public Methods
Public Method | Description
GetAlignmentGeometryPoints | Gets the alignment geometry points from profile data bands.
GetProfileGeometryPoints | Gets the profile geometry points from profile data bands.
SetAlignmentGeometryPoints | Sets the alignment geometry points from profile data bands.
SetProfileGeometryPoints | Sets the profile geometry points from profile data bands.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Methods
Legend
Legend
Method
public


ProfileViewStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Methods
ProfileViewStyle Methods Public Methods
ProfileViewStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the profile view component plan display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Methods
Legend
Legend
Method
public


ProfileViewStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class > ProfileViewStyleCollection Methods
ProfileViewStyleCollection Methods Public Methods
ProfileViewStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class > ProfileViewStyleCollection Methods
Legend
Legend
Method
public
virtual


SampleLineStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Methods
SampleLineStyle Methods Public Methods
SampleLineStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the SampleLine component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SampleLine component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class > SampleLineStyle Methods
Legend
Legend
Method
public


SectionalDataBandStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Methods
SectionalDataBandStyle Methods Public Methods
SectionalDataBandStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionalData component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Methods
Legend
Legend
Method
public


SectionDataBandStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Methods
SectionDataBandStyle Methods Public Methods
SectionDataBandStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionData component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Methods
Legend
Legend
Method
public


SectionSegmentBandStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Methods
SectionSegmentBandStyle Methods Public Methods
SectionSegmentBandStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SectionalSegment component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Methods
Legend
Legend
Method
public


SectionStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class > SectionStyle Methods
SectionStyle Methods Public Methods
SectionStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties for the Section component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class > SectionStyle Methods
Legend
Legend
Method
public


SectionViewBandSetItemCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Methods
SectionViewBandSetItemCollection Methods Public Methods
SectionViewBandSetItemCollection Methods
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Methods
Legend
Legend
Method
public
virtual


SectionViewStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Methods
SectionViewStyle Methods Public Methods
SectionViewStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the section view component plan display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Methods
Legend
Legend
Method
public


SheetStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Methods
SheetStyle Methods Public Methods
SheetStyle Methods
Public Methods
Public Method | Description
GetDisplayPlan | Gets the DisplayStyle object that specifies plan display properties for the SheetStyle component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Methods
Legend
Legend
Method
public


SlopePatternStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Methods
SlopePatternStyle Methods Public Methods
SlopePatternStyle Methods
Public Methods
Public Method | Description
AddComponent | Adds a new component using the default parameters in a specified position.
CopyComponent | Copy a component and insert into the slope pattern style.
RemoveAt | Removes the component from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Methods
Legend
Legend
Method
public


SlopePatternStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class > SlopePatternStyleCollection Methods
SlopePatternStyleCollection Methods Public Methods
SlopePatternStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class > SlopePatternStyleCollection Methods
Legend
Legend
Method
public
virtual


SuperelevationDataBandStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Methods
SuperelevationDataBandStyle Methods Public Methods
SuperelevationDataBandStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the SuperelevationData component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Methods
Legend
Legend
Method
public


SurfaceContourStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Methods
SurfaceContourStyle Methods Public Methods
SurfaceContourStyle Methods
Public Methods
Public Method | Description
GetContourValues | Gets an array of ContourValues that represent how to render major and minor contours.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Methods
Legend
Legend
Method
public


SurfaceStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Methods
SurfaceStyle Methods Public Methods
SurfaceStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the surface component Model display color, layer, linetype, etc.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the surface component Plan display color, layer, linetype, etc.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies the surface component Section display color, layer, linetype, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Methods
Legend
Legend
Method
public


VerticalGeometryBandStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Methods
VerticalGeometryBandStyle Methods Public Methods
VerticalGeometryBandStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the VerticalGeometry component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Methods
Legend
Legend
Method
public


ViewFrameStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Methods
ViewFrameStyle Methods Public Methods
ViewFrameStyle Methods
Public Methods
Public Method | Description
GetViewFrameBoundaryDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Methods
Legend
Legend
Method
public


SuperElevationData Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Methods
SuperElevationData Methods Public Methods
SuperElevationData Methods
Public Methods
Public Method | Description
Add | Adds a SuperElevationDataElement object to the SuperElevationData collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Remove | Removes a SuperElevationDataElement at a specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Methods
Legend
Legend
Method
public
virtual


SuperElevationDataElement Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Methods
SuperElevationDataElement Methods Public Methods
SuperElevationDataElement Methods
Public Methods
Public Method | Description
GetSegmentCrossSlope | Gets the superelevation cross slope value.
SetSegmentCrossSlope | Sets the superelevation cross slope value.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Methods
Legend
Legend
Method
public


Surface Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Methods
Surface Methods Public Methods
Surface Methods
Public Methods
Public Method | Description
FindElevationAtXY |


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Methods
Legend
Legend
Method
public


ViewFrameGroup Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Methods
ViewFrameGroup Methods Public Methods
ViewFrameGroup Methods
Public Methods
Public Method | Description
GetMatchLineIds | Gets the objectId collection of all match line.
GetViewFrameIds | Gets the objectId collection of view frame.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class > ViewFrameGroup Methods
Legend
Legend
Method
public


GeometryPointSelector Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Methods
GeometryPointSelector Methods Public Methods
GeometryPointSelector Methods
Public Methods
Public Method | Description
SelectAll | Selects all supported geometry points.
UnSelectAll | Unselects all supported geometry points.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Methods
Legend
Legend
Method
public


ProfileDesignCheckCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Methods
ProfileDesignCheckCollection Methods Public Methods
ProfileDesignCheckCollection Methods
Public Methods
Public Method | Description
Add | Adds a DesignCheck by specifying the name and expression.
Clear | Removes all DesignChecks from the collection.
Remove | Removes ProfileDesignCheck from the collection by the specified name.
RemoveAt | Removes DesignCheck from the collection by the specified index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Methods
Legend
Legend
Method
public
virtual


SettingsAbbreviationAlignment Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class > SettingsAbbreviationAlignment Methods
SettingsAbbreviationAlignment Methods Public Methods
SettingsAbbreviationAlignment Methods
Public Methods
Public Method | Description
GetAlignmentAbbreviation | Gets the alignment abbreviation settings
SetAlignmentAbbreviation | Sets the alignment abbreviation settings


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class > SettingsAbbreviationAlignment Methods
Legend
Legend
Method
public


SettingsAbbreviationAlignmentEnhanced Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class > SettingsAbbreviationAlignmentEnhanced Methods
SettingsAbbreviationAlignmentEnhanced Methods Public Methods
SettingsAbbreviationAlignmentEnhanced Methods
Public Methods
Public Method | Description
GetAlignmentEnhancedAbbreviation | Gets the alignment enhanced abbreviation settings
SetAlignmentEnhancedAbbreviation | Sets the alignment enhanced abbreviation settings


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class > SettingsAbbreviationAlignmentEnhanced Methods
Legend
Legend
Method
public


SettingsAbbreviationProfile Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class > SettingsAbbreviationProfile Methods
SettingsAbbreviationProfile Methods Public Methods
SettingsAbbreviationProfile Methods
Public Methods
Public Method | Description
GetProfileAbbreviation | Gets the profile abbreviation settings
SetProfileAbbreviation | Sets the profile abbreviation settings


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class > SettingsAbbreviationProfile Methods
Legend
Legend
Method
public


SettingsAbbreviationSuperelevation Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class > SettingsAbbreviationSuperelevation Methods
SettingsAbbreviationSuperelevation Methods Public Methods
SettingsAbbreviationSuperelevation Methods
Public Methods
Public Method | Description
GetSuperelevationAbbreviation | Gets the superelevation abbreviation settings
SetSuperelevationAbbreviation | Sets the superelevation abbreviation settings


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class > SettingsAbbreviationSuperelevation Methods
Legend
Legend
Method
public


Network Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods
Network Methods Public Methods
Network Methods
Public Methods
Public Method | Description
AddCurvePipe | Add a curve pipe by using the geometry information of an input curve.
AddLinePipe | Add a line pipe by using the geometry information of an input line.
AddStructure | Overloaded
BreakPipe | Break the specified pipe with a specified existing structure at a point.
Create | Creates a pipe network specified by name.
FindShortestNetworkPath | Find a shortest path in the network.
GetPipeIds | Gets the objectId collection of all pipes belonging to this pipe network.
GetSpanningPipePlanLabelIds | Gets the spanning pipe plan label collection.
GetSpanningPipeProfileLabelIds | Get the spanning pipe profile label collection.
GetStructureIds | Gets the objectId collection of all structures belonging to this pipe network.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Methods
Legend
Legend
Method
public


NetworkCatalogDef Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class > NetworkCatalogDef Methods
NetworkCatalogDef Methods Public Methods
NetworkCatalogDef Methods
Public Methods
Public Method | Description
DeclareNewParameter | Declares a new part catalog parameter
DeclarePartProperty | Declares a new part property.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class > NetworkCatalogDef Methods
Legend
Legend
Method
public


Part Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods
Part Methods Public Methods
Part Methods
Public Methods
Public Method | Description
AddToProfileView | Draws the part into the specified profile view.
AddToSectionView | Draws the part into the specified section view.
GetOverriddenRuleIds | Gets the overridden Rule ids which this part contains.
GetProfileViewsDisplayingMe | Gets the object id collection of all the profile views in which this part was drawn.
GetSectionViewsDisplayingMe | Gets the object id collection of all the section views in which this part was drawn.
RemoveFromAllProfileViews | Remove the part from all the profile views in which it is drawn.
RemoveFromAllSectionViews | Removes the part from all the section views in which it is drawn.
RemoveFromProfileView | Remove the part from the specified profile view in which it is drawn.
RemoveFromSectionView | Removes the part from the specified section view in which it is drawn.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Methods
Legend
Legend
Method
public


PartDataList Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Methods
PartDataList Methods Public Methods
PartDataList Methods
Public Methods
Public Method | Description
IsValidValue | Gets if the specified value is in the list.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Methods
Legend
Legend
Method
public


PartDataRange Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Methods
PartDataRange Methods Public Methods
PartDataRange Methods
Public Methods
Public Method | Description
IsValidValue | Gets if the specified value is in the range.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Methods
Legend
Legend
Method
public


PartDataRecord Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods
PartDataRecord Methods Public Methods
PartDataRecord Methods
Public Methods
Public Method | Description
GetAllDataFields | Gets all data fields.
GetDataFieldBy | Overloaded
GetMaxIndex | Gets the maximum index of one context type.
GetSupportedContexts | Gets the collection of supported ContextType.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class > PartDataRecord Methods
Legend
Legend
Method
public


PartDef Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Methods
PartDef Methods Public Methods
PartDef Methods
Public Methods
Public Method | Description
Get3dBody | Gets the 3d solid body.
GetBoundingShapeBody | Gets the bounding shape body.
GetNetworkPartViewDef | Gets the network part view def.
GetProfileInFrontView | Gets the profile in front view.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class > PartDef Methods
Legend
Legend
Method
public


Pipe Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods
Pipe Methods Public Methods
Pipe Methods
Public Methods
Public Method | Description
ConnectToPipe | Connect one pipe to another pipe. If needed, disconnect the original one and move the pipe to that pipe for... more
ConnectToStructure | Connect one pipe to another structure. If needed, disconnect the original one and move the pipe to that structure for... more
Disconnect | Disconnect pipe.
GetClosestPointTo | Gets the closest point found to the given point on a pipe.
GetLabelIds | Gets the collection of pipe label ids.
GetParamAtPoint | Gets the scale on the pipe for the given point.
GetPointAtParam | Gets a 3d point for the given parameter.
GetProject2dPointVertically | Returns true if get the Project2dPoint successfully, otherwise false.
IsMaxCoverViolated | Returns true if the Maximum Cover is violated.
IsMinCoverViolated | Returns true if the Minimum Cover is violated.
ResizeByInnerDiameterOrWidth | Resize the pipe by inner diameter or width.
SetSlopeHoldEnd | Sets the slope of the pipe away from the pipe’s end point.
SetSlopeHoldStart | Sets the slope of the pipe away from the pipe’s start point.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Methods
Legend
Legend
Method
public


ProfileViewPart Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Methods
ProfileViewPart Methods Public Methods
ProfileViewPart Methods
Public Methods
Public Method | Description
GetLabelIds | Gets the object ids of the labels attached to this profile network part


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Methods
Legend
Legend
Method
public


Structure Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods
Structure Methods Public Methods
Structure Methods
Public Methods
Public Method | Description
ConnectToPipe | Connect this structure to the specified pipe.
Disconnect | Disconnect with pipe.
GetConnectedPipeNames | Gets all the connected pipe names.
GetLabelIds | Gets the collection of structure label ids.
IsConnectedPipeFlowingIn | Determines if the connected pipe is flowing into the structure
IsConnectedPipeFlowingOut | Determines if the connected pipe is flowing out of the structure
IsPointInsideStructureRegion | Returns true if the point is within the structure region.
ResizeByPipeDepths | Resize the structure by pipe depths.
ResizeJunctionStructure | Resize the Junction structure by rim and sump elevations.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Methods
Legend
Legend
Method
public


InterferenceStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Methods
InterferenceStyle Methods Public Methods
InterferenceStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that defines the model style for the component indicated by the specified InterferenceDisplayStyleType value.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified InterferenceDisplayStyleType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified InterferenceDisplayStyleType value.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Methods
Legend
Legend
Method
public


InterferenceStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class > InterferenceStyleCollection Methods
InterferenceStyleCollection Methods Public Methods
InterferenceStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class > InterferenceStyleCollection Methods
Legend
Legend
Method
public
virtual


NetworkRuleSetStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Methods
NetworkRuleSetStyle Methods Public Methods
NetworkRuleSetStyle Methods
Public Methods
Public Method | Description
CloneAndAddRule | Add a copy of input source rule to rule set.
GetRuleIds | Gets the objectId collection of all rules belonging to this network rule set.
RemoveAllRules | Remove all the rules belonging to the rule set.
RemoveRule | Remove the specified rule from rule set.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Methods
Legend
Legend
Method
public


PartFamily Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Methods
PartFamily Methods Public Methods
PartFamily Methods
Public Methods
Public Method | Description
AddPartSize | Adds part one or more part sizes to this part family.
RemovePartSize | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Methods
Legend
Legend
Method
public


PartsList Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods
PartsList Methods Public Methods
PartsList Methods
Public Methods
Public Method | Description
AddPartFamilyByDescription | Adds a part family referenced by unique description of current active catalog to this parts list.
AddPartFamilyByGuid | Adds a part family referenced by unique GUID of current active catalog to this parts list. A parts list can... more
GetAvailablePartFamilies | Gets available part families of the current active catalog.
GetPartFamilyIdsByDomain | Gets the object id collection of part families of specified domain under this parts list.
RemovePartFamily | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Methods
Legend
Legend
Method
public


PartsListCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class > PartsListCollection Methods
PartsListCollection Methods Public Methods
PartsListCollection Methods
Public Methods
Public Method | Description
Add | Create a new parts list named by the input string. The new parts list will automatically have the null structure... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class > PartsListCollection Methods
Legend
Legend
Method
public
virtual


PipeNetworkBandStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Methods
PipeNetworkBandStyle Methods Public Methods
PipeNetworkBandStyle Methods
Public Methods
Public Method | Description
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the PipeNetwork component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Methods
Legend
Legend
Method
public


PipeRuleSetStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class > PipeRuleSetStyleCollection Methods
PipeRuleSetStyleCollection Methods Public Methods
PipeRuleSetStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class > PipeRuleSetStyleCollection Methods
Legend
Legend
Method
public
virtual


PipeStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods
PipeStyle Methods Public Methods
PipeStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that defines the Model style.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified PipeDisplayStylePlanType value.
GetDisplayStyleProfile | Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified PipeDisplayStyleProfileType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified PipeDisplayStyleSectionType value.
GetHatchStylePlan | Gets the HatchDisplayStyle object that defines the Plan style.
GetHatchStyleProfile | Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified PipeHatchStyleProfileType value.
GetHatchStyleSection | Gets the HatchDisplayStyle object that defines the Section style.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Methods
Legend
Legend
Method
public


PipeStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class > PipeStyleCollection Methods
PipeStyleCollection Methods Public Methods
PipeStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class > PipeStyleCollection Methods
Legend
Legend
Method
public
virtual


SizeFilterRecord Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Methods
SizeFilterRecord Methods Public Methods
SizeFilterRecord Methods
Public Methods
Public Method | Description
GetParamByContextAndIndex | Gets the catalog parameter by context and index.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Methods
Legend
Legend
Method
public


StructureRuleSetStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class > StructureRuleSetStyleCollection Methods
StructureRuleSetStyleCollection Methods Public Methods
StructureRuleSetStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class > StructureRuleSetStyleCollection Methods
Legend
Legend
Method
public
virtual


StructureStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods
StructureStyle Methods Public Methods
StructureStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that defines the Model style.
GetDisplayStylePlan | Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified StructureDisplayStylePlanType value.
GetDisplayStyleProfile | Gets the DisplayStyle object that defines the Profile style for the component indicated by the specified StructureDisplayStyleProfileType value.
GetDisplayStyleSection | Gets the DisplayStyle object that defines the Section style for the component indicated by the specified StructureDisplayStyleSectionType value.
GetHatchStylePlan | Gets the HatchDisplayStyle object that defines the Plan style.
GetHatchStyleProfile | Gets the HatchDisplayStyle object that defines the Profile style for the component indicated by the specified StructureHatchStyleProfileType value.
GetHatchStyleSection | Gets the HatchDisplayStyle object that defines the Section style.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Methods
Legend
Legend
Method
public


StructureStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class > StructureStyleCollection Methods
StructureStyleCollection Methods Public Methods
StructureStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class > StructureStyleCollection Methods
Legend
Legend
Method
public
virtual


QTOUtility Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Methods
QTOUtility Methods Public Methods
QTOUtility Methods
Public Methods
Public Method | Description
AddPayItemId | Adds a pay item id.
DeleteAllPayItemsIds | Deletes all pay item information from the specified object.
DeletePayItemIds | Deletes the pay item ids in the collection from the specified object.
GetPayItemIds | Gets a string collection of pay items ids for the specified object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class > QTOUtility Methods
Legend
Legend
Method
public


AppliedAssembly Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Methods
AppliedAssembly Methods Public Methods
AppliedAssembly Methods
Public Methods
Public Method | Description
GetAppliedSubassemblies | Gets the collection of AppliedAssemblies in this AppliedAssembly.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Methods
Legend
Legend
Method
public


AppliedAssemblyCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Methods
AppliedAssemblyCollection Methods Public Methods
AppliedAssemblyCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetItemAt | Gets the AppliedAssembly object nearest the specified station.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Stations | Gets a list of stations in the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Methods
Legend
Legend
Method
public
virtual


AppliedSubassemblyCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Methods
AppliedSubassemblyCollection Methods Public Methods
AppliedSubassemblyCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
ObjectIds | Gets an array of AppliedSubassemblies' ObjectIds.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Methods
Legend
Legend
Method
public
virtual


Assembly Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Methods
Assembly Methods Public Methods
Assembly Methods
Public Methods
Public Method | Description
GetOffsetBaselineNames | Gets an array of names of associated offset baselines.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Methods
Legend
Legend
Method
public


AssemblyCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Methods
AssemblyCollection Methods Public Methods
AssemblyCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Methods
Legend
Legend
Method
public
virtual


BaseBaseline Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Methods
BaseBaseline Methods Public Methods
BaseBaseline Methods
Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.
StationOffsetElevationToXYZ | Transforms an SOE coordinate to an xyz world coordinate.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Methods
Legend
Legend
Method
public
abstract
virtual


Baseline Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Methods
Baseline Methods Public Methods
Baseline Methods
Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Methods
Legend
Legend
Method
public
virtual


BaselineCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Methods
BaselineCollection Methods Public Methods
BaselineCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Methods
Legend
Legend
Method
public
virtual


BaselineFeatureLines Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Methods
BaselineFeatureLines Methods Public Methods
BaselineFeatureLines Methods
Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Methods
Legend
Legend
Method
public


BaselineFeatureLinesCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Methods
BaselineFeatureLinesCollection Methods Public Methods
BaselineFeatureLinesCollection Methods
Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Methods
Legend
Legend
Method
public
virtual


BaselineRegion Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Methods
BaselineRegion Methods Public Methods
BaselineRegion Methods
Public Methods
Public Method | Description
AddStation | Adds a station to the BaselineRegion.
DeleteStation | Removes a station from the BaselineRegion.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Methods
Legend
Legend
Method
public


BaselineRegionCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Methods
BaselineRegionCollection Methods Public Methods
BaselineRegionCollection Methods
Public Methods
Public Method | Description
AddRegion | Overloaded
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Methods
Legend
Legend
Method
public
virtual


CalculatedLinkCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Methods
CalculatedLinkCollection Methods Public Methods
CalculatedLinkCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Methods
Legend
Legend
Method
public
virtual


CalculatedPointCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Methods
CalculatedPointCollection Methods Public Methods
CalculatedPointCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Methods
Legend
Legend
Method
public
virtual


CalculatedShapeCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Methods
CalculatedShapeCollection Methods Public Methods
CalculatedShapeCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Methods
Legend
Legend
Method
public
virtual


CodeCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Methods
CodeCollection Methods Public Methods
CodeCollection Methods
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more
Remove | Remove the code from collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Methods
Legend
Legend
Method
public
virtual


Corridor Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Methods
Corridor Methods Public Methods
Corridor Methods
Public Methods
Public Method | Description
Rebuild | Forces the corridor to rebuild.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Methods
Legend
Legend
Method
public


CorridorCodeCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Methods
CorridorCodeCollection Methods Public Methods
CorridorCodeCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.... more
GetObjectEnumerator | Implements the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Methods
Legend
Legend
Method
public
virtual


CorridorCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Methods
CorridorCollection Methods Public Methods
CorridorCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Methods
Legend
Legend
Method
public
virtual


CorridorSection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Methods
CorridorSection Methods Public Methods
CorridorSection Methods
Public Methods
Public Method | Description
GetCorridor | Gets the ObjectId of the parent Corridor.
SetCorridor | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class > CorridorSection Methods
Legend
Legend
Method
public


CorridorSurface Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Methods
CorridorSurface Methods Public Methods
CorridorSurface Methods
Public Methods
Public Method | Description
FeatureLineCodeIsBreak | Gets the IsBreak value of the link code.
FeatureLineCodes | Gets the feature line codes used to construct the surface.
FindElevationAtXY | Finds the elevation of the surface at the specified XY location.
GetSampleElevations | Gets the collection of sample elevations.
LinkCodes | Gets the link codes used to construct the surface.
PointCodes | Gets the point codes used to construct the surface.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Methods
Legend
Legend
Method
public


CorridorSurfaceBaseMask Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Methods
CorridorSurfaceBaseMask Methods Public Methods
CorridorSurfaceBaseMask Methods
Public Methods
Public Method | Description
PolygonPoints | Gets the points of the polygon that make up the edge of the boundary or mask.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Methods
Legend
Legend
Method
public


CorridorSurfaceBoundaryCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Methods
CorridorSurfaceBoundaryCollection Methods Public Methods
CorridorSurfaceBoundaryCollection Methods
Public Methods
Public Method | Description
BoundaryNames | Gets an array of boundary names.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Methods
Legend
Legend
Method
public
virtual


CorridorSurfaceCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Methods
CorridorSurfaceCollection Methods Public Methods
CorridorSurfaceCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
SurfaceNames | Gets an array of surface names from the collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Methods
Legend
Legend
Method
public
virtual


CorridorSurfaceMaskCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Methods
CorridorSurfaceMaskCollection Methods Public Methods
CorridorSurfaceMaskCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
MaskNames | Gets an array of mask names.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Methods
Legend
Legend
Method
public
virtual


FeatureLineCodeInfoCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Methods
FeatureLineCodeInfoCollection Methods Public Methods
FeatureLineCodeInfoCollection Methods
Public Methods
Public Method | Description
CodeNames | Gets a list of code names in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Methods
Legend
Legend
Method
public
virtual


FeatureLineCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Methods
FeatureLineCollection Methods Public Methods
FeatureLineCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Methods
Legend
Legend
Method
public
virtual


FeatureLineCollectionMap Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Methods
FeatureLineCollectionMap Methods Public Methods
FeatureLineCollectionMap Methods
Public Methods
Public Method | Description
CodeNames | Gets an array of code names used in all feature lines in the collection.
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Methods
Legend
Legend
Method
public
virtual


FeatureLineComponentCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Methods
FeatureLineComponentCollection Methods Public Methods
FeatureLineComponentCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Methods
Legend
Legend
Method
public
virtual


FeatureLinePointCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Methods
FeatureLinePointCollection Methods Public Methods
FeatureLinePointCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Methods
Legend
Legend
Method
public
virtual


HardcodedOffsetBaseline Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Methods
HardcodedOffsetBaseline Methods Public Methods
HardcodedOffsetBaseline Methods
Public Methods
Public Method | Description
SortedStations | Gets the sorted stations for the baseline.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Methods
Legend
Legend
Method
public
virtual


IntersectionRegionCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Methods
IntersectionRegionCollection Methods Public Methods
IntersectionRegionCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Methods
Legend
Legend
Method
public
virtual


IntersectionRoadCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Methods
IntersectionRoadCollection Methods Public Methods
IntersectionRoadCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Methods
Legend
Legend
Method
public
virtual


LinkCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods
LinkCollection Methods Public Methods
LinkCollection Methods
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Methods
Legend
Legend
Method
public
virtual


OffsetBaseline Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Methods
OffsetBaseline Methods Public Methods
OffsetBaseline Methods
Public Methods
Public Method | Description
GetOffsetElevationFromMainBaselineStation | Gets the offset at a station from main baseline.
MainBaselineStationToOffsetBaselineStation | Transforms the Main Baseline station to an offset Baseline station.
OffsetBaselineStationToMainBaselineStation | Transforms the offset Baseline station to Main Baseline station.
SortedStations | Gets the sorted stations for the baseline.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Methods
Legend
Legend
Method
public
virtual


OffsetBaselineCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Methods
OffsetBaselineCollection Methods Public Methods
OffsetBaselineCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
OffsetBaselineNames | Gets an array of OffsetBaseline names.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Methods
Legend
Legend
Method
public
virtual


Point Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Methods
Point Methods Public Methods
Point Methods
Public Methods
Public Method | Description
GetXYZ | Gets the XYZ world coordinates from the soe cordinates


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Methods
Legend
Legend
Method
public


PointCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods
PointCollection Methods Public Methods
PointCollection Methods
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Methods
Legend
Legend
Method
public
virtual


SampledSectionLinkCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Methods
SampledSectionLinkCollection Methods Public Methods
SampledSectionLinkCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Methods
Legend
Legend
Method
public
virtual


ShapeCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods
ShapeCollection Methods Public Methods
ShapeCollection Methods
Public Methods
Public Method | Description
Add | Overloaded
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method return an enumerator which can be used to enumerate this... more
Remove | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Methods
Legend
Legend
Method
public
virtual


SlopeElevationTarget Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Methods
SlopeElevationTarget Methods Public Methods
SlopeElevationTarget Methods
Public Methods
Public Method | Description
GetElevation | Overloaded
GetNearestPipeOfNetworkToAlignment | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Methods
Legend
Legend
Method
public


AssemblyStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Methods
AssemblyStyle Methods Public Methods
AssemblyStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the corridor model display components.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the corridor plan display components.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Methods
Legend
Legend
Method
public


AssemblyStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class > AssemblyStyleCollection Methods
AssemblyStyleCollection Methods Public Methods
AssemblyStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class > AssemblyStyleCollection Methods
Legend
Legend
Method
public
virtual


CodeSetStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Methods
CodeSetStyle Methods Public Methods
CodeSetStyle Methods
Public Methods
Public Method | Description
Add | Add method.
GetCurrentStyleSetId | Gets the ObjectId of the current CodeSetStyle. void InitAsCurrent();
GetEnumerator | Get the enumerator of this collection.
GetItemBy | Indexer.
GetObjectEnumerator | Get the enumerator of this collection.
Remove | Remove method.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Methods
Legend
Legend
Method
public
virtual


CodeSetStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class > CodeSetStyleCollection Methods
CodeSetStyleCollection Methods Public Methods
CodeSetStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class > CodeSetStyleCollection Methods
Legend
Legend
Method
public
virtual


CorridorStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Methods
CorridorStyle Methods Public Methods
CorridorStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies the corridor model display components.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies the corridor plan display components.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class > CorridorStyle Methods
Legend
Legend
Method
public


CorridorStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class > CorridorStyleCollection Methods
CorridorStyleCollection Methods Public Methods
CorridorStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class > CorridorStyleCollection Methods
Legend
Legend
Method
public
virtual


IntersectionStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Methods
IntersectionStyle Methods Public Methods
IntersectionStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties for the intersection component.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties for the intersection component.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Methods
Legend
Legend
Method
public


IntersectionStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class > IntersectionStyleCollection Methods
IntersectionStyleCollection Methods Public Methods
IntersectionStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class > IntersectionStyleCollection Methods
Legend
Legend
Method
public
virtual


LinkStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Methods
LinkStyle Methods Public Methods
LinkStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
GetDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
GetDisplayStyleSection | Gets the DisplayStyle that specifies such Section display styles as color, linetype, plotstyle, etc.
GetLinkDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
GetLinkDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Methods
Legend
Legend
Method
public


LinkStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class > LinkStyleCollection Methods
LinkStyleCollection Methods Public Methods
LinkStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class > LinkStyleCollection Methods
Legend
Legend
Method
public
virtual


QuantityTakeoffCriteria Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Methods
QuantityTakeoffCriteria Methods Public Methods
QuantityTakeoffCriteria Methods
Public Methods
Public Method | Description
AddMaterial | Adds a new empty material with the default value to the list.
Clear | Removes all the material items from the list.
RemoveAt | Removes a material item from the list.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Methods
Legend
Legend
Method
public


QuantityTakeoffCriteriaCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class > QuantityTakeoffCriteriaCollection Methods
QuantityTakeoffCriteriaCollection Methods Public Methods
QuantityTakeoffCriteriaCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class > QuantityTakeoffCriteriaCollection Methods
Legend
Legend
Method
public
virtual


QuantityTakeoffCriteriaItem Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Methods
QuantityTakeoffCriteriaItem Methods Public Methods
QuantityTakeoffCriteriaItem Methods
Public Methods
Public Method | Description
AddCorridorShape | Adds a new corridor shape data with the default value to the material item.
AddSurface | Remove a surface data from the material item.
RemoveCorridorShape | Remove a corridor shape data from the material item.
RemoveSurface | Adds a new surface data with the default value to the material item.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Methods
Legend
Legend
Method
public


ShapeStyle Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods
ShapeStyle Methods Public Methods
ShapeStyle Methods
Public Methods
Public Method | Description
GetDisplayStyleModel | Gets the DisplayStyle object that specifies model display properties.
GetDisplayStylePlan | Gets the DisplayStyle object that specifies plan display properties.
GetDisplayStyleProfile | Gets the DisplayStyle object that specifies profile display properties.
GetDisplayStyleSection | Gets the DisplayStyle object that specifies section display properties.
GetHatchDisplayStyleModel | Gets the HatchDisplayStyle object that specifies model display properties.
GetHatchDisplayStylePlan | Gets the HatchDisplayStyle object that specifies plan display properties.
GetHatchDisplayStyleProfile | Gets the HatchDisplayStyle object that specifies profile display properties.
GetHatchDisplayStyleSection | Gets the HatchDisplayStyle object that specifies section display properties.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Methods
Legend
Legend
Method
public


ShapeStyleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class > ShapeStyleCollection Methods
ShapeStyleCollection Methods Public Methods
ShapeStyleCollection Methods
Public Methods
Public Method | Description
Add | Creates a new style object, adds it to the collection, and returns an ObjectId for the object.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class > ShapeStyleCollection Methods
Legend
Legend
Method
public
virtual


Subassembly Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Methods
Subassembly Methods Public Methods
Subassembly Methods
Public Methods
Public Method | Description
EraseAllParams | Erases all the subassembly's script parameters.
GetResourceString | Overloaded
Run | Runs the callback function associated with the Subassembly.
ShowHelp | Shows the help information associated with a subassembly.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Methods
Legend
Legend
Method
public


SubassemblyCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Methods
SubassemblyCollection Methods Public Methods
SubassemblyCollection Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method returns an enumerator for this collection.
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Methods
Legend
Legend
Method
public
virtual


WidthOffsetTarget Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Methods
WidthOffsetTarget Methods Public Methods
WidthOffsetTarget Methods
Public Methods
Public Method | Description
GetDistanceToAlignment | Overloaded
GetNearestPipeOfNetworkToAlignment | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Methods
Legend
Legend
Method
public


CorridorState Methods Public Methods
CorridorState Methods
Public Methods
Public Method | Description
IntersectAlignment | Overloaded
IntersectLink | Intersects a ray with an assembly's links.
IntersectSurface | Overloaded
IsAboveSurface | Overloaded
RecordError | Record error.
SampleSection | Samples elevation along an existing surface.
SoeToXyz | Transforms from assembly local station, offset, elevation (SOE) coordinates to world x,y,z coordinates.
XyzToSoe | Transforms from world x,y,z coordinates to assembly local station, offset, elevation (SOE) coordinates.


ParamAlignmentCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Methods
ParamAlignmentCollection Methods Public Methods
ParamAlignmentCollection Methods
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Methods
Legend
Legend
Method
public
virtual


ParamBoolCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Methods
ParamBoolCollection Methods Public Methods
ParamBoolCollection Methods
Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Methods
Legend
Legend
Method
public
virtual


ParamCollectionBase Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Methods
ParamCollectionBase Methods Public Methods
ParamCollectionBase Methods
Public Methods
Public Method | Description
GetEnumerator | Implements the method declared in the IEnumerable<T> interface. This method return an enumerator which can be use to enumerate this... more
GetObjectEnumerator | Implements the method declared in the IEnumerable interface. This method returns an enumerator for this collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Methods
Legend
Legend
Method
public
virtual


ParamDoubleCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Methods
ParamDoubleCollection Methods Public Methods
ParamDoubleCollection Methods
Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Methods
Legend
Legend
Method
public
virtual


ParamElevationTargetCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Methods
ParamElevationTargetCollection Methods Public Methods
ParamElevationTargetCollection Methods
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Methods
Legend
Legend
Method
public
virtual


ParamLong Methods Public Methods
ParamLong Methods
Public Methods
Public Method | Description
AddEnumData | Gets the name, display name, and value for the enum specified by name.
EnumCount | Gets the number of values in the enums for this parameter.
GetEnumData | Gets the name, display name, and value for the enum specified by index.


ParamLongCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Methods
ParamLongCollection Methods Public Methods
ParamLongCollection Methods
Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Methods
Legend
Legend
Method
public
virtual


ParamOffsetTargetCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Methods
ParamOffsetTargetCollection Methods Public Methods
ParamOffsetTargetCollection Methods
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Methods
Legend
Legend
Method
public
virtual


ParamPoint Methods Public Methods
ParamPoint Methods
Public Methods
Public Method | Description
GetPoint | Gets the station, offset, and elevation associated with the parameter.
SetPoint | Sets the station, offset, and elevation associated with the parameter.


ParamPointCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Methods
ParamPointCollection Methods Public Methods
ParamPointCollection Methods
Public Methods
Public Method | Description
Add | Overloaded
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Methods
Legend
Legend
Method
public
virtual


ParamProfileCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Methods
ParamProfileCollection Methods Public Methods
ParamProfileCollection Methods
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Methods
Legend
Legend
Method
public
virtual


ParamStringCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Methods
ParamStringCollection Methods Public Methods
ParamStringCollection Methods
Public Methods
Public Method | Description
Add | Adds a new item to parameters collection.
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Methods
Legend
Legend
Method
public
virtual


ParamSurfaceCollection Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Methods
ParamSurfaceCollection Methods Public Methods
ParamSurfaceCollection Methods
Public Methods
Public Method | Description
Value | Overloaded


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Methods
Legend
Legend
Method
public
virtual


PipeNetworkState Methods Public Methods
PipeNetworkState Methods
Public Methods
Public Method | Description
RuleResourceString | Resolves resource string ids defined inside the C3DPipeRules.DVB project.
SetAlignmentOnPart | Sets the specified parameter of alignment on the current part.
SetBoolOnPart | Sets the specified parameter of bool on the current part.
SetDoubleOnCurrentPart | Sets an double value on the current part for the specified parameter.
SetErrorMsgOnCurrentPart | Sets an error message on the current part for the specified parameter.
SetLongOnPart | Sets the specified parameter of long on the current part.
SetPointOnPart | Sets the specified parameter of point on the current part.
SetProfileOnPart | Sets the specified parameter of profile on the current part.
SetStringOnPart | Sets the specified parameter of string on the current part.
SetSurfaceOnPart | Sets the specified parameter of surface on the current part.


SettingsObjectLayers Methods Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Methods
SettingsObjectLayers Methods Public Methods
SettingsObjectLayers Methods
Public Methods
Public Method | Description
GetObjectLayerSetting | Gets a SettingsObjectLayer object by specifying its type.


Public Methods

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Methods
Legend
Legend
Method
public


SettingsRoot Methods Public Methods
SettingsRoot Methods
Public Methods
Public Method | Description
GetSettings | Gets feature settings or command settings by specifying a type.


SettingsUnitZone Methods Public Methods
SettingsUnitZone Methods
Public Methods
Public Method | Description
GetAllCodes | Gets an array that specifies all avilable code strings.
GetCoordinateSystemByCode | Gets an coordinate system by an code string.


AppliedAssembly Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Nested Types
AppliedAssembly Nested Types Public Nested Types
AppliedAssembly Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssembly::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Nested Types
Legend
Legend
public


AppliedAssemblyCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Nested Types
AppliedAssemblyCollection Nested Types Public Nested Types
AppliedAssemblyCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedAssemblyCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Nested Types
Legend
Legend
public


AppliedSubassembly Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Nested Types
AppliedSubassembly Nested Types Public Nested Types
AppliedSubassembly Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassembly::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Nested Types
Legend
Legend
public


AppliedSubassemblyCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Nested Types
AppliedSubassemblyCollection Nested Types Public Nested Types
AppliedSubassemblyCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassemblyCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Nested Types
Legend
Legend
public


Baseline Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Nested Types
Baseline Nested Types Public Nested Types
Baseline Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::Baseline::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Nested Types
Legend
Legend
public


BaselineFeatureLines Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Nested Types
BaselineFeatureLines Nested Types Public Nested Types
BaselineFeatureLines Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLines::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Nested Types
Legend
Legend
public


BaselineFeatureLinesCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Nested Types
BaselineFeatureLinesCollection Nested Types Public Nested Types
BaselineFeatureLinesCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLinesCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Nested Types
Legend
Legend
public


BaselineRegion Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Nested Types
BaselineRegion Nested Types Public Nested Types
BaselineRegion Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegion::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Nested Types
Legend
Legend
public


BaselineRegionCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Nested Types
BaselineRegionCollection Nested Types Public Nested Types
BaselineRegionCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::BaselineRegionCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Nested Types
Legend
Legend
public


CalculatedLink Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Nested Types
CalculatedLink Nested Types Public Nested Types
CalculatedLink Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLink::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Nested Types
Legend
Legend
public


CalculatedLinkCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Nested Types
CalculatedLinkCollection Nested Types Public Nested Types
CalculatedLinkCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedLinkCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Nested Types
Legend
Legend
public


CalculatedPoint Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Nested Types
CalculatedPoint Nested Types Public Nested Types
CalculatedPoint Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPoint::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Nested Types
Legend
Legend
public


CalculatedPointCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Nested Types
CalculatedPointCollection Nested Types Public Nested Types
CalculatedPointCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedPointCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Nested Types
Legend
Legend
public


CalculatedShape Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Nested Types
CalculatedShape Nested Types Public Nested Types
CalculatedShape Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShape::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Nested Types
Legend
Legend
public


CalculatedShapeCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Nested Types
CalculatedShapeCollection Nested Types Public Nested Types
CalculatedShapeCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedShapeCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Nested Types
Legend
Legend
public


CalculatedSubentity Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Nested Types
CalculatedSubentity Nested Types Public Nested Types
CalculatedSubentity Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Nested Types
Legend
Legend
public


CodeCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Nested Types
CodeCollection Nested Types Public Nested Types
CodeCollection Nested Types
Public Nested Types
Public Nested Type | Description
SubEntityType | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CodeCollection::SubEntityType.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Nested Types
Legend
Legend
public


CorridorCodeCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Nested Types
CorridorCodeCollection Nested Types Public Nested Types
CorridorCodeCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorCodeCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Nested Types
Legend
Legend
public


CorridorSurface Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Nested Types
CorridorSurface Nested Types Public Nested Types
CorridorSurface Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurface::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Nested Types
Legend
Legend
public


CorridorSurfaceBaseMask Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Nested Types
CorridorSurfaceBaseMask Nested Types Public Nested Types
CorridorSurfaceBaseMask Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Nested Types
Legend
Legend
public


CorridorSurfaceBoundaryCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Nested Types
CorridorSurfaceBoundaryCollection Nested Types Public Nested Types
CorridorSurfaceBoundaryCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Nested Types
Legend
Legend
public


CorridorSurfaceMaskCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Nested Types
CorridorSurfaceMaskCollection Nested Types Public Nested Types
CorridorSurfaceMaskCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMaskCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Nested Types
Legend
Legend
public


FeatureLine Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Nested Types
FeatureLine Nested Types Public Nested Types
FeatureLine Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLine::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Nested Types
Legend
Legend
public


FeatureLineCodeInfo Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Nested Types
FeatureLineCodeInfo Nested Types Public Nested Types
FeatureLineCodeInfo Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfo::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Nested Types
Legend
Legend
public


FeatureLineCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Nested Types
FeatureLineCollection Nested Types Public Nested Types
FeatureLineCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Nested Types
Legend
Legend
public


FeatureLineCollectionMap Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Nested Types
FeatureLineCollectionMap Nested Types Public Nested Types
FeatureLineCollectionMap Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollectionMap::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Nested Types
Legend
Legend
public


FeatureLineComponent Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Nested Types
FeatureLineComponent Nested Types Public Nested Types
FeatureLineComponent Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponent::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Nested Types
Legend
Legend
public


FeatureLineComponentCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Nested Types
FeatureLineComponentCollection Nested Types Public Nested Types
FeatureLineComponentCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponentCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Nested Types
Legend
Legend
public


FeatureLinePoint Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Nested Types
FeatureLinePoint Nested Types Public Nested Types
FeatureLinePoint Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePoint::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Nested Types
Legend
Legend
public


FeatureLinePointCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Nested Types
FeatureLinePointCollection Nested Types Public Nested Types
FeatureLinePointCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePointCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Nested Types
Legend
Legend
public


HardcodedOffsetBaseline Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Nested Types
HardcodedOffsetBaseline Nested Types Public Nested Types
HardcodedOffsetBaseline Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::HardcodedOffsetBaseline::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Nested Types
Legend
Legend
public


OffsetBaseline Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Nested Types
OffsetBaseline Nested Types Public Nested Types
OffsetBaseline Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaseline::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Nested Types
Legend
Legend
public


OffsetBaselineCollection Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Nested Types
OffsetBaselineCollection Nested Types Public Nested Types
OffsetBaselineCollection Nested Types
Public Nested Types
Public Nested Type | Description
Identity | This is nested type Autodesk::Civil::Roadway::DatabaseServices::OffsetBaselineCollection::Identity.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Nested Types
Legend
Legend
public


ParamBase Nested Types Public Nested Types
ParamBase Nested Types
Public Nested Types
Public Nested Type | Description
InnerType | This is nested type Autodesk::Civil::Runtime::ParamBase::InnerType.
TCast | This is nested type Autodesk::Civil::Runtime::ParamBase::TCast.
ValueType | This is nested type Autodesk::Civil::Runtime::ParamBase::ValueType.


ParamCollectionBase Nested Types Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Nested Types
ParamCollectionBase Nested Types Public Nested Types
ParamCollectionBase Nested Types
Public Nested Types
Public Nested Type | Description
InnerType | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::InnerType.
TCast | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::TCast.
ValueType | This is nested type Autodesk::Civil::Runtime::ParamCollectionBase::ValueType.


Public Nested Types

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Nested Types
Legend
Legend
public


PolylineOptions Operators Public Operators

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Operators
PolylineOptions Operators Public Operators
PolylineOptions Operators
Public Operators
Public Operator | Description
!= | Compares two PolylineOptions objects, returns true if they are not equal.
== | Compares two PolylineOptions objects, returns true if they are equal.


Public Operators

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Operators
Legend
Legend
Operator
public


CivilApplication Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilApplication Class > CivilApplication Properties
CivilApplication Properties Public Properties
CivilApplication Properties
Public Properties
Public Property | Description
ActiveDocument | Gets the active CivilDocument object.
ActiveProduct | Gets the type of the currently running product.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilApplication Class > CivilApplication Properties
Legend
Legend
Property
public


CivilDocument Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties
CivilDocument Properties Public Properties
CivilDocument Properties
Public Properties
Public Property | Description
AssemblyCollection | Gets the ObjectId collection of Assembly objects in the drawing.
CorridorCollection | Gets the ObjectId collection of Corridor objects in the drawing.
CorridorState | Gets the CorridorState object, which is used for the creation of custom subassemblies.
IsCorridorSectionViewActive | Returns true if the corridor section view is active in the current document.
NetworkState | Gets the drawing's PipeNetworkState object.
Settings | Gets the root object for Civil 3D settings.
Styles | Gets the root object for Civil 3D styles.
SubassemblyCollection | Gets the ObjectId collection of SubAssembly objects in the drawing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::ApplicationServices Namespace > Classes > CivilDocument Class > CivilDocument Properties
Legend
Legend
Property
public


AutoFeatureLabelGroup Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Properties
AutoFeatureLabelGroup Properties Public Properties
AutoFeatureLabelGroup Properties
Public Properties
Public Property | Description
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Gets or sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Gets or sets whether the range starts at the same value where the feature starts.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > AutoFeatureLabelGroup Class > AutoFeatureLabelGroup Properties
Legend
Legend
Property
public


DBObject Properties Public Properties
DBObject Properties
Public Properties
Public Property | Description
Application | Gets the Application associated with the DBObject. Not implemented.
Description | Gets or sets the description.
Document | Gets the Document associated with the DBObject. Not implemented.
Name | Gets or sets the name.


Entity Properties Public Properties
Entity Properties
Public Properties
Public Property | Description
Application | Gets the Application. Not currently implemented.
DisplayName | Gets the Entity object's display name.
Document | Gets the Document. Not currently implemented.
IsReferenceObject | Gets whether the Entity is a reference object. A reference object is located in another drawing, and linked using a... more
IsReferenceStale | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is stale.
IsReferenceSubObject | For reference objects (IsReferenceObject == true), gets whether the Entity is a reference subobject. For example, when iterating through... more
IsReferenceValid | For reference objects (IsReferenceObject == true), gets whether the Entity object's reference is valid. This indicates whether the referenced... more
Name | Gets or sets the Entity object's name.
ShowToolTip | Gets or sets whether to show tooltips for the Entity.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


Feature Properties Public Properties
Feature Properties
Public Properties
Public Property | Description
IsEditable | Gets the value indicates whether the Feature derived entity (Alignment,Profile,etc) is editable.


GraphOverride Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > GraphOverride Class > GraphOverride Properties
GraphOverride Properties Public Properties
GraphOverride Properties
Public Properties
Public Property | Description
Draw | Gets or sets whether this entity will be drawn in the graph.
OverrideStyleId | Gets or sets the override style of the entity.
OverrideStyleName | Gets or sets the override style of the entity.
UseOverrideStyle | Gets or sets whether to override style for the display of the entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > GraphOverride Class > GraphOverride Properties
Legend
Legend
Property
public


ICommonLabel Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties
ICommonLabel Properties Public Properties
ICommonLabel Properties
Public Properties
Public Property | Description
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the label style id.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabel Interface > ICommonLabel Properties
Legend
Legend
Property
public


ICommonLabelOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties
ICommonLabelOptions Properties Public Properties
ICommonLabelOptions Properties
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Interfaces > ICommonLabelOptions Interface > ICommonLabelOptions Properties
Legend
Legend
Property
public


Label Properties Public Properties
Label Properties
Public Properties
Public Property | Description
AnchorInfo | Gets information about the label anchor.
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the Entity object's style Id.
StyleName | Gets or sets the Entity object's style name.


LabelBase Properties Public Properties
LabelBase Properties
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AutoStagger | Gets or sets the auto stagger type on the label object.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
FeatureId | Gets the ObjectId of the feature being labeled by the label object.
Mask | Gets or sets the mask type.
ViewId | Gets the ObjectId of the view where the label exists.


LabelGroup Properties Public Properties
LabelGroup Properties
Public Properties
Public Property | Description
DescriptiveText | Gets a description of the label.
IsGroupLabelType | Specifies whether the label is a group label.
LabelType | Gets the type of the label.
StyleId | Gets or sets the label group's style Id.
StyleName | Gets or sets the label style name.
SubEntities | Gets the number of sub-entity labels managed by this group label.
SubEntityCount | Gets the number of sub-entity labels managed by this group label.


LabelGroupSubEntity Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties
LabelGroupSubEntity Properties Public Properties
LabelGroupSubEntity Properties
Public Properties
Public Property | Description
AllowsAnchorMarker | Gets a boolean value that specifies whether anchor markers are supported by the label object.
AllowsDimensionAnchors | Gets a boolean value that specifies whether dimension anchors are supported by the label object.
AllowsDragging | Gets a boolean value that specifies whether the label object can be dragged.
AllowsFlipping | Gets a boolean value that specifies whether the label object can be flipped.
AllowsLeaderAttachment | Gets a boolean value that specifies whether leader attachment options are supported by the label object.
AllowsPinning | Gets a boolean value that specifies whether the label object can be pinned.
AllowsReversing | Gets a boolean value that specifies whether the label object can be reversed.
AnchorInfo | ICommonLabel
AnchorMarkerStyleId | Gets or sets the anchor marker style.
DefaultDimensionAnchorOption | Gets or sets the default dimension anchor option.
DefaultDimensionAnchorValue | Gets or sets the default anchor value.
DimensionAnchorInfo | Gets information about the label dimension anchor.
DimensionAnchorOption | Gets or sets the dimension anchor option.
DimensionAnchorValue | Gets or sets the dimension anchor value.
Dragged | Gets a bool value that specifies whether the label has been dragged.
DraggedOffset | Gets or sets the dragged offset on the sub-entity label.
Flipped | Gets or sets the flipped state of the label.
Index | Gets a reference to the LabelGroup instance parent of this object.
LeaderAttachment | Gets or sets the leader attachment option.
LeaderTailVisibility | Gets or sets the leader tail visibility.
LeaderVisibility | Gets or sets the leader visibility.
Parent | Gets a reference to the LabelGroup instance parent of this object.
Pinned | Gets or sets the pinned state of the label.
Reversed | Gets or sets the reversed state of the label.
StyleId | Gets or sets the label style.
Visibility | This is Visibility, a member of class LabelGroupSubEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Classes > LabelGroupSubEntity Class > LabelGroupSubEntity Properties
Legend
Legend
Property
public


AxisStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Properties
AxisStyle Properties Public Properties
AxisStyle Properties
Public Properties
Public Property | Description
HorizontalGeometryTickStyle | Gets the style object that specifies the appearance of horizontal geometry ticks on the horizontal axes, for example, interval, size,... more
MajorTickStyle | Gets the style object that specifies the appearance of major ticks on the vertical or horizontal axes, for example, interval,... more
MinorTickStyle | Gets the style object that specifies the appearance of minor ticks on the vertical or horizontal axes, for example, interval,... more
ShowTickAndLabel | Gets or sets the boolean value that specifies whether ticks and labels are placed at the start station on the... more
TitleStyle | Gets the style object that controls the appearance of the axis title text for profile or section views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class > AxisStyle Properties
Legend
Legend
Property
public


AxisTickStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties
AxisTickStyle Properties Public Properties
AxisTickStyle Properties
Public Properties
Public Property | Description
Interval | Gets or sets the spacing of ticks on the axes, using the actual ground units.
Justification | Gets or sets the justification (alignment) of the title.
LabelText | Gets or sets the label text for the tick.
OffsetX | Gets or sets a horizontal offset for the tick label from the bottom of the tick.
OffsetY | Gets or sets a vertical offset for the tick label from the bottom of the tick.
Rotation | Gets or sets the angle for the tick label.
Size | Gets or sets the height of the actual ticks on axes, using plotted units.
TextHeight | Gets or sets the height of text (in plotted units) used to label ticks.
TextStyle | Gets or sets the text style for the tick label from the available AutoCAD text styles defined in the current... more
TickAndLabelStartElevation | Gets or sets a boolean value specifies that whether need to tick and label the start elevatioin.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class > AxisTickStyle Properties
Legend
Legend
Property
public


AxisTitleStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties
AxisTitleStyle Properties Public Properties
AxisTitleStyle Properties
Public Properties
Public Property | Description
Location | Gets or sets the location of the title in relation to the view grid.
OffsetX | Gets or sets a horizontal offset from the Location setting.
OffsetY | Gets or sets a vertical offset from the Location setting.
Rotation | Gets or sets the angle for the axis title.
Text | Gets or sets the title text for the axis.
TextHeight | Gets or sets the axis title text height (in plotted units).
TextStyle | Gets or sets the text style for the axis title from the available AutoCAD text styles defined in the current... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class > AxisTitleStyle Properties
Legend
Legend
Property
public


BandSetItem Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Properties
BandSetItem Properties Public Properties
BandSetItem Properties
Public Properties
Public Property | Description
BandStyleId | Gets the object that identifies the style for the band type.
Gap | Gets or sets the distance between the current data band and the adjacent grid or data band.
Location | Gets the BandSetOptionsType enum value that identifies band location and display settings.
Weeding | Gets or sets the weeding value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class > BandSetItem Properties
Legend
Legend
Property
public


BandSetItemCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Properties
BandSetItemCollection Properties Public Properties
BandSetItemCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of band style sets in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class > BandSetItemCollection Properties
Legend
Legend
Property
public


BandStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties
BandStyle Properties Public Properties
BandStyle Properties
Public Properties
Public Property | Description
BandHeight | Gets or sets the height of the band used in the title.
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
OffsetFromBand | Gets or sets the distance between the title box and the left side of the data band.
Text | Gets or sets the current title text.
TextBoxPosition | Gets or sets the text box position of the band title.
TextBoxWidth | Gets or sets the width of the box that contains the text of the band title.
TextHeight | Gets or sets the height of the band title text in plot units.
TextLocation | Gets or sets the band title text location.
TextStyle | Gets or sets the string name of the AutoCAD text style for the band.
TitleTextLabelStyleId | Gets the band profile data title text label style.
WeedingFactor | Gets or sets the band weeding factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class > BandStyle Properties
Legend
Legend
Property
public


BandStylesRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties
BandStylesRoot Properties Public Properties
BandStylesRoot Properties
Public Properties
Public Property | Description
ProfileViewHorizontalGeometryBandStyles | Gets the collection of all profile view horizontal geometry band styles.
ProfileViewPipeNetworkBandStyles | Gets the collection of all profile view pipe network band styles.
ProfileViewProfileDataBandStyles | Gets the collection of all profile view profile data band styles.
ProfileViewSectionalDataBandStyles | Gets the collection of all profile view sectional data band styles.
ProfileViewSuperElevationBandStyles | Gets the collection of all profile view super elevation band styles.
ProfileViewVerticalGeometryBandStyles | Gets the collection of all profile view vertical geometry band styles.
SectionViewSectionDataBandStyles | Gets the collection of all section view section data band styles.
SectionViewSegmentsBandStyles | Gets the collection of all section view section segments band styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class > BandStylesRoot Properties
Legend
Legend
Property
public


BandTickStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties
BandTickStyle Properties Public Properties
BandTickStyle Properties
Public Properties
Public Property | Description
IncrementSmallTicksAtBottom | Gets or sets the boolean value that indicates whether to draw the tick(s) at the bottom of the selected type.... more
IncrementSmallTicksAtMiddle | Gets or sets the boolean value that indicates whether to draw the tick(s) in the middle of the selected type.... more
IncrementSmallTicksAtTop | Gets or sets the boolean value that indicates whether to draw the tick(s) at the top of the selected type.... more
IncrementTicksToFullHeight | Gets or sets the boolean value that indicates whether to draw the tick at the full band height.
SmallTicksAtBottomSize | Gets or sets the height, in drawing units, of small ticks located at the bottom of the data band.
SmallTicksAtMiddleSize | Gets or sets the height, in drawing units, of small ticks located at the middle of the data band.
SmallTicksAtTopSize | Gets or sets the height, in drawing units, of small ticks located at the top of the data band.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class > BandTickStyle Properties
Legend
Legend
Property
public


BaseLabelSetItem Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class > BaseLabelSetItem Properties
BaseLabelSetItem Properties Public Properties
BaseLabelSetItem Properties
Public Properties
Public Property | Description
LabelStyleId | Gets or Sets the label style object id in the current label set item.
LabelStyleName | Gets or Sets the label style name in the current label set item.
LabelStyleType | Gets the label type in the current label set item.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class > BaseLabelSetItem Properties
Legend
Legend
Property
public


BaseLabelSetStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Properties
BaseLabelSetStyle Properties Public Properties
BaseLabelSetStyle Properties
Public Properties
Public Property | Description
Count | Gets the number of label set items.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class > BaseLabelSetStyle Properties
Legend
Legend
Property
public


ColumnStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties
ColumnStyle Properties Public Properties
ColumnStyle Properties
Public Properties
Public Property | Description
ColumnWidth | Gets or sets the column width of the column style, 0 represents auto width.
ContentJustification | Gets or sets the Content Justification of column style.
ContentString | Gets the display content of column style, this property is usable for most table columns, but for alignment segment table,... more
ContentStringFormatted | Gets the formatted content of column style, this property is usable for most table columns, but for alignment segment table,... more
HeaderJustification | Gets or sets the Header Justification of column style
HeaderString | Gets or sets the display header string of the column style.
HeaderStringFormatted | Gets or sets the formatted header string of the column style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class > ColumnStyle Properties
Legend
Legend
Property
public


ColumnStyleCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Properties
ColumnStyleCollection Properties Public Properties
ColumnStyleCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of column styles in the collection.
default | Gets the column style at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class > ColumnStyleCollection Properties
Legend
Legend
Property
public


Expression Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Properties
Expression Properties Public Properties
Expression Properties
Public Properties
Public Property | Description
Description | Gets and sets the description of the Expression.
ExpressionString | Gets or sets the expression string of the Expression.
FormatResultAs | Gets or sets the format type of the expression result.
Name | Gets the name of the Expression.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class > Expression Properties
Legend
Legend
Property
public


ExpressionCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Properties
ExpressionCollection Properties Public Properties
ExpressionCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of Expression objects in the collection.
default | Gets the Expression at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class > ExpressionCollection Properties
Legend
Legend
Property
public


FeatureLineStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties
FeatureLineStyle Properties Public Properties
FeatureLineStyle Properties
Public Properties
Public Property | Description
FeatureLineDisplayStyleModel | Gets the DisplayStyle property that specifies, for the feature line, such Model display styles as color, linetype, plotstyle, etc.
FeatureLineDisplayStylePlan | Gets the DisplayStyle property that specifies, for the feature line, such Plan display styles as color, linetype, plotstyle, etc.
ProfileBeginningVertexMarkerStyleId | Gets or sets the object id of the profile beginning vertex marker style for the feature line style.
ProfileBeginningVertexMarkerStyleName | Gets or sets the name of the profile beginning vertex marker style for the feature line style.
ProfileEndingVertexMarkerStyleId | Gets or sets the object id of the profile ending vertex marker style for the feature line style.
ProfileEndingVertexMarkerStyleName | Gets or sets the name of the profile ending vertex marker style for the feature line style.
ProfileInternalVertexMarkerStyleId | Gets or sets the object id of the profile internal vertex marker style for the feature line style.
ProfileInternalVertexMarkerStyleName | Gets or sets the name of the profile internal vertex marker style for the feature line style.
SectionMarkerDisplayStyleSection | Gets the DisplayStyle property that specifies, for the section marker, such Section display styles as color, linetype, plotstyle, etc.
SectionMarkerStyleId | Gets or sets the object id of the marker style for the feature line style.
SectionMarkerStyleName | Gets or sets the name of the marker style for the feature line style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class > FeatureLineStyle Properties
Legend
Legend
Property
public


GraphStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Properties
GraphStyle Properties Public Properties
GraphStyle Properties
Public Properties
Public Property | Description
CurrentHorizontalScale | Gets the plotted size of graph horizontal scale from draw setting.
Direction | Gets or sets the direction of the profile in the profile view grid.
TitleStyle | Gets the style object that specifies graph title text display properties for cross section and profile views.
VerticalExaggeration | Gets or sets the graph vertical exaggeration factor.
VerticalScale | Gets or sets the vertical scale of the profile view or section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class > GraphStyle Properties
Legend
Legend
Property
public


GraphTitleStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties
GraphTitleStyle Properties Public Properties
GraphTitleStyle Properties
Public Properties
Public Property | Description
Border | Gets or sets a bool value that specifies whether a border line is drawn around the title block.
BorderGap | Gets or sets the gap between the border and graph title text in plotted units.
Justification | Gets or sets the justification (alignment) of the title.
Location | Gets or sets the location of the title in relation to the view grid.
OffsetX | Gets or sets a horizontal offset from the position set by the Location and Justification values.
OffsetY | Gets or sets a vertical offset from the position set by Location and Justification values.
Text | Gets or sets the graph title text.
TextHeight | Gets or sets the current text height in drawing units.
TextStyle | Gets or sets the text style for the graph title from the available AutoCAD text styles defined in the current... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class > GraphTitleStyle Properties
Legend
Legend
Property
public


GridOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class > GridOptions Properties
GridOptions Properties Public Properties
GridOptions Properties
Public Properties
Public Property | Description
ClipToHighestProfile | Specifies whether vertical or horizontal profile view grid lines are drawn to the highest of all displayed profiles.
OmitGridInPaddingAreas | Specifies whether vertical or horizontal profile view grid lines are not drawn in the padding areas.
UseClipGrid | Specifies whether to clip a vertical or horizontal grid lines at a selected profile..


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class > GridOptions Properties
Legend
Legend
Property
public


GridStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties
GridStyle Properties Public Properties
GridStyle Properties
Public Properties
Public Property | Description
AxisOffsetAbove | Gets or sets the distance to offset the axis above the vertical extent.
AxisOffsetBottom | Gets or sets the distance to offset the axis below the vertical extent.
AxisOffsetLeft | Gets or sets the distance to offset the axis to the left of the horizontal extent.
AxisOffsetRight | Gets or sets the distance to offset the horizontal axis to the right of the horizontal extent.
GridPaddingAbove | Gets or sets the number of grid blocks that the view extends above the maximum profile elevation.
GridPaddingBottom | Gets or sets the number of grid blocks that the view extends below the datum or minimum profile elevation.
GridPaddingLeft | Gets or sets the number of major grids to place before the left-most station value of the alignment.
GridPaddingRight | Gets or sets the number of major grids to place after the right-most station value of the alignment.
HorizontalGridOptions | Gets the horizontal clipping options on the profile view or section view grid.
VerticalGridOptions | Gets the vertical clipping options on the profile view or section view grid.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class > GridStyle Properties
Legend
Legend
Property
public


LabelSetStylesRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class > LabelSetStylesRoot Properties
LabelSetStylesRoot Properties Public Properties
LabelSetStylesRoot Properties
Public Properties
Public Property | Description
AlignmentLabelSetStyles | Gets the collection of all alignment label set styles in the database.
ProfileLabelSetStyles | Gets the collection of all profile label set styles in the database.
SectionLabelSetStyles | Gets the collection of all section label set styles in the database.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class > LabelSetStylesRoot Properties
Legend
Legend
Property
public


LabelStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Properties
LabelStyle Properties Public Properties
LabelStyle Properties
Public Properties
Public Property | Description
ChildrenCount | Gets the number of child label style under the current labelstyle node.
default | Gets the child lable style by name.
ParentLabelStyleId | Gets the object id of parent lable style .
Properties | Gets the leader related properties of the default label style settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class > LabelStyle Properties
Legend
Legend
Property
public


LabelStyleBase Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Properties
LabelStyleBase Properties Public Properties
LabelStyleBase Properties
Public Properties
Public Property | Description
Behavior | Gets the behavior related properties of the default label style.
DraggedStateComponents | Gets dragged state components related properties of the default label style.
Label | Gets the label related properties of the default label style.
Leader | Gets the leader related properties of the default label style.
PlanReadability | Gets the plan readability related properties of the default label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class > LabelStyleBase Properties
Legend
Legend
Property
public


LabelStyleBase::BaseBehavior Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class > LabelStyleBase::BaseBehavior Properties
LabelStyleBase::BaseBehavior Properties Public Properties
LabelStyleBase::BaseBehavior Properties
Public Properties
Public Property | Description
InsertOption | Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.
InsideCurveOption | Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.
OrientationReference | Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class > LabelStyleBase::BaseBehavior Properties
Legend
Legend
Property
public


LabelStyleBase::BaseDraggedStateComponents Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties
LabelStyleBase::BaseDraggedStateComponents Properties Public Properties
LabelStyleBase::BaseDraggedStateComponents Properties
Public Properties
Public Property | Description
BorderType | Gets the shape of the border, either rounded or rectangular.
BorderVisibility | Gets the boolean value that specifies whether a border is visible for dragged labels.
Color | Gets the color for dragged components.
DisplayType | Gets the enum value that specifies how label content is displayed after it is dragged from its default position.
Gap | Gets the distance between the leader and the label text.
LeaderAttachment | Gets the location where a leader hook is drawn in relation to label content.
LeaderJustification | Gets the boolean value that specifies the justification of label text in relation to the leader.
Linetype | Gets the linetype for dragged components.
Lineweight | Gets the linetype for dragged components.
TextHeight | Gets the plotted height for all text components.
UseBackgroundMask | Gets the boolean value that specifies whether use background mask when drawing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class > LabelStyleBase::BaseDraggedStateComponents Properties
Legend
Legend
Property
public


LabelStyleBase::BaseLabel Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Properties
LabelStyleBase::BaseLabel Properties Public Properties
LabelStyleBase::BaseLabel Properties
Public Properties
Public Property | Description
DisplayMode | Gets the display mode for all label styles in a drawing.
Layer | Gets the default layer for all label styles in a drawing.
TextStyle | Gets the default text style for all label text components in a drawing.
Visibility | Gets the boolean value that specifies visibility of labels in the drawing (independent of layer).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class > LabelStyleBase::BaseLabel Properties
Legend
Legend
Property
public


LabelStyleBase::BaseLeader Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties
LabelStyleBase::BaseLeader Properties Public Properties
LabelStyleBase::BaseLeader Properties
Public Properties
Public Property | Description
ArrowheadSize | Gets the size of the arrow head.
ArrowheadStyle | Gets the arrow head style for a leader.
Color | Gets the color for leaders.
Linetype | Gets the linetype for leaders.
Lineweight | Gets the lineweight for leaders.
Shape | Gets the enum value that specifies the shape of the leader.
Visibility | Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class > LabelStyleBase::BaseLeader Properties
Legend
Legend
Property
public


LabelStyleBase::BasePlanReadability Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class > LabelStyleBase::BasePlanReadability Properties
LabelStyleBase::BasePlanReadability Properties Public Properties
LabelStyleBase::BasePlanReadability Properties
Public Properties
Public Property | Description
FlipAnchorsWithText | Gets the boolean that specifies whether flip anchors with text.
PlanReadable | Gets the boolean that specifies whether all text components in labels can be read easily in plan view.
PlanReadableBias | Gets the angle at which label text flips 180 degrees to remain plan readable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class > LabelStyleBase::BasePlanReadability Properties
Legend
Legend
Property
public


LabelStyleBlockComponent::StyleBlock Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties
LabelStyleBlockComponent::StyleBlock Properties Public Properties
LabelStyleBlockComponent::StyleBlock Properties
Public Properties
Public Property | Description
Attachment | Gets the location on the block component that is attached to the anchor point
BlockHeight | Gets the height to whick the block is scaled to fit.
BlockName | Gets the block to use for the block component.
Color | Gets the color of block component.
Linetype | Gets the line type of the block component.
Lineweight | Gets the line weight of the block component.
RotationAngle | Gets the angle for block component.
XOffset | Gets the offset distance between the attachment point and the anchor point in the X direction
YOffset | Gets the offset distance between the attachment point and the anchor point in the Y direction


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class > LabelStyleBlockComponent::StyleBlock Properties
Legend
Legend
Property
public


LabelStyleBlockComponent::StyleGeneral Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Properties
LabelStyleBlockComponent::StyleGeneral Properties Public Properties
LabelStyleBlockComponent::StyleGeneral Properties
Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the block component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the block component is attached.
Name | Gets the name for block component.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the block component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class > LabelStyleBlockComponent::StyleGeneral Properties
Legend
Legend
Property
public


LabelStyleCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Properties
LabelStyleCollection Properties Public Properties
LabelStyleCollection Properties
Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.
Expressions | This is Expressions, a member of class LabelStyleCollection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class > LabelStyleCollection Properties
Legend
Legend
Property
public


LabelStyleDefault::DefaultBehavior Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class > LabelStyleDefault::DefaultBehavior Properties
LabelStyleDefault::DefaultBehavior Properties Public Properties
LabelStyleDefault::DefaultBehavior Properties
Public Properties
Public Property | Description
InsertOption | Gets the ForcedInsertionType enum value that specifies the position of a label relative to an object.
InsideCurveOption | Gets the LabelPlaceType enum value that specifies whether labels are placed inside or outside a curve.
OrientationReference | Gets the OrientationReferenceType enum value that specifies the orientation reference of the labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class > LabelStyleDefault::DefaultBehavior Properties
Legend
Legend
Property
public


LabelStyleDefault::DefaultComponents Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Properties
LabelStyleDefault::DefaultComponents Properties Public Properties
LabelStyleDefault::DefaultComponents Properties
Public Properties
Public Property | Description
Color | Gets the color for label components.
Linetype | Gets the linetype for label components.
Lineweight | Gets the lineweight for label components.
TextHeight | Gets the plotted height for label text.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class > LabelStyleDefault::DefaultComponents Properties
Legend
Legend
Property
public


LabelStyleDefault::DefaultDraggedStateComponents Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties
LabelStyleDefault::DefaultDraggedStateComponents Properties Public Properties
LabelStyleDefault::DefaultDraggedStateComponents Properties
Public Properties
Public Property | Description
BorderType | Gets the shape of the border, either rounded or rectangular.
BorderVisibility | Gets the boolean value that specifies whether a border is visible for dragged labels.
Color | Gets the color for dragged components.
DisplayType | Gets the enum value that specifies how label content is displayed after it is dragged from its default position.
Gap | Gets the distance between the leader and the label text.
LeaderAttachment | Gets the location where a leader hook is drawn in relation to label content.
LeaderJustification | Gets the boolean value that specifies the justification of label text in relation to the leader.
Linetype | Gets the linetype for dragged components.
Lineweight | Gets the lineweight for dragged components.
TextHeight | Gets the plotted height for all text components.
UseBackgroundMask | Gets the boolean value that specifies whether use background mask when drawing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class > LabelStyleDefault::DefaultDraggedStateComponents Properties
Legend
Legend
Property
public


LabelStyleDefault::DefaultLabel Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class > LabelStyleDefault::DefaultLabel Properties
LabelStyleDefault::DefaultLabel Properties Public Properties
LabelStyleDefault::DefaultLabel Properties
Public Properties
Public Property | Description
Layer | Gets the default layer for all label styles in a drawing.
TextStyle | Gets the default text style for all label text components in a drawing.
Visibility | Gets the boolean value that specifies visibility of labels in the drawing (independent of layer settings).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class > LabelStyleDefault::DefaultLabel Properties
Legend
Legend
Property
public


LabelStyleDefault::DefaultLeader Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties
LabelStyleDefault::DefaultLeader Properties Public Properties
LabelStyleDefault::DefaultLeader Properties
Public Properties
Public Property | Description
ArrowheadSize | Gets the size of the arrow head.
ArrowheadStyle | Gets the arrow head style for a leader.
Color | Gets the color for leaders.
Linetype | Gets the linetype for leaders.
Lineweight | Gets the lineweight for leaders.
Shape | Gets the enum value that specifies the shape of the leader.
Visibility | Gets a boolean value that sSpecifies whether leaders are visible when you drag a label from its original position.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class > LabelStyleDefault::DefaultLeader Properties
Legend
Legend
Property
public


LabelStyleDefault::DefaultPlanReadability Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class > LabelStyleDefault::DefaultPlanReadability Properties
LabelStyleDefault::DefaultPlanReadability Properties Public Properties
LabelStyleDefault::DefaultPlanReadability Properties
Public Properties
Public Property | Description
FlipAnchorsWithText | Gets the boolean that specifies whether flip anchors with text.
PlanReadable | Gets the boolean that specifies whether all text components in labels can be read easily in plan view.
PlanReadableBias | Gets the angle at which label text flips 180 degrees to remain plan readable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class > LabelStyleDefault::DefaultPlanReadability Properties
Legend
Legend
Property
public


LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties
LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties Public Properties
LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties
Public Properties
Public Property | Description
ArrowheadSize | Gets the size of arrow head in plot unit.
ArrowheadStyle | Gets the arrow head style.
Color | Gets the color of direction arrow component.
FixedLength | Gets whether the arrow length is controlled by the length setting or by the length of the object being labeled.... more
LengthOrMinimumLength | Gets the length of direction arrow.
Linetype | Gets the line type of the direction arrow component.
Lineweight | Gets the line weight of the direction arrow component.
RotationAngle | Gets the angle for direction arrow component.
XOffset | Gets the offset distance between the mid-point of the direction arrow and the anchor component in the X direction.
YOffset | Gets the offset distance between the mid-point of the direction arrow and the anchor component in the Y direction.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class > LabelStyleDirectionArrowComponent::StyleDirectionArrow Properties
Legend
Legend
Property
public


LabelStyleDirectionArrowComponent::StyleGeneral Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties
LabelStyleDirectionArrowComponent::StyleGeneral Properties Public Properties
LabelStyleDirectionArrowComponent::StyleGeneral Properties
Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the direction arrow component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the direction arrow component is attached.
Name | Gets the name for direction arrow component.
SpanOutsideSegments | Gets whether this component refers to the properties of outside segments.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the direction arrow component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class > LabelStyleDirectionArrowComponent::StyleGeneral Properties
Legend
Legend
Property
public


LabelStyleLineComponent::StyleGeneral Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties
LabelStyleLineComponent::StyleGeneral Properties Public Properties
LabelStyleLineComponent::StyleGeneral Properties
Public Properties
Public Property | Description
EndAnchorPoint | Gets the location on the end point anchor component where the end point of the line component is attached.
EndPointAnchorComponent | Gets a reference object for positioning the end point of the line component.
EndPointAnchorPoint | Gets the location on the end point anchor component where the end point of the line component is attached.
Name | Gets the name for line component.
StartAnchorPoint | Gets the location on the start point anchor component where the start point of the line component is attached.
StartPointAnchorComponent | Gets a reference object for positioning the start point of the line component.
StartPointAnchorPoint | Gets the location on the start point anchor component where the start point of the line component is attached.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
UseEndPointAnchor | Gets the method for defining the line component.
Visible | Gets whether the line component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class > LabelStyleLineComponent::StyleGeneral Properties
Legend
Legend
Property
public


LabelStyleLineComponent::StyleLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties
LabelStyleLineComponent::StyleLine Properties Public Properties
LabelStyleLineComponent::StyleLine Properties
Public Properties
Public Property | Description
Angle | Gets the angle of the line component from the start point.
Color | Gets the color of the line component.
EndPointXOffset | Gets the offsets the line end point from the end point anchor point in the X direction.
EndPointYOffset | Gets the offsets the line end point from the end point anchor point in the Y direction.
Length | Gets the length of line component.
Linetype | Gets the line type of the line component.
Lineweight | Gets the line weight of the line component.
StartPointXOffset | Gets the offsets the line start point from the start point anchor point in the X direction.
StartPointYOffset | Gets the offsets the line start point from the start point anchor point in the Y direction.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class > LabelStyleLineComponent::StyleLine Properties
Legend
Legend
Property
public


LabelStylesNode Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesNode Class > LabelStylesNode Properties
LabelStylesNode Properties Public Properties
LabelStylesNode Properties
Public Properties
Public Property | Description
DefaultLabelStyle | Gets the default vaules of label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesNode Class > LabelStylesNode Properties
Legend
Legend
Property
public


LabelStylesRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties
LabelStylesRoot Properties Public Properties
LabelStylesRoot Properties
Public Properties
Public Property | Description
AlignmentLabelStyles | Gets the root of all alignment label styles.
GeneralCurveLabelStyles | Gets the collection of all general curve label styles.
GeneralLineLabelStyles | Gets the collection of all general line label styles.
GeneralLinkLabelStyles | Gets the collection of all general link label styles.
GeneralMarkerLabelStyles | Gets the collection of all general marker label styles.
GeneralNoteLabelStyles | Gets the collection of all general note label styles.
GeneralShapeLabelStyles | Gets the collection of all general shape label styles.
IntersectionLabelStyles | Gets the root of all intersection label styles.
MatchLineLabelStyles | Gets the root of all match line label styles.
ParcelLabelStyles | Gets the root of all parcel label styles.
PipeLabelStyles | Gets the root of all pipe label styles.
PointLabelStyles | Gets the root of all point label styles.
ProfileLabelStyles | Gets the root of all profile label styles.
ProfileViewLabelStyles | Gets the root of all profile view label styles.
ProjectionLabelStyles | Gets the root of all projection label styles.
SampleLineLabelStyles | Gets the root of all sample line label styles.
SectionLabelStyles | Gets the root of all section label styles.
SectionViewLabelStyles | Gets the root of all section view label styles.
StructureLabelStyles | Gets the root of all structure label styles.
SurfaceLabelStyles | Gets the root of all surface label styles.
ViewFrameLabelStyles | Gets the root of all view frame label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class > LabelStylesRoot Properties
Legend
Legend
Property
public


LabelStyleTextComponent Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class > LabelStyleTextComponent Properties
LabelStyleTextComponent Properties Public Properties
LabelStyleTextComponent Properties
Public Properties
Public Property | Description
Border | Gets the border style settings.
General | Gets the general style settings.
Text | Gets the text style settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class > LabelStyleTextComponent Properties
Legend
Legend
Property
public


LabelStyleTextComponent::StyleBorder Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties
LabelStyleTextComponent::StyleBorder Properties Public Properties
LabelStyleTextComponent::StyleBorder Properties
Public Properties
Public Property | Description
BackgroundMask | Gets whether use background mask when drawing.
BorderType | Gets the shape of the border around the entire label when the label has been dragged from its default position.... more
Color | Gets the color for a new text border or changes the color of an existing border.
Gap | Gets the gap, in plotted units, between the label text and the boarder.
Linetype | Gets the linetype for a new text border or changes an existing border linetype.
Lineweight | Gets the lineweight for a new text border or changes the lineweight of an existing border.
Visible | Gets whether to display a border around the text component.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class > LabelStyleTextComponent::StyleBorder Properties
Legend
Legend
Property
public


LabelStyleTextComponent::StyleGeneral Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties
LabelStyleTextComponent::StyleGeneral Properties Public Properties
LabelStyleTextComponent::StyleGeneral Properties
Public Properties
Public Property | Description
AnchorComponent | Gets a reference object for positioning the point of the text component.
AnchorLocation | Gets the location on the anchor component where the point of the block component is attached.
AnchorPoint | Gets the location on the anchor component where the point of the text component is attached.
Name | Gets the name for text component.
SpanOutsideSegments | Gets whether this component refers to the properties of outside segments.
UsedIn | Gets the display mode in which the component is used;for example if this is set to label, only display the... more
Visible | Gets whether the text component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class > LabelStyleTextComponent::StyleGeneral Properties
Legend
Legend
Property
public


LabelStyleTextComponent::StyleText Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties
LabelStyleTextComponent::StyleText Properties Public Properties
LabelStyleTextComponent::StyleText Properties
Public Properties
Public Property | Description
Angle | Gets the angle of the text comonent from the start point.
Attachment | Gets the point, calculated based on a rectangle that encompasses the text component, where the text component is attached to... more
Color | Gets the color of the text component.
Contents | Gets the contents for text component.
Height | Gets the height for text component.
Lineweight | Gets the line weight of the line component.
XOffset | Gets the text component away from an object in the X direction.
YOffset | Gets the text component away from an object in the Y direction.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class > LabelStyleTextComponent::StyleText Properties
Legend
Legend
Property
public


LabelStyleTickComponent::StyleGeneral Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class > LabelStyleTickComponent::StyleGeneral Properties
LabelStyleTickComponent::StyleGeneral Properties Public Properties
LabelStyleTickComponent::StyleGeneral Properties
Public Properties
Public Property | Description
Name | Gets the name for tick component.
Visible | Gets whether the tick component is visible in the label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class > LabelStyleTickComponent::StyleGeneral Properties
Legend
Legend
Property
public


LabelStyleTickComponent::StyleTick Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties
LabelStyleTickComponent::StyleTick Properties Public Properties
LabelStyleTickComponent::StyleTick Properties
Public Properties
Public Property | Description
AlignWithObject | Gets whether the tick insert at an angle relative the object.
BlockHeight | Gets the height to whick the tick block is scaled to fit.
BlockName | Gets the block to use for the tick component.
Color | Gets the color of the tick component.
Linetype | Gets the line type of the tick component.
Lineweight | Gets the line weight of the tick component.
RotationAngle | Gets the angle for tick component.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class > LabelStyleTickComponent::StyleTick Properties
Legend
Legend
Property
public


MarkerStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Properties
MarkerStyle Properties Public Properties
MarkerStyle Properties
Public Properties
Public Property | Description
MarkerDisplayStyleProfile | Gets the marker display style for profile views.
MarkerDisplayStyleSection | Gets the marker display style for section views.
MarkerType | Gets or sets the marker type (point, symbol, vertical line, or custom).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class > MarkerStyle Properties
Legend
Legend
Property
public


MarkerStyleBase Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties
MarkerStyleBase Properties Public Properties
MarkerStyleBase Properties
Public Properties
Public Property | Description
CustomMarkerStyle | Gets or sets a long value specifying a custom marker style.
CustomMarkerSuperimposeStyle | Gets or sets the CustomMarkerSuperimposeType enum value that specifies the shape superimposed on the custom point style marker as either... more
MarkerDisplayStyleModel | Gets the DisplayStyle property that specifies the point style marker Model display styles such as color, linetype, plotstyle, etc.
MarkerDisplayStylePlan | Gets the DisplayStyle property that specifies the point style marker Plan display styles such as color, linetype, plotstyle, etc.
MarkerFixedScale | Gets or sets a fixed scale used to scale the point symbol.
MarkerRotationAngle | Gets or sets the marker's rotation angle.
MarkerSize | Gets or sets the marker size in drawing units.
MarkerSymbolName | Gets or sets a string value that represents the marker symbol block name.
Orientation | Gets or sets the MarkerOrientationType enum value that defines how the marker rotation angle is applied.
SizeType | Gets or sets the MarkerSizeType enum value that defines how the marker is sized, such as relative to screen, fixed... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class > MarkerStyleBase Properties
Legend
Legend
Property
public


ProjectionProfileOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties
ProjectionProfileOptions Properties Public Properties
ProjectionProfileOptions Properties
Public Properties
Public Property | Description
AutoCAD3dPolylineBeginVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline beginning vertex marker style.
AutoCAD3dPolylineBeginVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline beginning vertex marker style's name.
AutoCAD3dPolylineEndVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline ending vertex marker style.
AutoCAD3dPolylineEndVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline ending vertex marker style's name.
AutoCAD3dPolylineInternalVertexMarkerStyleId | Gets or sets the AutoCAD 3D polyline internal vertex marker style.
AutoCAD3dPolylineInternalVertexMarkerStyleName | Gets or sets the AutoCAD 3D polyline internal vertex marker style's name.
AutoCADBlockDisplayOptions | Gets or sets the AutoCAD block display options.
AutoCADBlockMarkerStyleId | Gets or sets the AutoCAD block marker style.
AutoCADBlockMarkerStyleName | Gets or sets the AutoCAD block marker style's name.
AutoCADBlockSymbolBlockId | Gets or sets the AutoCAD block symbol block.
AutoCADBlockSymbolBlockName | Gets or sets the AutoCAD block symbol block's name.
AutoCADPointDisplayOptions | Gets or sets AutoCAD point display options.
AutoCADPointMarkerStyleId | Gets or sets the AutoCAD point marker style.
AutoCADPointMarkerStyleName | Gets or sets the AutoCAD point marker style's name.
AutoCADSolidDisplayOptions | Gets or sets AutoCAD solid display options.
AutoCADSolidMarkerStyleId | Gets or sets the AutoCAD solid marker style.
AutoCADSolidMarkerStyleName | Gets or sets the AutoCAD solid marker style's name.
MultiViewBlockDirection | Gets or sets the multi-view block direction.
MultiViewBlockDisplayOptions | Gets or sets the multi-view block display options.
MultiViewBlockDisplayRepresentationId | Gets or sets the multi-view block display representation.
MultiViewBlockDisplayRepresentationName | Gets or sets the name of the multi-view block display representation.
MultiViewBlockMarkerStyleId | Gets or sets the multi-view block marker style.
MultiViewBlockMarkerStyleName | Gets or sets the multi-view block marker style's name.
MultiViewBlockSymbolBlockId | Gets or sets the multi-view block symbol block.
MultiViewBlockSymbolBlockName | Gets or sets the name of the multi-view block symbol block.
VerticallyExaggerateBlocks | Gets or sets whether to vertically exaggerate blocks.
VerticallyExaggerateMultiViewBlocks | Gets or sets whether to vetically exaggerate multi-view blocks.
VerticallyExaggerateSolids | Gets or sets whether to vertically exaggerate solids.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class > ProjectionProfileOptions Properties
Legend
Legend
Property
public


ProjectionSectionOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties
ProjectionSectionOptions Properties Public Properties
ProjectionSectionOptions Properties
Public Properties
Public Property | Description
AutoCAD3dPolylineCrossingMarkerStyleId | Gets AutoCAD 3D polyline crossing marker style.
AutoCAD3dPolylineCrossingMarkerStyleName | Gets AutoCAD 3D polyline crossing marker style's.
AutoCADBlockDisplayOptions | Gets AutoCAD block display options.
AutoCADBlockMarkerStyleId | Gets AutoCAD block marker style.
AutoCADBlockMarkerStyleName | Gets AutoCAD block marker style's name.
AutoCADBlockSymbolBlockId | Gets AutoCAD block symbol block.
AutoCADBlockSymbolBlockName | Gets AutoCAD block symbol block's name.
AutoCADPointDisplayOptions | Gets AutoCAD point display options.
AutoCADPointMarkerStyleId | Gets AutoCAD point marker style.
AutoCADPointMarkerStyleName | Gets AutoCAD point marker style's name.
AutoCADSolidDisplayOptions | Gets AutoCAD solid display options.
AutoCADSolidMarkerStyleId | Gets AutoCAD solid marker style.
AutoCADSolidMarkerStyleName | Gets AutoCAD solid marker style's name.
MultiViewBlockDirection | Gets multi-view block direction.
MultiViewBlockDisplayOptions | Gets multi-view block display options.
MultiViewBlockDisplayRepresentationId | Gets multi-view block display representation.
MultiViewBlockDisplayRepresentationName | Gets multi-view block display representation's name.
MultiViewBlockMarkerStyleId | Gets multi-view block marker style.
MultiViewBlockMarkerStyleName | Gets multi-view block marker style's name.
MultiViewBlockSymbolBlockId | Gets multi-view block symbol block.
MultiViewBlockSymbolBlockName | Gets multi-view block symbol block's name.
VerticallyExaggerateBlocks | Gets vertically exaggerate blocks.
VerticallyExaggerateMultiViewBlocks | Gets vertically exaggerate multi-view blocks.
VerticallyExaggerateSolids | Gets vertically exaggerate solids.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class > ProjectionSectionOptions Properties
Legend
Legend
Property
public


ProjectionStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Properties
ProjectionStyle Properties Public Properties
ProjectionStyle Properties
Public Properties
Public Property | Description
ProfileOptions | Gets the ProjectionProfileOptions object that specifies profile options.
SectionOptions | Gets the ProjectionSectionOptions object that specifies section options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class > ProjectionStyle Properties
Legend
Legend
Property
public


StructureColumnComponentData Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class > StructureColumnComponentData Properties
StructureColumnComponentData Properties Public Properties
StructureColumnComponentData Properties
Public Properties
Public Property | Description
ComponentType | Gets the type of the table cell component data.
Content | Gets or sets the content of the tabel cell component data.
Name | Gets or sets the name of the tabel cell component data.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class > StructureColumnComponentData Properties
Legend
Legend
Property
public


StructureColumnComponents Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Properties
StructureColumnComponents Properties Public Properties
StructureColumnComponents Properties
Public Properties
Public Property | Description
Count | Gets the number of table cell component datas in the collection.
default | Gets the table cell component data at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class > StructureColumnComponents Properties
Legend
Legend
Property
public


StyleBase Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Properties
StyleBase Properties Public Properties
StyleBase Properties
Public Properties
Public Property | Description
CreateBy | Gets or Sets the "Created by" string for the style.
DateCreated | Gets the "Date created" string for the style.
DateModified | Gets the "Date modified" string for the style.
ModifiedBy | Gets the "Modified by" string for the style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class > StyleBase Properties
Legend
Legend
Property
public


StyleCollectionBase Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Properties
StyleCollectionBase Properties Public Properties
StyleCollectionBase Properties
Public Properties
Public Property | Description
Count | Gets the number of style objects in the collection.
default | Gets the style by name or index from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class > StyleCollectionBase Properties
Legend
Legend
Property
public


StylesRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties
StylesRoot Properties Public Properties
StylesRoot Properties
Public Properties
Public Property | Description
AlignmentDesignCheckSets | Gets the collection of alignment design check set in the database.
AlignmentStyles | Gets the collection of all alignment styles in the database.
AssemblyStyles | Gets the collection of AssemblyStyle objects in the database.
BandStyles | Gets the root object of Civil 3D band styles.
BuildingSiteStyles | Gets the collection of BuildingSiteStyle objects in the database.
CodeSetStyles | Gets the collection of CodeSetStyle objects in the database.
CorridorStyles | Gets the collection of all corridor styles in the database.
FeatureLineStyles | Gets the collection of all feature line styles in the database.
GradingCriteriaSets | Gets the collection of GradingCriteriaSet objects in the database.
GradingStyles | Gets the collection of all grading styles in the database.
GroupPlotStyles | Gets the collection of all group plot styles in the database.
InterferenceStyles | Gets the collection of all interference styles in the database.
IntersectionStyles | Gets the collection of IntersectionStyle objects in the database.
LabelSetStyles | Gets the root object of Civil 3D label set styles.
LabelStyles | Gets the root object of Civil 3D label styles.
LinkStyles | Gets the collection of LinkStyle objects in the database.
MarkerStyles | Gets the root object of Civil 3D mark styles.
MassHaulLineStyles | Gets the collection of MassHaulLineStyle objects in the database.
MassHaulViewStyles | Gets the collection of MassHaulViewStyle objects in the database.
MatchLineStyles | Gets the collection of all match line styles in the database.
ParcelStyles | Gets the collection of all parcel styles in the database.
PartsListSet | Gets the collection of parts list in the database.
PipeRuleSetStyles | Gets the collection of all pipe rule set styles in the database.
PipeStyles | Gets the collection of all pipe styles in the database.
PointStyles | Gets the collection of all point styles in the database.
ProfileDesignCheckSets | Gets the collection of profile design check set in the database.
ProfileStyles | Gets the collection of all profile styles in the database.
ProfileViewBandSetStyles | Gets the collection of all profile view band set styles in the database.
ProfileViewStyles | Gets the collection of all profile view styles in the database.
ProjectionStyles | Gets the collection of ProjectionStyle objects in the database.
QuantityTakeoffCriterias | Gets the collection of QuantityTakeoffCriteria objects in the database.
SampleLineStyles | Gets the collection of all sample line styles in the database.
SectionStyles | Gets the collection of all section styles in the database.
SectionViewBandSetStyles | Gets the collection of all section view band set styles in the database.
SectionViewStyles | Gets the collection of all section view styles in the database.
ShapeStyles | Gets the collection of ShapeStyle objects in the database.
SheetStyles | Gets the collection of all sheet styles in the database.
SlopePatternStyles | Gets the collection of SlopePatternStyle objects in the database.
StructureRuleSetStyles | Gets the collection of all structure rule set styles in the database.
StructureStyles | Gets the collection of all structure styles in the database.
SurfaceStyles | Gets the collection of all surface styles in the database.
SurveyFigureStyles | Gets the collection of SurveyFigureStyle objects in the database.
SurveyNetworkStyles | Gets the collection of SurveyNetworkStyle objects in the database.
TableStyles | Gets the root object of Civil 3D table styles.
ViewFrameStyles | Gets the collection of all view frame styles in the database.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class > StylesRoot Properties
Legend
Legend
Property
public


TableStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties
TableStyle Properties Public Properties
TableStyle Properties
Public Properties
Public Property | Description
BorderDisplayStyleModel | Gets the AeccDisplayStyle object that specifies Model display settings such as layer and linetype for the graphic line that forms... more
BorderDisplayStylePlan | Gets the AeccDisplayStyle object that specifies Plan display settings such as layer and linetype for the graphic line that forms... more
ColumnStyles | Gets the ColumnStyles collection of styles defining column width and value properties.
DataAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for all... more
DataAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for all... more
DataDividerDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the vertical graphic line that separates columns.
DataDividerDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the vertical graphic line that separates columns.
DataSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates data rows.
DataSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates data rows.
DataTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the all text in data rows of table.
DataTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the all text in data rows of table.
DataTextHeight | Gets or sets the height for row data text.
DataTextStyle | Gets or sets the text style for the row data from the available AutoCAD text styles defined in the current... more
EnableWordWrapping | Gets or sets the boolean value that determines whether to force text to fit within the specified width of the... more
HeaderAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the... more
HeaderAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the... more
HeaderSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates column headings from data rows.... more
HeaderSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates column headings from data rows.... more
HeaderTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the column names in second row of table.
HeaderTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the column names in second row of table.
HeaderTextHeight | Gets or sets the height for column headings text.
HeaderTextStyle | Gets or sets the text style for the column headings from the available AutoCAD text styles defined in the current... more
MaintainViewOrientation | Gets or sets the boolean value that determines whether to realign the table to the view (screen) direction regardless of... more
RepeatHeaderInSplitTables | Gets or sets the boolean value that determines whether to show the column headers when displaying split tables.
RepeatTitleInSplitTables | Gets or sets the boolean value that determines whether to show the title header when displaying split tables.
SortData | Gets or sets the boolean value that specifies whether to enable the table style data sorting option.
SortingColumn | Gets or sets the column that determines whether to organize drawing information for clear and quick reference.
SortingOrder | Gets or sets the AeccTableSortingOrderType enum value that specifies the table style sort order as either ascending or descending.
TableType | Gets the type of feature to which this table style applies.
Title | Gets or sets the title that displays as the first row of a table.
TitleAreaFillDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the solid hatch pattern that serves as background fill for the... more
TitleAreaFillDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the solid hatch pattern that serves as background fill for the... more
TitleJustification | Gets or sets the justification of the title that displays as the first row of a table.
TitleSeparatorDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the horizontal graphic line that separates title from column headings.
TitleSeparatorDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the horizontal graphic line that separates title from column headings.
TitleTextDisplayStyleModel | Gets the AeccDisplayStyle that specifies Model display properties for the table name in first row of table.
TitleTextDisplayStylePlan | Gets the AeccDisplayStyle that specifies Plan display properties for the table name in first row of table.
TitleTextHeight | The text height of the table title.
TitleTextStyle | Gets or sets the text style for the title text from the available AutoCAD text styles defined in the current... more
TitleUnformatted | Gets the unformatted table title string.
TransposeSectionViewTable | Gets or sets the boolean value that determines whether to transpose the section view table.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class > TableStyle Properties
Legend
Legend
Property
public


TableStylesRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties
TableStylesRoot Properties Public Properties
TableStylesRoot Properties
Public Properties
Public Property | Description
AlignmentCurveTableStyles | Gets the collection of all alignment curve table styles.
AlignmentLineTableStyles | Gets the collection of all alignment line table styles.
AlignmentSegmentTableStyles | Gets the collection of all alignment segment table styles.
AlignmentSpiralTableStyles | Gets the collection of all alignment spiral table styles.
ParcelAreaTableStyles | Gets the collection of all parcel area table styles.
ParcelCurveTableStyles | Gets the collection of all parcel curve table styles.
ParcelLineTableStyles | Gets the collection of all parcel line table styles.
ParcelSegmentTableStyles | Gets the collection of all parcel segment table styles.
PipeTableStyles | Gets the collection of all pipe table styles.
PointTableStyles | Gets the collection of all point table styles.
QuantityTakeoffMaterialTableStyles | Gets the collection of all quantity takeoff material table styles.
QuantityTakeoffTotalVolumeTableStyles | Gets the collection of all quantity takeoff total volume table styles.
SectionViewMaterialTableStyles | Gets the collection of all section view material table styles.
SectionViewTotalVolumeTableStyles | Gets the collection of all section view total volume table styles.
StructureTableStyles | Gets the collection of all structure table styles.
SurfaceContourTableStyles | Gets the collection of all surface contour table styles.
SurfaceDirectionTableStyles | Gets the collection of all surface direction table styles.
SurfaceElevationTableStyles | Gets the collection of all surface elevation table styles.
SurfaceSlopeArrowContourTableStyles | Gets the collection of all surface user slope arrow table styles.
SurfaceSlopeTableStyles | Gets the collection of all surface slope table styles.
SurfaceUserDefinedContourTableStyles | Gets the collection of all surface user defined contour table styles.
SurfaceWatershedTableStyles | Gets the collection of all surface watershed table styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class > TableStylesRoot Properties
Legend
Legend
Property
public


DesignCheck Properties Public Properties
DesignCheck Properties
Public Properties
Public Property | Description
Description | Gets and sets the description of the DesignCheck.
Expression | Gets or sets the expression of the DesignCheck.
Name | Gets the name of the DesignCheck.


DesignCheckCollection Properties Public Properties
DesignCheckCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of DesignCheck in the collection.
default | Gets the DesignCheck by a specified name in the collection.


AlignmentDesignCheck Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheck Class > AlignmentDesignCheck Properties
AlignmentDesignCheck Properties Public Properties
AlignmentDesignCheck Properties
Public Properties
Public Property | Description
DesignCheckType | Gets the type of the DesignCheck.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheck Class > AlignmentDesignCheck Properties
Legend
Legend
Property
public


AlignmentDesignCheckCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Properties
AlignmentDesignCheckCollection Properties Public Properties
AlignmentDesignCheckCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of AlignmentDesignCheck in the collection.
default | Gets the AlignmentDesignCheck by a specified name in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckCollection Class > AlignmentDesignCheckCollection Properties
Legend
Legend
Property
public


AlignmentDesignCheckRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Properties
AlignmentDesignCheckRoot Properties Public Properties
AlignmentDesignCheckRoot Properties
Public Properties
Public Property | Description
CurveDesignChecks | Gets the collection of all alignment curve design checks.
LineDesignChecks | Gets the collection of all alignment line design checks.
SpiralDesignChecks | Gets the collection of all alignment spiral design checks.
TangentIntersectionDesignChecks | Gets the collection of all alignment tangent intersection design checks.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > AlignmentDesignCheckRoot Class > AlignmentDesignCheckRoot Properties
Legend
Legend
Property
public


Alignment Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties
Alignment Properties Public Properties
Alignment Properties
Public Properties
Public Property | Description
AlignmentType | Gets the alignment type.
CreationMode | Gets the Alignment creation mode.
DesignCheckSetId | Gets the object id of design check set that is used in the alignment.
DesignCheckSetName | Gets the name of of design check set that is used in the alignment.
DesignSpeeds | Gets the Alignment design speed collection.
EndingStation | Gets the Alignment's end station.
Entities | Gets the Alignment entities collection for the Alignment.
IsSiteless | Gets a bool value that indicates whether this Alignment is a siteless Alignment.
Length | Gets the Alignment's length.
ReferencePoint | Gets or sets the Alignment reference point.
ReferencePointStation | Gets or sets the Alignment reference point station.
SiteId | Gets the Id for the Site to which this Alignment belongs. ObjectId.Null for a siteless alignment.
SiteName | Gets the name of the Site to which this Alignment belongs. a string of "" for a siteless alignment.
StartingStation | Gets the Alignment's start station.
StationEquations | Gets the Alignment's station equation collection.
StationIndexIncrement | Gets or sets the Alignment station index increment.
StyleId | Sets the Alignment's style Id.
StyleName | Sets the Alignment's style name.
SuperElevationData | Gets the superelevation data collection on the Alignment. A read-only copy is returned.
UpdateMode | Gets the update mode of the alignment.
UseDesignCheckSet | Gets or sets whether the Alignment uses the design check set.
UseDesignCriteriaFile | Gets or sets whether the alignment uses the design criteria file.
UseDesignSpeed | Gets or sets a bool value that indicates whether this Alignment uses degign speed.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class > Alignment Properties
Legend
Legend
Property
public


AlignmentArc Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties
AlignmentArc Properties Public Properties
AlignmentArc Properties
Public Properties
Public Property | Description
CenterPoint | Gets or sets the AlignmentArc's center point.
ChordDirection | Gets the AlignmentArc's chord direction.
ChordLength | Gets or sets the AlignmentArc's chord length.
Clockwise | Gets a bool value that specifies whether the curve entity is a reverse curve.
Constraint2 | Gets the AlignmentArc entity constraint type.
CurveGroupIndex | Gets or sets the AlignmentArc's group index.
CurveGroupSubEntityIndex | Gets or sets the AlignmentArc's group subentity index.
default | Gets a subentity from the AlignmentEntity by index.
DeflectedAngle | Gets or sets the AlignmentArc's deflected angle.
Delta | Gets or sets the AlignmentArc's delta.
DirectionAtPoint1 | Gets or sets the AlignmentArc's direction at point1.
DirectionAtPoint2 | Gets the AlignmentArc's direction at point2.
EndDirection | Gets the AlignmentArc's end direction.
ExternalSecant | Gets or sets the AlignmentArc's external secant.
ExternalTangent | Gets or sets the AlignmentArc's external tangent.
GreaterThan180 | Gets or sets a bool value indicating whether the Arc solution angle is > 180 Degrees.
Length | Gets or sets the AlignmentArc's length.
MidOrdinate | Gets or sets the AlignmentArc's mid ordinate.
MinimumRadius | Gets the minimum radius according to the design speed check.
PassThroughPoint1 | Gets or sets the AlignmentArc's first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentArc's second pass-through point.
PassThroughPoint3 | Gets or sets the AlignmentArc's third pass-through point.
PIStation | Gets the AlignmentArc's PI station.
Radius | Gets or sets the AlignmentArc's radius.
ReverseCurve | Gets a bool value that specifies whether the curve entity is a reverse curve.
StartDirection | Gets the AlignmentArc's start direction.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class > AlignmentArc Properties
Legend
Legend
Property
public


AlignmentCurve Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Properties
AlignmentCurve Properties Public Properties
AlignmentCurve Properties
Public Properties
Public Property | Description
EndPoint | Gets the end point of the AlignmentCurve.
EndStation | Gets the end station of the AlignmentCurve.
HighestDesignSpeed | Gets the highest design speed of the AlignmentCurve.
Length | Gets the length of the AlignmentCurve.
StartPoint | Gets the start point of the AlignmentCurve.
StartStation | Gets the start station of the AlignmentCurve.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class > AlignmentCurve Properties
Legend
Legend
Property
public


AlignmentEntity Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties
AlignmentEntity Properties Public Properties
AlignmentEntity Properties
Public Properties
Public Property | Description
Constraint1 | Gets the AlignmentEntity constraint type, either Fixed, Float or Free.
default | Gets a subentity from the AlignmentEntity by index.
EntityAfter | Gets the ID of the AlignmentEntity after this one.
EntityBefore | Gets the ID of the AlignmentEntity before this one.
EntityId | Gets the AlignmentEntity id, which is the unique representation of this alignment entity.
EntityType | Gets the AlignmentEntity type.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class > AlignmentEntity Properties
Legend
Legend
Property
public


AlignmentEntityCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Properties
AlignmentEntityCollection Properties Public Properties
AlignmentEntityCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of AlignmentEntity objects in the collection.
default | Gets the AlignmentEntity object at a specified index in the collection.
FirstEntity | Gets the ID of the first AlignmentEntity in the collection.
LastEntity | Gets the ID of the last AlignmentEntity in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class > AlignmentEntityCollection Properties
Legend
Legend
Property
public


AlignmentLabelGroup Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Properties
AlignmentLabelGroup Properties Public Properties
AlignmentLabelGroup Properties
Public Properties
Public Property | Description
RangeEnd | Gets or sets the end of the labeled range.
RangeEndFromFeature | Sets whether the range ends at the same value where the feature ends.
RangeStart | Gets or sets the start of the labeled range.
RangeStartFromFeature | Sets whether the range starts at the same value where the feature starts.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class > AlignmentLabelGroup Properties
Legend
Legend
Property
public


AlignmentLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties
AlignmentLine Properties Public Properties
AlignmentLine Properties
Public Properties
Public Property | Description
Constraint2 | Gets the AlignmentLine entity constraint type.
CurveGroupIndex | Gets or sets the AlignmentLine's group index.
CurveGroupSubEntityIndex | Gets or sets the AlignmentLine's group subentity index.
default | Gets a subentity from the AlignmentEntity by index.
Direction | Gets the direction of the AlignmentSubEntityLine.
Length | Gets or sets the AlignmentLine length.
MidPoint | Gets the AlignmentSubEntityLine middle point coordinate.
PassThroughPoint1 | Gets or sets the AlignmentSubEntityLine first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentSubEntityLine second pass-through point.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class > AlignmentLine Properties
Legend
Legend
Property
public


AlignmentMinorStationLabelGroup Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Properties
AlignmentMinorStationLabelGroup Properties Public Properties
AlignmentMinorStationLabelGroup Properties
Public Properties
Public Property | Description
MajorStationLabelGroup | Gets or Sets the major station label group.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class > AlignmentMinorStationLabelGroup Properties
Legend
Legend
Property
public


AlignmentRegion Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Properties
AlignmentRegion Properties Public Properties
AlignmentRegion Properties
Public Properties
Public Property | Description
EndStation | Gets or sets the end station.
Length | Gets or sets the length of region.
OffsetDist | Gets or sets the distance of offset.
RegionType | Gets or sets the type of region.
StartStation | Gets or sets the start station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class > AlignmentRegion Properties
Legend
Legend
Property
public


AlignmentRegionCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Properties
AlignmentRegionCollection Properties Public Properties
AlignmentRegionCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of AlignmentRegion objects in the collection.
default | Gets the AlignmentRegion object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class > AlignmentRegionCollection Properties
Legend
Legend
Property
public


AlignmentSCS Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Properties
AlignmentSCS Properties Public Properties
AlignmentSCS Properties
Public Properties
Public Property | Description
Arc | Gets the arc of the SCS group.
Constraint2 | Gets the AlignmentSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
SpiralIn | Gets the in spiral of the SCS group.
SpiralOut | Gets the out spiral of the SCS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class > AlignmentSCS Properties
Legend
Legend
Property
public


AlignmentSCSCS Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties
AlignmentSCSCS Properties Public Properties
AlignmentSCSCS Properties
Public Properties
Public Property | Description
Arc1 | Gets the first arc of the SCSCS group.
Arc2 | Gets the second arc of the SCSCS group.
Constraint2 | Gets the AlignmentSCSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
Spiral1 | Gets the first spiral of the SCSCS group.
Spiral2 | Gets the second spiral of the SCSCS group.
Spiral3 | Gets the third spiral of the SCSCS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class > AlignmentSCSCS Properties
Legend
Legend
Property
public


AlignmentSCSSCS Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties
AlignmentSCSSCS Properties Public Properties
AlignmentSCSSCS Properties
Public Properties
Public Property | Description
Arc1 | Gets the first arc of the SCSSCS group.
Arc2 | Gets the second arc of the SCSSCS group.
Constraint2 | Gets the AlignmentSCSSCS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
Spiral1 | Gets the first spiral of the SCSSCS group.
Spiral2 | Gets the second spiral of the SCSSCS group.
Spiral3 | Gets the third spiral of the SCSSCS group.
Spiral4 | Gets the fourth spiral of the SCSSCS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class > AlignmentSCSSCS Properties
Legend
Legend
Property
public


AlignmentSpiral Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties
AlignmentSpiral Properties Public Properties
AlignmentSpiral Properties
Public Properties
Public Property | Description
A | Gets the spiral A value.
Compound | Gets the AlignmentSpiral entity Simple/Compound Flag.
Constraint2 | Gets the AlignmentSpiral entity constraint type.
CurveGroupIndex | Gets the AlignmentSpiral entity curve group index string.
CurveGroupSubEntityIndex | Gets the AlignmentSpiral entity curve group subentity index string.
CurveType | Gets the AlignmentSpiral entity Incurve/Outcurve type.
default | Gets the subentity of the AlignmentEntity by index.
Delta | Gets the AlignmentSpiral entity curve delta angle.
Direction | Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.
EndDirection | Gets the direction value at the end point.
K | Gets the spiral K value.
Length | Gets or sets the spiral length.
LongTangent | Gets the spiral long tangent.
MinimumTransitionLength | Gets the minimum transition length according to the design speed check.
P | Gets the spiral P value.
RadialPoint | Gets the AlignmentSpiral subentity radial Point2D coordinate.
RadiusIn | Gets the incoming curve radius.
RadiusOut | Gets the outgoing curve radius.
ShortTangent | Gets the spiral short tangent.
SPIAngle | Gets the AlignmentSpiral entity SPI angle.
SPIPoint | Gets the AlignmentSpiral entity SPI Point2D coordinate.
SpiralDefinition | Gets the AlignmentSpiral entity spiral type.
SPIStation | Gets the AlignmentSpiral entity SPI station.
StartDirection | Gets the direction value at the start point.
SubEntityCount | Gets the number of subentities in the AlignmentEntity.
TotalX | Gets the spiral total X value.
TotalY | Gets the spiral total Y value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class > AlignmentSpiral Properties
Legend
Legend
Property
public


AlignmentSSCSS Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties
AlignmentSSCSS Properties Public Properties
AlignmentSSCSS Properties
Public Properties
Public Property | Description
Arc | Gets the arc from the SSCSS group.
Constraint2 | Gets the AlignmentSSCSS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
Spiral1 | Gets the first spiral from the SSCSS group.
Spiral2 | Gets the second spiral from the SSCSS group.
Spiral3 | Gets the third spiral from the SSCSS group.
Spiral4 | Gets the fourth spiral from the SSCSS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class > AlignmentSSCSS Properties
Legend
Legend
Property
public


AlignmentStationLabelGroup Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Properties
AlignmentStationLabelGroup Properties Public Properties
AlignmentStationLabelGroup Properties
Public Properties
Public Property | Description
Increment | Gets or sets the increment at which to insert major and minor station labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class > AlignmentStationLabelGroup Properties
Legend
Legend
Property
public


AlignmentSTS Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Properties
AlignmentSTS Properties Public Properties
AlignmentSTS Properties
Public Properties
Public Property | Description
Constraint2 | Gets the AlignmentSTS entity constraint type.
default | Gets a subentity from the AlignmentEntity by index.
SpiralIn | Gets the in spiral of the STS group.
SpiralOut | Gets the out spiral of the STS group.
SubEntityCount | Gets the number of subentities that make up the AlignmentEntity.
Tangent | Gets the tangent of the STS group.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class > AlignmentSTS Properties
Legend
Legend
Property
public


AlignmentSubEntity Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties
AlignmentSubEntity Properties Public Properties
AlignmentSubEntity Properties
Public Properties
Public Property | Description
CurveGroupIndex | Gets or sets the alignment sub-entity group index.
CurveGroupSubEntityIndex | Gets or sets the alignment sub-entity group subentity index.
EndPoint | Gets the alignment sub-entity end point coordinate.
EndStation | Gets the alignment sub-entity ending station.
Length | Gets or sets the alignment sub-entity length.
StartPoint | Gets the alignment sub-entity start point coordinate.
StartStation | Gets the alignment sub-entity starting station.
SubEntityType | Gets the alignment sub-entity type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class > AlignmentSubEntity Properties
Legend
Legend
Property
public


AlignmentSubEntityArc Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties
AlignmentSubEntityArc Properties Public Properties
AlignmentSubEntityArc Properties
Public Properties
Public Property | Description
CenterPoint | Gets or sets the arc's center point.
ChordDirection | Gets the arc's chord direction.
ChordLength | Gets or sets the arc's chord length.
Clockwise | Gets a bool value that specifies whether the curve entity is clockwise.
DeflectedAngle | Gets or sets the arc's deflected angle.
Delta | Gets or sets the arc's delta.
DirectionAtPoint1 | Gets or sets the arc's direction at point1.
DirectionAtPoint2 | Gets the arc's direction at point2.
EndDirection | Gets the arc's end direction.
ExternalSecant | Gets or sets the arc's external secant.
ExternalTangent | Gets or sets the arc's external tangent.
GreaterThan180 | Gets or sets a bool value that indicates whether the arc solution angle is greather than 180 Degrees.
MidOrdinate | Gets or sets the arc's mid ordinate.
MinimumRadius | Gets the minimum radius according to the design speed check.
PassThroughPoint1 | Gets or sets the arc's first pass-through point.
PassThroughPoint2 | Gets or sets the arc's second pass-through point.
PassThroughPoint3 | Gets or sets the arc's third pass-through point.
PIPoint | Gets the arc's PI point.
PIStation | Gets the arc's PI station.
Radius | Gets or sets the arc's radius.
ReverseCurve | Gets a bool value that specifies whether the curve entity is a reverse curve.
StartDirection | Gets the arc's start direction.
SubEntityType | Gets the alignment sub-entity type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class > AlignmentSubEntityArc Properties
Legend
Legend
Property
public


AlignmentSubEntityLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Properties
AlignmentSubEntityLine Properties Public Properties
AlignmentSubEntityLine Properties
Public Properties
Public Property | Description
Direction | Gets the direction of AlignmentSubEntityLine.
MidPoint | Gets the AlignmentSubEntityLine middle point coordinate.
PassThroughPoint1 | Gets or sets the AlignmentSubEntityLine first pass-through point.
PassThroughPoint2 | Gets or sets the AlignmentSubEntityLine second pass-through point.
SubEntityType | Gets the alignment sub-entity type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class > AlignmentSubEntityLine Properties
Legend
Legend
Property
public


AlignmentSubEntitySpiral Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties
AlignmentSubEntitySpiral Properties Public Properties
AlignmentSubEntitySpiral Properties
Public Properties
Public Property | Description
A | Gets the spiral A value.
Compound | Gets the alignment spiral entity Simple/Compound Flag.
CurveType | Gets the alignment spiral entity Incurve/Outcurve type.
Delta | Gets the curve delta angle.
Direction | Gets the AeccAlignmentSpiralDirectionType enum value that specifies the curve direction as either left or right.
EndDirection | Gets the direction value at the end point.
K | Gets the spiral K value.
LongTangent | Gets the spiral long tangent.
MinimumTransitionLength | Gets the minimum transition length according to the design speed check.
P | Gets the spiral P value.
RadialPoint | Gets the alignment spiral subentity radial Point2D coordinate.
RadiusIn | Gets the incoming curve radius, in radians.
RadiusOut | Gets the outgoing curve radius, in radians.
ShortTangent | Gets the spiral short tangent.
SPIAngle | Gets the alignment spiral entity SPI angle.
SPIPoint | Gets the alignment spiral entity SPI Point2D coordinate.
SpiralDefinition | Gets the alignment spiral entity spiral type.
SPIStation | Gets the alignment spiral entity SPI station.
StartDirection | Gets the direction value at the start point.
SubEntityType | Gets the alignment sub-entity type.
TotalX | Gets the spiral total X value.
TotalY | Gets the spiral total Y value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class > AlignmentSubEntitySpiral Properties
Legend
Legend
Property
public


AlignmentVerticalGeometryPointLabelGroup Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Properties
AlignmentVerticalGeometryPointLabelGroup Properties Public Properties
AlignmentVerticalGeometryPointLabelGroup Properties
Public Properties
Public Property | Description
VerticalAlignment | Gets or sets the major station label group.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class > AlignmentVerticalGeometryPointLabelGroup Properties
Legend
Legend
Property
public


DesignSpeed Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Properties
DesignSpeed Properties Public Properties
DesignSpeed Properties
Public Properties
Public Property | Description
Comment | Gets and sets the DesignSpeed comment.
SpeedNumber | Gets the DesignSpeed number.
Station | Gets and sets the DesignSpeed Station.
Value | Gets and sets the DesignSpeed value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class > DesignSpeed Properties
Legend
Legend
Property
public


DesignSpeedCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Properties
DesignSpeedCollection Properties Public Properties
DesignSpeedCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of DesignSpeed objects in the collection.
default | Gets the DesignSpeed at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class > DesignSpeedCollection Properties
Legend
Legend
Property
public


MassHaulView Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulView Class > MassHaulView Properties
MassHaulView Properties Public Properties
MassHaulView Properties
Public Properties
Public Property | Description
MassHaulLineId | Gets the ObjectId of the MassHaulLine associated with this view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulView Class > MassHaulView Properties
Legend
Legend
Property
public


MatchLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MatchLine Class > MatchLine Properties
MatchLine Properties Public Properties
MatchLine Properties
Public Properties
Public Property | Description
GroupId | Gets the object id of the view frame group it belongs to.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MatchLine Class > MatchLine Properties
Legend
Legend
Property
public


PointEntity Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties
PointEntity Properties Public Properties
PointEntity Properties
Public Properties
Public Property | Description
DescriptionFormat | Gets or sets the description format string for the point.
FullDescription | Gets an expanded description determined by a description key match.
IsNamed | Check whether this Cogo Point is named.
IsSurveyPoint | Check whether this Cogo Point is Survey Point.
Location | Gets or sets the point location.
PointName | Gets or sets the name of Cogo Point.
PointNumber | Gets or sets the identifying number assigned to the point.
RawDescription | Gets or sets an unexpanded description for the point, which could be the description entered by the surveyor in the... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class > PointEntity Properties
Legend
Legend
Property
public


PolylineOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Properties
PolylineOptions Properties Public Properties
PolylineOptions Properties
Public Properties
Public Property | Description
AddCurvesBetweenTangents | Specifies whether to add curves between tangents.
EraseExistingEntities | Specifies whether to erase the polyline after the Alignment is created.
PlineId | Specifies the objectId of the polyline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class > PolylineOptions Properties
Legend
Legend
Property
public


Profile Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties
Profile Properties Public Properties
Profile Properties
Public Properties
Public Property | Description
AlignmentId | Gets the object id of the corresponding alignment for the profile.
DataSourceId | Gets the object id of object that is associated with the profile.
DataSourceName | Gets the name of object that is associated with the profile.
DesignCheckSetId | Gets the object id of design check set that is used in the profile.
DesignCheckSetName | Gets the name of of design check set that is used in the profile.
DesignSpeedBased | Gets or sets whether the design is speed-based.
ElevationMax | Gets the maximum elevation value on the profile.
ElevationMin | Gets the minimum elevation value on the profile.
EndingStation | Gets the profile ending station.
Entities | Gets the profile entities' collection.
Length | Gets the profile length.
Offset | Gets the profile offset.
Plinegen | Gets or sets the PLINEGEN setting for the profile.
ProfileType | Gets or sets the profile type.
PVIs | Gets the points of vertical intersection for the profile.
StartingStation | Gets the profile starting station.
StyleId | Sets the profile's style Id.
StyleName | Sets the profile's style name.
UpdateMode | Gets or sets the update mode of the profile.
UseDesignCheckSet | Gets or sets whether the design check set is used.
UseDesignCriteriaFile | Gets or sets whether the design criteria file is used.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class > Profile Properties
Legend
Legend
Property
public


ProfileCircular Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties
ProfileCircular Properties Public Properties
ProfileCircular Properties
Public Properties
Public Property | Description
CurveType | Gets the curve type, crest or sag.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
M | Gets or sets the M value of the curve.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
Radius | Gets or sets the radius of the curve.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class > ProfileCircular Properties
Legend
Legend
Property
public


ProfileCriteria Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class > ProfileCriteria Properties
ProfileCriteria Properties Public Properties
ProfileCriteria Properties
Public Properties
Public Property | Description
BoundaryType | Gets the profile critera's boundary type of the hatch area.
ProfileId | Gets or Sets the profile id in the profile critera of the hatch area.
ProfileName | Gets or Sets the profile name in the profile critera of the hatch area.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class > ProfileCriteria Properties
Legend
Legend
Property
public


ProfileCriteriaCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Properties
ProfileCriteriaCollection Properties Public Properties
ProfileCriteriaCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of ProfileCriteria objects in the collection.
default | Gets the ProfileCriteria at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class > ProfileCriteriaCollection Properties
Legend
Legend
Property
public


ProfileEntity Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties
ProfileEntity Properties Public Properties
ProfileEntity Properties
Public Properties
Public Property | Description
Constraint1 | Gets the entity constraint of the profile entity.
Constraint2 | Gets the construction constraint of the profile entity(by CurveLength, Radius etc.) In UI it is shown as Constraint Type Desc.... more
EndElevation | Gets the curve end elevation.
EndStation | Gets the curve end station.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
EntityId | Gets the identifier of the profile entity.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
HighestDesignSpeed | Returns the highest speed in the station range.
Length | Gets or sets the curve length.
MinimumKValueHSD | Gets the minimum K value for headlight sight distance.
MinimumKValuePSD | Gets the minimum K value for passing sight distance.
MinimumKValueSSD | Gets the minimum K value for stopping sight distance.
StartElevation | Gets the curve start elevation.
StartStation | Gets the curve start station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class > ProfileEntity Properties
Legend
Legend
Property
public


ProfileEntityCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Properties
ProfileEntityCollection Properties Public Properties
ProfileEntityCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of ProfileEntity objects in the collection.
default | Gets the ProfileEntity object at a specified index in the collection.
FirstEntity | Gets the ID of the first ProfileEntity in the collection.
LastEntity | Gets the ID of the last ProfileEntity in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class > ProfileEntityCollection Properties
Legend
Legend
Property
public


ProfileHatchArea Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Properties
ProfileHatchArea Properties Public Properties
ProfileHatchArea Properties
Public Properties
Public Property | Description
Criteria | Gets the collection of hatch area criteria in the profile hatch area.
Name | Gets or Sets the profile hatch area's name.
ShapeStyleId | Gets or Sets the profile hatch area's shape style id.
ShapeStyleName | Gets or Sets the profile hatch area's shape style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class > ProfileHatchArea Properties
Legend
Legend
Property
public


ProfileHatchAreaCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Properties
ProfileHatchAreaCollection Properties Public Properties
ProfileHatchAreaCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of ProfileHatchArea objects in the collection.
default | Gets the ProfileHatchArea at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class > ProfileHatchAreaCollection Properties
Legend
Legend
Property
public


ProfileOverride Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Properties
ProfileOverride Properties Public Properties
ProfileOverride Properties
Public Properties
Public Property | Description
OverrideStyleId | Sets the override style of the entity.
OverrideStyleName | Sets the override style of the entity.
ProfileId | Gets the object id of the profile.
ProfileName | Gets the name of the profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class > ProfileOverride Properties
Legend
Legend
Property
public


ProfileOverrideCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Properties
ProfileOverrideCollection Properties Public Properties
ProfileOverrideCollection Properties
Public Properties
Public Property | Description
ClipGridAt | Gets or sets which profile controls the size of the profile view grid.
Count | Gets the number of ProfileOverride objects in the collection.
default | Gets the ProfileOverride at a specified index in the collection.
SplitAt | Gets or sets which profile to favor when splitting a profile view containing multiple profiles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class > ProfileOverrideCollection Properties
Legend
Legend
Property
public


ProfileParabolaAsymmetric Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties
ProfileParabolaAsymmetric Properties Public Properties
ProfileParabolaAsymmetric Properties
Public Properties
Public Property | Description
AsymmetricLength1 | Gets or sets the length of the parabola in.
AsymmetricLength2 | Gets or sets the length of the parabola out.
CurveType | Gets the curve type, crest or sag.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class > ProfileParabolaAsymmetric Properties
Legend
Legend
Property
public


ProfileParabolaSymmetric Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties
ProfileParabolaSymmetric Properties Public Properties
ProfileParabolaSymmetric Properties
Public Properties
Public Property | Description
CurveType | Gets the curve type, crest or sag.
EntityType | Gets the profile entity type, either Tangent, Circular, ParabolaSymmetric or ParabolaAsymmetric
GradeAtThroughPoint1 | Gets or sets the grade value of the first pass-through point.
GradeAtThroughPoint2 | Gets or sets the grade value of the second pass-through point.
GradeChange | Gets the A value (Grade Change) between the end point and start point.
GradeIn | Gets the grade at the start point.
GradeOut | Gets the grade at the end point.
HighLowPointElevation | Gets the elevation value of the high/low point of the curve.
HighLowPointStation | Gets the station value of the high/low point of the curve.
K | Gets or sets the K value (Curve Coefficient) of the curve.
M | Gets the M value of the curve.
PVIElevation | Gets the elevation value of the PVI this curve is associated with.
PVIStation | Gets the station value of the PVI this curve is associated with.
Radius | Gets or sets the radius of the curve.
TangentOffsetAtPVI | Gets the tangent offset value at the PVI the curve is associated with.
ThroughPoint1Elevation | Gets or sets the elevation value of the first pass-through point.
ThroughPoint1Station | Gets or sets the station value of the first pass-through point.
ThroughPoint2Elevation | Gets or sets the elevation value of the second pass-through point.
ThroughPoint2Station | Gets or sets the station value of the second pass-through point.
ThroughPoint3Elevation | Gets or sets the elevation value of the third pass-through point.
ThroughPoint3Station | Gets or sets the station value of the third pass-through point.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class > ProfileParabolaSymmetric Properties
Legend
Legend
Property
public


ProfilePVI Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties
ProfilePVI Properties Public Properties
ProfilePVI Properties
Public Properties
Public Property | Description
Elevation | Gets or sets the elevation value of the PVI.
EntityAfter | Gets the ID of the profile entity that follows the current entity.
EntityBefore | Gets the ID of the profile entity that precedes the current entity.
GradeIn | Gets or sets the grade of the curve into the PVI.
GradeOut | Gets or sets the grade of the curve out of the PVI.
HeadlightSightDistance | Gets or sets the headlight sight distance of the sag parabolic curve.
PassingSightDistance | Gets or sets the passing sight distance of the crest parabolic curve.
PVIType | Gets the type of subentity at the PVI.
Station | Gets or sets the station value of the PVI.
StoppingSightDistance | Gets or sets the stopping sight distance of the crest parabolic curve.
VerticalCurve | Gets the vertical curve object at the PVI.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class > ProfilePVI Properties
Legend
Legend
Property
public


ProfilePVICollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Properties
ProfilePVICollection Properties Public Properties
ProfilePVICollection Properties
Public Properties
Public Property | Description
Count | Gets the number of ProfilePVI objects in the collection.
default | Gets the ProfilePVI object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class > ProfilePVICollection Properties
Legend
Legend
Property
public


ProfileTangent Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Properties
ProfileTangent Properties Public Properties
ProfileTangent Properties
Public Properties
Public Property | Description
EntityType | Gets the profile entity type.
Grade | Gets the tangent grade.
ThroughPoint1Elevation | Gets or sets the elevation value of the first pass-through point.
ThroughPoint1Station | Gets or sets the station value of the first pass-through point.
ThroughPoint2Elevation | Gets or sets the elevation value of the second pass-through point.
ThroughPoint2Station | Gets or sets the station value of the second pass-through point.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class > ProfileTangent Properties
Legend
Legend
Property
public


ProfileView Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties
ProfileView Properties Public Properties
ProfileView Properties
Public Properties
Public Property | Description
AlignmentId | Gets the object id of the alignment from which the profile view was created.
AlignmentName | Gets the name of the alignment from which the profile view was created.
ElevationMax | Gets or sets the maximum elevation of the profile view.
ElevationMin | Gets or sets the minimum elevation of the profile view.
ElevationRangeMode | Gets or sets how to specify the vertical range of the profile view.
GraphOverrides | Gets the collection of the profiles that belong to the alignment.
HatchAreas | Gets the collection of hatch area in the profile view.
SplitDataLines | Gets the collection of split data lines.
SplitDatumRounding | Gets or sets where to round the vertical split location.
SplitHeight | Gets or sets the elevation range for splitting the profile view.
SplitProfileView | Gets or sets whether to split the profile view to multiple segments.
SplitStationMode | Gets or sets the mode to split the profile view.
SplitStationRounding | Gets or sets where to round the horizontal split location.
StationEnd | Gets or sets the end station of the profile view.
StationRangeMode | Gets or sets how to specify the horizontal range of the profile view.
StationStart | Gets or sets the start station of the profile view.
StyleId | Sets the ProfileView's style by ObjectId.
StyleName | Sets the ProfileView's style by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class > ProfileView Properties
Legend
Legend
Property
public


ProfileViewSplitData Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Properties
ProfileViewSplitData Properties Public Properties
ProfileViewSplitData Properties
Public Properties
Public Property | Description
AdjustedDatum | Gets or sets the vertical split location.
ProfileViewStyleId | Gets of sets the style of the profile view segment.
ProfileViewStyleName | Gets of sets the style of the profile view segment.
SplitStation | Gets or sets the starting station value of the split location.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class > ProfileViewSplitData Properties
Legend
Legend
Property
public


ProfileViewSplitDataCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Properties
ProfileViewSplitDataCollection Properties Public Properties
ProfileViewSplitDataCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of ProfileViewSplitData objects in the collection.
default | Gets the ProfileViewSplitData at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class > ProfileViewSplitDataCollection Properties
Legend
Legend
Property
public


SampleLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Properties
SampleLine Properties Public Properties
SampleLine Properties
Public Properties
Public Property | Description
GroupId | Gets the object id of the sample line group it belongs to.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class > SampleLine Properties
Legend
Legend
Property
public


Section Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Section Class > Section Properties
Section Properties Public Properties
Section Properties
Public Properties
Public Property | Description
ParentId | Gets the ObjectId of the Section object's parent.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Section Class > Section Properties
Legend
Legend
Property
public


SectionView Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionView Class > SectionView Properties
SectionView Properties Public Properties
SectionView Properties
Public Properties
Public Property | Description
ParentEntityId | Gets the ObjectId of the parent Entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionView Class > SectionView Properties
Legend
Legend
Property
public


Station Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Properties
Station Properties Public Properties
Station Properties
Public Properties
Public Property | Description
GeometryStationType | Gets the geometry point station type.
Location | Gets the station's location.
RawStation | Gets the station's raw station.
StationType | Gets the station type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class > Station Properties
Legend
Legend
Property
public


StationEquation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Properties
StationEquation Properties Public Properties
StationEquation Properties
Public Properties
Public Property | Description
EquationType | Gets or sets the type of station equation.
RawStationBack | Gets or sets the raw back station value.
StationAhead | Gets or sets the ahead station value.
StationBack | Gets or sets the back station value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class > StationEquation Properties
Legend
Legend
Property
public


StationEquationCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Properties
StationEquationCollection Properties Public Properties
StationEquationCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of StationEquation objects in the collection.
default | Gets the StationEquation object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class > StationEquationCollection Properties
Legend
Legend
Property
public


StationOffsetLabel Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Properties
StationOffsetLabel Properties Public Properties
StationOffsetLabel Properties
Public Properties
Public Property | Description
AnchorAtXY | Gets or sets a flag to indicate whether the label should move when the alignment is moved or if it... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class > StationOffsetLabel Properties
Legend
Legend
Property
public


AlignmentStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties
AlignmentStyle Properties Public Properties
AlignmentStyle Properties
Public Properties
Public Property | Description
ArrowHeadOption | Gets the alignment arrow head option.
BeginPointMarkerStyle | Gets or sets the marker style object id for 'begin of alignment' points on the alignment.
CompoundCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'compound curve intersection' points on the alignment.
CurveLineIntersectPointMarkerStyle | Gets or sets the marker style object id for 'curve line intersection' points on the alignment.
CurveSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'curve spiral intersection' points on the alignment.
EnableRadiusSnap | Gets or sets the boolean value that specifies whether to enable snapping when changing the curve radius value.
EndPointMarkerStyle | Gets or sets the marker style object id for 'end of alignment' points on the alignment.
IntersectionPointMarkerStyle | Gets or sets the marker style object id for 'point of intersection' points on the alignment.
LineCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'line curve intersection' points on the alignment.
LineMarkerDisplayStyleSection | Gets the display style for line markers in section view orientation.
LineSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'line spiral intersection' points on the alignment.
MidPointMarkerStyle | Gets or sets the marker style object id for mid points on the alignment.
RadiusSnapValue | Gets or sets the even increment value by which a curve radius can change using snapping.
ReverseCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'reverse curve intersection' points on the alignment.
ReverseSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'reverse spiral intersection' points on the alignment.
SpiralCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral curve intersection' points on the alignment.
SpiralLineIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral line intersection' points on the alignment.
SpiralSpiralIntersectPointMarkerStyle | Gets or sets the marker style object id for 'spiral spiral intersection' points on the alignment.
StationReferencePointMarkerStyle | Gets or sets the marker style object id for 'station reference' points on the alignment.
ThroughPointMarkerStyle | Gets or sets the marker style object id for 'through points' on the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class > AlignmentStyle Properties
Legend
Legend
Property
public


ArrowHeadOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties
ArrowHeadOption Properties Public Properties
ArrowHeadOption Properties
Public Properties
Public Property | Description
ArrowBlockName | Gets or Sets the arrow block name.
ArrowType | Gets or Sets the arrow head drawing type.
Fit | Gets or Sets the arrow head fit option.
FixedScaleX | Gets or Sets the arrow head fixed scale in X.
FixedScaleY | Gets the arrow head fixed scale in Y.
FixedScaleZ | Gets the arrow head fixed scale in Z.
SizeOption | Gets or Sets the arrow head size option.
SizeValue | Gets or Sets the arrow head size value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class > ArrowHeadOption Properties
Legend
Legend
Property
public


BuildingSiteStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Properties
BuildingSiteStyle Properties Public Properties
BuildingSiteStyle Properties
Public Properties
Public Property | Description
MarkerStyleId | Gets or sets the object id of the marker style for the building site style.
MarkerStyleName | Gets or sets the name of the marker style for the building site style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class > BuildingSiteStyle Properties
Legend
Legend
Property
public


ContourValues Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Properties
ContourValues Properties Public Properties
ContourValues Properties
Public Properties
Public Property | Description
MajorColor | Gets or sets the color for major contours.
MajorLineTypeId | Gets or sets the ObjectId of the major line type.
MajorLineWight | Gets or sets the major line weight.
MinorColor | Gets or sets the color for minor contours.
MinorLineTypeId | Gets or sets the ObjectId of the minor line type.
MinorLineWight | Gets or sets the minor line weight.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class > ContourValues Properties
Legend
Legend
Property
public


GradingCriteria Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties
GradingCriteria Properties Public Properties
GradingCriteria Properties
Public Properties
Public Property | Description
CutSlope | Specifies the cut grade value.
CutSlopeFormatType | Specifies how the cut slope should be represented.
Distance | Specifies that the grading projection lines will be extended from the footprint until they are match a specified horizontal distance.... more
DistanceProjectionType | Specifies the type of projection for the Distance target.
Elevation | Specifies that the grading projection lines will be extended from the footprint until they reach a specified elevation.
ElevationProjectionType | Specifies the type of projection for the Elevation target.
FillSlope | Specifies the fill grade value.
FillSlopeFormatType | Specifies how the fill slope should be represented.
InteriorCornerOverlap | Specifies how interior corner projections are cleaned up when the footprint corner has different elevations.
ProjectionDistance | Specifies the fixed distance from the footprint for the projection.
ProjectionRelativeElevation | Specifies the projection relative elevation.
RelativeElevation | Specifies that the grading projection lines will be extended from the footprint until they reach an elevation (depth or height)... more
RelativeElevationProjectionType | Specifies the type of projection for the Relative Elevation target.
SearchOrder | Specifies whether to search first for cut or fill slopes in cases where both would work.
Slope | Specifies the grade value.
SlopeFormatType | Specifies how the slope should be represented.
SurfaceProjectionType | Specifies the type of projection for the Surface target.
Target | Specifies the target method for the grading.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class > GradingCriteria Properties
Legend
Legend
Property
public


GradingCriteriaSet Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Properties
GradingCriteriaSet Properties Public Properties
GradingCriteriaSet Properties
Public Properties
Public Property | Description
Count | Gets the number of grading criteria in the current grading criteria set.
default | Gets the grading criteria by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class > GradingCriteriaSet Properties
Legend
Legend
Property
public


GradingStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties
GradingStyle Properties Public Properties
GradingStyle Properties
Public Properties
Public Property | Description
CenterMarker | Gets or Sets the MarkerSizeType enum value that specifies the size of the marker and how it is calculated.
FixedSize | Gets or sets the marker size that is specified in the current drawing units (usually feet or meters).
PercentageOfScreen | Gets or sets the current zoom level of the marker size.
PlottedSize | Gets or sets the marker size that is based on the current drawing scale(inches or millimeters).
SlopePatternStyleId | Gets or sets the object id of the slope pattern style for the grading style.
SlopePatternStyleName | Gets or sets the name of the slope pattern style for the grading style.
SlopeRangeMax | Gets or sets the maximum value of the slope value.
SlopeRangeMin | Gets or sets the minimum value of the slope value.
UseSlopePatternStyle | Gets or sets a bool value that specifies whether use a slope pattern style for the grading style.
UseSlopeRange | Gets or sets a bool value that specifies whether the slope pattern is applied to a limited range of slope... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class > GradingStyle Properties
Legend
Legend
Property
public


GroupPlotStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties
GroupPlotStyle Properties Public Properties
GroupPlotStyle Properties
Public Properties
Public Property | Description
AlignType | Gets or sets the GroupPlotAlignType enum value that specifies how the section views are aligned.
CellSizeType | Gets or sets the GroupPlotCellSizeType enum value that specifies cell size as either uniform or uniform row/column.
GapBetweenPages | Gets of sets the plotted distance between each successive page in a multiple section view plot.
MaximumInColumn | Gets or sets the maximum number of cross section views plotted in a column before moving on to the next... more
MaximumInRow | Gets or sets the maximum number of cross section views plotted in a row before moving on to the next... more
PlotAreaType | Gets or sets the GroupPlotAreaType enum value that specifies whether to plot page by page or plot all.
PlotRule | Gets or sets the SectionViewPlotRuleType enum value that specifies whether to plot the section views by column or row.
SheetStyleId | Gets or sets the object id of the sheet style for the GroupPlotStyle.
SheetStyleName | Gets or sets the name of the sheet style for the GroupPlotStyle.
SpaceColumn | Gets or sets the minimum number of major grid lines between columns of section views.
SpaceRow | Gets or sets the minimum number of major grid lines between rows of section views.
StartCorner | Gets or sets the GroupPlotStartCornerType enum value that specifies the starting corner type for plotting the section views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class > GroupPlotStyle Properties
Legend
Legend
Property
public


HorizontalGeometryBandStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties
HorizontalGeometryBandStyle Properties Public Properties
HorizontalGeometryBandStyle Properties
Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CurveLabelStyleId | Gets the band horizontal label style id at the curve.
CurveTickStyle | Gets the band horizontal tick style at the curve.
SchematicLineType | Gets the band horizontal line type at the schematic.
SpiralLabelStyleId | Gets the band horizontal geometry spiral label style id at the horizontal.
SpiralTickStyle | Gets the band horizontal tick style at the spiral.
TangentLabelStyleId | Gets the band horizontal label style id at the tangent.
TangentTickStyle | Gets the band horizontal tick style at the tangent.
TitleTextLabelStyleId | Gets the band profile data title text label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class > HorizontalGeometryBandStyle Properties
Legend
Legend
Property
public


LabelStylesAlignmentRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties
LabelStylesAlignmentRoot Properties Public Properties
LabelStylesAlignmentRoot Properties
Public Properties
Public Property | Description
CurveLabelStyles | Gets the collection of styles associated with an alignment's curve labels.
DesignSpeedLabelStyles | Gets the collection of styles for design speedon the alignment.
GeometryPointLabelStyles | Gets the collection of all alignment geometry point label styles.
LineLabelStyles | Gets the collection of all alignment line label styles.
MajorStationLabelStyles | Gets the collection of all alignment major station label styles.
MinorStationLabelStyles | Gets the collection of all alignment minor station label styles.
SpiralLabelStyles | Gets the collection of all alignment spiral label styles.
StationEquationLabelStyles | Gets the collection of all alignment station equation label styles.
StationOffsetLabelStyles | Gets the collection of all alignment station offset label styles.
SuperelevationCriticalPointsLabelStyles | Gets the collection of all alignment superelevation Critical points label styles.
TangentIntersectionLabelStyles | Gets the collection of all alignment tangent intersection label styles.
VerticalGeometryPointLabelStyles | Gets the collection of all alignment vertical geometry point label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class > LabelStylesAlignmentRoot Properties
Legend
Legend
Property
public


LabelStylesMatchLineRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class > LabelStylesMatchLineRoot Properties
LabelStylesMatchLineRoot Properties Public Properties
LabelStylesMatchLineRoot Properties
Public Properties
Public Property | Description
LeftLabelStyles | Gets the collection of all match line left label styles.
RightLabelStyles | Gets the collection of all match line right label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class > LabelStylesMatchLineRoot Properties
Legend
Legend
Property
public


LabelStylesProfileRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties
LabelStylesProfileRoot Properties Public Properties
LabelStylesProfileRoot Properties
Public Properties
Public Property | Description
CurveLabelStyles | Gets the collection of all profile curve label styles.
GradeBreadLabelStyles | Gets the collection of all profile grade break label styles.
GradeBreakLabelStyles | Gets the collection of all profile grade break label styles.
HorizontalGeometryPointLabelStyles | Gets the collection of all profile horizontal geometry point label styles.
LineLabelStyles | Gets the collection of all profile line label styles.
MajorStationLabelStyles | Gets the collection of all profile major station label styles.
MinorStationLabelStyles | Gets the collection of all profile minor station label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class > LabelStylesProfileRoot Properties
Legend
Legend
Property
public


MassHaulLineStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Properties
MassHaulLineStyle Properties Public Properties
MassHaulLineStyle Properties
Public Properties
Public Property | Description
FreeHaulOption | Gets the FreeHaulDisplayType enumeration that defines how to show the free haul in the graph.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class > MassHaulLineStyle Properties
Legend
Legend
Property
public


MassHaulViewStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties
MassHaulViewStyle Properties Public Properties
MassHaulViewStyle Properties
Public Properties
Public Property | Description
BottomAxis | Gets the style object that specifies display properties for masshual view bottom axes.
GraphStyle | Gets the style object that specifies all display properties for masshual view graphs.
GridStyle | Gets the style object that specifies display properties for masshual view grid.
LeftAxis | Gets the style object that specifies display properties for masshual view left axes.
MiddleAxis | Gets the style object that specifies display properties for masshual view midlle axes.
RightAxis | Gets the style object that specifies display properties for masshual view right axes.
TopAxis | Gets the style object that specifies display properties for masshual view top axes.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class > MassHaulViewStyle Properties
Legend
Legend
Property
public


MatchLineStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Properties
MatchLineStyle Properties Public Properties
MatchLineStyle Properties
Public Properties
Public Property | Description
LinesDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match lines.
MatchLineMaskDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the match line mask areas.
MatchLineMaskHatchDisplayStyle | Gets the HatchDisplayStyle that specifies the hatch pattern for the match line mask areas.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class > MatchLineStyle Properties
Legend
Legend
Property
public


ParcelStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Properties
ParcelStyle Properties Public Properties
ParcelStyle Properties
Public Properties
Public Property | Description
AreaFillHatchDisplayStyleModel | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Model display styles as color, linetype, plotstyle,... more
AreaFillHatchDisplayStylePlan | Gets the AeccDisplayStyle property that specifies, for the area fill hatch pattern, such Plan display styles as color, linetype, plotstyle,... more
NameTemplate | Gets or sets the parcel name template string.
ObservePatternFillDistance | Gets or sets the boolean value that enables the use of the width of boundary area parcel setting, the offset... more
PatternFillDistance | Gets or sets the width of the boundary area parcel setting, which is the offset distance from the parcel boundary.... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class > ParcelStyle Properties
Legend
Legend
Property
public


PointStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Properties
PointStyle Properties Public Properties
PointStyle Properties
Public Properties
Public Property | Description
Display3dType | Gets or sets the PointDisplay3dType enum value that specifies how the display elevation of the Points is established when view... more
Elevation | Gets or sets the point's elevation if the points are to be flattened to an elevation.
LabelDisplayStyleModel | Gets the DisplayStyle property that specifies the PointStyle label Model display styles such as color, linetype, plotstyle, etc.
LabelDisplayStylePlan | Gets the DisplayStyle property that specifies the PointStyle label Plan display styles such as color, linetype, plotstyle, etc.
MarkerType | Gets or sets the marker to an AutoCAD point, a customer mark, or a symbol.
ScaleFactor | Gets or sets the scale factor for point elevations for when viewing in 3D.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class > PointStyle Properties
Legend
Legend
Property
public


ProfileDataBandStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties
ProfileDataBandStyle Properties Public Properties
ProfileDataBandStyle Properties
Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
HGPLabelStyleId | Gets the band profile data label style id at the horizontal geometry point (HGP).
HGPTickStyle | Gets the band profile data tick style at the horizontal geometry point (HGP).
IncrementalDistanceLabelStyleId | Gets the band profile data label style id at the incremental distance.
MajorIncrementLabelStyleId | Gets the band profile data label style id at the major increment.
MajorIncrementTickStyle | Gets the band profile data tick style at the major increment.
MinorIncrementLabelStyleId | Gets the band profile data label style id at the minor increment.
MinorIncrementTickStyle | Gets the band profile data tick style at the minor increment.
StationEquationLabelStyleId | Gets the band profile data label style id at the station equation.
StationEquationTickStyle | Gets the band profile data tick style at the station equation.
TitleTextLabelStyleId | Gets the band profile data title text label style.
VGPLabelStyleId | Gets the band profile data label style id at the vertical geometry point (VGP).
VGPTickStyle | Gets the band profile data tick style at the vertical geometry point (VGP).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class > ProfileDataBandStyle Properties
Legend
Legend
Property
public


ProfileLabelSetStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Properties
ProfileLabelSetStyle Properties Public Properties
ProfileLabelSetStyle Properties
Public Properties
Public Property | Description
default | Gets the profile label set item at the given index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class > ProfileLabelSetStyle Properties
Legend
Legend
Property
public


ProfileStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties
ProfileStyle Properties Public Properties
ProfileStyle Properties
Public Properties
Public Property | Description
ArrowHeadOption | Gets the profile arrow head option.
BeginPointMarkerStyle | Gets or sets the marker style object id for 'Begin point' on the profile.
Chain3DDisplayStyleModel | Gets the AeccDisplayStyle for 3D chain display style in model view orientation.
ChainTessellationDistance3D | Gets or sets the curve tessellation distance used for 3D chain visualization.
EndPointMarkerStyle | Gets or sets the marker style object id for 'End point' on the profile
HighPointMarkerStyle | Gets or sets the marker style object id for 'High Point' on the profile
LowPointMarkerStyle | Gets or sets the marker style object id for 'Low Point' on the profile
ProfileMarkerDisplayStyleSection | Gets the AeccDisplayStyle for marker display style in section view orientation.
ProfileMarkerSectionViewMarkerStyle | Gets or sets the marker style object id for 'Section View' on the profile
ThroughPointMarkerStyle | Gets or sets the marker style object id for 'Through points' on the profile.
VCompoundCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Compound Curve Intersection' on the profile
VCurveTangentIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Curve Tangent intersection' on the profile
VIntersectionPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Intersection' on the profile.
VReverseCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Reverse Curve Intersection' on the profile
VTangentCurveIntersectPointMarkerStyle | Gets or sets the marker style object id for 'Point of Vertical Tangent Curve Intersection' on the profile


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class > ProfileStyle Properties
Legend
Legend
Property
public


ProfileViewBandSetItem Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Properties
ProfileViewBandSetItem Properties Public Properties
ProfileViewBandSetItem Properties
Public Properties
Public Property | Description
LabelAtEndStation | Gets or sets the label at end station.
LabelAtStartStation | Gets or sets the label at start station.
MajorInterval | Gets or sets the d view data band major interval distance.
MinorInterval | Gets or sets the section view data band minor interval distance.
StaggerLabel | Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor... more
StaggerLineHeight | Gets or sets height of the label stagger line.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class > ProfileViewBandSetItem Properties
Legend
Legend
Property
public


ProfileViewBandSetStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Properties
ProfileViewBandSetStyle Properties Public Properties
ProfileViewBandSetStyle Properties
Public Properties
Public Property | Description
BottomBandSetItems | Gets the bottom band set item collection from profile view band set style.
MatchIncrement | Gets or sets if the profile data band major/minor interval distances for profile views matches the profile view style’s major/minor... more
TopBandSetItems | Gets the top band set item collection from profile view band set style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class > ProfileViewBandSetStyle Properties
Legend
Legend
Property
public


ProfileViewStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Properties
ProfileViewStyle Properties Public Properties
ProfileViewStyle Properties
Public Properties
Public Property | Description
BottomAxis | Gets the style object that specifies display properties for profile view bottom axes.
GraphStyle | Gets the style object that specifies all display properties for profile view graphs.
GridStyle | Gets the style object that specifies display properties for profile view grid.
LeftAxis | Gets the style object that specifies display properties for profile view left axes.
RightAxis | Gets the style object that specifies display properties for profile view right axes.
TopAxis | Gets the style object that specifies display properties for profile view top axes.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class > ProfileViewStyle Properties
Legend
Legend
Property
public


SectionalDataBandStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Properties
SectionalDataBandStyle Properties Public Properties
SectionalDataBandStyle Properties
Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
IncrementalSectionDataLabelStyleId | Gets the band section data label style id at the incremental section data.
IncrementalSectionDataTickStyle | Gets the band section data tick style at the incremental section data.
SampleLineStationLabelStyleId | Gets the band section data label style id at the sample line station.
SampleLineStationTickStyle | Gets the band section data tick style at the sample line station.
TitleTextLabelStyleId | Gets the band profile data title text label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class > SectionalDataBandStyle Properties
Legend
Legend
Property
public


SectionDataBandStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties
SectionDataBandStyle Properties Public Properties
SectionDataBandStyle Properties
Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CenterlineLabelStyleId | Gets the band section data label style id at the centerline.
CenterlineTickStyle | Gets the band section data tick style at the centerline.
GradeBreaksLabelStyleId | Gets the band section data label style id at the grade breaks.
GradeBreaksTickStyle | Gets the band section data tick style at the grade breaks.
IncrementalDistanceLabelStyleId | Gets the band section data label style id at the incremental distance.
MajorIncrementLabelStyleId | Gets the band section data label style id at the major increment.
MajorIncrementTickStyle | Gets the band section data tick style at the major increment.
MinorIncrementLabelStyleId | Gets the band section data label style id at the minor increment.
MinorIncrementTickStyle | Gets the band section data tick style at the minor increment.
SampleLineVerticesLabelStyleId | Gets the band section data label style id at the sample line vertices.
SampleLineVerticesTickStyle | Gets the band section data tick style at the sample line vertices.
TitleTextLabelStyleId | Gets the band profile data title text label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class > SectionDataBandStyle Properties
Legend
Legend
Property
public


SectionSegmentBandStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Properties
SectionSegmentBandStyle Properties Public Properties
SectionSegmentBandStyle Properties
Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
SegmentLabelsTickStyle | Gets the band section data tick style at the segment labels.
SegmentsLabelStyleId | Gets the band section data label style id at the segment labels.
TitleTextLabelStyleId | Gets the band profile data title text label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class > SectionSegmentBandStyle Properties
Legend
Legend
Property
public


SectionViewBandSetItem Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Properties
SectionViewBandSetItem Properties Public Properties
SectionViewBandSetItem Properties
Public Properties
Public Property | Description
LabelAtEndOffset | Gets or sets the label at end offset.
LabelAtStartOffset | Gets or sets the label at start offset.
MajorInterval | Gets or sets the section view data band major interval distance.
MinorInterval | Gets or sets the section view data band minor interval distance.
StaggerLabel | Gets or sets the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or Stagger... more
StaggerLineHeight | Gets or sets the height of the label stagger line.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class > SectionViewBandSetItem Properties
Legend
Legend
Property
public


SectionViewBandSetItemCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Properties
SectionViewBandSetItemCollection Properties Public Properties
SectionViewBandSetItemCollection Properties
Public Properties
Public Property | Description
default | Gets the profile view band set item at the given index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class > SectionViewBandSetItemCollection Properties
Legend
Legend
Property
public


SectionViewBandSetStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Properties
SectionViewBandSetStyle Properties Public Properties
SectionViewBandSetStyle Properties
Public Properties
Public Property | Description
BottomBandSetItems | Gets the bottom band set item collection from section view band set style.
MatchIncrement | Gets or sets if the section data band major/minor interval distances for Section views matches the section view style’s major/minor... more
TopBandSetItems | Gets the top band set item collection from section view band set style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class > SectionViewBandSetStyle Properties
Legend
Legend
Property
public


SectionViewStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties
SectionViewStyle Properties Public Properties
SectionViewStyle Properties
Public Properties
Public Property | Description
BottomAxis | Gets the style object that specifies display properties for section view bottom axes.
CenterAxis | Gets the style object that specifies display properties for section view center axes.
GraphStyle | Gets the style object that specifies all display properties for section view graphs.
GridStyle | Gets the style object that specifies display properties for section view grid.
LeftAxis | Gets the style object that specifies display properties for section view left axes.
RightAxis | Gets the style object that specifies display properties for section view right axes.
TopAxis | Gets the style object that specifies display properties for section view top axes.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class > SectionViewStyle Properties
Legend
Legend
Property
public


SheetStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties
SheetStyle Properties Public Properties
SheetStyle Properties
Public Properties
Public Property | Description
GridHorizontalMajor | Gets or Sets the value of sheet style's horizontal major plot area grid.
GridHorizontalMinor | Gets or Sets the value of sheet style's horizontal minor plot area grid.
GridVerticalMajor | Gets or Sets the value of sheet style's vertical major plot area grid.
GridVerticalMinor | Gets or Sets the value of sheet style's vertical minor plot area grid.
PageLayoutId | Gets or Sets the object id of the sheet style's page layout.
PageMarginBottom | Gets or Sets the sheet style's bottom page margin.
PageMarginLeft | Gets or Sets the sheet style's left page margin.
PageMarginRight | Gets or Sets the sheet style's right page margin.
PageMarginTop | Gets or Sets the sheet style's top page margin.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class > SheetStyle Properties
Legend
Legend
Property
public


SlopePatternComponent Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class > SlopePatternComponent Properties
SlopePatternComponent Properties Public Properties
SlopePatternComponent Properties
Public Properties
Public Property | Description
SlopeLine | Gets the slope line class in the component.
SlopeLineOffset | Gets the slope line offset class in the component.
SlopeLineSymbol | Gets the slope line symbol class in the component.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class > SlopePatternComponent Properties
Legend
Legend
Property
public


SlopePatternLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties
SlopePatternLine Properties Public Properties
SlopePatternLine Properties
Public Properties
Public Property | Description
Color | Specifies the color of the line.
Grade1 | Specifies the first grade values for the component.
Grade2 | Specifies the second grade values for the component.
Length | Specifies the length value in drawing units (usually feet or meters). The line is trimmed if the slope is shorter... more
LengthType | Specifies how to determine the line length for this component.
Linetype | Specifies the linetype for the component.
LineWeight | Specifies the lineweight for the component.
MaximumLength | Specifies the maximum line length in drawing units.
PercentofLength | Specifies the percentage value up to a specified maximum.
PercentofLength1 | Specifies the line length as a percent of slope length for Slope 1.
PercentofLength2 | Specifies the line length as a percent of slope length for Slope 2.
StartType | Specifies whether the pattern begins at the top or bottom of the slope.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class > SlopePatternLine Properties
Legend
Legend
Property
public


SlopePatternLineOffset Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties
SlopePatternLineOffset Properties Public Properties
SlopePatternLineOffset Properties
Public Properties
Public Property | Description
Distance | Specifies the linear value in drawing units (usually feet or meters).
MaximumDistance | Specifies maximum offsets value in drawing units.
MinimumDistance | Specifies minimum offsets value in drawing units.
Numberoflines | Specifies the number of instances of this component to insert.
OffsetType | Specifies how to determine the offset distance between this component and the previous component in the slope line style.
PercentofLength | Specifies the percentage to the slope length at the position being offset from.
RadialOffsetAngle | Specifies the angular value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class > SlopePatternLineOffset Properties
Legend
Legend
Property
public


SlopePatternLineSymbol Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties
SlopePatternLineSymbol Properties Public Properties
SlopePatternLineSymbol Properties
Public Properties
Public Property | Description
BlockName | Specifies the block to insert.
Color | Specifies the color of the symbol.
Length | Specifies the length value in drawing units (usually feet or meters).
LengthType | Specifies how to determine the length of the symbol.
Linetype | Specifies the linetype for the symbol.
LineWeight | Specifies the lineweight for the symbol.
Numberoflines | Specifies the number of lines to include in the tapered lines set.
PercentofLength | Specifies the percentage value to the slope length.
SymbolType | Specifies whether a symbol is added to the beginning of the slope line.
WidthRatio | Specifies the ratio of the symbol’s width to its length along the slope line (width = length * width ratio).... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class > SlopePatternLineSymbol Properties
Legend
Legend
Property
public


SlopePatternStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Properties
SlopePatternStyle Properties Public Properties
SlopePatternStyle Properties
Public Properties
Public Property | Description
Count | Gets slope pattern style components' count.
default | Gets the slope pattern component by index.
MinDisplayLength | Gets or sets the minimum slope length on which to display the slope pattern.
PreviewFeatureLength | Gets or sets the length of the feature line to display.
PreviewSlope | Gets or sets the slope value to display.
PreviewSlopeLength | Gets or sets the length of the slope to display.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class > SlopePatternStyle Properties
Legend
Legend
Property
public


SuperelevationDataBandStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties
SuperelevationDataBandStyle Properties Public Properties
SuperelevationDataBandStyle Properties
Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
FullSuperLabelStyleId | Gets the band label style id at the full super.
FullSuperTickStyle | Gets the band tick style at the full super.
LevelCrownLabelStyleId | Gets the band label style id at the level crown.
LevelCrownTickStyle | Gets the band tick style at the level crown.
NormalCrownLabelStyleId | Gets the band label style id at the normal crown.
NormalCrownTickStyle | Gets the band tick style at the normal crown.
ReverseCrownLabelStyleId | Gets the band label style id at the reverse crown.
ReverseCrownTickStyle | Gets the band tick style at the reverse crown.
ShoulderCriticalPointsLabelStyleId | Gets the band label style id at the shoulder critical points.
ShoulderCriticalPointsTickStyle | Gets the band tick style at the shoulder critical points.
SlopeTransitionRegionLabelStyleId | Gets the band label style id at the slope transition region.
SlopeTransitionRegionTickStyle | Gets the band tick style at the slope transition region.
TitleTextLabelStyleId | Gets the band profile data title text label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class > SuperelevationDataBandStyle Properties
Legend
Legend
Property
public


SurfaceBaseStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class > SurfaceBaseStyle Properties
SurfaceBaseStyle Properties Public Properties
SurfaceBaseStyle Properties
Public Properties
Public Property | Description
DisplayMode | Gets or sets the Display3dType enum value that specifies the appearance of surface elevations.
ExaggerateElevationBy | Gets or sets the double value by which the surface object component elevation values are scaled.
FlattenToElevationBy | Gets or sets the double value to which the surface object component is flattened, or projected.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class > SurfaceBaseStyle Properties
Legend
Legend
Property
public


SurfaceContourStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties
SurfaceContourStyle Properties Public Properties
SurfaceContourStyle Properties
Public Properties
Public Property | Description
BaseElevationInterval | Gets or sets the double value used to specify the contour base elevation interval.
DepressionTickMarkInterval | Gets or sets the double value that specifies the spacing of the tick marks along the depression contour.
DepressionTickMarkLength | Gets or sets the double value that specifies the length of the tick mark that is drawn normal to the... more
DisplayDepressions | Gets or sets the boolean value that specifies whether depression contours are displayed.
GroupRangeValuesBy | Gets or sets the GroupValuesByType enum value used to specify how to group the contour range values.
LegendStyleId | Gets or sets the string value that specifies the surface contour legend style.
LegendStyleName | Gets or sets the string value that specifies the surface contour legend style.
MajorContourColorScheme | Gets or sets the major color scheme for the contour range.
MajorContourInterval | Gets or sets the double value used to specify the number of minor contours per major contour.
MinorContourColorScheme | Gets or sets the minor color scheme for the contour range.
MinorContourInterval | Gets or sets the double value used to specify the contour interval.
NumberOfRanges | Gets or sets the long value that specifies the number of ranges to be used.
RangePrecision | Gets or sets the PrecisionRangeType enum value that specifies the range precision.
SmoothContours | Gets or sets the boolean value that specifies whether contours are smoothed.
SmoothingFactor | Gets or sets an int value that specifies the degree to which the surface is smoothed.
SmoothingType | Gets or sets the ContourSmoothingType enum value that specifies the type of smoothing used. This property is usable only when... more
UseColorScheme | Gets or sets the boolean value that specifies whether the major and minor color schemes are displayed.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class > SurfaceContourStyle Properties
Legend
Legend
Property
public


SurfaceDirectionStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties
SurfaceDirectionStyle Properties Public Properties
SurfaceDirectionStyle Properties
Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme name.
DisplayEntityMode | Gets or sets the DisplayType Specifies how the surface should be displayed/rendered.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface directional data is grouped.
LegendStyleId | Gets or sets the ObjectId value that specifies the surface direction legend style.
LegendStyleName | Gets or sets the string value that specifies the surface direction legend style.
NumberOfRanges | Gets or sets the number of directional ranges.
RangePrecision | Gets or sets the PrecisionRangeType Specifies the precision to use for the directional ranges included in this style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class > SurfaceDirectionStyle Properties
Legend
Legend
Property
public


SurfaceElevationStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties
SurfaceElevationStyle Properties Public Properties
SurfaceElevationStyle Properties
Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme for the range.
DisplayEntityMode | Gets or sets the 3D display behavior of the surface object sub-component.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface elevation data is grouped.
LegendStyleId | Gets or sets the ObjectId value that specifies the surface elevation legend style.
LegendStyleName | Gets or sets the string value that specifies the surface elevation legend style.
NumberOfRanges | Gets or sets the number of surface elevation range values to be used.
RangePrecision | Gets or sets the surface elevation range precision value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class > SurfaceElevationStyle Properties
Legend
Legend
Property
public


SurfacePointStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties
SurfacePointStyle Properties Public Properties
SurfacePointStyle Properties
Public Properties
Public Property | Description
DataPointsColor | Gets or sets the value specifying the true color of the data point display.
DataPointsSymbol | Gets or sets the value specifying the symbology of the data point display.
DerivedPointsColor | Gets or sets the value specifying the true color of the derived point display.
DerivedPointsSymbol | Gets or sets the value specifying the symbology of the derived point display.
NondestructivePointsColor | Gets or sets the value specifying the true color of the non-destructive point display.
NondestructivePointsSymbol | Gets or sets the value specifying the symbology of the non-destructive point display.
ScalingMethodType | Gets or sets the ScaleType enum value that specifies how to scale the point marker.
Units | Gets or sets the units property.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class > SurfacePointStyle Properties
Legend
Legend
Property
public


SurfaceSlopeArrowStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties
SurfaceSlopeArrowStyle Properties Public Properties
SurfaceSlopeArrowStyle Properties
Public Properties
Public Property | Description
ArrowScale | Gets or sets the scale in which slope arrows are drawn.
ArrowType | Gets or sets the SlopeArrowType enum value that specifies the arrowhead style.
ColorScheme | Gets or sets the color scheme for the range.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface slope arrows are grouped.
LegendStyleId | Gets or sets the style for the slope arrow legend.
LegendStyleName | Gets or sets the style for the slope arrow legend.
NumberOfRanges | Gets or sets the number of surface slope arrow range values to be used.
RangePrecision | Gets or sets the surface slope arrow range precision value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class > SurfaceSlopeArrowStyle Properties
Legend
Legend
Property
public


SurfaceSlopeStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties
SurfaceSlopeStyle Properties Public Properties
SurfaceSlopeStyle Properties
Public Properties
Public Property | Description
ColorScheme | Gets or sets the color scheme for the range.
DisplayEntityMode | Gets or sets the 3D display behavior of the surface object sub-component.
GroupValuesBy | Gets or sets the GroupValuesByType Specifies how the surface slope data is grouped.
LegendStyleId | Gets or sets the style for the surface slope legend.
LegendStyleName | Gets or sets the style for the surface slope legend.
NumberOfRanges | Gets or sets the number of surface slope range values to be used.
RangePrecision | Gets or sets the surface slope range precision value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class > SurfaceSlopeStyle Properties
Legend
Legend
Property
public


SurfaceStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties
SurfaceStyle Properties Public Properties
SurfaceStyle Properties
Public Properties
Public Property | Description
BoundaryStyle | Gets the style object that specifies properties for surface outer, show and hide boundaries/borders.
ContourStyle | Gets the style object that specifies properties for surface minor, major, depression, and user-defined contour lines.
DirectionStyle | Gets the style object that specifies properties for surface direction analysis components.
ElevationStyle | Gets the style object that specifies properties for surface elevation analysis components.
GridStyle | Gets the style object that specifies properties for surface primary, secondary, and datum grid information.
PointStyle | Gets the style object that specifies properties for surface point objects.
SlopeArrowStyle | Gets the style object that specifies properties for the surface slope arrow analysis components.
SlopeStyle | Gets the style object that specifies properties for surface slope analysis components.
TriangleStyle | Gets the style object that specifies properties for the surface TIN face components.
WatershedStyle | Gets the style object that specifies properties for the various kinds of surface watershed analysis components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class > SurfaceStyle Properties
Legend
Legend
Property
public


VerticalGeometryBandStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties
VerticalGeometryBandStyle Properties Public Properties
VerticalGeometryBandStyle Properties
Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
CrestCurveLabelStyleId | Gets the band vertical geometry label style id at the crest curve.
CrestCurveTickStyle | Gets the band vertical geometry tick style at the crest curve.
DownhillTangentLabelStyleId | Gets the band vertical geometry label style id at the down hill tangent.
DownhillTangentTickStyle | Gets the band vertical geometry tick styleat the down hill tangent.
SagCurveLabelStyleId | Gets the band vertical geometry label style id at the sag curve.
SagCurveTickStyle | Gets the band vertical geometry tick style at the sag curve.
TitleTextLabelStyleId | Gets the band profile data title text label style.
UphillTangentLabelStyleId | Gets the band vertical geometry label style id at the up hill tangent.
UphillTangentTickStyle | Gets the band vertical geometry tick style at the up hill tangent.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class > VerticalGeometryBandStyle Properties
Legend
Legend
Property
public


ViewFrameStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Properties
ViewFrameStyle Properties Public Properties
ViewFrameStyle Properties
Public Properties
Public Property | Description
ViewFrameBoundaryDisplayStylePlan | Gets the DisplayStyle that specifies plan display properties for the extents of a view frame.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class > ViewFrameStyle Properties
Legend
Legend
Property
public


SuperElevationData Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Properties
SuperElevationData Properties Public Properties
SuperElevationData Properties
Public Properties
Public Property | Description
Count | Gets the number of items in the collection.
default | Gets the default item.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class > SuperElevationData Properties
Legend
Legend
Property
public


SuperElevationDataElement Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Properties
SuperElevationDataElement Properties Public Properties
SuperElevationDataElement Properties
Public Properties
Public Property | Description
RawStation | Gets or sets raw station value.
SmoothingCurveLength | Gets or sets smoothing curve length for superelevation data element.
TransitionPointDescription | Gets or sets transition point description string.
TransitionPointType | Gets or sets transition point type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class > SuperElevationDataElement Properties
Legend
Legend
Property
public


Surface Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Properties
Surface Properties Public Properties
Surface Properties
Public Properties
Public Property | Description
IsVolumeSurface | Gets if the surface is a volume surface.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class > Surface Properties
Legend
Legend
Property
public


ViewFrame Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrame Class > ViewFrame Properties
ViewFrame Properties Public Properties
ViewFrame Properties
Public Properties
Public Property | Description
GroupId | Gets the object id of the view frame group it belongs to.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrame Class > ViewFrame Properties
Legend
Legend
Property
public


GeometryPointLabelOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointLabelOption Template > GeometryPointLabelOption Properties
GeometryPointLabelOption Properties Public Properties
GeometryPointLabelOption Properties
Public Properties
Public Property | Description
PointType | This is PointType, a member of class GeometryPointLabelOption.
Selected | This is Selected, a member of class GeometryPointLabelOption.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointLabelOption Template > GeometryPointLabelOption Properties
Legend
Legend
Property
public


GeometryPointSelector Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Properties
GeometryPointSelector Properties Public Properties
GeometryPointSelector Properties
Public Properties
Public Property | Description
default | Gets the GeometryPointLabelOption instance for the specified type, which allows the user to modify its Selected state.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > GeometryPointSelector Template > GeometryPointSelector Properties
Legend
Legend
Property
public


ProfileDesignCheck Properties Public Properties
ProfileDesignCheck Properties
Public Properties
Public Property | Description
DesignCheckType | Gets the type of the Profile DesignCheck type.


ProfileDesignCheckCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Properties
ProfileDesignCheckCollection Properties Public Properties
ProfileDesignCheckCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of ProfileDesignCheck in the collection.
default | Gets the ProfileDesignCheck by a specified name in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckCollection Class > ProfileDesignCheckCollection Properties
Legend
Legend
Property
public


ProfileDesignCheckRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Properties
ProfileDesignCheckRoot Properties Public Properties
ProfileDesignCheckRoot Properties
Public Properties
Public Property | Description
CurveDesignChecks | Gets the collection of all profile curve design checks.
LineDesignChecks | Gets the collection of all profile line design checks.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Classes > ProfileDesignCheckRoot Class > ProfileDesignCheckRoot Properties
Legend
Legend
Property
public


SettingsAlignment Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties
SettingsAlignment Properties Public Properties
SettingsAlignment Properties
Public Properties
Public Property | Description
CriteriaBasedDesignOptions | Gets the defaults for creating an alignment using design criteria
Data | Gets the defaults data for creating an alignment
DefaultNameFormat | Gets the default name formats for new alignments
DynamicAlignmentHighlight | Gets the defaults data for creating an alignment
StationIndexing | Gets the default station indexing for new alignments
StyleSettings | Gets the default styles for new alignments
SuperelevationOptions | Gets the defaults for calculating superelevation specifications


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class > SettingsAlignment Properties
Legend
Legend
Property
public


SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties
SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties Public Properties
SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties
Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
DesignSpeed | Gets default alignment design speed.
DesignSpeedLookupMethod | Gets the table lookup rule in cases where the actual design speed does not exactly match the speed specified in... more
RadiusLookupMethod | Gets the table lookup rule in cases where the actual radius does not exactly match the speed specified in the... more
UseCriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
UseDesignChecksOption | Gets whether to use a design check set by default.
UseDesignCriteriaFileOption | Gets whether to use a design criteria file by default.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class > SettingsAlignment::SettingsCriteriaBasedDesignOptions Properties
Legend
Legend
Property
public


SettingsAlignment::SettingsData Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsData Class > SettingsAlignment::SettingsData Properties
SettingsAlignment::SettingsData Properties Public Properties
SettingsAlignment::SettingsData Properties
Public Properties
Public Property | Description
CriteriaBasedDesignOption | Gets whether alignments use design criteria by default.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsData Class > SettingsAlignment::SettingsData Properties
Legend
Legend
Property
public


SettingsAlignment::SettingsDefaultNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class > SettingsAlignment::SettingsDefaultNameFormat Properties
SettingsAlignment::SettingsDefaultNameFormat Properties Public Properties
SettingsAlignment::SettingsDefaultNameFormat Properties
Public Properties
Public Property | Description
AlignmentNameTemplate | Gets specify the default name formats for new alignments.
OffsetAlignmentNameTemplate | Gets specify the default name formats for new alignments.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class > SettingsAlignment::SettingsDefaultNameFormat Properties
Legend
Legend
Property
public


SettingsAlignment::SettingsDynamicAlignmentHighlight Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties
SettingsAlignment::SettingsDynamicAlignmentHighlight Properties Public Properties
SettingsAlignment::SettingsDynamicAlignmentHighlight Properties
Public Properties
Public Property | Description
CurbReturnFilletRegionColor | Gets CurbReturnFilletRegionColor for dynamic alignment highlight.
CurbReturnFilletRegionLineweight | Gets CurbReturnFilletRegionLineweight for dynamic alignment highlight.
OffsetRegionColor | Gets OffsetRegionColor for dynamic alignment highlight.
OffsetRegionLineweight | Gets OffsetRegionLineweight for dynamic alignment highlight.
ParentAlignmentColor | Gets ParentAlignmentColor for dynamic alignment highlight.
ParentAlignmentLineweight | Gets ParentAlignmentLineweight for dynamic alignment highlight.
ParentAlignmentTrackerColor | Gets ParentAlignmentTrackerColor for dynamic alignment highlight.
ParentAlignmentTrackerLineweight | Gets ParentAlignmentTrackerLineweight for dynamic alignment highlight.
TransitionRegionColor | Gets TransitionRegionColor for dynamic alignment highlight.
TransitionRegionLineweight | Gets TransitionRegionLineweight for dynamic alignment highlight.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class > SettingsAlignment::SettingsDynamicAlignmentHighlight Properties
Legend
Legend
Property
public


SettingsAlignment::SettingsStationIndexing Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStationIndexing Class > SettingsAlignment::SettingsStationIndexing Properties
SettingsAlignment::SettingsStationIndexing Properties Public Properties
SettingsAlignment::SettingsStationIndexing Properties
Public Properties
Public Property | Description
DefaultStationIndexIncrement | Gets the default value for station increments.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStationIndexing Class > SettingsAlignment::SettingsStationIndexing Properties
Legend
Legend
Property
public


SettingsAlignment::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties
SettingsAlignment::SettingsStyles Properties Public Properties
SettingsAlignment::SettingsStyles Properties
Public Properties
Public Property | Description
AlignmentLabelSet | Gets the default alignment label set.
AlignmentStyle | Gets the default alignment style.
CurveLabelStyle | Gets the default curve label style.
LineLabelStyle | Gets the default line label style.
MarkerStyle | Gets the display and appearance of points on the alignment.
SpiralLabelStyle | Gets the default spiral label style.
StationOffsetLabelStyle | Gets the default station offset label style.
TangentIntersectLabelStyle | Gets the default tangent intersection label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class > SettingsAlignment::SettingsStyles Properties
Legend
Legend
Property
public


SettingsAlignment::SettingsSuperelevationOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties
SettingsAlignment::SettingsSuperelevationOptions Properties Public Properties
SettingsAlignment::SettingsSuperelevationOptions Properties
Public Properties
Public Property | Description
CorridorType | Gets the type of roadway as Undivided (single carriage way) or Divided (dual carriage way).
CrossSectionShape | Gets the cross sectional shape of the roadway as Planar .
HighsideLocation | Gets the default Highside Location for planar roads.
InsideShoulderMethod | Gets the method that is applied to the inside shoulder during superelevation.
NominalWidth | Gets the typical width of the roadway from the superelevation pivot point to the outer edge-of-traveled way.
NormalLaneSlope | Gets the % slope of the roadway lanes on tangent (unsuperelevated) tangents.
NormalShoulderSlope | Gets the % slope value of the roadway shoulders.
OutsideShoulderMethod | Gets the method that is applied to the outside shoulder during superelevation.
StationRoundingOption | Gets the number of positions for station rounding.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class > SettingsAlignment::SettingsSuperelevationOptions Properties
Legend
Legend
Property
public


SettingsBuildingSite Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Properties
SettingsBuildingSite Properties Public Properties
SettingsBuildingSite Properties
Public Properties
Public Property | Description
NameFormat | Gets the default name formats for new building sites.
Styles | Gets the default styles for new building sites.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class > SettingsBuildingSite Properties
Legend
Legend
Property
public


SettingsBuildingSite::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsNameFormat Class > SettingsBuildingSite::SettingsNameFormat Properties
SettingsBuildingSite::SettingsNameFormat Properties Public Properties
SettingsBuildingSite::SettingsNameFormat Properties
Public Properties
Public Property | Description
BuildingSite | Gets the default name formats for building sites.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsNameFormat Class > SettingsBuildingSite::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsBuildingSite::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsStyles Class > SettingsBuildingSite::SettingsStyles Properties
SettingsBuildingSite::SettingsStyles Properties Public Properties
SettingsBuildingSite::SettingsStyles Properties
Public Properties
Public Property | Description
BuildingSite | Gets the default style for building site.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsStyles Class > SettingsBuildingSite::SettingsStyles Properties
Legend
Legend
Property
public


SettingsCmdAddAlignmentCurveTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Properties
SettingsCmdAddAlignmentCurveTable Properties Public Properties
SettingsCmdAddAlignmentCurveTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddAlignmentCurveTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class > SettingsCmdAddAlignmentCurveTable Properties
Legend
Legend
Property
public


SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties Public Properties
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddAlignmentLineTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Properties
SettingsCmdAddAlignmentLineTable Properties Public Properties
SettingsCmdAddAlignmentLineTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddAlignmentLineTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class > SettingsCmdAddAlignmentLineTable Properties
Legend
Legend
Property
public


SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties Public Properties
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddAlignmentSegmentTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Properties
SettingsCmdAddAlignmentSegmentTable Properties Public Properties
SettingsCmdAddAlignmentSegmentTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddAlignmentSegmentTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class > SettingsCmdAddAlignmentSegmentTable Properties
Legend
Legend
Property
public


SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties Public Properties
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddAlignmentSpiralTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Properties
SettingsCmdAddAlignmentSpiralTable Properties Public Properties
SettingsCmdAddAlignmentSpiralTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddAlignmentSpiralTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class > SettingsCmdAddAlignmentSpiralTable Properties
Legend
Legend
Property
public


SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties Public Properties
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddContourLabelingGroup Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Properties
SettingsCmdAddContourLabelingGroup Properties Public Properties
SettingsCmdAddContourLabelingGroup Properties
Public Properties
Public Property | Description
AddContourLabeling | Gets the defaults assigned to surface labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class > SettingsCmdAddContourLabelingGroup Properties
Legend
Legend
Property
public


SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties Public Properties
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties
Public Properties
Public Property | Description
IntervalAlongContour | Gets the Interval Along Contour.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Properties
Legend
Legend
Property
public


SettingsCmdAddParcelCurveTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Properties
SettingsCmdAddParcelCurveTable Properties Public Properties
SettingsCmdAddParcelCurveTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddParcelCurveTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class > SettingsCmdAddParcelCurveTable Properties
Legend
Legend
Property
public


SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties Public Properties
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddParcelLineTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Properties
SettingsCmdAddParcelLineTable Properties Public Properties
SettingsCmdAddParcelLineTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddParcelLineTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class > SettingsCmdAddParcelLineTable Properties
Legend
Legend
Property
public


SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties Public Properties
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddParcelSegmentLabels Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Properties
SettingsCmdAddParcelSegmentLabels Properties Public Properties
SettingsCmdAddParcelSegmentLabels Properties
Public Properties
Public Property | Description
Options | Gets the default setting of Options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class > SettingsCmdAddParcelSegmentLabels Properties
Legend
Legend
Property
public


SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties Public Properties
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties
Public Properties
Public Property | Description
LabelingDirection | Gets the default parcel segment labeling direction .


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Properties
Legend
Legend
Property
public


SettingsCmdAddParcelSegmentTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Properties
SettingsCmdAddParcelSegmentTable Properties Public Properties
SettingsCmdAddParcelSegmentTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddParcelSegmentTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class > SettingsCmdAddParcelSegmentTable Properties
Legend
Legend
Property
public


SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties Public Properties
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddParcelTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Properties
SettingsCmdAddParcelTable Properties Public Properties
SettingsCmdAddParcelTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddParcelTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class > SettingsCmdAddParcelTable Properties
Legend
Legend
Property
public


SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties
SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties Public Properties
SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class > SettingsCmdAddParcelTable::SettinsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddPointTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Properties
SettingsCmdAddPointTable Properties Public Properties
SettingsCmdAddPointTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddPointTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class > SettingsCmdAddPointTable Properties
Legend
Legend
Property
public


SettingsCmdAddPointTable::SettinsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Properties
SettingsCmdAddPointTable::SettinsCmdTableCreation Properties Public Properties
SettingsCmdAddPointTable::SettinsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class > SettingsCmdAddPointTable::SettinsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddSurfaceBoundaries Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Properties
SettingsCmdAddSurfaceBoundaries Properties Public Properties
SettingsCmdAddSurfaceBoundaries Properties
Public Properties
Public Property | Description
DataOptions | Gets the default setting of adding data options for the command AddSurfaceBoundaries.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class > SettingsCmdAddSurfaceBoundaries Properties
Legend
Legend
Property
public


SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties Public Properties
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties
Public Properties
Public Property | Description
BoundaryType | Gets the default boundary type.
MidOrdinateDistance | Gets the default mid-ordinate distance.
NonDestructive | Gets a PropertyBoolean value that specifies the default selection of a type of breakline (destructive of non-destructive).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Properties
Legend
Legend
Property
public


SettingsCmdAddSurfaceBreaklines Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Properties
SettingsCmdAddSurfaceBreaklines Properties Public Properties
SettingsCmdAddSurfaceBreaklines Properties
Public Properties
Public Property | Description
DataOptions | Gets the default setting of adding data options for the command AddSurfaceBreaklines.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class > SettingsCmdAddSurfaceBreaklines Properties
Legend
Legend
Property
public


SettingsCmdAddSurfaceContours Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Properties
SettingsCmdAddSurfaceContours Properties Public Properties
SettingsCmdAddSurfaceContours Properties
Public Properties
Public Property | Description
AddDataOptions | Gets the defaults assigned when adding contours, boundaries, and breaklines to a surface.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class > SettingsCmdAddSurfaceContours Properties
Legend
Legend
Property
public


SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties Public Properties
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties
Public Properties
Public Property | Description
MidOrdinateDistance | Gets the default mid-ordinate distance.
SupplementingDistance | Gets the default supplementing distance.
WeedingAngle | Gets the default weeding angle.
WeedingDistance | Gets the default weeding distance.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Properties
Legend
Legend
Property
public


SettingsCmdAddSurfaceDemFile Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Properties
SettingsCmdAddSurfaceDemFile Properties Public Properties
SettingsCmdAddSurfaceDemFile Properties
Public Properties
Public Property | Description
ImportOptions | Gets the defaults assigned when creating surfaces.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class > SettingsCmdAddSurfaceDemFile Properties
Legend
Legend
Property
public


SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties Public Properties
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties
Public Properties
Public Property | Description
NullElevation | Gets null elevation.
UseCustomNullElevation | Gets whether use custom null elevation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Properties
Legend
Legend
Property
public


SettingsCmdAddSurfaceDrawingObjects Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Properties
SettingsCmdAddSurfaceDrawingObjects Properties Public Properties
SettingsCmdAddSurfaceDrawingObjects Properties
Public Properties
Public Property | Description
DataOptions | Gets the default setting of adding data options for the command AddSurfaceDrawingObjects.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class > SettingsCmdAddSurfaceDrawingObjects Properties
Legend
Legend
Property
public


SettingsCmdAddWidening Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Properties
SettingsCmdAddWidening Properties Public Properties
SettingsCmdAddWidening Properties
Public Properties
Public Property | Description
WideningOptions | Gets the widening options settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class > SettingsCmdAddWidening Properties
Legend
Legend
Property
public


SettingsCmdAddWidening::SettingsCmdWideningOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties
SettingsCmdAddWidening::SettingsCmdWideningOptions Properties Public Properties
SettingsCmdAddWidening::SettingsCmdWideningOptions Properties
Public Properties
Public Property | Description
RadiusForCurve1 | Specifies the RadiusForCurve1 for alignment widening options.
RadiusForCurve2 | Specifies the RadiusForCurve2 for alignment widening options.
RadiusForCurve3 | Specifies the RadiusForCurve3 for alignment widening options.
TaperInputType | Specifies the TaperInputType for alignment widening options.
TaperRatio | Specifies the TaperRatio for alignment widening options.
TransitionLength | Specifies the TransitionLength for alignment widening options.
TransitionType | Specifies the TransitionType for alignment widening options.
WideningOffset | Specifies the WideningOffset for alignment widening options.
WideningSegmentLength | Specifies the WideningSegmentLength for alignment widening options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class > SettingsCmdAddWidening::SettingsCmdWideningOptions Properties
Legend
Legend
Property
public


SettingsCmdCatchmentArea Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Properties
SettingsCmdCatchmentArea Properties Public Properties
SettingsCmdCatchmentArea Properties
Public Properties
Public Property | Description
Layer | Gets the catchment layer.
Marker | Gets the catchment marker.
MarkerStyle | Gets the catchment marker style.
ObjectType | Gets the catchment object type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class > SettingsCmdCatchmentArea Properties
Legend
Legend
Property
public


SettingsCmdConvertPointstoSdskPoints Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Properties
SettingsCmdConvertPointstoSdskPoints Properties Public Properties
SettingsCmdConvertPointstoSdskPoints Properties
Public Properties
Public Property | Description
Layer | Gets the default setting of Layer.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class > SettingsCmdConvertPointstoSdskPoints Properties
Legend
Legend
Property
public


SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties Public Properties
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties
Public Properties
Public Property | Description
Layer | Gets the default Layer.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignmentEntities Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Properties
SettingsCmdCreateAlignmentEntities Properties Public Properties
SettingsCmdCreateAlignmentEntities Properties
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the AlignmentTypeOption settings.
CreateFromEntities | Gets the CreateFromEntities settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class > SettingsCmdCreateAlignmentEntities Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignmentLayout Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Properties
SettingsCmdCreateAlignmentLayout Properties Public Properties
SettingsCmdCreateAlignmentLayout Properties
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the default setting of alignment type for the command CreateAlignmentLayout.
CurveAndSpiralSettings | Gets the default setting of curve and spiral for the command CreateAlignmentLayout.
CurveTessellationOption | Gets the default setting of curve tessellation option for the command CreateAlignmentLayout.
RegressionGraphOption | Gets the default setting of tegression graph option for the command CreateAlignmentLayout.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class > SettingsCmdCreateAlignmentLayout Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties Public Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties
Public Properties
Public Property | Description
AlignmentType | Specifies whether to erase existing entities for creating alignment entities.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties Public Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties
Public Properties
Public Property | Description
CurveRadiusForSCSGroup | Specifies a radius value for the SCS group.
SpiralInAValue | Specifies the length for the Spiral In.
SpiralInLength | Specifies the length for the Spiral In.
SpiralOutAValue | Specifies the A value for the Spiral Out.
SpiralOutLength | Specifies the length for the Spiral Out.
SpiralType | Specifies the spiral type.
UseCurve | Specifies whether your design includes a curve.
UseSpiralIn | Specifies whether your design includes a spiral either before a curve or before a Spiral Out.
UseSpiralOut | Specifies whether your design includes a Spiral Out.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties Public Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties
Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies the mid-ordinate tolerance based on a distance across the tessellated curve segments.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties Public Properties
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Properties
Legend
Legend
Property
public


SettingsCmdCreateFeatureLineFromAlign Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Properties
SettingsCmdCreateFeatureLineFromAlign Properties Public Properties
SettingsCmdCreateFeatureLineFromAlign Properties
Public Properties
Public Property | Description
FeatureLineCreation | Gets the default setting of feature line creation for the command CreateFeatureLineFromAlign.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class > SettingsCmdCreateFeatureLineFromAlign Properties
Legend
Legend
Property
public


SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties Public Properties
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties
Public Properties
Public Property | Description
CreateDynamicLink | Gets a PropertyBoolean value specifies whether to create a dynamic link to the alignment. Change this value to False to... more
LayerSetting | Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from... more
MidOrdinateDistance | Gets the default Mid-ordinate distance for tessellating curves into short line segments.
SpiralTessellationFactor | Gets the default Spiral tessellation factor.
UseFeatureLineName | Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.
WeedPoints | Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateFeatureLines Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Properties
SettingsCmdCreateFeatureLines Properties Public Properties
SettingsCmdCreateFeatureLines Properties
Public Properties
Public Property | Description
FeatureLineCreation | Gets the default setting of feature line creation for the command CreateFeatureLines.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class > SettingsCmdCreateFeatureLines Properties
Legend
Legend
Property
public


SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties Public Properties
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties
Public Properties
Public Property | Description
AssignElevations | Gets a PropertyBoolean value specifies whether to open the Assign Elevations dialog box.
ElevationSource | Gets the default elevation source settings.
EraseExistingEntities | Gets a PropertyBoolean value specifies whether creation commands erase selected objects when they are converted to feature lines. By default... more
IncludeMidElevationBreaks | Gets a PropertyBoolean value specifies whether to include intermediate elevation breaks when assigning elevations from a surface or grading group.... more
LayerSetting | Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is from... more
UseFeatureLineName | Gets a PropertyBoolean value specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Gets a PropertyBoolean value specifies whether a style is applied to feature lines when created.
WeedPoints | Gets a PropertyBoolean value specifies whether to open the Weed Vertices dialog box so you can weed the objects when... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateGrading Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Properties
SettingsCmdCreateGrading Properties Public Properties
SettingsCmdCreateGrading Properties
Public Properties
Public Property | Description
GradingCreation | Gets the default setting of grading creation for the command CreateGrading.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class > SettingsCmdCreateGrading Properties
Legend
Legend
Property
public


SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading::SettingsCmdGradingCreation Class > SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties
SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties Public Properties
SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties
Public Properties
Public Property | Description
TransitionRegionLength | Specifies the default length for transition regions.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading::SettingsCmdGradingCreation Class > SettingsCmdCreateGrading::SettingsCmdGradingCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateGradingGroup Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Properties
SettingsCmdCreateGradingGroup Properties Public Properties
SettingsCmdCreateGradingGroup Properties
Public Properties
Public Property | Description
GradingGroupCreation | Gets the default setting of grading group creation for the command CreateGradingGroup.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class > SettingsCmdCreateGradingGroup Properties
Legend
Legend
Property
public


SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties Public Properties
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties
Public Properties
Public Property | Description
GradingSurfaceCreation | Specifies whether a grading group generates an automatic surface by default.
SurfaceConeTessellationAngle | Specifies the default maximum angle between supplemental projection lines on exterior corners.
SurfaceStyle | Specifies the default style for the grading group.
SurfaceTessellationIncrement | Specifies the default maximum distance along the feature line to add supplemental surface triangle lines for better definition of the... more
UseGroupName | Specifies whether the automatic surface is named after the grading group by default.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateMassHaulDiagram Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Properties
SettingsCmdCreateMassHaulDiagram Properties Public Properties
SettingsCmdCreateMassHaulDiagram Properties
Public Properties
Public Property | Description
MassHaulCreation | Specifies the Mass haul data settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class > SettingsCmdCreateMassHaulDiagram Properties
Legend
Legend
Property
public


SettingsCmdCreateMultipleProfileView Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Properties
SettingsCmdCreateMultipleProfileView Properties Public Properties
SettingsCmdCreateMultipleProfileView Properties
Public Properties
Public Property | Description
MultipleProfileViewCreation | Gets the default setting of multiple profile view creation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class > SettingsCmdCreateMultipleProfileView Properties
Legend
Legend
Property
public


SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties Public Properties
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties
Public Properties
Public Property | Description
ColumnSpacing | Gets
DefaultProfileViewHeight | Gets
DefaultProfileViewLength | Gets the default length for profile views.
PlotPattern | Gets
ProfileViewDatumBy | Gets
ProfileViewsInRowOrColumn | Gets
RowSpacing | Gets
StartCorner | Gets


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateMultipleSectionView Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Properties
SettingsCmdCreateMultipleSectionView Properties Public Properties
SettingsCmdCreateMultipleSectionView Properties
Public Properties
Public Property | Description
MultipleSectionViewCreation | Specifies the multiple section view settings.
TableCreation | Specifies the table creation settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class > SettingsCmdCreateMultipleSectionView Properties
Legend
Legend
Property
public


SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties Public Properties
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties
Public Properties
Public Property | Description
SectionViewHeight | Specifies whether a station range is set for the creation of multiple section views.
SpecifyMultipleSectionViewStationRange | Specifies whether a station range is set for the creation of multiple section views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties Public Properties
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaterialVolumeTableStyle | Specifies the styles for a material table.
MaximumNumberOfRows | Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum,... more
MaximumTablesPerStack | Specifies the maximum number of sections to include in each stack.
SectionViewAnchor | Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableAnchor | Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
TableLayout | Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
TableSpacing | Specifies the spacing between tables.
TileDirection | Specifies the direction in which the table tiles (across or down).
TotalVolumeTableStyle | Specifies the style for a total volume table.
XOffset | Specifies the horizontal offset of the table.
YOffset | Specifies the vertical offset of the table.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateOffsetAlignment Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Properties
SettingsCmdCreateOffsetAlignment Properties Public Properties
SettingsCmdCreateOffsetAlignment Properties
Public Properties
Public Property | Description
OffsetAlignmentOptions | Specifies the offset alignment options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class > SettingsCmdCreateOffsetAlignment Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelByLayout Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Properties
SettingsCmdCreateParcelByLayout Properties Public Properties
SettingsCmdCreateParcelByLayout Properties
Public Properties
Public Property | Description
AutomaticLayout | Gets the default setting of automatic layout for the command CreateParcelByLayout.
ConvertFromEntities | Gets the default setting of converting from entities for the command CreateParcelByLayout.
ParcelSizing | Gets the default setting of parcel sizing for the command CreateParcelByLayout.
PreviewGraphics | Gets the default setting of preview graphics for the command CreateParcelByLayout.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class > SettingsCmdCreateParcelByLayout Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties Public Properties
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties
Public Properties
Public Property | Description
AutomaticMode | Gets a PropertyBoolean value specifies whether the automatic mode is set for parcel layout.
RemainderDistributionType | Gets the PropertyEnum value spctifies remainder from a new parcel is distributed.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties Public Properties
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties
Public Properties
Public Property | Description
AutoAddSegmentLabel | Gets a PropertyBoolean value specifies whether segment labels are automatically added to a new parcel.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties Public Properties
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties
Public Properties
Public Property | Description
FrontageOffset | Gets the default frontage offset. Must be greater than zero.
MaximumDepth | Gets the default maximum depth. Must be greater than or equal to zero.
MinimumArea | Gets the default minimum area for a new parcel.
MinimumDepth | Gets the default minimum depth.
MinimumFrontage | Gets the default minimum frontage for a new parcel.
MinimumWidth | Gets the default minimum width.
SelectionMethod | Gets the default parcel selection method.
SolutionPreference | Gets the default multiple solution preference.
UseMaximumDepth | Gets a PropertyBoolean value specifies whether using maximum depth.
UseMinimumFrontageAtOffset | Gets a PropertyBoolean value specifies whether using minimum frontage at offset.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties Public Properties
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties
Public Properties
Public Property | Description
FrontageColor | Gets the default color for the frontage preview.
FrontageOffsetColor | Gets the default color for the frontage offset preview.
MinimumDepthColor | Gets the default color for the minimum depth preview.
MinimumFrontageColor | Gets the default color for the minimum frontage preview.
MinimumWidthColor | Gets the default color for the minimum width preview.
NewParcelColor | Gets the default color for the new parcel preview.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelFromObjects Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Properties
SettingsCmdCreateParcelFromObjects Properties Public Properties
SettingsCmdCreateParcelFromObjects Properties
Public Properties
Public Property | Description
ConvertFromEntities | Gets the default setting of Convert From Entities.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class > SettingsCmdCreateParcelFromObjects Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties Public Properties
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties
Public Properties
Public Property | Description
AutoAddSegmentLabels | Gets whether existing entities are erased when a new parcel is created.
EraseAllExistingEntities | Gets whether existing entities are erased when a new parcel is created.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelROW Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Properties
SettingsCmdCreateParcelROW Properties Public Properties
SettingsCmdCreateParcelROW Properties
Public Properties
Public Property | Description
CleanupAtAlignmentIntersections | Gets the default setting of Cleanup at Alignment Intersections for the command AeccCreateParcelROW.
CleanupAtParcelBoundaries | Gets the default setting of Cleanup at Parcel Boundaries for the command AeccCreateParcelROW.
CreateParcelRightOfWay | Gets the default setting of Create Parcel Right Of Way for the command AeccCreateParcelROW.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class > SettingsCmdCreateParcelROW Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties Public Properties
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties
Public Properties
Public Property | Description
CleanupMethodFillet | Gets whether the cleanup method is Fillet, Chamfer, or None.
FilletRadiusAtAlignmentIntersections | Gets the width of the radius of the fillet at alignment intersections.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties Public Properties
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties
Public Properties
Public Property | Description
CleanupMethodFillet | Gets whether the cleanup method is Fillet, Chamfer, or None.
FilletRadiusAtParcelBoundaryIntersections | Gets the width of the radius of the fillet at parcel boundary intersections.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Properties
Legend
Legend
Property
public


SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties Public Properties
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties
Public Properties
Public Property | Description
OffsetFromAlignment | Gets the offset from the alignment for the new right of way.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Properties
Legend
Legend
Property
public


SettingsCmdCreatePoints Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Properties
SettingsCmdCreatePoints Properties Public Properties
SettingsCmdCreatePoints Properties
Public Properties
Public Property | Description
Layer | Gets the default setting of Layer.
PointsCreation | Gets the settings to establish default information for creating points.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class > SettingsCmdCreatePoints Properties
Legend
Legend
Property
public


SettingsCmdCreatePoints::SettingsCmdLayer Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdLayer Class > SettingsCmdCreatePoints::SettingsCmdLayer Properties
SettingsCmdCreatePoints::SettingsCmdLayer Properties Public Properties
SettingsCmdCreatePoints::SettingsCmdLayer Properties
Public Properties
Public Property | Description
Layer | Gets or sets a default layer


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdLayer Class > SettingsCmdCreatePoints::SettingsCmdLayer Properties
Legend
Legend
Property
public


SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties
SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties Public Properties
SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties
Public Properties
Public Property | Description
DefaultDescription | Gets or sets the description that is automatically assigned by the point creation commands when Prompt For Descriptions is set... more
DefaultElevation | Gets or sets the elevation automatically assigned by the point creation commands when the Prompt For Elevations setting is set... more
DisableDescriptionKeys | Gets or sets whether description key matching occurs during point creation.
EchoCoordinatesToCommandLine | Gets or sets whether description key matching occurs during point creation.
GeographicCoordinates | Gets or sets the order in which geographic coordinates are displayed on the command line during point creation.
GridCoordinates | Gets or sets the order in which grid coordinates are displayed on the command line during point creation.
LocalCoordinates | Gets or sets the order and format used to display local coordinates on the command line during point creation.
MatchOnDescriptionParameters | Gets or sets whether parameters are used in description key matching to rotate and scale the point symbol.
PromptForDescriptions | Gets or sets how descriptions are assigned during point creation.
PromptForElevations | Gets or sets how elevations are assigned point creation.
PromptForPointNames | Gets or sets how point names are entered during point creation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class > SettingsCmdCreatePoints::SettingsCmdPointsCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateProfileFromSurface Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Properties
SettingsCmdCreateProfileFromSurface Properties Public Properties
SettingsCmdCreateProfileFromSurface Properties
Public Properties
Public Property | Description
Geometry | Gets the default setting of Geometry.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class > SettingsCmdCreateProfileFromSurface Properties
Legend
Legend
Property
public


SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties Public Properties
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties
Public Properties
Public Property | Description
ProfileSampleOffsetsCommandSetting | Specifies whether to create offset profiles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Properties
Legend
Legend
Property
public


SettingsCmdCreateProfileLayout Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Properties
SettingsCmdCreateProfileLayout Properties Public Properties
SettingsCmdCreateProfileLayout Properties
Public Properties
Public Property | Description
CurveTessellationOption | Gets the default setting of curve tessellation option.
RegressionGraphOption | Gets the default setting of regression graph option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class > SettingsCmdCreateProfileLayout Properties
Legend
Legend
Property
public


SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties Public Properties
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties
Public Properties
Public Property | Description
MidOrdinateTolerance | Gets the mid-ordinate tolerance based on a distance across the tessellated curve segments.
TessellateCurve | Gets whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Properties
Legend
Legend
Property
public


SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties Public Properties
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Gets whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Properties
Legend
Legend
Property
public


SettingsCmdCreateQuickProfile Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Properties
SettingsCmdCreateQuickProfile Properties Public Properties
SettingsCmdCreateQuickProfile Properties
Public Properties
Public Property | Description
QuickProfile | Gets the default setting of quick profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class > SettingsCmdCreateQuickProfile Properties
Legend
Legend
Property
public


SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties Public Properties
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties
Public Properties
Public Property | Description
Draw3DEntityProfile | Gets whether to include elevation data for the selected 3D entity in the quick profile.
SelectAllSurfaces | Gets whether to generate profiles of all surfaces in the drawing file in the quick profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Properties
Legend
Legend
Property
public


SettingsCmdCreateSampleLines Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Properties
SettingsCmdCreateSampleLines Properties Public Properties
SettingsCmdCreateSampleLines Properties
Public Properties
Public Property | Description
AdditionalSampleControls | Gets the default setting of Additional Sample Controls.
Miscellaneous | Gets the default setting of Miscellaneous.
SamplingIncrements | Gets the default setting of Sampling Increments.
SwathWidths | Gets the default setting of swath widths.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class > SettingsCmdCreateSampleLines Properties
Legend
Legend
Property
public


SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties Public Properties
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties
Public Properties
Public Property | Description
AtHorizontalGeometryPoints | Gets whether additional sample lines are created at horizontal geometry points.
AtRangeEnd | Gets whether a sample line is created at the beginning of the specified range.
AtRangeStart | Gets whether a sample line is created at the beginning of the specified range.
AtSuperelevationCriticalStations | Gets whether additional sample lines are created at superelevation critical stations within the current range.
EndRangeAtAlignmentEnd | Gets whether the sampling range ends at the end of the alignment.
StartRangeAtAlignmentStart | Gets whether the sampling range starts at the beginning of the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Properties
Legend
Legend
Property
public


SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties Public Properties
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties
Public Properties
Public Property | Description
LockTostation | Gets whether the sample lines update when the alignment geometry and properties change.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Properties
Legend
Legend
Property
public


SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties Public Properties
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties
Public Properties
Public Property | Description
IncrementAlongCurves | Gets the sample increment distance along curves.
IncrementAlongSpirals | Gets the sample increment distance along spirals.
IncrementAlongTangents | Gets the sample increment distance along tangents.
UseSamplingIncrements | Gets whether sample lines are created at incremental stations along the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Properties
Legend
Legend
Property
public


SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties Public Properties
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties
Public Properties
Public Property | Description
LeftSwathWidth | Gets the swath width to the left of the alignment.
RightSwathWidth | Gets the swath width to the right of the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Properties
Legend
Legend
Property
public


SettingsCmdCreateSectionView Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Properties
SettingsCmdCreateSectionView Properties Public Properties
SettingsCmdCreateSectionView Properties
Public Properties
Public Property | Description
TableCreation | Specifies the table creation settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class > SettingsCmdCreateSectionView Properties
Legend
Legend
Property
public


SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties
SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties Public Properties
SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaterialVolumeTableStyle | Specifies the styles for a material table.
MaximumNumberOfRows | Specifies the maximum number of rows to include per section. If the number of data rows exceeds the specified maximum,... more
MaximumTablesPerStack | Specifies the maximum number of sections to include in each stack.
SectionViewAnchor | Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableAnchor | Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
TableLayout | Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
TableSpacing | Specifies the spacing between tables.
TileDirection | Specifies the direction in which the table tiles (across or down).
TotalVolumeTableStyle | Specifies the style for a total volume table.
XOffset | Specifies the horizontal offset of the table.
YOffset | Specifies the vertical offset of the table.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class > SettingsCmdCreateSectionView::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateSheets Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Properties
SettingsCmdCreateSheets Properties Public Properties
SettingsCmdCreateSheets Properties
Public Properties
Public Property | Description
SheetCreation | Gets the setting of sheet creation for the command CreateSheets.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class > SettingsCmdCreateSheets Properties
Legend
Legend
Property
public


SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties
SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties Public Properties
SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties
Public Properties
Public Property | Description
AddNetworkLabels | Specify whether to copy the pipe network labels to destination drawings.
AddToVault | Specify whether to add newly created files to Vault.
AlignNorthArrow | Specify whether to cause the chosen North arrow block to be aligned to North.
AlignProfileAndPlanViewType | Specify how to align profile and plan view.
ExistingSheetSetName | Specify the existing sheet set file where to add created sheet.
NorthArrowBlockName | Specify the block that will be rotated as the North arrow block.
NumberOfLayoutsPerDrawing | Specify the number of layouts to be created in each drawing.
SheetCreateMethod | Specify the sheet create method.
UseExistingSheetSet | Specify whether to use an existing one or create new sheet set.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class > SettingsCmdCreateSheets::SettingsCmdSheetCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateSite Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Properties
SettingsCmdCreateSite Properties Public Properties
SettingsCmdCreateSite Properties
Public Properties
Public Property | Description
Alignment | Gets the default setting of alignment for the command CreateSite.
FeatureLine | Gets the default setting of freature line for the command CreateSite.
Parcel | Gets the default setting of parcel for the command CreateSite.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class > SettingsCmdCreateSite Properties
Legend
Legend
Property
public


SettingsCmdCreateSite::SettingsCmdAlignment Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Properties
SettingsCmdCreateSite::SettingsCmdAlignment Properties Public Properties
SettingsCmdCreateSite::SettingsCmdAlignment Properties
Public Properties
Public Property | Description
AlignmentCurveNextAutomaticTagCounter | Gets the increment by which the next new alignment curve tag is automatically numbered.
AlignmentCurveNextManualTagCounter | Gets the increment by which the next new alignment curve tag is manually numbered.
AlignmentLineNextAutomaticTagCounter | Gets the increment by which the next new alignment line tag is automatically numbered.
AlignmentLineNextManualTagCounter | Gets the increment by which the next new alignment line tag is manually numbered.
AlignmentSpiralNextAutomaticTagCounter | Gets the increment by which the next new alignment spiral tag is automatically numbered.
AlignmentSpiralNextManualTagCounter | Gets the increment by which the next new alignment spiral tag is manually numbered.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class > SettingsCmdCreateSite::SettingsCmdAlignment Properties
Legend
Legend
Property
public


SettingsCmdCreateSite::SettingsCmdFeatureLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdFeatureLine Class > SettingsCmdCreateSite::SettingsCmdFeatureLine Properties
SettingsCmdCreateSite::SettingsCmdFeatureLine Properties Public Properties
SettingsCmdCreateSite::SettingsCmdFeatureLine Properties
Public Properties
Public Property | Description
FeatureLineStyle | Gets the default feature line style priority.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdFeatureLine Class > SettingsCmdCreateSite::SettingsCmdFeatureLine Properties
Legend
Legend
Property
public


SettingsCmdCreateSite::SettingsCmdParcel Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Properties
SettingsCmdCreateSite::SettingsCmdParcel Properties Public Properties
SettingsCmdCreateSite::SettingsCmdParcel Properties
Public Properties
Public Property | Description
ParcelCurveNextAutomaticTagCounter | Gets the increment by which the next new parcel line tag is manually numbered.
ParcelCurveNextManualTagCounter | Gets the increment by which the next new parcel curve tag is manually numbered.
ParcelLineNextAutomaticTagCounter | Gets the increment by which the next new parcel line tag is automatically numbered.
ParcelLineNextManualTagCounter | Gets the increment by which the next new parcel line tag is manually numbered.
ParcelNextAutomaticAreaCounter | Gets the increment by which the next new parcel area is automatically numbered.
ParcelNextManualAreaCounter | Gets the increment by which the next new parcel area is manually numbered.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class > SettingsCmdCreateSite::SettingsCmdParcel Properties
Legend
Legend
Property
public


SettingsCmdCreateSurface Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Properties
SettingsCmdCreateSurface Properties Public Properties
SettingsCmdCreateSurface Properties
Public Properties
Public Property | Description
BuildOptions | Gets the defaults assigned when creating surfaces.
NameFormat | Gets the default surface name format settings.
SurfaceCreation | Gets the defaults assigned when creating surfaces.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class > SettingsCmdCreateSurface Properties
Legend
Legend
Property
public


SettingsCmdCreateSurface::SettingCmdBuildOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties
SettingsCmdCreateSurface::SettingCmdBuildOptions Properties Public Properties
SettingsCmdCreateSurface::SettingCmdBuildOptions Properties
Public Properties
Public Property | Description
AllowCrossingBreaklines | Gets whether breaklines can cross each other.
ConvertProximityBreaklinesToStandard | Gets whether proximity breaklines are converted to standard breaklines when the surface is built.
CopyDeletedDependentObjects | Gets whether a drawing object is copied to the surface definition item if the object is deleted.
ElevationGreaterThan | Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.
ElevationLessThan | Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.
ElevationToUse | Gets the elevation to use for the crossing breaklines.
ExcludeElevationsGreaterThan | Gets whether an elevation greater than a certain value should be excluded when the surface is built.
ExcludeElevationsLessThan | Gets whether an elevation less than a certain value should be excluded when the surface is built.
MaximumTriangleLength | Gets the triangle length to use when the Use Maximum Triangle Length property is set to Yes.
UseMaximumTriangleLength | Gets whether the surface triangles that exceed the length specified by the Maximum Triangle Length property are removed from the... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class > SettingsCmdCreateSurface::SettingCmdBuildOptions Properties
Legend
Legend
Property
public


SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties Public Properties
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties
Public Properties
Public Property | Description
CutFactor | Gets the cut factor.
DefaultType | Gets the default surface type that is used when creating a surface.
FillFactor | Gets the fill factor.
GridSurfaceOrientation | Gets the default orientation for a grid.
GridSurfaceXSpacing | Gets the default value for a grid surfaces X spacing.
GridSurfaceYSpacing | Gets the default value for a grid surfaces Y spacing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateSurface::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingsNameFormat Class > SettingsCmdCreateSurface::SettingsNameFormat Properties
SettingsCmdCreateSurface::SettingsNameFormat Properties Public Properties
SettingsCmdCreateSurface::SettingsNameFormat Properties
Public Properties
Public Property | Description
Surface | Gets the default maintain edges setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingsNameFormat Class > SettingsCmdCreateSurface::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsCmdCreateSurfaceGridFromDEM Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Properties
SettingsCmdCreateSurfaceGridFromDEM Properties Public Properties
SettingsCmdCreateSurfaceGridFromDEM Properties
Public Properties
Public Property | Description
BuildOptions | Gets the build options assigned when creating surfaces.
ImportOptions | Gets the defaults assigned when creating surfaces.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class > SettingsCmdCreateSurfaceGridFromDEM Properties
Legend
Legend
Property
public


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties Public Properties
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties
Public Properties
Public Property | Description
CopyDeletedDependentObjects | Gets whether a drawing object is copied to the surface definition item if the object is deleted.
ElevationGreaterThan | Gets the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.
ElevationLessThan | Gets the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.
ExcludeElevationsGreaterThan | Gets whether an elevation greater than a certain value should be excluded when the surface is built.
ExcludeElevationsLessThan | Gets whether an elevation less than a certain value should be excluded when the surface is built.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Properties
Legend
Legend
Property
public


SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties Public Properties
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties
Public Properties
Public Property | Description
NullElevation | Gets null elevation.
UseCustomNullElevation | Gets whether use custom null elevation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Properties
Legend
Legend
Property
public


SettingsCmdCreateSurfaceReference Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Properties
SettingsCmdCreateSurfaceReference Properties Public Properties
SettingsCmdCreateSurfaceReference Properties
Public Properties
Public Property | Description
NameFormat | Gets the default surface name format settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class > SettingsCmdCreateSurfaceReference Properties
Legend
Legend
Property
public


SettingsCmdCreateSurfaceWaterdrop Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Properties
SettingsCmdCreateSurfaceWaterdrop Properties Public Properties
SettingsCmdCreateSurfaceWaterdrop Properties
Public Properties
Public Property | Description
WaterdropMarker | Gets the default water drop marker options for surfaces.
WaterdropPath | Gets the default water drop path options for surfaces.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class > SettingsCmdCreateSurfaceWaterdrop Properties
Legend
Legend
Property
public


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties Public Properties
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties
Public Properties
Public Property | Description
PlaceMarkerAtStartPoint | Gets whether to draw a marker at the start point of the water drop path.
StartPointMarkerStyle | Gets the default start point marker style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Properties
Legend
Legend
Property
public


SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties Public Properties
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties
Public Properties
Public Property | Description
PathLayer | Gets the default layer on which to draw the water drop path.
PathObjectType | Gets the default type of AutoCAD object to use for the water drop path.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Properties
Legend
Legend
Property
public


SettingsCmdCreateViewFrames Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Properties
SettingsCmdCreateViewFrames Properties Public Properties
SettingsCmdCreateViewFrames Properties
Public Properties
Public Property | Description
ViewFrameCreation | Gets the setting of view frame creation for the command CreateViewFrames.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class > SettingsCmdCreateViewFrames Properties
Legend
Legend
Property
public


SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties Public Properties
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties
Public Properties
Public Property | Description
AlignmentStationRangeSpecifiedByUser | Specify whether to create view frames for a user specified range or for the entire alignment.
EnableFirstViewFrameOffset | Specify whether to enable first view frame offset.
FirstViewFrameOffsetDistance | Specify the distance of the first view frame offset.
InsertMatchLines | Specify whether to enable match lines to be inserted.
MatchLineRepositioning | Specify whether to enalbe extra margin for match line movement after placement.
MatchLineRepositioningValue | Specify the distance for additional margin of match line movement.
MatchLineSnapStation | Specify whether to enable match lines to snap down to a rounded station value.
MatchLineSnapStationValue | Specify the rounding value when match line snap to station.
SheetType | Specify the type of sheet what will be created.
ViewFrameOrientation | Specify the view frame orientation option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Properties
Legend
Legend
Property
public


SettingsCmdDrawFeatureLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Properties
SettingsCmdDrawFeatureLine Properties Public Properties
SettingsCmdDrawFeatureLine Properties
Public Properties
Public Property | Description
FeatureLineCreation | Gets the default setting of feature line creation for the command DrawFeatureLine.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class > SettingsCmdDrawFeatureLine Properties
Legend
Legend
Property
public


SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties Public Properties
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties
Public Properties
Public Property | Description
LayerSetting | Specifies the default layer setting when feature lines are created.
UseFeatureLineName | Specifies whether a name is applied to feature lines when created.
UseFeatureLineStyle | Specifies whether a style is applied to feature lines when created.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Properties
Legend
Legend
Property
public


SettingsCmdExportParcelAnalysis Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Properties
SettingsCmdExportParcelAnalysis Properties Public Properties
SettingsCmdExportParcelAnalysis Properties
Public Properties
Public Property | Description
ParcelAnalysis | Gets the default setting of parcel analysis.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class > SettingsCmdExportParcelAnalysis Properties
Legend
Legend
Property
public


SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties Public Properties
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties
Public Properties
Public Property | Description
AnalysisType | Gets whether Inverse Analysis or Mapcheck Analysis is used.
EnableMapcheckAcrossChord | Gets whether mapcheck across chord is enabled or disabled.
ProcessCounterClockwise | Gets whether segments will be processed in counter-clockwise or clockwise order.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Properties
Legend
Legend
Property
public


SettingsCmdFitCurveFeature Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Properties
SettingsCmdFitCurveFeature Properties Public Properties
SettingsCmdFitCurveFeature Properties
Public Properties
Public Property | Description
FeatureLineFitCurve | Gets the default setting of featureline fit curve for the command FitCurveFeature.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class > SettingsCmdFitCurveFeature Properties
Legend
Legend
Property
public


SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties Public Properties
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties
Public Properties
Public Property | Description
MinimumNumberOfSegments | Specifies the minimum number of segments that must be identified before creating an arc.
Tolerance | Specifies the maximum distance from a PI along the feature to the arc that is to be inserted.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Properties
Legend
Legend
Property
public


SettingsCmdGradingElevEditor Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Properties
SettingsCmdGradingElevEditor Properties Public Properties
SettingsCmdGradingElevEditor Properties
Public Properties
Public Property | Description
GradingElevationEditor | Gets the default setting of grading elevation editor for the command GradingElevEditor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class > SettingsCmdGradingElevEditor Properties
Legend
Legend
Property
public


SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties Public Properties
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties
Public Properties
Public Property | Description
RaiseLowerIncrement | Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered... more
ShowGradeBreaksOnly | Specifies whether only the feature line start/end points and any grade breaks in between are displayed.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Properties
Legend
Legend
Property
public


SettingsCmdGradingTools Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Properties
SettingsCmdGradingTools Properties Public Properties
SettingsCmdGradingTools Properties
Public Properties
Public Property | Description
GradingLayoutTools | Gets the default setting of grading layout tools for the command GradingTools.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class > SettingsCmdGradingTools Properties
Legend
Legend
Property
public


SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties Public Properties
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties
Public Properties
Public Property | Description
Criteria | Specifies the default Criteria to use when creating grading.
GradingCriteriaSet | Specifies the default Criteria Set to use when creating grading.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Properties
Legend
Legend
Property
public


SettingsCmdGradingVolumeTools Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Properties
SettingsCmdGradingVolumeTools Properties Public Properties
SettingsCmdGradingVolumeTools Properties
Public Properties
Public Property | Description
LimitFeatureSelectionToCurrentGroup | Specifies whether features outside the current grading group can be selected for raising or lowering in the volume calculations.
RaiseLowerElevationIncrement | Specifies the default vertical distance used for each increment when the feature lines of a grading are raised or lowered... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class > SettingsCmdGradingVolumeTools Properties
Legend
Legend
Property
public


SettingsCmdImportGEData Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Properties
SettingsCmdImportGEData Properties Public Properties
SettingsCmdImportGEData Properties
Public Properties
Public Property | Description
GoogleEarthOptions | Gets the default number of rows and columns collected when importing Google Earth information.
SurfaceCreation | Gets the defaults assigned when creating surfaces.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class > SettingsCmdImportGEData Properties
Legend
Legend
Property
public


SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties Public Properties
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties
Public Properties
Public Property | Description
GoogleEarthColumns | Gets the number of columns of data that are collected when importing terrain information from Google Earth.
GoogleEarthRows | Gets the number of rows of data that are collected when importing terrain information from Google Earth.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Properties
Legend
Legend
Property
public


SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties Public Properties
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties
Public Properties
Public Property | Description
NameFormat | Gets the default name format for new surfaces.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Properties
Legend
Legend
Property
public


SettingsCmdImportGESurface Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Properties
SettingsCmdImportGESurface Properties Public Properties
SettingsCmdImportGESurface Properties
Public Properties
Public Property | Description
GoogleEarthOptions | Gets the default number of rows and columns collected when importing Google Earth information.
NameFormat | Gets the default surface name format settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class > SettingsCmdImportGESurface Properties
Legend
Legend
Property
public


SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties Public Properties
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties
Public Properties
Public Property | Description
GoogleEarthColumns | Gets the number of columns of data that are collected when importing terrain information from Google Earth.
GoogleEarthRows | Gets the number of rows of data that are collected when importing terrain information from Google Earth.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Properties
Legend
Legend
Property
public


SettingsCmdImportGESurface::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsNameFormat Class > SettingsCmdImportGESurface::SettingsNameFormat Properties
SettingsCmdImportGESurface::SettingsNameFormat Properties Public Properties
SettingsCmdImportGESurface::SettingsNameFormat Properties
Public Properties
Public Property | Description
Surface | Gets the default maintain edges setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsNameFormat Class > SettingsCmdImportGESurface::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsCmdJoinFeatures Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Properties
SettingsCmdJoinFeatures Properties Public Properties
SettingsCmdJoinFeatures Properties
Public Properties
Public Property | Description
FeatureLineJoin | Gets the default setting of featureline join for the command JoinFeatures.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class > SettingsCmdJoinFeatures Properties
Legend
Legend
Property
public


SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties Public Properties
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties
Public Properties
Public Property | Description
Tolerance | Specifies how close feature lines must be when using the Join command.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Properties
Legend
Legend
Property
public


SettingsCmdSimplifySurface Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Properties
SettingsCmdSimplifySurface Properties Public Properties
SettingsCmdSimplifySurface Properties
Public Properties
Public Property | Description
MaximumChangeInElevation | Gets the maximum allowed difference between the elevation of the original surface and the elevation of the simplified surface.
PercentageOfPointsToRemove | Gets the percent of surface points to remove.
RegionOptions | Gets the default option by which surfaces will be simplified.
SimplifyMethod | Gets the default method by which surfaces will be simplified.
UseMaximumChangeInElevation | Gets whether you will set a default maximum change in elevation.
UsePercentageOfPointsToRemove | Gets whether simplify the image by removing a percent of surface points.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class > SettingsCmdSimplifySurface Properties
Legend
Legend
Property
public


SettingsCmdSuperimposeProfile Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Properties
SettingsCmdSuperimposeProfile Properties Public Properties
SettingsCmdSuperimposeProfile Properties
Public Properties
Public Property | Description
SuperimposeProfile | Gets the default setting of superimpose profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class > SettingsCmdSuperimposeProfile Properties
Legend
Legend
Property
public


SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties Public Properties
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties
Public Properties
Public Property | Description
HorizontalMidOrdinateDistance | Gets the horizontal mid-ordinate distance for tessellated curve segments.
VerticalMidOrdinateDistance | Gets the horizontal mid-ordinate distance for tessellated curve segments.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Properties
Legend
Legend
Property
public


SettingsCmdSurfaceExportToDem Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Properties
SettingsCmdSurfaceExportToDem Properties Public Properties
SettingsCmdSurfaceExportToDem Properties
Public Properties
Public Property | Description
ExportOptions | Gets the defaults assigned when exporting surfaces to a DEM file.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class > SettingsCmdSurfaceExportToDem Properties
Legend
Legend
Property
public


SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties Public Properties
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties
Public Properties
Public Property | Description
GridSpacing | Gets the spacing between grids when exporting to a DEM file.
NullElevation | Gets the default custom null elevation used when exporting to a DEM file.
UseCustomNullElevation | Gets whether a custom null elevation is used when exporting to a DEM file.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Properties
Legend
Legend
Property
public


SettingsCmdWeedFeatures Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Properties
SettingsCmdWeedFeatures Properties Public Properties
SettingsCmdWeedFeatures Properties
Public Properties
Public Property | Description
FeatureLineWeed | Gets the default setting of featureline weed for the command WeedFeatures.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class > SettingsCmdWeedFeatures Properties
Legend
Legend
Property
public


SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties Public Properties
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties
Public Properties
Public Property | Description
AngleFactor | Specifies the default Angle factor.
ApplyAngleFactor | Specifies whether the Angle factor in the Weed Vertices dialog box is selected by default.
ApplyGradeFactor | Specifies whether the Grade factor in the Weed Vertices dialog box is selected by default.
ApplyLengthFactor | Specifies whether the Length factor in the Weed Vertices dialog box is selected by default.
ClosePoint3DDistance | Specifies the 3D distance for weeding. Points that are close together in plan view, with slightly different elevations can be... more
ClosePointRemoval | Specifies whether the 3D Distance factor in the Weed Vertices dialog box is selected by default.
GradeFactor | Specifies the default Grade factor.
LengthFactor | Specifies the default Length factor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Properties
Legend
Legend
Property
public


SettingsGrading Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Properties
SettingsGrading Properties Public Properties
SettingsGrading Properties
Public Properties
Public Property | Description
NameFormat | Gets the default name format for new feature lines and grading groups.
Styles | Property for Grading feature setting ////////////////////////////////////////// Gets the default styles for new slope grading .


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class > SettingsGrading Properties
Legend
Legend
Property
public


SettingsGrading::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class > SettingsGrading::SettingsNameFormat Properties
SettingsGrading::SettingsNameFormat Properties Public Properties
SettingsGrading::SettingsNameFormat Properties
Public Properties
Public Property | Description
FeatureLine | Gets the default name formats for new new feature lines.
GradingGroup | Gets the default name formats for new grading groups.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class > SettingsGrading::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsGrading::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Properties
SettingsGrading::SettingsStyles Properties Public Properties
SettingsGrading::SettingsStyles Properties
Public Properties
Public Property | Description
CutSlopeGrading | Gets the default style to apply when creating cut slope grading.
FeatureLineStyle | Gets the default style to apply when creating feature lines.
FillSlopeGrading | Gets the default style to apply when creating fill slope grading..
GradingStyle | Gets the default style to apply when creating grading.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class > SettingsGrading::SettingsStyles Properties
Legend
Legend
Property
public


SettingsMassHaulView Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Properties
SettingsMassHaulView Properties Public Properties
SettingsMassHaulView Properties
Public Properties
Public Property | Description
MassHaulCreation | Gets the default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings... more
NameFormat | Gets the default name formats for new mass haul lines and new mass haul views.
Styles | Gets the default styles for mass haul components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class > SettingsMassHaulView Properties
Legend
Legend
Property
public


SettingsMassHaulView::SettingsMassHaulCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class > SettingsMassHaulView::SettingsMassHaulCreation Properties
SettingsMassHaulView::SettingsMassHaulCreation Properties Public Properties
SettingsMassHaulView::SettingsMassHaulCreation Properties
Public Properties
Public Property | Description
BorrowPitCapacity | Gets the the capacity of a borrow pit.
DumpSiteCapacity | Gets the the capacity of a dump site.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class > SettingsMassHaulView::SettingsMassHaulCreation Properties
Legend
Legend
Property
public


SettingsMassHaulView::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class > SettingsMassHaulView::SettingsNameFormat Properties
SettingsMassHaulView::SettingsNameFormat Properties Public Properties
SettingsMassHaulView::SettingsNameFormat Properties
Public Properties
Public Property | Description
MassHaulLine | Gets the default name formats for mass haul lines.
MassHaulView | Gets the default name formats for mass haul views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class > SettingsMassHaulView::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsMassHaulView::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class > SettingsMassHaulView::SettingsStyles Properties
SettingsMassHaulView::SettingsStyles Properties Public Properties
SettingsMassHaulView::SettingsStyles Properties
Public Properties
Public Property | Description
MassHaulLine | Gets the default style for mass haul lines.
MassHaulView | Gets the default style for mass haul views.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class > SettingsMassHaulView::SettingsStyles Properties
Legend
Legend
Property
public


SettingsParcel Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Properties
SettingsParcel Properties Public Properties
SettingsParcel Properties
Public Properties
Public Property | Description
Styles | Gets the default styles for creating and labeling parcels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class > SettingsParcel Properties
Legend
Legend
Property
public


SettingsParcel::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Properties
SettingsParcel::SettingsStyles Properties Public Properties
SettingsParcel::SettingsStyles Properties
Public Properties
Public Property | Description
Parcel | Gets the default style for parcel .
ParcelAreaLabelStyle | Gets the default style for parcel area label.
ParcelCurveLabel | Gets the default style for parcel curve label
ParcelLineLabel | Gets the default style for parcel line label


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class > SettingsParcel::SettingsStyles Properties
Legend
Legend
Property
public


SettingsPoint Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Properties
SettingsPoint Properties Public Properties
SettingsPoint Properties
Public Properties
Public Property | Description
NameFormat | Gets the default name format for new points and point groups.
Styles | Gets the default styles assigned to points and points labels.
UpdatePoints | Gets whether you can change local copies of project points without checking them out.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class > SettingsPoint Properties
Legend
Legend
Property
public


SettingsPoint::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class > SettingsPoint::SettingsNameFormat Properties
SettingsPoint::SettingsNameFormat Properties Public Properties
SettingsPoint::SettingsNameFormat Properties
Public Properties
Public Property | Description
Point | Gets the default name formats for new points.
PointGroup | Gets the default name formats for new point groups.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class > SettingsPoint::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsPoint::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class > SettingsPoint::SettingsStyles Properties
SettingsPoint::SettingsStyles Properties Public Properties
SettingsPoint::SettingsStyles Properties
Public Properties
Public Property | Description
Point | Gets the default point style.
PointLabel | Gets the default point label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class > SettingsPoint::SettingsStyles Properties
Legend
Legend
Property
public


SettingsPoint::SettingsUpdatePoints Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsUpdatePoints Class > SettingsPoint::SettingsUpdatePoints Properties
SettingsPoint::SettingsUpdatePoints Properties Public Properties
SettingsPoint::SettingsUpdatePoints Properties
Public Properties
Public Property | Description
AllowCheckedInPointsToBeModified | Gets whether you can change checked in points when you are working offline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsUpdatePoints Class > SettingsPoint::SettingsUpdatePoints Properties
Legend
Legend
Property
public


SettingsProfile Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Properties
SettingsProfile Properties Public Properties
SettingsProfile Properties
Public Properties
Public Property | Description
CriteriaBasedDesignOptions | Gets the defaults for creating a profile using design criteria
DefaultNameFormat | Gets the default name formats for new profiles
ProfilesCreation | Gets default values for vertical curve sub-entities
StyleSettings | Gets the default styles for new profiles


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class > SettingsProfile Properties
Legend
Legend
Property
public


SettingsProfile::SettingsCriteriaBasedDesignOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class > SettingsProfile::SettingsCriteriaBasedDesignOptions Properties
SettingsProfile::SettingsCriteriaBasedDesignOptions Properties Public Properties
SettingsProfile::SettingsCriteriaBasedDesignOptions Properties
Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
UseDesignChecksOption | Gets whether to associate a design check set with the profile
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class > SettingsProfile::SettingsCriteriaBasedDesignOptions Properties
Legend
Legend
Property
public


SettingsProfile::SettingsDefaultNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Properties
SettingsProfile::SettingsDefaultNameFormat Properties Public Properties
SettingsProfile::SettingsDefaultNameFormat Properties
Public Properties
Public Property | Description
OffsetProfileNameTemplate | Gets the default name formats for default name formats for offset profiles
ProfileNameTemplate | Gets the default name formats for default name formats for profiles
SuperimposedProfileNameTemplate | Gets the default name formats for default name formats for superimposed profiles
ThreeDEntityProfileNameTemplate | Gets the default name formats for default name formats for 3D entity profiles


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class > SettingsProfile::SettingsDefaultNameFormat Properties
Legend
Legend
Property
public


SettingsProfile::SettingsProfileCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties
SettingsProfile::SettingsProfileCreation Properties Public Properties
SettingsProfile::SettingsProfileCreation Properties
Public Properties
Public Property | Description
AsymmetricalCrestCurveLength1 | Gets the default length for the first part of the asymmetrical crest curve.
AsymmetricalCrestCurveLength2 | Gets the default length for the second part of the asymmetrical crest curve.
AsymmetricalSagCurveLength1 | Gets the default length for the first part of the asymmetrical sag curve.
AsymmetricalSagCurveLength2 | Gets the default length for the second part of the asymmetrical sag curve.
CircularCrestCurveConstraint | Gets whether curve length or radius is the primary constraint on a circular crest curve.
CircularCrestCurveLength | Gets the default length for a circular crest curve.
CircularCrestCurveRadius | Gets the default radius for a circular crest curve.
CircularSagCurveConstraint | Gets whether curve length or radius is the primary constraint on a circular sag curve.
CircularSagCurveLength | Gets the default length for a circular sag curve.
CircularSagCurveRadius | Gets the default radius for a circular sag curve.
DefaultVerticalCurve | Gets the default vertical curve type for a new profile.
HeadlightAngle | Gets the default headlight angle.
HeadlightHeight | Gets the default headlight height.
ParabolicCrestCurveKValue | Gets the default K-value for a parabolic crest curve.
ParabolicCrestCurveLength | Gets the default length for a parabolic crest curve.
ParabolicCrestVerticalConstraint | Gets whether curve length or K value is the primary constraint on a parabolic crest curve.
ParabolicSagCurveKValue | Gets the default K-value for a parabolic sag curve.
ParabolicSagCurveLength | Gets the default length for a parabolic sag curve.
ParabolicSagVerticalConstraint | Gets whether curve length or K value is the primary constraint on a parabolic sag curve.
PassingEyeHeight | Gets the default passing eye height.
PassingObjectHeight | Gets the default passing object height.
StopEyeHeight | Gets the default stop eye height.
StopObjectHeight | Gets the default stop object height.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class > SettingsProfile::SettingsProfileCreation Properties
Legend
Legend
Property
public


SettingsProfile::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class > SettingsProfile::SettingsStyles Properties
SettingsProfile::SettingsStyles Properties Public Properties
SettingsProfile::SettingsStyles Properties
Public Properties
Public Property | Description
ProfileLabelSet | Gets the default profile label set.
ProfileStyle | Gets the default profile style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class > SettingsProfile::SettingsStyles Properties
Legend
Legend
Property
public


SettingsProfileView Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Properties
SettingsProfileView Properties Public Properties
SettingsProfileView Properties
Public Properties
Public Property | Description
Creation | Gets style settings for profile view.
NameFormat | Gets style settings for profile view.
ProjectionLabelPlacement | Gets style settings for profile view.
SplitOptions | Gets style settings for profile view.
StackedOptions | Gets style settings for profile view.
Styles | Gets style settings for profile view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class > SettingsProfileView Properties
Legend
Legend
Property
public


SettingsProfileView::SettingsCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class > SettingsProfileView::SettingsCreation Properties
SettingsProfileView::SettingsCreation Properties Public Properties
SettingsProfileView::SettingsCreation Properties
Public Properties
Public Property | Description
PipeNetworkParts | Settings for PipeNetworkParts.
SpecifyProfileElevationRange | Settings for SpecifyProfileElevationRange.
SpecifyProfileStationRange | Settings for SpecifyProfileElevationRange.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class > SettingsProfileView::SettingsCreation Properties
Legend
Legend
Property
public


SettingsProfileView::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Properties
SettingsProfileView::SettingsNameFormat Properties Public Properties
SettingsProfileView::SettingsNameFormat Properties
Public Properties
Public Property | Description
CutArea | Settings for CutArea name template.
FillArea | Settings for FillArea name template.
MultipleBoundaryArea | Settings for MultipleBoundaryArea name template.
ProfileView | Settings for ProfileView name template.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class > SettingsProfileView::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsProfileView::SettingsProjectionLabelPlacement Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class > SettingsProfileView::SettingsProjectionLabelPlacement Properties
SettingsProfileView::SettingsProjectionLabelPlacement Properties Public Properties
SettingsProfileView::SettingsProjectionLabelPlacement Properties
Public Properties
Public Property | Description
DimensionAnchorElevationValueForProjections | Settings for DimensionAnchorElevationValueforProjections.
DimensionAnchorOption | Settings for DimensionAnchorOption.
DimensionAnchorPlotHeightValueForProjections | Settings for DimensionAnchorPlotHeightValueforProjections.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class > SettingsProfileView::SettingsProjectionLabelPlacement Properties
Legend
Legend
Property
public


SettingsProfileView::SettingsSplitOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class > SettingsProfileView::SettingsSplitOptions Properties
SettingsProfileView::SettingsSplitOptions Properties Public Properties
SettingsProfileView::SettingsSplitOptions Properties
Public Properties
Public Property | Description
SplitDatumOption | Settings for SplitDatumOption.
SplitProfileViews | Settings for SplitProfileViews.
SplitStationOption | Settings for SplitStationOption.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class > SettingsProfileView::SettingsSplitOptions Properties
Legend
Legend
Property
public


SettingsProfileView::SettingsStackedOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class > SettingsProfileView::SettingsStackedOptions Properties
SettingsProfileView::SettingsStackedOptions Properties Public Properties
SettingsProfileView::SettingsStackedOptions Properties
Public Properties
Public Property | Description
GapBetweenViews | Settings for GapBetweenViews.
NumberOfStackedViews | Settings for NumberofStackedViews.
StackedViews | Settings for StackedViews.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class > SettingsProfileView::SettingsStackedOptions Properties
Legend
Legend
Property
public


SettingsProfileView::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties
SettingsProfileView::SettingsStyles Properties Public Properties
SettingsProfileView::SettingsStyles Properties
Public Properties
Public Property | Description
BottomStackViewStyle | Settings for ProfileView BottomStackViewStyle.
CutAreaShapeStyle | Settings for ProfileView CutAreaShapeStyle.
FillAreaShapeStyle | Settings for ProfileView FillAreaShapeStyle.
FirstSplitViewStyle | Settings for ProfileView FirstSliptViewStyle.
IntermediateSplitViewStyle | Settings for ProfileView IntermediateSplitViewStyle.
LastSplitViewStyle | Settings for ProfileView LastSplitViewStyle.
MarkerStyle | Settings for ProfileView MarkerStyle.
MiddleStackViewStyle | Settings for ProfileView MiddleStackViewStyle.
MultipleBoundaryAreaShapeStyle | Settings for ProfileView MultipleBoundaryAreaShapeStyle.
ProfileDepthLabelStyle | Settings for ProfileView ProfileDepthLabelStyle.
ProfileLabelSet | Settings for ProfileView ProfileLabelSet.
ProfileLabelStyle | Settings for ProfileView ProfileLabelStyle.
ProfileProjectionLabelStyle | Settings for ProfileView ProfileProjectionLabelStyle.
ProfileStationAndElevationLabelStyle | Settings for ProfileView ProfileStationandElevationLabelStyle.
ProfileViewBandStyle | Settings for ProfileView ProfileViewBandStyle.
ProfileViewStyle | Settings for ProfileView ProfileViewStyle.
ProjectionStyle | Settings for ProfileView ProjectionStyle.
TopStackViewStyle | Settings for ProfileView TopStackViewStyle.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class > SettingsProfileView::SettingsStyles Properties
Legend
Legend
Property
public


SettingsSampleLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Properties
SettingsSampleLine Properties Public Properties
SettingsSampleLine Properties
Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for sample line.
Styles | Settings to establish the default styles assigned to sample line.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class > SettingsSampleLine Properties
Legend
Legend
Property
public


SettingsSampleLine::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class > SettingsSampleLine::SettingsNameFormat Properties
SettingsSampleLine::SettingsNameFormat Properties Public Properties
SettingsSampleLine::SettingsNameFormat Properties
Public Properties
Public Property | Description
SampleLine | Settings SampleLine default name format.
SampleLineGroup | Settings SampleLine group default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class > SettingsSampleLine::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsSampleLine::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class > SettingsSampleLine::SettingsStyles Properties
SettingsSampleLine::SettingsStyles Properties Public Properties
SettingsSampleLine::SettingsStyles Properties
Public Properties
Public Property | Description
SampleLine | Settings of SampleLine style.
SampleLineLabel | Settings of SampleLine label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class > SettingsSampleLine::SettingsStyles Properties
Legend
Legend
Property
public


SettingsSection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Properties
SettingsSection Properties Public Properties
SettingsSection Properties
Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for sample line.
Styles | Settings to establish the default styles assigned to sample line.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class > SettingsSection Properties
Legend
Legend
Property
public


SettingsSection::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsNameFormat Class > SettingsSection::SettingsNameFormat Properties
SettingsSection::SettingsNameFormat Properties Public Properties
SettingsSection::SettingsNameFormat Properties
Public Properties
Public Property | Description
Section | Settings Section default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsNameFormat Class > SettingsSection::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsSection::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsStyles Class > SettingsSection::SettingsStyles Properties
SettingsSection::SettingsStyles Properties Public Properties
SettingsSection::SettingsStyles Properties
Public Properties
Public Property | Description
Section | Settings of Section style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsStyles Class > SettingsSection::SettingsStyles Properties
Legend
Legend
Property
public


SettingsSectionView Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Properties
SettingsSectionView Properties Public Properties
SettingsSectionView Properties
Public Properties
Public Property | Description
NameFormat | Gets the template for naming the section view.
ProjectionLabelPlacement | settings to specify the default name formats for sample line.
SectionViewCreation | Gets the settings to establish the defaults assigned for section view creation.
Styles | Gets the default styles assigned to section view components


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class > SettingsSectionView Properties
Legend
Legend
Property
public


SettingsSectionView::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsNameFormat Class > SettingsSectionView::SettingsNameFormat Properties
SettingsSectionView::SettingsNameFormat Properties Public Properties
SettingsSectionView::SettingsNameFormat Properties
Public Properties
Public Property | Description
SectionView | Settings SectionView default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsNameFormat Class > SettingsSectionView::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsSectionView::SettingsProjectionLabelPlacement Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class > SettingsSectionView::SettingsProjectionLabelPlacement Properties
SettingsSectionView::SettingsProjectionLabelPlacement Properties Public Properties
SettingsSectionView::SettingsProjectionLabelPlacement Properties
Public Properties
Public Property | Description
DimensionAnchorElevationValueForProjections | Specifies the default value for anchor elevation. Enter a value or click and select an elevation in the drawing area.... more
DimensionAnchorOption | Specifies whether the default anchor option will be Fixed, Above, Below, Graph View Top, or Graph View Bottom.
DimensionAnchorPlotHeightValueForProjections | Specifies the default value for anchor plot height. Enter a value or retain the existing default value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class > SettingsSectionView::SettingsProjectionLabelPlacement Properties
Legend
Legend
Property
public


SettingsSectionView::SettingsSectionViewCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class > SettingsSectionView::SettingsSectionViewCreation Properties
SettingsSectionView::SettingsSectionViewCreation Properties Public Properties
SettingsSectionView::SettingsSectionViewCreation Properties
Public Properties
Public Property | Description
SectionGroupElevationRange | Specifies how the elevation range of the section group is set.
SpecifySectionViewHeight | Specifies whether the default section view height is set for the creation of a section view.
SpecifySectionViewOffsetRange | Specifies whether an offset range is set for the creation of a section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class > SettingsSectionView::SettingsSectionViewCreation Properties
Legend
Legend
Property
public


SettingsSectionView::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties
SettingsSectionView::SettingsStyles Properties Public Properties
SettingsSectionView::SettingsStyles Properties
Public Properties
Public Property | Description
GroupPlot | Settings of GroupPlot style.
Marker | Specifies the default marker style for section view points for offset elevation and depth grade labels.
Projection | Settings of Projection style.
SectionLabelSet | Settings of SectionLabelSet style.
SectionProjectionLabel | Settings of SectionProjectionLabel style.
SectionView | Settings of SectionView style.
SectionViewBandSet | Settings of SectionViewBandSet style.
SectionViewDepthGradeLabel | Specifies the default section view grade label style.
SectionViewOffsetElevationLabel | Specifies the default section view offset elevation label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class > SettingsSectionView::SettingsStyles Properties
Legend
Legend
Property
public


SettingsSurface Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Properties
SettingsSurface Properties Public Properties
SettingsSurface Properties
Public Properties
Public Property | Description
ContourLabeling | Gets the defaults assigned to surface labels.
Defaults | Gets the surface defaults setting.
Styles | Gets the default styles.assigned to surfaces and surface-related labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class > SettingsSurface Properties
Legend
Legend
Property
public


SettingsSurface::SettingsContourLabeling Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Properties
SettingsSurface::SettingsContourLabeling Properties Public Properties
SettingsSurface::SettingsContourLabeling Properties
Public Properties
Public Property | Description
DisplayContourLabelLine | Gets whether or not the contour label lines are displayed.
LabelMask | Gets the label mask type.
SurfaceContourLabelStyleMajor | Gets the default major contour label style.
SurfaceContourLabelStyleMinor | Gets the default minor contour label style.
SurfaceContourLabelStyleUserDefined | Gets the user-defined major contour label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class > SettingsSurface::SettingsContourLabeling Properties
Legend
Legend
Property
public


SettingsSurface::SettingsDefaults Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsDefaults Class > SettingsSurface::SettingsDefaults Properties
SettingsSurface::SettingsDefaults Properties Public Properties
SettingsSurface::SettingsDefaults Properties
Public Properties
Public Property | Description
AutoRebuild | Gets the PropertyBoolean value that specifies Automatic as the default setting for the Rebuild Surface command.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsDefaults Class > SettingsSurface::SettingsDefaults Properties
Legend
Legend
Property
public


SettingsSurface::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Properties
SettingsSurface::SettingsStyles Properties Public Properties
SettingsSurface::SettingsStyles Properties
Public Properties
Public Property | Description
Marker | Gets the default style for marker.
RenderMaterial | Gets the default render material.
Surface | Gets the default style for surface.
SurfaceSlopeLabel | Gets the default style for slope label.
SurfaceSpotElevationLabel | Gets the default style for spot elevation label .


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class > SettingsSurface::SettingsStyles Properties
Legend
Legend
Property
public


SettingsViewFrameGroup Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Properties
SettingsViewFrameGroup Properties Public Properties
SettingsViewFrameGroup Properties
Public Properties
Public Property | Description
Information | Gets the default match line label location.
NameFormat | Gets the default name formats for view frame group components.
Styles | Gets the default styles assigned to view frame group components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class > SettingsViewFrameGroup Properties
Legend
Legend
Property
public


SettingsViewFrameGroup::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Properties
SettingsViewFrameGroup::SettingsNameFormat Properties Public Properties
SettingsViewFrameGroup::SettingsNameFormat Properties
Public Properties
Public Property | Description
Layout | Gets the default name formats for layouts.
MatchLine | Gets the default name formats for match lines.
SheetFile | Gets the default name formats for sheet files.
ViewFrame | Gets the default name formats for view frames.
ViewFrameGroup | Gets the default name formats for view frame groups.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class > SettingsViewFrameGroup::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsViewFrameGroup::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties
SettingsViewFrameGroup::SettingsStyles Properties Public Properties
SettingsViewFrameGroup::SettingsStyles Properties
Public Properties
Public Property | Description
MatchLine | Gets the default style for match lines.
MatchLineLabelLeft | Gets the default style for labels that are displayed on the left side of a match line.
MatchLineLabelRight | Gets the default style for labels that are displayed on the right side of a match line.
MatchLineLeftLabelLocation | Gets the default location for labels that are displayed on the left side of a match line.
MatchLineRightLabelLocation | Gets the default location for labels that are displayed on the right side of a match line.
ProfileView | Gets the default profile view style.
ProfileViewBandSet | Gets the default style for profile view band sets.
ViewFrame | Gets the default style for view frames.
ViewFrameLabel | Gets the default style for view frame labels.
ViewFrameLabelLocation | Gets the default location on the view frame for view frame labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class > SettingsViewFrameGroup::SettingsStyles Properties
Legend
Legend
Property
public


Interference Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class > Interference Properties
Interference Properties Public Properties
Interference Properties
Public Properties
Public Property | Description
Network1Id | This is Network1Id, a member of class Interference.
Network2Id | This is Network2Id, a member of class Interference.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class > Interference Properties
Legend
Legend
Property
public


Network Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties
Network Properties Public Properties
Network Properties
Public Properties
Public Property | Description
PartsListId | Gets or sets the part list id.
PartsListName | Gets or sets the part list name.
PipeNameTemplate | Gets or sets the pipe name template string.
PipeNetworkSectionLayerId | Gets or sets the pipe network section layer id.
PipeNetworkSectionLayerName | Gets or sets the pipe network section layer name.
PipePlanLabelStyleId | Gets or sets the pipe plan label style id.
PipePlanLabelStyleName | Gets or sets the pipe plan label style name.
PipePlanLayerId | Gets or sets the pipe plan layer id.
PipePlanLayerName | Gets or sets the pipe plan layer name.
PipeProfileLabelStyleId | Gets or sets the pipe profile label style id.
PipeProfileLabelStyleName | Gets or sets the pipe profile label style name.
PipeProfileLayerId | Gets or sets the pipe profile layer id.
PipeProfileLayerName | Gets or sets the pipe profile layer name.
ReferenceAlignmentId | Gets or sets the reference alignment id.
ReferenceAlignmentName | Gets or sets the reference alignment name.
ReferenceSurfaceId | Gets or sets the reference surface id.
ReferenceSurfaceName | Gets or sets the reference surface name.
StructureNameTemplate | Gets or sets the structure name template string.
StructurePlanLabelStyleId | Gets or sets the structure plan label style id.
StructurePlanLabelStyleName | Gets or sets the structure plan label style name.
StructurePlanLayerId | Gets or sets the structure plan layer id.
StructurePlanLayerName | Gets or sets the structure plan layer name.
StructureProfileLabelStyleId | Gets or sets the structure profile label style id.
StructureProfileLabelStyleName | Gets or sets the structure profile label style name.
StructureProfileLayerId | Gets or sets the structure profile layer id.
StructureProfileLayerName | Gets or sets the structure profile layer name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class > Network Properties
Legend
Legend
Property
public


NetworkRule Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class > NetworkRule Properties
NetworkRule Properties Public Properties
NetworkRule Properties
Public Properties
Public Property | Description
ParamsDouble | Gets the Double parameters collection.
ParamsLong | Gets the Long parameters collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class > NetworkRule Properties
Legend
Legend
Property
public


Part Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties
Part Properties Public Properties
Part Properties
Public Properties
Public Property | Description
ConnectedPartCount | Gets the number of parts that connects to the part
Domain | Gets the part's domain.
Material | Gets the material defined for this part.
Name | Gets part's name.
NetworkId | Gets the object id of the network to which this part belongs
NetworkName | Gets the name of the network to which this part belongs
OverrideRuleSet | Gets or sets whether to use overridden rules.
ParamsBool | Gets the boolean parameters collection.
ParamsDouble | Gets the double parameters collection.
ParamsLong | Gets the long parameters collection.
ParamsString | Gets the string parameters collection.
PartData | Gets or sets the part data record.
PartDefId | Gets the object id of PartDef.
PartDescription | Gets the part’s description.
PartSizeName | Gets the part size name.
PartSubType | Gets the part’s subtype.
PartType | Gets the type of the network park.
Position | Gets or sets the position of the network part.
ProfileViewPartId | Gets the object id of the part's counterpart in profile views.
RefAlignmentId | Gets or sets the object id of the alignment which this part references.
RefAlignmentName | Gets the name of the alignment which this part references
RefSurfaceId | Gets or sets the object id of the surface that this part references.
RefSurfaceName | Gets the name of the surface which this part references.
RuleSetStyleId | Gets or sets the object id of RuleSetStyle.
RuleSetStyleName | Gets or sets RuleSetStyle by name.
SectionViewPartId | Gets the object id of the part's counterpart in section views.
Solid3dBody | Gets the 3d solid body of the part.
SurfaceId | Gets or sets the object id of the surface that this part references.
WallThickness | Gets the wall thickness for this structure, measured from the inside edge of the structure to the outside edge of... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class > Part Properties
Legend
Legend
Property
public


PartDataField Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties
PartDataField Properties Public Properties
PartDataField Properties
Public Properties
Public Property | Description
Context | Gets the parameter context.
ContextString | Gets the parameter context string.
DataType | Gets the type of the reserved data.
Description | Gets the description of the data field.
Index | Gets the parameter index.
IsFromList | Gets if the value of data field should be set from a fixed list.
IsFromRange | Gets if the value of data field should be set from a range.
IsReadOnly | Checks if the data field is read-only.
Name | Gets the name of the data field.
Units | Gets the parameter units.
Value | Gets or sets the value. The value type is returned by the DataType property.
ValueList | Gets the list of valid data if the data field is from a fixed list.
ValueRange | Gets the range of valid data if the data field is from a range.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class > PartDataField Properties
Legend
Legend
Property
public


PartDataList Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Properties
PartDataList Properties Public Properties
PartDataList Properties
Public Properties
Public Property | Description
Context | Gets the parameter context of the list
Count | The count of fields in the list
DataType | Gets the type of the data value.
default | Gets the value in the list by index.
Index | Gets the parameter index of the list


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class > PartDataList Properties
Legend
Legend
Property
public


PartDataRange Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Properties
PartDataRange Properties Public Properties
PartDataRange Properties
Public Properties
Public Property | Description
Context | Gets the parameter context of the list.
DataType | Gets the type of the data value.
Index | Gets the parameter index of the list.
RangeDefault | Gets the default value of the range.
RangeMax | Gets the maximum of range.
RangeMin | Gets the minimum of range.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class > PartDataRange Properties
Legend
Legend
Property
public


PartViewDef Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Properties
PartViewDef Properties Public Properties
PartViewDef Properties
Public Properties
Public Property | Description
BoundingBodyBlockId | Gets the bounding body block id.
BoundingBodyBlockName | Gets the bounding body block name.
PartBodyGraphicsBlockId | Gets the part body graphics block id.
PartBodyGraphicsBlockName | Gets the part body graphics block name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class > PartViewDef Properties
Legend
Legend
Property
public


Pipe Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties
Pipe Properties Public Properties
Pipe Properties
Public Properties
Public Property | Description
Bearing | Gets the horizontal bearing for straight pipes, and chord bearing for curved pipes.
CoverOfEndpoint | Gets the end point's cover of pipe.
CoverOfStartPoint | Gets the start point's cover of pipe.
CrossSectionalShape | Gets the pipe’s cross sectional shape, such as circular, egg-shaped, elliptical, or rectangular.
EndOffset | Gets the offset of the ending point for the pipe object.
EndPoint | Gets or sets the endpoint of the Pipe.
EndStation | Gets the station of the ending point for the pipe object.
EndStructureId | Gets the end structure id of the Pipe. If no connected structure, return ObjectId::Null.
FlowDirection | Gets the current flow direction of the pipe, relative to the start and endpoint of the pipe.
FlowDirectionMethod | Gets or sets the method that is used to determine the flow for this pipe.
HoldOnResizeType | Gets or sets how Structure should hold when resized.
InnerDiameterOrWidth | Gets the inner diameter or inner width of the pipe.
InnerHeight | Gets the inner height of the pipe in drawing units.
Length2D | Use Autodesk.Civil.PipeNetwork.Pipe.Length2DCenterToCenter instead.
Length2DCenterToCenter | Gets the two-dimensional length of the pipe, measured from the center of the connected starting structure to the center of... more
Length2DToInsideEdge | Gets the two-dimensional length of the pipe, measured from the inside edge of the connected starting structure to the inside... more
Length3D | Use Autodesk.Civil.PipeNetwork.Pipe.Length3DCenterToCenter instead.
Length3DCenterToCenter | Gets the three-dimensional length of the pipe, measured from the center of the connected starting structure to the center of... more
Length3DToInsideEdge | Gets the three-dimensional length of the pipe,measured from the inside edge of the connected starting structure to the inside edge... more
MaximumCover | Gets the maximum depth of cover along the entire length of pipe, from the top outside of the pipe to... more
MinimumCover | Gets the minimum depth of cover along the entire length of pipe, from the top outside of the pipe to... more
OuterDiameterOrWidth | Gets the outer diameter or outer width of the pipe.
OuterHeight | Gets the outer height of the pipe in drawing units.
Radius | Gets the radius of the pipe.
Slope | Gets the pipe’s slope in absolute value.
StartOffset | Gets the offset of the starting point for the pipe object.
StartPoint | Gets or sets the start point of the Pipe.
StartStation | Gets the station of the starting point for the pipe object.
StartStructureId | Gets the start structure id of the Pipe. If no connected structure, return ObjectId::Null.
SubEntityType | Gets the type of the pipe.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class > Pipe Properties
Legend
Legend
Property
public


ProfileViewPart Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Properties
ProfileViewPart Properties Public Properties
ProfileViewPart Properties
Public Properties
Public Property | Description
ModelPartId | Gets the object id of the source network part of model space


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class > ProfileViewPart Properties
Legend
Legend
Property
public


Structure Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties
Structure Properties Public Properties
Structure Properties
Public Properties
Public Property | Description
AutomaticRimSurfaceAdjustment | Gets or sets whether the rim should be automatically adjusted.
BarrelPipeClearance | Gets the clearance of barrel pipe.
BoundingShape | Gets the structure bounding shape.
ConeHeight | Gets the height of the cone shaped section of the structure.
ConnectedPipe | Gets the pipe connected to the structure by index.
ConnectedPipesCount | Gets the count of the pipes connected to the structure.
ControlSumpBy | Gets or sets how the sump should be adjusted.
Cover | Gets the model or type of grate used for a structure intended to be used as a catchbasin.
DiameterOrWidth | Gets the structure diameter or width.
Easting | Gets or sets the structure’s easting.
FloorThickness | Gets the thickness of the bottom of the structure.
Frame | Gets the model or type of frame used for a structure.
FrameDiameter | Gets the diameter of the structure’s frame.
FrameHeight | Gets the height of the structure’s frame.
Grate | Gets the grate of the pipe.
HeadwallBaseThickness | Gets the thickness of the base of the headwall.
HeadwallBaseWidth | Gets the width of the base of the headwall.
Height | Gets the structure height.
InnerDiameterOrWidth | Gets the structure inner diameter or width.
InnerLength | Gets the structure inner length.
Length | Gets the structure length.
Location | Gets or sets the location.
Northing | Gets or sets the structure’s northing.
Offset | Gets the structure’s offset.
PipeCenterDepth | Gets the center depth of the pipe.
PipeInnerDiameterOrWidth | Gets the inner diameter or inner width of the pipe.
PipeInvertDepth | Gets the invert depth.
PipeLowestBottomDepth | Gets the lowest bottom depth of a pipe.
PipeOuterBottomDepth | Gets the outer bottom pipe depth.
PipeOuterTopDepth | Gets the outer top pipe depth.
PipeUpperTopDepth | Gets the upper top depth of a pipe.
PipeWallThickness | Gets the pipe wall thickness.
RimElevation | Gets or sets the rim elevation.
RimToSumpHeight | Gets or sets the distance between the sump to the structure’s rim.
Rotation | Gets or sets the structure rotation.
Station | Gets the structure’s station.
SumpDepth | Gets or sets the sump depth.
SumpElevation | Gets or sets the sump elevation.
SurfaceAdjustmentValue | Gets or sets the surface adjustment value
SurfaceElevationAtInsertionPoint | Gets the inner diameter or inner width of the pipe.
VerticalPipeClearance | Gets the clearance required from the top outside of the highest pipe connected to the structure, to the rim.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class > Structure Properties
Legend
Legend
Property
public


DataPartFamily Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Properties
DataPartFamily Properties Public Properties
DataPartFamily Properties
Public Properties
Public Property | Description
BoundingShape | Gets the bounding shape type if the part is Structure, or it's undefined.
Description | Gets the part description
Domain | Gets the part domain
GUID | Gets the GUID of the part family
PartType | Gets the part type
SweptShape | Gets the swept shape type if the part is Pipe, or it's undefined.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class > DataPartFamily Properties
Legend
Legend
Property
public


InterferenceStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Properties
InterferenceStyle Properties Public Properties
InterferenceStyle Properties
Public Properties
Public Property | Description
AbsoluteModelSize | Gets or sets the absolute model size.
DrawingScaleModelSize | Gets or sets the drawing scale model size.
MarkerStyle | Gets or sets the marker style.
ModelOptions | Gets or sets the model options, TrueSolid or Sphere.
ModelSizeOptions | Gets or sets the model size options, UseAbsoluteUnits or UseDrawingScale.
ModelSizeType | Gets or sets the interference size type, SolidExtents or UserDefined.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class > InterferenceStyle Properties
Legend
Legend
Property
public


LabelStylesPipeRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class > LabelStylesPipeRoot Properties
LabelStylesPipeRoot Properties Public Properties
LabelStylesPipeRoot Properties
Public Properties
Public Property | Description
CrossSectionLabelStyles | Gets the collection of all pipe Cross Section label styles in the database.
PlanProfileLabelStyles | Gets the collection of all pipe Plan Profile label styles in the database.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class > LabelStylesPipeRoot Properties
Legend
Legend
Property
public


LabelStylesStructureRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesStructureRoot Class > LabelStylesStructureRoot Properties
LabelStylesStructureRoot Properties Public Properties
LabelStylesStructureRoot Properties
Public Properties
Public Property | Description
LabelStyles | Gets the collection of all structure label styles in the database.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesStructureRoot Class > LabelStylesStructureRoot Properties
Legend
Legend
Property
public


NetworkRuleSetStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Properties
NetworkRuleSetStyle Properties Public Properties
NetworkRuleSetStyle Properties
Public Properties
Public Property | Description
RulesCount | Gets the count of all rules belonging to this network rule set.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class > NetworkRuleSetStyle Properties
Legend
Legend
Property
public


PartFamily Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties
PartFamily Properties Public Properties
PartFamily Properties
Public Properties
Public Property | Description
BoundingShape | Gets the bounding shape type if the part is Structure, or it's undefined.
default | Gets the object id of the part size with the given description under the part family.
Description | Gets the part family description
Domain | Gets the part domain
GUID | Gets the GUID of the part family
PartSizeCount | Gets count of part sizes under this part family
PartSizeFilter | Gets the part size filter record through which you can set the corresponding properties to specify what part sizes you... more
PartType | Gets the part type
SweptShape | Gets the swept shape type if the part is Pipe, or it's undefined.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class > PartFamily Properties
Legend
Legend
Property
public


PartSize Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Properties
PartSize Properties Public Properties
PartSize Properties
Public Properties
Public Property | Description
MaterialStyleId | Gets or sets the object id of the material style to apply side by side with the part size.
PartStyleId | Gets or sets the object id of the part style to apply side by side with the part size.
PayItems | Gets or Sets the payitem list.
RulesStyleId | Gets or sets the object id of the rule set style to apply side by side with the part size.... more
SizeDataRecord | Gets the serialized catalog part size record.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class > PartSize Properties
Legend
Legend
Property
public


PartsList Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Properties
PartsList Properties Public Properties
PartsList Properties
Public Properties
Public Property | Description
default | Gets the object id of the part family from this parts list by given description. Returns null object id if... more
PartFamilyCount | Gets the count of part families under this parts list.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class > PartsList Properties
Legend
Legend
Property
public


PipeNetworkBandStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Properties
PipeNetworkBandStyle Properties Public Properties
PipeNetworkBandStyle Properties
Public Properties
Public Property | Description
BandType | Gets the BandStyleType enum value that specifies the type of data band data.
PipeLabelStyleId | Gets the band profile data pipe label style id.
PipeTickStyle | Gets the band profile data pipe tick style.
StructureLabelStyleId | Gets the band profile data structure label style id.
StructureTickStyle | Gets the band profile data structure tick style.
TitleTextLabelStyleId | Gets the band profile data title text label style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class > PipeNetworkBandStyle Properties
Legend
Legend
Property
public


PipeStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Properties
PipeStyle Properties Public Properties
PipeStyle Properties
Public Properties
Public Property | Description
PlanOption | Gets the object that defines the appearance of the pipe in a 2D plan view.
ProfileOption | Gets the object that defines the appearance of the pipe in a profile view.
SectionCrossingHatch | Gets or sets the PipeHatchOptions object that specifies the style for the inside walls of pipe crossings displayed in section... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class > PipeStyle Properties
Legend
Legend
Property
public


PipeStyleOptionBase Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties
PipeStyleOptionBase Properties Public Properties
PipeStyleOptionBase Properties
Public Properties
Public Property | Description
AlignHatchToPipe | Gets or sets the AlignHatchToPipe value that specifies whether the angle of the hatch lines for the pipe align with... more
EndLineSize | Pipe style end line size.
EndLineSizePercent | Pipe style end line size percent.
EndSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe end size is drawn in absolute units, to drawing scale,... more
EndSizeType | Specifies the appearance of the pipe end, such as draw to inner wall, draw to outer wall, or user-defined.
HatchOptions | Specifies which components of the pipe shape display a hatch pattern.
InnerDiameter | Specifies the inner pipe wall dimensions as an absolute value.
InnerDiameterPercent | Specifies the inner pipe wall dimensions as a percent of drawing size.
OuterDiameter | Specifies the outer pipe wall dimensions as an absolute value.
OuterDiameterPercent | Specifies the outer pipe wall dimensions as a percent of drawing size.
PipeToPipeEndCleanup | Gets or sets the PipeToPipeEndCleanup value that specifies whether the appearance of pipe to pipe connections in plan/profile view is... more
WallSizeOptions | Gets or sets the PipeDisplayOptions value that specifies whether pipe wall size is drawn in absolute units, to drawing scale,... more
WallSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe wall.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class > PipeStyleOptionBase Properties
Legend
Legend
Property
public


PipeStylePlanOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Properties
PipeStylePlanOption Properties Public Properties
PipeStylePlanOption Properties
Public Properties
Public Property | Description
CenterlineOptions | Gets or sets the method that will be used to define and draw the dimensions of the pipe centerline.
CenterlineSize | Gets or sets pipe style center line size.
CenterlineSizePercent | Gets or sets pipe style center line size percent.
CenterlineWidthOptions | Gets or sets the center line width option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class > PipeStylePlanOption Properties
Legend
Legend
Property
public


PipeStyleProfileOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleProfileOption Class > PipeStyleProfileOption Properties
PipeStyleProfileOption Properties Public Properties
PipeStyleProfileOption Properties
Public Properties
Public Property | Description
CrossingHatch | Specifies which components of a pipe crossing display a hatch pattern.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleProfileOption Class > PipeStyleProfileOption Properties
Legend
Legend
Property
public


SizeFilterField Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class > SizeFilterField Properties
SizeFilterField Properties Public Properties
SizeFilterField Properties
Public Properties
Public Property | Description
DataSource | Gets the parameter data source.
IsMultipleSelect | Gets if multiselecting all the values if the data source of this parameter is "FixedList"


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class > SizeFilterField Properties
Legend
Legend
Property
public


SizeFilterRecord Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Properties
SizeFilterRecord Properties Public Properties
SizeFilterRecord Properties
Public Properties
Public Property | Description
default | Gets the catalog part parameter by name.
ParamCount | Gets the count of parameters in the catalog part.
PartFamilyGuid | Gets the guid of the part family this size filter belongs to


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class > SizeFilterRecord Properties
Legend
Legend
Property
public


StructureStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Properties
StructureStyle Properties Public Properties
StructureStyle Properties
Public Properties
Public Property | Description
ModelOption | Gets the object that defines the appearance of the Structure in a model view.
PlanOption | Gets the object that defines the appearance of the Structure in a 2D plan view.
ProfileOption | Gets the object that defines the appearance of the Structure in a profile view.
SectionOption | Gets the object that defines the appearance of the Structure in a section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class > StructureStyle Properties
Legend
Legend
Property
public


StructureStyleModelOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class > StructureStyleModelOption Properties
StructureStyleModelOption Properties Public Properties
StructureStyleModelOption Properties
Public Properties
Public Property | Description
ModelViewOptions | Gets or sets the enum value that indicates whether the 3D object composed in the parts catalog should be used... more
SimpleSolidType | When ModelViewOptions is defined as Simple3dPart, the 3D object composed in the parts catalog is ignored and the structure is... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class > StructureStyleModelOption Properties
Legend
Legend
Property
public


StructureStyleOptionBase Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties
StructureStyleOptionBase Properties Public Properties
StructureStyleOptionBase Properties
Public Properties
Public Property | Description
BlockInsertLocation | Gets or sets the insertion point to use for the block displayed in profile/section view.
MaskConnectedObjects | Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in profile/section... more
SizeType | Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure... more
SymbolBlockName | Gets or sets the name of the block reference to use when displaying in profile/section view.
SymbolBlockXScale | Gets or sets the x scale to use when displaying with a block reference in profile/section view.
SymbolBlockYScale | Gets or sets the y scale to use when displaying with a block reference in profile/section view.
SymbolBlockZScale | Gets or sets the z scale to use when displaying with a block reference in profile/section view.
ViewOptions | Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as... more
XSize | Gets or sets the absolute X-dimension size of the block to display in profile/section view.
XSizePercent | Gets or sets the percentage of the screensize (X-dimension) for the block to display in profile/section view.
YSize | Gets or sets the absolute Y-dimension size of the block to display in profile/section view.
YSizePercent | Gets or sets the percentage of the screensize (Y-dimension) for the block to display in profile/section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class > StructureStyleOptionBase Properties
Legend
Legend
Property
public


StructureStylePlanOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties
StructureStylePlanOption Properties Public Properties
StructureStylePlanOption Properties
Public Properties
Public Property | Description
MaskConnectedObjects | Gets or sets the boolean value that specifies whether the pipe objects are masked by the structure object in plan... more
PlanViewOptions | Gets or sets the enum value that specifies whether the 2D plan view of the structure style is displayed as... more
Size | Gets or sets the absolute size of the block to display in plan view, if the SizeType is specified as... more
SizePercent | Gets or sets the percent of screen to use when sizing the block displayed in plan view, if SizeType is... more
SizeType | Gets or sets the enum value that controls relative sizing when an AutoCAD block is used to represent the structure... more
SymbolBlockName | Gets or sets the name of the block reference to use when displaying in plan view.
SymbolBlockXScale | Gets or sets the X scale to use when displaying with a block reference in plan view.
SymbolBlockYScale | Gets or sets the Y scale to use when displaying with a block reference in plan view.
SymbolBlockZScale | Gets or sets the Z scale to use when displaying with a block reference in plan view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class > StructureStylePlanOption Properties
Legend
Legend
Property
public


SettingsCmdAddNetworkPipeTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Properties
SettingsCmdAddNetworkPipeTable Properties Public Properties
SettingsCmdAddNetworkPipeTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the defaults when you add a network pipe table.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class > SettingsCmdAddNetworkPipeTable Properties
Legend
Legend
Property
public


SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties Public Properties
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Gets the maximum number of rows to include per section.
MaximumTablesPerStack | Gets the maximum number of sections to include in each stack.
SplitTable | Gets whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Gets the spacing between tables.
TableStyle | Gets the style for a table.
TileDirection | Gets the direction in which the table tiles (across or down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddNetworkStructTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Properties
SettingsCmdAddNetworkStructTable Properties Public Properties
SettingsCmdAddNetworkStructTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the defaults when you add a network structure table.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class > SettingsCmdAddNetworkStructTable Properties
Legend
Legend
Property
public


SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties Public Properties
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Gets the maximum number of rows to include per section.
MaximumTablesPerStack | Gets the maximum number of sections to include in each stack.
SplitTable | Gets whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Gets the spacing between tables.
TableStyle | Gets the style for a table.
TileDirection | Gets the direction in which the table tiles (across or down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignFromNetwork Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Properties
SettingsCmdCreateAlignFromNetwork Properties Public Properties
SettingsCmdCreateAlignFromNetwork Properties
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the alignment type options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class > SettingsCmdCreateAlignFromNetwork Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties Public Properties
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties
Public Properties
Public Property | Description
AlignmentType | Specifies the alignment type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Properties
Legend
Legend
Property
public


SettingsCmdCreateInterferenceCheck Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Properties
SettingsCmdCreateInterferenceCheck Properties Public Properties
SettingsCmdCreateInterferenceCheck Properties
Public Properties
Public Property | Description
InterferenceCriteria | Gets the default interference criteria.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class > SettingsCmdCreateInterferenceCheck Properties
Legend
Legend
Property
public


SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties Public Properties
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties
Public Properties
Public Property | Description
Apply3DProximityCheck | Gets whether apply 3d proximity check.
Distance | Gets the tolerance distance value for interference check.
ScaleFactor | Gets the scale factor for scaling each network part for performing the interference check.
UseDistanceOrScaleFactor | Gets the selection of distance or scale factor to perform the 3D proximity check.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Properties
Legend
Legend
Property
public


SettingsCmdCreateNetwork Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Properties
SettingsCmdCreateNetwork Properties Public Properties
SettingsCmdCreateNetwork Properties
Public Properties
Public Property | Description
DefaultLayoutCommand | Gets the default layout command type.
LabelNewParts | Gets the default labeling when you add parts to a network.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class > SettingsCmdCreateNetwork Properties
Legend
Legend
Property
public


SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties Public Properties
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties
Public Properties
Public Property | Description
PipeInPlan | Gets whether a new pipe is labeled by default when placed in plan view.
PipeProfile | Gets whether a new pipe is labeled by default when placed in profile view.
StructureInPlan | Gets whether a new structure is labeled by default when placed in plan view.
StructureProfile | Gets whether a new structure is labeled by default when placed in profile view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Properties
Legend
Legend
Property
public


SettingsPipeNetwork Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Properties
SettingsPipeNetwork Properties Public Properties
SettingsPipeNetwork Properties
Public Properties
Public Property | Description
NameFormat | Gets the settings to specify the default name formats for pipe network components (pipe network, pipes, structures).
ProfileLabelPlacement | Gets the settings to establish the default placement of profile view labels associated with the pipe network.
Rules | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
SectionLabelPlacement | Gets the settings to establish the default placement of section view labels associated with the pipe network.
StormSewersMigration | Gets the settings to establish the default rule set assigned to pipes and structures that are added to the pipe... more
Styles | Gets the default styles assigned to pipe network components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class > SettingsPipeNetwork Properties
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Properties
SettingsPipeNetwork::SettingsNameFormat Properties Public Properties
SettingsPipeNetwork::SettingsNameFormat Properties
Public Properties
Public Property | Description
AlignmentFromNetwork | Settings for PipeNetwork AlignmentFromNetwork name format .
Interference | Settings for PipeNetwork Interference name format .
InterferenceCheck | Settings for PipeNetwork InterferenceCheck name format .
Network | Settings for PipeNetwork Network name format .
Pipe | Settings for PipeNetwork Pipe name format .
Structure | Settings for PipeNetwork Structure name format .


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class > SettingsPipeNetwork::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsProfileLabelPlacement Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties
SettingsPipeNetwork::SettingsProfileLabelPlacement Properties Public Properties
SettingsPipeNetwork::SettingsProfileLabelPlacement Properties
Public Properties
Public Property | Description
DimensionAnchorElevationValueForPipes | Specifies the default elevation of the dimension line anchor for profile view labels for pipes.
DimensionAnchorElevationValueForStructures | Specifies the default elevation of the dimension line anchor for profile view labels for structures.
DimensionAnchorOptionForPipes | Specifies the location of the dimension line anchor for profile view labels for pipes.
DimensionAnchorOptionForStructures | Specifies the location of the dimension line anchor for profile view labels for structures.
DimensionAnchorPlotHeightValueForPipes | Specifies the default plot height of the dimension line anchor for profile view labels for pipes.
DimensionAnchorPlotHeightValueForStructures | Specifies the default plot height of the dimension line anchor for profile view labels for structures.
StructureLabelPlacement | Specifies the default location of structure labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class > SettingsPipeNetwork::SettingsProfileLabelPlacement Properties
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsRules Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class > SettingsPipeNetwork::SettingsRules Properties
SettingsPipeNetwork::SettingsRules Properties Public Properties
SettingsPipeNetwork::SettingsRules Properties
Public Properties
Public Property | Description
Pipe | Specifies the default rule set assigned to pipes.
Structure | Specifies the default rule set assigned to structures.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class > SettingsPipeNetwork::SettingsRules Properties
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsSectionLabelPlacement Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties
SettingsPipeNetwork::SettingsSectionLabelPlacement Properties Public Properties
SettingsPipeNetwork::SettingsSectionLabelPlacement Properties
Public Properties
Public Property | Description
DimensionAnchorElevationValueForPipes | Specifies the default elevation of the dimension line anchor for section view labels for pipes.
DimensionAnchorElevationValueForStructures | Specifies the default elevation of the dimension line anchor for section view labels for structures.
DimensionAnchorOptionForPipes | Specifies the location of the dimension line anchor for section view labels for pipes.
DimensionAnchorOptionForStructures | Specifies the location of the dimension line anchor for section view labels for structures.
DimensionAnchorPlotHeightValueForPipes | Specifies the default plot height of the dimension line anchor for section view labels for pipes.
DimensionAnchorPlotHeightValueForStructures | Specifies the default plot height of the dimension line anchor for section view labels for structures.
PipeSectionLabel | Specifies the default location of pipe labels displayed in section views.
StructureLabelPlacement | Specifies the default location of structure labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class > SettingsPipeNetwork::SettingsSectionLabelPlacement Properties
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsStormSewersMigration Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class > SettingsPipeNetwork::SettingsStormSewersMigration Properties
SettingsPipeNetwork::SettingsStormSewersMigration Properties Public Properties
SettingsPipeNetwork::SettingsStormSewersMigration Properties
Public Properties
Public Property | Description
PartMatching | Specifies the defaults used for part matching when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil... more
PartsListUsedForMigration | Specifies the default parts list assigned when migrating pipe network data between the Storm Sewers extension and AutoCAD Civil 3D.... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class > SettingsPipeNetwork::SettingsStormSewersMigration Properties
Legend
Legend
Property
public


SettingsPipeNetwork::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties
SettingsPipeNetwork::SettingsStyles Properties Public Properties
SettingsPipeNetwork::SettingsStyles Properties
Public Properties
Public Property | Description
Interference | Specifies the default style for interference in the pipe network.
InterferenceRenderMaterial | Specifies the default interference render material in the pipe network.
PartsList | Specifies the default parts list for the pipe network.
Pipe | Specifies the default style for pipes in the pipe network.
PipePlanLabel | Specifies the default style for pipe labels that are displayed in plan view.
PipeProfileLabel | Specifies the default style for pipe labels that are displayed in profile view.
PipeSectionLabel | Specifies the default style for pipe labels that are displayed in section view.
RenderMaterial | Specifies the default render material in the pipe network.
Structure | Specifies the default style for structures in the pipe network.
StructurePlanLabel | Specifies the default style for structure labels that are displayed in plan view.
StructureProfileLabel | Specifies the default style for structure labels that are displayed in a profile view.
StructureSectionLabel | Specifies the default style for structure labels that are displayed in a section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class > SettingsPipeNetwork::SettingsStyles Properties
Legend
Legend
Property
public


PropertyAnchorPoint Properties Public Properties
PropertyAnchorPoint Properties
Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyAnchorPoint.


PropertyAngle Properties Public Properties
PropertyAngle Properties
Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyAngle.


PropertyBlock Properties Public Properties
PropertyBlock Properties
Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyBlock.


PropertyEnum Properties Public Properties
PropertyEnum Properties
Public Properties
Public Property | Description
Value | Gets or sets the property value.


PropertyObjectName Properties Public Properties
PropertyObjectName Properties
Public Properties
Public Property | Description
Value | This is Value, a member of class PropertyObjectName.


AppliedAssembly Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties
AppliedAssembly Properties Public Properties
AppliedAssembly Properties
Public Properties
Public Property | Description
AssemblyId | Gets the ID of this AppliedAssembly.
CorridorId | Gets the parent Corridor Id.
Links | Gets the collection of CalculatedLinks in this AppliedAssembly.
LinksByCode | Gets the collection of CalculatedLinks in this AppliedAssembly that have a particular code.
Points | Gets the collection of CalculatedPoints in this AppliedAssembly.
PointsByCode | Gets the collection of CalculatedPoints in this AppliedAssembly that have a particular code.
Shapes | Gets the collection of CalculatedShapes in this AppliedAssembly.
ShapesByCode | Gets the collection of CalculatedShapes in this AppliedAssembly that have a particular code.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class > AppliedAssembly Properties
Legend
Legend
Property
public


AppliedAssemblyCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Properties
AppliedAssemblyCollection Properties Public Properties
AppliedAssemblyCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of AppliedAssembly objects in the collection.
default | Gets the default AppliedAssembly object from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class > AppliedAssemblyCollection Properties
Legend
Legend
Property
public


AppliedSubassembly Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties
AppliedSubassembly Properties Public Properties
AppliedSubassembly Properties
Public Properties
Public Property | Description
BaselineHookedTo | Gets the hooked Baseline.
CorridorId | Gets the ID of the parent Corridor object.
Links | Gets the collection of CalculatedLinks in this AppliedSubssembly.
OriginStationOffsetElevationToBaseline | Gets the origin SOE coordinate to Baseline.
Points | Gets the collection of CalculatedPoints in this AppliedSubssembly.
Shapes | Gets the collection of CalculatedShapes in this AppliedSubssembly.
SubassemblyId | Gets the ID of this AppliedSubassembly.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class > AppliedSubassembly Properties
Legend
Legend
Property
public


AppliedSubassemblyCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Properties
AppliedSubassemblyCollection Properties Public Properties
AppliedSubassemblyCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of AppliedSubassembly objects in the collection.
default | Gets the defaul AppliedSubassembly object from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class > AppliedSubassemblyCollection Properties
Legend
Legend
Property
public


Assembly Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Properties
Assembly Properties Public Properties
Assembly Properties
Public Properties
Public Property | Description
CodeSetStyleName | Gets or sets the CodeSetStyle by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class > Assembly Properties
Legend
Legend
Property
public


AssemblyCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Properties
AssemblyCollection Properties Public Properties
AssemblyCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of Assembly objects in the collection.
default | Gets an Assembly by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class > AssemblyCollection Properties
Legend
Legend
Property
public


BaseBaseline Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties
BaseBaseline Properties Public Properties
BaseBaseline Properties
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
CorridorId | Gets the ID of the Corridor this baseline is associated with.
DirectionAtStation | Gets the direction at a station of the baseline.
EndStation | Gets the end station for this baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
StartStation | Gets the starting station for this baseline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class > BaseBaseline Properties
Legend
Legend
Property
public


Baseline Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties
Baseline Properties Public Properties
Baseline Properties
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
AppliedAssembly | Gets the AppliedAssembly by station.
BaselineRegions | Gets the collection of BaselineRegion objects in this Baseline.
BaselineType | Gets the baseline type.
EndStation | Gets the end station for this baseline.
IsProcessed | Gets whether this Baseline is built during corridor rebuild.
MainBaselineFeatureLines | Gets the main baseline FeatureLine collection.
OffsetBaselineFeatureLinesCol | Gets the offset baseline FeatureLine collection.
ProfileId | Gets the ID of the Profile this baseline is associated with.
StartStation | Gets the starting station for this baseline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class > Baseline Properties
Legend
Legend
Property
public


BaselineCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Properties
BaselineCollection Properties Public Properties
BaselineCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of Baseline objects in the collection.
default | Gets a Baseline by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class > BaselineCollection Properties
Legend
Legend
Property
public


BaselineFeatureLines Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Properties
BaselineFeatureLines Properties Public Properties
BaselineFeatureLines Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
FeatureLineCollectionMap | Gets the collection of feature lines (FeatureLinesCollection).
HardcodedOffsetBaselineName | Gets the hardcoded offset baseline name.
IsMainBaseline | Returns True if this is a main baseline.
OffsetAlignmentId | Gets the ObjectId for the offset alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class > BaselineFeatureLines Properties
Legend
Legend
Property
public


BaselineFeatureLinesCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Properties
BaselineFeatureLinesCollection Properties Public Properties
BaselineFeatureLinesCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of BaselineFeatureLines objects in the collection.
default | Gets a BaselineFeatureLines object by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class > BaselineFeatureLinesCollection Properties
Legend
Legend
Property
public


BaselineRegion Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties
BaselineRegion Properties Public Properties
BaselineRegion Properties
Public Properties
Public Property | Description
AppliedAssemblies | Gets the collection of AppliedAssembly objects associated with this BaselineRegion.
AssemblyId | Gets the ObjectId of the Assembly associated with this BaselineRegion.
CorridorId | Gets the ObjectId of the Corridor this BaselineRegion is associated with.
EndStation | Gets the number of the end station for this BaselineRegion.
IsProcessed | Gets whether this BaselineRegion is processed.
OffsetBaselines | Gets the collection of OffsetBaseline objects associated with this BaselineRegion.
StartStation | Gets the number of the start station for this BaselineRegion.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class > BaselineRegion Properties
Legend
Legend
Property
public


BaselineRegionCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Properties
BaselineRegionCollection Properties Public Properties
BaselineRegionCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLines BaselineRegion in the collection.
default | Gets a BaselineRegion object by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class > BaselineRegionCollection Properties
Legend
Legend
Property
public


CalculatedLink Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Properties
CalculatedLink Properties Public Properties
CalculatedLink Properties
Public Properties
Public Property | Description
CalculatedPoints | Gets the collection of CalculatedPoints associated with the CalculatedLink.
CorridorCodes | Gets the collection of codes associated with the CalculatedLink.
DrawOverride | Gets the draw override type of the CalculatedLink (CorridorLinkDrawOverride enumeration).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class > CalculatedLink Properties
Legend
Legend
Property
public


CalculatedLinkCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Properties
CalculatedLinkCollection Properties Public Properties
CalculatedLinkCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CalculatedLink objects in this collection.
default | Gets the default CalculatedLink object from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class > CalculatedLinkCollection Properties
Legend
Legend
Property
public


CalculatedPoint Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Properties
CalculatedPoint Properties Public Properties
CalculatedPoint Properties
Public Properties
Public Property | Description
CorridorCodes | Gets the collection of codes associated with the CalculatedPoint.
NormalToBaseline | Gets the normal to baseline vector.
NormalToSubassembly | Gets the normal to subassembly vector.
StationOffsetElevationToBaseline | Gets the Station (X), offset to baseline (Y) and elevation from baseline (Z) for the point.
StationOffsetElevationToSubassembly | Gets the Station (X), offset to subassembly (Y) and elevation from subassembly (Z) for the point.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class > CalculatedPoint Properties
Legend
Legend
Property
public


CalculatedPointCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Properties
CalculatedPointCollection Properties Public Properties
CalculatedPointCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CalculatedPoint objects in the collection.
default | Gets a CalculatedPoint by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class > CalculatedPointCollection Properties
Legend
Legend
Property
public


CalculatedShape Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Properties
CalculatedShape Properties Public Properties
CalculatedShape Properties
Public Properties
Public Property | Description
Area | Gets the area of the CalculatedShape.
CalculatedLinks | Gets the collection of links that make up the CalculatedShape.
CorridorCodes | Gets the collection of codes associated with the CalculatedShape.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class > CalculatedShape Properties
Legend
Legend
Property
public


CalculatedShapeCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Properties
CalculatedShapeCollection Properties Public Properties
CalculatedShapeCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CorridorSurfaceBoundary objects in the collection.
default | Gets a CalculatedShape by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class > CalculatedShapeCollection Properties
Legend
Legend
Property
public


CalculatedSubentity Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Properties
CalculatedSubentity Properties Public Properties
CalculatedSubentity Properties
Public Properties
Public Property | Description
CorridorCodes | Gets the collection of CorridorCode objects.
CorridorId | Gets the ObjectId of the parent Corridor.
SubassemblyBelongedTo | Gets the AppliedSubassembly this calculated subentity belongs to.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class > CalculatedSubentity Properties
Legend
Legend
Property
public


CodeCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Properties
CodeCollection Properties Public Properties
CodeCollection Properties
Public Properties
Public Property | Description
Count | Get the count of code in the collection
default | Get a code in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class > CodeCollection Properties
Legend
Legend
Property
public


Corridor Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties
Corridor Properties Public Properties
Corridor Properties
Public Properties
Public Property | Description
Baselines | Gets the baselines collection for the corridor.
CodeSetStyleName | Gets or sets the corridor's code set style name.
CorridorSurfaces | Gets the surfaces collection for the corridor.
FeatureLineCodeInfos | Gets the feature line code info collection for the corridor.
IsOutOfDate | Gets the corridor's out of date flag.
MaximumTriangleSideLength | Gets or sets the corridor surface's maximum triangle side length.
RebuildAutomatic | Gets or sets the automatic rebuild mode for the corridor.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class > Corridor Properties
Legend
Legend
Property
public


CorridorCodeCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Properties
CorridorCodeCollection Properties Public Properties
CorridorCodeCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of Corridor code strings in the collection.
default | Gets a Corridor code string from the collection by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class > CorridorCodeCollection Properties
Legend
Legend
Property
public


CorridorCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Properties
CorridorCollection Properties Public Properties
CorridorCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of Corridor objects in the collection.
default | Gets an Corridor by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class > CorridorCollection Properties
Legend
Legend
Property
public


CorridorSurface Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties
CorridorSurface Properties Public Properties
CorridorSurface Properties
Public Properties
Public Property | Description
Boundaries | Gets the collection of surface boundaries.
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description for the CorridorSurface.
IsBuild | Returns true if the CorridorSurface is built.
IsDraw | Returns true if the CorridorSurface is drawn.
Masks | Gets the collection of surface masks.
Name | Gets the name of the CorridorSurface.
SectionStyleId | Gets the ID of the SectionStyle.
SurfaceStyleId | Gets the ID of the SurfaceStyle.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class > CorridorSurface Properties
Legend
Legend
Property
public


CorridorSurfaceBaseMask Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Properties
CorridorSurfaceBaseMask Properties Public Properties
CorridorSurfaceBaseMask Properties
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Description | Gets the description.
FeatureLineComponents | Gets the collection of feature line components that make up the edge, if the border was originally defined by selecting... more
Name | Gets the name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class > CorridorSurfaceBaseMask Properties
Legend
Legend
Property
public


CorridorSurfaceBoundary Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Properties
CorridorSurfaceBoundary Properties Public Properties
CorridorSurfaceBoundary Properties
Public Properties
Public Property | Description
BoundaryType | Gets the surface boundary type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class > CorridorSurfaceBoundary Properties
Legend
Legend
Property
public


CorridorSurfaceBoundaryCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Properties
CorridorSurfaceBoundaryCollection Properties Public Properties
CorridorSurfaceBoundaryCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CorridorSurfaceBoundary objects in the collection.
default | Gets a CorridorSurfaceBoundary by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class > CorridorSurfaceBoundaryCollection Properties
Legend
Legend
Property
public


CorridorSurfaceCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Properties
CorridorSurfaceCollection Properties Public Properties
CorridorSurfaceCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of CorridorSurface objects in the collection.
default | Gets a CorridorSurface by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class > CorridorSurfaceCollection Properties
Legend
Legend
Property
public


CorridorSurfaceMaskCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Properties
CorridorSurfaceMaskCollection Properties Public Properties
CorridorSurfaceMaskCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of CorridorSurfaceMask objects in the collection.
default | Gets a CorridorSurfaceMask object by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class > CorridorSurfaceMaskCollection Properties
Legend
Legend
Property
public


FeatureLine Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Properties
FeatureLine Properties Public Properties
FeatureLine Properties
Public Properties
Public Property | Description
CodeName | Gets the code name used to construct the feature line.
CorridorId | Gets the ObjectId of the parent Corridor.
FeatureLinePoints | Gets the collection of all points that make up the feature line.
StyleId | Gets or Sets the FeatureLine's style Id.
StyleName | Gets or Sets the FeatureLine's style name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class > FeatureLine Properties
Legend
Legend
Property
public


FeatureLineCodeInfo Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Properties
FeatureLineCodeInfo Properties Public Properties
FeatureLineCodeInfo Properties
Public Properties
Public Property | Description
CodeName | Gets the code name.
CorridorId | Gets the ID of the parent Corridor.
IsConnect | Returns True if the feature line connects to multiple points in the same applied assembly if those points share the... more
IsDraw | Returns true if the feature line is drawn.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class > FeatureLineCodeInfo Properties
Legend
Legend
Property
public


FeatureLineCodeInfoCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Properties
FeatureLineCodeInfoCollection Properties Public Properties
FeatureLineCodeInfoCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineCodeInfo objects in the collection.
default | Gets a FeatureLineCodeInfo by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class > FeatureLineCodeInfoCollection Properties
Legend
Legend
Property
public


FeatureLineCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Properties
FeatureLineCollection Properties Public Properties
FeatureLineCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
Count | Gets the number of FeatureLine objects in this collection.
default | Gets the default FeatureLine object in this collection.
FeatureLineCodeInfo | Gets the object that contains information about the code used to construct the FeatureLine.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class > FeatureLineCollection Properties
Legend
Legend
Property
public


FeatureLineCollectionMap Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Properties
FeatureLineCollectionMap Properties Public Properties
FeatureLineCollectionMap Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineCollection objects in the collection.
default | Gets a FeatureLineCollection from the collection by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class > FeatureLineCollectionMap Properties
Legend
Legend
Property
public


FeatureLineComponent Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties
FeatureLineComponent Properties Public Properties
FeatureLineComponent Properties
Public Properties
Public Property | Description
CorridorId | Gets the parent Corridor Id.
EndStation | Gets the end station.
FeatureLine | Gets the parent FeatureLine object.
IsReversed | Returns True if the station values have been reversed.
StartStation | Gets the start station.
UseEndStation | Returns true if the end station is used.
UseStartStation | Returns true if the start station is used.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class > FeatureLineComponent Properties
Legend
Legend
Property
public


FeatureLineComponentCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Properties
FeatureLineComponentCollection Properties Public Properties
FeatureLineComponentCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLineComponent objects in the collection.
default | Gets a FeatureLineComponent by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class > FeatureLineComponentCollection Properties
Legend
Legend
Property
public


FeatureLinePoint Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Properties
FeatureLinePoint Properties Public Properties
FeatureLinePoint Properties
Public Properties
Public Property | Description
CorridorId | Gets the ID of the parent Corridor.
IsBreak | Gets the IsBreak value of this point.
Station | Gets the station of the assembly containing this point.
XYZ | Gets the coordinates of this point.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class > FeatureLinePoint Properties
Legend
Legend
Property
public


FeatureLinePointCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Properties
FeatureLinePointCollection Properties Public Properties
FeatureLinePointCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of FeatureLinePoint objects in the collection.
default | Gets a FeatureLinePoint by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class > FeatureLinePointCollection Properties
Legend
Legend
Property
public


HardcodedOffsetBaseline Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties
HardcodedOffsetBaseline Properties Public Properties
HardcodedOffsetBaseline Properties
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
EndStation | Gets the end station for this baseline.
Name | Gets the name of the HardcodedOffsetBaseline.
OffsetElevationFromMainBaseline | Gets the offset elevation from the main Baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
RelatedOffsetBaselineFeatureLines | Gets related offset baseline featurelines.
StartStation | Gets the starting station for this baseline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class > HardcodedOffsetBaseline Properties
Legend
Legend
Property
public


Intersection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Properties
Intersection Properties Public Properties
Intersection Properties
Public Properties
Public Property | Description
CorridorId | Gets or sets the object id of the corresponding corridor.
GradeRuleType | Gets or sets the grade rule type.
IntersectionRegions | Gets the regions of this Intersection.
IntersectionRoads | Gets the roads of this Intersection.
Location | Gets the location of the intersection.
RoadwayDrivingDirection | Gets or sets the direction of roadway driving.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class > Intersection Properties
Legend
Legend
Property
public


IntersectionRegion Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Properties
IntersectionRegion Properties Public Properties
IntersectionRegion Properties
Public Properties
Public Property | Description
Angle | Gets the angle.
CurbReturnAlignmentId | Gets the object id of curb return alignment.
CurbReturnProfileId | Gets the object id of curb return profile.
InAlignmentId | Gets the in alignment.
Name | Gets or sets the name of region.
OutAlignmentId | Gets the out alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class > IntersectionRegion Properties
Legend
Legend
Property
public


IntersectionRegionCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Properties
IntersectionRegionCollection Properties Public Properties
IntersectionRegionCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of IntersectionRegion objects in the collection.
default | Gets the IntersectionRegion object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class > IntersectionRegionCollection Properties
Legend
Legend
Property
public


IntersectionRoad Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Properties
IntersectionRoad Properties Public Properties
IntersectionRoad Properties
Public Properties
Public Property | Description
CenterlineAlignmentId | Gets the object id of Centerline alignment.
CenterlineProfileId | Gets the object id of Centerline profile.
OffsetLeftAlignmentId | Gets the object id of left offset alignment.
OffsetLeftProfileId | Gets the object id of left offset profile.
OffsetRightAlignmentId | Gets the object id of right offset alignment.
OffsetRightProfileId | Gets the object id of right offset profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class > IntersectionRoad Properties
Legend
Legend
Property
public


IntersectionRoadCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Properties
IntersectionRoadCollection Properties Public Properties
IntersectionRoadCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of IntersectionRoad objects in the collection.
default | Gets the IntersectionRoad object at a specified index in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class > IntersectionRoadCollection Properties
Legend
Legend
Property
public


IPoint Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Properties
IPoint Properties Public Properties
IPoint Properties
Public Properties
Public Property | Description
Codes | Gets the roadway codes.
Elevation | Gets or sets the point elevation.
Index | Gets the point index.
Offset | Gets or sets the point offset.
Station | Gets or sets the point station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface > IPoint Properties
Legend
Legend
Property
public


Link Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Properties
Link Properties Public Properties
Link Properties
Public Properties
Public Property | Description
Codes | Get the Corridor codes of a Link.
Index | Get the index of the link.
IsHidden | Gets or sets the boolean value that specifies if the link will be drawn.
Points | Gets the points collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class > Link Properties
Legend
Legend
Property
public


LinkCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Properties
LinkCollection Properties Public Properties
LinkCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of links in the collection.
default | Gets a link from the collection by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class > LinkCollection Properties
Legend
Legend
Property
public


OffsetBaseline Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties
OffsetBaseline Properties Public Properties
OffsetBaseline Properties
Public Properties
Public Property | Description
AlignmentId | Gets the ID of the Alignment this baseline is associated with.
BaselineType | Gets the baseline type.
EndStation | Gets the end station for this baseline.
EndStationOnMainBaseline | Gets the end station on the main baseline.
ProfileId | Gets the ID of the Profile this baseline is associated with.
RelatedOffsetBaselineFeatureLines | Gets related offset Baseline FeatureLines.
StartStation | Gets the starting station for this baseline.
StartStationOnMainBaseline | Gets the start station on the main baseline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class > OffsetBaseline Properties
Legend
Legend
Property
public


OffsetBaselineCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Properties
OffsetBaselineCollection Properties Public Properties
OffsetBaselineCollection Properties
Public Properties
Public Property | Description
CorridorId | Gets the ObjectId of the parent Corridor.
Count | Gets the number of BaseBaseline objects in the collection.
default | Gets a BaseBaseline by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class > OffsetBaselineCollection Properties
Legend
Legend
Property
public


Point Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties
Point Properties Public Properties
Point Properties
Public Properties
Public Property | Description
Codes | Gets the collection of codes associated with this point.
Elevation | Gets or sets the point elevation.
Index | Gets the point index.
IsHidden | Gets or sets the boolean value that specifies if the Point will be drawn.
IsLoopPoint | Gets or sets the Point as a loop point for subsequent subassemblies to attach to.
Offset | Gets or sets the point offset.
Station | Gets or sets the point station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class > Point Properties
Legend
Legend
Property
public


PointCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Properties
PointCollection Properties Public Properties
PointCollection Properties
Public Properties
Public Property | Description
Count | Get the count of shape in the collection
default | Get a point in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class > PointCollection Properties
Legend
Legend
Property
public


SampledSectionLink Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Properties
SampledSectionLink Properties Public Properties
SampledSectionLink Properties
Public Properties
Public Property | Description
EndPointElevation | Gets or sets the line segment ending point elevation.
EndPointOffset | Gets or sets the line segment ending point offset.
EndPointStation | Gets the line segment ending point station.
StartPointElevation | Gets the line segment starting point elevation.
StartPointOffset | Gets the line segment starting point offset.
StartPointStation | Gets the line segment starting point station.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class > SampledSectionLink Properties
Legend
Legend
Property
public


SampledSectionLinkCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Properties
SampledSectionLinkCollection Properties Public Properties
SampledSectionLinkCollection Properties
Public Properties
Public Property | Description
default | Gets a SampledSectionLink in the collection by index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class > SampledSectionLinkCollection Properties
Legend
Legend
Property
public


Shape Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Properties
Shape Properties Public Properties
Shape Properties
Public Properties
Public Property | Description
Codes | Get the roadway codes of the shape.
Index | Get the index of the shape.
IsHidden | Gets or sets the boolean value that specifies if the shape will be drawn.
Links | Get the roadway links of the shape.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class > Shape Properties
Legend
Legend
Property
public


ShapeCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Properties
ShapeCollection Properties Public Properties
ShapeCollection Properties
Public Properties
Public Property | Description
Count | Get the count of shape in the collection
default | Get a shape in the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class > ShapeCollection Properties
Legend
Legend
Property
public


SlopeElevationTarget Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Properties
SlopeElevationTarget Properties Public Properties
SlopeElevationTarget Properties
Public Properties
Public Property | Description
TargetId | This is TargetId, a member of class SlopeElevationTarget.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class > SlopeElevationTarget Properties
Legend
Legend
Property
public


AssemblyStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Properties
AssemblyStyle Properties Public Properties
AssemblyStyle Properties
Public Properties
Public Property | Description
MarkerStyleAtAssemblyOriginId | Gets the ID of the marker style at the Assembly origin.
MarkerStyleAtMainBaselineId | Gets the ID of the marker style at the Assembly main baseline.
MarkerStyleAtMainBaselineOriginId | Gets the ID of the marker style at the Assembly main baseline origin.
MarkerStyleAtOffsetBaselineId | Gets the ID of the marker style at the Assembly offset baseline.
MarkerStyleAtOffsetBaselineOriginId | Gets the ID of the marker style at the Assembly offset baseline origin.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class > AssemblyStyle Properties
Legend
Legend
Property
public


CodeSetStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Properties
CodeSetStyle Properties Public Properties
CodeSetStyle Properties
Public Properties
Public Property | Description
Count | Gets the code set item count.
default | Indexer.
SubentityStyleType | Set the Corridor Style Type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class > CodeSetStyle Properties
Legend
Legend
Property
public


CodeSetStyleItem Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties
CodeSetStyleItem Properties Public Properties
CodeSetStyleItem Properties
Public Properties
Public Property | Description
Code | Gets or sets the code string.
CodeStyleId | Gets or sets the ID of the code style for this code.
CodeStyleName | Gets or Sets the code style name.
Description | Gets or sets the description for the CodeSetStyleItem.
FeatureLineStyleId | Gets or Sets the feature line style object id.
FeatureLineStyleName | Gets or Sets the feature line style name.
ItemType | Gets the code set style item type.
LabelStyleId | Gets or Sets the label style object id. We can set the label style to "none" as UI did with... more
LabelStyleName | Gets or Sets the label style name.
MaterialAreaFillStyleId | Gets or Sets the object id of the shape style used to fill the material area.
MaterialAreaFillStyleName | Gets or Sets the name of the shape style used to fill the material area.
PayItems | Gets or Sets the payitem list.
RenderMaterialStyleId | Gets or Sets the object id of render material style .
RenderMaterialStyleName | Gets or Sets the name of render material style.
StyleType | Gets the subassembly subentity style type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class > CodeSetStyleItem Properties
Legend
Legend
Property
public


IntersectionStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Properties
IntersectionStyle Properties Public Properties
IntersectionStyle Properties
Public Properties
Public Property | Description
MarkerStyleId | Gets the marker style object id for the intersection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class > IntersectionStyle Properties
Legend
Legend
Property
public


LabelStylesIntersectionRoot Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LabelStylesIntersectionRoot Class > LabelStylesIntersectionRoot Properties
LabelStylesIntersectionRoot Properties Public Properties
LabelStylesIntersectionRoot Properties
Public Properties
Public Property | Description
LocationLabelStyles | Gets the collection of all intersection location label styles.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LabelStylesIntersectionRoot Class > LabelStylesIntersectionRoot Properties
Legend
Legend
Property
public


LinkStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Properties
LinkStyle Properties Public Properties
LinkStyle Properties
Public Properties
Public Property | Description
LinkDisplayStyleModel | Gets the DisplayStyle that specifies such Model display styles as color, linetype, plotstyle, etc.
LinkDisplayStylePlan | Gets the DisplayStyle that specifies such Plan display styles as color, linetype, plotstyle, etc.
StyleType | Gets the style type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class > LinkStyle Properties
Legend
Legend
Property
public


QuantityTakeoffCriteria Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Properties
QuantityTakeoffCriteria Properties Public Properties
QuantityTakeoffCriteria Properties
Public Properties
Public Property | Description
Count | Gets the number of material items.
default | Gets the material item at the given index.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class > QuantityTakeoffCriteria Properties
Legend
Legend
Property
public


QuantityTakeoffCriteriaData Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class > QuantityTakeoffCriteriaData Properties
QuantityTakeoffCriteriaData Properties Public Properties
QuantityTakeoffCriteriaData Properties
Public Properties
Public Property | Description
Condition | Gets or sets the material data condition.
ItemType | Gets the material item data type.
Name | Gets the name of material item data.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class > QuantityTakeoffCriteriaData Properties
Legend
Legend
Property
public


QuantityTakeoffCriteriaItem Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties
QuantityTakeoffCriteriaItem Properties Public Properties
QuantityTakeoffCriteriaItem Properties
Public Properties
Public Property | Description
Count | Gets the number of material items' data count.
CutFactor | Gets or sets the expansion or swell of the cut material.
default | Gets the material item's data at the given index.
FillFactor | Gets or sets the contraction or shrinkage of the fill material.
MaterialName | Gets or sets the material name.
QuantityType | Gets or sets the material quantity type.
ReFillFactor | Gets or sets the usability factor used to calculate how much cut material can be reused as fill.
ShapeStyleId | Gets or Sets the object id of the default style used to display the material in a section view.
ShapeStyleName | Gets or Sets the name of the default style used to display the material in a section view.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class > QuantityTakeoffCriteriaItem Properties
Legend
Legend
Property
public


ShapeStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Properties
ShapeStyle Properties Public Properties
ShapeStyle Properties
Public Properties
Public Property | Description
AreaFillHatchDisplayStyleModel |
AreaFillHatchDisplayStylePlan |
StyleType | Gets the style type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class > ShapeStyle Properties
Legend
Legend
Property
public


SubassemblySubentityStyle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class > SubassemblySubentityStyle Properties
SubassemblySubentityStyle Properties Public Properties
SubassemblySubentityStyle Properties
Public Properties
Public Property | Description
StyleType | Gets the style type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class > SubassemblySubentityStyle Properties
Legend
Legend
Property
public


Subassembly Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties
Subassembly Properties Public Properties
Subassembly Properties
Public Properties
Public Property | Description
AssemblyId | Gets the ID of the Assembly this Subassembly belongs to.
AttachedToOffsetAssembly | Gets a bool value that specifies whether the subassembly is attached to a offset assembly or a main assembly.
CodeSetStyleName | Gets or sets the code set style name.
DefaultLoopInLayoutMode | Gets or sets a flag indicating if the first or last point in the subassembly is used as the loop... more
DefaultLoopOffsetInLayoutMode | Gets or sets the default loop point offset distance for subassembly in layout mode.
GeometryGenerator | Gets or sets the SubassemblyGenerator object that controls how the Subassembly geometry is generated.
HasParentAssembly | Returns true if this Subassembly has a parent Assembly.
HelpCommand | Gets or sets the command to invoke the Subassembly help.
HelpData | Gets or sets help data for the Subassembly.
HelpFile | Gets or sets the file name of the Subassembly help file.
IsDynamic | Returns true if the subassembly dynamically computes its state.
Links | Gets the Links collection.
OffsetToAssembly | Gets a vector value that specifies the offset to the assembly it belongs to in layout mode.
OffsetToBaseline | Gets a vector value that specifies the offset to the assembly or offset assembly it attached in layout mode.
ParamsBool | Gets the Boolean parameters collection.
ParamsDouble | Gets the Double parameters collection.
ParamsLong | Gets the Long parameters collection.
ParamsString | Gets the String parameters collection.
Points | Gets the Points collection.
ResourceModule | Gets or sets the Subassembly resource module file.
Shapes | Gets the Shapes collection.
StyleName | The name of the Subassembly style.
SubassemblyHookTo | Gets the object id of the Subassembly which it hook to
UseEmbeddedProject | Gets or sets whether the Subassembly uses macros in embedded projects.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class > Subassembly Properties
Legend
Legend
Property
public


SubassemblyCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Properties
SubassemblyCollection Properties Public Properties
SubassemblyCollection Properties
Public Properties
Public Property | Description
Count | Gets the number of Subassembly objects in the collection.
default | Gets a Subassembly by name.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class > SubassemblyCollection Properties
Legend
Legend
Property
public


SubassemblyGenerator Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Properties
SubassemblyGenerator Properties Public Properties
SubassemblyGenerator Properties
Public Properties
Public Property | Description
GeometryGenerateMode | Gets or sets the way the Subassembly geometry is generated.
MacroOrClassName | Gets or sets the macro or class name. This is the class name when GeometryGenerateMode is UseDotNet.
ProjectOrAssemblyName | Gets or sets the project or assembly name. This is the assembly name when GeometryGenerateMode is UseDotNet.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class > SubassemblyGenerator Properties
Legend
Legend
Property
public


WidthOffsetTarget Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Properties
WidthOffsetTarget Properties Public Properties
WidthOffsetTarget Properties
Public Properties
Public Property | Description
TargetId | This is TargetId, a member of class WidthOffsetTarget.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class > WidthOffsetTarget Properties
Legend
Legend
Property
public


SettingsAssembly Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Properties
SettingsAssembly Properties Public Properties
SettingsAssembly Properties
Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Styles | Settings to establish the default styles assigned to corridor components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class > SettingsAssembly Properties
Legend
Legend
Property
public


SettingsAssembly::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class > SettingsAssembly::SettingsNameFormat Properties
SettingsAssembly::SettingsNameFormat Properties Public Properties
SettingsAssembly::SettingsNameFormat Properties
Public Properties
Public Property | Description
Assembly | Settings Assembly default name format.
Group | Settings Group default name format.
Offset | Settings Offset default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class > SettingsAssembly::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsAssembly::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class > SettingsAssembly::SettingsStyles Properties
SettingsAssembly::SettingsStyles Properties Public Properties
SettingsAssembly::SettingsStyles Properties
Public Properties
Public Property | Description
Assembly | Settings of Assembly style.
CodeSet | Settings of code set style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class > SettingsAssembly::SettingsStyles Properties
Legend
Legend
Property
public


SettingsCmdAddMaterialVolumeTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Properties
SettingsCmdAddMaterialVolumeTable Properties Public Properties
SettingsCmdAddMaterialVolumeTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddMaterialVolumeTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class > SettingsCmdAddMaterialVolumeTable Properties
Legend
Legend
Property
public


SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties Public Properties
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAddTotalVolumeTable Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Properties
SettingsCmdAddTotalVolumeTable Properties Public Properties
SettingsCmdAddTotalVolumeTable Properties
Public Properties
Public Property | Description
TableCreation | Gets the default setting of table creation for the command AddTotalVolumeTable.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class > SettingsCmdAddTotalVolumeTable Properties
Legend
Legend
Property
public


SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties Public Properties
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties
Public Properties
Public Property | Description
MaximumNumberOfRows | Specifies the maximum number of rows to include per section.
MaximumTablesPerStack | Specifies the maximum number of tables to include in each stack.
SplitTable | Specifies whether a table is split into two or more sections after a specified maximum number of rows has been... more
TableSpacing | Specifies the spacing between tables.
TableStyle | Specifies the style for a table.
TileDirection | Specifies the direction in which the table tiles (Across or Down).


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Properties
Legend
Legend
Property
public


SettingsCmdAssignPayItemToArea Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Properties
SettingsCmdAssignPayItemToArea Properties Public Properties
SettingsCmdAssignPayItemToArea Properties
Public Properties
Public Property | Description
AssignPayItemToAreaOption | Gets the default setting for the command AssignPayItemToArea.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class > SettingsCmdAssignPayItemToArea Properties
Legend
Legend
Property
public


SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties Public Properties
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties
Public Properties
Public Property | Description
ColorForHatch | Specifies the color for hatch.
LayerForHatch | Specifies the layer for hatch.
UseAcadLayerAndColor | Specifies whether to use AutoCAD current layer and color.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Properties
Legend
Legend
Property
public


SettingsCmdComputeMaterials Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Properties
SettingsCmdComputeMaterials Properties Public Properties
SettingsCmdComputeMaterials Properties
Public Properties
Public Property | Description
DefineMaterialOption | Gets the default setting of define material for the command ComputeMaterials.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class > SettingsCmdComputeMaterials Properties
Legend
Legend
Property
public


SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties Public Properties
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties
Public Properties
Public Property | Description
ApplyCurveCorrection | Specifies whether to apply curve correction.
CurveCorrectionTolerance | Specifies the curve correction tolerance.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignFromCorridor Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Properties
SettingsCmdCreateAlignFromCorridor Properties Public Properties
SettingsCmdCreateAlignFromCorridor Properties
Public Properties
Public Property | Description
AlignmentTypeOption | Gets the alignment type options.
CriteriaBasedDesignOptions | Gets the criteria based design options.
ProfileCreationOption | Gets the profile creation options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class > SettingsCmdCreateAlignFromCorridor Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties Public Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties
Public Properties
Public Property | Description
AlignmentType | Specifies the alignment type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties Public Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
DesignSpeed | Gets the default design speed.
DesignSpeedLookupMethod | Gets the default design speed lookup method.
RadiusLookupMethod | Gets the default radius lookup method.
UseCriteriaBasedDesignOption | Gets whether alignments use design criteria by default.
UseDesignChecksOption | Gets whether to associate a design check set with the alignment.
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
Legend
Legend
Property
public


SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties Public Properties
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties
Public Properties
Public Property | Description
CreateProfileFromCorridor | Gets whether a profile is automatically created when creating an alignment from a corridor feature line.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Properties
Legend
Legend
Property
public


SettingsCmdCreateCorridor Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Properties
SettingsCmdCreateCorridor Properties Public Properties
SettingsCmdCreateCorridor Properties
Public Properties
Public Property | Description
AssemblyInsertion | Gets the default settings of assembly insertion.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class > SettingsCmdCreateCorridor Properties
Legend
Legend
Property
public


SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties Public Properties
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties
Public Properties
Public Property | Description
FrequencyAlongCurves | Gets the corridor station placement frequency along the curve portion of an alignment.
FrequencyAlongProfileCurves | Gets the corridor station placement frequency along curve portions of the profile geometry.
FrequencyAlongSpirals | Gets the corridor station placement frequency along the spiral portion of an alignment.
FrequencyAlongTangents | Gets the corridor station placement frequency along the tangent portion of an alignment.
HorizontalGeometryPoints | Gets the corridor station placement frequency along the spiral portion of an alignment.
ProfileGeometryPoints | Gets whether corridor stations are placed at profile geometry points.
ProfileHighLowPoints | Gets whether assemblies are inserted at the high and low points of the profile geometry.
SuperelevationCriticalPoints | Gets whether corridor stations are placed at superelevation critical points.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Properties
Legend
Legend
Property
public


SettingsCmdCreateIntersection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties
SettingsCmdCreateIntersection Properties Public Properties
SettingsCmdCreateIntersection Properties
Public Properties
Public Property | Description
AssemblyInsertion | Gets the default assembly insertion for new intersection
CrossSlopes | Gets the default cross slopes for new intersection
CurbReturnParameters | Gets the default curb return parameters for new intersection
CurbReturnProfileRules | Gets the default curb return profile rules for new intersection
IntersectionOptions | Gets the default intersection options for new intersection
Offsets | Gets the default offsets for new intersection
SecondaryRoadProfileRules | Gets the default secondary road profile rules for new intersection
WideningParameters | Gets the default widening parameters for new intersection


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class > SettingsCmdCreateIntersection Properties
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties Public Properties
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties
Public Properties
Public Property | Description
FrequencyAlongCurves | Specifies the frequency that the intersection object assemblies is inserted for curve segments of the alignment.
FrequencyAlongProfileCurves | Specifies the frequency along stations that intersection object assemblies are inserted for curve segments of the profile.
FrequencyAlongSpirals | Specifies the frequency that the intersection object assemblies is inserted for spiral segments of the alignment.
FrequencyAlongTangents | Specifies the frequency that the intersection object assemblies is inserted for tangent segments of the alignment.
HorizontalGeometryPoints | Specifies whether or not to use horizontal geometry points to define intersection objects.
ProfileGeometryPoints | Specifies whether or not to use profile geometry points to define intersection objects.
ProfileHighLowPoints | Specifies whether or not to use the highest and lowest points of the profile to define intersection objects.
SuperelevationCriticalPoints | Specifies whether or not to use superelevation critical points to define intersection objects.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Properties
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties Public Properties
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties
Public Properties
Public Property | Description
PrimaryRoadLeftCrossSlope | Specifies the cross slope of the left side of the primary road.
PrimaryRoadRightCrossSlope | Specifies the cross slope of the right side of the primary road.
SecondaryRoadLeftCrossSlope | Specifies the cross slope of the left side of the secondary road.
SecondaryRoadRightCrossSlope | Specifies the cross slope of the right side of the secondary road.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Properties
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties Public Properties
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties
Public Properties
Public Property | Description
ChamferFilletLengthAlongIncomingLane | When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s... more
ChamferFilletLengthAlongOutgoingLane | When Chamfer is selected as the curb return type, this option lets you specify the length of the curb return’s... more
CircularFilletRadius | When Circular Fillet is selected as the curb return type, this option lets you specify the radius for the circular... more
CurbReturnType | Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.
LengthOfCurve1 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the first... more
LengthOfCurve3 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the third... more
RadiusOfCurve1 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the first... more
RadiusOfCurve2 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the second... more
RadiusOfCurve3 | When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for the third... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Properties
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties Public Properties
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties
Public Properties
Public Property | Description
DefineCurbReturnProfileBy | Specifies the method that is used to define the curb return profile.
ExtendProfileAlongIncomingLane | Specifies whether or not to extend the curb return profile along the incoming lane of the intersection.
ExtendProfileAlongOutgoingLane | Specifies whether or not to extend the curb return profile along the outgoing lane of the intersection.
LengthToExtendAlongIncomingLane | When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the... more
LengthToExtendAlongOutgoingLane | When Extend Profile Along Incoming Lane is set to yes, this option lets you specify the length to extend the... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Properties
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties Public Properties
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties
Public Properties
Public Property | Description
CreateCurbReturnAlignments | Specifies whether or not to create curb return alignments.
CreateCurbReturnProfiles | Specifies whether or not to create curb return profiles.
CreateIntersectionCorridors | Specifies whether or not to create intersection corridors.
IntersectionType | Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options... more
PrimaryRoadDefaultExitAndEntryLength | Specifies the default length of the primary road as it enters and exits the intersection.
SecondaryRoadDefaultExitAndEntryLength | Specifies the default length of the secondary road as it enters and exits the intersection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Properties
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdOffsets Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Properties
SettingsCmdCreateIntersection::SettingsCmdOffsets Properties Public Properties
SettingsCmdCreateIntersection::SettingsCmdOffsets Properties
Public Properties
Public Property | Description
OffsetLengthOptions | Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are... more
PrimaryRoadLeftOffset | Specifies the elevation of the offset alignment on the left side of the primary road.
PrimaryRoadRightOffset | Specifies the elevation of the offset alignment on the right side of the primary road.
SecondaryRoadLeftOffset | Specifies the elevation of the offset alignment on the left side of the secondary road.
SecondaryRoadRightOffset | Specifies the elevation of the offset alignment on the right side of the secondary road.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class > SettingsCmdCreateIntersection::SettingsCmdOffsets Properties
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties Public Properties
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties
Public Properties
Public Property | Description
ApplyGradeRules | Specifies whether or not to apply grade rules.
DistanceRuleToAdjusttheGrade | Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is... more
DistanceValue | Specifes the distance that is used to adjust the grade for the secondary road profile when Specify Distance is selected... more
MaximumGrade | Specifies the maximum grade that can be used in the profile for the secondary road.
MaximumGradeChange | Specifies the maximum grade change that can be used in the profile for the secondary road.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Properties
Legend
Legend
Property
public


SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties Public Properties
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties
Public Properties
Public Property | Description
LinearTransitionType | When Linear is selected as the Transition Type, this option lets you specify the type of linear transition used for... more
RadiusofCurve1 | When a curve option is selected as the Transition Type, this option lets you specify the radius for the first... more
RadiusofCurve2 | When a curve option is selected as the Transition Type, this option lets you specify the radius for the second... more
RadiusOfReverseCurve | When Curve-Curve - Reverse Curve is selected as the Transition Type, this option lets you specify the radius for the... more
TaperRation | When By Taper Ratio is selected as the Linear Transition Type, this option lets you specify the ratio of the... more
TransitionLength | When By Length is selected as the Linear Transition Type, this option lets you specify the length of the transition... more
TransitionType | Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.
WidenedOffset | Specifies the elevation for the offset alignment that has been widened, at both the entrance to the intersection, and as... more
WideningAtIncomingLane | Specifies whether or not to widen the incoming lane as it enters the intersection.
WideningAtOutgoingLane | Specifies whether or not to widen the outgoing lane as it exits the intersection.
WideningSegmentLength | Specifies the length of the offset alignment that will be widened, at both the entrance to the intersection, and as... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Properties
Legend
Legend
Property
public


SettingsCmdCreateProfileFromCorridor Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Properties
SettingsCmdCreateProfileFromCorridor Properties Public Properties
SettingsCmdCreateProfileFromCorridor Properties
Public Properties
Public Property | Description
CriteriaBasedDesignOptions | Gets the default settings of criteria-based design options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class > SettingsCmdCreateProfileFromCorridor Properties
Legend
Legend
Property
public


SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties Public Properties
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
Public Properties
Public Property | Description
DefaultDesignCheckSet | Gets the default design check set.
UseDesignChecksOption | Gets whether to associate a design check set with the profile.
UseDesignCriteriaFileOption | Gets whether to associate a design criteria file with the profile.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Properties
Legend
Legend
Property
public


SettingsCmdCreateSimpleCorridor Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Properties
SettingsCmdCreateSimpleCorridor Properties Public Properties
SettingsCmdCreateSimpleCorridor Properties
Public Properties
Public Property | Description
AssemblyInsertion | Gets the default settings of assembly insertion.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class > SettingsCmdCreateSimpleCorridor Properties
Legend
Legend
Property
public


SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties Public Properties
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties
Public Properties
Public Property | Description
FrequencyAlongCurves | Gets the corridor station placement frequency along the curve portion of an alignment.
FrequencyAlongProfileCurves | Gets the corridor station placement frequency along curve portions of the profile geometry.
FrequencyAlongSpirals | Gets the corridor station placement frequency along the spiral portion of an alignment.
FrequencyAlongTangents | Gets the corridor station placement frequency along the tangent portion of an alignment.
HorizontalGeometryPoints | Gets whether corridor stations are placed at horizontal geometry points.
ProfileGeometryPoints | Gets whether corridor stations are placed at profile geometry points.
ProfileHighLowPoints | Gets whether assemblies are inserted at the high and low points of the profile geometry.
SuperelevationCriticalPoints | Gets whether corridor stations are placed at superelevation critical points.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Properties
Legend
Legend
Property
public


SettingsCmdCreateSubassemblyTool Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Properties
SettingsCmdCreateSubassemblyTool Properties Public Properties
SettingsCmdCreateSubassemblyTool Properties
Public Properties
Public Property | Description
SubassemblyOptions | Gets the default setting of subassembly option for the command CreateSubassemblyTool.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class > SettingsCmdCreateSubassemblyTool Properties
Legend
Legend
Property
public


SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties Public Properties
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties
Public Properties
Public Property | Description
CurrentSide | Specifies the current side.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Properties
Legend
Legend
Property
public


SettingsCmdCreateSubFromPline Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Properties
SettingsCmdCreateSubFromPline Properties Public Properties
SettingsCmdCreateSubFromPline Properties
Public Properties
Public Property | Description
CreateFromEntities | Gets the default setting of create from entities for the command CreateSubFromPline.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class > SettingsCmdCreateSubFromPline Properties
Legend
Legend
Property
public


SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties Public Properties
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties
Public Properties
Public Property | Description
LinkCreation | Specifies the quantity of subassembly links (None, Single, Multiple) created from the polyline(s).
MidOrdinateDistance | Specifies mid-ordinate distance to approximate curvilinear segments


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Properties
Legend
Legend
Property
public


SettingsCmdFeatureLinesFromCorridor Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Properties
SettingsCmdFeatureLinesFromCorridor Properties Public Properties
SettingsCmdFeatureLinesFromCorridor Properties
Public Properties
Public Property | Description
FeatureLineCreation | Gets the default settings of feature line creation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class > SettingsCmdFeatureLinesFromCorridor Properties
Legend
Legend
Property
public


SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties Public Properties
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties
Public Properties
Public Property | Description
CreateDynamicLink | Gets the create dynamic link setting.
FeatureLineName | Gets whether to specify the name of the feature line.
HorizontalDeviation | Gets the horizontal deviation setting.
InclusionDistance | Gets the inclusion distance setting.
LayerSetting | Gets the layer setting.
SmoothTheFeatureLine | Gets the feature line smoothing setting.
UseFeatureLineStyle | Gets whether to use the feature line style.
WeedingDistance | Gets the weeding distance setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Properties
Legend
Legend
Property
public


SettingsCmdGenerateQuantitiesReport Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Properties
SettingsCmdGenerateQuantitiesReport Properties Public Properties
SettingsCmdGenerateQuantitiesReport Properties
Public Properties
Public Property | Description
DisplayXmlReport | specifies whether to display XML report.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class > SettingsCmdGenerateQuantitiesReport Properties
Legend
Legend
Property
public


SettingsCmdTakeOff Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Properties
SettingsCmdTakeOff Properties Public Properties
SettingsCmdTakeOff Properties
Public Properties
Public Property | Description
ComputeTakeOffOption | Gets the default setting of take off computation for the command TakeOff.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class > SettingsCmdTakeOff Properties
Legend
Legend
Property
public


SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties Public Properties
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties
Public Properties
Public Property | Description
DefaultReportStyle | specifies the default style sheet which is used to format the take off report.
DrawingBasedReportTableFont | Specifies the text font used in drawing-based report table.
IncludeFormulasInReports | specifies whether to include the formulas of pay items in the quantity takeoff report remarks.
LengthComputeType | Specifies the length computation type in the quantity takeoff process.
LimitToAlignmentStation | specifies whether to limit the report extents to a specified alignment station range.
PipeLengthType | Specifies the pipe length type used in the quantity takeoff process.
ReportExtentsType | specifies the extents used when finding entities to participate in the quantity takeoff process.
ReportSelectedPayItemOnly | specifies whether to allow reports to be generated on a subset of pay items which are selected in master pay... more
ReportType | Specifies the report type for quantity takeoff process.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Properties
Legend
Legend
Property
public


SettingsCmdViewEditCorridorSection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Properties
SettingsCmdViewEditCorridorSection Properties Public Properties
SettingsCmdViewEditCorridorSection Properties
Public Properties
Public Property | Description
GridSettings | Gets the default settings of grid settings.
GridTextSettings | Gets the default settings of grid text settings.
ViewEditOptions | Gets the default settings of view/edit options.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class > SettingsCmdViewEditCorridorSection Properties
Legend
Legend
Property
public


SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties Public Properties
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties
Public Properties
Public Property | Description
CenterAxisColor | Gets the Center Axis Color setting.
DisplayCenterAxis | Gets the Display Center Axis setting.
DisplayHorizontalGrid | Gets the Display Horizontal Grid setting.
DisplayVerticalGrid | Gets the Display Vertical Grid setting.
GridColor | Gets the Grid Color setting.
HorizontalGridInterval | Gets the Horizontal Grid Interval setting.
VerticalGridInterval | Gets the Vertical Grid Interval setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Properties
Legend
Legend
Property
public


SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties Public Properties
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties
Public Properties
Public Property | Description
AnnotateCenterAxis | Gets the Annotate Center Axis setting.
TextColor | Gets the Text Color setting.
TextHeightRelativeToScreen | Gets the Text Height Relative to Screen setting.
TextStyle | Gets the Text Style setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Properties
Legend
Legend
Property
public


SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties Public Properties
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties
Public Properties
Public Property | Description
BackClip | Gets the Back Clip setting.
DefaultViewScale | Gets the default view scale setting.
FrontClip | Gets the Front Clip setting.
RebuildOnEdit | Gets the Rebuild On Edit setting.
StationTrackerInMultipleViewports | Gets the Station Tracker in Multiple Viewports setting.
TurnOffUnassociatedLayers | Gets the Turn Off Unassociated Layers setting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Properties
Legend
Legend
Property
public


SettingsCorridor Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Properties
SettingsCorridor Properties Public Properties
SettingsCorridor Properties
Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
RegionHighlightGraphics | Settings corridor highlight region graphics.
Styles | Settings to establish the default styles assigned to corridor components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class > SettingsCorridor Properties
Legend
Legend
Property
public


SettingsCorridor::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties
SettingsCorridor::SettingsNameFormat Properties Public Properties
SettingsCorridor::SettingsNameFormat Properties
Public Properties
Public Property | Description
AlignmentFromFeatureLine | AlignmentFromFeatureLine Style for corridor settings.
Corridor | CorridorName Style for corridor settings.
CorridorBaseline | CorridorBaseline Style for corridor settings.
CorridorRegion | CorridorRegion Style for corridor settings.
CorridorSurface | CorridorSurface Style for corridor settings.
FeatureLine | FeatureLine Style for corridor settings.
ProfileFromFeatureLine | ProfileFromFeatureLine Style for corridor settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class > SettingsCorridor::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsCorridor::SettingsRegionHighlightGraphics Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties
SettingsCorridor::SettingsRegionHighlightGraphics Properties Public Properties
SettingsCorridor::SettingsRegionHighlightGraphics Properties
Public Properties
Public Property | Description
BaselineColor | BaselineColor highlight graphics for corridor settings.
BaselineLineweight | BaselineLineweight highlight graphics for corridor settings.
HighlightBaseline | HighlightBaseline highlight graphics for corridor settings.
HighlightHorizontalTargets | HighlightHorizontalTargets highlight graphics for corridor settings.
HighlightInteriorAssemblies | HighlightInteriorAssemblies highlight graphics for corridor settings.
HighlightRegionBoundary | HighlightRegionBoundary highlight graphics for corridor settings.
HorizontalTargetsColor | HorizontalTargetsColor highlight graphics for corridor settings.
HorizontalTargetsLineweight | HorizontalTargetsLineweight highlight graphics for corridor settings.
InteriorAssembliesColor | InteriorAssembliesColor highlight graphics for corridor settings.
InteriorAssembliesLineweight | InteriorAssembliesLineweight highlight graphics for corridor settings.
RegionBoundaryColor | RegionBoundaryColor highlight graphics for corridor settings.
RegionBoundaryLineweight | RegionBoundaryLineweight highlight graphics for corridor settings.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class > SettingsCorridor::SettingsRegionHighlightGraphics Properties
Legend
Legend
Property
public


SettingsCorridor::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties
SettingsCorridor::SettingsStyles Properties Public Properties
SettingsCorridor::SettingsStyles Properties
Public Properties
Public Property | Description
Alignment | Specifies the default style for an alignment created from the corridor.
AlignmentLabelSet | Specifies the default style for the alignment label sets created from corridors.
Corridor | Specifies the default style for the corridor.
CorridorCodeSet | Specifies the default code set style for corridors.
CorridorSurface | Specifies the default corridor surface style.
FeatureLine | Specifies the default feature line style for the corridor.
Profile | Specifies the default style for a profile created from the corridor.
ProfileLabelSet | Specifies the default profile label set style.
RenderMaterial | Specifies the default render material style for the corridor.
SlopePattern | Specifies the default style for the slope patterns added to corridors.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class > SettingsCorridor::SettingsStyles Properties
Legend
Legend
Property
public


SettingsIntersection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Properties
SettingsIntersection Properties Public Properties
SettingsIntersection Properties
Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
Styles | Settings to establish the default styles assigned to corridor components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class > SettingsIntersection Properties
Legend
Legend
Property
public


SettingsIntersection::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties
SettingsIntersection::SettingsNameFormat Properties Public Properties
SettingsIntersection::SettingsNameFormat Properties
Public Properties
Public Property | Description
CorridorRegion | Settings CorridorRegion default name format.
CurbReturnAlignment | Settings CurbReturnAlignment default name format.
CurbReturnProfile | Settings CurbReturnProfile default name format.
Intersection | Settings Intersection default name format.
IntersectionQuadrant | Settings IntersectionQuadrant default name format.
OffsetAlignment | Settings OffsetAlignment default name format.
OffsetProfile | Settings OffsetProfile default name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class > SettingsIntersection::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsIntersection::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties
SettingsIntersection::SettingsStyles Properties Public Properties
SettingsIntersection::SettingsStyles Properties
Public Properties
Public Property | Description
CurbReturnAlignment | Settings of CurbReturnAlignment style.
CurbReturnAlignmentLabelSet | Settings of CurbReturnAlignmentLabelSet style.
CurbReturnProfile | Settings of CurbReturnProfile style.
CurbReturnProfileLabelSet | Settings of CurbReturnProfileLabelSet style.
Intersection | Settings of Intersection style.
IntersectionLabel | Settings of IntersectionLabel style.
OffsetAlignment | Settings of OffsetAlignment style.
OffsetAlignmentLabelSet | Settings of OffsetAlignmentLabelSet style.
OffsetProfile | Settings of OffsetProfile style.
OffsetProfileLabelSet | Settings of OffsetProfileLabelSet style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class > SettingsIntersection::SettingsStyles Properties
Legend
Legend
Property
public


SettingsQuantityTakeoff Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Properties
SettingsQuantityTakeoff Properties Public Properties
SettingsQuantityTakeoff Properties
Public Properties
Public Property | Description
NameFormat | settings to specify the default name formats for QuantityTakeoff.
Styles | Settings to establish the default styles assigned to QuantityTakeoff components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class > SettingsQuantityTakeoff Properties
Legend
Legend
Property
public


SettingsQuantityTakeoff::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class > SettingsQuantityTakeoff::SettingsNameFormat Properties
SettingsQuantityTakeoff::SettingsNameFormat Properties Public Properties
SettingsQuantityTakeoff::SettingsNameFormat Properties
Public Properties
Public Property | Description
Material | Settings QuantityTakeoff material name format.
MaterialList | Settings QuantityTakeoff material list name format.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class > SettingsQuantityTakeoff::SettingsNameFormat Properties
Legend
Legend
Property
public


SettingsQuantityTakeoff::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class > SettingsQuantityTakeoff::SettingsStyles Properties
SettingsQuantityTakeoff::SettingsStyles Properties Public Properties
SettingsQuantityTakeoff::SettingsStyles Properties
Public Properties
Public Property | Description
MaterialShape | Settings of QuantityTakeoff material shape.
QuantityTakeoffCriteria | Settings of QuantityTakeoff criteria style.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class > SettingsQuantityTakeoff::SettingsStyles Properties
Legend
Legend
Property
public


SettingsSubassembly Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Properties
SettingsSubassembly Properties Public Properties
SettingsSubassembly Properties
Public Properties
Public Property | Description
DefaultStyles | Gets the settings to specify the default styles for subassembly.
NameFormat | Gets the settings to specify the default name formats for subassembly.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class > SettingsSubassembly Properties
Legend
Legend
Property
public


SettingsSubassembly::SettingsDefaultStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsDefaultStyles Class > SettingsSubassembly::SettingsDefaultStyles Properties
SettingsSubassembly::SettingsDefaultStyles Properties Public Properties
SettingsSubassembly::SettingsDefaultStyles Properties
Public Properties
Public Property | Description
CodeSetStyle | Gets the settings to specify the default code set style for subassembly.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsDefaultStyles Class > SettingsSubassembly::SettingsDefaultStyles Properties
Legend
Legend
Property
public


SettingsSubassembly::SettingsNameFormat Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class > SettingsSubassembly::SettingsNameFormat Properties
SettingsSubassembly::SettingsNameFormat Properties Public Properties
SettingsSubassembly::SettingsNameFormat Properties
Public Properties
Public Property | Description
CreateFromEntities | Gets the settings to specify the default name formats for subassembly.
CreateFromMacro | Gets the settings to specify the default name formats for subassembly.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class > SettingsSubassembly::SettingsNameFormat Properties
Legend
Legend
Property
public


CorridorState Properties Public Properties
CorridorState Properties
Public Properties
Public Property | Description
CurrentAlignmentId | Gets the current alignment where Subassembly is being applied.
CurrentAlignmentIsOffsetAlignment | Returns true if current processing state is along an offset alignment.
CurrentAssemblyElevation | Returns elevation difference from profile grade line elevation where current assembly is being applied.
CurrentAssemblyFixedElevation | If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed elevation difference of the offset assembly portion from the... more
CurrentAssemblyFixedOffset | If the CurrentAssemblyOffsetIsFixed property returns True, this property is the fixed offset distance of the offset assembly portion from the... more
CurrentAssemblyId | Gets the ObjectId of the current Assembly being applied.
CurrentAssemblyName | Gets the name of the current Assembly being applied.
CurrentAssemblyOffset | Returns offset from baseline alignment where current assembly is being applied.
CurrentAssemblyOffsetIsFixed | Returns true if current processing state is along offset portion of assembly without offset alignment defined.
CurrentBaselineId | Gets the current baseline alignment where a Subassembly is being applied.
CurrentCorridorId | Gets the OjbectId of the current Corridor being applied.
CurrentCorridorName | Gets the name of the current Corridor being applied.
CurrentElevation | Gets the current elevation.
CurrentOffset | Gets the current offset.
CurrentProfileId | Gets the current profile where Subassembly is being applied.
CurrentStation | Gets the current baseline alignment station where a Subassembly is being applied.
CurrentSubassemblyElevation | Returns the elevation difference from the assembly origin where the current subassembly is being applied.
CurrentSubassemblyId | Gets the ObjectId of the current Subassembly being applied.
CurrentSubassemblyName | Gets the name of the current Subassembly being applied.
CurrentSubassemblyOffset | Returns the offset from assembly origin where the current subassembly is being applied.
LayoutModeDisplayType | Gets or sets the corridor state's display mode.
Links | Gets the collection of links.
Mode | Gets corridor state's mode.
ParamsAlignment | Gets the collection of alignment parameters.
ParamsAlignmentGlobal | ParamsAlignmentGlobal
ParamsBool | Gets the collection of boolean parameters.
ParamsBoolGlobal | ParamsBoolGlobal
ParamsDouble | Gets the collection of double parameters.
ParamsDoubleGlobal | ParamsDoubleGlobal
ParamsElevationTarget | Gets the collection of elevation parameters.
ParamsElevationTargetGlobal | ParamsElevationGlobal
ParamsLong | Gets the collection of long parameters.
ParamsLongGlobal | ParamsLongGlobal
ParamsOffsetTarget | Gets the collection of offset target parameters.
ParamsOffsetTargetGlobal | ParamsOffsetTargetGlobal
ParamsPoint | Gets the collection of marked point parameters.
ParamsPointGlobal | ParamsPointGlobal
ParamsProfile | Gets the collection of profile parameters.
ParamsProfileGlobal | ParamsProfileGlobal
ParamsString | Gets the collection of string parameters.
ParamsStringGlobal | ParamsStringGlobal
ParamsSurface | Gets the collection of surface parameters.
ParamsSurfaceGlobal | ParamsSurfaceGlobal
Points | Gets the collection of points.
ResourceString | Converts a resource id (numeric) to a resource string from the current subassembly's resource module.
Shapes | Gets the collection of shapes.


IParam Properties Public Properties
IParam Properties
Public Properties
Public Property | Description
Access | Gets or sets access permissions for the parameter.
Comment | Gets or sets the comment string for the parameter.
Description | Gets or sets the description for the parameter.
DisplayName | Gets or sets the display name for the parameter.
DisplayOrder | Gets or sets the display order for the parameter.
IsReadOnly | Gets or sets whether the parameter is read-only.
Value | Gets or sets the parameter value.


ParamAlignment Properties Public Properties
ParamAlignment Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamAlignmentCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Properties
ParamAlignmentCollection Properties Public Properties
ParamAlignmentCollection Properties
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamAlignmentCollection Class > ParamAlignmentCollection Properties
Legend
Legend
Property
public


ParamBase Properties Public Properties
ParamBase Properties
Public Properties
Public Property | Description
Access | Gets or sets access permissions for the parameter.
Comment | Gets or sets the comment string for the parameter.
Description | Gets or sets the description for the parameter.
DisplayName | Gets or sets the display name for the parameter.
DisplayOrder | Gets or sets the display order for the parameter.
IsReadOnly | Gets or sets whether the parameter is read-only.
Value | Gets or sets the parameter value.


ParamBool Properties Public Properties
ParamBool Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | The sub-type of the boolean parameter.
Value | Gets or sets the parameter value.


ParamBoolCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Properties
ParamBoolCollection Properties Public Properties
ParamBoolCollection Properties
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamBoolCollection Class > ParamBoolCollection Properties
Legend
Legend
Property
public


ParamCollectionBase Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Properties
ParamCollectionBase Properties Public Properties
ParamCollectionBase Properties
Public Properties
Public Property | Description
Count | Gets the number of objects in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamCollectionBase Template > ParamCollectionBase Properties
Legend
Legend
Property
public


ParamDouble Properties Public Properties
ParamDouble Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | Gets or sets the type information for this parameter.
Value | Gets or sets the parameter value.


ParamDoubleCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Properties
ParamDoubleCollection Properties Public Properties
ParamDoubleCollection Properties
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamDoubleCollection Class > ParamDoubleCollection Properties
Legend
Legend
Property
public


ParamElevationTarget Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties
ParamElevationTarget Properties Public Properties
ParamElevationTarget Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTarget Class > ParamElevationTarget Properties
Legend
Legend
Property
public


ParamElevationTargetCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Properties
ParamElevationTargetCollection Properties Public Properties
ParamElevationTargetCollection Properties
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamElevationTargetCollection Class > ParamElevationTargetCollection Properties
Legend
Legend
Property
public


ParamLong Properties Public Properties
ParamLong Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
TypeInfo | Gets or sets the type information for this parameter.
Value | Gets or sets the parameter value.


ParamLongCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Properties
ParamLongCollection Properties Public Properties
ParamLongCollection Properties
Public Properties
Public Property | Description
Count | This is Count, a member of class ParamLongCollection.
default | This is default, a member of class ParamLongCollection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamLongCollection Class > ParamLongCollection Properties
Legend
Legend
Property
public


ParamOffsetTarget Properties Public Properties
ParamOffsetTarget Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamOffsetTargetCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Properties
ParamOffsetTargetCollection Properties Public Properties
ParamOffsetTargetCollection Properties
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamOffsetTargetCollection Class > ParamOffsetTargetCollection Properties
Legend
Legend
Property
public


ParamPoint Properties Public Properties
ParamPoint Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
Elevation | Gets or sets the elevation associated with the parameter.
IsReadOnly | Read only state for the parameter.
Offset | Gets or sets the offset associated with the parameter.
Station | Gets or sets the station associated with the parameter.
Value | Gets or sets the parameter value.


ParamPointCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Properties
ParamPointCollection Properties Public Properties
ParamPointCollection Properties
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamPointCollection Class > ParamPointCollection Properties
Legend
Legend
Property
public


ParamProfile Properties Public Properties
ParamProfile Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamProfileCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Properties
ParamProfileCollection Properties Public Properties
ParamProfileCollection Properties
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamProfileCollection Class > ParamProfileCollection Properties
Legend
Legend
Property
public


ParamString Properties Public Properties
ParamString Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamStringCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Properties
ParamStringCollection Properties Public Properties
ParamStringCollection Properties
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamStringCollection Class > ParamStringCollection Properties
Legend
Legend
Property
public


ParamSurface Properties Public Properties
ParamSurface Properties
Public Properties
Public Property | Description
Access | Access permissions for the parameter.
Comment | Parameter comment.
Description | Parameter description.
DisplayName | Display name for the parameter.
DisplayOrder | Display order for the parameter.
IsReadOnly | Read only state for the parameter.
Value | Gets or sets the parameter value.


ParamSurfaceCollection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Properties
ParamSurfaceCollection Properties Public Properties
ParamSurfaceCollection Properties
Public Properties
Public Property | Description
Count | The number of parameters in the collection.
default | Gets the default parameter from the collection.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Runtime Namespace > Classes > ParamSurfaceCollection Class > ParamSurfaceCollection Properties
Legend
Legend
Property
public


PipeNetworkState Properties Public Properties
PipeNetworkState Properties
Public Properties
Public Property | Description
CurrentPipeId | Gets the ID of the current pipe in the network.
CurrentStructureId | Gets the ID of the current structure in the network.
IsBreakingPipe | Gets the state if it's breaking a pipe
IsConnectingToStructure | Gets the state if it's connecting to a structure
IsCurrentPartBeingAdd | Gets the state if the current part is being added.
IsInLayoutMode | Returns whether the pipe network is in layout mode.
IsLayoutUpStream | Gets the state if 'upstream' is the current layout flow direction
LastPipeElevation | Gets or sets the elevation of the last pipe in the network.
ParamsBool | Gets a collection of parameters with boolean values associated with the network state.
ParamsDouble | Gets a collection of parameters with double values associated with the network state.
ParamsLong | Gets a collection of parameters with long values associated with the network state.


RuntimeState Properties Public Properties
RuntimeState Properties
Public Properties
Public Property | Description
CurrentMacroName | Gets the current macro name.
CurrentMacroProject | Gets the current macro project.


SettingsAbbreviation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Properties
SettingsAbbreviation Properties Public Properties
SettingsAbbreviation Properties
Public Properties
Public Property | Description
AlignmentGeoPointEntityData | Gets Abbreviation settings of Alignment Geometry Point Entity Data
AlignmentGeoPointText | Gets Abbreviation settings of Alignment Geometry Point Text
GeneralText | Gets Abbreviation settings that are not feature specific.
Profile | Gets Abbreviation settings of Profile
Superelevation | Gets Abbreviation settings of Superelevation


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAbbreviation Class > SettingsAbbreviation Properties
Legend
Legend
Property
public


SettingsAmbient Properties Public Properties
SettingsAmbient Properties
Public Properties
Public Property | Description
Angle | The Angle settings
Area | The Area settings
Coordinate | The Coordinate settings
Dimension | The Dimension settings
Direction | The Direction settings
Distance | The Distance settings
Elevation | The Elevation settings
General | The General settings
Grade | The Grade settings
GradeSlope | The GradeSlope settings
GridCoordinate | The GridCoordinate settings
Labeling | The Labeling settings
LatLong | The LatLong settings
Slope | The Slope settings
Speed | The Speed settings
Station | The Station settings
TransparentCommands | The TransparentCommands settings
Unitless | The Unitless settings
Volume | The Volume settings


SettingsAmbient::SettingsAngle Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsAngle Class > SettingsAmbient::SettingsAngle Properties
SettingsAmbient::SettingsAngle Properties Public Properties
SettingsAmbient::SettingsAngle Properties
Public Properties
Public Property | Description
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsAngle Class > SettingsAmbient::SettingsAngle Properties
Legend
Legend
Property
public


SettingsAmbient::SettingsDirection Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Properties
SettingsAmbient::SettingsDirection Properties Public Properties
SettingsAmbient::SettingsDirection Properties
Public Properties
Public Property | Description
BearingQuadrant | Specifies which bearing quadrant to use.
Capitalization | Specifies how to display direction names.
Direction | Specify how to display directions.
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.
MeasurementType | Specifies how to calculate the direction of a vector.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsDirection Class > SettingsAmbient::SettingsDirection Properties
Legend
Legend
Property
public


SettingsFormatNumber Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsFormatNumber Template > SettingsFormatNumber Properties
SettingsFormatNumber Properties Public Properties
SettingsFormatNumber Properties
Public Properties
Public Property | Description
Format | Specifies the format of the measurement.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsFormatNumber Template > SettingsFormatNumber Properties
Legend
Legend
Property
public


SettingsAmbient::SettingsGeneral Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties
SettingsAmbient::SettingsGeneral Properties Public Properties
SettingsAmbient::SettingsGeneral Properties
Public Properties
Public Property | Description
DrivingDirection | Specifies the direction of traffic on the roadway.
IndependentLayerOn | Specifies whether object display is controlled by layer visibility, This is equivalent to SettingsObjectLayers.ObjectControlledByLayer
NewEntityToolTipState | Specifies whether to display tooltips by default for new objects.
PlottedUnitDisplay | Specifies how to display numbers in interface controls and on the command line.
SaveCommandChangesToSettings | Specifies whether any changes made to the settings during a command are saved for the drawing, even if the setting... more
ShowEventViewer | Specifies whether the Event Viewer is displayed automatically when an event occurs.
ShowToolTips | Specifies whether to display tooltips in the drawing. This setting does not affect tooltips for toolbar icons.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsGeneral Class > SettingsAmbient::SettingsGeneral Properties
Legend
Legend
Property
public


SettingsAmbient::SettingsLabeling Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLabeling Class > SettingsAmbient::SettingsLabeling Properties
SettingsAmbient::SettingsLabeling Properties Public Properties
SettingsAmbient::SettingsLabeling Properties
Public Properties
Public Property | Description
PromptMethod | Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLabeling Class > SettingsAmbient::SettingsLabeling Properties
Legend
Legend
Property
public


SettingsAmbient::SettingsLatLong Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Properties
SettingsAmbient::SettingsLatLong Properties Public Properties
SettingsAmbient::SettingsLatLong Properties
Public Properties
Public Property | Description
Capitalization | Specifies how to display direction names.
Direction | Specifies the format of lat/long labels.
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosForDegrees | Drops leading zeros before values less than 10.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsLatLong Class > SettingsAmbient::SettingsLatLong Properties
Legend
Legend
Property
public


SettingsAmbient::SettingsStation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Properties
SettingsAmbient::SettingsStation Properties Public Properties
SettingsAmbient::SettingsStation Properties
Public Properties
Public Property | Description
DropDecimalForWholeNumbers | Specifies whether to display whole numbers with zeros after decimals: Yes (example: North 90.00), No (example: North 90)
DropLeadingZerosRightOfStationCharacter | Drops leading zeros before the station character for whole number station values.
MinimumDisplayWidth | Specifies the minimum display width for the station value, which allows leading zeros to be added if necessary. For example,... more
StationDelimiterCharacter | Specifies the separator character used to display stations.
StationDelimiterPosition | Specifies the scale to use for major stations.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsStation Class > SettingsAmbient::SettingsStation Properties
Legend
Legend
Property
public


SettingsAmbient::SettingsTransparentCommands Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Properties
SettingsAmbient::SettingsTransparentCommands Properties Public Properties
SettingsAmbient::SettingsTransparentCommands Properties
Public Properties
Public Property | Description
PromptFor3DPoints | Specifies the prompt sequence (X,Y or X, Y, Z) when creating a point in 3D. True (prompt for 3D points),... more
PromptForEastingThenNorthing | Specifies whether commands prompt for the Easting before the Northing: True (Easting first),False (Northing first)
PromptForLongitudeThenLatitude | Specifies whether commands prompt for the Longitude before the Latitude: False (Latitude first),True (Longitude first)
PromptForYBeforeX | Specifies whether commands prompt for the Y coordinate before the X coordinate: True (Y first),False (X first)


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient::SettingsTransparentCommands Class > SettingsAmbient::SettingsTransparentCommands Properties
Legend
Legend
Property
public


SettingsUnitlessNumber Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class > SettingsUnitlessNumber Properties
SettingsUnitlessNumber Properties Public Properties
SettingsUnitlessNumber Properties
Public Properties
Public Property | Description
Precision | Specifies the number of digits to show to the right of the decimal.
Rounding | Specifies how numbers are rounded up or down to the number of decimal places specified in Precision.
Sign | Specifies how to mark numbers as positive or negative.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class > SettingsUnitlessNumber Properties
Legend
Legend
Property
public


SettingsUnitNumber Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsUnitNumber Template > SettingsUnitNumber Properties
SettingsUnitNumber Properties Public Properties
SettingsUnitNumber Properties
Public Properties
Public Property | Description
Unit | Specifies the unit of the measurement.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsUnitNumber Template > SettingsUnitNumber Properties
Legend
Legend
Property
public


TUnit Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template > TUnit Properties
TUnit Properties Public Properties
TUnit Properties
Public Properties
Public Property | Description
Format | Specifies the format of the measurement.
Unit | Specifies the unit of the measurement.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template > TUnit Properties
Legend
Legend
Property
public


SettingsCmdCreateArcByBestFit Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Properties
SettingsCmdCreateArcByBestFit Properties Public Properties
SettingsCmdCreateArcByBestFit Properties
Public Properties
Public Property | Description
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit Class > SettingsCmdCreateArcByBestFit Properties
Legend
Legend
Property
public


SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties Public Properties
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties
Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Properties
Legend
Legend
Property
public


SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties Public Properties
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Properties
Legend
Legend
Property
public


SettingsCmdCreateLineByBestFit Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Properties
SettingsCmdCreateLineByBestFit Properties Public Properties
SettingsCmdCreateLineByBestFit Properties
Public Properties
Public Property | Description
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit Class > SettingsCmdCreateLineByBestFit Properties
Legend
Legend
Property
public


SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties Public Properties
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties
Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Properties
Legend
Legend
Property
public


SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties Public Properties
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Properties
Legend
Legend
Property
public


SettingsCmdCreateParabolaByBestFit Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Properties
SettingsCmdCreateParabolaByBestFit Properties Public Properties
SettingsCmdCreateParabolaByBestFit Properties
Public Properties
Public Property | Description
CurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
RegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit Class > SettingsCmdCreateParabolaByBestFit Properties
Legend
Legend
Property
public


SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties Public Properties
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties
Public Properties
Public Property | Description
MidOrdinateTolerance | Specifies whether to tesselate curve segments if they are included as an input option.
TessellateCurve | Specifies whether to tesselate curve segments if they are included as an input option.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Properties
Legend
Legend
Property
public


SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties Public Properties
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties
Public Properties
Public Property | Description
SplineFitForRegressionAnalysisGraph | Specifies whether the regression graph displays splines on the green line that represents the best fit entity.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Properties
Legend
Legend
Property
public


SettingsCmdMapCheck Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Properties
SettingsCmdMapCheck Properties Public Properties
SettingsCmdMapCheck Properties
Public Properties
Public Property | Description
Mapcheck | Use these settings to specify the default behavior for Mapcheck.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck Class > SettingsCmdMapCheck Properties
Legend
Legend
Property
public


SettingsCmdMapCheck::SettingsCmdMapcheck Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties
SettingsCmdMapCheck::SettingsCmdMapcheck Properties Public Properties
SettingsCmdMapCheck::SettingsCmdMapcheck Properties
Public Properties
Public Property | Description
CurrentMapcheckColor | Specifies the color for the current mapcheck.
CurrentPointofBeginningColor | Specifies the color of the beginning not for a selected mapcheck.
CurrentSideColor | Specifies the color for the current selected side.
DefaultAngleType | Specifies the default type of any angle created using Mapcheck.
DefaultCurveDirection | Specifies the default direction of any curve created using Mapcheck.
DefaultCurveTraverseMethod |
DefaultSideType | Specifies the default type of any side created using Mapcheck.
MapcheckColor | Specifies the color for Mapcheck lines and curves which are not part of the current mapcheck.
UseCommandLineInput | Specifies whether Mapcheck will accept commands from the command line interface. Selecting No causes Mapcheck to accept input only from... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdMapCheck::SettingsCmdMapcheck Class > SettingsCmdMapCheck::SettingsCmdMapcheck Properties
Legend
Legend
Property
public


SettingsCoordinateSystem Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Properties
SettingsCoordinateSystem Properties Public Properties
SettingsCoordinateSystem Properties
Public Properties
Public Property | Description
Category | Gets the coordinate system geographic zone.
Code | Gets the coordinate system code string.
Datum | Gets the abbreviation for the datum on which the coordinate system is based.
Description | Gets the description for the selected zone.
Projection | Gets the projection method, which is the basis of the zone computation.
Unit | Gets the coordinate system unit.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCoordinateSystem Class > SettingsCoordinateSystem Properties
Legend
Legend
Property
public


SettingsDrawing Properties Public Properties
SettingsDrawing Properties
Public Properties
Public Property | Description
AbbreviationsSettings | Gets Abbreviations of Drawing settings.
AmbientSettings | Gets Ambient setting of the drawing.
ApplyTransformSettings | Gets or sets the boolean value that specifies whether to apply the settings for coordinate system zone transformation.
ObjectLayerSettings | Gets the Object layer settings for various objects in AutoCAD Civil 3D. For example, you can specify that you want... more
TransformationSettings | Gets Transformation of Drawing settings.
UnitZoneSettings | Gets UnitZone of Drawing settings.


SettingsGeneral Properties Public Properties
SettingsGeneral Properties
Public Properties
Public Property | Description
Styles | Gets the default styles for general.


SettingsGeneral::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral::SettingsStyles Class > SettingsGeneral::SettingsStyles Properties
SettingsGeneral::SettingsStyles Properties Public Properties
SettingsGeneral::SettingsStyles Properties
Public Properties
Public Property | Description
CurveLabel | Gets the default style to use when inserting Curve labels.
LineLabel | Gets the default style to use when inserting Line labels.
NoteLabel | Gets the default style to use when inserting Note labels.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsGeneral::SettingsStyles Class > SettingsGeneral::SettingsStyles Properties
Legend
Legend
Property
public


SettingsLandXML Properties Public Properties
SettingsLandXML Properties
Public Properties
Public Property | Description
Export | Export settings for landXML.
Import | Import settings for landXML.


SettingsLandXMLExport Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Properties
SettingsLandXMLExport Properties Public Properties
SettingsLandXMLExport Properties
Public Properties
Public Property | Description
AlignmentExport | AlignmentExport settings for LandXML exporting.
Data | Data settings for LandXML exporting.
Identification | Identification settings for LandXML exporting.
ParcelExport | ParcelExport settings for LandXML exporting.
PointExport | PointExport settings for LandXML exporting.
SurfaceExport | SurfaceExport settings for LandXML exporting.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport Class > SettingsLandXMLExport Properties
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsAlignmentExport Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsAlignmentExport Class > SettingsLandXMLExport::SettingsAlignmentExport Properties
SettingsLandXMLExport::SettingsAlignmentExport Properties Public Properties
SettingsLandXMLExport::SettingsAlignmentExport Properties
Public Properties
Public Property | Description
ExportCrossSections | Exports cross section data if sample lines are defined for the alignment.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsAlignmentExport Class > SettingsLandXMLExport::SettingsAlignmentExport Properties
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsData Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsData Class > SettingsLandXMLExport::SettingsData Properties
SettingsLandXMLExport::SettingsData Properties Public Properties
SettingsLandXMLExport::SettingsData Properties
Public Properties
Public Property | Description
AngleDirectionFormat | Specifies the units of the exported angles and directions.
CreateReadOnlyFile | Specifies whether the LandXML file is created as a read-only file. This is done in two places: a tag is... more
ImperialUnits | Specifies how to tag LandXML data when working in Imperial units.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsData Class > SettingsLandXMLExport::SettingsData Properties
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsIdentification Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Properties
SettingsLandXMLExport::SettingsIdentification Properties Public Properties
SettingsLandXMLExport::SettingsIdentification Properties
Public Properties
Public Property | Description
Company | Specifies the creator’s company.
CompanyURL | Specifies the company’s URL.
Creator | Specifies the creator of the LandXML file.
EmailAddress | Specifies the creator’s email address.
WriteIdentificationElements | Specifies whether the identification properties are written to the LandXML file.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsIdentification Class > SettingsLandXMLExport::SettingsIdentification Properties
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsParcelExport Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsParcelExport Class > SettingsLandXMLExport::SettingsParcelExport Properties
SettingsLandXMLExport::SettingsParcelExport Properties Public Properties
SettingsLandXMLExport::SettingsParcelExport Properties
Public Properties
Public Property | Description
ParcelDirection | Specifies the direction from the parcel start point for exporting parcel segments. Parcel segments are exported in sequence in either... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsParcelExport Class > SettingsLandXMLExport::SettingsParcelExport Properties
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsPointExport Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Properties
SettingsLandXMLExport::SettingsPointExport Properties Public Properties
SettingsLandXMLExport::SettingsPointExport Properties
Public Properties
Public Property | Description
CodeAttribute | Specifies the field that is used for the ‘code’ attribute in the LandXML file.
DescAttribute | Specifies the field that is used for the ‘desc’ attribute in the LandXML file
ExportDescriptionKeys | Specifies whether the description key definitions are exported. Select On to export all description key definitions in the drawing. If... more
ExportPointReferences | Specifies whether to export point references. Point references substitute a known point name instead of using northing and easting coordinates.... more
PointReferenceTolerance | Specifies the tolerance value for point references.
SkipFullWhenSameAsRaw | Specifies whether to export the full description if it is the same as the raw description.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsPointExport Class > SettingsLandXMLExport::SettingsPointExport Properties
Legend
Legend
Property
public


SettingsLandXMLExport::SettingsSurfaceExport Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsSurfaceExport Class > SettingsLandXMLExport::SettingsSurfaceExport Properties
SettingsLandXMLExport::SettingsSurfaceExport Properties Public Properties
SettingsLandXMLExport::SettingsSurfaceExport Properties
Public Properties
Public Property | Description
SurfaceData | Specifies how to export the surface data.
Watersheds | Exports both the points and the surface faces, if available. Creates the surface information from the face edges and creates... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLExport::SettingsSurfaceExport Class > SettingsLandXMLExport::SettingsSurfaceExport Properties
Legend
Legend
Property
public


SettingsLandXMLImport Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties
SettingsLandXMLImport Properties Public Properties
SettingsLandXMLImport Properties
Public Properties
Public Property | Description
ConflictResolution | ConflictResolution settings for LandXML importing.
DiameterUnits | DiameterUnits settings for LandXML importing.
PipeNetwork | PipeNetwork settings for LandXML importing.
PointImport | PointImport settings for LandXML importing.
Rotation | Rotation settings for LandXML importing.
SurfaceImport | SurfaceImport settings for LandXML importing.
Translation | Translation settings for LandXML importing.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport Class > SettingsLandXMLImport Properties
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsConflictResolution Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsConflictResolution Class > SettingsLandXMLImport::SettingsConflictResolution Properties
SettingsLandXMLImport::SettingsConflictResolution Properties Public Properties
SettingsLandXMLImport::SettingsConflictResolution Properties
Public Properties
Public Property | Description
ConflictResolution | Specifies how objects with the same name are handled.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsConflictResolution Class > SettingsLandXMLImport::SettingsConflictResolution Properties
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsDiameterUnits Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsDiameterUnits Class > SettingsLandXMLImport::SettingsDiameterUnits Properties
SettingsLandXMLImport::SettingsDiameterUnits Properties Public Properties
SettingsLandXMLImport::SettingsDiameterUnits Properties
Public Properties
Public Property | Description
Imperial | Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source... more
Metric | Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsDiameterUnits Class > SettingsLandXMLImport::SettingsDiameterUnits Properties
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsPipeNetwork Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties
SettingsLandXMLImport::SettingsPipeNetwork Properties Public Properties
SettingsLandXMLImport::SettingsPipeNetwork Properties
Public Properties
Public Property | Description
MatchChannelShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchCircularPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchCircularStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchConnectionStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchEggShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchEllipticalShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchInletOutletStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchRectangleShapedPipesWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
MatchRectangleStructuresWith | Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD Civil 3D.
PartsListForPartFamilySizeMatching | Specifies the pipe network parts list that is used during import to match pipe network part types in a LandXML... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPipeNetwork Class > SettingsLandXMLImport::SettingsPipeNetwork Properties
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsPointImport Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPointImport Class > SettingsLandXMLImport::SettingsPointImport Properties
SettingsLandXMLImport::SettingsPointImport Properties Public Properties
SettingsLandXMLImport::SettingsPointImport Properties
Public Properties
Public Property | Description
PointDescription | Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsPointImport Class > SettingsLandXMLImport::SettingsPointImport Properties
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsRotation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsRotation Class > SettingsLandXMLImport::SettingsRotation Properties
SettingsLandXMLImport::SettingsRotation Properties Public Properties
SettingsLandXMLImport::SettingsRotation Properties
Public Properties
Public Property | Description
Angle | Specifies the angle about the base point where the LandXML data is rotated.
Direction | Specifies the direction of rotation.
Rotate | Specifies whether to rotate data when importing it from the LandXML file.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsRotation Class > SettingsLandXMLImport::SettingsRotation Properties
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsSurfaceImport Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Properties
SettingsLandXMLImport::SettingsSurfaceImport Properties Public Properties
SettingsLandXMLImport::SettingsSurfaceImport Properties
Public Properties
Public Property | Description
ConvertSurveyFootToInternationalFoot | Specifies whether to convert survey foot to international foot.
CreateSnapshotAfterImport | After importing surface data, a snapshot can automatically be created. By creating a snapshot after importing a LandXML file, AutoCAD... more
CreateSourceDataInDrawing | Imports the surface source data (breaklines, contours, points, and chains) into the drawing as 3D polylines and points.
SurfaceData | Specifies how to import the data.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsSurfaceImport Class > SettingsLandXMLImport::SettingsSurfaceImport Properties
Legend
Legend
Property
public


SettingsLandXMLImport::SettingsTranslation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties
SettingsLandXMLImport::SettingsTranslation Properties Public Properties
SettingsLandXMLImport::SettingsTranslation Properties
Public Properties
Public Property | Description
BasePointEasting | Specifies the base point easting coordinate from which all import values are translated.
BasePointElevation | Specifies the base point elevation from which all import values are translated.
BasePointNorthing | Specifies the base point northing coordinate from which all import values are translated.
Translate | Specifies whether to translate data to new coordinates when importing the data from the LandXML file.
TranslatedCoordinateEasting | Specifies the easting coordinate value used to translate data from the base point.
TranslatedCoordinateElevation | Specifies the elevation value used to translate data from the base point.
TranslatedCoordinateNorthing | Specifies the northing coordinate value used to translate data from the base point.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsTranslation Class > SettingsLandXMLImport::SettingsTranslation Properties
Legend
Legend
Property
public


SettingsObjectLayer Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Properties
SettingsObjectLayer Properties Public Properties
SettingsObjectLayer Properties
Public Properties
Public Property | Description
LayerId | Specifies the layer on which the object is drawn
LayerName | Specifies the layer on which the object is drawn.
Locked | Specifies whether layer settings are locked for the drawing to prevent overrides for individual objects.
Modifier | Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.
ModifierValue | Specifies the text string to use as the modifier. You can enter an asterisk (*) to include the object name... more
ObjectType | Get the object type.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayer Class > SettingsObjectLayer Properties
Legend
Legend
Property
public


SettingsObjectLayers Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Properties
SettingsObjectLayers Properties Public Properties
SettingsObjectLayers Properties
Public Properties
Public Property | Description
ObjectControlledByLayer | Specifies whether object display is controlled by layer visibility.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsObjectLayers Class > SettingsObjectLayers Properties
Legend
Legend
Property
public


SettingsRoot Properties Public Properties
SettingsRoot Properties
Public Properties
Public Property | Description
AssociateShortcutProjectId | Gets or sets the id of associate shortcut project to this drawing.
DrawingSettings | Gets the Drawing settings.
LandXMLSettings | Gets the LandXML importing/exporting settings.
TagSettings | Gets the tag settings.


SettingsTag Properties Public Properties
SettingsTag Properties
Public Properties
Public Property | Description
Creation | Gets the creation options of TableTag settings.
Renumbering | Gets the renumbering options of TableTag settings.


SettingsTag::SettingsCreation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Properties
SettingsTag::SettingsCreation Properties Public Properties
SettingsTag::SettingsCreation Properties
Public Properties
Public Property | Description
CurvesIncrement | Specifies the difference between numbers in the numbering sequence.
CurvesStartingNumber | Specifies the starting number for new curve tags to be created in the site. The numbering is incremented with creation... more
LinesIncrement | Specifies the difference between numbers in the numbering sequence.
LinesStartingNumber | Specifies the starting number for new lines to be created in the site. The numbering is incremented with creation of... more
SpiralsIncrement | Specifies the difference between numbers in the numbering sequence.
SpiralsStartingNumber | Specifies the starting number for new spiral tags to be created in the site. The numbering is incremented with creation... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsCreation Class > SettingsTag::SettingsCreation Properties
Legend
Legend
Property
public


SettingsTag::SettingsRenumbering Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Properties
SettingsTag::SettingsRenumbering Properties Public Properties
SettingsTag::SettingsRenumbering Properties
Public Properties
Public Property | Description
CurvesIncrement | Specifies the difference between numbers in the numbering sequence.
CurvesStartingNumber | Specifies the starting number for new curve tags to be renumbered.
LinesIncrement | Specifies the difference between numbers in the numbering sequence.
LinesStartingNumber | SettingsRenumbering.
SpiralsIncrement | Specifies the difference between numbers in the numbering sequence.
SpiralsStartingNumber | Specifies the starting number for new spiral tags to be created on alignments in the site. The numbering is incremented... more


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTag::SettingsRenumbering Class > SettingsTag::SettingsRenumbering Properties
Legend
Legend
Property
public


SettingsTransformation Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties
SettingsTransformation Properties Public Properties
SettingsTransformation Properties
Public Properties
Public Property | Description
ApplySeaLevelScaleFactor | Gets or sets the boolean value that specifies whether to apply the settings for curvature correction to survey data so... more
GridReferencePoint | Gets or sets the grid reference point value used to associate local coordinates to grid coordinates.
GridRotationPoint | Gets or sets the grid rotation point that specifies a rotation about the grid reference point.
GridScaleFactor | Gets or sets a positive value for the grid scale factor.
GridScaleFactorComputation | Gets or sets the GridScaleFactorType enum value that specifies the type of scale factor.
LocalReferencePoint | Gets or sets the local reference point value used to associate local coordinates to grid coordinates.
LocalRotationPoint | Gets or sets the local rotation point that specifies a rotation about the local reference point.
RotationToGridAzimuth | Gets or sets the direction of the azimuth for the grid rotation angle in degree units.
RotationToGridNorth | Gets or sets the angle to grid north for the grid rotation angle in degree units.
SeaLevelScaleElevation | Gets or sets the mean elevation value of your project site with respect to the mean sea level.
SpecifyRotationType | Gets or sets an enumeration value that specify the rotation type.
SpheroidRadius | Gets the spheroid radius for the spheroid used by the coordinate system.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsTransformation Class > SettingsTransformation Properties
Legend
Legend
Property
public


SettingsUnitZone Properties Public Properties
SettingsUnitZone Properties
Public Properties
Public Property | Description
AngularUnits | Gets or sets the AngleUnitType enum value that specifies the units in which angles are displayed.
CoordinateSystemCode | Gets the coordinate system code string.
DrawingScale | Gets the plotted size of various annotation-related components, such as label text, ticks, and band heights. If you change the... more
DrawingUnits | Gets the linear unit, either meters or feet, for distances, lengths, widths, and offsets in a drawing.
ImperialToMetricConversion | Gets or sets the foot to meter conversion flag that determines what the unit "foot" means.
MatchAutoCADVariables | Synchronizes AutoCAD settings with Autodesk Civil 3D settings. Deprecated. Gets or sets the boolean value that specifies whether synchronizes AutoCAD... more
ScaleObjectsFromOtherDrawings | Gets or sets the boolean value that specifies whether objects inserted from another drawing will be scaled if necessary to... more


SettingsSurvey Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Properties
SettingsSurvey Properties Public Properties
SettingsSurvey Properties
Public Properties
Public Property | Description
Styles | Gets the default styles for survey features.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class > SettingsSurvey Properties
Legend
Legend
Property
public


SettingsSurvey::SettingsStyles Properties Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class > SettingsSurvey::SettingsStyles Properties
SettingsSurvey::SettingsStyles Properties Public Properties
SettingsSurvey::SettingsStyles Properties
Public Properties
Public Property | Description
Figure | Gets the default style for a survey figure.
Network | Gets the default style for a survey network.


Public Properties

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class > SettingsSurvey::SettingsStyles Properties
Legend
Legend
Property
public


SettingsAmbient Templates Templates
SettingsAmbient Templates
Templates
Template | Description
SettingsFormatNumber | Representing a formattable number's settings, this is the base class for many other formattable number measurement.
SettingsUnitNumber | Representing a unit number's settings, this is the base class for many other unit number based measurement
TUnit | Representing a formattable unit number's settings, this is the base class for many other formattable unit number measurement.


Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
AccelerationUnitType | An enumeration that describes accelleration units.
AlignmentPointType | Defines types of points on an Alignment.
AnchorLocationType | Specifies where to anchor various label annotations.
AnchorPointType | Specifies where to anchor various label annotations.
AngleFormatType | Specifies angle format.
AngleUnitType | Specifies angle units.
AreaUnitType | Specifies area units.
ArrowHeadFitType | An enumeration that defines the arrow head fit type.
ArrowHeadSizeType | An enumeration that defines the arrow head size type.
ArrowHeadType | An enumeration that defines the arrow head type.
BearingQuadrantType | Specifies bearing quadrant type.
BlockAttachmentType | Specifies specifies how block label components are attached.
CapitalizationType | Specifies how direction value text is capitalized.
CurbReturnType | Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.
DecimalCharacterType | Specifies decimal character type.
DimensionAnchorOptionType | An enumeration that specifies the behavior of the anchor dimension.
DimensionAnchorType | Defines the location of the anchor used to position dimension lines for certain profile view labels, such as vertical curve... more
DirectionDisplayType | Specifies display direction.
DirectionNameDisplayType | Specifies direction name display.
DrivingDirectionType | The Autodesk::Civil::DrivingDirectionType enumeration.
DropDecimalWholeType | Specifies decimal rounding.
DropLeadingZeroType | Specifies whether to drop leading zeros.
FlowUnitType | Specifies flow units.
GradeFormatType | Specifies grade format.
GradeSlopeFormatType | Specifies grade slope format.
LabelContentDisplayType | Defines label content display type after it is dragged from its default position.
LabelingPromptType | Specifies labeling prompt.
LabelInsertionType | Specifies label insertion.
LabelInsideCurveType | Defines labels place type, inside or outside a curve.
LabelMaskType | Specifies label mask types.
LabelTextAttachmentType | Enumeration that label text attachment location.
LatLongDirectionType | Specifies latitude / longitude direction.
LayoutModeType | Specifies layout mode.
LeaderAttachmentBehaviorType | An enumeration that specifies the attachment behavior of the leader.
LeaderAttachmentType | Specifies leader attachment location.
LeaderShapeType | Defines the leader shape type.
LeaderTailVisibilityType | An enumeration that specifies the behavior of the leader tail visibility.
LeaderVisibilityType | An enumeration that specifies the behavior of the leader visibility.
LinearUnitType | Specifies linear units.
MaskType | An enumeration that specifies the behavior of a label's background mask.
OrientationReferenceType | Specifies orientation reference.
PlottedUnitDisplayType | Specifies plotted units.
ProfilePointType | Defines types of points on a Profile.
RotationDirType | Specifies rotation direction.
RoundingType | Specifies rounding.
ROWCleanupType | Specifies ROW cleanup.
SignType | Specifies sign.
SlopeFormatType | Specifies slope format.
SpeedUnitType | Specifies speed units.
SpiralType | An enumeration that defines the sprial types.
StationDelimiterCharacterType | Specifies station delimeter character.
StationDelimiterPositionType | Specifies station position.
StationFormatType | Specifies station format.
StructureColumnComponentType | An enumeration that specifies the structure table cell component type.
StyleConflictResolverType | Specifies how to resolve conflicts (the same name for an existing style and a new imported style) when exporting styles... more
SuperelevationPointType | Defines the superelevation critical points type that need to be labeled.
TableSegmentDataType | Defines the type of content in a table column.
TableTitleDirectionType | An enumeration that defines the table title directions.
TextBorderType | Specifies text border types.
TextJustificationType | Specifies text justification.
TransitionInputType | Specify the type of linear transition used for the widening: By Length or By Taper Ratio.
TransitionType | Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.
VectorMeasurementType | Specifies vector measurment.
VolumeUnitType | Specifies volume units.


Enumerations

Legend
Legend
Enumeration


Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
ProductType | The available products types, returned by CivilApplication.ActiveProduct.


Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
LabelType | An enumeration that describes all possible label types that a base label object can be.


Structs, Records, Enums Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums
Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
AxisPosition | Defines profile view, section view axis position.
AxisTickJustificationType | Specifies the position of the tick relative to the axis.
AxisTickType | Defines profile view, section view axis tick type.
AxisTitleLocationType | Specifies the location of the axis title in relation to the view grid.
BandLabelStyleType | Defines the band label style type.
BandSetItemLocationType | Enumerates the location for a band set item.
BandStyleType | Defines the band style type.
BandTickAttributeIdType | Defines the band tick position type.
BandTitleBoxPosition | Defines the band title box postion.
BandTitleTextLocation | Defines the band title text location.
CustomMarkerSuperimposeType | Specifies the custom point style marker as either none, a superimposed circle, a superimposed square, or both superimposed square and... more
CustomMarkerType | Specifies the custom point style marker as either a dot, a blank, two perpendicular lines (plus sign), two x-crossed lines,... more
ExpressionFormatedType | Defines the format type of the expression result.
FeatureLineDisplayStyleProfileType | Defines FeatureLineStyle display style type.
GraphDirectionType | Specifies the direction of the profile in the profile view grid.
GraphTitleJustificationType | Specifies the location of the graph title in relation to the view grid.
GraphTitleLocationType | Specifies the location of the graph title in relation to the view grid.
GridType | Defines clipping options on the profile view or section view grid.
LabelDisplayModeType | The Autodesk::Civil::DatabaseServices::Styles::LabelDisplayModeType enumeration.
LabelStyleComponentType | Defines the label style components type.
LabelStyleType | Defines the label style type.
MarkerDisplayType | Specifies the kind of marker to use: point, custom, symbol, or vertical line.
MarkerOrientationType | Defines how the marker is oriented, for example, to object, to world, or to view.
MarkerSizeType | Defines how the marker is sized, for example, relative to screen, or fixed scale.
markStylePropertyType | The Autodesk::Civil::DatabaseServices::Styles::markStylePropertyType enumeration.
ProjectionBlockDisplayType | An enumeration that defines projection block display type.
ProjectionDisplayStyleProfileType | An enumeration that defines projection display style profile type.
ProjectionDisplayStyleSectionType | An enumeration that defines projection display style section type.
ProjectionEntityDisplayType | An enumeration that defines projection point display type. This enum is only used for AutoCAD point and AutoCAD solid display... more
ReferenceTextComponentSelectedType | The Autodesk::Civil::DatabaseServices::Styles::ReferenceTextComponentSelectedType enumeration.
StaggerLabelType | Defines the grade break label stagger type.
TableDisplayStyleType | An enumeration that defines tab display style type.
TableSortingOrderType | Specifies the table sorting order type.
TableStyleType | Specifies the table style type.
TextForEachComponentSelectedType | The Autodesk::Civil::DatabaseServices::Styles::TextForEachComponentSelectedType enumeration.


Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Structs, Records, Enums
Legend
Legend
Enumeration


Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
AlignmentDesignCheckType | Specifies the kind of alignment design check.
BreaklineElevationType |
CatchmentWatershedObjectType |
CrossSectionShapeType | Specifies cross section shapes.
DesignSpeedLookupMethodType | Specifies design speed lookup methods.
ElevationSourceType |
ElevationToUseType | An enumeration that defines the elevation to use for the crossing breaklines.
FeatureLineLayerSettingType | Defines the layer setting type.
FeatureLineLayerType |
FreeHaulDisplayType | An enumeration that defines how to show the free haul in the graph.
GradingDistanceProjectionType | An enumeration that defines the type of projection for the Distance target.
GradingElevationProjectionType | An enumeration that defines the type of projection for the Elevation target.
GradingInteriorCornerOverlapSolutionType | An enumeration that defines how interior corner projections are cleaned up when the footprint corner has different elevations.
GradingRelativeElevationProjectionType | An enumeration that defines the type of projection for the Relative Elevation target.
GradingSearchOrderType | An enumeration that defines the secarch order for the grading.
GradingSlopeFormatType | An enumeration that defines the target method for the grading
GradingSurfaceProjectionType | An enumeration that defines the type of projection for the Surface target.
GradingTargetType | An enumeration that defines the target method for the grading
HighsideLocationType | Specifies whether to drop leading zeros.
MapcheckDefaultAngleType |
MapcheckDefaultCurveDirectionType |
MapcheckDefaultCurveTraverseMethodType |
MapcheckDefaultSideType |
MassHaulLineDisplayStyleType | An enumeration that defines MassHaulLineStye display style type.
MassHaulLineHatchDisplayStyleType | An enumeration that defines MassHaulLineStye hatch display style type.
MassHaulViewDisplayStyleType | An enumeration that defines masshaul view components type.
MatchLineLabelLocationType | The Autodesk::Civil::Land::MatchLineLabelLocationType enumeration.
ParcelAnalysisType |
ParcelRemainderDistributionType | Defines the parcel remainder distribution type.
ParcelSelectionType | Defines the parcel selection type.
ParcelSolutionType | Defines the parcel solution type.
PipeNetworkPartDisplayType | The Autodesk::Civil::Land::PipeNetworkPartDisplayType enumeration.
PlanViewAlignType |
PointNamesExistType | Specifies how to resolve existing point names on import.
PointNumbersAssignedType | Specifies how to assign point numbers.
PointNumbersExistType | Specifies how to resolve conflicting point numbers.
PointNumbersSuppliedType | Specifies how to number supplied point numbers.
ProfileApplyCurveType | The Autodesk::Civil::Land::ProfileApplyCurveType enumeration.
ProfileCircularVerticalConstraintType |
ProfileCurveType |
ProfileDesignCheckType | Specifies the kind of Profile design check.
ProfileParabolicVerticalConstraintType |
ProfileViewDatumType | #UI Remove public enum class PointCreationPromptType { }; /PROPERTYENUM(PointCreationPrompt);
ProfileViewDisplayNetworkPartsType |
ProfileViewPlotType |
ProfileViewSplitDatumType |
ProfileViewSplitStationType |
ProfileViewStartCornerType |
RadiusLookupMethodType |
RemainderDistributionType |
SectionViewElevationRangeType | Specifies section view elevation ranges.
SheetCreateType |
SheetSetType |
ShoulderMethodType | Specifies shoulder methods.
SlopePatternLengthType | An enumeration that defines the slope pattern length type.
SlopePatternOffsetType | An enumeration that defines the slope pattern offset type.
SlopePatternStartType | An enumeration that defines the slope pattern start type.
SlopePatternSymbolType | An enumeration that defines the slope pattern symbol type.
SuperelevationCorridorType | Specifies superelevation corridor types.
SuperelevationStationRoundingType |
SurfaceBoundaryType | Defines the boundary type.
SurfaceRegionOptionsType |
SurfaceSimplifyType |
SurfaceType |
ViewFrameAngleType |
ViewFrameLabelLocationType | The Autodesk::Civil::Land::ViewFrameLabelLocationType enumeration.
WaterdropObjectType |


Structs, Records, Enums Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums
Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
AlignmentArcConstraintType | Defines the underlying alignment arc entity constraint type. For example, three points, or center radius
AlignmentCreationType | The Autodesk::Civil::Land::DatabaseServices::AlignmentCreationType enumeration.
AlignmentEntityConstraintType | Specifies the underlying alignment entity constraint type.
AlignmentEntityType | Specifies the underlying entity type, for example, tangent, arc, spiral, etc.
AlignmentGeometryPointStationType | Defines types of Stations at geometry points on an alignment.
AlignmentLineConstraintType | Defines the underlying line entity constraint type. For example, two points, or through point.
AlignmentRegionType | Defines alignment regions.
AlignmentSCSConstraintType | Defines the underlying Spiral-Curve-Spiral entity constraint type.
AlignmentSCSCSConstraintType | Defines the underlying Spiral-Curve-Spiral-Curve-Spiral entity constraint type.
AlignmentSCSSCSConstraintType | Defines the underlying Spiral-Curve-Spiral-Spiral-Curve-Spiral entity constraint type.
AlignmentSide | Alignment side enumeration. This enum is used by DistanceToAlignment() to specify on which side of the Alignment to look for... more
AlignmentSpiralConstraintType | Defines the underlying spiral entity constraint type. For example, spiral in radius spiral out, spiral length radius pass point.
AlignmentSSCSSConstraintType | Defines the underlying Spiral-Spiral-Curve-SpiralSpiral entity constraint type.
AlignmentSTSConstraintType | Defines the underlying Spiral-Line-Spiral entity constraint type.
AlignmentSubEntityType | Specifies the sub-entity type, for example, line, arc, spiral, etc.
AlignmentType | The Autodesk::Civil::Land::DatabaseServices::AlignmentType enumeration.
AlignmentUpdateType | The Autodesk::Civil::Land::DatabaseServices::AlignmentUpdateType enumeration.
CurveParamType | Defines the free curve type.
CurveType | Defines the free curve type.
DatumRoundingType | Specifies where to round the vertical split location.
ElevationRangeType | Defines the ways to specify the vertical range of the profile view.
EntityAttachType | Defines the type to attach the entity.
EntityVerticalConstraintType | Specifies the construction constraint type of ProfileEntity, for example, use PassThroughPt1AndPt2 if you create this entity by two fixed... more
HatchCriteriaBoundaryType | Defines the hatch criteria's boundary type.
ProfileEntityConstraintType | Specifies the connection constraint type of ProfileEntity, including fixed(attached to none entity), float(attached to one entity) and free(attached to... more
ProfileEntityType | Specifies the underlying ProfileEntity type, including tangent, circular, symmetric parabola and asymmetric parabola.
ProfileType | Defines the profile type.
ProfileUpdateType | Defines the profile's update mode.
RegionPropertyType | The Autodesk::Civil::Land::DatabaseServices::RegionPropertyType enumeration.
SpiralCurveType | Defines the curve type for a spiral sub-entity.
SpiralDirectionType | Defines the direction of a spiral sub-entity.
SpiralParamType | Defines the type to attch the entity.
SplitStationType | Defines the ways to split profile view.
StationEquationType | Specifies the kind of StationEquation.
StationRangeType | Defines the ways to specify the horizontal range of the profile view.
StationRoundingType | Specifies where to round the horizontal split location.
StationTypes | Defines the possible station types, used by Alignment::GetStationSet().
SubEntityExtensionType | Specifies sub-entity extension type.
SuperElevationCrossSegmentType | Specifies the type of a SuperElevationDataElement cross segment.
SuperElevationTransitionPointType | Specifies the type of a SuperElevationDataElement transition point.
VerticalCurveType | Specifies the geometry type of a ProfileEntity curve, used for three types of parabolic entities.


Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Structs, Records, Enums
Legend
Legend
Enumeration


Structs, Records, Enums Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums
Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
AlignmentDisplayStyleType | Defines AlignmentStyle display style type.
BuildingSiteDisplayStyleType | An enumeration that defines BuildingSiteStyle display style type.
CenterMarkerSizeType | Defines grading style center marker size type.
ColorSchemeType | Defines color scheme type
ContourSmoothingType | Defines how surface contours are smoothed.
GradingDisplayStyleType | Defines grading display style type.
GroupPlotAlignType | Specifies how the section views are aligned.
GroupPlotAreaType | An enumeration that specify the method of plotting section views (either all or by page).
GroupPlotCellSizeType | Specifies how the size of each cell in the array will be determined.
GroupPlotStartCornerType | Specifies the starting corner for plotting the section views.
HorizontalGeometryDisplayStyleType | Defines HorizontalGeometryBandStyle display style type.
ParcelDisplayStyleType | Defines ParcelStyle display style type.
PointDisplay3dType | Specifies how point elevation is displayed.
PointDisplayStyleType | An enumeration that defines PointStyle display style type.
PointMarkerDisplayType | Specifies the kind of marker to use, any of: point, custom, or symbol.
PointSymbolType | Defines the symbology of the point display.
PrecisionRangeType | Defines range precision for some surface styles.
ProfileDataDisplayStyleType | Defines ProfileDataBandStyle display style type.
ProfileDesignCheckCurveType | Design check curve type.
ProfileDisplayStyleProfileType | Defines ProfileStyle display style type.
ProfileViewDisplayStyleType | Defines profile view components type.
SampleLineDisplayStyleType | Defines SampleLineStyle display style type.
ScaleType | Defines how to scale the point marker.
SchematicLineOption | Defines HorizontalGeometryBandStyle schematic line option.
SectionalDataDisplayStyleType | Defines SectionalDataBandStyle display style type.
SectionDataDisplayStyleType | Defines SectionDataBandStyle display style type.
SectionDisplayStyleSectionType | Defines SectionStyle display style type.
SectionSegmentDisplayStyleType | Defines SectionSegmentBandStyle display style type.
SectionViewDisplayStyleType | Defines section view components type.
SectionViewPlotRuleType | Specifies whether to plot the section views by rows or columns.
SheetDisplayStyleType | Defines SheetStyle display style type.
SlopeArrowType | Defines the head style of ArrowType
SuperelevationDataDisplayStyleType | Defines SuperelevationDataBandStyle display style type.
SurfaceDisplay3dType | Defines how to display surface style, whether it is exaggerated, flattened, or displayed at actual elevation levels.
SurfaceDisplayStyleType | Defines surface display style type.
SurfaceDisplayType | Defines how surface objects are to be displayed/rendered.
SurfaceGroupValuesByType | Defines how values are grouped.
VerticalGeometryDisplayStyleType | Defines VerticalGeometryBandStyle display style type.


Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Structs, Records, Enums
Legend
Legend
Enumeration


Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
AbbreviationAlignmentEnhancedType | Defines Abbreviation Alignment Enhanced type.
AbbreviationAlignmentType | Defines Abbreviation Alignment type.
AbbreviationProfileType | Defines Abbreviation Profile type.
AbbreviationSuperelevationType | Defines Abbreviation Superelevation type.
AutomaticManual | Specifies how some properties are assigned point creation.
GeographicCoordinateType | Specifies the order in which geographic coordinates are displayed on the command line during point creation.
GridCoordinateType | Specifies the order in which grid coordinates are displayed on the command line during point creation.
LocalCoordinateType | Specifies the order and format used to display local coordinates on the command line during point creation.
SectionViewAnchorType | Defines types of section view anchors.
TableAnchorType | Defines types of table anchors.
TableLayoutType | Defines table layout directions.
TileDirectionType | Defines tile directions.


Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
DistanceScaleFactorType | The Autodesk::Civil::PipeNetwork::DistanceScaleFactorType enumeration.
NetworkDefaultLayoutCommandType | The Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType enumeration.
PipeSectionLabelPlacementType | The Autodesk::Civil::PipeNetwork::PipeSectionLabelPlacementType enumeration.
StructureProfileLabelPlacementType | The Autodesk::Civil::PipeNetwork::StructureProfileLabelPlacementType enumeration.


Structs, Records, Enums Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums
Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
BoundingShapeType | Specifies bounding shapes for Part objects.
ConnectorPositionType | Specifies the connector position.
DomainType | Specifies a Part domain type.
FlowDirectionMethodType | Specifies the method that is used to determine the flow for a pipe.
FlowDirectionType | Specifies the current flow direction of a pipe.
HoldOnResizeType | Specifies the pipe behavior that occurs when the pipe is automatically resized.
PartCatalogDataType | Specifies the data type of the reserved data.
PartContextType | Specifies the context type, which corresponds to every property of a Part.
PartParamUsageType | Defines the usage of a part catalog parameter.
PartType | Specifies a Part type.
PipeSubEntityType | Specifies the subentity type of a pipe.
StructureControlSumpType | Specifies how a sump should be adjusted.
SweptShapeType | Specifies the swept shape of a pipe.


Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Structs, Records, Enums
Legend
Legend
Enumeration


Structs, Records, Enums Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums
Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
InterferenceDisplayStyleType | Specifies the display style type when the Structure is displayed in plan/model/section view.
InterferenceModelSizeOptionType | Specifies the model size option.
InterferenceModelSizeType | Specifies the size of the sphere in model view.
InterferenceModelType | Specifies the type that will be used to visually identify interferences in model view.
PartDataSourceType | Specifies the source type of part data.
PipeCenterlineType | Specifies the method that will be used to define and draw the dimensions of the pipe centerline.
PipeCenterlineWidthType | Specifies the centerline width type.
PipeDisplayStylePlanType | Specifies the display style type when the pipe is displayed in plan view.
PipeDisplayStyleProfileType | Specifies the display style type when the pipe is displayed in profile view.
PipeDisplayStyleSectionType | Specifies the display style type when the pipe is displayed in section view.
PipeEndSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe ends.
PipeHatchStyleProfileType | Specifies the hatch display style type when the pipe is displayed in profile view.
PipeHatchType | Specifies which components of the pipe shape display a hatch pattern.
PipeNetworkDisplayStyleType | Defines ProfileViewPipeNetworkBandStyle display style type.
PipeStylePropertyType | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePropertyType enumeration.
PipeUserDefinedType | Specifies the user defined type.
PipeWallSizeType | Specifies which components of the pipe shape display a hatch pattern.
StructureDisplayStylePlanType | Specifies the display style type when the Structure is displayed in plan view.
StructureDisplayStyleProfileType | Specifies the display style type when the Structure is displayed in profile view.
StructureDisplayStyleSectionType | Specifies the display style type when the Structure is displayed in section view.
StructureInsertionLocation | Specifies the block insertion laction.
StructureModelViewOptionType | Specifies the dimensions of the structure in model view.
StructurePlanViewType | specifies whether the 2D plan view of the structure style is displayed as an outline of the 3D object, or... more
StructureSimpleSolidType | Specifies the simple shape options.
StructureSizeOptionsType | Specifies the size options type.
StructureStylePropertyType | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePropertyType enumeration.
StructureViewType | Specifies the method that will be used to define and draw the dimensions of the structure in profile or section... more


Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Structs, Records, Enums
Legend
Legend
Enumeration


Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
AssemblyDisplayStyleType | The Autodesk::Civil::Roadway::AssemblyDisplayStyleType enumeration.
LinkCreationType | An enumeration that defines the link creation type.
QuantityTakeoffLengthComputeType | An enumeration that specifies the length computation type in the take off process.
QuantityTakeoffPipeLengthType | An enumeration that specifies the pipe length type in the take off process.
QuantityTakeoffReportExtentType | An enumeration that specifies the extents used when finding entities to participate in the take off process.
QuantityTakeoffReportType | An enumeration that specifies the quantity takeoff report type.
RoadwaySideType | An enumeration that defines the roadway side type.


Structs, Records, Enums Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums
Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
CorridorBaselineType | Enumerates baseline types.
CorridorLinkDisplay | The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDisplay enumeration.
CorridorLinkDrawOverride | The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDrawOverride enumeration.
CorridorSurfaceBoundaryType | Defines CorridorSurfaceBoundary types.
CurbReturnJoiningType | Specifies the method that is used to define the curb return profile.
IntersectionCorridorType | Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options... more
MaterialConditionType | An enumeration that specifies the material condition type.
MaterialItemType | An enumeration that specifies the material item type.
MaterialQuantityType | An enumeration that specifies the material quantity type.
OffsetLengthOption | Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are... more
SideRoadProfileDistanceRuleType | Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is... more
SubassemblyGeometryGenerateMode | Enumerates the way subassembly geometry can be generated.


Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Structs, Records, Enums
Legend
Legend
Enumeration


Structs, Records, Enums Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Structs, Records, Enums
Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
CodeSetStyleItemType | Specifies valid CodeSetStyleItem types.
CorridorDisplayStyleType | The Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorDisplayStyleType enumeration.
ShapeDisplayStyleType | Defines ShapeStyle display style type.
SubassemblySubentityStyleType | The Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyleType enumeration.


Enumerations

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Structs, Records, Enums
Legend
Legend
Enumeration


Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
CorridorError | Corridor error types.
CorridorErrorLevel | Error severity levels for Corridors.
CorridorLayoutModeDisplay | Layout modes for subassemblies.
CorridorMode | Roadway mode (design or layout).
ParamAccessType | Defines access permissions for a parameter.
ParamLogicalNameType | The Autodesk::Civil::Runtime::ParamLogicalNameType enumeration.
ParamScope | Defines the parameter scope.
ParamsOwnerType | Defines the owner type for a parameter.
ParamType | Defines the parameter type.
TypeInfoBool | The Autodesk::Civil::Runtime::TypeInfoBool enumeration.
TypeInfoDouble | The Autodesk::Civil::Runtime::TypeInfoDouble enumeration.
TypeInfoLong | The Autodesk::Civil::Runtime::TypeInfoLong enumeration.


Structs, Records, Enums Enumerations
Structs, Records, Enums
Enumerations
Enumeration | Description
DrawingUnitType | Specifies the linear units (feet or meters) for drawing entities in AutoCAD model space.
GridScaleFactorType | Specifies the type of scale factor.
ImperialToMetricConversionType | Specifies the Imperial to Metric conversion type for the drawing.
LandXMLAngularUnits | Specifies the units of the exported angles and directions.
LandXMLAttributeExportType | Specifies the field that is used for specific attribute in the LandXML file.
LandXMLConflictResolutionType | Specifies how objects with the same name are handled.
LandXMLImperialUnitType | Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source... more
LandXMLLinearUnits | Specifies how to tag LandXML data when working in Imperial units.
LandXMLMetricUnitType | Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source... more
LandXMLPointDescriptionType | Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.
LandXMLSurfaceDataExportType | Specifies how to export the surface data.
LandXMLSurfaceDataImportType | Specifies how to import the data. NoteIf the LandXML surface you intend to import has only breaklines (for example, no... more
MapcheckAngleType | Definition of MapCheck Angle type.
MapcheckCurveDirectionType | Definition of MapCheck Curve Direction type.
MapcheckSideType | Definition of MapCheck side type.
MapcheckTraverseMethodType | Definition of MapCheck Traverse Method type.
ObjectLayerModifierType | Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.
SettingsObjectLayerType | The Autodesk::Civil::Settings::SettingsObjectLayerType enumeration.
SpecifyRotationType | An enumeration that use to specify a rotation about the reference point in one of two ways: specify a rotation... more


Autodesk Namespace Namespaces

Autodesk Namespace
Autodesk Namespace Namespaces
Autodesk Namespace
Namespaces
Namespace | Description
Civil | The Autodesk::Civil namespace.


Autodesk::Civil Namespace Classes
Autodesk::Civil Namespace
Classes
Class | Description
Constant | Constants used by the Civil API.
DesignCheck | The abstract design check class.
DesignCheckCollection | The DesignCheckCollection class.
PropertyAnchorPoint | Property template for label anchor location.
PropertyAngle | Angle property template.
PropertyBlock | Encapsulates a Block name.
PropertyBoolean | Encapsulates a boolean value.
PropertyEnum | Property template for enumerations.
PropertyObjectName | Object name property template.


Classes (AutoDoc Folder)

Legend
Legend
Class


Autodesk::Civil Namespace Namespaces
Autodesk::Civil Namespace
Namespaces
Namespace | Description
ApplicationServices |
DatabaseServices | The Autodesk::Civil::DatabaseServices namespace.
Land | The Autodesk::Civil::Land namespace.
PipeNetwork | The Autodesk::Civil::PipeNetwork namespace.
QTO | The Autodesk::Civil::QTO namespace.
Roadway | The Autodesk::Civil::Roadway namespace.
Runtime | The Autodesk::Civil::Runtime namespace.
Settings | The Autodesk::Civil::Settings namespace.
Survey | The Autodesk::Civil::Survey namespace.


Autodesk::Civil Namespace Structs, Records, Enums
Autodesk::Civil Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
AccelerationUnitType | An enumeration that describes accelleration units.
AlignmentPointType | Defines types of points on an Alignment.
AnchorLocationType | Specifies where to anchor various label annotations.
AnchorPointType | Specifies where to anchor various label annotations.
AngleFormatType | Specifies angle format.
AngleUnitType | Specifies angle units.
AreaUnitType | Specifies area units.
ArrowHeadFitType | An enumeration that defines the arrow head fit type.
ArrowHeadSizeType | An enumeration that defines the arrow head size type.
ArrowHeadType | An enumeration that defines the arrow head type.
BearingQuadrantType | Specifies bearing quadrant type.
BlockAttachmentType | Specifies specifies how block label components are attached.
CapitalizationType | Specifies how direction value text is capitalized.
CurbReturnType | Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.
DecimalCharacterType | Specifies decimal character type.
DimensionAnchorOptionType | An enumeration that specifies the behavior of the anchor dimension.
DimensionAnchorType | Defines the location of the anchor used to position dimension lines for certain profile view labels, such as vertical curve... more
DirectionDisplayType | Specifies display direction.
DirectionNameDisplayType | Specifies direction name display.
DrivingDirectionType | The Autodesk::Civil::DrivingDirectionType enumeration.
DropDecimalWholeType | Specifies decimal rounding.
DropLeadingZeroType | Specifies whether to drop leading zeros.
FlowUnitType | Specifies flow units.
GradeFormatType | Specifies grade format.
GradeSlopeFormatType | Specifies grade slope format.
LabelContentDisplayType | Defines label content display type after it is dragged from its default position.
LabelingPromptType | Specifies labeling prompt.
LabelInsertionType | Specifies label insertion.
LabelInsideCurveType | Defines labels place type, inside or outside a curve.
LabelMaskType | Specifies label mask types.
LabelTextAttachmentType | Enumeration that label text attachment location.
LatLongDirectionType | Specifies latitude / longitude direction.
LayoutModeType | Specifies layout mode.
LeaderAttachmentBehaviorType | An enumeration that specifies the attachment behavior of the leader.
LeaderAttachmentType | Specifies leader attachment location.
LeaderShapeType | Defines the leader shape type.
LeaderTailVisibilityType | An enumeration that specifies the behavior of the leader tail visibility.
LeaderVisibilityType | An enumeration that specifies the behavior of the leader visibility.
LinearUnitType | Specifies linear units.
MaskType | An enumeration that specifies the behavior of a label's background mask.
OrientationReferenceType | Specifies orientation reference.
PlottedUnitDisplayType | Specifies plotted units.
ProfilePointType | Defines types of points on a Profile.
RotationDirType | Specifies rotation direction.
RoundingType | Specifies rounding.
ROWCleanupType | Specifies ROW cleanup.
SignType | Specifies sign.
SlopeFormatType | Specifies slope format.
SpeedUnitType | Specifies speed units.
SpiralType | An enumeration that defines the sprial types.
StationDelimiterCharacterType | Specifies station delimeter character.
StationDelimiterPositionType | Specifies station position.
StationFormatType | Specifies station format.
StructureColumnComponentType | An enumeration that specifies the structure table cell component type.
StyleConflictResolverType | Specifies how to resolve conflicts (the same name for an existing style and a new imported style) when exporting styles... more
SuperelevationPointType | Defines the superelevation critical points type that need to be labeled.
TableSegmentDataType | Defines the type of content in a table column.
TableTitleDirectionType | An enumeration that defines the table title directions.
TextBorderType | Specifies text border types.
TextJustificationType | Specifies text justification.
TransitionInputType | Specify the type of linear transition used for the widening: By Length or By Taper Ratio.
TransitionType | Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse Curve, or Curve - Reverse Curve.
VectorMeasurementType | Specifies vector measurment.
VolumeUnitType | Specifies volume units.


Structs, Records, Enums (AutoDoc Folder)

Legend
Legend
Enumeration


Topics
Autodesk::Civil Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Autodesk::Civil::ApplicationServices Namespace Classes
Autodesk::Civil::ApplicationServices Namespace
Classes
Class | Description
CivilApplication | The CivilApplication class. This is the base class used to access CivilDocument.
CivilDocument | The CivilDocument class. This is the root object for accessing settings, styles, and C3D entities, Alignment etc.


Autodesk::Civil::ApplicationServices Namespace Structs, Records, Enums
Autodesk::Civil::ApplicationServices Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
ProductType | The available products types, returned by CivilApplication.ActiveProduct.


Topics
Autodesk::Civil::ApplicationServices Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy
CivilApplication Class
Class Hierarchy
Autodesk::Civil::ApplicationServices::CivilApplication


Class Hierarchy
CivilDocument Class
Class Hierarchy
Autodesk::Civil::ApplicationServices::CivilDocument


Class Hierarchy
Constant Class
Class Hierarchy
Autodesk::Civil::Constant


Autodesk::Civil::DatabaseServices Namespace Classes
Autodesk::Civil::DatabaseServices Namespace
Classes
Class | Description
AnchorInfo | This is class Autodesk::Civil::DatabaseServices::AnchorInfo.
AutoFeatureLabelGroup | The base class for all label group objects that automatically label a range on a feature.
DBObject | The base class for database entities.
Entity | The base class for entities, such as Feature, Table, Grading, Site, etc.
Feature | Base class for Alignment, FeatureLine, ParcelSegment, and Profile.
FeatureLabel | A base class for feature label classes, such as AlignmentCurveLabel.
GeoEntity | The base class for geometry db entities.
Graph | The base class for graphic entities.
GraphOverride | The base class for graphic override.
Label | The base class for all single-entity label objects.
LabelBase | The base class for all label classes, including single-feature labels (FeatureLabel derived classes) and group labels (LabelGroup derived... more
LabelGroup | The base class for all label group objects, such as AutoFeatureLabelGroup.
LabelGroupSubEntity | A class that represents individual labels in a label group.
LegendTable | A table that displays colors and range values for a surface analysis.
Table | Base class for table objects, such as LegendTable and AlignmentTable.


Autodesk::Civil::DatabaseServices Namespace Interfaces
Autodesk::Civil::DatabaseServices Namespace
Interfaces
Interface | Description
ICommonLabel | The interface ICommonLabel declares properties and methods common to all classes representing labels.
ICommonLabelOptions | The interface ICommonLabelOptions declares common behavioral options on labels.


Interfaces (AutoDoc Folder)

Legend
Legend
Interface


Autodesk::Civil::DatabaseServices Namespace Namespaces
Autodesk::Civil::DatabaseServices Namespace
Namespaces
Namespace | Description
Styles | The Autodesk::Civil::DatabaseServices::Styles namespace.


Autodesk::Civil::DatabaseServices Namespace Structs, Records, Enums
Autodesk::Civil::DatabaseServices Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
LabelType | An enumeration that describes all possible label types that a base label object can be.


Topics
Autodesk::Civil::DatabaseServices Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy
AnchorInfo Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::AnchorInfo


Class Hierarchy
AutoFeatureLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup


Class Hierarchy
DBObject Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::NetworkRule
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartFamily
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartSize


Class Hierarchy
Entity Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
    Autodesk::Civil::DatabaseServices::GeoEntity
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::Table
    Autodesk::Civil::Land::DatabaseServices::Grading
    Autodesk::Civil::Land::DatabaseServices::MassHaulLine
    Autodesk::Civil::Land::DatabaseServices::Parcel
    Autodesk::Civil::Land::DatabaseServices::ProfileProjection
    Autodesk::Civil::Land::DatabaseServices::Site
    Autodesk::Civil::Land::DatabaseServices::Surface
    Autodesk::Civil::PipeNetwork::DatabaseServices::ProfileViewPart
    Autodesk::Civil::Roadway::DatabaseServices::Corridor
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSection
    Autodesk::Civil::Roadway::DatabaseServices::Intersection
    Autodesk::Civil::Survey::DatabaseServices::SurveyNetworkEntity


Class Hierarchy
Feature Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::Alignment
        Autodesk::Civil::Land::DatabaseServices::FeatureLine
        Autodesk::Civil::Land::DatabaseServices::ParcelSegment
        Autodesk::Civil::Land::DatabaseServices::Profile


Class Hierarchy
FeatureLabel Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentCurveLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentPILabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentSpiralLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentTangentLabel
                Autodesk::Civil::Land::DatabaseServices::StationOffsetLabel


Class Hierarchy
GeoEntity Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
        Autodesk::Civil::Land::DatabaseServices::MatchLine
        Autodesk::Civil::Land::DatabaseServices::SampleLine
        Autodesk::Civil::Land::DatabaseServices::SampleLineGroup
        Autodesk::Civil::Land::DatabaseServices::Section
        Autodesk::Civil::Land::DatabaseServices::Sheet
        Autodesk::Civil::Land::DatabaseServices::ViewFrame
        Autodesk::Civil::Land::DatabaseServices::ViewFrameGroup
        Autodesk::Civil::PipeNetwork::DatabaseServices::Interference
        Autodesk::Civil::PipeNetwork::DatabaseServices::InterferenceCheck
        Autodesk::Civil::PipeNetwork::DatabaseServices::Network
        Autodesk::Civil::PipeNetwork::DatabaseServices::Part
        Autodesk::Civil::Roadway::DatabaseServices::Assembly
        Autodesk::Civil::Roadway::DatabaseServices::Subassembly


Class Hierarchy
Graph Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
            Autodesk::Civil::Land::DatabaseServices::MassHaulView
            Autodesk::Civil::Land::DatabaseServices::ProfileView
            Autodesk::Civil::Land::DatabaseServices::SectionView


Class Hierarchy
GraphOverride Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::GraphOverride
    Autodesk::Civil::Land::DatabaseServices::ProfileOverride


Class Hierarchy
ICommonLabel Interface
Class Hierarchy
Autodesk::Civil::DatabaseServices::ICommonLabel
    Autodesk::Civil::DatabaseServices::Label
    Autodesk::Civil::DatabaseServices::LabelGroupSubEntity


Class Hierarchy
ICommonLabelOptions Interface
Class Hierarchy
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::LabelGroupSubEntity


Class Hierarchy
Label Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel


Class Hierarchy
LabelBase Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::Label
        Autodesk::Civil::DatabaseServices::LabelGroup


Class Hierarchy
LabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
            Autodesk::Civil::Land::DatabaseServices::ProfileBandLabelGroup
            Autodesk::Civil::Land::DatabaseServices::SectionBandLabelGroup


Class Hierarchy
LabelGroupSubEntity Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::ICommonLabel
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelGroupSubEntity


Class Hierarchy
LegendTable Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::DatabaseServices::LegendTable


Autodesk::Civil::DatabaseServices::Styles Namespace Classes
Autodesk::Civil::DatabaseServices::Styles Namespace
Classes
Class | Description
AxisStyle | Controls the use of tick marks on the horizontal and vertical axes of the profile view or cross section view.... more
AxisTickStyle | Controls the title location and display on the horizontal and vertical axes of the profile view or cross section view.... more
AxisTitleStyle | The AxisTitleStyle class, which defines the text, text style, size etc. of an axis title.
BandSetItem | Encapsulates a single profile view data band style.
BandSetItemCollection | A collection of BandStyle objects.
BandStyle | Specifies style properties for data bands, the graphic frames that are associated with a profile view object or section view... more
BandStyleCollection | A collection of BandStyle objects.
BandStylesRoot | The root object that contains collections of the various band styles in a document.
BandTickStyle | Specifies the type and location of ticks for profile or section view data bands.
BaseLabelSetItem | The base class for alignment label set items.
BaseLabelSetStyle | The base class for alignment label set styles.
ColumnStyle | Defines column width and value properties for table style objects.
ColumnStyleCollection | A collection of ColumnStyle objects.
Expression | Encapsulates an expression used in label styles.
ExpressionCollection | A collection of Expression objects.
FeatureLineStyle | Specifies default display and other characteristics for feature line features when they are created.
FeatureLineStyleCollection | A collection of FeatureLineStyle objects.
GraphStyle | Specifies format and contents of the title, vertical exaggeration, and grid options for graphs.
GraphTitleStyle | Specifies display characteristics for profile and section view graphs.
GridOptions | Specifies various grid options used by GridStyle.
GridStyle | Specifies display characteristics for profile and section view graph gridlines.
LabelSetStylesRoot | The root object for accessing label set style collections in the database.
LabelStyle | The master label style class, containing feature-specific label styles and associated information such as derived styles.
LabelStyleBase | Base class for label style defaults.
LabelStyleBase::BaseBehavior | The behavior related properties of the default label style.
LabelStyleBase::BaseDraggedStateComponents | The dragged state components related properties of the default label style.
LabelStyleBase::BaseLabel | The label related properties of the default label style.
LabelStyleBase::BaseLeader | The leader related properties of the default label style.
LabelStyleBase::BasePlanReadability | The plan readability related properties of the default label style.
LabelStyleBlockComponent::StyleBlock | Block style settings for label block components.
LabelStyleBlockComponent::StyleGeneral | General style settings for label block components.
LabelStyleCollection | A collection of LabelStyle objects.
LabelStyleDefault::DefaultBehavior | The behavior related properties of the default label style settings.
LabelStyleDefault::DefaultComponents | The component related properties of the default label style settings.
LabelStyleDefault::DefaultDraggedStateComponents | The dragged state components related properties of the default label style settings.
LabelStyleDefault::DefaultLabel | The label related properties of the default label style settings.
LabelStyleDefault::DefaultLeader | The leader related properties of the default label style settings.
LabelStyleDefault::DefaultPlanReadability | The plan readability related properties of the default label style settings.
LabelStyleDirectionArrowComponent::StyleDirectionArrow | Direction arrow style settings for label direction arrow components.
LabelStyleDirectionArrowComponent::StyleGeneral | General style settings for label direction arrow components.
LabelStyleLineComponent::StyleGeneral | General style settings for line labels.
LabelStyleLineComponent::StyleLine | Line style settings for line labels.
LabelStylesNode | Base class for root label style classes, such as LabelStylesAlignmentRoot.
LabelStylesRoot | Root object for accessing all label styles in a CivilDocument.
LabelStyleTextComponent | Specifies the appearance and behavior of text feature labels in the drawing. Controls the appearance of the text itself.
LabelStyleTextComponent::StyleBorder | Border style settings for label text components.
LabelStyleTextComponent::StyleGeneral | General style settings for label text components.
LabelStyleTextComponent::StyleText | Text style settings for label text components.
LabelStyleTickComponent::StyleGeneral | General style settings for label tick components.
LabelStyleTickComponent::StyleTick | Tick style settings for label tick components.
MarkerStyle | Sets the style of a marker. Markers are used to mark locations along Alignment objects or survey figures (SurveyFigure... more
MarkerStyleBase | The base class for marker and point styles.
MarkerStyleCollection | A collection of MarkerStyle objects.
ProjectionProfileOptions | Contains display options and styles for objects projected from a plan view onto a profile view.
ProjectionSectionOptions | Contains display options and styles for objects projected from a plan view onto a section view. Used by ProjectionStyle.... more
ProjectionStyle | Contains display options and styles for objects projected from a plan view onto a section or profile view.
ProjectionStyleCollection | A collection of ProjectionStyle objects.
SegmentColumnStyle | Specifies the advance column style obtained from the Parcel Segment table style or Alignment Segment table style.
StructureColumnComponentData | Specifies the tabel cell component data information.
StructureColumnComponents |
StructureColumnStyle | Specifies the advance column style obtained from the Structure table style.
StyleBase | The base class for all style objects.
StyleCollectionBase | The base class for all style collections.
StylesRoot | The root class for accessing collections of all Civil 3D styles.
TableStyle | Controls the display of tables.
TableStyleCollection | A collection of TableStyle objects.
TableStylesRoot | The root object of all Civil 3D table-related styles.


Autodesk::Civil::DatabaseServices::Styles Namespace Structs, Records, Enums
Autodesk::Civil::DatabaseServices::Styles Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
AxisPosition | Defines profile view, section view axis position.
AxisTickJustificationType | Specifies the position of the tick relative to the axis.
AxisTickType | Defines profile view, section view axis tick type.
AxisTitleLocationType | Specifies the location of the axis title in relation to the view grid.
BandLabelStyleType | Defines the band label style type.
BandSetItemLocationType | Enumerates the location for a band set item.
BandStyleType | Defines the band style type.
BandTickAttributeIdType | Defines the band tick position type.
BandTitleBoxPosition | Defines the band title box postion.
BandTitleTextLocation | Defines the band title text location.
CustomMarkerSuperimposeType | Specifies the custom point style marker as either none, a superimposed circle, a superimposed square, or both superimposed square and... more
CustomMarkerType | Specifies the custom point style marker as either a dot, a blank, two perpendicular lines (plus sign), two x-crossed lines,... more
ExpressionFormatedType | Defines the format type of the expression result.
FeatureLineDisplayStyleProfileType | Defines FeatureLineStyle display style type.
GraphDirectionType | Specifies the direction of the profile in the profile view grid.
GraphTitleJustificationType | Specifies the location of the graph title in relation to the view grid.
GraphTitleLocationType | Specifies the location of the graph title in relation to the view grid.
GridType | Defines clipping options on the profile view or section view grid.
LabelDisplayModeType | The Autodesk::Civil::DatabaseServices::Styles::LabelDisplayModeType enumeration.
LabelStyleComponentType | Defines the label style components type.
LabelStyleType | Defines the label style type.
MarkerDisplayType | Specifies the kind of marker to use: point, custom, symbol, or vertical line.
MarkerOrientationType | Defines how the marker is oriented, for example, to object, to world, or to view.
MarkerSizeType | Defines how the marker is sized, for example, relative to screen, or fixed scale.
markStylePropertyType | The Autodesk::Civil::DatabaseServices::Styles::markStylePropertyType enumeration.
ProjectionBlockDisplayType | An enumeration that defines projection block display type.
ProjectionDisplayStyleProfileType | An enumeration that defines projection display style profile type.
ProjectionDisplayStyleSectionType | An enumeration that defines projection display style section type.
ProjectionEntityDisplayType | An enumeration that defines projection point display type. This enum is only used for AutoCAD point and AutoCAD solid display... more
ReferenceTextComponentSelectedType | The Autodesk::Civil::DatabaseServices::Styles::ReferenceTextComponentSelectedType enumeration.
StaggerLabelType | Defines the grade break label stagger type.
TableDisplayStyleType | An enumeration that defines tab display style type.
TableSortingOrderType | Specifies the table sorting order type.
TableStyleType | Specifies the table style type.
TextForEachComponentSelectedType | The Autodesk::Civil::DatabaseServices::Styles::TextForEachComponentSelectedType enumeration.


Topics
Autodesk::Civil::DatabaseServices::Styles Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisStyle Class
Class Hierarchy
AxisStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::AxisStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTickStyle Class
Class Hierarchy
AxisTickStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::AxisTickStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > AxisTitleStyle Class
Class Hierarchy
AxisTitleStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::AxisTitleStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItem Class
Class Hierarchy
BandSetItem Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItem
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetItem
    Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetItem


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandSetItemCollection Class
Class Hierarchy
BandSetItemCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItemCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetItemCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyle Class
Class Hierarchy
BandStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::HorizontalGeometryBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDataBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionalDataBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionDataBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionSegmentBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SuperelevationDataBandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::VerticalGeometryBandStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeNetworkBandStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStyleCollection Class
Class Hierarchy
BandStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::BandStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandStylesRoot Class
Class Hierarchy
BandStylesRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandStylesRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BandTickStyle Class
Class Hierarchy
BandTickStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandTickStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetItem Class
Class Hierarchy
BaseLabelSetItem Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetItem


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > BaseLabelSetStyle Class
Class Hierarchy
BaseLabelSetStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileLabelSetStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyle Class
Class Hierarchy
ColumnStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ColumnStyle
    Autodesk::Civil::DatabaseServices::Styles::SegmentColumnStyle
    Autodesk::Civil::DatabaseServices::Styles::StructureColumnStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ColumnStyleCollection Class
Class Hierarchy
ColumnStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ColumnStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > Expression Class
Class Hierarchy
Expression Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::Expression


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ExpressionCollection Class
Class Hierarchy
ExpressionCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ExpressionCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyle Class
Class Hierarchy
FeatureLineStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > FeatureLineStyleCollection Class
Class Hierarchy
FeatureLineStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphStyle Class
Class Hierarchy
GraphStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::GraphStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GraphTitleStyle Class
Class Hierarchy
GraphTitleStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::GraphTitleStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridOptions Class
Class Hierarchy
GridOptions Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::GridOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > GridStyle Class
Class Hierarchy
GridStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::GridStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelSetStylesRoot Class
Class Hierarchy
LabelSetStylesRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelSetStylesRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyle Class
Class Hierarchy
LabelStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::LabelStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase Class
Class Hierarchy
LabelStyleBase Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseBehavior Class
Class Hierarchy
LabelStyleBase::BaseBehavior Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BaseBehavior


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseDraggedStateComponents Class
Class Hierarchy
LabelStyleBase::BaseDraggedStateComponents Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BaseDraggedStateComponents


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLabel Class
Class Hierarchy
LabelStyleBase::BaseLabel Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BaseLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BaseLeader Class
Class Hierarchy
LabelStyleBase::BaseLeader Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BaseLeader


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBase::BasePlanReadability Class
Class Hierarchy
LabelStyleBase::BasePlanReadability Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBase::BasePlanReadability


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleBlock Class
Class Hierarchy
LabelStyleBlockComponent::StyleBlock Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBlockComponent::StyleBlock


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleBlockComponent::StyleGeneral Class
Class Hierarchy
LabelStyleBlockComponent::StyleGeneral Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleBlockComponent::StyleGeneral


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleCollection Class
Class Hierarchy
LabelStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultBehavior Class
Class Hierarchy
LabelStyleDefault::DefaultBehavior Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultBehavior


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultComponents Class
Class Hierarchy
LabelStyleDefault::DefaultComponents Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultComponents


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultDraggedStateComponents Class
Class Hierarchy
LabelStyleDefault::DefaultDraggedStateComponents Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultDraggedStateComponents


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLabel Class
Class Hierarchy
LabelStyleDefault::DefaultLabel Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultLeader Class
Class Hierarchy
LabelStyleDefault::DefaultLeader Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultLeader


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDefault::DefaultPlanReadability Class
Class Hierarchy
LabelStyleDefault::DefaultPlanReadability Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDefault::DefaultPlanReadability


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleDirectionArrow Class
Class Hierarchy
LabelStyleDirectionArrowComponent::StyleDirectionArrow Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDirectionArrowComponent::StyleDirectionArrow


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleDirectionArrowComponent::StyleGeneral Class
Class Hierarchy
LabelStyleDirectionArrowComponent::StyleGeneral Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleDirectionArrowComponent::StyleGeneral


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleGeneral Class
Class Hierarchy
LabelStyleLineComponent::StyleGeneral Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleLineComponent::StyleGeneral


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleLineComponent::StyleLine Class
Class Hierarchy
LabelStyleLineComponent::StyleLine Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleLineComponent::StyleLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesNode Class
Class Hierarchy
LabelStylesNode Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::DatabaseServices::Styles::LabelStylesRoot
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesAlignmentRoot
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesMatchLineRoot
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProfileRoot
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesPipeRoot
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesStructureRoot
    Autodesk::Civil::Roadway::DatabaseServices::Styles::LabelStylesIntersectionRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStylesRoot Class
Class Hierarchy
LabelStylesRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::DatabaseServices::Styles::LabelStylesRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent Class
Class Hierarchy
LabelStyleTextComponent Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTextComponent


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleBorder Class
Class Hierarchy
LabelStyleTextComponent::StyleBorder Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTextComponent::StyleBorder


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleGeneral Class
Class Hierarchy
LabelStyleTextComponent::StyleGeneral Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTextComponent::StyleGeneral


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTextComponent::StyleText Class
Class Hierarchy
LabelStyleTextComponent::StyleText Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTextComponent::StyleText


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleGeneral Class
Class Hierarchy
LabelStyleTickComponent::StyleGeneral Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTickComponent::StyleGeneral


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > LabelStyleTickComponent::StyleTick Class
Class Hierarchy
LabelStyleTickComponent::StyleTick Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStyleTickComponent::StyleTick


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyle Class
Class Hierarchy
MarkerStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase
            Autodesk::Civil::DatabaseServices::Styles::MarkerStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleBase Class
Class Hierarchy
MarkerStyleBase Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase
            Autodesk::Civil::DatabaseServices::Styles::MarkerStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::PointStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > MarkerStyleCollection Class
Class Hierarchy
MarkerStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::MarkerStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionProfileOptions Class
Class Hierarchy
ProjectionProfileOptions Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ProjectionProfileOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionSectionOptions Class
Class Hierarchy
ProjectionSectionOptions Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ProjectionSectionOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyle Class
Class Hierarchy
ProjectionStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::ProjectionStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > ProjectionStyleCollection Class
Class Hierarchy
ProjectionStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::ProjectionStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > SegmentColumnStyle Class
Class Hierarchy
SegmentColumnStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ColumnStyle
    Autodesk::Civil::DatabaseServices::Styles::SegmentColumnStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponentData Class
Class Hierarchy
StructureColumnComponentData Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StructureColumnComponentData


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnComponents Class
Class Hierarchy
StructureColumnComponents Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StructureColumnComponents


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StructureColumnStyle Class
Class Hierarchy
StructureColumnStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::ColumnStyle
    Autodesk::Civil::DatabaseServices::Styles::StructureColumnStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleBase Class
Class Hierarchy
StyleBase Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
        Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetStyle
        Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyle
        Autodesk::Civil::DatabaseServices::Styles::LabelStyle
        Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase
        Autodesk::Civil::DatabaseServices::Styles::ProjectionStyle
        Autodesk::Civil::DatabaseServices::Styles::TableStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSet
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteria
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSet
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::MatchLineStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ParcelStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SheetStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceStyle
        Autodesk::Civil::Land::DatabaseServices::Styles::ViewFrameStyle
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyle
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::NetworkRuleSetStyle
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsList
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyle
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyle
        Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteria
        Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StyleCollectionBase Class
Class Hierarchy
StyleCollectionBase Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::BandStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::FeatureLineStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::LabelStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::MarkerStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::ProjectionStyleCollection
    Autodesk::Civil::DatabaseServices::Styles::TableStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSetCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSetCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSetCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyleCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsListCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyleCollection
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyleCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaCollection
    Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > StylesRoot Class
Class Hierarchy
StylesRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StylesRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyle Class
Class Hierarchy
TableStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::TableStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStyleCollection Class
Class Hierarchy
TableStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::DatabaseServices::Styles::TableStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::DatabaseServices Namespace > Autodesk::Civil::DatabaseServices::Styles Namespace > Classes > TableStylesRoot Class
Class Hierarchy
TableStylesRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::TableStylesRoot


Class Hierarchy
Table Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::DatabaseServices::LegendTable
        Autodesk::Civil::Land::DatabaseServices::AlignmentTable
        Autodesk::Civil::Land::DatabaseServices::ParcelSegmentTable
        Autodesk::Civil::Land::DatabaseServices::ParcelTable
        Autodesk::Civil::Land::DatabaseServices::PointTable


Class Hierarchy
DesignCheck Class
Class Hierarchy
Autodesk::Civil::DesignCheck
    Autodesk::Civil::Land::AlignmentDesignCheck
    Autodesk::Civil::Land::ProfileDesignCheck


Class Hierarchy
DesignCheckCollection Template
Class Hierarchy
Autodesk::Civil::DesignCheckCollection


Autodesk::Civil::Land Namespace Classes
Autodesk::Civil::Land Namespace
Classes
Class | Description
AlignmentDesignCheck | The Alignment design check class.
AlignmentDesignCheckCollection | The AlignmentDesignCheckCollection class.
AlignmentDesignCheckRoot | The AlignmentDesignCheckRoot class.
GeometryPointLabelOption | This class controls the selection state of a point type. The class is implemented as a generic that can be... more
GeometryPointSelector | This class encapsulates the functionality to allow selecting and un-selecting point types.
ProfileDesignCheck | The Profile design check class.
ProfileDesignCheckCollection | The ProfileDesignCheckCollection class.
ProfileDesignCheckRoot | The ProfileDesignCheckRoot class.


Autodesk::Civil::Land Namespace Namespaces
Autodesk::Civil::Land Namespace
Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::Land::DatabaseServices namespace.
Settings | The Autodesk::Civil::Land::Settings namespace.


Autodesk::Civil::Land Namespace Structs, Records, Enums
Autodesk::Civil::Land Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
AlignmentDesignCheckType | Specifies the kind of alignment design check.
BreaklineElevationType |
CatchmentWatershedObjectType |
CrossSectionShapeType | Specifies cross section shapes.
DesignSpeedLookupMethodType | Specifies design speed lookup methods.
ElevationSourceType |
ElevationToUseType | An enumeration that defines the elevation to use for the crossing breaklines.
FeatureLineLayerSettingType | Defines the layer setting type.
FeatureLineLayerType |
FreeHaulDisplayType | An enumeration that defines how to show the free haul in the graph.
GradingDistanceProjectionType | An enumeration that defines the type of projection for the Distance target.
GradingElevationProjectionType | An enumeration that defines the type of projection for the Elevation target.
GradingInteriorCornerOverlapSolutionType | An enumeration that defines how interior corner projections are cleaned up when the footprint corner has different elevations.
GradingRelativeElevationProjectionType | An enumeration that defines the type of projection for the Relative Elevation target.
GradingSearchOrderType | An enumeration that defines the secarch order for the grading.
GradingSlopeFormatType | An enumeration that defines the target method for the grading
GradingSurfaceProjectionType | An enumeration that defines the type of projection for the Surface target.
GradingTargetType | An enumeration that defines the target method for the grading
HighsideLocationType | Specifies whether to drop leading zeros.
MapcheckDefaultAngleType |
MapcheckDefaultCurveDirectionType |
MapcheckDefaultCurveTraverseMethodType |
MapcheckDefaultSideType |
MassHaulLineDisplayStyleType | An enumeration that defines MassHaulLineStye display style type.
MassHaulLineHatchDisplayStyleType | An enumeration that defines MassHaulLineStye hatch display style type.
MassHaulViewDisplayStyleType | An enumeration that defines masshaul view components type.
MatchLineLabelLocationType | The Autodesk::Civil::Land::MatchLineLabelLocationType enumeration.
ParcelAnalysisType |
ParcelRemainderDistributionType | Defines the parcel remainder distribution type.
ParcelSelectionType | Defines the parcel selection type.
ParcelSolutionType | Defines the parcel solution type.
PipeNetworkPartDisplayType | The Autodesk::Civil::Land::PipeNetworkPartDisplayType enumeration.
PlanViewAlignType |
PointNamesExistType | Specifies how to resolve existing point names on import.
PointNumbersAssignedType | Specifies how to assign point numbers.
PointNumbersExistType | Specifies how to resolve conflicting point numbers.
PointNumbersSuppliedType | Specifies how to number supplied point numbers.
ProfileApplyCurveType | The Autodesk::Civil::Land::ProfileApplyCurveType enumeration.
ProfileCircularVerticalConstraintType |
ProfileCurveType |
ProfileDesignCheckType | Specifies the kind of Profile design check.
ProfileParabolicVerticalConstraintType |
ProfileViewDatumType | #UI Remove public enum class PointCreationPromptType { }; /PROPERTYENUM(PointCreationPrompt);
ProfileViewDisplayNetworkPartsType |
ProfileViewPlotType |
ProfileViewSplitDatumType |
ProfileViewSplitStationType |
ProfileViewStartCornerType |
RadiusLookupMethodType |
RemainderDistributionType |
SectionViewElevationRangeType | Specifies section view elevation ranges.
SheetCreateType |
SheetSetType |
ShoulderMethodType | Specifies shoulder methods.
SlopePatternLengthType | An enumeration that defines the slope pattern length type.
SlopePatternOffsetType | An enumeration that defines the slope pattern offset type.
SlopePatternStartType | An enumeration that defines the slope pattern start type.
SlopePatternSymbolType | An enumeration that defines the slope pattern symbol type.
SuperelevationCorridorType | Specifies superelevation corridor types.
SuperelevationStationRoundingType |
SurfaceBoundaryType | Defines the boundary type.
SurfaceRegionOptionsType |
SurfaceSimplifyType |
SurfaceType |
ViewFrameAngleType |
ViewFrameLabelLocationType | The Autodesk::Civil::Land::ViewFrameLabelLocationType enumeration.
WaterdropObjectType |


Topics
Autodesk::Civil::Land Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy
AlignmentDesignCheck Class
Class Hierarchy
Autodesk::Civil::DesignCheck
    Autodesk::Civil::Land::AlignmentDesignCheck


Class Hierarchy
AlignmentDesignCheckCollection Class
Class Hierarchy
Autodesk::Civil::Land::AlignmentDesignCheckCollection


Class Hierarchy
AlignmentDesignCheckRoot Class
Class Hierarchy
Autodesk::Civil::Land::AlignmentDesignCheckRoot


Autodesk::Civil::Land::DatabaseServices Namespace Classes
Autodesk::Civil::Land::DatabaseServices Namespace
Classes
Class | Description
Alignment | The Alignment class. Alignment objects can represent centerlines, lanes, shoulders, right-of-ways, or construction baselines.
AlignmentArc | The AlignmentArc class. AlignmentArc derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single AlignmentSubEntityArc... more
AlignmentCurve | The AlignmentCurve class. This is an abstract base class for other Alignment Entity classes, such as AlignmentArc, AlignmentSCS,... more
AlignmentCurveLabel | This class represents an alignment curve label.
AlignmentDesignSpeedLabelGroup | This class represents an alignment design speed label group.
AlignmentEntity | The AlignmentEntity class. This is an abstract class from which AlignmentCurve inherits.
AlignmentEntityCollection | The AlignmentEntity collection class. This class represents the collection of all AlignmentEntity objects that belong to an Alignment.
AlignmentGeometryPointLabelGroup | This class encapsulates the functionality to label a geometry point group in an alignment.
AlignmentLabelGroup | This class represents an alignment label group.
AlignmentLine | The AlignmentLine class. This class represents an AlignmentEntity made up of a single line subentity.
AlignmentMinorStationLabelGroup | This class represents an alignment minor station label group.
AlignmentPILabel | This class represents an alignment tangent intersection label.
AlignmentPILabelGroup |
AlignmentRegion | Represents a segment of an alignment which uses a single assembly.
AlignmentRegionCollection | A collection of AlignmentRegion objects.
AlignmentSCS | The Alignment SpiralCurveSpiral class. This class represents an AlignmentEntity made up of an in spiral subentity, an arc subentity, and... more
AlignmentSCSCS | The Alignment SpiralCurveSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an... more
AlignmentSCSSCS | The Alignment SpiralCurveSpiralSpiralCurveSpiral class. This class represents an AlignmentEntity made up of the following subentities: an in spiral, then an... more
AlignmentSpiral | The AlignmentSpiral Class. AlignmentSpiral derives from the abstract AlignmentCurve class, and represents an AlignmentEntity made up of a single spiral... more
AlignmentSpiralLabel | This class represents an alignment spiral label.
AlignmentSSCSS | The Alignment SpiralSpiralCurveSpiralSpiral class. This class represents an AlignmentEntity made up of the following subentities: spiral, spiral, arc, spiral, spiral.... more
AlignmentStationEquationLabelGroup | This class represents an alignment station equation label group.
AlignmentStationLabelGroup | This class represents an alignment station label group.
AlignmentSTS | The Alignment SpiralTangentSpiral class. This class represents an AlignmentEntity made up of a spiral, then tangent, then spiral subentities.
AlignmentSubEntity | The alignment subentity class. This class represents the basic drawing components that make up an alignment entity.
AlignmentSubEntityArc | The Alignment arc subentity class.
AlignmentSubEntityLine | The AlignmentSubEntityLine class. This class represents the line object in AlignmentEntity objects.
AlignmentSubEntitySpiral | The Alignment spiral subentity class. This class represents spiral object in AlignmentEntity objects.
AlignmentSuperelevationLabelGroup | This class encapsulates the functionality of an alignment super-elevation group label.
AlignmentTable | The AlignmentTable class.
AlignmentTangentLabel | This class represents an alignment tangent label.
AlignmentVerticalGeometryPointLabelGroup | This class represents an alignment vertical geometry point label group.
DesignSpeed | The Alignment DesignSpeed class. Specifies a single design speed used for criteria-based Alignment design.
DesignSpeedCollection | A collection of DesignSpeed objects.
FeatureLine | A feature line is a connected series of points along a corridor created by joining those points from each assembly... more
Grading | The Grading class.
GridSurface | A surface formed from points that lie on a regular grid.
MassHaulLine | A line that displays free haul and overhaul volumes in a mass haul view..
MassHaulView | A mass haul diagram view.
MatchLine | A match line is a straight line that indicate locations in a view frame group where one view frame intersects... more
MaterialSection | The AeccDbMaterialSection wrapper.
Parcel | An object that represents real estate parcels, such as lots in a subdivision, and other features that have closed boundaries... more
ParcelSegment | A parcel segment is a line segment, arc, or AutoCAD entity within a site. When parcel segments form a closed... more
ParcelSegmentTable | A Table associated with a ParcelSegment.
ParcelTable | A table associated with a Parcel.
PointEntity | Encapsulates a COGO point object, with associated information such as elevation, marker display styles, etc.
PointTable | The AeccDbPointScheduleTable wrapper.
PolylineOptions | The PolylineOptions class. This class specifies the options for creating an Alignment using a polyline.
Profile | A record of elevation against distance along a horizontal Alignment or other line. Profiles are used to visualize the terrain... more
ProfileBandLabelGroup | The AeccDbProfileBandLabeling wrapper.
ProfileCircular | The ProfileCircular class. This class represents an ProfileEntity made up of a circular curve.
ProfileCriteria | Critera used by the criteria-based design feature to apply agency-specific standards to a profile.
ProfileCriteriaCollection | The ProfileCriteria collection class represents the collection of all criteria in the hatch area.
ProfileEntity | The abstract class of profile entity. ProfileEntity has four derived classes: ProfileLine, ProfileAsymmetric, ProfileCircular, and ProfileParabolic.
ProfileEntityCollection | The ProfileEntity collection class. This class represents the collection of all ProfileEntity objects that belong to the Profile.
ProfileHatchArea | The ProfilevHatchArea class.
ProfileHatchAreaCollection | The ProfileHatchAreaCollection class represents the collection of all hatch areas in the ProfileView.
ProfileOverride | Object used to change the style or label set for a profile.
ProfileOverrideCollection | The ProfileOverride collection class represents the collection of all profiles listed in the ProfileView.
ProfileParabolaAsymmetric | The ProfileParabolaAsymmetric class. This class represents an ProfileEntity made up of a asymmetric parabola.
ProfileParabolaSymmetric | This class represents an ProfileEntity made up of a symmetric parabola.
ProfileProjection | The AeccDbProfileProjection class.
ProfilePVI | In a profile, the point where the lines formed by two tangent entities meet, whether the entities meet or not... more
ProfilePVICollection | The ProfilePVI collection class represents the collection of all ProfilePVI objects that belong to an Profile.
ProfileTangent | This class represents an ProfileEntity made up of a single tangent.
ProfileView | Manages the graphic display of profile data objects within a drawing. A ProfileView is used to display one or more... more
ProfileViewSplitData | This class represents a split location.
ProfileViewSplitDataCollection | The class provides a collection for the profile view split data.
SampleLine | Lines used for obtaining elevational information from an existing terrain model or surface for creating profiles and cross sections.
SampleLineGroup | Controls a set of related sample lines, the surfaces they sample, and methods for creating cross sections.
SCSCSConstraints | The SCSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Curve-Spiral (AlignmentSCSCS) compound Alignment entities.
SCSSCSConstraints | The SCSSCSConstraints class. This class defines contraints for creating Spiral-Curve-Spiral-Spiral-Curve-Spiral (AlignmentSCSSCS) compound Alignment entities.
Section | Provides views created at a 90 degree angle to a surface or an alignment.
SectionBandLabelGroup | A group of section band labels.
SectionProjection | AutoCAD or AutoCAD Civil 3D objects projected from plan view into a section view.
SectionView | Used to display cross sectional data for both existing and finished ground along a sampled cross section line at any... more
Sheet | A sheet (construction document) object.
Site | The construction site abstraction containing parcels and alignments. Note: Alignments are generally associated with a site. An alignment interacts with... more
Station | The Alignment Station class.
StationEquation | Represents a particular system of renumbering or reordering stations within a portion of an alignment.
StationEquationCollection | A collection of StationEquation objects.
StationOffsetLabel | This class represents a station offset label.
SuperElevationData | The SuperelevationData class. This class is a collection of SuperelevationDataElement objects for an Alignment.
SuperElevationDataElement | Superelevation data element at a particular station.
Surface | The base class for TIN and grid surfaces. A surface is a three-dimensional geometric representation of the surface (TIN or... more
TinSurface | A Triangular Irregular Network (TIN) surface, from points connected together in triangles, and used to interpolate for contours, and to... more
ViewFrame | View frames are rectangular-shaped regions along an alignment that define an area that will be displayed in a sheet.
ViewFrameGroup | Manages a single group of view frames that are displaying consecutive station ranges along the same alignment.


Autodesk::Civil::Land::DatabaseServices Namespace Namespaces
Autodesk::Civil::Land::DatabaseServices Namespace
Namespaces
Namespace | Description
Styles | The Autodesk::Civil::Land::DatabaseServices::Styles namespace.


Autodesk::Civil::Land::DatabaseServices Namespace Structs, Records, Enums
Autodesk::Civil::Land::DatabaseServices Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
AlignmentArcConstraintType | Defines the underlying alignment arc entity constraint type. For example, three points, or center radius
AlignmentCreationType | The Autodesk::Civil::Land::DatabaseServices::AlignmentCreationType enumeration.
AlignmentEntityConstraintType | Specifies the underlying alignment entity constraint type.
AlignmentEntityType | Specifies the underlying entity type, for example, tangent, arc, spiral, etc.
AlignmentGeometryPointStationType | Defines types of Stations at geometry points on an alignment.
AlignmentLineConstraintType | Defines the underlying line entity constraint type. For example, two points, or through point.
AlignmentRegionType | Defines alignment regions.
AlignmentSCSConstraintType | Defines the underlying Spiral-Curve-Spiral entity constraint type.
AlignmentSCSCSConstraintType | Defines the underlying Spiral-Curve-Spiral-Curve-Spiral entity constraint type.
AlignmentSCSSCSConstraintType | Defines the underlying Spiral-Curve-Spiral-Spiral-Curve-Spiral entity constraint type.
AlignmentSide | Alignment side enumeration. This enum is used by DistanceToAlignment() to specify on which side of the Alignment to look for... more
AlignmentSpiralConstraintType | Defines the underlying spiral entity constraint type. For example, spiral in radius spiral out, spiral length radius pass point.
AlignmentSSCSSConstraintType | Defines the underlying Spiral-Spiral-Curve-SpiralSpiral entity constraint type.
AlignmentSTSConstraintType | Defines the underlying Spiral-Line-Spiral entity constraint type.
AlignmentSubEntityType | Specifies the sub-entity type, for example, line, arc, spiral, etc.
AlignmentType | The Autodesk::Civil::Land::DatabaseServices::AlignmentType enumeration.
AlignmentUpdateType | The Autodesk::Civil::Land::DatabaseServices::AlignmentUpdateType enumeration.
CurveParamType | Defines the free curve type.
CurveType | Defines the free curve type.
DatumRoundingType | Specifies where to round the vertical split location.
ElevationRangeType | Defines the ways to specify the vertical range of the profile view.
EntityAttachType | Defines the type to attach the entity.
EntityVerticalConstraintType | Specifies the construction constraint type of ProfileEntity, for example, use PassThroughPt1AndPt2 if you create this entity by two fixed... more
HatchCriteriaBoundaryType | Defines the hatch criteria's boundary type.
ProfileEntityConstraintType | Specifies the connection constraint type of ProfileEntity, including fixed(attached to none entity), float(attached to one entity) and free(attached to... more
ProfileEntityType | Specifies the underlying ProfileEntity type, including tangent, circular, symmetric parabola and asymmetric parabola.
ProfileType | Defines the profile type.
ProfileUpdateType | Defines the profile's update mode.
RegionPropertyType | The Autodesk::Civil::Land::DatabaseServices::RegionPropertyType enumeration.
SpiralCurveType | Defines the curve type for a spiral sub-entity.
SpiralDirectionType | Defines the direction of a spiral sub-entity.
SpiralParamType | Defines the type to attch the entity.
SplitStationType | Defines the ways to split profile view.
StationEquationType | Specifies the kind of StationEquation.
StationRangeType | Defines the ways to specify the horizontal range of the profile view.
StationRoundingType | Specifies where to round the horizontal split location.
StationTypes | Defines the possible station types, used by Alignment::GetStationSet().
SubEntityExtensionType | Specifies sub-entity extension type.
SuperElevationCrossSegmentType | Specifies the type of a SuperElevationDataElement cross segment.
SuperElevationTransitionPointType | Specifies the type of a SuperElevationDataElement transition point.
VerticalCurveType | Specifies the geometry type of a ProfileEntity curve, used for three types of parabolic entities.


Topics
Autodesk::Civil::Land::DatabaseServices Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Alignment Class
Class Hierarchy
Alignment Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::Alignment


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentArc Class
Class Hierarchy
AlignmentArc Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentArc


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurve Class
Class Hierarchy
AlignmentCurve Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentArc
        Autodesk::Civil::Land::DatabaseServices::AlignmentLine
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCS
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCSCS
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCSSCS
        Autodesk::Civil::Land::DatabaseServices::AlignmentSpiral
        Autodesk::Civil::Land::DatabaseServices::AlignmentSSCSS
        Autodesk::Civil::Land::DatabaseServices::AlignmentSTS


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentCurveLabel Class
Class Hierarchy
AlignmentCurveLabel Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentCurveLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentDesignSpeedLabelGroup Class
Class Hierarchy
AlignmentDesignSpeedLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentDesignSpeedLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntity Class
Class Hierarchy
AlignmentEntity Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentEntityCollection Class
Class Hierarchy
AlignmentEntityCollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntityCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentGeometryPointLabelGroup Class
Class Hierarchy
AlignmentGeometryPointLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentGeometryPointLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLabelGroup Class
Class Hierarchy
AlignmentLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentDesignSpeedLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentGeometryPointLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentPILabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationEquationLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentSuperelevationLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentVerticalGeometryPointLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentLine Class
Class Hierarchy
AlignmentLine Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentMinorStationLabelGroup Class
Class Hierarchy
AlignmentMinorStationLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationLabelGroup
                        Autodesk::Civil::Land::DatabaseServices::AlignmentMinorStationLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabel Class
Class Hierarchy
AlignmentPILabel Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentPILabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentPILabelGroup Class
Class Hierarchy
AlignmentPILabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentPILabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegion Class
Class Hierarchy
AlignmentRegion Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentRegion


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentRegionCollection Class
Class Hierarchy
AlignmentRegionCollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentRegionCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCS Class
Class Hierarchy
AlignmentSCS Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCS


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSCS Class
Class Hierarchy
AlignmentSCSCS Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCSCS


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSCSSCS Class
Class Hierarchy
AlignmentSCSSCS Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSCSSCS


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiral Class
Class Hierarchy
AlignmentSpiral Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSpiral


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSpiralLabel Class
Class Hierarchy
AlignmentSpiralLabel Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentSpiralLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSSCSS Class
Class Hierarchy
AlignmentSSCSS Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSSCSS


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationEquationLabelGroup Class
Class Hierarchy
AlignmentStationEquationLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationEquationLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentStationLabelGroup Class
Class Hierarchy
AlignmentStationLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentStationLabelGroup
                        Autodesk::Civil::Land::DatabaseServices::AlignmentMinorStationLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSTS Class
Class Hierarchy
AlignmentSTS Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentCurve
        Autodesk::Civil::Land::DatabaseServices::AlignmentSTS


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntity Class
Class Hierarchy
AlignmentSubEntity Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityArc
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityLine
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntitySpiral


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityArc Class
Class Hierarchy
AlignmentSubEntityArc Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityArc


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntityLine Class
Class Hierarchy
AlignmentSubEntityLine Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSubEntitySpiral Class
Class Hierarchy
AlignmentSubEntitySpiral Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntity
    Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntitySpiral


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentSuperelevationLabelGroup Class
Class Hierarchy
AlignmentSuperelevationLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentSuperelevationLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTable Class
Class Hierarchy
AlignmentTable Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::Land::DatabaseServices::AlignmentTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentTangentLabel Class
Class Hierarchy
AlignmentTangentLabel Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::AlignmentTangentLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > AlignmentVerticalGeometryPointLabelGroup Class
Class Hierarchy
AlignmentVerticalGeometryPointLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::DatabaseServices::AutoFeatureLabelGroup
                Autodesk::Civil::Land::DatabaseServices::AlignmentLabelGroup
                    Autodesk::Civil::Land::DatabaseServices::AlignmentVerticalGeometryPointLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeed Class
Class Hierarchy
DesignSpeed Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::DesignSpeed


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > DesignSpeedCollection Class
Class Hierarchy
DesignSpeedCollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::DesignSpeedCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > FeatureLine Class
Class Hierarchy
FeatureLine Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::FeatureLine
            Autodesk::Civil::Survey::DatabaseServices::SurveyFigure


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Grading Class
Class Hierarchy
Grading Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Grading


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > GridSurface Class
Class Hierarchy
GridSurface Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Surface
        Autodesk::Civil::Land::DatabaseServices::GridSurface


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulLine Class
Class Hierarchy
MassHaulLine Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::MassHaulLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MassHaulView Class
Class Hierarchy
MassHaulView Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
            Autodesk::Civil::Land::DatabaseServices::MassHaulView


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MatchLine Class
Class Hierarchy
MatchLine Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::MatchLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > MaterialSection Class
Class Hierarchy
MaterialSection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Section
            Autodesk::Civil::Land::DatabaseServices::MaterialSection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Parcel Class
Class Hierarchy
Parcel Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Parcel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ParcelSegment Class
Class Hierarchy
ParcelSegment Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::ParcelSegment


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ParcelSegmentTable Class
Class Hierarchy
ParcelSegmentTable Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::Land::DatabaseServices::ParcelSegmentTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ParcelTable Class
Class Hierarchy
ParcelTable Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::Land::DatabaseServices::ParcelTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointEntity Class
Class Hierarchy
PointEntity Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::PointEntity


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PointTable Class
Class Hierarchy
PointTable Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Table
        Autodesk::Civil::Land::DatabaseServices::PointTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > PolylineOptions Class
Class Hierarchy
PolylineOptions Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::PolylineOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Profile Class
Class Hierarchy
Profile Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::Profile


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileBandLabelGroup Class
Class Hierarchy
ProfileBandLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::Land::DatabaseServices::ProfileBandLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCircular Class
Class Hierarchy
ProfileCircular Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileCircular


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteria Class
Class Hierarchy
ProfileCriteria Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileCriteria


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileCriteriaCollection Class
Class Hierarchy
ProfileCriteriaCollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileCriteriaCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntity Class
Class Hierarchy
ProfileEntity Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileCircular
    Autodesk::Civil::Land::DatabaseServices::ProfileParabolaAsymmetric
    Autodesk::Civil::Land::DatabaseServices::ProfileParabolaSymmetric
    Autodesk::Civil::Land::DatabaseServices::ProfileTangent


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileEntityCollection Class
Class Hierarchy
ProfileEntityCollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntityCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchArea Class
Class Hierarchy
ProfileHatchArea Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileHatchArea


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileHatchAreaCollection Class
Class Hierarchy
ProfileHatchAreaCollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileHatchAreaCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverride Class
Class Hierarchy
ProfileOverride Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::GraphOverride
    Autodesk::Civil::Land::DatabaseServices::ProfileOverride


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileOverrideCollection Class
Class Hierarchy
ProfileOverrideCollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileOverrideCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaAsymmetric Class
Class Hierarchy
ProfileParabolaAsymmetric Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileParabolaAsymmetric


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileParabolaSymmetric Class
Class Hierarchy
ProfileParabolaSymmetric Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileParabolaSymmetric


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileProjection Class
Class Hierarchy
ProfileProjection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::ProfileProjection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVI Class
Class Hierarchy
ProfilePVI Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfilePVI


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfilePVICollection Class
Class Hierarchy
ProfilePVICollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfilePVICollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileTangent Class
Class Hierarchy
ProfileTangent Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileEntity
    Autodesk::Civil::Land::DatabaseServices::ProfileTangent


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileView Class
Class Hierarchy
ProfileView Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
            Autodesk::Civil::Land::DatabaseServices::ProfileView


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitData Class
Class Hierarchy
ProfileViewSplitData Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileViewSplitData


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ProfileViewSplitDataCollection Class
Class Hierarchy
ProfileViewSplitDataCollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::ProfileViewSplitDataCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLine Class
Class Hierarchy
SampleLine Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::SampleLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SampleLineGroup Class
Class Hierarchy
SampleLineGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::SampleLineGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSCSConstraints Class
Class Hierarchy
SCSCSConstraints Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::SCSCSConstraints


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SCSSCSConstraints Class
Class Hierarchy
SCSSCSConstraints Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::SCSSCSConstraints


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Section Class
Class Hierarchy
Section Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Section
            Autodesk::Civil::Land::DatabaseServices::MaterialSection
            Autodesk::Civil::Land::DatabaseServices::SectionProjection
            Autodesk::Civil::PipeNetwork::DatabaseServices::SectionPipeNetwork


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionBandLabelGroup Class
Class Hierarchy
SectionBandLabelGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
        Autodesk::Civil::DatabaseServices::LabelGroup
            Autodesk::Civil::Land::DatabaseServices::SectionBandLabelGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionProjection Class
Class Hierarchy
SectionProjection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Section
            Autodesk::Civil::Land::DatabaseServices::SectionProjection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SectionView Class
Class Hierarchy
SectionView Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::DatabaseServices::Graph
            Autodesk::Civil::Land::DatabaseServices::SectionView


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Sheet Class
Class Hierarchy
Sheet Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Sheet


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Site Class
Class Hierarchy
Site Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Site


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Station Class
Class Hierarchy
Station Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Station


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquation Class
Class Hierarchy
StationEquation Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::StationEquation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationEquationCollection Class
Class Hierarchy
StationEquationCollection Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::StationEquationCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > StationOffsetLabel Class
Class Hierarchy
StationOffsetLabel Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
Autodesk::Civil::DatabaseServices::ICommonLabelOptions
    Autodesk::Civil::DatabaseServices::LabelBase
    Autodesk::Civil::DatabaseServices::ICommonLabel
        Autodesk::Civil::DatabaseServices::Label
            Autodesk::Civil::DatabaseServices::FeatureLabel
                Autodesk::Civil::Land::DatabaseServices::StationOffsetLabel


Autodesk::Civil::Land::DatabaseServices::Styles Namespace Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Autodesk::Civil::Land::DatabaseServices::Styles Namespace Classes
Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Classes
Class | Description
AlignmentDesignCheckSet | A collection of alignment design checks, which can be applied to an alignment.
AlignmentDesignCheckSetCollection | The AlignmentDesignCheckSetCollection class.
AlignmentStyle | Specifies properties for the various alignment components.
AlignmentStyleCollection | A collection of AlignmentStyle objects.
ArrowHeadOption | Display options for arrows in AlignmentStyle and ProfileStyle.
BuildingSiteStyle | Display options for building site objects.
BuildingSiteStyleCollection | A collection of BuildingSiteStyle objects.
ContourValues | Defines how to display major and minor contour lines; used by the SurfaceContourStyle class.
GradingCriteria | Specifies grading criteria (a projection method and target) to create a finished grading surface.
GradingCriteriaCollection | A collection of GradingCriteria objects.
GradingCriteriaSet | A set of multiple related GradingCriteria objects.
GradingCriteriaSetCollection | A collection of GradingCriteriaSet objects.
GradingStyle | Specifies default display and other characteristics for grading features when they are created.
GradingStyleCollection | A collection of GradingStyle objects.
GroupPlotStyle | Specifies section view group plot style settings.
GroupPlotStyleCollection | A collection of GroupPlotStyle objects.
HorizontalGeometryBandStyle | The style object specifying characteristics for profile view horizontal geometry data bands.
LabelStylesAlignmentRoot | All Alignment-related label styles. These styles control the label display for alignment components, such as major and minor stations,... more
LabelStylesMatchLineRoot | All styles associated with match line labels.
LabelStylesProfileRoot | LabelStylesProfileRoot
MassHaulLineStyle | The view frame style wrapper class.
MassHaulLineStyleCollection | The MassHaulLineStyleCollection class.
MassHaulViewStyle | The view frame style wrapper class.
MassHaulViewStyleCollection | The MassHaulViewStyleCollection class.
MatchLineStyle | The match line style wrapper class.
ParcelStyle | The parcel style wrapper class.
PointStyle | The point style class.
ProfileDataBandStyle | The profile data band style wrapper class.
ProfileDesignCheckSet | A collection of profile design checks, which can be applied to an alignment.
ProfileDesignCheckSetCollection | The AlignmentStyleCollection class.
ProfileLabelSetStyle | The profile lable set wrapper class.
ProfileStyle | The profile style wrapper class.
ProfileViewBandSetItem | The profile view band set item wrapper class.
ProfileViewBandSetStyle | A collection of ProfileViewBandSetItemCollection objects for profile view band set styles.
ProfileViewStyle | The profile view style wrapper class.
ProfileViewStyleCollection | The ProfileViewStyleCollection class.
SampleLineStyle | Specifies display properties for the sample lines used to obtain elevational information from an existing terrain model or surface.
SectionalDataBandStyle | The section data band style wrapper class.
SectionDataBandStyle | The section data band style wrapper class.
SectionSegmentBandStyle | The section data band style wrapper class.
SectionStyle | Specifies display characteristics and associated information for cross sections and their constituent components.
SectionViewBandSetItem | Encapsulates a single section view data band.
SectionViewBandSetItemCollection | The SectionViewBandSetItemCollectione wrapper class.
SectionViewBandSetStyle | The SectionViewBandSetStyle wrapper class.
SectionViewStyle | The section view style wrapper class.
SheetStyle | The sheet plot style applied when plot by page is selected.
SlopePatternComponent | Encapsulates the properties of slope pattern components used to make up a SlopePatternStyle.
SlopePatternLine | Defines a line used in a SlopePatternComponent.
SlopePatternLineOffset | Defines the offset of lines in a SlopePatternComponent.
SlopePatternLineSymbol | Defines the symbol used with a SlopePatternComponent.
SlopePatternStyle | A style that defines the pattern that represents a slope in a grading style.
SlopePatternStyleCollection | The SlopePatternStyleCollection class.
SuperelevationDataBandStyle | The super elevation data band style wrapper class.
SurfaceBaseStyle | The surface base style class
SurfaceContourStyle | The surface boundary style class
SurfaceDirectionStyle | The surface boundary style class
SurfaceElevationStyle | The surface boundary style class
SurfacePointStyle | The SurfacePointStyle class.
SurfaceSlopeArrowStyle | The SurfaceSlopeArrowStyle class.
SurfaceSlopeStyle | The SurfaceSlopeStyle class.
SurfaceStyle | The surface style class.
VerticalGeometryBandStyle | The vertical geometry band style wrapper class.
ViewFrameStyle | The view frame style wrapper class.


Classes (AutoDoc Folder)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Legend
Legend
Class


Autodesk::Civil::Land::DatabaseServices::Styles Namespace Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Autodesk::Civil::Land::DatabaseServices::Styles Namespace Structs, Records, Enums
Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
AlignmentDisplayStyleType | Defines AlignmentStyle display style type.
BuildingSiteDisplayStyleType | An enumeration that defines BuildingSiteStyle display style type.
CenterMarkerSizeType | Defines grading style center marker size type.
ColorSchemeType | Defines color scheme type
ContourSmoothingType | Defines how surface contours are smoothed.
GradingDisplayStyleType | Defines grading display style type.
GroupPlotAlignType | Specifies how the section views are aligned.
GroupPlotAreaType | An enumeration that specify the method of plotting section views (either all or by page).
GroupPlotCellSizeType | Specifies how the size of each cell in the array will be determined.
GroupPlotStartCornerType | Specifies the starting corner for plotting the section views.
HorizontalGeometryDisplayStyleType | Defines HorizontalGeometryBandStyle display style type.
ParcelDisplayStyleType | Defines ParcelStyle display style type.
PointDisplay3dType | Specifies how point elevation is displayed.
PointDisplayStyleType | An enumeration that defines PointStyle display style type.
PointMarkerDisplayType | Specifies the kind of marker to use, any of: point, custom, or symbol.
PointSymbolType | Defines the symbology of the point display.
PrecisionRangeType | Defines range precision for some surface styles.
ProfileDataDisplayStyleType | Defines ProfileDataBandStyle display style type.
ProfileDesignCheckCurveType | Design check curve type.
ProfileDisplayStyleProfileType | Defines ProfileStyle display style type.
ProfileViewDisplayStyleType | Defines profile view components type.
SampleLineDisplayStyleType | Defines SampleLineStyle display style type.
ScaleType | Defines how to scale the point marker.
SchematicLineOption | Defines HorizontalGeometryBandStyle schematic line option.
SectionalDataDisplayStyleType | Defines SectionalDataBandStyle display style type.
SectionDataDisplayStyleType | Defines SectionDataBandStyle display style type.
SectionDisplayStyleSectionType | Defines SectionStyle display style type.
SectionSegmentDisplayStyleType | Defines SectionSegmentBandStyle display style type.
SectionViewDisplayStyleType | Defines section view components type.
SectionViewPlotRuleType | Specifies whether to plot the section views by rows or columns.
SheetDisplayStyleType | Defines SheetStyle display style type.
SlopeArrowType | Defines the head style of ArrowType
SuperelevationDataDisplayStyleType | Defines SuperelevationDataBandStyle display style type.
SurfaceDisplay3dType | Defines how to display surface style, whether it is exaggerated, flattened, or displayed at actual elevation levels.
SurfaceDisplayStyleType | Defines surface display style type.
SurfaceDisplayType | Defines how surface objects are to be displayed/rendered.
SurfaceGroupValuesByType | Defines how values are grouped.
VerticalGeometryDisplayStyleType | Defines VerticalGeometryBandStyle display style type.


Structs, Records, Enums (AutoDoc Folder)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Legend
Legend
Enumeration


Topics

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Topics
Autodesk::Civil::Land::DatabaseServices::Styles Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSet Class
Class Hierarchy
AlignmentDesignCheckSet Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSet
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSet


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentDesignCheckSetCollection Class
Class Hierarchy
AlignmentDesignCheckSetCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSetCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyle Class
Class Hierarchy
AlignmentStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > AlignmentStyleCollection Class
Class Hierarchy
AlignmentStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ArrowHeadOption Class
Class Hierarchy
ArrowHeadOption Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::ArrowHeadOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyle Class
Class Hierarchy
BuildingSiteStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > BuildingSiteStyleCollection Class
Class Hierarchy
BuildingSiteStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ContourValues Class
Class Hierarchy
ContourValues Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::ContourValues


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteria Class
Class Hierarchy
GradingCriteria Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteria


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaCollection Class
Class Hierarchy
GradingCriteriaCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSet Class
Class Hierarchy
GradingCriteriaSet Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSet


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingCriteriaSetCollection Class
Class Hierarchy
GradingCriteriaSetCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingCriteriaSetCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyle Class
Class Hierarchy
GradingStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GradingStyleCollection Class
Class Hierarchy
GradingStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::GradingStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyle Class
Class Hierarchy
GroupPlotStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > GroupPlotStyleCollection Class
Class Hierarchy
GroupPlotStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > HorizontalGeometryBandStyle Class
Class Hierarchy
HorizontalGeometryBandStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::HorizontalGeometryBandStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesAlignmentRoot Class
Class Hierarchy
LabelStylesAlignmentRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesAlignmentRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesMatchLineRoot Class
Class Hierarchy
LabelStylesMatchLineRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesMatchLineRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > LabelStylesProfileRoot Class
Class Hierarchy
LabelStylesProfileRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::Land::DatabaseServices::Styles::LabelStylesProfileRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyle Class
Class Hierarchy
MassHaulLineStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulLineStyleCollection Class
Class Hierarchy
MassHaulLineStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulLineStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyle Class
Class Hierarchy
MassHaulViewStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MassHaulViewStyleCollection Class
Class Hierarchy
MassHaulViewStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::MassHaulViewStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > MatchLineStyle Class
Class Hierarchy
MatchLineStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::MatchLineStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ParcelStyle Class
Class Hierarchy
ParcelStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ParcelStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > PointStyle Class
Class Hierarchy
PointStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::MarkerStyleBase
            Autodesk::Civil::Land::DatabaseServices::Styles::PointStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDataBandStyle Class
Class Hierarchy
ProfileDataBandStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDataBandStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSet Class
Class Hierarchy
ProfileDesignCheckSet Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDesignCheckSet
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSet


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileDesignCheckSetCollection Class
Class Hierarchy
ProfileDesignCheckSetCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckSetCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileLabelSetStyle Class
Class Hierarchy
ProfileLabelSetStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BaseLabelSetStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::ProfileLabelSetStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileStyle Class
Class Hierarchy
ProfileStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetItem Class
Class Hierarchy
ProfileViewBandSetItem Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItem
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetItem


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewBandSetStyle Class
Class Hierarchy
ProfileViewBandSetStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewBandSetStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyle Class
Class Hierarchy
ProfileViewStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ProfileViewStyleCollection Class
Class Hierarchy
ProfileViewStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SampleLineStyle Class
Class Hierarchy
SampleLineStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionalDataBandStyle Class
Class Hierarchy
SectionalDataBandStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionalDataBandStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionDataBandStyle Class
Class Hierarchy
SectionDataBandStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionDataBandStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionSegmentBandStyle Class
Class Hierarchy
SectionSegmentBandStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SectionSegmentBandStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionStyle Class
Class Hierarchy
SectionStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItem Class
Class Hierarchy
SectionViewBandSetItem Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItem
    Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetItem


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetItemCollection Class
Class Hierarchy
SectionViewBandSetItemCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::BandSetItemCollection
    Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetItemCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewBandSetStyle Class
Class Hierarchy
SectionViewBandSetStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewBandSetStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SectionViewStyle Class
Class Hierarchy
SectionViewStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SheetStyle Class
Class Hierarchy
SheetStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SheetStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternComponent Class
Class Hierarchy
SlopePatternComponent Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternComponent


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLine Class
Class Hierarchy
SlopePatternLine Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineOffset Class
Class Hierarchy
SlopePatternLineOffset Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternLineOffset


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternLineSymbol Class
Class Hierarchy
SlopePatternLineSymbol Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternLineSymbol


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyle Class
Class Hierarchy
SlopePatternStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SlopePatternStyleCollection Class
Class Hierarchy
SlopePatternStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Land::DatabaseServices::Styles::SlopePatternStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SuperelevationDataBandStyle Class
Class Hierarchy
SuperelevationDataBandStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::SuperelevationDataBandStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceBaseStyle Class
Class Hierarchy
SurfaceBaseStyle Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceContourStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDirectionStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceElevationStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfacePointStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceSlopeArrowStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceSlopeStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceContourStyle Class
Class Hierarchy
SurfaceContourStyle Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceContourStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceDirectionStyle Class
Class Hierarchy
SurfaceDirectionStyle Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDirectionStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceElevationStyle Class
Class Hierarchy
SurfaceElevationStyle Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceElevationStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfacePointStyle Class
Class Hierarchy
SurfacePointStyle Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfacePointStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeArrowStyle Class
Class Hierarchy
SurfaceSlopeArrowStyle Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceSlopeArrowStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceSlopeStyle Class
Class Hierarchy
SurfaceSlopeStyle Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceBaseStyle
    Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceSlopeStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > SurfaceStyle Class
Class Hierarchy
SurfaceStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > VerticalGeometryBandStyle Class
Class Hierarchy
VerticalGeometryBandStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::Land::DatabaseServices::Styles::VerticalGeometryBandStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Autodesk::Civil::Land::DatabaseServices::Styles Namespace > Classes > ViewFrameStyle Class
Class Hierarchy
ViewFrameStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Land::DatabaseServices::Styles::ViewFrameStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationData Class
Class Hierarchy
SuperElevationData Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::SuperElevationData


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > SuperElevationDataElement Class
Class Hierarchy
SuperElevationDataElement Class
Class Hierarchy
Autodesk::Civil::Land::DatabaseServices::SuperElevationDataElement


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > Surface Class
Class Hierarchy
Surface Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Surface
        Autodesk::Civil::Land::DatabaseServices::GridSurface
        Autodesk::Civil::Land::DatabaseServices::TinSurface


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > TinSurface Class
Class Hierarchy
TinSurface Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Land::DatabaseServices::Surface
        Autodesk::Civil::Land::DatabaseServices::TinSurface


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrame Class
Class Hierarchy
ViewFrame Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::ViewFrame


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::DatabaseServices Namespace > Classes > ViewFrameGroup Class
Class Hierarchy
ViewFrameGroup Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::ViewFrameGroup


Class Hierarchy
GeometryPointLabelOption Template
Class Hierarchy
Autodesk::Civil::Land::GeometryPointLabelOption


Class Hierarchy
GeometryPointSelector Template
Class Hierarchy
Autodesk::Civil::Land::GeometryPointSelector


Class Hierarchy
ProfileDesignCheck Class
Class Hierarchy
Autodesk::Civil::DesignCheck
    Autodesk::Civil::Land::ProfileDesignCheck


Class Hierarchy
ProfileDesignCheckCollection Class
Class Hierarchy
Autodesk::Civil::Land::ProfileDesignCheckCollection


Class Hierarchy
ProfileDesignCheckRoot Class
Class Hierarchy
Autodesk::Civil::Land::ProfileDesignCheckRoot


Autodesk::Civil::Land::Settings Namespace Classes
Autodesk::Civil::Land::Settings Namespace
Classes
Class | Description
SettingsAbbreviationAlignment | Abbreviations Settings for Alignment Geometry Point Entity Data
SettingsAbbreviationAlignmentEnhanced | Abbreviations Settings for Alignment Geometry Point Text
SettingsAbbreviationProfile | Abbreviations Settings for Profile
SettingsAbbreviationSuperelevation | Abbreviations Settings for Superelevation
SettingsAlignment | Settings for Alignment.
SettingsAlignment::SettingsCriteriaBasedDesignOptions | Default settings for creating an alignment using design criteria.
SettingsAlignment::SettingsData | Default settings for creating an alignment using data.
SettingsAlignment::SettingsDefaultNameFormat | Settings for Alignment Default Name Format.
SettingsAlignment::SettingsDynamicAlignmentHighlight | Default settings for dynamic alignment hightlight options.
SettingsAlignment::SettingsStationIndexing | Settings for Alignment Station Indexing.
SettingsAlignment::SettingsStyles | Settings for Alignment default styles.
SettingsAlignment::SettingsSuperelevationOptions | Default settings for calculating superelevation specifications.
SettingsBuildingSite | Settings for ViewFrameGroup.
SettingsBuildingSite::SettingsNameFormat | Default name format for new building sites.
SettingsBuildingSite::SettingsStyles | Default styles for new building sites.
SettingsCmdAddAlignmentCurveTable | Settings for AddAlignmentCurveTable command.
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentCurveTable.
SettingsCmdAddAlignmentLineTable | Settings for AddAlignmentLineTable command.
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentLineTable.
SettingsCmdAddAlignmentOffLbl | Settings for AddAlignmentOffLbl command.
SettingsCmdAddAlignmentOffXYLbl | Settings for AddAlignmentOffXYLbl command.
SettingsCmdAddAlignmentSegmentTable | Settings for AddAlignmentSegmentTable command.
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentSegmentTable.
SettingsCmdAddAlignmentSpiralTable | Settings for AddAlignmentSpiralTable command.
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation | Settings of table creation for the command AddAlignmentSpiralTable.
SettingsCmdAddAlignSegLbl | Settings for AddAlignSegLbl command.
SettingsCmdAddAlignSegLbls | Settings for AddAlignSegLbls command.
SettingsCmdAddAlignTagentLbl | Settings for AddAlignTagentLbl command.
SettingsCmdAddAlignTagentLbls | Settings for AddAlignTagentLbls command.
SettingsCmdAddContourLabeling | Settings for AddContourLabeling command.
SettingsCmdAddContourLabelingGroup | Settings for AddContourLabelingGroup command.
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling | Settings that specify the defaults assigned to surface labels.
SettingsCmdAddContourLabelingSingle | Settings for AddContourLabelingSingle command.
SettingsCmdAddParcelAreaLabel | Settings for AddParcelAreaLabel command.
SettingsCmdAddParcelCurveTable | Settings for AddParcelCurveTable command.
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelCurveTable.
SettingsCmdAddParcelLineLabel | Settings for AddParcelLineLabel command.
SettingsCmdAddParcelLineTable | Settings for AddParcelLineTable command.
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelLineTable.
SettingsCmdAddParcelSegmentLabels | Settings for AddParcelSegmentLabels command.
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions | Settings that specify defaults for creating labels with parcel segments.
SettingsCmdAddParcelSegmentTable | Settings for AddParcelSegmentTable command.
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelSegmentTable.
SettingsCmdAddParcelTable | Settings for AddParcelTable command.
SettingsCmdAddParcelTable::SettinsCmdTableCreation | Settings of table creation for the command AddParcelTable.
SettingsCmdAddPointTable | Settings for AddPointTable command.
SettingsCmdAddPointTable::SettinsCmdTableCreation | Settings of table creation for the command AddPointTable.
SettingsCmdAddProfileViewDepthLbl | Settings for AddProfileViewDepthLbl command.
SettingsCmdAddProfileViewStaElevLbl | Settings for AddProfileViewStaElevLbl command.
SettingsCmdAddSectionViewGradeLbl | Settings for AddSectionViewGradeLbl command.
SettingsCmdAddSectionViewOffElevLbl | Settings for AddSectionViewOffElevLbl command.
SettingsCmdAddSpotElevLabelsOnGrid | Settings for AddSpotElevLabelsOnGrid command.
SettingsCmdAddSurfaceBoundaries | Settings for AddSurfaceBoundaries command.
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions | Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.
SettingsCmdAddSurfaceBreaklines | Settings for AddSurfaceBreaklines command.
SettingsCmdAddSurfaceContours | Settings for AddSurfaceContours command.
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions | Settings that specify the defaults assigned when adding contours, boundaries, and breaklines to a surface.
SettingsCmdAddSurfaceDemFile | Settings for AddSurfaceDemFile command.
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdAddSurfaceDrawingObjects | Settings for AddSurfaceDrawingObjects command.
SettingsCmdAddSurfaceSlopeLabel | Settings for AddSurfaceSlopeLabel command.
SettingsCmdAddSurfaceSpotElevLabel | Settings for AddSurfaceSpotElevLabel command.
SettingsCmdAddWidening | Settings for AddWidening command.
SettingsCmdAddWidening::SettingsCmdWideningOptions | Settings for the alignment widening options.
SettingsCmdCatchmentArea | Settings for CatchmentArea command.
SettingsCmdConvertPointstoSdskPoints | Settings for ConvertPointstoSdskPoints command.
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer | Settings that specify defaults for Layer.
SettingsCmdCreateAlignmentEntities | Settings for CreateAlignmentEntities command.
SettingsCmdCreateAlignmentLayout | Settings for CreateAlignmentLayout command.
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption | Settings of alignment type option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings | Settings of curve and spiral for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption | Settings of curve tessellation option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption | Settings of tegression graph option for the command CreateAlignmentLayout.
SettingsCmdCreateAlignmentReference | Settings for CreateAlignmentReference command.
SettingsCmdCreateFeatureLineFromAlign | Settings for CreateFeatureLineFromAlign command.
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating feature lines from alignments.
SettingsCmdCreateFeatureLines | Settings for CreateFeatureLines command.
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating feature lines from objects.
SettingsCmdCreateGrading | Settings for CreateGrading command.
SettingsCmdCreateGrading::SettingsCmdGradingCreation | Settings that specify the default behavior for creating grading.
SettingsCmdCreateGradingGroup | Settings for CreateGradingGroup command.
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation | Settings that specify the default behavior for creating grading.
SettingsCmdCreateMassHaulDiagram | Settings for CreateMassHallDiagram command.
SettingsCmdCreateMultipleProfileView | Settings for CreateMultipleProfileView command.
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation | Settings that specify defaults for creating multiple profile views.
SettingsCmdCreateMultipleSectionView | Settings for CreateMultipleSectionView command.
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation | Settings for the table creation.
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation | Settings for table creation.
SettingsCmdCreateOffsetAlignment | Settings for CreateOffsetAlignment command.
SettingsCmdCreateParcelByLayout | Settings for CreateParcelByLayout command.
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout | Settings that specify defaults for automatic parcel layout.
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities | Settings that specify defaults for creation of parcels.
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing | Settings that specify defaults for sizing parcels.
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics | Settings that specify defaults for temporary parcel layout preview graphics.
SettingsCmdCreateParcelFromObjects | Settings for CreateParcelFromObjects command.
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities | Settings that specify defaults for creation of parcels.
SettingsCmdCreateParcelROW | Settings for CreateParcelROW command.
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections | Settings that specify default offset for cleanup at alignment intersections.
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries | Settings that specify default offset for cleanup at parcel boundaries.
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay | Setting that specify default offset for creation of parcel rights of way.
SettingsCmdCreatePointGroup | Settings for CreatePointGroup command.
SettingsCmdCreatePoints | Settings for CreatePoints command.
SettingsCmdCreatePoints::SettingsCmdLayer | Default layer settings for the CreatePoints command.
SettingsCmdCreatePoints::SettingsCmdPointsCreation | Settings that specify defaults for Points Creation.
SettingsCmdCreateProfileFromFile | Settings for CreateProfileFromFile command.
SettingsCmdCreateProfileFromSurface | Settings for CreateProfileFromSurface command.
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry | Settings that specify the geometry setting.
SettingsCmdCreateProfileLayout | Settings for CreateProfileLayout command.
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption | Settings that specify the default behavior when curve entities are used as an input option for best fit arc, line,... more
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption | Setting that specifies the default behavior for regression analysis graphs in best fit arc, line, and parabola creation.
SettingsCmdCreateProfileReference | Settings for CreateProfileReference command.
SettingsCmdCreateProfileView | Settings for CreateProfileView command.
SettingsCmdCreateQuickProfile | Settings for CreateQuickProfile command.
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile | Settings that specify the default settings for quick profile creation.
SettingsCmdCreateSampleLines | Settings for CreateSampleLines command.
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls | Settings that specify the default behavior for additional sample controls.
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous | Setting that specifies miscellaneous default behavior for sample lines.
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements | Settings that specify the default behavior for sampling increments.
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths | Settings that specify the default behavior for sample line swath width.
SettingsCmdCreateSectionView | Settings for CreateSectionView command.
SettingsCmdCreateSectionView::SettingsCmdTableCreation | Settings for the table creation.
SettingsCmdCreateSheets | Settings for CreateSheets command.
SettingsCmdCreateSheets::SettingsCmdSheetCreation | Settings for the sheet creation.
SettingsCmdCreateSite | Settings for CreateSite command.
SettingsCmdCreateSite::SettingsCmdAlignment | Settings that specify default increments for alignment tag numbering.
SettingsCmdCreateSite::SettingsCmdFeatureLine | Settings that specify defaults for feature line style priority.
SettingsCmdCreateSite::SettingsCmdParcel | Settings that specify default increments for parcel numbering.
SettingsCmdCreateSurface | Settings for CreateSurface command.
SettingsCmdCreateSurface::SettingCmdBuildOptions | Settings that specify the build options assigned when creating surfaces.
SettingsCmdCreateSurface::SettingCmdSurfaceCreation | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdCreateSurface::SettingsNameFormat | Settings that specify name format for the command.
SettingsCmdCreateSurfaceFromTIN | Settings for CreateSurfaceFromTIN command.
SettingsCmdCreateSurfaceGridFromDEM | Settings for CreateSurfaceGridFromDEM command.
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions | Settings that specify the build options assigned when creating surfaces.
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdCreateSurfaceReference | Settings for CreateSurfaceReference command.
SettingsCmdCreateSurfaceWaterdrop | Settings for CreateSurfaceWaterdrop command.
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker | Settings that specify the default water drop marker options for surfaces.
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath | Settings that specify the default water drop path options for surfaces.
SettingsCmdCreateViewFrames | Settings for CreateViewFrames command.
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation | Settings for the view frame creation.
SettingsCmdDrawFeatureLine | Settings for DrawFeatureLine command.
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation | Settings that specify the default behavior for creating featureline.
SettingsCmdEditSVGroupStyle | Settings for EditSVGroupStyle command.
SettingsCmdExportParcelAnalysis | Settings for ExportParcelAnalysis command.
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis | Settings that specify defaults for parcel analysis.
SettingsCmdFitCurveFeature | Settings for FitCurveFeature command.
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve | Settings that specify the default behavior for feature line fit curve.
SettingsCmdGradingElevEditor | Settings for GradingElevEditor command.
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor | Settings that specify the default behavior for grading elevation editor.
SettingsCmdGradingTools | Settings for GradingTools command.
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools | Settings that specify the default behavior for grading layout tools.
SettingsCmdGradingVolumeTools | Settings for GradingVolumeTools command.
SettingsCmdImportBuildingSite | Settings for ImportBuildingSite command.
SettingsCmdImportGEData | Settings for ImportGEData command.
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions | Settings that specify the default number of rows and columns collected when importing Google Earth information.
SettingsCmdImportGEData::SettingsCmdSurfaceCreation | Settings that specify the defaults assigned when creating surfaces.
SettingsCmdImportGESurface | Settings for ImportGESurface command.
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions | Settings that specify the default number of rows and columns collected when importing Google Earth information.
SettingsCmdImportGESurface::SettingsNameFormat | Settings that specify name format for the command.
SettingsCmdJoinFeatures | Settings for JoinFeatures command.
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin | Settings that specify the default behavior for featureline join.
SettingsCmdLayoutSectionViewGroup | Settings for LayoutSectionViewGroup command.
SettingsCmdMoveBlockstoAttribElev | Settings for MoveBlockstoAttribElev command.
SettingsCmdMoveBlocksToSurface | Settings for MoveBlocksToSurface command.
SettingsCmdMoveTextToElevation | Settings for MoveTextToElevation command.
SettingsCmdProjectObjectsToProf | Settings for ProjectObjectsToProf command.
SettingsCmdProjectObjectsToSect | Settings for ProjectObjectsToSect command.
SettingsCmdReAddParcelAreaLabel | Settings for ReAddParcelAreaLabel command.
SettingsCmdReAddParcelSegmentLabels | Settings for ReAddParcelSegmentLabels command.
SettingsCmdReverseAlignmentDirection | Settings for ReverseAlignmentDirection command.
SettingsCmdShowGeodeticCalculator | Settings for ShowGeodeticCalculator command.
SettingsCmdShowPointGroupProperties | Settings for ShowPointGroupProperties command.
SettingsCmdSimplifySurface | Settings for SimplifySurface command.
SettingsCmdSuperimposeProfile | Settings for SuperimposeProfile command.
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption | Settings that specify the default values for the mid-ordinate distances that the system uses when tessellating (approximating) the shape of... more
SettingsCmdSurfaceExportToDem | Settings for SurfaceExportToDem command.
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions | Settings that specify the defaults assigned when exporting surfaces to a DEM file.
SettingsCmdSurfaceExtractObjects | Settings for SurfaceExtractObjects command.
SettingsCmdWeedFeatures | Settings for WeedFeatures command.
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed | Settings that specify the default behavior for grading layout tools.
SettingsGrading | Settings for Grading.
SettingsGrading::SettingsNameFormat | Default name format for grading feature settings.
SettingsGrading::SettingsStyles | Default styles.setting class
SettingsMassHaulLine | Settings for MassHaulLine.
SettingsMassHaulView | Settings for MassHaulView.
SettingsMassHaulView::SettingsMassHaulCreation | Default settings which are available when accessing the settings from the CreateMassHaul command, to establish the default settings when you... more
SettingsMassHaulView::SettingsNameFormat | Default name format for new mass haul lines and new mass haul views.
SettingsMassHaulView::SettingsStyles | Default styles.for mass haul components.
SettingsMatchLine | Settings for MatchLine.
SettingsParcel | Settings for Parcel.
SettingsParcel::SettingsStyles | Default styles.setting class
SettingsPoint | Settings for Point.
SettingsPoint::SettingsNameFormat | Default name format for point feature settings.
SettingsPoint::SettingsStyles | Default styles.setting class
SettingsPoint::SettingsUpdatePoints | Update points setting class.
SettingsProfile | Settings for Profile.
SettingsProfile::SettingsCriteriaBasedDesignOptions | Criteria Based Design options setting class
SettingsProfile::SettingsDefaultNameFormat | Default name format setting class
SettingsProfile::SettingsProfileCreation | Default values for vertical curve sub-entities
SettingsProfile::SettingsStyles | Default styles.setting class
SettingsProfileView | Settings for ProfileView.
SettingsProfileView::SettingsCreation | Settings for ProfileView default Creation.
SettingsProfileView::SettingsNameFormat | Settings for ProfileView default NameFormat.
SettingsProfileView::SettingsProjectionLabelPlacement | Settings for ProfileView default ProjectionLabelPlacement.
SettingsProfileView::SettingsSplitOptions | Settings for ProfileView default SplitOptions.
SettingsProfileView::SettingsStackedOptions | Settings for ProfileView default StackedOptions.
SettingsProfileView::SettingsStyles | Settings for ProfileView default Styles.
SettingsSampleLine | Settings for SampleLine.
SettingsSampleLine::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSampleLine::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSection | Settings for Section.
SettingsSection::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSection::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSectionView | Settings to specify the default styles assigned to section view components
SettingsSectionView::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsProjectionLabelPlacement | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsSectionViewCreation | Settings to establish the default styles assigned to assembly components.
SettingsSectionView::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsSurface | Settings for Surface.
SettingsSurface::SettingsContourLabeling | Defaults assigned to surface labels.
SettingsSurface::SettingsDefaults | Default name format for new surfaces.
SettingsSurface::SettingsStyles | Default styles.assigned to surfaces and surface-related labels.
SettingsViewFrame | Settings for ViewFrame.
SettingsViewFrameGroup | Settings for ViewFrameGroup.
SettingsViewFrameGroup::SettingsInformation | Default match line label location.
SettingsViewFrameGroup::SettingsNameFormat | Default name format for view frame group components.
SettingsViewFrameGroup::SettingsStyles | Default styles assigned to view frame group components.


Autodesk::Civil::Land::Settings Namespace Structs, Records, Enums
Autodesk::Civil::Land::Settings Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
AbbreviationAlignmentEnhancedType | Defines Abbreviation Alignment Enhanced type.
AbbreviationAlignmentType | Defines Abbreviation Alignment type.
AbbreviationProfileType | Defines Abbreviation Profile type.
AbbreviationSuperelevationType | Defines Abbreviation Superelevation type.
AutomaticManual | Specifies how some properties are assigned point creation.
GeographicCoordinateType | Specifies the order in which geographic coordinates are displayed on the command line during point creation.
GridCoordinateType | Specifies the order in which grid coordinates are displayed on the command line during point creation.
LocalCoordinateType | Specifies the order and format used to display local coordinates on the command line during point creation.
SectionViewAnchorType | Defines types of section view anchors.
TableAnchorType | Defines types of table anchors.
TableLayoutType | Defines table layout directions.
TileDirectionType | Defines tile directions.


Topics
Autodesk::Civil::Land::Settings Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignment Class
Class Hierarchy
SettingsAbbreviationAlignment Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAbbreviationAlignment


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationAlignmentEnhanced Class
Class Hierarchy
SettingsAbbreviationAlignmentEnhanced Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAbbreviationAlignmentEnhanced


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationProfile Class
Class Hierarchy
SettingsAbbreviationProfile Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAbbreviationProfile


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAbbreviationSuperelevation Class
Class Hierarchy
SettingsAbbreviationSuperelevation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAbbreviationSuperelevation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment Class
Class Hierarchy
SettingsAlignment Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentCurveTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentLineTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentOffLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentOffXYLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSegmentTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSpiralTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignSegLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignSegLbls
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignTagentLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignTagentLbls
        Autodesk::Civil::Land::Settings::SettingsCmdAddWidening
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentEntities
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentReference
        Autodesk::Civil::Land::Settings::SettingsCmdCreateOffsetAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdReverseAlignmentDirection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsCriteriaBasedDesignOptions Class
Class Hierarchy
SettingsAlignment::SettingsCriteriaBasedDesignOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsCriteriaBasedDesignOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsData Class
Class Hierarchy
SettingsAlignment::SettingsData Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsData


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDefaultNameFormat Class
Class Hierarchy
SettingsAlignment::SettingsDefaultNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsDefaultNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsDynamicAlignmentHighlight Class
Class Hierarchy
SettingsAlignment::SettingsDynamicAlignmentHighlight Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsDynamicAlignmentHighlight


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStationIndexing Class
Class Hierarchy
SettingsAlignment::SettingsStationIndexing Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsStationIndexing


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsStyles Class
Class Hierarchy
SettingsAlignment::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsAlignment::SettingsSuperelevationOptions Class
Class Hierarchy
SettingsAlignment::SettingsSuperelevationOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsAlignment::SettingsSuperelevationOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite Class
Class Hierarchy
SettingsBuildingSite Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsBuildingSite
        Autodesk::Civil::Land::Settings::SettingsCmdImportBuildingSite


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsNameFormat Class
Class Hierarchy
SettingsBuildingSite::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsBuildingSite::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsBuildingSite::SettingsStyles Class
Class Hierarchy
SettingsBuildingSite::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsBuildingSite::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable Class
Class Hierarchy
SettingsCmdAddAlignmentCurveTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentCurveTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable Class
Class Hierarchy
SettingsCmdAddAlignmentLineTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentLineTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentOffLbl Class
Class Hierarchy
SettingsCmdAddAlignmentOffLbl Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentOffLbl


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentOffXYLbl Class
Class Hierarchy
SettingsCmdAddAlignmentOffXYLbl Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentOffXYLbl


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable Class
Class Hierarchy
SettingsCmdAddAlignmentSegmentTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSegmentTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable Class
Class Hierarchy
SettingsCmdAddAlignmentSpiralTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSpiralTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignSegLbl Class
Class Hierarchy
SettingsCmdAddAlignSegLbl Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignSegLbl


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignSegLbls Class
Class Hierarchy
SettingsCmdAddAlignSegLbls Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignSegLbls


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignTagentLbl Class
Class Hierarchy
SettingsCmdAddAlignTagentLbl Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignTagentLbl


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddAlignTagentLbls Class
Class Hierarchy
SettingsCmdAddAlignTagentLbls Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddAlignTagentLbls


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabeling Class
Class Hierarchy
SettingsCmdAddContourLabeling Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabeling


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup Class
Class Hierarchy
SettingsCmdAddContourLabelingGroup Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class
Class Hierarchy
SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddContourLabelingSingle Class
Class Hierarchy
SettingsCmdAddContourLabelingSingle Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingSingle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelAreaLabel Class
Class Hierarchy
SettingsCmdAddParcelAreaLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelAreaLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable Class
Class Hierarchy
SettingsCmdAddParcelCurveTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelCurveTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineLabel Class
Class Hierarchy
SettingsCmdAddParcelLineLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable Class
Class Hierarchy
SettingsCmdAddParcelLineTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddParcelLineTable::SettinsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineTable::SettinsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels Class
Class Hierarchy
SettingsCmdAddParcelSegmentLabels Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentLabels


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class
Class Hierarchy
SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable Class
Class Hierarchy
SettingsCmdAddParcelSegmentTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable Class
Class Hierarchy
SettingsCmdAddParcelTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddParcelTable::SettinsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddParcelTable::SettinsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddParcelTable::SettinsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable Class
Class Hierarchy
SettingsCmdAddPointTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdAddPointTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddPointTable::SettinsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddPointTable::SettinsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddPointTable::SettinsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddProfileViewDepthLbl Class
Class Hierarchy
SettingsCmdAddProfileViewDepthLbl Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdAddProfileViewDepthLbl


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddProfileViewStaElevLbl Class
Class Hierarchy
SettingsCmdAddProfileViewStaElevLbl Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdAddProfileViewStaElevLbl


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSectionViewGradeLbl Class
Class Hierarchy
SettingsCmdAddSectionViewGradeLbl Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdAddSectionViewGradeLbl


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSectionViewOffElevLbl Class
Class Hierarchy
SettingsCmdAddSectionViewOffElevLbl Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdAddSectionViewOffElevLbl


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSpotElevLabelsOnGrid Class
Class Hierarchy
SettingsCmdAddSpotElevLabelsOnGrid Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSpotElevLabelsOnGrid


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries Class
Class Hierarchy
SettingsCmdAddSurfaceBoundaries Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBoundaries


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class
Class Hierarchy
SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceBreaklines Class
Class Hierarchy
SettingsCmdAddSurfaceBreaklines Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBreaklines


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours Class
Class Hierarchy
SettingsCmdAddSurfaceContours Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceContours


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class
Class Hierarchy
SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile Class
Class Hierarchy
SettingsCmdAddSurfaceDemFile Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDemFile


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class
Class Hierarchy
SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceDrawingObjects Class
Class Hierarchy
SettingsCmdAddSurfaceDrawingObjects Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDrawingObjects


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceSlopeLabel Class
Class Hierarchy
SettingsCmdAddSurfaceSlopeLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceSlopeLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddSurfaceSpotElevLabel Class
Class Hierarchy
SettingsCmdAddSurfaceSpotElevLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceSpotElevLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening Class
Class Hierarchy
SettingsCmdAddWidening Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdAddWidening


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdAddWidening::SettingsCmdWideningOptions Class
Class Hierarchy
SettingsCmdAddWidening::SettingsCmdWideningOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdAddWidening::SettingsCmdWideningOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCatchmentArea Class
Class Hierarchy
SettingsCmdCatchmentArea Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCatchmentArea


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints Class
Class Hierarchy
SettingsCmdConvertPointstoSdskPoints Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdConvertPointstoSdskPoints


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class
Class Hierarchy
SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentEntities Class
Class Hierarchy
SettingsCmdCreateAlignmentEntities Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentEntities


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout Class
Class Hierarchy
SettingsCmdCreateAlignmentLayout Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class
Class Hierarchy
SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class
Class Hierarchy
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class
Class Hierarchy
SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class
Class Hierarchy
SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateAlignmentReference Class
Class Hierarchy
SettingsCmdCreateAlignmentReference Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdCreateAlignmentReference


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign Class
Class Hierarchy
SettingsCmdCreateFeatureLineFromAlign Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLineFromAlign


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class
Class Hierarchy
SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines Class
Class Hierarchy
SettingsCmdCreateFeatureLines Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLines


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class
Class Hierarchy
SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading Class
Class Hierarchy
SettingsCmdCreateGrading Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateGrading


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGrading::SettingsCmdGradingCreation Class
Class Hierarchy
SettingsCmdCreateGrading::SettingsCmdGradingCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateGrading::SettingsCmdGradingCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup Class
Class Hierarchy
SettingsCmdCreateGradingGroup Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateGradingGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class
Class Hierarchy
SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMassHaulDiagram Class
Class Hierarchy
SettingsCmdCreateMassHaulDiagram Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsMassHaulView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMassHaulDiagram


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView Class
Class Hierarchy
SettingsCmdCreateMultipleProfileView Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleProfileView


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class
Class Hierarchy
SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView Class
Class Hierarchy
SettingsCmdCreateMultipleSectionView Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleSectionView


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class
Class Hierarchy
SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateOffsetAlignment Class
Class Hierarchy
SettingsCmdCreateOffsetAlignment Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdCreateOffsetAlignment


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout Class
Class Hierarchy
SettingsCmdCreateParcelByLayout Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class
Class Hierarchy
SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class
Class Hierarchy
SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class
Class Hierarchy
SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class
Class Hierarchy
SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects Class
Class Hierarchy
SettingsCmdCreateParcelFromObjects Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelFromObjects


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class
Class Hierarchy
SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW Class
Class Hierarchy
SettingsCmdCreateParcelROW Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class
Class Hierarchy
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class
Class Hierarchy
SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class
Class Hierarchy
SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePointGroup Class
Class Hierarchy
SettingsCmdCreatePointGroup Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdCreatePointGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints Class
Class Hierarchy
SettingsCmdCreatePoints Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdCreatePoints


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdLayer Class
Class Hierarchy
SettingsCmdCreatePoints::SettingsCmdLayer Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreatePoints::SettingsCmdLayer


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreatePoints::SettingsCmdPointsCreation Class
Class Hierarchy
SettingsCmdCreatePoints::SettingsCmdPointsCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreatePoints::SettingsCmdPointsCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromFile Class
Class Hierarchy
SettingsCmdCreateProfileFromFile Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromFile


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface Class
Class Hierarchy
SettingsCmdCreateProfileFromSurface Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromSurface


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class
Class Hierarchy
SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout Class
Class Hierarchy
SettingsCmdCreateProfileLayout Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileLayout


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class
Class Hierarchy
SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class
Class Hierarchy
SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileReference Class
Class Hierarchy
SettingsCmdCreateProfileReference Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileReference


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateProfileView Class
Class Hierarchy
SettingsCmdCreateProfileView Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileView


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile Class
Class Hierarchy
SettingsCmdCreateQuickProfile Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateQuickProfile


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class
Class Hierarchy
SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines Class
Class Hierarchy
SettingsCmdCreateSampleLines Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSampleLine
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class
Class Hierarchy
SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class
Class Hierarchy
SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class
Class Hierarchy
SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class
Class Hierarchy
SettingsCmdCreateSampleLines::SettingsCmdSwathWidths Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines::SettingsCmdSwathWidths


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView Class
Class Hierarchy
SettingsCmdCreateSectionView Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSectionView


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSectionView::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdCreateSectionView::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSectionView::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets Class
Class Hierarchy
SettingsCmdCreateSheets Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsViewFrameGroup
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSheets


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSheets::SettingsCmdSheetCreation Class
Class Hierarchy
SettingsCmdCreateSheets::SettingsCmdSheetCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSheets::SettingsCmdSheetCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite Class
Class Hierarchy
SettingsCmdCreateSite Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSite


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdAlignment Class
Class Hierarchy
SettingsCmdCreateSite::SettingsCmdAlignment Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSite::SettingsCmdAlignment


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdFeatureLine Class
Class Hierarchy
SettingsCmdCreateSite::SettingsCmdFeatureLine Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSite::SettingsCmdFeatureLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSite::SettingsCmdParcel Class
Class Hierarchy
SettingsCmdCreateSite::SettingsCmdParcel Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSite::SettingsCmdParcel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface Class
Class Hierarchy
SettingsCmdCreateSurface Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdBuildOptions Class
Class Hierarchy
SettingsCmdCreateSurface::SettingCmdBuildOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface::SettingCmdBuildOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class
Class Hierarchy
SettingsCmdCreateSurface::SettingCmdSurfaceCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface::SettingCmdSurfaceCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurface::SettingsNameFormat Class
Class Hierarchy
SettingsCmdCreateSurface::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceFromTIN Class
Class Hierarchy
SettingsCmdCreateSurfaceFromTIN Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceFromTIN


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM Class
Class Hierarchy
SettingsCmdCreateSurfaceGridFromDEM Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceGridFromDEM


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class
Class Hierarchy
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class
Class Hierarchy
SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceReference Class
Class Hierarchy
SettingsCmdCreateSurfaceReference Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceReference


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop Class
Class Hierarchy
SettingsCmdCreateSurfaceWaterdrop Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceWaterdrop


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class
Class Hierarchy
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class
Class Hierarchy
SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames Class
Class Hierarchy
SettingsCmdCreateViewFrames Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsViewFrameGroup
        Autodesk::Civil::Land::Settings::SettingsCmdCreateViewFrames


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class
Class Hierarchy
SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine Class
Class Hierarchy
SettingsCmdDrawFeatureLine Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdDrawFeatureLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class
Class Hierarchy
SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdEditSVGroupStyle Class
Class Hierarchy
SettingsCmdEditSVGroupStyle Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdEditSVGroupStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis Class
Class Hierarchy
SettingsCmdExportParcelAnalysis Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdExportParcelAnalysis


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class
Class Hierarchy
SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature Class
Class Hierarchy
SettingsCmdFitCurveFeature Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdFitCurveFeature


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class
Class Hierarchy
SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor Class
Class Hierarchy
SettingsCmdGradingElevEditor Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdGradingElevEditor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class
Class Hierarchy
SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools Class
Class Hierarchy
SettingsCmdGradingTools Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdGradingTools


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class
Class Hierarchy
SettingsCmdGradingTools::SettingsCmdGradingLayoutTools Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdGradingTools::SettingsCmdGradingLayoutTools


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdGradingVolumeTools Class
Class Hierarchy
SettingsCmdGradingVolumeTools Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdGradingVolumeTools


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportBuildingSite Class
Class Hierarchy
SettingsCmdImportBuildingSite Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsBuildingSite
        Autodesk::Civil::Land::Settings::SettingsCmdImportBuildingSite


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData Class
Class Hierarchy
SettingsCmdImportGEData Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdImportGEData


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class
Class Hierarchy
SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class
Class Hierarchy
SettingsCmdImportGEData::SettingsCmdSurfaceCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdImportGEData::SettingsCmdSurfaceCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface Class
Class Hierarchy
SettingsCmdImportGESurface Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdImportGESurface


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class
Class Hierarchy
SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdImportGESurface::SettingsNameFormat Class
Class Hierarchy
SettingsCmdImportGESurface::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdImportGESurface::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures Class
Class Hierarchy
SettingsCmdJoinFeatures Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdJoinFeatures


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class
Class Hierarchy
SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdLayoutSectionViewGroup Class
Class Hierarchy
SettingsCmdLayoutSectionViewGroup Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdLayoutSectionViewGroup


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdMoveBlockstoAttribElev Class
Class Hierarchy
SettingsCmdMoveBlockstoAttribElev Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveBlockstoAttribElev


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdMoveBlocksToSurface Class
Class Hierarchy
SettingsCmdMoveBlocksToSurface Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveBlocksToSurface


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdMoveTextToElevation Class
Class Hierarchy
SettingsCmdMoveTextToElevation Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveTextToElevation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdProjectObjectsToProf Class
Class Hierarchy
SettingsCmdProjectObjectsToProf Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdProjectObjectsToProf


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdProjectObjectsToSect Class
Class Hierarchy
SettingsCmdProjectObjectsToSect Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdProjectObjectsToSect


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdReAddParcelAreaLabel Class
Class Hierarchy
SettingsCmdReAddParcelAreaLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdReAddParcelAreaLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdReAddParcelSegmentLabels Class
Class Hierarchy
SettingsCmdReAddParcelSegmentLabels Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdReAddParcelSegmentLabels


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdReverseAlignmentDirection Class
Class Hierarchy
SettingsCmdReverseAlignmentDirection Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
        Autodesk::Civil::Land::Settings::SettingsCmdReverseAlignmentDirection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdShowGeodeticCalculator Class
Class Hierarchy
SettingsCmdShowGeodeticCalculator Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdShowGeodeticCalculator


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdShowPointGroupProperties Class
Class Hierarchy
SettingsCmdShowPointGroupProperties Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdShowPointGroupProperties


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSimplifySurface Class
Class Hierarchy
SettingsCmdSimplifySurface Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdSimplifySurface


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile Class
Class Hierarchy
SettingsCmdSuperimposeProfile Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdSuperimposeProfile


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class
Class Hierarchy
SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem Class
Class Hierarchy
SettingsCmdSurfaceExportToDem Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExportToDem


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class
Class Hierarchy
SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdSurfaceExtractObjects Class
Class Hierarchy
SettingsCmdSurfaceExtractObjects Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExtractObjects


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures Class
Class Hierarchy
SettingsCmdWeedFeatures Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdWeedFeatures


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class
Class Hierarchy
SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading Class
Class Hierarchy
SettingsGrading Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLineFromAlign
        Autodesk::Civil::Land::Settings::SettingsCmdCreateFeatureLines
        Autodesk::Civil::Land::Settings::SettingsCmdCreateGrading
        Autodesk::Civil::Land::Settings::SettingsCmdCreateGradingGroup
        Autodesk::Civil::Land::Settings::SettingsCmdDrawFeatureLine
        Autodesk::Civil::Land::Settings::SettingsCmdFitCurveFeature
        Autodesk::Civil::Land::Settings::SettingsCmdGradingElevEditor
        Autodesk::Civil::Land::Settings::SettingsCmdGradingTools
        Autodesk::Civil::Land::Settings::SettingsCmdGradingVolumeTools
        Autodesk::Civil::Land::Settings::SettingsCmdJoinFeatures
        Autodesk::Civil::Land::Settings::SettingsCmdWeedFeatures


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsNameFormat Class
Class Hierarchy
SettingsGrading::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsGrading::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsGrading::SettingsStyles Class
Class Hierarchy
SettingsGrading::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsGrading::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulLine Class
Class Hierarchy
SettingsMassHaulLine Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsMassHaulLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView Class
Class Hierarchy
SettingsMassHaulView Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsMassHaulView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMassHaulDiagram


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsMassHaulCreation Class
Class Hierarchy
SettingsMassHaulView::SettingsMassHaulCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsMassHaulView::SettingsMassHaulCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsNameFormat Class
Class Hierarchy
SettingsMassHaulView::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsMassHaulView::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMassHaulView::SettingsStyles Class
Class Hierarchy
SettingsMassHaulView::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsMassHaulView::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsMatchLine Class
Class Hierarchy
SettingsMatchLine Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsMatchLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel Class
Class Hierarchy
SettingsParcel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsParcel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelAreaLabel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelCurveTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineLabel
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelLineTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentLabels
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelSegmentTable
        Autodesk::Civil::Land::Settings::SettingsCmdAddParcelTable
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelByLayout
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelFromObjects
        Autodesk::Civil::Land::Settings::SettingsCmdCreateParcelROW
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSite
        Autodesk::Civil::Land::Settings::SettingsCmdExportParcelAnalysis
        Autodesk::Civil::Land::Settings::SettingsCmdReAddParcelAreaLabel
        Autodesk::Civil::Land::Settings::SettingsCmdReAddParcelSegmentLabels


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsParcel::SettingsStyles Class
Class Hierarchy
SettingsParcel::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsParcel::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint Class
Class Hierarchy
SettingsPoint Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsPoint
        Autodesk::Civil::Land::Settings::SettingsCmdAddPointTable
        Autodesk::Civil::Land::Settings::SettingsCmdConvertPointstoSdskPoints
        Autodesk::Civil::Land::Settings::SettingsCmdCreatePointGroup
        Autodesk::Civil::Land::Settings::SettingsCmdCreatePoints
        Autodesk::Civil::Land::Settings::SettingsCmdShowGeodeticCalculator
        Autodesk::Civil::Land::Settings::SettingsCmdShowPointGroupProperties


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsNameFormat Class
Class Hierarchy
SettingsPoint::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsPoint::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsStyles Class
Class Hierarchy
SettingsPoint::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsPoint::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsPoint::SettingsUpdatePoints Class
Class Hierarchy
SettingsPoint::SettingsUpdatePoints Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsPoint::SettingsUpdatePoints


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile Class
Class Hierarchy
SettingsProfile Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromFile
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileFromSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileLayout
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileReference
        Autodesk::Civil::Land::Settings::SettingsCmdCreateQuickProfile
        Autodesk::Civil::Land::Settings::SettingsCmdSuperimposeProfile


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsCriteriaBasedDesignOptions Class
Class Hierarchy
SettingsProfile::SettingsCriteriaBasedDesignOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfile::SettingsCriteriaBasedDesignOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsDefaultNameFormat Class
Class Hierarchy
SettingsProfile::SettingsDefaultNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfile::SettingsDefaultNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsProfileCreation Class
Class Hierarchy
SettingsProfile::SettingsProfileCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfile::SettingsProfileCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfile::SettingsStyles Class
Class Hierarchy
SettingsProfile::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfile::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView Class
Class Hierarchy
SettingsProfileView Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdAddProfileViewDepthLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddProfileViewStaElevLbl
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateProfileView
        Autodesk::Civil::Land::Settings::SettingsCmdProjectObjectsToProf


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsCreation Class
Class Hierarchy
SettingsProfileView::SettingsCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsNameFormat Class
Class Hierarchy
SettingsProfileView::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsProjectionLabelPlacement Class
Class Hierarchy
SettingsProfileView::SettingsProjectionLabelPlacement Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsProjectionLabelPlacement


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsSplitOptions Class
Class Hierarchy
SettingsProfileView::SettingsSplitOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsSplitOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStackedOptions Class
Class Hierarchy
SettingsProfileView::SettingsStackedOptions Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsStackedOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsProfileView::SettingsStyles Class
Class Hierarchy
SettingsProfileView::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsProfileView::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine Class
Class Hierarchy
SettingsSampleLine Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSampleLine
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSampleLines


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsNameFormat Class
Class Hierarchy
SettingsSampleLine::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSampleLine::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSampleLine::SettingsStyles Class
Class Hierarchy
SettingsSampleLine::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSampleLine::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection Class
Class Hierarchy
SettingsSection Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsNameFormat Class
Class Hierarchy
SettingsSection::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSection::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSection::SettingsStyles Class
Class Hierarchy
SettingsSection::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSection::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView Class
Class Hierarchy
SettingsSectionView Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdAddSectionViewGradeLbl
        Autodesk::Civil::Land::Settings::SettingsCmdAddSectionViewOffElevLbl
        Autodesk::Civil::Land::Settings::SettingsCmdCreateMultipleSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSectionView
        Autodesk::Civil::Land::Settings::SettingsCmdEditSVGroupStyle
        Autodesk::Civil::Land::Settings::SettingsCmdLayoutSectionViewGroup
        Autodesk::Civil::Land::Settings::SettingsCmdProjectObjectsToSect


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsNameFormat Class
Class Hierarchy
SettingsSectionView::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSectionView::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsProjectionLabelPlacement Class
Class Hierarchy
SettingsSectionView::SettingsProjectionLabelPlacement Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSectionView::SettingsProjectionLabelPlacement


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsSectionViewCreation Class
Class Hierarchy
SettingsSectionView::SettingsSectionViewCreation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSectionView::SettingsSectionViewCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSectionView::SettingsStyles Class
Class Hierarchy
SettingsSectionView::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSectionView::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface Class
Class Hierarchy
SettingsSurface Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsSurface
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabeling
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingGroup
        Autodesk::Civil::Land::Settings::SettingsCmdAddContourLabelingSingle
        Autodesk::Civil::Land::Settings::SettingsCmdAddSpotElevLabelsOnGrid
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBoundaries
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceBreaklines
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceContours
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDemFile
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceDrawingObjects
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceSlopeLabel
        Autodesk::Civil::Land::Settings::SettingsCmdAddSurfaceSpotElevLabel
        Autodesk::Civil::Land::Settings::SettingsCmdCatchmentArea
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurface
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceFromTIN
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceGridFromDEM
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceReference
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSurfaceWaterdrop
        Autodesk::Civil::Land::Settings::SettingsCmdImportGEData
        Autodesk::Civil::Land::Settings::SettingsCmdImportGESurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveBlockstoAttribElev
        Autodesk::Civil::Land::Settings::SettingsCmdMoveBlocksToSurface
        Autodesk::Civil::Land::Settings::SettingsCmdMoveTextToElevation
        Autodesk::Civil::Land::Settings::SettingsCmdSimplifySurface
        Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExportToDem
        Autodesk::Civil::Land::Settings::SettingsCmdSurfaceExtractObjects


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsContourLabeling Class
Class Hierarchy
SettingsSurface::SettingsContourLabeling Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSurface::SettingsContourLabeling


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsDefaults Class
Class Hierarchy
SettingsSurface::SettingsDefaults Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSurface::SettingsDefaults


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsSurface::SettingsStyles Class
Class Hierarchy
SettingsSurface::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsSurface::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrame Class
Class Hierarchy
SettingsViewFrame Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsViewFrame


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup Class
Class Hierarchy
SettingsViewFrameGroup Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsViewFrameGroup
        Autodesk::Civil::Land::Settings::SettingsCmdCreateSheets
        Autodesk::Civil::Land::Settings::SettingsCmdCreateViewFrames


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsInformation Class
Class Hierarchy
SettingsViewFrameGroup::SettingsInformation Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsViewFrameGroup::SettingsInformation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsNameFormat Class
Class Hierarchy
SettingsViewFrameGroup::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsViewFrameGroup::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Land Namespace > Autodesk::Civil::Land::Settings Namespace > Classes > SettingsViewFrameGroup::SettingsStyles Class
Class Hierarchy
SettingsViewFrameGroup::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Land::Settings::SettingsViewFrameGroup::SettingsStyles


Autodesk::Civil::PipeNetwork Namespace Namespaces
Autodesk::Civil::PipeNetwork Namespace
Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::PipeNetwork::DatabaseServices namespace.
Settings | The Autodesk::Civil::PipeNetwork::Settings namespace.


Autodesk::Civil::PipeNetwork Namespace Structs, Records, Enums
Autodesk::Civil::PipeNetwork Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
DistanceScaleFactorType | The Autodesk::Civil::PipeNetwork::DistanceScaleFactorType enumeration.
NetworkDefaultLayoutCommandType | The Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType enumeration.
PipeSectionLabelPlacementType | The Autodesk::Civil::PipeNetwork::PipeSectionLabelPlacementType enumeration.
StructureProfileLabelPlacementType | The Autodesk::Civil::PipeNetwork::StructureProfileLabelPlacementType enumeration.


Topics
Autodesk::Civil::PipeNetwork Namespace
Topics
Topic | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Autodesk::Civil::PipeNetwork::DatabaseServices Namespace Classes
Autodesk::Civil::PipeNetwork::DatabaseServices Namespace
Classes
Class | Description
Interference | Represents one location where elements of a pipe network interfere with each other.
InterferenceCheck | Determines where pipes and structures intersect or are too close to each other, and holds a collection of the resulting... more
Network | The container object used to associate pipes and structures that are part of the same pipe run or pipe network.... more
NetworkCatalogDef | The NetworkCatalogDef class. This class allows you to use a part catalog definition at runtime.
NetworkRule | Holds parameter collections for pipe and structure rules.
Part | A pipe network part, base class for Pipe and Structure classes.
PartDataField | An extensible field of part data.
PartDataList | The part data list associated with a PartDataField or SizeFilterField.
PartDataRange | Defines the range of valid data for a PartDataField.
PartDataRecord | A single data record for a Part object.
PartDef | A part definition for Pipe or Structure objects.
PartViewDef | Contains information about how a part is displayed.
Pipe | A pipe network part serving to move fluids from one point to another.
ProfileViewPart | Manages the graphic display of pipe network parts in profile view.
SectionPipeNetwork | Section view of a pipe network.
Structure | The drawing shape used to represent items such as manholes, catch basins, and headwalls used in utility networks. A Structure... more


Autodesk::Civil::PipeNetwork::DatabaseServices Namespace Namespaces
Autodesk::Civil::PipeNetwork::DatabaseServices Namespace
Namespaces
Namespace | Description
Styles | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles namespace.


Autodesk::Civil::PipeNetwork::DatabaseServices Namespace Structs, Records, Enums
Autodesk::Civil::PipeNetwork::DatabaseServices Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
BoundingShapeType | Specifies bounding shapes for Part objects.
ConnectorPositionType | Specifies the connector position.
DomainType | Specifies a Part domain type.
FlowDirectionMethodType | Specifies the method that is used to determine the flow for a pipe.
FlowDirectionType | Specifies the current flow direction of a pipe.
HoldOnResizeType | Specifies the pipe behavior that occurs when the pipe is automatically resized.
PartCatalogDataType | Specifies the data type of the reserved data.
PartContextType | Specifies the context type, which corresponds to every property of a Part.
PartParamUsageType | Defines the usage of a part catalog parameter.
PartType | Specifies a Part type.
PipeSubEntityType | Specifies the subentity type of a pipe.
StructureControlSumpType | Specifies how a sump should be adjusted.
SweptShapeType | Specifies the swept shape of a pipe.


Topics
Autodesk::Civil::PipeNetwork::DatabaseServices Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Interference Class
Class Hierarchy
Interference Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Interference


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > InterferenceCheck Class
Class Hierarchy
InterferenceCheck Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::InterferenceCheck


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Network Class
Class Hierarchy
Network Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Network


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkCatalogDef Class
Class Hierarchy
NetworkCatalogDef Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::NetworkCatalogDef


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > NetworkRule Class
Class Hierarchy
NetworkRule Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::PipeNetwork::DatabaseServices::NetworkRule


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Part Class
Class Hierarchy
Part Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Part
            Autodesk::Civil::PipeNetwork::DatabaseServices::Pipe
            Autodesk::Civil::PipeNetwork::DatabaseServices::Structure


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataField Class
Class Hierarchy
PartDataField Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataField
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::SizeFilterField


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataList Class
Class Hierarchy
PartDataList Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataList


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRange Class
Class Hierarchy
PartDataRange Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataRange


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDataRecord Class
Class Hierarchy
PartDataRecord Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataRecord


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartDef Class
Class Hierarchy
PartDef Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDef


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > PartViewDef Class
Class Hierarchy
PartViewDef Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartViewDef


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Pipe Class
Class Hierarchy
Pipe Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Part
            Autodesk::Civil::PipeNetwork::DatabaseServices::Pipe


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > ProfileViewPart Class
Class Hierarchy
ProfileViewPart Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::PipeNetwork::DatabaseServices::ProfileViewPart


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > SectionPipeNetwork Class
Class Hierarchy
SectionPipeNetwork Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Land::DatabaseServices::Section
            Autodesk::Civil::PipeNetwork::DatabaseServices::SectionPipeNetwork


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Classes > Structure Class
Class Hierarchy
Structure Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::PipeNetwork::DatabaseServices::Part
            Autodesk::Civil::PipeNetwork::DatabaseServices::Structure


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace Classes
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Classes
Class | Description
DataPartFamily | Part family data that is queried from the catalog.
InterferenceStyle | Defines how a pipe interference appears in plan, profile, section, and 3D view.
InterferenceStyleCollection | A collection of InterferenceStyle objects.
LabelStylesPipeRoot | Root object for pipe label styles.
LabelStylesStructureRoot | Root object for structure label styles.
NetworkRuleSetStyle | Base class for Pipe and Structure rule sets.
PartFamily | Each Part is a member of a PartFamily containing all size variations for a given part.
PartSize | Pipe network part size filter.
PartsList | List of pipe network parts (pipes and structures) used for a particular drawing.
PartsListCollection | A collection of PartsList objects.
PipeNetworkBandStyle | Band style in pipe network profile views.
PipeRuleSetStyle | A set of rules for pipe objects.
PipeRuleSetStyleCollection | A collection of PipeRuleSetStyle objects.
PipeStyle | Defines how a pipe appears in plan, profile, section, and 3D view.
PipeStyleCollection | A collection of PipeStyle objects.
PipeStyleOptionBase | Base interface for settings that define the appearance of the pipe in a 2D plan view. Used by PipeStylePlanOption and... more
PipeStylePlanOption | Settings that define the appearance of the pipe in a 2D plan view.
PipeStyleProfileOption | Settings that define the appearance of the pipe in a profile view.
SizeFilterField | Part size parameters from a SizeFilterRecord.
SizeFilterRecord | Lets users specify what part sizes they want to add into a part family.
StructureRuleSetStyle | A set of rules for structure objects.
StructureRuleSetStyleCollection | A collection of StructureRuleSetStyle objects.
StructureStyle | Specifies display properties for all structure objects in the drawing.
StructureStyleCollection | A collection of StructureStyle objects.
StructureStyleModelOption | Specifies the method that is used to define and draw the dimensions of the structure in model view.
StructureStyleOptionBase | Base class for StructureStyleProfileOption and StructureStyleSectionOption.
StructureStylePlanOption | Specifies the method that is used to define and draw the dimensions of the structure in 2D plan view.
StructureStyleProfileOption | Specifies the method that is used to define and draw the dimensions of the structure in profile view.
StructureStyleSectionOption | Specifies the method that is used to define and draw the dimensions of the structure in section view.


Classes (AutoDoc Folder)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Legend
Legend
Class


Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace Structs, Records, Enums
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
InterferenceDisplayStyleType | Specifies the display style type when the Structure is displayed in plan/model/section view.
InterferenceModelSizeOptionType | Specifies the model size option.
InterferenceModelSizeType | Specifies the size of the sphere in model view.
InterferenceModelType | Specifies the type that will be used to visually identify interferences in model view.
PartDataSourceType | Specifies the source type of part data.
PipeCenterlineType | Specifies the method that will be used to define and draw the dimensions of the pipe centerline.
PipeCenterlineWidthType | Specifies the centerline width type.
PipeDisplayStylePlanType | Specifies the display style type when the pipe is displayed in plan view.
PipeDisplayStyleProfileType | Specifies the display style type when the pipe is displayed in profile view.
PipeDisplayStyleSectionType | Specifies the display style type when the pipe is displayed in section view.
PipeEndSizeType | Specifies the method that will be used to define and draw the dimensions of the pipe ends.
PipeHatchStyleProfileType | Specifies the hatch display style type when the pipe is displayed in profile view.
PipeHatchType | Specifies which components of the pipe shape display a hatch pattern.
PipeNetworkDisplayStyleType | Defines ProfileViewPipeNetworkBandStyle display style type.
PipeStylePropertyType | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePropertyType enumeration.
PipeUserDefinedType | Specifies the user defined type.
PipeWallSizeType | Specifies which components of the pipe shape display a hatch pattern.
StructureDisplayStylePlanType | Specifies the display style type when the Structure is displayed in plan view.
StructureDisplayStyleProfileType | Specifies the display style type when the Structure is displayed in profile view.
StructureDisplayStyleSectionType | Specifies the display style type when the Structure is displayed in section view.
StructureInsertionLocation | Specifies the block insertion laction.
StructureModelViewOptionType | Specifies the dimensions of the structure in model view.
StructurePlanViewType | specifies whether the 2D plan view of the structure style is displayed as an outline of the 3D object, or... more
StructureSimpleSolidType | Specifies the simple shape options.
StructureSizeOptionsType | Specifies the size options type.
StructureStylePropertyType | The Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePropertyType enumeration.
StructureViewType | Specifies the method that will be used to define and draw the dimensions of the structure in profile or section... more


Structs, Records, Enums (AutoDoc Folder)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Legend
Legend
Enumeration


Topics

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Topics
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > DataPartFamily Class
Class Hierarchy
DataPartFamily Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::DataPartFamily


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyle Class
Class Hierarchy
InterferenceStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > InterferenceStyleCollection Class
Class Hierarchy
InterferenceStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesPipeRoot Class
Class Hierarchy
LabelStylesPipeRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesPipeRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > LabelStylesStructureRoot Class
Class Hierarchy
LabelStylesStructureRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::LabelStylesStructureRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > NetworkRuleSetStyle Class
Class Hierarchy
NetworkRuleSetStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::NetworkRuleSetStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartFamily Class
Class Hierarchy
PartFamily Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartFamily


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartSize Class
Class Hierarchy
PartSize Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartSize


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsList Class
Class Hierarchy
PartsList Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsList


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PartsListCollection Class
Class Hierarchy
PartsListCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartsListCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeNetworkBandStyle Class
Class Hierarchy
PipeNetworkBandStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::DatabaseServices::Styles::BandStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeNetworkBandStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyle Class
Class Hierarchy
PipeRuleSetStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::NetworkRuleSetStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeRuleSetStyleCollection Class
Class Hierarchy
PipeRuleSetStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeRuleSetStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyle Class
Class Hierarchy
PipeStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleCollection Class
Class Hierarchy
PipeStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleOptionBase Class
Class Hierarchy
PipeStyleOptionBase Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePlanOption
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleProfileOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStylePlanOption Class
Class Hierarchy
PipeStylePlanOption Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePlanOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > PipeStyleProfileOption Class
Class Hierarchy
PipeStyleProfileOption Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStyleProfileOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterField Class
Class Hierarchy
SizeFilterField Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::PartDataField
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::SizeFilterField


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > SizeFilterRecord Class
Class Hierarchy
SizeFilterRecord Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::SizeFilterRecord


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyle Class
Class Hierarchy
StructureRuleSetStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::NetworkRuleSetStyle
            Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureRuleSetStyleCollection Class
Class Hierarchy
StructureRuleSetStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureRuleSetStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyle Class
Class Hierarchy
StructureStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleCollection Class
Class Hierarchy
StructureStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleModelOption Class
Class Hierarchy
StructureStyleModelOption Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleModelOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleOptionBase Class
Class Hierarchy
StructureStyleOptionBase Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleProfileOption
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleSectionOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStylePlanOption Class
Class Hierarchy
StructureStylePlanOption Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePlanOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleProfileOption Class
Class Hierarchy
StructureStyleProfileOption Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleProfileOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices Namespace > Autodesk::Civil::PipeNetwork::DatabaseServices::Styles Namespace > Classes > StructureStyleSectionOption Class
Class Hierarchy
StructureStyleSectionOption Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleOptionBase
    Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStyleSectionOption


Autodesk::Civil::PipeNetwork::Settings Namespace Classes
Autodesk::Civil::PipeNetwork::Settings Namespace
Classes
Class | Description
SettingsCmdAddNetworkPartPlanLabel | Settings for AddNetworkPartPlanLabel command.
SettingsCmdAddNetworkPartProfLabel | Settings for AddNetworkPartProfLabel command.
SettingsCmdAddNetworkPartSectLabel | Settings for AddNetworkPartSectLabel command.
SettingsCmdAddNetworkPartsToProf | Settings for AddNetworkPartsToProf command.
SettingsCmdAddNetworkPipeTable | Settings for AddNetworkPlanTable command.
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation | Settings for alignment type option.
SettingsCmdAddNetworkPlanLabels | Settings for AddNetworkPlanLabels command.
SettingsCmdAddNetworkProfLabels | Settings for AddNetworkProfLables command.
SettingsCmdAddNetworkSectLabels | Settings for AddNetworkSectLables command.
SettingsCmdAddNetworkStructTable | Settings for AddNetworkStructTable command.
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation | Settings for alignment type option.
SettingsCmdAddSpanningPipePlanLabel | Settings for AddSpanningPipePlanLabel command.
SettingsCmdAddSpanningPipeProfLabel | Settings for AddSpanningPipeProfLabel command.
SettingsCmdCreateAlignFromNetwork | Settings for CreateAlignFromNetwork command.
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption | Settings for alignment type option.
SettingsCmdCreateInterferenceCheck | Settings for CreateInterferenceCheck command.
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria | Settings for interference criteria.
SettingsCmdCreateNetwork | Settings for CreateNetwork command.
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts | Settings for alignment type option.
SettingsCmdCreateNetworkFromObject | Settings for CreateNetworkFromObject command.
SettingsCmdCreateNetworkPartsList | Settings for CreateNetworkPartsList command.
SettingsCmdCreateNetworkPartsListFull | Settings for CreateNetworkPartsListFull command.
SettingsCmdCreateNetworkReference | Settings for CreateNetworkReference command.
SettingsCmdEditInStormSewers | Settings for EditInStormSewers command.
SettingsCmdExportStormSewerData | Settings for ExportStormSewerData command.
SettingsCmdImportStormSewerData | Settings for ImportStormSewerData command.
SettingsCmdRenamePipeNetworkParts | Settings for RenamePipeNetworkParts command.
SettingsCmdResetAnchorPipe | Settings for ResetAnchorPipe command.
SettingsCmdShowSpanningPipes | Settings for ShowSpanningPipes command.
SettingsPipe | Settings for Pipe.
SettingsPipeNetwork | Settings for PipeNetwork.
SettingsPipeNetwork::SettingsNameFormat | Settings for PipeNetwork default NameFormat.
SettingsPipeNetwork::SettingsProfileLabelPlacement | Settings for PipeNetwork default ProfileLabelPlacement.
SettingsPipeNetwork::SettingsRules | Settings for PipeNetwork default Rules.
SettingsPipeNetwork::SettingsSectionLabelPlacement | Settings for PipeNetwork default SectionLabelPlacement.
SettingsPipeNetwork::SettingsStormSewersMigration | Settings for PipeNetwork default StormSewersMigration.
SettingsPipeNetwork::SettingsStyles | Settings for PipeNetwork default Styles.
SettingsStructure | Settings for Structure.


Topics
Autodesk::Civil::PipeNetwork::Settings Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPartPlanLabel Class
Class Hierarchy
SettingsCmdAddNetworkPartPlanLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartPlanLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPartProfLabel Class
Class Hierarchy
SettingsCmdAddNetworkPartProfLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartProfLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPartSectLabel Class
Class Hierarchy
SettingsCmdAddNetworkPartSectLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartSectLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPartsToProf Class
Class Hierarchy
SettingsCmdAddNetworkPartsToProf Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartsToProf


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable Class
Class Hierarchy
SettingsCmdAddNetworkPipeTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPipeTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkPlanLabels Class
Class Hierarchy
SettingsCmdAddNetworkPlanLabels Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPlanLabels


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkProfLabels Class
Class Hierarchy
SettingsCmdAddNetworkProfLabels Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkProfLabels


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkSectLabels Class
Class Hierarchy
SettingsCmdAddNetworkSectLabels Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkSectLabels


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable Class
Class Hierarchy
SettingsCmdAddNetworkStructTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkStructTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddSpanningPipePlanLabel Class
Class Hierarchy
SettingsCmdAddSpanningPipePlanLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddSpanningPipePlanLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdAddSpanningPipeProfLabel Class
Class Hierarchy
SettingsCmdAddSpanningPipeProfLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddSpanningPipeProfLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork Class
Class Hierarchy
SettingsCmdCreateAlignFromNetwork Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateAlignFromNetwork


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class
Class Hierarchy
SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck Class
Class Hierarchy
SettingsCmdCreateInterferenceCheck Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateInterferenceCheck


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class
Class Hierarchy
SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork Class
Class Hierarchy
SettingsCmdCreateNetwork Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetwork


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class
Class Hierarchy
SettingsCmdCreateNetwork::SettingsCmdLabelNewParts Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetwork::SettingsCmdLabelNewParts


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetworkFromObject Class
Class Hierarchy
SettingsCmdCreateNetworkFromObject Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkFromObject


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetworkPartsList Class
Class Hierarchy
SettingsCmdCreateNetworkPartsList Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkPartsList


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetworkPartsListFull Class
Class Hierarchy
SettingsCmdCreateNetworkPartsListFull Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkPartsListFull


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdCreateNetworkReference Class
Class Hierarchy
SettingsCmdCreateNetworkReference Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkReference


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdEditInStormSewers Class
Class Hierarchy
SettingsCmdEditInStormSewers Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdEditInStormSewers


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdExportStormSewerData Class
Class Hierarchy
SettingsCmdExportStormSewerData Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdExportStormSewerData


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdImportStormSewerData Class
Class Hierarchy
SettingsCmdImportStormSewerData Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdImportStormSewerData


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdRenamePipeNetworkParts Class
Class Hierarchy
SettingsCmdRenamePipeNetworkParts Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdRenamePipeNetworkParts


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdResetAnchorPipe Class
Class Hierarchy
SettingsCmdResetAnchorPipe Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdResetAnchorPipe


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsCmdShowSpanningPipes Class
Class Hierarchy
SettingsCmdShowSpanningPipes Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdShowSpanningPipes


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipe Class
Class Hierarchy
SettingsPipe Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipe


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork Class
Class Hierarchy
SettingsPipeNetwork Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartPlanLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartProfLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartSectLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPartsToProf
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPipeTable
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkPlanLabels
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkProfLabels
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkSectLabels
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddNetworkStructTable
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddSpanningPipePlanLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdAddSpanningPipeProfLabel
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateAlignFromNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateInterferenceCheck
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetwork
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkFromObject
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkPartsList
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkPartsListFull
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdCreateNetworkReference
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdEditInStormSewers
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdExportStormSewerData
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdImportStormSewerData
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdRenamePipeNetworkParts
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdResetAnchorPipe
        Autodesk::Civil::PipeNetwork::Settings::SettingsCmdShowSpanningPipes


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsNameFormat Class
Class Hierarchy
SettingsPipeNetwork::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsProfileLabelPlacement Class
Class Hierarchy
SettingsPipeNetwork::SettingsProfileLabelPlacement Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsProfileLabelPlacement


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsRules Class
Class Hierarchy
SettingsPipeNetwork::SettingsRules Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsRules


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsSectionLabelPlacement Class
Class Hierarchy
SettingsPipeNetwork::SettingsSectionLabelPlacement Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsSectionLabelPlacement


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStormSewersMigration Class
Class Hierarchy
SettingsPipeNetwork::SettingsStormSewersMigration Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsStormSewersMigration


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsPipeNetwork::SettingsStyles Class
Class Hierarchy
SettingsPipeNetwork::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::PipeNetwork Namespace > Autodesk::Civil::PipeNetwork::Settings Namespace > Classes > SettingsStructure Class
Class Hierarchy
SettingsStructure Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::PipeNetwork::Settings::SettingsStructure


Class Hierarchy
PropertyAnchorPoint Class
Class Hierarchy
Autodesk::Civil::PropertyAnchorPoint


Class Hierarchy
PropertyAngle Class
Class Hierarchy
Autodesk::Civil::PropertyAngle


Class Hierarchy
PropertyBlock Class
Class Hierarchy
Autodesk::Civil::PropertyBlock


Class Hierarchy
PropertyBoolean Class
Class Hierarchy
Autodesk::Civil::PropertyBoolean


Class Hierarchy
PropertyEnum Template
Class Hierarchy
Autodesk::Civil::PropertyEnum


Class Hierarchy
PropertyObjectName Class
Class Hierarchy
Autodesk::Civil::PropertyObjectName


Autodesk::Civil::QTO Namespace Namespaces
Autodesk::Civil::QTO Namespace
Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::QTO::DatabaseServices namespace.


Autodesk::Civil::QTO::DatabaseServices Namespace Classes
Autodesk::Civil::QTO::DatabaseServices Namespace
Classes
Class | Description
QTOUtility | This is class Autodesk::Civil::QTO::DatabaseServices::QTOUtility.


Topics
Autodesk::Civil::QTO::DatabaseServices Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::QTO Namespace > Autodesk::Civil::QTO::DatabaseServices Namespace > Classes > QTOUtility Class
Class Hierarchy
QTOUtility Class
Class Hierarchy
Autodesk::Civil::QTO::DatabaseServices::QTOUtility


Autodesk::Civil::Roadway Namespace Namespaces
Autodesk::Civil::Roadway Namespace
Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::Roadway::DatabaseServices namespace.
Settings | The Autodesk::Civil::Roadway::Settings namespace.


Autodesk::Civil::Roadway Namespace Structs, Records, Enums
Autodesk::Civil::Roadway Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
AssemblyDisplayStyleType | The Autodesk::Civil::Roadway::AssemblyDisplayStyleType enumeration.
LinkCreationType | An enumeration that defines the link creation type.
QuantityTakeoffLengthComputeType | An enumeration that specifies the length computation type in the take off process.
QuantityTakeoffPipeLengthType | An enumeration that specifies the pipe length type in the take off process.
QuantityTakeoffReportExtentType | An enumeration that specifies the extents used when finding entities to participate in the take off process.
QuantityTakeoffReportType | An enumeration that specifies the quantity takeoff report type.
RoadwaySideType | An enumeration that defines the roadway side type.


Topics
Autodesk::Civil::Roadway Namespace
Topics
Topic | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Autodesk::Civil::Roadway::DatabaseServices Namespace Classes
Autodesk::Civil::Roadway::DatabaseServices Namespace
Classes
Class | Description
AppliedAssembly | Represents an AppliedAssembly object. An AppliedAssembly is a cross section of an existing corridor.
AppliedAssemblyCollection | The collection of assembly cross sections placed at intervals along corridor baselines.
AppliedSubassembly | An AppliedSubassemby object. An AppliedSubassembly is a series of points, links, and shapes that make up part of an AppliedAssembly... more
AppliedSubassemblyCollection | Collection of AppliedSubassembly objects.
Assembly | Pattern for the cross section of a corridor. Made up of multiple Subassembly objects.
AssemblyCollection | A collection of Assembly objects.
BaseBaseline | The base class for baselines, such as Baseline, OffsetBaseline, and HardcodedOffsetBaseline.
Baseline | A 3D path defined by an alignment and a profile. A corridor is defined by a baseline (or multiple baselines)... more
BaselineCollection | A collection of Baseline objects.
BaselineFeatureLines | A collection of multiple feature line collections (FeatureLinesCol) associated with a particular baseline or offset baseline.
BaselineFeatureLinesCollection | A collection of multiple feature line collections (BaselineFeatureLines) objects.
BaselineRegion | A segment of a baseline, specified by alignment stations for the start and end point. In a corridor, each baseline... more
BaselineRegionCollection | A collection of baseline region (BaselineRegion) objects.
CalculatedLink | The CalculatedLink class. A CalculatedLink joins two CalculatedPoint objects, and is a component of an AppliedSubassembly object, which in turn... more
CalculatedLinkCollection | A calculated link is a collection of calculated points (CalculatedPoint) which are connected to form a line. Calculated... more
CalculatedPoint | The CalculatedPoint class. A CalculatedPoint is the basic component that defines the stucture of an AppliedSubassembly.
CalculatedPointCollection | A collection of calculated point (CalculatedPoint) objects. Calculated points are used to define applied subassemblies.
CalculatedShape | The CalculatedShape class. A CalculatedShape is defined from links and defines a closed region that represents materials used in a... more
CalculatedShapeCollection | Collection of calculated shape (CalculatedShape) objects.
CalculatedSubentity | Parent class for the CalculatedShape, CalculatedLink and CalculatedPoint interfaces.
CodeCollection | The Corridor code collection class. The wrapped object could be AeccDbRoadwayState or AeccDbSubassembly.
Corridor | Representation of a roadway. Follows a 3D path defined by a baseline, and is made up of cross sections (... more
CorridorCodeCollection | A collection of strings containing corridor codes. A code is used to identify common calculated points in applied assemblies in... more
CorridorCollection | A collection of Corridor objects.
CorridorSection | A section of a Corridor.
CorridorSurface | Represents a layer of a corridor, and is computed from a set of feature lines, calculated points, and calculated links.... more
CorridorSurfaceBaseMask | Base class for CorridorSurfaceMask and CorridorSurfaceBoundary.
CorridorSurfaceBoundary | A corridor surface boundary represents an outside or inside edge of a corridor surface (CorridorSurface). It is defined... more
CorridorSurfaceBoundaryCollection | Collection of corridor surface boundary (CorridorSurfaceBoundary) objects.
CorridorSurfaceCollection | A collection of corridor surface (CorridorSurface) objects.
CorridorSurfaceMask | The corridor surface mask is a region defined by a polygon or a series of feature line components (FeatureLineComponent... more
CorridorSurfaceMaskCollection | Collection of corridor surface mask (CorridorSurfaceMask) objects.
FeatureLine | A feature line is a connected series of points along a corridor created by joining those points from each assembly... more
FeatureLineCodeInfo | Information about the code used to construct a feature line.
FeatureLineCodeInfoCollection | A collection of feature line code information (FeatureLineCodeInfo) objects.
FeatureLineCollection | Collection of feature lines that share a particular code. Multiple points in a single assembly may contain the same code,... more
FeatureLineCollectionMap | A collection of multiple feature line collections (FeatureLineCollection) objects.
FeatureLineComponent | A portion of an entire feature line, delimited by a starting and ending station.
FeatureLineComponentCollection | A collection of feature line component (FeatureLineComponent) objects.
FeatureLinePoint | A point in a feature line (FeatureLine object). A feature line is created by connecting common points within applied... more
FeatureLinePointCollection | A collection of feature line point (FeatureLinePoint) objects.
HardcodedOffsetBaseline | An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between... more
Intersection | An object that manages the intersection of two Alignments. An intersection object builds on and manages various object data, including... more
IntersectionRegion | Corridor regions in an Intersection area.
IntersectionRegionCollection | A collection of IntersectionRegion objects.
IntersectionRoad | Road components managed by an Intersection object.
IntersectionRoadCollection | A collection of IntersectionRoad objecs managed by an Intersection object.
Link | Roadway Link object. Connects roadway points in a subassembly.
LinkCollection | A collection of Link objects.
OffsetBaseline | An offset baseline is a secondary baseline within a corridor that is offset from the main baseline. The distance between... more
OffsetBaselineCollection | Collection of offset baseline objects. There are two kinds of offset baselines, OffsetBaseline and HardcodedOffsetBaseline. Both of these are... more
Point | Roadway Point object. Represents a single point within a subassembly.
PointCollection | A collection of Roadway Point objects.
SampledSectionLink | Defines a single line segment of sample surface cross-section data.
SampledSectionLinkCollection | Collection of sampled elevation data.
Shape | Roadway Shape object. Represents a series of roadway links which form a closed shape. Used in subassemblies.
ShapeCollection | A collection of Roadway Shape objects.
SlopeElevationTarget | The SlopeElevation class.
Subassembly | Pattern for part of a corridor cross section, representing a particular portion of a roadway.
SubassemblyCollection | A collection of Subassembly objects.
SubassemblyGenerator | Controls the way Subassembly geometry is generated.
WidthOffsetTarget | The WidthOffsetTarget class.


Autodesk::Civil::Roadway::DatabaseServices Namespace Interfaces
Autodesk::Civil::Roadway::DatabaseServices Namespace
Interfaces
Interface | Description
IPoint | This is class Autodesk::Civil::Roadway::DatabaseServices::IPoint.


Autodesk::Civil::Roadway::DatabaseServices Namespace Namespaces
Autodesk::Civil::Roadway::DatabaseServices Namespace
Namespaces
Namespace | Description
Styles | The Autodesk::Civil::Roadway::DatabaseServices::Styles namespace.


Autodesk::Civil::Roadway::DatabaseServices Namespace Structs, Records, Enums
Autodesk::Civil::Roadway::DatabaseServices Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
CorridorBaselineType | Enumerates baseline types.
CorridorLinkDisplay | The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDisplay enumeration.
CorridorLinkDrawOverride | The Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDrawOverride enumeration.
CorridorSurfaceBoundaryType | Defines CorridorSurfaceBoundary types.
CurbReturnJoiningType | Specifies the method that is used to define the curb return profile.
IntersectionCorridorType | Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown Maintained: When this options... more
MaterialConditionType | An enumeration that specifies the material condition type.
MaterialItemType | An enumeration that specifies the material item type.
MaterialQuantityType | An enumeration that specifies the material quantity type.
OffsetLengthOption | Specifies how the length of the offset alignment is determined. When Select To Intersection Extents is selected, offset alignments are... more
SideRoadProfileDistanceRuleType | Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection Extents is... more
SubassemblyGeometryGenerateMode | Enumerates the way subassembly geometry can be generated.


Topics
Autodesk::Civil::Roadway::DatabaseServices Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssembly Class
Class Hierarchy
AppliedAssembly Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AppliedAssembly


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedAssemblyCollection Class
Class Hierarchy
AppliedAssemblyCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AppliedAssemblyCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassembly Class
Class Hierarchy
AppliedSubassembly Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassembly


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AppliedSubassemblyCollection Class
Class Hierarchy
AppliedSubassemblyCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AppliedSubassemblyCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Assembly Class
Class Hierarchy
Assembly Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Roadway::DatabaseServices::Assembly


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > AssemblyCollection Class
Class Hierarchy
AssemblyCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::AssemblyCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaseBaseline Class
Class Hierarchy
BaseBaseline Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaseBaseline
    Autodesk::Civil::Roadway::DatabaseServices::Baseline
    Autodesk::Civil::Roadway::DatabaseServices::HardcodedOffsetBaseline
    Autodesk::Civil::Roadway::DatabaseServices::OffsetBaseline


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Baseline Class
Class Hierarchy
Baseline Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaseBaseline
    Autodesk::Civil::Roadway::DatabaseServices::Baseline


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineCollection Class
Class Hierarchy
BaselineCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLines Class
Class Hierarchy
BaselineFeatureLines Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLines


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineFeatureLinesCollection Class
Class Hierarchy
BaselineFeatureLinesCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineFeatureLinesCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegion Class
Class Hierarchy
BaselineRegion Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineRegion


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > BaselineRegionCollection Class
Class Hierarchy
BaselineRegionCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaselineRegionCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLink Class
Class Hierarchy
CalculatedLink Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedLink


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedLinkCollection Class
Class Hierarchy
CalculatedLinkCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedLinkCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPoint Class
Class Hierarchy
CalculatedPoint Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedPoint


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedPointCollection Class
Class Hierarchy
CalculatedPointCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedPointCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShape Class
Class Hierarchy
CalculatedShape Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedShape


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedShapeCollection Class
Class Hierarchy
CalculatedShapeCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedShapeCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CalculatedSubentity Class
Class Hierarchy
CalculatedSubentity Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CalculatedSubentity
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedLink
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedPoint
    Autodesk::Civil::Roadway::DatabaseServices::CalculatedShape


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CodeCollection Class
Class Hierarchy
CodeCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CodeCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Corridor Class
Class Hierarchy
Corridor Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Roadway::DatabaseServices::Corridor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCodeCollection Class
Class Hierarchy
CorridorCodeCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorCodeCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorCollection Class
Class Hierarchy
CorridorCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSection Class
Class Hierarchy
CorridorSection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurface Class
Class Hierarchy
CorridorSurface Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurface


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBaseMask Class
Class Hierarchy
CorridorSurfaceBaseMask Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundary
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMask


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundary Class
Class Hierarchy
CorridorSurfaceBoundary Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundary


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceBoundaryCollection Class
Class Hierarchy
CorridorSurfaceBoundaryCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceCollection Class
Class Hierarchy
CorridorSurfaceCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMask Class
Class Hierarchy
CorridorSurfaceMask Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBaseMask
    Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMask


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > CorridorSurfaceMaskCollection Class
Class Hierarchy
CorridorSurfaceMaskCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceMaskCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLine Class
Class Hierarchy
FeatureLine Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLine


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfo Class
Class Hierarchy
FeatureLineCodeInfo Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfo


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCodeInfoCollection Class
Class Hierarchy
FeatureLineCodeInfoCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCodeInfoCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollection Class
Class Hierarchy
FeatureLineCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineCollectionMap Class
Class Hierarchy
FeatureLineCollectionMap Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineCollectionMap


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponent Class
Class Hierarchy
FeatureLineComponent Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponent


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLineComponentCollection Class
Class Hierarchy
FeatureLineComponentCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLineComponentCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePoint Class
Class Hierarchy
FeatureLinePoint Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePoint


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > FeatureLinePointCollection Class
Class Hierarchy
FeatureLinePointCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::FeatureLinePointCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > HardcodedOffsetBaseline Class
Class Hierarchy
HardcodedOffsetBaseline Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaseBaseline
    Autodesk::Civil::Roadway::DatabaseServices::HardcodedOffsetBaseline


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Intersection Class
Class Hierarchy
Intersection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Roadway::DatabaseServices::Intersection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegion Class
Class Hierarchy
IntersectionRegion Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IntersectionRegion


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRegionCollection Class
Class Hierarchy
IntersectionRegionCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IntersectionRegionCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoad Class
Class Hierarchy
IntersectionRoad Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IntersectionRoad


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > IntersectionRoadCollection Class
Class Hierarchy
IntersectionRoadCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IntersectionRoadCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Interfaces > IPoint Interface
Class Hierarchy
IPoint Interface
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IPoint
    Autodesk::Civil::Roadway::DatabaseServices::Point


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Link Class
Class Hierarchy
Link Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Link


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > LinkCollection Class
Class Hierarchy
LinkCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::LinkCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaseline Class
Class Hierarchy
OffsetBaseline Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::BaseBaseline
    Autodesk::Civil::Roadway::DatabaseServices::OffsetBaseline


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > OffsetBaselineCollection Class
Class Hierarchy
OffsetBaselineCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::OffsetBaselineCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Point Class
Class Hierarchy
Point Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::IPoint
    Autodesk::Civil::Roadway::DatabaseServices::Point


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > PointCollection Class
Class Hierarchy
PointCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::PointCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLink Class
Class Hierarchy
SampledSectionLink Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SampledSectionLink


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SampledSectionLinkCollection Class
Class Hierarchy
SampledSectionLinkCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SampledSectionLinkCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Shape Class
Class Hierarchy
Shape Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Shape


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > ShapeCollection Class
Class Hierarchy
ShapeCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::ShapeCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SlopeElevationTarget Class
Class Hierarchy
SlopeElevationTarget Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SlopeElevationTarget


Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace Classes

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace Classes
Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Classes
Class | Description
AssemblyStyle | Used to control the visual style of an Assembly object.
AssemblyStyleCollection | A collection of AssemblyStyle objects.
CodeSetStyle | A collection of CodeSetStyleItem objects. CodeSetStyleItem defines a code and related style, where the style is the ObjectId of a... more
CodeSetStyleCollection | A collection of CodeSetStyle objects.
CodeSetStyleItem | Defines the style to apply to a specific code.
CorridorStyle | Defines the appearance of objects.
CorridorStyleCollection | A collection of CorridorStyle objects.
IntersectionStyle | The match line style wrapper class.
IntersectionStyleCollection | The IntersectionStyleCollection class.
LabelStylesIntersectionRoot | Root for all intersection label collections.
LinkStyle | Used to control the visual style of a roadway link (Link) object.
LinkStyleCollection | A collection of LinkStyle objects.
QuantityTakeoffCriteria | A collection of items that define the criteria used to calculate material lists, which are then used ot generate quantity... more
QuantityTakeoffCriteriaCollection | The QuantityTakeoffCriteriaCollection class.
QuantityTakeoffCriteriaData | Defines additional data for material in QuantityTakeoffCriteria.
QuantityTakeoffCriteriaItem | Defines a material used to create quantity takeoff criteria (QuantityTakeoffCriteria).
ShapeStyle | Used to control the visual style of a roadway shape (Shape) object.
ShapeStyleCollection | A collection of ShapeStyle objects.
SubassemblySubentityStyle | Base class for LinkStyle and ShapeStyle.


Classes (AutoDoc Folder)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Legend
Legend
Class


Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace Structs, Records, Enums

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace Structs, Records, Enums
Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
CodeSetStyleItemType | Specifies valid CodeSetStyleItem types.
CorridorDisplayStyleType | The Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorDisplayStyleType enumeration.
ShapeDisplayStyleType | Defines ShapeStyle display style type.
SubassemblySubentityStyleType | The Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyleType enumeration.


Structs, Records, Enums (AutoDoc Folder)

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Legend
Legend
Enumeration


Topics

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Topics
Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyle Class
Class Hierarchy
AssemblyStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > AssemblyStyleCollection Class
Class Hierarchy
AssemblyStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::AssemblyStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyle Class
Class Hierarchy
CodeSetStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleCollection Class
Class Hierarchy
CodeSetStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CodeSetStyleItem Class
Class Hierarchy
CodeSetStyleItem Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleItem


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyle Class
Class Hierarchy
CorridorStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > CorridorStyleCollection Class
Class Hierarchy
CorridorStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyle Class
Class Hierarchy
IntersectionStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > IntersectionStyleCollection Class
Class Hierarchy
IntersectionStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::IntersectionStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LabelStylesIntersectionRoot Class
Class Hierarchy
LabelStylesIntersectionRoot Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::LabelStylesNode
    Autodesk::Civil::Roadway::DatabaseServices::Styles::LabelStylesIntersectionRoot


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyle Class
Class Hierarchy
LinkStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyle
            Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > LinkStyleCollection Class
Class Hierarchy
LinkStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteria Class
Class Hierarchy
QuantityTakeoffCriteria Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteria


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaCollection Class
Class Hierarchy
QuantityTakeoffCriteriaCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaData Class
Class Hierarchy
QuantityTakeoffCriteriaData Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaData


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > QuantityTakeoffCriteriaItem Class
Class Hierarchy
QuantityTakeoffCriteriaItem Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::Styles::QuantityTakeoffCriteriaItem


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyle Class
Class Hierarchy
ShapeStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyle
            Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > ShapeStyleCollection Class
Class Hierarchy
ShapeStyleCollection Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Styles::StyleCollectionBase
    Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyleCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Autodesk::Civil::Roadway::DatabaseServices::Styles Namespace > Classes > SubassemblySubentityStyle Class
Class Hierarchy
SubassemblySubentityStyle Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::DBObject
    Autodesk::Civil::DatabaseServices::Styles::StyleBase
        Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyle
            Autodesk::Civil::Roadway::DatabaseServices::Styles::LinkStyle
            Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeStyle


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > Subassembly Class
Class Hierarchy
Subassembly Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::GeoEntity
        Autodesk::Civil::Roadway::DatabaseServices::Subassembly


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyCollection Class
Class Hierarchy
SubassemblyCollection Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SubassemblyCollection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > SubassemblyGenerator Class
Class Hierarchy
SubassemblyGenerator Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::SubassemblyGenerator


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::DatabaseServices Namespace > Classes > WidthOffsetTarget Class
Class Hierarchy
WidthOffsetTarget Class
Class Hierarchy
Autodesk::Civil::Roadway::DatabaseServices::WidthOffsetTarget


Autodesk::Civil::Roadway::Settings Namespace Classes
Autodesk::Civil::Roadway::Settings Namespace
Classes
Class | Description
SettingsAssembly | Settings for Assembly.
SettingsAssembly::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsAssembly::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsCmdAddIntersectionLabel | Settings for AddIntersectionLabel command.
SettingsCmdAddMaterialVolumeTable | Settings for AddMaterialVolumeTable command.
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation | Settings of table creation for command AddMaterialVolumeTable.
SettingsCmdAddTotalVolumeTable | Settings for AddTotalVolumeTable command.
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation | Settings of table creation for command AddTotalVolumeTable.
SettingsCmdAssignPayItemToArea | Settings for AssignPayItemToArea command.
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions | Settings of pay item assignment for command AssignPayItemToArea.
SettingsCmdComputeMaterials | Settings for ComputeMaterials command.
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial | Settings of material definition for command ComputeMaterials.
SettingsCmdCorridorExtractSurfaces | Settings for CorridorExtractSurfaces command.
SettingsCmdCreateAlignFromCorridor | Settings for CreateAlignFromCorridor command.
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption | Settings for alignment type option.
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions | Settings for criteria based design options.
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption | Settings for profile creation option.
SettingsCmdCreateAssembly | Settings for CreateAssembly command.
SettingsCmdCreateAssemblyTool | Settings for CreateAssemblyTool command.
SettingsCmdCreateCorridor | Settings for CreateCorridor command.
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion | Settings for alignment type option.
SettingsCmdCreateIntersection | Settings for CreateIntersection command.
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion | Settings for the default assembly insertion of new intersection
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes | Settings for the default cross slopes of new intersection
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters | Settings for the default curb return parameters of new intersection
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules | Settings for the default curb return profile rules of new intersection
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions | Settings for the default intersection options of new intersection
SettingsCmdCreateIntersection::SettingsCmdOffsets | Settings for the default offsets of new intersection
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules | Settings for the default secondary road profile rules of new intersection
SettingsCmdCreateIntersection::SettingsCmdWideningParameters | Settings for the default widening parameters of new intersection
SettingsCmdCreatePointsFromCorridor | Settings for CreatePointsFromCorridor command.
SettingsCmdCreatePolylineFromCorridor | Settings for CreatePolylineFromCorridor command.
SettingsCmdCreateProfileFromCorridor | Settings for CreateProfileFromCorridor command.
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions | Settings that specify the defaults used when creating a profile using design criteria.
SettingsCmdCreateSimpleCorridor | Settings for CreateSimpleCorridor command.
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion | Settings that establish the defaults assigned to corridor creation.
SettingsCmdCreateSubassemblyTool | Settings for CreateSubassemblyTool command.
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions | Settings
SettingsCmdCreateSubFromPline | Settings for CreateSubFromPline command.
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities | Settings that specifies the default behavior for creating subassemblies from polylines.
SettingsCmdFeatureLinesFromCorridor | Settings for FeatureLinesFromCorridor command.
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation | Default settings for the Feature Line Creation command.
SettingsCmdGenerateQuantitiesReport | Settings for GenerateQuantitiesReport command.
SettingsCmdTakeOff | Settings for TakeOff command.
SettingsCmdTakeOff::SettingsCmdComputeTakeOff | Settings of take off computation for command TakeOff.
SettingsCmdViewEditCorridorSection | Settings for ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings | Settings for the Grid Settings section of the ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings | Settings for the Grid Text Settings section of the ViewEditCorridorSection command.
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions | Settings for the View/Edit Options section of the ViewEditCorridorSection command.
SettingsCorridor | Controls ambient settings for corridors.
SettingsCorridor::SettingsNameFormat | Settings to specify the default name formats for corridors and corridor surfaces, as well as for alignments and profiles from... more
SettingsCorridor::SettingsRegionHighlightGraphics | Settings for Corridor styles.
SettingsCorridor::SettingsStyles | Settings to establish the default styles assigned to corridor components.
SettingsIntersection | Settings for Intersection.
SettingsIntersection::SettingsNameFormat | Settings to establish the default styles assigned to assembly components.
SettingsIntersection::SettingsStyles | Settings to establish the default styles assigned to assembly components.
SettingsQuantityTakeoff | Settings for QuantityTakeoff.
SettingsQuantityTakeoff::SettingsNameFormat | Settings to establish the default name format to quantity takeoff.
SettingsQuantityTakeoff::SettingsStyles | Settings to establish the default styles assigned to quantity takeoff.
SettingsSubassembly | Contains settings that apply to the assembly feature, as specified in the Edit Feature Settings dialog box.
SettingsSubassembly::SettingsDefaultStyles | Settings for subassembly default styles.
SettingsSubassembly::SettingsNameFormat | Settings for Corridor styles.


Topics
Autodesk::Civil::Roadway::Settings Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly Class
Class Hierarchy
SettingsAssembly Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsAssembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAssembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAssemblyTool


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsNameFormat Class
Class Hierarchy
SettingsAssembly::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsAssembly::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsAssembly::SettingsStyles Class
Class Hierarchy
SettingsAssembly::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsAssembly::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddIntersectionLabel Class
Class Hierarchy
SettingsCmdAddIntersectionLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsIntersection
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddIntersectionLabel


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable Class
Class Hierarchy
SettingsCmdAddMaterialVolumeTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddMaterialVolumeTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable Class
Class Hierarchy
SettingsCmdAddTotalVolumeTable Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddTotalVolumeTable


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class
Class Hierarchy
SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea Class
Class Hierarchy
SettingsCmdAssignPayItemToArea Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdAssignPayItemToArea


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class
Class Hierarchy
SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials Class
Class Hierarchy
SettingsCmdComputeMaterials Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdComputeMaterials


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class
Class Hierarchy
SettingsCmdComputeMaterials::SettingsCmdDefineMaterial Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdComputeMaterials::SettingsCmdDefineMaterial


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCorridorExtractSurfaces Class
Class Hierarchy
SettingsCmdCorridorExtractSurfaces Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCorridorExtractSurfaces


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor Class
Class Hierarchy
SettingsCmdCreateAlignFromCorridor Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class
Class Hierarchy
SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class
Class Hierarchy
SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class
Class Hierarchy
SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAssembly Class
Class Hierarchy
SettingsCmdCreateAssembly Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsAssembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAssembly


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateAssemblyTool Class
Class Hierarchy
SettingsCmdCreateAssemblyTool Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsAssembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAssemblyTool


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor Class
Class Hierarchy
SettingsCmdCreateCorridor Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateCorridor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class
Class Hierarchy
SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection Class
Class Hierarchy
SettingsCmdCreateIntersection Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsIntersection
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class
Class Hierarchy
SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class
Class Hierarchy
SettingsCmdCreateIntersection::SettingsCmdCrossSlopes Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdCrossSlopes


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class
Class Hierarchy
SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class
Class Hierarchy
SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class
Class Hierarchy
SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdOffsets Class
Class Hierarchy
SettingsCmdCreateIntersection::SettingsCmdOffsets Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdOffsets


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class
Class Hierarchy
SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class
Class Hierarchy
SettingsCmdCreateIntersection::SettingsCmdWideningParameters Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection::SettingsCmdWideningParameters


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreatePointsFromCorridor Class
Class Hierarchy
SettingsCmdCreatePointsFromCorridor Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreatePointsFromCorridor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreatePolylineFromCorridor Class
Class Hierarchy
SettingsCmdCreatePolylineFromCorridor Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreatePolylineFromCorridor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor Class
Class Hierarchy
SettingsCmdCreateProfileFromCorridor Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateProfileFromCorridor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class
Class Hierarchy
SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor Class
Class Hierarchy
SettingsCmdCreateSimpleCorridor Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSimpleCorridor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class
Class Hierarchy
SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool Class
Class Hierarchy
SettingsCmdCreateSubassemblyTool Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsSubassembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubassemblyTool


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class
Class Hierarchy
SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline Class
Class Hierarchy
SettingsCmdCreateSubFromPline Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsSubassembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubFromPline


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class
Class Hierarchy
SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor Class
Class Hierarchy
SettingsCmdFeatureLinesFromCorridor Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdFeatureLinesFromCorridor


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class
Class Hierarchy
SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdGenerateQuantitiesReport Class
Class Hierarchy
SettingsCmdGenerateQuantitiesReport Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdGenerateQuantitiesReport


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff Class
Class Hierarchy
SettingsCmdTakeOff Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdTakeOff


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class
Class Hierarchy
SettingsCmdTakeOff::SettingsCmdComputeTakeOff Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdTakeOff::SettingsCmdComputeTakeOff


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection Class
Class Hierarchy
SettingsCmdViewEditCorridorSection Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class
Class Hierarchy
SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class
Class Hierarchy
SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class
Class Hierarchy
SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor Class
Class Hierarchy
SettingsCorridor Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCorridorExtractSurfaces
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateAlignFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreatePointsFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreatePolylineFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateProfileFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSimpleCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdFeatureLinesFromCorridor
        Autodesk::Civil::Roadway::Settings::SettingsCmdViewEditCorridorSection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsNameFormat Class
Class Hierarchy
SettingsCorridor::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCorridor::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsRegionHighlightGraphics Class
Class Hierarchy
SettingsCorridor::SettingsRegionHighlightGraphics Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCorridor::SettingsRegionHighlightGraphics


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsCorridor::SettingsStyles Class
Class Hierarchy
SettingsCorridor::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsCorridor::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection Class
Class Hierarchy
SettingsIntersection Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsIntersection
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddIntersectionLabel
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateIntersection


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsNameFormat Class
Class Hierarchy
SettingsIntersection::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsIntersection::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsIntersection::SettingsStyles Class
Class Hierarchy
SettingsIntersection::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsIntersection::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff Class
Class Hierarchy
SettingsQuantityTakeoff Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddMaterialVolumeTable
        Autodesk::Civil::Roadway::Settings::SettingsCmdAddTotalVolumeTable
        Autodesk::Civil::Roadway::Settings::SettingsCmdAssignPayItemToArea
        Autodesk::Civil::Roadway::Settings::SettingsCmdComputeMaterials
        Autodesk::Civil::Roadway::Settings::SettingsCmdGenerateQuantitiesReport
        Autodesk::Civil::Roadway::Settings::SettingsCmdTakeOff


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsNameFormat Class
Class Hierarchy
SettingsQuantityTakeoff::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff::SettingsNameFormat


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsQuantityTakeoff::SettingsStyles Class
Class Hierarchy
SettingsQuantityTakeoff::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff::SettingsStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly Class
Class Hierarchy
SettingsSubassembly Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Roadway::Settings::SettingsSubassembly
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubassemblyTool
        Autodesk::Civil::Roadway::Settings::SettingsCmdCreateSubFromPline


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsDefaultStyles Class
Class Hierarchy
SettingsSubassembly::SettingsDefaultStyles Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsSubassembly::SettingsDefaultStyles


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Roadway Namespace > Autodesk::Civil::Roadway::Settings Namespace > Classes > SettingsSubassembly::SettingsNameFormat Class
Class Hierarchy
SettingsSubassembly::SettingsNameFormat Class
Class Hierarchy
Autodesk::Civil::Roadway::Settings::SettingsSubassembly::SettingsNameFormat


Autodesk::Civil::Runtime Namespace Classes
Autodesk::Civil::Runtime Namespace
Classes
Class | Description
CorridorState | Contains a wide array of information about a corridor and methods for determining locations relative to the corridor. Used in... more
Param | Use Autodesk.Civil.IParam instead.
ParamAlignment | Alignment parameter.
ParamAlignmentCollection | A collection of Alignment parameters.
ParamBase | The base class for parameters.
ParamBool | A boolean parameter.
ParamBoolCollection | A collection of boolean parameters.
ParamCollectionBase | Base class for parameter collections.
ParamDouble | A parameter with a double value.
ParamDoubleCollection | A collection of double parameters.
ParamElevationTarget | Elevation target parameter.
ParamElevationTargetCollection | A collection of elevation target parameters.
ParamLong | A long parameter.
ParamLongCollection | A collection of long parameters.
ParamOffsetTarget | An offset target parameter.
ParamOffsetTargetCollection | A collection of offset target parameters.
ParamPoint | A point parameter.
ParamPointCollection | A collection of point parameters.
ParamProfile | A Profile parameter.
ParamProfileCollection | A collection of profile parameters.
ParamString | A string parameter.
ParamStringCollection | A collection of string parameters.
ParamSurface | A Surface parameter.
ParamSurfaceCollection | A collection of surface parameters.
PipeNetworkState | Contains the properties of the drawing's pipe network state.
RuntimeState | Base class for objects containing user-defined parameters describing an object state.


Autodesk::Civil::Runtime Namespace Interfaces
Autodesk::Civil::Runtime Namespace
Interfaces
Interface | Description
IParam | Interface for parameters.


Autodesk::Civil::Runtime Namespace Structs, Records, Enums
Autodesk::Civil::Runtime Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
CorridorError | Corridor error types.
CorridorErrorLevel | Error severity levels for Corridors.
CorridorLayoutModeDisplay | Layout modes for subassemblies.
CorridorMode | Roadway mode (design or layout).
ParamAccessType | Defines access permissions for a parameter.
ParamLogicalNameType | The Autodesk::Civil::Runtime::ParamLogicalNameType enumeration.
ParamScope | Defines the parameter scope.
ParamsOwnerType | Defines the owner type for a parameter.
ParamType | Defines the parameter type.
TypeInfoBool | The Autodesk::Civil::Runtime::TypeInfoBool enumeration.
TypeInfoDouble | The Autodesk::Civil::Runtime::TypeInfoDouble enumeration.
TypeInfoLong | The Autodesk::Civil::Runtime::TypeInfoLong enumeration.


Topics
Autodesk::Civil::Runtime Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy
CorridorState Class
Class Hierarchy
Autodesk::Civil::Runtime::RuntimeState
    Autodesk::Civil::Runtime::CorridorState


Class Hierarchy
IParam Interface
Class Hierarchy
Autodesk::Civil::Runtime::IParam
    Autodesk::Civil::Runtime::ParamBase


Class Hierarchy
Param Class
Class Hierarchy
Autodesk::Civil::Runtime::Param


Class Hierarchy
ParamAlignment Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamAlignment


Class Hierarchy
ParamAlignmentCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamAlignmentCollection


Class Hierarchy
ParamBase Template
Class Hierarchy
Autodesk::Civil::Runtime::IParam
    Autodesk::Civil::Runtime::ParamBase


Class Hierarchy
ParamBool Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamBool


Class Hierarchy
ParamBoolCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamBoolCollection


Class Hierarchy
ParamCollectionBase Template
Class Hierarchy
Autodesk::Civil::Runtime::ParamCollectionBase


Class Hierarchy
ParamDouble Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamDouble


Class Hierarchy
ParamDoubleCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamDoubleCollection


Class Hierarchy
ParamElevationTarget Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamElevationTarget


Class Hierarchy
ParamElevationTargetCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamElevationTargetCollection


Class Hierarchy
ParamLong Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamLong


Class Hierarchy
ParamLongCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamLongCollection


Class Hierarchy
ParamOffsetTarget Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamOffsetTarget


Class Hierarchy
ParamOffsetTargetCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamOffsetTargetCollection


Class Hierarchy
ParamPoint Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamPoint


Class Hierarchy
ParamPointCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamPointCollection


Class Hierarchy
ParamProfile Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamProfile


Class Hierarchy
ParamProfileCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamProfileCollection


Class Hierarchy
ParamString Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamString


Class Hierarchy
ParamStringCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamStringCollection


Class Hierarchy
ParamSurface Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamSurface


Class Hierarchy
ParamSurfaceCollection Class
Class Hierarchy
Autodesk::Civil::Runtime::ParamSurfaceCollection


Class Hierarchy
PipeNetworkState Class
Class Hierarchy
Autodesk::Civil::Runtime::RuntimeState
    Autodesk::Civil::Runtime::PipeNetworkState


Class Hierarchy
RuntimeState Class
Class Hierarchy
Autodesk::Civil::Runtime::RuntimeState
    Autodesk::Civil::Runtime::CorridorState
    Autodesk::Civil::Runtime::PipeNetworkState


Autodesk::Civil::Settings Namespace Classes
Autodesk::Civil::Settings Namespace
Classes
Class | Description
SettingsAbbreviation | Contains profile and alignment abbreviation strings as specified on the Abbreviations tab of the Drawing Settings dialog box.
SettingsAmbient | Specify default ambient (background) settings for units of measurement. These units are used throughout AutoCAD Civil 3D, unless they are... more
SettingsAmbient::SettingsAngle | Specify how to display deflection angles between two vectors.
SettingsAmbient::SettingsArea | Specify how to display surface areas.
SettingsAmbient::SettingsCoordinate | Specify how to display X and Y coordinates.
SettingsAmbient::SettingsDimension | Specify how to display linear dimensions.
SettingsAmbient::SettingsDirection | Specify how to display directions.
SettingsAmbient::SettingsDistance | Specify how to display linear distances.
SettingsAmbient::SettingsElevation | Specify how to display surface elevations.
SettingsAmbient::SettingsGeneral | Specify how to display text, numbers, and units.
SettingsAmbient::SettingsGrade | Specify how to display grade measurements.
SettingsAmbient::SettingsGradeSlope | Specify how to display grade and slope measurements.
SettingsAmbient::SettingsGridCoordinate | Specifies default (ambient) settings for grid coordinate values.
SettingsAmbient::SettingsLabeling | Specifies the default method for prompting for objects when inserting labels that contain Referenced Text components.
SettingsAmbient::SettingsLatLong | Specify how to display latitude and longitude.
SettingsAmbient::SettingsSlope | Specify how to display slope measurements.
SettingsAmbient::SettingsSpeed | Specify how to display speeds for design criteria.
SettingsAmbient::SettingsStation | Specify how to display linear features that use station or chainage.
SettingsAmbient::SettingsTransparentCommands | specify the prompting behavior of transparent commands across all features. The formats used to prompt for grade and slope values... more
SettingsAmbient::SettingsUnitless | These settings specify how to display numeric values that are not specifically defined by the unit type.
SettingsAmbient::SettingsVolume | Specify how to display terrain volumes.
SettingsCmdAddNoteLabel | Settings for AddNoteLabel command.
SettingsCmdAddSegmentLabel | Settings for AddSegmentLabel command.
SettingsCmdAddSegmentLabels | Settings for AddSegmentLabels command.
SettingsCmdCreateArcByBestFit | Settings for CreateArcByBestFit command.
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit arc creation.
SettingsCmdCreateLineByBestFit | Settings for CreateLineByBestFit command.
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit line creation.
SettingsCmdCreateParabolaByBestFit | Settings for CreateParabolaByBestFit command.
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption | Use these settings to specify the default behavior when curve entities are used as an input option for best fit... more
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption | Use this setting to specify the default behavior for regression analysis graphs in best fit parabola creation.
SettingsCmdMapCheck | Settings for MapCheck command.
SettingsCmdMapCheck::SettingsCmdMapcheck | Use these settings to specify the default behavior for Mapcheck.
SettingsCoordinateSystem | Encapsulates coordinate system settings.
SettingsDrawing | Contains settings that apply to the drawing, as specified in the Drawing Settings dialog box.
SettingsGeneral | Settings for General.
SettingsGeneral::SettingsStyles | Default styles settings class.
SettingsLandXML | Settings that define how data is imported from LandXML file.
SettingsLandXMLExport | Settings that define how data is exported from LandXML file.
SettingsLandXMLExport::SettingsAlignmentExport | Alignment Settings for LandXML export.
SettingsLandXMLExport::SettingsData | Data Settings for LandXML export.
SettingsLandXMLExport::SettingsIdentification | Identification Settings for LandXML export.
SettingsLandXMLExport::SettingsParcelExport | Parcel Settings for LandXML export.
SettingsLandXMLExport::SettingsPointExport | Point Settings for LandXML export.
SettingsLandXMLExport::SettingsSurfaceExport | Surface Settings for LandXML export.
SettingsLandXMLImport | Settings that define how data is imported from LandXML file.
SettingsLandXMLImport::SettingsConflictResolution | ConflictResolution settings for LandXML importing.
SettingsLandXMLImport::SettingsDiameterUnits | On import, AutoCAD Civil 3D reads the LandXML.Units.diameterUnits, and if they are defined, those units are used for both pipes... more
SettingsLandXMLImport::SettingsPipeNetwork | PipeNetwork settings for LandXML importing.
SettingsLandXMLImport::SettingsPointImport | PointImport settings for LandXML importing.
SettingsLandXMLImport::SettingsRotation | Rotation settings for LandXML importing.
SettingsLandXMLImport::SettingsSurfaceImport | SurfaceImport settings for LandXML importing.
SettingsLandXMLImport::SettingsTranslation | Translation settings for LandXML importing.
SettingsObjectLayer | SettingsObjectLayer class specifies layers for individual object in AutoCAD Civil 3D.
SettingsObjectLayers | The SettingsObjectLayers class is to specify layers for various objects in AutoCAD Civil 3D. For example, you can specify that... more
SettingsRoot | The root of the settings hierarchy.
SettingsTag | The Settings specify how line, curve and spiral components are numbered and renumbered.
SettingsTag::SettingsCreation | Settings of creation for the SettingsTag.
SettingsTag::SettingsRenumbering | Settings of renumbering for the SettingsTag.
SettingsTransformation | The SettingsTransformation class use to transform the coordinate system to local specifications.
SettingsUnitZone | The settings class for the unit zone.


Autodesk::Civil::Settings Namespace Structs, Records, Enums
Autodesk::Civil::Settings Namespace
Structs, Records, Enums
Struct, Record, Enum | Description
DrawingUnitType | Specifies the linear units (feet or meters) for drawing entities in AutoCAD model space.
GridScaleFactorType | Specifies the type of scale factor.
ImperialToMetricConversionType | Specifies the Imperial to Metric conversion type for the drawing.
LandXMLAngularUnits | Specifies the units of the exported angles and directions.
LandXMLAttributeExportType | Specifies the field that is used for specific attribute in the LandXML file.
LandXMLConflictResolutionType | Specifies how objects with the same name are handled.
LandXMLImperialUnitType | Defines the default imperial pipe and structure diameter units that are applied when units are not specified in the source... more
LandXMLLinearUnits | Specifies how to tag LandXML data when working in Imperial units.
LandXMLMetricUnitType | Defines the default metric pipe and structure diameter units that are applied when units are not specified in the source... more
LandXMLPointDescriptionType | Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions.
LandXMLSurfaceDataExportType | Specifies how to export the surface data.
LandXMLSurfaceDataImportType | Specifies how to import the data. NoteIf the LandXML surface you intend to import has only breaklines (for example, no... more
MapcheckAngleType | Definition of MapCheck Angle type.
MapcheckCurveDirectionType | Definition of MapCheck Curve Direction type.
MapcheckSideType | Definition of MapCheck side type.
MapcheckTraverseMethodType | Definition of MapCheck Traverse Method type.
ObjectLayerModifierType | Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier.
SettingsObjectLayerType | The Autodesk::Civil::Settings::SettingsObjectLayerType enumeration.
SpecifyRotationType | An enumeration that use to specify a rotation about the reference point in one of two ways: specify a rotation... more


Topics
Autodesk::Civil::Settings Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.


Class Hierarchy
SettingsAbbreviation Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAbbreviation


Class Hierarchy
SettingsAmbient Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Land::Settings::SettingsAlignment
    Autodesk::Civil::Land::Settings::SettingsBuildingSite
    Autodesk::Civil::Land::Settings::SettingsGrading
    Autodesk::Civil::Land::Settings::SettingsMassHaulLine
    Autodesk::Civil::Land::Settings::SettingsMassHaulView
    Autodesk::Civil::Land::Settings::SettingsMatchLine
    Autodesk::Civil::Land::Settings::SettingsParcel
    Autodesk::Civil::Land::Settings::SettingsPoint
    Autodesk::Civil::Land::Settings::SettingsProfile
    Autodesk::Civil::Land::Settings::SettingsProfileView
    Autodesk::Civil::Land::Settings::SettingsSampleLine
    Autodesk::Civil::Land::Settings::SettingsSection
    Autodesk::Civil::Land::Settings::SettingsSectionView
    Autodesk::Civil::Land::Settings::SettingsSurface
    Autodesk::Civil::Land::Settings::SettingsViewFrame
    Autodesk::Civil::Land::Settings::SettingsViewFrameGroup
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipe
    Autodesk::Civil::PipeNetwork::Settings::SettingsPipeNetwork
    Autodesk::Civil::PipeNetwork::Settings::SettingsStructure
    Autodesk::Civil::Roadway::Settings::SettingsAssembly
    Autodesk::Civil::Roadway::Settings::SettingsCorridor
    Autodesk::Civil::Roadway::Settings::SettingsIntersection
    Autodesk::Civil::Roadway::Settings::SettingsQuantityTakeoff
    Autodesk::Civil::Roadway::Settings::SettingsSubassembly
    Autodesk::Civil::Settings::SettingsGeneral
    Autodesk::Civil::Survey::Settings::SettingsSurvey


Class Hierarchy
SettingsAmbient::SettingsAngle Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsAngle


Class Hierarchy
SettingsAmbient::SettingsArea Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsArea


Class Hierarchy
SettingsAmbient::SettingsCoordinate Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsCoordinate


Class Hierarchy
SettingsAmbient::SettingsDimension Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsDimension


Class Hierarchy
SettingsAmbient::SettingsDirection Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsDirection


Class Hierarchy
SettingsAmbient::SettingsDistance Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsDistance


Class Hierarchy
SettingsAmbient::SettingsElevation Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsElevation


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsFormatNumber Template
Class Hierarchy
SettingsAmbient::SettingsFormatNumber Template
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsFormatNumber


Class Hierarchy
SettingsAmbient::SettingsGeneral Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsGeneral


Class Hierarchy
SettingsAmbient::SettingsGrade Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsGrade


Class Hierarchy
SettingsAmbient::SettingsGradeSlope Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsGradeSlope


Class Hierarchy
SettingsAmbient::SettingsGridCoordinate Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsGridCoordinate


Class Hierarchy
SettingsAmbient::SettingsLabeling Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsLabeling


Class Hierarchy
SettingsAmbient::SettingsLatLong Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsLatLong


Class Hierarchy
SettingsAmbient::SettingsSlope Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsSlope


Class Hierarchy
SettingsAmbient::SettingsSpeed Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsSpeed


Class Hierarchy
SettingsAmbient::SettingsStation Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsStation


Class Hierarchy
SettingsAmbient::SettingsTransparentCommands Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsTransparentCommands


Class Hierarchy
SettingsAmbient::SettingsUnitless Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsUnitless


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Classes > SettingsAmbient::SettingsUnitlessNumber Class
Class Hierarchy
SettingsAmbient::SettingsUnitlessNumber Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsUnitlessNumber


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::SettingsUnitNumber Template
Class Hierarchy
SettingsAmbient::SettingsUnitNumber Template
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsUnitNumber


Class Hierarchy
SettingsAmbient::SettingsVolume Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::SettingsVolume


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsAmbient Class > SettingsAmbient Templates > SettingsAmbient::TUnit Template
Class Hierarchy
SettingsAmbient::TUnit Template
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient::TUnit


Class Hierarchy
SettingsCmdAddNoteLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdAddNoteLabel


Class Hierarchy
SettingsCmdAddSegmentLabel Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdAddSegmentLabel


Class Hierarchy
SettingsCmdAddSegmentLabels Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdAddSegmentLabels


Class Hierarchy
SettingsCmdCreateArcByBestFit Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdCreateArcByBestFit


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class
Class Hierarchy
SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class
Class Hierarchy
SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption


Class Hierarchy
SettingsCmdCreateLineByBestFit Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdCreateLineByBestFit


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class
Class Hierarchy
SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class
Class Hierarchy
SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption


Class Hierarchy
SettingsCmdCreateParabolaByBestFit Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdCreateParabolaByBestFit


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class
Class Hierarchy
SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class
Class Hierarchy
SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption


Class Hierarchy
SettingsCmdMapCheck Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdMapCheck


Class Hierarchy
SettingsCmdMapCheck::SettingsCmdMapcheck Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsCmdMapCheck::SettingsCmdMapcheck


Class Hierarchy
SettingsCoordinateSystem Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsCoordinateSystem


Class Hierarchy
SettingsDrawing Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsDrawing


Class Hierarchy
SettingsGeneral Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Settings::SettingsGeneral
        Autodesk::Civil::Settings::SettingsCmdAddNoteLabel
        Autodesk::Civil::Settings::SettingsCmdAddSegmentLabel
        Autodesk::Civil::Settings::SettingsCmdAddSegmentLabels
        Autodesk::Civil::Settings::SettingsCmdCreateArcByBestFit
        Autodesk::Civil::Settings::SettingsCmdCreateLineByBestFit
        Autodesk::Civil::Settings::SettingsCmdCreateParabolaByBestFit
        Autodesk::Civil::Settings::SettingsCmdMapCheck


Class Hierarchy
SettingsGeneral::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsGeneral::SettingsStyles


Class Hierarchy
SettingsLandXML Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXML


Class Hierarchy
SettingsLandXMLExport Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport


Class Hierarchy
SettingsLandXMLExport::SettingsAlignmentExport Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsAlignmentExport


Class Hierarchy
SettingsLandXMLExport::SettingsData Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsData


Class Hierarchy
SettingsLandXMLExport::SettingsIdentification Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsIdentification


Class Hierarchy
SettingsLandXMLExport::SettingsParcelExport Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsParcelExport


Class Hierarchy
SettingsLandXMLExport::SettingsPointExport Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsPointExport


Class Hierarchy
SettingsLandXMLExport::SettingsSurfaceExport Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLExport::SettingsSurfaceExport


Class Hierarchy
SettingsLandXMLImport Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Settings Namespace > Classes > SettingsLandXMLImport::SettingsConflictResolution Class
Class Hierarchy
SettingsLandXMLImport::SettingsConflictResolution Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsConflictResolution


Class Hierarchy
SettingsLandXMLImport::SettingsDiameterUnits Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsDiameterUnits


Class Hierarchy
SettingsLandXMLImport::SettingsPipeNetwork Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsPipeNetwork


Class Hierarchy
SettingsLandXMLImport::SettingsPointImport Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsPointImport


Class Hierarchy
SettingsLandXMLImport::SettingsRotation Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsRotation


Class Hierarchy
SettingsLandXMLImport::SettingsSurfaceImport Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsSurfaceImport


Class Hierarchy
SettingsLandXMLImport::SettingsTranslation Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsLandXMLImport::SettingsTranslation


Class Hierarchy
SettingsObjectLayer Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsObjectLayer


Class Hierarchy
SettingsObjectLayers Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsObjectLayers


Class Hierarchy
SettingsRoot Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsRoot


Class Hierarchy
SettingsTag Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsTag


Class Hierarchy
SettingsTag::SettingsCreation Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsTag::SettingsCreation


Class Hierarchy
SettingsTag::SettingsRenumbering Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsTag::SettingsRenumbering


Class Hierarchy
SettingsTransformation Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsTransformation


Class Hierarchy
SettingsUnitZone Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsUnitZone


Autodesk::Civil::Survey Namespace Namespaces
Autodesk::Civil::Survey Namespace
Namespaces
Namespace | Description
DatabaseServices | The Autodesk::Civil::Survey::DatabaseServices namespace.
Settings | The Autodesk::Civil::Survey::Settings namespace.


Autodesk::Civil::Survey::DatabaseServices Namespace Classes
Autodesk::Civil::Survey::DatabaseServices Namespace
Classes
Class | Description
SurveyFigure | Survey figure class. Figures are groups of connected lines and arcs where the figure vertexes can reference survey points.
SurveyNetworkEntity | The drawing database version of a survey network object.


Topics
Autodesk::Civil::Survey::DatabaseServices Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::DatabaseServices Namespace > Classes > SurveyFigure Class
Class Hierarchy
SurveyFigure Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::DatabaseServices::Feature
        Autodesk::Civil::Land::DatabaseServices::FeatureLine
            Autodesk::Civil::Survey::DatabaseServices::SurveyFigure


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::DatabaseServices Namespace > Classes > SurveyNetworkEntity Class
Class Hierarchy
SurveyNetworkEntity Class
Class Hierarchy
Autodesk::Civil::DatabaseServices::Entity
    Autodesk::Civil::Survey::DatabaseServices::SurveyNetworkEntity


Autodesk::Civil::Survey::Settings Namespace Classes
Autodesk::Civil::Survey::Settings Namespace
Classes
Class | Description
SettingsSurvey | Settings for Survey.
SettingsSurvey::SettingsStyles | Default styles settings for Survey class


Topics
Autodesk::Civil::Survey::Settings Namespace
Topics
Topic | Description
Classes | The following table lists classes in this documentation.


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey Class
Class Hierarchy
SettingsSurvey Class
Class Hierarchy
Autodesk::Civil::Settings::SettingsAmbient
    Autodesk::Civil::Survey::Settings::SettingsSurvey


Class Hierarchy

Autodesk Namespace > Autodesk::Civil Namespace > Autodesk::Civil::Survey Namespace > Autodesk::Civil::Survey::Settings Namespace > Classes > SettingsSurvey::SettingsStyles Class
Class Hierarchy
SettingsSurvey::SettingsStyles Class
Class Hierarchy
Autodesk::Civil::Survey::Settings::SettingsSurvey::SettingsStyles


Comments?

Using this form sends your comments to the Autodesk Technical Publications group responsible for this documentation.

Topic title and location (do not edit):
Name (optional):
         Email (optional):
Comments:

Note: This form is not intended as a way for you to receive feedback or technical support. The information you provide will be used to enhance future updates to the documentation. Thanks!


Copyright Information

©2008 Autodesk, Inc. All Rights Reserved. Except as otherwise permitted by Autodesk, Inc., this publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose.
Certain materials included in this publication are reprinted with the permission of the copyright holder.

Trademarks

The following are registered trademarks or trademarks of Autodesk, Inc., in the USA and other countries: 3DEC (design/logo), 3December, 3December.com, 3ds Max, ActiveShapes, Actrix, ADI, Alias, Alias (swirl design/logo), AliasStudio, Alias|Wavefront (design/logo), ATC, AUGI, AutoCAD, AutoCAD Learning Assistance, AutoCAD LT, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, Autodesk, Autodesk Envision, Autodesk Insight, Autodesk Intent, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSnap, AutoSketch, AutoTrack, Backdraft, Built with ObjectARX (logo), Burn, Buzzsaw, CAiCE, Can You Imagine, Character Studio, Cinestream, Civil 3D, Cleaner, Cleaner Central, ClearScale, Colour Warper, Combustion, Communication Specification, Constructware, Content Explorer, Create>what's>Next> (design/logo), Dancing Baby (image), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, Design|Studio (design/logo), Design Your World, Design Your World (design/logo), DWF, DWG, DWG (logo), DWG TrueConvert, DWG TrueView, DXF, EditDV, Education by Design, Exposure, Extending the Design Team, FBX, Filmbox, FMDesktop, Freewheel, GDX Driver, Gmax, Heads-up Design, Heidi, HOOPS, HumanIK, i-drop, iMOUT, Incinerator, IntroDV, Inventor, Inventor LT, Kaydara, Kaydara (design/logo), LocationLogic, Lustre, Maya, Mechanical Desktop, MotionBuilder, Mudbox, NavisWorks, ObjectARX, ObjectDBX, Open Reality, Opticore, Opticore Opus, PolarSnap, PortfolioWall, Powered with Autodesk Technology, Productstream, ProjectPoint, ProMaterials, Reactor, RealDWG, Real-time Roto, Recognize, Render Queue, Reveal, Revit, Showcase, ShowMotion, SketchBook, SteeringWheels, StudioTools, Topobase, Toxik, ViewCube, Visual, Visual Bridge, Visual Construction, Visual Drainage, Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Syllabus, Visual Toolbox, Visual Tugboat, Visual LISP, Voice Reality, Volo, Wiretap, and WiretapCentral.
The following are registered trademarks or trademarks of Autodesk Canada Co. in the USA and/or Canada and other countries: Backburner, Discreet, Fire, Flame, Flint, Frost, Inferno, Multi-Master Editing, River, Smoke, Sparks, Stone, and Wire.
All other brand names, product names or trademarks belong to their respective holders.

Disclaimer

THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE BY AUTODESK, INC. "AS IS." AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS.

Published by: Autodesk, Inc.
111 Mclnnis Parkway
San Rafael, CA 94903, USA


Index

Index

Search Result

Index

! | = | A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y

!

!=

=

==

A

A

AbbreviationsSettings

Above enumeration member

AbsoluteModelSize

AbsoluteUnits enumeration member

Acceleration enumeration member

Access

Acre enumeration member

Across enumeration member

AcrossChord enumeration member

ActiveDocument

ActiveProduct

Add

AddChild

AddComponent

AddContourLabeling

AddCorridorShape

AddCrestCurve

AddCriteria

AddCurvePipe

AddCurvesBetweenTangents

AddDataOptions

AddDesignCheck

AddEnumData

AddFixedCurve

AddFixedLine

AddFixedSpiral

AddFixedSymmetricParabolaByEntityEndAndThroughPoint

AddFixedSymmetricParabolaByThreePoints

AddFixedSymmetricParabolaByTwoPointsAndEndGrade

AddFixedSymmetricParabolaByTwoPointsAndK

AddFixedSymmetricParabolaByTwoPointsAndRadius

AddFixedSymmetricParabolaByTwoPointsAndStartGrade

AddFixedTangent

AddFixedTangentWithPreviousEntity

AddFloatingArcWithSpiral

AddFloatingCSS

AddFloatingCurve

AddFloatingLine

AddFloatingLineWithSpiral

AddFloatingSSC

AddFloatingSymmetricParabolaByThroughPointAndGrade

AddFloatingSymmetricParabolaByThroughPointAndK

AddFloatingSymmetricParabolaByThroughPointAndRadius

AddFloatingTangent

AddFreeAsymmetricParabolaByPVIAndLengths

AddFreeCircularCurveByPVIAndLength

AddFreeCircularCurveByPVIAndRadius

AddFreeCircularCurveByPVIAndThroughPoint

AddFreeCurve

AddFreeLine

AddFreeSCS

AddFreeSCSCS

AddFreeSCSSCS

AddFreeSpiral

AddFreeSSBetweenCurves

AddFreeSSBetweenTangents

AddFreeSTS

AddFreeSymmetricParabolaByK

AddFreeSymmetricParabolaByLength

AddFreeSymmetricParabolaByPVIAndCurveLength

AddFreeSymmetricParabolaByPVIAndK

AddFreeSymmetricParabolaByPVIAndThroughPoint

AddFreeSymmetricParabolaByRadius

AddFreeTangent

AdditionalSampleControls

AddLinePipe

AddMaterial

AddNetworkLabels

AddOffset enumeration member

AddPartFamilyByDescription

AddPartFamilyByGuid

AddPartSize

AddPayItemId

AddPVI

AddPVIArc

AddPVIAsymParabola

AddPVISymParabola

AddReferenceTextComponent

AddRegion

AddSagCurve

AddStation

AddStructure

AddSurface

AddTextForEachComponent

AddToProfileView

AddToSectionView

AddToVault

AddVertices enumeration member

AdjustedDatum

AlignHatchToPipe

AlignHatchToPipe enumeration member

Alignment

Alignment class

about Alignment class

Alignment enumeration member

Alignment::AlignmentType property

Alignment::CopyToSite method

Alignment::Create method

Alignment::CreateOffsetAlignment method

Alignment::CreationMode property

Alignment::DesignCheckSetId property

Alignment::DesignCheckSetName property

Alignment::DesignSpeeds property

Alignment::DistanceToAlignment method

Alignment::EndingStation property

Alignment::Entities property

Alignment::GetInstantaneousRadius method

Alignment::GetLabelGroupIds method

Alignment::GetLabelIds method

Alignment::GetNextUniqueName method

Alignment::GetPolyline method

Alignment::GetProfileIds method

Alignment::GetProfileViewIds method

Alignment::GetRegions method

Alignment::GetSampleLineGroupIds method

Alignment::GetStationSet method

Alignment::GetStationStringWithEquations method

Alignment::GetSuperelevationZoneAtStation method

Alignment::ImportLabelSet method

Alignment::IsSiteless property

Alignment::Length property

Alignment::PointLocation method

Alignment::ReferencePoint property

Alignment::ReferencePointStation property

Alignment::Reverse method

Alignment::SiteId property

Alignment::SiteName property

Alignment::StartingStation property

Alignment::StationEquations property

Alignment::StationIndexIncrement property

Alignment::StationOffset method

Alignment::StyleId property

Alignment::StyleName property

Alignment::SuperElevationAtStation method

Alignment::SuperElevationData property

Alignment::UpdateMode property

Alignment::UseDesignCheckSet property

Alignment::UseDesignCriteriaFile property

Alignment::UseDesignSpeed property

AlignmentArc class

about AlignmentArc class

AlignmentArc::CenterPoint property

AlignmentArc::ChordDirection property

AlignmentArc::ChordLength property

AlignmentArc::Clockwise property

AlignmentArc::Constraint2 property

AlignmentArc::CurveGroupIndex property

AlignmentArc::CurveGroupSubEntityIndex property

AlignmentArc::default property

AlignmentArc::DeflectedAngle property

AlignmentArc::Delta property

AlignmentArc::DirectionAtPoint1 property

AlignmentArc::DirectionAtPoint2 property

AlignmentArc::EndDirection property

AlignmentArc::ExternalSecant property

AlignmentArc::ExternalTangent property

AlignmentArc::GreaterThan180 property

AlignmentArc::Length property

AlignmentArc::MidOrdinate property

AlignmentArc::MinimumRadius property

AlignmentArc::PassThroughPoint1 property

AlignmentArc::PassThroughPoint2 property

AlignmentArc::PassThroughPoint3 property

AlignmentArc::PIStation property

AlignmentArc::Radius property

AlignmentArc::ReverseCurve property

AlignmentArc::StartDirection property

AlignmentArc::SubEntityCount property

AlignmentBeginning enumeration member

AlignmentBeginningPoint enumeration member

AlignmentCurve class

about AlignmentCurve class

AlignmentCurve enumeration member

AlignmentCurve::EndPoint property

AlignmentCurve::EndStation property

AlignmentCurve::HighestDesignSpeed property

AlignmentCurve::Length property

AlignmentCurve::StartPoint property

AlignmentCurve::StartStation property

AlignmentCurveLabel class

about AlignmentCurveLabel class

AlignmentCurveLabel::Create method

AlignmentCurveNextAutomaticTagCounter

AlignmentCurveNextManualTagCounter

AlignmentCurveTableStyles

AlignmentDesignCheck class

about AlignmentDesignCheck class

AlignmentDesignCheck::DesignCheckType property

AlignmentDesignCheckCollection class

about AlignmentDesignCheckCollection class

AlignmentDesignCheckCollection::Add method

AlignmentDesignCheckCollection::Clear method

AlignmentDesignCheckCollection::Count property

AlignmentDesignCheckCollection::default property

AlignmentDesignCheckCollection::Remove method

AlignmentDesignCheckCollection::RemoveAt method

AlignmentDesignCheckRoot

AlignmentDesignCheckRoot class

about AlignmentDesignCheckRoot class

AlignmentDesignCheckRoot::AlignmentDesignCheckRoot constructor

AlignmentDesignCheckRoot::CurveDesignChecks property

AlignmentDesignCheckRoot::LineDesignChecks property

AlignmentDesignCheckRoot::SpiralDesignChecks property

AlignmentDesignCheckRoot::TangentIntersectionDesignChecks property

AlignmentDesignCheckSet class

about AlignmentDesignCheckSet class

AlignmentDesignCheckSet::AddDesignCheck method

AlignmentDesignCheckSet::GetAllDesignChecks method

AlignmentDesignCheckSet::RemoveAllDesignCheck method

AlignmentDesignCheckSet::RemoveDesignCheck method

AlignmentDesignCheckSetCollection class

about AlignmentDesignCheckSetCollection class

AlignmentDesignCheckSetCollection::Add method

AlignmentDesignCheckSets

AlignmentDesignSpeed enumeration member

AlignmentDesignSpeedLabelGroup class

about AlignmentDesignSpeedLabelGroup class

AlignmentDesignSpeedLabelGroup::Create method

AlignmentDesignSpeedLabelGroup::GetAvailableLabelGroups method

AlignmentEnd enumeration member

AlignmentEndPoint enumeration member

AlignmentEntity class

about AlignmentEntity class

AlignmentEntity::Constraint1 property

AlignmentEntity::default property

AlignmentEntity::DesignChecks method

AlignmentEntity::EntityAfter property

AlignmentEntity::EntityBefore property

AlignmentEntity::EntityId property

AlignmentEntity::EntityType property

AlignmentEntity::SubEntityCount property

AlignmentEntity::ValidateDesignCheck method

AlignmentEntityCollection class

about AlignmentEntityCollection class

AlignmentEntityCollection::AddFixedCurve method

AlignmentEntityCollection::AddFixedLine method

AlignmentEntityCollection::AddFixedSpiral method

AlignmentEntityCollection::AddFloatingArcWithSpiral method

AlignmentEntityCollection::AddFloatingCSS method

AlignmentEntityCollection::AddFloatingCurve method

AlignmentEntityCollection::AddFloatingLine method

AlignmentEntityCollection::AddFloatingLineWithSpiral method

AlignmentEntityCollection::AddFloatingSSC method

AlignmentEntityCollection::AddFreeCurve method

AlignmentEntityCollection::AddFreeLine method

AlignmentEntityCollection::AddFreeSCS method

AlignmentEntityCollection::AddFreeSCSCS method

AlignmentEntityCollection::AddFreeSCSSCS method

AlignmentEntityCollection::AddFreeSpiral method

AlignmentEntityCollection::AddFreeSSBetweenCurves method

AlignmentEntityCollection::AddFreeSSBetweenTangents method

AlignmentEntityCollection::AddFreeSTS method

AlignmentEntityCollection::Clear method

AlignmentEntityCollection::Count property

AlignmentEntityCollection::default property

AlignmentEntityCollection::EntityAtId method

AlignmentEntityCollection::EntityAtStation method

AlignmentEntityCollection::FirstEntity property

AlignmentEntityCollection::GetEntityByOrder method

AlignmentEntityCollection::GetEnumerator method

AlignmentEntityCollection::GetObjectEnumerator method

AlignmentEntityCollection::LastEntity property

AlignmentEntityCollection::Remove method

AlignmentEntityCollection::RemoveAt method

AlignmentExport

AlignmentFromFeatureLine

AlignmentFromNetwork

AlignmentGeometryPoint enumeration member

AlignmentGeometryPointLabelGroup class

about AlignmentGeometryPointLabelGroup class

AlignmentGeometryPointLabelGroup::Create method

AlignmentGeometryPointLabelGroup::GetAvailableLabelGroups method

AlignmentGeometryPointLabelGroup::GetGeometryPointsOptions method

AlignmentGeometryPointLabelGroup::SetGeometryPointsOptions method

AlignmentGeoPointEntityData

AlignmentGeoPointText

AlignmentId

AlignmentLabelGroup class

about AlignmentLabelGroup class

AlignmentLabelGroup::GetAvailableLabelGroups method

AlignmentLabelGroup::RangeEnd property

AlignmentLabelGroup::RangeEndFromFeature property

AlignmentLabelGroup::RangeStart property

AlignmentLabelGroup::RangeStartFromFeature property

AlignmentLabeling enumeration member

AlignmentLabelSet

AlignmentLabelSetStyles

AlignmentLabelStyles

AlignmentLine class

about AlignmentLine class

AlignmentLine enumeration member

AlignmentLine::Constraint2 property

AlignmentLine::CurveGroupIndex property

AlignmentLine::CurveGroupSubEntityIndex property

AlignmentLine::default property

AlignmentLine::Direction property

AlignmentLine::Length property

AlignmentLine::MidPoint property

AlignmentLine::PassThroughPoint1 property

AlignmentLine::PassThroughPoint2 property

AlignmentLine::SubEntityCount property

AlignmentLineNextAutomaticTagCounter

AlignmentLineNextManualTagCounter

AlignmentLineTableStyles

AlignmentMajorStation enumeration member

AlignmentMinorStation enumeration member

AlignmentMinorStationLabelGroup class

about AlignmentMinorStationLabelGroup class

AlignmentMinorStationLabelGroup::Create method

AlignmentMinorStationLabelGroup::GetAvailableLabelGroups method

AlignmentMinorStationLabelGroup::MajorStationLabelGroup property

AlignmentName

AlignmentNameTemplate

AlignmentPILabel class

about AlignmentPILabel class

AlignmentPILabel::Create method

AlignmentPILabelGroup class

about AlignmentPILabelGroup class

AlignmentProfileGeometryPoint enumeration member

AlignmentRegion class

about AlignmentRegion class

AlignmentRegion::EndStation property

AlignmentRegion::Length property

AlignmentRegion::OffsetDist property

AlignmentRegion::RegionType property

AlignmentRegion::StartStation property

AlignmentRegionCollection class

about AlignmentRegionCollection class

AlignmentRegionCollection::Count property

AlignmentRegionCollection::default property

AlignmentRegionCollection::GetEnumerator method

AlignmentRegionCollection::GetObjectEnumerator method

AlignmentRegionCollection::MergeToNeighborRegion method

AlignmentSCS class

about AlignmentSCS class

AlignmentSCS::Arc property

AlignmentSCS::Constraint2 property

AlignmentSCS::default property

AlignmentSCS::SpiralIn property

AlignmentSCS::SpiralOut property

AlignmentSCS::SubEntityCount property

AlignmentSCSCS class

about AlignmentSCSCS class

AlignmentSCSCS::Arc1 property

AlignmentSCSCS::Arc2 property

AlignmentSCSCS::Constraint2 property

AlignmentSCSCS::default property

AlignmentSCSCS::Spiral1 property

AlignmentSCSCS::Spiral2 property

AlignmentSCSCS::Spiral3 property

AlignmentSCSCS::SubEntityCount property

AlignmentSCSSCS class

about AlignmentSCSSCS class

AlignmentSCSSCS::Arc1 property

AlignmentSCSSCS::Arc2 property

AlignmentSCSSCS::Constraint2 property

AlignmentSCSSCS::default property

AlignmentSCSSCS::Spiral1 property

AlignmentSCSSCS::Spiral2 property

AlignmentSCSSCS::Spiral3 property

AlignmentSCSSCS::Spiral4 property

AlignmentSCSSCS::SubEntityCount property

AlignmentSegment enumeration member

AlignmentSegmentTableStyles

AlignmentSpiral class

about AlignmentSpiral class

AlignmentSpiral enumeration member

AlignmentSpiral::A property

AlignmentSpiral::Compound property

AlignmentSpiral::Constraint2 property

AlignmentSpiral::CurveGroupIndex property

AlignmentSpiral::CurveGroupSubEntityIndex property

AlignmentSpiral::CurveType property

AlignmentSpiral::default property

AlignmentSpiral::Delta property

AlignmentSpiral::Direction property

AlignmentSpiral::EndDirection property

AlignmentSpiral::K property

AlignmentSpiral::Length property

AlignmentSpiral::LongTangent property

AlignmentSpiral::MinimumTransitionLength property

AlignmentSpiral::P property

AlignmentSpiral::RadialPoint property

AlignmentSpiral::RadiusIn property

AlignmentSpiral::RadiusOut property

AlignmentSpiral::ShortTangent property

AlignmentSpiral::SPIAngle property

AlignmentSpiral::SPIPoint property

AlignmentSpiral::SpiralDefinition property

AlignmentSpiral::SPIStation property

AlignmentSpiral::StartDirection property

AlignmentSpiral::SubEntityCount property

AlignmentSpiral::TotalX property

AlignmentSpiral::TotalY property

AlignmentSpiralLabel class

about AlignmentSpiralLabel class

AlignmentSpiralLabel::Create method

AlignmentSpiralNextAutomaticTagCounter

AlignmentSpiralNextManualTagCounter

AlignmentSpiralTableStyles

AlignmentSSCSS class

about AlignmentSSCSS class

AlignmentSSCSS::Arc property

AlignmentSSCSS::Constraint2 property

AlignmentSSCSS::default property

AlignmentSSCSS::Spiral1 property

AlignmentSSCSS::Spiral2 property

AlignmentSSCSS::Spiral3 property

AlignmentSSCSS::Spiral4 property

AlignmentSSCSS::SubEntityCount property

AlignmentStartToEnd enumeration member

AlignmentStationEquation enumeration member

AlignmentStationEquationLabelGroup class

about AlignmentStationEquationLabelGroup class

AlignmentStationEquationLabelGroup::Create method

AlignmentStationEquationLabelGroup::GetAvailableLabelGroups method

AlignmentStationLabelGroup class

about AlignmentStationLabelGroup class

AlignmentStationLabelGroup::Create method

AlignmentStationLabelGroup::GetAvailableLabelGroups method

AlignmentStationLabelGroup::Increment property

AlignmentStationOffset enumeration member

AlignmentStationRangeSpecifiedByUser

AlignmentSTS class

about AlignmentSTS class

AlignmentSTS::Constraint2 property

AlignmentSTS::default property

AlignmentSTS::SpiralIn property

AlignmentSTS::SpiralOut property

AlignmentSTS::SubEntityCount property

AlignmentSTS::Tangent property

AlignmentStyle

AlignmentStyle class

about AlignmentStyle class

AlignmentStyle::ArrowHeadOption property

AlignmentStyle::BeginPointMarkerStyle property

AlignmentStyle::CompoundCurveIntersectPointMarkerStyle property

AlignmentStyle::CurveLineIntersectPointMarkerStyle property

AlignmentStyle::CurveSpiralIntersectPointMarkerStyle property

AlignmentStyle::EnableRadiusSnap property

AlignmentStyle::EndPointMarkerStyle property

AlignmentStyle::GetDisplayStyleModel method

AlignmentStyle::GetDisplayStylePlan method

AlignmentStyle::GetDisplayStyleSection method

AlignmentStyle::GetLineMarkerDisplayStyleSection method

AlignmentStyle::IntersectionPointMarkerStyle property

AlignmentStyle::LineCurveIntersectPointMarkerStyle property

AlignmentStyle::LineMarkerDisplayStyleSection property

AlignmentStyle::LineSpiralIntersectPointMarkerStyle property

AlignmentStyle::MidPointMarkerStyle property

AlignmentStyle::RadiusSnapValue property

AlignmentStyle::ReverseCurveIntersectPointMarkerStyle property

AlignmentStyle::ReverseSpiralIntersectPointMarkerStyle property

AlignmentStyle::SpiralCurveIntersectPointMarkerStyle property

AlignmentStyle::SpiralLineIntersectPointMarkerStyle property

AlignmentStyle::SpiralSpiralIntersectPointMarkerStyle property

AlignmentStyle::StationReferencePointMarkerStyle property

AlignmentStyle::ThroughPointMarkerStyle property

AlignmentStyleCollection class

about AlignmentStyleCollection class

AlignmentStyleCollection::Add method

AlignmentStyles

AlignmentSubEntity class

about AlignmentSubEntity class

AlignmentSubEntity::CurveGroupIndex property

AlignmentSubEntity::CurveGroupSubEntityIndex property

AlignmentSubEntity::DesignChecks method

AlignmentSubEntity::EndPoint property

AlignmentSubEntity::EndStation property

AlignmentSubEntity::Length property

AlignmentSubEntity::StartPoint property

AlignmentSubEntity::StartStation property

AlignmentSubEntity::SubEntityType property

AlignmentSubEntity::ValidateDesignCheck method

AlignmentSubEntityArc class

about AlignmentSubEntityArc class

AlignmentSubEntityArc::CenterPoint property

AlignmentSubEntityArc::ChordDirection property

AlignmentSubEntityArc::ChordLength property

AlignmentSubEntityArc::Clockwise property

AlignmentSubEntityArc::DeflectedAngle property

AlignmentSubEntityArc::Delta property

AlignmentSubEntityArc::DirectionAtPoint1 property

AlignmentSubEntityArc::DirectionAtPoint2 property

AlignmentSubEntityArc::EndDirection property

AlignmentSubEntityArc::ExternalSecant property

AlignmentSubEntityArc::ExternalTangent property

AlignmentSubEntityArc::GreaterThan180 property

AlignmentSubEntityArc::MidOrdinate property

AlignmentSubEntityArc::MinimumRadius property

AlignmentSubEntityArc::PassThroughPoint1 property

AlignmentSubEntityArc::PassThroughPoint2 property

AlignmentSubEntityArc::PassThroughPoint3 property

AlignmentSubEntityArc::PIPoint property

AlignmentSubEntityArc::PIStation property

AlignmentSubEntityArc::Radius property

AlignmentSubEntityArc::ReverseCurve property

AlignmentSubEntityArc::StartDirection property

AlignmentSubEntityArc::SubEntityType property

AlignmentSubEntityLine class

about AlignmentSubEntityLine class

AlignmentSubEntityLine::Direction property

AlignmentSubEntityLine::MidPoint property

AlignmentSubEntityLine::PassThroughPoint1 property

AlignmentSubEntityLine::PassThroughPoint2 property

AlignmentSubEntityLine::SubEntityType property

AlignmentSubEntitySpiral class

about AlignmentSubEntitySpiral class

AlignmentSubEntitySpiral::A property

AlignmentSubEntitySpiral::Compound property

AlignmentSubEntitySpiral::CurveType property

AlignmentSubEntitySpiral::Delta property

AlignmentSubEntitySpiral::Direction property

AlignmentSubEntitySpiral::EndDirection property

AlignmentSubEntitySpiral::K property

AlignmentSubEntitySpiral::LongTangent property

AlignmentSubEntitySpiral::MinimumTransitionLength property

AlignmentSubEntitySpiral::P property

AlignmentSubEntitySpiral::RadialPoint property

AlignmentSubEntitySpiral::RadiusIn property

AlignmentSubEntitySpiral::RadiusOut property

AlignmentSubEntitySpiral::ShortTangent property

AlignmentSubEntitySpiral::SPIAngle property

AlignmentSubEntitySpiral::SPIPoint property

AlignmentSubEntitySpiral::SpiralDefinition property

AlignmentSubEntitySpiral::SPIStation property

AlignmentSubEntitySpiral::StartDirection property

AlignmentSubEntitySpiral::SubEntityType property

AlignmentSubEntitySpiral::TotalX property

AlignmentSubEntitySpiral::TotalY property

AlignmentSuperelevationCriticalPoints enumeration member

AlignmentSuperelevationLabelGroup class

about AlignmentSuperelevationLabelGroup class

AlignmentSuperelevationLabelGroup::Create method

AlignmentSuperelevationLabelGroup::GetAvailableLabelGroups method

AlignmentSuperelevationLabelGroup::GetGeometryPointsOptions method

AlignmentSuperelevationLabelGroup::SetGeometryPointsOptions method

AlignmentTable class

about AlignmentTable class

AlignmentTable enumeration member

AlignmentTangent enumeration member

AlignmentTangentIntersection enumeration member

AlignmentTangentLabel class

about AlignmentTangentLabel class

AlignmentTangentLabel::Create method

AlignmentType

AlignmentTypeOption

AlignmentVerticalGeometryPointLabelGroup class

about AlignmentVerticalGeometryPointLabelGroup class

AlignmentVerticalGeometryPointLabelGroup::Create method

AlignmentVerticalGeometryPointLabelGroup::GetAvailableLabelGroups method

AlignmentVerticalGeometryPointLabelGroup::GetGeometryPointsOptions method

AlignmentVerticalGeometryPointLabelGroup::SetGeometryPointsOptions method

AlignmentVerticalGeometryPointLabelGroup::VerticalAlignment property

AlignNorthArrow

AlignProfileAndPlanViewType

AlignType

AlignWithObject

All enumeration member

AllCrownsMaintained enumeration member

AllLayoutsInCurrentDrawing enumeration member

AllLayoutsInOneNewDrawing enumeration member

AllowCheckedInPointsToBeModified

AllowCrossingBreaklines

AllowsAnchorMarker

AllowsDimensionAnchors

AllowsDragging

AllowsFlipping

AllowsLeaderAttachment

AllowsPinning

AllowsReversing

AlongAlignment enumeration member

Always enumeration member

AlwaysDraw enumeration member

AlwaysHide enumeration member

AmbientSettings

AnalysisType

AnchorAtXY

AnchorComponent

AnchorInfo

AnchorInfo class

about AnchorInfo class

AnchorInfo::AnchorInfo constructor

AnchorInfo::CenterOfCurve data member

AnchorInfo::DirectionAtLocation data member

AnchorInfo::IsOnCurve data member

AnchorInfo::Location data member

AnchorLocation

AnchorMarkerStyleId

AnchorPoint

Angle

Angle enumeration member

AngleDirectionFormat

AngleFactor

AngularUnits

AnnotateCenterAxis

Append enumeration member

Application

AppliedAssemblies

AppliedAssembly

AppliedAssembly class

about AppliedAssembly class

AppliedAssembly::AssemblyId property

AppliedAssembly::CorridorId property

AppliedAssembly::GetAppliedSubassemblies method

AppliedAssembly::Identity nested type

AppliedAssembly::Links property

AppliedAssembly::LinksByCode property

AppliedAssembly::Points property

AppliedAssembly::PointsByCode property

AppliedAssembly::Shapes property

AppliedAssembly::ShapesByCode property

AppliedAssemblyCollection class

about AppliedAssemblyCollection class

AppliedAssemblyCollection::CorridorId property

AppliedAssemblyCollection::Count property

AppliedAssemblyCollection::default property

AppliedAssemblyCollection::GetEnumerator method

AppliedAssemblyCollection::GetItemAt method

AppliedAssemblyCollection::GetObjectEnumerator method

AppliedAssemblyCollection::Identity nested type

AppliedAssemblyCollection::Stations method

AppliedSubassembly class

about AppliedSubassembly class

AppliedSubassembly::BaselineHookedTo property

AppliedSubassembly::CorridorId property

AppliedSubassembly::Identity nested type

AppliedSubassembly::Links property

AppliedSubassembly::OriginStationOffsetElevationToBaseline property

AppliedSubassembly::Points property

AppliedSubassembly::Shapes property

AppliedSubassembly::SubassemblyId property

AppliedSubassemblyCollection class

about AppliedSubassemblyCollection class

AppliedSubassemblyCollection::CorridorId property

AppliedSubassemblyCollection::Count property

AppliedSubassemblyCollection::default property

AppliedSubassemblyCollection::GetEnumerator method

AppliedSubassemblyCollection::GetObjectEnumerator method

AppliedSubassemblyCollection::Identity nested type

AppliedSubassemblyCollection::ObjectIds method

Apply3DProximityCheck

ApplyAngleFactor

ApplyCurveCorrection

ApplyGradeFactor

ApplyGradeRules

ApplyLengthFactor

ApplySeaLevelScaleFactor

ApplyTransformSettings

Arc

Arc enumeration member

Arc1

Arc2

Arched enumeration member

ArchTick enumeration member

Area

Area enumeration member

AreaFill enumeration member

AreaFillHatchDisplayStyleModel

AreaFillHatchDisplayStylePlan

Arrow enumeration member

ArrowBlockName

ArrowHeadOption

ArrowHeadOption class

about ArrowHeadOption class

ArrowHeadOption::ArrowBlockName property

ArrowHeadOption::ArrowType property

ArrowHeadOption::Fit property

ArrowHeadOption::FixedScaleX property

ArrowHeadOption::FixedScaleY property

ArrowHeadOption::FixedScaleZ property

ArrowHeadOption::SizeOption property

ArrowHeadOption::SizeValue property

ArrowheadSize

ArrowheadStyle

ArrowScale

ArrowType

Ascending enumeration member

Assembly

Assembly class

about Assembly class

Assembly enumeration member

Assembly::CodeSetStyleName property

Assembly::GetOffsetBaselineNames method

AssemblyCollection

AssemblyCollection class

about AssemblyCollection class

AssemblyCollection::Count property

AssemblyCollection::default property

AssemblyCollection::GetEnumerator method

AssemblyCollection::GetObjectEnumerator method

AssemblyId

AssemblyInsertion

AssemblyInsertionStations enumeration member

AssemblyStyle class

about AssemblyStyle class

AssemblyStyle::GetDisplayStyleModel method

AssemblyStyle::GetDisplayStylePlan method

AssemblyStyle::MarkerStyleAtAssemblyOriginId property

AssemblyStyle::MarkerStyleAtMainBaselineId property

AssemblyStyle::MarkerStyleAtMainBaselineOriginId property

AssemblyStyle::MarkerStyleAtOffsetBaselineId property

AssemblyStyle::MarkerStyleAtOffsetBaselineOriginId property

AssemblyStyleCollection class

about AssemblyStyleCollection class

AssemblyStyleCollection::Add method

AssemblyStyles

AssignElevations

AssignPayItemToAreaOption

AssociateShortcutProjectId

AsWarning enumeration member

AsymmetricalCrestCurveLength1

AsymmetricalCrestCurveLength2

AsymmetricalParabola enumeration member

AsymmetricalSagCurveLength1

AsymmetricalSagCurveLength2

AsymmetricLength1

AsymmetricLength2

AsymmetricParabola enumeration member

AtHorizontalGeometryPoints

AtPipeBottom enumeration member

AtPipeMiddle enumeration member

AtPipeTop enumeration member

AtRangeEnd

AtRangeStart

AtStructureBottom enumeration member

AtStructureMiddle enumeration member

AtStructureTop enumeration member

AtSuperelevationCriticalStations

AttachedToOffsetAssembly

Attachment

AutoAddSegmentLabel

AutoAddSegmentLabels

AutoCAD3dPolylineBeginVertexMarkerStyleId

AutoCAD3dPolylineBeginVertexMarkerStyleName

AutoCAD3dPolylineCrossingMarkerStyleId

AutoCAD3dPolylineCrossingMarkerStyleName

AutoCAD3dPolylineEndVertexMarkerStyleId

AutoCAD3dPolylineEndVertexMarkerStyleName

AutoCAD3dPolylineInternalVertexMarkerStyleId

AutoCAD3dPolylineInternalVertexMarkerStyleName

AutoCADBlockDisplayOptions

AutoCADBlockMarkerStyleId

AutoCADBlockMarkerStyleName

AutoCADBlockSymbolBlockId

AutoCADBlockSymbolBlockName

AutoCADPointDisplayOptions

AutoCADPointMarkerStyleId

AutoCADPointMarkerStyleName

AutoCADSolidDisplayOptions

AutoCADSolidMarkerStyleId

AutoCADSolidMarkerStyleName

Autodesk namespace

Autodesk::Civil namespace

Autodesk::Civil::AccelerationUnitType enumeration

Autodesk::Civil::AlignmentPointType enumeration

Autodesk::Civil::AnchorLocationType enumeration

Autodesk::Civil::AnchorPointType enumeration

Autodesk::Civil::AngleFormatType enumeration

Autodesk::Civil::AngleUnitType enumeration

Autodesk::Civil::ApplicationServices namespace

Autodesk::Civil::ApplicationServices::ProductType enumeration

Autodesk::Civil::AreaUnitType enumeration

Autodesk::Civil::ArrowHeadFitType enumeration

Autodesk::Civil::ArrowHeadSizeType enumeration

Autodesk::Civil::ArrowHeadType enumeration

Autodesk::Civil::BearingQuadrantType enumeration

Autodesk::Civil::BlockAttachmentType enumeration

Autodesk::Civil::CapitalizationType enumeration

Autodesk::Civil::CurbReturnType enumeration

Autodesk::Civil::DatabaseServices namespace

Autodesk::Civil::DatabaseServices::LabelType enumeration

Autodesk::Civil::DatabaseServices::Styles namespace

Autodesk::Civil::DatabaseServices::Styles::AxisPosition enumeration

Autodesk::Civil::DatabaseServices::Styles::AxisTickJustificationType enumeration

Autodesk::Civil::DatabaseServices::Styles::AxisTickType enumeration

Autodesk::Civil::DatabaseServices::Styles::AxisTitleLocationType enumeration

Autodesk::Civil::DatabaseServices::Styles::BandLabelStyleType enumeration

Autodesk::Civil::DatabaseServices::Styles::BandSetItemLocationType enumeration

Autodesk::Civil::DatabaseServices::Styles::BandStyleType enumeration

Autodesk::Civil::DatabaseServices::Styles::BandTickAttributeIdType enumeration

Autodesk::Civil::DatabaseServices::Styles::BandTitleBoxPosition enumeration

Autodesk::Civil::DatabaseServices::Styles::BandTitleTextLocation enumeration

Autodesk::Civil::DatabaseServices::Styles::CustomMarkerSuperimposeType enumeration

Autodesk::Civil::DatabaseServices::Styles::CustomMarkerType enumeration

Autodesk::Civil::DatabaseServices::Styles::ExpressionFormatedType enumeration

Autodesk::Civil::DatabaseServices::Styles::FeatureLineDisplayStyleProfileType enumeration

Autodesk::Civil::DatabaseServices::Styles::GraphDirectionType enumeration

Autodesk::Civil::DatabaseServices::Styles::GraphTitleJustificationType enumeration

Autodesk::Civil::DatabaseServices::Styles::GraphTitleLocationType enumeration

Autodesk::Civil::DatabaseServices::Styles::GridType enumeration

Autodesk::Civil::DatabaseServices::Styles::LabelDisplayModeType enumeration

Autodesk::Civil::DatabaseServices::Styles::LabelStyleComponentType enumeration

Autodesk::Civil::DatabaseServices::Styles::LabelStyleType enumeration

Autodesk::Civil::DatabaseServices::Styles::MarkerDisplayType enumeration

Autodesk::Civil::DatabaseServices::Styles::MarkerOrientationType enumeration

Autodesk::Civil::DatabaseServices::Styles::MarkerSizeType enumeration

Autodesk::Civil::DatabaseServices::Styles::markStylePropertyType enumeration

Autodesk::Civil::DatabaseServices::Styles::ProjectionBlockDisplayType enumeration

Autodesk::Civil::DatabaseServices::Styles::ProjectionDisplayStyleProfileType enumeration

Autodesk::Civil::DatabaseServices::Styles::ProjectionDisplayStyleSectionType enumeration

Autodesk::Civil::DatabaseServices::Styles::ProjectionEntityDisplayType enumeration

Autodesk::Civil::DatabaseServices::Styles::ReferenceTextComponentSelectedType enumeration

Autodesk::Civil::DatabaseServices::Styles::StaggerLabelType enumeration

Autodesk::Civil::DatabaseServices::Styles::TableDisplayStyleType enumeration

Autodesk::Civil::DatabaseServices::Styles::TableSortingOrderType enumeration

Autodesk::Civil::DatabaseServices::Styles::TableStyleType enumeration

Autodesk::Civil::DatabaseServices::Styles::TextForEachComponentSelectedType enumeration

Autodesk::Civil::DecimalCharacterType enumeration

Autodesk::Civil::DimensionAnchorOptionType enumeration

Autodesk::Civil::DimensionAnchorType enumeration

Autodesk::Civil::DirectionDisplayType enumeration

Autodesk::Civil::DirectionNameDisplayType enumeration

Autodesk::Civil::DrivingDirectionType enumeration

Autodesk::Civil::DropDecimalWholeType enumeration

Autodesk::Civil::DropLeadingZeroType enumeration

Autodesk::Civil::FlowUnitType enumeration

Autodesk::Civil::GradeFormatType enumeration

Autodesk::Civil::GradeSlopeFormatType enumeration

Autodesk::Civil::LabelContentDisplayType enumeration

Autodesk::Civil::LabelingPromptType enumeration

Autodesk::Civil::LabelInsertionType enumeration

Autodesk::Civil::LabelInsideCurveType enumeration

Autodesk::Civil::LabelMaskType enumeration

Autodesk::Civil::LabelTextAttachmentType enumeration

Autodesk::Civil::Land namespace

Autodesk::Civil::Land::AlignmentDesignCheckType enumeration

Autodesk::Civil::Land::BreaklineElevationType enumeration

Autodesk::Civil::Land::CatchmentWatershedObjectType enumeration

Autodesk::Civil::Land::CrossSectionShapeType enumeration

Autodesk::Civil::Land::DatabaseServices namespace

Autodesk::Civil::Land::DatabaseServices::AlignmentArcConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentCreationType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentEntityConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentEntityType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentGeometryPointStationType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentLineConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentRegionType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentSCSConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentSCSCSConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentSCSSCSConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentSide enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentSpiralConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentSSCSSConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentSTSConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentSubEntityType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentType enumeration

Autodesk::Civil::Land::DatabaseServices::AlignmentUpdateType enumeration

Autodesk::Civil::Land::DatabaseServices::CurveParamType enumeration

Autodesk::Civil::Land::DatabaseServices::CurveType enumeration

Autodesk::Civil::Land::DatabaseServices::DatumRoundingType enumeration

Autodesk::Civil::Land::DatabaseServices::ElevationRangeType enumeration

Autodesk::Civil::Land::DatabaseServices::EntityAttachType enumeration

Autodesk::Civil::Land::DatabaseServices::EntityVerticalConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::HatchCriteriaBoundaryType enumeration

Autodesk::Civil::Land::DatabaseServices::ProfileEntityConstraintType enumeration

Autodesk::Civil::Land::DatabaseServices::ProfileEntityType enumeration

Autodesk::Civil::Land::DatabaseServices::ProfileType enumeration

Autodesk::Civil::Land::DatabaseServices::ProfileUpdateType enumeration

Autodesk::Civil::Land::DatabaseServices::RegionPropertyType enumeration

Autodesk::Civil::Land::DatabaseServices::SpiralCurveType enumeration

Autodesk::Civil::Land::DatabaseServices::SpiralDirectionType enumeration

Autodesk::Civil::Land::DatabaseServices::SpiralParamType enumeration

Autodesk::Civil::Land::DatabaseServices::SplitStationType enumeration

Autodesk::Civil::Land::DatabaseServices::StationEquationType enumeration

Autodesk::Civil::Land::DatabaseServices::StationRangeType enumeration

Autodesk::Civil::Land::DatabaseServices::StationRoundingType enumeration

Autodesk::Civil::Land::DatabaseServices::StationTypes enumeration

Autodesk::Civil::Land::DatabaseServices::Styles namespace

Autodesk::Civil::Land::DatabaseServices::Styles::AlignmentDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::BuildingSiteDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::CenterMarkerSizeType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::ColorSchemeType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::ContourSmoothingType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::GradingDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAlignType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotAreaType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotCellSizeType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::GroupPlotStartCornerType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::HorizontalGeometryDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::ParcelDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::PointDisplay3dType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::PointDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::PointMarkerDisplayType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::PointSymbolType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::PrecisionRangeType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDataDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDesignCheckCurveType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::ProfileDisplayStyleProfileType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::ProfileViewDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SampleLineDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::ScaleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SchematicLineOption enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SectionalDataDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SectionDataDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SectionDisplayStyleSectionType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SectionSegmentDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SectionViewPlotRuleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SheetDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SlopeArrowType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SuperelevationDataDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplay3dType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceDisplayType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::SurfaceGroupValuesByType enumeration

Autodesk::Civil::Land::DatabaseServices::Styles::VerticalGeometryDisplayStyleType enumeration

Autodesk::Civil::Land::DatabaseServices::SubEntityExtensionType enumeration

Autodesk::Civil::Land::DatabaseServices::SuperElevationCrossSegmentType enumeration

Autodesk::Civil::Land::DatabaseServices::SuperElevationTransitionPointType enumeration

Autodesk::Civil::Land::DatabaseServices::VerticalCurveType enumeration

Autodesk::Civil::Land::DesignSpeedLookupMethodType enumeration

Autodesk::Civil::Land::ElevationSourceType enumeration

Autodesk::Civil::Land::ElevationToUseType enumeration

Autodesk::Civil::Land::FeatureLineLayerSettingType enumeration

Autodesk::Civil::Land::FeatureLineLayerType enumeration

Autodesk::Civil::Land::FreeHaulDisplayType enumeration

Autodesk::Civil::Land::GradingDistanceProjectionType enumeration

Autodesk::Civil::Land::GradingElevationProjectionType enumeration

Autodesk::Civil::Land::GradingInteriorCornerOverlapSolutionType enumeration

Autodesk::Civil::Land::GradingRelativeElevationProjectionType enumeration

Autodesk::Civil::Land::GradingSearchOrderType enumeration

Autodesk::Civil::Land::GradingSlopeFormatType enumeration

Autodesk::Civil::Land::GradingSurfaceProjectionType enumeration

Autodesk::Civil::Land::GradingTargetType enumeration

Autodesk::Civil::Land::HighsideLocationType enumeration

Autodesk::Civil::Land::MapcheckDefaultAngleType enumeration

Autodesk::Civil::Land::MapcheckDefaultCurveDirectionType enumeration

Autodesk::Civil::Land::MapcheckDefaultCurveTraverseMethodType enumeration

Autodesk::Civil::Land::MapcheckDefaultSideType enumeration

Autodesk::Civil::Land::MassHaulLineDisplayStyleType enumeration

Autodesk::Civil::Land::MassHaulLineHatchDisplayStyleType enumeration

Autodesk::Civil::Land::MassHaulViewDisplayStyleType enumeration

Autodesk::Civil::Land::MatchLineLabelLocationType enumeration

Autodesk::Civil::Land::ParcelAnalysisType enumeration

Autodesk::Civil::Land::ParcelRemainderDistributionType enumeration

Autodesk::Civil::Land::ParcelSelectionType enumeration

Autodesk::Civil::Land::ParcelSolutionType enumeration

Autodesk::Civil::Land::PipeNetworkPartDisplayType enumeration

Autodesk::Civil::Land::PlanViewAlignType enumeration

Autodesk::Civil::Land::PointNamesExistType enumeration

Autodesk::Civil::Land::PointNumbersAssignedType enumeration

Autodesk::Civil::Land::PointNumbersExistType enumeration

Autodesk::Civil::Land::PointNumbersSuppliedType enumeration

Autodesk::Civil::Land::ProfileApplyCurveType enumeration

Autodesk::Civil::Land::ProfileCircularVerticalConstraintType enumeration

Autodesk::Civil::Land::ProfileCurveType enumeration

Autodesk::Civil::Land::ProfileDesignCheckType enumeration

Autodesk::Civil::Land::ProfileParabolicVerticalConstraintType enumeration

Autodesk::Civil::Land::ProfileViewDatumType enumeration

Autodesk::Civil::Land::ProfileViewDisplayNetworkPartsType enumeration

Autodesk::Civil::Land::ProfileViewPlotType enumeration

Autodesk::Civil::Land::ProfileViewSplitDatumType enumeration

Autodesk::Civil::Land::ProfileViewSplitStationType enumeration

Autodesk::Civil::Land::ProfileViewStartCornerType enumeration

Autodesk::Civil::Land::RadiusLookupMethodType enumeration

Autodesk::Civil::Land::RemainderDistributionType enumeration

Autodesk::Civil::Land::SectionViewElevationRangeType enumeration

Autodesk::Civil::Land::Settings namespace

Autodesk::Civil::Land::Settings::AbbreviationAlignmentEnhancedType enumeration

Autodesk::Civil::Land::Settings::AbbreviationAlignmentType enumeration

Autodesk::Civil::Land::Settings::AbbreviationProfileType enumeration

Autodesk::Civil::Land::Settings::AbbreviationSuperelevationType enumeration

Autodesk::Civil::Land::Settings::AutomaticManual enumeration

Autodesk::Civil::Land::Settings::GeographicCoordinateType enumeration

Autodesk::Civil::Land::Settings::GridCoordinateType enumeration

Autodesk::Civil::Land::Settings::LocalCoordinateType enumeration

Autodesk::Civil::Land::Settings::SectionViewAnchorType enumeration

Autodesk::Civil::Land::Settings::TableAnchorType enumeration

Autodesk::Civil::Land::Settings::TableLayoutType enumeration

Autodesk::Civil::Land::Settings::TileDirectionType enumeration

Autodesk::Civil::Land::SheetCreateType enumeration

Autodesk::Civil::Land::SheetSetType enumeration

Autodesk::Civil::Land::ShoulderMethodType enumeration

Autodesk::Civil::Land::SlopePatternLengthType enumeration

Autodesk::Civil::Land::SlopePatternOffsetType enumeration

Autodesk::Civil::Land::SlopePatternStartType enumeration

Autodesk::Civil::Land::SlopePatternSymbolType enumeration

Autodesk::Civil::Land::SuperelevationCorridorType enumeration

Autodesk::Civil::Land::SuperelevationStationRoundingType enumeration

Autodesk::Civil::Land::SurfaceBoundaryType enumeration

Autodesk::Civil::Land::SurfaceRegionOptionsType enumeration

Autodesk::Civil::Land::SurfaceSimplifyType enumeration

Autodesk::Civil::Land::SurfaceType enumeration

Autodesk::Civil::Land::ViewFrameAngleType enumeration

Autodesk::Civil::Land::ViewFrameLabelLocationType enumeration

Autodesk::Civil::Land::WaterdropObjectType enumeration

Autodesk::Civil::LatLongDirectionType enumeration

Autodesk::Civil::LayoutModeType enumeration

Autodesk::Civil::LeaderAttachmentBehaviorType enumeration

Autodesk::Civil::LeaderAttachmentType enumeration

Autodesk::Civil::LeaderShapeType enumeration

Autodesk::Civil::LeaderTailVisibilityType enumeration

Autodesk::Civil::LeaderVisibilityType enumeration

Autodesk::Civil::LinearUnitType enumeration

Autodesk::Civil::MaskType enumeration

Autodesk::Civil::OrientationReferenceType enumeration

Autodesk::Civil::PipeNetwork namespace

Autodesk::Civil::PipeNetwork::DatabaseServices namespace

Autodesk::Civil::PipeNetwork::DatabaseServices::BoundingShapeType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::ConnectorPositionType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::DomainType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::FlowDirectionMethodType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::FlowDirectionType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::HoldOnResizeType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::PartCatalogDataType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::PartContextType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::PartParamUsageType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::PartType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::PipeSubEntityType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::StructureControlSumpType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles namespace

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceDisplayStyleType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelSizeOptionType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelSizeType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::InterferenceModelType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PartDataSourceType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeCenterlineType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeCenterlineWidthType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStylePlanType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStyleProfileType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeDisplayStyleSectionType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeEndSizeType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeHatchStyleProfileType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeHatchType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeNetworkDisplayStyleType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeStylePropertyType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeUserDefinedType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::PipeWallSizeType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStylePlanType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStyleProfileType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureDisplayStyleSectionType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureInsertionLocation enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureModelViewOptionType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructurePlanViewType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureSimpleSolidType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureSizeOptionsType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureStylePropertyType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::Styles::StructureViewType enumeration

Autodesk::Civil::PipeNetwork::DatabaseServices::SweptShapeType enumeration

Autodesk::Civil::PipeNetwork::DistanceScaleFactorType enumeration

Autodesk::Civil::PipeNetwork::NetworkDefaultLayoutCommandType enumeration

Autodesk::Civil::PipeNetwork::PipeSectionLabelPlacementType enumeration

Autodesk::Civil::PipeNetwork::Settings namespace

Autodesk::Civil::PipeNetwork::StructureProfileLabelPlacementType enumeration

Autodesk::Civil::PlottedUnitDisplayType enumeration

Autodesk::Civil::ProfilePointType enumeration

Autodesk::Civil::QTO namespace

Autodesk::Civil::QTO::DatabaseServices namespace

Autodesk::Civil::Roadway namespace

Autodesk::Civil::Roadway::AssemblyDisplayStyleType enumeration

Autodesk::Civil::Roadway::DatabaseServices namespace

Autodesk::Civil::Roadway::DatabaseServices::CorridorBaselineType enumeration

Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDisplay enumeration

Autodesk::Civil::Roadway::DatabaseServices::CorridorLinkDrawOverride enumeration

Autodesk::Civil::Roadway::DatabaseServices::CorridorSurfaceBoundaryType enumeration

Autodesk::Civil::Roadway::DatabaseServices::CurbReturnJoiningType enumeration

Autodesk::Civil::Roadway::DatabaseServices::IntersectionCorridorType enumeration

Autodesk::Civil::Roadway::DatabaseServices::MaterialConditionType enumeration

Autodesk::Civil::Roadway::DatabaseServices::MaterialItemType enumeration

Autodesk::Civil::Roadway::DatabaseServices::MaterialQuantityType enumeration

Autodesk::Civil::Roadway::DatabaseServices::OffsetLengthOption enumeration

Autodesk::Civil::Roadway::DatabaseServices::SideRoadProfileDistanceRuleType enumeration

Autodesk::Civil::Roadway::DatabaseServices::Styles namespace

Autodesk::Civil::Roadway::DatabaseServices::Styles::CodeSetStyleItemType enumeration

Autodesk::Civil::Roadway::DatabaseServices::Styles::CorridorDisplayStyleType enumeration

Autodesk::Civil::Roadway::DatabaseServices::Styles::ShapeDisplayStyleType enumeration

Autodesk::Civil::Roadway::DatabaseServices::Styles::SubassemblySubentityStyleType enumeration

Autodesk::Civil::Roadway::DatabaseServices::SubassemblyGeometryGenerateMode enumeration

Autodesk::Civil::Roadway::LinkCreationType enumeration

Autodesk::Civil::Roadway::QuantityTakeoffLengthComputeType enumeration

Autodesk::Civil::Roadway::QuantityTakeoffPipeLengthType enumeration

Autodesk::Civil::Roadway::QuantityTakeoffReportExtentType enumeration

Autodesk::Civil::Roadway::QuantityTakeoffReportType enumeration

Autodesk::Civil::Roadway::RoadwaySideType enumeration

Autodesk::Civil::Roadway::Settings namespace

Autodesk::Civil::RotationDirType enumeration

Autodesk::Civil::RoundingType enumeration

Autodesk::Civil::ROWCleanupType enumeration

Autodesk::Civil::Runtime namespace

Autodesk::Civil::Runtime::CorridorError enumeration

Autodesk::Civil::Runtime::CorridorErrorLevel enumeration

Autodesk::Civil::Runtime::CorridorLayoutModeDisplay enumeration

Autodesk::Civil::Runtime::CorridorMode enumeration

Autodesk::Civil::Runtime::ParamAccessType enumeration

Autodesk::Civil::Runtime::ParamLogicalNameType enumeration

Autodesk::Civil::Runtime::ParamScope enumeration

Autodesk::Civil::Runtime::ParamsOwnerType enumeration

Autodesk::Civil::Runtime::ParamType enumeration

Autodesk::Civil::Runtime::TypeInfoBool enumeration

Autodesk::Civil::Runtime::TypeInfoDouble enumeration

Autodesk::Civil::Runtime::TypeInfoLong enumeration

Autodesk::Civil::Settings namespace

Autodesk::Civil::Settings::DrawingUnitType enumeration

Autodesk::Civil::Settings::GridScaleFactorType enumeration

Autodesk::Civil::Settings::ImperialToMetricConversionType enumeration

Autodesk::Civil::Settings::LandXMLAngularUnits enumeration

Autodesk::Civil::Settings::LandXMLAttributeExportType enumeration

Autodesk::Civil::Settings::LandXMLConflictResolutionType enumeration

Autodesk::Civil::Settings::LandXMLImperialUnitType enumeration

Autodesk::Civil::Settings::LandXMLLinearUnits enumeration

Autodesk::Civil::Settings::LandXMLMetricUnitType enumeration

Autodesk::Civil::Settings::LandXMLPointDescriptionType enumeration

Autodesk::Civil::Settings::LandXMLSurfaceDataExportType enumeration

Autodesk::Civil::Settings::LandXMLSurfaceDataImportType enumeration

Autodesk::Civil::Settings::MapcheckAngleType enumeration

Autodesk::Civil::Settings::MapcheckCurveDirectionType enumeration

Autodesk::Civil::Settings::MapcheckSideType enumeration

Autodesk::Civil::Settings::MapcheckTraverseMethodType enumeration

Autodesk::Civil::Settings::ObjectLayerModifierType enumeration

Autodesk::Civil::Settings::SettingsObjectLayerType enumeration

Autodesk::Civil::Settings::SpecifyRotationType enumeration

Autodesk::Civil::SignType enumeration

Autodesk::Civil::SlopeFormatType enumeration

Autodesk::Civil::SpeedUnitType enumeration

Autodesk::Civil::SpiralType enumeration

Autodesk::Civil::StationDelimiterCharacterType enumeration

Autodesk::Civil::StationDelimiterPositionType enumeration

Autodesk::Civil::StationFormatType enumeration

Autodesk::Civil::StructureColumnComponentType enumeration

Autodesk::Civil::StyleConflictResolverType enumeration

Autodesk::Civil::SuperelevationPointType enumeration

Autodesk::Civil::Survey namespace

Autodesk::Civil::Survey::DatabaseServices namespace

Autodesk::Civil::Survey::Settings namespace

Autodesk::Civil::TableSegmentDataType enumeration

Autodesk::Civil::TableTitleDirectionType enumeration

Autodesk::Civil::TextBorderType enumeration

Autodesk::Civil::TextJustificationType enumeration

Autodesk::Civil::TransitionInputType enumeration

Autodesk::Civil::TransitionType enumeration

Autodesk::Civil::VectorMeasurementType enumeration

Autodesk::Civil::VolumeUnitType enumeration

AutoFeatureLabelGroup class

about AutoFeatureLabelGroup class

AutoFeatureLabelGroup::RangeEnd property

AutoFeatureLabelGroup::RangeEndFromFeature property

AutoFeatureLabelGroup::RangeStart property

AutoFeatureLabelGroup::RangeStartFromFeature property

AutoFeatureLabelGroup::SetRange method

Automatic enumeration member

AutomaticLayout

AutomaticMode

AutomaticObject enumeration member

AutomaticRimSurfaceAdjustment

AutoRebuild

AutoStagger

AValue enumeration member

Average enumeration member

AxisOffsetAbove

AxisOffsetBottom

AxisOffsetLeft

AxisOffsetRight

AxisStyle class

about AxisStyle class

AxisStyle::HorizontalGeometryTickStyle property

AxisStyle::MajorTickStyle property

AxisStyle::MinorTickStyle property

AxisStyle::ShowTickAndLabel property

AxisStyle::TitleStyle property

AxisTickStyle class

about AxisTickStyle class

AxisTickStyle::Interval property

AxisTickStyle::Justification property

AxisTickStyle::LabelText property

AxisTickStyle::OffsetX property

AxisTickStyle::OffsetY property

AxisTickStyle::Rotation property

AxisTickStyle::Size property

AxisTickStyle::TextHeight property

AxisTickStyle::TextStyle property

AxisTickStyle::TickAndLabelStartElevation property

AxisTitleStyle class

about AxisTitleStyle class

AxisTitleStyle::Location property

AxisTitleStyle::OffsetX property

AxisTitleStyle::OffsetY property

AxisTitleStyle::Rotation property

AxisTitleStyle::Text property

AxisTitleStyle::TextHeight property

AxisTitleStyle::TextStyle property

Azimuth enumeration member

B

BackClip

BackgroundMask

BalancePoint enumeration member

BandBottom enumeration member

BandHeight

BandMiddle enumeration member

BandSetItem class

about BandSetItem class

BandSetItem::BandStyleId property

BandSetItem::Gap property

BandSetItem::Location property

BandSetItem::Weeding property

BandSetItemCollection class

about BandSetItemCollection class

BandSetItemCollection::Count property

BandSetItemCollection::Remove method

BandSetItemCollection::Swap method

BandStyle class

about BandStyle class

BandStyle::BandHeight property

BandStyle::BandType property

BandStyle::OffsetFromBand property

BandStyle::Text property

BandStyle::TextBoxPosition property

BandStyle::TextBoxWidth property

BandStyle::TextHeight property

BandStyle::TextLocation property

BandStyle::TextStyle property

BandStyle::TitleTextLabelStyleId property

BandStyle::WeedingFactor property

BandStyleCollection class

about BandStyleCollection class

BandStyleCollection::Add method

BandStyleId

BandStyles

BandStylesRoot class

about BandStylesRoot class

BandStylesRoot::ProfileViewHorizontalGeometryBandStyles property

BandStylesRoot::ProfileViewPipeNetworkBandStyles property

BandStylesRoot::ProfileViewProfileDataBandStyles property

BandStylesRoot::ProfileViewSectionalDataBandStyles property

BandStylesRoot::ProfileViewSuperElevationBandStyles property

BandStylesRoot::ProfileViewVerticalGeometryBandStyles property

BandStylesRoot::SectionViewSectionDataBandStyles property

BandStylesRoot::SectionViewSegmentsBandStyles property

BandTickStyle class

about BandTickStyle class

BandTickStyle::IncrementSmallTicksAtBottom property

BandTickStyle::IncrementSmallTicksAtMiddle property

BandTickStyle::IncrementSmallTicksAtTop property

BandTickStyle::IncrementTicksToFullHeight property

BandTickStyle::SmallTicksAtBottomSize property

BandTickStyle::SmallTicksAtMiddleSize property

BandTickStyle::SmallTicksAtTopSize property

BandTop enumeration member

BandType

BarrelPipeClearance

Base enumeration member

BaseBaseline class

about BaseBaseline class

BaseBaseline::AlignmentId property

BaseBaseline::BaselineType property

BaseBaseline::CorridorId property

BaseBaseline::DirectionAtStation property

BaseBaseline::EndStation property

BaseBaseline::ProfileId property

BaseBaseline::SortedStations method

BaseBaseline::StartStation property

BaseBaseline::StationOffsetElevationToXYZ method

BaseElevationInterval

BaseLabelSetItem class

about BaseLabelSetItem class

BaseLabelSetItem::LabelStyleId property

BaseLabelSetItem::LabelStyleName property

BaseLabelSetItem::LabelStyleType property

BaseLabelSetStyle class

about BaseLabelSetStyle class

BaseLabelSetStyle::Add method

BaseLabelSetStyle::Count property

BaseLabelSetStyle::RemoveAt method

Baseline class

about Baseline class

Baseline enumeration member

Baseline::AlignmentId property

Baseline::AppliedAssembly property

Baseline::BaselineRegions property

Baseline::BaselineType property

Baseline::EndStation property

Baseline::Identity nested type

Baseline::IsProcessed property

Baseline::MainBaselineFeatureLines property

Baseline::OffsetBaselineFeatureLinesCol property

Baseline::ProfileId property

Baseline::SortedStations method

Baseline::StartStation property

BaselineCollection class

about BaselineCollection class

BaselineCollection::CorridorId property

BaselineCollection::Count property

BaselineCollection::default property

BaselineCollection::GetEnumerator method

BaselineCollection::GetObjectEnumerator method

BaselineColor

BaselineFeatureLines class

about BaselineFeatureLines class

BaselineFeatureLines::CodeNames method

BaselineFeatureLines::CorridorId property

BaselineFeatureLines::FeatureLineCollectionMap property

BaselineFeatureLines::HardcodedOffsetBaselineName property

BaselineFeatureLines::Identity nested type

BaselineFeatureLines::IsMainBaseline property

BaselineFeatureLines::OffsetAlignmentId property

BaselineFeatureLinesCollection class

about BaselineFeatureLinesCollection class

BaselineFeatureLinesCollection::CodeNames method

BaselineFeatureLinesCollection::CorridorId property

BaselineFeatureLinesCollection::Count property

BaselineFeatureLinesCollection::default property

BaselineFeatureLinesCollection::GetEnumerator method

BaselineFeatureLinesCollection::GetObjectEnumerator method

BaselineFeatureLinesCollection::Identity nested type

BaselineHookedTo

BaselineLineweight

BaselineOrigin enumeration member

BaselineRegion class

about BaselineRegion class

BaselineRegion::AddStation method

BaselineRegion::AppliedAssemblies property

BaselineRegion::AssemblyId property

BaselineRegion::CorridorId property

BaselineRegion::DeleteStation method

BaselineRegion::EndStation property

BaselineRegion::Identity nested type

BaselineRegion::IsProcessed property

BaselineRegion::OffsetBaselines property

BaselineRegion::StartStation property

BaselineRegionCollection class

about BaselineRegionCollection class

BaselineRegionCollection::AddRegion method

BaselineRegionCollection::CorridorId property

BaselineRegionCollection::Count property

BaselineRegionCollection::default property

BaselineRegionCollection::GetEnumerator method

BaselineRegionCollection::GetObjectEnumerator method

BaselineRegionCollection::Identity nested type

BaselineRegions

Baselines

BaselineType

BasePointEasting

BasePointElevation

BasePointNorthing

BasicTable enumeration member

Bearing

BearingQuadrant

Bearings enumeration member

Begin enumeration member

BeginFullSuper enumeration member

BeginningVertex enumeration member

BeginNormalCrown enumeration member

BeginNormalShoulder enumeration member

BeginOfAlignment enumeration member

BeginPointMarkerStyle

BeginVerticalCurve enumeration member

BeginVerticalCurveElevation enumeration member

BeginVerticalCurveStation enumeration member

BegOfAlign enumeration member

Behavior

Below enumeration member

BestFit enumeration member

BestFitArc enumeration member

Bidirectional enumeration member

BiQuadratic enumeration member

Block enumeration member

BlockHeight

BlockInsertLocation

BlockInsertLocation enumeration member

BlockName

BlockProfile enumeration member

BlockSection enumeration member

Bloss enumeration member

Blues enumeration member

Bool enumeration member

BoolGeneral enumeration member

Border

Border enumeration member

BorderDisplayStyleModel

BorderDisplayStylePlan

BorderGap

BorderType

BorderVisibility

BorrowPitCapacity

Both enumeration member

Bottom enumeration member

BottomAxis

BottomAxis enumeration member

BottomAxisAnnotationHGP enumeration member

BottomAxisAnnotationMajor enumeration member

BottomAxisAnnotationMinor enumeration member

BottomAxisTicksHGP enumeration member

BottomAxisTicksMajor enumeration member

BottomAxisTicksMinor enumeration member

BottomAxisTitle enumeration member

BottomBandSetItems

BottomCenter enumeration member

BottomInnerDiameter enumeration member

BottomLeft enumeration member

BottomOrRight enumeration member

BottomOuterDiameter enumeration member

BottomRight enumeration member

BottomSize enumeration member

BottomStackViewStyle

Boundaries

Boundary enumeration member

BoundaryNames

BoundaryStyle

BoundaryType

BoundingBodyBlockId

BoundingBodyBlockName

BoundingShape

Box enumeration member

BoxBlank enumeration member

BoxFilled enumeration member

BracketNegative enumeration member

BreakoverRemoval enumeration member

BreakPipe

BuildingFootprint enumeration member

BuildingModel enumeration member

BuildingSite

BuildingSite enumeration member

BuildingSiteStyle class

about BuildingSiteStyle class

BuildingSiteStyle::GetDisplayStyleModel method

BuildingSiteStyle::GetDisplayStylePlan method

BuildingSiteStyle::MarkerStyleId property

BuildingSiteStyle::MarkerStyleName property

BuildingSiteStyleCollection class

about BuildingSiteStyleCollection class

BuildingSiteStyleCollection::Add method

BuildingSiteStyles

BuildOptions

ByColumns enumeration member

ByDepth enumeration member

ByElevation enumeration member

ByLength enumeration member

ByLineWeight enumeration member

ByRows enumeration member

BySlope enumeration member

ByTaperRatio enumeration member

C

CalculatedLink class

about CalculatedLink class

CalculatedLink::CalculatedPoints property

CalculatedLink::CorridorCodes property

CalculatedLink::DrawOverride property

CalculatedLink::Identity nested type

CalculatedLinkCollection class

about CalculatedLinkCollection class

CalculatedLinkCollection::CorridorId property

CalculatedLinkCollection::Count property

CalculatedLinkCollection::default property

CalculatedLinkCollection::GetEnumerator method

CalculatedLinkCollection::GetObjectEnumerator method

CalculatedLinkCollection::Identity nested type

CalculatedLinks

CalculatedPoint class

about CalculatedPoint class

CalculatedPoint::CorridorCodes property

CalculatedPoint::Identity nested type

CalculatedPoint::NormalToBaseline property

CalculatedPoint::NormalToSubassembly property

CalculatedPoint::StationOffsetElevationToBaseline property

CalculatedPoint::StationOffsetElevationToSubassembly property

CalculatedPointCollection class

about CalculatedPointCollection class

CalculatedPointCollection::CorridorId property

CalculatedPointCollection::Count property

CalculatedPointCollection::default property

CalculatedPointCollection::GetEnumerator method

CalculatedPointCollection::GetObjectEnumerator method

CalculatedPointCollection::Identity nested type

CalculatedPoints

CalculatedShape class

about CalculatedShape class

CalculatedShape::Area property

CalculatedShape::CalculatedLinks property

CalculatedShape::CorridorCodes property

CalculatedShape::Identity nested type

CalculatedShapeCollection class

about CalculatedShapeCollection class

CalculatedShapeCollection::CorridorId property

CalculatedShapeCollection::Count property

CalculatedShapeCollection::default property

CalculatedShapeCollection::GetEnumerator method

CalculatedShapeCollection::GetObjectEnumerator method

CalculatedShapeCollection::Identity nested type

CalculatedSubentity class

about CalculatedSubentity class

CalculatedSubentity::CorridorCodes property

CalculatedSubentity::CorridorId property

CalculatedSubentity::Identity nested type

CalculatedSubentity::SubassemblyBelongedTo property

Calculation enumeration member

CancelRemaining enumeration member

Capitalization

Category

CellSizeType

Center enumeration member

CenterAxis

CenterAxis enumeration member

CenterAxisAnnotationMajor enumeration member

CenterAxisAnnotationMinor enumeration member

CenterAxisColor

CenterAxisTicksMajor enumeration member

CenterAxisTicksMinor enumeration member

CenterAxisTitle enumeration member

Centerline enumeration member

CenterlineAlignmentId

CenterlineLabelStyleId

CenterlineOptions

CenterlineProfileId

CenterlineSize

CenterlineSizePercent

CenterlineTickStyle

CenterlineWidthOptions

CenterMarker

CenterOfCurve

CenterPassThroughPoint enumeration member

CenterPoint

CenterRadius enumeration member

CenterToCenter enumeration member

Centimeter enumeration member

CentiMeter enumeration member

CentroidMarker enumeration member

Chain3DDisplayStyleModel

ChainTessellationDistance3D

Chamfer enumeration member

ChamferFilletLengthAlongIncomingLane

ChamferFilletLengthAlongOutgoingLane

Channel enumeration member

ChildrenCount

ChordDirection

ChordLength

ChordLength enumeration member

Circle enumeration member

Circular enumeration member

CircularCrestCurveConstraint

CircularCrestCurveLength

CircularCrestCurveRadius

CircularFillet enumeration member

CircularFilletRadius

CircularSagCurveConstraint

CircularSagCurveLength

CircularSagCurveRadius

Civil enumeration member

Civil3D enumeration member

CivilApplication class

about CivilApplication class

CivilApplication::ActiveDocument property

CivilApplication::ActiveProduct property

CivilDocument class

about CivilDocument class

CivilDocument::AssemblyCollection property

CivilDocument::CorridorCollection property

CivilDocument::CorridorState property

CivilDocument::GetAlignmentIds method

CivilDocument::GetAlignmentTableIds method

CivilDocument::GetAllPointIds method

CivilDocument::GetIntersectionIds method

CivilDocument::GetLegendTableIds method

CivilDocument::GetParcelSegmentTableIds method

CivilDocument::GetParcelTableIds method

CivilDocument::GetPipeNetworkIds method

CivilDocument::GetPointTableIds method

CivilDocument::GetSiteIds method

CivilDocument::GetSitelessAlignmentId method

CivilDocument::GetSitelessAlignmentIds method

CivilDocument::GetSurfaceIds method

CivilDocument::GetViewFrameGroupIds method

CivilDocument::IsCorridorSectionViewActive property

CivilDocument::NetworkState property

CivilDocument::Settings property

CivilDocument::Styles property

CivilDocument::SubassemblyCollection property

CleanupAtAlignmentIntersections

CleanupAtParcelBoundaries

CleanupMethodFillet

Clear

ClearAllTextComponentOverrides

ClipGridAt

ClipToHighestProfile

Clockwise

Clockwise enumeration member

CloneAndAddRule

Closed enumeration member

ClosedBlank enumeration member

ClosedFilled enumeration member

ClosePoint3DDistance

ClosePointRemoval

Clothoid enumeration member

Code

CodeAttribute

CodeCollection class

about CodeCollection class

CodeCollection::Add method

CodeCollection::Count property

CodeCollection::default property

CodeCollection::GetEnumerator method

CodeCollection::GetObjectEnumerator method

CodeCollection::Remove method

CodeCollection::SubEntityType nested type

CodeName

CodeNames

Codes

CodeSet

CodeSetStyle

CodeSetStyle class

about CodeSetStyle class

CodeSetStyle::Add method

CodeSetStyle::Count property

CodeSetStyle::default property

CodeSetStyle::GetCurrentStyleSetId method

CodeSetStyle::GetEnumerator method

CodeSetStyle::GetItemBy method

CodeSetStyle::GetObjectEnumerator method

CodeSetStyle::Remove method

CodeSetStyle::SubentityStyleType property

CodeSetStyleCollection class

about CodeSetStyleCollection class

CodeSetStyleCollection::Add method

CodeSetStyleItem class

about CodeSetStyleItem class

CodeSetStyleItem::Code property

CodeSetStyleItem::CodeStyleId property

CodeSetStyleItem::CodeStyleName property

CodeSetStyleItem::Description property

CodeSetStyleItem::FeatureLineStyleId property

CodeSetStyleItem::FeatureLineStyleName property

CodeSetStyleItem::ItemType property

CodeSetStyleItem::LabelStyleId property

CodeSetStyleItem::LabelStyleName property

CodeSetStyleItem::MaterialAreaFillStyleId property

CodeSetStyleItem::MaterialAreaFillStyleName property

CodeSetStyleItem::PayItems property

CodeSetStyleItem::RenderMaterialStyleId property

CodeSetStyleItem::RenderMaterialStyleName property

CodeSetStyleItem::StyleType property

CodeSetStyleName

CodeSetStyles

CodeStyleId

CodeStyleName

CogoPoint enumeration member

Color

Color enumeration member

ColorForHatch

ColorScheme

ColumnSpacing

ColumnStyle class

about ColumnStyle class

ColumnStyle::ColumnWidth property

ColumnStyle::ContentJustification property

ColumnStyle::ContentString property

ColumnStyle::ContentStringFormatted property

ColumnStyle::HeaderJustification property

ColumnStyle::HeaderString property

ColumnStyle::HeaderStringFormatted property

ColumnStyleCollection class

about ColumnStyleCollection class

ColumnStyleCollection::Add method

ColumnStyleCollection::Count property

ColumnStyleCollection::default property

ColumnStyleCollection::GetEnumerator method

ColumnStyleCollection::GetObjectEnumerator method

ColumnStyleCollection::RemoveAt method

ColumnStyles

ColumnWidth

Comma enumeration member

CommandLine enumeration member

Comment

Company

CompanyURL

Compare enumeration member

CompCurve enumeration member

CompCurveCurve enumeration member

ComponentType

Composed enumeration member

Compound

Compound enumeration member

CompoundCurveCurveIntersect enumeration member

CompoundCurveIntersectPointMarkerStyle

CompoundSpiralLargeRadiusAtBeginning enumeration member

CompoundSpiralLargeRadiusAtEnd enumeration member

CompoundSpiralSmallRadiusAtBeginning enumeration member

CompoundSpiralSmallRadiusAtEnd enumeration member

Compute2D enumeration member

Compute3D enumeration member

ComputeTakeOffOption

Condition

Conditional enumeration member

Conduit enumeration member

ConeHeight

ConflictResolution

ConnectedPartCount

ConnectedPipe

ConnectedPipesCount

ConnectionType enumeration member

ConnectToPipe

ConnectToStructure

Constant class

about Constant class

Constant enumeration member

Constant::VerticalGrade data member

Constraint1

Constraint2

Content

ContentJustification

Contents

ContentString

ContentStringFormatted

Context

ContextString

ContourLabeling

ContourLineOnly enumeration member

ContourStyle

ContourValues class

about ContourValues class

ContourValues::MajorColor property

ContourValues::MajorLineTypeId property

ContourValues::MajorLineWight property

ContourValues::MinorColor property

ContourValues::MinorLineTypeId property

ContourValues::MinorLineWight property

ControlSumpBy

ConvergenceAngle enumeration member

ConvertFromEntities

ConvertProximityBreaklinesToStandard

ConvertSurveyFootToInternationalFoot

Coordinate

Coordinate enumeration member

CoordinateSystemCode

CopyAsSibling

CopyComponent

CopyDeletedDependentObjects

CopyToSite

Corridor

Corridor class

about Corridor class

Corridor enumeration member

Corridor::Baselines property

Corridor::CodeSetStyleName property

Corridor::CorridorSurfaces property

Corridor::FeatureLineCodeInfos property

Corridor::IsOutOfDate property

Corridor::MaximumTriangleSideLength property

Corridor::Rebuild method

Corridor::RebuildAutomatic property

CorridorBaseline

CorridorCodeCollection class

about CorridorCodeCollection class

CorridorCodeCollection::CorridorId property

CorridorCodeCollection::Count property

CorridorCodeCollection::default property

CorridorCodeCollection::GetEnumerator method

CorridorCodeCollection::GetObjectEnumerator method

CorridorCodeCollection::Identity nested type

CorridorCodes

CorridorCodeSet

CorridorCollection

CorridorCollection class

about CorridorCollection class

CorridorCollection::Count property

CorridorCollection::default property

CorridorCollection::GetEnumerator method

CorridorCollection::GetObjectEnumerator method

CorridorFeature enumeration member

CorridorId

CorridorOutOfDate enumeration member

CorridorRegion

CorridorSection class

about CorridorSection class

CorridorSection enumeration member

CorridorSection::GetCorridor method

CorridorSection::SetCorridor method

CorridorShape enumeration member

CorridorState

CorridorState class

about CorridorState class

CorridorState::CurrentAlignmentId property

CorridorState::CurrentAlignmentIsOffsetAlignment property

CorridorState::CurrentAssemblyElevation property

CorridorState::CurrentAssemblyFixedElevation property

CorridorState::CurrentAssemblyFixedOffset property

CorridorState::CurrentAssemblyId property

CorridorState::CurrentAssemblyName property

CorridorState::CurrentAssemblyOffset property

CorridorState::CurrentAssemblyOffsetIsFixed property

CorridorState::CurrentBaselineId property

CorridorState::CurrentCorridorId property

CorridorState::CurrentCorridorName property

CorridorState::CurrentElevation property

CorridorState::CurrentOffset property

CorridorState::CurrentProfileId property

CorridorState::CurrentStation property

CorridorState::CurrentSubassemblyElevation property

CorridorState::CurrentSubassemblyId property

CorridorState::CurrentSubassemblyName property

CorridorState::CurrentSubassemblyOffset property

CorridorState::IntersectAlignment method

CorridorState::IntersectLink method

CorridorState::IntersectSurface method

CorridorState::IsAboveSurface method

CorridorState::LayoutModeDisplayType property

CorridorState::Links property

CorridorState::Mode property

CorridorState::ParamsAlignment property

CorridorState::ParamsAlignmentGlobal property

CorridorState::ParamsBool property

CorridorState::ParamsBoolGlobal property

CorridorState::ParamsDouble property

CorridorState::ParamsDoubleGlobal property

CorridorState::ParamsElevationTarget property

CorridorState::ParamsElevationTargetGlobal property

CorridorState::ParamsLong property

CorridorState::ParamsLongGlobal property

CorridorState::ParamsOffsetTarget property

CorridorState::ParamsOffsetTargetGlobal property

CorridorState::ParamsPoint property

CorridorState::ParamsPointGlobal property

CorridorState::ParamsProfile property

CorridorState::ParamsProfileGlobal property

CorridorState::ParamsString property

CorridorState::ParamsStringGlobal property

CorridorState::ParamsSurface property

CorridorState::ParamsSurfaceGlobal property

CorridorState::Points property

CorridorState::RecordError method

CorridorState::ResourceString property

CorridorState::SampleSection method

CorridorState::Shapes property

CorridorState::SoeToXyz method

CorridorState::XyzToSoe method

CorridorStateNotFound enumeration member

CorridorStyle class

about CorridorStyle class

CorridorStyle::GetDisplayStyleModel method

CorridorStyle::GetDisplayStylePlan method

CorridorStyleCollection class

about CorridorStyleCollection class

CorridorStyleCollection::Add method

CorridorStyles

CorridorSurface

CorridorSurface class

about CorridorSurface class

CorridorSurface::Boundaries property

CorridorSurface::CorridorId property

CorridorSurface::Description property

CorridorSurface::FeatureLineCodeIsBreak method

CorridorSurface::FeatureLineCodes method

CorridorSurface::FindElevationAtXY method

CorridorSurface::GetSampleElevations method

CorridorSurface::Identity nested type

CorridorSurface::IsBuild property

CorridorSurface::IsDraw property

CorridorSurface::LinkCodes method

CorridorSurface::Masks property

CorridorSurface::Name property

CorridorSurface::PointCodes method

CorridorSurface::SectionStyleId property

CorridorSurface::SurfaceStyleId property

CorridorSurfaceBaseMask class

about CorridorSurfaceBaseMask class

CorridorSurfaceBaseMask::CorridorId property

CorridorSurfaceBaseMask::Description property

CorridorSurfaceBaseMask::FeatureLineComponents property

CorridorSurfaceBaseMask::Identity nested type

CorridorSurfaceBaseMask::Name property

CorridorSurfaceBaseMask::PolygonPoints method

CorridorSurfaceBoundary class

about CorridorSurfaceBoundary class

CorridorSurfaceBoundary::BoundaryType property

CorridorSurfaceBoundaryCollection class

about CorridorSurfaceBoundaryCollection class

CorridorSurfaceBoundaryCollection::BoundaryNames method

CorridorSurfaceBoundaryCollection::CorridorId property

CorridorSurfaceBoundaryCollection::Count property

CorridorSurfaceBoundaryCollection::default property

CorridorSurfaceBoundaryCollection::GetEnumerator method

CorridorSurfaceBoundaryCollection::GetObjectEnumerator method

CorridorSurfaceBoundaryCollection::Identity nested type

CorridorSurfaceCollection class

about CorridorSurfaceCollection class

CorridorSurfaceCollection::CorridorId property

CorridorSurfaceCollection::Count property

CorridorSurfaceCollection::default property

CorridorSurfaceCollection::GetEnumerator method

CorridorSurfaceCollection::GetObjectEnumerator method

CorridorSurfaceCollection::SurfaceNames method

CorridorSurfaceMask class

about CorridorSurfaceMask class

CorridorSurfaceMaskCollection class

about CorridorSurfaceMaskCollection class

CorridorSurfaceMaskCollection::CorridorId property

CorridorSurfaceMaskCollection::Count property

CorridorSurfaceMaskCollection::default property

CorridorSurfaceMaskCollection::GetEnumerator method

CorridorSurfaceMaskCollection::GetObjectEnumerator method

CorridorSurfaceMaskCollection::Identity nested type

CorridorSurfaceMaskCollection::MaskNames method

CorridorSurfaces

CorridorType

CouldNotSolveInLayoutMode enumeration member

Count

Counter enumeration member

Counterclockwise enumeration member

CounterClockwise enumeration member

Cover

CoverOfEndpoint

CoverOfStartPoint

CPI enumeration member

Create

CreateBy

CreateByArc1Angle

CreateByArc1Length

CreateByArc1PassPt

CreateByArc2Angle

CreateByArc2Length

CreateByArc2PassPt

CreateByEndPoint

CreateByLayout

CreateByStartPoint

CreateByTan1Length

CreateByTan2Length

CreateCurbReturnAlignments

CreateCurbReturnProfiles

CreateDynamicLink

CreateFromEntities

CreateFromMacro

CreateFromSurface

CreateIntersectionCorridors

CreateOffsetAlignment

CreateParcelRightOfWay

CreateProfileFromCorridor

CreateReadOnlyFile

CreateRemainderParcel enumeration member

CreateSnapshotAfterImport

CreateSourceDataInDrawing

Creation

CreationMode

Creator

Crest enumeration member

CrestAndSag enumeration member

CrestCurveLabelStyleId

CrestCurvesOnly enumeration member

CrestCurveTickStyle

CrestOnly enumeration member

CrestSagCurves enumeration member

Criteria

CriteriaBasedDesignOption

CriteriaBasedDesignOptions

CrossingHatch

CrossingPipeHatch enumeration member

CrossingPipeInsideWall enumeration member

CrossingPipeOutsideWall enumeration member

CrossSectionalShape

CrossSectionLabelStyles

CrossSectionShape

CrossSlopes

Crown enumeration member

Crowned enumeration member

CubicFoot enumeration member

CubicFootPerSec enumeration member

CubicMeter enumeration member

CubicMeterPerSec enumeration member

CubicParabola enumeration member

CubicYard enumeration member

CurbReturn enumeration member

CurbReturnAlignment

CurbReturnAlignmentId

CurbReturnAlignmentLabelSet

CurbReturnFilletRegionColor

CurbReturnFilletRegionLineweight

CurbReturnParameters

CurbReturnProfile

CurbReturnProfile enumeration member

CurbReturnProfileId

CurbReturnProfileLabelSet

CurbReturnProfileRules

CurbReturnType

CurrentAlignmentId

CurrentAlignmentIsOffsetAlignment

CurrentAssemblyElevation

CurrentAssemblyFixedElevation

CurrentAssemblyFixedOffset

CurrentAssemblyId

CurrentAssemblyName

CurrentAssemblyOffset

CurrentAssemblyOffsetIsFixed

CurrentBaselineId

CurrentCorridorId

CurrentCorridorName

CurrentElevation

CurrentHorizontalScale

CurrentLayer enumeration member

CurrentMacroName

CurrentMacroProject

CurrentMapcheckColor

CurrentOffset

CurrentPipeId

CurrentPointofBeginningColor

CurrentProfileId

CurrentSide

CurrentSideColor

CurrentStation

CurrentStructureId

CurrentSubassemblyElevation

CurrentSubassemblyId

CurrentSubassemblyName

CurrentSubassemblyOffset

Curvature enumeration member

Curve enumeration member

CurveAndSpiralSettings

CurveAngle enumeration member

CurveBeginning enumeration member

CurveCoefficient enumeration member

CurveCompCurve enumeration member

CurveCorrectionTolerance

CurveCurvature enumeration member

CurveCurveReverseCurve enumeration member

Curved enumeration member

CurveDesignChecks

CurveEnd enumeration member

CurveEndDimension enumeration member

CurveEndExtension enumeration member

CurveEndInView enumeration member

CurveEndInViewDimension enumeration member

CurveExtensions enumeration member

CurveGeometry enumeration member

CurveGroupIndex

CurveGroupSubEntityIndex

CurveHighPoint enumeration member

CurveHighPointDimension enumeration member

CurveLabel

CurveLabels enumeration member

CurveLabelStyle

CurveLabelStyleId

CurveLabelStyles

CurveLength enumeration member

CurveLineCurve enumeration member

CurveLineIntersectPointMarkerStyle

CurveLowPoint enumeration member

CurveLowPointDimension enumeration member

CurveMid enumeration member

CurveMidDimension enumeration member

CurveMiddleExtension enumeration member

CurveRadiusForSCSGroup

CurveRevCurve enumeration member

CurveReverseCurve enumeration member

CurvesIncrement

CurveSpiral enumeration member

CurveSpiralIntersect enumeration member

CurveSpiralIntersectPointMarkerStyle

CurveSpiralSpiral enumeration member

CurvesStartingNumber

CurveStart enumeration member

CurveStartDimension enumeration member

CurveStartExtension enumeration member

CurveStartInView enumeration member

CurveStartInViewDimension enumeration member

CurveTan enumeration member

CurveTangentIntersect enumeration member

CurveTessellationOption

CurveThroughPoint enumeration member

CurveTickStyle

CurveType

CustomMarkerBlank enumeration member

CustomMarkerDot enumeration member

CustomMarkerPlus enumeration member

CustomMarkerStyle

CustomMarkerStyle enumeration member

CustomMarkerSuperimposeStyle

CustomMarkerSuperimposeStyle enumeration member

CustomMarkerVLine enumeration member

CustomMarkerX enumeration member

CustomShape enumeration member

Cut enumeration member

CutArea

CutAreaShapeStyle

CutFactor

CutFill enumeration member

CutFillSlope enumeration member

CutFirst enumeration member

CutSlope

CutSlope enumeration member

CutSlopeFormatType

CutSlopeGrading

Cylinder enumeration member

D

Dashed enumeration member

DashedWithArrowhead enumeration member

Data

DataAreaFill enumeration member

DataAreaFillDisplayStyleModel

DataAreaFillDisplayStylePlan

DataClip enumeration member

DataDivider enumeration member

DataDividerDisplayStyleModel

DataDividerDisplayStylePlan

DataOptions

DataPartFamily class

about DataPartFamily class

DataPartFamily::BoundingShape property

DataPartFamily::Description property

DataPartFamily::Domain property

DataPartFamily::GUID property

DataPartFamily::PartType property

DataPartFamily::SweptShape property

DataPointsColor

DataPointsSymbol

DataSeparator enumeration member

DataSeparatorDisplayStyleModel

DataSeparatorDisplayStylePlan

DataSource

DataSourceId

DataSourceName

DataText enumeration member

DataTextDisplayStyleModel

DataTextDisplayStylePlan

DataTextHeight

DataTextStyle

DataType

DateCreated

DateModified

Datum

DatumBlank enumeration member

DatumFilled enumeration member

DBObject class

about DBObject class

DBObject::Application property

DBObject::Description property

DBObject::Document property

DBObject::Name property

Decimal enumeration member

DecimalFractional enumeration member

Decimeter enumeration member

DeciMeter enumeration member

DeclareNewParameter

DeclarePartProperty

Decreasing enumeration member

default

Default enumeration member

DefaultAngleType

DefaultCurveDirection

DefaultCurveTraverseMethod

DefaultDescription

DefaultDesignCheckSet

DefaultDimensionAnchorOption

DefaultDimensionAnchorValue

DefaultElevation

DefaultItemType enumeration member

DefaultLabelStyle

DefaultLayoutCommand

DefaultLoopInLayoutMode

DefaultLoopOffsetInLayoutMode

DefaultNameFormat

DefaultProfileViewHeight

DefaultProfileViewLength

DefaultReportStyle

Defaults

DefaultSideType

DefaultSlope enumeration member

DefaultStationIndexIncrement

DefaultStyles

DefaultType

DefaultVerticalCurve

DefaultViewScale

DefineCurbReturnProfileBy

DefineMaterialOption

DeflectedAngle

DeflectionAngle enumeration member

Degree enumeration member

DegreeMinuteSecond enumeration member

DegreeOfCurve enumeration member

DegreesDecimal enumeration member

DegreesDms enumeration member

DeleteAllPayItemsIds

DeletePayItemIds

DeleteStation

Delimiter10 enumeration member

Delimiter100 enumeration member

Delimiter1000 enumeration member

Delimiter10000 enumeration member

Delimiter100000 enumeration member

Delta

deprecated

Deprecated Items

DepressionTickMarkInterval

DepressionTickMarkLength

DerivedPointsColor

DerivedPointsSymbol

DerivedStation enumeration member

DescAttribute

Descending enumeration member

Description

DescriptionFormat

DescriptiveText

Design enumeration member

DesignCheck class

about DesignCheck class

DesignCheck::Description property

DesignCheck::Expression property

DesignCheck::Name property

DesignCheckCollection template

about DesignCheckCollection template

DesignCheckCollection::Add method

DesignCheckCollection::Clear method

DesignCheckCollection::Count property

DesignCheckCollection::default property

DesignCheckCollection::GetEnumerator method

DesignCheckCollection::GetObjectEnumerator method

DesignCheckCollection::Remove method

DesignCheckCollection::RemoveAt method

DesignChecks

DesignCheckSetId

DesignCheckSetName

DesignCheckType

DesignSpeed

DesignSpeed class

about DesignSpeed class

DesignSpeed::Comment property

DesignSpeed::SpeedNumber property

DesignSpeed::Station property

DesignSpeed::Value property

DesignSpeedBased

DesignSpeedCollection class

about DesignSpeedCollection class

DesignSpeedCollection::Add method

DesignSpeedCollection::Count property

DesignSpeedCollection::default property

DesignSpeedCollection::GetDesignSpeed method

DesignSpeedCollection::GetEnumerator method

DesignSpeedCollection::GetObjectEnumerator method

DesignSpeedCollection::Remove method

DesignSpeedLabelStyles

DesignSpeedLookupMethod

DesignSpeeds

Detailed enumeration member

Dialog enumeration member

DiameterOrWidth

DiameterUnits

Dimension

Dimension enumeration member

DimensionAnchorElevationValueForPipes

DimensionAnchorElevationValueForProjections

DimensionAnchorElevationValueForStructures

DimensionAnchorInfo

DimensionAnchorOption

DimensionAnchorOptionForPipes

DimensionAnchorOptionForStructures

DimensionAnchorPlotHeightValueForPipes

DimensionAnchorPlotHeightValueForProjections

DimensionAnchorPlotHeightValueForStructures

DimensionAnchorValue

Direction

Direction enumeration member

DirectionArrow enumeration member

DirectionAtLocation

DirectionAtPoint1

DirectionAtPoint2

DirectionAtStation

DirectionLeft enumeration member

DirectionRight enumeration member

Directions enumeration member

DirectionStyle

Disabled enumeration member

DisabledEnabled enumeration member

DisableDescriptionKeys

Disconnect

Display3dType

DisplayAll enumeration member

DisplayAsBlock enumeration member

DisplayAsBoundary enumeration member

DisplayAsSolid enumeration member

DisplayCenterAxis

DisplayContourLabelLine

DisplayDepressions

DisplayEntityMode

DisplayHorizontalGrid

DisplayMode

DisplayName

DisplayOrder

DisplaySelected enumeration member

DisplayType

DisplayVerticalGrid

DisplayXmlReport

Distance

Distance enumeration member

DistanceAbove enumeration member

DistanceBelow enumeration member

DistanceProjectionType

DistanceRuleToAdjusttheGrade

DistanceToAlignment

DistanceValue

Divide enumeration member

Divided enumeration member

Document

Domain

Dot enumeration member

DotBlank enumeration member

DotSmall enumeration member

Double enumeration member

DoubleAngle enumeration member

DoubleArea enumeration member

DoubleDistance enumeration member

DoubleDistanceMinor enumeration member

DoubleElevation enumeration member

DoubleGeneral enumeration member

DoubleNonZero enumeration member

DoubleNonZeroNonNegative enumeration member

DoublePercent enumeration member

DoubleVolume enumeration member

Down enumeration member

DownhillTangentLabelStyleId

DownhillTangentTickStyle

Dragged

DraggedOffset

DraggedStateComponents

Draw

Draw3DEntityProfile

Drawing enumeration member

DrawingBasedReportTableFont

DrawingScale

DrawingScale enumeration member

DrawingScaleModelSize

DrawingSettings

DrawingUnits

DrawOverride

DrawToInnerWall enumeration member

DrawToInnerWalls enumeration member

DrawToOuterWall enumeration member

DrawToOuterWalls enumeration member

DrivingDirection

DropDecimalForWholeNumbers

DropLeadingZerosForDegrees

DropLeadingZerosRightOfStationCharacter

DumpSiteCapacity

Dynamic enumeration member

DynamicAlignmentHighlight

DynamicUpdate enumeration member

E

Earthwork enumeration member

Easting

EastingNorthing enumeration member

EchoCoordinatesToCommandLine

EdgeContraction enumeration member

EG enumeration member

EggShaped enumeration member

Elevation

Elevation enumeration member

ElevationAt

ElevationAtStationNotFound enumeration member

ElevationGreaterThan

ElevationLessThan

ElevationMax

ElevationMin

ElevationPoint enumeration member

ElevationProjectionType

ElevationRangeMode

Elevations enumeration member

ElevationSource

ElevationStyle

ElevationTarget enumeration member

ElevationTargetPipe enumeration member

ElevationToUse

Elliptical enumeration member

EmailAddress

EnableFirstViewFrameOffset

EnableMapcheckAcrossChord

EnableRadiusSnap

EnableWordWrapping

End enumeration member

EndAnchorPoint

EndDirection

EndElevation

EndExtension enumeration member

EndFullSuper enumeration member

EndingStation

EndingVertex enumeration member

EndLine enumeration member

EndLineSize

EndLineSize enumeration member

EndLineSizePercent

EndLineSizePercent enumeration member

EndNormalCrown enumeration member

EndNormalShoulder enumeration member

EndOfAlign enumeration member

EndOfAlignment enumeration member

EndOffset

EndPoint

EndPointAnchorComponent

EndPointAnchorPoint

EndPointElevation

EndPointMarkerStyle

EndPointOffset

EndPointStation

EndPointXOffset

EndPointYOffset

EndRangeAtAlignmentEnd

EndSizeOptions

EndSizeOptions enumeration member

EndSizeType

EndSizeType enumeration member

EndStation

EndStation enumeration member

EndStationOnMainBaseline

EndStructureId

EndToStart enumeration member

EndVerticalCurve enumeration member

EndVerticalCurveElevation enumeration member

EndVerticalCurveStation enumeration member

EnergyGradeLine enumeration member

Entities

Entity class

about Entity class

Entity::Application property

Entity::DisplayName property

Entity::Document property

Entity::IsReferenceObject property

Entity::IsReferenceStale property

Entity::IsReferenceSubObject property

Entity::IsReferenceValid property

Entity::Name property

Entity::ShowToolTip property

Entity::StyleId property

Entity::StyleName property

EntityAfter

EntityAtId

EntityAtStation

EntityBefore

EntityId

EntityType

EnumCount

EqualInterval enumeration member

Equals

Equation enumeration member

EquationType

EraseAllExistingEntities

EraseAllParams

EraseExistingEntities

ExactElevation enumeration member

ExactStation enumeration member

ExaggerateElevationBy

ExaggerateElevations enumeration member

ExaggeratePointElevations enumeration member

Exclude enumeration member

ExcludeElevationsGreaterThan

ExcludeElevationsLessThan

ExistingSheetSetName

Export

ExportCrossSections

ExportDescriptionKeys

ExportOptions

ExportPointReferences

ExportTo

Expression

Expression class

about Expression class

Expression::Description property

Expression::ExpressionString property

Expression::FormatResultAs property

Expression::Name property

ExpressionCollection class

about ExpressionCollection class

ExpressionCollection::Add method

ExpressionCollection::Clear method

ExpressionCollection::Count property

ExpressionCollection::default property

ExpressionCollection::GetEnumerator method

ExpressionCollection::GetObjectEnumerator method

ExpressionCollection::RemoveAt method

Expressions

ExpressionString

ExtendingEdge enumeration member

ExtendProfileAlongIncomingLane

ExtendProfileAlongOutgoingLane

ExternalDist enumeration member

ExternalSecant

ExternalTangent

F

Faces3d enumeration member

Failure enumeration member

Feature class

about Feature class

Feature::IsEditable property

Feature::IsEditableFeature method

FeatureId

FeatureLabel class

about FeatureLabel class

FeatureLine

FeatureLine class

about FeatureLine class

about FeatureLine class

FeatureLine enumeration member

FeatureLine::CodeName property

FeatureLine::CorridorId property

FeatureLine::FeatureLinePoints property

FeatureLine::Identity nested type

FeatureLine::StyleId property

FeatureLine::StyleName property

FeatureLineCodeInfo

FeatureLineCodeInfo class

about FeatureLineCodeInfo class

FeatureLineCodeInfo::CodeName property

FeatureLineCodeInfo::CorridorId property

FeatureLineCodeInfo::Identity nested type

FeatureLineCodeInfo::IsConnect property

FeatureLineCodeInfo::IsDraw property

FeatureLineCodeInfoCollection class

about FeatureLineCodeInfoCollection class

FeatureLineCodeInfoCollection::CodeNames method

FeatureLineCodeInfoCollection::CorridorId property

FeatureLineCodeInfoCollection::Count property

FeatureLineCodeInfoCollection::default property

FeatureLineCodeInfoCollection::GetEnumerator method

FeatureLineCodeInfoCollection::GetObjectEnumerator method

FeatureLineCodeInfos

FeatureLineCodeIsBreak

FeatureLineCodes

FeatureLineCollection class

about FeatureLineCollection class

FeatureLineCollection::CorridorId property

FeatureLineCollection::Count property

FeatureLineCollection::default property

FeatureLineCollection::FeatureLineCodeInfo property

FeatureLineCollection::GetEnumerator method

FeatureLineCollection::GetObjectEnumerator method

FeatureLineCollection::Identity nested type

FeatureLineCollectionMap

FeatureLineCollectionMap class

about FeatureLineCollectionMap class

FeatureLineCollectionMap::CodeNames method

FeatureLineCollectionMap::CorridorId property

FeatureLineCollectionMap::Count property

FeatureLineCollectionMap::default property

FeatureLineCollectionMap::GetEnumerator method

FeatureLineCollectionMap::GetObjectEnumerator method

FeatureLineCollectionMap::Identity nested type

FeatureLineComponent class

about FeatureLineComponent class

FeatureLineComponent::CorridorId property

FeatureLineComponent::EndStation property

FeatureLineComponent::FeatureLine property

FeatureLineComponent::Identity nested type

FeatureLineComponent::IsReversed property

FeatureLineComponent::StartStation property

FeatureLineComponent::UseEndStation property

FeatureLineComponent::UseStartStation property

FeatureLineComponentCollection class

about FeatureLineComponentCollection class

FeatureLineComponentCollection::CorridorId property

FeatureLineComponentCollection::Count property

FeatureLineComponentCollection::default property

FeatureLineComponentCollection::GetEnumerator method

FeatureLineComponentCollection::GetObjectEnumerator method

FeatureLineComponentCollection::Identity nested type

FeatureLineComponents

FeatureLineCreation

FeatureLineDisplayStyleModel

FeatureLineDisplayStylePlan

FeatureLineFitCurve

FeatureLineJoin

FeatureLineName

FeatureLinePoint class

about FeatureLinePoint class

FeatureLinePoint::CorridorId property

FeatureLinePoint::Identity nested type

FeatureLinePoint::IsBreak property

FeatureLinePoint::Station property

FeatureLinePoint::XYZ property

FeatureLinePointCollection class

about FeatureLinePointCollection class

FeatureLinePointCollection::CorridorId property

FeatureLinePointCollection::Count property

FeatureLinePointCollection::default property

FeatureLinePointCollection::GetEnumerator method

FeatureLinePointCollection::GetObjectEnumerator method

FeatureLinePointCollection::Identity nested type

FeatureLinePoints

FeatureLineStyle

FeatureLineStyle class

about FeatureLineStyle class

FeatureLineStyle::FeatureLineDisplayStyleModel property

FeatureLineStyle::FeatureLineDisplayStylePlan property

FeatureLineStyle::GetDisplayStyleProfile method

FeatureLineStyle::GetFeatureLineDisplayStyleModel method

FeatureLineStyle::GetFeatureLineDisplayStylePlan method

FeatureLineStyle::GetSectionMarkerDisplayStyleSection method

FeatureLineStyle::ProfileBeginningVertexMarkerStyleId property

FeatureLineStyle::ProfileBeginningVertexMarkerStyleName property

FeatureLineStyle::ProfileEndingVertexMarkerStyleId property

FeatureLineStyle::ProfileEndingVertexMarkerStyleName property

FeatureLineStyle::ProfileInternalVertexMarkerStyleId property

FeatureLineStyle::ProfileInternalVertexMarkerStyleName property

FeatureLineStyle::SectionMarkerDisplayStyleSection property

FeatureLineStyle::SectionMarkerStyleId property

FeatureLineStyle::SectionMarkerStyleName property

FeatureLineStyleCollection class

about FeatureLineStyleCollection class

FeatureLineStyleCollection::Add method

FeatureLineStyleId

FeatureLineStyleName

FeatureLineStyles

FeatureLineWeed

Feet enumeration member

FG enumeration member

Figure

File enumeration member

Fill enumeration member

FillArea

FillAreaShapeStyle

Filled enumeration member

Fillet enumeration member

FilletRadiusAtAlignmentIntersections

FilletRadiusAtParcelBoundaryIntersections

FillFactor

FillFirst enumeration member

FillSlope

FillSlope enumeration member

FillSlopeFormatType

FillSlopeGrading

FindElevationAtXY

FindShortestNetworkPath

FindStationAndElevationAtXY

FindXYAtStationAndElevation

First enumeration member

FirstEntity

FirstSplitViewStyle

FirstViewFrameOffsetDistance

Fit

Five enumeration member

Fixed enumeration member

FixedElevation enumeration member

FixedLength

FixedLength enumeration member

FixedList enumeration member

FixedScale enumeration member

FixedScaleX

FixedScaleY

FixedScaleZ

FixedSize

FlattenElevations enumeration member

FlattenPointElevations enumeration member

FlattenToElevationBy

Flex enumeration member

FlipAnchorsWithText

Flipped

Float enumeration member

FloorThickness

FloorThickness enumeration member

Flow enumeration member

FlowAnalysisDarcyWeisbach enumeration member

FlowAnalysisHazenWilliams enumeration member

FlowAnalysisManning enumeration member

FlowDirection

FlowDirectionMethod

FollowASection enumeration member

Foot enumeration member

FootPerSec enumeration member

FootPerSecSquared enumeration member

Format

FormatResultAs

Fractional enumeration member

Frame

FrameDiameter

FrameHeight

Free enumeration member

FreeHaulAreaHatch enumeration member

FreeHaulLine enumeration member

FreeHaulOption

FrequencyAlongCurves

FrequencyAlongProfileCurves

FrequencyAlongSpirals

FrequencyAlongTangents

FromLabelStyle enumeration member

FrontageColor

FrontageOffset

FrontageOffsetColor

FrontClip

FullDescription

FullDescription enumeration member

FullHeight enumeration member

FullImport enumeration member

FullSuperLabelStyleId

FullSuperTickStyle

G

Gap

GapBetweenPages

GapBetweenViews

General

General enumeration member

GeneralCurve enumeration member

GeneralCurveLabelStyles

GeneralLine enumeration member

GeneralLineLabelStyles

GeneralLink enumeration member

GeneralLinkLabelStyles

GeneralMarker enumeration member

GeneralMarkerLabelStyles

GeneralNote enumeration member

GeneralNoteLabel enumeration member

GeneralNoteLabelStyles

GeneralSegmentLabel enumeration member

GeneralShape enumeration member

GeneralShapeLabelStyles

GeneralText

GeoEntity class

about GeoEntity class

GeographicCoordinates

GeometricOverrideStations enumeration member

Geometry

Geometry enumeration member

GeometryGenerateMode

GeometryGenerator

GeometryPoint enumeration member

GeometryPointLabelOption template

about GeometryPointLabelOption template

GeometryPointLabelOption::PointType property

GeometryPointLabelOption::Selected property

GeometryPointLabelStyles

GeometryPointSelector

GeometryPointSelector template

about GeometryPointSelector template

GeometryPointSelector::default property

GeometryPointSelector::GeometryPointSelector constructor

GeometryPointSelector::SelectAll method

GeometryPointSelector::UnSelectAll method

GeometryStationType

Get3dBody

GetAlignmentAbbreviation

GetAlignmentEnhancedAbbreviation

GetAlignmentGeometryPoints

GetAlignmentIds

GetAlignmentTableIds

GetAllCodes

GetAllDataFields

GetAllDesignChecks

GetAllPointIds

GetAppliedSubassemblies

GetAreaFillHatchDisplayStyleModel

GetAreaFillHatchDisplayStylePlan

GetAt

GetAvailableLabelGroups

GetAvailablePartFamilies

GetBoundingShapeBody

GetChain3DDisplayStyleModel

GetClosestPointTo

GetComponents

GetComponentsCount

GetComponentsDrawOrder

GetConnectedPipeNames

GetContentString

GetContentStringFormatted

GetContourValues

GetCoordinateSystemByCode

GetCorridor

GetCurrentStyleSetId

GetCurveDesignCheckType

GetDataFieldBy

GetDesignSpeed

GetDisplayPlan

GetDisplayStyleModel

GetDisplayStylePlan

GetDisplayStyleProfile

GetDisplayStyleSection

GetDistanceToAlignment

GetElevation

GetEntityByOrder

GetEnumData

GetEnumerator

GetFeatureLineDisplayStyleModel

GetFeatureLineDisplayStylePlan

GetFeatureLineIds

GetGeometryPointsOptions

GetHashCode

GetHatchDisplayStyleModel

GetHatchDisplayStylePlan

GetHatchDisplayStyleProfile

GetHatchDisplayStyleSection

GetHatchStylePlan

GetHatchStyleProfile

GetHatchStyleSection

GetHeadlightSightDistance

GetInstantaneousRadius

GetIntersectionIds

GetItemAt

GetItemBy

GetLabelDisplayStyleModel

GetLabelDisplayStylePlan

GetLabelGroupIds

GetLabelIds

GetLegendTableIds

GetLineMarkerDisplayStyleSection

GetLinesDisplayStylePlan

GetLinkDisplayStyleModel

GetLinkDisplayStylePlan

GetMarkerDisplayStyleModel

GetMarkerDisplayStylePlan

GetMarkerDisplayStyleProfile

GetMarkerDisplayStyleSection

GetMassHaulViewIds

GetMatchLineIds

GetMatchLineMaskDisplayStylePlan

GetMatchLineMaskHatchDisplayStyle

GetMaxIndex

GetNearestPipeOfNetworkToAlignment

GetNetworkPartViewDef

GetNextUniqueName

GetObjectEnumerator

GetObjectLayerSetting

GetOffsetBaselineNames

GetOffsetElevationFromMainBaselineStation

GetOverriddenRuleIds

GetParamAtPoint

GetParamByContextAndIndex

GetParcelIds

GetParcelSegmentTableIds

GetParcelTableIds

GetPartFamilyIdsByDomain

GetPassingSightDistance

GetPayItemIds

GetPipeIds

GetPipeNetworkIds

GetPoint

GetPointAtParam

GetPointTableIds

GetPolyline

GetProfileAbbreviation

GetProfileGeometryPoints

GetProfileIds

GetProfileInFrontView

GetProfileMarkerDisplayStyleSection

GetProfileViewIds

GetProfileViewsDisplayingMe

GetProject2dPointVertically

GetPVIAt

GetRegions

GetResourceString

GetRuleIds

GetSampleElevations

GetSampleLineGroupIds

GetSampleLineIds

GetSectionMarkerDisplayStyleSection

GetSectionViewIds

GetSectionViewsDisplayingMe

GetSegmentCrossSlope

GetSettings

GetSiteIds

GetSitelessAlignmentId

GetSitelessAlignmentIds

GetSpanningPipePlanLabelIds

GetSpanningPipeProfileLabelIds

GetStationEquation

GetStationSet

GetStationStringWithEquations

GetStoppingSightDistance

GetStructureIds

GetSuperelevationAbbreviation

GetSuperelevationZoneAtStation

GetSupportedContexts

GetSurfaceIds

GetTextComponentIds

GetTextComponentJustificationOverride

GetTextComponentOverride

Getting Started

GetViewFrameBoundaryDisplayStylePlan

GetViewFrameGroupIds

GetViewFrameIds

GetXYZ

Global enumeration member

GoogleEarthColumns

GoogleEarthOptions

GoogleEarthRows

Grad enumeration member

Grade

Grade enumeration member

Grade1

Grade2

GradeAt

GradeAtThroughPoint1

GradeAtThroughPoint2

GradeBreadLabelStyles

GradeBreak enumeration member

GradeBreakExtension enumeration member

GradeBreakLabelStyles

GradeBreaksLabelStyleId

GradeBreaksTickStyle

GradeChange

GradeChange enumeration member

GradeFactor

GradeIn

GradeOut

GradePoint enumeration member

GradeRatio enumeration member

GradeRuleType

GradeSlope

GradeSlope enumeration member

Grading class

about Grading class

Grading enumeration member

GradingCreation

GradingCriteria class

about GradingCriteria class

GradingCriteria::CopyAsSibling method

GradingCriteria::CutSlope property

GradingCriteria::CutSlopeFormatType property

GradingCriteria::Distance property

GradingCriteria::DistanceProjectionType property

GradingCriteria::Elevation property

GradingCriteria::ElevationProjectionType property

GradingCriteria::FillSlope property

GradingCriteria::FillSlopeFormatType property

GradingCriteria::InteriorCornerOverlap property

GradingCriteria::ProjectionDistance property

GradingCriteria::ProjectionRelativeElevation property

GradingCriteria::RelativeElevation property

GradingCriteria::RelativeElevationProjectionType property

GradingCriteria::SearchOrder property

GradingCriteria::Slope property

GradingCriteria::SlopeFormatType property

GradingCriteria::SurfaceProjectionType property

GradingCriteria::Target property

GradingCriteriaCollection class

about GradingCriteriaCollection class

GradingCriteriaCollection::Add method

GradingCriteriaIds

GradingCriteriaSet

GradingCriteriaSet class

about GradingCriteriaSet class

GradingCriteriaSet::AddCriteria method

GradingCriteriaSet::Count property

GradingCriteriaSet::default property

GradingCriteriaSet::GradingCriteriaIds method

GradingCriteriaSet::MoveCriteria method

GradingCriteriaSet::RemoveCriteria method

GradingCriteriaSetCollection class

about GradingCriteriaSetCollection class

GradingCriteriaSetCollection::Add method

GradingCriteriaSets

GradingElevationEditor

GradingGroup

GradingGroupCreation

GradingLabeling enumeration member

GradingLayoutTools

GradingStyle

GradingStyle class

about GradingStyle class

GradingStyle::CenterMarker property

GradingStyle::FixedSize property

GradingStyle::GetDisplayStyleModel method

GradingStyle::GetDisplayStylePlan method

GradingStyle::PercentageOfScreen property

GradingStyle::PlottedSize property

GradingStyle::SlopePatternStyleId property

GradingStyle::SlopePatternStyleName property

GradingStyle::SlopeRangeMax property

GradingStyle::SlopeRangeMin property

GradingStyle::UseSlopePatternStyle property

GradingStyle::UseSlopeRange property

GradingStyleCollection class

about GradingStyleCollection class

GradingStyleCollection::Add method

GradingStyleCollection::SetCenterMarkerVisable method

GradingStyleCollection::SetSlopePatternVisable method

GradingStyles

GradingSurfaceCreation

Grads enumeration member

Graph class

about Graph class

GraphOverride class

about GraphOverride class

GraphOverride::Draw property

GraphOverride::OverrideStyleId property

GraphOverride::OverrideStyleName property

GraphOverride::UseOverrideStyle property

GraphOverrides

GraphStyle

GraphStyle class

about GraphStyle class

GraphStyle::CurrentHorizontalScale property

GraphStyle::Direction property

GraphStyle::TitleStyle property

GraphStyle::VerticalExaggeration property

GraphStyle::VerticalScale property

GraphTitle enumeration member

GraphTitleStyle class

about GraphTitleStyle class

GraphTitleStyle::Border property

GraphTitleStyle::BorderGap property

GraphTitleStyle::Justification property

GraphTitleStyle::Location property

GraphTitleStyle::OffsetX property

GraphTitleStyle::OffsetY property

GraphTitleStyle::Text property

GraphTitleStyle::TextHeight property

GraphTitleStyle::TextStyle property

GraphViewBottom enumeration member

GraphViewTop enumeration member

Grate

GreaterThan180

Greens enumeration member

GridAtHGP enumeration member

GridAtPGP enumeration member

GridAtSampleLineStations enumeration member

GridColor

GridCoordinate

GridCoordinates

Gridded enumeration member

GridHorizontalMajor

GridHorizontalMajor enumeration member

GridHorizontalMinor

GridHorizontalMinor enumeration member

GridOptions class

about GridOptions class

GridOptions::ClipToHighestProfile property

GridOptions::OmitGridInPaddingAreas property

GridOptions::UseClipGrid property

GridPaddingAbove

GridPaddingBottom

GridPaddingLeft

GridPaddingRight

GridReferencePoint

GridRotationAngle enumeration member

GridRotationPoint

GridScaleFactor

GridScaleFactorComputation

GridSettings

GridSpacing

GridStyle

GridStyle class

about GridStyle class

GridStyle::AxisOffsetAbove property

GridStyle::AxisOffsetBottom property

GridStyle::AxisOffsetLeft property

GridStyle::AxisOffsetRight property

GridStyle::GridPaddingAbove property

GridStyle::GridPaddingBottom property

GridStyle::GridPaddingLeft property

GridStyle::GridPaddingRight property

GridStyle::HorizontalGridOptions property

GridStyle::VerticalGridOptions property

GridSurface class

about GridSurface class

GridSurface enumeration member

GridSurfaceLabeling enumeration member

GridSurfaceOrientation

GridSurfaceXSpacing

GridSurfaceYSpacing

GridTextSettings

GridVerticalMajor

GridVerticalMajor enumeration member

GridVerticalMinor

GridVerticalMinor enumeration member

GridVolumeSurface enumeration member

Group

GroupArc enumeration member

GroupArc2 enumeration member

GroupId

GroupPlot

GroupPlotStyle class

about GroupPlotStyle class

GroupPlotStyle::AlignType property

GroupPlotStyle::CellSizeType property

GroupPlotStyle::GapBetweenPages property

GroupPlotStyle::MaximumInColumn property

GroupPlotStyle::MaximumInRow property

GroupPlotStyle::PlotAreaType property

GroupPlotStyle::PlotRule property

GroupPlotStyle::SheetStyleId property

GroupPlotStyle::SheetStyleName property

GroupPlotStyle::SpaceColumn property

GroupPlotStyle::SpaceRow property

GroupPlotStyle::StartCorner property

GroupPlotStyleCollection class

about GroupPlotStyleCollection class

GroupPlotStyleCollection::Add method

GroupPlotStyles

GroupRangeValuesBy

GroupSpiral1 enumeration member

GroupSpiral2 enumeration member

GroupSpiral3 enumeration member

GroupSpiral4 enumeration member

GroupTangent enumeration member

GroupValuesBy

GUID

H

HardCoded enumeration member

HardcodedOffsetBaseline class

about HardcodedOffsetBaseline class

HardcodedOffsetBaseline enumeration member

HardcodedOffsetBaseline::AlignmentId property

HardcodedOffsetBaseline::BaselineType property

HardcodedOffsetBaseline::EndStation property

HardcodedOffsetBaseline::Identity nested type

HardcodedOffsetBaseline::Name property

HardcodedOffsetBaseline::OffsetElevationFromMainBaseline property

HardcodedOffsetBaseline::ProfileId property

HardcodedOffsetBaseline::RelatedOffsetBaselineFeatureLines property

HardcodedOffsetBaseline::SortedStations method

HardcodedOffsetBaseline::StartStation property

HardcodedOffsetBaselineName

HasParentAssembly

Hatch enumeration member

HatchAreas

HatchOptions

HatchOptions enumeration member

HatchSolid enumeration member

HatchToInnerWalls enumeration member

HatchToOuterWalls enumeration member

HatchWallsOnly enumeration member

HeaderAreaFill enumeration member

HeaderAreaFillDisplayStyleModel

HeaderAreaFillDisplayStylePlan

HeaderJustification

HeaderSeparator enumeration member

HeaderSeparatorDisplayStyleModel

HeaderSeparatorDisplayStylePlan

HeaderString

HeaderStringFormatted

HeaderText enumeration member

HeaderTextDisplayStyleModel

HeaderTextDisplayStylePlan

HeaderTextHeight

HeaderTextStyle

HeadlightAngle

HeadlightHeight

HeadlightSightDistance

HeadwallBaseThickness

HeadwallBaseWidth

Hectare enumeration member

Height

HelpCommand

HelpData

HelpFile

HGPLabelStyleId

HGPTickStyle

Hide enumeration member

HighestDesignSpeed

HighlightBaseline

HighlightHorizontalTargets

HighlightInteriorAssemblies

HighlightRegionBoundary

HighLowPointElevation

HighLowPointStation

HighPoint enumeration member

HighPointMarkerStyle

HighsideLocation

HoldOnResizeType

HoldSlopeAsMaximum enumeration member

HoldSlopeAsMinimum enumeration member

Horizontal enumeration member

HorizontalDeviation

HorizontalElliptical enumeration member

HorizontalGeometry enumeration member

HorizontalGeometryBand enumeration member

HorizontalGeometryBandStyle class

about HorizontalGeometryBandStyle class

HorizontalGeometryBandStyle::BandType property

HorizontalGeometryBandStyle::CurveLabelStyleId property

HorizontalGeometryBandStyle::CurveTickStyle property

HorizontalGeometryBandStyle::GetDisplayStylePlan method

HorizontalGeometryBandStyle::SchematicLineType property

HorizontalGeometryBandStyle::SpiralLabelStyleId property

HorizontalGeometryBandStyle::SpiralTickStyle property

HorizontalGeometryBandStyle::TangentLabelStyleId property

HorizontalGeometryBandStyle::TangentTickStyle property

HorizontalGeometryBandStyle::TitleTextLabelStyleId property

HorizontalGeometryCurve enumeration member

HorizontalGeometryPointLabelStyles

HorizontalGeometryPoints

HorizontalGeometrySpiral enumeration member

HorizontalGeometryTangent enumeration member

HorizontalGeometryTickStyle

HorizontalGridInterval

HorizontalGridOptions

HorizontalMask enumeration member

HorizontalMidOrdinateDistance

HorizontalTargetsColor

HorizontalTargetsLineweight

HydraulicGradeLine enumeration member

Hydro enumeration member

I

ICommonLabel interface

about ICommonLabel interface

ICommonLabel::AnchorInfo property

ICommonLabel::AnchorMarkerStyleId property

ICommonLabel::ClearAllTextComponentOverrides method

ICommonLabel::DimensionAnchorInfo property

ICommonLabel::DimensionAnchorOption property

ICommonLabel::DimensionAnchorValue property

ICommonLabel::Dragged property

ICommonLabel::DraggedOffset property

ICommonLabel::Flipped property

ICommonLabel::GetTextComponentIds method

ICommonLabel::GetTextComponentJustificationOverride method

ICommonLabel::GetTextComponentOverride method

ICommonLabel::IsTextComponentOverriden method

ICommonLabel::LeaderAttachment property

ICommonLabel::LeaderTailVisibility property

ICommonLabel::LeaderVisibility property

ICommonLabel::Pinned property

ICommonLabel::Reset method

ICommonLabel::ResetLocation method

ICommonLabel::ResetProperties method

ICommonLabel::Reversed property

ICommonLabel::SetTextComponentJustificationOverride method

ICommonLabel::SetTextComponentOverride method

ICommonLabel::StyleId property

ICommonLabelOptions interface

about ICommonLabelOptions interface

ICommonLabelOptions::AllowsAnchorMarker property

ICommonLabelOptions::AllowsDimensionAnchors property

ICommonLabelOptions::AllowsDragging property

ICommonLabelOptions::AllowsFlipping property

ICommonLabelOptions::AllowsLeaderAttachment property

ICommonLabelOptions::AllowsPinning property

ICommonLabelOptions::AllowsReversing property

ICommonLabelOptions::DefaultDimensionAnchorOption property

ICommonLabelOptions::DefaultDimensionAnchorValue property

Identification

Identity

Ignore enumeration member

Imperial

ImperialToMetricConversion

ImperialUnits

Import

ImportLabelSet

ImportOptions

InAlignmentId

Inch enumeration member

Include enumeration member

IncludeFormulasInReports

IncludeMidElevationBreaks

InclusionDistance

Increasing enumeration member

Increment

IncrementalDistanceLabelStyleId

IncrementAlongCurves

IncrementAlongSpirals

IncrementAlongTangents

IncrementalSectionDataLabelStyleId

IncrementalSectionDataTickStyle

IncrementalStationRegionLabels enumeration member

IncrementSmallTicksAtBottom

IncrementSmallTicksAtMiddle

IncrementSmallTicksAtTop

IncrementTicksToFullHeight

InCurve enumeration member

IndependentLayerOn

Index

Information

Informational enumeration member

InnerDiameter

InnerDiameter enumeration member

InnerDiameterOrWidth

InnerDiameterPercent

InnerDiameterPercent enumeration member

InnerHeight

InnerLength

InnerType

InOutCurve enumeration member

Input enumeration member

InputAndOutput enumeration member

Insertion enumeration member

InsertionPoint enumeration member

InsertMatchLines

InsertOption

Inside enumeration member

InsideBoundary enumeration member

InsideCurveOption

InsideShoulderMethod

InsideWalls enumeration member

Int enumeration member

Integral enumeration member

Interference

Interference class

about Interference class

Interference enumeration member

Interference::Network1Id property

Interference::Network2Id property

InterferenceCheck

InterferenceCheck class

about InterferenceCheck class

InterferenceCriteria

InterferenceRenderMaterial

InterferenceStyle class

about InterferenceStyle class

InterferenceStyle::AbsoluteModelSize property

InterferenceStyle::DrawingScaleModelSize property

InterferenceStyle::GetDisplayStyleModel method

InterferenceStyle::GetDisplayStylePlan method

InterferenceStyle::GetDisplayStyleSection method

InterferenceStyle::MarkerStyle property

InterferenceStyle::ModelOptions property

InterferenceStyle::ModelSizeOptions property

InterferenceStyle::ModelSizeType property

InterferenceStyleCollection class

about InterferenceStyleCollection class

InterferenceStyleCollection::Add method

InterferenceStyles

InteriorAssembliesColor

InteriorAssembliesLineweight

InteriorCornerOverlap

IntermediateSplitViewStyle

InternalEdges enumeration member

InternalVertex enumeration member

InternationalFoot enumeration member

Interpolate enumeration member

IntersectAlignment

Intersection

Intersection class

about Intersection class

Intersection enumeration member

Intersection::CorridorId property

Intersection::GradeRuleType property

Intersection::IntersectionRegions property

Intersection::IntersectionRoads property

Intersection::Location property

Intersection::RoadwayDrivingDirection property

IntersectionAllAlignment enumeration member

IntersectionExtents enumeration member

IntersectionLabel

IntersectionLabeling enumeration member

IntersectionLabelStyles

IntersectionLocationLabels enumeration member

IntersectionOptions

IntersectionPointMarkerStyle

IntersectionQuadrant

IntersectionRegion class

about IntersectionRegion class

IntersectionRegion::Angle property

IntersectionRegion::CurbReturnAlignmentId property

IntersectionRegion::CurbReturnProfileId property

IntersectionRegion::InAlignmentId property

IntersectionRegion::Name property

IntersectionRegion::OutAlignmentId property

IntersectionRegionCollection class

about IntersectionRegionCollection class

IntersectionRegionCollection::Count property

IntersectionRegionCollection::default property

IntersectionRegionCollection::GetEnumerator method

IntersectionRegionCollection::GetObjectEnumerator method

IntersectionRegions

IntersectionRoad class

about IntersectionRoad class

IntersectionRoad::CenterlineAlignmentId property

IntersectionRoad::CenterlineProfileId property

IntersectionRoad::OffsetLeftAlignmentId property

IntersectionRoad::OffsetLeftProfileId property

IntersectionRoad::OffsetRightAlignmentId property

IntersectionRoad::OffsetRightProfileId property

IntersectionRoadCollection class

about IntersectionRoadCollection class

IntersectionRoadCollection::Count property

IntersectionRoadCollection::default property

IntersectionRoadCollection::GetEnumerator method

IntersectionRoadCollection::GetObjectEnumerator method

IntersectionRoads

IntersectionStyle class

about IntersectionStyle class

IntersectionStyle::GetDisplayStyleModel method

IntersectionStyle::GetDisplayStylePlan method

IntersectionStyle::MarkerStyleId property

IntersectionStyleCollection class

about IntersectionStyleCollection class

IntersectionStyleCollection::Add method

IntersectionStyles

IntersectionType

IntersectLink

IntersectSurface

Interval

IntervalAlongContour

IntGeneral enumeration member

IntNonZero enumeration member

IntNonZeroNonNegative enumeration member

InvalidArraySpecifiedForLinkDefinition enumeration member

InvalidArraySpecifiedForLinkDefinitionFormat enumeration member

InvalidArraySpecifiedForShapeDefinition enumeration member

InvalidArraySpecifiedForShapeDefinitionFormat enumeration member

InvalidCorridorStateObjectId enumeration member

InvalidSubassemblyCOMClassId enumeration member

Inverse enumeration member

Invert enumeration member

IParam interface

about IParam interface

IParam::Access property

IParam::Comment property

IParam::Description property

IParam::DisplayName property

IParam::DisplayOrder property

IParam::IsReadOnly property

IParam::Value property

IPoint interface

about IPoint interface

IPoint::Codes property

IPoint::Elevation property

IPoint::Index property

IPoint::Offset property

IPoint::Station property

IsAboveSurface

IsBreak

IsBreakingPipe

IsBuild

IsConnect

IsConnectedPipeFlowingIn

IsConnectedPipeFlowingOut

IsConnectingToStructure

IsCorridorSectionViewActive

IsCurrentPartBeingAdd

IsDraw

IsDynamic

IsEditable

IsEditableFeature

IsFromList

IsFromRange

IsGroupLabelType

IsHidden

IsInLayoutMode

IsLayoutUpStream

IsLoopPoint

IsMainBaseline

IsMaxCoverViolated

IsMinCoverViolated

IsMultipleSelect

IsNamed

IsOnCurve

IsOutOfDate

IsPointInsideStructureRegion

IsProcessed

IsReadOnly

IsReferenceObject

IsReferenceStale

IsReferenceSubObject

IsReferenceValid

IsReversed

IsSiteless

IsSupportedComponent

IsSurveyPoint

IsTextComponentOverriden

IsValidValue

IsVolumeSurface

ItemType

J

JapaneseCubic enumeration member

JoiningTangent enumeration member

Justification

K

K

K0 enumeration member

K1 enumeration member

K100 enumeration member

K2 enumeration member

K3 enumeration member

K32 enumeration member

K33 enumeration member

K34 enumeration member

K35 enumeration member

K36 enumeration member

K4 enumeration member

K64 enumeration member

K65 enumeration member

K66 enumeration member

K67 enumeration member

K68 enumeration member

K96 enumeration member

K97 enumeration member

K98 enumeration member

K99 enumeration member

Kilometer enumeration member

KiloMeter enumeration member

KilometerPerHour enumeration member

kSp1AValSp2AValPt1Pt2 enumeration member

kSp1AValSp2AValRadiusPt enumeration member

kSp1LenSp2LenPt1Pt2 enumeration member

kSp1LenSp2LenRadiusPt enumeration member

KValue enumeration member

L

Label

Label class

about Label class

Label enumeration member

Label::AnchorInfo property

Label::AnchorMarkerStyleId property

Label::ClearAllTextComponentOverrides method

Label::DimensionAnchorInfo property

Label::DimensionAnchorOption property

Label::DimensionAnchorValue property

Label::Dragged property

Label::DraggedOffset property

Label::Flipped property

Label::GetTextComponentIds method

Label::GetTextComponentJustificationOverride method

Label::GetTextComponentOverride method

Label::IsTextComponentOverriden method

Label::LeaderAttachment property

Label::LeaderTailVisibility property

Label::LeaderVisibility property

Label::Pinned property

Label::Reset method

Label::ResetLocation method

Label::ResetProperties method

Label::Reversed property

Label::SetTextComponentJustificationOverride method

Label::SetTextComponentOverride method

Label::StyleId property

Label::StyleName property

LabelAtEndOffset

LabelAtEndStation

LabelAtStartOffset

LabelAtStartStation

LabelBase class

about LabelBase class

LabelBase::AllowsAnchorMarker property

LabelBase::AllowsDimensionAnchors property

LabelBase::AllowsDragging property

LabelBase::AllowsFlipping property

LabelBase::AllowsLeaderAttachment property

LabelBase::AllowsPinning property

LabelBase::AllowsReversing property

LabelBase::AutoStagger property

LabelBase::DefaultDimensionAnchorOption property

LabelBase::DefaultDimensionAnchorValue property

LabelBase::FeatureId property

LabelBase::Mask property

LabelBase::ViewId property

LabelDisplayStyleModel

LabelDisplayStylePlan

LabelGroup class

about LabelGroup class

LabelGroup::DescriptiveText property

LabelGroup::GetAt method

LabelGroup::IsGroupLabelType property

LabelGroup::LabelType property

LabelGroup::ResetAllSubCommonLabelLocations method

LabelGroup::ResetAllSubCommonLabelProperties method

LabelGroup::ResetAllSubCommonLabels method

LabelGroup::StyleId property

LabelGroup::StyleName property

LabelGroup::SubEntities property

LabelGroup::SubEntityCount property

LabelGroupSubEntity class

about LabelGroupSubEntity class

LabelGroupSubEntity::AllowsAnchorMarker property

LabelGroupSubEntity::AllowsDimensionAnchors property

LabelGroupSubEntity::AllowsDragging property

LabelGroupSubEntity::AllowsFlipping property

LabelGroupSubEntity::AllowsLeaderAttachment property

LabelGroupSubEntity::AllowsPinning property

LabelGroupSubEntity::AllowsReversing property

LabelGroupSubEntity::AnchorInfo property

LabelGroupSubEntity::AnchorMarkerStyleId property

LabelGroupSubEntity::ClearAllTextComponentOverrides method

LabelGroupSubEntity::DefaultDimensionAnchorOption property

LabelGroupSubEntity::DefaultDimensionAnchorValue property

LabelGroupSubEntity::DimensionAnchorInfo property

LabelGroupSubEntity::DimensionAnchorOption property

LabelGroupSubEntity::DimensionAnchorValue property

LabelGroupSubEntity::Dragged property

LabelGroupSubEntity::DraggedOffset property

LabelGroupSubEntity::Flipped property

LabelGroupSubEntity::GetTextComponentIds method

LabelGroupSubEntity::GetTextComponentJustificationOverride method

LabelGroupSubEntity::GetTextComponentOverride method

LabelGroupSubEntity::Index property

LabelGroupSubEntity::IsTextComponentOverriden method

LabelGroupSubEntity::LeaderAttachment property

LabelGroupSubEntity::LeaderTailVisibility property

LabelGroupSubEntity::LeaderVisibility property

LabelGroupSubEntity::Parent property

LabelGroupSubEntity::Pinned property

LabelGroupSubEntity::Reset method

LabelGroupSubEntity::ResetLocation method

LabelGroupSubEntity::ResetProperties method

LabelGroupSubEntity::Reversed property

LabelGroupSubEntity::SetTextComponentJustificationOverride method

LabelGroupSubEntity::SetTextComponentOverride method

LabelGroupSubEntity::StyleId property

LabelGroupSubEntity::Visibility property

Labeling

LabelingDirection

LabelLocation enumeration member

LabelMask

LabelNewParts

Labels enumeration member

LabelsAlongTransitionSegment enumeration member

LabelsAtCenterline enumeration member

LabelsAtFullSuper enumeration member

LabelsAtGradeBreaks enumeration member

LabelsAtHGP enumeration member

LabelsAtIncrementalDistance enumeration member

LabelsAtLevelCrown enumeration member

LabelsAtMajorOffsets enumeration member

LabelsAtMinorOffsets enumeration member

LabelsAtNormalCrown enumeration member

LabelsAtReverseCrown enumeration member

LabelsAtSampleLineVertices enumeration member

LabelsAtShoulderBreakOver enumeration member

LabelsAtStationEquations enumeration member

LabelsAtStructureLocation enumeration member

LabelsAtVGP enumeration member

LabelSetStyles

LabelSetStylesRoot class

about LabelSetStylesRoot class

LabelSetStylesRoot::AlignmentLabelSetStyles property

LabelSetStylesRoot::ProfileLabelSetStyles property

LabelSetStylesRoot::SectionLabelSetStyles property

LabelsForPipe enumeration member

LabelStyle class

about LabelStyle class

LabelStyle::AddChild method

LabelStyle::AddComponent method

LabelStyle::AddReferenceTextComponent method

LabelStyle::AddTextForEachComponent method

LabelStyle::ChildrenCount property

LabelStyle::default property

LabelStyle::GetComponents method

LabelStyle::GetComponentsCount method

LabelStyle::GetComponentsDrawOrder method

LabelStyle::IsSupportedComponent method

LabelStyle::ParentLabelStyleId property

LabelStyle::Properties property

LabelStyle::RemoveAllDescendants method

LabelStyle::RemoveChild method

LabelStyle::RemoveComponent method

LabelStyle::SetComponentsDrawOrder method

LabelStyle::SwitchComponentsDrawOrder method

LabelStyleBase class

about LabelStyleBase class

LabelStyleBase::BaseBehavior class

about LabelStyleBase::BaseBehavior class

LabelStyleBase::BaseBehavior::InsertOption property

LabelStyleBase::BaseBehavior::InsideCurveOption property

LabelStyleBase::BaseBehavior::OrientationReference property

LabelStyleBase::BaseDraggedStateComponents class

about LabelStyleBase::BaseDraggedStateComponents class

LabelStyleBase::BaseDraggedStateComponents::BorderType property

LabelStyleBase::BaseDraggedStateComponents::BorderVisibility property

LabelStyleBase::BaseDraggedStateComponents::Color property

LabelStyleBase::BaseDraggedStateComponents::DisplayType property

LabelStyleBase::BaseDraggedStateComponents::Gap property

LabelStyleBase::BaseDraggedStateComponents::LeaderAttachment property

LabelStyleBase::BaseDraggedStateComponents::LeaderJustification property

LabelStyleBase::BaseDraggedStateComponents::Linetype property

LabelStyleBase::BaseDraggedStateComponents::Lineweight property

LabelStyleBase::BaseDraggedStateComponents::TextHeight property

LabelStyleBase::BaseDraggedStateComponents::UseBackgroundMask property

LabelStyleBase::BaseLabel class

about LabelStyleBase::BaseLabel class

LabelStyleBase::BaseLabel::DisplayMode property

LabelStyleBase::BaseLabel::Layer property

LabelStyleBase::BaseLabel::TextStyle property

LabelStyleBase::BaseLabel::Visibility property

LabelStyleBase::BaseLeader class

about LabelStyleBase::BaseLeader class

LabelStyleBase::BaseLeader::ArrowheadSize property

LabelStyleBase::BaseLeader::ArrowheadStyle property

LabelStyleBase::BaseLeader::Color property

LabelStyleBase::BaseLeader::Linetype property

LabelStyleBase::BaseLeader::Lineweight property

LabelStyleBase::BaseLeader::Shape property

LabelStyleBase::BaseLeader::Visibility property

LabelStyleBase::BasePlanReadability class

about LabelStyleBase::BasePlanReadability class

LabelStyleBase::BasePlanReadability::FlipAnchorsWithText property

LabelStyleBase::BasePlanReadability::PlanReadable property

LabelStyleBase::BasePlanReadability::PlanReadableBias property

LabelStyleBase::Behavior property

LabelStyleBase::DraggedStateComponents property

LabelStyleBase::Label property

LabelStyleBase::Leader property

LabelStyleBase::PlanReadability property

LabelStyleBlockComponent::StyleBlock class

about LabelStyleBlockComponent::StyleBlock class

LabelStyleBlockComponent::StyleBlock::Attachment property

LabelStyleBlockComponent::StyleBlock::BlockHeight property

LabelStyleBlockComponent::StyleBlock::BlockName property

LabelStyleBlockComponent::StyleBlock::Color property

LabelStyleBlockComponent::StyleBlock::Linetype property

LabelStyleBlockComponent::StyleBlock::Lineweight property

LabelStyleBlockComponent::StyleBlock::RotationAngle property

LabelStyleBlockComponent::StyleBlock::XOffset property

LabelStyleBlockComponent::StyleBlock::YOffset property

LabelStyleBlockComponent::StyleGeneral class

about LabelStyleBlockComponent::StyleGeneral class

LabelStyleBlockComponent::StyleGeneral::AnchorComponent property

LabelStyleBlockComponent::StyleGeneral::AnchorLocation property

LabelStyleBlockComponent::StyleGeneral::AnchorPoint property

LabelStyleBlockComponent::StyleGeneral::Name property

LabelStyleBlockComponent::StyleGeneral::UsedIn property

LabelStyleBlockComponent::StyleGeneral::Visible property

LabelStyleCollection class

about LabelStyleCollection class

LabelStyleCollection::Add method

LabelStyleCollection::DefaultLabelStyle property

LabelStyleCollection::Expressions property

LabelStyleCollection::Remove method

LabelStyleDefault::DefaultBehavior class

about LabelStyleDefault::DefaultBehavior class

LabelStyleDefault::DefaultBehavior::InsertOption property

LabelStyleDefault::DefaultBehavior::InsideCurveOption property

LabelStyleDefault::DefaultBehavior::OrientationReference property

LabelStyleDefault::DefaultComponents class

about LabelStyleDefault::DefaultComponents class

LabelStyleDefault::DefaultComponents::Color property

LabelStyleDefault::DefaultComponents::Linetype property

LabelStyleDefault::DefaultComponents::Lineweight property

LabelStyleDefault::DefaultComponents::TextHeight property

LabelStyleDefault::DefaultDraggedStateComponents class

about LabelStyleDefault::DefaultDraggedStateComponents class

LabelStyleDefault::DefaultDraggedStateComponents::BorderType property

LabelStyleDefault::DefaultDraggedStateComponents::BorderVisibility property

LabelStyleDefault::DefaultDraggedStateComponents::Color property

LabelStyleDefault::DefaultDraggedStateComponents::DisplayType property

LabelStyleDefault::DefaultDraggedStateComponents::Gap property

LabelStyleDefault::DefaultDraggedStateComponents::LeaderAttachment property

LabelStyleDefault::DefaultDraggedStateComponents::LeaderJustification property

LabelStyleDefault::DefaultDraggedStateComponents::Linetype property

LabelStyleDefault::DefaultDraggedStateComponents::Lineweight property

LabelStyleDefault::DefaultDraggedStateComponents::TextHeight property

LabelStyleDefault::DefaultDraggedStateComponents::UseBackgroundMask property

LabelStyleDefault::DefaultLabel class

about LabelStyleDefault::DefaultLabel class

LabelStyleDefault::DefaultLabel::Layer property

LabelStyleDefault::DefaultLabel::TextStyle property

LabelStyleDefault::DefaultLabel::Visibility property

LabelStyleDefault::DefaultLeader class

about LabelStyleDefault::DefaultLeader class

LabelStyleDefault::DefaultLeader::ArrowheadSize property

LabelStyleDefault::DefaultLeader::ArrowheadStyle property

LabelStyleDefault::DefaultLeader::Color property

LabelStyleDefault::DefaultLeader::Linetype property

LabelStyleDefault::DefaultLeader::Lineweight property

LabelStyleDefault::DefaultLeader::Shape property

LabelStyleDefault::DefaultLeader::Visibility property

LabelStyleDefault::DefaultPlanReadability class

about LabelStyleDefault::DefaultPlanReadability class

LabelStyleDefault::DefaultPlanReadability::FlipAnchorsWithText property

LabelStyleDefault::DefaultPlanReadability::PlanReadable property

LabelStyleDefault::DefaultPlanReadability::PlanReadableBias property

LabelStyleDirectionArrowComponent::StyleDirectionArrow class

about LabelStyleDirectionArrowComponent::StyleDirectionArrow class

LabelStyleDirectionArrowComponent::StyleDirectionArrow::ArrowheadSize property

LabelStyleDirectionArrowComponent::StyleDirectionArrow::ArrowheadStyle property

LabelStyleDirectionArrowComponent::StyleDirectionArrow::Color property

LabelStyleDirectionArrowComponent::StyleDirectionArrow::FixedLength property

LabelStyleDirectionArrowComponent::StyleDirectionArrow::LengthOrMinimumLength property

LabelStyleDirectionArrowComponent::StyleDirectionArrow::Linetype property

LabelStyleDirectionArrowComponent::StyleDirectionArrow::Lineweight property

LabelStyleDirectionArrowComponent::StyleDirectionArrow::RotationAngle property

LabelStyleDirectionArrowComponent::StyleDirectionArrow::XOffset property

LabelStyleDirectionArrowComponent::StyleDirectionArrow::YOffset property

LabelStyleDirectionArrowComponent::StyleGeneral class

about LabelStyleDirectionArrowComponent::StyleGeneral class

LabelStyleDirectionArrowComponent::StyleGeneral::AnchorComponent property

LabelStyleDirectionArrowComponent::StyleGeneral::AnchorLocation property

LabelStyleDirectionArrowComponent::StyleGeneral::AnchorPoint property

LabelStyleDirectionArrowComponent::StyleGeneral::Name property

LabelStyleDirectionArrowComponent::StyleGeneral::SpanOutsideSegments property

LabelStyleDirectionArrowComponent::StyleGeneral::UsedIn property

LabelStyleDirectionArrowComponent::StyleGeneral::Visible property

LabelStyleId

LabelStyleLineComponent::StyleGeneral class

about LabelStyleLineComponent::StyleGeneral class

LabelStyleLineComponent::StyleGeneral::EndAnchorPoint property

LabelStyleLineComponent::StyleGeneral::EndPointAnchorComponent property

LabelStyleLineComponent::StyleGeneral::EndPointAnchorPoint property

LabelStyleLineComponent::StyleGeneral::Name property

LabelStyleLineComponent::StyleGeneral::StartAnchorPoint property

LabelStyleLineComponent::StyleGeneral::StartPointAnchorComponent property

LabelStyleLineComponent::StyleGeneral::StartPointAnchorPoint property

LabelStyleLineComponent::StyleGeneral::UsedIn property

LabelStyleLineComponent::StyleGeneral::UseEndPointAnchor property

LabelStyleLineComponent::StyleGeneral::Visible property

LabelStyleLineComponent::StyleLine class

about LabelStyleLineComponent::StyleLine class

LabelStyleLineComponent::StyleLine::Angle property

LabelStyleLineComponent::StyleLine::Color property

LabelStyleLineComponent::StyleLine::EndPointXOffset property

LabelStyleLineComponent::StyleLine::EndPointYOffset property

LabelStyleLineComponent::StyleLine::Length property

LabelStyleLineComponent::StyleLine::Linetype property

LabelStyleLineComponent::StyleLine::Lineweight property

LabelStyleLineComponent::StyleLine::StartPointXOffset property

LabelStyleLineComponent::StyleLine::StartPointYOffset property

LabelStyleName

LabelStyles

LabelStylesAlignmentRoot class

about LabelStylesAlignmentRoot class

LabelStylesAlignmentRoot::CurveLabelStyles property

LabelStylesAlignmentRoot::DesignSpeedLabelStyles property

LabelStylesAlignmentRoot::GeometryPointLabelStyles property

LabelStylesAlignmentRoot::LineLabelStyles property

LabelStylesAlignmentRoot::MajorStationLabelStyles property

LabelStylesAlignmentRoot::MinorStationLabelStyles property

LabelStylesAlignmentRoot::SpiralLabelStyles property

LabelStylesAlignmentRoot::StationEquationLabelStyles property

LabelStylesAlignmentRoot::StationOffsetLabelStyles property

LabelStylesAlignmentRoot::SuperelevationCriticalPointsLabelStyles property

LabelStylesAlignmentRoot::TangentIntersectionLabelStyles property

LabelStylesAlignmentRoot::VerticalGeometryPointLabelStyles property

LabelStylesIntersectionRoot class

about LabelStylesIntersectionRoot class

LabelStylesIntersectionRoot::LocationLabelStyles property

LabelStylesMatchLineRoot class

about LabelStylesMatchLineRoot class

LabelStylesMatchLineRoot::LeftLabelStyles property

LabelStylesMatchLineRoot::RightLabelStyles property

LabelStylesNode class

about LabelStylesNode class

LabelStylesNode::DefaultLabelStyle property

LabelStylesPipeRoot class

about LabelStylesPipeRoot class

LabelStylesPipeRoot::CrossSectionLabelStyles property

LabelStylesPipeRoot::PlanProfileLabelStyles property

LabelStylesProfileRoot class

about LabelStylesProfileRoot class

LabelStylesProfileRoot::CurveLabelStyles property

LabelStylesProfileRoot::GradeBreadLabelStyles property

LabelStylesProfileRoot::GradeBreakLabelStyles property

LabelStylesProfileRoot::HorizontalGeometryPointLabelStyles property

LabelStylesProfileRoot::LineLabelStyles property

LabelStylesProfileRoot::MajorStationLabelStyles property

LabelStylesProfileRoot::MinorStationLabelStyles property

LabelStylesRoot class

about LabelStylesRoot class

LabelStylesRoot::AlignmentLabelStyles property

LabelStylesRoot::GeneralCurveLabelStyles property

LabelStylesRoot::GeneralLineLabelStyles property

LabelStylesRoot::GeneralLinkLabelStyles property

LabelStylesRoot::GeneralMarkerLabelStyles property

LabelStylesRoot::GeneralNoteLabelStyles property

LabelStylesRoot::GeneralShapeLabelStyles property

LabelStylesRoot::IntersectionLabelStyles property

LabelStylesRoot::MatchLineLabelStyles property

LabelStylesRoot::ParcelLabelStyles property

LabelStylesRoot::PipeLabelStyles property

LabelStylesRoot::PointLabelStyles property

LabelStylesRoot::ProfileLabelStyles property

LabelStylesRoot::ProfileViewLabelStyles property

LabelStylesRoot::ProjectionLabelStyles property

LabelStylesRoot::SampleLineLabelStyles property

LabelStylesRoot::SectionLabelStyles property

LabelStylesRoot::SectionViewLabelStyles property

LabelStylesRoot::StructureLabelStyles property

LabelStylesRoot::SurfaceLabelStyles property

LabelStylesRoot::ViewFrameLabelStyles property

LabelStylesStructureRoot class

about LabelStylesStructureRoot class

LabelStylesStructureRoot::LabelStyles property

LabelStyleTextComponent class

about LabelStyleTextComponent class

LabelStyleTextComponent::Border property

LabelStyleTextComponent::General property

LabelStyleTextComponent::StyleBorder class

about LabelStyleTextComponent::StyleBorder class

LabelStyleTextComponent::StyleBorder::BackgroundMask property

LabelStyleTextComponent::StyleBorder::BorderType property

LabelStyleTextComponent::StyleBorder::Color property

LabelStyleTextComponent::StyleBorder::Gap property

LabelStyleTextComponent::StyleBorder::Linetype property

LabelStyleTextComponent::StyleBorder::Lineweight property

LabelStyleTextComponent::StyleBorder::Visible property

LabelStyleTextComponent::StyleGeneral class

about LabelStyleTextComponent::StyleGeneral class

LabelStyleTextComponent::StyleGeneral::AnchorComponent property

LabelStyleTextComponent::StyleGeneral::AnchorLocation property

LabelStyleTextComponent::StyleGeneral::AnchorPoint property

LabelStyleTextComponent::StyleGeneral::Name property

LabelStyleTextComponent::StyleGeneral::SpanOutsideSegments property

LabelStyleTextComponent::StyleGeneral::UsedIn property

LabelStyleTextComponent::StyleGeneral::Visible property

LabelStyleTextComponent::StyleText class

about LabelStyleTextComponent::StyleText class

LabelStyleTextComponent::StyleText::Angle property

LabelStyleTextComponent::StyleText::Attachment property

LabelStyleTextComponent::StyleText::Color property

LabelStyleTextComponent::StyleText::Contents property

LabelStyleTextComponent::StyleText::Height property

LabelStyleTextComponent::StyleText::Lineweight property

LabelStyleTextComponent::StyleText::XOffset property

LabelStyleTextComponent::StyleText::YOffset property

LabelStyleTextComponent::Text property

LabelStyleTickComponent::StyleGeneral class

about LabelStyleTickComponent::StyleGeneral class

LabelStyleTickComponent::StyleGeneral::Name property

LabelStyleTickComponent::StyleGeneral::Visible property

LabelStyleTickComponent::StyleTick class

about LabelStyleTickComponent::StyleTick class

LabelStyleTickComponent::StyleTick::AlignWithObject property

LabelStyleTickComponent::StyleTick::BlockHeight property

LabelStyleTickComponent::StyleTick::BlockName property

LabelStyleTickComponent::StyleTick::Color property

LabelStyleTickComponent::StyleTick::Linetype property

LabelStyleTickComponent::StyleTick::Lineweight property

LabelStyleTickComponent::StyleTick::RotationAngle property

LabelStyleType

LabelTag enumeration member

LabelText

LabelType

Land enumeration member

LandXMLSettings

Last enumeration member

LastEntity

LastPipeElevation

LastSplitViewStyle

Latitude enumeration member

LatLong

LatLong enumeration member

Layer

LayerForHatch

LayerId

LayerName

LayerSetting

LayerSetting enumeration member

Layout

Layout enumeration member

LayoutModeDisplayType

Leader

LeaderAttachment

LeaderBottomOfBottomLine enumeration member

LeaderJustification

LeaderMiddle enumeration member

LeaderMiddleOfBottomLine enumeration member

LeaderMiddleOfTopLine enumeration member

LeaderTailVisibility

LeaderTopOfTopLine enumeration member

LeaderVisibility

Left enumeration member

LeftAxis

LeftAxis enumeration member

LeftAxisAnnotationMajor enumeration member

LeftAxisAnnotationMinor enumeration member

LeftAxisTicksMajor enumeration member

LeftAxisTicksMinor enumeration member

LeftAxisTitle enumeration member

LeftEdge enumeration member

LeftLabelStyles

LeftOfBand enumeration member

LeftSideOfTheRoad enumeration member

LeftSwathWidth

LeftToRight enumeration member

LegendStyleId

LegendStyleName

LegendTable class

about LegendTable class

Length

Length enumeration member

Length2D

Length2DCenterToCenter

Length2DToInsideEdge

Length3D

Length3DCenterToCenter

Length3DToInsideEdge

LengthComputeType

LengthFactor

LengthMidBandBottom enumeration member

LengthMidBandMiddle enumeration member

LengthMidBandTop enumeration member

LengthOfCurve1

LengthOfCurve3

LengthOrMinimumLength

LengthToExtendAlongIncomingLane

LengthToExtendAlongOutgoingLane

LengthType

Level enumeration member

LevelCrown enumeration member

LevelCrownLabelStyleId

LevelCrownTickStyle

LimitFeatureSelectionToCurrentGroup

LimitToAlignmentStation

Line enumeration member

Linear enumeration member

LinearTransitionType

LineBeginning enumeration member

LineCurveIntersectPointMarkerStyle

LineDesignChecks

LineEnd enumeration member

LineExtension enumeration member

LineExtensions enumeration member

LineLabel

LineLabelStyle

LineLabelStyles

LineLeftInsidePavement enumeration member

LineLeftInsideShoulder enumeration member

LineLeftOutsidePavement enumeration member

LineLeftOutsideShoulder enumeration member

LineMarkerDisplayStyleSection

LinePipeSchematic enumeration member

LineRightInsidePavement enumeration member

LineRightInsideShoulder enumeration member

LineRightOutsidePavement enumeration member

LineRightOutsideShoulder enumeration member

Lines enumeration member

LinesDisplayStylePlan

LinesIncrement

LineSpiral enumeration member

LineSpiralIntersectPointMarkerStyle

LinesStartingNumber

Linetype

Lineweight

LineWeight

LineWeight enumeration member

Link class

about Link class

Link::Codes property

Link::Index property

Link::IsHidden property

Link::Points property

LinkCodes

LinkCollection class

about LinkCollection class

LinkCollection::Add method

LinkCollection::Count property

LinkCollection::default property

LinkCollection::GetEnumerator method

LinkCollection::GetObjectEnumerator method

LinkCollection::Remove method

LinkCreation

LinkDisplayStyleModel

LinkDisplayStylePlan

Links

LinksByCode

LinkStyle class

about LinkStyle class

LinkStyle::GetDisplayStyleModel method

LinkStyle::GetDisplayStylePlan method

LinkStyle::GetDisplayStyleSection method

LinkStyle::GetLinkDisplayStyleModel method

LinkStyle::GetLinkDisplayStylePlan method

LinkStyle::LinkDisplayStyleModel property

LinkStyle::LinkDisplayStylePlan property

LinkStyle::StyleType property

LinkStyleCollection class

about LinkStyleCollection class

LinkStyleCollection::Add method

LinkStyles

LinkType enumeration member

Local enumeration member

LocalCoordinates

LocalReferencePoint

LocalRotationPoint

Location

LocationLabelStyles

Locked

LockTostation

LogicalNameNotFound enumeration member

Long enumeration member

Longitude enumeration member

LongLat enumeration member

LongName enumeration member

LongNameSpaced enumeration member

LongTangent

Lower enumeration member

LowerCase enumeration member

LowerLeft enumeration member

LowerRight enumeration member

LowestElevation enumeration member

LowPoint enumeration member

LowPointMarkerStyle

LowShoulderMatch enumeration member

M

M

MacroOrClassName

MainBaseline enumeration member

MainBaselineFeatureLines

MainBaselineStationToOffsetBaselineStation

MaintainViewOrientation

Major enumeration member

MajorColor

MajorContour enumeration member

MajorContourColorScheme

MajorContourInterval

MajorHorizontalGrid enumeration member

MajorIncrementLabelStyleId

MajorIncrementTickStyle

MajorInterval

MajorLineTypeId

MajorLineWight

MajorStationLabel enumeration member

MajorStationLabelGroup

MajorStationLabelStyles

MajorTicks enumeration member

MajorTickStyle

MajorVerticalGrid enumeration member

Manual enumeration member

ManuallyCreation enumeration member

Map enumeration member

Mapcheck

Mapcheck enumeration member

MapcheckColor

Marker

Marker enumeration member

MarkerDisplayStyleModel

MarkerDisplayStylePlan

MarkerDisplayStyleProfile

MarkerDisplayStyleSection

MarkerFixedScale

MarkerFixedScale enumeration member

MarkerRotationAngle

MarkerRotationAngle enumeration member

MarkerSize

MarkerSize enumeration member

MarkerStyle

MarkerStyle class

about MarkerStyle class

MarkerStyle::GetMarkerDisplayStyleProfile method

MarkerStyle::GetMarkerDisplayStyleSection method

MarkerStyle::MarkerDisplayStyleProfile property

MarkerStyle::MarkerDisplayStyleSection property

MarkerStyle::MarkerType property

MarkerStyleAtAssemblyOriginId

MarkerStyleAtMainBaselineId

MarkerStyleAtMainBaselineOriginId

MarkerStyleAtOffsetBaselineId

MarkerStyleAtOffsetBaselineOriginId

MarkerStyleBase class

about MarkerStyleBase class

MarkerStyleBase::CustomMarkerStyle property

MarkerStyleBase::CustomMarkerSuperimposeStyle property

MarkerStyleBase::GetMarkerDisplayStyleModel method

MarkerStyleBase::GetMarkerDisplayStylePlan method

MarkerStyleBase::MarkerDisplayStyleModel property

MarkerStyleBase::MarkerDisplayStylePlan property

MarkerStyleBase::MarkerFixedScale property

MarkerStyleBase::MarkerRotationAngle property

MarkerStyleBase::MarkerSize property

MarkerStyleBase::MarkerSymbolName property

MarkerStyleBase::Orientation property

MarkerStyleBase::SizeType property

MarkerStyleCollection class

about MarkerStyleCollection class

MarkerStyleCollection::Add method

MarkerStyleId

MarkerStyleName

MarkerStyles

MarkerSymbolName

MarkerSymbolName enumeration member

MarkerType

MarkerType enumeration member

Mask

MaskConnectedObjects

MaskConnectedObjects enumeration member

MaskNames

Masks

MassHaulCreation

MassHaulLine

MassHaulLine class

about MassHaulLine class

MassHaulLine enumeration member

MassHaulLineId

MassHaulLineStyle class

about MassHaulLineStyle class

MassHaulLineStyle::FreeHaulOption property

MassHaulLineStyle::GetDisplayStyleProfile method

MassHaulLineStyle::GetHatchDisplayStyleProfile method

MassHaulLineStyleCollection class

about MassHaulLineStyleCollection class

MassHaulLineStyleCollection::Add method

MassHaulLineStyles

MassHaulView

MassHaulView class

about MassHaulView class

MassHaulView enumeration member

MassHaulView::MassHaulLineId property

MassHaulViewStyle class

about MassHaulViewStyle class

MassHaulViewStyle::BottomAxis property

MassHaulViewStyle::GetDisplayStylePlan method

MassHaulViewStyle::GraphStyle property

MassHaulViewStyle::GridStyle property

MassHaulViewStyle::LeftAxis property

MassHaulViewStyle::MiddleAxis property

MassHaulViewStyle::RightAxis property

MassHaulViewStyle::TopAxis property

MassHaulViewStyleCollection class

about MassHaulViewStyleCollection class

MassHaulViewStyleCollection::Add method

MassHaulViewStyles

MatchAutoCADVariables

MatchChannelShapedPipesWith

MatchCircularPipesWith

MatchCircularStructuresWith

MatchConnectionStructuresWith

MatchEggShapedPipesWith

MatchEllipticalShapedPipesWith

MatchIncrement

MatchInletOutletStructuresWith

MatchLaneSlope enumeration member

MatchLine

MatchLine class

about MatchLine class

MatchLine enumeration member

MatchLine::GroupId property

MatchLineLabeling enumeration member

MatchLineLabelLeft

MatchLineLabelRight

MatchLineLabelStyles

MatchLineLeft enumeration member

MatchLineLeftLabelLocation

MatchLineMaskDisplayStylePlan

MatchLineMaskHatchDisplayStyle

MatchLineRepositioning

MatchLineRepositioningValue

MatchLineRight enumeration member

MatchLineRightLabelLocation

MatchLineSnapStation

MatchLineSnapStationValue

MatchLineStyle class

about MatchLineStyle class

MatchLineStyle::GetLinesDisplayStylePlan method

MatchLineStyle::GetMatchLineMaskDisplayStylePlan method

MatchLineStyle::GetMatchLineMaskHatchDisplayStyle method

MatchLineStyle::LinesDisplayStylePlan property

MatchLineStyle::MatchLineMaskDisplayStylePlan property

MatchLineStyle::MatchLineMaskHatchDisplayStyle property

MatchLineStyles

MatchOnDescriptionParameters

MatchRectangleShapedPipesWith

MatchRectangleStructuresWith

Material

Material enumeration member

MaterialAreaFillStyleId

MaterialAreaFillStyleName

MaterialList

MaterialName

MaterialSection class

about MaterialSection class

MaterialSection enumeration member

MaterialShape

MaterialStyleId

MaterialTable enumeration member

MaterialVolumeTableStyle

MaximumChangeInElevation

MaximumCover

MaximumDepth

MaximumDistance

MaximumGrade

MaximumGradeChange

MaximumInColumn

MaximumInRow

MaximumLength

MaximumNumberOfRows

MaximumTablesPerStack

MaximumTriangleLength

MaximumTriangleSideLength

MeanElevation enumeration member

MeasurementType

Merge enumeration member

MergeToNeighborRegion

Meter enumeration member

MeterPerSec enumeration member

MeterPerSecSquared enumeration member

Meters enumeration member

Metric

Middle enumeration member

MiddleAxis

MiddleAxis enumeration member

MiddleAxisAnnotationHGP enumeration member

MiddleAxisAnnotationMajor enumeration member

MiddleAxisAnnotationMinor enumeration member

MiddleAxisTicksHGP enumeration member

MiddleAxisTicksMajor enumeration member

MiddleAxisTicksMinor enumeration member

MiddleAxisTitle enumeration member

MiddleCenter enumeration member

MiddleExtension enumeration member

MiddleLeft enumeration member

MiddleOrCenter enumeration member

MiddleOrdinate enumeration member

MiddleRight enumeration member

MiddleSize enumeration member

MiddleStackViewStyle

MidOrdinate

MidOrdinateDistance

MidOrdinateTolerance

MidPoint

MidPointMarkerStyle

Mile enumeration member

MilePerHour enumeration member

Millimeter enumeration member

MilliMeter enumeration member

MinCurveRadius enumeration member

MinDisplayLength

MinElevation enumeration member

MinimumArea

MinimumCover

MinimumDepth

MinimumDepthColor

MinimumDisplayWidth

MinimumDistance

MinimumFrontage

MinimumFrontageColor

MinimumKValueHSD

MinimumKValuePSD

MinimumKValueSSD

MinimumNumberOfSegments

MinimumRadius

MinimumTransitionLength

MinimumWidth

MinimumWidthColor

Minor enumeration member

MinorColor

MinorContour enumeration member

MinorContourColorScheme

MinorContourInterval

MinorHorizontalGrid enumeration member

MinorIncrementLabelStyleId

MinorIncrementTickStyle

MinorInterval

MinorLineTypeId

MinorLineWight

MinorStationLabel enumeration member

MinorStationLabelStyles

MinorTicks enumeration member

MinorTickStyle

MinorVerticalGrid enumeration member

MinusSign enumeration member

MinuteSecond enumeration member

MinuteSecondSpaced enumeration member

Miscellaneous

Mode

ModelOption

ModelOptions

ModelPartId

ModelSizeOptions

ModelSizeType

ModelViewOptions

ModifiedBy

Modifier

ModifierValue

MoveCriteria

Multiple enumeration member

MultipleBoundaryArea

MultipleBoundaryAreaShapeStyle

MultipleProfileViewCreation

MultipleSectionViewCreation

MultipleValueDirection enumeration member

MultipleValuePosition enumeration member

MultiViewBlockDirection

MultiViewBlockDisplayOptions

MultiViewBlockDisplayRepresentationId

MultiViewBlockDisplayRepresentationName

MultiViewBlockMarkerStyleId

MultiViewBlockMarkerStyleName

MultiViewBlockSymbolBlockId

MultiViewBlockSymbolBlockName

MvBlockProfile enumeration member

MvBlockSection enumeration member

N

Name

NameFormat

NameTemplate

NativeEntity enumeration member

Nearest enumeration member

Negative enumeration member

Network

Network class

about Network class

Network::AddCurvePipe method

Network::AddLinePipe method

Network::AddStructure method

Network::BreakPipe method

Network::Create method

Network::FindShortestNetworkPath method

Network::GetPipeIds method

Network::GetSpanningPipePlanLabelIds method

Network::GetSpanningPipeProfileLabelIds method

Network::GetStructureIds method

Network::PartsListId property

Network::PartsListName property

Network::PipeNameTemplate property

Network::PipeNetworkSectionLayerId property

Network::PipeNetworkSectionLayerName property

Network::PipePlanLabelStyleId property

Network::PipePlanLabelStyleName property

Network::PipePlanLayerId property

Network::PipePlanLayerName property

Network::PipeProfileLabelStyleId property

Network::PipeProfileLabelStyleName property

Network::PipeProfileLayerId property

Network::PipeProfileLayerName property

Network::ReferenceAlignmentId property

Network::ReferenceAlignmentName property

Network::ReferenceSurfaceId property

Network::ReferenceSurfaceName property

Network::StructureNameTemplate property

Network::StructurePlanLabelStyleId property

Network::StructurePlanLabelStyleName property

Network::StructurePlanLayerId property

Network::StructurePlanLayerName property

Network::StructureProfileLabelStyleId property

Network::StructureProfileLabelStyleName property

Network::StructureProfileLayerId property

Network::StructureProfileLayerName property

Network1Id

Network2Id

NetworkCatalogDef class

about NetworkCatalogDef class

NetworkCatalogDef::DeclareNewParameter method

NetworkCatalogDef::DeclarePartProperty method

NetworkId

NetworkName

NetworkRule class

about NetworkRule class

NetworkRule::ParamsDouble property

NetworkRule::ParamsLong property

NetworkRuleSetStyle class

about NetworkRuleSetStyle class

NetworkRuleSetStyle::CloneAndAddRule method

NetworkRuleSetStyle::GetRuleIds method

NetworkRuleSetStyle::RemoveAllRules method

NetworkRuleSetStyle::RemoveRule method

NetworkRuleSetStyle::RulesCount property

NetworkState

NewEntityToolTipState

NewParcelColor

NextOffsetBandBottom enumeration member

NextOffsetBandMiddle enumeration member

NextOffsetBandTop enumeration member

NextStationBandBottom enumeration member

NextStationBandMiddle enumeration member

NextStationBandTop enumeration member

NextSubEntEndAndPassPt enumeration member

NextSubEntPassPtAndParameter enumeration member

NextSubEntPassPtWithGrade enumeration member

NLayoutsPerNewDrawing enumeration member

No enumeration member

NoCodeItemType enumeration member

NoConstraint enumeration member

NoConstraints enumeration member

NoLinkIntersectFound enumeration member

NoMarkedPointFound enumeration member

NominalWidth

NonDestructive

NondestructivePointsColor

NondestructivePointsSymbol

None enumeration member

NonNegativeDouble enumeration member

NonNegativeLong enumeration member

NonNegativeNonZeroDouble enumeration member

NonNegativeNonZeroLong enumeration member

NonPositiveDouble enumeration member

NonPositiveLong enumeration member

NonPositiveNonZeroDouble enumeration member

NonPositiveNonZeroLong enumeration member

NonZeroDouble enumeration member

NonZeroLong enumeration member

Normal enumeration member

NormalCrownLabelStyleId

NormalCrownTickStyle

NormalItemType enumeration member

NormalLaneSlope

NormalShoulderSlope

NormalToBaseline

NormalToSubassembly

NormalWithArrowhead enumeration member

Norminal enumeration member

NorthArrowBlockName

NorthAzimuth enumeration member

Northeast enumeration member

Northing

NorthingEasting enumeration member

Northwest enumeration member

NoSideslopeIntersectFound enumeration member

NoSubgradeIntersectFound enumeration member

Note enumeration member

NoteLabel

Notify enumeration member

NoYes enumeration member

NullElevation

NumberOfLayoutsPerDrawing

Numberoflines

NumberOfRanges

NumberOfStackedViews

O

Object enumeration member

ObjectControlledByLayer

ObjectIds

ObjectLayerSettings

ObjectOnly enumeration member

ObjectType

Oblique enumeration member

ObservePatternFillDistance

OffOn enumeration member

Offset

Offset enumeration member

OffsetAlignment

OffsetAlignmentId

OffsetAlignmentLabelSet

OffsetAlignmentNameTemplate

OffsetAlignmentOptions

OffsetBaseline class

about OffsetBaseline class

OffsetBaseline enumeration member

OffsetBaseline::AlignmentId property

OffsetBaseline::BaselineType property

OffsetBaseline::EndStation property

OffsetBaseline::EndStationOnMainBaseline property

OffsetBaseline::GetOffsetElevationFromMainBaselineStation method

OffsetBaseline::Identity nested type

OffsetBaseline::MainBaselineStationToOffsetBaselineStation method

OffsetBaseline::OffsetBaselineStationToMainBaselineStation method

OffsetBaseline::ProfileId property

OffsetBaseline::RelatedOffsetBaselineFeatureLines property

OffsetBaseline::SortedStations method

OffsetBaseline::StartStation property

OffsetBaseline::StartStationOnMainBaseline property

OffsetBaselineCollection class

about OffsetBaselineCollection class

OffsetBaselineCollection::CorridorId property

OffsetBaselineCollection::Count property

OffsetBaselineCollection::default property

OffsetBaselineCollection::GetEnumerator method

OffsetBaselineCollection::GetObjectEnumerator method

OffsetBaselineCollection::Identity nested type

OffsetBaselineCollection::OffsetBaselineNames method

OffsetBaselineFeatureLinesCol

OffsetBaselineNames

OffsetBaselineOrigin enumeration member

OffsetBaselines

OffsetBaselineStationToMainBaselineStation

OffsetDist

OffsetDist enumeration member

OffsetElevationFromMainBaseline

OffsetExtension enumeration member

OffsetFromAlignment

OffsetFromBand

OffsetLeftAlignmentId

OffsetLeftProfileId

OffsetLengthOptions

OffsetProfile

OffsetProfile enumeration member

OffsetProfileLabelSet

OffsetProfileNameTemplate

OffsetRegionColor

OffsetRegionLineweight

OffsetRightAlignmentId

OffsetRightProfileId

Offsets

OffsetTarget enumeration member

OffsetTargetPipe enumeration member

OffsetToAssembly

OffsetToBaseline

OffsetType

OffsetX

OffsetY

Omit enumeration member

OmitGridInPaddingAreas

One enumeration member

OnlySelected enumeration member

Open enumeration member

Open30 enumeration member

Open90 enumeration member

Optional enumeration member

Options

Orientation

Orientation enumeration member

OrientationReference

OrientToObject enumeration member

OrientToView enumeration member

OrientToWCS enumeration member

Origin enumeration member

Origin2 enumeration member

OriginStationOffsetElevationToBaseline

Other enumeration member

OutAlignmentId

OutCurve enumeration member

Outer enumeration member

OuterDiameter

OuterDiameter enumeration member

OuterDiameterOrWidth

OuterDiameterPercent

OuterDiameterPercent enumeration member

OuterHeight

Output enumeration member

Outside enumeration member

OutsideBoundary enumeration member

OutsideShoulderMethod

OutsideWalls enumeration member

OverallHighPoint enumeration member

OverallLowPoint enumeration member

OverHaulAreaHatch enumeration member

Override enumeration member

OverrideRuleSet

OverrideStyleId

OverrideStyleName

Overview

Overwrite enumeration member

P

P

Page enumeration member

PageLayoutId

PageMarginBottom

PageMarginLeft

PageMarginRight

PageMarginTop

ParabolaAsymmetric enumeration member

ParabolaSymmetric enumeration member

ParabolicCrestCurveKValue

ParabolicCrestCurveLength

ParabolicCrestVerticalConstraint

ParabolicCurveExtension enumeration member

ParabolicSagCurveKValue

ParabolicSagCurveLength

ParabolicSagVerticalConstraint

Param class

about Param class

ParamAlignment class

about ParamAlignment class

ParamAlignment::Access property

ParamAlignment::Comment property

ParamAlignment::Description property

ParamAlignment::DisplayName property

ParamAlignment::DisplayOrder property

ParamAlignment::IsReadOnly property

ParamAlignment::Value property

ParamAlignmentCollection class

about ParamAlignmentCollection class

ParamAlignmentCollection::Count property

ParamAlignmentCollection::default property

ParamAlignmentCollection::Value method

ParamBase template

about ParamBase template

ParamBase::Access property

ParamBase::Comment property

ParamBase::Description property

ParamBase::DisplayName property

ParamBase::DisplayOrder property

ParamBase::InnerType nested type

ParamBase::IsReadOnly property

ParamBase::TCast nested type

ParamBase::Value property

ParamBase::ValueType nested type

ParamBool class

about ParamBool class

ParamBool::Access property

ParamBool::Comment property

ParamBool::Description property

ParamBool::DisplayName property

ParamBool::DisplayOrder property

ParamBool::IsReadOnly property

ParamBool::TypeInfo property

ParamBool::Value property

ParamBoolCollection class

about ParamBoolCollection class

ParamBoolCollection::Add method

ParamBoolCollection::Count property

ParamBoolCollection::default property

ParamBoolCollection::Value method

ParamCollectionBase template

about ParamCollectionBase template

ParamCollectionBase::Count property

ParamCollectionBase::default property

ParamCollectionBase::GetEnumerator method

ParamCollectionBase::GetObjectEnumerator method

ParamCollectionBase::InnerType nested type

ParamCollectionBase::TCast nested type

ParamCollectionBase::Value method

ParamCollectionBase::ValueType nested type

ParamCount

ParamDouble class

about ParamDouble class

ParamDouble::Access property

ParamDouble::Comment property

ParamDouble::Description property

ParamDouble::DisplayName property

ParamDouble::DisplayOrder property

ParamDouble::IsReadOnly property

ParamDouble::TypeInfo property

ParamDouble::Value property

ParamDoubleCollection class

about ParamDoubleCollection class

ParamDoubleCollection::Add method

ParamDoubleCollection::Count property

ParamDoubleCollection::default property

ParamDoubleCollection::Value method

ParamElevationTarget class

about ParamElevationTarget class

ParamElevationTarget::Access property

ParamElevationTarget::Comment property

ParamElevationTarget::Description property

ParamElevationTarget::DisplayName property

ParamElevationTarget::DisplayOrder property

ParamElevationTarget::IsReadOnly property

ParamElevationTarget::Value property

ParamElevationTargetCollection class

about ParamElevationTargetCollection class

ParamElevationTargetCollection::Count property

ParamElevationTargetCollection::default property

ParamElevationTargetCollection::Value method

ParameterNotFound enumeration member

ParameterOverrideStations enumeration member

ParamLong class

about ParamLong class

ParamLong::Access property

ParamLong::AddEnumData method

ParamLong::Comment property

ParamLong::Description property

ParamLong::DisplayName property

ParamLong::DisplayOrder property

ParamLong::EnumCount method

ParamLong::GetEnumData method

ParamLong::IsReadOnly property

ParamLong::TypeInfo property

ParamLong::Value property

ParamLongCollection class

about ParamLongCollection class

ParamLongCollection::Add method

ParamLongCollection::Count property

ParamLongCollection::default property

ParamLongCollection::Value method

ParamOffsetTarget class

about ParamOffsetTarget class

ParamOffsetTarget::Access property

ParamOffsetTarget::Comment property

ParamOffsetTarget::Description property

ParamOffsetTarget::DisplayName property

ParamOffsetTarget::DisplayOrder property

ParamOffsetTarget::IsReadOnly property

ParamOffsetTarget::Value property

ParamOffsetTargetCollection class

about ParamOffsetTargetCollection class

ParamOffsetTargetCollection::Count property

ParamOffsetTargetCollection::default property

ParamOffsetTargetCollection::Value method

ParamPoint class

about ParamPoint class

ParamPoint::Access property

ParamPoint::Comment property

ParamPoint::Description property

ParamPoint::DisplayName property

ParamPoint::DisplayOrder property

ParamPoint::Elevation property

ParamPoint::GetPoint method

ParamPoint::IsReadOnly property

ParamPoint::Offset property

ParamPoint::SetPoint method

ParamPoint::Station property

ParamPoint::Value property

ParamPointCollection class

about ParamPointCollection class

ParamPointCollection::Add method

ParamPointCollection::Count property

ParamPointCollection::default property

ParamPointCollection::Value method

ParamProfile class

about ParamProfile class

ParamProfile::Access property

ParamProfile::Comment property

ParamProfile::Description property

ParamProfile::DisplayName property

ParamProfile::DisplayOrder property

ParamProfile::IsReadOnly property

ParamProfile::Value property

ParamProfileCollection class

about ParamProfileCollection class

ParamProfileCollection::Count property

ParamProfileCollection::default property

ParamProfileCollection::Value method

ParamsAlignment

ParamsAlignmentGlobal

ParamsBool

ParamsBoolGlobal

ParamsDouble

ParamsDoubleGlobal

ParamsElevationTarget

ParamsElevationTargetGlobal

ParamsLong

ParamsLongGlobal

ParamsOffsetTarget

ParamsOffsetTargetGlobal

ParamsPoint

ParamsPointGlobal

ParamsProfile

ParamsProfileGlobal

ParamsString

ParamsStringGlobal

ParamsSurface

ParamsSurfaceGlobal

ParamString class

about ParamString class

ParamString::Access property

ParamString::Comment property

ParamString::Description property

ParamString::DisplayName property

ParamString::DisplayOrder property

ParamString::IsReadOnly property

ParamString::Value property

ParamStringCollection class

about ParamStringCollection class

ParamStringCollection::Add method

ParamStringCollection::Count property

ParamStringCollection::default property

ParamStringCollection::Value method

ParamSurface class

about ParamSurface class

ParamSurface::Access property

ParamSurface::Comment property

ParamSurface::Description property

ParamSurface::DisplayName property

ParamSurface::DisplayOrder property

ParamSurface::IsReadOnly property

ParamSurface::Value property

ParamSurfaceCollection class

about ParamSurfaceCollection class

ParamSurfaceCollection::Count property

ParamSurfaceCollection::default property

ParamSurfaceCollection::Value method

Parcel

Parcel class

about Parcel class

Parcel enumeration member

ParcelAnalysis

ParcelArea enumeration member

ParcelAreaLabelStyle

ParcelAreaTableStyles

ParcelCurve enumeration member

ParcelCurveLabel

ParcelCurveNextAutomaticTagCounter

ParcelCurveNextManualTagCounter

ParcelCurveTableStyles

ParcelDirection

ParcelExport

ParcelFace enumeration member

ParcelLabeling enumeration member

ParcelLabelStyles

ParcelLine enumeration member

ParcelLineLabel

ParcelLineNextAutomaticTagCounter

ParcelLineNextManualTagCounter

ParcelLineTableStyles

ParcelNextAutomaticAreaCounter

ParcelNextManualAreaCounter

ParcelSegment class

about ParcelSegment class

ParcelSegment enumeration member

ParcelSegmentLabeling enumeration member

ParcelSegmentTable class

about ParcelSegmentTable class

ParcelSegmentTableStyles

ParcelSizing

ParcelStyle class

about ParcelStyle class

ParcelStyle::AreaFillHatchDisplayStyleModel property

ParcelStyle::AreaFillHatchDisplayStylePlan property

ParcelStyle::GetAreaFillHatchDisplayStyleModel method

ParcelStyle::GetAreaFillHatchDisplayStylePlan method

ParcelStyle::GetDisplayStyleModel method

ParcelStyle::GetDisplayStylePlan method

ParcelStyle::NameTemplate property

ParcelStyle::ObservePatternFillDistance property

ParcelStyle::PatternFillDistance property

ParcelStyles

ParcelTable class

about ParcelTable class

ParcelTable enumeration member

Parent

ParentAlignmentColor

ParentAlignmentLineweight

ParentAlignmentTrackerColor

ParentAlignmentTrackerLineweight

ParentEntityId

ParentId

ParentLabelStyleId

Part class

about Part class

Part::AddToProfileView method

Part::AddToSectionView method

Part::ConnectedPartCount property

Part::Domain property

Part::GetOverriddenRuleIds method

Part::GetProfileViewsDisplayingMe method

Part::GetSectionViewsDisplayingMe method

Part::Material property

Part::Name property

Part::NetworkId property

Part::NetworkName property

Part::OverrideRuleSet property

Part::ParamsBool property

Part::ParamsDouble property

Part::ParamsLong property

Part::ParamsString property

Part::PartData property

Part::PartDefId property

Part::PartDescription property

Part::PartSizeName property

Part::PartSubType property

Part::PartType property

Part::Position property

Part::ProfileViewPartId property

Part::RefAlignmentId property

Part::RefAlignmentName property

Part::RefSurfaceId property

Part::RefSurfaceName property

Part::RemoveFromAllProfileViews method

Part::RemoveFromAllSectionViews method

Part::RemoveFromProfileView method

Part::RemoveFromSectionView method

Part::RuleSetStyleId property

Part::RuleSetStyleName property

Part::SectionViewPartId property

Part::Solid3dBody property

Part::SurfaceId property

Part::WallThickness property

PartBodyGraphicsBlockId

PartBodyGraphicsBlockName

PartData

PartDataField class

about PartDataField class

PartDataField::Context property

PartDataField::ContextString property

PartDataField::DataType property

PartDataField::Description property

PartDataField::Index property

PartDataField::IsFromList property

PartDataField::IsFromRange property

PartDataField::IsReadOnly property

PartDataField::Name property

PartDataField::Units property

PartDataField::Value property

PartDataField::ValueList property

PartDataField::ValueRange property

PartDataList class

about PartDataList class

PartDataList::Context property

PartDataList::Count property

PartDataList::DataType property

PartDataList::default property

PartDataList::Index property

PartDataList::IsValidValue method

PartDataRange class

about PartDataRange class

PartDataRange::Context property

PartDataRange::DataType property

PartDataRange::Index property

PartDataRange::IsValidValue method

PartDataRange::RangeDefault property

PartDataRange::RangeMax property

PartDataRange::RangeMin property

PartDataRecord class

about PartDataRecord class

PartDataRecord::GetAllDataFields method

PartDataRecord::GetDataFieldBy method

PartDataRecord::GetMaxIndex method

PartDataRecord::GetSupportedContexts method

PartDef

PartDef class

about PartDef class

PartDef::Get3dBody method

PartDef::GetBoundingShapeBody method

PartDef::GetNetworkPartViewDef method

PartDef::GetProfileInFrontView method

PartDef::PartDef constructor

PartDefId

PartDefinedShape enumeration member

PartDescription

PartFamily class

about PartFamily class

PartFamily::AddPartSize method

PartFamily::BoundingShape property

PartFamily::default property

PartFamily::Description property

PartFamily::Domain property

PartFamily::GUID property

PartFamily::PartSizeCount property

PartFamily::PartSizeFilter property

PartFamily::PartType property

PartFamily::RemovePartSize method

PartFamily::SweptShape property

PartFamilyCount

PartFamilyGuid

PartMatching

PartSize class

about PartSize class

PartSize::MaterialStyleId property

PartSize::PartStyleId property

PartSize::PayItems property

PartSize::RulesStyleId property

PartSize::SizeDataRecord property

PartSizeCount

PartSizeFilter

PartSizeName

PartsList

PartsList class

about PartsList class

PartsList::AddPartFamilyByDescription method

PartsList::AddPartFamilyByGuid method

PartsList::default property

PartsList::GetAvailablePartFamilies method

PartsList::GetPartFamilyIdsByDomain method

PartsList::PartFamilyCount property

PartsList::RemovePartFamily method

PartsListCollection class

about PartsListCollection class

PartsListCollection::Add method

PartsListForPartFamilySizeMatching

PartsListId

PartsListName

PartsListSet

PartsListUsedForMigration

PartStyleId

PartSubType

PartType

PartViewDef class

about PartViewDef class

PartViewDef::BoundingBodyBlockId property

PartViewDef::BoundingBodyBlockName property

PartViewDef::PartBodyGraphicsBlockId property

PartViewDef::PartBodyGraphicsBlockName property

PassingEyeHeight

PassingObjectHeight

PassingSightDistance

PassThrough enumeration member

PassThroughDirection enumeration member

PassThroughHoldEnd enumeration member

PassThroughPoint1

PassThroughPoint2

PassThroughPoint3

PassThroughPt enumeration member

PassThroughPt1 enumeration member

PassThroughPt1AndPt2 enumeration member

PassThroughPt2 enumeration member

PassThroughRadius enumeration member

Pastels enumeration member

PathLayer

PathObjectType

PatternFillDistance

PayItems

PDMODE enumeration member

Percent enumeration member

PercentageOfPointsToRemove

PercentageOfScreen

PercentageOfScreen enumeration member

PercentLength enumeration member

PercentofLength

PercentOfLength enumeration member

PercentofLength1

PercentofLength2

Period enumeration member

PerMille enumeration member

PI enumeration member

PickPointWithinParcel enumeration member

Pinned

Pipe

Pipe class

about Pipe class

Pipe enumeration member

Pipe::Bearing property

Pipe::ConnectToPipe method

Pipe::ConnectToStructure method

Pipe::CoverOfEndpoint property

Pipe::CoverOfStartPoint property

Pipe::CrossSectionalShape property

Pipe::Disconnect method

Pipe::EndOffset property

Pipe::EndPoint property

Pipe::EndStation property

Pipe::EndStructureId property

Pipe::FlowDirection property

Pipe::FlowDirectionMethod property

Pipe::GetClosestPointTo method

Pipe::GetLabelIds method

Pipe::GetParamAtPoint method

Pipe::GetPointAtParam method

Pipe::GetProject2dPointVertically method

Pipe::HoldOnResizeType property

Pipe::InnerDiameterOrWidth property

Pipe::InnerHeight property

Pipe::IsMaxCoverViolated method

Pipe::IsMinCoverViolated method

Pipe::Length2D property

Pipe::Length2DCenterToCenter property

Pipe::Length2DToInsideEdge property

Pipe::Length3D property

Pipe::Length3DCenterToCenter property

Pipe::Length3DToInsideEdge property

Pipe::MaximumCover property

Pipe::MinimumCover property

Pipe::OuterDiameterOrWidth property

Pipe::OuterHeight property

Pipe::Radius property

Pipe::ResizeByInnerDiameterOrWidth method

Pipe::SetSlopeHoldEnd method

Pipe::SetSlopeHoldStart method

Pipe::Slope property

Pipe::StartOffset property

Pipe::StartPoint property

Pipe::StartStation property

Pipe::StartStructureId property

Pipe::SubEntityType property

PipeAll enumeration member

PipeAndStructureTable enumeration member

PipeCenterDepth

PipeCrossSection enumeration member

PipeDimension enumeration member

PipeIn enumeration member

PipeInnerBottomToBasePoint enumeration member

PipeInnerDiameter enumeration member

PipeInnerDiameterOrWidth

PipeInnerHeight enumeration member

PipeInnerWidth enumeration member

PipeInPlan

PipeInvertDepth

PipeLabeling enumeration member

PipeLabelStyleId

PipeLabelStyles

PipeLengthType

PipeLowestBottomDepth

PipeNameTemplate

PipeNetwork

PipeNetwork enumeration member

PipeNetworkBand enumeration member

PipeNetworkBandStyle class

about PipeNetworkBandStyle class

PipeNetworkBandStyle::BandType property

PipeNetworkBandStyle::GetDisplayStylePlan method

PipeNetworkBandStyle::PipeLabelStyleId property

PipeNetworkBandStyle::PipeTickStyle property

PipeNetworkBandStyle::StructureLabelStyleId property

PipeNetworkBandStyle::StructureTickStyle property

PipeNetworkBandStyle::TitleTextLabelStyleId property

PipeNetworkPart enumeration member

PipeNetworkParts

PipeNetworkPipeLocation enumeration member

PipeNetworkRule enumeration member

PipeNetworkSection enumeration member

PipeNetworkSectionLayerId

PipeNetworkSectionLayerName

PipeNetworkState class

about PipeNetworkState class

PipeNetworkState enumeration member

PipeNetworkState::CurrentPipeId property

PipeNetworkState::CurrentStructureId property

PipeNetworkState::IsBreakingPipe property

PipeNetworkState::IsConnectingToStructure property

PipeNetworkState::IsCurrentPartBeingAdd property

PipeNetworkState::IsInLayoutMode property

PipeNetworkState::IsLayoutUpStream property

PipeNetworkState::LastPipeElevation property

PipeNetworkState::ParamsBool property

PipeNetworkState::ParamsDouble property

PipeNetworkState::ParamsLong property

PipeNetworkState::RuleResourceString method

PipeNetworkState::SetAlignmentOnPart method

PipeNetworkState::SetBoolOnPart method

PipeNetworkState::SetDoubleOnCurrentPart method

PipeNetworkState::SetErrorMsgOnCurrentPart method

PipeNetworkState::SetLongOnPart method

PipeNetworkState::SetPointOnPart method

PipeNetworkState::SetProfileOnPart method

PipeNetworkState::SetStringOnPart method

PipeNetworkState::SetSurfaceOnPart method

PipeNetworkStructureLocation enumeration member

PipeOrStructureProfile enumeration member

PipeOut enumeration member

PipeOuterBottomDepth

PipeOuterTopDepth

PipePlanLabel

PipePlanLabelStyleId

PipePlanLabelStyleName

PipePlanLayerId

PipePlanLayerName

PipePlanProfile enumeration member

PipeProfile

PipeProfile enumeration member

PipeProfileLabel

PipeProfileLabelStyleId

PipeProfileLabelStyleName

PipeProfileLayerId

PipeProfileLayerName

PipeRuleSetStyle class

about PipeRuleSetStyle class

PipeRuleSetStyleCollection class

about PipeRuleSetStyleCollection class

PipeRuleSetStyleCollection::Add method

PipeRuleSetStyles

PipesAndStrucutres enumeration member

PipeSection enumeration member

PipeSectionLabel

PipesOnly enumeration member

PipeStyle class

about PipeStyle class

PipeStyle::GetDisplayStyleModel method

PipeStyle::GetDisplayStylePlan method

PipeStyle::GetDisplayStyleProfile method

PipeStyle::GetDisplayStyleSection method

PipeStyle::GetHatchStylePlan method

PipeStyle::GetHatchStyleProfile method

PipeStyle::GetHatchStyleSection method

PipeStyle::PlanOption property

PipeStyle::ProfileOption property

PipeStyle::SectionCrossingHatch property

PipeStyleCollection class

about PipeStyleCollection class

PipeStyleCollection::Add method

PipeStyleOptionBase class

about PipeStyleOptionBase class

PipeStyleOptionBase::AlignHatchToPipe property

PipeStyleOptionBase::EndLineSize property

PipeStyleOptionBase::EndLineSizePercent property

PipeStyleOptionBase::EndSizeOptions property

PipeStyleOptionBase::EndSizeType property

PipeStyleOptionBase::HatchOptions property

PipeStyleOptionBase::InnerDiameter property

PipeStyleOptionBase::InnerDiameterPercent property

PipeStyleOptionBase::OuterDiameter property

PipeStyleOptionBase::OuterDiameterPercent property

PipeStyleOptionBase::PipeToPipeEndCleanup property

PipeStyleOptionBase::WallSizeOptions property

PipeStyleOptionBase::WallSizeType property

PipeStylePlanOption class

about PipeStylePlanOption class

PipeStylePlanOption::CenterlineOptions property

PipeStylePlanOption::CenterlineSize property

PipeStylePlanOption::CenterlineSizePercent property

PipeStylePlanOption::CenterlineWidthOptions property

PipeStyleProfileOption class

about PipeStyleProfileOption class

PipeStyleProfileOption::CrossingHatch property

PipeStyles

PipeTableStyles

PipeTickStyle

PipeToPipeEndCleanup

PipeToPipeEndCleanup enumeration member

PipeUpperTopDepth

PipeWallThickness

PIPoint

PIPoint enumeration member

PIStation

PlaceMarkerAtStartPoint

PlaceRemainderInLastParcel enumeration member

PlanAndProfile enumeration member

Planar enumeration member

PlanOnly enumeration member

PlanOption

PlanProfileLabelStyles

PlanReadability

PlanReadable

PlanReadableBias

PlanViewOptions

Plinegen

PlineId

PlotAreaType

PlotHeight enumeration member

PlotPattern

PlotRule

Plotted enumeration member

PlottedSize

PlottedUnitDisplay

PlusSign enumeration member

Point

Point class

about Point class

Point enumeration member

Point::Codes property

Point::Elevation property

Point::GetXYZ method

Point::Index property

Point::IsHidden property

Point::IsLoopPoint property

Point::Offset property

Point::Station property

Point3d enumeration member

PointCodes

PointCollection class

about PointCollection class

PointCollection::Add method

PointCollection::Count property

PointCollection::default property

PointCollection::GetEnumerator method

PointCollection::GetObjectEnumerator method

PointCollection::Remove method

PointDescription

PointEntity class

about PointEntity class

PointEntity::DescriptionFormat property

PointEntity::FullDescription property

PointEntity::IsNamed property

PointEntity::IsSurveyPoint property

PointEntity::Location property

PointEntity::PointName property

PointEntity::PointNumber property

PointEntity::RawDescription property

PointExport

PointGroup

PointImport

PointLabel

PointLabelStyles

PointLocation

PointName

PointNumber

PointOfIntersection enumeration member

PointOfVerticalIntersection enumeration member

PointOne enumeration member

PointProfile enumeration member

PointReferenceTolerance

PointRemoval enumeration member

Points

Points enumeration member

PointsAndFaces enumeration member

PointsByCode

PointsCreation

PointSection enumeration member

PointsOnly enumeration member

PointStyle

PointStyle class

about PointStyle class

PointStyle::Display3dType property

PointStyle::Elevation property

PointStyle::GetDisplayStyleModel method

PointStyle::GetDisplayStylePlan method

PointStyle::GetDisplayStyleProfile method

PointStyle::GetDisplayStyleSection method

PointStyle::GetLabelDisplayStyleModel method

PointStyle::GetLabelDisplayStylePlan method

PointStyle::LabelDisplayStyleModel property

PointStyle::LabelDisplayStylePlan property

PointStyle::MarkerType property

PointStyle::ScaleFactor property

PointStyles

PointTable class

about PointTable class

PointTable enumeration member

PointTableStyles

PointType

PolygonPoints

Polyline2D enumeration member

Polyline3D enumeration member

PolylineOptions class

about PolylineOptions class

PolylineOptions::!= operator

PolylineOptions::== operator

PolylineOptions::AddCurvesBetweenTangents property

PolylineOptions::Equals method

PolylineOptions::EraseExistingEntities property

PolylineOptions::GetHashCode method

PolylineOptions::PlineId property

PolyMesh enumeration member

Position

Precision

Precision000001 enumeration member

Precision00001 enumeration member

Precision0001 enumeration member

Precision001 enumeration member

Precision01 enumeration member

Precision1 enumeration member

Precision10 enumeration member

Precision100 enumeration member

Precision1000 enumeration member

Precision10000 enumeration member

Precision100000 enumeration member

Precision1000000 enumeration member

Prefix enumeration member

PrefixLongName enumeration member

PrefixLongNameSpaced enumeration member

PrefixShortName enumeration member

PrefixShortNameSpaced enumeration member

Prepend enumeration member

PreserveCase enumeration member

PreviewFeatureLength

PreviewGraphics

PreviewSlope

PreviewSlopeLength

PreviousMajorGrid enumeration member

PreviousMinorGrid enumeration member

PreviousOffsetBandBottom enumeration member

PreviousOffsetBandMiddle enumeration member

PreviousOffsetBandTop enumeration member

PreviousStationBandBottom enumeration member

PreviousStationBandMiddle enumeration member

PreviousStationBandTop enumeration member

PreviousSubEntEndAndPassPt enumeration member

PreviousSubEntPassPtAndParameter enumeration member

PreviousSubEntPassPtWithGrade enumeration member

PrimaryRoadCrownMaintained enumeration member

PrimaryRoadDefaultExitAndEntryLength

PrimaryRoadLeftCrossSlope

PrimaryRoadLeftOffset

PrimaryRoadRightCrossSlope

PrimaryRoadRightOffset

PrintArea enumeration member

PrismodialFormula enumeration member

ProcessCounterClockwise

Profile

Profile class

about Profile class

Profile enumeration member

Profile::AlignmentId property

Profile::CreateByLayout method

Profile::CreateFromSurface method

Profile::DataSourceId property

Profile::DataSourceName property

Profile::DesignCheckSetId property

Profile::DesignCheckSetName property

Profile::DesignSpeedBased property

Profile::ElevationAt method

Profile::ElevationMax property

Profile::ElevationMin property

Profile::EndingStation property

Profile::Entities property

Profile::GradeAt method

Profile::Length property

Profile::Offset property

Profile::Plinegen property

Profile::ProfileType property

Profile::PVIs property

Profile::StartingStation property

Profile::StyleId property

Profile::StyleName property

Profile::UpdateMode property

Profile::UseDesignCheckSet property

Profile::UseDesignCriteriaFile property

ProfileBandHGP enumeration member

ProfileBandHorizontalGeometryCurve enumeration member

ProfileBandHorizontalGeometrySpiral enumeration member

ProfileBandHorizontalGeometryTangent enumeration member

ProfileBandIncrementalDistance enumeration member

ProfileBandLabelGroup class

about ProfileBandLabelGroup class

ProfileBandMajorIncrement enumeration member

ProfileBandMinorIncrement enumeration member

ProfileBandPipeNetworkPipeLocation enumeration member

ProfileBandPipeNetworkStructureLocation enumeration member

ProfileBandSectionalDataIncrementalSectionData enumeration member

ProfileBandSectionalDataSampleLineLocation enumeration member

ProfileBandStationEquation enumeration member

ProfileBandSuperelevationDataFullSuper enumeration member

ProfileBandSuperelevationDataLevelCrown enumeration member

ProfileBandSuperelevationDataNormalCrown enumeration member

ProfileBandSuperelevationDataReverseCrown enumeration member

ProfileBandSuperelevationDataShoulderCritical enumeration member

ProfileBandSuperelevationDataSlopeTransition enumeration member

ProfileBandVerticalGeometryCrestCurve enumeration member

ProfileBandVerticalGeometryDownhillTangent enumeration member

ProfileBandVerticalGeometrySagCurve enumeration member

ProfileBandVerticalGeometryUphillTangent enumeration member

ProfileBandVGP enumeration member

ProfileBeginningVertexMarkerStyleId

ProfileBeginningVertexMarkerStyleName

ProfileBegOfAlign enumeration member

ProfileCircular class

about ProfileCircular class

ProfileCircular::CurveType property

ProfileCircular::EntityType property

ProfileCircular::GradeChange property

ProfileCircular::GradeIn property

ProfileCircular::GradeOut property

ProfileCircular::HighLowPointElevation property

ProfileCircular::HighLowPointStation property

ProfileCircular::K property

ProfileCircular::M property

ProfileCircular::PVIElevation property

ProfileCircular::PVIStation property

ProfileCircular::Radius property

ProfileCircular::TangentOffsetAtPVI property

ProfileCreationOption

ProfileCrestCurve enumeration member

ProfileCriteria class

about ProfileCriteria class

ProfileCriteria::BoundaryType property

ProfileCriteria::ProfileId property

ProfileCriteria::ProfileName property

ProfileCriteriaCollection class

about ProfileCriteriaCollection class

ProfileCriteriaCollection::Add method

ProfileCriteriaCollection::Count property

ProfileCriteriaCollection::default property

ProfileCriteriaCollection::GetEnumerator method

ProfileCriteriaCollection::GetObjectEnumerator method

ProfileCriteriaCollection::RemoveAt method

ProfileCurve enumeration member

ProfileCurveCompCurve enumeration member

ProfileCurveHighPoint enumeration member

ProfileCurveLowPoint enumeration member

ProfileCurvePVI enumeration member

ProfileCurveRevCurve enumeration member

ProfileCurveTan enumeration member

ProfileData enumeration member

ProfileDataBand enumeration member

ProfileDataBandStyle class

about ProfileDataBandStyle class

ProfileDataBandStyle::BandType property

ProfileDataBandStyle::GetDisplayStylePlan method

ProfileDataBandStyle::HGPLabelStyleId property

ProfileDataBandStyle::HGPTickStyle property

ProfileDataBandStyle::IncrementalDistanceLabelStyleId property

ProfileDataBandStyle::MajorIncrementLabelStyleId property

ProfileDataBandStyle::MajorIncrementTickStyle property

ProfileDataBandStyle::MinorIncrementLabelStyleId property

ProfileDataBandStyle::MinorIncrementTickStyle property

ProfileDataBandStyle::StationEquationLabelStyleId property

ProfileDataBandStyle::StationEquationTickStyle property

ProfileDataBandStyle::TitleTextLabelStyleId property

ProfileDataBandStyle::VGPLabelStyleId property

ProfileDataBandStyle::VGPTickStyle property

ProfileDataHGP enumeration member

ProfileDataIncrementalDistance enumeration member

ProfileDataMajorIncrement enumeration member

ProfileDataMinorIncrement enumeration member

ProfileDataStationEquation enumeration member

ProfileDataVGP enumeration member

ProfileDepthLabelStyle

ProfileDesignCheck class

about ProfileDesignCheck class

ProfileDesignCheck::DesignCheckType property

ProfileDesignCheckCollection class

about ProfileDesignCheckCollection class

ProfileDesignCheckCollection::Add method

ProfileDesignCheckCollection::Clear method

ProfileDesignCheckCollection::Count property

ProfileDesignCheckCollection::default property

ProfileDesignCheckCollection::Remove method

ProfileDesignCheckCollection::RemoveAt method

ProfileDesignCheckRoot

ProfileDesignCheckRoot class

about ProfileDesignCheckRoot class

ProfileDesignCheckRoot::CurveDesignChecks property

ProfileDesignCheckRoot::LineDesignChecks property

ProfileDesignCheckRoot::ProfileDesignCheckRoot constructor

ProfileDesignCheckSet class

about ProfileDesignCheckSet class

ProfileDesignCheckSet::AddDesignCheck method

ProfileDesignCheckSet::GetAllDesignChecks method

ProfileDesignCheckSet::GetCurveDesignCheckType method

ProfileDesignCheckSet::RemoveAllDesignCheck method

ProfileDesignCheckSet::RemoveDesignCheck method

ProfileDesignCheckSet::SetCurveDesignCheckType method

ProfileDesignCheckSetCollection class

about ProfileDesignCheckSetCollection class

ProfileDesignCheckSetCollection::Add method

ProfileDesignCheckSets

ProfileEnd enumeration member

ProfileEndingVertexMarkerStyleId

ProfileEndingVertexMarkerStyleName

ProfileEndOfAlign enumeration member

ProfileEntity class

about ProfileEntity class

ProfileEntity::Constraint1 property

ProfileEntity::Constraint2 property

ProfileEntity::DesignChecks method

ProfileEntity::EndElevation property

ProfileEntity::EndStation property

ProfileEntity::EntityAfter property

ProfileEntity::EntityBefore property

ProfileEntity::EntityId property

ProfileEntity::EntityType property

ProfileEntity::HighestDesignSpeed property

ProfileEntity::Length property

ProfileEntity::MinimumKValueHSD property

ProfileEntity::MinimumKValuePSD property

ProfileEntity::MinimumKValueSSD property

ProfileEntity::StartElevation property

ProfileEntity::StartStation property

ProfileEntity::ValidateDesignCheck method

ProfileEntityCollection class

about ProfileEntityCollection class

ProfileEntityCollection::AddFixedSymmetricParabolaByEntityEndAndThroughPoint method

ProfileEntityCollection::AddFixedSymmetricParabolaByThreePoints method

ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndEndGrade method

ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndK method

ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndRadius method

ProfileEntityCollection::AddFixedSymmetricParabolaByTwoPointsAndStartGrade method

ProfileEntityCollection::AddFixedTangent method

ProfileEntityCollection::AddFixedTangentWithPreviousEntity method

ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndGrade method

ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndK method

ProfileEntityCollection::AddFloatingSymmetricParabolaByThroughPointAndRadius method

ProfileEntityCollection::AddFloatingTangent method

ProfileEntityCollection::AddFreeAsymmetricParabolaByPVIAndLengths method

ProfileEntityCollection::AddFreeCircularCurveByPVIAndLength method

ProfileEntityCollection::AddFreeCircularCurveByPVIAndRadius method

ProfileEntityCollection::AddFreeCircularCurveByPVIAndThroughPoint method

ProfileEntityCollection::AddFreeSymmetricParabolaByK method

ProfileEntityCollection::AddFreeSymmetricParabolaByLength method

ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndCurveLength method

ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndK method

ProfileEntityCollection::AddFreeSymmetricParabolaByPVIAndThroughPoint method

ProfileEntityCollection::AddFreeSymmetricParabolaByRadius method

ProfileEntityCollection::AddFreeTangent method

ProfileEntityCollection::Clear method

ProfileEntityCollection::Count property

ProfileEntityCollection::default property

ProfileEntityCollection::EntityAtId method

ProfileEntityCollection::FirstEntity property

ProfileEntityCollection::GetEnumerator method

ProfileEntityCollection::GetObjectEnumerator method

ProfileEntityCollection::LastEntity property

ProfileEntityCollection::Remove method

ProfileEntityCollection::RemoveAt method

ProfileFromFeatureLine

ProfileGeometryPoints

ProfileGradeBreaks enumeration member

ProfileHatch enumeration member

ProfileHatchArea class

about ProfileHatchArea class

ProfileHatchArea::Criteria property

ProfileHatchArea::Name property

ProfileHatchArea::ShapeStyleId property

ProfileHatchArea::ShapeStyleName property

ProfileHatchAreaCollection class

about ProfileHatchAreaCollection class

ProfileHatchAreaCollection::Add method

ProfileHatchAreaCollection::Count property

ProfileHatchAreaCollection::default property

ProfileHatchAreaCollection::GetEnumerator method

ProfileHatchAreaCollection::GetObjectEnumerator method

ProfileHatchAreaCollection::Remove method

ProfileHighLowPoints

ProfileHorizontalGeometryPoint enumeration member

ProfileId

ProfileInternalVertexMarkerStyleId

ProfileInternalVertexMarkerStyleName

ProfileLabeling enumeration member

ProfileLabelPlacement

ProfileLabelSet

ProfileLabelSetStyle class

about ProfileLabelSetStyle class

ProfileLabelSetStyle::AddCrestCurve method

ProfileLabelSetStyle::AddSagCurve method

ProfileLabelSetStyle::default property

ProfileLabelSetStyle::GetEnumerator method

ProfileLabelSetStyle::GetObjectEnumerator method

ProfileLabelSetStyles

ProfileLabelStyle

ProfileLabelStyles

ProfileLine enumeration member

ProfileMajorStation enumeration member

ProfileMarkerDisplayStyleSection

ProfileMarkerSectionViewMarkerStyle

ProfileMinorStation enumeration member

ProfileName

ProfileNameTemplate

ProfileOnly enumeration member

ProfileOption

ProfileOptions

ProfileOverallHighPoint enumeration member

ProfileOverallLowPoint enumeration member

ProfileOverride class

about ProfileOverride class

ProfileOverride::GetLabelGroupIds method

ProfileOverride::OverrideStyleId property

ProfileOverride::OverrideStyleName property

ProfileOverride::ProfileId property

ProfileOverride::ProfileName property

ProfileOverrideCollection class

about ProfileOverrideCollection class

ProfileOverrideCollection::ClipGridAt property

ProfileOverrideCollection::Count property

ProfileOverrideCollection::default property

ProfileOverrideCollection::GetEnumerator method

ProfileOverrideCollection::GetObjectEnumerator method

ProfileOverrideCollection::SplitAt property

ProfileParabolaAsymmetric class

about ProfileParabolaAsymmetric class

ProfileParabolaAsymmetric::AsymmetricLength1 property

ProfileParabolaAsymmetric::AsymmetricLength2 property

ProfileParabolaAsymmetric::CurveType property

ProfileParabolaAsymmetric::EntityType property

ProfileParabolaAsymmetric::GradeChange property

ProfileParabolaAsymmetric::GradeIn property

ProfileParabolaAsymmetric::GradeOut property

ProfileParabolaAsymmetric::HighLowPointElevation property

ProfileParabolaAsymmetric::HighLowPointStation property

ProfileParabolaAsymmetric::K property

ProfileParabolaAsymmetric::PVIElevation property

ProfileParabolaAsymmetric::PVIStation property

ProfileParabolaAsymmetric::TangentOffsetAtPVI property

ProfileParabolaSymmetric class

about ProfileParabolaSymmetric class

ProfileParabolaSymmetric::CurveType property

ProfileParabolaSymmetric::EntityType property

ProfileParabolaSymmetric::GetHeadlightSightDistance method

ProfileParabolaSymmetric::GetPassingSightDistance method

ProfileParabolaSymmetric::GetStoppingSightDistance method

ProfileParabolaSymmetric::GradeAtThroughPoint1 property

ProfileParabolaSymmetric::GradeAtThroughPoint2 property

ProfileParabolaSymmetric::GradeChange property

ProfileParabolaSymmetric::GradeIn property

ProfileParabolaSymmetric::GradeOut property

ProfileParabolaSymmetric::HighLowPointElevation property

ProfileParabolaSymmetric::HighLowPointStation property

ProfileParabolaSymmetric::K property

ProfileParabolaSymmetric::M property

ProfileParabolaSymmetric::PVIElevation property

ProfileParabolaSymmetric::PVIStation property

ProfileParabolaSymmetric::Radius property

ProfileParabolaSymmetric::SetHeadlightSightDistance method

ProfileParabolaSymmetric::SetPassingSightDistance method

ProfileParabolaSymmetric::SetStoppingSightDistance method

ProfileParabolaSymmetric::TangentOffsetAtPVI property

ProfileParabolaSymmetric::ThroughPoint1Elevation property

ProfileParabolaSymmetric::ThroughPoint1Station property

ProfileParabolaSymmetric::ThroughPoint2Elevation property

ProfileParabolaSymmetric::ThroughPoint2Station property

ProfileParabolaSymmetric::ThroughPoint3Elevation property

ProfileParabolaSymmetric::ThroughPoint3Station property

ProfileProjection class

about ProfileProjection class

ProfileProjection enumeration member

ProfileProjectionLabelStyle

ProfilePVI class

about ProfilePVI class

ProfilePVI::Elevation property

ProfilePVI::EntityAfter property

ProfilePVI::EntityBefore property

ProfilePVI::GradeIn property

ProfilePVI::GradeOut property

ProfilePVI::HeadlightSightDistance property

ProfilePVI::PassingSightDistance property

ProfilePVI::PVIType property

ProfilePVI::Station property

ProfilePVI::StoppingSightDistance property

ProfilePVI::VerticalCurve property

ProfilePVICollection class

about ProfilePVICollection class

ProfilePVICollection::AddPVI method

ProfilePVICollection::AddPVIArc method

ProfilePVICollection::AddPVIAsymParabola method

ProfilePVICollection::AddPVISymParabola method

ProfilePVICollection::Count property

ProfilePVICollection::default property

ProfilePVICollection::GetEnumerator method

ProfilePVICollection::GetObjectEnumerator method

ProfilePVICollection::GetPVIAt method

ProfilePVICollection::Remove method

ProfilePVICollection::RemoveAt method

ProfileSagCurve enumeration member

ProfileSampleOffsetsCommandSetting

ProfilesCreation

ProfileStart enumeration member

ProfileStationAndElevationLabelStyle

ProfileStationElevation enumeration member

ProfileStyle

ProfileStyle class

about ProfileStyle class

ProfileStyle::ArrowHeadOption property

ProfileStyle::BeginPointMarkerStyle property

ProfileStyle::Chain3DDisplayStyleModel property

ProfileStyle::ChainTessellationDistance3D property

ProfileStyle::EndPointMarkerStyle property

ProfileStyle::GetChain3DDisplayStyleModel method

ProfileStyle::GetDisplayStyleProfile method

ProfileStyle::GetProfileMarkerDisplayStyleSection method

ProfileStyle::HighPointMarkerStyle property

ProfileStyle::LowPointMarkerStyle property

ProfileStyle::ProfileMarkerDisplayStyleSection property

ProfileStyle::ProfileMarkerSectionViewMarkerStyle property

ProfileStyle::ThroughPointMarkerStyle property

ProfileStyle::VCompoundCurveIntersectPointMarkerStyle property

ProfileStyle::VCurveTangentIntersectPointMarkerStyle property

ProfileStyle::VIntersectionPointMarkerStyle property

ProfileStyle::VReverseCurveIntersectPointMarkerStyle property

ProfileStyle::VTangentCurveIntersectPointMarkerStyle property

ProfileStyles

ProfileTanCurve enumeration member

ProfileTangent class

about ProfileTangent class

ProfileTangent::EntityType property

ProfileTangent::Grade property

ProfileTangent::ThroughPoint1Elevation property

ProfileTangent::ThroughPoint1Station property

ProfileTangent::ThroughPoint2Elevation property

ProfileTangent::ThroughPoint2Station property

ProfileTanTan enumeration member

ProfileType

ProfileView

ProfileView class

about ProfileView class

ProfileView enumeration member

ProfileView::AlignmentId property

ProfileView::AlignmentName property

ProfileView::Create method

ProfileView::ElevationMax property

ProfileView::ElevationMin property

ProfileView::ElevationRangeMode property

ProfileView::FindStationAndElevationAtXY method

ProfileView::FindXYAtStationAndElevation method

ProfileView::GetLabelIds method

ProfileView::GraphOverrides property

ProfileView::HatchAreas property

ProfileView::SplitDataLines property

ProfileView::SplitDatumRounding property

ProfileView::SplitHeight property

ProfileView::SplitProfileView property

ProfileView::SplitStationMode property

ProfileView::SplitStationRounding property

ProfileView::StationEnd property

ProfileView::StationRangeMode property

ProfileView::StationStart property

ProfileView::StyleId property

ProfileView::StyleName property

ProfileViewBandSet

ProfileViewBandSetItem class

about ProfileViewBandSetItem class

ProfileViewBandSetItem::GetAlignmentGeometryPoints method

ProfileViewBandSetItem::GetProfileGeometryPoints method

ProfileViewBandSetItem::LabelAtEndStation property

ProfileViewBandSetItem::LabelAtStartStation property

ProfileViewBandSetItem::MajorInterval property

ProfileViewBandSetItem::MinorInterval property

ProfileViewBandSetItem::SetAlignmentGeometryPoints method

ProfileViewBandSetItem::SetProfileGeometryPoints method

ProfileViewBandSetItem::StaggerLabel property

ProfileViewBandSetItem::StaggerLineHeight property

ProfileViewBandSetStyle class

about ProfileViewBandSetStyle class

ProfileViewBandSetStyle::BottomBandSetItems property

ProfileViewBandSetStyle::MatchIncrement property

ProfileViewBandSetStyle::TopBandSetItems property

ProfileViewBandSetStyles

ProfileViewBandStyle

ProfileViewDatumBy

ProfileViewDepth enumeration member

ProfileViewHorizontalGeometryBandStyles

ProfileViewLabeling enumeration member

ProfileViewLabelStyles

ProfileViewPart class

about ProfileViewPart class

ProfileViewPart::GetLabelIds method

ProfileViewPart::ModelPartId property

ProfileViewPartId

ProfileViewPipeNetworkBandStyles

ProfileViewProfileDataBandStyles

ProfileViewProjection enumeration member

ProfileViewSectionalDataBandStyles

ProfileViewsInRowOrColumn

ProfileViewSplitData class

about ProfileViewSplitData class

ProfileViewSplitData::AdjustedDatum property

ProfileViewSplitData::ProfileViewStyleId property

ProfileViewSplitData::ProfileViewStyleName property

ProfileViewSplitData::SplitStation property

ProfileViewSplitDataCollection class

about ProfileViewSplitDataCollection class

ProfileViewSplitDataCollection::Add method

ProfileViewSplitDataCollection::Count property

ProfileViewSplitDataCollection::default property

ProfileViewSplitDataCollection::GetEnumerator method

ProfileViewSplitDataCollection::GetObjectEnumerator method

ProfileViewSplitDataCollection::RemoveAt method

ProfileViewStationElevation enumeration member

ProfileViewStyle

ProfileViewStyle class

about ProfileViewStyle class

ProfileViewStyle::BottomAxis property

ProfileViewStyle::GetDisplayStylePlan method

ProfileViewStyle::GraphStyle property

ProfileViewStyle::GridStyle property

ProfileViewStyle::LeftAxis property

ProfileViewStyle::RightAxis property

ProfileViewStyle::TopAxis property

ProfileViewStyleCollection class

about ProfileViewStyleCollection class

ProfileViewStyleCollection::Add method

ProfileViewStyleId

ProfileViewStyleName

ProfileViewStyles

ProfileViewSuperElevationBandStyles

ProfileViewVerticalGeometryBandStyles

Projection

Projection enumeration member

ProjectionDistance

ProjectionLabelPlacement

ProjectionLabelStyles

ProjectionProfileOptions class

about ProjectionProfileOptions class

ProjectionProfileOptions::AutoCAD3dPolylineBeginVertexMarkerStyleId property

ProjectionProfileOptions::AutoCAD3dPolylineBeginVertexMarkerStyleName property

ProjectionProfileOptions::AutoCAD3dPolylineEndVertexMarkerStyleId property

ProjectionProfileOptions::AutoCAD3dPolylineEndVertexMarkerStyleName property

ProjectionProfileOptions::AutoCAD3dPolylineInternalVertexMarkerStyleId property

ProjectionProfileOptions::AutoCAD3dPolylineInternalVertexMarkerStyleName property

ProjectionProfileOptions::AutoCADBlockDisplayOptions property

ProjectionProfileOptions::AutoCADBlockMarkerStyleId property

ProjectionProfileOptions::AutoCADBlockMarkerStyleName property

ProjectionProfileOptions::AutoCADBlockSymbolBlockId property

ProjectionProfileOptions::AutoCADBlockSymbolBlockName property

ProjectionProfileOptions::AutoCADPointDisplayOptions property

ProjectionProfileOptions::AutoCADPointMarkerStyleId property

ProjectionProfileOptions::AutoCADPointMarkerStyleName property

ProjectionProfileOptions::AutoCADSolidDisplayOptions property

ProjectionProfileOptions::AutoCADSolidMarkerStyleId property

ProjectionProfileOptions::AutoCADSolidMarkerStyleName property

ProjectionProfileOptions::MultiViewBlockDirection property

ProjectionProfileOptions::MultiViewBlockDisplayOptions property

ProjectionProfileOptions::MultiViewBlockDisplayRepresentationId property

ProjectionProfileOptions::MultiViewBlockDisplayRepresentationName property

ProjectionProfileOptions::MultiViewBlockMarkerStyleId property

ProjectionProfileOptions::MultiViewBlockMarkerStyleName property

ProjectionProfileOptions::MultiViewBlockSymbolBlockId property

ProjectionProfileOptions::MultiViewBlockSymbolBlockName property

ProjectionProfileOptions::VerticallyExaggerateBlocks property

ProjectionProfileOptions::VerticallyExaggerateMultiViewBlocks property

ProjectionProfileOptions::VerticallyExaggerateSolids property

ProjectionRelativeElevation

ProjectionSectionOptions class

about ProjectionSectionOptions class

ProjectionSectionOptions::AutoCAD3dPolylineCrossingMarkerStyleId property

ProjectionSectionOptions::AutoCAD3dPolylineCrossingMarkerStyleName property

ProjectionSectionOptions::AutoCADBlockDisplayOptions property

ProjectionSectionOptions::AutoCADBlockMarkerStyleId property

ProjectionSectionOptions::AutoCADBlockMarkerStyleName property

ProjectionSectionOptions::AutoCADBlockSymbolBlockId property

ProjectionSectionOptions::AutoCADBlockSymbolBlockName property

ProjectionSectionOptions::AutoCADPointDisplayOptions property

ProjectionSectionOptions::AutoCADPointMarkerStyleId property

ProjectionSectionOptions::AutoCADPointMarkerStyleName property

ProjectionSectionOptions::AutoCADSolidDisplayOptions property

ProjectionSectionOptions::AutoCADSolidMarkerStyleId property

ProjectionSectionOptions::AutoCADSolidMarkerStyleName property

ProjectionSectionOptions::MultiViewBlockDirection property

ProjectionSectionOptions::MultiViewBlockDisplayOptions property

ProjectionSectionOptions::MultiViewBlockDisplayRepresentationId property

ProjectionSectionOptions::MultiViewBlockDisplayRepresentationName property

ProjectionSectionOptions::MultiViewBlockMarkerStyleId property

ProjectionSectionOptions::MultiViewBlockMarkerStyleName property

ProjectionSectionOptions::MultiViewBlockSymbolBlockId property

ProjectionSectionOptions::MultiViewBlockSymbolBlockName property

ProjectionSectionOptions::VerticallyExaggerateBlocks property

ProjectionSectionOptions::VerticallyExaggerateMultiViewBlocks property

ProjectionSectionOptions::VerticallyExaggerateSolids property

ProjectionStyle

ProjectionStyle class

about ProjectionStyle class

ProjectionStyle::GetDisplayStyleProfile method

ProjectionStyle::GetDisplayStyleSection method

ProjectionStyle::ProfileOptions property

ProjectionStyle::SectionOptions property

ProjectionStyleCollection class

about ProjectionStyleCollection class

ProjectionStyleCollection::Add method

ProjectionStyles

ProjectOrAssemblyName

PromptFor3DPoints

PromptForDescriptions

PromptForEastingThenNorthing

PromptForElevations

PromptForLongitudeThenLatitude

PromptForPointNames

PromptForYBeforeX

PromptMethod

Properties

PropertyAnchorPoint class

about PropertyAnchorPoint class

PropertyAnchorPoint::Value property

PropertyAngle class

about PropertyAngle class

PropertyAngle::Value property

PropertyBlock class

about PropertyBlock class

PropertyBlock::Value property

PropertyBoolean class

about PropertyBoolean class

PropertyEnum template

about PropertyEnum template

PropertyEnum::Value property

PropertyLines enumeration member

PropertyObjectName class

about PropertyObjectName class

PropertyObjectName::Value property

PVI enumeration member

PVIDimension enumeration member

PVIElevation

PVIEnd enumeration member

PVIEndDimension enumeration member

PVIEndInView enumeration member

PVIEndInViewDimension enumeration member

PVIExtension enumeration member

PVIs

PVIStart enumeration member

PVIStartDimension enumeration member

PVIStartInView enumeration member

PVIStartInViewDimension enumeration member

PVIStation

PVIType

Q

QTOUtility class

about QTOUtility class

QTOUtility::AddPayItemId method

QTOUtility::DeleteAllPayItemsIds method

QTOUtility::DeletePayItemIds method

QTOUtility::GetPayItemIds method

Quantile enumeration member

QuantityTakeoffCriteria

QuantityTakeoffCriteria class

about QuantityTakeoffCriteria class

QuantityTakeoffCriteria::AddMaterial method

QuantityTakeoffCriteria::Clear method

QuantityTakeoffCriteria::Count property

QuantityTakeoffCriteria::default property

QuantityTakeoffCriteria::RemoveAt method

QuantityTakeoffCriteriaCollection class

about QuantityTakeoffCriteriaCollection class

QuantityTakeoffCriteriaCollection::Add method

QuantityTakeoffCriteriaData class

about QuantityTakeoffCriteriaData class

QuantityTakeoffCriteriaData::Condition property

QuantityTakeoffCriteriaData::ItemType property

QuantityTakeoffCriteriaData::Name property

QuantityTakeoffCriteriaItem class

about QuantityTakeoffCriteriaItem class

QuantityTakeoffCriteriaItem::AddCorridorShape method

QuantityTakeoffCriteriaItem::AddSurface method

QuantityTakeoffCriteriaItem::Count property

QuantityTakeoffCriteriaItem::CutFactor property

QuantityTakeoffCriteriaItem::default property

QuantityTakeoffCriteriaItem::FillFactor property

QuantityTakeoffCriteriaItem::MaterialName property

QuantityTakeoffCriteriaItem::QuantityType property

QuantityTakeoffCriteriaItem::ReFillFactor property

QuantityTakeoffCriteriaItem::RemoveCorridorShape method

QuantityTakeoffCriteriaItem::RemoveSurface method

QuantityTakeoffCriteriaItem::ShapeStyleId property

QuantityTakeoffCriteriaItem::ShapeStyleName property

QuantityTakeoffCriterias

QuantityTakeoffMaterial enumeration member

QuantityTakeoffMaterialTableStyles

QuantityTakeoffTotalVolume enumeration member

QuantityTakeoffTotalVolumeTableStyles

QuantityType

QuickImport enumeration member

QuickProfile

R

RadialOffsetAngle

RadialPoint

Radian enumeration member

Radians enumeration member

Radius

Radius enumeration member

RadiusAndLength enumeration member

RadiusForCurve1

RadiusForCurve2

RadiusForCurve3

RadiusIn

RadiusLookupMethod

RadiusofCurve1

RadiusOfCurve1

RadiusofCurve2

RadiusOfCurve2

RadiusOfCurve3

RadiusOfReverseCurve

RadiusOut

RadiusSnapValue

Rainbow enumeration member

RaiseLowerElevationIncrement

RaiseLowerIncrement

RangeDefault

RangeEnd

RangeEnd enumeration member

RangeEndFromFeature

RangeList enumeration member

RangeMax

RangeMin

RangePrecision

RangeStart

RangeStart enumeration member

RangeStartFromFeature

RawDescription

RawDescription enumeration member

RawStation

RawStationBack

Rebuild

RebuildAutomatic

RebuildOnEdit

RecordError

Rectangular enumeration member

RedistributeRemainder enumeration member

Reds enumeration member

RefAlignmentId

RefAlignmentName

ReferenceAlignmentId

ReferenceAlignmentName

ReferenceLine enumeration member

ReferencePoint

ReferencePoint enumeration member

ReferencePointStation

ReferenceSurfaceId

ReferenceSurfaceName

ReferenceText enumeration member

ReFillFactor

RefSurfaceId

RefSurfaceName

RegionBoundaries enumeration member

RegionBoundaryColor

RegionBoundaryLineweight

RegionHighlightGraphics

RegionOptions

RegionType

RegressionGraphOption

RelatedOffsetBaselineFeatureLines

RelativeElevation

RelativeElevation enumeration member

RelativeElevationProjectionType

RelativeToScreen enumeration member

RemainderDistributionType

Remove

RemoveAllDescendants

RemoveAllDesignCheck

RemoveAllRules

RemoveAt

RemoveChild

RemoveComponent

RemoveCorridorShape

RemoveCriteria

RemoveDesignCheck

RemoveFromAllProfileViews

RemoveFromAllSectionViews

RemoveFromProfileView

RemoveFromSectionView

RemovePartFamily

RemovePartSize

RemoveRule

RemoveSurface

Rename enumeration member

RenderMaterial

RenderMaterialStyleId

RenderMaterialStyleName

Renumber enumeration member

Renumbering

RepeatHeaderInSplitTables

RepeatTitleInSplitTables

ReportExtentsType

ReportSelectedPayItemOnly

ReportType

Reset

ResetAllSubCommonLabelLocations

ResetAllSubCommonLabelProperties

ResetAllSubCommonLabels

ResetLocation

ResetProperties

ResizeByInnerDiameterOrWidth

ResizeByPipeDepths

ResizeJunctionStructure

ResourceModule

ResourceString

RevCurve enumeration member

RevCurveCurve enumeration member

Reverse

Reverse enumeration member

ReverseCrown enumeration member

ReverseCrownLabelStyleId

ReverseCrownTickStyle

ReverseCurve

ReverseCurveCurveIntersect enumeration member

ReverseCurveIntersectPointMarkerStyle

Reversed

ReverseSpiralIntersect enumeration member

ReverseSpiralIntersectPointMarkerStyle

RevSpiral enumeration member

Right enumeration member

RightAxis

RightAxis enumeration member

RightAxisAnnotationMajor enumeration member

RightAxisAnnotationMinor enumeration member

RightAxisTicksMajor enumeration member

RightAxisTicksMinor enumeration member

RightAxisTitle enumeration member

RightEdge enumeration member

RightLabelStyles

RightLeft enumeration member

RightOfBand enumeration member

RightSideOfTheRoad enumeration member

RightSwathWidth

RightToLeft enumeration member

Rim enumeration member

RimElevation

RimToSumpHeight

RiseRun enumeration member

RoadwayDrivingDirection

RoadwayState enumeration member

Rotate

RotateToNorth enumeration member

Rotation

RotationAngle

RotationPoint enumeration member

RotationToGridAzimuth

RotationToGridNorth

RoundedRectangular enumeration member

Rounding

RoundToNearest enumeration member

RowSpacing

RuleBasedCreation enumeration member

RuleResourceString

Rules

RulesCount

RuleSetStyleId

RuleSetStyleName

RulesStyleId

Run

RunRise enumeration member

RuntimeState class

about RuntimeState class

RuntimeState::CurrentMacroName property

RuntimeState::CurrentMacroProject property

S

Sag enumeration member

SagCurveLabelStyleId

SagCurvesOnly enumeration member

SagCurveTickStyle

SagOnly enumeration member

SampledSectionLink class

about SampledSectionLink class

SampledSectionLink::EndPointElevation property

SampledSectionLink::EndPointOffset property

SampledSectionLink::EndPointStation property

SampledSectionLink::StartPointElevation property

SampledSectionLink::StartPointOffset property

SampledSectionLink::StartPointStation property

SampledSectionLinkCollection class

about SampledSectionLinkCollection class

SampledSectionLinkCollection::default property

SampledSectionLinkCollection::GetEnumerator method

SampledSectionLinkCollection::GetObjectEnumerator method

SampleLine

SampleLine class

about SampleLine class

SampleLine enumeration member

SampleLine::GetSectionViewIds method

SampleLine::GroupId property

SampleLineGroup

SampleLineGroup class

about SampleLineGroup class

SampleLineGroup::GetMassHaulViewIds method

SampleLineGroup::GetSampleLineIds method

SampleLineLabel

SampleLineLabeling enumeration member

SampleLineLabelStyles

SampleLineLabelStyles enumeration member

SampleLineStationLabels enumeration member

SampleLineStationLabelStyleId

SampleLineStationTickStyle

SampleLineStyle class

about SampleLineStyle class

SampleLineStyle::GetDisplayStyleModel method

SampleLineStyle::GetDisplayStylePlan method

SampleLineStyles

SampleLineVerticesLabelStyleId

SampleLineVerticesTickStyle

SampleSection

SamplingIncrements

SaveCommandChangesToSettings

ScaleFactor

ScaleFactor enumeration member

ScaleObjectsFromOtherDrawings

ScalingMethodType

SchematicLineEnd enumeration member

SchematicLineMid enumeration member

SchematicLineStart enumeration member

SchematicLineType

ScriptMacroNotFound enumeration member

ScriptModuleNotFound enumeration member

ScriptModulePathUpdated enumeration member

ScriptPossibleSyntaxError enumeration member

SCSCSConstraints class

about SCSCSConstraints class

SCSCSConstraints::CreateByArc1Angle method

SCSCSConstraints::CreateByArc1Length method

SCSCSConstraints::CreateByArc1PassPt method

SCSCSConstraints::CreateByArc2Angle method

SCSCSConstraints::CreateByArc2Length method

SCSCSConstraints::CreateByArc2PassPt method

SCSCSConstraints::CreateByEndPoint method

SCSCSConstraints::CreateByStartPoint method

SCSCSConstraints::CreateByTan1Length method

SCSCSConstraints::CreateByTan2Length method

SCSSCSConstraints class

about SCSSCSConstraints class

SCSSCSConstraints::CreateByArc1Angle method

SCSSCSConstraints::CreateByArc1Length method

SCSSCSConstraints::CreateByArc1PassPt method

SCSSCSConstraints::CreateByArc2Angle method

SCSSCSConstraints::CreateByArc2Length method

SCSSCSConstraints::CreateByArc2PassPt method

SCSSCSConstraints::CreateByEndPoint method

SCSSCSConstraints::CreateByStartPoint method

SeaLevelScaleElevation

SearchOrder

SecondaryRoadDefaultExitAndEntryLength

SecondaryRoadLeftCrossSlope

SecondaryRoadLeftOffset

SecondaryRoadProfileRules

SecondaryRoadRightCrossSlope

SecondaryRoadRightOffset

Section

Section class

about Section class

Section enumeration member

Section::ParentId property

SectionalData enumeration member

SectionalDataBand enumeration member

SectionalDataBandStyle class

about SectionalDataBandStyle class

SectionalDataBandStyle::BandType property

SectionalDataBandStyle::GetDisplayStylePlan method

SectionalDataBandStyle::IncrementalSectionDataLabelStyleId property

SectionalDataBandStyle::IncrementalSectionDataTickStyle property

SectionalDataBandStyle::SampleLineStationLabelStyleId property

SectionalDataBandStyle::SampleLineStationTickStyle property

SectionalDataBandStyle::TitleTextLabelStyleId property

SectionalDataIncrementalSectionData enumeration member

SectionalDataSampleLineLocation enumeration member

SectionBandCenterline enumeration member

SectionBandGradeBreaks enumeration member

SectionBandIncrementalDistance enumeration member

SectionBandLabelGroup class

about SectionBandLabelGroup class

SectionBandMajorIncrement enumeration member

SectionBandMinorIncrement enumeration member

SectionBandSampleLineVertices enumeration member

SectionBandSegmentSurfaceLabels enumeration member

SectionCrossingHatch

SectionData enumeration member

SectionDataBand enumeration member

SectionDataBandStyle class

about SectionDataBandStyle class

SectionDataBandStyle::BandType property

SectionDataBandStyle::CenterlineLabelStyleId property

SectionDataBandStyle::CenterlineTickStyle property

SectionDataBandStyle::GetDisplayStylePlan method

SectionDataBandStyle::GradeBreaksLabelStyleId property

SectionDataBandStyle::GradeBreaksTickStyle property

SectionDataBandStyle::IncrementalDistanceLabelStyleId property

SectionDataBandStyle::MajorIncrementLabelStyleId property

SectionDataBandStyle::MajorIncrementTickStyle property

SectionDataBandStyle::MinorIncrementLabelStyleId property

SectionDataBandStyle::MinorIncrementTickStyle property

SectionDataBandStyle::SampleLineVerticesLabelStyleId property

SectionDataBandStyle::SampleLineVerticesTickStyle property

SectionDataBandStyle::TitleTextLabelStyleId property

SectionDataCenterline enumeration member

SectionDataGradeBreaks enumeration member

SectionDataIncrementalDistance enumeration member

SectionDataMajorIncrement enumeration member

SectionDataMinorIncrement enumeration member

SectionDataSampleLineVertices enumeration member

SectionGradeBreak enumeration member

SectionGroupElevationRange

SectionLabeling enumeration member

SectionLabelPlacement

SectionLabelSet

SectionLabelSetStyles

SectionLabelStyles

SectionMajorOffset enumeration member

SectionMarkerDisplayStyleSection

SectionMarkerStyleId

SectionMarkerStyleName

SectionMinorOffset enumeration member

SectionOption

SectionOptions

SectionPipeNetwork class

about SectionPipeNetwork class

SectionProjection class

about SectionProjection class

SectionProjection enumeration member

SectionProjectionLabel

SectionSegment enumeration member

SectionSegmentBandStyle class

about SectionSegmentBandStyle class

SectionSegmentBandStyle::BandType property

SectionSegmentBandStyle::GetDisplayStylePlan method

SectionSegmentBandStyle::SegmentLabelsTickStyle property

SectionSegmentBandStyle::SegmentsLabelStyleId property

SectionSegmentBandStyle::TitleTextLabelStyleId property

SectionSegmentSurfaceLabels enumeration member

SectionStyle class

about SectionStyle class

SectionStyle::GetDisplayStyleSection method

SectionStyleId

SectionStyles

SectionView

SectionView class

about SectionView class

SectionView enumeration member

SectionView::ParentEntityId property

SectionViewAnchor

SectionViewBandSet

SectionViewBandSetItem class

about SectionViewBandSetItem class

SectionViewBandSetItem::LabelAtEndOffset property

SectionViewBandSetItem::LabelAtStartOffset property

SectionViewBandSetItem::MajorInterval property

SectionViewBandSetItem::MinorInterval property

SectionViewBandSetItem::StaggerLabel property

SectionViewBandSetItem::StaggerLineHeight property

SectionViewBandSetItemCollection class

about SectionViewBandSetItemCollection class

SectionViewBandSetItemCollection::Add method

SectionViewBandSetItemCollection::default property

SectionViewBandSetItemCollection::GetEnumerator method

SectionViewBandSetItemCollection::GetObjectEnumerator method

SectionViewBandSetStyle class

about SectionViewBandSetStyle class

SectionViewBandSetStyle::BottomBandSetItems property

SectionViewBandSetStyle::MatchIncrement property

SectionViewBandSetStyle::TopBandSetItems property

SectionViewBandSetStyles

SectionViewBottom enumeration member

SectionViewBottomAtEnd enumeration member

SectionViewBottomAtMiddle enumeration member

SectionViewBottomAtStart enumeration member

SectionViewCreation

SectionViewDepth enumeration member

SectionViewDepthGradeLabel

SectionViewGrade enumeration member

SectionViewHeight

SectionViewLabeling enumeration member

SectionViewLabelStyles

SectionViewMaterial enumeration member

SectionViewMaterialTableStyles

SectionViewOffsetElevation enumeration member

SectionViewOffsetElevationLabel

SectionViewPartId

SectionViewProjection enumeration member

SectionViewQuantityTakeoffTable enumeration member

SectionViewSectionDataBandStyles

SectionViewSegmentsBandStyles

SectionViewStyle class

about SectionViewStyle class

SectionViewStyle::BottomAxis property

SectionViewStyle::CenterAxis property

SectionViewStyle::GetDisplayStylePlan method

SectionViewStyle::GraphStyle property

SectionViewStyle::GridStyle property

SectionViewStyle::LeftAxis property

SectionViewStyle::RightAxis property

SectionViewStyle::TopAxis property

SectionViewStyles

SectionViewTop enumeration member

SectionViewTopAtEnd enumeration member

SectionViewTopAtMiddle enumeration member

SectionViewTopAtStart enumeration member

SectionViewTotalVolume enumeration member

SectionViewTotalVolumeTableStyles

SegmentColumnStyle class

about SegmentColumnStyle class

SegmentColumnStyle::GetContentString method

SegmentColumnStyle::GetContentStringFormatted method

SegmentColumnStyle::SetContentString method

SegmentColumnStyle::SetContentStringFormatted method

Segmented enumeration member

SegmentEndAndBandBot enumeration member

SegmentEndAndBandMiddle enumeration member

SegmentEndAndBandTop enumeration member

SegmentLabelsTickStyle

SegmentMiddleAndBandBot enumeration member

SegmentMiddleAndBandMiddle enumeration member

SegmentMiddleAndBandTop enumeration member

SegmentMiddleSuperelevationBand enumeration member

Segments enumeration member

SegmentsLabelStyleId

SegmentStartAndBandBot enumeration member

SegmentStartAndBandMiddle enumeration member

SegmentStartAndBandTop enumeration member

SelectAll

SelectAllSurfaces

Selected

SelectionMethod

SelectionSet enumeration member

SelectObjects enumeration member

SelectParcelAreaLabel enumeration member

SequenceFrom enumeration member

SetAlignmentAbbreviation

SetAlignmentEnhancedAbbreviation

SetAlignmentGeometryPoints

SetAlignmentOnPart

SetBoolOnPart

SetCenterMarkerVisable

SetComponents

SetComponentsDrawOrder

SetContentString

SetContentStringFormatted

SetCorridor

SetCurveDesignCheckType

SetDoubleOnCurrentPart

SetErrorMsgOnCurrentPart

SetGeometryPointsOptions

SetHeadlightSightDistance

SetLongOnPart

SetPassingSightDistance

SetPoint

SetPointOnPart

SetProfileAbbreviation

SetProfileGeometryPoints

SetProfileOnPart

SetRange

SetSegmentCrossSlope

SetSlopeHoldEnd

SetSlopeHoldStart

SetSlopePatternVisable

SetStoppingSightDistance

SetStringOnPart

SetSuperelevationAbbreviation

SetSurfaceOnPart

SetTextComponentJustificationOverride

SetTextComponentOverride

Settings

SettingsAbbreviation class

about SettingsAbbreviation class

SettingsAbbreviation::AlignmentGeoPointEntityData property

SettingsAbbreviation::AlignmentGeoPointText property

SettingsAbbreviation::GeneralText property

SettingsAbbreviation::Profile property

SettingsAbbreviation::Superelevation property

SettingsAbbreviationAlignment class

about SettingsAbbreviationAlignment class

SettingsAbbreviationAlignment::GetAlignmentAbbreviation method

SettingsAbbreviationAlignment::SetAlignmentAbbreviation method

SettingsAbbreviationAlignmentEnhanced class

about SettingsAbbreviationAlignmentEnhanced class

SettingsAbbreviationAlignmentEnhanced::GetAlignmentEnhancedAbbreviation method

SettingsAbbreviationAlignmentEnhanced::SetAlignmentEnhancedAbbreviation method

SettingsAbbreviationProfile class

about SettingsAbbreviationProfile class

SettingsAbbreviationProfile::GetProfileAbbreviation method

SettingsAbbreviationProfile::SetProfileAbbreviation method

SettingsAbbreviationSuperelevation class

about SettingsAbbreviationSuperelevation class

SettingsAbbreviationSuperelevation::GetSuperelevationAbbreviation method

SettingsAbbreviationSuperelevation::SetSuperelevationAbbreviation method

SettingsAlignment class

about SettingsAlignment class

SettingsAlignment::CriteriaBasedDesignOptions property

SettingsAlignment::Data property

SettingsAlignment::DefaultNameFormat property

SettingsAlignment::DynamicAlignmentHighlight property

SettingsAlignment::SettingsCriteriaBasedDesignOptions class

about SettingsAlignment::SettingsCriteriaBasedDesignOptions class

SettingsAlignment::SettingsCriteriaBasedDesignOptions::DefaultDesignCheckSet property

SettingsAlignment::SettingsCriteriaBasedDesignOptions::DesignSpeed property

SettingsAlignment::SettingsCriteriaBasedDesignOptions::DesignSpeedLookupMethod property

SettingsAlignment::SettingsCriteriaBasedDesignOptions::RadiusLookupMethod property

SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseCriteriaBasedDesignOption property

SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseDesignChecksOption property

SettingsAlignment::SettingsCriteriaBasedDesignOptions::UseDesignCriteriaFileOption property

SettingsAlignment::SettingsData class

about SettingsAlignment::SettingsData class

SettingsAlignment::SettingsData::CriteriaBasedDesignOption property

SettingsAlignment::SettingsDefaultNameFormat class

about SettingsAlignment::SettingsDefaultNameFormat class

SettingsAlignment::SettingsDefaultNameFormat::AlignmentNameTemplate property

SettingsAlignment::SettingsDefaultNameFormat::OffsetAlignmentNameTemplate property

SettingsAlignment::SettingsDynamicAlignmentHighlight class

about SettingsAlignment::SettingsDynamicAlignmentHighlight class

SettingsAlignment::SettingsDynamicAlignmentHighlight::CurbReturnFilletRegionColor property

SettingsAlignment::SettingsDynamicAlignmentHighlight::CurbReturnFilletRegionLineweight property

SettingsAlignment::SettingsDynamicAlignmentHighlight::OffsetRegionColor property

SettingsAlignment::SettingsDynamicAlignmentHighlight::OffsetRegionLineweight property

SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentColor property

SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentLineweight property

SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentTrackerColor property

SettingsAlignment::SettingsDynamicAlignmentHighlight::ParentAlignmentTrackerLineweight property

SettingsAlignment::SettingsDynamicAlignmentHighlight::TransitionRegionColor property

SettingsAlignment::SettingsDynamicAlignmentHighlight::TransitionRegionLineweight property

SettingsAlignment::SettingsStationIndexing class

about SettingsAlignment::SettingsStationIndexing class

SettingsAlignment::SettingsStationIndexing::DefaultStationIndexIncrement property

SettingsAlignment::SettingsStyles class

about SettingsAlignment::SettingsStyles class

SettingsAlignment::SettingsStyles::AlignmentLabelSet property

SettingsAlignment::SettingsStyles::AlignmentStyle property

SettingsAlignment::SettingsStyles::CurveLabelStyle property

SettingsAlignment::SettingsStyles::LineLabelStyle property

SettingsAlignment::SettingsStyles::MarkerStyle property

SettingsAlignment::SettingsStyles::SpiralLabelStyle property

SettingsAlignment::SettingsStyles::StationOffsetLabelStyle property

SettingsAlignment::SettingsStyles::TangentIntersectLabelStyle property

SettingsAlignment::SettingsSuperelevationOptions class

about SettingsAlignment::SettingsSuperelevationOptions class

SettingsAlignment::SettingsSuperelevationOptions::CorridorType property

SettingsAlignment::SettingsSuperelevationOptions::CrossSectionShape property

SettingsAlignment::SettingsSuperelevationOptions::HighsideLocation property

SettingsAlignment::SettingsSuperelevationOptions::InsideShoulderMethod property

SettingsAlignment::SettingsSuperelevationOptions::NominalWidth property

SettingsAlignment::SettingsSuperelevationOptions::NormalLaneSlope property

SettingsAlignment::SettingsSuperelevationOptions::NormalShoulderSlope property

SettingsAlignment::SettingsSuperelevationOptions::OutsideShoulderMethod property

SettingsAlignment::SettingsSuperelevationOptions::StationRoundingOption property

SettingsAlignment::StationIndexing property

SettingsAlignment::StyleSettings property

SettingsAlignment::SuperelevationOptions property

SettingsAmbient class

about SettingsAmbient class

SettingsAmbient::Angle property

SettingsAmbient::Area property

SettingsAmbient::Coordinate property

SettingsAmbient::Dimension property

SettingsAmbient::Direction property

SettingsAmbient::Distance property

SettingsAmbient::Elevation property

SettingsAmbient::General property

SettingsAmbient::Grade property

SettingsAmbient::GradeSlope property

SettingsAmbient::GridCoordinate property

SettingsAmbient::Labeling property

SettingsAmbient::LatLong property

SettingsAmbient::SettingsAngle class

about SettingsAmbient::SettingsAngle class

SettingsAmbient::SettingsAngle::DropDecimalForWholeNumbers property

SettingsAmbient::SettingsAngle::DropLeadingZerosForDegrees property

SettingsAmbient::SettingsArea class

about SettingsAmbient::SettingsArea class

SettingsAmbient::SettingsCoordinate class

about SettingsAmbient::SettingsCoordinate class

SettingsAmbient::SettingsDimension class

about SettingsAmbient::SettingsDimension class

SettingsAmbient::SettingsDirection class

about SettingsAmbient::SettingsDirection class

SettingsAmbient::SettingsDirection::BearingQuadrant property

SettingsAmbient::SettingsDirection::Capitalization property

SettingsAmbient::SettingsDirection::Direction property

SettingsAmbient::SettingsDirection::DropDecimalForWholeNumbers property

SettingsAmbient::SettingsDirection::DropLeadingZerosForDegrees property

SettingsAmbient::SettingsDirection::MeasurementType property

SettingsAmbient::SettingsDistance class

about SettingsAmbient::SettingsDistance class

SettingsAmbient::SettingsElevation class

about SettingsAmbient::SettingsElevation class

SettingsAmbient::SettingsFormatNumber template

about SettingsAmbient::SettingsFormatNumber template

SettingsAmbient::SettingsFormatNumber::Format property

SettingsAmbient::SettingsGeneral class

about SettingsAmbient::SettingsGeneral class

SettingsAmbient::SettingsGeneral::DrivingDirection property

SettingsAmbient::SettingsGeneral::IndependentLayerOn property

SettingsAmbient::SettingsGeneral::NewEntityToolTipState property

SettingsAmbient::SettingsGeneral::PlottedUnitDisplay property

SettingsAmbient::SettingsGeneral::SaveCommandChangesToSettings property

SettingsAmbient::SettingsGeneral::ShowEventViewer property

SettingsAmbient::SettingsGeneral::ShowToolTips property

SettingsAmbient::SettingsGrade class

about SettingsAmbient::SettingsGrade class

SettingsAmbient::SettingsGradeSlope class

about SettingsAmbient::SettingsGradeSlope class

SettingsAmbient::SettingsGridCoordinate class

about SettingsAmbient::SettingsGridCoordinate class

SettingsAmbient::SettingsLabeling class

about SettingsAmbient::SettingsLabeling class

SettingsAmbient::SettingsLabeling::PromptMethod property

SettingsAmbient::SettingsLatLong class

about SettingsAmbient::SettingsLatLong class

SettingsAmbient::SettingsLatLong::Capitalization property

SettingsAmbient::SettingsLatLong::Direction property

SettingsAmbient::SettingsLatLong::DropDecimalForWholeNumbers property

SettingsAmbient::SettingsLatLong::DropLeadingZerosForDegrees property

SettingsAmbient::SettingsSlope class

about SettingsAmbient::SettingsSlope class

SettingsAmbient::SettingsSpeed class

about SettingsAmbient::SettingsSpeed class

SettingsAmbient::SettingsStation class

about SettingsAmbient::SettingsStation class

SettingsAmbient::SettingsStation::DropDecimalForWholeNumbers property

SettingsAmbient::SettingsStation::DropLeadingZerosRightOfStationCharacter property

SettingsAmbient::SettingsStation::MinimumDisplayWidth property

SettingsAmbient::SettingsStation::StationDelimiterCharacter property

SettingsAmbient::SettingsStation::StationDelimiterPosition property

SettingsAmbient::SettingsTransparentCommands class

about SettingsAmbient::SettingsTransparentCommands class

SettingsAmbient::SettingsTransparentCommands::PromptFor3DPoints property

SettingsAmbient::SettingsTransparentCommands::PromptForEastingThenNorthing property

SettingsAmbient::SettingsTransparentCommands::PromptForLongitudeThenLatitude property

SettingsAmbient::SettingsTransparentCommands::PromptForYBeforeX property

SettingsAmbient::SettingsUnitless class

about SettingsAmbient::SettingsUnitless class

SettingsAmbient::SettingsUnitlessNumber class

about SettingsAmbient::SettingsUnitlessNumber class

SettingsAmbient::SettingsUnitlessNumber::Precision property

SettingsAmbient::SettingsUnitlessNumber::Rounding property

SettingsAmbient::SettingsUnitlessNumber::Sign property

SettingsAmbient::SettingsUnitNumber template

about SettingsAmbient::SettingsUnitNumber template

SettingsAmbient::SettingsUnitNumber::Unit property

SettingsAmbient::SettingsVolume class

about SettingsAmbient::SettingsVolume class

SettingsAmbient::Slope property

SettingsAmbient::Speed property

SettingsAmbient::Station property

SettingsAmbient::TransparentCommands property

SettingsAmbient::TUnit template

about SettingsAmbient::TUnit template

SettingsAmbient::TUnit::Format property

SettingsAmbient::TUnit::Unit property

SettingsAmbient::Unitless property

SettingsAmbient::Volume property

SettingsAssembly class

about SettingsAssembly class

SettingsAssembly::NameFormat property

SettingsAssembly::SettingsNameFormat class

about SettingsAssembly::SettingsNameFormat class

SettingsAssembly::SettingsNameFormat::Assembly property

SettingsAssembly::SettingsNameFormat::Group property

SettingsAssembly::SettingsNameFormat::Offset property

SettingsAssembly::SettingsStyles class

about SettingsAssembly::SettingsStyles class

SettingsAssembly::SettingsStyles::Assembly property

SettingsAssembly::SettingsStyles::CodeSet property

SettingsAssembly::Styles property

SettingsBuildingSite class

about SettingsBuildingSite class

SettingsBuildingSite::NameFormat property

SettingsBuildingSite::SettingsNameFormat class

about SettingsBuildingSite::SettingsNameFormat class

SettingsBuildingSite::SettingsNameFormat::BuildingSite property

SettingsBuildingSite::SettingsStyles class

about SettingsBuildingSite::SettingsStyles class

SettingsBuildingSite::SettingsStyles::BuildingSite property

SettingsBuildingSite::Styles property

SettingsCmdAddAlignmentCurveTable class

about SettingsCmdAddAlignmentCurveTable class

SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation class

about SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation class

SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::SplitTable property

SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TableSpacing property

SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TableStyle property

SettingsCmdAddAlignmentCurveTable::SettingsCmdTableCreation::TileDirection property

SettingsCmdAddAlignmentCurveTable::TableCreation property

SettingsCmdAddAlignmentLineTable class

about SettingsCmdAddAlignmentLineTable class

SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation class

about SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation class

SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::SplitTable property

SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TableSpacing property

SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TableStyle property

SettingsCmdAddAlignmentLineTable::SettingsCmdTableCreation::TileDirection property

SettingsCmdAddAlignmentLineTable::TableCreation property

SettingsCmdAddAlignmentOffLbl class

about SettingsCmdAddAlignmentOffLbl class

SettingsCmdAddAlignmentOffXYLbl class

about SettingsCmdAddAlignmentOffXYLbl class

SettingsCmdAddAlignmentSegmentTable class

about SettingsCmdAddAlignmentSegmentTable class

SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation class

about SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation class

SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::SplitTable property

SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TableSpacing property

SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TableStyle property

SettingsCmdAddAlignmentSegmentTable::SettingsCmdTableCreation::TileDirection property

SettingsCmdAddAlignmentSegmentTable::TableCreation property

SettingsCmdAddAlignmentSpiralTable class

about SettingsCmdAddAlignmentSpiralTable class

SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation class

about SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation class

SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::SplitTable property

SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TableSpacing property

SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TableStyle property

SettingsCmdAddAlignmentSpiralTable::SettingsCmdTableCreation::TileDirection property

SettingsCmdAddAlignmentSpiralTable::TableCreation property

SettingsCmdAddAlignSegLbl class

about SettingsCmdAddAlignSegLbl class

SettingsCmdAddAlignSegLbls class

about SettingsCmdAddAlignSegLbls class

SettingsCmdAddAlignTagentLbl class

about SettingsCmdAddAlignTagentLbl class

SettingsCmdAddAlignTagentLbls class

about SettingsCmdAddAlignTagentLbls class

SettingsCmdAddContourLabeling class

about SettingsCmdAddContourLabeling class

SettingsCmdAddContourLabelingGroup class

about SettingsCmdAddContourLabelingGroup class

SettingsCmdAddContourLabelingGroup::AddContourLabeling property

SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling class

about SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling class

SettingsCmdAddContourLabelingGroup::SettingsCmdAddContourLabeling::IntervalAlongContour property

SettingsCmdAddContourLabelingSingle class

about SettingsCmdAddContourLabelingSingle class

SettingsCmdAddIntersectionLabel class

about SettingsCmdAddIntersectionLabel class

SettingsCmdAddMaterialVolumeTable class

about SettingsCmdAddMaterialVolumeTable class

SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation class

about SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation class

SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::SplitTable property

SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TableSpacing property

SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TableStyle property

SettingsCmdAddMaterialVolumeTable::SettingsCmdTableCreation::TileDirection property

SettingsCmdAddMaterialVolumeTable::TableCreation property

SettingsCmdAddNetworkPartPlanLabel class

about SettingsCmdAddNetworkPartPlanLabel class

SettingsCmdAddNetworkPartProfLabel class

about SettingsCmdAddNetworkPartProfLabel class

SettingsCmdAddNetworkPartSectLabel class

about SettingsCmdAddNetworkPartSectLabel class

SettingsCmdAddNetworkPartsToProf class

about SettingsCmdAddNetworkPartsToProf class

SettingsCmdAddNetworkPipeTable class

about SettingsCmdAddNetworkPipeTable class

SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation class

about SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation class

SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::SplitTable property

SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TableSpacing property

SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TableStyle property

SettingsCmdAddNetworkPipeTable::SettingsCmdTableCreation::TileDirection property

SettingsCmdAddNetworkPipeTable::TableCreation property

SettingsCmdAddNetworkPlanLabels class

about SettingsCmdAddNetworkPlanLabels class

SettingsCmdAddNetworkProfLabels class

about SettingsCmdAddNetworkProfLabels class

SettingsCmdAddNetworkSectLabels class

about SettingsCmdAddNetworkSectLabels class

SettingsCmdAddNetworkStructTable class

about SettingsCmdAddNetworkStructTable class

SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation class

about SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation class

SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::SplitTable property

SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TableSpacing property

SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TableStyle property

SettingsCmdAddNetworkStructTable::SettingsCmdTableCreation::TileDirection property

SettingsCmdAddNetworkStructTable::TableCreation property

SettingsCmdAddNoteLabel class

about SettingsCmdAddNoteLabel class

SettingsCmdAddParcelAreaLabel class

about SettingsCmdAddParcelAreaLabel class

SettingsCmdAddParcelCurveTable class

about SettingsCmdAddParcelCurveTable class

SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation class

about SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation class

SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::SplitTable property

SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TableSpacing property

SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TableStyle property

SettingsCmdAddParcelCurveTable::SettinsCmdTableCreation::TileDirection property

SettingsCmdAddParcelCurveTable::TableCreation property

SettingsCmdAddParcelLineLabel class

about SettingsCmdAddParcelLineLabel class

SettingsCmdAddParcelLineTable class

about SettingsCmdAddParcelLineTable class

SettingsCmdAddParcelLineTable::SettinsCmdTableCreation class

about SettingsCmdAddParcelLineTable::SettinsCmdTableCreation class

SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::SplitTable property

SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TableSpacing property

SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TableStyle property

SettingsCmdAddParcelLineTable::SettinsCmdTableCreation::TileDirection property

SettingsCmdAddParcelLineTable::TableCreation property

SettingsCmdAddParcelSegmentLabels class

about SettingsCmdAddParcelSegmentLabels class

SettingsCmdAddParcelSegmentLabels::Options property

SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions class

about SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions class

SettingsCmdAddParcelSegmentLabels::SettingsCmdOptions::LabelingDirection property

SettingsCmdAddParcelSegmentTable class

about SettingsCmdAddParcelSegmentTable class

SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation class

about SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation class

SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::SplitTable property

SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TableSpacing property

SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TableStyle property

SettingsCmdAddParcelSegmentTable::SettinsCmdTableCreation::TileDirection property

SettingsCmdAddParcelSegmentTable::TableCreation property

SettingsCmdAddParcelTable class

about SettingsCmdAddParcelTable class

SettingsCmdAddParcelTable::SettinsCmdTableCreation class

about SettingsCmdAddParcelTable::SettinsCmdTableCreation class

SettingsCmdAddParcelTable::SettinsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddParcelTable::SettinsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddParcelTable::SettinsCmdTableCreation::SplitTable property

SettingsCmdAddParcelTable::SettinsCmdTableCreation::TableSpacing property

SettingsCmdAddParcelTable::SettinsCmdTableCreation::TableStyle property

SettingsCmdAddParcelTable::SettinsCmdTableCreation::TileDirection property

SettingsCmdAddParcelTable::TableCreation property

SettingsCmdAddPointTable class

about SettingsCmdAddPointTable class

SettingsCmdAddPointTable::SettinsCmdTableCreation class

about SettingsCmdAddPointTable::SettinsCmdTableCreation class

SettingsCmdAddPointTable::SettinsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddPointTable::SettinsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddPointTable::SettinsCmdTableCreation::SplitTable property

SettingsCmdAddPointTable::SettinsCmdTableCreation::TableSpacing property

SettingsCmdAddPointTable::SettinsCmdTableCreation::TableStyle property

SettingsCmdAddPointTable::SettinsCmdTableCreation::TileDirection property

SettingsCmdAddPointTable::TableCreation property

SettingsCmdAddProfileViewDepthLbl class

about SettingsCmdAddProfileViewDepthLbl class

SettingsCmdAddProfileViewStaElevLbl class

about SettingsCmdAddProfileViewStaElevLbl class

SettingsCmdAddSectionViewGradeLbl class

about SettingsCmdAddSectionViewGradeLbl class

SettingsCmdAddSectionViewOffElevLbl class

about SettingsCmdAddSectionViewOffElevLbl class

SettingsCmdAddSegmentLabel class

about SettingsCmdAddSegmentLabel class

SettingsCmdAddSegmentLabels class

about SettingsCmdAddSegmentLabels class

SettingsCmdAddSpanningPipePlanLabel class

about SettingsCmdAddSpanningPipePlanLabel class

SettingsCmdAddSpanningPipeProfLabel class

about SettingsCmdAddSpanningPipeProfLabel class

SettingsCmdAddSpotElevLabelsOnGrid class

about SettingsCmdAddSpotElevLabelsOnGrid class

SettingsCmdAddSurfaceBoundaries class

about SettingsCmdAddSurfaceBoundaries class

SettingsCmdAddSurfaceBoundaries::DataOptions property

SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions class

about SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions class

SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::BoundaryType property

SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::MidOrdinateDistance property

SettingsCmdAddSurfaceBoundaries::SettingsCmdAddDataOptions::NonDestructive property

SettingsCmdAddSurfaceBreaklines class

about SettingsCmdAddSurfaceBreaklines class

SettingsCmdAddSurfaceBreaklines::DataOptions property

SettingsCmdAddSurfaceContours class

about SettingsCmdAddSurfaceContours class

SettingsCmdAddSurfaceContours::AddDataOptions property

SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions class

about SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions class

SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::MidOrdinateDistance property

SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::SupplementingDistance property

SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::WeedingAngle property

SettingsCmdAddSurfaceContours::SettingsCmdAddDataOptions::WeedingDistance property

SettingsCmdAddSurfaceDemFile class

about SettingsCmdAddSurfaceDemFile class

SettingsCmdAddSurfaceDemFile::ImportOptions property

SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions class

about SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions class

SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions::NullElevation property

SettingsCmdAddSurfaceDemFile::SettingsCmdImportOptions::UseCustomNullElevation property

SettingsCmdAddSurfaceDrawingObjects class

about SettingsCmdAddSurfaceDrawingObjects class

SettingsCmdAddSurfaceDrawingObjects::DataOptions property

SettingsCmdAddSurfaceSlopeLabel class

about SettingsCmdAddSurfaceSlopeLabel class

SettingsCmdAddSurfaceSpotElevLabel class

about SettingsCmdAddSurfaceSpotElevLabel class

SettingsCmdAddTotalVolumeTable class

about SettingsCmdAddTotalVolumeTable class

SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation class

about SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation class

SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::SplitTable property

SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TableSpacing property

SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TableStyle property

SettingsCmdAddTotalVolumeTable::SettingsCmdTableCreation::TileDirection property

SettingsCmdAddTotalVolumeTable::TableCreation property

SettingsCmdAddWidening class

about SettingsCmdAddWidening class

SettingsCmdAddWidening::SettingsCmdWideningOptions class

about SettingsCmdAddWidening::SettingsCmdWideningOptions class

SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve1 property

SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve2 property

SettingsCmdAddWidening::SettingsCmdWideningOptions::RadiusForCurve3 property

SettingsCmdAddWidening::SettingsCmdWideningOptions::TaperInputType property

SettingsCmdAddWidening::SettingsCmdWideningOptions::TaperRatio property

SettingsCmdAddWidening::SettingsCmdWideningOptions::TransitionLength property

SettingsCmdAddWidening::SettingsCmdWideningOptions::TransitionType property

SettingsCmdAddWidening::SettingsCmdWideningOptions::WideningOffset property

SettingsCmdAddWidening::SettingsCmdWideningOptions::WideningSegmentLength property

SettingsCmdAddWidening::WideningOptions property

SettingsCmdAssignPayItemToArea class

about SettingsCmdAssignPayItemToArea class

SettingsCmdAssignPayItemToArea::AssignPayItemToAreaOption property

SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions class

about SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions class

SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::ColorForHatch property

SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::LayerForHatch property

SettingsCmdAssignPayItemToArea::SettingsCmdAssignPayItemToAreaOptions::UseAcadLayerAndColor property

SettingsCmdCatchmentArea class

about SettingsCmdCatchmentArea class

SettingsCmdCatchmentArea::Layer property

SettingsCmdCatchmentArea::Marker property

SettingsCmdCatchmentArea::MarkerStyle property

SettingsCmdCatchmentArea::ObjectType property

SettingsCmdComputeMaterials class

about SettingsCmdComputeMaterials class

SettingsCmdComputeMaterials::DefineMaterialOption property

SettingsCmdComputeMaterials::SettingsCmdDefineMaterial class

about SettingsCmdComputeMaterials::SettingsCmdDefineMaterial class

SettingsCmdComputeMaterials::SettingsCmdDefineMaterial::ApplyCurveCorrection property

SettingsCmdComputeMaterials::SettingsCmdDefineMaterial::CurveCorrectionTolerance property

SettingsCmdConvertPointstoSdskPoints class

about SettingsCmdConvertPointstoSdskPoints class

SettingsCmdConvertPointstoSdskPoints::Layer property

SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer class

about SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer class

SettingsCmdConvertPointstoSdskPoints::SettingsCmdLayer::Layer property

SettingsCmdCorridorExtractSurfaces class

about SettingsCmdCorridorExtractSurfaces class

SettingsCmdCreateAlignFromCorridor class

about SettingsCmdCreateAlignFromCorridor class

SettingsCmdCreateAlignFromCorridor::AlignmentTypeOption property

SettingsCmdCreateAlignFromCorridor::CriteriaBasedDesignOptions property

SettingsCmdCreateAlignFromCorridor::ProfileCreationOption property

SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption class

about SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption class

SettingsCmdCreateAlignFromCorridor::SettingsCmdAlignmentTypeOption::AlignmentType property

SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions class

about SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions class

SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DefaultDesignCheckSet property

SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DesignSpeed property

SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DesignSpeedLookupMethod property

SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::RadiusLookupMethod property

SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseCriteriaBasedDesignOption property

SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignChecksOption property

SettingsCmdCreateAlignFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignCriteriaFileOption property

SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption class

about SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption class

SettingsCmdCreateAlignFromCorridor::SettingsCmdProfileCreationOption::CreateProfileFromCorridor property

SettingsCmdCreateAlignFromNetwork class

about SettingsCmdCreateAlignFromNetwork class

SettingsCmdCreateAlignFromNetwork::AlignmentTypeOption property

SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption class

about SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption class

SettingsCmdCreateAlignFromNetwork::SettingsCmdAlignmentTypeOption::AlignmentType property

SettingsCmdCreateAlignmentEntities class

about SettingsCmdCreateAlignmentEntities class

SettingsCmdCreateAlignmentEntities::AlignmentTypeOption property

SettingsCmdCreateAlignmentEntities::CreateFromEntities property

SettingsCmdCreateAlignmentLayout class

about SettingsCmdCreateAlignmentLayout class

SettingsCmdCreateAlignmentLayout::AlignmentTypeOption property

SettingsCmdCreateAlignmentLayout::CurveAndSpiralSettings property

SettingsCmdCreateAlignmentLayout::CurveTessellationOption property

SettingsCmdCreateAlignmentLayout::RegressionGraphOption property

SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption class

about SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption class

SettingsCmdCreateAlignmentLayout::SettingsCmdAlignmentTypeOption::AlignmentType property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings class

about SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings class

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::CurveRadiusForSCSGroup property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralInAValue property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralInLength property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralOutAValue property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralOutLength property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::SpiralType property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseCurve property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseSpiralIn property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveAndSpiralSettings::UseSpiralOut property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption class

about SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption class

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption::MidOrdinateTolerance property

SettingsCmdCreateAlignmentLayout::SettingsCmdCurveTessellationOption::TessellateCurve property

SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption class

about SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption class

SettingsCmdCreateAlignmentLayout::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph property

SettingsCmdCreateAlignmentReference class

about SettingsCmdCreateAlignmentReference class

SettingsCmdCreateArcByBestFit class

about SettingsCmdCreateArcByBestFit class

SettingsCmdCreateArcByBestFit::CurveTessellationOption property

SettingsCmdCreateArcByBestFit::RegressionGraphOption property

SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption class

about SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption class

SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance property

SettingsCmdCreateArcByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve property

SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption class

about SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption class

SettingsCmdCreateArcByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph property

SettingsCmdCreateAssembly class

about SettingsCmdCreateAssembly class

SettingsCmdCreateAssemblyTool class

about SettingsCmdCreateAssemblyTool class

SettingsCmdCreateCorridor class

about SettingsCmdCreateCorridor class

SettingsCmdCreateCorridor::AssemblyInsertion property

SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion class

about SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion class

SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongCurves property

SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves property

SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals property

SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongTangents property

SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints property

SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::ProfileGeometryPoints property

SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::ProfileHighLowPoints property

SettingsCmdCreateCorridor::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints property

SettingsCmdCreateFeatureLineFromAlign class

about SettingsCmdCreateFeatureLineFromAlign class

SettingsCmdCreateFeatureLineFromAlign::FeatureLineCreation property

SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation class

about SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation class

SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::CreateDynamicLink property

SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::LayerSetting property

SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::MidOrdinateDistance property

SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::SpiralTessellationFactor property

SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::UseFeatureLineName property

SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::UseFeatureLineStyle property

SettingsCmdCreateFeatureLineFromAlign::SettingsCmdFeatureLineCreation::WeedPoints property

SettingsCmdCreateFeatureLines class

about SettingsCmdCreateFeatureLines class

SettingsCmdCreateFeatureLines::FeatureLineCreation property

SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation class

about SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation class

SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::AssignElevations property

SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::ElevationSource property

SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::EraseExistingEntities property

SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::IncludeMidElevationBreaks property

SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::LayerSetting property

SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::UseFeatureLineName property

SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::UseFeatureLineStyle property

SettingsCmdCreateFeatureLines::SettingsCmdFeatureLineCreation::WeedPoints property

SettingsCmdCreateGrading class

about SettingsCmdCreateGrading class

SettingsCmdCreateGrading::GradingCreation property

SettingsCmdCreateGrading::SettingsCmdGradingCreation class

about SettingsCmdCreateGrading::SettingsCmdGradingCreation class

SettingsCmdCreateGrading::SettingsCmdGradingCreation::TransitionRegionLength property

SettingsCmdCreateGradingGroup class

about SettingsCmdCreateGradingGroup class

SettingsCmdCreateGradingGroup::GradingGroupCreation property

SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation class

about SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation class

SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::GradingSurfaceCreation property

SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceConeTessellationAngle property

SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceStyle property

SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::SurfaceTessellationIncrement property

SettingsCmdCreateGradingGroup::SettingsCmdGradingGroupCreation::UseGroupName property

SettingsCmdCreateInterferenceCheck class

about SettingsCmdCreateInterferenceCheck class

SettingsCmdCreateInterferenceCheck::InterferenceCriteria property

SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria class

about SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria class

SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::Apply3DProximityCheck property

SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::Distance property

SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::ScaleFactor property

SettingsCmdCreateInterferenceCheck::SettingsCmdInterferenceCriteria::UseDistanceOrScaleFactor property

SettingsCmdCreateIntersection class

about SettingsCmdCreateIntersection class

SettingsCmdCreateIntersection::AssemblyInsertion property

SettingsCmdCreateIntersection::CrossSlopes property

SettingsCmdCreateIntersection::CurbReturnParameters property

SettingsCmdCreateIntersection::CurbReturnProfileRules property

SettingsCmdCreateIntersection::IntersectionOptions property

SettingsCmdCreateIntersection::Offsets property

SettingsCmdCreateIntersection::SecondaryRoadProfileRules property

SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion class

about SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion class

SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongCurves property

SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves property

SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals property

SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::FrequencyAlongTangents property

SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints property

SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::ProfileGeometryPoints property

SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::ProfileHighLowPoints property

SettingsCmdCreateIntersection::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints property

SettingsCmdCreateIntersection::SettingsCmdCrossSlopes class

about SettingsCmdCreateIntersection::SettingsCmdCrossSlopes class

SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::PrimaryRoadLeftCrossSlope property

SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::PrimaryRoadRightCrossSlope property

SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::SecondaryRoadLeftCrossSlope property

SettingsCmdCreateIntersection::SettingsCmdCrossSlopes::SecondaryRoadRightCrossSlope property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters class

about SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters class

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::ChamferFilletLengthAlongIncomingLane property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::ChamferFilletLengthAlongOutgoingLane property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::CircularFilletRadius property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::CurbReturnType property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::LengthOfCurve1 property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::LengthOfCurve3 property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve1 property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve2 property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnParameters::RadiusOfCurve3 property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules class

about SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules class

SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::DefineCurbReturnProfileBy property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::ExtendProfileAlongIncomingLane property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::ExtendProfileAlongOutgoingLane property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::LengthToExtendAlongIncomingLane property

SettingsCmdCreateIntersection::SettingsCmdCurbReturnProfileRules::LengthToExtendAlongOutgoingLane property

SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions class

about SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions class

SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateCurbReturnAlignments property

SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateCurbReturnProfiles property

SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::CreateIntersectionCorridors property

SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::IntersectionType property

SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::PrimaryRoadDefaultExitAndEntryLength property

SettingsCmdCreateIntersection::SettingsCmdIntersectionOptions::SecondaryRoadDefaultExitAndEntryLength property

SettingsCmdCreateIntersection::SettingsCmdOffsets class

about SettingsCmdCreateIntersection::SettingsCmdOffsets class

SettingsCmdCreateIntersection::SettingsCmdOffsets::OffsetLengthOptions property

SettingsCmdCreateIntersection::SettingsCmdOffsets::PrimaryRoadLeftOffset property

SettingsCmdCreateIntersection::SettingsCmdOffsets::PrimaryRoadRightOffset property

SettingsCmdCreateIntersection::SettingsCmdOffsets::SecondaryRoadLeftOffset property

SettingsCmdCreateIntersection::SettingsCmdOffsets::SecondaryRoadRightOffset property

SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules class

about SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules class

SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::ApplyGradeRules property

SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::DistanceRuleToAdjusttheGrade property

SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::DistanceValue property

SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::MaximumGrade property

SettingsCmdCreateIntersection::SettingsCmdSecondaryRoadProfileRules::MaximumGradeChange property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters class

about SettingsCmdCreateIntersection::SettingsCmdWideningParameters class

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::LinearTransitionType property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusofCurve1 property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusofCurve2 property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::RadiusOfReverseCurve property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TaperRation property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TransitionLength property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::TransitionType property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WidenedOffset property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningAtIncomingLane property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningAtOutgoingLane property

SettingsCmdCreateIntersection::SettingsCmdWideningParameters::WideningSegmentLength property

SettingsCmdCreateIntersection::WideningParameters property

SettingsCmdCreateLineByBestFit class

about SettingsCmdCreateLineByBestFit class

SettingsCmdCreateLineByBestFit::CurveTessellationOption property

SettingsCmdCreateLineByBestFit::RegressionGraphOption property

SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption class

about SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption class

SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance property

SettingsCmdCreateLineByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve property

SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption class

about SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption class

SettingsCmdCreateLineByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph property

SettingsCmdCreateMassHaulDiagram class

about SettingsCmdCreateMassHaulDiagram class

SettingsCmdCreateMassHaulDiagram::MassHaulCreation property

SettingsCmdCreateMultipleProfileView class

about SettingsCmdCreateMultipleProfileView class

SettingsCmdCreateMultipleProfileView::MultipleProfileViewCreation property

SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation class

about SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation class

SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ColumnSpacing property

SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::DefaultProfileViewHeight property

SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::DefaultProfileViewLength property

SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::PlotPattern property

SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ProfileViewDatumBy property

SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::ProfileViewsInRowOrColumn property

SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::RowSpacing property

SettingsCmdCreateMultipleProfileView::SettingsCmdMultipleProfileViewCreation::StartCorner property

SettingsCmdCreateMultipleSectionView class

about SettingsCmdCreateMultipleSectionView class

SettingsCmdCreateMultipleSectionView::MultipleSectionViewCreation property

SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation class

about SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation class

SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation::SectionViewHeight property

SettingsCmdCreateMultipleSectionView::SettingsCmdMultipleSectionViewCreation::SpecifyMultipleSectionViewStationRange property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation class

about SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation class

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaterialVolumeTableStyle property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::SectionViewAnchor property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::SplitTable property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableAnchor property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableLayout property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TableSpacing property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TileDirection property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::TotalVolumeTableStyle property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::XOffset property

SettingsCmdCreateMultipleSectionView::SettingsCmdTableCreation::YOffset property

SettingsCmdCreateMultipleSectionView::TableCreation property

SettingsCmdCreateNetwork class

about SettingsCmdCreateNetwork class

SettingsCmdCreateNetwork::DefaultLayoutCommand property

SettingsCmdCreateNetwork::LabelNewParts property

SettingsCmdCreateNetwork::SettingsCmdLabelNewParts class

about SettingsCmdCreateNetwork::SettingsCmdLabelNewParts class

SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::PipeInPlan property

SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::PipeProfile property

SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::StructureInPlan property

SettingsCmdCreateNetwork::SettingsCmdLabelNewParts::StructureProfile property

SettingsCmdCreateNetworkFromObject class

about SettingsCmdCreateNetworkFromObject class

SettingsCmdCreateNetworkPartsList class

about SettingsCmdCreateNetworkPartsList class

SettingsCmdCreateNetworkPartsListFull class

about SettingsCmdCreateNetworkPartsListFull class

SettingsCmdCreateNetworkReference class

about SettingsCmdCreateNetworkReference class

SettingsCmdCreateOffsetAlignment class

about SettingsCmdCreateOffsetAlignment class

SettingsCmdCreateOffsetAlignment::OffsetAlignmentOptions property

SettingsCmdCreateParabolaByBestFit class

about SettingsCmdCreateParabolaByBestFit class

SettingsCmdCreateParabolaByBestFit::CurveTessellationOption property

SettingsCmdCreateParabolaByBestFit::RegressionGraphOption property

SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption class

about SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption class

SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption::MidOrdinateTolerance property

SettingsCmdCreateParabolaByBestFit::SettingsCmdCurveTessellationOption::TessellateCurve property

SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption class

about SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption class

SettingsCmdCreateParabolaByBestFit::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph property

SettingsCmdCreateParcelByLayout class

about SettingsCmdCreateParcelByLayout class

SettingsCmdCreateParcelByLayout::AutomaticLayout property

SettingsCmdCreateParcelByLayout::ConvertFromEntities property

SettingsCmdCreateParcelByLayout::ParcelSizing property

SettingsCmdCreateParcelByLayout::PreviewGraphics property

SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout class

about SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout class

SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout::AutomaticMode property

SettingsCmdCreateParcelByLayout::SettingsCmdAutomaticLayout::RemainderDistributionType property

SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities class

about SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities class

SettingsCmdCreateParcelByLayout::SettingsCmdConvertFromEntities::AutoAddSegmentLabel property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing class

about SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing class

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::FrontageOffset property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MaximumDepth property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumArea property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumDepth property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumFrontage property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::MinimumWidth property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::SelectionMethod property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::SolutionPreference property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::UseMaximumDepth property

SettingsCmdCreateParcelByLayout::SettingsCmdParcelSizing::UseMinimumFrontageAtOffset property

SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics class

about SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics class

SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::FrontageColor property

SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::FrontageOffsetColor property

SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumDepthColor property

SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumFrontageColor property

SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::MinimumWidthColor property

SettingsCmdCreateParcelByLayout::SettingsCmdPreviewGraphics::NewParcelColor property

SettingsCmdCreateParcelFromObjects class

about SettingsCmdCreateParcelFromObjects class

SettingsCmdCreateParcelFromObjects::ConvertFromEntities property

SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities class

about SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities class

SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities::AutoAddSegmentLabels property

SettingsCmdCreateParcelFromObjects::SettingsCmdConvertFromEntities::EraseAllExistingEntities property

SettingsCmdCreateParcelROW class

about SettingsCmdCreateParcelROW class

SettingsCmdCreateParcelROW::CleanupAtAlignmentIntersections property

SettingsCmdCreateParcelROW::CleanupAtParcelBoundaries property

SettingsCmdCreateParcelROW::CreateParcelRightOfWay property

SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections class

about SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections class

SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections::CleanupMethodFillet property

SettingsCmdCreateParcelROW::SettingsCmdCleanupAtAlignmentIntersections::FilletRadiusAtAlignmentIntersections property

SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries class

about SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries class

SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries::CleanupMethodFillet property

SettingsCmdCreateParcelROW::SettingsCmdCleanupAtParcelBoundaries::FilletRadiusAtParcelBoundaryIntersections property

SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay class

about SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay class

SettingsCmdCreateParcelROW::SettingsCmdCreateParcelRightOfWay::OffsetFromAlignment property

SettingsCmdCreatePointGroup class

about SettingsCmdCreatePointGroup class

SettingsCmdCreatePoints class

about SettingsCmdCreatePoints class

SettingsCmdCreatePoints::Layer property

SettingsCmdCreatePoints::PointsCreation property

SettingsCmdCreatePoints::SettingsCmdLayer class

about SettingsCmdCreatePoints::SettingsCmdLayer class

SettingsCmdCreatePoints::SettingsCmdLayer::Layer property

SettingsCmdCreatePoints::SettingsCmdPointsCreation class

about SettingsCmdCreatePoints::SettingsCmdPointsCreation class

SettingsCmdCreatePoints::SettingsCmdPointsCreation::DefaultDescription property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::DefaultElevation property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::DisableDescriptionKeys property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::EchoCoordinatesToCommandLine property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::GeographicCoordinates property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::GridCoordinates property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::LocalCoordinates property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::MatchOnDescriptionParameters property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForDescriptions property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForElevations property

SettingsCmdCreatePoints::SettingsCmdPointsCreation::PromptForPointNames property

SettingsCmdCreatePointsFromCorridor class

about SettingsCmdCreatePointsFromCorridor class

SettingsCmdCreatePolylineFromCorridor class

about SettingsCmdCreatePolylineFromCorridor class

SettingsCmdCreateProfileFromCorridor class

about SettingsCmdCreateProfileFromCorridor class

SettingsCmdCreateProfileFromCorridor::CriteriaBasedDesignOptions property

SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions class

about SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions class

SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::DefaultDesignCheckSet property

SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignChecksOption property

SettingsCmdCreateProfileFromCorridor::SettingsCmdCriteriaBasedDesignOptions::UseDesignCriteriaFileOption property

SettingsCmdCreateProfileFromFile class

about SettingsCmdCreateProfileFromFile class

SettingsCmdCreateProfileFromSurface class

about SettingsCmdCreateProfileFromSurface class

SettingsCmdCreateProfileFromSurface::Geometry property

SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry class

about SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry class

SettingsCmdCreateProfileFromSurface::SettingsCmdGeometry::ProfileSampleOffsetsCommandSetting property

SettingsCmdCreateProfileLayout class

about SettingsCmdCreateProfileLayout class

SettingsCmdCreateProfileLayout::CurveTessellationOption property

SettingsCmdCreateProfileLayout::RegressionGraphOption property

SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption class

about SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption class

SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption::MidOrdinateTolerance property

SettingsCmdCreateProfileLayout::SettingsCmdCurveTessellationOption::TessellateCurve property

SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption class

about SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption class

SettingsCmdCreateProfileLayout::SettingsCmdRegressionGraphOption::SplineFitForRegressionAnalysisGraph property

SettingsCmdCreateProfileReference class

about SettingsCmdCreateProfileReference class

SettingsCmdCreateProfileView class

about SettingsCmdCreateProfileView class

SettingsCmdCreateQuickProfile class

about SettingsCmdCreateQuickProfile class

SettingsCmdCreateQuickProfile::QuickProfile property

SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile class

about SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile class

SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile::Draw3DEntityProfile property

SettingsCmdCreateQuickProfile::SettingsCmdQuickProfile::SelectAllSurfaces property

SettingsCmdCreateSampleLines class

about SettingsCmdCreateSampleLines class

SettingsCmdCreateSampleLines::AdditionalSampleControls property

SettingsCmdCreateSampleLines::Miscellaneous property

SettingsCmdCreateSampleLines::SamplingIncrements property

SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls class

about SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls class

SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtHorizontalGeometryPoints property

SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtRangeEnd property

SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtRangeStart property

SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::AtSuperelevationCriticalStations property

SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::EndRangeAtAlignmentEnd property

SettingsCmdCreateSampleLines::SettingsCmdAdditionalSampleControls::StartRangeAtAlignmentStart property

SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous class

about SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous class

SettingsCmdCreateSampleLines::SettingsCmdMiscellaneous::LockTostation property

SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements class

about SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements class

SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongCurves property

SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongSpirals property

SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::IncrementAlongTangents property

SettingsCmdCreateSampleLines::SettingsCmdSamplingIncrements::UseSamplingIncrements property

SettingsCmdCreateSampleLines::SettingsCmdSwathWidths class

about SettingsCmdCreateSampleLines::SettingsCmdSwathWidths class

SettingsCmdCreateSampleLines::SettingsCmdSwathWidths::LeftSwathWidth property

SettingsCmdCreateSampleLines::SettingsCmdSwathWidths::RightSwathWidth property

SettingsCmdCreateSampleLines::SwathWidths property

SettingsCmdCreateSectionView class

about SettingsCmdCreateSectionView class

SettingsCmdCreateSectionView::SettingsCmdTableCreation class

about SettingsCmdCreateSectionView::SettingsCmdTableCreation class

SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaterialVolumeTableStyle property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaximumNumberOfRows property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::MaximumTablesPerStack property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::SectionViewAnchor property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::SplitTable property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableAnchor property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableLayout property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::TableSpacing property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::TileDirection property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::TotalVolumeTableStyle property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::XOffset property

SettingsCmdCreateSectionView::SettingsCmdTableCreation::YOffset property

SettingsCmdCreateSectionView::TableCreation property

SettingsCmdCreateSheets class

about SettingsCmdCreateSheets class

SettingsCmdCreateSheets::SettingsCmdSheetCreation class

about SettingsCmdCreateSheets::SettingsCmdSheetCreation class

SettingsCmdCreateSheets::SettingsCmdSheetCreation::AddNetworkLabels property

SettingsCmdCreateSheets::SettingsCmdSheetCreation::AddToVault property

SettingsCmdCreateSheets::SettingsCmdSheetCreation::AlignNorthArrow property

SettingsCmdCreateSheets::SettingsCmdSheetCreation::AlignProfileAndPlanViewType property

SettingsCmdCreateSheets::SettingsCmdSheetCreation::ExistingSheetSetName property

SettingsCmdCreateSheets::SettingsCmdSheetCreation::NorthArrowBlockName property

SettingsCmdCreateSheets::SettingsCmdSheetCreation::NumberOfLayoutsPerDrawing property

SettingsCmdCreateSheets::SettingsCmdSheetCreation::SheetCreateMethod property

SettingsCmdCreateSheets::SettingsCmdSheetCreation::UseExistingSheetSet property

SettingsCmdCreateSheets::SheetCreation property

SettingsCmdCreateSimpleCorridor class

about SettingsCmdCreateSimpleCorridor class

SettingsCmdCreateSimpleCorridor::AssemblyInsertion property

SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion class

about SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion class

SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongCurves property

SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongProfileCurves property

SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongSpirals property

SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::FrequencyAlongTangents property

SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::HorizontalGeometryPoints property

SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::ProfileGeometryPoints property

SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::ProfileHighLowPoints property

SettingsCmdCreateSimpleCorridor::SettingsCmdAssemblyInsertion::SuperelevationCriticalPoints property

SettingsCmdCreateSite class

about SettingsCmdCreateSite class

SettingsCmdCreateSite::Alignment property

SettingsCmdCreateSite::FeatureLine property

SettingsCmdCreateSite::Parcel property

SettingsCmdCreateSite::SettingsCmdAlignment class

about SettingsCmdCreateSite::SettingsCmdAlignment class

SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentCurveNextAutomaticTagCounter property

SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentCurveNextManualTagCounter property

SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentLineNextAutomaticTagCounter property

SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentLineNextManualTagCounter property

SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentSpiralNextAutomaticTagCounter property

SettingsCmdCreateSite::SettingsCmdAlignment::AlignmentSpiralNextManualTagCounter property

SettingsCmdCreateSite::SettingsCmdFeatureLine class

about SettingsCmdCreateSite::SettingsCmdFeatureLine class

SettingsCmdCreateSite::SettingsCmdFeatureLine::FeatureLineStyle property

SettingsCmdCreateSite::SettingsCmdParcel class

about SettingsCmdCreateSite::SettingsCmdParcel class

SettingsCmdCreateSite::SettingsCmdParcel::ParcelCurveNextAutomaticTagCounter property

SettingsCmdCreateSite::SettingsCmdParcel::ParcelCurveNextManualTagCounter property

SettingsCmdCreateSite::SettingsCmdParcel::ParcelLineNextAutomaticTagCounter property

SettingsCmdCreateSite::SettingsCmdParcel::ParcelLineNextManualTagCounter property

SettingsCmdCreateSite::SettingsCmdParcel::ParcelNextAutomaticAreaCounter property

SettingsCmdCreateSite::SettingsCmdParcel::ParcelNextManualAreaCounter property

SettingsCmdCreateSubassemblyTool class

about SettingsCmdCreateSubassemblyTool class

SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions class

about SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions class

SettingsCmdCreateSubassemblyTool::SettingsCmdSubassemblyOptions::CurrentSide property

SettingsCmdCreateSubassemblyTool::SubassemblyOptions property

SettingsCmdCreateSubFromPline class

about SettingsCmdCreateSubFromPline class

SettingsCmdCreateSubFromPline::CreateFromEntities property

SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities class

about SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities class

SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities::LinkCreation property

SettingsCmdCreateSubFromPline::SettingsCmdCreateFromEntities::MidOrdinateDistance property

SettingsCmdCreateSurface class

about SettingsCmdCreateSurface class

SettingsCmdCreateSurface::BuildOptions property

SettingsCmdCreateSurface::NameFormat property

SettingsCmdCreateSurface::SettingCmdBuildOptions class

about SettingsCmdCreateSurface::SettingCmdBuildOptions class

SettingsCmdCreateSurface::SettingCmdBuildOptions::AllowCrossingBreaklines property

SettingsCmdCreateSurface::SettingCmdBuildOptions::ConvertProximityBreaklinesToStandard property

SettingsCmdCreateSurface::SettingCmdBuildOptions::CopyDeletedDependentObjects property

SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationGreaterThan property

SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationLessThan property

SettingsCmdCreateSurface::SettingCmdBuildOptions::ElevationToUse property

SettingsCmdCreateSurface::SettingCmdBuildOptions::ExcludeElevationsGreaterThan property

SettingsCmdCreateSurface::SettingCmdBuildOptions::ExcludeElevationsLessThan property

SettingsCmdCreateSurface::SettingCmdBuildOptions::MaximumTriangleLength property

SettingsCmdCreateSurface::SettingCmdBuildOptions::UseMaximumTriangleLength property

SettingsCmdCreateSurface::SettingCmdSurfaceCreation class

about SettingsCmdCreateSurface::SettingCmdSurfaceCreation class

SettingsCmdCreateSurface::SettingCmdSurfaceCreation::CutFactor property

SettingsCmdCreateSurface::SettingCmdSurfaceCreation::DefaultType property

SettingsCmdCreateSurface::SettingCmdSurfaceCreation::FillFactor property

SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceOrientation property

SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceXSpacing property

SettingsCmdCreateSurface::SettingCmdSurfaceCreation::GridSurfaceYSpacing property

SettingsCmdCreateSurface::SettingsNameFormat class

about SettingsCmdCreateSurface::SettingsNameFormat class

SettingsCmdCreateSurface::SettingsNameFormat::Surface property

SettingsCmdCreateSurface::SurfaceCreation property

SettingsCmdCreateSurfaceFromTIN class

about SettingsCmdCreateSurfaceFromTIN class

SettingsCmdCreateSurfaceGridFromDEM class

about SettingsCmdCreateSurfaceGridFromDEM class

SettingsCmdCreateSurfaceGridFromDEM::BuildOptions property

SettingsCmdCreateSurfaceGridFromDEM::ImportOptions property

SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions class

about SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions class

SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::CopyDeletedDependentObjects property

SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ElevationGreaterThan property

SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ElevationLessThan property

SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ExcludeElevationsGreaterThan property

SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdBuildOptions::ExcludeElevationsLessThan property

SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions class

about SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions class

SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions::NullElevation property

SettingsCmdCreateSurfaceGridFromDEM::SettingsCmdImportOptions::UseCustomNullElevation property

SettingsCmdCreateSurfaceReference class

about SettingsCmdCreateSurfaceReference class

SettingsCmdCreateSurfaceReference::NameFormat property

SettingsCmdCreateSurfaceWaterdrop class

about SettingsCmdCreateSurfaceWaterdrop class

SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker class

about SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker class

SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker::PlaceMarkerAtStartPoint property

SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropMarker::StartPointMarkerStyle property

SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath class

about SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath class

SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath::PathLayer property

SettingsCmdCreateSurfaceWaterdrop::SettingsCmdWaterdropPath::PathObjectType property

SettingsCmdCreateSurfaceWaterdrop::WaterdropMarker property

SettingsCmdCreateSurfaceWaterdrop::WaterdropPath property

SettingsCmdCreateViewFrames class

about SettingsCmdCreateViewFrames class

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation class

about SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation class

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::AlignmentStationRangeSpecifiedByUser property

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::EnableFirstViewFrameOffset property

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::FirstViewFrameOffsetDistance property

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::InsertMatchLines property

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineRepositioning property

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineRepositioningValue property

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineSnapStation property

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::MatchLineSnapStationValue property

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::SheetType property

SettingsCmdCreateViewFrames::SettingsCmdViewFrameCreation::ViewFrameOrientation property

SettingsCmdCreateViewFrames::ViewFrameCreation property

SettingsCmdDrawFeatureLine class

about SettingsCmdDrawFeatureLine class

SettingsCmdDrawFeatureLine::FeatureLineCreation property

SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation class

about SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation class

SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::LayerSetting property

SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::UseFeatureLineName property

SettingsCmdDrawFeatureLine::SettingsCmdFeatureLineCreation::UseFeatureLineStyle property

SettingsCmdEditInStormSewers class

about SettingsCmdEditInStormSewers class

SettingsCmdEditSVGroupStyle class

about SettingsCmdEditSVGroupStyle class

SettingsCmdExportParcelAnalysis class

about SettingsCmdExportParcelAnalysis class

SettingsCmdExportParcelAnalysis::ParcelAnalysis property

SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis class

about SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis class

SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::AnalysisType property

SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::EnableMapcheckAcrossChord property

SettingsCmdExportParcelAnalysis::SettingsCmdParcelAnalysis::ProcessCounterClockwise property

SettingsCmdExportStormSewerData class

about SettingsCmdExportStormSewerData class

SettingsCmdFeatureLinesFromCorridor class

about SettingsCmdFeatureLinesFromCorridor class

SettingsCmdFeatureLinesFromCorridor::FeatureLineCreation property

SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation class

about SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation class

SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::CreateDynamicLink property

SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::FeatureLineName property

SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::HorizontalDeviation property

SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::InclusionDistance property

SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::LayerSetting property

SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::SmoothTheFeatureLine property

SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::UseFeatureLineStyle property

SettingsCmdFeatureLinesFromCorridor::SettingsCmdFeatureLineCreation::WeedingDistance property

SettingsCmdFitCurveFeature class

about SettingsCmdFitCurveFeature class

SettingsCmdFitCurveFeature::FeatureLineFitCurve property

SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve class

about SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve class

SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve::MinimumNumberOfSegments property

SettingsCmdFitCurveFeature::SettingsCmdFeatureLineFitCurve::Tolerance property

SettingsCmdGenerateQuantitiesReport class

about SettingsCmdGenerateQuantitiesReport class

SettingsCmdGenerateQuantitiesReport::DisplayXmlReport property

SettingsCmdGradingElevEditor class

about SettingsCmdGradingElevEditor class

SettingsCmdGradingElevEditor::GradingElevationEditor property

SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor class

about SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor class

SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor::RaiseLowerIncrement property

SettingsCmdGradingElevEditor::SettingsCmdGradingElevationEditor::ShowGradeBreaksOnly property

SettingsCmdGradingTools class

about SettingsCmdGradingTools class

SettingsCmdGradingTools::GradingLayoutTools property

SettingsCmdGradingTools::SettingsCmdGradingLayoutTools class

about SettingsCmdGradingTools::SettingsCmdGradingLayoutTools class

SettingsCmdGradingTools::SettingsCmdGradingLayoutTools::Criteria property

SettingsCmdGradingTools::SettingsCmdGradingLayoutTools::GradingCriteriaSet property

SettingsCmdGradingVolumeTools class

about SettingsCmdGradingVolumeTools class

SettingsCmdGradingVolumeTools::LimitFeatureSelectionToCurrentGroup property

SettingsCmdGradingVolumeTools::RaiseLowerElevationIncrement property

SettingsCmdImportBuildingSite class

about SettingsCmdImportBuildingSite class

SettingsCmdImportGEData class

about SettingsCmdImportGEData class

SettingsCmdImportGEData::GoogleEarthOptions property

SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions class

about SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions class

SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions::GoogleEarthColumns property

SettingsCmdImportGEData::SettingsCmdGoogleEarthOptions::GoogleEarthRows property

SettingsCmdImportGEData::SettingsCmdSurfaceCreation class

about SettingsCmdImportGEData::SettingsCmdSurfaceCreation class

SettingsCmdImportGEData::SettingsCmdSurfaceCreation::NameFormat property

SettingsCmdImportGEData::SurfaceCreation property

SettingsCmdImportGESurface class

about SettingsCmdImportGESurface class

SettingsCmdImportGESurface::GoogleEarthOptions property

SettingsCmdImportGESurface::NameFormat property

SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions class

about SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions class

SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions::GoogleEarthColumns property

SettingsCmdImportGESurface::SettingsCmdGoogleEarthOptions::GoogleEarthRows property

SettingsCmdImportGESurface::SettingsNameFormat class

about SettingsCmdImportGESurface::SettingsNameFormat class

SettingsCmdImportGESurface::SettingsNameFormat::Surface property

SettingsCmdImportStormSewerData class

about SettingsCmdImportStormSewerData class

SettingsCmdJoinFeatures class

about SettingsCmdJoinFeatures class

SettingsCmdJoinFeatures::FeatureLineJoin property

SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin class

about SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin class

SettingsCmdJoinFeatures::SettingsCmdFeatureLineJoin::Tolerance property

SettingsCmdLayoutSectionViewGroup class

about SettingsCmdLayoutSectionViewGroup class

SettingsCmdMapCheck class

about SettingsCmdMapCheck class

SettingsCmdMapCheck::Mapcheck property

SettingsCmdMapCheck::SettingsCmdMapcheck class

about SettingsCmdMapCheck::SettingsCmdMapcheck class

SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentMapcheckColor property

SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentPointofBeginningColor property

SettingsCmdMapCheck::SettingsCmdMapcheck::CurrentSideColor property

SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultAngleType property

SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultCurveDirection property

SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultCurveTraverseMethod property

SettingsCmdMapCheck::SettingsCmdMapcheck::DefaultSideType property

SettingsCmdMapCheck::SettingsCmdMapcheck::MapcheckColor property

SettingsCmdMapCheck::SettingsCmdMapcheck::UseCommandLineInput property

SettingsCmdMoveBlockstoAttribElev class

about SettingsCmdMoveBlockstoAttribElev class

SettingsCmdMoveBlocksToSurface class

about SettingsCmdMoveBlocksToSurface class

SettingsCmdMoveTextToElevation class

about SettingsCmdMoveTextToElevation class

SettingsCmdProjectObjectsToProf class

about SettingsCmdProjectObjectsToProf class

SettingsCmdProjectObjectsToSect class

about SettingsCmdProjectObjectsToSect class

SettingsCmdReAddParcelAreaLabel class

about SettingsCmdReAddParcelAreaLabel class

SettingsCmdReAddParcelSegmentLabels class

about SettingsCmdReAddParcelSegmentLabels class

SettingsCmdRenamePipeNetworkParts class

about SettingsCmdRenamePipeNetworkParts class

SettingsCmdResetAnchorPipe class

about SettingsCmdResetAnchorPipe class

SettingsCmdReverseAlignmentDirection class

about SettingsCmdReverseAlignmentDirection class

SettingsCmdShowGeodeticCalculator class

about SettingsCmdShowGeodeticCalculator class

SettingsCmdShowPointGroupProperties class

about SettingsCmdShowPointGroupProperties class

SettingsCmdShowSpanningPipes class

about SettingsCmdShowSpanningPipes class

SettingsCmdSimplifySurface class

about SettingsCmdSimplifySurface class

SettingsCmdSimplifySurface::MaximumChangeInElevation property

SettingsCmdSimplifySurface::PercentageOfPointsToRemove property

SettingsCmdSimplifySurface::RegionOptions property

SettingsCmdSimplifySurface::SimplifyMethod property

SettingsCmdSimplifySurface::UseMaximumChangeInElevation property

SettingsCmdSimplifySurface::UsePercentageOfPointsToRemove property

SettingsCmdSuperimposeProfile class

about SettingsCmdSuperimposeProfile class

SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption class

about SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption class

SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption::HorizontalMidOrdinateDistance property

SettingsCmdSuperimposeProfile::SettingsCmdSuperimposeProfileOption::VerticalMidOrdinateDistance property

SettingsCmdSuperimposeProfile::SuperimposeProfile property

SettingsCmdSurfaceExportToDem class

about SettingsCmdSurfaceExportToDem class

SettingsCmdSurfaceExportToDem::ExportOptions property

SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions class

about SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions class

SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::GridSpacing property

SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::NullElevation property

SettingsCmdSurfaceExportToDem::SettingsCmdExportOptions::UseCustomNullElevation property

SettingsCmdSurfaceExtractObjects class

about SettingsCmdSurfaceExtractObjects class

SettingsCmdTakeOff class

about SettingsCmdTakeOff class

SettingsCmdTakeOff::ComputeTakeOffOption property

SettingsCmdTakeOff::SettingsCmdComputeTakeOff class

about SettingsCmdTakeOff::SettingsCmdComputeTakeOff class

SettingsCmdTakeOff::SettingsCmdComputeTakeOff::DefaultReportStyle property

SettingsCmdTakeOff::SettingsCmdComputeTakeOff::DrawingBasedReportTableFont property

SettingsCmdTakeOff::SettingsCmdComputeTakeOff::IncludeFormulasInReports property

SettingsCmdTakeOff::SettingsCmdComputeTakeOff::LengthComputeType property

SettingsCmdTakeOff::SettingsCmdComputeTakeOff::LimitToAlignmentStation property

SettingsCmdTakeOff::SettingsCmdComputeTakeOff::PipeLengthType property

SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportExtentsType property

SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportSelectedPayItemOnly property

SettingsCmdTakeOff::SettingsCmdComputeTakeOff::ReportType property

SettingsCmdViewEditCorridorSection class

about SettingsCmdViewEditCorridorSection class

SettingsCmdViewEditCorridorSection::GridSettings property

SettingsCmdViewEditCorridorSection::GridTextSettings property

SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings class

about SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings class

SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::CenterAxisColor property

SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayCenterAxis property

SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayHorizontalGrid property

SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::DisplayVerticalGrid property

SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::GridColor property

SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::HorizontalGridInterval property

SettingsCmdViewEditCorridorSection::SettingsCmdGridSettings::VerticalGridInterval property

SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings class

about SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings class

SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::AnnotateCenterAxis property

SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextColor property

SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextHeightRelativeToScreen property

SettingsCmdViewEditCorridorSection::SettingsCmdGridTextSettings::TextStyle property

SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions class

about SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions class

SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::BackClip property

SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::DefaultViewScale property

SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::FrontClip property

SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::RebuildOnEdit property

SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::StationTrackerInMultipleViewports property

SettingsCmdViewEditCorridorSection::SettingsCmdViewEditOptions::TurnOffUnassociatedLayers property

SettingsCmdViewEditCorridorSection::ViewEditOptions property

SettingsCmdWeedFeatures class

about SettingsCmdWeedFeatures class

SettingsCmdWeedFeatures::FeatureLineWeed property

SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed class

about SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed class

SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::AngleFactor property

SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyAngleFactor property

SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyGradeFactor property

SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ApplyLengthFactor property

SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ClosePoint3DDistance property

SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::ClosePointRemoval property

SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::GradeFactor property

SettingsCmdWeedFeatures::SettingsCmdFeatureLineWeed::LengthFactor property

SettingsCoordinateSystem class

about SettingsCoordinateSystem class

SettingsCoordinateSystem::Category property

SettingsCoordinateSystem::Code property

SettingsCoordinateSystem::Datum property

SettingsCoordinateSystem::Description property

SettingsCoordinateSystem::Projection property

SettingsCoordinateSystem::Unit property

SettingsCorridor class

about SettingsCorridor class

SettingsCorridor::NameFormat property

SettingsCorridor::RegionHighlightGraphics property

SettingsCorridor::SettingsNameFormat class

about SettingsCorridor::SettingsNameFormat class

SettingsCorridor::SettingsNameFormat::AlignmentFromFeatureLine property

SettingsCorridor::SettingsNameFormat::Corridor property

SettingsCorridor::SettingsNameFormat::CorridorBaseline property

SettingsCorridor::SettingsNameFormat::CorridorRegion property

SettingsCorridor::SettingsNameFormat::CorridorSurface property

SettingsCorridor::SettingsNameFormat::FeatureLine property

SettingsCorridor::SettingsNameFormat::ProfileFromFeatureLine property

SettingsCorridor::SettingsRegionHighlightGraphics class

about SettingsCorridor::SettingsRegionHighlightGraphics class

SettingsCorridor::SettingsRegionHighlightGraphics::BaselineColor property

SettingsCorridor::SettingsRegionHighlightGraphics::BaselineLineweight property

SettingsCorridor::SettingsRegionHighlightGraphics::HighlightBaseline property

SettingsCorridor::SettingsRegionHighlightGraphics::HighlightHorizontalTargets property

SettingsCorridor::SettingsRegionHighlightGraphics::HighlightInteriorAssemblies property

SettingsCorridor::SettingsRegionHighlightGraphics::HighlightRegionBoundary property

SettingsCorridor::SettingsRegionHighlightGraphics::HorizontalTargetsColor property

SettingsCorridor::SettingsRegionHighlightGraphics::HorizontalTargetsLineweight property

SettingsCorridor::SettingsRegionHighlightGraphics::InteriorAssembliesColor property

SettingsCorridor::SettingsRegionHighlightGraphics::InteriorAssembliesLineweight property

SettingsCorridor::SettingsRegionHighlightGraphics::RegionBoundaryColor property

SettingsCorridor::SettingsRegionHighlightGraphics::RegionBoundaryLineweight property

SettingsCorridor::SettingsStyles class

about SettingsCorridor::SettingsStyles class

SettingsCorridor::SettingsStyles::Alignment property

SettingsCorridor::SettingsStyles::AlignmentLabelSet property

SettingsCorridor::SettingsStyles::Corridor property

SettingsCorridor::SettingsStyles::CorridorCodeSet property

SettingsCorridor::SettingsStyles::CorridorSurface property

SettingsCorridor::SettingsStyles::FeatureLine property

SettingsCorridor::SettingsStyles::Profile property

SettingsCorridor::SettingsStyles::ProfileLabelSet property

SettingsCorridor::SettingsStyles::RenderMaterial property

SettingsCorridor::SettingsStyles::SlopePattern property

SettingsCorridor::Styles property

SettingsDrawing class

about SettingsDrawing class

SettingsDrawing::AbbreviationsSettings property

SettingsDrawing::AmbientSettings property

SettingsDrawing::ApplyTransformSettings property

SettingsDrawing::ObjectLayerSettings property

SettingsDrawing::TransformationSettings property

SettingsDrawing::UnitZoneSettings property

SettingsGeneral class

about SettingsGeneral class

SettingsGeneral::SettingsStyles class

about SettingsGeneral::SettingsStyles class

SettingsGeneral::SettingsStyles::CurveLabel property

SettingsGeneral::SettingsStyles::LineLabel property

SettingsGeneral::SettingsStyles::NoteLabel property

SettingsGeneral::Styles property

SettingsGrading class

about SettingsGrading class

SettingsGrading::NameFormat property

SettingsGrading::SettingsNameFormat class

about SettingsGrading::SettingsNameFormat class

SettingsGrading::SettingsNameFormat::FeatureLine property

SettingsGrading::SettingsNameFormat::GradingGroup property

SettingsGrading::SettingsStyles class

about SettingsGrading::SettingsStyles class

SettingsGrading::SettingsStyles::CutSlopeGrading property

SettingsGrading::SettingsStyles::FeatureLineStyle property

SettingsGrading::SettingsStyles::FillSlopeGrading property

SettingsGrading::SettingsStyles::GradingStyle property

SettingsGrading::Styles property

SettingsIntersection class

about SettingsIntersection class

SettingsIntersection::NameFormat property

SettingsIntersection::SettingsNameFormat class

about SettingsIntersection::SettingsNameFormat class

SettingsIntersection::SettingsNameFormat::CorridorRegion property

SettingsIntersection::SettingsNameFormat::CurbReturnAlignment property

SettingsIntersection::SettingsNameFormat::CurbReturnProfile property

SettingsIntersection::SettingsNameFormat::Intersection property

SettingsIntersection::SettingsNameFormat::IntersectionQuadrant property

SettingsIntersection::SettingsNameFormat::OffsetAlignment property

SettingsIntersection::SettingsNameFormat::OffsetProfile property

SettingsIntersection::SettingsStyles class

about SettingsIntersection::SettingsStyles class

SettingsIntersection::SettingsStyles::CurbReturnAlignment property

SettingsIntersection::SettingsStyles::CurbReturnAlignmentLabelSet property

SettingsIntersection::SettingsStyles::CurbReturnProfile property

SettingsIntersection::SettingsStyles::CurbReturnProfileLabelSet property

SettingsIntersection::SettingsStyles::Intersection property

SettingsIntersection::SettingsStyles::IntersectionLabel property

SettingsIntersection::SettingsStyles::OffsetAlignment property

SettingsIntersection::SettingsStyles::OffsetAlignmentLabelSet property

SettingsIntersection::SettingsStyles::OffsetProfile property

SettingsIntersection::SettingsStyles::OffsetProfileLabelSet property

SettingsIntersection::Styles property

SettingsLandXML class

about SettingsLandXML class

SettingsLandXML::Export property

SettingsLandXML::Import property

SettingsLandXMLExport class

about SettingsLandXMLExport class

SettingsLandXMLExport::AlignmentExport property

SettingsLandXMLExport::Data property

SettingsLandXMLExport::Identification property

SettingsLandXMLExport::ParcelExport property

SettingsLandXMLExport::PointExport property

SettingsLandXMLExport::SettingsAlignmentExport class

about SettingsLandXMLExport::SettingsAlignmentExport class

SettingsLandXMLExport::SettingsAlignmentExport::ExportCrossSections property

SettingsLandXMLExport::SettingsData class

about SettingsLandXMLExport::SettingsData class

SettingsLandXMLExport::SettingsData::AngleDirectionFormat property

SettingsLandXMLExport::SettingsData::CreateReadOnlyFile property

SettingsLandXMLExport::SettingsData::ImperialUnits property

SettingsLandXMLExport::SettingsIdentification class

about SettingsLandXMLExport::SettingsIdentification class

SettingsLandXMLExport::SettingsIdentification::Company property

SettingsLandXMLExport::SettingsIdentification::CompanyURL property

SettingsLandXMLExport::SettingsIdentification::Creator property

SettingsLandXMLExport::SettingsIdentification::EmailAddress property

SettingsLandXMLExport::SettingsIdentification::WriteIdentificationElements property

SettingsLandXMLExport::SettingsParcelExport class

about SettingsLandXMLExport::SettingsParcelExport class

SettingsLandXMLExport::SettingsParcelExport::ParcelDirection property

SettingsLandXMLExport::SettingsPointExport class

about SettingsLandXMLExport::SettingsPointExport class

SettingsLandXMLExport::SettingsPointExport::CodeAttribute property

SettingsLandXMLExport::SettingsPointExport::DescAttribute property

SettingsLandXMLExport::SettingsPointExport::ExportDescriptionKeys property

SettingsLandXMLExport::SettingsPointExport::ExportPointReferences property

SettingsLandXMLExport::SettingsPointExport::PointReferenceTolerance property

SettingsLandXMLExport::SettingsPointExport::SkipFullWhenSameAsRaw property

SettingsLandXMLExport::SettingsSurfaceExport class

about SettingsLandXMLExport::SettingsSurfaceExport class

SettingsLandXMLExport::SettingsSurfaceExport::SurfaceData property

SettingsLandXMLExport::SettingsSurfaceExport::Watersheds property

SettingsLandXMLExport::SurfaceExport property

SettingsLandXMLImport class

about SettingsLandXMLImport class

SettingsLandXMLImport::ConflictResolution property

SettingsLandXMLImport::DiameterUnits property

SettingsLandXMLImport::PipeNetwork property

SettingsLandXMLImport::PointImport property

SettingsLandXMLImport::Rotation property

SettingsLandXMLImport::SettingsConflictResolution class

about SettingsLandXMLImport::SettingsConflictResolution class

SettingsLandXMLImport::SettingsConflictResolution::ConflictResolution property

SettingsLandXMLImport::SettingsDiameterUnits class

about SettingsLandXMLImport::SettingsDiameterUnits class

SettingsLandXMLImport::SettingsDiameterUnits::Imperial property

SettingsLandXMLImport::SettingsDiameterUnits::Metric property

SettingsLandXMLImport::SettingsPipeNetwork class

about SettingsLandXMLImport::SettingsPipeNetwork class

SettingsLandXMLImport::SettingsPipeNetwork::MatchChannelShapedPipesWith property

SettingsLandXMLImport::SettingsPipeNetwork::MatchCircularPipesWith property

SettingsLandXMLImport::SettingsPipeNetwork::MatchCircularStructuresWith property

SettingsLandXMLImport::SettingsPipeNetwork::MatchConnectionStructuresWith property

SettingsLandXMLImport::SettingsPipeNetwork::MatchEggShapedPipesWith property

SettingsLandXMLImport::SettingsPipeNetwork::MatchEllipticalShapedPipesWith property

SettingsLandXMLImport::SettingsPipeNetwork::MatchInletOutletStructuresWith property

SettingsLandXMLImport::SettingsPipeNetwork::MatchRectangleShapedPipesWith property

SettingsLandXMLImport::SettingsPipeNetwork::MatchRectangleStructuresWith property

SettingsLandXMLImport::SettingsPipeNetwork::PartsListForPartFamilySizeMatching property

SettingsLandXMLImport::SettingsPointImport class

about SettingsLandXMLImport::SettingsPointImport class

SettingsLandXMLImport::SettingsPointImport::PointDescription property

SettingsLandXMLImport::SettingsRotation class

about SettingsLandXMLImport::SettingsRotation class

SettingsLandXMLImport::SettingsRotation::Angle property

SettingsLandXMLImport::SettingsRotation::Direction property

SettingsLandXMLImport::SettingsRotation::Rotate property

SettingsLandXMLImport::SettingsSurfaceImport class

about SettingsLandXMLImport::SettingsSurfaceImport class

SettingsLandXMLImport::SettingsSurfaceImport::ConvertSurveyFootToInternationalFoot property

SettingsLandXMLImport::SettingsSurfaceImport::CreateSnapshotAfterImport property

SettingsLandXMLImport::SettingsSurfaceImport::CreateSourceDataInDrawing property

SettingsLandXMLImport::SettingsSurfaceImport::SurfaceData property

SettingsLandXMLImport::SettingsTranslation class

about SettingsLandXMLImport::SettingsTranslation class

SettingsLandXMLImport::SettingsTranslation::BasePointEasting property

SettingsLandXMLImport::SettingsTranslation::BasePointElevation property

SettingsLandXMLImport::SettingsTranslation::BasePointNorthing property

SettingsLandXMLImport::SettingsTranslation::Translate property

SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateEasting property

SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateElevation property

SettingsLandXMLImport::SettingsTranslation::TranslatedCoordinateNorthing property

SettingsLandXMLImport::SurfaceImport property

SettingsLandXMLImport::Translation property

SettingsMassHaulLine class

about SettingsMassHaulLine class

SettingsMassHaulView class

about SettingsMassHaulView class

SettingsMassHaulView::MassHaulCreation property

SettingsMassHaulView::NameFormat property

SettingsMassHaulView::SettingsMassHaulCreation class

about SettingsMassHaulView::SettingsMassHaulCreation class

SettingsMassHaulView::SettingsMassHaulCreation::BorrowPitCapacity property

SettingsMassHaulView::SettingsMassHaulCreation::DumpSiteCapacity property

SettingsMassHaulView::SettingsNameFormat class

about SettingsMassHaulView::SettingsNameFormat class

SettingsMassHaulView::SettingsNameFormat::MassHaulLine property

SettingsMassHaulView::SettingsNameFormat::MassHaulView property

SettingsMassHaulView::SettingsStyles class

about SettingsMassHaulView::SettingsStyles class

SettingsMassHaulView::SettingsStyles::MassHaulLine property

SettingsMassHaulView::SettingsStyles::MassHaulView property

SettingsMassHaulView::Styles property

SettingsMatchLine class

about SettingsMatchLine class

SettingsObjectLayer class

about SettingsObjectLayer class

SettingsObjectLayer::LayerId property

SettingsObjectLayer::LayerName property

SettingsObjectLayer::Locked property

SettingsObjectLayer::Modifier property

SettingsObjectLayer::ModifierValue property

SettingsObjectLayer::ObjectType property

SettingsObjectLayers class

about SettingsObjectLayers class

SettingsObjectLayers::GetObjectLayerSetting method

SettingsObjectLayers::ObjectControlledByLayer property

SettingsParcel class

about SettingsParcel class

SettingsParcel::SettingsStyles class

about SettingsParcel::SettingsStyles class

SettingsParcel::SettingsStyles::Parcel property

SettingsParcel::SettingsStyles::ParcelAreaLabelStyle property

SettingsParcel::SettingsStyles::ParcelCurveLabel property

SettingsParcel::SettingsStyles::ParcelLineLabel property

SettingsParcel::Styles property

SettingsPipe class

about SettingsPipe class

SettingsPipeNetwork class

about SettingsPipeNetwork class

SettingsPipeNetwork::NameFormat property

SettingsPipeNetwork::ProfileLabelPlacement property

SettingsPipeNetwork::Rules property

SettingsPipeNetwork::SectionLabelPlacement property

SettingsPipeNetwork::SettingsNameFormat class

about SettingsPipeNetwork::SettingsNameFormat class

SettingsPipeNetwork::SettingsNameFormat::AlignmentFromNetwork property

SettingsPipeNetwork::SettingsNameFormat::Interference property

SettingsPipeNetwork::SettingsNameFormat::InterferenceCheck property

SettingsPipeNetwork::SettingsNameFormat::Network property

SettingsPipeNetwork::SettingsNameFormat::Pipe property

SettingsPipeNetwork::SettingsNameFormat::Structure property

SettingsPipeNetwork::SettingsProfileLabelPlacement class

about SettingsPipeNetwork::SettingsProfileLabelPlacement class

SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorElevationValueForPipes property

SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorElevationValueForStructures property

SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorOptionForPipes property

SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorOptionForStructures property

SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorPlotHeightValueForPipes property

SettingsPipeNetwork::SettingsProfileLabelPlacement::DimensionAnchorPlotHeightValueForStructures property

SettingsPipeNetwork::SettingsProfileLabelPlacement::StructureLabelPlacement property

SettingsPipeNetwork::SettingsRules class

about SettingsPipeNetwork::SettingsRules class

SettingsPipeNetwork::SettingsRules::Pipe property

SettingsPipeNetwork::SettingsRules::Structure property

SettingsPipeNetwork::SettingsSectionLabelPlacement class

about SettingsPipeNetwork::SettingsSectionLabelPlacement class

SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorElevationValueForPipes property

SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorElevationValueForStructures property

SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorOptionForPipes property

SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorOptionForStructures property

SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorPlotHeightValueForPipes property

SettingsPipeNetwork::SettingsSectionLabelPlacement::DimensionAnchorPlotHeightValueForStructures property

SettingsPipeNetwork::SettingsSectionLabelPlacement::PipeSectionLabel property

SettingsPipeNetwork::SettingsSectionLabelPlacement::StructureLabelPlacement property

SettingsPipeNetwork::SettingsStormSewersMigration class

about SettingsPipeNetwork::SettingsStormSewersMigration class

SettingsPipeNetwork::SettingsStormSewersMigration::PartMatching property

SettingsPipeNetwork::SettingsStormSewersMigration::PartsListUsedForMigration property

SettingsPipeNetwork::SettingsStyles class

about SettingsPipeNetwork::SettingsStyles class

SettingsPipeNetwork::SettingsStyles::Interference property

SettingsPipeNetwork::SettingsStyles::InterferenceRenderMaterial property

SettingsPipeNetwork::SettingsStyles::PartsList property

SettingsPipeNetwork::SettingsStyles::Pipe property

SettingsPipeNetwork::SettingsStyles::PipePlanLabel property

SettingsPipeNetwork::SettingsStyles::PipeProfileLabel property

SettingsPipeNetwork::SettingsStyles::PipeSectionLabel property

SettingsPipeNetwork::SettingsStyles::RenderMaterial property

SettingsPipeNetwork::SettingsStyles::Structure property

SettingsPipeNetwork::SettingsStyles::StructurePlanLabel property

SettingsPipeNetwork::SettingsStyles::StructureProfileLabel property

SettingsPipeNetwork::SettingsStyles::StructureSectionLabel property

SettingsPipeNetwork::StormSewersMigration property

SettingsPipeNetwork::Styles property

SettingsPoint class

about SettingsPoint class

SettingsPoint::NameFormat property

SettingsPoint::SettingsNameFormat class

about SettingsPoint::SettingsNameFormat class

SettingsPoint::SettingsNameFormat::Point property

SettingsPoint::SettingsNameFormat::PointGroup property

SettingsPoint::SettingsStyles class

about SettingsPoint::SettingsStyles class

SettingsPoint::SettingsStyles::Point property

SettingsPoint::SettingsStyles::PointLabel property

SettingsPoint::SettingsUpdatePoints class

about SettingsPoint::SettingsUpdatePoints class

SettingsPoint::SettingsUpdatePoints::AllowCheckedInPointsToBeModified property

SettingsPoint::Styles property

SettingsPoint::UpdatePoints property

SettingsProfile class

about SettingsProfile class

SettingsProfile::CriteriaBasedDesignOptions property

SettingsProfile::DefaultNameFormat property

SettingsProfile::ProfilesCreation property

SettingsProfile::SettingsCriteriaBasedDesignOptions class

about SettingsProfile::SettingsCriteriaBasedDesignOptions class

SettingsProfile::SettingsCriteriaBasedDesignOptions::DefaultDesignCheckSet property

SettingsProfile::SettingsCriteriaBasedDesignOptions::UseDesignChecksOption property

SettingsProfile::SettingsCriteriaBasedDesignOptions::UseDesignCriteriaFileOption property

SettingsProfile::SettingsDefaultNameFormat class

about SettingsProfile::SettingsDefaultNameFormat class

SettingsProfile::SettingsDefaultNameFormat::OffsetProfileNameTemplate property

SettingsProfile::SettingsDefaultNameFormat::ProfileNameTemplate property

SettingsProfile::SettingsDefaultNameFormat::SuperimposedProfileNameTemplate property

SettingsProfile::SettingsDefaultNameFormat::ThreeDEntityProfileNameTemplate property

SettingsProfile::SettingsProfileCreation class

about SettingsProfile::SettingsProfileCreation class

SettingsProfile::SettingsProfileCreation::AsymmetricalCrestCurveLength1 property

SettingsProfile::SettingsProfileCreation::AsymmetricalCrestCurveLength2 property

SettingsProfile::SettingsProfileCreation::AsymmetricalSagCurveLength1 property

SettingsProfile::SettingsProfileCreation::AsymmetricalSagCurveLength2 property

SettingsProfile::SettingsProfileCreation::CircularCrestCurveConstraint property

SettingsProfile::SettingsProfileCreation::CircularCrestCurveLength property

SettingsProfile::SettingsProfileCreation::CircularCrestCurveRadius property

SettingsProfile::SettingsProfileCreation::CircularSagCurveConstraint property

SettingsProfile::SettingsProfileCreation::CircularSagCurveLength property

SettingsProfile::SettingsProfileCreation::CircularSagCurveRadius property

SettingsProfile::SettingsProfileCreation::DefaultVerticalCurve property

SettingsProfile::SettingsProfileCreation::HeadlightAngle property

SettingsProfile::SettingsProfileCreation::HeadlightHeight property

SettingsProfile::SettingsProfileCreation::ParabolicCrestCurveKValue property

SettingsProfile::SettingsProfileCreation::ParabolicCrestCurveLength property

SettingsProfile::SettingsProfileCreation::ParabolicCrestVerticalConstraint property

SettingsProfile::SettingsProfileCreation::ParabolicSagCurveKValue property

SettingsProfile::SettingsProfileCreation::ParabolicSagCurveLength property

SettingsProfile::SettingsProfileCreation::ParabolicSagVerticalConstraint property

SettingsProfile::SettingsProfileCreation::PassingEyeHeight property

SettingsProfile::SettingsProfileCreation::PassingObjectHeight property

SettingsProfile::SettingsProfileCreation::StopEyeHeight property

SettingsProfile::SettingsProfileCreation::StopObjectHeight property

SettingsProfile::SettingsStyles class

about SettingsProfile::SettingsStyles class

SettingsProfile::SettingsStyles::ProfileLabelSet property

SettingsProfile::SettingsStyles::ProfileStyle property

SettingsProfile::StyleSettings property

SettingsProfileView class

about SettingsProfileView class

SettingsProfileView::Creation property

SettingsProfileView::NameFormat property

SettingsProfileView::ProjectionLabelPlacement property

SettingsProfileView::SettingsCreation class

about SettingsProfileView::SettingsCreation class

SettingsProfileView::SettingsCreation::PipeNetworkParts property

SettingsProfileView::SettingsCreation::SpecifyProfileElevationRange property

SettingsProfileView::SettingsCreation::SpecifyProfileStationRange property

SettingsProfileView::SettingsNameFormat class

about SettingsProfileView::SettingsNameFormat class

SettingsProfileView::SettingsNameFormat::CutArea property

SettingsProfileView::SettingsNameFormat::FillArea property

SettingsProfileView::SettingsNameFormat::MultipleBoundaryArea property

SettingsProfileView::SettingsNameFormat::ProfileView property

SettingsProfileView::SettingsProjectionLabelPlacement class

about SettingsProfileView::SettingsProjectionLabelPlacement class

SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorElevationValueForProjections property

SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorOption property

SettingsProfileView::SettingsProjectionLabelPlacement::DimensionAnchorPlotHeightValueForProjections property

SettingsProfileView::SettingsSplitOptions class

about SettingsProfileView::SettingsSplitOptions class

SettingsProfileView::SettingsSplitOptions::SplitDatumOption property

SettingsProfileView::SettingsSplitOptions::SplitProfileViews property

SettingsProfileView::SettingsSplitOptions::SplitStationOption property

SettingsProfileView::SettingsStackedOptions class

about SettingsProfileView::SettingsStackedOptions class

SettingsProfileView::SettingsStackedOptions::GapBetweenViews property

SettingsProfileView::SettingsStackedOptions::NumberOfStackedViews property

SettingsProfileView::SettingsStackedOptions::StackedViews property

SettingsProfileView::SettingsStyles class

about SettingsProfileView::SettingsStyles class

SettingsProfileView::SettingsStyles::BottomStackViewStyle property

SettingsProfileView::SettingsStyles::CutAreaShapeStyle property

SettingsProfileView::SettingsStyles::FillAreaShapeStyle property

SettingsProfileView::SettingsStyles::FirstSplitViewStyle property

SettingsProfileView::SettingsStyles::IntermediateSplitViewStyle property

SettingsProfileView::SettingsStyles::LastSplitViewStyle property

SettingsProfileView::SettingsStyles::MarkerStyle property

SettingsProfileView::SettingsStyles::MiddleStackViewStyle property

SettingsProfileView::SettingsStyles::MultipleBoundaryAreaShapeStyle property

SettingsProfileView::SettingsStyles::ProfileDepthLabelStyle property

SettingsProfileView::SettingsStyles::ProfileLabelSet property

SettingsProfileView::SettingsStyles::ProfileLabelStyle property

SettingsProfileView::SettingsStyles::ProfileProjectionLabelStyle property

SettingsProfileView::SettingsStyles::ProfileStationAndElevationLabelStyle property

SettingsProfileView::SettingsStyles::ProfileViewBandStyle property

SettingsProfileView::SettingsStyles::ProfileViewStyle property

SettingsProfileView::SettingsStyles::ProjectionStyle property

SettingsProfileView::SettingsStyles::TopStackViewStyle property

SettingsProfileView::SplitOptions property

SettingsProfileView::StackedOptions property

SettingsProfileView::Styles property

SettingsQuantityTakeoff class

about SettingsQuantityTakeoff class

SettingsQuantityTakeoff::NameFormat property

SettingsQuantityTakeoff::SettingsNameFormat class

about SettingsQuantityTakeoff::SettingsNameFormat class

SettingsQuantityTakeoff::SettingsNameFormat::Material property

SettingsQuantityTakeoff::SettingsNameFormat::MaterialList property

SettingsQuantityTakeoff::SettingsStyles class

about SettingsQuantityTakeoff::SettingsStyles class

SettingsQuantityTakeoff::SettingsStyles::MaterialShape property

SettingsQuantityTakeoff::SettingsStyles::QuantityTakeoffCriteria property

SettingsQuantityTakeoff::Styles property

SettingsRoot class

about SettingsRoot class

SettingsRoot::AssociateShortcutProjectId property

SettingsRoot::DrawingSettings property

SettingsRoot::GetSettings method

SettingsRoot::LandXMLSettings property

SettingsRoot::TagSettings property

SettingsSampleLine class

about SettingsSampleLine class

SettingsSampleLine::NameFormat property

SettingsSampleLine::SettingsNameFormat class

about SettingsSampleLine::SettingsNameFormat class

SettingsSampleLine::SettingsNameFormat::SampleLine property

SettingsSampleLine::SettingsNameFormat::SampleLineGroup property

SettingsSampleLine::SettingsStyles class

about SettingsSampleLine::SettingsStyles class

SettingsSampleLine::SettingsStyles::SampleLine property

SettingsSampleLine::SettingsStyles::SampleLineLabel property

SettingsSampleLine::Styles property

SettingsSection class

about SettingsSection class

SettingsSection::NameFormat property

SettingsSection::SettingsNameFormat class

about SettingsSection::SettingsNameFormat class

SettingsSection::SettingsNameFormat::Section property

SettingsSection::SettingsStyles class

about SettingsSection::SettingsStyles class

SettingsSection::SettingsStyles::Section property

SettingsSection::Styles property

SettingsSectionView class

about SettingsSectionView class

SettingsSectionView::NameFormat property

SettingsSectionView::ProjectionLabelPlacement property

SettingsSectionView::SectionViewCreation property

SettingsSectionView::SettingsNameFormat class

about SettingsSectionView::SettingsNameFormat class

SettingsSectionView::SettingsNameFormat::SectionView property

SettingsSectionView::SettingsProjectionLabelPlacement class

about SettingsSectionView::SettingsProjectionLabelPlacement class

SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorElevationValueForProjections property

SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorOption property

SettingsSectionView::SettingsProjectionLabelPlacement::DimensionAnchorPlotHeightValueForProjections property

SettingsSectionView::SettingsSectionViewCreation class

about SettingsSectionView::SettingsSectionViewCreation class

SettingsSectionView::SettingsSectionViewCreation::SectionGroupElevationRange property

SettingsSectionView::SettingsSectionViewCreation::SpecifySectionViewHeight property

SettingsSectionView::SettingsSectionViewCreation::SpecifySectionViewOffsetRange property

SettingsSectionView::SettingsStyles class

about SettingsSectionView::SettingsStyles class

SettingsSectionView::SettingsStyles::GroupPlot property

SettingsSectionView::SettingsStyles::Marker property

SettingsSectionView::SettingsStyles::Projection property

SettingsSectionView::SettingsStyles::SectionLabelSet property

SettingsSectionView::SettingsStyles::SectionProjectionLabel property

SettingsSectionView::SettingsStyles::SectionView property

SettingsSectionView::SettingsStyles::SectionViewBandSet property

SettingsSectionView::SettingsStyles::SectionViewDepthGradeLabel property

SettingsSectionView::SettingsStyles::SectionViewOffsetElevationLabel property

SettingsSectionView::Styles property

SettingsStructure class

about SettingsStructure class

SettingsSubassembly class

about SettingsSubassembly class

SettingsSubassembly::DefaultStyles property

SettingsSubassembly::NameFormat property

SettingsSubassembly::SettingsDefaultStyles class

about SettingsSubassembly::SettingsDefaultStyles class

SettingsSubassembly::SettingsDefaultStyles::CodeSetStyle property

SettingsSubassembly::SettingsNameFormat class

about SettingsSubassembly::SettingsNameFormat class

SettingsSubassembly::SettingsNameFormat::CreateFromEntities property

SettingsSubassembly::SettingsNameFormat::CreateFromMacro property

SettingsSurface class

about SettingsSurface class

SettingsSurface::ContourLabeling property

SettingsSurface::Defaults property

SettingsSurface::SettingsContourLabeling class

about SettingsSurface::SettingsContourLabeling class

SettingsSurface::SettingsContourLabeling::DisplayContourLabelLine property

SettingsSurface::SettingsContourLabeling::LabelMask property

SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleMajor property

SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleMinor property

SettingsSurface::SettingsContourLabeling::SurfaceContourLabelStyleUserDefined property

SettingsSurface::SettingsDefaults class

about SettingsSurface::SettingsDefaults class

SettingsSurface::SettingsDefaults::AutoRebuild property

SettingsSurface::SettingsStyles class

about SettingsSurface::SettingsStyles class

SettingsSurface::SettingsStyles::Marker property

SettingsSurface::SettingsStyles::RenderMaterial property

SettingsSurface::SettingsStyles::Surface property

SettingsSurface::SettingsStyles::SurfaceSlopeLabel property

SettingsSurface::SettingsStyles::SurfaceSpotElevationLabel property

SettingsSurface::Styles property

SettingsSurvey class

about SettingsSurvey class

SettingsSurvey::SettingsStyles class

about SettingsSurvey::SettingsStyles class

SettingsSurvey::SettingsStyles::Figure property

SettingsSurvey::SettingsStyles::Network property

SettingsSurvey::Styles property

SettingsTag class

about SettingsTag class

SettingsTag::Creation property

SettingsTag::Renumbering property

SettingsTag::SettingsCreation class

about SettingsTag::SettingsCreation class

SettingsTag::SettingsCreation::CurvesIncrement property

SettingsTag::SettingsCreation::CurvesStartingNumber property

SettingsTag::SettingsCreation::LinesIncrement property

SettingsTag::SettingsCreation::LinesStartingNumber property

SettingsTag::SettingsCreation::SpiralsIncrement property

SettingsTag::SettingsCreation::SpiralsStartingNumber property

SettingsTag::SettingsRenumbering class

about SettingsTag::SettingsRenumbering class

SettingsTag::SettingsRenumbering::CurvesIncrement property

SettingsTag::SettingsRenumbering::CurvesStartingNumber property

SettingsTag::SettingsRenumbering::LinesIncrement property

SettingsTag::SettingsRenumbering::LinesStartingNumber property

SettingsTag::SettingsRenumbering::SpiralsIncrement property

SettingsTag::SettingsRenumbering::SpiralsStartingNumber property

SettingsTransformation class

about SettingsTransformation class

SettingsTransformation::ApplySeaLevelScaleFactor property

SettingsTransformation::GridReferencePoint property

SettingsTransformation::GridRotationPoint property

SettingsTransformation::GridScaleFactor property

SettingsTransformation::GridScaleFactorComputation property

SettingsTransformation::LocalReferencePoint property

SettingsTransformation::LocalRotationPoint property

SettingsTransformation::RotationToGridAzimuth property

SettingsTransformation::RotationToGridNorth property

SettingsTransformation::SeaLevelScaleElevation property

SettingsTransformation::SpecifyRotationType property

SettingsTransformation::SpheroidRadius property

SettingsUnitZone class

about SettingsUnitZone class

SettingsUnitZone::AngularUnits property

SettingsUnitZone::CoordinateSystemCode property

SettingsUnitZone::DrawingScale property

SettingsUnitZone::DrawingUnits property

SettingsUnitZone::GetAllCodes method

SettingsUnitZone::GetCoordinateSystemByCode method

SettingsUnitZone::ImperialToMetricConversion property

SettingsUnitZone::MatchAutoCADVariables property

SettingsUnitZone::ScaleObjectsFromOtherDrawings property

SettingsViewFrame class

about SettingsViewFrame class

SettingsViewFrameGroup class

about SettingsViewFrameGroup class

SettingsViewFrameGroup::Information property

SettingsViewFrameGroup::NameFormat property

SettingsViewFrameGroup::SettingsInformation class

about SettingsViewFrameGroup::SettingsInformation class

SettingsViewFrameGroup::SettingsNameFormat class

about SettingsViewFrameGroup::SettingsNameFormat class

SettingsViewFrameGroup::SettingsNameFormat::Layout property

SettingsViewFrameGroup::SettingsNameFormat::MatchLine property

SettingsViewFrameGroup::SettingsNameFormat::SheetFile property

SettingsViewFrameGroup::SettingsNameFormat::ViewFrame property

SettingsViewFrameGroup::SettingsNameFormat::ViewFrameGroup property

SettingsViewFrameGroup::SettingsStyles class

about SettingsViewFrameGroup::SettingsStyles class

SettingsViewFrameGroup::SettingsStyles::MatchLine property

SettingsViewFrameGroup::SettingsStyles::MatchLineLabelLeft property

SettingsViewFrameGroup::SettingsStyles::MatchLineLabelRight property

SettingsViewFrameGroup::SettingsStyles::MatchLineLeftLabelLocation property

SettingsViewFrameGroup::SettingsStyles::MatchLineRightLabelLocation property

SettingsViewFrameGroup::SettingsStyles::ProfileView property

SettingsViewFrameGroup::SettingsStyles::ProfileViewBandSet property

SettingsViewFrameGroup::SettingsStyles::ViewFrame property

SettingsViewFrameGroup::SettingsStyles::ViewFrameLabel property

SettingsViewFrameGroup::SettingsStyles::ViewFrameLabelLocation property

SettingsViewFrameGroup::Styles property

Severe enumeration member

Shape

Shape class

about Shape class

Shape::Codes property

Shape::Index property

Shape::IsHidden property

Shape::Links property

ShapeCollection class

about ShapeCollection class

ShapeCollection::Add method

ShapeCollection::Count property

ShapeCollection::default property

ShapeCollection::GetEnumerator method

ShapeCollection::GetObjectEnumerator method

ShapeCollection::Remove method

Shapes

ShapesByCode

ShapeStyle class

about ShapeStyle class

ShapeStyle::AreaFillHatchDisplayStyleModel property

ShapeStyle::AreaFillHatchDisplayStylePlan property

ShapeStyle::GetDisplayStyleModel method

ShapeStyle::GetDisplayStylePlan method

ShapeStyle::GetDisplayStyleProfile method

ShapeStyle::GetDisplayStyleSection method

ShapeStyle::GetHatchDisplayStyleModel method

ShapeStyle::GetHatchDisplayStylePlan method

ShapeStyle::GetHatchDisplayStyleProfile method

ShapeStyle::GetHatchDisplayStyleSection method

ShapeStyle::StyleType property

ShapeStyleCollection class

about ShapeStyleCollection class

ShapeStyleCollection::Add method

ShapeStyleId

ShapeStyleName

ShapeStyles

ShapeType enumeration member

Sheet class

about Sheet class

Sheet enumeration member

SheetCreateMethod

SheetCreation

SheetFile

SheetStyle class

about SheetStyle class

SheetStyle::GetDisplayPlan method

SheetStyle::GridHorizontalMajor property

SheetStyle::GridHorizontalMinor property

SheetStyle::GridVerticalMajor property

SheetStyle::GridVerticalMinor property

SheetStyle::PageLayoutId property

SheetStyle::PageMarginBottom property

SheetStyle::PageMarginLeft property

SheetStyle::PageMarginRight property

SheetStyle::PageMarginTop property

SheetStyleId

SheetStyleName

SheetStyles

SheetType

ShortName enumeration member

ShortNameSpaced enumeration member

ShortTangent

ShoulderBreakover enumeration member

ShoulderBreakOver enumeration member

ShoulderCriticalPointsLabelStyleId

ShoulderCriticalPointsTickStyle

Show enumeration member

ShowEventViewer

ShowGradeBreaksOnly

ShowHelp

ShowTickAndLabel

ShowToolTip

ShowToolTips

Shrink enumeration member

Sideslope enumeration member

Sign

SimpleSolidType

SimpleSpiralLargeRadiusAtBeginning enumeration member

SimpleSpiralLargeRadiusAtEnd enumeration member

SimpleSpiralSmallRadiusAtBeginning enumeration member

SimpleSpiralSmallRadiusAtEnd enumeration member

SimplifyMethod

SineHalfWave enumeration member

Single enumeration member

Sinusoidal enumeration member

Site class

about Site class

Site::Create method

Site::GetAlignmentIds method

Site::GetFeatureLineIds method

Site::GetParcelIds method

SiteId

SiteModel enumeration member

SiteName

Size

SizeDataRecord

SizeFilterField class

about SizeFilterField class

SizeFilterField::DataSource property

SizeFilterField::IsMultipleSelect property

SizeFilterRecord class

about SizeFilterRecord class

SizeFilterRecord::default property

SizeFilterRecord::GetParamByContextAndIndex method

SizeFilterRecord::ParamCount property

SizeFilterRecord::PartFamilyGuid property

SizeInAbsoluteUnits enumeration member

SizeOption

SizePercent

SizeRelativeToScreen enumeration member

SizeType

SizeType enumeration member

SizeValue

Skip enumeration member

SkipFullWhenSameAsRaw

Slope

Slope enumeration member

SlopeArrows enumeration member

SlopeArrowStyle

SlopeElevationTarget

SlopeElevationTarget class

about SlopeElevationTarget class

SlopeElevationTarget::GetElevation method

SlopeElevationTarget::GetNearestPipeOfNetworkToAlignment method

SlopeElevationTarget::SlopeElevationTarget constructor

SlopeElevationTarget::TargetId property

SlopeFormatType

SlopeLine

SlopeLineOffset

SlopeLineSymbol

SlopePat enumeration member

SlopePattern

SlopePatternComponent class

about SlopePatternComponent class

SlopePatternComponent::SlopeLine property

SlopePatternComponent::SlopeLineOffset property

SlopePatternComponent::SlopeLineSymbol property

SlopePatternLine class

about SlopePatternLine class

SlopePatternLine::Color property

SlopePatternLine::Grade1 property

SlopePatternLine::Grade2 property

SlopePatternLine::Length property

SlopePatternLine::LengthType property

SlopePatternLine::Linetype property

SlopePatternLine::LineWeight property

SlopePatternLine::MaximumLength property

SlopePatternLine::PercentofLength property

SlopePatternLine::PercentofLength1 property

SlopePatternLine::PercentofLength2 property

SlopePatternLine::StartType property

SlopePatternLineOffset class

about SlopePatternLineOffset class

SlopePatternLineOffset::Distance property

SlopePatternLineOffset::MaximumDistance property

SlopePatternLineOffset::MinimumDistance property

SlopePatternLineOffset::Numberoflines property

SlopePatternLineOffset::OffsetType property

SlopePatternLineOffset::PercentofLength property

SlopePatternLineOffset::RadialOffsetAngle property

SlopePatternLineSymbol class

about SlopePatternLineSymbol class

SlopePatternLineSymbol::BlockName property

SlopePatternLineSymbol::Color property

SlopePatternLineSymbol::Length property

SlopePatternLineSymbol::LengthType property

SlopePatternLineSymbol::Linetype property

SlopePatternLineSymbol::LineWeight property

SlopePatternLineSymbol::Numberoflines property

SlopePatternLineSymbol::PercentofLength property

SlopePatternLineSymbol::SymbolType property

SlopePatternLineSymbol::WidthRatio property

SlopePatternStyle class

about SlopePatternStyle class

SlopePatternStyle::AddComponent method

SlopePatternStyle::CopyComponent method

SlopePatternStyle::Count property

SlopePatternStyle::default property

SlopePatternStyle::MinDisplayLength property

SlopePatternStyle::PreviewFeatureLength property

SlopePatternStyle::PreviewSlope property

SlopePatternStyle::PreviewSlopeLength property

SlopePatternStyle::RemoveAt method

SlopePatternStyleCollection class

about SlopePatternStyleCollection class

SlopePatternStyleCollection::Add method

SlopePatternStyleId

SlopePatternStyleName

SlopePatternStyles

SlopeRangeMax

SlopeRangeMin

SlopeRatio enumeration member

Slopes enumeration member

SlopeStyle

SlopeTransitionRegionLabelStyleId

SlopeTransitionRegionTickStyle

Small enumeration member

SmallTicksAtBottomSize

SmallTicksAtMiddleSize

SmallTicksAtTopSize

SmoothContours

SmoothingCurveLength

SmoothingFactor

SmoothingType

SmoothTheFeatureLine

SoeToXyz

Solid enumeration member

Solid2d enumeration member

Solid3dBody

SolidExtents enumeration member

SolidProfile enumeration member

SolidSection enumeration member

SolidShading enumeration member

SolutionPreference

SortData

SortedStations

SortingColumn

SortingOrder

SouthAzimuth enumeration member

Southeast enumeration member

Southwest enumeration member

SpaceColumn

SpaceRow

SpanOutsideSegments

SpAValAndArc1Angle enumeration member

SpAValAndArc1Length enumeration member

SpAValAndArc1PassPt enumeration member

SpAValAndArc2Angle enumeration member

SpAValAndArc2Length enumeration member

SpAValAndArc2PassPt enumeration member

SpAValAndEndPoint enumeration member

SpAValAndStartPoint enumeration member

SpAValAndTanLenIn enumeration member

SpAValAndTanLenOut enumeration member

Specific enumeration member

SpecifyDistance enumeration member

SpecifyMultipleSectionViewStationRange

SpecifyProfileElevationRange

SpecifyProfileStationRange

SpecifyRotationType

SpecifySectionViewHeight

SpecifySectionViewOffsetRange

SpecifyWidth enumeration member

SpecifyWindow enumeration member

Speed

SpeedNumber

Sphere enumeration member

SpheroidRadius

SPI enumeration member

SPIAngle

SpInAValSpOutAVal enumeration member

SpInLenSpOutLen enumeration member

SPIPoint

Spiral enumeration member

Spiral1

Spiral1AValRadiusSpiral2AVal enumeration member

Spiral1AValSpiral2AVal enumeration member

Spiral1LengthSpiral2Length enumeration member

Spiral2

Spiral3

Spiral4

SpiralAVal enumeration member

SpiralAValRadius enumeration member

SpiralAValRadiusArcLen enumeration member

SpiralAValRadiusPassPt enumeration member

SpiralAValTangentLength enumeration member

SpiralAValTangentPassPt enumeration member

SpiralCompSpiral enumeration member

SpiralCurvature enumeration member

SpiralCurve enumeration member

SpiralCurveIntersect enumeration member

SpiralCurveIntersectPointMarkerStyle

SpiralCurveSpiral enumeration member

SpiralCurveSpiralCurveSpiral enumeration member

SpiralCurveSpiralSpiralCurveSpiral enumeration member

SpiralDefinition

SpiralDesignChecks

SpiralGeometry enumeration member

SpiralIn

SpiralInAValue

SpiralInLength

SpiralInRadiusSpiralOut enumeration member

SpiralLabels enumeration member

SpiralLabelStyle

SpiralLabelStyleId

SpiralLabelStyles

SpiralLength enumeration member

SpiralLengthTangentLength enumeration member

SpiralLengthTangentPassPt enumeration member

SpiralLenRadius enumeration member

SpiralLenRadiusArcLen enumeration member

SpiralLenRadiusPassPt enumeration member

SpiralLine enumeration member

SpiralLineIntersectPointMarkerStyle

SpiralLineSpiral enumeration member

SpiralNoParameter enumeration member

SpiralOut

SpiralOutAValue

SpiralOutLength

SpiralRevSpiral enumeration member

SpiralsIncrement

SpiralSpiral enumeration member

SpiralSpiralCurve enumeration member

SpiralSpiralCurveSpiralSpiral enumeration member

SpiralSpiralIntersect enumeration member

SpiralSpiralIntersectPointMarkerStyle

SpiralsStartingNumber

SpiralTan enumeration member

SpiralTangentIntersect enumeration member

SpiralTessellationFactor

SpiralTickStyle

SpiralType

SPIStation

SpLenAndArc1Angle enumeration member

SpLenAndArc1Length enumeration member

SpLenAndArc1PassPt enumeration member

SpLenAndArc2Angle enumeration member

SpLenAndArc2Length enumeration member

SpLenAndArc2PassPt enumeration member

SpLenAndEndPoint enumeration member

SpLenAndStartPoint enumeration member

SpLenAndTanLenIn enumeration member

SpLenAndTanLenOut enumeration member

Spline enumeration member

SplineCurve enumeration member

SplineFitForRegressionAnalysisGraph

SplitAt

SplitDataLines

SplitDatumOption

SplitDatumRounding

SplitHeight

SplitOptions

SplitProfileView

SplitProfileViews

SplitStation

SplitStationMode

SplitStationOption

SplitStationRounding

SplitTable

Square enumeration member

SquareCircle enumeration member

SquareFoot enumeration member

SquareKilometer enumeration member

SquareMeter enumeration member

SquareMile enumeration member

SquareYard enumeration member

StackedOptions

StackedText enumeration member

StackedViews

StaggerLabel

StaggerLineHeight

StandardDeviation enumeration member

Start enumeration member

StartAnchorPoint

StartCorner

StartDirection

StartElevation

StartExtension enumeration member

StartingStation

StartOffset

StartPoint

StartPointAnchorComponent

StartPointAnchorPoint

StartPointElevation

StartPointMarkerStyle

StartPointOffset

StartPointStation

StartPointXOffset

StartPointYOffset

StartPtAndDirRadiusLength enumeration member

StartPtAndDirStartAndEndRadiusLength enumeration member

StartRangeAtAlignmentStart

StartStation

StartStation enumeration member

StartStationOnMainBaseline

StartStructureId

StartToEnd enumeration member

StartType

Static enumeration member

StaticUpdate enumeration member

Station

Station class

about Station class

Station enumeration member

Station::GeometryStationType property

Station::Location property

Station::RawStation property

Station::StationType property

StationAhead

StationBack

StationDelimiterCharacter

StationDelimiterPosition

StationEnd

StationEquation class

about StationEquation class

StationEquation::EquationType property

StationEquation::RawStationBack property

StationEquation::StationAhead property

StationEquation::StationBack property

StationEquationCollection class

about StationEquationCollection class

StationEquationCollection::Add method

StationEquationCollection::Count property

StationEquationCollection::default property

StationEquationCollection::GetEnumerator method

StationEquationCollection::GetObjectEnumerator method

StationEquationCollection::GetStationEquation method

StationEquationCollection::Remove method

StationEquationDecreasing enumeration member

StationEquationIncreasing enumeration member

StationEquationLabelStyleId

StationEquationLabelStyles

StationEquations

StationEquationTickStyle

StationExtension enumeration member

StationFormat enumeration member

StationFormatDecimal enumeration member

StationIndexFormat enumeration member

StationIndexIncrement

StationIndexing

StationOffset

StationOffsetElevationToBaseline

StationOffsetElevationToSubassembly

StationOffsetElevationToXYZ

StationOffsetLabel class

about StationOffsetLabel class

StationOffsetLabel::AnchorAtXY property

StationOffsetLabel::Create method

StationOffsetLabelStyle

StationOffsetLabelStyles

StationRangeMode

StationReferencePointMarkerStyle

StationRoundingOption

Stations

StationStart

StationTrackerInMultipleViewports

StationType

StopEyeHeight

StopObjectHeight

StoppingSightDistance

StopProcessingAssembly enumeration member

StopProcessingBaseline enumeration member

StopProcessingConditional enumeration member

StopProcessingCorridor enumeration member

StopProcessingGroup enumeration member

StopProcessingRegion enumeration member

StormSewersMigration

Straight enumeration member

StraightSpline enumeration member

String enumeration member

StringEnumKey enumeration member

StringGeneral enumeration member

StringGuid enumeration member

StringName enumeration member

StructApronBackThickness enumeration member

StructApronFrontThickness enumeration member

StructApronLength enumeration member

StructApronWidth enumeration member

StructBarrelHeight enumeration member

StructBarrelPipeClearance enumeration member

StructBoundingShape enumeration member

StructConeHeight enumeration member

StructCover enumeration member

StructDiameter enumeration member

StructEquipment enumeration member

StructFrame enumeration member

StructFrameDiameter enumeration member

StructFrameHeight enumeration member

StructFrameLength enumeration member

StructFrameWidth enumeration member

StructGeneral enumeration member

StructGrate enumeration member

StructHeadwallBaseThickness enumeration member

StructHeadwallBaseWidth enumeration member

StructHeadwallTopThickness enumeration member

StructHeadwallTopWidth enumeration member

StructHeight enumeration member

StructHorizontalPipeClearance enumeration member

StructInletOutlet enumeration member

StructInnerDiameter enumeration member

StructInnerLength enumeration member

StructInnerWidth enumeration member

StructJunction enumeration member

StructLength enumeration member

StructNull enumeration member

StructPipeCenterElevation enumeration member

StructPipeCrownElevation enumeration member

StructPipeDirection enumeration member

StructPipeFlowDirection enumeration member

StructPipeInnerHeight enumeration member

StructPipeInnerWidth enumeration member

StructPipeInvertElevation enumeration member

StructPipeMaterial enumeration member

StructPipeOuterBottomElevation enumeration member

StructPipeOuterHeight enumeration member

StructPipeOuterTopElevation enumeration member

StructPipeOuterWidth enumeration member

StructPipeShape enumeration member

StructPipeWallThickness enumeration member

StructRimToSumpHeight enumeration member

StructRiserHeight enumeration member

StructSlabThickness enumeration member

Structure

Structure class

about Structure class

Structure enumeration member

Structure::AutomaticRimSurfaceAdjustment property

Structure::BarrelPipeClearance property

Structure::BoundingShape property

Structure::ConeHeight property

Structure::ConnectedPipe property

Structure::ConnectedPipesCount property

Structure::ConnectToPipe method

Structure::ControlSumpBy property

Structure::Cover property

Structure::DiameterOrWidth property

Structure::Disconnect method

Structure::Easting property

Structure::FloorThickness property

Structure::Frame property

Structure::FrameDiameter property

Structure::FrameHeight property

Structure::GetConnectedPipeNames method

Structure::GetLabelIds method

Structure::Grate property

Structure::HeadwallBaseThickness property

Structure::HeadwallBaseWidth property

Structure::Height property

Structure::InnerDiameterOrWidth property

Structure::InnerLength property

Structure::IsConnectedPipeFlowingIn method

Structure::IsConnectedPipeFlowingOut method

Structure::IsPointInsideStructureRegion method

Structure::Length property

Structure::Location property

Structure::Northing property

Structure::Offset property

Structure::PipeCenterDepth property

Structure::PipeInnerDiameterOrWidth property

Structure::PipeInvertDepth property

Structure::PipeLowestBottomDepth property

Structure::PipeOuterBottomDepth property

Structure::PipeOuterTopDepth property

Structure::PipeUpperTopDepth property

Structure::PipeWallThickness property

Structure::ResizeByPipeDepths method

Structure::ResizeJunctionStructure method

Structure::RimElevation property

Structure::RimToSumpHeight property

Structure::Rotation property

Structure::Station property

Structure::SumpDepth property

Structure::SumpElevation property

Structure::SurfaceAdjustmentValue property

Structure::SurfaceElevationAtInsertionPoint property

Structure::VerticalPipeClearance property

StructureAllPipes enumeration member

StructureColumnComponentData class

about StructureColumnComponentData class

StructureColumnComponentData::ComponentType property

StructureColumnComponentData::Content property

StructureColumnComponentData::Name property

StructureColumnComponents class

about StructureColumnComponents class

StructureColumnComponents::AddComponent method

StructureColumnComponents::Clear method

StructureColumnComponents::Count property

StructureColumnComponents::default property

StructureColumnComponents::RemoveAt method

StructureColumnComponents::SwitchComponentsOrder method

StructureColumnStyle class

about StructureColumnStyle class

StructureColumnStyle::GetComponents method

StructureColumnStyle::SetComponents method

StructureDimension enumeration member

StructureHatch enumeration member

StructureInFlowPipes enumeration member

StructureInPlan

StructureLabel enumeration member

StructureLabeling enumeration member

StructureLabelPlacement

StructureLabelStyle enumeration member

StructureLabelStyleId

StructureLabelStyles

StructureNameTemplate

StructureOutFlowPipes enumeration member

StructurePipeOutlines enumeration member

StructurePlanLabel

StructurePlanLabelStyleId

StructurePlanLabelStyleName

StructurePlanLayerId

StructurePlanLayerName

StructureProfile

StructureProfile enumeration member

StructureProfileLabel

StructureProfileLabelStyleId

StructureProfileLabelStyleName

StructureProfileLayerId

StructureProfileLayerName

StructureRuleSetStyle class

about StructureRuleSetStyle class

StructureRuleSetStyleCollection class

about StructureRuleSetStyleCollection class

StructureRuleSetStyleCollection::Add method

StructureRuleSetStyles

StructureSection enumeration member

StructureSectionLabel

StructureStyle class

about StructureStyle class

StructureStyle::GetDisplayStyleModel method

StructureStyle::GetDisplayStylePlan method

StructureStyle::GetDisplayStyleProfile method

StructureStyle::GetDisplayStyleSection method

StructureStyle::GetHatchStylePlan method

StructureStyle::GetHatchStyleProfile method

StructureStyle::GetHatchStyleSection method

StructureStyle::ModelOption property

StructureStyle::PlanOption property

StructureStyle::ProfileOption property

StructureStyle::SectionOption property

StructureStyleCollection class

about StructureStyleCollection class

StructureStyleCollection::Add method

StructureStyleModelOption class

about StructureStyleModelOption class

StructureStyleModelOption::ModelViewOptions property

StructureStyleModelOption::SimpleSolidType property

StructureStyleOptionBase class

about StructureStyleOptionBase class

StructureStyleOptionBase::BlockInsertLocation property

StructureStyleOptionBase::MaskConnectedObjects property

StructureStyleOptionBase::SizeType property

StructureStyleOptionBase::SymbolBlockName property

StructureStyleOptionBase::SymbolBlockXScale property

StructureStyleOptionBase::SymbolBlockYScale property

StructureStyleOptionBase::SymbolBlockZScale property

StructureStyleOptionBase::ViewOptions property

StructureStyleOptionBase::XSize property

StructureStyleOptionBase::XSizePercent property

StructureStyleOptionBase::YSize property

StructureStyleOptionBase::YSizePercent property

StructureStylePlanOption class

about StructureStylePlanOption class

StructureStylePlanOption::MaskConnectedObjects property

StructureStylePlanOption::PlanViewOptions property

StructureStylePlanOption::Size property

StructureStylePlanOption::SizePercent property

StructureStylePlanOption::SizeType property

StructureStylePlanOption::SymbolBlockName property

StructureStylePlanOption::SymbolBlockXScale property

StructureStylePlanOption::SymbolBlockYScale property

StructureStylePlanOption::SymbolBlockZScale property

StructureStyleProfileOption class

about StructureStyleProfileOption class

StructureStyles

StructureStyleSectionOption class

about StructureStyleSectionOption class

StructureTableStyles

StructureTickStyle

StructVerticalPipeClearance enumeration member

StructWidth enumeration member

StructWingBackHeight enumeration member

StructWingFrontHeight enumeration member

StructWingLength enumeration member

StructWingThickness enumeration member

StrucutresOnly enumeration member

StyleBase class

about StyleBase class

StyleBase::CopyAsSibling method

StyleBase::CreateBy property

StyleBase::DateCreated property

StyleBase::DateModified property

StyleBase::ExportTo method

StyleBase::ModifiedBy property

StyleCollectionBase class

about StyleCollectionBase class

StyleCollectionBase::Add method

StyleCollectionBase::Count property

StyleCollectionBase::default property

StyleCollectionBase::GetEnumerator method

StyleCollectionBase::GetObjectEnumerator method

StyleCollectionBase::Remove method

StyleId

StyleName

Styles

StyleSettings

StylesRoot class

about StylesRoot class

StylesRoot::AlignmentDesignCheckSets property

StylesRoot::AlignmentStyles property

StylesRoot::AssemblyStyles property

StylesRoot::BandStyles property

StylesRoot::BuildingSiteStyles property

StylesRoot::CodeSetStyles property

StylesRoot::CorridorStyles property

StylesRoot::FeatureLineStyles property

StylesRoot::GradingCriteriaSets property

StylesRoot::GradingStyles property

StylesRoot::GroupPlotStyles property

StylesRoot::InterferenceStyles property

StylesRoot::IntersectionStyles property

StylesRoot::LabelSetStyles property

StylesRoot::LabelStyles property

StylesRoot::LinkStyles property

StylesRoot::MarkerStyles property

StylesRoot::MassHaulLineStyles property

StylesRoot::MassHaulViewStyles property

StylesRoot::MatchLineStyles property

StylesRoot::ParcelStyles property

StylesRoot::PartsListSet property

StylesRoot::PipeRuleSetStyles property

StylesRoot::PipeStyles property

StylesRoot::PointStyles property

StylesRoot::ProfileDesignCheckSets property

StylesRoot::ProfileStyles property

StylesRoot::ProfileViewBandSetStyles property

StylesRoot::ProfileViewStyles property

StylesRoot::ProjectionStyles property

StylesRoot::QuantityTakeoffCriterias property

StylesRoot::SampleLineStyles property

StylesRoot::SectionStyles property

StylesRoot::SectionViewBandSetStyles property

StylesRoot::SectionViewStyles property

StylesRoot::ShapeStyles property

StylesRoot::SheetStyles property

StylesRoot::SlopePatternStyles property

StylesRoot::StructureRuleSetStyles property

StylesRoot::StructureStyles property

StylesRoot::SurfaceStyles property

StylesRoot::SurveyFigureStyles property

StylesRoot::SurveyNetworkStyles property

StylesRoot::TableStyles property

StylesRoot::ViewFrameStyles property

StyleType

Subassembly class

about Subassembly class

Subassembly enumeration member

Subassembly::AssemblyId property

Subassembly::AttachedToOffsetAssembly property

Subassembly::CodeSetStyleName property

Subassembly::DefaultLoopInLayoutMode property

Subassembly::DefaultLoopOffsetInLayoutMode property

Subassembly::EraseAllParams method

Subassembly::GeometryGenerator property

Subassembly::GetResourceString method

Subassembly::HasParentAssembly property

Subassembly::HelpCommand property

Subassembly::HelpData property

Subassembly::HelpFile property

Subassembly::IsDynamic property

Subassembly::Links property

Subassembly::OffsetToAssembly property

Subassembly::OffsetToBaseline property

Subassembly::ParamsBool property

Subassembly::ParamsDouble property

Subassembly::ParamsLong property

Subassembly::ParamsString property

Subassembly::Points property

Subassembly::ResourceModule property

Subassembly::Run method

Subassembly::Shapes property

Subassembly::ShowHelp method

Subassembly::StyleName property

Subassembly::SubassemblyHookTo property

Subassembly::UseEmbeddedProject property

SubassemblyBelongedTo

SubassemblyCollection

SubassemblyCollection class

about SubassemblyCollection class

SubassemblyCollection::Count property

SubassemblyCollection::default property

SubassemblyCollection::GetEnumerator method

SubassemblyCollection::GetObjectEnumerator method

SubassemblyGenerator

SubassemblyGenerator class

about SubassemblyGenerator class

SubassemblyGenerator::GeometryGenerateMode property

SubassemblyGenerator::MacroOrClassName property

SubassemblyGenerator::ProjectOrAssemblyName property

SubassemblyGenerator::SubassemblyGenerator constructor

SubassemblyHookTo

SubassemblyId

SubassemblyOptions

SubassemblySubentityStyle class

about SubassemblySubentityStyle class

SubassemblySubentityStyle::StyleType property

SubEntities

SubEntityCount

SubentityStyleType

SubEntityType

Subgrade enumeration member

Success enumeration member

Suffix enumeration member

SuffixLongName enumeration member

SuffixLongNameSpaced enumeration member

Summary enumeration member

Sump enumeration member

SumpDepth

SumpElevation

SuperBeginAlignment enumeration member

SuperBeginFullSuper enumeration member

SuperBeginNormalCrown enumeration member

SuperBeginNormalShoulder enumeration member

Superelevation

SuperElevationAtStation

SuperElevationBand enumeration member

SuperelevationCriticalPoints

SuperelevationCriticalPointsLabelStyles

SuperElevationData

SuperElevationData class

about SuperElevationData class

SuperelevationData enumeration member

SuperElevationData::Add method

SuperElevationData::Count property

SuperElevationData::default property

SuperElevationData::GetEnumerator method

SuperElevationData::GetObjectEnumerator method

SuperElevationData::Remove method

SuperelevationDataBandStyle class

about SuperelevationDataBandStyle class

SuperelevationDataBandStyle::BandType property

SuperelevationDataBandStyle::FullSuperLabelStyleId property

SuperelevationDataBandStyle::FullSuperTickStyle property

SuperelevationDataBandStyle::GetDisplayStylePlan method

SuperelevationDataBandStyle::LevelCrownLabelStyleId property

SuperelevationDataBandStyle::LevelCrownTickStyle property

SuperelevationDataBandStyle::NormalCrownLabelStyleId property

SuperelevationDataBandStyle::NormalCrownTickStyle property

SuperelevationDataBandStyle::ReverseCrownLabelStyleId property

SuperelevationDataBandStyle::ReverseCrownTickStyle property

SuperelevationDataBandStyle::ShoulderCriticalPointsLabelStyleId property

SuperelevationDataBandStyle::ShoulderCriticalPointsTickStyle property

SuperelevationDataBandStyle::SlopeTransitionRegionLabelStyleId property

SuperelevationDataBandStyle::SlopeTransitionRegionTickStyle property

SuperelevationDataBandStyle::TitleTextLabelStyleId property

SuperElevationDataElement

SuperElevationDataElement class

about SuperElevationDataElement class

SuperElevationDataElement::GetSegmentCrossSlope method

SuperElevationDataElement::RawStation property

SuperElevationDataElement::SetSegmentCrossSlope method

SuperElevationDataElement::SmoothingCurveLength property

SuperElevationDataElement::SuperElevationDataElement constructor

SuperElevationDataElement::TransitionPointDescription property

SuperElevationDataElement::TransitionPointType property

SuperelevationDataFullSuper enumeration member

SuperelevationDataLevelCrown enumeration member

SuperelevationDataNormalCrown enumeration member

SuperelevationDataReverseCrown enumeration member

SuperelevationDataShoulderCritical enumeration member

SuperelevationDataSlopeTransition enumeration member

SuperelevationOptions

SuperEndAlignment enumeration member

SuperEndFullSuper enumeration member

SuperEndNormalCrown enumeration member

SuperEndNormalShoulder enumeration member

Superimposed enumeration member

SuperimposedProfileNameTemplate

SuperimposeProfile

SuperLeftInLaneCrossSlope enumeration member

SuperLeftInShoulderCrossSlope enumeration member

SuperLeftOutLaneCrossSlope enumeration member

SuperLeftOutShoulderCrossSlope enumeration member

SuperLevelCrown enumeration member

SuperLowShoulderMatch enumeration member

SuperManual enumeration member

SuperReverseCrown enumeration member

SuperRightInLaneCrossSlope enumeration member

SuperRightInShoulderCrossSlope enumeration member

SuperRightOutLaneCrossSlope enumeration member

SuperRightOutShoulderCrossSlope enumeration member

SuperShoulderBreakOver enumeration member

SuperTransPoint enumeration member

SupplementingDistance

Suppress enumeration member

Surface

Surface class

about Surface class

Surface enumeration member

Surface::FindElevationAtXY method

Surface::IsVolumeSurface property

SurfaceAdjustmentValue

SurfaceBaseStyle class

about SurfaceBaseStyle class

SurfaceBaseStyle::DisplayMode property

SurfaceBaseStyle::ExaggerateElevationBy property

SurfaceBaseStyle::FlattenToElevationBy property

SurfaceConeTessellationAngle

SurfaceContour enumeration member

SurfaceContourLabelStyleMajor

SurfaceContourLabelStyleMinor

SurfaceContourLabelStyleUserDefined

SurfaceContourStyle class

about SurfaceContourStyle class

SurfaceContourStyle::BaseElevationInterval property

SurfaceContourStyle::DepressionTickMarkInterval property

SurfaceContourStyle::DepressionTickMarkLength property

SurfaceContourStyle::DisplayDepressions property

SurfaceContourStyle::GetContourValues method

SurfaceContourStyle::GroupRangeValuesBy property

SurfaceContourStyle::LegendStyleId property

SurfaceContourStyle::LegendStyleName property

SurfaceContourStyle::MajorContourColorScheme property

SurfaceContourStyle::MajorContourInterval property

SurfaceContourStyle::MinorContourColorScheme property

SurfaceContourStyle::MinorContourInterval property

SurfaceContourStyle::NumberOfRanges property

SurfaceContourStyle::RangePrecision property

SurfaceContourStyle::SmoothContours property

SurfaceContourStyle::SmoothingFactor property

SurfaceContourStyle::SmoothingType property

SurfaceContourStyle::UseColorScheme property

SurfaceContoursUser enumeration member

SurfaceContourTableStyles

SurfaceCreation

SurfaceData

SurfaceDirection enumeration member

SurfaceDirectionStyle class

about SurfaceDirectionStyle class

SurfaceDirectionStyle::ColorScheme property

SurfaceDirectionStyle::DisplayEntityMode property

SurfaceDirectionStyle::GroupValuesBy property

SurfaceDirectionStyle::LegendStyleId property

SurfaceDirectionStyle::LegendStyleName property

SurfaceDirectionStyle::NumberOfRanges property

SurfaceDirectionStyle::RangePrecision property

SurfaceDirectionTableStyles

SurfaceElevation enumeration member

SurfaceElevationAtInsertionPoint

SurfaceElevationStyle class

about SurfaceElevationStyle class

SurfaceElevationStyle::ColorScheme property

SurfaceElevationStyle::DisplayEntityMode property

SurfaceElevationStyle::GroupValuesBy property

SurfaceElevationStyle::LegendStyleId property

SurfaceElevationStyle::LegendStyleName property

SurfaceElevationStyle::NumberOfRanges property

SurfaceElevationStyle::RangePrecision property

SurfaceElevationTableStyles

SurfaceExport

SurfaceId

SurfaceImport

SurfaceLabelStyles

SurfaceLegendTable enumeration member

SurfaceNames

SurfacePointStyle class

about SurfacePointStyle class

SurfacePointStyle::DataPointsColor property

SurfacePointStyle::DataPointsSymbol property

SurfacePointStyle::DerivedPointsColor property

SurfacePointStyle::DerivedPointsSymbol property

SurfacePointStyle::NondestructivePointsColor property

SurfacePointStyle::NondestructivePointsSymbol property

SurfacePointStyle::ScalingMethodType property

SurfacePointStyle::Units property

SurfaceProjectionType

SurfaceSlope enumeration member

SurfaceSlopeArrow enumeration member

SurfaceSlopeArrowContourTableStyles

SurfaceSlopeArrowStyle class

about SurfaceSlopeArrowStyle class

SurfaceSlopeArrowStyle::ArrowScale property

SurfaceSlopeArrowStyle::ArrowType property

SurfaceSlopeArrowStyle::ColorScheme property

SurfaceSlopeArrowStyle::GroupValuesBy property

SurfaceSlopeArrowStyle::LegendStyleId property

SurfaceSlopeArrowStyle::LegendStyleName property

SurfaceSlopeArrowStyle::NumberOfRanges property

SurfaceSlopeArrowStyle::RangePrecision property

SurfaceSlopeLabel

SurfaceSlopeStyle class

about SurfaceSlopeStyle class

SurfaceSlopeStyle::ColorScheme property

SurfaceSlopeStyle::DisplayEntityMode property

SurfaceSlopeStyle::GroupValuesBy property

SurfaceSlopeStyle::LegendStyleId property

SurfaceSlopeStyle::LegendStyleName property

SurfaceSlopeStyle::NumberOfRanges property

SurfaceSlopeStyle::RangePrecision property

SurfaceSlopeTableStyles

SurfaceSpotElevation enumeration member

SurfaceSpotElevationLabel

SurfaceStyle

SurfaceStyle class

about SurfaceStyle class

SurfaceStyle::BoundaryStyle property

SurfaceStyle::ContourStyle property

SurfaceStyle::DirectionStyle property

SurfaceStyle::ElevationStyle property

SurfaceStyle::GetDisplayStyleModel method

SurfaceStyle::GetDisplayStylePlan method

SurfaceStyle::GetDisplayStyleSection method

SurfaceStyle::GridStyle property

SurfaceStyle::PointStyle property

SurfaceStyle::SlopeArrowStyle property

SurfaceStyle::SlopeStyle property

SurfaceStyle::TriangleStyle property

SurfaceStyle::WatershedStyle property

SurfaceStyleId

SurfaceStyles

SurfaceTessellationIncrement

SurfaceUserDefinedContourTableStyles

SurfaceWatershed enumeration member

SurfaceWatershedTableStyles

SurfBorder enumeration member

SurveyFigure class

about SurveyFigure class

SurveyFigure enumeration member

SurveyFigureStyles

SurveyFoot enumeration member

SurveyNetwork enumeration member

SurveyNetworkEntity class

about SurveyNetworkEntity class

SurveyNetworkStyles

Swap

SwathWidths

SweptShape

SweptShape enumeration member

SwitchComponentsDrawOrder

SwitchComponentsOrder

Symbol enumeration member

SymbolBlockName

SymbolBlockName enumeration member

SymbolBlockXScale

SymbolBlockXScale enumeration member

SymbolBlockYScale

SymbolBlockYScale enumeration member

SymbolBlockZScale

SymbolBlockZScale enumeration member

SymbolType

SymmetricalParabola enumeration member

SymmetricParabola enumeration member

T

Table class

about Table class

TableAnchor

TableCreation

TableLayout

TableSpacing

TableStyle

TableStyle class

about TableStyle class

TableStyle::BorderDisplayStyleModel property

TableStyle::BorderDisplayStylePlan property

TableStyle::ColumnStyles property

TableStyle::DataAreaFillDisplayStyleModel property

TableStyle::DataAreaFillDisplayStylePlan property

TableStyle::DataDividerDisplayStyleModel property

TableStyle::DataDividerDisplayStylePlan property

TableStyle::DataSeparatorDisplayStyleModel property

TableStyle::DataSeparatorDisplayStylePlan property

TableStyle::DataTextDisplayStyleModel property

TableStyle::DataTextDisplayStylePlan property

TableStyle::DataTextHeight property

TableStyle::DataTextStyle property

TableStyle::EnableWordWrapping property

TableStyle::GetDisplayStyleModel method

TableStyle::GetDisplayStylePlan method

TableStyle::HeaderAreaFillDisplayStyleModel property

TableStyle::HeaderAreaFillDisplayStylePlan property

TableStyle::HeaderSeparatorDisplayStyleModel property

TableStyle::HeaderSeparatorDisplayStylePlan property

TableStyle::HeaderTextDisplayStyleModel property

TableStyle::HeaderTextDisplayStylePlan property

TableStyle::HeaderTextHeight property

TableStyle::HeaderTextStyle property

TableStyle::MaintainViewOrientation property

TableStyle::RepeatHeaderInSplitTables property

TableStyle::RepeatTitleInSplitTables property

TableStyle::SortData property

TableStyle::SortingColumn property

TableStyle::SortingOrder property

TableStyle::TableType property

TableStyle::Title property

TableStyle::TitleAreaFillDisplayStyleModel property

TableStyle::TitleAreaFillDisplayStylePlan property

TableStyle::TitleJustification property

TableStyle::TitleSeparatorDisplayStyleModel property

TableStyle::TitleSeparatorDisplayStylePlan property

TableStyle::TitleTextDisplayStyleModel property

TableStyle::TitleTextDisplayStylePlan property

TableStyle::TitleTextHeight property

TableStyle::TitleTextStyle property

TableStyle::TitleUnformatted property

TableStyle::TransposeSectionViewTable property

TableStyleCollection class

about TableStyleCollection class

TableStyleCollection::Add method

TableStyles

TableStylesRoot class

about TableStylesRoot class

TableStylesRoot::AlignmentCurveTableStyles property

TableStylesRoot::AlignmentLineTableStyles property

TableStylesRoot::AlignmentSegmentTableStyles property

TableStylesRoot::AlignmentSpiralTableStyles property

TableStylesRoot::ParcelAreaTableStyles property

TableStylesRoot::ParcelCurveTableStyles property

TableStylesRoot::ParcelLineTableStyles property

TableStylesRoot::ParcelSegmentTableStyles property

TableStylesRoot::PipeTableStyles property

TableStylesRoot::PointTableStyles property

TableStylesRoot::QuantityTakeoffMaterialTableStyles property

TableStylesRoot::QuantityTakeoffTotalVolumeTableStyles property

TableStylesRoot::SectionViewMaterialTableStyles property

TableStylesRoot::SectionViewTotalVolumeTableStyles property

TableStylesRoot::StructureTableStyles property

TableStylesRoot::SurfaceContourTableStyles property

TableStylesRoot::SurfaceDirectionTableStyles property

TableStylesRoot::SurfaceElevationTableStyles property

TableStylesRoot::SurfaceSlopeArrowContourTableStyles property

TableStylesRoot::SurfaceSlopeTableStyles property

TableStylesRoot::SurfaceUserDefinedContourTableStyles property

TableStylesRoot::SurfaceWatershedTableStyles property

TableType

Tag enumeration member

TagSettings

TanCurve enumeration member

Tangent

Tangent enumeration member

TangentCurvature enumeration member

TangentCurveIntersect enumeration member

TangentEnd enumeration member

TangentEndDimension enumeration member

TangentEndExtension enumeration member

TangentEndInView enumeration member

TangentEndInViewDimension enumeration member

TangentGeometry enumeration member

TangentIntersection enumeration member

TangentIntersectionDesignChecks

TangentIntersectionLabelStyles

TangentIntersectLabelStyle

TangentLabels enumeration member

TangentLabelStyleId

TangentLength enumeration member

TangentMiddle enumeration member

TangentMiddleDimension enumeration member

TangentMiddleExtension enumeration member

TangentOffsetAtPVI

TangentSpiralIntersect enumeration member

TangentStart enumeration member

TangentStartDimension enumeration member

TangentStartExtension enumeration member

TangentStartInView enumeration member

TangentStartInViewDimension enumeration member

TangentTangentIntersect enumeration member

TangentTickStyle

TanSpiral enumeration member

TanTan enumeration member

TaperedLines enumeration member

TaperedLinesNoGap enumeration member

TaperInputType

TaperRatio

TaperRation

Target

TargetId

TargetLine enumeration member

TCast

Ten enumeration member

TessellateCurve

Text

Text enumeration member

TextBoxPosition

TextBoxWidth

TextColor

TextForEach enumeration member

TextHeight

TextHeightRelativeToScreen

TextLocation

TextStyle

ThreeCenteredArcs enumeration member

ThreeDEntityProfileNameTemplate

ThreeDPolylineBeginVertexProfile enumeration member

ThreeDPolylineEndVertexProfile enumeration member

ThreeDPolylineInternalVertexProfile enumeration member

ThreeDPolylineSection enumeration member

ThreeDPolylineSegmentsProfile enumeration member

ThreePassPoints enumeration member

ThreePoints enumeration member

ThroughPoint enumeration member

ThroughPoint1Elevation

ThroughPoint1Station

ThroughPoint2Elevation

ThroughPoint2Station

ThroughPoint3Elevation

ThroughPoint3Station

ThroughPointMarkerStyle

ThroughRadius enumeration member

Tick enumeration member

TickAndLabelStartElevation

Ticks enumeration member

TicksAtCenterline enumeration member

TicksAtFullSuper enumeration member

TicksAtGradeBreaks enumeration member

TicksAtHGP enumeration member

TicksAtLevelCrown enumeration member

TicksAtMajorOffsets enumeration member

TicksAtMinorOffsets enumeration member

TicksAtNormalCrown enumeration member

TicksAtPipeEnds enumeration member

TicksAtReverseCrown enumeration member

TicksAtSampleLineStation enumeration member

TicksAtSampleLineVertices enumeration member

TicksAtShoulderBreakOver enumeration member

TicksAtStationEquations enumeration member

TicksAtStructureLocation enumeration member

TicksAtVGP enumeration member

TileDirection

TinSurface class

about TinSurface class

TinSurface enumeration member

TinSurfaceLabeling enumeration member

TinVolumeSurface enumeration member

Title

TitleAreaFill enumeration member

TitleAreaFillDisplayStyleModel

TitleAreaFillDisplayStylePlan

TitleBox enumeration member

TitleBoxText enumeration member

TitleCaps enumeration member

TitleJustification

TitleSeparator enumeration member

TitleSeparatorDisplayStyleModel

TitleSeparatorDisplayStylePlan

TitleStyle

TitleText enumeration member

TitleTextDisplayStyleModel

TitleTextDisplayStylePlan

TitleTextHeight

TitleTextLabelStyleId

TitleTextStyle

TitleUnformatted

ToInsideEdges enumeration member

ToIntersectionExtents enumeration member

Tolerance

ToMarkerExtents enumeration member

Top enumeration member

TopAxis

TopAxis enumeration member

TopAxisAnnotationHGP enumeration member

TopAxisAnnotationMajor enumeration member

TopAxisAnnotationMinor enumeration member

TopAxisTicksHGP enumeration member

TopAxisTicksMajor enumeration member

TopAxisTicksMinor enumeration member

TopAxisTitle enumeration member

TopBandSetItems

TopCenter enumeration member

TopInnerDiameter enumeration member

TopLeft enumeration member

ToPoint enumeration member

TopOrLeft enumeration member

TopOuterDiameter enumeration member

TopRight enumeration member

TopSize enumeration member

TopStackViewStyle

TotalVolumeTableStyle

TotalX

TotalY

TransformationSettings

TransitionLength

TransitionPointDescription

TransitionPointType

TransitionRegionColor

TransitionRegionLength

TransitionRegionLineweight

TransitionType

Translate

TranslatedCoordinateEasting

TranslatedCoordinateElevation

TranslatedCoordinateNorthing

Translation

TransparentCmdGrade enumeration member

TransparentCmdSlope enumeration member

TransparentCommands

TransposeSectionViewTable

Triangle enumeration member

TriangleFilled enumeration member

Triangles enumeration member

TriangleStyle

TrueSolid enumeration member

Truncate enumeration member

TurnOffUnassociatedLayers

TwoPassPointsAndGrade enumeration member

TwoPassPointsAndParameter enumeration member

TwoPoints enumeration member

TypeInfo

U

Undefined enumeration member

UndefinedPartType enumeration member

Underscore enumeration member

Undivided enumeration member

UniformForAll enumeration member

UniformPerRowOrColumn enumeration member

Unit

Unitless

Units

Unity enumeration member

UnitZoneSettings

Unknown enumeration member

UnSelectAll

Up enumeration member

Update enumeration member

UpdateMode

UpdatePoints

UphillTangentLabelStyleId

UphillTangentTickStyle

Upper enumeration member

UpperCase enumeration member

UpperLeft enumeration member

UpperRight enumeration member

Use enumeration member

UseAbsoluteUnits enumeration member

UseAcadLayerAndColor

UseAverage enumeration member

UseAverageSlope enumeration member

UseBackgroundMask

UseCatalogDefined3DPart enumeration member

UseClipGrid

UseCodeThenDesc enumeration member

UseCodeValue enumeration member

UseColorScheme

UseCOM enumeration member

UseCommandLineInput

UseCriteriaBasedDesignOption

UseCurrentLayer enumeration member

UseCurve

UseCustomMarker enumeration member

UseCustomNullElevation

UseDescThenCode enumeration member

UseDescValue enumeration member

UseDesignCheckSet

UseDesignChecksOption

UseDesignCriteriaFile

UseDesignCriteriaFileOption

UseDesignSpeed

UsedIn

UseDistanceOrScaleFactor

UseDotNet enumeration member

UseDrawingScale enumeration member

UseDrawingUnits enumeration member

UseDrawScale enumeration member

UseEmbeddedProject

UseEndPointAnchor

UseEndStation

UseExistingSheetSet

UseFeatureLineName

UseFeatureLineStyle

UseFirst enumeration member

UseFixedScale enumeration member

UseFixedScaleFromPartSize enumeration member

UseGroupName

UseLast enumeration member

UseLayerSetting enumeration member

UseMaximumChangeInElevation

UseMaximumDepth

UseMaximumTriangleLength

UseMinimumFrontageAtOffset

UseNameTemplate enumeration member

UseNext enumeration member

UseOuterPartBoundary enumeration member

UseOverrideStyle

UsePartDimensions enumeration member

UsePercentageOfPointsToRemove

UsePointElevation enumeration member

UsePointForMarker enumeration member

UserContours enumeration member

UserDefined enumeration member

UserDefinedEndSize enumeration member

UserDefinedPart enumeration member

UserDefinedWallSize enumeration member

UserEntityLayer enumeration member

UserSpecified enumeration member

UseSamplingIncrements

UseShortestFrontage enumeration member

UseSimple3DPart enumeration member

UseSizeAsPercentageOfScreen enumeration member

UseSizeInAbsUnits enumeration member

UseSizeInRelUnits enumeration member

UseSlopePatternStyle

UseSlopeRange

UseSmallestArea enumeration member

UseSpiralIn

UseSpiralOut

UseStartStation

UseSurfaceElevation enumeration member

UseSymbolForMarker enumeration member

UseVBA enumeration member

UseVerticalLineForMarker enumeration member

UsSurveyFoot enumeration member

Utilities enumeration member

Utility enumeration member

V

ValidateDesignCheck

Value

ValueInABadPosition enumeration member

ValueList

ValueRange

ValueShouldNotBeLessThanOrEqualToZero enumeration member

ValueShouldNotBeLessThanZero enumeration member

ValueShouldNotBeOdd enumeration member

ValueShouldNotBeZero enumeration member

ValueTooLarge enumeration member

ValueTooSmall enumeration member

ValueType

VCompoundCurveIntersectPointMarkerStyle

VCurveTangentIntersectPointMarkerStyle

Velocity enumeration member

Vertical enumeration member

VerticalAlignment

VerticalCompoundCurveIntersect enumeration member

VerticalCompoundCurveIntersectElevation enumeration member

VerticalCompoundCurveIntersectStation enumeration member

VerticalCurve

VerticalExaggeration

VerticalGeometry enumeration member

VerticalGeometryBand enumeration member

VerticalGeometryBandStyle class

about VerticalGeometryBandStyle class

VerticalGeometryBandStyle::BandType property

VerticalGeometryBandStyle::CrestCurveLabelStyleId property

VerticalGeometryBandStyle::CrestCurveTickStyle property

VerticalGeometryBandStyle::DownhillTangentLabelStyleId property

VerticalGeometryBandStyle::DownhillTangentTickStyle property

VerticalGeometryBandStyle::GetDisplayStylePlan method

VerticalGeometryBandStyle::SagCurveLabelStyleId property

VerticalGeometryBandStyle::SagCurveTickStyle property

VerticalGeometryBandStyle::TitleTextLabelStyleId property

VerticalGeometryBandStyle::UphillTangentLabelStyleId property

VerticalGeometryBandStyle::UphillTangentTickStyle property

VerticalGeometryCrestCurve enumeration member

VerticalGeometryDownhillTangent enumeration member

VerticalGeometryPointLabelStyles

VerticalGeometrySagCurve enumeration member

VerticalGeometryUphillTangent enumeration member

VerticalGrade

VerticalGridInterval

VerticalGridOptions

VerticallyExaggerateBlocks

VerticallyExaggerateMultiViewBlocks

VerticallyExaggerateSolids

VerticalMidOrdinateDistance

VerticalPipeClearance

VerticalReverseCurveIntersect enumeration member

VerticalReverseCurveIntersectElevation enumeration member

VerticalReverseCurveIntersectStation enumeration member

VerticalScale

Vertices enumeration member

VGPLabelStyleId

VGPTickStyle

View enumeration member

ViewBottom enumeration member

ViewEditOptions

ViewFrame

ViewFrame class

about ViewFrame class

ViewFrame enumeration member

ViewFrame::GroupId property

ViewFrameBoundaryDisplayStylePlan

ViewFrameCreation

ViewFrameGroup

ViewFrameGroup class

about ViewFrameGroup class

ViewFrameGroup::GetMatchLineIds method

ViewFrameGroup::GetViewFrameIds method

ViewFrameLabel

ViewFrameLabeling enumeration member

ViewFrameLabelLocation

ViewFrameLabelStyles

ViewFrameOrientation

ViewFrameStyle class

about ViewFrameStyle class

ViewFrameStyle::GetViewFrameBoundaryDisplayStylePlan method

ViewFrameStyle::ViewFrameBoundaryDisplayStylePlan property

ViewFrameStyles

ViewId

ViewOptions

ViewOptions enumeration member

ViewTop enumeration member

VIntersectionPointMarkerStyle

Visibility

Visible

Volume

Volume enumeration member

VReverseCurveIntersectPointMarkerStyle

VTangentCurveIntersectPointMarkerStyle

W

WallSizeOptions

WallSizeOptions enumeration member

WallSizeType

WallSizeType enumeration member

WallThickness

WallThickness enumeration member

WarningSymbol enumeration member

WaterdropMarker

WaterdropPath

Watersheds

Watersheds enumeration member

WatershedStyle

Weeding

WeedingAngle

WeedingDistance

WeedingFactor

WeedPoints

WidenedOffset

WideningAtIncomingLane

WideningAtOutgoingLane

WideningOffset

WideningOptions

WideningParameters

WideningSegmentLength

WidthOffsetTarget

WidthOffsetTarget class

about WidthOffsetTarget class

WidthOffsetTarget::GetDistanceToAlignment method

WidthOffsetTarget::GetNearestPipeOfNetworkToAlignment method

WidthOffsetTarget::TargetId property

WidthOffsetTarget::WidthOffsetTarget constructor

WidthRatio

Wire enumeration member

WithArrowhead enumeration member

WorldCoordinateSystem enumeration member

WriteIdentificationElements

X

XOffset

XSize

XSize enumeration member

XSizePercent

XSizePercent enumeration member

XY enumeration member

XYCoordinatePair enumeration member

XYZ

XyzToSoe

Y

Yard enumeration member

Yes enumeration member

YOffset

YSize

YSize enumeration member

YSizePercent

YSizePercent enumeration member

YX enumeration member


Comments Reply

Thank you for your input!

If we have any questions, we'll try to contact you.