
P
ublish

V
iew

 &
 P

rint
R

eview
 &

 M
ark U

p

DWF
TM

 
Tips &Tricks



P
ublish

Sharing complex design information has never been 

easy. Since design files are large, sending sheet sets and 

3D models to printers or sharing work with extended 

team members has taken a lot of time and effort, not to 

mention bandwidth. DWF™ technology changes all that. 

DWF-based designs are compact, secure, and easy-to-

use. In fact, because sharing rich 2D and 3D design  

information is a snap with DWF, completely digital 

workflows become possible—streamlining the flow of 

information across the entire project team.

This handy pocket guide of DWF Tips and Tricks provides 

individual users and entire project or product teams with 

the information needed to get the most from DWF and 

applications like Autodesk Design Review. To learn more 

about DWF visit www.autodesk.com/dwf. 

Publish 
The ability to publish DWF files is built 
into every Autodesk® design application. 
It is also available free of charge when 
using third-party applications with the 
Autodesk® DWF™ Writer. 

Learn more on how to publish DWF  
files from Autodesk products at  
www.autodesk.com/dwf-publishing. 

Publish 3D DWF Formats
Use the 3D DWF PUBLISH command 
from AutoCAD (2006 or later), Revit or 
Inventor to publish 3D DWF formats:

1.	 On the command line, enter  
3ddwfpublish. 

2.	In the 3D DWF Publish dialog box, 
under DWF File Name, change the 
name and location of the DWF file 
to be saved, or use the [...] button to 
navigate to a new location for the  
3D DWF file. 

3.	Under Objects to Publish, click one of 
the following: 

•	All Model Space Objects: All model 
space objects are published to the 3D 
DWF file 

•	Selected Model Space Objects:  
Create a selection set of model space 
objects, which are published to the 
3D DWF file 

4.	If the drawing contains xrefs, the 
Group By xref Hierarchy option is 
selected by default. Clear the check 
box if you do not want to display the 
objects grouped by xref hierarchy in 
the published DWF file. 

5.	Under Group Individual Objects By, 
select one of the following options to 
group individual objects in the DWF 
file for viewing. 

•	Layer: Group individual objects  
by layer 

•	Object Type: Group individual  
objects by object type (for example, 
by block)

6.	Click OK.



Increase the Precision of the  
DWF File
Specify the pixel resolution for vector 
and raster graphics when creating DWF 
files. The higher the resolution, the 
greater the precision but the larger the 
file size.

1.	 From the File menu, choose Plot to 
display the Plot dialog box.

2.	Ensure that DWF 6 ePlot.pc3 is 
selected. Click Properties to display a 
tree control.

3.	Select Graphics from the tree, and 
expand it. Select Custom Properties 
in the drop down menu, and then click 
the Custom Properties button.

4.	Set Vector Resolution to the desired 
value. You can leave the other DPI 
values (Gradient Resolution, Color 
and Grayscale Resolution, and Black 
and White Resolution) as they are. 
Valid values from the pull-down menu 
are between 150 and 4800. Use the 
keyboard to enter a custom value,  
such as 30270.

A table of useful resolution values is 
available at dwf.blogs.com.

Pass It On: Publish DWF and Email 
From Windows Explorer
Easily email a DWF file when using  
Autodesk DWF Writer.

1.	 Start Windows® Explorer and open 
the folder containing the file to be 
published and emailed. 

2.	Right-click the file and choose Publish 
DWF and Email. The default email ap-
plication opens a new email message 

with the published DWF file attached. 
The subject displays the name of the 
published DWF file. 

3.	Type email addresses in the To..., Cc..., 
and Bcc... fields and add a message, as 
necessary. A link to download the free 
Autodesk DWF Viewer is automatically 
included for email recipients who don’t 
have it.

4.	Click Send.

Add Object Properties from  
AutoCAD Blocks

Enable team members to access  
AutoCAD block properties in the DWF 
file by setting DWF publishing options. 

1.	 From the File menu, choose Publish. 

2.	In the Publish dialog box, under Pub-
lish To, click DWF File, and then click 
Publish Options. 

3.	In the Publish Options dialog box, 
under DWF Data Options, Block 
Information, select Include from the 
drop-down list.*

4.	Click OK. 

5.	In the Publish dialog box, either con-
tinue with publishing tasks or close the 
dialog box. 

*By default, Block Information is set to Don’t Include. 
If you change the setting to include block informa-
tion, you can use the viewer to view or print block 
property and attribute information in the DWF file.
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Publish from SolidWorks  
Pro/ENGINEER Wildfire, or  
CATIA 
Install Autodesk DWF Writer 3 to  
publish 3D models and design data from 
SolidWorks® 2006, Pro/ENGINEER® 
Wildfire 2.0, or CATIA® V5 software.  

1. From the file menu, select Publish DWF 
to automatically turn your 2D drawing 
or 3D model into DWF.

2. Learn about publishing from other  
applications, by visiting  
www.autodesk.com/dwf-publishing. 

Publish from Microsoft Office 
Documents
With Autodesk DWF Writer installed, 
users can publish DWF files from  
Microsoft® applications (PowerPoint®, 
Word, Excel®, Visio®, Outlook, and  
Internet Explorer) and share them as  
part of the project set.

1.	 Click the Publish DWF button on the 
Microsoft application toolbar, or from 
the File menu, choose Print and then 
select Autodesk DWF Writer in the list 
of available printers.

2.	Specify a file name and location for 
the published DWF file.

3.	Click save or choose print.

View & Print
In the past, viewing rich design data 
required the purchase of a full license of 
CAD software. Now, the free, download-
able Autodesk® DWF™ Viewer means 
that everyone on the team can navigate 
sheet sets, access design information, 
and print whatever they need.

Download the free Autodesk DWF 
Viewer at www.autodesk.com/ 
dwfviewer-download.

Quickly Zoom and Pan
Use the mouse wheel button to zoom in 
and out. 

To pan, press and hold the mouse wheel 
button and move the mouse. 

Note: Your mouse settings may need to be 
changed to enable panning in this manner.
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1.	 Choose View and then select  
orbit to enable the Orbit tool.

2.	Click the 3D model and drag in any 
direction to rotate the view.

3.	Select Standard Views and navigate to 
the Front, Back, or see Shaded Edges.

Search and View Design Data
1.	 In Explorer, click Search to open the 

Search Explorer Bar.

2.	Type search terms for the DWF file 
such as doors, bolts, and more. 

3.	Select the location to search and click 
Search Now.

4.	Microsoft Windows Explorer search 
will list DWF files that contain the 
search term.
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Viewing Assembly Instructions
When an animated DWF file with  
assembly instructions is opened in  
Autodesk DWF Viewer or Autodesk  
Design Review, the instructions are  
displayed for the current task or  
sequence in the left sub-pane below  
the Canvas Pane. 

Important information: Although loading 
a DWF may populate the text or grid 
panes with data, the data panes will not 
be displayed automatically.

Use the Pane Layout  drop-down to 
select which panes are displayed. 

To hide or show the Text or Grid panes:

1.	 Click the Pane Layout drop down.  

2.	Choose from: 

•	Show Canvas and Grid Panes  

•	Hide Data Pane  

•	Hide Canvas Pane  

•	Show All Panes  

DWF View and Design Review display  
the pane configuration you selected. 

The left sub-pane displays text such  
as step-by-step instructions for an  
assembly.

Pull Apart a 3D Model 
Autodesk Design Review and DWF 
Viewer users can navigate 3D models 
published from Autodesk applications  
or with the free Autodesk DWF Writer. 
Follow these steps to rotate and pull 
apart individual pieces of a model:

1.	 From the Tools menu, choose 
Move>Rotate.

2.	In the Model palette  or view area, 
click the parts that you want to move 
or rotate.
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3. To remove a part from the selection, 
press and hold the Ctrl key and click 
the part again (Ctrl+click). In the 
Model palette, use Shift+click to select 
consecutive parts by clicking the first 
and last parts in the series.

Move along an axis 
On the axis along which you want to 
move the part, click that axis near the 
origin. Drag in either direction along the 
axis. Alternatively, press the Up Arrow 
key to move away from the origin or the 
Down Arrow to move toward the origin.

Move within a plane 
Roll the cursor over a plane defined by 
two axes until a plane icon with arrows 
appears, and click. Drag the part in any 
direction. 

Move parallel to the screen 
Click the origin, and drag the part in any 
direction. Or use the keyboard arrows to 
move left, right, up, or down.

Rotate 
On the axis around which you want to 
rotate the part, click near the end of the 
axis and drag the part around the axis. 
Or press the Down Arrow key to rotate 

Result

Begin Move

1 degree clockwise or the Up Arrow key 
to rotate 1 degree counterclockwise. To 
rotate the part in 45 degree increments, 
press and hold the Shift key while using 
the keyboard arrows.



Undoing Pulling Apart a 3D Model 
or a Sectioning
Autodesk Design Review and the DWF 
Viewer both feature sectioning and pull 
apart capabilities when working with 3D 
DWF files. Though these capabilities are 
easily accessible and very powerful, some 
users do not know how to undo them. 
After applying a section or pulling a piece 
of a model apart from its original loca-
tion, users can restore the original view 
of the model using:

View->Go->Home 

A shortcut for this capability is Ctrl+ G.

Access Design Intelligence
Publish detailed design information from 
Autodesk® Architectural Desktop 2004 
and later versions, AutoCAD® 2007–
based products, and Autodesk Inventor® 
software, for viewing in Autodesk Design 
Review or DWF Viewer.

1.	 View and sort object properties: Click 
the Properties window.
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Create 3D Cross Sections
Cut through a model with a section plane 
and manipulate the view in various ways 
by moving and rotating the section plane 
and flipping the view.

1.	 Open a model and from the Tools 
menu, choose Cross Section >XY  
Section, YZ Section, or XZ Section. 

2.	A transparent purple sheet (the sec-
tion plane) and a tripod drop into the 
center of the model, cutting through 
the model to reveal a cross section. 
Move or rotate the section plane  
to reveal a different cross section  
each time.

3.	The three legs, or axes, of the tripod 
meet at a central point called the 
origin. To change the cross section 
revealed, move or rotate the section 
plane by moving the cursor over 
the tripod. Hot spots appear, each 
enabling the user to move the section 
plane in a different way. After

Before

Move along an axis 
On the axis along which you want to 
move the section plane, click the axis 
near the origin. Drag in either direction 
along the axis. Click the Up Arrow key to 
move away from the origin or the Down 
Arrow key to move toward the origin.

Move within a plane 
Roll the cursor over a plane defined by 
two axes until a plane icon with arrows 
appears, and click. Drag the section 
plane in any direction.

Move parallel to screen 
Click the origin. Drag the section plane in 
any direction. 

Rotate 
On the axis around which you want to 
rotate, click near the end of the axis. 
Drag the section plane around the axis. 
If you press and hold the Shift key while 
using the keyboard arrows to rotate, 
the section plane rotates in 45 degree 
increments. 



2.	Access block information: In the 
Content Browser, select the Proper-
ties window, and then choose Object 
Properties from the drop-down menu.

	 Click the selector button, and  
then click the block to display  
the block data.

3.	Search for design data: In Microsoft® 
Windows® Explorer, select Search, and 
enter your search string to find data 
within the DWF file such as doors, 
bolts, and more.

4.	Navigate sheets or views using hyper-
links: From the main menu, choose 
View>Show>Hyperlinks (Ctrl+H) to 
display hyperlinks in blue. To follow a 
hyperlink, hold down the Ctrl key and 
click the hyperlink (Ctrl+click). The 
drawing, file, or web page to which it 
was linked opens.

2.	Preview what you print: 

•	From the File menu, choose Print to 
open the Print dialog box

•	Choose the settings that affect your 
preview, like paper size or landscape 
view 

•	Click the Show Print Preview button

 

3.	Print instantly to HP printers:

•	Click the HP Instant Printing  
button 

	 Note: The button automatically  
appears if you are connected to a  
supported HP® Designjet™ printer.

•	The optimal print settings are chosen 
automatically based on the proper-
ties of the DWF file

Present in Microsoft Office  
Applications
Share the full design intent in Microsoft 
PowerPoint, Excel, or Word whether it’s a 
client presentation, product documenta-
tion, or bill of materials.

1.	 Drag the file from Windows Explorer 
into the document.

2.	Alternatively, from the Insert menu, 
choose Object and Autodesk DWF 
Viewer Control, then right-click and 
select Autodesk DWF Viewer Control 
Object Properties to embed an inter-
active DWF.
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Use Flexible Printing Options
Preview the job before sending it to the 
printer. Partnerships with printer manu-
facturers like HP and Océ help assure 
fast, high-quality output.

1.	 Print to spec: Customize the settings 
that affect output from standard to 
large format. Choose from among the 
following options: 

•	Full Page or the Current View

•	Paper Size or select Use DWF Paper 
Size

•	Landscape or Portrait

•	Fit to Page or Print to Scale

•	Tile across multiple pages



2.	Zoom in for greater accuracy: To 
achieve greater accuracy, zoom in to 
the section of the drawing to which 
you are applying the starting and  
ending points of the dimension.

Work with Advanced Redlines and 
Markups
Autodesk Design Review includes easy-
to-use shapes, text, freehand, stamp, 
and custom symbol tools in addition to 
markup tools.

1.	 Control markup shape: Hold down the 
Shift key to constrain the range of 
movement when marking up drawings. 

•	To start again, press the Esc key and 
try again 

•	To delete a markup, use the Selection 
tool and press Delete

Post Files to Autodesk Buzzsaw
Autodesk Design Review and the DWF 
Viewer  are fully integrated into the  
Autodesk® Buzzsaw® collaborative proj-
ect management solution. Follow these 
steps to efficiently share your designs:

1.	 Drag DWF files into the project folder.

2.	Notify the project team using the 
Buzzsaw notification system. Updates 
and versions are automatically tracked.

Review, Measure  
& Mark Up
No more looking through faxes and 
emails to incorporate feedback by hand. 
With Autodesk Design Review software, 
team members can review, measure, and 
mark up designs, and then round-trip 
redlines and changes back to the original 
design application. All changes are auto-
matically tracked and kept in the context 
of the design.

Measure Accurately
The dimension tools with the AutoSnap™ 
feature help project team members de-
termine lengths, polylines, and areas.

1.	 Snap to endpoints: Set the measure 
tools to snap to endpoints, midpoints, 
and lines for precision measurement of 
design elements in the DWF file. Click 
the Tools command, and turn on the 
Snap to Geometry feature.
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Use Custom Symbols and Stamps
Use symbols to annotate and mark up 
information in the office or in the field.

1.	 Create custom symbol catalog: Publish 
the 2D drawings, images, or text to 
a DWF file using the Autodesk DWF 
Writer. In Autodesk Design Review, im-
port this file into the symbol catalog.

•	From the toolbar, click the  
Stamps and Symbols button

2.	Color code reviews: Use different 
markup colors to indicate different 
users.

•	Select from the 48 predefined colors 
or one of your own 

•	Change the Text Color and Line Color 
on the main menu, and then click 
your chosen color

3.	Save a new markup view: When you 
create a markup, the current view of 
the page is stored with that markup. 
To change and automatically store a 
new view, pan and zoom to the desired 
view, and then move the markup 
slightly or modify it in some way. R
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Manage Your Project Information 
in One Place
Work with multiple document types in 
one multisheet DWF sheet set, combin-
ing images, sketches, project timelines, 
specifications, bills of materials, and 
other project information.

1.	 Capture information with Snapshot tool: 
Add a snapshot to an existing DWF file, 
or create a new DWF file by adding one 
or more snapshots to a blank file. 

•	Click the Snapshot button  

•	Set up the subject of your screen shot

•	Click the Capture button on  
the Snapshot window title bar              

2.	Drag and drop: Combine DWF files, 
raster images, and other project infor-
mation into a single DWF file or send it 
out for review:

•	Drag and drop, or use File>Open to 
view and mark up many different 
types of image files, such as JPEG or 
GIF files 

•	Drag a page or pages into an email 
or onto the desktop to create a new 
DWF file 

•	Select Import DWF as Symbol  
Catalog

•	Browse for and select the DWF file 
that contains your symbols, and click 
Open or press Enter 

2.	Create your own stamp: Create custom 
annotations and stamps by double-
clicking a stamp and typing to insert 
text, or highlight the text you want to 
change. 



Markup Bill of Materials
Using the Grid Snapshot tool in Autodesk 
Design Review, you can capture  bill of 
materials on a separate sheet for markup 
purpose.

1.	 A bill of materials must be loaded in 
the Grid Data Pane below the canvas 
to enable capture.

Advanced Tips
Take advantage of these advanced DWF 
tips from the experts.

Autodesk DWF Viewer Tips
1.	 Use the mouse wheel button to zoom 

in and out. To pan, hold the button 
down and move the mouse. 

2.	Select Options in the Content Browser 
to show thumbnails, list views, or 
bookmarks of the original DWF data.

3.	When rotating 3D objects, keep the 
triad at least slightly oblique to the 
screen to move or rotate. You cannot 
move or rotate the axis that points 
directly toward you.

Install Across Your Company

Autodesk DWF Viewer can be installed 
silently via the following:

msiexec /i SetupDWFViewer.msi /qn

Your IT department can install the 
Autodesk DWF Viewer across your com-
pany. By installing the Autodesk DWF 
Viewer silently, the viewer can be includ-
ed as part of a company-wide automated 
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2.	On the Standard Toolbar, display the 
Callout Tool button drop-down list.  

3.	Click the Grid Snapshot Tool button.  

4.	A snapshot is of the bill of materials is 
added to the Contents palette.

5.	Select the BOM snapshot in the  
Contents palette to add markup.

script. For example, this is particularly 
useful when installing Autodesk DWF 
Viewer company-wide using SMS.

Embed Autodesk DWF Viewer in 
HTML Documents
Autodesk DWF Viewer is available as an 
ActiveX® control that is embedded in 
Microsoft Internet Explorer, providing a 
smooth installation of the free Autodesk 
DWF Viewer in web pages. 

1.	 Embed DWF files directly in web pages 
by using the <object> element tag.

A
dvanced Tips

Capturing bill of materials



2. Access, copy and paste a sample HTML 
that demonstrates how to embed a 
DWF file in HTML: 
http://dwf.blogs.com/ 
beyond_the_paper/2006/05/ 
how_do_i_embed_.html

Save DWF Files That You View
Follow these steps to save a local copy of 
a DWF file published to a website:

1.	 Right-click the DWF file and choose 
Save As. Alternatively, click the Save 
As button on the toolbar. (Note: The 
Save As options appear only when you 
are using DWF Viewer in embedded 
mode—for example, in a web page.) 

2.	To save a local copy of the DWF file 
you are viewing, specify a file name.

Learn and Get More

Visit the DWF Center 
www.autodesk.com/dwf

Visit the DWF Blog 
dwf.blogs.com

Participate in the discussion groups 
www.autodesk.com/ 
   designreview-discussion 
www.autodesk.com/dwf-discussion

Get free downloads 
www.autodesk.com/ 
   dwfviewer-download 
www.autodesk.com/designreview-trial  
www.autodesk.com/dwfwriter  

Find product information 
www.autodesk.com/designreview 
www.autodesk.com/dwfviewer 
www.autodesk.com/dwf-publishing

Find developer tools and information 
www.autodesk.com/dwf-developers 
www.autodesk.com/dwftoolkit 

Try our newest software 
labs.autodesk.com 
dwfit.com

(especially on hatches and fills). Using 
“Poster Mode” on these files typically 
resolved the issue. 

Use API to Customize and Extend 
Functionality
Use the Autodesk Design Review and 
DWF Viewer and  application program-
ming interface (API) documentation to 
integrate Design Review or DWF Viewer 
within websites or third-party applica-
tions. The documentation provides 
instruction on features such as naviga-
tion to a specific page or view, control 
over layer visibility, the ability to show 
and hide the toolbar and context menus, 
as well as control of the viewer behavior. 
Visit www.autodesk.com/dwf-developers 
to download the API documentation.
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Printing DWF files on Océ Devices
With its default settings, some Océ de-
vices (e.g., TDS800, TDS600, or TDS400) 
cut off the leading or trailing edge of 
DWF plots. There is an option in the Océ 
Windows Raster Driver to override the 
“cutting method” on the Power Logic 
Controller. In the Printing Defaults dialog 
box, there is a “Delivery” tab. In the “De-
livery” tab’s “Cutting Method” section, 
there is a combo box that has 3 options: 

1.	 Synchro: Trims to fit the plot size. 

2.	Standard: Trims to a standard  
paper size. 

3.	Printer default: Uses whatever the 
default on the controller is set to.

When plotting DWF files, you should use 
the “Standard” cutting method by chang-
ing the printer properties. 

When printing DWF files on the Océ 
9800 or Océ TDS800. some users found 
that when architects and engineers used 
pen 0 in their AutoCAD drawings, the 
published DWF files would print out too 
light on the 9800 and TDS800 devices 
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This product is subject to the terms and conditions of the end-user 
license agreement that accompanies download of this software.

Autodesk, AutoCAD, Autodesk Inventor, AutoSnap, Buzzsaw, DWF, 
Inventor, and Revit are registered trademarks or trademarks of 
Autodesk, Inc., in the USA and other countries. All other brand names, 
product names, or trademarks belong to their respective holders.  
Autodesk reserves the right to alter product offerings and specifica-
tions at any time without notice, and is not responsible for typo-
graphical or graphical errors that may appear in this document.  
© 2006 Autodesk, Inc. All rights reserved. 
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“Overall, DWF and  Autodesk Design Review 
are helping us improve productivity.”

—	Patrik Chartrand, CAD Administrator 
Advanced Dynamics
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